ActiveReports 13

Glossary Item Box

This is the help file for ActiveReports, reporting software for use in Visual Studio 2012, 2013, 2015, 2017, or 2019.

In This Documentation

ActiveReports User Guide
The User Guide has many getting started topics and how-to topics with code samples to copy and paste.
Class Library
This is the API documentation with topics for all of the public members of each assembly included with ActiveReports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveReports User Guide

ActiveReports User Guide
See Also
ActiveReports 13 > ActiveReports User Guide

Glossary Item Box

ActiveReports provides fully integrated Visual Studio components which combine user-friendly visual controls with the low-level control of code in Visual Studio .NET programming languages to provide a powerful report designer.

In This Documentation

Welcome to ActiveReports 13
This section provides basic information on installing and using the product, as well as support, licensing, and what's new.
License Your ActiveReports
This topic walks you through how to license your machine and how to add licensing to any projects created during your evaluation.
Upgrading Reports
This topic provides information about upgrading reports from previous versions of ActiveReports and Data Dynamics Reports, and about importing MS Access Reports, Crystal Reports, and Excel files with the Import Wizard.
Importing Reports
This section describes about importing different reports in ActiveReports using ActiveReports Import Wizard.
Getting Started
This section provides an overview of the interface and where to find everything you need to get started designing reports.
Viewing Reports
Learn how to preview a report at design time or view it in Windows Form or Web Viewers.
Concepts
This section provides information on what you can do with ActiveReports.
How To
This section provides step-by-step instructions for many features.
Samples and Walkthroughs
This section provides a description of the samples available with ActiveReports and step-by-step walkthroughs explaining key features.
Troubleshooting
This section provides troubleshooting symptoms, causes, and solutions to commonly encountered issues.

See Also

Class Library
Class Library

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Welcome to ActiveReports 13

Welcome to ActiveReports 13
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13

Glossary Item Box

Learn to use and install ActiveReports 13.

This section contains information about

What's New
Learn about the new features in ActiveReports.
ActiveReports Editions
Find out which features can be used with Standard and Professional Edition licenses.
Installation
View requirements for installation of ActiveReports, learn what files are installed and how to verify your installation, and find installation troubleshooting tips.
GrapeCity Copyright Notice
Explains GrapeCity copyright information.
End User License Agreement
Understand the terms of the ActiveReports License Agreement and Limited Warranty.
Redistributable Files
Find out the list of files that may be distributed.

See Also

Concepts

Getting Started
Getting Started

How To
How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


What's New

What's New
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > What's New

Glossary Item Box

We have made a number of changes and added new features since the last version of ActiveReports. Following are some of the major highlights of this release.

LookupSet Function in Data Regions

Now in Page and RDL reports, you can use the LookupSet function to display all matching data for a specified name in a dataset with name and value pairs.

Learn More

Improved JS Viewer

Improved JS Viewer performance includes the following features.

  • Optimized memory usage at report rendering.
  • Improved image and barcode processing for page and rdl reports.

New Charts (Page/RDL Reports)

We have introduced two new chart types to the Chart control of Page/RDL reports – Polar and Spiral. The new charts are available in the ActiveReports Web Designer or End User Designer.

Learn More

Collapsible Rows in Excel (RDL Reports)

In your RDL report, you can have collapsible rows in the Excel exported file.

The new property EnableToggles allows to export collapsible rows in the detail and row groups of the Table control. The EnableToggles property appears in the Export menu when the Pagination property is set to False. The default value is False.

Learn More

New Chart Tooltips

The new Tooltip Template property allows to select a value from the list of predefined tooltip templates in the ActiveReports Web Designer or End User Designer. The new chart tooltips are displayed in JS Viewer and HTML5 Viewer.

Learn More

Vertical Merge in Table Cells

The Table control in Page and RDL reports now supports the vertical merge of cells. You can merge cells in the vertical direction inside the Table's section (Header, Group Header, Footer, Group Footer, and Detail) when creating a report in ActiveReports Designer and ActiveReports Web Designer.

Merge Multiple Page/RDL Reports

With this feature, you can combine multiple Page and RDL reports into one report, one after the another. You can then preview and export the combined report to any exportable format.

Learn More

IVS Character Support

ActiveReports now supports Ideographic Variation Sequences (IVS). The IVS characters can be viewed in any viewer or at run-time in the Win and Web designers; and can be exported to any exportable format.

Devanagari support in PDF Export

The PDF Export in ActiveReports now supports Devanagari characters with fonts such as Arial Unicode MS, Nirmala UI, and Mangal, which contain Devanagari glyphs.

PDF Font Factory and Azure Web Applications

An improved PDF Font Factory allows to embed end-user defined characters (EUDCs) in PDF by modifying the web.config settings. The information that you set for the end-user defined characters (EUDCs) in the web.config file will override the registry setting at the Azure Web Application deployment.
This feature works with both ExportFilter and RenderingExtension and is part of the Professional Edition.

Support for Visual Studio 2019

ActiveReports 13 is now fully integrated into the new Visual Studio 2019 IDE.

JS Viewer

ActiveReports now provides new generation viewer which is built on JavaScript library. Following advantages of JS Viewer can be noted in comparison to HTML5 Viewer:

  • Responsive web design
  • Adapts different display sizes
  • Less dependency on other libraries (jquery, etc.)
  • Works on modern web application frameworks - ASP.NET MVC, ASP.NET Core MVC, HTML5, and major JavaScript Frameworks such as Angular and Vue.js.

Learn More

Web Designer as Component

Web Designer is now available as component in ActiveReports. Now you can embed Web Designer into any web application to create and edit reports effortlessly.

Learn More

New Chart Control

The ActiveReports now presents new Chart control that provides ease of data visualization through encodings. The encodings map the data values to graphical representations and make charts more effective and visually understandable.

Learn More

Support for converting Section reports to Page reports

The ActiveReports Import tool now allows you to convert Section reports to Page reports, in addition to RDL report which is already supported.

Learn More

Automatic Cell Merge

We have a new AutoMergeMode property for detail cells in Table and Tablix data region. This property allows merging consecutive cells with same data values depending on the previous row or column merge setting.

Learn More

GS1 QR Barcode

Now all report types support the GS1 QR barcode, which is a 2D symbol denoting the Extended Packaging URL for a trade item.

Learn More

New RichTextBox

The improved RichTextBox control now supports more tags and attributes. The other enhancement is that you can edit the HTML data in RichTextBox directly as now the control displays the HTML markup when you put it in the edit mode.

Learn More

New FormattedText

The FormattedText control has also undergone improvements and now supports more tags and attributes. Moreover, the FormattedText control now displays the formatting of the html text directly in the Designer tab, thus you can immediately see what the text will look like at run time.

Learn More

Visual Studio and ActiveReports Designer theme integration

Now if you select a theme for your Visual Studio, this theme is automatically applied to the integrated ActiveReports Designer. The Visual Studio theme is extended to such ActiveReports Designer elements as Reports Library, Layer List, Report Explorer and Group Editor. This improvement works for all reports (Page, RDL, and Section) opened in Visual Studio 2012 or higher.

Learn More

Improved CSV Export

A new CSV export option, NoHeader, is now available that allows to export a report to CSV without the default CSV header. The option is set to False by default.

Learn More

URL Support in CSV Path (Page/RDL Reports)

An improved CSV Data Source dialog provides the URL support of the CSV data provider. You can enter a valid CSV file URL address into the Path option of the dialog.

Learn More

See Also

Concepts
Adding an ActiveReport to a Project

Getting Started
Getting Started

How To
How To

Walkthroughs
Samples and Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveReports Editions

ActiveReports Editions
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > ActiveReports Editions

Glossary Item Box

Show All Show All
Hide All Hide All

Available in two editions, Standard and Professional, ActiveReports 13 delivers outstanding reporting capabilities. Drop down the sections below to see the features packed into each edition.

Show Standard Edition Features

The Standard Edition provides a report designer that is fully integrated with the Visual Studio IDE, a report viewer for Windows Forms, and export filters for generating reports in various file formats. The report designer even includes a barcode control with all of the most popular barcode styles, and its own chart control.

Designer

  • Full integration with the .NET environment
  • Familiar user interfaces
  • Choice of section or page or RDL report types
    • C# and VB.NET support with code-based section reports
    • Script support with XML-based section reports
    • Expression support with page reports and RDL reports
  • The ability to compile reports into the application for speed and security or to keep them separate for ease of updating
  • Designer hosting of .NET and user controls

Report Controls

Section Reports Page Reports/RDL Reports
  • ReportInfo
  • Label
  • Line
  • PageBreak
  • OleObject
  • SubReport
  • Shape
  • Picture
  • RichTextBox with HTML tag support
  • Chart with separate data source
  • Textbox
  • Barcode with standard styles plus RSS and UPC styles
  • Checkbox
  • CrossSectionBox extends from a header section to the related footer section
  • CrossSectionLine extends from a header section to the related footer section
  • Table data region
  • Tablix data region
  • Map data region
  • Chart data region
  • List data region
  • BandedList data region
  • Sparkline data region
  • FormattedText with mail merge capabilities and XHTML + CSS support
  • Bullet Graph
  • BarCode
  • CheckBox
  • TextBox
  • TableOfContents
  • Line
  • Container
  • Shape
  • Image
  • Subreport
  • Overflow Placeholder

Expressions (Page reports/RDL reports)

  • Aggregates
  • Data visualization
    • Data bar
    • Icon set
    • Range bar
    • Color scale
    • Gradient
    • Hatch

Interactive Features

  • Document map (table of contents)
  • Bookmark links, hyperlinks, and drill through links
  • Parameters
  • Drill-down (page report/RDL reports)
  • Copy, pan, and zoom
  • Jump to previous, next, first, or last group or search result

Reporting Engine

  • Managed code
  • Binding to ADO.NET, XML, iList, and custom data sources
  • Master reports, themes, and styles
  • All of the features of previous versions of ActiveReports and Data Dynamics Reports

Windows Forms Report Viewer

  • Managed C# code
  • Very small deployment assembly, suitable for use on the Internet
  • Table of contents and bookmarks
  • Thumbnail view
  • HyperLinking
  • Annotations (section reports only)
  • Configurable scroll bar jump buttons (like those found in Microsoft® Word®)
  • Parameters
  • Bookmark links, hyperlinks and drillthrough links
  • Interactive sorting (page reports/RDL reports)
  • Touch mode

HTML5 Viewer

  • A Javascript component
  • Provides multiple UI options
  • Ability to create a customized viewer
  • Touch mode support in Mobile UI
    Note: HTML5 Viewer is deprecated and will be obsolete in the future version.

WPF Viewer

  • Managed C# code
  • Table of contents and bookmarks
  • Thumbnail view
  • Parameters
  • Annotations
  • Configurable scroll bar jump buttons (like those found in Microsoft® Word®)
  • Bookmark links, hyperlinks and drillthrough links
  • Interactive sorting

Export Filters

ActiveReports includes export filters to generate output into many popular formats.

Export formats | Section report | Page/RDL report
Html: Export reports to HTML, DHTML, or MHT formats, all of which open in a Web browser. | ✓ | ✓
Pdf: Export reports to PDF, a portable document format that opens in the Adobe Reader. | ✓ | ✓
Rtf: Export reports to RTF, RichText format that opens in Microsoft Word, and is native to WordPad. | ✓ | ✓
Word: Export reports to DOC, a format that opens in Microsoft Word. | ✘ | ✓
Text: Export reports to TXT, plain text, a format that opens in Notepad or any text editor. Export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. | ✓ | ✓
Image: Export reports to BMP, EMF, GIF, JPEG, or PNG image format. | ✘ | ✓
Tiff: Export reports to TIFF image format for optical archiving and faxing. | ✓ | ✓
Excel: Export reports to formats that open in Microsoft Excel, XLS or XLSX. | ✓ | ✓
Xml: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. | ✘ | ✓
CSV: Export reports to a CSV file, a form of structured data in plain text. The text in a CSV file is saved as series of values separated by comma. | ✘ | ✓
JSON: Export reports to a JSON file, a text-based data format in which the data is stored in the hierarchical form. | ✘ | ✓

Import Filters

  • Access® Reports
  • Crystal Reports
  • Excel file
  • RPX file

Stand-Alone Applications

  • The Report Viewer application contains all the functionality of the ReportPreview control. It can be opened from the shortcut provided in the Start menu.
  • The WPF Viewer application contains all the functionality of the WPF Viewer control.
  • The ActiveReports Import Wizard application allows importing Microsoft Access reports, Crystal Reports, Excel files, and RPX files.

Show Professional Edition Features

The Professional Edition includes all of the features of the Standard Edition and supports the following additional features:

End-User Report Designer

The control is a run-time designer that may be distributed royalty-free. It allows the ActiveReports designer to be hosted in an application and provides end-user report editing capabilities. The control's methods and properties provide easy access for saving and loading report layouts, monitoring and controlling the design environment, and customizing the look and feel to the needs of end users.

Stand-Alone Applications

  • The Report Designer application contains all the functionality of the integrated Report Designer. It can be opened from the shortcut provided in the Start menu.

ASP.NET Integration

  • The Web server control provides convenience for running and exporting reports in ASP.NET.
  • HTTP Handler extensions allow report files (RPX or RDLX) or compiled assemblies containing reports to be dropped on the server and hyperlinked.

WebViewer Control

  • The WebViewer control allows quick viewing of ActiveReports on the web as well as printing capability with the AcrobatReader ViewerType enumeration.

HTTP Handlers

  • The RPX and RDLX HTTPHandler allows the developer to hyperlink ActiveReports on a web page to return HTML format or PDF format reports for viewing and/or printing.
  • The Compiled Report HTTPHandler allows the developer to hyperlink ActiveReports compiled in an assembly on a web page to return HTML format or PDF format reports for viewing and/or printing.

Table of Contents Control

  • TableOfContents control is used to display the document map, an organized hierarchy of the report heading levels and labels along with their page numbers, in the body of a report.
  • TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports

Map Control

  • The Map data region shows your business data against a geographical background.
  • Create different types of map, depending on the type of information you want to communicate in your report.

PdfSignature and TimeStamp Features

  • The PdfSignature class allows you to provide PDF document digital signatures and certification.
  • The PdfStamp class allows you to draw the digital signatures and certification onto the documents.
  • The TimeStamp class allows you to add a TSA (Time Stamping Authority) stamp to your digital signatures.

Font Linking

  • Font linking helps you resolve the situation when fonts on a deployment machine do not have the glyphs that were used in a development environment.
  • By linking fonts, you can resolve the problem with a different PDF output on deployment and development machines that may occur due to the missing glyphs.

Font Fallback

  • If missing glyphs are not found in linked fonts, the PDF export filter looks for the glyphs in fonts declared in the FontFallback property.
  • A default font is used if you do not declare one, or you can declare an empty string for this property to leave out missing glyphs from the exported file.

PDF Export

  • PDF/A and PDF/UA support.
  • IVS character support.
  • Devanagari character support.

Bold Font Emulation (PDF Export Filter)

  • Some fonts (for example, Franklin Gothic Medium, Microsoft Sans Serif, most East Asian fonts, etc.) may lose bold style for the PDF output. The Professional Edition provides bold style emulation in the PDF export filter to eliminate this limitation.

Word Export

  • Export your reports in .docx format, a format that opens in Microsoft Word application.

Web Designer

  • Create or modify reports by embedding Web Designer into your web applications.

JS Viewer

  • View reports in all modern browsers using JS Viewer.

Show Comparison Between Editions

Professional Edition features are disabled or marked with an evaluation banner if you have purchased a Standard Edition license.

Features Standard Professional
Visual Studio Controls
Web Forms WebViewer: Use this control to display your reports on the Web. Includes viewer types HTML and PDF. ✘ ✓
HTML5 Viewer: Use this Javascript component in web applications to preview reports hosted on ActiveReports 13 Web Service. ✓ ✓
HTTP Handlers: PDF and HTML (compiled report, RPX file) ✘ ✓
Windows Forms Viewer: Use this control to offer your users report zoom and preview, multiple tabs for hyperlinks, split-page and multi-page views, a Table of Contents pane, a Thumbnails pane, text searches, and annotations. ✓ ✓
Designer: Use this control to create a royalty-free, custom designer that your end users can use to create and modify their own reports. ✘ ✓
ReportExplorer: Use this control along with the Designer control to provide functionality to your users. ✓ ✓
ToolBox: Use this control along with the Designer control to provide report controls for your users. ✓ ✓
LayerList: Use this control along with the Designer control to provide Layers functionality to your users. ✓ ✓
ReportsLibrary: Use this control to view, add, or hide report parts. ✓ ✓
WPF WPF Viewer: Use this control to display your section, page and RDL reports. The WPF Viewer offers the Thumbnails pane, the Parameters pane, the Document map pane, and the Search results pane. ✓ ✓
Web and Windows Forms HtmlExport: Export reports to HTML, DHTML, or MHT formats that open in a Web browser. ✓ ✓
PdfExport: Export reports to PDF, a portable document format that opens in the Adobe Reader. ✓ ✓
RtfExport: Export reports to RTF, RichText format that opens in Microsoft Word, and is native to WordPad. ✓ ✓
WordExport (.doc): Export reports to DOC (Word HTML), a format that opens in Microsoft Word. ✓ ✓
WordExport (.docx): Export reports to DOCX (Office Open XML), a format that opens in any word processing software. ✘ ✓
TextExport: Export reports to TXT, plain text, a format that opens in Notepad or any text editor.
This export filter can also export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. 		✓ ✓
ImageExport: Export reports to BMP, EMF, GIF, JPEG, TIFF, or PNG image format.
Note that you can only export section reports to the TIFF image type. All other image types are for page reports and RDL reports. 		✓ ✓
XlsExport: Export reports to formats that open in Microsoft Excel, XLS or XLSX. ✓ ✓
XmlExport: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. ✓ ✓
Components Web Designer: Create or modify reports by embedding Web Designer into your web applications. ✘ ✓
JS Viewer: View reports in all modern browsers using JS Viewer. ✘ ✓
PDF Export Advanced Features Digital signatures ✘ ✓
Time stamp ✘ ✓
EUDC ✘ ✓
Select from Japanese embedded fonts or unembedded fonts ✘ *1 ✓
Bold ✘ ✓
Italic ✓ ✓
Multi Language ✓ *2 ✓
PDF/A and PDF/UA Support ✘ ✓
IVS Character Support ✘ ✓
Devanagari Character Support ✘ ✓
Print Presets ✘ ✓
Integrated Report Designer
Design Format

Section reports support banded layouts.
Page reports support fixed page layouts.
RDL reports support continuous page layout.

 ✓ ✓
Script and Code In section reports, you can add C# or VB code to events behind your code-based reports, or add script to events in the script editor in XML-based reports.
In page reports/RDL reports, you can use regular expressions in any property, plus you can add VB.NET methods to the code tab, and call them in your expressions. 		✓ ✓
Report File Formats You can save and load page reports/RDL reports in RDLX (extended RDL) format.
You can save and load section reports in RPX (report XML) format, and you can compile section reports in CS or VB code formats. 		✓ ✓
Report Controls The BarCode control supports all of the following styles:
ANSI 3 of 9 | ANSI Extended 3 of 9 | Code 2 of 5 | Interleaved 2 of 5
Code 25 Matrix | Code 39 | Extended Code 39 | Code 128 A
Code 128 B | Code 128 C | Code 128 Auto | Code 93
Extended Code 93 | MSI | PostNet | Codabar
EAN-8 | EAN-13 | UPC-A | UPC-E0
UPC-E1 | RoMail RM4SCC | UCC/EAN-128 | QRCode
Code 49 | Japanese Postal | Pdf417 | EAN-128 FNC1
RSS-14 | RSS-14 Truncated | RSS-14 Stacked | MicroPdf417
RSS-14 Stacked Omnidirectional | RSS Expanded | RSS Expanded Stacked | MicroQRCode
BC412 | Code_11 | ISBN | ISMN
ISSN | ITF14 | MaxiCode | Pharmacode
Plessey | PZN | SSCC_18 | Telepen
IntelligentMail | IntelligentMailPackage | HIBC Code 128 | HIBC Code 39
 ✓ ✓
The Map control allows you to display data against a geographical background on the report. ✘ ✓

The TableofContents control allows you to display a document map in an organized hierarchy of the report heading levels and labels along with there page numbers, in the body of a report.

 ✘ ✓
The Chart control supports all of the following styles:

  • Common Charts: Area, Bar2D, Bezier, Doughnut/Pie, Line, Scatter, StackedArea, StackedBar, StackedArea100Pct, and StackedBAR110Pct
  • 3D Charts: Area3D, Bar3D, ClusteredBar, Line3D, Doughnut3D/Pie, StackedBar3D, and StackedBar3D100Pct
  • XY Charts: Bubble, BubbleXY, LineXY, and PlotXY
  • Financial Charts: Candle, HiLo, and HiLoOpenClose
  • Composite Charts for following chart types:
    • Column: Plain, Stacked, Percent Stacked
    • Area: Plain, Stacked, Percent Stacked
    • Line: Plain, Smooth
 ✓ ✓
Other report controls include:
Label | TextBox | CheckBox | Picture
Line | Shape | RichText | PageBreak
SubReport | ReportInfo | CrossSectionLine | CrossSectionBox
 ✓ ✓
Styles and Report Settings You can control page settings, printer settings, global settings such as grid display, grid size, and whether to show a verification dialog when deleting controls. You can specify row count or column count in grids, ruler units, and how many pages to display in previews. ✓ ✓
External Style Sheets You can reuse report designer styles by saving and loading style information in external files. ✓ ✓
Others The designer also offers snaplines, report preview, designer zoom, various formatting settings, control and text alignment settings, Z order settings, unbound fields, and parameters support. ✓ ✓
Input and Output
Data Supported data includes: ADO.NET data provider, ADO.NET data class (DataSet, DataTable, DataReader, DataView), Oracle data, XML data, and unbound data ✓ ✓
Print You can control the page size, orientation, and margins, as well as specifying bound (double page spread), collating, duplex printing, and paper feed trays. ✓ ✓
Import You can import Crystal Reports, MS Access Reports, Excel files, and RPX files using the ActiveReports Import Wizard. ✓ ✓

*1: Japanese fonts can only be output as embedded fonts.
*2: Cannot handle output of multiple language fonts in a single control. Please refer to Multi-Language PDF for details.

See Also

Getting Started
Getting Started

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Installation

Installation
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > Installation

Glossary Item Box

This section helps you understand the installation process.

In this section:

Requirements
Learn about the hardware and software required to run ActiveReports.
Install ActiveReports
Find out how to install the ActiveReports Setup.
Installed Files
Find out what files are installed with ActiveReports and where to locate them.
Side-by-Side Installation
Learn about working with different versions of ActiveReports on a single machine.

See Also

Getting Started
Getting Started

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Requirements

Requirements
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > Installation > Requirements

Glossary Item Box

To install and use ActiveReports 13, you need the following hardware and software.

Hardware requirements (minimum)

  • Hard drive space: 200 MB available

Development Environments

Windows Forms, WPF, ASP.NET Applications, HTML5 Viewer, JavaScript library
  • Operating System:
    Windows 7, 8.1, or 10, or
    Windows Server 2008 R2, 2012, 2012 R2, 2016, and 2019
  • Microsoft Visual Studio: 2012, 2013, 2015, 2017, and 2019
  • Internet Information Services 7.5, 8.0, 8.5, 10

    Note:

    The Express Editions of Visual Studio do not work with ActiveReports, as they do not support packages.
You are required to perform following updates from the links provided for proper working in Visual Studio.

Developer Pack for .NET Framework 4.6.2 or above

https://www.microsoft.com/net/download/visual-studio-sdks

NuGet Package

  • for VS2012
    https://marketplace.visualstudio.com/items?itemName=NuGetTeam.NuGetPackageManager
  • for VS2013
    https://marketplace.visualstudio.com/items?itemName=NuGetTeam.NuGetPackageManagerforVisualStudio2013
  • for VS2015
    https://dist.nuget.org/visualstudio-2015-vsix/latest/NuGet.Tools.vsix

Visual Studio Update Packages

  • update 5 for VS2012
    https://support.microsoft.com/en-us/help/3072098/visual-studio-2012-update-5
  • update 5 for VS2013
    https://docs.microsoft.com/en-us/visualstudio/releasenotes/vs2013-update5-vs
  • Update 3 for VS2015
    https://docs.microsoft.com/en-us/visualstudio/releasenotes/vs2015-update3-vs
  • update 3 and KB3165756 for VS2015
    https://docs.microsoft.com/en-us/previous-versions/mt752379(v=vs.140)
  • version 15.9 for VS2017
    https://docs.microsoft.com/en-us/visualstudio/releasenotes/vs2017-relnotes
  • version 16.1 for VS2019
    https://docs.microsoft.com/en-us/visualstudio/releases/2019/release-notes#16.1.0

TypeScript Plugin

Download latest TypeScript plugin (required for Angular applications)

  • For VS2015
    https://www.microsoft.com/en-us/download/details.aspx?id=48593
  • For VS2017/VS2019
    https://github.com/Microsoft/TypeScript/releases

Run Time Supported Environments

Windows Forms and WPF
  • Microsoft® .NET Framework Version: 4.6.2 and above
  • Operating System:
    Windows 7(SP1), 8.1, or 10, or
    Windows Server 2008 R2, 2012, 2012 R2, 2016, and 2019

Web Development

ASP.NET Application, HTML5 Viewer, JavaScript Viewer, ActiveReports Web Designer

  • Server
    • Microsoft® .NET Framework Version: 4.6.2 and above
    • Operating System:
      Windows 7(SP1), 8.1, or 10, or
      Windows Server 2008 R2, 2012, 2012 R2, 2016, and 2019
    • Internet Information Services 7.5, 8.0, 8.5, 10
  • Client
    • Microsoft Internet Explorer 11
    • Google Chrome 50 and higher
    • Mozilla Firefox 57 and higher
    • Mobile Safari (iOS10.0.3 and higher)

See Also

Getting Started
Getting Started

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Install ActiveReports

Install ActiveReports
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > Installation > Install ActiveReports

Glossary Item Box

Follow the steps below to install GrapeCity ActiveReports on your machine.

Note: Your machine setup may require you to be logged in as an Administrator to install new software. If this is the case and you do not have Administrator privileges, consult your system administrator.
  1. On your system, double-click the ActiveReports-v13.x.x.0.msi file or right-click the file and select Install.
  2. On the End-User License Agreement screen that appears, go through the terms in the License Agreement.

    • If you want to continue with the default installation settings, select the check box to accept the license agreement and click Install to continue with installation.
    • If you want to change the default installation path and the way product features are installed,

      1. Select Advanced and click Change.

      2. Specify the path for the installation and click OK.

      3. Click Next and select how controls, features, and samples are installed and integrated with VisualSudio versions.

      4. Select Install.

  3. On the User Account Control screen, select Yes to allow ActiveReports software installation on your PC.
  4. Once the installation finishes, a screen notifying the completion of installation appears. Select Activate now check box and click Finish to close the window and complete the installation process.
  5. Click Yes on the User Account Control screen to continue with activating the license.

See Also

Installed Files
Installation

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Installed Files

Installed Files
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > Installation > Installed Files

Glossary Item Box

Show All Show All
Hide All Hide All

You can verify your package installation by following the steps below:

  1. Open Visual Studio.
  2. From the Visual Studio Help menu, select About Microsoft Visual Studio and verify that ActiveReports 13 appears in the installed products list.

When you install ActiveReports and use all of the default settings, files are installed in the following folders:

Show C:\ProgramData\Microsoft\Windows\Start Menu\Programs\GrapeCity

File (or Folder) | Description
ActiveReports (folder) | Shortcut to the folder containing stand-alone applications and Samples folder. See the next dropdown for further details.
License Manager | Shortcut to the License Manager application.

Show C:\ProgramData\Microsoft\Windows\Start Menu\Programs\GrapeCity\ActiveReports 13

File (or Folder) | Description
ActiveReports 13 Designer | Shortcut to the stand-alone designer application.
ActiveReports 13 Import | Shortcut to the ActiveReports Import wizard application.
ActiveReports 13 Samples (folder) | Shortcut to the folder containing sample projects.
ActiveReports 13 Theme Editor | Shortcut to the ActiveReports Theme Editor application.
ActiveReports 13 User Guide(CHM) | Shortcut to the Compiled HTML help file for ActiveReports.
ActiveReports 13 User Guide(PDF) | Shortcut to the PDF help file for ActiveReports.
ActiveReports 13 User Guide(Web) | Shortcut to the Online help file for ActiveReports.
ActiveReports 13 Viewer | Shortcut to the stand-alone ActiveReports Viewer application.

Show C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13

Folder | Description
Advanced | Includes samples with advanced features.
API | Includes samples demonstrating API.
Data | Includes sample data files.
Data Binding | Includes samples illustrating data binding.
Designer Pro | Includes samples illustrating features available with professional edition.
Desktop | Includes WinForms Viewer and WPF Viewer sample.
Web | Includes Web samples.

Show C:\Program Files\GrapeCity\ActiveReports 13 (C:\Program Files (x86)\GrapeCity\ActiveReports 13 on a 64-bit Windows operating system)

Folder | Description
Deployment | Includes templates for WPF, Web service file required for Web Site or Web Applications, and JavaScript files for HTML and JS Viewer.
Icons | Includes associated Icons image files.
Localization | Includes Resource and DOS batch files for localizing ActiveReports components.
Tools | Includes all ActiveReports application, XML configuration files, and localization resources for designer and import tool in Chinese environment.
VisualStudio | Includes Microsoft Visual Studio application extension and bootstrapper application.

Show C:\Program Files\Common Files\GrapeCity\ActiveReports 13 (C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 13 on a 64-bit Windows operating system)

File (or Folder) | Description
Design (folder) | Includes GrapeCity.ActiveReports.Viewer.Wpf.VisualStudio.Design.4.5.dll assembly file.
License (folder) | Includes License Service assembly file.
redist (folder) | Includes native functions assembly for 64-bit machines.
zh-CN (folder) | Includes resource files for the Chinese environment.
DocumentFormat.OpenXml.dll | OpenXML assembly file.
Gcef.Data.DataEngine.dll | Gcef's DataEngine assembly file.
Gcef.Data.ExpressionInfo.dll | Gcef's ExpressionInfo assembly file.
Gcef.Data.VBFunctionLib.dll | Gcef's VBFunctionLib assembly file.
GrapeCity.ActiveReports.Aspnet.Viewer.dll | ASP.NET viewer assembly file.
GrapeCity.ActiveReports.Aspnet.Designer.dll | ASP.NET designer assembly file.
GrapeCity.ActiveReports.Aspnetcore.Designer.dll | ASP.NET Core designer assembly file.
GrapeCity.ActiveReports.Aspnetcore.Viewer.dll | ASP.NET Core viewer assembly file.
Grapecity.ActiveReports.config | XML configuration file.
GrapeCity.ActiveReports.Chart.dll | Chart control assembly file.
GrapeCity.ActiveReports.Core.DataProviders.dll | Data Providers assembly.
GrapeCity.ActiveReports.Design.Win.dll | Windows Designer assembly file.
GrapeCity.ActiveReports.Core.Diagnostics.dll | ActiveReports Diagnostics assembly file.
GrapeCity.ActiveReports.Document.dll | Document assembly file.
GrapeCity.ActiveReports.Core.Drawing.Gdi.dll | Drawing Gdi assembly file.
GrapeCity.ActiveReports.Export.Excel.dll | Excel Export assembly file.
GrapeCity.ActiveReports.Core.Export.Excel.Page.dll | Excel Export (for Page report) assembly file.
GrapeCity.ActiveReports.Export.Html.dll | HTML Export assembly file.
GrapeCity.ActiveReports.Core.Export.Html.Page.dll | HTML Export (for Page report) assembly file.
GrapeCity.ActiveReports.Export.Image.dll | Image Export assembly file.
GrapeCity.ActiveReports.Export.Pdf.dll | PDF Export assembly file.
GrapeCity.ActiveReports.Export.Rdf.dll | RDF Export assembly file.
GrapeCity.ActiveReports.Export.Svg.dll | SVG Export assembly file.
GrapeCity.ActiveReports.Core.Export.Text.Page.dll | Text Export assembly file.
GrapeCity.ActiveReports.Export.Word.dll | Word Export assembly file.
GrapeCity.ActiveReports.Export.Xml.dll | XML Export assembly file.
GrapeCity.ActiveReports.Interop.dll | Native functions assembly file.
GrapeCity.ActiveReports.Core.Rdl.dll | RDL assembly file.
GrapeCity.ActiveReports.Core.Rendering.dll | Rendering assembly file.
GrapeCity.ActiveReports.Serializer.dll | Serializer assembly file.
GrapeCity.ActiveReports.dll | Run time engine assembly file.
GrapeCity.ActiveReports.Viewer.Win.dll | Windows Viewer assembly file.
GrapeCity.ActiveReports.Viewer.Wpf.dll | WPF Viewer assembly file.
GrapeCity.ActiveReports.VisualStudio.dll | Visual Studio assembly file.
GrapeCity.ActiveReports.Web.Design.dll | Web Designer assembly file.
GrapeCity.ActiveReports.Web.dll | Web assembly file.
Grapecity.DataVisualization.dll | Data visualization assembly file.
Newtonsoft.Json.dll | Assembly file required when you use the JSON Provider in Page and RDL reports.
System.IO.Compression.dll | Compression/decompression assembly file.

Show C:\Program Files\Common Files\GrapeCity\Components (C:\Program Files (x86)\Common Files\GrapeCity\Components on a 64-bit Windows operating system)

File or Application | Description
GrapeCity.LicenseManager.exe | License Manager setup file.
GrapeCity.LicenseManager.exe.config | License Manager setup XML configuration file.

Show C:\Program Files\Grapecity\ActiveReports 13\Tools (C:\Program Files (x86)\GrapeCity\ActiveReports 13\Tools on a 64-bit Windows operating system)

File or Application | Description
ApplicationLicenseGenerator.exe | Application License Generator setup file.
ApplicationLicenseGenerator.exe.config | License Manager setup XML configuration file.
GrapeCity.ActiveReports.Designer.exe | Stand-alone designer setup file.
GrapeCity.ActiveReports.Designer.exe.config | Stand-alone designer setup XML configuration file.
GrapeCity.ActiveReports.Imports.exe | ActiveReports Import application setup file.
GrapeCity.ActiveReports.Imports.exe.config | ActiveReports Import application setup XML configuration file.
GrapeCity.ActiveReports.Imports.Win.exe | ActiveReports Import wizard setup file.
GrapeCity.ActiveReports.Imports.Win.exe.config | ActiveReports Import wizard setup XML configuration file.
GrapeCity.ActiveReports.ThemeEditor.exe | ActiveReports Theme Editor setup file.
GrapeCity.ActiveReports.ThemeEditor.exe.config | ActiveReports Theme Editor setup XML configuration file.
GrapeCity.ActiveReports.Viewer.exe | Stand-Alone ActiveReports Viewer setup file.
GrapeCity.ActiveReports.Viewer.exe.config | Stand-Alone ActiveReports Viewer setup XML configuration file.
GrapeCity.ActiveReports.WpfViewer.exe | Stand-Alone ActiveReports WPF Viewer setup file.
GrapeCity.ActiveReports.WpfViewer.exe.config | Stand-Alone ActiveReports WPF Viewer setup XML configuration file.
ReportDesigner.Switcher.exe | Report Designer Switcher setup file.
ReportDesigner.Switcher.exe.config | Web Key Generator setup XML configuration file.
WebKeyGenerator.exe | Web Key Generator setup file.
WebKeyGenerator.exe.config | Web Key Generator setup XML configuration file.
zh-CN folder | Includes resource files for the Chinese environment.
GrapeCity.ActiveReports.Imports.Access.dll | Microsoft Access Import assembly file.
GrapeCity.ActiveReports.Imports.Crystal.dll | Crystal Reports Import assembly file.
GrapeCity.ActiveReports.Imports.Excel.dll | Excel Import assembly file.
GrapeCity.ActiveReports.Imports.RPX.dll | RPX Import assembly file.
Newtonsoft.Json.dll | JSON framework assembly file.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Side-by-Side Installation

Side-by-Side Installation
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > Installation > Side-by-Side Installation

Glossary Item Box

Once ActiveReports 13 is installed on your system, it becomes the primary report designer. This means that when Visual Studio opens one of our proprietary file types, RPX or RDLX, it uses the ActiveReports 13 version of the following Visual Studio integrated features:

  • Integrated report designer
  • Report menu
  • ActiveReports toolbar
  • Report Explorer
  • Toolbox tabs
Note: Always use the Switcher tool of the latest ActiveReports version to switch designers in Visual Studio.

In ActiveReports, ReportDesigner.Switcher tool allows you to change packages which are registered in Visual Studio.

Tip: You can still access some of the integrated features even if they are hidden.

  • Right-click in the Visual Studio toolbar area to select which toolbars to show.
  • The Visual Studio View menu, under Other Windows, lets you select Report Explorer versions.
  • Toolbox tabs are still visible for other versions, but ones that do not work with the current designer are disabled.

In order to work with ActiveReports 12 RPX and RDLX reports, you must run the Switcher tool and change the Primary designer to ActiveReports 12. If you don't, the reports open in the ActiveReports 13 designer, and the toolbar does not work. To switch between designers,

  1. Close all instances of Visual Studio.
  2. In ...\GrapeCity\ActiveReports 13\Tools, double-click ReportDesigner.Switcher.exe to run the switcher tool.
  3. In the dialog that appears, under Primary designer, choose the radio button for the product you want to use and click OK.

See Also

Upgrading Reports
Breaking Changes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


GrapeCity Copyright Notice

GrapeCity Copyright Notice
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > GrapeCity Copyright Notice

Glossary Item Box

Information in this document, including URLs and web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. No part of this document may be reproduced, stored in, or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photo copying, recording, or otherwise), or for any purpose, without the express written permission of GrapeCity, inc.

The ActiveReports License Agreement constitutes written permission for Professional Edition licensees to copy documentation content for distribution with their end user designer applications so long as GrapeCity is given credit within the distributed documentation.

ActiveReports and the ActiveReports logo are registered trademarks of GrapeCity, inc.

All other trademarks are the property of their respective owners.

The following open source software is used in ActiveReports.

  • PDF Export/ Rendering Extensions
    iTextSharp v4.1.7.7
    Zlib
  • Designer
    jquery v2.1.0
    jQuery-ui v1.10.4
    Bootstrap v3.0.1
    bootstrap-treeview.js v1.0.0
    jQuery.event.drag v2.2
    jQuery.livequery v1.3.6
    jQuery.nicescroll v3.5.4
    Knockout v3.1.0
    knockout-handlebars.js v0.0.6
    korest.js v0.0.7
    Sharp Express
    Irony
    JSON.NET 7.0
  • Web Viewer
    jQuery v1.7.2
    jquery.layout v1.2.0
    JSON2 knockout.js v2.1.0
    SWFObject v2.2
    jQuery UI v1.8.16
    jQuery Timepicker Addon v1.4.5
    jsTree v1.0-rc3
    JSON.NET 7.0
  • HTML5 Viewer
    parseUri v1.2.2
    bootstrapSwitch v1.3
    spin.js v2.3.2
    jquery.spin.js
    Modernizr v2.7.1
  • Samples
    jquery.js v1.10.2
    knockout.js v2.3.0
    bootstrap.js v3.0.0

See Also

End User License Agreement

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


End User License Agreement

End User License Agreement
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > End User License Agreement

Glossary Item Box

The End-User license agreement is available online at https://www.grapecity.com/legal/eula.

Please read carefully before installing this software package. Your installation of the package indicates your acceptance of the terms and conditions of this license agreement. Contact GrapeCity Inc. if you have any questions about this license.

See Also

GrapeCity Copyright Notice

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Redistributable Files

Redistributable Files
See Also
ActiveReports 13 > ActiveReports User Guide > Welcome to ActiveReports 13 > Redistributable Files

Glossary Item Box

ActiveReports is developed and published by GrapeCity, Inc. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s). You may also distribute, free of royalties, the following Redistributable Files with any such application you develop to the extent that they are used separately on a single CPU on the client/workstation side of the network:

  • DocumentFormat.OpenXml.dll
  • Gcef.Data.DataEngine.dll
  • Gcef.DataExpressionInfo.dll
  • Gcef.Data.VBFunctionLib.dll
  • GrapeCity.ActiveReports.Chart.dll
  • GrapeCity.ActiveReports.Aspnetcore.Viewer.dll
  • GrapeCity.ActiveReports.Aspnet.Viewer.dll
  • GrapeCity.ActiveReports.Aspnetcore.Designer.dl
  • GrapeCity.ActiveReports.Aspnet.Designer.dll
  • GrapeCity.ActiveReports.Core.DataProviders.dll
  • GrapeCity.ActiveReports.Core.Diagnostics.dll
  • GrapeCity.ActiveReports.Core.Export.Html.Page.dll
  • GrapeCity.ActiveReports.Core.Export.Text.Page.dll
  • GrapeCity.ActiveReports.Core.Export.Excel.Page.dll
  • GrapeCity.ActiveReports.Core.Drawing.Gdi.dll
  • GrapeCity.ActiveReports.Core.Rdl.dll
  • GrapeCity.ActiveReports.Core.Rendering.dll
  • GrapeCity.ActiveReports.Document.dll
  • GrapeCity.ActiveReports.Export.Html.dll
  • GrapeCity.ActiveReports.Export.Excel.dll
  • GrapeCity.ActiveReports.Export.Image.dll
  • GrapeCity.ActiveReports.Export.Pdf.dll
  • GrapeCity.ActiveReports.Export.Rdf.dll
  • GrapeCity.ActiveReports.Export.Svg.dll
  • GrapeCity.ActiveReports.Export.Text.dll
  • GrapeCity.ActiveReports.Export.Word.dll
  • GrapeCity.ActiveReports.Export.Xml.dll
  • GrapeCity.ActiveReports.Imports.Access.dll
  • GrapeCity.ActiveReports.Imports.Crystal.dll
  • GrapeCity.ActiveReports.Interop.dll
  • GrapeCity.ActiveReports.OracleClient.dll
  • GrapeCity.ActiveReports.Serializer.dll
  • GrapeCity.ActiveReports.dll
  • GrapeCity.ActiveReports.Viewer.Win.dll
  • GrapeCity.ActiveReports.Viewer.Wpf.dll
  • GrapeCity.ActiveReports.VisualStudio.dll
  • GrapeCity.ActiveReports.Interop64.dll
  • DefaultWPFViewerTemplates.xaml
  • GrapeCity.ActiveReports.Viewer.Html.css
  • GrapeCity.ActiveReports.Viewer.Html.js
  • GrapeCity.ActiveReports.Viewer.Html.min.js
  • jsViewer.min.js
  • jsViewer.min.css
  • web-designer.js
  • web-designer.css
  • Newtonsoft.Json.dll
  • System.IO.Compression.dll

The following Redistributable Files require the Professional Edition license for redistribution:

  • GrapeCity.ActiveReports.Design.Win.dll
  • GrapeCity.ActiveReports.Web.dll
Note: See Installed Files for the location of the files listed above.

See Also

Welcome to ActiveReports 13

How To
License Your Active Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


License Your ActiveReports

License Your ActiveReports
ActiveReports 13 > ActiveReports User Guide > License Your ActiveReports

Glossary Item Box

Show All Show All
Hide All Hide All

You can use the GrapeCity License Manager utility to license ActiveReports during installation or if you already have a trial version installed. This topic gives an overview of all aspects of licensing in ActiveReports.

License Types

See ActiveReports Editions to learn which features are exclusive to the Professional Edition.

License Type | Description
Evaluation | Trial key is required. Evaluation banners display on all reports and controls, and the product stops functioning after 30 days from the date of installation. The first key is already activated when you download the trial. If needed, you can request a new key from the Sales department for an additional 30 day trial.
Standard | Standard Edition product key is required. Evaluation banners appear only on features that are exclusive to the Professional Edition. You receive this key by email when you purchase ActiveReports Standard Edition or upgrade from a previous version of ActiveReports Standard Edition.
Professional | Professional Edition product key is required. All reporting functionality and controls appear without any evaluation banners. You receive this key by email when you purchase ActiveReports Professional Edition or upgrade from a previous version of ActiveReports Professional Edition.

If you cannot find your email with the product key, please contact activereports.sales@grapecity.com to have it looked up.

Licensing a Developer Machine

Note that any machine on which ActiveReports are opened in Visual Studio or on which ActiveReports projects are compiled in Visual Studio must be licensed.

Tip: Always run the License Manager as Administrator.

Show To license a machine with ActiveReports during installation or to license a trial without reinstalling

  1. From the Start menu, go to All Programs (or All apps) > GrapeCity > License Manager, or during installation, select Activate now and the dialog will appear automatically.
  2. In the GrapeCity License Manager window that appears, under Action click Activate.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  3. On the Activate ActiveReports 13 dialog that appears, click the Next button.
  4. In the Enter a Product Key screen that appears next, enter the following information:
    • User Name: Enter your name here.
    • Organization: Enter your company name here.
    • Email: Enter your e-mail address here.
    • Product Key: Enter the product key exactly as you received it from GrapeCity, including any capital letters. When you enter the product key, a green check mark appears next to this field to indicate a valid key.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink

  5. Click the Next and then the Finish button to complete the licensing process.

Show To license ActiveReports on a machine without an internet connection

  1. At the time of installation, on the last screen a check box that states Run license manager appears. Select this checkbox and click the Close button to complete the installation.
  2. In the GrapeCity License Manager window that appears, under the Action field, click Activate.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  3. In the Activate ActiveReports 13 screen that appears, click the Next button.
  4. In the Enter a Product Key screen that appears next, enter the following information:
    • User Name: Enter your name here.
    • Organization: Enter your company name here.
    • Email: Enter your e-mail address here.
    • Product Key: Enter the product key exactly as you received it from GrapeCity, including any capital letters. When you enter the product key, a green check mark appears next to this field to indicate a valid key.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink

  5. Click the Next button to authenticate the license.
  6. If your machine does not have an internet connection, select the Use a browser on another machine with Internet connectivity option from the following screen and click the Next button.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  7. From the Activate using the GrapeCity web site screen that appears, copy the Product Key and Authentication Number.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  8. On another machine with an internet connection, go to https://sas.grapecity.com/activation. Remember not to close the activation dialog on your original machine until the activation process is complete.
  9. Enter the Product Key and Authentication Number you copied in step 7 on this website.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  10. Click the Send Request button to generate a license key.
  11. Copy the license key from the web page that looks like the following image and in the Activate using GrapeCity web site dialog under step 3, enter the key.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  12. Click the Next and then the Finish button to complete the licensing process.

Show To activate a license for ActiveReports on multiple machines

You can only activate a single developer license key for ActiveReports on three machines for use by one developer.

If you have used all three of the license activations and you want to license a fourth machine, for example, a virtual machine for use by the same licensed developer, you must deactivate the license key from one of the other machines. For more information, drop down the section below titled "To deactivate an ActiveReports license."

After you have deactivated licensing on one of the machines, you can activate ActiveReports on another machine.

Note: Deactivate your ActiveReports license before formatting a machine to avoid loss of activation. If this happens by accident, you can contact our support team for help.

Show To deactivate an ActiveReports license

To use your ActiveReports license on another machine for your own use when you have used up all three of your activations, you can deactivate it on one machine.

  1. From the Start menu, go to All Programs (or All apps) > GrapeCity > License Manager.
  2. In the GrapeCity License Manager window that appears, under Action click Deactivate.
  3. In the Deactivate ActiveReports 13 page that appears, select the Next button.
  4. In the Confirm the Product screen that appears, confirm that the correct product is getting deactivated and click the Next button.
  5. The Deactivation Successful screen appears with the Product Name as ActiveReports 13 and the Current Status as Trial License (number of days left).

Show To upgrade or downgrade a license

Note: In order to upgrade or downgrade a license on a machine, you must have installed both a Professional and a Standard license on the machine. If you have not, the Upgrade/Downgrade column does not appear in the License Manager. If you have one and wish to install the other, you must first deactivate the installed license. The Upgrade/Downgrade option is added at that point.

If you want to change your ActiveReports license type you need to do one of the following:

Upgrade from a Standard to a Professional License:

  1. From the Start menu, go to All Programs (or All apps) > GrapeCity > License Manager.
  2. In the GrapeCity License Manager window that appears, under Upgrade/Downgrade click Upgrade to Professional License.
  3. Follow the activation steps from step 3 of To license an ActiveReports Trial without reinstalling to upgrade.

Downgrade from a Professional to a Standard License:

  1. From the Start menu, go to All Programs > GrapeCity > License Manager.
  2. In the GrapeCity License Manager window that appears, under Upgrade/Downgrade, click Downgrade to Standard License.
  3. In the Deactivate ActiveReports 13 page that appears, select the Next button.
  4. In the Confirm the Product screen that appears, confirm that the correct product is being downgraded and click the Next button.
  5. The Deactivation Successful screen appears with the Product Name as ActiveReports 13 and the Current Status as Standard License.

Note: You can upgrade a license only if you buy an upgrade from Standard Edition to Professional Edition.

Show To determine whether a machine is licensed

  1. In Visual Studio, open any sample from the included samples located in C:\Users\USERNAME\Documents\GrapeCity Samples\ActiveReports 13.
  2. Open one of the reports in the sample and click the Preview tab.
  3. Scroll to the bottom of the report. If there is red evaluation text, the machine is not licensed.

Note: To check for Professional Edition licensing, open a sample from the Professional folder, run it, and look for evaluation messages.

Licensing a Project

Tips:

  • To deploy using XCOPY, you must include the DLLs for all of your ActiveReports references in your bin/debug folder. To do this, in the Visual Studio Solution Explorer, select each reference, and in the Properties window, set Copy Local to True and rebuild your solution.
  • To avoid having to change the version number every time you install an ActiveReports service pack, in the Visual Studio Solution Explorer, select each reference, and in the Properties window, set Specific Version to False.

Show To license Windows Forms projects made on the trial version

These steps assume that you already have an ActiveReports licensed edition installed on your system.

  1. Open the project in Microsoft Visual Studio.
    Note: If another application calls the one containing ActiveReports features, you must license the calling application to avoid evaluation banners after deployment.
  2. Go to the Visual Studio Build menu and select Rebuild Solution.
  3. To verify that the application is licensed, open the licenses.licx file and compare it to the Required references section below.

The executable application is now licensed, and no nag screens or evaluation banners appear when you run it. You can distribute the application to unlicensed machines and no nag screens or evaluation banners appear.

Show Required references in the licenses.licx file (for Standard and Professional Editions)

The licenses.licx file must contain the following references to ActiveReports if you were using both Section and Page reports, and both Windows and WPF viewers. See the table below for the references to the ActiveReports version and the reference to the Viewer control.

Note: The Version, Culture, and PublicKeyToken information is added automatically, but can be removed, and should be removed if the version is wrong.
Paste INSIDE the licenses.licx file. Copy Code
GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports
GrapeCity.ActiveReports.PageReport, GrapeCity.ActiveReports
GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win
GrapeCity.ActiveReports.Viewer.Wpf.Viewer, GrapeCity.ActiveReports.Viewer.Wpf

Here are all of the license strings that you may need:

Component | License String
Section report engine | GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports
Page and RDL report engine | GrapeCity.ActiveReports.PageReport, GrapeCity.ActiveReports
WinForms viewer control | GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win
WPF viewer control | GrapeCity.ActiveReports.Viewer.Wpf.Viewer, GrapeCity.ActiveReports.Viewer.Wpf
PRO (some features) PDF export | GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf
PRO ONLY: WebViewer, HTTP handlers, Web service | GrapeCity.ActiveReports.Web.WebViewer, GrapeCity.ActiveReports.Web
PRO ONLY: End-user designer | GrapeCity.ActiveReports.Design.Designer, GrapeCity.ActiveReports.Design.Win

Note: When using the PDF export filter in your project, make sure you check the licenses.licx file for reference to the PDF Export Assembly.

Show To license Web Forms projects made on the trial version

Follow these steps after you license ActiveReports on your machine.

  1. Open the project in Microsoft Visual Studio.
  2. Open the Visual Studio Build menu and select Rebuild Solution.
  3. The web site application is now licensed. You can distribute the web site application to unlicensed machines and no evaluation banners appear.

Show To license Web Site applications

Follow these steps after you license ActiveReports on your machine.

  1. Open the project in Visual Studio.
  2. In the Solution Explorer, right-click the licenses.licx file and select select Build Runtime Licenses to create the App_Licenses.dll file.

The web site application is now licensed. You can distribute the web site application to unlicensed machines and no evaluation banners appear.

Show To license medium trust projects

To provide licensing for medium trust projects with ActiveReports, you can generate a web key using the Web Key Generator utility on a machine with licensed ActiveReports.

  1. From the ...\GrapeCity\ActiveReports 13\Tools folder, run the WebKeyGenerator.exe.
  2. In the dialog that appears, click Copy.
    Note: In your web.config file, if you already have content in your <configuration> and <appSettings> elements, you can use the first Copy button to copy only the web key. If not, you can use the second Copy button to copy the whole <configuration> section.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  3. In your project web.config file, between the opening and closing <configuration> tags (or in place of them, if they are empty) paste the web key so that it looks like the following.
    XML code. Paste INSIDE the Web.config file Copy Code
    <configuration>
<appSettings>
<add key=" ActiveReports 13 License" value="Generated Web Key" />
</appSettings>
</configuration>
Note: If you see the message "Your computer is not currently licensed" in the Web Key Generator dialog, please license your machine.

Show To license a class library project

Follow these steps after you license ActiveReports on your machine.

  1. Open the project for the root-level calling application, that is, the executable that calls your class library, in Visual Studio.
    Note: If you do not have access to this project, see "To license ActiveReports when you cannot compile the calling application."
  2. From the Project menu, select Add New Item, and the select an ActiveReports report. (You can delete it later. This is only to add the references to the project.)
  3. Open the Visual Studio Build menu and select Rebuild Solution.
  4. Check the licenses.licx file and verify that ActiveReports licensing is added for all of the features used in your project.
Note: If you use other ActiveReports features in your class library that are still showing an evaluation banner, for example, features exclusive to the Professional Edition, you can add those references manually and rebuild the solution.

Show To license ActiveReports when you cannot compile the calling application or the calling application is COM

When you are not able to compile the calling application in .NET, whether because you don't have access to build a third-party project, or because the calling application is COM, you can still license ActiveReports using the Application License Generator utility.

Definition: A calling application is the root-level application that the user initiates to eventually access your compiled assembly. This could be an executable, a web page, a COM executable, etc.

IMPORTANT: This is the ONLY reason you should ever use the Application License Generator.

Follow these steps after you license ActiveReports on your machine.

  1. From the ...\GrapeCity\ActiveReports 13\Tools folder, run the ApplicationLicenseGenerator.exe. If you are using a Windows 7 or higher machine, right click the executable file and select Run As Administrator.

  2. Click the Browse button and select the compiled dll that requires licensing.
  3. In the Assembly description field, enter the description for the assembly that you are licensing. You can later view this description by right-clicking the licensed assembly.
  4. Click the Generate button.
  5. Distribute the generated file <AssemblyName>.GrapeCity.Licenses.dll along with the application.

Licensing Errors

Here are some common licensing errors and their causes.

Error | Cause
Application cannot run because it was built with no license. | Licensing is not present in the application or the calling application. See below for information on how to license the calling application.
License for XXXX (control name) could not be found. | Extra lines for components that you do not use are in the licenses.licx file. Delete unnecessary information and Rebuild the project.
Licensing has not been correctly applied to the application. | Check the three key points below.
Exception (LicenseException) | Check the three key points below.
  1. Ensure that the license file is added to the appropriate project.

    The licenses.licx file is automatically generated in the project where ActiveReports is used. But if your application is composed of multiple projects and another project calls the reports defined in your class library, you need to register it in the calling project rather than just in your report project.

    When you add an ActiveReports web service to a Page report, RDL report, or XML-based Section report project, the licenses.licx file is not created automatically, and the license strings are not added. You also need to manually add licensing to your application if you want to create a control at run time or use the HTTP handlers.

    Show To manually add licensing to the calling application

    Note: In a C# Windows Forms project, the license file is in the Properties folder. In a Visual Basic project, it is in the My Project folder.

    1. In your application that contains ActiveReports components, check that the proper licensing strings are in the licenses.licx file. (See the table of license strings below.)

    2. Copy the ActiveReports strings from the file into the licenses.licx file in the calling application.
    a. If there is no license file, from the Project menu, select Add New Item.
    b. From the listed templates, select Text file and change the name to "licenses.licx."
    c. In the Solution Explorer, double-click the newly created licenses.licx file to open it, and paste in the licensing strings for all components you use.

    3. From the Build menu, select Rebuild Project to embed the licensing.

    ​Note: If your project is a web site, the bin folder has the licenses embedded in the App_Licenses.dll file.
  2. Ensure that the contents of the license file are correct.

    Depending on which features of ActiveReports you use in your application, the license file may need to contain multiple license strings.

    You will find a full list of license strings that you may need in the Required references in the licenses.licx file (for Standard and Professional Editions) section above.

  3. Ensure that the Build Action property is configured correctly for the license file.

    1. In the Solution Explorer, select licenses.licx (you may need to click the Show all files button to see it).

    2. In the Properties window, ensure that the Build Action property is set to Embedded Resource.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Upgrading Reports

Upgrading Reports
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports

Glossary Item Box

This section summarizes information on migration of ActiveReports, importing Microsoft Access reports, Crystal reports, and Microsoft Excel; and coexistence of ActiveReports .NET designers of different versions.

In this section:

Breaking Changes
Describes changes from the previous version
Migration Types
Describes the migration types and layouts.
Migrating from Previous Versions
Describes migration from previous versions of ActiveReports for .NET.
Migrating Execution Environment
Describes about migration of execution environment.
Migrating from ActiveReports 2 COM
Describes migration from ActiveReports COM (the ActiveX version).
ActiveReports 2 COM versus ActiveReports for .NET
Describes the difference between ActiveReports COM and ActiveReports for .NET.
Coexistence of ActiveReports Designers
Describes the compatibility of different versions of ActiveReports designers and Visual Studio.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Breaking Changes

Breaking Changes
See Also
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Breaking Changes

Glossary Item Box

Show All Show All
Hide All Hide All

Breaking changes from ActiveReports 12 to ActiveReports 13

  1. Following is the list of changes in public classes and namespaces location:
    Class/Namespace | ActiveReports 12 | ActiveReports 13 | Impact
    ResourceLocator, DefaultResourceLocator | GrapeCity.ActiveReports.Extensibility.v12 | GrapeCity.ActiveReports.Core.Rdl | On creating own resource locator
    GrapeCity.ActiveReports.PageReportModel.* | GrapeCity.ActiveReports.v12 | GrapeCity.ActiveReports.Core.Rdl | On creating reports dynamically
    GrapeCity.ActiveReports.Rendering.IO.* | GrapeCity.ActiveReports.v12 | GrapeCity.ActiveReports.Core.Rendering | On rendering to any rendering extension
    GrapeCity.ActiveReports.Extensibility.Rendering.Components.* | GrapeCity.ActiveReports.Extensibility.v12 | GrapeCity.ActiveReports.Core.Rendering | On creating own rendering extensions or custom report items
    GrapeCity.ActiveReports.Extensibility.Data.* GrapeCity.ActiveReports.Extensibility.v12 - On using own data providers
    GrapeCity.ActiveReports.Dashboard.* GrapeCity.ActiveReports.Dashboard.v12 GrapeCity.ActiveReports.Core.Rendering -
    GrapeCity.ActiveReports.Calendar.* GrapeCity.ActiveReports.Calendar.v12 Calendar is moved to samples -
    GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension | GrapeCity.ActiveReports.Extensibility.v12 | GrapeCity.ActiveReports | On creating own rendering extensions
    GrapeCity.ActiveReports.ReportData.DataProviders.* | GrapeCity.ActiveReports.v12 | GrapeCity.ActiveReports.Core.DataProviders | On using CSV, JSON, Object, Xml, DataSet data providers
    GrapeCity.ActiveReports.ArsClient.* GrapeCity.ActiveReports.ArsClient.v12 removed -
    GrapeCity.ActiveReports.OracleClient.* GrapeCity.ActiveReports.OracleClient.v12 GrapeCity.ActiveReports.Core.DataProviders -

  2. The following assemblies have been removed:
    • GrapeCity.ActiveReports.ArsClient
    • GrapeCity.ActiveReports.Calendar
    • GrapeCity.ActiveReports.Dashboard
    • GrapeCity.ActiveReports.Export.Document
    • GrapeCity.ActiveReports.Export.Image.Unsafe
    • GrapeCity.ActiveReports.Export.Xaml
    • GrapeCity.ActiveReports.Extensibility
  3. Following ActiveReports Core assemblies have been added:
    • GrapeCity.ActiveReports.Core.DataProviders
    • GrapeCity.ActiveReports.Core.Drawing.Gdi
    • GrapeCity.ActiveReports.Core.Rdl
    • GrapeCity.ActiveReports.Core.Rendering
    • GrapeCity.ActiveReports.Core.Export.Text.Page
    • GrapeCity.ActiveReports.Core.Export.Excel.Page
    • GrapeCity.ActiveReports.Core.Export.Html.Page
  4. Assembly GrapeCity.ActiveReports.Diagnostics is renamed to GrapeCity.ActiveReports.Core.Diagnostics.
  5. Following assemblies are added that have back-ends for JsViewer and Web Designer components:
    • GrapeCity.ActiveReports.Aspnetcore.Viewer.dll
    • GrapeCity.ActiveReports.Aspnet.Viewer.dll
    • GrapeCity.ActiveReports.Aspnetcore.Designer.dl
    • GrapeCity.ActiveReports.Aspnet.Designer.dll

  6. Flash and Silverlight viewers are now obsolete.

  7. HTML5 Viewer is deprecated and will be obsolete in the future version.

  8. Custom Data Providers have been modified as:
    • Removed extra classes and interfaces - DbCommand, DbConnection and others have been removed to reuse standard System.Data.* classes. Now implement System.Data.DataProviderFactory, System.Data.DbCommand, System.Data.DbConnection, System.Data.DbDataReader OR download any third-party implementation of those standard interfaces.
    • Simplified using custom data providers - The customer may just configure ActiveReports to start using of any ADO component.
      Note: Multivalue parameters, Credentials, and UI editor are available only if customer implements special adapter.
      To support setting of credentials and multivalue parameters, implement GrapeCity.ActiveReports.ReportData.DataProviders.DbConnectionAdapter.
    • Created data provider should be configured using ActiveReports.config - Specify name and data provider factory type. You may specify custom editor, adapter type (AdapterType attribute) and schema provider type (SchemaProviderType attribute).

  9. LocateDataSourceEventArgs class which obtains data for LocateDataSource event has undergone following changes.
    • Following properties have been removed:
      • DataSetName:string
      • DataSourceName:string
      • Report:PageDocument
    • Following properties have been added:
      • DataSet:IDataSet
      • Report:ReportObjectModel.Report
      • Parameters:IReadonlyList<DataParameter>
    ActiveReports 12 approach ActiveReports 13 approach

    class LocateDataSourceEventArgs{

    public object Data {get;set;}

    public string DataSetName {get;}

    public string DataSourceName {get;}

    public PageDocument Report {get;}

    }

    class LocateDataSourceEventArgs{

    public object Data {get;set;}

    public IDataSet DataSet {get;}

    public Report Report {get;}

    public IReadonlyList<DataParameter> Parameters {get;}

    }
    Note: The ActiveReports 13 parameters are Query parameters, so if you want to obtain Subreport parameters (available in PageDocument in ActiveReports 12), you should map them to Query parameters first.
  10. Custom Report Items have been modified as:
    • Most of the extra methods of ICustomReportItem interface (required for Flash) were dropped.
    • Now CRIs should implement IReportItemRenderersFactory interface.

  11. HTML RE ILinkProvider
    Cleaned ILinkProvider interface with few new properties.

  12. HTML RE
    HTML RE does not inherit IDisposable since state is moved to ReportService.asmx. In previous version, HTMLRE inherits IDisposable because it keeps huge state (for WebViewer puposes).

Show Breaking changes from ActiveReports 11 to ActiveReports 12

  • The GrapeCity.ActiveReports.Expressions namespace is now GrapeCity.Enterprise.Data.DataEngine.Expressions.
  • The hybrid expressions like =Theme.Constants("Name") & " - " & [OrderDate].Year are now evaluated as 'render time' expressions.
  • ActiveReports 12 is not supported in Microsoft Visual Studio 2010.
  • Flash and Silverlight viewers are deprecated.

Show Breaking changes from Previous ActiveReports versions to ActiveReports 12

When you upgrade reports from previous versions of ActiveReports or Data Dynamics Reports, there are several breaking changes. In ActiveReports 12, data engine has been revamped to improve the data manipulation tasks such as sorting, filtering, and grouping.

Control Changes

The Excel Transformation Device option, the File menu item Microsoft Excel WorkSheet - Data (XLS), is no longer available for RDL reports in the default export dialogs of the viewer and designer applications shipped with the product. For backward compatibility, the Excel Transformation Device API is still available, but it does not support the new Tablix control. In order to successfully export reports using the new Tablix control, please use the Excel Rendering Extension option, the File menu item Microsoft Excel WorkSheet - Layout (XLS, XLSX).

The Matrix data region has been replaced in the toolbox with the new Tablix data region. However, it is still available in the API for backward compatibility.

The OleObject control is now hidden by default in the toolbox for Section reports. To show this control in Visual Studio, open the GrapeCity.ActiveReports.config file and change the EnableOleObject value to true, and include this file with your application. You can find this file here: C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 12.

To show the OleObject control in the Designer control in your own end users designer applications, select the Designer control and, in the Properties window, change the EnableOleObject property to True.

The WebViewer control is now AJAX-based, and requires ActiveReports.ReportService.asmx to be in the root of the Web site or Web application. This is added automatically when you drop a WebViewer control on a Web form, or you can add it from the Add New Item dialog by selecting ActiveReports 12 Web Service, or manually by copying it from C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 12. ExceptionOccurring, QueuingReport, ReportCreating and ReportDisposing events are no longer available in WebViewer class.

The Viewer control no longer has Annotations turned on by default. To enable Annotations, set the AnnotationDropDownVisible property of the Viewer control to True. DataDynamics.ActiveReports.Viewer.ReportViewer.MultiplePageMode property is now integrated into ViewType property of Viewer class. Viewer.ReportViewer.PaperColor property has been removed. Viewer.PageOffset property's type has been changed from Integer to System.Drawing.Point.

The Toolbar is now a Windows ToolStrip. Please see the MSDN ToolStrip Class for more information.

In RDL and Page reports, the default behavior of the Series Border Style setting for Area, Pie and Doughnut chart types has been changed. Now, the default value of this setting is None, thus no style formatting is applied.

Other Changes

Rendering Extensions (Image): ColorDepth is an obsolete property of GrapeCity.ActiveReports.Export.Image.Page.Settings class.

Expressions: In Page report and RDL report expressions, "True" and "False" values are now handled as String, and not as Boolean values.
For example, =IIF(Fields!FieldName.Value = "True", 1, 0) is now an invalid expression when FieldName.Value returns a Boolean value, instead, use =IIF(Fields!FieldName.Value = True, 1, 0) expression.

Classes in Different Namespaces

In ActiveReports 12, some classes have been moved to different namespaces from previous versions of ActiveReports and Data Dynamics Reports. Drop down the table below to see some of the most commonly used classes that are in new namespaces.

Namespace Changes and Restructuring

Some of the changes that are not picked up by the upgrade tool may cause some issues in your code. The two most frequently encountered changes are:

  • DataDynamics.ActiveReports.ActiveReport is now GrapeCity.ActiveReports.SectionReport
  • DataDynamics.ActiveReports.Document.Document is now GrapeCity.ActiveReports.Document.SectionDocument

These are all of the assemblies and namespaces that have changed, with any major changes noted.

Show ActiveReports is now GrapeCity.ActiveReports.v12

  • ActiveReport class is now called SectionReport.
  • BarWidth property is now called NarrowBarWidth.
ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports
  • GrapeCity.ActiveReports
  • GrapeCity.ActiveReports.SectionReportModel
  • GrapeCity.ActiveReports.Data
DataDynamics.ActiveReports.DataSources | GrapeCity.ActiveReports.Data
DataDynamics.ActiveReports.Interop GrapeCity.ActiveReports
DataDynamics.ActiveReports.Options GrapeCity.ActiveReports.SectionReportModel

Show ActiveReports.Chart is now GrapeCity.ActiveReports.Chart.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Chart | GrapeCity.ActiveReports.Chart
DataDynamics.ActiveReports.Chart.Annotations | GrapeCity.ActiveReports.Chart.Annotations
DataDynamics.ActiveReports.Chart.Graphics | GrapeCity.ActiveReports.Chart.Graphics

Show ActiveReports.Design is now GrapeCity.ActiveReports.Design.Win.v12

The Report property is now an Object that gets or sets a GrapeCity.ActiveReports.Document.SectionDocument or GrapeCity.ActiveReports.Document.PageDocument.

The ColorTheme property of the Designer class is deprecated.

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Design | GrapeCity.ActiveReports.Design
DataDynamics.ActiveReports.Design.ReportExplorer | GrapeCity.ActiveReports.ReportExplorer
DataDynamics.ActiveReports.Design.Toolbox | GrapeCity.ActiveReports.Design.Toolbox

Show ActiveReports.Document is now GrapeCity.ActiveReports.Document.v12

The Document class is now called SectionDocument.

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports | GrapeCity.ActiveReports
DataDynamics.ActiveReports.Document
  • GrapeCity.ActiveReports.Document
  • GrapeCity.ActiveReports.Document.Section
  • GrapeCity.ActiveReports.Extensibility.Printing(GrapeCity.ActiveReports.Extensibility.v12)
DataDynamics.ActiveReports.Export | GrapeCity.ActiveReports.Export
DataDynamics.ActiveReports.Export.Html | GrapeCity.ActiveReports.Export.Html
DataDynamics.ActiveReports.Document.Annotations | GrapeCity.ActiveReports.Document.Section.Annotations

Show ActiveReports.HtmlExport is now GrapeCity.ActiveReports.Export.Html.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Export.Html | GrapeCity.ActiveReports.Export.Html.Section

Show ActiveReports.PdfExport is now GrapeCity.ActiveReports.Export.Pdf.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Export.Pdf | GrapeCity.ActiveReports.Export.Pdf.Section
DataDynamics.ActiveReports.Export.Pdf.Signing | GrapeCity.ActiveReports.Export.Pdf.Section.Signing

Show ActiveReports.RtfExport is now GrapeCity.ActiveReports.Export.Word.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Export.Rtf | GrapeCity.ActiveReports.Export.Word.Section

Show ActiveReports.Silverlight is now GrapeCity.ActiveReports.Viewer.Silverlight.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports | GrapeCity.ActiveReports

Show ActiveReports.TextExport is now GrapeCity.ActiveReports.Export.Xml.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Export.Text | GrapeCity.ActiveReports.Export.Xml.Section

Show ActiveReports.TiffExport is now GrapeCity.ActiveReports.Export.Image.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReportsExport.Tiff | GrapeCity.ActiveReports.Export.Image.Tiff.Section

Show ActiveReports.Viewer is now GrapeCity.ActiveReports.Viewer.Win.v12

  • The History class is now an interface, IHistoryApi, that resides in the GrapeCity.Viewer.Common namespace.
  • The SearchResultsForeColor property now gets applied as the border around the searched text.
  • The DisplayUnits and RulerVisible properties of the Viewer class have been removed as the Viewer no longer uses a ruler.
  • The TabTitleLength property of the Viewer class is not available as the tab function of the Viewer has been removed.
  • The ViewerToolbar.DisplayToolTips property of the Viewer.ViewerToolbar class is now ViewerToolbar.ToolStrip.ShowItemToolTips.
  • The ViewerToolbar.Enabled property of the Viewer.ViewerToolbar class is now ViewerToolbar.ToolStrip.Enabled.
  • The ViewerToolbar.Visible property of the Viewer.ViewerToolbar class is now ViewerToolbar.ToolStrip.Visible.
  • The TargetView enumeration now has two enumeration values (Primary and Secondary).
  • The ToggleVisibility() method is now Visible property that determines whether sidebar is visible or hidden.
  • The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in Grapecity.ActiveReport namespace of GrapeCity.ActiveReports.Viewer.Win.v12 assembly.
ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Toolbar | The viewer now uses Visual Studio ToolStrips. Please see MSDN ToolStrip Class for more information.
DataDynamics.ActiveReports.Viewer
  • GrapeCity.ActiveReports.Viewer.Win
  • GrapeCity.Viewer.Common
Note: GrapeCity.ActiveReports.Viewer.Win.v12.dll does not get added automatically to the project references when the report layout is added. You need to either add the Viewer control or manually add the reference to this assembly.

Show ActiveReports.Web is now GrapeCity.ActiveReports.Web.v12

The Report property is now an Object that gets or sets a SectionDocument or ReportDocument.

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Web | GrapeCity.ActiveReports.Web
DataDynamics.ActiveReports.Web.Controls | GrapeCity.ActiveReports.Web.Controls
DataDynamics.ActiveReports.Web.ExportOptions | GrapeCity.ActiveReports.Web.ExportOptions
DataDynamics.ActiveReports.Web.Handlers | GrapeCity.ActiveReports.Web.Handlers

Show ActiveReports.XlsExport is now GrapeCity.ActiveReports.Export.Excel.v12

ActiveReports Namespace (previous versions) | ActiveReports 12 Namespace
DataDynamics.ActiveReports.Export.Xls | GrapeCity.ActiveReports.Export.Excel.Section
DataDynamics.SpreadBuilder | GrapeCity.SpreadBuilder
DataDynamics.SpreadBuilder.Cells | GrapeCity.SpreadBuilder.Cells
DataDynamics.SpreadBuilder.Imaging | GrapeCity.SpreadBuilder.Imaging
DataDynamics.SpreadBuilder.Printing | GrapeCity.SpreadBuilder.Printing
DataDynamics.SpreadBuilder.Style | GrapeCity.SpreadBuilder.Style

See Also

Upgrading Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Migration Types

Migration Types
See Also
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migration Types

Glossary Item Box

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Migration from ActiveReports for .NET (1 / 2 / 3 / 6 / 7 / 8/ 9/ 10/11)

You can migrate to all the three types of reports - Section report, Page, or an RDL report in ActiveReports 13 using the file converter.

Migrating from ActiveReports 2 COM

You can migrate only the design information of ActiveReports 2 COM by saving the report as an RPX file. You can load and use the file after migrating to ActiveReports for .NET 11. No special migration tools are required.

Migrating from MS Access, Crystal Reports, and Excel workbook

You can use the Import Wizard to migrate reports to RPX files (Section reports) or RDLX files (Page and RDL reports). When migrating from MS Excel, it is possible to migrate only to RDLX file. You can load and use the file after migrating to ActiveReports for .NET 12.

See Also

Migrating from Previous Versions
Importing Crystal Reports/MS Access Reports
Importing Excel
Importing RPX

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Migrating from Previous Versions

Migrating from Previous Versions
See Also
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions

Glossary Item Box

This section explains how to migrate projects created with previous versions of ActiveReports to ActiveReports 13.

This section contains information about:

ActiveReports Version Up History
Describes the history of changes in the ActiveReports for .NET product.
ActiveReports File Converter
Describes how to migrate reports using ActiveReports file converter.
Migrating to ActiveReports 13
Describes how to migrate ActiveReports versions starting from ActiveReports 1 to ActiveReports 13.
Reference Migration
Describes how to migrate assembly (DLL) references.
License Migration
Describes how to migrate license information in a project.
ds Variable
Describes how to migrate the public variable 'ds' automatically generated by the previous version of ActiveReports.
WebViewer Migration
Describes how to migrate the WebViewer control included in ActiveReports Professional Edition.
ActiveX Viewer Migration
Describes how to migrate the ActiveX Viewer included in ActiveReports 1, 2, and 3.
Compatibility Guidelines
Describes compatibility issues between ActiveReports 13 and older versions of ActiveReports.

See Also

What's New
Breaking Changes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveReports Version Up History

ActiveReports Version Up History
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > ActiveReports Version Up History

Glossary Item Box

Please refer to this link for the history of changes that ActiveReports for .NET have undergone due to version upgrade.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveReports File Converter

ActiveReports File Converter
See Also
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > ActiveReports File Converter

Glossary Item Box

The ActiveReports file converter allows you to upgrade your existing reports from previous versions of ActiveReports (ActiveReports 12, 11, 10, 9, 8, 7, 6, 3, 2, and 1) to the latest version.

To use the file converter

  1. In Visual Studio, open an existing ActiveReports project.
    Caution: If you are migrating a project from a different version of Visual Studio, a Visual Studio conversion wizard will run automatically to convert the project.
  2. From the Visual Studio Tools menu, select Convert to ActiveReports 13. In the ActiveReports 13 Upgrade tool window that appears, you can see a list of report files to be converted.

    File Type | Extension
    Report file | *.rdlx, *.rpx, *.vb, *.cs
    Form with a viewer | *.vb, *.cs, *.xaml
    ASP.NET Web Form with a web viewer | *.aspx, *.aspx.vb, *.aspx.cs
    Project file | *.vbproj, *.csproj, Web.confg
    License file | licenses.licx
  3. Click OK to convert the files. After the files are successfully converted, all of the reference files are updated and the reports are converted to C# or Visual Basic class files. The old files are copied to ARConverterBackup folder generated under the root folder of the project. You can delete these files from the project if you do not need them.
    Caution: When converting from version 6 or below, you may observe the following warnings on migrating a form with the viewer control. These warnings are due to API modifications in ActiveReports 7 or above. You can ignore these warnings or delete them manually.
    • 'Public Property Text() As String' is an old format: 'Not used anymore'
    • 'Public Property TabTitleLength() As Integer' is an old format: 'Not used anymore'
    Note: In addition to the above conversions, you may also observe some formatting changes, such as code breaks, while using this converter tool.
  4. After running the converter, you need to manually update all the project references. For more details, see Migrating from Previous Versions.

See Also

Reference Migration
License Migration

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Migrating to ActiveReports 13

Migrating to ActiveReports 13
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > Migrating to ActiveReports 13

Glossary Item Box

Show All Show All
Hide All Hide All

The following steps explain how to migrate previous ActiveReports versions to ActiveReports 13.

  1. From the Visual Studio Tools menu, select Convert to ActiveReports 13.
    • If the assembly version of reference files does not automatically change to ActiveReport 13 after running the converter, you need to manually update the reference files. For more details, see Reference Migration.
    • If the license information is not displayed correctly after running the converter, you need to manually update the license information. For more details, see License Migration.
  2. See details below to migrate any of the following versions that contain specific classes or properties:

    Show ActiveReports 1

    • If you export to PDF and use the Version property, you need to change the casing in the PdfVersion enumerated values as follows:

      Before migration: PDFVersion.PDF13
      After migration: PdfVersion.Pdf13

    • If you are using the public variable 'ds' within the report, see ds Variable.
    • If you are using the WebViewer control, see WebViewer Migration.
    • If you are using the ActiveX viewer (ARVIEW2.CAB file) in a Web application, see ActiveX Viewer Migration.

    Show ActiveReports 2

    • If you are using the public variable 'ds' within the report, see ds Variable.
    • If you are using the WebViewer control, see WebViewer Migration.
    • If you are using the ActiveX viewer (ARVIEW2.CAB file) in a Web application, see ActiveX Viewer Migration.

    Show ActiveReports 3

    • If you are using the ActiveReport3 class in your project, you need to change ActiveReport3 class to SectionReport class.

      Before migration: DataDynamics.ActiveReports.ActiveReport3
      After migration: GrapeCity.ActiveReports.SectionReport

    • If you are migrating from an initial version of ActiveReports 3 and use the Barcode control's Style and BackColor properties, then the size of the Barcode control may change on migration. You can set the BackColor property of the Barcode control to White, or manually change the size.
      Property | Value
      Style | QRCode, Code49, JapanesePostal, Pdf417, EAN128FNC1 (Any of these)
      BackColor | System.Drawing.Color.Transparent
    • If you are using the public variable 'ds' within the report, see ds Variable.
    • If you are using the WebViewer control, see WebViewer Migration.
    • If you are using the ActiveX viewer (ARVIEW2.CAB file) in a Web application, see ActiveX Viewer Migration.

    Show From ActiveReports 6 to ActiveReports 12

    If you are using the WebViewer control, see WebViewer Migration.
  3. Check the Compatibility Guidelines.
  4. From the Build menu, select Rebuild Solution to rebuild the entire solution.
    Note: Between versions 1 and 13, we have updated several class names. This may cause syntax errors on migration. To resolve these errors, see the Breaking Changes topic.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reference Migration

Reference Migration
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > Reference Migration

Glossary Item Box

This topic explains how to upgrade your project references (.dlls) in your project.

ActiveReports 13 does not support references to previous versions, so you need to remove the old references and add new ones.

To upgrade your references

  1. In Visual Studio, open an existing ActiveReports project.
  2. In the Project Explorer, expand the References node, and remove the old references.
    Here are the ActiveReports version numbers by product name.
    Product Name | Assembly Version
    ActiveReports 1 | 3.x.x.xxxx
    ActiveReports 2 | 4.x.x.xxxx
    ActiveReports 3 | 5.x.x.xxxx
    ActiveReports 6 | 6.x.x.xxxx
    ActiveReports 7 | 7.x.x.xxxx
    ActiveReports 8 | 8.x.x.xxxx
    ActiveReports 9 | 9.x.x.xxxx
    ActiveReports 10 | 10.x.x.xxxx
    ActiveReports 11 | 11.x.x.xxxx
    ActiveReports 12 | 12.x.x.xxxx
    ActiveReports 13 | 13.x.x.xxxx

    Here is an example of an ActiveReports 9 project. In this project, delete all of the v9 references.

  3. Add references to ActiveReports 13. In the Solution Explorer, right-click the References node and select Add Reference.

    From the Add Reference dialog, add ActiveReports 13 references. Add each of the ActiveReports 13 references that corresponds to the ones we removed in Step 2. Please see Installed Files for details on the list of assemblies required in ActiveReports 13.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


License Migration

License Migration
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > License Migration

Glossary Item Box

This topic explains how to migrate license information for your ActiveReports project from an older version.

The process of licensing an ActiveReports application is different for each version. Migrate license information for Windows or Web projects as follows.

Windows Application

In your Windows application, check that the licenses.licx file contains the appropriate licensing strings. When upgrading from a previous version, remove the old information and update the license strings in the licenses.licx file. You can find the full list of license strings that you may need for licensing in the License Your ActiveReports topic Required references in the licenses.licx file (for Standard and Professional Editions) section.
Here are how the licensing strings appear before and after migration.

  • Before migration (ActiveReports 1/2/3)
    DataDynamics.ActiveReports.ActiveReport, ActiveReports
  • Before migration (ActiveReports 6)
    DataDynamics.ActiveReports.ActiveReport, ActiveReports
    DataDynamics.ActiveReports.Viewer.Viewer, ActiveReports.Viewer6
    DataDynamics.ActiveReports.Export.Pdf.PdfExport, ActiveReports.PdfExport
  • Before migration (ActiveReports 7)
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.
    GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.
  • Before migration (ActiveReports 9)
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v9
    GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.v9
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.v9
  • Before migration (ActiveReports 10)
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v10
    GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.v10
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.v10
  • Before migration (ActiveReports 11)
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v11
    GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.v11
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.v11
  • Before migration (ActiveReports 12)
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v12
    GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.v12
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.v12
  • After migration (ActiveReports 13)
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports
    GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf

Web Application

When migrating from ActiveReports versions 1, 2, and 3, you can find the license strings in the Web.config file. In ActiveReports 6 or above, the license strings are in the licenses.licx file. You can remove the old information from the Web.config file and update the necessary licensing strings in the project. For more details, please see the License Your ActiveReports topic Required references in the licenses.licx file (for Standard and Professional Editions) section.

  • Before migration (Web.Config file)

    The following information is not required in ActiveReports 6 or above.

    <Configuration>
          (...)
    <appSettings>
        <add key="DataDynamicsARLic" value="xxxxxxx,xxxxxxxxxx,xxxxxxxxxx,xxxxxxxxxxxxx" />
    </appSettings>
         （...）
    </Configuration>
  • After migration (licenses.licx file)

    For example, if you are creating a Web application that uses the WebViewer, add the following strings to the licenses.licx file in the project.

    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf
    GrapeCity.ActiveReports.Web.WebViewer, GrapeCity.ActiveReports.Web
  • You may also face an error due to the compiled license information of previous version mentioned in the Bin folder of the project. If the error occurs even after including the correct information in the license file, remove App_Licenses.dll available in the Bin folder

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ds Variable

ds Variable
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > ds Variable

Glossary Item Box

Show All Show All
Hide All Hide All

Migration Requirements

In ActiveReports 2 or below, when you create a data connection using the Report Data Source dialog, a public variable 'ds' is generated automatically by the report designer. This variable is not generated in ActiveReports 3 or above. If you use this variable in your code for making data connection settings of subreport, you need to change the code as follows.

To migrate code with public variable 'ds'

Before migration

Me.ds.ConnectionString 'Visual Basic

this.ds.ConnectionString; //C#

After migration

CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString 'Visual Basic

((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString; //C#

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


WebViewer Migration

WebViewer Migration
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > WebViewer Migration

Glossary Item Box

This topic explains how to upgrade the WebViewer control available in the Professional edition of ActiveReports.

The ASP.NET Web form or the Web.config file included in the WebViewer control is upgraded automatically on running the ActiveReports file converter. However, the converter does not upgrade the Flash viewer since flash viewer is obsolete.

The license file should also get updated while conversion, but in some cases due to the project configuration, you may need to manually update the license file. For more information on upgrading license, see License Migration.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveX Viewer Migration

ActiveX Viewer Migration
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > ActiveX Viewer Migration

Glossary Item Box

This topic explains how to migrate the ActiveX viewer included in ActiveReports 3, 2, and 1.

Migration Requirements

In ActiveReports 6 or above, ActiveX viewer (ARVIEW2.CAB) is not provided with the product installer. You need to migrate a web application that includes ActiveX viewer on the Web form or contains the WebViewer with ViewerType property set to ActiveXViewer. In ActiveReports 13, you can use the PDF export feature instead of ActiveX Viewer.

Note: To use the ActiveX viewer associated with previous version
In ActiveReports 13, you cannot use the ActiveX viewer of previous version. You can obtain the expected display or print results as per the report, however, such usage methods are not included in the product operational guarantee.

Alternative Approach

For both Professional and Standard editions, use PDF export to preview or print a report with quality similar to that observed with ActiveX viewer.

  • For ActiveReports Professional edition
    • WebViewer (PDF)
    • PDF Export
  • For ActiveReports Standard edition
    • PDF Export

Precautions

You can use print and preview features with same quality as mentioned in alternate approach, however, some print features are disabled.

 | Not available in ActiveReports 13 |  | Available in ActiveReports 13
Important Features | ActiveX Viewer | WebViewer (ActiveX) Professional Edition | WebViewer (PDF) Professional Edition | PDF Export
Direct printing from client printer | ○ | ○ | ○ | ○
Direct printing from client printer without preview | ○ | ○ | ○ | ○
Direct printing from client printer without preview (Windows print dialog is hidden ※1) | ○ | ○ | × | ×
Direct printing from client printer after changing settings (printer type, paper size etc.) | ○ (※3) | ○ (※3) | ○ (※2) | ○ (※2)
Auto scaling | × | × | × | ×
Automatic setting of page orientation | × | × | × | ×

※1: In client printing, if you click Print button, Windows Print dialog is displayed. In ActiveX viewer you can hide the Windows Print dialog.

※2: In Windows Print dialog, similar to general Office application, you can select paper size or orientation.

※3: In addition to point ※2, the developer can set the desired page size or page orientation in the printer through client scripting before the user displays the Windows print dialog.

To migrate project that uses ActiveXViewer as the ViewerType

If the ViewerType property is set to ActiveXViewer, you need to change it to AcrobatReader. For example, modify the code marked in red like the following code.

Before migration

Show Visual Basic

 Copy Code
' Set the type of the selected view in ViewerType property of the Web viewer.
Dim selection As String = Me.cboViewerType.Items(Me.cboViewerType.SelectedIndex).Text
Select Case selection
  Case "AcrobatReader"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.AcrobatReader
  Case "ActiveX viewer"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.ActiveXViewer
  Case "HTML viewer"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.HtmlViewer
  Case "RawHtml"
    Me.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.RawHtml
End Select

Show C#

 Copy Code

// Set the type of the selected view in ViewerType property of the Web viewer.

{
string selection = this.cboViewerType.Items(this.cboViewerType.SelectedIndex).Text;
switch (selection) {
case "AcrobatReader":
this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.AcrobatReader;
break;
case "ActiveX viewer":
this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.ActiveXViewer;
break;
case "HTML viewer":
this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.HtmlViewer;
break;
case "RawHtml":
this.arvWebMain.ViewerType = DataDynamics.ActiveReports.Web.ViewerType.RawHtml;
break;
}
}

After migration

Show Visual Basic

 Copy Code
' Set the type of the selected view in ViewerType property of the Web viewer.
Dim selection As String = Me.cboViewerType.Items(Me.cboViewerType.SelectedIndex).Text
Select Case selection
  Case "AcrobatReader"
    Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader
  Case "HTML viewer"
    Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer
  Case "RawHtml"
    Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml
End Select

Show C#

 Copy Code

// Set the type of the selected view in ViewerType property of the Web viewer.

{
string selection = this.cboViewerType.Items(this.cboViewerType.SelectedIndex).Text;
switch (selection) {
case "AcrobatReader":
this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader;
break;
case "HTML viewer":
this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer;
break;
case "RawHtml":
this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml;
break;
}
}

To migrate project that uses PDF Export

Re-create the application by referring the following basic operation or sample. Note that you don't need to re-create everything.
The basic difference between ActiveX viewer and PDF export is in the format of the data received from the web server to the client. An RDF file is generated on the Web server with ActiveX viewer and binary data of PDF format is created on the web server with PDF export. The other operations are common in ActiveX viewer and PDF export, there is no need to re-create the existing applications that are created using the ActiveX viewer. See Custom Web Exporting fro more information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Compatibility Guidelines

Compatibility Guidelines
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from Previous Versions > Compatibility Guidelines

Glossary Item Box

This topic guides you regarding the compatibility between the previous versions and ActiveReports 13. You may face issues related to following after the migration.

Show Method

In ActiveReports 6.0 and above, the Show method has been removed from the report class and as a result, the dependency to the main assembly (ActiveReports6.dll) and the viewer assembly (Viewer6.dll) is no longer available. Earlier, the main assembly and the viewer assembly in the execution environment were required to be added even for the applications that did not required preview. In ActiveReports 6 or above, you no longer need to add the viewer assembly.
If you are previewing reports using the following code in a previous version, you need to change it to the preview method that uses the Viewer component.

Before migration

Show Visual Basic

Copy Code
Private Sub Form1_Load(...) Handles MyBase.Load
  Dim rpt As New SampleReport
  rpt.Show()
End Sub

Show C#

Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
  SampleReport rpt = new SampleReport();
  rpt.Show();
}

In the following code, Form1 has been placed in the Viewer control. Here, if you set Document property of the report and then run the report, results obtained are similar to that with Show method.

After migration

Show Visual Basic

Copy Code
Private Sub Form1_Load(...) Handles MyBase.Load
  Dim rpt As New SampleReport
  Me.Viewer1.Document = rpt.Document
  rpt.Run()
End Sub

Show C#

Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
  SampleReport rpt = new SampleReport();
  this.viewer1.Document = rpt.Document;
  rpt.Run();
}

Print Method

In ActiveReports 7, the internal implementation of the Document.Print method has been changed. The Print method that was available in Document class upto ActiveReport 6 has been replaced by an extension method in PrintExtension class of Grapecity.ActiveReports namespace (GrapeCity.ActiveReports.Viewer.Win.dll) introduced in ActiveReports 7. Therefore in ActiveReports 7 and above, you need to import namespace in order to use the Print method. For more details, see Print Methods.

Custom Toolbar

ActiveReports 7 onward, toolbar has been reformed to use ToolStrip class. Also, the Viewer feature has been added to the toolbar and as a result, the display order of toolbar buttons has also changed. For more details, see Customizing the Viewer Control.

In case you have set the toolbar as Hidden, modify the code as follows:

Before migration

Show Visual Basic

Copy Code
‘Code for ActiveReports 6
Me.Viewer1.Toolbar.Tools(23).Visible = False 'Hide the [Annotation] button
Me.Viewer1.Toolbar.Tools(4).Visible = False ‘Hide the copy button

Show C#

Copy Code
//Code for ActiveReports 6
this.Viewer1.Toolbar.Tools(23).Visible == false //Hide the [Annotation] button
this.Viewer1.Toolbar.Tools(4).Visible == false //Hide the copy button

After migration

Show Visual Basic

Copy Code

‘Viewer1.Toolbar.ToolStrip.Items.RemoveAt(37)
‘[Annotation] button is hidden in ActiveReports 7, we don't have to mention it.
Viewer1.Toolbar.ToolStrip.Items.RemoveAt(5) ‘Hide the copy button

Show C#

Copy Code

//Viewer1.Toolbar.ToolStrip.Items.RemoveAt(37);
//[Annotation] button is hidden in ActiveReports 7, we don't have to mention it.
  Viewer1.Toolbar.ToolStrip.Items.RemoveAt(5); //Hide the copy button

In case you have set additional buttons in the toolbar through the code, you need to replace it with the new API code.

Before migration (from Version 6)

Show Visual Basic

Copy Code

'Delete the existing Annotation button and add [Add Custom Annotation] button

Dim image As System.Drawing.Icon
image = New System.Drawing.Icon(Me.GetType.Module.Assembly.GetManifestResourceStream("CustomAnnotations.NOTE16.ICO"))
Viewer1.Toolbar.Images.Images.Add(image)

Dim btn As DataDynamics.ActiveReports.Toolbar.Button
btn = New DataDynamics.ActiveReports.Toolbar.Button

btn.ButtonStyle = DataDynamics.ActiveReports.Toolbar.ButtonStyle.TextAndIcon

btn.ImageIndex = 14 'Add new image in Toolbar.Images
btn.Id = ToolIds.Annotation 'Set unique ID in the button
btn.Caption = "Custom Annotation"
btn.ToolTip = "Set confirmation mark"
Viewer1.Toolbar.Tools.RemoveAt(23) 'Delete the existing Annotation button.
Viewer1.Toolbar.Tools.Insert(23, btn)

Private Sub Viewer1_ToolClick(ByVal sender As Object, ByVal e As DataDynamics.ActiveReports.Toolbar.ToolClickEventArgs) Handles Viewer1.ToolClick

'Describe about the event fired while pressing the annotation button

End Sub

Show C#

Copy Code

//Delete the existing Annotation button and add [Add Custom Annotation] button

System.Drawing.Icon image = default(System.Drawing.Icon);
image = new System.Drawing.Icon(this.GetType.Module.Assembly.GetManifestResourceStream("CustomAnnotations.NOTE16.ICO"));
Viewer1.Toolbar.Images.Images.Add(image);

DataDynamics.ActiveReports.Toolbar.Button btn = default(DataDynamics.ActiveReports.Toolbar.Button);
btn = new DataDynamics.ActiveReports.Toolbar.Button();

btn.ButtonStyle = DataDynamics.ActiveReports.Toolbar.ButtonStyle.TextAndIcon;

btn.ImageIndex = 14; //Add new image in Toolbar.Images
btn.Id = ToolIds.Annotation; //Set unique ID in the button
btn.Caption = "Custom Annotation";
btn.ToolTip = "Set confirmation mark";
Viewer1.Toolbar.Tools.RemoveAt(23); //Delete the existing Annotation button.
Viewer1.Toolbar.Tools.Insert(23, btn);

private void Viewer1_ToolClick(object sender, DataDynamics.ActiveReports.Toolbar.ToolClickEventArgs e)
{
//Describe about the event fired while pressing the annotation button

}

After migration (from Version 6)

Show Visual Basic

Copy Code

'Delete the existing Annotation button and add [Add Custom Annotation] button

Dim image As System.Drawing.Icon
image = New System.Drawing.Icon(Me.GetType.Module.Assembly.GetManifestResourceStream("CustomAnnotations.NOTE16.ICO"))

Dim btn As New ToolStripButton("Custom Annotation")
btn.DisplayStyle = ToolStripItemDisplayStyle.ImageAndText
btn.Image = image.ToBitmap
btn.ToolTipText = "Set confirmation mark"

‘Viewer1.Toolbar.ToolStrip.Items.RemoveAt(37) ‘The annotation button is by default hidden in ActiveReports 7, so it doesn't need description.
Viewer1.Toolbar.ToolStrip.Items.Add(btn)
‘Viewer1.Toolbar.ToolStrip.Items.Insert(37,btn) ‘Create event handler if you want to place button in a specified location during the button click.
AddHandler btn.Click, AddressOf tsbAnnotation_Click

Private Sub tsbAnnotation_Click(sender As Object, e As EventArgs)

‘Describe about the event fired while pressing the annotation button

End Sub

Show C#

Copy Code

//Delete the existing Annotation button and add [Add Custom Annotation] button

System.Drawing.Icon image = default(System.Drawing.Icon);
image = new System.Drawing.Icon(this.GetType.Module.Assembly.GetManifestResourceStream("CustomAnnotations.NOTE16.ICO"));

ToolStripButton btn = new ToolStripButton("Custom Annotation");
btn.DisplayStyle = ToolStripItemDisplayStyle.ImageAndText;
btn.Image = image.ToBitmap;
btn.ToolTipText = "Set confirmation mark";

//Viewer1.Toolbar.ToolStrip.Items.RemoveAt(37); //The annotation button is by default hidden in ActiveReports 7, so it doesn't need description.
Viewer1.Toolbar.ToolStrip.Items.Add(btn);
//Viewer1.Toolbar.ToolStrip.Items.Insert(37,btn); //Create event handler if you want to place button in a specified location during the button click.
btn.Click += tsbAnnotation_Click;

private void tsbAnnotation_Click(object sender, EventArgs e)
{
//Describe about the event fired while pressing the annotation button
}

In C# code, remove the additional code of Viewer.ToolClick event handler in XXX.Designer.cs.

Control Borders

ActiveReports 6 or above does not provide support the use of control borders of the Line control. As a result, control border of the Line control set in the previous version will not get rendered after migrating to ActiveReports 7 or above.

You cannot set the control border in the following controls:

  • Line
  • PageBreak
  • CrossSectionBox
  • CrossSectionLine

HTTP Handler (Professional edition only)

In ActiveReports 2 or above, the upper case and lower case characters of hyperlink strings used for directly referring the report layout file have been clearly distinguished. This may affect the working after the migration if upper case and lower case characters are not used correctly.

WebViewer Control (Professional edition only)

There are certain modifications in the properties available within the property window. In ActiveReports 1, you can use Report property to specify the report to be displayed. In ActiveReports 2 or above ReportName property has been introduced to replace Report property.
Please note that the Report property is removed from the property window but not from the WebViewer object, and hence there is no change in the code.

The type to set the Report property and ReportName property are different.

  • Report property: Object type
  • ReportName property: String type

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Migrating Execution Environment

Migrating Execution Environment
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating Execution Environment

Glossary Item Box

In .NET Framework, there is an assembly recognition mechanism with which the executable files or assembly files created in Visual Studio identify the assembly they depend. Therefore, it is necessary to have the same product version while building an application as that distributed in the run-time environment.

In case the product version is changed after distributing the application, the application will not run by simply changing the component (DLL file) in the run-time environment. To migrate the run-time environment of application to ActiveReports 13, migrate the development environment, migrate the project, and then re-create the application by rebuilding the solution. After doing, this you can deploy the created application along with ActiveReports 13 component.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Migrating from ActiveReports 2 COM

Migrating from ActiveReports 2 COM
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Migrating from ActiveReports 2 COM

Glossary Item Box

The reports in ActiveReports 2 COM, which is ActiveX version of ActiveReports, are saved in DSR/DSX format unlike .NET versions which saves report layouts in the XML based RPX format. Therefore, to migrate from ActiveReports 2 COM to ActiveReports for .NET, you need to save reports in ActiveReports 2 COM as .rpx file and embed it in ActiveReports 13 project. When you save the report layout as .rpx, ActiveReports only saves the code in the script editor. Any code behind the report is not saved to the RPX file, therefore, the code in the .cs or .vb file needs to be re-written.

Embedding an RPX file in a Visual Studio Project

Note: Adding an ActiveReports 2 COM report layout file (.rpx) directly to a project is not supported. Be sure to migrate using the following steps.
  1. From the Solution Explorer, select the project in which you want to add the item.
  2. From the Project menu, select Add New Item.
  3. From the Template pane, select ActiveReports 13 Section Report (code-based) or ActiveReports 13 Section Report (xml-based) file and click Add.
  4. From the Report menu, select the Load Layout option.
  5. Navigate to the location of the .rpx file, select the .rpx file, and click Open.
    Note:
    • Script codes such as Visual Basic and C# are not imported properly.
    • The border shadow (Border.Shadow property) is not migrated.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveReports 2 COM versus ActiveReports for .NET

ActiveReports 2 COM versus ActiveReports for .NET
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > ActiveReports 2 COM versus ActiveReports for .NET

Glossary Item Box

Show All Show All
Hide All Hide All

This section explains about the difference between ActiveReports 2 COM (ActiveX version) and ActiveReports 13.

Comparison between Section Report Controls

The following table compares the controls available in Section Report in ActiveX product and .NET product.

ActiveX product | .NET product
Field | TextBox
Label | Label
CheckBox | CheckBox
Image | Picture
Line | Line
OleObject | OleObject
PageBreak | PageBreak
RichEdit | RichTextBox
Shape | Shape
SubReport | SubReport
ActiveX control (includes Barcode) | ×（※１）
Frame | ×（※２）
ADO Data Control | OLEDataSource（※３）
XML Data Control | XMLDataSource（※４）
RDO Data Control | ×
DAO Data Control | ×
－ | Chart（※５）
－ | CrossSectionBox（※６）
－ | CrossSectionLine（※７）
－ | ReportInfo（※８）

※１ It will only get migrated as basic class ARControl.

※２ Control placed inside the Frame will be migrated.

※３ Only Source (SQL) and ConnectionString properties set at design time are migrated.

※４ Only FileURL/RecordSetPattern property set at design time are migrated.

※５ Control that renders 2D/3D graph.

※６ Control that renders a rectangle across multiple sections.

※７ Control that renders a straight line across multiple sections.

※８ A control that renders the execution date and time of report, page number, and total number of pages in a specified format.

Important properties that have been changed in .NET product

 | Property Name |  |
Control names in Section Report (.NET products) | ActiveX product | .NET product | Remarks
GroupHeader | GrpKeepTogether | GroupKeepTogether | The type itself is different
 | Repeat | RepeatStyle | The type itself is different
CheckBox TextBox Label | WordWrap | WrapMode | The type itself is different
TextBox | DataValue | Value |
 | SummaryDistinctField | DistinctField |
CheckBox | Alignment | CheckAlignment | The type itself is different
 | Value | Checked |
Picture | Picture | Image | The type itself is different
Shape | Shape | Style |
SubReport | Object | Report |

Important properties added in .NET product

Control names in Section Report (.NET product) | Property Name | Description
GroupHeader | ColumnGroupKeepTogether | Make groups as one block on the same column
Detail | RepeatToFill | Adds an empty line
CheckBox TextBox Label | Padding | Sets the blank space inside a control
TextBox Label | CharacterSpacing | Sets the character pitch(interval) in points units
 | LineSpacing | Sets the line spacing in point units
 | TextJustify | Sets equal allocation
 | VerticalText | Optimize character shape for vertical writing
 | ShrinkToFit | Shrink the character according to the Control size
Picture | Description | Sets the visual explanation of Picture's appearance (valid when exporting Html)
Line | AnchorBottom | Draw the end of the ruled line till the adjacent section
Shape | RoundingRadius | Sets the roundness of round cornered rectangle in percentage unit
SubReport | CloseBorder | When a sub-report spans multiple pages, it sets whether to close it with a ruled line or not

The above table lists only those properties that are frequently used, although, in addition to the above properties, there are some newly added properties and changed properties in the .NET product.

Also, the properties and methods of OleObject control and RichTextBox (RichEdit) control have been significantly changed. If you are using these controls, refer to "Class Library Reference" and adjust the settings as necessary.

Difference in Export Function

Export function of .NET product is developed to export the reports of .NET product.
Compared with the ActiveX products, various enhancements have been made in the Export function of .NET products along with the changes in properties and events.

For more information, please refer to the content below.

Show PDF Export

Subject | ActiveX product | .NET product
PDF Version | 1.1～1.3 | 1.1～1.7
PDF image quality setting of internal image | JPGQuality property in settings (1～100) | ImageQuality (three levels - Lowest, Medium, and Highest) and ImageResolution (75～2400 dpi) property in settings
Non embedding of Japanese font | × (always embedded) | ○ (※1, always embedded in Standard Edition)
Bold characters of Japanese font | × (output with normal thickness) | ○ (※1)
Foreign letters | × (no output) | ○ (※1)
Electronic Signature Time Stamp | × | ○: Signature property (※1)
GIF and transparent elements of meta images | × (present in non-transparent state) | ○
Output of bookmark | ○: OutputTOCAsBookmarks property | ○: ExportBookmarks property
Document property | × | ○: Options property (※2)
Document display state | △: ShowBookmarksInAcrobat (only display bookmarks are configurable) | ○: PdfDocumentOptions.DisplayMode property (※3)
Display window setting | × | ○: PdfDocumentOptions property (※4)
UI setting | × | ○: PdfDocumentOptions property (※5)
Print only | × | ○: PdfDocumentOptions.OnlyForPrint property
Gets the state of progress | ○: OnProgress event | ×

※1　Can be set only for Professional Edition.

※2　Five items - Title, Author, Subject, Keywords, and Application can be set.

※3　Four types - None, Outlines, Thumbs, and FullScreen can be set.

※4　CenterWindow, FitWindow, and DisplayTitle can be set.

※5　Display permission of Menu bar (HideMenubar), Toolbar (HideToolbar), and UI Window (HideWindowUI) can be set.

Show Excel Export

Show Excel export (XlsExport class)

Subject |  | ActiveX product | .NET product
Save File | File version | Excel 95/97 | Excel 95/97/2007 (OpenXML)
Layout | Space between cell and borders to prevent overlapping of cells | ○：BorderSpace Property | ×
 | Column appearance in the output | ○：DoubleBoundaries Property | ×
 | Generate page break automatically | ○：GenPageBreaks property | △: (always output the page break)
 | Display space between the report elements and the report margin | ○：ShowMarginSpace property | ×
 | Print scale | ○：SizeToFit property | ×
 | Remove vertical space | ○：TrimEmptySpace property | ○：RemoveVerticalSpace property
 | Version | ○：Version property | ○：FileFormat property
 | Display grid line | × (display fixing) | ○：DisplayGridLines property
 | Merge cells | × | ○：UseCellMerging property
 | Color palette | × (always keep palette in workbook） | ○：UseDefaultPalette property
Printing | Paper size | × (dependent on excel default settings) | ○：PageSettings.PaperSize property
 | Page orientation | × (dependent on excel default settings) | ○：PageSettings.Orientation property
Security | Read password | × | ○：Security.Password property
 | Write password | × | ○：Security.WritePassword property
 | Save as read only | × | ○：Security.ReadOnlyRecommended property
 | Username responsible to password protect an Excel sheet | × | ○：Security.ProtectedBy property
State of progress |  | ○：OnProgress event | ×

Show Excel export (SpreadBuilder API)

Subject |  | ActiveX product | .NET product
Implementation method |  | control in SpreadBuilder object | control in Workbook object
Save File | File version | Excel 95/97 | Excel 95/97/2007（OpenXML）
 | prior error check | ○：GetSaveCaps method | ×（processing due to Exception）
Layout | Cell merge/unmerge | × | ○: Merge/UnMerge method
 | Display grid line | × (always display) | ○: DisplayGridLines property
 | Line striking through a text | × | ○: FontStrikeOut property
 | Format setting by range specification | × | ○: Use DDCells class
 | Color palette | × (always keep palette in workbook) | ○: UseDefaultPalette property
Printing | Page setup | Setting available in DDSheet object | Use settings in PageSetup class
 | Black and white print | × | ○: BlackAndWhite property
 | Print without graphics | × | ○: Draft property
 | Scale print to fit page | ○：SizeToFit property | ○: FitToPage property
 | Vertical scale page count | × (set to one page) | ○: FitToPagesTall property
 | Horizontal scale page count | × (set to one page) | ○: FitToPagesWide property
 | Scale factor | × (set to 100%) | ○: Zoom property
 | Paper size | × (depends on excel default settings) | ○: PaperSize property
 | First page number | × (automatic) | ○: FirstPageNumber property
 | Header height | × | ○: HeaderMargin property
 | Footer height | × | ○: FooterMargin property
 | Page orientation | × (set from 'left to right' ) | ○: Order property
 | Print setting of cell notes | × (set to 'none') | △: PrintNotes property ※only 'screen display image' can be set
Security | Read password | × | ○: Password property
 | Write password | × | ○: WritePassword property
 | Save as read only | × | ○: ReadOnlyRecommended property
 | Username responsible to password protect an Excel sheet | × | ○: ProtectedBy property
 | Workbook protection password | × | ○: ProtectWorkbookPassword property

Show TIFF export

Subject |  | ActiveX product | .NET product
Compression scheme |  | Decided by the method to use | Setting available in CompressionScheme property
Compression format | none | × | ○：”None”
 | Lzw | × | ○：”Lzw”
 | Rle (PackBits) | ○：Export/ExportTIFF method | ○：”Rle” (however, default is black and white)
 | CCITT Group3 | ○：FaxExportCITT3 method | ○：”Ccitt3”
 | CCITT Group4 | ○：FaxExport method | ○：”Ccitt4”
Dithering |  | ○：only FaxExport or FaxExportCITT3 methods can be used (※1) | ○：Dither property (※2)
Resolution |  | ○：only ExportTIFF method can be used | ○：DpiX, DpiY property
State of progress |  | ○：OnProgress event | ×

※1　The white threshold can be set within the range of 0～765.

※2　Valid only for “Rle”, ”Ccitt3”, ”Ccitt4”. Also, this property is of Boolean type.

Show HTML export

Subject |  | ActiveX product | .NET product
File output | Image save location | ○：AuxOutputPath property | × (always same path as HTML in output)
 | Whether to embed CSS style inside the html file | ○：CreateCSSFile property | × StyleStream property
 | Output file name | FileNamePrefix property setting | Specified by argument of Export method
 | File output location | HTMLOutputPath property setting | Specified by argument of Export method
 | JPEG compression ratio | ○: JPEGQuality property | ×
 | Output in MHT format | ○: MHTOutput property | ×
 | Output setting for multiple pages | MultiPageOutput property setting | MultiPage property setting
 | Output of bookmarks | ○: TableOfContents property (※1) | ○: BookmarkStyle property (※2)
Layout | Insert code just before HEAD tag | ○: HeadExtraInnerText property | ×
 | HTML version setting | ○: HTMLVersion property | ○: OutputType property
 | Remove vertical space | × | ○: RemoveVerticalSpace property
 | Add HTML just before page output | ○: ExportPageStart event | ×
 | Add HTML just after page output | ○: ExportPageEnd event | ×
State of progress |  | ○: OnProgress event | ×

※1　Either of these properties can be set - None, <DL>tag format, DHTML format, or XML format.

※2　Either of these properties can be set - None, HTML.

Show Text export

Subject | ActiveX product | .NET product
Encoding | △: Unicode property (※1) | ○: Encoding property
Obtaining state of progress | ○: OnProgress event | ×

※1　Unicode format and ASCII format configurable only from either of them.

Show RTF export

Subject | ActiveX product | .NET product
Obtaining state of progress | ○: OnProgress event | ×

Difference in Barcode Control

The barcodes and their properties available in .NET product are different from that available in ActiveX product. While in ActiveX product, the barcode is rendered as an ActiveX control, in the .NET product, the Barcode is available as a control. For full list of barcodes available in ActiveReports, see Barcode topic.

Barcode formats

ActiveX product | .NET product | Remarks
CODE39 | Code39, Ansi39 | ※1
CODE39(Full ASCII) | Code39x, Ansi39x |
CODE49 | Code49 |
CODE93 | Code_93 | Only Uppercase of letters,%, $, *, ., +, -, Space, number can be set.
 | Code93x | whole letter of ASCII letter set can be set
CODE128 | Code_128auto | ※2
 | Code_128_A | CODE-A fixed format
 | Code_128_B | CODE-B fixed format
 | Code_128_C | CODE-C fixed format
JAN8 | EAN_8 |
JAN13 | EAN_13 |
EAN128 | UCCEAN128 | ※2, 3, 4
 | EAN128FNC1 | ※2, 3, 4
ITF | Code25intlv | ※5, 6
POSTNET5, 9, 11 | PostNet | without depending on data number of digits, symbol can be generated
UPC/A | UPC_A |
UPC/E | UPC_E0, UPC_E1 | ※7
UPC/E Addon2, Addon5 | UPC_E0, UPC_E1 |
NW-7(CODABAR) | Codabar |
Customer Barcode | JapanesePostal |

※1　Code39 (Code39x) and Ansi39 (Ansi39x) have the same bar code configuration specifications, but the default width ratio of narrow bar and wide bar is different. The former is 1: 2, whereas the latter is 1: 3.

※2　Start character setting of CODE128 is different for ActiveX product and .NET product.

※3　In CODE128 format, there is no function to arbitrarily switch code sets.

※4　In CODE128 (EAN128) format, there is no function to insert FNC2 to FNC4 in arbitrary place.

※5　Check digit is not calculated automatically. For .NET products, you need to set a value with check digit added.

※6　Bearer bar is not supported.

※7　UPC_E0 is compressed zero type of UPC symbol and can only set only numbers. UPC_E1 is generally used in retail shops price labels and it supports six numeric characters.

Important ActiveX product properties that are not supported by .NET product

The properties that do not exist in .NET product but affect generated barcode are listed as follows:

Property name | Description
BarRatio | Set bar ratio. We can set relative width ratio of fine module to thick module in the range of 1:2 to 1:3 using NWRatio property.
LongModuleSize | Set thick module width.
TargetDpiX | Set the resolution of screen in the horizontal direction.
TargetDpiY | Set the resolution of screen in the vertical direction.

About ActiveReport Object

The ActiveReport object (the base of ActiveX product report), included not just the engine and the report layout information, but also the viewer function. The .NET product provides SectionReport class (the base class of section report) and the viewer function, and the Viewer class is reconfigured.
Also, In ActiveX product the generated page information was stored in the Pages class but in .NET product it has been reconfigured to the Document class and PagesCollection class. Along with these configuration updates, some methods and events have also been modified. The following table lists the important changes:

Difference in property

ActiveX product | .NET product |  | Remarks
 | Class | Property name |
AllowSplitters | Viewer | AllowSplitter |
documentName | SectionDocument | Name |
PageBorder | × | × | ※1
Pages | SectionDocument | Pages | ※2
Printer | SectionDocument | Printer |
RulerVisible | × | × | Ruler does not exist.
ShowMessages | × | × | ※3
ScriptDebuggerEnabled | SectionReport | EnableScriptDebugging |
Status | SectionReport | State |
TOC | SectionDocument | Bookmarks |
TOCEnabled | TOCPanel (Viewer.Sidebar) | Enabled |
TOCVisible | TOCPanel (Viewer.Sidebar) | Visible | ※4
TOCWidth | Sidebar(Viewer) | Width |
Toolbar | Viewer | Toolbar |
ToolbarVisible | ToolStrip (Viewer.Toolbar) | Visible |
Zoom | Viewer | Zoom |

※1 Draw border in CrossSectionBox control and other controls.

※2 In ActiveX product, it is the collection of Canvas objects but in .NET product, it is the collection of Document.Page.

※3 If an exception is thrown due to an error in the .NET product, use Try and Catch Statement.

※4 Use the ToggleVisibility method of the Viewer.Sidebar object to display headings.

Difference in method

ActiveX product | .NET product |  |
 | Class | Method name | Remarks
Export | (each export filter) | Export |
PageSetup | × | × | ※1
PrintReport | SectionDocument PageDocument Viewer | Print |
Refresh | × | × | ※2

※1 Implemented using PageSetupDialog Class.

※2 Reset the report document using Document property and LoadDocument method.

Difference in event

ActiveX product | .NET product |  |
 | Class | Event name | Remarks
Error | × | × | ※1
FindProgress | Viewer | Find |
HyperLink | Viewer | HyperLink |
PromptDialogClosed | SectionReport | ParameterUIClosed |
TOCClick | Viewer | TableOfContentsClick |
TOCSelChange | Viewer | TableOfContentsSelectedIndexChanged |
ToolbarClick | × | × | ※2

※1 If an exception is thrown due to an error in the .NET product, use Try and Catch Statement.

※2 Implement using Viewer.Toolbar.ToolStrip class. For more information please see Customize the Viewer Control.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Coexistence of ActiveReports Designers

Coexistence of ActiveReports Designers
ActiveReports 13 > ActiveReports User Guide > Upgrading Reports > Coexistence of ActiveReports Designers

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports 13 can be installed and used on the same machine in which other older versions of ActiveReports for .NET have been installed.

Show Compatibility of ActiveReports designer with Visual Studio

ActiveReports designer of different versions can be used by integrating the designer with Visual Studio IDE (Integrated development environment). The following table shows the Visual Studio versions corresponding to the ActiveReports designer versions that are supported.

 | Visual Studio .NET 2002 | Visual Studio .NET 2003 | Visual Studio 2005 | Visual Studio 2008 | Visual Studio 2010 | Visual Studio 2012 | Visual Studio 2013 | Visual Studio 2015 | Visual Studio 2017
ActiveReports 1 | ○ | ○(*1) | × | × | × | × | × | × | ×
ActiveReports 2 | × | ○(*1) | ○(*1)(*2) | × | × | × | × | × | ×
ActiveReports 3 | × | ○ | ○ | × | × | × | × | × | ×
ActiveReports 6 | × | × | ○(*2) | ○(*3) | ○(*3) | × | × | × | ×
ActiveReports 7 | × | × | × | ○(*3) | ○(*3) | ○ | ○ | × | ×
ActiveReports 8 | × | × | × | ○ | ○(*4) | ○(*4) | ○(*4) | × | ×
ActiveReports 9 | × | × | × | × | ○ | ○ | ○ | ○ | ×
ActiveReports 10 | × | × | × | × | ○ | ○ | ○ | ○ | ×
ActiveReports 11 | × | × | × | × | ○(*4) | ○(*4) | ○(*4) | ○ | ○
ActiveReports 12 | × | × | × | × | × | ○ | ○ | ○ | ○(SP2+)
ActiveReports 13 | × | × | × | × | × | ○ | ○ | ○ | ○(SP2+)

You will need to switch the designer using the switcher tool:

*1: If you want ActiveReports 1 and ActiveReports 2 designers to coexist in Visual Studio 2003.

*2: If you want ActiveReports 2 and ActiveReports 6 designers to coexist in Visual Studio 2005. From ActiveReports 6 onwards, RPX file can be directly edited in higher versions with the help of the switch tool.

*3: If you want ActiveReports 6 and ActiveReports 7 designers to coexist in Visual Studio 2008 and Visual Studio 2010.

*4: If you want ActiveReports 8 and ActiveReports 11 designers to coexist in Visual Studio 2010, Visual Studio 2012, and Visual Studio 2013.

Note:

  • It is not possible to use different versions of ActiveReports for .NET within a single Visual Studio project.

  • Please do not work on Visual Studio when running the switcher tool.

Show Coexistence of ActiveReports designers of 12, 11, 10, 9 versions

To enable coexistence of ActiveReports 10 and 9 designers (Visual Studio 2010, 2012, 2013, 2015), switch designers using ActiveReports 12 Switcher Tool (ReportDesigner.Switcher.exe).

  1. Exit the Visual Studio IDE.
  2. Run ActiveReports 13 Designer Switcher Tool (ReportDesigner.Switcher.exe). It is located at ......\GrapeCity\ActiveReports 13\Tools.
  3. Select the version you want to enable and select OK.

Note:

  • It is not possible to use different versions of ActiveReports for .NET within a single Visual Studio project.

  • Please do not work on Visual Studio when running the switcher tool.

Show Common Execution (Distribution) Environment

In .NET Framework, there is an assembly recognition mechanism that identifies the name, version, and other information of executable files or assembly files created in Visual Studio on which they depend.

Due to this reason, applications created in different version can commonly be used in execution environment.

Please refer to "Distribution of Runtime file" and "Distribution of Application" for details on method to deploy components.

Please refer to "Migration of Execution (Distribution) Environment" for details on migration of application created on previous versions to an application created in 6.0J.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Importing Reports

Importing Reports
ActiveReports 13 > ActiveReports User Guide > Importing Reports

Glossary Item Box

This section explains about importing reports in ActiveReports using the ActiveReports Import Wizard.

Importing Crystal/MS Access Reports
This section describes about importing Crystal and MS Access reports in ActiveReports.
Importing Excel
This section describes about importing MS Excel reports in ActiveReports.
Importing RPX
This section describes how to import ActiveReports section reports to ActiveReports Page or RDL reports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Importing Crystal Reports/MS Access Reports

Importing Crystal Reports/MS Access Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Importing Reports > Importing Crystal Reports/MS Access Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can import a Crystal Reports report, a Microsoft Access report, an Excel file, or an ActiveReports section report in ActiveReports by running the ActiveReports Import Wizard.

To learn about importing Excel files, please see Importing Excel.

To learn about importing ActiveReports section reports, please see Importing RPX.

Show Importing Crystal reports/MS Access Reports in the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing GrapeCity.ActiveReports.Imports.Win.exe from C:\Program Files (x86)\GrapeCity\ActiveReports 13\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  3. Choose Microsoft Access (mdb) or Crystal Reports (rpt) as the input format and click Next.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  4. Click the ellipsis button to browse to the location that contains the files that you want to import. A list of files that you can import appears.
  5. Select the reports to import, click Open, and then click Next to analyze them.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  6. Use the ellipsis button to select a destination folder to store the converted reports. Also select an output format (Section Report, Page Report or RDL Report or Both) for each report in the Output Format column.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  7. Click Next to start the conversion.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

The import wizard converts reports to the closest possible ActiveReports format, but due to differences between products and versions, the extent to which your reports are converted depends on your specific report layout. You may have to partially redesign the report and add script or code to get the same output as Microsoft Access Reports or Crystal Reports.

When converting to Page Reports or RDL Reports, whether a report is imported as a Page Report or RDL Report, depends on the following factors:

  • If a report has a single detail section it is imported as a Page Report.
  • If a report has a CrossTab control and its layout is composed of multiple sections it is imported as an RDL Report.
Note: Sections in a report appear as BandedList.

Please refer to the additional information below, to understand the conversion process in detail.

Importing Crystal Reports

To import Crystal Reports in ActiveReports, you need to install Visual Studio and Crystal Reports for Visual Studio on your machine. The supported versions of Visual Studio and corresponding Crystal Reports are as follows:

Visual Studio | Editions | Crystal Reports | Assembly Version
2008 | Professional, Team System | Crystal Reports for Visual Studio 2008 | 10.5.3700.0
2010 | ... | SAP Crystal Reports, developer version for Microsoft Visual Studio | 13.x.x.x
2012 | ... | SAP Crystal Reports, developer version for Microsoft Visual Studio | 13.x.x.x
2013 | ... | SAP Crystal Reports, developer version for Microsoft Visual Studio | 13.x.x.x
2015 | ... | SAP Crystal Reports, developer version for Microsoft Visual Studio | 13.x.x.x

Crystal Report controls are converted in ActiveReports as follows:

Crystal Report | Section Report | Page Report/RDL Report | Note
Box | Shape | Container | The LineWidth property and rounded boxes are not imported. If the Box control extends to multiple sections, the box is imported as line controls.
CrossTab | SubReport | BandedList | CrossTab control is not imported as it is.
Line | Line | Line | The size of Dot and Dash (the LineStyle property) is not the same as the original report.
Subreport | SubReport | Subreport | Set the subreport in code after conversion.
TextObject | Label | Textbox | Only page number, total page, page n of m in Special Fields are imported.
FieldObject | TextBox | Textbox | Only page number, total page, page n of m in Special Fields are imported.
Picture | ... | Container | Picture object is not converted.

Importing Microsoft Access Reports

To import Microsoft® Access® reports in ActiveReports, you must have Access 97, 2000, 2002, 2003, 2007, 2010, or 2013 installed on your system.

Microsoft Access report controls are converted in ActiveReports as follows:

Microsoft Access Report | Section Report | Page Report/RDL Report | Note
Rectangle | Shape | Container | Controls placed inside the Rectangle control are also imported along with the parent control.
CheckBox | Label | Textbox | ...
Image | ... | Image | Image control is not converted while converting to a Section Report.
Label | Label | Textbox | ...
Textbox | TextBox | Textbox | ...
Line | Line | Line | ...
Page Break | PageBreak | Container | In Page Reports and RDL Reports, the PageBreakAtEnd property is automatically set to True on importing a Page Break control.
Subform/Subreport | SubReport | Subreport | ...

Limitations in Crystal Report/MS Access conversion

  • Any controls, functions, and text formats which are not supported by ActiveReports are not imported.
  • The shadow property of a control is not imported while converting a report.
  • The OLE object is not imported in ActiveReports as it is treated as PictureObject in the object structure of Crystal Reports.
  • In Microsoft Access reports, VBA code appears in as commented statements in script. You have to modify the code after importing.

See Also

Upgrading Reports
Toolbox
Section Report Toolbox
Importing Excel
Importing RPX

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Importing Excel

Importing Excel
ActiveReports 13 > ActiveReports User Guide > Importing Reports > Importing Excel

Glossary Item Box

Show All Show All
Hide All Hide All

The migration from Microsoft Excel file to ActiveReports can now be accomplished by using the ActiveReports Import Wizard. The ActiveReports Import Wizard is particularly useful when you want to convert multiple sheets of an Excel file to ActiveReports. It saves the time and effort of a developer to manually replicate the layout of each sheet of an Excel file in ActiveReports.

You can import a single sheet or multiple sheets of an Excel file to a Page or an RDL report with just a few clicks. A single Excel sheet is imported as a report file, and the report name is the name of the sheet. An Excel file with multiple sheets is by default imported as separate report files, and the report names are the name of the corresponding sheets in the Excel file. You can also set Merge all sheets into a single report file option in the ActiveReports Import Wizard to import multiple sheets of Excel file as different pages of the report.

  • Importing Excel files in the ActiveReports Import Wizard
  • Defining Table area in an Excel file
  • Naming Rules for defining a Table area in Excel
  • Conversion Rules for Table area in Excel
  • Supported Objects and Properties
  • Limitations
Note: The import formats that are not supported are .xls (Excel 97-2003) and .xlsm (Open XML with macro).

Show Importing Excel files in the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing GrapeCity.ActiveReports.Imports.Win.exe from C:\Program Files (x86)\GrapeCity\ActiveReports 13\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  3. Choose Microsoft Excel (xlsx) as the input format and click Next.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. Click the ellipsis button to browse to the location that contains the files that you want to import. A list of files that you can import appears.
  5. Select the sheets to import, click Open, and then click Next to analyze them.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  6. Use the ellipsis button to select a destination folder to store the converted reports. You can set the following options:
    • Report Type: Choose from Page report or RDL report formats to import the Excel file. Note that Page report does not support multiple data sources. You should select RDL report type if you want to add multiple data sources to the report.
    • Merge all sheets into single report file: Choose this option to import sheets of the Excel file as separate pages of a Page report. The report name is the name of the first sheet of the Excel file.
    • Import Excel formula as text: Choose this option to import Excel formula as text. If you keep the option unchecked, the Excel formula is imported as a calculated result.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  7. Click Next to start the conversion.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Defining Table area in an Excel file

Table area in Excel is the range of cells representing a Tabular data in the Excel.
If an Excel file has the table area that you want to import into ActiveReports as the Table data region, you must define the Table area first and then run the ActiveReports Import Wizard. Otherwise, defining the table area is not required.

  1. Open the Excel file and select the table area.
  2. Right-click to view the context menu.
  3. Select the Define Name option.
  4. In the New Name dialog box, define the table area and the rows based on Naming Rules. These naming rules must be followed for defining table areas in Excel.
  5. Click OK.

Naming Rules for defining a Table area in Excel

To obtain the required table sections in ActiveReports' Table data region, you need to define the table area and its rows in the Excel file. In general, the table area is defined as ARTable#.******, where:

  • # is used to define more than one table areas. It can be any character, except symbol or character restricted by Excel. For example, ARTable, ARTable_1, or ARTableAbc.
  • ****** is the name of the row (section): Detail, TableHeader, TableFooter, GroupHeader, or GroupFooter.
    In case of multiple rows (Table Header/Footer, Detail, Group Header/Footer), you need to set "#" for each row as well (for example, GroupHeader1, GroupHeader2, etc.)

Example 1: To define a single table area

Action | Naming Rule
Define whole table area | ARTable
Define each row | ARTable.Detail ARTable.TableHeader ARTable.TableFooter ARTable.GroupHeader1 ARTable.GroupFooter1

Example 2: To define a multiple table area

Action | Naming Rule
Define whole table area | ARTable1 ARTable2
Define each row | ARTable1.Detail ARTable1.TableHeader ARTable1.TableFooter ARTable2.Detail ARTable2.TableHeader ARTable2.TableFooter

Conversion Rules for Table area in Excel

The table area of Excel is imported as a Table data region in ActiveReports based on the following conversion rules.

  • If the defined table area of Excel has three or more rows, the file data is converted to Table Header, Detail, and Table Footer as:
    Excel Table | ActiveReports Table
    Top Row | Table Header
    Bottom Row | Table Footer
    Other Rows | Detail
Note: For the Table Detail row, values for properties such as Value, Location, Size, etc. are imported from the cells of the first row.
  • If the defined table area of Excel has two rows, the file data is converted as follows.
    Excel Table | ActiveReports Table
    First Row | Table Header
    Second Row | Detail
  • If the defined table area of Excel has only one row, the file data is converted as follows.
    Excel Table | ActiveReports Table
    First Row | Detail

Supported Objects and Properties

Excel | Page/RDL Report
Item | Property | Item | Property
Page Page setting Report -
Size | PaperSize
Orientation: Portrait | PaperOrientation: Portrait
Orientation: Landscape | PaperOrientation: Landscape
Margins (Top, Bottom, Left, Right) | Margins (Top, Bottom, Left, Right)
Cell Value

TextBox

 Value
Location | Location (Left, Top)
Size | Size (Width, Height)
Alignment -
Horizontal alignment: General | TextAlign: General
Horizontal alignment: Left (Indent) | TextAlign: Left
Horizontal alignment: Center | TextAlign: Center
Horizontal alignment: Right (Indent) | TextAlign: Right
Horizontal alignment: Justify | TextAlign: Justify
Horizontal alignment: Distributed (Indent) | TextJustify: DistributeAllLines
Vertical alignment: Top | VerticalAlign: Top
Vertical alignment: Center | VerticalAlign: Middle
Vertical alignment: Bottom | VerticalAlign: Bottom
Text control: Wrap text | WrapMode: WordWrap
Text control: Shrink to fit | ShrinkToFit: True
Text direction: Left-to-Right | Direction: LTR
Text direction: Right-to-Left | Direction: RTL
Font -
Name | FontFamily
Style: Regular | FontStyle: Normal
Style: Italic | FontStyle: Italic
Style: Bold | FontWeight: Bold
Style: Bold Italic | FontWeight: Bold
Size | FontSize
Color | Color
Underline: None | TextDecoration: None
Underline: Single | TextDecoration: Single
Border -
Line style (Top, Bottom, Left, Right): xlLineStyleNone | BorderStyle: None
Line style (Top, Bottom, Left, Right): xlContinuous | BorderStyle: Solid
Line style (Top, Bottom, Left, Right): xlDot | BorderStyle: Dotted
Line style (Top, Bottom, Left, Right): xlDash | BorderStyle: Dashed
Line style (Top, Bottom, Left, Right): xlDouble | BorderStyle: Double
Line color | BorderColor
Line weight: xlThin | BorderWidth: 1pt
Line weight: xlMedium | BorderWidth: 2pt
Line weight: xlThick | BorderWidth: 3pt
Fill -
Background color | BackgroundColor
Table area

Each cell in a table area is converted to TextBox report item.

Note: Whole table area is imported in ActiveReports even if table data is filtered.
Table

Location (Left, Top)
Size (Width, Height)
FixedSize (Width, Height)
Picture Picture object is converted to Image report item. Image

Value
Source: Embedded
Sizing: FitProportional
Location (Left, Top)
Size (Width, Height)

Limitations

  • An Excel file that contains merged cells and table areas that are partially out of bounds, is not imported.
    • Merged cell - If merged cell starts within the page bounds and ends outside of them, the cell is not imported.
    • ​Table area - ​If table area starts within the page bounds and ends outside of them, the table area is not imported.
  • ActiveReports Import Wizard does not support conversion of a password protected Excel file.
  • The layout of only the first page of an Excel, as shown in the Page Break Preview option, is imported.
  • Vertical texts can not be imported.
  • The following Excel items are not imported to ActiveReports.
    1. ​Page
      • Header/Footer
    2. Cell
      • Number format (all categories, like Number, Date, Currency, etc.)
      • Strikethrough
      • Border (diagonal)
      • Fill effect
      • Fill pattern
      • Comment
      • Hyperlink
      • Table styles
      • Conditional formatting
    3. Object
      • Table
      • Shape
      • Chart
      • Pivot Table
      • WordArt
      • ClipArt

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Importing RPX

Importing RPX
See Also
ActiveReports 13 > ActiveReports User Guide > Importing Reports > Importing RPX

Glossary Item Box

The ActiveReports Import Wizard helps you to convert existing ActiveReports Section report(s) (rpx) to Page and RDL reports.

Show Importing Section Report(s) (rpx) in the ActiveReports Import Wizard

  1. Run the ActiveReports Import Wizard. The wizard can be run from the start menu or by executing GrapeCity.ActiveReports.Imports.Win.exe from C:\Program Files (x86)\GrapeCity\ActiveReports 13\Tools location.
  2. In the ActiveReports Import Wizard that appears, click Next.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  3. Choose ActiveReports (rpx) as the input format and click Next.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  4. Click the ellipsis button to browse to the location that contains section report(s).
  5. Select the reports to import and then click Next to analyze them.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  6. Specify the import options.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    1. Use the ellipsis button to select a destination folder to store the converted reports.
    2. Select the output format of the reports.
      From the drop-down, select output format as Page, RDL, or Both. If 'Both' is selected, then the converted Page and RDL reports are added with postfixes _page and _rdl, respectively in the destination folder.
    3. Select whether to use Banded List for Page report.
      The option to select Use Banded List Mode is available if the output format of a report is Page report.
      • If you want all controls to be placed on one BandedList in the same way as in RDL report, you should use banded list mode. In this case, the Fixed size for Page report needs to be set manually.
      • If you want to convert a Section report that has only one section (that is detail), you should not use banded list mode. With 'Use Banded List Mode' not selected (default):
        • controls are not placed on BandedList
        • sections such as Report Header/Report Footer and Page Header/Page Footer are ignored
        • all converted controls are placed on one Page and treated as they have been on one section
  7. Click Next to start the conversion.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
Important: At conversion, any script from the script editor is ignored.

Section report controls are replaced with the RDL or Page report controls as follows.

Section Report Control | RDL/Page Report Control
Label | TextBox
TextBox | TextBox
CheckBox | CheckBox
RichTextBox | FormattedText
Shape | Shape
Picture | Image
Line | Line
Barcode | Barcode
SubReport | SubReport
Chart | Chart
ReportInfo | TextBox
CrossSectionLine | Line (in Page report when BandedList is not used)
CrossSectionBox | Container (in Page report when BandedList is not used)
PageBreak | Container in RDL report with 'Height=0in' and 'PageBreakAtEnd=True' Not supported in Page report

Conversion rules for Section report to Page report

  • The converted report inherits these properties of Section report - Paper Size, Orientation, and the Margins.
  • If controls are placed outside the paper size (red line appears), they are not converted.
  • If the sum of height of all sections (PageHeader, Detail, etc.) in a Section report is more than its paper height, controls above or below the paper height are ignored.

Conversion rules for Section report to RDL report

  • The entire Section report is converted to an RDL report as the BandedList control.
  • PageHeader and PageFooter sections are automatically created at conversion. You must not remove these sections even if no content is available for them.

Conversion Limitations (both Page and RDL)

  • The support of Chart, Subreport, and RichTextBox controls is limited to the basic functionality.
  • Unused database fields are not imported.
  • Calculated fields are converted into simple expressions.
  • PageTotal and PageCount summary functions are not supported.
  • Visual Basic functions are not supported. Expressions with function calls are imported as is.
  • Following properties of Section report, on conversion to Page/RDL report, are not supported.
    • Culture
    • DataMember
    • ExpressionErrorMessage
    • MaxPages
    • TrayHeight
    • TrayLargeIcon
    • UserData
    • Watermark (for RDL and Page (using banded list mode))
  • MaxLength property for RichTextBox control on conversion to Page/RDL report is not supported.

See Also

Importing Crystal Reports/MS Access Reports
Importing Excel

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Getting Started

Getting Started
See Also
ActiveReports 13 > ActiveReports User Guide > Getting Started

Glossary Item Box

Quickly begin using ActiveReports by reviewing some of the most commonly used features.

This section contains information about

Adding ActiveReports Controls
Learn how to add ActiveReports controls to the toolbox in Visual Studio.
Adding an ActiveReport to a Project
Learn how to add an ActiveReport to a Visual Studio project. Also in this section, learn about the different types of reports and how to add code or script to each.
Adding a Data Source to a Report
Learn about the different ways that you can add data to each type of report, and where to find more information on each.
Adding an ActiveReports Application
Learn how to add an ActiveReports application to the Visual Studio project and avoid additional implementation rendering the report in the Viewer.

See Also

Concepts
Welcome to ActiveReports 13

How To
How To

Walkthroughs
Samples and Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Adding ActiveReports Controls

Adding ActiveReports Controls
See Also
ActiveReports 13 > ActiveReports User Guide > Getting Started > Adding ActiveReports Controls

Glossary Item Box

You can add an ActiveReport to a project without using the Visual Studio toolbox, but in order to use the Viewer control, any of the exports, the Designer and related controls, or the WebViewer control, you need to have them in your toolbox.

The installer generally adds the controls to the Visual Studio toolbox in an ActiveReports 13 tab. However, if they are removed for any reason, you can re-add them at any time.

To add the controls

  1. Right-click the Visual Studio toolbox tab where you want to add ActiveReports controls and select Choose Items.
  2. In the Choose Toolbox Items window that appears, on the .NET Framework Components tab, in the Filter textbox, enter GrapeCity.ActiveReports.
  3. Select the check boxes next to any of the controls that you want to add to your toolbox:
    • Designer
    • GroupEditor
    • LayerList
    • ReportExplorer
    • ReportsLibrary
    • Toolbox
    • Viewer
    • WebViewer
    • HtmlExport
    • PdfExport
    • RtfExport
    • TextExport
    • TiffExport
    • XlsExport
  4. Click OK to add the controls to the selected toolbox tab.
Caution: ActiveReports controls may not appear in the toolbox unless your project is using .NET 4.5.2 or later.

See Also

Adding an ActiveReport to a Project
Windows Forms Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Adding an ActiveReport to a Project

Adding an ActiveReport to a Project
See Also
ActiveReports 13 > ActiveReports User Guide > Getting Started > Adding an ActiveReport to a Project

Glossary Item Box

To use ActiveReports in a Visual Studio project, you add one of the included report templates.

Show All Show All
Hide All Hide All

To add an ActiveReport to a project

  1. From the Visual Studio Project menu (or Website menu in Web projects), select Add New Item.
  2. Select the type of report that you want to add (for information on the differences, see Report Types):
    • Section Report (code-based)
    • Section Report (xml-based)
    • Page Report
    • RDL Report

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink

  3. In the Name box, type a name for the report, and click Add. The selected report type is added to your project and opens in the report designer.
Note: When you add a report layout the Viewer assembly (GrapeCity.ActiveReports.Viewer.Win.dll) is not added automatically to the project references. You may need to manually add it in your project if required.

To add an ActiveReport to a project at run time

  1. In Visual Studio, create a new Windows Forms Application or open an existing one.
  2. From the Visual Studio toolbox, drag the Viewer control onto your Windows Form.
  3. Set the Viewer's Dock property to Fill to show the complete Viewer control on the form.
  4. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  5. Add the following code inside the Form_Load event.

Show Page Report

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Create a new Page report instance
Dim pageReport As New GrapeCity.ActiveReports.PageReport()
Dim Page As New GrapeCity.ActiveReports.PageReportModel.Page()
Dim fixedPage As New GrapeCity.ActiveReports.PageReportModel.FixedPage()

' Add a textbox to your Page report
Dim textbox1 As New GrapeCity.ActiveReports.PageReportModel.TextBox()
textbox1.Name = "TextBox1"
textbox1.Height = "1cm"
textbox1.Width = "10cm"
textbox1.Left = "2cm"
textbox1.Top = "0.5cm"
textbox1.Value = "Sample Page Report"
Page.ReportItems.Add(textbox1)
fixedPage.Pages.Add(Page)
pageReport.Report.Body.ReportItems.Add(fixedPage)

' Create a Page document and load it in Viewer
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
viewer1.LoadDocument(pageDocument)
C# code. Paste INSIDE the Form Load event. Copy Code
// Create a new Page report instance
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.PageReportModel.Page Page = new GrapeCity.ActiveReports.PageReportModel.Page();
GrapeCity.ActiveReports.PageReportModel.FixedPage fixedPage = new GrapeCity.ActiveReports.PageReportModel.FixedPage();

// Add a textbox to your Page report
GrapeCity.ActiveReports.PageReportModel.TextBox textbox1 = new GrapeCity.ActiveReports.PageReportModel.TextBox();
textbox1.Name = "TextBox1";
textbox1.Height = "1cm";
textbox1.Width = "10cm";
textbox1.Left = "2cm";
textbox1.Top = "0.5cm";
textbox1.Value = "Sample Page Report";
Page.ReportItems.Add(textbox1);
fixedPage.Pages.Add(Page);
pageReport.Report.Body.ReportItems.Add(fixedPage);

// Create a Page document and load it in Viewer
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
viewer1.LoadDocument(pageDocument);

Show RDL Report

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Create a new RDL report instance
Dim rdlReport As New GrapeCity.ActiveReports.PageReport()

' Add a textbox to your RDL report
Dim textbox1 As New GrapeCity.ActiveReports.PageReportModel.TextBox()
textbox1.Name = "TextBox1"
textbox1.Height = "1cm"
textbox1.Width = "10cm"
textbox1.Left = "2cm"
textbox1.Top = "0.5cm"
textbox1.Value = "Sample RDL Report"
rdlReport.Report.Body.ReportItems.Add(textbox1)

' Create a Page document and load it in Viewer
Dim rdlDocument As New GrapeCity.ActiveReports.Document.PageDocument(rdlReport)
viewer1.LoadDocument(rdlDocument)
C# code. Paste INSIDE the Form Load event. Copy Code
// Create a new RDL report instance
GrapeCity.ActiveReports.PageReport rdlReport = new GrapeCity.ActiveReports.PageReport();

// Add a textbox to your RDL report
GrapeCity.ActiveReports.PageReportModel.TextBox textbox1 = new GrapeCity.ActiveReports.PageReportModel.TextBox();
textbox1.Name = "TextBox1";
textbox1.Height = "1cm";
textbox1.Width = "10cm";
textbox1.Left = "2cm";
textbox1.Top = "0.5cm";
textbox1.Value = "Sample RDL Report";
rdlReport.Report.Body.ReportItems.Add(textbox1);

// Create a Page document and load it in Viewer
GrapeCity.ActiveReports.Document.PageDocument rdlDocument = new GrapeCity.ActiveReports.Document.PageDocument(rdlReport);
viewer1.LoadDocument(rdlDocument);

Show Section Report

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Create a new Section report instance
Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()

' Create a Detail section
sectionReport.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Body")

' Add a textbox to your Section report
Dim textbox1 As New GrapeCity.ActiveReports.SectionReportModel.TextBox()
textbox1.Name = "TextBox1"
textbox1.Height = 1.5F
textbox1.Width = 10.0F
textbox1.Left = 0.5F
textbox1.Top = 0.5F
textbox1.Value = "Sample Section Report"
sectionReport.Sections(0).Controls.Add(textbox1)

' Load the Section report in the Viewer
sectionReport.Run()
viewer1.LoadDocument(sectionReport)
C# code. Paste INSIDE the Form Load event. Copy Code
// Create a new Section report instance
GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();

// Create a Detail section
sectionReport.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Body");

// Add a textbox to your Section report
GrapeCity.ActiveReports.SectionReportModel.TextBox textbox1 = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
textbox1.Name = "TextBox1";
textbox1.Height = 1.5F;
textbox1.Width = 10F;
textbox1.Left = 0.5F;
textbox1.Top = 0.5F;
textbox1.Value = "Sample Section Report";
sectionReport.Sections[0].Controls.Add(textbox1);

// Load the Section report in the Viewer
sectionReport.Run();
viewer1.LoadDocument(sectionReport);

See Also

Adding ActiveReports Controls

Concepts
ActiveReports Designer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Adding a Data Source to a Report

Adding a Data Source to a Report
See Also
ActiveReports 13 > ActiveReports User Guide > Getting Started > Adding a Data Source to a Report

Glossary Item Box

The first thing you probably want to do when you create a report is to add data. You can accomplish this in a variety of ways, depending on the type of report you are using.

Page Report/RDL Report Data

With page reports or RDL reports, you basically connect to a data source, and then add a dataset. You can also create a shared data source if you use the same one for many reports. For information on how to perform these tasks, see Work with Data in the How To section. For more information on each item in the associated dialogs, see Data Sources and Datasets in the Concepts section.

For more advanced ways to connect data, see the Walkthroughs section for step by step instructions on using Reports with Stored Procedures, or creating a Custom Data Provider.

Section Report Data

With section reports, you bind a report to any of a variety of data sources and select the data using a SQL query or XPath expression in the Data Source Dialog. You can also use code to create an unbound data source or to change the data source at run time. For more information on all of these methods of binding reports to data, see Work with Data in the Section Report How To section.

See Also

Grouping Data in Section Reports
Grouping Data (Page Layout)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Adding an ActiveReports Application

Adding an ActiveReports Application
See Also
ActiveReports 13 > ActiveReports User Guide > Getting Started > Adding an ActiveReports Application

Glossary Item Box

ActiveReports provides an in-built sample application that includes a report template along with the Viewer control. You learnt about creating a report and viewing it in the preceding topics. See Adding an ActiveReport to a Project and Viewing Reports for further details. With this Windows Forms application you only need to create a report layout and run the application to view the report, effectively skipping the manual process of adding a Viewer and template separately and creating an instance of the report.

To add an ActiveReports application to a project

  1. From the Visual Studio File menu, select New, then Project.
  2. In the New Project dialog that appears, under your desired language (VB.NET or C#), click the Reporting node.
  3. Select the type of report application that you want to add (for information on the differences, see Report Types):
    • ActiveReports 13 Page Report Application
    • ActiveReports 13 RDL Report Application
    • ActiveReports 13 Section Report Application (xml-based)
    • ActiveReports 13 Section Report Application (code-based)

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. In the Name field, enter a name for the report application, and click OK. The selected report type is added to your project.
  5. Go to the Visual Studio Solution Explorer and double-click Form1.cs or Form1.vb. Notice that the Viewer control already appears on the form.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    Note: If you run the application right after the new report project is created, a blank report appears on the Form.

See Also

Getting Started
Ading ActiveReports Controls

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Viewing Reports

Viewing Reports
ActiveReports 13 > ActiveReports User Guide > Viewing Reports

Glossary Item Box

ActiveReports provides a number of ways to view your report output. You have an option of previewing the report as you create it in a Visual Studio project at design time.

Previewing Reports at Design Time

ActiveReports makes it easy for you to preview your report while you are still creating it. Click the Preview tab at the bottom of the designer and see the output as it appears in a viewer. See Designer Tabs for further information.

With the in-built Viewers for Windows Forms and Web, you can view your report in any of these platforms as well in a separate viewer control.

The following topics introduce all the available report viewing options.

In this section

Windows Forms
This section explains how to view a report in the Windows Forms Viewer and demonstrates the Viewer's features, touch gestures and shortcut keys.
ASP.NET
This section introduces the Web Viewer where you can view your report output in various types of viewers and provides key features of each viewer type.
JS Viewer
This section describes the JS Viewer and how to configure a target ASP.NET backend application with the JS Viewer.
HTML5
Learn about the features available with the HTML5 Viewer.
ReportService Settings
This section describes ReportService settings used in Web Viewers.
WPF
This section describes the WPF Viewer toolbar, its additional features and how to view a report in the WPF viewer.
Medium Trust Support
Learn about the features and limitations available in Medium Trust Support environment.
Viewing Reports from Different Domains using CORS
Learn about accessing the reports from different domains using Cross-Origin Resource Sharing technology.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Windows Forms Viewer

Windows Forms Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > Windows Forms Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

Besides previewing your report at design time, you can also view the reports you design in the Viewer. This viewer contains a toolbar and a sidebar with Thumbnails, Search results, Document map and Parameters panes.

Show Viewer Toolbar

The following table lists the actions you can perform through the Viewer toolbar.

Toolbar Element | Name | Description
First page | Takes you to the first page of the report. This button is enabled when a page other than the first page is open.
Last page | Takes you to the last page of the report. This button is disabled on reaching the last page of the report.
Previous page | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
Next page | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
Backward | Takes you to the last viewed page. This button is enabled when you move to any page from the initial report page. Clicking this button for the first time also enables the Forward button.
Forward | Takes you to last viewed page before you clicked the Backward button. This button is enabled once you click the Backward button.
Back to parent report | Returns you to the parent report in a drillthrough report.
Default | Allows you to specify a default mouse pointer mode.
Pan mode | A hand symbol serves as the cursor that you can use to navigate.
Selection mode | Allows you to select contents on the report. Click the Copy icon (see image and description below) to copy the selected content to the clipboard.
Snapshot mode | Allows you to select content on the report that you can paste as an image into any application that accepts pasted images.
Toggle sidebar | Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
Print | Displays the Print dialog where you can specify the printing options.
Galley mode | Provides a viewer mode which removes automatic page breaks from a Report Definition Language (RDL) and displays data in a single scrollable page. This mode maintains page breaks you create in the report and removes only automatic page breaks.
Copy Copies text that you select in the Selection mode to the clipboard.
Note: In case the GrapeCity.ActiveReports.Export.Xml.dll and GrapeCity.ActiveReports.Export.Word.dll are not available in GAC, you might need to add references to these assembly files to enable the viewer's Copy button.
Find | Displays the Find dialog to find any text in the report.
Zoom out | Decreases the magnification of your report.
Current zoom | Displays the current zoom percentage which can also be edited.
Zoom in | Increases the magnification of your report.
Fit width | Fits the width of the page according to viewer dimensions.
Fit page | Fits the whole page within the current viewer dimensions.
Single page view | Shows one page at a time in the viewer.
Continuous view | Shows all preview pages one below the other.
Multipage view | Offers you an option to select how many pages to preview in the viewer at one time.
Refresh Refreshes the report.

Caution: Refresh button gets disabled when you load a section report in the Viewer control through any of the following:

  • Document Property
  • LoadDocument(SectionDocument) Method
  • LoadDocument(String) Method
Cancel | Cancels the report rendering.
Touch Mode Allows you to select touch mode for the Viewer.
Note: The Touch Mode button only appears on the toolbar while working on touch enabled devices.

Show Viewer Sidebar

The Viewer sidebar appears on the left of the Viewer control when you click the Toggle sidebar button in the toolbar. By default, this sidebar shows the Thumbnails and Search Results panes. The additional Document map and Parameters also appear in this sidebar. You can toggle between any of the viewer panes by clicking the buttons for each pane at the bottom of the sidebar.

Show Thumbnails pane

The Thumbnails pane appears by default in the sidebar when you click the Toggle sidebar button in the toolbar.

This pane is composed of a thumbnail view of all the pages in a report. Click any thumbnail to navigate directly to the selected report page. You can also modify the size of the thumbnail when you click (+) or (-) button to zoom in and zoom out.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Search results pane

The Search pane is the other default pane besides Thumbnails that appears in the sidebar when you click the Toggle sidebar button. This pane lets you enter a word or phrase from which to search within the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To search in a report:

  • Enter the word or phrase in the search field.
  • Under Use these additional criteria, you may optionally choose to search for the whole word or match the case of the search string while searching in the report.
  • Click the Search button to see the results appear in the Find results list.
  • Click an item in the list to jump to that item in the report and highlight it.

To start a new search or clear the current search results, click the Clear button under the Find results list.

Show Document map pane

The Documents map pane is enabled for reports where the Label property or the Document map label is set. This pane displays each value for the text box, group, or sub report that you label, and you can click them to navigate to the corresponding area of the report in the Viewer.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

If a report does not have the Label property or Document map label set, the Documents map pane does not appear in the sidebar.

Show Parameters pane

The Viewer allows you to view reports with parameters. In the toolbar, click the Toggle sidebar button to open the Viewer sidebar and if your report contains parameters, the Parameters pane shows up automatically.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
  1. In the Parameters pane, you are prompted to enter a value by which to filter the data to display.
  2. Enter a value or set of values and click View report, to filter the report data and display the report.

If a report does not have parameters, the Parameters pane does not appear in the sidebar.

Display Report Output in the Viewer

The following code examples demonstrate how you can display the report output in the Viewer.

  1. In a Visual Studio Windows Forms application, from the Visual Studio toolbox, drag the Viewer control onto your Windows Form.
  2. Set the viewer's Dock property to Fill to show the complete Viewer control on the Form.
  3. Double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  4. In the Form_Load event, add code like the following to run the report and display it in the viewer. Each of these code snippets presumes a report in the project of the type indicated with the default name. (If you have renamed your report, you need to rename it in the code as well)

    Show To write the code in Visual Basic.NET

    The following example demonstrates how you display a page report in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim file_name As String = "..\..\PageReport1.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
Viewer1.LoadDocument(pageDocument)

    The following example demonstrates how you display a RDL Report in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim file_name As String = "..\..\RdlReport1.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
Viewer1.LoadDocument(pageDocument)

    The following example demonstrates how you can display a section report (code-based) in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim sectionReport As New SectionReport1()
Viewer1.LoadDocument(sectionReport)

    The following example demonstrates how you can display a section report (xml-based) in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("..\..\SectionReport1.rpx")
sectionReport.LoadLayout(xtr)
xtr.Close()
Viewer1.LoadDocument(sectionReport)

    Show To write the code in C#

    The following example demonstrates how you display a page report in the Viewer control.

    C# code. Paste INSIDE the Form_Load event. Copy Code
    string file_name = @"..\..\PageReport1.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
viewer1.LoadDocument(pageDocument);

    The following example demonstrates how you display a RDL Report in the Viewer control.

    C# code. Paste INSIDE the Form_Load event. Copy Code
    string file_name = @"..\..\RdlReport1.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
viewer1.LoadDocument(pageDocument);

    The following example demonstrates how you can display a section report (code-based) in the Viewer control.

    C# code. Paste INSIDE the Form_Load event. Copy Code
    SectionReport1 sectionReport = new SectionReport1();
viewer1.LoadDocument(sectionReport);

    The following example demonstrates how you can display a section report (xml-based) in the Viewer control.

    C# code. Paste INSIDE the Form_Load event Copy Code
    GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(@"..\..\SectionReport1.rpx");
sectionReport.LoadLayout(xtr);
xtr.Close();
viewer1.LoadDocument(sectionReport);

Additional Features

Following is an introduction to the additional capabilities of the Viewer to guide you on using it effectively:

Show Split windows

  1. Run your viewer project.
  2. Click above the vertical scrollbar to grab the splitter control and drag downward.
  3. With the viewer split into two sections, you can easily compare report pages.

Show Advanced Printing Options

Viewer provides advanced printing options that allow you to control the report page layout and watermark settings through the Page Setup dialog. In this dialog, you can also preview the report as it would appear with each print setting. See Advanced Print Options for further details.

You can also set the PrintingSettings property of the Viewer to directly print without displaying a dialog or to switch from a ActiveReports print dialog to a .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) on clicking the Print button on the Viewer toolbar. You can set the PrintingSettings property of the Viewer control from the Properties window.

PrintingSettings property provides the following options:

PrintingSettings Options | Description
ShowPrintDialog | Displays a dialog in which the user can set the printer options before printing.
ShowPrintProgressDialog | Displays a print progress dialog, in which the user can cancel the printing job.
UsePrintingThread | Specifies whether printing should be performed for individual threads or not.
UseStandardDialog | Specifies whether to use the .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) while printing the document (section or page).

Show Exporting

Use the Export Filters to export a page or a section report to different formats directly from the Viewer. After you load the document in the Viewer, you can use a sample code like the following which shows one overload of the Export method with a PDF export filter. This code creates an outputPDF.pdf file in the bin\debug folder of your project.

Show To write the code in Visual Basic.NET

Visual Basic. NET code. Paste INSIDE an event like Button_Click event. Copy Code
Dim PDFEx As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
Viewer1.Export(PDFEx, New FileInfo(Application.StartupPath + "\outputPDF.pdf"))

Show To write the code in C#

C# code. Paste INSIDE an event like Button_Click event. Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport PDFEx = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
viewer1.Export(PDFEx, new System.IO.FileInfo (Application.StartupPath + "\\outputPDF.pdf" ));
Note: Make sure that you add a reference to the required export assembly in your project before setting the export filter in code. See Export Filters further details.

Show Annotations Toolbar

You can use annotations when working with a report in the Viewer and add notes, special instructions or images directly to the reports.

Annotations are added via the Viewer's toolbar, which is hidden by default. You can make the Annotations toolbar available by setting the AnnotationDropDownVisible property to true in the viewer's properties grid.

Annotation Name | Description
AnnotationText | A rectangular box in which you can enter text.
AnnotationCircle | A circle without text. You can change the shape to an oval.
AnnotationRectangle | A rectangular box without text.
AnnotationArrow | A 2D arrow in which you can enter text. You can change the arrow direction.
AnnotationBalloon | A balloon caption in which you can enter text. You can point the balloon's tail in any direction.
AnnotationLine | A line with text above or below it. You can add arrow caps to one or both ends and select different dash styles.
AnnotationImage | A rectangle with a background image and text. You can select an image and its position, and place text on the image.

Show Keyboard Shortcuts

The following shortcuts are available on the Viewer:

Keyboard Shortcut | Action
Ctrl + F | Shows the find dialog.
Ctrl + P | Shows the print dialog.
Esc | Closes the find or print dialogs.
Page Down | Moves to the next page.
Page Up | Moves to the previous page.
Ctrl + T | Shows or hides the table of contents.
Ctrl + Home | Moves to the first page.
Ctrl + End | Moves to the last page.
Ctrl + Right | Navigates forward.
Ctrl + Left | Navigates backward.
Ctrl + - | Zooms out.
Ctrl + + | Zooms in.
Left, Right, Up, Down | Moves the visible area of the page in the corresponding direction.
Ctrl + 0 (zero) | Sets the zoom level to 100%.
Ctrl + rotate mouse wheel | Changes the zoom level up or down.
Ctrl + M | Turns on the continuous view.
Ctrl + S | Turns off the continuous view.
Ctrl + I | Shows multiple pages.
Ctrl + G | Focuses on PageNumber area and selects content.
F5 | Refreshes the report.
Home | Moves to the start of the current page.
End | Moves to the end of the current page.

Show Viewer's Thumbnails pane shortcut keys

You can use the following shortcut keys while using the thumbnails pane in the Viewer.

Keyboard Shortcut | Action
Up Arrow | Goes to the previous page.
Down Arrow | Goes to the next page.
Right Arrow | Goes to right page. If no thumbnail exist on the right, it goes to the next page.
Left Arrow | Goes to left page. If no thumbnail exist on the left, it goes to the previous page.
Page Down | Scroll to the next thumbnail's view port. It also keep the current selected page unchanged.
Page Up | Scroll to the previous thumbnail's view port. It also keep the current selected page unchanged.
Home | Goes to the first page.
End | Goes to last page.

Touch Support

ActiveReports introduces touch support for Windows Viewer. This feature gives you the flexibility to interact with the Viewer using simple touch gestures. Now you can install ActiveReports on any touch enabled Windows device and view the reports anywhere you are.

You can switch to the touch mode by just clicking the Touch mode button on the Viewer toolbar.

Note: In touch mode, you can still use the mouse to perform ActiveReports operations.

Show Touch mode Toolbar

The following table lists the actions you can perform through the Viewer toolbar.

Icon | Function | Details
Sidebar | Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
Print | Displays the Print dialog where you can specify the printing options.
Galley mode

Provides a viewer mode which removes automatic page breaks from a Report Definition Language (RDL) and displays data in a single page. This mode maintains page breaks you create in the report and removes only automatic page breaks.

For RDL report only.
Copy Copies text that you select in the Selection mode to the clipboard.
Note: In case the GrapeCity.ActiveReports.Export.Xml.dll and GrapeCity.ActiveReports.Export.Word.dll are not available in GAC, you might need to add references to these assembly files to enable the viewer's Copy button.
Find | Displays the Find dialog to find any text in the report.
Current zoom | Displays the current zoom percentage which can also be edited.
Single page view | Shows one page at a time in the viewer.
Continuous page | Shows all preview pages one below the other.
Multiple page | Offers you an option to select how many pages to preview in the viewer at one time.
Previous page | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
Next page | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
Back to parent report | Returns you to the parent report in a drillthrough report.
Refresh Refreshes the Viewer.

Caution: Refresh button gets disabled when you load a section report in the Viewer control through any of the following:

  • Document Property
  • LoadDocument(SectionDocument) Method
  • LoadDocument(String) Method
Cancel | Cancels the report rendering.
Touch mode | Allows you to select touch mode for the Viewer.

Show Context menu

To display the context menu, you must tap and hold in the preview area.

Icon | Function | Gesture | Details
 | Pan mode | Tap | Hand cursor used to move the visible portion of the reports. Drag the hand tool in the direction you want to move the report.
 | Selection mode | Tap | Allows you to select contents on the report. Click the Copy icon (see image and description above) to copy the selected content to the clipboard.
 | Snapshot mode | Tap | Allows you to select content on the report that you can paste as an image into any application that accepts pasted images.

Show Preview

Gesture | Gesture (Image) | Preview Area Element | Details
Flick | Single Page View | Flick in the vertical or horizontal direction moves to the next or previous page. A single flick moves single page.
Continuous Page View | Performs the page scrolling.
Tap | Link | Opens links (URL, drill-though links, etc).
Pan | Slider | Moves the slider.
Border between Sidebar and Preview Area Moves the border.
Note: The pan gesture does not work in the report area where ScrollbarEnabled property is set to False.
Selection mode, Snapshot mode | Pan from selection start point to selection end point.
Pinch

Preview Area

 Pinch to zoom out.
Stretch

Preview Area

 Stretch to zoom in.
Double tap

Preview Area

 Tap twice to change the view mode (from the Single page view to the Multiple page mode).
Tap and hold | Selection mode, Snapshot mode | Displays the context menu where you can select the pan, selection, or snapshot mode.

See Also

Parameters
Add and Save Annotations

How To
Advanced Print Options

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Customize the Viewer ToolStrip

Customize the Viewer ToolStrip
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > Windows Forms > Customize the Viewer ToolStrip

Glossary Item Box

There are a number of ways in which you can customize the Viewer control to make it a perfect fit for your Windows application. You can add and remove buttons from the toolbars, add and remove menu items, create custom dialogs, and call them from custom click events.

You can use the methods listed in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN to customize each ToolStrip.

ToolStrip

TheToolStrip contains the following ToolStripItems by index number.

  • 0 Toggle sidebar
  • 1 Separator
  • 2 Print
  • 3 Galley mode
  • 4 Separator
  • 5 Copy
  • 6 Find
  • 7 Separator
  • 8 Zoom out
  • 9 Zoom In
  • 10 Current Zoom
  • 11 Separator
  • 12 Fit width
  • 13 Fit page
  • 14 Separator
  • 15 Single page
  • 16 Continuous mode
  • 17 Multipage mode
  • 18 Separator
  • 19 First page
  • 20 Previous page
  • 21 Current
  • 22 Next page
  • 23 Last page
  • 24 Separator
  • 25 History back
  • 26 History forward
  • 27 Separator
  • 28 Back to parent
  • 29 Separator
  • 30 Refresh
  • 31 Cancel button
  • 32 Separator
  • 33 Pan mode
  • 34 Copy select
  • 35 Snapshot
  • 36 Separator
  • 37 Annotations

You can access these ToolStripItems by index with the Insert and RemoveAt methods. Other methods, including Add and AddRange, are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

ToolStrip Implementation

When you add a new item to a ToolStrip, you need to add an ItemClicked event handler and an ItemClicked event for the ToolStrip with the new item. At run time, when a user clicks the new ToolStrip item, they raise the ItemClicked event of the ToolStrip containing the item

Add the event handler to the Load event of the Form that contains the Viewer control, and use the IntelliSense Generate Method Stub feature to create the related event. For examples of the code to create an event hander, see the Customize the Viewer Control topic, and the Custom Preview sample that is located in ...\Documents\GrapeCity Samples\ActiveReports 13\Web\CustomPreview.

See Also

How To
Customize the Viewer Control

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Customize the Viewer Control

Customize the Viewer Control
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > Windows Forms > Customize the Viewer Control

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports includes a Viewer control for Windows Forms that lets you show report output in a custom preview form. You can modify both viewer's mouse mode and touch mode toolbars and set custom commands. For example, in the following sample codes we show customization specific to mouse mode toolbar and touch mode toolbar.

Show To create a basic preview form

  1. In Visual Studio, create a new Windows Forms project.
  2. From the Visual Studio toolbox on the ActiveReports 13 tab, drag the Viewer control onto the form. If you do not have the Viewer in your toolbox, see Adding ActiveReports Controls.
  3. With the viewer control selected, in the Properties window, set the Dock property to Fill.
  4. From the Project menu, select Add New Item.
  5. Select ActiveReports 13 Section Report (code-based) and click the Add button.
  6. Double-click in the title bar of the form to create a Form Load event.
  7. Add the following code to run the report and display the resulting document in the viewer.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim rpt as new SectionReport1
Viewer1.LoadDocument(rpt)

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    SectionReport1 rpt = new SectionReport1();
viewer1.LoadDocument(rpt);
  8. Press F5 to run the project.

Show Customize the Mouse Mode Toolbar

  1. Add a second Windows Form to the project created above and name it frmPrintDlg.
  2. Add a label to frmPrintDlg and change the Text property to This is the custom print dialog.
  3. Add a button to frmPrintDlg and change the Text property to OK.
  4. Back on the viewer form, double-click the title bar of the form to go to the Form Load event.
  5. Add the following code to the Form Load event to remove the default print button and add your own.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    'Remove the print button.
Viewer1.Toolbar.ToolStrip.Items.RemoveAt(2)
'Remove the extra separator.
Viewer1.Toolbar.ToolStrip.Items.RemoveAt(1)
'Add a new button to the end of the tool strip with the caption "Print."
Dim tsbPrint As New ToolStripButton("Print")
Viewer1.Toolbar.ToolStrip.Items.Add(tsbPrint)
'Create a click event handler for the button.
AddHandler tsbPrint.Click, AddressOf tsbPrint_Click

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    //Remove the print button.
viewer1.Toolbar.ToolStrip.Items.RemoveAt(2);
//Remove the extra separator.
viewer1.Toolbar.ToolStrip.Items.RemoveAt(1);
//Add a new button to the end of the tool strip with the caption "Print."
ToolStripButton tsbPrint = new ToolStripButton("Print");
viewer1.Toolbar.ToolStrip.Items.Add(tsbPrint);
//Create a click event handler for the button.
tsbPrint.Click += new EventHandler(tsbPrint_Click);
  6. Add the following code to the Form class below the Load event to display frmPrintDlg when a user clicks the custom print button.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste BELOW the Form Load event. Copy Code
    'Call the custom dialog from the new button's click event.
Private Sub tsbPrint_Click(sender As Object, e As EventArgs)
    Me.CustomPrint()
End Sub

'Call the custom print dialog.
Private Sub CustomPrint()
    Dim _printForm As New frmPrintDlg()
    _printForm.ShowDialog(Me)
End Sub

    Show To write the code in C#

    C# code. Paste BELOW the Form Load event. Copy Code
    //Call the custom dialog from the new button's click event.
private void tsbPrint_Click(object sender, EventArgs e)
{
    this.CustomPrint();
}

//Call the custom print dialog.
private void CustomPrint()
{
    frmPrintDlg _printForm = new frmPrintDlg();
    _printForm.ShowDialog(this);
}
  7. Press F5 to run the project and click on the print button of main viewer to view custom print dialog.

Show Customize the Touch Mode Toolbar

  1. Double-click in the title bar of the Viewer form to create a Form Load event.
  2. Add the following code to add a custom Zoom out button.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim zoomOutButton = viewer1.TouchModeToolbar.ToolStrip.Items(8)
zoomOutButton.Visible = true

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    var zoomOutButton = viewer1.TouchModeToolbar.ToolStrip.Items[8];
zoomOutButton.Visible = true;

Caution: Any customization done in mouse mode does not apply to the touch mode and vice versa.

Although this topic and the sample both demonstrate using section reports, customized viewers support page reports and RDL reports as well. The only difference is in the way that you load reports. For more information, see Windows Forms Viewer.

See Also

Customize the Viewer ToolStrip

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Localize the Viewer Control

Localize the Viewer Control
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > Windows Forms > Localize the Viewer Control

Glossary Item Box

Show All Show All
Hide All Hide All

You can localize all of the strings and images that appear in the Windows Forms Viewer control in included resource files, and alter and run a batch file to localize the control.

To localize the viewer control

All of the localization files are located in C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization.

Show Specify the culture you want to use in the batch file.

  1. Start Notepad or another text editor as an Administrator.
  2. Open the WinViewer.bat file and change the Culture value to the culture you want to use.
  3. Ensure that the path in ProductPath is correct for your installation, but do not alter any of the other properties.
  4. Save and close the file.

Show Localize strings (and images) in the resource files.

  1. Launch your zip program as an Administrator and open the WinViewer.zip file.
  2. Extract all of the files to
    C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization.
    A WinViewer subfolder is created.
  3. In the new WinViewer folder, open each subfolder and change the strings in each of the *.resx files.
    Tip: Strings are located between <value> and </value> tags in the resource files.
  4. If you want to change the images, rename your localized images to the names of the ones in the Res\Resources subfolder and replace them with your localized images.

Show Run the batch file as an Administrator.

  1. From the Start menu, type cmd in the text box, and press CTRL + SHIFT + ENTER to open a command prompt as an Administrator.
  2. To change directories, type:
    cd C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization
    and press Enter.
  3. Type WinViewer.bat and press Enter to run the file. The NameCompleter.exe application runs, and creates the following.
    • A SatelliteAssembly folder inside the WinViewer folder.
    • A language subfolder with the name of the culture you set inside the SatelliteAssemby folder.
    • A localized GrapeCity.ActiveReports.Viewer.Win.resources.dll file inside the language subfolder.
  4. Copy the language subfolder and paste it into the Debug folder of your application.
    Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.Viewer.Win.resources.dll file to GrapeCity and get it signed with a strong name. Then you can drag the language subfolder with the signed dll file into C:\WINDOWS\ASSEMBLY.

Show Test your localized application on a machine that does not share the culture of the localized DLL.

  1. Add the following code in the form's constructor just before the InitializeComponent method is called.
  2. Replace the "ja" in the example code with the culture you specified in the WinViewer.bat file.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the form's constructor just before the InitializeComponent method. Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = New System.Globalization.CultureInfo("ja")

Show To write the code in C#

C# code. Paste INSIDE the form's constructor just before the InitializeComponent method. Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = new System.Globalization.CultureInfo("ja");

See Also

Customize the Viewer Control

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web Viewer (ASP.NET)

Web Viewer (ASP.NET)
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > Web Viewer (ASP.NET)

Glossary Item Box

Professional Edition

With the Professional Edition license, you can use the WebViewer control to quickly display reports in any of the three viewer types: HtmlViewer, RawHtml, or AcrobatReader.

Important:

  • Before using the WebViewer control, you must first Configure HTTPHandlers in IIS 7, IIS 8 and IIS 10.

In this section

Getting Started with the Web Viewer
Explore the ways that the WebViewer control can save you time.
Using the HTML Viewer
Learn about the features available with the HTML viewer, including parameters, table of contents, search, and the toolbar.
Using Javascript with the HTML Viewer
Learn about how you can use HTML Viewer using Javascript.

Standard Edition

With the Standard Edition license, you can export reports to use on the Web or use Web Services to distribute reports or data sources. For more information on Web exporting, please see the Custom Web Exporting (Std Edition) section.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Getting Started with the Web Viewer

Getting Started with the Web Viewer
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > ASP.NET > Getting Started with the Web Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

The WebViewer control that is licensed with the Professional Edition allows you to quickly display reports in Web applications.

Once you drop the control onto a Web Form, you can look in the Visual Studio Properties grid and select the ViewerType that you want to use.

The WebViewer control supports the following types:

  • HtmlViewer (default): Provides a scrollable view of a single page of the report at a time. Downloads only HTML and javascript to the client browser. Not recommended for printable output. See the Using the HTML Viewer topic for details.
  • RawHTML: Shows all pages in the report document as one continuous HTML page. Provides a static view of the entire report document, and generally printable output, although under some circumstances pagination is not preserved.
  • AcrobatReader: Returns output as a PDF document viewable in Acrobat Reader.
    Client requirements: Adobe Acrobat Reader

In a web viewer, an RDL report can be rendered in two modes - Paginated and Galley. Using galley mode, you can view the contents of the RDL report in a single and scrollable page. You can set Galley mode through UI of the web viewer or through code by setting RenderMode property to Galley.

To use the WebViewer control

  1. In a Visual Studio Web Application, add the WebViewer control to the Visual Studio toolbox. See Adding ActiveReports Controls for more information.
  2. While in Design view of an ASPX page, from the toolbox, drag the WebViewer control and drop it on the page.
  3. With the WebViewer control selected, in the Properties grid, select the ViewerType you want to use. The viewer displays any prerequisites for using the selected ViewerType.
  4. To bind a report to the WebViewer, do one of the following:
    • Set the ReportName property to the name of a report within your solution.
      Note: Alternatively, you can set the ReportName property programmatically to a new instance of an ActiveReport class. For example:
      VB code: WebViewer.ReportName="YourReport.rpx"
      C# code: WebViewer.ReportName="YourReport.rpx";
    • Set the Report property to a new instance of an ActiveReport class as shown in the examples below.

      Show To write the code in Visual Basic.NET (Page report/RDL report)

      VB code. Paste INSIDE the Page Load event Copy Code
      Dim rpt As New GrapeCity.ActiveReports.PageReport()
rpt.Load(New System.IO.FileInfo(Server.MapPath("")+"\invoice.rdlx"))
WebViewer1.Report = rpt

      Show To write the code in C# (Page report/RDL report)

      C# code. Paste INSIDE the Page Load event Copy Code
      GrapeCity.ActiveReports.PageReport rpt = new GrapeCity.ActiveReports.PageReport();
rpt.Load(new System.IO.FileInfo(Server.MapPath("")+"\\invoice.rdlx"));
WebViewer1.Report = rpt;

      Show To write the code in Visual Basic.NET (Section code-based report)

      VB code. Paste INSIDE the Page Load event Copy Code
      Dim rpt As New MyInvoiceReport()
WebViewer1.Report = rpt

      Show To write the code in C# (Section code-based report)

      C# code. Paste INSIDE the Page Load event Copy Code
      MyInvoiceReport rpt = new MyInvoiceReport();
WebViewer1.Report = rpt;

      Show To write the code in Visual Basic.NET (Section xml-based report)

      VB code. Paste INSIDE the Page Load event Copy Code
      Dim sr As New SectionReport()
sr.LoadLayout(Server.MapPath("") + "\Invoice.RPX")
WebViewer1.Report = sr

      Show To write the code in C# (Section xml-based report)

      C# code. Paste INSIDE the Page Load event Copy Code
      SectionReport sr = new SectionReport();
sr.LoadLayout(Server.MapPath("") + "\\Invoice.RPX);
WebViewer1.Report = sr;

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Using the HTML Viewer

Using the HTML Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > ASP.NET > Using the HTML Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

HtmlViewer is the default viewer type of the WebViewer control, and provides a scrollable view of the report one page at a time. It includes HTML representations of the toolbar as well as the sidebar that contains Parameters, Table of Contents and Search panes.

Show HTML Viewer Properties

These HtmlExportOptions properties on the WebViewer control apply only when you select the HTML ViewerType. If you change the ViewerType property to another value, these settings are ignored.

Property | Description
BookmarkStyle | Specify whether to use HTML bookmarks, or none.
CharacterSet | Select from 15 character sets to use for the report.
IncludePageMargins | Specify whether to keep page margins on reports in the generated HTML.
OutputType | Specify whether to use DHTML or HTML for the output.
RemoveVerticalSpace | Specify whether to keep white space, for example at the end of a page not filled with data before a page break.

The HtmlViewer downloads only HTML and javascript to the client browser.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show HTML Viewer Toolbar

The HTML viewer toolbar offers various ways to navigate through reports.

Toolbar Element | Name | Description
 | Toggle Sidebar | Displays the sidebar that includes the Parameters, Table of Contents and Search panes.
 | Galley mode | Provides a viewer mode which removes automatic page breaks from an RDL report and displays data in a single scrollable page. This mode maintains page breaks you create in the report.
 | Find | Displays the Search pane of the sidebar.
 | Go to page | Opens a specific page in the report. To view a specific page, type the page number and press ENTER.
 | Go to Previous/Next page | Navigates through a report page by page.
 | Go to First/Last page | Jumps to the first or last page of a report.
 | Back to parent report | Returns to the parent report in a drill-down page report or RDL report.

Show HTML Viewer Parameters

The HTML viewer allows you to view reports with parameters. The Parameters pane shows up automatically. To show or hide the Parameters pane in the sidebar, click the Toggle Sidebar button in the Toolbar.

In the Parameters pane, you are asked to enter a value by which to filter the data to display.

To filter the report data, enter a value or set of values and click View report.

If a report does not have parameters, the Parameters pane of the sidebar is disabled.

Show HTML Viewer Table of Contents

To display the Table of Contents pane, in the toolbar, click Toggle Sidebar. Then at the bottom of the sidebar, click the Table of Contents button.

Note that the Table of Contents pane is only enabled for reports with Bookmarks. The Table of Contents displays each value for the text box, group, or subreport that you bookmark, and you can click them to navigate to the corresponding section of the report in the Viewer.

Show HTML Viewer Search

The Search pane lets you enter a word or phrase for which to search within the report. Under Use these additional criteria, you may optionally select additional criteria. When you click Search, any results appear in the Find results list. Click an item in the list to jump to the item you selected and highlight it.

To start a new search, click Clear under the Find results list.

See Also

Interactive Features
Web Viewer (ASP.NET)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Using Javascript with the HTML Viewer

Using Javascript with the HTML Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > ASP.NET > Using Javascript with the HTML Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

To use JavaScript with the WebViewer, initialize the WebViewer's view model using the clientId returned from the WebViewer, and subscribe to its Loaded event. Once you initialize the view model, you can access its API methods and properties to modify the WebViewer. You can also use the same view model to access the API for the side bar search panel and the toolbar.

Show Loaded Event

The WebViewer raises the Loaded event to notify listeners that internal initialization is complete. The following code subscribes to the Loaded event of the viewer with the specified clientId.$(document).ready(function () {
  $('#' + clientId).bind('loaded', function(){
    ...
  });
});
Note: You can get the ClientId from the WebViewer control. By default, it's WebViewer1.

Show ViewerViewModel

To work with the API, first initialize the viewer's view model using the GetViewModel(clientId) function. The clientId is the WebViewer control's name, by default, WebViewer1. If there is no ViewerViewModel with the requested clientId, an exception occurs.

Use code like the following to initialize the ViewerViewModel:

var viewModel = GetViewModel(clientId);

Now you can access API methods and properties using the viewModel variable.

Methods/Properties | Example | Description
Sidebar | viewModel.Sidebar; | Gets the Sidebar view model.
Toolbar | viewModel.Toolbar; | Gets the Toolbar view model.
PageLoaded | viewModel.PageLoaded; | Gets a Boolean value indicating whether the page is loaded.
Export viewModel.Export(exportType, callback, saveAsDialog, settings);viewModel.Export(ExportType.Pdf, callback, true, {FileName:"report.pdf"});

Exports the loaded page to the specified format. In order to export without any errors, the PageLoaded() property must be True.

  • exportType: Requested output format.
  • callback: Function which obtains the URI of the exported document.
  • saveAsDialog: Optional request to show save as dialog after export.
  • settings: Optional export settings. Here you can specify the exported file name. Note that the FileName keyword is case sensitive.
Note: ExportType is an Enumeration.
var ExportType = { Pdf, Html, Word, Xls, Xml };
Print | viewModel.Print(); | Prints the report using pdf printing. In order to print without any errors the PageLoaded() property must be True.
RenderMode viewModel.RenderMode = "Galley";

Provides viewer mode:

  • Paginated: displays a report in which data is displayed in discrete pages
  • Galley: displays an RDL report by removing automatic page breaks from a report and displaying data in a single scrollable page. This mode maintains page breaks you create in the report.

Show SidebarViewModel

The SidebarViewModel allows you to use its properties and methods to get the current state and show or hide the sidebar and panels within the sidebar.

Use code like the following to get the SidebarViewModel from the ViewerViewModel:

var sideBarModel = viewModel.Sidebar;

Now you can access API methods and properties using the sideBarModel variable.

Methods/Properties | Example | Description
IsSidebarVisible | sideBarModel.IsSidebarVisible = false; | Gets or sets a Boolean value indicating whether the Sidebar is visible.
HideShowSidebar | sideBarModel.HideShowSidebar(); | Toggles the visibility of the Sidebar.
IsBookmarksPaneVisible | sideBarModel.IsBookmarksPaneVisible = false; | Gets or sets a Boolean value indicating whether the Bookmarks Pane is visible.
ShowBookmarksPane | sideBarModel.ShowBookmarksPane(); | Toggles the visibility of the Bookmarks Pane.
IsParametersPaneVisible | sideBarModel.IsParametersPaneVisible = false; | Gets or sets a Boolean value indicating whether the Parameters Pane is visible.
ShowParametersPane | sideBarModel.ShowParametersPane(); | Toggles the visibility of the Parameters Pane.
IsSearchPaneVisible | sideBarModel.IsSearchPaneVisible = false; | Gets or sets a Boolean value indicating whether the Search Pane is visible.
ShowSearchPane | sideBarModel.ShowSearchPane(); | Toggles the visibility of the Search Pane.
HideAll | sideBarModel.HideAll(); | Hides all Sidebar Panes.

See Also

Using the HTML Viewer

Walkthroughs
Customizing the HTML Viewer UI

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


JS Viewer

JS Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > JS Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

The JS Viewer is a Javascript component that you can easily customize and use in web applications to preview all types of reports - page, rdl, and section reports. The JS Viewer works on modern web application frameworks - ASP.NET MVC, ASP.NET Core MVC, HTML5, and major JavaScript Frameworks such as Angular and Vue.js.

A responsive visualization allows the JS Viewer to automatically adjust to the screen size, so you can use it on all desktop, mobile and touch devices and modern browsers.

Note: The Server side of the JS Viewer works on .NET Full Framework (IIS is required) but you can also use it in .NET Core project. However, the backend for .NET Core projects is not provided as ActiveReports13 targets .NET Full Framework only.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

JS Viewer UI

Show JS Viewer Top Toolbar

Toolbar Element | Name | Description
 | First Page | Navigates to the first page of the displayed report.
 | Previous Page | Navigates to the previous page of the displayed report.
 | Current Page | Displays the current page number and page total. Enter the page number to view a specific page.
 | Next Page | Navigates to the next page of the displayed report.
 | Last Page | Navigates to the last page of the displayed report.
 | Refresh | Refreshes the report.
 | Download | Downloads the report. Allows you to select from available export options - PDF document, Excel workbook, Word document, Word (docx) document, and Json object.
 | Print | Displays the Print dialog to specify printing options.
 | Display view | Galley - Provides a viewer mode which removes automatic page breaks from an RDL report and displays data in a single scrollable page. This mode maintains page breaks you create in the report. Single page - Shows one page at a time in the viewer. Continuous view - Shows all preview pages one below the other.
 | Zoom In | Increases the magnification of your report.
 | 100% | Displays the current zoom percentage which can also be edited. Allows you to select from the available zoom options - Zoom In, Zoom Out, 100%, Fit to Page, Fit to Width, and Stretch to Page.
 | Zoom Out | Decreases the magnification of your report.
 | Parameters | Displays the Parameters pane. If a report does not have parameters, the Parameters button is disabled.
 | Table of Contents | Displays the Table of Contents pane.

Show JS Viewer Table of Contents Pane

The Table of Contents pane appears when you click the Table of Contents button in the toolbar. Click any TOC item to navigate to the corresponding section of the report in the Viewer.

Note that the Table of Contents is only available for reports with Bookmarks. The Table of Contents displays each value for the text box, group, or subreport that you bookmark, and you can click them to navigate to the corresponding section of the report in the Viewer.

Show JS Viewer Parameters Pane

The Parameters pane appears when you click the Parameters button in the toolbar. In the Parameters pane, enter a value to filter the data to be displayed and click Preview.

If a report does not have parameters, the Parameters pane is disabled.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Using JS Viewer
Viewing Reports using JS Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Using JS Viewer

Using JS Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > JS Viewer > Using JS Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

Initialization Options

The following options can be set during initialization or at run time while working with the JS Viewer.

Show action

Description: The callback that is invoked before the JS Viewer opens the hyperlink, bookmark link, drill down report or toggles the report control visibility.

Type: function(actionType, actionParams)

Example:
action: (actionType, actionParams) => console.log('Action type: ' + actionType + '; Action parameters: ' + actionParams)

Show availableExports

Description: The array of export types available via Export functionality of JS Viewer. By default, PDF, Excel, Word, JSON, XML, CSV, and Image exports are available.

Type: Array

Example:
availableExports: ['Xml', 'Pdf']

Show displayMode

Description: Set up single page or continuous page.

Type: String

Accepted Value: 'single', 'continuous'

Example:
displayMode: 'Continuous'

Show documentLoaded

Description: The callback that is invoked when a document is loaded entirely on the server.

Type: function()

Example:
documentLoaded: () => console.log('The document is loaded entirely on the server')

Returns: Void

Show element

Description: JQuery selector that specifies the element that hosts the JS Viewer control.

Type: String

Example:

element: '#viewerContainer'

Show error

Description: The callback that is invoked when an error occurs in the process of displaying the report. The default error panel does not appear if the callback returns true. The error parameter is an object that has a message property which allows the users to customize the error message.

Type: function(error)

Example: To hide the default error panel
error: (error) => {
    if (error.message) {
        // show error message.
        alert("Internal error! Please ask administrator.");
        // do not show default error message.
    }
}

Show reportID

Description: The id of the report to be shown by the JS Viewer.

Type: String

Example:

reportID: 'AnnualReport.rdlx'

Show reportLoaded

Description: The callback that is invoked when the JS Viewer obtains the information about the requested report. The reportInfo object is passed in the callback including the TOC info, Parameters info and the link to the rendered report result.

Type: function(reportInfo)

Example:
reportLoaded: (reportInfo) => console.log('The report ' + reportInfo.name + ' was successfully loaded!')

Show reportParameters

Description: The array of the {name, value} pairs that describe the parameters values used to run the report.

Type: Array

Example:

reportParameters: [{ name: 'ReportParameter1', values: ['1']}]

Show reportService

Description: Set up the settings to connect the Web API.

Type: Object that has the url and optional securityToken properties.

Example:
reportService: {
    url: 'http://example.com/api/reporting',
    securityToken: '42A9CD80A4F3445A9BB60A221D042FCC',
};

Public API Methods and Properties

Methods

Show backtoParent

Description: Makes the viewer to display the parent report of the drill-down report.

Syntax: backToParent()Void

Example:
viewer.backToParent()

Return Value: Void

Show create

Description: Creates a new instance of the Viewer and renders it in the specified DOM element.

Syntax: create()Void

Parameters:

  • params
Example:
const viewer = GrapeCity.ActiveReports.JSViewer.create({
    element: '#root',
    reportID: 'AnnualReport.rdlx',
    availableExports: ['Xml', 'Pdf'],
    // other properties
});

Return Value: Void

Show destroy

Description: Removes the viewer content from the element.

Syntax: destroy()Void

Example:
viewer.destroy()

Return Value: Void

Show export

Description: Exports the currently displayed report.

Syntax: export(exportType,callback,saveAsDialog,settings)Void

Parameters:

  • exportType: Specifies export format.
  • settings: The export settings are available for RenderingExtensions.
  • Note: In section reports, the export settings are not enabled when exporting files using the rendering extensions. In Page report and RDL report, the export settings are not enabled when exporting files to PDF using the export filter.

Example:

viewer.export('Pdf', downloadReport, true, { Title: '1997 Annual Report' })

Return Value: Void

Show getTOC

Description: Obtains the report TOC.

Syntax: viewer.getToc()

Example:

console.log(viewer.getToc())

Return Value: any

Show goToPage

Description: Makes the viewer to display the specific page.

Syntax: goToPage(number, offset, callback)Void

Parameters:

  • number: The number of pages to go to.
Example:
viewer.goToPage(1)

Return Value: Void

Show openReport

Description: Opens a report.

Syntax: openReport(reportID: string, reportParameters?: Array<Parameter>): void

Parameters:

  • reportID: The id of the report.
Example:
viewer.openReport('Invoice.rdlx')

Return Value: Void

Show Print

Description: Prints the currently displayed report if any.

Syntax: print()Void

Example:
viewer.print()

Return Value: Void

Show Refresh

Description: Refreshes the report preview.

Syntax: option(name,[value])Object

Example:
viewer.refresh()

Return Value: Void

Show Version

Description: A string that represents the current version of the JS Viewer.

Syntax: viewer.version

Example:
console.log(viewer.version)

Return Value: string

Properties

Show currentPage

Description: Gets the currently displayed page number.

Syntax: viewer.currentPage

Example:
console.log(viewer.currentPage())

Return Value: An integer representing currently displayed page number.

Show pageCount

Description: Gets the page count of the currently displayed report.

Syntax: viewer.pageCount

Example:
console.log(viewer.pageCount())

Return Value: An integer representing page count.

See Also

JS Viewer
Viewing Reports using JS Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Viewing Reports using JS Viewer

Viewing Reports using JS Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > JS Viewer > Viewing Reports using JS Viewer

Glossary Item Box

JS Viewer communicates with the reporting service through the Web API. To implement the Web API, the GrapeCity.ActiveReports.Aspnet.Viewer.dll (.NET Framework) assembly is used.

The following steps describe how to configure a target ASP.NET backend application.

  1. JS Viewer Web API Server

  2. Open Microsoft Visual Studio 2017 and create a new ASP .NET Web Application project.
  3. Select Empty project template and click OK
  4. In the Menu bar, go to Tools > NuGet Package Manager > Package Manager Console.
  5. In the Package Manager Console window, write the following command:
    install-package Microsoft.Owin.Host.SystemWeb –Pre
    Note that following Owin packages are installed:
    • Microsoft.Owin.Host.SystemWeb 4.0.0
    • Microsoft.Owin 4.0.0
  6. Now to add Owin startup class, go to Solution Explorer, right-click the project and select Add > New Item.
  7. In the Add New Item dialog, select OWIN Startup Class.

  8. In Solution Explorer, right-click References and select Add Reference.
    .
  9. In the Reference Manager dialog that appears, click Browse and navigate to ActiveReports 13 folder containing assemblies. By default it is C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 13 on 64-bit Windows.
  10. Select GrapeCity.ActiveReports.Aspnet.Viewer.dll assembly and click Add. In the Reference Manager dialog, click OK to confirm the added assembly.
  11. Go to C:\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\JSViewer folder on 64-bit Windows.
  12. Copy the Web.config file and paste it in your project to replace the existing one.
    Note: Remove the <handlers> directive from the Web.config file if the application does not serve its own static files. Keep this handler only if the application serves its own static files similar to the HomeController class in the JS Viewer samples provided with ActiveReports .
  13. Add and configure a reporting middleware, for example:
    Startup.cs Copy Code
    // Startup.cs
using GrapeCity.ActiveReports.Aspnet.Viewer;
public void Configuration(IAppBuilder app)
{
    <...>
    app.UseReporting(settings =>
    {
        // Reporting middleware settings
        settings.UseFileStore(new DirectoryInfo("path to the reports folder"));
    });
}

    Note: Don't forget to configure CORS if you're using a separate backend application.

    JS Viewer Client Application

    The following steps describe how to view reports in the JS Viewer. The steps include adding and initializing the JSViewer on a static HTML page.

  14. In Solution Explorer, right-click project and select Add > New Item.
  15. Select HTML Page item type, input index.html and click Add.
  16. Create 'scripts' folder in your sample project root.
  17. Go to C:\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\JSViewer folder.
  18. Copy jsViewer.min.js and jsViewer.min.css files and paste them in the 'scripts' folder.
  19. In Solution Explorer, find newly-added index.html and modify its content as follows:
    Paste inside the <head></head> tags Copy Code
    <!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8" />
    <title></title>
<!--Add the references to these files to the target HTML page-->
    <link rel="stylesheet" href="https://cdn.materialdesignicons.com/2.4.85/css/materialdesignicons.min.css">
    <link rel="stylesheet" href="https://fonts.cat.net/css?family=Open+Sans:400,300,600,700" type="text/css">
    <link rel="stylesheet" href="scripts/jsViewer.min.css" type="text/css">
    <script src="scripts/jsViewer.min.js"></script>
</head>
<body>
<!--Add the DIV element that will contain the JSViewer in the target HTML page-->
    <div class=theme-default id="viewerContainer">Loading Report</div>
</body>
</html>
<!--Add the code that initializes and passes the parameters in the JSViewer instance. The code might vary depending on the technology used to develop the JSViewer component. The example of code for the pure javascript component:-->
<script type="text/javascript">
    var viewer = GrapeCity.ActiveReports.JSViewer.create({
        element: '#viewerContainer',
        reportID: 'ReportName.rdlx', // the id of the report to display
        availableExports: ['Xml', 'Pdf', 'Excel'],
        reportService: {}
        // other properties
    });
</script>
  20. Press F5 to run the project. You see a report is deployed in the target web site in JS Viewer:

See Also

JS Viewer
Using JS Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


HTML5 Viewer

HTML5 Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > HTML5 Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

The HTML5 Viewer is a Javascript component that can be used in web applications to preview reports hosted on ActiveReports 13 Web Service. The HTML5 Viewer provides several UI types to target the wide range of supported devices. The application can switch between these options using the public API methods and properties.

Note: HTML5 Viewer is deprecated and will be obsolete in the future version.

HTML5 Viewer Mobile UI

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show HTML5 Viewer Mobile Top Toolbar

Toolbar Element | Name | Description
 | Table of Contents | Displays the Table of Contents pane.
 | Parameters | Displays the Parameters pane.
 | Search | Displays the Search pane.
 | Galley mode | Lets you switch between the paginated mode and galley mode which removes automatic page breaks from an RDL report and displays data in a single scrollable page. The galley mode maintains page breaks you create in the report.
 | Single page view | Shows one page at a time in the viewer.
 | Continuous page view | Shows all preview pages one below the other.
 | Save As | Displays the drop-down list of formats to export the report. The available options are PDF Document, Word Document, Image File, MHTML Web Archives, Excel Workbook, and CSV File. Tapping the menu item exports the report to the selected format.

Show HTML5 Viewer Mobile Bottom Toolbar

Toolbar Element | Name | Description
 | Previous Page | Navigates to the previous page of the displayed report.
 | Next Page | Navigates to the next page of the displayed report.
2/124 | Current Page | Displays the current page number and page total. Enter the page number to view a specific page.
 | Back to Parent | Returns to the parent report in a drill-through page report.
 | Partial Data. Run Full Report | Provides information that report is not fully rendered. It is partially rendered either due to page limit set by administrator or user has cancelled rendering using option. Click option again to run full report.
 | Cancel Report | Use this option to cancel loading full report. This option is displayed for large reports.

Show HTML5 Viewer Mobile Table of Contents Pane

The Table of Contents pane appears when you tap the TOC button on the toolbar. Tap any TOC item in the Table of Contents pane to navigate to the corresponding section of the report in the Viewer.

The Table of Contents pane has a Close (x) button that hides the pane and shows the report display area. If a report does not have a Table of Contents, the TOC button in the toolbar is disabled.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show HTML5 Viewer Mobile Parameters Pane

The Parameters pane appears automatically if your report contains parameters.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

In the Parameters pane, click the [image] button to open the Parameters Value editor where you can choose or enter values depending on the parameter type.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

After you select or enter the values, click the Back button to navigate to Parameters Pane. Click the View Report button to view the report according to the selected parameter values.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

If a report does not have parameters, the Parameters button in the toolbar is disabled. For more information, see Parameters.

Show HTML5 Viewer Mobile Search Pane

The Search pane appears when you tap the Search button in the toolbar.

This pane allows you to search for a specific text in the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To search in a report:

  • Enter the word or phrase in the search field.
  • Under the search field, you may choose to use the Match case and Whole phrase options while searching in the report.
  • Click the Search button to see the results appear below the Search button.
  • Click an item in the list to jump to that item in the report.

HTML5 Viewer Desktop UI

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show HTML5 Viewer Desktop Toolbar

Toolbar Element | Name | Description
 | Sidebar | Displays the sidebar with the Table of Contents and Parameters panes.
 | Search | Displays the Search pane.
 | First | Navigates to the first page of the displayed report.
 | Prev | Navigates to the previous page of the displayed report.
2/124 | Current page | Displays the current page number and page total. Enter the page number to view a specific page.
 | Next | Navigates to the next page of the displayed report.
 | Last | Navigates to the last page of the displayed report.
 | Back to Parent | Returns to the parent report in a drill-through page report.
 | Print | Displays the Print dialog to specify printing options.
 | Galley mode | Provides a viewer mode which removes automatic page breaks from an RDL report and displays data in a single scrollable page. This mode maintains page breaks you create in the report.
 | Single page view | Shows one page at a time in the viewer.
 | Continuous page view | Shows all preview pages one below the other.
 | Save As | Displays the drop-down list of formats to export the report. The available options are PDF Document, Word Document, Image File, MHTML Web Archives, Excel Workbook, and CSV File. Tapping the menu item exports the report to the selected format.
 | Partial Data. Run Full Report | Provides information that report is not fully rendered. It is partially rendered either due to page limit set by administrator or user has cancelled rendering using Cancel Report option. Click Partial Data. Run Full Report option again to run full report.
 | Cancel Report | Use this option to cancel loading full report. This option is displayed for large reports.

Show HTML5 Viewer Desktop Table of Contents Pane

The Table of Contents pane appears when you click the Sidebar button in the toolbar. Click any TOC item to navigate to the corresponding section of the report in the Viewer.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show HTML5 Viewer Desktop Parameters Pane

The Parameters pane appears when you click the Sidebar button in the toolbar and then click the Parameters tab. In the Parameters pane, enter a value to filter the data to be displayed.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click View Report button to view the report according to the selected parameter values.

Note: Internet Explorer and Mozilla Firefox browsers do not support the display of DatePicker control in the Parameters panel. However, DatePicker control is available in case of Google Chrome browser.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Caution: For a DateTime type parameter in HTML5 Viewer, the FormatString for the DatePicker is represented with (mm/dd/yyyy) while the TimePicker is represented with dashes (--:--:-- --).

For more information, see Parameters.

Show HTML5 Viewer Desktop Search Pane

The Search pane appears when you click the Search button on the toolbar. This pane allows you to search for a specific text in the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To search in a report:

  • Enter the word or phrase in the search field.
  • Under the search field, you may choose to use the Match case and Whole phrase options while searching the report.
  • Click the Search button to see the results appear below the Search button.
  • Click an item in the search results to jump to that item in the report.
Note: 'Partial Data. Run Full Report' button appears on loading Page/RDL Report when pages in report equal 'previewPages' set in HTML5 viewer.

HTML5 Viewer Custom UI

The custom UI option of the HTML5 Viewer provides the ability to create a customized viewer for targeted devices and to meet the specific application requirements.

You can customize the appearance of the HTML5 Viewer using the public API methods and properties, described in Working with HTML5 Viewer using Javascript.

Note: When using input tags in the HTML 5 viewer, please note that due to limitations in certain browsers, the datetime-local type may not appear correctly.

See Also

Using Javascript
Viewing Reports using HTML5 Viewer

Sample ReadMe Files
HTML5 Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Using Javascript

Using Javascript
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > HTML5 > Using Javascript

Glossary Item Box

Show All Show All
Hide All Hide All

Initialization Options

The following options can be set during initialization or at run time while working with the HTML5 Viewer.

Show uiType

Description: Sets the UI mode of the HTML5 Viewer.

Type: String

Accepted Value: 'Custom', 'Mobile' or 'Desktop'

Example:
viewer.option('uiType', 'Mobile');

Show element

Description: JQuery selector that specifies the element that hosts the HTML5 Viewer control.

Note: This option is used during initialization only.

Type: String

Example:
var viewer = GrapeCity.ActiveReports.Viewer(
{
   element: '#viewerContainer2',
   reportService: {
      url: '/ActiveReports.ReportService.asmx'
   },
});

Show reportService

Description: The report service that can use ActiveReports Web Report Service.

Type: Object that has the url and optional securityToken properties

Example:
reportService: {
   url: '/ActiveReports.ReportService.asmx'
};

Show reportService.url

Description: The ActiveReports Web service url that provides the reportInfo and output.

Type: String

Example:
reportService: {
   url: '/ActiveReports.ReportService.asmx'
};

Show report

Description: The report that is displayed in ActiveReports Web Report Service.

Type: An object that has id and parameters properties.

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

Show reportID

Description: The id of the report to be shown by the HTML5 Viewer.

Type: String

Example:

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

Show reportParameters

Description: The array of the {name, value} pairs that describe the parameters values used to run the report.

Type: Array

Example:

For single value parameter:

  report: {
     id: 'CustomersList',
     parameters: [
     {
        name: 'CustomerID',
        value: 'ALFKI'
     }]};

For multi-value parameter as array:

  var arrParam = [1, 2, 3];
  var reportOption = {
     id: 'PageReport1.rdlx',
     parameters: [
     {
        name: 'Parameter1',
        values: arrParam,
        multivalue: true
     }]
  };
  viewer.option('report', reportOption);

Show reportLoaded

Description: The callback that is invoked when the HTML5 Viewer obtains the information about the requested report. The reportInfo object is passed in the callback including the TOC info, Parameters info and the link to the rendered report result.

Type: function(reportInfo)

Example:
var reportLoaded = function reportLoaded(reportInfo)
   {
      console.log(reportInfo.parameters);
   }
viewer.option('reportLoaded', reportLoaded);

Show action

Description: The callback that is invoked before the HTML5 Viewer opens the hyperlink, bookmark link, drill down report or toggles the report control visibility.

Type: function(actionType, actionParams)

Example:
function onAction(actionType, actionParams)
{
   if (actionType === 0)
   {
      window.open(params.url, "Linked from report", "height=200,width=200");
   }
}
viewer.option('action', onAction);

Show availableExports

Description: The array of export types available via Export functionality of HTML5 Viewer. By default, PDF, Word, Image, Mht, Excel, and CSV exports are available.

Type: Array

Example:
viewer.option("availableExports", ['Pdf']);

Show maxSearchResults

Description: The number of search results received for a single search invoke.

Type: Number

Example:
maxSearchResults: 10

Show error

Description: The callback that is invoked when an error occurs in the process of displaying the report. The default error panel does not appear if the callback returns true. The error parameter is an object that has a message property which allows the users to customize the error message.

Type: function(error)

Example: To hide the default error panel
var options = {
  error: function(error){
    if (error.message) {
      // show error message.
      alert("Internal error! Please ask administrator.");
      return true; // do not show default error message.
    }
  },
  // other properties.
};
var viewer = GrapeCity.ActiveReports.Viewer(options);
Example: To customize the error message
var options = {
  error: function(error){
    error.message = "My error message";
  },
  // other properties
};
var viewer = GrapeCity.ActiveReports.Viewer(options);

Show documentLoaded

Description: The callback that is invoked when a document is loaded entirely on the server.

Type: function()

Example:
var documentLoaded = function documentLoaded()
   {
      setPaginator();
   }
viewer.option('documentLoaded', documentLoaded);

Show localeUri

Description: The url of the file containing the localization strings.

Note: This option is used during initialization only.

Type: String

Example:
var viewer = GrapeCity.ActiveReports.Viewer(
{
   localeUri: 'Scripts/i18n/ru.txt'
});

Show showOnlyLastError

Description: Removes the Show Details button in the error panel and shows only the last error.

Type: String

Example: To hide the Show Details button

var viewer = GrapeCity.ActiveReports.Viewer({
   showOnlyLastError: true
});

Show displayMode

Description: Set up single page or continuous page.

Type: String

Accepted Value: 'single', 'continuous'

Example:
viewer.option('displayMode', 'continuous');

Show previewPages

Description: Specify the maximum number of report pages to be rendered on HTML5Viewer while previewing RDL or Page reports.

Type: Integer

Example:
previewPages: 6

Public API Methods and Properties

After initializing the HTML5 Viewer, the following API methods and properties can be used.

Methods

Show option

Description: Gets or sets the option value by name if the value parameter is specified.

Syntax: option(name,[value])Object

Parameters:

  • name: The option name to get or set.
  • value: (optional) The option value to set. If this argument is omitted than the method returns the current option value.
Examples:
viewer.option('uiType', 'mobile');
viewer.option('report', {
id: 'my report'
});

viewer.option('displayMode', 'continuous');

Return Value: The current option value.

Show refresh

Description: Refreshes the report preview.

Syntax: option(name,[value])Object

Example:
viewer.refresh()

Return Value: Void

Show print

Description: Prints the currently displayed report if any.

Syntax: print()Void

Example:
viewer.print()

Return Value: Void

Show goToPage

Description: Makes the viewer to display the specific page, scroll to the specific offset (optional) and invokes the callback once it's done.

Syntax: goToPage(number, offset, callback)Void

Parameters:

  • number: The number of pages to go to.
  • offset object: The object such as {left:12.2, top:15}.
  • callback: The function to call after perform action.
Example:
viewer.goToPage(1, {
   2, 3
}, function onPageOpened()
{});

Return Value: Void

Show backToParent

Description: Makes the viewer to display the parent report of the drill-down report.

Syntax: backToParent()Void

Example:
viewer.backToParent()

Return Value: Void

Show destroy

Description: Removes the viewer content from the element.

Syntax: destroy()Void

Example:
viewer.destroy()

Return Value: Void

Show export

Description: Exports the currently displayed report.

Syntax: export(exportType,callback,saveAsDialog,settings)Void

Parameters:

  • exportType: Specifies export format.
  • callback: Function that is invoked once the export result is available (its Url is passed in the callback).
  • saveAsDialog: Indicates whether the save as dialog should be shown immediately once the export result is ready.
  • settings: The export settings are available for RenderingExtensions.
    Note: In section reports, the export settings are not enabled when exporting files using the rendering extensions. In Page report and RDL report, the export settings are not enabled when exporting files to PDF using the export filter.

Example:
function exportToExcel()

{
viewer.export('Xls', downloadReport, true, { FileName: "DefaultName.xls" });
}
// function fetches the report from uri(callback function)
var downloadReport = function (uri) {
    var newWin = null;
    // open uri in new window
    try {
        newWin = window.open(uri);
    } catch (e) { }
    // if browser rejects opening new window, open uri in current window
    if (!newWin) {
        window.location = uri;
    }
};

Return Value: Void

Show search

Description: Performs the search of a specific term with specific search options (match case, whole word) and invokes the specific callback with the search result passed.

Syntax: search(searchTerm, searchOptions, callback)Void

Parameters:

  • searchTerm: String to find.
  • searchOptions: The object optionally defines the search options:
    • matchCase: Whether the search should respect the case.
    • wholePhrase: Whether the search should look for a whole phrase.
  • callback: The function to call after performing search.
Example:
viewer.search('a', {
   matchCase: true,
   wholePhrase: false
}, function (results)
{
   console.log(results);
});

Return Value: Void

Show getToc

Description: Obtains the part of the report TOC specified by parent(node), startChild(index), count parameters and invokes callback function passing the result as parameter.

Syntax: getToc(callback) Void

Parameters:

  • callback: The callback to handle TOC tree.
Example:
viewer.getToc(function (toc)
{
   console.log(toc);
})

Return Value: Void

Properties

Show pageCount

Description: Gets the page count of the currently displayed report.

Syntax: viewer.pageCount

Example:
console.log(viewer.pageCount)

Return Value: An integer representing page count.

Show currentPage

Description: Gets the currently displayed page number.

Syntax: viewer.currentPage

Example:
console.log(viewer.currentPage)

Return Value: An integer representing currently displayed page number.

Show Toolbar

Description: Returns the HTML element that displays the toolbar in desktop UI mode. The developer may use it to add the custom elements or remove the existing ones using jQuery/Html/Css capabilities.

Syntax: viewer.Toolbar

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();

Show ToolbarTop

Description: Returns the HTML element that displays the top toolbar in mobile UI mode.

Syntax: viewer.ToolbarTop

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();

Show ToolbarBottom

Description: Returns the HTML element that displays the bottom toolbar in mobile UI mode.

Syntax: viewer.ToolbarBottom

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();

See Also

HTML5 Viewer

Sample ReadMe Files
HTML5 Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Viewing Reports using HTML5 Viewer

Viewing Reports using HTML5 Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > HTML5 > Viewing Reports using HTML5 Viewer

Glossary Item Box

The following steps describe how to view reports in HTML5 Viewer.

  1. Create a new Visual Studio Web Application project.
  2. Copy and place GrapeCity.ActiveReports.Viewer.Html.js, GrapeCity.ActiveReports.Viewer.Html.min.js, and GrapeCity.ActiveReports.Viewer.Html.css files at a suitable location near the target HTML page.
    Note: In ActiveReports, these files are located in the C:\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\Html
  3. In the target HTML page, add the references to the GrapeCity.ActiveReports.Viewer.Html.css, GrapeCity.ActiveReports.Viewer.Html.js and its following dependencies:
    • jQuery 1.9.0 or higher
    • Bootstrap 3.0
    • Knockout.js 2.3.0 or higher
    Note: You can obtain the dependencies like jQuery from Content Delivery Network (CDN) or copy them locally.
    Paste inside the <head></head> tags Copy Code
    <link rel="stylesheet" href="css/GrapeCity.ActiveReports.Viewer.Html.css" />
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"
     type="text/javascript"></script>
    <script src="//netdna.bootstrapcdn.com/bootstrap/3.3.1/js/bootstrap.min.js"
     type="text/javascript"></script>
    <script src="//cdnjs.cloudflare.com/ajax/libs/knockout/3.2.0/knockout-min.js"
     type="text/javascript"></script>
    <script src="Scripts/GrapeCity.ActiveReports.Viewer.Html.js"
     type="text/javascript"></script>
  4. Add the reference to the bootstrap.min.css in the target HTML page.
    Paste inside the <head></head> tags Copy Code
    <link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css" />
  5. In the target HTML page, add the DIV element that will contain the HTML5 Viewer.
    Paste inside the <body></body> tags Copy Code
    <div id="viewer" style="width:800px;height:600px;"></div>
  6. From the Project menu, select Add New Item.
  7. In the Add New Item dialog that appears, select ActiveReports 13 Web Service and click Add. The ActiveReports 13 Web Service is required for the proper functioning of the HTML5 Viewer.
  8. Add an ActiveReport to the Visual Studio project. See Adding an ActiveReport to a Project for information on adding different report layouts.
  9. Open the licenses.licx file, and add the following references to it.
    Paste inside the licenses.licx file Copy Code
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports, Version=13.0.11236.0,
    Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.PageReport, GrapeCity.ActiveReports, Version=13.0.11236.0,
    Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf,
    Version=13.0.11236.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Web.WebViewer, GrapeCity.ActiveReports.Web, Version=13.0.11236.0,
    Culture=neutral, PublicKeyToken=cc4967777c49a3ff
  10. Add the following code to view your report in the HTML5 Viewer. The code might vary depending on the technology that you use to develop the HTML5 Viewer component.
    Paste inside the <script></script> tags Copy Code
    $(function ()
    {
       var viewer = GrapeCity.ActiveReports.Viewer(
       {
          element: '#viewer',
          report: {
             id: "PageReport.rdlx"
          },
          reportService: {
             url: '/ActiveReports.ReportService.asmx'
          },
          uiType: 'desktop'

   });
    });

    Note: The reportID should be a full name of the class when you display a Section Report.
  11. Press F5 to run the project.

See Also

Viewing Reports from Different Domains using CORS
Using Javascript

Getting Started
HTML5 Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Customize

Customize
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > HTML5 > Customize

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports HTML5 Viewer is a fully customizable control. You can easily change the look of the viewer and show or hide the components using its public API.

The following example demonstrates few of the many modifications possible in the HTML5 Viewer. It shows setting the Custom uiType, adding the custom buttons for Print and Export and adding the Paginator control that allows you to display the number of report pages and to navigate through them.

Note: These steps assume that you have already created a new ASP.Net Web Application and added a sample report to display in the viewer.
  1. Add a new HTML page item to the project and in the Name field, rename the page item as HTML5Viewer.html.
  2. Copy and place GrapeCity.ActiveReports.Viewer.Html.js and GrapeCity.ActiveReports.Viewer.Html.css files in the project folder and add them to your project.
    Note: In ActiveReports, these files are located in the C:\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\Html folder.
  3. In the HTML5Viewer page item, add references to the stylesheets that will control the styling and appearance of the HTML5 Viewer.
    Note: You can obtain the source of Bootstrap.min.js from Content Delivery Network (CDN) like shown in the code below. You can also download the file from the source website and add the file to the project locally.

    Show Code

    Paste inside the <head></head> tags Copy Code
    <link href="//netdna.bootstrapcdn.com/bootstrap/3.0.0/css/bootstrap.min.css" rel="stylesheet" />
<link href="/GrapeCity.ActiveReports.Viewer.Html.css" rel="stylesheet" />
  4. Add the following DIV element inside the <body></body> tags that will contain the HTML5 Viewer and the Paginator control.

    Show Code

    Paste inside the <body></body> tags Copy Code
    <div class="container">
    <div id="paginator" class="pagination"></div>
    <div id="viewer" style="width: auto; height: 600px"></div>
</div>
  5. Add the following Style element inside the <body></body> tags to make the viewer fill the entire browser window.

    Show Code

    Paste inside the <body></body> tags Copy Code
    <style>
    #viewer {
    position: absolute;
    left: 5px;
    right: 5px;
    top: auto;
    bottom: 5px;
    font-family: 'segoe ui', 'ms sans serif';
    overflow: hidden;
   }
</style>
  6. Add the following DIV element inside the <body></body> tags that will contain the buttons for Print and Export.

    Show Code

    Paste inside the <body></body> tags Copy Code
    <div class="panel panel-default">
    <div class="panel-heading">
        <div id="appToolbar" class="btn-toolbar" style="margin-bottom: 10px">
            <button type="button" class="btn" id="btnPrint">
                Print</button>
           <button type="button" class="btn" id="btnExport">
                Export to PDF</button>
        </div>
    </div>
</div>
  7. In the Project menu, click Add New Item, select ActiveReports 13 Web Service and then click the Add button. This adds the ActiveReports.ReportService.asmx file to the project.
  8. Add the reference to the GrapeCity.ActiveReports.Viewer.Html.js and its following dependencies:
    • jQuery 1.10.2 or higher
    • Bootstrap 3.1.0 or higher
    • Knockout 2.3.0 or higher
    Note: You can obtain the source of dependencies like jQuery from Content Delivery Network (CDN). You can also download and add them to the project locally.

    Show Code

    Paste inside the <head></head> tags Copy Code
    <script src="//cdnjs.cloudflare.com/ajax/libs/jquery/1.10.2/jquery.js" type="text/javascript"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.1.0/js/bootstrap.js" type="text/javascript"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/knockout/2.3.0/knockout-debug.js" type="text/javascript"></script>
<script src="/GrapeCity.ActiveReports.Viewer.Html.js" type="text/javascript"></script>
  9. Add the following script element below other script elements to create the HTML5 Viewer for the viewer <div> element we have added above.

    Show Code

    Paste inside the <body></body> tags Copy Code
    <script type="text/javascript">
   $(function () {
       var paginator = $('#paginator');
       var viewer = GrapeCity.ActiveReports.Viewer(
           {
               element: '#viewer',
               report: {
                   id: "SampleReport.rdlx"
               },
               reportService: {
                   url: '/ActiveReports.ReportService.asmx'
               },
               //Setting the uiType to Custom
               uiType: 'custom',
               documentLoaded: function () {
                   setPaginator();
               }
           });
     //Creating the function for Printing
       $('#btnPrint').click(function () {
             viewer.print();
       });
     //Creating the function for Exporting
       $('#btnExport').click(function () {
           viewer.export('Pdf', function (uri) {
               window.open(uri);
           }, false, {});
       });

       //Creating the function for using Paginator control to display report pages and to navigate through them
       function setPaginator() {
           if (viewer.pageCount > 0) {
               for (var i = 1; i <= viewer.pageCount; i++) {
                   $('<li data-bind="' + i + '"><a class="js-page" href="javascript:void(0)">' + i + '</a></li>').appendTo(paginator);
               }
               paginator.children(":first").addClass('active');
               paginator.children().click(function () {
                   var self = $(this);
                   viewer.goToPage(self.attr('data-bind'), 0, function () {
                     paginator.children().removeClass('active');
                     self.addClass('active');
                   });
               });
           }
       }
   });
</script>
  10. Press F5 to run the project and navigate to the webpage containing the HTML5 Viewer that we have just created.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  11. As the report gets loaded in the viewer, use the paginator control to navigate through the all the report pages and click Print or Export to PDF to print or export the displayed report.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Localize and Deploy

Localize and Deploy
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > HTML5 > Localize and Deploy

Glossary Item Box

Localization

The HTML5 viewer can be localized by localizing the strings present in the en.txt file and then using it through the localeUri option while initializing the viewer. The en.txt file contains strings for viewer's toolbar items, panes, dialogs and errors. These strings can be localized to any culture and should be saved in the UTF-8 format. Follow these steps to learn localizing the HTML5 viewer:

  1. Go to C:\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\Html\i18n and open the en.txt file in a Notepad.
  2. Localize the strings in the file to any desired culture and save the file in the UTF-8 format as jp.txt.
  3. Add the newly created localized file to the project containing the HTML5 viewer. See Using Javascript to learn creating the HTML5 viewer.
  4. In the targeted HTML page that contains code to create the HTML5 viewer, paste the following code:
    XML Copy Code
    var viewer = GrapeCity.ActiveReports.Viewer(
{
   localeUri: 'Scripts/i18n/jp.txt'
});
  5. Press F5 to run the project and navigate to the webpage containing the HTML5 Viewer with localized strings.

Deployment

You can deploy the HTML5 viewer on IIS by deploying the ActiveReports Web Application that contains the viewer.

See Using Javascript to learn creating the HTML5 viewer in a ASP.Net Web Application project and Deploy Web Applications to learn deploying an ActiveReport Web Application.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ReportService Settings

ReportService Settings
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > ReportService Settings

Glossary Item Box

ActiveReports ReportService supports some external settings, which are useful while previewing reports in Web Viewers. The following table describes each of these settings with an example.

Setting | Description | Example
accessPoint | It is the path to report service descriptor. This setting should be used in a Web Viewer to override the default web service. This setting is only required for Web Viewer. | <> <WebService accessPoint="http.../*.asmx" /> </>
reportsFolder | It is the relative path to reports on the server. Supported in all viewers. | <> <WebService reportsFolder="~" /> </>
publicURI | It is a special setting to support redirection because report service results contain absolute URIs. Supported in all viewers. | <> <WebService publicURI="http.../" /> </>
reportLifetime | It is the current report lifetime if the report tab is not closed. The default report lifetime is 10 minutes, but it can be set to any value. It is not recommended to make the report lifetime less than 2 minutes. Supported in all viewers. | <> <WebService reportLifetime="00:10:00" /> </>
maxReportLifetime | It is the maximum allowed report lifetime, after which the report is destroyed on the server. The default maximum report lifetime is 24 hours; it can be set to any value. Supported in all viewers. | <> <WebService maxReportLifetime="24:00:00" /> </>
assemblyFolder | It is the temporary folder path, specified only if required. Supported in all viewers. | <> <WebService assemblyFolder="~" /> </>
Note: ReportService settings do not work in obsolete Medium trust environment.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


WPF Viewer

WPF Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > WPF Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides the WPF Viewer that you can use to load and view your reports. This viewer contains a toolbar and a sidebar with Thumbnails, Search results, Document map and Parameters panes.

Warning: The TargetInvocationException occurs on running a WPF browser application in Partial Trust. Refer to Running WPF Viewer in Partial Trust section given below to run your WPF Browser Application in Partial Trust. To ensure that you are using Full Trust:

  1. From the Visual Studio Project menu, select YourProject Properties.
  2. On the Security tab, under Enable ClickOnce security settings, select the This is a full trust application option.

Show WPF Viewer Toolbar

The following table lists the actions you can perform through the WPF Viewer toolbar.

Toolbar Element | Name | Description
 | Toggle Sidebar | Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
 | Print | Displays the Print dialog where you can specify the printing options.
 | Galley mode | Provides a viewer mode which removes automatic page breaks from an RDL report and displays the data in a single scrollable page. This mode maintains page breaks you create in the report.1
 | Find | Displays the Find dialog to find any text in the report.
 | Zoom out | Decreases the magnification of your report.
 | Zoom in | Increases the magnification of your report.
 | Current zoom | Displays the current zoom percentage which can also be edited.
 | Fit page width | Fits the width of the page according to viewer dimensions.
 | Fit whole page | Fits the whole page within the current viewer dimensions.
 | First page | Takes you to the first page of the report. This button is enabled when a page other than the first page is open.
 | Previous page | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
 | Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
 | Next page | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
 | Last page | Takes you to the last page of the report. This button is disabled on reaching the last page of the report.
 | Backward | Takes you to the last viewed page. This button is enabled when you move to any page from the initial report page. Clicking this button for the first time also enables the Forward button.
 | Forward | Takes you to last viewed page before you clicked the Backward button. This button is enabled once you click the Backward button.
 | Back to parent report | Returns you to the parent report in a drillthrough report.
 | Refresh | Refreshes the report.
 | Cancel | Cancels rendering of the report.

1To view drillthrough reports in WPF Viewer, you need to turn off the Galley mode.

Show WPF Viewer Sidebar

The WPF Viewer sidebar appears on the left of the Viewer control when you click the Toggle sidebar button in the toolbar. By default, this sidebar shows the Thumbnails and Search Results panes. The additional Document map and Parameters also appear in this sidebar. You can toggle between any of the viewer panes by clicking the buttons for each pane at the bottom of the sidebar.

Show Thumbnails pane

The Thumbnails pane appears by default in the sidebar when you click the Toggle sidebar button in the toolbar.

This pane is composed of a thumbnail view of all the pages in a report. Click any thumbnail to navigate directly to the selected report page. You can also modify the size of the thumbnail when you click (+) or (-) button to zoom in and zoom out.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Search results pane

The Search pane is the other default pane besides Thumbnails that appears in the sidebar when you click the Toggle sidebar button. This pane lets you enter a word or phrase from which to search within the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To search in a report:

  • Enter the word or phrase in the search field.
  • Under Use these additional criteria, you may optionally choose to search for the whole word or match the case of the search string while searching in the report.
  • Click the Search button to see the results appear in the Find results list.
  • Click an item in the list to jump to that item in the report and highlight it.

To start a new search or clear the current search results, click the Clear button under the Find results list.

Show Document map pane

The Documents map pane sis enabled for reports where the Label property or the Document map label is set. This pane displays each value for the text box, group, or sub report that you label, and you can click them to navigate to the corresponding area of the report in the Viewer.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

If a report does not have the Label property or Document map label set, the Documents map panes does not appear in the sidebar.

Show Parameters pane

The WPF Viewer allows you to view reports with parameters. In the toolbar, click the Toggle sidebar button to open the WPF Viewer sidebar and if your report contains parameters, the Parameters pane shows up automatically.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
  1. In the Parameters pane, you are prompted to enter a value by which to filter the data to display.
  2. Enter a value or set of values and click View report, to filter the report data and display the report.

If a report does not have parameters, the Parameters pane does not appear in the sidebar.

Display the report in the WPF Viewer

Set up your WPF Application project by using the following steps.

  1. Create a new WPF Application project or open an existing one.
  2. For a new project, in the Visual Studio Solution Explorer, right-click YourProject and select Add, then New Item.
  3. In the Add New Item dialog that appears, select the ActiveReports 13 Page Report, ActiveReports 13 RDL Report, ActiveReports 13 Section Report (code-based) or ActiveReports 13 Section Report (xml-based). This adds the necessary references to your project.
  4. From the Toolbox ActiveReports 13 tab, drag the Viewer control and drop it on the design view of MainWindow.xaml.
    Note: Dragging the Viewer control to the design view of MainWindow.xaml automatically adds the corresponding reference to the licenses.licx file.
  5. In the Properties window, with the report selected, set Copy to Output Directory to Copy always.

    Note:

    • If Page/RDL report is selected from dropdown of Source property (containing relative path), 'Copy to Output Directory' for selected report should be set as 'Copy always/Copy if newer' otherwise error "Could not find file ... " appears on loading WPF Viewer.

    Caution: In WPF Viewer control, previewing code-based Section reports using Source and SourceFormat properties is not supported.
  6. On MainWindow.xaml, with the viewer selected, go to the Properties window and double click the Loaded event.
  7. In the MainWindow code view that appears, add code like the following to the viewer1_loaded event to bind the report to the viewer. Each of these code snippets presumes a report in the project of the type indicated with the default name. (If you have renamed your report, you need to rename it in the code as well).

    Note:

    • Refer to the LoadDocument method to see other ways to load a report in WPF Viewer.
    • We can set report for WPFViewer directly on XAML file and load the report in WPF Viewer using Source and SourceFormat properties.

    Show To write the code in Visual Basic.NET

    The following example demonstrates how you display a page report or RDL Report in the WPF Viewer control.

    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb. Copy Code
    Viewer1.LoadDocument("YourReportName.rdlx")

    The following example demonstrates how you can display a section report (code-based) in the WPF Viewer control.

    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb. Copy Code
    viewer1.LoadDocument(new YourReportName())

    The following example demonstrates how you can display a section report (xml-based) in the WPF Viewer control.

    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb. Copy Code
    Viewer1.LoadDocument("YourReportName.rpx")

    Show To write the code in C#

    The following example demonstrates how you display a page report or RDL report in the WPF Viewer control.

    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs. Copy Code
    viewer1.LoadDocument("YourReportName.rdlx");

    The following example demonstrates how you can display a section report (code-based) in the WPF Viewer control.

    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs. Copy Code
    viewer1.LoadDocument(new YourReportName());

    The following example demonstrates how you can display a section report (xml-based) in the WPF Viewer control.

    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs. Copy Code
    viewer1.LoadDocument("YourReportName.rpx");

Additional Features

Following is an introduction to the additional capabilities of the Viewer to guide you on using it effectively.

Show Keyboard Shortcuts

The following shortcuts are available on the WPF Viewer.

Keyboard Shortcut | Action
Ctrl + F | Shows the search pane.
Ctrl + P | Shows the print dialog.
Esc | Closes the print dialog.
Page Down | Moves to the next page.
Page Up | Moves to the previous page.
Ctrl + T | Shows or hides the table of contents.
Ctrl + Home | Moves to the first page.
Ctrl + End | Moves to the last page.
Ctrl + Right | Navigates forward.
Ctrl + Left | Navigates backward.
Ctrl + - | Zooms out.
Ctrl + + | Zooms in.
Left, Right, Up, Down | Moves the visible area of the page in the corresponding direction.
Ctrl + 0 (zero) | Sets the zoom level to 100%.
Ctrl + rotate mouse wheel | Changes the zoom level up or down.
Ctrl + G | Moves the focus to current page toolbar option.
F5 | Refreshes the report.

Show Advance Printing Options

You can set the PrintingSettings property of the Viewer to directly print without displaying a dialog or to switch from a ActiveReports print dialog to a .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) on clicking the Print button on the Viewer toolbar. You can set the PrintingSettings property of the Viewer control from the Properties window.

PrintingSettings property provides the following options:

PrintingSettings Options | Description
ShowPrintDialog | Displays a dialog in which the user can set the printer options before printing.
ShowPrintProgressDialog | Displays a print progress dialog, in which the user can cancel the printing job.
UsePrintingThread | Specifies whether printing should be performed for individual threads or not.
UseStandardDialog | Specifies whether to use the .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) while printing the document (section or page).

Running WPF Viewer in Partial Trust

You can run a WPF Viewer Browser Application in Partial Trust by customizing the permission set in the app.mainfest file. While customizing the permission set, some of the permissions are to be set explicitly like MediaPermission, UIPermission, etc. Follow these steps to learn how to run a WPF Viewer application in partial trust.

Note: These steps assume that you have already created a WPF Browser Application that contains the WPF Viewer control.
  1. In the Solution Explorer, right-click your WPF Browser Application and select Properties.
  2. On the properties page that opens, go to the Security tab.
  3. On the Security tab, set Zone your application will be installed from to Custom and click the Edit Permissions XML button. This opens the app.mainfest file.
  4. In the app.manifest file, replace the existing xml code inside the <applicationRequestMinimum> </applicationRequestMinimum> tags with the following code.

    Show Code

    XML Copy Code
    <defaultAssemblyRequest permissionSetReference="Custom" />
<PermissionSet class="System.Security.PermissionSet" version="1" ID="Custom" SameSite="site">
  <IPermission class="System.Data.SqlClient.SqlClientPermission, System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Data.OleDb.OleDbPermission, System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.MediaPermission, WindowsBase, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" version="1" Audio="SafeAudio" Video="SafeVideo" Image="SafeImage" />
  <IPermission class="System.Security.Permissions.UIPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.ReflectionPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />>
  <IPermission class="System.Security.Permissions.StrongNameIdentityPermission, , mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
</PermissionSet>
  5. Press F5 to run your WPF Browser Application.
Note: The Partial Trust Limitations are applicable to the WPF viewer running in Partial Trust. For more information, see Medium Trust Support.

See Also

Walkthroughs
WPF Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Medium Trust Support

Medium Trust Support
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > Medium Trust Support

Glossary Item Box

Show All Show All
Hide All Hide All

All features of ActiveReports are available without restrictions in a Full trust environment. You can also use ActiveReports under Medium trust, but with limitations on some of the features.

Caution: Medium trust does not adequately protect your application and should not be used. For more information see MSDN link.

Note:

  • Assemblies placed in the Global Assembly Cache, or GAC (C:\WINDOWS\ASSEMBLY), have Full trust permissions, so the results on your deployment machine may differ from those on your development machine.
  • If you see an evaluation banner when deploying your ActiveReports project, you should use the Web Key Generator utility to create the Web Key and integrate the license information into your project.

Feature Limitations

  1. Exporting
    • RTF, Text, TIFF and Excel filters are not supported in Medium trust.
    • Digital signatures cannot be used in case of PDF rendering extension and PDF export.
    • Chart and Tablix control of Page Reports and RDL Reports are not displayed properly in case of PDF rendering extension and PDF export.
  2. The End User Designer and Windows Form Viewer controls require Full trust.
  3. The Picture control does not support metafiles, which require Full trust.
  4. The ImageType property of the Chart control must be set to PNG.
  5. OleObject, Formatted Text and Custom controls require Full trust.
  6. Scripting requires Full trust, so if you need to use code in reports under Medium trust, use code-based reports rather than RPX format.
  7. WebViewer
    • Bullet and Sparkline controls of PageReports and RDLReports are not displayed in all the Viewer types.
    • Report containing the Image control of PageReports and RDLReports is not displayed properly in case of HTML type.

Recommended Development Environment for Medium Trust Tests

Show To set up a Medium trust environment

Open the Web.config file and paste the following code between the <system.web> and </system.web> tags.

XML code. Paste BETWEEN the system.web tags. Copy Code
<trust level="Medium"></trust>

Show To set up the PrintingPermission level

Most hosting providers disable the printing permissions in a partially trusted environment.

  1. Open the web_mediumtrust. config file (located in the \Windows\Microsoft.NET\Framework\v4.0.30319\Config folder).
  2. Set the PrintingPermission level to NoPrinting.
XML code. Paste BETWEEN the system.web tags. Copy Code
<IPermission class="PrintingPermission"version="1"Level="NoPrinting"/>
Note: The default set of medium trust permissions is available in the web_mediumtrust.config.default file.

See Also

How To
License Your ActiveReports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Viewing Reports from Different Domains using CORS

Viewing Reports from Different Domains using CORS
See Also
ActiveReports 13 > ActiveReports User Guide > Viewing Reports > Viewing Reports from Different Domains using CORS

Glossary Item Box

Cross-Origin Resource Sharing is a technology for the web that provides async web operations to directly access reports from different domains. CORS works by adding a special header to responses from a server to the client. If a response contains the Access-Control-Allow-Origin header, then you can directly access the reports from another domain.

The following viewers require CORS:

  1. HTML5 Viewer
  2. HTML Viewer (WebViewer control)
  3. RawHTML (WebViewer control)

The following steps describe how to access reports from different domain using CORS.

  1. Add Global Application Class file (Global.asax) in your application on the service side.
  2. Open the Global.asax.cs file, and add the following code to access reports using cross websites.
    Paste inside the Global.asax.cs Copy Code
     protected void Application_BeginRequest(object sender, EventArgs e)
     {
       HttpContext.Current.Response.AddHeader("Access-Control-Allow-Origin", "*");
       if (HttpContext.Current.Request.HttpMethod == "OPTIONS")
         {
           HttpContext.Current.Response.AddHeader("Access-Control-Allow-Methods",
     "GET, POST, OPTIONS");
           HttpContext.Current.Response.AddHeader("Access-Control-Allow-Headers",
     "Content-Type, Accept");
           HttpContext.Current.Response.End();
         }
  }
    Paste inside the Global.asax.vb Copy Code
    Sub Application_BeginRequest(ByVal sender As Object, ByVal e As EventArgs)
       HttpContext.Current.Response.AddHeader("Access-Control-Allow-Origin", "*")
       If HttpContext.Current.Request.HttpMethod = "OPTIONS" Then
           HttpContext.Current.Response.AddHeader("Access-Control-Allow-Methods",
     "GET, POST, OPTIONS")
           HttpContext.Current.Response.AddHeader("Access-Control-Allow-Headers",
     "Content-Type, Accept")
           HttpContext.Current.Response.End()
       End If
    End Sub

    Note:

    • In case of Internet Explorer 9, you need to add $.support.cors = true; code on the client side while initializing the HTML5 Viewer to access reports from a different domain.
    • If you get error 404 or 500 on the report preview, please make sure that your browser supports CORS.

See Also

HTML5 Viewer
Viewing Reports using HTML5 Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Concepts

Concepts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts

Glossary Item Box

Learn about concepts that help you to understand how best to use ActiveReports.

This section contains information about

ActiveReports Designer
Learn what each of the tools and UI items on the report designer can help you to accomplish.
Report Types
Learn which type of ActiveReport best suits your needs.
Page Report/RDL Report Concepts
Learn basic concepts that apply to Page reports and RDL reports.
Section Report Concepts
Learn basic concepts that apply to Section reports.
Exporting
Learn about rendering extensions and exports, and which formats are available with Page and Section reports.
Visual Query Designer
Learn about Visual Query Designer features and it's SQL capabilities.
Interactive Features
Learn about various interactive features that affect your report output.
Report Parts
Learn about reports and how to use them in different reports.
Text Justification
Learn how to use the TextJustify property.
Multi Line in Report Controls
Learn how to enter multiline text in a report.
Line Spacing and Character Spacing
Learn how to control line spacing and character spacing in TextBox and Label report controls.
Shrink Text to Fit in a Control
Learn how to shrink text to fit in a TextBox control.
Condense Characters to Fit in a Control
Learn how to condense characters to fit in a TextBox control.
Standalone Designer and Viewers
Learn about the stand-alone designer and Viewer applications that help you create, edit and view a report quickly.
Localization
Learn about the ActiveReports localization model.
Section 508 Compliance
Learn about Section 508 compliance.
ActiveReports Web Designer
Learn about Web Designer in ActiveReports.

See Also

How To
How To

Getting Started
Getting Started

Walkthroughs
Samples and Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveReports Designer

ActiveReports Designer
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports offers an integrated designer that lets you create report layouts in Visual Studio and edit them at design time, visually, and through code, script, or regular expressions. Like any form in Visual Studio, it includes a Property Window with extensive properties for each element of the report, and also adds its own Toolbox filled with report controls, and a Report Explorer with a tree view of report controls.

The designer supports three types of report layouts: section layout, page layout, and rdl layout.

Show Section Report Layout

This layout presents reports in three banded sections by default: page header, detail and page footer. You can remove the page header and footer, add a report header and footer, and add up to 32 group headers and footers. Drag controls onto these sections to display your report data. Reports designed in this layout are saved in RPX format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Page Report Layout

This layout defines reports in pages where the same page layout can be used throughout the report or separate layout pages are designed for complex reports. Reports designed in this layout are saved in Rdlx format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show RDL Report Layout

This layout defines reports where controls grow vertically to accommodate data. Reports designed in this layout are saved in Rdlx format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Note that a theme you select for your Visual Studio, is automatically applied to the ActiveReports Designer. For example, if you select the Dark theme for your Visual Studio, this theme is applied automatically to the Designer. The Visual Studio theme is extended to such ActiveReports Designer elements as Reports Library, Layer List, Report Explorer, and Group Editor.

The theme integration works for all reports (Page, RDL, and Section) opened in Visual Studio 2012 or higher.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

In this section

Design View
Explore the elements of the design tab that appear for each report type.
Report Menu
Learn about the options available in the Report menu in Visual Studio.
Designer Tabs
Find general information about the Designer, Script, and Preview tabs of the designer.
Designer Buttons
Learn to control grid settings, drag and drop settings, and mouse modes on the designer.
Page Tabs
Explore the ways that you can use different page layouts in the same report in Page Reports.
Toolbar
Learn about the commands available in the ActiveReports Toolbar.
Report Explorer
Learn how you can use the Report Explorer to manage the report controls, data regions, parameters, and other items in your reports.
Toolbox
Find information on controls you can use to design report layouts.
Properties Window
See an overview of how to access properties for report controls, data regions, report sections, and the report itself.
Rulers
Learn how you can use rulers to align your controls on the report design surface.
Scroll Bars
See an explanation of scroll bars including the new auto scrolling feature.
Snap Lines
Find information about snap lines, and how they work.
Zoom Support
Get the ability to zoom in or zoom out of your report layout.

See Also

Getting Started
Adding ActiveReports Controls
Adding an ActiveReport to a Project

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Design View

Design View
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Design View

Glossary Item Box

Show All Show All
Hide All Hide All

The report designer is fully integrated with the Microsoft Visual Studio IDE. In this topic, we introduce the main parts of the designer in Section report, Page report, and RDL report to help you select the one to best suit your specific needs.

Show Report designer in section reports

In a section report, the designer offers the following features that you can use to create, design and edit a report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Design Surface

The design surface offers a default report structure that contains a page header, a detail section, and a page footer along with some grey area below these sections. Drag report controls and fields onto these sections to display your data. Use section grab handles to drag a section's height up or down. Right click the report and select Insert to add other types of header and footer section pairs.

DataSource Icon

The DataSource icon is located in the band along the top of the detail section. Click this icon to open the Report Data Source dialog, where you can bind your report to any OLE DB, SQL, or XML data source. See Report Data Source Dialog for more information

Section Collapse Icon

A Section Collapse icon (-) appears on each band adjacent to the section header. When you click the collapse icon the section collapses and an expand icon (+) appears. Please note that section collapse is only available in the Designer tab. All sections of the report are visible in the Preview tab or when the report is rendered.

Tip: In order to make a section invisible, set the Height property of the section to 0 or the Visible property to False.

Rulers

Rulers are located at the top and left of the design view. They help a user visualize the placement of controls in the report layout and how they appear in print. Please note that you have to add the right and left margin widths to determine whether your report fits on the selected paper size. The left ruler includes a grab handle for each section to resize the section height. See Rulers for more information.

Grab Handles

Grab handles on the vertical ruler indicate the height of individual sections. You can drag them up or down to change section heights, or double-click to automatically resize the section to fit the controls in it.

Designer Tabs

The designer provides three tabs: Designer, Script and Preview. You can create your report layout visually in the Designer tab, add script to report events in the Script tab to implement .NET functionality, and see the result in the Preview tab. See Designer Tabs for more information.

Designer Buttons

Designer buttons are located below the design surface next to the designer tabs. Dimension Lines, Hide Grid, Dots, Lines, Snap to Lines, and Snap to Grid buttons help you to align report controls and data regions. The Select Mode and Pan Mode buttons determine whether you select controls on the design surface, or move the visible area of a zoomed-in report. See Designer Buttons for more information.

Zoom Bar

The zoom bar provides a slider that you drag to zoom in and out of the design surface, or you can use the Zoom in and Zoom out buttons at either end of the slider. See Zoom Support for more information.

Show Report designer in page reports/RDL reports

In a page report or a RDL report, the designer offers the following features that you can use to create, design and edit a report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Design Surface

The design surface of a report appears initially as a blank page and grid lines. You can create your own layout and drag report controls and fields onto the design surface to display your data.

Rulers

Use the ruler to determine how your report will look on paper. Please note that you have to add the right and left margin widths to determine whether your report will fit on the selected paper size. See Rulers for more information.

Designer Tabs

The designer provides three tabs: Designer, Script and Preview. You can create your report layout visually in the Designer tab, add script to report events in the Script tab to implement .NET functionality, and see the result in the Preview tab. See Designer Tabs for more information.

Page Tabs(Page Report)

By default, the designer provides two page tabs, Page 1 and New, below the design surface. Each page tab represents a layout page of the report. Page 1 represents the first page of your report, and you can click New to add another page to your report. See Page Tabs for more information.

Designer Buttons

Designer buttons are located below the design surface next to the designer tabs. Dimension Lines, Hide Grid, Dots, Lines, Snap to Lines, and Snap to Grid buttons help you to align report controls and data regions. The Select Mode and Pan Mode buttons determine whether you select controls on the design surface, or move the visible area of a zoomed-in report. See Designer Buttons for more information.

Zoom Bar

The Zoom Bar provides a slider that you drag to zoom in and out of the design surface, or you can use the Zoom in and Zoom out buttons at either end of the slider. See Zoom Support for more information.

Tip: ActiveReports provides some useful keyboard shortcuts for the controls placed on the design surface.

  • Arrow Keys: To move control by one grid line.
  • [Ctrl] + Arrow Keys: To move control by 1/100 inch (around 0.025 cms)
  • [Shift] + Arrow Keys: To increase or decrease the size of the control by one grid line.

See Also

ActiveReports Designer
Report Explorer
Properties Window
Toolbox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Menu

Report Menu
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Menu

Glossary Item Box

Show All Show All
Hide All Hide All

The Report menu provides access to common reporting operations. To show the Report Menu in the Visual Studio menu bar, select the Design View of the report in the ActiveReports Designer. This menu does not appear in the menu bar when the report is not selected.

The following drop-down sections describe the Report menu items. Menu items differ based on the type of report layout in use.

Note: The Report menu in Visual Studio 2019 is available as submenu under Extensions.

Show Report Menu for Section Reports

Menu Item | Description
Save Layout | Opens the Save As dialog to save the newly created report in RPX file format.
Load Layout | Opens the Open dialog where you can navigate to any RPX file and open it in the designer. Note that any changes to the current report are lost, as the layout file replaces the current report in the designer.
Data Source | Opens the Report Data Source dialog to bind a data source to the report.
Settings | Opens the Report Settings dialog. See Report Settings Dialog for more information.
View
  • Designer
  • Script
  • Preview
 Opens the Designer, Script or Preview tab. See Designer Tabs for more details.

Show Report Menu for Page and RDL Reports

Menu Item | Description
Save Layout | Opens the Save As dialog to save the newly created report in RDLX file format.
Load Layout | Opens the Open dialog where you can navigate to any RDL, RDLX, RDLX-master file and open it in the designer. Note that any changes to the current report are lost, as the layout file replaces the current report in the designer.
Convert to Master Report (RDL Reports only)

Converts a RDL report to a Master Report.

It disappears from the Report menu when a master report is applied to the report through Set Master Report. See Master Reports (RDL) for more details.
Report Parameters | Opens the Report dialog to the Parameters page where you can manage, add and delete parameters.
Embedded Images | Opens the Report dialog to the Images page, where you can select images to embed in a report. Once you add images to the collection, they appear in the Report Explorer under the Embedded Images node.
Report Properties | Opens the Report dialog to the General page where you can set report properties such as the author, description, page header and footer properties, and grid spacing.
Stylesheet Editor | Opens the Stylesheet Editor dialog, where you can create, edit or remove styles. You can also embed these styles in a style sheet or save them externally in *.rdlx-styles format. Embedded style sheets appear under the Embedded Stylesheets node in the Report Explorer.
Set Master Report (RDL Reports only)
  • Open Local File

Select Open Local File option to open the Open dialog, and then select a master report.
View
  • Designer
  • Script
  • Preview
 Opens the Designer, Script or Preview tab. See Designer Tabs for more details.
Page Header (RDL Reports only) | Toggles the report Page Header on or off.
Page Footer (RDL Reports only) | Toggles the report Page Footer on or off.

See Also

Report Explorer
ActiveReports Designer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Designer Tabs

Designer Tabs
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Designer Tabs

Glossary Item Box

Show All Show All
Hide All Hide All

The Designer has three tabs located at the bottom of the report design surface. Create a report layout in the Designer tab, write a script in the Script tab to implement .NET functionality and see the result in the Preview tab.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Designer Tab

The Designer tab appears by default on your designer. This tab is used to design your report layout visually. You can implement most of the design-time features here, drag controls from the toolbox to create a layout, bind data regions to data, and set properties for the report and controls through the context menu.

Tip: Layout-related features like designer buttons and zoom slider can be used in this tab to help you manage your report display efficiently.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Script Tab

The Script tab opens the script editor, where you can provide VB.NET or C# functionality to the reports without compiling the .vb or .cs files. You may use either Visual Basic or C# script in this tab with section reports, or Visual Basic with page reports and RDL reports.

The generated reports serve as stand-alone reports which you can load, run, and display in the viewer control without the designer. This feature is useful when distributing reports without recompiling.

In page reports/RDL reports, you can embed code blocks that you can reference in the expressions you use on report controls. See Using Script for more information about using script.

In section reports, you can add code to object events. The two drop-down boxes in the script editor allow you to select any section of the ActiveReport and any events associated with that section, or the report itself and related events. When you select an event, the script editor generates a method stub for the event. See Add Code to Layouts Using Script for more information about scripting in section reports.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Preview Tab

The Preview tab allows you to view your report without the need to actually run your project. This makes it easy to quickly see the run-time impact of changes you make in the designer or the code.

This tab does not display data in the following conditions:

  • Code or script in the report class is incorrect.
  • Report class constructor has been changed.
  • Report data source has not been set correctly.
  • Settings have been implemented outside the report class
  • .mdb file is being copied in the project

When the report is inherited from a class other than ActiveReports, preview is possible only when the base class is in the same project. If the base class is not in the same project and is referencing an external class library, you will not get a preview in the Preview tab.

When adding a report directly to ASP.NET Web site, the Preview tab is not visible and thus you cannot preview.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Designer Buttons

Designer Buttons
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Designer Buttons

Glossary Item Box

Show All Show All
Hide All Hide All

Designer buttons are located to the right of the designer tabs along the bottom of the designer, and are enabled when you are on the Designer tab. They allow you to control settings for the design surface.

Grid Settings

Show Dimension Lines

Dimension lines appear during a drag operation, and run from the borders of the report control or data region being moved or resized to the edges of the report designer surface. Dimension lines let you track the location of the control as you move it by displaying the distance between the control and the edge of the writable area of the report.

Button Type | Behavior
Note: With section reports, you can change the number of grid columns and rows in the Report Settings dialog on the Global Settings tab. With page reports and RDL reports, you can change the grid spacing in the Report Properties dialog on the General tab.

Show Hide Grid

By default, grid lines and dots appear on the report design surface. You can click this button to hide the grid and design your report on a blank page. Lines or dots are also removed from the design surface when you hide the grid, but Snap to Lines or Snap to Grid settings remain unaffected.

Button Type | Behavior

Show Show Dots

You can click this button to have dots appear on the design surface in between the grid lines to guide you in the placement of controls.

Button Type | Behavior

Show Show Lines

You can click this button to have faint grey lines appear on the design surface in between the grid lines to guide you in the placement of controls.

Button Type | Behavior
Note: Only one option out of Hide Grid, Show Dots and Show Lines can be selected at one time.

Control Drag and Drop Settings

These settings allow you to specify how you want controls to behave when you drag and drop them on the design surface.

Tip: If you plan to export a report to Excel format, use Snap Lines or Snap to Grid to ensure that your controls are aligned in columns and rows as it prevents overlapping. This makes the export to excel closer to how a report looks at run or design time.

Show Snap Lines

This setting aligns the control you are dragging with other controls on the report design surface. When you drag the control around, snap lines appear when it is aligned with other controls or with the edges of the report, and when you drop it, it snaps into place in perfect alignment. See Snap Lines for more information.

Button Type | Behavior

Show Snap to Grid

This setting aligns the control you are dragging with grid lines on the report design surface. When you drop the control, it snaps into place in alignment with the nearest grid mark. To place your controls freely on the report design surface, turn this setting off.

Button Type | Behavior

Mouse Modes

These settings allow you to specify how you want the mouse to behave in the designer.

Show Select Mode

In Select mode, when you click items on the report designer surface, you select them. Use this mode for editing, data binding and styling in the Designer tab. An arrow cursor appears in the Select mode.

Button Type | Behavior

Show Pan Mode

Use the Pan mode to make navigation easier. A hand cursor appears in Pan mode and you can navigate through your report by pressing the left mouse button and dragging the report to the desired position.

Tip: To enable Pan mode while you are in Select Mode, hold down the middle mouse button and move to the desired location with the hand cursor.
Button Type | Behavior

See Also

Designer Tabs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page Tabs

Page Tabs
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Page Tabs

Glossary Item Box

Show All Show All
Hide All Hide All

Page tabs appear in an Excel-like bar below the report design surface. This feature is only available in page reports, where report layouts are designed on separate pages and you can control the way each page appears. Using page tabs, you can select which page to view or edit, add new pages, remove existing pages, reorder pages, and create duplicate pages.

By default, a new report has a Page 1 tab and a New tab.

  • Page 1: This is the layout for the first page of the report. If no other page layouts exist, the layout on this page is applied to the entire report.
  • New: Click to add a new page where you can create a layout for pages displayed after the first page.

Right-click any page tab (except the New tab) to get a context menu that allows you to Insert a new page, Duplicate the page, or Delete the page.

Show Adding a new page

To add a new page, click the New tab.

A new page tab with an incremented page number appears to the right of any existing page tabs. This page has the same page size and margins as the previous page. The New tab moves to the right of the newly added page.

Show Inserting a page

To insert a page, right-click the page tab and select Insert. A page is inserted to the left of the selected page. It has the same page size and margins as the selected page.

Show Deleting a page

To delete a page, right-click the page tab that you want to remove and select Delete. This option is disabled if there is only one page in the report.

Show Creating a copy of a page

To create a copy of a page, right-click on the page tab that you want to copy and select Duplicate. A copy of the selected page appears to the right of the selected page.

Note: When the duplicate page contains a data region, ActiveReports replaces the data region with an OverflowPlaceHolder on the new page. Reset the GrapeCity.ActiveReports.PageReportModel.DataRegion.OverflowName property for the duplicated page to maintain the overflow data chain between page tabs.

Show Reordering pages

To change the order of page tabs, drag a tab and drop it at the desired location. The tab is inserted in the chosen location and the page number is updated according to its position. The page numbers of other tabs also change automatically.

You can cancel the move operation by pressing the [Esc] key while dragging the tab.

See Also

Overflow Place Holder

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Toolbar

Toolbar
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Toolbar

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides a toolbar integrated with the Visual Studio IDE for quick access to report designing commands. This toolbar is composed of buttons and dropdown lists which offer functions for a number of commonly used commands.

To Show or Hide the Toolbar in Visual Studio

  1. Create a new project or open an existing project in Visual Studio.
  2. Right click on the Visual Studio toolbar and from the context menu that appears, select ActiveReports.

The ActiveReports toolbar appears under the Visual Studio menu bar. The toolbar options may differ based on whether you have a section report, page report or a RDL report open.

See the description of each toolbar option in the tables below.

Note: Toolbar descriptions are grouped in a logical order for understanding. The buttons and dropdowns may appear in a different order in the ActiveReports toolbar.

Show Text Decoration

Command | Description
Style | Sets the style for the selected report control. For details on setting styles in Page and RDL reports, see Working with Styles. For details on setting styles in Section report, see Use External Style Sheets.
Font Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink | Sets the typeface of all the text in a control. In a section report, for the RichTextBox control, typeface of only the selected text changes. In a page report or a RDL report, in a data region like Tablix or Table, you can change the typeface of the entire data region or only the selected TextBox within the region.
Font Size Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink | Sets the font size of all the text in a control. In a section report, for the RichTextBox control, font size of only the selected text changes. In a page report or a RDL report, for a data region like Tablix or Table, you can change the font size of the entire data region or only the selected TextBox within the region.
Fore Color | Opens a Choose Color dialog to set the text color of controls.
Back Color | Opens a Choose Color dialog to set the background color of controls.
Bold | Sets or removes text emphasis from the entire text of the control. In section report, for the RichTextBox control, bold applies to the selected text only. In a page report or a RDL report, for a data region like Tablix or Table, you can change the emphasis of the entire text or only the text of the selected TextBox within the region.
Italic | Sets or removes text slant for the entire text of the control. In a section report, for the RichTextBox control, italic applies to the selected text only. In a page report or a RDL report, for a data region like Tablix or Table, you can italicize the entire text or only the text of the selected TextBox within the region.
Underline | Sets or removes the text underline for the entire text of the control. In a section report, for the RichTextBox control, underline applies to the selected text only. In a page report or a RDL report, for a data region like Tablix or Table, you can also underline the entire text or only the text of the selected TextBox within the region.

Show Text Alignment

Command | Description
Align Left | Aligns the text to the left in the control area.
Center | Aligns the text to the center in the control area.
Align Right | Aligns the text to the right in the control area.
Align Justify | Justifies the text in the control area.

Show Layout Editing

Command | Description
Zoom Out | Reduces the magnification level of the design surface and any elements within it.
Zoom In | Increases the magnification level of the design surface and any elements within it.
Zoom | Opens a dropdown list to set the magnification level of the design surface between 50% and 400%. Zoom percentage is set to 100% by default.

Show Control Alignment

Command | Description
Align to Grid | Snaps the top left of the selected control to the closest gridline.
Align Lefts | Aligns the selected controls with their left border coinciding with the left border of the primary control. The vertical space separating the controls remains the same.
Align Rights | Aligns the selected controls with their right border coinciding with the right border of the primary control. The vertical space separating the controls remains the same.
Align Tops | Aligns the selected controls with their top border coinciding with the top border of the primary control. The horizontal space separating the controls remains the same.
Align Middles | Aligns the selected controls vertically to the middle with respect to the primary control. The horizontal space separating the controls remains the same.
Align Bottoms | Aligns the selected controls with their bottom border coinciding with bottom border of the primary control. The horizontal space separating the controls remains the same.

Show Control Resizing

Command | Description
Make Same Width | Resizes the width of the selected controls to the width of the primary control.
Make Same Height | Resizes the height of the selected controls to the height of the primary control.
Make Same Size | Resizes the size (width and height) of the selected controls to the size of the primary control.
Size to Grid | Snaps the selected control to the closest gridline by resizing the control on all four sides.

Show Control Spacing

Command | Description
Make Horizontal Spacing Equal | Creates equal space between the selected controls with respect to the primary control, using the outermost edges of the controls as end points.
Increase Horizontal Spacing | Increases the horizontal spacing by one grid unit with respect to the primary control.
Decrease Horizontal Spacing | Decreases the horizontal spacing by one grid unit with respect to the primary control.
Remove Horizontal Spacing | Removes the horizontal space so that the selected controls move to the nearest edge of the top-left control.
Make Vertical Spacing Equal | Creates equal space between the selected controls with respect to the primary control, using the top and bottom edges of the control as the end points.
Increase Vertical Spacing | Increases the vertical spacing by one grid unit with respect to the primary control.
Decrease Vertical Spacing | Decreases the vertical spacing by one grid unit with respect to the primary control.
Remove Vertical Spacing | Removes the vertical spacing so that the selected controls move to the nearest edge of the top-left control.

Show Z-order Alignment

Command | Description
Bring to Front | Moves the selected controls to the front of all other controls on the report.
Send to Back | Moves the selected controls behind all other controls on the report.

Show RichTextBox commands

Command | Description
Bullets | Adds or removes bullets from the selected text inside a RichTextBox control in a section report.
Increase Indent | Increases the indent of selected text in the RichTextBox control area in a section report.
Decrease Indent | Decreases the indent of selected text in the RichTextBox control area in a section report.

Show Others

Command | Description
View ReportExplorer | Shows or hides the Report Explorer window. See Report Explorer for further details.
Reorder Groups | Opens the Group Order dialog, where you can drag and drop groups to rearrange them. This button is enabled when you have multiple groups in a section report.
Layer List | Opens the Layer List window to displays a list of Layers in the report along with their visibility and lock options. Layer List Explorer also allows you to add or remove Layers from your reports. See Working with Layers for further details.
Note: Primary control is the control in a selected group of controls, to which you align all other controls. It is generally the first control selected in the group and has sizing handles (white boxes) which are different from the rest of the selected controls.

See Also

ActiveReports Designer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Explorer

Report Explorer
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Explorer

Glossary Item Box

Show All Show All
Hide All Hide All

The Report Explorer gives you a visual overview of the report elements in the form of a tree view where each node represents a report element.

Using the Report Explorer with any type of report, you can remove controls, add, edit or remove parameters, add a data source, and drag fields onto the report. You can also select the report or any element in the report to display in the Properties Window, where you can modify its properties.

ActiveReports supports three types of reports:

  • Section reports (in your choice of XML-based RPX or code-based CS or VB files)
  • Page reports (in XML-based RDLX files)
  • RDL reports

Section reports, RDL reports and page reports are composed of different types of report elements, so the Report Explorer shows different elements in the report tree depending on the type of report you have open. For more information on how to use the Report Explorer with each, see Exploring Page and RDL Reports and Exploring Section Reports .

Show To show or hide the Report Explorer in Visual Studio

Once you add the Report Explorer in Visual Studio, it appears every time you create a new Windows application. Use the steps below to hide it when you do not need it.

  1. Right-click on the Visual Studio toolbar and select ActiveReports to display the report designer toolbar. See Toolbar for further details.
  2. On the Designer toolbar, click the View ReportExplorer button. The Report Explorer window appears.
  3. To hide the Report Explorer, follow the steps above and toggle View ReportExplorer back off.

Tip: Another way to show the Report Explorer window in Visual Studio, is from the View menu, select Other Windows, then Report Explorer 10.

To change a report using the Report Explorer

More actions specific to each report type can be found in Exploring Page and RDL Reports and Exploring Section Reports .

Show To change control properties

  1. In the Report Explorer, select the control for which properties are to be changed. In the Properties Window, all of the properties for the item appear.
  2. Change property values by entering text or selecting values from drop-down lists. With some properties, for example, OutputFormat or Filters, when you click the property, an ellipsis button appears to the right. Click the ellipsis button to open a dialog where you can make changes.

Show To delete a control

  1. In the Report Explorer, expand the node that contains the control that you want to remove.
  2. Right-click the control and select Delete.
  3. In the dialog that appears, click Yes to confirm the deletion.

See Also

Exploring Section Reports
Exploring Page and RDL Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Exploring Page and RDL Reports

Exploring Page and RDL Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Explorer > Exploring Page and RDL Reports

Glossary Item Box

Show All Show All
Hide All Hide All

When you have a Page or RDL report open in the ActiveReports Designer, you can see nodes like the following in the Report Explorer.

  • Document Outline
    • Each report page (or the body for RDL reports)
      • Each control, for example:
        • BandedList
        • Tablix
        • Table
  • Data Sources
    • DataSource (right-click to add a data source; you can have more than one)
      • DataSet (right-click the DataSource to add a data set)
        • Fields (drag onto the report or onto a data region)
      • Another DataSet (you can have more than one)
  • Parameters (right-click to open a dialog and add a parameter)
  • Embedded Images (right-click to browse for an image to add)
  • Embedded StyleSheets (right-click to open and add a style sheet)
  • Common Values (drag onto the report to display the value in a textbox)

In the Report Explorer, you can

  • remove controls
  • add, edit or remove parameters
  • add a data source
  • drag fields onto the report
  • share a data source
  • add data sets
  • add, edit, or remove embedded images
  • drag common values like page numbers, current date, or report name onto the report as a textbox
  • select the report or any element in the report to display in the Properties window, where you can modify its properties.

Show To add a DataSource

  1. In the Report Explorer, right-click the Data Sources node and select Add Data Source. The Report Data Source dialog appears, open to the General page.
  2. On the General page, drop down the Type list and select Microsoft OleDb Provider.
  3. Under Connection, on the Connection Properties tab, drop down the OLE DB Provider list and select Microsoft.Jet.OLEDB.4.0.
  4. In the Server or file name box, enter the path and file name to your Access database, for example,
    C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.MDB.
  5. Click the Accept button. The new data source is added to the Data Sources node. To use fields from the data source, add a data set.

Show To share a DataSource

  1. In the Report Explorer, expand the DataSources node, right-click the node for the data source that you want to share, and select Share Data Source. The Save Shared Data Source File dialog appears.
  2. Navigate to the folder where you want to save the file, enter a name for the file, and click Save.
  3. The type of data source as well as the connection string are saved to a file of type RDSX that you can use in other reports.

Show To add a DataSet

  1. In the Report Explorer, expand the DataSources node, right-click the node for the data source that you want to use, and select Add DataSet. The DataSet dialog appears.
  2. In the list to the left, select Query to show the Query page.
  3. In the Query box to the right, enter a SQL query to pull the data you want for your report.
    Example Query Copy Code
    SELECT * FROM Customers
  4. Click the Accept button to create the data set. The data fields appear in the data set node.

Show To bind a DataSet field to a TextBox control

  1. In the Report Explorer, expand the DataSources node, then the node for the data source, then the DataSet that you want to use.
  2. From the DataSet node, click the DataSet field that you want to bind to a TextBox control, drag it onto the report surface or onto a data region and drop it.
  3. A TextBox control is created and bound to the field with the proper expression in the Value property. For example, if you drag the City field onto the report, the Value property of the TextBox contains the expression =Fields!City.Value.

Show To add parameters

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter. The Report Parameters dialog appears.
  2. On the General tab of the dialog, enter text for prompting users for a value.
  3. On the Available Values tab, you can select values from a DataSet to populate a list from which users can select a value.
  4. On the Default Values tab, you can provide default values to use if the user does not select a value.
  5. Click Accept to save the parameter. The new parameter appears in the Report Explorer under the Parameters node.
  6. From the Report Explorer, drag the parameter to report design area to create a TextBox that is bound to the parameter. When you run the report, the value that the user supplies in the prompt dialog displays in the bound TextBox on the report.

See Also

Exploring Section Reports
Report Explorer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Exploring Section Reports

Exploring Section Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Explorer > Exploring Section Reports

Glossary Item Box

Show All Show All
Hide All Hide All

By default, when you have a section report open in the ActiveReports Designer, you can see nodes like the following.

  • The Report
    • Each report section, for example:
    • Detail (default, cannot be removed)
    • Report Header and Footer (default, can be removed)
    • Page Header and Footer (can be added)
    • Group Header and Footer (can be added)
      • Each control, for example:
      • TextBox
      • Picture
      • PageBreak
      • SubReport
  • Fields
    • Bound (lists fields from the bound data source)
    • Calculated (right-click to add calculated fields)
  • Parameters (right-click to add parameters)
  • Report Settings (opens a dialog for page setup, printer settings, styles and global settings)

In the Report Explorer, in addition to removing controls, adding, editing or removing parameters, adding a data source, and dragging fields onto the report, you can also add, edit, or remove calculated fields; drag bound data fields onto the report as textbox controls; change report settings like margins, printer settings, styles, and ruler and grid settings. You can also select the report or any element in the report to display in the Properties window, where you can modify its properties.

Show To add a DataSource

  1. Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog.
  2. On the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button. Click the ellipsis (...) button to browse to your database or the sample Northwind database, nwind.mdb.
  4. Once you have selected your *.mdb file, click Open.
  5. Click OK to close the window and fill in the Connection String field.
  6. In the Query field, enter a SQL query to select the data that you want, for example
    Example Query Copy Code
    SELECT * FROM Customers
  7. Click OK to save the data source and return to the report design surface. In the Report Explorer, under the Fields node, the Bound node is populated with fields returned by the query.

Show To add a calculated field

  1. In the Report Explorer, expand the Fields node.
  2. Right-click the Calculated node and select Add. The new calculated field is displayed in the Report Explorer and in the Properties window.
  3. In the Properties window, set the Formula property to a calculation, for example: = UnitPrice * 1.07
  4. Drag the field from the Report Explorer onto the design surface of your report to create a textbox that is bound to the field.

Show To bind a Field to a TextBox control

  1. In the Report Explorer, expand the Fields node, then the Bound or Calculated node that you want to use.
  2. Click the field that you want to bind to a TextBox control, drag it onto the report surface and drop it into the section where you want the TextBox to appear.
  3. A TextBox control is created and bound to the field with the filed name in the DataField property, and a related value in the Name and Text properties. For example, if you drag the City field onto the report, the DataField property of the TextBox becomes City, the Name and Text properties become txtCity1.

Show To add parameters

  1. In the Report Explorer, right-click the Parameters node and select Add. The new parameter is displayed in the Report Explorer and in the Properties window.
  2. In the Properties window, set the Prompt property to a string value to ask users for data.
  3. Leave the PromptUser property set to True. When you run the report, a dialog displays the Prompt to the user.
  4. From the Report Explorer, drag the parameter to the report design area to create a TextBox that is bound to the parameter. When you run the report, the value that the user supplies in the prompt dialog displays in the bound TextBox on the report.

Show To change report settings

  1. In the Report Explorer, double-click the Settings node. The Report Settings dialog appears.
  2. You can set a number of options on the four tabs in the dialog.
  3. When you have finished changing report settings, click OK.

See Also

Report Explorer
Exploring Page and RDL Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Toolbox

Toolbox
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Toolbox

Glossary Item Box

In ActiveReports, the Visual Studio integrated toolbox tabs display all of the controls specific to the type of report that has focus, or the ActiveReports controls that you can use on Web Forms or Windows Forms.

When a Section report has focus, the ActiveReports 13 Section Report toolbox becomes available. For information about the report controls available in this toolbox, please see the Section Report Toolbox topic.

When a Page report has focus, the ActiveReports 13 Page Report toolbox becomes available. For information about the report controls available in this toolbox, please see the Toolbox topic.

When a RDL report has focus, the ActiveReports 13 RDL Report toolbox becomes available. For information about the report controls available in this toolbox, please see the Toolbox topic.

When a Windows Form has focus, the ActiveReports 13 toolbox group offers the following Windows Forms controls:

  • ReportExplorer (requires Professional Edition license)
  • Toolbox (requires Professional Edition license)
  • Designer (requires Professional Edition license)
  • Viewer

When a Web Form has focus, the ActiveReports 13 toolbox group offers one Web control: the WebViewer (requires Professional Edition license). For more information, see Getting Started with the Web Viewer.

See Also

Toolbar
Report Explorer

Getting Started
Adding ActiveReports Controls

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Properties Window

Properties Window
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Properties Window

Glossary Item Box

The Visual Studio Properties window is an important tool when you design a report. Select any page, section, data region, control or the report itself to gain access to its properties in the Properties window. By default, this window is placed to the right of the report design area, or wherever you may have placed it in Visual Studio. You can show the list of properties by category or in alphabetical order by clicking the buttons at the top of the Properties window.

Select a property to reveal a description at the bottom of the window. Just above the description is a commands section that contains commands, links to dialogs that give you access to further properties for the item. You can resize the commands or description sections by dragging the top or bottom edges up or down.

Tip: If the commands or description section is missing in Visual Studio, you can toggle it back on by right-clicking anywhere in the Properties window and clicking Commands or Description.

In the image below, you can see a chart control selected on the designer surface, revealing its properties in the Properties window, along with any associated commands, and a description of the selected property.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

ActiveReports Designer

Getting Started
Adding an ActiveReport to a Project

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rulers

Rulers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Rulers

Glossary Item Box

In ActiveReports, rulers appear to the top and left of the Design View to guide you in vertically and horizontally aligning items in the report. They have large tick marks to indicate half inch points and smaller tick marks to indicate eighths of an inch.

Note: The numbers indicate the distance in inches from the left margin, not from the edge of the page.

Section Reports

In Section Reports, the white area on the ruler indicates the designable area of the report. The grey area at the bottom of the vertical ruler and at the right of the horizontal ruler indicate the report margins. Grab handles on the vertical ruler indicate the height of individual sections. You can drag them up or down to change section heights, or double-click to automatically resize the section to fit the controls in it.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

In a section layout, you can change ruler measurements from inches to centimeters and centimeters to inches. Use the following instructions to modify ruler measurements at design- time.

To change ruler measurements at design-time in Section Report

At design time, you can change the ruler measurements from the Report Settings Dialog.

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Global Settings.
  3. From the Ruler Units dropdown select Centimeters or Inches.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

In section reports, you can change the units of measure for the rulers. See Change Ruler Measurements for further details.

Page/RDL Reports

In Page Reports or RDL Reports, margin markers indicate the designable area of the report. The area inside the margin markers is designable, and the areas outside the markers are the margins. To change the margins, you can drag the margin markers to the desired locations.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

In a page layout, you can change ruler measurements from inches to centimeteres and centimeteres to inches. Use the following instructions to modify ruler measurements in page reports.

To change ruler measurements at design-time in Page Report

At design time, you can change the ruler measurements from the Report Dialog.

  1. In the Report Explorer, select the Report node.
  2. In the command section of the Properties Window, click Property dialog.
  3. In the dialog that appears, go to the General tab.
  4. From the Ruler Units dropdown select Centimeters or Inches.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Design View

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Scroll Bars

Scroll Bars
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Scroll Bars

Glossary Item Box

Scroll Bars appear automatically when controls or data regions do not fit the visible area of the report design surface. A scroll bar consists of a shaded column with a scroll arrow at each end and a scroll box (also called a thumb) between the arrows. You can scroll up, down, right or left using the scroll arrow buttons, scroll box or mouse wheel.

Auto Scrolling

When a user drags a control beyond the edge of the design surface and the mouse pointer reaches near the surface edge, scrolling starts automatically in the direction of the mouse movement. Auto scrolling works in all four directions. This feature is useful while designing reports with a magnified design view.

Note: In Section Layout and Report Definition Language (RDL), when the mouse button is released during auto scrolling at a location outside the design surface, the surface extends to accommodate the control.

Scrolling stops in the following scenarios:

  • The user stops dragging the mouse (Mouse Up).
  • The user moves the mouse in the opposite direction.
  • The [Esc] key is pressed while dragging the mouse.
Tip: To enable auto scrolling for multiple controls, hold down the [Ctrl] or [Shift] key to select the controls. Drag them together to the edge of the design surface and enable auto scrolling.

See Also

Zoom Support
Design View

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Snap Lines

Snap Lines
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Snap Lines

Glossary Item Box

Show All Show All
Hide All Hide All

Snap lines assist in accurate positioning of elements on a report design surface while you drag report controls on it. These dynamic horizontal and vertical layout guidelines are similar to the ones found in Visual Studio. You can see snap lines on the ActiveReports Designer as well as the Stand-alone designer application.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Snap lines appear on the design surface by default. In order to disable them, click the Snap Lines button below the design surface, or in section reports, hold down the [Alt] key while dragging a control to temporarily hide the snap lines.

When you drag a control on the design surface, blue snap lines appear and the control slows down as it aligns with another control or a section edge. Unless you are also using the Snap to Grid setting, with Snap Lines, the control can move freely around the report and can be placed anywhere on the design surface.

Tip: If you plan to export a report to Excel format, use snap lines to ensure that your controls are aligned in columns and rows to avoid empty cells or overlapping of controls in the spreadsheet.

Snap Line Behavior

Show On dragging with a mouse

When you drag report controls across the design surface, they snap to other controls, report and section edges. Snap lines appear when the control you are dragging aligns with any edge of any of the following:

  • Any control inside any section of the report.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  • Another control inside the same data region.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  • Parts of a data region (bands in a Banded List, or columns and rows in a Table).

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  • Report edges and section edges.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  • Other control edges while resizing with a mouse.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  • On selecting multiple items where all the items move as a single unit, snap lines appear for all items in the selection.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Show With keyboard actions

  • Use [Ctrl] + [Shift] + Arrow keys to resize the selected control from one snap line to the next.
  • Use [Ctrl] + Arrow keys to move the selected control to the next snap line.
  • Use [Ctrl] + Left mouse button to copy the control and see snap lines appear between the edges of the copied control being dragged and the original control.
Note: Snap lines do not appear when you move a control with arrow keys.

See Also

Designer Buttons
ActiveReports Designer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Zoom Support

Zoom Support
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Designer > Zoom Support

Glossary Item Box

ActiveReports allows you to zoom in or out on the report design surface for better control over your report layout. As you zoom in or out, the size of every item on the design surface changes.

In the designer, you can access the zoom feature from the Zoom bar below the report design surface where the slider thumb is set to 100% by default. The slider allows you to zoom in and out of the report designer surface. Using this slider you can magnify the layout from 50% to 400%. You can also use the zoom in (+) and zoom out (-) buttons at either end of the slider to change the zoom level.

Zoom settings are also available on the ActiveReports toolbar where you can change the zoom percentage or use the zoom in/zoom out buttons. See Toolbar for further information.

Keyboard Shortcuts

You can hold down the Ctrl key and use the mouse wheel to zoom in and zoom out of the design surface.

You can also use keyboard shortcuts for the following functions:

  • [Ctrl] + [+] : Zoom in
  • [Ctrl] + [-] : Zoom out
  • [Ctrl] + 0 : Return to 100%

See Also

Design View

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


ActiveReports Web Designer

ActiveReports Web Designer
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Web Designer

Glossary Item Box

The ActiveReports Web Designer component can be embedded into web applications to create and edit reports. The following topics explain concepts behind setting up Web Designer and using the API:

  • Web Designer Initialization
  • Web Designer Plug-ins API

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web Designer Initialization

Web Designer Initialization
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Web Designer > Web Designer Initialization

Glossary Item Box

This document provides information on how to set up Web Designer and utilize its API.

Following folders or files are mandatory to set up Web Designer:

Module | Folders/Files
Base Server API | baseServerApi.js
Web Designer | web-designer.js, web-designer.css
Vendor | vendor folder

Basic Designer Sample

The snippet below illustrates the idea how basic designer sample can be prepared:

index.html Copy Code

<!DOCTYPE html>
<html>
<head>
    <title>Web Designer Sample</title>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="x-ua-compatible" content="ie=edge">
    <!-- designer-related css -->
    <link rel="stylesheet" href="vendor/css/materialdesignicons.min.css" media="all" type="text/css" />
    <link rel="stylesheet" href="vendor/css/bootstrap.min.css" />
    <link rel="stylesheet" href="vendor/css/font-awesome.min.css">
    <link rel="stylesheet" href="vendor/css/ionicons.min.css">
    <link rel="stylesheet" href="vendor/css/fonts-googleapis.css" type="text/css">
    <link rel="stylesheet" href="web-designer.css" />
</head>
<body class="theme-blue">
    <!-- designer-related js -->
    <script src="vendor/js/jquery.min.js"></script>
    <script src="vendor/js/bootstrap.min.js"></script>
    <script src="baseServerApi.js"></script>
    <script src="web-designer.js"></script>
    <!-- designer root div -->
    <div id="designer-id" style="width: 100%; height: 100%;"></div>
    <script>
        // create designer options
        var designerOptions = GrapeCity.ActiveReports.WebDesigner.createDesignerOptions(baseServerApi);
        // render designer application
        GrapeCity.ActiveReports.WebDesigner.renderApplication('designer-id', designerOptions);
    </script>
</body>
</html>

Functions createDesignerOptions() and renderApplication() are described below.

Public API

The module web-designer.js has GrapeCity.ActiveReports.WebDesigner object providing the following Public API.

Create Designer Options

Parameters | Return Value
createDesignerOptions(designerServerApi: DesignerServerApi) | DesignerOptions

Description: Creates the default DesignerOptions to be passed to renderApplication() function. This object includes both required and optional Designer settings.

Example:

Copy Code
var designerOptions = GrapeCity.ActiveReports.WebDesigner.createDesignerOptions(baseServerApi);

For more information, see topics Designer Server API Object and Designer Options Object.

Render Designer Application

Parameters | Return Value
renderApplication(designerElementId: string, designerOptions: DesignerOptions) | void

Description: Renders Web Designer to <div> element with id designerElementId using the specified DesignerOptions object.

Example:

Copy Code
GrapeCity.ActiveReports.WebDesigner.renderApplication('designer-id', designerOptions);

Reporting API

This section contains information about functions from GrapeCity.ActiveReports.WebDesigner.api.

Create Report

The GrapeCity.ActiveReports.WebDesigner.api provides the ability to create a report using the GrapeCity.ActiveReports.WebDesigner.api.createReport() function.

Parameters | Return Value
GrapeCity.ActiveReports.WebDesigner.api.createReport(createReportOptions: CreateReportOptions) | void

Description: This function expects a single mandatory argument – CreateReportOptions object.

Create Report Options Object

Copy Code
type CreateReportOptions = {
    templateInfo?: TemplateInfo,
    dataSets?: Array<DataSetInfo>,
    // These functions can be used for making UI changes
    // (e.g. drawing overlays or switching current view)
    // while report is getting created.
    onStart?: { (): void },
    onFinish?: { (): void },
}

The mentioned objects TemplateInfo and DataSetInfo can be found below.

Template Info Object
Copy Code
// If templateInfo is specified for report creation,
// either id or content needs to be defined.
type TemplateInfo = {
    name: string,
    id?: string,
    // Template content in JSON format that can be useful
    // in case you would like to create a non-empty new report
    content?: object,
}

Data Set Info Object
Copy Code
type DataSetInfo = {
    name: string,
    id: string,
}

Example:

Copy Code
GrapeCity.ActiveReports.WebDesigner.api.createReport({
    onFinish: () => {
        console.log('An empty RDL report is created.');
    };
});

Open Report

The GrapeCity.ActiveReports.WebDesigner.api provides the ability to open a report using the GrapeCity.ActiveReports.WebDesigner.api.openReport() function.

Parameters | Return Value
GrapeCity.ActiveReports.WebDesigner.api.openReport(openReportOptions: OpenReportOptions) | void

Description: This function expects a single mandatory argument – OpenReportOptions object.

Open Report Options Object
Copy Code
type OpenReportOptions = {
    reportInfo: OpenReportInfo,
    // These functions can be used for making UI changes
    // (e.g. drawing overlays or switching current view)
    // while report is getting opened.
    onStart?: { (): void },
    onFinish?: { (): void },
}

Please find more details about OpenReportInfo object below.

Open Report Info Object
Copy Code
// For report opening either id or content has to be defined.
type OpenReportInfo = {
    name: string,
    id?: string,
    // Report content in JSON format
    content?: object,
}

Example:

Copy Code
GrapeCity.ActiveReports.WebDesigner.api.openReport({
    reportInfo: {
        id: 'MyReport.rdlx',
        name: 'MyReport.rdlx',
    }
    onFinish: () => {
        console.log('An existing report "MyReport.rdlx" is opened.');
    };
});

Save Report

The GrapeCity.ActiveReports.WebDesigner.api provides the ability to save a report using the GrapeCity.ActiveReports.WebDesigner.api.saveReport() function.

Parameters | Return Value
GrapeCity.ActiveReports.WebDesigner.api.saveReport(saveReportOptions: SaveReportOptions) | void

Description: This function expects a single mandatory argument – SaveReportOptions object.

Save Report Options Object
Copy Code
type SaveReportOptions = {
    reportInfo: SaveReportInfo,
    // These functions can be used for making UI changes
    // (e.g. drawing overlays or switching current view)
    // while report is getting opened.
    onStart?: { (): void },
    onFinish?: { (): void },
}

Please find more details about SaveReportInfo object below.

Save Report Info Object
Copy Code
type SaveReportInfo = {
    // The correct name needs to be always specified explicitly.
    name: string,
    // If an existing report is to be overwritten on saving,
    // the correct id should be specified explicitly.
    id?: string,
}

Example:

Copy Code
GrapeCity.ActiveReports.WebDesigner.api.saveReport({
    reportInfo: {
        name: 'MyReport.rdlx',
    }
    onFinish: () => {
        console.log('A new report "MyReport.rdlx" is saved.');
    };
});

Get information about Report

The GrapeCity.ActiveReports.WebDesigner.api provides the ability to get information about the currently edited report using these functions:

  • GrapeCity.ActiveReports.WebDesigner.api.getReportInfo() – this function returns CurrentReportInfo object having this structure:
    Copy Code
    // If an existing report is edited, id is defined.
// Otherwise, if a new report is edited, id is null.
type CurrentReportInfo = {
  id: string,
  name: string,
  isTemplate: boolean, // Reserved for future use.
  permissions: Array<string>,
}

    Example:

    Copy Code
    const reportInfo = GrapeCity.ActiveReports.WebDesigner.api.getReportInfo();
console.log(`Report "${reportInfo.name}" is currently edited.`);

  • GrapeCity.ActiveReports.WebDesigner.api.isReportDirty() – this function returns a Boolean value telling whether report has unsaved changes:
    Example:
    Copy Code
    const hasUnsavedChanges = GrapeCity.ActiveReports.WebDesigner.api.isReportDirty();
if (hasUnsavedChanges) console.log('Currently edited report has unsaved changes.');

Get information about ActiveReports Web Designer

The GrapeCity.ActiveReports.WebDesigner allows getting general information about Designer using these functions:

  • GrapeCity.ActiveReports.WebDesigner.getAboutInfo() - this function returns AboutInfo object containing information about application name/version and product title/version.
  • GrapeCity.ActiveReports.WebDesigner.getHelpInfos() - this function returns Array<HelpInfo> containing title/link pairs of Designer-related Help pages.

Both functions are intended for customizing information shown in File View in the corresponding areas - About and Help respectively - which are managed by aboutInfo and helpInfos properties of FileViewBaseOptions object.

Supplementary API

Focus Designer

The GrapeCity.ActiveReports.WebDesigner allows returning focus to Designer using GrapeCity.ActiveReports.WebDesigner.focus() function. Focus may be lost when plug-in components are opened or closed. Returning focus is essential to continue using Designer hotkeys like Ctrl+Z (undo), Ctrl+Y (redo), etc.

Example:

Copy Code
GrapeCity.ActiveReports.WebDesigner.focus();

APPENDIX

About Info Object

Copy Code
type AboutInfo = {
    // Application title replaces 'ActiveReports Web Designer'
    // in all the places where it is used by default.
    applicationTitle?: string,
    // Compact application title is used in places
    // where there is not enough space for a full title.
    applicationTitleCompact?: string,
    // By default the product title correlates with the back-end.
    // However, it is possible to overwrite it.
    productTitle?: string,
    // The same is applicable for the product version - by default
    // it is taken from the back-end but can be overwritten.
    productVersion?: string,
}

Help Info Object

Copy Code
type HelpInfo = {
    // Help page title
    title?: string,
    // Help page url
    link: string,
}

For Web Designer Plug-ins, see Web Designer Plug-ins API.

See Also

Designer Server API Object
Designer Options Object
Web Designer Plug-ins API
Create a Simple Web Designer Sample

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Designer Server API Object

Designer Server API Object
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Web Designer > Web Designer Initialization > Designer Server API Object

Glossary Item Box

The module baseServerApi.js contains certain functions required for Web Designer operation related to reports, data, themes, images, and report templates. These functions are described as follows.
Note: Certain properties and functions are marked 'Reserved' since these are not relevant in ActiveReports 13 (for example report revisions) but it is still required to have them for proper working of Web Designer. Web Designer is used not only in ActiveReports 13 but also in older version in ActiveReports Server.

Reports

GET REPORTS LIST

Parameters | Return Value | Response Model
getReportsList() | Promise | Array<ReportsListItem>

REPORTS LIST ITEM OBJECT

Copy Code
type ReportsListItem = {
  _id: string, // report id
  Name: string, // report name
  IsCpl: boolean, // specifies whether report is RDL or FPL
  Type: 'PageReport', // RESERVED - for now only 'PageReport' is supported
  $effectivePermissions: 'All', // RESERVED - for now only 'All' is supported
}

GET REPORT CONTENT

Parameters | Return Value | Response Model
getReportContent(options: GetReportContentOptions) | Promise | Report JSON Model

GET REPORT CONTENT OPTIONS OBJECT

Copy Code
type GetReportContentOptions {
  id: string, // report id
  version: null, // RESERVED - for now only null is supported
}

GET REPORT REVISIONS - RESERVED

Parameters | Return Value | Response Model
getReportRevisions(options: GetReportRevisionsOptions) | Promise | Array<ReportRevision>

GET REPORT REVISIONS OPTIONS OBJECT

Copy Code
type GetReportRevisionsOptions {
id: string, // report id
}

REPORT REVISION OBJECT

Copy Code
type ReportRevision = {
_id: string, // report id
Name: string, // report name
IsCpl: boolean, // specifies whether report is RDL or FPL
Type: 'PageReport', // RESERVED - for now only 'PageReport' is supported
$effectivePermissions: 'All', // RESERVED - for now only 'All' is supported
}

SAVE NEW REPORT

Parameters | Return Value | Response Model
saveNewReport(options: SaveNewReportOptions) | Promise | SaveReportResponse

SAVE NEW REPORT OPTIONS OBJECT

Copy Code
type SaveNewReportOptions = {
  name: string, // report name
  content: object, // report JSON model
}

SAVE REPORT RESPONSE OBJECT

Copy Code
type SaveReportResponse = {
  Id: string, // saved report id
}

SAVE EXISTING REPORT

Parameters | Return Value | Response Model
saveExistingReport(options: SaveExistingReportOptions) | Promise | SaveReportResponse

SAVE EXISTING REPORT OPTIONS OBJECT

Copy Code
type SaveExistingReportOptions = {
  id: string, // report id
  content: object, // report JSON model
}

SAVE TEMPORARY REPORT

Parameters | Return Value | Response Model
saveTemporaryReport(options: SaveTemporaryReportOptions) | Promise | SaveReportResponse

SAVE TEMPORARY REPORT OPTIONS OBJECT

Copy Code
type SaveTemporaryReportOptions = {
  name: string, // report name
  content: object, // report JSON model
}

DELETE TEMPORARY REPORT

This is an optional service function that is used outside of Designer. It can be used for deleting temporary reports when Report Viewer is closed and view is switched back to Designer.

Parameters | Return Value | Response Model
deleteTemporaryReport(options: DeleteTemporaryReportOptions) | Promise | DeleteReportResponse

DELETE TEMPORARY REPORT OPTIONS OBJECT

Copy Code
type DeleteTemporaryReportOptions = {
  id: string, // report id
}

DELETE REPORT RESPONSE OBJECT

Copy Code
type DeleteReportResponse = {
  Id: string, // deleted report id
}

Data

GET DATA SETS LIST

Parameters | Return Value | Response Model
getDataSetsList() | Promise | Array<DataSetsListItem>

DATA SETS LIST ITEM OBJECT

Copy Code
type DataSetsListItem = {
  id: string, // data set id
  name: string, // data set name
  version: null, // RESERVED - for now only null is supported
}

GET DATA SOURCES AND DATA SETS

Parameters | Return Value | Response Model
getDataSourcesAndDataSets(options: GetDataSourcesAndDataSetsOptions) | Promise | GetDataSourcesAndDataSetsResponse

GET DATA SOURCES AND DATA SETS OPTIONS OBJECT

Copy Code
type GetDataSourcesAndDataSetsOptions = {
  dataSetInfo: {
    id: string, // data set id
    name: string, // data set name
    version: null, // RESERVED - for now only null is supported
  },
  dataSourceInfo: object, // RESERVED
  reportDataSets: Array<DataSet>, // data sets used in report
  reportDataSources: Array<DataSource>, // data sources used in report
}

GET DATA SOURCES AND DATA SETS RESPONSE OBJECT

Copy Code
type GetDataSourcesAndDataSetsResponse = {
  dataSources: Array<DataSource>,
  dataSets: Array<DataSet>,
}

GET DATA SET CONTENT

This function is intended to be used in getDataSourcesAndDataSets(). The result dataSetContent object may store information required to create a data set and its parent data source.

Parameters | Return Value | Response Model
getDataSetContent(options: GetDataSetContentOptions) | Promise | dataSetContent: object

GET DATA SET CONTENT OPTIONS OBJECT

Copy Code
type GetDataSetContentOptions = {
  id: string, // data set id
}

DATA SOURCE AND DATA SET OBJECTS

Basic properties of DataSource and DataSet types are listed. Object models of DataSource and DataSet correlate with their structure in RDLX report definition.

Copy Code
type DataSource = {
  Name: string, // data source name
  ConnectionProperties: {
    ConnectString: string, // connection string
    DataProvider: string, // data provider - see AR Documentation
  },
  // ... more properties - see AR Documentation
}
type DataSet = {
  Name: string, // data set name
  Fields: Array<Field>, // data set fields
  Query: {
    DataSourceName: string, // parent data source name
    CommandType: 'Text' | 'StoredProcedure', // query command type
    CommandText: string, // query command text
    QueryParameters: Array<QueryParameter>,
  }
  // ... more properties - see AR Documentation
}
type Field = {
  Name: string, // field name
  // Either DataField or Value needs to be available.
  DataField?: string, // data field name - valid for bound fields
  Value?: string, // field value - valid for calculated fields
  /* Extra optional properties */
  // default field aggregate - see AR Documentation for more available aggregates
  Aggregate?: 'Count' | 'Sum' | 'Max' | 'Min' /* etc. */,
  // field data type
  DataType?: 'String' | 'Integer' | 'Float' | 'Number' | 'Boolean' | 'DateTime',
}
type QueryParameter = {
  Name: string, // query parameter name
  Value: string, // query parameter value
}

Themes

GET THEMES LIST

Parameters | Return Value | Response Model
getThemesList() | Promise | Array<ThemesListItem>

THEMES LIST ITEM OBJECT

Copy Code
type ThemesListItem = {
  _id: string, // theme id
  Name: string, // theme name
  IsDefault: boolean, // specifies whether theme is default or not, only a single theme can be default
  Dark1: string, // Dark1 theme color
  Dark2: string, // Dark2 theme color
  Light1: string, // Light1 theme color
  Light2: string, // Light2 theme color
  Accent1: string, // Accent1 theme color
  Accent2: string, // Accent2 theme color
  Accent3: string, // Accent3 theme color
  Accent4: string, // Accent4 theme color
  Accent5: string, // Accent5 theme color
  Accent6: string, // Accent6 theme color
  MajorFontFamily: string, // Major text theme font family
  MinorFontFamily: string, // Minor text theme font family
}

GET THEME CONTENT

Parameters | Return Value | Response Model
getThemeContent(options: GetThemeContentOptions) | Promise | ThemeModel

GET THEME CONTENT OPTIONS OBJECT

Copy Code
type GetThemeContentOptions = {
  id: string, // theme id
}

THEME MODEL OBJECT

Copy Code
type ThemeModel = {
  Colors: {
    Dark1: string, // Dark1 theme color
    Dark2: string, // Dark2 theme color
    Light1: string, // Light1 theme color
    Light2: string, // Light2 theme color
    Accent1: string, // Accent1 theme color
    Accent2: string, // Accent2 theme color
    Accent3: string, // Accent3 theme color
    Accent4: string, // Accent4 theme color
    Accent5: string, // Accent5 theme color
    Accent6: string, // Accent6 theme color
    Hyperlink: string, // Hyperlink theme color
    HyperlinkFollowed: string, // Followed hyperlink theme color
  },
  Fonts: {
    MajorFont: ThemeFont,
    MinorFont: ThemeFont,
  }
  Images: Array<ThemeImage>,
  Constants: Array<ThemeConstant>,
}
type ThemeFont = {
  Family: string, // font family
  Style: string, // font style
  Size: string, // font size
  Weight: string, // font weight
}
type ThemeImage = {
  Name: string, // image name
  MIMEType: string, // image MIME type
  ImageData: string, // Base64 image data
}
type ThemeConstant = {
  Key: string, // constant key
  Value: string, // constant value
}

Images

GET IMAGES LIST

Parameters | Return Value | Response Model
getImagesList() | Promise | Array<ImagesListItem>

IMAGES LIST ITEM OBJECT

Copy Code
type ImagesListItem = {
  _id: string, // image id
  Name: string, // image name
  MimeType: string, // image MIME type
  Thumbnail: null, // RESERVED - for now only null is supported
}

GET IMAGE URL

This url is used to display external image in design-time.

Parameters | Return Value
getImageUrl(options: GetImageUrlOptions) | imageUrl: string

GET IMAGE URL OPTIONS OBJECT

Copy Code
type GetImageUrlOptions = {
  id: string, // image id
}

Report Templates

GET TEMPLATES LIST

This function can be used in some custom File View implementation.

Parameters | Return Value | Response Model
getTemplatesList() | Promise | Array<TemplatesListItem>

TEMPLATES LIST ITEM OBJECT

Copy Code
type TemplatesListItem = {
  _id: string, // template id
  Name: string, // template name
}

GET TEMPLATE CONTENT

Parameters | Return Value | Response Model
getTemplateContent(options: GetTemplateContentOptions) | Promise | Report JSON Model

GET TEMPLATE CONTENT OPTIONS OBJECT

Copy Code
type GetTemplateContentOptions = {
  id: string, // template id
}

GET TEMPLATE THUMBNAIL

This function can be used in some custom File View implementation.

Parameters | Return Value | Response Model
getTemplateThumbnail(options: GetTemplateThumbnailOptions) | Promise | base64ImageData: string

GET TEMPLATE THUMBNAIL OPTIONS OBJECT

Copy Code
type GetTemplateThumbnailOptions = {
  id: string, // template id
}

Miscellaneous

CREATE RESOURCE LINK

This function creates a resource (report/image/theme) link to be stored in RDLX report definition. The Resource links are then resolved while rendering report. These links need to be correct for successful report preview.

Parameters | Return Value
createResourceLink(options: ResourceLinkOptions) | resourceLink: string

RESOURCE LINK OPTIONS OBJECT

Copy Code
type ResourceLinkOptions = {
  id: string, // resource id
  type: 'report' | 'image' | 'theme' | null, // resource type
  version: null, // RESERVED - for now only null is supported
}

PARSE RESOURCE LINK

The opposite operation to createResourceLink().

Parameters | Return Value
parseResourceLink(resourceLink: string) | ResourceLinkOptions

UPDATE ROUTE

This function can be used to update Designer url when a new or an existing report editing is started.

Parameters | Return Value
updateRoute(options: UpdateRouteOptions) | void

UPDATE ROUTE OPTIONS OBJECT

Copy Code
type UpdateRouteOptions = {
  id: string, // report id
  version: null, // RESERVED - for now only null is supported
}

See Also

Web Designer Plug-ins API

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Designer Options Object

Designer Options Object
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Web Designer > Web Designer Initialization > Designer Options Object

Glossary Item Box

Show All Show All
Hide All Hide All

This topic describes Designer Options Object Properties.

Show serverApi

Description: Specifies server-api calls for getting server resources, for example, reports, themes, data-sets, etc.

Type: DesignerServerApi

Show reportInfo (optional)

Description: If report id is specified, the corresponding report will be opened in designer when designer application is rendered.

Type:

{ id?: string }

Example:
designerOptions.reportInfo.id = 'MyReport.rdlx';

Show locale (optional)

Description: If the locale value is not specified explicitly here, the locale corresponding to the browser preferences is used.

Type: 'en' | 'zh' | 'ja'

Example:
designerOptions.locale = 'zh';

Show units (optional)

Description: If measurement units are not specified explicitly here, they are identified depending on locale.

Type: 'in' | 'cm'

Example:

designerOptions.units = 'cm';

Show reportItems (optional)

Description: It is possible to limit and/or reorder available report items. Specify comma-separated report items keys from following: TextBox, CheckBox, Container, Line, Shape, TableOfContents, Image, List, Table, Tablix, Chart, Bullet, Barcode, FormattedText, Sparkline, Subreport, and OverflowPlaceholder.

Type: string

Example:
designerOptions.reportItems = 'TextBox,CheckBox,Table,Chart,Image';

Show lockLayout

Description: By default lockLayout is disabled. When lockLayout is enabled, it is only possible to modify properties of existing report items. That is, adding a new report item or deleting an existing one is not possible as well as other operations that modify report layout structure.

Type: boolean

Example:

designerOptions.lockLayout = true;

Show restoreUnsavedReport

Description: By default restoreUnsavedReport is enabled. In this case the last unsaved report can be restored if browser tab or browser itself gets accidentally closed. When restoreUnsavedReport is disabled, the aforementioned functionality is not available.

Type: boolean

Example:
designerOptions.restoreUnsavedReport = false;

Show saveButton

Description: Specifies whether Save button needs to be shown. Save button is not visible by default.

Type:

{ visible: boolean }

Example:

designerOptions.saveButton.visible = true;

Show saveAsButton

Description: Specifies whether Save As button needs to be shown. Save As button is not visible by default.

Type:

{ visible: boolean }

Example:
designerOptions.saveAsButton.visible= true;

Show reportExplorer

Description: Specifies whether Report Explorer button needs to be shown. Report Explorer button is visible by default.

Type:

{ visible: boolean }

Example:

designerOptions.reportExplorer.visible= false;

Show groupEditor

Description: Specifies whether Group Editor button needs to be shown. Group Editor button is visible by default.

Type:

{ visible: boolean }

Example:
designerOptions.groupEditor.visible = false;

Show toolBox

Description: Specifies whether left-side menu Toolbox needs to be shown. Toolbox is visible by default.

Type:

{ visible: boolean }

Example:
designerOptions.toolBox.visible = false;

Show insertTab

Description: Specifies whether application bar menu Insert Tab needs to be shown. Insert Tab is not visible by default. Toolbox and Insert Tab are interchangeable.

Type:

{ visible: boolean }

Example:

designerOptions.insertTab.visible = true;

Show propertiesTab

Description:

  • visible - Specifies whether Properties Tab needs to be shown. Properties Tab is visible by default.
  • mode - Specifies available properties modes. The default value is 'Both'.
  • dataSets -
    • visible - Specifies whether Data Sets section needs to be shown. 'Data Sets' section is visible by default.
    • canModify - Specifies whether it is possible to modify (including add/remove) data sets. By default this feature is disabled.
  • defaultMode - Relevant only when mode is 'Both'. If undefined, the last used properties mode is set.

Type:
{
visible: boolean,
mode: 'Both' | 'Advanced' | 'Basic',
defaultMode?: 'Advanced' | 'Basic',
}

Example:

designerOptions.propertiesTab.visible = false;

designerOptions.propertiesTab.mode = 'Basic';
designerOptions.propertiesTab.defaultMode = 'Advanced';

Show dataTab

Description:

  • visible - Specifies whether Data Tab needs to be shown. Data Tab is visible by default.
  • dataSources -
    • visible - Specifies whether Data Sources section needs to be shown. Data Sources section is visible by default.
  • dataSets -
    • visible - Specifies whether Data Sets section needs to be shown. Data Sets section is visible by default.
    • canModify - Specifies whether it is possible to modify (including add/remove) data sets. By default this feature is disabled.
  • parameters -
    • visible - Specifies whether Parameters section needs to be shown. Parameters section is visible by default.
    • canModify - Specifies whether it is possible to modify (including add/remove) report parameters. By default this feature is enabled.
  • commonValues -
    • visible - Specifies whether Common Values section needs to be shown. Common Values section is visible by default.

Type:
{
visible: boolean,
dataSources: {
visible: boolean,
},
dataSets: {
visible: boolean,
canModify: boolean,
},
parameters: {
visible: boolean,
canModify: boolean,
},
commonValues: {
visible: boolean,
},
}

Example:

designerOptions.dataTab.visible = false;

designerOptions.dataTab.dataSources.visible = false;
designerOptions.dataTab.dataSets.visible = false;

designerOptions.dataTab.dataSets.canModify = true;

designerOptions.dataTab.parameters.visible = false;

designerOptions.dataTab.parameters.canModify = false;

designerOptions.dataTab.dataSources.visible = false;

Show gridSize

Description:

  • visible - Specifies whether Grid Size editor in Status Bar needs to be shown. Grid Size editor is visible by default.
  • value - If Grid Size editor is not visible, it is possible to specify grid size value in in/cm (inches or centimeters).
Type:
{
visible: boolean,
value?: string,
}

Example:

designerOptions.gridSize.visible = false;

designerOptions.gridSize.value = '0.75cm';
/* or */
designerOptions.gridSize.value = '0.5in';

Show showGrid

Description:

  • visible - Specifies whether Show Grid toggle in Status Bar needs to be shown. Show Grid toggle is visible by default.
  • value - If Show Grid toggle is not visible, it is possible to specify show grid value as true or false.
Type:
{
visible: boolean,
value?: boolean,
}

Example:

designerOptions.showGrid.visible = false;

designerOptions.showGrid.value = false;

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web Designer Plug-ins API

Web Designer Plug-ins API
ActiveReports 13 > ActiveReports User Guide > Concepts > ActiveReports Web Designer > Web Designer Plug-ins API

Glossary Item Box

It is possible to plug-in certain external components to Designer by means of DesignerOptions object.

Copy Code
{
    // Determines whether File View is available and
    // how File View is rendered. The function is optional.
    openFileView?: { (fileViewBaseOptions: FileViewBaseOptions): void },
    // Determines whether Viewer is available and
    // how Viewer is rendered. The function is optional.
    openViewer?: { (viewerBaseOptions: ViewerBaseOptions): void },
    // Determines what happens when report save procedure is initiated.
    // For example, 'silent' save could be performed here for an existing report.
    onSave?: { (saveBaseOptions: SaveBaseOptions): void },
    // Determines what happens when report save as procedure is initiated.
    // For example, save as dialog could be opened here for a new report.
    onSaveAs?: { (saveBaseOptions: SaveBaseOptions): void },
    dataSetPicker: {
        // If mode is 'Panel', then data set picker is rendered within 'Data Tab'.
        // Otherwise, it is up to user to manage how data set picker is rendered.
        mode: string,
        // Specifies what happens on opening data set picker.
        open?: { (openDataSetPickerBaseOptions: OpenDataSetPickerBaseOptions): void },
        // Specifies what happens on closing data set picker.
        close?: { (): void },
    },
}

The details of plug-in components are as follows:

File View

You can plug-in File View component by providing openFileView() function implementation to DesignerOptions object.
When openFileView() is implemented and passed to DesignerOptions, File Tab appears in Designer application bar.

Parameters
openFileView(fileViewBaseOptions: FileViewBaseOptions)

Return Value
void

File View Base Options Object

Copy Code
type FileViewBaseOptions = {
    locale: 'en' | 'ja' | 'zh', // Designer passes its locale.
    mode: 'new' | 'open' | 'saveAs', // Designer requests File View to be opened in the specified mode.
    // Information about the currently edited report
    reportInfo: FileViewReportInfo,
    // About info is either passed from Designer,
    // or can be explicitly overwritten for File View.
    aboutInfo?: AboutInfo,
    // Help infos are either passed from Designer,
    // or can be explicitly overwritten for File View.
    helpInfos?: Array<HelpInfo>,
}

You can find information about objects FileViewReportInfo, AboutInfo and HelpInfo below.

File View Report Info Object
Copy Code
type FileViewReportInfo = {
    id?: string,
    name: string,
    permissions: Array<string>,
    isTemplate?: boolean, // Reserved for future use.
}

Example

In sample code below you will see that several Designer Server API functions and Designer Reporting API functions are used while plugging-in some custom File View to Designer.

Copy Code
<link rel="stylesheet" href="sample-file-view.css" />
<!-- ... -->
< script src="sample-file-view.js"></script>
<!-- ... -->
< div id="sample-file-view-id" style="width: 100%; height: 100%; display: none;"></div>
<script>
  function openFileViewImpl(fileViewBaseOptions) {
    // ... hide Designer and show File View
    function addOptions(baseOptions, additionalOptions) {
      return $.extend({}, baseOptions || {}, additionalOptions || {});
    }
    var fileViewOptions = addOptions(fileViewBaseOptions, {
      onClose: function () {
        // ... hide File View and show Designer
      },
      serverApi: {
        getReportsList: baseServerApi.getReportsList,
        getReportRevisions: baseServerApi.getReportRevisions,
        getDataSetsList: baseServerApi.getDataSetsList,
        getTemplatesList: baseServerApi.getTemplatesList,
        getTemplateThumbnail: baseServerApi.getTemplateThumbnail,
      },
      createReport: GrapeCity.ActiveReports.WebDesigner.api.createReport,
      openReport: GrapeCity.ActiveReports.WebDesigner.api.openReport,
      saveReport: GrapeCity.ActiveReports.WebDesigner.api.saveReport,
    });
    sampleFileView.render('sample-file-view-id', fileViewOptions);
  }
  // ... create designer options
  designerOptions.openFileView = openFileViewImpl;
  // ... render designer application
</script>

Report Viewer

You can plug-in Report Viewer component by providing openViewer() function implementation to DesignerOptions object.
When openViewer() is implemented and passed to DesignerOptions, Preview button appears in Designer application bar.

Parameters
openViewer(viewerBaseOptions: ViewerBaseOptions)

Return Value
void

Viewer Base Options Object

Copy Code
type ViewerBaseOptions = {
 locale: 'en' | 'ja' | 'zh', // Designer passes its locale.
 // Information about the report to-be-previewed
 reportInfo: ViewerReportInfo,
}

You can find information about ViewerReportInfo object below.
Viewer Report Info Object
Copy Code
type ViewerReportInfo = {
    id?: string,
    // Report content in JSON format that can be useful
    // for report viewers with in-browser rendering
    content?: object,
    name: string,
    // Specifies whether the report to-be-previewed
    // is an existing report saved on server.
    isTemporary?: boolean,
}

Example:

In sample code below you will see how some custom Report Viewer can be plugged-in to Designer.

Copy Code
<link rel="stylesheet" href="sample-viewer.css" />
<!-- ... -->
< script src="sample-viewer.js"></script>
<!-- ... -->
< div id="sample-viewer-id" style="width: 100%; height: 100%; display: none;"></div>
<script>
  function openViewerImpl(viewerBaseOptions) {
    // ... hide Designer and show Report Viewer
    function addOptions(baseOptions, additionalOptions) {
      return $.extend({}, baseOptions || {}, additionalOptions || {});
    }
    var viewerOptions = addOptions(viewerBaseOptions, {
      onClose: function () {
        // ... hide Report Viewer and show Designer
      },
    });
    sampleViewer.render('sample-viewer-id', viewerOptions);
  }
  // ... create designer options
  designerOptions.openViewer = openViewerImpl;
  // ... render designer application
</script>

Behavior On Save / Save As

You can specify behavior for Save / Save As scenarios by providing onSave() / onSaveAs() functions implementations to DesignerOptions object.

Parameters | Return Value
onSave(saveBaseOptions: SaveBaseOptions) | void
onSaveAs(saveBaseOptions: SaveBaseOptions) | void

Save Base Options Object

Copy Code
type SaveBaseOptions = {
    locale: 'en' | 'ja' | 'zh', // Designer passes its locale.
    reportInfo: SaveReportInfo,
    onSuccess: { (): void },
}

You can find information about SaveReportInfo object below.

Save Report Info Object
Copy Code
type SaveReportInfo = {
 name: string,
 id?: string,
 // Report content in JSON format.
 content?: object,
}

Example:

In sample code below you will see how some custom Save / Save As behavior can be plugged-in to Designer.
Several Designer Server API functions and Designer Reporting API functions are used here.

Copy Code
<link rel="stylesheet" href="sample-save-as-dialog.css" />
<!-- ... -->
< script src="sample-save-as-dialog.js"></script>
<!-- ... -->
< div id="sample-save-as-dialog-id" style="position: absolute; top: 0; left: 0; width: 100%; height: 100%; display: none; z-index: 9999;"></div>
<script>
  function onSaveImpl(saveBaseOptions) {
    // An existing report is saved silently,
    // i.e. no dialogs appear.
    GrapeCity.ActiveReports.WebDesigner.api.saveReport({
      reportInfo: {
        id: saveBaseOptions.reportInfo.id,
        name: saveBaseOptions.reportInfo.name,
      },
    });
  }
  function onSaveAsImpl(saveBaseOptions) {
    // ... show Save As dialog
    function addOptions(baseOptions, additionalOptions) {
      return $.extend({}, baseOptions || {}, additionalOptions || {});
    }
    var saveOptions = addOptions(saveBaseOptions, {
      onClose: function () {
        // ... hide Save As dialog
        GrapeCity.ActiveReports.WebDesigner.focus();
      },
      serverApi: {
        getReportsList: baseServerApi.getReportsList,
      },
      saveReport: GrapeCity.ActiveReports.WebDesigner.api.saveReport,
    });
    sampleSaveAsDialog.render('sample-save-as-dialog-id', saveOptions);
  }

  // ... create designer options
  designerOptions.saveButton.visible = true;
  designerOptions.onSave = onSaveImpl;
  designerOptions.saveAsButton.visible = true;
  designerOptions.onSaveAs = onSaveAsImpl;
  // ... render designer application
</script>

Data Set Picker

You can specify behavior on clicking Add Data Set button from Data tab Data Sets section.

Parameters

Parameters | Return Value
dataSetPicker.open(openDataSetPickerBaseOptions: OpenDataSetPickerBaseOptions) | void
dataSetPicker.close() | void

Open Data Set Picker Base Options Object

Copy Code
type OpenDataSetPickerBaseOptions = {
  locale: 'en' | 'ja' | 'zh', // Designer passes its locale.
 // If mode is 'Panel', data set picker is rendered within 'Data Tab'.
 mode: string,
 // If mode is not 'Panel', data set picker is rendered to element with this id.
 elementId?: string,
 // Data sources from report
 reportDataSources: Array<DataSource>,
 // Data sets from report
 reportDataSets: Array<DataSet>,
 // New data sources and data sets to be added are passed as parameters to this function.
 addDataSourcesAndDataSets: { ({ dataSources: Array<DataSource>, dataSets: Array<DataSet> }): void },
 // Specifies what should happen on closing data set picker.
 onClose: { (): void },
}

Regarding DataSource and DataSet types, see Data Source And Data Set Objects.

Example:

In sample code below you will see how some custom data set picker can be plugged-in to Designer.
Several Designer Server API functions and Designer Reporting API functions are used here.

Copy Code
<link rel="stylesheet" href="sample-data-set-picker.css" />
<!-- ... -->
< script src="sample-data-set-picker.js"></script>
<!-- ... -->
< div id="sample-data-set-picker-dialog-id" style="position: absolute;top: 0;left: 0;width: 100%;height: 100%;display: none;z-index: 9999;"></div>
<script>
  function openDataSetPickerImpl(openDataSetPickerBaseOptions) {
    function addOptions(baseOptions, additionalOptions) {
      return $.extend({}, baseOptions || {}, additionalOptions || {});
    }
    var openInPanel = options.mode === 'Panel';
    var openDataSetPickerOptions = addOptions(openDataSetPickerBaseOptions, {
      onClose: function () {
        options.onClose();
        if (!openInPanel) // ... hide Data Set Picker
        // ... dispose Data Set Picker and show Designer
      },
      serverApi: {
        getDataSetsList: baseServerApi.getDataSetsList,
        getDataSourcesAndDataSets: baseServerApi.getDataSourcesAndDataSets,
      },
    });
    if (!openInPanel) // ... show Data Set Picker
    var dataSetPickerId = openInPanel ? options.elementId : 'sample-data-set-picker-dialog-id';
    sampleDataSetPicker.render(dataSetPickerId, openDataSetPickerOptions);
  }
  function closeDataSetPickerImpl() {
    // ... dispose Data Set Picker and show Designer
  }
  // ... create designer options
  designerOptions.dataTab.dataSets.canModify = true;
  designerOptions.dataSetPicker.mode = 'Panel';
  designerOptions.dataSetPicker.open = openDataSetPickerImpl;
  designerOptions.dataSetPicker.close = closeDataSetPickerImpl;
  // ... render designer application
</script>

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Types

Report Types
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Report Types

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides a number of ways to design a report. You can choose a report type based on your layout requirements. Depending on the type of report you select, you also get various file formats to create your reports.

In this section

Report Definition Language (RDL) Report

Page Report

Code-Based Section Report

XML-Based Section Report

Report Layout Types

You can design reports using different layouts depending on your requirements. This section introduces these layout types and describes the differences between them to allow you to select the one that suits your report.

Show Page Layout

In a Page Layout, you design reports at the page level without any banded sections. This lets you place controls anywhere on the report.

In a Page report, controls do not change in size based on the data, but you can use an Overflow Place Holder to handle any extra data.

Show RDL Layout

In a RDL report, controls grow vertically to accommodate data.Controls can grow and shrink, you can set up interactive sorting, you can set up drill-down reports in which detail data is initially hidden, and can be toggled by other items, and you can add drill-through links to other reports and to bookmark links within reports.

Show Section Layout

In a Section Layout, you design reports in banded sections. A PageHeader, Detail and PageFooter section appear by default, and you can remove any but the detail section. Right-click the report and select Insert to add other section pairs like ReportHeader and ReportFooter, or GroupHeader and GroupFooter.

A report section contains a group of controls that are processed and printed at the same time as a single unit. All sections except the detail section come in pairs, above and below the detail section. When you use group headers and footers, the detail section processes for each group, and then the next group processes a group header, related details, and group footer. See Grouping Data for more information.

You can hide any section that you do not want shown by setting the Visible property of the section to False.

Report File Format Types

You can create reports in a number of file formats with a varied set of features. This section describes the use of each of these file formats.

Show Report Template Formats

To create a report, a user must select one of the following templates containing the report layout. See Adding an ActiveReport to a Project for details on how to access report templates.

  • RDLX: This is an XML-based proprietary file format that provides custom extensions to the Report Definition Language (RDL) files used by SQL Server Reporting Services. These are stand-alone files that you can process without compiling them into your application. You can customize the report through the Script Tab by embedding script in the report.
    See this msdn page for more on RDL report.
  • VB or CS: These are code-based reports, and are saved as C# or Visual Basic files that are compiled into your applications. They have corresponding code views similar to Windows forms and provide a design and coding experience in line with Visual Studio. This format is ideal for developers who are comfortable with coding in .NET programming languages and would like to use the extensive event-based API provided by ActiveReports in the code-behind rather than design view. You may also use the scripts in the Script Tab instead of the code behind.
  • RPX: This is an XML-based proprietary file format that the ActiveReports engine can process without compiling it into an application. Instead of Visual Basic or C# code behind, you can customize the report with script embedded in the report XML using the Script Tab. You can also use an RPX file with script as a stand-alone file in a Web project.

Show Additional File Formats

ActiveReports also provides some additional file formats for reports. Each of these formats is used for a specific purpose as described below.

  • RDLX-master: This is a master report file that you can reference from other RDLX report files for a standard layout, for example, you can add company logo and address sections. This file is loaded each time the report is executed, so you can change the logo on all of your reports by just changing it on the master report.
  • RDLX-theme: This is a theme file that consists of a collection of styles that you can apply to a report. See Themes for further details.
  • RDSX: This is a proprietary format that is created when you share a data source, making it available to multiple reports.
  • RDF: This is the Report Document Format, in which the data is static. You can save a report in this format to display the data that is retrieved. Once a report has been saved to an RDF file, it can be loaded into the viewer control. See Save and Load RDF Report Files for further details.

See the following list of file formats available in each layout.

Format | Page Layout/RDL Layout | Section Layout
RDLX | ✓ | ✘
VB or CS | ✘ | ✓
RPX | ✘ | ✓
RDLX-Master | ✓ | ✘
RDLX-Theme | ✓ | ✘
RDSX | ✓ | ✘
RDF | ✘ | ✓

Show Features comparison between report types

In ActiveReports, the features available in a report depend on the type of report you select. See the following comparison list of features with each report type:

Feature | Section report | Page report | RDL report
Viewers & Editors |  |  |
Visual Studio Integrated Designer | ✓ | ✓ | ✓
Expressions Editor | ✘ | ✓ | ✓
Designer Script Editor | ✓ | ✓ | ✓
Windows Form Viewer | ✓ | ✓ | ✓
WebViewer (Pro Edition). Includes viewer types HTML, RawHTML, and PDF. | ✓ | ✓ | ✓
HTTP Handlers (Pro Edition) | ✓ | ✓ | ✓
Report Controls |  |  |
BandedList | ✘ | ✓ | ✓
List | ✘ | ✓ | ✓
Tablix | ✘ | ✓ | ✓
Table | ✘ | ✓ | ✓
OverflowPlaceHolder | ✘ | ✓ | ✘
Chart | ✓ | ✓ | ✓
Barcode | ✓ | ✓ | ✓
Bullet | ✘ | ✓ | ✓
CheckBox | ✓ | ✓ | ✓
Container | ✘ | ✓ | ✓
CrossSectionLine | ✓ | ✘ | ✘
CrossSectionBox | ✓ | ✘ | ✘
FormattedText | ✘ | ✓ | ✓
Image | ✘ | ✓ | ✓
Label | ✓ | ✘ | ✘
Line | ✓ | ✓ | ✓
PageBreak | ✓ | ✘ | ✘
Picture | ✓ | ✘ | ✘
ReportInfo | ✓ | ✘ | ✘
RichTextBox | ✓ | ✘ | ✘
Shape | ✓ | ✓ | ✓
Sparkline | ✘ | ✓ | ✓
SubReport | ✓ | ✓ | ✓
TextBox | ✓ | ✓ | ✓
TableOfContents | ✘ | ✓ | ✓
Interactivity |  |  |
Hyperlinks | ✓ | ✓ | ✓
Parameters | ✓ | ✓ | ✓
Drill through | ✘ | ✓ | ✓
Drill down | ✓ | ✘ | ✓
Filtering | ✘ | ✓ | ✓
Grouping | ✓ | ✓ | ✓
Sorting | ✘ | ✓ | ✓
Data Connections |  |  |
Standard Data Sources supported (e.g. SQL, OleDB, XML) | ✓ | ✓ | ✓
Unbound Data Source | ✓ | ✓ | ✓
Shared Data Source | ✘ | ✓ | ✓
Export |  |  |
Export Filters | ✓ | ✓ | ✓
Rendering Extensions | ✘ | ✓ | ✓
PDF advanced export features: digital signatures, time stamp, bold font emulation (Pro Edition) | ✓ | ✓ | ✓
Miscellaneous |  |  |
Master Reports | ✓ | ✘ | ✓
Themes | ✘ | ✓ | ✓
Collation | ✘ | ✓ | ✓
Styles (through Report Settings dialog) | ✓ | ✘ | ✘
Printing | ✓ | ✓ | ✓
Stand-alone Applications |  |  |
ActiveReports Viewer | ✓ | ✓ | ✓
ActiveReports Theme Editor | ✘ | ✓ | ✓
ActiveReports Designer (stand-alone application) | ✓ | ✓ | ✓

See Also

Concepts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page Report

Page Report
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Report Types > Page Report

Glossary Item Box

The new Page report offers you a way to create very specific styles of reports that are very difficult, if not impossible, in other .NET reporting tools. You design this type of report on a page where none of the report controls can grow or shrink at run time, making it ideal for duplicating legacy paper forms.

As with all Page reports, instead of report sections where you place report controls, you place data regions and controls directly on the page. But with Page reports, there is no need to use code or add measurements to make sure that everything fits. Unlike the RDL Report, the controls remain fixed at run time, so you can drop a table on the report, set a property to size it exactly how you want it, and have something very close to a WYSIWYG report at design time.

One row of data per page or one group per page

By default, all of the records are in one group, but you can set page level grouping to render one row of data on each page. This is ideal for something like a tax form that you want to print for every client or every employee, or an invoice that you want to print for every customer. For more information, see Grouping in a fixed page.

Where does the rest of the data go?

If there is data that does not fit within the space allocated for the data region at design time, you can assign it to flow into an OverflowPlaceholder control. This can go on the same page in a different area, for example, in the form of columns, or it can go on a separate page. For more information, see OverflowPlaceholder and Overflow Data in a Single Page.

Additional pages

You can run an entire report using the same page layout for every page, which is useful for something like an invoice, but does not satisfy every reporting need.

For other types of reports, you can add pages and create different layouts for each one, or duplicate a page you have already created. This can save a lot of time and effort when you have a report with many precisely placed controls, and you need additional pages that duplicate many of them. For example, when you need to provide employees with federal, state, and city copies of tax forms that have only one label changed. For more information, see Overflow Data in Multiple Pages.

You can also insert new pages between existing ones, and drag page tabs to rearrange them. With multiple pages, you can also choose how to collate the pages at run time. For more information, see how to Set Up Collation and Collate Multiple Copies of a Report.

Caution: Page Reports do not support nested data regions. A red border indicating overlapping of controls appears around the nested data region, on placing one data region inside another.

See Also

Toolbox

Walkthroughs
Page Report/RDL Report Walkthroughs

How To
Work with Report Controls and Data Regions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Definition Language (RDL) Report

Report Definition Language (RDL) Report
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Report Types > Report Definition Language (RDL) Report

Glossary Item Box

The Report Definition Language (RDL) report is the most interactive type of report that we offer. Controls can grow and shrink, you can set up interactive sorting, you can set up drill-down reports in which detail data is initially hidden, and can be toggled by other items, and you can add drill-through links to other reports and to bookmark links within reports.

When you add a RDL report to a project, the OverflowPlaceholder control disappears from the toolbox, and the page tabs disappear from below the report design surface.

Master Reports

One way in which RDL reports differ from Page reports is the ability to create and use master reports. A master report is one that you use to add common report functionality like data, company logos, and page headers or footers, while using the ContentPlaceHolder control to designate areas where content reports can add data. In this way, you can quickly change the data source or company address and logo for an entire suite of reports in one convenient place. For more information, see Master Reports.

Page Break

RDL reports provides you the ability to add a page break by using the PageSize setting or by specifying the PageBreakBefore and PageBreakAfter properties of data region, group, and rectangle. In addition to the traditional print preview mode that allows you to consider the sheet size while printing a report, it also provides a galley mode wherein you can browse all your data in a single sheet. In RDL reports, you can easily verify data that does not include any page breaks, therefore it can be more appropriately used for browsing laterally extended reports that use controls like Tablix data region or for previewing reports that includes large amount of data.

Themes

Both Page and RDL reports can use themes to apply standard formatting to a range of report controls. Like using a master report, this allows you to change the look of a whole suite of reports in one place. You can specify colors for text and background, hyperlink colors, major and minor fonts, images, and constants, and then specify theme values in report control properties. When you want to change the look, you can do it all in the *.rdlx-theme file and it will apply to each report when it runs. For more information, see Create and Add Themes.

Data

RDL reports are ideal when you need to show data from different data sets, and when you do not need to control where the data appears on the page. Use data regions to display data in the report, and after the controls grow to accommodate your data, ActiveReports breaks it down into pages. For more information, see Data Sources and Datasets.

Shared Data Sources

RDL reports allow you to create and use shared data sources, so that you need not enter the same connection string every time you create a report.

Custom Resource Locators

You can create a custom resource locator for items to use in your reports. In this way, you can locate images for reports, or even reports to use in subreports or in drill-through links. For more information, see Custom Resource Locator.

Data Regions and Report Controls

All Rdl reports have controls that can display data differently than in section reports. You can use Sparkline and Bullet report controls for dashboard reports, plus there is a List, Table, and Tablix data regions to display your data. You can use expressions in many of the properties to determine what to display and how to display it. For more information on these and other report controls, see Toolbox.

Note: The PageHeader and PageFooter sections of RDL Reports do not display controls bound to dataset values at run time. These sections only display controls with static data like labels or, you can also add parameters using dataset values and use controls bound to parameter value in order to display dataset field values in these sections.

Data Visualizers

The Image and TextBox report controls have a Data Visualizer feature that allows you to display data in small, easy-to-comprehend graphs. This is a powerful tool to really make your data pop. For more information, see Data Visualizers.

Grouping

You can group data within data regions by fields or expressions, control the scope of aggregates, and even create recursive hierarchies in data with parent-child relationships. The Level function allows you to indent by level to show these relationships visually. For more information, see Grouping Data (Page Layout).

Interactivity

Interactive Sorting

You can allow users to sort data in List, BandedList, Table, or Tablix data regions using the Interactive Sort properties of a TextBox report control. For more information, see Allow Users to Sort Data in the Viewer.

Parameters

You can add parameters to reports that allow users to select which values to display in the report. These are also useful in creating drill-through reports. For more information, see Add Parameters.

Drill Down

You can use the ToggleItem property in the Visibility section for report controls, data regions, table rows, and tablix row and column groups to create drill-down reports. With these settings, you can initially hide items and set a toggle item that users can click to drill into more detailed data. For more information, see Create a Drill-Down Report.

Drill Through

You can use the Action property in the Navigation settings available on text boxes, images, and chart data values to create drill-through reports that let users click links to more detailed reports with parameters. Although you can create drill-through links to reports without parameters, this may leave users searching a huge detailed report for relevant information.

Bookmark Links

You can also use the Action property in the Navigation settings to jump to a bookmark or URL.

Pagination

You can control where pages break in RDL reports using PageSize settings, as well as PageBreakBefore and PageBreakAfter properties on data regions, groups, and rectangles.

See Also

Page Report

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Code-Based Section Report

Code-Based Section Report
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Report Types > Code-Based Section Report

Glossary Item Box

When you add an ActiveReports 13 Section Report (code-based) to your Visual Studio project, report layouts are saved as C# or Visual Basic files within the project in which they are created. these files are compiled into the application when you build it. Each report is composed of three files:

  • rptYourReportName.vb or .cs
  • rptYourReportName.Designer.vb or .cs
  • rptYourReportName.resx

In this way, layout information models the behavior of Windows Forms in the .NET framework.

The design surface of a section report has banded sections that repeat depending on the data and the type of section. For more information, see Section Report Structure and Section Report Events.

Code

This type of report is the most flexible in terms of what a .NET developer can achieve using code. It has an extensive API and is event-based, which allows you to control all aspects of the report and how it is generated. If you like, you can even build a report completely in code. See details about the API in the Class Library section of the help.

The API is also available with XML-based section reports, but you use VB or C# script instead of Windows Forms-like code. For more information, see XML-Based Section Report .

Data

Code-based section reports connect to data either via settings that you specify in the Report Data Source dialog, or through code. You can find more information on all of the ways to connect to data in a section report in the Work with Data in Section Reports topic.

Viewing and Exporting

To display a code-based report in the viewer, you use the LoadDocument method of the viewer. See Viewing Reports for more information. To export a code-based report, you use the Export method of the export you choose.

See Also

Section Report Concepts

How To
Section Report How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


XML-Based Section Report

XML-Based Section Report
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Report Types > XML-Based Section Report

Glossary Item Box

When you add an ActiveReports 13 Section Report (xml-based) report to your Visual Studio project, the layout is saved as a stand-alone Report XML (RPX) file. Since these files are not compiled into your application, they are a good option for solutions in which you need to update or add reports frequently.

The RPX format cannot contain Visual Basic.NET or C# code. Instead, you can add VB.NET or C# script in the Script view of the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

For more information on using script with a layout file, see Scripting in Section Reports.

XML-based section reports are the same as Code-Based Section Report with regard to data, events, structure, and exports, but everything is contained in a single, portable RPX file.

End User Report Designer

If you want to allow end users to edit and create section reports in a Windows Forms application you create with the Designer control, these are XML-based, as there is nowhere to put Visual Studio code and no way to handle multiple files for a code-based section report. For more information, see Creating a Basic End User Report Designer (Pro Edition).

See Also

Report Types

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page Report/RDL Report Concepts

Page Report/RDL Report Concepts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts

Glossary Item Box

There are a number of concepts that apply to page reports and RDL reports.

In this section

Toolbox
Learn about the report controls and data regions available in the ActiveReports 13 Page Report and ActiveReports 13 RDL Report group in the Visual Studio toolbox.
Data Sources and Datasets
Learn about the Data Sources you can access through ActiveReports and fetch data through DataSets along with an overview of the Report DataSource and DataSet dialogs.
Expressions
Learn about setting expressions in reports and creating expression through the Expression Editor.
Layers
Learn about using Layers a in reports and it's advantages.
Styles
Learn about using Styles in a reports and it's advantages.
Using Script
Learn about embedding code in the script tab to extend the features in your reports.
Report Dialog
Learn about the various options provided in Report Dialog.
Fixed Page Dialog
Learn about the various options provided in FixedPage Dialog.
Grouping Data (Page Layout)
Learn about the various options provided for grouping data in ActiveReports.
Add Page Numbering
Learn about the various pre-defined formats or creating custom formats to display page numbers in reports.
Themes
Learn about creating themes to define the appearance of reports, and apply the themes to any number of reports for a consistent look.
Master Reports (RDL)
Learn about using master reports to create a reusable template of common elements you can apply to other reports.
Data Visualizers
Learn about a number of ways to make your data pop using small graphs in images and background colors.
Custom Resource Locator
Learn about the ResourceLocator class that allows you to find resources on your machine for use in your RDL reports.
Nested Data Regions Bound to Different Data
Learn about using nested data regions that are bound to different datasets.
LookupSet Function in Data Regions
Learn about using the LookupSet function in data regions.

See Also

Section Report Concepts

How To
Page Report/RDL Report How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Toolbox

Toolbox
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox

Glossary Item Box

When a Page report or RDL report has focus in Visual Studio, the ActiveReports 13 Page Report and ActiveReports 13 RDL Report toolbox group offers a number of report controls and data regions that you can use when creating a report. You can drag these from the toolbox and drop them onto your reports. These tools are different than those in the Section Report Toolbox.

Note: Take care in naming report controls, as they are displayed to end users in the advanced search feature of the Viewer.

In this section

Banded List
The BandedList is a data region with freeform bands in which you can place report controls. With a detail band that repeats data for every row in the dataset, this data region resembles the Section report design surface.
Barcode
The BarCode report control renders scannable barcodes in any of 39 popular symbologies. You can bind it to data, control the bar width, rotation, quiet zones, caption locations, whether check sum is enabled, and many other properties.
Bullet
The Bullet report control is an easy-to-read linear gauge that is a good alternative to using a dashboard for data visualization. You can bind it to data and set best, worst, and satisfactory values as well as labels and ranges.
Chart
The new Chart is a graphic data region similar to Classic Chart, which is based on representing the data using encodings. It is the default chart available in the designer.
Classic Chart
The Classic Chart is a graphic data region which allows you to display data in a variety of chart styles with 3D effects and colors, and provides many options for customization. You can choose from numerous chart types.
CheckBox (Page Report)
The CheckBox report control can display Boolean data, or you can set its Checked property. You can also enter static text to display.
Container
The Container report control is a graphical element that is used as a container for other items. The Container report control has no data associated with it.
Formatted Text
The FormattedText report control displays data, and allows you to format selected areas of text within the control in different ways. This report control accepts XHTML input, and allows you to set up mail merge.
Image
The Image report control allows you to specify any image file to display from an external source, a database or an embedded image.
Line
The Line report control, a graphical element that has no data associated with it, visually marks boundaries or highlights specific areas of a report. You can use lines of various weight, color, and style to highlight regions of your reports and to add style and polish.
List
The List is a freeform data region in which you can place other report controls. It repeats any report control it contains for every record in the dataset.
Map
The Map data region shows your business data against a geographical background. You can select different types of map, depending on the type of information you want to communicate in your report.
Overflow Place Holder
The Overflow Placeholder report control is only available with page reports. It is a simple rectangle that you link to a List, BandedList, Tablix, or Table data region to display data that extends beyond one page.
Shape
The Shape report control, a graphical element that has no data associated with it, allows you to mark visual boundaries or highlight specific areas of a report with rectangles, rounded rectangles, or elliptical shapes. Unlike the Container report control, it cannot contain other controls.
Sparkline
The Sparkline report control displays a data trend over time in a graph small enough to be used inline, with a height similar to the surrounding text. You can select from line, area, stacked bar, column, and whisker sparkline types.
Subreport
The Subreport control displays data from a separate report that you specify. You can pass a parameter to the subreport from the main report to filter data displayed in a subreport.
Table
The Table is a data region that shows data in rows. By default, it has three columns and three rows. Once set at design time, the columns are static, while the rows repeat for each row of data. The default rows are the header, detail, and footer.
TableOfContents
The TableOfContents (ToC) report control is used to display the document map, an organized hierarchy of the report bookmarks and labels along with their page numbers, in the body of a report. The TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports.
TextBox
The TextBox displays data, and is the default data region that appears in each cell of a Table or Tablix data region. It is also the data region that is created automatically when you drag a field from the Data Explorer onto your report. You can use expressions to modify the data that appears in a TextBox.
Tablix
Tablix data region displays data in cells that are arranged in rows and columns. Tablix is mainly a combination of two data regions- table and a matrix.

See Also

Section Report Toolbox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Banded List

Banded List
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Banded List

Glossary Item Box

Show All Show All
Hide All Hide All

The BandedList data region is a collection of free-form bands. By default, it is composed of three bands: a header, a footer and a detail band. Bound report controls in the detail band repeat for every row of data. The header and footer rows render once at the beginning and end of the BandedList, respectively, and are a good place for titles and grand totals.

Click inside each band to reveal its properties in the Properties window, or click the four-way arrow to select the entire data region and reveal its properties. Properties for this data region include the following.

Show Band Properties

Property | Description
CanGrow | Change to True to allow the data region to grow vertically to accommodate data.
CanShrink | Change to True to allow the data region to shrink if there is not enough data to fill it.
KeepTogether | Change to True to have ActiveReports attempt to keep all of the data in the band together on one page.
PageBreakAtEnd | Change to True to insert a page break after rendering all of the data in the band.
PageBreakAtStart | Change to True to insert a page break before rendering any of the data in the band.
RepeatOnNewPage | With header and footer bands, repeats the band on every page when the related details span multiple pages.

Show BandedList Properties

Property | Description
DataSetName | Select the dataset to use in the data region.
DataSetParameters | Specify the parameters for the data set.
KeepTogether | Change to True to have ActiveReports attempt to keep all of the data in the data region together on one page.
NewSection | Change to True to render the data region in a new section.
OverflowName | Select the name of the OverflowPlaceHolder control in which to render data that exceeds the allowed space for the data region on the first page of the report.

You can add group header and group footer bands. Report controls in these bands repeat once for each group instance. You can also nest groups, plus, in RDL reports, you can nest other data regions in any header or footer band. Grouping in the BandedList is similar to grouping in the Table data region. You can provide a grouping expression for each group, and also sort the groups.

Caution: You cannot sort the detail data in a BandedList, so any sorting of this type must be done at the query level.

BandedList Dialog

Properties for the BandedList data region are available in the BandedList dialog. To open it, with the BandedList selected on the report, under the Properties Window, click the Property dialog link.

The BandedList dialog lets you set properties on the data region with the following pages.

Note: You can click <Expression...> in many of these properties to open the Expression Editor where you can create an expression to determine the value.

Show General

Name: Enter a name for the banded list that is unique within the report. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset name: Select a dataset to associate with the banded list. The combo box is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether this banded list is in its own section with regards to pagination.

Page Breaks: Select any of the following options to apply to each instance of the banded list.

  • Insert a page break before this banded list
  • Insert a page break after this banded list
  • Fit banded list on a single page if possible

Header and Footer: Select any of the following options.

  • Repeat header band on each page
  • Repeat footer band on each page

Show Visibility

By default, the banded list is visible when the report runs, but you can hide it, hide it only when certain conditions are met, or toggle its visibility with another report control.

Initial visibility

  • Visible: The banded list is visible when the report runs.
  • Hidden: The banded list is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the BandedList is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the BandedList. The user can click the toggle item to show or hide this BandedList.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this BandedList. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Groups

Click the plus sign button to add a new group to the BandedList, and delete them using the X button. Once you add one or more groups, you can reorder them using the arrow buttons, and set up information for each group on the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select Ascending or Descending.

Show Visibility

By default, the group is visible when the report runs, but you can hide a group, hide it when certain conditions are met, or toggle its visibility with another report control.

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report item. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Show Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Include group header: Adds a group header band (selected by default).

Include group footer: Adds a group footer band (selected by default).

Repeat group header: Repeats the group header band on each page.

Repeat group footer: Repeats the group footer band on each page.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Data Output

The Data Output page of the BandedList dialog allows you to control the following properties when you export to XML.

  • Element name: Enter a name to be used in the XML output for this BandedList.
  • Output: Choose Auto, Yes, or No to decide whether to include this BandedList in the XML output. Choosing Auto exports the contents of the BandedList.

See Also

How To
Page Report/RDL Report How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Barcode

Barcode
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Barcode

Glossary Item Box

Show All Show All
Hide All Hide All

The Barcode report control offers various barcode styles to choose from. This saves you the time and expense of finding and integrating a separate component. As with other data-bound report controls, you can use an expression to bind the value of a field to the Barcode Value property.

Apart from the barcode style, you can manage the alignment, direction, color, background color, bar width, caption position, font, text, and check whether checksum is enabled in the Properties Window. There are more properties available with the Code49, PDF417, and QRCode barcode styles. Click the Barcode to reveal its properties in the Properties window. All of the properties specific to this report control are also available in the Barcode dialog.

Note: This barcode is ported from the Section report Barcode control, so if you create reports programmatically, the Page report/RDL report barcode is treated as a CustomReportItem.

Barcode Dialog

Properties for the Barcode are available in the Barcode dialog. To open it, with the Barcode selected in the report, under the Properties Window, click the Property dialog link.

The Barcode dialog lets you set properties on the report control with the following pages.

Note: You can select the <Expression...> option in many of these properties to open the Expression Editor where you can create an expression to determine the value. You can also access the Expression Editor from the context menu of the Barcode control.

Show General

Name: Enter a name for the barcode that is unique within the report. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Value: Enter an expression or a static label, or choose a field expression from the drop-down list. You can access the expression editor by selecting <Expression...> in the list. The value of this expression or text is used to render the barcode in the report.

Invalid Barcode Text: Enter a message to display if the barcode contains invalid values (content, character, length).

Caption

Location: Select whether to display the caption above or below the barcode, or select None to display the barcode without a caption.

Text Alignment: Select the horizontal alignment of the caption. The default value of General centers the caption.

Show Barcode Settings

Symbology: Enter the type of barcode to use. ActiveReports supports all of the most popular symbologies:

Show Table of all included symbologies

Notes: The RSS and QRCode styles have fixed height-to-width ratios. When you resize the width, the height is automatically calculated.

When you choose a style that offers supplemental options, the additional options appear below.
Symbology Name | Example | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %. This is the default barcode style.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
BC412 | Data BC412 uses 35 characters, 0 - 9 and A - Z. It is designed for semiconductor wafer identification.
Codabar | Codabar uses A B C D + - : . / $ and numbers.
Code_11 | Encodes the numbers 0 through 9, the hyphen (-), and start/stop characters. It is primarily used in labeling telecommunications equipment.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses uppercase, % $ * / , + -, and numbers.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode containing two to eight rows of eight characters each. Each row has a start code and a stop code. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). It takes only 12 numbers as a string to calculate a check digit (CheckSum) and add it to the thirteenth position. The check digit is an additional digit used to verify that a bar code has been scanned correctly. The check digit is added automatically when the CheckSum property is set to True.
EAN_13 with the add-on code | EAN-13 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1 | EAN-128FNC1 is an alphanumeric one-dimensional representation of Application Identifier (AI) data for marking containers in the shipping industry. This barcode is now obsolete. You should use UCC/EAN-128 instead which provides similar functionality with better performance.
GS1QRCode

GS1QRCode is a subset of the QR Code. The GS1 QR Code is a 2D symbol that denotes the Extended Packaging URL for a trade item. It is processed to obtain one URL address associated with the trade item identified by the Global Trade Item Number (GTIN). GS1 QR Code requires the mandatory association of the GTIN and Extended Packaging URL.

GS1 QR Code allows to encode GS1 System Application Identifiers (AI) into QR Code 2D barcodes.

Limitation: Kanji, CN, JP and Korean characters.
HIBCCode128 | HIBCCode128 barcode uses the Code128 symbology. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
HIBCCode39 | HIBCCode39 barcode uses the Code39 symbology, with the Code39OptionalCheckDigit property set to True. It encodes Primary Data and Secondary Data using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
IATA_2_of_5 | IATA_2_of_5 is a variant of Code_2_of_5 and uses only numbers with a check digit.
IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
IntelligentMailPackage | IntelligentMailPackage is more efficient in terms of processing and tracking mails than Intelligent Mail barcode.
ISBN | International Standard Book Number barcode is a special form of the EAN-13 code and is used as a unique 9-digit commercial book identifier.
ISMN | Internationally Standard Music Number barcode is a special form of the EAN-13 code. It is used for marking printed musical publications.
ISSN | International Standard Serial Number barcode is a special form of the EAN-13 code. It is used to identify serial publications, publications that are issued in numerical order, such as the volumes of a magazine.
ITF14 | Interleaved Two of Five code is used to mark cartons that contain goods with an EAN-13 code. One digit is added in front of the EAN-13 code to mark the packing variant.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars.
MaxiCode

MaxiCode is special polar barcode that uses 256 characters. It is used to encode a specific amount of data.
MicroPDF417

MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.

MicroPDF417 allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
MicroQRCode

MicroQRCode is a two-dimensional (2D) barcode that is designed for applications that use a small amount of data. It can handle numeric and alphanumeric data as well as Japanese kanji and kana characters. This symbology can encode up to 35 numeric characters.
MSI | MSI Code uses only numbers.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. This symbology can encode up to 35 alphanumeric characters or 2,710 numeric characters.
Pharmacode | Pharmacode represents only numeric data from 3 to 131070. It is a barcode standard used in the pharmaceutical industry for packaging. It is designed to be readable despite printing errors.
Plessey | Plessey uses hexadecimal digits to encode. It is a one-dimensional barcode used mainly in libraries.
PostNet | PostNet uses only numbers with a check digit.
PZN | Pharmaceutical Central/General Number uses the same encoding algorithm as Code 39 but can carry only digits – 0123456789. The number of digits supported for encoding are 6 or 7. The letters 'PZN' and checksum digit are automatically added. It is mainly used to identify medicine and health-care products in Germany and other German-speaking countries.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail (RM4SCC) uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a 14-digit Reduced Space Symbology that uses EAN.UCC item identification for point-of-sale omnidirectional scanning. The RSS family of barcodes is also known as GS1 DataBar.
RSS14Stacked RSS14Stacked uses the EAN.UCC information with Indicator digits as in the RSS14Truncated, but stacked in two rows for a smaller width.
RSS14Stacked allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSS14Stacked CCA | RSS14Stacked with Composite Component - Version A.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional uses the EAN.UCC information with omnidirectional scanning as in the RSS14, but stacked in two rows for a smaller width.
RSS14Truncated | RSS14Truncated uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSExpanded

RSSExpanded uses the EAN.UCC information as in the RSS14, but also adds AI elements such as weight and best-before dates.

RSSExpanded allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSExpandedStacked

RssExpandedStacked uses the EAN.UCC information with AI elements as in the RSSExpanded, but stacked in two rows for a smaller width.

RSSExpandedStacked allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSLimited RSS Limited uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSLimited allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSSLimited CCA | RSS Limited with Composite Component - Version A.
SSCC_18 | SSCC_18 is an 18-digit Serial Shipping Container Code. It is used to identify individual shipping containers for tracking purposes.
Telepen | Telepen has 2 different modes - alphanumeric-only and numeric-only. Both modes require a start character, a check digit, and a stop character. It is mainly used in manufacturing industries.
UCCEAN128 | UCC/EAN-128 complies to GS1-128 standards. GS1-128 uses a series of Application Identifiers to encode data. This barcode uses the complete ASCII character set. It also uses FNC1 character as the first character position. Using AI's, it encodes best before dates, batch numbers, weights, and more such attributes. It is also used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_A with the add-on code | UPC-A may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be zero) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E0 with the add-on code | UPC-E0 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.
UPC_E1 with the add-on code | UPC-E1 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.

When you choose a symbology which offers supplemental options, the additional options appear below the Symbology drop-down box.

Bar Height: Enter a value in inches (for example, .25in) for the height of the barcode.

Narrow Bar Width (also known as X dimension): This is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is specified in Length units (for example, '10cm', '4mm', '1in').

Tip: For accurate scanning, the quiet zone should be ten times the Narrow Bar Width value.

Narrow Width Bar Ratio (also known as N dimension): Enter a value to define the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3. Commonly used values are 2, 2.5, 2.75, and 3.

Quiet Zone

A quiet zone is an area of blank space on either side of a barcode that tells the scanner where the symbology starts and stops.

Left: Enter a size in inches of blank space to leave to the left of the barcode.

Right: Enter a size in inches of blank space to leave to the right of the barcode.

Top: Enter a size in inches of blank space to leave at the top of the barcode.

Bottom: Enter a size in inches of blank space to leave at the bottom of the barcode.

Note: The units of measure listed for all of these properties are the default units of measure used if you do not specify. You may also specify cm, mm, in, pt, or pc.

Checksum

A checksum provides greater accuracy for many barcode symbologies.

Compute Checksum: Select whether to automatically calculate a checksum for the barcode.

Note: If the symbology you choose requires a checksum, setting this value to False has no effect.

Code49 Options

Code49 Options are available for the Code49 barcode style.

Use Grouping: Indicates whether to use grouping for the Code49 barcode. The possible values are True or False.

Group Number: Enter a number between 0 and 8 for the barcode grouping.

DataMatrix Options

DataMatrix Options are available for the DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

EAN128FNC1 Options

EAN128FNC1 Options are available for the EAN128FNC1 barcode style.

DPI: Specify the resolution of the printer as dots per inch to create an optimized barcode image with the specified Dpi value.

Module Size: Enter the horizontal size of the barcode module. Module size is the width of the narrowest bar.

Bar Adjust: Enter the adjustment size by dot units, which affects the size of the module and not the entire barcode.

GS1Composite Options

GS1Composite Options are available for the RSS14Stacked and RSSLimited barcode styles.

Type: Select the type of the composite barcode from the drop-down list. The possible values are None or CCA. CCA (Composite Component - Version A) is the smallest variant of the 2-dimensional composite component.

Value: Enter the expression to set the value of the composite barcode.

MaxiCode Options

MaxiCode option to select mode is available for MaxiCode barcode.

Mode: Select the mode of the MaxiCode barcode. The available values are Mode2 to Mode6.

MicroPDF417 Options

MicroPDF417 Options are available for the MicroPDF417 barcode style.

Compaction Mode: Select the type of the compaction mode from the drop-down list. The possible values are Auto, TextCompactionMode, NumericCompactionMode, or ByteCompactionMode.

Version: Select the version from the drop-down box to set the symbol size.

Segment Index: The segment index of the structured append symbol. The valid value is from 0 to 99998, and less than the value in Segment Count.

Segment Count: The segment count of the structured append symbol. The valid value is from 0 to 99999.

File ID: The file id of the structured append symbol. The valid value is from 0 to 899.

PDF417 Options

PDF417 Options are available for the Pdf417 barcode style.

Columns: Enter column numbers for the barcode.

Rows: Enter row numbers for the barcode.

Error Correction Level: Enter the error correction level for the barcode.

PDF 417 Barcode Type: Select the PDF417 barcode type form the drop-down list. The possible values are Normal or Simple.

MicroQRCode Options

MicroQRCode Options are available for the MicroQRCode barcode style.

Error Level: Select the error correction level for the barcode from the drop-down list. Valid values are M, L, or Q. The available Error Level values change depending on the version you select.

Version: Enter the version of the MicroQRCode barcode style. Valid values are M1, M2, M3, or M4. The maximum amount of data can be stored in version M4.

Mask: Select the pattern for the barcode masking from the drop-down list. Valid values are Mask00, Mask01, Mask10, or Mask11.

Encoding: Select the barcode encoding from the drop-down list.

QRCode Options

QRCode Options are available for the QRCode barcode style.

Model: Select the model for the QRCode barcode style from the drop-down list. The possible values are Model1 or Model2. For GS1QRCode, Model1 is not supported.

Error Level: Select the error correction level for the barcode from the drop-down list. The possible values are M, L, H or Q.

Version: Enter the version of the QRCode barcode style.

  • For Model1, valid values for Version are -1 or between 1 to 14.
  • For Model2, valid values for Version are -1 or between 1 to 40.

Mask: Select the pattern for the barcode masking from the drop-down list.

Connection: Select whether to use the connection for the barcode. The possible values are True or False. This property is not applicable to GS1QRCode barcode.

ConnectionNumber: Enter the connection number for the barcode. This property is not applicable to GS1QRCode barcode.

Encoding: Select the barcode encoding from the drop-down list.

RssExpandedStacked Options

RssExpandedStacked Options are available for the RSSExpandedStacked barcode style.

Row Count: Enter the number of the barcode stacked rows.

Supplementary Options

Supplementary Options are available for UPC_A, UPC_E0, UPC_E1, EAN_13, and EAN_8 barcode styles.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and supplement barcodes.

Show Appearance

Font

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, or Bolder.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Show Format

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Amount of space to leave around report control

Top margin: Set the top padding in points.

Left margin: Set the left padding in points.

Right margin: Set the right padding in points.

Bottom margin: Set the bottom padding in points.

Rotation: Choose None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.

Show Visibility

Initial visibility

  • Visible: The barcode is visible when the report runs.
  • Hidden: The barcode is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the barcode is visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box where you can select the TextBox control that users can click to show or hide this barcode in the viewer.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this barcode. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Data Output

Element Name: Enter a name to be used in the XML output for this barcode.

Output: Choose Auto, Yes, or No to decide whether to include this barcode in the XML output. Auto exports the contents of the barcode only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render barcodes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bullet

Bullet
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Bullet

Glossary Item Box

Show All Show All
Hide All Hide All

The Bullet report control is an easy-to-read linear gauge that is a good alternative to using a dashboard for data visualization.

A bullet graph has a pointer that shows a key measure. With this control, you can take a single value, the year-to-date revenue for example, and compare it to a target value that you define in the control's properties. You can also define the beginning of the graph as the worst value and the end of the graph as the best value. To make the data visualization even more intuitive, you can define a qualitative range (bad, satisfactory and good) for segments on the bullet graph and immediately see the position of the key measure within the bullet graph range.

You can combine multiple Bullets into a data region, a table for example, to show single values side by side. You can orient Bullets horizontally or vertically, and put them together as a stack to analyze several data dimensions at once.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Bullet Dialog

Properties for the Bullet are available in the Bullet dialog. To open it, with the Bullet control selected on the report, under the Properties Window, click the Property dialog link.

The Bullet dialog lets you set properties on the report control with the following pages.

Note: You can click <Expression...> in many of these properties to open the Expression Editor where you can create an expression to determine the value. For properties with enumerated values, the values are listed under Constants in the Fields tree view on the left side of the Expression Editor.

Show General

Name: Enter a name for the Bullet that is unique within the report. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Show Data

Value: Enter an expression to use as the bullet value.

Target Value: Enter an expression to use as the target value of the bullet graph.

Show Appearance

Bullet Graph Orientation

Horizontal: Select to display a horizontal bullet graph.

Vertical: Select to display a vertical bullet graph.

Value Style

Color: Select a color to use for the value marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is Black.

Target Style

Target Type: Choose Line, Dot or Square. The default value is Line.

Color: Select a color to use for the target value marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is Black.

Width: Enter a value in points to set the width of the target value marker. The default value is 3pt.

Note: The Width setting applies only when the Target Type is set to Line.

Tick Marks

Position: Choose None, Inside or Outside. The default value is Outside.

Color: Select a color to use for the tick marks, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is LightGray.

Width: Enter a value in points to set the width of the tick marks. The default value is 1pt.

Interval between tick marks: Set the interval at which you want to show tick marks.

Show Ranges

Worst Value: Enter a value or expression to define the lowest value on the graph.

Bad/Satisfactory Boundary: Enter a value or expression to define the boundary between bad and satisfactory values.

Display 3 Sections: Select this check box to show three separate value ranges (bad, satisfactory, and good) instead of two (bad and satisfactory). This enables the Satisfactory/Good Boundary.

Satisfactory/Good Boundary: Enter a value or expression to define the boundary between satisfactory and good values.

Best Value: Enter a value or expression to define the highest value on the graph.

Show Labels

Display Labels: Select this check box to display axis labels for the bullet graph. Selecting this box enables the rest of the properties on this page.

Format: Select one of the provided format codes or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Font

Family: Choose the font family name. The default value is Arial.

Size: Choose the size in points for the font. The default value is 10pt.

Style: Choose Regular, Bold, Italic, Underline or Strikeout. The default value is Regular.

Color: Select a Web or custom color for the font. The default value is Black.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this Bullet. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Visibility

Initial visibility

  • Visible: The bullet graph is visible when the report runs.
  • Hidden: The bullet graph is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the bullet graph is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the bullet. The user can click the toggle item to show or hide this bullet.

Show Data Output

Element Name: Enter a name to be used in the XML output for this Bullet.

Output: Choose Auto, Yes, No, or Content only to decide whether to include this Bullet in the XML output. Auto exports the contents of the bullet graph only when the value is not a constant.

See Also

How To
Create a Bullet Graph

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart

Chart
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart

Glossary Item Box

The Chart data region represents your data graphically. It is a data visualization control that is primarily based on slicing data through encodings.

Chart Elements

The Chart elements help you to easily analyze the visual information and interpret numerical and relational data. The following image illustrates the elements that make up the Chart data region.

Axis Label: A label along an axis that lets you label the units being shown.

Axis Title: The axis title allows you to provide a title for the information being shown on the axis.

Chart Title: The chart title serves as the title for the chart.

Grid Line: Grid lines can occur on horizontal and vertical axes and normally correlate to the major or minor tick marks for the axes.

Legend: The legend serves as a key to the specific colors or patterns being used to show series values in the chart. To display legends for each plot on a chart, use VALUESNAME as the color field encoding.

Major Tick: Major tick marks can occur on horizontal and vertical axes and normally correlate to the major gridlines for the axes.

Minor Tick: Minor tick marks can occur on horizontal and vertical axes and normally correlate to the minor gridlines for the axes.

Plot area: The Plot Area contains data plotted against X-axis and Y-axis.

Encodings

Encodings convert the data into visual elements. They define how each field from a data set is visualized. There are following encodings that are used in the process of creating charts.

Category Fields
The category mapping in Category Fields groups the data set into multiple categories for each unique value (or numerical range) that exists for the specified field.
Data Fields
The values mapping in Data Fields specifies which fields should be plotted along the Y-axis. For scatter plot charts, the values property includes mappings for both X and Y using comma delimited notation.
Details
The detail mapping slices the data into sub-divisions that can be clustered or stacked next to each other in the plot.
Color
The color mapping determines which field should be used to determine color assignations for the plot and legend.
Shape
The shape mapping determines which field should be used to determine shape assignations for the plot and legend.
Size
The size mapping determines which field to apply a continuous size-based scale to for the plot and legend.

Important Properties

Property | Description
ToolTip | A textual label for the report item used to include Title or ALT attributes in HTML reports.
SwapAxes | Represents whether the axes are swapped.
Reversed | Represents whether the axis is reversed (top to bottom or right to left).
Padding | The amount of padding to place between the text or graphics and the edge of the report item.
LabelsAngle | Rotation angle of the axis labels. The angle is measured in degrees with valid values ranging from -90 to 90.
ShowNulls | Represents how to show the null or an empty value.
Sweep | Sweep of plots for radial plots.
InnerRadius | Inner radius in percentage for radial plots.
StartAngle | Starting angle of the radial plot.
Palette | The color support rgb and rgba format
Plots | The plots define the data fields that map to the chart. There can be single or multiple plots in a chart.
Tooltip Template | Contains the tooltip template settings. You can choose from the list of predefined settings or set your own in the Expression Editor.

See Also

Chart Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Types

Chart Types
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types

Glossary Item Box

Depending on the volume of data, number of variables, time period, and other data points, you can create charts from the following available types:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Column Chart
Column, Stacked Column, and Percent Stacked Column.
Bar Chart
Bar, Stacked Bar, and Percent Stacked Bar.
Line Chart
Line and Smooth Line.
Area Chart
Area, Stacked Area, and Stacked Percent Area.
Pie Chart
Pie and Doughnut.
Spiral Chart
Spiral, Stacked Spiral, and Percent Stacked Spiral.
Polar Chart
Polar, Stacked Polar, and Percent Stacked Polar.
Other Chart Types
Pyramid, Funnel, Bubble, Scatter, Gantt, High Low close, High Low Open Close, and Candlestick.

See Also

Column Charts
Funnel Charts
Gantt Charts
Composite Charts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Column Chart

Column Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Column Chart

Glossary Item Box

Column charts present each series as a vertical column, and group the columns by category. The y-axis values determine the heights of the columns, while the x-axis displays the category labels. With a column chart, you can select from the following subtypes.

Column

Compares values of items across categories.

Stacked Column

A column chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.

Percent Stacked Column

A column chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to a total with the relative size of each series representing its contribution to the total.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bar Chart

Bar Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Bar Chart

Glossary Item Box

Bar charts present each series as a horizontal bar, and group the bars by category. The x-axis values determine the lengths of the bars, while the y-axis displays the category labels. With a bar chart, you can select from the following subtypes.

Bar

Compares values of items across categories.

Stacked Bar

A bar chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.

Percent Stacked Bar

A bar chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to the total with the relative size of each series representing its contribution to the total.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Line Chart

Line Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Line Chart

Glossary Item Box

Line charts present each series as a point, and connect the points with a line. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With a line chart, you can select from the following subtypes.

Line

Compares trends over a period of time or in certain categories.

Smooth Line

Plots curves rather than angled lines through the data points in a series to compare trends over a period of time or in certain categories.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Area Chart

Area Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Area Chart

Glossary Item Box

Area charts present each series as a point, connect the points with a line, and fill the area below the line. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With an area chart, you can select from the following subtypes.

Area

Compare trends over a period of time or in specific categories.

Stacked

An area chart with two or more data series stacked one on top of the other, shows how each value contributes to the total.

Percent Stacked

An area chart with two or more data series stacked one on top of the other to sum up to 100%, shows how each value contributes to the total with the relative size of each series representing its contribution to the total.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Pie Chart

Pie Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Pie Chart

Glossary Item Box

Pie charts present each category as a slice of pie or doughnut, sized according to value. Series groups are not represented in pie charts. With a pie chart, you can select from the following subtypes.

Pie

Shows how the percentage of each data item contributes to the total.

Doughnut

Shows how the percentage of each data item contributes to a total percentage.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Spiral Chart

Spiral Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Spiral Chart

Glossary Item Box

Spiral charts present data in the form of a spiral that is suitable for large data sets, showing trends over a long period of time. With a spiral chart, you can select from the following subtypes.

Spiral

Plots series along spirals, starting from the center of the circle.

Stacked Spiral

Plots multiple series one on top of the other showing contribution of each value to the total.

Percent Stacked Spiral

Plots multiple series one on top of the other showing percentage contribution of each value to the total.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Polar Chart

Polar Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Polar Chart

Glossary Item Box

Polar charts present data with geographical component. With a polar chart, you can select from the following subtypes.

Polar

Polar charts plot series with circular x-axis representing angle values and radial y-axis representing radius values.

Stacked Polar

Plots multiple series one on top of the other showing contribution of each value to the total.

Percent Stacked Polar

Plots multiple series one on top of the other showing percentage contribution of each value to the total.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Other Chart Types

Other Chart Types
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Types > Other Chart Types

Glossary Item Box

Pyramid

Shows how the percentage of each data item contributes to the whole, with the smallest value at the top and the largest at the bottom. This chart type works best with relatively few data items.

Funnel

Shows how the percentage of each data item contributes to the whole, with the largest value at the top and the smallest at the bottom. This chart type works best with relatively few data items.

Bubble

Shows each series as a bubble. The y-axis values determine the height of the bubble, while the x-axis displays the category labels.

Scatter

Scatter charts present each series as a point or bubble. The y-axis values determine the heights of the points, while the x-axis displays the category labels. Shows the relationships between numeric values in two or more series sets of XY values.

Gantt

This project management tool charts the progress of individual project tasks. The chart compares project task completion to the task schedule.

High Low Close

Displays stock information using High, Low, and Close values. High and low values are displayed using vertical lines, while tick marks on the right indicate closing values.

High Low Open Close

Displays stock information using High, Low, Open, and Close values. Opening values are displayed using lines to the left, while lines to the right indicate closing values. The high and low values determine the top and bottom points of the vertical lines.

Candlestick

Displays stock information using High, Low, Open and Close values. The height of the wick line is determined by the High and Low values, while the height of the bar is determined by the Open and Close values. The bar is displayed using different colors, depending on whether the price of the stock has gone up or down.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Classic Chart

Classic Chart
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Classic Chart

Glossary Item Box

Show All Show All
Hide All Hide All
Note: The Classic Chart is by default hidden from the toolbox. If you want to use Classic Chart instead of new Chart, you can enable it from Grapecity.ActiveReports.config file located at C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 13.

The Chart data region shows your data in a graphical representation that often makes it easier for users to comprehend large amounts of data quickly. Different types of charts are more efficient for different types of information, so we offer a wide variety of chart types. This makes it easy and cost effective to add charting to your reports, as there is no need to purchase and integrate a separate charting tool.

To hone in on your needs, when you first drag the Chart report control onto a Page report/RDL report, you can select the broad category of chart type to use: Bar, Column, Scatter, Line, or Dot Plot.

Once you select a chart category, there are a number of dialogs to help you to customize your chart.

Note: You can select <Expression...> within many of these properties to create an expression to determine the value, or you can select a theme value to keep reports consistent.

Chart Appearance

To open the Chart Appearance dialog, select the Chart on the report, and below the Properties window, click the Chart appearance command. This dialog has the following pages.

Tip: To go directly to the Plot Area page, click in the middle of the chart to select the Plot Area, then under the Properties Window, click Property dialog.

Show Gallery

The Gallery page of the Chart dialog, in basic mode, displays each of the broad categories of chart types, plus subtypes so that you can refine your choice. For even more chart types, click the Advanced button.

Basic Chart Types

Bar Charts

Bar charts present each series as a horizontal bar, and group the bars by category. The x-axis values determine the lengths of the bars, while the y-axis displays the category labels. With a bar chart, you can select from the following subtypes.

  • Plain: Compares values of items across categories.
  • Stacked: A bar chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.
  • Percent Stacked: A bar chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to the total with the relative size of each series representing its contribution to the total.

Column Charts

Column charts present each series as a vertical column, and group the columns by category. The y-axis values determine the heights of the columns, while the x-axis displays the category labels. With a column chart, you can select from the following subtypes.

  • Plain: Compares values of items across categories.
  • Stacked: A column chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.
  • Percent Stacked: A column chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to a total with the relative size of each series representing its contribution to the total.

Scatter Charts

Scatter charts present each series as a point or bubble. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With a scatter chart, you can select from the following subtypes.

  • Plain: Shows the relationships between numeric values in two or more series sets of XY values.
  • Connected: Plots points on the X and Y axes as one series and uses a line to connect points to each other.
  • Smoothly Connected: Plots points on the X and Y axes as one series and uses a line with the angles smoothed out to connect points to each other.
  • Bubble: Shows each series as a bubble. The y-axis values determine the height of the bubble, while the x-axis displays the category labels. This chart type is only accessible in Advanced chart types.

Line Charts

Line charts present each series as a point, and connect the points with a line. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With a line chart, you can select from the following subtypes.

  • Plain: Compares trends over a period of time or in certain categories.
  • Smooth: Plots curves rather than angled lines through the data points in a series to compare trends over a period of time or in certain categories. Also known as a Bezier chart.

Dot Plot Charts

A Dot Plot chart is a statistical chart containing group of data points plotted on a simple scale. Dot Plot chart are used for continuous, quantitative, univariate data. The dot plot chart has one subtype.

Plain: Displays simple statistical plots. It is ideal for small to moderate sized data sets. You can also highlight clusters and gaps, as well as outliers, while conserving numerical information.

Advanced Chart Types

Area Charts

Area charts present each series as a point, connect the points with a line, and fill the area below the line. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With an area chart, you can select from the following subtypes.

  • Plain: Compare trends over a period of time or in specific categories.
  • Stacked: An area chart with two or more data series stacked one on top of the other, shows how each value contributes to the total.
  • Percent Stacked: An area chart with two or more data series stacked one on top of the other to sum up to 100%, shows how each value contributes to the total with the relative size of each series representing its contribution to the total.

Pie Charts

Pie charts present each category as a slice of pie or doughnut, sized according to value. Series groups are not represented in pie charts. With a pie chart, you can select from the following subtypes.

  • Pie: Shows how the percentage of each data item contributes to the total.
  • Exploded: Shows how the percentage of each data item contributes to the total, with the pie slices pulled out from the center to show detail.
  • Doughnut: Shows how the percentage of each data item contributes to a total percentage.
  • Exploded Doughnut: Shows how the percentage of each data item contributes to the total, with the pie slices pulled out from the center to show detail.

Financial Charts

Stock charts present each series as a line with markers showing some combination of high, low, open, and close values. The y-axis values determine the heights of the lines, while the x-axis displays the category labels. With a financial chart, you can select from the following subtypes.

  • High Low Close: Displays stock information using High, Low, and Close values. High and low values are displayed using vertical lines, while tick marks on the right indicate closing values.
  • Open High Low Close: Displays stock information using Open, High, Low, and Close values. Opening values are displayed using lines to the left, while lines to the right indicate closing values. The high and low values determine the top and bottom points of the vertical lines.
  • Candlestick: Displays stock information using High, Low, Open and Close values. The height of the wick line is determined by the High and Low values, while the height of the bar is determined by the Open and Close values. The bar is displayed using different colors, depending on whether the price of the stock has gone up or down.
  • Renko: Bricks of uniform size chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. A change in box color and direction signifies a trend reversal.
  • Kagi: Displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).
  • Point and Figure: Stacked columns of Xs indicate that demand exceeds supply and columns of Os indicate that supply exceeds demand to define pricing trends. A new X or O is added to the chart if the price moves higher or lower than the BoxSize value you set. A new column is added when the price reverses to the level of the BoxSize value multiplied by the ReversalAmount you set. This calculation of pricing trends is best suited for long-term financial analysis.
  • Three Line Break: Vertical boxes or lines illustrate price changes of an asset or market. The price in a three line break graph must break the prior high or low set in the NewLineBreak property in order to reverse the direction of the graph.

Other Charts

Other chart types may be used for special functions like charting the progress of individual tasks. You can select from the following subtypes.

  • Funnel: Shows how the percentage of each data item contributes to the whole, with the largest value at the top and the smallest at the bottom. This chart type works best with relatively few data items.
  • Pyramid: Shows how the percentage of each data item contributes to the whole, with the smallest value at the top and the largest at the bottom. This chart type works best with relatively few data items.
  • Gantt: This project management tool charts the progress of individual project tasks. The chart compares project task completion to the task schedule.

Show Title

Chart title: Enter an expression or text to use for the title.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Show Palette

Default: The same as Subdued below, the recommended palette for charts.

EarthTones: A palette of autumnal browns, oranges, and greens.

Excel: A palette of muted plums, blues, and creams.

GrayScale: A palette of patterns suitable for printing to a black and white printer.

Light: A palette of pale pinks and peaches.

Pastel: A palette of blues, greens, and purples.

SemiTransparent: A palette of primary and tertiary colors that allows the backdrop to show through.

Subdued: A palette of muted tones of browns, greens, blues, and grays.

Vivid: The same as Subdued, but with richer tones.

Custom: A palette of colors that you define. When you select Custom, you can list colors that are used in the order you specify.

Show Area

Border

Style: Choose an enumerated style for the border.

Width: Set a width value in points between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Background Fill Color

Fill Color: Select a Web or Custom color.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. The Fill Color is used to fill the area and the Gradient End Color property is ignored.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color.

Show Plot Area

Border

Style: Choose an enumerated style for the border.

Width: Choose a width value between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Background Fill Color

Fill Color: Select a Web or Custom color.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. The Fill Color is used to fill the area and the Gradient End Color property is ignored.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color.

Series line (Bar Stacked and Percent Stacked, Column Stacked and Percent Stacked types only)

Style: Choose an enumerated style for the series line.

Width: Choose a width value between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Show 3D Effects

These properties are enabled when you select the 3D checkbox on the Gallery page.

Display the chart with 3D visual effects: Select this check box to enable all of the following properties.

Horizontal rotation: Move the slider to rotate the chart to left and right. All the way to the left (-90°) shows the chart from the left side, while all the way to the right (90°) shows it from the right side. The default value is 20°.

Vertical rotation: Move the slider to rotate the chart up and down. All the way to the left (-90°) shows the chart from the bottom, while all the way to the right (90°) shows it from the top. The default value is 20°.

Wall thickness: Move the slider to change the thickness of the walls at the axes. The default value is 0% and the range of values is 0% (left) to 100% (right). If the chart type is pie or doughnut, this property is ignored.

Perspective: Move the slider to change the perspective from which the chart is displayed. The default value is 0% and the range of values is 0% (left) to 100% (right). If you select Orthographic Projection, this property is ignored.

Shading: Select the type of shading to apply to the chart. The default value is Real.

  • None: Colors are uniform.
  • Simple: Colors are darkened in areas where the light source does not hit them.
  • Real: Colors are darkened in areas where the light source does not hit them, and lightened in areas where the light source is strongest.

Orthographic Projection: Select this check box to use orthographic or "true drawing" projection. This type of projection is ignored with pie and doughnut chart types.

Clustered: With chart types of bar and column, select this check box to cluster series groups. Other chart types ignore this setting.

Display bars as cylinders: With chart types of bar and column, select this check box to display cylinders instead of bars or columns.

Defaults (button): Click this button when you want to set all of the 3D effect properties back to their default values.

Chart Data

See the Chart Data Dialog topic for all of the pages and tabs available for customizing your chart data.

Chart Legend

To open the Chart Legend dialog, select the Chart on the report, and below the Properties window, click the Chart legend command. This dialog has the following pages.

Show General

Show chart legend: Clear this check box to disable the legend. This also disables all of the other properties on this page.

Use Smart Settings: Check this option to apply smart settings or clear this checkbox to activate the properties given below.

Layout: Choose the layout style for the legend.

  • Column: This option displays legend items in a single vertical column.
  • Row: This option displays legend items in a single horizontal row.
  • Table: This option displays legend items in a table of vertical columns, and is best when you have a large number of values.

Position: Select an enumerated value to determine the position of the legend relative to the chart area. The default value is RightCenter.

Display legend inside plot area: Select this check box to display the legend inside the plot area along with your data elements.

Show Style

The Style page of the Chart Legend dialog allows you to control the Font, Border, and Fill properties for the legend.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Border

Style: Choose an enumerated style for the border.

Width: Enter a width value between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Background Fill Color

Fill Color: Select a Web or Custom color.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. The Fill Color is used to fill the area and the Gradient End Color property is ignored.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color.

Chart Axis

Click the Axis X or Axis Y line of the chart to select AxisXLine or AxisYLine, then under the Properties Window, click Property dialog. The Chart Axis dialogs let you set axis properties on the data region with the following pages.

Note: The X and Y Axis dialogs are disabled if your chart type is doughnut or pie.

Show Title

Axis X or Axis Y

X- or Y-Axis title: Enter text to display near the X or Y axis of the chart.

Text alignment: Choose Center, Near, or Far.

Text orientation: Set the text orientation of the label text to Auto, Horizontal, Rotated90, Rotated270, and Stacked.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

The following are additional properties available for the Y-axis that allow you to plot two or more series along it. Composite charts have two or more series plotted along the Y-axis.

Name: Enter a name for each Y axis that is unique within the chart. Note that you can add a maximum of six Y-axes.

Position: Choose Left or Right.

Margin: Enter the distance between two consecutive Y-axes.

Name | Position | Margin | Description
Y1 | Left | 0 | Displayed on the left. It is closest to the plot area.
Y2 | Left | 10 | Displayed on the left of Y1. The distance between Y1 and Y2 is 10.
Y3 | Right | 0 | Displayed on the right. It is closest to the plot area.
Y4 | Right | 20 | Displayed on the right of Y3. The distance between Y3 and Y4 is 20.
Y5 | Left | 30 | Displayed on the left of Y2. The distance between Y2 and Y5 is 30.

The image below depicts each of the Y-axes from the table above.

Show Line Style

Axis Line Appearance

Style: Choose from an enumerated style for the axis line.

Color: Select a Web or Custom color.

End Cap: Choose either None or Arrow as the End Cap style, or enter an expression using Expression Editor dialog.

Show Labels

Show x- or y-axis labels: Select this check box to show labels along the axis and to enable the rest of the properties on this page.

Format code: Select a format code from the list or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Labels Text Orientation: Set the text orientation of the label text to Auto, Angled, Horizontal, Rotated90, Rotated270, and Stacked.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Show Major Grid Lines

Show major grid lines: Select this check box to show grid lines for the axis.

Interval: Set the interval at which you want to show major grid lines or tick marks or both.

Border

Style: Choose one from the enumerated styles for the border.

Width: Enter a width value between 0.25pt and 20pt.

Color: Select a color for the border.

Tick mark: Choose one of the following values to determine whether and where to display major tick marks. The style and interval of the tick marks are set with the above properties.

  • None: No tick mark is displayed.
  • Inside: Tick marks are displayed inside the axis.
  • Outside: Tick marks are displayed outside the axis.
  • Cross: Tick marks are displayed crossing the axis.

Show Minor Grid Lines

Show minor grid lines: Select this check box to show minor grid lines for the axis.

Interval: Set the interval at which you want to show minor grid lines or tick marks or both.

Border

Style: Choose one from the enumerated styles for the border.

Width: Enter a width value between 0.25pt and 20pt.

Color: Select a color for the border.

Tick mark: Choose one of the following values to determine whether and where to display minor tick marks. The style and interval of the tick marks are set with the above properties.

  • None: No tick mark is displayed.
  • Inside: Tick marks are displayed inside the axis.
  • Outside: Tick marks are displayed outside the axis.
  • Cross: Tick marks are displayed crossing the axis.

Show Scale

Minimum: Leave this value blank to allow the data to determine the minimum value to use.

Maximum: Leave this value blank to allow the data to determine the maximum value to use.

Logarithmic scale: Select this check box to display axis data as a percentage of change instead of as absolute arithmetic values.

Numeric or time scale values: Select this check box to indicate that the data on the X axis is scalar so that the chart fills in missing numbers or dates between data values. This property is only available on the X axis.

Show Other

Cross at: Leave this value blank to allow the chart type to determine where the axis should cross the other axis, or you can enter a custom value.

Side margins: Select this check box to add padding between the data and the edges of the chart.

Interlaced strips: Select this check box to display alternating light and dark strips between major intervals specified on the Major Grid Lines page. If none are specified, a default value of 1 is used.

Reversed: Select this check box to reverse the direction of the chart. This will have different effects depending on chart type.

Reference Line (Y Axis only)

Value: Enter a value.

Line/Border

Style: Choose one from the enumerated styles.

Width: Set a width of the axis line.

Color: Select a color for the axis line.

Legend Label: Enter a label for the legend to display in the viewer.

See Also

Chart Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Data Dialog

Chart Data Dialog
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Classic Chart > Chart Data Dialog

Glossary Item Box

Show All Show All
Hide All Hide All

When you first open the Chart Data dialog, you can select a Dataset name to associate with the chart. The list is populated with all of the datasets in the report's dataset collection.

This dialog also gives you access to the following related pages.

General Page

Name: Enter a name for the chart that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset Name: Select a dataset to associate with the chart. The combo box is populated with all of the datasets in the report's dataset collection.

Series Values Page

Add at least one Value series to determine the size of the chart element. Click the plus sign button to enable the General tab. Once you have one or more value series in place, you can use the arrow buttons to change the order or the X button to delete them.

Another way to add Chart Series Values is to drag fields from the Report Explorer onto the tray along the top edge of the chart that reads Drop data fields here.

If you have already added values, you can right-click any value displayed in the UI along the top of the chart and choose Edit to open this dialog.

The Series Values page has the following tabs.

Show General

The General tab of the Series Values page allows you to control different items depending on the Chart Type you have chosen.

For all Chart types

Series label: Enter an expression to use as a series label to display in the legend.

For Scatter or Bubble Chart types

X: Enter an expression to use as an X value.

Y: Enter an expression to use as a Y value.

Size: If the chart type is bubble, enter an expression to use as the bubble size value.

For Stock Chart

High: Enter an expression to use as the high value.

Low: Enter an expression to use as the low value.

Open: Enter an expression to use as the open value.

Close: Enter an expression to use as the close value.

For Column, Bar, Line, Pie, Area, Doughnut, Funnel, Pyramid, ThreeLineBreak, Kagi, Renko, PointAndFigure, or DotPlot Chart types

Value: Enter an expression to use as a series value.

For Column, Line, or Area Chart types

Chart Type: For Composite charts, select the chart type to use in combination with other chart types within the same plot area. The available chart types are:

  • Column Plain
  • Column Stacked
  • Column Percent Stacked
  • Area Plain
  • Area Stacked
  • Area Percent Stacked
  • Line Plain
  • Smooth Line
Y-Axis: Select the Y-axis from the list of available Y-axes.

Show Styles

Line/Border

These properties control the appearance of the border of bars or columns, or the lines, depending on the type of chart.

Style: Choose one of the enumerated styles for the lines.

Width: Choose a width value between 0.25pt and 20pt for the thickness of the lines.

Color: Choose a Web or Custom color to use for the lines.

Background Fill Color

These properties control the appearance of the background of the series values.

Fill Color: Choose a Web or Custom color to fill the background.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. A single color (defined by the Fill Color property above) is used to fill the area and the Gradient End Color property remains disabled.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color to blend with the Fill Color in the background of the series.

Show Markers

Marker type: Choose one of the following values to determine the shape of the marker or whether one is displayed.

  • None - Markers are not used. (Default)
  • Square - Markers are square.
  • Circle - Markers are circular.
  • Diamond - Markers are diamond shaped.
  • Triangle - Markers are triangular.
  • Cross - Markers are cross shaped.
  • Auto - A shape is chosen automatically.

Marker size: Enter a value between 2pt and 10pt to determine the size of the plotting area of the markers.

Plot data as secondary: If the chart type is Column, Bar, or DotPlot, you can select this check box and select whether to use a Line or Points to show the data.

Show Labels

Show point labels: Select this check box to display a label for each chart value. Selecting this box enables the disabled properties on this page.

Data label: Enter a value to use as the label, or select <Expression...> to open the Expression Editor.

Format code: Select one of the provided format codes or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Position: Leave Auto selected to use the default point label position for the chart type, or select an enumerated value to position the labels.

Angle: Enter the value in tenths of degrees to use for the angle of the point label text. The default (0°) position denotes no angle and renders regular horizontal text.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Show Action

Choose from the following actions to perform when the user clicks on the chart element.

None: The default behavior is to do nothing when a user clicks the chart element at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Parameters

  • Name: Supply the exact names of any parameters required for the targeted report. Note that parameter names you supply in this must match parameters in the target report.
    Important: The Parameter Name must exactly match the name of the parameter in the detail report. If any parameter is spelled differently, capitalized differently, or if an expected parameter is not supplied, the drill-through report will fail.
  • Value: Enter a Parameter Value to pass to the detail report. This value must evaluate to a valid value for the parameter.
  • Omit: Select this check box to omit this parameter from the report.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Show Data Output

Element name: Enter a name to be used in the XML output for this chart element.

Output: Choose Yes or No to decide whether to include this chart element in the XML output.

Category Groups Page

Add Category Groups to group data and provide labels for the chart elements. Click the Add button to enable the General tab. Once you have one or more category groups in place, you can use the arrow buttons to change the order or the X button to delete them.

Another way to add Category Groups is to drag fields from the Report Explorer onto the tray along the bottom edge of the chart that reads Drop category fields here.

If you have already added values, you can right-click the value displayed in the UI along the bottom of the chart and choose Edit to open this dialog.

The Category Groups page has the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This name can be called in code.

Group on: Enter an expression to use for grouping the data.

Label: Enter an expression to use as a label for the group. You can select <Expression...> to open the Expression Editor.

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

The Sorting tab of Category Groups page allows you to enter new sort expressions and remove or change the order of them using the X or arrow buttons. For each sort expression in this list, you can also choose the direction.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select whether you want to sort the data in an Ascending or Descending direction.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Series Groups Page

Optionally add Series Groups for extra levels of data (for example, Orders by Country can be broken down by year as well). Labels for the series are displayed in the chart legend. Click the Add button to open the General page. Once you have one or more series groups in place, you can use the arrow buttons to change the order or the X button to delete them.

Another way to add Series Groups is to drag fields from the Report Explorer onto the tray along the right edge of the chart that reads Optionally drop series fields here.

If you have already added values, you can right-click the value displayed in the UI along the right edge of the chart and choose Edit to open this dialog.

The Series Groups page has the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This name can be called in code.

Group on: Enter an expression to use for grouping the data.

Label: Enter an expression to use as a label for the group. You can select <Expression...> to open the Expression Editor.

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

The Sorting tab of Series Groups page allows you to enter new sort expressions and remove or change the order of them using the X or arrow buttons. For each sort expression in this list, you can also choose the direction.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select whether you want to sort the data in an Ascending or Descending direction.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Filters Page

Show Chart Data Filters Page

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the chart.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values (used with the In and Between operators) separate values using commas.

Data Output Page

Show Chart Data Output Page

Element name: Enter a name to be used in the XML output for the chart.

Output: Choose one between Auto, Yes, No or Contents Only to decide whether to include this group in the XML output.

See Also

Concepts
Classic Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


CheckBox (Page Report)

CheckBox (Page Report)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > CheckBox (Page Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, you can use the CheckBox control to represent a Boolean value in a report. By default, it appears as a small box with text to the right. If the value evaluates to True, the small box appears with a check mark; if False, the box is empty. By default, the checkbox is empty.

Checkbox Dialog

Properties for the CheckBox are available in the Checkbox dialog. To open it, with the CheckBox control selected on the report, under the Properties Window, click the Property dialog link.

The Checkbox dialog lets you set properties on the report control with the following pages.

Note: You can select the <Expression...> option in many of these properties to create an expression to determine the value. For properties with enumerated values, the values are listed under Constants in the Fields tree view on the left side of the Expression Editor. You can also access the Expression Editor from the context menu of the CheckBox control.

Show General

Name: Enter a name for the checkbox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Value: Enter an expression or a static label, or choose a field expression from the drop-down list. You can access the expression editor by selecting <Expression...> in the list. The value of this expression or text is displayed in the report to the right of the checkbox.

Show Visibility

Initial visibility

  • Visible - The checkbox is visible when the report runs.
  • Hidden - The checkbox is hidden when the report runs.
  • Expression - Use an expression with a Boolean result to decide whether the checkbox is visible. For example, on a "Free Shipping" checkbox, you could use the expression to see whether the ShippingCountry is international. A value of true hides the checkbox, false shows it.

Visibility can be toggled by another report control: Select this checkbox to specify a report control to use as a toggle to show or hide the checkbox. Then specify the TextBox control to display with a toggle image button. When the user clicks the TextBox control, the checkbox changes between visible and hidden.

Show Appearance

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background of the checkbox.

Image: Enter an image to use for the background of the checkbox.

Show Font

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose an enumerated weight value or select a theme.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Show Format

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Line Spacing: This property sets the space between lines of text.

Line height: This property sets the height of each line of text.

Note: This property only affects HTML output.

Character Spacing: This property sets the space between characters of text.

Text direction and writing mode

Direction: Choose LTR for left to right, or RTL for right to left.

Mode: Choose lr-tb for left right top bottom (normal horizontal text) or tb-rl for top bottom right left (vertical text on its side).

Show Alignment

Alignment

Vertical alignment: Choose Top, Middle, Bottom, or the <Expression...> option.

Horizontal alignment: Choose General, Left, Center, Right, Justify, or the <Expression...> option.

Justification method: Choose Auto, Distribute, DistributAllLines, or the <Expression...> option.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap.

Note: You must select Justify in the Horizontal alignment property to enable the Justification method property options.

Amount of space to leave around report control

  • Top padding: Set the top padding in points.
  • Left padding: Set the left padding in points.
  • Right padding: Set the right padding in points.
  • Bottom padding: Set the bottom padding in points.

Show Data Output

Element Name: Enter a name to be used in the XML output for this checkbox.

Output: Choose Auto, Yes, or No to decide whether to include this checkbox in the XML output. Auto exports the contents of the checkbox only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render checkboxes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.

Attribute example: <table1 checkbox3="Report created on: 7/26/2005 1:13:00 PM">

Element example: <table1> <checkbox3>Report created on: 7/26/2005 1:13:28 PM</checkbox3>

See Also

CheckBox (Section Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Container

Container
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Container

Glossary Item Box

Show All Show All
Hide All Hide All

The Container report control is a container for other items. There are a number of ways in which you can use it to enhance your reports.

Visual Groupings

You can place report controls within the Container to group them visually, and to make it easier at design time to move a group of report controls.

Note: Drawing a container around existing items does not contain them. Instead you must drag the items into the container.

You can use a container as a border for your report pages, and set border properties to create purely visual effects within your report, and even display an image behind a group of report controls by setting the BackgroundImage property of the Container.

Anchoring Items

Probably the best usage of the Container report control is to anchor report controls which may otherwise be pushed down by a vertically expanding data region. For example, if you have a group of textboxes below a table with some of them to the left or right, any of them directly below the table are pushed down below the expanded table at run time, while the upper textboxes remain where you placed them at design time. To prevent this from happening, place the group of textboxes within a container.

Container Dialog

Properties for the Container are available in the Container dialog. To open it, with the Container control selected on the report, under the Properties Window, click the Property dialog link.

The Container dialog lets you set properties on the report control with the following pages.

Note: You can select the <Expression...> option in many of these properties to create an expression to determine the value. For properties with enumerated values, the values are listed under Constants in the Fields tree view on the left side of the Expression Editor.

Show General

Name: Enter a name for the container that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Page breaks:

  • Insert a page break before this container: Insert a page break before the container.
  • Insert a page break after this container: Insert a page break after the container.

Show Appearance

Background

Color: Select a color to use for the background of the container.

Image: Specify the background image of container using Expression or Data Visualizer, or directly open the image file on your system.

Note: For Page/RDL reports, if the Hatch and Gradient background styles are set using Data Visualizers, these are not displayed at design time.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Rounded Rectangle: Specify the radius for each corner of the shape independently. Drag the handlers [image] available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the Container control.

Show Visibility

Initial visibility

  • Visible: The container is visible when the report runs.
  • Hidden: The container is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the container is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the container. The user can click the toggle item to show or hide this container.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this container. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Data Output

The Data Output page of the Container dialog allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for this container.
  • Output: Choose Auto, Yes, No, or Contents only to decide whether to include the contents of this container in the XML output. Choosing Auto exports the contents of the container only when the value is not a constant.

See Also

Exploring Page and RDL Reports
Shape

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Formatted Text

Formatted Text
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Formatted Text

Glossary Item Box

Show All Show All
Hide All Hide All

The FormattedText report control can perform mail merge operations, plus it displays richly formatted text in HTML. To format text in the FormattedText report control, enter HTML code into the Html property.

The design time editor displays the HTML text with the applied formatting, so you can view the text just as it will be displayed at run time in the Designer tab.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Supported HTML Tags

If you use valid HTML tags that are not in this list, ActiveReports ignores them.

Important: All text used in the Html property must be enclosed in the <body></body> tags.
Tag | Description
<%MergeFieldName%> | Inserts a mail merge field.
<!-- -- > | Defines a comment
<!DOCTYPE> | Defines the document type
<a> | Defines an anchor
<abbr> | Defines an abbreviation
<acronym> | Defines an acronym
<address> | Defines an address element
<b> | Defines bold text
<base /> | Defines a base URL for all the links in a page
<bdo> | Defines the direction of text display
<big> | Defines big text
<blockquote> | Defines a long quotation
<body> | Defines the body element (Required)
<br /> | Inserts a single line break
<caption> | Defines a table caption
<center> | Defines centered text
<cite> | Defines a citation
<code> | Defines computer code text
<col> | Defines attributes for table columns
<dd> | Defines a definition description
<del> | Defines deleted text
<dir> | Defines a directory list
<div> | Defines a section in a document
<dfn> | Defines a definition term
<dl> | Defines a definition list
<dt> | Defines a definition term
<em> | Defines emphasized text
<h1> to <h6> | Defines header 1 to header 6
<head> | Defines information about the document
<hr /> | Defines a horizontal rule
<html> | Defines an html document
<i> | Defines italic text
<img /> | Defines an image
<ins> | Defines inserted text
<kbd> | Defines keyboard text
<li> | Defines a list item
<link> | Defines a link
<map> | Defines an image map
<menu> | Defines a menu list
<ol> | Defines an ordered list
<p> | Defines a paragraph
<pre> | Defines preformatted text
<q> | Defines a short quotation
<s> | Defines strikethrough text
<samp> | Defines sample computer code
<small> | Defines small text
<span> | Defines a section in a document
<strike> | Defines strikethrough text
<strong> | Defines strong text
<style> | Defines a style definition
<sub> | Defines subscripted text
<sup> | Defines superscripted text
<table> | Defines a table
<tbody> | Defines a table body
<td> | Defines a table cell
<tfoot> | Defines a table footer
<th> | Defines a table header
<thead> | Defines a table header
<tr> | Defines a table row
<tt> | Defines teletype text
<u> | Defines underlined text
<ul> | Defines an unordered list
Caution: To enter & in the HTML property, you need to use &amp;.

Formatted Text Dialog

Properties for the FormattedText report control are available in the Formatted Text dialog. To open it, with the control selected on the report, under the Properties Window, click the Property dialog link.

The Formatted Text dialog lets you set properties on the report control with the following page.

Show General

Name: Enter a name for the FormattedText that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Show Visibility

Initial visibility

  • Visible: The FormattedText is visible when the report runs.
  • Hidden: The FormattedText is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the FormattedText is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the FormattedText. The user can click the toggle item to show or hide this FormattedText.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this FormattedText. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Appearance

Background

Color: Select a color to use for the background of the FormattedText.

Image: Enter an image to use for the background of the FormattedText.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Show Data Output

Element name: Enter a name to be used in the XML output for this FormattedText report control.

Output: Choose Auto, Yes, No, Contents Only to decide whether to include this FormattedText in the XML output. Choosing Auto exports the contents of the FormattedText report control.

Show Mail Merge

Click the plus sign button to add a new mail merge field to the FormattedText, and delete them using the X button. Once you add one or more fields, you can reorder them using the arrow buttons.

Field: Enter a name for the field that is unique within the report. This is used in the Html property inside <%FieldName%> tags to display the field in the formatted text.

Value: Enter an expression to pull data into the control for mail merge operations.

Here is a very simple example of HTML code that you can use to add mail merge fields to formatted text. This example assumes that you have added two mail merge fields named Field1 and Field2.

Paste this code in the Html property of the FormattedText control. Copy Code
<body><p>This is <%Field1/%> and this is <%Field2/%>.</p></body>

See Also

RichTextBox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Image

Image
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Image

Glossary Item Box

Show All Show All
Hide All Hide All

The Image report control displays an image that you embed in the report, add to the project, store in a database, or access through a URL. You can choose the Image Source in the Properties Window after you place the Image report control on the report.

Show Embedded Images

The benefit of using an embedded image is that there is no separate image file to locate or to keep track of when you move the report between projects. The drawback is that the larger the file size of the image you embed, the more inflated your report file size becomes.

To embed an image in your report

  1. In the Report menu, select Embedded Images.
  2. Click under the Image column to reveal an ellipsis button (...) and select an image file from your local files. The Name and MimeType columns are filled in automatically and the image file's data is stored in the report definition.
  3. Click to select the Image report control, and in the Properties grid, set the Source property to Embedded.

  4. Drop down the Value property and select the image from the list of embedded images.

Show Data Visualizer Images

You can use a data visualizer to display data in small graphs that are easy to comprehend.

To add a data visualizer image to your report

  1. Click to select the Image report control, and in the Properties grid, drop down the Value property and select <Data Visualizer...>.

  2. In the Data Visualizers dialog that appears, select the Visualizer Type that you want to use, Icon Set, Range Bar, or Data Bar.

  3. Use expressions related to your data to set the rest of the values in the dialog.

Show Project Images

You may have an image that you want to use in multiple reports, for example a logo. In such cases, you can store it as a project image. This not only allows you to quickly locate the correct image for new reports in the project, but also makes it easier when you update your logo, as you will not need to search through every report to replace embedded images. Another benefit is that the images are distributed with your application.

To store an image in your Visual Studio project

  1. Right-click the project in the Solution Explorer and select Add, then Add Existing Item and navigate to the image.
  2. Click to select the Image report control, and in the Properties grid, set the Source property to External.

  3. Drop down the Value property and select the image from the list of project images.

Show Database Images

Product catalogues are probably the most common scenario in which images stored in a database are used in reports. Place the Image report control in a data region to use database images that repeat for every row of data.

Keep in mind that you cannot use database images in Page Headers and Page Footers because these sections cannot have value expressions that refer to fields.

To use a database image in an Image report control

  1. Click to select the Image report control, and in the Properties grid, set the Source property to Database.
  2. Drop down the Value property and select the field containing the image.
Note: Microsoft Access database images are generally stored as OLE objects which the Image report control cannot read.

Show Web Images

You can also use any image to which you can navigate via a URL. The benefit of this is that images stored in this way add nothing to the file size of the project or of the report, but the drawback is that if the web based image is moved, it will no longer show up in your report.

To use a Web image

  1. Click to select the Image report control, and in the Properties grid, set the Source property to External.
  2. In the Value property, enter the URL for the image.

Image Dialog

Properties for the Image are available in the Image dialog. To open it, with the Image control selected on the report, under the Properties Window, click the Property dialog link.

The Image dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within many of these properties to open the Expression Editor.

Show General

Name: Enter a name for the image that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Image Value: Enter the name of the image to display. Depending on the Image Source chosen below, you can give a path to the image, select an image to embed, or pull images from a database. This property also allows you to choose the <Data Visualizer...> option to launch a dialog that will let you build a data visualization expression.

Image Source: Select whether the image comes from a source that is External, Embedded, or Database.

MIME Type: Select the MIME type of the image chosen.

Show Visibility

Initial visibility

  • Visible: The image is visible when the report runs.
  • Hidden: The image is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the image is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the image. The user can click the toggle item to show or hide this image.

Show Navigation

Action

Select one of the following actions to perform when a user clicks on this image.

None: The default behavior is to do nothing when a user clicks the image at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report.

Tip: You can remove or change the order of parameters using the X and arrow buttons.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this image. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

See Also

Picture

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Line

Line
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Line

Glossary Item Box

Show All Show All
Hide All Hide All

The Line report control can be used to visually separate data regions in a report layout. You can set properties in the Properties grid or the Line Dialog to control the appearance of the line, and to control when the line is rendered.

Show Important Properties

Property | Description
LineColor | Gets or sets the color of the line.
LineStyle | Gets or sets the pen style used to draw the line. The line styles include Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.
LineWidth | Gets or sets the pen width of the line in points.
Visibility | Indicates whether the line is visible or hidden.
LayerName | Gets or sets the name of the containing layer.
EndPoint | Set the vertical and horizontal end points of the line.
Location | Gets or sets the position of the top-left corner of the report item in relation to its container.

Line Dialog

Properties for the Line are available in the Line dialog. To open it, with the Line control selected on the report, under the Properties Window, click the Property dialog link.

The Line dialog lets you set properties on the report control with the following pages.

Show General

Name: Enter a name for the line that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Show Visibility

The Visibility page of the Line dialog allows you to control the following items:

Initial visibility

  • Visible: The line is visible when the report runs.
  • Hidden: The line is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the line is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the line. The user can click the toggle item to show or hide this line.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this line. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

See Also

Line (Section Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


List

List
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > List

Glossary Item Box

Show All Show All
Hide All Hide All

The List data region repeats any report controls it contains for every record in the dataset. Unlike other data regions, the List is free-form, so you can arrange report controls in any configuration you like.

Grouping in the list is done on the details group.

List Dialog

Properties for the List are available in the List dialog. To open it, with the List control selected on the report, under the Properties Window, click the Property dialog link.

The List dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

Show General

Name: Enter a name for the list that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset name: Select a dataset to associate with the list. The drop-down list is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether this List is in its own section with regards to pagination.

Page Breaks: Select any of the following options to apply to each instance of the list.

  • Insert a page break before this list
  • Insert a page break after this list
  • Fit list on a single page if possible

Show Detail Grouping

Detail grouping is useful when you do not want to repeat values within the details. When a detail grouping is set, the value repeats for each distinct result of the grouping expression instead of for each row of data. For example, if you use the Customers table of the NorthWind database to create a list of countries without setting the details grouping, each country is listed as many times as there are customers in that country. If you set the details grouping to =Fields!Country.Value each country is listed only once.

Note: If the detail grouping expression you use results in a value that is distinct for every row of data, a customer number for example, you will see no difference in the results.

The Detail Grouping page of the List dialog has the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Show Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Show Visibility

Initial visibility

  • Visible: The list is visible when the report runs.
  • Hidden: The list is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the list is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the list. The user can click the toggle item to show or hide this list.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this list. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Show Data Output

Element name: Enter a name to be used in the XML output for this list.

Output: Choose Auto, Yes, or No to decide whether to include this List in the XML output. Choosing Auto exports the contents of the list.

Instance element name: Enter a name to be used in the XML output for the data element for instances of the list. This name is ignored if you have specified a detail grouping.

Instance element output: Choose Yes or No to decide whether to include the instances of the list in the XML output. This is ignored if you have specified a detail grouping.

See Also

Grouping Data (Page Layout)
Grouping Data in Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Map

Map
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Map

Glossary Item Box

Show All Show All
Hide All Hide All

The Map data region is a professional edition feature that shows your business data against a geographical background. You can create different types of map, depending on the type of information you want to communicate in your report.

The Map data region consists of the following basic elements:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Title

Map Title describes the theme or subject of the map. The purpose of map title is to tell the viewer of what he is looking at. You can add multiple titles to the Map using the MapTitleDesigner Collection Editor.

For more information, see Create a Map.

Show Viewport

Viewport refers to the area on the map where data is displayed against a geographical background. It specifies the coordinates, projection system, parallels and meridians, center point, and scale of the map. In other words, it is a map element that actually displays geographical data and occupies most area of the map control depending on the location and dock position of other map elements. For more information, see Create a Map.

The Map Viewport dialog lets you set properties with the following pages.

Show General

Coordinate system: Specify the coordinate system of the viewport. Select from Planar, Geographic, or select the <Expression...> option to open the Expression Editor and create an expression.

Projection: Specify the projection of the map. Tile layers must use the Mercator projection.

Minimum X: Specify the minimum X coordinate of the map in degrees.

Maximum X: Specify the maximum X coordinate of the map in degrees.

Minimum Y: Specify the minimum Y coordinate of the map in degrees.

Maximum Y: Specify the maximum Y coordinate of the map in degrees.

Projection Center X: Specify the X coordinate of the projection center in degrees.

Projection Center Y: Specify the Y coordinate of the projection center in degrees.

Minimum zoom: Specify the minimum zoom value.

Maximum zoom: Specify the maximum zoom value.

Map resolution: Enables the viewport to simplify vector data for polygon and line layers.

Show grid lines below the map: Specify whether to show the grid lines above or below the content of the map.

Show Meridians

Hide meridians: Specify whether to hide meridians.

Interval: Specify the spacing between the grid lines in degrees.

Line

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, Outset, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Width: Specify the width of the line.
  • Color: Select a Web or custom color for the line.

Show labels: Specify whether to show labels for meridians on the map.

Format: Specify the format string to display numeric labels.

Position: Specify the position of the meridians on the map.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal or Italic.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Show Parallels

Hide parallels: Specify whether to hide parallels.

Interval: Specify the spacing between the grid lines in degrees.

Line

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, Outset, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Width: Specify the width of the line.
  • Color: Select a Web or custom color for the line.

Show labels: Specify whether to show labels for parallels on the map.

Format: Specify the format string to display numeric labels.

Position: Specify the position of the parallels on the map.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal or Italic.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Show View

Center and zoom: Specify how the map viewport zooms and centers during the report processing.

  • Custom
  • Center map to show a map element
  • Center map to show a map layer
  • Center map to show all map elements

View Center X: Specify the X coordinate of the current view center.

View Center Y: Specify the Y coordinate of the current view center.

Zoom level: Specify the zoom level of the map view.

Show Appearance

Border

  • Style: Choose an enumerated style for the border.
  • Width: Set a width value in points between 0.25pt and 20pt.
  • Color: Select a Web or custom color for the border.

Background

  • Color: Select a color to use for the background of the Viewport.
  • Gradient: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of a report control.

Shadow offset: Specify the size of the shadow. Shadow offsets are drawn to the right and below an element.

Show Legend

A legend on a map provides valuable information to users for interpreting the map data visualization rules such as color, size, and marker type differences for map elements on a layer. By default, a single Legend item already exists in the legends collection which can be used by all layers to display items. You can also create additional legends to use them individually with layers that have associated rules to display items in the legend.

Legends are added in the LegendDesigner Collection Editor. For more information, see Create a Map.

Show Distance Scale

A distance scale helps a user to understand the scale of the map. Distance on a map is not the same as the actual real-world distance, so a distance scale shows that a certain distance on the map equals a certain distance in a real-world. In distance scale, the distance is displayed in both miles and kilometers. The scale range and values are automatically calculated using the viewport boundaries, projection type, and zoom level. For more information, see Create a Map.

The Map Distance Scale dialog lets you set properties with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

Show General

Location

  • Position: Specify the docking position of the distance scale panel. Choose from TopCenter, TopLeft, TopRight, LeftTop, LeftCenter, LeftBottom, RightTop, RightCenter, RightBottom, BottomRight, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Show distance scale outside the viewport: Specify whether the panel is docked inside or outside of the map viewport.

Scale

  • Color: Select the fill color for the distance scale bar.
  • Border color: Select the border color for the distance scale bar.

Show Appearance

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Choose the width of the border line.
  • Color: Select a color for the border.

Background

  • Color: Select a color to use for the background of the distance scale.
  • Gradient: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of the distance scale panel from the list of patterns, or select the <Expression...> option to open the Expression Editor and create an expression.

Shadow offset: Specify the size of the shadow of the distance scale panel. Shadow offsets are drawn to the right and below an element.

Show Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic, or select the <Expression...> option to open the Expression Editor and create an expression.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline and LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Show Visibility

Initial visibility

  • Visible: The distance scale is visible when the report runs.
  • Hidden: The distance scale is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the distance scale is visible. True for hidden, false for visible.

Show Navigation

Action

Select one of the following actions to perform when a user clicks on the distance scale element.

  • None: The default behavior is to do nothing when a user clicks the distance scale element at run time.
  • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
  • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.
  • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Show Color Scale

A color scale helps a user to understand the range of colors that are used for data visualization on a layer. A map has just one color scale and multiple layers can provide data for it. For more information, see Create a Map.

The Map Color Scale dialog lets you set properties with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

Show General

Location

  • Position: Specify the docking position of the color scale panel. Choose from TopCenter, TopLeft, TopRight, LeftTop, LeftCenter, LeftBottom, RightTop, RightCenter, RightBottom, BottomRight, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Show color scale outside the viewport: Specify whether the panel is docked inside or outside of the map viewport.

Color bar

  • Border color: Specify the outline color for color scale divisions.
  • Range gap color: Specify color to fill color divisions for undefined range values.

Show Labels

Display: Specify whether to display color scale labels on the color scale panel. Select from Auto, ShowMiddleValue, ShowBorderValue, or select the <Expression...> option to open the Expression Editor and create an expression.

Hide end labels: Specify whether to display first and last labels on the color scale panel.

Format: Specify the format string to display numeric labels.

Placement: Speciy the position of the color scale labels on the color scale panel. Select from Alternate, Top, Bottom, or select the <Expression...> option to open the Expression Editor and create an expression.

Interval: Specify the frequency of the labels on the color scale panel. A value of 0 means no labels are displayed.

Tick mark length: Specify the length of the tick marks on the color scale panel.

Show Title

Text: Specify the text of the color scale panel.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Show Appearance

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Specify the width of the border.
  • Color: Specify a color for the border.

Background

  • Color: Select a color to use for the background of the distance scale.
  • Gradient: Specify whether and how to use color gradients in the color scale background. Select from None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, VerticalCenter, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of the color scale panel from the list of patterns, or select the <Expression...> option to open the Expression Editor and create an expression.

Shadow offset: Specify the size of the shadow of the color scale panel. Shadow offsets are drawn to the right and below an element.

Show Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Show Visibility

Initial visibility

  • Visible: The color scale is visible when the report runs.
  • Hidden: The color scale is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the color scale is visible. True for hidden, false for visible.

Show Navigation

Action

Select one of the following actions to perform when a user clicks on the color scale element.

  • None: The default behavior is to do nothing when a user clicks the color scale element at run time.
  • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
  • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.
  • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Map Dialog

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Properties for the Map are available in the Map dialog. To open it, with the Map control selected on the report, under the Properties Window, click the Property dialog link.

The Map dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

Show General

Name: Enter a name for the map that is unique within the report. This name is called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Antialiasing: Select the smoothing mode to apply to all map control elements. Choose All, None, Text, Graphic, or select the <Expression...> option to open the Expression Editor and create an expression.

Antialiasing quality: Select the quality for antialiasing. Choose High, Normal, SystemDefault, or select the <Expression...> option to open the Expression Editor and create an expression.

Show Visibility

Initial visibility

  • Visible: The map is visible when the report runs.
  • Hidden: The map is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the map is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the map. The user can click the toggle item to show or hide this map.

Show Appearance

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Specify the width of the border.
  • Color: Select a Web or custom color for the font.

Background

  • Color: Select a color to use for the background of the map.
  • Gradient: Specify whether and how to use color gradients in the color scale background. Select from None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, VerticalCenter, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of a report control.

Show Data Output

Element name: Enter a name to be used in the XML output for this map.

Output: Choose Auto, Yes, or No to decide whether to include this map in the XML output. Choosing Auto exports the contents of the map.

Layers

A map is a collection of layers that display data on the map control.

  • Polygon layer: Display outlines of areas or markers for the polygon center point. See, Use a Polygon Layer for more information.
  • Point layer: Display markers for point locations. See, Use a Point Layer for more information.
  • Line layer: Display lines for paths or routes. See, Use a Line Layer for more information.
  • Tile layer: Adds a Bing map tiles background. See, Use a Tile Layer for more information.

A map can have one or more layers. You can load these layers on top of each other to create a more detailed map. For example, a polygon layer can represent the borders of a country, a line can represent transportation routes, a point can represent the locations and a tile can add a virtual earth background on the map. See, Use Layers for more information.

Map layer element appearance:

  • Properties that you set on a polygon layer, line layer and a point layer apply to all map elements on that layer, whether or not the map elements are embedded in the report definition.
  • Properties that you set for rules apply to all map elements on a layer. All data visualization options apply only to map elements that are associated with spatial data.

Map Layer Data Dialog

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The Map layer Data dialog is used to set up spatial and analytical data for the map control. For more information on spatial and analytical data, see Add Data.

To access Map Layer Data Properties dialog

  1. Click the map until the map panes appears.
  2. Right click the layers pane and select Add <layerName> Layer. This adds a new layer to the map and opens the Map Layer Data Properties dialog

Or, in case you already have a layer added to the map control, then follow these steps:

  1. Click the map until the map panes appears.
  2. In the layer pane, right-click the existing layer and select Layer Data to open Map Layer Data Properties dialog.

Show General

Spatial data source: Select one of the spatial data source connection types:

  • Embedded: The map layer data is loaded from the .shp data source that you embed into the map layer by indicating the .shp file in the Import spatial data from file: field. This field appears below when you select this option.

    Spatial fields: Use the plus sign button to add a field, and the X button to delete a field. For each newly added spatial field, you must specify the name and type in the corresponding fields below.

    Field name: Enter a name of a spatial field.

    Field type: Select the type of a spatial field from the list.

  • Linked: The map layer data is linked to the .shp file and is uploaded at report rendering. You select this type of data source by indicating the .shp file in the File Name field that appears.
  • Dataset: The map layer data is loaded from the data source of the report. In the Dataset field and in the Field name field that appear below, select a dataset from the bound data source and a dataset field.
    Caution: In Field name, simply type the name of the dataset field that contains spatial data. For example, enter the dataset field name as StateName, not as =[StateName].
  • Analytical data: The map layer data is loaded from the the analytical dataset of the bound report data source. In the Field name field that appears below, you must set the name of the data field that contains spatial data in the Analytical dataset.
    Caution: In Field name, enter the data field name as =[StateName], not as StateName.

Show Analytical Data

Dataset: Select the dataset for the analytical data to be displayed on the map layer.

Match: Use the plus sign button to add a relationship between a spatial data field and an analytical data field.

Spatial field: A field with spatial data that specifies an element on the map surface, for example, boundaries of a country.

Analytical field: A field with analytical data that displays information on the related map element, for example, the country population.

Show Filters

The Filters page of the Map Layer Data Properties dialog allows you to filter the data that is included in the map. Use the plus sign button to add a filter, and the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection.

Expression: Enter the expression to use for evaluating whether data should be included in the map.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values (used with the In and Between operators) separate values using commas.

See Also

Add Data
Use Layers

How To
Create a Map

Walkthroughs
Reports with Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Overflow Place Holder

Overflow Place Holder
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Overflow Place Holder

Glossary Item Box

Show All Show All
Hide All Hide All

In a Page report, the OverflowPlaceHolder control is a rectangular placeholder for data that does not fit inside the fixed size of a List, BandedList, Tablix or Table data region. When you link a data region to an OverflowPlaceHolder, this control gets its Size property values from the FixedSize of the data region it is linked with.

You can also place multiple OverflowPlaceHolder controls in a report to create different looks for your data output. Link a data region to an OverflowPlaceHolder control and then link that OverflowPlaceHolder control to another OverflowPlaceHolder control. Two common layouts that you can create through this process are:

  • Multiple Page Layout: Place the data region on the first page of the report and OverflowPlaceHolder controls on subsequent pages to create a layout with overflow data on multiple pages.

    Note: If a page contains only an OverflowPlaceHolder with no data to display, the empty page does not render. However, if the page also contains any control with static data, the page renders. To skip rendering the page, set GrapeCity.ActiveReports.PageReportModel.Page.ThrowIfPlaceHoldersEmpty property to True.
  • Columnar Report Layout: Place the data region and the OverflowPlaceHolder on the same page of the report to create a layout that displays data in a columnar format like the one in the following image.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Data overflow to an OverflowPlaceHolder

You can bind overflow data from a data region to an OverflowPlaceHolder control or from an OverflowPlaceHolder control to another OverflowPlaceHolder control in a report. The following steps take you through the process:

These steps assume that you have already added a Page Report template to your project, connected it to a data source and added a DataSet. See Connect to a Data Source and Add a Dataset for more information.

Show To link a data region to an OverflowPlaceHolder control

When your data goes beyond the fixed size of a data region, you can create a link from the data region to enable flow of data into the OverflowPlaceHolder.

  1. From the Visual Studio toolbox, on the Page1 tab of the report, drag and drop a data region like List onto the design surface and set its FixedSize property.
  2. If the data goes beyond the fixed size of the data region, from the Visual Studio toolbox, on Page2 tab of the report, drag and drop an OverflowPlaceHolder control (OverflowPlaceHolder1 by default) onto the design surface.
  3. On the Page1 design surface, select the data region placed above and go to the Properties Window.
  4. In the Properties Window, go to the GrapeCity.ActiveReports.PageReportModel.DataRegion.OverflowName property and from the dropdown list, select the name of the OverflowPlaceHolder control you added earlier.

    The following image shows the Properties Window of a List data region (List1) where OverflowPlaceHolder1 is set in the OverflowName property.

    Tip: Depending on your layout requirements, you can place the OverflowPlaceHolder control on the same page tab as the data region or a different page tab.

Show To link an OverflowPlaceHolder control to another OverflowPlaceHolder control

You can place additional OverflowPlaceHolder controls, to display data that flows beyond the first OverflowPlaceHolder control.

  1. From the Visual Studio toolbox, drag and drop another OverflowPlaceHolder control like OverflowPlaceHolder2 onto the design surface.
  2. In the Designer, select the OverflowPlaceHolder1 control that contains overflow data and go to the properties window.
  3. In the Properties Window, go to OverflowName property and select the name of the new OverflowPlaceHolder control you placed above. For e.g., in OverflowPlaceHolder1, set the OverflowName property to OverflowPlaceHolder2.

    The following image shows the Properties Window of OverflowPlaceHolder1 where the OverflowPlaceHolder2 is set in the OverflowName property.

Caution: In a report with multiple OverflowPlaceHolder controls, link the OverflowPlaceHolder controls to their respective data regions and other OverflowPlaceHolder controls such that the overflow chain does not break.

See Also

Page Report Toolbox
Page Report
Overflow Data in Multiple Pages(Page Report)

Walkthroughs
Overflow Data in a Single Page(Page Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Shape

Shape
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Shape

Glossary Item Box

Show All Show All
Hide All Hide All

The Shape report control is used to display one of the available shape types on a report. You can add a shape report control to a report by dragging it from the toolbox and dropping it onto the report design surface.

In the ShapeStyle property of the Shape report control, you can select Rectangle, RoundRect or Ellipse, or you can use an expression to assign fields, datasets, parameters, constants, operations or common values to it. You can highlight different sections or parts of a report using a shape report control. For example, you can use a Rectangle as border around different report controls or the entire page or you can use an Ellipse to highlight a note on your report.

Shape Dialog

Properties for the Shape are available in the Shape dialog. To open it, with the Shape control selected on the report, under the Properties Window, click the Property dialog link.

The Shape dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within many of these properties to open the Expression Editor.

Show General

Name: Enter a name for the image that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Shape Style: Choose Rectangle, RoundRect or Ellipse from the dropdown list.

Rounded Rectangle: When the Shape type is set to RoundRect, you can specify the radius for each corner of the shape independently. Drag the handlers [image] available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the Shape control.

Show Appearance

Background

Color: Select a color to use for the background of the Shape.

Image: Specify the background image of shape using Expression or Data Visualizer, or directly open the image file on your system.

Note: For Page/RDL reports, if the Hatch and Gradient background styles are set using Data Visualizers, these are not displayed at design time.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Show Visibility

Initial visibility

  • Visible: The shape is visible when the report runs.
  • Hidden: The shape is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the shape is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle shape next to another report control. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the shape.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this shape. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Data Output

Element name: Enter a name to be used in the XML output for this shape report control.

Output: Choose Auto, Yes, No, Contents Only to decide whether to include this Shape in the XML output. Choosing Auto exports the contents of the Shape report control.

See Also

Shape
Container

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Sparkline

Sparkline
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Sparkline

Glossary Item Box

Show All Show All
Hide All Hide All

You can use the Sparkline report control as a simple means of displaying the trend of data in a small graph. The Sparkline displays the most recent value as the rightmost data point and compares it with earlier values on a scale, allowing you to view general changes in data over time. With the height similar to the surrounding text and the width not more than 14 letters wide, the sparkline fits well in dashboards, reports, and other documents.

Customize the Sparkline control with the following types.

Type | Description
Line | The Line sparkline is widely used in financial and economic data analysis and is based on a continuous flow of data. The currency exchange rates, changes in price are the examples of application of this type of sparklines.
Columns | The Column sparkline is used for sports scores, cash register receipts, and other cases where previous values and the current value do not closely influence one another. In this case you are dealing with discrete data points, and not a continuous flow of data as in the Line sparkline.
Whiskers | The Whisker sparkline is typically used in win/loss/tie or true/false scenarios. This type is similar to the Column sparkline, but it renders a tie (0 value) in a different manner. The bars in a whisker sparkline render below the baseline for a negative value, above the baseline for a positive value, and on the baseline for a zero value.
Area | The Area sparkline is similar to the Line sparkline but visually you see the space under the line as shaded.
StackedBar | The Stacked Bar sparkline is presented as a horizontal bar with different segment lengths marked by distinct color hues. The Stacked bar illustrates how the various segments of a part-to-whole relationship correspond to one another - the largest segment represents the highest value and the change in brightness indicates a new value on a scale.

Sparkline Dialog

Properties for the Sparkline are available in the Sparkline dialog. To open it, with the Sparkline control selected on the report, under the Properties Window, click the Property dialog link.

The Sparkline dialog lets you set properties on the report control with the following pages.

Show General

Name: Enter a name for the sparkline that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Show Data

Value: Enter an expression to use as the sparkline value.

Name: Enter a name for the sparkline that is unique within the report. This name can be called in code. A name is created automatically if you do not enter one.

Group on: Enter an expression to use for grouping the data. If you open the expression editor, you can select a field from the dataset.

Detail Grouping: Enter an expression to use if you do not want to repeat values within the details. If you open the expression editor, you can select a field from the dataset.

Parent Group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Appearance

Sparkline Type: Choose Line, Columns, Whiskers, Area or StackedBar. Each of these types has its own set of Appearance properties that appears when you select the type.

Show Line Type Appearance Properties

Last point marker is visible: Select to display a marker at the last point on the sparkline.

Marker Color: Select a color to use for the last point marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Line Style

Color: Select a color to use for the line, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Width: Enter a value in points to set the width of the line.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient to use for the backdrop: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Show Columns Type Appearance Properties

Fill Color: Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Maximum Column Width: Select the maximum width of columns in the sparkline. If blank, all columns are sized to fit.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Show Whiskers Type Appearance Properties

Fill Color: Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Maximum Column Width: Select the maximum width of columns in the sparkline. If blank, all columns are sized to fit.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Show Area Type Appearance Properties

Fill Color: Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Show StackedBar Type Appearance Properties

Fill Color: Select a color to use for the base color of the stacked bars, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The other colors of the stacked bars are calculated using this based color.

Show Visibility

Initial visibility

  • Visible: The sparkline is visible when the report runs.
  • Hidden: The sparkline is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the sparkline is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control which, if clicked, toggles the visibility of the sparkline in the Viewer.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this sparkline. You will then be able to provide a bookmark link to this item from another report item using a Jump to bookmark action.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Show Data Output

Element name: Enter a name to be used in the XML output for this sparkline report control.

Output: Choose Auto, Yes, No, Contents Only to decide whether to include this Sparkline in the XML output. Choosing Auto exports the contents of the Sparkline report control.

See Also

Set Detail Grouping In Sparklines

How To
Create a Whisker Sparkline

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Subreport

Subreport
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Subreport

Glossary Item Box

Show All Show All
Hide All Hide All

The Subreport control is a placeholder for data from a separate report. In ActiveReports, for better performance, we recommend using data regions instead of Subreport controls wherever possible. The reason is that the report server must process every instance of each subreport, which can become burdensome in very large reports with a large number of subreports processed many times per report. Using data regions to display separate groups of data can be much more efficient in such reports. For more information, see Work with Report Controls and Data Regions.

Note:
  • A Page report can use an RDL report as the target subreport.
  • You cannot use a Section report as the target of a Subreport in a Page/RDL report, and vice versa.

Subreports make sense when you need to nest groups of data from different data sources within a single data region, or when you can reuse a subreport in a number of reports. Here are some things to keep in mind while designing subreports.

  • If you make changes to the subreport without changing the main report, click Refresh to re-run the subreport in the Preview tab.
  • If you design the parent report in a stand-alone Report Designer application, save the parent report to the same directory as the subreport to render it in the Preview tab.
  • If you set borders on the Subreport control and the body of the report hosted in it, ActiveReports does not merge the two borders.
  • If the report hosted in the Subreport control cannot be found or contains no rows, only the border of the Subreport control is rendered.
  • If the hosted report is found and does contain rows, the border of the hosted report body is rendered.

Parameters

You can use parameters supplied by the parent report to filter data displayed in a subreport. You can also pass parameters to a repeating subreport nested in a data region to filter each instance.

Subreport Dialog

Properties for the Subreport are available in the Subreport dialog. To open it, with the Subreport control selected on the report, under the Properties Window, click the Property dialog link.

The Subreport dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within any of these properties to open the Expression Editor.

Show General

Name: Enter a name for the subreport that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Subreport:
Select the <From File...> option to open the Open dialog, and then select a report to display within the Subreport control.

Use this report’s theme when rendering subreport: Select this check box to have the subreport automatically use the same theme as the hosting report.

Show Visibility

Initial visibility

  • Visible: The subreport is visible when the report runs.
  • Hidden: The subreport is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the subreport is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the subreport.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this subreport. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Parameters

The Parameters page of the Subreport dialog allows you to enter new parameters and remove or change the order of parameters using the X and arrow buttons. For each parameter in this list, there is a Parameter Name and a Parameter Value.

Each Parameter Name must exactly match the name of a parameter in the target report.

For the Parameter Value, enter an expression to use to send information from the summary or main report to the subreport target.

Note: The following metods are not supported in the Parameter Value expression for a parameter that passes a value from the main report to subreport. However, this restriction does not apply to parameter default values.

  • RowNumber
  • RunningValue
  • Lookup/LookupSet
  • Previous
  • CountRows
  • CumulativeTotal

Show Data Output

Element name: Enter a name to be used in the XML output for this subreport.

Output: Choose Auto, Yes, or No to decide whether to include this subreport in the XML output. Choosing Auto exports the contents of the subreport.

See Also

SubReport (Section Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Table

Table
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Table

Glossary Item Box

Show All Show All
Hide All Hide All

The Table data region consists of columns and rows that organize data. A Table has three columns and three rows by default, a total of nine cells, each of which is filled with a text box. At design time, you can add or remove columns, rows and groupings to suit your needs. In Page and RDL reports, you can embed other data regions in table cells.

You can also choose to set the height of multiple rows or width of multiple columns using Distribute Rows Evenly and Distribute Columns Evenly options from the context menu of the Table data region. Multiple rows or columns can be selected using Ctrl key and mouse click combination or by simply dragging the mouse over rows and columns.

You can merge cells in both of horizontal and vertical direction in the Header, Group Header, Footer, Group Footer, and Detail sections when creating a report in ActiveReports Designer and ActiveReports Web Designer. You can merge cells inside one section by using Merge Cells in the context menu of selected cells. Cells of different sections cannot be merged with each other.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Adding Data

Once you place the Table data region on a report, you can add data to its cells. As with any data region, you can drag fields from your Fields list onto cells in the table. Although the default report control within each cell of the table is a text box, you can replace it with any other report control, and on RDL reports, you can even add a data region. When you drag a field into a cell in the detail row, ActiveReports automatically provides a label in the table header. As with all report controls, you can use expressions to further manipulate the data within the cells of the table. For more information, see Expressions.

Show Grouping

One of the types of rows you can add to the table is the group header or group footer. For example, if you have a report that displays Customer details – CustomerID, Address, and Country Name fields, you can add a group header, and in the Group On expression, choose the Country Name field to group the details based on country name.

You can also group the data in your detail section, and you can add multiple rows to any group in the table. You can use aggregate functions in group footer rows to provide subtotals. For more information, see Group in a Data Region.

Show Appearance

There are many ways in which you can control the appearance of the table data region. You can merge cells, control visibility, text color, and background color. You can use graphical elements within the cells and borders on the cells themselves. You can even freeze row and column headers in RDL reports in the HTML5 Viewer. For more information, see Freeze Rows and Columns.

Table Dialog

Properties for the Table are available in the Table dialog. To open it, with the Table data region selected on the report, under the Properties Window, click the Property dialog link.

The Table dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

Show General

Name: Enter a name for the table that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Dataset name: Select a dataset to associate with the table. The combo box is populated with all of the datasets in the report's dataset collection.

Header and Footer: Select any of the following options.

  • Repeat header row on each page
  • Repeat footer row on each page
  • Prevent orphaned footer on next page

Show Visibility

Initial visibility

  • Visible: The table is visible when the report runs.
  • Hidden: The table is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the table is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box where you can specify the report control which, if clicked, toggles the visibility of the table.

Show Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this table. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Show Groups

The Groups page of the Table dialog allows you to remove or change the order of items in the Group list using the X and arrow buttons. Click the Add button to add a new group to the table and set up information for each group on the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Show Visibility

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the TextBox control that users can click to show or hide this group.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Show Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Include group header: Adds a group header band (selected by default).

Include group footer: Adds a group footer band (selected by default).

Repeat group header: Repeats the group header band on each page.

Repeat group footer: Repeats the group footer band on each page.

Prevent orphaned footer:　Prints the last detailed row with the footer in order to prevent orphaned footer on the next page.

Show Detail Grouping

Detail grouping is useful when you do not want to repeat values within the details. When a detail grouping is set, the value repeats for each distinct result of the grouping expression instead of for each row of data. For example, if you use the Customers table of the NorthWind database to create a list of countries without setting the details grouping, each country is listed as many times as there are customers in that country. If you set the details grouping to =Fields!Country.Value each country is listed only once.

Note: If the detail grouping expression you use results in a value that is distinct for every row of data, a customer number for example, you will see no difference in the results.

Go to the Detail Grouping page has the following tabs.

Show General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Visibility

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Show Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Show Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Show Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the table.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Data Output

Element name: Enter a name to be used in the XML output for this table.

Output: Choose Auto, Yes, or No to decide whether to include this table in the XML output. Choosing Auto exports the contents of the table.

Detail element name: Enter a name to be used in the XML output for the data element for instances of the table. This name is ignored if you have specified a details grouping.

Detail collection name: Enter a name to be used in the XML output for the data element for the collection of all instances of the detail grouping.

Data element output: Choose Yes or No to decide whether to include the details in the XML output.

Table Layout Actions

The Table data region provides context menu options to perform basic layout actions. You can access layout options for Table rows from the context menu by right-clicking on a selected row.

  • Insert Row Above: Add a row above the selected row. The inserted row type is similar to the type of selected row, that is, if the selected row type is a header row, a new header row is added.
  • Insert Row Below: Add a row below the selected row. The inserted row type is similar to the type of selected row, that is, if the selected row type is a header row, a new header row is added.
  • Delete Rows: Delete the selected rows.
  • Distribute Rows Evenly: Set the same height for multiple selected rows.
  • Table Header: Show or hide table header rows.
  • Table Details: Show or hide table detail rows.
  • Table Footer: Show or hide table footer rows.
  • Insert Group: Insert groups in a table.
  • Edit Group: Edit a group in a table.
  • Delete Groups: Delete groups in a table.

You can access layout options for Table columns from the context menu by right-clicking on a selected column.

  • Insert Column to the Left: Add a column to the left of the selected column.
  • Insert Column to the Right: Add a column to the right of the selected column.
  • Distribute Columns Evenly: Set the same width for multiple selected columns.
  • Add Columns: Add one or more column(s) to the right of the selected column.
  • Delete Columns: Delete the selected columns.

See Also

Work with Report Controls and Data Regions
Freeze Rows and Columns (RDL Report)
Group in a Data Region

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Table of Contents

Table of Contents
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Table of Contents

Glossary Item Box

Show All Show All
Hide All Hide All

The TableOfContents report control is used to display the document map, an organized hierarchy of the report heading levels and labels along with their page numbers, in the body of a report. The TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports. Unlike the Document Map that is only available in the Viewers and cannot be rendered or printed, you can use the TableOfContents control to embed the TableOfContents structure in the report body for printing and rendering purposes. You can add a TableOfContents report control to a report by dragging it from the toolbox and dropping it onto the report design surface.

In the Properties Window, there are a number of properties that you can use to control the appearance and behavior of the TableOfContents report control. For example, you can use the OverflowName property to specify the OverflowPlaceHolder control name to link it with the TableOfContents control. The FixedHeight property allows you to set the maximum height of the TableOfContents control on each page, similar to the FixedSize property that is available with other report controls. The StyleName property allows you to apply the selected styles from a style sheet. These styles can be applied to the TableOfContents report control using the StyleName property or to Table Of Contents levels using the LevelDesigner Collection Editor dialog. For more information on how to set styles, see Add TableofContents.

The Levels property contains the collection of TableOfContents levels and allows you to access the LevelDesigner Collection Editor dialog, where you can set up the report TableOfContents levels and their properties. The MaxLevel property restricts the maximum number of levels in the document map.

Any customization made to the Document Map like setting Numbering Style for document map levels using the Report dialog or using the DocumentMap property gets directly applied to the TableOfContents control. For more information, see Add Items to the Document Map.

Table Of Contents properties Dialog

Properties for the TableOfContents are available in the Table Of Contents dialog. To open it, with the TableOfContents control selected on the report, under the Properties Window, click the Property dialog link.

The Table Of Contents Properties dialog lets you set properties on the report control with the following pages.

Note: You can click <Expression...> in many of these properties to open the Expression Editor where you can create an expression to determine the value.

Show General

Name: Enter a name for the table of contents that is unique within the report. This name can be called in code. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Show Visibility

By default, the TableOfContents is visible when the report runs, but you can hide it, hide it only when certain conditions are met, or toggle its visibility with another report control.

Initial visibility

Visible: The TableOfContents is visible when the report runs.

Hidden: The TableOfContents is hidden when the report runs.

Expression: Use an expression with a Boolean result to decide whether the TableOfContents is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle TableOfContents next to another report control. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the TableOfContents.

Show Appearance

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background.

Show Data Output

Element name: Enter a name to be used in the XML output for the TableOfContents report control.

Output: Choose Auto, Yes, No to decide whether to include this TableOfContents in the XML output. Choosing Auto exports the contents of the TableOfContents report control.

LevelDesigner Collection Editor

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The LevelDesigner Collection Editor is used to set up the report TableOfContents levels and their properties. To access the LevelDesigner Collection Editor dialog, go to the Properties Window and in the Levels property, click (Collection).

You can set the TableOfContents level properties from the following locations:

  • The Properties grid of the LevelDesigner Collection Editor.
  • The Level properties dialog that gets displayed if you click the Property Pages button above the LevelDesigner Collection Editor Properties grid.

The LevelDesigner Collection Editor lets you set the properties of a TableOfContents level as follows.

Show Appearance

BackgoundColor: Select a color to use for the background of the TableOfContents level.

Color: Select the color of the text.

Font: Select the font to render the TableOfContents level text.

Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.

Family: Choose the font family name.

Size: Choose the size in points for the font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder, or select the <Expression...> option to open the Expression Editor and create an expression.

Padding: Specify left, right, top and bottom values for the padding to apply to a TableOfContents level.

StyleName: Select a style to apply to the TableOfContents level.

TextAlign: Specify the horizontal alignment of the text.

TextDecoration: Choose from None, Underline, Overline, and LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Show Data

DataElementName: Enter a name to be used in the XML output for this TableOfContents level.

Show General

DisplayFillCharacters: Specifies whether to display a leading character. The Default value is True.

DisplayPageNumber: Specifies whether to display a page number. The Default value is True.

FillCharacter: Use the expression to specify a fill character for a leading character.

Show Layout

TextIndent: Specify the text indent.

Show Misc

Name: Specify a name for the TableOfContents level.

See Also

Document Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


TextBox

TextBox
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > TextBox

Glossary Item Box

Show All Show All
Hide All Hide All

The Textbox is the most commonly used report control that displays data. By default, the TextBox appears in each cell of a Table or Tablix data region. Also, the TextBox is what is created when you drag a field from the Data Explorer onto the report.

In the Value property of the TextBox, you can enter static text or an expression. An expression can display fields from a database, calculate a value, or visually display data.

Tip: You can enter text directly into the TextBox on the design surface of the report by double-clicking inside it.

In the Properties Window are a number of properties that you can use to control the appearance and behavior of the TextBox. For example, you can set the Action property to have the viewer jump to a bookmark within the report, another report, or a URL when a user clicks the TextBox at run time. The DataElement properties allow you to control how and whether the TextBox displays in XML exports.

By default, in RDL Reports, the TextBox can grow vertically to accommodate the data it displays, and it cannot shrink smaller than it appears at design time. To change this behavior, set the CanShrink and CanGrow properties in the Properties grid. (These properties are not available in Page Reports.)

Data Fields

When you drag a field from a dataset in the Data Explorer and drop it onto the report surface, a TextBox report control with an expression is automatically created. The type of expression that is created depends upon the context where you drop the field. The following table describes the various contexts and expressions created if you drag a field named SalesAmount onto the report.

Show Expressions created for fields in different contexts

Note: The expression created is different for a field with a string or unknown data type. In these cases, the First aggregate is used in place of the Sum aggregate in the expressions below. At run time, the first value found within the scope is displayed instead of a summary.
Context | Expression | Run-Time Behavior
Directly on the report surface | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the entire dataset.
List data region | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
BandedList data region, header or footer band | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the dataset associated with the BandedList.
BandedList data region, detail band | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
BandedList data region, group header or footer band | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the grouping.
Table data region, header or footer row | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the dataset associated with the Table.
Table data region, detail row | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
Table data region, group header or footer row | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the grouping.
Tablix data region, corner cell | none | Displays a blank cell. You can add a label or even use this area to embed other report control.
Tablix data region, column group cell | =Fields!SalesAmount.Value | Displays the value at the top of a new column for each row of data running to the right.
Tablix data region, row group cell | =Fields!SalesAmount.Value | Displays the value to the left of a new row for each row of data running down the page.
Tablix data region, body cell | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the intersection of the column and row.

Textbox Dialog

Properties for the Textbox are available in the Textbox dialog. To open it, with the Textbox control selected on the report, under the Properties Window, click the Property dialog link.

The Textbox dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within many of these properties to open the Expression Editor. You can also access the Expression Editor from the context menu of the TextBox control.

Show General

Name: Enter a name for the textbox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tooltip: A textual label for the report item used to include TITLE or ALT attributes in HTML reports.

Note: When the group or dataset breaks to a new page, the first instance of the repeated value is printed.

Show Visibility

Initial visibility allows you to select from the following options:

  • Visible: The textbox is visible when the report runs.
  • Hidden: The textbox is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the textbox is visible. For example, on a "Free Shipping" textbox, you could use the expression to see whether the ShippingCountry is international. A value of True hides the textbox, False shows it.

Visibility can be toggled by another report control: If you select this check box, it enables the drop-down box where you can specify the TextBox control that users can click to toggle the visibility of the textbox.

Initial appearance of the toggle image: allows you to select from the following options:

  • Expanded: The toggle image shows as a minus sign, and all instances of this textbox are visible.
  • Collapsed: The toggle image shows as a plus sign, and all instances of this textbox are hidden.
  • Expression: Use an expression with a Boolean result to decide whether the toggle image is expanded. A value of True expands the toggle image, False collapses it.

Show Navigation

Action

Select one of the following actions to perform when a user clicks on the textbox.

None: The default behavior is to do nothing when a user clicks the textbox at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server. You can also use expressions to create drill-through links.

Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report. You can remove or change the order of parameters using the X and arrow buttons.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this textbox. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Show Appearance

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background of the textbox.

Image: Enter an image to use for the background of the textbox.

Note: The Background Color and Background Image properties allow you to choose the <Data Visualizer...> option as well to launch the dialog that let you build a data visualization expression.

Show Font

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, or Bolder.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Show Format

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Line Spacing: This property sets the space between lines of text.

Character Spacing: This property sets the space between characters.

Minimal rate of text horizontal shrinking (in %): Specify the percentage to which the text should be shrunk horizontally.

Textbox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Can shrink text to fit fixed size control: Select this check box to set ShrinkToFit to True.

Text direction and writing mode

Direction: Choose LTR for left to right, or RTL for right to left.

Mode: Choose lr-tb for left right top bottom (normal horizontal text) or tb-rl for top bottom right left (vertical text on its side).

Angle: Enter the number of degrees to rotate the text in a counter-clockwise direction. Enter a negative number to rotate the text in a clockwise direction.

Show Alignment

Vertical alignment: Choose Top, Middle, Bottom, or the <Expression...> option.

Horizontal alignment: Choose General, Left, Center, Right, Justify, or the <Expression...> option.

Justify method: Set Horizontal alignment to Justify to enable this property. Choose Auto, Distribute, DistributeAllLines, or the <Expression...> option.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap.

Amount of space to leave around report control

  • Top padding: Set the top padding in points.
  • Left padding: Set the left padding in points.
  • Right padding: Set the right padding in points.
  • Bottom padding: Set the bottom padding in points.

Show Interactive Sort

Select the checkbox next to Add an interactive sort action to this textbox to enable the following controls which allow end users to sort the report data in the viewer.

Sort expression: Enter an expression to use for determining the data to sort.

Data region or group to sort: Select the grouping level or data region within the report to sort. The default value is Current scope, but you may also elect to choose an alternate data region or grouping.

Evaluate sort expression in this scope: Select the grouping level within the report on which to evaluate an aggregate sorting expression. The default value is Current scope, but you may also elect to choose an alternate data region or grouping.

Show Data Output

Element Name: Enter a name to be used in the XML output for this textbox.

Output: Choose Auto, Yes, or No to decide whether to include this textbox in the XML output. Auto exports the contents of the textbox only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render textboxes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.

Attribute example: <table1 textbox3="Report created on: 7/26/2005 1:13:00 PM">

Element example: <table1> <textbox3>Report created on: 7/26/2005 1:13:28 PM</textbox3>

See Also

Text Justification
TextBox (Section Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Tablix

Tablix
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Tablix

Glossary Item Box

A Tablix data region displays data in cells that are arranged in rows and columns. It provides enhanced layout capabilities ranging from creation of simple tables to advanced matrices. Tablix is essentially a combination of two data regions, the table and the matrix. Therefore, it provides all the features of a table and a matrix along with added capabilities including support for multiple adjacent groups on rows or columns and improved layout flexibility with stepped group layouts.

You can also choose to set the height of multiple rows or width of multiple columns using Distribute Rows Evenly and Distribute Columns Evenly options from the context menu of the Tablix data region. You can select multiple rows or columns using the Ctrl key and mouse click together or by simply dragging the mouse over rows and columns.

You can even freeze row and column headers in RDL reports in the HTML5 Viewer. For more information, see Freeze Rows and Columns.

This topic describes how the elements of the Tablix data region work together and explains its basic operations.

  • Areas of Tablix Data Region
  • Row Column Handles
  • Tablix Layout Actions

Areas of the Tablix Data Region

The Tablix data region is composed of four areas denoted by dotted lines on the design surface: the corner, the row group area, the column group area, and the body. By default, each tablix cell contains a TextBox control and the function for each cell is determined by its location. You can change the layout of the Tablix data region using the GrapeCity.ActiveReports.PageReportModel.Tablix.LayoutDirection property.

ActiveReports includes a Group Editor window that is specifically designed to manage the tablix structure. In the Visual Studio integrated designer as well as in applications using the Designer control, the Group Editor window is located below the report design surface. Developers can use it in custom designer applications as well.

Note: In case the Group Editor window does not appear automatically in your application, select View > Other Windows > Group Editor 13 in your Visual Studio project.

The image below demonstrates the areas of a Tablix data region, where column groups are set to TheoryScore and PracticalScore, and the row group is set to SubjectName.

Tablix Data Region Areas

The Group Editor window contains the following groups:

  • Row Groups: The Row Groups section in the Group Editor displays all the groups that are applied in the row group area of the Tablix data region.

    Subject
    The left center cell of the Tablix data region =[SubjectName] represents the Subject group in the Group Editor window. This group displays the subject names for the current semester.

  • Column Groups : The Column Groups section in the Group Editor window displays all the groups that are applied in the column group area of the Tablix data region.

    Theory
    The center left cell of the Tablix data region =[TheoryScore] represents the Theory group in the Group Editor window. This group displays theory scores for the student in each subject.

    Practical
    The center right cell of the Tablix data region =[PracticalScore] represents the Practical group in the Group Editor window. This group displays practical scores for the student in each subject.

  • Static Cells: Static cells in the Row Groups and Column Groups are not represented in the Group Editor window because these cells are not associated with any grouped data. Static row and column cells are used to display labels and totals in a Tablix data region.

    The static column cell displays the label ASSESSMENT and TOTAL ASSESSMENT in the Tablix data region. The static row cell displays the label Total in the Tablix data region.

The image below displays the subjects in a row group. Nested column groups display practical and theory scores for the students. The total row displays the total scores for all of the subjects.

Tablix Data Region Areas

To perform basic operations in the Tablix data region, we need to first understand the concept of static and dynamic rows and columns.

Rows or columns in the Tablix data region can be static or dynamic. The Tablix data region contains multiple rows and columns that provide a grid type layout, where you can add or remove static or dynamic rows and columns in order to display your data efficiently.

  • Static Rows and Columns - A static row or column is not associated with any group data. When the report runs, a static row or column is rendered only once. Labels and totals are displayed using static rows or columns in Tablix data region.
  • Dynamic Rows and Columns - A dynamic row or column is associated with one or more groups, and renders once for every unique value in the group. You can also create dynamic group rows or columns by adding a row group or a column group.

Row and Column Handles

When you select a Tablix data region, the row and column handles appear. These handles help you to work with the data region and visually specify the type of data added in your tablix layout.

The following table shows the different types of handles that appear in a Tablix data region.

Handle Icon | Description
OuterGroup | Row or column with one outer group.
ParentChildGroup | One outer group and one inner group.
OuterInnerGroup | One outer group with an extra row for totals and one inner group.

Tablix Layout Actions

The Tablix data region provides context menu options to perform basic layout actions. You can access layout options for Tablix rows from the context menu by right-clicking on a selected row.

  • Insert Row: Select from the following options to insert a row inside or outside of the selected group cell.
    • Inside Group: If a row group contains groups having distinct values, then as many rows are inserted as there are groups.
      • Above: Inserts a row above for each unique value of the row group.
      • Below: Inserts a row below for each unique value of the row group.
    • Outside Group: If a row group contains nested groups consisting of child and parent groups, then as many rows are inserted as there are parent groups.
      • Above: Inserts a row above for each unique value of the parent row group.
      • Below: Inserts a row below for each unique value of the parent row group.
  • Delete Row: Delete the selected rows.
  • Distribute Rows Evenly: Set the same height for multiple selected rows.
  • Add Row Group: Select from the following options to insert row groups in a tablix.
    • Parent Group: To insert a parent row group.
    • Child Group: To insert a child row group.
    • Adjacent Above: To insert an adjacent row group above the selected row group.
    • Adjacent Below: To insert an adjacent row group below the selected row group.
  • Row Group: Select the Delete Group option to delete a row group.

You can access layout options for Tablix columns from the context menu by right-clicking on a selected column.

  • Insert Column: Select from the following options to insert a column inside or outside of the selected group cell.
    • Inside Group: If a column group contains groups having distinct values, then as many columns are inserted as there are groups.
      • Left: Inserts a column to the left for each unique value of the column group.
      • Right: Inserts a column to the right for each unique value of the column group.
    • Outside Group: If a column group contains nested groups consisting of child and parent groups, then as many columns are inserted as there are parent groups.
      • Left: Inserts a column to the left for each unique value of the parent column group.
      • Right: Inserts a column to the right for each unique value of the parent column group.
  • Delete Column: Delete the selected columns.
  • Distribute Columns Evenly: Set the same width for multiple selected columns.
  • Add Column Group: Select from the following options to insert column groups in a tablix.
    • Parent Group: To insert a parent column group.
    • Child Group: To insert a child column group.
    • Adjacent Left: To insert an adjacent column group to the left of the selected column group.
    • Adjacent Right: To insert an adjacent column group to the right of the selected column group.
  • Column Group: Select the Delete Group option to delete a column group.

See Also

Tablix Reports

Walkthroughs
Tablix

How To
Freeze Rows and Columns (RDL Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Tablix Reports

Tablix Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Tablix > Tablix Reports

Glossary Item Box

Tablix data region can be used to display complex data using row groups and column groups. Let us look at a few scenarios to understand how Tablix data region works.

Using Multiple Adjacent Groups

In Tablix data region, unlike Matrix and Table data regions, it is possible to create multiple adjacent groups. Let us take an example of a Sales report to understand how grouping works in a Tablix data region.

Scenario

An organization wants to create a Sales report that displays sales data by year and media type. To design such a report using Tablix data region, you need to create multiple adjacent groups in column group area, a single group in row group area, and display aggregated data in the body area.

Let us see how each area of Tablix data region works to create the desired output given below.

Column group area
The column group area contains two adjacent groups, namely Year and Media Type. The Year group displays the grouped data according to the year 2004 and 2005 and the Media Type group displays the grouped data values according to DVD, VHS, LaserDisc, HD-DVD media types stored in the database.

Row group area
The row group area contains a single group that is StoreName. Cells in the row group area display row group values and represent members of the row group hierarchy.

Body area
This area displays the aggregate sum of the TotalAmount in the Tablix. Cells in the tablix body area display detail data when the cells are in detail row or column and aggregated group data when the cell are in a group row or column.

Refer to Grouping in Tablix Walkthrough for detailed steps on how to create the above report using Tablix data region.

Using Cell Merging

In Tablix data region, it is possible to merge cells having duplicate values. Let us take an example of a Store Mangers report to understand how cell merging works in a Tablix data region.

Scenario

An organization wants to create a report to display names of all the store managers, using the concept of cell merging where cells with same value are merged automatically to avoid clutter.

To design such a report, you need to create nested groups in Tablix data region to display the name of managers according to the Region, District and StoreName.

Let us see how each area of Tablix data region works to create the desired output given below.

Column group area
The column group area contains no groups, however there are static labels for each column. There are four column labels, namely Region, District, Store, and Manager that are added as headers to describe information about the data.

Row group area
The row group area contains three groups that are nested in a parent/child relationship to display the row group data. The Region (parent) and District group (child) values are merged automatically to remove duplicate data values.

Body area
This area displays the full name of store managers. The body area displays the managers full name by concatenating two fields FirstName and LastName using the & operator in the expression.

Refer to Cell Merging in Tablix Walkthrough for detailed steps on how to create the above report using Tablix data region.

See Also

Grouping in Tablix

Concepts
Tablix

Walkthroughs
Cell Merging in a Row Group Area in Tablix

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Data Sources and Datasets

Data Sources and Datasets
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets

Glossary Item Box

Setting up a connection to the data source is the first step in binding data to the report. Once a connection is established, a data set is required to get the data you want to show on the report.

Data Sources

In ActiveReports, you can set the data source information in the Report Data Source Dialog.

The Report Data Source dialog is where you select the type of data to use, provide a connection string, and choose other options for your data source. You can also decide to use a shared data source, use a single transaction, and select a method for handling credentials. Once you add a data source, it appears in the Report Explorer under the Data Sources node. You can also add multiple data sources in a single report.

Datasets

A dataset fetches data from the data source to display in a report. The DataSet Dialog is where you provide a command type and query string and choose other options for your dataset.

You can also control the timeout period and other data options, and add fields, parameters, and filters to fetch the data you need. With the XML data type, you have to add fields manually with XPath expressions. Once you have added a dataset, its fields appear under the Data Source node in the Report Explorer. You can add multiple datasets for a data source.

Note: In both Page and RDL reports, you can also use multiple data sets, see Nested Data Regions Bound to Different Data for more information.

See Also

How To
Bind a Page Report to a Data Source at Run Time

Page Report/RDL Report Concepts
Report Data Source Dialog

Report Page Concepts
DataSet Dialog

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Data Source Dialog

Report Data Source Dialog
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog

Glossary Item Box

You can access the Report Data Source dialog from the Report Explorer by doing one of the following:

  • Click the Add icon on the top left and select Data Source.
  • Right-click the Data Sources node and select Add Data Source.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The Report Data Source dialog provides the following pages where you can set data source properties:

General

The General page of the Report Data Source dialog is where you can set the Name, Type, and Connection string of a new data source, or choose to use a shared data source reference.

  • In the Name field, you can enter a name for the data source. This name must be unique within the report. By default, the name is set to DataSource1.
  • In the Shared Reference checkbox, you can select a shared data source reference. See Connect to a Data Source for further information. Once you have chosen the Shared Reference option, the Reference field to select a Shared Data Source becomes available. In the Reference field, select From File and select a shared data source file on your machine.
  • If the Shared Reference checkbox is clear, you can select a data source type from the Type dropdown field. ActiveReports supports the following providers:
    • Microsoft SQL Client Provider
    • Csv Provider
    • DataSet Provider
    • JSON Provider
    • Microsoft ODBC Provider
    • Microsoft OleDb Provider
    • Oracle Client Provider
    • XML Provider
  • You can also select to execute datasets that use this data source in a single transaction by checking the Use Single Transaction checkbox.
  • If you select SQL, OleDb, or Oracle as the data source Type value, the Connection Properties, Connection String and Advanced Settings pages appear under the Connection section. For XML data source, Connection Properties and Connection String pages appear. For JSON data source, Schema, Content, and Connection String pages appear. In other data source types, only the Connection String page appears.

Credentials

The Credentials page gives you the following four options for the level of security you need for the data in your report.

Use Windows Authentication

Select this option when you know that any users with a valid Windows account are cleared for access to the data, and you do not want to prompt them for a user name and password.

Use a specific user name and password

Select this option when you want to allow only a single user name and password to access the data in the report.

Prompt for credentials

Select this option when there is a subset of users who can access the data. The Prompt string textbox allows you to customize the text requesting a user name and password from users.

No credentials

Select this option only if the data in the report is for general public consumption.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Microsoft SQL Client Provider

Microsoft SQL Client Provider
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > Microsoft SQL Client Provider

Glossary Item Box

The Microsoft SQL Client Data Provider supports following options under the Connection section in Report Data Source dialog.

Connection Properties

The Connection Properties tab gives access to properties specific to the following data types.

  • Server name: This field requires you to enter a server name.
  • Log on to server: Through this field, you can select whether to use Windows authentication or server authentication which requires a user name and password. Below this field you can also check the Save my password option for future reference.
  • Connect to a database: Through this field, you can select whether to enter a database name or attach a database file.

Connection String

Sample Connection string

data source=in-data-sql\sql_2012;initial catalog=ADventurewORKS2012;user id=user1;password=password@123

Advanced Settings

The Advanced Settings tab gives access to properties specific to each data type.

With the SQL data type, the Advanced Settings tab gives access to the following properties:

  • Application Name: Indicates the client application name.
  • Auto Translate: Indicates whether the OEM/ANSI characters are converted. You can set this property to True or False. By default, the value is set to True. If True then SQLOLEDB performs the OEM/ANSI character conversion when multi-byte character strings are retrieved from, or sent to, the SQL Server.
  • Current Language: Indicates the SQL Server language name. It also identifies the language used for system message selection and formatting. The language must be installed on the SQL Server, otherwise opening the connection will fail.
  • Network Address: Indicates the network address of the SQL Server, specified by the Location property.
  • Network Library: Indicates the name of the network library (DLL) used to communicate with the SQL Server. The name should not contain the path or the .dll file name extension. The default name is provided by the SQL Server client configuration.
  • Packet Size: Indicates a network packet size in bytes. The Packet Size property value must be between 512 and 32767. By default, the SQLOLEDB network packet size is 4096.
  • Trusted Connection: Indicates the user authentication mode. You can set this property to Yes or No. By default, the property value is set to No. If Yes, the SQLOLEDB uses the Microsoft Windows NT Authentication Mode to authorize user access to the SQL Server database, specified by the Location and Datasource property values. If this property is set to No, then the SQLOLEDB uses the Mixed mode to authorize user access to the SQL Server database. The SQL Server login and password are specified in the User Id and Password properties.
  • Use Procedure for Prepare: Determines whether the SQL Server creates temporary stored procedures when Commands are prepared by the Prepared property.
  • Workstation ID: Denotes a string that identifies the workstation.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


CSV Provider

CSV Provider
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > CSV Provider

Glossary Item Box

The CSV Data Provider supports following option under the Connection section in Report Data Source dialog.

Connection String

The CSV connection string is generated on the basis of options selected in the Configure CSV Data Source wizard.

Options in the Configure CSV Data Source wizard | Description | Example
Path | Path to the CSV file - both local and relative; or a URL for centrally located CSV data sources. | C:\Categories.csv
Encoding | Encoding of the CSV file. | Unicode (UTF-7)
File Type | The type of CSV file. You can choose from Fixed and Delimited options. | Delimited
Text Qualifiers | Symbol to specify where the text begins and ends. You can choose from Quotes and Single quotes options. | Quotes
Column Separator | Symbol to separate the columns. You can choose from Comma, Semicolon, Tab, and Space options. | Semicolon
Treat consecutive as one | Specify whether to join the column separators or row separators as one. | Checked for Column separator Unchecked for Row Separator
Locale | Specify the locale. | English (United States)
Starting Row | Row number to start fetching data. | 0
Columns have headers | Specify whether the CSV file has columns with headers or not. | Checked
Row Separator | Symbol to separate the rows. You can choose from CRLF (carriage return and line feed), CR (carriage return), and LF (line feed) new line formats. | New line (CRLF)
Get from preview | Fills the Columns area with names and data types (string by default) for columns present in csv file. This allows you to modify the name and data type (as String, Boolean, Date Time, Integer, or Float) for the columns. | ClaimAmt(Float), SvcDate(DateTime)
Note: Text Qualifiers, Column Separator, Row Separator, and Treat Consecutive as one options are not available for Fixed file type.

For example, the following connection string is generated based on the options selected in the Example column above.

Path=C:\\Categories.csv;Encoding=utf-7;Locale=en-US;TextQualifier=";ColumnsSeparator=\;;RowsSeparator=\r\n;
Columns=EmployeeID,LastName,FirstName,Role,City;JoinColumnsSeparators=True;HasHeaders=True

See Also

Bind a Section Report to CSV Data Source

Walkthroughs
Reports with CSV Data

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


DataSet and Object Providers

DataSet and Object Providers
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > DataSet and Object Providers

Glossary Item Box

The data source and data set for DataSet Provider and Object Provider data types can be set at run time. For more information, see Bind a Page Report to a Data Source at Run Time.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


JSON Provider

JSON Provider
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > JSON Provider

Glossary Item Box

The JSON Data Provider supports following options under the Connection section in Report Data Source dialog.

Content

In the Content tab, specify the type of JSON data source. The options available for specifying the JSON data are as follows:

  • External file or URL: Enter the path or URL of an external JSON data file or select the file from the drop-down which displays the JSON files available in the same folder as the report. The connection string generated using this option starts with the keyword jsondoc.
  • Embedded: Enter the path of the JSON data file to embed in the report. You can enter the data manually or edit the data in selected JSON file. The connection string generated using this option starts with the keyword jsondata.
  • Expression: Enter an expression to bind to the JSON data at runtime. For more information on Expressions, see Use Dynamically Built JSON Data Source topic.

Schema

The JSON schema describes the structure of a JSON data. In ActiveReports, the JSON data provider uses the JSON schema to obtain fields. For more information on JSON schema, please see http://json-schema.org/latest/json-schema-core.html.
The keywords of JSON schema that are supported in the JSON data provider are:

  • type: Indicates the type of the JSON schema element. See here for more information on type keyword.
  • properties: Indicates the properties collection for JSON schema elements with the object type. See here for more information on properties keyword.
  • items: Indicates the definition of items for JSON schema elements with array type. Only single values are supported.
    For example, "items" : [ {...}, {...}, {...} ] is not supported because it contains multiple values. See here for more information on items keyword.
  • definitions: Indicates the independent definitions which can be used by other JSON schema elements using $ref keyword. See here for more information on definitions keyword.
  • $ref: Indicates the reference to a definition for JSON schema elements with object type. Only "definitions" ({ $ref : #/definitions/... }) references are supported.
Note: Schema is the only required option to create a connection string.

In the Schema tab, select the JSON schema file corresponding to your JSON data. The options available for specifying the JSON schema are:

  • External file or URL: Enter the path or URL of an external JSON schema file or select the file from the drop-down which displays the JSON files available in the same folder as the report is located. The connection string generated using this option starts with the keyword schemadoc.
  • Embedded: Enter the path of the JSON schema file to embed in the report. You can enter the schema manually or edit the schema in the selected JSON file. The connection string generated using this option starts with the keyword schemadata.

    For generating JSON schema, use the JSON schema generator available at http://jsonschema.net/#/.

Connection String

JSON connection string has two parts - jsondoc or jsondata and schemadoc or schemadata.

  • jsondoc or jsondata: Refers to a specific JSON data file located on either the file system or at a web-accessible location.
  • schemadoc or schemadata: Refers to JSON schema file corresponding to the existing JSON data.

    For example,
    jsondoc=C:\Data\customers.json;schemadata={
      "$schema": "http://json-schema.org/draft-04/schema#",
      "type": "object",
      "properties": {
        "address": {
          "type": "object",
          "properties": {
            "streetAddress": {
              "type": "string"
            },
            "city": {
              "type": "string"
            }
          },
          "required": [
            "streetAddress",
            "city"
          ]
        },
        "phoneNumber": {
          "type": "array",
          "items": {
            "type": "object",
            "properties": {
              "location": {
                "type": "string"
              },
              "code": {
                "type": "integer"
              }
            },
            "required": [
              "location",
              "code"
            ]
          }
        }
      },
      "required": [
        "address",
        "phoneNumber"
      ]
    }
Note: If you are using an expression in the connection string, you should use single quotes (') instead of double quotes (") in jsondoc or jsondata and schemadoc or schemadata.

For example, the following connnection string is invalid:

="jsondata={  "Name": "Name"};schemadata={    "$schema": "http://json-schema.org/draft-04/schema#",
    "definitions": {},    "id": "http://example.com/example.json",
    "properties": {        "Name": {            "id": "/properties/Name",
            "type": "string"        }    },    "type": "object"}"

Use the following instead:

="jsondata={  'Name': 'Name'};schemadata={    '$schema': 'http://json-schema.org/draft-04/schema#',
    'definitions': {},    'id': 'http://example.com/example.json',
    'properties': {        'Name': {            'id': '/properties/Name',
            'type': 'string'        }    },    'type': 'object'}"

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Microsoft ODBC Provider

Microsoft ODBC Provider
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > Microsoft ODBC Provider

Glossary Item Box

The Microsoft ODBC Data Provider supports following option under the Connection section in Report Data Source dialog.

Connection String

Sample Odbc Connection String

Driver=Microsoft Access Driver (*.mdb);Dbq=C:\nwind.mdb;

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Microsoft OLeDb Provider

Microsoft OLeDb Provider
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > Microsoft OLeDb Provider

Glossary Item Box

The Microsoft OleDb Data Provider supports following options under the Connection section in Report Data Source dialog.

Connection Properties

The Connection Properties tab gives access to properties specific to the following data types.

  • OLE DB Provider: This field requires you to select one among the list of OLE DB Providers provided in the drop down list.
  • Enter a server or file name: This field requires you to enter a server or a file name along with its location.
  • Log on to server: Through this field you can select whether to use Windows NT integrated security or use a specific user name and password.

Connection String

Sample OleDb Connection String

provider=Microsoft.Jet.OLEDB.4.0;data source=c:\nwind.mdb;

Advanced Settings

With the OleDb data type, the Advanced Settings tab gives access to the Microsoft Jet OLEDB provider-specific connection parameters.

  • Jet OLEDB: Compact Reclaimed Space Amount: Indicates an estimate of the amount of space, in bytes, that can be reclaimed by compacting the database. This value is only valid after a database connection has been established.
  • Jet OLEDB: Connection Control: Indicates whether users can connect to the database.
  • Jet OLEDB: Create System Database: Indicates whether to create a system database when creating a new data source.
  • Jet OLEDB: Database Locking Mode: Indicates the locking mode for this database. The first user to open the database determines what mode to use when the database is open.
  • Jet OLEDB: Database Password: Indicates the database password.
  • Jet OLEDB: Don't Copy Locale on Compact: Indicates whether the Jet should copy locale information when compacting a database.
  • Jet OLEDB: Encrypt Database: Indicates whether a compacted database should be encrypted. If this property is not set, the compacted database will be encrypted if the original database was encrypted.
  • Jet OLEDB: Engine Type: Indicates the storage engine to access the current data store.
  • Jet OLEDB: Exclusive Async Delay: Indicates the maximum length of time, in milliseconds, that the Jet can delay asynchronous writes to disk when the database is opened exclusively. This property is ignored unless Jet OLEDB: Flush Transaction Timeout is set to 0.
  • Jet OLEDB: Flush Transaction Timeout: Indicates the amount of time before data stored in a cache for asynchronous writing is actually written to disk. This setting overrides the values for Jet OLEDB:Shared Async Delay and jet OLEDB: Exclusive Async Delay.
  • Jet OLEDB: Global Bulk Transactions: Indicates whether the SQL bulk transactions are transacted.
  • Jet OLEDB: Global Partial Bulk Ops: Indicates the password to open the database.
  • Jet OLEDB: Implicit Commit Sync: Indicates whether the changes made in internal implicit transactions are written in synchronous or asynchronous mode.
  • Jet OLEDB: Lock Delay: Indicates the number of milliseconds before attempting to acquire a lock after a previous attempt has failed.
  • Jet OLEDB: Lock Retry: Indicates the frequency of attempts to access a locked page.
  • Jet OLEDB: Max Buffer Size: Indicates the maximum amount memory, in kilobytes, the Jet can use before it starts flushing changes to disk.
  • Jet OLEDB: MaxLocksPerFile: Indicates the maximum number of locks the Jet can place on a database. The default value is 9500.
  • Jet OLEDB: New Database Password: Indicates the new password for this database. The old password is stored in Jet OLEDB: Database Password.
  • Jet OLEDB: ODBC Command Time Out: Indicates the number of milliseconds before a remote ODBC query from the Jet will timeout.
  • Jet OLEDB: Page Locks to Table Lock: Indicates how many pages to lock within a transaction before the Jet attempts to promote the lock to a table lock. If this value is 0, then the lock is never promoted.
  • Jet OLEDB: Page Timeout: Indicates the number of milliseconds before the Jet will check if its cache is out of date with the database file.
  • Jet OLEDB: Recycle Long-Valued Pages: Indicates whether the Jet should aggressively try to reclaim BLOB pages when they are freed.
  • Jet OLEDB: Registry Path: Indicates the Windows registry key that contains values for the Jet database engine.
  • Jet OLEDB: Reset ISAM Stats: Indicates whether the schema Recordset DBSCHEMA_JETOLEDB_ISAMSTATS should reset its performance counters after returning performance information.
  • Jet OLEDB: Shared Async Delay: Indicates the maximum amount of time, in milliseconds, the Jet can delay asynchronous writes to disk when the database is opened in the multi-user mode.
  • Jet OLEDB: System Database: Indicates the path and file name for the workgroup information file (system database).
  • Jet OLEDB: Transaction Commit Mode: Indicates whether the Jet writes data to disk synchronously or asynchronously when a transaction is committed.
  • Jet OLEDB: User Commit Sync: Indicates whether changes made in transactions are written in the synchronous or the asynchronous mode.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Oracle Client Provider

Oracle Client Provider
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > Oracle Client Provider

Glossary Item Box

The Oracle Client Data Provider supports following options under the Connection section in Report Data Source dialog.

Connection Properties

  • Server name: This field requires you to enter a server name.
  • Log on to server: This field requires you to enter a user name and a password for server authentication. Below this field you can also check the Save my password option for future reference.

Connection String

Sample Oracle Connection String

provider=ORACLE;data source=in-data-sql/orcl.grapecity.net;user id=user1;password=password@123;

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


XML Provider

XML Provider
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog > XML Provider

Glossary Item Box

The XML Data Provider supports following options under the Connection section in Report Data Source dialog.

Connection Properties

  • External file or URL: This field requires you to enter the path of an external XML source such as a local file or the http location of a file.
  • Embedded: This field requires you to enter the path of the XML file to embed in the report. You can also enter the data manually or edit the data in selected XML file.
  • Expression: This field requires you to enter the path expression. User can also enter the path expression in the Connection String.

Connection String

  • xmldoc: Refers to a specific XML file located on either the file system or at a web-accessible location. For example, xmldoc=C:\MyXmlFile.xml;
  • xmldata: Provides specific XML data in the Connection String itself. For example,
    xmldata=<people>
      <person>
        <name>
          <given>John</given>
          <family>Doe</family>
        </name>
      </person>
      <person>
        <name>
          <given>Jane</given>
          <family>Smith</family>
        </name>
      </person>
    </people>;
  • TransformationDoc: Refers to a specific XSLT file to apply to the XML data.

Note that elements in the Connection String must be terminated with a semicolon (;) character.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


DataSet Dialog

DataSet Dialog
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > DataSet Dialog

Glossary Item Box

Show All Show All
Hide All Hide All

You can access the DataSet dialog from the Report Explorer by doing one of the following:

  • With the Data Source node (like DataSource1) selected, click the Add icon on the top left and select Data Set.
  • Right-click an existing data source and select Add Data Set.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The DataSet dialog provides the following pages where you can set dataset properties:

Show General

The General page of the DataSet dialog is where you can set the Name of the dataset.

Name: In the Name field, you can enter a name for the dataset. By default, the name is set to DataSet1. The name of the dataset appears in the tree view of the Report Explorer. It is also used to call the dataset in code so it should be unique within the report.

Show Query

The Query page of the DataSet dialog is where you set the SQL query, stored procedure or table to define the data you want to fetch in the dataset of your report.

Command type: You can choose from the three enumerated command types.

Type | Description
Text | Choose Text if you want to write a SQL query to retrieve data.
StoredProcedure | Choose StoredProcedure if you want to use a stored procedure.
TableDirect | Choose TableDirect if you want to return all rows and columns from one or more tables.

Query: Based on the command type you select above, you can set the query string in this field.

Note:

  • If you select the TableDirect command type, you may need to use escape characters or qualifying characters in case any of the table names include special characters.
  • For Oracle data source, you should use the Text SQL query as command type instead of StoredProcedure to call a stored procedure.

  • Specify the calculated index for arrays in a JSONPath expression in the following ways:

    • To obtain the last entry in an array, use -1: in square brackets. For example, use $..book[-1:].
    • To obtain evaluated expressions correctly, the field names in square brackets should be in single quotes. For example, use $..book[0]['category','author'].

To create multiple datasets based on the JSON data provider, check Select multiple nodes option in the JSON Query Builder.

Timeout: You can set the number of seconds that you want the report server to wait for the query to return the data before it stops trying.

Show Options

The Options page is where you select one of the various options available to the dataset.

CaseSensitivity: Set this value to Auto, True, or False to indicate whether to make distinctions between upper and lower case letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without case sensitivity.

Collation: Choose from Default or a country from the list to indicate which collation sequence to use to sort data. The Default value causes the report server to get the value from the data provider. If the data provider does not set the value, the report uses the server locale. This is important with international data, as the sort order for different languages can be different from the machine sort.

KanaTypeSensitivity: Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between Hiragana and Katakana kana types. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without kana type sensitivity.

WidthSensitivity: Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between single-byte (half-width) characters and double-byte (full-width) characters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without width sensitivity.

AccentSensitivity: Set this value to Auto, True, or False to indicate whether distinctions are made between accented and unaccented letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without accent sensitivity.

Show Fields

The Fields page of the DataSet dialog populates automatically for OleDb, ODBC, SQL, JSON, XML, and Oracle data providers. To see a list of fields in the Name and Value columns of the Fields page, enter a valid query, table name, or stored procedure on the Query page.

Note: The dataset for a CSV data source is automatically created on adding the data source. You can edit the name of the data set on the General page and modify the fields on the Fields page.

You can edit the populated fields, delete them by using the Remove (X) icon, or add new ones by using the Add (+) icon above the Fields list. Any fields you add in this list show up in the Report Explorer tree view and you can drag and drop them onto the design surface. The field name must be unique within the dataset.

When working with Fields, the meaning of the value varies depending on the data source type. In most cases this is simply the name of the field. The following table describes the meaning of the field value and gives some examples of how to use the value.

Data Provider | Description | Example
SQL, Oracle, OleDb | The field value is the name of a field returned by the query. | Query: OrderQuantity FirstName
Dataset | The field value can be the name of a field in the DataTable specified by the query. You can also use DataRelations in a DataSet, specify the name of the relation followed by a period and then the name of a field in the related DataTable. | Query: Quantity OrdersToOrderDetails.CustomerID
XML | The field value is an XPath expression that returns a value when evaluated with the query. | Query: Statistics/Game/TeamName
JSON | The field value is a JSONPath expression that returns a value when evaluated with the query. | Query: $.Statistics.Game[*].TeamName
Object | The field value can be the name of a property of the object contained in the collection returned by the data provider. You may also use properties available for the object returned from a property. | Query: Quantity Order.Customer.FirstName
CSV | The field value is the name of a field returned by each column specified in the connection string. | Connection string: Path=C:\\Data\\FixedWidth.csv;Locale=en-US;TextQualifier=";ColumnsSeparator=,;RowsSeparator=\r\n;HasHeaders=True

Show Parameters

The Parameters page of the Dataset dialog is where you can pass a Report Parameter into the parameter you enter in the Query page. Enter a Name that matches the name of the Report Parameter and a Value for each parameter in this page.

  • You can edit the parameters by selecting a parameter in the list and editing its Name and Value.
  • You can delete the parameters by using the Remove (X) icon above the Parameters list.
  • You can add new parameters by using the Add (+) icon above the Parameters list. The parameter name must be unique within the dataset.

The Value of a parameter can be a static value or an expression referring to an object within the report. The Value cannot refer to a report control or field.

Show Filters

The Filters page of the Dataset dialog allows you to filter data after it is returned from the data source. This is useful when you have a data source (such as XML) that does not support query parameters.

A filter is composed of three fields:

Expression: Type or use the expression editor to provide the expression on which to filter data.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

See Also

Data Sources and Datasets

How To
Add a Dataset

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Expressions

Expressions
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Expressions

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, you can use an expression to set the value of a control in the report, or set conditions under which certain styles apply. You can set Microsoft Visual Basic® .NET in expressions through,

  • Properties in the properties window
  • Expression Editor dialog

All expressions begin with an equal sign (=). Even the expression for a field value for a TextBox is set as follows:
=Fields!LastName.Value

Expression Editor Dialog

You can build expressions quickly using the Expression Editor dialog. This dialog allows you to choose from a number of fields available to the report as well as to a particular property. You can access the Expression Editor by selecting nearly any property of a control and choosing <Expression...> from the drop-down list.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

There are the following types of fields available in the Expression Editor:

  • Constants
    Constants available for properties which have enumerated values such as TextDecoration or BorderStyle.
  • Common Values
    Run time values available to every property in every report. There are two variables in this list which come from the User collection: User ID and User Language. See Common Values for further information.
  • Parameters
    Parameters fields available in reports which contain report parameters. If available, you can choose a parameter from this field to retrieve the current value of the parameter.
  • Fields (DataSet name)
    All fields from a dataset which is linked to the report control.
  • Datasets
    All fields in each dataset associated with the report. However, the report retrieves only the sum or the first value of any field that is not within the current dataset scope.
  • Operations
    Arithmetic, comparison, concatenation, logical/bitwise, bit shift operators for creating custom expressions.
  • Common Functions
    Predefined Visual Basic .NET functions for which ActiveReports provides intrinsic support. See Common Functions for more information.
  • Document Map
    The DocumentMap.Path expression defines labels for the report's TableOfContents members. The example of such expression is =DocumentMap.Path & " General Information". If this expression is defined in the Label property of the report's control associated with the report's TableOfContents, General Information will be displayed as the label of the corresponding report's TableOfContents member.

Show To create an Expression in the Expression Editor

The Expression Editor dialog is composed of two panes, Fields and Expression.

  • From the Fields pane, select a field you want to use in your expression.
  • Click the Replace, Insert or Append button to add the field to the Expression pane. The expression pane shows the fields in a valid expression format.
  • Click OK to close the dialog.

The expression appears as the property value in the properties grid.

Tip: While building an expression, you can directly add the entire expression or part of it in the Expression pane of the Expression Editor. Then use the Insert or Append buttons to create a complete expression.

Using Expressions in Reports

In the raw form, your data may not be ideally suited for display in a report. You can customize it and bring it into shape using expressions. Following are some examples of how expressions are set in different scenarios.

Show Concatenating Fields and Strings

You can concatenate fields with strings and with other fields. For e.g., use the following expression to get a result like Customer Name: Bossert, Lewis.

="Customer Name: " & Fields!LastName.Value & "," & Fields!FirstName.Value

Show Conditional Formatting

You can use expressions in properties like Color, Font, Border etc. on specific field values based on a condition, to highlight a part of data. The formula for conditional formatting is:
=iif( Fields!YourFieldName.Value operator "Value to compare", "If condition is met, use this value.", "If not, use this one."

For e.g., if you enter the following expression in the Font > FontWeight property of a textbox that displays names of people, you get the name "Denise" in bold.

=iif(Fields!FirstName.Value = "Denise", "Bold", "Normal")

Show Functions

You can use a number of aggregate and other functions in your expressions. ActiveReports includes a range of functions, including running value, population standard variance, standard deviation, count, minimum and maximum. For e.g., use the following expression to get a count of employees.

=Count(Fields!EmployeeID.Value, Nothing)

Displaying Expressions at Design Time

As you design the report, the full text of an expression can get very long. ActiveReports makes expressions easier to read by shortening them.

When an expression is in the form:
=Fields!<FieldName>.Value

On the design surface, you see this text inside that TextBox:
=[<FieldName>]

Double-click the TextBox to view the full expression in edit mode.

For aggregates too, when the Expression value is:
=<Aggregate>(Fields!<FieldName>.Value)

On the design surface, you see this text inside the TextBox:
=<Aggregate>([<FieldName>])

This shortened expression value is only a visual change to allow you to see the field name easily. It shows up in both the TextBox on the design surface as well as any dropdown boxes inside the dialogs.

Note: You can type the format as listed above for either field name values or aggregates on field names. This evaluates the full expression when the report is viewed.

Besides the shorthand for field names, you can also type shorthand like [@Param] for parameters and [&Value] for Globals such as [&PageNumber] on the design surface. Please note that you cannot use shorthand in the Expression Editor.

See Also

Common Values
Common Functions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Common Values

Common Values
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Expressions > Common Values

Glossary Item Box

Common Values are run time values available to every property in every report. You can directly drag and drop these common values from the Report Explorer onto the design surface or add and modify the values from the Expression Editor. Following is a list of the values that you can see under the Common Values node in the Report Explorer and the Expression Editor.

Value | Description | Expression
Page N of M | Gets both the current page and the total number of pages in the report. | ="Page " & Globals!PageNumber & " of" & Globals!TotalPages
Page N of M (Section) | Gets both the current page and the total number of pages in the report section. | ="Page " & Globals!PageNumberInSection & " of " & Globals!TotalPagesInSection
Page N of M (Cumulative) | Gets both the current page and the total number of cumulative pages in a report. | ="Page " & Globals!CumulativePageNumber & " of " & Globals!CumulativeTotalPages
Current Date and Time | Gets the date and time when the report began to run. | =Globals!ExecutionTime
User ID | Gets the machine name/user name of the current user. | =User!UserID
Page Number | Gets the current page number in the report. | =Globals!PageNumber
Page Number (Section) | Gets the current page number in the report section. | =Globals!PageNumberInSection
Total Pages | Gets the total number of pages in the report. | =Globals!TotalPages
Total Pages (Section) | Gets the total number of pages in the report section. | =Globals!TotalPagesInSection
Cumulative Page Number | Gets the current cumulative page number. | =Globals!CumulativePageNumber
Cumulative Total Pages | Gets the total number of cumulative pages in the report. | =Globals!CumulativeTotalPages
Report Folder | Gets the name of the folder containing the report. | =Globals!ReportFolder
Report Name | Gets the name of the report. | =Globals!ReportName
User Language | Gets the language settings of the current user. | =User!Language
Note: Page N of M (Section), Page Number (Section) or Total Pages (Section) is applied to page numbering when you set grouping in a report. Each section represents a group, not to be confused with sections in a section report.
Note: Page N of M (Cumulative), Page Number (Cumulative) or Total Pages (Cumulative) is applied to page numbering when you use collation in a report.

See Also

Expressions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Common Functions

Common Functions
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Expressions > Common Functions

Glossary Item Box

Show All Show All
Hide All Hide All

You can use a function in an expression to perform actions on data in data regions, groups and datasets. You can access these functions in the Expression Editor dialog. In any property that accepts expressions, you can drop down the property and select <Expression...> to open the dialog.

Within the Expression Editor dialog, there is a tree view of Fields. Expand the Common Functions node to view the available functions. The following tables contain details about each of the functions included in ActiveReports for use in property expressions.

Show Date & Time

These are all methods from the DateAndTime class in Visual Basic. Please see the msdn DateAndTime Class topic for information on overloads for each method.

  • DateAdd
  • DateDiff
  • DatePart
  • DateSerial
  • DateString
  • DateValue
  • Now
  • Today
  • Day
  • Hour
  • Minute
  • Month
  • MonthName
  • Second
  • TimeSerial
  • TimeValue
  • TimeOfDay
  • Timer
  • TimeString
  • Weekday
  • WeekdayName
  • Year

Show Math

These are all methods and fields from the System.Math class. Please see the msdn Math Class topic for information on overloads for each method.
  • Abs
  • Acos
  • Asin
  • Atan
  • Atan2
  • BigMul
  • Ceiling
  • Cos
  • Cosh
  • E
  • Exp
  • Fix
  • Floor
  • IEEERemainder
  • Log
  • Log10
  • Max
  • Min
  • PI
  • Pow
  • Round
  • Sign
  • Sin
  • Sinh
  • Sqrt
  • Tan
  • Tanh

Show Inspection

These are all methods from the DateAndTime class in Visual Basic. Please see the msdn DateAndTime Class topic for information on overloads for each method.

  • IsArray
  • IsDate
  • IsDBNull
  • IsError
  • IsNothing
  • IsNumeric

Show ProgramFlow

These are all methods from the Interaction class in Visual Basic. Please see the msdn Interaction Class topic for more information.

  • Choose
  • IIf
  • Switch
  • Partition

Show Aggregate

You can use aggregate functions within report control value expressions to accrue data. ActiveReports supports aggregate functions from RDL 2005, plus some proprietary extended set of functions. For all of the functions, you can add an optional <Scope> parameter.

These are all the available aggregate functions:

Function | Description | Example
AggregateIf | Decides whether to calculate a custom aggregate from the data provider of the values returned by the expression based on a Boolean expression. | =AggregateIf(Fields!Discontinued.Value=True, Sum, Fields!InStock.Value)
Avg | Calculates the average of the non-null values returned by the expression. | =Avg(Fields!Cost.Value, Nothing)
Count | Calculates the number of non-null values returned by the expression. | =Count(Fields!EmployeeID.Value, Nothing)
CountDistinct | Calculates the number of non-repeated values returned by the expression. | =CountDistinct(Fields!ManagerID.Value, "Department")
CountRows | Calculates the number of rows in the scope returned by the expression. | =CountRows("Department")
CumulativeTotal | Calculates the sum of page-level aggregates returned by the expression for current and previous pages. | =CumulativeTotal(Fields!OrderID.Value, Count)
DistinctSum | Calculates the sum of the values returned by an expression using only the rows when the value of another expression is not repeated. | =DistinctSum(Fields!OrderID.Value, Fields!OrderFreight.Value, "Order")
First | Shows the first value returned by the expression. | =First(Fields!ProductNumber.Value, "Category")
Last | Shows the last value returned by the expression. | =Last(Fields!ProductNumber.Value, "Category")
Max | Shows the largest non-null value returned by the expression. | =Max(Fields!OrderTotal.Value, "Year")
Median | Shows the value that is the mid-point of the values returned by the expression. Half of the values returned will be above this value and half will be below it. | =Median(Fields!OrderTotal.Value)
Min | Shows the smallest non-null value returned by the expression | =Min(Fields!OrderTotal.Value)
Mode | Shows the value that appears most frequently in the values returned by the expression. | =Mode(Fields!OrderTotal.Value)
RunningValue | Shows a running aggregate of values returned by the expression (Takes one of the other aggregate functions as a parameter), | =RunningValue(Fields!Cost.Value, Sum, Nothing)
StDev | Calculates the dispersion (standard deviation) of all non-null values returned by the expression. | =StDev(Fields!LineTotal.Value, "Order")
StDevP | Calculates the population dispersion (population standard deviation) of all non-null values returned by the expression. | =StDevP(Fields!LineTotal.Value, "Order")
Sum | Calculates the sum of the values returned by the expression. | =Sum(Fields!LineTotal.Value, "Order")
Var | Calculates the variance (standard deviation squared) of all non-null values returned by the expression. | =Var(Fields!LineTotal.Value, "Order")
VarP | Calculates the population variance (population standard deviation squared) of all non-null values returned by the expression. | =VarP(Fields!LineTotal.Value, "Order")

Show Conversion

These are all methods from the Convert class in the .NET Framework. Please see the msdn Convert Class topic for more information.

  • ToBoolean
  • ToByte
  • ToDateTime
  • ToDouble
  • ToInt16
  • ToInt32
  • ToInt64
  • ToSingle
  • ToUInt16
  • ToUInt32
  • ToUInt64

Show Miscelleneous

ActiveReports also offers several functions which do not aggregate data, but which you can use with an IIf function to help determine which data to display or how to display it.

The first four are miscellaneous functions from the RDL 2005 specifications. Please see the msdn Built-in Functions for ReportViewer Reports topic for more information. GetFields is a proprietary function to extend RDL specifications.

Function | Description | Syntax and Example
InScope Determines whether the current value is in the indicated scope.
=InScope(<Scope>)
=InScope("Order")
Level Returns the level of the current value in a recursive hierarchy.
=Level(optional <Scope>)
=Level()
Previous Returns the previous value within the indicated scope.
=Previous(<Expression>)
=Previous(Fields!OrderID.Value)
RowNumber Shows a running count of all the rows in the scope returned by the expression.
=RowNumber(optional <Scope>)
=RowNumber()
GetFields

Returns an IDictionary<string,Field> object that contains the current contents of the Fields collection. Only valid when used within a data region. This function makes it easier to write code that deals with complex conditionals. To write the equivalent function without GetFields() would require passing each of the queried field values into the method which could be prohibitive when dealing with many fields.

=GetFields()
=Code.DisplayAccountID(GetFields())
Custom function. Paste in the Code tab. Copy Code
'Within the Code tab, add this function.
Public Function DisplayAccountID( flds as Object) as Object
  If flds("FieldType").Value = "ParentAccount" Then
    Return flds("AccountID").Value
  Else
    Return flds("ParentAccountID").Value
  End If
End Function
Lookup Returns the first matching value for the specified name from the dataset with pairs of name and value. For more information, see
Report Builder Functions - Lookup Function.
=Lookup(<SourceExpression>, <DestinationExpression>, <ResultExpression>, <LookupDataset>)
=Lookup(Fields!ProductID.Value, Fields!ProductID.Value, Fields!Quantity.Value, "DataSet2")
LookupSet Returns multiple row values from a specified dataset and can be used for the 1-to-many relationship. For more information, see
Report Builder Functions - LookupSet Function.
=LookupSet(source_expression, destination_expression, result_expression, dataset)
=LookupSet(Fields!CategoryID.Value, Fields!CategoryID.Value, Fields!UnitsInStock.Value, "Products")
MapPoint | Allows displaying simple data directly on the Map as a map Point Layer. | =MapPoint(<Latitude>, <Longitude>)

Scope

All functions have a Scope parameter which determines the grouping, data region, or dataset to be considered when calculating the aggregate or other function. Within a data region, the Scope parameter's default value is the innermost grouping to which the report control belongs. Alternately, you can specify the name of another grouping, dataset, or data region, or you can specify Nothing, which sets it to the outermost data region to which the report control belongs.

The Scope parameter must be a data region, grouping, or dataset that directly or indirectly contains the report control using the function in its expression. If the report control is outside of a data region, the Scope parameter refers to a dataset. If there is only one dataset in the report, you can omit the Scope parameter. If there are multiple datasets, you must specify which one to use to avoid ambiguity.

Note: You cannot set the Scope parameter to Nothing outside of a data region.

See Also

Expressions

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


LookupSet Function in Data Regions

LookupSet Function in Data Regions
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Expressions > LookupSet Function in Data Regions

Glossary Item Box

The LookupSet function returns multiple row values from a specified dataset, so you will use this function for the 1-to-many relationship. The fields of the dataset returned by the LookupSet function behave as regular dataset fields that you can use in functions/aggregates within the scope of the data region.

The following data regions can use the LookupSet function in the Value property - Tablix, Table, Classic Chart, BandedList, List, and Sparkline.

The basic syntax of the Lookup expression is as follows.

LookupSet(<SourceExpression>, <DestinationExpression>, <ResultExpression>, <LookupSetDataset>)

• SourceExpression: An expression that is evaluated in the current scope and that specifies the name or key to look up.
• DestinationField: An expression that is evaluated for each row in a dataset and that specifies the name or key to match on.
• ResultExpression: An expression that is evaluated for the row in the dataset where source_expression = destination_expression, and that specifies the value to retrieve.
• LookupSetDataset: A constant that specifies the name of a dataset in the report. For example, "ContactInformation".

The report below shows information on addresses for each employee and displays the addresses as string separated by commas. To display all addresses for each employee in a string separated by commas, we need to use the Join function in the expression with the LookupSet function.

For example:

=LookupSet(Fields!CategoryID.Value, Fields!CategoryID.Value, Fields!UnitsInStock.Value, "Products")
=Join(LookupSet(Fields!CategoryID.Value, Fields!CategoryID.Value, Fields!UnitsInStock.Value, "Products"), ",")

See Also

Common Functions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Layers

Layers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers

Glossary Item Box

  • What are Layers?
  • Why Use Layers?
  • Other Advantages

What are Layers?

Layers can be understood as a named group of controls. You can lock or unlock, add or remove, show or hide these groups of controls. When you create a new report, a Default Layer is automatically added to it.

Layers are supported in the following types of reports:

  • Page Report
  • Rdl Report

Why Use Layers?

You can trace the layout of a pre-printed form accurately using Layers. This feature is useful where you use the scanned copy of the form to trace that you can place on one Layer and you want use it to print.

Let us understand this concept with an example of a school diploma certificate. The requirement is to print the name of graduating students on a pre-printed school diploma certificates. We already have a set format for this certificate and a list of names in our data base that need to be printed at the correct location on the certification in the correct style.

Step1: Scan a copy of the school diploma certificate.

The scanned image is placed on a Layer and acts as the base image to identify the location where the name is to be placed.

As a best practice, avoid placing images of pre-printed forms on the Default Layer because this Layer cannot be deleted. Instead, create a new Layer to place the scanned image so that you can delete the Layer if you want to remove the scanned image from the background.

The Layer with the image of a pre-printed form is now ready for tracing.

Step 2: Trace a field that contains the names of graduating students.

On the Default Layer, place a TextBox control that is bound to a list of graduating students on the report designer. Placing the StudentName field at the accurate location becomes easy with the scanned image Layer displayed in the background.

Step 3: Printing the names of graduating students on the school diploma certificate.

Now, that the field has been placed at the correct location and bound to a list of student names, the last step is to print the names on the actual certificates.

Assuming that pre-printed certificates are already placed in the printer, the image Layer that contains the scanned certificate image need not be printed. This can be done using the TargetDevice property in Layers.

The TargetDevice property applies to each layer separately and you can choose from screen, paper, export, all or none options. See View, Export or Print Layers for further details. For this example, set the TargetDevice property of Default Layer to Paper for printing the name field on pre-printed certificates.

In this scenario, Layers are used to trace the layout of a field on a pre-printed certificate.

However, Layers are useful in some other scenarios as well.

Other Advantages

Creating Template Reports

Leverage the advantage of Layers in scenarios where you do not want to make changes to an existing report but want to perform minor modifications to the layout.

With Layers, it is possible to make modifications to the same report without changing the original report layout. Let's take an example of a sales receipt to see how Layers can help in this scenario.

Illustrative Example

The requirement is that a hard copy of the report is printed with a Customer Copy watermark and the soft copy of the same report is exported in a PDF format with a Merchant Copy watermark.

Lock the Default Layer to use the original sales receipt report as a template. This step is necessary to make sure that the existing layout of the template report is not modified while making changes or adding controls to the layout. Please see Working with Layers for details on how to lock a Layer.

Add two Layers on the existing report template, one for the Customer Copy watermark image and the other for the Merchant Copy watermark image. Set the TargetDevice property of Customer Layer to Paper for printing a hard copy of the sales receipt and Merchant Layer to Export for exporting it to a PDF format. Please see View, Export or Print Layers for details on how to export Layers.

In this scenario an existing report is used as a template to output two different versions of the same report without having to create and save two copies separately.

Replicating a Layout

Layers can be used to replicate the layout of a pre-printed form. This is particularly useful when you want to replicate a layout of a pre-printed form which is either uneditable or unavailable in soft copy.

Let us take an example of an order summary letter sent to the customers to see how Layers can help replicate the Layout of the scanned image easily.

Illustrative Example

Place the scanned image of the letter that needs to be replicated on Layer1 and set the DesignerLock property of this Layer to True to make sure the image being traced is not modified or changed by mistake. Please see Working with Layers for details on how to lock a Layer.

While designing any report, it is advisable to separate the layout, data and logic of your report. In this example, we have placed all the static labels like the logo, header, footer on Layer2 and data bound fields on the Default Layer. This is particularly useful when designing complex report layouts such as tax forms, regulatory notices or bill of lading forms. Working on different Layers makes report designing easier as you can modify one aspect of the report, such as static labels or bound data fields without modifying the entire report layout.

On the Default Layer, place the data bound fields like Order ID, Order Date and Amount. Notice the DesignerTransparency of Layer2 above and the Default Layer below is set to 0.5 to display the scanned image placed on Layer1 in the background.

Once the layout being used to copy the layout (scanned image in Layer1) is no longer required, set the DesignerVisible property of Layer1 to False to hide the Layer or you can also delete this Layer. DesignerVisible property helps in checking the accuracy of the layout by quickly showing or hiding the controls on the selected layer. In this case we have hidden the visibility of Layer1 to verify the layout of the final output.

In this scenario, Layers are used to replicate the layout of a scanned image and also separate the layout and the data to help organize our report better.

See Also

Working with Layers
View, Export or Print Layers

Walkthroughs
Tracing Layers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Working with Layers

Working with Layers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers > Working with Layers

Glossary Item Box

When you begin working with Layers, access the Layers List window to handle basic functions like adding or removing a Layer from a report at design time. You may also change the settings for each Layer at design time through a set of in-built properties.

Using the Layers List

The Layers List window displays a list of Layers in the report along with their visibility and lock options. You can also add or remove Layers and even send the Layer back or bring it to the front in the Layers List.

In the Layers List window,

  • A Default Layer is automatically added when you create a new page report. This Layer cannot be deleted or renamed.
  • Any Layer can be set as an Active Layer in the report by selecting it in the Layers List 13 window. There is only one Active Layer at any given time in a report.
    Note: Modifications can only be made to the Active Layer in the report. No modifications are possible on the inactive Layers.

Show or Hide the Layers List

When ActiveReports is installed on your system, a Layers List button is automatically added to the Visual Studio toolbar and it appears every time you create a new application.

  1. Right-click the Visual Studio toolbar and select ActiveReports 13 to display the report designer toolbar. See Toolbar for further details.
  2. On the report designer toolbar, click the View Layers List button. The Layers List 13 window appears.
  3. Click the View Layers List button again to hide the Layers List 13 window.

Note:

  • In case the Layers List window does not appear automatically in your application, select View > Other Windows > Layers List 13 in Visual Studio.
  • A LayerList control is also available in the Visual Studio toolbar and can be used to add the Layers feature in the End User Designer application. See how to add the Layer List control in the walkthrough on Creating a Basic End User Report Designer (Pro Edition).
  • The stand-alone designer application (GrapeCity.ActiveReports.Designer.exe) also contains a Layers List window. See Stand-alone Designer and Viewer for more information.

Add a Layer

Once a report is created, a Default Layer is automatically added in the Layers List.

  1. In the report, select the page on which the Layer is to be added.
  2. On the Layers List toolbar, click the New button.
  3. A new Layer with the name 'Layer1' gets added to the report and the Layers List.

Remove a Layer

All Layers, except the Default Layer, can be removed.

  1. In the Layers List, select the Layer to be removed.
  2. On the Layers List toolbar, click the Remove button to remove the selected Layer.

This removes the selected Layer along with the controls placed on it from the report and the Layers List.

Send to Back/Bring to Front

Use the Send to Back or Bring to Front buttons to send a group of controls placed on a selected Layer to the front or to the back of the controls on other layers.

  1. In the Layers List, select the Layer for which the order is to be set.
  2. In the Layers List toolbar, click the Bring to Front or Send to Back button to send the controls placed on a Layer to the front or the back.

Using the Layers Properties

Select a Layer from the Layers List to access the following properties in the property grid.

Property | Value | Description
DesignerLock True/False

Locks or unlocks controls placed on a Layer.

You cannot move or resize the controls placed on the design surface of a locked Layer through a keyboard or a mouse. Other editing functions like cut, copy or paste and addition or deletion of controls are possible.

This property can also be set using the check-box for Lock in the Layers List.
DesignerTransparency | 0 to 1 | Sets the transparency of the controls on a Layer at design time to a value between 0 and 1. A Layer with transparency set to 1 is not visible on the designer.
DesignerVisible True/False

Determines if the controls placed on a Layer are visible on the designer or not.

This property can also be set using the check-box for Visibility in the Layers List.
Name Layer Name (string)

Sets the name of a Layer (except the Default Layer).
TargetDevice None, Screen, Paper, Export, All

Specifies or limits the visibility of controls placed on a Layer based on the selected target.

  • None: Layer is not visible on any target device
  • Screen: Layer is visible on the viewers
  • Paper: Layer is visible on printing
  • Export: Layer is visible on export
  • All: Layer is visible on all targets i.e. Screen, Paper and Export

See View, Export or Print Layers for information on TargetDevice specific outputs.

See Also

Layers
View, Export or Print Layers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


View, Export or Print Layers

View, Export or Print Layers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers > View, Export or Print Layers

Glossary Item Box

The GrapeCity.ActiveReports.PageReportModel.Layer.TargetDevice property determines whether you can view, export or print the controls placed on a Layer. It allows you to show or hide the controls that belong to a Layer on a specific target device. For example, if you want to display controls placed on Layer1 in the WinViewer and export the output to PDF, you can select the Screen and Export options of the TargetDevice property simultaneously.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: TargetDevice property only determines the target (i.e. Screen, Export or Print) where the group of controls placed on a Layer appear. In order to get the output on a viewer or export or print the controls, you need to add code for exporting or printing or adding a viewer to the application.

TargetDevice property allows you to select from the following options:

  • None
  • Screen
  • Paper
  • Export
  • All

Setting the TargetDevice Property

Use the following steps to set or change the TargetDevice property of a Layer:

  1. Select a Layer from the Layers List window. This becomes the Active Layer of the control.
  2. In the Properties window, select the TargetDevice property.
  3. From the dropdown, select out of the options: None, Screen, Paper, Export or All.
    You can also select more than one option out of Screen, Paper and Export at the same time.

TargetDevice | Output Type | Description
None | - | Controls placed on a Layer cannot be viewed, exported or printed.
Screen | WinViewer | Controls placed on a Layer can be viewed on any of the supported viewers.
 | WebViewer
 | HTML5Viewer
 | WPF Viewer
Paper | Physical/ Virtual Printer | Controls placed on a Layer are can be printed to physical or virtual printers.
Export | RenderingExtensions - HTML, PDF, Word, Image, Xml, Excel | Controls placed on a Layer are exported to any of the supported file formats.
 | Export Filters - HTML, PDF, Tiff, Text, Rft, Excel
All | All Outputs | Controls placed on a Layer can be viewed, exported and printed.

See Also

Layers
Working with Layers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Tracing Layers

Tracing Layers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers > Tracing Layers

Glossary Item Box

In Page Reports and Rdl reports, you can trace the layout of a pre-printed form to a pixel perfect accuracy using Layers.

This walkthrough illustrates how you can trace data fields accurately from a scanned image of a boarding pass. These steps show the results on a Page Report but are applicable to Rdl Reports also.

Note: Right-click and save the image below in your project folder before starting the walkthrough.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to an XML data source
  • Adding a dataset
  • Creating a report layout on different layers
  • Viewing the report

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Adding an ActiveReport to a Visual Studio project

  1. In Visual Studio, create a new Windows Forms Application project.
  2. In the Solution Explorer window, right-click Form1, and rename it to MainForm.
  3. From the Project menu, select Add New Item.
  4. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file to Boarding.
  5. Click the Add button to open a new Page Report in the designer.
See Adding an ActiveReport to a Project for information on adding different report layouts.

Connecting the report to an XML data source

  1. From the Solution Explorer, open Boarding.rdlx created earlier.
  2. In the Report Explorer, right-click the Data Sources node and select Add Data Source or select Data Source from the Add button dropdown.
  3. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like CustomDS.
  4. In the Type drop down to select a data provider, choose Xml Provider.
  5. In the connection string section, add the following custom data to your project.
    Xml Copy Code
     XmlData =

    <Flight ID="31">
      <Passengers>
        <Passenger>

          <PassengerName>Maria Anders</PassengerName>
          <Seat>23A</Seat>
          <Tracking>2322- 030-0074321</Tracking>
        </Passenger>

        <Passenger>
          <PassengerName>Ana Trujillo</PassengerName>
          <Seat>18E</Seat>
          <Tracking>2322- 030-0074343</Tracking>
        </Passenger>

        <Passenger>
          <PassengerName>Antonio Moreno</PassengerName>
          <Seat>25A</Seat>
          <Tracking>6722- 034-6784349</Tracking>
        </Passenger>

        <Passenger>
          <PassengerName>Christina Berglund</PassengerName>
          <Seat>14B</Seat>
          <Tracking>5678- 543-6784349</Tracking>
        </Passenger>
        <Passenger>
          <PassengerName>Thomas Hardy</PassengerName>
          <Seat>28F</Seat>
          <Tracking>9834- 413-6784569</Tracking>
        </Passenger>
      </Passengers>
    </Flight>
  6. Click OK to close the dialog box.

Adding a dataset

  1. In the Report Explorer, right-click the data source created in the previous step and select Add Data Set or select Data Set option from the Add button dropdown.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as BoardingData.
  3. On the Query page, select Text under Command Type and enter the following XML path into the Query text box to access the data of each passenger.
    //Passenger
  4. On the Fields page, enter the values from the table below to create fields for your report. Values for XML data fields must be a valid XPath expression.
    Field Name | Type | Value
    Tracking | Database Field | Tracking
    PassengerName | Database Field | PassengerName
    Seat | Database Field | Seat
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

See Adding a DataSet for more information on adding dataset to a data source.

Creating a report layout on different layers

  1. In the LayerList window, click the [image] icon to add a new Layer to the report. Notice that a default Layer is already added in the Layer List.
  2. Select Layer1 to make it the Active Layer, and from the Properties window, change the Layer Name to ImgLayer.
  3. In the Layer List window, check the Lock check-box to lock ImgLayer to make sure the image being traced is not modified or changed by mistake.
  4. In the Layer List window,click the Send To Back button to move ImgLayer behind the Default Layer.
  5. In the LayerList window, select Default to make it the Active Layer.
  6. From the Properties window, set the DesignerTransparency of the Default Layer to 0.5 to display the scanned image to be placed on ImgLayer in the background.
  7. From the toolbox, drag a List data region onto the design surface of the report.
  8. In the Properties window of the List data region set the following values.
    Property Name | Values
    DataSetName | BoardingData
    FixedSize Width: 6.27in
    Height: 3in
    Location Left: 0in
    Top: 0.125in
    Size Width: 6.27in
    Height: 2.87in
  9. In the Report Explorer window, right-click the Embedded Images node and select Add Embedded Image.
  10. In the Open dialog box that appears, browse to the project folder location and select the BoardingPass.jpg image you saved earlier.
  11. Click Open to embed the image in your project.
  12. From the Report Explorer, drag the embedded BoardingPass image onto the List data region and set the properties as described in the following table.
    Property Name | Property Value
    LayerName | ImgLayer
    Location | 0in, 0.125in
    Size | 6.27in, 2.875in
  13. From the Report Explorer, drag the following fields onto the List data region and set the following properties.
    Field Name Property Values
    PassengerName

    LayerName: Default

    Location: 2.91in, 0.35in

    Size: 1.375in, 0.25in
    PassengerName

    LayerName: Default

    Location: 0.15in, 0.9in

    Size: 1.37in, 0.25in
    PassengerName

    LayerName: Default

    Location: 4.5in, 0.9in

    Size: 1.25in, 0.25in
    Tracking

    LayerName: Default

    Location: 0.15in, 2.19in

    Size: 1.5in, 0.25in
    Seat

    LayerName: Default

    Location: 4.5in, 1.45in

    Size: 1in, 0.375in

    Font > FontSize: 22pt
  14. In the Layer List window, select the Default Layer and then the ImgLayer and change their TargetDevice property to Screen from the Properties window. See View, Export or Print Layers for more information.

Viewing the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at run time.
Go to Top

See Also

Working with Layers
View, Export or Print Layers

Concepts
Layers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Styles

Styles
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Styles

Glossary Item Box

What are Styles?

Styles are a set of properties that you can apply to selected controls in your Page or RDL reports to quickly change their appearance. A single style can define properties for font, background color, line spacing, border color, padding, and many more. You can create four different types of styles, namely Common, Text, Table Of Contents and Table Of Contents Level. For more information on the type of styles and how they differ from each other, see Working with Styles.

What are Style Sheets?

ActiveReports provides you with the ability to create multiple styles and store them in a style sheet. A style sheet can be understood as a collection of styles. You can add the style sheet to your Page or RDL reports using the GrapeCity.ActiveReports.PageReportModel.Report.StyleSheetSource and GrapeCity.ActiveReports.PageReportModel.Report.StyleSheetValue properties and apply the styles to selected controls using the GrapeCity.ActiveReports.PageReportModel.Style.StyleName property. You can either embed the style sheet within your report or save it externally in the *.rdlx-styles format. For more information, see Working with Styles.

There are two ways to use these style sheets:

  • Embed the style sheets within the report and use its styles on controls in that report
  • Save the style sheets externally in *.rdlx-styles format and use it in multiple reports

Why use Styles?

Using styles gives you more control over how you format the report. Let us look at a few scenarios to understand how styles are helpful while designing reports.

Reusing Styles

An organization wants to create an Annual Sales Report that consists of multiple subreports, representing Sales by District and Sales by Product. Since all the subreports are a part of the Annual Sales Report, the formatting needs to be consistent. You normally have to manually set properties for each control on the report to format it and then replicate those same set of properties for the two subreports. This can be time consuming and can lead to inconsistent styling in your reports. Let us see how the ActiveReports Style feature can help you generate consistent styles in all reports similar to the screenshot below.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Report author can create a style sheet for designing the Annual Sales Report (main report), add styles to the style sheet using the Stylesheet Editor dialog. After creating the styles, these styles can be applied to various controls on Annual Sales Report using the GrapeCity.ActiveReports.PageReportModel.Style.StyleName property. For more information, see Working with Styles.

Once the Annual Sales Report has been designed, the GrapeCity.ActiveReports.PageReportModel.Subreport.InheritStyleSheet property can be set to True (by default) for each subreport.

By setting the InheritStyleSheet property to True, the style sheet used for the Annual Sales Report is automatically inherited in the subreports. This makes all the styles in the style sheet available to the two subreports. To apply the styles to the report controls in a subreport, you simply need to select the report control and specify the name of the style you want to use in the StyleName property.

In this example we can see how styles can help save time and maintain consistent formatting by giving you the flexibility to use the same style sheet in multiple subreports.

You can also use the same style sheet in multiple reports by saving the style sheets externally in *.rdlx-styles format. For more information on how to work with external style sheets, see Working with Styles.

Enhancing Report Portability

In ActiveReports, you can embed external style sheets in a report. This is particularly useful when you want to send reports that are styled using multiple style sheets. Let us take an example of a Sales Report to see how embedded style sheets can help improve the report portability.

Scenario

An organization wants to send a Sales report that is styled using 4 different external style sheets. While sending the styled report, 5 files have to be sent together, i.e. one report and 4 external style sheets. The person receiving these files needs to maintain and store 5 different files. Moreover, if the location of a style sheet is changed from the path set in the report, the style sheet will no longer be applied to the report until the path is modified in the report.

By embedding the external style sheets within the Sales report, only 1 file needs to be sent which in turn improves the portability of the report. For more information on how to embed external style sheets, see Embed External style sheet into a report

See Also

Working with Styles

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Working with Styles

Working with Styles
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Styles > Working with Styles

Glossary Item Box

ActiveReports provides you the ability to create styles and store them in a style sheet. You can add these style sheets to your Page or RDL reports and apply the styles to selected controls using the GrapeCity.ActiveReports.PageReportModel.Style.StyleName property. You can also save these style sheets on your system.

The styles feature consists of the following elements.

  • Style Sheet Properties
  • Stylesheet Editor Dialog
  • Add New Style Dialog
  • Embed Stylesheet Dialog
  • Open Embedded Stylesheet Dialog

Here is some guidance on how to work with style sheets

  • Working with Styles within a Style Sheet
  • Working with Embedded Style Sheets
  • Working with External Style Sheets
  • Applying Styles Through Code

Style Sheet Properties

Define the style sheet of a report in the Properties window using the Source property and the Value property. For subreports, use the InheritStyleSheet property.

Property Name Description
Source

The source of a report's style sheet. You can choose from the following options:

External - Choose this option if the style sheet (*.rdlx-styles format) is located as an external source, such as a local file, an http location or a custom resource. To learn how to create external style sheets, see Working with External Style Sheets.

Embedded - Choose this option if style sheet is embedded in the report. The embedded style sheets are displayed under the Embedded StyleSheets node of the Report Explorer.To learn how to create embedded style sheets, see Working with Embedded Style Sheets.
Value

The style sheet to apply to the report. You can choose from the following options:

Expression - Opens the Expression Editor dialog to create a valid expression.

New - Opens the New Stylesheet Editor dialog to create an external or embedded style sheet.

Open file - Opens the Open Stylesheet from file dialog to navigate to a local style sheet file. This option is only available for external style sheets.

For embedded style sheets, a list of available style sheets in the report is provided.
InheritStyleSheet

The style sheet to inherit in a subreport. Setting the InheritStyleSheet property to True (default value) inherits the style sheet of the main report in the subreport.

Note: Field values are not evaluated when used as an expression in Stylesheet Value, StyleName and Styles properties.

Stylesheet Editor Dialog

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

You can open the Stylesheet Editor dialog by selecting the Stylesheet Editor option from the Report menu of the stand-alone designer or Visual Studio .NET designer.

The Stylesheet Editor dialog consists of the following elements.

Elements | Description
Open Stylesheet from File | Opens a style sheet (*.rdlx-styles format) located externally.
Open Embedded Stylesheet | Opens a style sheet embedded in the report.
Save Stylesheet to File | Saves the current style sheet as an external style sheet in *.rdlx-styles format.
Embed Stylesheet | Embeds the current style sheet in the report.
New Style | Creates a new style in the current style sheet.
Remove Style | Removes a style from the current style sheet.
Property window | Modifies the properties of the selected style based on the selected style type. Available style properties change depending on the type of style selected. You set the style type when you create a new style. The style type is selected when a new style is created.
OK | Saves the current style.
Cancel | Closes the dialog without saving the changes.

Note: The values set in the Properties window override the values defined in the report's style sheet. The overridden values are displayed in bold in the Properties window.

Add New Style Dialog

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

You can open the Add New Style dialog by clicking the New Style option in the Stylesheet Editor dialog.

The Add New Style dialog consists of the following elements.

Elements | Description
Name | Contains the name of the new style.
Type

Sets the type of control to which you can apply the style, which determines the options that are available in the Properties window of the Stylesheet Editor dialog.

Common
Apply this style type to the following report controls:
  • CheckBox
  • Image
  • List
  • Tablix
  • Shape
  • Table
  • TableOfContents
  • TextBox
Text
Apply this style type to the TextBox report control. It includes all properties of the Common style type, plus it offers properties specific to the TextBox control.
TOC
Apply this style type to the TableOfContents control.
TOC Level
Apply this style type to the ToC.Level object of the TableOfContents control.
Parent | Represents the parent style of a new style. If the parent style is specified, the property values are taken from the selected parent style values. By default, the parent style is set to None.

Embed Stylesheet Dialog

You can access the Embed Stylesheet dialog by selecting the Save current Stylesheet option and then selecting Embed Stylesheet in the Stylesheet Editor dialog.

The Embed Stylesheet dialog consists of the following elements.

Elements | Description
Drop-down list box for style sheet name | Enter a name for the embedded style sheet, or choose an existing style sheet from the drop-down list box to overwrite.

Open Embedded Stylesheet Dialog

You can access the Open Embedded Stylesheet dialog by selecting the Open stylesheet option and then selecting Open embedded Stylesheet from the Stylesheet Editor dialog.

The Open Embedded Stylesheet dialog consists of the following elements.

Elements | Description
Drop-down list box for opening style sheet | Provides a drop-down list box to choose an existing style sheet to overwrite. You can also enter a new name for the style sheet here.

Here is some guidance on how to work with style sheets

  • Working with Styles within a Style Sheet
  • Working with Embedded Style Sheets
  • Working with External Style Sheets
  • Applying Styles Through Code

Working with Styles within a Style Sheet

For any of these operations, you first need to open the style sheet in the editor.

To open the editor for embedded style sheets

  1. In the Report Explorer, expand the Embedded StyleSheets node and select the existing style sheet you want to edit.
  2. Right-click and select Edit to open it in Stylesheet Editor dialog.

To open the editor for external style sheets

  1. In the stand-alone designer or Visual Studio designer, click the Report menu and select the Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Open Stylesheet from File option.
  3. In the Open dialog, navigate to the *.rdlx-styles file that you want to open.
  4. Click Open to open the external stylesheet in the Stylesheet Editor.

To add a new style to a style sheet

  1. In the Stylesheet Editor dialog, click the New Style button to add a new style.
  2. In the Add New Style dialog, enter the Name of the style, and then select the Type and Parent style.
    Tip: For more information on the style types, see Working with Styles. To create style types for TableOfContents controls and heading levels, see Apply styles to the TableOfContents control and Apply styles to the TableOfContents levels.

To modify a style in a style sheet

  1. In the Stylesheet Editor, select the existing style that you want to modify and use the property fields on the right to make the changes.
  2. Click OK to save the changes.

To remove a style from a style sheet

  1. In the Stylesheet Editor, select the style that you want to remove and click Remove Style.
  2. Click OK to save the changes.

To use a style from a style sheet at design time

  1. Click the gray area around the report to select it, and under the Properties window, click the Property dialog link in the Commands section. See Properties Window for more information on how to access commands.
  2. In the Report dialog, go to the Appearance page.
  3. In the Appearance page, set the Stylesheet Source to Embedded and in the Value field select an existing embedded style sheet. (Or select External and select the <Open File> option and navigate to an *.rdlx-styles external style sheet.)
    Tip: You can also access the Source and Value properties in the Properties window by expanding the Stylesheet node. For more details on the Source and Value properties, see Working with Styles.
  4. Click OK to close the dialog.
  5. On the design surface, select the control you want to apply the style to.
  6. In the Properties Window, from the StyleName property drop-down, select a style to apply to the controls.

Working with Embedded Style Sheets

Create and save a style sheet

  1. In the Report Explorer, right-click the Embedded StyleSheets node, and select the Add Embedded Stylesheet option to access the Stylesheet Editor dialog.

    Tip: You can also access the Stylesheet Editor dialog from the Report Explorer by clicking the Add button and selecting Embedded Stylesheet. In the stand-alone designer or Visual Studio designer, from the Report menu, select Stylesheet Editor.
  2. Click the Save button and select Embed Stylesheet to embed the style sheet into the report.
  3. Enter a name for the style sheet or choose an existing style sheet from the drop-down to overwrite, and then click OK to save the embedded style sheet.

All the saved style sheets embedded in the report appear under the Embedded StyleSheets node in the Report Explorer.

Save embedded style sheet as an external style sheet

  1. In the Report Explorer, expand the Embedded StyleSheets node and select the embedded style sheet.
  2. Right-click and select Edit to open the Stylesheet Editor dialog.
  3. In the Stylesheet Editor dialog, click the Open button and select the Save Stylesheet to file option to save the embedded style sheet externally.

  4. In the Save As dialog, navigate to the location where you want to save the style sheet, provide a name for the style sheet and click the Save button to save it as an external *.rdlx-styles file.

Working with External Style Sheets

Create and save a style sheet

  1. In the stand-alone designer or Visual Studio designer, click the Report menu and select the Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Save Stylesheet to file option.
  3. In the Save As dialog, navigate to the location where you want to save the style sheet, provide a name for the style sheet and click the Save button to save it as an external *.rdlx-styles file.

Embed External style sheet into a report

  1. In the stand-alone designer or Visual Studio .NET designer, click the Report menu and select the Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Open Stylesheet from file option.
  3. In the Open dialog, navigate to the external style sheet (*.rdlx-styles file) that you want to load and click the Open button to load it in the Stylesheet Editor dialog.
  4. In the Stylesheet Editor dialog, click the Save button and then select the Embed Stylesheet option.
  5. In the Embedded Stylesheet dialog, enter a name for the style sheet and then click OK to embed the loaded style sheet into your report.

All the saved style sheets embedded in the report appear under the Embedded StyleSheets node in the Report Explorer.

Applying Styles Through Code

  1. In Visual Studio, create a new Page Report Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.

    Show Visual Basic

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    'Path and Name of the loaded PageReport
Dim filePath As String = "C:\SampleReport.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(filePath))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)

' Set the style sheet source and value using external style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.External
reportDocument.PageReport.Report.StyleSheetValue = "C:\ExternalStyle.rdlx-styles"

' Set the style sheet source and value using embedded style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.Embedded
reportDocument.PageReport.Report.StyleSheetValue = "EmbeddedStylesheet1

' Add a Textbox control and apply style
Dim text As New GrapeCity.ActiveReports.PageReportModel.TextBox()
text.Value = "Sample Text"
text.Style.StyleName = "Style1"
pageReport.Report.Body.ReportItems.Add(text)
viewer1.LoadDocument(reportDocument)

    Show C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    //Path and Name of the loaded PageReport
string filePath = @"C:\SampleReport.rdlx";
GrapeCity.ActiveReports.PageReport pageReport =
new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(filePath));
GrapeCity.ActiveReports.Document.PageDocument reportDocument =
new GrapeCity.ActiveReports.Document.PageDocument(pageReport);

// Set the style sheet source and value using external style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.External;
reportDocument.PageReport.Report.StyleSheetValue = @"C:\ExternalStyle.rdlx-styles";

// Set the style sheet source and value using embedded style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.Embedded;
reportDocument.PageReport.Report.StyleSheetValue = "EmbeddedStylesheet1";

// Add a Textbox control and apply style
GrapeCity.ActiveReports.PageReportModel.TextBox text =
new GrapeCity.ActiveReports.PageReportModel.TextBox();
text.Value = "Sample Text";
text.Style.StyleName = "Style1";
pageReport.Report.Body.ReportItems.Add(text);
viewer1.LoadDocument(reportDocument);

See Also

Styles

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Using Script

Using Script
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Using Script

Glossary Item Box

Show All Show All
Hide All Hide All

In a page report or a RDL report, you can use custom code in your expressions to extend the capabilities of your report. However, for complex functions, or functions you plan to use many times in the report, you also have the facility to embed the code within the report. You can also create and maintain a custom assembly for code that you want to use in multiple reports and refer to its methods in expressions.

Embed Code in the Report

Add a page report/RDL report template to your project and in the ActiveReports Designer that appears, add code like the following in the Script tab.

Show To call a function from the control's property

This is a simple example of a single method code block:
Public Function GetDueDate() as Date
    Return DateTime.Now.AddDays(30)
End Function

This is an expression used to call the method in the code block from the control's property. For example, you can call this function in the Value property of the Textbox control:
=Code.GetDueDate()

Show To use the custom constant and variable from the control's property

This is a simple example of how to define custom constants and variables in your code block:
Public Dim MyVersion As String = "123.456"
Public Dim MyDoubleVersion As Double = 123.456
Public Const MyConst As String = "444"

This is an expression to use the custom constant and variable in the code block from the control's property. For example, you can get the value of a variable or a constant in the Value property of the Textbox control:
=Code.MyVersion
=Code.MyDoubleVersion
=Code.MyConst

Show To call a global collection from the control's property

This is a simple example of a global collection code block where the code block references the report object to access the report parameter value:
Public Function ReturnParam() As String
    Return "param value = " + Report.Parameters!ReportParameter1.value.ToString()
End Function

This is an expression used to call a global collection in the code block from the control's property. For example, you can call the global collection in the Value property of the Textbox control:
=Code.ReturnParam()

Use instance-based Visual Basic .NET code in the form of a code block. You can include multiple methods in your code block, and access those methods from expressions in the control properties.

Note: In a page report or a RDL report, you can use Visual Basic.NET as the script language. However, you can use both Visual Basic.Net and C# in your script for a section report.

Create custom assemblies

You can create custom assemblies in C# or Visual Basic .NET to make code available to multiple reports:

  1. Create or find the assembly you wish to use.
  2. Make the assembly available to the report engine.
    • If you are embedding the designer or viewer controls in your own application, copy the assembly to the same location as your executable.
    • If you are using the included designer or viewer, copy the assembly into the ActiveReports assembly folder located at ...\Common Files\GrapeCity\ActiveReports 13 by default.
      Note: To make the assembly available for use in your own application and for use in designing reports for your application, copy it to both locations listed above. Alternatively, you can place the assembly in the Global Assembly Cache (C:\Windows\assembly).
  3. Add an assembly reference to the report.
    • From the Report Menu, choose Report Properties.
    • In the Report dialog that appears, select the References and click the Open icon above the assembly name list to add your own assembly.
    • Go to the Class list below the assembly names and under Class name, enter the namespace and class name. Similarly, under Instance name, enter the name you want to use in your expressions.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink
  4. Access the assembly through expressions.
    • To access static members (member denoted as public static in C# assemblies, or as Public Shared in Visual Basic assemblies):
      =Namespace.Class.Member
    • To access class instances:
      =Code.InstanceName

See Also

Designer Tabs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Dialog

Report Dialog
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Report Dialog

Glossary Item Box

Show All Show All
Hide All Hide All

In a page report or a RDL report, you can set the basic report properties in the Report dialog. You can access this dialog by doing one of the following:

  • Go to the Visual Studio Report menu and select Report Properties.
  • In the Report Explorer, right-click the Report node and from the context menu that appears, select Report Properties.
  • In the Report Explorer, select the Report node and in the Commands section at the bottom of the Properties Window, click the Property dialog command.
  • Right-click the gray area outside the design surface to select the Report and in the Commands section at the bottom of the Properties Window, click the Property dialog command.

The Report dialog provides the following pages where you can set report properties:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show General

The General page of the Report dialog allows you to control the following items:

  • Author: Enter the name of the report author here.
  • Description: Enter a description of the report here.
  • Draw grid: Clear this check box to remove the grid lines from the report design surface.
  • Snap to grid: Clear this check box to allow free placement of report items on the report design surface instead of the automatic alignment of report items with grid lines.
  • Grid spacing: Enter the spacing between grid lines in inches. The default value is 0.125 inches.
  • Page headers: These options are enabled when you set a Page Header in a Report Definition Language (RDL) report.
    • Print on first page - Select this check box to set the page header on the first page of the report.
    • Print on last page - Select this check box to set the page header on the last page of the report.
  • Page footers: These options are enabled when you set a Page Footer in a RDL report.
    • Print on first page - Select this check box to set the page footer on the first page of the report.
    • Print on last page - Select this check box to set the page footer on the last page of the report.
  • Auto refresh: Select this check box to automatically refresh the pages of the report at regular intervals. When this check box is selected, you can supply the interval in seconds.
  • Ruler Units: Set the ruler units in Inches or Centimeters.
  • Preview Pages: Set the number of pages to display in the Preview tab. Minimum values is 0 and maximum is 10000 pages. If the value is set to 0, the Preview tab displays all the pages. By default, the Preview tab displays all the pages.

Show Appearance

The Appearance page of the Report dialog allows you to control the page layout for your report.

Columns

  • Number of columns: Enter the number of columns you want to use in your report.
  • Spacing: Enter the number of inches of space to use between columns.

Page Layout

  • Paper Size: Select one among the standard paper sizes from the dropdown.
  • Width: Specify the width of the layout.
  • Height: Specify the height of the layout.
  • Left margin: Specify the Left margin for the layout.
  • Right margin: Specify the Right margin for the layout.
  • Top margin: Specify the Top margin for the layout.
  • Bottom margin: Specify the Bottom margin for the layout.
  • Orientation: Select one among Portrait and Landscape as your page orientation.

Design

  • Output background only at design-time: Select the checkbox to display background (for example, background image or background color) in the design tab only.

Stylesheet

  • Source: Select one among Embedded and External as your style sheet source.
  • Value: Select the style sheet to apply to the report. Following options are available:

    Expression - opens the Expression Editor dialog to set an expression.

    New - opens the New Stylesheet Editor dialog for creating an external or embedded style sheet.

    Open file - opens the Open Stylesheet from file dialog for navigating to a local style sheet file. This option is only available for external style sheets.
    In case of embedded style sheets, a list of available style sheets in the report is provided.

Show Parameters

The Parameters page of the Report dialog allows you to control how a user interface is presented to your users for each parameter. See Parameters for further information.

Show Images

The Images page of the Report dialog allows you to add and modify images for your report. Click the Open button located at the top left of the page to display the Open file dialog, where you can navigate to an image. Once you select an image file and click the Open button, a thumbnail of the image is displayed in the Image column, and the Name and MIME Type values are automatically populated in their respective columns.

You can use the images you add here in the Image control. The MIME Type column provides a combo-box with a list of image file extensions, where you can change default file filter of the added image.

You can also use the Remove button located at the top right of the page to remove any added image.

Show References

The References page of the Report dialog allows you to add references to assemblies and classes so that you can call methods from them in expressions throughout your report. You can also access the References dialog from the Properties Window by selecting the Classes (Collection) or References (Collection) property of a report and clicking the ellipsis button that appears.

Caution: If you are using the ActiveReports stand-alone report designer application, make sure the assembly you load is created using .NET 3.5 framework or below as the stand-alone report designer is a .NET 3.5 application.

Assembly Name

This is a list of the assemblies available for use in your report. You can delete assemblies using the Remove button, or add them using the Open button which presents the Open file dialog.

Note: Any assemblies you reference must be copied to the ActiveReports 13 folder (...Common Files\GrapeCity\ActiveReports 13) on your development machine.

Classes

This is a list of instance-based classes you can create for use in your report.

  • Class name: Enter the namespace and name of the class here. (i.e. Invoicing.GetDueDate)
  • Instance name: Enter a name for the instance of the class here. (i.e. m_myGetDueDate)

Show Data Output

The Data Output page of the Report dialog allows you to control how the report's data is rendered in XML exports.

  • Element name: Enter the name you want to appear as the top level data element in your exported XML file.
  • Data transform (.xsl file): Enter the name of the XSL file you want to use as a style sheet for the exported XML file.
  • Data schema: Enter the schema or namespace to use for validating data types in the exported XML file.
  • Render textboxes as: Choose whether to render textboxes as Attributes or Elements in the exported XML file.
    • Attributes example: <table1 textbox3="Report created on: 7/26/2005 1:13:00 PM">
    • Elements example: <table1> <textbox3>Report created on: 7/26/2005 1:13:28 PM</textbox3>

Show Themes

The Themes page of the Report dialog displays the report's themes. This dialog allows you to create a new theme, add, modify or remove an existing one, as well as rearrange the order of themes if a report has many themes. When you select to create or modify a theme, the Theme Editor is opened. See Themes for further information.

See Also

Page Report/RDL Report Concepts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Fixed Page Dialog

Fixed Page Dialog
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Fixed Page Dialog

Glossary Item Box

Show All Show All
Hide All Hide All

In a Page Report, you can set the basic properties for your page from the FixedPage dialog. You can access the FixedPage dialog by doing one of the following:

  • Right-click the gray area outside the design surface and from the context menu that appears, select Fixed Layout Settings.
  • Click the gray area outside the design surface to select the Report and in the commands section at the bottom of the Properties Window, click the Fixed Layout Settings command.
  • Click the design surface to select the Page and in the Commands section at the bottom of the Properties Window, click the Property dialog command.
  • In the Report Explorer, select the Report node or the page node and in the commands section at the bottom of the Properties Window, click the Fixed Layout Settings or Property dialog command respectively.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

The FixedPage dialog provides the following pages where you can set the page properties:

Show General

The General page of the FixedPage dialog allows you to control the following properties:

  • Name: Enter a name for the Page report. This name is used to call the page in code so it should be unique within the report.
  • Dataset name: Select a dataset to associate with the page report. The dropdown list is automatically populated with all the datasets in the report's dataset collection.

Show Grouping

The Grouping page is useful when you want to show data grouped on a field or an expression on report's pages. See Group in a FixedPage for more information.

The Grouping page contains following tabs which provide access to various grouping properties:

Show General

  • Name: Enter a name for the Fixed Layout group that is unique within the report. This property cannot be set until after a Group on expression is supplied. A name is created automatically if you do not enter one.
  • Group On: Enter an expression to use for grouping the data.
  • Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Show Filters

The Filters tab allows you to add and control the Filter collection for the Fixed Layout Group. Use the + button to add a filter and the X button to delete a filter. You need to provide three values to add a new filter to the collection:

  • Expression: Enter the expression to use for evaluating whether data should be included in the group.
  • Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:
    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right. Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.
  • Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

  • Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Data Output

The Data Output tab allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for this group.
  • Collection: Enter a name to be used in the XML output for the collection of all instances of this group.
  • Output: Choose Yes or No to decide whether to include this group in the XML output.

Show Layout

  • Has own page numbering: Check this box to enable section page numbering like Page N of M (Section). See Add Page Numbering for further information on setting page numbering in Page Report.

Show Sorting

The Sorting page of the FixedPage dialog allows you to enter sort expressions for sorting data alphabetically or numerically.

Expression: Enter an expression by which to sort the data.

Direction: Select whether you want to sort the data in an Ascending or Descending order.

Show Filters

The Filters page of the FixedPage dialog allows you to control the Filter collection for the Fixed Layout. Use the + button to add filters and X buttons to delete them. You need to provide three values to add a new filter to the collection:

  • Expression: Enter the expression to use for evaluating whether data should be included in the Fixed Layout.
  • Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:
    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right. Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

  • Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

  • Values: When you choose the In operator, you can enter as many values as you need in this list.

Show Data Output

The Data Output page of the FixedPage dialog allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for the Page report.
  • Output: Choose Auto, Yes, or No to decide whether to include the fixed page layout in the XML output. Choosing Auto exports the contents of the fixed layout.

See Also

Sorting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Grouping Data (Page Layout)

Grouping Data (Page Layout)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Grouping Data (Page Layout)

Glossary Item Box

In a page report and RDL report, you can set grouping to organize data in your reports. The most common grouping scenario is to create groups by fields or expressions in a data region.
Depending on the data region you select, you can group data in one of the following ways:

  • In a Table or Banded List, you can add group header and footer rows. You can also set detail grouping in the Table data region.
  • In a List, you can set detail grouping.
  • In a Tablix, you can add columns and rows either dynamically or manually to group data.
  • In a Classic Chart , you can group data by categories or series.

See Group in a Data Region for further information.

Note: In this topic, the data displayed in the screenshots is from the Movie table available in the Reels database. By default, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

In a Page Report, you can also group data on a report page. See Group in a FixedPage for further information.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Detail Grouping

Detail grouping is available in the List and Table data regions. It is useful when you do not want to repeat values within the details. When you set detail grouping, the value repeats for each distinct result of the grouping expression instead of each row of data.

For example, if you use the Movie table of the Reels database to display movie titles by year without setting detail grouping, you see each year as many times as there are movies from that year.

If you set detail grouping to =Fields!YearReleased.Value, each year appears only once.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: If the detail grouping expression you use results in a value that is distinct for every row of data, MovieID for example, you will see no difference in the results.

Recursive Hierarchies

If you want to display parent-child relationships in your data, you can create a recursive hierarchy. To do this, you need a unique ID field for the child group and an ID field for the parent group.

For example, if you have pulled data from the Reels database using the following SQL query:

SQL Query Copy Code
SELECT EmployeePosition.*, Employee.*, Employee_1.PositionID AS ManagerPosition FROM Employee AS Employee_1 RIGHT JOIN (EmployeePosition INNER JOIN Employee ON EmployeePosition.PositionID = Employee.PositionID) ON Employee_1.EmployeeID = Employee.ManagementID;

You can set Detail Grouping in a Table data region using the =Fields.Item("EmployeePosition.PositionID").Value field, and the =Fields!ManagerPosition.Value field as the parent group to display parent-child relationships in your data.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: You can use only one group expression when you set a parent group.

Level Function

To better visualize data in a recursive hierarchy, you can use the Level function. This function indents text and further clarifies the relationships between parent and child data. To do this, you set an expression in the Padding - Left property of the text box you want to indent.

For example, in a Table data region, for the recursive hierarchy example above, you can set the following expression in the Padding - Left property of the text box that contains the Title to indent values according to levels:

=Convert.ToString(2 + (Level()*10)) & "pt"

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Group in a Data Region

How To
Group in a FixedPage

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Page Numbering

Add Page Numbering
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Add Page Numbering

Glossary Item Box

Show All Show All
Hide All Hide All

You can choose the page numbering format for your Page reports/RDL reports by selecting from a list of pre-defined formats or by creating a custom page numbering expression.

Adding page numbers to a report

There are two ways to add page numbering to a report.

  • From the Report Explorer, under the Common Values node, drag a pre-defined page numbering format and drop it directly onto the report design surface.
  • Or add a TextBox control to the report design surface and in the Value property of the control, use the Expression Editor Dialog to select a page numbering expression from the Common Values node.

Usually a page number is added to a report header or footer, but you can add it anywhere on the layout page.

Pre-defined page numbering formats

You can find the pre-defined page numbering formats listed in the Report Explorer under the Common Values node, and in the Expression Editor under the Common Values field.

Show Predefined Format Descriptions

Numbering Format | Description
Page N of M | This format displays the current page out of the total number of pages in the report. Here N signifies the current page of a report and M the total number of report pages. Use the following expression to set this page numbering format: ="Page " & Globals!PageNumber & " of " & Globals!TotalPages
Page N of M (Section) | This format displays the current page out of the total number of pages of a grouped report section. Here N signifies the current page of a grouped report section and M signifies the total number of pages in a grouped report section. Use the following expression to set this page numbering format: ="Page " & Globals!PageNumberInSection & " of " & Globals!TotalPagesInSection
Page N of M (Cumulative) | This format displays the current page out of the total number of cumulative pages in a report. Here N signifies the current page of the report and M signifies the total number of cumulative pages in a report. Use the following expression to set this page numbering format: ="Page " & Globals!CumulativePageNumber & " of " & Globals!CumulativeTotalPages
Page Number | This format displays only the current page number of a report. Use the following expression to set this page numbering format: =Globals!PageNumber
Page Number (Section) | This format displays only the current page number of a specific grouped report section. Use the following expression to set this page numbering format: =Globals!PageNumberInSection
Total Pages | This format displays only the total number of pages in the report. Use the following expression to set this page numbering format: =Globals!TotalPages
Total Pages (Section) | This format displays only the total number of pages in specific grouped report section. Use the following expression to set this page numbering format: =Globals!TotalPagesInSection
Cumulative Page Number | This format displays only the current cumulative page number of the report. Use the following expression to set this page numbering format: =Globals!CumulativePageNumber
Cumulative Total Pages | This format displays only the total number of cumulative pages in a report. Use the following expression to set this page numbering format: =Globals!CumulativeTotalPages
Tip: In addition to modifying the page numbering expression in the Expression Editor, you can also modify the pre-defined formats directly in the control on the design surface.

Custom page numbering formats

Use the following steps to create your own page numbering format.

Show To create a custom page numbering format

  1. From the toolbox, drag and drop a Textbox control onto the report design surface.
  2. With the Textbox selected on the report, under the Properties window, click the Property dialog link. This is a command to open the TextBox dialog. See Properties Window for more on how to access commands.
  3. In the TextBox - General dialog that appears, in the Value field, enter a page numbering expression like the following: =Globals!PageNumber & "/" & Globals!TotalPages
  4. Click OK to close the dialog.
  5. Select the Preview tab. Page numbers appear in the expression format you set in the Value field above, in this case, for a one-page report, "1/1."

See Also

Expressions

Concepts
Common Values

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Themes

Themes
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Themes

Glossary Item Box

Show All Show All
Hide All Hide All

A theme is a collection of properties that defines the appearance of a report. A theme includes colors, fonts, images, and constant expressions that you can apply to report elements once you add a theme to a report.

You can add one or many themes to a report. If a report has multiple themes, you can use the report's GrapeCity.ActiveReports.PageReportModel.CollateBy enumeration to control the page order in a report. See Set Up Collation for more information.

The Theme Editor and the Report - Themes dialog allow you to manage themes in a report.

In the Theme Editor, you can create a new theme by setting colors, fonts, images, and Use Constant Expressions in a Theme and then saving a new theme as an .rdlx-theme file on your local machine. Then you can add this theme to your report in the Report – Themes dialog. Also, in the File menu, select Open to open and modify an existing theme and select Save or Save As to save the changes on your local machine.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To access the Theme Editor

From the Start menu, go to All Programs > GrapeCity > ActiveReports and select ActiveReports Theme Editor.

The Report – Themes dialog displays the report's themes. This dialog allows you to create a new theme, add, modify or remove an existing one, as well as rearrange the order of themes if a report has many themes. When you select to create or modify a theme, the Theme Editor is opened.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To access the Theme - Report dialog

  1. In the Designer, click the gray area around the report page to select a report.
  2. Do one of the following:
    • In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
    • With the report selected, in the Properties window under properties where the commands are displayed, click the Property dialog link. In the Report dialog that appears, go to Themes. See Properties Window for further information on commands.
    • On the Report menu, select Report Properties and go to Themes in the Report dialog that appears.

See Also

Customize and Apply a Theme
Use Constant Expressions in a Theme
Set Up Collation

How To
Create and Add Themes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Master Reports (RDL)

Master Reports (RDL)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Master Reports (RDL)

Glossary Item Box

Show All Show All
Hide All Hide All

Master Reports are like dynamic templates you can design for use with content reports. This assists users in creating reports that share common elements such as a logo in the page header or a web site link in the page footer. You design the master report with controls, code, data sources, and layout properties that cannot be modified from content reports.

Master Reports differ from templates in that they are loaded each time the report is executed. Therefore, you can modify a master report and the changes to the master report automatically appear in any reports that reference it.

Advantages of a Master Report

  • Implement common report functionality such as adding consistent page headers and footers within master reports.
  • Apply company-wide changes in information such as address changes to a single master instead of modifying each report individually.
  • Apply widespread data-related changes (such as data source location) to a single master report instead of modifying each report.
  • Create code, data sources, themes and page layouts that are shared across the application or enterprise.
  • Hide report complexity from end users who can use the stand-alone designer application to create content reports.

Advantages of a Shared Master Report

Shared master reports offer the advantages of a local master report, plus:

  • They make your reports portable
  • They allow multiple authors to use them

Designing Master Reports

When designing a master report, you use controls, code, data sources, and layout properties in the same way that you do in a normal report. A master report is valid on its own, and can be run without a content report. To prevent end users from modifying a master report, you can set permissions on the file to Read Only for that user or group.

In an RDL report, you can create a master report by saving it as an RDLX-master file. You can then apply it like a template to content reports.

A ContentPlaceHolder control appears in the toolbox when you convert an RDL report to a Master Report. This control defines regions where users can add content after applying a master report template.

Note: In a section report (code-based report), there is a concept similar to Master Reports. However, here you create a base report class in a standard report that other reports inherit. See Inherit a Report Template for further information.

Creating Content Reports

The reports to which you apply the master report are content reports. A content report is not valid on its own, and cannot be run without its specified master report.

When the user creates a new report and sets a master report on it, the design view is effectively the opposite of the design view of the master report. Any report controls overlaid by ContentPlaceHolder controls are not visible in the content report at design time, but are visible at run time. These are the only areas where users can add report controls.

Show While designing the content report the user can

  • Add elements that do not exist in the master report.
  • Add new data sources that do not exist in the master report.
  • Add new datasets from a data source in the master report.
  • Add images to the EmbeddedImages collection.
  • Add parameters to the ReportParameter collection.
  • Add any number of report controls into placeholder rectangles designated by the master report.
  • Modify the report name and description.
  • Add new custom code that does not exist in the master report.

Show While designing the content report the user cannot

  • Modify or remove elements that exist in the master report (disabled grey area).
  • Remove a master report data source.
  • Remove a master report dataset or modify its query.
  • Modify the sort or filter on a master report dataset.
  • Remove images from the EmbeddedImages collection.
  • Remove parameters from the ReportParameter collection.
  • Modify the margins or page settings of the master report.
    Note: Code in the master report is hidden in the content report, so in order to allow content report users to access code, the master report developer must provide information.

Run-Time Sequence of Events

This is what happens behind the scenes when you run a content report.

  1. ActiveReports loads the content report.
  2. The loader parses the master report tag on the content report and requests the master report from the resource resolver.
  3. The master report is loaded into the definition.
  4. As each ContentPlaceHolder in the content report is parsed, it finds the corresponding placeholder in the master report and loads the content from the content report into it.
  5. Data sources, datasets, and fields are merged. The master report has higher priority if there is a conflict.
  6. Themes are merged. The master report has higher priority if there is a conflict.
  7. Report properties from the content report are added to those of the master report. For the following properties, the content report has a higher priority in case of conflict:
    • Report Description
    • Report Author
    • Report AutoRefresh
    • Report Custom
    • Report Language
    • Report DataTransform
    • Report DataSchema
    • Report ElementName
    • Report DataElementStyle
    • Dataset filters
    • Report Theme
    • Report Code
    • All content inside the ContentPlaceHolder controls

Modifying an Aggregated Report Definition

When you run a content report, the content report and its master combine to form an aggregated report definition. Using the ReportDefinition API, you can save this aggregate at run time as a third report definition which has no master or content report. Once this aggregate is saved as a normal report definition (*.rdlx file) you can edit it like any other report definition.

See Also

Inherit a Report Template

How To
Create and Use a Master Report (RDL Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Data Visualizers

Data Visualizers
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers

Glossary Item Box

There are several report controls that support a type of expression called Data Visualizers that allow you to create small graphs to make your data easy to understand. For example, you can red flag an overdue account using the Flags Icon Set as a background image in TextBox control.
There are several types of Data Visualizers available through a dialog linked to properties on the report controls.

Image Data Visualizers

These Data Visualizers are supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property. See the topics below to learn more.

Caution: In the following topics, the terms "argument" and "parameter" may seem interchangeable, but within an expression, an argument refers to the returned value of a parameter, while a parameter may be a variable.
Icon Set
Learn about the included image strips from which you can select using arguments. These include traffic lights, arrows, flags, ratings, symbols, and more, plus you can create your own custom image strips.
Range Bar
Learn how you can provide minimum, maximum, and length arguments to render a 96 by 96 dpi bar image in line with your text to show a quick visual representation of your data values.
Range Bar Progress
Learn how you can use a second bar to show progress along with the data range.
Data Bar
Learn about data bars, which are similar to range bars with a few different arguments.
Gradient
Learn how to apply gradient style to the background of a control.
Hatch
Learn how to apply hatch style to the background of a control.

Background Color Data Visualizer

These Data Visualizers are available in the TextBox and CheckBox report controls' BackgroundColor property. See the topics below to learn more.

Color Scale 2
Learn about displaying TextBoxes with a range of background colors that are keyed to the value of the data.
Color Scale 3
Learn about color scales with an additional middle color value.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Icon Set

Icon Set
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Icon Set

Glossary Item Box

Show All Show All
Hide All Hide All

The Icon Set data visualization allows you to use arguments to select an image from an image strip and display it either as a BackgroundImage, or as a Value. You can use the standard image strips included with ActiveReports, or create custom image strips.

The Icon Set Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

Show Standard Image Strips

Name | Image
Checkbox |
3TrafficLights |
Arrows |
Blank |
Flags |
GrayArrows |
Quarters |
Ratings |
RedToBlack |
Signs |
Symbols1 |
Symbols2 |
TrafficLights |

Note: When using icon sets, you must set the Source property to Database.

Parameters

  • Icon Set. This designates the name of the icon set to use.
  • Icon 1 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 2 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 3 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 4 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 5 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.

You can use static values or any expression that evaluates to a Boolean value. For icon sets with fewer than five icons, set the unused values to False.

Syntax

=IconSet("Flags", False, True, False, False, False)

Usage

Following the Icon Set argument, there are five Boolean arguments. The first argument to evaluate to True displays the corresponding image. Use data expressions that evaluate to a Boolean value to replace the literal values in the code above.

Show Example

This expression displays the first symbol (the green flag) on each row in which the Difference exceeds 10, displays the second symbol (the yellow flag) on each row in which the quantity is greater than 0, and displays the third symbol (the red flag) on each row in which the quantity is equal to or below 0. Notice that we provide literal False values in the fourth and fifth arguments, which have no images in this strip.

Paste in the BackgroundImage Value property of a Textbox Copy Code
=IconSet("Flags",Fields!Difference.Value > 10,Fields!Difference.Value > 0,Fields!Difference.Value <= 0,False,False)

In several of the included image strips, the last spots are empty. When using the Checkbox, 3TrafficLights, Flags, RedToBlack, Signs, Symbols1, Symbols2, or TrafficLights image strip, it generally makes sense to set the Boolean values for all of the unused icon spaces to False.

Custom Image Strips

The Blank image strip is included so that you can customize it. Drop down the section below for details.

Show Custom image strips

Custom image strips must conform to the following rules.

  1. The format must be of a type that is handled by the .NET framework.
  2. The size of the strip must be 120 x 24 pixels.
  3. Each image must be 24 x 24 pixels in size.
  4. There must be no more than five images in the strip.
  5. If there are fewer than five images in the strip, there must be blank spaces in the image to fill in.

Types of Custom Images

Here is the syntax for various types of custom images, followed by examples of each.

External image syntax

=IconSet(location of image strip, condition#1, condition#2, condition#3, condition#4, condition#5)
External image path example Copy Code
=IconSet("C:\Images\customstrip.bmp", 4 > 9, 5 > 9, 10 > 9, False, False)
External image URL example Copy Code
=IconSet("http://mysite.com/images/customstrip.gif", 4 > 9, 5 > 9, 10 > 9, False, False)

Image from an assembly resource syntax

=IconSet("res:[Assembly Name]/Resource name", condition#1, condition#2, condition#3, condition#4, condition#5)
Assembly resource image example Copy Code
=IconSet("res:ReportAssembly, Version=1.1.1.1./ReportAssembly.Resources.Images.CustomImage.png",
4 > 9, 5 > 9, 10 > 9, False, False)

Embedded image syntax

=IconSet("embeddedImage:ImageName", condition#1, condition#2, condition#3, condition#4, condition#5)
Embedded image example Copy Code
=IconSet("embeddedImage:Grades", Fields!Score.Value >=90, Fields!Score.Value >=80, Fields!Score.Value >=70, Fields!Score.Value >=60, True)

Theme image syntax

=IconSet("theme:ThemeImageName", condition#1, condition#2, condition#3, condition#4, condition#5)
Theme image example Copy Code
=IconSet("theme:Grades", Fields!Score.Value >=90, Fields!Score.Value >=80, Fields!Score.Value >=70,
Fields!Score.Value >=60, True)

Show Data Visualizers Dialog

To open the dialog, drop down the BackgroundImage property of TextBox, CheckBox, Shape, and Container report controls, or the Value property of Image report control, and select <Data Visualizer...>. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Icon Set Data Visualizer dialog

See Also

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Range Bar

Range Bar
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Range Bar

Glossary Item Box

Show All Show All
Hide All Hide All

The Range Bar data visualization displays a 96 by 96 dpi bar image. The colored bar renders as half the height of the image, centered vertically. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Length argument. If the Length argument is zero, a diamond renders.

The Minimum and Maximum arguments determine the range of data. The area between the Length argument and the Maximum argument is transparent (or between the Length and the Minimum in the case of a negative value).

The Range Bar Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

Parameters

  • Minimum. The lowest value in the range of data. This value corresponds to the leftmost edge of the image. If this argument is greater than the Start argument, Start becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data. This value corresponds to the rightmost edge of the image. If this argument is less than the Start argument, Start becomes equal to Maximum. The data type is Single.
  • Color. The HTML color string to use in rendering the Length in the bar image.
  • Start. The point from which the Range Bar begins to be rendered. The data type is Single.
  • Length. The width of the bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.

You can use static values or aggregate functions (e.g. Min or Max) to set the parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=RangeBar(Minimum, Maximum, Color, Start, Length)

Usage

Use this data visualizer to render a bar in the color specified, the length of which changes depending on the number returned by the Length parameter, in the case of the simple example, GrossProfit. If your data contains only positive values, Start corresponds with Minimum at the left edge of the DataBar. The area between the Length and the Maximum is transparent.

Show Simple Example

Set the Length parameter to the value of a field in your dataset to display the field values visually.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBar(0,15000,"BlueViolet",0,Fields!GrossProfit.Value)

Show Example Using Negative Values

When your data contains negative as well as positive values, you can use an Immediate If expression for the Color parameter. In this example, if the Projected Stock value is negative, it renders in Crimson, while positive values render in BlueViolet. You can also see that negative values render to the left of Zero and positive values render to the right. A Length value of exactly zero renders as a diamond.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBar(-5,20,IIf((Fields!InStock.Value - 5) < 0, "Crimson", "BlueViolet"),0,Fields!InStock.Value-5)

Show Default Behavior

The function returns null (i.e. no image is rendered) in the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

The Start value changes in the following cases:

  1. If the Start value is less than the Minimum value, Start is the same as Minimum.
  2. If the Start value is greater than the Maximum value, Start is the same as Maximum.

The Length value changes in the following cases:

  1. If the Start value plus the Length value is less than the Minimum value, Length becomes Minimum minus Start.
  2. If the Start value plus the Length value is greater than the Maximum value, Length becomes Maximum minus Start.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Minimum | 0
Maximum | 0
Color | Green
Start | 0
Length | 0

Show Dialog

When you select a TextBox, CheckBox, Shape, or a Container control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundImage Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Range Bar Data Visualizer dialog

See Also

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Range Bar Progress

Range Bar Progress
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Range Bar Progress

Glossary Item Box

Show All Show All
Hide All Hide All

The Range Bar Progress data visualization displays a 96 by 96 dpi double bar image. The first colored bar renders as half the height of the image, centered vertically. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Length argument. If the Length argument is zero, a diamond renders.

The second colored bar renders using the ProgressColor as one fourth of the height of the image, centered vertically over the Length bar. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Progress argument. If the Progress argument is zero, a smaller diamond renders.

The Minimum and Maximum arguments determine the range of data. The area between the Length and Progress arguments and the Maximum argument is transparent (or between the Length and Progress and the Minimum in the case of a negative value).

The Range Bar Progress Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

Parameters

  • Minimum. The lowest value in the range of data. This value corresponds to the leftmost edge of the image. If this argument is greater than the Start argument, Start becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data. This value corresponds to the rightmost edge of the image. If this argument is less than the Start argument, Start becomes equal to Maximum. The data type is Single.
  • Color. The HTML color string to use in rendering the Length, the thicker bar in the bar image.
  • Start. The point from which the Range Bar Progress begins to be rendered. The data type is Single.
  • Length. The length of the thicker bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.
  • ProgressColor. The HTML color string to use in rendering the Progress, the thinner bar in the bar image.
  • Progress. The length of the thinner bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.

You can use static values or aggregate functions (e.g. Min or Max) to set the parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=RangeBarProgress(Minimum, Maximum, Color, Start, Length, ProgressColor, Progress)

Usage

Use this data visualizer to render a double bar in the colors specified, the length of which changes depending on the number returned by the Length parameter for the thick bar, in the case of the simple example, GrossSales. The thin bar length is based on the value returned by the Progress parameter, in this case, GrossProfit. If your data contains only positive values, Start corresponds with Minimum at the left edge of the Range Bar. The area between the Length or Progress and the Maximum is transparent.

Show Simple Example

Set the Length and Progress parameters to the values of fields in your dataset to display the field values visually.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBarProgress(0,30000,"BlueViolet",0,Fields!GrossSales.Value,"Gold",Fields!GrossProfit.Value)

Show Example Using Negative Values

When your data contains negative as well as positive values, you can use an Immediate If expression for the Color parameter. In the example below, if the Difference value is negative, it is rendered in red, while positive values are rendered in gold. You can also see that negative values are rendered to the left of Zero and positive values are rendered to the right. A Length value of exactly zero is rendered as a diamond. The thicker blue violet bar represents the InStock value.

Paste into a TextBox BackgroundImage property Copy Code
=RangeBarProgress(-10,20,"BlueViolet",0,Fields!InStock.Value,IIf(Fields!Difference.Value < 0, "Red", "Gold"),Fields!Difference.Value)

Show Default Behavior

The function returns null (i.e. no image is rendered) in any of the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

The Start value changes in the following cases:

  1. If the Start value is less than the Minimum value, Start is the same as Minimum.
  2. If the Start value is greater than the Maximum value, Start is the same as Maximum.

The Length value changes in the following cases:

  1. If the Start value plus the Length value is less than the Minimum value, Length becomes Minimum minus Start.
  2. If the Start value plus the Length value is greater than the Maximum value, Length becomes Maximum minus Start.

The Progress value changes in the following cases:

  1. If the Start value plus the Progress value is less than the Minimum value, Progress becomes Minimum minus Start.
  2. If the Start value plus the Progress value is greater than the Maximum value, Progress becomes Maximum minus Start.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Minimum | 0
Maximum | 0
Color | Green
Start | 0
Length | 0
ProgressColor | Red
Progress | 0

Show Dialog

When you select a TextBox, CheckBox, Shape, or a Container control on your report, in the Properties window or Properties dialog, you can drop down the BackgroundImage Value property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options on the dialog.

For a Range Bar Progress expression, be sure to select the Display a progress indicator check box. This enables the progress options.

Range Bar Data Visualizer dialog

See Also

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Data Bar

Data Bar
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Data Bar

Glossary Item Box

Show All Show All
Hide All Hide All

The Data Bar data visualization displays a 96 by 96 dpi bar image. The colored bar fills the Image top to bottom, while the Value argument determines the amount of colored bar to render to the right of the Zero argument (or to the left in the case of a negative value).

The Minimum and Maximum arguments determine the range of data. The area between the Value argument and the Maximum argument is transparent (or between the Value and the Minimum in the case of a negative value).

The Data Bar Data Visualizer is supported in the Image report control Value property, and also in the TextBox, CheckBox, Shape, and Container report controls' BackgroundImage - Value property.

Parameters

  • Value. This is the field value in the report to be evaluated. The data type is Single.
  • Minimum. The lowest value in the range of data against which the Value argument is compared. This value corresponds to the leftmost edge of the image. If this argument is greater than the Zero argument, Zero becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data against which the Value argument is compared. This value corresponds to the rightmost edge of the image. If this argument is less than the Zero argument, Zero becomes equal to Maximum. The data type is Single.
  • Zero. This value determines the zero point to the left of which negative data is rendered, and to the right of which positive data is rendered. The data type is Single.
  • Color. The HTML color string to use in rendering the Value in the bar image.
  • Alternate Color. The HTML color string to use when the Value is less than the Zero value (optional).

Select the Use Alternate Color when Value is less than Zero Value check box to enable the Alternate Color parameter. You can use static values or aggregate functions (e.g. Min or Max) to set parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=DataBar(Value, Minimum, Maximum, Zero, Color)
=DataBar(Value, Minimum, Maximum, Zero, Color, Alternate Color)

Usage

Use this data visualizer to render a bar in the color specified, the length of which changes depending on the number returned by the Value parameter, in the case of the simple example, InStock. If your data contains only positive values, Zero corresponds with Minimum at the left edge of the Data Bar. The area between the Value and the Maximum is transparent.

Show Simple Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundImage Value property of a TextBox Copy Code
=DataBar(Fields!InStock.Value,0,20,0,"BlueViolet")

Show Example Using Negative Values

When your data contains negative as well as positive values, you can select the Use Alternate Color when Value is less than Zero Value check box, and then select an Alternate Color. In this example, if the Difference value is negative, it is rendered in Crimson, while positive values are rendered in BlueViolet. You can also see that negative values are rendered to the left of Zero and positive values are rendered to the right.

Paste in the BackgroundImage Value property of a TextBox Copy Code
=DataBar(Fields!Difference.Value,-10,20,0,"BlueViolet","Crimson")

Show Default Behavior

The function returns null (i.e. no image is rendered) in any of the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Maximum | 0
Zero | 0
Color | Green
Alternate Color | null

Show Dialog

When you select a TextBox, CheckBox, Shape, or a Container control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundImage Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Data Bar Data Visualizer dialog

See Also

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Gradient

Gradient
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Gradient

Glossary Item Box

The Gradient data visualization displays a gradient of color that transitions from one color to another.

Parameters

  • Gradient type. The available gradient types are Horizontal, Vertical, DiagonalUp, DiagonalDown, FromCenter, and FromCorner.
  • Color1. The start (primary) color of the gradient.
  • Color2. The end (secondary) color of the gradient.

Syntax

=Gradient(Gradient type, Color1, Color2)

Usage

Using Data Visualizers, the gradient can be applied in TextBox, Shape, CheckBox, and Container controls from BackgroundImage - Value property and in Image control from Value property. The following example shows how Gradient background style can be simply applied to a control.

Show Example

Set the following expression in the BackgroundImage.Value property of the Shape control.

Paste into the BackgroundImage Value property of a Shape Copy Code
=Gradient("Vertical","LightCyan","BlueVoilet")

Show Dialog

When you select a Shape control on your report, in the Properties window, drop down the BackGroundImage - Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: The Gradient style set using Data Visualizers is not displayed at design time.

See Also

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Hatch

Hatch
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Hatch

Glossary Item Box

The Hatch data visualization displays the geometric hatch pattern.

Parameters

  • Hatch style. The available hatch styles are Horizontal, Vertical, ForwardDiagonal, BackwardDiagonal, LargeGrid, and many more.
  • Color1. The color of pattern or foreground color.
  • Color2. The background color.

Syntax

=Hatch(Hatch style,Color1,Color2)

Usage

Using Data Visualizers, the hatch can be applied in TextBox, Shape, CheckBox, and Container controls from BackgroundImage - Value property and in Image control from Value property. The following example shows how Hatch background style can be simply applied to a control.

Show Example

Set the following expression in the Shape control's BackgroundImage - Value property.

Paste into BackgroundImage property Copy Code
=Hatch("BackwardDiagonal","LightCyan","BlueVoilet")

Show Dialog

When you select a Shape control on your report, in the Properties window, drop down the BackGroundImage - Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: The Hatch style set using Data Visualizers is not displayed at design time.

See Also

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Color Scale 2

Color Scale 2
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Color Scale 2

Glossary Item Box

Show All Show All
Hide All Hide All

The ColorScale2 data visualization displays a background color in a range of colors to indicate minimum and maximum values, and all shades in between. The Color Scale Data Visualizer is available for TextBox and CheckBox controls.

Parameters

  • Value. This is the field value in the report to evaluate. The data type is Single.
  • Minimum. If the Value evaluates to this number, the StartColor renders.
  • Maximum. If the Value evaluates to this number, the EndColor renders.
  • StartColor. The HTML color string to use if the Value evaluates to the Minimum value.
  • EndColor. The HTML color string to use if the Value evaluates to the Maximum value.

You can use static values or aggregate functions (e.g. Min or Max) to set the Minimum and Maximum parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=ColorScale2(Value, Minimum, Maximum, StartColor, EndColor)

Usage

Use an expression with this syntax in the BackgroundColor property of a Textbox or a CheckBox control. This causes the background color to change depending on the value of the field you specified in the Value parameter, in the case of the example, InStock. Any values falling between the Minimum value and the Maximum render with a color between the StartColor and EndColor.

Show Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundColor property of a TextBox Copy Code
=ColorScale2(Fields!InStock.Value,0,20,"Crimson","MidnightBlue")

Show Default Behavior

The function returns Transparent in any of the following cases:

  1. The Value is out of range (i.e. does not fall between the Minimum and Maximum values).
  2. The Maximum is less than the Minimum.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Maximum | 0
StartColor | Silver
EndColor | WhiteSmoke

Show Dialog

When you select a TextBox or a CheckBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundColor property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: If you select the Use a middle color check box, the expression used in the BackgroundColor property changes to ColorScale3. For more information, see ColorScale3.

Color Scale Data Visualizer dialog

See Also

Color Scale 3

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Color Scale 3

Color Scale 3
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Color Scale 3

Glossary Item Box

Show All Show All
Hide All Hide All

The ColorScale3 data visualization displays a background color in a range of colors to indicate minimum, middle, and maximum values, and all shades in between. The Color Scale Data Visualizer is available for TextBox and CheckBox controls.

Parameters

  • Value. This is the field value in the report to be evaluated. The data type is Single.
  • Minimum. If the Value evaluates to this number, the StartColor is rendered.
  • Middle. If the Value evaluates to this number, the MiddleColor is rendered.
  • Maximum. If the Value evaluates to this number, the EndColor is rendered.
  • StartColor. The HTML color string to use if the Value evaluates to the Minimum value.
  • MiddleColor. The HTML color string to use if the Value evaluates to the Middlevalue.
  • EndColor. The HTML color string to use if the Value evaluates to the Maximum value.

You can use static values or aggregate functions (e.g. Min, Avg, or Max) to set the Minimum, Middle, and Maximum parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=ColorScale3(Value, Minimum, Middle, Maximum, StartColor, MiddleColor, EndColor)

Usage

Use an expression with this syntax in the BackgroundColor property of a Textbox or a CheckBox control. This causes the background color to change depending on the value of the field you specified in the Value parameter, in the case of the example, InStock. Any values falling between the Minimum value and the Middle value render with a gradient scale color between the StartColor and MiddleColor. The closer the value is to the Minimum, the closer to Crimson the color renders. In the same way, values falling between the Middle and Maximum render with a color between the MiddleColor and EndColor, in this case, varying shades of yellow-green.

Show Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundColor property of a TextBox Copy Code
=ColorScale3(Fields!InStock.Value,0,10,20,"Crimson","Yellow","MidnightBlue")

Show Default Behavior

The function returns Transparent in any of the following cases:

  1. The Value is out of range (i.e. does not fall between the Minimum and Maximum values).
  2. The Maximum is less than the Minimum.
  3. The Middle is not between the Minimum and the Maximum.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Middle | 0
Maximum | 0
StartColor | Silver
MiddleColor | Gainsboro
EndColor | WhiteSmoke

Show Dialog

When you select a TextBox or a CheckBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundColor property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: If you clear the Use a middle color check box, the expression used in the BackgroundColor property changes to ColorScale2. For more information, see ColorScale2.

Color Scale Data Visualizer dialog

See Also

Color Scale 2

How To
Data Visualizers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Resource Locator

Custom Resource Locator
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Custom Resource Locator

Glossary Item Box

Show All Show All
Hide All Hide All

Page reports and RDL reports can resolve resources from your file system using file paths, but sometimes resources are preserved in very specific sources, such as a database. With RDL report, you can create a custom resource locator to read any resources that might be required by your reports from any type of location. You can use it for resources such as images and theme files, or for reports to use in drillthrough links, subreports, or master reports.

API

You can implement a custom resource locator by deriving from the GrapeCity.ActiveReports.ResourceLocator and overriding the GetResource method.

The GetResource method returns ParentUri and Value properties. The Value property contains the located resource as a memory stream. The ParentUri property contains the string URI of the parent of the resource within the resource hierarchy.

Here is the GetResource method used in the sample.

Show C# MyPicturesLocator.cs code showing usage of the GetResource Method from the Sample

C# code. Paste inside a class. Copy Code
using System;
using System.Collections.Generic;
using System.Drawing;
using System.Globalization;
using System.IO;
using System.Runtime.InteropServices;
using System.Text;
using GrapeCity.ActiveReports.Samples.CustomResourceLocator.Properties;
namespace GrapeCity.ActiveReports.Samples.CustomResourceLocator
{
    /// Implementation of ResourceLocator which looks for resources in the My Pictures folder.
    internal sealed class MyPicturesLocator : ResourceLocator
    {
        private const string UriSchemeMyImages = "MyPictures:";
    '<summary>
    'Look for the resources in My Pictures folder.
    '</summary>
    '<param name="resourceInfo">The information about the resource to be obtained. </param>
    '<returns>The resource, null if it was not found. </returns>
        public override Resource GetResource(ResourceInfo resourceInfo)
        {

            Resource resource;
            string name = resourceInfo.Name;
            if (name == null || name.Length == 0)
            {
                throw new ArgumentException(Resources.ResourceNameIsNull, "name");
            }
            Uri uri = new Uri(name);
            if (uri.GetLeftPart(UriPartial.Scheme).StartsWith(UriSchemeMyImages, true, CultureInfo.InvariantCulture))
            {
                Stream stream = GetPictureFromSpecialFolder(uri);
                if (stream == null)
                {
                    stream = new MemoryStream();
                    Resources.NoImage.Save(stream, Resources.NoImage.RawFormat);
                }
                resource = new Resource(stream, uri);
            }
            else
            {
                throw new InvalidOperationException(Resources.ResourceSchemeIsNotSupported);
            }
            return resource;
        }
            /// <summary>
        /// Returns the specified image from My Pictures folder.
        /// </summary>
        /// <param name="path">The uri of the image located in My Pictures code, i.e. MyImages:logo.gif.</param>
        /// <returns>The stream contains the image data or null if the picture can't be found or handled.</returns>
        private static Stream GetPictureFromSpecialFolder(Uri path)
        {
            int startPathPos = UriSchemeMyImages.Length;
            if (startPathPos >= path.ToString().Length)
            {
                return null;
            }
            string pictureName = path.ToString().Substring(startPathPos);
            string myPicturesPath = Environment.GetFolderPath(Environment.SpecialFolder.MyPictures);
            if (!myPicturesPath.EndsWith("\\")) myPicturesPath += "\\";
             string picturePath = Path.Combine(myPicturesPath, pictureName);
            if (!File.Exists(picturePath)) return null;
            MemoryStream stream = new MemoryStream();
            try
            {
                Image picture = Image.FromFile(picturePath);
                picture.Save(stream, picture.RawFormat);
                stream.Position = 0;
            }
            catch(OutOfMemoryException)
                        /// The file is not a valid image, or GDI+ doesn't support the image type.
            {
                return null;
            }
            catch(ExternalException)
                        /// The image can't be saved.
            {
                return null;
            }
            return stream;
        }
    }
}

Show Visual Basic MyPicturesLocator.vb code showing usage of the GetResource Method from the Sample

Visual Basic code. Paste inside a class. Copy Code
Imports System.Globalization
Imports System.IO
Imports System.Runtime.InteropServices

Public Class MyPicturesLocator
    Inherits ResourceLocator

    Const UriSchemeMyImages As String = "MyPictures:"

    '<summary>
    'Look for the resources in My Pictures folder.
    '</summary>
    '<param name="resourceInfo">The information about the resource to be obtained. </param>
    '<returns>The resource, null if it was not found. </returns>

    Public Overrides Function GetResource(ByVal resourceInfo As ResourceInfo) As Resource
        Dim resource As Resource
        Dim name As String = resourceInfo.Name

        If (String.IsNullOrEmpty(name)) Then

            Throw New ArgumentException(My.Resources.ResourceNameIsNull, "name")

        End If

        Dim uri As New Uri(name)
        If (Uri.GetLeftPart(UriPartial.Scheme).StartsWith(UriSchemeMyImages, True, CultureInfo.InvariantCulture)) Then

            Dim stream As Stream = GetPictureFromSpecialFolder(uri)
            If (stream Is Nothing) Then
                stream = New MemoryStream()
                My.Resources.NoImage.Save(stream, My.Resources.NoImage.RawFormat)
            End If
            resource = New Resource(stream, uri)

        Else
            Throw New InvalidOperationException(My.Resources.ResourceSchemeIsNotSupported)
        End If
        Return resource
    End Function

    Function GetPictureFromSpecialFolder(ByVal path As Uri) As Stream
        Dim startPathPos As Integer = UriSchemeMyImages.Length

        If (startPathPos >= path.ToString().Length) Then
            Return Nothing
        End If

        Dim pictureName As String = path.ToString().Substring(startPathPos)
        Dim myPicturesPath As String = Environment.GetFolderPath(Environment.SpecialFolder.MyPictures)

        If (Not myPicturesPath.EndsWith("\\")) Then
            myPicturesPath += "\\"
        End If

        Dim picturePath As String = System.IO.Path.Combine(myPicturesPath, pictureName)

        If (Not File.Exists(picturePath)) Then
            Return Nothing
        End If

        Dim stream As New MemoryStream()

        Try
            Dim picture As Image = Image.FromFile(picturePath)
            picture.Save(stream, picture.RawFormat)
            stream.Position = 0
        Catch ex As OutOfMemoryException
                ' The file is not a valid image, or GDI+ doesn't support the image type.
            Return Nothing
        Catch ex As ExternalException
                ' The image can't be saved.
            Return Nothing
        End Try

        Return stream
    End Function

End Class

Sample

The product sample is located here:

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomResourceLocator\C# or VB.NET

contains a custom resource locator that looks for files in the current user’s My Pictures folder. It does this by looking for special MyPictures protocol.

See Also

Walkthroughs
Custom Resource Locator

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Nested Data Regions Bound to Different Data

Nested Data Regions Bound to Different Data
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Nested Data Regions Bound to Different Data

Glossary Item Box

In Page and RDL reports, you can use nested data regions that are bound to different datasets. To display data, you can either use a filter for a nested data region or a parameter that is set in the new GrapeCity.ActiveReports.PageReportModel.DataRegion.DataSetParameters property.

Binding data regions to different data is available for all data regions that you can use in Page and RDL Reports, that is Tablix, List, Chart, BandedList, Table, and Sparkline.

The report below shows the customer's contact name and phone information for products that are still in stock. The report layout consists of three (3) nested Table data regions, each data region bound to a different dataset - Products (Table1), Invoices (Table2), and Customers (Table3).

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Using a filter

To display data in nested data regions that are bound to different data, you can set a filter in the Table - Filters dialog. This filter will contain the value from a nested data region in the left side and the value from a parent data region in the right side of it.

In the sample report above, two (2) filters are created. For the Table2 data region bound to the Invoices dataset, we create the filter with the expression [ProductID]=[ProductID]. For the Table3 data region bound to the Customers dataset, we create the filter with the expression [CustomerID]=[CustomerID].

As a result, the report shows the Product Name and Units In Stock information from the Products dataset. For each Product Name, the report shows the Customer Name information from the Invoices dataset and the Contact Name and Phone information from the Customers dataset.

Using a parameter

Setting a parameter in the DataSetParameters property also allows displaying data in nested data regions that are bound to different datasets. The basic steps are as follows.

  1. In the DataSetParameters property of a data region, add a new parameter, for example, productID.

  2. In the data region’s dataset, add a new parameter - productID.
  3. In the data region’s dataset, add a substring with the parameter to the existing dataset query, for example: WHERE productID = @productID

For the sample report layout above, two parameters are created. For the Table2 data region, bound to the Invoices dataset, we create the parameter productID and modify the dataset query as select * from Invoices where productID = @productID. For the Table3 data region, bound to the Customers dataset, we create the parameter customerID and modify the dataset query as select * from Invoices where customerID = @customerID.

As a result, the report shows the Product Name and Units In Stock information from the Products dataset. For each Product Name, the report shows the Customer Name information from the Invoices dataset and the Contact Name and Phone information from the Customers dataset.

See Also

Filtering
Parameters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Report Concepts

Section Report Concepts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts

Glossary Item Box

There are a number of concepts that only apply to section reports.

In this section

Section Report Toolbox
This section provides information on each of the report controls available in the ActiveReports 13 Section Report group of the Visual Studio toolbox.
Section Report Structure
Learn about the report structure in a section layout.
Section Report Events
Learn about events that you can use to customize section reports.
Scripting in Section Reports
Learn how to use scripts in a section layout.
Report Settings Dialog
See the various options provided in Report Settings dialog.
Grouping Data in Section Reports
Learn about grouping data in section layout.
Date, Time, and Number Formatting
Learn how you can customize formatting with .NET strings.
Optimizing Section Reports
Learn about ways to optimize section reports to reduce memory consumption and increase speed.
CacheToDisk and Resource Storage
Learn about IsolatedStorage and other considerations when you use CacheToDisk to reduce memory consumption.

See Also

Page Report/RDL Report Concepts

Getting Started
Getting Started

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Report Toolbox

Section Report Toolbox
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox

Glossary Item Box

When a Section report has focus in Visual Studio, the ActiveReports 13 Section Report toolbox group offers a number of report controls that you can use when creating a section report. You can drag these from the toolbox and drop them onto your section reports. These tools are different than those in the Toolbox.

Note: Take care in naming report controls, as they are displayed to end users in the advanced search feature of the Viewer.

In this section

Label
The label is used to display descriptive text for a control and helps the user to describe the data displayed in a report.
TextBox (Section Report)
The text box is a basic reporting control that allows direct display and editing of unformatted text.
CheckBox (Page Report)
The checkbox gives the user an option of yes or no and true or false.
RichTextBox
The rich text box control allows the user to enter rich text in the form of formatted text, tables, hyperlinks, images, etc.
Shape
The shape is a user interface element that allows to draw shapes on the screen.
Picture
This control displays images files on the screen and also performs functions like resizing and cropping of images being used.
Line (Section Report)
The line visually draws boundaries or highlights specific areas of a report.
Page Break
The PageBreak control is used when you need to stop printing a report inside the selected section and resume it on a new page.
Barcode (Section Report)
The BarCode control allows you to choose from several barcode styles available, and bind them to a data source.
SubReport (Section Report)
Use the subreport control as a placeholder for data from a separate report. Use code to connect the separate report to the subreport control.
Ole Object
You can add an OLE object, bound to a database or unbound, directly to your report.
Note: The OleObject control is not displayed in the toolbox by default, because it is obsolete, and is only available for backward compatibility.
Chart

You can use the ChartControl for a graphical presentation of data in a report. There are numerous chart types that you can use to easily design and render data.

Report Info
The ReportInfo control allows you to quickly display page numbers, page counts and report dates.
Cross Section Controls
The CrossSectionLine and CrossSectionBox controls provide visual boundaries and highlight specific areas of your report that span multiple report sections. This CrossSectionLine control is a vertical line that starts in the header section and spans the intervening sections until it ends in the footer. (For a horizontal or diagonal line, use the Line control.) The CrossSectionBox control starts in the header section and spans any intervening sections to end in the related footer section.

See Also

Toolbox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Label

Label
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Label

Glossary Item Box

Show All Show All
Hide All Hide All

The Label control for Section reports is very similar to the standard Visual Studio Label control. Since, by inheriting from the ARControl object, it can bind to data with the DataField property, and since you can enter static text in the TextBox control, the main difference between the two controls is the Angle property of the Label control, and the following properties of the TextBox control: CanGrow, CanShrink, CountNullValues, Culture, DistinctField, OutputFormat, SummaryFunc, SummaryGroup, SummaryRunning, and SummaryType.

This control may become obsolete if the Angle property is added to the TextBox, and then will be kept only for compatibility with previous versions.

Show Important Properties

Property | Description
Angle | Gets or sets the angle (slope) of the text within the control area. Set the Angle property to 900 to display text vertically.
CharacterSpacing | Gets or sets the space between characters in points.
DataField | Gets or sets the field name from the data source to bind to the control.
HyperLink | Gets or sets a URL to which the viewer navigates when the user clicks the label at run time. The URL becomes an anchor tag or a hyperlink in HTML and PDF exports.
LineSpacing | Gets or sets the space between lines in points.
MinCondenseRate | Specifies the minimal rate of the text horizontal shrinking in percentages. Should be between 10 and 100.
MultiLine | Gets or sets a value indicating whether to allow text to break to multiple lines within the control.
ShrinkToFit | Gets or sets a value indicating whether to decrease the font size so that all of the text shows within the boundaries of the control.
Style | Gets or sets a style string for the label.
Text | Gets or sets the text to show on the report.
TextJustify | Specifies how to distribute text when the Alignment property is set to Justify. With any other Alignment setting, this property is ignored.
VerticalAlignment | Gets or sets the vertical position of the label's text within the bounds of the control.
VerticalText | Indicates whether to render the label's text vertically.
WrapMode | Indicates whether a multi-line label control wraps words or characters to the beginning of the next line when necessary.

You can double-click in the Label control to enter edit mode and enter text directly in the control, or you can enter text in the Properties window or in code through the Text property.

You can format text in the Label control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties window. Formats apply to all of the text in the control. Text formatting changes in the Properties window immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties window.

Note: In edit mode for a Label with the Alignment property set to Justify, the Alignment value temporarily changes to the default value, Left. Once you leave edit mode, it automatically changes back to Justify.

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

Label Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the label that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the label.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Show Appearance

Background Color: Select a color to use for the background of the label.

Angle: Use the slider to set the degree of slope for the text within the control area.

Show Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Show Format

Line spacing: Enter a value in points to use for the amount of space between lines.

Character spacing: Enter a value in points to use for the amount of space between characters.

Multiline: Select this check box to allow text to render on multiple lines within the control.

Minimal rate of text horizontal shrinking (in %): Specify the percentage to which the text should be shrunk horizontally.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Vertical text: Select this check box for top to bottom text.

Show Alignment

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Justify method: Choose Auto, Distribute, or DistributeAllLines.

Note: You must select Justify in the Horizontal alignment property to enable the Justification method property options.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to determine whether and how text breaks to the next line.

Padding

Enter values in points to set the amount of space to leave around the label.

  • Top
  • Left
  • Right
  • Bottom

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


TextBox (Section Report)

TextBox (Section Report)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > TextBox (Section Report)

Glossary Item Box

Show All Show All
Hide All Hide All

The TextBox control is the basis of reporting as it is used to display text in section reports. You can bind it to data or set it at run time. It is the same control that forms when you drag a field onto a report from the Report Explorer.

Show Important Properties

Property | Description
CharacterSpacing | Gets or sets a character spacing in points.
LineSpacing | Gets or sets a line spacing in points.
OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Style | Gets or sets a style string for the textbox.
TextJustify | Specifies text justification with TextAlign set to Justify.
VerticalAlignment | Gets or sets the position of the textbox's text vertically within the bounds of the control.
VerticalText | Gets or sets whether to render text according to vertical layout rules.
CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
CanShrink | Determines whether ActiveReports should decrease the height of the control based on its value.
MinCondenseRate | Specifies the minimal rate of the text horizontal shrinking in percentages. Should be between 10 and 100.
MultiLine | Gets or sets a value indicating whether this is a multi-line textbox control.
ShrinkToFit | Determines whether ActiveReports decreases the font size when text values exceed available space.
WrapMode | Indicates whether a multi-line textbox control automatically wraps words or characters to the beginning of the next line when necessary.
CountNullValues | Boolean which determines whether DBNull values should be included as zeroes in summary fields.
Culture | Gets or sets CultureInfo used for value output formatting.
DataField | Gets or sets the field name from the data source to bind to the control.
HyperLink | Gets or sets the hyperlink for the text control.
Text | Gets or sets the formatted text value to be rendered in the control.
DistinctField | Gets or sets the name of the data field used in a distinct summary function.
SummaryFunc | Gets or sets the summary function type used to process the DataField Values.
SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
SummaryRunning | Gets or sets a value that determines whether that data field summary value will be accumulated or reset for each level (detail, group or page).
SummaryType | Gets or sets a value that determines the summary type to be performed.

You can double-click in the TextBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties window or in code through the Text property.

You can format text in the TextBox control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties window. Formats apply to all of the text in the control. Text formatting changes in the Properties window immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties window.

Note: In edit mode for a TextBox with the Alignment property set to Justify, the Alignment value temporarily changes to the default value, Left. Once you leave edit mode, it automatically changes back to Justify.

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

TextBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the textbox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Show Appearance

Background Color: Select a color to use for the background of the textbox.

Show Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Show Format

Line spacing: Enter a value in points to use for the amount of space between lines.

Character spacing: Enter a value in points to use for the amount of space between characters.

Multiline: Select this check box to allow text to render on multiple lines within the control.

Minimal rate of text horizontal shrinking (in %): Specify the percentage to which the text should be shrunk horizontally.

Textbox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Can shrink text to fit fixed size control: Select this check box to set ShrinkToFit to True.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Vertical text: Select this check box for top to bottom text.

Show Alignment

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Justify method: Choose Auto, Distribute, or DistributeAllLines.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

Note: You must select Justify in the Horizontal alignment property to enable the Justification method property options.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to determine whether and how text breaks to the next line.

Padding

Enter values in points to set the amount of space to leave around the label.

  • Top
  • Left
  • Right
  • Bottom

Show Summary

SummaryFunc: Select a type of summary function to use if you set the SummaryRunning and SummaryType properties to a value other than None. For descriptions of the available functions, see the SummaryFunc Enumeration.

SummaryGroup: Select a section group that you have added to the report. If you also set the SummaryRunning property to Group, the textbox summarizes only the values for that group.

SummaryRunning: Select None, Group, or All. If None, the textbox shows the value for each record. If Group, the textbox summarizes the value for the selected SummaryGroup. If All, the textbox summarizes the value for the entire report.

SummaryType: Select the type of summary to use. For descriptions of the available types, see the SummaryType Enumeration.

Distinct Field: Select a field to use with one of the SummaryFunc distinct enumerated values.

Count null values: Select this check box to include null values as zeroes in summary fields.

See Also

TextBox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


CheckBox (Section Report)

CheckBox (Section Report)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > CheckBox (Section Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, you can use the CheckBox control to represent a Boolean value in a report. By default, it appears as a small box with text to the right. If the DataField value evaluates to True, the small box appears with a check mark; if False, the box is empty. By default, the checkbox is empty.

Show Important Properties

Property | Description
CheckAlignment | Gets or sets the alignment of the check box text within the control drawing area.
Checked | Gets or sets a value indicating whether the check box is in the checked state. You can also set the Checked property of the check box in code or bind it to a Boolean database value.
DataField | Gets or sets the field from the data source to bind to the control.
Text | Gets or sets the printed caption of the check box.

You can double-click in the CheckBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties window or you can assign data to display in code through the Text property.

You can format text in the CheckBox control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties window. Formats apply to all of the text in the control. Text formatting changes in the Properties window immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties window.

Note: In edit mode for a CheckBox with the Alignment property set to Justify, the Alignment value temporarily changes to the default value, Left. Once you leave edit mode, it automatically changes back to Justify.

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

CheckBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the CheckBox that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field that returns a Boolean value from the data source to bind to the control. The value of this field determines how to set the Checked property at run time.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

Check Alignment: Drop down the visual selector to choose the vertical and horizontal position for the check box within the control.

Checked: Select this check box to have the CheckBox control appear with a check mark in the box.

Show Appearance

Background Color: Select a color to use for the background of the textbox.

Show Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Show Alignment

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

Padding

Enter values in points to set the amount of space to leave around the check box.

  • Top
  • Left
  • Right
  • Bottom

See Also

CheckBox (Page Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


RichTextBox

RichTextBox
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > RichTextBox

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, the RichTextBox control is used to display, insert and manipulate formatted text. It is different from the TextBox control in a number of ways. The most obvious is that it allows you to apply different formatting to different parts of its content.

You can also load an RTF file or an HTML file into the RichTextBox control at design time or at run time, and you can use it to create field merged reports with field placeholders that you replace with values at run time. You can add fields to the text you enter directly in the control by right-clicking and choosing Insert Fields and providing a field name.

For more information, see Load a File into a RichTextBox Control and Mail Merge with RichTextBox.

Show Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

Load File Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Load file command to open the dialog. This allows you to select a file to load into the control at design time. Supported file types are as follows.

  • Text (*.txt)
  • RichText (*.rtf)
  • HTML (*.htm, *.html)

Show Text/RichText file

When you load a Text/RichText file, the control will display the file at design time in the edit mode.

Show Important Properties

Property | Description
AutoReplaceFields | If True, any fields in the RTF control are replaced with fields from the data source.
CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
MultiLine | Gets or sets a value that determines whether the RichTextBox prints multiple lines or a single line.
DataField | Gets or sets the field name from the data source to bind to the control.

Show HTML File

When you load an HTML file, the control will display the HTML markup at design time in the edit mode.

Important: The HTML text in an HTML file, loaded into the RichTextBox control, must be enclosed in the <body></body> tags. Otherwise, the HTML data is converted into RTF.

Supported Tags

See the Supported HTML Tags section in Formatted Text to learn about what HTML tags the RichTextBox control supports.

To load a file into the report at run time, use the Load method. For more information, see Load Method.

RichTextBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the RichTextBox that is unique within the report. This name is displayed in the Document Outline. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Max length: Enter the maximum number of characters to display in the control. If you do not specify a value, it displays an unlimited number of characters.

AutoReplaceFields: Select this check box to have ActiveReports replace any fields in the control with values from the data source.

Show Appearance

Background Color: Select a color to use for the background of the control.

Show Format

RichTextBox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Multiline: Select this check box to allow the control to display multiple lines of text.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Shape (Section Report)

Shape (Section Report)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Shape (Section Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, the Shape control is used to add simple shapes to a report.

Show Important Properties

Property | Description
LineColor | Gets or sets the color of the shape lines.
LineStyle | Gets or sets the pen style used to draw the line.
LineWeight | Gets or sets the pen width used to draw the shape.
Style | Gets or sets the shape type to draw. You can select from Rectangle, Ellipse and a RoundedRect.
RoundingRadius | Sets the radius of each corner for the RoundRect shape type. You can select Default, TopLeft, TopRight, BottomLeft or BottomRight. Selecting Default sets the radius of all the corners of the Shape control to a specified percentage. Default value = 10 (percent).

Shape Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the shape that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Show Appearance

Shape type: Select the type of shape to display. You can choose from Rectangle, Ellipse, or RoundRect. For a circle, set the control width and height properties to the same value, and choose Ellipse, or choose RoundRect and set the Rounding radius to 100%.

Rounded Rectangle: When the Shape type is set to RoundRect, you can specify the radius for each corner of the shape independently. Drag the handlers [image] available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the Shape control.

  • Use the same radius on specified corners: Select this option to apply the same radius to all selected corners of the shape.

  • Use different radius on specified corners: Select this option to apply a different radius to each selected corner of the shape.

Line style: Select a line style to use for the shape line. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the shape line.

Line color: Select a color to use for the shape line.

Background color: Select a color to use for the background of the shape.

Background style: Select a background style for the shape from Solid, Gradient, and Pattern. Depending on the style selected, other properties are available.

See Also

Shape

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Picture

Picture
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Picture

Glossary Item Box

Show All Show All
Hide All Hide All

In section reports, the Picture control is used to print an image on the report. In the Image property of the Picture control, you can select any image file to display on your report.

Note: Use the PictureAlignment and SizeMode properties to control cropping and alignment.

Show Important Properties

Property | Description
LineColor | Gets or sets the border line color around the Picture control.
LineStyle | Gets or sets the pen style used to paint the border around the Picture control.
LineWeight | Gets or sets the pen width of the border line.
PictureAlignment | Gets or sets the position of the image within the control area.
Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
HyperLink | Gets or sets a URL address that can be used in the viewer's Hyperlink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Image | Gets or sets the image to print.
SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.

Picture Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the picture control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Choose image: Click this button open a dialog where you can navigate to a folder from which to select an image file to display.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Title: Enter static text for the picture.

Description: Enter text to describe the image for those who cannot see it. This is used in the HTML export for the "alt" attribute of the img tag.

Show Appearance

Line style: Select a line style to use for the border line. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the border line.

Line color: Select a color to use for the border line.

Background color: Select a color to use for the background of the picture control.

Picture alignment: Select how to align the image within the control. You can select from TopLeft, TopRight, Center, BottomLeft, or BottomRight.

Size mode: Select how to size the image within the control. You can select from Clip, Stretch, or Zoom. Clip uses the original image size and clips off any excess, Stretch fits the image to the size and shape of the control, and Zoom fits the image into the control while maintaining the aspect ratio of the original image.

See Also

Image (Page Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Line (Section Report)

Line (Section Report)
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Line (Section Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, the Line control allows you to draw vertical, horizontal or diagonal lines that visually separate or highlight areas within a section on a report.

Note: If you need lines to span across report sections, please see the CrossSectionLine control.

You can use your mouse to visually move and resize the Line, or you can use the Properties window to change its X1, X2, Y1, and Y2 properties to specify the coordinates for its starting and ending points.

Show Important Properties

Property | Description
AnchorBottom | Anchors the line to the bottom of the containing section so that the line grows along with the section.
LineColor | Gets or sets the color of the line.
LineStyle | Gets or sets the pen style used to draw the line.
LineWeight | Gets or sets the pen width of the line.
X1 | Gets or sets the horizontal coordinate of the line's starting point.
X2 | Gets or sets the horizontal coordinate of the line's end point.
Y1 | Gets or sets the vertical coordinate of the line's starting point.
Y2 | Gets or sets the vertical coordinate of the line's end point.

Line Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the line that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Show Appearance

Line style: Select a line style to use for the line. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the line.

Line color: Select a color to use for the line.

Anchor at bottom: Select this check box to automatically change the Y2 value to the value of the bottom edge of the containing section after it has grown to accommodate data at run time.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page Break

Page Break
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Page Break

Glossary Item Box

Show All Show All
Hide All Hide All

You can cause ActiveReports to break to a new page at any point within any section using the PageBreak control. All controls placed below the PageBreak in the section render to a new page.

Caution: It is not recommended to place PageReport control over other controls as it can cause extra page breaks.

Tip: Another way to cause ActiveReports to break to a new page is by setting the NewPage property of a section to Before, After, or BeforeAfter. This property is available on any section except for PageHeader and PageFooter.

Show Important Properties

Property | Description
Enabled | Determines whether to enable the PageBreak.
Location - X | Gets or sets the horizontal location of an object.
Location - Y | Gets or sets the vertical location of an object.

PageBreak Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the PageBreak that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Enabled: Select a field from the data source to bind to the control.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Barcode (Section Report)

Barcode (Section Report)
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Barcode (Section Report)

Glossary Item Box

Show All Show All
Hide All Hide All

The Barcode report control offers various barcode styles to choose from. This saves you the time and expense of finding and integrating a separate component. As with other data-bound report controls, you can bind a barcode to data using the DataField property.

Apart from the barcode style, you can manage the alignment, color, background color, caption position, font, text, and check whether checksum is enabled in the Properties Window. There are more properties available with the Code49, PDF417, and QRCode barcode styles. Click the Barcode to reveal its properties in the Properties window. All of the properties specific to this report control are also available in the Barcode dialog.

Show Important Properties

The following properties help you to customize the specific barcode you need for your application:

Property | Description
Alignment | The horizontal alignment of the caption in the control. Select from Near, Center, or Far. See CaptionPosition for vertical alignment.
AutoSize | When set to True, the barcode automatically stretches to fit the control.
BackColor | Select a background fill color for the barcode.
BarHeight | Set the height, in inches, of the barcode's bars. If the bar height exceeds the height of the control, this property is ignored.
CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read. This property is only available with certain styles of barcode, and is ignored with other styles.
CaptionPosition | The vertical alignment of the caption in the control. Select from None, Above, or Below. See Alignment for horizontal alignment. None is selected by default, and no caption is displayed.
CheckSumEnabled | Some barcode styles require a checksum and some have an optional checksum. CheckSumEnabled has no effect if the style already requires a check digit or if the style does not offer a checksum option.
Font | Set the font for the caption. Only takes effect if you set the CaptionPosition property to a value other than None.
ForeColor | Select a color for the barcode and caption.
NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is specified in pixels (for example, 10 pixels).
NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
QuietZone | Sets an area of blank space on each side of a barcode that tells the scanner where the symbology starts and stops. You can set separate values for the Left, Right, Top, and Bottom.
Rotation | Sets the amount of rotation to use for the barcode. You can select from None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.
Style | Sets the symbology used to render the barcode. See the table below for details about each style.
SupplementOptions | Sets the 2/5-digit add-ons for EAN/UPC symbologies. You can specify Text, DataField, BarHeight, CaptionPosition, and Spacing for the supplement.
Text | Sets the value to print as a barcode symbol and caption. ActiveReports fills this value from the bound data field if the control is bound to the data source.

Show Limitations

Some barcode types may render incorrectly and contain white lines in the Html and RawHtml views. However, this limitation does not affect printing and scanning. The list of barcode types that may render with white lines in the Html and RawHtml views:

  • Code49
  • QRCode
  • Pdf417
  • RSSExpandedStacked
  • RSS14Stacked
  • RSS14StackedOmnidirectional

Barcode Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

Autosize: Clear this check box to prevent the barcode from automatically resizing to fit the control.

Caption

Location: Select a value to indicate whether and where to display a caption for the barcode. You can select from Above, Below, or None.

Text alignment: Select a value to indicate how to align the caption text. You can select from Center, Near, or Far.

Show Barcode Settings

Style: Enter the type of barcode to use. ActiveReports supports all of the most popular symbologies:

Show Table of all included symbologies

Notes: The RSS and QRCode styles have fixed height-to-width ratios. When you resize the width, the height is automatically calculated.

When you choose a style that offers supplemental options, the additional options appear below.
Symbology Name | Example | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %. This is the default barcode style.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
BC412 | Data BC412 uses 35 characters, 0 - 9 and A - Z. It is designed for semiconductor wafer identification.
Codabar | Codabar uses A B C D + - : . / $ and numbers.
Code_11 | Encodes the numbers 0 through 9, the hyphen (-), and start/stop characters. It is primarily used in labeling telecommunications equipment.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses uppercase, % $ * / , + -, and numbers.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode containing two to eight rows of eight characters each. Each row has a start code and a stop code. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). It takes only 12 numbers as a string to calculate a check digit (CheckSum) and add it to the thirteenth position. The check digit is an additional digit used to verify that a bar code has been scanned correctly. The check digit is added automatically when the CheckSumEnabled property is set to True.
EAN_13 with the add-on code | EAN-13 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1 | EAN-128 is an alphanumeric one-dimensional representation of Application Identifier (AI) data for marking containers in the shipping industry. This barcode is now obsolete. You should use UCC/EAN–128 instead which provides similar functionality with better performance.
GS1QRCode

GS1QRCode is a subset of the QR Code. The GS1 QR Code is a 2D symbol that denotes the Extended Packaging URL for a trade item. It is processed to obtain one URL address associated with the trade item identified by the Global Trade Item Number (GTIN). GS1 QR Code requires the mandatory association of the GTIN and Extended Packaging URL.

GS1 QR Code allows to encode GS1 System Application Identifiers (AI) into QR Code 2D barcodes.

Limitation: Kanji, CN, JP and Korean characters.
HIBCCode128 | HIBCCode128 barcode uses the Code128 symbology. It encodes Primary Data and Secondary Data using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
HIBCCode39 | HIBCCode39 barcode uses the Code39 symbology, with the Code39OptionalCheckDigit property set to True. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
IATA_2_of_5 | IATA_2_of_5 is a variant of Code_2_of_5 and uses only numbers with a check digit.
IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
IntelligentMailPackage | IntelligentMailPackage is more efficient in terms of processing and tracking mails than Intelligent Mail barcode.
ISBN | International Standard Book Number barcode is a special form of the EAN-13 code and is used as a unique 9-digit commercial book identifier.
ISMN | Internationally Standard Music Number barcode is a special form of the EAN-13 code. It is used for marking printed musical publications.
ISSN | International Standard Serial Number barcode is a special form of the EAN-13 code. It is used to identify serial publications, publications that are issued in numerical order, such as the volumes of a magazine.
ITF14 | Interleaved Two of Five This code is used to mark cartons and palettes that are including goods with an EAN-13 code. One digit is added in front of the EAN-13 code to mark the packing variant.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars.
MaxiCode

MaxiCode is special polar barcode that uses 256 characters. It is used to encode a specific amount of data.
MicroPDF417

MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.

MicroPDF417 allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
MicroQRCode

MicroQRCode is a two-dimensional (2D) barcode that is designed for applications that use a small amount of data. It can handle numeric and alphanumeric data as well as Japanese kanji and kana characters. This symbology can encode up to 35 numeric characters.
MSI | MSI Code uses only numbers.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. Encodes the full ASCII character set. It has ten error correction levels and three data compaction modes: Text, Byte, and Numeric. This symbology can encode up to 1,850 alphanumeric characters or 2,710 numeric characters.
Pharmacode | Pharmacode represents only numeric data from 3 to 131070. It is a barcode standard used in the pharmaceutical industry for packaging. It is designed to be readable despite printing errors.
Plessey | Plessey uses hexadecimal digits to encode. It is a one-dimensional barcode used mainly in libraries.
PostNet | PostNet uses only numbers with a check digit.
PZN | PZN Pharmaceutical Central/General Number uses the same encoding algorithm as Code 39 but can carry only digits – 0123456789. The number of digits supported for encoding are 6 or 7. The letters 'PZN' and checksum digit are automatically added. It is mainly used to identify medicine and health-care products in Germany and other German-speaking countries.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail RM4SCC uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a 14-digit Reduced Space Symbology that uses EAN.UCC item identification for point-of-sale omnidirectional scanning. The RSS family of barcodes is also known as GS1 DataBar.
RSS14Stacked RSS14Stacked uses the EAN.UCC information with Indicator digits as in the RSS14Truncated, but stacked in two rows for a smaller width.
RSS14Stacked allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSS14Stacked CCA | RSS14Stacked with Composite Component - Version A.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional uses the EAN.UCC information with omnidirectional scanning as in the RSS14, but stacked in two rows for a smaller width.
RSS14Truncated | RSS14Truncated uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSExpanded

RSSExpanded uses the EAN.UCC information as in the RSS14, but also adds AI elements such as weight and best-before dates.

RSSExpanded allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSExpandedStacked

RssExpandedStacked uses the EAN.UCC information with AI elements as in the RSSExpanded, but stacked in two rows for a smaller width.

RSSExpandedStacked allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at run time.
RSSLimited RSS Limited uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSLimited allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSSLimited CCA | RSS Limited with Composite Component - Version A.
SSCC_18 | SSCC_18 is an 18-digit Serial Shipping Container Code. It is used to identify individual shipping containers for tracking purposes.
Telepen | Telepen has 2 different modes - alphanumeric-only and numeric-only. Both modes require a start character, a check digit, and a stop character. It is mainly used in manufacturing industries.
UCCEAN128 | UCC/EAN –128 complies to GS1-128 standards. GS1-128 uses a series of Application Identifiers to encode data. This barcode uses the complete ASCII character set. It also uses FNC1 character as the first character position. Using AI's, it encodes best before dates, batch numbers, weights, and more such attributes. It is also used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_A with the add-on code | UPC-A may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be zero) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E0 with the add-on code | UPC-E0 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.
UPC_E1 with the add-on code | UPC-E1 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.

Bar Height: Enter a value in inches (for example, .25in) for the height of the barcode.

Narrow Bar Width (also known as X dimension): Enter a value in points (for example, 0.8pt) for the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it.

Tip: For accurate scanning, the quiet zone should be ten times the Narrow Bar Width value.

Narrow Width Bar Ratio: Enter a value to define the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3. Commonly used values are 2, 2.5, 2.75, and 3.

QuietZone

A quiet zone is an area of blank space on either side of a barcode that tells the scanner where the symbology starts and stops.

Left: Enter a size in inches of blank space to leave to the left of the barcode.

Right: Enter a size in inches of blank space to leave to the right of the barcode.

Top: Enter a size in inches of blank space to leave at the top of the barcode.

Bottom: Enter a size in inches of blank space to leave at the bottom of the barcode.

Note: The units of measure listed for all of these properties are the default units of measure used if you do not specify. You may also specify cm, mm, in, pt, or pc.

Checksum

A checksum provides greater accuracy for many barcode symbologies.

Compute Checksum: Select whether to automatically calculate a checksum for the barcode.

Note: If the symbology you choose requires a checksum, setting this value to False has no effect.

Code49 Options

Code49 Options are available for the Code49 barcode style.

Grouping: Indicates whether to use grouping for the Code49 barcode. The possible values are True or False (default). If Grouping is set to True, any value not expressed by a single barcode is expressed by splitting it into several barcodes.

GroupNumber: Enter a number between 0 (default) and 8 for the barcode grouping. When the Group property is set to 2, the grouped barcode's second symbol is created. When invalid group numbers are set, the BarCodeDataException is thrown.

Code128 Options

Code128 has three settings that work in conjunction: Dpi, BarAdjust, and ModuleSize. This property only applies to the barcode style EANFNC1. You can improve the readability of the barcode by setting all three properties.
  • Dpi: Sets the printer resolution. Specify the resolution of the printer as dots per inch to create an optimized barcode image with the specified Dpi value.
  • BarAdjust: Sets the adjustment size by dot units, which affects the size of the module and not the entire barcode.
  • ModuleSize: Sets the horizontal size of the barcode module.

DataMatrix Options

DataMatrix Options are available for the DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

EAN128FNC1 Options

EAN128FNC1 Options are available for the EAN128FNC1 barcode style.

DPI: Specify the printer resolution.

Module Size: Enter the horizontal size of the barcode module.

Bar Adjust: Enter the adjustment size by dot units, which affects the size of the module and not the entire barcode.

GS1Composite Options

GS1Composite Options are available for the RSS14Stacked and RSSLimited barcode styles.

Type: Select the type of the composite barcode from the drop-down list. The possible values are None or CCA. CCA (Composite Component - Version A) is the smallest variant of the 2-dimensional composite component.

Value: Enter the expression to set the value of the composite barcode.

MaxiCode Options

MaxiCode option to select mode is available for MaxiCode barcode.

Mode: Select the mode of the MaxiCode barcode. The available values are Mode2 to Mode6.

MicroPDF417 Options

MicroPDF417 Options are available for the MicroPDF417 barcode style.

Compaction Mode: Select the type of the compaction mode from the drop-down list. The possible values are Auto, TextCompactionMode, NumericCompactionMode, or ByteCompactionMode.

Version: Select the version from the drop-down box to set the symbol size.

Segment Index: The segment index of the structured append symbol. The valid value is from 0 to 99998, and less than the value in Segment Count.

Segment Count: The segment count of the structured append symbol. The valid value is from 0 to 99999.

File ID: The file id of the structured append symbol. The valid value is from 0 to 899.

MicroQRCode Options

MicroQRCode Options are available for the MicroQRCode barcode style.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. Valid values are M, L, or Q. The available Error Level values change depending on the version you select.

Version: Enter the version of the MicroQRCode barcode style. Valid values are M1, M2, M3, or M4. The maximum amount of data can be stored in version M4.

Mask: Select the pattern for the barcode masking from the drop-down list. Valid values are Mask00, Mask01, Mask10, or Mask11.

Encoding: Select the barcode encoding from the drop-down list.

PDF417 Options

PDF417 Options are available for the Pdf417 barcode style.

Columns: Enter column numbers for the barcode. Values for this property range from 1 to 30. The default value is -1 which automatically determines column numbers.

Rows: Enter row numbers for the barcode. Values range between 3 and 90. The default value is -1 which automatically determines row numbers.

ErrorLevel: Enter the error correction level for the barcode. Values range between 0 and 8. The error correction capability increases as the value increases. With each increase in the ErrorLevel value, the size of the barcode increases. The default value is -1 for automatic configuration.

PDF 417 Barcode Type: Select the PDF417 barcode type form the drop-down list. The possible values are Normal or Simple. Simple is the compact type in which the right indicator is neither displayed nor printed.

QRCode Options

QRCode Options are available for the QRCode barcode style.

Model: Select the model for the QRCode barcode style from the drop-down list. The possible values are Model1, the original model or Model2, the extended model. For GS1QRCode, Model1 is not supported.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. The possible values are L (7% restorable), M (15% restorable), Q (25% restorable), and H (30% restorable). The higher the percentage, the larger the barcode becomes.

Version: Enter the version of the QRCode barcode style. Version indicates the size of the barcode. As the value increases, the barcode's size increases, enabling more information to be stored. Specify any value between 1 and 14 when the Model property is set to Model1 and 1 to 40 for Model2. The default value is -1, which automatically determines the version most suited to the value.

Mask: Select the pattern for the barcode masking form the drop-down list. Mask is used to balance brightness and offers 8 patterns in the QRCodeMask enumeration. The default value is Auto, which sets the masking pattern automatically, and is recommended for most uses.

  • Mask000 (i+j) mod 2 = 0
  • Mask001 i mod 2 = 0
  • Mask010 j mod 3 = 0
  • Mask011 (i+j) mod 3 = 0
  • Mask100 (( i div 2)+(j div 3)) mod 2 = 0
  • Mask101 (ij) mod 2 + (ij) mod 3 = 0
  • Mask110 ((ij) mod 2 +(ij) mod 3) mod 2 = 0
  • Mask111 ((ij)mod 3 + (i+j) mod 2) mod 2 = 0

Connection: Select whether to use the connection for the barcode. The possible values are True or False. This property is used in conjunction with the ConnectionNumber property. This property is not applicable to GS1QRCode barcode.

ConnectionNumber: Enter the connection number for the barcode. Use this property with the Connection property to set the number of barcodes it can split into. Values between 0 and 15 are valid. An invalid number raises the BarCodeData Exception. This property is not applicable to GS1QRCode barcode.

Encoding: Select the barcode encoding from the drop-down list.

RssExpandedStacked Options

RssExpandedStacked Options are available for the RSSExpandedStacked barcode style.

Row Count: Enter the number of the barcode stacked rows.

Supplementary Options

Supplementary Options are available for UPC_A, UPC_E0, UPC_E1, EAN_13, and EAN_8 barcode styles.

Supplement DataField: Select the data field for the barcode supplement.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and supplement barcodes.

Show Appearance

Fore color: Select a color to use for the bars in the barcode.

Background color: Select a color to use for the background of the control.

Rotation: Select a value indicating the degree of rotation to apply to the barcode. You can select from None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.

Show Font

Name: Select a font family name to use for the caption.

Size: Choose the size in points for the font.

Style: Choose from Normal or Italic.

Weight: Choose from Normal or Bold.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


SubReport (Section Report)

SubReport (Section Report)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > SubReport (Section Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In section reports, you can use the SubReport control to embed a report into another report. Once you place the Subreport control on a report, use code to create an instance of the report you want to load in it, and to attach the report object to the SubReport.

You can also pass parameters to the subreport from the main report so that data related to the main report displays in each instance of the subreport.

When to use a subreport

Due to the high overhead of running a second report and embedding it in the first, it is generally best to consider whether you need to use subreports. Some good reasons to use subreports include:

  • Multiple data sources
  • Multiple detail sections
  • Side-by-side charts or tables

Remove page-dependent features from reports to be used as subreports

Subreports are disconnected from any concept of a printed page because they render inside the main report. For this reason, page-dependent features are not supported for use in subreports. Keep any such logic in the main report. Page-related concepts that are not supported in subreports include:

  • Page numbers
  • Page header and footer sections (delete these sections to save processing time)
  • KeepTogether properties
  • GroupKeepTogether properties
  • NewPage properties

Coding best practices

Use the ReportStart event of the main report to create an instance of the report for your SubReport control, and then dispose of it in the ReportEnd event. This way, you are creating only one subreport instance when you run the main report.

In the Format event of the containing section, use the Report property of the SubReport control to attach a report object to the SubReport control.

Caution: It is not a recommended practice to initialize the subreport in the Format event. Doing so creates a new instance of the subreport each time the section processes. This consumes a lot of memory and processing time, especially in a report that processes a large amount of data.

Show Important Properties

Property | Description
CanGrow | Determines whether ActiveReports increases the height of the control based on its content.
CanShrink | Determines whether ActiveReports decreases the height of the control based on its value.
CloseBorder | By default, the bottom border of the control does not render until the end of the subreport. Set this property to True to have it render at the bottom of each page. (Only available in code.)
Report | Attaches a report object to the control. (Only available in code.)

SubReport Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the SubReport that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

ReportName: Enter the name of the report.

Show Format

SubReport Height

Can increase to accommodate contents: Clear this check box to set CanGrow to False.

Can decrease to accommodate contents: Clear this check box to set CanShrink to False.

See Also

How To
Embed Subreports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Ole Object

Ole Object
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Ole Object

Glossary Item Box

Show All Show All
Hide All Hide All

The OleObject control is hidden from the toolbox by default, and is only retained for backward compatibility. You can enable the OleObject control in the Visual Studio toolbox only.

To enable the control in the Visual Studio toolbox, you must change the EnableOleObject property to true. This property can be found here: C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 13\Grapecity.ActiveReports.config

Once enabled, you can add the OleObject control to reports. When you drop the control onto your report, the Insert Object dialog appears. This dialog allows you to create a new object or select one from an existing file.

Note: When you deploy reports that use the OleObject, you must also deploy the GrapeCity.ActiveReports.Interop.dll, or for 64-bit machines, the GrapeCity.ActiveReports.Interop64.dll.
Caution: The WPF Viewer does not support the OLE object. If you preview a report containing the OLE object in the WPF Viewer, the OLE object will not be displayed.

Important Properties

Property | Description
PictureAlignment | Gets or sets the position of the object's content within the control area.
Class | Specifies the class name of the Ole object.
SizeMode | Gets or sets a value that determines how the object is sized to fit the OleObject control area.

Insert Object Dialog

The Insert Object dialog provides the following two options:

  • Create New lets you select from a list of object types that you can insert into your report.

    Show Object Types

    • Adobe Acrobat Document
    • Microsoft Equation 3.0
    • Microsoft Excel 97-2003 Worksheet
    • Microsoft excel Binary Worksheet
    • Microsoft Excel Chart
    • Microsoft Excel Macro-Enabled Worksheet
    • Microsoft Excel Worksheet
    • Microsoft Graph Chart
    • Microsoft PowerPoint 97-2003 Presentation
    • Microsoft PowerPoint 97-2003 Slide
    • Microsoft PowerPoint Macro-Enabled Presentation
    • Microsoft PowerPoint Macro-Enabled Slide
    • Microsoft PowerPoint Presentation
    • Microsoft PowerPoint Slide
    • Microsoft Word 97-2003 Document
    • Microsoft Word Document
    • Microsoft Macro-Enabled Document
    • OpenDocument Presentation
    • OpenDocument Spreadsheet
    • OpenDocument Text
    • Package
    • Paintbrush Picture
    • Wordpad Document
  • Create from File allows you to insert the contents of the file as an object into your document so that you can display it while printing.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart

Chart
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, you can use the Chart data region to present data graphically in a report. The chart offers you 17 core chart types along with all of their variations, plus access to properties that control every aspect of your chart's appearance.

The Chart data region presents a series of points in different ways depending upon the chart type you choose. Some chart types display multiple series of data points in a single chart. Add more information to your chart by configuring data points, axes, titles, and labels. You can modify all of these elements in the Properties Window.

When you first drop a Chart data region onto a report, the Chart Wizard appears, and you can set up your chart type, appearance, series, titles, axes, and legend on the pages of the wizard. You can specify a data source on the Series page.

Show Important Properties

Property | Description
BlackAndWhiteMode | Gets or sets a value indicating whether the chart is drawn in black and white using hatch patterns and line dashing to designate colors.
AutoRefresh | Gets or sets a value indicating whether the chart is automatically refreshed (redrawn) after every property change.
Backdrop | Gets or sets the chart's background style.
ChartAreas | Opens the ChartArea Collection Editor where you can set properties such as axes and wall ranges, and you can add more chart areas.
ChartBorder | Gets or sets the chart's border style.
ColorPalette | Gets or sets the chart's color palette.
DataSource | Gets or sets the data source for the chart.
GridLayout | Gets or sets the layout of the chart's areas in columns and rows.
Legends | Opens the Legend Collection Editor where you can set up the chart's legends.
Series | Opens the Series Collection Editor where you can set up the series collection for the chart.
Titles | Opens the Titles Collection Editor where you can set up titles in the header and footer of the chart.
UIOptions | Gets or sets user interface features for the chart. Choose from None, ContextCustomize, UseCustomTooltips, or ForceHitTesting.
Culture | Gets or sets the chart's culture used for value output formatting.
ImageType | Sets or returns the image generated by the chart. Choose from Metafile or PNG.

Chart Commands and Dialogs

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click any of the commands to open a dialog. Commands in this section include:

  • Clear Chart clears all of the property settings from the chart so that you can begin with a clean slate. You are given an opportunity to cancel this action.
  • Load allows you to load a saved XML file containing a chart that you created using the Chart data region.
  • Save As allows you to save the current chart to an XML file that you can load into a chart on any section report.
  • Customize opens the main Chart Designer dialog where you can access Chart Areas, Titles, Series, Legends, and Appearance tabs. This dialog has access to more of the customizable areas than the wizard, but all of the properties in this dialog are also available in the Properties window.
  • Wizard reopens the Chart Wizard that appears by default when you first drop a Chart data region onto a report.
  • Data Source opens the Chart Data Source dialog where you can build a connection string and create a query.

Chart Elements

The Chart elements help you to easily analyze the visual information and interpret numerical and relational data. The following image illustrates the elements that make up the Chart data region.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Axis Label

A label along an axis that lets you label the units being shown.

Show Axis Title

The axis title allows you to provide a title for the information being shown on the axis.

Show Chart Backdrop

The chart backdrop is the background for the whole chart that is created. You can create your own backdrop using the different styles and colors available or you can use an image as a backdrop for your chart.

Show Chart Title

The chart title serves as the title for the chart.

Show Footer Title

The footer title allows you to add a secondary title for the chart along the bottom.

Show Grid Line

Grid lines can occur on horizontal and vertical axes and normally correlate to the major or minor tick marks for the axes.

Show Legend

The legend serves as a key to the specific colors or patterns being used to show series values in the chart.

Show Marker

The marker is used to annotate a specific plotted point in a data series.

Show Marker Label

The marker label allows you to display the value of a specific plotted point in a data series.

Show Major Tick

Major tick marks can occur on horizontal and vertical axes and normally correlate to the major gridlines for the axes.

Show Minor Tick

Minor tick marks can occur on horizontal and vertical axes and normally correlate to the minor gridlines for the axes.

Show Series

The series is a related group of data values that are plotted on the chart. Each plotted point is a data point that reflects the specific values charted. Most charts, such as the above bar chart, can contain more than one series, while others, such as a pie chart, can contain only one.

Show Wall Backdrop

The wall is the back section of the chart on which data is plotted.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Wizard

Chart Wizard
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Wizard

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart data region features a Chart Wizard which takes you through the basic steps of creating a chart. The Chart Wizard automatically appears when you first add a chart control to a report. If you prefer not to have the wizard appear automatically, clear the Auto Run Wizard checkbox at the bottom of the wizard.

The Chart Wizard has the following pages:

Show Chart Type

In the Chart Wizard that appears, the Chart Type page displays all available 2D and 3D chart types, along with a preview of the selected chart to the right. You can select the type of chart that you want to create and change the axes by selecting the Swap Axes checkbox. If you are using a 3D chart, you can also change the projection and light settings.

Show Appearance

The Appearance page has two tabs. The Palette tab allows you to select a color scheme. The Appearance tab allows you to select individual elements in the chart preview, such as its title, footer, legend, legend title, backdrop, and the chart itself and select appearance settings for them.

Show Series

The Series page has two tabs. The Series Settings tab allows you to set the data source for the chart and bind data fields to X and Y values for each series in the chart, and to add and remove chart series. You can even set different chart types for each series. The Data Points tab allows you to set static data values when you choose not to bind the X and Y values to data fields.

Show Title

The Title Page helps you to set properties for the header and footer titles. You can change the title text, font size and color, border settings, background color and visibility.

Show Axes

The Axes page has two tabs, one for Axis X and the other for Axis Y. On these tabs, you can enter titles for the axes and set the font size and other font properties. This page also allows you to add and format labels, add tick marks and grid lines, and select whether to show the axis inside or outside the chart area.

Show Legend

The Legend page allows you to set up the appearance of the legend. You can change its visibility, label appearance, header and footer text and appearance, layout, and location within the chart. You can also place the legend inside the chart by checking the Legend inside check box in the Position section.

See Also

Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Types (Section Reports)

Chart Types (Section Reports)
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports)

Glossary Item Box

These topics introduce you to the different Chart Types you can create with the Chart control.

Area Chart
Area2D, StackedArea, StackedArea100Pct, and Area3D
Bar Chart
Bar2D and Bar3D
Line Chart
Bezier, Line, LineXY and Line3D
Pie and Doughnut Charts
Doughnut/Pie and Doughnut3D/Pie
Financial Chart
Candle, HiLo, Renko, Point and Figure, Kagi, Stock, StockOpenClose, and Three Line Break
Point and Bubble Charts
Bubble, BubbleXY, Scatter, and PlotXY
Pyramid Chart Renko Chart Bubble Chart Funnel Chart Multiple Chart Types Stacked Area Chart Stacked Bar Chart Doughnut 3D Chart Point and Figure Chart Kagi Chart Plot XY Chart 3D Area Chart Gantt Chart Candle Chart Bubble XY Chart 3D Stacked Bar Chart Bezier Chart Chart Annotations Line XY Chart HiLoOpenClose Chart Line XY Chart 2 Plot XY Chart 2 Multiple Chart Types 2 Bar Chart with Markers 100 Percent Stacked Bar Chart 3D Line Chart 3D Bar Chart with Custom BarType and 6 Vertices Clustered 3D Bar Chart HiLo Financial Chart Bar Chart with Constant Lines and Stripes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Area Chart

Area Chart
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Area Chart

Glossary Item Box

The Area Chart displays quantitive data and is based on the Line chart. In Area charts, the space between axis and line are commonly emphasized with colors, textures and hatchings.

2D Area Charts
This section describes 2D charts that fall under the Area Chart category.
3D Area Charts
This section describes 3D charts that fall under the Area Chart category.

See Also

Charts
Chart Types (Section Reports)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


2D Area Charts

2D Area Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Area Chart > 2D Area Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Area Chart category:

Show Area Chart

An area chart is used to compare trends over a period of time or across categories.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Area2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

Show Stacked Area Chart

A stacked area chart is an area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Area2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

Show Stacked Area 100% Chart

A stacked area chart (100%) is an 100% area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Area2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

See Also

Area Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


3D Area Charts

3D Area Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Area Chart > 3D Area Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Area Chart category:

Show Area Chart

Use a 3D area chart to compare trends in two or more data series over a period of time or in specific categories, so that data can be viewed side by side.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Note: To view a chart in 3D, in the ChartAreas property open the ChartArea Collection Editor and set the ProjectionType property to Orthogonal.
Chart Information
ChartType | Area3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The LineBackdrop property gets or sets the backdrop information for the 3D line. The Thickness property gets or sets the thickness of the 3D line. The Width property gets or sets the width of the 3D line.

Below is an example of how to set the custom chart properties at run time for a 3D area chart as shown for the first series in the image above.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("LineBackdrop") = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.Red, CType(150, Byte))
Me.ChartControl1.Series(0).Properties("Thickness") = 5.0F
Me.ChartControl1.Series(0).Properties("Width") = 30.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["LineBackdrop"] = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Red, ((System.Byte)(150)));
this.ChartControl1.Series[0].Properties["Thickness"] = 5f;
this.ChartControl1.Series[0].Properties["Width"] = 30f;

Show Stacked Area Chart

3D stacked area chart displays stacked area chart in 3D.

Chart Information
ChartType | Area3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Width property gets or sets the width of the 3D stacked area.

Show Stacked Area 100%

3D stacked area chart (100%) displays stacked area chart in 3D (100%).

Chart Information
ChartType | Area3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | 3
Custom Properties | The Width property gets or sets the width of the 3D stacked area.

See Also

Area Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bar Chart

Bar Chart
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Bar Chart

Glossary Item Box

The Bar Chart is a chart with rectangular bars where the lengths of bars are proportional to the values they represent. The bars can be plotted vertically or horizontally.

2D Bar Charts
This section describes 2D charts that fall under the Bar Chart category.
3D Bar Charts
This section describes 3D charts that fall under the Bar Chart category.

See Also

Charts
Chart Types (Section Reports)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


2D Bar Charts

2D Bar Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Bar Chart > 2D Bar Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 2D charts that falls under the Bar Chart category.

Show Bar Chart

In a Bar Chart, values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. Use a bar chart to compare values of items across categories.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of series | 1 or more
Marker support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a bar chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 50.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 50f;

Show Gantt Chart

The Gantt chart is a project management tool used to chart the progress of individual project tasks. The chart compares project task completion to the task schedule.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Caution: In a Gantt chart, the X and Y axes are reversed. AxisX is vertical and AxisY is horizontal.
Chart Information
ChartType | Bar2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a Gantt chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 50.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 50f;

Show Horizontal Bar Chart

In a Horizontal Bar Chart, both the axes are swapped and therefore the bars appears horizontally. Although, values are represented by the height of the bar shaped marker as measured by the y-axis and the Category labels are displayed on the x-axis. Use a horizontal bar chart to compare values of items across categories.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a horizontal bar chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties（"Gap") = 65.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 65f；

Show Stacked Bar Chart

A stacked bar chart is a bar chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a StackedBar chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 100.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 100f;

Show Stacked Bar Chart 100%

A StackedBAR110Pct chart is a bar chart with two or more data series stacked one on top of the other to sum up to 100%. Use this chart to show how each value contributes to a total with the relative size of each series representing its contribution to the total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value

Below is an example of how to set the custom chart properties at run time for a StackedBAR110Pct chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 100.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 100f;

See Also

Bar Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


3D Bar Charts

3D Bar Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Bar Chart > 3D Bar Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Bar Chart category.

Caution: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.

Show Bar Chart

In a Bar Chart, values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. Use a 3D bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that is displayed.Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle propertygets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Show Gantt Chart

The 3D gantt chart displays a gantt chart in 3D.

Caution: In a 3D Gantt chart the X and Y axes are reversed. AxisX is vertical and AxisY is horizontal.
Chart Information
ChartType | Bar3D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Show Horizontal Bar Chart

In a Horizontal Bar Chart, both the axes are swapped and therefore the bars appears horizontally. Although, values are represented by the height of the bar shaped marker as measured by the y-axis and the Category labels are displayed on the x-axis. Use a horizontal 3D bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType propertygets or sets the type of bars that is displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a horizontal 3D bar chart as shown above.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
Me.ChartControl1.Series(0).Properties("PointBarDepth") = 100.0F
Me.ChartControl1.Series(0).Properties("RotationAngle") = 0.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C# Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 80f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["Gap"] = 65f;
this.ChartControl1.Series[0].Properties["PointBarDepth"] = 100.0f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 0f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6;

Show Stacked Bar Chart

Use a 3D bar graph to compare values of items across categories, allowing the data to be viewed conveniently in a 3D format. A stacked bar graph is a bar graph with two or more data series stacked on top of each other. Use this graph to show how each value contributes to a total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a StackedBar3D chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C# Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 100f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["Gap"] = 65f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6

Show Stacked Bar Chart 100%

A Stacked Bar 3D 100% chart is a bar chart with two or more data series in 3D stacked one on top of the other to sum up to 100%. Use this chart to show how each value contributes to a total with the relative size of each series representing its contribution to the total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.

The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.

The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a StackedBar3D100Pct chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C# Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 100f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["Gap"] = 65f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6

Show Bar/Cylinder Chart

It is almost similar to a bar chart and values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. The only difference is that in a Bar/Cylinder Chart the data is represented through cylindrical shaped markers.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that is displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Show Bar/Pyramid Chart

In a Bar/Pyramid Chart the data is represented through pyramid shaped bars and values are represented by the height of the bars as measured by the y-axis. Category labels are displayed on the x-axis.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that is displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Show Clustered Bar chart

Use a 3D clustered bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a 3D clustered bar chart as shown above.

Visual Basic Copy Code
' set the custom properties for series 1.
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 50.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 300.0F
Me.ChartControl1.Series(0).Properties("RotationAngle") = 0.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6

' set the custom properties for series 2.
Me.ChartControl1.Series(1).Properties("BarTopPercent") = 20.0F
Me.ChartControl1.Series(1).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(1).Properties("Gap") = 300.0F
Me.ChartControl1.Series(1).Properties("RotationAngle") = 90.0F
Me.ChartControl1.Series(1).Properties("VertexNumber") = 3
C# Copy Code
// set the custom properties for series 1.
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 50f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 0f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6;

// set the custom properties for series 2.
this.ChartControl1.Series[1].Properties["BarTopPercent"] = 20f;
this.ChartControl1.Series[1].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[1].Properties["Gap"] = 300f;
this.ChartControl1.Series[1].Properties["RotationAngle"] = 90f;
this.ChartControl1.Series[1].Properties["VertexNumber"] = 3;

See Also

Bar Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Line Chart

Line Chart
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Line Chart

Glossary Item Box

The Line Chart is a type of chart that displays information as a series of data points, connected by straight line segments.

2D Line Charts
This section describes 2D charts that fall under the Line Chart category.
3D Line Charts
This section describes 3D charts that fall under the Line Chart category.

See Also

Charts
Chart Types (Section Reports)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


2D Line Charts

2D Line Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Line Chart > 2D Line Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Line Chart category.

Show Bezier Chart

Use a Bezier or spline chart to compare trends over a period of time or across categories. It is a line chart that plots curves through the data points in a series.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets the line element. Used to set color, thickness and shape of a line. The Tension property gets or sets the tension of the curved lines.

Show Bezier XY Chart

A Bezier XY chart connects DataPoints on X and Y with curved lines.

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets the line element. Used to set color, thickness and shape of a line. The Tension property gets or sets the tension of the curved lines.

Show Line Chart

Use a 2D line chart to compare trends over a period of time or in certain categories in a 2D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets the line element. Used to set color, thickness and shape of a line. The LineJoin property sets the type of join to draw when two lines connect.

Show Line XY Chart

A line XY chart plots points on the X and Y axes as one series and uses a line to connect points to each other.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets line elements. Used for setting color, thickness and shape of a line. The LineJoin property gets or sets the type of join to draw when two lines connect.

See Also

Line Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


3D Line Charts

3D Line Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Line Chart > 3D Line Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Line Chart category.

Show Bezier Chart

Render a Bezier or Spline chart in 3D format.

Chart Information
ChartType | Line3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The LineBackdrop property gets or sets the backdrop information for the 3D curved line. The Tension property gets or sets the tension of the curved lines. The Width property gets or sets the width of the 3D curved line.

Show Line Chart

Use a 3D line chart to compare trends over a period of time or in certain categories in a 3D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Caution: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.
Chart Information
ChartType | Line3D
Number of Y values per data point | 1
Number of Series | 1or more
Marker Support | Series or Data Point
Custom Properties | The LineBackdrop property gets or sets the backdrop information for the 3D line. The Thickness property gets or sets the thickness of the 3D line. The Width property gets or sets the width of the 3D line.

Below is an example of how to set the custom chart properties at run time for a horizontal 3D bar chart as shown above.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("LineBackdrop") = New Backdrop(Color.GreenYellow)
Me.ChartControl1.Series(0).Properties("Thickness") = 8.0F
Me.ChartControl1.Series(0).Properties("Width") = 40.0F
C# Copy Code
this.chartControl1.Series[0].Properties["LineBackdrop"] = new Backdrop(Color.GreenYellow);
this.chartControl1.Series[0].Properties["Thickness"] = 8f;
this.chartControl1.Series[0].Properties["Width"] = 40f;

See Also

Line Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Pie and Doughnut Charts

Pie and Doughnut Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Pie and Doughnut Charts

Glossary Item Box

A Pie Chart is a circular chart divided into sectors to illustrate proportion.

A Doughnut Chart is functionally identical to a Pie Charts. It also has single-series and multi-series versions, with the only difference that it has a hole in the middle.

2D Pie/Doughnut Charts
This section describes 2D charts that fall under the Pie/Doughnut Chart category.
3D Pie/Doughnut Charts
This section describes 3D charts that fall under the Pie/Doughnut Chart category.

See Also

Charts
Chart Types (Section Reports)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


2D Pie/Doughnut Charts

2D Pie/Doughnut Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Pie and Doughnut Charts > 2D Pie/Doughnut Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Pie/Doughnut Chart category.

Show Doughnut Chart

A doughnut chart shows how the percentage of each data item contributes to the total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

In order to show each section of the pie in a different color, set the Background property for each data point.
Chart Information
ChartType | Pie/Doughnut 2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Clockwise property gets or sets a value indicating whether to display the data in clockwise order. The ExplodeFactor property gets or sets the amount of separation between data point values. The HoleSize property gets or sets the inner radius of the chart. The OutsideLabels property gets or sets a value indicating whether the data point labels appear outside the chart. The StartAngle property gets or sets the horizontal start angle for the series.

Below is an example of how to set custom chart properties at run time for a doughnut chart.

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("ExplodeFactor") = 0.0F
Me.ChartControl1.Series(0).Properties("HoleSize") = 0.25F
Me.ChartControl1.Series(0).Properties("OutsideLabels") = False
Me.ChartControl1.Series(0).Properties("Radius") = 2.0F
Me.ChartControl1.Series(0).Properties("StartAngle") = 0.0F
C# Copy Code
this.ChartControl1.Series[0].Properties["ExplodeFactor"] = 0f;
this.ChartControl1.Series[0].Properties["HoleSize"] = 0.25f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = false;
this.ChartControl1.Series[0].Properties["Radius"] = 2.0f;
this.ChartControl1.Series[0].Properties["StartAngle"] = 0f;

Show Funnel Chart

A funnel chart shows how the percentage of each data item contributes as a whole.

Chart Information
ChartType | Pie/Doughnut 2D
Number of Y values per data points | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding funnel section. The default value is a black one-point line.
The FunnelStyle property gets or sets the Y value for the series points to the width or height of the funnel. The default value is YIsHeight.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the funnel chart. The height is measured in relative coordinates.
The NeckHeight property gets or sets the neck height for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The NeckWidth property gets or sets the neck width for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the funnel chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the funnel. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the funnel chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.

Show Pyramid Chart

A Pyramid chart shows how the percentage of each data item contributes as a whole.

Chart Information
ChartType | Pie/Doughnut 2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding pyramid section. The default value is a black one-point line. The MinPointHeight property gets or sets the minimum height allowed for a data point in the pyramid chart. The height is measured in relative coordinates. The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the pyramid chart. The default value is True. The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the pyramid. This property can only be used with the OutsideLabels property set to True. The PointGapPct property gets or sets the amount of space between the data points of the pyramid chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.

See Also

Pie and Doughnut Charts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


3D Pie/Doughnut Charts

3D Pie/Doughnut Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Pie and Doughnut Charts > 3D Pie/Doughnut Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Pie/Doughnut Chart category.

Caution: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.

Show Doughnut Chart

A 3D doughnut chart shows how the percentage of each data item contributes to a total percentage, allowing the data to be viewed in a 3D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Clockwise property gets or sets a value indicating whether to display the data in clockwise order. The ExplodeFactor property gets or sets the amount of separation between data point values. The value must be less than or equal to 1. To explode one section of the doughnut chart, set ExplodeFactor to the data point instead of the series. The HoleSize property gets or sets the inner radius of the chart. If set to 0, the chart looks like a pie chart. The value must be less than or equal to 1. The OutsideLabels property gets or sets a value indicating whether the data point labels appear outside the chart. The Radius property gets or sets the size of the doughnut within the chart area. The StartAngle property gets or sets the horizontal start angle for the series data points.

Below is an example of how to set the custom chart properties at run time for a 3D doughnut chart as shown in the image above.

Show To write the code in Visual Basic.NET

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("ExplodeFactor") = 0.0F
Me.ChartControl1.Series(0).Properties("HoleSize") = 0.33F
Me.ChartControl1.Series(0).Properties("OutsideLabels") = False
Me.ChartControl1.Series(0).Properties("Radius") = 2.0F
Me.ChartControl1.Series(0).Properties("StartAngle") = 50.0F

Show To write the code in C#

C# Copy Code
this.chartControl1.Series[0].Properties["ExplodeFactor"] = 0f;
this.chartControl1.Series[0].Properties["HoleSize"] = .33f;
this.chartControl1.Series[0].Properties["OutsideLabels"] = false;
this.chartControl1.Series[0].Properties["StartAngle"] = 50f;

Show Funnel Chart

A 3D funnel chart shows how the percentage of each data item contributes to the whole, allowing the data to be viewed in a 3D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data points | 1
Number of Series | 1 or more
Marker Support | Series or Data Point

Custom Properties

The BaseStyle property gets or sets a circular or square base drawing style for the 3D funnel chart.
The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding funnel section. The default value is a black one-point line.
The FunnelStyle property gets or sets the Y value for the series points to the width or height of the funnel. The default value is YIsHeight.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the funnel chart. The height is measured in relative coordinates.
The NeckHeight property gets or sets the neck height for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The NeckWidth property gets or sets the neck width for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the funnel chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the funnel. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the funnel chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.
The RotationAngle property gets or sets the left-to-right rotation angle of the funnel. The valid values range from -180 to 180 degrees. This property is only effective with the Projection property set to Orthogonal and the BaseStyle property set to SquareBase.

Below is an example of how to set the custom chart properties at run time for a 3D funnel chart.

Show To write the code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BaseStyle") = BaseStyle.SquareBase
    .Properties("CalloutLine") = New Line(Color.Black, 2, LineStyle.Dot)
    .Properties("FunnelStyle") = FunnelStyle.YIsWidth
    .Properties("MinPointHeight") = 10.0F
    .Properties("NeckWidth") = 20.0F
    .Properties("NeckHeight") = 5.0F
    .Properties("OutsideLabels") = True
    .Properties("OutsideLabelsPlacement") = LabelsPlacement.Right
    .Properties("PointGapPct") = 3.0F
    .Properties("RotationAngle") = 3.0F
End With

Show To write the code in C#

C# Copy Code
using GrapeCity.ActiveReports.Chart;
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BaseStyle"] = BaseStyle.SquareBase;
this.ChartControl1.Series[0].Properties["CalloutLine"] = new Line(Color.Black, 2, LineStyle.Dot);
this.ChartControl1.Series[0].Properties["FunnelStyle"] = FunnelStyle.YIsWidth;
this.ChartControl1.Series[0].Properties["MinPointHeight"] = 10f;
this.ChartControl1.Series[0].Properties["NeckWidth"] = 20f;
this.ChartControl1.Series[0].Properties["NeckHeight"] = 5f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = true;
this.ChartControl1.Series[0].Properties["OutsideLabelsPlacement"] = LabelsPlacement.Right;
this.ChartControl1.Series[0].Properties["PointGapPct"] = 3f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 3f;

Show Pyramid Chart

A 3D Pyramid chart shows how the percentage of each data item contributes to the whole, allowing the data to be viewed in a 3D format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties

The BaseStyle property gets or sets a circular or square base drawing style for the 3D pyramid chart.
The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding pyramid section. The default value is a black one-point line.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the pyramid chart. The height is measured in relative coordinates.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the pyramid chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the pyramid. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the pyramid chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.
The RotationAngle property gets or sets the left-to-right rotation angle of the pyramid. The valid values range from -180 to 180 degrees. This property is only effective with the Projection property set to Orthogonal and the BaseStyle property set to SquareBase.

Below is an example of how to set the custom chart properties at run time for a Pyramid chart.

Show To write the code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BaseStyle") = BaseStyle.SquareBase
    .Properties("MinPointHeight") = 10.0F
    .Properties("OutsideLabels") = True
    .Properties("OutsideLabelsPlacement") = LabelsPlacement.Right
    .Properties("PointGapPct") = 3.0F
    .Properties("RotationAngle") = 3.0F
End With

Show To write the code in C#

C# Copy Code
using GrapeCity.ActiveReports.Chart;
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BaseStyle"] = BaseStyle.SquareBase;
this.ChartControl1.Series[0].Properties["MinPointHeight"] = 10f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = true;
this.ChartControl1.Series[0].Properties["OutsideLabelsPlacement"] = LabelsPlacement.Right;
this.ChartControl1.Series[0].Properties["PointGapPct"] = 3f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 3f;

Show Pie Chart

This type of chart displays the contribution of each value to a total.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties |

Show Ring Chart

This chart type uses rings (inner and outer) to represent data.

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties |

See Also

Pie and Doughnut Charts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Financial Chart

Financial Chart
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Financial Chart

Glossary Item Box

Financial charts are those which are specific to representing data related to financial activities. The Chart data region can draw a number of financial chart types:

  • Candle, High Low, High Low Open Close
  • Kagi, Renko
  • Point and Figure, Three Line Break
2D Financial Charts
This section describes 2D charts that fall under the Financial Chart category.
3D Financial Charts
This section describes 3D charts that fall under the Financial Chart category.

See Also

Charts
Chart Types (Section Reports)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


2D Financial Charts

2D Financial Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Financial Chart > 2D Financial Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Financial Chart category.

Show Candle Stick Chart

A candle chart displays stock information, using High, Low, Open and Close values. The size of the wick line is determined by the High and Low values, while the size of the bar is determined by the Open and Close values. The bar is displayed using different colors, depending on whether the price of the stock has gone up or down.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Chart Information
ChartType | Financial2D
Number of Y values per data point | 4 (The first value is the high figure, the second is the low figure, the third is the opening figure, and the fourth is the closing figure.)
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the first Y value as the default value.
Custom Properties | The BodyDownswingBackdrop property gets or sets the backdrop information used to fill the rectangle for data points in which the closing figure is lower than the opening figure. The BodyUpswingBackdrop property gets or sets the backdrop information used to fill the rectangle for data points in which the closing figure is higher than the opening figure. The BodyWidth property gets or sets the width of the rectangle used to show upswing or downswing. The WickLine property gets or sets the line information for the wick line.

Below is an example of how to set the custom chart properties at run time for a candle chart as shown in the image above.

Show To write the code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
.Properties("BodyDownswingBackdrop") = New Chart.Graphics.Backdrop(Color.FromArgb(255, 192, 255))
.Properties("BodyUpswingBackdrop") = New Chart.Graphics.Backdrop(Color.FromArgb(192, 192, 255))
.Properties("WickLine") = New Chart.Graphics.Line(Color.Indigo)
.Properties("BodyWidth") = 7.0F
End With

Show To write the code in C#

C# code Copy Code
Using GrapeCity.ActiveReports.Chart.Graphics
C# Code Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"]= new Chart.Graphics.Backdrop
(Color.FromArgb(255, 192, 255));
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Chart.Graphics.Backdrop
(Color.FromArgb(192, 192, 255));
this.ChartControl1.Series(0).Properties("WickLine") = new Chart.Graphics.Line(Color.Indigo);
this.ChartControl1.Series[0].Properties["BodyWidth"] = 7f;

Show HiLo Chart

A HiLo chart displays stock information using High and Low, or Open and Close, values. The length of the HiLo line is determined by the High and Low values, or the Open and Close values.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Chart Information
ChartType | Financial2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the first Y value as the default value.
Custom Properties | The HiloLine property gets or sets the line information for the HiLo line.

Below is an example of how to set the custom chart properties at run time for a HiLo chart as shown in the image above.

Show To write the code in Visual Basic.NET

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("HiloLine") = New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.DeepSkyBlue, 4)

Show To write the code in C#

C# Copy Code
this.ChartControl1.Series[0].Properties["HiloLine"] = new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.DeepSkyBlue, 4);

Show Point and Figure Chart

The point and figure chart uses stacked columns of X's to indicate that demand exceeds supply and columns of O's to indicate that supply exceeds demand to define pricing trends. A new X or O is added to the chart if the price moves higher or lower than the BoxSize value. A new column is added when the price reverses to the level of the BoxSize value multiplied by the ReversalAmount. The use of these values in the point and figure chart to calculate pricing trends makes this chart best suited for long-term financial analysis.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Financial2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The BoxSize property gets or sets the amount a price must change in order to create another X or O. The DownswingLine property gets or sets the style and color settings for the downswing O's. The ReversalAmount property gets or sets the amount that a price must shift in order for a new column to be added. The UpswingLine property gets or sets the style and color settings for the upswing X's.

Below is an example of how to set the custom chart properties at run time for a Point and Figure chart.

Show To write the code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.Red)
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.Blue)
    .Properties("BoxSize") = 3.0F
End With

Show To write the code in C#

C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.Red);
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.Blue);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Show Renko Chart

The Renko chart uses bricks of uniform size to chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. The change in box color and direction signifies a trend reversal.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Financial2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing bricks. The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing bricks. The BoxSize property gets or sets the amount a price must change in order to create another brick.

Below is an example of how to set the custom chart properties at run time for a Renko chart.

Show To write the code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.BlueViolet)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Navy)
    .Properties("BoxSize") = 3.0F
End With

Show To write the code in C#

CS Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
CS Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.BlueViolet);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Navy);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Show Kagi Chart

A Kagi chart displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Financial2D
Number of Y values per data point | 1
Number of Series | 1
Marker Support | Series or Data Points
Custom Properties | The DownswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price decrease. The ReversalAmount property gets or sets the amount that a price must shift in order for the Kagi line to change direction. The UpswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price increase.

Below is an example of how to set the custom chart properties at run time for a Kagi chart.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Blue)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.DarkRed)
    .Properties("ReversalAmount") = "25"
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.DarkBlue)
    .Properties("Width") = 50.0F
End With

Show To write code in C#

C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Blue);
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.DarkRed);
this.ChartControl1.Series[0].Properties["ReversalAmount"] = "25";
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.DarkBlue);
this.ChartControl1.Series[0].Properties["Width"] = 50f;

Show Stock Chart

In a stock chart, series are displayed as a set of lines with markers for high, low, close, and open values. Values are represented by the height of the marker as measured by the y-axis. Category labels are displayed on the x-axis.

Stock chart is a visual representation of data related to the stock market. It may be used to represent data like stock prices and stock activities.

Chart Information
ChartType | Financial2D
Number of Y values per data point | 4
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The CloseLine property gets or sets the information for the close value line. The HiLoLine property gets or sets the line information for the HiLo line. The OpenLine property property gets or sets the information for the open value line. The TickLen property property gets or sets the tick length for the close value and open value lines.

Show Stock Close Only Chart

A Stock chart is a visual representation of data related to the stock market. This type of chart requires four series of values in the correct order (open, high, low, and then close).

Chart Information
ChartType | Financial2D
Number of Y values per data point | 4
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The CloseLine property gets or sets the information for the close value line. The HiLoLine property gets or sets the line information for the HiLo line. The OpenLine property property gets or sets the information for the open value line. The TickLen property property gets or sets the tick length for the close value and open value lines.

Show Stock Open Only Chart

A Stock chart is a visual representation of data related to the stock market. This type of chart requires four series of values in the correct order (open, high, low, and then close), low, and then close).

Chart Information
ChartType | Financial2D
Number of Y values per data point | 4
Number of Series | 3
Marker Support | Series or Data Point
Custom Properties | The CloseLine property gets or sets the information for the close value line. The HiLoLine property gets or sets the line information for the HiLo line. The OpenLine property property gets or sets the information for the open value line. The TickLen property property gets or sets the tick length for the close value and open value lines.

Show Three Line Break Chart

A Three Line Break chart uses vertical boxes or lines to illustrate price changes of an asset or market. Movements are depicted with box colors and styles; movements that continue the trend of the previous box paint similarly while movements that trend oppositely are indicated with a different color and/or style. The opposite trend is only drawn if its value exceeds the extreme value of the previous three boxes or lines. The below Three Line Break depicts upward pricing movement with black boxes and downward pricing movement with red boxes.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Financial2D
Number of Y values per data point | 1
Number of Series | 1
Marker Support | Series or Data Points
Chart-Specific Properties | The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing boxes. The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing boxes. The NewLineBreak property gets or sets the number of previous boxes/lines that must be compared before a new box/line is drawn. The default value is 3.

Below is an example of how to set the custom chart properties at run time for a Three Line Break chart.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Black)
    .Properties("NewLineBreak") = 3
End With

Show To write code in C#

C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Black);
this.ChartControl1.Series[0].Properties["NewLineBreak"] = 3;

See Also

Financial Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


3D Financial Charts

3D Financial Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Financial Chart > 3D Financial Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Financial Chart category.

Show Kagi Chart

A Kagi chart displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).

Chart Information

ChartType

 Financial3D

Number of Y values per data point

 1

Number of Series

 1

Marker Support

 Series or Data Points

Custom Properties

 The BodyDownswingBackdrop property gets or sets the style and color settings for the three-dimensional side view of downswing Kagi lines. This property is only available with the Kagi 3D chart type, and is only effective when the Width property is set to a value higher than 25.
The BodyUpswingBackdrop property gets or sets the style and color settings for the three-dimensional side view of upswing Kagi lines. This property is only available with the Kagi 3D chart type, and is only effective when the Width property is set to a value higher than 25.
The DownswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price decrease.
The ReversalAmount property gets or sets the amount that a price must shift in order for the Kagi line to change direction.
The UpswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price increase.
The Width property gets or sets the width of the three-dimensional side view of the Kagi lines.This property is only available with the Kagi 3D chart type, and must be set higher than its default value of 1 in order to display body downswing and upswing backdrops.

Below is an example of how to set the custom chart properties at run time for a Kagi chart.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Blue)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.DarkRed)
    .Properties("ReversalAmount") = "25"
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.DarkBlue)
    .Properties("Width") = 50.0F
End With

Show To write code in C#

C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Blue);
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.DarkRed);
this.ChartControl1.Series[0].Properties["ReversalAmount"] = "25";
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.DarkBlue);
this.ChartControl1.Series[0].Properties["Width"] = 50f;

Show Renko Chart

The Renko chart uses bricks of uniform size to chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. The change in box color and direction signifies a trend reversal.

Chart Information
ChartType | Financial3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing bricks. BodyDownswingBackdrop Gets or sets the style and color settings for the downswing bricks. The BoxSize property gets or sets the amount a price must change in order to create another brick.

Below is an example of how to set the custom chart properties at run time for a Renko chart.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Blue)
    .Properties("BoxSize") = 3.0F
End With

Show To write code in C#

CS Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Blue);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Show Three Line Break Chart

Three line break 3D chart is a chart rendered in 3D.

Chart Information
ChartType | Financial3D
Number of Y values per data point | 1
Number of Series | 1
Marker Support | Series or Data Points
Custom Properties | The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing boxes. The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing boxes. The NewLineBreak property gets or sets the number of previous boxes/lines that must be compared before a new box/line is drawn. The default value is 3.

See Also

Financial Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Point and Bubble Charts

Point and Bubble Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Point and Bubble Charts

Glossary Item Box

Point or Bubble charts represent data by means of points and bubbles.

The ActiveReports Chart control can draw a number of point/bubble chart types:

  • Bubble, BubbleXY, PlotXY and Scatter.
2D Point/Bubble Charts
This section describes 2D charts that fall under the Point/Bubble Chart category.

See Also

Charts
Chart Types (Section Reports)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


2D Point/Bubble Charts

2D Point/Bubble Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Types (Section Reports) > Point and Bubble Charts > 2D Point/Bubble Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Point/Bubble Chart category.

Show Bubble Chart

The Bubble chart is an XY chart in which bubbles represent data points. The first Y value is used to plot the bubble along the Y axis, and the second Y value is used to set the size of the bubble. The bubble shape can be changed using the series Shape property.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the second Y value as the default value.
Custom Properties | The MaxSizeFactor property gets or sets the maximum size of the bubble radius. Values must be less than or equal to 1. Default is .25. The MaxValue property gets or sets the bubble size that is used as the maximum. The MinValue property gets or sets the bubble size that is used as the minimum. The Shape property gets or sets the shape of the bubbles. Uses or returns a valid MarkerStyle enumeration value.

Below is an example of setting the custom chart properties at run time for a bubble chart as shown in the image above.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("MaxSizeFactor") = 0.25F
Me.ChartControl1.Series(0).Properties("MaxValue") = 55.0R
Me.ChartControl1.Series(0).Properties("MinValue") = 5.0R
Me.ChartControl1.Series(0).Properties("Shape") = GrapeCity.ActiveReports.Chart.MarkerStyle.Circle

Show To write code in C#

C# Copy Code
this.ChartControl1.Series[0].Properties["MaxSizeFactor"] = .25f;
this.ChartControl1.Series[0].Properties["MaxValue"] = 55D;
this.ChartControl1.Series[0].Properties["MinValue"] = 5D;
this.ChartControl1.Series[0].Properties["Shape"] = GrapeCity.ActiveReports.Chart.MarkerStyle.Circle;

Show Bubble XY Chart

The Bubble XY chart is an XY chart in which bubbles represent data points. The BubbleXY uses a numerical X axis and plots the x values and first set of Y values on the chart. The second Y value is used to set the size of the bubble.

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the second Y value as the default value.
Custom Properties | The MaxSizeFactor gets or sets the maximum size of the bubble radius. Values must be less than or equal to 1. Default is .25. The MaxValue property gets or sets the bubble size that is used as the maximum. The MinValue property gets or sets the bubble size that is used as the minimum. The Shape property gets or sets the shape of the bubbles. Uses or returns a valid MarkerStyle enumeration value.

Below is an example of setting the custom chart properties at run time for a bubble XY chart as shown in the image above.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Me.ChartControl1.Series(0).Properties("MaxSizeFactor") = 0.25F
Me.ChartControl1.Series(0).Properties("MaxValue") = 50.0R
Me.ChartControl1.Series(0).Properties("MinValue") = 0.0R
Me.ChartControl1.Series(0).Properties("Shape") = GrapeCity.ActiveReports.Chart.MarkerStyle.InvTriangle

Show To write code in C#

C# Copy Code
this.ChartControl1.Series[0].Properties["MaxSizeFactor"] = .25f;
this.ChartControl1.Series[0].Properties["MinValue"] = 0D;
this.ChartControl1.Series[0].Properties["MaxValue"] = 50D;
this.ChartControl1.Series[0].Properties["Shape"] = GrapeCity.ActiveReports.Chart.MarkerStyle.InvTriangle;

Show Plot XY Chart

A plot XY chart shows the relationships between numeric values in two or more series sets of XY values.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

Show Scatter Chart

Use a scatter chart to compare values across categories.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

See Also

Point and Bubble Charts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Series

Chart Series
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Series

Glossary Item Box

Show All Show All
Hide All Hide All

A chart series is the key to showing data in a chart. All data is plotted in a chart as a series and all charts contain at least one series. The bars in the image below depict two series in a simple bar chart.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Each series is made up of a set of data points consisting of an X value that determines where on the X axis the data is plotted, and one or more Y values. Most charts use one Y value but a few charts such as the Bubble, BubbleXY, and the financial charts take multiple Y values.

When you bind data to a series, the X value is bound using the ValueMembersX property on the Series object, and the Y value is bound using the ValueMembersY property.

The Series object also contains properties for each individual series, including chart type, custom chart properties, annotations, containing chart area, and more. Each chart type in the ActiveReports Chart control contains series-specific properties that apply to it. You can set the chart type and these series-specific properties in the Series Collection Editor dialog, which opens when you click the ellipsis button next to the Series (Collection) property in the Visual Studio Properties window.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

You can manipulate each data point in the DataPoint Collection dialog box. You can access the dialog from the Series Collection Editor by clicking the ellipsis button next to the Points (Collection) property.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

When you set a property on the Series object, it is applied to all data point objects in the series unless a different value for the property is set on a specific data point. In that case, the data point property setting overrides the series property setting for that particular data point. Note that for charts bound to a data source, you do not have access to the DataPoint collection in the dialog.

If you specify the value for any of the custom properties, this value is not cleared when you change the ChartType. Although this will show properties that do not apply to certain ChartTypes, it has the advantage of keeping your settings in case you accidentally change the ChartType.

Setting chart and series-specific properties at run time

To set custom properties for a chart on the series programmatically, reference the series by name or index and use the string Properties attribute name you wish to set.

The following code samples set the shape for bubbles on a bubble chart to diamond.

Show To write code in Visual Basic.Net

Visual Basic.NET code. Paste INSIDE the section Format event. 		Copy Code
Me.ChartControl1.Series(0).Properties("Shape") = Chart.MarkerStyle.Diamond

Show To write the code in C#

C# code. Paste INSIDE the section Format event. Copy Code
this.chartControl1.Series[0].Properties["Shape"] = GrapeCity.ActiveReports.Chart.MarkerStyle.Diamond;

To set custom properties for a chart on the data points object programmatically, reference the series by name or index, reference the data point by index, and use the string Properties attribute name you wish to set.

The following code samples set the explode factor on a doughnut chart for the second point in the series.

Show To write code in Visual Basic.Net

Visual Basic.NET code. Paste INSIDE the section Format event. Copy Code
Me.ChartControl1.Series(0).Points(1).Properties("ExplodeFactor") = 0.5F

Show To write the code in C#

C# code. Paste INSIDE the section Format event. Copy Code
this.chartControl1.Series[0].Points[1].Properties["ExplodeFactor"] = .5f;

See Also

Concepts
Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Appearance

Chart Appearance
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance

Glossary Item Box

The following section explains in what ways you can modify the chart appearance.

Chart Effects
This section describes the visual effects that are available for the Chart data region.
Chart Control Items
This section describes the chart elements that you can use to customize the Chart data region.
Chart Axes and Walls
This section provides basic information about the axes and walls in the Chart data region.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Effects

Chart Effects
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Effects

Glossary Item Box

These topics introduce some basic information on the visual effects of the Chart data region.

Colors
Learn about the different ways you can change the color and gradients to enhance the visual appearance of a chart.
3D Effect
This section describes 3D effects that you can use to customize the chart.
Alpha Blending
This section explains about alpha blending property of the chart.
Lightning
Learn about directional light ratio, line type and line source of the chart.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Colors

Colors
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Effects > Colors

Glossary Item Box

Show All Show All
Hide All Hide All

In the Chart data region, colors can be used in different ways to enhance the chart's appearance, distinguish different series, point out or draw attention to data information such as averages, and more.

Color Palettes

The Chart data region includes several pre-defined color palettes that can be used to automatically set the colors for data values in a series. The pre-defined palettes are as follows.

  • Default The default palette.
  • Cascade A cascade of eight cool colors ranging from deep teal down through pale orchid.
  • Springtime The colors of spring, in deep green, two vivid colors and five pastels.
  • Iceberg A range of the soft blues and greys found in an iceberg.
  • Confetti A sprinkling of bright and pastel colors.
  • Greens A palette of greens.
  • Berries The colors of berries.
  • Autumn A quiet palette of autumn colors.
  • Murphy A range of the soft blues and greens.

These enumerated values are accessed through the Series class with code like the following.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Me.ChartControl1.Series(0).ColorPalette = Chart.ColorPalette.Iceberg

Show To write code in C#

C# Copy Code
this.ChartControl1.Series[0].ColorPalette = GrapeCity.ActiveReports.Chart.ColorPalette.Iceberg;

Gradients

Gradients can be used in object backdrops to enhance the visual appearance of various chart items. Gradients can be used in the following chart sections:

  • Chart
  • Chart area
  • Wall
  • Title
  • Legend
  • Legend item (for custom legend items)
  • WallRange
  • Series
  • Data point
  • Marker
  • Marker Label
  • Annotation TextBar

You can set gradients for a backdrop at run time by creating a BackdropItem, setting its Style property to Gradient, setting the GradientType, and setting the two colors to use for the gradient as shown in the following example.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic Copy Code
Dim bItem As New GrapeCity.ActiveReports.Chart.BackdropItem
bItem.Style = Chart.Graphics.BackdropStyle.Gradient
bItem.Gradient = Chart.Graphics.GradientType.Vertical
bItem.Color = Color.Purple
bItem.Color2 = Color.White
Me.ChartControl1.Backdrop = bItem

Show To write code in C#

C# Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C# Copy Code
GrapeCity.ActiveReports.Chart.BackdropItem bItem = new GrapeCity.ActiveReports.Chart.BackdropItem();
bItem.Style = GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Gradient;
bItem.Gradient = GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical;
bItem.Color = System.Drawing.Color.Purple;
bItem.Color2 = System.Drawing.Color.White;
this.ChartControl1.Backdrop = bItem;

See Also

Chart Effects

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


3D Effects

3D Effects
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Effects > 3D Effects

Glossary Item Box

Using the projection and viewpoint settings, you can display your 3D chart at any angle to provide the desired view or call attention to a specific chart section.

Projection

Determine the projection for a 3D chart using the following properties.

Property Name | Description
ZDepthRatio | The Z depth ratio is the level of depth the Z axis has in the chart. The ratio of the length specified in the X-axis of Z-axis Values range from 0 (for a 2D chart) to 1.0. This property is useful in adjusting the size of 3D chart.
ProjectionDX | The origin position of the Z axis in relation to the X axis. This property is valid only when the ProjectionType is Orthogonal.
ProjectionDY | The origin position of the Z axis in relation to the Y axis. This property is valid only when the ProjectionType is Orthogonal.
ProjectionType | The type of projection used for the chart. In order to show charts three dimensionally, the ProjectionType in the ChartArea Collection editor must be set to Orthogonal. To access this dialog box, click the ellipsis button next to the ChartAreas (Collection) property in the Properties Window.
HorizontalRotation | The HorizontalRotation property allows you to set the degree (-90° to 90°) of horizontal rotation from which the chart is seen.
VerticalRotation | The VerticalRotation property allows you to set the degree (-90° to 90°) of vertical rotation from which the chart is seen.

See Also

Chart Effects

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Alpha Blending

Alpha Blending
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Effects > Alpha Blending

Glossary Item Box

Show All Show All
Hide All Hide All

The Backdrop class in the Chart control has an Alpha property which employs GDI+, and is used to set the transparency level of each object's backdrop. GDI+ uses 32 bits overall and 8 bits per alpha, red, green, and blue channels respectively to indicate the transparency and color of an object. Like a color channel's levels of color, the alpha channel represents 256 levels of transparency.

The default value of the Alpha property is 255, which represents a fully opaque color. For a fully transparent color, set this value to 0. To blend the color of the object's backdrop with the background color, use a setting between 0 and 255.

In the Chart control, you can use the Color.FromArgb method provided by standard Color constructor of .NET Framework class library to set the alpha and color levels for a particular chart element.

The following example shows how you can use the method to set the alpha and color values for the chart backdrop.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Me.ChartControl1.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem(Color.FromArgb(100, 0, 11, 220))

Show To write code in C#

C# Copy Code
this.ChartControl1.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem(System.Drawing.Color.FromArgb(100, 0, 11, 220));

Changing the alpha level of a chart element reveals other items that are beneath the object. Because you can set the alpha level for any chart element that supports color, you can also create custom effects for any chart. For example, you can use alpha blending to combine background images with a semi-transparent chart backdrop to create a watermark look.

See Also

Chart Effects

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Lighting

Lighting
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Effects > Lighting

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control allows you to completely customize lighting options for 3D charts.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Directional Light Ratio

Using the DirectionalLightRatio property, you can control the directional or ambient intensity ratio.

Light Type

By setting the Type property to one of the enumerated LightType values, you can control the type of lighting used in the chart. The settings are as follows:

  • Ambient：An ambient light source is used. It is equal to DirectionalLightRatio = 0.
  • Directional：An infinite directional light source (like the sun, the light source having the same angle of incidence from each side) is used.
  • Point：A point light source (light is generated from one point and light source having different angle of incidence according to the sides) is used.

Light Source

You can also set the Source property to a Point3d object, which controls the location of the light source.

See Also

Chart Appearance

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Control Items

Chart Control Items
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Control Items

Glossary Item Box

The following topics review the chart control items that you can use to customize your chart.

Chart Annotation
This topic explains how you can add annotations to your chart.
Chart Titles and Footers
This topic explains how you can add a title or a footer to your chart.
Legends
This topic explains how you can add legends to your chart.
Markers
This topic explains how to create markers for showing specific data series values.
Label Symbols
This topic describes how to set format strings to display data in a legend, a marker or a symbol to be used as placeholders.
Constant Lines and Stripes
This topic explains how to add constant lines and stripes to your chart.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Annotations

Chart Annotations
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Control Items > Chart Annotations

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control offers a built-in annotation tool to allow you to include floating text bars or images in your charts or call attention to specific items or values in your charts using the line and text bar controls included in the Annotations Collection Editor. You can find the Annotations Collection Editor under the Series properties of the Chart Designer.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The following properties are important while setting up annotations for your chart:

  • StartPoint Sets the starting point (X and Y axis values) for an annotation line.
  • EndPoint Sets the end point (X and Y axis values) for an annotation line.
  • AnchorPlacement Sets the position of the anchor point for the text bar on the chart surface.
  • AnchorPoint Sets the point (X and Y axis values) where the text bar will be anchored based on the anchor placement selected.

The following code demonstrates creating annotation lines and annotation text, setting their properties, and adding them to the series annotations collection at run time.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
' create the annotation lines and text bar.
Dim aLine1 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
Dim aLine2 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
Dim aText1 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar
Dim aText2 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar

' set the properties for each line and text bar.
With aLine1
        .EndPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 30.0F)
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .StartPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 15.0F)
End With
With aLine2
        .EndPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.6F, 47.0F)
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .StartPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(3.6F, 45.0F)
End With
With aText1
        .AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Bottom
        .AnchorPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 31.0F)
        .Height = 25.0F
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .Text = "Min Value"
        .Width = 100.0F
End With
With aText2
        .AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Left
        .AnchorPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.7F, 47.0F)
        .Height = 25.0F
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .Text = "Max Value"
        .Width = 100.0F
End With

' add the annotation lines and text bars to the annotations collection for the series
Me.ChartControl1.Series(0).Annotations.AddRange(New GrapeCity.ActiveReports.Chart.Annotations.Annotation() {aLine1, aLine2, aText1, aText2})

Show To write code in C#

C# Copy Code
// create the annotation lines and text bar.
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine aLine1 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine();
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine aLine2 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine();
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar aText1 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar();
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar aText2 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar();

// set the properties for each line and text bar.
aLine1.EndPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 30F);
aLine1.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aLine1.StartPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 15F);
aLine2.EndPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.6F, 47F);
aLine2.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aLine2.StartPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(3.6F, 45F);
aText1.AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Bottom;
aText1.AnchorPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 31F);
aText1.Height = 25F;
aText1.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aText1.Text = "Min Value";
aText1.Width = 100F;
aText2.AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Left;
aText2.AnchorPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.7F, 47F);
aText2.Height = 25F;
aText2.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aText2.Text = "Max Value";
aText2.Width = 100F;

// add the annotation lines and text bars to the annotations collection for the series
this.ChartControl1.Series[0].Annotations.AddRange(
new GrapeCity.ActiveReports.Chart.Annotations.Annotation[] {aLine1, aLine2, aText1, aText2});

See Also

Chart Control Items

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Titles and Footers

Chart Titles and Footers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Control Items > Chart Titles and Footers

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control allows you to add custom titles to your charts. The Titles collection is accessible from the Chart object. With the ability to add as many titles as needed, dock them to any side of a chart area, change all of the font properties, add borders and shadows, make the background look the way you want it, and change the location of the text, you can easily make your titles look the way you want them to look.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The following code demonstrates creating header and footer titles, setting their properties, and adding them to the titles collection at run time.

  1. In design view of the report, double-click the section where you placed your chart. This creates a Format event handling method for the section.
  2. Add code to the handler to create header and footer titles.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the section Format event. Copy Code
' create the header and footer titles
Dim tHeader As New GrapeCity.ActiveReports.Chart.Title
Dim tFooter As New GrapeCity.ActiveReports.Chart.Title

' set the properties for the header
tHeader.Alignment = Chart.Alignment.Center
tHeader.Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle)
tHeader.Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.DimGray), 3)
tHeader.DockArea = Me.ChartControl1.ChartAreas(0)
tHeader.Docking = Chart.DockType.Top
tHeader.Font = New GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White, New System.Drawing.Font("Arial", 25.0F))
tHeader.Text = "Chart Title"
tHeader.Visible = True

' set the properties for the footer
tFooter.Alignment = Chart.Alignment.Center
tFooter.Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle)
tFooter.Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Indigo), 0, System.Drawing.Color.Black)
tFooter.DockArea = Me.ChartControl1.ChartAreas(0)
tFooter.Docking = Chart.DockType.Bottom
tFooter.Font = New GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.DimGray, New System.Drawing.Font("Arial", 12.0F, System.Drawing.FontStyle.Bold))
tFooter.Text = "Chart Footer"
tFooter.Visible = True

' add the header and footer titles to the titles collection
Me.ChartControl1.Titles.AddRange(New GrapeCity.ActiveReports.Chart.Title() {tHeader, tFooter})

Show To write the code in C#

C# code. Paste INSIDE the section Format event. Copy Code
// create the header and footer titles
GrapeCity.ActiveReports.Chart.Title tHeader = new GrapeCity.ActiveReports.Chart.Title();
GrapeCity.ActiveReports.Chart.Title tFooter = new GrapeCity.ActiveReports.Chart.Title();

// set the properties for the header
tHeader.Alignment = Chart.Alignment.Center;
tHeader.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle);
tHeader.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.DimGray), 3);
tHeader.DockArea = this.ChartControl1.ChartAreas[0];
tHeader.Docking = Chart.DockType.Top;
tHeader.Font = new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White, new System.Drawing.Font("Arial", 25F));
tHeader.Text = "Chart Title";
tHeader.Visible = true;

// set the properties for the footer
tFooter.Alignment = Chart.Alignment.Center;
tFooter.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle);
tFooter.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Indigo), 0, System.Drawing.Color.Black);
tFooter.DockArea = this.ChartControl1.ChartAreas[0];
tFooter.Docking = Chart.DockType.Bottom;
tFooter.Font = new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.DimGray, new System.Drawing.Font("Arial", 12F, System.Drawing.FontStyle.Bold));
tFooter.Text = "Chart Footer";
tFooter.Visible = true;

// add the header and footer titles to the titles collection
this.ChartControl1.Titles.AddRange(new GrapeCity.ActiveReports.Chart.Title[] {tHeader,tFooter});

See Also

Charts
Chart Control Items

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Legends

Legends
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Control Items > Legends

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control automatically creates a legend item for each series added to a chart at design time and sets the Legend property for each series by default. However, the legend's Visible property must be set to True for getting it displayed with the chart. The text for legend caption is taken from the Name property on the series.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Note: Each Series displayed in the Legend must have a Name. If the Name property is not set, the Series does not show up in the Legend.

The following code demonstrates how to create a legend at run time, add it to the Legends collection of the Chart object and set the legend property of the series to the new legend, resulting in the legend shown above.

Show To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event Copy Code
' create the legend and title for the legend
Dim legend1 As New GrapeCity.ActiveReports.Chart.Legend
Dim lHeader As New GrapeCity.ActiveReports.Chart.Title

' set the properties for the legend title
lHeader.Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Chart.Graphics.BackdropStyle.Transparent,
 _Color.White, Color.White, Chart.Graphics.GradientType.Vertical,
 Drawing2D.HatchStyle.DottedGrid, Nothing, _Chart.Graphics.PicturePutStyle.Stretched)
lHeader.Border = New GrapeCity.ActiveReports.Chart.Border(New Chart.Graphics.Line(Color.White, 2,
 _Chart.Graphics.LineStyle.None), 0, Color.Black)
lHeader.Font = New GrapeCity.ActiveReports.Chart.FontInfo
(Color.White, New System.Drawing.Font("Arial", 10.0F, _FontStyle.Bold))
lHeader.Text = "Series:"

' set the properties for the legend and add it to the legends collection
legend1.Alignment = GrapeCity.ActiveReports.Chart.Alignment.TopRight
legend1.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem(Chart.Graphics.BackdropStyle.Transparent,
 _Color.Gray, Color.White, Chart.Graphics.GradientType.Vertical, Drawing2D.HatchStyle.DottedGrid, Nothing,
 _Chart.Graphics.PicturePutStyle.Stretched)
legend1.Border = New GrapeCity.ActiveReports.Chart.Border(New Chart.Graphics.Line(Color.Navy, 2), _0, Color.Black)
legend1.DockArea = Me.ChartControl1.ChartAreas(0)
legend1.LabelsFont = New GrapeCity.ActiveReports.Chart.FontInfo(Color.White, New System.Drawing.Font("Arial", 9.0F))
legend1.Header = lHeader
legend1.MarginX = 5
legend1.MarginY = 5
Me.ChartControl1.Legends.Add(legend1)

' Generate legend items
Dim legenditem As New GrapeCity.ActiveReports.Chart.LegendItem
Dim legenditem2 As New GrapeCity.ActiveReports.Chart.LegendItem

' Set properties of legend item
legenditem.Text = "High Range"
legenditem2.Text = "Low Range"
legenditem.Marker.Style = Chart.MarkerStyle.None
legenditem2.Marker.Style = Chart.MarkerStyle.None
legenditem.Border.Line.Style = Chart.Graphics.LineStyle.None
legenditem2.Border.Line.Style = Chart.Graphics.LineStyle.None
legenditem.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem
(System.Drawing.Color.LightSteelBlue, Chart.Graphics.AntiAliasMode.Auto)
legenditem2.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem
(System.Drawing.Color.LightGray, Chart.Graphics.AntiAliasMode.Auto)

' Add to legend collection
legend1.LegendItems.Add(legenditem)
legend1.LegendItems.Add(legenditem2)

' Set the legend property of the series to the legend you created
Me.ChartControl1.Series(0).Legend = legend1
Me.ChartControl1.Series(1).Legend = legend1
Me.ChartControl1.Series(2).Legend = legend1

Show To write code in C#

C# code. Paste INSIDE the section Format event Copy Code
// create the legend and title for the legend
GrapeCity.ActiveReports.Chart.Legend legend1 = new GrapeCity.ActiveReports.Chart.Legend();
GrapeCity.ActiveReports.Chart.Title lHeader = new GrapeCity.ActiveReports.Chart.Title();

// set the properties for the legend title
lHeader.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop
(GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Transparent,System.Drawing.Color.White,
System.Drawing.Color.White, GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical,
System.Drawing.Drawing2D.HatchStyle.DottedGrid, null, GrapeCity.ActiveReports.Chart.Graphics.
PicturePutStyle.Stretched);

lHeader.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.White, 2, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0,
 System.Drawing.Color.Black);

lHeader.Font = new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White,
new System.Drawing.Font("Arial", 10.0F, System.Drawing.FontStyle.Bold));
lHeader.Text = "Series:";

// set the properties for the legend and add it to the legends collection.
legend1.Alignment = GrapeCity.ActiveReports.Chart.Alignment.TopRight;
legend1.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem
(GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Transparent, System.Drawing.Color.Gray,
System.Drawing.Color.White, GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical,
System.Drawing.Drawing2D.HatchStyle.DottedGrid, null, GrapeCity.ActiveReports.Chart.Graphics.
PicturePutStyle.Stretched);

legend1.Border = new GrapeCity.ActiveReports.Chart.Border
(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Navy, 2),0, System.Drawing.Color.Black);
legend1.DockArea = this.ChartControl1.ChartAreas[0];
legend1.LabelsFont = new GrapeCity.ActiveReports.Chart.FontInfo
(System.Drawing.Color.White, new System.Drawing.Font("Arial", 9F));
legend1.Header = lHeader;
legend1.MarginX = 5;
legend1.MarginY = 5;
this.ChartControl1.Legends.Add(legend1);

// Generate legend items
GrapeCity.ActiveReports.Chart.LegendItem legenditem = new GrapeCity.ActiveReports.Chart.LegendItem();
GrapeCity.ActiveReports.Chart.LegendItem legenditem2 = new GrapeCity.ActiveReports.Chart.LegendItem();

// Set properties of legend item
legenditem.Text = "High Range";
legenditem2.Text = "Low Range";
legenditem.Marker.Style = GrapeCity.ActiveReports.Chart.MarkerStyle.None;
legenditem2.Marker.Style = GrapeCity.ActiveReports.Chart.MarkerStyle.None;
legenditem.Border.Line.Style = GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None;
legenditem2.Border.Line.Style = GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None;
legenditem.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem
(System.Drawing.Color.LightSteelBlue, GrapeCity.ActiveReports.Chart.Graphics.AntiAliasMode.Auto);
legenditem2.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem
(System.Drawing.Color.LightGray, GrapeCity.ActiveReports.Chart.Graphics.AntiAliasMode.Auto);

// Add to legend collection
legend1.LegendItems.Add(legenditem);
legend1.LegendItems.Add(legenditem2);

// set the legend property of the series to the legend you created.
this.ChartControl1.Series[0].Legend = legend1;
this.ChartControl1.Series[1].Legend = legend1;
this.ChartControl1.Series[2].Legend = legend1;

See Also

Chart Control Items

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Markers

Markers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Control Items > Markers

Glossary Item Box

Show All Show All
Hide All Hide All

Use markers to show specific data series values in a chart. Markers are created by setting the Marker property of the series.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The following code demonstrates how to create a marker object at run time and assign it to the Marker property of the Series object. The results are shown in the image above.

Show To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event Copy Code
' create the marker object
Dim marker1 As New GrapeCity.ActiveReports.Chart.Marker

' set the marker properties.
marker1.Backdrop = New Chart.Graphics.Backdrop(Chart.Graphics.GradientType.Horizontal, Color.Navy, Color.Black)
marker1.Line = New Chart.Graphics.Line(Color.White)
marker1.Label = New Chart.LabelInfo(New Chart.Graphics.Line(Color.Transparent, 0, Chart.Graphics.LineStyle.None),
 New Chart.Graphics.Backdrop(Chart.Graphics.BackdropStyle.Transparent, Color.White, Color.White,
 _ Chart.Graphics.GradientType.Vertical, System.Drawing.Drawing2D.HatchStyle.DottedGrid, Nothing,
 _Chart.Graphics.PicturePutStyle.Stretched),
 New Chart.FontInfo(Color.White, New Font("Arial", 8.0F)), "{Value}", Chart.Alignment.Center)
marker1.Size = 24
marker1.Style = Chart.MarkerStyle.Diamond

' assign the marker to the series Marker property
Me.ChartControl1.Series(0).Marker = marker1

Show To write code in C#

C# code. Paste INSIDE the section Format event Copy Code
// create the marker object
GrapeCity.ActiveReports.Chart.Marker marker1 = new GrapeCity.ActiveReports.Chart.Marker();

// set the marker properties
marker1.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(GrapeCity.ActiveReports.Chart.Graphics.GradientType.Horizontal,
 System.Drawing.Color.Navy, System.Drawing.Color.Black);
marker1.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.White);
marker1.Label = new GrapeCity.ActiveReports.Chart.LabelInfo(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Transparent,
 System.Drawing.Color.White, System.Drawing.Color.White, GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical,
System.Drawing.Drawing2D.HatchStyle.DottedGrid, null, GrapeCity.ActiveReports.Chart.Graphics.PicturePutStyle.Stretched),
 new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White, new System.Drawing.Font("Arial", 8F)),
 "{Value}", GrapeCity.ActiveReports.Chart.Alignment.Center);
marker1.Size = 24;
marker1.Style = GrapeCity.ActiveReports.Chart.MarkerStyle.Diamond;

// assign the marker to the series Marker property
this.ChartControl1.Series[0].Marker = marker1;

See Also

Chart Control Items

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Label Symbols

Label Symbols
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Control Items > Label Symbols

Glossary Item Box

Show All Show All
Hide All Hide All

You can use Labels in Chart markers or legends.

By default, marker labels display Y value of data points, whereas legend labels display series name or data name.

Setting Strings

You can change a string (format string) displayed in a marker or legend label.

Show To change a string in a marker label

  1. Display the Series collection editor of properties window.
  2. Select the series that sets marker. (By default the first series (Series1) gets selected.
  3. Expand the Properties property.
  4. Expand the Marker property.
  5. Expand the Label property.
  6. Set the string to display in the Format property.

Show To change a string in a legend label

  1. Display the Series collection editor of properties window.
  2. Set the string you want to set in legend label using the LegendText property.

When the LegendItemMode property of Series is set to Series, series are displayed in legend. Data point will be displayed when set to Point. By default, in each graph the common setting will get displayed. For example, in case of bar chart it is series and in case of pie chart it is data point that gets displayed in legends.

Symbols

It is possible to easily display constant strings by simply performing the above mentioned settings. To display data, you need to embed the section (placeholder) that displays the value within format string at run time.

A placeholder is a particular symbol enclosed within brackets {}.

The following symbols can be used. The sections enclosed within {} are changed by values.

Value

Data Value（Y value）

Pct

Percentage within series

PPct

Percentage having 100% as sum of multiple series for data points.

Name

X value of data

Index

Index of data point

Total

Total number of series

PTotal

Total number of multiple series for data points

When displaying numeric value, it is possible to set format specifying string similar to System.String.Format method used when displaying numeric values. For example, when format string is {Value}, numeric value is displayed in default format but when ":" (colon) format specifying string is added after Value, it is possible to insert comma or specify decimal place digits.

For example, the format string for "inserting comma in numeric value and displaying 2 digits after decimal place" would be as follows.

{Value:#,##0.00}

Please refer to the technical information posted on Microsoft site for details on format specifying string after continued numeric value after comma.

  • [Format Function]
  • [User defined numeric value format (Format function)]

Sample Image

The following image displays a bar chart with the following values.

X Value | abc | def | ghi
Y value of series 1（Red） | 1 | 2 | 3
Y value of series 2（green） | 4 | 3 | 2

String displayed below the image is a string set in Label.Format property of marker.

Value={Value}

Pct={Pct:0.0}

PPct={PPct:0.0}

Name={Name}

Total={Total}

PTotal={PTotal}

{Name}:{Value}

In case you wish to add a line break in between, as it is not possible to add a line break from Series collection editor, the following format string needs to be set at run time.

Show To write code in Visual Basic.NET

Visual Basic Copy Code
Private Sub rptLabelSymbol4_ReportStart(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart

Dim m As GrapeCity.ActiveReports.Chart.Marker
m = CType(Me.ChartControl1.Series(0).Properties("Marker"), GrapeCity.ActiveReports.Chart.Marker)
m.Label.Format = "{Name}" & vbCrLf & "{Value}"
End Sub

Show To write code in C#

C# Copy Code
private void NewActiveReport1_ReportStart(object sender, EventArgs e)
{
GrapeCity.ActiveReports.Chart.Marker m;
m = (GrapeCity.ActiveReports.Chart.Marker)
this.ChartControl1.Series[0].Properties["Marker"];
m.Label.Format = "{Name}\n{Value}";
}

Specific symbols

The specific symbols that are used according to the chart type.

Bubble Charts

Value

Y2 value

Value0

Y value

Value1

Y2value

Bubble XY Chart

Value0

X value

Value1

Y value

Value2

Y2 value

Candle or Hilo Chart

For a Candle chart or HiLo chart, symbols are not enabled for legend or marker labels.

See Also

Chart Control Items

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Constant Lines and Stripes

Constant Lines and Stripes
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Control Items > Constant Lines and Stripes

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control supports constant lines and stripes through the use of the WallRanges collection. It allows you to display horizontal or vertical lines or stripes in a chart to highlight certain areas. For example, you could draw a stripe in a chart to draw attention to a high level in the data or draw a line to show the average value of the data presented.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: The Chart control does not aggregate average values. Please aggregate the average values beforehand and then render the line.

Important properties

  • StartValue Sets the start value on the primary axis for the wall range.
  • EndValue Sets the end value on the primary axis for the wall range.
  • PrimaryAxis Sets the axis on which the wall range appears.

The following code demonstrates how to create wall ranges, set their properties, and assign them to a chart area at run time. The results are shown in the image above.

Show To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event Copy Code
' Create the WallRange objects
Dim wallRange1 As New GrapeCity.ActiveReports.Chart.WallRange
Dim wallRange2 As New GrapeCity.ActiveReports.Chart.WallRange
Dim wallRange3 As New GrapeCity.ActiveReports.Chart.WallRange

' Set WallRange property
With wallRange1
    .Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.White)
    .Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0, Color.Black)
    .EndValue = 40
    .PrimaryAxis = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisY"), GrapeCity.ActiveReports.Chart.Axis)))
    .StartValue = 30
End With
With wallRange2
    .Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.Lime)
    .Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0, Color.Black)
    .EndValue = 34
    .PrimaryAxis = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisY"), GrapeCity.ActiveReports.Chart.Axis)))
    .StartValue = 33
End With
With wallRange3
    .Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.DarkGreen, CType(150, Byte))
    .Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0, Color.Black)
    .EndValue = 40
    .PrimaryAxis = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisZ"), GrapeCity.ActiveReports.Chart.Axis)))
    .StartValue = 20
End With

' Add the WallRange to the chart area and set wall and Z axis properties to show lines.
With ChartControl1.ChartAreas(0)
    .WallRanges.AddRange(New GrapeCity.ActiveReports.Chart.WallRange() {wallRange1, wallRange2, wallRange3})
    .WallXY.Backdrop.Alpha = 100
    .WallXZ.Backdrop.Alpha = 100
    .WallYZ.Backdrop.Alpha = 100
    .Axes(4).MajorTick.Step = 20
    .Axes(4).Max = 60
    .Axes(4).Min = 0
    .Axes(4).Visible = True
End With

Show To write code in C#

C# code. Paste INSIDE the section Format event Copy Code
// Create the WallRange objects
GrapeCity.ActiveReports.Chart.WallRange wallRange1 = new GrapeCity.ActiveReports.Chart.WallRange();
GrapeCity.ActiveReports.Chart.WallRange wallRange2 = new GrapeCity.ActiveReports.Chart.WallRange();
GrapeCity.ActiveReports.Chart.WallRange wallRange3 = new GrapeCity.ActiveReports.Chart.WallRange();

// Set WallRange property
wallRange1.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.White);
wallRange1.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
0, System.Drawing.Color.Black);
wallRange1.EndValue = 40;
wallRange1.PrimaryAxis = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisY"];
wallRange1.StartValue = 30;
wallRange2.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Lime);
wallRange2.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
0, System.Drawing.Color.Black);
wallRange2.EndValue = 34;
wallRange2.PrimaryAxis = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisY"];
wallRange2.StartValue = 33;
wallRange3.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.DarkGreen);
wallRange3.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
0, System.Drawing.Color.Black);
wallRange3.EndValue = 40;
wallRange3.PrimaryAxis = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisZ"];
wallRange3.StartValue = 20;

// Add the WallRange to the chart area and set wall and Z axis properties to show lines.
this.ChartControl1.ChartAreas[0].WallRanges.AddRange(
new GrapeCity.ActiveReports.Chart.WallRange[] {wallRange1,wallRange2,wallRange3});
this.ChartControl1.ChartAreas[0].WallXY.Backdrop.Alpha = 100;
this.ChartControl1.ChartAreas[0].WallXZ.Backdrop.Alpha = 100;
this.ChartControl1.ChartAreas[0].WallYZ.Backdrop.Alpha = 100;
this.ChartControl1.ChartAreas[0].Axes[4].MajorTick.Step = 20;
this.ChartControl1.ChartAreas[0].Axes[4].Max = 60;
this.ChartControl1.ChartAreas[0].Axes[4].Min = 0;
this.ChartControl1.ChartAreas[0].Axes[4].Visible = true;

See Also

Chart Control Items

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart Axes and Walls

Chart Axes and Walls
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Axes and Walls

Glossary Item Box

This section explains about the axis and walls of the Chart data region.

Standard Axes
This section explains about standard axis properties or special characteristics.
Custom Axes
This section explains about the method to create custom axis.
Gridlines and Tick Marks
This section explains about the usage of grid lines and ticks.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Standard Axes

Standard Axes
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Axes and Walls > Standard Axes

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control provides the means to change axis settings at design time or at run time. Chart axes make it possible to view and understand the data plotted in a graph.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Axis Types

Most 2D charts contain a numerical axis (AxisY) and a categorical axis (AxisX). 3D charts include another numerical axis (AxisZ). These axes are accessible at run time from the ChartArea object and allow you to control the settings for each, including scaling, labels, and various formatting properties. For any of the scaling or labeling properties you set to show up at run time, you will need to set the Visible property of the axis to True.

Changing Axis Settings

Axis settings can be changed at design time by clicking on a Chart control and using the Properties Window or at run time in code from the chart's ChartArea object.

Scaling

For normal linear scaling on a numeric axis, set the Max and Min properties for the axis, which correspond to the numerical values in the chart's data series. Also, set the Step property of the MajorTick to show the major numerical unit values. The Step property controls where labels and tick marks are shown on the numerical axis.

Show To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event Copy Code
With Me.ChartControl1.ChartAreas(0).Axes("AxisY")
   .Max = 100
   .Min = 0
   .MajorTick.Step = 10
End With

Show To write code in C#

C# code. Paste INSIDE the section Format event Copy Code
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Max = 100;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Min = 0;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].MajorTick.Step = 10;

The Chart control also supports logarithmic scaling which allows you to show the vertical spacing between two points that corresponds to the percentage of change between those numbers. You can set your numeric axis to scale logarithmically by setting the IsLogarithmic property on the axis to True and setting the Max and Min properties of the axis.

Labeling

To show labels on an axis, you will need to specify the value for the LabelsGap property, set your LabelsFont properties, and set LabelsVisible to True. These properties can be set in the AxisBase Collection editor, which is accessed at design time by clicking the ellipsis button next to the ChartAreas (Collection) property, then the Axes (Collection) property of the ChartArea.

Tip: Labels render first, and then the chart fills in the remaining area, so be sure to make the chart large enough if you use angled labels.

You can specify strings to be used for the labels instead of numerical values on an axis by using the Labels collection property at design time or assigning a string array to the Labels property at run time. You can also specify whether you want your axis labels to appear on the outside or inside of the axis line using the LabelsInside property. By default, labels appear outside the axis line.

Format for numeric value axis label

You can use the LabelFormat property to set the label format of numeric value axis. The LabelFormat property can be referenced from the AxisBase collection editor.

For example, if you want to display a digit separator as shown in the image above, you should specify "{0:c}" in the LabelFormat property to output the "\1,213" value. When "{0:#,###円}" is specified, the output value is "1,213円". The LabelFormat property uses the same format as the ListControl.DataFormatString property of .NET Framework standard control.

Tip: To set a specific tick interval using the LabelFormat property, the SmartLabels property should be set to False.

Secondary Axes

By default, a Chart object includes secondary X and Y axes (AxisX2 and AxisY2). At design time or run time, you can specify a secondary axis to plot data against by setting all of the appropriate properties for AxisX2 or AxisY2, including the Visible property.For example, if you want to use two axes to show the same data as it appears on two different scales, you can set the primary axis to show the actual data value scale, for example, and set the secondary axis to show a logarithmic scale.

Show To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event Copy Code
' set properties for AxisY (primary axis)
With Me.ChartControl1.ChartAreas(0).Axes("AxisY")
   .Max = 25
   .Min = 0
   .MajorTick.Step = 5
End With

' set properties for AxisY2 (secondary Y axis)
With Me.ChartControl1.ChartAreas(0).Axes("AxisY2")
   .Max = 1000
   .Min = 0
   .MajorTick.Step = 200
' set the scaling for the secondary axis to logarithmic
   .AxisType = GrapeCity.ActiveReports.Chart.AxisType.Logarithmic
   .Visible = True
End With

Show To write code in C#

C# code. Paste INSIDE the section Format event Copy Code
// set properties for AxisY (primary axis)
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Max = 25;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Min = 0;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].MajorTick.Step = 5;

// set properties for AxisY2 (secondary Y axis)
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].Max = 1000;
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].Min = 0;
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].MajorTick.Step = 200;

// set the scaling for the secondary axis to logarithmic
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].AxisType = GrapeCity.ActiveReports.Chart.AxisType.Logarithmic;
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].Visible = true;

See Also

Chart Axes and Walls

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Axes

Custom Axes
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Axes and Walls > Custom Axes

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control supports the creation of additional custom axes through the use of the chart's CustomAxes collection. Once a custom axis has been added to the collection, in addition to setting the normal axis properties, you will need to set the following properties:

  • Parent - The Parent property allows you to choose the primary or secondary axis on which your custom axis resides.
  • PlacementLength - The PlacementLength property allows you to set the length of the custom axis in proportion to the Min and Max property values you have already set for the parent axis.
  • PlacementLocation - The PlacementLocation property allows you to set the starting location value for the custom axis to appear in relation to the parent axis.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The following code sample demonstrates creating a custom axis, adding it to the Axes collection for the ChartArea, and setting its properties.

Show To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event Copy Code
' create the custom axis and add it to the ChartArea's Axes collection
Dim customAxisY As New GrapeCity.ActiveReports.Chart.CustomAxis
Me.ChartControl1.ChartAreas(0).Axes.Add(customAxisY)

' set the basic axis properties for customAxisY
customAxisY.LabelFont = New GrapeCity.ActiveReports.Chart.FontInfo(Color.Red, New Font("Arial", 7.0!))
customAxisY.LabelsGap = 1
customAxisY.LabelsVisible = True
customAxisY.Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.Solid)
customAxisY.Max = 100
customAxisY.Min = 0
customAxisY.MaxDerived = False
customAxisY.Visible = True

' set major tick
customAxisY.MajorTick = New GrapeCity.ActiveReports.Chart.Tick(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), 20, 5, True)
customAxisY.MajorTick.Visible = True

' set minor tick
customAxisY.MinorTick.Visible = False
customAxisY.MinorTick.GridLine.Style = Chart.Graphics.LineStyle.None

' set custom axis property
customAxisY.Parent = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisY"), GrapeCity.ActiveReports.Chart.Axis)))
customAxisY.PlacementLength = 20
customAxisY.PlacementLocation = 45

Show To write code in C#

C# code. Paste INSIDE the section Format event Copy Code
// create the custom axis and add it to the ChartArea's Axes collection
GrapeCity.ActiveReports.Chart.CustomAxis customAxisY = new GrapeCity.ActiveReports.Chart.CustomAxis();
this.ChartControl1.ChartAreas[0].Axes.Add(customAxisY);

// set the basic axis properties for customAxisY
customAxisY.LabelFont = new GrapeCity.ActiveReports.Chart.FontInfo(Color.Red, new Font("Arial", 7F, FontStyle.Regular, GraphicsUnit.Point, ((System.Byte)(0))));
customAxisY.LabelsGap = 1;
customAxisY.LabelsVisible = true;
customAxisY.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red);
customAxisY.MajorTick = new GrapeCity.ActiveReports.Chart.Tick(new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), 1, 2F, true);
customAxisY.MajorTick.GridLine = new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.Solid);
customAxisY.MajorTick.Visible = true;
customAxisY.Max = 5;
customAxisY.MaxDerived = false;
customAxisY.Min = 0;
customAxisY.Visible = true;

// set the special custom axis properties
customAxisY.Parent = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisY"];
customAxisY.PlacementLength = 20;
customAxisY.PlacementLocation = 30;

See Also

Chart Axes and Walls

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Gridlines and Tick Marks

Gridlines and Tick Marks
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Chart > Chart Appearance > Chart Axes and Walls > Gridlines and Tick Marks

Glossary Item Box

Show All Show All
Hide All Hide All

Gridlines and tick marks are generally used to help increase the readability of a chart.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Types

There are two kinds of gridlines and tick marks in the Chart control: major and minor. The properties for the major gridlines and tick marks are set on the MajorTick object of the particular axis and the properties for minor gridlines and ticks are set on the MinorTick object of the axis. The location for any labels shown for the axis are determined by the Step property of the MajorTick object.

Step and TickLength

For either the MajorTick or MinorTick objects, you can define where the tick marks and gridlines will appear by setting the Step property. The TickLength property allows you to set the region the tick mark will extend outside of the axis line.

Tip: To set a specific tick interval using the Step property, you should set the SmartLabels property to False.

Visible

To make any defined major or minor tick marks to show up at design time or run time, the Visible property of the MajorTick or MinorTick object must be set to True. To show major or minor gridlines at design time or run time, the Visible property of the WallXY object as well as that of the MajorTick or MinorTick object must be set to True.

See Also

Chart Axes and Walls

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Info

Report Info
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Report Info

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, the ReportInfo control allows you to quickly display page numbers, page counts, and report dates. The ReportInfo control is a text box with a selection of preset FormatString options. You can set page counts to count the pages for the entire report, or for a specified group.

You can customize the preset values by editing the string after you select it. For example, if you want to display the total number of pages in the ReportHeader section, you can enter a value like:

Total of {PageCount} pages.
Caution: With large reports using the CacheToDisk property, placing page counts in header sections may have an adverse effect on memory as well as rendering speed. Since the rendering of the header is delayed until ActiveReports determines the page count of the following sections, CacheToDisk is unable to perform any optimization. For more information on this concept, see Optimizing Section Reports.

For more information on creating formatting strings, see the Date, Time, and Number Formatting topic.

Show Important Properties

Property | Description
FormatString | Gets or sets the string used to display formatted page numbering or report date and time values in the control.
Style | Gets or sets the style string for the control. This property reflects any settings you choose in the Font and ForeColor properties.
SummaryGroup | Gets or sets the name of the GroupHeader section that is used to reset the number of pages when displaying group page numbering.

Show Displaying page numbers and report dates

  1. From the toolbox, drag the ReportInfo control to the desired location on the report.

  2. With the ReportInfo control selected in the Properties window, drop down the FormatString property and select the preset value that best suits your needs.

Show Displaying group level page counts

  1. From the toolbox, add the ReportInfo control to the GroupHeader or GroupFooter section of a report and set the FormatString property to a value that includes PageCount.
  2. With the ReportInfo control still selected, in the Properties window, drop down the SummaryGroup property and select the group for which you want to display a page count.

ReportInfo Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field name from the data source to which to bind the control.

Show Appearance

Background Color: Select a color to use for the background of the control.

Show Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Show Format

Format string: Select a formatted page numbering or report date and time value to display in the control. You may also type in this box to change or add text to display along with the formatted date and page number values.

Multiline: Select this check box to allow text to render on multiple lines within the control.

ReportInfo height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Show Alignment

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

Show Summary

SummaryGroup: Select a GroupHeader section in the report to display the number of pages in each group when using the PageCount.

SummaryRunning: Select None, Group, or All to display a summarized value.

See Also

Optimizing Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Cross Section Controls

Cross Section Controls
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Cross Section Controls

Glossary Item Box

Show All Show All
Hide All Hide All

In section reports, you can use the CrossSectionLine and CrossSectionBox report controls to display a frame, borders, and vertical lines that run from a header section through its related footer section, spanning all details that come between. You can specify line appearance using properties on the report controls, and even round the corners of the CrossSectionBox.

You can only place the cross section controls in header sections in the designer. They automatically span intervening sections to end in the related footer section. (You can also place them in footer sections, but they automatically associate themselves with the related header section in the Report Explorer.)

Show CrossSectionLine

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The CrossSectionLine control draws a vertical line from a header section to the corresponding footer section. At run time, this vertical line stretches through any intervening sections. You can change the appearance of CrossSectionLine by changing the following properties.

Property | Description
LineColor | Allows you to get or set color of the line.
LineStyle | Allows you to select the line style from solid, dash, dotted, or double.
LineWeight | Allows you to specify the thickness of the line.

Show CrossSectionBox

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The CrossSectionBox control draws a rectangle from a header section to its corresponding footer section. To change the appearance of the rectangle, you can use the following properties in addition to the ones mentioned above.

Property | Description
Radius | Sets the radius of each corner for the RoundRect shape type. You can select Default, TopLeft, TopRight, BottomLeft or BottomRight. Selecting Default sets the radius of all the corners of the CrossSectionBox control to a specified percentage. Default value = 0 (point).
BackColor | Sets the back color.
Note: At run time, the BackColor property renders first and the LineColor property renders last.

Caution:

  • The CrossSectionBox and CrossSectionLine controls do not render properly in multi-column reports, that is, those in which a GroupHeader section has the ColumnLayout property set to True.
  • The CrossSection control (CrossSectionBox and CrossSectionLine) is drawn across multiple sections. Therefore, it is not possible to change its appearance etc. in the event of a section. The appearance of the CrossSection control can be dynamically changed only in the ReportStart event.

CrossSectionLine Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Show Appearance

Line style: Select a line style to use for the control. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the line.

Line color: Select a color to use for the line.

CrossSectionBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

Show General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Show Appearance

Line style: Select a line style to use for the border line. You can set it to Transparent, Solid, Dash, Dot, DashDot, DashDotDot, or Double.

Line weight: Enter the width for the border line.

Line color: Select a color to use for the border line.

Background color: Select a color to use for the background of the picture control.

CloseBorder: Select the checkbox to close the borders.

Note: The CloseBorder property is only available for CrossSectionBox control placed in Section report's Group Header and Group Footer.

Rounded Rectangle: Specify the radius for each corner of the CrossSectionBox individually. Drag the handlers [image] available at each corner of the CrossSectionBox to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the CrossSectionBox control.

  • Use the same radius on specified corners: Select this option to apply the same radius to all selected corners of the CrossSectionBox.

  • Use different radius on specified corners: Select this option to apply a different radius to each selected corner of the CrossSectionBox.

See Also

Shape (Section Report)
Line (Section Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Report Structure

Section Report Structure
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Structure

Glossary Item Box

Show All Show All
Hide All Hide All

By default, a section report is composed of three banded sections: a PageHeader, a Detail section, and a PageFooter. You can right-click the report and select Insert and choose other section pairs to add: ReportHeader and Footer, or GroupHeader and Footer.

All sections except the detail section come in pairs, above and below the detail section. You can hide any section that you are not using by setting the Visible property of the section to False.

ActiveReports defines the following section types:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Report Header

A report can have one report header section that prints at the beginning of the report. You generally use this section to print a report title, a summary table, a chart or any information that only needs to appear once at the report's start. This section has a NewPage property that you can use to add a new page before or after it renders.

The Report Header does not appear on a section report by default. In order to add this section, right-click the report and select Insert > Report Header/Footer to add a Report Header and Footer pair.

Show Page Header

A report can have one page header section that prints at the top of each page. Unless the page contains a report header section, the page header is the first section that prints on the page. You can use the page header to print column headers, page numbers, a page title, or any information that needs to appear at the top of each page.

Show Group Header

A report can include single or nested groups, with each group having its own header and footer sections. You can insert and print the header section immediately before the detail section. For more information on grouping, see Grouping Data in Section Reports.

In Columnar Reports, you can use ColumnGroupKeepTogether, and select whether to start a NewColumn before or after a group.

You can also specify whether to print a NewPage before or after the section, and have the section print on every page until the group details complete with the RepeatStyle property. The UnderlayNext property allows you to show group header information inside the group details, so long as you keep the BackColor property of the Detail section set to Transparent.

See GroupHeader for further information on properties.

Show Detail

A report has one detail section. The detail section is the body of the report and one instance of the section is created for each record in the report. You can set the CanShrink property to True to eliminate white space after controls, and you can set up Columnar Reports using ColumnCount, ColumnDirection, ColumnSpacing and NewColumn properties.

The KeepTogether property attempts to keep the section together on a single page, and the RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

See Detail for further information on properties.

Note: You cannot use the RepeatToFill property if you are using the PageBreak or SubReport control in the Detail section, or if you have set the NewPage or NewColumn property to any value other than None. When you use this property in a report where two groups are present, the ReportFooter section prints on the next page. This property processes correctly only with single grouping.

Show Group Footer

A report can include single or nested groups, with each group having its own header and footer sections. You can insert and print the footer section immediately after the detail section. For more information on grouping, see Grouping Data in Section Reports.

Show Page Footer

A report can have one page footer section that prints at the bottom of each page. You can use the page footer to print page totals, page numbers, or any other information that needs to appear at the bottom of each page.

Show Report Footer

A report can have one report footer section that prints at the end of the report. Use this section to print a summary of the report, grand totals, or any information that needs to print once at the end of the report.

The Report Footer does not appear on a section report by default. In order to add this section, right-click the report and select Insert > Report Header/Footer to add a Report Header and Footer pair.

Note: If the report contains a Page Footer on the last page, the Report Footer appears above the Page Footer.

See Also

Section Report Events

How To
Add Grouping in Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Report Events

Section Report Events
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Events

Glossary Item Box

Show All Show All
Hide All Hide All

Section reports use events to allow you to control report behavior.

Single-Occurrence Events

The following events are all of the events that are raised only once during a Section report's processing. These events are raised at the beginning or at the end of the report processing cycle.

Show Events raised once

ReportStart

Use this event to initialize any objects or variables needed while running a report. This event is also used to set any Subreport control objects to a new instance of the report assigned to the Subreport control.

Caution: Be sure to add dynamic items to the report before this event finishes.

DataInitialize

This event is raised after ReportStart. Use it to add custom fields to the report's Fields collection. Custom fields can be added to a bound report (one that uses a Data Control to connect and retrieve records) or an unbound report (one that does not depend on a data control to get its records). In a bound report the dataset is opened and the dataset fields are added to the custom fields collection, then the DataInitialize event is raised so new custom fields can be added. The DataInitialize event can also be used to make adjustments to the DataSource or to set up database connectivity.

ReportEnd

This event is raised after the report finishes processing. Use this event to close or free any objects that you were using while running a report in unbound mode, or to display information or messages to the end user. This event can also be used to export reports.

Multiple-Occurrence Events

The following events are raised multiple times during a Section report's processing.

Show Events raised more than once

FetchData

This event is raised every time a new record is processed. The FetchData has an EOF parameter indicating whether the FetchData event should be raised. This parameter is not the same as the Recordset's EOF property and is defaulted to True. When working with bound reports (reports using a DataControl), the EOF parameter is automatically set by the report; however, when working with unbound reports this parameter needs to be controlled manually.

Use the FetchData event with unbound reports to set the values of custom fields that were added in the DataInitialize event or with bound reports to perform special functions, such as combining fields together or performing calculations. The FetchData event should not have any references to controls on the report.

If you need to use a value from a Dataset with a control in the Detail section, set a variable in the FetchData event and use the variable in the section's Format event to set the value for the control. Please note that this method of setting a variable in the FetchData event and using it to set a control's value is only supported in the Detail_Format event.

Also use the FetchData event to increment counters when working with arrays or collections.

PageStart

This event fires before a page is rendered. Use this event to initialize any variables needed for each page when running an unbound report.

PageEnd

This event is raised after each page in the report is rendered. Use this event to update any variables needed for each page when running an unbound report.

When Bound and Unbound Data Values Are Set

  1. The Fields collection is populated from the dataset that is bound to the report after the DataInitialize event is raised. (In an unbound report, the Fields collection values are not set to anything at this point.)
  2. The FetchData event is raised, giving the user a chance to modify the Fields collection.
  3. Any fields that are bound have the values transferred over.
  4. The Format event is raised.

Events that Occur for Each Instance of Each Section

In a Section report, regardless of the type or content of the various sections, there are three events for each section: Format, BeforePrint and AfterPrint.

Show Section Events

Because there are many possible report designs, the event-raising sequence is dynamic in order to accommodate individual report demands. The only guaranteed sequence is that a section's Format event is raised before the BeforePrint event, which in turn occurs before the AfterPrint event but not necessarily all together. Reports should not be designed to rely on these events being raised in immediate succession.

Important: Never reference the report's Fields collection in these section events. Only reference the Fields collection in theDataInitialize and FetchData events.

Format

ActiveReports raises this event after the data is loaded and bound to the controls contained in a section, but before the section is rendered to a page.

The Format event is the only event in which you can change the section's height. Use this section to set or change the properties of any controls or the section itself.

Also use the Format event to pass information, such as an SQL String, to a Subreport.

If the CanGrow or CanShrink property is True for the section or any control within the section, all of the growing and shrinking takes place in the Format event. Because of this, you cannot obtain information about a control or section's height in this event.

Because a section's height is unknown until the Format event finishes, it is possible for a section's Format event to be raised while the report is on a page to which the section is not rendered. For example, the Detail Format event is raised but the section is too large to fit on the page. This causes the PageFooter events and the PageEnd event to be raised on the current page, and the PageStart, any other Header events, and possibly the FetchData event to be raised before the section is rendered to the canvas on the next page.

BeforePrint

ActiveReports raises this event before the section is rendered to the page.

The growing and shrinking of the section and its controls have already taken place. Therefore, you can use this event to get an accurate height of the section and its controls. You can modify values and resize controls in the BeforePrint event, but you cannot modify the height of the section itself.

Also use this event to do page-specific formatting since the report knows which page the section will be rendered to when this event is raised. Once this event has finished, the section cannot be changed in any way because the section is rendered to the canvas immediately after this event.

Note: If a section contains the SubReport control that occupies more than one page, the SubReport gets split into smaller parts at rendering. In this case, you can use the BeforePrint event - it will fire multiple times to get the height of each part of the rendered SubReport.

AfterPrint

ActiveReports raises this event after the section is rendered to the page.

Although AfterPrint was an important event prior to ActiveReports Version 1 Service Pack 3, it is rarely used in any of the newer builds of ActiveReports. This event is still useful, however, if you want to draw on the page after text has already been rendered to it.

Event Sequence

Multi-threaded, single-pass processing enables Section reports to surpass other reports in processing and output generation speed. ActiveReports processes and renders each page as soon as the page is ready. If a page has unknown data elements or its layout is not final, it places the page in cache until the data is available.

Show Sequence of Events

Summary fields and KeepTogether constraints are two reasons why a page might not render immediately. The summary field is not complete until all the data needed for calculation is read from the data source. When a summary field such as a grand total is placed ahead of its completion level, such as in the report header, the report header and all following sections are delayed until all of the data is read.

There are ten report events in the code behind a Section report, or seven in a ActiveReport script.

Because there are so many ways in which you can customize your reports, not all reports execute in the same way. However, when you run a report, this is generally what happens:

  1. ActiveReports raises the ReportStart event. The report validates any changes made to the report structure in ReportStart. In some cases, data source properties raise the DataInitialize event.
  2. Printer settings are applied. If none are specified, the local machine's default printer settings are used.
  3. If the DataInitialize event was not already raised, ActiveReports raises it and opens the data source.
  4. If the data source contains Parameters with unset values and the ShowParameterUI property is set to True, ActiveReports displays a parameters dialog to request values from the user.
  5. Closing the dialog raises the ParameterUIClosed event. If the report is a subreport that requires parameters, ActiveReports binds the subreport parameters to any fields in the parent report.
  6. ActiveReports raises the FetchData event.
  7. If there is no data, the NoData event is raised.
  8. The PageStart event raises, and then raises again after each PageEnd event until the final page.
  9. Group sections are bound and sections begin rendering on pages.
  10. ActiveReports raises Section Events to process sections in (roughly) the following order:
    • Report header
    • Page header
    • Group header
    • Detail
    • Group footer
    • Page footer
    • Report footer
  11. After each event, ActiveReports checks the Cancel flag to ensure that it should continue.
  12. Other events may raise, depending on the report logic.
  13. The PageEnd event raises after each page becomes full, and the PageStart raises if the report has not finished.
  14. Finally, ActiveReports raises the ReportEnd event.

Events that May Occur

These events occur in response to user actions, or when there is no data for a report.

Show Other Events

DataSourceChanged

This event occurs if the report's data source is changed. This is mainly useful with the end-user designer control.

NoData

This event occurs if the report's data source returns no records.

ParameterUIClosed

This event occurs when the user closes the parameter dialog.

PrintAborted

This event occurs when the user cancels a print job.

PrintProgress

This event occurs once for each page while the report document is printing.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Scripting in Section Reports

Scripting in Section Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Scripting in Section Reports

Glossary Item Box

In a section report, ActiveReports allows you to use VB.NET or C# script to port your custom logic to report layouts. This permits layouts saved to report XML (RPX) files to serve as stand-alone reports. By including scripting before you save the report layout as an RPX file, you can later load, run, and display the report directly to the viewer control without using the designer. In conjunction with report files, scripting allows you to update distributed reports without recompiling your project.

Script Editor

To access the script editor, click the script tab below the report design surface. The script tab contains two drop-downs (Object and Event).

  • Object: Drop down the list and select one of the report sections, or the report itself.
  • Event: Drop down the list and select from the list of events generated based on your selection in the Object drop down. If you select a report section as the Object, there are three events: Format, BeforePrint, and AfterPrint. If you select ActiveReport as the Object, there are seven events. See Section Report Events for further information.

Add script to the events in the same way that you add code to events in the code view of the report. When you select an event, the script editor generates a method stub for the event.

Using the ScriptLanguage property of the report, you can set the script language that you want to use.

Select the scripting language to use

  • In design view of the report, click in the grey area below the report to select it.
  • In the Properties window, drop down the ScriptLanguage property and select C# or VB.NET.

You can also add scripts at run time using the Script property.

Caution: Since the RPX file can be read with any text editor, use the AddCode or AddNamedItem method to add secure information such as a connection string.

Tips for Using Script

  • Keep the section report class public: If the Section Report class is private, the script cannot recognize the items in your report. The Section Report class is public by default.
  • Set the Modifiers property of any control referenced in script to Public: If the control's Modifiers property is not set to Public, the control cannot be referenced in script and an error occurs when the report is run. The Modifiers property has a default value of Private, so you must set this property in the designer.
  • Use "this" (as in C# code-behind) or "Me" (as in VB code-behind) to reference the report. Using "rpt" to reference the report is also possible but it is recommended to use the "this" and "Me" keywords.
    Note: The basic approach of using the "this/Me" and "rpt" keywords is as follows - use "this/Me" to access the properties and controls added to the sections of the report, whereas use "rpt" within the instance of the ActiveReports class only to access its public properties, public events and public methods.
  • Use Intellisense support: The script tab supports IntelliSense that helps in inserting the language elements and provides other helpful options when adding script to a report.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  • Use Run-time error handling: When run-time errors occur, a corresponding error message is displayed in the Preview tab stating the problem.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

    Note: A declared variable is not static by default. Use the static keyword to declare static variables.

Difference in script and code-behind event handler

Code-behind and the script tab require a different syntax for the event handler method definition. Use the Private modifier in code-behind and the Public modifier in the script editor.

See the following examples of the ReportStart event handler definition in Visual Basic and C#:

Show Script and code-behind examples in Visual Basic

The ReportStart event handler definition in the script editor:

Visual Basic.NET Copy Code
Sub ActiveReport_ReportStart End Sub

The ReportStart event handler definition in code-behind:

Visual Basic.NET Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart End Sub

Show Script and code-behind examples in C#

The ReportStart event handler definition in the script editor:

CS Copy Code
public void ActiveReport_ReportStart() { }

The ReportStart event handler definition in code-behind:

CS Copy Code
private void SectionReport1_ReportStart(object sender, EventArgs e) { }

See Also

How To
Add Code to Layouts Using Script

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Settings Dialog

Report Settings Dialog
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Report Settings Dialog

Glossary Item Box

Show All Show All
Hide All Hide All

With ActiveReports, you can modify facets of your report, such as the page setup, printer settings, styles, and global settings at design time, as well as at run time. To make changes at design time, access the Report Settings dialog through any of the following:

  • With the report selected, go to the Visual Studio toolbar select Report menu > Settings.
  • In the Report Explorer, right-click the Settings node and select Show or double-click the Settings node.
  • Click the gray area outside the design surface to select the report and in the Commands section at the bottom of the Properties Window, click the Property dialog command.

The Report Settings dialog provides the following pages where you can set or modify various settings of your report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Page Setup

On the Page Setup page, you can make changes to the report margins (left, right, top, and bottom), specify a gutter, and select the Mirror margins option. This page also shows a preview of how each setting appears on the report page.

  • Top margin: Set the Top margin for report pages.
  • Bottom margin: Set the Bottom margin for report pages.
  • Left margin: Set the Left margin for report pages.
  • Right margin: Set the Right margin for report pages.
  • Gutter: Set Gutter to give extra space between the edge of the page and the margins. This allows reports to be bound.
  • Mirror Margins: Select this option to set same inner and outside margins for opposite pages in the report.

By setting a gutter and selecting Mirror margins, you can easily set up reports for publishing.

Show Printer Settings

On the Printer Settings page, you can make changes to the printer paper size and orientation.

  • Paper Size: Select a paper size from the list of pre-defined paper sizes or choose Custom paper from the list to enable the Width and Height options for defining your own custom paper size.
  • Width: Set the width of your custom paper size.
  • Height: Set the height of your custom paper size.
  • Orientation: Select one among Default, Portrait or Landscape as your paper orientation.
  • Collate: Select whether to use collation or not.
  • Duplex: Select whether the report should be printed in Simplex, Horizontal or Vertical duplex.
  • Paper Source: Set the location of the paper source from the dropdown list.
Important: For items set to Printer Default, default printer settings are used from the printer installed on the environment where the report is being created. The paper size might also change based on the run time environment so in case the paper size of your report is fixed, please specify it beforehand.

Show Styles

On the Styles page, you can change the appearance of text associated with controls, either by creating a new style sheet, or by modifying and applying an existing style.

  • New: Use this button to create a new style.
  • Delete: Use this button to delete an existing style.
  • Export styles to file: Use this button to export an existing style to an external XML *.reportstyle file.
  • Import styles from file: Use this button to import styles a *.reportstyle file.
  • Font name: Set or modify the font in your new or existing style.
  • Font size: Set or modify the font size in your new or existing style.
  • Bold: Enable or disable Bold text for your new or existing style.
  • Italic: Enable or disable Italic text in your new or existing style.
  • Underline: Enable or disable Underlined text in your new or existing style.
  • Strikethrough: Enable or disable Strikethrough text in your new or existing style.
  • BackColor: Set the Backcolor to use in your new or existing style.
  • ForeColor: Set the Forecolor to use in your new or existing style.
  • Horizontal Alignment: Set the horizontal alignment to Left, Center, Right, Justify for your new or existing style.
  • Vertical Alignment: Set the vertical alignment to Top, Middle, Bottom for your new or existing style.
  • Script: Select the script to use in your new or existing style.

Show Global Settings

On the Global Settings page, you can change the design layout of your report.

  • Snap Lines: Select whether to use snap lines at design time or not.
  • Snap to Grid: Select whether the control moves from one snap line to another at design time.
  • Show Grid: Select whether to show or hide the grid at design time.
  • Grid Columns: Set the count of columns in a grid.
  • Grid Rows: Set the count of rows in a grid.
  • Dimension Lines: Set whether to use dimension lines at design time or not.
  • Grid Mode: Select whether to show gridlines as Dots or Lines.
  • Show Delete Prompt: Select this option to get a warning when you try to delete a parameter or calculated field from the Report Explorer.
  • Ruler Units: Set the ruler units in Inches or Centimeters.
  • Preview Pages: Set the number of pages to display in the Preview tab. Minimum values is 1 and maximum is 10000 pages. By default, the Preview tab displays 10 pages.
    Note: This property allows you to set number of pages to display in the Preview tab only. To set the number of pages for viewer/export, you can use MaxPages property.

See Also

Designer Buttons
Report Explorer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Grouping Data in Section Reports

Grouping Data in Section Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Grouping Data in Section Reports

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can group data by adding a pair of group header and group footer sections to the report. These sections appear immediately above and below the detail section. See Add Grouping in Section Reports for further information on how to group data.

Caution: You cannot add a header section without a corresponding footer section. If you try to do so in code, the results are unstable.

You can set the properties for the GroupHeader and GroupFooter sections in their corresponding dialogs. Following is a list of properties you can set through the options in these dialogs. Each option in the GroupHeader dialog corresponds to a property in the properties window. To access the properties directly, select the section and open the properties window. See the associated property names in parenthesis with each dialog option below.

GroupHeader Dialog

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To access the GroupHeader dialog, right click the group header and in the Properties window under the properties list where the commands are displayed, click the Property dialog link. See Properties Window for further information on commands.

Show General

  • Name (Name): Indicates the name of the GroupHeader in code. It is unique for a report.
  • Tag (Tag): Indicates the user-defined information persisted with the GroupHeader section.
  • Visible (Visible): Checkbox to specify the visibility of the GroupHeader section.
  • DataField (DataField): Field or expression on which you group the data.

Show Appearance

  • Background color (BackColor): Dropdown list to set the background color of the GroupHeader section.

Show Layout

  • Insert new page (NewPage): Dropdown list to determine whether a new page is inserted before and/or after displaying the GroupHeader section.
  • Insert new column (NewColumn): Dropdown list to determine whether a new column (in a multi-column report) appears before and/or after displaying the GroupHeader section.
  • Repeat section (RepeatStyle): Dropdown list to specify whether the GroupHeader section appears with every column or page that the Detail section or associated footer appears on.
  • Keep section and its footer on a single page (GroupKeepTogether): Dropdown list to specify whether the GroupHeader section and its footer appear as a single block on the same page or not.
  • Keep section on a single page (KeepTogether): Checkbox to specify whether the GroupHeader section appears on a single page.
  • Keep section and its footer in a single column (ColumnGroupKeepTogether): Checkbox to specify whether the GroupHeader section and its footer appear as a single block in the same column.
  • Keep section underneath the following section (UnderlayNext): Checkbox to specify whether the GroupHeader section appears in the following section or not. It allows you to show group header information inside the group details, so long as you keep the BackColor property of the Detail section set to Transparent.
  • Use column layout (ColumnLayout): Checkbox to determine whether the GroupHeader section uses the same column layout as the Detail section.
  • Can increase to accommodate contents (CanGrow): Checkbox to specify whether the height of the GroupHeader section can grow when its controls extend beyond its original height.
  • Can decrease to accommodate contents (CanShrink): Checkbox to specify whether the height of the GroupHeader section can adjust to the total height of controls placed in it.

GroupFooter Dialog

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To access the GroupFooter dialog, right click the group footer and in the Properties window under the properties list where the commands are displayed, click the Property dialog link. See Properties Window for further information on commands.

Show General

  • Name (Name): Indicates the name of the GroupFooter in code. It is unique for a report.
  • Tag (Tag): Indicates the user-defined information persisted with the GroupFooter section.
  • Visible (Visible): Checkbox to specify the visibility of the GroupFooter section.

Show Appearance

  • Background color (BackColor): Dropdown list to set the background color of the GroupFooter section.

Show Layout

  • Insert new page (NewPage): Dropdown list to determine whether a new page is inserted before and/or after displaying the GroupFooter section.
  • Insert new column (NewColumn): Dropdown list to determine whether a new column (in a multi-column report) appears before and/or after displaying the GroupFooter section.
  • Keep section on a single page (KeepTogether): Checkbox to determine whether the GroupFooter section appears on a single page.
  • Use column layout (ColumnLayout): Checkbox to specify whether the GroupFooter section uses the same column layout as the Detail section.
  • Print at the bottom of page (PrintAtBottom): Checkbox to specify whether the GroupFooter section is printed at the bottom of the page immediately before the PageFooter section.
  • Can increase to accommodate contents (CanGrow): Checkbox to specify whether the height of the GroupFooter section can grow when its controls extend beyond its original height.
  • Can decrease to accommodate contents (CanShrink): Checkbox to specify whether the height of the GroupFooter section can adjust to the total height of controls placed in it.

When you run the report, it renders the group header, followed by all related instances of the detail section, and then the group footer. It renders a new group header section for each instance of the grouping field.

Controls in the group header render once for each instance of the group, so you can place the column header labels to describe the data in the detail fields here.

Multiple Grouping

In a section report, you can nest group header and footer pairs and group each on a different field. You can add up to 32 groupings in one report.

Note: As with any group header and footer pair, group your data on the fields that you specify in the DataField property of the group header, but in the order of your groups. For example: SELECT * FROM Customers ORDER BY GroupHeader1DataField, GroupHeader2DataField, GroupHeader3DataField

See the image below for the order in which report sections appear on the report. GroupHeader1 in the image was added first and appears above the other two group headers, while its pair GroupFooter1, appears below the other two group footers.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

When you run a report with multiple groupings like the one above, the sections print in the following order:

  1. ReportHeader1 prints once and does not repeat.
  2. PageHeader1 prints once at the top of each page.
  3. GroupHeader1 prints once for the first value its DataField returns.
  4. GroupHeader2 prints once for the first value its DataField returns within the context of GroupHeader1's DataField value.
  5. GroupHeader3 prints once for the first value its DataField returns within the context of GroupHeader2's DataField value.
  6. Detail1 prints once for each record that falls within the context of GroupHeader3's DataField value.
  7. GroupFooter3 prints once at the end of the records that fall within the context of GroupHeader3's DataField value.
  8. GroupHeader3 may print again, if more values return within the context of GroupHeader2's DataField value.
  9. Each time GroupHeader3 prints again, it is followed by Detail1 (once for each related record) and GroupFooter3.
  10. GroupFooter2 prints once after GroupFooter3.
  11. GroupHeader2 may print again, if more values return within the context of GroupHeader1's DataField value.
  12. Each time GroupHeader2 prints again, it is followed by Detail1 (once for each related record) and GroupFooter2.
  13. GroupFooter1 prints once after GroupFooter2.
  14. GroupHeader1 prints once for the second value its DataField returns, followed by GroupHeader2, and so on in a pattern similar to the one above.
  15. ReportFooter1 prints once on the last page where the data displayed in the report ends.
  16. PageFooter1 prints once at the bottom of each page. Also, its position within groups varies.
    Note: At design time, although the PageFooter section is located above the ReportFooter section, at run time it appears after the ReportFooter section on the last page.

With many groupings, you might find the need to rearrange the order of your groups. If your report has more than one group, you can right-click the report surface, and select Reorder Groups. This opens the Group Order dialog, where you can drag the groups and set them in any order you want.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Alternatively, you can also click the Reorder Groups button in the ActiveReports toolbar, to open the Group Order dialog. See Toolbar for further information.

See Also

How To
Add Grouping in Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Date, Time, and Number Formatting

Date, Time, and Number Formatting
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Date, Time, and Number Formatting

Glossary Item Box

In Section Reports, you can set formatting strings for date, time, currency, and other numeric values using the OutputFormat property on the TextBox control. The OutputFormat dialog also allows you to select international currency values and select from various built-in string expressions. In addition to the built-in string expressions, you may use any .NET standard formatting strings. You can find information about these strings (Numerics and Date/Time formats) on MSDN.

Note: The ReportInfo control has many preformatted options in the FormatString property for RunDateTime and Page Numbers. For more information, see Display Page Numbers and Report Dates.
Caution:
  • The format from the OutputFormat property is applied to the value set in the DataField property of the Value property. It is not applied when a string is set in the Text property.
  • OutputFormat property settings are valid only for Double or DateTime type values. In case of a String or when no data type is set, the format is automatically applied to only those values that can be converted to Double or DateTime, otherwise no format is applied.

The OutputFormat property allows four sections delimited by a semicolon. Each section contains the format specifications for a different type of number:

  • The first section provides the format for positive numbers.
  • The second section provides the format for negative numbers.
  • The third section provides the format for Zero values.
  • The fourth section provides the format for Null or System.DBNull values.

For example: $#,#00.00; ($#,#00.00_); $0.00; #

Dates:

  • dddd, MMMM d, yyyy = Saturday, December 25, 2012
  • dd/MM/yyyy = 25/12/2012
  • d or dd = day in number format
  • ddd = day in short string format (for example, Sat for Saturday)
  • dddd = day in string format (for example, Saturday)
  • MM = month in number format
  • MMM = month in short string format (for example, Dec for December)
  • MMMM = month in string format (for example, December)
  • y or yy = year in two digit format (for example, 12 for 2012)
  • yyyy or yyyy = year in four digit format (for example, 2012)

Times:

  • hh:mm tt = 09:00 AM
  • HH:mm = 21:00 (twenty-four hour clock)
  • HH = hours in 24 hour clock
  • hh = hours in 12 hour clock
  • mm = minutes
  • ss = seconds
  • tt = AM or PM

Currency and numbers:

  • $0.00 = $6.25
  • $#,#00.00 = $06.25
  • 0 = digit or zero
  • # = digit or nothing
  • % = percent-multiplies the string expression by 100
Note: Underscore (_) keycode can be used in OutputFormat property to skip the width of the next character. This code is commonly used as _) to leave space for a closing parenthesis in a positive number format when the negative number format includes parentheses. This allows both positive and negative values to line up at the decimal point.

See Also

How To
Display Page Numbers and Report Dates

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Optimizing Section Reports

Optimizing Section Reports
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > Optimizing Section Reports

Glossary Item Box

Show All Show All
Hide All Hide All

Optimization can be crucial for large reports (i.e. over 100 pages). Here is some information which will help you to achieve the best possible results for such reports. To optimize ActiveReports for the web, please refer to the memory considerations section.

Show Memory Considerations

  • Images: Limit the use of large images when exporting to RTF and TIFF formats. Note that even one image uses a lot of memory if it's repeated on every page of a very long report exported to TIFF or RTF. If you are not exporting, or if you are exporting to Excel, PDF, or HTML, repeated images are stored only once to save memory, but the comparison necessary to detect duplicate images slows the processing time for the report.
  • SubReports: Limit the use of subreports in repeating sections because each subreport instance consumes memory. For example, consider that a subreport in the Detail section of a report in which the Detail section is repeated 2,000 times will have 2,000 instances of the subreport. Nested subreports will compound the number of instances. If you need to use subreports in repeating sections, instantiate them in the ReportStart event instead of the Format event of the repeating section so that they will be instantiated only once and use less memory.
  • CacheToDisk: Set the CacheToDisk property of the Document object to True. Although it slows down the processing time, this allows the document to be cached to disk instead of loading the whole report in memory. The PDF export also detects this setting and exports the cached report. Please note that only the PDF export is affected by the CacheToDisk property; other exports may run out of memory with very large reports. By default, CacheToDisk uses IsolatedStorage, which requires IsolatedStorageFilePermission.
    It is recommended that you use the CacheToDiskLocation property to specify the physical path instead of using isolated storage so that you do not run into the size limit.
  • Summary: Placing summaries (primarily page count and report totals) in header sections will have an adverse effect on memory as well as rendering speed with large reports using the CacheToDisk property. Since the rendering of the header is delayed until ActiveReports determines the total or page count of the following sections, CacheToDisk is unable to perform any optimization. The greater the number of affected sections, the longer rendering is delayed and the less optimization CacheToDisk will offer. Therefore, a group total in a group header section does not affect performance and memory as much as a report total in the report header.

Show Speed Considerations

  • Image: An image repeated on every page of a very long report is stored only once to improve memory, but the comparison necessary to detect duplicate images slows performance. This is not only the case with the report document itself, but also with the Excel, PDF, and HTML exports as they perform their own comparisons.
  • Summaries: Placing summaries (primarily page count and report totals) in header sections will slow report processing. ActiveReports must determine the total or page count of the following sections before it can render the header section. The greater the number of affected sections, the longer rendering is delayed. Therefore, a group total in a group header section does not affect performance and memory as much as a report total in the report header.
  • CacheToDisk: Be sure that the CacheToDisk property of the Document object is not set to True. Setting it to True increases the amount of time the report takes to load, and should only be used with very large reports that use a lot of memory. If this is used with smaller reports of less than 100 pages, it may actually cause more memory to be used.
  • SELECT *：Using the SELECT * statement is only recommended when you actually want to use all of the data returned by this statement. Contact your database administrator for other methods to speed up your queries.

Show Printing Considerations

  • Virtual Printer：We recommend use of virtual printer in case report generate environment differs from the environment in which the report is viewed or printed like in the case of Web applications.
  • Line：Please be careful as Line control has been used to draw borders within a report. An issue has been observed that spool size is increased (when comparing with Solid) during printing in case LineStyle property is set to an any value e.g. Dash or Dot etc. other than Solid that is the default value. As a result, time is taken for spooling by the report thus hindering the performance while printing. Same issue is observed when rendering a line using GDI+ in PrintDocument of .NET Framework.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


CacheToDisk and Resource Storage

CacheToDisk and Resource Storage
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section Report Concepts > CacheToDisk and Resource Storage

Glossary Item Box

The CacheToDisk property of the SectionDocument object tells ActiveReports whether to hold resources in memory, or cache them somewhere on your disk. Caching resources slows processing time, but can save you from running out of memory with very large reports.

Isolated Storage

If you use the CacheToDisk property without setting a CacheToDiskLocation, the default location in which it caches resources is IsolatedStorage, so you must have IsolatedStorageFilePermission in order to use it. The cache capacity for IsolatedStorage may depend on your configuration, but does not exceed 3 GB.

Important: Temporary files and folders created in IsolatedStorage are not deleted automatically.

Cache to Disk Location

To avoid using IsolatedStorage, you can specify a folder in the CacheToDiskLocation property. The cache capacity for a disk location is 3 GB.

For an example of the code used to turn on CacheToDisk and specify a folder, see the CacheToDiskLocation property in the Class Library documentation.

See Also

Optimizing Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Exporting

Exporting
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting

Glossary Item Box

ActiveReports provides three independent ways to export a report to different formats:

  • Rendering Extensions: You can use the Render method in Rendering Extensions of the PageDocument class to render a page report and RDL Report to Image, Html, Pdf, Xml, Word and Excel formats.
  • Export Filters: You can use the Export method of the corresponding ExportFilter class to export a section report, page report and RDL Reports. Exporting in Section Report is only possible through Export Filters.
The following table illustrates the supported export formats for section, page and an RDL report.

Click the ✓ mark to see the implementation of the corresponding Export format.

Export formats |  | Section report | Page report | RDL report
HTML: Export reports to HTML or MHT formats, all of which open in a Web browser. | Rendering Extension | ✘ | ✓ | ✓
 | Export Filter | ✓ | ✓ | ✓
Pdf: Export reports to PDF, a portable document format that opens in the Adobe Reader. | Rendering Extension | ✘ | ✓ | ✓
 | Export Filter | ✓ | ✓ | ✓
Rtf: Export reports to RTF, RichText Format that opens in Microsoft Word, and is native to WordPad. |  | ✓ | ✓ | ✓
Word: Export reports to DOC, a format that opens in Microsoft Word. | Word HTML (.doc) | ✘ | ✓ | ✓
 | Office Open XML (.docx) | ✘ | ✓ | ✓
Text: Export reports to TXT, plain text format that opens in Notepad or any text editor. Export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. |  | ✓ | ✓ | ✓
Image: Export reports to BMP, EMF, GIF, JPEG, TIFF, and PNG image formats |  | ✘ | ✓ | ✓
Tiff: Export reports to TIFF image format for optical archiving and faxing. |  | ✓ | ✓ | ✓
Excel | Export Filter(XLS, XLSX) | ✓ | ✓ | ✓
 | Rendering Extension - Microsoft Excel Worksheet - Layout(XLS, XLSX) | ✘ | ✓ | ✓
Xml: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. |  | ✘ | ✓ | ✓
CSV: Export reports to a CSV file, a form of structured data in plain text. The text in a CSV file is saved as series of values separated by comma. |  | ✘ | ✓ | ✓
JSON: Export reports to a JSON file, a text-based data format in which the data is stored in the hierarchical form. |  | ✘ | ✓ | ✓

See Also

Export Filters

How To
Exporting Reports using Export Filters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering Extensions

Rendering Extensions
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions

Glossary Item Box

In ActiveReports, you can use the Render method in Rendering Extensions of the PageDocument class to render in any one of the following formats. Each exporting format provides it's own set of properties to control how the report is rendered.

  • Rendering to HTML
  • Rendering to PDF
  • Rendering to Image
  • Rendering to XML
  • Rendering to Excel
  • Rendering to Word
  • Rendering to CSV
  • Rendering to JSON

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to HTML

Rendering to HTML
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to HTML

Glossary Item Box

Show All Show All
Hide All Hide All

HTML, or hypertext markup language, is a format that opens in a Web browser. You can export your reports to HTML or MHT formats. It is a good format for delivering content because virtually all users have an HTML browser. The HTMLRenderingExtension renders your report in this format with improved table border rendering and high quality SVG output for charts. If you do not want to use SVG in charts, set the RenderingEngine property to Html.

The following steps provide an example of rendering a report in the HTML format.

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Html.dll and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    ' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport()
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyHTML")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim htmlSetting As New GrapeCity.ActiveReports.Export.Html.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = htmlSetting

' Set the rendering extension and render the report.
Dim htmlRenderingExtension As New GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

reportDocument.Render(htmlRenderingExtension, outputProvider, htmlSetting)
    C# code. Paste INSIDE the Form Load event. Copy Code
    // Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyHTML");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Html.Page.Settings htmlSetting = new GrapeCity.ActiveReports.Export.Html.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = htmlSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension htmlRenderingExtension = new GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

reportDocument.Render(htmlRenderingExtension, outputProvider, htmlSetting);

HTML Rendering Properties

ActiveReports offers several options to control how reports render to HTML.

Property | Description
Fragment | Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.
MhtOutput | Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.
RenderingEngine | The RenderingEngine property is set to Mixed by default for improved quality output. The choices are Html or Mixed, where Mixed uses SVG to render charts.
StyleStream | Set the StyleStream to True to create an external .css file containing style information from your report controls' style properties. If you prefer to have style information embedded in the HTML file, set the StyleStream property to False.
JavaScript | Gets or sets whether or not JavaScript will be included in the html. True indicates JaveScript will be used; otherwise false. The default is true.
LinkTarget | Specify a link target to control whether drill down reports and other links open in a new window or reuse the current window. By default, no value is set and links open in the same window. A value of _blank opens the link in a new window, or you can specify a window using window_name. By default this value is not set.
Mode | Galley mode renders the report in one HTML stream. Select Paginated mode to render each page as a section inside the HTML document.
OutputTOC | Indicates whether the report's existing TOC should be added in the output.

Limitations

  • HTML is not the best format for printing. Use the PDF rendering extension instead.
  • Diagonal lines, Page margins, Border/Line Style (like DashedDotDot, DashDot, WindowInset) are not supported.
  • Checkbox color does not affect the color of the square.
  • TextIndent property and FillCharacter property of the TableOfContents control's Level setting are not supported.

Interactivity

Reports rendered in HTML support a number of interactive features. Hyperlinks, Bookmarks and Drill through links can be rendered to HTML. However, Document Maps are not available in this format. For a drill down report, make sure that the data you want to display is expanded before rendering, otherwise it renders in the hidden state.

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to PDF

Rendering to PDF
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to PDF

Glossary Item Box

Show All Show All
Hide All Hide All

Portable Document Format (PDF), is a format recommended for printing and for preserving formatting. You can use the PDFRenderingExtension to render your report in this format. With the PDF rendering extension, you can use features such as font linking, digital signatures and end-user defined characters (EUDC). These features are only available in the Professional Edition of ActiveReports.

The following steps provide an example of rendering a report in PDF format.

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Pdf.dll and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the page report you want to render.
Dim rptPath As New IO.FileInfo("..\..\PageReport1.rdlx")
Dim pageReport As New GrapeCity.ActiveReports.PageReport(rptPath)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyPDF")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim pdfSetting As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()

' Reduce the report size and report generation time.
pdfSetting.OptimizeStatic = True

' Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists
outputProvider.OverwriteOutputFile = True

pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the page report you want to render.
System.IO.FileInfo rptPath = new System.IO.FileInfo(@"..\..\PageReport1.rdlx");
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(rptPath);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyPDF");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Pdf.Page.Settings pdfSetting = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();

// Reduce the report size and report generation time.
pdfSetting.OptimizeStatic = true;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists
outputProvider.OverwriteOutputFile = true;

pageReport.Document.Render(pdfRenderingExtension, outputProvider, pdfSetting);

PDF Rendering Properties

ActiveReports offers a number of options to control how reports render to PDF.

Property | Description
Application | Set the value that appears for application in the Document Properties dialog of the PDF viewer application.
Author | Enter the name of the author to appear in the Document Properties dialog of the PDF viewer application.
CenterWindow | Set to True to position the document's window in the center of the screen.
DisplayMode | Specifies how the document is displayed when opened. FullScreen mode displays the document with no menu bar, window controls, or any other window visible.
DisplayTitle | Set to True to display text you enter in the Title property. When set to False it displays the name of the PDF file.
DpiX | Set the horizontal resolution of the rendered PDF file.
DpiY | Set the vertical resolution of the rendered PDF file.
Encrypt | Determines whether the document is encrypted or not. Note: If Encrypt is set to False, permissions and passwords have no effect.
EndPage | The last page of the report to render. The default value is the value for StartPage, that is, 0.
FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Keywords | Keywords associated with the document.
MarginBottom | The bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
MarginLeft | The left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
MarginRight | The right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
MarginTop | The top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
OptimizeStatic | True to generate a PDF file optimized with XObjects. Static report items are reused to a generate a smaller PDF file in less time.
OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
PageHeight | The page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
PageWidth | The page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Permissions | Specifies the user permissions for the document. Permissions can be combined using a comma between values. In order to use AllowFillin, AllowAccessibleReaders, and AllowAssembly permissions, you must set the Use128Bit property to True.
PrintLayoutMode | Specifies layout mode to be used for PDF document.
PrintOnOpen | Gets or sets the value indicating whether the document should be printed after open.
PrintPresets | Gets or sets the PDF print preset dialog.
SizeToFit | Determines whether PDF pages are fit to the selected paper size or not.
StartPage | The first page of the report to render. A value of 0 indicates that all pages are rendered.
Subject | The subject of the document.
Title | The title of the document.
Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions
UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
WatermarkAngle | Specify the degree of angle for the watermark text on the PDF document. Valid values range from 0 to 359, where 0 is horizontal, left to right.
WatermarkColor | Select a color for the watermark text on the PDF document. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
WatermarkTitle | Enter text (i.e. CONFIDENTIAL) to use as the watermark on the PDF document.

PDF Print Presets Properties

ActiveReports allows you to preset the printing properties for PDF report exports using the PrintPresets class. This prepopulates the print settings in the Print dialog box. Please see Use PDF Printing Presets for more information.

Note: The print preset properties are only available with the Professional Edition license. An evaluation message is displayed when used with the Standard Edition license.
Property | Description
PageScaling | Specify scaling for the printable area.You can select Default to shrink to the printable area, or you can select None for the actual size.
DuplexMode

Specify the duplex mode of the printer. For the best results with the duplex option, the selected printer should support duplex printing. You can choose from the following values,

  • Simplex: Prints on one side of the paper. This is the default value.
  • Duplex (Flip on long edge): Prints on both sides of the paper with paper flip on the long edge.
  • Duplex (Flip on short edge): Prints on both sides of the paper with paper flip on the short edge.
PaperSourceByPageSize | Determines the output tray based on PDF page size, rather than page setting options. This option is useful when printing PDFs with multiple page sizes, where different sized output trays are available. By default, this option is set to False.
PrintPageRange | Specify the range of page numbers as 1-3 or 1, 2, 3.
NumberOfCopies | Specify the number of copies to print. You can select any number of copies from 2 to 5, or select Default to specify a single copy.
Note: These properties are available in PDF version 1.7 or higher. The PageScaling property is supported in PDF version 1.6.

PDF/A Support Limitations

  • The NeverEmbedFonts property is ignored, so all fonts of a report are embedded into the PDF document.
  • The Security.Encrypt property is ignored and the PDF export behaves as if this property is always set to False.
  • The OnlyForPrint property is ignored and the PDF export behaves as if this property is always set to False.
  • The DocumentToAddBeforeReport and DocumentToAddAfterReport properties of the PDF Rendering Extension settings are ignored.
  • Transparent images lose their transparency when exported to PDF/A-1.
  • External hyperlinks are exported as plain text.

Interactivity

PDF is considered as the best format for printing and it also supports interactive features like Document Map, Bookmarks and Hyperlinks. However, in case you have any data hidden (like in a drill-down report) at the time of rendering, it does not show up in the output. Therefore, it is recommended to expand all toggle items prior to rendering.

See Also

Font Linking
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to Images

Rendering to Images
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to Images

Glossary Item Box

Show All Show All
Hide All Hide All

Image is the format that converts your report to an image file. You can use the ImageRenderingExtension to your render you report in this format. Make sure that you select an ImageType to any of the six different image formats available: BMP, EMF, GIF, JPEG, TIFF, and PNG.

Note: By default, the image rendering extension creates a separate file for each page in a report and adds an index to each corresponding file name (for example, image001.PNG, image002.PNG, etc).

To render the entire report as a single image, set the Pagination setting to False.

The following steps provide an example of rendering a report in Image format.

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Image.dll and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport()
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyImage")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim imageSetting As New GrapeCity.ActiveReports.Export.Image.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = imageSetting

' Set the rendering extension and render the report.
Dim imageRenderingExtension As New GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

reportDocument.Render(imageRenderingExtension, outputProvider, imageSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyImage");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Image.Page.Settings imageSetting = new GrapeCity.ActiveReports.Export.Image.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = imageSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension imageRenderingExtension = new GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

reportDocument.Render(imageRenderingExtension, outputProvider, imageSetting);

Image Rendering Properties

ActiveReports offers several options to control how reports render to Image.

Property | Description
Compression | Sets or returns a value which specifies the compression to be used when exporting.
Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
DpiX | Adjust the horizontal resolution of rendered images. The default value is 96.
DpiY | Adjust the vertical resolution of rendered images.
EndPage | The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.
ImageType | Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.
MarginBottom | Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
MarginLeft | Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
MarginRight | Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
MarginTop | Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
PageHeight | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
PageWidth | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
PrintLayoutMode Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)
Quality | Gets or sets the quality of the report to be rendered as an image.
SizeToFit | By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.
Start Page | The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.
WatermarkAngle | Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.
WatermarkColor | Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
WatermarkTitle | Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.

Interactivity

Reports rendered as images do not support any of the interactive features of Data Dynamics Reports. Any data hidden at the time of export is hidden in the image. To display all data in a drill-down report, expand all toggle items prior to exporting.

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to XML

Rendering to XML
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to XML

Glossary Item Box

Show All Show All
Hide All Hide All

XML is a useful format for delivering data to other applications as the resulting XML file opens in an internet browser. You can use the XmlRenderingExtension to render your report in this format. XML is a good format for delivering data to other applications. The resulting XML file opens in an internet browser

The following steps provide an example of rendering a report in the Xml format.

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Xml.dll and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport()Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyXml")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim xmlSetting As New GrapeCity.ActiveReports.Export.Xml.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = xmlSetting

' Set the rendering extension and render the report.
Dim xmlRenderingExtension As New GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension()Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

reportDocument.Render(xmlRenderingExtension, outputProvider, xmlSetting)
C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport();GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyXml");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Xml.Page.Settings xmlSetting = new GrapeCity.ActiveReports.Export.Xml.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = xmlSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension xmlRenderingExtension = new GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

reportDocument.Render(xmlRenderingExtension, outputProvider, xmlSetting);

Xml Rendering Properties

ActiveReports offers several options to control how reports render to Xml.

Property | Description
Encoding | Select the encoding schema to use in the XML transformation.
XslStylesheet | Select the existing XSL Stylesheet file to use to transform the resulting XML file. Note: When using the XslStylesheet option, be sure to save the file in the correct file format, such as HTML.

Controlling XML Output

You can also control XML output through properties on the individual report controls. These properties are:

  • DataElementName Indicates the name to use for the data element or attribute.
  • DataElementOutput Indicates whether the report controls renders in the XML output.
  • DataElementStyle Indicates whether a text box renders as an element or an attribute.
  • DetailDataCollectionName Indicates the name to use for the collection of all instances of the detail group in the XML output.
  • DetailDataElementName Indicates the name to use for instances of the detail group in the XML output.
  • DetailDataElementOutput Indicates whether the details appear in the XML output.
  • DataInstanceElementOutput Indicates whether a list appears in the XML output. (This property is ignored if there is a grouping in the list.)
  • DataInstanceName Indicates the name to use for instances of the list in the XML output.

Interactivity

XML format does not support interactive features except that when rendering a report to XML, complete drill-down data is shown regardless of whether the data is rendered in expanded state or not.

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to Excel

Rendering to Excel
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to Excel

Glossary Item Box

Microsoft Excel is one of the formats to which you can render your report using ExcelRenderingExtension. You can export excel files in two formats, i.e. Xls and Xlsx.

The following steps provide an example of rendering a report in the Microsoft Excel format.

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Excel.dll, GrapeCity.ActiveReports.Core.Export.Excel.Page.dll, and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    ' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport()
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyExcel")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim excelSetting As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings()
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xls
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = excelSetting

' Set the rendering extension and render the report.
Dim excelRenderingExtension As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

reportDocument.Render(excelRenderingExtension, outputProvider, setting.GetSettings())
    C# code. Paste INSIDE the Form Load event. Copy Code
    // Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyExcel");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings excelSetting = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings();
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xls;
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = excelSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension excelRenderingExtension = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

reportDocument.Render(excelRenderingExtension, outputProvider, setting.GetSettings());
Caution: To be able to successfully compile application in Visual Studio 2012, you need to edit app.config file as follows:
  • If target framework version of the sample is 4.6.2:
    <dependentAssembly>
            <assemblyIdentity name="System.IO.Compression" culture="neutral" publicKeyToken="b77a5c561934e089"/>
            <bindingRedirect oldVersion="0.0.0.0-4.2.0.0" newVersion="4.0.0.0"/>
    </dependentAssembly>
  • If target framework version is 4.7.0 or higher:
    <dependentAssembly>
            <assemblyIdentity name="System.IO.Compression" culture="neutral" publicKeyToken="b77a5c561934e089"/>
            <bindingRedirect oldVersion="0.0.0.0-4.2.0.0" newVersion="4.2.0.0"/>
    </dependentAssembly>

Excel Rendering Properties

ActiveReports offers several options to control how reports render to Microsoft Excel.

Property | Description
PageSettings | Returns an ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Pagination | Forces pagination or galley report layout mode.
Security | Returns an ExcelRenderingExtensionSecurity object for initializing document security.
UseDefaultPalette | Indicates whether to export the document with the default Excel palette.
FileFormat | Specifies the output format of the Excel document, i.e. Xls or Xlsx.
OpenXmlStandard | Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose from the following values: Show Strict The default value. Show Transitional The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices. To change the default value of OpenXMLStandard, add following configuration settings in GrapeCity.ActiveReports.config file: <ReportingConfiguration> <Extensions> <Render> <Extension Name="Excel" Type="GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension, GrapeCity.ActiveReports.Export.Excel, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" > <Settings> <Property Name="OpenXmlStandard" Value="Transitional" Type="GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard, GrapeCity.ActiveReports.Export.Excel, Culture=neutral, PublicKeyToken=cc4967777c49a3ff"/> </Settings> </Extension> </Render> </Extensions> </ReportingConfiguration>
MultiSheet | Indicates whether to generate a single-sheet or multi-sheet Excel document.
EnableToggles | Allows to export collapsible rows in the detail and row groups of the Table control of an RDL report. This property gets displayed in the Export menu when the Pagination property is set to False.

Interactivity

Reports rendered in Excel support a number of interactive features like Bookmarks and Hyperlinks. However, in case you have any data hidden at the time of rendering (like in a drill-down report), it does not show up in the output. It is recommended that you expand all toggle items prior to rendering.

Limitations

  • BackgroundImage and rounded corners (for Shape and Container) are not exported.
  • Overlapping controls are not supported and an incorrect result will be obtained in the case of export.
  • LineSpacing is not retained after export.
  • Exported FormattedText control does not preserve styles and formatting. It exports FormattedText as TextBox with plain text without any tags.
  • Barcodes are exported as an image object so scanning of barcode image may fail in some cases. It depends on printer settings and the scanner quality. Barcodes may be blurred on export and the caption may get truncated in case of physical printing.
  • Exported Boolean values are displayed in uppercase in both Xls and Xlsx files.
  • TextIndent property and FillCharacter property of the TableOfContents control's Level setting are not supported.
  • Text decoration (Underline and LineThrough) gets applied to the indented area, when left padding is applied to the TableOfControl's levels.
  • When a report is exported to Excel, CharWrap mode is ignored.

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to Word

Rendering to Word
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to Word

Glossary Item Box

Show All Show All
Hide All Hide All

The WordRenderingExtension class renders your reports to the native Microsoft Word file formats. You can export Page reports and RDL reports to the Office Open XML (OOXML) format (.Docx) or Word HTML format (.Doc) using the FileFormat property.

The Word HTML format (.Doc) provides greater layout accuracy for Page and RDL Reports in Microsoft Word, on the other hand, OOXML format (.Docx) provides excellent editing experience for the exported reports.

The OOXML format (.Docx) is recommended in the following scenarios:

  • Open exported reports in a wide range of applications: Users can open and modify the exported Word document in any of the following applications.
    • Microsoft Office 2007 - 2013
    • Microsoft Office for Mac 2008 - 2011
    • iWord and Pages v4 or higher for OS X
    • Apache OpenOffice
    • Google Quickoffice for Android
    • Documents Free (Mobile Office Suite) by SavySoda for iOS
      Note: Besides the applications listed above, .Docx files exported through ActiveReports WordRenderingExtension class might work in other applications that support the .Docx format.
  • Customize reports after exporting: Positioning and arrangement of report elements in the exported document is implemented using the OOXML format (.Docx) which provides a natural document flow for editing the exported documents.
  • Use Word automation features: With support for automation features in the OOXML format (.Docx), tasks that previously required manual adjustments in the exported Word document are now handled automatically. Report elements such as page header and footer, expressions, heading levels, and table of contents are automatically transformed to the OOXML format (.Docx).
  • Set compatibility mode: You can render a report as a Word document that is compatible with Microsoft Word 2007-2010 as well as Microsoft Word 2013 using the DocumentCompatibleVersion property.

The following steps provide an example of rendering a report in the Word format (.doc or .docx).

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Word.dll and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event to render your report in .OOXML or .HTML file format.
Note: To export your report in Word HTML format (.Doc), change the FileFormat property option from OOXML to HTML format as depicted below.
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.HTML

To export a report in .Docx file format

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport()
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyWord")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim wordSetting As New GrapeCity.ActiveReports.Export.Word.Page.Settings()

' Set the FileFormat property to .OOXML.
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML

' Set the rendering extension and render the report.
Dim wordRenderingExtension As New GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting)

C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyWord");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Word.Page.Settings wordSetting = new GrapeCity.ActiveReports.Export.Word.Page.Settings();

// Set the FileFormat property to .OOXML.
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension wordRenderingExtension = new GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting);
Caution: To be able to successfully compile application in Visual Studio 2012, you need to edit app.config file as follows:
  • If target framework version of the sample is 4.6.2:
    <dependentAssembly>
            <assemblyIdentity name="System.IO.Compression" culture="neutral" publicKeyToken="b77a5c561934e089"/>
            <bindingRedirect oldVersion="0.0.0.0-4.2.0.0" newVersion="4.0.0.0"/>
    </dependentAssembly>
  • If target framework version is 4.7.0 or higher:
    <dependentAssembly>
            <assemblyIdentity name="System.IO.Compression" culture="neutral" publicKeyToken="b77a5c561934e089"/>
            <bindingRedirect oldVersion="0.0.0.0-4.2.0.0" newVersion="4.2.0.0"/>
    </dependentAssembly>

Word Rendering Extension Properties

ActiveReports offers several options to control how reports render to Microsoft Word.

Common properties (HTML and OOXML)

Property | Description
Author | Sets the name of the author that appears in the Author field of the Properties dialog in the rendered Word document.
FileFormat | Sets the output file format to HTML (.Doc) or OOXML (.Docx). By default the file format is set to HTML format.
Title | Sets the title for a document that appears in the Title field of properties dialog in the rendered Word document.

HTML format

Property | Description
BaseUrl | Sets the base URL for any relative hyperlinks that appear in the Hyperlink base field of the Properties dialog in the rendered Word document.
Generator | Sets the identity of the document generator in the rendered Word document.
PageHeight | Sets the height of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.
PageWidth | Sets the width of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.
UseMhtOutput | Indicates whether Mht output is to be used for the resultant Word document or not.

OOXML format

Property | Description
CompanyName | Sets the name of the organization or company that appears in the Company field of Properties dialog in the rendered Word document.
DocumentCompatibilityVersion | Sets the compatibility mode of the document to the latest version (Microsoft Word 2013) or to previous versions (Microsoft Word 2007 - 2010) of Word. By default the compatibility version is set to Word2007.
DpiX | Sets the horizontal resolution of the images in the rendered Word document. By default DpiX is set to 96.
DpiY | Sets the vertical resolution of the images in the rendered Word document. By default DpiY is set to 96.
PageOrientation | Sets a value that specifies whether the document pages should be printed in portrait or landscape in the rendered Word document.
PaperSize | Sets the paper size for the page.
Password | Sets a password that must be provided to open the rendered Word document.
ReadOnlyRecommended | Sets a value that indicates whether Microsoft Office Word displays a message whenever a user opens the document, suggesting that the document is read-only.
WritePassword | Sets the write password that is required for saving changes in the rendered Word document.
TOCAutoUpdate | Automatically updates the TableOfContents control while opening the Word document. By default TOCAutoUpdate is set to False.

Limitations

HTML format

  • Although background colors for controls export to Word documents, background colors for sections such as Body and Page Header or Footer do not.
  • The BackgroundImage is not supported when used in TextBox and CheckBox controls embedded in data regions such as Table and Tablix.
  • The BackgroundImage is not supported for reports, and for List, Container, Shape, FormattedText, Table, and Tablix report controls.
  • KeepTogether property of Table/Tablix is not supported.
  • Some FormattedText tags, for example <b>bi</b> and <s>es</s>, are not exported to Word.
  • Image alignments other than the defaults (HorizontalAlignment: Left and VerticalAlignment: Top) are not supported.
  • EMF text in the Image report item is blurred when exported to Word.
  • Checkbox color does not affect the color of the square.

OOXML format

Report properties

  • The LineSpacing property of a report's style sheet, StartPageNumber property of the report, PrintOnLastPage property of the PageHeader and PageFooter are not supported.
  • For Page reports, some of the NumberingStyle property (DocumentMap settings) options are not supported. The supported NumberingStyle options are Decimal, DecimalZero, LowerLetter, UpperLetter, LowerRoman, UpperRoman.
  • Background image is not supported for report item except Shape.
  • The BackgroundRepeat property of the BackgroundImage is not supported in Page (Page reports) and Body (RDL reports).
  • For RDL reports, Background and Border properties of Page Header or Page Footer are not supported.
  • Microsoft Word calculates the columns width by the document width. A RDL report calculates the columns width based on the body width, therefore the width of columns in an exported RDL report may differ from an original RDL report.
  • In Microsoft Word, the maximum supported page size is 22 inches (55.87 cm) wide and 22 inches (55.87 cm) high. If an exported report exceeds the maximum size, some data may be lost during export.
  • In Microsoft Word, a table can have a maximum of 63 columns. If an exported report table has more than 63 columns, then the table is split and therefore an exported document may differ from an original report.
  • A repeated Table Footer (the RepeatOnNewPage property of Table Footer) or multiple repeated headers on a single page are not supported.
  • The OverflowPlaceHolder control is not supported.
  • If the PrintOnFirstPage property of PageHeader or PageFooter is set to False, then both PageHeader and PageFooter will not be available on the first page of the exported document.
  • The report data gets rendered only in first theme if a Page report containing multiple themes is exported to Docx format.

Report controls

  • The Inset, Outset, and Windowsinset border styles (in BorderStyle property) are not supported.
  • The Map, Chart, Image, Barcode, SparkLine, Bullet, and CustomControl report controls are exported as an image. If a report control uses the BorderColor, BorderStyle or BorderWidth properties, a report is exported as a table.
  • The BorderWidth property of report controls is not exported as is and may differ from the original BorderWidth value.
  • PageBreaks are not fully supported. The report contents exported to the Word's table or cell items do not support the page breaks.
  • For Shape report control, if the BorderStyle property is set to Double, it is exported as Solid.
  • For Line control, if LineStyle property is set to Double/Transparent, it is exported as Solid.
  • For BandedList data region, only the BandedList Header is repeated on each page. The BandedList Footer, GroupHeaders and GroupFooters are not supported.
  • Tablix data region is exported as a single table without horizontal split.
  • For Image control, Border properties and Padding properties are not supported if the Sizing property is set to Clip.
  • For Container report control, rounding corners (the RoundingRadius property) are not supported.
  • RepeatToFill property for Table and Tablix is not supported.
  • Images embedded in a Table data region are not properly supported.
  • Pagination is not supported due to difference in the layouts of ActiveReports and Word.
  • Page Number in Section (Page N of M(Section)) is not supported.
  • KeepTogether property of Table/Tablix is not supported.
  • Horizontal aligned images may overlap in iWord.
  • The properties set to the 'Body' region of a Subreport are not exported.

    Show FormattedText

    • FormattedText is exported as it is. It does not support all HTML and CSS features.
    • The <a> tag without a href attribute, <abbr> and <q> tags are exported as simple text.
    • For Border Styles - Inset and Outset, the <ul> tags are not exported.
    • The BackgroundColor, BackgroundImage, BorderColor, BorderStyle and BorderWidth properties are not supported.
    • Anchors with an href attribute are exported as hyperlinks.
    • Headers like h1, h2, etc. are exported as corresponding Microsoft Word built-in header styles.

    Show TableOfContents

    • The TextAlign, DisplayPageNumber, TextIndent, and Overline TextDecoration properties are not supported.
    • The Source property of the Document Map settings is not fully supported. Only the Headings Only option of the Source property is supported.
    • If a report uses more than one TableOfContents controls, the properties of the first TableOfContents are applied to the other TableOfContents controls in the exported document.
    • The FillCharacter property is exported as dots.
    • The background of TOC control appears black on opening exported file in Apache OpenOffice.

    Show TextBox/CheckBox

    • If the Format property is set to Numeric or Date, the exported TextBox has a right alignment. Other Format values are exported with the left alignment.
    • The Transparent color for text is exported as white.
    • The Underline for numbered lists, Right-To-Left (RTL) option of the Direction, Angle, ShrinkToFit and Overline TextDecoration properties are not supported.
    • The action Jump to report is not supported.
    • The tb-rl (vertical text) option of the WritingMode property is not supported. TextBoxes with the WritingMode property set to tb-rl are exported as lr-tb.
    • The NoWrap option of the WrapMode property is exported as WordWrap.
    • The LineSpacing property of an exported document will differ from the original report. This is because in Microsoft Word, the line spacing is calculated by the font size value of a report control plus the line spacing value of a report control.
    • For CheckBox control, the CheckAlignment property is exported as MiddleRight for TopRight, MiddleRight, and BottomRight options. Other CheckAlignment options are exported as MiddleLeft.
    • Paddings exceeding 31 inches is exported as border spaces.
    • Right-To-Left text direction does not work in the Apache OpenOffice.
    • On exporting to Word 2013, when the background (shading) and padding are applied on a paragraph, the padding is also applied to the background, so a gap between the border and the background appears on the left side of the paragraph.
    • CharWrap property is not supported.
    • The fields in a TextBox control are evaluated as follows:
      • PageNumber and TotalPages expressions are exported as special fields, evaluated by a text editor (Word or other).
      • The fields placed in Header or Footer are automatically evaluated.
      • The fields placed in the Body should be re-evaluated manually by clicking 'Update field' from context menu.

Interactivity

HTML format

Reports rendered in a Word format supports both Bookmarks and Hyperlinks. However, if visibility toggling (like in a drill-down report) is essential to your report, it is recommended to use the HTML rendering extension. If a Document map is essential to your report, it is recommended to use the PDF rendering extension.

OOXML format

  • Hyperlinks - Hyperlinks on TextBox and Image controls are rendered as hyperlinks in the Microsoft Word.
  • Bookmarks - Bookmarks in the report are rendered as Microsoft Word bookmarks. Bookmark links are rendered as hyperlinks that link to the bookmark labels within the document.
  • TOC AutoUpdate - TableofContents control in the report is rendered as Microsoft Word table of contents.

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to CSV

Rendering to CSV
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to CSV

Glossary Item Box

Comma-Separated Values (CSV) is a form of structured data in plain text. The text in a CSV file is saved as series of values separated by comma. You can use the CsvRenderingExtension to render your report in this format.

The following steps provide an example of rendering a report in the Csv format.

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Xml.dll and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport()
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyCSV")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim csvSettings As New GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings()
csvSettings.ColumnsDelimiter = ","
csvSettings.Encoding = System.Text.Encoding.UTF8
csvSettings.NoHeader = "True"
csvSettings.QuotationSymbol = """"c
csvSettings.RowsDelimiter = vbCr & vbLf

' Set the rendering extension and render the report.
Dim csvRenderingExtension As New GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

reportDocument.Render(csvRenderingExtension, outputProvider, csvSettings)

C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyCSV");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings csvSettings = new GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings();
csvSettings.ColumnsDelimiter = ",";
csvSettings.Encoding = Encoding.UTF8;
csvSettings.NoHeader = "True";
csvSettings.QuotationSymbol = '"';
csvSettings.RowsDelimiter = "\r\n";

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension csvRenderingExtension = new GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

reportDocument.Render(csvRenderingExtension, outputProvider, csvSettings);

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Rendering to JSON

Rendering to JSON
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to JSON

Glossary Item Box

JavaScript Object Notation (JSON) is a text-based data format in which the data is stored in the hierarchical form. You can use the JsonRenderingExtension to render your report in this format.

The following steps provide an example of rendering a report in the Json format.

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and specify a name for the project in the Name field.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Add reference to GrapeCity.ActiveReports.Export.Xml.dll and GrapeCity.ActiveReports.Core.Rendering.dll assemblies in the project.
  5. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  6. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport()
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory.
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyJSON")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim jsonSettings As New GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension.Settings()
jsonSettings.Formatted = True

' Set the rendering extension and render the report.
Dim jsonRenderingExtension As New GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))

' Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = True

reportDocument.Render(jsonRenderingExtension, outputProvider, jsonSettings)

C# code. Paste INSIDE the Form Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory.
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyJSON");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension.Settings jsonSettings = new GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension.Settings();
jsonSettings.Formatted = true;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension jsonRenderingExtension = new GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));

// Overwrite output file if it already exists.
outputProvider.OverwriteOutputFile = true;

reportDocument.Render(jsonRenderingExtension, outputProvider, jsonSettings);

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Export Filters

Export Filters
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters

Glossary Item Box

ActiveReports provides custom components for exporting reports into six formats. Each export format has special features, however, not all formats support all of the features that you can use in your reports. Here are the unique usage possibilities of each format, along with any limitations inherent in each.

  • HTML Export
  • PDF Export
  • Text Export
  • RTF Export
  • Excel Export
  • TIFF Export

See Exporting Reports using Export Filters for exporting Page Report, RDL Report or Section Report using the export filters.

See Also

Concepts
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


HTML Export

HTML Export
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters > HTML Export

Glossary Item Box

Show All Show All
Hide All Hide All

HTML, or hypertext markup language, is a format that opens in a Web browser. The HTML export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the HTMLExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

GrapeCity.ActiveReports.Export.Html.dll

Show HTML Export Properties

Property | Valid Values | Description
BookmarkStyle | Html (default) or None | Set to Html to generate a page of bookmarks from the bookmarks in the report. If the report has no bookmarks, this setting is ignored.
CharacterSet | Big5, EucJp, HzGb2312, Ibm850, Iso2022Jp, Iso2022Kr, Iso8859_1, Iso8859_2, Iso8859_5, Iso8859_6, Koi8r, Ksc5601, ShiftJis, UnicodeUtf16, UnicodeUtf8 (default) | Select the IANA character set that you want to use in the meta tag in the header section of the HTML output. This property only takes effect if the IncludeHtmlHeader property is set to True.
CreateFramesetPage | True or False (default) | Set to True to generate a set of frames that display a page of bookmarks (if available) in the left frame and the report document in the right frame. The HTML output uses the specified filename with the extension .frame.html.
IncludeHtmlHeader | True (default) or False | Set to False if you want to embed the HTML output in another HTML document. Otherwise, the HTML output includes the usual HTML, HEAD, and BODY elements.
IncludePageMargins | True or False (default) | Set to True to include the report's margins in the HTML output.
MultiPage | True or False (default) | Set to True to create a separate HTML page for each page of the report. Otherwise, the HTML output is a single page.
OutputType | DynamicHtml (default) or LegacyHtml | Set to LegacyHtml to use tables for positioning and avoid the use of cascading style sheets (CSS). Otherwise, positioning of controls is handled in the CSS.
RemoveVerticalSpace | True or False (default) | Set to True if the OutputType property is set to LegacyHtml and you plan to print the output from a browser. This removes white space from the report to help improve pagination. Otherwise, vertical white space is kept intact.
Title | Any String | Enter the text to use in the header section's title. This is displayed in the title bar of the browser.

More information on output types

By default, the report is exported as DynamicHtml (DHTML), with cascading style sheets (CSS). Using the OutputType property, you can change the output to LegacyHtml (HTML). Neither of the output types creates a report that looks exactly like the one you display in the viewer because of differences in formats. Following is the usage of each output type and controls to avoid in each.

Show DynamicHtml (DHTML)

Usage:

  • Create Web reports with Cascading Style Sheets (CSS)
  • Open in Web browsers

Does not support:

  • Diagonal line control
  • Control borders

Show LegacyHtml (HTML)

Usage:

  • Create archival reports
  • Open in Web browsers

Does not support:

  • Line control
  • Control borders
  • CrossSectionLine controls
  • Overlapping controls
  • MinCondenseRate property

Limitations of HTML Export Filter

  • Line spacing in exported HTML can be different from the line spacing in Viewer.
  • There may be space between the borders of each control in exported file.
  • Text in RichTextBox may appear overlapped.
  • Vertical Text and Bookmarks are not supported.

See Also

Exporting Reports using Export Filters
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


PDF Export

PDF Export
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters > PDF Export

Glossary Item Box

Show All Show All
Hide All Hide All

PDF, or portable document format, opens in the Adobe Reader. The PDF export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the PDFExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

GrapeCity.ActiveReports.Export.Pdf.dll

With the PDF export filter, you can use the feature Font Linking.

Note: These features are only available in the Professional Edition of ActiveReports.

Show PDF Export Properties

Property | Valid Values | Description
ConvertMetaToPng | True or False (default) | Set to True to change any Windows metafile images to PNG format to keep the file size down. If the report has no metafiles, this setting is ignored.
ExportBookmarks | True (default) or False | Set to True to generate bookmarks from the bookmarks in the report. If the report has no bookmarks, this setting is ignored. To control how the exported bookmarks are displayed, use Options.DisplayMode detailed below.
FontFallback | String of font families | Set a comma-delimited string of font families to be used to lookup glyphs missing in the original font.
ImageQuality | Lowest, Medium (default), or Highest | Set to Highest in combination with a high value in the ImageResolution property to yield the best printing results when converting Windows metafiles (.wmf and .emf). Set to Lowest to keep the file size down. If the report has no metafiles, this setting is ignored.
ImageResolution | 75 - 2400 dpi | Set to 75 dpi to save space, 150 dpi for normal screen viewing, and 300 dpi or higher for print quality. Use this property in combination with ImageQuality (highest) to yield the best results when the report contains metafiles or the Page.DrawPicture API is used. Neither property has any effect on other image types.
NeverEmbedFonts | A semicolon-delimited string of font names | List all of the fonts that you do not want to embed in the PDF file to keep the file size down. This can make a big difference if you use a lot of fonts in your reports.
Options | See below | Expand this property to see a group of sub properties. These settings control how the Adobe Reader displays the output PDF file when it is first opened. See the table below for details.
Security | See below | Expand this property to see a group of sub properties. These settings control encryption and permissions on the output PDF file. See the table below for details.
Signature | A valid PdfSignature object | This must be set up in code. For more information, see Digital Signature .
Version | Pdf11, Pdf12, Pdf13, Pdf14, Pdf15, Pdf16, Pdf17, PdfA1a, PdfA1b, PdfA2a, PdfA2b, or PdfA2u | Sets the version of the PDF format the exported document is saved in.

PDF (Portable Document Format)

Usage:

  • Create printable reports whose formats do not change from machine to machine.
  • Open in Adobe Reader.

Does not support:

  • Dash and dot border patterns appear to look longer in the PDF output than in the ActiveReports Window Forms Viewer.
  • Multiple lines of vertical text is not supported in Page and RDL reports.
  • Transparent background-color in charts are not supported.

PDF/A Support Limitations

  • The NeverEmbedFonts property is ignored, so all fonts of a report are embedded into the PDF document.
  • The Security.Encrypt property is ignored and the PDF export behaves as if this property is always set to False.
  • The OnlyForPrint property is ignored and the PDF export behaves as if this property is always set to False.
  • Transparent images lose their transparency when exported to PDF/A-1.
  • External hyperlinks are exported as plain text.

Options and Security

When you expand the Options or Security properties in the Properties window, the following sub properties are revealed.

Show PDF Options Properties

Property | Valid Values | Description
Application | String | Set to the string value that you want to display in the Adobe Document Properties dialog, Description tab, Application field.
Author | String | Set to the string value that you want to display in the Adobe Document Properties dialog, Description tab, Author field.
CenterWindow | True or False (default) | Set to True to position the Adobe Reader window in the center of the screen when the document is first opened.
DisplayMode None (default), Outlines, Thumbs, or FullScreen

Select how to display bookmarks when the document is first opened.

  • None (default) bookmarks are not displayed until opened by the user.
  • Outlines shows bookmarks in outline format.
  • Thumbs shows bookmarks as thumbnails.
  • FullScreen shows the document in full screen, and bookmarks are not displayed.
DisplayTitle | True or False (default) | Set to True to use the Title string entered in the Title property below. Otherwise, the file name is used.
FitWindow | True or False (default) | Set to True to expand the window to fit the size of the first displayed page.
HideMenubar | True or False (default) | Set to True to hide the menu in the Adobe Reader when the document is first opened.
HideToolbar | True or False (default) | Set to True to hide the toolbars in the Adobe Reader when the document is first opened.
HideWindowUI | True or False (default) | Set to True to hide the scrollbars and navigation controls in the Adobe Reader when the document is first opened, displaying only the document.
Keywords | String | Enter keywords to display in the Adobe Document Properties dialog, Description tab, Keywords field.
OnlyForPrint | True or False (default) | Set to indicate whether the PDF is only for print.
Subject | String | Enter a subject to display in the Adobe Document Properties dialog, Description tab, Subject field.
Title String

Enter a title to display in the Adobe Document Properties dialog, Description tab, Title field.

Set DisplayTitle to True to display this text in the title bar of the Adobe Reader when the document is opened.

Show PDF Security Properties

Property | Valid Values | Description
Encrypt | True or False (default) | Sets or returns a value indicating whether the document is encrypted.
OwnerPassword | String | Enter the string to use as a password that unlocks the document regardless of specified permissions.
Permissions | None, AllowPrint, AllowModifyContents, AllowCopy, AllowModifyAnnotations, AllowFillIn, AllowAccessibleReaders, or AllowAssembly | Combine multiple values by dropping down the selector and selecting the check boxes of any permissions you want to grant. By default, all of the permissions are granted.
Use128Bit | True (default) or False | Set to False to use 40 bit encryption with limited permissions. (Disables AllowFillIn, AllowAccessibleReaders, and AllowAssembly permissions.)
UserPassword | String | Enter the string to use as a password that unlocks the document using the specified permissions. Leave this value blank to allow anyone to open the document using the specified permissions.

PDF Print Presets Properties

ActiveReports allows you to preset the printing properties for PDF report exports using the PrintPresets class. This prepopulates the print settings in the Print dialog box. Please see Use PDF Printing Presets for more information.

Note: The print preset properties are only available with the Professional Edition license. An evaluation message is displayed when used with the Standard Edition license.

Property | Description
PageScaling | Specify scaling for the printable area.You can select Default to shrink to the printable area, or you can select None for the actual size.
DuplexMode

Specify the duplex mode of the printer. For the best results with the duplex option, the selected printer should support duplex printing. You can choose from the following values,

  • Simplex: Prints on one side of the paper. This is the default value.
  • Duplex (Flip on long edge): Prints on both sides of the paper with paper flip on the long edge.
  • Duplex (Flip on short edge): Prints on both sides of the paper with paper flip on the short edge.
PaperSourceByPageSize | Determines the output tray based on PDF page size, rather than page setting options. This option is useful when printing PDFs with multiple page sizes, where different sized output trays are available. By default, this option is set to False.
PrintPageRange | Specify the range of page numbers as 1-3 or 1, 2, 3.
NumberOfCopies | Specify the number of copies to print. You can select any number of copies from 2 to 5, or select Default to specify a single copy.

Note: These properties are available in PDF version 1.7 or higher. The PageScaling property is supported in PDF version 1.6.

See Also

Exporting Reports using Export Filters
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Text Export

Text Export
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters > Text Export

Glossary Item Box

Show All Show All
Hide All Hide All

Plain Text is a format that opens in Notepad or Microsoft Excel depending on the file extension you use in the filePath parameter of the Export method. Use the extension .txt to open files in Notepad, or use .csv to open comma separated value files in Excel. The Text export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the TextExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Xml.dll

Show Text Export Properties

Property | Valid Values | Description
Encoding | System.Text.ASCIIEncoding (default), System.Text.UnicodeEncoding, System.Text.UTF7Encoding, or System.Text.UTF8Encoding | This property can only be set in code. Enter an enumerated system encoding value to use for character encoding.
PageDelimiter | String | Enter a character or sequence of characters to mark the end of each page.
QuotationSymbol | Char | Enter a character to use as quotation mark in the exported text file. Only fields with delimiter characters are quoted.
SuppressEmptyLines | True (default) or False | Set to False if you want to keep empty lines in the exported text file. Otherwise, white space is removed.
TextDelimiter | String | Enter a character or sequence of characters to mark the end of each text field. This is mainly for use with CSV files that you open in Excel.

Text

Usage:

  • Create plain text files
  • Create comma (or other character) delimited text files
  • Feed raw data to spreadsheets or databases
  • Open in Notepad or Excel (comma delimited)

Does not support anything but plain fields and labels:

  • Supports plain text only with no formatting other than simple delimiters
  • Supports encoding for foreign language support

See Also

Exporting Reports using Export Filters
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


RTF Export

RTF Export
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters > RTF Export

Glossary Item Box

RTF, or RichText format, opens in Microsoft Word, and is native to WordPad. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats.

You can set the property either in code using the RTFExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Word.dll

Usage:

  • Create word-processing files
  • Open in Word or WordPad

Does not support:

  • Section or Page back colors
  • Angled text

See Also

Exporting Reports using Export Filters
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Excel Export

Excel Export
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters > Excel Export

Glossary Item Box

Show All Show All
Hide All Hide All

XLSX is a format that opens in Microsoft Excel as a spreadsheet. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats. The XLSX export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the XLSExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Excel.dll

Show Excel Export Properties

Property | Valid Values | Description
AutoRowHeight | True or False (default) | Set to True to have Excel set the height of rows based on the contents. Otherwise XlsExport calculates the height of rows. In some cases this may make the output look better inside Excel. However, a value of True may adversely affect pagination when printing, as it may stretch the height of the page.
DisplayGridLines | True (default) or False | Set to False to hide grid lines in Excel.
FileFormat | Xls97Plus (default) or Xls95 or Xlsx | Set to Xls95 to use Microsoft Excel 95, Xls95Plus to use Microsoft Excel 97and Xlsx to use Microsoft Excel 2007 or newer.
MinColumnWidth | Single (VB) or float (C#) | Set the number of inches that is the smallest width for a column in the exported spreadsheet. Tip: Larger values reduce the number of empty columns in a sheet. Set this value to 1 inch or more to get rid of small empty columns.
MinRowHeight | Single (VB) or float (C#) | Set the number of inches that is the smallest height for a row in the exported spreadsheet. Tip: Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space. Set this value to .25 inches or more to get rid of small empty rows.
MultiSheet | True or False (default) | Set to True to export each page of your report to a separate sheet within the Excel file. This can increase performance and output quality at the cost of memory consumption for reports with complex pages and a lot of deviation between page layouts. In general, use False for reports with more than 30 pages.
PageSettings |  | Set a print orientation and paper size of Excel sheet.
RemoveVerticalSpace | True or False (default) | Set to True to remove vertical empty spaces from the spreadsheet. This may improve pagination for printing.
Security |  | Set a password and username to protect the excel spreadsheet.
UseCellMerging | True or False (default) | Set to True to merge cells where applicable.
UseDefaultPalette | True or False (default) | Set to True to export document with Excel default palette.

Usage:

  • Create spreadsheets
  • Open in Microsoft Excel

Does not support:

  • Line control
  • Shapes (other than filled rectangles)
  • CrossSectionBox and CrossSectionLine controls
  • Overlapping controls
  • Borders on controls with angled text
  • Angled text
  • CheckBox control (only its text element is exported)

See Also

Exporting Reports using Export Filters
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


TIFF Export

TIFF Export
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters > TIFF Export

Glossary Item Box

Show All Show All
Hide All Hide All

TIFF, or tagged image file format, opens in the Windows Picture and Fax Viewer or any TIFF viewer. This export looks very much like the report as it displays in the viewer, but it is a multi-page image, so the text cannot be edited. The TIFF export filter has a couple of useful properties that allow you to control your output. You can set the properties either in code using the TIFFExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Image.dll

Show TIFF Export Properties

Property | Valid Values | Description
CompressionScheme None, Rle, Ccitt3 (default), Ccitt4 or Lzw

Select an enumerated value to use for color output control:

  • None delivers color output with no compression.
  • Rle (run-length encoding) is for 1, 4, and 8 bit color depths.
  • Ccitt3 and Ccitt4 are for 1 color depth, and are used in old standard faxes.
  • Lzw (based on Unisys patent) is for 1, 4, and 8 bit color depths with lossless compression.
Dither | True or False (default) | Set to True to dither the image when you save it to a black and white format (Ccitt3, Ccitt4 or Rle). This property has no effect if the CompressionScheme is set to Lzw or None.
DpiX Integer (VB) or int (C#) greater than 0

Set the horizontal resolution of a report when exporting to TIFF format. The default value is 200.

Setting the DpiX or DpiY property to large values can cause the rendered image to be too large and not enough memory in system can be allocated to the bitmap.
DpiY Integer (VB) or int (C#) greater than 0

Set the vertical resolution of a report when exporting to TIFF format. The default value is 196.

Setting the DpiX or DpiY property to large values can cause the rendered image to be too large and not enough memory in system can be allocated to the bitmap.

Usage:

  • Create optical archive reports
  • Send reports via fax machines
  • Open in image viewers
  • Generates an image of each page. 100% WYSIWYG.

See Also

Exporting Reports using Export Filters
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Exporting Reports using Export Filters

Exporting Reports using Export Filters
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Export Filters > Exporting Reports using Export Filters

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides various export filters that can be used to export Page, Section and Rdl Reports to the supported file formats. Here are the export formats that are included with ActiveReports:

  • HTML For displaying on Web browsers or e-mail. You can access the HTML Export filter by adding the reference to GrapeCity.ActiveReports.Export.Html.dll in your project.
  • PDF For preserving formatting on different computers. You can access the PDF Export filter by adding the reference to GrapeCity.ActiveReports.Export.Pdf.dll in your project.
  • RTF For preserving some formatting, but allowing reports to be opened with Word or WordPad. You can access the RTF Export filter by adding the reference to GrapeCity.ActiveReports.Export.Word.dll in your project.
  • Text For transmitting raw data, with little or no formatting. You can access the Text Export filter by adding the reference to GrapeCity.ActiveReports.Export.Xml.dll in your project.
  • TIFF For transmitting faxes. You can access the Image Export filter by adding the reference to GrapeCity.ActiveReports.Export.Image.dll in your project.
  • Excel For displaying as spreadsheets. You can access the Excel Export filter by adding the reference to GrapeCity.ActiveReports.Export.Excel.dll in your project.
Note: In ActiveReports, by default, the assemblies are located in the ...\Common Files\GrapeCity\ActiveReports 13 folder.

Use the following steps to export reports through export filters. These steps assume that you have already created a Windows Application and added the export controls to your Visual Studio toolbox. For more information, see Adding ActiveReports Controls.

To export a report

  1. In your project's Bin>Debug folder, place the report.rpx (Section Report) or report.rdlx (Page/Rdl Report).
  2. In the Solution Explorer, right-click the References node and select Add Reference.
  3. In the Reference Manager dialog that appears, select the following references and click OK to add them to your project.
    GrapeCity.ActiveReports.Export.Excel
    GrapeCity.ActiveReports.Export.Html
    GrapeCity.ActiveReports.Export.Image
    GrapeCity.ActiveReports.Export.Pdf
    GrapeCity.ActiveReports.Export.Word
    GrapeCity.ActiveReports.Export.Xml
  4. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  5. In Form_Load event, add the following code to add a report to your project.

    Show To add Page/Rdl report to your project

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    ' Create a page/Rdl report.
Dim rpt As New GrapeCity.ActiveReports.PageReport()
' Load the report you want to export.
' For the code to work, this report must be stored in the bin\debug folder of your project.
rpt.Load(New System.IO.FileInfo ("report.rdlx"))
Dim MyDocument As New GrapeCity.ActiveReports.Document.PageDocument (rpt)
    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a page/Rdl report.
GrapeCity.ActiveReports.PageReport rpt = new GrapeCity.ActiveReports.PageReport();
// Load the report you want to export.
// For the code to work, this report must be stored in the bin\debug folder of your project.
rpt.Load(new System.IO.FileInfo ("report.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument MyDocument = new GrapeCity.ActiveReports.Document.PageDocument (rpt);

    Show To add Section report to your project

    Visual Basic.NETcode. Paste INSIDE the Form_Load event. Copy Code
    ' Create a Section report.
    Dim rpt As New GrapeCity.ActiveReports.SectionReport()
    ' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
    Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
    rpt.LoadLayout(xtr)
    rpt.Run()
    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Create a Section report.
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();
  6. Add the following code to export Page, Rdl and Section Reports to multiple format.
    This code is common for all the report types (.rpx and .rdlx).

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    ' Export the report in HTML format.
Dim HtmlExport1 As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport()
HtmlExport1.Export(MyDocument, Application.StartupPath + "\HTMLExpt.html")

' Export the report in PDF format.
Dim PdfExport1 As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport()
PdfExport1.Export(MyDocument, Application.StartupPath + "\PDFExpt.pdf")

' Export the report in RTF format.
Dim RtfExport1 As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport()
RtfExport1.Export(MyDocument, Application.StartupPath + "\RTFExpt.rtf")

' Export the report in text format.
Dim TextExport1 As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport()
TextExport1.Export(MyDocument, Application.StartupPath + "\TextExpt.txt")

' Export the report in TIFF format.
Dim TiffExport1 As New GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport()
TiffExport1.Export(MyDocument, Application.StartupPath + "\TIFFExpt.tiff")

' Export the report in Excel format.
Dim XlsExport1 As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
' Set a file format of the exported excel file to Xlsx to support Microsoft Excel 2007 and newer versions.
XlsExport1.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx
XlsExport1.Export(MyDocument, Application.StartupPath + "\XLSExpt.xlsx")

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    // Export the report in HTML format.
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport HtmlExport1 = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
HtmlExport1.Export(MyDocument, Application.StartupPath + "\\HTMLExpt.html");

// Export the report in PDF format.
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport PdfExport1 = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
PdfExport1.Export(MyDocument, Application.StartupPath + "\\PDFExpt.pdf");

// Export the report in RTF format.
GrapeCity.ActiveReports.Export.Word.Section.RtfExport RtfExport1 = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
RtfExport1.Export(MyDocument, Application.StartupPath + "\\RTFExpt.rtf");

// Export the report in text format.
GrapeCity.ActiveReports.Export.Xml.Section.TextExport TextExport1 = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
TextExport1.Export(MyDocument, Application.StartupPath + "\\TextExpt.txt");

// Export the report in TIFF format.
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport TiffExport1 = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
TiffExport1.Export(MyDocument, Application.StartupPath + "\\TIFFExpt.tiff");

// Export the report in XLSX format.
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport XlsExport1 = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
// Set a file format of the exported excel file to Xlsx to support Microsoft Excel 2007 and newer versions.
XlsExport1.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx;
XlsExport1.Export(MyDocument, Application.StartupPath + "\\XLSExpt.xlsx");
    Note: When exporting a report to .MHT file by Export filters use htmlExport.Export(Document doc, Stream outputStream);
    For more information, see HTML Export Method.
  7. Press F5 to run the application. The exported files are saved in the bin\debug folder.
    Caution: To be able to successfully compile application in Visual Studio 2012, you need to edit app.config file as follows:
    • If target framework version of the sample is 4.6.2:
      <dependentAssembly>
              <assemblyIdentity name="System.IO.Compression" culture="neutral" publicKeyToken="b77a5c561934e089"/>
              <bindingRedirect oldVersion="0.0.0.0-4.2.0.0" newVersion="4.0.0.0"/>
      </dependentAssembly>
    • If target framework version is 4.7.0 or higher:
      <dependentAssembly>
              <assemblyIdentity name="System.IO.Compression" culture="neutral" publicKeyToken="b77a5c561934e089"/>
              <bindingRedirect oldVersion="0.0.0.0-4.2.0.0" newVersion="4.2.0.0"/>
      </dependentAssembly>

See Also

Exporting
Export Filters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Font Linking

Font Linking
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Font Linking

Glossary Item Box

Font linking helps resolve the situation when fonts on a deployment machine do not have the glyphs that are used in a development environment. When you find such a glyph mismatch, there is a possibility that the PDF output on development and deployment machines may be different.

In order to resolve this issue, the PDF export filter or the PDF rendering extension looks for the missing glyphs in the installed fonts as follows:
  • Checks the system font link settings for each font that is used in the report. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink registry key stores the information on font links.
  • If font links are not set or the needed glyphs are not found, searches for the glyphs in the fonts declared in the FontFallback Property.
  • Uses glyphs from the font links collection to replace fonts that do not have their own declared linked fonts.
  • If necessary glyphs are not found by font links or in the fonts declared in the FontFallback property, glyphs from Microsoft Sans Serif font are taken as the predefined font.
Note: Font Linking is only possible in the Professional Edition of ActiveReports.

See Also

PDF Export

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Font Factory (Pro Edition)

Custom Font Factory (Pro Edition)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Exporting > Custom Font Factory (Pro Edition)

Glossary Item Box

Show All Show All
Hide All Hide All

Typically, when using PDF export filters and drawing extensions in a Medium trust level environment or Azure web application, ActiveReports does not have access to the System Fonts folder due to security restrictions. Therefore, if your reports use special glyphs or non-ASCII characters that are only found in certain fonts, the PDF output may be incorrect on some machines.

The ActiveReports custom font factory allows you to embed any fonts you need in PDF in the Medium trust environment. To deploy the necessary fonts with your Medium trust solution, you must add the used font files in the specific folder and set up your web.config file.

ActiveReports looks for the custom fonts in the order as follows:

  1. A font specified in the control.
  2. A mapped specified font in the Substitute setting.
  3. A font specified in the the AddFontLink setting (Pro Edition only).
  4. A font specified in the SetFallbackFont setting (Pro Edition only).

Notice that you need to copy the required font files (.ttc, .ttf) manually into the font folder you are accessing.

Custom Font Factory in Windows Azure

For your Azure project, you need to set the properties for all fonts in the project Fonts folder as follows:

  1. Set Copy to Output Directory to Copy always.
  2. Set BuildAction to Content.

To add a font factory section group

XML code. Paste INSIDE the configSections tags of the web.config file. Copy Code
<sectionGroup name="ActiveReports.PdfExport">
<section name="FontFactory"
    type="GrapeCity.ActiveReports.Web.FontFactorySectionHandler,
    GrapeCity.ActiveReports.Web,
    Version=13.0.15823.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff"
    requirePermission="false" />
</sectionGroup>

To create a font factory

Required fonts or the folder containing the required fonts are set in the font factory. Paste code like the following after the configSections tag, but before the appSettings tag.

Note: Please make the required changes for the font that you wish to use. In case of the following sample code, create a Font folder and copy the required font files (arial.ttf, tahoma.ttf, msgothic.ttc, simsun.ttc, gulim.ttc, mingliu.ttc, micross.ttf).
XML code. Paste between configSections and appSettings tags of the web.config file. Copy Code
<ActiveReports.PdfExport>
    <FontFactory Mode="File">
        <AddFolder VirtualPath="~/Fonts" Recurse="true"/>
        <Substitute Font="Helv" To="Helvetica"/>
        <SetFallbackFont Font="Arial"/>

        <!-- font link nodes -->
        <AddFontLink Font="Arial" List="SimSun,gulim,PMingLiU"/>
        <AddFontLink Font="Tahoma" List="MS UI Gothic,SimSun,gulim,PMingLiU"/>
        <AddFontLink Font="MS UI Gothic" List="SimSun,gulim,PMingLiU,Microsoft Sans Serif" IsDefault="true"/>

    <!-- EUDC link nodes -->
           <DefaultEudcFont File="EUDC.tte"/>
           <AddEudcFont Font="MS UI Gothic" File="myEUDC1.tte"/>
           <AddEudcFont Font="Meiryo" File="myEUDC2.tte"/>
    </FontFactory>
</ActiveReports.PdfExport>
Note: For the Azure worker role project, use an absolute path instead of a virtual path in the code above: <AddFolder Path="~/Fonts" Recurse="true"/>.

As shown in the previous code, you can embed end-user defined characters (EUDCs) in the PDF output by modifying the web.config file settings by deploying an EUDC file (.tte) to any location.

Configuration settings

Show EUDC configuration settings

Element | Description
DefaultEUDCFont | This is the node, like the SystemDefaultEudcFont entry in the registry file, that contains the default EUDC font settings.
DefaultEUDCFont File | Specifies the file name of the default EUDC file.
AddEudcFont | This is the node that associates the EUDC file and the fontname. This node can be added more than once.
AddEudcFont Font | Specifies the font name.
AddEudcFont File | Specifies the file name of the EUDC file to associate the above font.

Show FontFactory

Description: This is the main font factory node to which you can add fonts.

Attributes

Element | Description
Mode | Setting the Mode attribute to File allows to use a file based factory, or remove the attribute for a Windows GDI factory.

Child Elements

None.

Parent Elements

Element | Description
ActiveReports.PdfExport | The assembly that contains the PdfExport namespace (PDF export, document options, and security classes).

Example

<FontFactory Mode="File">

Show AddFolder

Description: Adds all TrueType fonts (.ttc, .ttf) from the specified folder.

Attributes

Element | Description
Path | Specifies the absolute path to the folder.
VirtualPath | Specifies the relative path to the folder.
Recurse | When set to True, it can read the subfolder. When set to False, it cannot read the subfolder.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

<AddFolder VirtualPath="~/Fonts" Recurse="true"/>

Show Substitute

Description: Maps an alternate name of fonts to their official names.

Attributes

Element | Description
Font | Specifies the abbreviated font name (e.g. "Helv").
To | Specifies the official font name (e.g. "Helvetica").

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <Substitute Font="Helv" To="Helvetica"/>

Show SetFallbackFont (Professional Edition only)

Description: In the Professional Edition, sets the font to use if a) the specified font is not installed, b) the Substitute font is not specified or not installed, or c) the font links are not set or the needed glyphs are not found in the AddFontLink setting.

Attributes

Element | Description
Font | Specifies the font name.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <SetFallbackFont Font="Arial"/>

Show AddFontLink (Professional Edition only)

Description: In the Professional Edition, there is the extra support for CJK glyphs. You can add font links that allow the PdfExport to look up any glyphs missing from the specified font in the list of other fonts to check.

Attributes

Element | Description
Font

Specifies the font used in the reports.
List Specifies the comma-separated list of fonts to be used in case the glyph is not found.
Caution: The character style of the link won't be outputted in case the alternate font file does not exist in the specified folder of the AddFolder setting.
IsDefault | When set to True, indicates to use the specified list for any fonts that do not have their own font links.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <AddFontLink Font="Tahoma" List="MS UI Gothic,SimSun,gulim,PMingLiU"/>

See Also

PDF Export

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Visual Query Designer

Visual Query Designer
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Visual Query Designer

Glossary Item Box

  • Access the Visual Query Designer
  • Elements of Visual Query Designer

Visual Query Designer is a graphical interface that simplifies data binding by allowing users to interactively build queries and view the results. With the Visual Query Designer's interactive interface, users who are unfamiliar with SQL can easily design, edit and preview queries.

Visual Query Designer supports the following SQL capabilities:

  • Selecting fields
  • Custom expression
  • Inner, left outer and right outer joins
  • Filtering Data
  • Grouping and aggregate functions
  • Sorting
  • Setting aliases for the selected fields and tables

For more information on how to use these capabilites in Visual Query Designer, refer to Query Building With Visual Query Designer.

Note: You need to have Microsoft Internet Explorer 9 or higher installed on the system to run the Visual Query Designer.

See the graphic below to understand how a simple SQL query is generated in the Visual Query Designer.

Limitations
  1. Queries for XML, Object, DataSet Provider or any other specific data providers cannot be created in Visual Query Designer.
  2. Unions, nested queries and stored procedures are not supported in Design Tab.
  3. Crosses, full joins, provider-specific joins, and other SQL-specific implementation capabilities are not supported in the Design Tab.

Accessing the Visual Query Designer

  1. Connect a Page/RDL Report to a data source. See Connect to a Data Source for details on how to connect to a data source in Page/Rdl Reports and Bind Reports to a Data Source for Section Reports.
  2. Right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set from the Add button on the Report Explorer toolbar to add a data set to the report.
  3. In the DataSet Dialog that appears, select the Query page and then select the edit with visual query designer button [image] .

    This opens the Visual Query Designer in a Page Report or Rdl Report.

In a Section Report

  1. Connect a Section Report to a data source through the Report Data Source dialog. The Query Designer button is disabled until the report connects to a data source. For more information see, Bind Reports to a Data Source.

  2. Once enabled, click the [image] button.

    This opens the Visual Query Designer in a Section Report.

Elements of Visual Query Designer

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Database View

Database View contains the structure of a database including namespaces, tables, views and columns. You can drag and drop or double click the elements in the Database View to add them to the Design tab. Alternatively, you can double click the crossed arrows icon on the right hand side of each element in the Database View to add it to the Design tab.

This is the first step in query building through the Visual Query Designer. A SQL query is generated as you add the database elements to the Design tab.

Query Tools

The Visual Query Designer provides several tools to generate a query. The Query Tools section is divided into three major areas: Design tab, SQL tab and Toolbar buttons.

Design Tab

The Design tab is the area of the Visual Query Designer where you set up queries. It provides a visual interface for the SQL query you want to generate.

  • Selected Fields panel

    Displays the fields, tables or any other element selected from the Database view. Each field in the Selected Fields panel has its own set of editable options.

    Option | Description
    Output

    Checkbox to determine whether the field is included in the result set. The checkbox is selected by default when a field is added to the Selected Fields panel. You can clear this checkbox if you do not want the field to be displayed in the Results panel.
    Table | Displays the name of the table the selected field belongs to.
    Alias | Allows the user to provide an alternative name for the field.
    Total

    Applies grouping or aggregates on a field. Total (expression) is used to perform a calculation, retrieve the value of a control, define regulations, create calculated fields, and define a group level for a report.

    • Expression - Allows selection of fields from a table. Custom expressions can also be specified here.
    • GroupBy - Groups data based on the selected field.
    • Count - Returns the number of items in a group. Implements the SQL COUNT aggregate.
    • Avg - Returns the average of the values in a group. Implements the SQL AVG aggregate.
    • Sum - Returns the sum of all the values in the group. Implements the SQL SUM aggregate.
    • Min - Returns the minimum value in a group. Implements the SQL MIN aggregate.
    • Max - Returns the maximum value in a group. Implements the SQL MAX aggregate.
    • StDev - Returns the statistical standard deviation of all values in a group. Implements the SQL STDEV aggregate.
    • Var - Returns the statistical variance of all values in the group. Implements the SQL VAR aggregate.
    Sort | Arranges data in a prescribed sequence i.e. in Ascending or Descending order.
    Sort Order | Allows the user to set the order of sorting in case multiple fields are to be sorted.
    Where | Allows the user to set a filtering condition for the column data. The WHERE clause can be used when you want to fetch any specific data from a table omitting other unrelated data.
    Note: When you add a table to the Selected Fields panel, all the fields in that table are added to the query. In effect you get a query like Select * from Customers.
  • Tables and Relationships

    The Tables and Relationships panel displays a list of all the tables with fields in the Selected Fields panel. In case the Selected Fields panel has fields from multiple tables, a Relations button appears at the bottom of the related table's name to show the relationship between two tables.

    Tables and Relationships panel provides the following options for each table:

    Option | Description
    Table | Displays the names of all the tables with fields in the Selected Fields panel.
    Alias | Allows the user to provide an alternative name for the table.

SQL Tab

The SQL Tab displays the SQL statement for the current query. Users can edit the query directly in the SQL Tab.

When you switch to the SQL Tab, the Visual Query Designer automatically formats your query in the correct syntax with highlighted keywords.

In the SQL Tab you can:

  • Add new queries by directly typing SQL statements.
  • Modify the SQL statement created by Visual Query Designer.

Tool Bar Buttons

Option | Description
Distinct Checkbox | Distinct Checkbox is used to remove duplicates from the result set of a SELECT statement. If checked, it allows users to display only distinct values.
Execute | Allows users to execute their query and display the result in Results panel.
Save | Allows users to save the query to a DataSet dialog.
Clear | Allows users to clear all the panels in the Visual Query Designer and the SQL tab along with it.

The Query Tools section also has a dropdown on the top right corner with two options:

  1. Toggle Panels: To expand or collapse the Selected Fields and the Tables and Relationships panel.
  2. Show Hints: To show or hide hints on how to use the Visual Query Designer effectively.
    Example: "Double click the table or field name in the database view or drag and drop it here." appears at the top of the Selected Fields panel.

Result panel

Displays the result of the query set in the Visual Query Designer.

This panel is populated when you click the Execute button on the Visual Query Designer toolbar after adding the required fields or tables in the Selected Fields panel.

Go to Top

See Also

Tables And Relations
Query Building With Visual Query Designer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Query Building With Visual Query Designer

Query Building With Visual Query Designer
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Visual Query Designer > Query Building With Visual Query Designer

Glossary Item Box

The topic takes you through the query building process in the Visual Query Designer. Query building in Visual Query Designer can be accomplished in a few simple steps:

Step 1: Adding fields from a table to generate a simple query

Step 2: Setting relationships (only applicable to queries using multiple tables)

Step 3: Setting options for individual fields or tables

Step 4: Executing a query

Step 5: Previewing a query

  • Create and Execute a Query (Single Table)
  • Create and Execute a Query (Multiple Tables)
  • Preview a Query
  • Save a Query
  • Edit a Query
  • Clear a Query
  • Access the Visual Query Designer
  • Delete a field
  • Sort data
  • Display Distinct Values
  • Aggregate Functions and Grouping
  • Hide Fields from a Query
  • Set filter condition
  • Create a parameterized query

The following steps assume that you have already added a Page Report or an Rdl Report template and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.
For more information on how to access Visual Query Designer, see Accessing Visual Query Designer.

Note: This topic uses the Reels database. By default, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

Create and Execute a Query (Single Table)

Go to Top

In the Visual Query Designer, you get a visual interface to assist you in quickly designing simple queries that reference a single table.

Query Result in SQL

SQL Query Copy Code
select Movie.MovieID, Movie.Title
from Movie

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the field MovieID to the Selected Fields panel.

  2. Add another field, Movie.Title from the same table, to the Selected Fields panel.
  3. On the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Create and Execute a Query (Multiple Tables)

Go to Top

In the Visual Query Designer, you get a visual interface to reference multiple tables and set up relationships between them.

The following example shows how to implement a right outer join using the tables Movie and MovieCrew from Reels database and apply a filter condition to your result set using the WHERE clause. For more information about table relationships and joins in Visual Query Designer, see Tables and Relations.

Query Result in SQL

SQL Query Copy Code
select Movie.MovieID, Movie.Country, Movie.Title, MovieCrew.CastID,
MovieCrew.TitleID from Movie right join MovieCrew on
MovieCrew.MovieID = Movie.MovieID
where (Movie.Country = 'USA' and MovieCrew.CastID =1)

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the fields MovieID, Country and Title to the Selected Fields panel.
  2. From the MovieCrew table in Database view, drag and drop the fields CastID and TitleID to the Selected Fields panel.
  3. When you add the first field in step 2, a Tables relations dialog automatically appears on the screen.
    In Tables relations dialog, you can also select any other field from MovieCrew table which matches the related table's field to form a join between the both.
  4. In Tables relations dialog, select the Right Outer Join Type for joining the two tables Movie and Movie Crew. The Right Outer tab is highlighted.
    Refer to Tables And Relations for more information on types of joins.

  5. In Tables relations dialog, click OK to save the relationship between tables.
    Once the relationship has been set up between tables, you may also access the Tables relations dialog from the Relations button in the Tables and Relationships panel.
  6. In the Selected Fields panel, under the Where option, add a filter condition for the Country field of the Movie table. Set the value to "= 'USA'".
  7. Again, in the Selected Fields panel, under the Where option, add a filter condition for the CastID field of the MovieCrew table. Set the value to "= 1".
  8. On the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Preview a Query

Go to Top

When you have finished designing your query, you can execute it and then preview the result in the Visual Query Designer.

  1. In the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button.

    You can preview the result in the Results panel at the bottom of the Visual Query Designer dialog.

Note: When previewing a query, Visual Query Designer shows only a part of the data from the database.

Save a Query

Go to Top

Page Report/Rdl Report

Once a query is created in the Visual Query Designer, the Save button allows you to save the query into the DataSet dialog.

  1. Once your query is created in Visual Query Designer, in the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button. Your query appears in Query field of the Query page in the DataSet dialog.
  3. Click OK to close the dialog.
    Your data set and queried fields appear as nodes in the Report Explorer.

Section Report

Once a query is created in the Visual Query Designer, the Save button allows you to save the query into the Report Data Source dialog.

  1. Once the query is created in Visual Query Designer, in the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button.
    Your query appears in Query field of the Report Data Source dialog.
  3. Click OK to close the dialog. Your queried fields appear as bound field nodes in the Report Explorer.

Clear a Query

Go to Top

Once a query is created, the Selected Fields panel is populated with fields and Tables and Relationship panel displays the tables to which the fields used in the query belong.

  1. In the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button.

    This clears the Query Tools section completely including Selected Fields and Tables and Relationships panel. It also removes the SQL query from the SQL tab and any data appearing in the Results panel.

Edit a Query

Go to Top

There are two ways to edit a query in the Visual Query Designer:

  • Edit a query created in the Visual Query Designer directly in the SQL tab.

    Follow the steps below to edit a query created in the Visual Query Designer manually in the SQL:
  1. From the Movie table in Database view, drag and drop the fields MovieID and Title onto the Selected Fields panel.
  2. Under Query Tools, switch to the SQL tab to edit the query manually.

  3. Enter the field name Movie.Length in the SQL tab.
    SQL Query Copy Code
    select Movie.MovieID, Movie.Title, Movie.Length
from Movie
  4. On the Toolbar of the Visual Query Designer, click the Execute button.

    The additional Length column appears in Results panel.

  • Edit an existing SQL query in the Visual Query Designer.

    This approach has some limitations based on the type of queries that can be handled in the Visual Query Designer.

  • Assuming that a query like the following already exists in the Data Set dialog of a Page/Rdl Report or the Report Data Source dialog of a Section Report, follow the steps below to edit it in the Visual Query Designer.
    SQL Query Copy Code
    select Movie.MovieID, Movie.Title
from Movie
  1. Open the Visual Query Designer and under Query Tools, go to the SQL tab. Notice that the SQL query is already present in the this tab.
  2. Go to the Design tab and notice that the Selected Fields panel already contains the fields MovieID and Title.
  3. From the Database view, drag and drop a field, Length from the Movie table onto the Selected Fields panel.
  4. Go to the SQL tab again and see that the query now appears as follows:
    SQL Query Copy Code
    select Movie.MovieID, Movie.Title, Movie.Length
from Movie
  5. On the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Delete a field

Go to Top

You can delete any field from a query in the Visual Query Designer. When you delete a field from a query, the field remains in the database, but is no longer used in the query.

  1. From the Movie table in the Database view, drag and drop the fields MovieID, Country and Title onto the Selected Fields panel.
  2. Hover your mouse over the MovieID field in Selected Fields panel to display the Delete icon.
  3. Click the Delete icon to delete the field.
    Please note that once you delete a field, it is also removed from the SQL query in the SQL tab.

Sort data

Go to Top

You can sort the records in a table, query, form, or a report on one or more fields in the Visual Query Designer. For example, you can sort the Movie table by Title in ascending order and Country in descending order. In case multiple fields are being sorted, you can also determine which field is sorted first and which is sorted later.

Query Result in SQL

SQL Query Copy Code
select Movie.MovieID, Movie.Title, Movie.Countryfrom Movieorder by Movie.Country desc, Movie.Title asc

Steps to create the Query in Visual Query Designer

  1. In the Database view, from the Movie table, drag and drop the fields MovieID, Title and Country onto the Selected Fields panel.
  2. In the Selected Fields panel, go to the Title field and set the Sort option to ascending. Sort Order option is automatically set to 1.
  3. Go to the Country field next and set the Sort option to ascending. Sort Order option is automatically set to 2.
    Based on steps 2 and 3, the table values sort on the Title field first and then on the Country field in ascending order.
  4. In Country field, change the Sort Order value to 1. Sort Order value of the Title field automatically changes to 2.
    The table values now sort on the Country field first in and then on the Title field in ascending order.
  5. In the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Display Distinct Values

Go to Top

When retrieving data from a table, you may get duplicate records. Use the Distinct operator in the Select statement of your query to remove such values.

In the Visual Query Designer, you can use the Distinct checkbox available in the Toolbar to eliminate duplicate records. For example, you can retrieve unique records from YearReleased field of the Movie table.

Query Result in SQL

SQL Query Copy Code
select DISTINCT Movie.Title, Movie.YearReleased
from Movie

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the Title and YearReleased fields onto the Selected Fields panel.
  2. In the Toolbar of the Visual Query Designer, check the [image] checkbox to display unique values from the YearReleased field.
  3. Click the Execute button.

    Result data similar to the following appears in Results panel.

Aggregate Functions and Grouping

Go to Top

You can group data on a field and create an aggregate query that involves a function such as Sum or Avg in the Visual Query Designer. For example, you can group the movies in the Movie table by Country and calculate the average movie ratings for different countries using the Visual Query Designer.

Query Result in SQL

SQL Query Copy Code
select Movie.Country, Avg(Movie.UserRating) as [Average Ratings]
from Movie group by Movie.Country

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the Country and UserRating fields onto Selected Fields panel.
  2. In the Selected Fields panel, under the Country field, select GroupBy from the Total dropdown list. This groups the data by country name.
  3. In the Selected Fields panel under the UserRating field, select the option Alias and set its alternate name to Average Ratings.
  4. Under the UserRating field again, select Avg from a list of pre-defined aggregate functions in the Total dropdown list. This provides average user ratings for movies.
  5. In the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Hide Fields from a Query

Go to Top

The Hide option in the Visual Query Designer allows you to hide part of the data that a query retrieves. For example, you can hide the MovieID field in the Movie table, from the result set of your query.

Follow the steps below to hide a field through the Visual Query Designer:

  1. From the Movie table in the Database view, drag and drop the fields Title, UserRating and Country onto the Selected Fields panel.
  2. In the Selected Fields panel, go to the Country field and select the Where option and set it's value to " = 'USA' "
  3. In the Selected Fields panel, go to the Title field and set the value of the Alias option to Movies from USA.
  4. Clear the Output check box for the Country field as shown in the image below to hide the field from the result set.

  5. In the Toolbar of the Visual Query Designer, click the Execute button.

    The data for the Country field does not appear in the in the Results panel anymore.

Set filter condition

Go to Top

The SQL Where clause is used to filter results that match a given criteria. The Where clause can be used when you want to fetch any specific data from a table omitting other unrelated data.

For example if you want to display UserRating of only those movies where the MovieID is either 1 or 2, you can use the Where clause with an '=' operator in the Visual Query Designer.

Query Result in SQL

SQL Query Copy Code
select Movie.MovieID, Movie.UserRating
from Movie
where (Movie.MovieID = 1 or Movie.MovieID = 2)

Steps to create the Query in Visual Query Designer

  1. Form the Movie table in Database view, drag and drop the MovieID and UserRating fields onto the Selected Fields panel.
  2. In the Selected Fields panel under the MovieID field, select the Where option and set the value to "=1".
  3. Add an OR condition in MovieID field and set the value to "=2".

    Rows which have either have MovieID = 1 or MovieID = 2 are displayed in the Result set.
  4. In the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Create a parameterized query

Go to Top

You can set parameters in your query using the Visual Query Designer. A parameterized query generally prompts the user to enter a value before the query is executed, to determine the type of data to be displayed in the result set.

As an example of a simple parameterized query, you can create a query parameter that prompts a user for a Movie ID and displays the Title, UserRating and Length of the movie based on the ID entered.

Query Result in SQL

SQL Query Copy Code
select Movie.MovieID, Movie.Title, Movie.Country, Movie.UserRating
from Movie
where Movie.Country = ?

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the MovieID, Title, UserRating and Country fields onto the Selected Fields panel.
  2. In the Selected Fields panel under the Country field, select the option Where and set its value to "= @Country".
    This creates a parameter Country.
  3. In the Toolbar of the Visual Query Designer, click the Execute button. The Parameters dialog automatically appears on the screen.
  4. Enter the parameter value USA in the dialog box and click OK.

    Result data similar to the following appears in Results panel.
Go to Top

See Also

Visual Query Designer
Tables And Relations

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Tables And Relations

Tables And Relations
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Visual Query Designer > Query Building With Visual Query Designer > Tables And Relations

Glossary Item Box

Queries can incorporate fields from different tables. It is the relationship you set up between the data in these tables that determines how the data appears in the result set.

Users can set up these relationships between tables using SQL Joins like Inner Join, Left Join and Right Join in the Visual Query Designer.

  1. Inner Join (simple join) - Inner Join matches rows from Table1 with rows in Table2, and allows the user to retrieve records that show a relationship in both the tables. Inner join produces a set of data that matches both Table1 and Table2.

    Syntax for the SQL Inner Join:
    SELECT columns
    FROM table1
    INNER JOIN table2
    ON table1.column = table2.column;

    Visual Illustration
    SQL Inner Join returns the records where table1 and table2 intersect.
  2. Left Outer Join (left join) - Left Outer Join allows users to select rows that match from both the left and right tables, plus all the rows from the left table (table 1). This means only those rows from table2 that intersect with table1 appear in the result set.

    Syntax for SQL Left Outer Join:
    SELECT columns
    FROM table1
    LEFT [OUTER] JOIN table2
    ON table1.column = table2.column;

    Visual Illustration
    SQL Left Outer Join returns the records from table1 and only those records from table2 that intersect with table1.
  3. Right Outer Join (right join) - Right outer join allows users to select rows that match from the both the left and right tables, plus all the rows from right table (table 2). This means that only those rows from table 1 that intersect with table 2. appear in the result set

    Syntax for SQL Right Outer Join:
    SELECT columns
    FROM table1
    RIGHT [OUTER] JOIN table2
    ON table1.column = table2.column;

    Visual Illustration

    SQL Right Outer Join returns the records from table 2 and only those records from table 1 that intersect with table2.

Tables relations dialog

The Tables relations dialog allows users to set up a relationship between two different tables with at least one common field.

Complete the following steps to access the Tables relations dialog:

  1. In the Visual Query Designer, drag and drop a field or fields from a table in the Database view to the Selection Fields panel.
  2. Add another field from a different table in the Database tab to the Selected Fields panel. Make sure that at least one field between these two tables' matches i.e. the second table contains a foreign key.
  3. When the field in step 2 is added, the Tables relations dialog automatically pops up on the screen.

Once the relationship has been set up between tables, you may also access the Tables relations dialog from the Relations button in the Tables and Relationships panel.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Option | Description
Join Type | Enables selection of an appropriate Join type out of Inner Join, Left Outer Join and Right Outer Join. Example: Inner Join tab is highlighted in the image above.
<Table Name> Field | Displays the name of the field that is common between tables i.e. the foreign key name in the second table. Example: "Products" Field contains the 'Category ID' field in the image above.
Related Table | Displays the name of the table to which the relationship has been set up. Example: 'Categories' table is listed in the image above.
Related Table's Field | Displays the name of the field from the table to which the relationship has been set up. Example: 'Category ID' is the field from the Categories tables listed in the image above.
Delete | Icon adjacent to the Related Table's Field to delete the currently added relation.
Add Relation | Button that allows users to add another relationship to the table.
Cancel | Closes the Tables relations window.
OK | Saves the relationship between tables as a SQL query in the SQL tab.
Go to Top

See Also

Visual Query Designer
Query Building With Visual Query Designer

Walkthroughs
Using the Visual Query Designer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Using the Visual Query Designer

Using the Visual Query Designer
ActiveReports 13 > ActiveReports User Guide > Concepts > Visual Query Designer > Using the Visual Query Designer

Glossary Item Box

The following walkthrough shows how to implement an Inner Join using the tables Categories and Products from the Nwind database. It also explains how to use a parameter and sort data in a Visual Query Designer. You may also see Tables and Relations for more information on table relationships and joins in Visual Query Designer.

Note:

  • This walkthrough uses the Products and Categories table from the NWIND database. By default, in ActiveReports, the NWIND.mdb file is located in [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.
  • This walkthrough uses Page Reports, but the same steps can be used to generate queries in Rdl or Section reports also. See Accessing the Visual Query Designer, for more information on how to access the Visual Query Designer in Rdl and Section reports.
​
  • Add an ActiveReport to a Visual Studio Project
  • Access the Visual Query Designer
  • Create a Query
  • Save a Query
  • View the Report

Add an ActiveReport to a Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as VisualQueryDesigner.
  4. Click the Add button to open a new Page Report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Access the Visual Query Designer

  1. Connect a Page Report to a data source. See Connect to a Data Source for details on how to connect to a data source in Page Reports.
  2. Right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set from the Add button on the Report Explorer toolbar to add a data set to the report.
  3. In the DataSet Dialog that appears, select the Query page and then select the Edit with visual query designer button [image] .
    This opens the Visual Query Designer.

Create a Query

Visual Query Designer provides you with an interface to reference multiple tables, set up relationships, sort the data and add parameters to your query.
Follow the steps below to create a query like the following using the Visual Query Designer.

Query Result in SQL

SQL Query Copy Code
select Products.ProductName, Products.UnitPrice, Categories.CategoryName
from Products inner join Categories on Products.CategoryID = Categories.CategoryID
where Categories.CategoryName = ?
order by Products.UnitPrice desc

Steps to create a Query in Visual Query Designer

  1. From the Products table in the Database view, drag and drop the fields ProductName and UnitPrice to the Selected Fields panel.
  2. From the Categories table in Database view, drag and drop the field CategoryName to the Selected Fields panel.
  3. When you add the field in step 2, a Tables relations dialog automatically appears on the screen.
    In the Tables relations dialog, you can also select any other field from Categories table which matches the related table's field to form a join between the both.
  4. In Tables relations dialog, select the Inner Join Type for joining the two tables Products and Categories. The Inner Join tab is selected by default.
    Refer to Tables And Relations for more information on types of joins.
  5. In Tables relations dialog, click OK to save the relationship between tables.
    Once the relationship has been set up between tables, you may also access the Tables relations dialog from the Relations button in the Tables and Relationships panel under the Query Tools section.
  6. In the Selected Fields panel under the CategoryName field, select the option Where and set its value to "= @CategoryName". This creates a parameter on the CategoryName field.

  7. In the Selected Fields panel, go to the UnitPrice field and set the Sort option to descending. This sorts the data in descending order on UnitPrice.
  8. On the Toolbar of the Visual Query Designer, click the Execute button. A Parameters dialog appears on the screen.
  9. Enter any parameter value, for example, Produce in the dialog box and click OK.

    Result data similar to the following appears in Results panel.

Save a Query

  1. Once your query is created in Visual Query Designer, go to the Toolbar in the Query Tools section of the Visual Query Designer.
  2. Click the [image] button. Your query appears in the Query field of the Query page in the DataSet dialog.
    Note: On clicking the Save button, your query is automatically validated by the Visual Query Designer.

View the Report

  1. Place a data region like a Table onto the design surface and add fields to it. For more information on how to add fields to a table, see the Adding Data on the Table data region page.
  2. Click the preview tab to view the report with the Parameters panel displayed in the sidebar.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

    OR

    Open the report in the Viewer to view the report with the Parameters panel displayed in the sidebar. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Interactive Features

Interactive Features
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports supports features like parameters, filters, drill-down, links, document map and sorting to provide an interactive look to your report at run time.

Parameters

ActiveReports allows you to set parameters in your report to filter the data displayed. Parameters make navigation of the report easier for the user at run time. See Parameters for further details.

Filters

The filtering feature is only available with page layout reports. By using filters in your page report or RDL report you can limit the information you want to display on your report. See Filtering for further details.

Drill-Down Reports

When you open a report with drill-down features, part of the data is hidden so that you only see high-level data until you request more detail. See Drill-Down Reports for more information.

Bookmark, Hyperlinks and Drill-Through Links

Bookmark Links

When you click a bookmark link, the viewer navigates to a bookmarked item within the current report.

Hyperlinks

When you click a hyperlink, your machine's default internet browser opens to display a Web page.

Drill-Through

Using the drill-through link feature in your report you can navigate to another report for details about the item you clicked.

See Linking in Reports for further details.

Document Map

The Document Map (Table of Contents) feature allows you to navigate to a particular item in a report. See Document Map for further details.

Sorting

The sorting feature allows you to organize your data and present it in a logical order at run-time. Using this feature you can sort the data alphabetically or numerically in ascending or descending order. See Sorting for further details.

Note: You cannot use the interactive features in the following cases:
  • With Adobe Acrobat Reader and RawHTML types of the WebViewer.
  • With reports that use the collation feature, i.e. reports that have two or more themes.
  • With the ViewerType of WebViewer control set to FlashViewer, you can only use hyperlinks and document map interactive features.

Annotations

The annotations feature allows you to add floating text bars or images to call attention to specific items or values or to add notes and special instructions directly to the reports. These annotations are accessible through the Annotation button present on the Viewer toolbar which is hidden by default. Annotations added via the viewer's toolbar are temporary and are destroyed when the report closes. See Annotations for further details.

See Also

Concepts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Parameters

Parameters
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features > Parameters

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to use parameters to filter or add the data to display in reports at run time. You can either prompt users for parameters so that they control the output, or supply the parameters behind the scenes.

Adding parameter for different data sources

A query parameter can get its value from the Report Parameters collection (entered by the user or from a value you supply), a field in another dataset, or an expression. Syntax for adding a parameter in your query might differ depending upon the data source that you are using. Use the syntax specific to your data source type to create a parameter.

Parameterized query for different data sources are as follows:

Data Source | Parameter Syntax | Example
OleDB | (?) | SELECT * FROM Customer WHERE (CustomerID = ? AND AccountNumber = ?)
ODBC | @ParameterName | SELECT * FROM Customer WHERE (CustomerID = @CustomerID AND AccountNumber = @AccountNumber)
SQL Client | @ParameterName | SELECT * FROM Customer WHERE (CustomerID = @CustomerID AND AccountNumber = @AccountNumber)
OracleDB | :ParameterName | SELECT * FROM Customer WHERE CustomerID = :CustomerID AND AccountNumber = :AccountNumber

Page Report/RDL Report

In a page report or a RDL report, the easiest way to build queries with parameters is to use the Visual Query Designer, as it automatically sets up each parameter.
In the DataSet dialog, click on [image] to access Visual Query Designer for creating SQL queries. See Query Building With Visual Query Designer for further information on how to create a parameterized query using the interactive query designer.

However, if you would like to do it manually, you must enter each parameter in three locations: the Report Parameters dialog (for filtering data at run time), the Parameters page of the DataSet dialog, and the Query page of the DataSet dialog.

Show Report - Parameters dialog

The Report - Parameters dialog allows you to control how and whether a user interface is presented to your users for each parameter. You have to set the following properties in the dialog to create a parameter:

  • Enter a report parameter name. Each report parameter in the collection must have a unique name, and the name must match the name you call in the Parameters page of the DataSet dialog. In the example above, the name is MPAA.
  • Set the data type, the text used to prompt the user, whether to allow null, blank, multiple values or multiline text, and whether to hide the user interface.
  • Select the default value or populate a list of available values from which users can choose.

Parameter values are collected in the order they appear in the Report Parameters collection. You can change the order using the arrows in the Report - Parameters dialog.

Show General Tab

  • Name: Set the name for the parameter in this field. The value you supply here appears in the parameters list and must match the corresponding query parameter.
  • Data type: Set the data type for your parameter which must match the data type of the field that it filters. The interface presented might also differ depending on the data type.
    • Boolean: Presents the user with two options True or False
    • Date: Presents the user with a calendar picker to select a date if you do not supply a default value or a drop-down selection of available values
    • DateTime: Presents the user with a calendar picker to select a date and a time picker to select the time in cases where you do not supply a default value or a drop-down selection of available values
    • Integer: Presents the user with a text box or a drop-down selection of available values
    • Float: Presents the user with a text box or a drop-down selection of available values
    • String: Presents the user with a text box or a drop-down selection of available values
  • Text for prompting users for a value: Enter the text you want to see on the user interface to request information from the user in this field. By default this is the same as the Name property.
  • Allow null value: Select this check box if you want to allow null values to be passed for the parameter. It is not selected by default.
  • Allow blank value: Select this check box if you want to allow blank values to be passed for the parameter. It is not selected by default.
  • Multivalue: Select this check box to allow the user to select multiple items in the available values list.
    For a multi-value parameter, you can also allow user to specify special value for 'Select all' option in the Value for 'Select All' property.
  • Multiline: Select this check box to allow multiline values in the parameter. The control will automatically adjust to accommodate multiple lines.
  • Hidden: Select this check box to hide the parameter interface from the user and instead provide a default value or pass in values from a subreport or drill-through link. Please note that if you hide the user interface and do not provide a default value, the report will not run.

Show Available Values

These values are used to fill a drop-down list from which the end user can choose.

  • Non-queried: You can supply Labels and Values by typing in static values or using expressions.
  • From query: You can select a Dataset from which to select a Value field and Label field.

Show Default Values

This is the value that you give for the parameter if the user does not supply one, or if you hide the parameter user interface.
  • Non-queried: You can supply a default Value by entering a static value or using an expression.
  • From query: You can select a Dataset from which to select a Value field.
  • None: You can have your users provide a value for the parameter.
Note: In the Available Values tab the Value is what is passed to the query parameter, and the Label is what is shown to the user. For example, if the Value is an Employee Number, you might want to supply a more user-friendly Label showing Employee Names.

To access the Report - Parameters Dialog

You can access the Report - Parameters dialog through any one of the following:

  • In the Report Explorer, click the Add (+) icon and select the Parameter option.
  • In the Report Explorer, right-click the Parameters node and select Add Parameter.
  • In the Report Explorer, right-click the Report node and select Report Parameters.
  • From the Report Menu, select Report Parameters.

The Report Parameters dialog contains a parameters page with a list of parameters and three tabs to set parameter properties. To add a parameter to the list, click the Add (+) icon and set the parameter properties in the three tabs described below.

Show Parameters page of the DataSet dialog

On the Parameters page of the DataSet Dialog, pass a Report Parameter into the parameter in your query. You can click the Add (+) icon at the top of the parameters list, enter parameter name, and supply a value like:

=Parameters!MPAA.Value

Show Query page of the DataSet dialog

On the Query page of the DataSet Dialog, enter the parameter in the SQL query. Use the syntax specific to your data source type to create a parameter. For example, with an OleDB data source, add a query like the following for a multi-value Movie Rating parameter:

SELECT * FROM Movie WHERE (MPAA = ? AND YearReleased = ?)

If you want to run a report without prompting the user for a value at run time, you need to set a default value for each parameter and the Hidden check box should be selected in the Report - Parameters dialog, General tab.

Subreport parameters are also considered as hidden parameters as a user can easily synchronize a subreport's data with that of the parent report. See Subreports in Page/RDL Reports for further details.

Drill-Through parameters are also hidden parameters as drill-through links are used to navigate from one report to another. When you select Jump to report for the action, the parameters list is enabled.

Section Report

In section report, you can use the Parameters collection to pass values directly into a control at run time, or you can also use it to display a subset of data in a particular instance of a report.

There are several ways for setting up parameters in a report:

  • You can enter syntax like the following in your SQL query to filter the data displayed in a report at run time: <%Name | PromptString | DefaultValue | DataType | PromptUser%>
  • You can add parameters through the Report Explorer and place them on the report as TextBox controls to pass values in them at run time.
  • You can also add parameters through the code behind the report, inside the ReportStart event. See Add Parameters for more information.

Show Prompting for Parameter Values

In order to prompt the user for parameter values, all of the following must be in place:

  • At least one parameter should exist in the Parameters collection of the report.
  • The PromptUser property for at least one parameter must be set to True.
  • On the report object, the ShowParameterUI property must be set to True.

When there are parameters in the collection and the ShowParameterUI property is set to True, the user prompt automatically displays when the report is run. When the user enters the requested values and clicks the OK button, the report gets displayed using the specified values.

Values of a parameter added through the Report Explorer can be applied to a parameter in the SQL query by specifying the param: prefix for a parameter in the SQL query. This prefix relates the current parameter to the one in the Report Explorer.

For e.g., select * from CUSTOMERS where CustomerName = '<%param:Parameter1%>'. In this case, the parameter with the param: prefix in the SQL query is updated with values of the corresponding parameter in the Report Explorer.

Note: Within the same report, you can prompt users for some parameters and not for others by setting the PromptUser property to True on some and False on others. However, if the report object's ShowParameterUI property is set to False, the user prompt does not display for any parameters regardless of its PromptUser setting.

Show Adding Parameters to the Parameters Collection via the SQL Query

When you add a single parameter to a report's Parameters collection via the SQL query, the query looks like this:

SQL Query. Copy Code
SELECT * FROM Products
INNER JOIN Categories ON Products.CategoryID = Categories.CategoryID
WHERE Products.SupplierID = <%SupplierID|Enter a Supplier ID|1|S|True%>

You can also create a parameterized query from the Visual Query Designer. See Query Building With Visual Query Designer for further information on how to create a parameterized query using the interactive query designer.

There are five values in the parameter syntax, separated by the pipe character: |

Only the first value (Name) is required, but if you do not specify the third value (DefaultValue), the field list is not populated at design time. You can provide only the Name value and no pipes, or if you wish to provide some, but not all of the values, simply provide pipes with no space between them for the missing values. For example, <%ProductID||||False%>

Name: This is the unique name of the parameter, and corresponds to the Key property in parameters entered via code.
PromptString: This string is displayed in the user prompt to let the user know what sort of value to enter.
DefaultValue: Providing a default value to use for the parameter allows ActiveReports to populate the bound fields list while you are designing your report, enabling you to drag fields onto the report. It also populates the user prompt so that the user can simply click the OK button to accept the default value.
DataType: This value, which defaults to S for string, tells ActiveReports what type of data the parameter represents. It also dictates the type of control used in the user prompt. The type can be one of three values.

  • S (string) provides a textbox into which the user can enter the string.
    Depending on your data source, you may need to put apostrophes (single quotes) or quotation marks around the parameter syntax for string values.
    For example, '<%MyStringParameter%>'
    Also, if you provide a default value for a string parameter that is enclosed in apostrophes or quotation marks, ActiveReports sends the apostrophes or quotation marks along with the string to SQL.
    For example, <%MyStringParameter||"DefaultValue"|S|False%>
  • D (date) provides a drop-down calendar picker from which the user can select a date.
    Depending on your data source, you may need to put number signs around the parameter syntax.
    For example, #<%MyDateParameter%>#
  • B (Boolean) provides a checkbox which the user can select or clear.
    If you provide a default value of True or False, or 0 or 1 for a Boolean parameter, ActiveReports sends it to SQL in that format.
    Note: In case of Microsoft Access Database, the default value for boolean parameter is specified as -1(true) or 0(false).
PromptUser: This Boolean allows you to tell ActiveReports whether to prompt the user for a value. This can be set to True for some parameters and False for others. If you set the report's ShowParameterUI property to False, users are not prompted for any parameters, regardless of the PromptUser value set for any parameter in the report.

See Also

Interactive Features

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Filtering

Filtering
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features > Filtering

Glossary Item Box

In page layout, ActiveReports allows you to set filters on a large set of data that has already been retrieved from the data source and use them with datasets or data regions to limit the information you want to display on your report.

Although not as efficient performance-wise as query parameters which filter data at the source, there are still scenarios which demand filters. The obvious case is when the data source does not support query parameters. Another case for using filters is when users who require different sets of data view the same report.

You can set filters on a Filters page or a tab similar to the one in the following image.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

There are three major elements that constitute a filter:

  • Expression: Type or use the expression editor to provide the expression on which to filter data.
  • Operator: Select the operator to compare the expression results with the Value.
  • Value: Enter the value with which to compare the expression results.

For example, in the filter =Fields!YearReleased.Value = 1997 applied on a dataset from the Movies table of the Reels.mdb database, =Fields!YearReleased.Value is set under expression, = is the operator and 1997 is the value on which filter is set. See Set Filters for further instructions on adding filters in reports.

You can also use multiple values with the In and Between operators. Two fields with an And in the middle appear for the Between operator, and another Expression field is available at the bottom of the Filters page or tab for the In operator. The following table lists all available filtering operators.

Filtering Operators

Filter | Description
Equal | Select this operator if you want to choose data for which the value on the left is equal to the value on the right.
Like | Select this operator if you want to choose data for which the value on the left is similar to the value on the right. See the MSDN Web site for more information on the Like operator.
NotEqual | Select this operator if you want to choose data for which the value on the left is not equal to the value on the right.
GreaterThan | Select this operator if you want to choose data for which the value on the left is greater than the value on the right.
GreaterThanOrEqual | Select this operator if you want to choose data for which the value on the left is greater than or equal to the value on the right.
LessThan | Select this operator if you want to choose data for which the value on the left is less than the value on the right.
LessThanOrEqual | Select this operator if you want to choose data for which the value on the left is less than or equal to the value on the right.
TopN | Select this operator if you want to choose items from the value on the left which are the top number specified in the value on the right.
BottomN | Select this operator if you want to choose items from the value on the left which are the bottom number specified in the value on the right.
TopPercent | Select this operator if you want to choose items from the value on the left which are the top percent specified in the value on the right.
BottomPercent | Select this operator if you want to choose items from the value on the left which are the bottom percent specified in the value on the right.
In | Select this operator if you want to choose items from the value on the left which are in the array of values on the right. This operator enables the Values list at the bottom of the Filters page.
Between | Select this operator if you want to choose items from the value on the left which fall between pair of values you specify on the right. This operator enables two Value boxes instead of one.

See Also

Expressions
Set Filters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Drill-Down Reports

Drill-Down Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features > Drill-Down Reports

Glossary Item Box

The drill-down feature helps in temporarily hiding a part of your report. That hidden part can be controls, groups, columns or rows. When you open a drill-down report, part of the data is hidden so that you can only see high-level data until you request for more detail. In such reports you find an expand icon (plus-sign image) next to the toggle item in the report. Clicking the toggle image, or plus sign, expands hidden content into view and the expand icon changes to a collapse icon (minus-sign). When you click the minus-sign image, it hides the content and returns the report to its previous state.

To create a drill-down report, use the Visibility properties of controls, groups, columns, or rows. Simply set the Visibility-hidden property to True and set the toggle item to the name of another item in the report, usually a text box in the group containing the hidden item. At run time, this puts a plus sign next to the toggle item which the user can click to display the hidden data.

If you export a drill-down report or render it through rendering extensions, any content which is hidden at the time of export remains hidden in the exported file. If you want all of the content to appear in the exported file, you must first expand all hidden data.

Only when you render a report using the XML using the XmlRenderingExtension, all hidden data is exported regardless of whether it is hidden at the time of export.

See Also

Interactive Features

How To
Create a Drill-Down Report

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Linking in Reports

Linking in Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features > Linking in Reports

Glossary Item Box

You can enhance the interactivity in your report by adding different types of links to it. ActiveReports provides the ability to add bookmarks, hyperlinks, drill-through links to reports.

The following topic explains the links you can create in page and section reports.

Page Report/RDL Report

Hyperlinks

Hyperlinks take you to a web page that opens in the default browser of the system. You can set hyperlinks in the Textbox, Image, Chart, and Map controls to access a Web page from your report. See Add Hyperlinks for further information.

Hyperlinks are displayed when you preview a page report or a RDL report in the Viewer, export a report in HTML , PDF, RTF, and Excel formats. You can also see hyperlinks in Word, HTML, and PDF formats when you render reports using rendering extensions.

Bookmarks

A bookmark link is similar to a hyperlink, except that it moves the viewer to another area in the report instead of linking to a web page. You can create these links on a control using a Bookmark ID that connects to another target control. See Adding Bookmarks for further information.

Bookmarks are displayed when you preview a page report/RDL report in the Viewer or render a report through rendering extensions in Word, HTML, and PDF formats.

Drill through links

A drill-through link takes you to another report with more detail. Drill-through links appear as a hyperlink that you can click to move to a completely different report. You can also create more complex links where you pass parameters to the report called by the link.

Drill-through links are displayed when you preview a page report/RDL report in the Viewer or render a report through rendering extensions in HTML format.

Note: While rendering a report to HTML, drill-through links are broken unless the target report is also exported to the same directory with the same name as the original.

Section Layout

Hyperlinks

Hyperlinks take you to a web page that opens in the default browser of the system. You can set the HyperLink property available with the Label, Textbox, Picture and OleObject controls that allow you to add hyperlinks that connect to a Web page. You can also use the HyperLink property to open an e-mail or jump to a bookmark. See Add Hyperlinks for further details.

Hyperlinks are supported when you preview a section report in the Viewer, export a report in HTML , PDF, RTF and Excel formats.

Bookmarks

Bookmark links take you to a location where the bookmark is set on your report. Unlike hyperlinks, these links take you within the report. Bookmarks and nested bookmarks appear in the document map for fields, groups and subreports. You can also add special bookmarks at run-time. You can use hyperlinks for simulating a drill through like feature similar to Page Layout. See Add Bookmarks for further details.

Bookmarks are supported when you preview a section report in the Viewer, export a report in HTML and PDF formats.

Note: When you export a report to HTML, a*.TOC file is created in the folder where you export the report. Use this file to reach the bookmarked locations.

See Also

Interactive Features
Document Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Document Map

Document Map
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features > Document Map

Glossary Item Box

Show All Show All
Hide All Hide All

When you click an item in the document map, the viewer jumps to that item in the report.

A document map functions as a table of contents for a page report or a RDL report and as a bookmarks panel for a section report. It provides a convenient way to navigate a lengthy report.

Page Reports/RDL Reports

In a page report or a RDL Report, you can add report controls, data regions, groups and detail groups to the document map by:

  • Assigning a value to the Document map label on the Navigation page of the corresponding dialog.
  • Setting the value of the Label property in the properties window.
  • Setting the value of the HeadingLevel property in the properties window.

See Add Items to the Document Map for more information.

Section Reports

In a section report, when you add a bookmark on any control it appears in the document map while viewing the report. In order to navigate to a bookmark you need to open the document map and click that bookmark.

See Add Bookmarks for more information.

Viewing the Document Map in the Viewer

  1. On the Viewer toolbar, click the Toggle sidebar button to display the sidebar.
  2. At the bottom of the sidebar pane, click the Document map button to display the document map.

    If there is no document map associated with the report, the button does not appear at the bottom of the sidebar pane.
  3. In the Document map that appears, click the item you want to view in the report.
Note: You can also access the Document map from the Toggle sidebar button on the preview tab toolbar.

Exporting document maps

In the Viewer, the document map appears in a sidebar to the left of the report, but when you export your page or section report to various file formats, they handle document maps differently.

Export Filter | Effect on Document Map
HTML | A .toc file containing the document map is exported along with the HTML report.
PDF | Document map appears in the bookmarks panel.
Text | Document map does not appear in the exported report.
Rich Text Format | Document map does not appear in the exported report.
TIFF | Document map does not appear in the exported report.
Excel | Document map does not appear in the exported report.

In a page report or a RDL report, if you use rendering extensions to export your report, the document map is not available in any rendering type except PDF where it appears in the bookmarks panel.

Note: For printing and rendering purposes use Table of Contents control in your page report and RDL report.

See Also

How To
Add Bookmarks

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Sorting

Sorting
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features > Sorting

Glossary Item Box

Show All Show All
Hide All Hide All

In order to better organize and present data in your report, you can sort it alphabetically or numerically in ascending or descending order. You can also use sorting effectively with grouped data to present an easy to understand, comprehensive view of report data.

Sorting in Page Reports/RDL Reports

In a page report or a RDL report, you can sort data in the data region, along with grouping, on a fixed page in Page report or sort data directly in the SQL query. You can also set interactive sorting for your data on a TextBox control.

Show Sorting at different levels in a Report

You can apply sorting at different levels on your report data. ActiveReports provides a Sorting page in the dialogs of a data region, grouped data and fixed page to determine where you want to display sorted data.

Sorting data in a Data Region

In Table and List data regions, you can sort data within the data region. To sort data within these data regions, set sorting in the Sorting page of the specific data region's dialog.

In Tablix, BandedList and Chart data regions, sorting is only possible on grouped data therefore there is no independent Sorting page available in their specific dialogs.

Sorting grouped data

A Sorting tab is available inside the Groups page of all the data region dialogs and the Detail Grouping page of the List dialog. It allows you to set the sort order of grouped data. This tab is enabled once grouping is set inside the data region.

Sorting on a Fixed Page

In a Page report, sorting is also possible on a fixed page grouped on a dynamic value. Sorting data on a fixed page is similar to sorting grouped data in a data region. The only difference is when you sort data on the fixed page you apply sorting to all the data regions that are placed on the design surface. See, Sort Data for more information.

Show Sorting data through SQL Query

When you connect to a data source and create a data set to fetch data for your report, you define a query. Set the ORDER BY keyword in the query to sort data in ascending or descending order.

By default, the ORDER BY keyword usually sorts the data in ascending order, but you can include the DESC keyword in your query to sort data in descending order. For example, if you want to fetch data from the Movie table of the Reels database and sort it on the Title field, your query looks like the following:
SELECT * FROM Movie ORDER BY Title
OR
SELECT * FROM Movie ORDER BY Title ASC

In case you want the Title field sorted in descending order, your query looks like the following:
SELECT * FROM Movie ORDER BY Title DESC

Show Interactive Sorting

You can add interactive sorting on a TextBox control to allow users to sort columns of data within a data region on a published report.

The interactive sorting feature is set through the Interactive Sort page which available in the TextBox dialog.

Once you set interactive sorting on a TextBox control, while viewing the report in the Viewer or in the Preview Tab the textbox control displays a sort icon inside it. A user can sort data that appears inside the textbox in ascending or descending order by clicking the icons.

On the Interactive Sort page of the TextBox dialog you can find following fields available for entering values:

  • Sort Expression: An expression specifying the sort value for data contained in the column.
  • Data region or group to sort: Select the grouping level or data region within the report to sort. The default value is Current scope, but you may also choose an alternate data region or grouping.
  • Evaluate sort expression in this scope: Select the grouping level within the report on which to evaluate an aggregate sorting expression. The default value is Current scope, but you may also choose an alternate data region or grouping.

See Allow Users to Sort Data in the Viewer for more information.

Sorting in Section Reports

In a section report, sorting is not explicitly available. However, you can modify the SQL Query to order your data while fetching it from the database.

Show Sorting data through SQL Query

When you connect the report to a data source and enter a query to fetch data, you can include the ORDER BY keyword in your query to get sorted data.

By default, the ORDER BY keyword usually sorts data in ascending order, but you can include the DESC keyword in your query to sort data in descending order. For example, if you want to fetch data from the Customers table of the NWind database and sort it on the CompanyName field, your query looks like the following:
SELECT * FROM Customers ORDER BY CompanyName
OR
SELECT * FROM Customers ORDER BY CompanyName ASC

In case you want the CompanyName field sorted in descending order, your query looks like the following:
SELECT * FROM Customers ORDER BY CompanyName DESC

See Also

Allow Users to Sort Data in the Viewer

How To
Sort Data

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Annotations

Annotations
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Interactive Features > Annotations

Glossary Item Box

Annotations are floating text bars or images to call attention to specific items or values or to add notes and special instructions directly to the reports. Annotations added via the viewer's toolbar are temporary and are destroyed when the report closes.

These annotations are accessible through the Annotation button present on the Viewer toolbar which is hidden by default. You can make the Annotations toolbar visible by setting the AnnotationDropDownVisible property to True in the viewer's properties window.

Show Available Annotations

Each annotation type allows you to change the colors, transparency, border, font, and alignment, plus other properties specific to the type of annotation. Available annotations include:

Annotation Name | Description
AnnotationText | A rectangular box to enter text using the Text property.
AnnotationCircle | A circle without text. You can change the shape to an oval by dragging its corners.
AnnotationRectangle | A rectangular box without text. You can change the shape to a square by dragging its corners.
AnnotationArrow | A 2D arrow to enter text using the Text property. You can also change the arrow direction using the ArrowDirection property.
AnnotationBalloon | A balloon caption to enter text using its Text property. You can also point the balloon's tail in any direction using its Quadrant property.
AnnotationLine | A line to enter text above or below it using its Text and LineLocation properties. You can also add arrow caps to one or both ends and select different dash styles using DashCap, DashStyle, and ShowArrowCaps properties.
AnnotationImage | A rectangle with a background image and text. You can select an any image inside it using the BackgroundImage property. You can also place text on the image using the Text property.

To add annotations using the Viewer

These steps assume that you have already placed the Viewer control onto a Windows Form and loaded a report in it. See Windows Forms Viewer for more information.
  1. In your Visual Studio project, on the Form where the Viewer control is placed, select the Viewer control an right-click to choose Properties.
  2. In the Properties Window that appears, set the AnnotationDropDownVisible property to True to get an additional toolbar in the viewer control.
  3. Run the report application and select the annotation you want use from the Annotation toolbar on the Viewer.
  4. Drag the annotation to the desired location on the report design surface. The annotation appears with a Delete and a Properties button on the top left corner.
  5. Inside the annotation, click the Properties button to view its properties in the Properties Window and use those properties to enter text, change color or transparency, set border or font, alignment etc.
  6. Close the Properties Window to apply changes to the annotation.
  7. Drag the corners to resize the annotation as needed. You can also select entire annotation to move it to another location on the report.
  8. Right-click the annotation to display the annotation context menu. The context menu includes the Properties and Delete commands.
Note: You can print a page, RDL or section report that contains annotations. In a section report, you can also save a report with annotations in RDF format. See Add and Save Annotations for further details.

See Also

Interactive Features

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Parts

Report Parts
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Report Parts

Glossary Item Box

What are Report Parts?

Report parts are groups of controls (with data and settings) in a report that you can reuse in other reports. Report parts are supported in Page, RDL, and Section reports. For example, you can use Chart and Tablix data regions from Report1, and a Table data region from Report2 to create a new report.

Note: The Report Parts feature is only available with the Professional Edition license.

Why use report parts?

Enhanced reusability: With Report Parts, you can reuse report controls along with their associated data resources such as data sets and data source connections. In earlier versions, you could copy controls from one report to another, but not the resources associated with them. Using report parts, you can add everything that is required for that control to work.

Automatic conflict resolution: ActiveReports automatically resolves name conflicts for report parts. For example, if a report already contains a Tablix1 data region and you add a report part named Tablix1, it automatically changes the new report part's name to Tablix2.

Zero dependency: After adding a report part to a report, you can modify it independent of the original report part. For example, if you add Table1 as a report part in your current report, you can modify its properties without impacting the Table1 settings in your original report.

Here is some guidance on how to work with Report Parts

  • Show or hide the Reports Library
  • Add report parts from local reports
  • Hide report parts from the Reports Library
  • Clear report parts from the Reports Library
  • Use report parts in your reports
  • Limitations

Show or Hide the Reports Library

When ActiveReports is installed on your system, a View Reports Library button is automatically added to the Visual Studio toolbar. It appears every time you create a new application.

  1. Right-click the Visual Studio toolbar and select ActiveReports 13 to display the report designer toolbar. See Toolbar for further details.
  2. On the report designer toolbar, click the View Reports Library button. The Reports Library 13 window appears.
  3. Click the View Reports Library button again to hide the Reports Library 13 window.
Note:
  • If the Reports Library window does not appear automatically in your application, select View > Other Windows > Reports Library 13 in Visual Studio.
  • The stand-alone designer application (GrapeCity.ActiveReports.Designer.exe) also contains a Reports Library window. See Stand-alone Designer and Viewer for more information.
  • Report authors can place reports in the GrapeCity Reports Library folder to show them as report parts in the Reports Library window. By default, the GrapeCity Reports Library folder is located in the User Documents folder.

Add report parts

  1. In the stand-alone designer, click the File menu and select Open. Alternatively, to add a report part from the Reports Library window, right-click the Reports Library node and select Add.
  2. In the Open dialog that appears, navigate through the folder hierarchy and select the report you want to use for report parts.

  3. Click the dropdown arrow next to the Open button and select Open As Library to add report parts to the Reports Library 13 window. Once the report parts are added to your Report Library, you can use them to design new or existing reports.

Hide report parts from the Reports Library

  1. Open the Reports Library window. For more information on how to open Reports Library window, see Show or Hide the Reports Library
  2. In the Reports Library window, select the report part that you want to hide.

  3. Right-click on the selected report part and then select Hide option from the context menu to hide the selected report part from Reports Library window.

Clear report parts from the Reports Library

  1. Right-click anywhere inside the Reports Library window and select the Clear option from the context menu to completely clear the Reports Library window.

Use report parts in your reports

  1. Once you have added the Report Parts to the Reports Library window, you can drag and drop the control from the Reports Library window onto the design surface. The report part is added to your report along with its dependencies such as data sources, data sets, and parameters.

    Note: If you are working with a Page or RDL report, Section report parts are disabled in the Reports Library window and vice versa.

Limitation

  • Page and RDL reports: CheckBox, Shape, Line, and Subreport controls are not supported as report parts.
  • Section reports: Picture, RichTextBox, Barcode, and Chart are the only controls that you can add as report parts. The rest of the controls are not supported as report parts.

See Also

Creating a report using Report Parts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Text Justification

Text Justification
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Text Justification

Glossary Item Box

The TextJustify Property of a Textbox control provides you justification options for aligning your text within a control. It is important that the TextAlign property (Alignment property in a Section Report) must be set to Justify' for TextJustify property to affect the text layout.

Note: In section layout, the TextJustify property is also available in the Label control.

You can choose from the following values of the TextJustify property:

Auto

Results in Standard MSWord like justification where space at the end of a line is spread across other words in that line. This is the default value.

Distribute

Spaces individual characters within a word, except for the last line.

DistributeAllLines

Spaces individual characters within words and also justifies the last line according to the length of others lines.

To set Text Justification

  1. On design surface, select the control to view it's properties in Properties window.
  2. In the properties window, set the TextAlign property (Alignment property in a Section Report) to Justify.
  3. Go to the TextJustify property and from the drop down list select any one option.

Text justification is supported when you preview a report in the Viewer, print a report or export a page, RDL or section report in PDF and TIFF formats. In page reports and RDL reports, it is also supported while rendering a report in Word, HTML, PDF and Image formats using rendering extensions. See Rendering Extensions for more information on rendering extensions.

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Multi Line in Report Controls

Multi Line in Report Controls
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Multi Line in Report Controls

Glossary Item Box

ActiveReports allows you to display text within a control on multiple lines.

Multiline in Section Reports

In a section report, to enable multiline display in your report control, you need to set the Multiline Property to True. Then, with your control in edit mode, insert line breaks at the desired location using the Enter key or Ctrl + Enter keys to create multiline text. However, when the MultiLine property is set to False, text entered into the control is displayed on a single line.

You can display multiline text in TextBox, RichTextBox and Label controls.

Multiline in Page Reports/RDL Reports

In a page report or a RDL Report, with your control in edit mode, insert line breaks at the desired location using the Enter key or Ctrl + Enter key to create multiline text. You can also insert line breaks in the Expression Editor through the Value property of the control.

You can display multiline text in the TextBox and CheckBox controls.

Note: In edit mode, scrollbars appear automatically to fit multiline content within a control. However, these are not displayed in the preview tab, so you may need to adjust the Size property of the control to display all of the text.

See Also

Toolbox
Section Report Toolbox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Line Spacing and Character Spacing

Line Spacing and Character Spacing
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Line Spacing and Character Spacing

Glossary Item Box

In ActiveReports, in order to make your report output clearly visible during export or printing you can set character and line spacing. In order to use line spacing you must first set the MultiLine property for the control to True.

The CharacterSpacing and LineSpacing properties are available in the following controls for this purpose:

Page Report/RDL Report

  • TextBox

Section Report

  • TextBox
  • Label

To set line or character spacing

  1. On the design surface, click the control to display it in the Properties Window.
  2. In the Properties window, click the Property Dialog command at the bottom to open the control dialog.
  3. In the TextBox dialog, go to the Format page and set the Line Spacing or Character Spacing values in points.
Note: You can also set the CharacterSpacing and LineSpacing property directly in the Properties Window.

Line and character spacing is supported when you preview a report in the Viewer, print a report or export a section report in HTML , PDF and TIFF formats.

In page reports and RDL reports, it is also supported while rendering a report through rendering extensions in Word, HTML, PDF and Image formats. See Rendering Extensions for further information on rendering extensions.

See Also

Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Designer Control (Pro Edition)

Designer Control (Pro Edition)
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Designer Control (Pro Edition)

Glossary Item Box

With the Professional Edition of ActiveReports, you can host the ActiveReports Designer control in your Windows Forms application and provide your end users with report editing capabilities. The control's methods and properties allow you to save and load report layouts, monitor and control the design environment, and customize the look and feel.

In addition to the Designer control, ActiveReports offers a CreateToolStrips method to help you add default toolbars to the designer and add and remove individual tool bars and commands. This gives your designer a finished look and allows you to quickly create a functioning report designer application.

Note: You cannot host the ActiveReports Designer control in the Web application and Web site project types.

See Also

Walkthroughs
Creating a Basic End User Report Designer (Pro Edition)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Shrink Text to Fit in a Control

Shrink Text to Fit in a Control
ActiveReports 13 > ActiveReports User Guide > Concepts > Shrink Text to Fit in a Control

Glossary Item Box

In ActiveReports, when working with the Textbox control in a page report and RDL report or a TextBox or Label control in a section report, you can use the GrapeCity.ActiveReports.PageReportModel.Style.ShrinkToFit property to reduce the size of the text so that it fits within the bounds of the control. The text shrinks at run time, so you can see the reduced font size when you preview, print or export the report.

The following image illustrates the result when the ShrinkToFit property is set to True on Title.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

You can use other text formatting properties in combination with the ShrinkToFit property.

Caution:

  • When both CanGrow and ShrinkToFit are set to True, CanGrow setting is ignored and only ShrinkToFit is applied to the report.
  • When ShrinkToFit is set to True and Angle is set to a value other than 0, the ShrinkToFit property is ignored.
  • ShrinkToFit property does not work in following conditions:
    • VerticalText property (in Section Report) or WritingMode property (in Page/RDL report) is set for a control.
    • Multiline property in Section report is set to False.
  • Common value with Page number (in data region or report header/footer) appears clipped in exported files (HTML, MHT, Word, and Excel) even when ShrinkToFit property for the TextBox is set to True.

Export Support

While exporting a report, various file formats handle ShrinkToFit differently.

ShrinkToFit gets exported in all formats except Text. While rendering a page report or RDL report using rendering extensions, ShrinkToFit is not supported in XML. However, all other rendering extensions allow ShrinkToFit display as it is. See Rendering Extensions for more on rendering extensions.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Condense Characters to Fit in a Control

Condense Characters to Fit in a Control
ActiveReports 13 > ActiveReports User Guide > Concepts > Condense Characters to Fit in a Control

Glossary Item Box

The MinCondenseRate property for Label and TextBox controls in Section and Page/RDL reports allows users to shrink the width of the text so that it fits within the width of the control. With MinCondenseRate property, the size of the text is compressed horizontally and all characters and character-spacing in the text shrink with the same ratio; and with ShrinkToFit property, both height and width of a text are compressed.

When the text is multi-line, the width of the text shrinks based on the longest line. If the text cannot fit the width of the control even after the width of the text is compressed with the minimum ratio, line breaks are inserted in the middle of the text depending on the setting of the WrapMode property.

The default value of the MinCondenseRate property is 100 (percentage) and the available range is from 10 to 100 (only natural number).

The following image illustrates how the text "ABCDEFGHIJ0123456789abcdefghij+-/*%#$&" is compressed when the MinCondenseRate property for a TextBox is set from 10 to 100.

Caution: When MinCondenseRate property is specified, the following properties are ignored:

  • Angle (Label control in Section report and TextBox control in Page/RDL report)
  • ShrinkToFit
  • VerticalText (Label control in Section report, and TextBox control in Section and Page/RDL reports)
  • WritingMode (TextBox control in Page/RDL report)
Export Support

The Condensed character feature is supported in PDF, HTML, and MHT export formats when exporting Page/RDL reports using Rendering Extensions.

Caution: The Condensed characters are NOT supported when exporting Page/RDL reports using PDF and HTML Export Filters.
Viewer Support

The Condensed character feature is supported in the WinForms, WPF, Web, and HTML5 viewers.

Caution: The Condensed character feature is NOT supported in the following export options of HTML5 Viewer:

  • Word Document
  • Excel Workbook

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Standalone Designer and Viewers

Standalone Designer and Viewers
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Standalone Designer and Viewers

Glossary Item Box

ActiveReports provides executable files for the Designer and the Viewer controls (Windows and WPF) in the startup menu. These executable files function as stand-alone applications to help create, edit, and view a report quickly.

Use the stand-alone designer application to create a report layout, save it in .rpx or .rdlx format and then load it in the stand-alone viewer application to view the report.

To access the Stand-alone Designer or Viewer application

From the Start Menu, go to All Programs > GrapeCity > ActiveReports and select ActiveReports 13 Designer or ActiveReports 13 Viewer.

OR

Select the following applications located under ...\GrapeCity\ActiveReports 13\Tools.

  • GrapeCity.ActiveReports.Designer.exe
  • GrapeCity.ActiveReports.Viewer.exe
  • GrapeCity.ActiveReports.WpfViewer.exe

Stand-alone Designer

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stand-alone designer refers to the GrapeCity.ActiveReports.Designer.exe bundled with the ActiveReports installer. This application provides a user interface comprising of a Designer at the center along with a toolbox, toolbar, menu, Report Explorer and Properties Window to mimic the Visual Studio look and feel.

The stand-alone designer supports all page, RDL and section reports. By default, a stand-alone designer appears with a section layout loaded in the designer. To open a page report or RDL report, do one of the following:

  • From the File menu > New menu option, open the Create New Report dialog and select Page Report or RDL report.
  • On the toolbar, select the New menu option to open the Create New Report dialog and select Page Report or RDL report.

Use the File menu > Save As option to save the report in .rpx or .rdlx format depending on the type of layout you are using. The Report menu that appears in the menu bar is similar to the one in Visual Studio. See Report Menu for more information.

Stand-alone Viewer

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stand-alone Viewer refers to the GrapeCity.ActiveReports.Viewer.exe bundled with the ActiveReports installer. This is basically a Windows Form application with an ActiveReports Viewer control in it. The default user interface of this application provides an ActiveReports Viewer control along with a menu bar.

You can open a .rdlx or .rpx report in the stand-alone viewer application, by going to the File menu > Open menu option and selecting a report to load in the viewer. Unlike the Viewer control, no code implementation is required to load the report in the stand-alone application.

Please note that any additional features activated through code like the annotation toolbar, are not available in the stand-alone viewer application. See Windows Forms Viewer for more information on how to implement these features in the Viewer control.

Stand-alone WPF Viewer

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Stand-alone WPF viewer refers to GrapeCity.ActiveReports.WpfViewer.exe bundled with ActiveReports 13 installer. This is basically a WPF application with an ActiveReports WPF Viewer control in it. The default user interface of this application provides an ActiveReports along with a menu bar.

You can open an .rdlx or .rpx report in the stand-alone WPF Viewer application, by going to the File menu > Open menu option and selecting a report to load in the viewer. Unlike the Viewer control, no code implementation is required to load the report in the stand-alone application.

Please note that features like customizing toolbar through code, are not available in the stand-alone WPF Viewer application. See Using the WPF Viewer for more information on how to implement these features in the Viewer control.

See Also

Designer Control (Pro Edition)

Walkthroughs
Creating a Basic End User Report Designer (Pro Edition)

Getting Started
Windows Forms Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Localization

Localization
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Localization

Glossary Item Box

ActiveReports uses the Hub and Spoke model for localizing resources. The hub is the main executing assembly and the spokes are the satellite DLLs that contain localized resources for the application.

For example, if you want to localize the Viewer Control, the hub is GrapeCity.ActiveReports.Viewer.Win.dll and the spoke is GrapeCity.ActiveReports.Viewer.Win.resources.dll.

In your Program Files folder, the Localization folder is in a path like ....\GrapeCity\ActiveReports 13\Localization, and contains all of the ActiveReports components that you can localize.

There are 16 ActiveReports components in the Localization folder and most have two files.

  • A .bat file that is used to set the Cultures to which you want to localize.
  • A .zip file that contains the resource files (.resx) in which you update or change the strings.

There is one application in the Localization folder: NameCompleter.exe. When you run your .bat file after updating your culture, it runs this application to create a SatelliteAssembly folder with a language sub-folder containing the localized GrapeCity.ActiveReports.AssemblyName.resources.dll file.

Place the language folder containing the *.resources.dll file inside your main executing assembly folder to implement changes.

Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.AssemblyName.resources.dll file to SupportOne by opening a support ticket, and get it signed with a strong name. Once you receive the signed DLL file, you can drag the language subfolder with the signed DLL file into C:\WINDOWS\ASSEMBLY, or distribute it with your solution.

When the main executing assembly needs a resource, it uses a ResourceManager object to load the required resource. The ResourceManager uses the thread's CurrentUICulture property.

The common language run time sets the CurrentUICulture property or you can set it in code to force a certain UI Culture so that you can test whether your satellite DLL is loading properly. The ResourceManager class uses the CurrentUICulture property to locate subdirectories that contain a satellite DLL for the current culture. If no subdirectory exists, the ResourceManager uses the resource that is embedded in the assembly. US English ("en-US") is the default culture for ActiveReports.

Tip: For more detailed information about how the Framework locates satellite DLLs, please refer to the help system in Visual Studio® or the book Developing International Software, 2nd edition by MS Press that contains information on localizing applications using the .NET Framework.

See Also

Localize the Viewer Control
Localize the End User Report Designer
Localize ActiveReports Resources
Localize Reports, TextBoxes, and Chart Controls
Customize, Localize, and Deploy

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Cultures

Cultures
ActiveReports 13 > ActiveReports User Guide > Concepts > Localization > Cultures

Glossary Item Box

For your convenience, here is a list of predefined System.Globalization cultures. (Source: MSDN.) For ActiveReports localization purposes, use the Culture and Language Name value in the first column.

Culture and Language Name | Culture Identifier | Culture
"" (empty string) | 0x007F | Invariant culture
af | 0x0036 | Afrikaans
af-ZA | 0x0436 | Afrikaans (South Africa)
sq | 0x001C | Albanian
sq-AL | 0x041C | Albanian (Albania)
ar | 0x0001 | Arabic
ar-DZ | 0x1401 | Arabic (Algeria)
ar-BH | 0x3C01 | Arabic (Bahrain)
ar-EG | 0x0C01 | Arabic (Egypt)
ar-IQ | 0x0801 | Arabic (Iraq)
ar-JO | 0x2C01 | Arabic (Jordan)
ar-KW | 0x3401 | Arabic (Kuwait)
ar-LB | 0x3001 | Arabic (Lebanon)
ar-LY | 0x1001 | Arabic (Libya)
ar-MA | 0x1801 | Arabic (Morocco)
ar-OM | 0x2001 | Arabic (Oman)
ar-QA | 0x4001 | Arabic (Qatar)
ar-SA | 0x0401 | Arabic (Saudi Arabia)
ar-SY | 0x2801 | Arabic (Syria)
ar-TN | 0x1C01 | Arabic (Tunisia)
ar-AE | 0x3801 | Arabic (U.A.E.)
ar-YE | 0x2401 | Arabic (Yemen)
hy | 0x002B | Armenian
hy-AM | 0x042B | Armenian (Armenia)
az | 0x002C | Azeri
az-Cyrl-AZ | 0x082C | Azeri (Azerbaijan, Cyrillic)
az-Latn-AZ | 0x042C | Azeri (Azerbaijan, Latin)
eu | 0x002D | Basque
eu-ES | 0x042D | Basque (Basque)
be | 0x0023 | Belarusian
be-BY | 0x0423 | Belarusian (Belarus)
bg | 0x0002 | Bulgarian
bg-BG | 0x0402 | Bulgarian (Bulgaria)
ca | 0x0003 | Catalan
ca-ES | 0x0403 | Catalan (Catalan)
zh-HK | 0x0C04 | Chinese (Hong Kong SAR, PRC)
zh-MO | 0x1404 | Chinese (Macao SAR)
zh-CN | 0x0804 | Chinese (PRC)
zh-Hans | 0x0004 | Chinese (Simplified)
zh-SG | 0x1004 | Chinese (Singapore)
zh-TW | 0x0404 | Chinese (Taiwan)
zh-Hant | 0x7C04 | Chinese (Traditional)
hr | 0x001A | Croatian
hr-HR | 0x041A | Croatian (Croatia)
cs | 0x0005 | Czech
cs-CZ | 0x0405 | Czech (Czech Republic)
da | 0x0006 | Danish
da-DK | 0x0406 | Danish (Denmark)
dv | 0x0065 | Divehi
dv-MV | 0x0465 | Divehi (Maldives)
nl | 0x0013 | Dutch
nl-BE | 0x0813 | Dutch (Belgium)
nl-NL | 0x0413 | Dutch (Netherlands)
en | 0x0009 | English
en-AU | 0x0C09 | English (Australia)
en-BZ | 0x2809 | English (Belize)
en-CA | 0x1009 | English (Canada)
en-029 | 0x2409 | English (Caribbean)
en-IE | 0x1809 | English (Ireland)
en-JM | 0x2009 | English (Jamaica)
en-NZ | 0x1409 | English (New Zealand)
en-PH | 0x3409 | English (Philippines)
en-ZA | 0x1C09 | English (South Africa)
en-TT | 0x2C09 | English (Trinidad and Tobago)
en-GB | 0x0809 | English (United Kingdom)
en-US | 0x0409 | English (United States)
en-ZW | 0x3009 | English (Zimbabwe)
et | 0x0025 | Estonian
et-EE | 0x0425 | Estonian (Estonia)
fo | 0x0038 | Faroese
fo-FO | 0x0438 | Faroese (Faroe Islands)
fa | 0x0029 | Farsi
fa-IR | 0x0429 | Farsi (Iran)
fi | 0x000B | Finnish
fi-FI | 0x040B | Finnish (Finland)
fr | 0x000C | French
fr-BE | 0x080C | French (Belgium)
fr-CA | 0x0C0C | French (Canada)
fr-FR | 0x040C | French (France)
fr-LU | 0x140C | French (Luxembourg)
fr-MC | 0x180C | French (Monaco)
fr-CH | 0x100C | French (Switzerland)
gl | 0x0056 | Galician
gl-ES | 0x0456 | Galician (Spain)
ka | 0x0037 | Georgian
ka-GE | 0x0437 | Georgian (Georgia)
de | 0x0007 | German
de-AT | 0x0C07 | German (Austria)
de-DE | 0x0407 | German (Germany)
de-LI | 0x1407 | German (Liechtenstein)
de-LU | 0x1007 | German (Luxembourg)
de-CH | 0x0807 | German (Switzerland)
el | 0x0008 | Greek
el-GR | 0x0408 | Greek (Greece)
gu | 0x0047 | Gujarati
gu-IN | 0x0447 | Gujarati (India)
he | 0x000D | Hebrew
he-IL | 0x040D | Hebrew (Israel)
hi | 0x0039 | Hindi
hi-IN | 0x0439 | Hindi (India)
hu | 0x000E | Hungarian
hu-HU | 0x040E | Hungarian (Hungary)
is | 0x000F | Icelandic
is-IS | 0x040F | Icelandic (Iceland)
id | 0x0021 | Indonesian
id-ID | 0x0421 | Indonesian (Indonesia)
it | 0x0010 | Italian
it-IT | 0x0410 | Italian (Italy)
it-CH | 0x0810 | Italian (Switzerland)
ja | 0x0011 | Japanese
ja-JP | 0x0411 | Japanese (Japan)
kn | 0x004B | Kannada
kn-IN | 0x044B | Kannada (India)
kk | 0x003F | Kazakh
kk-KZ | 0x043F | Kazakh (Kazakhstan)
kok | 0x0057 | Konkani
kok-IN | 0x0457 | Konkani (India)
ko | 0x0012 | Korean
ko-KR | 0x0412 | Korean (Korea)
ky | 0x0040 | Kyrgyz
ky-KG | 0x0440 | Kyrgyz (Kyrgyzstan)
lv | 0x0026 | Latvian
lv-LV | 0x0426 | Latvian (Latvia)
lt | 0x0027 | Lithuanian
lt-LT | 0x0427 | Lithuanian (Lithuania)
mk | 0x002F | Macedonian
mk-MK | 0x042F | Macedonian (Macedonia, FYROM)
ms | 0x003E | Malay
ms-BN | 0x083E | Malay (Brunei Darussalam)
ms-MY | 0x043E | Malay (Malaysia)
mr | 0x004E | Marathi
mr-IN | 0x044E | Marathi (India)
mn | 0x0050 | Mongolian
mn-MN | 0x0450 | Mongolian (Mongolia)
no | 0x0014 | Norwegian
nb-NO | 0x0414 | Norwegian (Bokmål, Norway)
nn-NO | 0x0814 | Norwegian (Nynorsk, Norway)
pl | 0x0015 | Polish
pl-PL | 0x0415 | Polish (Poland)
pt | 0x0016 | Portuguese
pt-BR | 0x0416 | Portuguese (Brazil)
pt-PT | 0x0816 | Portuguese (Portugal)
pa | 0x0046 | Punjabi
pa-IN | 0x0446 | Punjabi (India)
ro | 0x0018 | Romanian
ro-RO | 0x0418 | Romanian (Romania)
ru | 0x0019 | Russian
ru-RU | 0x0419 | Russian (Russia)
sa | 0x004F | Sanskrit
sa-IN | 0x044F | Sanskrit (India)
sr-Cyrl-CS | 0x0C1A | Serbian (Serbia, Cyrillic)
sr-Latn-CS | 0x081A | Serbian (Serbia, Latin)
sk | 0x001B | Slovak
sk-SK | 0x041B | Slovak (Slovakia)
sl | 0x0024 | Slovenian
sl-SI | 0x0424 | Slovenian (Slovenia)
es | 0x000A | Spanish
es-AR | 0x2C0A | Spanish (Argentina)
es-BO | 0x400A | Spanish (Bolivia)
es-CL | 0x340A | Spanish (Chile)
es-CO | 0x240A | Spanish (Colombia)
es-CR | 0x140A | Spanish (Costa Rica)
es-DO | 0x1C0A | Spanish (Dominican Republic)
es-EC | 0x300A | Spanish (Ecuador)
es-SV | 0x440A | Spanish (El Salvador)
es-GT | 0x100A | Spanish (Guatemala)
es-HN | 0x480A | Spanish (Honduras)
es-MX | 0x080A | Spanish (Mexico)
es-NI | 0x4C0A | Spanish (Nicaragua)
es-PA | 0x180A | Spanish (Panama)
es-PY | 0x3C0A | Spanish (Paraguay)
es-PE | 0x280A | Spanish (Peru)
es-PR | 0x500A | Spanish (Puerto Rico)
es-ES | 0x0C0A | Spanish (Spain)
es-ES_tradnl | 0x040A | Spanish (Spain, Traditional Sort)
es-UY | 0x380A | Spanish (Uruguay)
es-VE | 0x200A | Spanish (Venezuela)
sw | 0x0041 | Swahili
sw-KE | 0x0441 | Swahili (Kenya)
sv | 0x001D | Swedish
sv-FI | 0x081D | Swedish (Finland)
sv-SE | 0x041D | Swedish (Sweden)
syr | 0x005A | Syriac
syr-SY | 0x045A | Syriac (Syria)
ta | 0x0049 | Tamil
ta-IN | 0x0449 | Tamil (India)
tt | 0x0044 | Tatar
tt-RU | 0x0444 | Tatar (Russia)
te | 0x004A | Telugu
te-IN | 0x044A | Telugu (India)
th | 0x001E | Thai
th-TH | 0x041E | Thai (Thailand)
tr | 0x001F | Turkish
tr-TR | 0x041F | Turkish (Turkey)
uk | 0x0022 | Ukrainian
uk-UA | 0x0422 | Ukrainian (Ukraine)
ur | 0x0020 | Urdu
ur-PK | 0x0420 | Urdu (Pakistan)
uz | 0x0043 | Uzbek
uz-Cyrl-UZ | 0x0843 | Uzbek (Uzbekistan, Cyrillic)
uz-Latn-UZ | 0x0443 | Uzbek (Uzbekistan, Latin)
vi | 0x002A | Vietnamese
vi-VN | 0x042A | Vietnamese (Vietnam)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section 508 Compliance

Section 508 Compliance
See Also
ActiveReports 13 > ActiveReports User Guide > Concepts > Section 508 Compliance

Glossary Item Box

Show All Show All
Hide All Hide All

Section 508 requires that when Federal agencies develop, procure, maintain, or use electronic and information technology, Federal employees with disabilities have access to and use of information and data that is comparable to the access and use by Federal employees without disabilities, unless an undue burden would be imposed on the agency. Section 508 also requires that individuals with disabilities seeking information or services from a Federal agency have access to and use of information and data that is comparable to that provided to the general public, unless an undue burden would be imposed on the agency.

Summary

Guideline |  | Applicable | ActiveReports Area
Section 1194.21 | Software Applications and Operating Systems | Applicable | End User Designer, Windows Viewer, WPF Viewer, Web controls (HTML5 Viewer, HTML Viewer).
Section 1194.22 | Web-Based Intranet and Internet Information and Applications | Applicable | Web controls (HTML5 Viewer, HTML Viewer).
Section 1194.23 | Telecommunications Products | Not applicable | none
Section 1194.24 | Video and Multimedia Products | Not applicable | none
Section 1194.25 | Self-Contained, Closed Products | Not applicable | none
Section 1194.26 | Desktop and Portable Computers | Not applicable | none
Section 1194.31 | Functional Performance Criteria | Applicable | End User Designer, Windows Viewer, WPF Viewer, Web controls (HTML5 Viewer, HTML Viewer).
Section 1194.41 | Information, Documentation and Support | Applicable | Documentation and Support.

Accessibility Summary:

All major features of ActiveReports software are accessible via keyboard navigation.

DISCLAIMER:

GRAPECITY MAKES NO WARRANTIES, EXPRESS OR IMPLIED, IN THIS DOCUMENT. The following information reflects the general accessibility features of GrapeCity software components as related to the Section 508 standards. If you find that the information is not accurate, or if you have specific accessibility needs that our products do not meet, please contact us and we will attempt to rectify the problem, although we cannot guarantee that we will be able to do so in every case.

Software Applications and Operating Systems

Show Section 1194.21

Criteria | Status | Remarks
(a) When software is designed to run on a system that has a keyboard, product functions shall be executable from a keyboard where the function itself or the result of performing a function can be discerned textually. | Supported with exceptions | ActiveReports partially supports keyboard navigation. Users cannot execute report functions completely using the keyboard.
(b) Applications shall not disrupt or disable activated features of other products that are identified as accessibility features, where those features are developed and documented according to industry standards. Applications also shall not disrupt or disable activated features of any operating system that are identified as accessibility features where the application programming interface for those accessibility features has been documented by the manufacturer of the operating system and is available to the product developer. | Supported | The controls do not disrupt or disable industry standard accessibility features of other products.
(c) A well-defined on-screen indication of the current focus shall be provided that moves among interactive interface elements as the input focus changes. The focus shall be programmatically exposed so that Assistive Technology can track focus and focus changes. | Supported with exceptions | Some elements in ActiveReports cannot track focus. Focus is not exposed to screen readers like NVDA.
(d) Sufficient information about a user interface element including the identity, operation and state of the element shall be available to Assistive Technology. When an image represents a program element, the information conveyed by the image must also be available in text. | Supported with exceptions | The images representing program elements do not support alternative text. Partial support for Assistive Technology is provided for some interface elements.
(e) When bitmap images are used to identify controls, status indicators, or other programmatic elements, the meaning assigned to those images shall be consistent throughout an application's performance. | Supported | Any image used to identify a programmatic element has a consistent meaning throughout an application's performance.
(f) Textual information shall be provided through operating system functions for displaying text. The minimum information that shall be made available is text content, text input caret location, and text attributes. | Supported | Textual information such as text content, caret location, and any text attribute (i.e. bold, italic, size, color, etc.) is available for all the viewer elements.
(g) Applications shall not override user selected contrast and color selections and other individual display attributes. | Supported with exceptions | User selected contrast and color settings are not overridden, except for some minor exceptions in End User Designer.
(h) When animation is displayed, the information shall be displayable in at least one non-animated presentation mode at the option of the user. | Supported | Animated image is only used when a report is being loaded in the viewer. The users can provide a static text for the animation using the loadCompleted event of the Viewer.
(i) Color coding shall not be used as the only means of conveying information, indicating an action, prompting a response, or distinguishing a visual element. | Supported | Any interface element that uses color to indicate an action, prompt a response, or distinguish a visual element also provides a textual cue.
(j) When a product permits a user to adjust color and contrast settings, a variety of color selections capable of producing a range of contrast levels shall be provided. | Supported | ActiveReports supports a variety of colors, themes and styles that can be applied to controls in a report.
(k) Software shall not use flashing or blinking text, objects, or other elements having a flash or blink frequency greater than 2 Hz and lower than 55 Hz. | Supported | The controls do not use flashing or blinking text or objects.
(l) When electronic forms are used, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported | Any form-type dialogs or windows associated with the controls provide Assistive Technology with access to information on all directions, cues, field elements, and functionality required for completion.

Web-based Internet Information and Applications

Show Section 1194.22

Criteria | Status | Remarks
(a) A text equivalent for every non-text element shall be provided (e.g., via "alt", "longdesc", or in element content). | Supported | Each non-text element has a text equivalent.
(b) Equivalent alternatives for any multimedia presentation shall be synchronized with the presentation. | Not applicable | ActiveReports web controls do not include multimedia.
(c) Web pages shall be designed so that all information conveyed with color is also available without color, for example from context or markup. | Not applicable | ActiveReports web controls do not provide any information using color.
(d) Documents shall be organized so they are readable without requiring an associated style sheet. | Supported with exceptions | Toolbar icons in some web controls are not visible when the associated styles are disabled.
(e) Redundant text links shall be provided for each active region of a server-side image map. | Not applicable | There are no server-side image maps in ActiveReports web controls.
(f) Client-side image maps shall be provided instead of server-side image maps except where the regions cannot be defined with an available geometric shape. | Not applicable | ActiveReports does not use client-side image maps in ActiveReports web controls.
(g) Row and column headers shall be identified for data tables. | Not applicable | By default, there are no data tables associated with the ActiveReports web controls.
(h) Markup shall be used to associate data cells and header cells for data tables that have two or more logical levels of row or column headers. | Not applicable | By default, there are no data tables associated with the ActiveReports web controls.
(i) Frames shall be titled with text that facilitates frame identification and navigation. | Not applicable | By default, there are no frames associated with ActiveReports web controls.
(j) Pages shall be designed to avoid causing the screen to flicker with a frequency greater than 2 Hz and lower than 55 Hz. | Supported | ActiveReports Web controls do not contain any feature that causes page flickering.
(k) A text-only page, with equivalent information or functionality, shall be provided to make a web site comply with the provisions of this part, when compliance cannot be accomplished in any other way. The content of the text-only page shall be updated whenever the primary page changes. | Not applicable | Text-only page is not available in ActiveReports Web Viewer or Web controls.
(l) When pages utilize scripting languages to display content, or to create interface elements, the information provided by the script shall be identified with functional text that can be read by Assistive Technology. | Supported | The ActiveReports HTML5 Viewer control uses scripting that is supported by Assistive Technology.
(m) When a web page requires that an applet, plug-in or other application be present on the client system to interpret page content, the page must provide a link to a plug-in or applet that complies with §1194.21(a) through (l). | Not applicable | Not applicable
(n) When electronic forms are designed to be completed on-line, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported with exceptions | The components used in ActiveReports have been configured for maximum compliance. Some form controls may not support Assistive Technology.
(o) A method shall be provided that permits users to skip repetitive navigation links. | Not applicable | ActiveReports does not support repetitive navigation links.
(p) When a timed response is required, the user shall be alerted and given sufficient time to indicate more time is required. | Not applicable | Timed response is not required.

Performance Criteria

Show Section 1194.31

Criteria | Status | Remarks
(a) At least one mode of operation and information retrieval that does not require user vision shall be provided, or support for assistive technology used by people who are blind or visually impaired shall be provided. | Supported with exceptions | Partial support is provided for assistive technologies like screen readers.
(b) At least one mode of operation and information retrieval that does not require visual acuity greater than 20/70 shall be provided in audio and enlarged print output working together or independently, or support for assistive technology used by people who are visually impaired shall be provided. | Supported | ActiveReports does not require visual acuity greater than 20/70. It is exposed to magnification tools like the Screen Magnifier that can be used for magnifying the screen.
(c) At least one mode of operation and information retrieval that does not require user hearing shall be provided, or support for assistive technology used by people who are deaf or hard of hearing shall be provided. | Not applicable | ActiveReports does not use any sound output. Hearing is not necessary to use the product.
(d) Where audio information is important for the use of a product, at least one mode of operation and information retrieval shall be provided in an enhanced auditory fashion, or support for assistive hearing devices shall be provided. | Not applicable | ActiveReports does not provide functionalities that require audio or video aids.
(e) At least one mode of operation and information retrieval that does not require user speech shall be provided, or support for assistive technology used by people with disabilities shall be provided. | Not applicable | ActiveReports does not provide any functionality that make use of user speech.
(f) At least one mode of operation and information retrieval that does not require fine motor control or simultaneous actions and that is operable with limited reach and strength shall be provided. | Supported | ActiveReports does not provide any functionality that requires fine motor control or simultaneous action.

Information, Documentation and Support

Show Section 1194.41

Criteria | Status | Remarks
(a) Product support documentation provided to end-users shall be made available in alternate formats upon request, at no additional charge. | Supported | Documentation is available in four formats: HTML(Web), *.chm, *.PDF, and Help3(Visual Studio help content)
(b) End-users shall have access to a description of the accessibility and compatibility features of products in alternate formats or alternate methods upon request, at no additional charge. | Supported | ActiveReports provides information about accessibility and compatibility features in the documentation. The documentation is exposed to screen readers.
(c) Support services for products shall accommodate the communication needs of end-users with disabilities. | Supported | Support services such as telephone, email and forum support are provided to the customers.

See Also

How To
How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


How To

How To
See Also
ActiveReports 13 > ActiveReports User Guide > How To

Glossary Item Box

Learn to perform common tasks with ActiveReports with quick how-to topics.

In this section

Page Report/RDL Report How To
Learn how to work with both Page report and RDL report, and perform various page report tasks.
Section Report How To
Learn how to work with Section reports and perform various reporting tasks specific to this type of report.
Customize, Localize, and Deploy
Learn how to customize each of the Windows and Web controls, how to localize reports and controls, and how to deploy Windows and Web applications.
Print
Learn about the various ways to print reports.
Use Fields in Reports
Learn how to utilize bound or database fields and calculated fields in reports.

See Also

Getting Started
Getting Started

Concepts
Concepts

Walkthroughs
Samples and Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page Report/RDL Report How To

Page Report/RDL Report How To
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To

Glossary Item Box

Learn to perform common tasks in Page Reports and RDL Reports with quick how-to topics.

In this section

Work with Data
Learn how to connect to different data sources and add a data set in a Page report or a RDL report.
Work with Report Controls and Data Regions
Learn how to use controls like the TextBox, Map or Image, and data regions like the Tablix or Table on Page Reports/RDL reports.
Create Common Page Reports
Learn how to work with both Page report and RDL report, and perform various report tasks.
Add Parameters
Learn how to add a parameters to your report so that the users can filter data.
Add Tooltips in Charts for HTML5 Viewer
Learn how to add tooltips to the Chart data region viewed in HTML5 Viewer.
Freeze Rows and Columns (RDL Report)
Learn how to freeze rows and columns in RDL reports viewed in HTML5 Viewer.
Create and Add Themes
Learn how to create and add new themes.
Customize and Apply a Theme
Learn how to modify an existing theme and apply them in your report.
Use Constant Expressions in a Theme
Learn how to set a constant expression in a theme and display it on your report.
Set Up Collation
Learn how a report renders when multiple themes are applied.
Add Hyperlinks
Learn how to add hyperlinks and improve interactivity in your report.
Add Bookmarks
Learn how to add bookmark links and improve interactivity in your report.
Create and Use a Master Report (RDL Report)
Learn how to create a master report and apply common features to any number of reports.
Work with Images
Learn how to add an embedded image, data visualizer, web image, or data base image.
Use Dynamically Build JSON Data Source
Learn how to dynamically buid JSON Data Source by using expressions.
Sort Data
Learn how to sort data in page layout.
Allow Users to Sort Data in the Viewer
Learn how to use the Interactive Sort settings on a TextBox report control.
Create a Drill-Down Report
Learn how to use the Visibility settings to toggle detail data within a report.
Set a Drill-Through Link
Learn how to set a drill-through link.
Add Items to the Document Map
Learn how to add items in the Document Map.
Change Page Size
Learn how to change page size in page layout.
Add Page Breaks in RDL (RDL Report)
Learn how to add page breaks in RDL reports.
Add Totals and Subtotals in a Data Region
Learn how to set totals and subtotals in all the data regions with illustrative examples.
Create a Simple Web Designer Sample
Learn how create a simple Web Designer sample.
Merge Multiple Reports
Learn how combine multiple Page and RDL reports.

See Also

Section Report How To
Page Report/RDL Report Concepts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Data

Work with Data
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data

Glossary Item Box

See step-by-step instructions for performing common tasks in Page Reports and RDL Reports.

In this section

Connect to a Data Source
Learn how to bind reports to various data sources.
Add a Dataset
Learn how to add a dataset in a report.
Work with Local Shared Data Sources
Learn how to create and edit a local shared data source, and connect to a local shared data source.
Bind Reports to a Data Source at Run Time
Learn how to bind a page report to a data source at run time.

See Also

How To
Page Report/RDL Report How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Connect to a Data Source

Connect to a Data Source
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Connect to a Data Source

Glossary Item Box

In a Page report or an RDL report, you can connect to a data source at design time through the Report Explorer. Use the following instructions to connect to various data providers supported in ActiveReports.

These steps assume that you have already added a Page Report/RDL Report in a Visual Studio project. See Adding an ActiveReport to a Project for further information.

To connect to SQL, OLEDB, Oracle, DataSet, ODBC, and Object data sources

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under Type, select the type of data source you want to use.
  4. Under Connection, enter a Connection String. If you select SQL, OleDB, or Oracle as the data source Type, Connection Properties, Connection String and Advanced Settings pages appear under Connection. If you select DataSet, ODBC, and Object data source Type, Connection Properties and Connection String pages appear. See Report Data Source Dialog for further details.
  5. Click the Validate Data Source icon to confirm the connection string. This icon becomes inactive to indicate success, while an error message indicates an invalid connection string.
  6. On the Credentials page, you can specify password, credentials, or Windows authentication.
  7. Click the OK button on the lower right corner to close the dialog. You have successfully connected the report to a data source.

To connect to an XML data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under Type, select XML Provider.
  4. In the Connection Properties tab, select the type of XML data from the following options:
    • External file or URL: Enter the path of an external XML source such as a local file or the http location of a file.
    • Embedded: Enter the path of the XML file to embed in the report. You can also enter the data manually or edit the data in selected XML file.
    • Expression: Enter the path expression. User can enter expression in Connection String or in Expression field in Connection Properties.
  5. Click the Connection String tab. The connection string generated must include xmldoc or xmldata. You can validate the connection string by clicking the Validate DataSource icon. For more information on XML connection string, see topic XML Provider.
  6. Click the OK button on the lower right corner to close the dialog. You have successfully connected the report to a data source.

To connect to a CSV data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under Type, select CSV Provider.
  4. In the Connection String tab, click the Build icon to open the Configure CSV Data Source wizard.
  5. Specify the Path by clicking the Open button and selecting the .csv file available locally, or via URL for centrally located CSV data source.
  6. Set other options in the wizard to generate the connection string. For more information on CSV connection strings, see the CSV Provider topic.
  7. To edit the Name and Data Type of columns shown in the Preview area, click the Get from preview button. With Fixed data, you can also edit the Width.
  8. Click OK to save the changes and close the dialog. The Connection String tab displays the generated connection string. You can validate the connection string by clicking the Validate DataSource icon.
  9. Click OK on the lower right corner to close the dialog. You have successfully connected the report to a CSV data source. Note that the dataset for the CSV data source is added automatically.

To connect to a JSON data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under Type, select JSON Provider. See JSON Provider for further details.
  4. In the Schema tab, specify the JSON schema file corresponding to your JSON data from the following options:
    • External file or URL: Enter the path or URL of an external JSON schema file or select the file from the drop-down which displays the JSON files available in the same folder as the report.
    • Embedded: Enter the path of the JSON schema file to embed in the report. You can enter the schema manually or edit the schema in the selected JSON file.
      For generating the JSON schema, use the JSON schema generator available at http://jsonschema.net/#/.
  5. In the Content tab, specify the JSON data file from the following available options:
    • External file or URL: Enter the path or URL of an external JSON data file or select the file from the drop-down which displays the JSON files available in the same folder as the report.
    • Embedded: Enter the path of the JSON data file to embed in the report. You can enter the data manually or edit the data in the selected JSON file.
    • Expression: Enter an expression to bind to the JSON data.
  6. Click the Connection String tab. The connection string generated must include jsondoc or jsondata and schemadoc or schemadata, depending on the options selected in Content and Schema tabs. You can validate the connection string by clicking the Validate DataSource icon. For more information on JSON connection string, see topic JSON Provider.
  7. Click the OK button on the lower right corner to close the dialog. You have successfully connected the report to the JSON data source.

See Also

Add a Dataset

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add a Dataset

Add a Dataset
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Add a Dataset

Glossary Item Box

In a Page report or an RDL report, once you connect your report to a data source, in order to get a list of fields to use in the report, you need to add a dataset. Use the following instructions to add a dataset to the report.

Note: The data set for a CSV data source is automatically created on adding the data source.

These steps assume that you have already added a Page Report/RDL Report template and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. In the Report Explorer, right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set... from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, select a Command Type from the dropdown list.

    • Text - Allows the user to enter a SQL query or XML path in the Query box. See Visual Query Designer for further information on how to create a query using the interactive query designer.
    • StoredProcedure - Allows the user to enter the name of the stored procedure in the Query box.
    • TableDirect - Allows the user to enter the name of the table in the Query box.
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. The fields are automatically added to the Fields page in the DataSet dialog. For XML data, manually enter fields on the Fields page using valid XPath expressions.
  6. You can also set parameters, filters, and data options on the other pages of the dialog.
  7. Click the OK button to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.
Note: In case you are using an XML or JSON data source provider, you have to provide an XML path or JSON path using XPath or JSONPath expressions on the Query page, and generate fields on the Fields page of the DataSet dialog. See the following examples for details.

Show Query and Field settings for XML Data

Connection String

Example of an xmldata connection string.
xmldata=<people>
  <person>
    <name>
      <given>John</given>
      <family>Doe</family>
    </name>
  </person>
  <person>
    <name>
      <given>Jane</given>
      <family>Smith</family>
    </name>
  </person>
</people>;

XMLPath on Query Page

An XMLPath expression returns a value from an XML data source when evaluated with the query. The XML path is represented by slash (/) and the brackets ([]) represent iteration over collection of elements.

For example: /people/person/name

You can also build the XMLPath using XML DataSet Query Builder. Click the Edit with XML Query Designer icon [image] to open XML DataSet Query Builder dialog and then choose the XPath from the tree nodes.

Fields

Once the query is set, build the Fields collection with two fields that contain the following name and value pairs:
Name: given; Value: given
Name: family; Value: family

See Use Fields in Reports to understand fields further.

Show Query and Field settings for JSON Data

Connection String

Example of a JSON data connection string.
jsondoc=C:\Data\customers.json;schemadata={
  "$schema": "http://json-schema.org/draft-04/schema#",
  "type": "object",
  "properties": {
    "address": {
      "type": "object",
      "properties": {
        "streetAddress": {
          "type": "string"
        },
        "city": {
          "type": "string"
        }
      },
      "required": [
        "streetAddress",
        "city"
      ]
    },
    "phoneNumber": {
      "type": "array",
      "items": {
        "type": "object",
        "properties": {
          "location": {
            "type": "string"
          },
          "code": {
            "type": "integer"
          }
        },
        "required": [
          "location",
          "code"
        ]
      }
    }
  },
  "required": [
    "address",
    "phoneNumber"
  ]
}

JSONPath on Query Page

A JSONPath expression returns a value from a JSON data source when evaluated with the query. The JSON path is usually represented by dot (.) notation, with the root object as '$'. The brackets ([]) represent the array of elements.

For example: $.Customers[*]

For more information, please see http://goessner.net/articles/JsonPath/.
You can also build the JSONPath using JSON Query Builder, which can be accessed from Edit with JSON Query Designer icon [image] . The JSON Query Builder displays the structure of the JSON data, obtained from the JSON schema. You can choose the JSONPath from the tree nodes. You can also choose to create multiple datasets - just check-on the Select multiple nodes option and select the nodes that you want to add as datasets.

Fields

Once the query is set, build the Fields collection with two fields that contain the following name and value pairs:
Name: CompanyName; Value: CompanyName
Name: ContactName; Value: ContactName

See Also

Connect to a Data Source

Concepts
DataSet Dialog

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Local Shared Data Sources

Work with Local Shared Data Sources
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Work with Local Shared Data Sources

Glossary Item Box

You can save a data connection type such as an OleDb connection, Json connection, or an XML connection as a Shared Data Source (RDSX). This topic provides the steps to create a shared data source with an OleDb data connection.

To create a shared data source

  1. Create a new Visual Studio project or open an existing one.
  2. In the Visual Studio project, add a Page Report or an RDL Report template to create a new report. See Adding an ActiveReport to a Project for further details.
  3. In the Report Explorer, click the Add icon on the top left and select Data Source...
  4. In the Report Data Source dialog that appears, go to the General page and set the following properties to create a connection to an OleDb data source.
    • Name: Any Name
    • Type: Microsoft OleDB Provider

    Under Connection, go to the Connection Properties tab and set:

    • OLE DB Provider: Microsoft.Jet.OLEDB.4.0
    • Server or file Name: Your .mdb file location
  5. In the Report Data Source dialog, click the OK button to close the dialog. A data source node appears in the Report Explorer.
  6. In the Report Explorer, right-click the data source and select Share Data Source.
  7. In the Save Shared Data Source File dialog that appears, enter the file name and click the Save button to save the file in RDSX format. Notice that the data source icon changes to show sharing.
    Data Source Icon Shared Data Source Icon

To connect to a shared data source

In ActiveReports, you can connect to most data sources using the steps in the Connect to a Data Source. However, you need to follow the steps below to connect to a Shared Data Source.

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Check the Shared Reference checkbox on.
  4. Under Reference, from the drop-down list, select From File...
  5. If you have selected the From File... option, in the Shared Data Source File dialog that appears, go to the folder where your shared data source file is located and select it. A file path appears in the field adjacent to the Browse button.
  6. Click the OK button on the lower right corner to close the dialog. A shared data source node appears in the Report Explorer.

To edit a shared data source

These steps assume that you have already connected your report to a shared data source.

  1. To open the Report Data Source dialog, do one of the following:
    • In the Report Explorer, right-click a shared data source node and in the context menu that appears, select Edit.
    • In the Report Explorer toolbar, click the Edit Shared Data Source button.
  2. In the Report Data Source dialog that appears, edit the data connection information.

See Also

Report Explorer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bind a Page Report to a Data Source at Run Time

Bind a Page Report to a Data Source at Run Time
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Bind a Page Report to a Data Source at Run Time

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to modify a data source at run time. See the following set of sample codes to connect your Page report or RDL report to a data source at run time.

To connect to an OleDB data source

Use the API to set a data source and dataset on a report at run time. These steps assume that you have already added a Page Report template and placed a Viewer control on a Windows Form in your Visual Studio project. See Adding an ActiveReport to a Project and Windows Forms Viewer for further information.

Note: You can use the code example below for the SQL, Odbc, OleDB or Oracle data source binding. To do that, modify the Data Provider Type and Connection String according to the data source.
  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface of the report.
  2. In the Table, select the following cells and go to Properties Window to set their Value property.
    Cell | Value Property
    Left Cell | =Fields!ProductID.Value
    Middle Cell | =Fields!InStock.Value
    Right Cell | =Fields!Price.Value
  3. Go to the Visual Studio Report Menu, and select Save Layout.
  4. In the Save As window that appears navigate to your project's folder and save the layout (like RuntimeBinding.rdlx) inside the bin/debug folder.
  5. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  6. Add the following code to the handler to connect to a data source, add a dataset and to supply data in the report.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    'create an empty page report
Dim def As New PageReport
'load the report layout
def.Load(New System.IO.FileInfo(Application.StartupPath + "\RuntimeBinding.rdlx"))
'create and setup the data source
Dim myDataSource As New GrapeCity.ActiveReports.PageReportModel.DataSource
myDataSource.Name = "Example Data Source"
myDataSource.ConnectionProperties.DataProvider = "OLEDB"
myDataSource.ConnectionProperties.ConnectString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Documents folder]\GrapeCity\ActiveReports 13\Samples\Data\Reels.mdb"
'setup the dataset
Dim myDataSet As New GrapeCity.ActiveReports.PageReportModel.DataSet()
Dim myQuery As New GrapeCity.ActiveReports.PageReportModel.Query()
myDataSet.Name = "Example Data Set"
myQuery.DataSourceName = "Example Data Source"
myQuery.CommandType = GrapeCity.ActiveReports.PageReportModel.QueryCommandType.TableDirect
myQuery.CommandText = GrapeCity.ActiveReports.Expressions.ExpressionInfo.FromString("Product")
myDataSet.Query = myQuery
' add fields
Dim _field As New GrapeCity.ActiveReports.PageReportModel.Field("ProductID", "ProductID", Nothing)
myDataSet.Fields.Add(_field)
_field = New GrapeCity.ActiveReports.PageReportModel.Field("InStock", "InStock", Nothing)
myDataSet.Fields.Add(_field)
_field = New GrapeCity.ActiveReports.PageReportModel.Field("Price", "Price", Nothing)
myDataSet.Fields.Add(_field)
'bind the data source and the dataset to the report
def.Report.DataSources.Add(myDataSource)
def.Report.DataSets.Add(myDataSet)
def.Run()
Viewer1.LoadDocument(def.Document)

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    //create an empty page report
GrapeCity.ActiveReports.PageReport def = new GrapeCity.ActiveReports.PageReport();
//load the report layout
def.Load(new System.IO.FileInfo(Application.StartupPath + "\RuntimeBinding.rdlx"));
//create and setup the data source
GrapeCity.ActiveReports.PageReportModel.DataSource myDataSource = new GrapeCity.ActiveReports.PageReportModel.DataSource();
myDataSource.Name = "Example Data Source";
myDataSource.ConnectionProperties.DataProvider = "OLEDB";
myDataSource.ConnectionProperties.ConnectString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Documents folder]\\GrapeCity\\ActiveReports 13\\Samples\\Data\\Reels.mdb";
//setup the dataset
GrapeCity.ActiveReports.PageReportModel.DataSet myDataSet = new GrapeCity.ActiveReports.PageReportModel.DataSet();
GrapeCity.ActiveReports.PageReportModel.Query myQuery = new GrapeCity.ActiveReports.PageReportModel.Query();
myDataSet.Name = "Example Data Set";
myQuery.DataSourceName = "Example Data Source";
myQuery.CommandType = GrapeCity.ActiveReports.PageReportModel.QueryCommandType.TableDirect;
myQuery.CommandText = GrapeCity.ActiveReports.Expressions.ExpressionInfo.FromString("Product");
myDataSet.Query = myQuery;
// add fields
GrapeCity.ActiveReports.PageReportModel.Field _field = new
GrapeCity.ActiveReports.PageReportModel.Field("ProductID", "ProductID", null);
myDataSet.Fields.Add(_field);
_field = new GrapeCity.ActiveReports.PageReportModel.Field("InStock", "InStock", null);
myDataSet.Fields.Add(_field);
_field = new GrapeCity.ActiveReports.PageReportModel.Field("Price", "Price", null);
myDataSet.Fields.Add(_field);
//bind the data source and the dataset to the report
def.Report.DataSources.Add(myDataSource);
def.Report.DataSets.Add(myDataSet);
def.Run();
viewer1.LoadDocument(def.Document);
  7. Press F5 to run the Application.

To connect to an unbound Data Source

To connect to unbound data sources at run time, you can use the DataSet provider or the Object provider with the LocateDataSource event. The reporting engine raises the LocateDataSource event when it needs input on the data to use.

Show DataSet provider

With the DataSet provider, the ConnectionString and Query settings vary depending on how you connect to data.

To use the LocateDataSource event to bind the report to data, leave the ConnectionString blank.

  • If LocateDataSource returns a DataSet, the Query is set to the DataSet table name.
  • If LocateDataSource returns a DataTable or DataView, the Query is left blank.

To bind a report to a dataset located in a file, set the ConnectionString to the path of the file, and set the Query to the DataSet table name.

Limitations of the Dataset Provider

  • Relationship names that have periods in them are not supported.
  • Fields in nested relationships only traverse parent relationships (e.g. FK_Order_Details_Orders.FK_Orders_Customers.CompanyName).

Show Parent Table Fields

To request a field from a parent table, prefix the field name with the name of the relation(s) that must be traversed to navigate to the appropriate parent table. Separate field names and relations with periods.

For example, consider a main table named OrderDetails which has a parent table named Orders. A relation named Orders_OrderDetails defines the relationship between the two tables. Use a field with the syntax below to access the OrderDate from the parent table:

Orders_OrderDetails.OrderDate

Use this same technique to traverse multiple levels of table relations. For example, consider that the Orders table used in the prior example has a parent table named Customers and a relation binding the two called Customers_Orders. If the CommandText specifies the main table as OrderDetails, use the following syntax to get the CustomerName field from the parent table:

Customers_Orders.Orders_OrderDetails.CustomerName
Note: Ambiguity can occur if a field and a relation have the same name. This is not supported.

Show To use the Dataset Provider

You can use the API to set a dataset on a report at run time.

The Dataset provider returns a data table. All fields in the data table are available. To use the Dataset provider as a report's data source, set up a report definition and run time, and attach the page document to a LocateDataSourceEventHandler.

These steps assume that you have already added a Page Report template and placed a Viewer control on a Windows Form in your Visual Studio project. See Adding an ActiveReport to a Project and Windows Forms Viewer for further information.

  1. In the Report Explorer, go to the DataSources node and right-click to select Add Data Source.
  2. In the Report Data Source dialog that appears, set Type to DataSetProvider and close the dialog. A data source node appears in the ReportExplorer.
  3. Right-click the data source node and to select Add Data Set.
  4. In the DataSet dialog that appears select the Fields page.
  5. On the Fields page, add a fields like =Fields!ProductID.Value and =Fields!InStock.Value.
  6. Click OK to close the dialog. Nodes with the field names appear under the dataset name.
  7. From the Visual Studio toolbox ActiveReports 13 Page Report tab, drag a Table data region onto the design surface of the report.
  8. From the ReportExplorer, add the newly added fields onto cells in the detail row of the Table and save the report.
  9. In the Visual Studio Solution Explorer, right-click YourProjectName and select Add > Class.
  10. In the Add New Item window that appears, rename the class to DataLayer.cs or .vb and click Add.
  11. In the Solution Explorer, double-click the DataLayer.cs or .vb to open the code view of the class and paste the following code inside it.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the DataLayer class. Copy Code
    Imports GrapeCity.ActiveReports.Expressions.ExpressionObjectModel
Imports System.Globalization
Imports System.Data.OleDb

Friend NotInheritable Class DataLayer
    Private _datasetData As System.Data.DataSet

    Public Sub New()
        LoadDataToDataSet()
    End Sub

    Public ReadOnly Property DataSetData() As System.Data.DataSet
        Get
           Return _datasetData
        End Get
    End Property

    Private Sub LoadDataToDataSet()
        Dim connStr As String = "Provider=Microsoft.Jet.OLEDB.4.0;Persist Security Info=False;
                Data Source=[User Documents folder]\\GrapeCity\\ActiveReports 13\\Samples\\Data\\Reels.mdb"
        Dim productSql As String = "SELECT top 100 * FROM Product"

        _datasetData = New DataSet()
        Dim conn As New OleDbConnection(connStr)
        Dim cmd As OleDbCommand = Nothing
        Dim adapter As New OleDbDataAdapter

       cmd = New OleDbCommand(productSql, conn)
       adapter.SelectCommand = cmd
       adapter.Fill(_datasetData, "Products")
    End Sub

End Class

    Show To write the code in C#

    C# code. Paste inside the DataLayer class. Copy Code
    using System;
using System.Data;
using System.Data.OleDb;

internal sealed class DataLayer
{
    private DataSet dataSetData;
        public DataLayer()
        {
                LoadDataToDataSet();
        }

        public DataSet DataSetData
        {
                get { return dataSetData; }
        }

        private void LoadDataToDataSet()
        {
        string connStr = @"Provider=Microsoft.Jet.OLEDB.4.0;Persist Security Info=False;
                Data Source=[User Documents folder]\\GrapeCity\\ActiveReports 13\\Samples\\Data\\Reels.mdb";
        string productSql = "SELECT * From Product";

                dataSetData = new DataSet();
        OleDbConnection conn = new OleDbConnection(connStr);
        OleDbCommand cmd = new OleDbCommand(productSql, conn);
        OleDbDataAdapter adapter = new OleDbDataAdapter();
        adapter.SelectCommand = cmd;
        adapter.Fill(dataSetData, "Products");
        }
}
    Note: The DataSetDataSource sample provides context on how to create the DataLayer class, used in the code below. The DataSetDataSource sample is included in the ActiveReports installation and is located in the [UserDocumentFolder]\GrapeCity Samples\ActiveReports 13\Page Reports\RDL\API folder.
  12. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event and add the following code to the handler.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    LoadReport()
    Visual Basic.NET code. Paste INSIDE the class declaration of the form. Copy Code
    Dim WithEvents runtime As GrapeCity.ActiveReports.Document.PageDocument

Private Sub LoadReport()
    Dim rptPath As New System.IO.FileInfo("..\..\YourReportName.rdlx")
    'Create a report definition that loads an existing report.
    Dim definition As New GrapeCity.ActiveReports.PageReport(rptPath)
    'Load the report definition into a new page document.
    runtime = New GrapeCity.ActiveReports.Document.PageDocument(definition)
    'Attach the runtime to an event. This line of code creates the event shell below.
    Viewer1.LoadDocument(runtime)
End Sub

'ActiveReports raises this event when it cannot locate a report's data source in the usual ways.
Private Sub runtime_LocateDataSource(ByVal sender As Object, ByVal args As GrapeCity.ActiveReports.LocateDataSourceEventArgs) Handles Runtime.LocateDataSource
    Dim dl = New DataLayer
    args.Data = dl.DataSetData.Tables("Products")
End Sub

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    LoadReport();
    C# code. Paste INSIDE the class declaration of the form. Copy Code
    private void LoadReport()

{
   System.IO.FileInfo rptPath = new System.IO.FileInfo("..\\..\\YourReportName.rdlx");
   //Create a report definition that loads an existing report.
   GrapeCity.ActiveReports.PageReport definition = new GrapeCity.ActiveReports.PageReport(rptPath);
   //Load the report definition into a new page document.
   GrapeCity.ActiveReports.Document.PageDocument runtime = new GrapeCity.ActiveReports.Document.PageDocument(definition);
   //Attach the runtime to an event. This line of code creates the event shell below.
   runtime.LocateDataSource += new GrapeCity.ActiveReports.LocateDataSourceEventHandler(runtime_LocateDataSource);
   viewer1.LoadDocument(runtime);
}

//ActiveReports raises this event when it cannot locate a report's data source in the usual ways.
private void runtime_LocateDataSource(object sender, GrapeCity.ActiveReports.LocateDataSourceEventArgs args)
{

   DataLayer dl = new DataLayer();
   args.Data = dl.DataSetData.Tables["Products"];
}

Show Object Provider

Use the API to bind a report data source to a collection of objects. To bind the Object provider to a report, set up a report definition and a page document, and attach the page document to a LocateDataSourceEventHandler. Create a public class which sets up a property name to which the data field can bind.

The Object provider data source must have a dataset with the Query left blank and fields that correspond to the fields of your Object provider data source. Add these fields manually in the DataSet Dialog under Fields.

When using the Object provider, always leave the report's ConnectionString blank because it uses the LocateDataSource event to bind to an Object. Set the Query to one of these values:

Show To use the Object Provider

These steps assume that you have already added a Page Report template and placed a Viewer control on a Windows Form in your Visual Studio project. See Adding an ActiveReport to a Project and Windows Forms Viewer for further information.

  1. In the Report Explorer, go to the DataSources node and right-click to select Add Data Source.
  2. In the Report Data Source dialog that appears, set Type to ObjectProvider and close the dialog. A data source node appears in the ReportExplorer.
  3. Right-click the data source node and in the DataSet dialog that appears select the Fields page.
  4. In the Fields page, add a field like =Fields!name.Value and click ok to close the dialog. A node with the field name appears under the dataset name.
  5. From the Visual Studio toolbox ActiveReports 13 Page Report tab, drag a Table data region onto the design surface of the report.
  6. From the ReportExplorer, add the newly added field onto a cell in the detail row of the Table.
  7. Save the report as DogReport.rdlx.
  8. In the Solution Explorer, right-click the Form and select View Code to open the Code View.
  9. In the Code View of the form, paste the following code inside the class declaration.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the class declaration of the form. Copy Code
    ' Create a class from which to call a property.
Public Class dog
   Private _name As String
   Public Property name() As String
      Get
         Return _name
      End Get
      Set(ByVal value As String)
         _name = Value
      End Set
   End Property
End Class
' Create an array to contain the data.
Dim dogArray As System.Collections.ArrayList
' Create a method to populate the data array.
Private Sub LoadData()
   dogArray = New System.Collections.ArrayList()
   Dim dog1 As New dog()
   dog1.name = "border collie"
   dogArray.Add(dog1)
   dog1 = New dog()
   dog1.name = "cocker spaniel"
   dogArray.Add(dog1)
   dog1 = New dog()
   dog1.name = "golden retriever"
   dogArray.Add(dog1)
   dog1 = New dog()
   dog1.name = "shar pei"
   dogArray.Add(dog1)
End Sub

    Show To write the code in C#

    C# code. Paste INSIDE the class declaration of the form. Copy Code
    // Create a class from which to call a property.
public class dog
{
   private string _name;
   public string name
  {
      get { return _name; }
      set { _name = value; }
   }
}
// Create an array to contain the data.
System.Collections.ArrayList dogArray;
// Create a method to populate the data array.
private void LoadData()
{
   dogArray = new System.Collections.ArrayList();
   dog dog1 = new dog();
   dog1.name = "border collie";
   dogArray.Add(dog1);
   dog1 = new dog();
   dog1.name = "cocker spaniel";
   dogArray.Add(dog1);
   dog1 = new dog();
   dog1.name = "golden retriever";
   dogArray.Add(dog1);
   dog1 = new dog();
   dog1.name = "shar pei";
   dogArray.Add(dog1);
}
  10. Set up the report and add a handler for the LocateDataSource event.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
   ' Create file info with a path to the report in your project.
   Dim fi As New System.IO.FileInfo("..\\..\\DogReport.rdlx")
   ' Create a report definition using the file info.
   Dim repDef As New GrapeCity.ActiveReports.PageReport(fi)
   ' Create a page document using the report definition.
   Dim runt As New GrapeCity.ActiveReports.Document.PageDocument(repDef)
   ' Create a LocateDataSource event for the runtime.
   AddHandler runt.LocateDataSource, AddressOf runt_LocateDataSource
  ' Display the report in the viewer. The title can be any text.
   Viewer1.LoadDocument(runt)
End Sub

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    private void Form1_Load(object sender, EventArgs e)
{
   // Create file info with a path to the report in your project.
   System.IO.FileInfo fi = new System.IO.FileInfo("..\\..\\DogReport.rdlx");
   // Create a report definition using the file info.
   GrapeCity.ActiveReports.PageReport repDef = new GrapeCity.ActiveReports.PageReport(fi);
   // Create a page document using the report definition.
   GrapeCity.ActiveReports.Document.PageDocument runt = new GrapeCity.ActiveReports.Document.PageDocument(repDef);
   // Create a LocateDataSource event for the runtime.
   runt.LocateDataSource += new GrapeCity.ActiveReports.LocateDataSourceEventHandler(runt_LocateDataSource);
   // Display the report in the viewer. The title can be any text.
   viewer1.LoadDocument(runt);
}
  11. Use the LocateDataSource event to load data from the object.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the class declaration of the form. Copy Code
    Private Sub runt_LocateDataSource(ByVal sender As Object, ByVal args As GrapeCity.ActiveReports.LocateDataSourceEventArgs)
   If dogArray Is Nothing Then LoadData()
   args.Data = dogArray
End Sub

    Show To write the code in C#

    C# code. Paste INSIDE the class declaration of the form. Copy Code
    void runt_LocateDataSource(object sender, GrapeCity.ActiveReports.LocateDataSourceEventArgs args)
{
   if (dogArray == null)
   {
      LoadData();
   }
   args.Data = dogArray;
}
  12. Press F5 to run the application.

See Also

Concepts
Data Sources and Datasets

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Report Controls and Data Regions

Work with Report Controls and Data Regions
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions

Glossary Item Box

Learn to perform common tasks with ActiveReports with quick how-to topics.

In this section

Group in a FixedPage
Learn how group data on the fixed page to apply grouping on the entire report instead of a single control.
Group in a Data Region
Learn how to group data in a data region like Table, List, BandedList, Tablix and Chart.
Set Detail Grouping In Sparklines
Learn how to set detail grouping to reflect a trend in your data with sparklines.
Set Filters
Learn how set filters in your report and limit the data you want to display.
Set FixedSize of a Data Region
Learn how to set the FixedSize property of a Data Region using the resize handler and the Properties window.
Work with Map
Learn how to work with layers and data in a Map control.
Add Table Of Contents
Learn how to use the TableOfContents control to create an organized hierarchy.
Merge Cells in a Data Region
Learn how to merge cells in Table and Tablix data regions.

See Also

Create Common Page Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Group in a FixedPage

Group in a FixedPage
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Group in a FixedPage

Glossary Item Box

In a Page Report, you can group your data on the fixed page. A group set on the fixed page, applies to the entire report including the controls within the report. Therefore, once you set grouping here, you may decide not to group individual data regions.

Use the following steps to understand grouping on a fixed page. These steps assume that you have already added a Page Report template, connected it to a data source and created a dataset. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

Note: This topic uses the Movie table in the Reels database. By default, the Reels.mdb file is located in [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  1. Right-click the gray area outside the design surface and select Fixed Layout Settings or with the fixed page selected, under the Properties Window, click the Property dialog link to open the FixedPage dialog.
  2. On the Grouping page, in the General tab, under Group on enter the field name or expression on which you want to group the data. For example, =Fields!YearReleased.Value.
    Note: A default group name like FixedPage1_Group appears under Name, once you set the group. To modify the group name, add a field name or expression under Group on to enable the Name option and enter a new name.
  3. Under the Document map label field, you can optionally set a label to add the item to the document map.
  4. Click OK to close the dialog.
  5. Drag and drop a data region, like a Table onto the design surface and set data inside its cells.
  6. Go to the Preview Tab to view the result. You'll notice that the data appears in groups sorted according the YearReleased field on each report page.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Grouping Data (Page Layout)
Group in a Data Region

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Group in a Data Region

Group in a Data Region
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Group in a Data Region

Glossary Item Box

Show All Show All
Hide All Hide All

In a page report/RDL report, group your data from a data region on fields and expressions. Each data region provides grouping in a different way.

Use the steps below to learn how to set groups in each data region. These steps assume that you have already added a Page Report/RDL Report template and connected it to a data source. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: This topic uses examples from the Movie table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.

To set grouping in a Table

To group data in a Table data region, add group header and footer rows to the table or set detail grouping.

Show To add groups in a Table

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. With the Table selected on the report, under the Properties window, click the Property dialog link to open the Table dialog.
  3. In the table dialog that appears go to the Groups page and click the Add (+) button to add a group manually.
  4. In this dialog, on the General tab, under Group on enter the field name or expression on which you want to group the data. For e.g., =Fields!YearReleased.Value.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    Note: A default group name like Table1_Group1 appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  5. Under the Document map label, you can optionally set a label to add the item to the document map. See Document Map for further information.
  6. Under Parent group, you can optionally set the parent group for a recursive hierarchy.
  7. Click OK to close the dialog. Group header and group footer rows appear right above and below the table details row.
  8. Drag and drop fields onto the Table data region and in the group header row, add the field on which the grouping is set.
  9. Preview the report to see the result.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
Tip: You can sort, filter, set page breaks or repeat headers for your grouped data in the other tabs of the Table-Groups dialog.

Show To set detail grouping in a Table

Detail Grouping is useful when you do not want to repeat values within the data on display in the report.

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. With the Table selected on the report, under the Properties Window, click the Property dialog link to open the Table dialog > Detail Grouping page.
  3. In the Detail Grouping page, under Group on enter the expression on which you want to group the data. For e.g., =Fields!YearReleased.Value

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    Note: A default group name like Table1_Detail_Group1 appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  4. Under the Document map label, you can optionally set a label to add the item to the document map. See Document Map for further information.
  5. Under Parent group, you can optionally set the parent group for a recursive hierarchy.
  6. Click OK to close the dialog.
  7. Drag and drop fields onto the Table data region and go to the preview tab to see grouped data.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
Tip: You can filter, set page breaks or set visibility for your grouped data in the other tabs of the Table-Detail Grouping page.

To set detail grouping in a List

To group data in a List data region, set detail grouping. Detail Grouping is useful when you do not want to repeat values within the data on display in the report.

  1. From the Visual Studio toolbox, drag and drop a List data region onto the design surface.
  2. With the List selected on the report, under the Properties window, click the Property dialog link to open the List dialog > Detail Grouping page.
  3. In the Detail Grouping page, under Group on enter the expression on which you want to group the data. For e.g., =Fields!YearReleased.Value.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    Note: A default group name like List1_Detail_Group appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  4. Under the Document map label field, you can optionally set a label to add the item to the document map. See Document Map for further information.
  5. Under the Parent group field, you can optionally set the parent group for a recursive hierarchy.
  6. Click OK to close the dialog.
  7. Drag and drop fields or other data regions onto the List data region and go to the preview tab to see grouped data.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
Tip: You can place lists within lists to create nested grouping. You can also filter, set page breaks or set sorting for your grouped data in the other tabs of the List-Detail Grouping page.

To set grouping in a BandedList

To group data in a BandedList data region, add the BandedList group header and footer row.

  1. From the Visual Studio toolbox, drag and drop a BandedList data region onto the design surface.
  2. Right-click the BandedList data region and select Insert Group to open the Banded List-Groups dialog.
    OR
    With the BandedList selected on the report, under the Properties Window, click the Property dialog link to open the Banded List dialog > Groups page. However, you have to click the Add (+) button and add the group manually in this case.
  3. In the Groups page, under Group on enter the field name or expression on which you want to group the data. For e.g., =Fields!YearReleased.Value.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    Note: A default group name like BandedList1_Group1 appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  4. Under the Document map label field, you can optionally set a label to add the item to the document map. See Document Map for further information.
  5. Under Parent group you can set the parent group for a recursive hierarchy.
  6. Click the OK to close the dialog.
  7. Drag and drop fields onto the BandedList data region and go to the preview tab to see grouped data.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To set grouping in a Chart

To group data in a Chart data region, set grouping for categories or series. In a Chart, you can set groups directly on the design surface or add category groups and series groups manually.

Show To dynamically group a Chart category or series

  1. From the Visual Studio toolbox, drag and drop a Chart data region onto the design surface.
  2. From the Report Explorer,
  3. Drag a field near the lower edge of the Chart and drop it onto the part that reads Drop category fields here. This action groups the categorized chart data on the field set here.
  4. Drag a field near the upper edge of the Chart and drop it onto the part that reads Drop data fields here. This adds data which is to be grouped to the chart.
  5. Drag a field near the right edge of the Chart and drop it onto the part that reads Optionally drop series fields here. This action groups data on series.

Show To manually group a Chart category or series

  1. From the Visual Studio toolbox, drag and drop a Chart data region onto the design surface.
  2. With the Chart data region selected on the report, under the Properties Window, click the Chart Data link to open the Chart Data dialog.
  3. In the Chart Data dialog, go to the Category Groups page and click the Add button to add a new group.
  4. Enter an expression under Group on on which you want to categorize the data. For e.g., =Fields!Title.Value.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  5. In the Chart Data dialog, go to the Series Groups page and click the Add button to add a new group.
  6. Enter an expression under Group on on which you want to group your series data. For e.g., =Fields!Country.Value.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  7. Click OK to close the dialog.
  8. Drag the UserRating field near the upper edge of the Chart and drop it onto the part that reads, Drop data fields here. This adds data which is to be grouped to the chart.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
Note: A default group name like Chart1_CategoryGroup1 or Chart1_SeriesGroup1 appear under Name, until you set the grouping expression under Group On, after which you can modify the group name.

To set gouping in a Tablix

To group data in a Tablix data region, set row and column group expressions.

  1. From the Visual Studio toolbox, drag a Tablix data region and drop it onto the report design surface.
  2. Right-click the row or column where you want to insert a group, click Add Column Group, and select the type of grouping you want to implement. The group is added and appears in the Group Editor window.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

    Note: By default, a Tablix data region includes a column group and a row group. For more information, see Tablix.
  3. In the Group Editor, select the new group so that its properties display in the Properties window.
  4. In the Properties window, expand the Group property node and click the ellipsis button next to the GroupExpressions property to open the ExpressionDesigner Collection Editor.
  5. In the ExpressionDesigner Collection Editor that appears, click Add to create a new group hierarchy member.

  6. Select the group member from the Members list and in the property grid to the right, enter an expression to group the data. For example: =Fields!YearReleased.Value
  7. Click OK to close the dialog.
  8. Drag and drop fields in the body area (bottom right corner) of the Tablix data region and go to the Preview Tab to view the result.

See Also

Grouping Data (Page Layout)
Group in a FixedPage
Tablix
Tablix Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Set Detail Grouping In Sparklines

Set Detail Grouping In Sparklines
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Set Detail Grouping In Sparklines

Glossary Item Box

Applying detail grouping to a sparkline helps to visualize data clearly – the sparkline value is displayed as a set of sparklines grouped by a detail grouping value. The following steps take you through how to show trends in analyzed data when detail grouping is set with Sparklines.

These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a dataset. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: This topic uses examples from the SalesByGenre table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  1. From the toolbox, drag a Table data region onto the report design surface.
  2. With the table selected, set the following:
    • Set the DataSetName property (For example, SalesByGenre).
    • Right-click the table handle to the left of the Detail row and select Insert Row Below or Insert Row Above from the menu and add another detail row to the table.
    • Hover your mouse over the first Textbox located in the Detail row column to make the Field Selection Adorner appear. Click this adorner to display a list of available fields from the data set, select a field (For example, GenreName).
      Note: This automatically places an expression in the detail row and simultaneously places a static label Genre Name in the header row of the same column.
  3. From the toolbox, drag a Sparkline control to the second detail row of the table on your report and set the following in the Properties Window.
    • Set the SparklineType property to Line (by default).
    • Set the DataSetName property to a data set (For example, SalesByGenre).
    • Set the SeriesValue property by selecting <Expression...>. In the Expression Editor under Fields, expand the Fields (SalesByGenre) node and select a numeric field from the connected data set (for example, =Fields!Profit.Value). Click the OK button to accept the change.
    • Set the LineColor property to Gray.
    • Set the MarkerColor property to Blue.
  4. To apply the detail grouping to the sparkline, right-click the Table data region and go to Properties Window to select the Properties dialog command at the bottom.
  5. In the Table dialog that appears, select the Detail Grouping.
  6. In the General tab, under Group on, select an expression from the drop-down list on which to group the data (for example, =Fields!GenreName.Value).
  7. Click the OK button to close the dialog and save the changes.
  8. Go to the preview tab to view the sparkline you have added to your report.

This set of sparklines display the profit value grouped by the movie genres.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Set Filters

Set Filters
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Set Filters

Glossary Item Box

Show All Show All
Hide All Hide All

Normally you can filter your data using parameters in a query, but if your data source does not support parameters you can use filters. You can set filters on the following:

  • DataSet
  • Data Region
  • Groups in a Data Region

In a Page Report, you can also set filters on the page through the FixedPage dialog.

Use the following steps to create filters in a page report and RDL report. These steps assume that you have already added a Page Report/RDL Report template and have a data connection and a dataset in place. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

To set filters on a DataSet

When you set a filter on a dataset, any control you add to the design surface can utilize this filtered data.

  1. In the Report Explorer, right-click the DataSet node and select Edit.
  2. In the DataSet dialog that appears, select the Filters page and click the Add (+) icon to add a new filter for the data set. By default, an empty filter expression gets added to the filter list.
  3. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!YearReleased.Value
  4. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, set a GreaterThan operator on the Expression above. See Filtering for a list of available operators and their description.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  5. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 2000 to represent the year 2000.

    The resultant filter looks like the following.
    =Fields!YearReleased.Value > 2000

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To set filters in a Data Region

When you set a filter in a data region, you can limit the amount of data available for use inside that data region.

  1. With the data region selected on the report, under the Properties window, click the Property dialog link. This is a command to open the corresponding data region dialog. See Properties Window for more on how to access commands.
    Note: In a Classic Chart data region, right-click the data region and choose the Chart data option to open the Chart Data dialog.
  2. In the data region dialog that appears, select the Filters page and click the Add (+) icon to add a new filter for the data region. By default, an empty filter expression gets added to the filter list.
  3. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!UserRating.Value
  4. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, set a LessThan operator on the Expression above. See Filtering for a list of available operators and their description.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  5. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 6 to represent the Rating 6.

    The resultant filter looks like the following.
    =Fields!UserRating.Value < 6

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To set filters on groups in a Data Region

You can also set filters on grouped data in a data region. The following example uses the Table data region to show filtering on groups.

  1. In the report, set grouping on a data region. For example, on a Table data region, set grouping on the =Fields!YearReleased.Value field. See Group in a Data Region for further details.
  2. With the data region selected on the report, under the Properties window, click the Property dialog link. This is a command to open the corresponding data region dialog. See Properties Window for more on how to access commands.
    Note: In a Classic Chart data region, right-click the data region and choose the Chart data option to open the Chart Data dialog.
  3. In the Table dialog, go to the Groups tab and select the Group.
  4. After selecting the group, go to the Filters tab and click the Add (+) icon to add a new filter. By default, an empty filter expression gets added to the filter list.
  5. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!YearReleased.Value
  6. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, GreaterThan operator set on the Expression above. See Filtering for a list of available operators and their description.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  7. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 2000 to represent the year 2000.

    The resultant filter looks like the following.
    =Fields!YearReleased.Value > 2000

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Concepts
Filtering

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Set FixedSize of a Data Region

Set FixedSize of a Data Region
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Set FixedSize of a Data Region

Glossary Item Box

FixedSize property of a Page Report is used to set the exact height or width (or both) that the data region will occupy at run time. Using this property, you can control the number of records that are displayed on each page.

In case there are more records to display than what FixedSize can accommodate, the remaining records get displayed on the next page. However, in case there is an OverflowPlaceHolder control bound to a data region on the same page, the remaining records are displayed at the location where the OverflowPlaceHolder control is placed. When you link a data region to an OverflowPlaceHolder, this control gets its Size property value from the Size of the data region it is linked with. However, it is also possible to change the Size (Height and Width) property values of OverflowPlaceHolder control based on the requirement of your Page Report.

Caution: The Size of an OverflowPlaceHolder cannot be changed to a value which is less than the Size of a data region it is linked with.

The significance of the FixedHeight and FixedWidth property depends on the data region that is being used. For example, in case of Table data region, only the FixedHeight property holds importance as the Table control always grows vertically to accommodate excessive data, while in case of Tablix data region both FixedHeight and FixedWidth properties are important as the control expands both vertically and horizontally to fit excessive data.

The table below show the data regions that contains the FixedSize property and their support for FixedHeight and FixedWidth properties:

Data Region | Supported Property
Table | FixedHeight
Tablix | FixedHeight and FixedWidth both
List | FixedHeight
BandedList | FixedHeight

To set the FixedSize Property

You can use the Properties Window to set the FixedHeight and FixedWidth properties of a data region manually, or use the resize handlers that appears around the data region to set the FixedSize.

Follow these steps to set FixedSize through the Properties window:

  1. From the Visual Studio toolbox, drag and drop a data region like List or a Table control onto the design surface.
  2. On the design surface, click the data region to select it and go to the Properties Window.
  3. In the Properties Window, locate and expand the FixedSize property node to assign values for the Height and Width.

Follow these steps to set FixedSize using the resize handlers:

  1. From the Visual Studio toolbox, drag and drop a data region like List or a Table control onto the design surface. Notice the resize handlers that appear around the data region.
  2. Use mouse to drag the resize handlers to set the FixedSize area of a data region.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Map

Work with Map
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map

Glossary Item Box

Learn using Map data region in Page Reports and RDL Reports.

In this section

Create a Map
Learn how to add and create a Map in a Report.
Add Data
Learn how to add and work with data in a Map control.
Work with Layers
Learn how to use different layers to display different data on a Map data region.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create a Map

Create a Map
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Create a Map

Glossary Item Box

Show All Show All
Hide All Hide All

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The Map data region shows your business data against a geographical background. This topic illustrates how to create a Map and modify its appearance.

These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

To add a map to the report

  1. From the Visual Studio toolbox, drag a Map control onto the design surface.

  2. In the Select a Map Template wizard that appears, select a map template from the following options:

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    • Empty map: An empty map without any predefined data.
    • USA map: A map with the predefined polygon layer that contains the embedded spatial data with the USA map.
    • From ESRI file: Select from your local .shp file, the shapefile spatial data format that complies with the Environmental Systems Research Institute, Inc. (ESRI). An ESRI Shapefile is a collection of files, where a .shp file defines the geographical or geometrical shapes and the .dbf file provides attributes for the shapes in the .shp file. To successfully add spatial data using this option, both files (.shp and .dbf) must be copied to the same folder. ESRI files are available on public domain data sources on the Web, including government and university sites. For more information, go to www.census.gov/geo/maps-data/data/tiger.html.

To modify the appearance of the map

  1. On the design surface, select the Map control and click the Property dialog link in the command section that appears below the properties window.

  2. In the Map dialog that appears, on the General page, enter "Map" in the Name textbox. You can also make modifications in properties that control the smoothing mode of all map elements (Antialiasing and Antialiasing quality).

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  3. On the Visibility page of the dialog, you can setup the visibility mode of the map.

  4. On the Appearance page of the dialog, you can make modifications to the border width, style, color and background color.

  5. On the Data Output page of the dialog, choose from Auto, Yes or No to decide whether to include this map in the XML output. Also, if you choose to include this map in the XML output, then in Element Name, enter a name to be used in the XML output for this map. Choosing Auto will include the map in the XML output.

  6. Click OK to close the dialog.

To add a legend to the map

A legend on a map provides valuable information to users for interpreting the map data visualization rules such as color, size, and marker type differences for map elements on a layer. By default, a single Legend item already exists in the legends collection which can be used by all layers to display items. You can also create additional legends to use them individually with layers that have associated rules to display items in the legend. Use these steps to learn adding and setting a legend on a map:

  1. On the design surface, select the Map control.
  2. In the Properties window, click the Legends (Collection) property and then click the ellipsis (...) button that appears.

  3. In the LegendDesigner Collection Editor that appears, click Add under the Members list of legends. Legend1 with the default legend settings appears in the Members list.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. With Legend1 selected in the Members list of legends, you can make modifications to its font, border and background color settings.

  5. Click OK to close the dialog.

    Note: You can associate the newly added legend to a layer by specifying its name in the Legend Name field that appears in the Legend tab on a specific rule page of a Layer dialog. See, Use Color Rule, Marker Rule and Size Rule for more information.

To add a title to the map

Map Title describes the theme or subject of the map. The purpose of map title is to tell the viewer of what he is looking at. Use these steps to learn adding a title on a map control.

  1. On the design surface, select the Map control.
  2. In the Properties window, click the Titles (Collection) property and then click the ellipsis (...) button that appears.

  3. In the MapTitleDesigner Collection Editor that appears, in the Members list of titles, Title with the default property settings already exist.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. In the Properties Window, you can modify the text, font, border and the background color settings of the map title.

  5. Click OK to close the dialog.

To set the distance scale

A distance scale helps a user to understand the scale of the map. Distance on a map is not the same as the actual real-world distance, so a distance scale shows that a certain distance on the map equals a certain distance in a real-world. In distance scale, the distance is displayed in both miles and kilometers. The scale range and values are automatically calculated using the viewport boundaries, projection type, and zoom level. Use these steps to learn setting a distance scale on a map:

  1. On the design surface, select the Map control.
  2. In the Properties window, click the DistanceScale property and then click the ellipsis (...) button that appears.

  3. In the Map Distance Scale dialog that appears, on the General page, you can set the location and the color of the distance scale.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  4. On the Appearance page of the dialog, you can make modifications to the border width, style, color and background color.
  5. On the Font page of the dialog, you can make modifications to the font properties of the distance scale.
  6. On the Visibility page of the dialog, you can setup the visibility mode of the distance scale.
  7. On the Navigation page of the dialog, you can setup the interactivity features for the distance scale.
  8. Click OK to close the dialog.

To set the color scale

A color scale helps a user to understand the range of colors that are used for data visualization on a layer. A map has just one color scale and multiple layers can provide data for it. Use these steps to learn setting a color scale on a map.

  1. On the design surface, select the Map control.
  2. In the Properties window, click the ColorScale property and then click the ellipsis (...) button that appears.

  3. In the Map Color Scale dialog that appears, on the General page, you can set the location and the color of the color scale.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  4. On the Labels page of the dialog, you can make modifications to the properties of the color scale labels.
  5. On the Title page of the dialog, you can make modifications to title text and font properties of the color scale.
  6. On to the Appearance page, you can make modifications to the border width, style, color and background color.
  7. On the Font page, you can make modifications to the font properties of the color scale.

  8. On the Visibility page, you can setup the visibility mode of the color scale.

  9. On the Navigation page, you can setup the interactivity features for the color scale.

  10. Click OK to close the dialog.

To modify the appearance of the Viewport

Viewport refers to the area on the map where map data is displayed against a geographical background. It specifies the coordinates, projection system, parallels and meridians, center point, and scale of the map. In other words, it is a map element that actually display geographical data and occupies most area of the map control depending on the location and dock position of other map elements. See Map for more information.

You can modify Viewport properties to make the map look more attractive.

  1. On the design surface, select the Map control.
  2. Go to the Properties window, click the Viewport property and then click the ellipsis (...) button that appears.

  3. In the Map Viewport dialog that appears, on the General page, choose the Coordinate system. The map viewport supports the following two coordinate system:

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
    • Geographic: Specifies Earth coordinates by defining longitude and latitude values. If you set the CoordinateSystem property to Geographic, then you must specify the Projection property. A projection is a set of rules on how to locate three-dimensional objects onto a planar surface.
    • Planar: Specifies geometric coordinates on a two-dimensional surface by using X and Y values. and in case you set it to Geographic then set the Projection.
  4. Go to the Meridians page, set its visibility and its line and font style and color.
  5. Similarly, go to the Parallels page, set its visibility and its line and font style and color.
  6. On the View page of the dialog, choose a Center and Zoom mode. The map viewport supports the following four center and zoom modes:
    • Custom: Choose this option to specify custom values for the view center and the zoom level.
    • Center map to show a map layer: Choose this option to specify a layer and automatically, center the view on its map data. For example, center the view on LineLayer1.
    • Center map to show a map element: Choose this option to center the view on a specific data bound map element. For example, center the view on the map element where the name of the match field is [StateName] and the match value is "Washington".
    • Center map to show all map elements: Choose this option to center the view on all map elements in the layer.
    Note: Zoom and View Center level can also be set from the design surface using the zoom slider and arrow keys that appears in the View Pane of the Map control.
  7. On the Appearance page, set the Border and Background style and color of the viewport.

  8. Click OK to close the dialog.

See Also

Map
Use Layers

Walkthroughs
Reports with Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Data

Add Data
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Add Data

Glossary Item Box

Show All Show All
Hide All Hide All

The Map data region uses the following two types of data:

Spatial Data

Spatial data is a set of coordinates that defines a map element. Each map layer must have spatial data of one of the following types - a polygon, a line, or a point.

Spatial data can be either embedded in a map or can be linked to a map layer. The only difference between the two is that while having the spatial data embedded in a map, there is no separate file to locate or to keep track of when you move the report between projects or machines.

  • Embedded Spatial Data:

    Embedded spatial data can refer to the following:

    • Embedded ESRI shapefile or dataset: When you use the Embedded option in Map Layer Data Properties dialog or the From ESRI file option in the Map Wizard to import spatial data from an ESRI shapefile, the ESRI shapefile gets embedded in the Map. Similarly, if a report dataset is been used to provide spatial data to a map layer, you always have an option of embedding that spatial data in the map using the Embed Spatial Data option that appears in the layers pane. See, Use Layers to learn embedding spatial data to a map.
    • Custom data: When you add an empty layer to a map and enter spatial data manually in the LayerDesigner Collection Editor, the data entered gets embedded to the map automatically.

  • External Spatial Data:

    External spatial data can refer to the following:

    • Remote or Local ESRI shapefile: When you use the Linked option in Map Layer Data Properties dialog or use the File property in the Properties Window to specify the local or remote path/location of an ESRI shapefile, the ESRI shapefile gets linked to the Map layer. However, it remains an external source as the dependent ESRI shapefile needs to moved along with the report between projects or machines.
    • Report Dataset: When you use a report dataset to provide spatial data to a map layer and you don't embed the spatial data, it remains an external source. This requires the dependent database file to moved along with the report between projects or machines.

ActiveReports provide numerous ways to add spatial data to the map. You can either use the Map Wizard and add data from an ESRI shapefile or use the Map Layer Data Properties dialog for using advance options. You can also add spatial data from the Properties Window.

Show To add spatial data using Map Wizard

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select From ESRI file.
  3. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files, select the .shp file, use the Map Resolution slider to simplify vector data and click Open.

This option automatically imports the spatial data stored in the shapefile and adds a related layer to the map control.

Show To add spatial data using the Map Layer Data Properties dialog

The Map Layer Data Properties dialog provide the following advance options to add spatial data. For more information on Map Layer Data Properties dialog, see Map.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

  • Embedded : Use this option where you want to add spatial data from an ESRI file along with an additional option of adding custom spatial data fields if required.

    Show To add Spatial data from an ESRI file using the Embedded option

    1. In the Map Layer Data Properties dialog, on the General page, select the Embedded option and click the Browse button.
    2. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files.
    3. Select the .shp file, use the Map Resolution slider to simplify vector data and click Open. The fields list gets populated with spatial data fields that are added from the shapefile.
    4. In Dataset, set the name of the dataset.
    5. In the Fields list, click the Add (+) button to add a new empty spatial data field.
    6. With the newly added spatial data field selected in the list, in Field name, enter the name of the field.
    7. In Field type, set the field type of newly added spatial data field.
    8. Click OK to close the dialog.
    Note: In order to apply the new spatial data field on a layer, you must provide its value for each map layer element like polygons, points or lines in the added map layer Designer Collection Editor dialog.

  • Linked : Use this option when you just want to add spatial data from an ESRI shapefile without any additional modifications or additions .

    Show To add Spatial data from an ESRI file using the Linked option

    1. In the Map Layer Data Properties dialog, on the General page, select the Linked option and click the Browse button.
    2. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files.
    3. Select the .shp file and click Open.
    4. Click OK to close the dialog.

  • Dataset : Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. You can directly use the data fields from the dataset to display data on a map layer without setting the match fields for analytical data. Therefore, it also provides you an additional option of having different dataset for analytical data and spatial data respectively.

    Show To add Spatial data from a Dataset

    1. In the Map Layer Data Properties dialog, on the General page, select the Dataset option.
    2. In Dataset, set the name of the dataset.
    3. In Field name, enter the data field name that contains the spatial data.

      Caution:

      • Simply type the name of the dataset field that contains spatial data. For example, enter value as StateName, not as =[StateName].
      • You cannot use the MapPoint() function in parameters.
    4. Click OK to close the dialog.

    Note:

    • MapPoint() function is supported for Point layer only.
    • Simple (non spatial) data can also be added as Spatial field using MapPoint() expression as  =MapPoint(<Latitude>, <Longitude>) from Expression Editor.

  • Analytical : Use this option when you want to use the spatial data field from the same dataset that you may use for adding Analytical data to the layer. For using this option you need to first set the dataset for analytical data and then use the spatial data field from the dataset to provide spatial data to the map layer.

    Show To add spatial data from Analytical data

    1. Configure Analytical data for the Map control. See the dropdown section below to learn adding Analytical data.

      Note: Once the Analytical data has been set, the Analytical option on the General page of the Map Layer Data Properties dialog becomes active.
    2. In the Map Layer Data Properties dialog, on the General page, select the Analytical option.
    3. In Field name, enter the data field name that contains the spatial data.
      Caution: In Field name, enter the data field name as =[StateName], not as StateName.
    4. Click OK to close the dialog.

Show To add spatial data using Properties Window

These steps assume that you have a Map control containing at least one map data layer placed on the design surface. To learn how to add a layer to the Map control, see Use Layers.

  1. With the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  2. In the LayerDesigner Collection Editor that appears, under Members, select the map data layer you want to use and expand the SpatialData property.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  3. In Type, choose the spatial data source of the layer from the following supported options:
    • Embedded: Use this option when you want to add custom spatial data to the map data layer. This can be done by first adding the spatial data fields for the embedded spatial data using the MapFieldDefinitionDesigner Collection Editor which can be accessed through the FieldDefinitions property. And then later adding spatial data (points, polygons or lines) using the PolygonDesigner Collection Editor, PointsDesigner Collection Editor or LineDesigner Collection Editor depending on the layer in use. These Editor dialogs can be accessed using the SpatialData > Polygons, SpatialData > Points or SpatialData > Lines property.
    • File: Use this option when you want to add spatial data from an ESRI file. Use the Source property to specify the location of the shapefile.
      Note: The specified location must contain the shape format (.shp) and attribute format (.dbf) files.
    • DataSet: Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. This option is equivalent to the DataSet option in the Map Layer Data Properties dialog. Use the SpatialData > DataSetName property to specify the name of the dataset and the SpatialData > SpatialField property to specify the data field that contains spatial data.

      Note:

      • MapPoint() function is supported for Point layer only.
      • Simple (non spatial) data can also be added as Spatial field using MapPoint() expression as  =MapPoint(<Latitude>, <Longitude>) from Expression Editor.

      Caution: You cannot use the MapPoint() function in parameters.
    • DataRegion: Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. This option is equivalent to the Analytical option in the Map Layer Data Properties dialog. Use the LayerData > DataSetName property to specify the name of the dataset and the SpatialData > VectorData property to specify the data field or expression that contains spatial data.
  4. Click OK to close the dialog.

Analytical Data

Analytical data is the data that you want to visualize on the map, for example, tourist attractions in a city or product sales by region. For analytical data, you can associate it with map elements by indicating match fields in the Match box of the Map Layer Data Properties dialog. You can use one or more fields in the Match box of the Map Layer Data Properties dialog; for each spatial data field you must indicate a unique analytical data field. This data is optional.

You can get analytical data from the following types of data sources.

  • Dataset field: A field from a dataset.
  • Spatial data source field: A field from the spatial data source. For example, you can often find that an ESRI Shapefile contains both spatial and analytical data. Field names from the spatial data source are marked with the # sign in the drop-down list of fields.
  • Embedded data for a map element: After you embed polygons, lines, or points in a report, you can select the data fields for map elements and define custom values.

Show To add Analytical Data to the Map control

Use the following steps to add analytical data to the map. These steps assume that you have added a page layout template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. Add spatial data to the map control. See the dropdown sections above to learn adding spatial data to the map control.
  2. In the Map Layer Data Properties dialog, go to the Analytical data page.
  3. Select the dataset that you want to use from the Dataset dropdown list and click the Add (+) button located next to the Match field. This creates an empty match field expression and enables the Spatial and Analytical field properties.
  4. In the Spatial field and Analytical field options set data fields that contain same data in both Spatial and Analytical databases. This builds the match field expression and relates analytical data to map elements on a map layer.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  5. Click OK to close the dialog.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Layers

Work with Layers
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers

Glossary Item Box

See step-by-step instructions for using map layers in a Map data region to display data.

In this section

Use Layers
Learn adding and removing layers, adding bookmarks and hyperlinks to map layer elements and embedding spatial data on a map.
Use a Polygon Layer
Learn how to use a polygon layer to display data on a map.
Use a Point Layer
Learn how to use a point layer to display data on a map.
Use a Line Layer
Learn how to use a line layer to display data on a map.
Use a Tile Layer
Learn how to use a tile layer to display data on a map.
Use Color Rule, Marker Rule and Size Rule
Learn how to use Color, Marker and Size rules to modify appearance of the data displayed on a map.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use Layers

Use Layers
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use Layers

Glossary Item Box

Show All Show All
Hide All Hide All

A map is a collection of layers that display data on the map control. See, Map for more information.

This topic illustrates how to add, remove and change order of layers. It also shows how to add interactive navigational feature to map layer elements.

To add a map layer

Show To add a map layer from the design surface

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select a map template.
  3. Click the Map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and select the map layer you want to use.

Show To add a map layer using the LayerDesigner Collection Editor

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select a map template.
  3. With the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  4. In the LayerDesigner Collection Editor that appears, use the Add combo-box to view the list of available layers and select the map layer you want to use.

To delete a map layer

Show To delete a map layer from the design surface

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right click the layer you want to remove and select Delete.

Show To delete a map layer using the LayerDesigner Collection Editor

  1. On the design surface, with the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  2. In the LayerDesigner Collection Editor that appears, under the members list, select the map layer you want to delete and click the Remove button.

To change order of layers

Map layers are rendered from left to right in the order that they appear in the map panes. In the image below, the polygon layer is drawn first and the line layer is rendered last. Layers that are rendered later might hide map elements on layers that are rendered earlier. You can change rendering order of layers added to the map control using the LayerDesigner Collection Editor. Follow these to steps learn re-ordering the layers on a map.

  1. On the design surface, with the Map control selected, go to the Properties window.
  2. In the Properties Window, click the Layers (Collection) property and then click the ellipsis button that appears.
  3. In the LayerDesigner Collection Editor that appears, under the members list, select the map layer you want to reorder and use the up or down arrow to change the rendering order of each layer.
  4. Click OK to close the Collection Editor.

To embed layer spatial data or tiles in a map

When you embed map elements or map tiles in a report, the spatial data is stored in the report definition.

  1. Click the map until the map panes appear.
  2. In the layers pane, right click the added layer that contains spatial data, select Embed Spatial Data and then select All Spatial Data or Currently Visible Data. In case of Tile layer select Embed Tiles.
    Note: All Spatial Data refers to all the spatial data fields, while Currently Visible Data refers to the spatial data field that is set in the Field property.

To add Hyperlinks, Bookmarks and drill-through links

Map layer elements like point, polygon and line provides you a functionality to set interactive navigational features like a bookmark link to jump to other areas in the same report, a hyperlink to jump to a Web address, or a drill-through link to jump to another report. Follow these steps to learn adding hyperlinks, bookmarks and drill-through links to a layer element:

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right click the layer in use and select Edit.
  3. In the selected layer's dialog that appears, go to the Navigation page.
  4. On the Navigation page, select from the following actions to perform when a user clicks a data layer element :
    • None: The default behavior to indicate that the item has no action.
    • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.
      • Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report. You can remove or change the order of parameters using the X and arrow buttons.

      For detailed steps on adding a drill-through link, see Set a Drill-Through Link.

    • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to another report control with the same Bookmark ID.
      For more information on adding bookmarks, see Add Bookmarks.

    • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
      For more information on adding hyperlinks, see Add Hyperlinks.

  5. Click OK to close the dialog.

See Also

Use a Polygon Layer
Use a Point Layer
Use a Line Layer
Use a Tile Layer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use a Polygon Layer

Use a Polygon Layer
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Polygon Layer

Glossary Item Box

A Polygon layer display outlines of areas or site boundaries that can be linked to Locations and can be used to select records that fall within the boundary for reporting usage.

Use the following steps for creating a basic map using the Polygon layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and select Add Polygon Layer. This adds a polygon layer to the map and opens the Map Layer Data Properties dialog.
  5. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (polygons) from a shape file or use a data field from the analytical data to specify the spatial data source.
  6. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This creates an empty match field expression and enables the Spatial and Analytical field properties. See, Add Data for more information.
  7. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. This builds the match field expression and relates analytical data to map elements on a polygon layer.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  8. Go to the Filters page and set filters if any.
  9. Click OK to close the dialog.
  10. In the layers pane, right click on PolygonLayer1 and select Edit to open Map Polygon Layer dialog.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  11. In the General page of the dialog, select any data field from the Label Text combo box to display as labels inside polygons at run time.
  12. Go to the Color Rule page of the dialog, to set rules to visualize data using color pallets, color ranges or custom colors for polygons or polygon center points that gets displayed on the map or keep it set to the default "Use Appearance settings". See, Use Color Rule, Marker Rule and Size Rule for more information.
  13. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  14. In the Navigation page of the dialog, you can optionally link the polygon to a URL, bookmark or a report.
  15. The Appearance page of the dialog either reflects the default appearance of the polygons or the color rule settings if any.
  16. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set and color for the label text that you had set in the General page of the dialog.
  17. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  18. Click OK to close the dialog and go to the preview tab to view the map.

See Also

Use a Point Layer
Use a Line Layer
Use a Tile Layer

Walkthroughs
Reports with Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use a Point Layer

Use a Point Layer
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Point Layer

Glossary Item Box

A Point layer displays markers for point locations such as a city or an address for a store, restaurant, or school.

Use the following steps for creating a basic map using the Point layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and add either a Tile layer or a Polygon layer. One of these layers that you add serves as the geographic base to plot points on. See, Use a Polygon Layer or Use a Tile Layer for steps to add these layers on a Map control.
  5. Right click again inside the area labeled "Right click to add the new layer." and select Add Point Layer. This adds a point layer to the map and opens the Map Layer Data Properties dialog.
  6. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (points) from a shape file or use a data field from the analytical data to specify the spatial data source.
  7. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This makes the Spatial field and Analytical field options active. See, Add Data for more information.
  8. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. Match fields are used to relate the spatial data with the analytical data.
    Note: It is necessary to set match fields if you want to use a data field from the analytical data to set spatial data for the layer, or if you want to visualize analytical data on the map.
  9. Go to the Filters page and set filters if any.
  10. Click OK to close the dialog and return to design surface.
  11. In the layers pane, right click on PointLayer1 and select Edit to open Map Point Layer dialog.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  12. In the General page of the dialog, select any data field from the Label Text dropdown list to display as label for each point that gets displayed on the map at run time. You can also set the label placement, size and marker type.
  13. Go to the Marker Rule page to set rules to visualize data using markers or keep it set to "Use default marker type".
  14. Go to the Size Rule page to set rules to visualize data using different marker sizes or keep it set to "Use default marker size". See, Use Color Rule, Marker Rule and Size Rule for more information.
  15. Go to the Color Rule page to set rules to visualize data using color pallets, color ranges or custom colors for markers that gets displayed on the map or keep it set to "Use Appearance settings".
  16. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  17. In the Navigation page of the dialog, you can optionally link the layer to a URL, bookmark or a report.
  18. The Appearance page of the dialog either reflects the default appearance of the polygons or the color rule settings if any.
  19. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set and color for the label text that you had set in the General page of the dialog.
  20. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  21. Click OK to close the dialog and go to the preview tab to view the map.

See Also

Use a Line Layer
Use a Tile Layer
Use a Polygon Layer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use a Line Layer

Use a Line Layer
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Line Layer

Glossary Item Box

A Line layer displays routes and paths between different locations, for example, transportation route between two stores.

Use the following steps for creating a basic map using the Point layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and add either a Tile layer or a Polygon layer. One of these layers that you add serves as the geographic base to plot lines on. See, Use a Polygon Layer or Use a Tile Layer for steps to add these layers on a Map control.
  5. Right click again inside the area labeled "Right click to add the new layer." and select Add Line Layer. This adds a Line layer to the map and opens the Map Layer Data Properties dialog.
  6. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (lines) from a shape file or use a data field from the analytical data to specify the spatial data source.
  7. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This makes the Spatial field and Analytical field options active. See, Add Data for more information.
  8. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. Match fields are used to relate the spatial data with the analytical data.
    Note: It is necessary to set match fields if you want to use a data field from the analytical data to set spatial data for the layer, or if you want to visualize analytical data on the map.
  9. Go to the Filters page and set filters if any.
  10. Click OK to close the dialog and return to design surface.
  11. In the layers pane, right click on LineLayer1 and select Edit to open Map Line Layer dialog.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  12. In the General page of the dialog, select any data field from the Label Text dropdown list to display as label for each line that gets displayed on the map at run time. You can also set the label placement.
  13. Go to the Color Rule page to set rules to visualize data using color pallets, color ranges or custom colors for lines that gets displayed on the map or keep it set to "Use Appearance settings". See, Use Color Rule, Marker Rule and Size Rule for more information.
  14. Go to the Size Rule page to set rules to visualize data using line width or keep it set to the default line width.
  15. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  16. In the Navigation page of the dialog, you can optionally link the layer to a URL, bookmark or a report.
  17. Go to the Appearance page of the dialog and set the style, width and color of the layer border and the layer background.
  18. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set and color for the label text that you had set in the General page of the dialog.
  19. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  20. Click OK to close the dialog and go to the preview tab to view the map.

See Also

Use a Polygon Layer
Use a Point Layer
Use a Tile Layer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use a Tile Layer

Use a Tile Layer
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Tile Layer

Glossary Item Box

Show All Show All
Hide All Hide All

A Tile layer displays the virtual earth tile background on the map.

Use the following steps for creating a basic map using the Polygon layer. These steps assume that you have added a page layout template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and select Add Tile Layer. This adds a tile layer to the map and opens the Map Tile Properties dialog.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  5. In the Map Tile Properties dialog that appears, on the General page, set the layer name and choose its Source and Type. The default values in these fields also work fine.
  6. In the Provider property, choose one from the following supported tile providers:
    • Bing: The Microsoft Bing Map server offers static map images. This requires an Application key for authentication. The default key provided by ActiveReports is for demo purpose and can't be used by 3rd party applications. In order to obtain a Bing Map Key, see HowTo - Create a Bing Map Account and HowTo - Get a Bing Map Key.
      Note: After generating the key, add the following script in the Grapecity.ActiveReports.config file to configure embedded Bing tile provider with Application key.

      Show Script

      Paste inside the <Configuration></Configuration> tags. Copy Code
      <MapTileServerConfiguration>
   <Timeout>5</Timeout>
   <AppID>"Your Application Key"</AppID>
</MapTileServerConfiguration>

    • Caution: The Grapecity.ActiveReports.config file should always be placed in the same folder as the EndUserDesigner.exe file for displaying a Bing tile layer on a Map.
    • Google: The Google Map server creates your map tiles based on URL parameters sent through a standard HTTP request that returns the map tiles as an image. It is necessary to set the API key in order to monitor usage of this tile server with the Google API Console. Please register with Google to get the API key.

      Note: After obtaining the key, add the following script in the Grapecity.ActiveReports.config file to configure embedded Google tile provider with ApiKey.

      Show Script

      Paste inside the <Configuration></Configuration> tags. Copy Code
      <!-- Configure embedded Google tile provider with API Key -->
<MapTileProvider Name="Google" DisplayName="Google" >
    <Settings>
      <add key="ApiKey" value="API Key" />
      <add key="Timeout" value="5000" />
    </Settings>
</MapTileProvider>
    • CloudMade: The CloudMade tile server allows you to access it through the HTTP Tile API. The URL structure for this API is straightforward, and is instantly recognizable to anyone familiar with the OpenStreetMap tile numbering convention. To use a CloudMade Tile server you require an API key for authentication which can be obtained by registering at CloudMade.
      Note: After generating the key, add the following script in the Grapecity.ActiveReports.config file to configure embedded CloudMade tile provider with ApiKey.

      Show Script

      Paste inside the <Configuration></Configuration> tags. Copy Code
      <!-- Configure embedded CloudMade tile provider with ApiKey -->
<MapTileProvider Name="CloudMade" DisplayName="CloudMade Tiles Provider">
    <Settings>
      <add key="ApiKey" value="API Key" />
    </Settings>
</MapTileProvider>
    • MapQuest: The MapQuest tile server provides the tiles in a format similar to Google. This tile server requires an API Key for authentication which can be obtained by registering at MapQuest.
      Note: After generating the key, add the following script in the Grapecity.ActiveReports.config file to configure embedded MapQuest tile provider with ApiKey.

      Show Script

      Paste inside the <Configuration></Configuration> tags. Copy Code
      <!-- Configure embedded MapQuest tile provider with ApiKey -->
<MapTileProvider Name="MapQuest" DisplayName="Map Quest Tiles Provider">
    <Settings>
      <add key="ApiKey" value="API Key" />
      <add key="Timeout" value="3000" />
    </Settings>
</MapTileProvider>
    • OpenStreetMap: The OpenStreetMap server provides the tiles in an index based format. This tile server provides only the roadmap and returns fixed size images (256x256). Before using the OpenStreetMap server, go through the Copyright and License and Tile usage policy pages.
  7. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  8. Click OK to close the dialog and go to the preview tab to view the map.

Note: If you are using proxy server connection to see the map tile images, you need to set credentials for the proxy server in the application config file for authentication. To use your default proxy server credentials, you can do the following:

For Visual Studio Designer (IDE)

  1. Find devenv.exe.config (the devenv.exe configuration file) in: Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE
  2. In the configuration file, find the <system.net> block, and add this code:
    Paste inside the <system.net></system.net> tags. Copy Code
    <defaultProxy useDefaultCredentials="true" />

For Visual Studio Application

  1. On the menu bar, choose Project, Add New Item and then choose the Application Configuration File template.
  2. In the Name text box, enter a name, and then click Add button.
  3. In the configuration file, add this code:
    Paste inside the <configuration></configuration> tags. Copy Code
    <system.net>
    <defaultProxy useDefaultCredentials="true" />
    </system.net>
Note: Grapecity.ActiveReports.config file should be kept inside the project Debug folder and added to a Visual Studio project for displaying a Tile layer on a Map in any Viewer control.

See Also

Use a Polygon Layer
Use a Point Layer
Use a Line Layer
Add a Custom Tile Provider

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add a Custom Tile Provider

Add a Custom Tile Provider
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Tile Layer > Add a Custom Tile Provider

Glossary Item Box

Show All Show All
Hide All Hide All

You can add and configure a Custom Tile Provider in the Map control using the GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapTileProvider and GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapTile interfaces.

The IMapTileProvider interface contains detailed settings that are required to communicate with the tile server, whereas the IMapTile interface represents a single tile of a Map's tile layer that fetches the tile image based on the configurations in the IMapTileProvider interface.

Adding a custom tile provider also requires making some modifications in the Grapecity.ActiveReports.config file. Follow these steps to learn how to set a custom tile provider:

  1. Create a Class Library Project, for example MyClassLib, in Visual Studio.
  2. Add a new Class to the project and name the class, for example, MyTileProvider. You may add functions and features to this class for getting the Tile images based on your tile server settings and details. This class serves as the interface between your Map control and your custom tile server. Replace the existing code with the following in the MyTileProvider class to implement the IMapTileProvider interface.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System
Imports System.Collections.Specialized
Imports GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map
    VB code. Paste BELOW the Imports statements Copy Code
    Namespace MyClassLib
   Public Class MyTileProvider Implements IMapTileProvider
        ' Tile provider settings, like ApiKey, Language, Style and etc.
        Public Property Settings() As NameValueCollection
        ' Add your code here.
        End Property
        ' Get instance of tile by specifying tile coordinates and details.
        Public Sub GetTile(key As MapTileKey, success As Action(Of IMapTile),
     [error] As Action(Of Exception))
        ' Add your code here.
        End Sub
    End Class

    End Namespace

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System;
using System.Collections.Specialized;
using GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map;
    C# code. Paste BELOW the Using statements Copy Code
    namespace MyClassLib
{
    public Class MyTileProvider :IMapTileProvider
    {// Tile provider settings, like ApiKey, Language, Style and etc.
    public NameValueCollection Settings { get; private set;}
    // Get instance of tile by specifying tile coordinates and details.
    public void GetTile(MapTileKey key, Action<IMapTile> success, Action<Exception> error);
    // Add your code here.
    }
}

  3. Add a new Class to the project and name the class, for example, MyMapTile. Replace the existing code with the following in the MyMapTile class to implement the IMapTile interface.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System.IO
Imports GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map
    VB code. Paste BELOW the Imports statements Copy Code
    Namespace MyClassLib
   Public Class MyMapTile Implements IMapTile
       ' Gets the tile identifier
       Public Property Id() As MapTileKey
       ' Add your code here
       End Property
       ' Gets the tile image stream.
       Public Property Image() As Stream
       ' Add your code here.
       End Property
   End Class
End Namespace

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System.IO;
using GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map;
    C# code. Paste BELOW the Using statements Copy Code
    namespace MyClassLib
   public class MyMapTile : IMapTile
   {   // Gets the tile identifier.
       public MapTileKey Id { get; private set; }
       // Gets the tile image stream.
       public Stream Image { get; private set; }
       // Add your code here.
    }
}
  4. Add another Class to the project and name the class, for example, WebRequestHelper. Replace the existing code with the following in the WebRequestHelper class to implement the loading of raw website data into the System.IO.MemoryStream class.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System.IO
Imports System.Net
    VB code. Paste BELOW the Imports statements Copy Code
    Namespace MyClassLib
    Module StringExtensions
        Public Sub CopyTo(ByVal input As Stream, ByVal output As Stream)
        'Add your code here
        End Sub
        Private Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
        'Add your code here
        End Function
    End Module
    Friend NotInheritable Class WebRequestHelper
        Private Sub New()
        End Sub
        ' Load raw data into MemoryStream from specified Url.
        Public Shared Function DownloadData(url As String, timeoutMilliseconds As Integer) As Stream
        'Add your code here
        End Function
        'Load raw data into MemoryStream from specified Url.
        Public Shared Sub DownloadDataAsync(url As String, timeoutMilliseconds As Integer,
     success As Action(Of MemoryStream), [error] As Action(Of Exception))
        'Add your code here
        End Sub
        Private Shared Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
        'Add your code here
        End Function
    End Class
End Namespace

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System.IO;
using System.Net;
    C# code. Paste BELOW the Using statements Copy Code
    namespace MyClassLib
{
    internal static class WebRequestHelper
    {   // Load raw data into MemoryStream from specified Url.
        public static Stream DownloadData(string url, int timeoutMilliseconds)
        {//Add your code here  }
        public static void DownloadDataAsync(string url, int timeoutMilliseconds,
     Action<MemoryStream> success, Action<Exception> error)
        {//Add your code here  }
        public static void CopyTo(this Stream input, Stream output)
        {//Add your code here  }
    }
}
  5. Save and build your class library project and locate the new .dll file in its Bin>Debug folder. This file has the same name as your class library project, with a .dll extension.
  6. Create a Basic End User Designer in a new solution following the steps in Creating a Basic End User Designer.
  7. Run your Basic End User Designer project to create a EndUserDesigner.exe in your projects Bin>Debug folder.
  8. Copy the Grapecity.ActiveReports.config file from the C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 13\ location and paste it into your End User Designer project's Bin>Debug folder.
    Caution: Grapecity.ActiveReports.config file should always be placed inside the same folder as the EndUserDesigner.exe file for displaying a tile layer on a Map.
  9. Right-click on the Grapecity.ActiveReports.config file and select Include in this Project to make changes in the config file.
  10. Double-click to open the Grapecity.ActiveReports.config file and paste the following code between the <Configuration> and </Configuration> tags:
    Paste between the <Configuration></Configuration> tags. Copy Code
    <!-- Register and configure custom tile provider. -->
<MapTileProvider Name="Custom" DisplayName="Custom Provider" type="YourTileProvider, AssemblyName,
     Version = x.x.x.x">
    <Settings>
      <add key="ApiKey" value="API Key" />
    </Settings>
</MapTileProvider>
    Note: Replace YourTileProvider with fully qualified class name and AssemblyName with the name of the assembly created after implementing IMapTileProvider and IMapTile interfaces.
  11. Add the Class Library project created in step 5 to your Basic End User Designer project.
  12. Copy the YourProjectName.dll created in step 5 and paste it to the current project's Bin>Debug folder together with the EndUserDesigner.exe.
  13. Save and Run the project.
  14. Create a Report containing a Map control in the Basic End User Designer. See Reports with Map for more information.
  15. Add a Tile layer to the Map control. Right click the Tile layer and select Edit to view the custom tile provider added in the Provider drop-down. See Use a Tile Layer for more information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use Color Rule, Marker Rule and Size Rule

Use Color Rule, Marker Rule and Size Rule
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use Color Rule, Marker Rule and Size Rule

Glossary Item Box

Show All Show All
Hide All Hide All

You can visualize the data displayed on a map by setting rules to control color, size or marker type for all map elements on a layer. You can set three types of rules depending on the type of layer in use.

Color Rule

Color Rule is set to fill colors for map elements like polygons, markers (points or polygon center points) and lines while using a Polygon, Point or Line layer.
Color Rule provides four options:

  1. Apply Appearance Settings : Use the default appearance settings that are set in the Appearance page of the map layer dialog.
  2. Visualize data by using color palette : This option uses an in-built palette that you specify. Based on related analytical data, each map element is assigned a different color from the palette.
  3. Visualize data by using color ranges : This option, combined with the start, middle, and end colors that you specify on this page and the options that you specify on the Distribution page, divide the related analytical data into ranges. The report then assigns the appropriate color to each map element based on its associated data and the range that it falls into. For example, in a map which uses color to display temperatures on a scale of 0 to 100, low values are blue to represent cold and high values are red to represent hot.
  4. Visualize data by using custom colors : This option uses the list of custom colors that you specify. Based on related analytical data, each map element is assigned a color from the list.

To set Color Rule for polygons, lines and markers

Show To visualize polygons, lines or markers using color palette

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Color Rule page.
  4. In the Color Rule page, select the Visualize data by using color palette option.
  5. In Data field, set the name of the field or expression that contains the analytical data that you want to visualize by color.
  6. In Palette, set the name of the palette to use.
  7. Click OK to close the dialog.

Show To visualize polygons, lines or markers using color ranges

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Color Rule page.
  4. In the Color Rule page, select the Visualize data by using color ranges option.
  5. In Data field, set the name of the field or expression that contains the analytical data that you want to visualize by color.
  6. In Start color, set the color to be used for the color range.
  7. In Middle color, set the color to be used for the color range.
  8. In End color, set the color to be used for the color range.
  9. Click OK to close the dialog.

Show To visualize polygons, lines or markers using custom colors

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Color Rule page.
  4. In the Color Rule page, select the Visualize data by using custom colors option.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize by color.
  6. Click Add to specify each custom color.
  7. Click OK to close the dialog.

Marker Rule

Marker Rule is set on markers that represent points or polygon center points on a map while using a Point layer.
Marker Rule support two options:
  1. Use a default marker type : You specify one of the available marker types.
  2. Visualize data using markers : This option uses a set of markers in an order in which you want them to be used. Marker types include Rectangle, Circle, Diamond, Triangle, Trapezoid, Star, Wedge, Pentagon, PushPin and Image.

To set Marker Rule for points

Show To visualize points using default marker type

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Marker Rule page.
  4. In Default, set a default marker type that will appear in place of each point on a map.
  5. Click OK to close the dialog.

Show To visualize points using specific marker types

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Marker Rule page.
  4. In the Marker Rule page, select the Visualize data using markers option.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker types.
  6. Click Add and specify each Marker type in an order in which you want them to be used.
  7. Click OK to close the dialog.

Show To visualize points using Image as marker type

ActiveReports provides Image as one of the many available marker types to use from. You can set this marker type and use any image as a marker on a map layer. Like other marker types, you can either use it as a default marker or use it as one of the member in the markers collection.

Show Use Image as Default marker type

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, on the General page, set Marker Type to Image. A new set of properties appears on the page.
  4. In Image Source, choose the source of image from the provided options:
    • External: Select this option and set a path or url of the image file in Image Value.
    • Embedded: Choose from the list of embedded images added to your report. Once you set this option, the Image Value provides you the list of embedded images to choose from.
    • Database: Select this option and set the data field containing the image in the Image Value property.
  5. In MIME Type, set the MIME type of the image chosen. In case you are using the Embedded image source the MIME Type gets set automatically as you select the image in the Image Value property.
  6. Set the Transparent Color and the Resize Mode.
  7. Click OK to close the dialog.

Show Use Image in markers collection

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Marker Rule page.
  4. In the Marker Rule page, select the Visualize data using markers option.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker types.
  6. Click Add and set Marker type to Image. A new set of properties for image marker types appears on the page.
  7. In Image Source, choose the source of image from the provided options:
    • External: Select this option and set a path or url of the image file in Image Value.
    • Embedded: Choose from the list of embedded images added to your report. Once you set this option, the Image Value provides you the list of embedded images to choose from.
    • Database: Select this option and set the data field containing the image in the Image Value property.
  8. In MIME Type, set the MIME type of the image chosen. In case you are using the Embedded image source the MIME Type gets set automatically as you select the image in the Image Value property.
  9. Set the Transparent Color and the Resize Mode.
  10. Click OK to close the dialog.

Size Rule

Size Rule is set on markers, polygon center points or line width while using a Polygon, Point or a Line layer.
Size Rule support two options:
  1. Use a default marker size or Use a default line width : You specify the marker size or line width in points.
  2. Visualize data by using size or Visualize data by using line width : In this option, you set the minimum (start) and maximum (end) sizes or width for marker or line, specify the data field to be used for varying the marker size or line width and then specify the distribution options to apply to that data.

To set Size Rule for markers and line width

Show To visualize marker or line using default marker size or line width

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Size Rule page.
  4. In Default, set default size or width for each marker or line that appears on a map.
  5. Click OK to close the dialog.

Show To visualize marker or line using specific marker size or line width

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the Size Rule page.
  4. In the Size Rule page, select Visualize data by using size or Visualize data by using line width depending on the layer type in use.
  5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker sizes or line width.
  6. Set Start size and End size in case of Point Layer or Minimum line width and Maximum line width in case of Line Layer.
  7. Click OK to close the dialog.

Distribution Options

The distribution values are used by the rules to differ the map element display values.

To create a distribution of values, you divide your data into ranges by specifying the distribution method, the number of sub-ranges, and the range start and end values.

Show To set distribution values for rules

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the rule page(Color Rule, Marker Rule or Size Rule) where you need to specify distribution values.
  4. In the rule page of the dialog, select any option to visualize data using the selected rule type and go to the Distribution tab.
  5. On the Distribution tab, select one of the following distribution types:
    • EqualInterval : Create ranges that divide the data into equal range intervals. For the example, the three ranges would be 0-2999, 3000-5999, 6000-8999. Sub-range 1: 1, 10, 200, 500. Sub-range 2: 4777. Sub-range 3: 8999.
    • EqualDistribution : Create ranges that divide that data so that each range has an equal number of items. For example, the three ranges would be 0-10, 11-500, 501-8999. Sub-range 1: 1, 10. Sub-range 2: 200, 500. Sub-range 3: 4777, 8999.
    • Optimal : Specifies ranges that automatically adjust distribution to create balanced sub-ranges. The number of Sub-ranges is determined by the algorithm.
    • Custom : Specify your own number of ranges to control the distribution of values. For example, you can specify your own custom ranges 0-5000 and 5001-10000.
  6. In Number of Sub-ranges, type the number of sub-ranges to use.
  7. In Range start, type a minimum range value. All values less than this number are the same as the range minimum.
  8. In Range end, type a maximum range value. All values larger than this number are the same as the range maximum.
  9. Click OK to close the dialog.

Displaying Rule results in Legend

Show To display rule results in Legend

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the rule page(Color Rule, Marker Rule or Size Rule) where you need to specify displaying rule results in a legend.
  4. In the rule page of the dialog, select any option to visualize data using the selected rule type and go to the Legend tab.
  5. Select Show in legend checkbox and set Legend name.
  6. In Legend text, enter text that specify which data should appear in the legend. Use map keywords and custom formats to help control the format of legend text. For example, #VALUE {C2} specifies a currency format with two decimal places. Following are the supported formats that you can use:
    Format | Description | Example
    #Value | Displays a numeric value calculated using "(EndRangeValue - StartRangeValue)/2" formula.
    #FROMVALUE {C0} | Displays the currency of the total value with no decimal places. | $100
    #FROMVALUE {C2} | Displays the currency of the total value to two decimal places. | $40.25
    #TOVALUE | Displays the actual numeric value of the data field. | 100
    #FROMVALUE{N0} - #TOVALUE{N0} | Displays the actual numeric values of the beginning of the range and end of the range. | 10 - 500
  7. Click OK to close the dialog.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add TableOfContents

Add TableOfContents
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Add TableOfContents

Glossary Item Box

The Table of Contents control allows you to display the document map, an organized hierarchy of the report bookmark labels and heading levels along with their page numbers, in the body of a report.

To add items to the Document Map using HeadingLevel Property

You can define an hierarchical structure for your report using the HeadingLevel property of the TextBox control. For example, you can set the HeadingLevel property of the TextBox displaying the report title to Heading1 and then set the HeadingLevel property of the TextBox displaying a group header to Heading2, this will club all the Heading2 entries under the Heading1 entry in the Document Map.

These steps assume that you have already set the HeadingLevel property of the TextBox controls that your report contains. See, Add Items to the Document Map for more information.

  1. In the Report Explorer, right-click the Report item and select Report Properties...
  2. In the Report Properties dialog that appears, go to the Document Map page.
  3. On the Document Map page, set Source to Headings Only and optionally select the Numbering Style from the dropdown list.
    Tip: You can also set Source to Labels and Headings to include both labels and headings in the Document Map.
  4. Click OK to close the dialog.

To add items to the Document Map using Label Property or Document Map Labels

By setting the Label property or Document Map Label of the controls in your page report/RDL report, you can show a hierarchical structure based on the parent - child relationship between the controls in the Document Map. For example, set the Label property or Document Map Label of a List data region and a TextBox control and then place the TextBox control inside the List data region. When you view the Document Map, the TextBox label appears nested inside the List data region label, thereby displaying a hierarchical structure. Similarly, if you set a Document map label on multiple Groups of a data region, they appear nested below each other in the document map displaying the same hierarchy in which they were set.

These steps assume that you have already set the Label property or Document Map Label of the controls that your report contains. See, Add Items to the Document Map for more information.

  1. In the Report Explorer, right-click the control and select Report Properties...
  2. In the Report Properties dialog that appears, go to the Document Map page.
  3. In the Document Map page, set Source to Labels Only and optionally select the Numbering Style from the dropdown list.
    Tip: You can also set Source to Labels and Headings to include both labels and headings in the Document Map.
  4. Click OK to close the dialog.

To add items to the Document Map

  1. On the design surface, select a control you want to add to the Document map.
  2. In the command section of the Properties Window, click the Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  3. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.
  4. Click OK to close the dialog.

To add and configure TableOfContents

Follow these steps to setup the TableOfContents control in the report layout displaying the document map set in the procedures above.

To add a TableOfContents control in Page Report

  1. In the Report designer, click the New tab to add a new page to the report layout.
  2. From the toolbox, drag and drop the TableOfContents control onto Page 1 while use Page 2 to create layout for displaying the main content of the report. Using the same page that contains the TableOfContents may disrupt the flow of data displayed in the report.
  3. On the design surface, select the TableOfContents control and go to the Properties window to set its FixedHeight property. The use of the FixedHeight property is similar to the use of the FixedSize property that is available with other report controls.
    Note: You can also place the Overflow Place Holder control and link it with the TableOfContents control using its OverflowName property to display data that does not fit inside the fixed size of the TableOfContents control.
  4. With the TableOfContents control selected, click the Levels (Collection) property and then click the ellipsis button that appears.
  5. In the LevelDesigner Collection Editor that appears, consider the hierarchy of entries that appear in the Document Map and add as many levels required using the Add button. This allows you to customize entries at different nested levels. Using just a single Level will list down all the TableOfContents entries at the same level. You can also set various numbering styles for all levels or an individual level by setting the Numbering Style for document map levels using the Report dialog or using the DocumentMap property that gets directly applied to the TableOfContents control. For more information see Add Items to the Document Map.
  6. Select each level and set its related properties available in the LevelDesigner Collection Editor. These properties could be general properties like DisplayPageNumber or DisplayFillCharacter, or they could be related to the level's appearance like BackgroundColor, Font, Padding etc. These properties directly affect all the entries that appear in the selected level, thereby allowing you to customize them. For information on the important properties of the TableOfContents control, see Table of Contents.
  7. Click OK to close the dialog and return to the design surface.
  8. Go to the Preview Tab to view the Table of Contents appear in the report output.
  9. Click any TableOfContents entry and navigate to the targeted report control in the report.

To add a TableOfContents control in Report Definition Language (RDL)

  1. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.

To configure TableOfContents Appearance

  1. With the TableOfContents control selected, click the Levels (Collection) property and then click the ellipsis button that appears.
  2. In the LevelDesigner Collection Editor that appears, consider the hierarchy of entries that appear in the Document Map and add as many levels required using the Add button. This allows you to customize entries at different nested levels. Using just a single Level will list down all the TableOfContents entries at the same level.
  3. Select each level and set its related properties available in the LevelDesigner Collection Editor. These properties could be general properties like DisplayPageNumber or DisplayFillCharacter, or they could be related to the level's appearance like BackgroundColor, Font, Padding etc. These properties directly affect all the entries that appear in the selected level, thereby allowing you to customize them. For information on the important properties of the TableOfContents control, see Table of Contents.
    Note: You can also set various numbering styles for all levels or individual level by setting the Numbering Style for document map levels using the Report dialog or using the DocumentMap property that gets directly applied to the TableOfContents control. For more information see Add Items to the Document Map.
  4. Click OK to close the dialog and return to the design surface.
  5. Go to the Preview Tab to view the Table of Contents appear in the report output.
  6. Click any TableOfContents entry and navigate to that targeted report control in the report.

To apply styles to the TableOfContents control

In the TableOfContents control, styles can be applied using the StyleName property.

  1. Create a new style sheet and add styles that you want to apply to the TableOfContents control. For more information on creating style sheets and style types, see Working with Styles and Style Elements.
  2. Apply the style sheet to the report. For details on how to apply style sheets to reports at design time, see Working with Styles.
  3. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  4. On the design surface, select the TableOfContents control.
  5. In the Properties Window, from the StyleName property drop-down, select a style to apply to the TableOfContents control.

To apply styles to the TableOfContents levels

In the TableOfContents control, styles can be applied to each TableOfContents level using the StyleName property available in the LevelDesigner Collection Editor dialog.

  1. Create a new style sheet and add styles that you want to apply for the TableOfContents level. For more information on creating style sheets and and the type of styles available for TableOfContents level, see Working with Styles and Style Elements.
  2. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  3. With the TableOfContents control selected, click the Levels (Collection) property from the Properties window and then click the ellipsis button that appears.
  4. In the LevelDesigner Collection Edior dialog that appears, select a TableOfContents level on which to want to apply the style.
  5. From the list of properties on the right, drop-down the StyleName property to select a style to apply.

See Also

Add Items to the Document Map
Document Map

Concepts
Table of Contents

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Merge Cells in a Data Region

Merge Cells in a Data Region
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Merge Cells in a Data Region

Glossary Item Box

Merging data in Table or Tablix data regions is a common scenario. ActiveReports 13 provides AutoMergeMode property that consists of Always, Never, and Restricted values. The detail cells with same data values and with AutoMergeMode property set to:

  • Always - are merged.
  • Never - are not merged.
  • Restricted - are merged only if the corresponding cells in previous columns are similarly merged. If for example, cells in Column 2 (with same data values) are set 'Restricted' and the corresponding cells (with same data values) in previous column, that is Column 1, are set 'Never', then cells in Column 2 are not merged.

The reports using AutoMerge in older versions can be opened correctly in ActiveReports 13, and new reports with AutoMergeMode are correctly opened in previous ActiveReports versions.

The following steps take you through how to add automatic merge to the cells in Table and Tablix data regions.

These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a dataset. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: This topic uses the Orders table in the NWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

To apply merge in Table cells

  1. From the toolbox, drag a Table data region onto the report design surface.
  2. Select the Table and set the BorderStyle property to Solid.
  3. In the Table, select the following TextBoxes and from the Fields Selection Adorner, set their Values as follows.
    TextBox | Value
    TextBox4 | OrderID
    TextBox5 | ShipName
    TextBox6 | EmployeeID
  4. Select TextBox6 and set AutoMergeMode property to Restricted. This merges employee ids depending on whether the corresponding ship names (cells in previous column) are merged.
  5. Select TextBox5 and set AutoMergeMode property to Always. This merges the cells with similar ship names.
  6. Set the BorderStyle property of Header row and Detail row to Solid to view the merged cells clearly.

To merge cells in Tablix (outside row group)

  1. From the toolbox, drag a Tablix data region onto the report design surface.
  2. Select the Tablix and set the BorderStyle property to Solid.
  3. Right-click Textbox4, select Insert Column, and then select Outside Group - Right.
  4. In the Tablix, select the following TextBoxes and set their Values as follows.
    TextBox | Value
    TextBox3 | OrderID
    TextBox4 | ShipName
    TextBox6 | EmployeeID
  5. Select TextBox6 and set AutoMergeMode property to Restricted. This merges employee ids depending on whether the corresponding ship names (cells in previous column) are merged.
  6. Select TextBox4 and set AutoMergeMode property to Always. This merges the cells with similar ship names.
  7. Select the Row Group area and set the BorderStyle property to Solid to view the merged cells clearly.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Common Page Reports

Create Common Page Reports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports

Glossary Item Box

See step-by-step instructions for creating commonly used reports in a Page Layout.

In this section

Create Top N Report
Learn how to display top N data on a report.
Create Red Negatives Report
Learn to highlight negative values in red on a report.
Create Green Bar Report
Learn to create alternate background colors for report details.
Create a Bullet Graph
Learn how to create a Bullet Graph.
Create a Whisker Sparkline
Learn how to create a Whisker Sparkline.

See Also

Concepts
Expressions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Top N Report

Create Top N Report
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create Top N Report

Glossary Item Box

A Top N Report displays details for the top results in your report. You can create this report by modifying the SQL query while creating a dataset.

The following steps demonstrate how to create a Top N report. These steps assume that you have already added a Page Report/RDL Report template to your project and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for more information.

  1. In the Report Explorer, right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set from the add button.
  2. In the DataSet dialog that appears, go to the Query page and enter a query in the Query textbox in the following format : Select Top N FieldNames From TableName
    Note: In the query above TableName refers to the table you want to get from the database. FieldNames and N refer to the fields you want to fetch from the table and the number of records to display from that field. Following is an example of a Top N Report SQL query : Select Top 10 * From Movie
  3. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query and then click OK to close the dialog.
  4. In the Report Explorer, expand the DataSet node and drag and drop fields onto the design surface. In an Page report, you need to place these fields inside a data region.
  5. Go to the Preview tab and view the result. You'll notice only N number of records displaying in your report.

The following image is an example of a Top N Report displaying top 10 movie records:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Create Common Page Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Red Negatives Report

Create Red Negatives Report
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create Red Negatives Report

Glossary Item Box

A Red Negatives report shows negative values in red color if those values meet the requirements set in a conditional expression. The following steps demonstrate how to create a report with negative values in red negatives.

These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a DataSet. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface and place fields inside the cells of the details row.
  2. In the same Table, select any cell (Textbox) that displays integer values and right click to select Properties.
  3. In the Properties Window that appears, set the following expression in the Color property: =iif(Fields!FieldName.Value < 0, "Red", "Black")
    Note: In the expression above, FieldName refers to field that the textbox contains. For example, if a textbox contains the Rollup field, the expression looks like: =iif(Fields!Rollup.Value < 0, "Red", "Black")
  4. Go to the Preview tab and view the result.

The following image illustrates a report that contains negative values in red:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Create Common Page Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Green Bar Report

Create Green Bar Report
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create Green Bar Report

Glossary Item Box

You can create a Green Bar report by alternating the background color of a data region like a Table using conditional formatting. The following steps demonstrate Follow the steps below to learn creating a Green Bar Report.

These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a dataset. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. In the Table data region, click the row handle to the left of the detail row and right-click to select Properties.
  3. In the Properties Window dialog that appears, set the following expression in the BackgroundColor property: =iif(RowNumber(Nothing) Mod 2, "PaleGreen", "White")
  4. On the design surface, set fields the detail row of the table data region.
  5. Go to Preview tab and view the result. You will notice that every alternate detail the report displays has a green background.

The following image shows an example of a Green Bar report:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create a Bullet Graph

Create a Bullet Graph
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create a Bullet Graph

Glossary Item Box

You can create a bullet graph based on aggregated data from the data source. The following steps demonstrate how to create a bullet graph.

These steps assume that you have already added a Page Report/RDL Report template to your project and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for more information.

  1. From the Visual Studio toolbox, drag a drop Table control onto the design surface.
  2. From the Visual Studio toolbox, drag a Bullet control onto the detail row of the table and in the properties window, set its Value property to a numeric field (like =Fields!SalesAmount.Value). This Value property is used to define the key measure displayed on the graph.
  3. With the Bullet control selected on the design surface:
    • Set its Target Value property to 200. This property defines a target for the Value to be compared to.
    • Set its Best Value property to 500 and the Worst Value property to 0. The Best Value and Worst Value properties define the value range on the graph.
    • You can also optionally encode the segments on the graph as qualitative ranges indicating bad, satisfactory and good sections.
      • The Range1Boundary property defines a value for the bad/satisfactory boundary on the graph. Set this property to 150.
      • The Range2Boundary property defines a value for the satisfactory/good boundary on the graph. Set this property to 300.
    • You can also optionally define the Interval property for the graph value range. So, set this property to 100.
  4. Go to the Preview tab to view the bullet graph you have added to your report.
    As the bullet graph is based on aggregated data, you get a stack of bullet graphs indicating the Sales Amount value for different customers.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Create Common Page Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create a Whisker Sparkline

Create a Whisker Sparkline
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create a Whisker Sparkline

Glossary Item Box

You can use a whisker Sparkline to render “win/loss/tie” scenarios (for example, sport statistics) or “true/false” scenarios (for example, was the sales goal met or was the temperature above average), based on the numeric data from a data set.

The bars in a whisker sparkline render below the baseline for a negative value, above the baseline for a positive value and on the baseline for a zero value, for example, in a "profit/loss/no profit, no loss" scenario.

The following steps demonstrate how to create a whisker sparkline. These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a dataset. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: These steps use the AccountsChartData table from the Reels database. The sample Reels.mdb database file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  1. From the Visual Studio toolbox, drag a Sparkline control onto the design surface.
  2. With the sparkline selected on the design surface, go to the properties window and:
    • Set the Sparkline Type property to Whiskers.
    • Set the SeriesValue property to a numeric field (like =Fields!RollUp.Value) from the connected data set.
    • Set the FillStyle/FillColor property to Red.
  3. Go to the Preview tab to view the whisker sparkline.

See Also

Create Common Page Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Parameters

Add Parameters
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters

Glossary Item Box

You can add parameters to a page report/RDL report to allow users to select the data to display, or to use in creating drill-through reports.

To add a parameter

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter. The Report Parameters dialog appears.
  2. On the General tab of the dialog, set the name, data type and prompt text for the parameter. For example:
    • Name: MPAA
    • Data type: String
    • Text for prompting users for a value: Enter value

    Select out of the checkbox options to allow null values, multivalues, blank value, multiline values or set hidden parameters.

  3. On the Available Values tab, you can select From query populate a list from the data set from which users can select a value. Alternatively, you can select Non-queried to enter your own values.
  4. On the Default Values tab, you can provide default values to use if the user does not select a value. This is useful when you are creating a hidden parameter.
  5. Click OK to save the parameter. The new parameter appears in the Report Explorer under the Parameters node.
  6. From the Report Explorer, drag the parameter to report design surface to create a TextBox that is bound to the parameter. When you run the report, the value that the user supplies in the prompt dialog displays in the bound TextBox on the report.

For a step by step description of adding parameters in different scenarios look at the following pages:

Add a Multi-Value Parameter
Learn how to create a multi-value parameter.
Add a Cascading Parameter
Learn how to create cascading parameters where one parameter value is dependent on the selection of another.
Set a Hidden Parameter
Learn how to set a hidden parameter to allow data to fetched using the parameter value without prompting the user.

See Also

Parameters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add a Multi-Value Parameter

Add a Multi-Value Parameter
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters > Add a Multi-Value Parameter

Glossary Item Box

Show All Show All
Hide All Hide All

In a page report or an RDL report, you can create a multi-value parameter by selecting the Multivalue option. In a multi-value parameter, you can choose a few options from the list or simply choose 'Select all' to select all options.
If there are large number of options to choose from, choosing 'Select all' option creates an SQL query too long for an SQL Command to run. In such a case, you can specify a value to the multi-value parameter in Value for 'Select All' option.

The following procedures take you through a step by step process of how to create a multi-value parameter and specify a value for selecting all options from the list. These steps assume that you have added a Page Report/RDL Report template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

Note: This topic uses the Products table from the NorthWind database. By default, in ActiveReports, the Nwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWind.mdb.

To create a dataset to populate the parameter values

  1. In the Report Explorer, right-click the Data Source (DataSource1 by default) node and select Add Data Set.

  2. In the DataSet dialog that appears, select the Query page.
  3. Enter an SQL query like the following into the Query text box

    select distinct productName from Products
  4. Click the OK to close the dialog. You see the data set, DataSet1, and the field, productName, in the Report Explorer.

To add a Report Parameter

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter.
  2. In the Report - Parameters dialog that appears, add a name for the parameter, ReportParameter1.
  3. Ensure that the Data type matches that of the field (String for ProductName).
  4. Enter some text in the Text for prompting users for a value field.
  5. Select the check box next to Multivalue to allow users to select more than one item from the list.
  6. In the Value for 'Select All' option, enter '1'.

To provide a list of values for the Report Parameter

  1. In the Report - Parameters dialog, go to the Available Values tab and select the From query radio button.
  2. Under the Dataset field, select the dataset created previous steps (DataSet1).
  3. Under the Value and Label fields, select the field productName.
  4. Click the OK to close the dialog and add the parameter to the collection.

To add a dataset with a parameter

  1. In the Report Explorer, right-click the Data Source (DataSource1) node and select Add Data Set.
  2. In the DataSet dialog that appears, on the Parameters page, click the Add (+) icon above the parameters list and add the following to the dataset to provide values for the parameters we add to the query in step 3 below.
    Name: ReportParameter1; Value: =Parameters!ReportParameter1.Value
    Name: Parameter1; Value: =Parameters!ReportParameter1.Value
  3. On the Query page, enter a SQL query like the following in the Query text box:

    SELECT * FROM products where ProductName in (?) OR '1' in (?)

    At run time, this query matches the selected product name and fetches data accordingly. If the user chooses 'Select all' (for which we have specified value '1'), then query after 'OR' is evaluated and data is fetched for all products.
  4. Click the Validate DataSet icon to validate the query and to populate the Fields list.
  5. Click the OK to close the dialog. You see the data set, DataSet2, and the fields in the Report Explorer.

To view the report

Place a control like a Table onto the design surface and add fields to it. View the report in the preview tab and see the Parameters in the sidebar with Select all option at the top.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Note: If the Available Values (queried or non-queried) for a parameter contain only some values from database and Select all value is specified for the parameter, then on previewing report, selecting 'Select all’ checkbox shows all records from the database instead of only those present in the parameter. For example, if in database there are four records and in Available values there are only two records with Select all value specified, then on previewing report and selecting 'Select all' checkbox, all four records are shown instead of only two.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add a Cascading Parameter

Add a Cascading Parameter
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters > Add a Cascading Parameter

Glossary Item Box

When a parameter’s value list depends on the value of another parameter, the report collects the required parameter value and uses it to create the value list for the second parameter. This cascade of parameter values is sometimes also called dependent or hierarchical parameters.

Use the following instructions to create your own cascading parameters. These steps assume that you have added a Page Report/RDL template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information. Also refer to Add a Dataset before reading this topic.

Note: This topic uses the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.
  1. In the Report Explorer, right-click the Data Source (DataSource1 by default) node and select Add Data Set to create a dataset named Regions.
  2. On the Query page of the DataSet Dialog, use the following SQL Query to fetch data from the Regions table.
    SELECT RegionID, Region FROM Regions
  3. Click OK to close the Regions DataSet dialog.
  4. Follow step 1 to create another dataset named Districts and on the Parameters page of the DataSet Dialog, click the Add(+) icon to add a parameter named Region with the value set to:
    =Parameters!Region.Value
    This parameter is added to the Report Parameters collection later.
  5. In the Districts dataset dialog, on the Query page, add the following SQL query to fetch data from the Districts table. This query depends on the Region parameter.
    SELECT DistrictID, District FROM Districts WHERE Region = ?
  6. Click OK to close the Districts DataSet dialog.
  7. Follow step 1 and create another dataset named StoreNames and on the Parameters page of the DataSet Dialog, click the Add(+) icon to add a parameter named DistrictID with the value set to:
    =Parameters!DistrictID.Value
    This parameter is added to the Report Parameters collection later.
  8. In the StoreNames dataset, on the Query page, add the following SQL query to retrieve data for the selected region from the selected district. This query depends on the DistrictID parameter.
    SELECT StoreID, StoreName, OpenDate FROM Store WHERE NOT StoreID = 0 AND DistrictID = ?
  9. Click OK to close the StoreNames DataSet dialog.
  10. In the Report Explorer, right-click the Parameters node and select Add Parameter
  11. In the Report - Parameters dialog that appears, add a parameter named Region with an Integer data type. On the Available Values tab, select From query and set the dataset to Regions, the value field to RegionID, and the label field to Region.
  12. Click OK to close the Report - Parameters dialog.
  13. Follow the same process as steps 10 and 11 to add a second parameter named DistrictID with an Integer data type. On the Available Values tab, select From query and set the dataset to Districts, DistrictID for the value field, and District for the label field.
  14. From the Visual Studio toolbox, drag and drop a Table data region (or any other data region) onto the design surface, and drag the StoreID, StoreName and OpenDate fields onto the table details row.
  15. Click the Preview Tab to view the result.

Notice that the two drop down lists, for regions and districts appear in the Parameters sidebar while the second drop down list remains disabled until a region is selected. Click the View Report button to see the StoreID, StoreName and OpenDate values returned for the selected region and district.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: In a Page Report, when you have multiple datasets in the report, you need to set the DataSet property on the General tab of the FixedPage dialog in order to specify which dataset is used to display data in the report.

See Also

Concepts
Parameters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Set a Hidden Parameter

Set a Hidden Parameter
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters > Set a Hidden Parameter

Glossary Item Box

If you want to run a report without prompting the user for a value at run time, you need to set a default value for each parameter. The report collects the required parameter value from the default value and uses it to generate the report.

Default values can be queried or non-queried. A non-queried default value can be a static value or an expression. A queried default value is a field value from a dataset.

Use the following instructions to create your own hidden parameters. These steps assume that you have added a Page Report/RDL Report template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information. Also refer to Add a Dataset before reading this topic.

Note: This topic uses the DVDStock table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  1. In the Report Explorer, right-click the Parameters node and select Add Parameter.
  2. In the Report - Parameters dialog that appears, add a parameter named StorePrice with an Integer data type. Click the checkbox next to Hidden to hide the parameter UI at run time.
  3. On the Default Values tab, select Non-queried and click the Add(+) icon to add an empty expression for the value.
    Note: When you use From query to provide a default value, only the first returned row value is used as the default value.
  4. In the Value field enter 5 and click OK to close the Report - Parameters dialog.
    Note: When adding multiple default values, in the Report - Parameters dialog, General tab, check the Multivalue check box, otherwise the report collects only the first default value from the list and uses it to generate the report.
  5. In the Report Explorer, right-click Data Source (DataSource1 by default) node and select Add Data Set to create a dataset.
  6. In the DataSet Dialog that appears, on the Parameters page, click the Add(+) icon to add an empty expression for the parameter.
  7. In the Name field, enter the same parameter name (StorePrice) you had added in the steps above and set its value to:
    =Parameters!StorePrice.Value
  8. On the Query page of the DataSet Dialog, use the following SQL query to fetch data from the DvDStock table.
    SELECT * FROM DvDStock WHERE StorePrice IN (?).
  9. From the Visual Studio toolbox, drag and drop a Table data region (or any other data region) onto the design surface, and from the Report Explorer, drag the Title, StorePrice and In Stock fields onto the table details row.
  10. Click the Preview Tab to view the result.

Notice that the report collects the required parameter value from the default value (i.e. 5) and uses it to display the list of Movie DVDs with Store Price $5.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Concepts
Parameters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Tooltips in Charts for HTML5 Viewer

Add Tooltips in Charts for HTML5 Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Tooltips in Charts for HTML5 Viewer

Glossary Item Box

Tooltips display information about the area hovered by a cursor. When viewing a Chart, tooltips display information about data points and labels when you hover the cursor over a data series.

You can define tooltips for the chart's data point (viewed in HTML5 Viewer) by using expressions in the Tooltip field of the Series Values of the Chart Data dialog. You can also set a tooltip for a Chart in code by using the GrapeCity.ActiveReports.PageReportModel.DataPoint.ToolTip property.
If the Tooltip property is set, the label value of the current category group is displayed with the data points. In case of a nested grouping, the lowest category group value is displayed.

The following chart types, which do not support any interactivity feature, also do not support tooltips for charts in the HTML5 Viewer.

  • Area 3D - Stacked and Percent Stacked
  • Financial and Financial 3D – Kagi
  • Scatter and Scatter 3D - Connected and Smoothly Connected
Note: This topic uses the HTML5Viewer sample located in [User Documents folder]\GrapeCity Samples\ActiveReports 13 folder.

To add tooltips to a Chart viewed on HTML5 Viewer

  1. Open the HTML5Viewer sample.
  2. In the Solution Explorer, go to the Reports folder and open SalesDashboard.rdlx.
  3. In the Report Explorer, select the chSales_Column chart.
  4. In the Properties window, click Chart data to open the Chart Data dialog.
  5. Go to the Series Values page and select Sales.
  6. In the Tooltip field, enter the following expression:

    ="Sales: " & Sum(Fields!Sales.Value)

  7. On the Series Values page, select TargetValue.
  8. In the Tooltip field, enter the following expression:

    ="Target : " & Fields!TargetValue.Value

  9. Click OK and run the application. The tooltips are displayed on hovering the Chart series.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Note:

  • Tooltips are visible only at run time if the Tooltip property is not null.
  • The bold text in the tooltip is the Label value of the current category group. You can view the expression used for a tooltip in the Label field located on the Category Groups page of the Chart Data dialog.
  • If you have not specified the Label of the category group, then the label value in the tooltip will be auto-generated.
  • Tooltips you have set in the Tooltip Template property are visible in the HTML5 Viewer.

See Also

Expressions

Concepts
Classic Chart

Getting Started
HTML5 Viewer

Samples
HTML5 Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Freeze Rows and Columns (RDL Report)

Freeze Rows and Columns (RDL Report)
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Freeze Rows and Columns (RDL Report)

Glossary Item Box

When you use a Table or a Tablix data region containing a large amount of data in an RDL report, the user must scroll to see all of the data. On scrolling the column or row headers out of sight, the data becomes difficult to understand.

Note: The Frozen rows and columns feature is only available with RDL Reports.

To alleviate this problem, we have added GrapeCity.ActiveReports.PageReportModel.Table.FrozenRows and GrapeCity.ActiveReports.PageReportModel.Table.FrozenColumns properties to the Table and Tablix data regions. The properties take effect in the HTML5 Viewer in Galley mode, and allow you to freeze headers so that they remain visible while scrolling through the data region. You can freeze as many rows or columns as you have headers in the data region.

  • If your data stretches downward, set the FrozenRows property to a value to float the column headers when scrolling.
  • If your data stretches to the right, set the FrozenColumns property to a value to float the row headers when scrolling.
  • If your data stretches both downward and to the right, set both FrozenRows and FrozenColumns properties.

Here is an RDL report with a Tablix data region displayed in the HTML5 Viewer in Galley mode.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

When you scroll to view more rows and columns of data, the row and column headers scroll out of view, like this.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

When you set FrozenColumns = 3 and FrozenRows = 2, the three row headers and two column headers float when the user scrolls through the data, like this.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

If any header cells that you want to freeze are merged, you should not set the FrozenRows or FrozenColumns property to a value that would split a merged cell. For example, in the image above, there is an empty merged cell at the top left corner. This cell prevents you from setting FrozenRows to a value less than 2, because it would split the merged cell. The same cell also prevents you from setting FrozenColumns to a value less than 3, because that would also split the merged cell.

See Also

Tablix

Concepts
Table

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create and Add Themes

Create and Add Themes
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create and Add Themes

Glossary Item Box

Show All Show All
Hide All Hide All

A theme is a collection of properties that defines the appearance of a report. A theme includes colors, fonts, images, and expressions that you can apply to report elements once you add a theme to a report.

You can add one or many themes to a report. If a report has multiple themes, you can use the report's GrapeCity.ActiveReports.PageReportModel.Report.CollateBy property to control the page order in a report. For more information, see Collation.

Use the following instructions to create and add themes.

To create a new theme

  1. From the Start menu, go to All Programs > GrapeCity > ActiveReports and select ActiveReports Theme Editor.
  2. In the Theme Editor that opens, define the colors, fonts, images, and constant expressions properties for your new theme under the corresponding tabs.
  3. On the File menu, select Save.
  4. Choose a directory on your local machine and enter the name of a new theme, then click Save.

To add a theme to the report

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, click the Open... icon above the list of themes.
  4. In the Open dialog that appears, select a theme file from your local files and click Open.

See Also

Customize and Apply a Theme
Use Constant Expressions in a Theme

Concepts
Themes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Customize and Apply a Theme

Customize and Apply a Theme
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Customize and Apply a Theme

Glossary Item Box

Use the following instructions to customize an existing theme and apply it to your report.

To modify a theme

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, select an existing report theme.
  4. Click the Edit... icon above the list of themes.
  5. In the Theme Editor that opens, modify the theme properties and click OK to close the dialog.

To apply a theme color

  1. In the Designer, select the report’s control (for example, a TextBox).
  2. In the Properties window, go to the color-related property (for example, the BackgroundColor property) and click the arrow to display the drop-down list of values.
  3. In the list that appears, go to the Theme tab and select the color you want.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To apply a theme font

  1. In the Designer, select the report’s control (for example, a TextBox).
  2. In the Properties window, go to a property from the Font properties group (for example, the Font property) and click the arrow to display the drop-down list of values.
  3. In the values list that appears, select a font defined in a theme (for example, =Theme.Fonts!MinorFont.Family).

See Also

Create and Add Themes
Use Constant Expressions in a Theme

Concepts
Themes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use Constant Expressions in a Theme

Use Constant Expressions in a Theme
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Use Constant Expressions in a Theme

Glossary Item Box

Show All Show All
Hide All Hide All

In the Theme Editor, you can define constant expressions to be used in a theme. Later, you can apply a constant expression to the report’s control by selecting it in the Value field of that control.

Also, you can apply a constant expression to a report’s control in code by using the following syntax (VB code example):

=Theme.Constants!Header
=Theme.Constants("Header")

Constant expressions allow you to define a name and an associated value to be used in themes.

Use the following instructions to create and use constant expressions in themes.

To define a constant expression

  1. In the Theme Editor, go to Constants.
  2. Double-click the field under Name and enter the Constant name (for example, Header).
  3. In the next field to the right, under Value, enter the Constant value (for example, Invoice#).

To use a constant expression

  1. In the Designer, select the report’s control (for example, a TextBox).
  2. In the Properties Window, go to the Values field and select the <Expression> option from the drop-down list to open the Expression Editor.
  3. In the Expression Editor, expand the Themes node with the constant expressions defined in the report theme.
  4. In the Themes node, select a constant and then click the Replace or Insert button.
  5. Click OK to add the constant expression in the TextBox.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Create and Add Themes
Customize and Apply a Theme

Concepts
Themes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Set Up Collation

Set Up Collation
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Set Up Collation

Glossary Item Box

You can add multiple themes to the report. In this case, the report renders a combination of multiple outputs for each theme. For example, if a report has two themes, then the report output includes a combination of the first and the second themes, applied to each report page. You can control the combination rules of the report output in the GrapeCity.ActiveReports.PageReportModel.Report.CollateBy property.

Caution: If you are using collation in a report, you cannot use interactive features, such as drill down, links, document map, and sorting.

You can control the page order of a rendered report with multiple themes by selecting the collation mode in the CollateBy property of the report:

Note: The collection of constant expressions must be the same in all themes of a report. See Use Constant Expressions in a Theme for further information.
  1. In the Designer, click the gray area around the report page to select the report.
  2. In the Properties Window, go to the CollateBy property and select one of the available options:
    • Simple. Renders report pages without any specific sorting. For example, if you have a report with 2 themes, the report renders all pages with theme 1, then all pages with theme 2.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink

    • ValueIndex. Sorts report pages by page number. For example, if you have a report with 2 themes, the report renders page 1 for theme 1 and 2, then page 2 for theme 1 and 2, and so on.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink

    • Value. Sorts report pages by the grouping expression that you specify in the report's FixedPage dialog. For example, if you have a report with 2 themes with grouping, the report renders group1 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), then group 2 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), and so on.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink

      Note: In RDL Reports, the Value collation mode is not available by design.

See Add Page Numbering for information on setting cumulative page count formats for Page Report.

See Also

Add Page Numbering
Interactive Features
Expressions

Concepts
Themes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Hyperlinks

Add Hyperlinks
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Hyperlinks

Glossary Item Box

In a page report or a RDL report, you can set hyperlinks in the TextBox or Image controls to access a Web page from your report. You can also set hyperlinks on Map layer data elements. These hyperlinks open in the default browser of the system.

To add a hyperlink in the Textbox or Image control

  1. Add a Textbox or Image control to the design surface.
  2. With the control selected, under the Properties window, click the Property dialog link to open the respective control's dialog and go to the Navigation page.
    OR
    With the control selected, go to the Properties window and click the ellipses near the Action property to open the Navigation page in the dialog.
  3. On the Navigation page, select the Jump to URL radio button to enable the field below it.
  4. Type or use the expression editor to provide a valid Web page address. For example, http://activereports.grapecity.com/
  5. Click OK to close the dialog.
  6. In the Properties window, enter text in the Value property of the respective control to set the display text for the Web page hyperlink. For example, GrapeCity GrapeCity.

To add a hyperlink on Map layer elements

Map layer elements like point, polygon and line provides you a functionality to set hyperlinks on them to access a Web page from your report.

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right click the layer in use and select Edit.
  3. In the selected layer's dialog that appears, go to the Navigation page.
  4. On the Navigation page, select the Jump to URL radio button to enable the field below it.
  5. Type or use the expression editor to provide a valid Web page address. For example, http://activereports.grapecity.com/
  6. Click OK to close the dialog.

See Also

Concepts
Interactive Features

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Bookmarks

Add Bookmarks
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Bookmarks

Glossary Item Box

A bookmark link is similar to a hyperlink, except that it moves the viewer to another area in the report instead of opening a web page. You can add bookmarks in a two-step process:

  • Identify the place (target control) where you want to allow a user to jump to with the help of a Bookmark ID.
  • Share that Bookmark ID with another control that links to the target control.

Use the following steps to create a Bookmark ID on a Textbox control and create a bookmark link on another Textbox control at the bottom of the page.

These steps assume that you have already added a Page Report/RDL Report template to your project. See Adding an ActiveReport to a Project for further details.

To add a Bookmark ID on a control

Bookmark ID is like a URL that provides information required by the report viewer to locate the report control. You need to provide a Bookmark ID for any control to which you want to allow users to jump to via a Bookmark Link.

  1. From the Visual Studio toolbox, drag and drop a Textbox control onto the design surface.
  2. Select the Textbox to view its properties in the Properties window and enter any text in the Value property (For e.g., Top).
  3. Click the Property dialog link below the Properties window to open the Textbox dialog.
  4. In the TextBox dialog that appears, select the Navigation page and in the Bookmark ID field enter text like Link Text.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  5. Click OK to close the dialog.
Tip: You can also set the Bookmark ID through the Bookmark property in the Properties window.

To set a bookmark link

Bookmark Link is a simple link you create to jump to the location where the Bookmark ID is set.

  1. From the Visual Studio toolbox, drag and drop another Textbox control onto the design surface. Place it at the bottom of the page for this example.
  2. Select the Textbox to view its properties in the Properties window and in the Value property enter Go to Top.
  3. Click the Property dialog link below the Properties window to open the Textbox dialog.
  4. In the Textbox dialog that appears, click on the Navigation page and select the Jump To Bookmark radio button to activate it.
  5. Under Jump To Bookmark, enter the same text (i.e. Link Text) you assigned as Bookmark ID in the steps above.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  6. Click OK to close the dialog.
  7. Go to the Preview Tab, and click Go to Top.

You move to the top of the page where the Bookmark ID was set on the control.

Tip: You can also access the Navigation page of a control to set the bookmark link through the ellipsis button next to the Action property in the Properties window.

See Also

Concepts
Interactive Features

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create and Use a Master Report (RDL Report)

Create and Use a Master Report (RDL Report)
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create and Use a Master Report (RDL Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In an RDL report, you can create a master report and apply it to any number of content reports to keep common styles in one easy-to-maintain location. See Master Reports for more information.

To design a master report

Note: These steps assume that you have already added an RDL Report template and connected it to a data source. The Master Report feature is only available with RDL Reports. See the topic, Adding an ActiveReport to a Project for further information.
  1. With focus on the report, from the Report Menu, select Convert to Master Report to create a master report.
  2. Right-click the ruler area to the top or left of the report and choose Page Header. Repeat and choose Page Footer.
  3. From the toolbox, drag and drop controls into the page header and footer sections. These controls appear on every page of a content report when you apply the master report. For example, a company logo image, or a textbox with the company Web site address.

  4. A ContentPlaceHolder control appears in the toolbox when you convert an RDL report to a Master Report. This control defines regions where users can add content. Use the following instructions to add the ContentPlaceHolder control in the master report.

    • From the toolbox, drag and drop the ContentPlaceHolder control onto the report design surface.
    • Right-click the control and from the context menu that appears, select Properties to open the properties window.
    • Set the following properties for the ContentPlaceHolder control.
      Property | Description
      Location | To position the control with respect to the top left corner of the container.
      Size | To set the control size for determining the space available to design a content report.
      Text | To add instructive text for the user. E.g. "Design your content report here." This caption appears in the design view and not in the final output.

  5. Save the master report locally on your system.

    1. In Visual Studio, select the report, and from the Report menu, select Save Layout. In the stand-alone designer, the option is in the File menu. You can also save the master report from File menu of the stand-alone designer.
    2. In the Save As dialog that appears, navigate to the location where you want to save the report and click Save to save the report in rdlx-master file format.

To use a master report

  1. With focus on the report to which you want to apply the master report, from the Report menu, select Set Master Report, then Open Local File.
  2. In the Open dialog that appears, navigate to the location where you saved the master report and open it. The master report layout is applied to the content report with all areas locked except for the region with the ContentPlaceHolder, which is available for use.

See Also

Master Reports (RDL)
Report Types

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Images

Work with Images
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Images

Glossary Item Box

The Image report control displays an image that you embed in a report, add to a Visual Studio project, store in a database and access through a URL. You can choose an Image Source in the Properties window after you place the Image report control on a report.

To embed an image in your report

The benefit of using an embedded image is that there is no separate image file to locate or keep track of when you move the report between projects. The drawback of using embedded images is that when you use large images, it increases the size of your report.

  1. In the Report menu, select Embedded Images.
  2. Click under the Image column to reveal an ellipsis button (...) and select an image file from your local files. The Name and MimeType columns are filled in automatically and the image is stored in the report definition.
  3. With the Image report control selected, in the Properties grid, set the Source property to Embedded.
  4. In the Value property, select the embedded image from the drop-down list box.

To add a data visualizer image to your report

You can use a data visualizer to display data in small graphs that are easy to comprehend.

  1. With the Image report control selected, in the Properties grid, drop down the Value property and select <Data Visualizer...>.
  2. In the Data Visualizers dialog that appears, select the Visualizer Type that you want to use, Icon Set, Range Bar, or Data Bar.
  3. Use expressions related to your data to set the other values in the dialog.

To store an image in your Visual Studio project.

You may have an image that you want to use in multiple reports, for example a logo. In such cases, you can store your image as a project image. This not only allows you to quickly locate the correct image for new reports in the project, but also makes it easier when you update your logo, as you will not need to search through every report to replace embedded images. Another benefit is that the images are distributed with your application.

  1. From the Project menu, select Add Existing Item and navigate to the image file that you want to add to the project.
  2. With the Image report control selected, in the Properties grid, set the Source property to External.
  3. In the Value property, select project image from the drop-down list box.

To use a database image in an Image report control

Product catalogues are probably the most common scenario in which images stored in a database are used in reports. Place the Image report control in a data region to use database images that repeat for every row of data.

Note:
  • You cannot use database images in Page Headers and Page Footers because these sections cannot use the value expressions that refer to fields.
  • Microsoft Access database images are generally stored as OLE objects which the Image report control cannot read.
  1. With the Image report control selected, in the Properties grid, set the Source property to Database.
  2. In the Value property, select the field containing the image.

To use a Web image

You can also use any image to which you can navigate via a URL. The advantage of using web images is that images stored in this way add nothing to the file size of the project or of the report, but the drawback is that if the web based image is moved, it will no longer show up in your report.

  1. With the Image report control selected, in the Properties grid, set the Source property to External.
  2. In the Value property, enter the URL for the image.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use Dynamically Built JSON Data Source

Use Dynamically Built JSON Data Source
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Use Dynamically Built JSON Data Source

Glossary Item Box

JSON Data Provider supports dynamically built data sources. You can enter a connection string for the JSON data as an expression and pass values using parameters to set up data sources dynamically.

Steps to set up dynamically built data source are as follows:

Note:

  • JSON data source used is available at http://jsonplaceholder.typicode.com/comments/.
  • JSON schema for the above Json data is generated using http://jsonschema.net/#/.

Create a Page Report

  1. Open ActiveReport Report Designer application.
  2. From the File menu, select New.
  3. In the Create New Report dialog box that appears, select Page Report template and then click OK.

    Add a Parameter
  4. In the Report Explorer, right-click the Parameters node and select Add Parameters option.
  5. In the Report - Parameters dialog that appears, rename the parameter as UserId, and then click OK.

    Add a Data Source
  6. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the add button.
  7. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  8. Under Type, select JSON Provider.
  9. In the Content tab, select Expression.
  10. In the Expression field, enter an expression like the following:

    ="jsondoc=http://jsonplaceholder.typicode.com/comments/" & Parameters!UserId.Value & ";schemadata=
    {  ""$schema"": ""http://json-schema.org/draft-04/schema#"",  ""type"": ""object"",
    ""properties"": {      ""postId"": {        ""type"":    ""integer""      },
          ""id"": {        ""type"":    ""integer""      },
          ""name"": {        ""type"":    ""string""      },
          ""email"": {        ""type"":    ""string""      },
          ""body"": {        ""type"":    ""string""      }    },
        ""required"": [        ""postId"",      ""id"",      ""name"",        ""email"",      ""body""    ]  }}"

    Add a Data Set
  11. In the Report Explorer, right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set... from the Add button.
  12. In the DataSet Dialog that appears, select the General page and enter the name of the dataset.
  13. On the Query page of this dialog, select Command Type as Text and enter Query as $.
  14. On the Fields page, enter the Field name and value pairs as
    Name: postId; Value: postId
    Name: email; Value: email
    Name: name; Value: name
    Name: body; Value: body
  15. Click OK.

    Create layout for the Report
  16. Drop controls from Toolbox onto the report designer surface.
  17. Set the Value of each control to a data set field.

    Preview the Report
  18. Click the Preview tab.
  19. Enter the UserId parameter and click View report.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Sort Data

Sort Data
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Sort Data

Glossary Item Box

Show All Show All
Hide All Hide All

In a page report and a RDL report, you can apply sorting on a data region, grouped data or fixed page.

Use the following steps to determine how to sort your data. These steps assume that you have already added a Page Report (xml-based)/RDL Report template to your project and connected it to a data source. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

To sort in a data region

You can set the sorting expression on the Sorting page of a data region dialog.

  1. Right-click the data region and select Properties to open the Properties window. Select the Property dialog link under properties where the commands are displayed to open the data region dialog. See Properties Window for more information.
  2. In the dialog that appears, go to the Sorting page and click the Add(+) icon to add an empty expression to the sorting list below.
  3. In the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to sort your data.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag and drop the field on which the sorting expression is set and go to the Preview Tab to view the result.

The following image shows the result after setting sorting in a Table data region on the Title field in Ascending order:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To sort on grouped data

You can sort the order of groups through the Sorting tab of the Groups page or the Detail Grouping page of the List data region. The following steps assume that you have already grouped data in the data region. See Group in a Data Region for further information on grouping.

Note: In a Chart data region dialog, the Sorting tab is available on the Category Groups and Series Groups pages.
  1. On the Groups or the Detail Grouping page of the data region dialog, select the Sorting tab.
  2. In the Sorting tab, click the Add(+) icon to add an empty expression to the sorting list.
  3. In the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to sort your data. The expression set here should be the same as the grouping expression.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag and drop the field on which sorting is set and go to the Preview Tab to view the result.

The following image shows the result on a Table data region where grouping and sorting is set on the StorePrice field in Descending order:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To sort on a fixed page

In a Page Report , if the fixed page is grouped on a dynamic value, you can sort the order of the groups through the Sorting page of the FixedPage Dialog. Follow the steps below to learn setting up sorting on a Fixed Page:

  1. Right-click the gray area of the report and select Fixed Layout Settings to open the FixedPage dialog.
    OR
    Right click the report page and select Properties to open the Properties window. Select the Property dialog link under properties where the commands are displayed to open the FixedPage dialog. See Properties Window for more information on commands.
  2. In the FixedPage dialog that appears, go to the Grouping page and in the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to group your data.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  3. In the FixedPage dialog, now go to the Sorting page and click the Add(+) icon to add an empty expression to the sorting list below and in the Expression field enter the same expression you used for grouping the data.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
  5. Click OK to close and apply the settings.
  6. From the Report Explorer, drag and drop the field on which sorting is set and go to the Preview Tab to view the result.
    Note: The difference in setting sorting on a Fixed Page is that it affects every data region placed on the report layout, whereas sorting on a data region is limited to the data region only.

    The following images shows the result when sorting is set on a fixed page on the StorePrice field in descending order:

    Page 1 Page 2

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Concepts
Sorting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Allow Users to Sort Data in the Viewer

Allow Users to Sort Data in the Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Allow Users to Sort Data in the Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

In a page report or a RDL report, you can allow the end-user to sort columns of data in the Viewer by setting interactive sorting on a TextBox control within a data region. Follow the steps below to set interactive sorting in a TextBox control.

To set interactive sort properties on a TextBox

These steps assume that you have already added a Page Report (xml-based)/RDL Report template to your project and connected it to a data source and a data set. See Connect to a Data Source and Add a Dataset for further information.

  1. From the toolbox, drag a Table data region onto the report.
  2. From the Report Explorer, drag fields into the detail row of the table. Labels appear in the table header row, and expressions appear in the detail row.
  3. Click to select a TextBox in the header row on which you want to allow users to sort, and in the Commands section at the bottom of the Properties Window, click the Property dialog command.
  4. In the TextBox dialog that appears, select the Interactive Sort page.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  5. Select the checkbox next to Add an interactive sort action to this textbox and enable the other properties on the page.
  6. Under Sort expression, drop down the list and select the expression containing the value of the field on which you want to provide sorting.
    Note: Under Data region or group to sort, and Evaluate sort expression in this scope, you can optionally choose a different a scope from the Choose data region or grouping drop down list.
  7. Click OK to close the dialog and accept the changes.

When you preview the report, you can see a sort icon next to the TextBox control, the User Rating header in this case.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

You can click the icon to sort in descending order. The icon changes to an up arrow that you can click to sort ascending.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Concepts
TextBox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create a Drill-Down Report

Create a Drill-Down Report
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create a Drill-Down Report

Glossary Item Box

In a page layout, you can set up data regions, report controls, table rows, and tablix row and column groups to collapse, so that users can drill down into the data they choose to view.

In order to collapse an item, you use the Visibility settings available in the Properties Window or in the control dialog. You set the initial visibility of the report controls to Hidden and allow the user to toggle them by clicking other report controls (usually a TextBox).

When the report is initially displayed at run-time, the toggle items display with plus sign icons that you can click to display the detail data. Use the following steps to set a drill-down link.

  1. From the Visual Studio toolbox, drag and drop a TextBox control and a Table data region onto the report design surface.
  2. Place the TextBox control such that it appears as a header on your report.
  3. From the Report Explorer, expand your data set and drag fields and place them inside the detail row of the Table data region. Expressions for these fields appear in the detail row, and labels appear in the table header row.
  4. With the Table data region selected on the design surface, under the Properties window, click the Property dialog link. This is a command to open the respective control's dialog. See Properties Window for more on how to access commands.
  5. In the Table dialog that appears, go to the Visibility page, change the Initial visibility to Hidden, and select the check box next to Visibility can be toggled by another report control.
  6. From the drop-down list that appears, select the TextBox that you added in step 1. The TextBox is now used to toggle items in the Table and show detail data.
  7. Click OK to save the changes.

When you view the report, the Textbox displays an Expand/Collapse icon to its left.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click the icon to view the hidden data.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Concepts
Drill-Down Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Set a Drill-Through Link

Set a Drill-Through Link
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Set a Drill-Through Link

Glossary Item Box

In a page report or a RDL report, you can use drill-through links to connect one report to another detailed report. Follow the steps to set a drill-through link:

  1. On the design surface, select a report control (like a TextBox) on which you want set the link and under the Properties window, click the Property dialog link. This is a command to open the TextBox dialog. See Properties Window for more on how to access commands.
  2. In the control dialog that appears, go to the Navigation page and under Action, select the Jump to report radio button. Doing this activates the fields below it.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  3. Under the Jump to Report field, enter the name of the report (like BasicReport.rdlx) that you want to navigate to on clicking the drill-through link. You can also use expressions to create drill-through links.
    Note: In the Jump to Report field, enter just the report name if the targeted report is in the same directory as the parent report. Or you can enter a relative path to the report. Use the Custom Resource Locator to jump to a report in your connected database.

  4. After setting the detail report to drill-through, on the Navigation page, under Parameters, you can optionally enter a valid parameter Name and Value to pass to the detail report. This value must evaluate to a valid value for the parameter. By setting parameters you can jump right to the desired information. For example, if your summary report contains a list of invoice numbers and delivery dates for each customer, you could use a drill-through link with the invoice number as the parameter to allow the user to jump to the relevant invoice.

    Caution: The Parameter Name must exactly match the name of the parameter in the detail report. If any parameter is spelled differently, capitalized differently, or if an expected parameter is not supplied, the drill-through report fails.

  5. Go to the preview tab and click the drill-through link to navigate to the targeted report.
  6. On the Viewer toolbar, click the Back to Parent Report button to return to the main report.

The following images show a simple drill-through link set on a list displaying years. Click any year to drill-through to a report that contains top movies in that year.

Report With a Drill-Through Link

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Target Report

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Concepts
Linking in Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Items to the Document Map

Add Items to the Document Map
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Items to the Document Map

Glossary Item Box

In a page report or a RDL report, use the following steps to add report controls, groups and detail groups to the document map.

To add a control to the Document Map

Using Document Map Label or Label Property

  1. On the design surface, select a control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the command section of the Properties Window, click Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  3. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Alternatively,

  1. On the design surface, select the report control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the Properties window that appears, enter a text or an expression in the Label property to represent the report control in the Document map.

Using HeadingLevel Property

  1. On the design surface, select the report control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the Properties window that appears, set the HeadingLevel property of the report control.
    Note The HeadingLevel property defines the DocumentMap level for that control.

Go to the preview tab or the Viewer to view the document map.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To add a group or a detail group to the Document Map

  1. Open a report that contains a group. See Group in a Data Region for further information.
  2. On the design surface, select the data region on which grouping or detail grouping has been set and go to the command section which appears below the Properties Window.
  3. Click Property dialog to open the data region dialog. See Properties Window for more information on how to access commands.
  4. In the dialog that appears, go to the Grouping or Detail Grouping page, and under the Document map label, enter a text or an expression representing the group or detail group in the Document Map.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Go to the preview tab or the Viewer to view the document map.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To create a hierarchical Document Map

  1. Open a report that contains a data region like a Table.
  2. With the data region selected, right-click to open the context menu and select Properties.
  3. In the Properties Window that appears, select the Property dialog command at the bottom of the window to open the data region dialog. See Properties Window for further information on how to access commands.
  4. On the data region dialog, on the Groups page, set the grouping expression. For example, group the data on StorePrice (=Fields!StorePrice.Value). See Group in a Data Region for further information.
  5. On the same Groups page, set the Document map label to the value of the grouping expression. For example, =Fields!StorePrice.Value.
  6. On the design surface, select a control inside the data region. For example, the TextBox in the detail row of the Table data region.
  7. Right-click the control and select properties to open the Properties Window. In the command section of the Properties Window, click Property dialog.
  8. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.

Go to the preview tab or the Viewer to view the document map.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: In an Page report, you can also set grouping and set the document map label on the FixedPage dialog > Groups page. See Group in a FixedPage to learn how to set groups on a fixed page.

To set the numbering style for Document Map levels

You can the set the numbering style for all document map levels using the Report dialog or in the Properties Window using the DocumentMap property.

  1. In the Report Explorer select the Report item.
  2. In the command section of the Properties Window, click Property dialog. This is a command to open the Report dialog. See Properties Window for more information on how to access commands.
  3. In the Report dialog that appears, go to the Document Map page and set the Source property to one of the available value.
  4. Set the Numbering Style to one of the available formats. The selected style would get applied to all the document levels and only to the selected source that you had set above.
  5. Click OK to close the dialog.

You can also set separate numbering style to different document map levels using the DocumentMapLevelDesigner Collection Editor dialog.

  1. In the Report Explorer select the Report item.
  2. Go to the Properties Window, click the Levels (Collection) property and then click the ellipsis button that appears.
  3. In the DocumentMapLevelDesigner Collection Editor dialog that appears, consider the hierarchy of report bookmarks that appears in Document Map and add as many levels required using the Add button.
  4. Select each level and set its NumberingStyle to any of the available format.
  5. Click OK to close the dialog.
Note: Any customization made here gets directly applied to the Table of Contents control.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Change Page Size

Change Page Size
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Change Page Size

Glossary Item Box

You can change the size of your page through the Appearance page of the Report Dialog.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
  1. Click the gray area outside the design surface to select the report and under the Properties Window, click the Property dialog command.
  2. In the Report dialog that appears, on the Appearance page, select from a list of pre-defined Paper Size options from the dropdown list. This automatically changes the Height and Width values of the page based on the selected size.
  3. Set the Orientation of the page to Portrait or Landscape. This also modifies the Height and Width values of the page.

You can also set the page size through the PageSize property in the Properties Window.

Note: The unit of measure is based on your locale, but you can change it by typing in a different unit designator such as cm or pt after the number.

See Also

Concepts
Report Dialog

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Page Breaks in RDL (RDL Report)

Add Page Breaks in RDL (RDL Report)
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Page Breaks in RDL (RDL Report)

Glossary Item Box

In a page layout, you can add page breaks in a RDL report, using the PageBreakAtStart and PageBreakAtEnd properties of the report control.

You can set a page break before or after the Container control. It is also possible to force a page break before or after the following data regions or their groups:

  • List
  • Table
  • Tablix
  • Chart

Use the following steps to set page breaks in the report from the control dialogs:

To add a page break before or after a report control

  1. On the design surface, select the report control on which you want to add a page break and in the command section of the Properties Window, click Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  2. In the control's dialog that appears, on the General page, under Page Breaks, select the check box for Insert a page break before this control or Insert a page break after this control or both.
  3. Click the OK button to save the changes and to close the dialog.
  4. Go to the preview tab to view the result.

To add a page break before or after a group

  1. On the design surface, select the report control containing a group and in the command section of the Properties Window, click Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  2. In the control's dialog that appears, go to the Groups or Detail Grouping page whichever is available.
  3. On the Groups or Detail Grouping page, go the Layout tab and select the check box for Page break at start or Page break at end or both.
  4. Click the OK button to save the changes and to close the dialog.
  5. Go to the preview tab to view the result.

See Also

Concepts
Report Definition Language (RDL) Report

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Totals and Subtotals in a Data Region

Add Totals and Subtotals in a Data Region
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Totals and Subtotals in a Data Region

Glossary Item Box

Show All Show All
Hide All Hide All

You can add subtotals and grand totals in a data region to add meaning to the data it displays.

Use the steps below to learn how to set subtotals and totals in each data region. These steps assume that you have already added a Page Report/RDL Report template and connected it to a data source. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: This topic uses examples from the tables in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.

To add Totals and Subtotals in a Table

Show To add a subtotals to a table group

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. From the Report Explorer, drag a numeric field (like InStock) onto the detail row of the Table. This is the field for which you want to display subtotals.
  3. Follow the steps below to add groups to the Table data region.
    • Click inside the Table to reveal the row and column handles along the left and top edges.
    • Right-click in the row handles along the left edge of the table and select Insert Group.
    • In the Groups dialog that appears, set a Group on expression (like StorePrice) on which you want to group the data.
    • Click the OK button to close the dialog and add the group. A new pair of rows for group header and footer appear on the Table.
  4. From the Report Explorer, drag and drop the numeric field (like InStock) you added to the detail row in step 2, onto the GroupFooter row.
  5. Double click the textbox containing the field you just dropped onto the GroupFooter row and add a Sum function to its expression to calculate the total [for example, =Sum(Fields!InStock.Value)].
  6. Go to the Preview Tab to see the subtotals appearing below each group of data in the Table.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Show To add a grand total to a table

  1. Drag the numeric field (like InStock) you used to set subtotals on in the procedure above onto the Table Footer row.
  2. Double click the textbox containing the field you just dropped onto the Table Footer row and add a Sum function to its expression to calculate the total [for example, =Sum(Fields!InStock.Value)].
  3. Go to the Preview Tab and notice that at the end of the table, the Textbox from the Table Footer row supplies the grand total.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To add Totals and Subtotals in a List

Show To add a subtotals to a list

  1. From the Visual Studio toolbox, drag and drop a List data region onto the design surface.
  2. From the Report Explorer, drag and drop a numeric field (like Price) onto the List data region.
  3. Double click the textbox containing the field you just dropped and add a Sum function to its expression to calculate the total [for example, =Sum([Price] * [Quantity])].
    Note: If you preview the report at this point, you will notice that the field renders the grand total for the dataset after each sales amount.
  4. Follow the steps below to add detail grouping to the List data region.
    • Right-click the list and select Properties.
    • In the Detail Grouping page, select a Group on expression (like AccountNumber) on which you want to group the data.
    • Click the OK button to close the dialog and apply grouping.
  5. Go to the Preview Tab to view the report, you can see a subtotal on price for each account number.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Show To add a grand total to a list

  1. Drag the numeric field that shows subtotals in your list (like Price) just below the List data region.
  2. Double click the textbox containing the field you just dropped and add a Sum function to its expression to calculate the grand total [for example, =Sum([Price] * [Quantity], "List1")].
  3. Go to the Preview Tab and notice that below the List there is a Textbox that supplies the grand total.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To add Totals and Subtotals in a BandedList

Show To add a subtotal to a banded list

  1. From the Visual Studio toolbox, drag and drop a Banded List data region onto the design surface.
  2. From the Report Explorer, drag a numeric field (Like InStock) onto the detail band of the banded list.
  3. Follow the steps below to add groups to the BandedList data region.
    • Right-click the BandedList and select Insert Group.
    • In the Groups dialog that appears, select a Group on expression (like StorePrice) on which you want to group the data.
    • Click the OK button to close the dialog and add a group. A new pair of group bands appear on the data region.
  4. From the Report Explorer, the numeric field (like InStock) you added to the detail band in step 2, onto the GroupFooter band.
  5. Double click the textbox containing the field you just dropped and add a Sum function to its expression to calculate the subtotal[for example, =Sum(Fields!InStock.Value)].
  6. Go to the Preview Tab to view the report to see the subtotals appearing below each group of data in the BandedList.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Show To add a grand total to a banded list

  1. Drag the numeric field (like InStock) you used to set subtotals on in the procedure above onto the BandedListFooter band.
  2. Double click the textbox containing the field you just dropped onto the BandedListFooter band and add a Sum function to its expression to calculate the total [for example, =Sum(Fields!InStock.Value)].
  3. Go to Preview Tab and notice that at the end of the BandedList, the Textbox from the BandedListFooter band supplies the grand total.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To add Totals and Subtotals in a Tablix

Note: In this example, we are using the StoreSalesbyYear table from the Reels database.

Show To add a subtotal to a Tablix group

  1. From the Visual Studio toolbox, drag and drop a Tablix data region onto the design surface.
  2. Drag and drop the StoreName field from the Report Explorer to the row group area (bottom left corner) of the Tablix data region. This is the row header, and dragging a field into it automatically adds a row group.
  3. Drag and drop the SaleYear field from the Report Explorer to the column group area (top right corner) of the Tablix data region. This is the column header, and dragging a field into it automatically adds a column group. Modify the SaleDate field expression to =[SaleDate].Year to provide yearly data.
  4. Drag and drop the TotalSales field from the Report Explorer to the body area (bottom right corner) of the Tablix data region. This will automatically set expression of the cell to =Sum(Fields!TotalSales.Value).
  5. Right-click the column group area, select Add Total, and then click After. A new column appears to the right with the text Total. This displays the subtotals for each row group.
  6. Right-click the row group area, select Add Total, and then click After. A new row appears at the bottom with the text Total. This displays the subtotals for each column group.

  7. Go to the Preview tab to view the subtotals for each year.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Show To add a grand total to a Tablix

  1. The row and columns subtotals set in the previous procedure, intersect at the rightmost cell of the Tablix that contains the grand total of the combined sales amount for years 2004 and 2005 in all the stores.
  2. Go to the Preview tab to view the result.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Tablix Reports
Common Functions
Tablix

Concepts
Expressions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create a Simple Web Designer Sample

Create a Simple Web Designer Sample
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create a Simple Web Designer Sample

Glossary Item Box

The topic describes creating Web Designer sample using ASP .NET MVC Core and ASP .NET MVC.

ASP .NET MVC Core

The steps to create a Web Designer sample using ASP .NET MVC Core application are as follows:

  1. Open Microsoft Visual Studio 2017 and create a new ASP .NET Core Web Application project.

  2. Select .NET Framework - ASP .NET Core 2.1 - Empty project template.

    In Project > Properties ensure that Target framework is .NET Framework 4.6.2.
  3. In Solution Explorer right-click Dependencies and go to Manage NuGet Packages.
  4. In the window that appears, go to Browse and input Microsoft.AspNetCore.StaticFiles, select version 2.1.1 and click Install.
  5. In the Preview Changes dialog that appears, click OK.
  6. In the License Acceptance dialog that appears, click I Accept.
  7. In Solution Explorer, right-click Dependencies and select Add Reference.
  8. In the Reference Manager dialog that appears, click Browse and navigate to ActiveReports 13 folder containing assemblies. By default it is C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 13 on 64-bit Windows.
  9. Select following assemblies and click Add:
    • GrapeCity.ActiveReports.Core.Rdl.dll
    • GrapeCity.ActiveReports.dll
    • GrapeCity.ActiveReports.Core.Diagnostics.dll
    • GrapeCity.ActiveReports.Aspnetcore.Designer.dll
  10. In the Reference Manager dialog, click OK to confirm the above added assemblies.
  11. In Solution Explorer, find Startup.cs and modify its content as follows:
    Startup.cs Copy Code
    using System.IO;
using Microsoft.AspNetCore.Builder;
using Microsoft.AspNetCore.Hosting;
using Microsoft.Extensions.DependencyInjection;
using GrapeCity.ActiveReports.Aspnetcore.Designer;
namespace WebDesignerSample
{
        public class Startup
        {
                // resources (reports, themes, images) location
                private static readonly DirectoryInfo ResourcesRootDirectory = new DirectoryInfo(".\\resources\\");
                public void ConfigureServices(IServiceCollection services)
                {
                        // web designer services
                        services.AddDesigner();
                }
                public void Configure(IApplicationBuilder app, IHostingEnvironment env)
                {
                        // web designer middleware
                        app.UseDesigner(config => config.UseFileStore(ResourcesRootDirectory));
                        // static files middlewares
                        app.UseDefaultFiles();
                        app.UseStaticFiles();
                }
        }
}
  12. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.
  13. Go to C:\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\WebDesigner folder on a 64-bit Windows.
  14. Copy following basic WebDesigner-related files/folder and paste it to your sample project wwwroot subfolder:
    • baseServerApi.js
    • web-designer.css
    • web-designer.js
    • vendor folder
    Optionally you can also copy file-dialog.css and file-dialog.js if you would like to use our sample dialog for saving reports.
  15. In Solution Explorer, right-click wwwroot and select Add > New Item.
  16. Select HTML Page item type, input index.html and click Add.
  17. In Solution Explorer, find newly-added index.html and modify its content as follows:
    index.html Copy Code
    <!DOCTYPE html>
<html>
<head>
    <title>Web Designer Sample</title>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="x-ua-compatible" content="ie=edge">
    <!-- designer-related css -->
    <link rel="stylesheet" href="vendor/css/materialdesignicons.min.css" media="all" type="text/css" />
    <link rel="stylesheet" href="vendor/css/bootstrap.min.css" />
    <link rel="stylesheet" href="vendor/css/font-awesome.min.css">
    <link rel="stylesheet" href="vendor/css/ionicons.min.css">
    <link rel="stylesheet" href="vendor/css/fonts-googleapis.css" type="text/css">
    <link rel="stylesheet" href="web-designer.css" />
</head>
<body class="theme-blue">
    <!-- designer-related js -->
    <script src="vendor/js/jquery.min.js"></script>
    <script src="vendor/js/bootstrap.min.js"></script>
    <script src="baseServerApi.js"></script>
    <script src="web-designer.js"></script>
    <!-- designer root div -->
    <div id="designer-id" style="width: 100%; height: 100%;"></div>
    <script>
        // create designer options
        var designerOptions = GrapeCity.ActiveReports.WebDesigner.createDesignerOptions(baseServerApi);
        // render designer application
        GrapeCity.ActiveReports.WebDesigner.renderApplication('designer-id', designerOptions);
    </script>
</body>
</html>
  18. Build your solution (Build> Build Solution) and run it. WebDesigner with a blank RDL report opens in your browser.

  19. If you would like to open not a blank report but one of your existing reports in resources subfolder (added above in step 12), you will need to add the following line with your report name in index.html after createDesignerOptions() function call:
    index.html Copy Code
    designerOptions.reportInfo.id = "MyReport.rdlx";
  20. In case you copied file-dialog.css and file-dialog.js to the sample project wwwroot subfolder in step 14., you can plug-in our sample dialog for saving reports.
    Following steps are required to be performed in index.html to plug-in the dialog component:
    i. In <head> tag, add file-dialog.css near web-designer.css:
    Copy Code
    <link rel="stylesheet" href="file-dialog.css" />
<link rel="stylesheet" href="web-designer.css" />

    ii. In <body> tag, add file-dialog.js near web-designer.js:
    Copy Code
    <script src="file-dialog.js"></script>
<script src="web-designer.js"></script>

    iii. Near designer root div and dialog root div:
    Copy Code
    <!-- designer root div -->
< div id="designer-id" style="width: 100%; height: 100%;"></div>
<!-- save as dialog root div -->
< div id="save-as-dialog-id" style="position: absolute; top: 0; left: 0; width: 100%; height: 100%; display: none; z-index: 9999;"></div>

    iv. Modify <script> tag contents where designer application is rendered:
    Copy Code
    <script>
    var showElement = function (id) {
        if (!id) return;
        ($('#' + id)).css('display', 'block');
    };
    var hideElement = function (id) {
        if (!id) return;
        ($('#' + id)).css('display', 'none');
    };
    var designerId = 'designer-id';
    var saveAsDialogId = 'save-as-dialog-id';
    function onSaveAs(options) {
        showElement(saveAsDialogId);
        // render save-as dialog
        fileDialog.createSaveReportAsDialog(saveAsDialogId, {
            locale: options.locale,
            api: {
                getReportsList: function () {
                    return baseServerApi.getReportsList()
                        .then(function (reportsList) {
                            return reportsList.map(function (reportInfo) {
                                return { path: reportInfo.Name };
                            });
                        });
                },
                saveReport: function (saveOptions) {
                    return baseServerApi.saveNewReport({
                        name: saveOptions.path,
                        content: options.reportInfo.content,
                    }).then(function (saveResult) {
                        return { id: saveResult.Id };
                    });
                },
            },
            reportInfo: {
                path: options.reportInfo.name,
            },
            onSuccess: function (saveResult) {
                hideElement(saveAsDialogId);
                options.onSuccess({ id: saveResult.id, name: saveResult.path });
            },
            onClose: function () {
                hideElement(saveAsDialogId);
            },
        });
    };
    // create designer options
    var designerOptions = GrapeCity.ActiveReports.WebDesigner.createDesignerOptions(baseServerApi);
    // enable showing save-as button
    designerOptions.saveAsButton.visible = true;
    // specify behavior on save-as
    designerOptions.onSaveAs = onSaveAs;
    // render designer application
    GrapeCity.ActiveReports.WebDesigner.renderApplication(designerId, designerOptions);
</script>

You get a designer with plugged-in sample save-as dialog. Such minimalistic designer can be used for editing the existing reports without adding new data sets.

However, in case you need to create brand-new reports, add data sets and preview reports from designer, please refer to ActiveReports Web Designer API documentation as described in the Designer Options Object topic.

ASP .NET MVC

The steps to create a Web Designer sample using ASP .NET MVC application are as follows:

  1. Open Microsoft Visual Studio 2012 and create a NET Framework 4.6.2 ASP .NET Empty Web Application project.
  2. In Solution Explorer, right-click References and go to Manage NuGet Packages.
  3. In the window that appears, go to Online > nuget.org.
  4. In the right-upper corner search box, input Microsoft ASP.NET MVC and install this package.

    In the License Acceptance dialog that appears, click I Accept.
  5. In search box input OWIN, find 'OWIN' in search results and install this package:

  6. In search box input Microsoft.Owin and install this package.

    In the License Acceptance dialog that appears, click I Accept:
  7. In search box input Microsoft.Owin.Host.SystemWeb and install this package.

    In the appeared License Acceptance dialog click I Accept:
  8. In search box input Microsoft.Owin.StaticFiles and install this package.

    In the License Acceptance dialog that appears, click I Accept.
  9. In search box input Microsoft.Owin.FileSystems.
    However, this package should be already installed together with Microsoft.Owin.StaticFiles in the previous step.

    Therefore, all the needed packages are installed. Now, close NuGet Package Manager.
  10. In Solution Explorer right-click References > Add Reference...:
  11. In the Reference Manager dialog that appears, go to Assemblies, in the right-upper corner search box input GrapeCity.
    In search results, select following assemblies and click OK:
    • GrapeCity ActiveReports for .NET
    • GrapeCity.ActiveReports.Aspnet.Designer
    • GrapeCity.ActiveReports.Core.Diagnostics
    • Grapecity.ActiveReports.Core.Rdl

  12. In Solution Explorer, right-click your project, go to Add > New Item...

    In the window that appears, go to Code > Class, input Startup.cs and click Add.

    Modify the contents of newly-added Startup.cs as follows:

    Copy Code
    using System;
using System.IO;
using System.Linq;
using System.Web;
using GrapeCity.ActiveReports.Aspnet.Designer;
using Owin;
using Microsoft.Owin;
using Microsoft.Owin.StaticFiles;
using Microsoft.Owin.FileSystems;
using System.Web.Mvc;
using System.Web.Routing;
[assembly: OwinStartup(typeof(AspNetDesignerSample.Startup))]
namespace AspNetDesignerSample
{
    public class Startup
    {
        // resources (reports, themes, images) location
        private static readonly DirectoryInfo ResourcesRootDirectory =
            new DirectoryInfo(String.Format("{0}.\\resources\\", HttpRuntime.AppDomainAppPath));
        public void Configuration(IAppBuilder app)
        {
            // web designer middleware
            app.UseDesigner(config => config.UseFileStore(ResourcesRootDirectory));
            // static files middlewares
            var fileSystem = new PhysicalFileSystem(String.Format("{0}.\\wwwroot\\", HttpRuntime.AppDomainAppPath));
            app.UseDefaultFiles(new DefaultFilesOptions { DefaultFileNames = new[] { "index.html" }, FileSystem = fileSystem });
            app.UseStaticFiles(new StaticFileOptions { FileSystem = fileSystem });
        }
    }
}
  13. Create 'resources' folder in your sample project root; you can put your existing reports, themes, and images in this folder.
  14. Go to C:\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\WebDesigner folder on 64-bit Windows.
    a) Copy Web.Config to your sample project root (overwrite the existing Web.config):

    b) Create 'wwwroot' folder in your sample project root. Copy following basic WebDesigner-related files and paste it to your sample project wwwroot subfolder:
    • baseServerApi.js
    • web-designer.css
    • web-designer.js
    • vendor

      Optionally you can also copy file-dialog.css and file-dialog.js if you would like to use our sample dialog component for saving reports.
  15. In Solution Explorer top bar, check Show All Files.

    Right-click wwwroot and select Include In Project.

    Uncheck Show All Files.
  16. Right-click wwwroot and select Add > New Item...:

    In the window that appears, go to Web > HTML Page, input index.html and click Add.

    In Solution Explorer find newly-added index.html and modify its content as follows:

    Copy Code
    <!DOCTYPE html>
<html>
<head>
    <title>Web Designer Sample</title>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="x-ua-compatible" content="ie=edge">
    <!-- designer-related css -->
    <link rel="stylesheet" href="vendor/css/materialdesignicons.min.css" media="all" type="text/css" />
    <link rel="stylesheet" href="vendor/css/bootstrap.min.css" />
    <link rel="stylesheet" href="vendor/css/font-awesome.min.css">
    <link rel="stylesheet" href="vendor/css/ionicons.min.css">
    <link rel="stylesheet" href="vendor/css/fonts-googleapis.css" type="text/css">
    <link rel="stylesheet" href="web-designer.css" />
</head>
<body class="theme-blue">
    <!-- designer-related js -->
    <script src="vendor/js/jquery.min.js"></script>
    <script src="vendor/js/bootstrap.min.js"></script>
    <script src="baseServerApi.js"></script>
    <script src="web-designer.js"></script>
    <!-- designer root div -->
    <div id="designer-id" style="width: 100%; height: 100%;"></div>
    <script>
        // create designer options
        var designerOptions = GrapeCity.ActiveReports.WebDesigner.createDesignerOptions(baseServerApi);
        // render designer application
        GrapeCity.ActiveReports.WebDesigner.renderApplication('designer-id', designerOptions);
    </script>
</body>
</html>

    Build your solution and run it. WebDesigner with a blank RDL report opens in your browser.
  17. See steps from Step 19 of ASP .NET MVC Core application to complete this sample.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Merge Multiple Reports

Merge Multiple Reports
ActiveReports 13 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Merge Multiple Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can merge or combine multiple Page and RDL reports into one report. Merging is performed by using ReportCombiner class which adds the reports as subreports. The reports are merged one after the another, in the order in which they are added.

You can use the BuildReport method to utilize all the features of the PageReport class. You can also insert page breaks and specify the gap between two reports when merging. By default, the gap of 1 inch is added between the reports.

The following code combines three reports. You need to add GrapeCity.ActiveReports.Core.Rendering assembly to your project. The code also exports the merged report in PDF format, so you need to add GrapeCity.ActiveReports.Export.Pdf assembly.

Show To write the code in Visual Basic.NET

Visual Basic.NET Copy Code
Dim combiner = New GrapeCity.ActiveReports.ReportsCore.Tools.ReportCombiner()

Dim r1 = New GrapeCity.ActiveReports.PageReport()
r1.Load(New System.IO.FileInfo("c:\temp\Report1.rdlx"))

Dim r2 = New GrapeCity.ActiveReports.PageReport()
r2.Load(New System.IO.FileInfo("c:\temp\Report2.rdlx"))

Dim r3 = New GrapeCity.ActiveReports.PageReport()
r3.Load(New System.IO.FileInfo("c:\temp\Report3.rdlx"))

combiner.AddReport(r1)

Dim options = New GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions
options.Gap = "5in" 'adds a 5 inch gap from the first report. By default this gap is 1 inch.
options.PageBreakBefore = True 'adds a page break.

combiner.AddReport(r2, options)
combiner.AddReport(r3)

'PDF Rendering extension
Dim pdfRe = New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim provider = New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(New System.IO.DirectoryInfo("c:\temp\"), "CombinedReport")

Viewer1.LoadDocument(combiner.BuildReport().Document)   'load combined report in viewer
combiner.BuildReport().Document.Render(pdfRe, provider) 'export combined report in PDF format

Show To write the code in C#

C# code Copy Code
var combiner = new GrapeCity.ActiveReports.ReportsCore.Tools.ReportCombiner();

var r1 = new GrapeCity.ActiveReports.PageReport();
r1.Load(new System.IO.FileInfo(@"c:\temp\Report1.rdlx"));

var r2 = new GrapeCity.ActiveReports.PageReport();
r2.Load(new System.IO.FileInfo(@"c:\temp\Report2.rdlx"));

var r3 = new GrapeCity.ActiveReports.PageReport();
r3.Load(new System.IO.FileInfo(@"c:\temp\Report3.rdlx"));

combiner.AddReport(r1);
combiner.AddReport(r2, new LocationOptions() { PageBreakBefore = true, Gap = "5in" }); //adds second report after a page break and a 5 inch gap from the first report. By default this gap is 1 inch.
combiner.AddReport(r3);

//PDF Rendering extension
var pdfRe = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
var provider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(new System.IO.DirectoryInfo(@"c:\temp\"), "CombinedReport");

viewer1.LoadDocument(combiner.BuildReport().Document);   //load combined report in viewer
combiner.BuildReport().Document.Render(pdfRe, provider); //export combined report in PDF format

The merged reports can be modified in many ways as described below.

To add reports at particular index

If you want to add a report r4 after the first report r1, use the following code with index '1':

C# Copy Code
combiner.Insert(1, r4, new LocationOptions());
report = combiner.BuildReport();
VB.NET Copy Code
combiner.Insert(1, r4, New GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions())
report = combiner.BuildReport()

To add a list of reports

C# Copy Code
combiner.AddRange(new PageReport[] {r1, r2, r3, r4 }, new LocationOptions())
report = combiner.BuildReport();
VB.NET Copy Code
Dim reports As IEnumerable(Of GrapeCity.ActiveReports.PageReport) = {r1, r2, r3, r4}
combiner.AddRange(reports, New GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions())
report = combiner.BuildReport()

To delete report(s)

If you want to delete a report in first position, use the following code with index '0':

C# Copy Code
combiner.RemoveAt(0);
report = combiner.BuildReport();
VB.NET Copy Code
combiner.RemoveAt(0)
report = combiner.BuildReport()

Similarly, if you want to delete report at second position, use index '1'.

If you want to delete all instances of report r2, use the following code:

C# Copy Code
combiner.RemoveAll(r2);
report = combiner.BuildReport();
VB.NET Copy Code
combiner.RemoveAll(r2)
report = combiner.BuildReport()

Note:

  • If the reports being merged are of different sizes, the page size of the first report is applied to all the pages of combined report.
  • If the reports being merged are of different paper orientations, the paper orientation of the first report is applied to all the pages of combined report.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Report How To

Section Report How To
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To

Glossary Item Box

Learn to perform common tasks in Section reports with quick how-to topics.

In this section

Work with Data in Section Reports
Learn how to work with Section reports and perform various reporting tasks specific to this type of report.
Work with Report Controls
Learn how to work with fields, display page numbers, add charts, and many other tasks with Section report controls.
Create Common Section Reports
Learn what the tools and UI items on the report designer can help you to accomplish.
Inherit a Report Template
Learn how to inherit a report template in other reports to share common features with multiple reports.
Change Ruler Measurements
Learn how to change ruler measurements at design time and run time.
Print Multiple Copies, Duplex and Landscape
Learn how to set duplex and landscape printing from the Report Settings dialog and also set printing for multiple copies.
Conditionally Show or Hide Details
Learn how to conditionally show or hide details in a section layout report.
Add Parameters in a Section Report
Learn how to use parameters to filter data in the report.
Add and Save Annotations
Learn how you can save a report with annotations to RDF and add annotations in a report at run time.
Add Bookmarks
Learn how to set bookmarks.
Add Hyperlinks
Learn how to add hyperlinks in a section layout report.
Use External Style Sheets
Learn how to use external style sheets in a section layout report.
Insert or Add Pages
Learn how to insert or add pages in section layout report.
Embed Subreports
Learn how to create add a subreport to a child report in the project.
Add Code to Layouts Using Script
Learn how to add code to the layouts using script.
Save and Load RDF Report Files
Learn how to save and load a .rdf report file.
Save and Load RPX Report Files
Learn how to save and load a .rpx report file.

See Also

Page Report/RDL Report How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Data in Section Reports

Work with Data in Section Reports
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports

Glossary Item Box

See step-by-step instructions for performing common tasks using ActiveReports.

In this section

Bind Reports to a Data Source
Learn how to bind reports to various data sources.
Add Grouping in Section Reports
Learn how to use the GroupHeader section to group data in a section report.
Modify Data Sources at Run Time
Learn to use code to modify a report's data source.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bind Reports to a Data Source

Bind Reports to a Data Source
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports > Bind Reports to a Data Source

Glossary Item Box

Show All Show All
Hide All Hide All

At design time, you can connect a section report to a data source through the Report Data Source dialog. You can access the Report Data Source dialog by doing one of the following:

  • On the detail section band, click the Data Source Icon.
  • Click the gray area around the design surface and in the commands section at the bottom of the Properties Window, click the Edit Data Source command.

There are four tabs in the dialog for the four most commonly used data sources.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

The following steps take you through the process of binding reports to each data source. These steps assume that you have already added an ActiveReports 13 Section Report template in a Visual Studio project. See Adding an ActiveReport to a Project further information on adding different report layouts.

To use the OLE DB data source

  1. In the Report Data Source dialog, on the OLE DB tab, click the Build button next to Connection String.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter a SQL query to select the data that you want use from the connected database. For example, Select * From CUSTOMERS
    OR
    In the Report Data Source dialog, click on Query Designer button to access Visual Query Designer for creating SQL queries. See Visual Query Designer for further information on how to create a query using the interactive query designer.
  7. Click OK to save the data source and return to the report design surface.

To use the ODBC data source

Before you connect to a ODBC data source, you must install a ODBC driver and set up a ODBC data source. For more information, see How To: Setup an ODBC Data Source.

  1. In the Report Data Source dialog, click the ODBC tab.
  2. In the Connection String field on the ODBC tab, enter a connection string to connect to the database. For example, Provider=MSDASQL;Persist Security Info=False;DSN=MS Access Database
  3. In the Query field on the ODBC tab, enter a SQL query to select the data that you want use from the connected database. For example, Select * From CUSTOMERS
  4. Click OK to save the data source and return to the report design surface.

To use the SQL data source

  1. In the Report Data Source dialog, on the SQL tab, click the Build button next to Connection String.
  2. In the Data Link Properties window that appears, select Microsoft OLE DB Provider for SQL Server and click the Next button to move to the Connection tab.
  3. On the Connection tab of the Data Link Properties window:
    • In the Select or enter server name field, select your server from the drop down list.
    • Under Enter information to log on to the server, select the Windows NT security credentials or your specific user name and password.
    • Under Select the database on the server, select a database from the server or attach a database file.
    • Click the Test Connection button to see if you have successfully connected to the database.
  4. Click OK to close the Data Link Properties window and to return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  5. In the Query field on the SQL tab, enter a SQL query to select the data that you want use from the connected database. For example, Select * From CUSTOMERS
    OR
    In the Report Data Source dialog, click on Query Designer button to access Visual Query Designer for creating SQL queries. See Visual Query Designer for further information on how to create a query using the interactive query designer.
  6. Click OK to save the data source and return to the report design surface.

To use the XML data source

  1. In the Report Data Source dialog, on the XML tab, click the ellipsis (...) button next to File URL field.
  2. In the Open File window that appears, navigate to your XML data file to select it and click the Open button. You can use a sample XML data file located at C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13\Data\customer.xml.
  3. In the Recordset Pattern field, enter a valid XPath expression like the following. //CUSTOMER
  4. Click OK to save the data source and return to the report design surface.

You also have the option to use an unbound or an IEnumerable data source. See the following procedures to implement these data source connections in code.

To use the CSV data source

  1. In the Report Data Source dialog, on the CSV tab, click the Build button next to Connection String.
  2. Specify the File Path by clicking the Open button and selecting the .csv file.
  3. Set the options in the wizard. See the Sample CSV Connection String drop-down under Report Data Source Dialog for further details.
  4. To edit the Name, Width (if applicable), and Data Type of columns shown in the Preview, click the Get from preview button. Note that Width is applicable only for Fixed data type.
  5. Click OK to save the changes and close the dialog. The Connection String tab displays the generated connection string. You can validate the connection string by clicking the Validate DataSource icon [image].
  6. Click OK on the lower right corner to close the dialog. You have successfully connected the report to a CSV data source. Note that the dataset for the CSV data source is added automatically.

To use an Unbound data source

Show To create a data connection

  1. Add an Imports (VisualBasic.NET) or using (C#) statement for System.Data and System.Data.Oledb namespaces.
  2. Right-click the gray area outside the design surface to select the report and select Properties.
  3. In the Properties window that appears, click the Events icon to view the available events for the report.
  4. In the events list, double-click the ReportStart event. This creates an event-handling method for the ReportStart event in code.
  5. Add the following code to the handler.

    Show To write code in VisualBasic.NET

    Visual Basic.NET code. Paste above the ReportStart event. Copy Code
    Dim m_cnnString As String
Dim sqlString As String
Dim m_reader As OleDbDataReader
Dim m_cnn As OleDbConnection
    Visual Basic.NET code. Paste inside the ReportStart event. Copy Code
    'Set data source connection string.
m_cnnString = "Provider=Microsoft.Jet.OLEDB.4.0;" _
        + "Data Source=C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13\Data\Nwind.mdb;Persist Security Info=False"
'Set data source SQL query.
sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid " _
        + "= products.categoryid ORDER BY products.categoryid, products.productid"
'Open connection and create DataReader.
m_cnn = New OleDb.OleDbConnection(m_cnnString)
Dim m_Cmd As New OleDb.OleDbCommand(sqlString, m_cnn)
If m_cnn.State = ConnectionState.Closed Then
   m_cnn.Open()
End If
m_reader = m_Cmd.ExecuteReader()

    Show To write code in C#

    C# code. Paste above the ReportStart event. Copy Code
    private static OleDbConnection m_cnn;
private static OleDbDataReader m_reader;
private string sqlString;
private string m_cnnString;
    C# code. Paste inside the ReportStart event. Copy Code
    //Set data source connection string.
m_cnnString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source="
        + @"C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13\Data\Nwind.mdb;Persist Security Info=False";
//Set data source SQL query.
sqlString = "SELECT * FROM categories INNER JOIN products"
        + " ON categories.categoryid = products.categoryid"
        + " ORDER BY products.categoryid, products.productid";
//Open connection and create DataReader.
m_cnn = new OleDbConnection(m_cnnString);
OleDbCommand m_Cmd = new OleDbCommand(sqlString,m_cnn);
if(m_cnn.State == ConnectionState.Closed)
{
  m_cnn.Open();
}
m_reader = m_Cmd.ExecuteReader();

Show To close the data connection

  1. Right-click the gray area outside the design surface to select the report and select Properties.
  2. In the Properties window that appears, click the Events icon to view the available events for the report.
  3. In the events list, double-click the ReportEnd event. This creates an event-handling method for the ReportEnd event.
  4. Add the following code to the handler.

    Show To write the code in Visual Basic

    Visual Basic.NET code. Paste inside the ReportEnd event. Copy Code
    m_reader.Close()
m_cnn.Close()

    Show To write the code in C#

    C# code. Paste inside the ReportEnd event. Copy Code
    m_reader.Close();
m_cnn.Close();

Show To create a fields collection

  1. Right-click the gray area around the design surface to select the report and select Properties.
  2. In the Properties window that appears, click the Events icon to view the available events for the report.
  3. In the events list, double-click DataInitialize event. This creates an event-handling method for the report's DataInitialize event.
  4. Add code to the handler to add fields to the report's fields collection.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the DataInitialize event. Copy Code
    Fields.Add("CategoryName")
Fields.Add("ProductName")
Fields.Add("UnitsInStock")
Fields.Add("Description")

    Show To write the code in C#

    C# code. Paste inside the DataInitialize event. Copy Code
    Fields.Add("CategoryName");
Fields.Add("ProductName");
Fields.Add("UnitsInStock");
Fields.Add("Description");

Show To populate the fields

  1. Right-click the gray area around the design surface to select the report and select Properties.
  2. In the Properties window that appears, click the Events icon to view the available events for the report.
  3. In the events list, double-click the FetchData event. This creates an event-handling method for the report's FetchData event.
  4. Add the following code to the handler to retrieve information to populate the report fields.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the FetchData event. Copy Code
    Try
    m_reader.Read()
    Me.Fields("CategoryName").Value = m_reader("CategoryName")
    Me.Fields("ProductName").Value = m_reader("ProductName")
    Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
    Me.Fields("Description").Value = m_reader("Description")
    eArgs.EOF = False
Catch ex As Exception
    eArgs.EOF = True
End Try

    Show To write the code in C#

    C# code. Paste inside the FetchData event. Copy Code
    try
{
    m_reader.Read();
    Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
    Fields["ProductName"].Value = m_reader["ProductName"].ToString();
    Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
    Fields["Description"].Value = m_reader["Description"].ToString();
    eArgs.EOF = false;
}
catch
{
    eArgs.EOF = true;
}
Tip: In order to view the added data at run time, add controls to your report and assign their DataField property to the name of the fields you added in code while creating a field collection.
Caution: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

To use the IEnumerable data source

  1. Right-click the design surface and select View Code.
  2. Add the following code inside the class declaration of the report:

    Show To create a data source in Visual Basic

    Visual Basic.NET code. Paste inside the class declaration of the report. Copy Code
    Private datasource1 As IEnumerator(Of String) = Nothing
Dim list As List(Of String)= Nothing
    Visual Basic.NET code. Paste inside the class declaration of the report. Copy Code
    Private Function GetIEnumerableData() As IEnumerable(Of String)
    For i As Integer = 1 To 10
       list.Add(String.Format("TestData_{0}", i.ToString()))
    Next
    Return list
End Function

    Show To create a data source in C#

    C# code. Paste inside the class declaration of the report. Copy Code
    private IEnumerator<string> datasource = null;
    C# code. Paste inside the class declaration of the report. Copy Code
    private IEnumerable<string> GetIEnumerableData()
{
    for (int i = 1; i <= 10; i++)
    {
        yield return string.Format("TestData_{0}", i.ToString());
    }
}
  3. On the design surface, right-click the gray area around the design surface to select the report and select Properties.
  4. In the Properties window that appears, click the Events icon to view the available events for the report.
  5. Double-click the DataInitialize event. This creates an event-handling method for the report's DataInitialize event.
  6. Add the following code to the handler to add fields to the report's Fields collection.

    Show To add fields in Visual Basic

    Visual Basic.NET code. Paste inside the DataInitialize event. Copy Code
    Me.Fields.Add("TestField")
Me.list = New List(Of String)
datasource1 = GetIEnumerableData().GetEnumerator()

    Show To add fields in C#

    C# code. Paste inside the DataInitialize event. Copy Code
    this.Fields.Add("TestField");
datasource = GetIEnumerableData().GetEnumerator();
  7. Repeat steps 3 and 4 to open the events list in the property window.
  8. Double-click the FetchData event. This creates an event-handling method for the report's FetchData event.
  9. Add code to the handler to retrieve information to populate the report fields.

    Show To populate fields in Visual Basic

    Visual Basic.NET code. Paste inside the FetchData event. Copy Code
    If datasource1.MoveNext() Then
          Me.Fields("TestField").Value = datasource1.Current
          eArgs.EOF = False
    Else
          eArgs.EOF = True
    End If

    Show To populate fields in C#

    C# code. Paste inside the FetchData event. Copy Code
    if (datasource.MoveNext())
{
    this.Fields["TestField"].Value = datasource.Current;
    eArgs.EOF = false;
}
else
    eArgs.EOF = true;
Tip: In order to view the added data at run time, add controls to your report and assign their DataField property to the name of the fields you added in code while creating a field collection.

See Also

Modify Data Sources at Run Time

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Grouping in Section Reports

Add Grouping in Section Reports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports > Add Grouping in Section Reports

Glossary Item Box

In a section report, you can set grouping on a field or a field expression. Use the following steps to understand grouping in a section report.

These steps assume that you have already added a Section Report (xml-based) or Section Report (code based) template and connected it to a data source. See Adding an ActiveReport to a Project for further information.

  1. Right-click the design surface of a report and select Insert, then Group Header/Footer. Group Header and Footer sections appear immediately above and below the detail section.
  2. With the GroupHeader section selected, go to the Properties window and set the DataField to a field on which you want to group the data. For example, Country from Customers table in the NWind database.
    Note: You can also set a field expression in the DataField property. For example, =Country + City.
  3. Drag and drop the grouping field onto the GroupHeader section to see the grouping field while previewing the report.
  4. Drag and drop data fields onto the detail section. All the data placed inside the detail section gets grouped according to grouping field.
  5. Preview the report to see the result.

The following image shows a customer list grouped on the Country field.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Tip: In a section report, data is grouped in the order in which it is fetched in the raw form. Therefore, for best results, while setting the SQL query in your report data source, order the data by the grouping field. For example., SELECT * FROM Customers ORDER BY Country

See Also

Concepts
Grouping Data in Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Modify Data Sources at Run Time

Modify Data Sources at Run Time
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports > Modify Data Sources at Run Time

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can modify your data source at run time. Follow the steps below to connect your report to the NWind.mdb sample database at run time.

To find the database path

Note: These steps assume that the data path is defined in the following registry key.
  1. Right-click the design surface, and select View Code to display the code view for the report.
  2. Add the following code to the report to access the sample database path from the registry.

    Show To write the code in Visual Basic

    The following example shows what the code for the function looks like.

    Visual Basic.NET code. Paste below the Imports GrapeCity.ActiveReports statement at the top of the code view. Copy Code
    Imports System
Imports Microsoft.Win32

    This creates a function for getDatabasePath.

    Visual Basic.NET code. Paste inside the getDatabasePath function. Copy Code
    Private Function getDatabasePath() As String
    Dim regKey As RegistryKey
regKey = Registry.LocalMachine
regKey = regKey.CreateSubKey("SOFTWARE\\GrapeCity\\ActiveReports\\v13")
getDatabasePath = CType(regKey.GetValue(""), String)
    End Function

    Show To write the code in C#

    The following example shows what the code for the function looks like.

    C# code. Paste below the using GrapCity.ActiveReports statement at the top of the code view. Copy Code
    using Microsoft.Win32;
using System;

    This creates a function for getDatabasePath.

    C# code. Paste BELOW the getDatabasePath function. Copy Code
    private string getDatabasePath()
    {
RegistryKey regKey = Registry.LocalMachine;
regKey = regKey.CreateSubKey("SOFTWARE\\GrapeCity\\ActiveReports\\v13");
return ((string)(regKey.GetValue("")));
}

To change the data source at run time

  1. Double-click the gray area outside the design surface to create an event-handling method for the ReportStart event.
  2. Add the following code to the handler to change the data source at run time.

    Show To write the code in Visual Basic.NET

    The following example shows what the code for the method looks like.

    Visual Basic.NET code. Paste above the ReportStart event. Copy Code
    Dim conn As System.Data.OleDb.OleDbConnection
Dim reader As System.Data.OleDb.OleDbDataReader
    Visual Basic.NET code. Paste inside the ReportStart event. Copy Code
    Dim dbPath As String = getDatabasePath()
Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + dbPath + "\NWIND.mdb"
conn = New System.Data.OleDb.OleDbConnection(connString)
Dim cmd As New System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn)
conn.Open()
reader = cmd.ExecuteReader()
Me.DataSource = reader

    Show To write the code in C#

    The following example shows what the code for the method looks like.

    C# code. Paste above the ReportStart event. Copy Code
    private static System.Data.OleDb.OleDbConnection conn;
private static System.Data.OleDb.OleDbDataReader reader;
    C# code. Paste inside the ReportStart event. Copy Code
    string dbPath = getDatabasePath();
string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + dbPath + "\\NWIND.mdb";
conn = new System.Data.OleDb.OleDbConnection(connString);
System.Data.OleDb.OleDbCommand cmd = new System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn);
conn.Open();
reader = cmd.ExecuteReader();
this.DataSource = reader;

To close the data connection

  1. Right-click the gray area outside the design surface and select Properties.
  2. In the Properties Window that appears, click the Events button. A list of report events appear.
  3. Select the ReportEnd event and double click to create an event-handling method.
  4. Add the following code to the handler to close the data connection.

    Show To write the code in Visual Basic

    The following example shows what the code for the method looks like.

    Visual Basic.NET code. Paste inside the ReportEnd event. Copy Code
    reader.Close()
conn.Close()

    Show To write the code in C#

    The following example shows what the code for the method looks like.

    C# code. Paste inside the ReportEnd event. Copy Code
    reader.Close();
conn.Close();

See Also

Bind Reports to a Data Source

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Work with Report Controls

Work with Report Controls
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls

Glossary Item Box

See step-by-step instructions on using Section report controls.

In this section

Add Field Expressions
Learn how to add field expressions to a text box data field.
Display Page Numbers and Report Dates
Learn how to quickly add page numbering or report dates to Section reports using the ReportInfo control.
Load a File into a RichTextBox Control
Learn how to save and load an HTML or RTF file in a RichTextBox.
Use Custom Controls on Reports
Learn how to access a third party custom control in ActiveReports.

See Also

Work with Data in Section Reports
Section Report How To
Page Report/RDL Report How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Field Expressions

Add Field Expressions
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Add Field Expressions

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, expressions can be used in the DataField property to specify textbox output in a report, such as date/time, mathematical calculations or conditional values. All field expressions used in the DataField property begin with the equals sign (=).

To use a mathematical expression

Set the DataField property of a textbox control to a mathematical calculation.

Example:

=UnitPrice+5

=Quantity-5

=Quantity*UnitPrice

=UnitPrice/QuantityPerUnit

To use a substring

Set the DataField property of a textbox control to the required substring. While setting up grouping, change the GroupHeader's DataField property to the same substring.

Example:

=ProductName.Substring(0, 1)

To use date/time

Set the DataField property of a textbox control similar to the following expression to display date/time values.

Example:

=System.DateTime.Now.ToString()

To create a conditional value

Set the DataField property of a textbox control to the conditional statement as desired.

Example:

=(UnitsInStock > 0)?"In Stock":"Backorder"

To concatenate fields

Set the DataField property of a textbox control similar to the following expression to display concatenated fields.

Example:

="There are " + UnitsInStock + " units of " + ProductName + " in stock."

=TitleOfCourtesy + " " + FirstName + " " + LastName

Note: ActiveReports automatically handles null values, replacing them with an empty string.

To round a calculation

Set the DataField Property of a textbox control like the following example.

Example:

=(double)System.Math.Round(UnitsInStock/10)

To use modular division

Set the DataField property of a textbox control like the following example to get the remainder (2 in this case).

Example: =22%(5)

To replace a null value

Set the DataField property of a textbox control like the following example to replace null with your own value.

Example:

=(UnitsInStock == System.DBNull.Value) ? "No Units In Stock" : UnitsInStock

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Display Page Numbers and Report Dates

Display Page Numbers and Report Dates
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Display Page Numbers and Report Dates

Glossary Item Box

Show All Show All
Hide All Hide All

With the ReportInfo control available in a section report, you can display page numbers and report dates and times by selecting a value in the FormatString property. This property provides the following pre-defined options for page numbering and date and time formatting.

Predefined Options and their Description

Numbering Format | Description
Page {PageNumber} of {PageCount} on {RunDateTime} | Display the page numbers along with Date and Time in the following format : Page 1 of 100 on 1/31/2012 2:45:50 PM
Page {PageNumber} of {PageCount} | Display the only the page numbers in the following format : Page 1 of 100
{RunDateTime:} | Display the Date and Time in the following format : 1/31/2012 2:45:50 PM
{RunDateTime: M/d} | Display the Date in the following format : 1/31
{RunDateTime: M/d/yy} | Display the Date in the following format : 1/31/12
{RunDateTime: M/d/yyyy} | Display the Date in the following format : 1/31/2012
{RunDateTime: MM/dd/yy} | Display the Date in the following format : 01/31/12
{RunDateTime: MM/dd/yyyy} | Display the Date in the following format : 01/31/2012
{RunDateTime: d-MMM} | Display the Date in the following format : 31-Jan
{RunDateTime: d-MMM-yy} | Display the Date in the following format : 31-Jan-12
{RunDateTime: d-MMM-yyyy} | Display the Date in the following format : 31-Jan-2012
{RunDateTime: dd-MMM-yy} | Display the Date in the following format : 31-Jan-12
{RunDateTime: dd-MMM-yyyy} | Display the Date in the following format : 31-Jan-2012
{RunDateTime: MMM-yy} | Display the Date in the following format : Jan-12
{RunDateTime: MMM-yyyy} | Display the Date in the following format : Jan-2012
{RunDateTime: MMMM-yy} | Display the Date in the following format : January-12
{RunDateTime: MMMM-yyyy} | Display the Date in the following format : January-2012
{RunDateTime: MMMM d,yyyy} | Display the Date in the following format : January 31, 2012
{RunDateTime: M/d/yy h:mm tt} | Display the Date and Time in the following format : 1/31/12 2:45 PM
{RunDateTime: M/d/yyyy h:mm tt} | Display the Date and Time in the following format : 1/31/2012 2:45 PM
{RunDateTime: M/d/yy h:mm} | Display the Date and Time in the following format : 1/31/12 2:45
{RunDateTime: M/d/yyyy h:mm} | Display the Date and Time in the following format : 1/31/2012 2:45

Page numbering can also be set to a group level using the SummaryGroup and SummaryRunning properties.

These steps assume that you have already added a Section Report to a project in Visual Studio. See Adding an ActiveReport to a Project for more information.

To display page numbers and report dates on a report

  1. From the ActiveReports 13 Section Report tab in the toolbox, drag the ReportInfo control to the desired location on the design surface.
  2. With the ReportInfo control selected in the Properties Window, drop down the FormatString property.
  3. Select the pre-defined format that best suits your needs.
    Tip: You can customize the pre-defined formats in the Properties Window. For example, if you change the FormatString property to Page {PageNumber} / {PageCount}, it shows the first page number as Page 1/1. For more information on creating formatting strings, see the Date, Time, and Number Formatting topic.

To display page numbers and page count at the group level

  1. From the ActiveReports 13 Section Report tab in the toolbox, drag the ReportInfo control to the GroupHeader or GroupFooter section of the report and set the FormatString property as above.
  2. With the ReportInfo control still selected in the Properties Window, drop down the SummaryGroup property and select the group for which you want to display a page count.
  3. Drop down the SummaryRunning property and select Group.

See Also

Add Page Numbering
Common Values

Concepts
Report Info

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Load a File into a RichTextBox Control

Load a File into a RichTextBox Control
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Load a File into a RichTextBox Control

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can load an RTF or an HTML file into the RichTextBox control both at design time and at run time . Following is a step-by-step process that helps you load these files into the RichTextBox control.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project and have placed a RichTextBox control inside its detail section. See Adding an ActiveReport to a Project for more information.

Caution: Do not attempt to load a file into a RichTextBox in a section that repeats. After the first iteration of the section, the RTF or HTML file is already in use by that first iteration and returns "file in use" errors when that section is processed again.

To write an RTF file to load into a RichTextBox control

  1. Open wordpad, and paste the following formatted text into it.

    Paste the following section into an RTF File.

    Customer List by Country

    Argentina

    • Rancho grande
    • Océano Atlántico Ltda.
    • Cactus Comidas para llevar

    Austria

    • Piccolo und mehr
    • Ernst Handel

    Belgium

    • Suprêmes délices
    • Maison Dewey

    Brazil

    • Familia Arquibaldo
    • Wellington Improtadora
    • Que Delícia
    • Tradição Hipermercados
    • Ricardo Adocicados
    • Hanari Carnes
    • Queen Cozinha
    • Comércio Mineiro
    • Gourmet Lanchonetes
  2. Save the file as sample.rtf in the debug directory inside the bin folder of your project.
Note: The RichTextBox control is limited in its support for advanced RTF features such as the ones supported by Microsoft Word. In general, the features supported by WordPad are supported in this control.

To load an RTF file into the RichTextBox control at design time

  1. On the report design surface, add a RichTextBox control.
  2. With the RichTextBox control selected, at the botton of the Properties Window, click the Load File command. See Properties Window for a description of commands.
  3. In the Open dialog that appears, browse to an *.RTF file (For example, sample.rtf) and click the Open button to load the file in the RichTextBox control.

To load an RTF file into the RichTextBox control at run time

Note: The RichTextBox control has limited support for advanced RTF features such as the ones supported by Microsoft Word. Therefore, use a WordPad for obtaining best results.

These steps assume that the RTF file (for example, sample.rtf) to load has been saved in the bin/debug directory of your project.

  1. Right-click the report and select View Code to open the code view.
  2. Add an Imports (Visual Basic.NET) or using (C#) statement at the top of the code view for the GrapeCity.ActiveReports.SectionReportModel namespace.
  3. In the design view, double-click the detail section of the report to create an event-handling method for the Detail Format event.
  4. Add the following code to the handler to load the RTF file into the RichTextBox control.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail1_Format event. Copy Code
    Dim streamRTF As New System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\sample.rtf", System.IO.FileMode.Open)
    Me.RichTextBox1.Load(streamRTF, RichTextType.Rtf)

    Show To write the code in C#

    C# code. Paste INSIDE the detail_Format event. Copy Code

    System.IO.FileStream streamRTF = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.rtf", System.IO.FileMode.Open);
    this.richTextBox1.Load(streamRTF, RichTextType.Rtf);
    Note: The Application.Startup path code does not work in preview mode. You must run the project in order to see the file load.

To write an HTML file to load into a RichTextBox control

  1. Open a Notepad, and paste the following HTML code into it.
    HTML code. Paste in a NotePad file. Copy Code
    <html>
<body>
<center><h1>Customer List by Country</h1></center>
<h1>Argentina</h1>
<ul>
<li>Rancho grande
<li>Océano Atlántico Ltda.
<li>Cactus Comidas para llevar
</ul>
<h1>Austria</h1>
<ul>
<li>Piccolo und mehr
<li>Ernst Handel
</ul>
<h1>Belgium</h1>
<ul>
<li>Suprêmes délices
<li>Maison Dewey
</ul>
<h1>Brazil</h1>
<ul>
<li>Familia Arquibaldo
<li>Wellington Improtadora
<li>Que Delícia
<li>Tradição Hipermercados
<li>Ricardo Adocicados
<li>Hanari Carnes
<li>Queen Cozinha
<li>Comércio Mineiro
<li>Gourmet Lanchonetes
</ul>
</body>
</html>
  2. Save the file as sample.html.

To load an HTML file into the RichTextBox control at design time

  1. On the report design surface, add a RichTextBox control.
  2. With the RichTextBox control selected, at the bottom of the Properties Window, click the Load File command. See Properties Window for a description of commands.
  3. In the Open dialog that appears, browse to an *.html file (For example, sample.html) and click the Open button to load the file in the RichTextBox control.

To load an HTML file into a RichTextBox control at run time

These steps assume that the HTML file (for example, sample.html) to load has been saved in the bin/debug directory of your project.

  1. Right-click the report and select View Code to open the code view.
  2. Add an Imports (Visual Basic.NET) or using (C#) statement at the top of the code view for the GrapeCity.ActiveReports.SectionReportModel namespace.
  3. In the design view, double-click the detail section of the report to create an event-handling method for the Detail Format event.
  4. Add code to the handler to load the HTML file into the RichText control.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail1_Format event. Copy Code
    Dim streamHTML As New System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\sample.HTML", System.IO.FileMode.Open)
    Me.RichTextBox1.Load(streamHTML, RichTextType.Html)

    Show To write the code in C#

    C# code. Paste INSIDE the detail_Format event. Copy Code
    System.IO.FileStream streamHTML = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.html", System.IO.FileMode.Open);
    this.richTextBox1.Load(streamHTML, RichTextType.Html);
    Note: The Application.Startup path code does not work in preview mode. You must run the project in order to see the file load.

See Also

Concepts
RichTextBox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use Custom Controls on Reports

Use Custom Controls on Reports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Use Custom Controls on Reports

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, ActiveReports allows you to drop a third party control onto the report design surface where it is recognized as a custom control. You can access its properties using type casting.

In the following steps, we use hidden textbox controls to populate a Visual Studio TreeView control. These steps assume that you have already added a Section Report (code-based) template in a Visual Studio project. See Adding an ActiveReport to a Project for more information.

To add the TreeView control to a report

  1. From the Visual Studio toolbox Common Controls tab, drag and drop a TreeView control onto the detail section of a report.
  2. Notice that in the Properties window, the control is called CustomControl1.

To add data and hidden TextBox controls to the report

  1. Connect the report to the sample Nwind.mdb. The following steps use the Orders table from the NWind database. By default, in ActiveReports, the Nwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Nwind.mdb.
  2. From the Report Explorer, drag and drop the following fields onto the detail section of the report:
    • ShipCountry
    • ShipCity
    • CustomerID
    • EmployeeID
  3. On the design surface, select all four TextBox controls, and in the Properties window, change their Visible property to False.

To create a function to add nodes to the TreeView control

  1. Right-click the design surface and select View Code to see the code view for the report.
  2. Add the following code inside the report class to add a function to the report for adding nodes to the TreeView control.

    The following examples show what the code for the function looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the report class. Copy Code
    Private Function AddNodeToTreeView(ByVal colNodes As TreeNodeCollection, ByVal sText As String) As TreeNode
   Dim objTreeNode As TreeNode
   objTreeNode = New TreeNode(sText)
   colNodes.Add(objTreeNode)
   Return objTreeNode
End Function

    Show To write the code in C#

    C# code. Paste INSIDE the report class. Copy Code
    private TreeNode AddNodeToTreeView(TreeNodeCollection colNodes, string sText)
{
    TreeNode objTreeNode;
    objTreeNode = new TreeNode(sText);
    colNodes.Add(objTreeNode);
    return objTreeNode;
}

To access the TreeView control properties in code and assign data

  1. On the report design surface, double-click the detail section to create an event-handling method for the Detail_Format event.
  2. Add the following code to the handler to access the TreeView properties and assign data from the hidden TextBox controls.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code

    'Type cast the custom control as a TreeView
    Dim TreeView1 As New TreeView
    TreeView1 = CType(Me.CustomControl1.Control, TreeView)

    'Create a tree node
    Dim objCountryTreeNode As TreeNode
    'Assign the text from a hidden textbox to the node
    objCountryTreeNode = AddNodeToTreeView(TreeView1.Nodes, Me.txtShipCountry1.Text)
    'Add a second-level node
    AddNodeToTreeView(objCountryTreeNode.Nodes, Me.txtShipCity1.Text)
    'Expand the top-level node so the second-level node is in view
    objCountryTreeNode.Expand()

    'Create a second top-level node
    Dim objCustomerTreeNode As TreeNode
    objCustomerTreeNode = AddNodeToTreeView(TreeView1.Nodes, Me.txtCustomerID1.Text)
    AddNodeToTreeView(objCustomerTreeNode.Nodes, Me.txtEmployeeID1.Text)
    objCustomerTreeNode.Expand()

    Show To write the code in C#

    C# code. Paste INSIDE the Detail Format event. Copy Code
    //Type cast the custom control as a TreeView
    TreeView TreeView1 = new TreeView();
    TreeView1 = (TreeView)this.customControl1.Control;
//Create a tree node
    TreeNode objCountryTreeNode;
    //Assign the text from a hidden textbox to the node
    objCountryTreeNode = AddNodeToTreeView(TreeView1.Nodes, this.txtShipCountry1.Text);
    //Add a second-level node
    AddNodeToTreeView(objCountryTreeNode.Nodes, this.txtShipCity1.Text);
    //Expand the top-level node so the second-level node is in view
    objCountryTreeNode.Expand();
//Create a second top-level node
    TreeNode objCustomerTreeNode;
    objCustomerTreeNode = AddNodeToTreeView(TreeView1.Nodes, this.txtCustomerID1.Text);
    AddNodeToTreeView(objCustomerTreeNode.Nodes, this.txtEmployeeID1.Text);
    objCustomerTreeNode.Expand();

To load the report in the Viewer, change the Form Load event

Show To write code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event Copy Code
Dim ar = New SectionReport1()
ar.Run(False)
viewer1.LoadDocument(ar.Document)

Show To write code in C#

C# code. Paste INSIDE the Form Load event Copy Code
var ar = new SectionReport1();
ar.Run(false);
viewer1.LoadDocument(ar.Document);

See Also

Bind Reports to a Data Source

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Common Section Reports

Create Common Section Reports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports

Glossary Item Box

See step-by-step instructions for creating commonly used reports with Section Layout.

In this section

Create Top NReports
Learn to display top 10 data on a report.
Create a Summary Report
Learn to display summary data on a report.
Create Green Bar Reports
Learn to alternate background colors on the detail section.

See Also

Section Report How To

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Top NReports

Create Top NReports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports > Create Top NReports

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, in order to display only the top N number of details on a report, you can manipulate the data pulled by your SQL query.

To set an access data source to pull Top N data

  1. On the design surface, click the DataSource Icon in the detail section band to open the Report Data Source dialog.
  2. On the OLE DB tab of the Report Data Source dialog, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button.
  4. Click the ellipsis (...) button to browse to the NWind database. Click Open once you have selected the appropriate access path.
    Note: The sample NWind.mdb data file is located in: [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWind.mdb
  5. Click OK to close the window and fill in the Connection String field.
  6. Back in Report Data Source dialog, paste the following SQL query in the Query field to fetch Top 10 records from the database.
    SQL Query Copy Code
    SELECT TOP 10 Customers.CompanyName, Sum([UnitPrice]*[Quantity])
AS Sales
FROM (Customers INNER JOIN Orders ON Customers.CustomerID = Orders.CustomerID)
INNER JOIN [Order Details] ON Orders.OrderID = [Order Details].OrderID
GROUP BY Customers.CompanyName
ORDER BY Sum([UnitPrice]*[Quantity])
DESC
  7. Click OK to return to the report design surface.

To add controls to display the Top N data

  1. In the Report Explorer, expand the Fields node, then the Bound node.
  2. Drag and drop the following fields onto the detail section and set the properties of each textbox as indicated.
    Field | Text | Location | Miscellaneous
    CompanyName | Company Name | 0.5, 0
    Sales | Sales | 5, 0 | OutputFormat = Currency
  3. Go to Preview tab, to view the result.

A report with the Top 10 companies' data similar to the following will appear in the preview.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Create Common Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create a Summary Report

Create a Summary Report
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports > Create a Summary Report

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can display totals and subtotals by modifying the summary fields of a TextBox control. Use the following steps to learn how to add totals and subtotals in a report.

These steps assume that you have already added a Section Report template in a Visual Studio project and connected it to a data source. See Adding an ActiveReport to a Project and Bind Reports to a Data Source for further information.

Note: These steps use the Products table from the NWind database. The sample NWind.mdb database file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

To calculate and display subtotals in a report

  1. Right-click the design surface and select Insert, then Group Header/Footer to add group header and group footer sections to the layout.
  2. With the GroupHeader section selected in the Properties Window, set its DataField property to CategoryID. This groups the data on the report according to the set field.
  3. From the Report Explorer, drag and drop the following fields onto the corresponding sections of the report.

    • Field Name = CategoryID
      Section = GroupHeader

    • Field Name = ProductName
      Section = Detail

    • Field Name = UnitsInStock
      Section = Detail

    • Field Name = UnitsInStock
      Section = GroupFooter

  4. With the UnitsInStock field in the GroupFooter selected, go to the Properties Window and set the following:
    • SummaryFunc: Sum
    • SummaryType: Sub Total
    • SummaryRunning: Group
    • SummaryGroup: GroupHeader1
  5. Go to the Preview tab to view the report and see the Sub Total appear below each group of data similar to the following image.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To calculate and display grand total in a report

These steps are a continuation of the procedure above. The report generated at the end of this procedure contains totals and subtotals.

  1. Right-click the design surface and select Insert, then Report Header/Footer to add report header and footer sections to the layout.
  2. From Report Explorer, drag and drop the UnitsInStock field onto the ReportFooter section go to the Properties Window and set the following:
    • SummaryFunc: Sum
    • SummaryType: GrandTotal
    • SummaryRunning: All
  3. Go to the Preview tab to view the report and see the Grand Total appear on the last page of the report.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Create Common Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Green Bar Reports

Create Green Bar Reports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports > Create Green Bar Reports

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, green bar printouts can be created by setting alternate shades or background color in the report's detail section in the Format event. The following steps demonstrate how to create a Green Bar report.

  1. On the design surface, double-click the detail section of the report to create an event handling method for the Detail Format event.
  2. Add the following code to the handler to alternate background colors.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste JUST ABOVE the Detail Format event. Copy Code
    Dim color As Boolean
    Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code
    If color = True Then
    Me.Detail1.BackColor = System.Drawing.Color.DarkSeaGreen
    color = False
Else
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    color = True
End If

    Show To write the code in C#

    C# code. Paste JUST ABOVE the Detail Format event. Copy Code
    bool color;
    C# code. Paste INSIDE the Detail Format event. Copy Code
    if(color)
{
    this.detail.BackColor = System.Drawing.Color.DarkSeaGreen;
    color = false;
}
else
{
    this.detail.BackColor = System.Drawing.Color.Transparent;
    color = true;
}
  3. Add controls like TextBox to the report design surface and preview the report.

The following image shows a Green Bar report alternating between Transparent and Dark Sea Green backgrounds:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

See Also

Create Common Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Inherit a Report Template

Inherit a Report Template
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Inherit a Report Template

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can create a base report as a template from which other reports can inherit. This behavior is similar to creating a master report and is available in a Section Report (code-based) layout.

Inheriting reports is useful when multiple reports share common features, such as identical page headers and footers. Instead of recreating the look every time, create template headers and footers once and use inheritance to apply them to other reports.

Use the following instructions to create a base report and inherit it in other reports.

Caution: Base reports and the reports that inherit from them cannot contain controls with duplicate names. You can compile and run your project with duplicate control names, but you cannot save the layout until you change the duplicate names.

To create a base report

  1. In a Visual Studio project, add a Section Report (code-based) and name it rptLetterhead. See Adding an ActiveReport to a Project for more information.
  2. In the report template that appears, add the following controls from the Visual Studio toolbox to the indicated section of rptLetterhead and set the properties.
    Control Section Location Size Miscellaneous
    Picture PageHeader 0, 0 in 3, 0.65 in Image = (click ellipsis and navigate to the location of your image file)
    PictureAlignment = TopLeft
    Label PageHeader 1.16, 0.65 in 1.8, 0.25 in Text = Inheritance
    Font = Arial, 15pt, style=Bold
    Label PageFooter 0, 0 in 6.5, 0.19 in Text = http://www.grapecity.com
    HyperLink = http://www.grapecity.com
    Font/Bold = True
    Alignment = Center
  3. Right-click the gray area below the design surface and choose properties, to open the Properties window.
  4. In the Properties window, set the MasterReport property to True. Setting the MasterReport property to True locks the Detail section.
    Caution: Do not set the MasterReport property to True until you have finished designing or making changes to the report. Setting this property to True triggers major changes in the designer file of the report.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

You can use the Page Header and Page Footer sections to design the base report. When you create reports that inherit the layout from this base report, only the detail section is available for editing.

To inherit layout from a base report

These steps assume that you have already added another Section Report (code-based) template. This report functions like a content report where you can create the layout of the Detail section.

  1. In a Visual Studio project, add a Section Report (code-based) and name it rptLetter.
  2. In the Solution Explorer, right-click the new report and select the View Code option to open the code behind of the report.
  3. In the code view, modify the inheritance statement as shown below. The content report inherits from the base report instead of GrapeCity.ActiveReports.SectionReport.
    Caution: The existing report layout in the content report is lost once you inherit the base report. Even if you change it back to GrapeCity.ActiveReports.SectionReport, the original layout in content report will not be retrieved.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Replace YourContentReport, YourProjectName and YourMasterReportName with relevant names. Copy Code
    Partial Public Class rptLetter Inherits YourProjectName.rptLetterhead

    Show To write the code in C#

    C# code. Replace YourContentReport, YourProjectName and YourMasterReportName with relevant names. Copy Code
    public partial class rptLetter : YourProjectName.rptLetterhead
  4. Close the reports and from the Build menu on the Visual Studio menu bar, select Rebuild. When you reopen the report, the inherited sections and controls are disabled.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

    Note: To apply further changes from the base report to the content report, you might have to rebuild the project again.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Change Ruler Measurements

Change Ruler Measurements
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Change Ruler Measurements

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can change ruler measurements from inches to centimeters and centimeters to inches. Use the following instructions to modify ruler measurements at design- time and run-time.

To change ruler measurements at design-time

At design time, you can change the ruler measurements from the Report Settings Dialog.

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Global Settings.
  3. From the Ruler Units dropdown select Centimeters or Inches.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To call a measurement conversion at run-time

Call the CmToInch method or InchToCm method at run-time to change measurements. For example, you can use the following code when you are working in centimeters and need to convert a Label's position measurements from centimeters to inches at run-time.

  1. On the design surface select the section containing a control like a Label.
  2. In the Properties Window, click the Events button to get a list of report events.
  3. Select the Format event and double-click to create an event-handling method.
  4. Add code like the following to the handler to set the size of the control using centimeters to inches.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the Format event. Copy Code
    Me.Label1.Left = SectionReport1.CmToInch(2)
    Me.Label1.Top = SectionReport1.CmToInch(2)

    Show To write the code in C#

    C# code. Paste inside the Format event. Copy Code
    this.label1.Left = SectionReport1.CmToInch(2);
    this.label1.Top = SectionReport1.CmToInch(2);

See Also

Concepts
Rulers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Print Multiple Copies, Duplex and Landscape

Print Multiple Copies, Duplex and Landscape
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Print Multiple Copies, Duplex and Landscape

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can modify various printer settings or print multiple copies of a report at design time and at run time.

Printer Settings

At design time, you can set up duplex printing, page orientation, collation, and page size in the Printer Settings tab of the Report Settings Dialog.

To set up duplex printing in Printer Settings

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Printer Settings.
  3. On the Printer Settings page, next to Duplex, select one of the following options:
    • Printer Default: The report uses the default settings of the selected printer.
    • Simplex: Turns off duplex printing.
    • Horizontal: Prints horizontally on both sides of the paper.
    • Vertical: Prints vertically on both sides of the paper.
  4. Click OK to return to the report.

To use code to set up duplex printing

  1. Double-click the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to set up duplexing.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.PageSettings.Duplex = System.Drawing.Printing.Duplex.Horizontal

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Horizontal;

To set page orientation on the Printer Settings page

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Printer Settings.
  3. On the Printer Settings page, in the Orientation section, select either Default, Portrait or Landscape.
  4. Click OK to return to the report.

To use code to change page orientation

  1. Double-click the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to change the page orientation of the report for printing.
    Note: Page orientation can only be modified before the report runs. Otherwise, changes made to the page orientation are not used during printing.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;

Multiple Copies

You can print multiple copies using the Print dialog in the Preview tab or in the Viewer, or you can use code to set the number of copies to print.

To set multiple copies in the print dialog

  1. With a report displayed in the viewer or in the preview tab, click Print.
  2. In the Print dialog that appears, next to Number of copies, set the number of copies that you want to print.

To use code to set multiple copies

  1. Double-click in the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to set multiple copies of the report for printing.

    The following example shows what the code for the method looks like for printing five copies.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.Document.Printer.PrinterSettings.Copies = 5
    Visual Basic.NET code. Paste INSIDE the ReportEnd event. Copy Code
    Me.Document.Printer.Print()

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.Document.Printer.PrinterSettings.Copies = 5;
    C# code. Paste INSIDE the ReportEnd event. Copy Code
    this.Document.Printer.Print();

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Conditionally Show or Hide Details

Conditionally Show or Hide Details
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Conditionally Show or Hide Details

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can use conditions in the Format event to control the display of report's detail section at run time.

These steps assume that you have already added a Section Report (code-based) template in a Visual Studio project and connected it to a data source. See Adding an ActiveReport to a Project and Bind Reports to a Data Source for further information.

Note: These steps use the Products table from the NWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWind.mdb.
  1. From the Report Explorer, drag and drop the following fields onto the detail section of the report and set their properties in the Properties Window.
    Field Name Properties
    ProductName Location: 0, 0.104 in
    Size: 2.667, 0.2 in
    Discontinued Location: 2.667, 0.104 in
    Size: 2.021, 0.2 in
    ReorderLevel Location: 4.688, 0.104 in
    Size: 1.812, 0.2 in

  2. Double-click the detail section of the report to create an event-handling method for the Format event.
  3. Add the following code to the handler to hide the details of a product which is discontinued.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail_Format event. Copy Code
    If Me.txtReorderLevel1.Value = 0 And Me.txtDiscontinued1.Value = False Then
          Me.Detail1.Visible = True
          Me.txtReorderLevel1.Text = "Need to Reorder"
          Me.txtReorderLevel1.ForeColor = System.Drawing.Color.DarkRed
    Else
          Me.Detail1.Visible = False
    End If

    Show To write the code in C#

    C# code. Paste INSIDE the detail_Format event. Copy Code
    if (int.Parse(txtReorderLevel1.Value.ToString()) == 0 && txtDiscontinued1.Text == "False")
    {
    this.detail1.Visible = true;
    this.txtReorderLevel1.Text = "Need to Reorder";
    this.txtReorderLevel1.ForeColor = System.Drawing.Color.DarkRed;
    }
    else
    {
    this.detail1.Visible = false;
    }
  4. In Form1 of the Visual Studio project, add a Viewer control and load the report you created above in it. See Windows Forms Viewer for further details.
  5. Press F5 to debug and see a report with discontinued products hidden from view.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

See Also

Bind Reports to a Data Source

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Parameters in a Section Report

Add Parameters in a Section Report
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Add Parameters in a Section Report

Glossary Item Box

Show All Show All
Hide All Hide All

There are several ways to add parameters in a section report. The following sections provide a step by step overview of adding parameters in a report.

To add parameters using the Report Explorer

  1. In the Report Explorer, right-click the Parameters node and select Add. This adds a parameter (Parameter1) as a child to the Parameters node.

  2. Select the added parameter to open the Properties Window and set values in the following properties:
    • Name: This is the unique name of the parameter which appears as Parameter1 by default. It corresponds to the Key property in parameters entered via code.
    • Default Value: Sets/returns the value displayed when the user is prompted to enter a value at run time.
    • Prompt: Sets/returns a string displayed when a user is prompted for the value at run time.
    • PromptUser: Boolean value that indicates whether to prompt the user for a value or not. This is set True to use parameters at run time.
    • Type: This value which defaults to String defines the type of data the parameter represents. You can also set data type to Date or Boolean.
  3. Pass the parameter to a field on the report, or access it programmatically as described in the run time procedure below.

To add parameters directly using a SQL query

When you add SQL parameters to a report, ActiveReports displays an Enter Report Parameters dialog where the user can enter the values to fetch from the database.

  1. In the detail section band, click the DataSource icon to view the Report Data Source dialog.
  2. Connect the report to a data source, for example, OleDb data source. See Bind Reports to a Data Source for further details.
  3. In the Query field, enter a SQL query like the one below, which contains the parameter syntax to prompt for parameter values at run time.
    SELECT * FROM Products
    INNER JOIN (Orders INNER JOIN [Order Details] ON Orders.OrderID= [Order Details].OrderID)
    ON Products.ProductID = [Order Details].ProductID
    WHERE Products.SupplierID = <%SupplierID|Enter Supplier ID|7%>
    AND OrderDate >= #<%OrderDate|Order date from|11/1/1994|D%>#
    AND Discontinued = <%Discontinued|Is this checked?|true|B%>
  4. Click OK to save the data source and return to the report design surface.

    The SQL query above causes ActiveReports to display the following dialog to the user. The user can accept these or input other values to select report data.

To add parameters at run time

You can add, edit, and delete parameters at run time. The following code demonstrates how to add a parameter and display its value in a Textbox control.

  1. Double-click in the gray area below the report to create an event-handling method for the ReportStart event.
  2. Add code to the handler to set parameters at run time.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste at beginning of code view.　 Copy Code

    Imports GrapeCity.ActiveReports.SectionReportModel
    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code

    Dim myParam1 As New Parameter()
    myParam1.Key = "myParam1"
    myParam1.Type = Parameter.DataType.String

    'Set to False if you do not want input from user.
    myParam1.PromptUser = True
    myParam1.Prompt = "Enter Data:"
    myParam1.DefaultValue = "Default Value"
    Me.Parameters.Add(myParam1);

    'Set to True to display parameter dialog box when report is run.
    Me.ShowParameterUI = True

    Show To write the code in C#

    C# code. Paste at beginning of code view. Copy Code

    using GrapeCity.ActiveReports.SectionReportModel;
    C# code. Paste INSIDE the ReportStart event. Copy Code

    Parameter myParam1 = new Parameter();
    myParam1.Key = "myParam1";
    myParam1.Type = Parameter.DataType.String;

    //Set to false if you do not want input from user.
    myParam1.PromptUser = true;
    myParam1.Prompt = "Enter Data:";
    myParam1.DefaultValue = "Default Value";
    this.Parameters.Add(myParam1);

    //Set to true to display parameter dialog box when report is run.
    this.ShowParameterUI = true;
  3. In the design view, click the gray area below the report to select it and open the Properties Window.
  4. Click the events icon in the Properties Window to display available events for the report.
  5. Double-click FetchData. This creates an event-handling method for the report's FetchData event.
  6. Add code to the handler to pass the parameter at run time.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the FetchData event. Copy Code
    'Set textbox text equal to the value of the parameter.
    Me.txtParam1.Text = Me.Parameters("myParam1").Value

    Show To write the code in C#

    C# code. Paste INSIDE the FetchData event. Copy Code
    //Set textbox text equal to the value of the parameter.
    this.txtParam1.Text = this.Parameters["myParam1"].Value;
    The run-time implementation above causes ActiveReports to display the following dialog to the user. The user can enter any text in this prompt dialog and display it on the report.

To View a Parameterized Report

The parameter prompt dialog for a parameterized report depending on how you view the report.

To get a Parameter Dialog box

  1. In the Visual Studio project, add a Viewer control to the Form.
  2. Double-click the Form title bar to create a Form_Load event.
  3. Add the following code to the handler to view the report in the Viewer.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim rpt As New SectionReport1
    Viewer1.Document = rpt.Document
    rpt.Run()

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    SectionReport1 rpt = new SectionReport1();
    viewer1.Document = rpt.Document;
    rpt.Run();

To get a Parameter Panel in the Viewer sidebar

  1. In the Visual Studio project, add a Viewer control to the Form.
  2. Double-click the Form title bar to create a Form_Load event.
  3. Add the following code to the handler to view the report in the Viewer.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim rpt As New SectionReport1
    Me.Viewer1.LoadDocument(rpt)

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    SectionReport1 rpt = new SectionReport1();
    viewer1.LoadDocument(rpt);

See Also

Concepts
Parameters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add and Save Annotations

Add and Save Annotations
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Add and Save Annotations

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can save a report containing annotations along with the report data into an RDF file. You can also add annotations at run time. The following steps demonstrate how to accomplish these tasks in code.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project. See Adding an ActiveReport to a Project for more information.

To save annotations

The following example shows how to add a Save Annotated Report button to the viewer and save a report with annotations in RDF.

  1. From the Visual Studio toolbox, drag a Button control onto the viewer.
  2. Set the Text property of the button to Save Annotated Report.
  3. Double-click the button. This creates an event-handling method for the button Click event.
  4. Add code to the click handler to save the document to an RDF file. See Save and Load RDF Report Files for more information on loading the saved RDF file into the viewer.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the button Click event. Copy Code
    Me.Viewer1.Document.Save("C:\UserAnnotations.rdf")

    Show To write the code in C#

    C# code. Paste INSIDE the button Click event. Copy Code
    this.viewer1.Document.Save("C:\\UserAnnotations.rdf");

To add annotations in code

The following example shows how to add annotations at run time and save the report data and annotations to an RDF file.

  1. Double-click the title bar of the Form in which you host the viewer. This creates an event-handling method for the Form_Load event.
  2. Add code to the handler to run the report, add annotations, display the report in the viewer, and save it into an RDF file.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste ABOVE the class. Copy Code
    Imports GrapeCity.ActiveReports.Document.Section.Annotations
    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
       Dim rpt As New SectionReport1
   'Run the report first.
   rpt.Run()

   'Assign the viewer.
   Me.Viewer1.Document = rpt.Document

   'Create an annotation and assign property values.
   Dim circle As New AnnotationCircle
   circle.Color = System.Drawing.Color.GreenYellow
   circle.Border.Color = System.Drawing.Color.Chartreuse

   'Add the annotation.
   circle.Attach(1,1) 'screen location
   Me.Viewer1.Document.Pages(0).Annotations.Add(circle)

   'Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25
   circle.Width = 0.50

   'Save annotations with the report in an RDF file.
   rpt.Document.Save("C:\AnnotatedReport.rdf")

    Show To write the code in C#

    C# code. Paste ABOVE the class. Copy Code
    using GrapeCity.ActiveReports.Document.Section.Annotations;
    C# code. Paste INSIDE the Form Load event. Copy Code
       SectionReport1 rpt = new SectionReport1();
   //Run the report first.
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values.
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation.
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations with the report in an RDF file.
   rpt.Document.Save("C:\\AnnotatedReport.rdf");

See Also

Concepts
Annotations

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Bookmarks

Add Bookmarks
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Add Bookmarks

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can display bookmarks and nested bookmarks in the viewer's table of contents for fields, groups, and subreports. You can also add special bookmarks at run time.

To set up basic bookmarks

  1. From the Visual Studio toolbox, drag and drop a TextBox control onto the detail section.
  2. Double-click the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  3. Add code to the handler to set up bookmarks.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code
    Me.Detail1.AddBookmark(textBox1.text)

    Show To write the code in C#

    C# code. Paste INSIDE the Detail Format event. Copy Code
    Detail.AddBookmark(TextBox1.Text);

To set up leveled or nested bookmarks

  1. From the Report Explorer, drag and drop CustomerID and ContactName onto the detail section.
  2. Double-click the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  3. Add code to the handler to set up bookmarks.

    The following example shows what the code to set up leveled or nested Bookmarks looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code
    Me.Detail1.AddBookmark(txtCustomerID.Text + "\" + txtContactName.Text)

    Show To write the code in C#

    C# code. Paste INSIDE the Detail Format event. Copy Code
    detail.AddBookmark(txtCustomerID.Text + "\\" + txtContactName.Text);

To nest grandchild bookmarks and use bookmarks in grouping

  1. From the Report Explorer, drag and drop CustomerID, ContactName and City fields onto the detail section.
  2. Double-click in the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  3. Add code to the handler to set up a bookmark for each ContactName and nest ContactName bookmarks within each CustomerID, and CustomerID bookmarks in each City.

    The following example shows what the code for the detail section looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail_Format event. Copy Code
    Me.Detail1.AddBookmark(txtCity.Text + "\" + txtCustomerID.Text + "\" + txtContactName.Text)

    Show To write the code in C#

    C# code. Paste INSIDE the Detail_Format event. Copy Code
    this.detail.AddBookmark(txtCity.Text + "\\" + txtCustomerID.Text + "\\" + txtContactName.Text);
  4. Add a GroupHeader section to the layout and set its DataField property to City.
  5. Double-click in the Group Header section of the report. This creates an event-handling method for the report's Group Header Format event.
  6. Add code to the handler to set up a bookmark for each instance of the City group.

    The following example shows what the code for the group header looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Group Header Format event. Copy Code
    Me.GroupHeader1.AddBookmark(txtCity.Text)

    Show To write the code in C#

    C# code. Paste INSIDE the Group Header Format event. Copy Code
    this.groupHeader1.AddBookmark(txtCity.Text);

To combine parent report and subreport bookmarks

  1. From the Report Explorer, drag and drop the CustomerID field onto the detail section of the Parent report.
  2. Double-click the Detail section to create an event-handling method for the report's Detail Format event.
  3. Add code to the handler to create a bookmark for each instance of the CustomerID field in the main report.

    The following example shows what the code for the method looks like for the main report.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail Format event of the main report. Copy Code
    Me.Detail1.AddBookmark(txtCustomerID.Text)

    Show To write the code in C#

    C# code. Paste INSIDE the Detail Format event of the main report. Copy Code
    detail1.AddBookmark(txtCustomerID.Text);
  4. From the Report Explorer, drag and drop the ContactName field onto the detail section of the Subreport.
  5. Double-click in the Detail section to create an event-handling method for the report's Detail Format event.
  6. Add code to the handler to create a bookmark for each instance of the ContactName field in the subreport.

    The following example shows what the code for the method looks like for the subreport.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail Format event of the subreport. Copy Code
    Me.Detail1.AddBookmark(CType(Me.ParentReport.Sections("Detail1").Controls("txtCustomerID"), TextBox).Text
    + "\" + Me.txtContactName.Text)

    Show To write the code in C#

    C# code. Paste INSIDE the Detail Format event of the subreport. Copy Code
    this.detail1.AddBookmark(((TextBox)(this.ParentReport.Sections["Detail1"].Controls["txtCustomerID"])).Text
    + "\\" + this.txtContactName.Text);

To add special bookmarks at run time

To create and add special bookmarks to the bookmarks collection at run time, add the bookmarks to the report document's pages collection.

Caution: Remember that the page collection does not exist until the report runs, so use this code in the ReportEnd event or in form code after the report has run.

Show To write the code in Visual Basic.NET

  1. Click in the gray area outside the report and right-click to select Properties from the context menu.
  2. Click the Events icon in the Properties Window to display events available for the report.
  3. Double-click ReportEnd. This creates an event-handling method for the ReportEnd event.
  4. Add code to the handler to add a bookmark.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the ReportEnd event. Copy Code
Me.Document.Pages(0).AddBookmark("New Bookmark", 1)

Show To write the code in C#

C# code. Paste INSIDE the ReportEnd event. Copy Code
this.Document.Pages[0].AddBookmark("New Bookmark", 1);

To view a report bookmarks in the Viewer or Preview tab

  1. Add the ActiveReports Viewer control to your Windows Form.
  2. Add code to display the report in the Viewer. See Viewing Reports for further information.
  3. Press F5 to run the report.
  4. On the Viewer toolbar, select Toggle Sidebar to open the sidebar and click the Document Map button to view the list of bookmarks.

See Also

Concepts
Document Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Hyperlinks

Add Hyperlinks
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Add Hyperlinks

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can add hyperlinks in a report using the Hyperlink property available with the following controls:

  • Label
  • TextBox
  • Picture

You can add hyperlinks that connect to a Web page, open an e-mail, or jump to a bookmark.

Note: Specify the full URL address (for example, "http://www.grapecity.com") for the Hyperlink property to avoid broken links while viewing reports.

To link to a Web page

  1. Select an existing control or drag and drop a control from the Visual Studio toolbox onto the design surface.
  2. Right-click the control to open the Properties Window.
  3. In the Properties Window, set the HyperLink property to any valid URL. For example, for example, http://www.grapecity.com.

To link to an e-mail address

  1. Select an existing control or drag and drop a control from the Visual Studio toolbox onto the design surface.
  2. Right-click the control to open the Properties Window.
  3. In the Properties Window, set the HyperLink property to mailto: any valid e-mail address.

To parse the URL out of a database field for a hyperlink

  1. From the Report Explorer, drag and drop the link field onto the design surface.
  2. Double-click the section where you had placed the link field. This creates an event-handling method for the section's Format event.
  3. Add code to the Format event to,
    • Parse the URL out of the Link field
    • Assign it to the HyperLink property of TextBox
    • Remove the URL markers from the text displayed in TextBox

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    Dim iStart As Integer
Dim sHTML As String
If textBox1.Text <> "" Then
    iStart = InStr(1, textBox1.Text, "#", CompareMethod.Text)
    sHTML = Right(textBox1.Text, (Len(textBox1.Text) - iStart))
    sHTML = Replace(sHTML, "#", "", 1, -1, CompareMethod.Text)
    textBox1.HyperLink = sHTML
    textBox1.Text = Replace(textBox1.Text, "#", "", 1, -1, CompareMethod.Text)
End If

    Show To write the code in C#

    C# code. Paste INSIDE the Format event. Copy Code
    int iStart;
string sHTML;
if (textBox1.Text != "")
    {
     iStart = textBox1.Text.IndexOf("#",0);
     sHTML = textBox1.Text.Substring(iStart, textBox1.Text.Length - iStart);
     sHTML = sHTML.Replace("#", "");
     textBox1.HyperLink = sHTML;
     textBox1.Text = textBox1.Text.Replace("#", "");
    }

To create a hyperlink that jumps to a bookmark

  1. From the Report Explorer, drag and drop a field onto the design surface.
  2. Double-click the section where you had placed the field. This creates an event-handling method for the section's Format event.
  3. Add the following code inside the Format event.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste JUST ABOVE the Format event. Copy Code
    Public pBM As New BookmarksCollection()
Dim iEntry As Integer
    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    Me.Detail1.AddBookmark(Me.textBox1.Text)
Me.txtEntry.HyperLink = "toc://" + pBM(iEntry - 1).Label
Me.txtEntry.Text = pBM(iEntry - 1).Label
Me.txtPage.Text = pBM(iEntry - 1).PageNumber

    Show To write the code in C#

    C# code. Paste JUST ABOVE the Format event. Copy Code
    public BookmarksCollection pBM = new BookmarksCollection();
int iEntry;
    C# code. Paste INSIDE the Format event. Copy Code
    this.detail.AddBookmark(this.textBox.Text);
this.txtEntry.HyperLink = "toc://" + pBM[iEntry - 1].Label;
this.txtEntry.Text = pBM[iEntry - 1].Label;
this.txtPage.Text = pBM[iEntry - 1].PageNumber.ToString();

To display the page number of the bookmark in the table of contents

  1. Select the gray area outside the report and right-click to choose Properties option from the context menu.
  2. In the Properties Window that appears, click the Events button to get the list of events for the report.
  3. Select the FetchData event from that list and double-click it. This creates an event-handling method for the report's FetchData event in the code behind.
  4. Add code to the handler to retrieve information to populate the report fields.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic

    Visual Basic.NET code. Paste INSIDE the FetchData event. Copy Code
    If iEntry > pBM.Count - 1 Then
    eArgs.EOF = True
Else
    eArgs.EOF = False
    iEntry += 1
End If

    Show To write the code in C#

    C# code. Paste INSIDE the FetchData event. Copy Code
    if (iEntry > pBM.Count - 1)
{
    eArgs.EOF = true;
}
else
{
    eArgs.EOF = false;
    iEntry += 1;
}

See Also

Concepts
Interactive Features

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use External Style Sheets

Use External Style Sheets
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Use External Style Sheets

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can set custom style values in the Styles page of the Report Settings Dialog, and then apply the styles to controls using the ClassName property from the Properties Window.

You can also apply these same styles to controls in other reports, by exporting them to a XML file of type *.reportstyle and selecting it in other reports using the Report Settings dialog.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: You can apply styles to the CheckBox, Label, TextBox, and ReportInfo controls only.

To modify or create a style and save it to an external style sheet

  1. In the Report Explorer, right-click the Settings node and select Show.
  2. In the Report Settings dialog that appears, go to the Styles page. On the Styles page, there are four predefined styles: Normal, Heading1, Heading2 and Heading3.
  3. Click any of these styles in the list to modify them using the fields on the right, or click the New button to add a new style.
  4. Click the Export styles to file button to save the existing styles in a style sheet.
  5. In the Save As dialog that appears, navigate to the location where you want to save the style sheet, provide an name for the file and click the Save button to save it as an external *.reportstyle file.
  6. In the Report Settings dialog, click the OK button to close the dialog and save the styles in the current report.

To load and apply an external style sheet at design time

  1. In the Report Explorer, right-click the Settings node and select Show.
  2. In the Report Settings dialog that appears, go to the Styles page.
  3. On the Style page, click the Import styles from file button.
  4. A message box warns that current styles will be deleted. Click Yes to continue.
  5. In the Open dialog that appears, navigate to the *.reportstyle file that you want to use and click the Open button to load the external style sheet.
  6. On the design surface, select the control you want to apply the style to and right-click to choose Properties.
  7. In the Properties Window, from the Class Name property drop down select a style to apply (like Heading1).

To load an external style sheet at run time and apply it

  1. Right-click the gray area outside the design surface and select Properties.
  2. In the Properties Window that appears, click the Events button. A list of report events appear.
  3. Select the ReportStart event and double click to create an event-handling method.
  4. Add the following code to the handler to load an external style sheet.
    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.LoadStyles("C:\MyStyleSheet.reportstyle")
    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.LoadStyles(@"C:\MyStyleSheet.reportstyle");

To apply a style to a control at run time

The following steps assume that you have already loaded an external style sheet to the report.

  1. On the design surface select the section containing the control.
  2. In the Properties Window, click the Events button. A list of report events appear.
  3. Select the Format event and double click to create an event-handling method.
  4. Add the following code to the handler to apply a style to a control.
    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    Me.TextBox.ClassName = "Heading1"
    C# code. Paste INSIDE the Format event. Copy Code
    this.textBox.ClassName = "Heading1";

See Also

Concepts
Report Explorer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Insert or Add Pages

Insert or Add Pages
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Insert or Add Pages

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout, you can run multiple reports, merge their entire page collection or specific portions and view it as a single report. You can save the document containing merged reports to an RDF file or even export them.

These steps assume that you have already placed a Viewer control on a Windows Form and your Visual Studio project contains two section layout (code based) reports (rptOne and rptTwo). See Adding an ActiveReport to a Project and Using the Viewer for more information.

To add pages from one report to another

To add an entire report to another, use code like the one in the example below to iterate through the entire pages collection of a report and append it to the first report. The Add of the PagesCollection takes one parameter (value), which references a report document page.

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to add the entire rptTwo page collection to rptOne.

    The following example shows what the code for the Add() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim i As Integer
    Dim rpt As New rptOne()
    rpt.Run()
    Dim rpt2 As New rptTwo()
    rpt2.Run()
    For i = 0 To rpt2.Document.Pages.Count - 1
    rpt.Document.Pages.Add(rpt2.Document.Pages(i))
    Next
    Viewer1.Document = rpt.Document

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    int i;
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    for(i = 0; i < rpt2.Document.Pages.Count; i++)
    {
    rpt1.Document.Pages.Add(rpt2.Document.Pages[i]);
    }
    viewer1.Document = rpt1.Document;

To add a range of pages from one report to another

To add a range of pages from one report to another, use the AddRange. This method has two overloads, each with one parameter. The first overload takes an array of page objects which you can use to append only the specified pages from the second report onto the first (as in the example below).

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to use the AddRange() method to add pages from rptTwo to rptOne.

    The following example shows what the code for the AddRange() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim rpt1 As New rptOne()

    rpt1.Run()

    Dim rpt2 As New rptTwo()

    rpt2.Run()

    rpt1.Document.Pages.AddRange(New GrapeCity.ActiveReports.Document.Section.Page() {rpt2.Document.Pages(1), rpt2.Document.Pages(2)})

    Viewer1.Document = rpt1.Document

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    rptOne rpt1 = new rptOne();
rpt1.Run();
rptTwo rpt2 = new rptTwo();
rpt2.Run();
rpt1.Document.Pages.AddRange(new GrapeCity.ActiveReports.Document.Section.Page[] {rpt2.Document.Pages[0],rpt2.Document.Pages[1]} );
viewer1.Document = rpt1.Document;

To insert pages from one report into another

To insert pages from one report to another, use the Insert that takes two parameters, an index, which determines where to insert the pages in the main report, and a value which references the report page to insert.

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to insert page 1 of rptTwo at the beginning of rptOne.

    The following example shows what the code for the Insert() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim rpt1 As New rptOne()

    rpt1.Run()

    Dim rpt2 As New rptTwo()

    rpt2.Run()

    rpt1.Document.Pages.Insert(0, rpt2.Document.Pages(0))

    Viewer1.Document = rpt1.Document

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    rptOne rpt1 = new rptOne();

    rpt1.Run();

    rptTwo rpt2 = new rptTwo();

    rpt2.Run();

    rpt1.Document.Pages.Insert(0, rpt2.Document.Pages[0]);

    viewer1.Document = rpt1.Document;

To insert a new page at a specific report location

To insert a new blank page at a specific location in the report, use the InsertNew which takes one parameter, index, which specifies the page after which you want to insert a new blank page.

  1. In the design view of the viewer form, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to insert a blank page at the beginning of rptOne.

    The following example shows what the code for the InsertNew() method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
    Dim rpt1 As New rptOne()

    rpt1.Run()

    rpt1.Document.Pages.InsertNew(0)

    Viewer1.Document = rpt1.Document

    Show To write the code in C#

    C# code. Paste INSIDE the Form Load event. Copy Code
    rptOne rpt1 = new rptOne();

    rpt1.Run();

    rpt1.Document.Pages.InsertNew(0);

    viewer1.Document = rpt1.Document;

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Embed Subreports

Embed Subreports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Embed Subreports

Glossary Item Box

Show All Show All
Hide All Hide All

To embed a subreport into a parent report, you add two reports (one parent and one child report) to a Visual Studio project, and from the ActiveReports 13 Section Report toolbox, drag the SubReport control onto the parent report. The following steps take you through the process of adding a subreport in a section report.

These steps assume that you have already added a Section Report (code-based) template in a Visual Studio project. See Adding an ActiveReport to a Project for further information.

To add code to create an instance of the child report in the parent report

  1. Double-click the gray area around the parent report to create an event-handling method for the ReportStart event.
  2. Add code like the following to the handler to create a new instance of the child report.

    Show To write the code in Visual Basic

    Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
    Dim rpt As rptYourChildReportName
    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    rpt = New rptYourChildReportName()

    Show To write the code in C#

    C# code. Paste JUST ABOVE the ReportStart event. Copy Code
    private rptYourChildReportName rpt;
    C# code. Paste INSIDE the ReportStart event. Copy Code
    rpt = new rptYourChildReportName();
Caution: It is recommended that you do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, using a lot of memory.

To add code to display the child report in a subreport control on a parent report

  1. Add the SubReport control onto the design surface of the parent report.
  2. Double-click the detail section of the report to create a detail_Format event.
  3. Add code like the following to the handler to display a report in the SubReport control.

    Show To write the code in Visual Basic

    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    Me.SubReport1.Report = rpt

    Show To write the code in C#

    C# code. Paste INSIDE the Format event. Copy Code
    this.subReport1.Report = rpt;

See Also

Concepts
SubReport (Section Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Add Code to Layouts Using Script

Add Code to Layouts Using Script
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Add Code to Layouts Using Script

Glossary Item Box

Show All Show All
Hide All Hide All

In a section report, you can use script to access controls, functions in a class, namespaces, etc. You can also create classes inside the script to call methods or add code to a report's script from a Windows Form. The following sections illustrate simple scripting scenarios with examples.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project. See Adding an ActiveReport to a Project for more information.

To access controls in script

To add script to a report to access a textbox named TextBox1 in the detail section and assign the text "Hello" to it:

  1. On the script tab of the report, drop down the Object list and select Detail. This populates the Event drop-down list with section events.
  2. Drop down the Event list and select Format. This creates script stubs for the event.

    Show To access a textbox in the detail section in VB.NET script

    Visual Basic.NET script. Paste INSIDE the Detail Format event. Copy Code
    Me.TextBox1.Text = "Hello"

    Or

    Visual Basic.NET script. Paste INSIDE the Detail Format event. Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = "Hello"

    Show To access a textbox in the detail section in C# script

    C# script. Paste INSIDE the Detail Format event. Copy Code
    this.textBox1.Text = "Hello";

    Or

    C# script. Paste INSIDE the Detail Format event. Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["TextBox1"]).Text = "Hello";

To give a script access to functions in a class in your project

Using the AddNamedItem method, you can allow the script to access functions in a class file within your project. This allows you to keep secure information such as a database connection string or a SQL query string in the code instead of saving it in the RPX file.

  1. In the Code View of the Form, add a class to your project named clsMyItem.

    Show To add a class in Visual Basic.NET

    Visual Basic.NET code. Copy Code
    Public Class clsMyItem
End Class

    Show To add a class in C#

    C# code. Copy Code
    public partial class clsMyItem
{
}
  2. Add a public function to your class using code like the following:

    Show To create a public function in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the new class. Copy Code
    Public Function getMyItem() As String
    getMyItem = "Hello"
End Function

    Show To create a public function in C#

    C# code. Paste INSIDE the new class. Copy Code
    public string getMyItem()
{
    return "Hello";
}
  3. Go to the design view of the report and double-click the gray area around the design surface to create an event-handling method for the ReportStart event.
  4. Add the following code to the handler:

    Show To access the class in Visual Basic.NET

    Visual Basic.NET code. Paste before or in the ReportStart event. Copy Code
    Me.AddNamedItem("myItem", new clsMyItem())

    Show To access the class in C#

    C# code. Paste before or in the ReportStart event. Copy Code

    this.AddNamedItem("myItem", new clsMyItem());
  5. From the Visual Studio toolbox, drag and drop a TextBox control onto the detail section of the report.
  6. Go to the script tab and drop down the Object list to select Detail. This populates the Event drop-down list with section events.
  7. Drop down the Event list and select Format. This creates script stubs for the event.
  8. Add the following script to the event to access a control on the report and populate it using the named item.

    Show To access the control in VB.NET script

    VB.NET script. Paste INSIDE the Detail Format event. Copy Code

    Me.TextBox1.Text = myItem.getMyItem()

    Or

    VB.NET script. Paste INSIDE the Detail Format event. Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = myItem.getMyItem()

    Show To access the control in C# script

    C# script. Paste INSIDE the Detail Format event. Copy Code

    this.textBox1.Text = myItem.getMyItem();

    Or

    C# script. Paste INSIDE the Detail Format event. Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = myItem.getMyItem();
  9. Go to the preview tab to view the result.

To access namespaces

Using the AddScriptReference method, you can gain access to .NET or other namespaces. This is only necessary if you need a reference, such as System.Data.dll, that is not initialized in the project before the script runs.

Show To access a namespace in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form code. Replace YourReportName with the name of your report. Copy Code
Private Sub runReport()
      Dim rpt as new YourReportName
      rpt.AddScriptReference("System.Data.dll")
      rpt.Run()
End Sub

Show To access a namespace in C#

C# code. Paste INSIDE the Form code. Replace YourReportName with the name of your report. Copy Code
private void runReport()
{
      YourReportName rpt = new YourReportName;
      rpt.AddScriptReference("System.Data.dll");
      rpt.Run();
}

To add code to a report's script from a Windows Form

Using the AddCode method in the Code View of the Form, you can add code into the script. The AddCode method allows you to add actual code segments to the script at run time. This is useful for allowing secure information, such as a database connection string or SQL query string, to be used inside the script without saving it in the RPX file.

  1. Go to the Code View of your report and add a public function like the following:

    Show To add code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the report class. Copy Code
    Public Function addThisCode() As String
   Dim sCode As String = "Public Function ShowACMessage() As String" + Environment.NewLine + "ShowACMessage = ""my Added Code""" + Environment.NewLine + "End Function"
   addThisCode = sCode
End Function

    Show To add code in C#

    C# code. Paste INSIDE the report class. Copy Code
    public string addThisCode()
{
   string sCode = "public string ShowACMessage(){return \"my Added Code\";}";
   return sCode;
}
  2. In the design view of your report double-click the gray area around the design surface to create an event-handling method for the ReportStart event.
  3. Add the following code to the handler:

    Show To access the class in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Me.AddCode(addThisCode())

    Show To access the class in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    this.AddCode(addThisCode());
  4. Go to the script tab and drop down the Object list to select Detail. This populates the Event drop-down list with section events.
  5. Drop down the Event list and select Format. This creates script stubs for the event.
  6. Add the following script to the event:

    Show To write the script in Visual Basic.NET

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    Me.TextBox1.Text = ShowACMessage()

    Or

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = ShowACMessage()

    Show To write the script in C#

    C# script. Paste INSIDE the detail_Format event. Copy Code
    this.textBox1.Text = ShowACMessage();

    Or

    C# script. Paste INSIDE the detail_Format event. Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = ShowACMessage();

To create classes inside the script to call methods

If the script requires a method to be called, you can construct a class inside the script.

  1. Go to the script tab and add the following code at the top:

    Show To create a class inside the script in VB.NET script

    VB.NET script. Paste INSIDE the script tab. Copy Code
    Public Class MyFuncs
   Public  Sub New()
   End Sub
   Public Function ShowMyString() As String
      Return "This is my string"
   End Function
End Class

    Show To create a class inside the script in C#

    C# script. Paste INSIDE the script tab. Copy Code
    public class MyFuncs
{
   public MyFuncs()
   {
   }
   public string ShowMyString()
   {
      return "This is my string";
   }
}
  2. On the script tab, now drop down the Object list and select Detail. This populates the Event drop-down list with section events.
  3. Drop down the Event list and select Format. This creates script stubs for the event.
  4. Add the following script to the event:

    Show To create a class inside the script in VB.NET script

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    Dim f As MyFuncs =  New MyFuncs()
Me.TextBox1.Text = f.ShowMyString

    Or

    VB.NET script. Paste INSIDE the Detail1_Format event. Copy Code
    Dim f As MyFuncs =  New MyFuncs()
CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = f.ShowMyString

    Show To create a class inside the script in C#

    C# script. Paste INSIDE the detail_Format event. Copy Code
    MyFuncs f = new MyFuncs();
this.textBox1.Text = f.ShowMyString();

    Or

    C# script. Paste INSIDE the detail_Format event. Copy Code
    MyFuncs f = new MyFuncs();
((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = f.ShowMyString();
Note: Use the examples with the "this" (C#) and "Me"(Visual Basic.NET) keywords, as they are recommended rather than the ones with "rpt".

See Also

Concepts
Scripting in Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Save and Load RDF Report Files

Save and Load RDF Report Files
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Save and Load RDF Report Files

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows reports to be saved in their own standard format called an RDF file (Report Document Format). In this format, the data is static. The saved report displays the data that is retrieved when you run the report. You can save a report to an RDF file and load it into the viewer control.

To save a report as a static RDF file

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to save the report.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim rpt As New YourReportName()
    rpt.Run()
rpt.Document.Save(Application.StartupPath + \NewRDF.RDF)

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    YourReportName rpt = new YourReportName();
    rpt.Run();
rpt.Document.Save(Application.StartupPath + \\NewRDF.RDF);

To load a saved RDF file into the ActiveReports viewer

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to load the saved report.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Viewer1.Document.Load("Location of the .RDF File")

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    viewer1.Document.Load(@"Location of the .RDF File");
Note: The Windows Form Viewer can display RDF files made with any version of ActiveReports, including COM versions. The FlashViewer viewer type of the WebViewer (Professional Edition) may be able to display RDF files made with previous versions, but this is not guaranteed for every RDF.

To save or load report files to a memory stream

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to save the report to a memory stream and load the memory stream into the ActiveReports viewer.

    The following examples show what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
    Dim strm As New System.IO.MemoryStream()
Dim rpt As New YourReportName()
rpt.Run()
rpt.Document.Save(strm)
Dim theBytes(strm.Length) As Byte
strm.Read(theBytes, 0, Int(strm.Length))
strm.Position = 0
Viewer1.Document.Load(strm)

    Show To write the code in C#

    C# code. Paste INSIDE the Form_Load event. Copy Code
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
YourReportName rpt = new YourReportName();
rpt.Run();
rpt.Document.Save(strm);
byte[] theBytes = new byte[strm.Length];
strm.Read(theBytes, 0, (int)strm.Length);
strm.Position =0;
viewer1.Document.Load(strm);

See Also

Save and Load RPX Report Files

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Save and Load RPX Report Files

Save and Load RPX Report Files
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Section Report How To > Save and Load RPX Report Files

Glossary Item Box

Show All Show All
Hide All Hide All

Although ActiveReports writes report layouts in either C# or Visual Basic.NET, you can save the layout of your report as a report XML (RPX) file for portability. If you make changes to the RPX file and load it back into an ActiveReport in Visual Studio, you can see the changes you made reflected in the C# or Visual Basic.NET code in the YourReportName.Designer.vb or YourReportName.Designer.cs file.

Caution: When you load an RPX layout into a report object, it overwrites everything in the report object. In order to avoid overwriting important layouts, add a new blank ActiveReport and load the RPX file onto it.

To save a report as an RPX file at design time

  1. From the Visual Studio Report menu, select Save Layout.
  2. In the Save As dialog that appears, set the file name and select the location where you want to save it. The file extension is *.rpx.
  3. Click the Save button to save the report layout and close the dialog.
Note: When you save a layout that contains a dataset, ActiveReports saves the data adapter and data connection in the component tray, but not the dataset itself. When the saved layout is loaded into another report, you can regenerate the dataset with the data adapter and data connection.

To load an RPX file at design time

  1. From the Visual Studio Report menu, select Load Layout.
  2. In the Open dialog that appears, navigate to the location of the .rpx file and select it.
  3. Click the Open button to load the report layout.

To save a report as an RPX file at run time

Use the SaveLayout method to save your report layout at run time.

Note: When you save a report layout, ActiveReports only saves the code in the script editor to the file. Any code behind the report in the .cs or .vb file is not saved to the RPX file.
  1. Right-click the Windows Form and select View Code to see the code view for the Windows form.
  2. Add the following code to the Form class to save the report.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form class. Copy Code
    Dim rpt As New SectionReport1()
    Dim xtw As New System.Xml.XmlTextWriter(Application.StartupPath + "\report.rpx", Nothing)
    rpt.SaveLayout(xtw)
    xtw.Close()

    Show To write the code in C#

    C# code. Paste INSIDE the Form class. Copy Code
    SectionReport1 rpt = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter(Application.StartupPath + "\\report.rpx", null);
rpt.SaveLayout(xtw);
xtw.Close();

    Save report layouts before they run. If you save a layout after the report runs, you also save any dynamic changes made to properties or sections in the report. To avoid this when you call SaveLayout inside the report code, use the ReportStart event.

    Note: The SaveLayout method uses utf-16 encoding when you save to a stream, and utf-8 encoding when you save to a file.

To load an RPX file into the ActiveReports viewer at run time

  1. Right-click on the Windows Form and select View Code to see the code view for the Windows form.
  2. Add the following code to the form class to load a report.

    The following examples show what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form class. Copy Code
    Dim rpt As New GrapeCity.ActiveReports.SectionReport()
' For the code to work, this report.rpx must be stored in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
Viewer1.Document = rpt.Document
rpt.Run()

    Show To write the code in C#

    C# code. Paste INSIDE the Form class. Copy Code
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
// For the code to work, this report.rpx must be stored in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\Sample.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
viewer1.Document = rpt.Document;
rpt.Run();

See Also

Save and Load RDF Report Files

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Customize, Localize, and Deploy

Customize, Localize, and Deploy
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy

Glossary Item Box

ActiveReports uses an English locale by default, and includes localization resources for Japanese and Russian locales. You can also localize all of the components into any language you need. GrapeCity may, from time to time and on the agreement of users who localize components, include additional locales with future hot fixes and service packs. If you are willing to share your localized resources with other users, please inform technical support staff so that they can pass on your resource files to development.

There are several ways to deploy your ActiveReports applications. See the topics listed below for more information on customizing, localizing and deploying your applications.

In this section

Localize Reports, TextBoxes, and Chart Controls
Learn how to localize individual textboxes, chart controls, and entire reports.
Localize ActiveReports Resources
Learn to localize ActiveReports dialogs, error messages, and images.
Deploy Windows Applications
Learn to deploy ActiveReports Windows applications.
Deploy Web Applications
Learn to deploy ActiveReports Windows applications.
Localize the End User Report Designer
Learn to localize the strings and images in the End User Report Designer.
Configure HTTPHandlers in IIS 7, IIS 8 and IIS 10
Learn to deploy ActiveReports Windows applications.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Localize Reports, TextBoxes, and Chart Controls

Localize Reports, TextBoxes, and Chart Controls
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Localize Reports, TextBoxes, and Chart Controls

Glossary Item Box

Show All Show All
Hide All Hide All

In a section layout report, the Report object, TextBox control, and Chart control have a public Culture property that allows you to localize data when the OutputFormat property is set to D (date), C (currency), or other .NET formats.

Note: The default value for the Culture property is (default, inherit). For the Report object, this is the culture of the current thread and for the TextBox control and the ChartControl, this is the culture of the Report object.

In a page layout report, the Report object, TextBox control, and Chart control all have a Language property that works in the same way. The default value for the Language property is Default, which is the culture of the current thread.

Design Time

At design time, you can set the culture or language in the Visual Studio Properties window.

Show To localize a Report at design time

  1. Click the gray area around the design surface to select the Report in the Properties window.
  2. In the Properties window, drop down the Culture or Language property and select the culture that you want to apply to the report.

Show To localize a TextBox control at design time

  1. Click the TextBox control that you want to localize to select it.
  2. In the Properties window, drop down the Culture or Language property and select the culture that you want to apply to the textbox.

Show To localize a Chart control at design time

  1. Click the Chart control to select it.
  2. In the Properties window, drop down the Culture or Language property and select the culture that you want to apply to the chart.

Run Time

You can also specify a culture in code for section reports. For a list of System.Globalization culture codes, see Cultures.

Show To localize a Report at run time

  1. Double-click the gray area around the design surface, to create an event handling method for the ReportStart event.
  2. In the code view of the report that appears, paste code like the following.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    YourReportName.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US")

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    YourReportName.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US");

Show To localize a TextBox at run time

  1. On the design surface, double-click the section containing the TextBox control that you want to localize to create an event handling method for the section Format event.
  2. In the code view of the report that appears, paste code like the following inside the Format event.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    TextBox.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US")

    Show To write the code in C#

    C# code. Paste INSIDE the Format event. Copy Code
    textBox.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US");

Show To localize a Chart at run time

  1. On the design surface, double-click the section containing the ChartControl that you want to localize to create an event handling method for the section Format event.
  2. In the code view of the report that appears, paste code like the following in the Format event.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    ChartControl.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US")

    Show To write the code in C#

    C# code. Paste INSIDE the Format event. Copy Code
    chartControl.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US");

See Also

Localize ActiveReports Resources

Concepts
Localization

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Localize ActiveReports Resources

Localize ActiveReports Resources
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Localize ActiveReports Resources

Glossary Item Box

Show All Show All
Hide All Hide All

You can localize all of the UI strings, error messages, and images that appear in ActiveReports in included resource files, and alter and run a batch file to localize each resource.

To localize ActiveReports Resources

All of the localization files are located in C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization.

Show Specify the culture you want to use in the batch files.

  1. Start Notepad or another text editor as an Administrator.
  2. Open *.bat file for each resource you want to localize and change the Culture value to the culture you want to use.
  3. Ensure that the path in ProgamFilesAssemblyDir is correct for your installation, but do not alter any of the other properties.
  4. Save and close each file.

Show Localize strings (and images) in the resource files.

  1. Launch your zip program as an Administrator and open the *.zip file for each resource you want to localize.
  2. Extract all of the files to
    C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization.
    A resource subfolder with the same name as the zip file is created.
  3. In the new folder, open each subfolder and change the strings in each of the *.resx files.
    Tip: Strings are located between <value> and </value> tags in the resource files.
  4. If you want to change the images, rename your localized images to the names of the ones in the Res\Resources subfolder and replace them with your localized images.

Show Run the batch files as an Administrator.

  1. From the Start menu, type cmd in the text box, and press CTRL + SHIFT + ENTER to open a command prompt as an Administrator.
  2. To change directories, type:
    cd C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization
    and press Enter.
  3. Type the name of the *.bat file and press Enter to run the file. The NameCompleter.exe application runs, and creates the following.
    • A SatelliteAssembly folder inside the resource subfolder.
    • A language subfolder with the name of the culture you set inside the SatelliteAssemby folder.
    • A localized GrapeCity.ActiveReports.AssemblyName.resources.dll file inside the language subfolder.
  4. Copy the language subfolder and paste it into the Debug folder of your application.
    Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.AssemblyName.resources.dll file to GrapeCity and get it signed with a strong name. Then you can drag the language subfolder with the signed dll file into C:\WINDOWS\ASSEMBLY, or distribute it with your solution.

Show Test your localized application on a machine that does not share the culture of the localized DLLs.

  1. Add the following code in the form's constructor just before the InitializeComponent method is called.
  2. Replace the "ja-JP" in the example code with the culture you specified in the *.bat file.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the form's constructor just before the InitializeComponent method. Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = New System.Globalization.CultureInfo("ja-JP")

Show To write the code in C#

C# code. Paste INSIDE the form's constructor just before the InitializeComponent method. Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = new System.Globalization.CultureInfo("ja-JP");

See Also

Localize Reports, TextBoxes, and Chart Controls
Localize the End User Report Designer

Concepts
Localization

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Deploy Windows Applications

Deploy Windows Applications
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Deploy Windows Applications

Glossary Item Box

Show All Show All
Hide All Hide All

Before you begin

Before deploying a Windows application, there are a few settings that can be helpful.

  • On report files, in the Properties window, change the Copy to Output Directory property to Copy always.
  • For ActiveReports references, change the Copy Local property to True. This puts all of the needed reference assemblies into the Release folder when you build your project.

It is also good to be sure that all of the references you need for your reports are included. Here is a table listing features and required DLLs.

Show Features and References

These assemblies are added automatically when you add controls to forms or report controls to code-based section reports, but Visual Studio does not do this with XML-based (RPX and RDLX) reports.

Feature | Required Assembly
Export: Excel, Html, Image/Tiff, Pdf, Word/Rtf, Text/Xml | GrapeCity.ActiveReports.Export.*.dll (replace * with Excel, Html, Image, Pdf, Word, or Xml)
Viewer control (or printing without the Viewer control) | GrapeCity.ActiveReports.Viewer.Win.dll
Designer, Toolbox, or ReportExplorer control | GrapeCity.ActiveReports.Design.Win.dll

XCopy Deployment

  1. Open your project in Visual Studio, and set the Solution Configuration to Release.
  2. From the Build menu, select Build Solution.
  3. In Windows Explorer, navigate to the project's bin directory, and copy the files from the Release folder into a zip file.
  4. Distribute the zip file.

MSI Installer Deployment

Show To create an installer project

  1. Open an existing ActiveReports project or create a new one.
  2. From the Visual Studio Build menu, select Build YourActiveReportsProjectName to build your report project.
  3. From the File menu, select Add, then New Project to open the Add New Project dialog.
  4. In the Add New Project dialog under Project Types, expand the Other Project Types node and select Setup and Deployment.
  5. Under Visual Studio Installer, select Setup Project, rename the file and click OK. The ProductName that you enter determines the name that is displayed for the application in folder names and in the Programs and Features control panel item.
  6. In the File System editor that appears, under File System on Target Machine, select the Application Folder.
    Note: To show the File System editor at any time, drop down the View menu and select Editor, then File System.
  7. From the Visual Studio Action menu, select Add, then Project Output.
  8. In the Add Project Output Group dialog that appears, choose your ActiveReports project name from the drop-down list.
  9. In the list, select Primary Output and click OK. This adds all of the existing assembly dependencies to your project.
  10. If you want to add other ActiveReports DLLs to the installer (e.g. if you use OleObjects on reports, you need to include the Interop.dll or Interop64.dll for 64-bit machines), in the Solution Explorer, right-click the installer project name, select Add, then Assembly.
    Note: If you would rather use the ActiveReports .msm file, please contact our technical support team.
  11. In the Select Component dialog that appears, select any components that you want to add and click the OK button.
  12. From the Visual Studio Build menu, select Build YourInstallerProjectName to build your Installer project.

Show To deploy the installer application

  1. Select the Installer project in the Solution Explorer.
  2. From the Visual Studio Project menu, click Install.
  3. The Installer application runs and installs the project on your computer. The distributable exe and msi setup files appear in your installer project Debug folder.

See Also

Deploy Web Applications
Localize the Viewer Control

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Deploy Web Applications

Deploy Web Applications
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Deploy Web Applications

Glossary Item Box

Show All Show All
Hide All Hide All

Follow this guide to deploy ActiveReports Web projects to your Web server. For Web projects using the Professional Edition HttpHandlers, see Configure HTTPHandlers in IIS 7, IIS 8 and IIS 10.

Before you begin

To deploy ActiveReports Web projects, you must have access to the Microsoft .NET Framework version 4.6.2 or higher and the coordinating version of ASP.NET. You must also have access to Internet Information Services version 7.5 or higher, and you need administrative access to the server.

It is also good to be sure that all of the references you need for your reports are included. Here is a table listing features and required DLLs.

Show Features and References

These assemblies are added automatically when you add controls to forms or report controls to code-based section reports, but Visual Studio does not do this with XML-based (RPX and RDLX) reports.

Feature | Required Assembly
Export: Excel | GrapeCity.ActiveReports.Export.Excel.dll GrapeCity.ActiveReports.Core.Export.Excel.Page.dll DocumentFormat.OpenXml.dll System.IO.Compression.dll GrapeCity.ActiveReports.Export.Rdf.dll
Export: HTML | GrapeCity.ActiveReports.Export.Html.dll GrapeCity.ActiveReports.Core.Export.Html.Page.dll GrapeCity.ActiveReports.Export.Svg.dll GrapeCity.ActiveReports.Export.Rdf.dll
Export: Image | GrapeCity.ActiveReports.Export.Image.dll GrapeCity.ActiveReports.Export.Rdf.dll
Export: PDF | GrapeCity.ActiveReports.Export.Pdf.dll GrapeCity.ActiveReports.Export.Rdf.dll
Export: Word/RTF | GrapeCity.ActiveReports.Export.Word.dll DocumentFormat.OpenXml.dll System.IO.Compression.dll GrapeCity.ActiveReports.Export.Rdf.dll
Export: XML/CSV/JSON | GrapeCity.ActiveReports.Export.Xml.dll GrapeCity.ActiveReports.Core.Export.Text.Page.dll GrapeCity.ActiveReports.Export.Rdf.dll
WebViewer or HttpHandlers (Pro Edition only) | GrapeCity.ActiveReports.Web.dll
JS Viewer | GrapeCity.ActiveReports.Aspnetcore.Viewer.dll GrapeCity.ActiveReports.Aspnet.Viewer.dll
Web Designer | GrapeCity.ActiveReports.Aspnetcore.Designer.dll GrapeCity.ActiveReports.Aspnet.Designer.dll

Other important assemblies that are required for deploying web applications are as follows:
  • GrapeCity.ActiveReports.dll
  • GrapeCity.ActiveReports.Core.Rdl.dll
  • Newtonsoft.Json
  • Gcef.Data.DataEngine.dll
  • Gcef.Data.VBFunctionLib.dll
  • Gcef.Data.ExpressionInfo.dll
  • Grapecity.DataVisualization.dll
  • GrapeCity.ActiveReports.Core.Diagnostics.dll
  • GrapeCity.ActiveReports.Core.Rendering.dll
  • GrapeCity.ActiveReports.Core.Drawing.Gdi.dll
  • GrapeCity.ActiveReports.Core.DataProviders.dll
  • GrapeCity.ActiveReports.Chart.dll
  • GrapeCity.ActiveReports.Document.dll

Show To copy referenced DLLs to your project

  1. In the Visual Studio Solution Explorer, if the References node is not showing, click the Show All Files button.
  2. Expand the References node, and select one of the ActiveReports references.
  3. In the Properties window, change the Copy Local property to True. The corresponding DLL is stored in the Bin folder of your project.
  4. Set the Copy Local property to True for each ActiveReports reference used in your project.

Show To install prerequisites on the server

Follow Microsoft's instructions to install each of the following on your Web server:

  • The Microsoft .NET Framework version 4.6.2 or higher
  • Internet Information Services (IIS) version 7.5
  • ASP.NET version 4.6.2 or higher (must be the same version as the Framework)

Show To copy your project to the server

  1. Copy the entire directory containing your project to the server.
  2. If your project is in a virtual directory on your local machine (i.e. C:\Inetpub\wwwroot\YourProject), you must set up a virtual directory in IIS on the server as well.

Show To set permissions on the server

Depending on your project, you may need to set permissions to allow ActiveReports access to data or folders.

Some examples of required permissions on the server:

  • If you are saving files (e.g. PDF or RDF exports) to a folder on Windows machines, the ASPNET user ID needs Write access to that folder.
  • Windows is user configurable, so use the name assigned to the ASPNET user instead.
  • If your application reads anything from any folder, assign Read access to it.
  • If your reports run on any networked data source (e.g. SQL, Access, etc.) assign Read access to it.
  • If you use CacheToDisk, assign IsolatedStorageFilePermission to it.

See Also

Custom Web Exporting

Walkthroughs
Custom Web Exporting Section Reports (Std Edition)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Localize the End User Report Designer

Localize the End User Report Designer
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Localize the End User Report Designer

Glossary Item Box

Show All Show All
Hide All Hide All

You can localize all of the UI strings, error messages, and images that appear in the ActiveReports Windows Forms Designer control in included resource files, and alter and run a batch file to localize the assembly.

To localize the Designer control

All of the localization files are located in C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization.

Show Specify the culture you want to use in the batch file.

  1. Start Notepad or another text editor as an Administrator.
  2. Open the ARDesigner.bat file and change the Culture value to the culture you want to use.
  3. Ensure that the path in ProgamFilesAssemblyDir is correct for your installation, but do not alter any of the other properties.
  4. Save and close the file.

Show Localize strings (and images) in the resource files.

  1. Launch your zip program as an Administrator and open the ARDesigner.zip file.
  2. Extract all of the files to
    C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization.
    An ARDesigner subfolder is created.
  3. In the new folder, open each subfolder and change the strings in each of the *.resx files.
    Tip: Strings are located between <value> and </value> tags in the resource files.
  4. If you want to change the images, rename your localized images to the names of the ones in the Res\Resources subfolder and replace them with your localized images.

Show Run the batch file as an Administrator.

  1. From the Start menu, type cmd in the text box, and press CTRL + SHIFT + ENTER to open a command prompt as an Administrator.
  2. To change directories, type:
    cd C:\Program Files (x86)\GrapeCity\ActiveReports 13\Localization
    and press Enter.
  3. Type ARDesigner.bat and press Enter to run the file. The NameCompleter.exe application runs, and creates the following.
    • A SatelliteAssembly folder inside the ARDesigner subfolder.
    • A language subfolder with the name of the culture you set inside the SatelliteAssemby folder.
    • A localized GrapeCity.ActiveReports.Design.Win.resources.dll file inside the language subfolder.
  4. Copy the language subfolder and paste it into the Debug folder of your application.
    Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.Design.Win.resources.dll file to GrapeCity and get it signed with a strong name. Then you can drag the language subfolder with the signed dll file into C:\WINDOWS\ASSEMBLY, or distribute it with your solution.

Show Test your localized application on a machine that does not share the culture of the localized DLLs.

  1. Add the following code in the form's constructor just before the InitializeComponent method is called.
  2. Replace the "ja" in the example code with the culture you specified in the ARDesigner.bat file.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the form's constructor just before the InitializeComponent method. Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = New System.Globalization.CultureInfo("ja")

Show To write the code in C#

C# code. Paste INSIDE the form's constructor just before the InitializeComponent method. Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = new System.Globalization.CultureInfo("ja");

See Also

Customize, Localize, and Deploy

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Configure HTTPHandlers in IIS 7, IIS 8 and IIS 10

Configure HTTPHandlers in IIS 7, IIS 8 and IIS 10
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Configure HTTPHandlers in IIS 7, IIS 8 and IIS 10

Glossary Item Box

Show All Show All
Hide All Hide All

HttpHandlers are included in the Professional edition of ActiveReports to allow you to quickly and easily display reports in the browser.

Follow these steps to configure the ActiveReports HTTP handlers in IIS 7.x so that you can link directly to reports in your Web applications. Once the handlers are configured, you can automatically run a report and view it in the browser from a URL.

Classic Mode

If any part of your Web application is not supported in Integrated Mode, you can run it using the Classic .NET AppPool.

Show To run your Web application in the Classic .NET Application Pool

  1. In the Control Panel, open Administrative Tools, then Internet Information Services (IIS) Manager.
  2. In the Internet Information Services (IIS) Manager window that appears, in the left pane under Connections, expand the Sites node and select the Web application you want to configure.
  3. To the right of the Handler Mappings pane that appears, under Actions, click Basic Settings.
  4. In the Edit Site dialog that appears, click the Select button.
  5. In the Select Application Pool dialog that appears, drop down the Application pool, select Classic .NET AppPool, and click OK.
  6. Back in the Edit Site dialog, click OK to accept the changes.

Show To configure ActiveReports HTTP handlers to enable report linking in your Web applications

  1. In the Control Panel, open Administrative Tools, then Internet Information Services (IIS) Manager.
  2. In the Internet Information Services (IIS) Manager window that appears, in the left pane under Connections, expand the Sites node and select the Web application you want to configure.
  3. In the site's Home pane that appears, under IIS, double-click Handler Mappings.
  4. To the right of the Handler Mappings pane that appears, under Actions, click Add Script Map.
  5. In the Add Script Map dialog that appears, enter the information from the first row of the table below.
    Note: If you have a 64 bit app pool, add script mappings for the 64 bit version of the aspnet_isapi.dll by navigating to C:\Windows\Microsoft.NET\Framework64\v*\aspnet_isapi.dll.
    Request path | Executable | Name
    *.Web | aspnet_isapi.dll version to match your app pool | ActiveReports 13 Cache Item Script Mapping
    *.rpx | aspnet_isapi.dll version to match your app pool | ActiveReports 13 RPX Script Mapping
    *.rdlx | aspnet_isapi.dll version to match your app pool | ActiveReports 13 RDLX Script Mapping
    *.rdl | aspnet_isapi.dll version to match your app pool | ActiveReports 13 RDL Script Mapping
  6. Click the Request Restrictions button and ensure that the Invoke handler only if request is mapped to check box is cleared.
  7. Click OK to close the window and add the script mapping.
  8. Repeat for each script mapping in the table above.

Show To add handlers without configuring IIS 7, IIS 8 and IIS 10 using the Classic .NET AppPool

  1. In your Web application, open the Web.config file and add code like the following between the <system.web> and </system.web> tags, changing the ActiveReports Version number on each line to match the version installed on your machine.
    Paste inside the <system.web> tags. Copy Code
    <httpHandlers>
    <add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, GrapeCity.ActiveReports.Web, Version=13.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rdl" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web, Version=13.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web, Version=13.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.Web" type="GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler, GrapeCity.ActiveReports.Web, Version=13.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
</httpHandlers>

  2. In your Web application, open the Web.config file and add code like the following between the <system.webServer> and </system.webServer> tags depending on the .Net Framework version 4.0 installed on your machine.

Show.Net 4.0

Paste inside the <system.webServer> tags. Copy Code
<handlers>
      <add name="AR13Rpx" path="*.rpx" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
      <add name="AR13Rdlx" path="*.rdlx" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
      <add name="AR13Rdl" path="*.rdl" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
      <add name="AR13Web" path="*.Web" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
</handlers>

Note: If you have a 64 bit Web application, change the preCondition attribute on each line to classicMode,runtimeVersionv4.0,bitness64.

Integrated Mode

Show To configure ActiveReports HTTP handlers to enable report linking in your Web applications

  1. In the Control Panel, open Administrative Tools, then Internet Information Services (IIS) Manager.
  2. In the Internet Information Services (IIS) Manager window that appears, in the left pane under Connections, expand the Sites node and select the Web application you want to configure.
  3. In the site's Home pane that appears, under IIS, double-click Handler Mappings.
  4. To the right of the Handler Mappings pane that appears, under Actions, click Add Managed Handler.
  5. In the Add Managed Handler dialog that appears, enter the information from the first row of the table below.
    Request path | Type | Name
    *.Web | GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler | ActiveReports 13 cache item integrated handler mapping
    *.rpx | GrapeCity.ActiveReports.Web.Handlers.RpxHandler | ActiveReports 13 RPX integrated handler mapping
    *.rdlx | GrapeCity.ActiveReports.Web.Handlers.RdlxHandler | ActiveReports 13 RDLX integrated handler mapping
    *.rdl | GrapeCity.ActiveReports.Web.Handlers.RdlxHandler | ActiveReports 13 RDL integrated handler mapping
  6. Click the Request Restrictions button and ensure that the Invoke handler only if request is mapped to check box is cleared.
  7. Click OK to close the window and add the handler mapping.
  8. Repeat for each handler mapping in the table above.

Show To add handlers without configuring IIS 7, IIS 8 or IIS 10 using the DefaultAppPool

In your Web application, open the Web.config file and add code like the following between the <system.webServer> and </system.webServer> tags, changing the ActiveReports Version number on each line to match the version installed on your machine.

Paste inside the <system.webServer> tags. Copy Code
<add verb="*" path="*.Web" type="GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler, GrapeCity.ActiveReports.Web, Version=13.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR13_WebCacheAccessHandler" resourceType="Unspecified" preCondition="integratedMode"/>
<add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, GrapeCity.ActiveReports.Web, Version=13.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR13_RpxHandler" resourceType="Unspecified" preCondition="integratedMode"/>
<add verb="*" path="*.rdl,*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web, Version=13.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR13_RdlxHandler" resourceType="Unspecified" preCondition="integratedMode"/>

Note: If you have a 64 bit Web application, change the preCondition attribute on each line to integratedMode,runtimeVersionv4.0,bitness64.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Print

Print
ActiveReports 13 > ActiveReports User Guide > How To > Print

Glossary Item Box

Learn to perform common tasks with ActiveReports with quick how-to topics.

In this section

Advanced Print Options
Learn how to access and set up the advanced printing options provided with the ActiveReports Viewer.
Print Methods
Learn about various Print methods in ActiveReports.
PDF Print Presets
Learn how to preset basic print options for PDF printing.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Advanced Print Options

Advanced Print Options
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Print > Advanced Print Options

Glossary Item Box

Show All Show All
Hide All Hide All

The advanced printing options in the ActiveReports Viewer, allow you to change page scaling, set page margins and add a watermark when printing a report.

To access the advanced printing options

  1. In the Viewer toolbar, click the Print button. See Windows Forms Viewer for information on the Viewer toolbar.
  2. In the Print dialog that appears, click Advanced.
  3. In the Page Setup dialog that appears, go to the Layout and Watermark tabs to set page scaling, page margins and watermark options.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

To modify page scaling

  1. In the Page Setup dialog, on the Layout tab under the Page Handling group, select a value from the Page Scaling drop-down list.
  2. In case you select Multiple pages per sheet under Page Scaling, you can specify the Pages per sheet and Page Order options.
  3. Click OK to close the dialog.
Note: You may also check the Print page border or Auto-Rotate Pages check box for further customization of your print setup.

To change page margins

  1. In the Page Setup dialog, on the Layout tab under the Margins group, enter values for the Left, Top, Right and Bottom margins.
  2. Click OK to close the dialog.

To add a watermark to the report

  1. In the Page Setup dialog, on the Watermark tab, under the textbox named Text, enter the text you want to display in your watermark.
  2. Select the Font, Size, and Color for the text.
  3. In the Angle field, enter a numeric value between 0 and 360 (A value of 0 renders straight left-to-right text. A value of 180 renders inverted text).
  4. Click OK to close the dialog.

See Also

WPF Viewer

Getting Started
Windows Forms Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Print Methods

Print Methods
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Print > Print Methods

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides access to Print methods to enable printing of page and section reports. You can access Print methods in any of the following ways:

  • Viewer.Print method (using the Viewer control)
  • Print methods in SectionDocument or PageDocument
  • Print methods in the PrintExtension class

Viewer.Print method

The code sample illustrates how to access the print method using the Viewer control.

You can use the Print method of the Viewer class to print a report loaded in the Viewer control. Make sure that the report is loaded completely before Print is executed.

Visual Basic.NET code. Add this code INSIDE the LoadCompleted event of the Viewer Copy Code
Viewer1.Print(True, True, True)

C# code. Add this code INSIDE the LoadCompleted event of the Viewer Copy Code
viewer1.Print(true, true, true);

Print methods in SectionDocument or PageDocument

SectionDocument and PageDocument types have Print methods that can be used directly on the document object. The following code samples illustrate how to access the print methods that can be used directly on the document object.

Note: The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in the GrapeCity.ActiveReports namespace of GrapeCity.ActiveReports.Viewer.Win assembly.

In order to access Print method through SectionDocument or PageDocument class, you need to add GrapeCity.ActiveReports.Viewer.Win reference to the project. Also, as mentioned in the code, make sure that you add a reference for the GrapeCity.ActiveReports namespace in your project using Imports (Visual Basic.NET) or using (C#) statement.

Section Report

Visual Basic.NET code. Paste at the top of the code view. Copy Code
Imports GrapeCity.ActiveReports
Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
Dim rpt = New SectionReport1()
rpt.Run(False)
Dim sectionDocument = rpt.Document
sectionDocument.Print(True, True, False)

C# code. Paste at the top of the code view. Copy Code
using GrapeCity.ActiveReports;
C# code. Paste INSIDE the Form_Load event. Copy Code
var rpt = new SectionReport1();
rpt.Run(false);
var sectionDocument = rpt.Document;
sectionDocument.Print(true, true, false);

Page Report

Visual Basic.NET code. Paste at the top of the code view. Copy Code
Imports GrapeCity.ActiveReports
Visual Basic.NET code. Paste INSIDE the Form_Load event. Copy Code
Dim file_name As String = "..\..\PageReport1.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
pageDocument.Print(True, True, False)

C# code. Paste at the top of the code view. Copy Code
using GrapeCity.ActiveReports;
C# code. Paste INSIDE the Form_Load event. Copy Code
string file_name = @"..\..\PageReport1.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
pageDocument.Print(true, true, false);

Print methods in the PrintExtension class

You can use the Print method of the PrintExtension class to print a report loaded in the Viewer control. Make sure that the report is loaded completely before Print is executed. The following code samples illustrate how to access the print method of the PrintExtension class.

Note: The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in the GrapeCity.ActiveReports namespace of GrapeCity.ActiveReports.Viewer.Win assembly.

In order to access Print method through SectionDocument or PageDocument class, you need to add GrapeCity.ActiveReports.Viewer.Win reference to the project. Also, as mentioned in the code, make sure that you add a reference for the GrapeCity.ActiveReports namespace in your project using Imports (Visual Basic.NET) or using (C#) statement.

Section Report

Visual Basic.NET code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(sectionDocument, True, True)

C# code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(sectionDocument, true, true);

Page Report

Visual Basic.NET code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(pageDocument, True, True)

C# code. Paste INSIDE an event like Button_Click. Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(pageDocument, true, true);

See Also

Getting Started
Windows Forms Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


PDF Print Presets

PDF Print Presets
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Print > PDF Print Presets

Glossary Item Box

Show All Show All
Hide All Hide All

To economize your efforts each time a PDF document is printed, you can preset basic print options when exporting a report to a PDF format.

Note: The print preset properties are only available with the Professional Edition license. An evaluation message is displayed when used with the Standard Edition license.

In both Page/RDL and Section reports, you can set the PDF Print Preset properties using the Export dialog or through the code. The PDF print preset properties are available in the Export dialog of the following viewers.

  • Standalone Designer
  • End-User Designer
  • Web Viewer
  • HTML5 Viewer
  • WPF Viewer

To set PDF print presets using the Export dialog

  1. Open the Export dialog.
  2. In the Export Format field of the Export dialog, select Portable Document Format (PDF).

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  3. Expand PrintPresets options and set the required properties for print presets.
    Note: These properties are available in PDF version 1.7 or higher. The PageScaling property is supported in PDF version 1.6.
  4. Click OK to close the dialog.

To set PDF print presets through code

  1. From the Visual Studio File menu, select New, then Project.
  2. In the New Project dialog that appears, under language VB.NET or C#, click the Reporting node.
  3. Select the type of report application that you want to add:
    • ActiveReports 13 Page Report Application
    • ActiveReports 13 RDL Report Application
    • ActiveReports 13 Section Report Application (xml-based)
  4. In the Name field, enter a name for the report application, and click OK. The selected report type is added to your project.
  5. In the Design view, double-click the Form title bar to create the Form_Load event.
  6. Add the following code to invoke the Export methods and set print presets in the Form_Load event.

    Show Section Report

    Visual Basic.NET code. Paste INSIDE the Form_Load event Copy Code
    Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\..\..\SectionReport1.rpx")
sectionReport.LoadLayout(xtr)
sectionReport.Run()

'Define settings for PDF
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport()
p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf17

'Set default print settings using PrintPresets class
p.PrintPresets.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None
p.PrintPresets.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge
p.PrintPresets.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two
p.PrintPresets.PaperSourceByPageSize = True
p.PrintPresets.PrintPageRange = "1-3"
p.Export(sectionReport.Document, Application.StartupPath + "\PrintPresets.pdf")

    C# code. Paste INSIDE the Form_Load event Copy Code
    GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + @"\..\..\SectionReport1.rpx");
sectionReport.LoadLayout(xtr);
sectionReport.Run();

//Define settings for PDF
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf17;

//Set default print settings using PrintPresets class
p.PrintPresets.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None;
p.PrintPresets.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge;
p.PrintPresets.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two;
p.PrintPresets.PaperSourceByPageSize = true;
p.PrintPresets.PrintPageRange = "1-3";
p.Export(sectionReport.Document, Application.StartupPath + "\\PrintPresets.pdf");

    Show Page/RDL Report

    Visual Basic.NET code. Paste INSIDE the Form_Load event Copy Code
    'Set the rendering extension and render the report.
Dim pdfExport = New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()

'Define settings for PDF
Dim pdfSettings As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
pdfSettings.Version = GrapeCity.ActiveReports.Export.Pdf.Page.PdfVersion.Pdf17
pdfSettings.PrintOnOpen = True

'Set default print settings using PrintPresets class
Dim pdfPresetsSetting As New GrapeCity.ActiveReports.Export.Pdf.PrintPresets()
pdfPresetsSetting.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None
pdfPresetsSetting.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge
pdfPresetsSetting.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two
pdfPresetsSetting.PaperSourceByPageSize = True
pdfPresetsSetting.PrintPageRange = "1-3"

pdfSettings.PrintPresets = pdfPresetsSetting

Dim outputFile = New IO.FileInfo("..\..\PrintPresets.pdf")
Dim reportFile = New IO.FileInfo("..\..\PageReport1.rdlx")

Dim fileStreamProvider = New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputFile.Directory, Path.GetFileNameWithoutExtension(outputFile.FullName))

Using pageDocument = New GrapeCity.ActiveReports.PageReport(reportFile).Document
    pageDocument.Render(pdfExport, fileStreamProvider, pdfSettings)
End Using
    C# code. Paste INSIDE the Form_Load event Copy Code
    //Set the rendering extension and render the report.
var pdfExport = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();

//Define settings for PDF
GrapeCity.ActiveReports.Export.Pdf.Page.Settings pdfSettings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
pdfSettings.Version = GrapeCity.ActiveReports.Export.Pdf.Page.PdfVersion.Pdf17;
pdfSettings.PrintOnOpen = true;

//Set default print settings using PrintPresets class
GrapeCity.ActiveReports.Export.Pdf.PrintPresets pdfPresetsSetting = new GrapeCity.ActiveReports.Export.Pdf.PrintPresets();
pdfPresetsSetting.PageScaling = GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling.None;
pdfPresetsSetting.DuplexMode = GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode.DuplexFlipLongEdge;
pdfPresetsSetting.NumberOfCopies = GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies.Two;
pdfPresetsSetting.PaperSourceByPageSize = true;
pdfPresetsSetting.PrintPageRange = "1-3";

pdfSettings.PrintPresets = pdfPresetsSetting;

var outputFile = new System.IO.FileInfo(@"..\..\PrintPresets.pdf");
var reportFile = new System.IO.FileInfo(@"..\..\PageReport1.rdlx");

var fileStreamProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputFile.Directory,
System.IO.Path.GetFileNameWithoutExtension(outputFile.FullName));

using (var pageDocument = new GrapeCity.ActiveReports.PageReport(reportFile).Document)
{
    pageDocument.Render(pdfExport, fileStreamProvider, pdfSettings);
}

See Also

Advanced Print Options

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Use Fields in Reports

Use Fields in Reports
See Also
ActiveReports 13 > ActiveReports User Guide > How To > Use Fields in Reports

Glossary Item Box

Show All Show All
Hide All Hide All

Fields provide data to display on a report page. ActiveReports has two types of fields; a bound or database field and a calculated field.

  • Bound or Database field: A field where the value is returned by a query. See the Query dropdown in the Dataset Dialog for further information on queries in page reports and RDL reports.
  • Calculated field: A field where the value is an expression created with functions, formulas and operators. Use the following instructions to add calculated fields in a report.

To create a calculated field in a Section Report

In a section report, once you connect to a data source, bound fields automatically appear under the Fields > Bound node in the Report Explorer. However, you have to add calculated fields manually under the Fields > Calculated node. The following steps guide you through the process.

  1. In the Report Explorer, expand the Fields node.
  2. Right-click the Calculated node and select Add. This action creates an unbound field with a default name like field1.

  3. In the Report Explorer, with field1 selected, go to the Properties Window and set a value for the field in the Formula property. For e.g., for a calculated field Inventory, in the Formula field, enter the expression =UnitsInStock - ReorderLevel.

    You can change the name of the field in the Name property.
  4. Drag the field from the Calculated node onto the detail section of the report. This action creates a TextBox object, and sets its DataField property to the name of the calculated field.
Note: You can also add C# expressions in a Bound Field's DataField property to modify it. See Add Field Expressions for more information.

To create a calculated field in a Page Report/RDL Report

In a page report or a RDL report, all fields irrespective of their type appear under the corresponding DataSet node in the Report Explorer. To create a calculated field, you can add the new field in the DataSet dialog.

The following steps guide you through the process.

Note: These steps assume that you have added a DataSet in your report. See Add a Dataset for further information.
  1. In the Report Explorer, right-click the data set node and select Edit.
  2. In the DataSet dialog that appears, go to the Fields page and click the Add (+) button to add an empty field to the list.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  3. Under Name, enter the name of the field. By default it appears as Field1.
  4. Under Value, click the dropdown arrow and select <Expression...>, to open the Expression Editor dialog.
  5. In the Expression Editor dialog, create an expression you want to use as the value for the calculated field. For e.g., for a calculated field Cost, in the Formula field, enter the expression =[Quantity]*[Price]. See Expressions for further information.
  6. Click OK to close the Expression Editor and then the DataSet dialogs.
  7. From the Report Explorer, drag the calculated field from that now appears as a field under the DataSet node onto the design surface. This action creates a TextBox object, and sets its Value property to the name of the calculated field expression.

See Also

Add Field Expressions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Samples and Walkthroughs

Samples and Walkthroughs
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs

Glossary Item Box

To understand some of the more complex tasks you can accomplish using ActiveReports, you can open included sample projects, or you can follow walkthroughs, step-by-step tutorials that walk you through every step required to create a specific type of report.

This section contains information about

Samples
Browse brief descriptions of included samples, and follow links that open sample projects in Visual Studio.
Walkthroughs
Look through tutorials that teach you all of the steps involved in creating various types of ActiveReports projects, from the basic report through more complex unbound reports and Web options.

See Also

Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Samples

Samples
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples

Glossary Item Box

Learn about the samples provided with the ActiveReports installation standard and professional editions. The samples folder is located at the following location:

[User Documents folder]\GrapeCity Samples\ActiveReports 13

Each sample has a C# and a Visual Basic.NET code example for Visual Studio. You can also see the comments within the sample projects throughout code.

This section explains about samples, grouped by features, as follows:

Advanced
The samples under this folder demonstrate advanced features in Page, RDL, and Section reports.
API
The samples under this folder demonstrate creating reports and implementing various features through code in Page, RDL, and Section reports.
DataBinding
The samples under this folder demonstrate binding data with various data providers in Page, RDL, and Section reports.
Designer Pro
The samples under this folder demonstrate features provided with the ActiveReports professional edition.
Desktop
The samples under this folder demonstrate samples based on desktop viewers.
Web
The samples under this folder demonstrate working with web based reports.

See Also

Walkthroughs
Samples and Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Advanced

Advanced
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced

Glossary Item Box

The samples in the Advanced folder describe advanced features separately for:

  • Page and RDL Reports
  • Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page and RDL Reports

Page and RDL Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports

Glossary Item Box

This section discusses following samples describing various features in Page and Rdl reports:

Calendar
This sample demonstrates using Calendar data region in reports.
Custom Chart
This sample demonstrates using custom report item - Radar chart in a report.
Custom Data Provider
This sample demonstrates how to create a project using custom data provider and how to pull data from a comma separated value (CSV) file.
Custom Pdf Export
This sample demonstrates exporting reports to PDF format using third-party assemblies.
Custom Resource Locator
This sample showcases a custom implementation of the resource locator to load pictures from the user's "My Pictures" directory.
Custom Tile Provider
This sample demonstrates how to create a custom tile provider.
Svg Image
This sample illustrates using SVG as image format in ActiveReports.
RTF Control
This sample illustrates using RTF control in Page/RDL reports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Calendar

Calendar
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > Calendar

Glossary Item Box

The Calendar control is now moved to samples to allow customers to continue using this data region for displaying date-based data or events in a calendar format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\Calendar

Details

This sample consists of following projects; all data and files are taken from the Calendar data region itself:

  • CalendarComponent: It implements ICustomReportItem interface to render Calendar, IDataRegion interface for data binding, and IImageRenderer interface to render calendar content range to the canvas.
  • CalendarDesigner: The designer is inherited from CustomReportItemDesigner class. It implements property initialization, glyph drawing, and evaluation utils.
  • TestDesignerPro: This is the default start up project. On running this project, an RDL report with a calendar is displayed on the designer. You can also drag and drop and use the Calendar data region available on the toolbox.
  • TestViewer: On running this project, a calendar is rendered on Windows Forms Viewer.
  • Tests: It contains code for proper functioning of the sample.

Customers who are required to use calendar should now compile and distribute CalendarComponent and CalendarDesigner assemblies. Binding should be done through GrapeCity.ActiveReports.config file (see test applications).

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Chart

Custom Chart
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > Custom Chart

Glossary Item Box

This sample illustrates creating custom report item - Radar Chart. The ICustomReportItem interface is used to implement custom control, which is radar chart. The designer inherited from CustomReportItemDesigner class allows the chart to be available on the designer. The sample uses shared data source Nwind.rdsx.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomChart\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomChart\C#

Details

When you run this sample, an RDL report 'Radar.rdlx' with Radar chart is displayed on the designer. Go to the Preview tab of the designer to view the report with data pulled from Nwind.rdsx.

The sample consists of following projects:

  • RadarChart: It implements ICustomReportItem interface to render Radar chart and IDataRegion for data binding. The IImageRenderer interface renders data to image; this renderer accesses custom data grouping (note that series property name should be same as that defined in designer) and reads values for the chart series.

  • RadarDesigner: The designer is inherited from CustomReportItemDesigner class. To render one series, one data grouping is added in the Initialize method. Custom properties called DataSetName and SeriesValue are added which can be changed in the designer, see classes DataSetNamesConverter and RadarValuesConverter. For design-time rendering, RadarControlGlyph class implements overriding ControlGlyph property of the designer and rendering stub data. In this glyph, the MovableBehavior method implements moving and resizing of the chart control.

  • TestDesignerPro: This is the default start up project. On running this project, an RDL report with Radar chart is displayed on the designer. You can change the chart properties from the Properties pane. You can also drag and drop and use the Radar Chart control available on the toolbox.

  • TestViewer: On running this project, Radar chart is rendered on Windows Forms Viewer.

The custom report item (RadarChart) and its designer (RadarDesigner) are defined in GrapeCity.ActiveReports.config file placed in test application projects.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Data Provider

Custom Data Provider
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > Custom Data Provider

Glossary Item Box

The Custom Data Provider sample demonstrates how to create a project that use a custom data provider and how to pull data from a comma separated value (CSV) file. This sample is part of the ActiveReports Professional Edition.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomDataProvider\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomDataProvider\C#

Details

When you run this sample, a DesignerForm displaying the DemoReport.rdlx report in ActiveReports Designer and a HelperForm explaining the steps to connect a report to the comma separated value (CSV) file appears.

In the ActiveReports Designer, you can add a dataset with a comma separated values (CSV) file. For adding this file,in the Report Explorer, expand the DataSources node, right-click the node for the data source and select Add DataSet. In the DataSet dialog that appears, under Query section, go to the Query String field and click the drop-down arrow to display the custom query editor. In the custom query editor, click the Select CSV File button and select the Categories.csv file kept within the project.

Go to the Preview tab of the Designer to view the report with the data pulled from the custom data provider.

The sample consists of following three projects:

CustomDataProvider: It contains following items:

  • CsvColumn: This class represents information about fields in the data source.
  • CsvCommand: This class provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
  • CsvConnection: This class provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
  • CsvDataProviderFactory: This class implements the DataProviderFactory for .NET Framework CSV Data Provider.
  • CsvDataReader: This class provides an implementation of IDataReader for the .NET Framework CSV Data Provider.

CustomDataProviderUI: It contains following items:

  • CSVFileSelector: This is the form that contains the Select CSV File button. This button is displayed in the CSV data provider query editor when you open the DataSet dialog and under Query, in the Query String field and click the drop-down arrow to display the custom query editor. Clicking the Select CSV File button allows you to select the Categories.csv file that is used as a custom data provider for the sample report.
  • QueryEditor: This is the class that reads the content of the specified file and builds the CSV data provider query string.

CustomDataProviderUITest: It contains following items:

  • Categories.csv: This is the comma separated values (CSV) file that serves as a custom data provider for the sample report. This file is selected in the Please, select CSV File dialog that appears when you click the Select CSV File button in the Query String field under Query in the DataSet dialog.
  • DemoReport.rdlx: The DemoReport.rdlx displays the custom data. This report contains one Table data region with the TextBox controls, which display the name, the role and the city information of an employee.
  • DesignerForm: This is the main form of this sample that appears when you run the sample. On this form, you can connect the sample report to a custom data provider by adding a dataset with a comma separated values (CSV) file. Right-click the form and select View Code to see the code implementation for the ActiveReports Designer.
  • Grapecity.ActiveReports.config: The configuration file that configures the project to use the custom data provider.
  • HelperForm: This form appears on top of the main DesignerForm when you run the sample. This form contains the explanatory text with the steps on how to bind the sample report to the comma separated value (CSV) file. You can close the Help form by clicking the X button in the upper-right corner of the form.

See Also

ActiveReports Designer

Walkthroughs
Custom Data Provider

How To
Add a Dataset

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Pdf Export

Custom Pdf Export
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > Custom Pdf Export

Glossary Item Box

This sample shows how to implement simple exports to custom formats (which is not available in ActiveReports right now). The sample uses third-part library to show export to PDF.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomPdfExport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomPdfExport\C#

Details

When you run this sample, you see a testing application form, which splits to Windows Forms Viewer and PDF Viewer. You can choose a report and a Pdf export option, click 'Preview as PDF' and view the report in the viewers, and 'Save as PDF' to save the report as Pdf. The sample consists of following projects:

  • PdfRendering: It implements IRenderingExtension and IDrawingCanvas interfaces for customized export to PDF format.
  • TestApplication: This is the default start up project to compare and debug custom export.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Resource Locator

Custom Resource Locator
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > Custom Resource Locator

Glossary Item Box

The Custom Resource Locator sample demonstrates a custom implementation of the resource locator to load pictures from the user's Pictures or My Pictures directory. In general, you can use a resource locator in a report to find any resources that a report may require.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomResourceLocator\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomResourceLocator\C#

Details

When you run this sample, you see the MainForm with the list of images from the Pictures or My Pictures directory. Select any image and click the Show Report button. A report with the selected image opens in the PreviewForm.

Caution: To run this sample properly, you must have image files in your pictures directory. If the directory does not contain any pictures, you should add them to the folder manually.

The sample consists of:

  • Resources folder: This folder contains the Description.rtf file that contains a summarized content of the resource locator that gets displayed inside the RichTextBox control on the MainForm at run time. This folder also contains the NoImage.bmp image file that is used if there is no image in the pictures directory.

  • DemoReport.rdlx: The DemoReport.rdlx displays the selected image. This report contains two TextBox controls and one Image control, which display the image name, the image type and the image at run time after you click the Show Report button on the MainForm.

  • MainForm: This is the main form of this sample that appears when you run the sample. This form contains the RichTextBox, the ListView and the Button controls. The RichTextBox control displays the summarized information saved in the Description.rtf file about the resource locator and the sample. The ListView control gets populated with the images located in the My Pictures directory; the Button control is used to generate the report with the selected image. Right-click the form and select View Code to see how to load text in the RichTextBox control and images in the ListView control. It also contains code that displays the DemoReport.rdlx on the showReport_Click event.

  • MyPicturesLocator: This file is an internal class that contains code that looks for resources in the My Pictures directory.
  • PreviewForm: This form uses the ActiveReports Viewer control to display the DemoReport.rdlx with the selected image. Right-click the form and select View Code to see how to load the report into the Viewer.

See Also

DataSet DataSource
Reports Gallery

Getting Started
Windows Forms Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Tile Provider

Custom Tile Provider
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > Custom Tile Provider

Glossary Item Box

The CustomTileProvider sample demonstrates how to create a custom tile provider using IMapTileProvider and IMapTile interface and configure it in a Map Control which is placed on a RDL report. This sample makes use of two projects - CustomTileProviders and TileProviderEndUserDesigner in a single Visual Studio solution. The CustomTileProviders project contains the tile server configurations for the tile providers, whereas the TileProviderEndUserDesigner project references the created CustomTileProviders project assemblies.

Note: CustomTileProvider is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomTileProvider\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\CustomTileProvider\C#

Details

When you run this sample, the ActiveReports End User Designer appears with an overlaying Help-Creating a Custom Tile Provider dialog. This dialog gives you step-by-step instructions to create a new tile provider for a Map control with custom settings.
The End User Designer displays a RDL report containing a Map control with MapQuest set as the default tile provider. To change the existing tile provider, double-click on the Map control to display the existing tile layer and right click to select Edit. In the Map Tile Properties - General dialog that appears, click the Provider drop-down to select the tile provider you want to apply to the Map control. Go to the Preview tab to view the data in the selected tile provider. You can choose from the following tile provider options:

  • Google-Sample
  • Cloud-Made Sample
  • MapQuest-Sample
  • OpenStreetMap-Sample
Note: The Microsoft Bing Map server offers static map images. This requires an Application key for authentication. The default key provided by ActiveReports is for demo purpose and can not be used by 3rd party applications. In order to obtain a Bing Map Key, see HowTo - Create a Bing Map Account and HowTo - Generate a Bing Map Key.

The sample consists of two projects:

CustomTileProviders: It contains following classes:

  • CloudMadeTileProvider: This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://cloudmade.com.

  • GoogleMapsTileProvider: This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://maps.google.com.

  • MapQuestTileProvider: This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://www.mapquest.com.

  • MapTile: This class represents a single map tile, implementing the IMapTile interface. For more information on ImapTile interface, see Add a Custom Tile Provider.

  • OpenStreetMapTileProvider: This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://www.openstreetmap.org.

  • WebRequestHelper: This class picks the raw data from the tile providers and loads them into the System.IO.MemoryStream class.

TileProviderEndUserDesigner: It contains following files:

  • CustomTileProvider.rdlx: This report contains the Map control that visualizes the oil production in different parts of the world on a virtual earth background. The map control uses the color rule set on a polygon layer to differentiate parts of world as per their oil production capacity. These colors are defined using a color rule which is described in the legend at run time. The report gets the data from Factbook.rdsx shared data source.

  • DesignerForm.cs: This is the main form that gets displayed when you run the sample. This form uses multiple controls like the ToolStripPanel, ToolStripContainerPanel, SplitContainer, Designer, Toolbox, ReportExplorer and PropertyGrid controls to create a customized End User Designer. It also contains code to load CustomTileProvider.rdlx report into the Designer.

  • GrapeCity.ActiveReports.config: This configuration file contains the settings for the various tile providers, and is located in the same folder as the EndUserDesigner.exe file for the tile provider settings to work.

  • HelperForm.cs: This form uses the HelperForm class to display a screen containing step-by-step instructions for the user to create a custom tile provider.

See Also

How To
Add a Custom Tile Provider

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Svg Image

Svg Image
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > Svg Image

Glossary Item Box

This sample illustrates using SVG (Scalable Vector Graphics) as image format in ActiveReports through third-party assembly, Svg (SVG Rendering Library, see in NuGet packages). The use of SVG for rendering improves the precision of graphics significantly, so that even complex graphics look sharp and crisp.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\SvgImage\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\SvgImage\C#

Details

When you run this sample, an RDL report with an SVG image is displayed. You may need to install Svg library; the steps are as follows:

  1. Open "Package Manager Console".
  2. Use "Install-Package -Id Svg" command.
  3. Select the project in the Solution Explorer and click Refresh in toolbar.

The sample consists of the following projects:

  • SvgImage: It implements IReportItem and IGraphicsRenderer interfaces to create custom SVG image report item, SvgImage.

  • SvgDesigner: The designer is inherited from CustomReportItemDesigner class. For design-time rendering, SvgControlGlyph class implements overriding ControlGlyph property of the designer. In this glyph, the MovableBehavior method implements moving and resizing of the Svg Image control.

  • TestDesignerPro: This is the default startup project. On running this project, an RDL report with an SVG image is displayed on the designer. You can change its properties from the Properties pane. You can also drag and drop and use the SVGImage control available on the toolbox.

  • TestViewer: On running this project, an SVG image is rendered in the Windows Forms Viewer.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


RTF Control

RTF Control
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Page and RDL Reports > RTF Control

Glossary Item Box

This sample shows using a custom control, RichTextBox, to preview RTF directly in Page/RDL reports without need for conversion to HTML.

Just drag and drop the RichTextBox control to the design area, press F2 or Enter or double click the control to enable edit mode, and input the RTF.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\RtfControl\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\PageAndRDL\RtfControl\C#

Details

To run the sample, set TestViewer or TestDesignerPro as startup project.

  • TestDesignerPro: This is the default startup project. On running this project, an RDL report with RichTextBox is displayed on the designer. You can change its properties from the Properties pane or use the control available on the toolbox.
  • TestViewer: On running this project, an RichTextBox is rendered in the Windows Forms Viewer.

Note that this sample is implemented based on WinForms RichTextBox control that provides display features similar to WordPad RTF, such as:

  • Images
  • Color text and background
  • Font size and styles
  • Text alignment
  • Standard commands like copy/paste and undo/redo

The following hotkeys and shortcuts are supported in edit mode:

  • Ctrl + A: Select all content
  • Ctrl + C: Copy selected content
  • Ctrl + X: Cut selected content
  • Ctrl + V: Paste content from clipboard
  • Ctrl + B: Toggle bold style of selected text
  • Ctrl + I: Toggle italic style of selected text
  • Ctrl + U: Toggle underline style of selected text
  • Ctrl + T: Toggle strikeout style of selected text
  • Ctrl + Z: Undo
  • Ctrl + Shift + Z or Ctrl + Y: Redo
  • Ctrl + Backspace: Delete the word left to the cursor
  • Ctrl + Delete: Delete the word right to the cursor
  • Escape: Exit edit mode without saving changes
  • Alt + Enter: Exit edit mode with saving changes

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Reports

Section Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Section Reports

Glossary Item Box

This section discusses following samples describing various features in Section reports:

CustomDrillThrough
Demonstrates using hyperlinks and the viewer hyperlink event to simulate drill-down from one report to another.
CustomWordExport
Demonstrates exporting Section report to Word format using third-party assemblies.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Drill Through

Custom Drill Through
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Section Reports > Custom Drill Through

Glossary Item Box

The Hyperlinks and DrillThrough sample consists of three reports and a ViewerForm. The reports use the Hyperlink event of the Viewer control to pass a value from the Hyperlink property of a TextBox control to a Parameter value in a more detailed report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\Section\CustomDrillThrough\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\Section\CustomDrillThrough\C#

Details

When you run this sample, a report displaying bound fields with a link created on CustomerID is displayed in a Viewer control. DrillThrough feature allows users to navigate to another report containing detailed data. Clicking the CustomerID hyperlink takes you to the second report which displays detailed information of the selected CustomerID. On further clicking the OrderID hyperlink the third report displaying the details of the selected order is opened in the Viewer. This feature enables the users to systematically go through the detailed data of the desired CustomerID.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

The sample consists of:

ViewerForm: This form contains only the Viewer control. Right-click the form and select View Code to see the code that allows multiple ViewerForms to display for the reports, and see the Form Load event for the code that loads the main report into the viewer. See the Viewer Hyperlink event for the code that collects a string value from the Hyperlink property of the clicked TextBox on the main report and passes it into the customerID Parameter of the report DrillThrough1, or collects a numeric value and passes it to the orderID Parameter of the report DrillThrough2. This code then runs the report with the parameter value and displays it in another instance of the ViewerForm.

DrillThroughMainReport: The main report that is loaded in the ViewerForm by default uses the PageHeader and Detail sections.

  • PageHeader section: This section contains three Label controls to serve as column headers for the details, and a CrossSectionBox control. For more information, see Cross Section Controls.

  • Detail section: The Detail section has the BackColor property set to Thistle, and its RepeatToFill property set to True. This ensures that the background color reaches all the way to the bottom of the page when there is not enough data to fill it. Right click on the form, select View code to see the Connection String and SQL Query that provide data for the bound fields. The Detail section has three bound TextBox controls that display a list of customer information. Select CustomerID and you will see that the HyperLink property is not set in the Properties window. To see the code that assigns the data from the TextBox to its HyperLink property, right-click the report and select View Code. The HyperLink property is set in the Detail BeforePrint event.

  • PageFooter Section: This section is not in use, so it is hidden by setting the Visible property to False. This section cannot be deleted, because its related PageHeader section is in use.
    Note: This hyperlink does not work in Preview mode, because it relies on code in the ViewerForm to pass the value to DrillThrough1 report's parameter.

DrillThrough1 Report: This report looks similar to the DrillThroughMain report, but the main difference is that it has a CustomerID parameter in its SQL Query.

  • GroupHeader section: Since this report only displays order information for the CustomerID from the clicked hyperlink, the PageHeader section could have been used, but this report uses the GroupHeader section. To make this section print at the top of each page, the RepeatStyle property is set to OnPage. This section consists of five label controls to serve as column headers for the Detail section and a CrossSectionBox control.

  • Detail section: Right click on the form, select View code to see the parameter in the SQL Query that collects the value from the ViewerForm. Parameters in SQL Queries are denoted by the <% and %> symbols that trigger ActiveReports to add them to the report's Parameters collection. For more information, see Parameters. The Detail section has five bound TextBox controls that display a list of order information for the customer. Select OrderID and you will see that the HyperLink property is not set in the Properties window. To see the code that assigns the data from the TextBox to its HyperLink property, right-click the report and select View Code. The HyperLink property is set in the Detail BeforePrint event.

  • GroupFooter section: This section is not in use, so it is hidden by setting the Visible property to False. This section cannot be deleted, because it is related GroupHeader section is in use.

DrillThrough2 Report: Like DrillThrough1, this report has a parameter in a SQL Query, but unlike the other two reports, this one has no hyperlink. It displays order details for the OrderID value passed into it from the clicked hyperlink in DrillThrough1.

  • GroupHeader section: Like in the previous report, this section contains Label controls to serve as column headers for the details, and a CrossSectionBox control.

  • Detail section: Right click on the form, select View code to see the parameter in the SQL Query that collects the value from the ViewerForm.

See Also

How To
Create Common Section Reports
Add Hyperlinks

Concepts
Section Report Events

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Word Export

Custom Word Export
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Advanced > Section Reports > Custom Word Export

Glossary Item Box

This sample shows how to export Section report to Word (DOCX) format using third party assemblies.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\Section\CustomWordExport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Advanced\Section\CustomWordExport\C#

Details

When you run this sample, a Windows Form is displayed that prompts you to select the report type and the Word export format type. Please note that we are not going to support any third party assemblies or projects. This sample demonstrates the idea on creating custom exports to satisfy different requirements.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


API

API
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API

Glossary Item Box

The samples in the API folder describe creating reports and implementing various features through code in Page, RDL, and Section reports.

  • Page and RDL Reports
  • Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page and RDL Reports

Page and RDL Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Page and RDL Reports

Glossary Item Box

This section contains:

CreateReport
This sample demonstrates how to create a page report layout in code. It further shows creating a table control, adding table rows and table columns inside it, adding cells inside the table rows and columns and adding text boxes inside the cells.
DigitalSignaturePro
This sample demonstrates how to add digital signatures when exporting to PDF format.
Export
This sample demonstrates how to export Page and RDL reports to different export formats.
Layer
This sample demonstrates how to use Layers in a report.
ReportWizard
This sample demonstrates how to create a custom Report Wizard that allows you to select a report from the list of multiple reports and then allows you to select the data that you want to display in the selected report.
Stylesheets
This sample demonstrates how to work with embedded and external style sheets in Page and RDL reports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Create Report

Create Report
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Page and RDL Reports > Create Report

Glossary Item Box

The Create Report sample demonstrates how to create a RDL report using code and display it in the ActiveReports Designer.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\CreateReport\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\CreateReport\C#

Details

When you run this sample, the ActiveReports Designer appears with a RDL report that is bound to a database. To view the report, go to the Preview tab of the Designer.

Note: To run this sample, you must have access to the Reels.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

The sample consists of:

ReportsForm: This is the main form of the sample that contains the Designer, ReportExplorer, PropertyGrid, Toolbox and ToolStrip controls, used to create the ActiveReports Designer at run time. See Creating a Basic End User Report Designer (Pro Edition) for information on creating a basic ActiveReports Designer. Right-click the form and select View Code to see how to set up the Designer and attach the ReportExplorer, PropertyGrid and Toolbox controls to it. It also contains code that loads a layout created in the LayoutBuilder class to a page report object; then loads the page report object to a stream, which is loaded to the Designer.

Constants: This file is an internal class that contains string values that are required for creating a dataset of the report.

Layout: This file is an internal class that contains code for creating a RDL report layout and adding a data source and a dataset to it.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Digital Signature Pro

Digital Signature Pro
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Page and RDL Reports > Digital Signature Pro

Glossary Item Box

This sample demonstrates how you can digitally sign or set time stamp for a page/rdl report when exporting it to PDF format using the PDF Rendering Extension.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\DigitalSignaturePro\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\DigitalSignaturePro\C#

Details

When you run this sample, the Invoice report is displayed in the Viewer control.

Clicking the Generate Digitally Signed PDF button in the Viewer toolbar creates a PDF file with a time stamp or digital signatures, based on the settings you have specified in the Viewer toolbar. You can change the content of signatures in the Signature Format box and you can add the time stamp to the generated pdf file by checking the Set TimeStamp checkbox, in the Viewer toolbar.

When you click the Generate Digitally Signed PDF button, a dialog for saving the destination file appears. After you indicate the location for a new PDF file, the PDF report file is created. Digital signature certificates dynamically reference and use GrapeCity.pfx, included in the project. Also, digital signatures dynamically load and use the gc.bmp file that you can find in the Image folder of this sample project.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.
  • Image folder: This folder stores the gc.bmp file with the GrapeCity logo that digital signatures dynamically load and use.
  • Catalog report: It shows a multi page layout spread over four pages in the report. The layout in Page1 and Page2 contains Image, Label and Textbox controls to display introductory text. The layout on Page3 contains a List data region with TextBox controls and a Table to display product details for each product category. The layout on Page4 uses Textbox, Shape and Line controls amongst others to create an Order Form, which a user is to fill manually.
  • GrapeCity.pfx: In order to create a digital signature, you must have a valid PKCS#12 certificate (*.pfx) file. For information on creating a self-signed certificate, see the Adobe Acrobat Help topic "Create a self-signed digital ID."
    You can also create a PFX file from the Visual Studio command line. For more information and links to SDK downloads, see http://www.source-code.biz/snippets/vbasic/3.htm.
  • PDFDigitalSignature form: This is the main form of the Sample that uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains the Create Digitally Signed PDF button, the Signature Format box with the drop-down list and the Set TimeStamp checkbox.

    Clicking the Generate Digitally Signed PDF button opens a dialog for saving the destination file. After you indicate the location for a new PDF file, the PDF report file is created.

    The drop-down list of the Signature Format box contains the following options.

    • Invisible - the invisible pdf digital signature.
    • Text - the pdf digital signature that contains text only.
    • Image - the pdf digital signature that contains graphics only.
    • ImageText - the pdf digital signature that contains text and graphics.

    Checking the Set TimeStamp checkbox allows you to add the time stamp to the signature of the generated pdf file. The time stamp contains the Time Stamp Server address, its login and password information.

    Right-click PDFDigitalSignature in the Solution Explorer and select View Code to see the code implementation for the pdf digital signature options.

  • Resource.resx: This file contains the string for the message box that appears after the PDF file is generated and the string for the message box that appears when the free service limitation is exceeded.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Export

Export
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Page and RDL Reports > Export

Glossary Item Box

This sample illustrates how to export to different export formats using code. The available export formats are PDF, XLSX, CSV, DOCX, MHT and JSON.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\Export\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\Export\C#

Details

When you run this sample, the Export Form is displayed. The Export Form contains the Report Name and Export Type combo boxes along with the Export button.

The sample consists of ExportForm. It exports the selected report in the selected export format.
On running the application, select a report for export in the Report Name combo box. In the Export Type combo box, you can select one of the following formats for export - PDF, XLSX, CSV, DOCX, MHT and JSON. Clicking the Export button opens the Save As dialog where you can specify the name of the exported file. By default, the exported file is saved in the Documents folder.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Layer

Layer
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Page and RDL Reports > Layer

Glossary Item Box

The Layer sample demonstrates how to work with Layers in four different reporting scenarios.

  • Sample Location
  • Run-Time Features
  • Project Details

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET Copy Code
<User Folder>\GrapeCity Samples\ActiveReports 13\Page Reports And RDL Reports\API\Layer\VB.NET
C# Copy Code
<User Folder>\GrapeCity Samples\ActiveReports 13\Page Reports And RDL Reports\API\Layer\C#

Run-Time Features

When you run this sample, the End User Designer shows a list of .rdlx reports on the bottom left of the form. Expand the Reports node to view reports under it and double-click a report to load it into the designer. Once the report is loaded in the designer, a Layers List window showing all the Layers used in the report is displayed as a tab next to the Report Explorer tab. See Working with Layers for further details on the Layers List window.

Project Details

ReportForm

This is the main form that appears when you run the Layers sample. This form uses controls such as Designer, ReportExplorer, LayerList, Toolbox, PropertyGrid, ToolStripPanel, ToolStripContentPanel and TreeView to create a customized report designer.

Right-click the form and select View Code to see how to set up the report designer. It also contains code that adds reports to the TreeView control, loads a report into the Designer when it is double-clicked in the Reports node, and shows the Layer List window if the report type is Page or RDL.

Reports Folder

AccountStatementSheet.rdlx: This report uses the XML data source connection to provide custom data. Controls such as Image, FormattedTextBox, Table and Label are used to display the statement of an account holder. The FormattedTextBox control contains text in HTML tags to display the content.

This report is contains three Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
Default | All | This is a default layer. It does not contain any control.
Layer1 | Screen | Contains the Header and Footer section.
Layer2 | Screen, Paper | Contains a FormattedTextBox control to display the account information of the account holder.
Layer3 | All | Contains a Table data region and an OverflowPlaceHolder control to display the account transactions.

SalesRevenueReport.rdlx: This report uses the Reels shared data source connection to provide the data. The layout of the report uses a Chart data region to graphically display sales and profit for each month and two Table data regions to display the chart data. The first Table data region (Layer2) contains the sales revenue for each month and the second Table data region (Layer3) lists down the detailed figures for the monthly sales along with a DataBar to visually depict the profits.

This report contains three Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
Default | All | This is a default layer. It does not contain any control.
Layer1 | All | Contains a Chart data region to display the annual sales by month.
Layer2 | Paper | Contains a Table data region to display the sales by month. Visibility of this Layer has been set to hidden.
Layer3 | Screen, Export | Contains a Table data region to display the detailed sales and a DataBar to depict the profits.

SchoolStudentReportCard.rdlx: This report uses the XML data source connection to provide custom data. This report includes an Image control that acts as a background layout of the report. It also includes a few TextBox controls to display the name and the grades obtained by the student.

This report contains two Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
Default | All | This is a default layer. It does not contain any control.
Layer1 | Screen, Export | Contains an Image control with an image of a school graduation certificate.
Layer2 | All | Contains few TextBox controls to display the name and grades obtained by the student.

UserConferenceLabels.rdlx: This report uses the Nwind shared data source connection to provide data. This report uses the Image, TextBox, BarCode and Label controls to create a layout for the User Conference 2014 ticket.

This report contains two Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
default | All | This is a default layer. It does not contain any control.
Layer1 | Screen, Export | Contains Image controls to display the conference logo and sponsors and Label controls to display conference name and details.
Layer2 | All | Contains bound TextBox fields to display the conference attendee details and a BarCode control to display a unique BarCode for each attendee.

See Also

Layers
Working with Layers
View, Export or Print Layers

Walkthroughs
Tracing Layers

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Report Wizard

Report Wizard
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Page and RDL Reports > Report Wizard

Glossary Item Box

The Report Wizard sample demonstrates how to create and customize a report, using the report wizard.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Page Reports And RDL Reports\API\ReportWizard\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Page Reports And RDL Reports\API\ReportWizard\C#

Details

When you run this sample, the form with the Report Wizard appears. On the Select Report Type page, select the report type you want to analyze and click the Next button.

On the next Choose grouping options page of the wizard that appears, you are asked to choose a field for grouping the report data and click the Next button. You can also enable the checkbox at the bottom of the page if you like to include the last detail of the report as separate group. If you leave it unchecked, the checkbox automatically adds the last detail to a previous group.

On the next Select output fields page of the wizard that appears, you are asked to choose the fields you want to display in your report and click the Next button. On the next Summarization and Review page, you can review the settings you have selected previously. You can also set the summary options if you want to display a grand total or a sub-total in the report. Finally, when you click the Finish button, the GrapeCity Unified ReportDesigner appears and displays the report.

The sample consists of following items:

MetaData folder: This folder contains two internal classes, FieldMetaData and ReportMetaData. The FieldMetaData class contains information on the fields used in the report string values. This file provides this information when required by the application. Similarly, the ReportMetaData class contains information on the reports used in this sample. This file provides this information when required by the application.

Resources folder: This folder contains images and icons used by the Report Wizard API.

UI folder:

  • WizardSteps: This folder contains templates of the Report Wizard pages, which get displayed inside the Panel control on the WizardForm at run time.
  • DesignerForm: This form appears when you click the Finish button on the last page of the Report Wizard. This form uses the ToolStripPanel, ToolStripContentPanel, Designer, Toolbox, ReportExplorer and a PropertyGrid controls to create the Unified ReportDesigner.
  • Right-click the form and select View Code to see how to set the designer and create a blank page report. It also contains code that attaches the Toolbox, ReportExplorer and PropertyGrid controls to the Designer, inserts DropDown items to the ToolStripDropDownItem, sets their functions, and checks for any modifications that have been made to the report in the designer.
  • DragDropListBox: This file contains code to override methods that enable and handle the drag-and-drop feature in the ListBox, which appears on the wizard page where you select the grouping and the output fields. Thus, instead of selecting a field and clicking the Add button in the ListBox control, you can directly drag fields as well.
  • TipControl: This file contains the design of the Tip that appears on the first page of the report wizard.
  • WizardDialog: This is the main form that appears when you run the sample. It uses the PictureBox, two Labels, Panel and two Button controls to create the Report Wizard. The PictureBox displays the logo while the two Label controls display the Page Title and Page Description respectively. The Panel control loads the design of different pages of the Report Wizard. The two Button controls handle the last page and next page functions. Right-click the form and select View Code to see how to define functions of different controls used on the form.

Constants: This is an internal class that contains fields in string values that can be summarized.

GenreSales.rdlx-master: This is the master report for the Genre Sales report. It uses the Image, two Textbox and ContentPlaceholder controls to design the report. The Image control displays the logo on the top of the report while the two Textbox controls display the report execution time and page number information respectively. The ContentPlaceholder control displays its content report.

LayoutBuilder: This is the internal class file that contains code for creating the layout of both child reports and loading data in it.

Reports.xml: This XML file is used as a database to provide data for the reports in this sample.

ReportWizardState: This is the internal class file that contains code for handling the UI of the Report Wizard.

StoreSales.rdlx-master: This is the master report for the Store Sales report. It uses the Image, two Textbox and ContentPlaceholder controls to design the report. The Image control displays the logo on the top of the report while the two Textbox controls display the report execution time and page number information respectively. The ContentPlaceholder control displays its content report.

See Also

Concepts
Master Reports (RDL)

How To
Create and Use a Master Report (RDL Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Stylesheets

Stylesheets
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Page and RDL Reports > Stylesheets

Glossary Item Box

The Stylesheets sample demonstrates how to work with embedded and external style sheets in Page and RDL reports.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\Stylesheets\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\Stylesheets\C#

Details

When you run this sample, the main StyleSheetsForm interface displaying the following options appears:

  1. Choose Report: Select the type of report you want to display in the Viewer.
  2. Choose Style: Select a style sheet; embedded or external to apply to the report.

Click on Run Report button to load the report with the selected options in the Viewer. See Working with Styles for more information about style sheets.
StyleSheetsForm: This is the main form of the sample that displays reports in the ActiveReports Viewer control in the bottom section of the form, and options such as Choose report, Choose style and Run report button at the top of the form.

DeliverySlip.rdlx: This is a Page report, that contains TextBox, Label, Container controls and two Table data regions to display the invoice information. The report uses Theme1.rdlx-theme file and BaseStyle as an embedded style sheet. Some TextBox controls on the report also use the Sum function to display the total price information for each invoice. This report uses the Seikyu2 shared data source.

ReorderList.rdlx: This is an RDL report, that contains Table data region to display data from Reels shared data source. The Reels logo in the report is embedded within the Reels.rdlx-theme.

External Stylesheet: Following external style sheets are provided in this folder:

External Stylesheet Location - <User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\PageAndRDL\Stylesheets\Reports

  • BaseStyle.rdlx-styles
  • FaxSheetStyle.rdlx-styles
  • HighContrastStyle.rdlx-styles
  • ModernStyle.rdlx-styles

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Reports

Section Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports

Glossary Item Box

This section discusses following samples:

Charting
This sample demonstrates chart types used in different scenarios, in both bound and unbound modes.
Cross Section Controls
This sample demonstrates the use of the cross section lines and boxes.
Cross Tab Report
This sample demonstrates using unbound data, conditional highlighting and distributing data across columns to create a cross-tab view and data aggregation.
Custom Annotation
This sample demonstrates adding the Custom Annotation button to the report Viewer toolbar and adding a new annotation to the report.
Digital Signature Pro
This sample demonstrates how to sign digitally or set time stamp for a section report when exporting it to PDF format.
Export
This sample demonstrates how to export to different export formats using code.
Inheritance
This sample demonstrates using the method that inherits a report at run time and design time.
Print Multiple Pages per Sheet
This sample demonstrates printing a document with multiple pages per sheet by using the common PrintDocument class of the NET.Framework.
Style Sheets
This sample demonstrates changing styles at run time to provide a different look to a same report.
Sub Report
This sample demonstrates using subreports in an ActiveReports report.
Summary
This sample demonstrates how to display summarized data in a section report.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Charting

Charting
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Charting

Glossary Item Box

The Charting sample provides an option to choose from various chart types and a button to display the selected chart in a Viewer control.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\API\Section\Charting\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\API\Section\Charting\C#

Details

Chart type combobox

Select from the following ChartType options.

  • 2D Bar Chart - Use this chart to compare values of items across categories.
  • 3D Pie Chart - Use this chart to display data in 3D format to depict how percentage of each data item contributes to a total percentage. Selecting this ChartType provides an option to set the Direction of rotation of 3D Pie chart to Clockwise or Counterclockwise.
  • 3D Bar Chart - Use this chart to compare values of items across categories and to display the data in a 3D format.
  • Finance Chart -Use this chart to display the stock information using High, Low, Open and Close values. The size of the wick line is determined by the High and Low values, while the size of the bar is determined by the Open and Close values.
  • Stacked Area Chart - Use this chart to demonstrate how each value contributes to the total.

Report Display button
Click this button to display the selected chart type in a Viewer control.

Note: To run rpt2DBar, rpt3DPie and rpt3DBar report, you must have access to the Nwind.mdb database. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

ViewerForm
The ViewerForm contains the Viewer control, with the Dock property set to Fill. This enables the viewer to automatically resize along with the form. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

rpt2DBar report
Displays bar chart on a report. Retrieves the data to be displayed in a chart from Orders table in Nwind.mbd database. Settings for chart data source can be done using the Chart DataSource dialog.

rpt3DBar report
Displays 3D bar chart on a report. Retrieves the data to be displayed in a chart from Orders table in Nwind.mbd database. Generates a DataSet for the chart in ReportStart event and sets it in DataSource property of Chart control.

rpt3DPie report
Displays 3D pie chart on a report. Retrieves the data to be displayed in a chart from each of the Employees, Categories, Products, Orders, Order Details tables in Nwind.mdb database. Generates a DataTable for the chart in a ReportStart event and sets it in DataSource property of Chart control. Rotational direction of 3D pie chart can be set to Clockwise or Counterclockwise.

rptCandle report
Displays candle chart on a report. Chart data is set at design time using DataPoint Collection Editor. DataSource property is not used for this chart.

rptStackedArea report
Displays stacked area chart on a report. Chart data is set at design time using DataPoint Collection Editor. DataSource property is not used for this chart.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Cross Section Controls

Cross Section Controls
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Cross Section Controls

Glossary Item Box

This CrossSectionControls sample displays the invoice report of a company in detail. This sample uses the CrossSectionBox and CrossSectionLine controls to demonstrate the lines and display the Invoice report in a tabular form. It includes a ViewerForm with three tabs, three Viewer controls and an Invoice report to highlight several report features. Run the project and click the tab to see these features in action.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\CrossSectionControls\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\CrossSectionControls\C#

Details

When you run this sample, a form with three different tab options and each tab option displaying a report in a Viewer control is displayed. Click any tab option at the bottom of the form to display the selected tab feature applied to the report in a Viewer control. Select from the following tab options.

Cross Section Controls
Draws table style gridlines easily through multiple sections without any gap.

Detail RepeatToFill
The Detail RepeatToFill tab has the RepeatToFill property set to True. This ensures that the formatting (alternating purple and white rows and CrossSection controls) fills space as needed to keep the same layout between pages.

GroupFooter PrintAtBottom
The GroupFooter section has the PrintAtBottom property set to True. This pulls the GroupFooter section to the bottom of the page, just above the PageFooter section.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

  • ViewerForm: The ViewerForm has three tabs-Cross Section Controls, Detail RepeatToFill, GroupFooter PrintAtBottom, each with an ActiveReports Viewer control on it. Right-click the form and select View Code to see the code used to change the Invoice report's section properties at run time.
  • Invoice Report: The Invoice report demonstrates the usage of the following features.
    • PageHeader Section: This section contains Shape, Label and TextBox controls. The Shape control provides a border around the Order ID and Order Date fields and labels. The orderDateTextBox has the OutputFormat property set to d to display a short date. The Label controls use the BackColor, ForeColor, and Font properties to add a distinctive style to the report.
    • customerGroupHeader: The CrossSectionBox control is hosted in the GroupHeader section, and spans the Detail section to end in the GroupFooter section, forming a rectangle around the details of the invoice at run time. Three of the CrossSectionLine controls are hosted in the GroupHeader section, and span the Detail section to end in the GroupFooter section, forming vertical lines between columns of invoice details at run time.
    Note: If you try to drop a CrossSectionBox or CrossSectionLine control into a section other than a header or footer, the mouse pointer changes to unavailable, and you cannot drop the control.

    Two of the TextBox controls use a CalculatedField in the DataField property.

    Tip: In the Report Explorer, expand the Fields node, then Calculated to see all of the calculated fields. Select BillingAddress or ShippingAddress to take a look at the Formula used in the Properties window.

    The Line control is used below the column header labels to draw a horizontal line across the width of the report. (It is not visible at design time unless you make the Height of the GroupHeader section larger.) The DataField property of the customerGroupHeader section is set to the OrderID field, so that the section (followed by related details and GroupFooter) prints once per order.

    • Detail section: This section contains four bound TextBox controls. The four TextBox controls display each row of data associated with the current GroupHeader OrderID. The OutputFormat property of the UnitPrice and Total fields is set to C to display currency. The Line control is used below the TextBox controls to draw horizontal lines across the width of the report under each row of data. (It is not visible at design time unless you make the Height of the Detail section larger.) Right-click the report and select View Code to see the code used in the Detail Format event to create a colored bar (in this case, purple bar) report by alternating the BackColor property of the section. Click the Data Source Icon on the Detail band to view the Connection String used in the report.
    • customerGroupFooter section: This section has the NewPage property set to After so that a new page is printed for each OrderID (the associated GroupHeader's DataField). The Subtotal TextBox uses the following properties.
      • The DataField property uses a Total CalculatedField.
      • The SummaryFunc property is set to Sum, to add the values of the field in the detail section.
      • The SummaryGroup property is set to the name of the customerGroupHeader, to reset the summary value each time the GroupHeader section runs.
      • The SummaryRunning property is set to Group so that the value accumulates for the group rather than for the entire report or not at all.
      • The SummaryType property is set to GrandTotal.

      Right-click the report and select View Code to see the code used in the customerGroupFooter Format event to calculate the value for the Grand Total TextBox, and to format it as currency.**

    • PageFooter section: The ReportInfo control uses a FormatString property value of Page {PageNumber} of {PageCount}, one of the preset values you can use for quick page numbering.

      Tip: In order to easily select a control within the report, in the Report explorer, expand the section node and select the control. The control is highlighted in the Report Explorer and on the report design surface.

See Also

Concepts
Cross Section Controls

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Cross Tab Report

Cross Tab Report
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Cross Tab Report

Glossary Item Box

The CrossTabReport sample displays hierarchical information in a cross tabular structure. This sample consists of a StartForm with an ActiveReports Viewer control and a ProductWeeklySales report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\CrossTabReport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\CrossTabReport\C#

Details

When you run the sample, a report displaying a list of weekly sales for current week, month, quarter or year for each product category is displayed in the Viewer control. The values highlighted in red represent negative values.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

StartForm

The Viewer control has the Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer. ProductWeeklySales Report:

ProductWeeklySales Report

This report features a number of accumulated values using summary function property settings and calculated values in the code.The summary function displays a list of summary values only for weekly sales total in group footer without displaying the Detail section. By setting the Height property of Detail section to 0 and/or hiding the Detail section by setting Visible property to False, you can create a summary report that only displays sections other than the Detail section.
Based on the order date of Detail section data, you can determine whether it will be included in a week, month, quarter, year or previous year's quarter and set the values by sorting in unbound fields. Value of each unbound field is automatically summarized by each Field placed in the group footer section.

  • ReportHeader section: This section of the report features static controls including Labels, a Picture, a Line, and a Shape control. The report header prints only once on the first page of the report, thus report title, company information, and a logo are added in this section.
  • PageHeader section: The page header section contains static Label controls that print at the top of each page and serve as column headers for the group header sections.
  • ghCategory section: This group header section has the DataField property set to CategoryName. This setting, along with data sorted by the same field, produces a report grouped by category. The section contains one bound TextBox control to display the category name at the beginning of each group. The section's UnderlayNext property is set to True so that the category prints to the left of the top line of data instead of above it.
  • ghProduct section: Although this group header contains no controls and is hidden by setting the Height property to 0 and Visible property to False, it still performs two important functions. First, the DataField property is set to ProductName, to sort the data inside each category by product, and second, the related group footer section displays the bulk of the data for the report.
  • Detail section: The detail section of this report is hidden by setting the Height property to 0 and Visible property to False, but it does contain four bound fields whose values are used in the code. In the Detail Format event, the value from the hidden txtDetProduct TextBox is collected and passed to the _sProductName variable. For more information on section events, see Section Report Events.
  • gfProduct section: This group footer section displays the bulk of the data for the report in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection (see FetchData and DataInitialize events in the code) using the DataField property. In the gfProduct Format event for the inner group footer section, the product name collected from the Detail Format event is passed to the txtProduct TextBox. The Value for the txtPQTDChange TextBox is calculated by subtracting the prior year's quarter-to-date sales figure from the current quarter-to-date sales figure. The BackColor of the txtPQTDChange TextBox is set to Red if the value is negative. The total units and sales for each product is summarized using the following properties.
    • SummaryFunc: Sum (the default value)
      Adds values rather than counting or averaging them.
    • SummaryGroup: ghProduct
      Summarizes the values that fall within the current product group.
    • SummaryRunning: None (the default value)
      Ensures that this value is reset each time the product group changes.
    • SummaryType: SubTotal
      Summarizes the current group rather than a page or report total.
  • gfCategory section: This group footer section displays totals of the gfProduct data in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection (see FetchData and DataInitialize events in the code) using the DataField property. The total units and sales for each category is summarized using the following properties.
    • SummaryFunc: Sum (the default value)
      Adds values rather than counting or averaging them.
    • SummaryGroup: ghCategory
      Summarizes the values that fall within the current category group.
    • SummaryRunning: None (the default value)
      Ensures that this value is reset each time the category group changes.
    • SummaryType: SubTotal
      Summarizes the current group rather than a page or report total.
  • PageFooter section: This section is not used, so it is hidden by setting the Height property to 0 and/or Visible property to False. Otherwise, it would print at the bottom of each page. The section cannot be deleted, because the related PageHeader section is in use.
  • ReportFooter section: This section is not used, so it is hidden by setting the Height property to 0 and/or Visible property to False. Otherwise, it would print once at the end of the report. The section cannot be deleted, because its related ReportHeader section is in use.

See Also

Concepts
Section Report Structure
Section Report Events
Grouping Data in Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Annotation

Custom Annotation
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Custom Annotation

Glossary Item Box

The Custom Annotation sample demonstrates how to add the Custom Annotation button to the Viewer toolbar and depicts the method to add any annotation (seal image in this case) to the report. Only one annotation can be used per page.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\CustomAnnotation\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\CustomAnnotation\C#

Details

When you run the sample, the report appears in the Viewer control. The Viewer control toolbar contains the Custom Annotation button that opens the report annotation.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.
  • AnnotationForm: Add Custom Annotation button in Form_Load event. The behavior on clicking the Custom Annotation button is mentioned in the description of the Click event.
  • Annotation report:
    • ghOrderID section
      Product order receipt is grouped according to OrderID.
    • Detail section
      Use RepeatToFill property to output empty rows till the end and perform page break group wise.
    • GFOrderID section
      This group footer section displays the bulk of the data for the report in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection (see FetchData and DataInitialize events in the code) using the DataField property. The total units and sales for each product are summarized using the following properties:
      • SummaryFunc: Sum (the default value) adds values rather than counting or averaging them.
        Caution: SummaryFunc has no effect unless the SummaryType property is set to either SubTotal or GrandTotal.
      • SummaryGroup: ghOrderID summarizes the values that fall within the current order id.
      • SummaryRunning: None (the default value) ensures that this value is reset each time the order id changes.
      • SummaryType: SubTotal summarizes the current group rather than a page or report total.
  • Resources folder: This folder holds the icon used for adding annotation (seal image) to the report.
  • Resource1.resx: This file contains the string for the message box that appears when Custom Annotation button is clicked again to add the annotation.

See Also

Concepts
Annotations

How To
Add and Save Annotations

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Digital Signature Pro

Digital Signature Pro
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Digital Signature Pro

Glossary Item Box

This sample demonstrates how you can digitally sign or set time stamp for a section report when exporting it to PDF format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\DigitalSignaturePro\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\DigitalSignaturePro\C#

Details

When you run this sample, the Invoice report is displayed in the Viewer control.

Clicking the Generate Digitally Signed PDF button in the Viewer toolbar creates a PDF file with a time stamp or digital signatures, based on the settings you have specified in the Viewer toolbar. You can change the content of signatures in the Signature Format box and you can add the time stamp to the generated pdf file by checking the Set TimeStamp checkbox, in the Viewer toolbar.

When you click the Generate Digitally Signed PDF button, a dialog for saving the destination file appears. After you indicate the location for a new PDF file, the PDF report file is created. Digital signature certificates dynamically reference and use GrapeCity.pfx, included in the project. Also, digital signatures dynamically load and use the gc.bmp file that you can find in the Image folder of this sample project.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.
  • Image folder: This folder stores the gc.bmp file with the GrapeCity logo that digital signatures dynamically load and use.
  • Invoice report: The Invoice report is the Sample report that uses three GroupHeader sections, a Detail section and a GroupFooter section as well as a label in the PageFooter section to display data. See The Bound Data Sample topic for details on the Invoice report.
  • GrapeCity.pfx: In order to create a digital signature, you must have a valid PKCS#12 certificate (*.pfx) file. For information on creating a self-signed certificate, see the Adobe Acrobat Help topic "Create a self-signed digital ID."
    You can also create a PFX file from the Visual Studio command line. For more information and links to SDK downloads, see http://www.source-code.biz/snippets/vbasic/3.htm.
  • PDFDigitalSignature form: This is the main form of the Sample that uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains the Create Digitally Signed PDF button, the Signature Format box with the drop-down list and the Set TimeStamp checkbox.

    Clicking the Generate Digitally Signed PDF button opens a dialog for saving the destination file. After you indicate the location for a new PDF file, the PDF report file is created.

    The drop-down list of the Signature Format box contains the following options.

    • Invisible - the invisible pdf digital signature.
    • Text - the pdf digital signature that contains text only.
    • Image - the pdf digital signature that contains graphics only.
    • ImageText - the pdf digital signature that contains text and graphics.

    Checking the Set TimeStamp checkbox allows you to add the time stamp to the signature of the generated pdf file. The time stamp contains the Time Stamp Server address, its login and password information.

    Right-click PDFDigitalSignature in the Solution Explorer and select View Code to see the code implementation for the pdf digital signature options.

  • Resource.resx: This file contains the string for the message box that appears after the PDF file is generated and the string for the message box that appears when the free service limitation is exceeded.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Export

Export
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Export

Glossary Item Box

This sample illustrates how to export to different export formats using code. The available export formats are PDF, XLSX, RTF, MHT and CSV.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Export\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Export\C#

Details

When you run this sample, the Export Form is displayed. The Export Form contains the Report Name and Export Type combo boxes along with the Export button.

The sample consists of ExportForm. It exports the selected report in the selected export format.

On running the application, select a report for export in the Report Name combo box. In the Export Type combo box, you can select one of the following formats for export - PDF, XLSX, RTF, MHT and CSV. Clicking the Export button opens the Save As dialog where you can specify the name of the exported file. By default, the exported file is saved in the Documents folder.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Inheritance

Inheritance
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Inheritance

Glossary Item Box

This sample explains the method to inherit a report at run time and design time. The Inheritance sample solution is composed of two classes - the parent class and the child class for both inheritance at run time and design time.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Inheritance\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Inheritance\C#

Details

When you run the sample, the report is created and displayed, providing you with the choice of two options - Inheritance Report created at RunTime and Inheritance Report created at Design Time. By clicking a button on the form, you get a report that inherits another class at run time or at design time.

Inheritance Report created at RunTime
The rptInheritBase class is the inheritance class for the generated report when the Inheritance Report created at RunTime button is clicked on the form. The rptInheritBase class inherits the SectionReport class of the GrapeCity.ActiveReports namespace as parent class. It is possible to use DataInitialize event or FetchData event in this class and also possible to load csv file and set values for csv files. It defines the CsvPath property which gets csv file path.
The rptInheritChild class inherits the rptInheritBase class and is a class which only defines the report design. By adding the event handler for inheritance in the constructor and setting for csv file in CsvPath property, it is possible to perform rendering of data executed by event of BaseReport which is the inheritance class.

Inheritance Report created at Design Time
The rptDesignBase class is the inheritance class for the generated report when the Inheritance Report created at Design Time button is clicked on the form. The rptDesignBase class inherits SectionReport class of the GrapeCity.ActiveReports namespace as parent class. Using this class, you can place any control (ReportInfo controls etc. to display report title, page number, page count) you wish to inherit in PageHeader section and PageFooter section. The rptDesignChild class is inherited from rptDesignBase class. It only defines the design of Detail section. PageHeader section and PageFooter section use the design of rptDesignBase class which is an inherited class. DataSource setting can be performed from rptDesignChild class.

Caution: If you have not run the project even once, an error occurs when you try to open the report designers of the inherited classes rptInheritChild or rptDesignChild from the solution explorer. In case this error occurs, Build the project once before opening the report.
  • ViewerForm: Creates an instance of specified report and display the report in Viewer control.
  • rptDesignBase: The rptDesignBase class that defines the layout of PageHeader section and PageFooter section.
  • rptDesignChild: The rptDesignChild designer defines the layout on Detail section and sets the value of DataField property of the controls placed in Detail section. Also set the data source to output using Report Data Source dialog.
  • rptInheritBase: The class to set values for data field and rendering of csv file using DataInitialize event FetchData event.
  • rptInheritChild: The designer that sets layout for each control and it's DataField property.

See Also

Concepts
Grouping Data in Section Reports
Section Report Structure

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Print Multiple Pages per Sheet

Print Multiple Pages per Sheet
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Print Multiple Pages per Sheet

Glossary Item Box

The PrintMultiplePagesPerSheet sample demonstrates how you can print a document with multiple pages per sheet using the common PrintDocument class or PrintOptions class from .NET Framework. This sample project consists of the PrintMultiplePagesForm and the Invoice report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\PrintMultiplePagesPerSheet\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\PrintMultiplePagesPerSheet\C#

Details

When you run this sample, you will see the PrintMultiplePagesForm with the Invoice report. On this form, you can select the number of pages to be printed on each sheet using the Select Numer of Pages to Print on One Sheet ComboBox. You can also select from PrintMultiple Pages using PrintOptions API and PrintMultiple Pages using Custom Code tabs options and click the Print button on each of these tab to print the selected number of pages in one sheet.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.
  • PrintMultiplePagesForm: This form contains the ActiveReports Viewer control. The Dock property of the viewer is set to Fill so that it resizes automatically with the form at run time. The top section of Viewer contains a panel in which two tabs, ComboBox control, Label and two Print buttons are placed. ComboBox control lets you select the number of pages per sheet (2,4 or 8)and the Print button in PrintMultiple Pages using PrintOptions API and PrintMultiple Pages using Custom Code tab, print the selected number of pages in one sheet. The form also has two dialogs - dlgPrint and PrintDocument which assist in displaying the Print dialog box and printing the document.
    Right-click and select View Code to see the code that displays the Invoice report when the form loads. Also the code demonstrates the different ways of printing a document - the Print button in PrintMultiple Pages using Custom Code tab uses the PrintDocument class and the Print button in PrintMultiple Pages using PrintOptions API tab uses the PrintOptions class.
  • Invoice report: The Invoice report uses a PageHeader section, GroupHeader section, Detail section, GroupFooter section as well as a PageFooter section to display data in a Label control.

See Also

How To
Print Multiple Copies, Duplex and Landscape
Advanced Print Options

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Style Sheets

Style Sheets
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Style Sheets

Glossary Item Box

This sample demonstrates how you can change styles at run time to provide a different look to a same report. The project includes two reports, three report styles and a form containing the ActiveReports Viewer control and other controls that allow you to select any combination of styles and reports.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Stylesheets\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Stylesheets\C#

Details

Choose Report
Choose between the type of report, Categories and Product List, you want to display in the Viewer control.

Choose Style
Choose between Classic, Colored and External style sheet options to apply the style to the selected report.
Clicking the Choose button option for External style sheet displays the Open dialog that shows only *.reportstyle files, and passes the selected reportstyle path and file name string to the externalStyleSheet variable.

Run Report button
Click this button to display the selected report with the applied style in a Viewer control. Clicking this button creates an SectionReport object, assigns the selected report to it, and assigns a path and file name string to the styleSheet variable. It then assigns the style sheet to the report using the LoadStyles(styleSheet) method, runs the report, and displays it in the viewer.

The sample consists of:

  • Report Style Sheets: Look in Solution Explorer to see several *.reportstyle files. These are XML-based files that hold styles that you can apply to TextBox, Label, CheckBox, and ReportInfo controls on ActiveReports. Double-click one to open it. Each reportstyle contains a set of values for each of the standard style names:
    • Normal
    • Heading1
    • Heading2
    • Heading3
    • DetailRecord
    • ReportTitle

    When you select one of these style names on a report control, ActiveReports retrieves the style values, such as font size and color, from the specified style sheet when it runs the report.

    For more information on creating your own style sheets, see Use External Style Sheets.

  • Reports: Two reports, CategoryReport and ProductsReport, are included in this sample so that you can apply styles in different ways. Open one of the reports, and select the TextBox and Label controls on it to see which style is used for each.
  • StyleSheetsForm: The form in this project features radio buttons for choosing the report and style you want, a Choose button that opens a standard Windows Open dialog where you can select a reportstyle, and a Run report button that runs the selected report, applies the selected reportstyle, and displays the results in the ActiveReports viewer control below.
    To see how all of this works, right-click the form and select View Code.

    Choose Button Click Event

    This event contains code that sets up an Open dialog that shows only *.reportstyle files, and passes the selected reportstyle path and file name string to the externalStyleSheet variable.

    Run Report Button Click Event

    This event contains code that creates an empty SectionReport object, assigns the selected report to it, and assigns a path and file name string to the styleSheet variable. It then assigns the style sheet to the report using the LoadStyles(styleSheet) method, runs the report, and displays it in the viewer.

See Also

How To
Use External Style Sheets

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Sub Report

Sub Report
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Sub Report

Glossary Item Box

The SubReports sample demonstrates how SubReport control can be used to generate nested and hierarchical reports.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\SubReport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\SubReport\C#

Details

When you run this sample, the blank Viewer form appears, with the drop-down list of the sample reports on the top of the form. Select the report from the drop-down list to have it displayed in the Viewer control. You can select from the following options.

  • Simple SubReport - the basic sample report that demonstrates how to embed a report into another report. On selecting this report, rptSimpleMain report is displayed. The Detail section of this report contains the bound Textbox control to display the Category Name information and the Subreport control to display data from rptSimpleSub.
  • Nested SubReport - the report demonstrates how to nest subreports to display main, child, and grandchild levels in a report. It uses rptNestedParent, rptNestedChildMain, and rptNestedChildSub reports.
  • Hierarchical SubReport - the main report dataset with the SHAPE statement defines the hierarchical structure of the report that uses a subreport. It uses rptHierarchicalMain and rptHierarchicalSub reports.
  • SubReport using the data set that contains relationship - the main report having dataset with the relation that is defined in code, in the DataSet.Relations property of the main rptDSRelationParent report. It uses rptDSRelationParent, rptDSRelationChildMain, and rptDSRelationChildSub reports.
  • Master-detail report containing a SubReport - the sample report that demonstrates how to create a master detail report that uses a subreport. It uses rptMasterMain and rptMasterSub reports.
  • Bookmark in SubReport - the sample report that uses bookmarks from the subreport. It uses rptBookmarkMain and rptBookmarkSub reports.
  • Use a parameter in the SubReport - the sample report demonstrates how to set up a parameter in the data source of the subreport. See rptParamMain and rptParamSub for details.
  • To view the Dataset with multiple tables using SubReports - the sample report with the dataset that contains multiple data tables. The main report uses subreports to output multiple tables in a single report. See rptUnboundDSMain and rptUnboundDSSub for details.

    Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

See Also

How To
Embed Subreports
Bind Reports to a Data Source

Concepts
Interactive Features

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Summary

Summary
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > API > Section Reports > Summary

Glossary Item Box

Show All Show All
Hide All Hide All

This sample shows how to use calculated fields and data field expressions for simple calculations in a report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Summary\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\API\Section\Summary\C#

Details

When you run this sample, The Viewer control with the Select Report drop-down list is displayed. There, you can select one of the two reports - OrdersReport or DataFieldExpressionsReport, and click the Load Report button to display the report in the Viewer.

The OrdersReport shows how to use calculated fields, where the field values are calculated in code. A custom field is added to the Fields collection in the DataInitialize event and the field value is calculated in the FetchData event.

The DataFieldExpressionsReport demonstrates the use of data field expressions for simple calculations within the same section of the unbound report using known Fields collection values. These data field expressions cannot be used with the built in summary functions of ActiveReports 13.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

The sample consists of the StartForm and two reports - OrdersReport and DataFieldExpressionsReport.

  • StartForm: The Viewer control has the Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.
  • OrdersReport: The report shows the ProductID, UnitPrice, Quantity, Discount, Extended Price and Total value for each OrderID. The Extended Price value is a calculated field that displays the result of the formula specified in FetchData event.
    The OrdersReport uses a GroupHeader section, a Detail section and a GroupFooter section as well as a Label in the PageFooter section to display data.

    Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

    Show ghOrderID section

    This group header section has the DataField property set to OrderID. This setting, along with data sorted by the same field, displays a report grouped by OrderID. The section contains one bound TextBox control to display the OrderID at the beginning of each group.

    Show Detail section

    The Detail section of this report contains 5 bound TextBox controls that render for each row of data of the OrderID.

    Show gfOrderID section

    This group footer section displays total of the gfOrderID data in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection using the DataField property. The total extended price for the OrderID is summarized using the following properties:
    SummaryFunc: Sum (the default value)
    Adds values rather than counting or averaging them.
    SummaryGroup: ghOrderID
    Summarizes the values that fall within the current OrderID group.
    SummaryRunning: Group
    Calculates a running summary (each value is the sum of the current value and all preceding values) within the same group level.
    SummaryType: SubTotal
    Summarizes the current group rather than a page or report total.

    Show PageFooter section

    The page footer section contains a static Label control that prints at the bottom of each page and contains the note on the number of pages in the report.

  • DataFieldExpressionsReport: The DataFieldExpressionsReport displays data, using the Fields collection from the OrderDetail class. The report data under ExtendedPrice is calculated by the data field expression, specified in the DataField property of the txtExtendedPrice TextBox at the design time. The DataFieldExpressionsReport is an unbound report that uses the field values from the OrderDetail class for displaying the report data.

    Show PageHeader section

    The PageHeader section contains one Label control with the note text and four labels with the names of the report data fields.

    Show Detail section

    The Detail section contains four textboxes that use the Fields collection values to display the report data. The DataField property of the txtExtendedPrice textbox in the Detail section demonstrates how to format your data field expression.

    Show OrderDetail class

    The OrderDetail class contains data that is used in the fields of the report. When the report is run, the values of these fields are used to display data of the report. The field values are bound to the fields in the DataInitilize event and the data is bound to the field values in the FetchData event of the DataFieldExpressionsReport.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Data Binding

Data Binding
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding

Glossary Item Box

The samples in the Data Binding folder demonstrate data binding with various data providers separately for Page/RDL and Section reports.

  • Page and RDL Reports
  • Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page and RDL Reports

Page and RDL Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports

Glossary Item Box

This section contains:

CSV Data Source
This sample demonstrates how to connect to a CSV data source.
DataSet DataSource
This sample demonstrates how to use a dataset as a data source for a report.
Json Data Source
This sample demonstrates how to use the Json data provider at run time and add a web service for authentication.
Object Data Source
This sample demonstrates how to use Object provider for binding a report.
OData Data Source
This sample demonstrates how to use OData EndPoint for binding a report.
OleDb Data Source
This sample demonstrates how to connect to an OleDb data source at run time and pass data to the report using LocateDataSource event.
XML Data Source
This sample demonstrates how to connect to a XML data source at run time and pass data to the report using LocateDataSource event.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


CSV Data Source

CSV Data Source
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports > CSV Data Source

Glossary Item Box

Show All Show All
Hide All Hide All

The CSV Data Source sample demonstrates how to use the CSV data provider in a Page report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\CSVDataSource\VB.NET

Show C#

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\CSVDataDataSource\C#

Show Run-Time Features

When you run this sample, the CSV DataSource window appears. Select a radio button to specify the data format of the CSV file to use for the data source, and click the Run button to show the report in the viewer. You can choose from the following CSV data formats:

  • Delimited Data
    • No header, column separator is comma
    • Header exists, column separator is Tab
  • Fixed width Data
    • No header
    • Header exists

Show Project Details

Show MainForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at run time, and radio buttons to select the data source settings.

Right-click the form and select View Code to see how to set the data source settings in the connection string, and how to show the report at run time.

Show StockList.rdlx

This is the report that gets displayed in the Viewer at run time. The report is bound to the StockList dataset of the CSV data provider and uses a Table data region and TextBox controls to display the stock list. The stock list is grouped by CustomerID value.

See Also

Concepts
CSV Provider

Walkthroughs
Reports with CSV Data
Bind a Section Report to CSV Data Source

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


DataSet DataSource

DataSet DataSource
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports > DataSet DataSource

Glossary Item Box

Show All Show All
Hide All Hide All

The PageUnboundData sample demonstrates how to connect a page report to an unbound data source at run time, using the DataSet provider with the LocateDataSource event. The reporting engine raises the LocateDataSource event when it needs input on the data to use.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\PageUnboundData\VB.NET

Show C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Page Reports And RDL Reports\Data
\PageUnboundData\C#

Show Run-Time Features

When you run this sample, the Invoice2.rdlx report is displayed in the Viewer control. The report displays the Invoice form with the list of products along with the product ID, quantity and price of the products.

The report connects to an unbound data source at run time using the LocateDataSource event and the DataSet provider.

Show Project Details

Show Invoice2.rdlx

In the Report Data Source dialog, the type of the report data source is set to DataSetProvider and the ConnectionString is left blank. In the DataSet dialog, data fields used on the report are added to the DataSet on the Fields page.

This report uses the Table, TextBox, Label and Shape controls to create an Invoice layout for displaying the customer transactions. The Container control at the bottom of the report contains a label, a textbox and line control. The textbox uses the Sum function to display the sum of the values returned by the expression indicated in the Value property.

Show ViewerForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at run time. The code-behind the form contains the code with the LocateDataSource event that connects the Invoice2.rdlx report to unbound data and the code that populates fields for the data table.

See Also

Reports Gallery

Sample ReadMe Files
Custom Resource Locator

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Json Data Source

Json Data Source
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports > Json Data Source

Glossary Item Box

Show All Show All
Hide All Hide All

The Json Data Source sample demonstrates how to use the Json data provider. The sample uses a web service that requires authentication to access the Json data source at run time.

You must have IIS Express installed on your machine for the Json Data Source sample to run.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\JsonDataSource\VB.NET

Show C#

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\JsonDataDataSource\C#

Show Run-Time Features

The sample consists of two projects: the Windows Application project with a report, MainForm, and DataLayer class that provides report data; and the Web Application project with a web service that provides access authentication for the report data at run time.

When you run this sample, you will see the MainForm appear. The MainForm contains the ActiveReports Viewer that displays a report with a list of Customers from the Json data provider.

Note: To run this sample, you must have access to the Customers.json data file. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files in this folder, or change the reference path to the data files within the folder according to your environment.

Show Project Details

Show JsonDataSource

This is the Windows Application project that contains the MainForm, the sample page report, and the DataLayer file with the report data.

Show DataLayer

This file is an internal class that contains code to create the data connection. It provides interaction with the server containing Json data using HTTP, including the access credentials.

Show MainForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at run time.

Right-click the form and select View Code to see how to load and show the report at run time.

Show testReport.rdlx

This is the report that gets displayed in the Viewer at run time. The report contains the embedded Json schema as the data source.

It uses the Table data region to display data from the Json data source, the Customers sample data file.

Show WebService

This is the Web Application project that contains the web service used to retrieve data from the Json data source for the sample report at run time.

Show BasicAuthHttpModule

This file is the public class that provides access authentication when the report connects to the Json data source at run time.

Show Service.asmx

This is the web service required to access the Json data provider.

Show Web.config

This is the web configuration file for configuring your web application.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Object Data Source

Object Data Source
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports > Object Data Source

Glossary Item Box

The Object Data Source sample demonstrates how to use Object provider for binding a report that contains a subreport.

  • Sample Location
  • Run-Time Features
  • Project Details

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\ObjectDataSource\VB.NET
C# Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\ObjectDataSource\C#

Run-Time Features

When you run this sample, the MainForm with the ActiveReports Viewer appears. The viewer displays the report where YearReleased column is a part of the main report (ObjectsReport.rdlx) whereas other columns such as ID, Title and MPAA are part of the subreport (SubObjectsReport.rdlx).

Project Details

DataLayer

This file is an internal class that contains code to provide data for the report.

MainForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at run time.

Right-click the form and select View Code to see how to load and show the report at run time.

ObjectsReport.rdlx

This is the report that gets displayed in the Viewer at run time.

The report uses the header with the Textbox to display the report heading and the footer with a Textbox to display the page number information. The body of the report has the Table data region to display data where only first column is obtained from the Objects data provider. For that, the Textbox controls of the Table are bound to the Objects data source in the Value property. For rest three columns, subreport control is used.

SubObjectsReport.rdlx

This is the subreport that is placed on Table data region of the main report.

The report has a Table data region to display data obtained from the Objects data provider. Here also, the Textbox controls of the Table are bound to the Objects data source in the Value property.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


OData Data Source

OData Data Source
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports > OData Data Source

Glossary Item Box

The OData DataSource sample demonstrates how to use OData EndPoint for binding a report.

  • Sample Location
  • Run-Time Features
  • Project Details

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\ODataDataSource\VB.NET
C# Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\ODataDataSource\C#

Run-Time Features

The ODataDataSource sample needs a running ODataEndPoint to obtain data. To run the sample, please perform the following steps:

  1. Right-click solution in Solution Explorer and select Properties.
  2. Select Multiple startup projects radio button and Start actions in ODataEndPoint and ObjectDataSourceClient, or ODataEndPoint and JsonDataSourceClient projects in Startup Project tab.
  3. Run the sample again.

Project Details

The sample consists of JsonDataSourceClient and ObjectDataSourceClient projects to render data and ODataEndPoint to query data.

JsonDataSourceClient

This folder contains the DataLayer, Program and Service classes required for the data connection.

The MainForm is the form that appears when you run this sample if you have previously selected ODataEndPoint and JsonDataSourceClient projects as startup projects in the sample Properties.

ObjectDataSourceClient

This folder contains the DataLayer, Program and Service classes required for the data connection.

The MainForm is the form that appears when you run this sample if you have previously selected ODataEndPoint and ObjectDataSourceClient projects as startup projects in the sample Properties.

The Models subfolder contains Movie and Year classes.

ODataEndPoint

This folder contains the AppData and AppStart subfolders required to run the application.

The Controllers subfolder contains the MoviesController and CustomersController files. The MoviesController handles the user interaction and returns the main view. The CustomersController handles the customer details information that is displayed when a customer is selected.

The Models subfolder contains the Customer and Movie classes providing data for the report.

Global.asax is the default class that sets global URL routing values for this web application.

Web.config is the configuration file that contains the httpHandlers that allow ActiveReports to process this web application. Note that you need to manually update version information here when you update your version of ActiveReports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


OleDb Data Source

OleDb Data Source
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports > OleDb Data Source

Glossary Item Box

Show All Show All
Hide All Hide All

The OleDB Data Source sample demonstrates how to use the OleDb data provider for binding a report to data.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\OleDbDataSource\VB.NET

Show C#

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\OleDbDataSource\C#

Show Run-Time Features

When you run this sample, the MainForm with the ActiveReports Viewer appears. The Viewer displays the report with the list of movies, their ratings and the release year information.
Note: To run this sample, you must have access to the Reels.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Show Project Details

Show DataLayer

This file is an internal class that contains code to create a data connection. It creates the OleDb data reader to read data from the Reels database and add it to an array to provide data for the report.

Show MainForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at run time.

Right-click the form and select View Code to see how to load and show the report at run time.

Show OleDBReport.rdlx

This is the report that gets displayed in the Viewer at run time.

The report uses the header with the Textbox to display the report heading and the footer with the Textbox to display the page number information. The body of the report has the Table data region to display data obtained from the OleDb data provider. For that, the Textbox controls of the Table are bound to the OleDB data source in the Value property.

See Also

Walkthroughs
Single Layout Reports

How To
Bind a Page Report to a Data Source at Run Time

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Xml Data Source

Xml Data Source
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Page and RDL Reports > Xml Data Source

Glossary Item Box

Show All Show All
Hide All Hide All

The XML Data Source sample demonstrates how to use the XML data provider for supplying data to the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\XmlDataSource\VB.NET

Show C#

<User Folder>\GrapeCity Samples\ActiveReports 13\DataBinding\PageAndRDL\XmlDataDataSource\C#

Show Run-Time Features

When you run this sample, you will see the MainForm appear. The MainForm contains the ActiveReports Viewer that displays a report with data from the xml data provider.

Show Project Details

Show BandedListXML.rdlx

This is the main report that gets displayed in the Viewer at run time. It uses the BandedList and Textbox controls, and the Subreport control inside the BandedList data region to display data.

The BandedList data region uses two groups to group the report data by the fields City and Country.

The Subreport control, placed in the GroupFooter section of the BandedList, displays the CountrySales report.

Show CountrySales.rdlx

This is the report that gets displayed by the Subreport control of the BandedListXML report.

It uses the Chart data region to display data. The Chart Type property is set to Doughnut (Pie Exploded Doughnut), which shows the analysis of companies sales amount for different countries.

See Also

Concepts
Grouping Data (Page Layout)
Subreport
Classic Chart

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Reports

Section Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Section Reports

Glossary Item Box

This section contains:

Bound Data
Demonstrates binding to ADO.NET Data objects.
IList Binding
Demonstrates creating a custom collection that stores data from the database in the List. The custom collection is displayed by binding data to the DataGridView control by using the DataSource property of this control.
LINQ
The LINQ sample demonstrates how to use LINQ in an ActiveReports report.
Unbound Data
The Unbound Data sample demonstrates how to create a dataset for a section report and use the FetchData event to populate the Fields collection to display the report unbound data.
XML
This sample demonstrates how to create a report with XML data, using a SubReport or using the XML hierarchical structure.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bound Data

Bound Data
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Section Reports > Bound Data

Glossary Item Box

Show All Show All
Hide All Hide All

The Bound Data sample demonstrates various ways to bind data in a section report.

When you run the sample, the Viewer control displays the form with eight tabs, each with a different data binding technique. Click to select a tab, and then click the Bind To button to create the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\BoundData\VB.NET

Show C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\BoundData\C#

Show Run-Time Features

The top panel of the MainForm is composed of eight tabs:

Bind to DataSet
Creates a DataSet from the sample database and binds it to a SectionReport object.

Bind to DataReader
Creates a DataReader from the sample database and binds it to a SectionReport object.

Bind to DataView
Creates a DataView from the sample database and binds it to a SectionReport object. This tab contains a ComboBox which lets you choose the company name from the NWind database.

Bind to DataTable
Creates a DataTable from the sample database and binds it to a SectionReport object.

Bind to SQL Server
Creates a SQL Server DataSource from a SQL server instance and binds it to a SectionReport object. The ComboBox present in this tab lets you populate the dropdown list with the existing SQL servers on the network.

Bind to OleDb
Creates an Oledb DataSource and binds it to a SectionReport object.

Bind to XML
Creates a XML DataSource from a file and binds it to a SectionReport object. The XML tab also features a Generate XML button that generates a DataSet and saves it as an XML data file. The generated file is then used as a data source for the report.

Bind to CSV
Creates a CSV DataSource from a file and binds it to a SectionReport object. You can select the data type of the file from the following options:

  • Delimited Data (with or without header)
  • Fixed width Data (with or without header)

Show Project Details

Show MainForm

The MainForm uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains tabs, each with a different data binding technique.

Click to select a tab, and then double-click the button on the tab to jump to the button's Click event in the code.

Show Invoice Report

The Invoice report uses three GroupHeader sections, a Detail section and a GroupFooter section as well as a label in the PageFooter section to display data.

Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

Show ghOrderHeader

The DataField property of this section is set to OrderID. This setting, in conjunction with data ordered by the OrderID field, causes the report to print all of the information for one order ID value, including all of the related details and footers, before moving on to the next order ID. For more information on grouping, see Grouping Data in Section Reports.

This section also contains a Picture control, a number of Label controls, and two bound TextBox controls. The TextBoxes are bound using the DataField property in the Properties window, and the date is formatted using the OutputFormat property.

Show ghOrderID

The DataField property of this section is also set to OrderID. This allows subtotal summary functions in the related GFOrderID section to calculate properly.

This section contains a number of labels and bound text boxes, as well as two Line controls.

Show ghTableHeader

This section contains only labels for the data to follow in the Detail section.

Show Detail

This section contains bound TextBox controls. These TextBoxes render once for each row of data found in the current OrderID before the report moves on to the GroupFooter sections.

Show GFOrderID

The NewPage property of this section is set to After. This causes the report to break to a new page and generate a new invoice after this section prints its subtotals.

This section contains several labels and several TextBoxes. Two of the TextBox controls use the following properties to summarize the detail data: SummaryFunc, SummaryGroup, and SummaryType. For more information, Create a Summary Report.

The Total TextBox does not use the DataField property or any of the summary properties, or even any code. To find the functionality of this TextBox, in design view, click the Script tab at the bottom of the report.

Show PageFooter

This section has one simple Label control. For more information about report sections and the order in which they print, see Section Report Structure and Section Report Events.

Show ProductList Report

The ProductList report uses the Header and Detail sections to display data.

The Header section contains a number of Label controls to display column names for the product list.

The Detail section contains four TextBox controls to fetch the product data.

See Also

How To
Bind Reports to a Data Source

Concepts
Grouping Data in Section Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


IList Binding

IList Binding
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Section Reports > IList Binding

Glossary Item Box

Show All Show All
Hide All Hide All

The IList Binding sample uses CollectionBase class, with implementation of IList interface to create a ProductCollection class which gets populated from the Products table of the NWind database. The created ProductCollection is used as a database for binding data to the DataGridView control.The data from ProductCollection class gets displayed using the DataSource property of DataGridView control. On clicking the Generate Report button, the ProductCollection class is again used to display the data of the generated report in a Viewer control. Similarly, you can display a report by binding to the DataSource property of a report.

Data from ProductCollection class displayed in DataGridView control

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Generated report displayed in Viewer control

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\IListBinding\VB.NET

Show C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\IListBinding\C#

Show Run-Time Features

When you run this sample, DataGridView, which is a standard Windows Forms control displays the custom collection. To display a report with the bound custom collection, click the Generate Report button.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Show Project Details

The IList Binding sample consists of two projects: IListBinding and IListBinding.DataLayer.

Show IListBinding Project

Show BindIListToDataGridSample

This form contains a DataGridView control, a Label control and a Generate Report button. It displays output results by binding data of a custom collection to the DataGridView control. On clicking the Generate Report button, ViewerForm displays a report bound to this custom collection.

Show IlistReportSample report

The report uses the ReportHeader, GroupHeader1 and Detail sections for the report output.

ReportHeader section
The ReportHeader section contains a Label that displays the title of the report.

GroupHeader1 section
The GroupHeader1 section contains nine Label controls that define the layout of the report data.

Detail section
The Detail section contains TextBox controls to display the report data. Following settings have been performed to enhance the appearance of the report output.
  • Change the background color of alternate rows
    Use the BackColor property of the Detail section (set in the Format event of the Detail section) to change the background color of each row for better visibility of the table.
  • Change the background color for selected rows
    Use the BackColor property of the Detail section (set in the Format event of the Detail section) to change the background color of selected rows. The background color changes when Reorder Level is below Ordered Units.

Show ViewerForm

Setting the Dock property of the Viewer control to Fill ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

Show IListBinding.DataLayer project

DataProvider Class
Implements the connection to the data base.

Product Class
Defines custom collection class.

ProductCollection Class
Implements the CollectionBase class to create a collection of Product class. The list of this collection stores data from the Products table.

See Also

How To
Bind Reports to a Data Source

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


LINQ

LINQ
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Section Reports > LINQ

Glossary Item Box

Show All Show All
Hide All Hide All

The LINQ sample demonstrates how to use LINQ in an ActiveReports report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\LINQ\VB.NET

Show C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\LINQ\C#

Show Run-Time Features

This sample uses a LINQ Query to sort recordsets in descending order of age. The resultant recordsets are converted to an IList and used as a datasource for the report which is displayed in Viewer control.

Show Project Details

Show ViewerForm

Displays the report output results. ToList method is set in DataSource property of the report to extract objects that use LINQ.

Show rptLINQtoObject report

The report DataSource is a list of Person constructor created from generic class. Creates a query to sort in descending order of Age.

See Also

How To
Bind Reports to a Data Source

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Unbound Data

Unbound Data
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Section Reports > Unbound Data

Glossary Item Box

Show All Show All
Hide All Hide All

The Unbound Data sample demonstrates how to create a dataset for a section report and use the FetchData event to populate the Fields collection to display the report unbound data.

When you run the sample, the Viewer control displays the form with four tabs, each with a different dataset binding technique. Click to select a tab, and then click the Build Report From button to create the report with unbound data.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\UnboundData\VB.NET

Show C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\UnboundData\C#

Show Run-Time Features

  • Unbound data with a DataSet
    Creates a data set from the included Northwind sample database inside the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.
  • Unbound data with a DataReader
    Creates a data reader from the included Northwind sample database inside the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.
  • Unbound data with a Text File
    Sets the Invoice.txt file as a datasource for the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.
  • Unbound data with a Data Array
    Creates a data array from the included sample text file inside the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.

Show Project Details

Show MainForm

This is the main form of the sample that uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains four tabs, each with a different data binding technique. Click to select a tab, and then click the button on the tab to display the report with unbound data.

Show UnboundDAInvoice report

The Invoice report for the Unbound data with a Data Array option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

Show UnboundDRInvoice report

The Invoice report for the Unbound data with a DataReader option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

Show UnboundDSInvoice report

The Invoice report for the Unbound data with a DataSet option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

Show UnboundTFInvoice report

The Invoice report for the Unbound data with a Text File option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

See Also

Grouping Data in Section Reports

How To
Bind Reports to a Data Source

Sample ReadMe Files
Bound Data

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


XML

XML
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Data Binding > Section Reports > XML

Glossary Item Box

Show All Show All
Hide All Hide All

The XML sample displays customer order list using the XML data source. The sample demonstrates how to create a report with XML data, using a SubReport or using the XML hierarchical structure.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\XML\VB.NET

Show C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Section Reports\Data\XML\C#

Show Run-Time Features

When you run the sample, you will be asked to select between the following.

Run Customers XML Report
Demonstrates a two level Master/Detail XML Data Source. Uses a SubReport to print the orders of each customer. By selecting any of the radio buttons - Show All Data, Show Report where ID = 2301, or Show All Data with an E-Mail address, you can change the creation option of the generated report.

Customer Orders (Leveled)
Displays customer's orders by using the XML hierarchical structure. The Master/Detail is implemented using the XML hierarchy XPath selection patterns without any SubReports.

Show Project Details

Show StartForm

This is the main form of the sample. You see this form after you run the project and where you can select how to display XML data.

  • Run Customers XML Report
    Displays the customers order list by using SubReports.To bind the CustomersOrders report to the XML data source, the valid XPath expression is entered in the RecordsetPattern field on the XML tab of the Report Data Source dialog.
  • Customer Orders (Leveled)
    Displays customer's orders by using the XML hierarchical structure, which is demonstrated by the OrdersLeveled report. To bind this report to XML data, the path to the XML file is entered in the File URL field on the XML tab of the Report Data Source dialog and also the XML hierarchical structure like "../../@email" is specified in each field.

Show CustomersOrders report

This report embeds the srptOrders SubReport. Following settings are performed in this report.

  • Embed the SubReport control
    Places the SubReport control in the Detail section and connects it to the Orders SubReport for displaying the orders list.

Show OrderItems SubReport

This report binds to the Subreport control of Orders report.

Show Orders SubReport

This is the report with a SubReport control that is bound to the OrderItems report. Following settings are performed in this report.

  • Embed the SubReport control
    Places the SubReport control in the Detail section and connects it to the OrderItems report for displaying the list of orders.
    The Report property of the Subreport control is specified in the Orders_ReportStart event.
  • Set the XML data source included in the SubReport
    Indicates a method to retrieve the record set using the NodeList property instead of the RecordsetPattern property of the XML data source on OrderItems report at design time.
    The NodeList property of the XML data source is set in the Detail_Format event.

Show OrdersLeveled report

Displays the list of customer's orders. Following settings are performed in this report.

  • Groups data
    Groups data using the XPath pattern that represents the hierarchical structure of XML. DataField property of ghCustomers section and ghOrders section is set at design time.

Show ViewerForm

The Viewer control has its Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

See Also

How To
Bind Reports to a Data Source

Concepts
SubReport (Section Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Designer Pro

Designer Pro
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Designer Pro

Glossary Item Box

The samples in the Designer Pro folder demonstrate features provided with the ActiveReports professional edition.

Map
This sample demonstrates how to work with Map control in ActiveReports.
End User Designer
This sample demonstrates a custom end-user report designer that can be integrated in your applications to allow users to modify report layouts.
Reports Gallery
This sample demonstrates customizing End User Designer application to display a list of categorized reports.
Table of Contents
This sample demonstrates how to use TableofContents control in ActiveReports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Map

Map
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Designer Pro > Map

Glossary Item Box

The Map sample demonstrates the basic functioning of the Map control with the help of four reports that explain the different features of the control. This sample is part of the ActiveReports Professional Edition.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\DesignerPro\Map\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\DesignerPro\Map\C#

Details

When you run this sample, the End User Designer shows a list of .rdlx reports at the bottom left of the form. Expand the Reports node to view reports under it and double-click a report to load it into the designer.

Report Form

This is the main form that appears when you run the sample. This form uses the ToolStripPanel, ToolStripContentPanel, Designer, Toolbox, ReportExplorer and PropertyGrid controls to create a customized ReportDesigner.
Right-click the form and select View Code to see how to set up the designer and create a blank page report. It also contains code that adds the reports to the TreeView control, loads a report into the Designer when the report is double-clicked, and checks for any modifications that have been made to the report in the designer.

Reports Folder

OilProducingCountries.rdlx: This report uses the FactBook shared data source connection to provide data.

It contains a Map control that visually displays the oil production in different countries of the world on a virtual earth background. The map control uses the color rule set on a polygon layer to differentiate parts of world according to their oil production capacity. These colors are defined using a color rule which is described in the legend at run time.

RomePlaces.rdlx: This report contains a Map control that visually displays famous places in Rome.

The map control uses Google maps in a Tile layer to provide a virtual earth background and a Point layer to plot famous places on the map using image markers. Clicking the image marker opens the web page for the selected place in Wikipedia.

StoreSales.rdlx: This report contains a Map control that visually displays the sales of different stores in the US.

The Map control uses the built-in USA map template. The polygon layer defines the country and state boundaries while the point layer is used to plot store locations. The Point layer uses the marker size rule to differentiate stores according to their profits. The different sized markers used for plotting stores are defined in a legend that appears on the map at run time. The point layer also uses the drill-through link (the Action is set to Jump to report) that opens a specific store report (StoreReport2.rdlx) when the marker is clicked.

StoreReport2.rdlx: This report uses the Reels shared data source connection to provide data.

It opens on clicking a specific store location that is indicated with a marker. The Table data region in the report uses a drill-down link to display the list of employees in the selected store. The report uses the chart data region to display the sales for the store. The Reels logo that appears on the report in the Image control is embedded within the Reels theme.

See Also

Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


End User Designer

End User Designer
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Designer Pro > End User Designer

Glossary Item Box

The EndUserDesigner Sample demonstrates how to set up a custom end-user report designer using the Designer, ReportExplorer, Layer List, ToolBox, ReportsLibrary, and GroupEditor controls. This Sample is part of the ActiveReports Professional Edition.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DesignerPro\EndUserDesigner\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DesignerPro\EndUserDesigner\C#

Run-Time Features

When you run the sample, the End User Designer appears in the Viewer control. This report designer provides the functionality of the ActiveReports Designer and supports three types of report layouts: Page Report, RDL Report, and Section Report.

The End User Designer lets you create report layouts and edit them at design time or runtime. The Designer includes the Property Window with extensive properties for each element of the report, the Toolbox is filled with report controls, the Report Explorer with a tree view of report controls, the Reports Library displaying report parts (group of controls) in a report, and a Group Editor displaying row and column groups for Tablix data region. Page reports and RDL reports provide the Layer List in a tabbed window with the Report Explorer. The Layer List window displays a list of layers in the report along with their visibility and lock options.
See Report Parts, Layers, and Tablix for more information. For information on menu items, see ActiveReports Designer.

The project consists of following forms:

ExportForm

This is the form with the Export dialog for Page report, Rdl report and Section report.

A user sees the Export dialog under the Preview tab in the File menu > Export. This dialog allows to select the export type and to browse for the file location in local folders where the report is exported. See Exporting for details on the type of export formats supported in Section report, Page report, and RDL report.

Control | Name | Description
ComboBox | cmbExportFormat | The Export Format combo box that allows to select options for the report export type.
Button | btnOK | The OK button in the lower part of the ExportForm.
Button | btnCancel | The Cancel button in the lower part of the ExportForm.
PropertyGrid | exportPropertyGrid | Provides interface for export options of each export type.
SaveFileDialog | exportSaveFileDialog | The Save File dialog that allows to specify the file name for saving an exported report file.
Label | lblExport | The Export label in the header of the ExportForm.
Label | lblExportFormat | The Export Format label of the Export Format combo box.
Label | lblExportOptions | The Export Options label of the Export property grid.
Label | lblSelectExportTxt | The Select Export text that describes the purpose of the ExportForm.
SplitContainer | exportSettings SplitContainer | Represents a movable bar that divides the display area of the ExportForm into two resizable panels - the ExportForm header panel and the ExportForm panel with the Export Format combo box and the Property Grid.
SplitContainer | exportHeader SplitContainer | Represents a movable bar that divides the Export Format section consisting of the Export Format combo box with the Export Format label and the Property Grid of ExportForm.

Right-click the ExportForm in the Solution Explorer and select View Code to see the code implementation for the Export form.

EndUserDesigner form

This is the form with a basic end-user report designer that contains the following elements. These elements are dragged from the Visual Studio toolbox onto the form.

Control | Name | Description
Designer | reportDesigner | The Designer control that allows you to create and modify a report.
ReportExplorer | reportExplorer | Gives you a visual overview of the report elements in the form of a tree view where each node represents a report element.
TabControl | reportExplorerTabControl | Represents a movable bar that divides the display area of the designer into two tabs - the Report Explorer and the Layer List
PropertyGrid | reportPropertyGrid | Provides an interface for each element of the report.
Toolbox | reportToolbox | Displays all of the controls specific to the type of report that has focus.
LayerList | layerList | Represents a list of Layers in the report along with their visibility and lock options.
SplitContainer | mainContainer | Represents a movable bar that divides the display area of the Designer into two resizable panels.
SplitContainer | designerExplorerPropertyGridContainer | Represents a movable bar that divides the display area of the designer into two resizable panels -the toolbox and the toolstrip.
SplitContainer | bodyContainer | Represents a movable bar that divides the display area of the Viewer into two resizable panels.
SplitContainer | explorerPropertyGridContainer | Represents a movable bar that divides the display area of the designer into two resizable panels - the report explorer and the property grid.
ToolStripContainer | toolStripContainer | Provides a central panel on top of the Designer to hold the Toolstrip element with the menu items.
ReportsLibrary | reportsLibrary | Displays all reports and included report parts.
GroupEditor | groupEditor | Shows the row and column groups in a Tablix data region.

Right-click the EndUserDesigner form in the Solution Explorer and select View Code to see the code implementation for the End User Designer.

See Also

ActiveReports Designer
Exporting

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Table of Contents

Table of Contents
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Designer Pro > Table of Contents

Glossary Item Box

The TableofContents sample demonstrates the basic features of the TableofContents control. This sample is part of the ActiveReports Professional Edition.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\DesignerPro\TableOfContents\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\DesignerPro\TableOfContents\C#

Details

When you run this sample, the End User Designer appears with a MovieCatalog.rdlx under the Reports node. The report contains a TableOfContents control which displays a list of movie titles along with their page numbers under each genre. On clicking the movie title, the details on the selected movie are displayed.

Report Form

This is the main form that appears when you run this sample. This form uses the ToolStripPanel, LayerList, TreeView, ToolStripContentPanel, Designer, Toolbox, ReportExplorer and PropertyGrid controls to create a customized ReportDesigner.

Right-click the form and select View Code to see how to set up the designer. It also contains code that adds the reports to the TreeView control, loads a report into the Designer when it is double-clicked, and checks for any modifications that have been made to the report in the designer.

Reports Folder

MovieCatalog.rdlx: This report uses the Reels data source connection to provide data.

The report makes use of TableOfContents, Image, TextBox, Label and List controls to display the layout of the report. TableofContents control displays an organized hierarchy of movie titles under each genre with two heading levels. Clicking the genre name or the movie title takes you to the corresponding page number that contains the details. The Reels logo that appears on the report is embedded within the Reels theme.

See Also

Table of Contents

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Desktop

Desktop
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Desktop

Glossary Item Box

The samples in Desktop folder demonstrate features of WPF and Win Viewers.

Custom WPF Preview
This sample demonstrates obtaining continuous and multi-page views in WPF Viewer.
WPF Viewer
This sample demonstrates using WPF Viewer in a WPF application.
Win Viewer
This sample demonstrates using Win Viewer in a Windows Form application.
Reports Gallery
This sample demonstrates customizing End User Designer application.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom WPF Preview

Custom WPF Preview
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Desktop > Custom WPF Preview

Glossary Item Box

This sample illustrates obtaining continuous and multi-page views in WPF Viewer using third-party assemblies.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Desktop\CustomWPFPreview\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Desktop\CustomWPFPreview\C#

Details

When you run the sample, AnnualReport.rdlx report is displayed. You can choose to obtain continuous page or multi-page views using options available in the WPF viewer. The sample implements IRenderingExtension and uses Microsoft XPS Document Writer to create report.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports Gallery

Reports Gallery
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Desktop > Reports Gallery

Glossary Item Box

Show All Show All
Hide All Hide All

The Reports Gallery sample demonstrates how to customize the End User Designer application by adding the TreeView control to display a list of categorized reports. At run time, the user can double-click any report out of the three categories: Page, Rdl, and Section, and load it into the designer.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DesignerPro\ReportsGallery\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\DesignerPro\ReportsGallery\C#

Run-Time Features

When you run this sample, the End User Designer appears with a list of report categories at the bottom left of the Form. Expand each category to view the reports under it and double-click any report to load it into the designer. You can also go to the Preview Tab to view the report.

Project Details

ReportsForm

This is the main form that appears when you run this sample. This form uses the ToolStripPanel, ToolStripContentPanel, Designer, Toolbox, ReportExplorer, TreeView, PropertyGrid and LayerList controls to create a customized unified ReportDesigner.

Right-click the Form and select View Code to see how to set up the designer and create a blank page report. It also contains code that attaches the Toolbox, ReportExplorer, PropertyGrid and LayerList controls to the Designer, inserts DropDown items to the ToolStripDropDownItem and sets their functions. Finally, it also contains code that adds the reports to the TreeView control, loads a report into the Designer when the report is double-clicked, and checks for any modifications that have been made to the report in the designer.

Reports folder

Reports folder consists of three subfolders - Page Report, RDL Report and Section Report, each containing a set of reports that highlight the major features of the corresponding report types.

Page Report folder

This folder contains several subfolders that illustrate the use of Page Reports in different scenarios.

Show DrillDown

AllCustomers report: This report uses the NWind shared data source. It uses the Table data region to display customer's contact details. The Textbox displaying the CustomerID field in the detail row of the Table is used to set a drill-through link to navigate to the CustomerDetails report.

Show Invoice folder

BillingInvoice report: This report uses the NWind shared data source. It showcases a billing invoice layout commonly used in convenience stores. The report mostly contains Label, TextBox and Line controls in its layout. It also includes an EAN128FNC1 barcode due to its high reading accuracy.

Invoice1 report: This report uses the NWind shared data source. It includes a BandedList and few TextBox controls to create the Invoice layout for displaying customer transactions. Both the page and the BandedList control are grouped by the OrderID field. One of the text boxes in the footer section of the BandedList control uses the Sum function to display the grand total of all transactions.

Invoice2 report: This report uses the NWind shared data source. It uses a Table, few TextBoxes and Shape controls to create the Invoice layout for displaying customer transactions. The report page is grouped by the CustomerID field, therefore all transactions made by a customer appear together based on the ID. One of the text boxes placed inside the Container control at the bottom of the report uses the Sum function to display the grand total of all transactions.

Invoice_Grouped report: This report uses the NWind shared data source. It uses the Table, few TextBox and Label controls to display customer transactions in an Invoice. The data is grouped on the CustomerID field, so that all transactions made by a customer appear together based on their ID.

Invoice_Parameters report: This report uses the NWind shared data source connection and two datasets to provide data. It is similar to the Invoice_Grouped report with an additional parameters feature. It uses parameters set on the CompanyName field to filter data on report preview.

Show Other

BarCode report: This report demonstrates all barcode types that are supported by ActiveReports. The barcode types are presented in the Table data region, using a single page layout. The rows of the table use alternate background colors (grey and white). At run time, the Barcode report displays one page that fits the table with all the sample barcodes.

Catalog report: This report uses the NWind shared data source. It shows a multi page layout spread over four pages in the report. The layout in Page1 and Page2 contains Image, Label and Textbox controls to display introductory text. The layout on Page3 contains a List data region with TextBox controls and a Table to display product details for each product category. The List is grouped by the CategoryID field to filter products by their category and its FixedSize property is set to fit in excess data. The layout on Page4 (that appears as page 9 at run time) uses Textbox, Shape and Line controls amongst others to create an Order Form, which a user is to fill manually.

CellMerging report: This report uses the NWind shared data source. This report demonstrates cell merging in Tablix data region, where cells with same values are merged automatically to avoid showing duplicate values. The row group area contains three groups that are nested in a parent/child relationship to display the row group data. The Country (parent) and City group (child) values are merged automatically to remove duplicate data values.

DeliverySlip_theme report: This report uses the Seikyu2 shared data source. It uses the TextBox, Label, Container controls and two Table data regions to display the invoice information. The report uses two themes and has its CollateBy property set to ValueIndex to determine the order in which the report pages are rendered. Some TextBox controls on the report also use the Sum function to display the total price information for each Invoice. The page is grouped on the EstimateID field, so the invoices are sorted by EstimateID.

EmployeeSales report: This report uses the NWind shared data source. It contains the Chart and Table data regions to display sales by each employee for the year 1997. A column chart shows the graphical representation of sales by each employee while the Table lists down the exact sales figures. One of the TextBox controls on the report also uses the Sum function to display the grand total of all sales.

Enterprise Reports - Marketing Plan Data: This report displays information for the Marketing Plan. The report contains embedded XML data. Table, TextBox, Line, Image, and Shape controls are used to display data. The status of each task is represented through color coding using expressions.

IRS-W4 report: This report uses the IRS XML data source to provide data to the report. It mainly contains Textbox, CheckBox, Shape and Line controls to create the layout of a tax form used in the US.

Letter report: This report uses the NWind shared data source. It contains an Image, FormattedTextBox, Table and an OverflowPlaceholder controls to create a layout for a letter. The FormattedTextBox control uses text with HTML tags to display content. The Table displays OrderID with order dates and order amount and is linked with the OverflowPlaceholder control to display excess data on the same page. The Reels logo, displayed on the report inside the Image control, is embedded within the Reels theme and the TextBox placed below the Image control uses a Global expression to display the current date. The layout page is grouped by the CustomerID field to filter data on each report page according to individual customers.

MyOrdersReport: This report uses MyOrders.csv as a data source to demonstrate the native support for CSV data providers. It contains a Table data region that displays orders with data fetched from the CSV data source.

PurchaseReport: This report uses the NWind shared data source. It contains the Textbox and Table controls to display purchase details for each company. The layout page is grouped by the Company_CD field to filter data on each report page according to the company. The Textbox control placed below each table column uses the Sum function to display totals. The FixedSize property of the Table is set to fit in excess data.

ReelsTablix report: This report uses the Reels shared data source. It contains the Tablix data region to display a sales report for each country, city and media type by year. The Tablix data region uses row grouping to group the data by Country, City and MediaType, and column grouping to group the data by Years and Quarters.

ResourceConsumptionByYear report: This report uses MostPopulatedCountriesEnergyUsageByYear shared data source. It illustrates composite charts by using a Chart data region that shows annual Natural Resource Consumption - Oil and Electricity - versus Population size. Natural Resource Consumption and Population size are plotted on the two Y axes represented by two different chart types - Column and Line. The report also contains a parameter which lets users choose the country for which they want to view the data.

SalesReport: This report uses the Reels data source connection and two datasets that fetch data through a Stored Procedure. The layout of the report uses the Chart to display sales and profit for the selected date range and the Table to display the numeric values of the same. The table also uses the DataBar function to plot profits graphically. The Reels logo, displayed on the report inside the Image control, is embedded within the Reels theme. This report also uses two nullable parameters to select the range of dates.

TablixSample report: This report uses the NWind shared data source. It contains the Tablix data region that displays an orders report with product category and names showing quarterly and yearly orders. The Tablix uses a nested row grouping to group the Tablix data region by CategoryName and ProductName, and nested column grouping to group the Tablix data region by Years and Quarter. The tablix body area displays the aggregate Sum for each category and the grand total of order amount.

TackSeal report: This report uses the NWind shared data source. It contains the OverflowPlaceholder control and the List data region to create a columnar display of tack seals with postal barcodes. The List data region has its OverflowName property set to OverflowPlaceHolder1 and the OverflowPlaceHolder1 control has its OverflowName property set to OverflowPlaceHolder2 to assure correct display of columnar data display within the report page.

RDL Report folder

This folder contains several subfolders that illustrate the use of RDL Reports in different scenarios.

Show Dashboard

CallCenterDashBoard report: This report uses the CallCenter shared data source. It contains uses the Bullet control to indicate when the data is approaching or past a warning range and the Sparkline controls to indicate daily trends in key pieces of performance and sales data. It also uses the Icon Set data visualizer to indicate the warning levels for key performance data.

MarketDashBoard report: This report uses the MarketData shared data source. It contains the Sparkline control to display stock price trends over the last 30 days. The Sparkline allows investors to see trends without knowing what actual values are associated with each point.

TeamList report: This report uses the FootballStatistics shared data source. It contains the List control that displays a list of team names with drill-through links to navigate to the TeamStatisticsDashboard.rdlx report that displays the selected team's statistics.

SalesDashboard report: This report uses the SalesResult shared data source. It consists of two datasets to display multiple Chart controls and a Tablix data region to visualize the sales performance data. This report illustrates the Galley-mode feature where all of the report contents can be previewed in a single scrollable page.

Show Factbook

CountryFacts report: This report uses the Factbook shared data source. It contains a List data region grouped on CountryID that groups data by Country. The report also contains a map image whose Value property is set to the expression with the MapCode data field from the XML data source. It contains a hidden parameter that is used to accept the Country ID. This report is called in other reports by drill-through links or as a subreport, so the Country ID is passed silently. The default ID is the World. The dataset has a filter that retrieves only countries, specified by the report parameter. From each textbox with category under Energy Production / Consumption you can see the Image control that uses the Icon Set data visualizer to flag energy categories where consumption is greater than production.

LifeExpectancyByGdpAndMedianAge report: This report uses the Factbook shared data source. It contains the Tablix data region to compare the average life expectancy based on the category where the Median age and GDP fall. The tablix data region consist of a row group GDP of country and a column group Median Age to display the data.

Top10CountriesByGdp report: This report uses the FactbookSortedByGdp shared data source and shows the Top 10 countries by GDP. It contains a List data region with an image in the Image control that uses the RangeBar function to create an ad-hoc horizontal bar chart.

Show Reels

CustomerMailingList report: This report uses the Reels shared data source. It includes a Container control along with TextBox and Barcode controls to display a mailing list of customers. The Columns property of the Body section is set to 3 to display mailing labels in three columns.

CustomerOrders report: This report uses the Reels shared data source. It contains the List and Table data regions that group data by CustomerID and SaleID respectively to display order information. The SalesAmount textbox of the Table has its Value property set to Sum function to calculate the total for each order (as a table group subtotal). The YearTotal textbox of the Table also has its Value property set to Sum function to calculate the total of pre-tax sales. The Reels logo that is displayed on the report is embedded within the Reels theme. The page number in the PageHeader section is reset every time a new customer is displayed. This report also contains a subreport, CustomerOrdersCoupon.rdlx.

DistrictReport: This report uses the Reels shared data source. It contains the Chart and Tablix data region to display the number of sold items and the profit for each month during the two year span (2004-2005) for the selected district. The Tablix data region consists of a row group SaleDate and a column group StoreName. The report parameter determines which district to display and uses the available values from the second report dataset SalesData.The StoreName textbox in the report body uses the drill-through link (the Action is set to Jump to report) that opens the StoreReport.rdlx with more information.

DistrictSales report: This report uses the Reels shared data source. It contains the BandedList data region that groups data by SaleYear, DistrictID and RegionID to display district sales details. Sum function is used to get the total sales at the District, Region, Year levels and also to display a grand total. The Reels logo that is displayed on the report is embedded within the Reels theme.

Filmography report: This report uses the Reels shared data source. It contains nested List data regions that group data by MovieID and MoviePersonID to return a distinct number of movies with the selected actors. The report contains two cascading parameters that narrow down the number of actors displayed in the list first based on the alphabet with which the actor's name begins and then based on the actor's name. The Reels logo that is displayed on the report is embedded within the Reels theme.

GenreSales report: This report uses the Reels shared data source. It contains a Tablix data region to display the units sold for each genre, in each year and each quarter. The Tablix report data consist of a row group GenreName and a column group SaleDate.Year to display the data. The report also uses the plain column Chart to display the number of titles sold for each genre. This report uses the multi value parameter that allows you to select more than one genre for displaying sales data.

GenreStatistics report: This report uses the Reels shared data source. Median and Mode aggregate functions are used to show the middle values in a set of data as well as the most commonly occurring value. It also uses the ReelsConfidential.rdlx-master report to provide standard page headers and footers. The Reels logo that is displayed on the report is embedded within the Reels theme.

MonthlySalesReport: This report uses the Reels shared data source. It contains a Table data region that groups data by DistrictID. The Textbox controls in the Table have their Value property set to expressions to display the total of sales for each district and region as well as the totals of all districts within a region for a given month. It also uses the Plain Line Chart with the data grouped and sorted by Day for each SaleDate to display sales and profit for the selected month. This report uses query based parameters to select the month and region for displaying data. The Reels logo that is displayed on the report is embedded within the Reels theme.

MovieCatalog report: This report uses the Reels shared data source. It contains the Image, TextBox, TableofContents and List controls to display the list of movies in a catalog. This report uses the TableofContents control to display, an organized hierarchy of the report heading levels and labels along with their page numbers, in the body of a report. It also uses the TextBox and Image control to display the layout of the report. The Reels logo that is displayed on the report is embedded within the Reels theme.

MovieReport: This report uses the Reels shared data source. It contains four List data regions with groupings. The MovieList is grouped by MovieID, the GenreList is used to display the genre names and is grouped by GenreID, the CrewList is used to display the title and is grouped by CrewTitleID, and finally the CastNameList is used to display the cast and crew and is grouped by MoviePersonID. This report uses cascading parameters. The first parameter asks to select which letter the movie titles starts with, and then the second parameter asks to select a movie to display. The CrewName textbox in the report Body uses the drill-through link (the Action is set to Jump to report) that opens Filmography.rdlx with more information on the selected person. The parameters of this report are passed to the Filmography.rdlx report. The Reels logo that is displayed on the report is embedded within the Reels theme.

RegionPerformance report: This report uses NWind.mdb database. It contains the Table data region that uses the Region value to group the report data and the SalesAmount value to sort the report data. It also uses filtering to filter the report data by the RegionID value. Textbox controls in the Table have their Value properties set to Sum functions to display the total of sales amount for each region. The Reels logo that is displayed on the report is embedded within the Reels theme.

ReorderList report: This report uses Reels shared data source. It contains the Table data region without any grouping. The Table detail row has its BackgroundColor property set to the expression to create a light yellow bar report. The Reels logo that appears on the report is embedded within the Reels theme.

SalesByMediaType report: This report uses the Reels shared data source. It contains the List data region that is grouped by Image to display data. The list also includes the Table data region that groups its data by MediaID. The report also contains the Plain Column Chart to display sales and profit by media type and embedded images for each category. This report uses the ReelsConfidential.rdlx-master report to render the report page header and footer.

SalesByRegion report: This report uses the Reels shared data source. It contains the Tablix data region and subtotals to display the number of units sold and profit for each region by year and quarter. The Tablix report data consist of a row group Region and a column group SaleDate.Year to display the data. The report also uses the Plain Column Chart to display the annual profit for each region. Data in the Chart is also grouped by Region and SaleDate.Year.

SalesReceipt report: This report uses the Reels shared data source. It contains a Table data region and three Container controls nested in the List data region. The List is grouped by SaleID to produce the body of the receipt. The salesTaxLabel and totalSalesTax text boxes use the Sum function that totals the amount due in the list and adds tax to the sum of a field for the grand total due. The Reels logo that is displayed on the report is embedded within the Reels theme.

SalesReport: This report uses the Reels shared data source. It contains a Table and Chart data regions to display totals of sales and profit for the selected date range. The Table also uses the Data Bar function to plot the profits. The Chart and Table data is grouped by Month and Year. The Month textbox uses the drill-through link to display MonthlySalesReport.rdlx with more information on the selected month. This report uses parameters that allow the null value to select the range of dates. The Reels logo that is displayed on the report is embedded within the Reels theme.

StorePerformance report: This report uses the Reels shared data source. It identifies stores with profits above or below expectations. It also has two Image controls that display the database images and use the IconSet function. This report uses the ReelsConfidential.rdlx-master report to render page headers and footers.

StoreReport: This report uses the Reels shared data source. It contains the Table, List and Chart data regions to display sales for each employee. The Table and Chart data is grouped by EmployeeID. The Table uses hierarchical grouping to show the relationship between employee and supervisor for each store. The FirstName textbox has its Padding> Left property set to the Level function that leaves a space 15 pixels wide to the left of the control. This is the drill-down report where the Visibility > Hidden property of the Table detail row is set to =Fields!Supervisor.Value <> 0 and the Visibility > ToggleItem property is set to the FirstName data field. The expression in the Visibility > Hidden property calculates whether the supervisor field returns 0, so only the supervisor's name is displayed initially. By clicking the toggle image next to the supervisor's name, the rows with details about employees are displayed. The report uses a cascade of parameter values - Region, District and StoreNumber. Each parameter depends on the value of the previous parameter and each comes from a separate dataset. The Reels logo that is displayed on the report is embedded within the Reels theme.

TopPerformers report: This report uses the Reels shared data source. It contains two Table data regions to display the top and bottom performers based on the movies sales. Each Table data is grouped by MoviePersonID and MovieID (nested grouping). The TopN filter is applied to one table and the BottomN filter is applied to another. The number of items returned by each of the filters is specified in report parameters. This report also uses two integer parameters to alter the number of items displayed in each table. The parameters use default values, which are passed to textboxes of the Table Headers. This is the drill-down report where the second Table Group Header in each Table has its Visibility > Hidden property set to True and the ToggleItem property set to the PerformerName textbox. By clicking the toggle image next to the name, the rows containing details about performers are displayed.

Show Others

AnnualPortfolioChart report: This report uses the MostPopulatedCountriesEnergyUsageByYear shared data source. It illustrates composite charts by using a Chart data region that shows Annual Stock Performance. The Trading Volume and Trading Value are plotted on two Y axes represented by two different chart types, Column and Line.

Financial Reports - BalanceSheetReport: This report displays the company’s assets and liabilities. The report contains embedded JSON data. Table, Textbox, and Image controls are used to display data. The total assets and liabilities are calculated using expressions.

Financial Reports - CashFlowReport: This report displays the company’s cash flow. The report contains embedded JSON data. Table, Textbox, Line, Image, and Shape controls are used to display data. The VB code in the script transforms the numerical values in the accounting format.

Financial Reports - IncomeStatementReport: This report displays the income statement for the Year End (December 2017). The report contains embedded JSON data. Table, Textbox, and Image controls are used to display data. The net income and total revenue are calculated using expressions.

Financial Reports - IncomeStatementReport2: This report displays the company’s sales and expenses. The report contains embedded JSON data. Table, Textbox, Image, and Shape controls are used to display data. Total sales, Gross profit, and Net profit are calculated using expressions.

Flight On-time Performance Report: This report shows on-time performance of US airlines. The report uses nested data regions bound to different datasets from the following data sources:

  • States.xml - XML file stores information about geographical data of regions and states US.
  • FlightDetails.csv - CSV file stores flight information - flight date, arrival time, departure time, etc.
  • Airlines.json - JSON file stores unique airlines names corresponding to an airlineID.

The controls that are included in this report are List, Container, Table, and Tablix, where Container, Table, and Tablix are nested inside List. These controls show data as described below:

  • List displays geographical information - Region, State Name, and Number of Airports, from States.xml data file through Tablix data region and Textbox control inside Container control.
  • Table displays flight information - Number of flights, on-time arrival and departure details, from FlightDetails.csv.

The mapping for 'DataSet Joins' is created by adding a filter in Table on Region fields. This lists the flight information in Table control that flew in a particular region displayed in the List.

Medical Reports - BloodTestReport: This report displays the patient’s blood test results. The report contains embedded XML data. Table, Textbox, and Image controls are used to display data. Results and Reference Intervals are calculated using expressions.

Medical Reports - PatientDiseaseSummaryReport: This report displays a summary of the patient’s diseases and allergies. The report contains embedded JSON data. Table, Textbox, and Image controls are used to display data.

Telecom Reports - TelephoneBillSample: This report displays the company’s telephone bill. The report contains embedded XML data. Table, Checkbox, Image, and Textbox controls are used to display data. Expressions are used to calculate totals.

Section Report folder

BarCode report: This report displays all barcode types that are supported by ActiveReports.

  • PageHeader section: This section contains the table columns to display the report header. The Text property of the two Textbox controls, define the name of the two table columns.
  • Detail section: This section contains a list of all the Barcode types that are supported by ActiveReports. The barcodes are presented in a table that contains two columns, the one with the Textbox control displays the barcode name, and the other one with the Barcode control displays the barcode image.

Invoice1 report: This report calculates the total amount for each customer along with purchase details. The report also displays the average of the previous invoice amount, the current invoice amount and the consumption tax. This report uses Bill.mdb database to provide data.

  • PageHeader section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the invoice information in the header. The values of the Excise and BillTotal Textbox controls are set in the Script tab and are calculated in the BeforePrint event.
Note: This sample uses bound fields on the PageHeader section, assuming that the value of all records to be displayed on a page does not change. However, it is not recommend that you place bound fields in the PageHeader or PageFooter sections because these sections are displayed on a page once. For the same reason it is not recommended that you place bound fields on the GroupHeader and GroupFooter sections.
  • GroupHeader section: This section (ghColumnCaption) contains the Label controls that are captions for the information displayed in the Detail section. This section also uses the CrossSectionBox and the Shape controls.
  • Detail section: This section contains the bound TextBox controls that display each row of data associated with the current ghColumnCaption. The Shape control is used to alternate row colors in the Detail section. Go to the Script tab and see the shpDetailBack.BackColor property in the Detail_Format event.
  • PageFooter: This section contains the Label controls that explain codes used in the Category column of the invoice details.

Invoice2 report: This report shows another invoice layout and uses Seikyu2.mdb database to provide data.

  • GroupHeader1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the invoice information in the header. The values of the Year, Month and Day Textbox controls are set under the Script tab and are calculated in the ReportStart event. It also uses the CrossSectionLine and the CrossSectionBox controls that span the GroupHeader1 section to Detail section. The CrossSection Box ends in the GroupFooter1 section. These controls form vertical lines between columns of the invoice details and a rectangle around the details of the invoice at run time.
  • Detail section: This section uses the data table tb_Main for the main report data and the data table tb_Count to retrieve the number of data items within a group. The Detail data in each group is retrieved beforehand to calculate the required number of empty rows. For the required empty row count, substitute data with "" in the FetchData event. The Shape control is used to alternate row colors in the Detail section. Go to the Script tab and see the shpDetailBack.BackColor property in the Detail_Format event.
  • GroupFooter1 section: This section contains the Label and Textbox controls that display the totals of the invoice. The values of the Tax and Pretax Textbox controls are set under the Script tab and are calculated in the Format event.

LabelReport: This report displays the tack seal, which is commonly used in postal services. This multi-column report uses the customer barcode that is bound to data by using the DataField property. This report uses Nwind.mdb database to provide data.

  • Detail1 section: This section contains the bound data fields to display the contact information and the Barcode control that is bound to data by using the DataField property. The ColumnCount property is set to 3, which allows the report to display the tack seal in 3 columns.

PaymentSlip Report: The report displays the salary payment slip where the EAN128FNC1 barcode is used for barcode bound to a data field. This report uses Bill.mdb data source connection to provide data.

  • Detail section: This section contains bound data fields to display the payment information and the Barcode control that is bound to data by using the DataField property.

PurchaseOrder report: The report displays purchase slips created with bound data. It groups data for each purchase slip. The detail count is not fixed but the number of rows in the report layout is fixed. In this case, when the RepeatToFill property of the Detail section is set to True, the detail data is repeatedly displayed on the entire page. The report uses the RepeatToFill property and calculated fields to demonstrate how to create the report layout without any code. Calculated fields are used to calculate the total cost and the total selling price. This report uses Shiire.mdb data source.

  • groupHeader1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the company information in the header.
  • Detail section: This section contains Textbox controls. It uses bound data fields to calculate the product information in the body of the report. The detail.BackColor property is used to alternate row colors in the Detail section. Go to the Script tab and see the detailBack.BackColor property in the detail_Format event.
  • groupFooter1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the total information in the footer of the report group.

Schedule report: The sample report displays the weekly schedule of employees in the gantt chart format. The report displays six day report schedules on a single page in the Viewer control. This report uses Schedule.mdb database to provide data.

  • GroupHeader1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the employee information in the header.
  • Detail section: The Gantt chart view is created by using the Label, Shape and Line control. You can display the horizontal bars like in the gantt chart by modifying the size of the Label control. To add horizontal bars, you can dynamically add twenty four (12 x 2) Label controls within the 9-20 hours time frame that will become the horizontal bars of gantt chart in the ReportStart event. Once they are added, set the Visible property to False to hide them.

You can adjust the width of horizontal bars by setting calculated values from the time width in the Tag property of the Label control within Detail_Format event. For the horizontal adjustment of bars, change the width of the Label control to match with the value in the Tag property.
UnderlayNext report: This report displays the bound data. It uses Nwind.mdb database to provide data.

  • PageHeader section: This section contains the Label and Line controls to create the header for report data.
  • GroupHeader1 section: This section contains a TextBox control bound to the Country field and the CrossSectionLine controls to create the table for the body data of the report. UnderlayNext Property of this section is set to True to align the beginning position of the report data in the Detail section with the GroupHeader1 section.
  • Detail section: This section contains the bound Textbox controls to display report data. This section displays the name of the city, contact name and postal code for each customer according to their countries.

See Also

Custom Resource Locator
DataSet DataSource

How To
Work with Local Shared Data Sources
Add Parameters
Group in a Data Region

Concepts
Expressions
Section Report Toolbox
Toolbox

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Win Viewer

Win Viewer
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Desktop > Win Viewer

Glossary Item Box

This sample demonstrates using Win Viewer to load RPX, RDL, RDLX, JSON or RDF report formats or save reports to report document file (RDF) format.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Desktop\WinViewer\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Desktop\WinViewer\C#

Details

When you run this sample, a Viewer control containing File and Help menu appears on the top. You can load any of the RDF files from RDFs folder using File > Open. An RDF file is a static copy of a report saved to the native Report Document Format. This can be loaded into the Viewer control without running it or accessing data. You can use Save as RDF option to save other report formats to RDF format. For more information, see Save and Load RDF Report Files. You can also export to other file formats using File > Export option.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


WPF Viewer

WPF Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Desktop > WPF Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

The WPF Viewer samples demonstrates the use of WPF Viewer and its options to view the rdlx and rpx reports.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Desktop\WPFViewer\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Desktop\WPFViewer\C#

Details

Show Run-Time Features

When you run the sample, MainWindow.xaml containing the WPF Viewer, Select Report ComboBox, Preview button and Add Custom Button CheckBox appears.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Select Report

In the Select Report ComboBox, you can select from a list of 6 sample reports. The ComboBox contains the following reports - Catalog.rdlx, EmployeeSales.rdlx, Invoice1.rdlx, Invoice2.rpx, LabelReport.rpx, and PaymentSlip.rpx.

Preview

The Preview button opens the report selected in Select Report ComboBox in the WPF Viewer.

Add custom button

The Add custom button CheckBox demonstrates the customization options of the WPF Viewer. To see the About Us custom button appear in the WPF Viewer toolbar, select the Add custom button CheckBox and click the Preview button. To remove the About Us custom button from the WPF Viewer toolbar, click to clear the Add custom button CheckBox and then click the Preview button.

Note: Preview button and Add custom button CheckBox are only enabled when a report is selected from the Select Report ComboBox.

Show Project Details

Show Reports folder

The folder contains the following reports.

Catalog.rdlx: This is a sample layout for the product catalog. This report uses multiple page layouts to create a catalog. The layout of this report is spread over 4 pages, which appear one after another at run time. Page1 and Page2 layouts simply display introductive text. The layout on Page3 contains a List data region with TextBox controls and a Table to display product details for each product category. The List is grouped by the CategoryID field to filter products by their category. The layout on Page4 uses Textbox, Shape and Line controls to create a Order Form, which a user is to fill manually.

EmployeeSales.rdlx: This is a sample layout to display sales by each employee for the year 1997. The Chart control is used to display a graphical analysis of sales by each employee and the Table data region lists down the exact numbers.

Invoice1.rdlx: This report uses a BandedList and few TextBox controls to create the Invoice layout for displaying customer transactions. Both page and the BandedList control are grouped by the OrderID field. Texboxes in the footer section of the BandedList control use the Sum function to display the total of the transactions. For detailed information on the Invoice2.rpx report, see the Reports Gallery Sample.

Invoice2.rpx: This is a sample layout for the invoice report. The report page is grouped by the EstimateID field. Sum function is used to display the GrandTotal of all transactions. For detailed information on the Invoice2.rpx report, see the Reports Gallery Sample.

LabelReport.rpx: This report displays the tack seal, which is commonly used in postal services. This multi-column report uses the customer barcode that is bound to the data using the DataField property. For detailed information on the LabelReport.rpx report, see the Reports Gallery Sample.

PaymentSlip.rpx: This report displays the invoice payment slip with the GS1-128 barcode that is used for payment services in convenience stores. GS1-128 is the convenience store barcode, formerly called UCC/EAN-128. For detailed information on the PaymentSlip.rpx report, see the Reports Gallery Sample.

Show DefaultWPFViewerTemplates.Xaml

The DefaultWPFViewerTemplates.xaml is used for the WPF Viewer customization. For steps on the WPF Viewer customization, see the WPF Viewer walkthrough.

Show MainWindow.xaml

The MainWindow.xaml is displayed when you run the sample. It contains the WPF Viewer, the Select Report ComboBox, the Preview button and the Add custom button CheckBox.

The code behind of MainWindow.xaml.vb (or .cs), handles the display of RDLX and RPX reports in the WPF Viewer and the customization of the WPF Viewer application.

Show MyCommand

This class contains the text that is displayed when you click the About Us custom button in the WPF Viewer toolbar.

See Also

Getting Started
WPF Viewer

Walkthroughs
WPF Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web

Web
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web

Glossary Item Box

The samples in Web folder demonstrate web related features in HTML5 Viewer, JS Viewer, Web Designer, etc.
Custom Preview
The sample demonstrates exporting an ActiveReports report to the HTML or PDF format in your Web application.
Financial Portfolio
The sample demonstrates visualizing stock data with a Candlestick Chart.
HTML5 Viewer
This sample demonstrates the HTML 5 Viewer with its various options of loading Basic or Customized UI and Page, RDL and RDLX reports.
HTML5 MVC
The ActiveReports with MVC Sample demonstrates an MVC web application using the ActiveReports Web Viewer with the options of loading section and page report layouts. It is part of the ActiveReports Professional Edition.
HTML5 Web API With AngularJs
The sample demonstrates how to use the ActiveReports HTML5 Viewer in the ASP.NET MVC5 framework and is part of the ActiveReports Professional Edition.
JSViewer_Angular(Core)
The sample demonstrates the use of the GrapeCity ActiveReports JS Viewer with an Angular 7 app and ASP.NET Core back-end.
JSViewer_MVC
The sample demonstrates the use of GrapeCity ActiveReports JS Viewer with an ASP.NET MVC 5 back-end.
JSViewer_MVC(Core)
The sample demonstrates the use of GrapeCity ActiveReports JS Viewer with an ASP.NET MVC Core back-end.
Plant Performance
The sample demonstrates how to visualize the Plant Performance KPIs using the Map control.
Reports Gallery
The sample demonstrates a variety of RDL, Page, and Section reports along with their descriptions.
Web Designer MVC
The sample demonstrates Web Designer with an ASP.NET MVC 5 back-end.
Web Designer MVC(Core)
The sample demonstrates Web Designer with an ASP.NET MVC Core back-end.
WebViewer Pro
The Active Reports Web Pro Sample demonstrates the use of Professional Edition ASP.NET features, such as HTTP handlers, parameterized reports, and more.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Preview

Custom Preview
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > Custom Preview

Glossary Item Box

Show All Show All
Hide All Hide All

The Custom Preview sample demonstrates a method to view a report at client side in HTML or PDF format. Application structure consists of ASP.NET website, using which the report is streamed to the client as HTML or PDF. This sample describes custom exporting without the Pro Edition server controls or RPX handlers as well as running reports on the server. The PDF and HTML exports allow you to manually control exporting by writing a little code in ASP.NET language. Steps explained in this sample can be used for both Standard and Professional editions.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: Before running this sample, in the Solution Explorer, click the Licenses.licx file and then, from the Build menu, select Build Runtime License. Please see To license Web Forms projects made on the trial version for details.

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\CustomPreview\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\CustomPreview\C#

Details

When you run the sample, the Default.aspx page appears in your browser. This page provides two links to other reports that demonstrate custom PDF or HTML export options.

Clicking the Custom Exporting PDF Example option opens the Invoice report and clicking Custom Exporting HTML Example option opens NwindLabels report in the Default.aspx page.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

The project consists of the following elements.

  • Reports folder: The Reports folder contains two rpx reports - the Invoice report and the NwindLabels report.

    Show Invoice Report

    The Invoice report uses three GroupHeader sections, a Detail section and a GroupFooter section as well as a label in the PageFooter section to display data.

    Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

    Show ghOrderHeader section

    The DataField property of this section is set to OrderID. This setting, in conjunction with data ordered by the OrderID field, causes the report to print all of the information for one order ID value, including all of the related details and footers, before moving on to the next order ID. For more information on grouping, see Grouping Data in Section Reports.

    This section also contains a Picture control, a number of Label controls, and two bound TextBox controls. The TextBoxes are bound using the DataField property in the Properties window, and the date is formatted using the OutputFormat property.

    Show ghOrderID section

    The DataField property of this section is also set to OrderID. This allows subtotal summary functions in the related GFOrderID section to calculate properly.

    This section contains a number of labels and bound text boxes, as well as two Line controls.

    Show ghTableHeader section

    This section contains only labels for the data to follow in the Detail section.

    Show Detail section

    This section contains bound TextBox controls. These TextBoxes render once for each row of data found in the current OrderID before the report moves on to the GroupFooter sections.

    Show GFOrderID section

    The NewPage property of this section is set to After. This causes the report to break to a new page and generate a new invoice after this section prints its subtotals.

    This section contains several labels and several TextBoxes. Two of the TextBox controls use the following properties to summarize the detail data: SummaryFunc, SummaryGroup, and SummaryType. For more information, Create a Summary Report.

    The Total TextBox does not use the DataField property or any of the summary properties, or even any code. To find the functionality of this TextBox, in design view, click the Script tab at the bottom of the report.

    Show PageFooter section

    This section has one simple Label control. For more information about report sections and the order in which they print, see Section Report Structure and Section Report Events.

    Show NwindLabels Report

    TheNwindLabels report only uses the Detail section to display the report data.

    Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

    Show Detail section

    This section contains bound TextBox controls and Label controls. This section prints 30 labels per 8½ x 11 sheet.

    The Detail section uses the CanGrow property set to False to maintain the label size and the ColumnCount, ColumnDirection, and ColumnSpacing properties to accommodate multiple labels in a single page.

  • CustomExportHtml.aspx: This Web form is displayed by clicking the Custom Exporting HTML Example option on the Default.aspx page. In CustomExportHtml.aspx, report is outputted to the ReportOutput folder using the CustomHtmlOutput class and the exported HTML is displayed in the browser. The CustomHtmlOutput class implements the required IOutputHtml in the HTML export and saves the output results to a file with a unique name.
    Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.
  • CustomExportPdf.aspx: The Web form is displayed by clicking the Custom Exporting PDF Example option on the Default.aspx page. In CustomExportPdf.aspx, the report is exported to memory stream and then outputted in the browser.
    Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.
  • Default.aspx: This is the main Web form of the sample that shows the introductory text and links to other sample pages that demonstrate the following web features.
    • Custom Exporting PDF Example - This link opens the Invoice report in the PDF Reader by exporting it to memory stream and then outputting it in the browser.
    • Custom Exporting HTML Example - This link opens the NWindLabels report. This report is outputted to the ReportOutput folder by using the CustomHtmlOutput class and the exported HTML is displayed in the browser.
  • Web.config: This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web. Note that you need to manually update version information here when you update your version of ActiveReports.

See Also

How To
Customize the Viewer Control

Concepts
Section Report Events

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Financial Portfolio

Financial Portfolio
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > Financial Portfolio

Glossary Item Box

The Financial Portfolio sample demonstrates how to visualize stock data with a Candlestick Chart.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\FinancialPortfolio\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\FinancialPortfolio\C#

Details

When you run the sample, the start page with the Candlestick Chart appears. In the left panel, you can click a company from the list to see its stock data.

The project consists of the following elements.

  • Css folder: The css folder contains css files that store styles for the viewer application.
  • Data folder: This folder contains the Stocks.xml file with the data the Candlestick Chart uses.
  • fonts folder: The fonts folder contains font files to provide styles to the text that gets displayed in the viewer at run time.
  • images folder: The images folder contain images for the buttons used in the sample.
  • Reports folder: The Reports folder contains the following reports - AnnualStockTicker.rdlx and MonthlyStockTradingData.rdlx.
  • Scripts folder: The Scripts folder contains javascript files and its dependencies required to build this application.
  • ActiveReports.ReportService.asmx is an ASP.NET Webservices Source file that is required for creating and proper functioning of the Viewer. You can add this service using the Add New Item in the Visual Studio Project menu and then selecting ActiveReports 13 Web Service.
  • index.html hosts the UI page on the browser. It contains html code for the appearance and functioning of this page.
  • Web.config: This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web. Note that you need to manually update version information here when you update your version of ActiveReports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


HTML5 Viewer

HTML5 Viewer
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > HTML5 Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

The HTML5 Viewer sample demonstrates the use of HTML5 Viewer and its options to load different report types in basic or customized viewer.

Note: HTML5 Viewer is deprecated and will be obsolete in the future version.

Basic UI

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Custom UI

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\HTML5 Viewer\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\HTML5 Viewer\C#

Details

When you run the sample, the index.html containing the HTML5 Viewer appears on your browser with the following options to choose from:

  • Basic or Custom UI Viewer

The Basic UI Viewer appears by default with an option of switching to Custom UI Viewer by clicking the Custom UI option.

The Custom UI option loads the CustomUI.html in the browser. On the Custom UI Viewer page, you can click on any Genre category button to pass parameter to the MoviesReport.rdlx report and load the report in the viewer specific to the passed parameter value.

While working on the Custom UI Viewer, you can always switch back to the Basic UI Viewer by clicking the Basic option.

  • Choose Report: Page Report, RDL Report , RPX Report and Code-based Report

These options are a part of the Basic UI Viewer. Click on any of these buttons to load a report of specific format.

  • Choose UI Type: Desktop or Mobile

These options are a part of the Basic UI Viewer and are related to the Viewer report preview area. When you run this project, the HTML5 Viewer Desktop UI appears in the browser by default. You can switch to the HTML5 Viewer Mobile UI by clicking the Mobile button.

The project consists of the following elements:

  • Css folder: The css folder contains css files that store styles for the HTML5 viewer application.
  • Fonts folder: The fonts folder contains font files to provide styles to the text that gets displayed in the HTML5 viewer at run time.
  • images folder: The images folder contain images for the buttons used in the Custom UI Viewer.
  • Reports folder: The Reports folder contains the following reports:
BillingInvoice.rdlx: This page based report gets loaded in the viewer when you select the Page Report type in the Basic UI viewer. This report uses the NWind shared data source connection to provide data. This report showcases a billing invoice layout commonly used in convenience stores. The report mostly contains Label, TextBox and Line controls in its layout. The EAN128FNC1 barcode is used in this report due to its high reading accuracy in convenience stores.
Invoice.rpx: This section based report gets loaded in the viewer when you select the RPX report type in the Basic UI viewer. This report uses the NWind data source connection to provide data. This report uses TextBox controls to create the Invoice layout for displaying customer transactions. One of the TexBox uses the Sum function to display the GrandTotal of all transactions.
MoviesReport.rdlx: This page based report appears in the Custom UI viewer. This report uses the Reels database to provide data to showcase the list of movies based on different genres using the parameter set on the GenereName field.
OilProducingCountries.rdlx: This page based report gets loaded in the viewer when you select the RDL report type in the Basic UI viewer. This report uses the FactBook database to provide data to the Map control that visualizes the oil production for different parts of the world.
rpt2DBar: This code-based section report gets loaded in the viewer when you select the Code-based report type in the Basic UI viewer. This report displays bar chart and retrieves the data to be displayed in a chart from Orders table of NWind database.
SalesDashboard.rdlx: This page based report gets loaded in the viewer when you select the RDL report type in the Basic UI viewer. This report uses the SalesResult database to display multiple Chart controls and a Tablix data region to visualize the sales performance data. This report illustrates the Galley-mode feature where all of the report contents can be previewed in a single scrollable page.
  • Scripts folder: The Scripts folder contains javascript files and its dependencies required to build this application.
  • ActiveReports.ReportService.asmx is an ASP.NET Webservices Source file that is required for creating and proper functioning of the HTML5 Viewer. You can add this service using the Add New Item in the Visual Studio Project menu and then selecting ActiveReports 13 Web Service.
  • customUI.html hosts the Custom UI page on the browser. It contains html code for the appearance and functioning of the Custom Ul page.
  • index.html is the main page that gets hosted on the browser when you run this sample. It contains html code for the appearance and functioning of the main page.

See Also

Using Javascript

Getting Started
HTML5 Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


HTML5 MVC

HTML5 MVC
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > HTML5 MVC

Glossary Item Box

Show All Show All
Hide All Hide All

The HTML5 MVC sample demonstrates an MVC web application with the ActiveReports Web Viewer. This Sample is part of the ActiveReports Professional Edition.

Note: Before running this sample, you must first install the ASP.NET MVC 3 framework on your machine.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\HTML5_MVC\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\HTML5_MVC\C#

Details

When you run the project, the page with the Customer Index view appears. On this page, you can click a customer in the list to open a new page with the Customer Details information. At the bottom of the page, there are two links - Freight Summary (section report) and Order Summary (page report). Clicking the Freight Summary (section report) link opens a page with the OrderReport report. Clicking the Order Summary (page report) link opens a page with the OrderDetailsReport.rdlx report. The project consists of:

Controllers: This folder contains the HomeController that handles the user interaction and returns the main Index view, the CustomerDetails view and the views with Freight Summary (section report) and Order Summary (page report).

DBContext: This folder contains the NWindData class that gets the Customer, Orders, Order Details tables of the NWIND.mdb and populates the data into the components of this sample project.

Models: This folder contains the following classes.

  • Customer - a container for the rows in the Customers table of NWind.mdb.
  • Order - a container for the rows in the Orders table of NWind.mdb.
  • OrderDetails - a container for the rows in the Order Details table of NWind.mdb.
  • ReportDescriptor - the class representation of the ReportType (section or page layout) and the CustomerID.
  • Repository - a container for data required by the application.

Reports:

  • OrderDetailsReport.rdlx: This report uses the object provider to connect to data at run time. It uses the Table data region to display order details and the Plain Line chart to display sales by order id. The Table data is grouped by OrderID. Some TextBox controls of the Table use the Sum function to display the total price information for each order. This is the report that opens in a separate view when you click the Order Summary (page report) link on the Customer Details page.
  • OrderReport: This report binds to data at run time. The report uses the Textbox and Label controls to display the order details and the Bar chart to display the freight amounts by ship date. This is the report that opens in a separate view when you click the Freight Summary (section report) link on the Customer Details page.

Views: Contains the Home folder and the Web.config file. The Home folder consists of views. The configuration file contains the httpHandlers that allow ActiveReports to process view pages on the Web.

ActiveReports.Service.asmx: The report web service required for the proper functioning of the Web Viewer. The ActiveReports.Service.asmx is added automatically to the project when you place the Viewer control on the form. You can also can add this service by using Add New Item in the Visual Studio Project menu.

Global.asax: The default class that sets global URL routing values for this web application.

Web.config: The configuration file that contains the httpHandlers that allow ActiveReports to process this web application. Note that you need to manually update version information here when you update your version of ActiveReports.

See Also

Getting Started
Web Viewer (ASP.NET)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


HTML5 Web API With AngularJs

HTML5 Web API With AngularJs
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > HTML5 Web API With AngularJs

Glossary Item Box

Show All Show All
Hide All Hide All

This sample demonstrates how to use the ActiveReports HTML5 Viewer in the ASP.NET MVC5 framework. This Sample is part of the ActiveReports Professional Edition.

Note: Before running this sample, you must first install the ASP.NET MVC5 framework on your system.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\HTML5_WebApiWithAngularJs\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\HTML5_WebApiWithAngularJs\C#

Details

When you run the sample, the page with the main view appears. On the left side of the main view, you can click a customer name under the Customer List. On the right side of the main view, you have the Customer Info tab and the Reports tab. Following options are available on this page.

  • Customer List

    Displays a list of customer names. You can use the search box on the top to search for customer names.

  • Customer Info tab

    Displays details of the customer name selected in the customer list.

  • Reports tab

    Displays a report for the selected customer in the HTML5 Viewer. You can choose from the following options.

    • Choose Report: You can choose from Orders (Page Report) or Product Details (Section Report). The selected report is displayed in the HTML5 Viewer.
    • Choose UI type: You can choose from Desktop or Mobile options. The default mode is set to Desktop. On selecting the Mobile UI type, the layout adapts itself to the mobile device display.

The project cosists of the following elements.

  • App_Start folder: This folder contains cs files that are required to run the application.
  • Content folder: This folder contains images used for the Viewer buttons. It also contains .css files that define the style of application.
  • Controllers folder: This folder contains the HomeController and CustomersController files. The HomeController handles the user interaction and returns the main view. The CustomersController handles the customer details information that is displayed when a customer is selected.
  • css folder: The css folder contains the following css files that store styles for the HTML5 viewer application.
  • GrapeCity.ActiveReports.Viewer.Html.css
  • theme-cosmo.css
  • fonts folder: The folder contains the font files to provide styles to the text that gets displayed in the HTML5 viewer at run time.
  • Models folder: This folder contains the following classes.
  • Customer - Contains information for the rows in the Customers table of Reels.mdb.
  • CustomerContext - Contains information for the rows in the CustomerOrders table of Reels.mdb.
  • Reports:
  • OrderDetailsReport.rdlx: This page report loads in the HTML5 Viewer when you select the Orders report for the Desktop UI type. This report uses the Table data region to display the order details. The Sum function is used to display the totals.
  • ProductDetail.rpx: This section report loads in the HTML5 Viewer when you select Product Details for the Desktop UI type. This report uses the Textbox and Label controls to display the data. The Sum function is used to display the total price information for each customer order.
  • Scripts folder: The folder contains javascript files and its dependencies required to build this application.
  • Views folder: It consists of the Home folder with the index view start file, the Shared folder with the default layout file, ViewStart.cshtml which is the default view start file, and Web.config file that contains settings for the HTTP handler.
  • ActiveReports.ReportService.asmx: This is the report web service required for the proper functioning of the WebViewer control. The ActiveReports.ReportService.asmx is added automatically to the project when you place the Viewer control on the form. You can also can add this service by using Add New Item in the Visual Studio Project menu.
  • Global.asax: This is the default class that sets global URL routing values for this web application.
  • Startup.cs: This is the default startup file.
  • Web.config: The configuration file that contains the httpHandlers that allow ActiveReports to process this web application. Note that you need to manually update version information here when you update your version of ActiveReports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


JSViewer Angular(Core)

JSViewer Angular(Core)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > JSViewer Angular(Core)

Glossary Item Box

The JSViewer_Angular(Core) sample demonstrates the use of the GrapeCity ActiveReports JS Viewer with an Angular 7 app and ASP.NET Core back-end.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Note: To run this sample, you must have

  • Visual Studio 2017 (https://visualstudio.microsoft.com/vs/) version 15.7 or newer.
  • .NET Core 2.1 SDK or later installed on your machine.
  • .NET Core Hosting Bundle](https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/iis/index?view=aspnetcore-2.1#install-the-net-core-hosting-bundle) (for deployment to IIS).
  • Angular requires the Node.js 8.x or 10.x version.

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\JSViewer_Angular(Core)\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\JSViewer_Angular(Core)\C#

Details

When you run the sample, the default page appears in your browser. This page provides links to reports that demonstrate the use of the GrapeCity ActiveReports JS Viewer with an Angular 7 app and ASP.NET Core back-end.

Clicking the report link in the left panel opens the report for preview. You can preview the following reports.

  • AnnualReport.rdlx
  • Invoice.rdlx
  • Invoice.rpx
  • InvoiceList.rdlx
  • Invoice_Colored.rpx
  • Project&ResourceAnalysis
  • Statistical analysis scatter plot.rdlx - Staff Performance Analysis.rdlx
  • User defined report columns.rdlx

The project consists of the following elements.

  • ClientApp folder: This folder contains a standard Angular CLI app that is used for all UI concerns.
  • Controllers folder: This folder contains the ReportsController files. The ReportsController handles the interaction with reports when a report is selected in the left panel.
  • appsettings.json: The json configuration file.
  • readme: This file contains the instructions on how to run the sample project.
  • Startup.cs: This is the default startup file.
  • Web.config: This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web. Note that you need to manually update version information here when you update your version of ActiveReports.

Before publishing the sample, you must do the following.

  • In the JSViewer_Angular(Core).csproj file, set the PublishToIIS property to true as follows: <PublishToIIS>true</PublishToIIS>.
  • Copy the sample ViewerApp folder to the publish folder.

See Also

JS Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


JSViewer MVC

JSViewer MVC
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > JSViewer MVC

Glossary Item Box

The JSViewer_MVC sample demonstrates the use of the GrapeCity ActiveReports JS Viewer with an ASP.NET MVC 5 back-end.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Note: To run this sample, you must have:

  • Visual Studio 2012 (https://visualstudio.microsoft.com/vs/) or newer
  • .NET Framework Dev Pack (https://www.microsoft.com/net/download) 4.6.2 or later

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\JSViewer_MVC\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\JSViewer_MVC\C#

Details

When you run the sample, the default page appears in your browser. This page provides links to reports that demonstrate the use of the GrapeCity ActiveReports JS Viewer with an ASP.NET MVC 5 backend.

Clicking the report link in the left panel opens the report for preview. You can preview the following reports.

  • AnnualReport.rdlx
  • Invoice.rdlx
  • Invoice.rpx
  • Invoice_Colored.rpx
  • InvoiceList.rdlx
  • Project & Resource Analysis - Staff Performance Analysis.rdlx
  • User defined report columns.rdlx
  • Statistical analysis scatter plot.rdlx

The project consists of the following elements.

  • Controllers folder: This folder contains the HomeController that handles the user interaction and returns the main Index view.
  • ViewerApp folder: Contains JS Viewer CSS and JavaScript files.
  • Global.asax: The default class that sets global URL routing values for this web application.
  • packages.config
  • Startup.cs: This is the default startup file.
  • Web.config: This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web. Note that you need to manually update version information here when you update your version of ActiveReports.

Before publishing the sample, you must copy the sample ViewerApp folder to the publish folder.

See Also

Viewing Reports using JS Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


JSViewer MVC(Core)

JSViewer MVC(Core)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > JSViewer MVC(Core)

Glossary Item Box

The JSViewer_MVC(Core) sample demonstrates the use of the GrapeCity ActiveReports JS Viewer with an ASP.NET Core back-end.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Note: To run this sample, you must have

  • Visual Studio 2017 (https://visualstudio.microsoft.com/vs/) version 15.7 or newer
  • .NET Core 2.1 SDK or later installed on your machine.
  • .NET Core Hosting Bundle](https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/iis/index?view=aspnetcore-2.1#install-the-net-core-hosting-bundle) (for deployment to IIS)

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\JSViewer_MVC(Core)\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\JSViewer_MVC(Core)\C#

Details

When you run the sample, the JS Viewer opens in your browser. The viewer provides links to reports to demonstrate GrapeCity ActiveReports JS Viewer with an ASP.NET Core back-end.

Clicking the report link in the left panel opens the report for preview. You can preview the following reports.

  • AnnualReport.rdlx
  • Invoice.rdlx
  • Invoice.rpx
  • InvoiceList.rdlx
  • Invoice_Colored.rpx
  • Project & ResourceAnalysis - Staff Performance Analysis.rdlx
  • Statistical analysis scatter plot.rdlx
  • User defined report columns.rdlx

The project consists of the following elements.

  • Controllers folder: This folder contains the HomeController that handles the user interaction and returns the main Index view.
  • ViewerApp folder: Contains JS Viewer CSS and JavaScript files.
  • readme: This file contains the instructions on how to build and run the sample project.
  • Startup.cs: This is the default startup file.
  • Web.config: This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web. Note that you need to manually update version information here when you update your version of ActiveReports.

Before publishing the sample, you must do the following.

  • In the index.html file, uncomment the line <!--<base href="/JSViewer_MVC_Core/">-->.
  • Copy the sample ViewerApp folder to the publish folder.

See Also

Viewing Reports using JS Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Plant Performance

Plant Performance
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > Plant Performance

Glossary Item Box

The Plant Performance sample demonstrates how to visualize the Plant Performance KPIs using the Map control.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Plant Performance\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Plant Performance\C#

Details

When you run the sample, the start page with the Plant Perfomance KPIs for Atlanta is displayed. On this page, you can choose another location from the drop-down list on top of the page.

The project consist of the following elements.

  • Css folder: Contains css files that store styles for the viewer application.
  • fonts folder: Contains font files to provide styles to the text that gets displayed in the viewer at run time.
  • images folder: Contain images for the buttons used in the sample.
  • Reports folder: Contains the PlantPerformance.rdlx report.
  • Scripts folder: Contains javascript files and its dependencies required to build this application.
  • ActiveReports.ReportService.asmx is an ASP.NET Webservices Source file that is required for creating and proper functioning of the Viewer. You can add this service using the Add New Item in the Visual Studio Project menu and then selecting ActiveReports 13 Web Service.
  • index.html: Hosts the UI page on the browser. It contains html code for the appearance and functioning of this page.
  • Web.config: This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web. Note that you need to manually update version information here when you update your version of ActiveReports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports Gallery

Reports Gallery
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > Reports Gallery

Glossary Item Box

The Reports Gallery sample demonstrates a list of categorized reports. You can click any report out of the three categories: Page, Rdl, and Section and see the report page along with its description.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Reports Gallery\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Reports Gallery\C#

Details

When you run the sample, the start page with the Thumbnail images of reports that are categorized into the following groups - RDL Reports, Page Reports and Section Reports. Clicking each thumbnail image opens a separate page where a selected report is displayed in the Web Viewer. Each report is provided with a general description.

The project consists of the following elements.

  • Css folder: Contains css files that store styles for the viewer application.
  • fonts folder: Contains font files to provide styles to the text that gets displayed in the viewer at run time.
  • images folder: Contains images for the buttons used in the sample.
  • json folder: Contains json files required for this sample.
  • Reports folder: Consists of three subfolders - Page Report, RDL Report and Section Report, each containing a set of reports that highlight the major features of the corresponding report types. You will find the detailed descriptions of each report here.
  • Scripts folder: Contains javascript files and its dependencies required to build this application.
  • ActiveReports.ReportService.asmx is an ASP.NET Webservices Source file that is required for creating and proper functioning of the Viewer. You can add this service using the Add New Item in the Visual Studio Project menu and then selecting ActiveReports 13 Web Service.
  • Global.asax: The default class that sets global URL routing values for this web application.
  • index.html: Hosts the UI page on the browser. It contains html code for the appearance and functioning of this page.
  • readme.txt: Provides instructions on what to do if Directory Listing appears instead of Start page when you run the sample.
  • web.config: This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web. Note that you need to manually update version information here when you update your version of ActiveReports.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web Designer MVC

Web Designer MVC
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > Web Designer MVC

Glossary Item Box

The Web Designer_MVC sample demonstrates Web Designer with an ASP.NET MVC 5 back-end.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Web Designer_MVC\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Web Designer_MVC\C#

Details

When you run the sample, the Web Designer opens in your browser wherein you can create, edit, or modify your reports. Following are the main menu options:

  • File: Contains options to create, open or save reports. It also contains the version information in About option and help documentation link in Help option.

  • Home: Consists of report editing options such as cut, copy, paste, and delete. It also provides shortcuts for text formatting such as font, font size, font color, and horizontal and vertical text alignments.

  • Report: Contains options to add, delete, or move pages (in Page report) and add or remove header and footer (RDL report), and change report themes.

  • Properties: Displays the properties of the selected report element. If more than one element is selected, only their common properties are shown.

  • Data: Contains options to manage data sets and parameters. It also displays common values such as current date and time, page number, total pages, and more.

The project consists of the following elements.

  • Controllers: Contains DataSets, Design, Preview, and Templates controllers.
  • Datasets: Contains JSON datasets Categories, Employees, and Products.
  • Resources: Contains reports, themes, images, etc. that are used by the project to illustrate Web Designer.
  • Services: Consists of classes that get datasets and templates information.
  • wwwroot: Contains designer CSS and JavaScript files.

Before publishing the sample, you must copy the sample datasets, resources, templates folders to the publish folder.

See Also

Viewing Reports using JS Viewer

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web Designer MVC(Core)

Web Designer MVC(Core)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > Web Designer MVC(Core)

Glossary Item Box

The Web Designer_MVC(Core) sample demonstrates Web Designer with an ASP.NET Core back-end.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Web Designer_MVC(Core)\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\Web Designer_MVC(Core)\C#

Details

When you run the sample, the Web Designer opens in your browser wherein you can create, edit, or modify your reports. Following are the main menu options:

  • File: Contains options to create, open or save reports. It also contains the version information in About option and help documentation link in Help option.

  • Home: Consists of report editing options such as cut, copy, paste, and delete. It also provides shortcuts for text formatting such as font, font size, font color, and horizontal and vertical text alignments.

  • Report: Contains options to add, delete, or move pages (in Page report) and add or remove header and footer (RDL report), and change report themes.

  • Properties: Displays the properties of the selected report element. If more than one element is selected, only their common properties are shown.

  • Data: Contains options to manage data sets and parameters. It also displays common values such as current date and time, page number, total pages, and more.

The project consists of the following elements.

  • Controllers: Contains DataSets, Design, Preview, and Templates controllers.
  • Datasets: Contains JSON datasets Categories, Employees, and Products.
  • Resources: Contains reports, themes, images, etc that are used by the project to illustrate Web Designer.
  • Services: Consists of classes that get datasets and templates information.
  • wwwroot: Contains designer CSS and JavaScript files.

Before publishing the sample, you must copy the sample datasets, resources, templates folders to the publish folder.

See Also

Create a Simple Web Designer Sample

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


WebViewer Pro

WebViewer Pro
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Web > WebViewer Pro

Glossary Item Box

The Active Reports Web Pro Sample describes the standard ActiveReports web features as well as other features available in the Professional Edition only, such as HTTP handlers, custom PDF and HTML export, parameterized reports, and more.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: Before running this sample, in the Solution Explorer, click the Licenses.licx file and then, from the Build menu, select Build Runtime License. Please see To license Web Forms projects made on the trial version for details.

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\WebViewerPro\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 13\Web\WebViewerPro\C#

Details

When you run the sample, the Default.aspx page appears in your browser. This page provides links to other sample pages that demonstrate the following web features.

WebControl for ASP.NET: This link opens the WebControl.aspx page that allows you to select any of the three Viewer Types and it also allows you to select from Section, Page and RDL Report Type.

The three Viewer Types that are available are as follows:

  • HtmlViewer
  • AcrobatReader
  • RawHtml

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

HTTPHandlers: This link opens the HttpHandlers.aspx page with the http handler examples.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Custom Exporting PDF Example: This link opens the Invoice report in the PDF Reader by exporting it to memory stream and then outputting it in the browser.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Custom Exporting HTML Example: This link opens the NWindLabels report. This report is outputted to the ReportOutput folder by using the MyCustomHtmlOutputter class and the exported HTML is displayed in the browser.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Parameterized Report Example: This link opens the page that demonstrates how to generate a report by passing a parameter to the report.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

The project contains the following elements:

  • CodeReports: The CodeReports folder contains the following reports - Invoice, InvoiceFiltered, NwindLabels and NwindLabelsFiltered. The code reports are used to demonstrate how the ActiveReports Compiled Report HttpHandler functions. For more details, see HttpHandlers.aspx below.
  • PageReports: The PageReprorts folder contains the Invoice_Grouped and PurchaseReport report.
  • RDLReports: The RdlxReports folder contains the SalesReceipt report.
  • RPXReports: The RpxReports folder contains the following reports - Invoice, InvoiceFiltered, NwindLabels, NwindLabelsFiltered and Params. These reports are used to demonstrate how the RPX HttpHandlers function. For more details, see HttpHandlers.aspx below.

    The Invoice.rpx report is used to demonstrate the Web Viewer control options and is opened by clicking WebControl for ASP.NET on the Default.aspx page. This report is also opened by clicking the Custom Exporting PDF Example option on the Default.aspx page. For detailed information on the Invoice report, see the Cross Section Control Sample.

    The NwindLabels report is opened by clicking the Custom Exporting HTML Example option on the Default.aspx page.

    The Params report is used by the ParameterReport.aspx page to demonstrate how to generate a report by passing a parameter to the report.
  • ActiveReports.ReportService.asmx: The report web service is required for proper functioning of the Web Viewer. The ActiveReports.ReportService.asmx is added automatically to the project when you place the WebViewer control on the form. You can also add this service by using Add New Item in the Visual Studio Project menu.

    For the information on how to use the WebViewer control, see Getting Started with the Web Viewer.
  • CustomExportHtml.aspx: This Web form is displayed by clicking the Custom Exporting HTML Example option on the Default.aspx page.
    In CustomExportHtml.aspx, the NWindLabels report is outputted to the ReportOutput folder using the CustomHtmlOutput class and the exported HTML is displayed in the browser.
    Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.
  • CustomExportPdf.aspx: This Web form is displayed by clicking the Custom Exporting PDF Example option on the Default.aspx page. In CustomExportPdf.aspx, the Invoice report is exported to memory stream and then outputted in the browser.
    Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.
  • Default.aspx: This is the main Web form of the sample that shows the introductory text and links to the following sample pages.
    • WebControl for ASP.NET (WebControl.aspx)
    • HTTPHandlers (HttpHandlers.aspx)
    • Custom Exporting PDF Example (Invoice report)
    • Custom Exporting HTML Example (NWindLabels report)
    • Parameterized Report Example(ParameterReport.aspx)
  • HttpHandlers.aspx: ActiveReports provides HttpHandler components that allow ASP.NET to automatically process reports that have been placed into an ASP.NET web site folder. ActiveReports HttpHandler components enable easily deployable reports in both HTML and PDF file formats. ActiveReports includes a simple configuration utility to properly register the HttpHandler components with IIS and ASP.NET.
    The RPX and RDLX HttpHandler processes and outputs reports from ActiveReports layout files (ending in the .rpx/.rdlx extension). When the ASP.NET receives a request for an ActiveReport file ending with the .rpx/.rdlx extension, the RPX/RDLX HttpHandler will run, and return the report's output in a format of your choice.
    The compiled Report HttpHandler enables easy distribution of ActiveReports that use compiled .NET source code. Compiled reports are exposed as a .NET class in a .NET assembly file. When ASP.NET receives a request for a file with the .ActiveReport extension, the Compiled Report handler will load the ActiveReports from the assembly, run it, and return the output in a format of your choice.
    For information on configuring the http handlers, see Configure HttpHandlers in IIS 7 and IIS 8. The required mapping for each feature has been listed below.
    WebViewer control | ActiveReports 13 Cache Item Script Mapping is required
    Compiled Report Handler (the report explorer is embedded in the assembly after compiling the report ) | ActiveReport Script Mapping is required
    RPX HTTP Handler (when the *.rpx report is placed on the Web) | ActiveReports 13 RPX Script Mapping is required
    RDLX HTTP Handler (when the *.rdlx report is placed on the Web) | ActiveReports 13 RDLX Script Mapping is required
  • ParameterReport.aspx: The web form that demonstrates how to generate a report by passing a parameter to the report. This sample uses the Params report from the RpxReports folder of this Sample project. The date list is created by changing the SQL query of the report at run time. In this sample, when the date is selected from the Calendar control, the SQL query is updated and the report is generated. The report is generated dynamically in the SelectedIndexChanged event of the Calendar control. On this form, you can select the Viewer to display the report - HTML, AcrobatReader, or RawHTML.
    Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.

  • Web.config: The configuration file that contains the httpHandlers that allow ActiveReports to process reports on the Web.
    Note: You need to manually update version information here when you update your version of ActiveReports.
  • WebControl.aspx: This page is opened by clicking WebControl for ASP.NET on the Default.aspx page. By default, it displays the Web Viewer control with the Invoice report. In this page, you can select from HTMLViewer, AcrobatReader, RawHtml viewer types and can also select from Page, Section and RDL report types to be displayed.

See Also

Report Types
Parameters

Getting Started
Web Viewer (ASP.NET)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Walkthroughs

Walkthroughs
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs

Glossary Item Box

The Walkthroughs section of the User Guide provides you with step-by-step tutorials that you can follow as you create projects in Visual Studio. These walkthroughs cover the key features of Page Reports, RDL Reports and Section Reports in different scenarios. The walkthroughs progress from basic through advanced for Standard and Professional Editions of ActiveReports.

This section contains information about:

Page Report/RDL Report Walkthroughs
Learn the dynamic features through easy to implement scenarios for Page Report and RDL Report.
Section Report Walkthroughs
Use the walkthroughs under this section to understand key features of a section report through simple scenarios.
Common Walkthroughs
Common walkthroughs cover scenarios to introduce the key features of page, RDL and section reports.

See Also

Samples and Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Page Report/RDL Report Walkthroughs

Page Report/RDL Report Walkthroughs
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs

Glossary Item Box

Page Report walkthroughs cover scenarios to introduce the key features of Page Reports and RDL reports. Learn about different walkthroughs categorized as follows.

Data
This section contains the walkthroughs that explain various ways of working with data sources.
Layout
This section contains the walkthroughs that explain how to create different report layouts.
Chart
This section contains the walkthrough that demonstrates how to work with the ActiveReports Chart control.
Map
This section contains the walkthrough that demonstrates how to work with the ActiveReports Map control.
Tablix
This section contains the walkthroughs that demonstrates how to work with the ActiveReports Tablix data region.
Export
This section contains the walkthrough that demonstrates how to export your reports into several popular formats like PDF, HTML, Excel, Image and Word.
Preview
This section contains the walkthrough that demonstrates how to work with custom data and custom code.
Advanced
This section contains the walkthroughs that demonstrate interactive features of ActiveReports reports.

See Also

Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Data

Data
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data

Glossary Item Box

This section contains the following walkthroughs that fall under the Data category.

Master Detail Reports
This walkthrough demonstrates how to create a master detail report using the Table control and grouping.
Reports with Parameterized Queries
This walkthrough demonstrates how to create a simple dynamic query.
Reports with Stored Procedures
This walkthrough demonstrates how to create a report that uses a stored procedure as a data set.
Reports with XML Data
This walkthrough demonstrates how to connect a report to an XML data source and to create a data set.
Reports with JSON Data
This walkthrough demonstrates how to connect a report to a JSON data source at run time and use a web service to fetch the data with the authorized access.
Reports with CSV Data
This walkthrough demonstrates how to connect a report to a CSV data source.
Expressions in Reports
This walkthrough demonstrates how to use expressions to achieve different effects in a report.
Multiple Datasets in a Data Region
This walkthrough demonstrates how to use multiple datasets in a data region using Lookup function.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Master Detail Reports

Master Detail Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Master Detail Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a master detail report using the Table control and grouping. The following walkthrough takes you through the step by step procedure of creating a Master Detail report.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset to the report
  • Adding controls to the report to contain data
  • Viewing the report
Note:
  • This walkthrough uses the Customer table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as rptMasterDetail.
  4. Click the Add button to open a new fixed page report in the designer.
  5. For a $$RDL report$$, from the Report menu, select Convert to RDL Report.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as CustomerOrders. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT CustomerID, Title, LastName, Quantity, Price, [Quantity]*[Price] AS
Total FROM CustomerOrders WHERE CustomerID < 1010
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

Show To add a table with grouping to the report

  1. From the toolbox, drag a Table data region onto the report design surface and go to the Properties Window to set its Location property to 0in, 1in.
  2. Click inside the table to display the column and row handles along the top and left sides of the table.
  3. To visually group the data within the report, right-click the row handle to the left of the detail row and select Insert Group.
  4. In the Table - Groups dialog that appears, under Expression select =Fields!CustomerID.Value.
    This groups the details from each customer.
  5. Change the Name to Customer.
    Note: You cannot change the name of a table group until you have set the expression.
  6. Click OK to close the dialog. The group header and footer rows are added to the table.

Show To add a fourth column to the table

  1. Select the second column and in the Properties Window, change its Width property to 0.92in.
  2. Select the third column and in the Properties Window, change its Width property to 1.04in.
  3. Select the first column and in the Properties Window, change its Width property to 3.5in.
    Tip: Making some columns narrower before making other columns wider prevents your report width from changing.
  4. Right-click the column handle above the third column and select Insert Column to the Right. The inserted fourth column has the same width as the third column, which is 1.04in.

Show To add data to the table

  1. Place your mouse over the Textbox located in the first column of the group header row of the table to display the field selection adorner.
  2. Click the adorner to display the list of available fields from the DataSet and select LastName. This automatically places an expression in the group header row and simultaneously places a static label in the table header row.
  3. In the Properties window, set the FontSize property of this textbox to 12pt.
  4. In the table header row, delete the static label Last Name.
  5. To display static labels at the beginning of each new group, right-click the row handle to the left of the group header row and select Insert Row Below.
  6. In the first column of the detail row, use the field selector adorner to select the Title field.
  7. In the textbox immediately above it, type Title.
  8. In the table header row, delete the static label Title.
  9. In the second column of the detail row, use the field selector adorner to select the Quantity field. This automatically places an expression in the detail row and simultaneously places a static label in the header row of the same column.
  10. In the Properties window, set the TextAlign property of the Quantity field to Left.
  11. Cut the static label and paste it into the inserted row immediately above the detail row.
  12. In the third column of the detail row, use the field selector adorner to select the Price field.
  13. In the Properties window, set the following properties.
    Property Name | Property Value
    TextAlign | Left
    Format | C (uses currency formatting)
  14. Cut the static label from the group header and paste it into the inserted row immediately above the detail row.
  15. Select the Total field for the fourth column of the detail row of the table.
  16. In the Properties window, set the following properties.
    Property Name | Property Value
    TextAlign | Left
    Format | C (uses currency formatting)
  17. Cut the static label from the group header and paste it into the inserted row immediately above the detail row.

Show To refine the look of the report

  1. Right-click any row handle to the left of the table and select Table Header to remove the table header row since it is not being used.
  2. Select the Header row containing the labels by clicking the table handle to the left of the row.
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    RepeatOnNewPage | True
    FontWeight | Bold
  4. From the Report Explorer, drag the Total field into the group footer row in the fourth column to add subtotaling to the group. Notice that the expression automatically uses the Sum function.
  5. Go to the Properties window to set the following properties.
    Property Name | Property Value
    Format | C (uses currency formatting)
    FontWeight | Bold
  6. From the Report Explorer, drag the Total field into the table footer row in the fourth column. This adds grand totaling to the table.
  7. Go to the Properties window to set the following properties.
    Property Name | Property Value
    Format | C (uses currency formatting)
    FontWeight | Bold
  8. Delete the static label Total from the top row.
  9. In the Report Explorer select the Table data region and set its FixedSize property to 6.5in, 7in.
    Note: This step is valid only for Page report. For RDL report, follow steps 10-12.
  10. For RDL reports, click the gray area below the design surface to give report the focus and from the Report menu, select Page Header.
  11. From the toolbox, drag the TextBox control onto the PageHeader section to span the entire width of the report.
  12. Go to the Properties Window to set the following properties.
    Property Name | Property Value
    TextAlign | Center
    FontSize | 14pt
    Value | Customer Orders

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Grouping Data (Page Layout)
Drilldown Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with Parameterized Queries

Reports with Parameterized Queries
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with Parameterized Queries

Glossary Item Box

Show All Show All
Hide All Hide All
See Parameterized Reports topic for an alternative approach to build parameterized query for data sets.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Creating a second dataset for use by the parameter list
  • Adding parameters to the report
  • Changing the Products dataset to use a dynamic query
  • Adding a header to display the chosen parameter label
  • Viewing the report
Note:
  • This walkthrough uses the MovieType table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as DynamicQueries.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Products. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Movie.Title, Product.InStock, Product.StorePrice
FROM MediaType
INNER JOIN
(Movie INNER JOIN
(Product INNER JOIN MovieProduct
  ON Product.ProductID = MovieProduct.ProductID)
 ON Movie.MovieID = MovieProduct.MovieID)
ON MediaType.MediaID = MovieProduct.MediaType
WHERE (((MediaType.MediaID)=1))
ORDER BY Movie.Title
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. From the toolbox, drag a Table data region onto the report design surface and set the following properties in the Properties Window:
    Property Name | Property Value
    Location | 0in, 0.5in
    Size | 5.5in, 0.75in
    FixedSize (only for FixedPageLayout reports) | 6.5in, 7in
  2. In the Report Explorer from the Products dataset, drag the following fields onto the detail row of the table.
    Data Field | Column Name
    Title | TableColumn1
    InStock | TableColumn2
    StorePrice | TableColumn3
    Note: This automatically places an expression in the detail row and simultaneously places a static label in the header row of the same column.
  3. Select the header row, click the table handle to the left of the row and in the Properties Window, set the following properties:
    Property Name | Property Value
    FontWeight | Bold
    BackgroundColor | DarkSeaGreen
    RepeatOnNewPage | True

  4. Select the StorePrice field in the detail row and in the Properties Window, set its Format property to Currency.

  5. Click the column handle at the top of each column in turn to select it, and in the Properties Window, set the Width property as indicated in the table.
    Column | Width
    First | 4.5in
    Second | 1in
    Third | 1in

Show To create a second dataset for use by the parameter list

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MediaType.
  3. On the Query page, paste the following SQL command into the Query text box:
    SQL Query Copy Code
    SELECT 0 AS MediaID, "All" AS Description
FROM MediaType
UNION SELECT MediaID, Description
FROM MediaType
ORDER BY Description
  4. Click the Validate icon [image] to validate the query and to populate the Fields list.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add parameters to the report

  1. In the Report Explorer, select the Parameters node.
  2. Right-click the node and select Add Parameter to open the Report - Parameters dialog.
  3. In the dialog box that appears, select the parameter from the parameters list.
  4. Set properties in the following fields below the parameters list.

    In the General tab:

    • Name: MediaType
    • DataType: String
    • Text for prompting users for a value: Select a media type

    In the Available Values tab select From query:

    • DataSet: MediaType
    • Value: MediaID
    • Label: Description
  5. Click OK to close the dialog and add the parameter to the collection. This parameter appears under the Parameters node in the Report Explorer.

Show To modify the Products dataset to use a dynamic query

  1. In the Report Explorer, right-click the Products dataset and select Edit.
  2. In the DataSet dialog that appears, select the Query page.
  3. In the Query field, change the query to the following expression:
    Query Copy Code
    ="SELECT Movie.Title, Product.InStock, Product.StorePrice, MediaType.Description FROM MediaType INNER JOIN (Movie INNER JOIN (Product INNER JOIN MovieProduct ON Product.ProductID = MovieProduct.ProductID) ON Movie.MovieID = MovieProduct.MovieID) ON MediaType.MediaID = MovieProduct.MediaType" & IIf(Parameters!MediaType.Value = 0, ""," WHERE (MediaType = " & Parameters!MediaType.Value & ")") & " ORDER BY Movie.Title"
  4. Click OK to close the dialog.

Show To add a header to display the chosen parameter label

  1. From the toolbox, drag and drop a Textbox control onto the report design surface. In RDL reports, you can place the Textbox control in the PageHeader.
  2. Select the Textbox and set the following properties in the Properties window.
    Property Name | Property Value
    TextAlign | Center
    FontSize | 14pt
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    Value | =Parameters!MediaType.Label & " Movies in Stock"
    Note: Using Label instead of Value in the expression displays a more readily understandable Description field instead of the MediaID field we used for the parameter's value.

Show To view the report

  • Go to the preview tab and select a parameter in the Parameters pane to view the report at design time.

OR

  • Open the report in the Viewer and select a parameter in the Parameters pane to view the report. See Windows Forms Viewer for further information.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with Stored Procedures

Reports with Stored Procedures
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with Stored Procedures

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a report using a stored procedure as a dataset. A stored procedure is a group of SQL statements that are used to encapsulate a set of operations or queries to execute on a database.

This walkthrough illustrates how to create a report that uses a stored procedure as a data set. The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset (stored procedure) with a parameter
  • Creating a layout for the report
  • Viewing the report
Note:
  • This walkthrough uses a table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as StoredProcedure.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Reels.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset with a parameter

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as SalesDataForStore. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, set the Command Type to Stored Procedure.
  4. On the Query page of this dialog, in the Query field enter the stored procedure name (e.g. SalesDataForStore).

    Note: For Oracle data source, you should use the Text SQL query as command type instead of StoredProcedure to call a stored procedure.
  5. Click the Validate icon to validate the query. You may receive an error at this point since the required parameters have not yet been added.
  6. Go to the Parameters page and add a Parameter using the Add(+) button.
  7. On the same page, enter Name as StoreID and Value as 1002.
  8. Select the Query page of DataSet dialog, and click the Validate icon to validate the query and load the fields.
  9. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. From the toolbox, drag a Table data region onto the report design surface.
  2. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.
  3. With the Table selected, right-click and open the Properties Window to set the following properties:
    Property Name | Property Value
    Location | 0in, 0.5in
    Size | 6.5in, 0.75in
    FixedSize | 6.5in, 7in
  4. Click the adorner to show a list of available fields from the SalesDataForStore dataset and add the following fields to the cells of the table details row.
    Cell | Field
    Left Cell | StoreID
    Middle Cell | UnitsSold
    Right Cell | NetSales
    This automatically places an expression in the detail row and simultaneously places a static label in the header row of the same column.
  5. Select the Header row by clicking the table handle to the left of the row and go to the Properties Window to set the following properties:
    Property Name | Property Value
    FontWeight | Bold
    RepeatOnNewPage | True
  6. Click the column handle at the top of each column in turn to select it, and in the Properties Window, set the Width property as indicated in the table:
    Column | Width
    First | 3.5in
    Second | 2in
    Third | 1in
  7. Set the TextAlign property of all the columns to Left.
  8. From the toolbox, drag the Textbox onto the design surface to span the entire width of the report and go to the Properties Window to set the following properties:
    Property Name | Property Value
    TextAlign | Center
    Size | 6.5in, 0.35in
    Location | 0in, 0.125in
    FontSize | 14pt
    Value | Net Sales by Store
    Tip: In a RDL report, you can also add a Page Header to place the Textbox control.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with XML Data

Reports with XML Data
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with XML Data

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough explains the steps involved in connecting a page report to an XML data source and creating a dataset. It also demonstrates the use of the List control.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to an XML data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Viewing the report
Note:
  • This walkthrough uses the Factbook sample database. By default, in ActiveReports, the Factbook.xml file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Factbook.xml.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as ExchangeRates.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Factbook.
  3. Under the Type field, select XML Provider.
  4. In the Connection Properties tab, select the type of XML data as External file or URL.
  5. Click the dropdown in Select or type the file name or URL field.
  6. Select <Browse...> navigate to Factbook.xml, which is located in [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data. See Connect to a Data Source for information on connecting to a data source.
  7. Click the Connection String tab. The connection string that gets generated is xmldoc=[User Documents Folder]\GrapeCity Samples\ActiveReports 13\Data\Factbook.xml. You can validate the connection string by clicking the Validate DataSource icon [image].
  8. Click OK.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as ExchangeRates.
  3. On the Query page of this dialog, click the Edit with XML Query Designer icon [image] to open XML DataSet Query Builder dialog.
  4. Choose the XPath upto Country from the tree nodes. The following XML query is generated:
    countries/country
  5. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
    You can see all the fields available in the dataset on the Fields page.
  6. Click OK to close the dialog. Your data set and queried fields appear as nodes to the data source in the Report Explorer.

Show To add controls to the report

  1. From the toolbox, drag a List data region onto the design surface of the report and go to the Properties window to set the DataSetName property to ExchangeRates.
  2. From the Report Explorer, drag the @name field onto the list, center it at the top, and go to the Properties window to set the FontSize property to 14pt.
  3. From the Report Explorer, drag the following fields onto the list with properties set as described in the table below.
    Field Name Property Name
    Currency Location: 1.125in, 0.5in
    Size: 2.25in, 0.25in
    VsUSD2004 Location: 4.5in, 0.875in
    Size: 1in, 0.25in
    VsUSD2003 Location: 4.5in, 1.25in
    Size: 1in, 0.25in
    VsUSD2002 Location: 4.5in, 1.625in
    Size: 1in, 0.25in
    VsUSD2001 Location: 4.5in, 2in
    Size: 1in, 0.25in
    VsUSD2000 Location: 4.5in, 2.375in
    Size: 1in, 0.25in
    Note: You will notice that the expressions created for these fields are different than usual. Because Visual Basic syntax does not allow an identifier that begins with a number, any numeric field names must be treated as strings in expressions.
  4. From the toolbox, drag a TextBox onto the list and go to the Properties window to set the properties as described in the table below to combine static text with a field value.
    Property Name | Property Value
    Location | 0.145in, 0.875in
    Size | 3in, 0.25in
    Value | ="Value of " & Fields!Currency.Value & " versus US$ for year:"
  5. From the toolbox, drag TextBox controls onto the list and go to the Properties window to set the properties as described in the table below to create static labels.

    Show TextBox1

    Property Name | Property Value
    Location | 0.125in, 0.5in
    Size | 0.75in, 0.25in
    FontWeight | Bold
    Value | Currency:

    Show TextBox2

    Property Name | Property Value
    Location | 3.375in, 0.875in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2004:

    Show TextBox3

    Property Name | Property Value
    Location | 3.375in, 1.25in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2003:

    Show TextBox4

    Property Name | Property Value
    Location | 3.375in, 1.625in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2002:

    Show TextBox5

    Property Name | Property Value
    Location | 3.375in, 2in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2001:

    Show TextBox6

    Property Name | Property Value
    Location | 3.375in, 2.375in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2000:

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with JSON Data

Reports with JSON Data
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with JSON Data

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough explains the steps involved in connecting a page report to a JSON data source at run time and using a web service to fetch the data with the authorized access.

Note: For this walkthrough, you must have the IIS Express installed on your machine.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a JSON data source at run time
  • Adding a dataset
  • Adding controls to the report
  • Displaying a report in the Viewer
  • Adding a Web service that requires authentication to access JSON data
  • Adding the DataLayer class
  • Modifying Web.config file
  • Viewing the report
Note: This walkthrough uses the Customers sample data file. By default, in ActiveReports, the customers.json file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\customers.json.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as CustomerDetails.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.
  4. Right-click the solution and select Restore Nuget Package.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and enter the name of the data source.
  3. Under the Type field, select Json Provider.
  4. On the same page, select Embedded under Schema and enter the following schema to be embedded.
    JSON schema Copy Code
    {
      "$schema": "http://json-schema.org/draft-04/schema#",
      "type": "object",
      "properties": {
        "Customers": {
          "type": "array",
          "items": {
            "type": "object",
            "properties": {
              "Id": {
                "type": "string"
              },
              "CompanyName": {
                "type": "string"
              },
              "ContactName": {
                "type": "string"
              },
              "ContactTitle": {
                "type": "string"
              },
              "Address": {
                "type": "string"
              },
              "City": {
                "type": "string"
              },
              "PostalCode": {
                "type": "string"
              },
              "Country": {
                "type": "string"
              },
              "Phone": {
                "type": "string"
              },
              "Fax": {
                "type": "string"
              }
            },
            "required": [
              "Id",
              "CompanyName",
              "ContactName",
              "ContactTitle",
              "Address",
              "City",
              "PostalCode",
              "Country",
              "Phone",
              "Fax"
            ]
          }
        },
        "ResponseStatus": {
          "type": "object",
          "properties": {}
        }
      },
      "required": [
        "Customers",
        "ResponseStatus"
      ]
    }

    Note: The schema shown above has been generated for customers.json data, using the JSON schema generator available at http://jsonschema.net/#/.
  5. Click OK to save the data source connection.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Customers.
  3. On the Query page, click Edit with JSON Query Designer button and choose the JSONPath upto [*] to obtain the following query in the Query text box: $.Customers[*]
  4. Click OK to close the dialog. Your dataset and queried fields appear as nodes in the Report Explorer.

Show To add controls to the report

  1. From the Report Explorer, drag the Id field onto the design surface of the report and go to the Properties window to set the properties as follows.
    Property Name | Property Value
    Location | 0.375in, 0.25in
    FontSize | 14pt
    FontStyle | Italic
    Size | 4in, 0.375in
  2. From the Report Explorer, drag the Table data region onto the design area and go to the Properties window to set the properties as follows.
    Property Name | Property Value
    Location | 0.375in, 1in
    Size | 4.5in, 1.125in
    FixedSize

    4.5in, 0.75in
  3. Right-click any row handle to the left of the table and click Table Footer to remove the table footer row.
  4. Hover over TextBox5 to reveal the field selection adorner, click it to display a list of available fields, and select the CompanyName field. This automatically adds a static label in the table header row.
  5. Hover over TextBox6 to reveal the field selection adorner, click it to display a list of available fields, and select the ContactName field. This automatically adds static label in the table header row.
  6. Hover over TextBox7 to reveal the field selection adorner, click it to display a list of available fields, and select the Address field. This automatically adds static label in the table header row.

Show To display a report in the Viewer

  1. From Solution Explorer, open Form1.
  2. From the Visual Studio toolbox, drag the Viewer control onto the Form1.
  3. Set the viewer's Dock property to Fill to show the complete Viewer control on the Form1 and set the viewer's Name property to reportPreview.
  4. Double-click the title bar of the Form1 to create an event-handling method for the Form1_Load event.
  5. In Form1.cs, paste the following code after InitializeComponent method to load data in the report and display the report in the viewer.
    Form1.cs Copy Code
    // The handler of <see cref="PageDocument.LocateDataSource"/> that returns appropriate data for a report.
        private void OnLocateDataSource(object sender, GrapeCity.ActiveReports.LocateDataSourceEventArgs args)
        {
            object data = null;
            var dataSourceName = args.DataSourceName;
            var source = new DataLayer();
            if (dataSourceName == "DataSource1")
            {
                data = source.CreateData();
            }
            args.Data = data;
        }
// Loads and shows the report.
        private void Form1_Load(object sender, EventArgs e)
        {
            var rptPath = new System.IO.FileInfo(@"..\..\Customers.rdlx");
            var definition = new GrapeCity.ActiveReports.PageReport(rptPath);
            definition.Document.LocateDataSource += OnLocateDataSource;
            reportPreview.ReportViewer.LoadDocument(definition.Document);
        }

Show To add a Web service project

The web service added to the project authenticates access to the JSON data.

  1. From the File menu, go to Add, and then select New Project.
  2. In the New Project dialog that appears, select ASP.NET Web Application and in the Name field, rename the file as WebService.
  3. Click OK to add the new project.
  4. In the New ASP.NET Project dialog, select Empty template and click OK.
  5. In the Solution Explorer, right-click the WebService node, go to Add, and select Add Class.
  6. In the Add New Item dialog that appears, select Class and in the Name field, rename the file as BasicAuthHttpModule.cs.
  7. Click the Add button to add the new class to the project.
  8. In the BasicAuthHttpModule class file that opens, add the following code inside the WebService namespace.
    BasicAuthHttpModule.cs Copy Code
    namespace WebService
    {
        public class BasicAuthHttpModule : IHttpModule
        {
            private const string Realm = "My Realm";
            public void Init(HttpApplication context)
            {
                // Register event handlers
                context.AuthenticateRequest += OnApplicationAuthenticateRequest;
                context.EndRequest += OnApplicationEndRequest;
            }
            private static void SetPrincipal(System.Security.Principal.IPrincipal principal)
            {
                System.Threading.Thread.CurrentPrincipal = principal;
                if (HttpContext.Current != null)
                {
                    HttpContext.Current.User = principal;
                }
            }
            // Validate the username and password.
            private static bool CheckPassword(string username, string password)
            {
                return username == "admin" && password == "1";
            }
            private static void AuthenticateUser(string credentials)
            {
                try
                {
                    var encoding = System.Text.Encoding.GetEncoding("iso-8859-1");
                    credentials = encoding.GetString(Convert.FromBase64String(credentials));
                    int separator = credentials.IndexOf(':');
                    string name = credentials.Substring(0, separator);
                    string password = credentials.Substring(separator + 1);
                    if (CheckPassword(name, password))
                    {
                        var identity = new System.Security.Principal.GenericIdentity(name);
                        SetPrincipal(new System.Security.Principal.GenericPrincipal(identity, null));
                    }
                    else
                    {
                        // Invalid username or password.
                        HttpContext.Current.Response.StatusCode = 403;
                    }
                }
                catch (FormatException)
                {
                    // Credentials were not formatted correctly.
                    HttpContext.Current.Response.StatusCode = 401;
                }
            }
            private static void OnApplicationAuthenticateRequest(object sender, EventArgs e)
            {
                var request = HttpContext.Current.Request;
                System.IO.FileInfo info = new System.IO.FileInfo(request.Url.AbsolutePath);
                if (!info.Name.Equals("GetJson")) return;
                var authHeader = request.Headers["Authorization"];
                if (authHeader != null)
                {
                    var authHeaderVal = System.Net.Http.Headers.AuthenticationHeaderValue.Parse(authHeader);
                    // RFC 2617 sec 1.2, "scheme" name is case-insensitive
                    if (authHeaderVal.Scheme.Equals("basic",
                            StringComparison.OrdinalIgnoreCase) &&
                        authHeaderVal.Parameter != null)
                    {
                        AuthenticateUser(authHeaderVal.Parameter);
                    }
                }
                else
                {
                    HttpContext.Current.Response.StatusCode = 401;
                }
            }
            // If the request was unauthorized, add the WWW-Authenticate header
            // to the response.
            private static void OnApplicationEndRequest(object sender, EventArgs e)
            {
                var response = HttpContext.Current.Response;
                if (response.StatusCode == 401)
                {
                    response.Headers.Add("WWW-Authenticate",
                            string.Format("Basic realm=\"{0}\"", Realm));
                }
            }
            public void Dispose()
            {
            }
        }
    }
  9. Add reference to System.Net.Http.dll in the WebService project.
  10. In the Solution Explorer, right-click the WebService node, go to Add, and select New Item.
  11. In the Add New Item dialog that appears, select Web Service and in the Name field, rename the file as Service.asmx.
  12. Click the Add button to add the new service to the project.
  13. In the Service file that opens, uncomment [System.Web.Script.Services.ScriptService] line of code and add the following code below the WebMethod.
    Service.asmx.cs Copy Code
    [System.Web.Script.Services.ScriptMethod(UseHttpGet = true, ResponseFormat = System.Web.Script.Services.ResponseFormat.Json)]
            public string GetJson()
            {
                string result;
                try
                {
                    using (System.IO.StreamReader streamReader = new System.IO.StreamReader(Properties.Resource.JsonFilePath, System.Text.Encoding.UTF8))
                    {
                        result = streamReader.ReadToEnd();
                    }
                }
                catch (System.IO.FileNotFoundException e)
                {
                    var errorMessage = String.Format(Properties.Resource.FormatErrorMessage, e.Message, e.StackTrace);
                    result = "{'error': '" + errorMessage + "'}";
                }
                return result;
            }
  14. In the Solution Explorer, right-click the WebService node, go to Add, and select New Item.
  15. In the Add New Item dialog that appears, select Web Form and in the Name field, rename the file as default.aspx.
  16. Click the Add button to add a new file to the project.
  17. In the default.aspx code file that opens, replace <div> tags with <form> tags as shown.
    default.aspx Copy Code
    <form id="form1" runat="server">
        <asp:Label ID="messageLabel" runat="server" Text=""></asp:Label>
    </form>
  18. In Solution Explorer, right-click default.aspx and select View Code.
  19. In the default.aspx code file that opens, add the following code to the Page_Load event.
    default.aspx.cs Copy Code
    messageLabel.Text = Properties.Resource.bodyOfMessage;
  20. In the Solution Explorer, right-click the WebService node, go to Add, and select New Item.
  21. In the Add New Item dialog that appears, select Resources File and in the Name field, rename the file as Resource.resx.
  22. Click the Add button to add a new file to the project. Make sure that the Resources file is located in the WebService>Properties node.
  23. Add the following data to the Resource file.
    Name | Value
    bodyOfMessage | Json Data Source Sample WebService was started successfully
    FormatErrorMessage | Message : {0}, StackTrace: {1}
    JsonFilePath | C:\Users\user\Documents\GrapeCity Samples\ActiveReports 13\Data\customers.json
  24. In the Solution Explorer, right-click the solution node and select Properties.
  25. In the Solution Property Pages dialog that appears, select Multiple startup projects and then the Start action for each of the two projects.
  26. Click Apply and then OK to apply the changes to the solution.

Show To add the DataLayer class

The DataLayer class provides the data used in the walkthrough.

  1. Right-click WebService project, go to Add and select Class.
  2. In the Add New Item dialog that appears, select Class and in the Name field, rename the file as DataLayer.cs.
  3. Click the Add button to add the new class to the project.
  4. In the DataLayer class file that opens, add the following code inside the project namespace.
    Caution: It is required to change the URL port number set in “source_url” (the part after http://localhost:) to the port number that the IIS Express is actually using. The port number used by IIS Express can be confirmed or changed on the property page of the WebService project.

    DataLayer.cs Copy Code

// Provides the data used in the sample.
 internal sealed class DataLayer
        {
            public String CreateData()
            {
                string source_url = @"http://localhost:6719/Service.asmx/GetJson";
                string responseText = null;
                using (var webClient = new System.Net.WebClient())
                {
                    webClient.Headers[System.Net.HttpRequestHeader.Authorization] = "Basic " + Convert.ToBase64String(System.Text.Encoding.Default.GetBytes("admin:1")); // username:password
                    webClient.Headers[System.Net.HttpRequestHeader.ContentType] = "application/json;";
                    webClient.Encoding = System.Text.Encoding.UTF8;
                    var responseJson = webClient.DownloadString(source_url);
                    Dictionary<string, string> values = new System.Web.Script.Serialization.JavaScriptSerializer().Deserialize<Dictionary<string, string>>(responseJson);
                    if (values.ContainsKey("d"))
                    {
                        responseText = values["d"];
                    }
                }
                return responseText;
            }
        }

Show Modify the Web.config file

  1. From the Solution Explorer, open the Web.config file inside the WebService project.
  2. Replace the <configuration> tags with following code.
    Web.config Copy Code
    <configuration>
      <system.web>
        <compilation debug="true" targetFramework="4.5"/>
        <httpRuntime targetFramework="4.5"/>
        <httpModules>
          <add name="ApplicationInsightsWebTracking" type="Microsoft.ApplicationInsights.Web.ApplicationInsightsHttpModule, Microsoft.AI.Web"/>
        </httpModules>
      <webServices>
          <protocols>
            <add name="HttpGet"/>
            <add name="HttpPost"/>
            <add name="HttpSoap"/>
          </protocols>
    </webServices>
      </system.web>
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs"
            type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
            warningLevel="4" compilerOptions="/langversion:6 /nowarn:1659;1699;1701"/>
          <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb"
            type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
            warningLevel="4" compilerOptions="/langversion:14 /nowarn:41008 /define:_MYTYPE=\&quot;Web\&quot; /optionInfer+"/>
        </compilers>
      </system.codedom>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false"/>
        <modules>
          <add name="BasicAuthHttpModule" type="WebService.BasicAuthHttpModule, WebService"/>
          <remove name="ApplicationInsightsWebTracking"/>
          <add name="ApplicationInsightsWebTracking" type="Microsoft.ApplicationInsights.Web.ApplicationInsightsHttpModule, Microsoft.AI.Web"
            preCondition="managedHandler"/>
        </modules>
      </system.webServer>
    </configuration>

Show To view the report

  1. From the Build menu option, select Build Solution.
  2. Press F5 to run the project.

See Also

How To
Add a Dataset

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with CSV Data

Reports with CSV Data
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with CSV Data

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough explains the steps involved in connecting a page report to a CSV data source. The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a CSV data source
  • Adding controls to the report to contain data
  • Viewing the report
Note:
  • This walkthrough uses the Products_header_tab.csv sample database. By default, the Products_header_tab.csv file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as ProductsStock.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a CSV data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to DataSource1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under the Type field, select CSV Provider.
  4. In the Connection String tab, click the Build icon to open the Configure CSV Data Source wizard.
  5. To specify the Path of the file, click the Open button and navigate to [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data and select the Products_header_tab.csv file.
  6. Select the Column Separator as Tab from the drop-down menu. See the Sample CSV Connection String in the topic CSV Provider for further details.
  7. Click OK to save the changes and close the Configure CSV Data Source wizard. The Connection String tab displays the generated connection string as shown below:
    Path=C:\\[User Documents folder]\\GrapeCity Samples\\ActiveReports 13\\Data
    \\Products_header_tab.csv;Locale=en-US;
    TextQualifier=";ColumnsSeparator= ;RowsSeparator=\r\n;HasHeaders=True

    You can validate the connection string by clicking the Validate DataSource icon.
  8. Click OK to close the Report Data Source dialog. You have successfully connected the report to the CSV data source.
Note: The dataset for a CSV data source is automatically added. The default name of the data set is name of the CSV file selected.

Show To add controls to the report

  1. From the toolbox, drag a Table data region onto the design surface of the report.
  2. Select the last column of the table, right-click, and select Insert Column to the Right option to add a fourth column.
  3. Go to the Properties window and set the properties for the Table data region as described in the following section:
    Property Name | Property Value
    Location | 0.375in, 0.5in
    DataSetName | Products_header_tab
    Size | 5.5in, 0.75in
    FixedSize | 5.5in, 2in
  4. From the Report Explorer, drag the fields into the Table Details row as described in the following section:
    Field Name | TextBox
    ProductName | TextBox4
    QuantityPerUnit | TextBox5
    UnitPrice | TextBox6
    UnitsInStock | TextBox11
  5. Select the Table Header row and set FontWeight to Bold.
  6. From the toolbox, drag a TextBox onto the design surface of the report, go to the Properties window to set the properties as described in the following section:
    Property Name | Property Value
    Location | 2.5in, 0in
    Size | 1.375in, 0.25in
    Value | Products Stock
    FontSize | 12pt
    FontWeight | Bold

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

CSV Provider

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Expressions in Reports

Expressions in Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Expressions in Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can use expressions in the control's properties to calculate values. You can also use expressions to concatenate fields, to concatenate strings with fields, to aggregate data, to set formatting based on field values, to show or hide other controls based on field values and even to display a graphical representation of the data. This walkthrough illustrates the how to use expressions to achieve different effects.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Adding a field expression to a text box to multiply two field values
  • Adding an Immediate If expression to show or hide a control
  • Adding a Data Visualization expression to display data graphically
  • Viewing the report
Note:
  • This walkthrough uses the MovieProduct table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as rptExpressions.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as DVDStock. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM DVDStock
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. From the toolbox, drag a Table data region onto the design surface and go to the Properties Window to set the DataSetName property to DVDStock.
  2. Right-click in the column handle at the top of the third column and choose Insert Column to the Right to add a fourth column of the same width.
  3. Click inside the table to display the row and column handles along the left and top edges of the table and set the column width as follows:
    Table Column | Width
    TableColumn1 | 3.5in
    TableColumn2 | 1in
    TableColumn3 | 1in
    TableColumn4 | 1in
  4. In the Report Explorer from the DVDStock dataset, drag the following fields into the detail row and set their properties as follows.
    Data Field | Column Name
    TableColumn1 | Title
    TableColumn2 | StorePrice
    TableColumn3 | InStock
  5. Select detail row cell containing the StorePrice values in the TableColumn2 and in the Properties Window, set the Format property to Currency.
  6. Select the header row using the row handle to the left and in the Properties Window, set the FontWeight property to Bold.
  7. For an Page report, in the Report Explorer select the Table control and in the Properties window, set the FixedSize property to 6.5in, 7in.

Show To add a field expression to a text box to multiply two field values

  1. In the detail row of the fourth column, enter the following expression: = Fields!InStock.Value* Fields!StorePrice.Value
  2. Go to the Properties Window to set the Format property of the textbox to Currency formatting.
  3. In the header row immediately above this Textbox, enter Stock Value for the static label.

Show To add an Immediate If expression to show or hide a report control

  1. Select the cell in which we multiplied two field values (in the detail row of the fourth column) and in the Properties window, expand the Visibility property.
  2. In the Hidden property, enter the following immediate if expression to hide the textbox if there is no stock for the item. =iif(Fields!InStock.Value=0, True, False)

Show To add a Data Visualization expression to display data graphically

The ColorScale3 visualizer function displays a range of colors to indicate minimum, average, and maximum values in the data. See the Data Visualizers topic for further information.

Select the cell in the detail row under the In Stock label and in the Properties window, set the BackgroundColor property to the following expression: =ColorScale3(Fields!InStock.Value, 0, Avg(Fields!InStock.Value), Max(Fields!InStock.Value),
"Red", "Yellow", "Green")

Note: The parameters of the ColorScale3 function evaluate to Value, Minimum, Average, Maximum, StartColor, MiddleColor and EndColor. Note that aggregate functions (Avg and Max) are used within the ColorScale3 function. See Functions for details on these and other aggregate functions.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Expressions
Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Multiple Datasets in a Data Region

Multiple Datasets in a Data Region
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Multiple Datasets in a Data Region

Glossary Item Box

Show All Show All
Hide All Hide All

Many a time, we need to display varied data from different datasets into one data region. This is now possible by using the Lookup function in a data region.

The Lookup function returns a value corresponding to a related or a common field with the same data type in another data set. It is set as an expression in the Value property of a data region's Textbox. The Lookup function in ActiveReports is similar to the Microsoft Excel's VLOOKUP.

Show Lookup Function

Syntax

=Lookup(<SourceExpression>, <DestinationExpression>, <ResultExpression>, <LookupDataset>)

Parameters

  • Comparison Criteria: To compare the fields in the Source and the Lookup datasets. The criterion uses only the "=" operator.
  • SourceExpression: An expression evaluating to a value from the dataset associated with the data region. If this expression is a FieldName, then the value of the Field from the dataset associated with the data region is used.
  • DestinationExpression: An expression evaluating to a value from the dataset associated with the LookupDataset. If this expression is a FieldName, then the value of the Field from the dataset of the LookupDataset is used.
  • ResultExpression: An expression evaluating to the Field from the LookupDataset returned by the Lookup function.
  • LookupDataset: The dataset where the value from the data region's dataset is used to display the related attribute.

Usage

  • The data type of the SourceExpression and the DestinationExpression should be same.
  • When the Lookup function is used as a value expression in a data region, the expression is evaluated for each row or repeated data of the data region's dataset.
  • The Lookup function returns one value if found, and null if no rows are found in the Lookup dataset.
  • The Lookup expressions can be a part of aggregated expressions. A user can use the Lookup function in a table group or table header or footer, and sum all values for the table.

Limitations

  • Only "=" comparison is supported between SourceExpression and DestinationExpression.
  • Non-aggregate expressions such as multiply, mod, AND and OR, are not allowed in the comparison criteria.
  • Only one level of Lookup is allowed, that is, nested Lookup functions are not supported.

This walkthrough explains the steps involved in using multiple datasets in a data region. The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding the datasets
  • Adding controls to the report
  • Viewing the report
Note:
  • This walkthrough uses the SalesResult database. By default, in ActiveReports, the SalesResult.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as SalesResultReport.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like SalesResultData.
  3. On this page, create a connection to the SalesResult database. See Connect to a Data Source for information on connecting to a data source.

Show To add the datasets

To add Dataset1

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and let the name of the dataset be Dataset1. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT M01Product.Category, M01Product.ProductID
FROM M01Product
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

    The Dataset1 contains following fields:

    • Category
    • ProductID

To add Dataset2

  1. Repeat Steps 1 and 2 to add another dataset with name Dataset2.
  2. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM T01Result
  3. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  4. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

    The Dataset2 contains following fields:

    • ID
    • ProductID
    • Quantity
    • PDate
    • FY

Show To add controls to the report

  1. From the toolbox, drag a Table data region onto the design surface of the report.
  2. Go to the Properties Window to set the properties of Table data region as follows:
    Property Name | Property Value
    FixedSize | 4in, 4in
    Location | 0in, 0in
    Size | 3.875in, 0.75in
    DataSetName | Dataset1
  3. Hover your mouse over the text boxes of the Table Details row to access the field selection adorner and set the following fields in the table cells along with their properties.
    Cell | Field
    TextBox4 | Category
    TextBox5 | ProductID
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.

  4. Select TextBox6 of the Table data region and from the Properties pane, set the following properties:

    Property Name | Property Value
    Value | =Lookup(Fields!ProductID.Value, Fields!ProductID.Value, Fields!Quantity.Value, "DataSet2")
    TextAlign | Left

    The expression in the Value property returns the value of Quantity from Dataset2, corresponding to the related data field ProductID in Dataset1.

  5. Select TextBox3 of the Table data region and from the Properties pane, set the following properties:
    Property Name | Property Value
    Value | Quantity
    TextAlign | Left
  6. Select the header row using the row handle to the left and in the Properties Window, set the FontWeight property to Bold.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Common Functions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Layout

Layout
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout

Glossary Item Box

This section contains the following walkthroughs that fall under the Layout category.

BandedList Reports
This walkthrough demonstrates how to create a grouped BandedList report.
Collate Multiple Copies of a Report
This walkthrough demonstrates how to use the collation feature in a report that contains layouts on two page tabs.
Columnar Layout Reports (RDL)
This walkthrough demonstrates how to create a RDL report using columns.
Overflow Data in a Single Page(Page Report)
This walkthrough demonstrates how to use the OverflowPlaceHolder controls at any location on the same page to build a rich report layout.
Overflow Data in Multiple Pages(Page Report)
This walkthrough demonstrates how to create two different layouts using the OverflowPlaceHolder control.
Recursive Hierarchy Reports
This walkthrough demonstrates how to create a report using a recursive hierarchy and the Level function to show parent-child relationships in data.
Single Layout Reports
This walkthrough demonstrates how to create a layout at design time on a single page tab and apply it to the entire report.
Subreports in Page/RDL Reports
This walkthrough demonstrates how to create a report using a subreport.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Banded List Reports

Banded List Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Banded List Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a freeform report with groups using the Banded List control. This walkthrough illustrates how to create a grouped BandedList report.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a banded list with grouping
  • Adding controls to the banded list
  • Viewing the report
Note:
  • This walkthrough uses the Movie table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as rptBandedList.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Movies. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, change the Command Type to TableDirect and enter Movie into the Query text box.
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add the BandedList with grouping

  1. From the toolbox, drag a BandedList data region onto the design surface and go to the properties window to set the DataSetName property to Movies.
    Note: To select the banded list, click inside any band in the list and click the four-way arrow that appears at the top left of the control.
  2. Right-click inside the banded list and select Footer. This removes the footer band that we are not using in this walkthrough.
  3. Right-click inside the banded list and select Insert Group. This adds a group header between the BandedList header and the detail section, and a group footer below the detail section, and opens the BandedList - Groups dialog.
  4. In the BandedList - Groups dialog, drop down the list of expressions in the Group on expression box and select =Fields!YearReleased.Value to group the movies based on the year in which they were released.
  5. In the same dialog, change the Name to Year.
  6. In the same dialog under Layout, clear the Include group footer checkbox to remove the group footer.
  7. Click the Add icon. This adds a second group header under the first, and a group footer below the detail section.
  8. In the same dialog, select the newly added group from the list of groups, drop down the list of expressions in the Group on expression box and select =Fields!MPAA.Value to group the movies based on the rating (for example, G, PG, etc).
  9. In the same dialog, change the Name to MPAA.
  10. In the same dialog under Layout, clear the Include group footer checkbox to remove the group footer.
  11. Click OK to close the dialog.

Show To add controls to the BandedList

  1. From the toolbox, drag a TextBox control onto the top-most band (BandedList1_Header) and in the Properties window, set the following properties:
    Property Name | Property Value
    BackgroundColor | Gray
    Color | White
    FontSize | 14pt
    FontWeight | Bold
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    TextAlign | Center
    Value | Movie Details
  2. Click the BandedList1_Header band adorner (the grey bar along the top of the band) to select the banded list header.
  3. In the Properties window, set the following properties for the banded list header:
    Property Name | Property Value
    RepeatOnNewPage | True
    Height | 0.25in
  4. From the Report Explorer drag the YearReleased field onto the first grouping band (Year_Header) of the banded list.
  5. With this field selected, go to the Properties window to set the following properties:
    Property Name | Property Value
    BackgroundColor | DarkGray
    FontWeight | Bold
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    TextAlign | Left
    Value | =First(Fields!YearReleased.Value)
  6. Click the Year_Header band adorner (the grey bar along the top of the band) to select it and go to the properties window to set the Height property of the header band to 0.25in.
  7. From the Report Explorer, drag the MPAA field into the second grouping band (MPAA_Header) of the banded list.
  8. Go to the Properties window to set the following properties:
    Property Name | Property Value
    BackgroundColor | Silver
    BorderColor | Gray
    BorderStyle | Solid
    FontWeight | Bold
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    Note: The Value property is automatically set to an expression using the First aggregate. This displays the movie rating for each group.
  9. Click the MPAA_Header band adorner (the grey bar along the top of the band) to select it and go to the properties window to set the Height property of the header band to 0.25in.
  10. Click inside the detail band to select it and in the properties window, set its Height property to 1.2in.
  11. From the Report Explorer, drag the following six fields onto the detail band and in the properties window, set their properties as indicated.
    Data Field Property Name
    Title Location: 0in, 0.25in
    Size: 3.75in, 0.25in
    Country Location: 1.25in, 0.5in
    Size: 1in, 0.25in
    Language Location: 1.25in, 0.75in
    Size: 1in, 0.25in
    Length Location: 5.375in, 0in
    Size: 1in, 0.25in
    TextAlign = Left
    UserRating Location: 5.375in, 0.5in
    Size: 1in, 0.25in
    TextAlign = Left
    IsColor Location: 5.375in, 0.75in
    Size: 1in, 0.25in
    Note: When you drag and drop fields from a dataset in the Report Explorer onto the design surface, these fields are automatically converted to Textbox controls that you can modify by setting the control properties in the Properties Window.
  12. Once you've arranged the fields, select the IsColor field and in the properties window, change the Value property to the following expression so that instead of "True" or "False," it will read "Color" or "Black and White."
    =Iif(Fields!IsColor.Value=True, "Color", "Black and White")
  13. From the toolbox, drag six TextBox controls onto the detail band and in the properties window, set their properties as indicated.

    Show TextBox1

    Property Name | Property Value
    Value | Movie Title:
    Location | 0in, 0in
    Size | 1in, 0.25in
    FontWeight | Bold

    Show TextBox2

    Property Name | Property Value
    Value | Country of origin:
    Location | 0in, 0.5in
    Size | 1.25in, 0.25in
    FontWeight | Bold

    Show TextBox3

    Property Name | Property Value
    Value | Language:
    Location | 0in, 0.75in
    Size | 1in, 0.25in
    FontWeight | Bold

    Show TextBox4

    Property Name | Property Value
    Value | Length:
    Location | 4.25in, 0in
    Size | 1in, 0.25in
    FontWeight | Bold
    TextAlign | Right

    Show TextBox5

    Property Name | Property Value
    Value | User Rating:
    Location | 4.25in, 0.5in
    Size | 1in, 0.25in
    FontWeight | Bold
    TextAlign | Right

    Show TextBox6

    Property Name | Property Value
    Value | Format:
    Location | 4.25in, 0.75in
    Size | 1in, 0.25in
    FontWeight | Bold
    TextAlign | Right
  14. From the toolbox, drag a Line control onto the detail band and in the Properties window, set the properties.
    Property Name | Property Value
    LineColor | Gray
    LineWidth | 3pt
    Location | 0in, 1.12in
    EndPoint | 6.5in, 1.12in
  15. For a Page report, in the Report Explorer select the BandedList control and in the Properties window, set its FixedSize property to 6.5in, 7in.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Grouping Data (Page Layout)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Collate Multiple Copies of a Report

Collate Multiple Copies of a Report
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Collate Multiple Copies of a Report

Glossary Item Box

Show All Show All
Hide All Hide All

In a Page Report you can create reports with multiple themes, where you can control the page order of a rendered report by selecting the collation mode. This walkthrough uses a report that contains layouts on two page tabs in order to illustrate the collation feature.

This walkthrough is split into the following activities:

  • Creating report layout on multiple pages
  • Adding themes
  • Applying themes
  • Setting up collation
  • Viewing the report
Note:
  • This walkthrough uses the CustomerOrders table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a report that looks similar to the following. These images show the result of the Value collation mode.

Page 1 | Page 2 | Page 3 | Page 4
Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink | Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink | Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink | Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink

Show To create a report layout on multiple pages

In a Page Report, you can apply more than one layout to a single report by using page tabs. See the walkthrough Overflow Data in Multiple Pages, to learn how to create a report that consists of a first page with a different layout from all subsequent pages.

Note: The information provided henceforth is an extension of the Overflow Data in Multiple Pages walkthrough, so we recommend that you go through this topic before moving to the next procedure.

Show To add themes to the report

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, click the New icon above the list of themes.
  4. In the Theme Editor that opens, define the colors and constant expressions for your new theme under the corresponding tabs as follows:

    Theme 1

    Property Name | Property Value | Description
    Text/Background - Light1 (Colors tab) | Default (white) | To set the background color for the theme.
    Name (Constants tab) | Constant1 | To define a name for the constant expression to be used within in a theme.
    Value (Constants tab) | Theme1 | To associate a value to be used as a constant in the expression.
    Description (Constants tab) | Default Theme | To describe a constant expression.

  5. In the Theme Editor, click OK and in the Save As dialog that opens, choose a directory on your local machine and enter the name, Default Theme for your new theme.
  6. Click Save to save the theme at the desired location.
  7. Repeat steps 3-6 above to add another theme to the report. Define the colors and constant expressions of the theme under the corresponding tabs as follows:

    Theme 2

    Property Name | Property Value | Description
    Text/Background - Light1 (Colors tab) | Yellow | To set the background color for the theme.
    Name (Constants tab) | Constant1 | To define a name for the constant expression to be used within in a theme.
    Value (Constants tab) | Theme2 | To associate a value to be used as a constant in the expression.
    Description (Constants tab) | Yellow Theme | To describe a constant expression.

Show To apply themes to the report

In order to apply themes to a report, you need to set the theme as a value of a property. In this walkthrough we set the theme in the BackgroundColor property.

  1. In the Report Explorer, select the Page 1 node to open the layout for the first page of the report.
  2. In the Properties window, go to the BackgroundColor property and click the arrow to display the drop-down list of values.
  3. In the list that appears, go to the Theme button and select Light1.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. In the Report Explorer, select Page 2 node to open the layout for the second page of the report.
  5. In the Properties window, go to the BackgroundColor property and click the arrow to display the drop-down list of values.
  6. In the list that appears, go to the Theme button and select Light1.
  7. From the Visual Studio toolbox, ActiveReports 13 Page Report tab, drag the Textbox control and drop it onto the Page 1 design surface.
  8. With this TextBox control selected, set the following properties in the properties window. This is to display a constant value associated with the Theme.
    Property Name | Property Value
    Location | 4.4in, 0in
    Size | 2.1in, 0.25in
    Value

    = Theme.Constants("Constant1")

    Note: To set this value, enter it in the Value field of the Properties window. You may also use the Expression Editor option that appears when you click the ellipses (...) button adjacent to the Value property.

  9. From the Visual Studio toolbox, drag the Textbox control and drop it onto the Page 2 design surface. Set the properties specified in step 8 above in the properties window.

Your layout now contains two themes and a constant expression displaying the theme you are using on the top left corner of the page.

Show To set up collation

Collation is set to determine the order in which the report pages are rendered when you have multiple themes in the report. In order to define the order, you need to set the CollateBy property.

  1. In the Designer, click the gray area around the report page to select the report.
  2. In the Properties Window, go to the CollateBy property and select the Simple mode. The report will be rendered in the following way - the report renders all pages with theme 1, then all pages with theme 2.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  3. In the Properties Window, go to the CollateBy property and select the ValueIndex mode. The report will be rendered by page number. For example, if you have a report with 2 themes, the report renders page 1 for theme 1 and 2, then page 2 for theme 1 and 2, and so on.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  4. In the Properties Window, go to the CollateBy property and select the Value mode. The report will be rendered by the grouping expression that you specify in the FixedPage dialog. For example, if you have a report comprising of 2 themes with grouping, the report renders group1 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), then group 2 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), and so on.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Show To view the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at run time.

See Also

Themes

How To
Create and Add Themes
Customize and Apply a Theme
Use Constant Expressions in a Theme

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Columnar Layout Reports (RDL)

Columnar Layout Reports (RDL)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Columnar Layout Reports (RDL)

Glossary Item Box

Show All Show All
Hide All Hide All

In RDL report, you can create a columnar report layout by using the Columns property of the report. This walkthrough illustrates how to create a RDL report using columns, and is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a the data source
  • Adding a dataset
  • Creating a column report layout
  • Viewing the report
Note: This walkthrough uses the CustomerMailingList table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 RDL Report and in the Name field, rename the file as rptRDLColumnLayout.
  4. Click the Add button to open a new RDL report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as CustomerList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT TOP 100 * FROM CustomerMailingList
UNION
SELECT TOP 100 * FROM CustomerMailingList WHERE Country = "USA"
ORDER BY 8 DESC
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a column layout for the report

  1. In the Report Explorer, select Body and set the following properties in the properties window.
    Property Name | Property Value
    Columns | 2
    ColumnSpacing | 0.25in
    Size | 2.625in, 1in
  2. In the Visual Studio toolbox, go to the ActiveReports 13 Page Report tab and drag the List data region onto the design surface.
  3. In the Properties Window, set the following properties for the List.
    Property Name | Property Value
    DataSetName | CustomerList
    Size | 2.5in, 1in
  4. In the Visual Studio toolbox, go to the ActiveReports 13 Page Report tab and drag three TextBox controls onto the List data region added above.
  5. In the Properties Window, set the following properties for TextBox1.
    Property Name | Property Value
    Location | 0in, 0in
    Size | 2.5in, 0.25in
    DataElementName | FirstName
    Name | FirstName
    Value | =Fields!FirstName.Value & IIF( Fields!MiddleInitial.Value Is Nothing, "", " " & Fields!MiddleInitial.Value ) & " " & Fields!LastName.Value
    CanGrow | False
  6. In the Properties Window, set the following properties for TextBox2.
    Property Name | Property Value
    Location | 0in, 0.25in
    Size | 2.5in, 0.25in
    DataElementName | CustomerAddress1
    Name | CustomerAddress1
    Value | =Fields!Address1.Value & IIF( Fields!Address2.Value is Nothing, "", vbCrLf & Fields!Address2.Value )
    CanGrow | False
    CanShrink | True
  7. In the Properties window, set the following properties for TextBox3.
    Property Name | Property Value
    Location | 0in, 0.50in
    Size | 2.5in, 0.25in
    DataElementName | CustomerCity
    Name | CustomerCity
    Value | =Fields!City.Value & ", " & Fields!Region.Value & " " & Fields!PostalCode.Value & " " & IIf( Fields!Country.Value = "USA", "", Fields!Country.Value )
    CanGrow | False

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
If you want to create a similar layout in Page report, see Overflow Data in a Single Page(Page Report).

See Also

Overflow Data in a Single Page(Page Report)
Overflow Data in Multiple Pages(Page Report)
Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Overflow Data in a Single Page(Page Report)

Overflow Data in a Single Page(Page Report)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Overflow Data in a Single Page(Page Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In a Page Report, ActiveReports allows you to arrange the OverflowPlaceHolder controls at any location on the same page along with the host data region to build a rich report layout. The following walkthrough demonstrates this by using a Table data region and three OverflowPlaceHolder controls on a single page to create a columnar display.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a data source
  • Adding a dataset
  • Creating a columnar layout
  • Viewing the report
Note: This topic uses the Movie table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Notice that the run time report layout below is similar to the one you see at design time except for the data which you see at run time or when you preview the report.

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as rptColumnarLayout.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialogthat appears, select the General page and in the Name field, enter a name like ColumnData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Movie
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. In the Visual Studio toolbox, go to ActiveReports 13 Page Report tab and drag a TextBox control onto the design surface.
  2. Select the TextBox control and go to the properties window to set the following properties. This TextBox functions as the title in the report layout.
    Property Name | Property Value
    Location | 0in, 0in
    BackgroundColor | DarkCyan
    Font | Normal, Arial, 20pt, Bold
    Size | 6.5in, 0.5in
    TextAlign | Center
    Value | Movie Database
    VerticalAlign | Middle
  3. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface and set its following properties in the properties window.
    Property Name | Property Value
    Location | 0.125in, 1in
    BackgroundColor | Azure
    RepeatHeaderOnNewPage | True
    Size | 3in, 0.66in
    FixedSize | 3in, 3.5in
    OverflowName OverflowPlaceHolder1
    Note: Set this property after you add the OverflowPlaceHolder1 to the design surface in the next step, to handle the data that exceeds the fixed size of the Table data region.
  4. In the Table data region, right click the footer row and select Table Footer from the context menu to delete the unnecessary footer row.
  5. In the table details row, add the following fields using the field selection adorner:
    Cell | Field Name
    Left | Title
    Center | YearReleased
    Right | UserRating
  6. In the table details row, select the left cell containing the Title field and go to the Properties window to set the ShrinkToFit property to True. This will avoid clipping of longer movie titles and fit the string in the same cell in a smaller font size.
  7. In the design view, select the following rows of the Table data region by clicking the table handle to the left of the row and go to the Properties window to set the following properties:
    Row Property Name
    TableHeader BackgroundColor: PaleTurquoise
    BorderStyle: Solid
    FontSize: 10pt
    FontWeight: Bold
    TextAlign: Left
    TableDetail BorderStyle: Solid
    TextAlign: Left
    FontSize: 9pt
  8. From the Visual Studio toolbox, drag and drop three OverflowPlaceHolder controls onto the design surface and the set the following properties in the Properties window for each of them so that the data appears in a columnar format.
    Control Name Property
    OverflowPlaceHolder1

    Location: 3.375in, 1in
    Size: 3in, 3.5in
    OverflowName: OverflowPlaceHolder2

    Note: Set this property after you add the OverflowPlaceHolder2 to the design surface.
    OverflowPlaceHolder2 Location: 0.125in, 5in
    Size: 3in, 3.5in
    OverflowName: OverflowPlaceHolder3
    Note: Set this property after you add the OverflowPlaceHolder3 to the design surface.
    OverflowPlaceHolder3

    Location: 3.375in, 5in
    Size: 3in, 3.5in
    Note: Notice that the OverflowName property is set to link each OverflowPlaceHolder control to the next one.

Show To view the Report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at run time.

See Also

Single Layout Reports
Overflow Data in Multiple Pages(Page Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Overflow Data in Multiple Pages(Page Report)

Overflow Data in Multiple Pages(Page Report)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Overflow Data in Multiple Pages(Page Report)

Glossary Item Box

Show All Show All
Hide All Hide All

In a Page Report you can create different layouts in a single report by designing your report on more than one page tab. This walkthrough describes the steps to create two different layouts and how data flows from the first layout to the next using the Overflow Place Holder control.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a the data source
  • Adding a dataset
  • Creating a layout for the first page
  • Creating a layout for subsequent pages
  • Viewing the Report
Note: This walkthrough uses the CustomerOrders table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Page 1 | Page 2
Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink | Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink

Notice that the run-time report layout below is similar to the one you see at design time except for the data which is added to the report at run time or when you preview it.

Run-Time Layout

Page 1 | Page 2
Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink | Click to Enlarge Click to Enlarge Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as rptMultipleLayout.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like CustomerData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as OrdersList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    Select * from customerorders
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the first page

  1. Click the design surface to select the page, go to the properties window and set the FixedLayout - Grouping property to =Fields!SalesID.Value. See Group in a FixedPage to understand grouping further.
  2. In the Report Explorer, right-click the Embedded Images node to select Add Embedded Image.
    OR
    Alternatively, you can also select the Embedded Images option by clicking the Add (+) icon at the top on the Report Explorer.
    This opens the Open dialog where you can select an image to embed in the report.
  3. Drag and drop the embedded image, which now appears as a node in the Report Explorer, onto the Page 1 design surface and in the properties window set its Location property to 0in, 0in.
  4. From the Visual Studio toolbox, drag the following controls from the ActiveReports 13 Page Report tab, drop it onto the Page 1 design surface and set the following properties in the properties window.

    Show Controls

    Control Properties
    Textbox Color: DarkSlateBlue
    Font: Normal, Arial, 11pt, Bold
    Location: 0in, 1in
    Size: 2in, 0.25in
    TextAlign: Center
    Value: 5473 Sidelong Street
    Textbox Color: DarkSlateBlue
    Font: Normal, Arial, 11pt, Bold
    Location: 0in, 1.25in
    Size: 2in, 0.25in
    TextAlign: Center
    Value: Siler City, NC. 27344
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 0in, 2in
    Size: 1in, 0.25in
    TextAlign: Right
    Value: Sales Date :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 0in, 2.25in
    Size: 1in, 0.25in
    TextAlign: Right
    Value: Sales ID :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Customer Name :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2.25in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Address :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2.50in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: City :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2.75in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Country :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 0in, 4in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Account Number:
    Table BorderStyle: Solid
    FixedSize: 6.5in, 1in
    Location: 0in, 5in
    OverflowName: OverflowPlaceHolder1
    Note: Set this property after you add the OverflowPlaceHolder1 control to the design surface to handle the data that exceeds the fixed size of the Table data region.
    RepeatHeaderOnNewPage: True
    Size: 6.5in, 0.75in
  5. From the Report Explorer drag and drop the following fields onto the Page 1 design surface and set the following properties in the properties window.

    Show Fields

    Field Properties
    SaleDate Format: D
    Location: 1in, 2in
    Size: 2in, 0.25in
    TextAlign: Left
    SalesID Location: 1in, 2.25in
    Size: 2in, 0.25in
    TextAlign: Left
    FirstName Location: 4.5in, 2in
    Size: 2in, 0.25in
    TextAlign: Left
    Address1 Location: 4.5in, 2.25in
    Size: 2in, 0.25in
    TextAlign: Left
    City Location: 4.5in, 2.5in
    Size: 2in, 0.25in
    TextAlign: Left
    Country Location: 4.5in, 2.75in
    Size: 2in, 0.25in
    TextAlign: Left
    AccountNumber Location: 1.5in, 4in
    Size: 2in, 0.25in
    TextAlign: Left
  6. Hover your mouse over the columns of the Table Details row to access the field selection adorner and set the following fields in the table cells along with their properties.
    Cell Field Properties
    Left Cell Title BorderStyle: Solid
    TextAlign: Center
    Middle Cell Quantity BorderStyle: Solid
    TextAlign: Center
    Right Cell Price BorderStyle: Solid
    Format: c
    TextAlign: Center

    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.

  7. Select the Table Header row and set the following properties in the properties window.
    Property Name | Value
    BackgroundColor | Silver
    Font | Normal, Arial, 11pt, Bold
    RepeatOnNewPage | True
    TextAlign | Center
  8. Set the properties of the following cells on the Table Footer row through the properties window.
    Cell Properties
    Middle Cell Font: Normal, Arial, 10pt, Bold
    TextAlign: Right
    Value: Total:
    Right Cell Font: Normal, Arial, 10pt, Bold
    Format: c
    TextAlign: Center
    Value: =Sum(Fields!Price.Value)
  9. In the Report Explorer, expand the Common Values node and drag and drop the Page N of M (Section) field onto the Page 1 design surface and set its Location property to 0in, 8in in the properties window.

Show To create a layout for subsequent Pages

  1. Click the New tab to add a new page to the report layout. This page is named Page 2 by default.
  2. From the Visual Studio toolbox, drag the following controls from the ActiveReports 13 Page Report tab, drop it onto the Page 2 design surface and set the properties in the properties window.

    Show Controls

    Control Properties
    Textbox Font: Normal, Arial, 12pt, Bold
    Location: 0in, 1in
    Size: 2.625in, 0.25in
    TextAlign: Right
    Value: Account Details:
    Textbox Font: Normal, Arial, 12pt, Bold
    Location: 2.625in, 1in
    Size: 3.25in, 0.25in
    Value: =Fields!FirstName.Value + ", " + Fields!AccountNumber.Value
    OverflowPlaceHolder Location: 0in, 2in
    Size: 6.5in, 2in
    Textbox Location: 1.75in, 5in
    Size: 3in, 0.25in
    TextAlign: Center
    Value: Thank You For Your Business!
  3. In the Report Explorer, expand the Common Values node and drag and drop the Page N of M (Section) field onto the Page 2 design surface and set its Location property to 0in, 8in in the properties window.

Show To view the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at run time.

See Also

Overflow Data in a Single Page(Page Report)
Single Layout Reports

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Recursive Hierarchy Reports

Recursive Hierarchy Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Recursive Hierarchy Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a report using a recursive hierarchy and the Level function to show parent-child relationships in data. This walkthrough illustrates how to create a recursive hierarchy report.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Creating a dataset to populate the parameter values
  • Adding a report parameter
  • Adding a dataset for the report
  • Adding controls to the report to contain data
  • Setting up a recursive hierarchy
  • Using the Level function to display the hierarchy
  • Viewing the report
Note:
  • This walkthrough uses the Store table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Samples\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as rptRecursiveHierarchy.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To create a dataset to populate the parameter values

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Stores. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT StoreID FROM Store
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add a report parameter

  1. In the Report Explorer, right-click the data source node and select the Parameters node or select Parameter from the Add button.
  2. In the Report - Parameters dialog that appears, set the following values:

    In the General tab

    • Name: StoreID
    • DataType: Integer
    • Text for prompting users for a value: Select a store number

    In the Available Values tab select From query

    • Dataset: Stores
    • Value: StoreID
    • Label: StoreID
  3. Click OK to close the dialog and add the parameter under the Parameters node of the Report Explorer.

Show To add a dataset for the report

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Employees. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page, add a parameter with the following properties.
    • Parameter Name: @StoreID
    • Value: =Parameters!StoreID.Value
  4. On the Query page of this dialog, change the Command Type to StoredProcedure and enter the following stored procedure into the Query text box (the question mark denotes the parameter)
    StoredProcedure Query Copy Code
    EmployeesForStore ?
    EmployeesForStore ?
  5. Click the Validate icon to validate the query and to populate the Fields list.
  6. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. From the toolbox, drag a Table control onto the body of the report and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0in, 0in
    DataSetName | Employees
    FixedSize (only for Page reports) | 6.5in, 9in
  2. Click inside the table to display the row and column handles along the left and top edges of the table.
  3. Select the columns by clicking the grey column header above the column and change the Width property in the order as follows.
    Column | Property Name
    Second Column | Width: 1.5in
    Third Column | Width: 1.05in
    First Column | Width: 2.2in
  4. Right-click the grey column header above the third column and select Insert Column to the Right.
  5. Select the fourth column and change its Width property to 1.75in.
    Tip: Making some columns narrower before adding columns or making other columns wider prevents your report width from changing.
  6. In the Report Explorer from the Employees dataset, drag the following fields onto the detail row of the table.
    Data Field | Column Name
    Title | TableColumn1
    LastName | TableColumn2
    Supervisor | TableColumn3
    Department | TableColumn4
  7. Select the LastName field in the second column of the detail row and in the Properties window, set the Value property to =Fields!LastName.Value & " " & Fields!EmployeeID.Value. This will display the Employee ID number along with each employee's last name.
  8. Select the static label in the second column of the header row of the table and in the properties window, set its Value property to Last Name and ID.
  9. Select the Supervisor field in the third column of the detail row and in the Properties window, set its TextAlign property to Center.
  10. Select the static label in the third column of the detail row and in the Properties window, set its Value property to Supervisor ID.
  11. Select the header row by clicking the table handle to the left of the row and in the Properties window, set the following properties.
    Property Name | Property Value
    TextAlign | Center
    FontWeight | Bold
    BackgroundColor | DarkSlateBlue
    Color | White
  12. Select the detail row and in the Properties window, set the BorderStyle property to Solid.
  13. Right-click the table handle to the left of the header row and select Insert Row Above.
  14. While holding down the CTRL key, click each of the cells in the newly added top row.
  15. Right-click inside the selected cells and select Merge Cells to create a cell that spans the table.
  16. Go to the Properties window to set the following properties.
    Property Name | Property Value
    TextAlign | Center
    FontSize | 14pt
    Value | ="Store Number " & Parameters!StoreID.Value
  17. Right-click the table handle to the left of the row and select Table Footer to remove the footer row from the table.
Note: In case you are setting a recursive hierarchy on a Page report, set the DataSetName property in the Fixed Page Dialog to Employees.

Show To set up a recursive hierarchy

  1. Right-click the table handle to the left of the Detail row and select Edit Group to open the Table-Detail Grouping dialog.
  2. Under Group on: Expression, select =Fields!EmployeeID.Value.
  3. Under Parent group:, select =Fields!Supervisor.Value.
  4. Click OK to close the dialog.

Show To use the Level function to display the hierarchy

  1. Select the cell in the first column of the Detail row that reads =Fields!Title.Value and in the Properties window, expand the Padding property.
  2. In the Padding > Left property, enter the expression =2 + (Level() * 15) & "pt".
    Note: Adding 2 to the result ensures that a normal amount of padding is always used.

Show To use the Level function with themes in the BackgroundColor property of a textbox

  1. Go to C:\Users\<User>\Documents\GrapeCity Samples\ActiveReports 13\Reports Gallery\<C# or VB.NET>\Reports\RDL Report\Reels.
  2. Copy the file Reels.rdlx-theme and paste it into the folder in which you saved your report.
  3. In the Report Explorer, select Report.
  4. In the Properties window in the Theme property, enter the theme file name: Reels.rdlx-theme.
  5. Click the table handle to the left of the detail row to select the entire row.
  6. In the Properties window, set the BackgroundColor property to =Theme.Colors(Level() + 1, 4).

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Expressions

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Single Layout Reports

Single Layout Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Single Layout Reports

Glossary Item Box

Show All Show All
Hide All Hide All

A Page Report, allows you to create a layout at design time on a single page tab and apply it to the entire report. Designing a layout in this format gives you the advantage of creating a layout that appears exactly the same at design time and run time. This walkthrough illustrates how to create a report that contains a single layout and preview it.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a the data source
  • Adding a dataset
  • Creating a layout
  • Viewing the report
Note:
  • This walkthrough uses the DVDStock table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Samples\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Notice that the run time report layout below is similar to the one you see at design time except for the data which you see at run time or when you preview the report.

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as rptSingleLayout.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as DVDList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    Select * from dvdstock
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. In the Visual Studio toolbox, go to the ActiveReports 13 Page Report tab and drag a TextBox control onto the design surface.
  2. Select the TextBox control and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0.25in, 0.5in
    BackgroundColor | Khaki
    Color | Maroon
    Font | Normal, Arial, 16pt, Bold
    Size | 6in, 0.5in
    TextAlign | Center
    Value | DVD STOCK
  3. From the Visual Studio toolbox, drag a Table data region and place it on the design surface.
  4. Select the Table and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0.25in, 1in
    BackgroundColor | Khaki
    FixedSize | 6in, 7.5in
    RepeatHeaderOnNewPage | True
    Size | 6in, 0.75in
  5. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.

  6. Click the adorner to show a list of available fields from the DataSet and add the following fields to the cells of the table details row.

    Cell | Field
    Left Cell | Title
    Middle Cell | InStock
    Right Cell | StorePrice
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.
    Tip: You can also directly drag fields from the Report Explorer onto the textbox cells of the Table data region.
  7. Select the columns of the Table and set their Width property as follows:
    Cell | Field
    Left Cell | 2.5in
    Middle Cell | 1.75in
    Right Cell | 1.75in
  8. Select the following table rows and go to the Properties window to set their following properties.
    Row Properties
    Table Header BorderStyle: Solid
    Color: Maroon
    Font: Normal, Arial, 12pt, Bold
    TextAlign: Left
    Table Details BorderStyle: Solid
    Font: Normal, Arial, 10pt, Bold
    TextAlign: Left

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Overflow Data in Multiple Pages(Page Report)
Overflow Data in a Single Page(Page Report)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Subreports in Page/RDL Reports

Subreports in Page/RDL Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Subreports in Page/RDL Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a Page or an RDL report that hosts a subreport. This walkthrough illustrates how to create an RDL report using a subreport.

The walkthrough is split up into the following activities:

  • Creating a report for the subreport
  • Connecting the subreport to a data source
  • Adding a dataset with a parameter to the subreport
  • Adding a report parameter to the subreport
  • Adding controls to display data on the subreport
  • Creating the main report
  • Connecting the main report to a data source
  • Adding a dataset to the main report
  • Adding controls to display data on the main report
  • Viewing the report
Note: This topic uses the Employee, Sale and SaleDetails tables in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add a report for the subreport

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 RDL Report and in the Name field, rename the file as Sales.rdlx.
  4. Click the Add button to open a new RDL report in the designer.
  5. In the Solution Explorer, select Sales.rdlx and set the Build Action property to Content and the Copy to Output Directory property to Copy Always.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the subreport to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Reels.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a report parameter to the subreport

  1. In the Report Explorer, right-click the Parameters node and select the Add Parameter option or select Parameter from the Add button.
  2. Under Name, enter EmployeeID.
  3. Under Data type, select Integer.
  4. Click OK to close the dialog.

Show To add a dataset with a parameter to the subreport

When you add a query parameter using the syntax required by your database you must add a parameter to the Parameters page to ensure that the parameter value is passed to the query from the Report Parameters collection.

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as EmployeeSales. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page under Parameter Name enter EmployeeID.
  4. Under Value enter =Parameters!EmployeeID.Value
  5. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM EmployeeSales
  6. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  7. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add controls to display data on the subreport

  1. From the toolbox, drag a Table data region onto the body of the report and go to the properties window to set the DataSetName property to EmployeeSales.
  2. Click inside the table to display the column and row handles along the top and left sides of the table.
  3. Right-click the handle above the rightmost column and select Insert Column to the Right to add another column.
  4. Click the column handle at the top of each column in turn to select it, and in the property grid, set the Width property as indicated in the table.
    Column | Width
    First | 1.5in
    Second | 1.5in
    Third | 1.2in
    Fourth | 1.55in
    Tip: In most cases it is easier to resize existing columns before adding new columns because this prevents the table from growing horizontally and pushing the report width beyond what will fit on paper.
  5. Right-click the handle to the left of the table detail row and select Insert Group to open the Table-Groups dialog.
  6. Under Expression select =Fields!EmployeeID.Value. This groups all details from each employee.
  7. Change the Name to Employee and click OK to close the dialog. A grouping row is added to the table.
    Note: You cannot change the name of a table group until after you have set the expression.
  8. Right-click the handle to the left of the table detail row and select Edit Group to access the Table-Detail Grouping dialog.
  9. Under Expression select =Fields!SaleID.Value and click OK to close the dialog. This lists the total amount of each sale instead of listing each item sold within each SaleID.
  10. Right-click the handle to the left of the grouping row and select Insert Row Below. We will use this new row for static labels that repeat at the top of each new group.
  11. Right-click any handle to the left of the table and select Table Header to toggle off the table header.
  12. Right-click any handle to the left of the table and select Table Footer to toggle off the table footer.
  13. In the Report Explorer, select the Body node and go to the Properties window to set the Size property to 5.75in, 1in so that it fits inside the subreport control on the main report.

Show To add data fields to the Table data region

  1. In the Report Explorer, from the EmployeeSales dataset, drag the following field onto the first group header row of the table.
    Data Field | Column Name | Property Name
    Name | TableColumn1 | FontWeight: Bold
  2. Use the Shift key and the mouse to select the first two cells in the first group header row, right-click and select Merge Cells. This allows the employee name to span two columns in the table.
  3. Using the handle to the left of the first group header row, select the row and set the BackgroundColor property to LightSteelBlue.
    Tip: Even if you do not want to use colors in your finished report, it is often helpful to do so during the design of a report to make identification of the various sections easier for troubleshooting when you preview it.
  4. Enter the following text into the cells in the second group header row of the table.
    Data Field Column Name Property Name
    Sale Date TableColumn1 FontWeight: Bold
    TextAlign: Right
    Sale Number TableColumn2 FontWeight: Bold
    TextAlign: Right
    Quantity TableColumn3 FontWeight: Bold
    TextAlign: Right
    Total TableColumn4 FontWeight: Bold
    TextAlign: Right
  5. Using the handle to the left of the second group header row, select the row and set the BackgroundColor property to LightGray.
  6. In the Report Explorer, drag the following fields from the EmployeeSales dataset onto the detail row of the table.
    Data Field | Column Name | Property Name
    Sale Date | TableColumn1 | Format: Short date
    SaleID | TableColumn2
    Quantity | TableColumn3
    Total | TableColumn4 | Format: Currency
  7. In the detail row of the table, select the textbox with the Quantity data field and go to the Properties window to change the Value property to =Sum(Fields!Quantity.Value). This adds the Sum aggregate to the expression for the field and shows a summary of the quantity field for each SalesID.
  8. In the detail row of the table, select the textbox with the Total data field and go to the Properties window to change the Value property to =Sum(Fields!Total.Value). This adds the Sum aggregate to the expression for the field and shows a summary of the total field for each SalesID.
  9. In the Report Explorer, from the EmployeeSales dataset, drag the following fields onto the group footer row of the table. Notice that the value of fields dragged onto the group footer row automatically use the Sum aggregate function.
    Data Field | Column Name | Property Name
    Quantity | TableColumn3 | Value: =Sum(Fields!Quantity.Value)
    Total TableColumn4 Format: Currency
    Value: =Sum(Fields!Total.Value)
  10. Enter the following text into the indicated cell in the group footer row of the table.
    Text Column Name Property Name
    Employee Total: TableColumn2 FontWeight: Bold
    TextAlign: Right
  11. Using the handle to the left of the group footer row, select the row and in the BackgroundColor property select LightGray.
  12. Go to the preview tab, enter 1035 for the Employee ID, and click the View Report button. You get a layout that looks similar to the following at design time and at run time.
    Design-Time Layout Run-Time Layout

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  13. From the File menu, select Save and save this file. This report functions as the subreport you use in the main report.

Show To create the main report

  1. From the Visual Studio Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select ActiveReports 13 RDL Report and in the Name field, rename the file as Employees.rdlx.
  3. Click the Add button to open a new fixed RDL report in the designer.
  4. In the Report Explorer, select the Body node and go to the Properties window to set the Size property to 6.5in, 3.6in.

Show To connect the main report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Reels.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset to the main report

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as EmployeeInfo. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM EmployeeInfo
  4. Click the Validate icon to validate the query and to populate the Fields list.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add controls to display data on the main report

The following steps demonstrate how you can add controls and create the main report:

Show To add a static label to the top of the main report

From the toolbox, drag a TextBox control onto the body of the report and set the following properties:

Property Name | Property Value
Font | Normal, Arial, 14pt, Bold
Location | 0in, 0in
Size | 6.5in, 0.3in
TextAlign | Center
Value | Employee Report by City and Store

Show To add a List data region that repeats data for each city

  1. Drag a List data region from the toolbox onto the body of the report and with the data region selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    BackgroundColor | Silver
    DataSetName | EmployeeInfo
    Location

    0in, 0.5in
    Size | 6.5in, 3.1in
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. In the List dialog that appears, select Detail Grouping.
  4. Under Expression, select =Fields!City.Value
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag the City field onto the List data region and set the following properties:
    Property Name | Property Value
    FontSize | 12pt
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    TextAlign | Center

Show To nest a second List data region that repeats data for each store within the city

  1. Drag a List data region from the toolbox onto the the first list and with the data region selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    BackgroundColor | Beige
    DataSetName | EmployeeInfo
    Location | 0.125in, 0.3in
    Size | 6.25in, 2.7in
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. In the List dialog that appears, select Detail Grouping.
  4. Under Expression, select =Fields!StoreName.Value
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag the StoreName field onto the list and set the following properties:
    Property Name | Property Value
    FontWeight | Bold
    Location | 0in, 0in
    Size | 2in, 0.25in

Show To nest a third List data region that repeats data for each employee in the store

  1. Drag a List data region from the toolbox onto the second list and with the data region selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    BackgroundColor | White
    DataSetName | EmployeeInfo
    Location | 0in, 0.25in
    Size | 6.125in, 2.125in
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. In the List dialog, select Detail Grouping.
  4. Under Expression, select =Fields!EmployeeID.Value
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag the following fields onto the list and set the following properties:
    Data Field Property Name
    Name Location: 1.125in, 0in
    Size: 2.625in, 0.25in
    Education Location: 1.125in, 0.25in
    Size: 2.625in, 0.25in
    DateOfBirth Location: 5in, 0in
    Size: 0.875in, 0.25in
    Format: Short date
    PhoneNumber Location: 4.875in, 0.25in
    Size: 1in, 0.25in
  7. From the toolbox, drag five text boxes onto the List and set the following properties:
    TextBox Name Value Property Property Name
    TextBox 1 Name: Location: 0.125in, 0in
    Size: 0.625in, 0.25in
    FontWeight: Bold
    TextBox 2 Education: Location: 0.125in, 0.25in
    Size: 0.875in, 0.25in
    FontWeight: Bold
    TextBox 3 Date of Birth: Location: 3.875in, 0in
    Size: 1in, 0.25in
    FontWeight: Bold
    TextBox 4 Phone: Location: 3.875in, 0.25in
    Size: 0.875in, 0.25in
    FontWeight: Bold
    TextBox 5 Sales Record Location: 0.125in, 0.5in
    Size: 1in, 0.25in
    FontWeight: Bold

Show To add a Subreport control to the main report

  1. From the toolbox, drag a Subreport control onto the third list and with the control selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    Location | 0.125in, 0.75in
    NoRows | No sales recorded for this employee during 2005.
    ReportName

    Sales (ensure that this report is saved in the same directory as the Sales report)

    Note: To view the report in the preview tab, you should specify the full path to the subreport.
    Size | 5.75in, 1.3in
    Visibility: Hidden | True (hides the subreport initially)
    Visibility: ToggleItem | Sales Record text box added in the previous procedure (puts a toggle image next to the text that shows the subreport when clicked)
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. On the Parameters page of the Subreport dialog, set the Parameter Name to EmployeeID. This name must match the parameter in the subreport exactly.
  4. Set the Parameter Value to =Fields!EmployeeID.Value.
    Note: You can use the option of having the subreport automatically apply the same theme as the hosting report. This option is available on the General page of the Subreport Properties.
  5. Click OK to close the dialog.

Show To view the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at run time.
Note: Click the + to the left of Sales Record to see the subreport.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart

Chart
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart

Glossary Item Box

This section contains the walkthroughs on creating different types of charts.

Column Charts
This walkthrough demonstrates how to create a simple Column chart.
Funnel Charts
This walkthrough demonstrates how to create a Funnel chart.
Gantt Charts
This walkthrough demonstrates how to create a Gantt chart.
Column Charts (Classic Charts)
This walkthrough demonstrates how to create a simple Column chart (classic).

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Column Charts

Column Charts
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart > Column Charts

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a page report with a chart using the ActiveReports Chart data region. This walkthrough illustrates how to create a simple report with a Column chart.

The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a chart data region with data and grouping to the report
  • Configuring the appearance of the chart
  • Viewing the report
Note:
  • This walkthrough uses the StoreSummary table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as rptSalesByStore.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ChartData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the ChartData data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as StoreSummaryData. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * from StoreSummary
  4. Click the Validate DataSet [image] icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as child nodes to the data source in the Report Explorer.

Show To add chart data region with data and grouping to the report

  1. From the toolbox, drag the Chart data region onto the design surface of the report .
  2. In the Select a Chart Type wizard that appears, select the chart type Column.
  3. Go to the Properties Window, click ellipses button next to Plots property to open the PlotDesigner Collection Editor. You see that Plot1 is already added.
  4. Select Plot1 and click ellipses next to go to Encodings>Values property to open the DataFields Collection Editor.
  5. Add a field and set its value to expression =Fields!GrossSales.Value.
  6. Click OK to save and return to PlotDesigner Collection Editor.
  7. Go to Encodings>Category>Values property and click ellipses next to Values property.
  8. Add a field and set its value to expression =Fields!StoreName.Value.
  9. Click OK to save and exit expression editor and then again to close the collection editor.
    You see that 'Store Name' is added to Category Fields and 'Gross Sales' is added to Data Fields.

Show To configure the appearance of the chart

  1. Select Chart and set Pallet to Office.
  2. Select 'Chart title' on the chart and set Title to 'Sales by Store'.
  3. Select the chart plot and set following properties.
    Property Name | Property Value
    LineStyle>LineColor | Red
    LineStyle>LineStyle | Dotted
  4. Select X-axis and set Labels>LabelsAngle to -45 degrees.
  5. Select X-axis and set Title>TitleStyle>Padding>Top to 8pt.
  6. Select Y-axis and set Title>TitleStyle>Padding>Right to 4pt.
    Note: You may need to adjust:
    • Size of the chart so that all labels are displayed correctly. Select Chart and set Size property to a larger value.
    • Page size of the report so that the chart is fully rendered. Select Report and set PageSize property to a larger value.

Show To view the report

  • Click the Preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Composite Charts

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Composite Charts

Composite Charts
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart > Column Charts > Composite Charts

Glossary Item Box

Show All Show All
Hide All Hide All

You can create Page and RDL reports with composite charts using the ActiveReports Chart data region. A composite chart consists of two or more series plotted along the Y-axis, where each series can display a different chart type. In ActiveReports, a composite chart may have up to six Y-axis series. You can combine the following chart types:

  • Column: Plain, Stacked, Percent Stacked
  • Area: Plain, Stacked, Percent Stacked
  • Line: Plain, Smooth

This walkthrough illustrates a step-by-step implementation for creating a composite chart with three Y-axis series. The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a chart data region and define plots
  • Defining axes for plots
  • Configuring the appearance of the chart
  • Viewing the report

Note:

  • This walkthrough uses the StoreSummary table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as rptCompositeChart.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

    See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ChartData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the ChartData data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as StoreSummaryData.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * from StoreSummary
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as child nodes to the data source in the Report Explorer.

Show To add the chart data region and define plots

  1. From the toolbox, drag a Chart data region onto the design surface of the report.
  2. In the Select a Chart Type wizard that appears, select the chart type as Column.
  3. Go to the Properties Window, click ellipses button next to Plots property to open the PlotDesigner - Collection Editor. You see that default Plot1 is already added.
  4. Add two new plots and set their Name as Plot2 and Plot3. Now you have three chart plots - Plot1, Plot2, and Plot3.
  5. Set the properties of Plot1, Plot2, and Plot3 in the collection editor as follows.
    Property Name

    Property Values

    Plot1

    Plot2

    Plot3
    Encodings>Category>Values
    Bind field 'StoreName' to X-axis for each plot.

    =Fields!StoreName.Value

             =Fields!StoreName.Value =Fields!StoreName.Value
    Encodings>Values collection editor
    Bind fields 'GrossSales', 'GrossProfit', and 'TotalItems' to Y-axis for each plot, respectively.     		=Fields!GrossSales.Value =Fields!GrossProfit.Value =Fields!TotalItems.Value
    Encodings>Color>ShowValuesName
    Display Legends for each plot.     		True True True
    LineStyle>LineColor
    Display selected color as the color of line in respective plots.     		Black LimeGreen Black
    LineStyle>LineStyle
    Display selected style as the style of line in respective plots.     		Solid Solid Solid
    LineStyle>LineWidth
    Display selected width as the width of line (in pts) in respective plots.     		1pt 3pt 1pt
  6. Click OK to save and exit the collection editor.
  7. Right click Plot 1 and select Plot Template > Area > Area.
  8. Right click Plot 2 and select Plot Template > Line > Line.
  9. Right click Plot 3 and select Plot Template to Column > Column.

Show Define axes for the plots

  1. From Report Explorer, select Chart.
  2. Go to the Properties Window and click ellipses next to PlotArea > Axes property to open the AxisDesigner - Collection Editor. You see that six axes are already added.
  3. Remove Axis3 (AxisType X for Plot2) and Axis5 (AxisType X for Plot3). So now we have total four axes (one X axis - common for three plots and three Y axes - for three plots).
  4. Set the properties of the four axes in the collection editor as follows.
    Property Name

    Property Values

    Axis1

    Axes2

    Axes4

    Axes6
    Common>AxisType
    Specify axis type as X or Y.     		X Y Y Y
    Common>Plots
    Specify plots on respective axes.     		Plot1, Plot2, Plot3 Plot1 Plot2 Plot3
    Title>Title
    Specify title to be displayed for each axis.     		Store Name Gross Sales Gross Profit Total Items
    Labels>Format
    Specify format of the values displayed on each axis.     		Default c c d
    Line>LineStyle>LineStyle
    Specify axis line styles.     		Solid Solid Solid Solid
    Line>LineStyle>ShowLine
    Show axis lines on the plot.     		True True True True
    Layout>Position
    Specify position of axes.     		Near

    Near

             Near Far
    Major Grid > ShowMajorGrid
    Show or hide major grid lines.     		True False False False
  5. Click OK to save and exit the collection editor.

Show To configure the appearance of the chart

  1. Select Chart and set Pallet to Office.
  2. Select 'Chart title' on the chart and set Title to 'Store Summary'.
  3. Select X-axis and set Labels>LabelsAngle to 90 degrees.

    Let us set the maximum and minimum values to limit the values for each Y axis plots. This is based on the values in the data set.

  4. Go to the Properties Window and click ellipses next to PlotArea > Axes property to open the AxisDesigner - Collection Editor. Note that axes get renamed once you reopen the AxisDesigner - Collection Editor.

    Property Name

    Property Values
    Axes2
    (Y axis for Plot1)     		Axes3
    (Y axis for Plot2)     		Axes4
    (Y axis for Plot3)
    Scale>Max | 27000 | 15000 | 1400
    Scale>Min | 18000 | 9000 | 900
    Note: You may need to adjust:
    • Size of the chart so that all labels are displayed correctly. Select Chart and set Size property to a larger value.
    • Page size of the report so that the chart is fully rendered. Select Report and set PageSize property to a larger value.

Show To view the report

  • Click the Preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Funnel Charts

Funnel Charts
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart > Funnel Charts

Glossary Item Box

Show All Show All
Hide All Hide All

The Funnel charts enable users to visualize stages in a linear process. This walkthrough illustrates a step-by-step implementation for creating a composite chart with three Y-axis series. The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a chart data region and define plots
  • Configuring the appearance of the chart
  • Viewing the report

Note:

  • This walkthrough uses the StoreSales table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as rptFunnelChart.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

    See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ChartData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the ChartData data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as StoreSalesData.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * from StoreSales
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as child nodes to the data source in the Report Explorer.

Show To add a chart data region and define plots

  1. From the toolbox, drag a Chart data region onto the design surface of the report.
  2. In the Select a Chart Type wizard that appears and select the chart type as Column.
  3. Right-click on the chart and go to Plot Template > Miscellaneous and select Funnel.
  4. Select the chart plot and go to Properties window.
  5. Go to Encodings > Values property and click ellipses next to Values property to open ValueAggregateEncodingDesigner Collection Editor.
  6. Add a new Value field to the collection editor.
  7. Open its Value collection editor and add a value field and set its expression to =Fields!TotalSales.Value.
  8. Click OK to save and exit the collection editor. You see that 'Total Sales' field is added under the Data Fields on chart.
  9. Select the chart plot and go to Properties window.
  10. Go to Encodings > Details property and click ellipses next to Values property to open DetailEncodingDesigner Collection Editor.
  11. Add a new Detail field to the collection editor.
  12. Open its Values collection editor and add a value field and set its expression to =Fields!StoreName.Value.
  13. Click OK to save and exit expression editor and then again to close the collection editor. You see that 'Store Name' is added as Details encoding on the chart.
  14. Select 'Store Name' encoding and set following properties:
    Property Name | Property Values
    Group | Stack
    SortDirection | Ascending
    SortingField | =Fields!StoreName.Value

    Let us add legend to the chart.
  15. Select the chart plot and go to Encodings > Color > Values property.
  16. Click ellipses next to Values property to open the expressions editor.
  17. Add a value field and set its expression to =Fields!StoreName.Value

Show To configure the appearance of the chart

  1. Select Chart and set Pallet to Office.
  2. Select 'Chart title' on the chart and set Title to 'Store Sales'.
  3. Select Category axis and set Lines>ShowLine and Labels>ShowLabels to False.
  4. Select Value axis and set ShowLine and ShowLabels to False.
  5. Select the chart plot and set the label settings for the Funnel chart as:
    Property Name | Property Values
    Labels>Color | White
    Labels>Template
    Specify the template to be displayed for the label.     		{valueField.value:c}
    Labels>TextPosition
    Specify text position of the label.     		Center
  6. Select Legends on chart and set Title to 'Store Name'.

Show To view the report

  • Click the Preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Gantt Charts

Gantt Charts
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart > Gantt Charts

Glossary Item Box

Show All Show All
Hide All Hide All

The Gantt charts are used to represent the schedule of sequence of tasks in a project. To plot Gantt charts, you need to have the start and end times of a task.
The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a chart data region and define plots
  • Configuring the appearance of the chart
  • Viewing the report

Note:

  • This walkthrough uses the ScheduleOfTime table from the Schedule database. By default, in ActiveReports, the Schedule.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, rename the file as rptGanttChart.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

    See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ChartData.
  3. On this page, create a connection to the Schedule database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the ChartData data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as ScheduleData.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Top 5 * from ScheduleOfTime
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. To obtain end time of the tasks, you need to add a field that calculates end times. Go to Fields tab and add a calculated field EndTime with expression =DateAdd(DateInterval.Hour, [Hours], [StartTime]).
  6. Click OK to close the dialog. Your data set and queried fields appear as child nodes to the data source in the Report Explorer.

Show To add a chart data region and define plots

  1. From the toolbox, drag a Chart data region onto the design surface of the report.
  2. In the Select a Chart Type wizard that appears and select the chart type as Column.
  3. Right-click on the chart and go to Plot Template > Miscellaneous and select Gantt.

    Note that the chart changes to horizontal bar chart, where horizontal axis (AxisType Y) represents time duration that a task needs to finish and each bar (plotted along Vertical axis (AxisType X)) represents a task.
  4. Select the chart control so that the chart adorners are displayed.
  5. Right-click the Data Fields adorner and click Add. You see that a field is added.
  6. Select the field and click the ellipses next to Subfields property to open Complex Fields Collection Editor.
  7. Set lower value to =Fields!StartTime.Value and upper value to =Fields!EndTime.Value to show Value axis.
  8. Click OK to save and exit the collection editor.
  9. Select the chart control so that the chart adorners are displayed.
  10. Right-click the Category Fields adorner and click Add. You see that category 'Category0' is added.
  11. Select 'Category0' and set its Expression to =Fields!Labels.Value.

Show To configure the appearance of the chart

  1. Select Chart and set Pallet to Office.
  2. Select 'Chart title' on the chart and set Title to 'Schedule'.
  3. Select Category axis (AxisType X) and set Title to 'Topics'.
  4. Select Value axis (AxisType Y) and set Title to 'Timeline'.
  5. Select the Timeline axis and set the label settings as:
    Property Name | Property Values
    Labels>LabelAngle | -45
    Title>TitleStyle>Font>FontSize
    Specify the template to be displayed for the label.     		10pt
  6. Select the Topics axis and set Title>TitleStyle>Font>FontSize to 10 pt.

Show To view the report

  • Click the Preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Column Charts (Classic Charts)

Column Charts (Classic Charts)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart > Column Charts (Classic Charts)

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a page report with a chart using the ActiveReports Chart data region. This walkthrough illustrates how to create a report with a chart.

The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a chart data region with data and grouping to the report
  • Configuring the appearance of the chart
  • Viewing the report
Note:
  • This walkthrough uses the Sales table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 12\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 12 Page Report Application and in the Name field, rename the file as ProfitsByGenre.
  3. Click OK to create a new ActiveReports 12 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the ReportData data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as ProfitsByGenre. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Profit, SalesID, SaleDate, GenreName FROM SalesByGenre WHERE (SalesID < 1090) AND (GenreName = "Comedy" OR GenreName = "Drama" OR GenreName = "Adventure") ORDER BY SalesID
  4. Click the Validate DataSet [image] icon at the top right hand corner above the Query box to validate the query.
  5. On the Fields page, add a new field by clicking the Add (+) button above the fields list.
  6. Set the Name to Month and the Value of the new field to =Fields!SaleDate.Value.Month
    This parses out the month from the date field.
  7. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add chart data region with data and grouping to the report

  1. From the toolbox, drag the Chart data region onto the design surface of the report .
  2. In the wizard Select a Chart Type that appears, select the chart type Column and go to the Properties Window to set the following properties:
    Property Name | Property Value
    Location | 0in, 0in
    Size | 6.5in, 4.5in
  3. Double-click inside the chart area to display the UI along the top, right, and bottom of the chart to drop fields in.
  4. From the Report Explorer, drag the Month field into the area below the chart labeled "Drop category fields here." This automatically binds the Month field to the X axis.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  5. Right-click the month category group and select Edit to open the Chart Data - Category Groups dialog.
  6. In the dialog that appears on the General page, go to the Label field and enter the following expression: =MonthName(Fields!Month.Value) and click OK to close the dialog.
  7. From the ReportExplorer, drag the Profit field into the area above the chart labeled "Drop data fields here." This plots the profits to the Y axis of the chart.
  8. In the Report Explorer, drag the GenreName field into the area to the right of the chart labeled "Drop series fields here." This sets the series to be charted in the chart area.
  9. Right-click the genre series group and select Edit to open the Chart Data - Series Groups dialog.
  10. In the dialog that appears on the General page, go to the Label field and enter the following expression: =Fields!GenreName.Value. This shows genre names in the legend.
  11. Click OK to close the dialog.
  12. Select the chart and at the bottom of the Properties Window, select the Chart Data command. See Properties Window for further details on accessing commands.
  13. In the Chart Data dialog that appears, under Series Values go to the Value field and make sure it is set to =Sum(Fields!Profit.Value).

Show To configure the appearance of the chart

  1. Select the chart and at the bottom of the Properties Window, select the Chart appearance command.
  2. In the Chart Appearance dialog that appears set the following:

    Show Title Page

    On the Title page enter Profits by Genre in the Chart title text box and change the Size property to 14pt.

    Show Palette Page

    On the Palette page and select Light in the drop down list. This is a good color choice because it differentiates between genres without highlighting one of them unintentionally.

    Show Plot Area Page

    On the Plot Area page set the Background Fill Color > Fill Color to Silver.
  3. Click OK to close the dialog.
  4. Select the Chart Legends and at the bottom of the Properties Window, select the Property dialog command.
  5. In the Chart Legend - General dialog that appears, uncheck the Use smart settings option.
  6. Click OK to close the dialog.
  7. Select the X-Axis label in the chart and at the bottom of the Properties Window, select the Property dialog command.
  8. In the Chart X-Axis - Title dialog that appears set the following properties:

    Show Title Page

    On the Title page, in the X-Axis Title field remove the default "Axis X" text.

    Show Labels Page

    On the Labels page, set the Size property to 10pt.
  9. Click OK to close the dialog.
  10. Select the chart and at the bottom of the Properties Window, select the Chart Y-axis command.
  11. In the Chart Y-Axis - Title dialog that appears set the following properties:

    Show Title Page

    On the Title page, in the Y-Axis Title field remove the default "Axis Y" text if available.

    Show Labels Page

    On the Labels page and in the Format code field, select Currency in the Format drop-down list. Set the Size property to 10pt.

    Show Scale Page

    On the Scale page and in the Minimum field enter 0 (zero). This sets the currency labels to start at zero on the Y axis.
  12. Click OK to close the dialog.

Show To view the report

  • Click the Preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Composite Charts (Classic Charts)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Composite Charts (Classic Charts)

Composite Charts (Classic Charts)
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart > Column Charts (Classic Charts) > Composite Charts (Classic Charts)

Glossary Item Box

Show All Show All
Hide All Hide All

You can create Page and RDL reports with composite charts using the ActiveReports Chart data region. A composite chart consists of two or more series plotted along the Y-axis, where each series can display a different chart type. In ActiveReports, a composite chart may have up to six Y-axis series. You can combine the following chart types:

  • Column: Plain, Stacked, Percent Stacked
  • Area: Plain, Stacked, Percent Stacked
  • Line: Plain, Smooth

This walkthrough illustrates a step-by-step implementation for creating a composite chart with three Y-axis series. The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a chart data region with data to the report
  • Configuring the appearance of the chart
  • Viewing the report

Note:

  • This walkthrough uses the StoreSummary table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 12\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 12 Page Report Application and in the Name field, rename the file as rptCompositeChart.
  3. Click OK to create a new ActiveReports 12 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ChartData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the ChartData data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as StoreSummaryData.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * from StoreSummary
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as child nodes to the data source in the Report Explorer.

Show To add the chart data region with data to the report

  1. In the Report Explorer, select Report and in the Properties Window, set the PaperOrientation property to Landscape.
  2. From the toolbox, drag a Chart data region onto the design surface of the report.
  3. In the Select a Chart Type wizard that appears, select the chart type as Column and go to the Properties Window to set the following properties.

    Property Name | Property Value
    Location | 0in, 0in
    Size | 7.5in, 4.5in
  4. Double-click inside the chart area to display the chart panes along the top, right, and bottom of the chart to drop fields in.
  5. From the Report Explorer, drag the StoreName field into the area below the chart labeled "Drop category fields here." This automatically binds the StoreName field to the X-axis.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink
  6. Select the chart and at the bottom of Properties Window, select the Chart Y-Axis command.
  7. In the Y-axis dialog that appears, under the Title tab, set the Y-Axis title property to Gross Sales.
  8. Click Add to add the second Y-Axis. Set the Y-Axis title property to Gross Profit and the Margin property to 0.8in.
  9. Click Add to add the third Y-Axis. Set the Y-Axis title property to Total Items and the Position property to Right.
  10. Click OK to close the dialog.
  11. Select the chart and from the bottom of the Properties Window, select the Chart data command.
  12. Select the Series Values page. Click Add to add the first Y-axis series and set the properties as follows.

    Property Name | Property Value
    Series label | Gross Sales
    Value | =[GrossSales]
    Chart Type | Area Plain
    Y-Axis | Y1
  13. Click Add to add the second Y-axis series and set the properties as follows.

    Property Name | Property Value
    Series label | Gross Profit
    Value | =[GrossProfit]
    Chart Type | Line Plain
    Y-Axis | Y2
  14. Click Add to add the third Y-axis series and set the properties as follows.

    Property Name | Property Value
    Series label | Total Items
    Value | =[TotalItems]
    Chart Type | Column Plain
    Y-Axis | Y3
  15. Click OK to close the dialog.

Show To configure the appearance of the chart

  1. Select the chart and at the bottom of Properties Window, select the Chart appearance command.
  2. In the Chart Appearance dialog that appears, on the Title page enter Store Summary in the Chart title field.
  3. In the Palette page, open the Palette drop-down, and select Pastel.
  4. Click OK to close the dialog.
  5. Select the chart and at the bottom of the Properties Window, select the Chart X-Axis command.
  6. In the Chart X-Axis - Title dialog that appears set the properties as follows.

    Property Name | Property Value
    X-Axis title | Store Name
    Size | 6pt
  7. Click OK to close the dialog.
  8. Select the chart and at the bottom of the Properties Window, select the Chart Y-Axis command.
  9. Select Y1 from the list of Y-axes and under the Labels tab, select the Show y-axis labels check box. Also, select Currency from the Format code drop-down.
  10. Repeat the above step for Y2.
  11. Select Y3 from the list of Y-axes and under the Labels tab, select the Show y-axis labels check box.
  12. Click OK to close the dialog.

Show To view the report

  • Click the Preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Map

Map
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Map

Glossary Item Box

This section contains the following walkthrough that fall under the Map category.

Reports with Map
This walkthrough demonstrates how to create a report with a map.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with Map

Reports with Map
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Map > Reports with Map

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a page report that contains a map using the ActiveReports Map control. The Map data region shows your data on a geographical background. This walkthrough illustrates how to create a report that uses a Map to display data.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding Map control to the report and configuring its data
  • Configuring appearance of the Map
  • Viewing the report
Note:
  • This walkthrough use tables from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file to CustomersPopulation.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Customers. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Address.Region, Customer.CustomerID FROM (Address INNER JOIN Person ON Address.[AddressID] = Person.[AddressID]) INNER JOIN Customer ON Person.[PersonID] = Customer.[PersonID];
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add a Map data region and configure its data

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the USA Map template.
  3. Click the Map until the map panes appear.
  4. In the layers pane, right click PolygonLayer1 and select Layer Data to open Map Layer Data Properties dialog.
  5. In the Map Layer Data Properties dialog that appears, go to the Analytical data page.
  6. Select Customers from the Dataset property combo box and then click the Add (+) button located next to the Match label. This creates an empty match item and enables its Spatial and Analytical fields editor.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  7. In the Spatial field property, select STATE_ABBR from the combo box; and similarly, select =Fields!Region.Value in the Analytical field property. This builds the match field expression and relates the analytical data to map elements on a polygon layer.
  8. Click OK to close the dialog.

Show To configure appearance of the Map

  1. In the layers pane, right click PolygonLayer1 and select Edit to open Map Polygon Layer dialog.
  2. In the General page of the dialog, select #STATE_NAME from the Label Text combo box to display as label inside polygons at run time.
  3. Go to the Color Rule page of the dialog, and select Visualize data by using color palette option. This activates the tabs below.
  4. On the General tab, enter the following expression =Count([CustomerID]) in the Data field property and set Palette property to SemiTransparent.
  5. On the Distribution tab, set the Method property to EqualInterval.
  6. On the Legends tab, click to select Show in Legend.
  7. In Legend Name, enter Legend. This name relates to the default legend that appears in the Legend collection.
  8. Click OK to close the dialog.
  9. On the design surface, click on the Map control to select it and go to the Properties Window to set the following properties:

    Show Properties

    Property Name | Property Value
    BackgroundColor | White
    BackgroundGradientEndColor | White
    BorderStyle | Solid
    ColorScale > Hidden | True
    DistanceScale > Hidden | True
    Location | 0in, 0.625in
    Size | 6.5in, 4.75in
    ViewPort > BackgroundColor | LightSteelBlue
    ViewPort > BackgroundGradientEndColor | White
    ViewPort > BorderStyle | None
    ViewPort > CoordinateSystem | Planar
    ViewPort > Margin > Right | 20pt
    ViewPort > Meridians > Hidden | True
    ViewPort > Parallels > Hidden | True
    ViewPort > View > Zoom | 115
  10. With the Map control selected, go to the Properties window, click the Legends (Collection) property and then click the ellipsis button that appears.
  11. In the LegendDesigner Collection Editor that appears, under the Members list, select the existing legend and set the following properties:

    Show Properties

    Property Name | Property Value
    BackgroundColor | LightSteelBlue
    BackgroundGradientEndColor | White
    Location > DockOutsideViewport | False
    Location > DockPosition | RightBottom
    Title > (Caption) | Number of Customers
    Title > Font | Normal, Arial, 10pt, Bold
  12. Click OK to close the dialog.
  13. With the Map control selected, go to the Properties window, click the Titles (Collection) property and then click the ellipsis button that appears.
  14. In the MapTitleDesigner Collection Editor that appears, with Title selected in the Members list set the following properties:

    Show Properties

    Property Name | Property Value
    (Text) | Customers Population
    Color | Black
  15. Click OK to close the dialog.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Tablix

Tablix
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Tablix

Glossary Item Box

This section contains the following walkthrough that fall under the Tablix category.

Grouping in Tablix
This walkthrough demonstrates how to use grouping in Tablix.
Cell Merging in a Row Group Area in Tablix
This walkthrough demonstrates cells with duplicate values in a row group area are merged in Tablix.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Grouping in Tablix

Grouping in Tablix
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Tablix > Grouping in Tablix

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough illustrates a step-by-step implementation for creating a report which uses the Tablix data region to display regional product sales.

The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Creating a layout for the report
  • Enhancing the appearance of the report
  • Viewing the report
Note:
  • This walkthrough uses the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses RDL reports, you can also implement this using page reports.

When you complete this walkthrough, you will have a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-TimeLayout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Creating an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 RDL Report Application and in the Name field, name the file rptTablix.
  3. Click OK to create a new ActiveReports 13 RDL Report Application. By default an RDL report is added to the project.

    See Adding an ActiveReport to a Project for information on adding different report layouts.

Show Connecting the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show Adding a dataset

  1. In the Report Explorer, right-click the ReportData node (the name of data source added) and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and name the dataset SalesData. This name appears as a child node of the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Sale.SaleDate, Sale.TotalAmount, MediaType.Description, MediaType.MediaID, Sale.SalesID,
Sale.Store, Store.StoreName FROM Store INNER JOIN
(Sale INNER JOIN (MediaType INNER JOIN (MovieProduct INNER JOIN SaleDetails
ON MovieProduct.ProductID = SaleDetails.ProductID) ON MediaType.MediaID =
MovieProduct.MediaType) ON Sale.SalesID = SaleDetails.SaleID)
ON Store.StoreID = Sale.Store;
  4. Click the Validate DataSet icon [image] at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show Creating a layout for the report

  1. From the toolbox, drag a Tablix data region onto the designer surface of the report.
  2. Hover over TextBox2 to reveal the field selection adorner, click it to display a list of available fields, and select the SaleDate field. This is a column group cell, so selecting a field in it automatically adds a column group.
  3. With TextBox2 selected, in the Properties window set the Value to =Year(Fields!SaleDate.Value) using expressions. This groups and displays the data by Year.
  4. In the Group Editor, select the SaleDate group, and in the Properties window expand the Group property node and click the ellipsis button next to the GroupExpressions property to open the Expressions dialog.
  5. In the Expressions dialog that appears, select the group member from the Members list and in the property grid to the right, enter the expression =Year(Fields!SaleDate.Value) to group the data by year and then click OK to close the dialog.
  6. Right-click TextBox2 where SaleDate field is added in the Tablix data region, select Add Column Group, and then select the Adjacent Right option. The adjacent column group is added to the right and is listed under the Group Editor window.
  7. Hover over TextBox5 to reveal the field selection adorner, click it to display a list of available fields, and select the Description field. This is a column group cell, so selecting a field in it automatically adds a column group.
  8. Right-click TextBox5 where Description field is added in the Tablix data region, select Insert Row, and then select Outside Group - Above. The row is added above the new column group and is listed under the Group Editor window.
  9. In TextBox7 and TextBox8 above the SaleDate and Description fields, set the Value property to Year and Media Type, respectively.
  10. Hover over TextBox3 to reveal the field selection adorner, click it to display a list of available fields, and select the StoreName field. This is a row group cell, and selecting a field in it automatically adds a row group.
  11. Hover over TextBox4 to reveal the field selection adorner, click it to display the list of available fields, and select the TotalAmount field.
  12. Hover over TextBox6 to reveal the field selection adorner, click it to display the list of available fields, and select the TotalAmount field.

Show Enhancing the appearance of the report

When you preview the report at this point, you will notice the data from the fields is displayed in the Tablix data region. We can enhance the layout of the Tablix data region by setting cell properties in the Properties Window as follows:

  1. Cell | Property Name | Property Value
    =Year([SaleDate]) | BackgroundColor | WhiteSmoke
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    Year | BackgroundColor | LightSteelBlue
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[Description] | BackgroundColor | SlateGray
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    Media Type | BackgroundColor | LightSteelBlue
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[StoreName] | BackgroundColor | WhiteSmoke
    BorderStyle | Solid
    TextAlign | Center
    =Sum([TotalAmount]) | Format | c
    BorderStyle | Solid
    TextAlign | Center
  2. Select the two empty cells in the corner area (top left corner), right-click the selected area, and then select Merge Cells option to merge the cells.
  3. With the merged cell selected, in the Properties window set the Value property to Sales by Year and Media Type . This is the heading for the report.
  4. In the Tablix data region, select the textbox that contains Sales by Year and Media Type text and then go to Properties Window to set the following properties.
    Property Name | Property Value
    BackgroundColor | LightSteelBlue
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
  5. Select the Tablix data region and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0in, 0in
    Size | 3in, 1.125in

Show Viewing the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Cell Merging in a Row Group Area in Tablix

Cell Merging in a Row Group Area in Tablix
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Tablix > Cell Merging in a Row Group Area in Tablix

Glossary Item Box

This walkthrough illustrates a step-by-step implementation for creating a report which uses the Tablix data region to display store numbers and managers by region and district. The report in this walkthrough demonstrates how Tablix cells with same value in a row group area automatically merge to avoid clutter.

The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Creating a layout for the report
  • Enhancing the appearance of the report
  • Viewing the report
Note:
  • This walkthrough uses the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses RDL reports, you can also implement this using page reports.

When you complete this walkthrough, you will have a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 13 RDL Report Application and in the Name field, name the file rptTablix.
  3. Click OK to create a new ActiveReports 13 RDL Report Application. By default an RDL report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect a report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and name the dataset StoreDetails. This name appears as a child node of the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Regions.RegionID, Regions.Region, Districts.DistrictID, Districts.District,
Store.StoreName, Person.FirstName, Person.LastName FROM ((Regions INNER JOIN
Districts ON Regions.RegionID = Districts.Region) INNER JOIN Store ON
Districts.DistrictID = Store.DistrictID) INNER JOIN Person ON Store.Manager =
Person.PersonID;
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Tablix data region onto the designer surface of the report.
  2. Hover over TextBox3 to reveal the field selection adorner, click it to display a list of available fields, and select the Region field. This a row group cell, and selecting a field in it automatically adds a row group.
  3. Select TextBox1 above the Region row group cell, and in the Properties window set the Value property to Region. This is the heading for the row group.
  4. Right-click TextBox3 where the Region field was added in the Tablix data region, select Add Row Group, and then select the Child Group option. The child group is added to the right of the row header and is listed under the Group Editor window.
  5. Hover over TextBox5 to reveal the field selection adorner, click it to display a list of available fields, and select the District field. This a row group cell, and selecting a field in it automatically adds a row group.
  6. Select Textbox6 above the District row group cell, and in the Properties window set the Value property to District. This is the heading for the row group.
  7. Right-click TextBox5 where the District field was added in the Tablix data region, select Add Row Group, and then select the Child Group option. The child group is added next to the new row group and is listed under the Group Editor window.
  8. Hover over TextBox7 to reveal the field selection adorner, click it to display a list of available fields, and select the StoreName field. This a row group cell, and selecting a field in it automatically adds a row group.
  9. Select Textbox8 above the StoreName row group cell, and in the Properties window set the Value property to Store. This is the heading for row group.
  10. Right click Textbox8 above the StoreName row group cell, select Insert Column, and then select Right. This adds a new static column.
  11. Hover over TextBox9 to reveal the field selection adorner, click it to display a list of available fields, and select the FirstName field.
  12. With TextBox9 selected, in the Properties window set the Value property to =Fields!FirstName.Value & " " & Fields!LastName.Value using expressions.
  13. Select Textbox10 above the =[FirstName] & " " & [LastName] column cell, and in the Properties window set the Value property to Manager. This is the heading for the static column.

To enhance the appearance of the report

When you preview the report at this point, you will notice the data from the fields is displayed in the Tablix data region. We can enhance the layout of the Tablix data region by setting cell properties in the Properties Window as follows:

Cell | Property Name | Property Value
=[Region] | BackgroundColor | Gainsboro
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
 | VerticalAlign | Middle
Region | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
=[District] | BackgroundColor | LightSteelBlue
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
 | VerticalAlign | Middle
District | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
=[StoreName] | BackgroundColor | WhiteSmoke
 | BorderStyle | Solid
 | TextAlign | Center
Store | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
=[FirstName] & " " & [LastName] | BorderStyle | Solid
 | TextAlign | Center
Manager | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Export

Export
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Export

Glossary Item Box

This section contains the following walkthroughs that fall under the Export category.

Custom Web Exporting
This walkthrough demonstrates how to export your report into several popular formats like PDF, HTML, Excel, Image and Word.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Web Exporting

Custom Web Exporting
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Export > Custom Web Exporting

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides components that allow you to export your reports into several popular formats like PDF, HTML, Excel, Image, Word and XML.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Adding code to the Web Form to create the PDF, HTML, Excel, Word, XML and Image Export objects and export a report.
  • Running the project
Note: Although this walkthrough uses Page reports, you can also implement this using RDL reports.

Show To add an ActiveReport to the Visual Studio project

  1. Create a new ASP.NET Web Application project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as CustomWebExporting.
  4. Click the Add button to open a new fixed page report in the designer.
  5. In the Solution Explorer, right-click the References node and select Add Reference.
  6. In the Add Reference dialog that appears, select the following references and click OK to add them to your project.
    GrapeCity.ActiveReports.Export.Pdf
    GrapeCity.ActiveReports.Export.Html
    GrapeCity.ActiveReports.Export.Excel
    GrapeCity.ActiveReports.Export.Word
    GrapeCity.ActiveReports.Export.Image
    GrapeCity.ActiveReports.Export.Xml

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To add code to the Web Form to create the PDF Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
'Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

'Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
reportDocument.Render(pdfRenderingExtension, outputProvider)

Response.ContentType = "application/pdf"
Response.AddHeader("content-disposition", "inline;filename=MyExport.pdf")
Dim ms As New System.IO.MemoryStream()
CType(outputProvider.GetPrimaryStream().OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
reportDocument.Render(pdfRenderingExtension, outputProvider);

Response.ContentType = "application/pdf";
Response.AddHeader("content-disposition", "inline;filename=MyExport.pdf");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

Note: To use the one-touch printing option, add the following to the code above.

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
' Replace the line reportDocument.Render(pdfRenderingExtension, outputProvider) in the code above with the following

Dim setting As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
setting.PrintOnOpen = True
reportDocument.Render(pdfRenderingExtension, outputProvider,setting)
C# code. Paste INSIDE the Page Load event. Copy Code
// Replace the line reportDocument.Render(pdfRenderingExtension, outputProvider); in the code above with the following

GrapeCity.ActiveReports.Export.Pdf.Page.Settings setting = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
setting.PrintOnOpen = true;
reportDocument.Render(pdfRenderingExtension, outputProvider,setting);
Warning: You need to manually license your application in order to use PDF export.

Show To add code to the Web Form to create the HTML Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report.
Dim htmlRenderingExtension As New GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
Dim setting As New GrapeCity.ActiveReports.Export.Html.Page.Settings()
setting.Mode = GrapeCity.ActiveReports.Export.Html.Page.RenderMode.Galley
setting.MhtOutput = True

reportDocument.Render(htmlRenderingExtension, outputProvider, setting)

Response.ContentType = "message/rfc822"
Response.AddHeader("content-disposition", "inline;filename=MyExport.mht")
Dim ms As New System.IO.MemoryStream()
CType(outputProvider.GetPrimaryStream().OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension htmlRenderingExtension = new GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension();GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();GrapeCity.ActiveReports.Export.Html.Page.Settings setting = new GrapeCity.ActiveReports.Export.Html.Page.Settings();
setting.Mode = GrapeCity.ActiveReports.Export.Html.Page.RenderMode.Galley;
setting.MhtOutput = true;

reportDocument.Render(htmlRenderingExtension, outputProvider, setting);

Response.ContentType = "message/rfc822";
Response.AddHeader("content-disposition", "inline;filename=MyExport.html");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

Show To add code to the Web Form to create the Excel Export

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Provide settings for your rendering output.
Dim excelSetting As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings()
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xlsx
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = excelSetting

' Set the rendering extension and render the report.
Dim excelRenderingExtension As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
reportDocument.Render(excelRenderingExtension, outputProvider, setting.GetSettings())

Response.ContentType = "application/vnd.ms-excel"
Response.AddHeader("content-disposition", "inline;filename=MyExport.xls")
Dim ms As New System.IO.MemoryStream()
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.[End]()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings excelSetting = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings();
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xlsx;
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = excelSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension excelRenderingExtension = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
reportDocument.Render(excelRenderingExtension, outputProvider, setting.GetSettings());

Response.ContentType = "application/vnd.ms-excel";
Response.AddHeader("content-disposition", "inline;filename=MyExport.xls");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

Show To add code to the Web Form to create the Word Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.
    Note: To export your report in .Doc format, change the FileFormat property option from .Docx to .Doc format as depicted below.
    wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.Doc

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
' Provide the page report you want to render
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report
Dim wordRenderingExtension As New GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()

' Set FileFormat property to .Docx
Dim wordSetting As New GrapeCity.ActiveReports.Export.Word.Page.Settings()
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML

reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting)
Response.ContentType = "application/msword"
Response.AddHeader("content-disposition", "inline;filename=MyExport.docx")
Dim ms As New System.IO.MemoryStream()
CType(outputProvider.GetPrimaryStream().OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
// Provide the page report you want to render
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension wordRenderingExtension = new GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();

// Set the FileFormat property to .Docx
GrapeCity.ActiveReports.Export.Word.Page.Settings wordSetting = new GrapeCity.ActiveReports.Export.Word.Page.Settings();
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML;

reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting);
Response.ContentType = "application/msword";
Response.AddHeader("content-disposition", "inline;filename=MyExport.docx");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

Show To add code to the Web Form to create the Image Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report.
Dim imageRenderingExtension As New GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
Dim setting As New GrapeCity.ActiveReports.Export.Image.Page.Settings()
setting.ImageType = GrapeCity.ActiveReports.Export.Image.Page.Renderers.ImageType.JPEG
reportDocument.Render(imageRenderingExtension, outputProvider, setting)

Response.ContentType = "image/jpeg"
Response.AddHeader("content-disposition", "inline;filename=MyExport.jpg")
Dim ms As New System.IO.MemoryStream()

' Get the first page of the report
CType(outputProvider.GetSecondaryStreams()(0).OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension imageRenderingExtension = new GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
GrapeCity.ActiveReports.Export.Image.Page.Settings setting = new GrapeCity.ActiveReports.Export.Image.Page.Settings();
setting.ImageType = GrapeCity.ActiveReports.Export.Image.Page.Renderers.ImageType.JPEG;

reportDocument.Render(imageRenderingExtension, outputProvider, setting);

Response.ContentType = "image/jpeg";
Response.AddHeader("content-disposition", "inline;filename=MyExport.jpg");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
// Get the first page of the report
outputProvider.GetSecondaryStreams()[0].OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

Show To add code to the Web Form to create the XML Export object and export a report.

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report.
Dim xmlRenderingExtension As New GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
reportDocument.Render(xmlRenderingExtension, outputProvider)

Response.ContentType = "application/xml"
Response.AddHeader("content-disposition", "inline;filename=MyExport.xml")
Dim ms As New System.IO.MemoryStream()
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.[End]()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension xmlRenderingExtension = new GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
reportDocument.Render(xmlRenderingExtension, outputProvider);

Response.ContentType = "application/xml";
Response.AddHeader("content-disposition", "inline;filename=MyExport.xml");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

Show To run the project

Press F5 to run the project.

See Also

Custom Web Exporting (Std Edition)

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Preview

Preview
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview

Glossary Item Box

This section contains the following walkthroughs that fall under the Preview category.

Drilldown Reports
This walkthrough demonstrates how to create a drilldown report using the Hidden and ToggleItem properties.
Drill-Through Reports
This walkthrough demonstrates how to create a drill-through link to another report containing details about the linked item.
Parameterized Reports
This walkthrough demonstrates how to create a report with multivalue parameters and an option to select all of the data.
Reports with Bookmarks
This walkthrough demonstrates how to set up bookmarks and links in a report.
Reports with TableOfContents
This walkthrough demonstrates how to create a report that includes the Table of Contents (ToC) control and displays the document map on a report page.

See Also

Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Drilldown Reports

Drilldown Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Drilldown Reports

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough expands upon the report created in the Master Detail Reports walkthrough. If you have not created the Master Detail report (CustomerOrders.rdlx) already, please do so before continuing.

This walkthrough illustrates how to create a drilldown report using the Hidden and ToggleItem properties.

The walkthrough is split up into the following activities:

  • Opening the Master Detail Report
  • Hiding table rows and setting a toggle item
  • Viewing the report
Note: This walkthrough uses the Customer table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To open the report in Visual Studio

  1. Open the Master Detail Report project in Visual Studio.
  2. In the Visual Studio Solution Explorer, double-click CustomerOrders.rdlx.

Show To hide table rows and set a toggle item

  1. In the designer, click inside the table to display the column and row handles along the top and left sides of the table.
  2. Select the second group header row containing the static labels (Title, Quantity, Price and Total) by clicking the row handle to the left of it.
  3. Hold the CTRL key and select the Detail row containing field expressions to add to the selection.
  4. In the Properties window, expand the Visibility property and set its properties as follows.
    Property Name | Property Value
    Visibility Hidden | True
    Visibility Toggle Item | TextBox10 (the textbox containing the expression =First(Fields!LastName.Value))

Show To view the report

  • Click the preview tab to view the report at design time.
  1. Click the Preview tab of the report designer.
  2. Click the + icon next to a customer to display order details for that customer.
  3. Click the - icon to hide the details.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Drill- Through Reports

Drill- Through Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Drill- Through Reports

Glossary Item Box

Show All Show All
Hide All Hide All

The following procedures illustrate how to create a drill-through link to another report containing details about the linked item.

The walkthrough is split into the following activities:

  • Creating a main report
  • Connecting the main report to a data source and adding a dataset
  • Adding controls to the main report to contain data
  • Creating a detail report
  • Connecting the detail report to a data source
  • Adding a dataset with a parameter
  • Creating a dataset to populate the parameter values
  • Adding a report parameter
  • Adding controls to the detail report to contain data
  • Adding a drill-through link in the main report
  • Viewing the report
Note:
  • This walkthrough uses tables from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at run time.

Run-Time Layout (main report)

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout (detail report)

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create the main report

  1. Create a new Visual Studio project.
  2. From the Visual Studio Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as MainReport.rdlx.
  4. Click the Add button to open a new page report in the designer.

Show To connect the main report to a data source and add a dataset

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like MainReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.
  4. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  5. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Movie. This name appears as a child node to the data source icon in the Report Explorer.
  6. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Movie ORDER BY MovieID ASC
  7. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  8. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the main report

  1. In the Visual Studio toolbox, go to the ActiveReports 13 Page Report tab and drag a TextBox control onto the design surface.
  2. Select the TextBox control and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0.75in, 0.125in
    Font | Normal, Arial, 18pt, Bold
    Size | 5in, 0.5in
    TextAlign | Center
    Value | MOVIES INFORMATION
  3. From the Visual Studio toolbox, drag a Table data region and place it on the design surface.
  4. Select the Table and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0in, 1.125in
    FixedSize (only for Page reports) | 6.5in, 7in
    BorderStyle | Solid
    RepeatHeaderOnNewPage | True
    Size | 6.5in, 0.75in
  5. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.

  6. Click the adorner to show a list of available fields from the DataSet and add the following fields to the cells of the table details row.

    Cell | Field
    Left Cell | MovieID
    Middle Cell | Title
    Right Cell | YearReleased
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.
    Tip: You can also directly drag fields from the Report Explorer onto the textbox cells of the Table data region.
  7. Select the following table rows and go to the Properties window to set their properties.

    Show Table Header

    Property Name | Property Value
    BorderStyle | Solid
    Font | Normal, Arial, 12pt, Bold
    TextAlign | Center

    Show Table Details

    Property Name | Property Value
    BorderStyle | Solid
    Font | Normal, Arial, 10pt, Bold
    TextAlign | Center

Show To create the detail report

  1. From the Visual Studio Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as MovieDetails.rdlx.
  3. Click the Add button to open a new page report in the designer.

Show To connect the detail report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset to populate the parameter values

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieTitles. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT MovieID, Title FROM Movie ORDER BY Title ASC
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add a parameter to the report

  1. In the Report Explorer, select the Parameters node.
  2. Right-click the node and select Add Parameter to open the Report - Parameters dialog.
  3. Set properties in the following fields below the parameters list.

    In the General tab:

    • Name: MovieID
    • DataType: Integer

    In the Available Values tab select From query:

    • DataSet: MovieTitles
    • Value: MovieID
    • Label: Title
  4. Click OK to close the dialog and add the parameter to the collection. This parameter appears under the Parameters node in the Report Explorer.

Show To add a dataset with a parameter

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieInfo. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page under Parameter Name enter MovieID.
  4. Under Value enter =Parameters!MovieID.Value
  5. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    Select * from MovieCastInformation
  6. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  7. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.
  8. In an Page report, set the Dataset name in the FixedPage dialog > General tab to MovieInfo. For more information, see Fixed Page Dialog.
Caution: In an Page report, you may get an error if the Dataset name for the FixedPage is not be specified explicitly.

Show To create a layout for the detail report

  1. Click the gray area below the design surface to select the report.
  2. Go to the Properties window, expand the PageSize property and set the Width to 8.5in and Height to 3in.
  3. From the toolbox, drag a List control onto the design surface and in the Properties window, set the following properties:
    Property Name | Property Value
    DataSetName | MovieInfo
    Location | 0in, 0in
    Name | MovieList
    Size | 6.5in, 1in
    FixedSize (only for Page reports) | 6.5in, 1in
  4. With the List control selected, at the bottom of the Properties Window, select the Property dialog command.
  5. In the List dialog that appears, on the Detail Grouping page, set the Group on: Expression to =Fields!MovieID.Value.
  6. Click OK to close the dialog.
  7. From the Report Explorer, go to the MovieInfo dataset and drag the following five fields onto the MovieList data region. In the properties window, set their properties as indicated.

    Show Title

    Property Name | Property Value
    Name | MovieTitle
    Location | 0in, 0in
    Size | 6.5in, 0.375in
    TextAlign | Center
    FontSize | 14pt

    Show YearReleased

    Property Name | Property Value
    Name | YearReleased
    Location | 1in, 0.375in
    Size | 0.75in, 0.25in
    TextAlign | Left

    Show MPAA

    Property Name | Property Value
    Name | MPAA
    Location | 6in, 0.375in
    Size | 0.5in, 0.25in

    Show UserRating

    Property Name | Property Value
    Name | UserRating
    Location | 1in, 0.625in
    Size | 0.25in, 0.25in
    TextAlign | Left

    Show Length

    Property Name | Property Value
    Name | Length
    Location | 4.75in, 0.625in
    Size | 1.75in, 0.25in
    TextAlign | Left
    Value | =Fields!Length.Value & " minutes"
    Note: When you drag and drop fields from a dataset in the Report Explorer onto the design surface, these fields are automatically converted to Textbox controls that you can modify by setting the control properties in the Properties Window.
  8. From the Report Explorer, drag four TextBox controls onto the MovieList data region and in the properties window, set their properties as indicated.

    Show TextBox1

    Property Name | Property Value
    Location | 0in, 0.375in
    Size | 1in, 0.25in
    Name | ReleaseLabel
    Value | Released in:
    FontWeight | Bold

    Show TextBox2

    Property Name | Property Value
    Location | 3.625in, 0.375in
    Size | 1.875in, 0.25in
    Name | MPAALabel
    Value | The MPAA rated this film:
    FontWeight | Bold

    Show TextBox3

    Property Name | Property Value
    Location | 0in, 0.625in
    Size | 1in, 0.25in
    Name | UserRatingLabel
    Value | User rating:
    FontWeight | Bold

    Show TextBox4

    Property Name | Property Value
    Location | 4.125in, 0.625in
    Size | 0.625in, 0.25in
    Name | LengthLabel
    Value | Length:
    FontWeight | Bold

Show To add a drill-through link to the main report

  1. Switch to the Designer with the MainReport.rdlx.
  2. On the design surface, select the cell containing the Title field inside the table details row and at the bottom of the Properties Window, click the Property dialog command.
  3. In the Textbox dialog that appears, go to the Navigation page.
  4. Under Action, select Jump to report and set the report name MovieDetails.rdlx.
  5. Under Jump to report set the Name of the parameter to MovieID.
    Caution: The parameter name must exactly match the parameter in the target report.
  6. Set the Value to =Fields!MovieID.Value.
  7. Click OK to close the dialog.

Show To view the report

Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Parameterized Reports

Parameterized Reports
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Parameterized Reports

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a parameterized report with ActiveReports and provide the ability to select multiple values for those who want to view data for several items.

This walkthrough illustrates how to create a report with multi-value parameters and an option to select all of the data.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a Dataset with a parameter
  • Creating a Dataset to populate the parameter values
  • Adding a Report Parameter
  • Adding controls to the report to contain data
  • Viewing the report
Note:
  • This walkthrough uses the Products table from the Nwind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
  • Although this walkthrough uses RDL report, you can also implement this using Page report.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 RDL Report and in the Name field, rename the file as Product Details.
  4. Click the Add to open a new rdl report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Nwind database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset to populate the parameter values

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as DataSet1. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    select distinct productName from Products
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. You see the data set, DataSet1, and the field, productName in the Report Explorer.

Show To add a parameter to the report

  1. In the Report Explorer, select the Parameters node.
  2. Right-click the node and select Add Parameter to open the Report - Parameters dialog.
  3. In the dialog box that appears, click the Add(+) button to add a new parameter in the list.
  4. Set properties in the following fields below the parameters list.

    In the General tab:

    • Name: ReportParameter1
    • DataType: String
    • Text for prompting users for a value: Select the product name.
    • Select the check box next to Multivalue to allow users to select more than one product name from the list.
    • Enter Value for 'Select All': 1

    In the Available Values tab, select From query:

    • DataSet: DataSet1
    • Value: productName
    • Label: productName
      Note: The name of the parameter you enter must exactly match the name of the parameter in the linked report, and it is case sensitive. You can pass a value from the current report to the parameter in the Value column of the list. If a value is not supplied for an expected parameter in the linked report, or if the parameter names do not match, the linked report will not run.
  5. Click OK to close the dialog and add the parameter to the collection. The ReportParameter1 parameter appears under the Parameters node in the Report Explorer.

Show To add a dataset with a parameter

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as DataSet2. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page under Parameter Name enter ReportParameter1.
  4. Under Value enter =Parameters!ReportParameter1.Value.
  5. On the Parameters page under Parameter Name enter Parameter1.
  6. Under Value enter =Parameters!ReportParameter1.Value.
  7. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    select * from products where ProductName in (?) OR '1' in (?)
  8. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  9. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. From the toolbox, drag a Table control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0.5in, 0.25in
    DataSetName | DataSet2
    Size | 4.8in, 0.75in
  2. In the Report Explorer, from the DataSet2 dataset drag the following fields into the detail row of the table and set their properties as in the following table.
    Field | Column | Width
    ProductName | TableColumn1 | 2.37in
    UnitPrice | TableColumn2 | 0.67in
    UnitsOnOrder | TableColumn3 | 1.62in
  3. Static labels with the field names are automatically created in the table header row. To improve the appearance of the report, select the table header row, and set the BackgroundColor to DeepSkyBlue.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

How To
Add Parameters

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with Bookmarks

Reports with Bookmarks
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Reports with Bookmarks

Glossary Item Box

Show All Show All
Hide All Hide All

You can assign a bookmark ID to any report control and link a text box or image to it to allow users to easily navigate between items in the finished report. The bookmark link works like a hyperlink, except that clicking a bookmark link jumps to another page or area of the report instead of to a Web page.

This walkthrough explains the steps involved in setting up bookmarks and links.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to an XML data source
  • Adding a Dataset
  • Adding controls to the report to contain data
  • Assigning a bookmark ID to a report control
  • Adding a bookmark link to a report control
  • Viewing the report
Note:
  • This walkthrough uses the Factbook sample database. By default, in ActiveReports, the Factbook.rdsx file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Factbook.rdsx.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.
Note: If you have already created the report outlined in the Reports with XML Data walkthrough, you can open that report and go directly to the Assigning a Bookmark ID section of this walkthrough.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to a Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as ExchangeRates.rdlx.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Factbook.
  3. On this page, check the Shared Reference checkbox.
  4. Click the Browse button and select Factbook.rdsx, which is located in [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as ExchangeRates.
  3. On the Query page, enter the following XML path into the Query text box to access data for every country except "World":
    //country [@name != 'World']
  4. On the Fields page, enter the values in the table below to create fields for your report. Values for XML data fields must be valid XPath expressions.
    Field Name | Type | Value
    Names | Database Field | @name
    Currencies | Database Field | ./ExchangeRates/Currency
    2004 | Database Field | ./ExchangeRates/VsUSD2004
    2003 | Database Field | ./ExchangeRates/VsUSD2003
    2002 | Database Field | ./ExchangeRates/VsUSD2002
    2001 | Database Field | ./ExchangeRates/VsUSD2001
    2000 | Database Field | ./ExchangeRates/VsUSD2000
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To add controls to the report

  1. From the toolbox, drag a List data region onto the design surface of the report and go to the Properties window to set the DataSetName property to ExchangeRates, Location property to 0in, 0in and Size property to 6.5in, 3in.
  2. From the Report Explorer, drag the Names field onto the list, center it at the top and go to the Properties window to set the FontSize property to 14pt and the BorderStyle property to Solid.
  3. From the Report Explorer, drag the following fields onto the list with properties set as described in the table below.
    Field Name Property Name
    Currencies Location: 1.125in, 0.5in
    Size: 2.25in, 0.25in
    2004 Location: 4in, 0.875in
    Size: 1in, 0.25in
    2003 Location: 4in, 1.25in
    Size: 1in, 0.25in
    2002 Location: 4in, 1.625in
    Size: 1in, 0.25in
    2001 Location: 4in, 2in
    Size: 1in, 0.25in
    2000 Location: 4in, 2.375in
    Size: 1in, 0.25in
    Note: You will notice that the expressions created for these fields are different than usual. Because Visual Basic syntax does not allow an identifier that begins with a number, any numeric field names must be treated as strings in expressions.
  4. From the toolbox, drag a TextBox onto the list and go to the Properties window to set the properties as described in the table below to combine static text with a field value.
    Property Name | Property Value
    Location | 0.125in, 0.875in
    Size | 3.125in, 0.25in
    Value | ="Value of " & Fields!Currency.Value & " versus US$ for year:"
    Font | Normal, Arial, 10pt, Bold
    TextAlign | Right
  5. From the toolbox, drag TextBox controls onto the list and go to the Properties window to set the properties as described in the table below to create static labels.

    Show TextBox1

    Property Name | Property Value
    Location | 0.125in, 0.5in
    Size | 0.75in, 0.25in
    FontWeight | Bold
    Value | Currency:

    Show TextBox2

    Property Name | Property Value
    Location | 3.375in, 0.875in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2004:

    Show TextBox3

    Property Name | Property Value
    Location | 3.375in, 1.25in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2003:

    Show TextBox4

    Property Name | Property Value
    Location | 3.375in, 1.625in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2002:

    Show TextBox5

    Property Name | Property Value
    Location | 3.375in, 2in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2001:

    Show TextBox6

    Property Name | Property Value
    Location | 3.375in, 2.375in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2000:

Show To assign a bookmark ID to the report control

A bookmark ID marks any report control as something to which a bookmark link can navigate.

  1. On the designer surface, select the Names textbox at the top of the list and at the bottom of the Properties Window, select the Property dialog command.
  2. In the Textbox dialog that appears, go to the Navigation page.
  3. On the Navigation page, enter Names in the Bookmark ID field.
    Note: Every bookmark ID in a report must be a unique string. If you have duplicates, a link to it will navigate only to the first one it finds.
  4. Click OK to close the dialog.

Show To add a bookmark link to the report control

A bookmark link is like a hyperlink that navigates to a report control marked with a bookmark ID instead of to a URL. We will add a text box below the list we already created to display at the bottom of the report. This text box will have a bookmark link to the bookmark ID we created in the last procedure.

  1. From the toolbox, drag a text box onto the report below the list and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Value | Back to Top
    Location | 0in, 3in
    Size | 6.5in, .5in
    TextAlign | Center
  2. At the bottom of the Properties Window, select the Property dialog command.
  3. In the Textbox dialog that appears, go to the Navigation page.
  4. On the Navigation page, select the Jump to Bookmark radio button and enter the bookmark ID (Names) created in the procedure above.
  5. Click OK to close the dialog.

Show To view the report

Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with TableOfContents

Reports with TableOfContents
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Reports with TableOfContents

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough illustrates how to create a report that includes the Table of Contents (ToC) control and displays the document map on a report page.

The TableOfContents control allows you to quickly navigate to desired data inside a report. You can use the TableOfContents control to embed the list of contents in the report body for printing and rendering, unlike the Document Map that is only available in the Viewers and cannot be rendered or printed.

  • To add an ActiveReports to the Visual Studio project
  • To connect the report to a data source
  • To add a dataset
  • To create a layout for the report
  • To configure the appearance of Table of Contents
  • To view the report

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To add an ActiveReports to the Visual Studio project

  1. Create a new Visual Studio Windows Forms Application project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 RDL Report and in the Name field, rename the file as ReportsWithToC.rdlx.
  4. Click the Add button to open a new RDL report.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

This walkthrough uses the Movies table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieCatalog. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Genre.GenreName, Movie.Title, Movie.YearReleased, Movie.UserRating, Movie.Country FROM Genre INNER JOIN (Movie INNER JOIN MovieGenres ON Movie.MovieID = MovieGenres.MovieID) ON Genre.GenreID = MovieGenres.GenreID ORDER BY YearReleased ASC
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag the List control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    DataSetName | MovieCatalog
    Location | 0.25in, 1.875in
    Size | 6in, 4in
    PageBreakAtStart

    True

    Note: Applicable for RDL reports only.

  2. With the List data region selected, under the Properties window, click the Property dialog link to open the List dialog
  3. Go to the Detail Grouping page and on the General tab, under Group on, set the Expression field to =Fields!GenreName.Value.
  4. Click OK to close the dialog
  5. In the Report Explorer, from the MovieCatalog dataset, drag and drop the GenreName field inside the List data region and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0.25in, 0.375in
    Font | Normal, Arial, 12pt, Bold
    TextAlign | Center
    Size | 5.625in, 0.25in
    Label =Fields!GenreName.Value
    Note: Setting the control's Label property adds an entry of the control in the document map.
  6. From the toolbox, drag and drop the Table data region inside the List data region and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0.125in, 1in
    Size | 6in, 0.75in
    DataSetName | MovieCatalog
    BorderStyle | Solid
    RepeatHeaderOnNewPage | True
  7. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.

  8. Click the adorner to show a list of available fields from the MovieCatalog dataset and add the following fields to the cells of the table details row.

    Cell | Field
    Left Cell | Title
    Middle Cell | Country
    Right Cell | UserRating
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.
    Tip: You can also directly drag fields from the Report Explorer onto the textbox cells of the Table data region.
  9. Select the table header row using the row handle to the left and in the Properties Window set the following properties.
    Property Name | Property Value
    Font > FontWeight | Bold
    TextAlign | Left
    BackgroundColor | Silver
    BoderStyle | Solid
  10. Select the table detail row using the row handle to the left, and in the Properties Window set the following properties.
    Property Name | Property Value
    TextAlign | Left
    BorderStyle | Solid
  11. Right-click the table detail row using the row handle to the left, and select Insert Group...
  12. In the Table - Groups dialog that appears, on the General tab, under Group on, set the Expression field to =Fields!YearReleased.Value.
  13. Click OK to close the dialog.
  14. Select the textboxes inside the table group row using the CTRL key and left mouse button, right-click the selection and select Merge Cells.
  15. Select the merged cell and in the Properties window, set the following properties.
    Property Name | Property Value
    Font | Normal, Arial, 10pt, Bold
    HeadingLevel Heading 2
    Note: Setting the control's HeadingLevel property adds an entry of the control in the document map.
    TextAlign | Center
    Value | ="Movies Released in " & Fields !YearReleased.Value
  16. From the Visual Studio toolbox, drag a TableOfContents control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0.25in, 0.5in
    Size | 6in, 0.875in
    BorderStyle | Solid

To configure the appearance of Table of Contents

  1. With the TableOfContents control selected, select the Levels (Collection) property and then click the ellipsis button that appears.
  2. In the LevelDesigner Collection Editor dialog that appears, under Members, use the Add button to add Level2 to the TableOfContents.
  3. Under Members, select Level1 and click the Property Pages button above the LevelDesigner Collection Editor properties grid.
  4. In the Level Properties dialog that appears, set the following properties.

    Show Properties

    Property Name | Property Value
    Font > Size | 14
    Font > Weight | Bold
    Color | DarkBlue
    Padding > Left | 10pt
    Padding > Top | 10pt
    Padding > Right | 10pt
    Padding > Bottom | 10pt
    Fill character .
  5. In the LevelDesigner Collection Editor, select the Level2 entry under Members and click the Property Pages button above the LevelDesigner Collection Editor Properties grid.
  6. In the Level Properties dialog that appears, set the following properties.

    Show Properties

    Property Name | Property Value
    Font > Weight | Bold
    Padding > Left | 20pt
    Padding > Top | 10pt
    Padding > Right | 0pt
    Padding > Bottom | 0pt
    DisplayPageNumber | False
  7. Click OK to close the LevelDesigner Collection Editor dialog.
  8. In the Report Explorer, select the Report node and in the Properties window set the following properties:

    Show Properties

    Property Name | Property Value
    DocumentMap > Source | Labels and Headings
    DocumentMap > NumberingStyle | 1, 2, 3, 4, 5

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Table of Contents

How To
Add TableOfContents
Add Items to the Document Map

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Advanced

Advanced
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced

Glossary Item Box

This section contains the following walkthroughs that fall under the Advanced category.

Reports with Custom Code
This walkthrough demonstrates how to create a simple report with custom code.
Custom Resource Locator
This walkthrough is based on the Custom Resource Locator sample and illustrates how to load pictures from the user's My Pictures directory.
Custom Data Provider
This walkthrough demonstrates how to create a solution with projects that create a custom data provider and demonstrate how it pulls data from a comma separated values (CSV) file.

See Also

Page Report/RDL Report Walkthroughs

Concepts
Interactive Features

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Reports with Custom Code

Reports with Custom Code
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced > Reports with Custom Code

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough illustrates how to create a simple report with custom code.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Embedding code in a report and referencing it in a field expression
  • Viewing the report
Note:
  • This walkthrough uses the Store table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as CustomCode.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

Show To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Districts. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query Copy Code
    SELECT Store.StoreName, Address.City, Address.Region AS StateProvince, Address.Country, Districts.District
FROM Address INNER JOIN (Districts INNER JOIN Store ON Districts.DistrictID = Store.DistrictID) ON Address.AddressID = Store.Address WHERE NOT Districts.DistrictID = 0 ORDER BY Districts.District
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

Show To create a layout for the report

  1. From the toolbox, drag the TextBox control onto the design surface and go to the Properties window to set the following properties:
    Property Name | Property Value
    Location | 0in, 0in
    Size | 6.5in, 0.5in
    TextAlign | Center
    FontSize | 14pt
    Value | District Locations
  2. From the toolbox, drag a Table data region onto the design surface and go to the Properties window to set the DataSetName property to Districts.
  3. Set the following properties for the table:
    Property Name | Property Value
    Location | 0in, 0.5in
    FixedSize 6in, 7in
    Note: FixedSize property is set only in Page report.
  4. Click inside the table to display the column handles at the top and in the Properties window, set the Width property of following columns:
    Column | Width
    TableColumn1 | 3in
    TableColumn2 | 1.5in
    TableColumn3 | 1.5in
  5. Click inside the table to display the row handles along the left of the table and right-click any of the row handles to select Insert Group.
  6. In the Table - Groups dialog that appears, under Group on, select the following expression: =Fields!District.Value
  7. On the same dialog set the Name to District and click OK to close the dialog. The header and footer rows for the new group appear.
  8. In the Report Explorer from the Districts dataset, drag the District field into the second column of the group header row of the table. This automatically places an expression in the group header row and simultaneously places a static label in the table header row.
  9. In the first column of the group header row, just to the left of the District field, in the Properties window set the Value property to District Name:.
  10. Click the row handle to the left of the group header row to select the entire row and in the Properties window, set the properties as follows:
    Property Name | Property Value
    FontSize | 12pt
    FontWeight | Bold
    BackgroundColor | MediumPurple
    Color | White
  11. Right-click any row handle to the left of the table and select Table Header to remove the table header.
  12. Right-click any row handle to the left of the table and select Table Footer to remove the table footer.
  13. In the Report Explorer, drag the following fields from the Districts dataset onto the detail row of the table as follows.
    Field | Column
    StoreName | TableColumn1
    City | TableColumn2
    StateProvince | TableColumn3
  14. Remove the static label State Province from the group header for the third column.
  15. Right-click the row handle for the group header row and select Insert Row Below to add a row for static labels that will appear once for each group.
  16. In the new row, enter the following values for static label in table columns.

    Show TableColumn1

    Property Name | Property Value
    Value | Store Name
    FontWeight | Bold

    Show TableColumn2

    Property Name | Property Value
    Value | City
    FontWeight | Bold

    Show TableColumn3

    Property Name | Property Value
    Value | =iif(Fields!Country.Value="USA", "State", "Province")
    FontWeight | Bold
    Note: The expression in the third column displays the label "State" when the country is USA, and displays "Province" when it is not.

Show To embed code in a report and reference it in a field expression

This custom code creates a URL to Yahoo!® Maps for each city in the report.

  1. On the Script tab of the report, enter the following code to create a URL.
    Visual Basic.NET code. Add to the Script tab. Copy Code
    Public Function MapLink(ByVal Country, ByVal City, ByVal StateProvince) As String
        Dim Link As String
        Dim _Country As String = Country.ToString()
        Dim _City As String = City.ToString()
        Dim _StateProvince As String = StateProvince.ToString()

        Select Case _Country
                Case "USA"
                  Link = "http://maps.yahoo.com/maps_result?addr=&csz=" & _City & "%2C+" & _StateProvince & "&country=us&new=1&name=&qty="
                Case "Canada"
                  Link = "http:file://ca.maps.yahoo.com/maps_result?csz=%2C+" & _StateProvince & "&country=ca"
                Case Else
                  Link = ""
        End Select

        Return Link
End Function
    Note: Custom code is helpful if you intend to reuse code throughout the report or if code is too complex to use in an expression. Code must be instance based and written in Visual Basic.NET. You can include multiple methods, but if you want to use classes or other .NET languages, create a custom assembly. See Using Script in a Page Report for further details.

Show To reference embedded code in a field expression

  1. On the Designer tab of the report, click the detail cell in the second table column (containing the expression =Fields!City.Value) to select it and under the Properties window, click the Property dialog link. This is a command to open the respective control's dialog. See Properties Window for more on how to access commands. .
  2. In the Textbox - General dialog that appears, go to the Navigation page.
  3. Select the radio button next to Jump to URL, and enter the following expression in the combo box below it. = Code.MapLink(Fields!Country.Value, Fields!City.Value, Fields!StateProvince.Value)
  4. Click OK to close the dialog and use the code to create a hyperlink for the field.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Using Script

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Resource Locator

Custom Resource Locator
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced > Custom Resource Locator

Glossary Item Box

Show All Show All
Hide All Hide All

Page reports can get resources from your file system using file paths, but sometimes resources are preserved in very specific sources, such as a database. With page reports, you can create a custom resource locator to read any resources that might be required by your reports from any location. This walkthrough is based on the Custom Resource Locator sample and illustrates how to load pictures from the user's My Pictures directory.

This walkthrough is split into the following procedures:

  • Adding an ActiveReports to the Visual Studio project
  • Creating a layout for the report
  • Adding the new MyPicturesLocator class
  • Creating the PreviewForm that contains the Viewer control to view the report.
Note: Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at run time.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

To add an ActiveReports to the Visual Studio project

  1. Create a new Visual Studio Windows Forms Application project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Page Report and in the Name field, rename the file as DemoReport.rdlx.
  4. Click the Add button to open a new fixed page report.

To create a layout for the report

  1. From the toolbox, drag an Image control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Name | Image1
    Location | 0.1in, 0.1in
    Size | 2.8in, 2.8in
    Value | MyPictures:Penguins.jpg
  2. From the toolbox, drag another Image control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Name | Image2
    Location | 3.1in, 0.1in
    Size | 2.8in, 2.8in
    Value | MyPictures:Desert.jpg
  3. In the Solution Explorer, select DemoReport.rdlx and in the Properties window, set Build Action to Embedded Resource.

To add the new MyPicturesLocator class

  1. In the Solution Explorer window, right-click on your project name and select Add and then New Item.
  2. In the Add New Item dialog that appears, select Class.
  3. Change the name of the class to MyPicturesLocator and click the Add button.
  4. Replace the existing code with the following code to the new class.

    Show To write the code in Visual Basic.NET

    VB code. Paste on TOP Copy Code
    Imports System
Imports System.Drawing
Imports GrapeCity.ActiveReports.Extensibility
Imports System.Globalization
Imports System.IO
Imports System.Runtime.InteropServices
    VB code. Paste INSIDE the class Copy Code
     Inherits ResourceLocator

    Private Const UriSchemeMyImages As String = "MyPictures:"

    ' Obtain and return the resource.
    Public Overrides Function GetResource(resourceInfo As ResourceInfo) As Resource
        Dim name As String = resourceInfo.Name
        If name Is Nothing OrElse name.Length = 0 Then
            Throw New ArgumentException("The name of resource to be obtained should be non-empty string.", "name")
        End If
        Dim uri As New Uri(name)
        Dim stream As Stream = GetPictureFromSpecialFolder(name)
        If stream Is Nothing Then
            stream = New MemoryStream()
        End If
        Return New Resource(stream, uri)
    End Function

    ' Returns the specified image from Public Pictures folder.
    Private Shared Function GetPictureFromSpecialFolder(path As String) As Stream
        Dim startPathPos As Integer = UriSchemeMyImages.Length
        If startPathPos >= path.Length Then
            Return Nothing
        End If
        Dim pictureName As String = path.Substring(startPathPos)
        Dim myPicturesPath As String = Environment.GetEnvironmentVariable("public") & "\Pictures"
        If Not myPicturesPath.EndsWith("\") Then
            myPicturesPath += "\"
        End If
        Dim picturePath As String = System.IO.Path.Combine(myPicturesPath, pictureName)
        If Not File.Exists(picturePath) Then
            Return Nothing
        End If
        Dim stream As New MemoryStream()
        Try
            Dim picture As Image = Image.FromFile(picturePath)
            picture.Save(stream, picture.RawFormat)
            stream.Position = 0
        Catch generatedExceptionName As OutOfMemoryException
            ' The file is not valid image, or GDI+ doesn't support such images.
            Return Nothing
        Catch generatedExceptionName As ExternalException
            Return Nothing
    End Try
    Return stream
End Function

    Show To write the code in C#

    C# code. Paste on TOP Copy Code
    using System;
using System.Drawing;
using System.Globalization;
using System.IO;
using System.Runtime.InteropServices;
using System.Windows.Forms;
using GrapeCity.ActiveReports.Extensibility;
using your_project_name.Properties;
    C# code. Paste BELOW the Using statements Copy Code
    namespace your_project_name
{
    // Look for the resources in My Pictures folder.
    internal sealed class MyPicturesLocator : ResourceLocator
    {
        private const string UriSchemeMyImages = "MyPictures:";
        // Obtain and return the resource.
        public override Resource GetResource(ResourceInfo resourceInfo)
        {
            string name = resourceInfo.Name;
            if (name == null || name.Length == 0)
            {
                throw new ArgumentException("The name of resource to be obtained should be non-empty string.", "name");
            }
            Uri uri = new Uri(name);
            Stream stream = GetPictureFromSpecialFolder(name);
            if (stream == null)
            {
               stream = new MemoryStream();
            }
            return new Resource(stream, uri);
        }
        // Returns the specified image from Public Pictures folder.
        private static Stream GetPictureFromSpecialFolder(string path)
        {
            int startPathPos = UriSchemeMyImages.Length;
            if (startPathPos >= path.ToString().Length)
            {
                return null;
            }
            string pictureName = path.ToString().Substring(startPathPos);
            string myPicturesPath = Environment.GetEnvironmentVariable("public") + \\Pictures;
            if (!myPicturesPath.EndsWith("\\")) myPicturesPath += "\\";
            string picturePath = Path.Combine(myPicturesPath, pictureName);
                        if (!File.Exists(picturePath)) return null;
            MemoryStream stream = new MemoryStream();
            try
            {
                Image picture = Image.FromFile(picturePath);
                picture.Save(stream, picture.RawFormat);
                stream.Position = 0;
            }
            catch (OutOfMemoryException) // The file is not valid image, or GDI+ doesn't support such images.
            {
                return null;
            }
            catch (ExternalException)
            {
                return null;
            }
            return stream;
        }
    }
}

To create the PreviewForm

  1. In the Solution Explorer, select the Form1 in the Design view and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | PreviewForm
    Text | Preview Form
    Size | 1015, 770
  2. From the Visual Studio toolbox, drag the Viewer control onto the PreviewForm and in the Properties window, set the following properties.
    Property Name | Property Value
    Name | reportPreview1
    Dock | Fill
  3. Double-click the PreviewForm to create an instance for the Load event and add the following code.

    Show To write the code in Visual Basic.NET

    VB code. Paste BELOW the Import statements Copy Code
    Imports GrapeCity.ActiveReports.Document
Imports System.IO
Imports GrapeCity.ActiveReports
    VB code. Paste INSIDE the Load event Copy Code
    Dim reportData As Stream = [GetType]().Assembly.GetManifestResourceStream("your_project_name.DemoReport.rdlx")
reportData.Position = 0
Dim reader As New StreamReader(reportData)
Dim def As New PageReport(reader)
def.ResourceLocator = New MyPicturesLocator()
Dim runtime As New PageDocument(def)
reportPreview1.ReportViewer.LoadDocument(runtime)

    Show To write the code in C#

    C# code. Paste BELOW the Using statements Copy Code
    using GrapeCity.ActiveReports.Document;
using System.IO;
using GrapeCity.ActiveReports;
    C# code. Paste INSIDE the Load event Copy Code
    string myPicturesPath = Environment.GetFolderPath(Environment.SpecialFolder.MyPictures);
Stream reportData = GetType().Assembly.GetManifestResourceStream("your_project_name.DemoReport.rdlx");
reportData.Position = 0;
StreamReader reader = new StreamReader(reportData);
PageReport def = new PageReport(reader);
def.ResourceLocator = new MyPicturesLocator();
PageDocument runtime = new PageDocument(def);
reportPreview1.ReportViewer.LoadDocument(runtime);
  4. Press F5 to run the project.

See Also

Custom Resource Locator

Page Report Walkthroughs
Drill- Through Reports

Sample ReadMe Files
Custom Resource Locator

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Data Provider

Custom Data Provider
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced > Custom Data Provider

Glossary Item Box

Show All Show All
Hide All Hide All

A custom data provider allows you to use non-traditional data sources in your page reports, both at run time and at design time. This walkthrough illustrates how to create a solution with projects that create a custom data provider and demonstrate how it pulls data from a comma separated values (CSV) file.

This walkthrough is split into the following activities:

  • Creating a Designer project to demonstrate the custom data provider
  • Configuring the project to use a custom data provider
  • Adding a report to show the data
  • Adding a second project to contain the custom data provider
  • Adding a button to the query editor

When you complete this walkthrough, you will have a designer pre-loaded with a report that pulls data from a CSV file and looks like the following.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create a Designer project to demonstrate the custom data provider

  1. In Visual Studio, create a Windows Forms project and name it CustomDataProviderDemo.
  2. From the Visual Studio toolbox ActiveReports 13 tab, drag a ReportExplorer and drop it onto the default Windows form, resizing the form to a comfortable working area.
  3. In the Properties window, set the Dock property of the ReportExplorer control to Left.
  4. From the toolbox Common Controls tab, drag a RichTextBox control onto the form and set the Dock property to Top.
  5. Add the following text to the Text property. (Drop down the box to ensure that all of the lines of text are added.)
    Text. Paste in the Text property of the RichTextBox. Copy Code
    1. In the Report Explorer, right-click the Data Sources node and select Add Data Source.
2. In the Report Data Source dialog that appears, on the General tab, drop down the Type box, select CSV Data Provider, and click OK.
3. In the Report Explorer, right-click DataSource1 and select Add Data Set.
4. In the dialog that appears, select the Query page.
5. Drop down the Query String box to display the custom query editor.
6. Click the Select CSV File button and open the Categories.csv file in this project.
7. Click OK to save the changes and close the dialog.
8. Click Preview to see the report with data from the csv file.
  6. From the toolbox ActiveReports 13 tab, drag a Designer control and drop it on the empty part of the form.
  7. Set the Dock property to Fill, then right-click the Designer control on the form and select Bring to front.
  8. Select the ReportExplorer control and in the Properties window, drop down the ReportDesigner property and select Designer1.
  9. Double-click on the form's title bar to create a form Load event, and add code like the following above the class.
    Visual Basic code. Paste above the class. Copy Code
    Imports System.Xml
Imports System.IO
Imports GrapeCity.ActiveReports.Design
    C# code. Paste above the class. Copy Code
    using System.Xml;
using System.IO;
using GrapeCity.ActiveReports.Design;
  10. Add the following code to the form Load event.
    Visual Basic code. Paste inside the form Load event. Copy Code
    Using reportStream = File.OpenRead("DemoReport.rdlx")
        Using reader = XmlReader.Create(reportStream)
                Designer1.LoadReport(reader, DesignerReportType.Page)
        End Using
End Using
    C# code. Paste inside the form Load event. Copy Code
    using (var reportStream = File.OpenRead("DemoReport.rdlx"))
 {
     using (var reader = XmlReader.Create(reportStream))
      {
         designer1.LoadReport(reader, DesignerReportType.Page);
      }
 }

Show To configure the project to use a custom data provider

  1. In the Solution Explorer, right-click the project and select Add, then New Item.
  2. In the dialog that appears, select Text File, name it GrapeCity.ActiveReports.config, and click Add.
  3. In the Solution Explorer, select the new file and in the Properties window, set its Copy to Output Directory property to Copy always.
  4. Paste the following text into the file and save it. (You can safely ignore the warning that the 'Configuration' element is not declared.)
    Paste into the config file. Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Configuration>
  <Extensions>
    <Data>
      <Extension Name="CSV" DisplayName="CSV Data Provider"
        Type="CustomDataProvider.CsvDataProvider.CsvDataProviderFactory,
          CustomDataProvider"
          CommandTextEditorType="CustomDataProvider.CSVDataProvider.QueryEditor,
        CustomDataProvider"/>
    </Data>
     </Extensions>
</Configuration>
  5. In the Solution Explorer, right-click the project and select Add, then New Item.
  6. In the dialog that appears, select Text File, name it Categories.csv, and click Add.
  7. In the Solution Explorer, click to select the file, and in the Properties window, change the Copy to Output Directory property to Copy always.
  8. Paste the following text into the file and save it.
    Paste into the text file. Copy Code
    EmployeeID(int32),LastName,FirstName,Role,City
1,James,Yolanda,Owner,Columbus
7,Reed,Marvin,Manager,Newton
9,Figg,Murray,Cashier,Columbus
12,Snead,Lance,Store Keeper,Columbus
15,Halm,Jeffry,Store Keeper,Columbus
17,Hames,Alma,Store Keeper,Oak Bay
18,Nicki,Aubrey,Store Keeper,Columbus
24,Cliett,Vikki,Store Keeper,Newton

Show To add a report to show the data from the custom data provider

  1. In the Solution Explorer, right-click the project and select Add, then New Item.
  2. In the dialog that appears, select ActiveReports 13 RDL Report, name it DemoReport, and click Add.
  3. In the Solution Explorer, click to select the report, and in the Properties window, change the Copy to Output Directory property to Copy always.
  4. From the ActiveReports 13 RDL Report Toolbox, drag a Table report control onto the report.
    Note: In case you are still working on Page report layout, set the FixedSize property of the Table control to display all data on one page.
  5. Click inside the table to reveal the table adorners, then right-click the table adorner to the left of the footer row and select Delete Rows. The footer row is removed from the table.
  6. In the Report Explorer, select each of the textboxes in turn and set the properties as in the following table. (If you do not see the Report Explorer, from the View menu, select Other Windows, then Report Explorer 13.)
    TextBox Name | Value Property | BackgroundColor Property
    TextBox1 | Name | MediumSlateBlue
    TextBox2 | Role | MediumSlateBlue
    TextBox3 | City | MediumSlateBlue
    TextBox4 | =Fields!FirstName.Value & " " & Fields!LastName.Value
    TextBox5 | =Fields!Role.Value
    TextBox6 | =Fields!City.Value
  7. In the Report Explorer, select the Table1 node and in the Properties window, set the Location property to 0in, 1in and the Size property to 6in, 0.5in to make the table wide enough to see all of the data.
  8. With Table1 still selected in the Properties window, in the DataSetName property, enter the text DataSet1.

Show To add a class library project to the solution to contain the custom data provider

  1. From the File menu, select Add, then New Project.
  2. In the Add New Project dialog, select Class Library, and name the project CustomDataProvider.
  3. In the Solution Explorer, right-click the default class and select Delete. (We will add our classes to a folder below.)
  4. Right-click the CustomDataProvider project and select Add Reference, and in the Reference Manager dialog that appears, select the following references to add, holding down the Ctrl button to select multiple references.
    • GrapeCity ActiveReports 13 (GrapeCity.ActiveReports)
    • GrapeCity ActiveReports Extensibility Library (GrapeCity.ActiveReports.Extensibility)
    • System.Drawing
    • System.Windows.Forms
  5. Right-click the CustomDataProvider project and select Add, then New Folder, and name the folder CSVDataProvider.
  6. Right-click the folder and select Add, then Class, then name the class CsvColumn and add code like the following to replace the default stub in the class.

    Show Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class. Copy Code
    Namespace CSVDataProvider
        ' Represents information about fields in the data source.
        Friend Structure CsvColumn
                Private ReadOnly _fieldName As String
                Private ReadOnly _dataType As Type

                ' Creates a new instance of the CsvColumn class.
                ' The fieldName parameter is the name of the field represented by this instance of the CsvColumn.
                ' The dataType parameter is the Type of the field represented by this instance of the CsvColumn.
                Public Sub New(fieldName As String, dataType As Type)
                        If fieldName Is Nothing Then
                                Throw New ArgumentNullException("fieldName")
                        End If
                        If dataType Is Nothing Then
                                Throw New ArgumentNullException("dataType")
                        End If
                        _fieldName = fieldName
                        _dataType = dataType
                End Sub

                ' Gets the name of the field represented by this instance of the CsvColumn.
                Public ReadOnly Property FieldName() As String
                        Get
                                Return _fieldName
                        End Get
                End Property

                ' Gets the the Type of the field represented by this instance of the CsvColumn.
                Public ReadOnly Property DataType() As Type
                        Get
                                Return _dataType
                        End Get
                End Property

                ' Returns a String that represents this instance of the CsvColumn.
                Public Overrides Function ToString() As String
                        Return [String].Concat(New String() {FieldName, "(", DataType.ToString(), ")"})
                End Function

                ' Determines whether two CsvColumn instances are equal.
                ' The obj represents the CsvColumn to compare with the current CsvColumn.
                ' Returns True if the specified CsvColumn is equal to the current CsvColumn; otherwise, False.
                Public Overrides Function Equals(obj As Object) As Boolean
                        Dim flag As Boolean

                        If TypeOf obj Is CsvColumn Then
                                flag = Equals(CType(obj, CsvColumn))
                        Else
                                flag = False
                        End If
                        Return flag
                End Function

                Private Overloads Function Equals(column As CsvColumn) As Boolean
                        Return column.FieldName = FieldName
                End Function

                ' Serves as a hash function for a CsvColumn, suitable for use in hashing algorithms and data structures like a hash table.
                ' Returns a hash code for the current CsvColumn instance.
                Public Overrides Function GetHashCode() As Integer
                        Return (FieldName.GetHashCode() + DataType.GetHashCode())
                End Function
        End Structure
End Namespace

    Show C# code

    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;

namespace CustomDataProvider.CSVDataProvider
{
        // Represents information about fields in the data source.
        internal struct CsvColumn
        {
                private readonly string _fieldName;
                private readonly Type _dataType;

                // Creates a new instance of the CsvColumn class.
                // The fieldName parameter is the name of the field represented by this instance of the CsvColumn.
                // The dataType parameter is the Type of the field represented by this instance of the CsvColumn.
                public CsvColumn(string fieldName, Type dataType)
                {
                        if (fieldName == null)
                                throw new ArgumentNullException("fieldName");
                        if (dataType == null)
                                throw new ArgumentNullException("dataType");
                        _fieldName = fieldName;
                        _dataType = dataType;
                }

                // Gets the name of the field represented by this instance of the CsvColumn.
                public string FieldName
                {
                        get { return _fieldName; }
                }

                // Gets the the Type of the field represented by this instance of the CsvColumn.
                public Type DataType
                {
                        get { return _dataType; }
                }

               // Returns a String that represents this instance of the CsvColumn.
                public override string ToString()
                {
                        return String.Concat(new string[] {FieldName, "(", DataType.ToString(), ")"});
                }

                // Determines whether two CsvColumn instances are equal.
                // The obj represents the CsvColumn to compare with the current CsvColumn.
                // Returns True if the specified CsvColumn is equal to the current CsvColumn; otherwise, False.
                public override bool Equals(object obj)
                {
                        bool flag;

                        if (obj is CsvColumn)
                        {
                                flag = Equals((CsvColumn) obj);
                        }
                        else
                        {
                                flag = false;
                        }
                        return flag;
                }

                private bool Equals(CsvColumn column)
                {
                        return column.FieldName == FieldName;
                }

                // Serves as a hash function for a CsvColumn, suitable for use in hashing algorithms and data structures like a hash table.
               // Returns a hash code for the current CsvColumn instance.
                public override int GetHashCode()
                {
                        return (FieldName.GetHashCode() + DataType.GetHashCode());
                }
        }
}
  7. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvDataReader and add code like the following to replace the default stub in the class.

    Show Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class. Copy Code
    Imports System
Imports System.Collections
Imports System.Globalization
Imports System.IO
Imports System.Text.RegularExpressions
Imports GrapeCity.ActiveReports.Extensibility.Data

Namespace CSVDataProvider

    ' Provides an implementation of IDataReader for the .NET Framework CSV Data Provider.
    Friend Class CsvDataReader
        Implements IDataReader
        'NOTE: HashcodeProvider and Comparer need to be case-insensitive since TypeNames are capitalized differently in places.
        'Otherwise data types end up as strings when using Int32 vs int32.
        Private _typeLookup As New Hashtable(StringComparer.Create(CultureInfo.InvariantCulture, False))

        Private _columnLookup As New Hashtable()
        Private _columns As Object()
        Private _textReader As TextReader
        Private _currentRow As Object()

        'The regular expressions are set to be pre-compiled to make it faster. Since we were concerned about
        'multi-threading, we made the properties read-only so no one can change any properties on these objects.
        Private Shared ReadOnly _rxDataRow As New Regex(",(?=(?:[^""]*""[^""]*"")*(?![^""]*""))", RegexOptions.Compiled)
        'Used to parse the data rows.

        Private Shared ReadOnly _rxHeaderRow As New Regex("(?<fieldName>(\w*\s*)*)\((?<fieldType>\w*)\)", RegexOptions.Compiled)
        'Used to parse the header rows.

        ' Creates a new instance of the CsvDataReader class.
        ' The textReader parameter represents the TextReader to use to read the data.
        Public Sub New(textReader As TextReader)
            _textReader = textReader
            ParseCommandText()
        End Sub

        ' Parses the passed-in command text.
        Private Sub ParseCommandText()
            If _textReader.Peek() = -1 Then
                Return
            End If
            'Command text is empty or at the end already.
            FillTypeLookup()

            Dim header As String = _textReader.ReadLine()
            header = AddDefaultTypeToHeader(header)

            If Not ParseHeader(header) Then
                Throw New InvalidOperationException( _
                "Field names and types are not defined. " & _
                "The first line in the CommandText must contain the field names and data types. e.g FirstName(string)")
            End If
        End Sub

        'A hashtable is used to return a type for the string value used in the header text.
        Private Sub FillTypeLookup()
            _typeLookup.Add("string", GetType([String]))
            _typeLookup.Add("byte", GetType([Byte]))
            _typeLookup.Add("boolean", GetType([Boolean]))
            _typeLookup.Add("datetime", GetType(DateTime))
            _typeLookup.Add("decimal", GetType([Decimal]))
            _typeLookup.Add("double", GetType([Double]))
            _typeLookup.Add("int16", GetType(Int16))
            _typeLookup.Add("int32", GetType(Int32))
            _typeLookup.Add("int", GetType(Int32))
            _typeLookup.Add("integer", GetType(Int32))
            _typeLookup.Add("int64", GetType(Int64))
            _typeLookup.Add("sbyte", GetType([SByte]))
            _typeLookup.Add("single", GetType([Single]))
            _typeLookup.Add("time", GetType(DateTime))
            _typeLookup.Add("date", GetType(DateTime))
            _typeLookup.Add("uint16", GetType(UInt16))
            _typeLookup.Add("uint32", GetType(UInt32))
            _typeLookup.Add("uint64", GetType(UInt64))
        End Sub

        ' Returns a type based on the string value passed in from the header text string. If no match is found,
        ' a string type is returned.
        ' The fieldType parameter represents the String value from the header command text string.
        Private Function GetFieldTypeFromString(fieldType As String) As Type
            If _typeLookup.Contains(fieldType) Then
                Return TryCast(_typeLookup(fieldType), Type)
            End If
            Return GetType([String])
        End Function

        ' Parses the first line in the passed-in command text string to create the field names and field data types.
        ' The field information is stored in a CsvColumn struct, and these column info items are stored
        ' in an ArrayList. The column name is also added to a hashtable for easy lookup later.
        ' The header parameter represents the header string that contains all the fields.
        ' Returns True if it can parse the header string; otherwise False.
        Private Function ParseHeader(header As String) As Boolean
            Dim fieldName As String
            Dim index As Integer = 0
            If header.IndexOf("(") = -1 Then
                Return False
            End If

            Dim matches As MatchCollection = _rxHeaderRow.Matches(header)
            _columns = New Object(matches.Count - 1) {}
            For Each match As Match In matches
                fieldName = match.Groups("fieldName").Value
                Dim fieldType As Type = GetFieldTypeFromString(match.Groups("fieldType").Value)
                _columns.SetValue(New CsvColumn(fieldName, fieldType), index)
                _columnLookup.Add(fieldName, index)
                index += 1
            Next

            Return True
        End Function

        ' Ensures that the header contains columns in the form of name(type)
        ' The line parameter represents the raw header line from the file to fix up.
        ' Returns a modified header with default types appended to column names.
        Private Shared Function AddDefaultTypeToHeader(line As String) As String
            Const ColumnWithDataTypeRegex As String = "[""]?\w+[\""]?\(.+\)"
            Dim columns As String() = line.Split(New String() {","}, StringSplitOptions.None)
            Dim ret As String = Nothing
            For Each column As String In columns
                If Not String.IsNullOrEmpty(ret) Then
                    ret += ","
                End If
                If Not Regex.Match(column, ColumnWithDataTypeRegex).Success Then
                    ret += column + "(string)"
                Else
                    ret += column
                End If
            Next
            Return ret
        End Function

        ' Parses a row of data using a regular expression and stores the information inside an object
        ' array that is the current row of data.
        ' If the row does not have the correct number of fields, an exception is raised.
        ' The dataRow parameter represents the String value representing a comma delimited data row.
        ' Returns True if it can parse the data string; otherwise False.
        Private Function ParseDataRow(dataRow As String) As Boolean
            Dim index As Integer = 0
            Dim tempData As String() = _rxDataRow.Split(dataRow)

            _currentRow = New Object(tempData.Length - 1) {}
            If tempData.Length <> _columns.Length Then
                Dim [error] As String = String.Format(CultureInfo.InvariantCulture, _
                                "Invalid row ""{0}"". The row does not contain the same number of data columns as the table header definition.", dataRow)
                Throw New InvalidOperationException([error])
            End If
            For i As Integer = 0 To tempData.Length - 1
                Dim value As String = tempData(i)

                If value.Length > 1 Then
                    If value.IndexOf(""""c, 0) = 0 AndAlso value.IndexOf(""""c, 1) = value.Length - 1 Then
                        value = value.Substring(1, value.Length - 2)
                    End If
                End If
                _currentRow.SetValue(ConvertValue(GetFieldType(index), value), index)
                index += 1
            Next
            Return True
        End Function

        ' Coverts the string value coming from the command text to the appropriate data type, based on the field's type.
        ' This also checks a few string value rules to decide if a String.Empty of System.Data.DBNull needs to be returned.
        ' The type parameter represents the Type of the current column the data belongs to.
        ' The originalValue parameter represents the String value coming from the command text.
        ' Returns the object resulting from the converted string, based on the type.
        Private Function ConvertValue(type As Type, originalValue As String) As Object
            Dim fieldType As Type = type
            Dim invariantCulture As CultureInfo = CultureInfo.InvariantCulture
            Try
                If originalValue = """""" OrElse originalValue = " " Then
                    Return String.Empty
                End If
                If originalValue = "" Then
                    Return DBNull.Value
                End If
                If originalValue = "DBNull" Then
                    Return DBNull.Value
                End If
                If fieldType.Equals(GetType([String])) Then
                    Return originalValue.Trim()
                End If
                If fieldType.Equals(GetType(Int32)) Then
                    Return Convert.ToInt32(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Boolean])) Then
                    Return Convert.ToBoolean(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(DateTime)) Then
                    Return Convert.ToDateTime(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Decimal])) Then
                    Return Convert.ToDecimal(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Double])) Then
                    Return Convert.ToDouble(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(Int16)) Then
                    Return Convert.ToInt16(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(Int64)) Then
                    Return Convert.ToInt64(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Single])) Then
                    Return Convert.ToSingle(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Byte])) Then
                    Return Convert.ToByte(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([SByte])) Then
                    Return Convert.ToSByte(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt16)) Then
                    Return Convert.ToUInt16(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt32)) Then
                    Return Convert.ToUInt32(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt64)) Then
                    Return Convert.ToUInt64(originalValue, invariantCulture)
                End If
            Catch e As Exception
                Throw New InvalidOperationException(String.Format("Input value '{0}' could not be converted to the type '{1}'.", originalValue, type), e)
            End Try
            'If no match is found return DBNull instead.
            Return DBNull.Value
        End Function

#Region "IDataReader Members"

       ' Advances the CsvDataReader to the next record.
        ' Returns True if there are more rows; otherwise, False.
        Public Function Read() As Boolean Implements IDataReader.Read
            If _textReader.Peek() > -1 Then
                ParseDataRow(_textReader.ReadLine())
            Else
                Return False
            End If

            Return True
        End Function

#End Region

#Region "IDisposable Members"

        ' Releases the resources used by the CsvDataReader.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

        Private Sub Dispose(disposing As Boolean)
            If disposing Then
                If _textReader IsNot Nothing Then
                    _textReader.Close()
                End If
            End If

            _typeLookup = Nothing
            _columnLookup = Nothing
            _columns = Nothing
            _currentRow = Nothing
        End Sub

        ' Allows an Object to attempt to free resources and perform
        ' other cleanup operations before the Object is reclaimed by garbage collection.
        Protected Overrides Sub Finalize()
            Try
                Dispose(False)
            Finally
                MyBase.Finalize()
            End Try
        End Sub

#End Region

#Region "IDataRecord Members"

        ' Gets the number of columns in the current row.
        Public ReadOnly Property FieldCount() As Integer Implements IDataRecord.FieldCount
            Get
                Return _columns.Length
            End Get
        End Property

        ' The i parameter represents the index of the field to find.
        ' Returns the Type information corresponding to the type of Object that would be returned from GetValue.
        Public Function GetFieldType(i As Integer) As Type Implements IDataReader.GetFieldType
            If i > _columns.Length - 1 Then
                Return Nothing
            End If

            Return DirectCast(_columns.GetValue(i), CsvColumn).DataType
        End Function

        ' Gets the name for the field to find.
        ' The i parameter represents the index of the field to find.
        ' Returns the name of the field or an empty string (""), if there is no value to return.
        Public Function GetName(i As Integer) As String Implements IDataRecord.GetName
            If i > _columns.Length - 1 Then
                Return String.Empty
            End If

            Return DirectCast(_columns.GetValue(i), CsvColumn).FieldName
        End Function

        ' The name parameter represents the name of the field to find.
        ' Returns the index of the named field.
        Public Function GetOrdinal(name As String) As Integer Implements IDataRecord.GetOrdinal
            Dim value As Object = _columnLookup(name)
            If value Is Nothing Then
                Throw New IndexOutOfRangeException("name")
            End If
            Return CInt(value)
        End Function

        ' The i parameter represents the index of the field to find.
        ' Returns the Object which contains the value of the specified field.
        Public Function GetValue(i As Integer) As Object Implements IDataRecord.GetValue
            If i > _columns.Length - 1 Then
                Return Nothing
            End If

            Return _currentRow.GetValue(i)
        End Function

        Public Overridable Function GetData(fieldIndex As Integer) As IDataReader Implements IDataReader.GetData
            Throw New NotSupportedException()
        End Function

#End Region
    End Class
End Namespace

    Show C# code

    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;
using System.Collections;
using System.Globalization;
using System.IO;
using System.Text.RegularExpressions;
using GrapeCity.ActiveReports.Extensibility.Data;

namespace CustomDataProvider.CSVDataProvider
{

        // Provides an implementation of IDataReader for the .NET Framework CSV Data Provider.
        internal class CsvDataReader : IDataReader
        {
                //NOTE: HashcodeProvider and Comparer need to be case-insensitive since TypeNames are capitalized differently in places.
                                //Otherwise data types end up as strings when using Int32 vs int32.
                private Hashtable _typeLookup =
                        new Hashtable(StringComparer.Create(CultureInfo.InvariantCulture, false));
                private Hashtable _columnLookup = new Hashtable();
                private object[] _columns;
                private TextReader _textReader;
                private object[] _currentRow;

                //The regular expressions are set to be pre-compiled to make it faster. Since we were concerned about
                //multi-threading, we made the properties read-only so no one can change any properties on these objects.
                private static readonly Regex _rxDataRow = new Regex(@",(?=(?:[^""]*""[^""]*"")*(?![^""]*""))", RegexOptions.Compiled);
                        //Used to parse the data rows.

                private static readonly Regex _rxHeaderRow =
                        new Regex(@"(?<fieldName>(\w*\s*)*)\((?<fieldType>\w*)\)", RegexOptions.Compiled);
                        //Used to parse the header rows.

                // Creates a new instance of the CsvDataReader class.
                // The textReader parameter represents the TextReader to use to read the data.
                public CsvDataReader(TextReader textReader)
                {
                        _textReader = textReader;
                        ParseCommandText();
                }

                // Parses the passed-in command text.
                private void ParseCommandText()
                {
                        if (_textReader.Peek() == -1)
                                return; //Command text is empty or at the end already.

                        FillTypeLookup();

                        string header = _textReader.ReadLine();
                        header = AddDefaultTypeToHeader(header);

                        if (!ParseHeader(header))
                                throw new InvalidOperationException(
                                        "Field names and types are not defined. The first line in the CommandText must contain the field names and data types. e.g FirstName(string)");
                }

                //A hashtable is used to return a type for the string value used in the header text.
                private void FillTypeLookup()
                {
                        _typeLookup.Add("string", typeof (String));
                        _typeLookup.Add("byte", typeof (Byte));
                        _typeLookup.Add("boolean", typeof (Boolean));
                        _typeLookup.Add("datetime", typeof (DateTime));
                        _typeLookup.Add("decimal", typeof (Decimal));
                        _typeLookup.Add("double", typeof (Double));
                        _typeLookup.Add("int16", typeof (Int16));
                        _typeLookup.Add("int32", typeof (Int32));
                        _typeLookup.Add("int", typeof (Int32));
                        _typeLookup.Add("integer", typeof (Int32));
                        _typeLookup.Add("int64", typeof (Int64));
                        _typeLookup.Add("sbyte", typeof (SByte));
                        _typeLookup.Add("single", typeof (Single));
                        _typeLookup.Add("time", typeof (DateTime));
                        _typeLookup.Add("date", typeof (DateTime));
                        _typeLookup.Add("uint16", typeof (UInt16));
                        _typeLookup.Add("uint32", typeof (UInt32));
                        _typeLookup.Add("uint64", typeof (UInt64));
                }

                // Returns a type based on the string value passed in from the header text string. If no match is found, a string type is returned.
                // The fieldType parameter represents the String value from the header command text string.
                private Type GetFieldTypeFromString(string fieldType)
                {
                        if (_typeLookup.Contains(fieldType))
                                return _typeLookup[fieldType] as Type;
                        return typeof (String);
                }

                // Parses the first line in the passed-in command text string to create the field names and field data types. The field information
                // is stored in a CsvColumn struct, and these column info items are stored in an ArrayList. The column name is also added
                // to a hashtable for easy lookup later.

                // The header parameter represents the header string that contains all the fields.
                // Returns True if it can parse the header string; otherwise False.
                private bool ParseHeader(string header)
                {
                        string fieldName;
                        int index = 0;
                        if (header.IndexOf("(") == -1)
                                return false;

                        MatchCollection matches = _rxHeaderRow.Matches(header);
                        _columns = new object[matches.Count];
                        foreach (Match match in matches)
                        {
                                fieldName = match.Groups["fieldName"].Value;
                                Type fieldType = GetFieldTypeFromString(match.Groups["fieldType"].Value);
                                _columns.SetValue(new CsvColumn(fieldName, fieldType), index);
                                _columnLookup.Add(fieldName, index);
                                index++;
                        }

                        return true;
                }

                // Ensures that the header contains columns in the form of name(type)
                // The line parameter represents the raw header line from the file to fix up.
                // Returns a modified header with default types appended to column names.
                private static string AddDefaultTypeToHeader(string line)
                {
                        const string ColumnWithDataTypeRegex = @"[""]?\w+[\""]?\(.+\)";
                        string[] columns = line.Split(new string[] { "," }, StringSplitOptions.None);
                        string ret = null;
                        foreach (string column in columns)
                        {
                                if (!string.IsNullOrEmpty(ret))
                                        ret += ",";
                                if (!Regex.Match(column, ColumnWithDataTypeRegex).Success)
                                {
                                        ret += column + "(string)";
                                }
                                else
                                {
                                        ret += column;
                                }
                        }
                        return ret;
                }

                // Parses a row of data using a regular expression and stores the information inside an object array that is the current row of data.
                // If the row does not have the correct number of fields, an exception is raised.
                // The dataRow parameter represents the String value representing a comma delimited data row.
                // Returns True if it can parse the data string; otherwise False.
                private bool ParseDataRow(string dataRow)
                {
                        int index = 0;
                        string[] tempData = _rxDataRow.Split(dataRow);

                        _currentRow = new object[tempData.Length];
                        if (tempData.Length != _columns.Length)
                        {
                                string error =
                                        string.Format(CultureInfo.InvariantCulture,
                                                      "Invalid row \"{0}\". The row does not contain the same number of data columns as the table header definition.",
                                                      dataRow);
                                throw new InvalidOperationException(error);
                        }
                        for (int i = 0; i < tempData.Length; i++)
                        {
                                string value = tempData[i];

                                if (value.Length > 1)
                                {
                                        if (value.IndexOf('"', 0) == 0 && value.IndexOf('"', 1) == value.Length - 1)
                                                value = value.Substring(1, value.Length - 2);
                                }
                                _currentRow.SetValue(ConvertValue(GetFieldType(index), value), index);
                                index++;
                        }
                        return true;
                }

                // Coverts the string value coming from the command text to the appropriate data type, based on the field's type.
                // This also checks a few string value rules to decide if a String.Empty of System.Data.DBNull needs to be returned.
                // The type parameter represents the Type of the current column the data belongs to.
                // The originalValue parameter represents the String value coming from the command text.
                // Returns the object resulting from the converted string, based on the type.
                private object ConvertValue(Type type, string originalValue)
                {
                        Type fieldType = type;
                        CultureInfo invariantCulture = CultureInfo.InvariantCulture;
                        try
                        {
                                if (originalValue == "\"\"" || originalValue == " ")
                                        return string.Empty;
                                if (originalValue == "")
                                        return DBNull.Value;
                                if (originalValue == "DBNull")
                                        return DBNull.Value;
                                if (fieldType.Equals(typeof (String)))
                                        return originalValue.Trim();
                                if (fieldType.Equals(typeof (Int32)))
                                        return Convert.ToInt32(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Boolean)))
                                        return Convert.ToBoolean(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (DateTime)))
                                        return Convert.ToDateTime(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Decimal)))
                                        return Convert.ToDecimal(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Double)))
                                        return Convert.ToDouble(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Int16)))
                                        return Convert.ToInt16(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Int64)))
                                        return Convert.ToInt64(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Single)))
                                        return Convert.ToSingle(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Byte)))
                                        return Convert.ToByte(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (SByte)))
                                        return Convert.ToSByte(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt16)))
                                        return Convert.ToUInt16(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt32)))
                                        return Convert.ToUInt32(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt64)))
                                        return Convert.ToUInt64(originalValue, invariantCulture);
                        }
                        catch (Exception e)
                        {
                                throw new InvalidOperationException(
                                        string.Format("Input value '{0}' could not be converted to the type '{1}'.", originalValue, type), e);
                        }
                        //If no match is found return DBNull instead.
                        return DBNull.Value;
                }

                #region IDataReader Members

                // Advances the CsvDataReader to the next record.
                // Returns True if there are more rows; otherwise, False.
                public bool Read()
                {
                        if (_textReader.Peek() > -1)
                                ParseDataRow(_textReader.ReadLine());
                        else
                                return false;

                        return true;
                }

                #endregion

                #region IDisposable Members

                // Releases the resources used by the CsvDataReader.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }

                private void Dispose(bool disposing)
                {
                        if (disposing)
                        {
                                if (_textReader != null)
                                        _textReader.Close();
                        }

                        _typeLookup = null;
                        _columnLookup = null;
                        _columns = null;
                        _currentRow = null;
                }

                // Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
                ~CsvDataReader()
                {
                        Dispose(false);
                }

                #endregion

                #region IDataRecord Members

                // Gets the number of columns in the current row.
                public int FieldCount
                {
                        get { return _columns.Length; }
                }

                // The i parameter represents the index of the field to find.
                // Returns the Type information corresponding to the type of Object that would be returned from GetValue.
                public Type GetFieldType(int i)
                {
                        if (i > _columns.Length - 1)
                                return null;

                        return ((CsvColumn) _columns.GetValue(i)).DataType;
                }

                // Gets the name for the field to find.
                // The i parameter represents the index of the field to find.
                // Returns the name of the field or an empty string (""), if there is no value to return.
                public string GetName(int i)
                {
                        if (i > _columns.Length - 1)
                                return string.Empty;

                        return ((CsvColumn) _columns.GetValue(i)).FieldName;
                }

                // The name parameter represents the name of the field to find.
                // Returns the index of the named field.
                public int GetOrdinal(string name)
                {
                        object value = _columnLookup[name];
                        if (value == null)
                                throw new IndexOutOfRangeException("name");
                        return (int) value;
                }

                // The i parameter represents the index of the field to find.
                // Returns the Object which contains the value of the specified field.
                public object GetValue(int i)
                {
                        if (i > _columns.Length - 1)
                                return null;

                        return _currentRow.GetValue(i);
                }

                public virtual IDataReader GetData(int fieldIndex)
                {
                        throw new NotSupportedException();
                }

                #endregion
        }
}
  8. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvCommand and add code like the following to replace the default stub in the class.

    Show Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class. Copy Code
    Imports System
Imports System.IO
Imports GrapeCity.ActiveReports.Extensibility.Data

Namespace CSVDataProvider

    ' Provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
    Public NotInheritable Class CsvCommand
        Implements IDbCommand
        Private _commandText As String
        Private _connection As IDbConnection
        Private _commandTimeout As Integer
        Private _commandType As CommandType

        ' Creates a new instance of the CsvCommand class.
        Public Sub New()
            Me.New(String.Empty)
        End Sub

        ' Creates a new instance of the CsvCommand class with command text.
        ' The commandText parameter represents the command text.
        Public Sub New(commandText As String)
            Me.New(commandText, Nothing)
        End Sub

        ' Creates a new instance of the CsvCommand class with command text and a CsvConnection.
        ' The commandText parameter represents the command text.
        ' The connection parameter represents a CsvConnection to a data source.
        Public Sub New(commandText As String, connection As CsvConnection)
            _commandText = commandText
            _connection = connection
        End Sub

        ' Gets or sets the command to execute at the data source.
        Public Property CommandText() As String Implements IDbCommand.CommandText
            Get
                Return _commandText
            End Get
            Set(value As String)
                _commandText = value
            End Set
        End Property

        ' Gets or sets the wait time before terminating an attempt to execute the command and generating an error.
        Public Property CommandTimeout() As Integer Implements IDbCommand.CommandTimeout
            Get
                Return _commandTimeout
            End Get

            Set(value As Integer)
                _commandTimeout = value
            End Set
        End Property

        ' Gets or sets a value indicating how the CommandText property is interpreted.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Property CommandType() As CommandType Implements IDbCommand.CommandType
            Get
                Return _commandType
            End Get

            Set(value As CommandType)
                _commandType = value
            End Set
        End Property

        ' Gets or sets the CsvConnection used by this instance of the CsvCommand.
        Public Property Connection() As IDbConnection
            Get
                Return _connection
            End Get

            Set(value As IDbConnection)
                _connection = value
            End Set
        End Property

       ' Sends the CommandText to the CsvConnection, and builds a CsvDataReader using one of the CommandBehavior values.
        ' The behavior parameter represents a CommandBehavior value.
        ' Returns a CsvDataReader object.
        Public Function ExecuteReader(behavior As CommandBehavior) As IDataReader Implements IDbCommand.ExecuteReader
            Return New CsvDataReader(New StringReader(_commandText))
        End Function

        ' Returns a string that represents the command text with the parameters expanded into constants.
        Public Function GenerateRewrittenCommandText() As String Implements IDbCommand.GenerateRewrittenCommandText
            Return _commandText
        End Function

        ' Sends the CommandText to the CsvConnection and builds a CsvDataReader.
        ' Returns a CsvDataReader object.
        Public Function ExecuteReader() As IDataReader Implements IDbCommand.ExecuteReader
            Return ExecuteReader(CommandBehavior.SchemaOnly)
        End Function

#Region "Non implemented IDbCommand Members"

        Public ReadOnly Property Parameters() As IDataParameterCollection Implements IDbCommand.Parameters
            Get
                Throw New NotImplementedException()
            End Get
        End Property

        Public Property Transaction() As IDbTransaction Implements IDbCommand.Transaction
            Get
                Throw New NotImplementedException()
            End Get

            Set(value As IDbTransaction)
                Throw New NotImplementedException()
            End Set
        End Property

        Public Sub Cancel() Implements IDbCommand.Cancel

        End Sub

        Public Function CreateParameter() As IDataParameter Implements IDbCommand.CreateParameter
            Throw New NotImplementedException()
        End Function

#End Region

#Region "IDisposable Members"

        ' Releases the resources used by the CsvCommand.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

        Private Sub Dispose(disposing As Boolean)
            If disposing Then
                If _connection IsNot Nothing Then
                    _connection.Dispose()
                    _connection = Nothing
                End If
            End If
        End Sub

#End Region
    End Class
End Namespace

    Show C# code

    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;
using System.IO;
using GrapeCity.ActiveReports.Extensibility.Data;

namespace CustomDataProvider.CSVDataProvider
{

       // Provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
        public sealed class CsvCommand : IDbCommand
        {
                private string _commandText;
                private IDbConnection _connection;
                private int _commandTimeout;
                private CommandType _commandType;

                /// Creates a new instance of the CsvCommand class.
                public CsvCommand()
                        : this(string.Empty)
                {
                }

                // Creates a new instance of the CsvCommand class with command text.
                // The commandText parameter represents the command text.
                public CsvCommand(string commandText)
                        : this(commandText, null)
                {
                }

                // Creates a new instance of the CsvCommand class with command text and a CsvConnection.
                // The commandText parameter represents the command text.
                // The connection parameter represents a CsvConnection to a data source.?
                public CsvCommand(string commandText, CsvConnection connection)
                {
                        _commandText = commandText;
                        _connection = connection;
                }

                // Gets or sets the command to execute at the data source.
                public string CommandText
                {
                        get { return _commandText; }
                        set { _commandText = value; }
                }

                // Gets or sets the wait time before terminating an attempt to execute the command and generating an error.
                public int CommandTimeout
                {
                        get { return _commandTimeout; }

                        set { _commandTimeout = value; }
                }

                // Gets or sets a value indicating how the CommandText property is interpreted.
               // Remarks: We don't use this one for the Csv Data Provider.
                public CommandType CommandType
                {
                        get { return _commandType; }

                        set { _commandType = value; }
                }

               // Gets or sets the CsvConnection used by this instance of the CsvCommand.
                public IDbConnection Connection
                {
                        get { return _connection; }

                        set { _connection = value; }
                }

                // Sends the CommandText to the CsvConnection, and builds a CsvDataReader using one of the CommandBehavior values.
                // The behavior parameter represents a CommandBehavior value.
                // Returns a CsvDataReader object.
                public IDataReader ExecuteReader(CommandBehavior behavior)
                {
                        return new CsvDataReader(new StringReader(_commandText));
                }

               // Returns a string that represents the command text with the parameters expanded into constants.
                public string GenerateRewrittenCommandText()
                {
                        return _commandText;
                }

                // Sends the CommandText to the CsvConnection and builds a CsvDataReader.
                // Returns a CsvDataReader object.
                public IDataReader ExecuteReader()
                {
                        return ExecuteReader(CommandBehavior.SchemaOnly);
                }

                #region Non implemented IDbCommand Members

                public IDataParameterCollection Parameters
                {
                        get { throw new NotImplementedException(); }
                }

                public IDbTransaction Transaction
                {
                        get { throw new NotImplementedException(); }

                        set { throw new NotImplementedException(); }
                }

                public void Cancel()
                {

                }

                public IDataParameter CreateParameter()
                {
                        throw new NotImplementedException();
                }

                #endregion

                #region IDisposable Members

                // Releases the resources used by the CsvCommand.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }

                private void Dispose(bool disposing)
                {
                        if (disposing)
                        {
                                if (_connection != null)
                                {
                                        _connection.Dispose();
                                        _connection = null;
                                }
                        }
                }

                #endregion
        }
}
  9. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvConnection and add code like the following to replace the default stub in the class. (You can safely ignore the errors, as they will go away when you add the CsvConnection class.)

    Show Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class. Copy Code
    Imports System
Imports System.Collections.Specialized
Imports GrapeCity.ActiveReports.Extensibility.Data

Namespace CSVDataProvider

    ' Provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
    Public NotInheritable Class CsvConnection
        Implements IDbConnection
        Private _localizedName As String

        ' Creates a new instance of the CsvConnection class.
        Public Sub New()
            _localizedName = "Csv"
        End Sub

       ' Creates a new instance of the CsvConnection class.
       ' The localizedName parameter represents the localized name for the CsvConnection instance.
        Public Sub New(localizeName As String)
            _localizedName = localizeName
        End Sub

#Region "IDbConnection Members"

        ' Gets or sets the string used to open the connection to the data source.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Property ConnectionString() As String Implements IDbConnection.ConnectionString
            Get
                Return String.Empty
            End Get

            Set(value As String)

            End Set
        End Property

        ' Gets the amount of time to wait while trying to establish a connection before terminating
        ' the attempt and generating an error.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public ReadOnly Property ConnectionTimeout() As Integer Implements IDbConnection.ConnectionTimeout
            Get
                Throw New NotImplementedException()
            End Get
        End Property

        ' Begins a data source transaction.
        ' Returns an object representing the new transaction.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Function BeginTransaction() As IDbTransaction Implements IDbConnection.BeginTransaction
            Return Nothing
        End Function

        ' Opens a data source connection.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Sub Open() Implements IDbConnection.Open

        End Sub

        ' Closes the connection to the data source. This is the preferred method of closing any open connection.
        Public Sub Close() Implements IDbConnection.Close
            Dispose()
        End Sub

        ' Creates and returns a CsvCommand object associated with the CsvConnection.
        Public Function CreateCommand() As IDbCommand Implements IDbConnection.CreateCommand
            Return New CsvCommand(String.Empty)
        End Function

        Public Property DataProviderService() As IDataProviderService Implements IDbConnection.DataProviderService
            Get
                Return Nothing
            End Get
            Set(value As IDataProviderService)
            End Set
        End Property

#End Region

#Region "IDisposable Members"

        ' Releases the resources used by the CsvConnection.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

        Private Sub Dispose(disposing As Boolean)
        End Sub

       ' Allows an Object to attempt to free resources and perform other cleanup operations
        ' before the Object is reclaimed by garbage collection.
        Protected Overrides Sub Finalize()
            Try
                Dispose(False)
            Finally
                MyBase.Finalize()
            End Try
        End Sub

#End Region

#Region "IExtension Members"

       ' Gets the localized name of the CsvConnection.
        Public ReadOnly Property LocalizedName() As String Implements IDbConnection.LocalizedName
            Get
                Return _localizedName
            End Get
        End Property

       ' Specifies any configuration information for this extension.
       ' The configurationSettings parameter represents a NameValueCollection of the settings.
        Public Sub SetConfiguration(configurationSettings As NameValueCollection) Implements IDbConnection.SetConfiguration
        End Sub

#End Region
    End Class
End Namespace

    Show C# code

    C# code. Paste it to replace the default stub in the class. Copy Code
    using System;
using System.Collections.Specialized;
using GrapeCity.ActiveReports.Extensibility.Data;

namespace CustomDataProvider.CSVDataProvider
{

        // Provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
        public sealed class CsvConnection : IDbConnection
        {
                private string _localizedName;

                // Creates a new instance of the CsvConnection class.
                public CsvConnection()
                {
                        _localizedName = "Csv";
                }

                // Creates a new instance of the CsvConnection class.
                // The localizedName parameter represents the localized name for the CsvConnection instance.
                public CsvConnection(string localizeName)
                {
                        _localizedName = localizeName;
                }

                #region IDbConnection Members

               // Gets or sets the string used to open the connection to the data source.
               // Remarks: We don't use this one for the Csv Data Provider.
                public string ConnectionString
                {
                        get { return string.Empty; }

                        set { ; }
                }

                // Gets the amount of time to wait while trying to establish a connection before terminating the attempt and generating an error.
                // Remarks: We don't use this one for the Csv Data Provider.
                public int ConnectionTimeout
                {
                        get { throw new NotImplementedException(); }
                }

               // Begins a data source transaction.
               // Returns an object representing the new transaction.
               // Remarks: We don't use this one for the Csv Data Provider.
                public IDbTransaction BeginTransaction()
                {
                        return null;
                }

               // Opens a data source connection.
               // Remarks: We don't use this one for the Csv Data Provider.
                public void Open()
                {
                        ;
                }

                // Closes the connection to the data source. This is the preferred method of closing any open connection.
                public void Close()
                {
                        Dispose();
                }

               // Creates and returns a CsvCommand object associated with the CsvConnection.
                public IDbCommand CreateCommand()
                {
                        return new CsvCommand(string.Empty);
                }

                public IDataProviderService DataProviderService
                {
                        get { return null; }
                        set { }
                }

                #endregion

                #region IDisposable Members

               // Releases the resources used by the CsvConnection.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }

                private void Dispose(bool disposing)
                {
                }

                // Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
                ~CsvConnection()
                {
                        Dispose(false);
                }

                #endregion

                #region IExtension Members

                // Gets the localized name of the CsvConnection.
                public string LocalizedName
                {
                        get { return _localizedName; }
                }

                // Specifies any configuration information for this extension.
                // The configurationSettings parameter represents a NameValueCollection of the settings.
                public void SetConfiguration(NameValueCollection configurationSettings)
                {
                }

                #endregion
        }
}
  10. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvDataProviderFactory and add code like the following to replace the default stub in the class.

    Show Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class. Copy Code
    Imports GrapeCity.ActiveReports.Extensibility.Data
Imports GrapeCity.BI.Data.DataProviders

Namespace CSVDataProvider

       ' Implements the DataProviderFactory for .NET Framework CSV Data Provider.
        Public Class CsvDataProviderFactory
                Inherits DataProviderFactory

                ' Creates new instance of the CsvDataProviderFactory class.
                Public Sub New()
                End Sub

               ' Returns a new instance of the the CsvCommand.
                Public Overrides Function CreateCommand() As IDbCommand
                        Return New CsvCommand()
                End Function

                ' Returns a new instance of the the CsvConnection.
                Public Overrides Function CreateConnection() As IDbConnection
                        Return New CsvConnection()
                End Function
        End Class
End Namespace

    Show C# code

    C# code. Paste it to replace the default stub in the class. Copy Code
    using GrapeCity.ActiveReports.Extensibility.Data;
using GrapeCity.BI.Data.DataProviders;

namespace CustomDataProvider.CSVDataProvider
{

       // Implements the DataProviderFactory for .NET Framework CSV Data Provider.
        public class CsvDataProviderFactory : DataProviderFactory
        {

                // Creates new instance of the CsvDataProviderFactory class.
                public CsvDataProviderFactory()
                {
                }

               // Returns a new instance of the the CsvCommand.
                public override IDbCommand CreateCommand()
                {
                        return new CsvCommand();
                }

               // Returns a new instance of the the CsvConnection.
                public override IDbConnection CreateConnection()
                {
                        return new CsvConnection();
                }
        }
}

Show To add a button to the query editor

  1. In the Solution Explorer, right-click the CSVDataProvider folder and select Add, then Class, then name the class QueryEditor and add code like the following to replace the default stub in the class.

    Show Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class. Copy Code

    Imports System.Collections.Generic
    Imports System.Drawing.Design
    Imports System.IO
    Imports System.Linq
    Imports System.Text
    Imports System.Text.RegularExpressions
    Imports System.Windows.Forms
    Imports System.Windows.Forms.Design

    Namespace CustomDataProvider.CSVDataProvider
    Public NotInheritable Class QueryEditor
    Inherits UITypeEditor
    Public Overrides Function GetEditStyle(context As System.ComponentModel.ITypeDescriptorContext) As UITypeEditorEditStyle
    Return UITypeEditorEditStyle.DropDown
    End Function
    Public Overrides Function EditValue(context As System.ComponentModel.ITypeDescriptorContext, provider As System.IServiceProvider, value As Object) As Object
    Dim edSvc As IWindowsFormsEditorService = DirectCast(provider.GetService(GetType(IWindowsFormsEditorService)), IWindowsFormsEditorService)
    Dim path = ""
    Dim btn = New Button()
    btn.Text = "Select CSV File..."
    Dim pdg = btn.Padding
    pdg.Bottom += 2
    btn.Padding = pdg
    btn.Click += Sub() Using openDlg = New OpenFileDialog()
    openDlg.Filter = "CSV Files (*.csv)|*.csv|All Files (*.*)|*.*"
    If openDlg.ShowDialog() <> DialogResult.OK Then
    path = ""
    Else
    path = openDlg.FileName
    End If
    End Using
    edSvc.DropDownControl(btn)
    If String.IsNullOrEmpty(path) Then
    Return String.Empty
    End If
    If Not File.Exists(path) Then
    Return String.Empty
    End If
    Return GetCSVQuery(path)
    End Function

    Private Function GetCSVQuery(path As String) As Object
    Dim sr As StreamReader = Nothing
    Try
    sr = New StreamReader(path)
    Dim ret As String = String.Empty
    Dim currentLine As String
    Dim line As Integer = 0
    While (InlineAssignHelper(currentLine, sr.ReadLine())) IsNot Nothing
    If line = 0 Then
    ret += ProcessColumnsDefinition(currentLine) & Convert.ToString(vbCr & vbLf)
    Else
    ret += currentLine & Convert.ToString(vbCr & vbLf)
    End If
    line += 1
    End While
    Return ret
    Catch generatedExceptionName As IOException
    Return String.Empty
    Finally
    If sr IsNot Nothing Then
    sr.Close()
    End If
    End Try
    End Function
    Private Function ProcessColumnsDefinition(currentLine As String) As String
    Const ColumnWithDataTypeRegex As String = "[""]?\w+[\""]?\(.+\)"
    Dim columns As String() = currentLine.Split(New String() {","}, StringSplitOptions.None)
    Dim ret As String = Nothing
    For Each column As String In columns
    If Not String.IsNullOrEmpty(ret) Then
    ret += ","
    End If
    If Not Regex.Match(column, ColumnWithDataTypeRegex).Success Then
    ret += column & Convert.ToString("(string)")
    Else
    ret += column
    End If
    Next
    Return ret
    End Function
    Private Shared Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
    target = value
    Return value
    End Function
    End Class
    End Namespace

    Show C# code

    C# code. Paste it to replace the default stub in the class. Copy Code

    using System;
    using System.Collections.Generic;
    using System.Drawing.Design;
    using System.IO;
    using System.Linq;
    using System.Text;
    using System.Text.RegularExpressions;
    using System.Windows.Forms;
    using System.Windows.Forms.Design;
    namespace CustomDataProvider.CSVDataProvider
    {
    public sealed class QueryEditor : UITypeEditor
    {
    public override UITypeEditorEditStyle GetEditStyle(System.ComponentModel.ITypeDescriptorContext context)
    {
    return UITypeEditorEditStyle.DropDown;
    }

    public override object EditValue(System.ComponentModel.ITypeDescriptorContext context, System.IServiceProvider provider, object value)
    {
    IWindowsFormsEditorService edSvc = (IWindowsFormsEditorService)provider.GetService(typeof(IWindowsFormsEditorService));
    var path = "";
    var btn = new Button();
    btn.Text = "Select CSV File...";
    var pdg = btn.Padding;
    pdg.Bottom += 2;
    btn.Padding = pdg;
    btn.Click += delegate
    {
    using (var openDlg = new OpenFileDialog())
    {
    openDlg.Filter = "CSV Files (*.csv)|*.csv|All Files (*.*)|*.*";
    if (openDlg.ShowDialog() != DialogResult.OK)
    path = "";
    else
    path = openDlg.FileName;
    }
    };
    edSvc.DropDownControl(btn);
    if (string.IsNullOrEmpty(path)) return string.Empty;
    if (!File.Exists(path)) return string.Empty;
    return GetCSVQuery(path);
    }
    private object GetCSVQuery(string path)
    {
    StreamReader sr = null;
    try
    {
    sr = new StreamReader(path);
    string ret = string.Empty;
    string currentLine;
    int line = 0;
    while ((currentLine = sr.ReadLine()) != null)
    {
    if (line == 0)
    ret += ProcessColumnsDefinition(currentLine) + "\r\n";
    else
    ret += currentLine + "\r\n";
    line++;
    }
    return ret;
    }
    catch (IOException)
    {
    return string.Empty;
    }
    finally
    {
    if (sr != null)
    sr.Close();
    }
    }
    private string ProcessColumnsDefinition(string currentLine)
    {
    const string ColumnWithDataTypeRegex = @"[""]?\w+[\""]?\(.+\)";
    string[] columns = currentLine.Split(new string[] { "," }, StringSplitOptions.None);
    string ret = null;
    foreach (string column in columns)
    {
    if (!string.IsNullOrEmpty(ret))
    ret += ",";
    if (!Regex.Match(column, ColumnWithDataTypeRegex).Success)
    {
    ret += column + "(string)";
    }
    else
    {
    ret += column;
    }
    }
    return ret;
    }
    }
    }
  2. In the Solution Explorer, right-click the CustomDataProviderDemo project and select Add Reference. In the Reference Manager dialog that appears, on the Projects tab, select CustomDataProvider and click OK.
  3. Run the project, and follow the instructions in the RichTextBox to see the custom data provider in action.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Section Report Walkthroughs

Section Report Walkthroughs
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs

Glossary Item Box

Section Report walkthroughs cover scenarios to introduce the key features of code-based and XML-based section reports. Learn about different section report walkthroughs categorized as follows.

Data
This section contain the walkthroughs that explain various ways of working with data sources.
Layout
This section contain the walkthroughs that explain how to create different section report layouts.
Chart
This section contain the walkthroughs that demonstrate how to work with the ActiveReports Chart control in a section report.
Export
This section contains the walkthrough that demonstrates how to set up report custom exporting to PDF, Excel, TIFF, RTF, and plain text formats.
Script
This section contain the walkthroughs that demonstrate how to embed script in reports so that code becomes portable when you save a report layout to XML-based RPX format.
Parameters
This section contain the walkthroughs that demonstrate how to use parameters in SubReport and Chart controls.
Web
This section contains the walkthroughs that explain how to create a simple web service for each scenario and how to create a Document Windows application.

See Also

Walkthroughs
Page Report/RDL Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Data

Data
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data

Glossary Item Box

This section contains the following walkthroughs that fall under the Data category.

Basic Data Bound Reports
This walkthrough demonstrates the basics of setting up bound section reports.
Basic XML-Based Reports (RPX)
This walkthrough demonstrates how to create a simple section report, using the XML-based report template.
Run-Time Data Sources
Describes how to change the report data source at run time using the ReportStart event.
Bind a Section Report to CSV Data Source
Describes how to bind a report to a CSV data source.

See Also

Section Report Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Basic Data Bound Reports

Basic Data Bound Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data > Basic Data Bound Reports

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, the simplest reporting style is a tabular listing of fields from a data source.

This walkthrough illustrates the basics of setting up bound reports by introducing the ideas of using the DataSource icon and dragging fields from the Report Explorer onto the report.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Connecting to a data source
  • Adding controls to the report
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptBound.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Products
  8. Click OK to save the data source and return to the report design surface.

Show To create a layout for the report

  1. In the Visual Studio toolbox, expand the ActiveReports 13 Section Report node and drag three TextBox controls onto the detail section and set the properties of each textbox as indicated:

    Show TextBox1

    Property Name | Property Value
    DataField | ProductName
    Text | Product Name
    Location | 0, 0in
    Size | 2.3, 0.2in

    Show TextBox2

    Property Name | Property Value
    DataField | QuantityPerUnit
    Text | Quantity
    Location | 2.4, 0in
    Size | 1.5, 0.2in

    Show TextBox3

    Property Name | Property Value
    DataField | UnitsInStock
    Text | Stock
    Location | 4, 0in
    Size | 1, 0.2in
  2. Click just below the fields to select the Detail section, and in the Properties Window, set the CanShrink property to True to eliminate white space in the rendered report.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Basic XML-Based Reports (RPX)

Basic XML-Based Reports (RPX)
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data > Basic XML-Based Reports (RPX)

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to create reports with embedded script and save them to the XML-based RPX file format. By embedding script in reports saved as RPX files, you can later load, run, and display reports directly in the viewer control without rebuilding the application. This walkthrough illustrates how to create a simple report, using the XML-based report template.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Creating a layout for the report
  • Adding scripting to supply data for the controls
  • Applying scripting to set alternate row colors in the detail section
  • Loading an XML-based report from resources
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

When you have finished this walkthrough, you get a report that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (xml-based) and in the Name field, rename the file as rptScript.
  4. Click the Add button to open a new section report in the designer.
  5. In the Solution Explorer click the rptScript.rpx item and in the properties window set the Build Action property to Embedded Resource.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To create a layout for the report

  1. In the Visual Studio toolbox, expand the ActiveReports 13 Section Report node and drag three TextBox controls onto the detail section and set the properties of each textbox as indicated:

    Show TextBox1

    Property Name | Property Value
    DataField | ProductName
    Text | Product Name
    Location | 0, 0in
    Size | 2.3, 0.2in

    Show TextBox2

    Property Name | Property Value
    DataField | QuantityPerUnit
    Text | Quantity
    Location | 2.4, 0in
    Size | 2.4, 0.2in

    Show TextBox3

    Property Name | Property Value
    DataField | UnitsInStock
    Text | Stock
    Location | 4, 0in
    Size | 1, 0.2in
  2. Click just below the fields to select the Detail section, and in the Properties Window, set the CanShrink property to True to eliminate white space in the rendered report.

Show To add scripting to the report to supply data for the controls

  1. Click the Script tab located at the bottom of the report designer to access the script editor.
  2. Add the scripting code.

    The following example shows what the scripting code looks like.

    Warning: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

    Show To write the script in Visual Basic.NET

    Visual Basic.NET script. Paste in the script editor window. Copy Code
    Private Shared m_cnn As System.Data.OleDb.OleDbConnection

Public Sub ActiveReport_ReportStart()
  'Set up a data connection for the report
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb"
  Dim sqlString As String = "SELECT * FROM products"

  m_cnn = new System.Data.OleDb.OleDbConnection(connString)
  Dim m_Cmd As System.Data.OleDb.OleDbCommand = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn)

  If m_cnn.State = System.Data.ConnectionState.Closed Then
     m_cnn.Open
  End If
  rpt.DataSource = m_Cmd.ExecuteReader
End Sub

Public Sub ActiveReport_ReportEnd()
  'Close the data reader and connection
  m_cnn.Close
End Sub

    Show To write the script in C#

    C# script. Paste in the script editor window. Copy Code
    private static System.Data.OleDb.OleDbConnection m_cnn;

public void ActiveReport_ReportStart()
{
    //Set up a data connection for the report
    string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb";
    string sqlString = "SELECT * FROM products";
    m_cnn = new System.Data.OleDb.OleDbConnection(m_cnnString);
    System.Data.OleDb.OleDbCommand m_Cmd = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn);

    if(m_cnn.State == System.Data.ConnectionState.Closed)
    {
        m_cnn.Open();
    }
    rpt.DataSource = m_Cmd.ExecuteReader();
}

public void ActiveReport_ReportEnd()
{
    //Close the data reader and connection
    m_cnn.Close();
}

Show To add scripting to alternate colors in the detail section

  1. Click the Script tab located at the bottom edge of the report designer to access the scripting editor.
  2. Add the scripting code to set alternate colors in the rows of the detail section.

    The following example shows what the scripting code looks like.

    Show To write the script in Visual Basic.NET

    Visual Basic.NET script. Paste in the script editor window. Copy Code
    Dim b as boolean = true

Sub Detail_Format
 if b then
  Me.Detail.BackColor = Color.AliceBlue
  b= false
  else
  me.Detail.BackColor = Color.Cyan
  b = true
 End If
End Sub

    Show To write the script in C#

    C# script. Paste in the script editor window. Copy Code
    bool color = true;
public void Detail_Format()
{
  if(color)
  {
      this.Detail.BackColor = System.Drawing.Color.AliceBlue;
      color = false;
  }
  else
  {
      this.Detail.BackColor = System.Drawing.Color.Cyan;
      color = true;
  }
}

Show Loading the report to the Viewer

You can quickly view your report at design time by clicking the Preview tab at the bottom of the designer. You can also load the report to the Viewer control.

  • Drag the ActiveReports Viewer control from the Visual Studio toolbox onto the Windows Form and set its Dock property to Fill.
  • Double-click the title bar of the Windows Form containing the viewer to create a Form_Load event and add the code needed to load the RPX into a generic ActiveReport and display it in the viewer.

    The following example shows what the code for the method looks like.

    Show To write the script in Visual Basic.NET

    Visual Basic.NET script. Paste INSIDE the Form_Load event. Copy Code
    Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("..\..\rptScript.rpx")
sectionReport.LoadLayout(xtr)
xtr.Close()
Viewer1.LoadDocument(sectionReport)

    Show To write the script in C#

    C# script. Paste INSIDE the Form_Load event. Copy Code
    GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(@"..\..\rptScript.rpx");
sectionReport.LoadLayout(xtr);
xtr.Close();
viewer1.LoadDocument(sectionReport);

See Also

Section Report Walkthroughs
Walkthroughs

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Run-Time Data Sources

Run-Time Data Sources
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data > Run-Time Data Sources

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to change the data source of a report at run time. This walkthrough illustrates how to change the data source at run time.

This walkthrough is split up into the following activities:

  • Adding an ActiveReports to the Visual Studio project
  • Connecting the report to a design time data source
  • Adding controls to the report to display data
  • Adding code to change the data source at run time
  • Adding code to close the data connection
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptModifyDS.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

Tip: Even if you will change the data source at run time, setting a design time data source allows you to drag fields onto the report from the Report Explorer.
  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Products
  8. Click OK to save the data source and return to the report design surface.

Show To create a layout for the report

  1. On the design surface of the report, select the detail section and in the Properties window, set the CanShrink property to True.
  2. In the Report Explorer, expand the Fields node, then the Bound node. Drag the following fields onto the detail section and in the Properties window, set the following properties.

Show TextBox1 (ProductID)

Property Name | Property Value
Location | 0, 0 in
Size | 0.5, 0.2 in

Show TextBox2 (ProductName)

Property Name | Property Value
Location | 0.6, 0 in
Size | 2.8, 0.2 in

Show TextBox3 (UnitsInStock)

Property Name | Property Value
Location | 3.5, 0 in
Size | 0.5, 0.2 in
Alignment | Right

Show TextBox4 (UnitsOnOrder)

Property Name | Property Value
Location | 4.1, 0 in
Size | 0.5, 0.2 in
Alignment | Right

Show TextBox5 (UnitPrice)

Property Name | Property Value
Location | 4.7, 0 in
Size | 0.9, 0.2 in
Alignment | Right
OutputFormat | Currency

Show To change the data source at run time

To change the data source at run time

  1. Double-click in the gray area below rptModifyDS to create an event-handling method for the ReportStart event.
  2. Add code to the handler to change the data source at run time.

Show To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
Dim conn As System.Data.OleDb.OleDbConnection
Dim reader As System.Data.OleDb.OleDbDataReader
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + "C:\Users\[YourUserName]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb"
conn = New System.Data.OleDb.OleDbConnection(connString)
Dim cmd As New System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn)
conn.Open()
reader = cmd.ExecuteReader()
Me.DataSource = reader

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event. Copy Code
private static System.Data.OleDb.OleDbConnection conn;
private static System.Data.OleDb.OleDbDataReader reader;
C# code. Paste INSIDE the ReportStart event. Copy Code
string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + @"C:\Users\[YourUserName]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb";
conn = new System.Data.OleDb.OleDbConnection(connString);
System.Data.OleDb.OleDbCommand cmd = new System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn);
conn.Open();
reader = cmd.ExecuteReader();
this.DataSource = reader;

Show To close the data connection

Show To write the code in Visual Basic

  1. In design view of rptModifyDS, drop down the field at the top left of the code view and select (rptModifyDS Events).
  2. Drop down the field at the top right of the code view and select ReportEnd. This creates an event-handling method for ReportEnd event.
  3. Add code to the handler to close the data connection.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the ReportEnd event. Copy Code
reader.Close()
conn.Close()

Show To write the code in C#

  1. Click in the gray area below rptModifyDS to select the report.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click ReportEnd. This creates an event-handling method for the ReportEnd event.
  4. Add code to the handler to close the data connection.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the ReportEnd event. Copy Code
reader.Close();
conn.Close();

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

Run-Time Layouts
Unbound Data

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bind a Section Report to CSV Data Source

Bind a Section Report to CSV Data Source
See Also
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data > Bind a Section Report to CSV Data Source

Glossary Item Box

Show All Show All
Hide All Hide All

This walkthrough illustrates binding a section report to a CSV data source.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Connecting to a data source
  • Creating a layout for the report
  • Viewing the report
Note: This walkthrough uses the Products_header_tab.csv sample database. By default, the Products_header_tab.csv file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptProductsStock.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. On the detail section band, click the Data Source icon.
  2. In the Report Data Source dialog, on the CSV tab, click the Build button next to Connection String.
  3. To specify the File Path, click the Open button and navigate to [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data and select the Products_header_tab.csv file.
  4. Select the Column Separator as Tab from the drop-down menu. See the Sample CSV Connection String drop-down in CSV Data Provider topic for further details.
  5. Click OK to save the changes and close the Configure CSV Data Source wizard. The Connection String tab displays the generated connection string as shown below:
    Path=C:\\[User Documents folder]\\GrapeCity Samples\\ActiveReports 13
    \\Data\\Products_header_tab.csv;Locale=en-US;
    TextQualifier=";ColumnsSeparator= ;RowsSeparator=\r\n;HasHeaders=True
  6. Click OK to close the Report Data Source dialog. You have successfully connected the report to the CSV data source.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also

CSV Provider

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Layout

Layout
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout

Glossary Item Box

This section contains the following walkthroughs that fall under the Layout category.

Address Labels
This walkthrough demonstrates how to create a report that repeats labels using the LayoutAction property.
Columnar Reports
This walkthrough demonstrates how to create a simple report using columns.
Group On Unbound Fields
This walkthrough demonstrates how to set up grouping in an unbound section report.
Mail Merge with RichText
This walkthrough demonstrates how to create a mail-merge report using the RichText control.
Overlaying Reports (Letterhead)
This walkthrough demonstrates how to overlay an ActiveReport with a static letterhead report.
Run-Time Layouts
Describes how to create and modify report layouts dynamically.
Subreports with XML Data
Learn how to use XML data with subreports.
Subreports with Run-Time Data Sources
Learn how to embed a subreport in a main report, passing the data source from the main report to the subreport at run time.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Address Labels

Address Labels
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Address Labels

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports can be used to print any label size by using the newspaper column layout.

This walkthrough illustrates how to create a report that repeats labels using the LayoutAction property and prints labels to a laser printer. The labels in this example are 1" x 2.5" and print 30 labels per 8½" x 11" sheet.

The walkthrough is split up into the following activities:

  • Connecting the report to a data source
  • Adding controls to the report to display data
  • Adding code to the detail_Format event to repeat labels
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

When you have finished this walkthrough, you get a report that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptLabels.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT ContactName, CompanyName, Address, City, PostalCode, Country
    FROM Customers
  8. Click OK to save the data source and return to the report design surface.

Show To create a layout for the report

  1. Right-click the PageHeader section and select Delete to remove the PageHeader and Footer sections from the report.
  2. In the Report menu, select Settings and change the margins as follows:
    • Top margin: 0.5
    • Bottom margin: 0.5
    • Left margin: 0.2
    • Right margin: 0.2
  3. In the Report Explorer, select Report and in the Properties Window, set the PrintWidth property to 8.1 (the width of the label sheet less the Left and Right margins).
  4. Click the detail section of the report to select it and in the Properties window, set the properties as follows.
    Property Name | Property Value
    CanGrow | False
    ColumnCount | 3
    ColumnDirection | AcrossDown
    ColumnSpacing | 0.2
    Height | 1
  5. From the toolbox, drag six TextBox controls onto the detail section and set the properties of each textbox as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | ContactName
    Location | 0, 0 in
    Size | 2.5, 0.2 in
    Font > Bold | True

    Show TextBox2

    Property Name | Property Value
    DataField | CompanyName
    Location | 0, 0.2 in
    Size | 2.5, 0.2 in

    Show TextBox3

    Property Name | Property Value
    DataField | Address
    Location | 0, 0.4 in
    Size | 2.5, 0.2 in

    Show TextBox4

    Property Name | Property Value
    DataField | City
    Location | 0, 0.6 in
    Size | 2.5, 0.2 in

    Show TextBox5

    Property Name | Property Value
    DataField | PostalCode
    Location | 0, 0.8 in
    Size | 1.45, 0.2 in

    Show TextBox6

    Property Name | Property Value
    DataField | Country
    Location | 1.5, 0.8 in
    Size | 1, 0.2 in
  6. Select all of the textboxes, and in the Properties Window, set the CanGrow property to False. This prevents overlapping text, but may crop data if one of the fields contains more data than the control size allows.

If you preview the report at this point, one copy of each label appears on the page.

Show To add code to the detail_Format event to repeat labels

  1. Double-click in the detail section to create a detail_Format event.
  2. Add the following code to the event to repeat each label across all three columns.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
'print each label three times
Static counter As Integer
counter = counter + 1
If counter <= 2 Then
    Me.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout Or
 GrapeCity.ActiveReports.LayoutAction.PrintSection
Else
    Me.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout Or
 GrapeCity.ActiveReports.LayoutAction.NextRecord Or
 GrapeCity.ActiveReports.LayoutAction.PrintSection
    counter = 0
End If

Show To write the code in C#

C# code. Paste JUST ABOVE the Format event. Copy Code
int counter=0;
C# code. Paste INSIDE the Format event. Copy Code
//print each label three times
counter = counter + 1;
if (counter <= 2)
{
    this.LayoutAction =  GrapeCity.ActiveReports.LayoutAction.MoveLayout|
GrapeCity.ActiveReports.LayoutAction.PrintSection;
}
else
{
    this.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout|
GrapeCity.ActiveReports.LayoutAction.NextRecord|
GrapeCity.ActiveReports.LayoutAction.PrintSection;
    counter = 0;
}

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Columnar Reports

Columnar Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Columnar Reports

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports supports newspaper column layouts in both the Detail and Group sections. You can render the columns either horizontally or vertically in the section with options to break the column on the Group section (i.e. start a new column on the change of a group).

There is also a Boolean ColumnGroupKeepTogether property on the GroupHeader. When set to True, the ColumnGroupKeepTogether property attempts to prevent a group from splitting across columns. If a group cannot fit in the current column, it tries the next. If the group is too large for a single column, the property is ignored.

Note: The ColumnGroupKeepTogether property only works when the GroupHeader's GroupKeepTogether property is set to All.

This walkthrough illustrates how to create a simple report using columns, and is split up into the following activities:

  • Connecting the report to a data source
  • Adding controls to the report to display data
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptColumnar.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT Country, CompanyName, ContactName, Phone FROM Customers ORDER BY Country
  8. Click OK to save the data source and return to the report design surface.

Show To create a layout for the report

  1. Right-click the design surface of the report and select Insert, then Group Header/Footer to add a GroupHeader/Footer section.
  2. Select the group header and in the Properties Window, set the properties as follows.
    Property Name | Property Value
    Name | ghCountry
    BackColor | Gold
    DataField | Country
    ColumnGroupKeepTogether | True
    GroupKeepTogether | All
  3. Select the group footer and in the Properties window, set the BackColor property to Goldenrod.
  4. In the Report Explorer, drag the Country field onto the GroupHeader section and in the Properties window, set its properties as follows.
    Property Name | Property Value
    Location | 0, 0 in
    Size | 3.25, 0.2 in
    Alignment | Center
    Font > Size | 12
    Font > Bold | True
  5. Select the PageHeader section and in the Properties window, set the BackColor property to Linen.
  6. From the toolbox, drag a Label control onto the PageHeader section and in the Properties window, set the properties as follows:
    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 0.25 in
    Alignment | Center
    Font > Size | 14
    Text | Customer Telephone List by Country
  7. Select the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    CanShrink | True
    ColumnCount | 2
  8. In the Report Explorer, expand the Fields node, then the Bound node. Drag the following fields onto the Detail section and set the properties of each textbox as indicated.

    Show TextBox1

    Property Name | Property Value
    DataField | CompanyName
    Location | 0, 0 in
    Size | 1.15, 0.2 in
    Font > Size | 8pt

    Show TextBox2

    Property Name | Property Value
    DataField | ContactName
    Location | 1.15, 0 in
    Size | 1.15, 0.2 in
    Font > Size | 8pt

    Show TextBox3

    Property Name | Property Value
    DataField | Phone
    Location | 2.3, 0 in
    Size | 0.95, 0.2 in
    Font > Size | 8pt

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Group On Unbound Fields

Group On Unbound Fields
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Group On Unbound Fields

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to set up grouping in unbound reports. When setting up grouping, the group header's DataField property is used to retrieve the grouping data from the database in the same manner as a textbox's DataField property. This walkthrough illustrates how to set up grouping in an unbound report.

This walkthrough is split into the following activities:

  • Adding code to connect the report to a data source
  • Adding controls to contain the data
  • Using the DataInitialize event to add fields to the report's fields collection
  • Using the FetchData event to populate the report fields
  • Adding code to close the connection to the data source
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptGroupUnbound.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To add code to connect the report to a data source

  1. Double-click the gray area below the report. This creates an event-handling method for the report's ReportStart event.
  2. Add code to the handler to:
    • Set the data source connection string
    • Set the data source SQL query
    • Open the connection and retrieve the data with the data reader

The following examples show what the code for the method looks like in Visual Basic.NET and C#.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
Dim connection As System.Data.OleDb.OleDbConnection
Dim reader As System.Data.OleDb.OleDbDataReader
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
'Create the data connection and change the data source path as necessary
Dim connectionString As String
connectionString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb"
connection = New System.Data.OleDb.OleDbConnection(connectionString)
connection.Open()

Dim sqlString As String
sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid= products.categoryid ORDER BY categories.CategoryID"
Dim command As New System.Data.OleDb.OleDbCommand(sqlString, connection)
'Retrieve data
reader = command.ExecuteReader()

Show To write the code in C#

C# code. Paste JUST ABOVE the ReportStart event. Copy Code
private System.Data.OleDb.OleDbConnection connection;
private System.Data.OleDb.OleDbDataReader reader;
C# code. Paste INSIDE the ReportStart event. Copy Code
//Create the data connection and change the data source path as necessary
string connectionString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb";
connection=new System.Data.OleDb.OleDbConnection(connectionString);
connection.Open();

string sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY categories.CategoryID";
System.Data.OleDb.OleDbCommand command = new System.Data.OleDb.OleDbCommand(sqlString, connection);

//Retrieve data
reader = command.ExecuteReader();

Show To create a layout for the report

  1. On the design surface of the report, right-click and select Insert, then Group Header/Footer to add group header and footer sections.
  2. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | ghCategories
    BackColor | Silver
    CanShrink | True
    DataField | CategoryID
    GroupKeepTogether | All
    KeepTogether | True
  3. Select the group footer, and in the Properties Window, change the Name property to gfCategories.
  4. Select the Detail section, and in the Properties Window, change the CanShrink property to True.
  5. From the toolbox, drag the following controls to the Group Header section (drag the bottom edge of the section down to display all of the controls) and in the Properties window, set the properties of each control as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | CategoryName
    Name | txtCategoryName
    Text | Category Name
    Location | 0, 0 in
    Size | 2, 0.2 in
    ForeColor | Blue
    BackColor | Silver
    Font > Size | 12
    Font > Bold | True

    Show TextBox2

    Property Name | Property Value
    DataField | Description
    Name | txtDescription
    Text | Description
    Location | 0, 0.3 in
    Size | 6, 0.2 in

    Show Label1

    Property Name | Property Value
    Name | lblProductName
    Text | Product Name
    Location | 0, 0.6 in
    Font > Bold | True

    Show Label2

    Property Name | Property Value
    Name | lblUnitsInStock
    Text | Units In Stock
    Location | 4.4, 0.6 in
    Font > Bold | True
    Alignment | Right
  6. From the toolbox, drag two Textbox controls to the Detail section and in the Properties window, set the properties of each control as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | Product Name
    Location | 0, 0 in
    Size | 4, 0.2 in

    Show TextBox2

    Property Name | Property Value
    DataField | UnitsInStock
    Name | txtUnitsInStock
    Text | Units In Stock
    Location | 4.4, 0 in
    Alignment | Right

  7. From the toolbox, drag the following controls to the Group Footer section and in the Properties window, set the properties of each control as follows.

    Show Label

    Property Name | Property Value
    DataField | TotalLabel
    Name | lblTotalLabel
    Location | 2, 0 in
    Size | 2.4, 0.2 in

    Show TextBox

    Property Name | Property Value
    DataField | ProductName
    Name | txtTotalItems
    Text | Total Items
    Location | 4.4, 0 in
    SummaryType | SubTotal
    SummaryFunc | Count
    SummaryRunning | Group
    SummaryGroup | ghCategories
    Alignment | Right

    Show Line

    Property Name | Property Value
    Name | Line1
    LineWeight | 3
    X1 | 1.2
    X2 | 6.45
    Y1 | 0
    Y2 | 0

  8. Right-click the Page Header section and select Delete.

Show To add fields using the DataInitialize event

Warning: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

Show To write the code in Visual Basic

  1. Right-click in any section of the design surface of the report, and select View Code to display the code view for the report.
  2. At the top left of the code view of the report, click the drop-down arrow and select (YourReportName Events).
  3. At the top right of the code window, click the drop-down arrow and select DataInitialize. This creates an event-handling method for the report's DataInitialize event.
  4. Add code to the handler to add fields to the report's Fields collection.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the DataInitialize event. Copy Code
Fields.Add("CategoryID")
Fields.Add("CategoryName")
Fields.Add("ProductName")
Fields.Add("UnitsInStock")
Fields.Add("Description")
Fields.Add("TotalLabel")

Show To write the code in C#

  1. Click in the gray area below the report to select it.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click DataInitialize. This creates an event-handling method for the report's DataInitialize event.
  4. Add code to the handler to add fields to the report's Fields collection.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the DataInitialize event. Copy Code
Fields.Add("CategoryID");
Fields.Add("CategoryName");
Fields.Add("ProductName");
Fields.Add("UnitsInStock");
Fields.Add("Description");
Fields.Add("TotalLabel");

Show To populate the fields using the FetchData event

Show To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (YourReportName Events).
  2. At the top right of the code window, click the drop-down arrow and select FetchData. This creates an event-handling method for the report's FetchData event.
  3. Add code to the handler to retrieve information to populate the report fields.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the FetchData event. Copy Code
Try
   reader.Read()
   Me.Fields("CategoryID").Value = reader("categories.CategoryID")
   Me.Fields("CategoryName").Value = reader("CategoryName")
   Me.Fields("ProductName").Value = reader("ProductName")
   Me.Fields("UnitsInStock").Value = reader("UnitsInStock")
   Me.Fields("Description").Value = reader("Description")
   Me.Fields("TotalLabel").Value = "Total Number of " + reader("CategoryName") + ":"
   eArgs.EOF = False
Catch
   eArgs.EOF = True
End Try

Show To write the code in C#

  1. Back in design view, click in the gray area below the report to select it.
  2. Click the events icon in the Properties window to display available events for the report.
  3. Double-click FetchData. This creates an event-handling method for the report's FetchData event.
  4. Add code to the handler to retrieve information to populate the report fields.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the FetchData event. Copy Code
try
   {
      reader.Read();
      Fields["CategoryID"].Value = reader["categories.CategoryID"].ToString();
      Fields["CategoryName"].Value = reader["CategoryName"].ToString();
      Fields["ProductName"].Value = reader["ProductName"].ToString();
      Fields["UnitsInStock"].Value = reader["UnitsInStock"].ToString();
      Fields["Description"].Value = reader["Description"].ToString();
      Fields["TotalLabel"].Value = "Total Number of " + reader["CategoryName"].ToString() + ":";
      eArgs.EOF = false;
   }
catch
   {
      eArgs.EOF = true;
   }

Show To add code to close the connection to the data source

Show To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (YourReportName Events).
  2. At the top right of the code window, click the drop-down arrow and select ReportEnd. This creates an event-handling method for the report's ReportEnd event.
  3. Add code to the handler to close the connection.
Visual Basic.NET code. Paste INSIDE the ReportEnd event. Copy Code
reader.Close()
connection.Close()

Show To write the code in C#

  1. Back in design view, click in the gray area below the report to select it.
  2. Click the events icon in the Properties window to display available events for the report.
  3. Double-click ReportEnd. This creates an event-handling method for the report's ReportEnd event.
  4. Add code to the handler to close the connection.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the ReportEnd event. Copy Code
reader.Close();
connection.Close();

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Mail Merge with RichText

Mail Merge with RichText
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Mail Merge with RichText

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports supports field merged reports using the RichText control. The RichText control can contain field place holders that can be replaced with values (merged) at run time. This walkthrough illustrates how to create a mail-merge report using the RichText control.

This walkthrough is split up into the following activities:

  • Adding an ActiveReports to the Visual Studio project
  • Connecting the report to a data source
  • Adding controls and formatting the report
  • Adding fields and text to the RichText control
  • Using the FetchData event to conditionally format data
  • Adding code to update RichText fields with current date and conditional values
  • Adding code to send the group subtotal value to the RichText field
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptLetter.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT Customers.CustomerID, Customers.CompanyName, Customers.ContactName, Customers.Address, Customers.City, Customers.Region, Customers.Country, Customers.PostalCode, Orders.OrderID, Orders.OrderDate, [Order Subtotals].Subtotal
    FROM Customers INNER JOIN ([Order Subtotals] INNER JOIN Orders ON [Order Subtotals].OrderID = Orders.OrderID) ON Customers.CustomerID = Orders.CustomerID
  8. Click OK to save the data source and return to the report design surface.

Show To create a layout for the report

  1. On the design surface of the report, right-click and select Insert, then Group Header/Footer to add group header and footer sections.
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    DataField | CustomerID
    Height | 2.5
    KeepTogether | True
  4. On the design surface of the report, select the group footer section and in the Properties window, set the following properties.
    Property Name | Property Value
    Height | 1.1
    KeepTogether | True
    NewPage | After
  5. On the design surface of the report, select the detail section and in the Properties window, set the CanShrink property to True.
  6. On the design surface of the report, select the pageHeader section and in the Properties window, set the following properties.
    Property Name | Property Value
    Height | 0.8
    BackColor | Coral
  7. From the toolbox, drag the Label control to the pageHeader section and in the Properties window, set the properties as follows.

    Show Label

    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 0.65 in
    Text | GrapeCity
    Font > Size | 36
    Font > Bold | True
  8. In the Report Explorer, expand the Fields node, then the Bound node. Drag the SubTotal field onto the groupHeader section and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 4, 0 in
    Size | 1, 0.2 in
    Name | txtSubtotal1
    OutputFormat | Currency
    Visible | False
    SummaryType | SubTotal
    SummaryGroup | groupHeader1
    Note: Even though txtSubtotal1 is hidden, setting its properties is important as it provides the value and the formatting that is displayed in the RichText control.
  9. From the toolbox, drag the following controls to the groupHeader section and in the Properties window, set the properties as follows.

    Show RichTextBox

    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 2.1 in
    AutoReplaceFields | True

    Show Label1

    Property Name | Property Value
    Location | 0.875, 2.25 in
    Size | 1, 0.2 in
    Text | Order ID
    Font > Bold | True

    Show Label2

    Property Name | Property Value
    Location | 1.875, 2.25 in
    Size | 1, 0.2 in
    Text | Order Date
    Font > Bold | True

    Show Label3

    Property Name | Property Value
    Location | 4.375, 2.25 in
    Size | 1, 0.2 in
    Text | Amount
    Font > Bold | True
    Alignment | Right
  10. In the Report Explorer, expand the Fields node, then the Bound node. Drag the following fields onto the detail section and in the Properties window, set the properties of each textbox as follows.

    Show TextBox1 (OrderID)

    Property Name | Property Value
    Location | 0.875, 0 in
    Size | 1, 0.2 in

    Show TextBox2 (OrderDate)

    Property Name | Property Value
    Location | 1.875, 0 in
    Size | 1, 0.2 in
    OutputFormat | Date (MM/dd/yy)

    Show TextBox3 (Subtotal)

    Property Name | Property Value
    Location | 4.375, 0 in
    Size | 1, 0.2 in
    OutputFormat | Currency
    Alignment | Right
  11. From the toolbox, drag the following controls to the groupFooter section and in the Properties window, set the properties as follows.

    Show Label1

    Property Name | Property Value
    Location | 5.15, 0.15 in
    Size | 1.35, 0.2 in
    Text | Best regards,
    Alignment | Right

    Show Label2

    Property Name | Property Value
    Location | 5.15, 0.8 in
    Size | 1.35, 0.2 in
    Text | Accounts Receivable

Show To add fields to the RichText control

  1. Double-click the RichTextBox control box and delete the default text.
  2. Right-click the box and choose Insert Fields.
  3. In the Insert Field dialog that appears, enter Date and click OK.
  4. Place the cursor in front of the text [!Date] that appears in the RichText control, and add spaces until the text is at the right edge of the control (but not overlapping to the next line).
  5. Place the cursor at the end of the text, and press the Enter key to move to the next line.
  6. Insert each of the following fields using the Insert Field dialog (see design time image above for fields arrangement):
    • CompanyName
    • ContactName
    • Address
    • City
    • Region
    • Country
    • PostalCode
    • SubTotal
  7. Add the following text to the RichText control box after all of the fields.
    Paste into the RichText control Copy Code
    Dear [!ContactName],

Thank you for your business. Below is a list of your orders for the past year with a total of [!SubTotal].
Please take this opportunity to review each order and total for accuracy. Call us at 1-800-DNT-CALL with
any questions or concerns.
  8. Arrange the text and fields within the control as you would in any text editor.

Show To use the FetchData event to conditionally format data

Show To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (rptLetter Events).
  2. At the top right of the code window, click the drop-down arrow and select FetchData. This creates an event-handling method for the report's FetchData event.
  3. Add code to the handler to add a comma and a space if there is a Region value for the customer's address.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the FetchData event. Copy Code
Dim region As String
Visual Basic.NET code. Paste INSIDE the FetchData event. Copy Code
'If there is no region for the customer, display nothing
If Fields("Region").Value Is System.DBNull.Value Then
    region = ""
Else
'If there is a region, add a comma and a space
    region = ", " + Fields("Region").Value
End If

Show To write the code in C#

  1. Back in design view, click in the gray area below the report to select it.
  2. Click the events icon in the Properties window to display available events for the report.
  3. Double-click FetchData. This creates an event-handling method for the report's FetchData event.
  4. Add code to the handler to add a comma and a space if there is a Region value for the customer's address.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the FetchData event. Copy Code
string region;
C# code. Paste INSIDE the FetchData event. Copy Code
if(Fields["Region"].Value is System.DBNull)
  region = "";
else
  region = ", " + Fields["Region"].Value.ToString();

Show To add code to update RichText fields with the current date and conditional values

  1. Double-click in the group header section of the report to create an event-handling method for the group header's Format event.
  2. Add code to the handler to:
    • Replace the Date field in the RichText control with the current system date
    • Replace the Region field with the conditional value created in the FetchData event

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Group Header Format event. Copy Code
'Use the current date in the letter
Me.RichTextBox1.ReplaceField("Date", System.DateTime.Today.Date.ToShortDateString())
'Use the value returned by the FetchData event
Me.RichTextBox1.ReplaceField("Region", region)

Show To write the code in C#

C# code. Paste INSIDE the Group Header Format event. Copy Code
//Use the current date in the letter
this.richTextBox1.ReplaceField("Date", System.DateTime.Today.Date.ToShortDateString());
//Use the value returned by the FetchData event
this.richTextBox1.ReplaceField("Region", region);

Show To add code to send the group subtotal value to the RichText field

Show To write the code in Visual Basic.NET

  1. Right-click in any section of the design window of rptLetter, and click on View Code to display the code view for the report.
  2. At the top left of the code view for rptLetter, click the drop-down arrow and select GroupHeader1.
  3. At the top right of the code window, click the drop-down arrow and select BeforePrint. This creates an event-handling method for rptLetter's GroupHeader1_BeforePrint event.
    Note: We use the BeforePrint event instead of the Format event to get the final value of the subtotal field just prior to printing. For more information on section event usage, see the Section Events topic.
  4. Add code to the handler to replace the value of the Subtotal field in the RichText control with the value of the hidden textbox in the group header.
    Visual Basic.NET code. Paste INSIDE the Group Header BeforePrint event. Copy Code
    'Use the value from the hidden group subtotal field
Me.RichTextBox1.ReplaceField("SubTotal", Me.txtSubtotal1.Text)

Show To write the code in C#

  1. Back in design view, click the group header section to select it.
  2. Click the events icon in the Properties window to display available events for the group header.
  3. Double-click BeforePrint. This creates an event-handling method for the report's BeforePrint event.
    Add code to the handler to replace the value of the Subtotal field in the RichText control with the value of the hidden textbox in the group header.
    The following example shows what the code for the method looks like.
    C# code. Paste INSIDE the Group Header BeforePrint event. Copy Code
    //Use the value from the hidden group subtotal field
this.richTextBox1.ReplaceField("SubTotal", this.txtSubtotal1.Text);

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Overlaying Reports (Letterhead)

Overlaying Reports (Letterhead)
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Overlaying Reports (Letterhead)

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to overlay static report formats over data reports. This walkthrough illustrates how to overlay an ActiveReport with a static letterhead report.

This walkthrough is split up into the following activities:

  • Adding an ActiveReports to the Visual Studio project
  • Connecting the data report to a data source
  • Adding controls to the letterhead and data reports
  • Adding code to overlay the data report pages with the letterhead report
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout (rptLetterhead)

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Design-Time Layout (rptData)

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptLetterhead.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptData.
  7. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the rptData to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Customers ORDER BY Country
  8. Click OK to save the data source and return to the report design surface.

Show To create a layout for the rptData

  1. Select the PageHeader section and in the Properties Window, set the Height property to 0.65. (This will match the height of the page header in the template.)
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. Right-click the report and select Insert > GroupHeader/Footer to add group header and group footer sections.
  4. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | ghCustomers
    BackColor | MediumSlateBlue
    CanShrink | True
    DataField | Country
    GroupKeepTogether | FirstDetail
    KeepTogether | True
  5. From the toolbox, drag the following controls to ghCustomers and in the Properties window, set the properties as follows.

    Show TextBox1

    Property Name | Property Value
    DataField ="Customers in " + Country
    (DataField)
    Size | 2, 0.2 in
    Location | 0, 0 in
    Font Bold | True
    ForeColor | White
    Font Size | 12

    Show Label1

    Property Name | Property Value
    Text | ID
    Size | 0.6, 0.2 in
    Location | 0, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Show Label2

    Property Name | Property Value
    Text | Company Name
    Size | 1.1, 0.2 in
    Location | 0.7, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Show Label3

    Property Name | Property Value
    Text | Address
    Size | 1, 0.2 in
    Location | 2.7, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Show Label4

    Property Name | Property Value
    Text | City
    Size | 1, 0.2 in
    Location | 5.5, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue
  6. Click the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    BackColor | LightGray
    CanShrink | True
  7. From the toolbox, drag four TextBox controls onto the Detail section and set the properties of each textbox as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | CustomerID
    Size | 0.6, 0.2 in
    Location | 0, 0 in

    Show TextBox2

    Property Name | Property Value
    DataField | CompanyName
    Size | 2, 0.2 in
    Location | 0.7, 0 in

    Show TextBox3

    Property Name | Property Value
    DataField | Address
    Size | 2.8, 0.2 in
    Location | 2.7, 0 in

    Show TextBox4

    Property Name | Property Value
    DataField | City
    Size | 1, 0.2 in
    Location | 5.5, 0.2 in
  8. Select the group footer and in the Properties window, set the Height property to 0.

Show To create a layout for the rptLetterhead

  1. Select the Page Header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    BackColor | DarkSlateBlue
    Height | 0.65
  2. From the toolbox, drag a Label control onto the Page Header and in the Properties window, set the properties as follows.

    Show Label1

    Property Name | Property Value
    Size | 6.5, 0.65 in
    Location | 0, 0 in
    Font Size | 36
    Font Bold | True
    ForeColor | White
    Text | GrapeCity
  3. Select the Page Footer and in the Properties window, set the BackColor property to DarkSlateBlue.
  4. From the toolbox, drag a Label control onto the Page Footer and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Size | 6.5, 0.2 in
    Location | 0, 0 in
    Alignment | Center
    Font Bold | True
    ForeColor | White
    Text | 984-242-0700, http://activereports.grapecity.com, activereports.sales@grapecity.com

Show To add code to overlay the data report pages with the letterhead report

Show To write the code in Visual Basic.NET

  • Add the ActiveReports viewer control to the Windows Form. Then, double-click the top of the Windows Form to create an event-handling method for the form's Load event. Add code to the handler to:
    • Set the viewer to display the rptData report document
    • Overlay rptLetterhead on rptData

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
   Dim rpt As New rptData()
   rpt.Run()
   Dim rpt2 As New rptLetterhead()
   rpt2.Run()
   Dim i As Integer
   For i = 0 To rpt.Document.Pages.Count - 1
      rpt.Document.Pages(i).Overlay(rpt2.Document.Pages(0))
   Next
   Viewer1.Document = rpt.Document

Show To write the code in C#

  • Add the ActiveReports viewer control to the Windows Form. Then, double-click the top of the Windows Form to create an event-handling method for the form's Load event. Add code to the handler to:
    • Set the viewer to display the rptData report document
    • Overlay rptLetterhead on rptData

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the Form Load event. Copy Code
   rptData rpt = new rptData();
   rpt.Run();
   rptLetterhead rpt2 = new rptLetterhead();
   rpt2.Run();
   for(int i = 0; i < rpt.Document.Pages.Count; i++)
   {
      rpt.Document.Pages[i].Overlay(rpt2.Document.Pages[0]);
   }
   viewer1.Document = rpt.Document;

Show To view the report

Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Run-Time Layouts

Run-Time Layouts
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Run-Time Layouts

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports objects and controls are completely accessible at run time. You can modify the properties of any of the report sections or controls to produce a dynamic report. The section Format event allows you to modify the properties of the section and its controls, including height, visibility, and other visual properties. The Format event is the only event in which you can modify the printable area of a section. Once this event has run, any changes to the section's height are not reflected in the report output.

This walkthrough illustrates how to create a report layout at run time based on user input.

Note: Add controls dynamically in the ReportStart event, otherwise, results may be unpredictable. For more information on events, see the Section Report Events topic.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Adding controls to the Windows Form to display fields and a viewer
  • Generating a dataset for the Windows Form
  • Adding code to create the report layout
  • Adding code to fill the check list with fields and to launch the report
  • Adding code to alternate colors in the detail section
  • Adding code to the ReportStart event to call the report layout code
  • Adding code to the button's Click event to collect the selected values and launch the report
  • Adding code to enable the button when fields are selected
  • Adding code to the Form_Load event to call the fill check list code
  • Viewing the report
Note: This walkthrough uses the NWind database. By default, in ActiveReports, the Nwind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout (Windows form)

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptRunTime.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To add controls to the form

  1. Resize the Windows Form so that it is large enough to accommodate a number of controls.
  2. From the Visual Studio toolbox, drag the Panel control to the Windows Form and in the Properties Window, set the properties as follows.

    Show Panel

    Property Name | Property Value
    Dock | Left
    Name | Panel1
  3. From the Visual Studio toolbox, drag the following controls onto the Panel1 and in the Properties Window, set the properties listed below.

    Show Label

    Property Name | Property Value
    Dock | Top
    Name | lblSelectFields
    Text | Select Fields for Your Report

    Show CheckedListBox

    Property Name | Property Value
    Dock | Fill
    Name | clbFields

    Show Button

    Property Name | Property Value
    Dock | Bottom
    Name | btnGenRep
    Text | Generate Report

    Show CheckBox

    Property Name | Property Value
    Dock | Bottom
    Name | chkGroup
    Text | Group By Category ID
  4. From the Visual Studio toolbox, drag the Viewer control to the Windows Form and in the Properties Window, set the properties as follows.

    Show Viewer

    Property Name | Property Value
    Dock | Fill
    Name | Viewer1

Show To generate a dataset for the Form

  1. From the Project menu, select Add New Item.
  2. Select DataSet, rename the file NWINDDataSet.xsd and click the Add button.
  3. In the DataSet Designer that appears, click the Server Explorer link.
  4. In the Server Explorer, expand the node for your local copy of the Northwind database, then the Tables node, and drag the Products table onto the DataSet designer.
    Tip: If you do not see a copy of the Northwind database, click the Connect to Database icon on top of the Server Explorer and follow the prompts.
  5. Open the Form and from the Visual Studio toolbox, drag DataSet onto the Form.
  6. From the Add DataSet dialog that appears, select Typed dataset and click OK.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

Show To add code to create the report layout

  1. Right-click on rptRunTime and select View Code.
  2. Add the following code within the class declaration of the report to:
    • Create an array of fields
    • Create an option for whether to use groups
    • Set properties on the report sections
    • Add textboxes and labels to the report based on the array of fields
    • Handle exceptions

Show To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST BELOW the statements at the top of the code view Copy Code
Imports GrapeCity.ActiveReports.SectionReportModel
Visual Basic.NET code. Paste INSIDE the class declaration of the report. Copy Code
Private m_arrayFields As ArrayList
Private m_useGroups As Boolean
'Create an array to hold the fields selected by the user
Public WriteOnly Property FieldsList() As ArrayList
   Set(ByVal Value As ArrayList)
       m_arrayFields = Value
   End Set
End Property
'Create a property to hold the user's grouping choice
Public WriteOnly Property UseGroups() As Boolean
   Set(ByVal Value As Boolean)
       m_useGroups = False
       m_useGroups = Value
   End Set
End Property
Private m_defaultHeight As Single = 0.2F
Private m_defaultWidth As Single = 4.0F
Private m_currentY As Single = 0.0F
'Set up report formatting and add fields based on user choices
Private Sub constructReport()
   Try
      Me.Detail1.CanGrow = True
      Me.Detail1.CanShrink = True
      Me.Detail1.KeepTogether = True
      If m_useGroups = True Then
         'If the user wants grouping, add a group header and footer and set the grouping field
          Me.Sections.InsertGroupHF()
          CType(Me.Sections("GroupHeader1"), GroupHeader).DataField = "CategoryID"
          Me.Sections("GroupHeader1").BackColor = System.Drawing.Color.Gray
          Me.Sections("GroupHeader1").CanGrow = True
          Me.Sections("GroupHeader1").CanShrink = True
          CType(Me.Sections("GroupHeader1"), GroupHeader).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
          'Add a textbox to display the group's category ID
          Dim txt As New TextBox
          txt.DataField = "CategoryID"
          txt.Location = New System.Drawing.PointF(0.0F, 0)
          txt.Width = 2.0F
          txt.Height = 0.3F
          txt.Style = "font-weight: bold; font-size: 16pt"
          Me.Sections("GroupHeader1").Controls.Add(txt)
      End If
      Dim i As Integer
      For i = 0 To m_arrayFields.Count - 1
          'For all fields selected by the user (except CategoryID) create a label and a textbox
          If m_arrayFields(i).ToString <> "CategoryID" Then
              Dim lbl As New Label
              'Set the label to display the name of the selected field
              lbl.Text = m_arrayFields(i) + ":"
              'Set the location of each label
               '(m_currentY gets the height of each control added on each iteration)
              lbl.Location() = New System.Drawing.PointF(0.0F, m_currentY)
              lbl.Width = 0.9F
              lbl.Height = m_defaultHeight
              Me.Detail1.Controls.Add(lbl)
              Dim txt As New TextBox
               'Set the textbox to display data
              txt.DataField = m_arrayFields(i)
               'Set the location of the textbox
              txt.Location = New System.Drawing.PointF(1.0F, m_currentY)
              txt.Width = m_defaultWidth
              txt.Height = m_defaultHeight
              Me.Detail1.Controls.Add(txt)
               'Set the textbox to use currency formatting if the field is UnitPrice
              If m_arrayFields(i) = "UnitPrice" Then
                 txt.OutputFormat = "$#.00"
              End If
               'Increment the vertical location by adding the height of the added controls
              m_currentY = m_currentY + m_defaultHeight
           End If
       Next
   Catch ex As Exception
       System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message, "Project Error", System.Windows.Forms.MessageBoxButtons.OK, System.Windows.Forms.MessageBoxIcon.Error)
   End Try
End Sub

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST BELOW the statements at the top of the code view Copy Code
using GrapeCity.ActiveReports.SectionReportModel;
C# code. Paste INSIDE the class declaration of the report. Copy Code
private ArrayList m_arrayFields;
 //Create an array to hold the fields selected by the user
public ArrayList FieldsList
{
   set{m_arrayFields = value;}
}
private bool m_useGroups = false;
 //Create a property to hold the user's grouping choice
public bool UseGroups
{
   set{m_useGroups = value;}
}
float m_defaultHeight = .2f;
float m_defaultWidth = 4f;
float m_currentY = 0f;
 //Set up report formatting and add fields based on user choices
private void constructReport()
{
   try
   {
      this.detail.CanGrow = true;
      this.detail.CanShrink = true;
      this.detail.KeepTogether = true;
      if(m_useGroups)
      {
         //If the user wants grouping, add a group header and footer and set the grouping field
        this.Sections.InsertGroupHF();
        ((GroupHeader)this.Sections["GroupHeader1"]).DataField = "CategoryID";
        this.Sections["GroupHeader1"].BackColor = System.Drawing.Color.Gray;
        this.Sections["GroupHeader1"].CanGrow = true;
        this.Sections["GroupHeader1"].CanShrink = true;
        ((GroupHeader)this.Sections["GroupHeader1"]).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail;
        this.Sections["GroupFooter1"].Height = 0;
         //Add a textbox to display the group's category ID
        TextBox txt = new TextBox();
        txt.DataField = "CategoryID";
        txt.Location = new System.Drawing.PointF(0f,0);
        txt.Width =2f;
        txt.Height = .3f;
        txt.Style = "font-weight: bold; font-size: 16pt;";
        this.Sections["GroupHeader1"].Controls.Add(txt);
      }
      for(int i=0;i<m_arrayFields.Count;i++)
      {
        if(!m_useGroups || (m_useGroups && m_arrayFields[i].ToString() != "CategoryID"))
          //'For all fields selected by the user (except CategoryID) create a label and a textbox
          {
           Label lbl = new Label();
            //Set the label to display the name of the selected field
           lbl.Text = m_arrayFields[i].ToString() + ":";
            //Set the location of each label
            //(m_currentY gets the height of each control added on each iteration)
           lbl.Location = new System.Drawing.PointF(0f,m_currentY);
           lbl.Width =.9f;
           lbl.Height = m_defaultHeight;
           this.detail.Controls.Add(lbl);
           TextBox txt = new TextBox();
            //Set the textbox to display data
           txt.DataField = m_arrayFields[i].ToString();
            //Set the location of the textbox
           txt.Location = new System.Drawing.PointF(1f,m_currentY);
           txt.Width = m_defaultWidth;
           txt.Height = m_defaultHeight;
           this.detail.Controls.Add(txt);
           //Set the textbox to use currency formatting if the field is UnitPrice
           if (m_arrayFields[i].ToString().Equals("UnitPrice"))
          {
              txt.OutputFormat = "$#.00";
          }
            //Increment the vertical location by adding the height of the added controls
           m_currentY = m_currentY + m_defaultHeight;
        }
      }
   }
   catch(Exception ex)
   {
      System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message,"Project Error",System.Windows.Forms.MessageBoxButtons.OK,System.Windows.Forms.MessageBoxIcon.Error);
   }
}

Show To add code to fill the check list with fields and to launch the report

  1. Right-click the Windows Form and select View Code.
  2. Add code within the class declaration of the form to:
    • Fill the check list with fields
    • Launch the report

Show To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST BELOW the statements at the top of the code view Copy Code
Imports System.Collections
Visual Basic.NET code. Paste INSIDE the class declaration of the form. Copy Code
Dim i As Integer
Dim c As Integer
Dim m_arrayField As New ArrayList()
Private Sub fillCheckBox()
   For i = 0 To Me.NwindDataSet1.Tables.Count - 1
      For c = 0 To Me.NwindDataSet1.Tables(i).Columns.Count - 1
        Me.clbFields.Items.Add(Me.NwindDataSet1.Tables(i).Columns(c).ColumnName)
      Next
   Next
End Sub
Private Sub launchReport()
   Dim rpt As New rptRunTime()
   Dim dataAdapter As New NWINDDataSetTableAdapters.ProductsTableAdapter
      Try
           rpt.FieldsList = m_arrayField
           rpt.UseGroups = chkGroup.Checked
           dataAdapter.Fill(NwindDataSet1.Products)
           rpt.DataSource = Me.NwindDataSet1.Products
           Viewer1.Document = rpt.Document
           rpt.Run()
        Catch ex As Exception
           System.Windows.Forms.MessageBox.Show(Me, "Error in launchReport: " + ex.Message, "Project Error", MessageBoxButtons.OK, MessageBoxIcon.Error)
      End Try
End Sub

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST BELOW the statements at the top of the code view Copy Code
using System.Collections;
C# code. Paste INSIDE the class declaration of the form. Copy Code
ArrayList m_arrayField = new ArrayList();
private void fillCheckBox()
{
   for(int i = 0; i < this.nwindDataSet1.Tables.Count; i++)
   {
      for(int c = 0; c < this.nwindDataSet1.Tables[i].Columns.Count; c++)
      {
        this.clbFields.Items.Add(this.nwindDataSet1.Tables[i].Columns[c].ColumnName);
      }
   }
}
private void launchReport()
{
   try
   {
      rptRunTime rpt = new rptRunTime();
      rpt.FieldsList = m_arrayField;
      rpt.UseGroups = chkGroup.Checked;
      NWINDDataSetTableAdapters.ProductsTableAdapter dataAdapter = new NWINDDataSetTableAdapters.ProductsTableAdapter();
      dataAdapter.Fill(this.nwindDataSet1.Products);
      rpt.DataSource = this.nwindDataSet1.Products;
      this.Viewer1.Document = rpt.Document;
      rpt.Run();
   }
   catch(Exception ex)
   {
      MessageBox.Show(this,"Error in launchReport: " + ex.Message,"Project Error",MessageBoxButtons.OK,MessageBoxIcon.Error);
   }
}

Show To add code to alternate colors in the detail section

  1. Double-click the detail section of rptRunTime. This creates an event-handling method for rptRunTime's Detail_Format event.
  2. Add code to the handler to alternate colors for a green bar report effect.

Show To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the Detail Format event. Copy Code
Dim m_count As Integer
Visual Basic.NET code. Paste INSIDE the Detail Format event. Copy Code
If m_count Mod 2 = 0 Then
  Me.Detail1.BackColor = System.Drawing.Color.SlateGray
Else
  Me.Detail1.BackColor = System.Drawing.Color.Gainsboro
End If
m_count = m_count + 1

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the Detail Format event. Copy Code
int m_count;
C# code. Paste INSIDE the Detail Format event. Copy Code
if(m_count % 2 == 0)
{
  this.detail.BackColor = System.Drawing.Color.SlateGray;
}
else
{
  this.detail.BackColor = System.Drawing.Color.Gainsboro;
}
  m_count++;

Show To add code to the ReportStart event to call the report layout code

  1. Double-click the gray area below rptRunTime to create an event-handling method for rptRunTime's ReportStart event.
  2. Add code to call the constructReport method.

Show To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
constructReport()

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the ReportStart event. Copy Code
constructReport();

Show To add code to the button's Click event to collect the selected values and launch the report

  1. Double-click btnGenRep to create an event-handling method for the button click event.
  2. Add code to the handler to collect the selected values and launch the report.

Show To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the button click event. Copy Code
Me.m_arrayField.Clear()
For Me.i = 0 To Me.clbFields.CheckedItems.Count - 1
   m_arrayField.Add(Me.clbFields.CheckedItems(i).ToString)
Next
launchReport()

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the button click event. Copy Code
this.m_arrayField.Clear();
for(int i = 0; i < this.clbFields.CheckedItems.Count; i++)
{
  m_arrayField.Add(this.clbFields.CheckedItems[i].ToString());
}
launchReport();

Show To add code to enable the button when fields are selected

  1. Select the checked list box (clbFields) and go to the Properties Window.
  2. At the top of Properties Window, select the Events icon to open the events list.
  3. Double-click the SelectedIndexChanged event. This creates an event-handling method for the clbFields_SelectedIndexChanged event.
  4. Add code to the handler to enable the button when fields are selected.

The following example shows what the code for the method looks like.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the SelectedIndexChanged event. Copy Code
If Me.clbFields.CheckedItems.Count < 0 Then
    Me.btnGenRep.Enabled = False
Else
    Me.btnGenRep.Enabled = True
End If

Show To write the code in C#

C# code. Paste INSIDE the SelectedIndexChanged event. Copy Code
if(this.clbFields.CheckedItems.Count>0)
{
  this.btnGenRep.Enabled = true;
}
else
{
  this.btnGenRep.Enabled = false;
}

Show To add code to the Form_Load event to call the fill check list code

  1. Double-click the title bar of the form. This creates an event-handling method for the Windows Form_Load event.
  2. Add code to the handler to call the fillCheckBox() method to populate clbFields with field values and to handle exceptions.

Show To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
Try
  fillCheckBox()
Catch ex As Exception
  System.Windows.Forms.MessageBox.Show(Me, "Error in Form1_Load: " + ex.Message, "Project Error", MessageBoxButtons.OK, MessageBoxIcon.Error)
End Try

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the Form Load event. Copy Code
try
{
  fillCheckBox();
}
catch(Exception ex)
{
  MessageBox.Show(this,"Error in Form1_Load: " + ex.Message,"Project Error", MessageBoxButtons.OK,MessageBoxIcon.Error);
}

Show To view the report

  • Press F5 to run the project.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Subreports with XML Data

Subreports with XML Data
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Subreports with XML Data

Glossary Item Box

Show All Show All
Hide All Hide All

Using XML data requires some setup that is different from other types of data. This walkthrough illustrates how to set up a subreport bound to the XML DataSource in the parent report.

This walkthrough is split up into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Connecting the parent report to an XML data source
  • Adding controls to display the data
  • Adding code to create a new instance of the subreport
  • Adding code to pass a subset of the parent report's data to the subreport
  • Viewing the report
Note: This walkthrough uses Customer.xml. By default, in ActiveReports, the Customer.xml file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Samples\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptMain.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptSub.
  7. Click the Add button to open a second new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the Parent Report (rptMain) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog, on the XML tab, click the ellipsis (...) button next to File URL field.
  3. In the Open File window that appears, navigate to Customer.xml and click the Open button. (The default installation path is C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13\Data\customer.xml).
  4. In the Recordset Pattern field, enter //CUSTOMER.
  5. Click OK to save the data source and return to the report design surface.

Show To create a layout for the Parent Report (rptMain)

  1. On the design surface, select the pageHeader section and in the Properties window, set the Height property to 0.3.
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. On the design surface, select the detail section and in the Properties window, set the CanShrink property to True to eliminate white space.
  4. From the toolbox, drag the Label control onto the pageHeader section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Text | Orders by Customer
    Location | 0, 0 in
    Size | 6.5, 0.25 in
    Font | Arial, 14pt, style=Bold
    Alignment | Center
  5. From the toolbox, drag the controls onto the detail section and in the Properties window, set the properties of each control as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | NAME
    Location | 1.2, 0 in
    Size | 2, 0.2 in

    Show Label1

    Property Name | Property Value
    Text | Customer Name:
    Location | 0, 0 in
    Size | 1.2, 0.2 in
    Font Bold | True

    Show Label2

    Property Name | Property Value
    Text | Orders:
    Location | 1.2, 0.25 in
    Size | 1, 0.2 in
    Font Bold | True

    Show Subreport

    Property Name | Property Value
    Location | 2.3, 0.25 in
    Size | 4, 1 in

Show To create a layout for the Child Report (rptSub)

  1. On the design surface, select the detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    CanShrink | True
    BackColor | LightSteelBlue
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag the following controls to the detail section and in the Properties window, set the properties as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | TITLE
    Name | txtTitle
    Location | 0, 0 in
    Size | 2.9, 0.2 in

    Show TextBox2

    Property Name | Property Value
    DataField | PRICE
    Name | txtPrice
    Location | 3, 0 in
    Size | 1, 0.2 in
    Alignment | Right
    OutputFormat | $#,##0.00 (or select Currency in the dialog)

Show To add code to create a new instance of the Child Report (rptSub)

Warning: Do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, which uses a lot of memory.

Show To write the code in Visual Basic

  1. Right-click the design surface of rptMain and select View Code.
  2. At the top left of the code view of the report, click the drop-down arrow and select (rptMain Events).
  3. At the top right of the code window, click the drop-down arrow and select ReportStart. This creates an event-handling method for the ReportStart event.
  4. Add code to the handler to create an instance of rptSub.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
Dim rpt As rptSub
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
rpt = New rptSub

Show To write the code in C#

  1. Click in the gray area below rptMain to select it.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click ReportStart. This creates an event-handling method for the report's ReportStart event.
  4. Add code to the handler to create a new instance of rptSub.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event. Copy Code
private rptSub rpt;
C# code. Paste INSIDE the ReportStart event. Copy Code
rpt = new rptSub();

Show To add code to pass a subset of the Parent Report's data to the Child Report

To add code to pass a subset of the parent report's data to the subreport

  1. Double-click in the detail section of the design surface of rptMain to create a detail_Format event.
  2. Add code to the handler to:
    • Create a new GrapeCity XMLDataSource
    • Type cast the new data source as rptMain's data source and set the NodeList to the "ORDER/ITEM" field
    • Display rptSub in the subreport control
    • Pass the new data source to the subreport

Show To write the code in Visual Basic

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    Dim xmlDS As New GrapeCity.ActiveReports.Data.XMLDataSource
    xmlDS.NodeList = CType(CType(Me.DataSource, GrapeCity.ActiveReports.Data.XMLDataSource).Field("ORDER/ITEM", True), System.Xml.XmlNodeList)
    rpt.DataSource = xmlDS
    SubReport1.Report = rpt

Show To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the Format event. Copy Code
   GrapeCity.ActiveReports.Data.XMLDataSource xmlDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
   xmlDS.NodeList = (System.Xml.XmlNodeList)((GrapeCity.ActiveReports.Data.XMLDataSource) this.DataSource).Field("ORDER/ITEM", true);
   rpt.DataSource = xmlDS;
   subReport1.Report = rpt;

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Subreports with Run-Time Data Sources

Subreports with Run-Time Data Sources
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Subreports with Run-Time Data Sources

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows section reports to contain any number of child reports using the Subreport control. Child reports, or subreports, are executed each time the parent section (i.e. the section in which the Subreport control is placed) is processed. This walkthrough illustrates how to modify the subreport record source from the data in the parent report to retrieve the correct information.

This walkthrough is split up into the following activities:

  • Adding a main report and a subreport to a Visual Studio project
  • Connecting the main report to a data source
  • Adding controls to the main report to display data and contain the subreport
  • Adding controls to the subreport to display data
  • Adding code to save the current record's CategoryID for use in the subreport's SQL query
  • Adding code to create an instance of the subreport
  • Adding code to assign a data source for the subreport
  • Viewing the report
Note: This walkthrough uses tables from the NWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Samples\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptMain.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptSub.
  7. Click the Add button to open a second new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the Parent Report (rptMain) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Categories
  4. Click OK to save the data source and return to the report design surface.

Show To create a layout for the Parent Report (rptMain)

  1. In the Report Explorer, select the report and in the Properties window, set the PrintWidth property to 5.75.
  2. On the design surface, select the detail section and in the Properties window, set the CanShrink property to True to eliminate white space.
  3. From the toolbox, drag a Label control onto the pageHeader section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | lblProductsbyCategory
    Text | Products by Category
    Location | 0, 0 in
    Size | 5.75, 0.25 in
    Font Size | 14
    Alignment | Center
  4. From the toolbox, drag the following controls onto the detail section and in the Properties window, set the properties as follows.

    Show TextBox1

    Property Name | Property Value
    Name | txtCategoryID1
    DataField | CategoryID
    Visible | False

    Show TextBox2

    Property Name | Property Value
    Name | txtCategoryName1
    DataField | CategoryName
    Location | 1.15, 0.05 in

    Show Label1

    Property Name | Property Value
    Name | lblCategoryName
    Text | CategoryName:
    Location | 0, 0.05 in
    Size | 1.15, 0.2 in
    Font Bold | True

    Show Label2

    Property Name | Property Value
    Name | lblProducts
    Text | Products:
    Location | 2.4, 0.05 in
    Font Bold | True

    Show Subreport

    Property Name | Property Value
    Name | SubReport1
    Location | 3.5, 0.05 in
    Size | 2.25, 1 in

Show To create a layout for the Child Report (rptSub)

  1. On the design surface, select the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    CanShrink | True
    BackColor | AliceBlue
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag a TextBox control to the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | Product Name
    Location | 0, 0 in
    Size | 2.25, 0.2 in

Show To add code to create an instance of the subreport

Warning: Do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, which uses a lot of memory.

Show To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (rptMain Events).
  2. At the top right of the code window, click the drop-down arrow and select ReportStart. This creates an event-handling method for the report's ReportStart event.
  3. Add code to the handler to create a new instance of the subreport.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
Private rpt As rptSub
Private childDataSource As New GrapeCity.ActiveReports.Data.OleDBDataSource()
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
rpt = New rptSub()

Show To write the code in C#

  1. Click in the gray area below rptMain to select it.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click ReportStart. This creates an event-handling method for the report's ReportStart event.
  4. Add code to the handler to create a new instance of the subreport.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event. Copy Code
private rptSub rpt;
private GrapeCity.ActiveReports.Data.OleDBDataSource childDataSource = new GrapeCity.ActiveReports.Data.OleDBDataSource();
C# code. Paste INSIDE the ReportStart event. Copy Code
rpt = new rptSub();

Show To add code to assign a data source for the Child Report (rptSub)

  1. Back in design view of the Parent report (rptMain), double-click the detail section. This creates the Detail_Format event handler.
  2. Add code to the handler to:
    • Set the connection string for the OleDBDataSource for the subreport
    • Set the SQL query for the new data source and pass in the current record's CategoryID
    • Set the data source of the subreport to the data source
    • Assign rptSub to the SubReport control

Show To write the code in Visual Basic

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
childDataSource.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
childDataSource.SQL = "SELECT * FROM Products WHERE CategoryID = " + Me.txtCategoryID1.Value.ToString
rpt.DataSource = childDataSource
SubReport1.Report = rpt

Show To write the code in C#

C# code. Paste INSIDE the Format event. Copy Code
childDataSource.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)this.DataSource).ConnectionString;
childDataSource.SQL = "SELECT * FROM Products WHERE CategoryID = " + this.txtCategoryID1.Value.ToString();
rpt.DataSource = childDataSource;
SubReport1.Report = rpt;

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Chart

Chart
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart

Glossary Item Box

This section contains the following walkthroughs that fall under the Chart category.

Bar Chart
This walkthrough demonstrates how to create a bar chart which compares items across categories.
3D Pie Chart
This walkthrough demonstrates how to a three dimensional pie chart which shows how the percentage of each data item contributes to a total percentage.
Financial Chart
This walkthrough demonstrates how to create a financial chart which lets you plot high, low, opening, and closing prices.
Unbound Chart
This walkthrough demonstrates how to create a simple unbound chart.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Bar Chart

Bar Chart
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > Bar Chart

Glossary Item Box

Show All Show All
Hide All Hide All

Bar charts are useful in comparing items across categories. This walkthrough illustrates how to create a simple bar chart using the ActiveReports chart control.

The walkthrough is split up into the following activities:

  • Adding a chart control to the report
  • Setting a data source for the chart
  • Setting the chart's properties
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at
[User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at run time.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as BarChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To add the Chart control to the report

  1. From the toolbox, drag the Chart data region to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  4. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 3.5 in
  5. In the Report Explorer, select Detail1 and go to the properties window to set the Height property to 3.5.

Show To connect the Chart to a data source

  1. Select the Chart control and at the bottom of the Properties window, select the Data Source command. See Properties Window for further details on accessing commands.
    Tip: If the verb is not visible, right-click an empty space in the Properties Window and select Commands to display verbs.
  2. In the Chart DataSource dialog box that appears, click the Build button.
  3. In the Data Link Properties window, select Microsoft Jet 4.0 OLE DB Provider and click the Next button.
  4. Click the ellipsis button (...) to browse to the Northwind database. Click Open once you have selected the file.
  5. Click the OK button to close the window and fill in the Connection String.
  6. In the Query field, enter the following SQL query.
    SQL Query Copy Code
    SELECT ShipCountry, SUM(Freight) AS FreightSum FROM Orders GROUP BY ShipCountry
  7. Click OK to save the data source.

Show To configure the appearance of the Chart

  1. Select the Chart control and at the bottom of the Properties window, select the Customize command. See Properties Window for further details on accessing commands.
  2. In the Chart Designer dialog that appears set the following.

    Show Chart Areas

    1. Click the Axes bar on the left to expand it.
    2. Click Axis X, and on the Common tab in the pane to the right, type Country in the Title textbox and set the Font size to 12.
    3. On the Labels tab, select the Staggered Labels checkbox to avoid overlapping labels and set the Text angle property to 45.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink
    4. Click Axis Y on the left, and on the Common tab in the pane to the right, type Freight in the Title textbox and set the Font size to 12.

    Show Titles

    1. Click the Titles bar on the left to expand it. In the list of titles, the header is selected by default.
    2. In the Caption textbox, type Simple Bar Chart and increase the Font size to 14.
    3. In the list of titles to the left, select the footer and delete it by clicking the Delete icon on top of the list.

    Show Series

    1. Click the Series bar on the left. The Series1 is selected by default.
    2. In the Data Binding box, set X (Name) to ShipCountry, and set Y to FreightSum.
    3. In the list of series to the left, select Series2 and Series3 and delete them by clicking the Delete icon on top of the list.

    Show Legend

    1. Click the Legend bar on the left to expand it. The defaultLegend is selected by default.
    2. On the Common tab, clear the Visible checkbox to hide the legend.
  3. Click Finish to exit the Chart Designer.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


3D Pie Chart

3D Pie Chart
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > 3D Pie Chart

Glossary Item Box

Show All Show All
Hide All Hide All

Pie charts are useful in showing how the percentage of each data item contributes to the total. This walkthrough illustrates how to create a three dimensional pie chart.

The walkthrough is split up into the following activities:

  • Adding a chart control to the report
  • Adding a series and data points to the chart
  • Setting the chart's properties

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as 3DPieChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To add the Chart control to the report

  1. From the toolbox, drag the Chart data region to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0in
    Size | 6.5, 3.5in
  4. In the Report Explorer, select Detail1 and go to the properties window to set the Height property to 3.5.
  5. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.

Show To add a series and data points to the Chart

  1. With the chart control selected, go to the Properties window and click the Series (Collection) property , then click the ellipsis button (...) that appears.
  2. In the Series Collection Editor that appears, Series1 is selected by default. There, under Series1 properties, change the following.
    Property Name | Property Value
    ColorPalette | Confetti
    Type | Doughnut3D
  3. Click the Points (Collection) property, then click the ellipsis button that appears.
  4. In the DataPoint Collection that appears, click the Add button to add a data point.
  5. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Figs
    YValues | 19
    Properties>ExplodeFactor | 0.5
  6. Click the Add button to add another data point.
  7. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Raspberries
    YValues | 15
  8. Click the Add button to add another data point.
  9. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Blueberries
    YValues | 37
  10. Click the Add button to add another data point.
  11. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Bananas
    YValues | 21
  12. Click OK to save the data points and return to the Series Collection Editor.
  13. In the Series Collection Editor under Members, select Series2 and Series3 and click the Remove button.
  14. Click OK to save the changes and return to the report design surface.

Show To configure the appearance of the Chart

  1. With the chart control selected, go to the Properties window and click the ChartAreas (Collection) property and then click the ellipsis button that appears.
  2. In the ChartArea Collection Editor that appears, expand the Projection property node and set the VerticalRotation property to 50. This allows you to see more of the top of the pie.
  3. Click OK to return to the report design surface.
  4. With the chart control highlighted, go to the Properties window and click the Titles (Collection) property and then click the ellipsis button that appears.
  5. In the Title Collection Editor that appears, under header properties, set the following properties.
    Property Name | Property Value
    Text | 3D Pie Chart
    Font Size | 14
  6. Under Members, select the footer and click the Remove button.
  7. Click OK to return to the report design surface.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Financial Chart

Financial Chart
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > Financial Chart

Glossary Item Box

Show All Show All
Hide All Hide All

Financial charts are useful for displaying stock information using High, Low, Open and Close values. This walkthrough illustrates how to create a Candle chart.

The walkthrough is split up into the following activities:

  • Adding a chart control to the report
  • Adding a series and data points to the chart
  • Setting the chart's properties

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as FinancialChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To add the Chart control to the report

  1. From the toolbox, drag the Chart data region to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0in
    Size | 6.5, 3.5in
  4. In the Report Explorer, select Detail1 and go to the properties window to set the Height property to 3.5.On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.

Show To add a series and data points to the Chart

  1. With the chart control selected, go to the Properties window and click the Series (Collection) property and then click the ellipsis button.
  2. In the Series Collection Editor that appears, Series1 is selected by default. There, under Series1 properties, change the following.
    Property Name | Property Value
    Type | Candle
    Properties>BodyDownswingBackdrop | (Default)
    Properties>BodyDownswingBackdrop>Color | Fuchsia
    Properties>BodyUpswingBackdrop | (Default)
    Properties>BodyUpswingBackdrop>Color | DarkViolet
    Properties>BodyWidth | 5
    Properties>WickLine | (Default)
    Legend | (none)
  3. Click the Points (Collection) property, then click the ellipsis button that appears.
  4. In the DataPoint Collection window that appears, click Add to add a data point and set its YValues property to 99; 37; 53; 88.
    Note: The first Y value is the high figure or top of the wick; the second is the low figure, or bottom of the wick; the third is the opening figure; the fourth is the closing figure. If the fourth figure is higher than the third, the candle is DarkViolet, the BodyUpswingBackdrop.
  5. Click Add to add another data point and set its YValues property to 115; 22; 101; 35.
  6. Click Add to add another data point, and set its YValues property to 87; 1; 7; 80.
  7. Click Add to add another data point, and set its YValues property to 63; 14; 57; 25.
  8. Click Add to add another data point, and set its YValues property to 130; 25; 25; 120.
  9. Click OK to save the data points and close the window.
  10. In the Series Collection Editor under Members, select Series2 and Series3 and click the Remove button.
  11. Click OK to return to the report design surface.

Show To configure the appearance of the Chart

  1. With the chart control selected, go to the Properties window and click the ChartAreas (Collection) property and then click the ellipsis button that appears.
  2. In the ChartArea Collection Editor that appears, under defaultArea properties, click the Axes (Collection) property, then click the ellipsis button that appears.
  3. In the AxisBase Collection Editor that appears, set the following properties.

    Show AxisBase

    1. Under AxisX properties, in the Title property delete the default text.
    2. Click the Labels (Collection) property, then click the ellipsis button that appears. This is where you add the labels that appear along the X axis, the line across the bottom of the chart.
    3. In the Array Data Editor that appears, enter the following into the editor, each item on a separate line:
      • Monday
      • Tuesday
      • Wednesday
      • Thursday
      • Friday
    4. Click the OK button to return to the AxisBase Collection Editor.
    5. Under Members, select the AxisY member, and under AxisY properties set the following properties.
      Property Name | Property Value
      MajorTick>Step | 10
      LabelsVisible | True
      Min | 0
      Title | $,000
    6. Click OK to return to the ChartArea Collection Editor.
  4. Click OK to return to the report design surface and see the changes reflected in the chart.
  5. With the chart control selected, go to the Properties window and click the Titles (Collection) property and then click the ellipsis button that appears.
  6. In the Title Collection Editor that appears, set the following properties.

    Show Titles

    1. Under header properties, set the Text property to Candle Chart.
    2. Expand the Font property and set Font Size to 14.
    3. Under Members, select footer and click the Remove button.

  7. Click OK to return to the report design surface.
  8. With the Chart control selected, go to the Properties window and click the Legends (Collection) property and then click the ellipsis button that appears.
  9. In the Legend Collection Editor that appears, set the following properties.

    Show Legends

    1. In the Properties window, set the Visible property to False.
    2. Click OK to return to the report design surface and see the completed chart.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Unbound Chart

Unbound Chart
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > Unbound Chart

Glossary Item Box

Show All Show All
Hide All Hide All

The Chart control allows you to bind charts to any type of data source, including arrays. You can create a chart without setting its data source and load the data into the control at run time. This walkthrough illustrates how to create a simple unbound chart.

The walkthrough is split up into the following activities:

  • Adding the chart control to the report and setting chart properties
  • Adding code to create the chart at run time
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at run time.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as UnboundChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To add the Chart control to the report

  1. From the toolbox, drag the Chart data region to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0in
    Size | 6.5, 3.5in
  4. In the Report Explorer, select Detail and go to the properties window to set the Height property to 3.5.
  5. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.

Show To configure the appearance of the Chart

  1. Select the Chart control and at the bottom of the Properties window, select the Customize command. See Properties Window for further details on accessing commands.
    Tip: If the verb is not visible, right-click an empty space in the Properties Window and select Commands to display verbs.
  2. In the ChartAreas view which displays by default, click the Axes bar to expand it.
  3. Click Axis X, and on the Common tab in the pane to the right, type Company Name in the Title textbox and set the font size to 12.
  4. Click Axis Y on the left, and on the Common tab in the pane to the right, type Freight in US$ in the Title textbox and increase the Font size to 12.
  5. Click the Titles bar on the left. In the list of titles, header is selected by default.
  6. On the Title properties page, type Unbound Chart in the Caption textbox and set the Font size to 14.
  7. Under Titles, select the footer and delete it by clicking the Delete icon on top of the list.
  8. Click the Series bar on the left.
  9. Under Series, select Series1, Series2 and Series3 and delete them by clicking the Delete icon on top of the list.
  10. Click the Legends bar on the left. The defaultLegend is selected by default.
  11. On the Common page, clear the Visible checkbox to hide the legend.
  12. Click the Finish button to exit the Chart Designer.

Back on the design surface of the report, the chart appears empty except for the title.

Show To add the code to create a chart at run time chart in Visual Basic or C#

Double-click the gray area below the report. This creates an event-handling method for rptUnboundChart's ReportStart event. Add code to the handler to:

  • Create the series
  • Create the dataset
  • Set the chart properties
  • Angle the labels to avoid overlap

The following examples show what the code for the methods look like in Visual Basic.NET and C#.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
'create the series
Dim series As New GrapeCity.ActiveReports.Chart.Series
series.Type = Chart.ChartType.Bar3D

'connection string and data adapter
Dim dbPath As String = "C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.MDB"
Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source= " + dbPath"
Dim da As New System.Data.OleDb.OleDbDataAdapter("SELECT * from Orders WHERE OrderDate < #08/17/1994#", connString)

'create the dataset
Dim ds As New DataSet
da.Fill(ds, "Orders")

'set chart properties
Me.ChartControl1.DataSource = ds
Me.ChartControl1.Series.Add(series)
Me.ChartControl1.Series(0).ValueMembersY = ds.Tables("Orders").Columns(7).ColumnName
Me.ChartControl1.Series(0).ValueMemberX = ds.Tables("Orders").Columns(8).ColumnName

'angle the labels to avoid overlapping
Me.ChartControl1.ChartAreas(0).Axes(0).LabelFont.Angle = 45

Show To write the code in C#

C# code. Paste INSIDE the ReportStart event. Copy Code
//create the series
GrapeCity.ActiveReports.Chart.Series series = new GrapeCity.ActiveReports.Chart.Series();
series.Type = GrapeCity.ActiveReports.Chart.ChartType.Bar3D;

//connection string and data adapter
string dbPath = "C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.MDB";
string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source= " + dbPath;
System.Data.OleDb.OleDbDataAdapter da = new System.Data.OleDb.OleDbDataAdapter
("SELECT * from Orders WHERE OrderDate < #08/17/1994#", connString);

// create the dataset
System.Data.DataSet ds = new System.Data.DataSet();
da.Fill(ds, "Orders");

// set chart properties
this.chartControl1.DataSource = ds;
this.chartControl1.Series.Add(series);
this.chartControl1.Series[0].ValueMembersY = ds.Tables["Orders"].Columns[7].ColumnName;
this.chartControl1.Series[0].ValueMemberX = ds.Tables["Orders"].Columns[8].ColumnName;

// angle the labels to avoid overlapping
this.chartControl1.ChartAreas[0].Axes[0].LabelFont.Angle = 45;

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Export

Export
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Export

Glossary Item Box

This section contains the following walkthroughs that fall under the Export category.

Custom Web Exporting (Std Edition)
This walkthrough demonstrates how to set up report custom exporting to PDF, Excel, TIFF, RTF, and plain text formats.
Custom HTML Outputter
This walkthrough demonstrates how to create a custom HTML outputter for your ActiveReports ASP.NET Web Application.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom Web Exporting (Std Edition)

Custom Web Exporting (Std Edition)
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Export > Custom Web Exporting (Std Edition)

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports provides components that allow you to set up report custom exporting to PDF, Excel, TIFF, RTF, and plain text formats. You can similarly export to HTML, or you can create a custom HTML outputter.

Show To add a report and export references to the Web project

  1. From the View menu, select Component Designer to go to the design view of the aspx file.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item window that appears, select the ActiveReports 13 Section Report (xml-based) template, set the report's name to SectionReport1, and click the Add button.
  4. From the Project menu, select Add Reference.
  5. In the Reference Manager dialog that appears, select the following references and click OK to add them to your project.
    GrapeCity.ActiveReports.Export.Pdf
    GrapeCity.ActiveReports.Export.Html
    GrapeCity.ActiveReports.Export.Excel
    GrapeCity.ActiveReports.Export.Word
    GrapeCity.ActiveReports.Export.Xml
    GrapeCity.ActiveReports.Export.Image
  6. Design your report.

Show To add code to the Web Form to export a report to PDF

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim PdfExport1 As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
PdfExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "application/pdf"
Response.AddHeader("content-disposition", "attachment;filename=MyExport.pdf")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();

rpt.Run();
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport pdfExport1 = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
pdfExport1.Export(rpt.Document, m_stream);
Response.ContentType = "application/pdf";
Response.AddHeader("content-disposition", "inline;filename=MyExport.pdf");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

Note: To use the one-touch printing option, add the following to the code above.

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
pdfExport1.Options.OnlyForPrint = True
C# code. Paste INSIDE the Page Load event. Copy Code
pdfExport1.Options.OnlyForPrint = true;

Show To add code to the Web Form to export a report to Excel

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim XlsExport1 As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport
XlsExport1.MinColumnWidth = 0.5
XlsExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "application/vnd.ms-excel"
Response.AddHeader("content-disposition", "inline; filename=MyExport.xls")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport XlsExport1 = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
XlsExport1.MinColumnWidth = 0.5f;
XlsExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "application/vnd.ms-excel";
Response.AddHeader("content-disposition","inline; filename=MyExport.xls");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

Show To add code to the Web Form to export a report to TIFF

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader(Server.MapPath("\SectionReport1.rpx"))
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim TiffExport1 As New GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport
Me.TiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
Me.TiffExport1.Export(rpt.Document, m_stream)m_stream.Position = 0
Response.ContentType = "image/tiff"
Response.AddHeader("content-disposition", "inline; filename=MyExport.tiff")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport tiffExport1 = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
tiffExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "image/tiff";
Response.AddHeader("content-disposition","inline; filename=MyExport.tiff");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

Show To add code to the Web Form to export a report to RTF

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim RtfExport1 As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
RtfExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "application/msword"
Response.AddHeader("content-disposition", "inline; filename=MyExport.rtf")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Word.Section.RtfExport rtfExport1  = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
rtfExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "application/msword";
Response.AddHeader("content-disposition","inline; filename=MyExport.rtf");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

Show To add code to the Web Form to export a report to Plain Text

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim TextExport1 As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
TextExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "text/plain"
Response.AddHeader("content-disposition", "attachment; filename=MyExport.txt")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Xml.Section.TextExport textExport1 = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport ();
textExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "text/plain";
Response.AddHeader("content-disposition", "attachment; filename=MyExport.txt");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

Show To run the project

Press F5 to run the project.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Custom HTML Outputter

Custom HTML Outputter
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Export > Custom HTML Outputter

Glossary Item Box

Show All Show All
Hide All Hide All

You can create a custom HTML outputter for your ActiveReports ASP.NET Web Application.

Note: You cannot create a custom HTML outputter for a page report because the html rendering extension does not support the custom output formatter.

This walkthrough is split up into the following activities:

  • Creating a public class for the HTML outputter
  • Adding code to create the Html Export object and export the report
  • Adding a folder for report output

Show To create a public class for the HTML outputter

  1. In the Solution Explorer window, right-click on your project name and select Add, then New Item.
  2. In the Add New Item dialog that appears, select Class.
  3. Change the name of the class to MyCustomHtmlOutputter and click the Add button.
  4. This opens the code view of the class file where you can add the code needed to create the public class.
  5. For C# code, add the IOutputHtml interface to MyCustomHtmlOutputter class.
    C# code. Copy Code
    public class MyCustomHtmlOutputter: IOutputHtml

The following example shows what the complete code for the method looks like.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste JUST ABOVE the class. Copy Code
Imports System
Imports System.IO
Imports System.Web
Imports System.Text
Imports GrapeCity.ActiveReports
Imports GrapeCity.ActiveReports.Export.Html
Visual Basic.NET code. Paste INSIDE the class. Copy Code
Implements IOutputHtml
'The http context of the request.
Private context As System.Web.HttpContext = Nothing
'The directory in which to save filename--this ensures that the filename
'is unique.
Private dirToSave As System.IO.DirectoryInfo = Nothing
Public mainPage As String = ""
Public Sub New(ByVal context As System.Web.HttpContext)
If context Is Nothing Then
Throw New ArgumentNullException("context")
End If
Me.context = context
Dim dirName As String = context.Server.MapPath("ReportOutput")
Me.dirToSave = New DirectoryInfo(dirName)
End Sub
#Region "Implementation of IOutputHtml"
Public Function OutputHtmlData(ByVal info As HtmlOutputInfoArgs) As String Implements IOutputHtml.OutputHtmlData
Dim temp As String = ""
Select Case info.OutputKind
Case HtmlOutputKind.BookmarksHtml
Case HtmlOutputKind.FramesetHtml
temp = Me.GenUniqueFileNameWithExtension(".html")
Dim fs As New FileStream(temp, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
Case HtmlOutputKind.HtmlPage
'Store the name of the main page so we can redirect the
'browser to it
Me.mainPage = Me.GenUniqueFileNameWithExtension(".html")
Dim fs As New FileStream(Me.mainPage, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return Me.mainPage
Case HtmlOutputKind.ImageJpg
'Create a file with a .jpg extension:
temp = Me.GenUniqueFileNameWithExtension(".jpg")
Dim fs As New FileStream(temp, FileMode.CreateNew)
fs = File.Create(temp)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
Case HtmlOutputKind.ImagePng
'Create a file with a .png extension:
temp = Me.GenUniqueFileNameWithExtension(".png")
Dim fs As New FileStream(temp, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
Case Else
'Default to html:
temp = Me.GenUniqueFileNameWithExtension(".html")
Dim fs As New FileStream(temp, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
End Select
End Function Public Sub Finish() Implements IOutputHtml.Finish
End Sub
#End Region
Private Sub WriteStreamToStream(ByVal sourceStream As Stream, ByVal targetStream As Stream)
'Find the size of the source stream:
Dim size As Integer = CType(sourceStream.Length, Integer)
'Create a buffer that same size
Dim buffer(size) As Byte
'Move the source stream to the beginning
sourceStream.Seek(0, SeekOrigin.Begin)
'Copy the sourceStream into our buffer
sourceStream.Read(buffer, 0, size)
'Write out the buffer to the target stream
targetStream.Write(buffer, 0, size)
End Sub
Private Function GenUniqueFileNameWithExtension(ByVal extensionWithDot As String) As String
Dim r As New System.Random()
Dim unique As Boolean = False
Dim filePath As String = ""
Dim iRandom As Integer = 0
'Generate a random name until it's unique
While Not unique
iRandom = r.Next()
'Build the full filename
Dim sb = New StringBuilder()
sb.Append(Me.dirToSave.FullName)
sb.Append(Path.DirectorySeparatorChar)
sb.Append(iRandom.ToString())
sb.Append(extensionWithDot)
filePath = sb.ToString()
If File.Exists(filePath) = False Then
unique = True
Else
unique = False
End If
End While
Return filePath
End Function
End Class

Show To write the code in C#

C# code. Paste JUST ABOVE the class. Copy Code
using System;
using System.IO;
using System.Web;
using System.Text;
using GrapeCity.ActiveReports;
using GrapeCity.ActiveReports.Export.Html;
C# code. Paste INSIDE the class. Copy Code
   //The http context of the request
   private System.Web.HttpContext context = null;
    //The directory in which to save filename--this ensures that the filename
    //is unique.
   private System.IO.DirectoryInfo dirToSave = null;
   public string mainPage = "";
   public MyCustomHtmlOutputter(System.Web.HttpContext context)
   {
      if(context == null)
      {
        throw new ArgumentNullException("context");
          }
        this.context = context;
        string dirName = context.Server.MapPath("ReportOutput");
        this.dirToSave = new DirectoryInfo(dirName);
    }

#region Implementation of IOutputHtml
public string OutputHtmlData(HtmlOutputInfoArgs info)
{
   string temp = "";
   switch(info.OutputKind)
   {
      case HtmlOutputKind.BookmarksHtml:
      case HtmlOutputKind.FramesetHtml:
      {
        temp = this.GenUniqueFileNameWithExtension(".html");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }

      case HtmlOutputKind.HtmlPage:
      {
         //Store the name of the main page so we can
         //redirect the browser to it
        this.mainPage = this.GenUniqueFileNameWithExtension(".html");
        FileStream fs = File.Create(this.mainPage);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return this.mainPage;
      }

      case HtmlOutputKind.ImageJpg:
      {
         // Create a file with a .jpg extension:
         temp = this.GenUniqueFileNameWithExtension(".jpg");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }

      case HtmlOutputKind.ImagePng:
      {
        //Create a file with a .png extension:
        temp = this.GenUniqueFileNameWithExtension(".png");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }

      default:
      {
        //Default to html:
        temp = this.GenUniqueFileNameWithExtension(".html");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }
   }
}

public void Finish()
{
}
#endregion

private void WriteStreamToStream(Stream sourceStream, Stream targetStream)
{
   //Find the size of the source stream
   int size = (int)sourceStream.Length;

   //Create a buffer that same size
   byte[] buffer = new byte[size];

   //Move the source stream to the beginning
   sourceStream.Seek(0, SeekOrigin.Begin);

   //Copy the sourceStream into our buffer
   sourceStream.Read(buffer, 0, size);

   //Write out the buffer to the target stream
   targetStream.Write(buffer, 0, size);
}

private string GenUniqueFileNameWithExtension(string extensionWithDot)
{
    System.Random r = new Random();
    bool unique = false;
    string filePath = "";
    int iRandom = 0;
    //Generate a random name until it's unique
    while(!unique)
    {
       iRandom = r.Next();
       //Buld the full filename
       System.Text.StringBuilder sb = new System.Text.StringBuilder();
       sb.Append(this.dirToSave.FullName);
       sb.Append(Path.DirectorySeparatorChar);
       sb.Append(iRandom.ToString());
       sb.Append(extensionWithDot);
       filePath = sb.ToString();
       unique = !File.Exists(filePath);
     }
     return filePath;
  }

Show To add code to the Web Form to export to HTML

  1. Add an Section Report (Code-based) to the project, and name it rptCustHTML.
  2. Now add a Web form and double-click on the design view of the ASPX. This creates an event-handling method for the Web Form's Page Load event.
  3. Add the following code to the Page Load event.

The following example shows what the code for the method looks like.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event. Copy Code
Dim rpt As New rptCustHTML()
Try

rpt.Run(False)
Catch eRunReport As Exception
'If the report fails to run, report the error to the user

Response.Clear()
Response.Write("<h1>Error running report:</h1>")
Response.Write(eRunReport.ToString())
Return
End Try

'Buffer this page's output until the report output is ready.

Response.Buffer = True

'Clear any part of this page that might have already been buffered for output.

Response.ClearContent()

'Clear any headers that might have already been buffered (such as the content type

'for an HTML page)

Response.ClearHeaders()

'Tell the browser and the "network" that the resulting data of this page should be

'cached since this could be a dynamic report that changes upon each request.

Response.Cache.SetCacheability(HttpCacheability.NoCache)

'Tell the browser this is an Html document so it will use an appropriate viewer.

Response.ContentType = "text/HTML"

'Create the Html export object

Dim HtmlExport1 As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport()

Dim outputter As New MyCustomHtmlOutputter(Me.Context)
HtmlExport1.Export(rpt.Document, outputter, "")
Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage))

Show To write the code in C#

C# code. Paste INSIDE the Page Load event. Copy Code
   rptCustHTML rpt = new rptCustHTML();
   try
   {
      rpt.Run(false);
   }
   catch (Exception eRunReport)
   {
      //If the report fails to run, report the error to the user
      Response.Clear();
      Response.Write("<h1>Error running report:</h1>");
      Response.Write(eRunReport.ToString());
      return;
   }
   //Buffer this page's output until the report output is ready.
   Response.Buffer = true;

   //Clear any part of this page that might have already been buffered for output.
   Response.ClearContent();

   //Clear any headers that might have already been buffered (such as the content
   //type for an HTML page)
   Response.ClearHeaders();

   //Tell the browser and the "network" that the resulting data of this page should
   //be cached since this could be a dynamic report that changes upon each request.
   Response.Cache.SetCacheability(HttpCacheability.NoCache);

   //Tell the browser this is an Html document so it will use an appropriate viewer.
   Response.ContentType = "text/html";

   //Create the HTML export object
   GrapeCity.ActiveReports.Export.Html.Section.HtmlExport htmlExport1 = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();

   //Export the report to HTML in this session's webcache
   MyCustomHtmlOutputter outputter = new MyCustomHtmlOutputter(this.Context);
   htmlExport1.Export(rpt.Document, outputter, "");
   Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage));

Show To add a folder to the project for report output

  1. In the Solution Explorer, right-click your solution and select Add, then New Folder.
  2. Name the folder ReportOutput.
  3. Ensure that you have write permissions for this folder.
  4. To view the results in your Web browser, run the project.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Script

Script
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Script

Glossary Item Box

This section contains the following walkthroughs that fall under the Script category.

ActiveReports allows you to embed script in reports so that code becomes portable when you save a report layout to XML-based RPX format. This characteristic allows the options of stand-alone reporting and web reporting without the need to distribute related .vb or .cs files.

By embedding script when the report is saved as an RPX file, it can later by loaded, run and displayed directly to the viewer control without using the designer. Script can also be used in conjunction with RPX files to allow distributed reports to be updated without recompiling the Visual Studio project.

Script for Simple Reports
This walkthrough demonstrates how to embed script in a simple stand-alone report.
Script for Subreports
This walkthrough demonstrates how to embed script to pass a parameter to a subreport.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Script for Simple Reports

Script for Simple Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Script > Script for Simple Reports

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to use scripting to embed code in reports saved to the XML-based RPX file format. By embedding script in reports saved as RPX files, you can later load, run, and display reports directly in the viewer control without using the designer. This walkthrough illustrates how to include scripting in a simple report.

This walkthrough is split into the following activities:

  • Temporarily connecting the report to a data source
  • Adding controls to a report to display data
  • Adding scripting to supply data for the controls
  • Saving the report to an RPX file
Tip: For basic steps like adding a report to a Visual Studio project and viewing a report, please see the Basic Data Bound Reports walkthrough.
Note: This walkthrough uses the the Northwind database. By default, in ActiveReports, the NWind.mdb file is located in [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

When you have finished this walkthrough, you will have a report that looks similar to the following at design time and at run time.

Design-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptSimpleScript.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

Note: The following steps are just for convenience so that the fields list in the Report Explorer can be populated at design time.
  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM categories INNER JOIN products ON categories.categoryid =
products.categoryid ORDER BY products.categoryid, products.productid
  7. Click OK to save the data source and return to the report design surface.

Show To create a layout for the report

  1. Right-click the design surface of the report and select Insert then Group Header/Footer to add group header and footer sections to your report.
  2. Increase the group header section's height so that you have room to work.
  3. With the GroupHeader section selected, go to the Properties Window to set the following properties.
    Property Name | Property Value
    BackColor | LightBlue
    CanShrink | True
    DataField | CategoryName
    GroupKeepTogether | All
    KeepTogether | True
  4. From the toolbox, drag the following controls to the GroupHeader section and set the properties of each control as indicated.

    Show TextBox1

    Property Name | Property Value
    DataField | CategoryName
    Location | 0, 0 in
    Size | 6.5, 0.2 in
    BackColor | CadetBlue
    Font | Bold:True
    Font Size | 12

    Show TextBox2

    Property Name | Property Value
    DataField | Description
    Location | 0, 0.2 in
    Size | 6.5, 0.2 in
    BackColor | CadetBlue

    Show Label1

    Property Name | Property Value
    Text | Product Name
    Location | 0, 0.4 in
    Size | 1, 0.2 in
    Font | Bold:True

    Show Label2

    Property Name | Property Value
    Text | Units in Stock
    Location | 5.5, 0.4 in
    Size | 1, 0.2 in
    Font | Bold:True
    Alignment | Right
  5. From the toolbox, drag the following controls onto the detail section and set the properties of each as indicated.

    Show TextBox1

    Property Name | Property Value
    DataField | ProductName
    Location | 0, 0 in
    Size | 5.5, 0.2 in

    Show TextBox2

    Property Name | Property Value
    DataField | UnitsInStock
    Location | 5.5, 0 in
    Size | 1, 0.2 in
    Alignment | Right
  6. Click just below the fields to select the Detail section, and in the Properties Window, set the CanShrink property to True to eliminate white space in the rendered report.
  7. In the Detail section, select both TextBox1 and TextBox2, right-click and select Format Border.
    • Select DarkCyan in the color combo box.
    • Select the solid line in the Line Styles pane.
    • Click the bottom edge in the Preview pane.
    • Click the OK button to add a solid cyan line to the bottom edge of the text boxes.
  8. Increase the group footer section's height so that you have room to work.
  9. With the GroupFooter section selected, go to the properties window and set the following properties.
    Property Name | Property Value
    BackColor | PaleGreen
    CanShrink | True
  10. From the toolbox, drag the following controls to the GroupFooter Section and set the properties of each control as indicated.

    Show TextBox1

    Property Name | Property Value
    DataField | TotalLabel
    Location | 2.5, 0 in
    Size | 3, 0.2 in
    Font | Bold:True

    Show TextBox2

    Property Name | Property Value
    DataField | ProductName
    Location | 5.5, 0 in
    SummaryType | Subtotal
    SummaryFunc | Count
    SummaryRunning | Group
    SummaryGroup | GroupHeader1
    Alignment | Right

    Show Label1

    Property Name | Property Value
    Location | 0, 0.25 in
    Size | 6.5, 0.2 in
    BackColor | White (creates white space after the subtotal)
    Text
    Note: Delete the default text.

Show To add scripting to the report to supply data for the controls

  1. Click in the grey area below the report to select it, and in the Properties Window, change the ScriptLanguage property for the report to the scripting language you want to use. The default setting is C#.
  2. Click the Script tab located at the bottom edge of the report designer to access the scripting editor. Add the scripting code.

The following example shows what the scripting code looks like.

Warning: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

Show To write the script in Visual Basic.NET.

Visual Basic.NET script. Paste in the script editor window. Copy Code
Private Shared m_reader As System.Data.OleDb.OleDbDataReader
Private Shared m_cnn As System.Data.OleDb.OleDbConnection

Public Sub ActiveReport_ReportStart()
  'Set up a data connection for the report
  rpt.DataSource = ""
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb"
  Dim sqlString As String = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY products.categoryid, products.productid"

  m_cnn = new System.Data.OleDb.OleDbConnection(connString)
  Dim m_Cmd As System.Data.OleDb.OleDbCommand = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn)

  If m_cnn.State = System.Data.ConnectionState.Closed Then
     m_cnn.Open
  End If
  m_reader = m_Cmd.ExecuteReader
End Sub

Public Sub ActiveReport_DataInitialize()
  'Add data fields to the report
  rpt.Fields.Add("CategoryID")
  rpt.Fields.Add("CategoryName")
  rpt.Fields.Add("ProductName")
  rpt.Fields.Add("UnitsInStock")
  rpt.Fields.Add("Description")
  rpt.Fields.Add("TotalLabel")
End Sub

Public Function ActiveReport_FetchData(ByVal eof As Boolean) As Boolean
  Try
    m_reader.Read
    'Populated the fields with data from the data reader
    rpt.Fields("CategoryID").Value = m_reader("categories.CategoryID")
    rpt.Fields("CategoryName").Value = m_reader("CategoryName")
    rpt.Fields("ProductName").Value = m_reader("ProductName")
    rpt.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
    rpt.Fields("Description").Value = m_reader("Description")
    'Concatenate static text with data
    rpt.Fields("TotalLabel").Value = "Total Number of " + m_reader("CategoryName")+ " Products:"
    eof = False
  Catch
    'If the end of the data file has been reached, tell the FetchData function
    eof = True
  End Try
 Return eof
End Function

Public Sub ActiveReport_ReportEnd()
  'Close the data reader and connection
  m_reader.Close
  m_cnn.Close
End Sub

Show To write the script in C#.

C# script. Paste in the script editor window. Copy Code
//C#
private static System.Data.OleDb.OleDbDataReader m_reader;
private static System.Data.OleDb.OleDbConnection m_cnn;

public void ActiveReport_ReportStart()
{
   //Set up a data connection for the report
   rpt.DataSource = "";
   string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb";
   string sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY products.categoryid, products.productid";
   m_cnn = new System.Data.OleDb.OleDbConnection(m_cnnString);
   System.Data.OleDb.OleDbCommand m_Cmd = new System.Data.OleDb.OleDbCommand(sqlString,m_cnn);

   if(m_cnn.State == System.Data.ConnectionState.Closed)
   {
      m_cnn.Open();
   }
   m_reader = m_Cmd.ExecuteReader();
}

public void ActiveReport_DataInitialize()
{
   //Add data fields to the report
   rpt.Fields.Add("CategoryID");
   rpt.Fields.Add("CategoryName");
   rpt.Fields.Add("ProductName");
   rpt.Fields.Add("UnitsInStock");
   rpt.Fields.Add("Description");
   rpt.Fields.Add("TotalLabel");
}

public bool ActiveReport_FetchData(bool eof)
{
   try
   {
     m_reader.Read();
     //Populated the fields with data from the data reader
     rpt.Fields["CategoryID"].Value = m_reader["categories.CategoryID"].ToString();
     rpt.Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
     rpt.Fields["ProductName"].Value = m_reader["ProductName"].ToString();
     rpt.Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
     rpt.Fields["Description"].Value = m_reader["Description"].ToString();
     //Concatenate static text with data
     rpt.Fields["TotalLabel"].Value = "Total Number of " + m_reader["CategoryName"].ToString() + " Products:";
     eof = false;
   }
   catch
   {
     //If the end of the data file has been reached, tell the FetchData function
     eof = true;
   }
   return eof;
}

public void ActiveReport_ReportEnd()
{
   //Close the data reader and connection
   m_reader.Close();
   m_cnn.Close();
}

Show To save the report to an XML-based RPX file

  1. From the Report menu, select Save Layout.
  2. In the Save dialog that appears, enter a name for the report, i.e. rptScript.rpx, and click the Save button.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Script for Subreports

Script for Subreports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Script > Script for Subreports

Glossary Item Box

Show All Show All
Hide All Hide All

ActiveReports allows you to use scripting to permit reports saved to an XML file to contain code. By including scripting when reports are saved into XML, the reports later can be loaded, run, and displayed directly to the viewer control without needing to use the designer.

This walkthrough illustrates how to use scripting when creating a subreport.

This walkthrough is split up into the following activities:

  • Temporarily connecting the main report to a data source
  • Connecting the subreport to a data source
  • Adding controls to each report to display data
  • Adding the scripting code for rptMain
  • Viewing the report
Tip: For basic steps like adding a report to a Visual Studio project and viewing a report, please see the Basic Data Bound Reports walkthrough.
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb.

When you have finished this walkthrough, you will have a report that looks similar to the following at design time and at run time.

Design-Time Layout (main report)

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout (main report)

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (xml-based) and in the Name field, rename the file as rptMain.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report to a data source

Note: The following steps are just for convenience so that the fields list in the Report Explorer can be populated at design time.
  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Orders INNER JOIN Customers ON Orders.CustomerID = Customers.CustomerID ORDER BY CompanyName, OrderDate
  7. Click OK to save the data source and return to the report design surface.

Show To add a report for the subreport

  1. From the Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (xml-based) and in the Name field, rename the file as rptSub.
  3. Click the Add button to open a new section report in the designer.
  4. Right-click the PageHeader or PageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  5. Click in the grey area below the report to select it, and in the Properties window, change the report's ShowParameterUI property to False. This prevents the subreport from requesting a parameter from the user.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the subreport to a data source

Note: The following steps are just for convenience so that the fields list in the Report Explorer can be populated at design time.
  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM [order details] inner join products on [order details].productid = products.productid
  7. Click OK to save the data source and return to the report design surface.

Show To create a layout for the main report

  1. Right-click the design surface of rptMain and select Insert then Group Header/Footer to add group header and footer sections to the report.
  2. In the Properties Window, make the following changes to the group header.
    Property Name | Property Value
    Name | ghCompanies
    BackColor | LemonChiffon
    CanShrink | True
    DataField | CompanyName
    GroupKeepTogether | All
    KeepTogether | True
  3. In the Report Explorer, expand the Fields node, then the Bound node. Drag the CompanyName field onto ghCompanies and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Size | 4, 0.2 in
    Location | 0, 0 in
    Font Bold | True
    Font Size | 12
  4. Right-click the design surface of rptMain and select Insert then Group Header/Footer to add the second group header and footer sections to the report.
  5. In the Properties Window, make the following changes to the second group header.
    Property Name | Property Value
    Name | ghOrders
    BackColor | LightYellow
    CanShrink | True
    DataField | OrderDate
    GroupKeepTogether | All
    KeepTogether | True
  6. From the toolbox, drag three TextBox controls onto ghOrders and set the properties for each control as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | OrderDate
    Location | 1.1, 0 in
    Size | 1, 0.2 in
    OutputFormat | MM/dd/yy

    Show TextBox2

    Property Name | Property Value
    DataField | RequiredDate
    Location | 3.5, 0 in
    Size | 1, 0.2 in
    OutputFormat | MM/dd/yy

    Show TextBox3

    Property Name | Property Value
    DataField | ShippedDate
    Location | 5.5, 0 in
    Size | 1, 0.2 in
    OutputFormat | MM/dd/yy
    Alignment | Right
  7. From the toolbox, drag three Label controls onto ghOrders and set the properties for each control as follows.

    Show Label1

    Property Name | Property Value
    Location | 0, 0 in
    Size | 1, 0.2 in
    Text | Ordered:
    Font | Bold:True

    Show Label2

    Property Name | Property Value
    Location | 2.5, 0 in
    Size | 1, 0.2 in
    Text | Required:
    Font | Bold:True

    Show Label3

    Property Name | Property Value
    Location | 4.8, 0 in
    Size | 0.65, 0.2 in
    Text | Shipped:
    Font | Bold:True
  8. Select the Detail section and in the Properties window, set the CanShrink property to True.
  9. From the toolbox, drag the Subreport control onto the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    ReportName | full project path\rptSub.rpx
    Name | SubReport1
    Size | 6.5, 1 in
    Location | 0, 0 in

Show To create a layout for the subreport

  1. Right-click the design surface of rptSub and select Insert then Group Header/Footer to add group header and footer sections to the report.
  2. In the Properties window, make the following changes to the group header.
    Property Name | Property Value
    Name | ghOrderDetails
    BackColor | LightSteelBlue
    CanShrink | True
    DataField | OrderID
  3. From the toolbox, drag four label controls to ghOrderDetails and set the properties for each label as follows.

    Show Label1

    Property Name | Property Value
    Location | 0, 0 in
    Text | Product Name
    Font | Bold:True
    Alignment | Left

    Show Label2

    Property Name | Property Value
    Location | 3.25, 0 in
    Text | Quantity
    Font | Bold:True
    Alignment | Right

    Show Label3

    Property Name | Property Value
    Location | 4.4, 0 in
    Text | Unit Price
    Font | Bold:True
    Alignment | Right

    Show Label4

    Property Name | Property Value
    Location | 5.5, 0 in
    Text | Discount
    Font | Bold:True
    Alignment | Right
  4. From the toolbox, drag four Line controls to ghOrderDetails and set the properties for each line as follows.

    Show Line1

    Property Name | Property Value
    X1 | 3.2
    X2 | 3.2
    Y1 | 0
    Y2 | 0.2

    Show Line2

    Property Name | Property Value
    X1 | 4.3
    X2 | 4.3
    Y1 | 0
    Y2 | 0.2

    Show Line3

    Property Name | Property Value
    X1 | 5.45
    X2 | 5.45
    Y1 | 0
    Y2 | 0.2

    Show Line4

    Property Name | Property Value
    X1 | 0
    X2 | 6.5
    Y1 | 0.2
    Y2 | 0.2
  5. Click the Detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    BackColor | Gainsboro
    CanShrink | True
  6. From the toolbox, drag four TextBox controls onto onto the Detail section and set the properties as follows.

    Show TextBox1

    Property Name | Property Value
    DataField | ProductName
    Location | 0, 0 in
    Size | 3.15, 0.2 in
    Alignment | Left

    Show TextBox2

    Property Name | Property Value
    DataField | Quantity
    Location | 3.25, 0 in
    Size | 1, 0.2 in
    Alignment | Right

    Show TextBox3

    Property Name | Property Value
    DataField | Products.UnitPrice
    Location | 4.4, 0 in
    Size | 1, 0.2 in
    Alignment | Right
    OutputFormat | Currency

    Show TextBox4

    Property Name | Property Value
    DataField | Discount
    Location | 5.5, 0 in
    Size | 1, 0.2 in
    Alignment | Right
    OutputFormat | Percentage
  7. From the toolbox, drag four Line controls to the Detail section and set the properties as follows.

    Show Line5

    Property Name | Property Value
    X1 | 3.2
    X2 | 3.2
    Y1 | 0
    Y2 | 0.2

    Show Line6

    Property Name | Property Value
    X1 | 4.3
    X2 | 4.3
    Y1 | 0
    Y2 | 0.2

    Show Line7

    Property Name | Property Value
    X1 | 5.45
    X2 | 5.45
    Y1 | 0
    Y2 | 0.2

    Show Line8

    Property Name | Property Value
    X1 | 0
    X2 | 6.5
    Y1 | 0.2
    Y2 | 0.2

Show To embed script in the main report

  1. Change the ScriptLanguage property for the report to the appropriate scripting language. The default setting is C#.
  2. Click the Script tab located below the report designer to access the scripting editor.
  3. Embed script to set the data source for the main report and pass data into the subreport.

The following example shows what the script looks like.

Show To write the script in Visual Basic.NET

Visual Basic.NET script. Paste in the script editor window. Copy Code
Dim rptSub As GrapeCity.ActiveReports.SectionReport
Sub ActiveReport_ReportStart
  'Create a new instance of the generic report
  rptSub = new GrapeCity.ActiveReports.SectionReport()
  'Load the rpx file into the generic report
  rptSub.LoadLayout(me.SubReport1.ReportName)
  'Connect data to the main report
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb;Persist Security Info=False"
  Dim sqlString As String = "Select * from orders inner join customers on orders.customerid = customers.customerid order by CompanyName,OrderDate"
  Dim ds As new GrapeCity.ActiveReports.Data.OleDBDataSource()
  ds.ConnectionString = connString
  ds.SQL = sqlString
  rpt.DataSource = ds
End Sub

Sub Detail_Format
  Dim rptSubCtl As GrapeCity.ActiveReports.SubReport = me.SubReport1
  Dim childDataSource As New GrapeCity.ActiveReports.Data.OleDBDataSource()
  childDataSource.ConnectionString = CType(rpt.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
  'Set a parameter in the SQL query
  childDataSource.SQL = "Select * from [order details] inner join products on [order details].productid = products.productid where [order details].orderid = <%OrderID%>"
  'Pass the data to the subreport
  rptSub.DataSource = childDataSource
  'Display rptSub in the subreport control
  rptSubCtl.Report = rptSub
End Sub

Show To write the script in C#

C# code. Paste in the script editor window. Copy Code
GrapeCity.ActiveReports.SectionReport rptSub;
public void Detail_Format()
{
  GrapeCity.ActiveReports.SectionReportModel.SubReport rptSubCtl = this.SubReport1;
  GrapeCity.ActiveReports.Data.OleDBDataSource childDataSource = new GrapeCity.ActiveReports.Data.OleDBDataSource();
  childDataSource.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource) rpt.DataSource).ConnectionString;
  //Set a parameter in the SQL query
  childDataSource.SQL = "Select * from [order details] inner join products on [order details].productid = products.productid where [order details].orderid = <%OrderID%>";
  //Pass the data to the subreport
  rptSub.DataSource = childDataSource;
  //Display rptSub in the subreport control
  rptSubCtl.Report = rptSub;
}

public void ActiveReport_ReportStart()
{
  //Create a new instance of the generic report
  rptSub = new GrapeCity.ActiveReports.SectionReport();
  //Load the rpx file into the generic report
  rptSub.LoadLayout(this.SubReport1.ReportName);
  //Connect data to the main report
  string connString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb;Persist Security Info=False";
  string sqlString = "Select * from orders inner join customers on orders.customerid = customers.customerid order by CompanyName,OrderDate";
  GrapeCity.ActiveReports.Data.OleDBDataSource ds = new GrapeCity.ActiveReports.Data.OleDBDataSource();
  ds.ConnectionString = connString;
  ds.SQL = sqlString;
  rpt.DataSource = ds;
}

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information on how to load the xml-based section report onto the viewer.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Parameters

Parameters
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Parameters

Glossary Item Box

This section contains the following walkthroughs that fall under the Parameter category.

Using Parameters in Sub Reports
This walkthrough demonstrates how to link a report with a SubReport using parameters.
Parameters for Charts
This walkthrough demonstrates how to link a report with a chart using parameters.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Using Parameters in Sub Reports

Using Parameters in Sub Reports
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Parameters > Using Parameters in Sub Reports

Glossary Item Box

Show All Show All
Hide All Hide All

Using parameters in SubReport, you can connect a SubReport to the parent report. By setting the parameter on the field that binds the parent report to SubReport, the parent report passes the data to display in SubReport through a parameter. This walkthrough illustrates the method to link the main report with a SubReport using parameters.

This walkthrough is split up into the following activities:

  • Adding a parent report and a SubReport to a Visual Studio project
  • Connecting the parent report to a data source
  • Connecting the SubReport to a data source using parameter
  • Adding controls to create layout of the parent report (rptParent)
  • Adding controls to create a layout of the child report (rptChild)
  • Adding code to embed the SubReport to the SubReport control in parent report
  • Adding code to set the ShowParametersUI property of SubReport to False.
  • Viewing the report
Note: This walkthrough uses tables from the NorthWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.
Caution: SubReports do not render PageHeader and PageFooter sections.

When you complete this walkthrough you get a layout that looks similar to the following:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptParent.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptChild.
  7. Click the Add button to open a second new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the parent report (rptParent) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following SQL query.
    SQL Query Copy Code
    Select * from suppliers order by country
  4. Click OK to save the data source and return to the report design surface.

Show To connect the child report (rptChild) to a data source using parameter

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following parameterized SQL query.
    SQL Query Copy Code
    SELECT * FROM products INNER JOIN categories ON products.categoryid = categories.categoryid WHERE Products.SupplierID = <%SupplierID%>
  4. Click OK to save the data source and return to the report design surface.

Show To create a layout for the parent report (rptParent)

  1. On the design surface, right click the PageHeader or PageFooter section and select Delete to remove the PageHeader/Footer pair.
  2. Right click on the design surface of the parent report and insert GroupHeader/Footer section pair.
  3. Click the GroupHeader section to select it and go to the Properties window to set the following properties.
    Property Name | Property Value
    Name | ghSuppliers
    DataField | Country
  4. From the toolbox, drag a TextBox control onto the groupHeader section and in the Properties window, set the properties as follows:
    Property Name | Property Value
    DataField | Country
    Name | txtCountry
    Text | Country
    Location | 0, 0
    Font | Name:Arial, Size:13pt, Bold:True
  5. Click the Detail section to select it and go to the Properties window to set the CanShrink property to True.
  6. From the Visual Studio toolbox, drag and drop the following controls onto the detail section of the report and in the Properties window, set their properties as given below:

    Show TextBox1

    Property Name | Property Value
    DataField | CompanyName
    Name | txtCompanyName
    Text | Company Name
    Location | 0.0625, 0.0625
    Size | 2.25, 0.2 in
    BackColor | Silver
    Font | Bold:True

    Show TextBox2

    Property Name | Property Value
    DataField | ContactName
    Name | txtContactName
    Text | Contact Name
    Location | 2.312, 0.0625
    Size | 1.708, 0.2 in
    BackColor | Silver
    Font | Bold:True

    Show TextBox3

    Property Name | Property Value
    DataField | Phone
    Name | txtPhone
    Text | Phone
    Location | 4.562, 0.0625
    Size | 1.542, 0.2 in
    BackColor | Silver
    Font | Bold:True

    Show SubReport

    Property Name | Property Value
    Name | Subreport1
    ReportName | ProductName
    Location | 0.0625, 0.312

Show To create a layout for the child report (rptChild)

  1. On the design surface, right click the PageHeader or PageFooter section and select Delete to remove the PageHeader/Footer pair.
  2. Right click on the design surface of the child report and insert GroupHeader/Footer section pair.
  3. Click the GroupHeader section to select it and go to the Properties window to set the following properties.
    Property Name | Property Value
    Name | ghProducts
    DataField | CategoryName
  4. From the toolbox, drag and drop a TextBox control onto the groupHeader section and in the Properties window, set the following properties.
    Property Name | Property Value
    DataField | CategoryName
    Name | txtCategoryName
    Text | Category Name
    Location | 0.0625, 0.0625
    Size | 2.042, 0.2 in
    ForeColor | Maroon
    Font | Bold:True
  5. Click the Detail section to select it and go to the Properties window to set the CanShrink property to True.
  6. From the toolbox, drag and drop a TextBox control onto the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | Product Name
    Location | 0.0625, 0.0625
    Size | 1.99, 0.2 in
    ForeColor | Red

Show To connect the child report (rptChild) to the SubReport control in parent report (rptParent)

  1. Double-click the gray area around the parent report (rptParent) to create an event-handling method for the ReportStart event.
  2. Add code like the following to the handler to create a new instance of the child report (rptChild).

    Show To write the code in Visual Basic

    Visual Basic.NET code. Paste JUST ABOVE the ReportStart event. Copy Code
    Dim rpt As rptChild
    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    rpt = New rptChild()

    Show To write the code in C#

    C# code. Paste JUST ABOVE the ReportStart event. Copy Code
    private rptChild rpt;
    C# code. Paste INSIDE the ReportStart event. Copy Code
    rpt = new rptChild();
  3. Double-click the detail section of the parent report (rptParent) to create a detail_Format event.
  4. Add code like the following to the handler to display a report in the SubReport control.

    Show To write the code in Visual Basic

    Visual Basic.NET code. Paste INSIDE the Format event. Copy Code
    Me.SubReport1.Report = rpt

    Show To write the code in C#

    C# code. Paste INSIDE the Format event. Copy Code
    this.subReport1.Report = rpt;

Show To set the ShowParametersUI property of SubReport to False

  1. Click the gray area around the child report (rptChild) and go to the Properties window to set the ShowParameterUI property to False.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Parameters for Charts

Parameters for Charts
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Parameters > Parameters for Charts

Glossary Item Box

Show All Show All
Hide All Hide All

Using parameters you can connect your report to the chart control. By setting the parameter on the field that connects the report to the chart, the report passes the data to display in the chart. This walkthrough illustrates how to link report with chart using parameters.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding controls to the report to display data
  • Connecting the Chart control to a data source using parameter
  • Setting the Chart's properties
  • Viewing the report.

When you complete this walkthrough you get a layout that looks similar to the following at run time:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink
Note: This topic uses table from the NorthWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data folder.

Show To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 13 Section Report (code-based) and in the Name field, rename the file as rptChartParams.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Show To connect the report (rptChartParams) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following SQL query.
    SQL Query Copy Code
    SELECT * FROM Products ORDER BY CategoryID, ProductName
  4. Click OK to save the data source and return to the report design surface.

Show To add controls to the report to display data

  1. On the design surface, right click the PageHeader or PageFooter section and select Delete to remove the PageHeader/Footer pair.
  2. Right click on the design surface and insert GroupHeader/Footer section pair.
  3. Click the GroupHeader section to select it and go to the Properties window to set the following properties:
    Property Name | Property Value
    Name | ghCategoryID
    DataField | CategoryID
    GroupKeepTogether | All
    Height | 5.65 inches
  4. Set Height property of Detail section to 0.23 inches and of GroupFooter section to 0 inch.
  5. From the Visual Studio toolbox, drag and drop the following controls onto the GroupHeader section and set their properties as given below:

    Show Label1

    Property Name | Property Value
    Name | lblCategoryID
    Text | CategoryID
    Location | 1.78, 0

    Show Label2

    Property Name | Property Value
    Name | lblProductName
    Text | Product Name
    Location | 0.23, 5.43

    Show Label3

    Property Name | Property Value
    Name | lblUnitsInStock
    Text | Inventory stock
    Location | 5, 5.43

    Show TextBox

    Property Name | Property Value
    DataField | CategoryID
    Name | txtCategoryID
    Text | CategoryID
    Location | 3.72, 0

    Show Chart

    Property Name | Property Value
    Name | ChartControl
    Location | 0, 0.313
    Size | 6.5, 4.66
  6. From the Visual Studio toolbox, drag and drop the following controls onto the detail section and set their properties as given below:

    Show TextBox1

    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | ProductName
    Location | 0.23, 0

    Show TextBox2

    Property Name | Property Value
    DataField | UnitsInStock
    Name | txtUnitsInStock
    Text | UnitsInStock
    Location | 5, 0

Show To connect the Chart to a data source

  1. Select the Chart control and at the bottom of the Properties window, select the Data Source command. See Properties Window for further details on accessing commands.
    Tip: If the verb is not visible, right-click an empty space in the Properties Window and select Commands to display verbs.
  2. In the Chart DataSource dialog box that appears, click the Build button.
  3. In the Data Link Properties window, select Microsoft Jet 4.0 OLE DB Provider and click the Next button.
  4. Click the ellipsis button (...) to browse to the NorthWind database. Click Open once you have selected the file.
  5. Click the OK button to close the window and fill in the Connection String.
  6. In the Query field, enter the following parameterized SQL query.
    SQL Query Copy Code
    SELECT * FROM Products WHERE CategoryID = <%CategoryID||1%> ORDER BY ProductName
    Note: The chart data cannot be arranged if ORDER is not set in both the SQL statements (report and chart statement).
  7. Click OK to save the data source.

Show To configure the appearance of the Chart

  1. With the chart control selected, go to the Properties window, click the ChartAreas (Collection) property and then click the ellipsis button that appears.
  2. In the ChartArea Collection Editor that appears with defaultArea selected under the members list, click its Axes (Collection) property and then click the ellipsis button.
  3. In the AxesBase Collection Editor that appears, set the following properties.

    Show AxisBase

    1. With AxisX selected under members list, set Angle property of LabelFont to -90.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink
    2. Delete text from Title property to make sure that the ProductName label (lblProductName) does not overlap.
    3. Click AxisY under the members list and set its Title property to Unit Stock.
    4. With AxisY selected under the members list, expand the GridLine section under MajorTick property tree view and set its following sub-properties.
      Property Name | Property Value
      Style | Dot
      Color | Silver
      Weight | 1

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink
    5. Click OK to return back to ChartArea collection editor and then click OK again to return back to report design surface.
  4. With the chart control selected, go to the Properties window, click the ChartSeries (Collection) property and then click the ellipsis button that appears.
  5. In the Series Collection Editor that appears, set the following properties:

    Show Series

    1. With Series1 selected under the members list, set its following properties:
      Property Name | Property Value
      ValueMembersY | UnitsInStock
      ValueMembersX | ProductName

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink
    2. Click OK to return back to report design surface.
  6. With the chart control selected, go to the Properties window, click the Titles (Collection) property and then click the ellipsis button that appears.
  7. In the Title Collection Editor that appears, set the following properties:

    Show Titles

    1. With Header selected under the members list, set its Text property to Product Inventory.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink
    2. Delete/Remove Footer from the members list.
    3. Click OK to return back to report design surface.
  8. With the chart control selected, go to the Properties window, click the Legends (Collection) property and then click the ellipsis button that appears.
  9. In the Legend Collection Editor that appears, set the following properties:

    Show Legends

    1. With defaultLegend selected under the members list, set its Visible property to False.

      Click to Enlarge Click to Enlarge
      Click to Shrink Click to Shrink
    2. Click OK to return back to report design surface.

Show To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web

Web
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Web

Glossary Item Box

This section contains the following walkthroughs that fall under the Web category.

Document Web Service
This walkthrough describes how to set up a simple web service that returns an ActiveReports document.
Document Windows Application
This walkthrough describes how to set up a Windows client application for the ActiveReports Document Web Service
Important: In order to consume Web services in your Windows applications, you must set permissions to allow the ASP.NET user to consume the services. Ask your server administrator for help with this.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Document Web Service

Document Web Service
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Web > Document Web Service

Glossary Item Box

Show All Show All
Hide All Hide All

With ASP.NET and ActiveReports, you can set up a Web Service that returns a report document which can be shown in a report viewer control.

This walkthrough illustrates how to create a Web Service that returns the contents of an ActiveReports as a byte array.

This walkthrough is split up into the following activities:

  • Creating an ASP.NET Web Service project
  • Adding code to create the Web Method
  • Testing the Web Service
  • Publishing the Web Service
  • Creating a virtual directory in IIS
Note: For the information on how to connect your report to data and how to create the report layout, please see Basic Data Bound Reports for a section report.

When you have completed this walkthrough, you will have a Web Service that returns the contents of an ActiveReports as a byte array.

Show To create an ASP.NET Web Service project

  1. From the File menu, select New Project.
  2. In the New Project dialog that appears, select ASP.NET Web Service Application.
  3. Change the name of the project.
  4. Click OK to open the new project in Visual Studio.

Show To write the code to create the Web Method

  1. On the Service.vb or Service.cs tab is the code view of the Service.asmx file.
  2. Replace the existing WebMethod and HelloWorld function with the following code.

The following code demonstrates how you create the Web Method for a section report.

Visual Basic.NET code. REPLACE the existing WebMethod and function with this code. Copy Code
<WebMethod( _Description:="Returns a products report grouped by category")> _
Public Function GetProductsReport() As Byte()
     Dim rpt As New rptProducts()
     rpt.Run()
     Return rpt.Document.Content
End Function
C# code. REPLACE the existing WebMethod and function with this code. Copy Code
[WebMethod(_Description = "Returns a products report grouped by category")]
public byte[] GetProductsReport()
{
    rptProducts rpt = new rptProducts();
    rpt.Run();
    return rpt.Document.Content;
}

Show To test the Document Web Service

  1. Press F5 to run the project. The Service page appears in your browser.
  2. In the list of supported operations at the top, click GetProductsReport.
  3. Click the Invoke button to test the Web Service operation.
  4. If the test is successful, you will see the binary version of the contents of rptProducts.

Show To publish the Document Web Service

  1. In the Solution Explorer, right-click the project name and select Publish.
  2. In the Publish Web window that appears, enter locahost in the Service URL field and "SiteName"/WebService in the Site/application field.
    Note: Get the SiteName from the Internet Information Services Manager.
  3. Select the Mark an IIS application on destination option and click the OK button.

Show To check the configuration in IIS

  1. Open Internet Information Services Manager.
  2. In the Internet Information Services Manager window that appears, expand the tree view in the left pane until you see the Web Service you had added in the steps above.
  3. Right-click the Web Service select Manage Application then Browse.
  4. In the browser that appears, go to the Address bar and add \Service1 to the url.

For information on consuming the Document Web Service in a viewer, see Document Windows Application.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Document Windows Application

Document Windows Application
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Web > Document Windows Application

Glossary Item Box

Show All Show All
Hide All Hide All

In ActiveReports, you can use a Web Service that returns the content of a Section report to show in the Windows Forms viewer control.

This walkthrough illustrates how to create a Windows client application that returns the content of a Section report in the Windows Forms viewer.

This walkthrough builds on the Document Web Service walkthrough and is split up into the following activities:

  • Creating a Visual Studio project
  • Adding the ActiveReports Windows Forms viewer control to the form
  • Adding a reference to a Web service to the project
  • Displaying the content returned by the Document Web Service in the viewer
  • Running the project
Note: Refer to Document Web Service to set up Web service that returns an ActiveReports document.

Show To create a Visual Studio project

  1. From the File menu, select New, then Project.
  2. In the Templates section of the New Project dialog, select Windows Application.
  3. Change the name of the application to ARDocumentClient.
  4. Click OK to open the project.

Show To add the Viewer control

  1. From the Visual Studio toolbox, drag the ActiveReports Viewer control onto the form.
  2. Change the Dock property for the viewer control to Fill, and resize the form to accommodate a report.

Show To add a web reference

Show To add a reference to a web service in Visual Studio that is compatible with the .NET Framework Web service version

  1. From the Project menu, select Add Service Reference.
  2. In the Add Service Reference window that appears, click the Advanced button.
  3. In the Service Reference Settings window that appears, click Add Web Reference button.
  4. From the Project menu, select Add Web Reference.
  5. Type in the address of the .asmx file for the ActiveReports Document Web Service you created in the previous walkthrough. For example: http://localhost/ARDocumentWS/Service.asmx
  6. Click the Add Reference button when the Web Service is recognized.

Show To add a reference to a web service in Visual Studio

  1. From the Project menu, select Add Service Reference.
  2. In the Add Service Reference that appears, type in the address of the .asmx file for the ActiveReports Document Web Service you created in the previous walkthrough. For example: http://localhost/ARDocumentWS/Service.asmx
  3. Click the Go button, and then click the OK button when the Web Service is recognized.

Show To display the content returned by the Document Web Service in the viewer

Show To display the report content

  1. Double-click Form1 to create an event-handling method for the Form1_Load event.
  2. Add code to the handler to display the document Web service content in the viewer.

The following example shows what the code for the method looks like.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
Dim ws As New localhost.Service
Me.Viewer1.Document.Content = ws.GetProductsReport()

Show To write the code in C#

C# code. Paste INSIDE the Form Load event. Copy Code
localhost.Service ws = new localhost.Service();
this.viewer1.Document.Content = ws.GetProductsReport();

Show To display the report content

  1. Double-click on Form1 to create an event-handling method for the Form1_Load event.
  2. Add code to the handler to display the document Web service content in the viewer.

The following example shows what the code for the method looks like.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event. Copy Code
Dim ws As New ServiceReference1.ServiceSoapClient()
Me.Viewer1.Document.Content = ws.GetProductsReport()

Show To write the code in C#

C# code. Paste INSIDE the Form Load event. Copy Code
ServiceReference1.ServiceSoapClient ws = new ServiceReference1.ServiceSoapClient();
this.viewer1.Document.Content = ws.GetProductsReport();

Show To update the app.config file

Note: You need to update the app.config file if you added the Service Reference to Visual Studio project in the previous section.
  1. In the Solution Explorer, open the app.config file.
  2. In the tag <binding name = "ServiceSoap"...>, set maxBufferSize and maxReceivedMessageSize to some large number, for example, 200500.
  3. In the next tag <readerQuotas...>, set maxArrayLength to some large number, for example, 60500.

Show To run the project

Press F5 to run the project.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Common Walkthroughs

Common Walkthroughs
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs

Glossary Item Box

Common walkthroughs cover scenarios to introduce the key features of page and section reports. Learn about different page and section report walkthroughs categorized as follows.

Professional
This section contains the walkthroughs explaining features that are part of the ActiveReports Professional Edition.
Export
This section contains the walkthrough that explains how to create a simple custom spreadsheet and save it to an Excel file.
Web
This section contains the walkthroughs that explain how to create a simple web service for each scenario and how to create a Windows client application for each web service.
WPF
This section contains the walkthrough that explains how to use the ActiveReports WPF Viewer in a WPF application project.
Layout
This section contains the walkthough that explains how to create a report using Report Parts in a application project.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Professional

Professional
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Professional

Glossary Item Box

This section contains the following walkthroughs that fall under the Professional category.

Creating a Basic End User Designer
This walkthrough demonstrates how to set up a basic end-user report designer on a Windows Forms application.
Customizing the HTML Viewer UI
This walkthrough demonstrates how to customize the HTML Viewer interface using JQuery methods.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Creating a Basic End User Report Designer (Pro Edition)

Creating a Basic End User Report Designer (Pro Edition)
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Professional > Creating a Basic End User Report Designer (Pro Edition)

Glossary Item Box

This walkthrough illustrates how to set up a basic End-User Report Designer on a Windows Forms application in the Professional Edition of ActiveReports.

At the end of this walkthrough, the End-User Report Designer appears like the following image.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Adding the Designer control to the Form

You will add the Designer that could only edit and preview a report file.

  1. Create a new Windows Forms Application project.
  2. In the Name field, rename the file to CustomEUD and click OK.
  3. Select a Form and go to the Properties Window to change the Name property to frmMain and the Text property to ActiveReports.
  4. Resize the Form so that you can accommodate the controls listed further. See Adding ActiveReports Controls for more information.
  5. From the Visual Studio toolbox, drag the Designer control onto the Form and rename it to designer.
  6. From the Visual Studio toolbox, drag the Toolbox control onto the Form and rename it to toolbox.
  7. To attach the toolbox control to the designer control, in the Solution Explorer, right-click Form1.cs and select View Code.
  8. Add the following code (marked in bold) after the InitializeComponent method.
    C# code. Paste AFTER the InitializeComponent method Copy Code
    public frmMain()
{
  InitializeComponent();
  designer.Toolbox = toolbox;
}
  9. At the top of the code view, add a using directive.
    C# code. Paste at the top of the Form1 code view Copy Code
    using GrapeCity.ActiveReports.Design;

Loading and/or saving the report file

  1. From the Visual Studio Menus & Toolbars toolbox group, drag the MenuStrip control onto the Form.
  2. Create the following structure for the MenuStrip control: File > Open, File > Save as.

  3. On the Form, double-click the Open menu item and paste the following code (marked in bold) into the openToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the openToolStripMenuItem_Click handler Copy Code
    private void openToolStripMenuItem_Click(object sender, EventArgs e)
         {
             OpenFileDialog openFileDialog = new OpenFileDialog();
             var dialogResult = openFileDialog.ShowDialog();
             if (dialogResult == System.Windows.Forms.DialogResult.OK)
             {
                 designer.LoadReport(new System.IO.FileInfo(openFileDialog.FileName));
             }
         }
  4. On the Form, double-click the Save as menu item and paste the following code (marked in bold) into the saveAsToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the saveAsToolStripMenuItem_Click handler Copy Code
    private void saveAsToolStripMenuItem_Click(object sender, EventArgs e)
         {
             SaveFileDialog saveFileDialog = new SaveFileDialog();
             saveFileDialog.Filter = GetSaveFilter();
             var dialogResult = saveFileDialog.ShowDialog();
             if (dialogResult == System.Windows.Forms.DialogResult.OK)
             {
                designer.SaveReport(new System.IO.FileInfo(saveFileDialog.FileName));
             }
         }
  5. After the saveAsToolStripMenuItem_Click handler code, add the code for the GetSaveFilter method as follows.
    C# code. Paste AFTER the saveAsToolStripMenuItem_Click handler Copy Code
    private string GetSaveFilter()
 {
     switch (designer.ReportType)
     {
        case DesignerReportType.Section:
           return "Section Report Files (*.rpx)|*.rpx";
        case DesignerReportType.Page:
           return "Page Report Files (*.rdlx)|*.rdlx";
        case DesignerReportType.Rdl:
           return "RDL Report Files (*.rdlx)|*.rdlx";
        default:
           return "RDL Report Files (*.rdlx)|*.rdlx";
     }
 }

Creating a new report based on a chosen type

  1. Create the following structure for the MenuStrip control: File > New report > Section report; File > New report > Page report; File > New report > Rdl report.

  2. Double-click the Section report MenuStrip item and add the following code (marked in bold) into the sectionToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the sectionToolStripMenuItem_Click handler Copy Code
    private void sectionToolStripMenuItem_Click(object sender, EventArgs e)
  {
   designer.NewReport(DesignerReportType.Section);
  }
  3. Double-click the Page report MenuStrip item and add the following code (marked in bold) into the pageReportToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the pageReportToolStripMenuItem_Click handler Copy Code
    private void pageReportToolStripMenuItem_Click(object sender, EventArgs e)
  {
    designer.NewReport(DesignerReportType.Page);
  }
  4. Double-click the Rdl report MenuStrip item and add the following code (marked in bold) into the rdlReportToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the rdlReportToolStripMenuItem_Click handler Copy Code
    private void rdlReportToolStripMenuItem_Click(object sender, EventArgs e)
  {
   designer.NewReport(DesignerReportType.Rdl);
  }

Adding the Export option

  1. From the Project menu, select Add Reference.
  2. In the Reference Manager dialog that appears, select the following reference and click OK to add them to your project.
    GrapeCity.ActiveReports.Export.Pdf
  3. At the top of the code view, add using statements.
    C# code. Paste at the top of the Form1 code view Copy Code
    using GrapeCity.ActiveReports.Export.Pdf.Page;
using GrapeCity.ActiveReports.Rendering.IO;
using GrapeCity.ActiveReports;
using System.IO;
  4. In the MenuStrip control, add the Export menu item to the File menu.

  5. In the Properties Window, set the Enabled property to False. This enables the Export menu item to be displayed in the Preview mode only.
  6. To enable the Export menu item to be displayed for page and rdl reports only, add the following code (marked in bold) after the InitializeComponent method.
    C# code. Paste AFTER the InitializeComponent method Copy Code
    public frmMain()
             {
                 InitializeComponent();
                 designer.Toolbox = toolbox;
                 designer.ActiveTabChanged += designer_ActiveTabChanged;
             }

    void designer_ActiveTabChanged(object sender, EventArgs e)
             {
                 exportToolStripMenuItem.Enabled = designer.ActiveTab == DesignerTab.Preview && designer.ReportType != DesignerReportType.Section;
             }

  7. On the Form, double-click the Export item and add the following code (marked in bold) to the exportToolStripMenuItem_Click handler.
    C# code. Paste INSIDE the exportToolStripMenuItem_Click handler Copy Code
    private void exportToolStripMenuItem_Click(object sender, EventArgs e)
         {
             SaveFileDialog saveFileDialog = new SaveFileDialog();
             saveFileDialog.Filter = "Pdf (*.pdf)|*.pdf";
             var dialogResult = saveFileDialog.ShowDialog();
             if (dialogResult == System.Windows.Forms.DialogResult.OK)
             {
                 var pdfRe = new PdfRenderingExtension();
                 var msp = new MemoryStreamProvider();
                 (designer.Report as PageReport).Document.Render(pdfRe, msp);
                 using (var stream = msp.GetPrimaryStream().OpenStream())
                using (var fileStream = new FileStream(saveFileDialog.FileName, FileMode.Create, FileAccess.Write))
                 {
                     stream.CopyTo(fileStream);
                 }
                 MessageBox.Show("Export is done");
             }        }

For more information on export filters, rendering extensions and their settings, refer to the Exporting section of the ActiveReports User Guide.

Adding other controls to the Form

  1. From the Visual Studio toolbox, drag the following controls onto the Form.
    Control | Name | Property Value
    ReportExplorer arReportExplorer

    ReportDesigner = designer
    This binds the ActiveReports Designer to the ReportExplorer control.
    Resize and move as necessary.
    LayerList arLayerList

    ReportDesigner = designer
    This binds the ActiveReports Designer to the LayerList control.
    Resize and move as necessary.
    PropertyGrid | arPropertyGrid | Resize and move as necessary.
    GroupEditor arGroupEditor

    ReportDesigner = designer
    This binds the ActiveReports Designer to the GroupEditor control.
    Resize and move as necessary.
    ReportsLibrary arReportsLibrary

    ReportDesigner = designer
    This binds the ActiveReports Designer to the ReportsLibrary control.
    Resize and move as necessary.
  2. On the Form, select the Designer control.
  3. In the Properties Window, set the PropertyGrid property of the Designer control to arPropertyGrid. This binds the ActiveReports Designer to the Property Grid control.

Viewing the End User Report Designer

Press F5 to run the project. The End User Report Designer opens with an RDL Report.

For information on how you can customize the End User Report Designer and more, refer to the End User Designer product sample.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Customizing the HTML Viewer UI

Customizing the HTML Viewer UI
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Professional > Customizing the HTML Viewer UI

Glossary Item Box

Show All Show All
Hide All Hide All

You can customize the HTMLViewer interface using JQuery methods. WebViewer control adds JQuery library in page scripts. Use the code in this walkthrough to remove a button from the HTMLViewer toolbar and add a client side PDF export implementation.

This walkthrough is split into the following activities:

  • Loading an ActiveReport to a Visual Studio ASP.NET Web application.
  • Adding the jQuery library to the Web application project.
  • Accessing WebViewer's view model.
  • Removing an existing toolbar button.
  • Adding a function for PDF exporting.
  • Binding the Custom UI to WebViewer's view model.

When you complete this walkthrough you get an HTMLViewer that looks similar to the following at run time.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To load an ActiveReport in the Web application

  1. Create a new Visual Studio ASP.NET Web application.
  2. In the Default.aspx that gets created, go to the Visual Studio toolbox ActiveReports 13 Page Report tab and drag a WebViewer control onto the Design view.
  3. Load the report generated at the end of the Single Layout Reports walkthrough.
    Note: You may load any report, section or page in the HTMLViewer. See Getting Started with the Web Viewer for information on loading a report.

Show To add the jQuery library to the Web application project

Follow the steps below to add the jQuery library to your Web application project.

  1. In the Source view of the Default.aspx file, add the following code.
    Add this code after the <head> tag Copy Code
    <script src="https://code.jquery.com/jquery-2.1.4.min.js"></script>
  2. In the Source view of the Default.aspx file, add the following code.
    Add this code before the </script> tag Copy Code
    var clientID = ...;
$(document).ready(function ()
{
$('#' + clientID).on('loaded', viewer_loaded);
});

Show To access the WebViewer view model

The HTML Web Viewer is created using the MVVM pattern that provides a view model which does not depend on the UI. The code can access the Viewer's view model and bind the custom UI to it by using well-documented properties and methods. For MVVM support, the code can use knockout.js which is the standard MVVM library for JavaScript. Knockout.js provides declarative bindings, observable objects and collections in HTML markup. See Using Javascript with the HTML Viewerfor more information.

Follow the steps below to access the ViewModel.

  1. In the Source view of the Default.aspx file, add a <script> tag.
    Add a script tag like the following before the body tag Copy Code

    <script language="javascript" type="text/javascript">

    </script>
  2. Add the following Javascript code for document's Onload event handler and WebViewer's Loaded event handler that gets fired when the UI is rendered on the Html Page:
    Paste the code into .aspx source Copy Code
    <script language="javascript" type="text/javascript">
    function viewer_loaded()
    {
    };
    function document_onload()
    {
    };
    </script>
    ...
    <body onload="return document_onload()">
  3. Add the following Javascript code inside the viewer_loaded event handler to access WebViewer's view model:
    Paste the code into .aspx source Copy Code
    var viewModel = GetViewModel('WebViewer1');
  4. Add the following Javascript code inside the document_onload event handler to bind WebViewer's Loaded event to client side viewer_loaded event:
    Paste the code into .aspx source Copy Code
    $('#WebViewer1').bind('loaded', viewer_loaded);

Show To remove a button from the WebViewer toolbar

In the Source view of the Default.aspx file, add the following Javascript code inside the viewer_loaded event handler to access the WebViewer toolbar and remove the Next Page button from the toolbar:

Paste the code into .aspx source Copy Code
var toolbar = $('#WebViewer1').find('.arvToolBar');
toolbar.find('.btnNext').remove();

Note: In order to access the child elements of the WebViewer toolbar you need their css class names. Following is a list for reference:

Show Toolbar Child Elements

Toggle Sidebar button: btnToggleSidebar
Find button: btnFind
First page button: btnFirst
Previous page button: btnPrev
Page label: toolbarLabel
Page number input box: toolbarInput
Next page button: btnNext
Last page button: btnLast
Back to parent report button: btnBack

Show To add a function for exporting to PDF

The steps below illustrate how to build a custom UI.

  1. In the Source view of the Default.aspx file, add following Javascript code inside <script> tag to create a function. This function accesses the view model and exports the report in PDF format :
    Paste the code into .aspx source Copy Code
    function exportPDF()
    {

        var viewModel = GetViewModel('WebViewer1');

        if (viewModel.PageLoaded())
        {
            viewModel.Export(ExportType.Pdf, function (uri)
            {
                window.location = uri;
            }, true);
        }
    }
  2. In the Source view of the Default.aspx file, add the following Javascript code inside <form> tag to add a button on a custom toolbar. This button is enabled once the report is loaded and calls the exportPDF() function at run time:
    Paste the code into .aspx source Copy Code

    <div id="customToolbar" style = "display:inline">
    <button data-bind='enable: PageLoaded, click: exportPDF' style=" width: 105px;
    font-size: medium; height: 22px;">Export</button>
    </div>
  3. In the Source view of the Default.aspx file, add the following Javascript code inside the viewer_loaded event handler to attach the custom toolbar with the built-in toolbar:
    Paste the code into .aspx source Copy Code

    $('#customToolbar').appendTo(toolbar);

Show To bind the custom UI to the WebViewer view model and run the application

  1. Add the following Javascript code inside the viewer_loaded event handler to bind the custom UI to WebViewer view model:
    Paste the code into .aspx source Copy Code
    ko.applyBindings(viewModel, document.getElementById("customToolbar"));
  2. Press F5 to run the application.
Note: Replace 'WebViewer1' in the code snippets above, with the actual ID of the WebViewer control in your application.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Export

Export
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Export

Glossary Item Box

This section contains the following walkthroughs that fall under the Export category.

Basic Spreadsheet with SpreadBuilder
This walkthrough demonstrates how to create a simple custom spreadsheet and save it to an Excel file.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Basic Spreadsheet with SpreadBuilder

Basic Spreadsheet with SpreadBuilder
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Export > Basic Spreadsheet with SpreadBuilder

Glossary Item Box

Show All Show All
Hide All Hide All

Included with the ActiveReports Excel export filter is the SpreadBuilder API. With this utility, you can create Excel spreadsheets cell by cell for maximum control. This walkthrough illustrates how to create a simple custom spreadsheet and save it to an Excel file.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to your project
  • Adding an GrapeCity.ActiveReports.Export.Excel assembly reference
  • Creating a Workbook using code
  • Viewing the Excel File

When you have completed this walkthrough, a custom Excel file like the following is created in the Bin/Debug subfolder of your project's folder.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add an GrapeCity.ActiveReports.Export.Excel assembly reference to your project

  1. Create a new Visual Studio project.
  2. From the Visual Studio Project menu, select Add Reference.
  3. In the Add Reference window that appears, select GrapeCity.ActiveReports.Export.Excel assembly reference and click OK.
    Note: In ActiveReports, by default, the assemblies are located in the ...\Common Files\GrapeCity\ActiveReports 13 folder.

Show To add code to create a workbook

Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event. Add code to the handler to:

  • Create a Workbook, and add a sheet to the Workbook's Sheets collection
  • Set properties on columns and rows in the sheet
  • Set values of cells in the sheet
  • Use the Save method to create an Excel file

The following example shows what the code for the method looks like.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste inside the form Load event. Copy Code
'Create a Workbook and add a sheet to its Sheets collection
Dim sb As New GrapeCity.SpreadBuilder.Workbook()
sb.Sheets.AddNew()

'Set up properties and values for columns, rows, and cells as desired
With sb.Sheets(0)
   .Name = "Customer Call List" 'sets the name of the sheet
   .Columns(0).Width = 2 * 1440 'sets the width of the 1st column
   .Columns(1).Width = 1440
   .Columns(2).Width = 1440
   .Rows(0).Height = 1440 / 4

'Header row
    .Cell(0, 0).SetValue("Company Name")
    .Cell(0, 0).FontBold = True
    .Cell(0, 1).SetValue("Contact Name")
    .Cell(0, 1).FontBold = True
    .Cell(0, 2).SetValue("Phone")
    .Cell(0, 2).FontBold = True

'First row of data
    .Cell(1, 0).SetValue("GrapeCity")
    .Cell(1, 1).SetValue("Mortimer")
    .Cell(1, 2).SetValue("(425) 880-2601")
End With

'Save the Workbook to an Excel file
sb.Save(Application.StartupPath & "\x.xls")
MessageBox.Show("Your Spreadsheet has been saved to " & Application.StartupPath & "\x.xls")

Show To write the code in C#

C# code. Paste inside the form Load event. Copy Code
//Create a Workbook and add a sheet to its Sheets collection
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.Sheets.AddNew();

//Set up properties and values for columns, rows and cells as desired
sb.Sheets[0].Name = "Customer Call List";
sb.Sheets[0].Columns(0).Width = 2 * 1440;
sb.Sheets[0].Columns(1).Width = 1440;
sb.Sheets[0].Columns(2).Width = 1440;
sb.Sheets[0].Rows(0).Height = 1440/4;

//Header row
sb.Sheets[0].Cell(0,0).SetValue("Company Name");
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
sb.Sheets[0].Cell(0,1).FontBold = true;
sb.Sheets[0].Cell(0,2).SetValue("Phone");
sb.Sheets[0].Cell(0,2).FontBold = true;

//First row of data
sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
sb.Sheets[0].Cell(1,2).SetValue("(425) 880-2601");

//Save the Workbook to an Excel file
sb.Save (Application.StartupPath + @"\x.xls");
MessageBox.Show("Your Spreadsheet has been saved to " + Application.StartupPath + @"\x.xls");

Show To view the Excel File

  1. Press F5 to run the project. A message box informs you of the exact location of the exported x.xls file.
  2. Navigate to the Bin/Debug subfolder of your project's folder and open the XLS file.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Web

Web
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Web

Glossary Item Box

This section contains the following walkthroughs that fall under the Web category.

DataSet Web Service
This walkthrough describes how to set up a simple web service that returns a dataset.
DataSet Windows Application
This walkthrough describes how to set up a Windows client application for the dataset Web Service.
Important: In order to consume Web services in your Windows applications, you must set permissions to allow the ASP.NET user to consume the services. Ask your server administrator for help with this.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


DataSet Web Service

DataSet Web Service
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Web > DataSet Web Service

Glossary Item Box

Show All Show All
Hide All Hide All

With ASP.NET, you can set up a Web Service that returns a dataset to use in ActiveReports. This walkthrough illustrates how to create one.

This walkthrough is split into the following activities:

  • Creating an ASP.NET Web Service project
  • Adding code to create the Web method
  • Testing the Web service
  • Publishing the Web service
  • Creating a virtual directory in IIS
Note: For the information on how to connect your report to data and how to create the report layout, please see Single Layout Reports (for a page report) or Basic Data Bound Reports (for a section report).

Show To create an ASP.NET Web Service project

  1. From the File menu, select New Project.
  2. In the New Project dialog that appears, select ASP.NET Web Application to create a empty web application.
  3. Change the name of the project.
  4. Click OK to open the new project in Visual Studio.

Show To create the Web Method

  1. From the Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select Web Service (asmx) and change the name of the web service.

In the WebService, replace the existing <WebMethod()> _ and HelloWorld function with code like the following.

Show To write the code in Visual Basic.NET

Visual Basic.NET code. Paste OVER the existing WebMethod. Copy Code
Private connString As String
<WebMethod(Description:="Returns a DataSet containing all Products")> _
Public Function GetProduct() As Data.DataSet
connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Name]\Documents\GrapeCity Samples\ActiveReports 10\Data\nwind.mdb"
Dim adapter As New Data.OleDb.OleDbDataAdapter("select * from products", connString)
Dim ds As New Data.DataSet()
adapter.Fill(ds, "Products")
Return ds
End Function

Show To write the code in C#

C# code. Paste OVER the existing WebMethod. Copy Code
private static string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source = C:\\Users\\[User Name]\\Documents\\GrapeCity Samples\\ActiveReports 10\\Data\\nwind.mdb";
[WebMethod(Description="Returns a DataSet containing all Products")]
public Data.DataSet GetProduct()
{
   System.Data.OleDb.OleDbDataAdapter adapter;
   System.Data.DataSet ds;
   adapter = new System.Data.OleDb.OleDbDataAdapter("select * from products", connString);
   ds = new System.Data.DataSet();
   adapter.Fill(ds, "Products");
   return ds;
}

Show To test the Web Service

  1. Press F5 to run the project.
  2. If the Debugging Not Enabled dialog appears, select the option that enables debugging and click OK to continue.
  3. In the list of supported operations, click the GetProduct link. (The description string from the code above appears below the link.)
  4. Click the Invoke button to test the Web Service operation.
  5. If the test is successful, a valid XML schema of the Northwind products table displays in a new browser window.
  6. Copy the URL from the browser for use in the Web Reference of your DataSet Windows Application.

Show To publish the Web Service

  1. In the Solution Explorer, right-click the project name and select Publish.
  2. In the Publish Web window that appears, select Custom option to create a custom profile and click OK.
  3. Enter localhost in the Server field and "SiteName"/WebServiceName in the Site name field.
    Note: Get the SiteName from the Internet Information Services Manager.
  4. Click the Publish button.

Show To check the configuration in IIS

  1. Open Internet Information Services Manager.
  2. In the Internet Information Services Manager window that appears, expand the tree view in the left pane until you see the Web Service you had added in the steps above.
  3. Right-click the Web Service select Manage Application then Browse.
  4. In the browser that appears, go to the Address bar to add WebServiceName.asmx to the url and press Enter.

For information on consuming the DataSet Web Service in an ActiveReport, see DataSet Windows Application.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


DataSet Windows Application

DataSet Windows Application
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Web > DataSet Windows Application

Glossary Item Box

Show All Show All
Hide All Hide All

You can use a Web Service that returns a dataset as the data source for your reports in Windows applications. This walkthrough illustrates how to create a Windows client application that uses the dataset Web Service as the data source for an ActiveReports.

This walkthrough builds on the DataSet Web Service walkthrough and is split up into the following activities:

  • Adding a reference to a Web service to the project
  • Setting the report data source to the one returned by the Web service
Note: For the information on how to connect your report to data and how to create the report layout, please see Single Layout Reports (for a page report) or Basic Data Bound Reports (for a section report).

Show To add a reference to a web service in Visual Studio

  1. From the Project menu, select Add Service Reference.
  2. In the Add Service Reference window that appears, type in the address of the virtual directory you created in the previous walkthrough. You can get the address by running the project from the previous walkthrough and copying the url from the address in the browser. (It will look something like http://localhost:####/DataSetWS/Service.asmx where #### is the port number.)
  3. Click the Go button, and then click the OK button when the Web Service is recognized.

Show To set the report data source to the one returned by the Web service

Show To set the report data source (for Visual Studio compatible with .NET Framework Web service version)

  1. Double-click the gray area below the report. This creates an event-handling method for the ReportStart event.
  2. Add code to the handler to use the web service dataset in the report.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event Copy Code
    Dim ws As New localhost.Service
Dim ds As DataSet()= ws.GetProduct()
Me.DataSource = ds
Me.DataMember = "Products"

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    localhost.DataSetWS ws = new localhost.Service;
DataSet ds = ws.GetProduct();
this.DataSource = ds;
this.DataMember = "Products";

Show To set the report data source

  1. Double-click the gray area below the report. This creates an event-handling method for the ReportStart event.
  2. Add code to the handler to use the web service dataset in the report.

    The following example shows what the code for the method looks like.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
    Dim ws As New ServiceReference1.ServiceSoapClient()
Dim ds As DataSet = ws.GetProduct()
Me.DataSource = ds
Me.DataMember = "Products"

    Show To write the code in C#

    C# code. Paste INSIDE the ReportStart event. Copy Code
    ServiceReference1.ServiceSoapClient ws = new ServiceReference1.ServiceSoapClient();
DataSet ds = ws.GetProduct();
this.DataSource = ds;
this.DataMember = "Products";

Show To update the app.config file

Note: You need to update the app.config file if you added the Service Reference to the Visual Studio project in the previous section.
  1. In the Solution Explorer, open the app.config file.
  2. In the tag <binding name = "ServiceSoap"...>, set maxBufferSize and maxReceivedMessageSize to some large number, for example, 200500.
  3. In the next tag <readerQuotas...>, set maxArrayLength to some large number, for example, 60500.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


WPF

WPF
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > WPF

Glossary Item Box

This section contains the following walkthroughs that fall under the WPF category.

WPF Viewer
This walkthrough explains how to use the ActiveReports WPF Viewer in a WPF application project.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


WPF Viewer

WPF Viewer
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > WPF > WPF Viewer

Glossary Item Box

Show All Show All
Hide All Hide All

The ActiveReports WPF Viewer is a custom control that allows to easily view section, RDL and page report layouts.

This walkthrough is split up into the following activities.

  • Creating a WPF Application project in Visual Studio
  • Adding the ActiveReports WPF Viewer control to the xaml page
  • Loading a report to the ActiveReports WPF Viewer
  • Previewing a report
  • Customizing the ActiveReports WPF Viewer

When you have completed this walkthrough, you will have the ActiveReports WPF Viewer displaying a report that looks similar to the following.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To create a WPF application in Visual Studio

  1. On the Visual Studio File menu, click New > Project.
  2. In the New Project dialog that appears, select WPF Application in the list of templates.
  3. Specify the name and location of the project and then сlick the OK button.
  4. In the Visual Studio Solution Explorer, right-click YourProject and select Add, then New Item.
  5. In the Add New Item dialog that appears, select the ActiveReports 13 Page Report and create the rptSingleLayout report as described in the Single Layout Reports walkthrough.

Show To add the WPF Viewer control

  1. In Solution Explorer, open MainWindow.xaml.
  2. From the Toolbox ActiveReports 13 tab, drag the Viewer control and drop it on the design view of MainWindow.xaml.
  3. In the Properties window, set the properties of the Viewer control as follows.
    Property Name | Property Value
    HorizontalAlignment | Stretch
    VerticalAlignment | Stretch
    Margin | 0
  4. In the Properties window, rename the Viewer control to viewer1.

Show To load a report to the WPF Viewer

  1. In the Solution Explorer, select the rptSingleLayout report you have created.
  2. In the Properties window, set Copy to Output Directory to Copy Always.
  3. On MainWindow.xaml, with the viewer selected, go to the Properties window and double click the Loaded event.
  4. In the MainWindow code view that appears, add code like the following to the viewer1_loaded event to bind the report to the viewer. This code shows an .rdlx report being loaded but you can use an .rpx report as well.
    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb. Copy Code
    Viewer1.LoadDocument("rptSingleLayout.rdlx")
    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs. Copy Code
    viewer1.LoadDocument("rptSingleLayout.rdlx");
Note: For an example of other ways to bind a report to the WPF Viewer, see the LoadDocument method in the Class Library documentation.
Note: To avoid evaluation banners appearing at run time, license your ActiveReports WPF Application project. You can find information on licensing in License Your ActiveReports.

Show To view the report

Press F5 to run the project. The WPF Viewer displaying a report appears.

Show To customize the WPF Viewer

The ActiveReports WPF Viewer is a customizable control. You can easily change the look of the WPF Viewer and its elements, such as the error panel, search panel, sidebar and toolbar by modifying properties in the default WPF Viewer template (DefaultWPFiewerTemplates.xaml).

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show To add the customization template to the WPF project

  1. Open your WPF project.
  2. In Solution Explorer, select the YourProjectName node.
  3. On the Visual Studio Project menu, click Add Existing Item.
  4. In the dialog that appears, locate and select DefaultWPFViewerTemplates.xaml and click OK. You can find DefaultWPFViewerTemplates.xaml at [systemdrive]\Program Files\GrapeCity\ActiveReports 13\Deployment\WPF\Templates folder (on a 64-bit Windows operating system, this file is located in [systemdrive]\Program Files (x86)\GrapeCity\ActiveReports 13\Deployment\WPF\Templates).
  5. On MainWindow.xaml before the opening <Grid> tag, add the following code.
    Paste to the XAML view of MainWindow.xaml before the opening <Grid> tag Copy Code
    <Window.Resources>
<ResourceDictionary Source="DefaultWPFViewerTemplates.xaml" />
</Window.Resources>

Show To customize the WPF Viewer sidebar

  1. In Solution Explorer, double-click DefaultWPFViewerTemplates.xaml.
  2. In the file that opens, search for "thumbnails tab".
  3. In the GroupBox Header property of <!-- thumbnails tab -->, remove "{Binding Source.ThumbnailsPane.Text}" and type "THUMBNAILS".
  4. Search for "TabControl x:Name="Sidebar".
  5. Add Background="Yellow" after TabControl x:Name="Sidebar".
  6. Press F5 to see the customized viewer sidebar.

Show To add a customized button to the WPF Viewer toolbar

  1. In Solution Explorer, select the YourProjectName node.
  2. On the Visual Studio Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select Class, rename it to MyCommand and click Add.
  4. In the MyCommand.cs/vb that opens, add the following code to implement a command.

    Show To write the code in Visual Basic.NET

    Visual Basic.NET code. Add to MyCommand.vb Copy Code
    Implements ICommand
Public Function CanExecute(ByVal parameter As Object) As Boolean Implements System.Windows.Input.ICommand.CanExecute
    Return True
End Function

Public Event CanExecuteChanged(ByVal sender As Object, ByVal e As System.EventArgs) Implements System.Windows.Input.ICommand.CanExecuteChanged

Public Sub Execute(ByVal parameter As Object) Implements System.Windows.Input.ICommand.Execute
    MessageBox.Show("GrapeCity is the world's largest component vendor.", "About Us", MessageBoxButton.OK)
End Sub

    Show To write the code in C#

    C# code. Add after the statement using System.Text; Copy Code
    using System.Windows.Input;
using System.Windows;
    C# code. Add to MyCommand.cs Copy Code
    public class MyCommand : ICommand
    {
        public bool CanExecute(object parameter)
        {
            return true;
        }

        public void Execute(object parameter)
        {
            MessageBox.Show("GrapeCity is the world's largest component vendor.", "About Us", MessageBoxButton.OK);
        }

        public event EventHandler CanExecuteChanged;
    }
  5. In Solution Explorer, double-click DefaultWpfViewerTemplates.xaml.
  6. In the file that opens, add the following code.
    XML code. Add to DefaultWpfViewerTemplates.xaml Copy Code
    <ResourceDictionary>
 ...
xmlns:YourProjectName="clr-namespace:YourProjectName">
<YourProjectName:MyCommand x:Key="MyCommand" />
...
</ResourceDictionary>

  7. In the same file, add the following code to add a button.
    XML code. Add to DefaultWpfViewerTemplates.xaml before the closing Toolbar tag Copy Code
    <Button Command="{StaticResource MyCommand}" Content="About Us" />
  8. Press F5 to see the new customized button About Us in the Viewer toolbar.

Show To remove the Refresh button from the WPF Viewer toolbar

  1. In Solution Explorer, double-click DefaultWpfViewerTemplates.xaml.
  2. In the file that opens, search for "<!--Refresh btn-->".
  3. Replace the existing content in Visiblity="..." with the following.
    XML code. Add to DefaultWpfViewerTemplates.xaml Copy Code
    <Button Command=... Visibility="Collapsed">

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Layout

Layout
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Layout

Glossary Item Box

This section contains the following walkthroughs that fall under the layout category.

Creating a report using Report Parts
This walkthrough explains how to create a report using Report Parts in a application project.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Creating a report using Report Parts

Creating a report using Report Parts
ActiveReports 13 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Layout > Creating a report using Report Parts

Glossary Item Box

The walkthrough illustrates a step-by-step implementation for creating a report using Report Parts to display annual sales of an organization.

The walkthrough is spilt into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Creating a layout for the report
  • Enhancing the appearance of the report
  • Viewing the report
Note:
  • This walkthrough uses the SalesReport.rdlx report file. By default, in ActiveReports, the SalesReport.rdlx file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 13\Reports Gallery\C#\Reports\Page Report\Other.
  • Although this walkthrough uses Page reports, you can also implement report parts in RDL and Section reports.

When you complete this walkthrough, you will have a layout that looks similar to the following at design time and at run time.

Design Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Run-Time Layout

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Creating an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.

    Click to Enlarge Click to Enlarge
    Click to Shrink Click to Shrink

  2. In the New Project dialog that appears, select ActiveReports 13 Page Report Application and in the Name field, name the file as rptReportParts.
  3. Click OK to create a new ActiveReports 13 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Creating a layout for the report

  1. Select PageReport1.rdlx from the Solution Explorer.
  2. Open the Reports Library window. For more information on how to open the Reports Library window, see Show or Hide the Reports Library.
  3. To add a report part from the Reports Library window, right-click the Library node and select Add.
  4. In the Open dialog that appears, navigate through the GrapeCity Samples folder hierarchy mentioned above and select SalesReport.rdlx. Controls from SalesReport.rdlx are added as Report parts to your Report Library 13 window.
  5. Drag and drop the salesOverTime chart control from the Reports Library window onto the design surface. The report part is added to your report along with its data sources, data sets and parameters.
  6. Drag and drop the Image1 image from the Reports Library window onto the design surface.
  7. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  8. Hover over TextBox4 to reveal the field selection adorner, click it to display a list of available fields, and select the SaleDate field.
  9. Hover over TextBox5 to reveal the field selection adorner, click it to display a list of available fields, and select the Quantity field.
  10. Hover over TextBox6 to reveal the field selection adorner, click it to display a list of available fields, and select the Profit field.
  11. From the Visual Studio toolbox, drag and drop a Textbox control onto the design surface.
  12. Select the Textbox to view its properties in the Properties window and enter the text Annual Sales Report (2004-2005) in the Value property.

Enhancing the appearance of the report

When you preview the report at this point, you will notice the data from the fields is displayed in the Table data region. Let us now work on the report appearance to further enhance the layout.

  1. From the designer, select the Image control and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 0.095in, 0.156in
    Size | 1.3in, 1.1in
  2. From the designer, select TextBox10 and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 1.5in, 0.5in
    Size | 4.3in, 0.3in
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    FontSize | 16pt
  3. From the designer, select the Chart data region and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 0.1in, 1.3in
    Size | 6in, 4.125in
  4. From the designer, select the Table data region and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 1.25in, 5.5in
    Size | 4.25in, 1in
    FixedSize | 4.25in, 3.35in
    RepeatHeaderOnNewPage | True
  5. In the Table data region, select the textbox that contains the following fields and go to the Properties window to set the following properties.
    Cell | Property Name | Property Value
    Sale Date | BackgroundColor | LightCyan
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[SaleDate] | BorderStyle | Solid
    TextAlign | Center
    Quantity | BackgroundColor | LightCyan
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[Quantity] | BorderStyle | Solid
    TextAlign | Center
    Profit | BackgroundColor | LightCyan
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[Profit] | BorderStyle | Solid
    TextAlign | Center
    Format | Currency

Viewing the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Troubleshooting

Troubleshooting
ActiveReports 13 > ActiveReports User Guide > Troubleshooting

Glossary Item Box

Show All Show All
Hide All Hide All

If you run into an issue while using ActiveReports, you will probably find the solution within this section. Click any short description below to drop down the symptoms, cause, and solution. Or click a link to another section of the troubleshooting guide.

General Troubleshooting

Show Report menu does not appear in the main menu of Visual Studio 2019

Symptoms: When a report is opened in Visual Studio 2019, Report menu does not appear in the main menu.

Cause: Due to new behavior relating to extensions in Visual Studio 2019, Report menu is removed as main menu.

Solution: Go to Extensions menu. You can see that the Report menu is available as submenu.

Show References missing from Visual Studio Add Reference dialog

Symptoms: When you try to add references to your project, only a few of the ActiveReports references are available.

Cause: The project's target framework is set to an old version of the .NET framework that does not support the new assemblies.

Solution:

  1. In the Solution Explorer, right click the project and choose Properties.
  2. On the Application tab in C# projects (or the Compile tab, then the Advanced Compile Options button in Visual Basic projects), drop down the Target framework box and select .NET Framework 4.0.

Show Errors after installing a new build

Symptoms: When you open a project created with a previous build of ActiveReports after installing a new build, there are errors related to being unable to find the previous build.

Cause: Visual Studio has a property on references called Specific Version. If this property is set to True, the project looks for the specific version that you had installed when you created the report, and throws errors when it cannot find it.

Solution: For each of the ActiveReports references in the Solution Explorer, select the reference and change the Specific Version property to False in the Properties Window.

Show The project does not work if Integrated Managed Pipeline Mode is enabled

Symptoms: The web project does not work in the application pool if Integrated Managed Pipeline Mode is enabled.

Cause: The application configuration is incorrect for being used in Integrated mode.

Solution: Migrate the application configuration. Here is a sample command.

Paste the following on the command line. Copy Code
"%SystemRoot%\system32\inetsrv\appcmd migrate config YourWebSite/"

Show GrapeCity.ActiveReports.Interop64.dll is not available in the default "Add Reference" dialog

Symptoms: The GrapeCity.ActiveReports.Interop64.dll is not available in the default "Add Reference" dialog.

Cause: The GrapeCity.ActiveReports.Interop64.dll is located in the distribution folder.

Solution: The GrapeCity.ActiveReports.Interop64.dll is located in C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 13\redist.

Show GrapeCity.ActiveReports.Extensiblity.dll is added to the list of unused dlls in Visual Studio

Symptoms: GrapeCity.ActiveReports.Extensiblity.dll is added to the references folder when the viewer is dragged and dropped on the form, however it is present in the list of unused dll in Visual Studio.

Cause: GrapeCity.ActiveReports.Extensiblity.dll is used internally for certain features in ActiveReports and is present in the Global Assembly Cache. Therefore, Visual Studio can resolve the dependency and cannot find the direct references due to which it gets listed as a unused dll in Visual Studio.

Show Reports are not associated with the designer in Visual Studio when adding ActiveReports to a TFS-bound project

Symptoms: When adding ActiveReports to a Web site project that is bound to TFS (where reports are added to the App_Code folder), the report does not open in the designer in Visual Studio.

Cause: The FileAttributes.xml file that contains attribute information to associate ActiveReports files with the Designer is usually loaded and maintained in memory when a new ActiveReports file is added. However, if a Web site is bound to TFS, the FileAttributes.xml file is not maintained in memory. As a result, Visual Studio treats all the newly added files as normal code files.

Solution: Add the newly added reports to FileAttributes.xml manually.

  1. From the Website menu, select Add New Item.
  2. Select ActiveReports 13 Section Report (code-based) and click OK.
  3. Close the project.
  4. From Windows Explorer, open the FileAttributes.xml file in an editor and add the new ActiveReports file, setting the subtype to Component, using code like the following.

    Note: The FileAttributes.xml is located at C:\Documents and Settings\[username]\Local Settings\Application Data\Microsoft\WebsiteCache\[WebSite1]\ (Windows XP), or at C:\Users\[username]\AppData\Local\Microsoft\WebsiteCache\[WebSite1]\ (Windows 7).
    XML code. Paste inside FileAttributes.xml Copy Code
    <?xml version="1.0" encoding="utf-16" ?>
<DesignTimeData>
   <File RelativeUrl="App_Code/NewActiveReport1.cs" subtype="Component" />
   <File RelativeUrl="Default.aspx.cs" subtype="ASPXCodeBehind" codebehindowner="Default.aspx" />
   <File RelativeUrl="Default.aspx" subtype="ASPXCodeBehind" />
</DesignTimeData>
  5. Save the FileAttributes.xml file.
  6. Reopen the Web site project.

Show The SystemNotSupportedException occurs when running ActiveReports with scripts on .NET Framework 4.0

Symptoms: The SystemNotSupportedException occurs when running ActiveReports with scripts on .NET Framework 4.0.

Cause: This exception occurs because of the CAS policy, which is obsolete in the .NET Framework 4.0.

Solution: To resolve this issue, the configuration file needs to be updated. To do this, in the Solution Explorer, open the app.config file (for Windows Forms applications) or the Web.config file (for ASP.NET Web applications) and add the following code.

(Windows Forms Applications) XML code. Paste inside the app.config file Copy Code
<configuration>
  <runtime>
    <NetFx40_LegacySecurityPolicy enabled="true"/>
  </runtime>
</configuration>
(ASP.NET Web Applications) XML code. Paste inside the Web.config file Copy Code
<system.web>
   <trust legacyCasModel="true"/>
</system.web>

Show Microsoft Access OLE DB provider in a 64-bit system

Symptoms: Microsoft Access OLE DB provider, Microsoft.Jet.OLEDB.4.0 does not work on a 64-bit system.

Cause: In Visual Studio 2010, by default, projects are set to use 32 bit or 64 bit, depending on the environment on which they are run. The Microsoft Access OLE DB provider, Microsoft.Jet.OLEDB.4.0, is not compatible with 64 bit, so it fails with Visual Studio 2010 on a 64-bit system.

Solution: To avoid this situation, change the project settings to use only 32 bit.

  1. With the project open in Visual Studio, from the Project menu, select Project Properties.
  2. In the page that appears, select the Compile tab in a VB project, or the Build tab in a C# project.
  3. Scroll to the bottom of the page and click the Advanced Compile Options button in VB, or skip this step in C#.
  4. Drop down the Target CPU list in VB, or Platform target in C#, (set to use AnyCPU by default) and select x86.
  5. Click OK to save the changes, or skip this step in C#.

Show The printing thread dies before the report finishes printing

Symptoms: The printing thread dies before the report is printed.

Cause: If printing is done in a separate thread and the application is shut down right after the print call, the separate thread dies before the report is printed.

Solution: Set the usePrintingThread parameter of the Print() method to False to keep the printing on the same thread. This applies to all Page reports, RDL reports and Section reports.

  1. In the project where you call the Print method, add a reference to the GrapeCity.ActiveReports.Viewer.Win assembly.
  2. At the top of the code file where you call the Print method, add a using directive (Imports for VB) for GrapeCity.ActiveReports.
  3. Call the Print method with the usePrintingThread parameter (the third parameter) set to false with code like the following.
C# code. Copy Code
document.Print(false, false, false);
Visual Basic code. Copy Code
document.Print(False, False, False)

Show Exception thrown when using Viewer.Print to print a report

Symptoms: An exception is thrown when the Viewer.Print method is used to print a report.

Cause: Print method was called before the page was loaded completely.

Solution: Use the Viewer.Print method in the LoadCompleted event.

Show ActiveReports controls do not appear in the toolbox

Symptoms: ActiveReport controls do not appear in the toolbox even when they are added manually using the steps in Adding ActiveReports Controls.

Cause: The project is using .NET 2.0 or lower.

Solution: Confirm if the project is using .NET 3.5 or higher. ActiveReports does not support .NET 2.0.

Show Error on previewing Server reports

Symptoms: When you try to preview Server reports created in previous ActiveReports versions in ActiveReports 13 designer, error 'Server report is not supported' occurs.

Cause: The Server credentials are present in report definition and ActiveReports Server is not supported in ActiveReports 13.

Solution: Edit the report in any text editor and remove the <Custom Property> tag that contains the Server name and URL.

Show Error on rebuilding some ActiveReports samples in Visual Studio 2012 on .NET Framework 4.7 or higher

Symptoms: When you try to rebuild some ActiveReports samples in Visual Studio 2012 on .NET. Framework 4.7 or higher, compilation errors occur.

Cause: The default target framework version of the sample is 4.6.2.

Solution: In the App.config file of the project, drop the binding by removing <bindingRedirect oldVersion="0.0.0.0-4.2.0.0" newVersion="4.0.0.0" /> for the System.IO.Compression assembly.

Section Report Troubleshooting

Show Blank pages printed between pages, or a red line appears in the viewer

Symptoms: Blank pages are printed between pages of the report.

Cause: This problem occurs when the PrintWidth plus the left and right margins exceeds the paper width. For example, if the paper size were set to A4, the PrintWidth plus the left and right margins cannot exceed 8.27"; otherwise blank pages will be printed. At run time, ActiveReports marks a page overflow by displaying a red line in the viewer at the position in which the breach has occurred.

Solution: Adjust the PrintWidth in the report designer using either the property grid or by dragging the right edge of the report. Adjust page margins, height, and width either through the print properties dialog box (in the Report menu under Settings), or programmatically in the Report_Start event.

Show Copying reports results in stacked controls

Symptoms: A report file copied into a new project has all of its controls piled up at location 0, 0.

Cause: The report has become disconnected from its resource file. When you set a report"s Localizable property to True, the Size and Location properties of the report"s controls are moved to the associated *.resx file, so if you copy or move the report, you must move the *.resx file along with it.

Solution: When you copy a report"s *.vb or *.cs file from one project's App_Code folder into the App_Code folder of a new project, you need to also copy its *.resx file from the original project"s App_GlobalResources folder into the new project's App_GlobalResources folder.

Show No data appears in a report containing the OleObject control

Symptoms: No data appears in a report containing the OleObject control.

Cause: This issue occurs when the Microsoft .NET Framework 4.5.2 or above is used and the useLegacyV2RuntimeActivationPolicy attribute is not set to True.

Solution: Open the app.config file and set the useLegacyV2RuntimeActivationPolicy attribute to true.

XML code. Paste INSIDE the app.config file. Copy Code
<configuration>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="MyRunTimeVersion"/>
</startup>
</configuration>

Show An error message appears in the Fields list

Symptoms: An error message is displayed in the Fields list in the Report Explorer instead of the fields.

Cause: This is an expected error if no default value is given for a parameter. If the field is a data type other than text, memo, or date/time in Access, the report still runs normally.

Solution: To display the fields in the Fields list in the Report Explorer, supply a default value for the parameter in the Properties Window, or in the SQL query as below:

SQL Query Copy Code
<%Name | PromptString | DefaultValue | DataType | PromptUser%>

Only the Name parameter is required. To use some, but not all, of the optional parameters, use all of the separator characters but with no text between one and the next for unused parameters. For example:

SQL Query Copy Code
<%Name | | DefaultValue | |%>

Show An unhandled exception of type "System.Data..." occurs when the report is run

Symptoms: When the report is run, an exception like the following occurs: "An unhandled exception of type "System.Data.OleDb.OleDbException" occurred in system.data.dll"

Cause: If the field is a text, memo, or date/time data type in Access, the parameter syntax requires single quotes for text or memo fields, or pound signs for date/time fields. Please note that for different data sources, these requirements may differ.

Solution: To avoid the exception when the report is run against an Access database, use pound signs for date/time values, or single quotes for string values in your SQL query, for example:

SQL Query Copy Code
#<%InvoiceDate | Choose invoice date: | 11/2/04 | D | True%>#

or

SQL Query Copy Code
"<%Country | Country: | Germany | S | True%>"

Show User is prompted for parameters for subreports even though they are supplied by the main report

Symptoms: The parameter user interface pops up at run time asking for a value even though the main report is supplying the parameter values for the subreports.

Cause: The default value of the ShowParameterUI property of the report is True.

Solution: Set the ShowParameterUI property of the report to False. This can be done in the property grid or in code in the ReportStart event.

Show The viewer shows the report on the wrong paper size

Symptoms: In the viewer, the report renders to a different paper size than the one specified.

Cause: ActiveReports polls the printer driver assigned to the report to check for clipping, margins, and paper sizes supported by the printer. If the paper size specified for the report is not supported by the printer, ActiveReports uses the printer's default paper size to render the report.

Solution: If the report is to be printed, the printer assigned to the report must support the paper size and margins. Please note that any changes to the print settings in code must be made in or before the ReportStart event. To use custom paper sizes not supported by the driver, set the PrinterName to an empty string to use the ActiveReports virtual print driver. This does not allow printing, but is recommended for reports that are only exported or viewed. This prevents ActiveReports from making a call to the default printer driver. Use the following code in the ReportStart event, or just before .Run is called.

C# code. Paste INSIDE the ReportStart event. Copy Code
this.Document.Printer.PrinterName = '';
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
Me.Document.Printer.PrinterName = ''

The PaperHeight and PaperWidth properties, which take a float value defined in inches, have no effect unless you set the PaperKind property to Custom. Here is some sample code which can be placed in the ReportStart event, or just before .Run.

C# code. Paste INSIDE the ReportStart event. Copy Code
this.PageSettings.PaperKind = Drawing.Printing.PaperKind.Custom;
this.PageSettings.PaperHeight = 2;
//sets the height to two inches
this.PageSettings.PaperWidth = 4;
//sets the width to four inches
Visual Basic.NET code. Paste INSIDE the ReportStart event. Copy Code
Me.PageSettings.PaperKind = Drawing.Printing.PaperKind.Custom
Me.PageSettings.PaperHeight = 2
'sets the height to two inches
Me.PageSettings.PaperWidth = 4
'sets the width to four inches

Show Custom paper sizes do not work

Symptoms: Custom paper sizes do not work.

Cause: You can create more than one custom paper size, so setting only the PaperKind property is not enough to create a custom paper size.

Solution: In addition to setting the PaperKind property to Custom, you must also set the PaperName property to a unique string.

Page/RDL Report Troubleshooting

Show An expression containing a numeric field name does not display any data at run time.

Symptoms: An expression containing a numeric field name does not display any data at runtime.

Cause: Visual Basic syntax does not allow an identifier that begins with a number.

i.e. =Fields!2004.Value

Solution: Make the numeric field name a string.

i.e. =Fields("2004").Value or, =Fields.Item("2004").Value

Show DataSet field in PageHeader of an RDL report

Symptoms: Cannot set a dataset field (bound field) in the PageHeader of an RDL report.

Cause: ActiveReports is based on the RDL 2005 specifications, therefore, referencing datasets in the PageHeader of an RDL report is not supported.

Solution: There is no direct way to add a DataField in a PageHeader, however, as a workaround you can create a hidden report parameter that is bound to your dataset and has the default value set to your expression. For example, ="*" & First(Fields!name.Value). You can then use this parameter in the page header.
Alternatively, you can use a Page report, which lets you place data fields anywhere on a page.

Show Exception thrown when using Viewer.Document property

Symptoms: An exception is raised when Viewer.Document is used with a page report or RDL report.

Cause: Document property is available for section reports only.

Show Cannot add assembly reference created in .NET Framework 4.0 or above in PageReports/RDLReports

Symptoms: Cannot add assembly reference created in .NET Framework 4.0 or above in PageReports/RDLReports of the stand-alone designer application.

Cause: The Stand-alone Designer application was created using the .NET 3.5 framework, therefore it cannot load .NET 4.0 assemblies.

WPF Viewer Troubleshooting

Show TargetInvocationException occurs when running the WPF browser application

Symptoms: When running the WPF browser application, the TargetInvocationException occurs.

Cause: The WPF browser application does not support Partial Trust.

Solution: Make sure that the WPF browser application uses Full Trust. To do that, in the Visual Studio Project menu, go to YourProject Properties and on the Security tab, under EnableClickOnce security settings, select the option This is a full trust application.

Memory Troubleshooting

Note: According to Microsoft it is not necessary to call GC.Collect and it should be avoided. However, if calling GC.Collect reduces the memory leak, then this indicates that it is not a leak after all. A leak in managed code is caused by holding a reference to an object indefinitely. If ActiveReports is holding a reference to an object, then the object cannot be collected by the garbage collector.

Symptoms: ActiveReports is consuming too much memory; CPU usage always goes to 100% when using ActiveReports.

Cause: There are several reasons why too much memory may be consumed:

Show The report is not being disposed of properly

Cause: The report is not being disposed of properly. The incorrect syntax is as follows.

C# code. Copy Code
//Incorrect!
rpt.Dispose();
rpt=null;
Visual Basic code. Copy Code
'Incorrect!
rpt.Dispose()
rpt=Nothing

Solution: The correct syntax for disposing of a section report is as follows.

C# code. Copy Code
//Correct!
rpt.Document.Dispose();
rpt.Dispose();
rpt=null;
Visual Basic code. Copy Code
'Correct!
rpt.Document.Dispose()
rpt.Dispose()
rpt=Nothing

Show Machine.Config MemoryLimit setting is insufficient

Cause: Large reports in an ASP.NET application can easily use up the 60% of memory allocated to the ASP.NET worker process by default, which produces an error. In Machine.Config, MemoryLimit specifies the maximum allowed memory size, as a percentage of total system memory, that the worker process can consume before ASP.NET launches a new process and reassigns existing requests.

Solution: Set the CacheToDisk property of the document to True.

This caches the report to disk instead of holding it in memory. This setting is also detected by the PDF Export, which follows suit, but any other exports still consume memory. Although it is not advised, the ASP.NET worker process memory allocation can also be changed in your Machine.Config file, which is located in a path like: C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Config\. Search the Machine.Config file for memoryLimit, which is located in the processModel.

Show Report never finishes processing

Cause: In some cases, very large reports can consume so much memory that the report never finishes processing. Some of the things that can cause this include:

  1. Many non-repeating images, or a high resolution repeating image
  2. Instantiating a new instance of a subreport each time the format event of a section fires
  3. Using a lot of subreports instead of grouping with joins in the SQL query
  4. Pulling in all of the data when only a few fields are needed (e.g. Select * from db instead of Select First, Last, Address from db)

Solution: In cases where the report is too large to run any other way, the CacheToDisk property may be set to True. This property should only be used when there is no other way to run the report to completion. Before resorting to this method, please see the Optimizing Section Reports topic.

Show Task manager indicates the current "working set" of the process

Cause: If inflated memory usage is seen in the Task Manager it is not necessarily in use by the code. Task manager indicates the current "working set" of the process and, upon request, other processes can gain access to that memory. It is managed by the Operating System.

Solution: For an example of some working set behavior anomalies (which are considered normal), create a WinForms application and run it. Look in Task Manager at the working set for that process (it should be several megabytes), then minimize and maximize the form and notice that the working set reclaims to <1MB. Obviously, the code was not using all that memory even though Task Manager showed that it was allocated to that process. Similarly, you'll see ASP.NET and other managed service processes continue to gradually grow their working set even though the managed code in that process is not using all of it. To see whether this is the case, try using the two lines of code below in a button Click event after running the project.

System.Diagnostics.Process pc = System.Diagnostics.Process.GetCurrentProcess();
pc.MaxWorkingSet = pc.MinWorkingSet;

If that reclaims the memory then the Operating System trimmed the working set down to the minimum amount necessary and this indicates that the extra memory was not actually in use.

WebViewer Troubleshooting

Show The WebViewer will not print without displaying the report

Symptoms: The WebViewer will not automatically print a report without displaying it.

Cause: Only the new FlashViewer ViewerType of the WebViewer offers this functionality.

Solution:

  1. Set the ViewerType property to FlashViewer.
  2. Expand the FlashViewerOptions property, and expand the PrintOptions subproperty.
  3. Under the PrintOptions subproperty, set the StartPrint property to True.

Show PDF opens in a new window when an application contains the WebViewer

Symptoms: When using Internet Explorer and Acrobat Reader to view a page containing a WebViewer in PDF mode, the resulting PDF always opens in a new window.

Cause: Acrobat Reader is only available in a 32-bit version. When the 64-bit version of Internet Explorer is used, it opens up an instance of the 32-bit version of Internet Explorer so that the plug-in and the PDF can load, rendering the resulting PDF in a new window.

Solution:

  • Install a PDF reader plug-in that is 64-bit compatible.
    OR
  • Use the 32-bit version of Internet Explorer.

Show The report in the HTML viewer type does not look exactly like the other viewer types

Symptoms: The report in the HTML viewer type does not look exactly like the other viewer types.

Cause: The HTML format is not WYSIWYG. It does not support the following items:

  • Line control
  • Control borders
  • Shapes (other than filled rects)
  • CrossSectionBox and CrossSectionLine controls
  • Overlapping controls

Solution: Try to avoid using the above items in reports which are shown in HTML format.

Show Blank reports with the AcrobatReader viewer type on the production web server

Symptoms: In the WebViewer, reports render correctly with the HTML ViewerType but they show up blank with the AcrobatReader ViewerType on the production web server.

Cause: .ArCacheItem is not set up in your IIS extension mappings.

Solution:

  1. From the Start menu, choose Control Panel, then Administrative Tools, then Internet Information Services.
  2. Right-click your Default Web Site and choose Properties.
  3. On the Home Directory tab, click the Configuration button.
  4. On the Mapping tab, check the Extension column to see whether .ArCacheItem appears. If not, click Add.
  5. In the Add/Edit Application Extension Mapping dialog that appears, click Browse and navigate to (Windows)\Microsoft.NET\Framework\vx.0.
  6. In the Open dialog, change Files of type to Dynamic Link libraries (*.dll).
  7. Select aspnet_isapi.dll and click Open.
  8. In the Extension textbox type .ArCacheItem.
  9. Click the Limit to radio button and type GET,HEAD,POST,DEBUG.
  10. Ensure that the Script engine check box is selected and the Check that file exists check box is cleared.
  11. Click OK.

HTML5 Viewer Troubleshooting

Show Issue while previewing reports in HTML5 using redirection

Symptoms: When a url, such as an image path, a drill-through path, or a toggle path in a report points to an intranet location, the element specified in the url is not displayed properly.

Cause: One server can not access the paths specified from another server. For example, when HTML5 Viewer gets the report in HTML, the images use the img element and the src attribute of the image is built on the server side which uses default intranet url instead of the internet url.

Solution: Use HTML5 viewer together with reverse proxy or other redirection environment by specifying the following settings:

  1. Add the following line of code in index.html:
    Paste inside the index.html file Copy Code
    reportService: { url: 'http://reverse-proxy.com'; };

    See Using Javascript for more information.

  2. Specify publicURL setting in Web.config file as follows:
    XML code. Paste inside the Web.config file Copy Code
    <>
<WebService publicURI="https://reverse-proxy.com"/>
</>

    See ReportService Settings for more information.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Class Library

Class Library
ActiveReports 13 > Class Library

Glossary Item Box

The Class Library contains documentation and code samples for the entire ActiveReports API.

This section contains information about

GrapeCity.ActiveReports Assembly
This assembly contains the namespaces ActiveReports, Data, Expressions, Extensibility, Rendering, ReportsCore, and SectionReportModel.
GrapeCity.ActiveReports.Aspnet.Designer Assembly
This assembly contains the Services and Utilities namespaces for Aspnet Designer.
GrapeCity.ActiveReports.Aspnet.Viewer Assembly
This assembly contains the Services and Utilities namespaces for Aspnet Viewer.
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly
This assembly contains the Services and Utilities namespaces for Aspnetcore Designer.
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly
This assembly contains the Services and Utilities namespaces for Aspnetcore Viewer.
GrapeCity.ActiveReports.Design.Win Assembly
This assembly contains the Design namespace (including all End User Report Designer features).
GrapeCity.ActiveReports.Document Assembly
This assembly contains the namespaces ActiveReports (border classes), Document.Section (including canvas drawing classes, bookmarks, paper sizes, etc.), Export, Export.Html (for HTML output types) and Extensibility.Printing.
GrapeCity.ActiveReports.Export.Excel Assembly
This assembly contains the Export.Excel namespace (Excel export class with export methods and properties).
GrapeCity.ActiveReports.Export.Html Assembly
This assembly contains the Export.Html namespace (HTML export class with export methods and properties).
GrapeCity.ActiveReports.Export.Image Assembly
This assembly contains the Export.Image namespace (Image export class with export methods and properties).
GrapeCity.ActiveReports.Export.Pdf Assembly
This assembly contains the Export.Pdf namespace (PDF export, document options, and security classes).
GrapeCity.ActiveReports.Export.Word Assembly
This assembly contains the Export.Word namespace (Word export class with export methods and properties).
GrapeCity.ActiveReports.Export.Xml Assembly
This assembly contains the Export.Xml namespace (XML export class with export methods and properties).
GrapeCity.ActiveReports.Viewer.Win Assembly
This assembly contains the Windows.Forms namespace (Viewer class with methods and properties).
GrapeCity.ActiveReports.Viewer.Wpf Assembly
This assembly contains Viewer.Wpf namespace (classes similar to Viewer.Win namespace).
GrapeCity.ActiveReports.Web Assembly
This assembly contains the namespaces Web (including the WebViewer), WebControls, ExportOptions, and Handlers.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports)

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports Namespace

Glossary Item Box

The GrapeCity.ActiveReports namespace contains the report, control, and section classes that are the basis of all reports.

Classes

 | Class | Description
Class | GraphicsExtensions | Provides the extensions for GDI+ drawing surface implementation.
Class | LocateCredentialsEventArgs | Provides data for LocateCredentials event.
Class | LocateDataSourceEventArgs | Provides data for the LocateDataSource event.
Class | PageReport | Loads, modifies, or saves a report definition.
Class | PageSettings | Specifies the page settings used to print the report document pages.
Class | ReportDataException | This exception is thrown when an error occurs while connecting to the report's data source.
Class | ReportException | This exception or one of its descendent classes is thrown when an error occurs while running the report.
Class | ReportScriptException | The ReportScriptException is thrown when an error occurs in the report scripting code or any of the report's calculated DataField expressions.
Class | SectionCollection | Represents a collection of all sections (Section objects) in the report layout.
Class | SectionReport | The SectionReport class is the base class for all section reports. It is used to execute and render the report.
Class | SectionReport.FetchEventArgs | FetchEventArgs class provides data required for the FetchData Event.
Class | SystemPrinter | Represents the settings of the SystemPrinter class.

Delegates

 | Delegate | Description
Delegate | LocateCredentialsEventHandler | Represents method that handles LocateCredentials event.
Delegate | LocateDataSourceEventHandler | Represents the method that will handle the LocateDataSource event
Delegate | SectionReport.FetchEventHandler | Represents the method that handles the FetchData event.
Delegate | SectionReport.ParameterUIClosedHandler | Represents a method that handles the ParameterUIClosed event.

Enumerations

 | Enumeration | Description
Enumeration | LayoutAction | Specifies the action to be performed after a section is formatted.
Enumeration | PageSettings.PrinterCollate | Determines the collation order when printing multiple copies of a report.
Enumeration | ReportProcessingError | Describe possible error codes for future detail processing of the error.
Enumeration | SectionReport.ReportState | Determines the current state of the report engine.
Enumeration | SectionReport.RpxFormat | Specifies the format in which the report is to be saved.

See Also

Reference

GrapeCity.ActiveReports Assembly

Copyright © GrapeCity, Inc. All rights reserved.

© 2020 All Rights Reserved.


GraphicsExtensions Class

[image]
ActiveReports 13
GraphicsExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : GraphicsExtensions Class

Glossary Item Box

Provides the extensions for GDI+ drawing surface implementation.

Object Model

GraphicsExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class GraphicsExtensions
C#
public static class GraphicsExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.GraphicsExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsExtensions Members
GrapeCity.ActiveReports Namespace


GraphicsExtensions Class Members

[image]
ActiveReports 13
GraphicsExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : GraphicsExtensions Class

Glossary Item Box

The following tables list the members exposed by GraphicsExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateBrush | Creates new brush depending of specified background style.
static (Shared in Visual Basic) | CreateGradientBrush | Creates a new gradient brush based on a rectangle, starting and ending colors, and an orientation mode.
static (Shared in Visual Basic) | DrawDoubleLine | Draws a double line connecting the two points specified by the coordinate pairs.
static (Shared in Visual Basic) | DrawEllipseDoubleLine | Draws an ellipse specified by a bounding System.Drawing.Rectangle structure.
static (Shared in Visual Basic) | DrawRoundWithDoubleLine | Draws a round rectangle using a double line.
static (Shared in Visual Basic) | FillRound | Fills the round rectangle.
Top

See Also

Reference

GraphicsExtensions Class
GrapeCity.ActiveReports Namespace


GraphicsExtensions Class Methods

[image]
ActiveReports 13
GraphicsExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : GraphicsExtensions Class

Glossary Item Box

For a list of all members of this type, see GraphicsExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateBrush | Creates new brush depending of specified background style.
static (Shared in Visual Basic) | CreateGradientBrush | Creates a new gradient brush based on a rectangle, starting and ending colors, and an orientation mode.
static (Shared in Visual Basic) | DrawDoubleLine | Draws a double line connecting the two points specified by the coordinate pairs.
static (Shared in Visual Basic) | DrawEllipseDoubleLine | Draws an ellipse specified by a bounding System.Drawing.Rectangle structure.
static (Shared in Visual Basic) | DrawRoundWithDoubleLine | Draws a round rectangle using a double line.
static (Shared in Visual Basic) | FillRound | Fills the round rectangle.
Top

See Also

Reference

GraphicsExtensions Class
GrapeCity.ActiveReports Namespace


CreateBrush Method

[image]
ActiveReports 13
CreateBrush Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > GraphicsExtensions Class : CreateBrush Method

graphics
The graphics to draw on.
backgroundStyle
The style of the background.
hatchStyle
One of the System.Drawing.Drawing2D.HatchStyle values that represents the pattern drawn by this brush.
gradientStyle
One of the GrapeCity.ActiveReports.SectionReportModel.GradientStyle values the defines the gradient style.
rect
A System.Drawing.RectangleF structure that specifies the bounds of the linear gradient.
firstColor
A System.Drawing.Color structure that represents the first color.
secondColor
A System.Drawing.Color structure that represents the second color.

Glossary Item Box

Creates new brush depending of specified background style.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateBrush( _
   ByVal graphics As Graphics, _
   ByVal backgroundStyle As BackgroundStyle, _
   ByVal hatchStyle As HatchStyle, _
   ByVal gradientStyle As GradientStyle, _
   ByVal rect As RectangleF, _
   ByVal firstColor As Color, _
   ByVal secondColor As Color _
) As Brush
C#
public static Brush CreateBrush(
   Graphics graphics,
   BackgroundStyle backgroundStyle,
   HatchStyle hatchStyle,
   GradientStyle gradientStyle,
   RectangleF rect,
   Color firstColor,
   Color secondColor
)

Parameters

graphics
The graphics to draw on.
backgroundStyle
The style of the background.
hatchStyle
One of the System.Drawing.Drawing2D.HatchStyle values that represents the pattern drawn by this brush.
gradientStyle
One of the GrapeCity.ActiveReports.SectionReportModel.GradientStyle values the defines the gradient style.
rect
A System.Drawing.RectangleF structure that specifies the bounds of the linear gradient.
firstColor
A System.Drawing.Color structure that represents the first color.
secondColor
A System.Drawing.Color structure that represents the second color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsExtensions Class
GraphicsExtensions Members


CreateGradientBrush Method

[image]
ActiveReports 13
CreateGradientBrush Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > GraphicsExtensions Class : CreateGradientBrush Method

graphics
The graphics to draw on.
rect
A System.Drawing.RectangleF structure that specifies the bounds of the linear gradient.
gradientStyle
The style of the gradient.
firstColor
A System.Drawing.Color structure that represents the starting color for the gradient.
secondColor
A System.Drawing.Color structure that represents the ending color for the gradient.

Glossary Item Box

Creates a new gradient brush based on a rectangle, starting and ending colors, and an orientation mode.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateGradientBrush( _
   ByVal graphics As Graphics, _
   ByVal rect As RectangleF, _
   ByVal gradientStyle As GradientStyle, _
   ByVal firstColor As Color, _
   ByVal secondColor As Color _
) As Brush
C#
public static Brush CreateGradientBrush(
   Graphics graphics,
   RectangleF rect,
   GradientStyle gradientStyle,
   Color firstColor,
   Color secondColor
)

Parameters

graphics
The graphics to draw on.
rect
A System.Drawing.RectangleF structure that specifies the bounds of the linear gradient.
gradientStyle
The style of the gradient.
firstColor
A System.Drawing.Color structure that represents the starting color for the gradient.
secondColor
A System.Drawing.Color structure that represents the ending color for the gradient.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsExtensions Class
GraphicsExtensions Members


DrawDoubleLine Method

[image]
ActiveReports 13
DrawDoubleLine Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > GraphicsExtensions Class : DrawDoubleLine Method

g
The graphics to draw on.
pen
System.Drawing.Pen that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

Glossary Item Box

Draws a double line connecting the two points specified by the coordinate pairs.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawDoubleLine( _
   ByVal g As Graphics, _
   ByVal pen As Pen, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public static void DrawDoubleLine(
   Graphics g,
   Pen pen,
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

g
The graphics to draw on.
pen
System.Drawing.Pen that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsExtensions Class
GraphicsExtensions Members


DrawEllipseDoubleLine Method

[image]
ActiveReports 13
DrawEllipseDoubleLine Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > GraphicsExtensions Class : DrawEllipseDoubleLine Method

graphics
The graphics to draw on.
rect
System.Drawing.Rectangle structure that defines the boundaries of the ellipse.
pen
System.Drawing.Pen that determines the color, width, and style of the ellipse.
style
The style of double line.

Glossary Item Box

Draws an ellipse specified by a bounding System.Drawing.Rectangle structure.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawEllipseDoubleLine( _
   ByVal graphics As Graphics, _
   ByVal rect As Rectangle, _
   ByVal pen As Pen, _
   ByVal style As Integer _
)
C#
public static void DrawEllipseDoubleLine(
   Graphics graphics,
   Rectangle rect,
   Pen pen,
   int style
)

Parameters

graphics
The graphics to draw on.
rect
System.Drawing.Rectangle structure that defines the boundaries of the ellipse.
pen
System.Drawing.Pen that determines the color, width, and style of the ellipse.
style
The style of double line.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsExtensions Class
GraphicsExtensions Members


DrawRoundWithDoubleLine Method

[image]
ActiveReports 13
DrawRoundWithDoubleLine Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > GraphicsExtensions Class : DrawRoundWithDoubleLine Method

graphics
The graphics to draw on.
rect
System.Drawing.Rectangle structure that defines the boundaries of the round rectangle.
pen
System.Drawing.Pen that determines the color, width, and style of the line.
style
The style of double line.
tl
The top left rounding radius.
tr
The top right rounding radius.
br
The bottom right rounding radius.
bl
The bottom left rounding radius.

Glossary Item Box

Draws a round rectangle using a double line.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawRoundWithDoubleLine( _
   ByVal graphics As Graphics, _
   ByVal rect As Rectangle, _
   ByVal pen As Pen, _
   ByVal style As Integer, _
   ByVal tl As Integer, _
   ByVal tr As Integer, _
   ByVal br As Integer, _
   ByVal bl As Integer _
)
C#
public static void DrawRoundWithDoubleLine(
   Graphics graphics,
   Rectangle rect,
   Pen pen,
   int style,
   int tl,
   int tr,
   int br,
   int bl
)

Parameters

graphics
The graphics to draw on.
rect
System.Drawing.Rectangle structure that defines the boundaries of the round rectangle.
pen
System.Drawing.Pen that determines the color, width, and style of the line.
style
The style of double line.
tl
The top left rounding radius.
tr
The top right rounding radius.
br
The bottom right rounding radius.
bl
The bottom left rounding radius.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsExtensions Class
GraphicsExtensions Members


FillRound Method

[image]
ActiveReports 13
FillRound Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > GraphicsExtensions Class : FillRound Method

graphics
The graphics to draw on.
rect
System.Drawing.Rectangle structure that defines the boundaries of the round rectangle.
brush
System.Drawing.Brush that determines the characteristics of the fill.
tl
The top left rounding radius.
tr
The top right rounding radius.
br
The bottom right rounding radius.
bl
The bottom left rounding radius.

Glossary Item Box

Fills the round rectangle.

Syntax

Visual Basic (Declaration)
Public Shared Sub FillRound( _
   ByVal graphics As Graphics, _
   ByVal rect As Rectangle, _
   ByVal brush As Brush, _
   ByVal tl As Integer, _
   ByVal tr As Integer, _
   ByVal br As Integer, _
   ByVal bl As Integer _
)
C#
public static void FillRound(
   Graphics graphics,
   Rectangle rect,
   Brush brush,
   int tl,
   int tr,
   int br,
   int bl
)

Parameters

graphics
The graphics to draw on.
rect
System.Drawing.Rectangle structure that defines the boundaries of the round rectangle.
brush
System.Drawing.Brush that determines the characteristics of the fill.
tl
The top left rounding radius.
tr
The top right rounding radius.
br
The bottom right rounding radius.
bl
The bottom left rounding radius.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GraphicsExtensions Class
GraphicsExtensions Members


LocateCredentialsEventArgs Class

[image]
ActiveReports 13
LocateCredentialsEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

Glossary Item Box

Provides data for LocateCredentials event.

Object Model

LocateCredentialsEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocateCredentialsEventArgs
   Inherits System.EventArgs
C#
public sealed class LocateCredentialsEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.LocateCredentialsEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Members
GrapeCity.ActiveReports Namespace


LocateCredentialsEventArgs Class Members

[image]
ActiveReports 13
LocateCredentialsEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

Glossary Item Box

The following tables list the members exposed by LocateCredentialsEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LocateCredentialsEventArgs Constructor | Initializes new instance of LocateCredentialsEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | DataSource | Gets the data source to locate credentials for.
Public Property | Password | Gets ot sets the password of the credentials to be located.
Public Property | PromptText | Gets the text of prompt of the locate credentials request.
Public Property | ReportPath | Gets the name of the report to locate credentials for.
Public Property | UserName | Gets ot sets the user name of the credentials to be located.
Top

See Also

Reference

LocateCredentialsEventArgs Class
GrapeCity.ActiveReports Namespace


LocateCredentialsEventArgs Constructor

[image]
ActiveReports 13
LocateCredentialsEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : LocateCredentialsEventArgs Constructor

dataSource
The data source to locate credentials for.
reportPath
The name of the report to locate credentials for.
promptText
The text of prompt of the locate credentials request.

Glossary Item Box

Initializes new instance of LocateCredentialsEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataSource As GrapeCity.ActiveReports.PageReportModel.DataSource, _
   ByVal reportPath As String, _
   ByVal promptText As String _
)
C#
public LocateCredentialsEventArgs(
   GrapeCity.ActiveReports.PageReportModel.DataSource dataSource,
   string reportPath,
   string promptText
)

Parameters

dataSource
The data source to locate credentials for.
reportPath
The name of the report to locate credentials for.
promptText
The text of prompt of the locate credentials request.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


LocateCredentialsEventArgs Class Properties

[image]
ActiveReports 13
LocateCredentialsEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

Glossary Item Box

For a list of all members of this type, see LocateCredentialsEventArgs members.

Public Properties

 | Name | Description
Public Property | DataSource | Gets the data source to locate credentials for.
Public Property | Password | Gets ot sets the password of the credentials to be located.
Public Property | PromptText | Gets the text of prompt of the locate credentials request.
Public Property | ReportPath | Gets the name of the report to locate credentials for.
Public Property | UserName | Gets ot sets the user name of the credentials to be located.
Top

See Also

Reference

LocateCredentialsEventArgs Class
GrapeCity.ActiveReports Namespace


DataSource Property

[image]
ActiveReports 13
DataSource Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : DataSource Property

Glossary Item Box

Gets the data source to locate credentials for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As GrapeCity.ActiveReports.PageReportModel.DataSource
C#
public GrapeCity.ActiveReports.PageReportModel.DataSource DataSource {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


Password Property

[image]
ActiveReports 13
Password Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : Password Property

Glossary Item Box

Gets ot sets the password of the credentials to be located.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


PromptText Property

[image]
ActiveReports 13
PromptText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : PromptText Property

Glossary Item Box

Gets the text of prompt of the locate credentials request.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PromptText As String
C#
public string PromptText {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


ReportPath Property

[image]
ActiveReports 13
ReportPath Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : ReportPath Property

Glossary Item Box

Gets the name of the report to locate credentials for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportPath As String
C#
public string ReportPath {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


UserName Property

[image]
ActiveReports 13
UserName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : UserName Property

Glossary Item Box

Gets ot sets the user name of the credentials to be located.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


LocateDataSourceEventArgs Class

[image]
ActiveReports 13
LocateDataSourceEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

Glossary Item Box

Provides data for the LocateDataSource event.

Object Model

LocateDataSourceEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LocateDataSourceEventArgs
   Inherits System.EventArgs
C#
public sealed class LocateDataSourceEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.LocateDataSourceEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Members
GrapeCity.ActiveReports Namespace


LocateDataSourceEventArgs Class Members

[image]
ActiveReports 13
LocateDataSourceEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

Glossary Item Box

The following tables list the members exposed by LocateDataSourceEventArgs.

Public Properties

 | Name | Description
Public Property | Data | The data returned by the event handler.
Public Property | DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Public Property | Parameters | Gets the Parameters collection specified for a given report instance.
Public Property | Report | Gets the Report that is trying to locate the data set.
Top

See Also

Reference

LocateDataSourceEventArgs Class
GrapeCity.ActiveReports Namespace


LocateDataSourceEventArgs Class Properties

[image]
ActiveReports 13
LocateDataSourceEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

Glossary Item Box

For a list of all members of this type, see LocateDataSourceEventArgs members.

Public Properties

 | Name | Description
Public Property | Data | The data returned by the event handler.
Public Property | DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Public Property | Parameters | Gets the Parameters collection specified for a given report instance.
Public Property | Report | Gets the Report that is trying to locate the data set.
Top

See Also

Reference

LocateDataSourceEventArgs Class
GrapeCity.ActiveReports Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Data Property

Glossary Item Box

The data returned by the event handler.

Syntax

Visual Basic (Declaration)
Public Property Data As Object
C#
public object Data {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


DataSet Property

[image]
ActiveReports 13
DataSet Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : DataSet Property

Glossary Item Box

Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSet As GrapeCity.ActiveReports.PageReportModel.IDataSet
C#
public GrapeCity.ActiveReports.PageReportModel.IDataSet DataSet {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


Parameters Property

[image]
ActiveReports 13
Parameters Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Parameters Property

Glossary Item Box

Gets the Parameters collection specified for a given report instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IReadOnlyList(Of DataParameter)
C#
public IReadOnlyList<DataParameter> Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


Report Property

[image]
ActiveReports 13
Report Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Report Property

Glossary Item Box

Gets the Report that is trying to locate the data set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As GrapeCity.ActiveReports.PageReportModel.Report
C#
public GrapeCity.ActiveReports.PageReportModel.Report Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


PageReport Class

[image]
ActiveReports 13
PageReport Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

Loads, modifies, or saves a report definition.

Object Model

PageReport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageReport
   Inherits System.ComponentModel.Component
   Implements IReportComponentFactory
C#
public sealed class PageReport : System.ComponentModel.Component, IReportComponentFactory

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Members
GrapeCity.ActiveReports Namespace


PageReport Class Members

[image]
ActiveReports 13
PageReport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

The following tables list the members exposed by PageReport.

Public Constructors

 | Name | Description
Public Constructor | PageReport Constructor | Overloaded. Initializes a new instance of PageReport class.
Top

Public Properties

 | Name | Description
Public Property | ConfigurationProvider | Gets or sets the IConfigurationProvider associated with this ReportDefinition.
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | Document | Gets the document.
Public Property | Report | Returns the current report definition object.
Public Property | ResourceLocator | Gets the object responsible for resolving report resources.
Public Property | Site | Gets or sets the ISite of the Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFromMaster | Overloaded. Creates blank report with all of the content placeholders from specified master report.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Initialize | Allows post-initialization of the PageReport instance.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Load | Overloaded. Loads the specified report definition file.
Public Method | Run | Runs the specified report definition file.
Public Method | Save | Overloaded. Saves the report definition to the specified file.
Public Method | ToRdlString | Returns the report definition language (RDL) as a System.String in the report definition.
Public Method | ToString | Returns a String containing the name of the Component, if any. (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


PageReport Constructor

[image]
ActiveReports 13
PageReport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : PageReport Constructor

Glossary Item Box

Initializes a new instance of PageReport class.

Overload List

Overload | Description
PageReport Constructor() | Initializes a new instance of PageReport class.
PageReport Constructor(FileInfo) | Initializes a new instance of PageReport class using the specified report definition file.
PageReport Constructor(TextReader) | Initializes a new instance of PageReport class using the specified report definition.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


PageReport Constructor()

[image]
ActiveReports 13
PageReport Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor()

Glossary Item Box

Initializes a new instance of PageReport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Constructor(FileInfo)

[image]
ActiveReports 13
PageReport Constructor(FileInfo)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor(FileInfo)

reportDefinitionFile
The report definition (*.rdlx) file to load.

Glossary Item Box

Initializes a new instance of PageReport class using the specified report definition file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportDefinitionFile As FileInfo _
)
C#
public PageReport(
   FileInfo reportDefinitionFile
)

Parameters

reportDefinitionFile
The report definition (*.rdlx) file to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Constructor(TextReader)

[image]
ActiveReports 13
PageReport Constructor(TextReader)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor(TextReader)

reportDefinitionReader
The report definition (*.rdlx) file to load.

Glossary Item Box

Initializes a new instance of PageReport class using the specified report definition.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportDefinitionReader As TextReader _
)
C#
public PageReport(
   TextReader reportDefinitionReader
)

Parameters

reportDefinitionReader
The report definition (*.rdlx) file to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Class Methods

[image]
ActiveReports 13
PageReport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

For a list of all members of this type, see PageReport members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFromMaster | Overloaded. Creates blank report with all of the content placeholders from specified master report.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Initialize | Allows post-initialization of the PageReport instance.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Load | Overloaded. Loads the specified report definition file.
Public Method | Run | Runs the specified report definition file.
Public Method | Save | Overloaded. Saves the report definition to the specified file.
Public Method | ToRdlString | Returns the report definition language (RDL) as a System.String in the report definition.
Public Method | ToString | Returns a String containing the name of the Component, if any. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


CreateFromMaster Method

[image]
ActiveReports 13
CreateFromMaster Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : CreateFromMaster Method

Glossary Item Box

Creates blank report with all of the content placeholders from specified master report.

Overload List

Overload | Description
CreateFromMaster(Uri) | Creates blank report with all of the content placeholders from specified master report.
CreateFromMaster(String,ResourceLocator) | Creates blank report with all of the content placeholders from specified master report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


CreateFromMaster(Uri) Method

[image]
ActiveReports 13
CreateFromMaster(Uri) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > CreateFromMaster Method : CreateFromMaster(Uri) Method

masterUri
The Uri to the master report

Glossary Item Box

Creates blank report with all of the content placeholders from specified master report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateFromMaster( _
   ByVal masterUri As Uri _
) As PageReport
C#
public static PageReport CreateFromMaster(
   Uri masterUri
)

Parameters

masterUri
The Uri to the master report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


CreateFromMaster(String,ResourceLocator) Method

[image]
ActiveReports 13
CreateFromMaster(String,ResourceLocator) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > CreateFromMaster Method : CreateFromMaster(String,ResourceLocator) Method

masterName
The master report name.
resourceLocator
The resource locator.

Glossary Item Box

Creates blank report with all of the content placeholders from specified master report.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateFromMaster( _
   ByVal masterName As String, _
   ByVal resourceLocator As GrapeCity.ActiveReports.ResourceLocator _
) As PageReport
C#
public static PageReport CreateFromMaster(
   string masterName,
   GrapeCity.ActiveReports.ResourceLocator resourceLocator
)

Parameters

masterName
The master report name.
resourceLocator
The resource locator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Initialize Method

[image]
ActiveReports 13
Initialize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Initialize Method

Glossary Item Box

Allows post-initialization of the PageReport instance.

Syntax

Visual Basic (Declaration)
Public Sub Initialize()
C#
public void Initialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Load Method

[image]
ActiveReports 13
Load Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Load Method

Glossary Item Box

Loads the specified report definition file.

Overload List

Overload | Description
Load(FileInfo) | Loads the report definition file.
Load(TextReader) | Loads the report definition file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Load(FileInfo) Method

[image]
ActiveReports 13
Load(FileInfo) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Load Method : Load(FileInfo) Method

reportDefinitionFile
The report definition (*.rdlx) file to load.

Glossary Item Box

Loads the report definition file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal reportDefinitionFile As FileInfo _
)
C#
public void Load(
   FileInfo reportDefinitionFile
)

Parameters

reportDefinitionFile
The report definition (*.rdlx) file to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Load(TextReader) Method

[image]
ActiveReports 13
Load(TextReader) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Load Method : Load(TextReader) Method

reportDefinitionReader
The report definition (*.rdlx) file to load.

Glossary Item Box

Loads the report definition file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal reportDefinitionReader As TextReader _
)
C#
public void Load(
   TextReader reportDefinitionReader
)

Parameters

reportDefinitionReader
The report definition (*.rdlx) file to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Run Method

[image]
ActiveReports 13
Run Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Run Method

Glossary Item Box

Runs the specified report definition file.

Syntax

Visual Basic (Declaration)
Public Sub Run()
C#
public void Run()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Save Method

[image]
ActiveReports 13
Save Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Save Method

Glossary Item Box

Saves the report definition to the specified file.

Overload List

Overload | Description
Save(FileInfo) | Saves the report definition to the specified file.
Save(XmlWriter) | Saves the report definition to the XmlWriter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Save(FileInfo) Method

[image]
ActiveReports 13
Save(FileInfo) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Save Method : Save(FileInfo) Method

file

Glossary Item Box

Saves the report definition to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal file As FileInfo _
)
C#
public void Save(
   FileInfo file
)

Parameters

file

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


Save(XmlWriter) Method

[image]
ActiveReports 13
Save(XmlWriter) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Save Method : Save(XmlWriter) Method

xmlWriter

Glossary Item Box

Saves the report definition to the XmlWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal xmlWriter As XmlWriter _
)
C#
public void Save(
   XmlWriter xmlWriter
)

Parameters

xmlWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members
Overload List


ToRdlString Method

[image]
ActiveReports 13
ToRdlString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ToRdlString Method

Glossary Item Box

Returns the report definition language (RDL) as a System.String in the report definition.

Syntax

Visual Basic (Declaration)
Public Function ToRdlString() As String
C#
public string ToRdlString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


PageReport Class Properties

[image]
ActiveReports 13
PageReport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

For a list of all members of this type, see PageReport members.

Public Properties

 | Name | Description
Public Property | ConfigurationProvider | Gets or sets the IConfigurationProvider associated with this ReportDefinition.
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | Document | Gets the document.
Public Property | Report | Returns the current report definition object.
Public Property | ResourceLocator | Gets the object responsible for resolving report resources.
Public Property | Site | Gets or sets the ISite of the Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


ConfigurationProvider Property

[image]
ActiveReports 13
ConfigurationProvider Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ConfigurationProvider Property

Glossary Item Box

Gets or sets the IConfigurationProvider associated with this ReportDefinition.

Syntax

Visual Basic (Declaration)
Public Property ConfigurationProvider As IConfigurationProvider
C#
public IConfigurationProvider ConfigurationProvider {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Document Property

[image]
ActiveReports 13
Document Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Document Property

Glossary Item Box

Gets the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As PageDocument
C#
public PageDocument Document {get;}

Property Value

The document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Report Property

[image]
ActiveReports 13
Report Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Report Property

Glossary Item Box

Returns the current report definition object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As GrapeCity.ActiveReports.PageReportModel.Report
C#
public GrapeCity.ActiveReports.PageReportModel.Report Report {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


ResourceLocator Property

[image]
ActiveReports 13
ResourceLocator Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ResourceLocator Property

Glossary Item Box

Gets the object responsible for resolving report resources.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As GrapeCity.ActiveReports.ResourceLocator
C#
public GrapeCity.ActiveReports.ResourceLocator ResourceLocator {get; set;}

Example

VB.NET Copy Code
Private Sub ShowReport()
    Dim reportData As Stream = [GetType]().Assembly.GetManifestResourceStream("GrapeCity.ActiveReports.Samples.CustomResourceLocator.DemoReport.rdlx")
    reportData.Position = 0
    Dim reader As New StreamReader(reportData)
    Dim def As New PageReport(reader)
    def.ResourceLocator = New MyPicturesLocator()
    Dim runtime As New PageDocument(def)
    runtime.Parameters("PictureName").CurrentValue = listView.SelectedItems(0).Text
    runtime.Parameters("MimeType").CurrentValue = String.Format("image/{0}", listView.SelectedItems(0).Tag)
End Sub
C# Copy Code
private void ShowReport()
{
    Stream reportData = GetType().Assembly.GetManifestResourceStream(
            "GrapeCity.ActiveReports.Samples.CustomResourceLocator.DemoReport.rdlx");
    reportData.Position = 0;
    StreamReader reader = new StreamReader(reportData);
    PageReport def = new PageReport(reader);
    def.ResourceLocator = new MyPicturesLocator();
    PageDocument runtime = new PageDocument(def);
    runtime.Parameters["PictureName"].CurrentValue = listView.SelectedItems[0].Text;
    runtime.Parameters["MimeType"].CurrentValue = string.Format("image/{0}", listView.SelectedItems[0].Tag);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


PageSettings Class

[image]
ActiveReports 13
PageSettings Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

Specifies the page settings used to print the report document pages.

Object Model

PageSettings Class

Syntax

Visual Basic (Declaration)
Public Class PageSettings
C#
public class PageSettings

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Collate = GrapeCity.ActiveReports.PageSettings.PrinterCollate.Collate;
    this.PageSettings.DefaultPaperSize = true;
    this.PageSettings.DefaultPaperSource = true;
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Default;
    this.PageSettings.Gutter = 1.0f;
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.0f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
    this.PageSettings.MirrorMargins = false;
    this.PageSettings.Orientation = PageOrientation.Default;
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual;
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Collate = PageSettings.PrinterCollate.Collate
   Me.PageSettings.DefaultPaperSize = True
   Me.PageSettings.DefaultPaperSource = True
   Me.PageSettings.Duplex = Drawing.Printing.Duplex.Default
   Me.PageSettings.Gutter = 1.0F
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.0F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
   Me.PageSettings.MirrorMargins = False
   Me.PageSettings.Orientation = PageOrientation.Default
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Members
GrapeCity.ActiveReports Namespace


PageSettings Class Members

[image]
ActiveReports 13
PageSettings Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

The following tables list the members exposed by PageSettings.

Public Constructors

 | Name | Description
Public Constructor | PageSettings Constructor | Initializes a new instance of the PageSettings class.
Top

Public Properties

 | Name | Description
Public Property | Collate | Gets or sets a value indicating whether the report document is collated.
Public Property | DefaultPaperSize | Gets or sets a value that specifies whether the report document should print to the printer's default paper size.
Public Property | DefaultPaperSource | Gets or sets a value that specifies whether the report document should print to the printer's default paper source.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | Gutter | Gets or sets the amount of space between columns in inches.
Public Property | Margins | Gets or sets the default page margins of the report document.
Public Property | MirrorMargins | Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.
Public Property | Orientation | Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.
Public Property | PaperHeight | Gets or sets a value that specifies the height of a custom paper size.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | PaperSource | Gets or sets the paper source used to print the report document pages.
Public Property | PaperSourceName | Gets the name of the paper source.
Public Property | PaperWidth | Gets or sets a value that specifies the width, in inches, of a custom paper size.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases the PageSettings object from memory.
Top

Public Events

 | Name | Description
Public Event | Changed | Occurs when any of the PageSettings properties are changed.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


PageSettings Constructor

[image]
ActiveReports 13
PageSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PageSettings Constructor

Glossary Item Box

Initializes a new instance of the PageSettings class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Class Methods

[image]
ActiveReports 13
PageSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

For a list of all members of this type, see PageSettings members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases the PageSettings object from memory.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Dispose() Method

Glossary Item Box

Releases the PageSettings object from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Class Properties

[image]
ActiveReports 13
PageSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

For a list of all members of this type, see PageSettings members.

Public Properties

 | Name | Description
Public Property | Collate | Gets or sets a value indicating whether the report document is collated.
Public Property | DefaultPaperSize | Gets or sets a value that specifies whether the report document should print to the printer's default paper size.
Public Property | DefaultPaperSource | Gets or sets a value that specifies whether the report document should print to the printer's default paper source.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | Gutter | Gets or sets the amount of space between columns in inches.
Public Property | Margins | Gets or sets the default page margins of the report document.
Public Property | MirrorMargins | Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.
Public Property | Orientation | Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.
Public Property | PaperHeight | Gets or sets a value that specifies the height of a custom paper size.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | PaperSource | Gets or sets the paper source used to print the report document pages.
Public Property | PaperSourceName | Gets the name of the paper source.
Public Property | PaperWidth | Gets or sets a value that specifies the width, in inches, of a custom paper size.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Collate Property

[image]
ActiveReports 13
Collate Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Collate Property

Glossary Item Box

Gets or sets a value indicating whether the report document is collated.

Syntax

Visual Basic (Declaration)
Public Property Collate As PageSettings.PrinterCollate
C#
public PageSettings.PrinterCollate Collate {get; set;}

Property Value

A PrinterCollate enumeration value. Default is PrinterCollate.Default.

Remarks

Collating is performed only when the number of copies is greater than 1.

Setting the property to PrinterCollate.Collate will print a complete copy of the document before the first page of the next copy is printed. PrinterCollate.DontCollate will print each page by the number of copies specified before printing the next page. PrinterCollate.Default will use the printer's collate setting.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Collate = GrapeCity.ActiveReports.PageSettings.PrinterCollate.Collate;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Collate = PageSettings.PrinterCollate.Collate
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


DefaultPaperSize Property

[image]
ActiveReports 13
DefaultPaperSize Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : DefaultPaperSize Property

Glossary Item Box

Gets or sets a value that specifies whether the report document should print to the printer's default paper size.

Syntax

Visual Basic (Declaration)
Public Property DefaultPaperSize As Boolean
C#
public bool DefaultPaperSize {get; set;}

Property Value

Boolean. True if the document should use the printer's default paper size; otherwise, False. The default value is False.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.DefaultPaperSize = true;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.DefaultPaperSize = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property


DefaultPaperSource Property

[image]
ActiveReports 13
DefaultPaperSource Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : DefaultPaperSource Property

Glossary Item Box

Gets or sets a value that specifies whether the report document should print to the printer's default paper source.

Syntax

Visual Basic (Declaration)
Public Property DefaultPaperSource As Boolean
C#
public bool DefaultPaperSource {get; set;}

Property Value

Boolean. True if the document should use the printer's default paper source; otherwise, False. The default value is False.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.DefaultPaperSource = true;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.DefaultPaperSource = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperSource Property


Duplex Property

[image]
ActiveReports 13
Duplex Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Duplex Property

Glossary Item Box

Gets or sets the report document setting for double-sided printing.

Syntax

Visual Basic (Declaration)
Public Property Duplex As Duplex
C#
public Duplex Duplex {get; set;}

Property Value

A System.Drawing.Duplex enumeration value. The default value is determined by the value of System.Drawing.Printing.Duplex.Default.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Default;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Duplex = Drawing.Printing.Duplex.Default
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


Gutter Property

[image]
ActiveReports 13
Gutter Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Gutter Property

Glossary Item Box

Gets or sets the amount of space between columns in inches.

Syntax

Visual Basic (Declaration)
Public Property Gutter As Single
C#
public float Gutter {get; set;}

Property Value

A float or Single value in inches used to determine the gutter width.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Gutter = 1.0f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Gutter = 1.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


Margins Property

[image]
ActiveReports 13
Margins Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Margins Property

Glossary Item Box

Gets or sets the default page margins of the report document.

Syntax

Visual Basic (Declaration)
Public Property Margins As Margins
C#
public Margins Margins {get; set;}

Property Value

A Margins object that specifies the top, bottom, left and right margin settings in inches.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.0f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.0F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
Margins Class


MirrorMargins Property

[image]
ActiveReports 13
MirrorMargins Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : MirrorMargins Property

Glossary Item Box

Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.

Syntax

Visual Basic (Declaration)
Public Property MirrorMargins As Boolean
C#
public bool MirrorMargins {get; set;}

Property Value

Boolean. True if margins should be mirrored; otherwise, False. The default value is False.

Remarks

Use this property when printing in duplex and the left and right margins are not equal. This would alternate the margins between odd and even pages.

Example

Visual Basic Copy Code
Private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Vertical;
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.5f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
    this.PageSettings.MirrorMargins = True;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Duplex = System.Drawing.Printing.Duplex.Vertical
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.5F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
   Me.PageSettings.MirrorMargins = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


Orientation Property

[image]
ActiveReports 13
Orientation Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Orientation Property

Glossary Item Box

Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
C#
public PageOrientation Orientation {get; set;}

Property Value

A GrapeCity.ActiveReports.Document.Section.PageOrientation enumeration value that specifies the orientation of the document pages.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Orientation = PageOrientation.Default;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Orientation = PageOrientation.Default
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PageOrientation Enumeration


PaperHeight Property

[image]
ActiveReports 13
PaperHeight Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperHeight Property

Glossary Item Box

Gets or sets a value that specifies the height of a custom paper size.

Syntax

Visual Basic (Declaration)
Public Property PaperHeight As Single
C#
public float PaperHeight {get; set;}

Property Value

A float value that specifies the custom paper height in inches.

Remarks

Set the PaperKind property to PaperKind.Custom to use this property. Custom paper sizes must be supported by the printer for this property to work.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperWidth Property


PaperKind Property

[image]
ActiveReports 13
PaperKind Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperKind Property

Glossary Item Box

Gets or sets the kind of paper to be used to print the report.

Syntax

Visual Basic (Declaration)
Public Property PaperKind As PaperKind
C#
public PaperKind PaperKind {get; set;}

Property Value

A System.Drawing.Printing.PaperKind enumeration value that determines the paper size to use.

Remarks

To use custom paper sizes, you must set the PaperKind property to Custom and the PaperName property to a unique string.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperName = "My Paper";
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperName = "My Paper"
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PaperName Property

[image]
ActiveReports 13
PaperName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperName Property

Glossary Item Box

Gets or sets the name of the type of paper.

Syntax

Visual Basic (Declaration)
Public Property PaperName As String
C#
public string PaperName {get; set;}

Property Value

String. The name of the type of custom paper.

Remarks

You can set the paper name only if the PaperKind property is set to Custom. To use custom paper sizes, you must set the PaperKind property to Custom and set the PaperName property to a unique string.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperHeight = 3;
    this.PageSettings.PaperName = "Logo Labels";
    this.PageSettings.PaperWidth = 5;

}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.PageSettings.PaperKind = Printing.PaperKind.Custom
    Me.PageSettings.PaperHeight = 3
    Me.PageSettings.PaperName = "Logo Labels"
    Me.PageSettings.PaperWidth = 5
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property


PaperSource Property

[image]
ActiveReports 13
PaperSource Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperSource Property

Glossary Item Box

Gets or sets the paper source used to print the report document pages.

Syntax

Visual Basic (Declaration)
Public Property PaperSource As PaperSourceKind
C#
public PaperSourceKind PaperSource {get; set;}

Property Value

A System.Drawing.Printing.PaperSourceKind enumeration value that specifies the paper source.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


PaperSourceName Property

[image]
ActiveReports 13
PaperSourceName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperSourceName Property

Glossary Item Box

Gets the name of the paper source.

Syntax

Visual Basic (Declaration)
Public Property PaperSourceName As String
C#
public string PaperSourceName {get; set;}

Property Value

String. The name of the paper source.

Remarks

Call this property when the paper source needs to be displayed. The name of the paper source is generated based upon the PaperKind property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperSource Property


PaperWidth Property

[image]
ActiveReports 13
PaperWidth Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperWidth Property

Glossary Item Box

Gets or sets a value that specifies the width, in inches, of a custom paper size.

Syntax

Visual Basic (Declaration)
Public Property PaperWidth As Single
C#
public float PaperWidth {get; set;}

Property Value

A float value that specifies the custom paper width in inches.

Remarks

Set the PaperKind property to PaperKind.Custom to use this property. Custom paper sizes must be supported by the printer for this property to work.

Example

C# Copy Code
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperWidth = 8.5f;
}
Visual Basic Copy Code
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperWidth = 8.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperHeight Property


PageSettings Class Events

[image]
ActiveReports 13
PageSettings Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

Glossary Item Box

For a list of all members of this type, see PageSettings members.

Public Events

 | Name | Description
Public Event | Changed | Occurs when any of the PageSettings properties are changed.
Top

See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Changed Event

[image]
ActiveReports 13
Changed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Changed Event

Glossary Item Box

Occurs when any of the PageSettings properties are changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


ReportDataException Class

[image]
ActiveReports 13
ReportDataException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

Glossary Item Box

This exception is thrown when an error occurs while connecting to the report's data source.

Object Model

ReportDataException Class

Syntax

Visual Basic (Declaration)
Public Class ReportDataException
   Inherits ReportException
C#
public class ReportDataException : ReportException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportDataException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Members
GrapeCity.ActiveReports Namespace


ReportDataException Class Members

[image]
ActiveReports 13
ReportDataException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

Glossary Item Box

The following tables list the members exposed by ReportDataException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportDataException Class
GrapeCity.ActiveReports Namespace


ReportException Class

[image]
ActiveReports 13
ReportException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

Glossary Item Box

This exception or one of its descendent classes is thrown when an error occurs while running the report.

Object Model

ReportException Class

Syntax

Visual Basic (Declaration)
Public Class ReportException
   Inherits System.ApplicationException
C#
public class ReportException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportDataException
GrapeCity.ActiveReports.ReportScriptException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Members
GrapeCity.ActiveReports Namespace


ReportException Class Members

[image]
ActiveReports 13
ReportException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

Glossary Item Box

The following tables list the members exposed by ReportException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing.
Public Property | ErrorData | Error data, depends on error code.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


ReportException Class Properties

[image]
ActiveReports 13
ReportException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

Glossary Item Box

For a list of all members of this type, see ReportException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing.
Public Property | ErrorData | Error data, depends on error code.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


ErrorCode Property

[image]
ActiveReports 13
ErrorCode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ErrorCode Property

Glossary Item Box

Error code for future detail processing.

Syntax

Visual Basic (Declaration)
Public Property ErrorCode As ReportProcessingError
C#
public ReportProcessingError ErrorCode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


ErrorData Property

[image]
ActiveReports 13
ErrorData Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ErrorData Property

Glossary Item Box

Error data, depends on error code.

Syntax

Visual Basic (Declaration)
Public Property ErrorData As String()
C#
public string[] ErrorData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


ReportScriptException Class

[image]
ActiveReports 13
ReportScriptException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

Glossary Item Box

The ReportScriptException is thrown when an error occurs in the report scripting code or any of the report's calculated DataField expressions.

Object Model

ReportScriptException Class

Syntax

Visual Basic (Declaration)
Public Class ReportScriptException
   Inherits ReportException
C#
public class ReportScriptException : ReportException

Remarks

You should catch this exception and inspect the InnerException property to diagnose the location and type of the error that caused the exception.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportScriptException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Members
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports~GrapeCity.ActiveReports.ActiveReport~Script


ReportScriptException Class Members

[image]
ActiveReports 13
ReportScriptException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

Glossary Item Box

The following tables list the members exposed by ReportScriptException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportScriptException Class
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports~GrapeCity.ActiveReports.ActiveReport~Script


SectionCollection Class

[image]
ActiveReports 13
SectionCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

Represents a collection of all sections (Section objects) in the report layout.

Object Model

SectionCollection Class

Syntax

Visual Basic (Declaration)
Public Class SectionCollection
   Inherits System.Collections.CollectionBase
C#
public class SectionCollection : System.Collections.CollectionBase

Remarks

The collection provides access to the removal or addition of sections, as well as access to the individual sections within the report. You can use the collection to create dynamic reports at run time.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Members
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


SectionCollection Class Members

[image]
ActiveReports 13
SectionCollection Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

The following tables list the members exposed by SectionCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the SectionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the SectionCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to a Section in the SectionCollection using its index or unique name.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified SectionType to the SectionCollection.
Public Method | Clear | Remove all sections from the collection.
Public Method | Contains | Determines whether the specified section object exists in the collection.
Public Method | CopyTo | Copies the Sections collection from the specified report to a Sections collection at the specified index.
Public Method | Dispose | Releases the section collection from memory.
Public Method | IndexOf | Determines the specific index of the specified section in the collection.
Public Method | Insert | Overloaded. Inserts a section into the collection at the specified index.
Public Method | InsertGroupHF | Overloaded. Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Public Method | InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Public Method | InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.
Public Method | Remove | Overloaded. Removes the specified Section from the SectionCollection if it exists.
Public Method | RemoveAt | Inherited from System.Collections.CollectionBase. (Inherited from System.Collections.CollectionBase)
Top

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the SectionCollection have changed.
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


SectionCollection Class Methods

[image]
ActiveReports 13
SectionCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

For a list of all members of this type, see SectionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified SectionType to the SectionCollection.
Public Method | Clear | Remove all sections from the collection.
Public Method | Contains | Determines whether the specified section object exists in the collection.
Public Method | CopyTo | Copies the Sections collection from the specified report to a Sections collection at the specified index.
Public Method | Dispose | Releases the section collection from memory.
Public Method | IndexOf | Determines the specific index of the specified section in the collection.
Public Method | Insert | Overloaded. Inserts a section into the collection at the specified index.
Public Method | InsertGroupHF | Overloaded. Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Public Method | InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Public Method | InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.
Public Method | Remove | Overloaded. Removes the specified Section from the SectionCollection if it exists.
Public Method | RemoveAt | Inherited from System.Collections.CollectionBase. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Add Method

[image]
ActiveReports 13
Add Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Add Method

Glossary Item Box

Adds the specified SectionType to the SectionCollection.

Overload List

Overload | Description
Add(SectionType,String) | Adds the specified SectionType to the SectionCollection.
Add(Section) | Adds the specified section to the SectionCollection.

Remarks

When modifying the layout of a report, the Insert methods are easier to use for header/footer section pairs.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.arv.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail1")
    rpt.Sections.InsertPageHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
GrapeCity.ActiveReports.Extensibility~GrapeCity.ActiveReports.Extensibility.Layout.ILayoutSection~SectionType


Add(SectionType,String) Method

[image]
ActiveReports 13
Add(SectionType,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Add Method : Add(SectionType,String) Method

type
SectionType of the new section.
name
Name of the new section, must be unique within the report.

Glossary Item Box

Adds the specified SectionType to the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal type As SectionType, _
   ByVal name As String _
) As Section
C#
public Section Add(
   SectionType type,
   string name
)

Parameters

type
SectionType of the new section.
name
Name of the new section, must be unique within the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Add(Section) Method

[image]
ActiveReports 13
Add(Section) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Add Method : Add(Section) Method

section

Specifies the Section object to be added in the collection.

Glossary Item Box

Adds the specified section to the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal section As Section _
) As Integer
C#
public int Add(
   Section section
)

Parameters

section

Specifies the Section object to be added in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Clear Method

Glossary Item Box

Remove all sections from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Contains Method

section

Specifies the Section object to be searched for in the collection.

Glossary Item Box

Determines whether the specified section object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal section As Section _
) As Boolean
C#
public bool Contains(
   Section section
)

Parameters

section

Specifies the Section object to be searched for in the collection.

Return Value

Boolean. Returns True if the section exists in the collection; otherwise, False.

Example

C# Copy Code
private void rpt_ReportEnd(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show(this.Sections.Contains(this.Sections["detail"]).ToString());
}
Visual Basic Copy Code
Private Sub rpt_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    MsgBox(Me.Sections.Contains(Me.Sections("Detail1")).ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : CopyTo Method

sections
The array containing the copied Sections.
index

The insertion index in the collection.

Glossary Item Box

Copies the Sections collection from the specified report to a Sections collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal sections() As Section, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Section[] sections,
   int index
)

Parameters

sections
The array containing the copied Sections.
index

The insertion index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Dispose Method

Glossary Item Box

Releases the section collection from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


IndexOf(Section) Method

[image]
ActiveReports 13
IndexOf(Section) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : IndexOf(Section) Method

section

Specifies the Section object.

Glossary Item Box

Determines the specific index of the specified section in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal section As Section _
) As Integer
C#
public int IndexOf(
   Section section
)

Parameters

section

Specifies the Section object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Insert Method

Glossary Item Box

Inserts a section into the collection at the specified index.

Overload List

Overload | Description
Insert(Int32,Section) | Inserts a section at the specified index in the collection.
Insert(Int32,SectionType,String) | Creates a new Section of the specified type and name and inserts it into the SectionCollection at the specified index.

Example

C# Copy Code
GrapeCity.ActiveReports.ActiveReport rpt = New GrapeCity.ActiveReports.ActiveReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"Detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections.Insert(0,GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader,"rh");
    rpt.Sections.Insert(4,GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter,"rf");
    rpt.Sections[0].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections[1].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[3].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[4].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Run();
    this.arv.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.ActiveReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail")
    rpt.Sections.InsertPageHF()
    rpt.Sections.Insert(0, GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader, "rh")
    rpt.Sections.Insert(4, GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter, "rf")
    rpt.Sections(0).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections(1).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(2).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(3).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(4).BackColor = System.Drawing.Color.PowderBlue
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Insert(Int32,Section) Method

[image]
ActiveReports 13
Insert(Int32,Section) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Insert Method : Insert(Int32,Section) Method

index
The zero-based index where the specified section should be inserted.
section
The Section to be inserted.

Glossary Item Box

Inserts a section at the specified index in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Insert( _
   ByVal index As Integer, _
   ByVal section As Section _
)
C#
public void Insert(
   int index,
   Section section
)

Parameters

index
The zero-based index where the specified section should be inserted.
section
The Section to be inserted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Insert(Int32,SectionType,String) Method

[image]
ActiveReports 13
Insert(Int32,SectionType,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Insert Method : Insert(Int32,SectionType,String) Method

index
The zero-based index where the new section should be inserted.
type
SectionType of the section to insert.
name
Unique name of the new section.

Glossary Item Box

Creates a new Section of the specified type and name and inserts it into the SectionCollection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal index As Integer, _
   ByVal type As SectionType, _
   ByVal name As String _
) As Section
C#
public Section Insert(
   int index,
   SectionType type,
   string name
)

Parameters

index
The zero-based index where the new section should be inserted.
type
SectionType of the section to insert.
name
Unique name of the new section.

Return Value

A section that was created and added into the collection.

Remarks

Report, Page and Group sections must be added in a header/footer pair. The InsertReportHF, InsertPageHF and InsertGroupHF ensure proper pairing of the header/footer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List
InsertReportHF Method
InsertPageHF Method
InsertGroupHF Method


InsertGroupHF Method

[image]
ActiveReports 13
InsertGroupHF Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertGroupHF Method

Glossary Item Box

Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number. Inserts a group header and a matching group footer into the SectionCollection.

Overload List

Overload | Description
InsertGroupHF() | Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
InsertGroupHF(String,String) | Inserts a group header and a matching group footer into the SectionCollection with the names, specified in the corresponding grHeaderName and grFooterName parameters.

Remarks

The new sections are added at the inner level of the groups, immediately before and after the Detail section in the report layout.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"Detail");
    rpt.Sections.InsertGroupHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.Viewer.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail")
    rpt.Sections.InsertGroupHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
GroupHeader Class
GroupFooter Class
Section Class


InsertGroupHF() Method

[image]
ActiveReports 13
InsertGroupHF() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > InsertGroupHF Method : InsertGroupHF() Method

Glossary Item Box

Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertGroupHF()
C#
public void InsertGroupHF()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


InsertGroupHF(String,String) Method

[image]
ActiveReports 13
InsertGroupHF(String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > InsertGroupHF Method : InsertGroupHF(String,String) Method

grHeaderName
Specifies the name of the Group Header section.
grFooterName
Specifies the name of the Page Footer section.

Glossary Item Box

Inserts a group header and a matching group footer into the SectionCollection with the names, specified in the corresponding grHeaderName and grFooterName parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertGroupHF( _
   ByVal grHeaderName As String, _
   ByVal grFooterName As String _
)
C#
public void InsertGroupHF(
   string grHeaderName,
   string grFooterName
)

Parameters

grHeaderName
Specifies the name of the Group Header section.
grFooterName
Specifies the name of the Page Footer section.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


InsertPageHF() Method

[image]
ActiveReports 13
InsertPageHF() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertPageHF() Method

Glossary Item Box

Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.

Syntax

Visual Basic (Declaration)
Public Sub InsertPageHF()
C#
public void InsertPageHF()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


InsertReportHF() Method

[image]
ActiveReports 13
InsertReportHF() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertReportHF() Method

Glossary Item Box

Inserts a report header and a matching report footer into the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Sub InsertReportHF()
C#
public void InsertReportHF()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Remove Method

Glossary Item Box

Removes the specified Section from the SectionCollection if it exists.

Overload List

Overload | Description
Remove(Section) | Removes the specified Section from the SectionCollection if it exists.
Remove(Int32) | Removes the Section at the specified index from the SectionCollection.

Remarks

You should always remove the matching header/footer section when removing either a header or a footer section. The Detail section cannot be removed from the collection.

Removing a section from the collection adjusts the index of the remaining sections.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections.Insert(0,GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader,"rh");
    rpt.Sections.Insert(4,GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter,"rf");
    rpt.Sections[0].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections[1].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[3].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[4].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections.Remove(0);
    rpt.Sections.Remove(3);
    rpt.Run();
    this.arv.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail1")
    rpt.Sections.InsertPageHF()
    rpt.Sections.Insert(0, GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader, "rh")
    rpt.Sections.Insert(4, GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter, "rf")
    rpt.Sections(0).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections(1).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(2).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(3).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(4).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections.Remove(0)
    rpt.Sections.Remove(3)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Remove(Section) Method

[image]
ActiveReports 13
Remove(Section) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Remove Method : Remove(Section) Method

section
Section to be removed from the collection.

Glossary Item Box

Removes the specified Section from the SectionCollection if it exists.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal section As Section _
)
C#
public void Remove(
   Section section
)

Parameters

section
Section to be removed from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Remove(Int32) Method

[image]
ActiveReports 13
Remove(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Remove Method : Remove(Int32) Method

index
Index of the Section to be removed.

Glossary Item Box

Removes the Section at the specified index from the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal index As Integer _
)
C#
public void Remove(
   int index
)

Parameters

index
Index of the Section to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


SectionCollection Class Properties

[image]
ActiveReports 13
SectionCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

For a list of all members of this type, see SectionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the SectionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the SectionCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to a Section in the SectionCollection using its index or unique name.
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Item Property

Glossary Item Box

Returns a reference to a Section in the SectionCollection using its index or unique name.

Overload List

Overload | Description
Item(Int32) | Gets the Section object at the specified indexed location in the SectionCollection.
Item(String) | Gets the Section object with the specified name in the SectionCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Item(Int32) Property

[image]
ActiveReports 13
Item(Int32) Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Item Property : Item(Int32) Property

index
Index of the section to be returned.

Glossary Item Box

Gets the Section object at the specified indexed location in the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Section
C#
public Section Item(
   int index
) {get;}

Parameters

index
Index of the section to be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 13
Item(String) Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Item Property : Item(String) Property

name
Unique name of the Section to be returned.

Glossary Item Box

Gets the Section object with the specified name in the SectionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Section
C#
public Section Item(
   string name
) {get;}

Parameters

name
Unique name of the Section to be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


SectionCollection Class Events

[image]
ActiveReports 13
SectionCollection Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

Glossary Item Box

For a list of all members of this type, see SectionCollection members.

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the SectionCollection have changed.
Top

See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Changed Event

[image]
ActiveReports 13
Changed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Changed Event

Glossary Item Box

Occurs when the members of the SectionCollection have changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


SectionReport Class

[image]
ActiveReports 13
SectionReport Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

The SectionReport class is the base class for all section reports. It is used to execute and render the report.

Object Model

SectionReport Class

Syntax

Visual Basic (Declaration)
Public Class SectionReport
   Inherits System.MarshalByRefObject
C#
public class SectionReport : System.MarshalByRefObject

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.SectionReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Members
GrapeCity.ActiveReports Namespace


SectionReport Class Members

[image]
ActiveReports 13
SectionReport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

The following tables list the members exposed by SectionReport.

Public Constructors

 | Name | Description
Public Constructor | SectionReport Constructor | Initializes a new instance of the SectionReport class.
Top

Public Properties

 | Name | Description
Public Property | CalculatedFields | Gets a FieldCollection object containing all of the calculated fields in the report.
Public Property | Culture | Provides information on a specific culture, including its names and the writing system.
Public Property | CurrentPage | Returns the current page instance.
Public Property | DataMember | Gets or sets the specified list in an DataSource to which the report will bind.
Public Property | DataSource | Gets or sets the data source from which the report will retrieve data.
Public Property | Document | Gets a reference to the report output Document object.
Public Property | EnableScriptDebugging | Allows to catch script exceptions in the debugger. The default value is False.
Public Property | ExpressionErrorMessage | Stops the reporting engine from throwing exceptions and instead displays the provided string.
Public Property | Fields | Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.
Public Property | IsDirty | Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.
Public Property | LayoutAction | Sets or returns a custom action following the rendering of the current record.
Public Property | MaxPages | Sets or returns the maximum number of pages that the report will create.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageNumber | Returns the number of the current page being processed when a report is running.
Public Property | PageSettings | Returns a reference to the current report's page settings.
Public Property | Parameters | Returns a reference to the data source query parameters collection.
Public Property | ParentReport | Gets a reference to the parent report.
Public Property | PrintWidth | Sets or returns the report's printable width in inches.
Public Property | ResourceLocator | Gets the object responsible for resolving report resources.
Public Property | Script | Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.
Public Property | ScriptLanguage | Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.
Public Property | Sections | Returns a reference to the report's sections collection.
Public Property | ShowParameterUI | Sets or returns whether or not the query parameters dialog box will appear when the report is run.
Public Property | State | Returns the current state of the report.
Public Property | StyleSheet | Returns a collection of formatting styles used to format controls in the report.
Public Property | UserData | Sets or returns a user-defined value.
Public Property | Version | Returns the product's version number.
Public Property | Watermark | Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.
Public Property | WatermarkAlignment | Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.
Public Property | WatermarkPrintOnPages | Sets or returns a value indicating the specific pages to which the watermark should be added.
Public Property | WatermarkSizeMode | Sets or returns how the watermark will be sized when the image is rendered on the page.
Top

Public Methods

 | Name | Description
Public Method | AddCode | Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.
Public Method | AddControlLicense | Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.
Public Method | AddNamedItem | Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.
Public Method | AddScriptReference | Adds a reference to the specified assembly to be loaded into the scripting run-time context.
Public Method | Cancel | Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.
static (Shared in Visual Basic) | CmToInch | Converts value from centimeters to inches.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | InchToCm | Converts value from inches to centimeters.
Public Method | LoadLayout | Overloaded. Retrieves a report XML layout (RPX) from a file, stream or resource.
Public Method | LoadStyles | Overloaded. Loads an external stylesheet to use with the report.
Public Method | ResetScripts | Clears the script of any items added using the AddNamedItem method or code added using the AddCode method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.
Public Method | ResetWatermark | Resets the watermark to its default value.
Public Method | Restart | Resets the report data source and clears the pages collection.
Public Method | Run | Overloaded. Starts the report processing.
Public Method | SaveLayout | Overloaded. Saves a report's XML layout to a stream or file.
Public Method | SaveStyles | Overloaded. Saves a reports styles to an external stylesheet.
Public Method | Stop | Stops processing the report.
Top

Public Events

 | Name | Description
Public Event | DataInitialize | Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.
Public Event | DataSourceChanged | Raised when the properties of the report's data source are modified.
Public Event | FetchData | Raised every time a new record is processed.
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | NoData | Raised if the report's data source does not return any records and there is no data to be processed.
Public Event | PageEnd | Raised after the report finishes rendering each page.
Public Event | PageStart | Raised before the report renders any output to a new page.
Public Event | ParameterUIClosed | Raised after the user closes the query parameters dialog.
Public Event | PrintAborted | Raised when the user cancels a print job.
Public Event | PrintProgress | Raised for each page while printing the report document.
Public Event | ReportEnd | Raised after the report finishes processing all pages.
Public Event | ReportStart | Raised before a report starts processing.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


SectionReport Constructor

[image]
ActiveReports 13
SectionReport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SectionReport Constructor

Glossary Item Box

Initializes a new instance of the SectionReport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SectionReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


SectionReport Class Methods

[image]
ActiveReports 13
SectionReport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

For a list of all members of this type, see SectionReport members.

Public Methods

 | Name | Description
Public Method | AddCode | Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.
Public Method | AddControlLicense | Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.
Public Method | AddNamedItem | Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.
Public Method | AddScriptReference | Adds a reference to the specified assembly to be loaded into the scripting run-time context.
Public Method | Cancel | Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.
static (Shared in Visual Basic) | CmToInch | Converts value from centimeters to inches.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | InchToCm | Converts value from inches to centimeters.
Public Method | LoadLayout | Overloaded. Retrieves a report XML layout (RPX) from a file, stream or resource.
Public Method | LoadStyles | Overloaded. Loads an external stylesheet to use with the report.
Public Method | ResetScripts | Clears the script of any items added using the AddNamedItem method or code added using the AddCode method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.
Public Method | ResetWatermark | Resets the watermark to its default value.
Public Method | Restart | Resets the report data source and clears the pages collection.
Public Method | Run | Overloaded. Starts the report processing.
Public Method | SaveLayout | Overloaded. Saves a report's XML layout to a stream or file.
Public Method | SaveStyles | Overloaded. Saves a reports styles to an external stylesheet.
Public Method | Stop | Stops processing the report.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


AddCode Method

[image]
ActiveReports 13
AddCode Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddCode Method

script
Script code written in the specified report scripting language.

Glossary Item Box

Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.

Syntax

Visual Basic (Declaration)
Public Sub AddCode( _
   ByVal script As String _
)
C#
public void AddCode(
   string script
)

Parameters

script
Script code written in the specified report scripting language.

Remarks

This method is typically used when executing stand-alone reports that are not compiled into the application. Injected code allows the report to access features such as custom calculation functions and data access modules in the calling application.

Example

C# Copy Code
public string addThisCode()
{
    string sCode = "public string ShowACMessage()\"{return \"my Added Code\";}";
    return sCode;
}

private void rptAddCode_ReportStart(object sender, System.EventArgs eArgs)
{
    this.AddCode(addThisCode());
}
Visual Basic Copy Code
Public Function addThisCode() As String
    Dim sCode As String = "public string ShowACMessage()""{return ""my Added Code"";}"
    Return sCode
End Function

Private Sub rptAddCode_ReportStart(sender As Object, eArgs As System.EventArgs)
    Me.AddCode(addThisCode())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddNamedItem Method


AddControlLicense Method

[image]
ActiveReports 13
AddControlLicense Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddControlLicense Method

className
Licensed control's class name.
license
String containing the licensed control's license.

Glossary Item Box

Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.

Syntax

Visual Basic (Declaration)
Public Sub AddControlLicense( _
   ByVal className As String, _
   ByVal license As String _
)
C#
public void AddControlLicense(
   string className,
   string license
)

Parameters

className
Licensed control's class name.
license
String containing the licensed control's license.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


AddNamedItem Method

[image]
ActiveReports 13
AddNamedItem Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddNamedItem Method

objectName
The name of the new object.
objectReference
The value of the new object.

Glossary Item Box

Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.

Syntax

Visual Basic (Declaration)
Public Sub AddNamedItem( _
   ByVal objectName As String, _
   ByVal objectReference As Object _
)
C#
public void AddNamedItem(
   string objectName,
   object objectReference
)

Parameters

objectName
The name of the new object.
objectReference
The value of the new object.

Remarks

This method allows you to add objects such as data layer or business objects from the calling application into the report scripting context. For example, you might have an Order class that contains a method for computing sales tax. When you print the order you can pass an Order class instance to the report to allow you to call that method from the report script.

This method is typically used when running reports in stand-alone mode and not compiled into the application.

Example

C# Copy Code
//Add this code to the Class File
public class clsMyItem
{
      public clsMyItem()
      {
      }
      public string getMyItem()
      {
            return "Hello";
      }
}

//Add this code to the report
private void rptAddNamedItem_ReportStart(object sender, System.EventArgs eArgs)
{
      this.AddNamedItem("myItem", new clsMyItem());
}
Visual Basic Copy Code
'Add this code to the Class File
Public Class clsMyItem
      Public Function getMyItem() As String
            getMyItem = "Hello"
      End Function
End Class

'Add this code to the report
Private Sub rptAddNamedItem_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
      Me.AddNamedItem("myItem", New clsMyItem())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddCode Method


AddScriptReference Method

[image]
ActiveReports 13
AddScriptReference Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddScriptReference Method

scriptRef
Name of the assembly to be added to the scripting run-time context.

Glossary Item Box

Adds a reference to the specified assembly to be loaded into the scripting run-time context.

Syntax

Visual Basic (Declaration)
Public Sub AddScriptReference( _
   ByVal scriptRef As String _
)
C#
public void AddScriptReference(
   string scriptRef
)

Parameters

scriptRef
Name of the assembly to be added to the scripting run-time context.

Remarks

ActiveReports loads assemblies that are referenced in the application. You can use this method to add additional assemblies to be used in scripting that are not part of the application running the report.

Example

C# Copy Code
private void runReport()
{
      SectionReport1 rpt = new SectionReport1();
      rpt.AddScriptReference("System.Data");
      rpt.Run();
      this.viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub runReport()
      Dim rpt As New SectionReport1()
      rpt.AddScriptReference("System.Data")
      rpt.Run()
      Me.viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddNamedItem Method
AddCode Method


Cancel Method

[image]
ActiveReports 13
Cancel Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Cancel Method

Glossary Item Box

Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.

Syntax

Visual Basic (Declaration)
Public Sub Cancel()
C#
public void Cancel()

Remarks

You can call this method based on a user's request or in a report event such as ReportStart to prevent printing a blank report if their data source did not return any records.

Example

C# Copy Code
private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    if (this.DataSource==null)
    {
        this.Cancel();
    }
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    If Me.DataSource Is Nothing Then
        Me.Cancel()
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Stop Method


CmToInch Method

[image]
ActiveReports 13
CmToInch Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CmToInch Method

value
The measurement in centimeters to be converted to inches.

Glossary Item Box

Converts value from centimeters to inches.

Syntax

Visual Basic (Declaration)
Public Shared Function CmToInch( _
   ByVal value As Single _
) As Single
C#
public static float CmToInch(
   float value
)

Parameters

value
The measurement in centimeters to be converted to inches.

Return Value

Single value representing the specified centimeters value in inches.

Remarks

ActiveReports uses inches for all coordinate and dimension properties. This method helps convert centimeter values to inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Left = SectionReport1.CmToInch(2);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Left = SectionReport1.CmToInch(2)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
InchToCm Method


InchToCm Method

[image]
ActiveReports 13
InchToCm Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : InchToCm Method

value
Inches value to be converted to centimeters .

Glossary Item Box

Converts value from inches to centimeters.

Syntax

Visual Basic (Declaration)
Public Shared Function InchToCm( _
   ByVal value As Single _
) As Single
C#
public static float InchToCm(
   float value
)

Parameters

value
Inches value to be converted to centimeters .

Return Value

Single value representing the inches value in centimeters.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.Label1.Left = SectionReport1.InchToCm(2);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Left = SectionReport1.InchToCm(2)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
CmToInch Method


LoadLayout Method

[image]
ActiveReports 13
LoadLayout Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LoadLayout Method

Glossary Item Box

Retrieves a report XML layout (RPX) from a file, stream or resource.

Overload List

Overload | Description
LoadLayout(String) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Stream) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Stream,ArrayList) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Type,String) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(XmlReader) | Retrieves a report XML layout from an XmlReader and loads it into a report object.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport report = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader("\\report.rpx");
report.LoadLayout(xtr);
xtr.Close();

// reading from XML DOM (XmlNode)
using (System.Xml.XmlNodeReader reader = new System.Xml.XmlNodeReader(node))
{
    report.LoadLayout(reader);
}

// reading from stream
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(inputStream))
{
    report.LoadLayout(reader);
}

// reading from string
string layoutContent = "<ActiveReports>...  ...</ActiveReports>";
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(new System.IO.StringReader(layoutContent)))
{
    report.LoadLayout(reader);
}
Visual Basic Copy Code
Dim report As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("\report.rpx")
report.LoadLayout(xtr)
xtr.Close()

' reading from XML DOM (XmlNode)
Using reader As New System.Xml.XmlNodeReader(node)
    report.LoadLayout(reader)
End Using

' reading from stream
Using reader As New System.Xml.XmlTextReader(inputStream)
    report.LoadLayout(reader)
End Using

' reading from string
Dim layoutContent As String = "<ActiveReports>...  ...</ActiveReports>"
Using reader As New System.Xml.XmlTextReader(New System.IO.StringReader(layoutContent))
    report.LoadLayout(reader)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
SaveLayout Method

Concepts

Scripting


LoadLayout(String) Method

[image]
ActiveReports 13
LoadLayout(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(String) Method

fileName
Report layout (RPX) file name.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal fileName As String _
)
C#
public void LoadLayout(
   string fileName
)

Parameters

fileName
Report layout (RPX) file name.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Stream) Method

[image]
ActiveReports 13
LoadLayout(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Stream) Method

stream

A stream that contains a valid report XML layout.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal stream As Stream _
)
C#
public void LoadLayout(
   Stream stream
)

Parameters

stream

A stream that contains a valid report XML layout.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Stream,ArrayList) Method

[image]
ActiveReports 13
LoadLayout(Stream,ArrayList) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Stream,ArrayList) Method

stream

A stream that contains a valid report XML layout.

errors

An array containing any errors that occur during LoadLayout.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal stream As Stream, _
   ByRef errors As ArrayList _
)
C#
public void LoadLayout(
   Stream stream,
   out ArrayList errors
)

Parameters

stream

A stream that contains a valid report XML layout.

errors

An array containing any errors that occur during LoadLayout.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Type,String) Method

[image]
ActiveReports 13
LoadLayout(Type,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Type,String) Method

type
Type of stored resource.
resourceName
Name of the resource entry that contains the report XML layout.

Glossary Item Box

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal type As Type, _
   ByVal resourceName As String _
)
C#
public void LoadLayout(
   Type type,
   string resourceName
)

Parameters

type
Type of stored resource.
resourceName
Name of the resource entry that contains the report XML layout.

Remarks

Use LoadLayout(Stream) or LoadLayout(String) instead.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List

Concepts

Scripting


LoadLayout(XmlReader) Method

[image]
ActiveReports 13
LoadLayout(XmlReader) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(XmlReader) Method

reader
XmlReader object from which to retrieve the report's layout.

Glossary Item Box

Retrieves a report XML layout from an XmlReader and loads it into a report object.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal reader As XmlReader _
)
C#
public void LoadLayout(
   XmlReader reader
)

Parameters

reader
XmlReader object from which to retrieve the report's layout.

Remarks

This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.

Example

C# Copy Code
GrapeCity.ActiveReports.ActiveReport report = new GrapeCity.ActiveReports.ActiveReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader("\\report.rpx");
report.LoadLayout(xtr);
xtr.Close();

// reading from XML DOM (XmlNode)
using (System.Xml.XmlNodeReader reader = new System.Xml.XmlNodeReader(node))
{
   report.LoadLayout(reader);
}

// reading from stream
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(inputStream))
{
   report.LoadLayout(reader);
}

// reading from string
string layoutContent = "<ActiveReports>...  ...</ActiveReports>";
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(new System.IO.StringReader(layoutContent)))
{
   report.LoadLayout(reader);
}
Visual Basic Copy Code
Dim report As New GrapeCity.ActiveReports.ActiveReport()
Dim xtr As New System.Xml.XmlTextReader("\report.rpx")
report.LoadLayout(xtr)
xtr.Close()

' reading from XML DOM (XmlNode)
Using reader As New System.Xml.XmlNodeReader(node)
    report.LoadLayout(reader)
End Using

' reading from stream
Using reader As New System.Xml.XmlTextReader(inputStream)
    report.LoadLayout(reader)
End Using

' reading from string
Dim layoutContent As String = "<ActiveReports>... ...</ActiveReports>"
Using reader As New System.Xml.XmlTextReader(New System.IO.StringReader(layoutContent))
    report.LoadLayout(reader)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadStyles Method

[image]
ActiveReports 13
LoadStyles Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LoadStyles Method

Glossary Item Box

Loads an external stylesheet to use with the report.

Overload List

Overload | Description
LoadStyles(String) | Loads an external stylesheet to use with the report.
LoadStyles(Stream) | Loads an external stylesheet to use with the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members

How To

Use External Style Sheets


LoadStyles(String) Method

[image]
ActiveReports 13
LoadStyles(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadStyles Method : LoadStyles(String) Method

fileName
The name of the file that loads the style sheet.

Glossary Item Box

Loads an external stylesheet to use with the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadStyles( _
   ByVal fileName As String _
)
C#
public void LoadStyles(
   string fileName
)

Parameters

fileName
The name of the file that loads the style sheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadStyles(Stream) Method

[image]
ActiveReports 13
LoadStyles(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadStyles Method : LoadStyles(Stream) Method

inStream
The stream from which the external stylesheet is loaded.

Glossary Item Box

Loads an external stylesheet to use with the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadStyles( _
   ByVal inStream As Stream _
)
C#
public void LoadStyles(
   Stream inStream
)

Parameters

inStream
The stream from which the external stylesheet is loaded.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


ResetScripts Method

[image]
ActiveReports 13
ResetScripts Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResetScripts Method

Glossary Item Box

Clears the script of any items added using the AddNamedItem method or code added using the AddCode method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.

Syntax

Visual Basic (Declaration)
Public Sub ResetScripts()
C#
public void ResetScripts()

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.LoadLayout(Application.StartupPath + "\\rptAddNamedItem.rpx");
    clsAddNamedItem m = new clsAddNamedItem();
    rpt.AddNamedItem("x", m);
    rpt.Run();
    this.arv.Document=rpt.Document;
    rpt.ResetScripts();
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.LoadLayout(Application.StartupPath & "\rptAddNamedItem.rpx")
    Dim m As New clsAddNamedItem
    rpt.AddNamedItem("x", m)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    rpt.ResetScripts()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
AddCode
AddNamedItem
AddScriptReference


ResetWatermark Method

[image]
ActiveReports 13
ResetWatermark Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResetWatermark Method

Glossary Item Box

Resets the watermark to its default value.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetWatermark()
C#
public virtual void ResetWatermark()

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.ResetWatermark();
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.ResetWatermark()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Restart Method

[image]
ActiveReports 13
Restart Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Restart Method

Glossary Item Box

Resets the report data source and clears the pages collection.

Syntax

Visual Basic (Declaration)
Public Sub Restart()
C#
public void Restart()

Remarks

This method is used to reset an existing report instance after modifying its data source or page settings so that it can be run again. Note that in order to run the report with the new settings, you must call the Run method after calling Restart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Run Method


Run Method

[image]
ActiveReports 13
Run Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Run Method

Glossary Item Box

Starts the report processing.

Overload List

Overload | Description
Run() | Starts the report processing in blocked mode.
Run(Boolean) | Starts report execution and optionally keeps any linked viewer control document in sync with the report's document.

Remarks

Once the report is completed, the Document property is set to the report output Document. You can use the Document to Print, Preview or Export the output.

Example

C# Copy Code
private void formReport_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub formReport_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Document Property
Cancel Method
Stop Method


Run() Method

[image]
ActiveReports 13
Run() Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > Run Method : Run() Method

Glossary Item Box

Starts the report processing in blocked mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Run()
C#
public void Run()

Remarks

This method does not synchronize a viewer control's linked document until the report has finished processing.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List
Document Property


Run(Boolean) Method

[image]
ActiveReports 13
Run(Boolean) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > Run Method : Run(Boolean) Method

syncDocument
Set to True to synchronize a linked viewer control document with the report processing.

Glossary Item Box

Starts report execution and optionally keeps any linked viewer control document in sync with the report's document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Run( _
   ByVal syncDocument As Boolean _
)
C#
public void Run(
   bool syncDocument
)

Parameters

syncDocument
Set to True to synchronize a linked viewer control document with the report processing.

Remarks

If the report document is linked to a viewer control the report will synchronize the viewer display and load pages as soon as they have completed rendering.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run(True);
    viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run(True)
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveLayout Method

[image]
ActiveReports 13
SaveLayout Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SaveLayout Method

Glossary Item Box

Saves a report's XML layout to a stream or file.

Overload List

Overload | Description
SaveLayout(String) | This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.
SaveLayout(Stream) | This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.
SaveLayout(XmlWriter) | Saves a report's XML layout to the specified XmlWriter.

Remarks

The SaveLayout(String) method uses the UTF-8 encoding, and the SaveLayout(Stream) method uses the UTF-16 encoding for saving.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
SectionReport1 ar = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter("\\report.rpx", null);
ar.SaveLayout(xtw);
xtw.Close();

// saving to stream
System.IO.MemoryStream memory_stream = new System.IO.MemoryStream();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(memory_stream))
{
    ar.SaveLayout(writer);
}

// saving to string
System.Text.StringBuilder layoutContent = new System.Text.StringBuilder();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(layoutContent))
{
    ar.SaveLayout(writer);
}
Visual Basic Copy Code
Dim ar As New SectionReport1()
Dim xtw As New System.Xml.XmlTextWriter("\report.rpx", Nothing)
ar.SaveLayout(xtw)
xtw.Close()

' saving to stream
Dim memory_stream As New System.IO.MemoryStream
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(memory_stream)
    ar.SaveLayout(writer)
End Using

' saving to string
Dim layoutContent As New System.Text.StringBuilder()
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(layoutContent)
    ar.SaveLayout(writer)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
LoadLayout Method

Concepts

Scripting


SaveLayout(String) Method

[image]
ActiveReports 13
SaveLayout(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(String) Method

fileName
Name of the file where the report's layout will be saved.

Glossary Item Box

This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal fileName As String _
)
C#
public void SaveLayout(
   string fileName
)

Parameters

fileName
Name of the file where the report's layout will be saved.

Remarks

The SaveLayout(String) method uses the UTF-8 encoding when you save to a file.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
private void saveRPX()
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    rpt.SaveLayout(Application.StartupPath + "\\NewRPX.RPX");
}
VB.NET Copy Code
Dim rpt As New SectionReport1()
Private Sub saveRPX()
    rpt.Run()
    rpt.SaveLayout(Application.StartupPath + "\\NewRPX.RPX")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List

Concepts

Scripting


SaveLayout(Stream) Method

[image]
ActiveReports 13
SaveLayout(Stream) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(Stream) Method

stream
Stream object where the report's layout will be saved.

Glossary Item Box

This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal stream As Stream _
)
C#
public void SaveLayout(
   Stream stream
)

Parameters

stream
Stream object where the report's layout will be saved.

Remarks

You can use this method to save the report's layout as a stream, then store it in a database or a resource file.

The SaveLayout(Stream) method uses the UTF-16 encoding when you save to a stream.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
private void mnuPrintPreview_Click(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
    this.designer1.Report.SaveLayout(m_stream);
    m_stream.Position = 0;
    rpt.LoadLayout(m_stream);
    m_stream.Close();
    frmViewer frm = new frmViewer();
    frm.SetReport(rpt);
    frm.ShowDialog(this);
}
VB.NET Copy Code
Private Sub mnuPrintPreview_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) _
    Handles mnuPrintPreview.Click
        Dim rpt As New GrapeCity.ActiveReports.SectionReport()
        Dim m_stream As New System.IO.MemoryStream()
        Me.Designer1.Report.SaveLayout(m_stream)
        m_stream.Position = 0
        rpt.LoadLayout(m_stream)
        m_stream.Close()
        Dim frm As New frmViewer()
        frm.SetReport(rpt)
        frm.ShowDialog(Me)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveLayout(XmlWriter) Method

[image]
ActiveReports 13
SaveLayout(XmlWriter) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(XmlWriter) Method

writer
XmlWriter object where the report's layout is saved.

Glossary Item Box

Saves a report's XML layout to the specified XmlWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal writer As XmlWriter _
)
C#
public void SaveLayout(
   XmlWriter writer
)

Parameters

writer
XmlWriter object where the report's layout is saved.

Remarks

You can use this method to save the report's layout to an XmlWriter object, then store it in a database or a resource file.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example

C# Copy Code
SectionReport1 ar = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter("\\report.rpx", null);
ar.SaveLayout(xtw);
xtw.Close();

// saving to stream
System.IO.MemoryStream memory_stream = new System.IO.MemoryStream();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(memory_stream))
{
  ar.SaveLayout(writer);
}

// saving to string
System.Text.StringBuilder layoutContent = new System.Text.StringBuilder();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(layoutContent))
{
  ar.SaveLayout(writer);
}
Visual Basic Copy Code
Dim ar As New SectionReport1()
Dim xtw As New System.Xml.XmlTextWriter("\report.rpx", Nothing)
ar.SaveLayout(xtw)
xtw.Close()

' saving to stream
Dim memory_stream As New System.IO.MemoryStream
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(memory_stream)
    ar.SaveLayout(writer)
End Using

' saving to string
Dim layoutContent As New System.Text.StringBuilder()
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(layoutContent)
   ar.SaveLayout(writer)
End Using

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveStyles Method

[image]
ActiveReports 13
SaveStyles Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SaveStyles Method

Glossary Item Box

Saves a reports styles to an external stylesheet.

Overload List

Overload | Description
SaveStyles(String) | Saves a reports styles to an external stylesheet.
SaveStyles(Stream) | Saves a reports styles to an external stylesheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


SaveStyles(String) Method

[image]
ActiveReports 13
SaveStyles(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveStyles Method : SaveStyles(String) Method

fileName
The file name to save the report's Style Sheet to.

Glossary Item Box

Saves a reports styles to an external stylesheet.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveStyles( _
   ByVal fileName As String _
)
C#
public void SaveStyles(
   string fileName
)

Parameters

fileName
The file name to save the report's Style Sheet to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveStyles(Stream) Method

[image]
ActiveReports 13
SaveStyles(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveStyles Method : SaveStyles(Stream) Method

outStream
The stream to which the external stylesheet is saved.

Glossary Item Box

Saves a reports styles to an external stylesheet.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveStyles( _
   ByVal outStream As Stream _
)
C#
public void SaveStyles(
   Stream outStream
)

Parameters

outStream
The stream to which the external stylesheet is saved.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Overload List


Stop Method

[image]
ActiveReports 13
Stop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Stop Method

Glossary Item Box

Stops processing the report.

Syntax

Visual Basic (Declaration)
Public Sub Stop()
C#
public void Stop()

Remarks

All rendered pages are retained in the report's Document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Cancel Method


SectionReport Class Properties

[image]
ActiveReports 13
SectionReport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

For a list of all members of this type, see SectionReport members.

Public Properties

 | Name | Description
Public Property | CalculatedFields | Gets a FieldCollection object containing all of the calculated fields in the report.
Public Property | Culture | Provides information on a specific culture, including its names and the writing system.
Public Property | CurrentPage | Returns the current page instance.
Public Property | DataMember | Gets or sets the specified list in an DataSource to which the report will bind.
Public Property | DataSource | Gets or sets the data source from which the report will retrieve data.
Public Property | Document | Gets a reference to the report output Document object.
Public Property | EnableScriptDebugging | Allows to catch script exceptions in the debugger. The default value is False.
Public Property | ExpressionErrorMessage | Stops the reporting engine from throwing exceptions and instead displays the provided string.
Public Property | Fields | Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.
Public Property | IsDirty | Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.
Public Property | LayoutAction | Sets or returns a custom action following the rendering of the current record.
Public Property | MaxPages | Sets or returns the maximum number of pages that the report will create.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageNumber | Returns the number of the current page being processed when a report is running.
Public Property | PageSettings | Returns a reference to the current report's page settings.
Public Property | Parameters | Returns a reference to the data source query parameters collection.
Public Property | ParentReport | Gets a reference to the parent report.
Public Property | PrintWidth | Sets or returns the report's printable width in inches.
Public Property | ResourceLocator | Gets the object responsible for resolving report resources.
Public Property | Script | Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.
Public Property | ScriptLanguage | Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.
Public Property | Sections | Returns a reference to the report's sections collection.
Public Property | ShowParameterUI | Sets or returns whether or not the query parameters dialog box will appear when the report is run.
Public Property | State | Returns the current state of the report.
Public Property | StyleSheet | Returns a collection of formatting styles used to format controls in the report.
Public Property | UserData | Sets or returns a user-defined value.
Public Property | Version | Returns the product's version number.
Public Property | Watermark | Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.
Public Property | WatermarkAlignment | Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.
Public Property | WatermarkPrintOnPages | Sets or returns a value indicating the specific pages to which the watermark should be added.
Public Property | WatermarkSizeMode | Sets or returns how the watermark will be sized when the image is rendered on the page.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


CalculatedFields Property

[image]
ActiveReports 13
CalculatedFields Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CalculatedFields Property

Glossary Item Box

Gets a FieldCollection object containing all of the calculated fields in the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CalculatedFields As FieldCollection
C#
public FieldCollection CalculatedFields {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Culture Property

[image]
ActiveReports 13
Culture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Culture Property

Glossary Item Box

Provides information on a specific culture, including its names and the writing system.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


CurrentPage Property

[image]
ActiveReports 13
CurrentPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CurrentPage Property

Glossary Item Box

Returns the current page instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPage As Page
C#
public Page CurrentPage {get;}

Remarks

This property allows you to use primitive drawing methods or apply templates to report pages while the report is processing.

Example

C# Copy Code
private void rptTest_PageEnd(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawText("Confidential", 4F,10F,2F,0.188F);
}
Visual Basic Copy Code
Private Sub rptDocument_PageEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageEnd
    Me.CurrentPage.DrawText("Confidential", 4.0F, 10.0F, 2.0F, 0.188F)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


DataMember Property

[image]
ActiveReports 13
DataMember Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataMember Property

Glossary Item Box

Gets or sets the specified list in an DataSource to which the report will bind.

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
C#
public string DataMember {get; set;}

Remarks

Default is an empty string.

If a data source, such as a dataset, contains multiple lists, you must set the DataMember to a list contained in the data source. The ActiveReports built-in data sources always contain a single data source, hence do not require that this property be set.

Example

C# Copy Code
private void rptProducts_ReportStart(object sender, System.EventArgs eArgs)
{
    rptProducts rpt = new rptProducts();
    localhost.DataSetWS ws = new localhost.DataSetWS();
    DataSet ds = ws.GetProduct();
    this.DataSource = ds;
    this.DataMember = "Products";
}
Visual Basic Copy Code
Private Sub rptProducts_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim rpt As New rptProducts()
    Dim ws As New localhost.DataSetWS()
    Dim ds As New DataSet()
    ds = ws.GetProduct()
    Me.DataSource = ds
    Me.DataMember = "Products"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataSource Property


DataSource Property

[image]
ActiveReports 13
DataSource Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataSource Property

Glossary Item Box

Gets or sets the data source from which the report will retrieve data.

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
C#
public object DataSource {get; set;}

Property Value

An object that functions as a data source.

Remarks

The data source can be set to any of the ActiveReports built-in data sources or to any of the following:

  • DataSet
  • DataTable
  • DataView
  • RowCollection

You cannot change the data source property settings after the report starts processing.

Example

C# Copy Code
private void rptProducts_ReportStart(object sender, System.EventArgs eArgs)
{
    rptProducts rpt = new rptProducts();
    localhost.DataSetWS ws = new localhost.DataSetWS();
    DataSet ds = ws.GetProduct();
    this.DataSource = ds;
    this.DataMember = "Products";
}
Visual Basic Copy Code
Private Sub rptProducts_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim rpt As New rptProducts()
    Dim ws As New localhost.DataSetWS()
    Dim ds As New DataSet()
    ds = ws.GetProduct()
    Me.DataSource = ds
    Me.DataMember = "Products"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataMember Property


Document Property

[image]
ActiveReports 13
Document Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Document Property

Glossary Item Box

Gets a reference to the report output Document object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As SectionDocument
C#
public SectionDocument Document {get;}

Property Value

Generated Document object, null if the report has not been executed.

Remarks

The SectionDocument class is in the GrapeCity.ActiveReports.Document.v10 assembly in the GrapeCity.ActiveReports.Document namespace.

Example

C# Copy Code
private void formReport_Load(object sender, System.EventArgs e)
{
    rptMain rpt = new rptMain();
    this.viewer1.Document = rpt.Document;
    rpt.Run();
}
Visual Basic Copy Code
Private Sub formReport_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    Viewer1.Document = rpt.Document
    rpt.Run()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
SectionDocument Class


EnableScriptDebugging Property

[image]
ActiveReports 13
EnableScriptDebugging Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : EnableScriptDebugging Property

Glossary Item Box

Allows to catch script exceptions in the debugger. The default value is False.

Syntax

Visual Basic (Declaration)
Public Property EnableScriptDebugging As Boolean
C#
public bool EnableScriptDebugging {get; set;}

Remarks

The EnableScriptDebugging property should be set to True before the script code compilation, which is similar to setting it before calling the Run method in ActiveReports.

If EnableScriptDebugging is set to True, then the compiled code is stored to a .dll file in the temporary folder.

Note: Visual Studio does not support script debugging at design time preview of a report.

Example

C# Copy Code
public void SectionReport_ReportStart()
{
    // the following line of script code attaches the debugger to the script
    System.Diagnostics.Debugger.Launch();
}
Visual Basic Copy Code
Public Sub SectionReport_ReportStart()
   'the following line of script code attaches the debugger to the script
   System.Diagnostics.Debugger.Launch()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


ExpressionErrorMessage Property

[image]
ActiveReports 13
ExpressionErrorMessage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ExpressionErrorMessage Property

Glossary Item Box

Stops the reporting engine from throwing exceptions and instead displays the provided string.

Syntax

Visual Basic (Declaration)
Public Property ExpressionErrorMessage As String
C#
public string ExpressionErrorMessage {get; set;}

Property Value

String. The default value is null.

Remarks

If this property is not set and an expression can't be parsed, or if you get a divide-by-zero type exception, ActiveReports will throw a ReportScriptException and stop the report from running.

When this property is set to a valid string, the engine stops throwing exceptions and instead displays the specified string (like Excel). Set it to ### and try Sales/0 to test.

Persistence: There is a new attribute called "ExprError" in .rpx files.

Example

C# Copy Code
private void arViewer_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.ExpressionErrorMessage = "oops";
    rpt.Run();
    this.arViewer.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub arViewer_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arViewer.Load
    Dim rpt As New SectionReport1()
    rpt.ExpressionErrorMessage = "oops"
    rpt.Run()
    Me.arViewer.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Fields Property

[image]
ActiveReports 13
Fields Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Fields Property

Glossary Item Box

Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
C#
public FieldCollection Fields {get;}

Remarks

ActiveReports initializes the collection with all the fields in the DataSource if any. You can add custom unbound fields to the collection in the DataInitialize event. This allows you to create custom calculated fields and bind the report sections and controls to fields not available through the data source but provided at run time in the FetchData event. This allows the report to bind to collections, arrays or any other custom data structure that your application handles.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example

C# Copy Code
private void rptUnbound_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
}
Visual Basic Copy Code
Private Sub rptUnbound_DataInitialize(ByVal sender As Object, ByVal e As _
    System.EventArgs) Handles MyBase.DataInitialize
    Fields.Add("CategoryName")
    Fields.Add("ProductName")
    Fields.Add("UnitsInStock")
    Fields.Add("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataInitialize Event
FetchData Event


IsDirty Property

[image]
ActiveReports 13
IsDirty Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : IsDirty Property

Glossary Item Box

Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.

Syntax

Visual Basic (Declaration)
Public Property IsDirty As Boolean
C#
public bool IsDirty {get; set;}

Remarks

This property is typically used by the End-User Report Designer control to determine whether the current report layout needs to be saved.

Example

NOTE: The following is incomplete code. You would need to add your own code to handle the user's answer via the MessageBox.
C# Copy Code
private void mnuExit_Click(object sender, System.EventArgs e)
{
    if (((GrapeCity.ActiveReports.SectionReport)this.reportdesigner.Report).IsDirty == true)
    {
        MessageBox.Show("Do you want to save your report?");
    }
    else
    {
        this.Close();
    }
}
Visual Basic Copy Code
Private Sub mnuExit_Click(sender As Object, e As System.EventArgs)
    If DirectCast(Me.reportdesigner.Report, GrapeCity.ActiveReports.SectionReport).IsDirty = True Then
        MessageBox.Show("Do you want to save your report?")
    Else
        Me.Close()
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


LayoutAction Property

[image]
ActiveReports 13
LayoutAction Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LayoutAction Property

Glossary Item Box

Sets or returns a custom action following the rendering of the current record.

Syntax

Visual Basic (Declaration)
Public Property LayoutAction As LayoutAction
C#
public LayoutAction LayoutAction {get; set;}

Property Value

Current layout action. The default is LayoutAction.MoveLayout | LayoutAction.NextRecord | LayoutAction.PrintSection, which returns a value of 7.

  • PrintSection has a value of 1.
  • MoveLayout has a value of 2.
  • NextRecord has a value of 4.

Remarks

ActiveReports automatically performs the following actions for each record in the data source after each Detail section format:

  1. Prints the section.
  2. Moves the layout (sets the next print position for the rest of the report).
  3. Moves to the next record.

The LayoutAction property allows you to control which of these steps should be performed or omitted. Using a combination of layout actions when the report is executed can change a report's layout.

This property can be used only in the Detail section's Format event.

The following table shows the results of different combinations of LayoutActions

Value | Print | Layout | NextR | Description
7 | True | True | True | (Default) Move to next print location, get next record, and print data.
3 | True | True | False | Move to the next print location, don't advance to the next record, but print the data.
4 | False | False | True | Skip a record without leaving a blank space on the page.
6 | False | True | True | Skip a record and leave a blank space on the page.
2 | False | True | False | Leave a blank space without skipping a record.
5 | True | False | True | Print the next record on top of the current record (UnderlayNext).

Example

C# Copy Code
int counter=0;
private void detail_Format(object sender, System.EventArgs eArgs)
{
    //repeat each row five times
    counter = counter + 1;
    if (counter <= 4)
    {
        this.LayoutAction =  GrapeCity.ActiveReports.LayoutAction.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.LayoutAction.PrintSection;
    }
    else
    {
        this.LayoutAction = GrapeCity.ActiveReports.LayoutAction.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.LayoutAction.NextRecord|GrapeCity.ActiveReports.LayoutAction.LayoutAction.PrintSection;
        counter = 0;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    'repeat each row five times
    Static counter As Integer
    counter = counter + 1
    If counter <= 4 Then
        Me.LayoutAction = 3
    Else
        Me.LayoutAction = 7
        counter = 0
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Format Event
LayoutAction Enumeration


MaxPages Property

[image]
ActiveReports 13
MaxPages Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : MaxPages Property

Glossary Item Box

Sets or returns the maximum number of pages that the report will create.

Syntax

Visual Basic (Declaration)
Public Property MaxPages As Long
C#
public long MaxPages {get; set;}

Property Value

Maximum number of pages. The default value is 0, which specifies no page limit.

Remarks

ActiveReports will stop the report execution once the report Document reaches the set number of pages.

This property can be used to limit the number of output pages when running large reports and distributing the results over a slow connection. It can also be used to present a quick preview of a few pages in a long report.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.MaxPages = 2;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.MaxPages = 2
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Name Property

Glossary Item Box

Gets or sets the name of the report.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageNumber Property

[image]
ActiveReports 13
PageNumber Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageNumber Property

Glossary Item Box

Returns the number of the current page being processed when a report is running.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Example

C# Copy Code
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Text=this.PageNumber.ToString();
}
Visual Basic Copy Code
Private Sub detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.textBox1.Text = Me.PageNumber
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageSettings Property

[image]
ActiveReports 13
PageSettings Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageSettings Property

Glossary Item Box

Returns a reference to the current report's page settings.

Syntax

Visual Basic (Declaration)
Public Property PageSettings As PageSettings
C#
public PageSettings PageSettings {get; set;}

Property Value

Default PageSettings object.

Remarks

Used to specify settings that modify the way the report's pages will be printed.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1()
    rpt.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ActiveReports6~GrapeCity.ActiveReports.PageSettings


Parameters Property

[image]
ActiveReports 13
Parameters Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Parameters Property

Glossary Item Box

Returns a reference to the data source query parameters collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
C#
public ParameterCollection Parameters {get;}

Property Value

An initialized Parameters collection.

Remarks

The parameters collection is automatically populated when the report is started. If parameters are specified in the report's DataSource, they will be added to the collection.

For example, setting your RecordSource to the following SQL adds "Order Date" and "Order ID" to the parameters collection.

"SELECT * FROM orders WHERE OrderDate >= #<%OrderDate|Enter Order date|1/1/1995%># AND OrderID > <%OrderID|OrderID%>"

You can set the parameter values before the report starts or allow ActiveReports to collect the values from the user at run time.

Note: Depending on your data source, you may need to add pound signs around the parameter syntax for dates (as in the "Order Date" example above) or apostrophes around the parameter syntax for strings, i.e. "SELECT * FROM Customers CustomerID = '<%CustomerID%>'"

Example

Paste into the Viewer Hyperlink event.
C# Copy Code
private void arv_HyperLink(object sender, GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs e)
    {
     SectionReport1 rpt = new SectionReport1();
     Form1 frm = new Form1();
     rpt.Parameters["customerID"].Value = e.HyperLink.ToString();
     rpt.Run();
     frm.arv.Document = rpt.Document;
     frm.ShowDialog(this);
 }
Paste into the Viewer Hyperlink event.
Visual Basic Copy Code
Private Sub arv_HyperLink(sender As Object, e As GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs) Handles arv.HyperLink
Dim rpt As New SectionReport1()
Dim frm As New Form1()
rpt.Parameters("customerID").Value = e.HyperLink.ToString()
rpt.Run()
frm.arv.Document = rpt.Document
frm.ShowDialog(Me)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ShowParameterUI Property


ParentReport Property

[image]
ActiveReports 13
ParentReport Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ParentReport Property

Glossary Item Box

Gets a reference to the parent report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentReport As SectionReport
C#
public SectionReport ParentReport {get;}

Property Value

ActiveReport (Reference to the parent report object).

Remarks

This property is available when the report is running as a subreport of another report.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark(((TextBox)(this.ParentReport.Sections["detail"].Controls["txtCategoryName"])).
        Text + "\\" + this.txtProductName.Text);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark(CType(Me.ParentReport.Sections("Detail1").Controls("txtCategoryName"),  _
        TextBox).Text + "\" + Me.txtProductName.Text)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PrintWidth Property

[image]
ActiveReports 13
PrintWidth Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintWidth Property

Glossary Item Box

Sets or returns the report's printable width in inches.

Syntax

Visual Basic (Declaration)
Public Property PrintWidth As Single
C#
public float PrintWidth {get; set;}

Property Value

The amount of physical space to which a report can print. The default value is 6.5 inches.

Remarks

If the margin widths are not taken into consideration when setting the print width, the report may become wider than the paper size. When this happens, a blank page will be printed out after each page in the report, or in the viewer, a vertical red dotted line will appear on the right-hand side of the page.

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.PrintWidth = rpt.PageSettings.PaperWidth - rpt.PageSettings.Margins.Left - rpt.PageSettings.Margins.Right;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.PrintWidth = rpt.PageSettings.PaperWidth - rpt.PageSettings.Margins.Left - rpt.PageSettings.Margins.Right
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
PageSettings Property


ResourceLocator Property

[image]
ActiveReports 13
ResourceLocator Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResourceLocator Property

Glossary Item Box

Gets the object responsible for resolving report resources.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As GrapeCity.ActiveReports.ResourceLocator
C#
public GrapeCity.ActiveReports.ResourceLocator ResourceLocator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Script Property

[image]
ActiveReports 13
Script Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Script Property

Glossary Item Box

Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.

Syntax

Visual Basic (Declaration)
Public Property Script As String
C#
public string Script {get; set;}

Property Value

The current script code. The default value is an empty string.

Remarks

The Script property can be used to make modifications to the report outside the code written in the report's events. The script events run immediately after their matching ActiveReports code-behind events and take precedence over the code inside the project.

If reports with scripts are saved to XML, the scripts (unlike code-behind) are incorporated into the XML file. Changes can be made to the XML file scripts and then loaded back into a report project to show the changes. This allows reports to be modified without requiring the project to be recompiled.

When referencing the report in the script, use rpt instead of the report's name or "Me" or "this".

In order to reference a member of the report class using the "rpt" named object, the member has to be a public member. You can use a control's modifier property to change the generated code for a control from private to public.

If you plan to run the report from a stand-alone RPX file without the compiled code-behind class, your scripting code would have to reference the report class controls using the Controls collection instead of by name.

Scripts are compiled at run time using the language specified in the ScriptLanguage property.

Example

This snippet assumes that you have html in the RichTextBox, and that the Modifiers property of the RichTextBox is set to Public.
C# Copy Code
private void button1_Click(object sender, System.EventArgs e)
{
    string sScript = string.Empty;
    SectionReport1 rpt = new SectionReport1();

    sScript += "public void ReportHeader_Format()";
    sScript += "{";
    sScript += "rpt.RichTextBox1.Html = rpt.RichTextBox1.Text;";
    sScript += "}";

    rpt.Script = sScript;
    rpt.Run();
    arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnScript.Click
    Dim sScript As String = String.Empty
    Dim rpt As New SectionReport1

    sScript += "public void ReportHeader_Format()"
    sScript += "{"
    sScript += "rpt.RichTextBox1.Html = rpt.RichTextBox1.Text;"
    sScript += "}"

    rpt.Script = sScript
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ScriptLanguage Property


ScriptLanguage Property

[image]
ActiveReports 13
ScriptLanguage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ScriptLanguage Property

Glossary Item Box

Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.

Syntax

Visual Basic (Declaration)
Public Property ScriptLanguage As String
C#
public string ScriptLanguage {get; set;}

Property Value

String value that is the current scripting language. The default value is C#.

Remarks

When the ScriptLanguage is set, the script editor will use the specified scripting language. ActiveReports supports C# and VB.NET for run-time scripting.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Script Property


Sections Property

[image]
ActiveReports 13
Sections Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Sections Property

Glossary Item Box

Returns a reference to the report's sections collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sections As SectionCollection
C#
public SectionCollection Sections {get;}

Property Value

Sections collection.

Remarks

This property can be used to add or remove report sections at run time.

Example

C# Copy Code
float m_defaultHeight = .2f;
float m_defaultWidth = 4f;
float m_currentY = 0f;

private void constructReport()
{
    try
    {
        this.detail.CanGrow = true;
        this.detail.CanShrink = true;
        this.detail.KeepTogether = true;

        if(m_useGroups)
        {
            this.Sections.InsertGroupHF();
            ((GroupHeader)this.Sections["groupHeader1"]).DataField = "Country";
            this.Sections["groupHeader1"].BackColor = System.Drawing.Color.SlateBlue;
            this.Sections["groupHeader1"].CanGrow = true;
            this.Sections["groupHeader1"].CanShrink = true;
            ((GroupHeader)this.Sections["groupHeader1"]).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail;
            this.Sections["groupFooter1"].Height = 0;

            TextBox txt = new TextBox();
            txt.DataField = "Country";
            txt.Location = new System.Drawing.PointF(0f,0);
            txt.Width =2f;
            txt.Height = .3f;
            txt.Style = "font-weight: bold; font-size: 16pt;";
            this.Sections["groupHeader1"].Controls.Add(txt);

        }

        for(int i=0;i<m_arrayFields.Count;i++)
        {
            if(!m_useGroups || (m_useGroups && m_arrayFields[i].ToString() != "Country"))
            {
                Label lbl = new Label();
                lbl.Text = m_arrayFields[i].ToString() + ":";
                lbl.Location = new System.Drawing.PointF(0f,m_currentY);
                lbl.Width =.9f;
                lbl.Height = m_defaultHeight;
                this.detail.Controls.Add(lbl);

                TextBox txt = new TextBox();
                txt.DataField = m_arrayFields[i].ToString();
                txt.Location = new System.Drawing.PointF(1f,m_currentY);
                txt.Width =m_defaultWidth;
                txt.Height = m_defaultHeight;
                this.detail.Controls.Add(txt);

                m_currentY = m_currentY + m_defaultHeight;
            }
        }
    }
    catch(Exception ex)
    {
        System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message,"Project Error",System.Windows.Forms.MessageBoxButtons.OK,System.Windows.Forms.MessageBoxIcon.Error);
    }
}
Visual Basic Copy Code
Private Sub constructReport()
    Try
        Me.Detail1.CanGrow = True
        Me.Detail1.CanShrink = True
        Me.Detail1.KeepTogether = True
        If m_useGroups = True Then
            Me.Sections.InsertGroupHF()

            CType(Me.Sections("GroupHeader1"), GroupHeader).DataField = "CategoryID"
            Me.Sections("GroupHeader1").BackColor = System.Drawing.Color.SlateBlue
            Me.Sections("GroupHeader1").CanGrow = True
            Me.Sections("GroupHeader1").CanShrink = True
            CType(Me.Sections("GroupHeader1"), GroupHeader).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
            Me.Sections("GroupHeader1").Height = 0

            Dim txt As New TextBox()
            txt.DataField = "CatagoryID"
            txt.Location = New System.Drawing.PointF(0.0F, 0)
            txt.Width = 2.0F
            txt.Height = 0.3F
            txt.Style = "font-weight: bold; font-size: 16pt"
            Me.Sections("GroupHeader1").Controls.Add(txt)
        End If
        For i = 0 To m_arrayFields.Count - 1
           If (m_useGroups = False) Or (m_useGroups AndAlso m_arrayFields(i).ToString <> "CategoryID") Then

                Dim lbl As New Label()
                lbl.Text = m_arrayFields(i) + ":"
                lbl.Location() = New System.Drawing.PointF(0.0F, m_currentY)
                lbl.Width() = 0.9F
                lbl.Height = m_defaultHeight
                Me.Detail1.Controls.Add(lbl)

                Dim txt As New TextBox()
                txt.DataField = m_arrayFields(i)
                txt.Location = New System.Drawing.PointF(1.0F, m_currentY)
                txt.Width = m_defaultWidth
                txt.Height = m_defaultHeight
                Me.Detail1.Controls.Add(txt)
                If m_arrayFields(i) = "UnitPrice" Then
                    txt.OutputFormat = "$#.00"
                End If
                m_currentY = m_currentY + m_defaultHeight
            End If
        Next
    Catch ex As Exception
        System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message, "Project Error", System.Windows.Forms.MessageBoxButtons.OK, System.Windows.Forms.MessageBoxIcon.Error)
    End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members

Walkthroughs

Run Time Layouts


ShowParameterUI Property

[image]
ActiveReports 13
ShowParameterUI Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ShowParameterUI Property

Glossary Item Box

Sets or returns whether or not the query parameters dialog box will appear when the report is run.

Syntax

Visual Basic (Declaration)
Public Property ShowParameterUI As Boolean
C#
public bool ShowParameterUI {get; set;}

Remarks

Set this property to False if the report is a subreport that will take its parameter values from the parent report.

Example

C# Copy Code
private void rptChild_ReportStart(object sender, System.EventArgs eArgs)
{
    this.ShowParameterUI = false;
}
Visual Basic Copy Code
Private Sub rptChild_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.ShowParameterUI = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ParameterUIClosed Event


State Property

[image]
ActiveReports 13
State Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : State Property

Glossary Item Box

Returns the current state of the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As SectionReport.ReportState
C#
public SectionReport.ReportState State {get;}

Property Value

Current ReportState.

Remarks

The possible values for this property are Running, Idle, or Completed.

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    this.statusBar1.Text = "Report is " + rpt.State.ToString();
    rpt.Run();
    this.statusBar1.Text = "Report is " + rpt.State.ToString();
    this.viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    Me.StatusBar1.Text = "Report is " & rpt.State.ToString
    rpt.Run()
    Me.StatusBar1.Text = "Report is " & rpt.State.ToString
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


StyleSheet Property

[image]
ActiveReports 13
StyleSheet Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : StyleSheet Property

Glossary Item Box

Returns a collection of formatting styles used to format controls in the report.

Syntax

Visual Basic (Declaration)
Public Property StyleSheet As StyleSheet
C#
public StyleSheet StyleSheet {get; set;}

Property Value

Predefined default styles collection.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ActiveReports6~GrapeCity.ActiveReports.StyleSheet
ActiveReports6~GrapeCity.ActiveReports.Style


UserData Property

[image]
ActiveReports 13
UserData Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : UserData Property

Glossary Item Box

Sets or returns a user-defined value.

Syntax

Visual Basic (Declaration)
Public Property UserData As Object
C#
public object UserData {get; set;}

Remarks

Values specified in this property are saved and loaded as part of the report layout. You can use this property to store information beyond what the report properties offer, much like the Tag property in Visual Basic. This property is only persisted as a string if the RPX is saved or loaded to file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Version Property

[image]
ActiveReports 13
Version Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Version Property

Glossary Item Box

Returns the product's version number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As String
C#
public string Version {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


Watermark Property

[image]
ActiveReports 13
Watermark Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Watermark Property

Glossary Item Box

Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.

Syntax

Visual Basic (Declaration)
Public Property Watermark As Image
C#
public Image Watermark {get; set;}

Property Value

Watermark image object. Default is null.

Remarks

Watermark properties must be specified before the report starts executing, preferably in the ReportStart event. The watermark will be clipped and centered on the page unless the WatermarkSizeMode and WatermarkAlignment are specified.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark=System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
WatermarkAlignment Property
WatermarkPrintOnPages Property
WatermarkSizeMode Property


WatermarkAlignment Property

[image]
ActiveReports 13
WatermarkAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkAlignment Property

Glossary Item Box

Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.

Syntax

Visual Basic (Declaration)
Public Property WatermarkAlignment As PictureAlignment
C#
public PictureAlignment WatermarkAlignment {get; set;}

Property Value

PictureAlignment enumeration. The default value is PictureAlignment.Center.

Remarks

The watermark properties should be specified in or before the ReportStart event.

Example

Paste into the Viewer Load event.
C# Copy Code
SectionReport1 rpt = new SectionReport1();
    rpt.Watermark=System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.WatermarkAlignment = GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.BottomRight;
    rpt.Run();
    this.arv.Document = rpt.Document;
Paste into the Viewer Load event.
Visual Basic Copy Code
Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.WatermarkAlignment = GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.BottomRight
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Watermark Property


WatermarkPrintOnPages Property

[image]
ActiveReports 13
WatermarkPrintOnPages Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkPrintOnPages Property

Glossary Item Box

Sets or returns a value indicating the specific pages to which the watermark should be added.

Syntax

Visual Basic (Declaration)
Public Property WatermarkPrintOnPages As String
C#
public string WatermarkPrintOnPages {get; set;}

Property Value

String representing page or page range on which the watermark will be printed. Default is an empty string (all pages).

Remarks

The syntax can include a single page, page range or a combination of both. For example: 1, 5-8, 9, 10-12.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark=System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.WatermarkPrintOnPages = "1,3-5,7";
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.WatermarkPrintOnPages = "1,3-5,7"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
Watermark Property


WatermarkSizeMode Property

[image]
ActiveReports 13
WatermarkSizeMode Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkSizeMode Property

Glossary Item Box

Sets or returns how the watermark will be sized when the image is rendered on the page.

Syntax

Visual Basic (Declaration)
Public Property WatermarkSizeMode As SizeModes
C#
public SizeModes WatermarkSizeMode {get; set;}

Property Value

SizeModes enumeration. The default value is SizeModes.Clip.

Remarks

Watermark properties should be specified in the ReportStart event.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark = System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.WatermarkSizeMode = GrapeCity.ActiveReports.SectionReportModel.SizeModes.Zoom;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.WatermarkSizeMode = GrapeCity.ActiveReports.SectionReportModel.SizeModes.Zoom
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ActiveReports6~GrapeCity.ActiveReports.SizeModes


SectionReport Class Events

[image]
ActiveReports 13
SectionReport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

Glossary Item Box

For a list of all members of this type, see SectionReport members.

Public Events

 | Name | Description
Public Event | DataInitialize | Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.
Public Event | DataSourceChanged | Raised when the properties of the report's data source are modified.
Public Event | FetchData | Raised every time a new record is processed.
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | NoData | Raised if the report's data source does not return any records and there is no data to be processed.
Public Event | PageEnd | Raised after the report finishes rendering each page.
Public Event | PageStart | Raised before the report renders any output to a new page.
Public Event | ParameterUIClosed | Raised after the user closes the query parameters dialog.
Public Event | PrintAborted | Raised when the user cancels a print job.
Public Event | PrintProgress | Raised for each page while printing the report document.
Public Event | ReportEnd | Raised after the report finishes processing all pages.
Public Event | ReportStart | Raised before a report starts processing.
Top

See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


DataInitialize Event

[image]
ActiveReports 13
DataInitialize Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataInitialize Event

Glossary Item Box

Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.

Syntax

Visual Basic (Declaration)
Public Event DataInitialize As EventHandler
C#
public event EventHandler DataInitialize

Remarks

Custom fields can be added to a bound report (one that uses the built-in data source to retrieve records) or an unbound report (one that does not depend on the data source to get its records).

In a bound report, the report's data source is initialized, opened and its fields are added to the Fields collection before the DataInitialize event is raised.

The DataInitialize event is raised only once unless you call the Restart() method.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example

C# Copy Code
private void rptUnbound_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
}
Visual Basic Copy Code
Private Sub rptUnbound_DataInitialize(ByVal sender As Object, ByVal e As _
    System.EventArgs) Handles MyBase.DataInitialize
    Fields.Add("CategoryName")
    Fields.Add("ProductName")
    Fields.Add("UnitsInStock")
    Fields.Add("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
FetchData Event
Fields Property
DataSource Property
ReportStart Event

Concepts

Unbound Reporting
Sequence of Events


DataSourceChanged Event

[image]
ActiveReports 13
DataSourceChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataSourceChanged Event

Glossary Item Box

Raised when the properties of the report's data source are modified.

Syntax

Visual Basic (Declaration)
Public Event DataSourceChanged As EventHandler
C#
public event EventHandler DataSourceChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataSource Property


FetchData Event

[image]
ActiveReports 13
FetchData Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : FetchData Event

Glossary Item Box

Raised every time a new record is processed.

Syntax

Visual Basic (Declaration)
Public Event FetchData As SectionReport.FetchEventHandler
C#
public event SectionReport.FetchEventHandler FetchData

Event Data

The event handler receives an argument of type SectionReport.FetchEventArgs containing data related to this event. The following SectionReport.FetchEventArgs properties provide information specific to this event.

Property | Description
EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.

Remarks

This event is used to set the values of custom unbound fields that were added in the DataInitialize event.

ActiveReports does not null unbound field values before firing this event. The unbound field value is carried over so you should always set the values of all unbound fields in this event.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
DataInitialize Event

Concepts

Unbound Reporting
Sequence of Events


LocateCredentials Event

[image]
ActiveReports 13
LocateCredentials Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LocateCredentials Event

Glossary Item Box

Occurs when the report needs to obtain data source credentials from the calling application.

Syntax

Visual Basic (Declaration)
Public Event LocateCredentials As LocateCredentialsEventHandler
C#
public event LocateCredentialsEventHandler LocateCredentials

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


NoData Event

[image]
ActiveReports 13
NoData Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : NoData Event

Glossary Item Box

Raised if the report's data source does not return any records and there is no data to be processed.

Syntax

Visual Basic (Declaration)
Public Event NoData As EventHandler
C#
public event EventHandler NoData

Remarks

This event is used either to cancel the report or to print a page with a message informing the user that the report did not return any records to print.

Example

C# Copy Code
private void SectionReport1_NoData(object sender, System.EventArgs eArgs)
{
    this.Cancel();
}
Visual Basic Copy Code
Private Sub SectionReport1_NoData(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.NoData
    Me.Cancel()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageEnd Event

[image]
ActiveReports 13
PageEnd Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageEnd Event

Glossary Item Box

Raised after the report finishes rendering each page.

Syntax

Visual Basic (Declaration)
Public Event PageEnd As EventHandler
C#
public event EventHandler PageEnd

Remarks

This event is used to update any page level variables when running an unbound report.

Example

C# Copy Code
private void rptTest_PageEnd(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawText("Confidential", 4F,10F,2F,0.188F);
}
Visual Basic Copy Code
Private Sub rptDocument_PageEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageEnd
    Me.CurrentPage.DrawText("Confidential", 4.0F, 10.0F, 2.0F, 0.188F)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


PageStart Event

[image]
ActiveReports 13
PageStart Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageStart Event

Glossary Item Box

Raised before the report renders any output to a new page.

Syntax

Visual Basic (Declaration)
Public Event PageStart As EventHandler
C#
public event EventHandler PageStart

Remarks

This event is used to initialize any page-level variables when running an unbound report.

Example

C# Copy Code
bool bSwitch;
private void SectionReport1_PageStart(object sender, System.EventArgs eArgs)
{
    if (bSwitch == true)
    {
        this.PrintWidth = 6.5F;
        this.Document.Printer.Landscape = false;
    }
}
Visual Basic Copy Code
' boolean to keep track of which orientation to use
Dim bSwitch As Boolean

Private Sub rptMain_PageStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageStart
    If bSwitch = True Then
        Me.PrintWidth = 6.5
        Me.Document.Printer.Landscape = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


ParameterUIClosed Event

[image]
ActiveReports 13
ParameterUIClosed Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ParameterUIClosed Event

Glossary Item Box

Raised after the user closes the query parameters dialog.

Syntax

Visual Basic (Declaration)
Public Event ParameterUIClosed As SectionReport.ParameterUIClosedHandler
C#
public event SectionReport.ParameterUIClosedHandler ParameterUIClosed

Example

C# Copy Code
private void SectionReport1_ParameterUIClosed(object sender, bool Cancelled)
{
    System.Windows.Forms.MessageBox.Show ("Parameters sent.");
}
Visual Basic Copy Code
Private Sub SectionReport1_ParameterUIClosed(ByVal sender As Object, ByVal cancelled As Boolean) Handles MyBase.ParameterUIClosed
    MessageBox.Show("Parameters set.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
ShowParameterUI Property


PrintAborted Event

[image]
ActiveReports 13
PrintAborted Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintAborted Event

Glossary Item Box

Raised when the user cancels a print job.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As EventHandler
C#
public event EventHandler PrintAborted

Example

C# Copy Code
private void SectionReport1_PrintAborted(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show("Printing has been aborted.");
}
Visual Basic Copy Code
Private Sub SectionReport1_PrintAborted(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PrintAborted
    MessageBox.Show("Printing has been aborted.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
PrintProgress Event


PrintProgress Event

[image]
ActiveReports 13
PrintProgress Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintProgress Event

Glossary Item Box

Raised for each page while printing the report document.

Syntax

Visual Basic (Declaration)
Public Event PrintProgress As EventHandler
C#
public event EventHandler PrintProgress

Example

This sample assumes that you have created a public property in the report and passed in a reference to the calling form. You can also use this technique to set the title bar text on the form window.
C# Copy Code
private int x = 0;
private void testLA_PrintProgress(object sender, System.EventArgs eArgs)
{
    //Print Progress is triggered once per page printed.
    myWinForm.Label1.Text = "Now Printing Page " + x;
    x++;
}
Visual Basic Copy Code
Private x As Integer = 0
Private Sub SectionReport1_PrintProgress(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PrintProgress
    myWinForm.Label1.Text = "Now Printing Page " + x
    x = x + 1
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members
PrintAborted Event


ReportEnd Event

[image]
ActiveReports 13
ReportEnd Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ReportEnd Event

Glossary Item Box

Raised after the report finishes processing all pages.

Syntax

Visual Basic (Declaration)
Public Event ReportEnd As EventHandler
C#
public event EventHandler ReportEnd

Remarks

This event can be used to close or free any objects that you were using while running a report in unbound mode, or to display an information message to the end user.

Example

C# Copy Code
private void rptMain_ReportEnd(object sender, System.EventArgs eArgs)
{
    rptBookmarks rpt = new rptBookmarks();
    rpt.pBM = this.Document.Bookmarks;
    rpt.Run();
    this.Document.Pages.InsertRange(this.Document.Pages.Count, rpt.Document.Pages);
}
Visual Basic Copy Code
Private Sub rptMain_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
        Dim rpt As New rptBookmarks()
        rpt.pBM = Me.Document.Bookmarks
        rpt.Run()
        Me.Document.Pages.InsertRange(Me.Document.Pages.Count, rpt.Document.Pages)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


ReportStart Event

[image]
ActiveReports 13
ReportStart Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ReportStart Event

Glossary Item Box

Raised before a report starts processing.

Syntax

Visual Basic (Declaration)
Public Event ReportStart As EventHandler
C#
public event EventHandler ReportStart

Remarks

This event can be used to initialize any objects or variables that are needed while running a report.

Note: Printer values are set after this event is raised. The values that will be applied to the Printer object are in the PageSettings object. ReportStart is the event in which you can modify these values in the PageSettings object before they are applied to the Printer object.

Example

C# Copy Code
private void rptUnbound_ReportStart(object sender, System.EventArgs eArgs)
{
    string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[UserName]\Documents\GrapeCity Samples\ActiveReports 9\Data\NWIND.MDB;Persist Security Info=False";
    string sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY products.categoryid, products.productid";
    m_cnn = new OleDbConnection(m_cnnString);
    OleDbCommand m_Cmd = new OleDbCommand(sqlString,m_cnn);
    if(m_cnn.State == ConnectionState.Closed)
    {
        m_cnn.Open();
    }
        m_reader = m_Cmd.ExecuteReader();
}
Visual Basic Copy Code
Dim m_cnnString As String
Dim sqlString As String
Dim m_reader As OleDbDataReader
Dim m_cnn As OleDbConnection
Private Sub rptUnbound_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) _
    Handles MyBase.ReportStart
    m_cnnString =  "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[UserName]\Documents\GrapeCity Samples\ActiveReports 9\Data\NWIND.MDB;Persist Security Info=False"
    sqlString = "Select * FROM categories INNER JOIN products On categories.categoryid _
        = products.categoryid ORDER BY products.categoryid, products.productid"
    m_cnn = New OleDb.OleDbConnection(m_cnnString)
    Dim m_Cmd As New OleDb.OleDbCommand(sqlString, m_cnn)
    If m_cnn.State = ConnectionState.Closed Then
        m_cnn.Open()
    End If
    m_reader = m_Cmd.ExecuteReader()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members

Concepts

Unbound Reporting


SectionReport.FetchEventArgs Class

[image]
ActiveReports 13
SectionReport.FetchEventArgs Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

Glossary Item Box

FetchEventArgs class provides data required for the FetchData Event.

Object Model

SectionReport.FetchEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SectionReport.FetchEventArgs
   Inherits System.EventArgs
C#
public class SectionReport.FetchEventArgs : System.EventArgs

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.SectionReport.FetchEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventArgs Members
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


SectionReport.FetchEventArgs Class Members

[image]
ActiveReports 13
SectionReport.FetchEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

Glossary Item Box

The following tables list the members exposed by SectionReport.FetchEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SectionReport.FetchEventArgs Constructor | Creates a new SectionReport.FetchEventArgs instance.
Top

Public Properties

 | Name | Description
Public Property | EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.
Top

See Also

Reference

SectionReport.FetchEventArgs Class
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


SectionReport.FetchEventArgs Constructor

[image]
ActiveReports 13
SectionReport.FetchEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport.FetchEventArgs Class : SectionReport.FetchEventArgs Constructor

eof
End Of Fields as a Boolean value.

Glossary Item Box

Creates a new SectionReport.FetchEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal eof As Boolean _
)
C#
public SectionReport.FetchEventArgs(
   bool eof
)

Parameters

eof
End Of Fields as a Boolean value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventArgs Class
SectionReport.FetchEventArgs Members


SectionReport.FetchEventArgs Class Properties

[image]
ActiveReports 13
SectionReport.FetchEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

Glossary Item Box

For a list of all members of this type, see SectionReport.FetchEventArgs members.

Public Properties

 | Name | Description
Public Property | EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.
Top

See Also

Reference

SectionReport.FetchEventArgs Class
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


EOF Property

[image]
ActiveReports 13
EOF Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport.FetchEventArgs Class : EOF Property

Glossary Item Box

This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.

Syntax

Visual Basic (Declaration)
Public Property EOF As Boolean
C#
public bool EOF {get; set;}

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventArgs Class
SectionReport.FetchEventArgs Members


SystemPrinter Class

[image]
ActiveReports 13
SystemPrinter Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class

Glossary Item Box

Represents the settings of the SystemPrinter class.

Object Model

SystemPrinter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SystemPrinter
C#
public sealed class SystemPrinter

Remarks

Allows the developer to manually control report printing.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SystemPrinter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Members
GrapeCity.ActiveReports Namespace


SystemPrinter Class Members

[image]
ActiveReports 13
SystemPrinter Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class

Glossary Item Box

The following tables list the members exposed by SystemPrinter.

Public Constructors

 | Name | Description
Public Constructor | SystemPrinter Constructor | Initializes a new instance of the SystemPrinter class.
Top

Public Properties

 | Name | Description
Public Property | CanDuplex | Determines whether or not the report can be duplexed while printing.
Public Property | Collate | Determines whether all the pages of the report should be printed before another copy of the report.
Public Property | Color | Determines whether or not the report will print in color.
Public Property | Copies | Determines the number of copies to print.
Public Property | DpiX | Gets the horizontal resolution of the SystemPrinter object.
Public Property | DpiY | Gets the vertical resolution of the SystemPrinter object.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | FileName | Gets or sets the file name used to print to a file.
Public Property | FromPage | Sets the starting page in a print job.
Public Property | Graphics | Draws the page to the printer.
Public Property | Landscape | Determines whether or not the report will be landscaped for printing.
Public Property | MaxPage | Sets the total page count in the progress dialog when doing custom printing.
Public Property | PaperHeight | Gets or sets the paper height for printing.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSizes | Returns a reference to the collection of paper sizes the printer supports.
Public Property | PaperSource | Gets or sets the paper source for the page.
Public Property | PaperSources | Returns a reference to the collection of paper sources the printer supports.
Public Property | PaperWidth | Sets or returns the width of the paper used to print the report.
Public Property | PhysicalOffsetX | Returns the measurement in pixels of the non-printable section on the left side of the page.
Public Property | PhysicalOffsetY | Returns the measurement in pixels of the non-printable section at the top of the page.
Public Property | Port | Gets or sets the current printer port.
Public Property | Ports | Returns the collection of printer ports available.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterNames | Returns the collection of printer names available.
Public Property | PrinterResolution | Gets or sets the printer resolution for the page.
Public Property | PrinterResolutions | Returns a collection of the available printer resolutions.
Public Property | PrinterSettings | Gets or sets the printer settings associated with the page.
Public Property | ToPage | Sets the number of the last page to be printed.
Top

Public Methods

 | Name | Description
Public Method | AbortJob | Aborts the SystemPrinter print job initialized by the StartJob method.
Public Method | EndJob | Ends the SystemPrinter print job initialized by the StartJob method.
Public Method | EndPage | Ends a specific page in a SystemPrinter print job initialized by the StartPage method.
Public Method | Escape | Allows escape codes to be entered.
Public Method | PrintDialog | Shows a SystemPrinter print dialog.
Public Method | SetupDialog | Shows a SystemPrinter setup dialog.
Public Method | StartJob | Starts a SystemPrinter print job.
Public Method | StartPage | Starts a specific page in a SystemPrinter print job.
Top

See Also

Reference

SystemPrinter Class
GrapeCity.ActiveReports Namespace


SystemPrinter Constructor

[image]
ActiveReports 13
SystemPrinter Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : SystemPrinter Constructor

Glossary Item Box

Initializes a new instance of the SystemPrinter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SystemPrinter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


SystemPrinter Class Methods

[image]
ActiveReports 13
SystemPrinter Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class

Glossary Item Box

For a list of all members of this type, see SystemPrinter members.

Public Methods

 | Name | Description
Public Method | AbortJob | Aborts the SystemPrinter print job initialized by the StartJob method.
Public Method | EndJob | Ends the SystemPrinter print job initialized by the StartJob method.
Public Method | EndPage | Ends a specific page in a SystemPrinter print job initialized by the StartPage method.
Public Method | Escape | Allows escape codes to be entered.
Public Method | PrintDialog | Shows a SystemPrinter print dialog.
Public Method | SetupDialog | Shows a SystemPrinter setup dialog.
Public Method | StartJob | Starts a SystemPrinter print job.
Public Method | StartPage | Starts a specific page in a SystemPrinter print job.
Top

See Also

Reference

SystemPrinter Class
GrapeCity.ActiveReports Namespace


AbortJob Method

[image]
ActiveReports 13
AbortJob Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : AbortJob Method

Glossary Item Box

Aborts the SystemPrinter print job initialized by the StartJob method.

Syntax

Visual Basic (Declaration)
Public Sub AbortJob()
C#
public void AbortJob()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


EndJob Method

[image]
ActiveReports 13
EndJob Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : EndJob Method

Glossary Item Box

Ends the SystemPrinter print job initialized by the StartJob method.

Syntax

Visual Basic (Declaration)
Public Sub EndJob()
C#
public void EndJob()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


EndPage Method

[image]
ActiveReports 13
EndPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : EndPage Method

Glossary Item Box

Ends a specific page in a SystemPrinter print job initialized by the StartPage method.

Syntax

Visual Basic (Declaration)
Public Sub EndPage()
C#
public void EndPage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Escape Method

[image]
ActiveReports 13
Escape Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Escape Method

code
The escape code being entered.

Glossary Item Box

Allows escape codes to be entered.

Syntax

Visual Basic (Declaration)
Public Sub Escape( _
   ByVal code As String _
)
C#
public void Escape(
   string code
)

Parameters

code
The escape code being entered.

Remarks

Escape codes are specific to the printer being used. For a list of escape codes, see the documentation for the printer.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    if((openFileDialog1.ShowDialog(this) == DialogResult.OK))
    {
        this.viewer1.Document.Password = "Test";
        viewer1.Document.Load(openFileDialog1.OpenFile());
        Escape("&1 OH"); //page eject code for certain printer (see manual for printer's sequences)
    }
}

public void Escape(string code)
{
    //code is the escape sequence from the printer's manual
    m_myARPrinter.StartJob("Test Printer");
    m_myARPrinter.Graphics.PageUnit = GraphicsUnit.Pixel;

    GrapeCity.ActiveReports.Document.Section.Page aPage;
    int nCount;
    nCount = this.viewer1.Document.Pages.Count;
    RectangleF rcPage;
    rcPage = RectangleF.Empty;
    for (int i = 0; i <= nCount - 1; i++)
    {
        m_myARPrinter.Escape(code);
        m_myARPrinter.StartPage();
        aPage = viewer1.Document.Pages[i];
        aPage.Units = GrapeCity.ActiveReports.Document.Section.Units.Pixels;
        rcPage.Width = aPage.Width;
        rcPage.Height = aPage.Height;
        aPage.Draw(m_myARPrinter.Graphics, rcPage);
        m_myARPrinter.EndPage();
    }
    m_myARPrinter.EndJob();
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If (OpenFileDialog.ShowDialog(Me) = DialogResult.OK) Then
        Viewer1.Document.Password = "Test"
        Viewer1.Document.Load(OpenFileDialog.OpenFile())
        Escape("&l  0H") 'page eject code for certain printer (see manual for printer's sequences)
    End If
End Sub

Public Sub Escape(ByVal code As String) 'code is the escape sequence from the printer's manual
    m_myARPrinter.StartJob("Test Printer")
    m_myARPrinter.Graphics.PageUnit = GraphicsUnit.Pixel

    Dim aPage As GrapeCity.ActiveReports.Document.Section.Page
    Dim nCount As Integer
    nCount = Viewer1.Document.Pages.Count
    Dim rcPage As RectangleF
    rcPage = RectangleF.Empty
    For int i = 0 To nCount - 1
        m_myARPrinter.Escape(code)
        m_myARPrinter.StartPage()
        aPage = Viewer1.Document.Pages(i)
        aPage.Units = GrapeCity.ActiveReports.Document.Section.Units.Pixels
        rcPage.Width = aPage.Width
        rcPage.Height = aPage.Height
        aPage.Draw(m_myARPrinter.Graphics, rcPage)
        m_myARPrinter.EndPage()
    Next
    m_myARPrinter.EndJob()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrintDialog Method

[image]
ActiveReports 13
PrintDialog Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrintDialog Method

Glossary Item Box

Shows a SystemPrinter print dialog.

Syntax

Visual Basic (Declaration)
Public Function PrintDialog() As DialogResult
C#
public DialogResult PrintDialog()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


SetupDialog Method

[image]
ActiveReports 13
SetupDialog Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : SetupDialog Method

Glossary Item Box

Shows a SystemPrinter setup dialog.

Syntax

Visual Basic (Declaration)
Public Sub SetupDialog()
C#
public void SetupDialog()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


StartJob Method

[image]
ActiveReports 13
StartJob Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : StartJob Method

printJob
The job being printed.

Glossary Item Box

Starts a SystemPrinter print job.

Syntax

Visual Basic (Declaration)
Public Sub StartJob( _
   ByVal printJob As String _
)
C#
public void StartJob(
   string printJob
)

Parameters

printJob
The job being printed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


StartPage Method

[image]
ActiveReports 13
StartPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : StartPage Method

Glossary Item Box

Starts a specific page in a SystemPrinter print job.

Syntax

Visual Basic (Declaration)
Public Sub StartPage()
C#
public void StartPage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


SystemPrinter Class Properties

[image]
ActiveReports 13
SystemPrinter Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class

Glossary Item Box

For a list of all members of this type, see SystemPrinter members.

Public Properties

 | Name | Description
Public Property | CanDuplex | Determines whether or not the report can be duplexed while printing.
Public Property | Collate | Determines whether all the pages of the report should be printed before another copy of the report.
Public Property | Color | Determines whether or not the report will print in color.
Public Property | Copies | Determines the number of copies to print.
Public Property | DpiX | Gets the horizontal resolution of the SystemPrinter object.
Public Property | DpiY | Gets the vertical resolution of the SystemPrinter object.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | FileName | Gets or sets the file name used to print to a file.
Public Property | FromPage | Sets the starting page in a print job.
Public Property | Graphics | Draws the page to the printer.
Public Property | Landscape | Determines whether or not the report will be landscaped for printing.
Public Property | MaxPage | Sets the total page count in the progress dialog when doing custom printing.
Public Property | PaperHeight | Gets or sets the paper height for printing.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSizes | Returns a reference to the collection of paper sizes the printer supports.
Public Property | PaperSource | Gets or sets the paper source for the page.
Public Property | PaperSources | Returns a reference to the collection of paper sources the printer supports.
Public Property | PaperWidth | Sets or returns the width of the paper used to print the report.
Public Property | PhysicalOffsetX | Returns the measurement in pixels of the non-printable section on the left side of the page.
Public Property | PhysicalOffsetY | Returns the measurement in pixels of the non-printable section at the top of the page.
Public Property | Port | Gets or sets the current printer port.
Public Property | Ports | Returns the collection of printer ports available.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterNames | Returns the collection of printer names available.
Public Property | PrinterResolution | Gets or sets the printer resolution for the page.
Public Property | PrinterResolutions | Returns a collection of the available printer resolutions.
Public Property | PrinterSettings | Gets or sets the printer settings associated with the page.
Public Property | ToPage | Sets the number of the last page to be printed.
Top

See Also

Reference

SystemPrinter Class
GrapeCity.ActiveReports Namespace


CanDuplex Property

[image]
ActiveReports 13
CanDuplex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : CanDuplex Property

Glossary Item Box

Determines whether or not the report can be duplexed while printing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanDuplex As Boolean
C#
public bool CanDuplex {get;}

Property Value

Boolean value. True, if the report can be duplexed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Collate Property

[image]
ActiveReports 13
Collate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Collate Property

Glossary Item Box

Determines whether all the pages of the report should be printed before another copy of the report.

Syntax

Visual Basic (Declaration)
Public Property Collate As Boolean
C#
public bool Collate {get; set;}

Property Value

A Boolean value. True if a complete copy of the report should be printed before another copy begins printing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Color Property

[image]
ActiveReports 13
Color Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Color Property

Glossary Item Box

Determines whether or not the report will print in color.

Syntax

Visual Basic (Declaration)
Public Property Color As Boolean
C#
public bool Color {get; set;}

Property Value

Boolean value. True, if the report will print in color; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Copies Property

[image]
ActiveReports 13
Copies Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Copies Property

Glossary Item Box

Determines the number of copies to print.

Syntax

Visual Basic (Declaration)
Public Property Copies As Short
C#
public short Copies {get; set;}

Property Value

Short value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


DpiX Property

[image]
ActiveReports 13
DpiX Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : DpiX Property

Glossary Item Box

Gets the horizontal resolution of the SystemPrinter object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DpiX As Integer
C#
public int DpiX {get;}

Property Value

An integer value in pixels.

Remarks

Read only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


DpiY Property

[image]
ActiveReports 13
DpiY Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : DpiY Property

Glossary Item Box

Gets the vertical resolution of the SystemPrinter object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DpiY As Integer
C#
public int DpiY {get;}

Property Value

An integer value in pixels.

Remarks

Read only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Duplex Property

[image]
ActiveReports 13
Duplex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Duplex Property

Glossary Item Box

Gets or sets the report document setting for double-sided printing.

Syntax

Visual Basic (Declaration)
Public Property Duplex As Duplex
C#
public Duplex Duplex {get; set;}

Property Value

A System.Drawing.Duplex enumeration value. Default is determined by System.Drawing.Printing.Duplex.Default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


FileName Property

[image]
ActiveReports 13
FileName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : FileName Property

Glossary Item Box

Gets or sets the file name used to print to a file.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


FromPage Property

[image]
ActiveReports 13
FromPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : FromPage Property

Glossary Item Box

Sets the starting page in a print job.

Syntax

Visual Basic (Declaration)
Public Property FromPage As Integer
C#
public int FromPage {get; set;}

Property Value

Long value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Graphics Property

[image]
ActiveReports 13
Graphics Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Graphics Property

Glossary Item Box

Draws the page to the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Graphics As Graphics
C#
public Graphics Graphics {get;}

Remarks

This property is valid only after the StartJob event is called.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Landscape Property

[image]
ActiveReports 13
Landscape Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Landscape Property

Glossary Item Box

Determines whether or not the report will be landscaped for printing.

Syntax

Visual Basic (Declaration)
Public Property Landscape As Boolean
C#
public bool Landscape {get; set;}

Property Value

Boolean value. True, if the report will be landscaped; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


MaxPage Property

[image]
ActiveReports 13
MaxPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : MaxPage Property

Glossary Item Box

Sets the total page count in the progress dialog when doing custom printing.

Syntax

Visual Basic (Declaration)
Public Property MaxPage As Integer
C#
public int MaxPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperHeight Property

[image]
ActiveReports 13
PaperHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperHeight Property

Glossary Item Box

Gets or sets the paper height for printing.

Syntax

Visual Basic (Declaration)
Public Property PaperHeight As Single
C#
public float PaperHeight {get; set;}

Property Value

A float or Single value in inches.

Remarks

This property is used to set custom paper sizes that might not be available in the PaperSizes collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSize Property

[image]
ActiveReports 13
PaperSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSize Property

Glossary Item Box

Gets or sets the paper size for the page.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As PaperSize
C#
public PaperSize PaperSize {get; set;}

Property Value

System.Drawing.Printing.PaperSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSizes Property

[image]
ActiveReports 13
PaperSizes Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSizes Property

Glossary Item Box

Returns a reference to the collection of paper sizes the printer supports.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperSizes As PrinterSettings.PaperSizeCollection
C#
public PrinterSettings.PaperSizeCollection PaperSizes {get;}

Remarks

Read only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSource Property

[image]
ActiveReports 13
PaperSource Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSource Property

Glossary Item Box

Gets or sets the paper source for the page.

Syntax

Visual Basic (Declaration)
Public Property PaperSource As PaperSource
C#
public PaperSource PaperSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSources Property

[image]
ActiveReports 13
PaperSources Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSources Property

Glossary Item Box

Returns a reference to the collection of paper sources the printer supports.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperSources As PrinterSettings.PaperSourceCollection
C#
public PrinterSettings.PaperSourceCollection PaperSources {get;}

Remarks

Read only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperWidth Property

[image]
ActiveReports 13
PaperWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperWidth Property

Glossary Item Box

Sets or returns the width of the paper used to print the report.

Syntax

Visual Basic (Declaration)
Public Property PaperWidth As Single
C#
public float PaperWidth {get; set;}

Property Value

A float or Single value in inches.

Remarks

This property is used to set custom paper sizes that might not be available in the PaperSizes collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PhysicalOffsetX Property

[image]
ActiveReports 13
PhysicalOffsetX Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PhysicalOffsetX Property

Glossary Item Box

Returns the measurement in pixels of the non-printable section on the left side of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PhysicalOffsetX As Long
C#
public long PhysicalOffsetX {get;}

Property Value

An integer value in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PhysicalOffsetY Property

[image]
ActiveReports 13
PhysicalOffsetY Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PhysicalOffsetY Property

Glossary Item Box

Returns the measurement in pixels of the non-printable section at the top of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PhysicalOffsetY As Long
C#
public long PhysicalOffsetY {get;}

Property Value

An integer value in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Port Property

[image]
ActiveReports 13
Port Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Port Property

Glossary Item Box

Gets or sets the current printer port.

Syntax

Visual Basic (Declaration)
Public Property Port As String
C#
public string Port {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


Ports Property

[image]
ActiveReports 13
Ports Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Ports Property

Glossary Item Box

Returns the collection of printer ports available.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ports As StringCollection
C#
public StringCollection Ports {get;}

Remarks

Read only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterName Property

[image]
ActiveReports 13
PrinterName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterName Property

Glossary Item Box

Gets or sets the name of the printer to use.

Syntax

Visual Basic (Declaration)
Public Property PrinterName As String
C#
public string PrinterName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterNames Property

[image]
ActiveReports 13
PrinterNames Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterNames Property

Glossary Item Box

Returns the collection of printer names available.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrinterNames As PrinterSettings.StringCollection
C#
public PrinterSettings.StringCollection PrinterNames {get;}

Remarks

Read only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterResolution Property

[image]
ActiveReports 13
PrinterResolution Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterResolution Property

Glossary Item Box

Gets or sets the printer resolution for the page.

Syntax

Visual Basic (Declaration)
Public Property PrinterResolution As PrinterResolution
C#
public PrinterResolution PrinterResolution {get; set;}

Property Value

System.Drawing.Printing.PrinterResolution

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterResolutions Property

[image]
ActiveReports 13
PrinterResolutions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterResolutions Property

Glossary Item Box

Returns a collection of the available printer resolutions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrinterResolutions As PrinterSettings.PrinterResolutionCollection
C#
public PrinterSettings.PrinterResolutionCollection PrinterResolutions {get;}

Remarks

Read only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterSettings Property

[image]
ActiveReports 13
PrinterSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterSettings Property

Glossary Item Box

Gets or sets the printer settings associated with the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrinterSettings As PrinterSettings
C#
public PrinterSettings PrinterSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


ToPage Property

[image]
ActiveReports 13
ToPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : ToPage Property

Glossary Item Box

Sets the number of the last page to be printed.

Syntax

Visual Basic (Declaration)
Public Property ToPage As Integer
C#
public int ToPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SystemPrinter Class
SystemPrinter Members


LayoutAction Enumeration

[image]
ActiveReports 13
LayoutAction Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LayoutAction Enumeration

Glossary Item Box

Specifies the action to be performed after a section is formatted.

Syntax

Visual Basic (Declaration)
Public Enum LayoutAction
   Inherits System.Enum
C#
public enum LayoutAction : System.Enum

Members

Member | Description
MoveLayout | The layout position will move to the next printing location on the page.
NextRecord | The data navigation will advance to the next record.
PrintSection | The section will be printed.

Remarks

The following table shows the results for setting different LayoutAction combinations.

PrintSection | MoveLayout | NextRecord | (Default) Move to the next print location, get the next record, and print data.
PrintSection | MoveLayout | Move to the next print location, don't advance to the next record, but print the data (repeats the same record).
NextRecord | Skip a record without leaving a blank space on the page.
MoveLayout | NextRecord | Skip a record and leave a blank space on the page.
MoveLayout | Leave a blank space without skipping a record.
PrintSection | NextRecord | Print the next record on top of the current record (UnderlayNext).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.LayoutAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports~GrapeCity.ActiveReports~LayoutAction


PageSettings.PrinterCollate Enumeration

[image]
ActiveReports 13
PageSettings.PrinterCollate Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageSettings.PrinterCollate Enumeration

Glossary Item Box

Determines the collation order when printing multiple copies of a report.

Syntax

Visual Basic (Declaration)
Public Enum PageSettings.PrinterCollate
   Inherits System.Enum
C#
public enum PageSettings.PrinterCollate : System.Enum

Members

Member | Description
Collate | Print a complete copy of the document before starting another copy.
Default | Use the current printer collate settings.
DontCollate | Prints each page by the number of the copies specified before printing the next page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageSettings.PrinterCollate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace
Collate Property


ReportProcessingError Enumeration

[image]
ActiveReports 13
ReportProcessingError Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportProcessingError Enumeration

Glossary Item Box

Describe possible error codes for future detail processing of the error.

Syntax

Visual Basic (Declaration)
Public Enum ReportProcessingError
   Inherits System.Enum
C#
public enum ReportProcessingError : System.Enum

Members

Member | Description
BlankValueAssignedToNonBlankParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
CommandTextNotBeenSet | Command is empty.
CyclicParameter | Cyclic dependencies in parameters: ReportException.ErrorData provides name of the parameter.
DataSetNotFound | Specified data set is not found.
DataSetNotSpecified | Not specified shared data set.
InfinitePages | Internal loop in pages processing observed.
InternalError | Just internal error.
InvalidData | Invalid data or cannot access to date with current configuration.
InvalidDataTypeForParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
InvalidKeyInConnectionString | Invalid key in connection string
InvalidQueryParameters | Cannot parse/process data set query parameters.
InvalidReport | Something wrong in report structure.
InvalidSharedDataSource | No assess to shared data source: ReportException.ErrorData provides name of the data source.
InvalidTheme | Invalid theme was specified.
JsonSchemaNotAvailableOrInvalid | Json schema specified in connection string of JSON data provider is not available or invalid.
NoDataSets | Not specified shared data set.
NoMasterReport | No master report was found.
NoPermission | DB assess error.
NullValueAssignedToNonNullableParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ParameterNotValidated | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ParameterValueIsNotValid | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ScriptCompilationFailed | Describe script compilation problem: ReportException.ErrorData provides errors array.
ScriptError | Describe script execution problem.
SubreportNotFound | No subreport was found.
UnableToCreateConnection | Can not connect to data source.
UnexpectedCharacterWhileParsingPath | Unexpected character while parsing path.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ReportProcessingError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace


SectionReport.ReportState Enumeration

[image]
ActiveReports 13
SectionReport.ReportState Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.ReportState Enumeration

Glossary Item Box

Determines the current state of the report engine.

Syntax

Visual Basic (Declaration)
Public Enum SectionReport.ReportState
   Inherits System.Enum
C#
public enum SectionReport.ReportState : System.Enum

Members

Member | Description
Completed | The report processing is complete.
Idle | The report processing is idle.
InProgress | The report is currently being processed to create a document.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReport.ReportState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel~State


SectionReport.RpxFormat Enumeration

[image]
ActiveReports 13
SectionReport.RpxFormat Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.RpxFormat Enumeration

Glossary Item Box

Specifies the format in which the report is to be saved.

Syntax

Visual Basic (Declaration)
Public Enum SectionReport.RpxFormat
   Inherits System.Enum
C#
public enum SectionReport.RpxFormat : System.Enum

Members

Member | Description
Arnet | Saves the layout as a standard RPX file. Items in the component tray are not saved.
Arnet3 | Allows for the components in the component tray to be saved in the RPX file.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReport.RpxFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace


LocateCredentialsEventHandler Delegate

[image]
ActiveReports 13
LocateCredentialsEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventHandler Delegate

sender
The source of the event.
args
LocateCredentials object that contains event data.

Glossary Item Box

Represents method that handles LocateCredentials event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LocateCredentialsEventHandler( _
   ByVal sender As Object, _
   ByVal args As LocateCredentialsEventArgs _
)
C#
public delegate void LocateCredentialsEventHandler(
   object sender,
   LocateCredentialsEventArgs args
)

Parameters

sender
The source of the event.
args
LocateCredentials object that contains event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateCredentialsEventHandler Members
GrapeCity.ActiveReports Namespace


LocateDataSourceEventHandler Delegate

[image]
ActiveReports 13
LocateDataSourceEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventHandler Delegate

sender
The sender of the event.
args
The LocateDataSourceEventArgs that contains the LocateDataSource event class.

Glossary Item Box

Represents the method that will handle the LocateDataSource event

Syntax

Visual Basic (Declaration)
Public Delegate Sub LocateDataSourceEventHandler( _
   ByVal sender As Object, _
   ByVal args As LocateDataSourceEventArgs _
)
C#
public delegate void LocateDataSourceEventHandler(
   object sender,
   LocateDataSourceEventArgs args
)

Parameters

sender
The sender of the event.
args
The LocateDataSourceEventArgs that contains the LocateDataSource event class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocateDataSourceEventHandler Members
GrapeCity.ActiveReports Namespace


SectionReport.FetchEventHandler Delegate

[image]
ActiveReports 13
SectionReport.FetchEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventHandler Delegate

sender
The source of the event.
eArgs
FetchEventArgs that contains the event data

Glossary Item Box

Represents the method that handles the FetchData event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SectionReport.FetchEventHandler( _
   ByVal sender As Object, _
   ByVal eArgs As SectionReport.FetchEventArgs _
)
C#
public delegate void SectionReport.FetchEventHandler(
   object sender,
   SectionReport.FetchEventArgs eArgs
)

Parameters

sender
The source of the event.
eArgs
FetchEventArgs that contains the event data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.FetchEventHandler Members
GrapeCity.ActiveReports Namespace


SectionReport.ParameterUIClosedHandler Delegate

[image]
ActiveReports 13
SectionReport.ParameterUIClosedHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : SectionReport.ParameterUIClosedHandler Delegate

sender
The source of the event.
cancelled
Value indicates whether the parameters dialog was closed by using Cancel button.

Glossary Item Box

Represents a method that handles the ParameterUIClosed event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SectionReport.ParameterUIClosedHandler( _
   ByVal sender As Object, _
   ByVal cancelled As Boolean _
)
C#
public delegate void SectionReport.ParameterUIClosedHandler(
   object sender,
   bool cancelled
)

Parameters

sender
The source of the event.
cancelled
Value indicates whether the parameters dialog was closed by using Cancel button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport.ParameterUIClosedHandler Members
GrapeCity.ActiveReports Namespace


GrapeCity.ActiveReports.Configuration Namespace

GrapeCity.ActiveReports.Configuration Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Configuration Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Configuration namespace consists of classes that configure the report.

Classes

 | Class | Description
Class | CustomDesignerConfigurationDictionary | Represents a dictionary of custom designers configured for components.
Class | DefaultConfigurationProvider | Implements an IConfigurationProvider that gets configuration information from a file in the executable directory.
Class | PropertyElement | Represents a property configuration option for the associated export extension.
Class | RenderingExtensionInfo | Class containing rendering extension information.
Class | RenderingExtensionInfoCollection | Represents a collection of RenderingExtensionInfo.
Class | ReportItemsConfigurationDictionary | A dictionary of CustomReportItem type names and their corresponding System.Type.
Class | ToolboxItemConfig | Represents an entry for a toolbox configuration item.

Interfaces

 | Interface | Description
Interface | IConfigurationManager | Defines an interface to allow access to configuration information.
Interface | IConfigurationProvider | Defines interface for providing raw configuration information.

Delegates

 | Delegate | Description
Delegate | RenderingExtensionInfoCollection.ContentChangedEventHandler | Represents the method that processes the ContentChanged event.

See Also

Reference

GrapeCity.ActiveReports Assembly


CustomDesignerConfigurationDictionary Class

[image]
ActiveReports 13
CustomDesignerConfigurationDictionary Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

Glossary Item Box

Represents a dictionary of custom designers configured for components.

Object Model

CustomDesignerConfigurationDictionary Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomDesignerConfigurationDictionary
C#
public sealed class CustomDesignerConfigurationDictionary

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.CustomDesignerConfigurationDictionary

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Members
GrapeCity.ActiveReports.Configuration Namespace


CustomDesignerConfigurationDictionary Class Members

[image]
ActiveReports 13
CustomDesignerConfigurationDictionary Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

Glossary Item Box

The following tables list the members exposed by CustomDesignerConfigurationDictionary.

Public Constructors

 | Name | Description
Public Constructor | CustomDesignerConfigurationDictionary Constructor | Initializes a new instance of CustomDesignerConfigurationDictionary class.
Top

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForDesigner | Gets the CustomReportItem.Type value associated with the specified designer.
Public Method | GetDesignerForCustomTypeName | Returns the System.Type of the custom designer configured for the specified component type or null.
Top

See Also

Reference

CustomDesignerConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


CustomDesignerConfigurationDictionary Constructor

[image]
ActiveReports 13
CustomDesignerConfigurationDictionary Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : CustomDesignerConfigurationDictionary Constructor

Glossary Item Box

Initializes a new instance of CustomDesignerConfigurationDictionary class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomDesignerConfigurationDictionary()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


CustomDesignerConfigurationDictionary Class Methods

[image]
ActiveReports 13
CustomDesignerConfigurationDictionary Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

Glossary Item Box

For a list of all members of this type, see CustomDesignerConfigurationDictionary members.

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForDesigner | Gets the CustomReportItem.Type value associated with the specified designer.
Public Method | GetDesignerForCustomTypeName | Returns the System.Type of the custom designer configured for the specified component type or null.
Top

See Also

Reference

CustomDesignerConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


GetCustomTypeNameForDesigner Method

[image]
ActiveReports 13
GetCustomTypeNameForDesigner Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : GetCustomTypeNameForDesigner Method

designerType
The System.Type for the designer the caller wants a custom report item type name for.

Glossary Item Box

Gets the CustomReportItem.Type value associated with the specified designer.

Syntax

Visual Basic (Declaration)
Public Function GetCustomTypeNameForDesigner( _
   ByVal designerType As Type _
) As String
C#
public string GetCustomTypeNameForDesigner(
   Type designerType
)

Parameters

designerType
The System.Type for the designer the caller wants a custom report item type name for.

Return Value

A value appropriate for the CustomReportItem RDL element's Type attribute value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


GetDesignerForCustomTypeName Method

[image]
ActiveReports 13
GetDesignerForCustomTypeName Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : GetDesignerForCustomTypeName Method

customTypeName
The value of CustomReportItem.Type for which a configured designer is sought for.

Glossary Item Box

Returns the System.Type of the custom designer configured for the specified component type or null.

Syntax

Visual Basic (Declaration)
Public Function GetDesignerForCustomTypeName( _
   ByVal customTypeName As String _
) As Type
C#
public Type GetDesignerForCustomTypeName(
   string customTypeName
)

Parameters

customTypeName
The value of CustomReportItem.Type for which a configured designer is sought for.

Return Value

The System.Type of the custom designer configured for the specified component, or null if a custom designer is not configured for the specified component.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


DefaultConfigurationProvider Class

[image]
ActiveReports 13
DefaultConfigurationProvider Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

Glossary Item Box

Implements an IConfigurationProvider that gets configuration information from a file in the executable directory.

Object Model

DefaultConfigurationProvider Class

Syntax

Visual Basic (Declaration)
Public Class DefaultConfigurationProvider
   Implements IConfigurationProvider
C#
public class DefaultConfigurationProvider : IConfigurationProvider

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.DefaultConfigurationProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultConfigurationProvider Members
GrapeCity.ActiveReports.Configuration Namespace


DefaultConfigurationProvider Class Members

[image]
ActiveReports 13
DefaultConfigurationProvider Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

Glossary Item Box

The following tables list the members exposed by DefaultConfigurationProvider.

Public Constructors

 | Name | Description
Public Constructor | DefaultConfigurationProvider Constructor | Creates a new instance of DefaultConfigurationProvider.
Top

Public Properties

 | Name | Description
Public Property | Content | Returns the xml content of the configuration information.
Top

See Also

Reference

DefaultConfigurationProvider Class
GrapeCity.ActiveReports.Configuration Namespace


DefaultConfigurationProvider Constructor

[image]
ActiveReports 13
DefaultConfigurationProvider Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DefaultConfigurationProvider Class : DefaultConfigurationProvider Constructor

Glossary Item Box

Creates a new instance of DefaultConfigurationProvider.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DefaultConfigurationProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultConfigurationProvider Class
DefaultConfigurationProvider Members


DefaultConfigurationProvider Class Properties

[image]
ActiveReports 13
DefaultConfigurationProvider Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

Glossary Item Box

For a list of all members of this type, see DefaultConfigurationProvider members.

Public Properties

 | Name | Description
Public Property | Content | Returns the xml content of the configuration information.
Top

See Also

Reference

DefaultConfigurationProvider Class
GrapeCity.ActiveReports.Configuration Namespace


Content Property

[image]
ActiveReports 13
Content Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > DefaultConfigurationProvider Class : Content Property

Glossary Item Box

Returns the xml content of the configuration information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Content As String
C#
public string Content {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultConfigurationProvider Class
DefaultConfigurationProvider Members


PropertyElement Class

[image]
ActiveReports 13
PropertyElement Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

Glossary Item Box

Represents a property configuration option for the associated export extension.

Object Model

PropertyElement Class

Syntax

Visual Basic (Declaration)
Public Class PropertyElement
C#
public class PropertyElement

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.PropertyElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Members
GrapeCity.ActiveReports.Configuration Namespace


PropertyElement Class Members

[image]
ActiveReports 13
PropertyElement Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

Glossary Item Box

The following tables list the members exposed by PropertyElement.

Public Constructors

 | Name | Description
Public Constructor | PropertyElement Constructor | Initializes a new instance of the System.Object class with the specified property, value and value type.
Top

Public Properties

 | Name | Description
Public Property | Property | Gets the property to assign value to.
Public Property | Type | Gets the type of the value to convert the value to.
Public Property | Value | Gets the string value.
Top

See Also

Reference

PropertyElement Class
GrapeCity.ActiveReports.Configuration Namespace


PropertyElement Constructor

[image]
ActiveReports 13
PropertyElement Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : PropertyElement Constructor

property
The property to assign value to.
value
The value for the property.
type
The type of the value to convert the string value to.

Glossary Item Box

Initializes a new instance of the System.Object class with the specified property, value and value type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal property As String, _
   ByVal value As String, _
   ByVal type As String _
)
C#
public PropertyElement(
   string property,
   string value,
   string type
)

Parameters

property
The property to assign value to.
value
The value for the property.
type
The type of the value to convert the string value to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


PropertyElement Class Properties

[image]
ActiveReports 13
PropertyElement Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

Glossary Item Box

For a list of all members of this type, see PropertyElement members.

Public Properties

 | Name | Description
Public Property | Property | Gets the property to assign value to.
Public Property | Type | Gets the type of the value to convert the value to.
Public Property | Value | Gets the string value.
Top

See Also

Reference

PropertyElement Class
GrapeCity.ActiveReports.Configuration Namespace


Property Property

[image]
ActiveReports 13
Property Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Property Property

Glossary Item Box

Gets the property to assign value to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Property As String
C#
public string Property {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Type Property

Glossary Item Box

Gets the type of the value to convert the value to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As String
C#
public string Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


Value Property

[image]
ActiveReports 13
Value Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Value Property

Glossary Item Box

Gets the string value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
C#
public string Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyElement Class
PropertyElement Members


RenderingExtensionInfo Class

[image]
ActiveReports 13
RenderingExtensionInfo Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

Glossary Item Box

Class containing rendering extension information.

Object Model

RenderingExtensionInfo Class

Syntax

Visual Basic (Declaration)
Public Class RenderingExtensionInfo
C#
public class RenderingExtensionInfo

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Members
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfo Class Members

[image]
ActiveReports 13
RenderingExtensionInfo Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

Glossary Item Box

The following tables list the members exposed by RenderingExtensionInfo.

Public Properties

 | Name | Description
Public Property | AssemblyName | Fully qualified name of the assembly.
Public Property | MenuName | Export menu item name for this rendering extension name.
Public Property | Settings | Gets the configuration.
Public Property | TypeName | Rendering extension implementation class name.
Top

See Also

Reference

RenderingExtensionInfo Class
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfo Class Properties

[image]
ActiveReports 13
RenderingExtensionInfo Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfo members.

Public Properties

 | Name | Description
Public Property | AssemblyName | Fully qualified name of the assembly.
Public Property | MenuName | Export menu item name for this rendering extension name.
Public Property | Settings | Gets the configuration.
Public Property | TypeName | Rendering extension implementation class name.
Top

See Also

Reference

RenderingExtensionInfo Class
GrapeCity.ActiveReports.Configuration Namespace


AssemblyName Property

[image]
ActiveReports 13
AssemblyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : AssemblyName Property

Glossary Item Box

Fully qualified name of the assembly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssemblyName As String
C#
public string AssemblyName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


MenuName Property

[image]
ActiveReports 13
MenuName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : MenuName Property

Glossary Item Box

Export menu item name for this rendering extension name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MenuName As String
C#
public string MenuName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


Settings Property

[image]
ActiveReports 13
Settings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : Settings Property

Glossary Item Box

Gets the configuration.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Settings As ReadOnlyCollection(Of PropertyElement)
C#
public ReadOnlyCollection<PropertyElement> Settings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


TypeName Property

[image]
ActiveReports 13
TypeName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : TypeName Property

Glossary Item Box

Rendering extension implementation class name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


RenderingExtensionInfoCollection Class

[image]
ActiveReports 13
RenderingExtensionInfoCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

Represents a collection of RenderingExtensionInfo.

Object Model

RenderingExtensionInfoCollection Class

Syntax

Visual Basic (Declaration)
Public Class RenderingExtensionInfoCollection
   Inherits System.Collections.CollectionBase
C#
public class RenderingExtensionInfoCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfoCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Members
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfoCollection Class Members

[image]
ActiveReports 13
RenderingExtensionInfoCollection Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

The following tables list the members exposed by RenderingExtensionInfoCollection.

Public Constructors

 | Name | Description
Public Constructor | RenderingExtensionInfoCollection Constructor | Creates an instance of RenderingExtensionInfoCollection.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the RenderingExtensionInfoCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the RenderingExtensionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the RenderingExtensionInfo at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.
Public Method | IndexOf | Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.
Public Method | Remove | Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

Public Events

 | Name | Description
Public Event | ContentChanged | Occurs when the content has changed.
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfoCollection Constructor

[image]
ActiveReports 13
RenderingExtensionInfoCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : RenderingExtensionInfoCollection Constructor

Glossary Item Box

Creates an instance of RenderingExtensionInfoCollection.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RenderingExtensionInfoCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Methods

[image]
ActiveReports 13
RenderingExtensionInfoCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.
Public Method | IndexOf | Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.
Public Method | Remove | Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Add Method

value
The RenderingExtensionInfo info to be added.

Glossary Item Box

Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As RenderingExtensionInfo _
) As Integer
C#
public int Add(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo info to be added.

Return Value

The index of added item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Contains Method

value
The RenderingExtensionInfo to search.

Glossary Item Box

Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As RenderingExtensionInfo _
) As Boolean
C#
public bool Contains(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo to search.

Return Value

True if specified RenderingExtensionInfo is presented in the collection, False othervise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : IndexOf Method

value
The RenderingExtensionInfo to looking for.

Glossary Item Box

Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As RenderingExtensionInfo _
) As Integer
C#
public int IndexOf(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo to looking for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Remove Method

value
The RenderingExtensionInfo to remvoe.

Glossary Item Box

Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As RenderingExtensionInfo _
)
C#
public void Remove(
   RenderingExtensionInfo value
)

Parameters

value
The RenderingExtensionInfo to remvoe.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Properties

[image]
ActiveReports 13
RenderingExtensionInfoCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the RenderingExtensionInfoCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the RenderingExtensionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the RenderingExtensionInfo at the specified index.
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Item Property

index
The index of the item to get or set.

Glossary Item Box

Gets or sets the RenderingExtensionInfo at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As RenderingExtensionInfo
C#
public RenderingExtensionInfo this[
   int index
]; {get; set;}

Parameters

index
The index of the item to get or set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Events

[image]
ActiveReports 13
RenderingExtensionInfoCollection Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

Glossary Item Box

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Events

 | Name | Description
Public Event | ContentChanged | Occurs when the content has changed.
Top

See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


ContentChanged Event

[image]
ActiveReports 13
ContentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : ContentChanged Event

Glossary Item Box

Occurs when the content has changed.

Syntax

Visual Basic (Declaration)
Public Event ContentChanged As RenderingExtensionInfoCollection.ContentChangedEventHandler
C#
public event RenderingExtensionInfoCollection.ContentChangedEventHandler ContentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


ReportItemsConfigurationDictionary Class

[image]
ActiveReports 13
ReportItemsConfigurationDictionary Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

Glossary Item Box

A dictionary of CustomReportItem type names and their corresponding System.Type.

Object Model

ReportItemsConfigurationDictionary Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportItemsConfigurationDictionary
C#
public sealed class ReportItemsConfigurationDictionary

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.ReportItemsConfigurationDictionary

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsConfigurationDictionary Members
GrapeCity.ActiveReports.Configuration Namespace


ReportItemsConfigurationDictionary Class Members

[image]
ActiveReports 13
ReportItemsConfigurationDictionary Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

Glossary Item Box

The following tables list the members exposed by ReportItemsConfigurationDictionary.

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForReportItem | Gets the Type value associated with the specified ReportItem.
Public Method | GetReportItemForCustomTypeName | Returns the System.Type of the custom report item configured for the specified component type or null.
Top

See Also

Reference

ReportItemsConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


ReportItemsConfigurationDictionary Class Methods

[image]
ActiveReports 13
ReportItemsConfigurationDictionary Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

Glossary Item Box

For a list of all members of this type, see ReportItemsConfigurationDictionary members.

Public Methods

 | Name | Description
Public Method | GetCustomTypeNameForReportItem | Gets the Type value associated with the specified ReportItem.
Public Method | GetReportItemForCustomTypeName | Returns the System.Type of the custom report item configured for the specified component type or null.
Top

See Also

Reference

ReportItemsConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


GetCustomTypeNameForReportItem Method

[image]
ActiveReports 13
GetCustomTypeNameForReportItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ReportItemsConfigurationDictionary Class : GetCustomTypeNameForReportItem Method

reportItemType
The System.Type for the designer the caller wants a custom report item type name for.

Glossary Item Box

Gets the Type value associated with the specified ReportItem.

Syntax

Visual Basic (Declaration)
Public Function GetCustomTypeNameForReportItem( _
   ByVal reportItemType As Type _
) As String
C#
public string GetCustomTypeNameForReportItem(
   Type reportItemType
)

Parameters

reportItemType
The System.Type for the designer the caller wants a custom report item type name for.

Return Value

A value appropriate for the CustomReportItem RDL element's Type attribute value.

Remarks

The specified ReportItem Type should implement the interface IReportItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsConfigurationDictionary Class
ReportItemsConfigurationDictionary Members


GetReportItemForCustomTypeName Method

[image]
ActiveReports 13
GetReportItemForCustomTypeName Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ReportItemsConfigurationDictionary Class : GetReportItemForCustomTypeName Method

customReportItemTypeName
The value of Type for which a configured designer is sought for.

Glossary Item Box

Returns the System.Type of the custom report item configured for the specified component type or null.

Syntax

Visual Basic (Declaration)
Public Function GetReportItemForCustomTypeName( _
   ByVal customReportItemTypeName As String _
) As Type
C#
public Type GetReportItemForCustomTypeName(
   string customReportItemTypeName
)

Parameters

customReportItemTypeName
The value of Type for which a configured designer is sought for.

Return Value

The System.Type of the custom designer configured for the specified component, or null if a custom designer is not configured for the specified component.

Remarks

The returned type should implement the interface IReportItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemsConfigurationDictionary Class
ReportItemsConfigurationDictionary Members


ToolboxItemConfig Class

[image]
ActiveReports 13
ToolboxItemConfig Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

Glossary Item Box

Represents an entry for a toolbox configuration item.

Object Model

ToolboxItemConfig Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolboxItemConfig
C#
public sealed class ToolboxItemConfig

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.ToolboxItemConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Members
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfig Class Members

[image]
ActiveReports 13
ToolboxItemConfig Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

Glossary Item Box

The following tables list the members exposed by ToolboxItemConfig.

Public Properties

 | Name | Description
Public Property | BitmapResource | Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.
Public Property | ClearItems | Gets a value that indicates if all existing items should be cleared.
Public Property | ReportItemDesignerType | Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).
Top

See Also

Reference

ToolboxItemConfig Class
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfig Class Properties

[image]
ActiveReports 13
ToolboxItemConfig Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

Glossary Item Box

For a list of all members of this type, see ToolboxItemConfig members.

Public Properties

 | Name | Description
Public Property | BitmapResource | Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.
Public Property | ClearItems | Gets a value that indicates if all existing items should be cleared.
Public Property | ReportItemDesignerType | Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).
Top

See Also

Reference

ToolboxItemConfig Class
GrapeCity.ActiveReports.Configuration Namespace


BitmapResource Property

[image]
ActiveReports 13
BitmapResource Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : BitmapResource Property

Glossary Item Box

Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BitmapResource As String
C#
public string BitmapResource {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ClearItems Property

[image]
ActiveReports 13
ClearItems Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : ClearItems Property

Glossary Item Box

Gets a value that indicates if all existing items should be cleared.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClearItems As Boolean
C#
public bool ClearItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ReportItemDesignerType Property

[image]
ActiveReports 13
ReportItemDesignerType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : ReportItemDesignerType Property

Glossary Item Box

Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportItemDesignerType As String
C#
public string ReportItemDesignerType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


IConfigurationManager Interface

[image]
ActiveReports 13
IConfigurationManager Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

Glossary Item Box

Defines an interface to allow access to configuration information.

Syntax

Visual Basic (Declaration)
Public Interface IConfigurationManager
C#
public interface IConfigurationManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Members
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationManager Interface Members

[image]
ActiveReports 13
IConfigurationManager Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

Glossary Item Box

The following tables list the members exposed by IConfigurationManager.

Public Properties

 | Name | Description
Property | CustomItemDesigners | Returns a map for the custom report items with the custom designers.
Property | DataProviders | Returns a collection of custom data providers.
Property | MapTileServerConfiguration | Returns a configuration for communication with map tile server.
Property | RenderingExtensions | Returns the rendering extensions defined by the provider.
Property | ReportItems | Provides the mapping between CustomReportItem type names and their corresponding System.Type.
Property | Settings | Returns a collection of configuration settings.
Property | TileProviders | Returns map tile providers.
Property | ToolboxItems | Returns the toolbox item configuration entries.
Top

See Also

Reference

IConfigurationManager Interface
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationManager Interface Properties

[image]
ActiveReports 13
IConfigurationManager Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

Glossary Item Box

For a list of all members of this type, see IConfigurationManager members.

Public Properties

 | Name | Description
Property | CustomItemDesigners | Returns a map for the custom report items with the custom designers.
Property | DataProviders | Returns a collection of custom data providers.
Property | MapTileServerConfiguration | Returns a configuration for communication with map tile server.
Property | RenderingExtensions | Returns the rendering extensions defined by the provider.
Property | ReportItems | Provides the mapping between CustomReportItem type names and their corresponding System.Type.
Property | Settings | Returns a collection of configuration settings.
Property | TileProviders | Returns map tile providers.
Property | ToolboxItems | Returns the toolbox item configuration entries.
Top

See Also

Reference

IConfigurationManager Interface
GrapeCity.ActiveReports.Configuration Namespace


CustomItemDesigners Property

[image]
ActiveReports 13
CustomItemDesigners Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : CustomItemDesigners Property

Glossary Item Box

Returns a map for the custom report items with the custom designers.

Syntax

Visual Basic (Declaration)
ReadOnly Property CustomItemDesigners As CustomDesignerConfigurationDictionary
C#
CustomDesignerConfigurationDictionary CustomItemDesigners {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


DataProviders Property

[image]
ActiveReports 13
DataProviders Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : DataProviders Property

Glossary Item Box

Returns a collection of custom data providers.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataProviders As DataProviderInfoCollection
C#
DataProviderInfoCollection DataProviders {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


MapTileServerConfiguration Property

[image]
ActiveReports 13
MapTileServerConfiguration Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : MapTileServerConfiguration Property

Glossary Item Box

Returns a configuration for communication with map tile server.

Syntax

Visual Basic (Declaration)
ReadOnly Property MapTileServerConfiguration As MapTileServerConfiguration
C#
MapTileServerConfiguration MapTileServerConfiguration {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


RenderingExtensions Property

[image]
ActiveReports 13
RenderingExtensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : RenderingExtensions Property

Glossary Item Box

Returns the rendering extensions defined by the provider.

Syntax

Visual Basic (Declaration)
ReadOnly Property RenderingExtensions As RenderingExtensionInfoCollection
C#
RenderingExtensionInfoCollection RenderingExtensions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


ReportItems Property

[image]
ActiveReports 13
ReportItems Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : ReportItems Property

Glossary Item Box

Provides the mapping between CustomReportItem type names and their corresponding System.Type.

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportItems As ReportItemsConfigurationDictionary
C#
ReportItemsConfigurationDictionary ReportItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


Settings Property

[image]
ActiveReports 13
Settings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : Settings Property

Glossary Item Box

Returns a collection of configuration settings.

Syntax

Visual Basic (Declaration)
ReadOnly Property Settings As NameValueCollection
C#
NameValueCollection Settings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


TileProviders Property

[image]
ActiveReports 13
TileProviders Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : TileProviders Property

Glossary Item Box

Returns map tile providers.

Syntax

Visual Basic (Declaration)
ReadOnly Property TileProviders As IEnumerable(Of TileProviderInfo)
C#
IEnumerable<TileProviderInfo> TileProviders {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


ToolboxItems Property

[image]
ActiveReports 13
ToolboxItems Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : ToolboxItems Property

Glossary Item Box

Returns the toolbox item configuration entries.

Syntax

Visual Basic (Declaration)
ReadOnly Property ToolboxItems As ICollection
C#
ICollection ToolboxItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


IConfigurationProvider Interface

[image]
ActiveReports 13
IConfigurationProvider Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

Glossary Item Box

Defines interface for providing raw configuration information.

Syntax

Visual Basic (Declaration)
Public Interface IConfigurationProvider
C#
public interface IConfigurationProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationProvider Members
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationProvider Interface Members

[image]
ActiveReports 13
IConfigurationProvider Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

Glossary Item Box

The following tables list the members exposed by IConfigurationProvider.

Public Properties

 | Name | Description
Property | Content | Gets the xml representing the configuration.
Top

See Also

Reference

IConfigurationProvider Interface
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationProvider Interface Properties

[image]
ActiveReports 13
IConfigurationProvider Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

Glossary Item Box

For a list of all members of this type, see IConfigurationProvider members.

Public Properties

 | Name | Description
Property | Content | Gets the xml representing the configuration.
Top

See Also

Reference

IConfigurationProvider Interface
GrapeCity.ActiveReports.Configuration Namespace


Content Property

[image]
ActiveReports 13
Content Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationProvider Interface : Content Property

Glossary Item Box

Gets the xml representing the configuration.

Syntax

Visual Basic (Declaration)
ReadOnly Property Content As String
C#
string Content {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurationProvider Interface
IConfigurationProvider Members


RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate

[image]
ActiveReports 13
RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate

sender
The source of the event.
e
The RenderingExtensionInfoCollection.ContentChangedEventargs value that contains the event data.

Glossary Item Box

Represents the method that processes the ContentChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub RenderingExtensionInfoCollection.ContentChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void RenderingExtensionInfoCollection.ContentChangedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
The source of the event.
e
The RenderingExtensionInfoCollection.ContentChangedEventargs value that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection.ContentChangedEventHandler Members
GrapeCity.ActiveReports.Configuration Namespace


GrapeCity.ActiveReports.Data Namespace

GrapeCity.ActiveReports.Data Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Data Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Data namespace contains the classes used for section report data binding in section reports.

Classes

 | Class | Description
Class | CsvDataSource | Represents a section report data source based on an CSV document.
Class | Field | The Field class represents any data field available for data binding in section reports.
Class | FieldCollection | The FieldCollection class manages the data binding fields used in the section report.
Class | ListDataSource | Represents a section report data source based on the IDataRecord and IDataReader members of the .NET Framework.
Class | OdbcDataSource | ODBC data source - allows to connect through ODBC driver.
Class | OleDBDataSource | Represents a section report data source based on the OleDb ADO.NET data provider.
Class | ProviderSerializer | Used to serialize/deserialize data sources. Internal uses only.
Class | SqlDBDataSource | Represents a section report data source based on the SqlDB ADO.NET data provider.
Class | XMLDataSource | Represents a section report data source based on an XML document and an XPath pattern to select the XML nodes used as records in the data source.

Enumerations

 | Enumeration | Description
Enumeration | FieldTypeEnum | Provides a set of values for use with the FieldType property of the Field class.

Remarks

If you want to use run-time data binding in page reports, please see Bind a Page Report to a Data Source at Run Time.

See Also

Reference

GrapeCity.ActiveReports Assembly


CsvDataSource Class

[image]
ActiveReports 13
CsvDataSource Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

Represents a section report data source based on an CSV document.

Object Model

CsvDataSource Class

Syntax

Visual Basic (Declaration)
Public Class CsvDataSource
C#
public class CsvDataSource

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.CsvDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Members
GrapeCity.ActiveReports.Data Namespace


CsvDataSource Class Members

[image]
ActiveReports 13
CsvDataSource Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

The following tables list the members exposed by CsvDataSource.

Public Constructors

 | Name | Description
Public Constructor | CsvDataSource Constructor |
Top

Public Properties

 | Name | Description
Public Property | ConnectionString | Specifies the string used to load the data from the csv file.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Top

Public Methods

 | Name | Description
Public Method | Field | Returns the value of the field with the specified name.
Public Method | GetColumns | Returns the list of the csv columns names.
Public Method | Load | Loads the csv data from the source specified in connection string.
Public Method | MoveFirst | Moves the current position to the first data record.
Public Method | MoveNext | Moves the current position to the next data record.
Top

See Also

Reference

CsvDataSource Class
GrapeCity.ActiveReports.Data Namespace


CsvDataSource Constructor

[image]
ActiveReports 13
CsvDataSource Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : CsvDataSource Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CsvDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


CsvDataSource Class Methods

[image]
ActiveReports 13
CsvDataSource Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

For a list of all members of this type, see CsvDataSource members.

Public Methods

 | Name | Description
Public Method | Field | Returns the value of the field with the specified name.
Public Method | GetColumns | Returns the list of the csv columns names.
Public Method | Load | Loads the csv data from the source specified in connection string.
Public Method | MoveFirst | Moves the current position to the first data record.
Public Method | MoveNext | Moves the current position to the next data record.
Top

See Also

Reference

CsvDataSource Class
GrapeCity.ActiveReports.Data Namespace


Field Method

[image]
ActiveReports 13
Field Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : Field Method

name
The name of the field.

Glossary Item Box

Returns the value of the field with the specified name.

Syntax

Visual Basic (Declaration)
Public Function Field( _
   ByVal name As String _
) As Object
C#
public object Field(
   string name
)

Parameters

name
The name of the field.

Return Value

The value of the field.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


GetColumns Method

[image]
ActiveReports 13
GetColumns Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : GetColumns Method

Glossary Item Box

Returns the list of the csv columns names.

Syntax

Visual Basic (Declaration)
Public Function GetColumns() As List(Of String)
C#
public List<string> GetColumns()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


Load Method

[image]
ActiveReports 13
Load Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : Load Method

getStream
The stream getter.

Glossary Item Box

Loads the csv data from the source specified in connection string.

Syntax

Visual Basic (Declaration)
Public Sub Load( _
   Optional ByVal getStream As Func(Of String,Stream) _
)
C#
public void Load(
   Func<string,Stream> getStream
)

Parameters

getStream
The stream getter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


MoveFirst Method

[image]
ActiveReports 13
MoveFirst Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : MoveFirst Method

Glossary Item Box

Moves the current position to the first data record.

Syntax

Visual Basic (Declaration)
Public Sub MoveFirst()
C#
public void MoveFirst()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


MoveNext Method

[image]
ActiveReports 13
MoveNext Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : MoveNext Method

Glossary Item Box

Moves the current position to the next data record.

Syntax

Visual Basic (Declaration)
Public Sub MoveNext()
C#
public void MoveNext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


CsvDataSource Class Properties

[image]
ActiveReports 13
CsvDataSource Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : CsvDataSource Class

Glossary Item Box

For a list of all members of this type, see CsvDataSource members.

Public Properties

 | Name | Description
Public Property | ConnectionString | Specifies the string used to load the data from the csv file.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Top

See Also

Reference

CsvDataSource Class
GrapeCity.ActiveReports.Data Namespace


ConnectionString Property

[image]
ActiveReports 13
ConnectionString Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : ConnectionString Property

Glossary Item Box

Specifies the string used to load the data from the csv file.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members
8b2ee12b-264b-403f-aa50-aafadcf8c1cb


EOF Property

[image]
ActiveReports 13
EOF Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > CsvDataSource Class : EOF Property

Glossary Item Box

Determines whether the CurrentPosition is at the end of the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EOF As Boolean
C#
public bool EOF {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvDataSource Class
CsvDataSource Members


Field Class

[image]
ActiveReports 13
Field Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

The Field class represents any data field available for data binding in section reports.

Object Model

Field Class

Syntax

Visual Basic (Declaration)
Public Class Field
C#
public class Field

Remarks

Field objects are created automatically for all fields in the bound data source. This class allows you to inspect the value of each field. You can create additional custom fields and add them to the Fields collection in the DataIntialize event. Custom field values should be set in the FetchData event.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.Field

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Members
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Field Class Members

[image]
ActiveReports 13
Field Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

The following tables list the members exposed by Field.

Public Constructors

 | Name | Description
Public Constructor | Field Constructor | Initializes a new instance of the Field class.
Top

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets the user-defined default value of the field, which is used if the formula or value is null.
Public Property | FieldType | Gets or sets the type associated with the field.
Public Property | Formula | Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.
Public Property | Name | Gets or sets the name of the field.
Public Property | Tag | Gets or sets a user-defined value associated with the field object.
Public Property | Value | Gets or sets the current value of the field object.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns a string that represents the current Field object.
Top

Public Events

 | Name | Description
Public Event | Disposed | Raised when the Field object is released from memory.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Field Constructor

[image]
ActiveReports 13
Field Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Field Constructor

Glossary Item Box

Initializes a new instance of the Field class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Field()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Methods

[image]
ActiveReports 13
Field Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Methods

 | Name | Description
Public Method | ToString | Returns a string that represents the current Field object.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : ToString Method

Glossary Item Box

Returns a string that represents the current Field object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Properties

[image]
ActiveReports 13
Field Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets the user-defined default value of the field, which is used if the formula or value is null.
Public Property | FieldType | Gets or sets the type associated with the field.
Public Property | Formula | Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.
Public Property | Name | Gets or sets the name of the field.
Public Property | Tag | Gets or sets a user-defined value associated with the field object.
Public Property | Value | Gets or sets the current value of the field object.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


DefaultValue Property

[image]
ActiveReports 13
DefaultValue Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : DefaultValue Property

Glossary Item Box

Gets or sets the user-defined default value of the field, which is used if the formula or value is null.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue {get; set;}

Example

C# Copy Code
private void rptCalFields_ReportStart(object sender, System.EventArgs e)
{
    this.field1.DefaultValue = "\"Does not compute\"";
    this.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None;
    this.field1.Formula = "ProductName + UnitPrice";
    this.field1.Name = "field1";
    this.field1.Tag = null;
}
Visual Basic Copy Code
Private Sub rptCalFields_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
   Me.field1.DefaultValue = """Does not compute"""
   Me.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None
   Me.field1.Formula = "ProductName + UnitPrice"
   Me.field1.Name = "field1"
   Me.field1.Tag = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


FieldType Property

[image]
ActiveReports 13
FieldType Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : FieldType Property

Glossary Item Box

Gets or sets the type associated with the field.

Syntax

Visual Basic (Declaration)
Public Property FieldType As FieldTypeEnum
C#
public FieldTypeEnum FieldType {get; set;}

Remarks

If the output of a field does not match the setting of the FieldType property, Field.DefaultValue takes precedence.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[1].FieldType = FieldTypeEnum.String;
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(1).FieldType = FieldTypeEnum.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Formula Property

[image]
ActiveReports 13
Formula Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Formula Property

Glossary Item Box

Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.

Syntax

Visual Basic (Declaration)
Public Property Formula As String
C#
public string Formula {get; set;}

Example

C# Copy Code
private void rptCalFields_ReportStart(object sender, System.EventArgs e)
{
    this.field1.DefaultValue = "\"Does not compute\"";
    this.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None;
    this.field1.Formula = "ProductName + UnitPrice";
    this.field1.Name = "field1";
    this.field1.Tag = null;
}
Visual Basic Copy Code
Private Sub rptCalFields_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
   Me.field1.DefaultValue = """Does not compute"""
   Me.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None
   Me.field1.Formula = "ProductName + UnitPrice"
   Me.field1.Name = "field1"
   Me.field1.Tag = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Name Property

[image]
ActiveReports 13
Name Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Name Property

Glossary Item Box

Gets or sets the name of the field.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

String value representing the name of the field.

Remarks

The name must be unique within the collection and is used as a key of the field in the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[0].Name = "FirstField";
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(0).Name = "FirstField"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Tag Property

Glossary Item Box

Gets or sets a user-defined value associated with the field object.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An object user-defined value.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[0].Tag = "Some extra data";
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(0).Tag = "Some extra data"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Value Property

[image]
ActiveReports 13
Value Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Value Property

Glossary Item Box

Gets or sets the current value of the field object.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Example

C# Copy Code
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
Visual Basic Copy Code
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As GrapeCity.ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


Field Class Events

[image]
ActiveReports 13
Field Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

Glossary Item Box

For a list of all members of this type, see Field members.

Public Events

 | Name | Description
Public Event | Disposed | Raised when the Field object is released from memory.
Top

See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Disposed Event

Glossary Item Box

Raised when the Field object is released from memory.

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


FieldCollection Class

[image]
ActiveReports 13
FieldCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

The FieldCollection class manages the data binding fields used in the section report.

Object Model

FieldCollection Class

Syntax

Visual Basic (Declaration)
Public Class FieldCollection
   Inherits System.Collections.CollectionBase
C#
public class FieldCollection : System.Collections.CollectionBase

Remarks

ActiveReports populates this collection with fields from the data source and updates the values with each record in the data source. In addition, you can add your own custom fields in the DataInitialize event to create unbound calculated fields. Custom field values can be set in the FetchData event.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Data.FieldCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Members
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


FieldCollection Class Members

[image]
ActiveReports 13
FieldCollection Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

The following tables list the members exposed by FieldCollection.

Public Constructors

 | Name | Description
Public Constructor | FieldCollection Constructor | Initializes a new instance of the FieldCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the FieldCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the FieldCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | DuplicateNames | Returns HashSet with duplicated field names.
Public Property | Item | Overloaded. Gets the element at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new field to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Returns a value indicating whether the field collection contains a field with the specified name.
Public Method | CopyTo | Copies fields from the collection to an array, starting at a particular array index.
Public Method | IndexOf | Finds the index number of the specified field in the collection.
Public Method | Insert | Inserts an existing field in the fields collection at the specified location.
Public Method | Remove | Overloaded. Removes the specified field from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


FieldCollection Constructor

[image]
ActiveReports 13
FieldCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : FieldCollection Constructor

parent
The parent object of the field collection.

Glossary Item Box

Initializes a new instance of the FieldCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As IComponent _
)
C#
public FieldCollection(
   IComponent parent
)

Parameters

parent
The parent object of the field collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


FieldCollection Class Methods

[image]
ActiveReports 13
FieldCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

For a list of all members of this type, see FieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new field to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Returns a value indicating whether the field collection contains a field with the specified name.
Public Method | CopyTo | Copies fields from the collection to an array, starting at a particular array index.
Public Method | IndexOf | Finds the index number of the specified field in the collection.
Public Method | Insert | Inserts an existing field in the fields collection at the specified location.
Public Method | Remove | Overloaded. Removes the specified field from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


Add Method

[image]
ActiveReports 13
Add Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Add Method

Glossary Item Box

Adds a new field to the collection. Adds a new field to the collection.

Overload List

Overload | Description
Add(String) | Adds a new field to the collection.
Add(Field) | Adds a new field to the collection.

Remarks

The Add method should be used in the DataInitialize event.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Add(String) Method

[image]
ActiveReports 13
Add(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Add Method : Add(String) Method

fieldName

Name of the field to be added to the collection.

Glossary Item Box

Adds a new field to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal fieldName As String _
) As Integer
C#
public int Add(
   string fieldName
)

Parameters

fieldName

Name of the field to be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Add(Field) Method

[image]
ActiveReports 13
Add(Field) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Add Method : Add(Field) Method

field
The field to be added to the collection.

Glossary Item Box

Adds a new field to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal field As Field _
) As Integer
C#
public int Add(
   Field field
)

Parameters

field
The field to be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Contains Method

[image]
ActiveReports 13
Contains Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Contains Method

Glossary Item Box

Returns a value indicating whether the field collection contains a field with the specified name.

Overload List

Overload | Description
Contains(String) | Returns whether the field collection contains a field with the specified name.
Contains(Field) | Returns whether the field collection contains the specified field.

Example

C# Copy Code
private void UnboundGrp_ReportEnd(object sender, System.EventArgs eArgs)
{
    if (this.Fields.Contains("DiscountTotal"))
    {
        System.Windows.Forms.MessageBox.Show ("Contains Discount Total");
    }
}
Visual Basic Copy Code
Private Sub UnboundGrp_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    If Me.Fields.Contains("DiscountTotal") Then
        MsgBox("contains discount total")
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Contains(String) Method

[image]
ActiveReports 13
Contains(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Contains Method : Contains(String) Method

fieldName
Specifies the field name to look for in the collection.

Glossary Item Box

Returns whether the field collection contains a field with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal fieldName As String _
) As Boolean
C#
public bool Contains(
   string fieldName
)

Parameters

fieldName
Specifies the field name to look for in the collection.

Return Value

A Boolean value that indicates whether the specified fieldname was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Contains(Field) Method

[image]
ActiveReports 13
Contains(Field) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Contains Method : Contains(Field) Method

field
Specifies the field to look for in the collection.

Glossary Item Box

Returns whether the field collection contains the specified field.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal field As Field _
) As Boolean
C#
public bool Contains(
   Field field
)

Parameters

field
Specifies the field to look for in the collection.

Return Value

A Boolean value indicating whether the specified field was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : CopyTo Method

fields
The array containing the copied fields.
index
The insertion index in the collection.

Glossary Item Box

Copies fields from the collection to an array, starting at a particular array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal fields() As Field, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Field[] fields,
   int index
)

Parameters

fields
The array containing the copied fields.
index
The insertion index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


IndexOf(Field) Method

[image]
ActiveReports 13
IndexOf(Field) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : IndexOf(Field) Method

field
The field to find the index of in the collection.

Glossary Item Box

Finds the index number of the specified field in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal field As Field _
) As Integer
C#
public int IndexOf(
   Field field
)

Parameters

field
The field to find the index of in the collection.

Return Value

An integer indicating the position of the field within the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Insert Method

index
The indexed location within the fields collection in which to insert the new field.
field
The field to insert.

Glossary Item Box

Inserts an existing field in the fields collection at the specified location.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal field As Field _
)
C#
public void Insert(
   int index,
   Field field
)

Parameters

index
The indexed location within the fields collection in which to insert the new field.
field
The field to insert.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Insert(0,Fields[1]);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Remove Method

Glossary Item Box

Removes the specified field from the collection.

Overload List

Overload | Description
Remove(Field) | Removes the specified field from the collection.
Remove(String) | Removes the field with specified name from the collection.
Remove(Int32) | Removes the field at the specified index from the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove("Description");
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Remove(Field) Method

[image]
ActiveReports 13
Remove(Field) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(Field) Method

value
The field to remove.

Glossary Item Box

Removes the specified field from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal value As Field _
)
C#
public void Remove(
   Field value
)

Parameters

value
The field to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Remove(String) Method

[image]
ActiveReports 13
Remove(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(String) Method

fieldName
Specifies the field name to remove from the collection.

Glossary Item Box

Removes the field with specified name from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal fieldName As String _
)
C#
public void Remove(
   string fieldName
)

Parameters

fieldName
Specifies the field name to remove from the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove("Description");
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove("Description")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Remove(Int32) Method

[image]
ActiveReports 13
Remove(Int32) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(Int32) Method

index

Specifies the index of the field to be removed.

Glossary Item Box

Removes the field at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal index As Integer _
)
C#
public void Remove(
   int index
)

Parameters

index

Specifies the index of the field to be removed.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove(4);
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove(4)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


FieldCollection Class Properties

[image]
ActiveReports 13
FieldCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

Glossary Item Box

For a list of all members of this type, see FieldCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the FieldCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the FieldCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | DuplicateNames | Returns HashSet with duplicated field names.
Public Property | Item | Overloaded. Gets the element at the specified index.
Top

See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


DuplicateNames Property

[image]
ActiveReports 13
DuplicateNames Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : DuplicateNames Property

Glossary Item Box

Returns HashSet with duplicated field names.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DuplicateNames As HashSet(Of String)
C#
public HashSet<string> DuplicateNames {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Item Property

[image]
ActiveReports 13
Item Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Item Property

Glossary Item Box

Gets the element at the specified index. Gets the specified field object from the collection.

Overload List

Overload | Description
Item(Int32) | Gets the Field object at the specified indexed location in the FieldCollection.
Item(String) | Gets the Field object with the specified name in the FieldCollection.

Remarks

This is the default property for the FieldCollection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    System.Windows.Forms.MessageBox.Show (this.Fields[1].Name.ToString());
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  MessageBox.Show(Me.Fields.Item(1).Name.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Item(Int32) Property

[image]
ActiveReports 13
Item(Int32) Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Item Property : Item(Int32) Property

index
The indexed location of the Field in the collection.

Glossary Item Box

Gets the Field object at the specified indexed location in the FieldCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Field
C#
public Field Item(
   int index
) {get;}

Parameters

index
The indexed location of the Field in the collection.

Example

C# Copy Code
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    System.Windows.Forms.MessageBox.Show (this.Fields[1].Name.ToString());
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  MsgBox(Me.Fields.Item(1).Name.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 13
Item(String) Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Item Property : Item(String) Property

fieldName
The name of the Field in the collection.

Glossary Item Box

Gets the Field object with the specified name in the FieldCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal fieldName As String _
) As Field
C#
public Field Item(
   string fieldName
) {get;}

Parameters

fieldName
The name of the Field in the collection.

Example

C# Copy Code
private void UnboundGrp_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryID"].Value = m_reader["categories.CategoryID"].ToString();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        Fields["TotalLabel"].Value = "Total Number of " + m_reader["CategoryName"].ToString() + ":";
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
    //Item is the default property for Fields
    System.Windows.Forms.MessageBox.Show (this.Fields["Description"].Value.ToString());
}
Visual Basic Copy Code
Private Sub rptUnboundGrp_FetchData(ByVal sender As Object, ByVal eArgs As GrapeCity.ActiveReports.ActiveReport. _
    FetchEventArgs) Handles MyBase.FetchData
  Try    m_reader.Read()
    Me.Fields("CategoryID").Value = m_reader("categories.CategoryID")
    Me.Fields("CategoryName").Value = m_reader("CategoryName")
    Me.Fields("ProductName").Value = m_reader("ProductName")
    Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
    Me.Fields("Description").Value = m_reader("Description")
    Me.Fields("TotalLabel").Value = "Total Number of " + m_reader("CategoryName") + ":"
    eArgs.EOF = False
  Catch ex As Exception
    System.Windows.Forms.MessageBox.Show(ex.ToString())
    eArgs.EOF = True
  End Try
  MsgBox(Me.Fields.Item("Description").Value.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


ListDataSource Class

[image]
ActiveReports 13
ListDataSource Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ListDataSource Class

Glossary Item Box

Represents a section report data source based on the IDataRecord and IDataReader members of the .NET Framework.

Object Model

ListDataSource Class

Syntax

Visual Basic (Declaration)
Public Class ListDataSource
C#
public class ListDataSource

Remarks

This class uses the IList interface to bind data from a custom object or a RowCollection to the report. The interface determines the structure of the data, so that the user needs no additional code to structure it.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.ListDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListDataSource Members
GrapeCity.ActiveReports.Data Namespace


ListDataSource Class Members

[image]
ActiveReports 13
ListDataSource Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ListDataSource Class

Glossary Item Box

The following tables list the members exposed by ListDataSource.

Public Constructors

 | Name | Description
Public Constructor | ListDataSource Constructor | Initializes a new instance of the ListDataSource class.
Top

See Also

Reference

ListDataSource Class
GrapeCity.ActiveReports.Data Namespace


ListDataSource Constructor

[image]
ActiveReports 13
ListDataSource Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > ListDataSource Class : ListDataSource Constructor

list
System.Collections.IList

Glossary Item Box

Initializes a new instance of the ListDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal list As IList _
)
C#
public ListDataSource(
   IList list
)

Parameters

list
System.Collections.IList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListDataSource Class
ListDataSource Members


OdbcDataSource Class

[image]
ActiveReports 13
OdbcDataSource Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

Glossary Item Box

ODBC data source - allows to connect through ODBC driver.

Object Model

OdbcDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OdbcDataSource
C#
public sealed class OdbcDataSource

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.OdbcDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Members
GrapeCity.ActiveReports.Data Namespace


OdbcDataSource Class Members

[image]
ActiveReports 13
OdbcDataSource Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

Glossary Item Box

The following tables list the members exposed by OdbcDataSource.

Public Constructors

 | Name | Description
Public Constructor | OdbcDataSource Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CommandTimeout | Gets or sets current commant timeout.
Public Property | ConnectionString | Gets or sets connection string.
Public Property | SQL | Gets or sets current command text
Top

See Also

Reference

OdbcDataSource Class
GrapeCity.ActiveReports.Data Namespace


OdbcDataSource Constructor

[image]
ActiveReports 13
OdbcDataSource Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : OdbcDataSource Constructor

Glossary Item Box

Overload List

Overload | Description
OdbcDataSource Constructor() | Default ctor. By default, connection string and command text are empty strings, and command timeout is DefaultTimeout
OdbcDataSource Constructor(String,String,Int32) | Initializes a new instance of the OdbcDataSource class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


OdbcDataSource Constructor()

[image]
ActiveReports 13
OdbcDataSource Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class > OdbcDataSource Constructor : OdbcDataSource Constructor()

Glossary Item Box

Default ctor. By default, connection string and command text are empty strings, and command timeout is DefaultTimeout

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OdbcDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members
Overload List


OdbcDataSource Constructor(String,String,Int32)

[image]
ActiveReports 13
OdbcDataSource Constructor(String,String,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class > OdbcDataSource Constructor : OdbcDataSource Constructor(String,String,Int32)

connectionString
sql
The current command text.
timeout
The command timeout.

Glossary Item Box

Initializes a new instance of the OdbcDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String, _
   ByVal sql As String, _
   ByVal timeout As Integer _
)
C#
public OdbcDataSource(
   string connectionString,
   string sql,
   int timeout
)

Parameters

connectionString
sql
The current command text.
timeout
The command timeout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members
Overload List


OdbcDataSource Class Properties

[image]
ActiveReports 13
OdbcDataSource Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

Glossary Item Box

For a list of all members of this type, see OdbcDataSource members.

Public Properties

 | Name | Description
Public Property | CommandTimeout | Gets or sets current commant timeout.
Public Property | ConnectionString | Gets or sets connection string.
Public Property | SQL | Gets or sets current command text
Top

See Also

Reference

OdbcDataSource Class
GrapeCity.ActiveReports.Data Namespace


CommandTimeout Property

[image]
ActiveReports 13
CommandTimeout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : CommandTimeout Property

Glossary Item Box

Gets or sets current commant timeout.

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


ConnectionString Property

[image]
ActiveReports 13
ConnectionString Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : ConnectionString Property

Glossary Item Box

Gets or sets connection string.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


SQL Property

[image]
ActiveReports 13
SQL Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : SQL Property

Glossary Item Box

Gets or sets current command text

Syntax

Visual Basic (Declaration)
Public Property SQL As String
C#
public string SQL {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


OleDBDataSource Class

[image]
ActiveReports 13
OleDBDataSource Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

Glossary Item Box

Represents a section report data source based on the OleDb ADO.NET data provider.

Object Model

OleDBDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OleDBDataSource
C#
public sealed class OleDBDataSource

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    rptSub rpt = New rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.OleDBDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Members
GrapeCity.ActiveReports.Data Namespace


OleDBDataSource Class Members

[image]
ActiveReports 13
OleDBDataSource Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

Glossary Item Box

The following tables list the members exposed by OleDBDataSource.

Public Constructors

 | Name | Description
Public Constructor | OleDBDataSource Constructor | Overloaded. Initializes a new instance of the OleDBDataSource class.
Top

Public Properties

 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the OleDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top

See Also

Reference

OleDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


OleDBDataSource Constructor

[image]
ActiveReports 13
OleDBDataSource Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : OleDBDataSource Constructor

Glossary Item Box

Initializes a new instance of the OleDBDataSource class. Initializes a new instance of the OleDbDataSource class.

Overload List

Overload | Description
OleDBDataSource Constructor() | Initializes a new instance of the OleDbDataSource class. By default, the connection string and command text are empty strings; the command timeout is DefaultTimeout.
OleDBDataSource Constructor(String,String,Int32) | Initializes a new instance of the OleDbDataSource class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


OleDBDataSource Constructor()

[image]
ActiveReports 13
OleDBDataSource Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class > OleDBDataSource Constructor : OleDBDataSource Constructor()

Glossary Item Box

Initializes a new instance of the OleDbDataSource class. By default, the connection string and command text are empty strings; the command timeout is DefaultTimeout.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OleDBDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Overload List


OleDBDataSource Constructor(String,String,Int32)

[image]
ActiveReports 13
OleDBDataSource Constructor(String,String,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class > OleDBDataSource Constructor : OleDBDataSource Constructor(String,String,Int32)

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Glossary Item Box

Initializes a new instance of the OleDbDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String, _
   ByVal sql As String, _
   ByVal timeout As Integer _
)
C#
public OleDBDataSource(
   string connectionString,
   string sql,
   int timeout
)

Parameters

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Overload List


OleDBDataSource Class Properties

[image]
ActiveReports 13
OleDBDataSource Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

Glossary Item Box

For a list of all members of this type, see OleDBDataSource members.

Public Properties

 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the OleDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top

See Also

Reference

OleDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


CommandTimeout Property

[image]
ActiveReports 13
CommandTimeout Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : CommandTimeout Property

Glossary Item Box

Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout {get; set;}

Remarks

When using this property with the OleDBDataSource, you need to verify with the provider that it supports the command timeout settings. Some of them do not. This is provider-specific, so we are unable to provide a list of working providers.

Example

C# Copy Code
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    rptSubBM rpt = new rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.CommandTimeout = 30;
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.CommandTimeout = 30
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID
    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


ConnectionString Property

[image]
ActiveReports 13
ConnectionString Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : ConnectionString Property

Glossary Item Box

Specifies the string used to open a connection to the data source using the OleDb data provider.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Example

C# Copy Code
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    rptSubBM rpt = new rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


SQL Property

[image]
ActiveReports 13
SQL Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : SQL Property

Glossary Item Box

Specifies a valid SQL statement used to retrieve records from the data source.

Syntax

Visual Basic (Declaration)
Public Property SQL As String
C#
public string SQL {get; set;}

Remarks

ActiveReports creates a DataReader and uses it to load the data into the report.

The SQL string may contain parameter placeholder syntax to fill the report's parameters collection and prompt the user to enter their values before executing the report.

Example

C# Copy Code
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    rptSubBM rpt = new rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Parameters Property


ProviderSerializer Class

[image]
ActiveReports 13
ProviderSerializer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ProviderSerializer Class

Glossary Item Box

Used to serialize/deserialize data sources. Internal uses only.

Object Model

ProviderSerializer Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class ProviderSerializer
C#
public static class ProviderSerializer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.ProviderSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProviderSerializer Members
GrapeCity.ActiveReports.Data Namespace


ProviderSerializer Class Members

[image]
ActiveReports 13
ProviderSerializer Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ProviderSerializer Class

Glossary Item Box

The following tables list the members exposed by ProviderSerializer.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromStream | Internal uses only.
static (Shared in Visual Basic) | ToStream | Internal uses only.
Top

See Also

Reference

ProviderSerializer Class
GrapeCity.ActiveReports.Data Namespace


ProviderSerializer Class Methods

[image]
ActiveReports 13
ProviderSerializer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : ProviderSerializer Class

Glossary Item Box

For a list of all members of this type, see ProviderSerializer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | FromStream | Internal uses only.
static (Shared in Visual Basic) | ToStream | Internal uses only.
Top

See Also

Reference

ProviderSerializer Class
GrapeCity.ActiveReports.Data Namespace


FromStream Method

[image]
ActiveReports 13
FromStream Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > ProviderSerializer Class : FromStream Method

stream

Glossary Item Box

Internal uses only.

Syntax

Visual Basic (Declaration)
Public Shared Function FromStream( _
   ByVal stream As Stream _
) As Object
C#
public static object FromStream(
   Stream stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProviderSerializer Class
ProviderSerializer Members


ToStream Method

[image]
ActiveReports 13
ToStream Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > ProviderSerializer Class : ToStream Method

provider

Glossary Item Box

Internal uses only.

Syntax

Visual Basic (Declaration)
Public Shared Function ToStream( _
   ByVal provider As Object _
) As MemoryStream
C#
public static MemoryStream ToStream(
   object provider
)

Parameters

provider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ProviderSerializer Class
ProviderSerializer Members


SqlDBDataSource Class

[image]
ActiveReports 13
SqlDBDataSource Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

Represents a section report data source based on the SqlDB ADO.NET data provider.

Object Model

SqlDBDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlDBDataSource
C#
public sealed class SqlDBDataSource

Example

C# Copy Code
private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.SqlDBDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Members
GrapeCity.ActiveReports.Data Namespace


SqlDBDataSource Class Members

[image]
ActiveReports 13
SqlDBDataSource Class Members
See Also Fields Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

The following tables list the members exposed by SqlDBDataSource.

Public Constructors

 | Name | Description
Public Constructor | SqlDBDataSource Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultTimeout | Sets or returns the number of seconds to wait for a connection to open, before canceling the attempt and generate an error.
Top

Public Properties

 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the SqlDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top

See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


SqlDBDataSource Constructor

[image]
ActiveReports 13
SqlDBDataSource Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : SqlDBDataSource Constructor

Glossary Item Box

Initializes a new instance of the SqlDBDataSource class.

Overload List

Overload | Description
SqlDBDataSource Constructor() | Initializes a new instance of the SqlDBDataSource class.
SqlDBDataSource Constructor(String,String,Int32) | Initializes a new instance of the SqlDBDataSource class with the specified parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


SqlDBDataSource Constructor()

[image]
ActiveReports 13
SqlDBDataSource Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class > SqlDBDataSource Constructor : SqlDBDataSource Constructor()

Glossary Item Box

Initializes a new instance of the SqlDBDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SqlDBDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Overload List


SqlDBDataSource Constructor(String,String,Int32)

[image]
ActiveReports 13
SqlDBDataSource Constructor(String,String,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class > SqlDBDataSource Constructor : SqlDBDataSource Constructor(String,String,Int32)

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Glossary Item Box

Initializes a new instance of the SqlDBDataSource class with the specified parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String, _
   ByVal sql As String, _
   ByVal timeout As Integer _
)
C#
public SqlDBDataSource(
   string connectionString,
   string sql,
   int timeout
)

Parameters

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Overload List


SqlDBDataSource Class Properties

[image]
ActiveReports 13
SqlDBDataSource Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

For a list of all members of this type, see SqlDBDataSource members.

Public Properties

 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the SqlDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top

See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


CommandTimeout Property

[image]
ActiveReports 13
CommandTimeout Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : CommandTimeout Property

Glossary Item Box

Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout {get; set;}

Example

C# Copy Code
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


ConnectionString Property

[image]
ActiveReports 13
ConnectionString Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : ConnectionString Property

Glossary Item Box

Specifies the string used to open a connection to the data source using the SqlDb data provider.

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString {get; set;}

Example

C# Copy Code
Private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


SQL Property

[image]
ActiveReports 13
SQL Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : SQL Property

Glossary Item Box

Specifies a valid SQL statement used to retrieve records from the data source.

Syntax

Visual Basic (Declaration)
Public Property SQL As String
C#
public string SQL {get; set;}

Remarks

ActiveReports creates a DataReader and uses it to load the data into the report.

The SQL string may contain parameter placeholder syntax to fill the report's parameters collection and prompt the user to enter their values before executing the report.

Example

C# Copy Code
Private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Parameters Property


SqlDBDataSource Class Fields

[image]
ActiveReports 13
SqlDBDataSource Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

Glossary Item Box

For a list of all members of this type, see SqlDBDataSource members.

Public Fields

 | Name | Description
Public Field | DefaultTimeout | Sets or returns the number of seconds to wait for a connection to open, before canceling the attempt and generate an error.
Top

See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


DefaultTimeout Field

[image]
ActiveReports 13
DefaultTimeout Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : DefaultTimeout Field

Glossary Item Box

Sets or returns the number of seconds to wait for a connection to open, before canceling the attempt and generate an error.

Syntax

Visual Basic (Declaration)
Public Const DefaultTimeout As Integer
C#
public const int DefaultTimeout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


XMLDataSource Class

[image]
ActiveReports 13
XMLDataSource Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

Represents a section report data source based on an XML document and an XPath pattern to select the XML nodes used as records in the data source.

Object Model

XMLDataSource Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XMLDataSource
C#
public sealed class XMLDataSource

Remarks

ActiveReports supports a DataType attribute for nodes in the XML file. This attribute helps ActiveReports determine the data type of bound fields. Valid values include: double, datetime and string.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.XMLDataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Members
GrapeCity.ActiveReports.Data Namespace


XMLDataSource Class Members

[image]
ActiveReports 13
XMLDataSource Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

The following tables list the members exposed by XMLDataSource.

Public Constructors

 | Name | Description
Public Constructor | XMLDataSource Constructor | Overloaded. Initializes a new instance of the XMLDataSource class.
Top

Public Properties

 | Name | Description
Public Property | BOF | Determines whether the CurrentPosition is at the first node in the NodeList.
Public Property | Count | Gets the number of nodes (records) in the node list.
Public Property | CurrentPosition | Gets the index of the current node in the NodeList.
Public Property | Document | Returns a reference to the loaded XmlDocument that is used as the data source.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | FileURL | Gets or sets the file name or url used to retrieve the XML document to be used as a data source.
Public Property | NodeList | Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.
Public Property | RecordsetPattern | Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.
Public Property | ValidateOnParse | Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.
Top

Public Methods

 | Name | Description
Public Method | Field | Overloaded. Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).
Public Method | LoadXML | Loads an XML fragment from a string.
Public Method | MoveFirst | Moves the current position to the first node in the NodeList.
Public Method | MoveNext | Moves the CurrentPosition to the next node in the NodeList.
Top

See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


XMLDataSource Constructor

[image]
ActiveReports 13
XMLDataSource Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : XMLDataSource Constructor

Glossary Item Box

Initializes a new instance of the XMLDataSource class.

Overload List

Overload | Description
XMLDataSource Constructor() | Initializes a new instance of the XMLDataSource class.
XMLDataSource Constructor(String,String) | Initializes a new instance of the XMLDataSource class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


XMLDataSource Constructor()

[image]
ActiveReports 13
XMLDataSource Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > XMLDataSource Constructor : XMLDataSource Constructor()

Glossary Item Box

Initializes a new instance of the XMLDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public XMLDataSource()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


XMLDataSource Constructor(String,String)

[image]
ActiveReports 13
XMLDataSource Constructor(String,String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > XMLDataSource Constructor : XMLDataSource Constructor(String,String)

fileUrl
The path to the XML file.
recordsetPattern
The Xpath expression that specifies the record pattern.

Glossary Item Box

Initializes a new instance of the XMLDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileUrl As String, _
   ByVal recordsetPattern As String _
)
C#
public XMLDataSource(
   string fileUrl,
   string recordsetPattern
)

Parameters

fileUrl
The path to the XML file.
recordsetPattern
The Xpath expression that specifies the record pattern.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


XMLDataSource Class Methods

[image]
ActiveReports 13
XMLDataSource Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

For a list of all members of this type, see XMLDataSource members.

Public Methods

 | Name | Description
Public Method | Field | Overloaded. Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).
Public Method | LoadXML | Loads an XML fragment from a string.
Public Method | MoveFirst | Moves the current position to the first node in the NodeList.
Public Method | MoveNext | Moves the CurrentPosition to the next node in the NodeList.
Top

See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


Field Method

[image]
ActiveReports 13
Field Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Field Method

Glossary Item Box

Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).

Overload List

Overload | Description
Field(String,Boolean) | Returns the XML node or nodelist using the specified XPath pattern relative to the current node.
Field(String,Boolean,Boolean) | Returns the XML node or nodelist using the specified XPath pattern relative to the current node. The isOutputformatNull flag specifies whether to use the text of the current node.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)xDS.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


Field(String,Boolean) Method

[image]
ActiveReports 13
Field(String,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > Field Method : Field(String,Boolean) Method

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.

Glossary Item Box

Returns the XML node or nodelist using the specified XPath pattern relative to the current node.

Syntax

Visual Basic (Declaration)
Public Overloads Function Field( _
   ByVal name As String, _
   ByVal asNodeList As Boolean _
) As Object
C#
public object Field(
   string name,
   bool asNodeList
)

Parameters

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


Field(String,Boolean,Boolean) Method

[image]
ActiveReports 13
Field(String,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > Field Method : Field(String,Boolean,Boolean) Method

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.
isOutputformatNull
Specifies whether to use the text of the current node.

Glossary Item Box

Returns the XML node or nodelist using the specified XPath pattern relative to the current node. The isOutputformatNull flag specifies whether to use the text of the current node.

Syntax

Visual Basic (Declaration)
Public Overloads Function Field( _
   ByVal name As String, _
   ByVal asNodeList As Boolean, _
   ByVal isOutputformatNull As Boolean _
) As Object
C#
public object Field(
   string name,
   bool asNodeList,
   bool isOutputformatNull
)

Parameters

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.
isOutputformatNull
Specifies whether to use the text of the current node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


LoadXML Method

[image]
ActiveReports 13
LoadXML Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : LoadXML Method

xmlFragment
Specifies a valid XML fragment string to be loaded into the XML document.

Glossary Item Box

Loads an XML fragment from a string.

Syntax

Visual Basic (Declaration)
Public Sub LoadXML( _
   ByVal xmlFragment As String _
)
C#
public void LoadXML(
   string xmlFragment
)

Parameters

xmlFragment
Specifies a valid XML fragment string to be loaded into the XML document.

Remarks

The XML is parsed and used as the XML document source.

Example

Paste into the ReportStart event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource ds = new GrapeCity.ActiveReports.Data.XMLDataSource();
    ds.ValidateOnParse = true;
    ds.FileURL = null;
    ds.RecordsetPattern = "//Customer";
    ds.LoadXML("<Order><Customer><Name>John Doe</Name><Cardnum>131 131 131 131</Cardnum><Manifest><Item><ID>204</ID><Title>Advanced VB</Title><Quantity>1</Quantity><UnitPrice>$10.75</UnitPrice></Item></Manifest><Receipt><Subtotal>$23.75</Subtotal><Tax>$2.43</Tax></Receipt></Customer></Order>");
Paste into the ReportStart event.
Visual Basic Copy Code
Dim ds As New GrapeCity.ActiveReports.Data.XMLDataSource
    ds.FileURL = Nothing
    ds.ValidateOnParse = True
    ds.RecordsetPattern = "//Customer"
    ds.LoadXML("<Order>" & _
        "<Customer>" & _
        "<Name>John Doe</Name>" & _
        "<Cardnum>131 131 131 131</Cardnum>" & _
        "<Manifest>" & _
        "<Item>" & _
        "<ID>204</ID>" & _
        "<Title>Advanced VB</Title>" & _
        "<Quantity>1</Quantity>" & _
        "<UnitPrice>$10.75</UnitPrice>" & _
        "</Item>" & _
        "</Manifest>" & _
        "<Receipt>" & _
        "<Subtotal>$23.75</Subtotal>" & _
        "<Tax>$2.43</Tax>" & _
        "</Receipt>" & _
        "</Customer>" & _
        "</Order>")

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


MoveFirst Method

[image]
ActiveReports 13
MoveFirst Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : MoveFirst Method

Glossary Item Box

Moves the current position to the first node in the NodeList.

Syntax

Visual Basic (Declaration)
Public Sub MoveFirst()
C#
public void MoveFirst()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


MoveNext Method

[image]
ActiveReports 13
MoveNext Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : MoveNext Method

Glossary Item Box

Moves the CurrentPosition to the next node in the NodeList.

Syntax

Visual Basic (Declaration)
Public Sub MoveNext()
C#
public void MoveNext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


XMLDataSource Class Properties

[image]
ActiveReports 13
XMLDataSource Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

Glossary Item Box

For a list of all members of this type, see XMLDataSource members.

Public Properties

 | Name | Description
Public Property | BOF | Determines whether the CurrentPosition is at the first node in the NodeList.
Public Property | Count | Gets the number of nodes (records) in the node list.
Public Property | CurrentPosition | Gets the index of the current node in the NodeList.
Public Property | Document | Returns a reference to the loaded XmlDocument that is used as the data source.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | FileURL | Gets or sets the file name or url used to retrieve the XML document to be used as a data source.
Public Property | NodeList | Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.
Public Property | RecordsetPattern | Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.
Public Property | ValidateOnParse | Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.
Top

See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


BOF Property

[image]
ActiveReports 13
BOF Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : BOF Property

Glossary Item Box

Determines whether the CurrentPosition is at the first node in the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BOF As Boolean
C#
public bool BOF {get;}

Property Value

Boolean. True if the CurrentPostion is at the first node in the NodeList; otherwise, False.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


Count Property

[image]
ActiveReports 13
Count Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Count Property

Glossary Item Box

Gets the number of nodes (records) in the node list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

Integer.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


CurrentPosition Property

[image]
ActiveReports 13
CurrentPosition Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : CurrentPosition Property

Glossary Item Box

Gets the index of the current node in the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPosition As Integer
C#
public int CurrentPosition {get;}

Property Value

A long value that represents the current node in the NodeList.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


Document Property

[image]
ActiveReports 13
Document Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Document Property

Glossary Item Box

Returns a reference to the loaded XmlDocument that is used as the data source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As XmlDocument
C#
public XmlDocument Document {get;}

Example

C# Copy Code
Private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show (this.ds.Document.BaseURI.ToString());
}
Visual Basic Copy Code
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    MsgBox(Me.ds.Document.BaseURI.ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


EOF Property

[image]
ActiveReports 13
EOF Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : EOF Property

Glossary Item Box

Determines whether the CurrentPosition is at the end of the NodeList.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EOF As Boolean
C#
public bool EOF {get;}

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


FileURL Property

[image]
ActiveReports 13
FileURL Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : FileURL Property

Glossary Item Box

Gets or sets the file name or url used to retrieve the XML document to be used as a data source.

Syntax

Visual Basic (Declaration)
Public Property FileURL As String
C#
public string FileURL {get; set;}

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


NodeList Property

[image]
ActiveReports 13
NodeList Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : NodeList Property

Glossary Item Box

Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.

Syntax

Visual Basic (Declaration)
Public Property NodeList As XmlNodeList
C#
public XmlNodeList NodeList {get; set;}

Property Value

An XmlNodeList object.

Remarks

You can set the NodeList property to your own XmlNodeList object without setting the FileURL or RecordsetPattern. This can be useful in subreports where the parent report sets the NodeList of the subreport data source from one of its fields (returned from the Field method as an XmlNodeList).

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


RecordsetPattern Property

[image]
ActiveReports 13
RecordsetPattern Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : RecordsetPattern Property

Glossary Item Box

Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.

Syntax

Visual Basic (Declaration)
Public Property RecordsetPattern As String
C#
public string RecordsetPattern {get; set;}

Remarks

The report uses each node selected in the RecordSetPattern to create a detail section.

Note: XSL patterns are case sensitive and must use valid XSL syntax. XSL and XPath documentation can be found on MSDN at http://msdn.microsoft.com/en-us/library/ms256172%28v=vs.110%29.aspx and http://msdn.microsoft.com/en-us/library/ms256471%28v=vs.110%29.aspx

Typical XSL patterns:

Pattern Description

//* All Nodes
//ITEM All ITEM Nodes
/ Root item
/LAYOUT/ITEM/* All child nodes of /LAYOUT/ITEM
//ITEM[@type] All item nodes that contain the type attribute
//ITEM[@id="1"] All item nodes that have an id attribute value of "1"

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


ValidateOnParse Property

[image]
ActiveReports 13
ValidateOnParse Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : ValidateOnParse Property

Glossary Item Box

Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.

Syntax

Visual Basic (Declaration)
Public Property ValidateOnParse As Boolean
C#
public bool ValidateOnParse {get; set;}

Property Value

Boolean.

Example

Paste into the Detail Format event.
C# Copy Code
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
Visual Basic Copy Code
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XMLDataSource Class
XMLDataSource Members


FieldTypeEnum Enumeration

[image]
ActiveReports 13
FieldTypeEnum Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace : FieldTypeEnum Enumeration

Glossary Item Box

Provides a set of values for use with the FieldType property of the Field class.

Syntax

Visual Basic (Declaration)
Public Enum FieldTypeEnum
   Inherits System.Enum
C#
public enum FieldTypeEnum : System.Enum

Members

Member | Description
Boolean | Specifies that the field contains a Boolean value.
Date | Specifies that the field contains a date value.
Double | Specifies that the field contains a double value.
Float | Specifies that the field contains a float value.
Int32 | Specifies that the field contains an integer value.
None | No type is specified for the data value.
String | Specifies that the field contains a string value.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Data.FieldTypeEnum

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Data Namespace


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports)

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Document Namespace

Glossary Item Box

The Grape.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.

Classes

 | Class | Description
Class | PageDocument | Provides the capabilities necessary for processing a report.

See Also

Reference

GrapeCity.ActiveReports Assembly


PageDocument Class

[image]
ActiveReports 13
PageDocument Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

Provides the capabilities necessary for processing a report.

Object Model

PageDocument Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageDocument
C#
public sealed class PageDocument

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.PageDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Members
GrapeCity.ActiveReports.Document Namespace


PageDocument Class Members

[image]
ActiveReports 13
PageDocument Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

The following tables list the members exposed by PageDocument.

Public Constructors

 | Name | Description
Public Constructor | PageDocument Constructor | Initializes a new instance of PageDocument Class.
Top

Public Properties

 | Name | Description
Public Property | IsEmpty | Returns True if the report contains no data.
Public Property | LocateDataSourceFn | Gets the data source locator
Public Property | PageReport | Gets the ReportDefinition for the report.
Public Property | Parameters | Gets the parameters for the report.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Gets a reference to the document's print options.
Public Property | ResolveCredentialsFn | Gets the credentials locator
Top

Public Methods

 | Name | Description
Public Method | ApplyInteractivity | Interactivity actions to be applied to report instance next during rendering.
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
Public Method | InitializeReportHandlers | Sets the handlers to document
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension.
Public Method | ResetPrinter | Resets the printer properties.
Top

Public Events

 | Name | Description
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | LocateDataSource | Occurs when the report needs to locate a data source with from the calling application.
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


PageDocument Constructor

[image]
ActiveReports 13
PageDocument Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PageDocument Constructor

pageReport

Glossary Item Box

Initializes a new instance of PageDocument Class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageReport As PageReport _
)
C#
public PageDocument(
   PageReport pageReport
)

Parameters

pageReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Methods

[image]
ActiveReports 13
PageDocument Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

For a list of all members of this type, see PageDocument members.

Public Methods

 | Name | Description
Public Method | ApplyInteractivity | Interactivity actions to be applied to report instance next during rendering.
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
Public Method | InitializeReportHandlers | Sets the handlers to document
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension.
Public Method | ResetPrinter | Resets the printer properties.
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


ApplyInteractivity Method

[image]
ActiveReports 13
ApplyInteractivity Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : ApplyInteractivity Method

actions
The interactive actions to be applied.

Glossary Item Box

Interactivity actions to be applied to report instance next during rendering.

Syntax

Visual Basic (Declaration)
Public Sub ApplyInteractivity( _
   ByVal actions As GrapeCity.ActiveReports.Document.InteractiveActions _
)
C#
public void ApplyInteractivity(
   GrapeCity.ActiveReports.Document.InteractiveActions actions
)

Parameters

actions
The interactive actions to be applied.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Dispose Method

Glossary Item Box

Performs tasks associated with freeing and releasing resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


InitializeReportHandlers Method

[image]
ActiveReports 13
InitializeReportHandlers Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : InitializeReportHandlers Method

document

Glossary Item Box

Sets the handlers to document

Syntax

Visual Basic (Declaration)
Public Sub InitializeReportHandlers( _
   ByVal document As PageDocument _
)
C#
public void InitializeReportHandlers(
   PageDocument document
)

Parameters

document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Render Method

[image]
ActiveReports 13
Render Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Render Method

Glossary Item Box

Provides the output of the report to the specified rendering extension.

Overload List

Overload | Description
Render(IRenderingExtension,StreamProvider) | Provides the output of the report to the specified rendering extension.
Render(IRenderingExtension,StreamProvider,NameValueCollection) | Provides the output of the report to the specified rendering extension with the specified values.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) | Provides the output of this report to the specified rendering extension with the specified values and refreshed data.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) | Provides the output of this report to the specified rendering extension with the specified values and refreshed data.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) | Provides the output of this report to the specified rendering extension with the specified values and refreshed data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Render(IRenderingExtension,StreamProvider) Method

[image]
ActiveReports 13
Render(IRenderingExtension,StreamProvider) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider) Method

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.

Glossary Item Box

Provides the output of the report to the specified rendering extension.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

[image]
ActiveReports 13
Render(IRenderingExtension,StreamProvider,NameValueCollection) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.

Glossary Item Box

Provides the output of the report to the specified rendering extension with the specified values.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams,
   NameValueCollection settings
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method

[image]
ActiveReports 13
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.

Glossary Item Box

Provides the output of this report to the specified rendering extension with the specified values and refreshed data.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal forceDataRefresh As Boolean _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams,
   NameValueCollection settings,
   bool forceDataRefresh
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method

[image]
ActiveReports 13
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
forceParameterDataRefresh
Set to True to force a refresh or requery of the parameter data.

Glossary Item Box

Provides the output of this report to the specified rendering extension with the specified values and refreshed data.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal forceDataRefresh As Boolean, _
   ByVal forceParameterDataRefresh As Boolean _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams,
   NameValueCollection settings,
   bool forceDataRefresh,
   bool forceParameterDataRefresh
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
forceParameterDataRefresh
Set to True to force a refresh or requery of the parameter data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) Method

[image]
ActiveReports 13
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean,CancellationToken) Method

renderingExtension
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
forceParameterDataRefresh
Set to True to force a refresh or requery of the parameter data.
token
Allows to stop rendering

Glossary Item Box

Provides the output of this report to the specified rendering extension with the specified values and refreshed data.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection, _
   ByVal forceDataRefresh As Boolean, _
   ByVal forceParameterDataRefresh As Boolean, _
   ByVal token As CancellationToken _
)
C#
public void Render(
   IRenderingExtension renderingExtension,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams,
   NameValueCollection settings,
   bool forceDataRefresh,
   bool forceParameterDataRefresh,
   CancellationToken token
)

Parameters

renderingExtension
streams
The GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
forceParameterDataRefresh
Set to True to force a refresh or requery of the parameter data.
token
Allows to stop rendering

Exceptions

Exception | Description
System.ArgumentNullException | renderingExtension or streams is null.
GrapeCity.ActiveReports.ReportException | A report specific error occured.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members
Overload List


ResetPrinter Method

[image]
ActiveReports 13
ResetPrinter Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : ResetPrinter Method

Glossary Item Box

Resets the printer properties.

Syntax

Visual Basic (Declaration)
Public Sub ResetPrinter()
C#
public void ResetPrinter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Properties

[image]
ActiveReports 13
PageDocument Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

For a list of all members of this type, see PageDocument members.

Public Properties

 | Name | Description
Public Property | IsEmpty | Returns True if the report contains no data.
Public Property | LocateDataSourceFn | Gets the data source locator
Public Property | PageReport | Gets the ReportDefinition for the report.
Public Property | Parameters | Gets the parameters for the report.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Gets a reference to the document's print options.
Public Property | ResolveCredentialsFn | Gets the credentials locator
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


IsEmpty Property

[image]
ActiveReports 13
IsEmpty Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : IsEmpty Property

Glossary Item Box

Returns True if the report contains no data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


LocateDataSourceFn Property

[image]
ActiveReports 13
LocateDataSourceFn Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateDataSourceFn Property

Glossary Item Box

Gets the data source locator

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LocateDataSourceFn As Func(Of LocateDataSourceArgs,Object)
C#
public Func<LocateDataSourceArgs,object> LocateDataSourceFn {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageReport Property

[image]
ActiveReports 13
PageReport Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PageReport Property

Glossary Item Box

Gets the ReportDefinition for the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageReport As PageReport
C#
public PageReport PageReport {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Parameters Property

[image]
ActiveReports 13
Parameters Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Parameters Property

Glossary Item Box

Gets the parameters for the report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterCollection
C#
public GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterCollection Parameters {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


Printer Property

[image]
ActiveReports 13
Printer Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Printer Property

Glossary Item Box

Gets a reference to the document's printer settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Printer As Printer
C#
public Printer Printer {get;}

Remarks

Use this property to set the printer options before displaying a print dialog or directly printing the document to the printer with the specified options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintOptions Property

[image]
ActiveReports 13
PrintOptions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintOptions Property

Glossary Item Box

Gets a reference to the document's print options.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOptions As PrintOptions
C#
public PrintOptions PrintOptions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


ResolveCredentialsFn Property

[image]
ActiveReports 13
ResolveCredentialsFn Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : ResolveCredentialsFn Property

Glossary Item Box

Gets the credentials locator

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolveCredentialsFn As GrapeCity.ActiveReports.Rendering.ResolveCredentials
C#
public GrapeCity.ActiveReports.Rendering.ResolveCredentials ResolveCredentialsFn {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Events

[image]
ActiveReports 13
PageDocument Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

Glossary Item Box

For a list of all members of this type, see PageDocument members.

Public Events

 | Name | Description
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | LocateDataSource | Occurs when the report needs to locate a data source with from the calling application.
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top

See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


LocateCredentials Event

[image]
ActiveReports 13
LocateCredentials Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateCredentials Event

Glossary Item Box

Occurs when the report needs to obtain data source credentials from the calling application.

Syntax

Visual Basic (Declaration)
Public Event LocateCredentials As LocateCredentialsEventHandler
C#
public event LocateCredentialsEventHandler LocateCredentials

Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSource | Gets the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


LocateDataSource Event

[image]
ActiveReports 13
LocateDataSource Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateDataSource Event

Glossary Item Box

Occurs when the report needs to locate a data source with from the calling application.

Syntax

Visual Basic (Declaration)
Public Event LocateDataSource As LocateDataSourceEventHandler
C#
public event LocateDataSourceEventHandler LocateDataSource

Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Parameters | Gets the Parameters collection specified for a given report instance.
Report | Gets the Report that is trying to locate the data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintAborted Event

[image]
ActiveReports 13
PrintAborted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintAborted Event

Glossary Item Box

Occurs if the user clicks the Abort button on the status dialog.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As PrintAbortedEventHandler
C#
public event PrintAbortedEventHandler PrintAborted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintingThreadErrorEvent Event

[image]
ActiveReports 13
PrintingThreadErrorEvent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintingThreadErrorEvent Event

Glossary Item Box

Occurs when an exception is thrown by the printing thread.

Syntax

Visual Basic (Declaration)
Public Event PrintingThreadErrorEvent As PrintingThreadErrorEventHandler
C#
public event PrintingThreadErrorEventHandler PrintingThreadErrorEvent

Event Data

The event handler receives an argument of type PrintingThreadErrorEventArgs containing data related to this event. The following PrintingThreadErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the printing thread exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


PrintProgress Event

[image]
ActiveReports 13
PrintProgress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintProgress Event

Glossary Item Box

Occurs when the document pages are printing.

Syntax

Visual Basic (Declaration)
Public Event PrintProgress As PrintProgressEventHandler
C#
public event PrintProgressEventHandler PrintProgress

Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the current printing page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDocument Class
PageDocument Members


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports)

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Export Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.

Interfaces

 | Interface | Description
Interface | IDocumentExportEx | Provides a common interface for all the export filters.

See Also

Reference

GrapeCity.ActiveReports Assembly


IDocumentExportEx Interface

[image]
ActiveReports 13
IDocumentExportEx Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface

Glossary Item Box

Provides a common interface for all the export filters.

Syntax

Visual Basic (Declaration)
Public Interface IDocumentExportEx
   Inherits IDocumentExport
C#
public interface IDocumentExportEx : IDocumentExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Members
GrapeCity.ActiveReports.Export Namespace


IDocumentExportEx Interface Members

[image]
ActiveReports 13
IDocumentExportEx Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface

Glossary Item Box

The following tables list the members exposed by IDocumentExportEx.

Public Methods

 | Name | Description
Method | Export | Overloaded. Exports the specified document to HTML.
Top

See Also

Reference

IDocumentExportEx Interface
GrapeCity.ActiveReports.Export Namespace


IDocumentExportEx Interface Methods

[image]
ActiveReports 13
IDocumentExportEx Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface

Glossary Item Box

For a list of all members of this type, see IDocumentExportEx members.

Public Methods

 | Name | Description
Method | Export | Overloaded. Exports the specified document to HTML.
Top

See Also

Reference

IDocumentExportEx Interface
GrapeCity.ActiveReports.Export Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface : Export Method

Glossary Item Box

Exports the specified document to HTML.

Overload List

Overload | Description
Export(PageDocument,String,String) | Exports the specified range of pages to an HTML file.
Export(PageDocument,String) | Exports the entire ActiveReports document to the specified HTML file.
Export(PageDocument,Stream) | Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(PageDocument,Stream,String) | Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members


Export(PageDocument,String,String) Method

[image]
ActiveReports 13
Export(PageDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,String,String) Method

document
Page document to export.
filePath
The path to the file to save exported result to.
pageRange
The page range to export.

Glossary Item Box

Exports the specified range of pages to an HTML file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
void Export(
   PageDocument document,
   string filePath,
   string pageRange
)

Parameters

document
Page document to export.
filePath
The path to the file to save exported result to.
pageRange
The page range to export.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(PageDocument,String) Method

[image]
ActiveReports 13
Export(PageDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,String) Method

document
Page document to export.
filePath
The path to the file to save exported result to.

Glossary Item Box

Exports the entire ActiveReports document to the specified HTML file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String _
)
C#
void Export(
   PageDocument document,
   string filePath
)

Parameters

document
Page document to export.
filePath
The path to the file to save exported result to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(PageDocument,Stream) Method

[image]
ActiveReports 13
Export(PageDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,Stream) Method

document
Page document to export.
outputStream
The stream to write the output to.

Glossary Item Box

Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal outputStream As Stream _
)
C#
void Export(
   PageDocument document,
   Stream outputStream
)

Parameters

document
Page document to export.
outputStream
The stream to write the output to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(PageDocument,Stream,String) Method

[image]
ActiveReports 13
Export(PageDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,Stream,String) Method

document
Page document to export.
outputStream
The stream to write the output to.
pageRange
The page range to export.

Glossary Item Box

Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
void Export(
   PageDocument document,
   Stream outputStream,
   string pageRange
)

Parameters

document
Page document to export.
outputStream
The stream to write the output to.
pageRange
The page range to export.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,String,String) Method

[image]
ActiveReports 13
Export(IReport,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,String,String) Method

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath,
   string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,String) Method

[image]
ActiveReports 13
Export(IReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,String) Method

report
IReport instance to Export
filePath
Path to export

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String _
)
C#
void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,Stream) Method

[image]
ActiveReports 13
Export(IReport,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,Stream) Method

report
IReport instance to Export
outputStream
Stream to export

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream _
)
C#
void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
Stream to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,Stream,String) Method

[image]
ActiveReports 13
Export(IReport,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,Stream,String) Method

report
IReport instance to Export
outputStream
Stream to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream,
   string pageRange
)

Parameters

report
IReport instance to Export
outputStream
Stream to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


GrapeCity.ActiveReports.Extensibility.Data Namespace

GrapeCity.ActiveReports.Extensibility.Data Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Extensibility.Data Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DataRow | Data row.
Class | DataTable | Represents result set of query execution.

Interfaces

 | Interface | Description
Interface | IDataParameter | Represents a parameter used with a IDbCommand.
Interface | IDataParameterCollection | Represents a collection of IDataParameter objects.
Interface | IDbSchemaProvider | Specifies the schema provider.

Structures

 | Structure | Description
Structure | DataColumn | Data column.

See Also

Reference

GrapeCity.ActiveReports Assembly


DataRow Class

[image]
ActiveReports 13
DataRow Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

Glossary Item Box

Data row.

Object Model

DataRow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataRow
C#
public sealed class DataRow

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataRow Class Members

[image]
ActiveReports 13
DataRow Class Members
See Also Fields
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

Glossary Item Box

The following tables list the members exposed by DataRow.

Public Constructors

 | Name | Description
Public Constructor | DataRow Constructor | Creates new instance of DataRow.
Top

Public Fields

 | Name | Description
Public Field | Values | The row data.
Top

See Also

Reference

DataRow Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataRow Constructor

[image]
ActiveReports 13
DataRow Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataRow Class : DataRow Constructor

values
The row data.

Glossary Item Box

Creates new instance of DataRow.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal values() As Object _
)
C#
public DataRow(
   object[] values
)

Parameters

values
The row data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Class
DataRow Members


DataRow Class Fields

[image]
ActiveReports 13
DataRow Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

Glossary Item Box

For a list of all members of this type, see DataRow members.

Public Fields

 | Name | Description
Public Field | Values | The row data.
Top

See Also

Reference

DataRow Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


Values Field

[image]
ActiveReports 13
Values Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataRow Class : Values Field

Glossary Item Box

The row data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Values As Object()
C#
public readonly object[] Values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataRow Class
DataRow Members


DataTable Class

[image]
ActiveReports 13
DataTable Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

Glossary Item Box

Represents result set of query execution.

Object Model

DataTable Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataTable
C#
public sealed class DataTable

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataTable Class Members

[image]
ActiveReports 13
DataTable Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

Glossary Item Box

The following tables list the members exposed by DataTable.

Public Constructors

 | Name | Description
Public Constructor | DataTable Constructor | Creates new instance of DataTable.
Top

Public Properties

 | Name | Description
Public Property | Columns | Gets table columns.
Public Property | Rows | Gets table rows.
Top

See Also

Reference

DataTable Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataTable Constructor

[image]
ActiveReports 13
DataTable Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : DataTable Constructor

columns
The table columns.
rows
The table rows.

Glossary Item Box

Creates new instance of DataTable.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columns As IEnumerable(Of DataColumn), _
   ByVal rows As IEnumerable(Of DataRow) _
)
C#
public DataTable(
   IEnumerable<DataColumn> columns,
   IEnumerable<DataRow> rows
)

Parameters

columns
The table columns.
rows
The table rows.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Class
DataTable Members


DataTable Class Properties

[image]
ActiveReports 13
DataTable Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

Glossary Item Box

For a list of all members of this type, see DataTable members.

Public Properties

 | Name | Description
Public Property | Columns | Gets table columns.
Public Property | Rows | Gets table rows.
Top

See Also

Reference

DataTable Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


Columns Property

[image]
ActiveReports 13
Columns Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : Columns Property

Glossary Item Box

Gets table columns.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of DataColumn)
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<DataColumn> Columns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Class
DataTable Members


Rows Property

[image]
ActiveReports 13
Rows Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : Rows Property

Glossary Item Box

Gets table rows.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rows As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of DataRow)
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<DataRow> Rows {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTable Class
DataTable Members


DataColumn Structure

[image]
ActiveReports 13
DataColumn Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

Glossary Item Box

Data column.

Object Model

DataColumn Structure

Syntax

Visual Basic (Declaration)
Public Structure DataColumn
   Inherits System.ValueType
C#
public struct DataColumn : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Data.DataColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataColumn Structure Members

[image]
ActiveReports 13
DataColumn Structure Members
See Also Fields
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

Glossary Item Box

The following tables list the members exposed by DataColumn.

Public Constructors

 | Name | Description
Public Constructor | DataColumn Constructor | Creates new instance of DataColumn.
Top

Public Fields

 | Name | Description
Public Field | DataType | Specifies data type of the column.
Public Field | Name | Specifies column name.
Top

See Also

Reference

DataColumn Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataColumn Constructor

[image]
ActiveReports 13
DataColumn Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : DataColumn Constructor

name
The column name.
dataType
The column type.

Glossary Item Box

Creates new instance of DataColumn.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dataType As String _
)
C#
public DataColumn(
   string name,
   string dataType
)

Parameters

name
The column name.
dataType
The column type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Structure
DataColumn Members


DataColumn Structure Fields

[image]
ActiveReports 13
DataColumn Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

Glossary Item Box

For a list of all members of this type, see DataColumn members.

Public Fields

 | Name | Description
Public Field | DataType | Specifies data type of the column.
Public Field | Name | Specifies column name.
Top

See Also

Reference

DataColumn Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataType Field

[image]
ActiveReports 13
DataType Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : DataType Field

Glossary Item Box

Specifies data type of the column.

Syntax

Visual Basic (Declaration)
Public ReadOnly DataType As String
C#
public readonly string DataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Structure
DataColumn Members


Name Field

[image]
ActiveReports 13
Name Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : Name Field

Glossary Item Box

Specifies column name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
C#
public readonly string Name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataColumn Structure
DataColumn Members


IDataParameter Interface

[image]
ActiveReports 13
IDataParameter Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

Glossary Item Box

Represents a parameter used with a IDbCommand.

Syntax

Visual Basic (Declaration)
Public Interface IDataParameter
C#
public interface IDataParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameter Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameter Interface Members

[image]
ActiveReports 13
IDataParameter Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

Glossary Item Box

The following tables list the members exposed by IDataParameter.

Public Properties

 | Name | Description
Property | ParameterName | Gets or sets the name of the parameter.
Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

IDataParameter Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameter Interface Properties

[image]
ActiveReports 13
IDataParameter Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

Glossary Item Box

For a list of all members of this type, see IDataParameter members.

Public Properties

 | Name | Description
Property | ParameterName | Gets or sets the name of the parameter.
Property | Value | Gets or sets the value of the parameter.
Top

See Also

Reference

IDataParameter Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


ParameterName Property

[image]
ActiveReports 13
ParameterName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameter Interface : ParameterName Property

Glossary Item Box

Gets or sets the name of the parameter.

Syntax

Visual Basic (Declaration)
Property ParameterName As String
C#
string ParameterName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameter Interface
IDataParameter Members


Value Property

[image]
ActiveReports 13
Value Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameter Interface : Value Property

Glossary Item Box

Gets or sets the value of the parameter.

Syntax

Visual Basic (Declaration)
Property Value As Object
C#
object Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameter Interface
IDataParameter Members


IDataParameterCollection Interface

[image]
ActiveReports 13
IDataParameterCollection Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

Glossary Item Box

Represents a collection of IDataParameter objects.

Syntax

Visual Basic (Declaration)
Public Interface IDataParameterCollection
C#
public interface IDataParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameterCollection Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameterCollection Interface Members

[image]
ActiveReports 13
IDataParameterCollection Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

Glossary Item Box

The following tables list the members exposed by IDataParameterCollection.

Public Methods

 | Name | Description
Method | Add | Adds the specified IDataParameter object to the collection.
Top

See Also

Reference

IDataParameterCollection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameterCollection Interface Methods

[image]
ActiveReports 13
IDataParameterCollection Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

Glossary Item Box

For a list of all members of this type, see IDataParameterCollection members.

Public Methods

 | Name | Description
Method | Add | Adds the specified IDataParameter object to the collection.
Top

See Also

Reference

IDataParameterCollection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameterCollection Interface : Add Method

parameter

Glossary Item Box

Adds the specified IDataParameter object to the collection.

Syntax

Visual Basic (Declaration)
Function Add( _
   ByVal parameter As IDataParameter _
) As Integer
C#
int Add(
   IDataParameter parameter
)

Parameters

parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataParameterCollection Interface
IDataParameterCollection Members


IDbSchemaProvider Interface

[image]
ActiveReports 13
IDbSchemaProvider Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

Glossary Item Box

Specifies the schema provider.

Syntax

Visual Basic (Declaration)
Public Interface IDbSchemaProvider
C#
public interface IDbSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbSchemaProvider Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbSchemaProvider Interface Members

[image]
ActiveReports 13
IDbSchemaProvider Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

Glossary Item Box

The following tables list the members exposed by IDbSchemaProvider.

Public Methods

 | Name | Description
Method | GetSchema | Gets the schema of the specified db connection if it's of the same data provider.
Top

See Also

Reference

IDbSchemaProvider Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbSchemaProvider Interface Methods

[image]
ActiveReports 13
IDbSchemaProvider Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

Glossary Item Box

For a list of all members of this type, see IDbSchemaProvider members.

Public Methods

 | Name | Description
Method | GetSchema | Gets the schema of the specified db connection if it's of the same data provider.
Top

See Also

Reference

IDbSchemaProvider Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


GetSchema Method

[image]
ActiveReports 13
GetSchema Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbSchemaProvider Interface : GetSchema Method

connection
A connection to get schema for.

Glossary Item Box

Gets the schema of the specified db connection if it's of the same data provider.

Syntax

Visual Basic (Declaration)
Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection
A connection to get schema for.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDbSchemaProvider Interface
IDbSchemaProvider Members


GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace

GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Column | Defines a column.
Class | DataSchema | Defines the data schema of database.
Class | DbName | Defines the name of table.
Class | ForeignKey | Defines the foreigh key.
Class | Table | Defines a table.

Enumerations

 | Enumeration | Description
Enumeration | TableType | Defines enumeration of table types.

See Also

Reference

GrapeCity.ActiveReports Assembly


Column Class

[image]
ActiveReports 13
Column Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Column Class

Glossary Item Box

Defines a column.

Object Model

Column Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Column
C#
public sealed class Column

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.Column

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Column Class Members

[image]
ActiveReports 13
Column Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Column Class

Glossary Item Box

The following tables list the members exposed by Column.

Public Constructors

 | Name | Description
Public Constructor | Column Constructor | Initializes a new instance of the Column class.
Top

Public Properties

 | Name | Description
Public Property | DataType | The column data type.
Public Property | IsPrimaryKey | Whether the column is included to primary key.
Public Property | Name | The column name.
Top

See Also

Reference

Column Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Column Constructor

[image]
ActiveReports 13
Column Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : Column Constructor

name
The column name.
dataType
The column data type.
isPrimaryKey
Whether the column is included to primary key.

Glossary Item Box

Initializes a new instance of the Column class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dataType As Type, _
   ByVal isPrimaryKey As Boolean _
)
C#
public Column(
   string name,
   Type dataType,
   bool isPrimaryKey
)

Parameters

name
The column name.
dataType
The column data type.
isPrimaryKey
Whether the column is included to primary key.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


Column Class Properties

[image]
ActiveReports 13
Column Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Column Class

Glossary Item Box

For a list of all members of this type, see Column members.

Public Properties

 | Name | Description
Public Property | DataType | The column data type.
Public Property | IsPrimaryKey | Whether the column is included to primary key.
Public Property | Name | The column name.
Top

See Also

Reference

Column Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DataType Property

[image]
ActiveReports 13
DataType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : DataType Property

Glossary Item Box

The column data type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataType As Type
C#
public Type DataType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


IsPrimaryKey Property

[image]
ActiveReports 13
IsPrimaryKey Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : IsPrimaryKey Property

Glossary Item Box

Whether the column is included to primary key.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPrimaryKey As Boolean
C#
public bool IsPrimaryKey {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Column Class : Name Property

Glossary Item Box

The column name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Column Class
Column Members


DataSchema Class

[image]
ActiveReports 13
DataSchema Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

Defines the data schema of database.

Object Model

DataSchema Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataSchema
C#
public sealed class DataSchema

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.DataSchema

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DataSchema Class Members

[image]
ActiveReports 13
DataSchema Class Members
See Also Fields Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

The following tables list the members exposed by DataSchema.

Public Constructors

 | Name | Description
Public Constructor | DataSchema Constructor | Initializes a new instance of the DataSchema class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents the empty data schema.
Top

Public Properties

 | Name | Description
Public Property | ForeignKeys | The foreight keys collection which has this table as source.
Public Property | Tables | The tables collection
Top

See Also

Reference

DataSchema Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DataSchema Constructor

[image]
ActiveReports 13
DataSchema Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : DataSchema Constructor

tables
The tables collection.
foreighKeys
The foreigh keys collection.

Glossary Item Box

Initializes a new instance of the DataSchema class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tables As IEnumerable(Of Table), _
   ByVal foreighKeys As IEnumerable(Of ForeignKey) _
)
C#
public DataSchema(
   IEnumerable<Table> tables,
   IEnumerable<ForeignKey> foreighKeys
)

Parameters

tables
The tables collection.
foreighKeys
The foreigh keys collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


DataSchema Class Properties

[image]
ActiveReports 13
DataSchema Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

For a list of all members of this type, see DataSchema members.

Public Properties

 | Name | Description
Public Property | ForeignKeys | The foreight keys collection which has this table as source.
Public Property | Tables | The tables collection
Top

See Also

Reference

DataSchema Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


ForeignKeys Property

[image]
ActiveReports 13
ForeignKeys Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : ForeignKeys Property

Glossary Item Box

The foreight keys collection which has this table as source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ForeignKeys As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of ForeignKey)
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ForeignKey> ForeignKeys {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


Tables Property

[image]
ActiveReports 13
Tables Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : Tables Property

Glossary Item Box

The tables collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tables As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of Table)
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<Table> Tables {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


DataSchema Class Fields

[image]
ActiveReports 13
DataSchema Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DataSchema Class

Glossary Item Box

For a list of all members of this type, see DataSchema members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents the empty data schema.
Top

See Also

Reference

DataSchema Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DataSchema Class : Empty Field

Glossary Item Box

Represents the empty data schema.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As DataSchema
C#
public static readonly DataSchema Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSchema Class
DataSchema Members


DbName Class

[image]
ActiveReports 13
DbName Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

Defines the name of table.

Object Model

DbName Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DbName
C#
public sealed class DbName

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.DbName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DbName Class Members

[image]
ActiveReports 13
DbName Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

The following tables list the members exposed by DbName.

Public Constructors

 | Name | Description
Public Constructor | DbName Constructor | Initializes a new instance of the DbName class.
Top

Public Properties

 | Name | Description
Public Property | Name | The name of table.
Public Property | Schema | The schema name.
Top

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

DbName Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


DbName Constructor

[image]
ActiveReports 13
DbName Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : DbName Constructor

name
The name of table.
schema
The schema name.

Glossary Item Box

Initializes a new instance of the DbName class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal schema As String _
)
C#
public DbName(
   string name,
   string schema
)

Parameters

name
The name of table.
schema
The schema name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


DbName Class Methods

[image]
ActiveReports 13
DbName Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

For a list of all members of this type, see DbName members.

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

DbName Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Equals(Object) Method

[image]
ActiveReports 13
Equals(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : Equals(Object) Method

obj
The System.Object to compare with the current System.Object.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


DbName Class Properties

[image]
ActiveReports 13
DbName Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : DbName Class

Glossary Item Box

For a list of all members of this type, see DbName members.

Public Properties

 | Name | Description
Public Property | Name | The name of table.
Public Property | Schema | The schema name.
Top

See Also

Reference

DbName Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : Name Property

Glossary Item Box

The name of table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


Schema Property

[image]
ActiveReports 13
Schema Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : Schema Property

Glossary Item Box

The schema name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schema As String
C#
public string Schema {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


ForeignKey Class

[image]
ActiveReports 13
ForeignKey Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : ForeignKey Class

Glossary Item Box

Defines the foreigh key.

Object Model

ForeignKey Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ForeignKey
C#
public sealed class ForeignKey

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.ForeignKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


ForeignKey Class Members

[image]
ActiveReports 13
ForeignKey Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : ForeignKey Class

Glossary Item Box

The following tables list the members exposed by ForeignKey.

Public Constructors

 | Name | Description
Public Constructor | ForeignKey Constructor | Initializes a new instance of the ForeignKey class.
Top

Public Properties

 | Name | Description
Public Property | Destination | The destination table.
Public Property | DestinationColumns | The columnts that defines a destination.
Public Property | Source | The source table.
Public Property | SourceColumns | The columns that defines a source.
Top

See Also

Reference

ForeignKey Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


ForeignKey Constructor

[image]
ActiveReports 13
ForeignKey Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : ForeignKey Constructor

source
The source table.
destination
The destination table.
sourceColumns
The columns that defines a source.
destinationColumns
The columnts that defines a destination.

Glossary Item Box

Initializes a new instance of the ForeignKey class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As Table, _
   ByVal destination As Table, _
   ByVal sourceColumns As IEnumerable(Of Column), _
   ByVal destinationColumns As IEnumerable(Of Column) _
)
C#
public ForeignKey(
   Table source,
   Table destination,
   IEnumerable<Column> sourceColumns,
   IEnumerable<Column> destinationColumns
)

Parameters

source
The source table.
destination
The destination table.
sourceColumns
The columns that defines a source.
destinationColumns
The columnts that defines a destination.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


ForeignKey Class Properties

[image]
ActiveReports 13
ForeignKey Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : ForeignKey Class

Glossary Item Box

For a list of all members of this type, see ForeignKey members.

Public Properties

 | Name | Description
Public Property | Destination | The destination table.
Public Property | DestinationColumns | The columnts that defines a destination.
Public Property | Source | The source table.
Public Property | SourceColumns | The columns that defines a source.
Top

See Also

Reference

ForeignKey Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Destination Property

[image]
ActiveReports 13
Destination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : Destination Property

Glossary Item Box

The destination table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Table
C#
public Table Destination {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


DestinationColumns Property

[image]
ActiveReports 13
DestinationColumns Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : DestinationColumns Property

Glossary Item Box

The columnts that defines a destination.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DestinationColumns As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of Column)
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<Column> DestinationColumns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : Source Property

Glossary Item Box

The source table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As Table
C#
public Table Source {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


SourceColumns Property

[image]
ActiveReports 13
SourceColumns Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > ForeignKey Class : SourceColumns Property

Glossary Item Box

The columns that defines a source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourceColumns As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of Column)
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<Column> SourceColumns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForeignKey Class
ForeignKey Members


Table Class

[image]
ActiveReports 13
Table Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

Defines a table.

Object Model

Table Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Table
C#
public sealed class Table

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.Table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Members
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Table Class Members

[image]
ActiveReports 13
Table Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

The following tables list the members exposed by Table.

Public Constructors

 | Name | Description
Public Constructor | Table Constructor | Initializes a new instance of the Table class.
Top

Public Properties

 | Name | Description
Public Property | Columns | The table colums collection.
Public Property | Name | The name of table
Public Property | TableType | The table type.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.
Public Method | GetHashCode | Returns a System.Int32 that represents a hash code for the current object.
Public Method | ToString | Returns a System.String that represents this instance.
Top

Public Operators

public Operator Equality | Returns a System.Boolean. This is true if the first Table is equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.
public Operator Inequality | Returns a System.Boolean. This is true if the first Table is not equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Table Constructor

[image]
ActiveReports 13
Table Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Table Constructor

name
The name of the table.
tableType
The table type.
columns
The table colums collection.

Glossary Item Box

Initializes a new instance of the Table class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As DbName, _
   ByVal tableType As TableType, _
   ByVal columns As IEnumerable(Of Column) _
)
C#
public Table(
   DbName name,
   TableType tableType,
   IEnumerable<Column> columns
)

Parameters

name
The name of the table.
tableType
The table type.
columns
The table colums collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Methods

[image]
ActiveReports 13
Table Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.
Public Method | GetHashCode | Returns a System.Int32 that represents a hash code for the current object.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Equals Method

Glossary Item Box

Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.

Overload List

Overload | Description
Equals(Table) | Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.
Equals(Object) | Returns a System.Boolean. This is true if the specified Object is equal to the current Table; otherwise, false. The object for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Equals(Table) Method

[image]
ActiveReports 13
Equals(Table) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class > Equals Method : Equals(Table) Method

anotherTable
The table for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the specified Table is equal to the current Table; otherwise, false. The table for comparison.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal anotherTable As Table _
) As Boolean
C#
public bool Equals(
   Table anotherTable
)

Parameters

anotherTable
The table for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members
Overload List


Equals(Object) Method

[image]
ActiveReports 13
Equals(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class > Equals Method : Equals(Object) Method

obj
The object for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the specified Object is equal to the current Table; otherwise, false. The object for comparison.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members
Overload List


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : GetHashCode Method

Glossary Item Box

Returns a System.Int32 that represents a hash code for the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Table Class Properties

[image]
ActiveReports 13
Table Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : Table Class

Glossary Item Box

For a list of all members of this type, see Table members.

Public Properties

 | Name | Description
Public Property | Columns | The table colums collection.
Public Property | Name | The name of table
Public Property | TableType | The table type.
Top

See Also

Reference

Table Class
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


Columns Property

[image]
ActiveReports 13
Columns Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Columns Property

Glossary Item Box

The table colums collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of Column)
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<Column> Columns {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Name Property

Glossary Item Box

The name of table

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As DbName
C#
public DbName Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableType Property

[image]
ActiveReports 13
TableType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : TableType Property

Glossary Item Box

The table type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableType As TableType
C#
public TableType TableType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Equality Operator

[image]
ActiveReports 13
Equality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Equality Operator

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the first Table is equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal firstTable As Table, _
   ByVal secondTable As Table _
) As Boolean
C#
public bool operator ==(
   Table firstTable,
   Table secondTable
)

Parameters

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


Inequality Operator

[image]
ActiveReports 13
Inequality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > Table Class : Inequality Operator

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Glossary Item Box

Returns a System.Boolean. This is true if the first Table is not equal to the second Table; otherwise, false. The first table for comparison. The second table for comparison.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal firstTable As Table, _
   ByVal secondTable As Table _
) As Boolean
C#
public bool operator !=(
   Table firstTable,
   Table secondTable
)

Parameters

firstTable
The first table for comparison.
secondTable
The second table for comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Table Class
Table Members


TableType Enumeration

[image]
ActiveReports 13
TableType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace : TableType Enumeration

Glossary Item Box

Defines enumeration of table types.

Syntax

Visual Basic (Declaration)
Public Enum TableType
   Inherits System.Enum
C#
public enum TableType : System.Enum

Members

Member | Description
Table | Table
View | View

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.TableType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace


GrapeCity.ActiveReports.Extensibility.Rendering Namespace

GrapeCity.ActiveReports.Extensibility.Rendering Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Extensibility.Rendering Namespace

Glossary Item Box

Interfaces

 | Interface | Description
Interface | IConfigurable | Interface for configurable components.
Interface | IRenderingExtension | Interface for rendering extention objects.

See Also

Reference

GrapeCity.ActiveReports Assembly


IConfigurable Interface

[image]
ActiveReports 13
IConfigurable Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

Glossary Item Box

Interface for configurable components.

Syntax

Visual Basic (Declaration)
Public Interface IConfigurable
C#
public interface IConfigurable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IConfigurable Interface Members

[image]
ActiveReports 13
IConfigurable Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

Glossary Item Box

The following tables list the members exposed by IConfigurable.

Public Methods

 | Name | Description
Method | GetSupportedSettings | Overloaded. Returns the settings supported by a rendering extension.
Top

See Also

Reference

IConfigurable Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IConfigurable Interface Methods

[image]
ActiveReports 13
IConfigurable Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

Glossary Item Box

For a list of all members of this type, see IConfigurable members.

Public Methods

 | Name | Description
Method | GetSupportedSettings | Overloaded. Returns the settings supported by a rendering extension.
Top

See Also

Reference

IConfigurable Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetSupportedSettings Method

[image]
ActiveReports 13
GetSupportedSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface : GetSupportedSettings Method

Glossary Item Box

Returns the settings supported by a rendering extension.

Overload List

Overload | Description
GetSupportedSettings() | Returns the settings supported by a rendering extension.
GetSupportedSettings(Boolean) | Returns the settings supported by a rendering extension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Interface
IConfigurable Members


GetSupportedSettings() Method

[image]
ActiveReports 13
GetSupportedSettings() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Returns the settings supported by a rendering extension.

Syntax

Visual Basic (Declaration)
Overloads Function GetSupportedSettings() As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings()

Return Value

A GrapeCity.ActiveReports.Extensibility.Rendering.ISettings to provide access to the rendering extension settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Interface
IConfigurable Members
Overload List


GetSupportedSettings(Boolean) Method

[image]
ActiveReports 13
GetSupportedSettings(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method

fpl
Indicates that this is a fixed page layout

Glossary Item Box

Returns the settings supported by a rendering extension.

Syntax

Visual Basic (Declaration)
Overloads Function GetSupportedSettings( _
   ByVal fpl As Boolean _
) As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings(
   bool fpl
)

Parameters

fpl
Indicates that this is a fixed page layout

Return Value

A GrapeCity.ActiveReports.Extensibility.Rendering.ISettings to provide access to the rendering extension settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IConfigurable Interface
IConfigurable Members
Overload List


IRenderingExtension Interface

[image]
ActiveReports 13
IRenderingExtension Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

Glossary Item Box

Interface for rendering extention objects.

Syntax

Visual Basic (Declaration)
Public Interface IRenderingExtension
C#
public interface IRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderingExtension Interface Members

[image]
ActiveReports 13
IRenderingExtension Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

Glossary Item Box

The following tables list the members exposed by IRenderingExtension.

Public Methods

 | Name | Description
Method | Render | Overloaded. Renders the report.
Top

See Also

Reference

IRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderingExtension Interface Methods

[image]
ActiveReports 13
IRenderingExtension Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

Glossary Item Box

For a list of all members of this type, see IRenderingExtension members.

Public Methods

 | Name | Description
Method | Render | Overloaded. Renders the report.
Top

See Also

Reference

IRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Render Method

[image]
ActiveReports 13
Render Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface : Render Method

Glossary Item Box

Renders the report.

Overload List

Overload | Description
Render(IReport,StreamProvider) | Renders the report.
Render(IReport,StreamProvider,NameValueCollection) | Renders the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members


Render(IReport,StreamProvider) Method

[image]
ActiveReports 13
Render(IReport,StreamProvider) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface > Render Method : Render(IReport,StreamProvider) Method

report
The report to render.
streams
Stream for output.

Glossary Item Box

Renders the report.

Syntax

Visual Basic (Declaration)
Overloads Sub Render( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider _
)
C#
void Render(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams
)

Parameters

report
The report to render.
streams
Stream for output.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members
Overload List


Render(IReport,StreamProvider,NameValueCollection) Method

[image]
ActiveReports 13
Render(IReport,StreamProvider,NameValueCollection) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface > Render Method : Render(IReport,StreamProvider,NameValueCollection) Method

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.

Glossary Item Box

Renders the report.

Syntax

Visual Basic (Declaration)
Overloads Sub Render( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection _
)
C#
void Render(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams,
   NameValueCollection settings
)

Parameters

report
The report to render.
streams
Stream for output.
settings
Settings used in the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members
Overload List


GrapeCity.ActiveReports.General Namespace

GrapeCity.ActiveReports.General Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.General Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.Rendering Namespace

GrapeCity.ActiveReports.Rendering Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Rendering Namespace

Glossary Item Box

Classes

 | Class | Description
Class | GdiRenderersFactory | Factory with GDI+ based image renderer.

See Also

Reference

GrapeCity.ActiveReports Assembly


GdiRenderersFactory Class

[image]
ActiveReports 13
GdiRenderersFactory Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering Namespace : GdiRenderersFactory Class

Glossary Item Box

Factory with GDI+ based image renderer.

Object Model

GdiRenderersFactory Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GdiRenderersFactory
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory
C#
public sealed class GdiRenderersFactory : GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GdiRenderersFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiRenderersFactory Members
GrapeCity.ActiveReports.Rendering Namespace


GdiRenderersFactory Class Members

[image]
ActiveReports 13
GdiRenderersFactory Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering Namespace : GdiRenderersFactory Class

Glossary Item Box

The following tables list the members exposed by GdiRenderersFactory.

Public Constructors

 | Name | Description
Public Constructor | GdiRenderersFactory Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetRenderer<TRenderer> |
Top

See Also

Reference

GdiRenderersFactory Class
GrapeCity.ActiveReports.Rendering Namespace


GdiRenderersFactory Constructor

[image]
ActiveReports 13
GdiRenderersFactory Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering Namespace > GdiRenderersFactory Class : GdiRenderersFactory Constructor

graphicsFactory

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   Optional ByVal graphicsFactory As GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory _
)
C#
public GdiRenderersFactory(
   GrapeCity.ActiveReports.Extensibility.Rendering.IRenderersFactory graphicsFactory
)

Parameters

graphicsFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiRenderersFactory Class
GdiRenderersFactory Members


GdiRenderersFactory Class Methods

[image]
ActiveReports 13
GdiRenderersFactory Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering Namespace : GdiRenderersFactory Class

Glossary Item Box

For a list of all members of this type, see GdiRenderersFactory members.

Public Methods

 | Name | Description
Public Method | GetRenderer<TRenderer> |
Top

See Also

Reference

GdiRenderersFactory Class
GrapeCity.ActiveReports.Rendering Namespace


GetRenderer<TRenderer> Method

TRenderer
[image]
ActiveReports 13
GetRenderer<TRenderer> Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Rendering Namespace > GdiRenderersFactory Class : GetRenderer<TRenderer> Method

reportItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetRenderer(Of TRenderer As {Class, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer})( _
   ByVal reportItem As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem _
) As TRenderer
C#
public TRenderer GetRenderer<TRenderer>(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem reportItem
)
where TRenderer: class, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderer

Parameters

reportItem

Type Parameters

TRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GdiRenderersFactory Class
GdiRenderersFactory Members


GrapeCity.ActiveReports.ReportsCore Namespace

GrapeCity.ActiveReports.ReportsCore Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.ReportsCore.Configuration Namespace

GrapeCity.ActiveReports.ReportsCore.Configuration Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Configuration Namespace

Glossary Item Box

Classes

 | Class | Description
Class | MapTileServerConfiguration | Represents configuration settings for communication with map tile server.

See Also

Reference

GrapeCity.ActiveReports Assembly


MapTileServerConfiguration Class

[image]
ActiveReports 13
MapTileServerConfiguration Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

Glossary Item Box

Represents configuration settings for communication with map tile server.

Object Model

MapTileServerConfiguration Class

Syntax

Visual Basic (Declaration)
Public Class MapTileServerConfiguration
C#
public class MapTileServerConfiguration

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Configuration.MapTileServerConfiguration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Members
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


MapTileServerConfiguration Class Members

[image]
ActiveReports 13
MapTileServerConfiguration Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

Glossary Item Box

The following tables list the members exposed by MapTileServerConfiguration.

Public Constructors

 | Name | Description
Public Constructor | MapTileServerConfiguration Constructor | Initializes a new instance of the MapTileServerConfiguration class.
Top

Public Properties

 | Name | Description
Public Property | AppID | Gets or sets bing application id.
Public Property | MaxConnections | Gets or sets the number of maximum connections.
Public Property | Timeout | Gets or sets the timeout in seconds.
Top

See Also

Reference

MapTileServerConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


MapTileServerConfiguration Constructor

[image]
ActiveReports 13
MapTileServerConfiguration Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : MapTileServerConfiguration Constructor

Glossary Item Box

Initializes a new instance of the MapTileServerConfiguration class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MapTileServerConfiguration()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


MapTileServerConfiguration Class Properties

[image]
ActiveReports 13
MapTileServerConfiguration Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

Glossary Item Box

For a list of all members of this type, see MapTileServerConfiguration members.

Public Properties

 | Name | Description
Public Property | AppID | Gets or sets bing application id.
Public Property | MaxConnections | Gets or sets the number of maximum connections.
Public Property | Timeout | Gets or sets the timeout in seconds.
Top

See Also

Reference

MapTileServerConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


AppID Property

[image]
ActiveReports 13
AppID Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : AppID Property

Glossary Item Box

Gets or sets bing application id.

Syntax

Visual Basic (Declaration)
Public Property AppID As String
C#
public string AppID {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


MaxConnections Property

[image]
ActiveReports 13
MaxConnections Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : MaxConnections Property

Glossary Item Box

Gets or sets the number of maximum connections.

Syntax

Visual Basic (Declaration)
Public Property MaxConnections As Integer
C#
public int MaxConnections {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


Timeout Property

[image]
ActiveReports 13
Timeout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : Timeout Property

Glossary Item Box

Gets or sets the timeout in seconds.

Syntax

Visual Basic (Declaration)
Public Property Timeout As Integer
C#
public int Timeout {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


GrapeCity.ActiveReports.ReportsCore.Data Namespace

GrapeCity.ActiveReports.ReportsCore.Data Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Data Namespace

Glossary Item Box

Classes

 | Class | Description
Class | OracleConnectionAdapter | Allows to set multivalue parameter value by replacing substrings in command text.

See Also

Reference

GrapeCity.ActiveReports Assembly


OracleConnectionAdapter Class

[image]
ActiveReports 13
OracleConnectionAdapter Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace : OracleConnectionAdapter Class

Glossary Item Box

Allows to set multivalue parameter value by replacing substrings in command text.

Object Model

OracleConnectionAdapter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleConnectionAdapter
   Inherits GrapeCity.BI.Data.DataProviders.DbConnectionAdapter
   Implements GrapeCity.BI.Data.DataProviders.IDbConnectionAdapter
C#
public sealed class OracleConnectionAdapter : GrapeCity.BI.Data.DataProviders.DbConnectionAdapter, GrapeCity.BI.Data.DataProviders.IDbConnectionAdapter

Inheritance Hierarchy

System.Object
GrapeCity.BI.Data.DataProviders.DbConnectionAdapter
GrapeCity.ActiveReports.ReportsCore.Data.OracleConnectionAdapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Members
GrapeCity.ActiveReports.ReportsCore.Data Namespace


OracleConnectionAdapter Class Members

[image]
ActiveReports 13
OracleConnectionAdapter Class Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace : OracleConnectionAdapter Class

Glossary Item Box

The following tables list the members exposed by OracleConnectionAdapter.

Public Constructors

 | Name | Description
Public Constructor | OracleConnectionAdapter Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

Public Properties

 | Name | Description
Public Property | IsCredentialsSupported | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Property | IsSetConnectionStringSupported | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Property | IsSetMultiValueParameterSupported | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Top

Public Methods

 | Name | Description
Public Method | SetConnectionString | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Method | SetCredentials | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Method | SetMultiValueParameter | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Top

See Also

Reference

OracleConnectionAdapter Class
GrapeCity.ActiveReports.ReportsCore.Data Namespace


OracleConnectionAdapter Constructor

[image]
ActiveReports 13
OracleConnectionAdapter Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : OracleConnectionAdapter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleConnectionAdapter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


OracleConnectionAdapter Class Fields

[image]
ActiveReports 13
OracleConnectionAdapter Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace : OracleConnectionAdapter Class

Glossary Item Box

For a list of all members of this type, see OracleConnectionAdapter members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance |
Top

See Also

Reference

OracleConnectionAdapter Class
GrapeCity.ActiveReports.ReportsCore.Data Namespace


Instance Field

[image]
ActiveReports 13
Instance Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : Instance Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Instance As OracleConnectionAdapter
C#
public static OracleConnectionAdapter Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace

GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ConfigurableTileProvidersManager | Providers ability to create tile providers applying settings from config file.

See Also

Reference

GrapeCity.ActiveReports Assembly


ConfigurableTileProvidersManager Class

[image]
ActiveReports 13
ConfigurableTileProvidersManager Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ConfigurableTileProvidersManager Class

Glossary Item Box

Providers ability to create tile providers applying settings from config file.

Object Model

ConfigurableTileProvidersManager Class

Syntax

Visual Basic (Declaration)
Public Class ConfigurableTileProvidersManager
   Inherits GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager
   Implements GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.ITileProvidersManager
C#
public class ConfigurableTileProvidersManager : GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager, GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.ITileProvidersManager

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders.ConfigurableTileProvidersManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigurableTileProvidersManager Members
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


ConfigurableTileProvidersManager Class Members

[image]
ActiveReports 13
ConfigurableTileProvidersManager Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ConfigurableTileProvidersManager Class

Glossary Item Box

The following tables list the members exposed by ConfigurableTileProvidersManager.

Public Constructors

 | Name | Description
Public Constructor | ConfigurableTileProvidersManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | Providers | (Inherited from GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager)
Top

Public Methods

 | Name | Description
Public Method | CreateTileProvider | Create and configure specified tile provider (Inherited from GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager)
Top

See Also

Reference

ConfigurableTileProvidersManager Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


ConfigurableTileProvidersManager Constructor

[image]
ActiveReports 13
ConfigurableTileProvidersManager Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > ConfigurableTileProvidersManager Class : ConfigurableTileProvidersManager Constructor

configurationManager

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal configurationManager As IConfigurationManager _
)
C#
public ConfigurableTileProvidersManager(
   IConfigurationManager configurationManager
)

Parameters

configurationManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigurableTileProvidersManager Class
ConfigurableTileProvidersManager Members


GrapeCity.ActiveReports.ReportsCore.Tools Namespace

GrapeCity.ActiveReports.ReportsCore.Tools Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Tools Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DataSourceException | Specialized exception for data source actions.
Class | DataVisualizerInfoExtensions | Usefull extensions.
Class | ReportCombiner | Allows to create report combining existing reports by adding them as subreports

Structures

 | Structure | Description
Structure | LocationOptions | Additional options to control report location when using ReportCombiner

Enumerations

 | Enumeration | Description
Enumeration | DataSourceException.Codes | Codes of the exception for data source actions.

See Also

Reference

GrapeCity.ActiveReports Assembly


DataSourceException Class

[image]
ActiveReports 13
DataSourceException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataSourceException Class

Glossary Item Box

Specialized exception for data source actions.

Object Model

DataSourceException Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceException
   Inherits System.Exception
C#
public class DataSourceException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.ReportsCore.Tools.DataSourceException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DataSourceException Class Members

[image]
ActiveReports 13
DataSourceException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataSourceException Class

Glossary Item Box

The following tables list the members exposed by DataSourceException.

Public Constructors

 | Name | Description
Public Constructor | DataSourceException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Code | Gets the code.
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataSourceException Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DataSourceException Constructor

[image]
ActiveReports 13
DataSourceException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : DataSourceException Constructor

Glossary Item Box

Overload List

Overload | Description
DataSourceException Constructor(String) | Initializes a new instance of the DataSourceException class with a specified error message.
DataSourceException Constructor(Codes) | Initializes a new instance of the DataSourceException class.
DataSourceException Constructor(Codes,String) | Initializes a new instance of the DataSourceException class.
DataSourceException Constructor(Codes,Exception) | Initializes a new instance of the DataSourceException class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


DataSourceException Constructor(String)

[image]
ActiveReports 13
DataSourceException Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(String)

message
The message that describes the error.

Glossary Item Box

Initializes a new instance of the DataSourceException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public DataSourceException(
   string message
)

Parameters

message
The message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Constructor(Codes)

[image]
ActiveReports 13
DataSourceException Constructor(Codes)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(Codes)

code
The code.

Glossary Item Box

Initializes a new instance of the DataSourceException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As DataSourceException.Codes _
)
C#
public DataSourceException(
   DataSourceException.Codes code
)

Parameters

code
The code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Constructor(Codes,String)

[image]
ActiveReports 13
DataSourceException Constructor(Codes,String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(Codes,String)

code
The code.
message
The message.

Glossary Item Box

Initializes a new instance of the DataSourceException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As DataSourceException.Codes, _
   ByVal message As String _
)
C#
public DataSourceException(
   DataSourceException.Codes code,
   string message
)

Parameters

code
The code.
message
The message.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Constructor(Codes,Exception)

[image]
ActiveReports 13
DataSourceException Constructor(Codes,Exception)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class > DataSourceException Constructor : DataSourceException Constructor(Codes,Exception)

code
The code.
innerException
The inner exception.

Glossary Item Box

Initializes a new instance of the DataSourceException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As DataSourceException.Codes, _
   ByVal innerException As Exception _
)
C#
public DataSourceException(
   DataSourceException.Codes code,
   Exception innerException
)

Parameters

code
The code.
innerException
The inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members
Overload List


DataSourceException Class Properties

[image]
ActiveReports 13
DataSourceException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataSourceException Class

Glossary Item Box

For a list of all members of this type, see DataSourceException members.

Public Properties

 | Name | Description
Public Property | Code | Gets the code.
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataSourceException Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


Code Property

[image]
ActiveReports 13
Code Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : Code Property

Glossary Item Box

Gets the code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As DataSourceException.Codes
C#
public DataSourceException.Codes Code {get;}

Property Value

The code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


DataVisualizerInfoExtensions Class

[image]
ActiveReports 13
DataVisualizerInfoExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataVisualizerInfoExtensions Class

Glossary Item Box

Usefull extensions.

Object Model

DataVisualizerInfoExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DataVisualizerInfoExtensions
C#
public static class DataVisualizerInfoExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Tools.DataVisualizerInfoExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfoExtensions Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DataVisualizerInfoExtensions Class Members

[image]
ActiveReports 13
DataVisualizerInfoExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataVisualizerInfoExtensions Class

Glossary Item Box

The following tables list the members exposed by DataVisualizerInfoExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImage | Gets as PNG image.
Top

See Also

Reference

DataVisualizerInfoExtensions Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DataVisualizerInfoExtensions Class Methods

[image]
ActiveReports 13
DataVisualizerInfoExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataVisualizerInfoExtensions Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerInfoExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImage | Gets as PNG image.
Top

See Also

Reference

DataVisualizerInfoExtensions Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


GetImage Method

[image]
ActiveReports 13
GetImage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataVisualizerInfoExtensions Class : GetImage Method

buffer
Visualizer info.
width
Width in pixels.
height
Height in pixels.
dpiX
Horizontal resolution.
dpiY
Vertical resolution.
repeatOption
Background rendering mode.

Glossary Item Box

Gets as PNG image.

Syntax

Visual Basic (Declaration)
Public Shared Function GetImage( _
   ByVal buffer As GrapeCity.ActiveReports.Rendering.GraphicalRenderers.DataVisualizerInfo, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal dpiX As Single, _
   ByVal dpiY As Single, _
   Optional ByVal repeatOption As Nullable(Of BackgroundRepeatOption) _
) As GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo
C#
public static GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo GetImage(
   GrapeCity.ActiveReports.Rendering.GraphicalRenderers.DataVisualizerInfo buffer,
   int width,
   int height,
   float dpiX,
   float dpiY,
   Nullable<BackgroundRepeatOption> repeatOption
)

Parameters

buffer
Visualizer info.
width
Width in pixels.
height
Height in pixels.
dpiX
Horizontal resolution.
dpiY
Vertical resolution.
repeatOption
Background rendering mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerInfoExtensions Class
DataVisualizerInfoExtensions Members


ReportCombiner Class

[image]
ActiveReports 13
ReportCombiner Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

Allows to create report combining existing reports by adding them as subreports

Object Model

ReportCombiner Class

Syntax

Visual Basic (Declaration)
Public Class ReportCombiner
C#
public class ReportCombiner

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Tools.ReportCombiner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


ReportCombiner Class Members

[image]
ActiveReports 13
ReportCombiner Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

The following tables list the members exposed by ReportCombiner.

Public Constructors

 | Name | Description
Public Constructor | ReportCombiner Constructor | Creates instance of ReportCombiner
Top

Public Properties

 | Name | Description
Public Property | DefaultStep | Default gap between two adjacent subreports. It's 1in by default.
Top

Public Methods

 | Name | Description
Public Method | AddRange | Add reports collection with specified options.
Public Method | AddReport | Add report with specified options
Public Method | BuildReport | Returns a new PageReport instance
Public Method | Clear | Clears added items from current report combiner instance
Public Method | Insert | Add report to the specified position in reports list.
Public Method | RemoveAll | Remove all occurence of the specified report.
Public Method | RemoveAt | Remove the report at specified position in the reports list.
Public Method | SetMargin | Overloaded. Sets the margins of the report.
Top

See Also

Reference

ReportCombiner Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


ReportCombiner Constructor

[image]
ActiveReports 13
ReportCombiner Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : ReportCombiner Constructor

Glossary Item Box

Creates instance of ReportCombiner

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportCombiner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


ReportCombiner Class Methods

[image]
ActiveReports 13
ReportCombiner Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

For a list of all members of this type, see ReportCombiner members.

Public Methods

 | Name | Description
Public Method | AddRange | Add reports collection with specified options.
Public Method | AddReport | Add report with specified options
Public Method | BuildReport | Returns a new PageReport instance
Public Method | Clear | Clears added items from current report combiner instance
Public Method | Insert | Add report to the specified position in reports list.
Public Method | RemoveAll | Remove all occurence of the specified report.
Public Method | RemoveAt | Remove the report at specified position in the reports list.
Public Method | SetMargin | Overloaded. Sets the margins of the report.
Top

See Also

Reference

ReportCombiner Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


AddRange Method

[image]
ActiveReports 13
AddRange Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : AddRange Method

reports
Reports to be added.
options
The options to be applied to each report.

Glossary Item Box

Add reports collection with specified options.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal reports As IEnumerable(Of PageReport), _
   Optional ByVal options As LocationOptions _
)
C#
public void AddRange(
   IEnumerable<PageReport> reports,
   LocationOptions options
)

Parameters

reports
Reports to be added.
options
The options to be applied to each report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


AddReport Method

[image]
ActiveReports 13
AddReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : AddReport Method

report
location

Glossary Item Box

Add report with specified options

Syntax

Visual Basic (Declaration)
Public Sub AddReport( _
   ByVal report As PageReport, _
   Optional ByVal location As LocationOptions _
)
C#
public void AddReport(
   PageReport report,
   LocationOptions location
)

Parameters

report
location

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


BuildReport Method

[image]
ActiveReports 13
BuildReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : BuildReport Method

Glossary Item Box

Returns a new PageReport instance

Syntax

Visual Basic (Declaration)
Public Function BuildReport() As PageReport
C#
public PageReport BuildReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : Clear Method

Glossary Item Box

Clears added items from current report combiner instance

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : Insert Method

index
The position of the report to be added.
report
The report to be added.
options
The options to report be added with.

Glossary Item Box

Add report to the specified position in reports list.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal report As PageReport, _
   Optional ByVal options As LocationOptions _
)
C#
public void Insert(
   int index,
   PageReport report,
   LocationOptions options
)

Parameters

index
The position of the report to be added.
report
The report to be added.
options
The options to report be added with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


RemoveAll Method

[image]
ActiveReports 13
RemoveAll Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : RemoveAll Method

report
The report to be removed

Glossary Item Box

Remove all occurence of the specified report.

Syntax

Visual Basic (Declaration)
Public Function RemoveAll( _
   ByVal report As PageReport _
) As Integer
C#
public int RemoveAll(
   PageReport report
)

Parameters

report
The report to be removed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : RemoveAt Method

index
The index of the report to be removed.

Glossary Item Box

Remove the report at specified position in the reports list.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The index of the report to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


SetMargin Method

[image]
ActiveReports 13
SetMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : SetMargin Method

Glossary Item Box

Sets the margins of the report.

Overload List

Overload | Description
SetMargin(Length,Length,Length,Length) | Sets the margins of the report.
SetMargin(Length,Length) | Sets the margins of the report.
SetMargin(Length) | Sets the same margin for all borders.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


SetMargin(Length,Length,Length,Length) Method

[image]
ActiveReports 13
SetMargin(Length,Length,Length,Length) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class > SetMargin Method : SetMargin(Length,Length,Length,Length) Method

top
right
bottom
left

Glossary Item Box

Sets the margins of the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMargin( _
   ByVal top As GrapeCity.ActiveReports.PageReportModel.Length, _
   ByVal right As GrapeCity.ActiveReports.PageReportModel.Length, _
   ByVal bottom As GrapeCity.ActiveReports.PageReportModel.Length, _
   ByVal left As GrapeCity.ActiveReports.PageReportModel.Length _
)
C#
public void SetMargin(
   GrapeCity.ActiveReports.PageReportModel.Length top,
   GrapeCity.ActiveReports.PageReportModel.Length right,
   GrapeCity.ActiveReports.PageReportModel.Length bottom,
   GrapeCity.ActiveReports.PageReportModel.Length left
)

Parameters

top
right
bottom
left

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members
Overload List


SetMargin(Length,Length) Method

[image]
ActiveReports 13
SetMargin(Length,Length) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class > SetMargin Method : SetMargin(Length,Length) Method

topAndBottom
rightAndLeft

Glossary Item Box

Sets the margins of the report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMargin( _
   ByVal topAndBottom As GrapeCity.ActiveReports.PageReportModel.Length, _
   ByVal rightAndLeft As GrapeCity.ActiveReports.PageReportModel.Length _
)
C#
public void SetMargin(
   GrapeCity.ActiveReports.PageReportModel.Length topAndBottom,
   GrapeCity.ActiveReports.PageReportModel.Length rightAndLeft
)

Parameters

topAndBottom
rightAndLeft

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members
Overload List


SetMargin(Length) Method

[image]
ActiveReports 13
SetMargin(Length) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class > SetMargin Method : SetMargin(Length) Method

all

Glossary Item Box

Sets the same margin for all borders.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetMargin( _
   ByVal all As GrapeCity.ActiveReports.PageReportModel.Length _
)
C#
public void SetMargin(
   GrapeCity.ActiveReports.PageReportModel.Length all
)

Parameters

all

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members
Overload List


ReportCombiner Class Properties

[image]
ActiveReports 13
ReportCombiner Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : ReportCombiner Class

Glossary Item Box

For a list of all members of this type, see ReportCombiner members.

Public Properties

 | Name | Description
Public Property | DefaultStep | Default gap between two adjacent subreports. It's 1in by default.
Top

See Also

Reference

ReportCombiner Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


DefaultStep Property

[image]
ActiveReports 13
DefaultStep Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > ReportCombiner Class : DefaultStep Property

Glossary Item Box

Default gap between two adjacent subreports. It's 1in by default.

Syntax

Visual Basic (Declaration)
Public Property DefaultStep As GrapeCity.ActiveReports.PageReportModel.Length
C#
public GrapeCity.ActiveReports.PageReportModel.Length DefaultStep {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportCombiner Class
ReportCombiner Members


DataSourceException.Codes Enumeration

[image]
ActiveReports 13
DataSourceException.Codes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataSourceException.Codes Enumeration

Glossary Item Box

Codes of the exception for data source actions.

Syntax

Visual Basic (Declaration)
Public Enum DataSourceException.Codes
   Inherits System.Enum
C#
public enum DataSourceException.Codes : System.Enum

Members

Member | Description
ExecuteQueryError | Error appeared while query execution.
General | General exception.
InvalidConnectionString | Provided connection string is invalid.
SchemaProviderUnavaliable | Schema provider is unavaliable.
UnableToCreateCommand | Unable to create command.
UnableToCreateConnection | Unable to create connection.
UnableToOpenConnection | Unable to open connection.
UnableToRetreiveSchema | Unable to retreive schema.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ReportsCore.Tools.DataSourceException.Codes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.ReportsCore.Tools Namespace


LocationOptions Structure

[image]
ActiveReports 13
LocationOptions Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : LocationOptions Structure

Glossary Item Box

Additional options to control report location when using ReportCombiner

Object Model

LocationOptions Structure

Syntax

Visual Basic (Declaration)
Public Structure LocationOptions
   Inherits System.ValueType
C#
public struct LocationOptions : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationOptions Members
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


LocationOptions Structure Members

[image]
ActiveReports 13
LocationOptions Structure Members
See Also Fields
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : LocationOptions Structure

Glossary Item Box

The following tables list the members exposed by LocationOptions.

Public Fields

 | Name | Description
Public Field | Gap | Adds extra space between previous and added report
Public Field | PageBreakBefore | Adds a pagebreak before added report
Top

See Also

Reference

LocationOptions Structure
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


LocationOptions Structure Fields

[image]
ActiveReports 13
LocationOptions Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : LocationOptions Structure

Glossary Item Box

For a list of all members of this type, see LocationOptions members.

Public Fields

 | Name | Description
Public Field | Gap | Adds extra space between previous and added report
Public Field | PageBreakBefore | Adds a pagebreak before added report
Top

See Also

Reference

LocationOptions Structure
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


Gap Field

[image]
ActiveReports 13
Gap Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > LocationOptions Structure : Gap Field

Glossary Item Box

Adds extra space between previous and added report

Syntax

Visual Basic (Declaration)
Public Gap As GrapeCity.ActiveReports.PageReportModel.Length
C#
public GrapeCity.ActiveReports.PageReportModel.Length Gap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationOptions Structure
LocationOptions Members


PageBreakBefore Field

[image]
ActiveReports 13
PageBreakBefore Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > LocationOptions Structure : PageBreakBefore Field

Glossary Item Box

Adds a pagebreak before added report

Syntax

Visual Basic (Declaration)
Public PageBreakBefore As Boolean
C#
public bool PageBreakBefore

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationOptions Structure
LocationOptions Members


GrapeCity.ActiveReports.SectionReportModel Namespace

GrapeCity.ActiveReports.SectionReportModel Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.SectionReportModel Namespace

Glossary Item Box

The GrapeCity.ActiveReports.SectionReportModel namespace includes classes that can be used in section reports.

Classes

 | Class | Description
Class | ARControl | ARControl is the base class for ActiveReports controls. You should not need to use this class in your application.
Class | Barcode | The Barcode control is used to print barcode symbology in the report.
Class | ChartControl | Renders a chart on the report.
Class | CheckBox | Checkbox is used to print Boolean values as checked or unchecked.
Class | ControlCollection | Represents a collection of ARControl objects.
Class | CrossSectionBox | The CrossSectionBox control renders a rectangular outline with its corners where you place them in the header and footer sections, and its vertical lines growing with intervening sections.
Class | CrossSectionControl | ARControl is the base class for ActiveReports CrossSection controls. You should not need to use this class in your application.
Class | CrossSectionLine | The CrossSectionLine control renders a vertical line that begins where you place it in a header section, grows with any intervening sections, and ends where you place it in the related footer section.
Class | CustomControl | CustomControl is a wrapper class that allows you to print .NET controls that inherit from System.Windows.Forms.Control
Class | Detail | Detail section is the main section in a report. It is printed once for each record in the data source.
Class | GroupFooter | The GroupFooter section is directly related to the Detail section and its matching group header. It prints once each time a group of similar records (as defined in the GroupHeader.DataField property) ends. A GroupFooter section cannot exist without a matching GroupHeader section.
Class | GroupHeader | The GroupHeader section prints once for every data group defined using the field specified in DataField property. A GroupHeader section requires a matching GroupFooter section.
Class | Label | Prints static text on the report.
Class | Line | Prints a line on the report.
Class | OleObject | OleObject is a wrapper class for printing OLE objects.
Class | PageBreak | PageBreak ends the current page and starts a new page at the control's location on the page.
Class | PageFooter | The PageFooter section prints once at the bottom of every page in the report.
Class | PageHeader | The PageHeader section prints once at the top of every page in the report.
Class | Parameter | A Parameter is used to substitute values for parameter placeholders in the report's data source SQL query text.
Class | ParameterCollection | Represents the collection of parameters that ActiveReports parses from the parameter placeholders in the data source SQL query.
Class | Picture | Prints an image on the report.
Class | ReportFooter | The ReportFooter section prints once at the end of the report.
Class | ReportHeader | The ReportHeader section is printed once at the beginning of the report.
Class | ReportInfo | The ReportInfo control displays the information specified in the FormatString property.
Class | RichTextBox | Prints text formatted as Rich Text (RTF) on the report.
Class | Section | Section is the base class of all ActiveReports section types.
Class | Shape | Prints a rectangular or oval shape on the report.
Class | Style | Represents the formatting properties of a control.
Class | StyleSheet | Represents the collection of Style objects used to format controls.
Class | SubReport | Prints a linked report object as part of the current report. Subreports are linked using the Report property.
Class | TextBox | Prints a formatted text value, bound or unbound.

Enumerations

 | Enumeration | Description
Enumeration | BackgroundStyle | Specifies the style used to draw the background of an object.
Enumeration | BarCodeCaptionPosition | Specifies the barcode caption position relative to the barcode symbol.
Enumeration | BarCodeDirection | Specifies the print direction of the barcode symbol.
Enumeration | BarCodeStyle | Type of code, or symbology, the barcode control will use to generate the barcode.
Enumeration | ChartControl.UIAction | Specifies the action to perform on the chart control.
Enumeration | ColumnDirection | Specifies the direction of columns in a multi-column report.
Enumeration | GradientStyle | Specifies the type of gradient to draw.
Enumeration | GroupKeepTogether | Specifies whether a group header and footer pair with associated details will print as a single block on the same page.
Enumeration | ImageTypes | Specifies the type of image to be used for a chart.
Enumeration | LineStyle | Specifies the pen style used to draw a line.
Enumeration | NewColumn | Specifies whether a new column will be started before or after a section.
Enumeration | NewPage | Specifies whether a new page will be started before or after a section.
Enumeration | Parameter.DataType | Specifies the data type used to create the input control for collection of report parameter values.
Enumeration | ParameterCollection.ParseResultCode | Specifies the results of parsing the report's parameter values.
Enumeration | PictureAlignment | Determines the position of the picture within the control area.
Enumeration | RepeatStyle | Specifies whether a group header section will be repeated with subsequent detail pages.
Enumeration | RichTextBox.FindOptions | Specifies how a text search is carried out in a RichTextBox control. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Enumeration | RichTextBox.RichTextStreamType | Determines the RichText control's content type.
Enumeration | RichTextType | Determines the type of stream to load into the RichTextBox.
Enumeration | ShapeType | Specifies the type of shape that the shape control should print.
Enumeration | SizeModes | Determines how a picture should be sized within the control area.
Enumeration | SummaryFunc | Determines the summary calculation function performed on the field value.
Enumeration | SummaryRunning | Determines whether summary values will be accumulated or reset based on the specified level.
Enumeration | SummaryType | Determines the type of field summary.

See Also

Reference

GrapeCity.ActiveReports Assembly


ARControl Class

[image]
ActiveReports 13
ARControl Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

ARControl is the base class for ActiveReports controls. You should not need to use this class in your application.

Object Model

ARControl Class

Syntax

Visual Basic (Declaration)
Public Class ARControl
C#
public class ARControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode
GrapeCity.ActiveReports.SectionReportModel.ChartControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CustomControl
GrapeCity.ActiveReports.SectionReportModel.Label
GrapeCity.ActiveReports.SectionReportModel.Line
GrapeCity.ActiveReports.SectionReportModel.OleObject
GrapeCity.ActiveReports.SectionReportModel.PageBreak
GrapeCity.ActiveReports.SectionReportModel.Picture
GrapeCity.ActiveReports.SectionReportModel.ReportInfo
GrapeCity.ActiveReports.SectionReportModel.RichTextBox
GrapeCity.ActiveReports.SectionReportModel.Shape
GrapeCity.ActiveReports.SectionReportModel.SubReport
GrapeCity.ActiveReports.SectionReportModel.TextBox

Requirements

See Also

Reference

ARControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ARControl Class Members

[image]
ActiveReports 13
ARControl Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

The following tables list the members exposed by ARControl.

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control.
Public Property | Height | Gets or sets the height of the control in inches.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | Location | Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control.
Public Property | Parent | Gets a reference to the parent section of the control.
Public Property | Size | Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed.
Public Property | Width | Gets or sets the width of the control in inches.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | SendToBack | Sends the control to the back of the z-order.
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle.
Top

See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ARControl Class Methods

[image]
ActiveReports 13
ARControl Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

For a list of all members of this type, see ARControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | SendToBack | Sends the control to the back of the z-order.
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle.
Top

See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.BringToFront();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.BringToFront()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Example

C# Copy Code
private void detail_BeforePrint(object sender, System.EventArgs eArgs)
{
    this.barcode1.SendToBack();
}
Visual Basic Copy Code
Private Sub Detail1_BeforePrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.SendToBack()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : SetBounds Method

bounds
Rectangle that defines the location and size of the control.

Glossary Item Box

Sets the bounds of the control to the specified rectangle.

Syntax

Visual Basic (Declaration)
Public Sub SetBounds( _
   ByVal bounds As RectangleF _
)
C#
public void SetBounds(
   RectangleF bounds
)

Parameters

bounds
Rectangle that defines the location and size of the control.

Return Value

The rectangle is defined using float or Single values in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.RectangleF b = new System.Drawing.RectangleF();
    b.X=2;
    b.Y=1;
    b.Width=2;
    b.Height=1;
    this.barcode2.SetBounds(b);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim b As New System.Drawing.RectangleF
    With b
        .X = 2
        .Y = 1
        .Width = 2
        .Height = 0.5
    End With
    Me.Barcode2.SetBounds(b)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


ARControl Class Properties

[image]
ActiveReports 13
ARControl Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

Glossary Item Box

For a list of all members of this type, see ARControl members.

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control.
Public Property | Height | Gets or sets the height of the control in inches.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | Location | Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control.
Public Property | Parent | Gets a reference to the parent section of the control.
Public Property | Size | Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed.
Public Property | Width | Gets or sets the width of the control in inches.
Top

See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Border Property

[image]
ActiveReports 13
Border Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Border Property

Glossary Item Box

Gets a border object that defines the border style for each edge of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Border As Border
C#
public virtual Border Border {get;}

Property Value

Default border object.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    this.textBox1.Border.BottomStyle = BorderLineStyle.ThickDash;
    this.textBox1.Border.TopStyle = BorderLineStyle.ThickDash;
    b = this.textBox1.Border.Clone();
    this.textBox2.Border.BottomStyle = b.BottomStyle;
    this.textBox2.Border.TopStyle = b.TopStyle;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim b As New GrapeCity.ActiveReports.Border
    Me.TextBox1.Border.BottomStyle = BorderLineStyle.ThickDash
    Me.TextBox1.Border.TopStyle = BorderLineStyle.ThickDash
    b = Me.TextBox1.Border.Clone()
    Me.TextBox2.Border.BottomStyle = b.BottomStyle
    Me.TextBox2.Border.TopStyle = b.TopStyle
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Bounds Property

Glossary Item Box

Sets or returns a rectangle that defines the location and size of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
C#
public RectangleF Bounds {get; set;}

Property Value

A RectangleF object defined using Float or Single values in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


DataField Property

[image]
ActiveReports 13
DataField Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : DataField Property

Glossary Item Box

Gets or sets the field name from the data source to bind to the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property DataField As String
C#
public virtual string DataField {get; set;}

Property Value

Name of the data bound field. Default is an empty string; the control is not bound.

Remarks

When the DataField property is set to a field contained within the DataSource, ActiveReports binds the field's data from each record to the control. The recordset data is first saved into the Value property. It then converts to any output format and is set as the control's text.

The DataField property can also be used to perform calculations using a scripting expression beginning with an equals sign (=). This allows fields to be set up to display calculated results. For example, field control or data field's group field section can be set to an expression such as "=UnitPrice * Qty" or "=CompanyName.Trim()" where UnitPrice, Qty and CompanyName are members of the report's Fields collection.

Add an equals sign (=) at the beginning when using parameters in a DataField property.

When using XML, the DataField must be set to a valid XPath expression.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.textBox2.DataField = "CustomerID";
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.TextBox2.DataField = "CustomerID"
End Sub

Requirements

See Also

Reference

ARControl Class
ARControl Members


Height Property

[image]
ActiveReports 13
Height Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Height Property

Glossary Item Box

Gets or sets the height of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Property Value

A float or Single value in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Left Property

[image]
ActiveReports 13
Left Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Left Property

Glossary Item Box

Gets or sets the left position of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
C#
public float Left {get; set;}

Property Value

A float or Single value in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Location Property

[image]
ActiveReports 13
Location Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Location Property

Glossary Item Box

Gets or sets the location of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overridable Property Location As PointF
C#
public virtual PointF Location {get; set;}

Property Value

System.Drawing.PointF defined by X and Y float or Single values in inches.

Remarks

Note: Be sure that the section containing the control is sized to accommodate the location; otherwise the control may render in a hidden area.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0.5f;
    p.Y = 0.5f;
    this.textBox1.Location = p;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim p As System.Drawing.PointF
    p.X = 0.5
    p.Y = 0.5
    Me.TextBox1.Location = p
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Name Property

[image]
ActiveReports 13
Name Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Remarks

Requires a unique name within the report class. You can only use underscore (_) as a special character in the Name field. Other special characters such as period (.), space ( ), forward slash (/), back slash (\), exclamation (!), and hyphen (-) are not supported.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Name = "txtCustID";
    this.Sections["detail"].Controls["txtCustID"].Width = 4;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.TextBox1.Name = "txtCustID"
    Me.Sections("Detail1").Controls("txtCustID").Width = 4
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Parent Property

Glossary Item Box

Gets a reference to the parent section of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
C#
public object Parent {get;}

Property Value

Object - Reference to the parent section.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show (this.textBox2.Parent.ToString());
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    MessageBox.Show(Me.TextBox1.Parent.ToString())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members
ActiveReports6~GrapeCity.ActiveReports.Section


Size Property

[image]
ActiveReports 13
Size Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Size Property

Glossary Item Box

Gets or sets the size of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overridable Property Size As SizeF
C#
public virtual SizeF Size {get; set;}

Property Value

System.Drawing.SizeF.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.SizeF s = new System.Drawing.SizeF();
    s.Width = 2;
    s.Height = 1;
    this.textBox1.Size = s;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim s As System.Drawing.SizeF
    s.Width = 2
    s.Height = 1
    Me.TextBox1.Size = s
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Tag Property

Glossary Item Box

Gets or sets user-defined information to be persisted with the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReportModel.ARControl arcontrol = new GrapeCity.ActiveReports.SectionReportModel.ARControl();
arcontrol.Tag = new TextBox();
Visual Basic Copy Code
Dim arcontrol As New GrapeCity.ActiveReports.SectionReportModel.ARControl()
arcontrol.Tag = New TextBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Top Property

[image]
ActiveReports 13
Top Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Top Property

Glossary Item Box

Gets or sets, in inches, the top position of the control relative to the section that contains it.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
C#
public float Top {get; set;}

Property Value

A float or Single value in inches.

Remarks

Note: Be sure that the section containing the control is sized to accommodate the location. Otherwise the control may render in a hidden area.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Visible Property

Glossary Item Box

Sets or returns a value indicating whether the control will be printed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

A Boolean value. Default is True.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.textBox2.Value.ToString() == "ALFKI")
    {
        this.textBox2.Visible = false;
    }
    else
    {
        this.textBox2.Visible = true;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Me.TextBox1.Value = "ALFKI" Then
        Me.TextBox1.Visible = False
    Else
        Me.TextBox1.Visible = True
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Width Property

[image]
ActiveReports 13
Width Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Width Property

Glossary Item Box

Gets or sets the width of the control in inches.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Property Value

A float or Single value in inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ARControl Class
ARControl Members


Barcode Class

[image]
ActiveReports 13
Barcode Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

Glossary Item Box

The Barcode control is used to print barcode symbology in the report.

Object Model

Barcode Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Barcode
   Inherits ARControl
C#
public sealed class Barcode : ARControl

Remarks

The Barcode control can be bound to data fields or unbound.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Alignment = System.Drawing.StringAlignment.Center;
    this.barcode1.AutoSize = true;
    this.barcode1.BackColor = System.Drawing.Color.White;
    this.barcode1.BarHeight = 0.0f;
    this.barcode1.CaptionPosition = BarCodeCaptionPosition.Below;
    this.barcode1.CheckSumEnabled = true;
    this.barcode1.ForeColor = System.Drawing.Color.Green;
    this.barcode1.Style = BarCodeStyle.Code49;
    this.barcode1.Text = "Barcode";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Alignment = System.Drawing.StringAlignment.Center
    Me.Barcode1.AutoSize = True
    Me.Barcode1.BackColor = System.Drawing.Color.White
    Me.Barcode1.BarHeight = 0.0F
    Me.Barcode1.CaptionPosition = BarCodeCaptionPosition.Below
    Me.Barcode1.CheckSumEnabled = True
    Me.Barcode1.ForeColor = System.Drawing.Color.Green
    Me.Barcode1.Style = BarCodeStyle.Code49
    Me.Barcode1.Text = "Barcode"
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Barcode Class Members

[image]
ActiveReports 13
Barcode Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

Glossary Item Box

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor | Initializes a new instance of the Barcode class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the caption in the control.
Public Property | AutoSize | Gets or sets whether the barcode automatically stretches to fit the control.
Public Property | BackColor | Gets or sets the barcode's background color or fill color.
Public Property | BarHeight | Gets or sets the height of the bars in inches.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.
Public Property | CaptionPosition | Gets or sets the caption's vertical position relative to the barcode symbol.
Public Property | CheckSumEnabled | Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.
Public Property | Code128 | Gets or sets the Code128Options for the barcode control.
Public Property | Code49 | Gets or sets the Code49Options for the barcode control.
Public Property | DataField | Overridden. Gets or sets the name of the field used to bind the data source records.
Public Property | DataMatrix | DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Public Property | Font | Gets or returns the font object used to print the control's caption.
Public Property | ForeColor | Gets or returns the foreground color of the control.
Public Property | GS1Composite | Gets or sets the GS1CompositeOptions for the barcode control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MaxiCode | MaxiCode options.
Public Property | MicroPDF417 | Gets or sets the MicroPDF417Options for the barcode control.
Public Property | MicroQRCode | Gets or sets the MicroQRCodeOptions for the barcode control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is in pixel for SectionReports and in point/inch/cm for PageReports.
Public Property | NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PDF417 | Gets or sets the PDF417Options for the barcode control.
Public Property | QRCode | Gets or sets the QRCodeOptions for the barcode control.
Public Property | QuietZoneBottom | Gets or sets the bottom quiet zone of the barcode.
Public Property | QuietZoneLeft | Gets or sets the left quiet zone of the barcode.
Public Property | QuietZoneRight | Gets or sets the right quiet zone of the barcode
Public Property | QuietZoneTop | Gets or sets the top quiet zone of the barcode
Public Property | Rotation | Gets or sets the angle the barcode should be rotated to.
Public Property | RssExpandedStacked | When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the barcode symbology used to render the barcode text.
Public Property | SupplementBarHeight | The height of a bar in the supplement barcode.
Public Property | SupplementCaptionPosition | Defines how to display the barcode caption.
Public Property | SupplementDataField | The supplement for barcode data.
Public Property | SupplementSpacing | The spacing between main and supplement barcodes.
Public Property | SupplementText | The supplement for barcode data.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ValueBinary | Special property to pass binary data to barcode. Exists primary for QR Code barcode.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Barcode Constructor

[image]
ActiveReports 13
Barcode Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Barcode Constructor

Glossary Item Box

Initializes a new instance of the Barcode class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Barcode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Properties

[image]
ActiveReports 13
Barcode Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

Glossary Item Box

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the caption in the control.
Public Property | AutoSize | Gets or sets whether the barcode automatically stretches to fit the control.
Public Property | BackColor | Gets or sets the barcode's background color or fill color.
Public Property | BarHeight | Gets or sets the height of the bars in inches.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.
Public Property | CaptionPosition | Gets or sets the caption's vertical position relative to the barcode symbol.
Public Property | CheckSumEnabled | Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.
Public Property | Code128 | Gets or sets the Code128Options for the barcode control.
Public Property | Code49 | Gets or sets the Code49Options for the barcode control.
Public Property | DataField | Overridden. Gets or sets the name of the field used to bind the data source records.
Public Property | DataMatrix | DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Public Property | Font | Gets or returns the font object used to print the control's caption.
Public Property | ForeColor | Gets or returns the foreground color of the control.
Public Property | GS1Composite | Gets or sets the GS1CompositeOptions for the barcode control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MaxiCode | MaxiCode options.
Public Property | MicroPDF417 | Gets or sets the MicroPDF417Options for the barcode control.
Public Property | MicroQRCode | Gets or sets the MicroQRCodeOptions for the barcode control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is in pixel for SectionReports and in point/inch/cm for PageReports.
Public Property | NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PDF417 | Gets or sets the PDF417Options for the barcode control.
Public Property | QRCode | Gets or sets the QRCodeOptions for the barcode control.
Public Property | QuietZoneBottom | Gets or sets the bottom quiet zone of the barcode.
Public Property | QuietZoneLeft | Gets or sets the left quiet zone of the barcode.
Public Property | QuietZoneRight | Gets or sets the right quiet zone of the barcode
Public Property | QuietZoneTop | Gets or sets the top quiet zone of the barcode
Public Property | Rotation | Gets or sets the angle the barcode should be rotated to.
Public Property | RssExpandedStacked | When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the barcode symbology used to render the barcode text.
Public Property | SupplementBarHeight | The height of a bar in the supplement barcode.
Public Property | SupplementCaptionPosition | Defines how to display the barcode caption.
Public Property | SupplementDataField | The supplement for barcode data.
Public Property | SupplementSpacing | The spacing between main and supplement barcodes.
Public Property | SupplementText | The supplement for barcode data.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ValueBinary | Special property to pass binary data to barcode. Exists primary for QR Code barcode.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Alignment Property

Glossary Item Box

Gets or sets the horizontal alignment of the caption in the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As StringAlignment
C#
public StringAlignment Alignment {get; set;}

Property Value

StringAlignment enum. The default value is StringAlignment.Center.

The possible values are StringAlignment.Near, StringAlignment.Center and StringAlignment.Far.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Alignment = System.Drawing.StringAlignment.Near;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Alignment = System.Drawing.StringAlignment.Center
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : AutoSize Property

Glossary Item Box

Gets or sets whether the barcode automatically stretches to fit the control.

Syntax

Visual Basic (Declaration)
Public Property AutoSize As Boolean
C#
public bool AutoSize {get; set;}

Property Value

Boolean. The default value is True.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.AutoSize = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.AutoSize = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : BackColor Property

Glossary Item Box

Gets or sets the barcode's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.BackColor = System.Drawing.Color.White;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.BackColor = System.Drawing.Color.White
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


BarHeight Property

[image]
ActiveReports 13
BarHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : BarHeight Property

Glossary Item Box

Gets or sets the height of the bars in inches.

Syntax

Visual Basic (Declaration)
Public Property BarHeight As Single
C#
public float BarHeight {get; set;}

Remarks

If the bar height exceeds the height of the control, this property is ignored.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


CaptionGrouping Property

[image]
ActiveReports 13
CaptionGrouping Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CaptionGrouping Property

Glossary Item Box

Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.

Syntax

Visual Basic (Declaration)
Public Property CaptionGrouping As Boolean
C#
public bool CaptionGrouping {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


CaptionPosition Property

[image]
ActiveReports 13
CaptionPosition Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CaptionPosition Property

Glossary Item Box

Gets or sets the caption's vertical position relative to the barcode symbol.

Syntax

Visual Basic (Declaration)
Public Property CaptionPosition As BarCodeCaptionPosition
C#
public BarCodeCaptionPosition CaptionPosition {get; set;}

Property Value

Current position of the caption. Default is BarCodeCaptionPosition.None.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.CaptionPosition = BarCodeCaptionPosition.Below;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.CaptionPosition = BarCodeCaptionPosition.Below
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.BarCodeCaptionPosition


CheckSumEnabled Property

[image]
ActiveReports 13
CheckSumEnabled Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CheckSumEnabled Property

Glossary Item Box

Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.

Syntax

Visual Basic (Declaration)
Public Property CheckSumEnabled As Boolean
C#
public bool CheckSumEnabled {get; set;}

Property Value

Boolean. Default is true.

Remarks

  • Property is valid for the following barcodes:

Ansi39
Ansi39x
Code39
Code39x
Code_128_A
Code_128_B
Code_128_C
Code_128auto
Code_93
Code93x
MSI
PostNet
EAN_8
UPC_A
RM4SCC
UCCEAN128

  • Property is not valid for the following barcodes:

Codabar(NW-7)
EAN_13(JAN13)
Code_2_of_5
Code25intlv
Matrix_2_of_5
UPC_E0
UPC_E1
QRCode
Code49
DataMatrix
Pdf417
microPdf417
IntelligentMail
JapanesePostal (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
EAN128FNC1 (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14 (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14Truncated (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14Stacked (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14StackedOmnidirectional (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSExpanded (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSExpandedStacked (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSLimited (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)

CheckSumEnabled has no effect if the style is EAN-13 and the result is based on the length of the string as follows:

Under 12 digits | Barcode symbol is not generated. Error message appears on the control.
12 digits | Check digit is calculated automatically (modulus 10/ weight 3). The barcode symbol is generated once the 13th digit is added.
13 digits or above | Strings with 13 digits or above are ignored and check digit is calculated automatically till the 12th digit. The barcode symbol is generated once the 13th digit is added.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.CheckSumEnabled = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.CheckSumEnabled = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Code128 Property

[image]
ActiveReports 13
Code128 Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Code128 Property

Glossary Item Box

Gets or sets the Code128Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property Code128 As GrapeCity.ActiveReports.BarCodes.Code128Options
C#
public GrapeCity.ActiveReports.BarCodes.Code128Options Code128 {get; set;}

Example

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
    this.barcode1.Style = BarCodeStyle.EAN128FNC1;
    // "\n" is encoded as FNC1 character and displayed none in caption.
    this.barcode1.Text = "12\n3456\n78";
    this.barcode1.Code128.Dpi = 300;
    this.barcode1.Code128.BarAdjust = +1;
    this.barcode1.Code128.ModuleSize = 2;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Style = BarCodeStyle.EAN128FNC1
    ' vbLf is encoded as FNC1 character and displayed none in caption.
    Me.Barcode1.Text="12” & vbLf & "3456" & vbLf &"78"
    Me.Barcode1.Code128.Dpi = 300
    Me.Barcode1.Code128.BarAdjust = +1
    Me.Barcode1.Code128.ModuleSize = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Code49 Property

[image]
ActiveReports 13
Code49 Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Code49 Property

Glossary Item Box

Gets or sets the Code49Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property Code49 As GrapeCity.ActiveReports.BarCodes.Code49Options
C#
public GrapeCity.ActiveReports.BarCodes.Code49Options Code49 {get; set;}

Remarks

Code 49 is a high-density stacked symbology containing two to eight rows of eight characters each. Each row has a start code and a stop code.

Code49 Options include Grouping and Group. If Grouping is set to True, the Group property may be set to a number between 0 and 8. The default values are False and 0, respectively.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Code49.Grouping = true;
    this.barcode1.Code49.Group = 4;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Code49.Grouping = True
    Me.Barcode1.Code49.Group = 4
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.Options.Code49Options


DataField Property

[image]
ActiveReports 13
DataField Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : DataField Property

Glossary Item Box

Gets or sets the name of the field used to　bind the data source records.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property DataField As String
C#
public override string DataField {get; set;}

Property Value

Name of the data bound field. Default is an empty string; the control is not bound.

Remarks

When the DataField property is set to a field contained within the DataSource, ActiveReports binds the field's data from each record to the control. The recordset data is first saved into the Value property. It then converts to any output format and is set as the control's text.

The DataField property can also be used to perform calculations using a scripting expression beginning with an equals sign (=). This allows fields to be set up to display calculated results. For example, field control or data field's group field section can be set to an expression such as "=UnitPrice * Qty" or "=CompanyName.Trim()" where UnitPrice, Qty and CompanyName are members of the report's Fields collection.

Add an equals sign (=) at the beginning when using parameters in a DataField property.

When using XML, the DataField must be set to a valid XPath expression.

Requirements

See Also

Reference

Barcode Class
Barcode Members


DataMatrix Property

[image]
ActiveReports 13
DataMatrix Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : DataMatrix Property

Glossary Item Box

DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.

Syntax

Visual Basic (Declaration)
Public Property DataMatrix As GrapeCity.ActiveReports.BarCodes.DataMatrixOptions
C#
public GrapeCity.ActiveReports.BarCodes.DataMatrixOptions DataMatrix {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Font Property

[image]
ActiveReports 13
Font Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control's caption.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Example

Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Font = New System.Drawing.Font(Me.TextBox2.Font, FontStyle.Bold)
End Sub
C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Font = new System.Drawing.Font(this.TextBox2.Font, System.Drawing.FontStyle.Bold);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color

Remarks

This color applies to both the barcode symbol and any caption.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.ForeColor = System.Drawing.Color.Green;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.ForeColor = System.Drawing.Color.Green
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


GS1Composite Property

[image]
ActiveReports 13
GS1Composite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : GS1Composite Property

Glossary Item Box

Gets or sets the GS1CompositeOptions for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property GS1Composite As GrapeCity.ActiveReports.BarCodes.GS1CompositeOptions
C#
public GrapeCity.ActiveReports.BarCodes.GS1CompositeOptions GS1Composite {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


MaxiCode Property

[image]
ActiveReports 13
MaxiCode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : MaxiCode Property

Glossary Item Box

MaxiCode options.

Syntax

Visual Basic (Declaration)
Public Property MaxiCode As GrapeCity.ActiveReports.BarCodes.MaxiCodeOptions
C#
public GrapeCity.ActiveReports.BarCodes.MaxiCodeOptions MaxiCode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


MicroPDF417 Property

[image]
ActiveReports 13
MicroPDF417 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : MicroPDF417 Property

Glossary Item Box

Gets or sets the MicroPDF417Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property MicroPDF417 As GrapeCity.ActiveReports.BarCodes.MicroPDF417Options
C#
public GrapeCity.ActiveReports.BarCodes.MicroPDF417Options MicroPDF417 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


MicroQRCode Property

[image]
ActiveReports 13
MicroQRCode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : MicroQRCode Property

Glossary Item Box

Gets or sets the MicroQRCodeOptions for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property MicroQRCode As GrapeCity.ActiveReports.BarCodes.MicroQRCodeOptions
C#
public GrapeCity.ActiveReports.BarCodes.MicroQRCodeOptions MicroQRCode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


NarrowBarWidth Property

[image]
ActiveReports 13
NarrowBarWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : NarrowBarWidth Property

Glossary Item Box

Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it.

This value is in pixel for SectionReports and in point/inch/cm for PageReports.

Syntax

Visual Basic (Declaration)
Public Property NarrowBarWidth As Single
C#
public float NarrowBarWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


NWRatio Property

[image]
ActiveReports 13
NWRatio Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : NWRatio Property

Glossary Item Box

Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.

Syntax

Visual Basic (Declaration)
Public Property NWRatio As Single
C#
public float NWRatio {get; set;}

Remarks

Commonly used values are 2, 2.5, 2.75, and 3.

Some barcodes that use only two bar widths are Code39, Code25intlv, and MSI.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


PDF417 Property

[image]
ActiveReports 13
PDF417 Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : PDF417 Property

Glossary Item Box

Gets or sets the PDF417Options for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property PDF417 As GrapeCity.ActiveReports.BarCodes.PDF417Options
C#
public GrapeCity.ActiveReports.BarCodes.PDF417Options PDF417 {get; set;}

Remarks

PDF417 is a multi-row variable-length symbology that has ten error correction levels and three data compaction modes: Text, Byte, and Numeric. This symbology can encode up to 1,850 alphanumeric characters or 2,710 numeric characters.

PDF417 Options include Column, ErrorLevel, Row, and Type.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.PDF417.Column = 2;
    this.barcode1.PDF417.Row = -1;
    this.barcode1.PDF417.Type = GrapeCity.ActiveReports.Options.PDF417Type.Simple;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.PDF417.Column = 2
    Me.Barcode1.PDF417.Row = -1
    Me.Barcode1.PDF417.Type = GrapeCity.ActiveReports.Options.PDF417Type.Simple
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.Options.PDF417Options


QRCode Property

[image]
ActiveReports 13
QRCode Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QRCode Property

Glossary Item Box

Gets or sets the QRCodeOptions for the barcode control.

Syntax

Visual Basic (Declaration)
Public Property QRCode As GrapeCity.ActiveReports.BarCodes.QRCodeOptions
C#
public GrapeCity.ActiveReports.BarCodes.QRCodeOptions QRCode {get; set;}

Remarks

QRCode is a two-dimensional symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.

Example

Paste into the Detail Format event.
C# Copy Code
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.QRCode.Connection = false;
    this.barcode1.QRCode.ConnectionNumber = 0;
    this.barcode1.QRCode.ErrorLevel = GrapeCity.GrapeCity.ActiveReports.v10.Options.QRCodeErrorLevel.Q;
    this.barcode1.QRCode.Mask = GrapeCity.GrapeCity.ActiveReports.v10.Options.QRCodeMask.Mask111;
    this.barcode1.QRCode.Model = GrapeCity.GrapeCity.ActiveReports.v10.Options.QRCodeModel.Model2;
    this.barcode1.QRCode.Version = 3;
}
Paste into the Detail Format event.
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.QRCode.Connection = False
    Me.Barcode1.QRCode.ConnectionNumber = 0
    Me.Barcode1.QRCode.ErrorLevel = Options.QRCodeErrorLevel.Q
    Me.Barcode1.QRCode.Mask = Options.QRCodeMask.Mask111
    Me.Barcode1.QRCode.Model = Options.QRCodeModel.Model2
    Me.Barcode1.QRCode.Version = 3
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.Options.QRCodeOptions


QuietZoneBottom Property

[image]
ActiveReports 13
QuietZoneBottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneBottom Property

Glossary Item Box

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property QuietZoneBottom As Single
C#
public float QuietZoneBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QuietZoneLeft Property

[image]
ActiveReports 13
QuietZoneLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneLeft Property

Glossary Item Box

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property QuietZoneLeft As Single
C#
public float QuietZoneLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QuietZoneRight Property

[image]
ActiveReports 13
QuietZoneRight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneRight Property

Glossary Item Box

Gets or sets the right quiet zone of the barcode

Syntax

Visual Basic (Declaration)
Public Property QuietZoneRight As Single
C#
public float QuietZoneRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


QuietZoneTop Property

[image]
ActiveReports 13
QuietZoneTop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneTop Property

Glossary Item Box

Gets or sets the top quiet zone of the barcode

Syntax

Visual Basic (Declaration)
Public Property QuietZoneTop As Single
C#
public float QuietZoneTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Rotation Property

[image]
ActiveReports 13
Rotation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Rotation Property

Glossary Item Box

Gets or sets the angle the barcode should be rotated to.

Syntax

Visual Basic (Declaration)
Public Property Rotation As Rotation
C#
public Rotation Rotation {get; set;}

Property Value

The rotation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


RssExpandedStacked Property

[image]
ActiveReports 13
RssExpandedStacked Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : RssExpandedStacked Property

Glossary Item Box

When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.

Syntax

Visual Basic (Declaration)
Public Property RssExpandedStacked As GrapeCity.ActiveReports.BarCodes.RssExpandedStackedOptions
C#
public GrapeCity.ActiveReports.BarCodes.RssExpandedStackedOptions RssExpandedStacked {get; set;}

Remarks

If the RowCount property is set to 1, the RSS Expanded Stacked barcode style becomes the same symbol as the RSS Expanded barcode style.

There is a relation between the RowCount property and the Text property of an RSS Expanded Stacked barcode. This means that a barcode symbol is displayed using the number of rows that is determined, based on the value in the Text property against the value in the RowCount property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Style Property

[image]
ActiveReports 13
Style Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Style Property

Glossary Item Box

Gets or sets the barcode symbology used to render the barcode text.

Syntax

Visual Basic (Declaration)
Public Property Style As BarCodeStyle
C#
public BarCodeStyle Style {get; set;}

Property Value

Current barcode symbology. Default is BarCodeStyle.Ansi39

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Style = BarCodeStyle.Code49;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Style = BarCodeStyle.Code49
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.BarCodeStyle


SupplementBarHeight Property

[image]
ActiveReports 13
SupplementBarHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementBarHeight Property

Glossary Item Box

The height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property SupplementBarHeight As Single
C#
public float SupplementBarHeight {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementCaptionPosition Property

[image]
ActiveReports 13
SupplementCaptionPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementCaptionPosition Property

Glossary Item Box

Defines how to display the barcode caption.

Syntax

Visual Basic (Declaration)
Public Property SupplementCaptionPosition As BarCodeCaptionPosition
C#
public BarCodeCaptionPosition SupplementCaptionPosition {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementDataField Property

[image]
ActiveReports 13
SupplementDataField Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementDataField Property

Glossary Item Box

The supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property SupplementDataField As String
C#
public string SupplementDataField {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementSpacing Property

[image]
ActiveReports 13
SupplementSpacing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementSpacing Property

Glossary Item Box

The spacing between main and supplement barcodes.

Syntax

Visual Basic (Declaration)
Public Property SupplementSpacing As Single
C#
public float SupplementSpacing {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


SupplementText Property

[image]
ActiveReports 13
SupplementText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementText Property

Glossary Item Box

The supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property SupplementText As String
C#
public string SupplementText {get; set;}

Remarks

Supplement is 2/5-digit addons for EAN/UPC symbologies.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


Text Property

[image]
ActiveReports 13
Text Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Text Property

Glossary Item Box

Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

Current text string. Default is an empty string.

Remarks

ActiveReports fills this value from the bound data field if the control is bound to the data source.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Text = "Barcode";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Text = "Barcode"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


ValueBinary Property

[image]
ActiveReports 13
ValueBinary Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : ValueBinary Property

Glossary Item Box

Special property to pass binary data to barcode. Exists primary for QR Code barcode.

Syntax

Visual Basic (Declaration)
Public Property ValueBinary As Byte()
C#
public byte[] ValueBinary {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Barcode Class
Barcode Members


ChartControl Class

[image]
ActiveReports 13
ChartControl Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

Renders a chart on the report.

Object Model

ChartControl Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartControl
   Inherits ARControl
C#
public sealed class ChartControl : ARControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.ChartControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ChartControl Class Members

[image]
ActiveReports 13
ChartControl Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

The following tables list the members exposed by ChartControl.

Public Constructors

 | Name | Description
Public Constructor | ChartControl Constructor | Initializes a new instance of the ChartControl class.
Top

Public Properties

 | Name | Description
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | Backdrop | Gets or sets the BackdropItem used for the background of the chart control.
Public Property | BlackAndWhiteMode | Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ChartAreas | A collection of ChartArea objects drawn in the chart control.
Public Property | ChartBorder | Gets or sets the border used to draw around the chart.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | Culture | Gets or sets the culture for the chart control.
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Legends | Gets or sets the legend object for the chart control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Gets or sets a value indicating whether the control's elements are aligned to support locales using right-to-left fonts.
Public Property | Series | Gets the series collection for the chart object.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Titles | Gets the titles collection for the SharpGraph object.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | UIOptions | Gets or sets specific user interface features for the chart.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Load | Reconstructs a chart object from the specified file.
Public Method | Restart | Resets the chart data source and restarts chart processing.
Public Method | Save | Creates an XML encoding of the chart object and its current state (without data).
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Events

 | Name | Description
Public Event | DataSourceChanged | Raised when the data source of the chart changes.
Top

See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ChartControl Constructor

[image]
ActiveReports 13
ChartControl Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartControl Constructor

Glossary Item Box

Initializes a new instance of the ChartControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ChartControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Methods

[image]
ActiveReports 13
ChartControl Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

For a list of all members of this type, see ChartControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Load | Reconstructs a chart object from the specified file.
Public Method | Restart | Resets the chart data source and restarts chart processing.
Public Method | Save | Creates an XML encoding of the chart object and its current state (without data).
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Load Method

[image]
ActiveReports 13
Load Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Load Method

filename
The name of the file from which to load the chart.

Glossary Item Box

Reconstructs a chart object from the specified file.

Syntax

Visual Basic (Declaration)
Public Sub Load( _
   ByVal filename As String _
)
C#
public void Load(
   string filename
)

Parameters

filename
The name of the file from which to load the chart.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Restart Method

[image]
ActiveReports 13
Restart Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Restart Method

Glossary Item Box

Resets the chart data source and restarts chart processing.

Syntax

Visual Basic (Declaration)
Public Sub Restart()
C#
public void Restart()

Remarks

This method is obsolete.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Save Method

[image]
ActiveReports 13
Save Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Save Method

filename
The name of the file to which the chart is to be saved.

Glossary Item Box

Creates an XML encoding of the chart object and its current state (without data).

Syntax

Visual Basic (Declaration)
Public Sub Save( _
   ByVal filename As String _
)
C#
public void Save(
   string filename
)

Parameters

filename
The name of the file to which the chart is to be saved.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Properties

[image]
ActiveReports 13
ChartControl Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

For a list of all members of this type, see ChartControl members.

Public Properties

 | Name | Description
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | Backdrop | Gets or sets the BackdropItem used for the background of the chart control.
Public Property | BlackAndWhiteMode | Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ChartAreas | A collection of ChartArea objects drawn in the chart control.
Public Property | ChartBorder | Gets or sets the border used to draw around the chart.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | Culture | Gets or sets the culture for the chart control.
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Legends | Gets or sets the legend object for the chart control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Gets or sets a value indicating whether the control's elements are aligned to support locales using right-to-left fonts.
Public Property | Series | Gets the series collection for the chart object.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Titles | Gets the titles collection for the SharpGraph object.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | UIOptions | Gets or sets specific user interface features for the chart.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AutoRefresh Property

[image]
ActiveReports 13
AutoRefresh Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : AutoRefresh Property

Glossary Item Box

Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.

Syntax

Visual Basic (Declaration)
Public Property AutoRefresh As Boolean
C#
public bool AutoRefresh {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Backdrop Property

[image]
ActiveReports 13
Backdrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Backdrop Property

Glossary Item Box

Gets or sets the BackdropItem used for the background of the chart control.

Syntax

Visual Basic (Declaration)
Public Property Backdrop As GrapeCity.ActiveReports.Chart.Graphics.Backdrop
C#
public GrapeCity.ActiveReports.Chart.Graphics.Backdrop Backdrop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


BlackAndWhiteMode Property

[image]
ActiveReports 13
BlackAndWhiteMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : BlackAndWhiteMode Property

Glossary Item Box

Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.

Syntax

Visual Basic (Declaration)
Public Property BlackAndWhiteMode As Boolean
C#
public bool BlackAndWhiteMode {get; set;}

Property Value

A Boolean value. The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartAreas Property

[image]
ActiveReports 13
ChartAreas Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartAreas Property

Glossary Item Box

A collection of ChartArea objects drawn in the chart control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartAreas As GrapeCity.ActiveReports.Chart.ChartAreasCollection
C#
public GrapeCity.ActiveReports.Chart.ChartAreasCollection ChartAreas {get;}

Property Value

The chart areas.

Remarks

By default, one ChartArea is included in the ChartAreas collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartBorder Property

[image]
ActiveReports 13
ChartBorder Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartBorder Property

Glossary Item Box

Gets or sets the border used to draw around the chart.

Syntax

Visual Basic (Declaration)
Public Property ChartBorder As GrapeCity.ActiveReports.Chart.Border
C#
public GrapeCity.ActiveReports.Chart.Border ChartBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ColorPalette Property

[image]
ActiveReports 13
ColorPalette Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ColorPalette Property

Glossary Item Box

Gets or sets the color palette enumeration used for the series.

Syntax

Visual Basic (Declaration)
Public Property ColorPalette As GrapeCity.ActiveReports.Chart.ColorPalette
C#
public GrapeCity.ActiveReports.Chart.ColorPalette ColorPalette {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members
ColorPalette Enumeration


Culture Property

[image]
ActiveReports 13
Culture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Culture Property

Glossary Item Box

Gets or sets the culture for the chart control.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


DataSource Property

[image]
ActiveReports 13
DataSource Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : DataSource Property

Glossary Item Box

Gets or sets the global data source for the chart.

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
C#
public object DataSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


GridLayout Property

[image]
ActiveReports 13
GridLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : GridLayout Property

Glossary Item Box

Gets or sets the GridLayout object for the chart.

Syntax

Visual Basic (Declaration)
Public Property GridLayout As GrapeCity.ActiveReports.Chart.GridLayout
C#
public GrapeCity.ActiveReports.Chart.GridLayout GridLayout {get; set;}

Property Value

The grid layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ImageType Property

[image]
ActiveReports 13
ImageType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ImageType Property

Glossary Item Box

Sets or returns the type of image to which the chart will be rendered on the report.

Syntax

Visual Basic (Declaration)
Public Property ImageType As ImageTypes
C#
public ImageTypes ImageType {get; set;}

Property Value

An ImageTypes enumeration. The default value is Metafile. The alternate value is PNG.

Remarks

Some images can be a problem when exported as a metafile due to some graphic commands which are not supported. If you are noticing problems with images not exporting to PDF, set the ImageType to PNG.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members
ActiveReports6~GrapeCity.ActiveReports.ImageTypes


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

The IME mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Legends Property

[image]
ActiveReports 13
Legends Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Legends Property

Glossary Item Box

Gets or sets the legend object for the chart control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Legends As GrapeCity.ActiveReports.Chart.LegendsCollection
C#
public GrapeCity.ActiveReports.Chart.LegendsCollection Legends {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether the control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As RightToLeft
C#
public RightToLeft RightToLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Series Property

[image]
ActiveReports 13
Series Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Series Property

Glossary Item Box

Gets the series collection for the chart object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Series As GrapeCity.ActiveReports.Chart.SeriesCollection
C#
public GrapeCity.ActiveReports.Chart.SeriesCollection Series {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


Titles Property

[image]
ActiveReports 13
Titles Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Titles Property

Glossary Item Box

Gets the titles collection for the SharpGraph object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Titles As GrapeCity.ActiveReports.Chart.TitlesCollection
C#
public GrapeCity.ActiveReports.Chart.TitlesCollection Titles {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


UIOptions Property

[image]
ActiveReports 13
UIOptions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : UIOptions Property

Glossary Item Box

Gets or sets specific user interface features for the chart.

Syntax

Visual Basic (Declaration)
Public Property UIOptions As GrapeCity.ActiveReports.Chart.UIOptions
C#
public GrapeCity.ActiveReports.Chart.UIOptions UIOptions {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Events

[image]
ActiveReports 13
ChartControl Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

Glossary Item Box

For a list of all members of this type, see ChartControl members.

Public Events

 | Name | Description
Public Event | DataSourceChanged | Raised when the data source of the chart changes.
Top

See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


DataSourceChanged Event

[image]
ActiveReports 13
DataSourceChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : DataSourceChanged Event

Glossary Item Box

Raised when the data source of the chart changes.

Syntax

Visual Basic (Declaration)
Public Event DataSourceChanged As EventHandler
C#
public event EventHandler DataSourceChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


CheckBox Class

[image]
ActiveReports 13
CheckBox Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

Glossary Item Box

Checkbox is used to print Boolean values as checked or unchecked.

Object Model

CheckBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckBox
   Inherits ARControl
C#
public sealed class CheckBox : ARControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
    this.checkBox1.Checked = true;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    this.checkBox1.Text = "CheckBox";
    this.checkBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
   Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
   Me.CheckBox1.Checked = True
   Me.CheckBox1.ClassName = "Normal"
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
   Me.CheckBox1.Text = "CheckBox"
   Me.CheckBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
   'With the properties above set, the Style string would be:
   'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CheckBox Class Members

[image]
ActiveReports 13
CheckBox Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

Glossary Item Box

The following tables list the members exposed by CheckBox.

Public Constructors

 | Name | Description
Public Constructor | CheckBox Constructor | Initializes a new instance of the CheckBox class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CheckAlignment | Gets or sets the alignment of the checkbox text within the control drawing area.
Public Property | Checked | Gets or sets a value indicating the state of the checkbox.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control's text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets the number of points of padding to use on each side of the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the checkbox.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the printed caption of the checkbox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CheckBox Constructor

[image]
ActiveReports 13
CheckBox Constructor
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : CheckBox Constructor

Glossary Item Box

Initializes a new instance of the CheckBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CheckBox()

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
    this.checkBox1.Checked = true;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    this.checkBox1.Text = "CheckBox";
    this.checkBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
    Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
    Me.CheckBox1.Checked = True
    Me.CheckBox1.ClassName = "Normal"
    Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
    Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
    Me.CheckBox1.Text = "CheckBox"
    Me.CheckBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
    'With the properties above set, the Style string would be:
    'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

[image]
ActiveReports 13
CheckBox Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

Glossary Item Box

For a list of all members of this type, see CheckBox members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CheckAlignment | Gets or sets the alignment of the checkbox text within the control drawing area.
Public Property | Checked | Gets or sets a value indicating the state of the checkbox.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control's text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets the number of points of padding to use on each side of the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the checkbox.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the printed caption of the checkbox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


CheckAlignment Property

[image]
ActiveReports 13
CheckAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : CheckAlignment Property

Glossary Item Box

Gets or sets the alignment of the checkbox text within the control drawing area.

Syntax

Visual Basic (Declaration)
Public Property CheckAlignment As ContentAlignment
C#
public ContentAlignment CheckAlignment {get; set;}

Property Value

Current alignment setting. Default is System.Drawing.ContentAlignment.MiddleLeft.

Possible values are:

  • System.Drawing.ContentAlignment.BottomCenter
  • System.Drawing.ContentAlignment.BottomLeft
  • System.Drawing.ContentAlignment.BottomRight
  • System.Drawing.ContentAlignment.MiddleCenter
  • System.Drawing.ContentAlignment.MiddleLeft
  • System.Drawing.ContentAlignment.MiddleRight
  • System.Drawing.ContentAlignment.TopCenter
  • System.Drawing.ContentAlignment.TopLeft
  • System.Drawing.ContentAlignment.TopRight

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Checked Property

[image]
ActiveReports 13
Checked Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Checked Property

Glossary Item Box

Gets or sets a value indicating the state of the checkbox.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
C#
public bool Checked {get; set;}

Property Value

Boolean. True if the check box is in the checked state; otherwise, False. The default value is False.

Remarks

When the value is True, the check box portion of the control displays a check mark.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Checked = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Checked = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


ClassName Property

[image]
ActiveReports 13
ClassName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String. Style class name. Default value is "Normal".

Remarks

Style classes are defined in the report's Stylesheet.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.ClassName = "Normal";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.ClassName = "Normal"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members
StyleSheet Property


Font Property

[image]
ActiveReports 13
Font Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control's text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

System.Drawing.Font

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color

Remarks

This property sets the color for both the text and the checkbox in the control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Padding Property

Glossary Item Box

Gets or sets the number of points of padding to use on each side of the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members
Padding Class


Style Property

[image]
ActiveReports 13
Style Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Style Property

Glossary Item Box

Gets or sets a style string for the checkbox.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

String. CSS syntax of the control style.

Remarks

The style string overrides the global style rules specified in the ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
   Me.CheckBox1.ClassName = "Normal"
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
   'With the properties above set, the Style string would be:
   'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members
ActiveReports6~GrapeCity.ActiveReports.CheckBox~ClassName


Text Property

[image]
ActiveReports 13
Text Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Text Property

Glossary Item Box

Gets or sets the printed caption of the checkbox.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

String. Current caption of the checkbox.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Text = "CheckBox";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Text = "CheckBox"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


WrapMode Property

[image]
ActiveReports 13
WrapMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : WrapMode Property

Glossary Item Box

Sets/gets control's wrap mode using CSS.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As GrapeCity.ActiveReports.Drawing.WrapMode
C#
public GrapeCity.ActiveReports.Drawing.WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBox Class
CheckBox Members


ControlCollection Class

[image]
ActiveReports 13
ControlCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

Represents a collection of ARControl objects.

Object Model

ControlCollection Class

Syntax

Visual Basic (Declaration)
Public Class ControlCollection
   Inherits System.Collections.CollectionBase
C#
public class ControlCollection : System.Collections.CollectionBase

Remarks

The Add and Remove methods enable you to add or remove controls from the collection. You can also use the AddRange or Clear methods to add or remove all controls from the collection.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionReportModel.ControlCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ControlCollection Class Members

[image]
ActiveReports 13
ControlCollection Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

The following tables list the members exposed by ControlCollection.

Public Constructors

 | Name | Description
Public Constructor | ControlCollection Constructor | Initializes a new instance of the ControlCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a control in the collection at the specified index or with a specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of ARControl objects to the collection.
Public Method | Clear | Removes all controls which were added to the collection using the Add method.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | CopyTo | Copies the controls collection from the specified report to a controls collection at the specified index.
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | Insert | Inserts the control specified in the value parameter at the specified index.
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes the control from the collection at the specified index.
Top

Public Events

 | Name | Description
Public Event | Changed | Raised when an ARControl is added to or removed from the collection.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ControlCollection Constructor

[image]
ActiveReports 13
ControlCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : ControlCollection Constructor

section
The report section in which the control collection resides.

Glossary Item Box

Initializes a new instance of the ControlCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal section As Section _
)
C#
public ControlCollection(
   Section section
)

Parameters

section
The report section in which the control collection resides.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


ControlCollection Class Methods

[image]
ActiveReports 13
ControlCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

For a list of all members of this type, see ControlCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of ARControl objects to the collection.
Public Method | Clear | Removes all controls which were added to the collection using the Add method.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | CopyTo | Copies the controls collection from the specified report to a controls collection at the specified index.
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | Insert | Inserts the control specified in the value parameter at the specified index.
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes the control from the collection at the specified index.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Add Method

control
The ARControl to add to the collection.

Glossary Item Box

Adds the specified control to the control collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal control As ARControl _
)
C#
public void Add(
   ARControl control
)

Parameters

control
The ARControl to add to the collection.

Remarks

The Add method adds the control to the end of the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members
ActiveReports6~GrapeCity.ActiveReports.ControlCollection~AddRange


AddRange Method

[image]
ActiveReports 13
AddRange Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : AddRange Method

controls
An array of ARControl objects to add to the collection.

Glossary Item Box

Adds an array of ARControl objects to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal controls() As ARControl _
)
C#
public void AddRange(
   ARControl[] controls
)

Parameters

controls
An array of ARControl objects to add to the collection.

Remarks

The ARControl objects in the array are appended to the end of the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    //array initialization is one-based, while array access is zero-based
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members
ActiveReports6~GrapeCity.ActiveReports.ControlCollection~Add


Clear Method

[image]
ActiveReports 13
Clear Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Clear Method

Glossary Item Box

Removes all controls which were added to the collection using the Add method.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Remarks

To remove individual controls from the collection, use the Remove method.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Sections[0].Controls.Clear();
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Sections(0).Controls.Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Contains Method

control
The control to locate in the collection.

Glossary Item Box

Determines whether the specified control is a member of the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal control As ARControl _
) As Boolean
C#
public bool Contains(
   ARControl control
)

Parameters

control
The control to locate in the collection.

Return Value

Boolean. Returns True if the control is a member of the collection; otherwise, False.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);

    if (this.Sections[0].Controls.Contains(t))
    {
        System.Windows.Forms.MessageBox.Show("t");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
    If Me.Sections(0).Controls.Contains(t) Then
        MessageBox.Show("t")
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : CopyTo Method

values
The array containing the copied controls.
index

The insertion index in the collection.

Glossary Item Box

Copies the controls collection from the specified report to a controls collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal values() As ARControl, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   ARControl[] values,
   int index
)

Parameters

values
The array containing the copied controls.
index

The insertion index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : IndexOf Method

control
The control to locate in the collection.

Glossary Item Box

Retrieves the index of the specified control in the control collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal control As ARControl _
) As Integer
C#
public int IndexOf(
   ARControl control
)

Parameters

control
The control to locate in the collection.

Return Value

A zero-based value that represents the position of the specified control in the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);
    System.Windows.Forms.MessageBox.Show (this.Sections[0].Controls.IndexOf(t).ToString());
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
    MessageBox.Show(Me.Sections(0).Controls.IndexOf(t))
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Insert Method

index
Index to which the control should be inserted.
control
Control to be inserted.

Glossary Item Box

Inserts the control specified in the value parameter at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal control As ARControl _
)
C#
public void Insert(
   int index,
   ARControl control
)

Parameters

index
Index to which the control should be inserted.
control
Control to be inserted.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t2 = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    t2.Text="Insert some more text here.";
    t2.Left=1;
    this.Sections[0].Controls.Add (t);
    this.Sections[0].Controls.Insert(1,t2);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    Dim t2 As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    t2.Text = "Insert some more text here."
    t2.Left = 1
    Me.Sections(0).Controls.Add(t)
    Me.Sections(0).Controls.Insert(0, t2)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Remove Method

control
The control to be removed from the collection.

Glossary Item Box

Removes the specified control from the control collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal control As ARControl _
)
C#
public void Remove(
   ARControl control
)

Parameters

control
The control to be removed from the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
    //remove the checkbox
    this.Sections[0].Controls.Remove(arr[0]);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
    'remove the specified control
    Me.Sections(0).Controls.Remove(c)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : RemoveAt Method

index
The index of the control to be removed.

Glossary Item Box

Removes the control from the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public new void RemoveAt(
   int index
)

Parameters

index
The index of the control to be removed.

Example

C# Copy Code
private void arReport_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
    //remove a control from a specified location
    this.Sections[0].Controls.RemoveAt(1);
}
Visual Basic Copy Code
Private Sub rptReport_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
    'remove a control from the specified location
    Me.Sections(0).Controls.RemoveAt(1)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


ControlCollection Class Properties

[image]
ActiveReports 13
ControlCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

For a list of all members of this type, see ControlCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a control in the collection at the specified index or with a specified name.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Item Property

Glossary Item Box

Returns a control in the collection at the specified index or with a specified name.

Overload List

Overload | Description
Item(Int32) | Gets the Control object at the specified indexed location in the ControlCollection.
Item(String) | Gets the Control object with the specified name in the ControlCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Item(Int32) Property

[image]
ActiveReports 13
Item(Int32) Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class > Item Property : Item(Int32) Property

index
The indexed location of the Control in the collection.

Glossary Item Box

Gets the Control object at the specified indexed location in the ControlCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ARControl
C#
public ARControl Item(
   int index
) {get;}

Parameters

index
The indexed location of the Control in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 13
Item(String) Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class > Item Property : Item(String) Property

name
The name of the Control in the collection.

Glossary Item Box

Gets the Control object with the specified name in the ControlCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ARControl
C#
public ARControl Item(
   string name
) {get;}

Parameters

name
The name of the Control in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members
Overload List


ControlCollection Class Events

[image]
ActiveReports 13
ControlCollection Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

Glossary Item Box

For a list of all members of this type, see ControlCollection members.

Public Events

 | Name | Description
Public Event | Changed | Raised when an ARControl is added to or removed from the collection.
Top

See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Changed Event

[image]
ActiveReports 13
Changed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Changed Event

Glossary Item Box

Raised when an ARControl is added to or removed from the collection.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


CrossSectionBox Class

[image]
ActiveReports 13
CrossSectionBox Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

The CrossSectionBox control renders a rectangular outline with its corners where you place them in the header and footer sections, and its vertical lines growing with intervening sections.

Object Model

CrossSectionBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CrossSectionBox
   Inherits CrossSectionControl
C#
public sealed class CrossSectionBox : CrossSectionControl

Remarks

The background color of the CrossSectionBox control is rendered on the report page before any other sections and controls. This means that the background color is visible on transparent sections only.

Unlike the background color, the border of the CrossSectionBox control is rendered after all other controls on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionBox Class Members

[image]
ActiveReports 13
CrossSectionBox Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

The following tables list the members exposed by CrossSectionBox.

Public Constructors

 | Name | Description
Public Constructor | CrossSectionBox Constructor | Initializes a new instance of the CrossSectionBox class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CloseBorder | Sets or Gets the state borders
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Radius | Set the Radius property to control the degree of rounding on the corners of the box.
Public Property | Start | Gets or sets the starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | GetDoubleRadius | Gets the run-time value of the radius property.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionBox Constructor

[image]
ActiveReports 13
CrossSectionBox Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : CrossSectionBox Constructor

Glossary Item Box

Initializes a new instance of the CrossSectionBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CrossSectionBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionBox Class Methods

[image]
ActiveReports 13
CrossSectionBox Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

For a list of all members of this type, see CrossSectionBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | GetDoubleRadius | Gets the run-time value of the radius property.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GetDoubleRadius Method

[image]
ActiveReports 13
GetDoubleRadius Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : GetDoubleRadius Method

Glossary Item Box

Gets the run-time value of the radius property.

Syntax

Visual Basic (Declaration)
Public Function GetDoubleRadius() As Single
C#
public float GetDoubleRadius()

Return Value

A Single or float value in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionBox Class Properties

[image]
ActiveReports 13
CrossSectionBox Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

Glossary Item Box

For a list of all members of this type, see CrossSectionBox members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CloseBorder | Sets or Gets the state borders
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Radius | Set the Radius property to control the degree of rounding on the corners of the box.
Public Property | Start | Gets or sets the starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top

See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Remarks

The background color of the CrossSectionBox control is rendered on the report page before any other sections and controls. This means that the background color is visible on transparent sections only.

Unlike the background color, the border of the CrossSectionBox control is rendered after all other controls on the page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CloseBorder Property

[image]
ActiveReports 13
CloseBorder Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : CloseBorder Property

Glossary Item Box

Sets or Gets the state borders

Syntax

Visual Basic (Declaration)
Public Property CloseBorder As Boolean
C#
public bool CloseBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


Radius Property

[image]
ActiveReports 13
Radius Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : Radius Property

Glossary Item Box

Set the Radius property to control the degree of rounding on the corners of the box.

Syntax

Visual Basic (Declaration)
Public Property Radius As CornersRadius
C#
public CornersRadius Radius {get; set;}

Property Value

An integer value in points.

Requirements

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionControl Class

[image]
ActiveReports 13
CrossSectionControl Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

Glossary Item Box

ARControl is the base class for ActiveReports CrossSection controls. You should not need to use this class in your application.

Object Model

CrossSectionControl Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class CrossSectionControl
   Inherits ARControl
C#
public abstract class CrossSectionControl : ARControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionControl Class Members

[image]
ActiveReports 13
CrossSectionControl Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

Glossary Item Box

The following tables list the members exposed by CrossSectionControl.

Public Properties

 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section.
Public Property | Height | Gets or sets the height of the control in inches. This value changes as the detail section and any other intervening sections grow at run time. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | LineColor | Gets or sets the color of the control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | Gets or sets the starting position of the cross section control in the header section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionControl Class Properties

[image]
ActiveReports 13
CrossSectionControl Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

Glossary Item Box

For a list of all members of this type, see CrossSectionControl members.

Public Properties

 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section.
Public Property | Height | Gets or sets the height of the control in inches. This value changes as the detail section and any other intervening sections grow at run time. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | LineColor | Gets or sets the color of the control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | Gets or sets the starting position of the cross section control in the header section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches.
Top

See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


End Property

[image]
ActiveReports 13
End Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : End Property

Glossary Item Box

The ending position of the cross section control in the footer section.

Syntax

Visual Basic (Declaration)
Public Property End As PointF
C#
public PointF End {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Left Property

Glossary Item Box

Gets or sets the left position of the control in inches.

Syntax

Visual Basic (Declaration)
Public Shadows Property Left As Single
C#
public new float Left {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineColor Property

[image]
ActiveReports 13
LineColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineColor Property

Glossary Item Box

Gets or sets the color of the control.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the line. The default value is Color.Black.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineStyle Property

[image]
ActiveReports 13
LineStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to draw the line.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

LineStyle enumeration. The default value is LineStyle.Solid. Possible values are:

  • LineStyle.Dash
  • LineStyle.DashDot
  • LineStyle.DashDotDot
  • LineStyle.Dot
  • LineStyle.Solid
  • LineStyle.Transparent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineWeight Property

[image]
ActiveReports 13
LineWeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width of the line in pixels.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current weight of the line in pixels. Default is 1.0f.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Start Property

[image]
ActiveReports 13
Start Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Start Property

Glossary Item Box

Gets or sets the starting position of the cross section control in the header section.

Syntax

Visual Basic (Declaration)
Public Property Start As PointF
C#
public PointF Start {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Top Property

Glossary Item Box

Gets or sets, in inches, the top position of the control relative to the section that contains it.

Syntax

Visual Basic (Declaration)
Public Shadows Property Top As Single
C#
public new float Top {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Width Property

Glossary Item Box

Gets or sets the width of the control in inches.

Syntax

Visual Basic (Declaration)
Public Shadows Property Width As Single
C#
public new float Width {get; set;}

Property Value

A float or Single value in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


CrossSectionLine Class

[image]
ActiveReports 13
CrossSectionLine Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

Glossary Item Box

The CrossSectionLine control renders a vertical line that begins where you place it in a header section, grows with any intervening sections, and ends where you place it in the related footer section.

Object Model

CrossSectionLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CrossSectionLine
   Inherits CrossSectionControl
C#
public sealed class CrossSectionLine : CrossSectionControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionLine Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Class Members

[image]
ActiveReports 13
CrossSectionLine Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

Glossary Item Box

The following tables list the members exposed by CrossSectionLine.

Public Constructors

 | Name | Description
Public Constructor | CrossSectionLine Constructor | Initializes a new instance of the CrossSectionLine class.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | The starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CrossSectionLine Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Constructor

[image]
ActiveReports 13
CrossSectionLine Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionLine Class : CrossSectionLine Constructor

Glossary Item Box

Initializes a new instance of the CrossSectionLine class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CrossSectionLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CrossSectionLine Class
CrossSectionLine Members


CustomControl Class

[image]
ActiveReports 13
CustomControl Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

CustomControl is a wrapper class that allows you to print .NET controls that inherit from System.Windows.Forms.Control

Object Model

CustomControl Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CustomControl
   Inherits ARControl
C#
public sealed class CustomControl : ARControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CustomControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Class Members

[image]
ActiveReports 13
CustomControl Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

The following tables list the members exposed by CustomControl.

Public Constructors

 | Name | Description
Public Constructor | CustomControl Constructor | Overloaded. Initializes a new instance of the CustomControl class.
Top

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Control | Gets or sets a reference to the hosted control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Type | Sets or returns the type of the custom control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Constructor

[image]
ActiveReports 13
CustomControl Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : CustomControl Constructor

Glossary Item Box

Initializes a new instance of the CustomControl class.

Overload List

Overload | Description
CustomControl Constructor(Type) | Initializes a new instance of the specified type of CustomControl class.
CustomControl Constructor() | Initializes a new instance of the CustomControl class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members


CustomControl Constructor(Type)

[image]
ActiveReports 13
CustomControl Constructor(Type)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class > CustomControl Constructor : CustomControl Constructor(Type)

type
Specifies the type of the control to be created.

Glossary Item Box

Initializes a new instance of the specified type of CustomControl class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type _
)
C#
public CustomControl(
   Type type
)

Parameters

type
Specifies the type of the control to be created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members
Overload List


CustomControl Constructor()

[image]
ActiveReports 13
CustomControl Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class > CustomControl Constructor : CustomControl Constructor()

Glossary Item Box

Initializes a new instance of the CustomControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CustomControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members
Overload List


CustomControl Class Properties

[image]
ActiveReports 13
CustomControl Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

For a list of all members of this type, see CustomControl members.

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Control | Gets or sets a reference to the hosted control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Type | Sets or returns the type of the custom control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Control Property

[image]
ActiveReports 13
Control Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : Control Property

Glossary Item Box

Gets or sets a reference to the hosted control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Control
C#
public Control Control {get;}

Example

C# Copy Code
private void Detail1_Format(object sender,System.EventArgs e)
{
 DataTable dt = new DataTable();
 dt.Columns.Add("Name", typeof(string));
 dt.Columns.Add("Age", typeof(int));
 dt.Rows.Add("Name1", 23);
 dt.Rows.Add("Name2", 34);
 System.Windows.Forms.DataGridView gridView = ((System.Windows.Forms.DataGridView)this.customControl1.Control);
 gridView.DataSource = dt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
Dim dt As New DataTable()
dt.Columns.Add("Name", GetType(String))
dt.Columns.Add("Age", GetType(Integer))
dt.Rows.Add("Name1", 23)
dt.Rows.Add("Name2", 34)
Dim gridView As System.Windows.Forms.DataGridView = DirectCast(Me.customControl1.Control, System.Windows.Forms.DataGridView)
gridView.DataSource = dt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members

How To

Use Custom Controls on Reports (TreeView)


ImageType Property

[image]
ActiveReports 13
ImageType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : ImageType Property

Glossary Item Box

Sets or returns the type of image to which the chart will be rendered on the report.

Syntax

Visual Basic (Declaration)
Public Property ImageType As ImageTypes
C#
public ImageTypes ImageType {get; set;}

Property Value

An ImageTypes enumeration. The default value is Metafile. The alternate value is PNG.

Remarks

Some images can be a problem when exported as a metafile due to some graphic commands that are not supported. If you are noticing problems with images not exporting to PDF, set the ImageType to PNG.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members
ActiveReports6~GrapeCity.ActiveReports.ImageTypes


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : Type Property

Glossary Item Box

Sets or returns the type of the custom control.

Syntax

Visual Basic (Declaration)
Public Property Type As Type
C#
public Type Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomControl Class
CustomControl Members


Detail Class

[image]
ActiveReports 13
Detail Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

Detail section is the main section in a report. It is printed once for each record in the data source.

Object Model

Detail Class

Syntax

Visual Basic (Declaration)
Public Class Detail
   Inherits Section
C#
public class Detail : Section

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
    this.detail.ColumnDirection = ColumnDirection.DownAcross;
    this.detail.ColumnSpacing = 1;
    this.detail.KeepTogether = true;
    this.detail.NewColumn = NewColumn.After;
    this.detail.NewPage = NewPage.Before;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.ColumnCount = 1
   Me.Detail1.ColumnDirection = ColumnDirection.DownAcross
   Me.Detail1.ColumnSpacing = 1
   Me.Detail1.KeepTogether = True
   Me.Detail1.NewColumn = NewColumn.After
   Me.Detail1.NewPage = NewPage.Before
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Class Members

[image]
ActiveReports 13
Detail Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

The following tables list the members exposed by Detail.

Public Constructors

 | Name | Description
Public Constructor | Detail Constructor | Initializes a new instance of the Detail class.
Top

Public Properties

Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanGrow

Indicates whether the section height should grow when its controls extend beyond its original height.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanShrink

Indicates whether the section height should be adjusted to the exact total height of its controls.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnCount | Gets or sets a value that specifies the number of newspaper columns in the report.
Public Property | ColumnDirection | Determines how ActiveReports should print the detail section in a multi-column report.
Public Property | ColumnSpacing | Sets or returns the space between columns in a multi-column report.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property RepeatToFill

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property Visible

Specifies whether the section should be printed or not.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Constructor

[image]
ActiveReports 13
Detail Constructor
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : Detail Constructor

Glossary Item Box

Initializes a new instance of the Detail class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Detail()

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
    this.detail.ColumnDirection = ColumnDirection.DownAcross;
    this.detail.ColumnSpacing = 1;
    this.detail.KeepTogether = true;
    this.detail.NewColumn = NewColumn.None;
    this.detail.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.ColumnCount = 1
    Me.Detail1.ColumnDirection = ColumnDirection.DownAcross
    Me.Detail1.ColumnSpacing = 1
    Me.Detail1.KeepTogether = True
    Me.Detail1.NewColumn = NewColumn.None
    Me.Detail1.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


Detail Class Properties

[image]
ActiveReports 13
Detail Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

For a list of all members of this type, see Detail members.

Public Properties

Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanGrow

Indicates whether the section height should grow when its controls extend beyond its original height.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanShrink

Indicates whether the section height should be adjusted to the exact total height of its controls.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnCount | Gets or sets a value that specifies the number of newspaper columns in the report.
Public Property | ColumnDirection | Determines how ActiveReports should print the detail section in a multi-column report.
Public Property | ColumnSpacing | Sets or returns the space between columns in a multi-column report.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property RepeatToFill

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property Visible

Specifies whether the section should be printed or not.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnCount Property

[image]
ActiveReports 13
ColumnCount Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnCount Property

Glossary Item Box

Gets or sets a value that specifies the number of newspaper columns in the report.

Syntax

Visual Basic (Declaration)
Public Property ColumnCount As Integer
C#
public int ColumnCount {get; set;}

Property Value

Integer value that represents the current number of columns in the report; default is 1.

Remarks

This property can be used to print labels or phonebook-style listings. The width of each column equals the PrintWidth of the report divided by the number of columns.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail.ColumnCount = 1
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~ColumnLayout
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnDirection
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnSpacing


ColumnDirection Property

[image]
ActiveReports 13
ColumnDirection Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnDirection Property

Glossary Item Box

Determines how ActiveReports should print the detail section in a multi-column report.

Syntax

Visual Basic (Declaration)
Public Property ColumnDirection As ColumnDirection
C#
public ColumnDirection ColumnDirection {get; set;}

Property Value

ColumnDirection enumeration value that specifies whether the report will be printed across or down; default is ColumnDirection.DownAcross.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 3;
    this.detail.ColumnDirection = ColumnDirection.AcrossDown;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.Detail1.ColumnCount = 3
   Me.Detail1.ColumnDirection = ColumnDirection.AcrossDown
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnCount
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnSpacing
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~ColumnLayout


ColumnSpacing Property

[image]
ActiveReports 13
ColumnSpacing Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnSpacing Property

Glossary Item Box

Sets or returns the space between columns in a multi-column report.

Syntax

Visual Basic (Declaration)
Public Property ColumnSpacing As Single
C#
public float ColumnSpacing {get; set;}

Property Value

A single value that represents the space between columns.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 3;
    this.detail.ColumnSpacing = 1;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.ColumnCount = 3
   Me.Detail1.ColumnSpacing = 1
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


KeepTogether Property

[image]
ActiveReports 13
KeepTogether Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


NewColumn Property

[image]
ActiveReports 13
NewColumn Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : NewColumn Property

Glossary Item Box

Gets or sets a value that determines whether a new column should be started before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewColumn As NewColumn
C#
public NewColumn NewColumn {get; set;}

Property Value

NewColumn Enumeration. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.NewColumn = NewColumn.BeforeAfter;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.NewColumn = NewColumn.BeforeAfter
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


NewPage Property

[image]
ActiveReports 13
NewPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.NewPage = NewPage.BeforeAfter;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.NewPage = NewPage.BeforeAfter
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


RepeatToFill Property

[image]
ActiveReports 13
RepeatToFill Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : RepeatToFill Property

Glossary Item Box

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Syntax

Visual Basic (Declaration)
Public Property RepeatToFill As Boolean
C#
public bool RepeatToFill {get; set;}

Property Value

A Boolean value. True if the section will print formatting to fill the page if its contents permit; otherwise, False.

Remarks

Note: The RepeatToFill property cannot be used if the PageBreak or SubReport control is used in the Detail section, or if the NewPage or NewColumn property is set to any value other than None.

When you use this property when two groups are present, the second GroupFooter section is always on the next page. It processes correctly only with a single grouping. The ReportFooter section also prints on the next page when you set this property to True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Detail Class
Detail Members


GroupFooter Class

[image]
ActiveReports 13
GroupFooter Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

The GroupFooter section is directly related to the Detail section and its matching group header. It prints once each time a group of similar records (as defined in the GroupHeader.DataField property) ends. A GroupFooter section cannot exist without a matching GroupHeader section.

Object Model

GroupFooter Class

Syntax

Visual Basic (Declaration)
Public Class GroupFooter
   Inherits Section
C#
public class GroupFooter : Section

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.KeepTogether = true;
    this.groupFooter1.NewColumn = NewColumn.None;
    this.groupFooter1.NewPage = NewPage.None;
    this.groupFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
   Me.GroupFooter1.KeepTogether = True
   Me.GroupFooter1.NewColumn = NewColumn.None
   Me.GroupFooter1.NewPage = NewPage.None
   Me.GroupFooter1.PrintAtBottom = True
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.GroupFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Class Members

[image]
ActiveReports 13
GroupFooter Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

The following tables list the members exposed by GroupFooter.

Public Constructors

 | Name | Description
Public Constructor | GroupFooter Constructor | Initializes a new instance of the GroupFooter class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout of its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the group footer.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Constructor

[image]
ActiveReports 13
GroupFooter Constructor
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : GroupFooter Constructor

Glossary Item Box

Initializes a new instance of the GroupFooter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GroupFooter()

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.KeepTogether = true;
    this.groupFooter1.NewColumn = NewColumn.None;
    this.groupFooter1.NewPage = NewPage.None;
    this.groupFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.GroupFooter1.ColumnLayout = True
    Me.GroupFooter1.KeepTogether = True
    Me.GroupFooter1.NewColumn = NewColumn.None
    Me.GroupFooter1.NewPage = NewPage.None
    Me.GroupFooter1.PrintAtBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


GroupFooter Class Properties

[image]
ActiveReports 13
GroupFooter Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

For a list of all members of this type, see GroupFooter members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout of its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the group footer.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnLayout Property

[image]
ActiveReports 13
ColumnLayout Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : ColumnLayout Property

Glossary Item Box

Gets or sets a value to determine whether the section should use the same column layout of its detail section.

Syntax

Visual Basic (Declaration)
Public Property ColumnLayout As Boolean
C#
public bool ColumnLayout {get; set;}

Property Value

A Boolean value. True if the section will have the same number of columns as its detail section. False if the section will have a single column.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnCount


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : Height Property

Glossary Item Box

Gets or sets the height of the group footer.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


KeepTogether Property

[image]
ActiveReports 13
KeepTogether Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


NewColumn Property

[image]
ActiveReports 13
NewColumn Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : NewColumn Property

Glossary Item Box

Gets or sets a value that determines whether a new column should be started before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewColumn As NewColumn
C#
public NewColumn NewColumn {get; set;}

Property Value

NewColumn Enumeration. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.NewColumn = NewColumn.After;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
   Me.GroupFooter1.NewColumn = NewColumn.After
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


NewPage Property

[image]
ActiveReports 13
NewPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.NewPage = NewPage.Before;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.NewPage = NewPage.Before
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


PrintAtBottom Property

[image]
ActiveReports 13
PrintAtBottom Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : PrintAtBottom Property

Glossary Item Box

Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.

Syntax

Visual Basic (Declaration)
Public Property PrintAtBottom As Boolean
C#
public bool PrintAtBottom {get; set;}

Property Value

A Boolean value. True if the footer section will be printed at the bottom of the page; otherwise, False.

Remarks

Setting more than one group footer section in a report layout to print at the bottom of the page will cause subsequent group footer sections to print on separate pages.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.PrintAtBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupFooter Class
GroupFooter Members


GroupHeader Class

[image]
ActiveReports 13
GroupHeader Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

The GroupHeader section prints once for every data group defined using the field specified in DataField property. A GroupHeader section requires a matching GroupFooter section.

Object Model

GroupHeader Class

Syntax

Visual Basic (Declaration)
Public Class GroupHeader
   Inherits Section
C#
public class GroupHeader : Section

Remarks

Since ActiveReports does not sort the data before grouping it, your data source should be sorted on all the data fields that you have specified in group header sections. For example, for a report to properly create two groups on Country and City data fields you must sort the data by those data fields in the specified order. If your data is not sorted you end up with the same group appearing multiple times in the report at different locations (i.e. the report is NOT grouped).

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.None;
    this.groupHeader1.KeepTogether = true;
    this.groupHeader1.NewColumn = NewColumn.None;
    this.groupHeader1.NewPage = NewPage.None;
    this.groupHeader1.RepeatStyle =  RepeatStyle.None;
    this.groupHeader1.UnderlayNext = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.None
   Me.GroupHeader1.KeepTogether = True
   Me.GroupHeader1.NewColumn = NewColumn.None
   Me.GroupHeader1.NewPage = NewPage.None
   Me.GroupHeader1.RepeatStyle = RepeatStyle.None
   Me.GroupHeader1.UnderlayNext = True
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.GroupHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Class Members

[image]
ActiveReports 13
GroupHeader Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

The following tables list the members exposed by GroupHeader.

Public Constructors

 | Name | Description
Public Constructor | GroupHeader Constructor | Initializes a new instance of the GroupHeader class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnGroupKeepTogether | Gets or sets a value that specifies whether the group will print as a single block in the same column.
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout as its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | DataField | Gets or sets the name of the field used to group the data source records.
Public Property | GroupKeepTogether | Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.
Public Property | Height | Gets or sets the height of the group header.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | RepeatStyle | Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | UnderlayNext | Gets or sets a value that specifies whether the section should print underneath the following section.
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Constructor

[image]
ActiveReports 13
GroupHeader Constructor
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : GroupHeader Constructor

Glossary Item Box

Initializes a new instance of the GroupHeader class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GroupHeader()

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.DataField = "Country";
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.None;
    this.groupHeader1.KeepTogether = true;
    this.groupHeader1.NewColumn = NewColumn.None;
    this.groupHeader1.NewPage = NewPage.None;
    this.groupHeader1.RepeatStyle =  RepeatStyle.None;
    this.groupHeader1.UnderlayNext = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    Me.GroupHeader1.ColumnLayout = True
    Me.GroupHeader1.DataField = "Country"
    Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.None
    Me.GroupHeader1.KeepTogether = True
    Me.GroupHeader1.NewColumn = NewColumn.None
    Me.GroupHeader1.NewPage = NewPage.None
    Me.GroupHeader1.RepeatStyle = RepeatStyle.None
    Me.GroupHeader1.UnderlayNext = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


GroupHeader Class Properties

[image]
ActiveReports 13
GroupHeader Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

For a list of all members of this type, see GroupHeader members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnGroupKeepTogether | Gets or sets a value that specifies whether the group will print as a single block in the same column.
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout as its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | DataField | Gets or sets the name of the field used to group the data source records.
Public Property | GroupKeepTogether | Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.
Public Property | Height | Gets or sets the height of the group header.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | RepeatStyle | Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | UnderlayNext | Gets or sets a value that specifies whether the section should print underneath the following section.
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnGroupKeepTogether Property

[image]
ActiveReports 13
ColumnGroupKeepTogether Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : ColumnGroupKeepTogether Property

Glossary Item Box

Gets or sets a value that specifies whether the group will print as a single block in the same column.

Syntax

Visual Basic (Declaration)
Public Property ColumnGroupKeepTogether As Boolean
C#
public bool ColumnGroupKeepTogether {get; set;}

Property Value

Boolean.

Remarks

The Boolean ColumnGroupKeepTogether property will only be implemented when the GroupHeader's GroupKeepTogether property is set to All.

The purpose of this property is to prevent a group from splitting across columns. If the group will not fit in the current column, ActiveReports will attempt to render the full group in the next column. If the group is too large to fit in a single column, this property will be ignored.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.All;
    this.groupHeader1.ColumnGroupKeepTogether = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.All
   Me.GroupHeader1.ColumnGroupKeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


ColumnLayout Property

[image]
ActiveReports 13
ColumnLayout Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : ColumnLayout Property

Glossary Item Box

Gets or sets a value to determine whether the section should use the same column layout as its detail section.

Syntax

Visual Basic (Declaration)
Public Property ColumnLayout As Boolean
C#
public bool ColumnLayout {get; set;}

Property Value

A Boolean value. True if the section will have the same number of columns as its detail section. False if the section will have a single column.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


DataField Property

[image]
ActiveReports 13
DataField Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : DataField Property

Glossary Item Box

Gets or sets the name of the field used to group the data source records.

Syntax

Visual Basic (Declaration)
Public Property DataField As String
C#
public string DataField {get; set;}

Property Value

A string value that represents the name of the field to be grouped.

Remarks

ActiveReports checks for any changes in the value of the specified field and starts a new group when the value changes. Current groups are ended (i.e. the group footer section is printed) before the new group is started.

The specified field can originate from the data source or an unbound field added to the Fields collection in the DataInitialize event.

Example

C# Copy Code
private void rptSection_ReportStart(object sender, System.EventArgs eArgs)
{
  this.groupHeader1.DataField = "Country";
}
Visual Basic Copy Code
Private Sub rptSection_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
 Me.GroupHeader1.DataField = "Country"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


GroupKeepTogether Property

[image]
ActiveReports 13
GroupKeepTogether Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : GroupKeepTogether Property

Glossary Item Box

Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.

Syntax

Visual Basic (Declaration)
Public Property GroupKeepTogether As GroupKeepTogether
C#
public GroupKeepTogether GroupKeepTogether {get; set;}

Property Value

GroupKeepTogether enumeration. Default is GroupKeepTogether.None. Possible values are:

  • GroupKeepTogether.All
  • GroupKeepTogether.FirstDetail
  • GroupKeepTogether.None

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.FirstDetail;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.FirstDetail
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~KeepTogether


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : Height Property

Glossary Item Box

Gets or sets the height of the group header.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


KeepTogether Property

[image]
ActiveReports 13
KeepTogether Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~GroupKeepTogether


NewColumn Property

[image]
ActiveReports 13
NewColumn Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : NewColumn Property

Glossary Item Box

Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewColumn As NewColumn
C#
public NewColumn NewColumn {get; set;}

Property Value

A NewColumn enumeration value that determines the behavior of column breaks before or after printing the section. The default value is NewColumn.None. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.NewColumn = NewColumn.None;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.NewColumn = NewColumn.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


NewPage Property

[image]
ActiveReports 13
NewPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


RepeatStyle Property

[image]
ActiveReports 13
RepeatStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : RepeatStyle Property

Glossary Item Box

Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.

Syntax

Visual Basic (Declaration)
Public Property RepeatStyle As RepeatStyle
C#
public RepeatStyle RepeatStyle {get; set;}

Property Value

A RepeatStyle enumeration. The default value is RepeatStyle.None. Possible values are:

  • RepeatStyle.All
  • RepeatStyle.None
  • RepeatStyle.OnColumn
  • RepeatStyle.OnPage
  • RepeatStyle.OnPageIncludeNoDetail (prevents orphaned footers)

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.RepeatStyle =  RepeatStyle.OnPageIncludeNoDetail;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


UnderlayNext Property

[image]
ActiveReports 13
UnderlayNext Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : UnderlayNext Property

Glossary Item Box

Gets or sets a value that specifies whether the section should print underneath the following section.

Syntax

Visual Basic (Declaration)
Public Property UnderlayNext As Boolean
C#
public bool UnderlayNext {get; set;}

Property Value

A Boolean value. True if the following section will start rendering at the top of this section; otherwise, False.

Remarks

If this property is set to True, be sure that the next section's BackColor is set to System.Drawing.Color.Transparent. Otherwise, the GroupHeader will be hidden behind the next section.

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.UnderlayNext = true;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.UnderlayNext = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupHeader Class
GroupHeader Members


Label Class

[image]
ActiveReports 13
Label Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Glossary Item Box

Prints static text on the report.

Object Model

Label Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Label
   Inherits ARControl
C#
public sealed class Label : ARControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Alignment = TextAlignment.Left;
    this.label1.Angle = 0;
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.ClassName = "Normal";
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    this.label1.HyperLink = "mailto:support@company.com";
    this.label1.MultiLine = false;
    this.label1.Text = "Label";
    this.label1.VerticalAlignment = VerticalTextAlignment.Top;
    this.label1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Alignment = TextAlignment.Left
   Me.Label1.Angle = 0
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.ClassName = "Normal"
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   Me.Label1.HyperLink = "mailto:support@company.com"
   Me.Label1.MultiLine = False
   Me.Label1.Text = "Label"
   Me.Label1.VerticalAlignment = VerticalTextAlignment.Top
   Me.Label1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Label

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Class Members

[image]
ActiveReports 13
Label Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Glossary Item Box

The following tables list the members exposed by Label.

Public Constructors

 | Name | Description
Public Constructor | Label Constructor | Initializes a new instance of the Label class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | Angle | Gets or sets the angle (slope) of the text within the control area.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the label control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the label control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multi-line label control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the label.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the text of the label to be printed.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the current Value of the Label control.
Public Property | VerticalAlignment | Gets or sets the position of the label's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Constructor

[image]
ActiveReports 13
Label Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Label Constructor

Glossary Item Box

Initializes a new instance of the Label class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Label()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Label Class Properties

[image]
ActiveReports 13
Label Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Glossary Item Box

For a list of all members of this type, see Label members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | Angle | Gets or sets the angle (slope) of the text within the control area.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the label control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the label control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multi-line label control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the label.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the text of the label to be printed.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the current Value of the Label control.
Public Property | VerticalAlignment | Gets or sets the position of the label's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Alignment Property

Glossary Item Box

Gets or sets the alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As GrapeCity.ActiveReports.Drawing.TextAlignment
C#
public GrapeCity.ActiveReports.Drawing.TextAlignment Alignment {get; set;}

Property Value

TextAlignment enum. The default value is TextAlignment.Left. Possible values are:

  • TextAlignment.Center
  • TextAlignment.Justify
  • TextAlignment.Left
  • TextAlignment.Right

Remarks

The Justify text alignment option is not supported in edit mode. The text alignment automatically changes from Justify to Left (default value) when the control is in edit mode, and then back to Justify after exiting edit mode.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Alignment = TextAlignment.Left;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Alignment = TextAlignment.Left
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
VerticalAlignment Property
TextAlignment Property


Angle Property

[image]
ActiveReports 13
Angle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Angle Property

Glossary Item Box

Gets or sets the angle (slope) of the text within the control area.

Syntax

Visual Basic (Declaration)
Public Property Angle As Integer
C#
public int Angle {get; set;}

Property Value

Angle value in 1/10 of a degree. Default value is 0.

Remarks

To set a label's angle to 90 degrees, set the Angle property to 900, and be sure the height of the control will accommodate the text, as labels do not grow automatically.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Angle = 900;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Angle = 900
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~ForeColor


CharacterSpacing Property

[image]
ActiveReports 13
CharacterSpacing Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : CharacterSpacing Property

Glossary Item Box

Gets or sets the distance in points between individual characters in the label control.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Remarks

The integrity of character spacing cannot be guaranteed to correctly duplicate your settings when exporting reports in XLS, RTF, and TEXT formats.

Example

C# Copy Code
private void detail1_Format(object sender, EventArgs e)
{
   this.label1.MultiLine = true;
   this.label1.CharacterSpacing = 2;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.label1.MultiLine = True
   Me.label1.CharacterSpacing = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


ClassName Property

[image]
ActiveReports 13
ClassName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String value that represents the style class name used to format the control's appearance. Default is Normal.

Remarks

You can use predefined styles in the report's stylesheet or add new ones to it.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.ClassName = "Normal";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.ClassName = "Normal"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


Font Property

[image]
ActiveReports 13
Font Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

System.Drawing.Font. Current Font object used to render the control's text.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color. Default is Color.Black.

Example

C# Copy Code
private void dDetail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.ForeColor = System.Drawing.Color.Brown;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.ForeColor = System.Drawing.Color.Brown
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~BackColor


HyperLink Property

[image]
ActiveReports 13
HyperLink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : HyperLink Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Remarks

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "http://www.grapecity.com") for this property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.HyperLink = "mailto:support@company.com";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.HyperLink = "mailto:support@company.com"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
HyperLinkEventArgs


LineSpacing Property

[image]
ActiveReports 13
LineSpacing Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : LineSpacing Property

Glossary Item Box

Gets or sets the spacing in points between the lines of text within the label control.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   this.lblInfo.MultiLine = true;
   this.lblInfo.LineSpacing = 2;
}
VB.NET Copy Code
Private Sub detail_Format(sender As Object, e As EventArgs)
    Me.lblInfo.MultiLine = True
    Me.lblInfo.LineSpacing = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


MinCondenseRate Property

[image]
ActiveReports 13
MinCondenseRate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : MinCondenseRate Property

Glossary Item Box

Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property MinCondenseRate As Integer
C#
public int MinCondenseRate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


MultiLine Property

[image]
ActiveReports 13
MultiLine Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : MultiLine Property

Glossary Item Box

Gets or sets a value indicating whether this is a multi-line label control.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Property Value

A Boolean value. True if the label control is multiline; otherwise, False.

Remarks

A multi-line label control renders the label's text on more than one line. If the WordWrap property is set to True, long lines will be wrapped to the following line. If the WordWrap property is set to False, the text will print on a new line only when a new line character is encountered.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.MultiLine = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.MultiLine = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~WordWrap


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Remarks

This property has five settings at design time: All, Left, Top, Right, and Bottom. More settings, like Vertical and Horizontal, are available in code. The All property has a default value of -1, which means that all of the Padding values are not equal. Change this value to 10, and a space ten pixels wide is left around the text on all sides. The Left, Top, Right, and Bottom properties are 0, 0, 0, 0 by default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : RightToLeft Property

Glossary Item Box

Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


ShrinkToFit Property

[image]
ActiveReports 13
ShrinkToFit Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ShrinkToFit Property

Glossary Item Box

Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property ShrinkToFit As Boolean
C#
public bool ShrinkToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Style Property

[image]
ActiveReports 13
Style Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Style Property

Glossary Item Box

Gets or sets a style string for the label.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

String. CSS syntax of the control style.

Remarks

The style string overrides the global style rules specified in the ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label
ActiveReports6~GrapeCity.ActiveReports.Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


Text Property

[image]
ActiveReports 13
Text Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Text Property

Glossary Item Box

Gets or sets the text of the label to be printed.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Text = "Label";
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.Label1.Text = "Label"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


TextJustify Property

[image]
ActiveReports 13
TextJustify Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : TextJustify Property

Glossary Item Box

Gets or sets the type of justification to use when the Alignment property is set to Justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As GrapeCity.ActiveReports.Drawing.TextJustify
C#
public GrapeCity.ActiveReports.Drawing.TextJustify TextJustify {get; set;}

Property Value

TextJustify enum. The default value is Auto. Possible values are:

  • Auto
  • Distribute
  • DistributeAllLines

Remarks

When you set the Alignment property to Justify, this property extends your justification options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Value Property

[image]
ActiveReports 13
Value Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Value Property

Glossary Item Box

Gets or sets the current Value of the Label control.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Property Value

Object.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Value="Title";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Value = "Title"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


VerticalAlignment Property

[image]
ActiveReports 13
VerticalAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the position of the label's text vertically within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As GrapeCity.ActiveReports.Drawing.VerticalTextAlignment
C#
public GrapeCity.ActiveReports.Drawing.VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

Current vertical alignment of the label's text. Default is VerticalTextAlignment.Top. Possible values are:

  • VerticalTextAlignment.Bottom
  • VerticalTextAlignment.Middle
  • VerticalTextAlignment.Top

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.VerticalAlignment = VerticalTextAlignment.Top;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.VerticalAlignment = VerticalTextAlignment.Top
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~Alignment


VerticalText Property

[image]
ActiveReports 13
VerticalText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : VerticalText Property

Glossary Item Box

Gets or sets whether the control's text is rendered according to the vertical layout rules.

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Remarks

In case of the HTML export filter, the vertical text is supported just for the DynamicHtml output type and works with Microsoft Internet Explorer only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


WrapMode Property

[image]
ActiveReports 13
WrapMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : WrapMode Property

Glossary Item Box

Sets/gets control's wrap mode using CSS.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As GrapeCity.ActiveReports.Drawing.WrapMode
C#
public GrapeCity.ActiveReports.Drawing.WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


Line Class

[image]
ActiveReports 13
Line Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

Glossary Item Box

Prints a line on the report.

Object Model

Line Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Line
   Inherits ARControl
C#
public sealed class Line : ARControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.line1.LineColor = System.Drawing.Color.Blue;
    this.line1.LineStyle = LineStyle.DashDot;
    this.line1.LineWeight = 2.0f;
    this.line1.X1 = 1.0f;
    this.line1.X2 = 4.0f;
    this.line1.Y1 = 0.5f;
    this.line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Line1.LineColor = System.Drawing.Color.Blue
    Me.Line1.LineStyle = LineStyle.DashDot
    Me.Line1.LineWeight = 2.0F
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Line

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Class Members

[image]
ActiveReports 13
Line Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

Glossary Item Box

The following tables list the members exposed by Line.

Public Constructors

 | Name | Description
Public Constructor | Line Constructor | Initializes a new instance of the Line class.
Top

Public Properties

 | Name | Description
Public Property | AnchorBottom | Anchors the line to the bottom of the containing section.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the line control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Overridden. Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | X1 | Gets or sets the horizontal coordinate of the line's starting point.
Public Property | X2 | Gets or sets the horizontal coordinate of the line's end point.
Public Property | Y1 | Gets or sets the vertical coordinate of the line's starting point.
Public Property | Y2 | Gets or sets the vertical coordinate of the line's end point.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Constructor

[image]
ActiveReports 13
Line Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Line Constructor

Glossary Item Box

Initializes a new instance of the Line class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Line()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Line Class Properties

[image]
ActiveReports 13
Line Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

Glossary Item Box

For a list of all members of this type, see Line members.

Public Properties

 | Name | Description
Public Property | AnchorBottom | Anchors the line to the bottom of the containing section.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the line control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Overridden. Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | X1 | Gets or sets the horizontal coordinate of the line's starting point.
Public Property | X2 | Gets or sets the horizontal coordinate of the line's end point.
Public Property | Y1 | Gets or sets the vertical coordinate of the line's starting point.
Public Property | Y2 | Gets or sets the vertical coordinate of the line's end point.
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AnchorBottom Property

[image]
ActiveReports 13
AnchorBottom Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : AnchorBottom Property

Glossary Item Box

Anchors the line to the bottom of the containing section.

Syntax

Visual Basic (Declaration)
Public Property AnchorBottom As Boolean
C#
public bool AnchorBottom {get; set;}

Property Value

Boolean.

Remarks

When set to True, this property will create a continuous line from line controls in adjacent sections.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.line1.AnchorBottom = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Line1.AnchorBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


LineColor Property

[image]
ActiveReports 13
LineColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineColor Property

Glossary Item Box

Gets or sets the color of the line control.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the line. The default value is Color.Black.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineColor = System.Drawing.Color.Blue;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineColor = System.Drawing.Color.Blue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Line~LineWeight


LineStyle Property

[image]
ActiveReports 13
LineStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to draw the line.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

LineStyle enumeration. The default value is LineStyle.Solid. Possible values are:

  • LineStyle.Dash
  • LineStyle.DashDot
  • LineStyle.DashDotDot
  • LineStyle.Dot
  • LineStyle.Solid
  • LineStyle.Transparent

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineStyle = LineStyle.DashDot;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineStyle = LineStyle.DashDot
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~LineColor
ActiveReports6~GrapeCity.ActiveReports.Line~LineWeight


LineWeight Property

[image]
ActiveReports 13
LineWeight Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width of the line in pixels.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current weight of the line in pixels. Default is 1.0f.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~LineColor
ActiveReports6~GrapeCity.ActiveReports.Line~LineStyle


Location Property

[image]
ActiveReports 13
Location Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Location Property

Glossary Item Box

Gets or sets the location of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Location As PointF
C#
public override PointF Location {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0.5f;
    p.Y = 0.5f;
    this.line1.Location = p;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim p As System.Drawing.PointF
    p.X = 0.5
    p.Y = 0.5
    Me.Line1.Location = p
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Size Property

Glossary Item Box

Gets or sets the size of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Size As SizeF
C#
public override SizeF Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


X1 Property

[image]
ActiveReports 13
X1 Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : X1 Property

Glossary Item Box

Gets or sets the horizontal coordinate of the line's starting point.

Syntax

Visual Basic (Declaration)
Public Property X1 As Single
C#
public float X1 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X2
ActiveReports6~GrapeCity.ActiveReports.Line~Y1
ActiveReports6~GrapeCity.ActiveReports.Line~Y2


X2 Property

[image]
ActiveReports 13
X2 Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : X2 Property

Glossary Item Box

Gets or sets the horizontal coordinate of the line's end point.

Syntax

Visual Basic (Declaration)
Public Property X2 As Single
C#
public float X2 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X1
ActiveReports6~GrapeCity.ActiveReports.Line~Y1
ActiveReports6~GrapeCity.ActiveReports.Line~Y2


Y1 Property

[image]
ActiveReports 13
Y1 Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Y1 Property

Glossary Item Box

Gets or sets the vertical coordinate of the line's starting point.

Syntax

Visual Basic (Declaration)
Public Property Y1 As Single
C#
public float Y1 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X1
ActiveReports6~GrapeCity.ActiveReports.Line~X2
ActiveReports6~GrapeCity.ActiveReports.Line~Y2


Y2 Property

[image]
ActiveReports 13
Y2 Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Y2 Property

Glossary Item Box

Gets or sets the vertical coordinate of the line's end point.

Syntax

Visual Basic (Declaration)
Public Property Y2 As Single
C#
public float Y2 {get; set;}

Remarks

Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X1
ActiveReports6~GrapeCity.ActiveReports.Line~X2
ActiveReports6~GrapeCity.ActiveReports.Line~Y1


OleObject Class

[image]
ActiveReports 13
OleObject Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

OleObject is a wrapper class for printing OLE objects.

Object Model

OleObject Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OleObject
   Inherits ARControl
C#
public sealed class OleObject : ARControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.OleObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Members
GrapeCity.ActiveReports.SectionReportModel Namespace


OleObject Class Members

[image]
ActiveReports 13
OleObject Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

The following tables list the members exposed by OleObject.

Public Constructors

 | Name | Description
Public Constructor | OleObject Constructor | Initializes a new instance of the OleObject class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Class | Specifies the class name of the Ole object.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the object's content within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the OleObject control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | CreateFrom | Creates an Ole Object to embed in the control from the specified file.
Public Method | Edit | Invokes the Ole server to edit the current embedded instance.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


OleObject Constructor

[image]
ActiveReports 13
OleObject Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : OleObject Constructor

Glossary Item Box

Initializes a new instance of the OleObject class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OleObject()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


OleObject Class Methods

[image]
ActiveReports 13
OleObject Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

For a list of all members of this type, see OleObject members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | CreateFrom | Creates an Ole Object to embed in the control from the specified file.
Public Method | Edit | Invokes the Ole server to edit the current embedded instance.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CreateFrom Method

[image]
ActiveReports 13
CreateFrom Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : CreateFrom Method

fileName
Specifies the file to be used to create an embedded Ole object. A valid Ole server for the specified file type should be installed to handle the file instance.

Glossary Item Box

Creates an Ole Object to embed in the control from the specified file.

Syntax

Visual Basic (Declaration)
Public Sub CreateFrom( _
   ByVal fileName As String _
)
C#
public void CreateFrom(
   string fileName
)

Parameters

fileName
Specifies the file to be used to create an embedded Ole object. A valid Ole server for the specified file type should be installed to handle the file instance.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


Edit Method

[image]
ActiveReports 13
Edit Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : Edit Method

parentWindow
Specifies the parent window of the Ole object instance.

Glossary Item Box

Invokes the Ole server to edit the current embedded instance.

Syntax

Visual Basic (Declaration)
Public Sub Edit( _
   ByVal parentWindow As IWin32Window _
)
C#
public void Edit(
   IWin32Window parentWindow
)

Parameters

parentWindow
Specifies the parent window of the Ole object instance.

Remarks

End user report designer use only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


OleObject Class Properties

[image]
ActiveReports 13
OleObject Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

Glossary Item Box

For a list of all members of this type, see OleObject members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Class | Specifies the class name of the Ole object.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the object's content within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the OleObject control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.BackColor=System.Drawing.Color.OrangeRed;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.BackColor = System.Drawing.Color.CornflowerBlue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


Class Property

[image]
ActiveReports 13
Class Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : Class Property

Glossary Item Box

Specifies the class name of the Ole object.

Syntax

Visual Basic (Declaration)
Public Property Class As String
C#
public string Class {get; set;}

Property Value

String.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    System.Windows.Forms.MessageBox.Show(this.OleObject1.Class.ToString());
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    MessageBox.Show(Me.OleObject1.Class.ToString())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


HyperLink Property

[image]
ActiveReports 13
HyperLink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : HyperLink Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Remarks

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "http://www.grapecity.com") for this property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.HyperLink = "www.grapecity.com";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.HyperLink = "www.grapecity.com"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members


PictureAlignment Property

[image]
ActiveReports 13
PictureAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : PictureAlignment Property

Glossary Item Box

Gets or sets the position of the object's content within the control area.

Syntax

Visual Basic (Declaration)
Public Property PictureAlignment As PictureAlignment
C#
public PictureAlignment PictureAlignment {get; set;}

Remarks

A PictureAlignment enumeration member that specifies the alignment of the content.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.PictureAlignment = PictureAlignment.BottomLeft;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.PictureAlignment = PictureAlignment.BottomLeft
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members
ActiveReports6~GrapeCity.ActiveReports.PictureAlignment


SizeMode Property

[image]
ActiveReports 13
SizeMode Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : SizeMode Property

Glossary Item Box

Gets or sets a value that determines how the image is sized to fit the OleObject control area.

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeModes
C#
public SizeModes SizeMode {get; set;}

Property Value

A SizeModes enumeration value. The default value is SizeModes.Clip.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.SizeMode = SizeModes.Zoom;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.SizeMode = SizeModes.Zoom
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OleObject Class
OleObject Members
ActiveReports6~GrapeCity.ActiveReports.SizeModes


PageBreak Class

[image]
ActiveReports 13
PageBreak Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

Glossary Item Box

PageBreak ends the current page and starts a new page at the control's location on the page.

Object Model

PageBreak Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PageBreak
   Inherits ARControl
C#
public sealed class PageBreak : ARControl

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.PageBreak

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageBreak Class Members

[image]
ActiveReports 13
PageBreak Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

Glossary Item Box

The following tables list the members exposed by PageBreak.

Public Constructors

 | Name | Description
Public Constructor | PageBreak Constructor | Initializes a new instance of the PageBreak class.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Enabled | Determines whether the PageBreak is currently enabled.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageBreak Constructor

[image]
ActiveReports 13
PageBreak Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : PageBreak Constructor

Glossary Item Box

Initializes a new instance of the PageBreak class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageBreak()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


PageBreak Class Properties

[image]
ActiveReports 13
PageBreak Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

Glossary Item Box

For a list of all members of this type, see PageBreak members.

Public Properties

 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Enabled | Determines whether the PageBreak is currently enabled.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : Enabled Property

Glossary Item Box

Determines whether the PageBreak is currently enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

Boolean. True if the control is enabled and should create a page break at the specified position; otherwise False.

Example

C# Copy Code
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.pageBreak1.Enabled = false;
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.PageBreak1.Enabled = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


Location Property

[image]
ActiveReports 13
Location Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : Location Property

Glossary Item Box

Gets or sets the location of the control in inches.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Location As PointF
C#
public override PointF Location {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0f;
    p.Y = 5f;

    if(this.detail.Height > 5)
    {
        this.pageBreak1.Enabled = true;
        this.pageBreak1.Location = p;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Dim p As System.Drawing.PointF
   p.X = 0
   p.Y = 5
   If Me.Detail1.Height > 5 Then
      Me.PageBreak1.Enabled = True
      Me.PageBreak1.Location = p
   End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageBreak Class
PageBreak Members


PageFooter Class

[image]
ActiveReports 13
PageFooter Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

The PageFooter section prints once at the bottom of every page in the report.

Object Model

PageFooter Class

Syntax

Visual Basic (Declaration)
Public Class PageFooter
   Inherits Section
C#
public class PageFooter : Section

Remarks

The PageFooter section is rendered last on each page after all content has been rendered, thus, unlike other sections, its height cannot be changed in the Format event.

Bound controls are not supported in this section, or in the PageHeader section. The data displayed in a bound control in one of these sections may not be in synch with the data displayed in other sections on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.PageFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Class Members

[image]
ActiveReports 13
PageFooter Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

The following tables list the members exposed by PageFooter.

Public Constructors

 | Name | Description
Public Constructor | PageFooter Constructor | Initializes a new instance of the PageFooter class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page footer.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Constructor

[image]
ActiveReports 13
PageFooter Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageFooter Class : PageFooter Constructor

Glossary Item Box

Initializes a new instance of the PageFooter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageFooter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageFooter Class
PageFooter Members


PageFooter Class Properties

[image]
ActiveReports 13
PageFooter Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

For a list of all members of this type, see PageFooter members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page footer.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageFooter Class : Height Property

Glossary Item Box

Gets or sets the height of the page footer.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageFooter Class
PageFooter Members


PageHeader Class

[image]
ActiveReports 13
PageHeader Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

The PageHeader section prints once at the top of every page in the report.

Object Model

PageHeader Class

Syntax

Visual Basic (Declaration)
Public Class PageHeader
   Inherits Section
C#
public class PageHeader : Section

Remarks

Bound controls are not supported in this section, or in the PageFooter section. The data displayed in a bound control in one of these sections may not be in sync with the data displayed in other sections on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.PageHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Class Members

[image]
ActiveReports 13
PageHeader Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

The following tables list the members exposed by PageHeader.

Public Constructors

 | Name | Description
Public Constructor | PageHeader Constructor | Initializes a new instance of the PageHeader class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page header.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Constructor

[image]
ActiveReports 13
PageHeader Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageHeader Class : PageHeader Constructor

Glossary Item Box

Initializes a new instance of the PageHeader class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PageHeader()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeader Class
PageHeader Members


PageHeader Class Properties

[image]
ActiveReports 13
PageHeader Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

For a list of all members of this type, see PageHeader members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page header.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageHeader Class : Height Property

Glossary Item Box

Gets or sets the height of the page header.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageHeader Class
PageHeader Members


Parameter Class

[image]
ActiveReports 13
Parameter Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

A Parameter is used to substitute values for parameter placeholders in the report's data source SQL query text.

Object Model

Parameter Class

Syntax

Visual Basic (Declaration)
Public Class Parameter
C#
public class Parameter

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Parameter Class Members

[image]
ActiveReports 13
Parameter Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

The following tables list the members exposed by Parameter.

Public Constructors

 | Name | Description
Public Constructor | Parameter Constructor | Initializes a new instance of the Parameter class.
Top

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets a value to be used as the default value in the parameters input dialog.
Public Property | Key | Unique name of the parameter.
Public Property | Prompt | Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.
Public Property | PromptUser | Determines whether to prompt the user to input a parameter value.
Public Property | QueryCreated | Determines whether the query is created from the data source query string or user created.
Public Property | Tag | User-defined value.
Public Property | Type | Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.
Public Property | Value | Gets or sets the value of the parameter to be used in parameter placeholder substitution.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a clone of the Parameter object.
Public Method | ReadXml | Reads the parameter from an XmlElement.
Public Method | ToString | Returns a string that represents the Parameter object.
Public Method | WriteXml | Writes the parameter from an XmlElement.
Top

Public Events

 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Parameter Constructor

[image]
ActiveReports 13
Parameter Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Parameter Constructor

Glossary Item Box

Initializes a new instance of the Parameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Parameter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Methods

[image]
ActiveReports 13
Parameter Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a clone of the Parameter object.
Public Method | ReadXml | Reads the parameter from an XmlElement.
Public Method | ToString | Returns a string that represents the Parameter object.
Public Method | WriteXml | Writes the parameter from an XmlElement.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Clone Method

[image]
ActiveReports 13
Clone Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Clone Method

Glossary Item Box

Creates a clone of the Parameter object.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Parameter
C#
public Parameter Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ReadXml Method

[image]
ActiveReports 13
ReadXml Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : ReadXml Method

baseNode
The base node of the XML element.

Glossary Item Box

Reads the parameter from an XmlElement.

Syntax

Visual Basic (Declaration)
Public Function ReadXml( _
   ByVal baseNode As XmlNode _
) As Boolean
C#
public bool ReadXml(
   XmlNode baseNode
)

Parameters

baseNode
The base node of the XML element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : ToString Method

Glossary Item Box

Returns a string that represents the Parameter object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


WriteXml Method

[image]
ActiveReports 13
WriteXml Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : WriteXml Method

baseNode
The base node of the XML element.

Glossary Item Box

Writes the parameter from an XmlElement.

Syntax

Visual Basic (Declaration)
Public Function WriteXml( _
   ByVal baseNode As XmlElement _
) As Boolean
C#
public bool WriteXml(
   XmlElement baseNode
)

Parameters

baseNode
The base node of the XML element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

[image]
ActiveReports 13
Parameter Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Properties

 | Name | Description
Public Property | DefaultValue | Gets or sets a value to be used as the default value in the parameters input dialog.
Public Property | Key | Unique name of the parameter.
Public Property | Prompt | Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.
Public Property | PromptUser | Determines whether to prompt the user to input a parameter value.
Public Property | QueryCreated | Determines whether the query is created from the data source query string or user created.
Public Property | Tag | User-defined value.
Public Property | Type | Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.
Public Property | Value | Gets or sets the value of the parameter to be used in parameter placeholder substitution.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


DefaultValue Property

[image]
ActiveReports 13
DefaultValue Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : DefaultValue Property

Glossary Item Box

Gets or sets a value to be used as the default value in the parameters input dialog.

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue {get; set;}

Property Value

A string value specifying the default value of the parameter.

Remarks

If the user does not specify a value, the DefaultValue will be used.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Key Property

[image]
ActiveReports 13
Key Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Key Property

Glossary Item Box

Unique name of the parameter.

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key {get; set;}

Property Value

A string value that represents the unique name of the parameter.

Remarks

Used to reference the parameter in the parameters collection and to locate the different placeholder locations in the SQL query where the parameter value will be inserted.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Prompt Property

[image]
ActiveReports 13
Prompt Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Prompt Property

Glossary Item Box

Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.

Syntax

Visual Basic (Declaration)
Public Property Prompt As String
C#
public string Prompt {get; set;}

Property Value

A string value used to prompt the user for a parameter value.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


PromptUser Property

[image]
ActiveReports 13
PromptUser Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : PromptUser Property

Glossary Item Box

Determines whether to prompt the user to input a parameter value.

Syntax

Visual Basic (Declaration)
Public Property PromptUser As Boolean
C#
public bool PromptUser {get; set;}

Remarks

The default value is True. If the value is set to False, the Prompt property is ignored.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


QueryCreated Property

[image]
ActiveReports 13
QueryCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : QueryCreated Property

Glossary Item Box

Determines whether the query is created from the data source query string or user created.

Syntax

Visual Basic (Declaration)
Public Property QueryCreated As Boolean
C#
public bool QueryCreated {get; set;}

Property Value

True if created from the data source SQL query string; False if user created.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Tag Property

Glossary Item Box

User-defined value.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Remarks

Use for your own purposes.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Type Property

[image]
ActiveReports 13
Type Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Type Property

Glossary Item Box

Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.

Syntax

Visual Basic (Declaration)
Public Property Type As Parameter.DataType
C#
public Parameter.DataType Type {get; set;}

Property Value

A DataType enumeration value that determines the type of control to be created for the parameters input dialog.

Remarks

ActiveReports creates the parameters intput dialog for the user dynamically based on the number of parameters and their type. By default, all parameters are considered strings. You can specify a Boolean control (checkbox) or a Date (calendar) control instead of a standard textbox.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members
ActiveReports6~GrapeCity.ActiveReports.Parameter+DataType


Value Property

[image]
ActiveReports 13
Value Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Value Property

Glossary Item Box

Gets or sets the value of the parameter to be used in parameter placeholder substitution.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Property Value

A string value that is used to replace the parameter placeholder text in the report's data source SQL query.

Example

C# Copy Code
private void button1_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Parameters["country"].Value = "Germany";
    rpt.Run();
    arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    Dim rpt As New SectionReport1
    rpt.Parameters("country").Value = "Germany"
    rpt.Run()
    arv.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Events

[image]
ActiveReports 13
Parameter Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

Glossary Item Box

For a list of all members of this type, see Parameter members.

Public Events

 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
Top

See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Disposed Event

Glossary Item Box

Adds an event handler to listen to the Disposed event on the component.

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

[image]
ActiveReports 13
ParameterCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

Represents the collection of parameters that ActiveReports parses from the parameter placeholders in the data source SQL query.

Object Model

ParameterCollection Class

Syntax

Visual Basic (Declaration)
Public Class ParameterCollection
   Inherits System.Collections.CollectionBase
C#
public class ParameterCollection : System.Collections.CollectionBase

Remarks

ActiveReports parses the data source SQL query for the following parameters placeholder syntax, and it uses that syntax to create the parameters collection before the data source is accessed. Only the Name is required.

<%Name | PromptString | DefaultValue | DataType | PromptUser%>

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


ParameterCollection Class Members

[image]
ActiveReports 13
ParameterCollection Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

The following tables list the members exposed by ParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterCollection Constructor | Initializes a new instance of the ParameterCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to the specified Parameter.
Public Property | ParseResult | Returns the results of parsing the report's parameter values.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a Parameter object to the Parameter collection.
Public Method | AddRange | Overloaded. Adds a range of Parameter objects to the Parameter collection.
Public Method | AtLeastOneNeedsPrompt | Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.
Public Method | AtLeastOneQueryCreated | Determines whether a query for the parameters in the collection has been created.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the collection contains the specified parameter.
Public Method | IndexOf | Returns the index of the specified Parameter object in the collection.
Public Method | Insert | Inserts a Parameter object into the collection at the specified index.
Public Method | Remove | Removes a parameter from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

Public Events

 | Name | Description
Public Event | Modified | Is raised when the Parameter collection is modified.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


ParameterCollection Constructor

[image]
ActiveReports 13
ParameterCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : ParameterCollection Constructor

parent
The parent object of the parameter collection.

Glossary Item Box

Initializes a new instance of the ParameterCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As IComponent _
)
C#
public ParameterCollection(
   IComponent parent
)

Parameters

parent
The parent object of the parameter collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Methods

[image]
ActiveReports 13
ParameterCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a Parameter object to the Parameter collection.
Public Method | AddRange | Overloaded. Adds a range of Parameter objects to the Parameter collection.
Public Method | AtLeastOneNeedsPrompt | Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.
Public Method | AtLeastOneQueryCreated | Determines whether a query for the parameters in the collection has been created.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the collection contains the specified parameter.
Public Method | IndexOf | Returns the index of the specified Parameter object in the collection.
Public Method | Insert | Inserts a Parameter object into the collection at the specified index.
Public Method | Remove | Removes a parameter from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Add Method

parameter
The parameter object to be added to the collection.

Glossary Item Box

Adds a Parameter object to the Parameter collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal parameter As Parameter _
) As Integer
C#
public int Add(
   Parameter parameter
)

Parameters

parameter
The parameter object to be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


AddRange Method

[image]
ActiveReports 13
AddRange Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AddRange Method

Glossary Item Box

Adds a range of Parameter objects to the Parameter collection. Adds a range of Parameter objects to the Parameter collection.

Overload List

Overload | Description
AddRange(Parameter[]) | Adds a range of Parameter objects to the Parameter collection.
AddRange(ParameterCollection) | Adds a ParameterCollection object to the Parameter collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


AddRange(Parameter[]) Method

[image]
ActiveReports 13
AddRange(Parameter[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > AddRange Method : AddRange(Parameter[]) Method

parameters
The range of parameters to add.

Glossary Item Box

Adds a range of Parameter objects to the Parameter collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal parameters() As Parameter _
)
C#
public void AddRange(
   Parameter[] parameters
)

Parameters

parameters
The range of parameters to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


AddRange(ParameterCollection) Method

[image]
ActiveReports 13
AddRange(ParameterCollection) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > AddRange Method : AddRange(ParameterCollection) Method

parameters
The ParameterCollection object to add.

Glossary Item Box

Adds a ParameterCollection object to the Parameter collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal parameters As ParameterCollection _
)
C#
public void AddRange(
   ParameterCollection parameters
)

Parameters

parameters
The ParameterCollection object to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


AtLeastOneNeedsPrompt Method

[image]
ActiveReports 13
AtLeastOneNeedsPrompt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AtLeastOneNeedsPrompt Method

Glossary Item Box

Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.

Syntax

Visual Basic (Declaration)
Public Function AtLeastOneNeedsPrompt() As Boolean
C#
public bool AtLeastOneNeedsPrompt()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


AtLeastOneQueryCreated Method

[image]
ActiveReports 13
AtLeastOneQueryCreated Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AtLeastOneQueryCreated Method

Glossary Item Box

Determines whether a query for the parameters in the collection has been created.

Syntax

Visual Basic (Declaration)
Public Function AtLeastOneQueryCreated() As Boolean
C#
public bool AtLeastOneQueryCreated()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Contains Method

parameter
The parameter to find in the collection.

Glossary Item Box

Determines whether the collection contains the specified parameter.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal parameter As Parameter _
) As Boolean
C#
public bool Contains(
   Parameter parameter
)

Parameters

parameter
The parameter to find in the collection.

Return Value

True if the collection contains the parameter; otherwise, False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : IndexOf Method

parameter
Specifies the Parameter object for which to search.

Glossary Item Box

Returns the index of the specified Parameter object in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal parameter As Parameter _
) As Integer
C#
public int IndexOf(
   Parameter parameter
)

Parameters

parameter
Specifies the Parameter object for which to search.

Return Value

An integer specifying the index of the specified Parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Insert Method

index
The index at which the parameter is inserted
parameter
The parameter to insert.

Glossary Item Box

Inserts a Parameter object into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal parameter As Parameter _
)
C#
public void Insert(
   int index,
   Parameter parameter
)

Parameters

index
The index at which the parameter is inserted
parameter
The parameter to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Remove Method

parameter
The parameter to be removed.

Glossary Item Box

Removes a parameter from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal parameter As Parameter _
)
C#
public void Remove(
   Parameter parameter
)

Parameters

parameter
The parameter to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Properties

[image]
ActiveReports 13
ParameterCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to the specified Parameter.
Public Property | ParseResult | Returns the results of parsing the report's parameter values.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Item Property

Glossary Item Box

Returns a reference to the specified Parameter.

Overload List

Overload | Description
Item(Int32) | Gets the Parameters object at the specified indexed location in the Parameters collection.
Item(String) | Gets the Parameter object with the specified key in the Parameters collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item(Int32) Property

[image]
ActiveReports 13
Item(Int32) Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > Item Property : Item(Int32) Property

index
Specifies the index of the requested parameter in the collection.

Glossary Item Box

Gets the Parameters object at the specified indexed location in the Parameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Parameter
C#
public Parameter Item(
   int index
) {get;}

Parameters

index
Specifies the index of the requested parameter in the collection.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    System.Windows.Forms.MessageBox.Show (rpt.Parameters[0].Type.ToString());
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    MsgBox(rpt.Parameters.Item(0).Type.ToString)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


Item(String) Property

[image]
ActiveReports 13
Item(String) Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > Item Property : Item(String) Property

key
Specifies the key of the requested parameter.

Glossary Item Box

Gets the Parameter object with the specified key in the Parameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal key As String _
) As Parameter
C#
public Parameter Item(
   string key
) {get;}

Parameters

key
Specifies the key of the requested parameter.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    System.Windows.Forms.MessageBox.Show (rpt.Parameters["country"].Type.ToString());
    rpt.Run();
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    MsgBox(rpt.Parameters.Item("country").Type.ToString)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


ParseResult Property

[image]
ActiveReports 13
ParseResult Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : ParseResult Property

Glossary Item Box

Returns the results of parsing the report's parameter values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParseResult As ParameterCollection.ParseResultCode
C#
public ParameterCollection.ParseResultCode ParseResult {get;}

Property Value

Parameters.ParseResultCode enumeration.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.Success)
    {
        System.Windows.Forms.MessageBox.Show("success!");
    }
    else if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.MissingCloseParam)
    {
        System.Windows.Forms.MessageBox.Show("missingCloseParam");
    }
    else if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.MissingParamName)
    {
        System.Windows.Forms.MessageBox.Show("missingCloseParamName");
    }
    this.arv.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Run()
    If rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.Success Then
        MessageBox.Show("success!")
    ElseIf rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.MissingCloseParam Then
        MessageBox.Show("missingCloseParam")
    ElseIf rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.MissingParamName Then
        MessageBox.Show("missingCloseParamName")
    End If
    Me.Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection~ParseResult


ParameterCollection Class Events

[image]
ActiveReports 13
ParameterCollection Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

Glossary Item Box

For a list of all members of this type, see ParameterCollection members.

Public Events

 | Name | Description
Public Event | Modified | Is raised when the Parameter collection is modified.
Top

See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Modified Event

[image]
ActiveReports 13
Modified Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Modified Event

Glossary Item Box

Is raised when the Parameter collection is modified.

Syntax

Visual Basic (Declaration)
Public Event Modified As EventHandler
C#
public event EventHandler Modified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Picture Class

[image]
ActiveReports 13
Picture Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

Prints an image on the report.

Object Model

Picture Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Picture
   Inherits ARControl
C#
public sealed class Picture : ARControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.BackColor = System.Drawing.Color.Transparent;
    this.picture1.HyperLink = "mailto:support@company.com";
    this.picture1.Image = System.Drawing.Image.FromFile("\\mycompany.gif");
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
    this.picture1.PictureAlignment = PictureAlignment.Center;
    this.picture1.SizeMode = SizeModes.Clip;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.BackColor = System.Drawing.Color.Transparent
   Me.Picture1.HyperLink = "mailto:support@company.com"
   Me.Picture1.Image = System.Drawing.Image.FromFile("c:\mycompany.gif")
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
   Me.Picture1.PictureAlignment = PictureAlignment.Center
   Me.Picture1.SizeMode = SizeModes.Clip
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Picture

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Picture Class Members

[image]
ActiveReports 13
Picture Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

The following tables list the members exposed by Picture.

Public Constructors

 | Name | Description
Public Constructor | Picture Constructor | Initializes a new instance of the Picture class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Image | Gets or sets the Image to be printed in the Picture control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the border line color around the picture control.
Public Property | LineStyle | Gets or sets the pen style used to paint the border around the picture control.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the image within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Title | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | ResetImage | Sets the current image to null.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Picture Constructor

[image]
ActiveReports 13
Picture Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Picture Constructor

Glossary Item Box

Initializes a new instance of the Picture class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Picture()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


Picture Class Methods

[image]
ActiveReports 13
Picture Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

For a list of all members of this type, see Picture members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | ResetImage | Sets the current image to null.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ResetImage Method

[image]
ActiveReports 13
ResetImage Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : ResetImage Method

Glossary Item Box

Sets the current image to null.

Syntax

Visual Basic (Declaration)
Public Sub ResetImage()
C#
public void ResetImage()

Example

C# Copy Code
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    if (this.txtCountry.Value.ToString() == "France")
    {
        this.picture1.ResetImage();
    }
    else
    {
        this.picture1.Image = System.Drawing.Image.FromFile("c:\\DSCF2183.JPG");
    }
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    If Me.txtCountry.Value.ToString = "France" Then
        Me.Picture1.ResetImage()
    Else
        Me.Picture1.Image = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members
ActiveReports6~GrapeCity.ActiveReports.Picture~Image


Picture Class Properties

[image]
ActiveReports 13
Picture Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

Glossary Item Box

For a list of all members of this type, see Picture members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Image | Gets or sets the Image to be printed in the Picture control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the border line color around the picture control.
Public Property | LineStyle | Gets or sets the pen style used to paint the border around the picture control.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the image within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Title | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.BackColor = System.Drawing.Color.Transparent;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.BackColor = System.Drawing.Color.Transparent
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


Description Property

[image]
ActiveReports 13
Description Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Description Property

Glossary Item Box

Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


HyperLink Property

[image]
ActiveReports 13
HyperLink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : HyperLink Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.HyperLink = "mailto:support@company.com";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.HyperLink = "mailto:support@company.com"
End Sub

Requirements

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "http://www.grapecity.com/") for this property.

See Also

Reference

Picture Class
Picture Members
HyperLinkEventArgs


Image Property

[image]
ActiveReports 13
Image Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Image Property

Glossary Item Box

Gets or sets the Image to be printed in the Picture control.

Syntax

Visual Basic (Declaration)
Public Property Image As Image
C#
public Image Image {get; set;}

Property Value

A System.Drawing.Image value that represents the image to be printed in the Picture control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.Image = System.Drawing.Image.FromFile("\\mycompany.gif");
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.Image = System.Drawing.Image.FromFile("c:\mycompany.gif")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


LineColor Property

[image]
ActiveReports 13
LineColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineColor Property

Glossary Item Box

Gets or sets the border line color around the picture control.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color used to paint the picture border. Default value is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detai1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members
ActiveReports6~GrapeCity.ActiveReports.Picture~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Picture~LineWeight


LineStyle Property

[image]
ActiveReports 13
LineStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to paint the border around the picture control.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

A LineStyle enumeration value. Default is LineStyle.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members
ActiveReports6~GrapeCity.ActiveReports.LineStyle
ActiveReports6~GrapeCity.ActiveReports.Picture~LineColor
ActiveReports6~GrapeCity.ActiveReports.Picture~LineWeight


LineWeight Property

[image]
ActiveReports 13
LineWeight Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width of the line in pixels.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current width of the line in pixels.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


PictureAlignment Property

[image]
ActiveReports 13
PictureAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : PictureAlignment Property

Glossary Item Box

Gets or sets the position of the image within the control area.

Syntax

Visual Basic (Declaration)
Public Property PictureAlignment As PictureAlignment
C#
public PictureAlignment PictureAlignment {get; set;}

Property Value

A PictureAlignment enumeration member that specifies the alignment of the picture.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.PictureAlignment = PictureAlignment.Center;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.PictureAlignment = PictureAlignment.Center
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


SizeMode Property

[image]
ActiveReports 13
SizeMode Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : SizeMode Property

Glossary Item Box

Gets or sets a value that determines how the image is sized to fit the Picture control area.

Syntax

Visual Basic (Declaration)
Public Property SizeMode As SizeModes
C#
public SizeModes SizeMode {get; set;}

Property Value

A SizeModes enumeration value. The default value is SizeModes.Clip

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.SizeMode = SizeModes.Clip;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.SizeMode = SizeModes.Clip
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Title Property

Glossary Item Box

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Picture Class
Picture Members


ReportFooter Class

[image]
ActiveReports 13
ReportFooter Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

The ReportFooter section prints once at the end of the report.

Object Model

ReportFooter Class

Syntax

Visual Basic (Declaration)
Public Class ReportFooter
   Inherits Section
C#
public class ReportFooter : Section

Remarks

Use this section to print the summary of the report and include any grand summary calculations.

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.KeepTogether = true;
    this.reportFooter1.NewPage = NewPage.None;
    this.reportFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.KeepTogether = True
    Me.ReportFooter.NewPage = NewPage.None
    Me.ReportFooter.PrintAtBottom = True
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.ReportFooter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Class Members

[image]
ActiveReports 13
ReportFooter Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

The following tables list the members exposed by ReportFooter.

Public Constructors

 | Name | Description
Public Constructor | ReportFooter Constructor | Initializes a new instance of the ReportFooter class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report footer section.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Constructor

[image]
ActiveReports 13
ReportFooter Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : ReportFooter Constructor

Glossary Item Box

Initializes a new instance of the ReportFooter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportFooter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


ReportFooter Class Properties

[image]
ActiveReports 13
ReportFooter Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

For a list of all members of this type, see ReportFooter members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report footer section.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : Height Property

Glossary Item Box

Gets ot sets the height of the report footer section.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Property Value

The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


KeepTogether Property

[image]
ActiveReports 13
KeepTogether Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : KeepTogether Property

Glossary Item Box

Gets or sets a value that determines whether the section should be printed on a single page.

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
C#
public bool KeepTogether {get; set;}

Property Value

A Boolean value. True--if the section will print on a single page if its contents permit; otherwise, False.

Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the its original position and the contents will be split across multiple pages.

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.KeepTogether = true;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.KeepTogether = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


NewPage Property

[image]
ActiveReports 13
NewPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


PrintAtBottom Property

[image]
ActiveReports 13
PrintAtBottom Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : PrintAtBottom Property

Glossary Item Box

Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.

Syntax

Visual Basic (Declaration)
Public Property PrintAtBottom As Boolean
C#
public bool PrintAtBottom {get; set;}

Property Value

A Boolean value. True-- if the footer section will be printed at the bottom of the page; otherwise, False.

Example

C# Copy Code
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.PrintAtBottom = true;
}
Visual Basic Copy Code
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.PrintAtBottom = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportFooter Class
ReportFooter Members


ReportHeader Class

[image]
ActiveReports 13
ReportHeader Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

The ReportHeader section is printed once at the beginning of the report.

Object Model

ReportHeader Class

Syntax

Visual Basic (Declaration)
Public Class ReportHeader
   Inherits Section
C#
public class ReportHeader : Section

Example

C# Copy Code
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    this.reportHeader1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub ReportHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader.Format
   Me.ReportHeader.NewPage = NewPage.None
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.ReportHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Class Members

[image]
ActiveReports 13
ReportHeader Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

The following tables list the members exposed by ReportHeader.

Public Constructors

 | Name | Description
Public Constructor | ReportHeader Constructor | Initializes a new instance of the ReportHeader class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report header section.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Constructor

[image]
ActiveReports 13
ReportHeader Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : ReportHeader Constructor

Glossary Item Box

Initializes a new instance of the ReportHeader class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportHeader()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Class
ReportHeader Members


ReportHeader Class Properties

[image]
ActiveReports 13
ReportHeader Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

For a list of all members of this type, see ReportHeader members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report header section.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : Height Property

Glossary Item Box

Gets ot sets the height of the report header section.

Syntax

Visual Basic (Declaration)
Public Shadows Property Height As Single
C#
public new float Height {get; set;}

Property Value

The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Class
ReportHeader Members


NewPage Property

[image]
ActiveReports 13
NewPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : NewPage Property

Glossary Item Box

Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.

Syntax

Visual Basic (Declaration)
Public Property NewPage As NewPage
C#
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None

Example

C# Copy Code
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    this.reportHeader1.NewPage = NewPage.None;
}
Visual Basic Copy Code
Private Sub ReportHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader.Format
   Me.ReportHeader.NewPage = NewPage.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportHeader Class
ReportHeader Members


ReportInfo Class

[image]
ActiveReports 13
ReportInfo Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

Glossary Item Box

The ReportInfo control displays the information specified in the FormatString property.

Object Model

ReportInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportInfo
   Inherits ARControl
C#
public sealed class ReportInfo : ARControl

Remarks

Included format strings supply Page N of M and report run date information.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = new System.Drawing.Font("Arial", 10.0f);
    this.reportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10.0f)
    Me.ReportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}"
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.ReportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Class Members

[image]
ActiveReports 13
ReportInfo Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

Glossary Item Box

The following tables list the members exposed by ReportInfo.

Public Constructors

 | Name | Description
Public Constructor | ReportInfo Constructor | Initializes a new instance of the ReportInfo class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | FormatString | Gets or sets the mask string used to format the text property before placing it in the Text property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether the ReportInfo control is multiline enabled.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Determines whether text will be displayed in right-to-left order for this control.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the ReportInfo control.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Returns the FormatString format associated with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Constructor

[image]
ActiveReports 13
ReportInfo Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ReportInfo Constructor

Glossary Item Box

Initializes a new instance of the ReportInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ReportInfo Class Properties

[image]
ActiveReports 13
ReportInfo Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

Glossary Item Box

For a list of all members of this type, see ReportInfo members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | FormatString | Gets or sets the mask string used to format the text property before placing it in the Text property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether the ReportInfo control is multiline enabled.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Determines whether text will be displayed in right-to-left order for this control.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the ReportInfo control.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Returns the FormatString format associated with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Alignment Property

Glossary Item Box

Gets or sets the alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As GrapeCity.ActiveReports.Drawing.TextAlignment
C#
public GrapeCity.ActiveReports.Drawing.TextAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Calendar Property

[image]
ActiveReports 13
Calendar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Calendar Property

Glossary Item Box

Gets or sets calendar to use for formatting dates

Syntax

Visual Basic (Declaration)
Public Property Calendar As String
C#
public string Calendar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


CanGrow Property

[image]
ActiveReports 13
CanGrow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior of the control. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the control and shifts all controls below it to account for the increase in height.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
    this.reportInfo1.CanGrow = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
   Me.ReportInfo1.CanGrow = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


CanShrink Property

[image]
ActiveReports 13
CanShrink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
    this.reportInfo1.CanGrow = true;
    this.reportInfo1.CanShrink = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
   Me.ReportInfo1.CanGrow = True
   Me.ReportInfo1.CanShrink = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ClassName Property

[image]
ActiveReports 13
ClassName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String. Style class name. Default value is "Normal".

Remarks

Style classes are defined in the report's Stylesheet.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.ClassName = "Normal";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.ClassName = "Normal"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Culture Property

[image]
ActiveReports 13
Culture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Culture Property

Glossary Item Box

Gets or sets the culture for the text control.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Font Property

[image]
ActiveReports 13
Font Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control text

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = new System.Drawing.Font("Arial", 10);
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.ForeColor = System.Drawing.Color.Firebrick;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.ForeColor = System.Drawing.Color.Firebrick
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


FormatString Property

[image]
ActiveReports 13
FormatString Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : FormatString Property

Glossary Item Box

Gets or sets the mask string used to format the text property before placing it in the Text property.

Syntax

Visual Basic (Declaration)
Public Property FormatString As String
C#
public string FormatString {get; set;}

Remarks

The formatting mask can only be used to format numbers and dates. There is no support for formatting alphanumeric strings. The ReportInfo control will display variations of report Page and RunDateTime information.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = New System.Drawing.Font("Arial", 10.0f);
    this.reportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10.0f)
    Me.ReportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


MultiLine Property

[image]
ActiveReports 13
MultiLine Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : MultiLine Property

Glossary Item Box

Gets or sets a value indicating whether the ReportInfo control is multiline enabled.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.FormatString = "{RunDateTime:M/d/yy h:mm}";
    this.reportInfo1.MultiLine = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.FormatString = "{RunDateTime:M/d/yy h:mm}"
    Me.ReportInfo1.MultiLine = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : RightToLeft Property

Glossary Item Box

Determines whether text will be displayed in right-to-left order for this control.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.RightToLeft = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.RightToLeft = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Style Property

[image]
ActiveReports 13
Style Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Style Property

Glossary Item Box

Gets or sets a style string for the ReportInfo control.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Style = "color: Firebrick; text-align: center;";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Style = "color: FireBrick; text-align: center;"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


SummaryGroup Property

[image]
ActiveReports 13
SummaryGroup Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : SummaryGroup Property

Glossary Item Box

Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.

Syntax

Visual Basic (Declaration)
Public Property SummaryGroup As String
C#
public string SummaryGroup {get; set;}

Property Value

The summary group.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.SummaryGroup = null;
    this.reportInfo1.SummaryRunning = SummaryRunning.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.SummaryGroup = Nothing
   Me.ReportInfo1.SummaryRunning = SummaryRunning.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


SummaryRunning Property

[image]
ActiveReports 13
SummaryRunning Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : SummaryRunning Property

Glossary Item Box

Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).

Syntax

Visual Basic (Declaration)
Public Property SummaryRunning As SummaryRunning
C#
public SummaryRunning SummaryRunning {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.SummaryGroup = null;
    this.reportInfo1.SummaryRunning = SummaryRunning.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.SummaryGroup = Nothing
   Me.ReportInfo1.SummaryRunning = SummaryRunning.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Text Property

Glossary Item Box

Returns the FormatString format associated with the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


VerticalAlignment Property

[image]
ActiveReports 13
VerticalAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the position of the control's text vertically within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As GrapeCity.ActiveReports.Drawing.VerticalTextAlignment
C#
public GrapeCity.ActiveReports.Drawing.VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration value that represents the vertical alignment of the control's text. Default is VerticalTextAlignment.Top.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.VerticalAlignment = VerticalTextAlignment.Top;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.VerticalAlignment = VerticalTextAlignment.Top
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


WrapMode Property

[image]
ActiveReports 13
WrapMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : WrapMode Property

Glossary Item Box

Sets/gets control's wrap mode using CSS.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As GrapeCity.ActiveReports.Drawing.WrapMode
C#
public GrapeCity.ActiveReports.Drawing.WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportInfo Class
ReportInfo Members


RichTextBox Class

[image]
ActiveReports 13
RichTextBox Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

Prints text formatted as Rich Text (RTF) on the report.

Object Model

RichTextBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RichTextBox
   Inherits ARControl
C#
public sealed class RichTextBox : ARControl

Example

C# Copy Code
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    this.rtf.BackColor = System.Drawing.Color.RosyBrown;
    this.rtf.BulletIndent = 0.5f;
    this.rtf.CanGrow = true;
    this.rtf.CanShrink = false;
    this.rtf.Clear(); //Clears the content of the RichTextBox;
    this.rtf.Find("Germany");
    this.rtf.ForeColor = System.Drawing.Color.Black;
    this.rtf.InsertField("Phone");
    this.rtf.LoadFile(System.Windows.Forms.Application.StartupPath + " \\Letter.rtf"); //Loads the specified file into the RTF control
    this.rtf.MaxLength = 0;
    this.rtf.Multiline = true;
    this.rtf.RTF = "RTF Contents";
    this.rtf.SelectedText.ToString();
    this.rtf.SelectionAlignment = TextAlignment.Left;
    this.rtf.SelectionBackColor = System.Drawing.Color.RosyBrown;
    this.rtf.SelectionBullet = false;
    this.rtf.SelectionCharOffset = 0;
    this.rtf.SelectionColor = System.Drawing.Color.Blue;
    this.rtf.SelectionFont.ToString();
    this.rtf.SelectionHangingIndent = 3;
    this.rtf.SelectionIndent = 0;
    this.rtf.SelectionLength.ToString();
    this.rtf.SelectionRightIndent = 3;
    this.rtf.SelectionStart = 5;
    this.rtf.Text = "RTF Text";
}
Visual Basic Copy Code
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    Me.rtf.BackColor = System.Drawing.Color.RosyBrown
    Me.rtf.BulletIndent = 0.5
    Me.rtf.CanGrow = True
    Me.rtf.CanShrink = False
    Me.rtf.Clear() 'Clears the content of the RichTextBox
    Me.rtf.Find("Germany")
    Me.rtf.ForeColor = System.Drawing.Color.Black
    Me.rtf.InsertField("Phone")
    Me.rtf.LoadFile(Application.StartupPath + " \Letter.rtf") 'Loads the specified file into the RTF control
    Me.rtf.MaxLength = 0
    Me.rtf.Multiline = True
    Me.rtf.RTF = "RTF Contents"
    Me.rtf.SelectedText.ToString()
    Me.rtf.SelectionAlignment = TextAlignment.Left
    Me.rtf.SelectionBackColor = System.Drawing.Color.RosyBrown
    Me.rtf.SelectionBullet = False
    Me.rtf.SelectionCharOffset = 0
    Me.rtf.SelectionColor = System.Drawing.Color.Blue
    Me.rtf.SelectionFont.ToString()
    Me.rtf.SelectionHangingIndent = 3
    Me.rtf.SelectionIndent = 0
    Me.rtf.SelectionLength.ToString()
    Me.rtf.SelectionRightIndent = 3
    Me.rtf.SelectionStart = 5
    Me.rtf.Text = "RTF Text"
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.RichTextBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox Class Members

[image]
ActiveReports 13
RichTextBox Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

The following tables list the members exposed by RichTextBox.

Public Constructors

 | Name | Description
Public Constructor | RichTextBox Constructor | Initializes a new instance of the RichTextBox class.
Top

Public Properties

 | Name | Description
Public Property | AutoReplaceFields | Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | BulletIndent | Gets or sets the indentation used in the control when the bullet style is applied to the text.
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text. For design time use only.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Html | Sets or returns the hypertext to be rendered in the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MaxLength | Gets or sets the maximum number of characters in the control for the End-User Report Designer.
Public Property | Multiline | Gets or sets a value that determines whether the RichTextBox prints multiple lines or single line.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RTF | Gets or sets the rich text content of the control.
Public Property | SelectedText | Gets or sets the current selected text in the control.
Public Property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point.
Public Property | SelectionBackColor | Gets or sets the background color of the current text selection.
Public Property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection.
Public Property | SelectionCharOffset | Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.
Public Property | SelectionColor | Gets or sets the text color of the current text selection.
Public Property | SelectionFont | Gets or sets the font of the current text selection.
Public Property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. Renders the selected text the specified number of inches to the left of the RichTextBox.
Public Property | SelectionIndent | Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection. Renders the selected text the specified number of inches to the right of the RichTextBox.
Public Property | SelectionLength | Gets or sets the number of characters selected in control.
Public Property | SelectionRightIndent | The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the current text in the RichTextBox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Clear | Clears the content of the RichTextBox control.
Public Method | Find | Overloaded. Searches for text in the content of the RichTextBox control.
Public Method | InsertField | Inserts a RichTextBox merge field into the current location in the text.
Public Method | Load | Loads the contents of a stream into the RichTextBox control.
Public Method | LoadFile | Overloaded. Loads an HTML or RTF file.
Public Method | ReplaceField | Merges the contents of the RTF stream with the field values specified.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox Constructor

[image]
ActiveReports 13
RichTextBox Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RichTextBox Constructor

Glossary Item Box

Initializes a new instance of the RichTextBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RichTextBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


RichTextBox Class Methods

[image]
ActiveReports 13
RichTextBox Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

For a list of all members of this type, see RichTextBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Clear | Clears the content of the RichTextBox control.
Public Method | Find | Overloaded. Searches for text in the content of the RichTextBox control.
Public Method | InsertField | Inserts a RichTextBox merge field into the current location in the text.
Public Method | Load | Loads the contents of a stream into the RichTextBox control.
Public Method | LoadFile | Overloaded. Loads an HTML or RTF file.
Public Method | ReplaceField | Merges the contents of the RTF stream with the field values specified.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Clear Method

Glossary Item Box

Clears the content of the RichTextBox control.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    //Clears the content of the RichTextBox
    this.rtf.Clear();
    //Loads the specified file into the RTF control
    this.rtf.LoadFile(System.Windows.Forms.Application.StartupPath + " \\Letter.rtf");
}
Visual Basic Copy Code
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    'Clears the content of the RichTextBox
    Me.rtf.Clear()
    'Loads the specified file into the RTF control
    Me.rtf.LoadFile(Application.StartupPath + " \Letter.rtf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Find Method

[image]
ActiveReports 13
Find Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Find Method

Glossary Item Box

Searches for text in the content of the RichTextBox control.

Overload List

Overload | Description
Find(Char[]) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters.
Find(String) | Searches the text of the RichTextBox control for a string.
Find(String,Int32) | Searches the text in the RichTextBox control for a specified string starting at a specified location.
Find(String,Int32,FindOptions) | Searches the text in the RichTextBox control for a specified string starting at a specified location and with specific options applied to the search.

Example

C# Copy Code
Private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("past due")!= -1)
    {
        this.txtPayNow.Visible=true;
    }
    else
    {
        this.txtPayNow.Visible=false;
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("past due") = -1 Then
        Me.txtPayNow.Visible = True
    Else
        Me.txtPayNow.Visible = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Find(Char[]) Method

[image]
ActiveReports 13
Find(Char[]) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(Char[]) Method

characterSet
The array of characters for which to search.

Glossary Item Box

Searches the text of a RichTextBox control for the first instance of a character from a list of characters.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal characterSet() As Char _
) As Integer
C#
public int Find(
   char[] characterSet
)

Parameters

characterSet
The array of characters for which to search.

Return Value

The location within the control where the search characters were found or a negative one (-1) if the search characters are not found or an empty search character set is specified in the char parameter.

Remarks

This version of the Find method searches for the first instance of a character from a list of characters specified in the characterSet parameter and returns the location of the character. For example, you pass an array of characters containing the character 'Q'. If the control contained the text "The Quick Brown Fox", the Find method would return the value of four. An upper case character and a lower case character are considered different values in the search.

If the property returns a negative value, the characters being searched for were not found within the contents of the control. You can use this method to search for a group of characters within the control. This version of the Find method assumes that the entire document contained in the control is searched for the characters. If a character from the character list provided in the method's characterSet parameter is found, the value returned by this method is a zero-based index of the character's position in the control. A space is considered a character by the method when determining the location of a character.

Example

C# Copy Code
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    char[] ch = {'q'};
    if (!(this.rtbActiveReport.Find(ch) == -1))
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find(ch);
        this.rtbActiveReport.SelectionLength = 2;
        this.rtbActiveReport.SelectionColor = System.Drawing.Color.Crimson;
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim ch As New Char
    ch = "q"
    If Not Me.RichTextBox1.Find(ch) = -1 Then
        Me.RichTextBox1.SelectionStart = Me.RichTextBox1.Find(ch)
        Me.RichTextBox1.SelectionLength = 2
        Me.RichTextBox1.SelectionColor = System.Drawing.Color.Crimson
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


Find(String) Method

[image]
ActiveReports 13
Find(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(String) Method

str

The text to locate in the control.

Glossary Item Box

Searches the text of the RichTextBox control for a string.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal str As String _
) As Integer
C#
public int Find(
   string str
)

Parameters

str

The text to locate in the control.

Return Value

The location within the control where the search text was found or a negative one (-1) if the search string is not found or an empty search string is specified in the str parameter.

Remarks

The Find method searches for the text specified in the str parameter and returns the location of the first character within the control. If the property returns a negative value, the text string being searched for was not found within the contents of the control.

Note The Find methods that accept a string as a parameter cannot find text that is contained on more than one line of text within the RichTextBox. Performing such a search will return a value of negative one (-1).

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("past due")!= -1)
    {
        this.txtPayNow.Visible=true;
    }
    else
    {
        this.txtPayNow.Visible=false;
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("past due") = -1 Then
        Me.txtPayNow.Visible = True
    Else
        Me.txtPayNow.Visible = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


Find(String,Int32) Method

[image]
ActiveReports 13
Find(String,Int32) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(String,Int32) Method

str
The text to locate in the control.
start
The location within the control's text at which to begin searching.

Glossary Item Box

Searches the text in the RichTextBox control for a specified string starting at a specified location.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal str As String, _
   ByVal start As Integer _
) As Integer
C#
public int Find(
   string str,
   int start
)

Parameters

str
The text to locate in the control.
start
The location within the control's text at which to begin searching.

Return Value

The location within the control where the search text was found.

Remarks

The Find method searches for the text specified in the str parameter and returns the location of the first character within the control. If the property returns a negative value, the text string being searched for was not found within the contents of the control.

Note The Find methods that accept a string as a parameter cannot find text that is contained on more than one line of text within the RichTextBox. Performing such a search will return a value of negative one (-1).

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("excellent", 15)!= -1)
    {
        this.txtAward.Visible=true;
    }
    else
    {
        this.txtAward.Visible=false;
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("excellent", 15) = -1 Then
        Me.txtAward.Visible = True
    Else
        Me.txtAward.Visible = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


Find(String,Int32,FindOptions) Method

[image]
ActiveReports 13
Find(String,Int32,FindOptions) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(String,Int32,FindOptions) Method

str
The text to locate in the control.
start
The location within the control's text at which to begin searching.
findOptions
A bitwise combination of the FindOptions values.

Glossary Item Box

Searches the text in the RichTextBox control for a specified string starting at a specified location and with specific options applied to the search.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal str As String, _
   ByVal start As Integer, _
   ByVal findOptions As RichTextBox.FindOptions _
) As Integer
C#
public int Find(
   string str,
   int start,
   RichTextBox.FindOptions findOptions
)

Parameters

str
The text to locate in the control.
start
The location within the control's text at which to begin searching.
findOptions
A bitwise combination of the FindOptions values.

Return Value

The location within the control where the search text was found.

Remarks

The Find method searches for the text specified in the str parameter and returns the location of the first character within the control. If the property returns a negative value, the text string being searched for was not found within the contents of the control.

With this version of the Find method, you can specify options that enable you to expand or narrow your search. You can specify options that enable you to match the casing of the search word or to search for entire words instead of partial words. By specifying the FindOptions.Reverse enumeration in the options parameter, you can search for text from the bottom of the document to the top instead of the default top to bottom search method. This version of the Find method also enables you to narrow the search for text by selecting a specific starting position within the control's text. This feature can enable you to avoid text that might have already been searched or where the specific text you are searching for is known not to exist. When the FindOptions.Reverse value is specified in the options parameter, the value of the start parameter indicates the position where the reverse search will end since the search will start at the bottom of the document when using this version of the Find method.

Note The Find methods that accept a string as a parameter cannot find text that is contained on more than one line of text within the RichTextBox. Performing such a search will return a value of negative one (-1).

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None)!= -1)
    {
        this.RichTextBox1.SelectionStart = this.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None);
        this.RichTextBox1.SelectionLength = 7;
        this.RichTextBox1.SelectionColor = System.Drawing.Color.Crimson;
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None) = -1 Then
        Me.RichTextBox1.SelectionStart = Me.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None)
        Me.RichTextBox1.SelectionLength = 7
        Me.RichTextBox1.SelectionColor = System.Drawing.Color.Crimson
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


InsertField Method

[image]
ActiveReports 13
InsertField Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : InsertField Method

fieldName
Specifies a unique name to be used when to reference this field in the ReplaceField method.

Glossary Item Box

Inserts a RichTextBox merge field into the current location in the text.

Syntax

Visual Basic (Declaration)
Public Sub InsertField( _
   ByVal fieldName As String _
)
C#
public void InsertField(
   string fieldName
)

Parameters

fieldName
Specifies a unique name to be used when to reference this field in the ReplaceField method.

Remarks

You can use the InsertField method to create mail-merged content when the text is added to the RichTextBox control at run time. Inserting a mail-merge field adds brackets around the field name and sets the text to protected.

Example

C# Copy Code
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    this.rtf.ReplaceField("CompanyName", "m_companyName");
    this.rtf.ReplaceField("ContactName", "m_contactName");
    this.rtf.ReplaceField("AddressLine", "m_addressLine");
    this.rtf.ReplaceField("City", "m_city");
    this.rtf.ReplaceField("Region", "m_region");
    this.rtf.ReplaceField("Country", "m_country");
    this.rtf.ReplaceField("PostalCode", "m_postalCode");
    this.rtf.ReplaceField("Date", System.DateTime.Today.Date.ToString());
    this.rtf.InsertField("CustomerID");
}
Visual Basic Copy Code
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    Me.rtf.ReplaceField("CompanyName", "m_companyName")
    Me.rtf.ReplaceField("ContactName", "m_contactName")
    Me.rtf.ReplaceField("AddressLine", "m_addressLine")
    Me.rtf.ReplaceField("City", "m_city")
    Me.rtf.ReplaceField("Region", "m_region")
    Me.rtf.ReplaceField("Country", "m_country")
    Me.rtf.ReplaceField("PostalCode", "m_postalCode")
    Me.rtf.ReplaceField("Date", System.DateTime.Today.Date)
    Me.rtf.InsertField("CustomerID")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~ReplaceField


Load Method

[image]
ActiveReports 13
Load Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Load Method

stream
Stream with content
type
RichText type; one of rtf, html or text

Glossary Item Box

Loads the contents of a stream into the RichTextBox control.

Syntax

Visual Basic (Declaration)
Public Sub Load( _
   ByVal stream As Stream, _
   ByVal type As RichTextType _
)
C#
public void Load(
   Stream stream,
   RichTextType type
)

Parameters

stream
Stream with content
type
RichText type; one of rtf, html or text

Remarks

The data loaded from the stream replaces the existing text in the RichTextBox.

Example

To use this sample code, you will need a sample.rtf file and a sample.html file as well as two RichTextBox controls on an ActiveReport.
C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    System.IO.FileStream streamR = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.rtf", System.IO.FileMode.Open);
    rtfRTF.Load(streamR, RichTextType.Rtf);

    System.IO.FileStream streamH = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.html", System.IO.FileMode.Open);
    rtfHTML.Load(streamH, RichTextType.Html);
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim streamR As New System.IO.FileStream(Application.StartupPath & "\sample.rtf", IO.FileMode.Open)
    rtfRTF.Load(streamR, RichTextType.Rtf)
    Dim streamH As New System.IO.FileStream(Application.StartupPath & "\sample.html", IO.FileMode.Open)
    rtfHTML.Load(streamH, RichTextType.Html)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Clear
ActiveReports6~GrapeCity.ActiveReports.RichTextType


LoadFile Method

[image]
ActiveReports 13
LoadFile Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : LoadFile Method

Glossary Item Box

Loads an HTML or RTF file. Obsolete. Included only for backward compatibility.

Overload List

Overload | Description
LoadFile(String) | Loads an HTML or RTF file.
LoadFile(Stream) | Loads an HTML or RTF stream.

Remarks

This method has been deprecated. Please use Load(Stream stream, RichTextType type).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


LoadFile(String) Method

[image]
ActiveReports 13
LoadFile(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > LoadFile Method : LoadFile(String) Method

fileName
file name to load the RichTextBox content from

Glossary Item Box

Loads an HTML or RTF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadFile( _
   ByVal fileName As String _
)
C#
public void LoadFile(
   string fileName
)

Parameters

fileName
file name to load the RichTextBox content from

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


LoadFile(Stream) Method

[image]
ActiveReports 13
LoadFile(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > LoadFile Method : LoadFile(Stream) Method

stream
stream to load the RichTextBox content from

Glossary Item Box

Loads an HTML or RTF stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadFile( _
   ByVal stream As Stream _
)
C#
public void LoadFile(
   Stream stream
)

Parameters

stream
stream to load the RichTextBox content from

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


ReplaceField Method

[image]
ActiveReports 13
ReplaceField Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : ReplaceField Method

fieldName
Name of the merge field to be replaced with the specified text.
replaceText
The value used to replace the specified field.

Glossary Item Box

Merges the contents of the RTF stream with the field values specified.

Syntax

Visual Basic (Declaration)
Public Sub ReplaceField( _
   ByVal fieldName As String, _
   ByVal replaceText As String _
)
C#
public void ReplaceField(
   string fieldName,
   string replaceText
)

Parameters

fieldName
Name of the merge field to be replaced with the specified text.
replaceText
The value used to replace the specified field.

Remarks

A merge field is created using the InsertField method.

You can use this method to create mail-merge RTF content in your report. The control will replace all occurrences of the field with the specified value.

Example

C# Copy Code
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    this.rtf.ReplaceField("CompanyName", "m_companyName");
    this.rtf.ReplaceField("ContactName", "m_contactName");
    this.rtf.ReplaceField("AddressLine", "m_addressLine");
    this.rtf.ReplaceField("City", "m_city");
    this.rtf.ReplaceField("Region", "m_region");
    this.rtf.ReplaceField("Country", "m_country");
    this.rtf.ReplaceField("PostalCode", "m_postalCode");
    this.rtf.ReplaceField("Date", System.DateTime.Today.Date.ToString());
}
Visual Basic Copy Code
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    Me.rtf.ReplaceField("CompanyName", "m_companyName")
    Me.rtf.ReplaceField("ContactName", "m_contactName")
    Me.rtf.ReplaceField("AddressLine", "m_addressLine")
    Me.rtf.ReplaceField("City", "m_city")
    Me.rtf.ReplaceField("Region", "m_region")
    Me.rtf.ReplaceField("Country", "m_country")
    Me.rtf.ReplaceField("PostalCode", "m_postalCode")
    Me.rtf.ReplaceField("Date", System.DateTime.Today.Date)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
InsertField Method

Walkthroughs

Mail Merge with RichText


RichTextBox Class Properties

[image]
ActiveReports 13
RichTextBox Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

Glossary Item Box

For a list of all members of this type, see RichTextBox members.

Public Properties

 | Name | Description
Public Property | AutoReplaceFields | Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | BulletIndent | Gets or sets the indentation used in the control when the bullet style is applied to the text.
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text. For design time use only.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Html | Sets or returns the hypertext to be rendered in the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MaxLength | Gets or sets the maximum number of characters in the control for the End-User Report Designer.
Public Property | Multiline | Gets or sets a value that determines whether the RichTextBox prints multiple lines or single line.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RTF | Gets or sets the rich text content of the control.
Public Property | SelectedText | Gets or sets the current selected text in the control.
Public Property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point.
Public Property | SelectionBackColor | Gets or sets the background color of the current text selection.
Public Property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection.
Public Property | SelectionCharOffset | Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.
Public Property | SelectionColor | Gets or sets the text color of the current text selection.
Public Property | SelectionFont | Gets or sets the font of the current text selection.
Public Property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. Renders the selected text the specified number of inches to the left of the RichTextBox.
Public Property | SelectionIndent | Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection. Renders the selected text the specified number of inches to the right of the RichTextBox.
Public Property | SelectionLength | Gets or sets the number of characters selected in control.
Public Property | SelectionRightIndent | The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the current text in the RichTextBox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AutoReplaceFields Property

[image]
ActiveReports 13
AutoReplaceFields Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : AutoReplaceFields Property

Glossary Item Box

Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.

Syntax

Visual Basic (Declaration)
Public Property AutoReplaceFields As Boolean
C#
public bool AutoReplaceFields {get; set;}

Property Value

Boolean.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : BackColor Property

Glossary Item Box

Gets or sets the control's background color or fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.BackColor = System.Drawing.Color.DarkGoldenrod;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.BackColor = System.Drawing.Color.DarkGoldenrod
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


BulletIndent Property

[image]
ActiveReports 13
BulletIndent Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : BulletIndent Property

Glossary Item Box

Gets or sets the indentation used in the control when the bullet style is applied to the text.

Syntax

Visual Basic (Declaration)
Public Property BulletIndent As Single
C#
public float BulletIndent {get; set;}

Property Value

Float value that is the current bullet indent value in inches. Default is 0.5 inch.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.BulletIndent = .25f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.BulletIndent = 0.25
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


CanGrow Property

[image]
ActiveReports 13
CanGrow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior of the control. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the control and shifts all controls below it to account for the increase in height.

Remarks

The increase in height might cause the section height to increase. The section's CanGrow property should also be set to True to avoid clipping the section.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.CanGrow = false;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.rtbActiveReport.CanGrow = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanGrow
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~CanShrink


CanShrink Property

[image]
ActiveReports 13
CanShrink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should decrease the height of the field based on its value.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Remarks

The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are no intersecting controls along the shifting path.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.CanShrink = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.CanShrink = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanShrink
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~CanGrow


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control text. For design time use only.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

Current System.Drawing.Font object used to render the control's text.

Remarks

The Font property is for design-time use only. To set the font at run time, use the SelectionFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
SelectionFont Property


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

Current font System.Drawing.Color. Default is Color.Black.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.ForeColor = System.Drawing.Color.DarkGoldenrod;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.ForeColor = System.Drawing.Color.DarkGoldenrod
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~BackColor


Html Property

[image]
ActiveReports 13
Html Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Html Property

Glossary Item Box

Sets or returns the hypertext to be rendered in the control.

Syntax

Visual Basic (Declaration)
Public Property Html As String
C#
public string Html {get; set;}

Property Value

Valid hypertext with tags which will be rendered in the control.

Remarks

\n" + this.RichTextBox1.Text;}

Example

C# Copy Code
private void reportHeader1_Format(object sender, System.EventArgs e)
{
    RichTextBox1.Html = RichTextBox1.Text;
}
Visual Basic Copy Code
Private Sub ReportHeader1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReportHeader1.Format
    RichTextBox1.Html = RichTextBox1.Text
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


MaxLength Property

[image]
ActiveReports 13
MaxLength Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : MaxLength Property

Glossary Item Box

Gets or sets the maximum number of characters in the control for the End-User Report Designer.

Syntax

Visual Basic (Declaration)
Public Property MaxLength As Integer
C#
public int MaxLength {get; set;}

Property Value

An integer value that specifies the maximum number of characters. The default value is 0, which allows an unlimited number of characters.

Remarks

This property can only be used with the End-User Report Designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Multiline Property

[image]
ActiveReports 13
Multiline Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Multiline Property

Glossary Item Box

Gets or sets a value that determines whether the RichTextBox prints multiple lines or single line.

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
C#
public bool Multiline {get; set;}

Property Value

A Boolean value. True prints a content on multiple lines; if False, the control is limited to single lines.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.Multiline = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.Multiline = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


RTF Property

[image]
ActiveReports 13
RTF Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RTF Property

Glossary Item Box

Gets or sets the rich text content of the control.

Syntax

Visual Basic (Declaration)
Public Property RTF As String
C#
public string RTF {get; set;}

Property Value

A string value. Contents of the RichTextBox control.

Remarks

The RichTextBox control is limited in its support for advanced RTF features such as the ones supported by Microsoft Word. In general, the features supported by WordPad are supported in this control. Tables are now supported as well.

Example

The following example sets the contents of the RichTextBox to a formatted Rich Text string.
C# Copy Code
this.RichTextBox1.RTF = @"{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}\viewkind4\uc1\pard\lang1033\f0\fs17 Rich Text\par }";
Visual Basic Copy Code
Me.RichTextBox1.RTF = "{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}\viewkind4\uc1\pard\lang1033\f0\fs17 Rich Text\par }"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Text


SelectedText Property

[image]
ActiveReports 13
SelectedText Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectedText Property

Glossary Item Box

Gets or sets the current selected text in the control.

Syntax

Visual Basic (Declaration)
Public Property SelectedText As String
C#
public string SelectedText {get; set;}

Property Value

A string that represents the selected text in the control.

Remarks

To set this property, first set the SelectionStart and SelectionLength properties.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("terrorizing") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("terrorizing");
        this.rtbActiveReport.SelectionLength = 11;
        this.rtbActiveReport.SelectedText = "TERRORIZING";
        this.rtbActiveReport.SelectionColor = System.Drawing.Color.Crimson;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("terrorizing") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("terrorizing")
        Me.rtbActiveReport.SelectionLength = 11
        Me.rtbActiveReport.SelectedText = "TERRORIZING"
        Me.rtbActiveReport.SelectionColor = System.Drawing.Color.Crimson
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~RTF
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Text
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionStart
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionLength


SelectionAlignment Property

[image]
ActiveReports 13
SelectionAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionAlignment Property

Glossary Item Box

Gets or sets the alignment to apply to the current selection or insertion point.

Syntax

Visual Basic (Declaration)
Public Property SelectionAlignment As GrapeCity.ActiveReports.Drawing.TextAlignment
C#
public GrapeCity.ActiveReports.Drawing.TextAlignment SelectionAlignment {get; set;}

Property Value

TextAlignment enumeration.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("Title") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("Title");
        this.rtbActiveReport.SelectionLength = 5;
        this.rtbActiveReport.SelectionAlignment = TextAlignment.Center;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("Title") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("Title")
        Me.rtbActiveReport.SelectionLength = 5
        Me.rtbActiveReport.SelectionAlignment = TextAlignment.Center
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionBackColor Property

[image]
ActiveReports 13
SelectionBackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionBackColor Property

Glossary Item Box

Gets or sets the background color of the current text selection.

Syntax

Visual Basic (Declaration)
Public Property SelectionBackColor As Color
C#
public Color SelectionBackColor {get; set;}

Property Value

A System.Drawing.Color value that represents the background color to apply to the current text selection.

Remarks

If the current text selection has more than one color specified, this property returns Color.Empty.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("Title") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("Title");
        this.rtbActiveReport.SelectionLength = 5;
        this.rtbActiveReport.SelectionBackColor = System.Drawing.Color.Chocolate;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("Title") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("Title")
        Me.rtbActiveReport.SelectionLength = 5
        Me.rtbActiveReport.SelectionBackColor = System.Drawing.Color.Chocolate
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionBullet Property

[image]
ActiveReports 13
SelectionBullet Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionBullet Property

Glossary Item Box

Gets or sets a value indicating whether the bullet style is applied to the current selection.

Syntax

Visual Basic (Declaration)
Public Property SelectionBullet As Boolean
C#
public bool SelectionBullet {get; set;}

Property Value

True if the current selection has the bullet style applied; otherwise, False.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List") + 5;
        this.rtbActiveReport.SelectionBullet = true;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List") + 5
        Me.rtbActiveReport.SelectionBullet = True
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~BulletIndent


SelectionCharOffset Property

[image]
ActiveReports 13
SelectionCharOffset Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionCharOffset Property

Glossary Item Box

Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.

Syntax

Visual Basic (Declaration)
Public Property SelectionCharOffset As Single
C#
public float SelectionCharOffset {get; set;}

Property Value

A number that specifies the character offset in inches.

The value of this property must be between -2000 and 2000.

If this property is set to zero, the text appears on the baseline. If it is a positive number, the number specifies the number of inches by which to raise the text selection above the baseline. If it is a negative number, this number specifies the number of inches by which to subscript the text selection. You can use this property to specify text as superscript or subscript.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("footnote") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("footnote");
        this.rtbActiveReport.SelectionLength = 11;
        this.rtbActiveReport.SelectionCharOffset = .05f;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("footnote") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("footnote")
        Me.rtbActiveReport.SelectionLength = 11
        Me.rtbActiveReport.SelectionCharOffset = 0.05
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionColor Property

[image]
ActiveReports 13
SelectionColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionColor Property

Glossary Item Box

Gets or sets the text color of the current text selection.

Syntax

Visual Basic (Declaration)
Public Property SelectionColor As Color
C#
public Color SelectionColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color to apply to the current text selection.

Remarks

If the current text selection has more than one color specified, this property returns Color.Empty.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("footnote") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("footnote");
        this.rtbActiveReport.SelectionLength = 11;
        this.rtbActiveReport.SelectionCharOffset = .05f;
        this.rtbActiveReport.SelectionColor = System.Drawing.Color.CornflowerBlue;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("footnote") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("footnote")
        Me.rtbActiveReport.SelectionLength = 11
        Me.rtbActiveReport.SelectionCharOffset = 0.05
        Me.rtbActiveReport.SelectionColor = System.Drawing.Color.CornflowerBlue
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionBackColor


SelectionFont Property

[image]
ActiveReports 13
SelectionFont Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionFont Property

Glossary Item Box

Gets or sets the font of the current text selection.

Syntax

Visual Basic (Declaration)
Public Property SelectionFont As Font
C#
public Font SelectionFont {get; set;}

Property Value

A System.Drawing.Font value that represents the font to apply to the current text selection.

Remarks

If the current text selection has more than one font specified, this property is a null reference (Nothing in Visual Basic).

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("footnote") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("footnote");
        this.rtbActiveReport.SelectionLength = 8;
        this.rtbActiveReport.SelectionCharOffset = .05f;
        this.rtbActiveReport.SelectionFont = new System.Drawing.Font("Tahoma", 8, System.Drawing.FontStyle.Italic);
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("footnote") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("footnote")
        Me.rtbActiveReport.SelectionLength = 8
        Me.rtbActiveReport.SelectionCharOffset = 0.05
        Me.rtbActiveReport.SelectionFont = New System.Drawing.Font("Tahoma", 8, FontStyle.Italic)
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionHangingIndent Property

[image]
ActiveReports 13
SelectionHangingIndent Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionHangingIndent Property

Glossary Item Box

Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. Renders the selected text the specified number of inches to the left of the RichTextBox.

Syntax

Visual Basic (Declaration)
Public Property SelectionHangingIndent As Single
C#
public float SelectionHangingIndent {get; set;}

Property Value

An integer value that represents the distance, in inches, for the hanging indent applied to the current text selection.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List");
        this.rtbActiveReport.SelectionLength = 4;
        this.rtbActiveReport.SelectionHangingIndent = 0.5f;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List")
        Me.rtbActiveReport.SelectionLength = 4
        Me.rtbActiveReport.SelectionHangingIndent = 0.5
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionIndent
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionRightIndent


SelectionIndent Property

[image]
ActiveReports 13
SelectionIndent Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionIndent Property

Glossary Item Box

Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection. Renders the selected text the specified number of inches to the right of the RichTextBox.

Syntax

Visual Basic (Declaration)
Public Property SelectionIndent As Single
C#
public float SelectionIndent {get; set;}

Property Value

An integer value that represents the current distance, in inches, of the indentation applied to the left of the current text selection.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List");
        this.rtbActiveReport.SelectionLength = 4;
        this.rtbActiveReport.SelectionIndent = 0.5f;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List")
        Me.rtbActiveReport.SelectionLength = 4
        Me.rtbActiveReport.SelectionIndent = 0.5
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionHangingIndent
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionRightIndent


SelectionLength Property

[image]
ActiveReports 13
SelectionLength Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionLength Property

Glossary Item Box

Gets or sets the number of characters selected in control.

Syntax

Visual Basic (Declaration)
Public Property SelectionLength As Integer
C#
public int SelectionLength {get; set;}

Property Value

The number of characters selected in the text box.

Remarks

You can use this property to determine if any characters are currently selected in the text box control before performing operations on the selected text.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List");
        this.rtbActiveReport.SelectionLength = 4;
        this.rtbActiveReport.SelectionIndent = 0.5f;
    }
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List")
        Me.rtbActiveReport.SelectionLength = 4
        Me.rtbActiveReport.SelectionIndent = 0.5
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionStart


SelectionRightIndent Property

[image]
ActiveReports 13
SelectionRightIndent Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionRightIndent Property

Glossary Item Box

The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.

Syntax

Visual Basic (Declaration)
Public Property SelectionRightIndent As Single
C#
public float SelectionRightIndent {get; set;}

Property Value

The indentation space, in inches, at the right of the current selection or insertion point.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.SelectionStart = 0;
    this.rtbActiveReport.SelectionLength = 100;
    this.rtbActiveReport.SelectionRightIndent = 1;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.SelectionStart = 0
    Me.rtbActiveReport.SelectionLength = 100
    Me.rtbActiveReport.SelectionRightIndent = 0.5
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionHangingIndent
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionIndent


SelectionStart Property

[image]
ActiveReports 13
SelectionStart Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionStart Property

Glossary Item Box

Gets or sets the starting point of text selected in the text box.

Syntax

Visual Basic (Declaration)
Public Property SelectionStart As Integer
C#
public int SelectionStart {get; set;}

Property Value

The starting position of text selected in the text box.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.SelectionStart = 0;
    this.rtbActiveReport.SelectionLength = 100;
    this.rtbActiveReport.SelectionRightIndent = 1;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.SelectionStart = 0
    Me.rtbActiveReport.SelectionLength = 100
    Me.rtbActiveReport.SelectionRightIndent = 0.5
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionLength


Text Property

[image]
ActiveReports 13
Text Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Text Property

Glossary Item Box

Gets or sets the current text in the RichTextBox.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

The text displayed in the control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.Text = "Confidential";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.Text = "Confidential"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RichTextBox Class
RichTextBox Members


Section Class

[image]
ActiveReports 13
Section Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

Section is the base class of all ActiveReports section types.

Object Model

Section Class

Syntax

Visual Basic (Declaration)
Public Class Section
C#
public class Section

Remarks

Use this class to access, add or modify section controls and set section properties. You can add sections to a report using the Sections property of the report object and the SectionCollection class.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark("Products");
    this.detail.BackColor = System.Drawing.Color.Transparent;
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
    this.detail.Controls.Clear();
    this.detail.Height = 2.0f;
    this.detail.Name = "Products";
    this.detail.Visible = true;
    this.detail.SizeToFit();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark("Products")
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
    Me.Detail1.Controls.Clear()
    Me.Detail1.Height = 2.0F
    Me.Detail1.Name = "Products"
    Me.Detail1.Visible = True
    Me.Detail1.SizeToFit()
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail
GrapeCity.ActiveReports.SectionReportModel.GroupFooter
GrapeCity.ActiveReports.SectionReportModel.GroupHeader
GrapeCity.ActiveReports.SectionReportModel.PageFooter
GrapeCity.ActiveReports.SectionReportModel.PageHeader
GrapeCity.ActiveReports.SectionReportModel.ReportFooter
GrapeCity.ActiveReports.SectionReportModel.ReportHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Section Class Members

[image]
ActiveReports 13
Section Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

The following tables list the members exposed by Section.

Public Constructors

 | Name | Description
Public Constructor | Section Constructor | Initializes a new instance of the Section class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section.
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height.
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls.
Public Property | Controls | Gets a collection of all controls contained in the section.
Public Property | Height | Gets or sets the height of the section.
Public Property | Name | Gets or sets the name of the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section.
Public Property | Type | Gets the section's type.
Public Property | Visible | Specifies whether the section should be printed or not.
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Public Method | SizeToFit | Overloaded. The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.
Top

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page.
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page.
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Section Constructor

[image]
ActiveReports 13
Section Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Section Constructor

Glossary Item Box

Initializes a new instance of the Section class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Section()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Section Class Methods

[image]
ActiveReports 13
Section Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

For a list of all members of this type, see Section members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Public Method | SizeToFit | Overloaded. The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AddBookmark(String) Method

[image]
ActiveReports 13
AddBookmark(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AddBookmark(String) Method

text
The bookmark text.

Glossary Item Box

Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.

Syntax

Visual Basic (Declaration)
Public Sub AddBookmark( _
   ByVal text As String _
)
C#
public void AddBookmark(
   string text
)

Parameters

text
The bookmark text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


SizeToFit Method

[image]
ActiveReports 13
SizeToFit Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : SizeToFit Method

Glossary Item Box

The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.

Overload List

Overload | Description
SizeToFit() | Sizes the section to fit the contained controls.
SizeToFit(Boolean) | Sizes the section to fit the contained controls and optionally allows the section to shrink to fit the contained controls.

Remarks

Using this method, a user could add several controls to a section at run time and then size the section to the proper height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


SizeToFit() Method

[image]
ActiveReports 13
SizeToFit() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class > SizeToFit Method : SizeToFit() Method

Glossary Item Box

Sizes the section to fit the contained controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SizeToFit()
C#
public void SizeToFit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
Overload List


SizeToFit(Boolean) Method

[image]
ActiveReports 13
SizeToFit(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class > SizeToFit Method : SizeToFit(Boolean) Method

bAllowShrink
Set to True to allow the section to shrink to fit the contained controls.

Glossary Item Box

Sizes the section to fit the contained controls and optionally allows the section to shrink to fit the contained controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SizeToFit( _
   ByVal bAllowShrink As Boolean _
)
C#
public void SizeToFit(
   bool bAllowShrink
)

Parameters

bAllowShrink
Set to True to allow the section to shrink to fit the contained controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
Overload List


Section Class Properties

[image]
ActiveReports 13
Section Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

For a list of all members of this type, see Section members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section.
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height.
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls.
Public Property | Controls | Gets a collection of all controls contained in the section.
Public Property | Height | Gets or sets the height of the section.
Public Property | Name | Gets or sets the name of the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section.
Public Property | Type | Gets the section's type.
Public Property | Visible | Specifies whether the section should be printed or not.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the section.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color value used to paint the section background. Default is Color.Transparent.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.Detail.BackColor = System.Drawing.Color.Transparent;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail.BackColor = System.Drawing.Color.Transparent
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


CanGrow Property

[image]
ActiveReports 13
CanGrow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : CanGrow Property

Glossary Item Box

Indicates whether the section height should grow when its controls extend beyond its original height.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

Boolean. True if the section should grow to fit its controls, False if the controls should be clipped to the section's height. Default is True.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanShrink


CanShrink Property

[image]
ActiveReports 13
CanShrink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : CanShrink Property

Glossary Item Box

Indicates whether the section height should be adjusted to the exact total height of its controls.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

Boolean. True if the section should shrink to fit its controls; False, otherwise. Default is False.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanGrow


Controls Property

[image]
ActiveReports 13
Controls Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Controls Property

Glossary Item Box

Gets a collection of all controls contained in the section.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As ControlCollection
C#
public ControlCollection Controls {get;}

Property Value

A ControlCollection object representing all controls contained within the section.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Controls.Clear();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Controls.Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Height Property

[image]
ActiveReports 13
Height Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Height Property

Glossary Item Box

Gets or sets the height of the section.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Property Value

Height of the section in inches. Default is 2 inches.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Height = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Height = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Name Property

[image]
ActiveReports 13
Name Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Name Property

Glossary Item Box

Gets or sets the name of the section.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

String. Unique name of the section.

Remarks

The section name is used as a key in the report Sections collection.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Name = "Products";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Name = "Products"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Tag Property

Glossary Item Box

Gets or sets user-defined information to be persisted with the section.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Type Property

Glossary Item Box

Gets the section's type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As SectionType
C#
public SectionType Type {get;}

Property Value

SectionType enumeration specifying the type of the section. Default is SectionType.Detail.

Remarks

ActiveReports has seven section types that determine how the section is processed and rendered. Report header and footer sections print at the beginning and end of the report. Page header and footer sections print at the top and bottom of each page. Group header and footer sections print at the beginning and end of each data grouping. A Detail section is printed for each data record in the data source.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Visible Property

Glossary Item Box

Specifies whether the section should be printed or not.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

Boolean value that specifies whether the section will be printed or not. Default is true.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Visible = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail.Visible = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Section Class Events

[image]
ActiveReports 13
Section Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

Glossary Item Box

For a list of all members of this type, see Section members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page.
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page.
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.
Top

See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AfterPrint Event

[image]
ActiveReports 13
AfterPrint Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AfterPrint Event

Glossary Item Box

Occurs after the section has been rendered to the page.

Syntax

Visual Basic (Declaration)
Public Event AfterPrint As EventHandler
C#
public event EventHandler AfterPrint

Remarks

This event allows you to draw directly to the canvas after the section has been rendered. It is not recommended to use this event to manage any data or variables because the sequence of the event relative to the other section events is not guaranteed.

Example

C# Copy Code
Private void reportHeader1_AfterPrint(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawRect(1,1,3,1);
}
Visual Basic Copy Code
Private Sub ReportHeader1_AfterPrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader1.AfterPrint
    Me.CurrentPage.DrawRect(1, 1, 3, 1)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~BeforePrint_EV
ActiveReports6~GrapeCity.ActiveReports.Section~Format_EV


BeforePrint Event

[image]
ActiveReports 13
BeforePrint Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : BeforePrint Event

Glossary Item Box

Occurs immediately before the section is rendered to the page.

Syntax

Visual Basic (Declaration)
Public Event BeforePrint As EventHandler
C#
public event EventHandler BeforePrint

Remarks

When this event occurs the section layout has been finalized and is ready to render. Any changes that might affect the size of the section (such as changing the section Height property) will be ignored.

Example

C# Copy Code
private void ghCustomerID_BeforePrint(object sender, System.EventArgs eArgs)
{
    this.rtf.ReplaceField("TotalOrders",this.txtTotalOrders.Text);
}
Visual Basic Copy Code
Private Sub ghCustomerID_BeforePrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles _    ghCustomerID.BeforePrint
        Me.rtf.ReplaceField("TotalOrders", Me.txtTotalOrders.Text)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~AfterPrint_EV
ActiveReports6~GrapeCity.ActiveReports.Section~Format_EV


Format Event

[image]
ActiveReports 13
Format Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Format Event

Glossary Item Box

Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.

Syntax

Visual Basic (Declaration)
Public Event Format As EventHandler
C#
public event EventHandler Format

Remarks

The format event is the only event where the section's height may be changed. This event may be used to set or change the properties of any controls, or load subreport controls with subreports.

If the CanGrow or CanShrink property of any child control or the section itself is set to True, all of the growing and shrinking of child controls and the section itself takes place in this event. Because of this, information about a control or section's height would not be accurate since ActiveReports might modify the value immediately after the event to account for any layout or data changes.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark("Products");
    this.detail.BackColor = System.Drawing.Color.Transparent;
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
    this.detail.Controls.Clear();
    this.detail.Height = 2.0f;
    this.detail.Name = "Products";
    this.detail.Visible = true;
    this.detail.SizeToFit();
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark("Products")
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
    Me.Detail1.Controls.Clear()
    Me.Detail1.Height = 2.0F
    Me.Detail1.Name = "Products"
    Me.Detail1.Visible = True
    Me.Detail1.SizeToFit()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


Shape Class

[image]
ActiveReports 13
Shape Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

Glossary Item Box

Prints a rectangular or oval shape on the report.

Object Model

Shape Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Shape
   Inherits ARControl
C#
public sealed class Shape : ARControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
    this.shape1.LineColor = System.Drawing.Color.Navy;
    this.shape1.LineStyle = LineStyle.Solid;
    this.shape1.LineWeight = 2.0f;
    this.shape1.Style = ShapeType.Ellipse;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
   Me.Shape1.LineColor = System.Drawing.Color.Navy
   Me.Shape1.LineStyle = LineStyle.Solid
   Me.Shape1.LineWeight = 2.0F
   Me.Shape1.Style = ShapeType.Ellipse
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Shape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Shape Class Members

[image]
ActiveReports 13
Shape Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

Glossary Item Box

The following tables list the members exposed by Shape.

Public Constructors

 | Name | Description
Public Constructor | Shape Constructor | Initializes a new instance of the Shape class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | BackColor2 | Gets or sets the background color of the control area.
Public Property | BackgroundPattern | Gets or sets the background pattern to hatch style
Public Property | BackgroundStyle | Gets or sets the background style.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | GradientStyle | Gets or sets the gradient style.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the shape's lines.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width in pixels used to draw the shape.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RoundingRadius | Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.
Public Property | Size | Gets or sets the size of the Shape control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the shape type to be printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Shape Constructor

[image]
ActiveReports 13
Shape Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : Shape Constructor

Glossary Item Box

Initializes a new instance of the Shape class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Shape()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


Shape Class Properties

[image]
ActiveReports 13
Shape Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

Glossary Item Box

For a list of all members of this type, see Shape members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | BackColor2 | Gets or sets the background color of the control area.
Public Property | BackgroundPattern | Gets or sets the background pattern to hatch style
Public Property | BackgroundStyle | Gets or sets the background style.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | GradientStyle | Gets or sets the gradient style.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the shape's lines.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width in pixels used to draw the shape.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RoundingRadius | Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.
Public Property | Size | Gets or sets the size of the Shape control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the shape type to be printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


BackColor2 Property

[image]
ActiveReports 13
BackColor2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackColor2 Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor2 As Color
C#
public Color BackColor2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


BackgroundPattern Property

[image]
ActiveReports 13
BackgroundPattern Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackgroundPattern Property

Glossary Item Box

Gets or sets the background pattern to hatch style

Syntax

Visual Basic (Declaration)
Public Property BackgroundPattern As HatchStyle
C#
public HatchStyle BackgroundPattern {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


BackgroundStyle Property

[image]
ActiveReports 13
BackgroundStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackgroundStyle Property

Glossary Item Box

Gets or sets the background style.

Syntax

Visual Basic (Declaration)
Public Property BackgroundStyle As BackgroundStyle
C#
public BackgroundStyle BackgroundStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


GradientStyle Property

[image]
ActiveReports 13
GradientStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : GradientStyle Property

Glossary Item Box

Gets or sets the gradient style.

Syntax

Visual Basic (Declaration)
Public Property GradientStyle As GradientStyle
C#
public GradientStyle GradientStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


LineColor Property

[image]
ActiveReports 13
LineColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineColor Property

Glossary Item Box

Gets or sets the color of the shape's lines.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the shape's lines. Default is Color.Black.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineColor = System.Drawing.Color.Navy;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineColor = System.Drawing.Color.Navy
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members
ActiveReports6~GrapeCity.ActiveReports.Shape~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Shape~LineWeight


LineStyle Property

[image]
ActiveReports 13
LineStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineStyle Property

Glossary Item Box

Gets or sets the pen style used to draw the line.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
C#
public LineStyle LineStyle {get; set;}

Property Value

Current LineStyle value. Default is LineStyle.Solid.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineStyle = LineStyle.Solid;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineStyle = LineStyle.Solid
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members
ActiveReports6~GrapeCity.ActiveReports.Shape~LineColor
ActiveReports6~GrapeCity.ActiveReports.Shape~LineWeight


LineWeight Property

[image]
ActiveReports 13
LineWeight Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineWeight Property

Glossary Item Box

Gets or sets the pen width in pixels used to draw the shape.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As Single
C#
public float LineWeight {get; set;}

Property Value

Float value that represents the current pen width in pixels. Default is 1.0f.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineWeight = 2.0f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineWeight = 2.0F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members
ActiveReports6~GrapeCity.ActiveReports.Shape~LineColor
ActiveReports6~GrapeCity.ActiveReports.Shape~LineStyle


RoundingRadius Property

[image]
ActiveReports 13
RoundingRadius Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : RoundingRadius Property

Glossary Item Box

Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.

Syntax

Visual Basic (Declaration)
Public Property RoundingRadius As CornersRadius
C#
public CornersRadius RoundingRadius {get; set;}

Remarks

The default value is 10%; valid values range from 0% to 100%.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
    this.shape1.LineColor = System.Drawing.Color.Navy;
    this.shape1.LineStyle = LineStyle.Solid;
    this.shape1.LineWeight = 2.0f;
    this.shape1.Style = ShapeType.RoundRect;
    this.shape1.RoundingRadius = 20f;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
   Me.Shape1.LineColor = System.Drawing.Color.Navy
   Me.Shape1.LineStyle = LineStyle.Solid
   Me.Shape1.LineWeight = 2.0F
   Me.Shape1.Style = ShapeType.RoundRect
   Me.Shape1.RoundingRadius = 20F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


Style Property

[image]
ActiveReports 13
Style Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : Style Property

Glossary Item Box

Gets or sets the shape type to be printed.

Syntax

Visual Basic (Declaration)
Public Property Style As ShapeType
C#
public ShapeType Style {get; set;}

Property Value

A ShapeType enumeration value that determines the shape to be printed.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.Style = ShapeType.Ellipse;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.Style = ShapeType.Ellipse
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


Style Class

[image]
ActiveReports 13
Style Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

Glossary Item Box

Represents the formatting properties of a control.

Object Model

Style Class

Syntax

Visual Basic (Declaration)
Public Class Style
C#
public class Style

Remarks

The Style class encapsulates the properties that control the appearance of a control and can be applied to multiple controls to provide a common appearance.

Style properties can be cascaded using inheritance. When creating a new style you can set the values of unset properties to inherit from a parent style. For example, if you have a style named "Normal", you can create a new style named "NormalBold" and set only the Parent property to "Normal" and the FontBold property to true. The remaining properties will be set the same as the parent style.

ActiveReports has a set of built-in styles that are defined in the StyleSheet class.

Example

Paste inside the ReportStart event.
C# Copy Code
private void rptGrapeCity_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = 10.5;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = 10.5
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Label Class
ClassName Property
StyleSheet Class

How To

Use External Style Sheets


Style Class Members

[image]
ActiveReports 13
Style Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

Glossary Item Box

The following tables list the members exposed by Style.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal text alignment of the control to which the style is applied.
Public Property | BackColor | Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | CharacterSet | Gets or sets the CharacterSet of the control. The value must be cast as a byte.
Public Property | FontBold | Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontItalic | Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontName | Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontSize | Gets or sets the size of the font used to render the control.
Public Property | FontStrikeThrough | Gets or sets the Font.StrikeThrough property of the control.
Public Property | FontUnderline | Gets or sets the Font.Underline property of the control.
Public Property | FontVertical | Gets or sets the Font.Vertical property of the control.
Public Property | ForeColor | Gets or sets the text color of the control.
Public Property | Name | Gets or sets the unique name of the style.
Public Property | Parent | Gets or sets the name of the parent style.
Public Property | Value | Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of text within the bounds of the control.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Label Class
ClassName Property
StyleSheet Class

How To

Use External Style Sheets


Style Class Properties

[image]
ActiveReports 13
Style Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

Glossary Item Box

For a list of all members of this type, see Style members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal text alignment of the control to which the style is applied.
Public Property | BackColor | Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | CharacterSet | Gets or sets the CharacterSet of the control. The value must be cast as a byte.
Public Property | FontBold | Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontItalic | Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontName | Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontSize | Gets or sets the size of the font used to render the control.
Public Property | FontStrikeThrough | Gets or sets the Font.StrikeThrough property of the control.
Public Property | FontUnderline | Gets or sets the Font.Underline property of the control.
Public Property | FontVertical | Gets or sets the Font.Vertical property of the control.
Public Property | ForeColor | Gets or sets the text color of the control.
Public Property | Name | Gets or sets the unique name of the style.
Public Property | Parent | Gets or sets the name of the parent style.
Public Property | Value | Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of text within the bounds of the control.
Top

See Also

Reference

Style Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Label Class
ClassName Property
StyleSheet Class

How To

Use External Style Sheets


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Alignment Property

Glossary Item Box

Gets or sets the horizontal text alignment of the control to which the style is applied.

Syntax

Visual Basic (Declaration)
Public Property Alignment As Object
C#
public object Alignment {get; set;}

Property Value

An enumeration value that specifies the horizontal text alignment.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Object
C#
public object BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


CharacterSet Property

[image]
ActiveReports 13
CharacterSet Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : CharacterSet Property

Glossary Item Box

Gets or sets the CharacterSet of the control. The value must be cast as a byte.

Syntax

Visual Basic (Declaration)
Public Property CharacterSet As Object
C#
public object CharacterSet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontBold Property

[image]
ActiveReports 13
FontBold Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontBold Property

Glossary Item Box

Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property FontBold As Object
C#
public object FontBold {get; set;}

Property Value

A Boolean value. True if the control font should be set to bold; False otherwise.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontItalic Property

[image]
ActiveReports 13
FontItalic Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontItalic Property

Glossary Item Box

Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property FontItalic As Object
C#
public object FontItalic {get; set;}

Property Value

A Boolean value. True if the control font should be set to italic; False otherwise.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontName Property

[image]
ActiveReports 13
FontName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontName Property

Glossary Item Box

Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.

Syntax

Visual Basic (Declaration)
Public Property FontName As Object
C#
public object FontName {get; set;}

Property Value

The name of the font that should be used to render the control text.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontSize Property

[image]
ActiveReports 13
FontSize Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontSize Property

Glossary Item Box

Gets or sets the size of the font used to render the control.

Syntax

Visual Basic (Declaration)
Public Property FontSize As Object
C#
public object FontSize {get; set;}

Property Value

Float font size in points or null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = 10.5;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = 10.5
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontStrikeThrough Property

[image]
ActiveReports 13
FontStrikeThrough Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontStrikeThrough Property

Glossary Item Box

Gets or sets the Font.StrikeThrough property of the control.

Syntax

Visual Basic (Declaration)
Public Property FontStrikeThrough As Object
C#
public object FontStrikeThrough {get; set;}

Property Value

A Boolean value. True if the control font should be set to strikethrough; False otherwise. Null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontUnderline Property

[image]
ActiveReports 13
FontUnderline Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontUnderline Property

Glossary Item Box

Gets or sets the Font.Underline property of the control.

Syntax

Visual Basic (Declaration)
Public Property FontUnderline As Object
C#
public object FontUnderline {get; set;}

Property Value

A Boolean value. True if the control font should be set to underline; False otherwise. Null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


FontVertical Property

[image]
ActiveReports 13
FontVertical Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontVertical Property

Glossary Item Box

Gets or sets the Font.Vertical property of the control.

Syntax

Visual Basic (Declaration)
Public Property FontVertical As Object
C#
public object FontVertical {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : ForeColor Property

Glossary Item Box

Gets or sets the text color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Object
C#
public object ForeColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color used to render the control text. Null if the property is inherited from the Style parent or not to be set on the control.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Name Property

[image]
ActiveReports 13
Name Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Name Property

Glossary Item Box

Gets or sets the unique name of the style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A string name of the style.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Parent Property

Glossary Item Box

Gets or sets the name of the parent style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Style
C#
public Style Parent {get;}

Property Value

A string name of the Style from which this Style object inherits its properties.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


Value Property

[image]
ActiveReports 13
Value Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Value Property

Glossary Item Box

Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Property Value

String.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


VerticalAlignment Property

[image]
ActiveReports 13
VerticalAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the vertical alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As Object
C#
public object VerticalAlignment {get; set;}

Property Value

A VerticalTextAlignment value that represents the alignment to be applied to the control's content. Null if the property is inherited from the Style parent.

Example

Paste inside the ReportStart event.
C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Style Class
Style Members


StyleSheet Class

[image]
ActiveReports 13
StyleSheet Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

Represents the collection of Style objects used to format controls.

Object Model

StyleSheet Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StyleSheet
C#
public sealed class StyleSheet

Remarks

You can use this collection to add or modify the styles used in the report and globally modify the formatting of controls in your report.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.StyleSheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


StyleSheet Class Members

[image]
ActiveReports 13
StyleSheet Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

The following tables list the members exposed by StyleSheet.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of Style objects in the collection.
Public Property | Item | Overloaded. Returns a reference to a Style object in the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new Style object to the collection.
Public Method | Clear | Removes the SytleSheet object from the collection.
Public Method | Contains | Determines whether the StyleSheet object contains the specified object.
Public Method | CopyTo | Copies the Style object to the indicated location.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified StyleSheet into the collection at the specified index.
Public Method | Remove | Overloaded. Removes a style from the collection.
Public Method | RemoveAt | Removes the StyleSheet object at the specified location from the collection.
Top

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the StyleSheet have changed.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


StyleSheet Class Methods

[image]
ActiveReports 13
StyleSheet Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new Style object to the collection.
Public Method | Clear | Removes the SytleSheet object from the collection.
Public Method | Contains | Determines whether the StyleSheet object contains the specified object.
Public Method | CopyTo | Copies the Style object to the indicated location.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified StyleSheet into the collection at the specified index.
Public Method | Remove | Overloaded. Removes a style from the collection.
Public Method | RemoveAt | Removes the StyleSheet object at the specified location from the collection.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


Add Method

[image]
ActiveReports 13
Add Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Add Method

Glossary Item Box

Adds a new Style object to the collection.

Overload List

Overload | Description
Add(String) | Adds a new Style object with the specified name to the collection.
Add(String,String) | Adds a new Style object to the collection and sets its parent style to the specified parent Style.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Add(String) Method

[image]
ActiveReports 13
Add(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Add Method : Add(String) Method

name
Specifies the name of the new style. Used as a key to access the style.

Glossary Item Box

Adds a new Style object with the specified name to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal name As String _
)
C#
public void Add(
   string name
)

Parameters

name
Specifies the name of the new style. Used as a key to access the style.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Add(String,String) Method

[image]
ActiveReports 13
Add(String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Add Method : Add(String,String) Method

name
Specifies the name of the new Style object.
nameOfParent
Specifies the parent Style whose properties will be inherited by the new Style.

Glossary Item Box

Adds a new Style object to the collection and sets its parent style to the specified parent Style.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal name As String, _
   ByVal nameOfParent As String _
)
C#
public void Add(
   string name,
   string nameOfParent
)

Parameters

name
Specifies the name of the new Style object.
nameOfParent
Specifies the parent Style whose properties will be inherited by the new Style.

Remarks

Styles are cascaded. Any properties not specified in the child Style are inherited from the parent Style.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Clear Method

Glossary Item Box

Removes the SytleSheet object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Contains Method

value
The value to check.

Glossary Item Box

Determines whether the StyleSheet object contains the specified object.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public bool Contains(
   object value
)

Parameters

value
The value to check.

Return Value

Boolean. Returns True if the collection contains the value; otherwise False

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : CopyTo Method

array
The one-dimensional Array that is the destination of the elements copied from StyleSheet. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the Style object to the indicated location.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from StyleSheet. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : IndexOf Method

value

The StyleSheet object to locate in the collection.

Glossary Item Box

Returns the index of the first occurrence of a value in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public int IndexOf(
   object value
)

Parameters

value

The StyleSheet object to locate in the collection.

Return Value

The index of value if found in the list; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Insert Method

index
The index at which to insert the StyleSheet object.
value
The StyleSheet to insert.

Glossary Item Box

Inserts the specified StyleSheet into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public void Insert(
   int index,
   object value
)

Parameters

index
The index at which to insert the StyleSheet object.
value
The StyleSheet to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Remove Method

Glossary Item Box

Removes a style from the collection. Removes the Style object from the collection.

Overload List

Overload | Description
Remove(Int32) | Removes the Style object at the specified index.
Remove(String) | Removes the Style object with the specified name.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Remove(Int32) Method

[image]
ActiveReports 13
Remove(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Remove Method : Remove(Int32) Method

index
Specifies the index of the Style object to be removed from the collection.

Glossary Item Box

Removes the Style object at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal index As Integer _
)
C#
public void Remove(
   int index
)

Parameters

index
Specifies the index of the Style object to be removed from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Remove(String) Method

[image]
ActiveReports 13
Remove(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Remove Method : Remove(String) Method

name
Specified the name of the Style to be removed from the collection.

Glossary Item Box

Removes the Style object with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal name As String _
)
C#
public void Remove(
   string name
)

Parameters

name
Specified the name of the Style to be removed from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : RemoveAt Method

index
The index of the StyleSheet to remove.

Glossary Item Box

Removes the StyleSheet object at the specified location from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The index of the StyleSheet to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Properties

[image]
ActiveReports 13
StyleSheet Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of Style objects in the collection.
Public Property | Item | Overloaded. Returns a reference to a Style object in the collection.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


Count Property

[image]
ActiveReports 13
Count Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Count Property

Glossary Item Box

Returns the number of Style objects in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

An integer value that represents the total number of styles in the collection.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Console.WriteLine("contains " & Me.StyleSheet.Count.ToString & " stylesheets")
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Item Property

[image]
ActiveReports 13
Item Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Item Property

Glossary Item Box

Returns a reference to a Style object in the collection.

Overload List

Overload | Description
Item(Int32) | Gets the StyleSheet object at the specified indexed location in the StyleSheetCollection.
Item(String) | Gets the StyleSheet object with the specified name in the StyleSheetCollection.

Example

C# Copy Code
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = True;
    this.StyleSheet["MyStyle"].FontItalic = False;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = False;
    this.StyleSheet["MyStyle"].FontUnderline = False;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    If (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


Item(Int32) Property

[image]
ActiveReports 13
Item(Int32) Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Item Property : Item(Int32) Property

index
Specifies the index of the Style to be returned.

Glossary Item Box

Gets the StyleSheet object at the specified indexed location in the StyleSheetCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Style
C#
public Style Item(
   int index
) {get;}

Parameters

index
Specifies the index of the Style to be returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Item(String) Property

[image]
ActiveReports 13
Item(String) Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Item Property : Item(String) Property

name
Specifies the name of the Style object to be returned.

Glossary Item Box

Gets the StyleSheet object with the specified name in the StyleSheetCollection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Style
C#
public Style Item(
   string name
) {get;}

Parameters

name
Specifies the name of the Style object to be returned.

Example

C# Copy Code
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = True;
    this.StyleSheet["MyStyle"].FontItalic = False;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = False;
    this.StyleSheet["MyStyle"].FontUnderline = False;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    If (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


StyleSheet Class Events

[image]
ActiveReports 13
StyleSheet Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

Glossary Item Box

For a list of all members of this type, see StyleSheet members.

Public Events

 | Name | Description
Public Event | Changed | Occurs when the members of the StyleSheet have changed.
Top

See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


Changed Event

[image]
ActiveReports 13
Changed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Changed Event

Glossary Item Box

Occurs when the members of the StyleSheet have changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleSheet Class
StyleSheet Members


SubReport Class

[image]
ActiveReports 13
SubReport Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

Glossary Item Box

Prints a linked report object as part of the current report. Subreports are linked using the Report property.

Object Model

SubReport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SubReport
   Inherits ARControl
C#
public sealed class SubReport : ARControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.SubReport1.CanGrow = true;
    this.SubReport1.CanShrink = false;
    this.SubReport1.ReportName = "Subreport1";

    SectionReport1 rpt = new SectionReport1();
    this.SubReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.SubReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Members
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Class Members

[image]
ActiveReports 13
SubReport Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

Glossary Item Box

The following tables list the members exposed by SubReport.

Public Constructors

 | Name | Description
Public Constructor | SubReport Constructor | Initializes a new instance of the SubReport class.
Top

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CloseBorder | Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Report | Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.
Public Property | ReportName | Specifies the name of the subreport.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Constructor

[image]
ActiveReports 13
SubReport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : SubReport Constructor

Glossary Item Box

Initializes a new instance of the SubReport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SubReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


SubReport Class Properties

[image]
ActiveReports 13
SubReport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

Glossary Item Box

For a list of all members of this type, see SubReport members.

Public Properties

 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CloseBorder | Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Report | Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.
Public Property | ReportName | Specifies the name of the subreport.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CanGrow Property

[image]
ActiveReports 13
CanGrow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the controls and shifts all controls below it to account for the increase in height.

Remarks

The increase in height might cause the section height to increase. The section's CanGrow property should be set to True to avoid clipping the section.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members
ActiveReports6~GrapeCity.ActiveReports.SubReport~CanShrink


CanShrink Property

[image]
ActiveReports 13
CanShrink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should decrease the height of the field based on its value.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Remarks

The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are not intersecting controls along the shifting path.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members
ActiveReports6~GrapeCity.ActiveReports.SubReport~CanGrow


CloseBorder Property

[image]
ActiveReports 13
CloseBorder Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CloseBorder Property

Glossary Item Box

Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.

Syntax

Visual Basic (Declaration)
Public Property CloseBorder As Boolean
C#
public bool CloseBorder {get; set;}

Property Value

A Boolean value. If True, the subreport borders will be closed on every page on which the subreport is rendered. The default value is False.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.CloseBorder = true;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.CloseBorder = True
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


Report Property

[image]
ActiveReports 13
Report Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : Report Property

Glossary Item Box

Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.

Syntax

Visual Basic (Declaration)
Public Property Report As SectionReport
C#
public SectionReport Report {get; set;}

Remarks

You should set this property to a new instance of the report you want to render in the ReportStart event of the parent report.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


ReportName Property

[image]
ActiveReports 13
ReportName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : ReportName Property

Glossary Item Box

Specifies the name of the subreport.

Syntax

Visual Basic (Declaration)
Public Property ReportName As String
C#
public string ReportName {get; set;}

Remarks

This property has no effect. It is informational only. You can use it for your own purposes.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubReport Class
SubReport Members


TextBox Class

[image]
ActiveReports 13
TextBox Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

Glossary Item Box

Prints a formatted text value, bound or unbound.

Object Model

TextBox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextBox
   Inherits ARControl
C#
public sealed class TextBox : ARControl

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Alignment = TextAlignment.Center;
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.ClassName = "Normal";
    this.textBox1.DistinctField = null;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
    this.textBox1.HyperLink = "mailto:support@company.com";
    this.textBox1.MultiLine = true;
    this.textBox1.OutputFormat = null;
    this.textBox1.SummaryFunc = SummaryFunc.Sum;
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
    this.textBox1.Text = "TextBox";
    this.textBox1.VerticalAlignment = VerticalTextAlignment.Top;
    this.textBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Alignment = TextAlignment.Center
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.DistinctField = Nothing
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
   Me.TextBox1.HyperLink = "mailto:support@company.com"
   Me.TextBox1.MultiLine = True
   Me.TextBox1.OutputFormat = Nothing
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
   Me.TextBox1.Text = "TextBox"
   Me.TextBox1.VerticalAlignment = VerticalTextAlignment.Top
   Me.TextBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.TextBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


TextBox Class Members

[image]
ActiveReports 13
TextBox Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

Glossary Item Box

The following tables list the members exposed by TextBox.

Public Constructors

 | Name | Description
Public Constructor | TextBox Constructor | Initializes a new instance of the TextBox class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the textbox control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | CountNullValues | Determines whether DBNull values should be included as zeroes in summary fields.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DistinctField | Gets or sets the name of the data field used in a distinct summary function.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a hyperlink for the text control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the textbox.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multiline textbox control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the textbox.
Public Property | SummaryFunc | Gets or sets the summary function type used to process the DataField values.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | SummaryType | Gets or sets a value that determines the summary type to be performed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the formatted text value to be rendered in the control.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the value of the control before formatting.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


TextBox Constructor

[image]
ActiveReports 13
TextBox Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : TextBox Constructor

Glossary Item Box

Initializes a new instance of the TextBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TextBox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

[image]
ActiveReports 13
TextBox Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

Glossary Item Box

For a list of all members of this type, see TextBox members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Calendar | Gets or sets calendar to use for formatting dates
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the textbox control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | CountNullValues | Determines whether DBNull values should be included as zeroes in summary fields.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DistinctField | Gets or sets the name of the data field used in a distinct summary function.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a hyperlink for the text control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the textbox.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MinCondenseRate | Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.
Public Property | MultiLine | Gets or sets a value indicating whether this is a multiline textbox control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the textbox.
Public Property | SummaryFunc | Gets or sets the summary function type used to process the DataField values.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | SummaryType | Gets or sets a value that determines the summary type to be performed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the formatted text value to be rendered in the control.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the value of the control before formatting.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Alignment Property

Glossary Item Box

Gets or sets the alignment of text within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property Alignment As GrapeCity.ActiveReports.Drawing.TextAlignment
C#
public GrapeCity.ActiveReports.Drawing.TextAlignment Alignment {get; set;}

Property Value

TextAlignment enumeration. The default value is TextAlignment.Left.

Remarks

The Justify text alignment option is not supported in edit mode. The text alignment automatically changes from Justify to Left (default value) when the control is in edit mode, and then back to Justify after exiting edit mode.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Alignment = TextAlignment.Center;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Alignment = TextAlignment.Center
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the control area.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Calendar Property

[image]
ActiveReports 13
Calendar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Calendar Property

Glossary Item Box

Gets or sets calendar to use for formatting dates

Syntax

Visual Basic (Declaration)
Public Property Calendar As String
C#
public string Calendar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


CanGrow Property

[image]
ActiveReports 13
CanGrow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CanGrow Property

Glossary Item Box

Determines whether ActiveReports should increase the height of the control based on its content.

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
C#
public bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the controls and shifts all controls below it to account for the increase in height.

Remarks

The increase in height might cause the section height to increase. The section's CanGrow property should be set to True to avoid clipping the section.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.MultiLine = true;
    this.textBox1.WordWrap = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~CanShrink


CanShrink Property

[image]
ActiveReports 13
CanShrink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CanShrink Property

Glossary Item Box

Determines whether ActiveReports should decrease the height of the field based on its value.

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
C#
public bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.

Remarks

The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are not intersecting controls along the shifting path.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.MultiLine = true;
    this.textBox1.WordWrap = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~CanGrow
ActiveReports6~GrapeCity.ActiveReports.Section~CanShrink


CharacterSpacing Property

[image]
ActiveReports 13
CharacterSpacing Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CharacterSpacing Property

Glossary Item Box

Gets or sets the distance in points between individual characters in the textbox control.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Remarks

The integrity of character spacing cannot be guaranteed to correctly duplicate your settings when exporting reports in XLS, RTF, and TEXT formats.

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   this.textBox1.CanGrow = true;
   this.textBox1.MultiLine = true;
   this.textBox1.CharacterSpacing = 2;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.MultiLine = True
   Me.TextBox1.CharacterSpacing = 2
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


ClassName Property

[image]
ActiveReports 13
ClassName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ClassName Property

Glossary Item Box

Gets or sets a style rule class name. The style rule is used to format the control.

Syntax

Visual Basic (Declaration)
Public Property ClassName As String
C#
public string ClassName {get; set;}

Property Value

String value that represents the style class name used to format the control's appearance. Default is Normal.

Remarks

You can use predefined styles in the report's stylesheet or add new ones to it.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.ClassName = "Normal";
    this.textBox1.OutputFormat = null;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.OutputFormat = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~Style
ActiveReports6~GrapeCity.ActiveReports.Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


CountNullValues Property

[image]
ActiveReports 13
CountNullValues Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CountNullValues Property

Glossary Item Box

Determines whether DBNull values should be included as zeroes in summary fields.

Syntax

Visual Basic (Declaration)
Public Property CountNullValues As Boolean
C#
public bool CountNullValues {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.ClassName = "Normal";
    this.textBox1.OutputFormat = null;
    this.textBox1.CountNullValues = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.OutputFormat = Nothing
   TextBox1.CountNullValues = True;
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Culture Property

[image]
ActiveReports 13
Culture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Culture Property

Glossary Item Box

Gets or sets the culture for the text control.

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
C#
public CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


DistinctField Property

[image]
ActiveReports 13
DistinctField Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : DistinctField Property

Glossary Item Box

Gets or sets the name of the data field used in a distinct summary function.

Syntax

Visual Basic (Declaration)
Public Property DistinctField As String
C#
public string DistinctField {get; set;}

Property Value

A string value that represents the field name to be used as a distinct field in the summary calculation.

Remarks

The summary function will process DataField values based on the distinct value of this field.

This property is used only when the SummaryFunc value is one of Distinct Summary Functions. When using the summary functions with a field, the CanGrow and CanShrink properties are disabled for the field.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.DistinctField = null;
    this.textBox1.SummaryFunc = SummaryFunc.Sum;
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.DistinctField = Nothing
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc


Font Property

[image]
ActiveReports 13
Font Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Font Property

Glossary Item Box

Gets or returns the font object used to print the control text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

Current Font object used to render the control's text.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Font = new System.Drawing.Font("Times New Roman", 14, System.Drawing.FontStyle.Bold);
}
Visual Basic Copy Code
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.TextBox1.Font = New System.Drawing.Font("Times New Roman", 14, FontStyle.Bold)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ForeColor Property

Glossary Item Box

Gets or returns the foreground (font) color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

Current font color. Default is Color.Black.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~BackColor


HyperLink Property

[image]
ActiveReports 13
HyperLink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : HyperLink Property

Glossary Item Box

Gets or sets a hyperlink for the text control.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Property Value

A string value that specifies the target of the hyperlink.

Remarks

Hyperlinks can be used in the viewer control to allow users to link to a bookmark in the report "toc://bookmark" or to a properly formatted internet target location (http, ftp, etc).

Clicking a hyperlink in the viewer control raises the HyperLink event.

Note: When using the HtmlViewer or the RawHtml to display a report, you should indicate the full URL address (for example, "http://grapecity.com") for this property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.HyperLink = "mailto:support@company.com";
    this.textBox1.Text = "Email support.";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.HyperLink = "mailto:support@company.com"
   Me.TextBox1.Text = "Email support."
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


LineSpacing Property

[image]
ActiveReports 13
LineSpacing Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : LineSpacing Property

Glossary Item Box

Gets or sets the spacing in points between the lines of text within the textbox.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Example

C# Copy Code
private void detail_Format(object sender, EventArgs e)
{
   this.textBox1.CanGrow = True;
   this.textBox1.MultiLine = True;
   this.textBox1.LineSpacing = 5;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.MultiLine = True
   Me.TextBox1.LineSpacing = 5
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


MinCondenseRate Property

[image]
ActiveReports 13
MinCondenseRate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : MinCondenseRate Property

Glossary Item Box

Gets ot sets the value indicating the minimal value to which the label should condense its characters horizontally in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property MinCondenseRate As Integer
C#
public int MinCondenseRate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


MultiLine Property

[image]
ActiveReports 13
MultiLine Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : MultiLine Property

Glossary Item Box

Gets or sets a value indicating whether this is a multiline textbox control.

Syntax

Visual Basic (Declaration)
Public Property MultiLine As Boolean
C#
public bool MultiLine {get; set;}

Property Value

A Boolean value. True if the textbox control is multi-line; otherwise, False.

Remarks

A multiline textbox control renders its text on more than one line. If the WordWrap property is set to True, long lines will be wrapped to the following line. If the WordWrap property is set to False, the text will print on a new line only when a newline character is encountered.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.CanGrow = true;
    this.TextBox1.CanShrink = false;
    this.TextBox1.MultiLine = true;
    this.TextBox1.WordWrap = true;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~WordWrap


OutputFormat Property

[image]
ActiveReports 13
OutputFormat Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : OutputFormat Property

Glossary Item Box

Gets or sets the mask string used to format the Value property before placing it in the Text property.

Syntax

Visual Basic (Declaration)
Public Property OutputFormat As String
C#
public string OutputFormat {get; set;}

Remarks

The formatting mask can only be used to format numbers and dates. There is no support for formatting alphanumeric strings.

Setting the OutputFormat in the Format event of a control's section does not catch the first record. The reason for this behaviour is that the database values are applied to the the control BEFORE the Format event. If you change the OutputFormat in the Format event, set Control.Value=Control.Value so that the OutputFormat gets reapplied.

Underscore (_) keycode can be used in OutputFormat property to skip the width of the next character. This code is commonly used as _) to leave space for a closing parenthesis in a positive number format when the negative number format includes parentheses. This allows both positive and negative values to line up at the decimal point.

The OutputFormat property of the TextBox control includes four sections delimited by a semicolon. Each section contains the format specifications for a different type of number:

  • The first section provides the format for positive numbers.
  • The second section provides the format for negative numbers.
  • The third section provides the format for Zero values.
  • The fourth section provides the format for Null or System.DBNull values.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.txtShippedDate.OutputFormat = "MMMM";
    this.txtShippedDate.Value = this.txtShippedDate.Value;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.txtShippedDate.OutputFormat = "MMMM"
    Me.txtShippedDate.Value = Me.txtShippedDate.Value
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members

Concepts

Date, Time, and Number Formatting


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Remarks

This property has five settings at design time: All, Left, Top, Right, and Bottom. More settings, like Vertical and Horizontal, are available in code. The All property has a default value of -1, which means that all of the Padding values are not equal. Change this value to 10, and a space ten pixels wide is left around the text on all sides. The Left, Top, Right, and Bottom properties are 0, 0, 0, 0 by default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : RightToLeft Property

Glossary Item Box

Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Property Value

true if [right to left]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


ShrinkToFit Property

[image]
ActiveReports 13
ShrinkToFit Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ShrinkToFit Property

Glossary Item Box

Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.

Syntax

Visual Basic (Declaration)
Public Property ShrinkToFit As Boolean
C#
public bool ShrinkToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Style Property

[image]
ActiveReports 13
Style Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Style Property

Glossary Item Box

Gets or sets a style string for the textbox.

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Property Value

String. CSS syntax of the control style.

Remarks

The style string overrides the global style rules specified in ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.txtShippedDate.Style = "text-align: center; font-weight: bold; font-size: 14pt;";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.txtShippedDate.Style = "text-align: center; font-weight: bold; font-size: 14pt;"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~ClassName
ActiveReports6~GrapeCity.ActiveReports.Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


SummaryFunc Property

[image]
ActiveReports 13
SummaryFunc Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryFunc Property

Glossary Item Box

Gets or sets the summary function type used to process the DataField values.

Syntax

Visual Basic (Declaration)
Public Property SummaryFunc As SummaryFunc
C#
public SummaryFunc SummaryFunc {get; set;}

Property Value

SummaryFunc enumeration value that specifies the type of summarization to be performed on the field. Default is SummaryFunc.Sum

Remarks

You can use this function to create subtotals, grand totals and other summary values. SummaryFunc has no effect unless the SummaryType property is set to either SubTotal or GrandTotal.

Note: When a summary function is used on a control, the CanGrow and CanShrink properties will have no effect since the summary is calculated after the control height has been determined and finalized.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryGroup
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


SummaryGroup Property

[image]
ActiveReports 13
SummaryGroup Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryGroup Property

Glossary Item Box

Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.

Syntax

Visual Basic (Declaration)
Public Property SummaryGroup As String
C#
public string SummaryGroup {get; set;}

Remarks

For example, setting a sum of Price for an Order group header will reset the sum to zero for each order group. The property is only used when SummaryType is set to SummaryType.SubTotal

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


SummaryRunning Property

[image]
ActiveReports 13
SummaryRunning Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryRunning Property

Glossary Item Box

Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).

Syntax

Visual Basic (Declaration)
Public Property SummaryRunning As SummaryRunning
C#
public SummaryRunning SummaryRunning {get; set;}

Property Value

SummaryRunning enumeration that determines the summarization behavior. Default is SummaryRunning.None.

Remarks

Setting this property to Group or All will make ActiveReports print a running summary of the field at the group or report level.

When used with Groups this property should only be set when SummaryType is GrandTotal or PageTotal, otherwise it should be set to None.

Example

C# Copy Code
Private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryGroup
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


SummaryType Property

[image]
ActiveReports 13
SummaryType Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryType Property

Glossary Item Box

Gets or sets a value that determines the summary type to be performed.

Syntax

Visual Basic (Declaration)
Public Property SummaryType As SummaryType
C#
public SummaryType SummaryType {get; set;}

Property Value

A SummaryType enumeration value that determines the type of summary to be performed. Default is SummaryType.None.

Remarks

ActiveReports can summarize the field as:

  • Subtotal (group level; reset for each group),
  • Grand total (report level; do not reset until all records are processed),
  • Page total (page level; reset for each page),
  • or a page count, which is the total number of pages printed.

If the summarized field is placed ahead of its summary level, (for example, placing a page total in the page header or a report grand total in the report header), the containing section and the following sections will not be printed until the summary value is resolved (calculated). When using the summary functions with a field, the CanGrow and CanShrink properties are disabled for the field.

Example

C# Copy Code
Private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryGroup
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning


Text Property

[image]
ActiveReports 13
Text Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Text Property

Glossary Item Box

Gets or sets the formatted text value to be rendered in the control.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

String value that represents the text to be rendered in the control.

Remarks

Use the Value property to modify the control's content, the Value will be formatted using OutputFormat into the Text property.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Text = "TextBox";
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Text = "TextBox"
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


TextJustify Property

[image]
ActiveReports 13
TextJustify Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : TextJustify Property

Glossary Item Box

Gets or sets the type of justification to use when the Alignment property is set to Justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As GrapeCity.ActiveReports.Drawing.TextJustify
C#
public GrapeCity.ActiveReports.Drawing.TextJustify TextJustify {get; set;}

Property Value

TextJustify enum. The default value is Auto. Possible values are:

  • Auto
  • Distribute
  • DistributeAllLines

Remarks

When you set the Alignment property to Justify, this property extends your justification options.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


Value Property

[image]
ActiveReports 13
Value Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Value Property

Glossary Item Box

Gets or sets the value of the control before formatting.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Property Value

An object that represents the current value of the control.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.TextBox1.Value.ToString() == "10249")
    {
        this.txtShippedDate.OutputFormat = "MMMM";
        this.txtShippedDate.ForeColor = System.Drawing.Color.Crimson;
    }
    else
    {
        this.txtShippedDate.OutputFormat = "MMM";
        this.txtShippedDate.ForeColor = System.Drawing.Color.Black;
    }
    //use the following lines to be sure that the OutputFormat
    //is applied to every record
    this.TextBox1.Value = this.TextBox1.Value;
    this.txtShippedDate.Value = this.txtShippedDate.Value;
}
Visual Basic Copy Code
Private Sub detail_Format(sender As Object, eArgs As System.EventArgs)
    If Me.TextBox1.Value.ToString() = "10249" Then
        Me.txtShippedDate.OutputFormat = "MMMM"
        Me.txtShippedDate.ForeColor = System.Drawing.Color.Crimson
    Else
        Me.txtShippedDate.OutputFormat = "MMM"
        Me.txtShippedDate.ForeColor = System.Drawing.Color.Black
    End If
    'use the following lines to be sure that the OutputFormat
    'is applied to every record
    Me.TextBox1.Value = Me.TextBox1.Value
    Me.txtShippedDate.Value = Me.txtShippedDate.Value
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


VerticalAlignment Property

[image]
ActiveReports 13
VerticalAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the position of the control's text vertically within the bounds of the control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As GrapeCity.ActiveReports.Drawing.VerticalTextAlignment
C#
public GrapeCity.ActiveReports.Drawing.VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration value that represents the vertical alignment of the control's text. Default is VerticalTextAlignment.Top.

Example

C# Copy Code
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.VerticalAlignment = VerticalTextAlignment.Top;
}
Visual Basic Copy Code
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.VerticalAlignment = VerticalTextAlignment.Top
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


VerticalText Property

[image]
ActiveReports 13
VerticalText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : VerticalText Property

Glossary Item Box

Gets or sets whether the control's text is rendered according to the vertical layout rules.

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Remarks

In case of the HTML export filter, the vertical text is supported just for the DynamicHtml output type and works with Microsoft Internet Explorer only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


WrapMode Property

[image]
ActiveReports 13
WrapMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : WrapMode Property

Glossary Item Box

Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As GrapeCity.ActiveReports.Drawing.WrapMode
C#
public GrapeCity.ActiveReports.Drawing.WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBox Class
TextBox Members


BackgroundStyle Enumeration

[image]
ActiveReports 13
BackgroundStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BackgroundStyle Enumeration

Glossary Item Box

Specifies the style used to draw the background of an object.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundStyle
   Inherits System.Enum
C#
public enum BackgroundStyle : System.Enum

Members

Member | Description
Gradient | A gradient fill is used for the background.
Pattern | A pattern fill is used for the background.
Solid | A solid fill is used for the background.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BackgroundStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


BarCodeCaptionPosition Enumeration

[image]
ActiveReports 13
BarCodeCaptionPosition Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeCaptionPosition Enumeration

Glossary Item Box

Specifies the barcode caption position relative to the barcode symbol.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeCaptionPosition
   Inherits System.Enum
C#
public enum BarCodeCaptionPosition : System.Enum

Members

Member | Description
Above | Caption is printed above the barcode symbol.
Below | Caption is printed below the barcode symbol.
None | Caption is not printed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeCaptionPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Barcode~CaptionPosition


BarCodeDirection Enumeration

[image]
ActiveReports 13
BarCodeDirection Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeDirection Enumeration

Glossary Item Box

Specifies the print direction of the barcode symbol.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeDirection
   Inherits System.Enum
C#
public enum BarCodeDirection : System.Enum

Members

Member | Description
BottomToTop | The barcode symbol is printed bottom to top.
LeftToRight | The barcode symbol is printed left to right (default).
RightToLeft | The barcode symbol is printed right to left.
TopToBottom | The barcode symbol is printed top to bottom.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Barcode~Direction


BarCodeStyle Enumeration

[image]
ActiveReports 13
BarCodeStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeStyle Enumeration

Glossary Item Box

Type of code, or symbology, the barcode control will use to generate the barcode.

Syntax

Visual Basic (Declaration)
Public Enum BarCodeStyle
   Inherits System.Enum
C#
public enum BarCodeStyle : System.Enum

Members

Member | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
BC412 | Data BC412 uses 35 characters, 0 - 9 and A - Z. It is designed for semiconductor wafer identification.
Codabar | Codabar uses A B C D + - : , / and numbers.
Code_11 | Encodes the numbers 0 through 9, the hyphen (-), and start/stop characters. It is primarily used in labeling telecommunications equipment.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses uppercase, % $ * / , + -, and numbers.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). If there are only 12 numbers in the string, it calculates a checksum and adds it to the thirteenth position. If there are 13, it validates the checksum and throws an error if it is incorrect.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1

EAN-128 is an alphanumeric one-dimensional representation of Application Identifier data. It is not meant for point-of-sales use, but for marking containers in the shipping industry.

This type of bar code contains the following sections:

  • Leading quiet zone (blank area)
  • Code 128 start character
    • A allows standard alphanumeric plus control and special characters
    • B allows standard alphanumeric plus lower case alpha and special characters
    • C allows a set of 100 digit pairs from 00 to 99
  • FNC (function) 1 character which allows scanners to identify this as an EAN-128 barcode
  • Data (AI or Application Identifier plus data field)
  • Symbol check character (Start code value plus product of each character position plus value of each character divided by 103. The checksum is the remainder value.)
  • Stop character
  • Trailing quiet zone (blank area)

The AI or Application Identifier in the Data section sets the type of the data to follow (i.e. ID, dates, quantity, measurements, etc.). There is a specific data structure for each type of data. This AI is what distinguishes the EAN-128 code from Code 128.

Multiple AIs (along with their data) can be combined into a single bar code.

EAN128FNC1 is a UCC/EAN-128 (EAN128) type barcode that allows you to insert FNC1 character at any place and adjust the bar size etc, which is not available in UCC/EAN-128.

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.

GS1QRCode | GS1 QRCode
HIBCCode128 | HIBCCode128 barcode uses the Code128 symbology. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
HIBCCode39 | HIBCCode39 barcode uses the Code39 symbology, with Code39OptionalCheckDigit property set to True. It encodes 'Primary Data' and 'Secondary Data' using slash (/) as delimiter. It is used in the health care products industry for identification purpose.
IATA_2_of_5 | IATA_2_of_5 is a variant of Code_2_of_5 and uses only numbers with a check digit.
IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
IntelligentMailPackage | IntelligentMailPackage is more efficient in terms of processing and tracking mails than Intelligent Mail barcode.
ISBN | International Standard Book Number barcode is a special form of the EAN-13 code and is used as a unique 9-digit commercial book identifier.
ISMN | Internationally Standard Music Number barcode is a special form of the EAN-13 code. It is used for marking printed musical publications.
ISSN | International Standard Serial Number barcode is a special form of the EAN-13 code. It is used to identify serial publications, publications that are issued in numerical order, such as the volumes of a magazine.
ITF14 | Interleaved Two of Five. This code is used to mark cartons and palettes that are including goods with an EAN-13 code. One digit is added in front of the EAN-13 code to mark the packing variant.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars. Matrix_2_of_5 uses only numbers.
MaxiCode | MaxiCode is special polar barcode.
MicroPDF417 | MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.
MicroQRCode | Micro QR Code is a variant of QR Code, with reduced barcode size. It has only one position detection pattern.
MSI | MSI Code uses only numbers.
None | None.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. Encodes the full ASCII character set. Capable of encoding as many as 2725 data characters.
Pharmacode | Pharmacode represents only numeric data from 3 to 131070. It is a barcode standard used in the pharmaceutical industry for packaging. It is designed to be readable despite printing errors.
Plessey | Plessey uses hexadecimal digits to encode. It is a one-dimensional barcode used mainly in libraries.
PostNet | PostNet uses only numbers with a check digit.
PZN | PZN Pharmaceutical Central/General Number uses the same encoding algorithm as Code 39 but can carry only digits – 0123456789. The number of digits supported for encoding are 6 or 7. The letters 'PZN' and checksum digit are automatically added. It is mainly used to identify medicine and health-care products in Germany and other German-speaking countries.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail RM4SCC uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification for use with omnidirectional point-of-sale scanners.
RSS14Stacked | RSS14Stacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14Truncated, but stacked in two rows when RSS14Truncated is too wide.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14, but stacked in two rows when RSS14 is too wide.
RSS14Truncated | RSS14Truncated is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus Indicator digits for use on small items, not for point-of-sale scanners.
RSSExpanded | RSSExpanded is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus AI element strings (expiration date, weight, etc.) for use with omnidirectional point-of-sale scanners.
RSSExpandedStacked | RSSExpandedStacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSSExpanded, but stacked in two rows when RSSExpanded is too wide.
RSSLimited | RSS Limited is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification with indicator digits of 0 or 1 in a small symbol that is not scanned by point-of-sale scanners.
SSCC_18 | SSCC_18 is an 18-digit Serial Shipping Container Code. It is used to identify individual shipping containers for tracking purposes.
Telepen | Telepen has 2 different modes - alphanumeric-only and numeric-only. Both modes require a start character, a check digit, and a stop character. It is mainly used in manufacturing industries.
UCCEAN128 | UCC/EAN –128 uses the complete ASCII character Set. This is a special version of Code 128 used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be 0 (zero)) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeStyle

Requirements

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Barcode~Style


ChartControl.UIAction Enumeration

[image]
ActiveReports 13
ChartControl.UIAction Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl.UIAction Enumeration

Glossary Item Box

Specifies the action to perform on the chart control.

Syntax

Visual Basic (Declaration)
Public Enum ChartControl.UIAction
   Inherits System.Enum
C#
public enum ChartControl.UIAction : System.Enum

Members

Member | Description
Clear | Replace the selected Chart control with a new Chart. Please note that this clears all properties set on the Chart and restores all default values. (Same as clicking the "New Chart" link below the Properties Window.)
Customize | Shows the Chart Designer dialog.
OpenXml | Shows a File Open dialog from which you can choose a chart XML file to load into the control.
SaveXml | Shows a File Save As dialog from which you can save the current chart's settings to a chart XML file.
Wizard | Shows the Chart Wizard dialog.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ChartControl.UIAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ChartControl~ExecuteAction


ColumnDirection Enumeration

[image]
ActiveReports 13
ColumnDirection Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ColumnDirection Enumeration

Glossary Item Box

Specifies the direction of columns in a multi-column report.

Syntax

Visual Basic (Declaration)
Public Enum ColumnDirection
   Inherits System.Enum
C#
public enum ColumnDirection : System.Enum

Members

Member | Description
AcrossDown | Print a row of details across all the columns before beginning a second row below it, and so on.
DownAcross | Prints a column of details down the first column before moving on to the next column to its right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ColumnDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnDirection


GradientStyle Enumeration

[image]
ActiveReports 13
GradientStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GradientStyle Enumeration

Glossary Item Box

Specifies the type of gradient to draw.

Syntax

Visual Basic (Declaration)
Public Enum GradientStyle
   Inherits System.Enum
C#
public enum GradientStyle : System.Enum

Members

Member | Description
DiagonalDown | The gradient is drawn from top left to bottom right.
DiagonalUp | The gradient is drawn from bottom left to top right.
FromCenter | A radial gradient is drawn from the center.
FromCorner | A radial gradient is drawn to the center.
Horizontal | A horizontal gradient is drawn.
Vertical | A vertical gradient is drawn.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.GradientStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


GroupKeepTogether Enumeration

[image]
ActiveReports 13
GroupKeepTogether Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupKeepTogether Enumeration

Glossary Item Box

Specifies whether a group header and footer pair with associated details will print as a single block on the same page.

Syntax

Visual Basic (Declaration)
Public Enum GroupKeepTogether
   Inherits System.Enum
C#
public enum GroupKeepTogether : System.Enum

Members

Member | Description
All | The group header, detail and group footer sections will print together on the same page.
FirstDetail | The group header will print with at least the first detail section on the same page or column.
None | A page can be broken immediately after a group header.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.GroupKeepTogether

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~GroupKeepTogether


ImageTypes Enumeration

[image]
ActiveReports 13
ImageTypes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ImageTypes Enumeration

Glossary Item Box

Specifies the type of image to be used for a chart.

Syntax

Visual Basic (Declaration)
Public Enum ImageTypes
   Inherits System.Enum
C#
public enum ImageTypes : System.Enum

Members

Member | Description
Metafile | This is the default value. A metafile is used.
PNG | A PNG file is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ImageTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


LineStyle Enumeration

[image]
ActiveReports 13
LineStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : LineStyle Enumeration

Glossary Item Box

Specifies the pen style used to draw a line.

Syntax

Visual Basic (Declaration)
Public Enum LineStyle
   Inherits System.Enum
C#
public enum LineStyle : System.Enum

Members

Member | Description
Dash | Dashes.
DashDot | Alternating dashes and dots.
DashDotDot | Alternating dashes and two dots.
Dot | Dots.
Double | Double line.
Solid | Solid line.
Transparent | No line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.LineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Picture~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Line~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Shape~LineStyle


NewColumn Enumeration

[image]
ActiveReports 13
NewColumn Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : NewColumn Enumeration

Glossary Item Box

Specifies whether a new column will be started before or after a section.

Syntax

Visual Basic (Declaration)
Public Enum NewColumn
   Inherits System.Enum
C#
public enum NewColumn : System.Enum

Members

Member | Description
After | The report will break to a new column after each instance of the section.
Before | The report will break to a new column before each instance of the section.
BeforeAfter | The report will break to a new column before and after each instance of the section.
None | Sections will continue printing in the same column until they've run out of space.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.NewColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Detail~NewColumn
ActiveReports6~GrapeCity.ActiveReports.GroupFooter~NewColumn
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~NewColumn


NewPage Enumeration

[image]
ActiveReports 13
NewPage Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : NewPage Enumeration

Glossary Item Box

Specifies whether a new page will be started before or after a section.

Syntax

Visual Basic (Declaration)
Public Enum NewPage
   Inherits System.Enum
C#
public enum NewPage : System.Enum

Members

Member | Description
After | The report will break to a new page after each instance of the section.
Before | The report will break to a new page before each instance of the section.
BeforeAfter | The report will break to a new page before and after each instance of the section.
None | Sections will continue printing on the same page until they've run out of space.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.NewPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Detail~NewPage
ActiveReports6~GrapeCity.ActiveReports.GroupFooter~NewPage
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~NewPage
ActiveReports6~GrapeCity.ActiveReports.ReportFooter~NewPage
ActiveReports6~GrapeCity.ActiveReports.ReportHeader~NewPage


Parameter.DataType Enumeration

[image]
ActiveReports 13
Parameter.DataType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter.DataType Enumeration

Glossary Item Box

Specifies the data type used to create the input control for collection of report parameter values.

Syntax

Visual Basic (Declaration)
Public Enum Parameter.DataType
   Inherits System.Enum
C#
public enum Parameter.DataType : System.Enum

Members

Member | Description
Boolean | Create a checkbox to collect the parameter value as a Boolean.
Date | Create a month calendar drop-down dialog to collect the parameter value as a date.
String | Create a textbox to collect the parameter value as a string.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Parameter~Type


ParameterCollection.ParseResultCode Enumeration

[image]
ActiveReports 13
ParameterCollection.ParseResultCode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection.ParseResultCode Enumeration

Glossary Item Box

Specifies the results of parsing the report's parameter values.

Syntax

Visual Basic (Declaration)
Public Enum ParameterCollection.ParseResultCode
   Inherits System.Enum
C#
public enum ParameterCollection.ParseResultCode : System.Enum

Members

Member | Description
MissingCloseParam | Indicates that the Parameter value is missing the parameter close.
MissingParamName | Indicates that the Parameter value is missing the parameter name.
Success | Indicates that the Parameter value is successful.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection


PictureAlignment Enumeration

[image]
ActiveReports 13
PictureAlignment Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PictureAlignment Enumeration

Glossary Item Box

Determines the position of the picture within the control area.

Syntax

Visual Basic (Declaration)
Public Enum PictureAlignment
   Inherits System.Enum
C#
public enum PictureAlignment : System.Enum

Members

Member | Description
BottomLeft | The picture will print in the bottom left corner of the control.
BottomRight | The picture will print in the bottom right corner of the control.
Center | The picture will be centered within the control.
TopLeft | The picture will print in the top left corner of the control.
TopRight | The picture will print in the top right corner of the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.PictureAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.OleObject~PictureAlignment
ActiveReports6~GrapeCity.ActiveReports.Picture~PictureAlignment
GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel~WatermarkAlignment


RepeatStyle Enumeration

[image]
ActiveReports 13
RepeatStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RepeatStyle Enumeration

Glossary Item Box

Specifies whether a group header section will be repeated with subsequent detail pages.

Syntax

Visual Basic (Declaration)
Public Enum RepeatStyle
   Inherits System.Enum
C#
public enum RepeatStyle : System.Enum

Members

Member | Description
All | Repeat the group header section on every page or column.
None | The group header will not be repeated when the associated detail sections print on a new page.
OnColumn | Repeat the group header section with every new column.
OnPage | Repeat the group header section with every new page.
OnPageIncludeNoDetail | Repeat the group header section on every page that includes an associated detail section or a group footer section. This setting prevents orphaned group footer sections.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RepeatStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~RepeatStyle


RichTextBox.FindOptions Enumeration

[image]
ActiveReports 13
RichTextBox.FindOptions Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox.FindOptions Enumeration

Glossary Item Box

Specifies how a text search is carried out in a RichTextBox control.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Syntax

Visual Basic (Declaration)
Public Enum RichTextBox.FindOptions
   Inherits System.Enum
C#
public enum RichTextBox.FindOptions : System.Enum

Members

Member | Description
MatchCase | Locate only instances of the search text that have the exact casing.
None | Locate all instances of the search text to determine whether the instances found in the search are whole words or not.
Reverse | Starts the search at the end of the control's document and searches to the beginning of the document.
WholeWord | Locate only instances of the search text that are whole words.

Remarks

An application locates text in the RichTextBox control by calling the Find method of the RichTextBox control. This enumeration enables you to specify how the search is performed when the Find method is called. You can combine one or more values from this enumeration to specify more than one search option when calling the Find method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextBox.FindOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Find(String,Int32,FindOptions)


RichTextBox.RichTextStreamType Enumeration

[image]
ActiveReports 13
RichTextBox.RichTextStreamType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox.RichTextStreamType Enumeration

Glossary Item Box

Determines the RichText control's content type.

Syntax

Visual Basic (Declaration)
Public Enum RichTextBox.RichTextStreamType
   Inherits System.Enum
C#
public enum RichTextBox.RichTextStreamType : System.Enum

Members

Member | Description
PlainText | The RichText control contains a plain text stream that includes spaces in place of Object Linking and Embedding (OLE) objects.
RichText | The RichText control contains a Rich Text Format (RTF) stream.
UnicodePlainText | The RichText control contains a text stream that contains spaces in place of Object Linking and Embedding (OLE) objects. The text is encoded in Unicode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextBox.RichTextStreamType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.RichTextBox


RichTextType Enumeration

[image]
ActiveReports 13
RichTextType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextType Enumeration

Glossary Item Box

Determines the type of stream to load into the RichTextBox.

Syntax

Visual Basic (Declaration)
Public Enum RichTextType
   Inherits System.Enum
C#
public enum RichTextType : System.Enum

Members

Member | Description
Html | Loads an html stream into the RichTextBox control.
Rtf | Loads an rtf stream into the RichTextBox control.
Text | Loads a plain text stream into the RichTextBox control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Load


ShapeType Enumeration

[image]
ActiveReports 13
ShapeType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ShapeType Enumeration

Glossary Item Box

Specifies the type of shape that the shape control should print.

Syntax

Visual Basic (Declaration)
Public Enum ShapeType
   Inherits System.Enum
C#
public enum ShapeType : System.Enum

Members

Member | Description
Ellipse | Print an elliptical shape.
Rectangle | Print a rectangular shape.
RoundRect | Print a rounded rectangular shape.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ShapeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Shape~Style


SizeModes Enumeration

[image]
ActiveReports 13
SizeModes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SizeModes Enumeration

Glossary Item Box

Determines how a picture should be sized within the control area.

Syntax

Visual Basic (Declaration)
Public Enum SizeModes
   Inherits System.Enum
C#
public enum SizeModes : System.Enum

Members

Member | Description
Clip | The image is clipped to fit within the control area.
Stretch | The image is stretched to fit the control area.
Zoom | The image is scaled until it fits horizontally and vertically within the control area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SizeModes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.OleObject~SizeMode
ActiveReports6~GrapeCity.ActiveReports.Picture~SizeMode
GrapeCity.ActiveReports~GrapeCity.ActiveReports.SectionReportModel~WatermarkSizeMode


SummaryFunc Enumeration

[image]
ActiveReports 13
SummaryFunc Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryFunc Enumeration

Glossary Item Box

Determines the summary calculation function performed on the field value.

Syntax

Visual Basic (Declaration)
Public Enum SummaryFunc
   Inherits System.Enum
C#
public enum SummaryFunc : System.Enum

Members

Member | Description
Avg | Calculates the average of all values within the specified summary region (group, page or report).
Count | Calculates the count of all values within the specified summary region (group, page or report).
DAvg | Calculates the average based on the distinct values of another field within the specified summary region (group, page or report).
DCount | Calculates the distinct count based on the distinct values of another field within the specified summary region (group, page or report).
DStdDev | Calculates the standard deviation based on the distinct values of another field within the specified summary region (group, page or report).
DStdDevP | Calculates the population standard deviation based on the distinct values of another field within the specified summary region (group, page or report).
DSum | Calculates the total based on the distinct values of another field within the specified summary region (group, page or report).
DVar | Calculates the variance based on the distinct values of another field within the specified summary region (group, page or report).
DVarP | Calculates the population distinct variance based on the distinct values of another field within the specified summary region (group, page or report).
Max | Calculates the maximum of all values within the specified summary region (group, page or report).
Min | Calculates the minimum of all values within the specified summary region (group, page or report).
StdDev | Calculates the standard deviation of all values within the specified summary region (group, page or report).
StdDevP | Calculates the population standard deviation of all values within the specified summary region (group, page or report).
Sum | Calculates the total of all values within the specified summary region (group, page or report).
Var | Calculates the variance of all values within the specified summary region (group, page or report).
VarP | Calculates the population variance of all values within the specified summary region (group, page or report).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryFunc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc


SummaryRunning Enumeration

[image]
ActiveReports 13
SummaryRunning Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryRunning Enumeration

Glossary Item Box

Determines whether summary values will be accumulated or reset based on the specified level.

Syntax

Visual Basic (Declaration)
Public Enum SummaryRunning
   Inherits System.Enum
C#
public enum SummaryRunning : System.Enum

Members

Member | Description
All | Calculates a running summary for all values.
Group | Calculates a running summary (each value is the sum of the current value and all preceding values) within the same group level.
None | Summary values are not accumulated.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryRunning

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning


SummaryType Enumeration

[image]
ActiveReports 13
SummaryType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryType Enumeration

Glossary Item Box

Determines the type of field summary.

Syntax

Visual Basic (Declaration)
Public Enum SummaryType
   Inherits System.Enum
C#
public enum SummaryType : System.Enum

Members

Member | Description
GrandTotal | Evaluate the specified summary function for all records in the report.
None | No summarization.
PageCount | Print the page count or page number. Use with SummaryRunning set to All to print the page number.
PageTotal | Evaluate the specified summary function for all records on each page.
SubTotal | Evaluate the specified summary function for all records in each group level.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


GrapeCity.BI.Data.DataProviders Namespace

GrapeCity.BI.Data.DataProviders Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.BI.Data.DataProviders Namespace

Glossary Item Box

The GrapeCity.BI.Data.DataProviders namespace contains the DataProviderInfo class.

Classes

 | Class | Description
Class | MssqlSchemaProvider |

Structures

 | Structure | Description
Structure | DataProviderInfo | Specifies the information about a configured data provider.

See Also

Reference

GrapeCity.ActiveReports Assembly


MssqlSchemaProvider Class

[image]
ActiveReports 13
MssqlSchemaProvider Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace : MssqlSchemaProvider Class

Glossary Item Box

Object Model

MssqlSchemaProvider Class

Syntax

Visual Basic (Declaration)
Public Class MssqlSchemaProvider
   Implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider
C#
public class MssqlSchemaProvider : GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider

Inheritance Hierarchy

System.Object
GrapeCity.BI.Data.DataProviders.MssqlSchemaProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MssqlSchemaProvider Members
GrapeCity.BI.Data.DataProviders Namespace


MssqlSchemaProvider Class Members

[image]
ActiveReports 13
MssqlSchemaProvider Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace : MssqlSchemaProvider Class

Glossary Item Box

The following tables list the members exposed by MssqlSchemaProvider.

Public Constructors

 | Name | Description
Public Constructor | MssqlSchemaProvider Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSchema |
Top

See Also

Reference

MssqlSchemaProvider Class
GrapeCity.BI.Data.DataProviders Namespace


MssqlSchemaProvider Constructor

[image]
ActiveReports 13
MssqlSchemaProvider Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > MssqlSchemaProvider Class : MssqlSchemaProvider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public MssqlSchemaProvider()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MssqlSchemaProvider Class
MssqlSchemaProvider Members


MssqlSchemaProvider Class Methods

[image]
ActiveReports 13
MssqlSchemaProvider Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace : MssqlSchemaProvider Class

Glossary Item Box

For a list of all members of this type, see MssqlSchemaProvider members.

Public Methods

 | Name | Description
Public Method | GetSchema |
Top

See Also

Reference

MssqlSchemaProvider Class
GrapeCity.BI.Data.DataProviders Namespace


GetSchema Method

[image]
ActiveReports 13
GetSchema Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > MssqlSchemaProvider Class : GetSchema Method

connection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSchema( _
   ByVal connection As DbConnection _
) As DataSchema
C#
public DataSchema GetSchema(
   DbConnection connection
)

Parameters

connection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MssqlSchemaProvider Class
MssqlSchemaProvider Members


DataProviderInfo Structure

[image]
ActiveReports 13
DataProviderInfo Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace : DataProviderInfo Structure

Glossary Item Box

Specifies the information about a configured data provider.

Object Model

DataProviderInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure DataProviderInfo
   Inherits System.ValueType
C#
public struct DataProviderInfo : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.BI.Data.DataProviders.DataProviderInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Members
GrapeCity.BI.Data.DataProviders Namespace


DataProviderInfo Structure Members

[image]
ActiveReports 13
DataProviderInfo Structure Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace : DataProviderInfo Structure

Glossary Item Box

The following tables list the members exposed by DataProviderInfo.

Public Properties

 | Name | Description
Public Property | AdapterAssemblyQualifiedName | Fully assembly-qualified name of the class that implements additional features like seting of multivalue parameters and others.
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements DataProviderFactory for this provider.
Public Property | HumanReadableName | A human-readable name for the data provider.
Public Property | InvariantName | The name that can be used to refer to the data provider in reports.
Public Property | QueryDesignerSupported | True if query designer supports this data provider
Public Property | SchemaProviderAssemblyQualifiedName | Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider.
Top

See Also

Reference

DataProviderInfo Structure
GrapeCity.BI.Data.DataProviders Namespace


DataProviderInfo Structure Properties

[image]
ActiveReports 13
DataProviderInfo Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace : DataProviderInfo Structure

Glossary Item Box

For a list of all members of this type, see DataProviderInfo members.

Public Properties

 | Name | Description
Public Property | AdapterAssemblyQualifiedName | Fully assembly-qualified name of the class that implements additional features like seting of multivalue parameters and others.
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements DataProviderFactory for this provider.
Public Property | HumanReadableName | A human-readable name for the data provider.
Public Property | InvariantName | The name that can be used to refer to the data provider in reports.
Public Property | QueryDesignerSupported | True if query designer supports this data provider
Public Property | SchemaProviderAssemblyQualifiedName | Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider.
Top

See Also

Reference

DataProviderInfo Structure
GrapeCity.BI.Data.DataProviders Namespace


AdapterAssemblyQualifiedName Property

[image]
ActiveReports 13
AdapterAssemblyQualifiedName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : AdapterAssemblyQualifiedName Property

Glossary Item Box

Fully assembly-qualified name of the class that implements additional features like seting of multivalue parameters and others.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdapterAssemblyQualifiedName As String
C#
public string AdapterAssemblyQualifiedName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


AssemblyQualifiedName Property

[image]
ActiveReports 13
AssemblyQualifiedName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : AssemblyQualifiedName Property

Glossary Item Box

Fully assembly-qualified name of the class that implements DataProviderFactory for this provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssemblyQualifiedName As String
C#
public string AssemblyQualifiedName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


HumanReadableName Property

[image]
ActiveReports 13
HumanReadableName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : HumanReadableName Property

Glossary Item Box

A human-readable name for the data provider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HumanReadableName As String
C#
public string HumanReadableName {get;}

Remarks

An empty human readable name will prevent it from being displayed in UI.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


InvariantName Property

[image]
ActiveReports 13
InvariantName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : InvariantName Property

Glossary Item Box

The name that can be used to refer to the data provider in reports.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvariantName As String
C#
public string InvariantName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


QueryDesignerSupported Property

[image]
ActiveReports 13
QueryDesignerSupported Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : QueryDesignerSupported Property

Glossary Item Box

True if query designer supports this data provider

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryDesignerSupported As Boolean
C#
public bool QueryDesignerSupported {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


SchemaProviderAssemblyQualifiedName Property

[image]
ActiveReports 13
SchemaProviderAssemblyQualifiedName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : SchemaProviderAssemblyQualifiedName Property

Glossary Item Box

Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.IDbSchemaProvider.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaProviderAssemblyQualifiedName As String
C#
public string SchemaProviderAssemblyQualifiedName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


GrapeCity.ActiveReports.Aspnet.Designer Namespace

GrapeCity.ActiveReports.Aspnet.Designer Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DesignerSettings | Defines middleware settings.
Class | ImageNotFoundException |
Class | InvalidReportContentException |
Class | InvalidThemeContentException |
Class | ReportNotFoundException |
Class | ThemeNotFoundException |
Class | WebHostBuilderExtensions | Contains methods for configuring of web host application.

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Designer Assembly


DesignerSettings Class

[image]
ActiveReports 13
DesignerSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : DesignerSettings Class

Glossary Item Box

Defines middleware settings.

Object Model

DesignerSettings Class

Syntax

Visual Basic (Declaration)
Public Class DesignerSettings
C#
public class DesignerSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.DesignerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


DesignerSettings Class Members

[image]
ActiveReports 13
DesignerSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : DesignerSettings Class

Glossary Item Box

The following tables list the members exposed by DesignerSettings.

Public Constructors

 | Name | Description
Public Constructor | DesignerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Prefix |
Top

Public Methods

 | Name | Description
Public Method | UseCustomStore |
Public Method | UseFileStore | Use directory as the resources source.
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


DesignerSettings Constructor

[image]
ActiveReports 13
DesignerSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > DesignerSettings Class : DesignerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DesignerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DesignerSettings Class Methods

[image]
ActiveReports 13
DesignerSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : DesignerSettings Class

Glossary Item Box

For a list of all members of this type, see DesignerSettings members.

Public Methods

 | Name | Description
Public Method | UseCustomStore |
Public Method | UseFileStore | Use directory as the resources source.
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


UseCustomStore Method

[image]
ActiveReports 13
UseCustomStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > DesignerSettings Class : UseCustomStore Method

resourcesService

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub UseCustomStore( _
   ByVal resourcesService As IResourcesService _
)
C#
public void UseCustomStore(
   IResourcesService resourcesService
)

Parameters

resourcesService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


UseFileStore Method

[image]
ActiveReports 13
UseFileStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > DesignerSettings Class : UseFileStore Method

rootPath
useTopDirectoryOnly

Glossary Item Box

Use directory as the resources source.

Syntax

Visual Basic (Declaration)
Public Sub UseFileStore( _
   ByVal rootPath As DirectoryInfo, _
   Optional ByVal useTopDirectoryOnly As Boolean _
)
C#
public void UseFileStore(
   DirectoryInfo rootPath,
   bool useTopDirectoryOnly
)

Parameters

rootPath
useTopDirectoryOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DesignerSettings Class Properties

[image]
ActiveReports 13
DesignerSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : DesignerSettings Class

Glossary Item Box

For a list of all members of this type, see DesignerSettings members.

Public Properties

 | Name | Description
Public Property | Prefix |
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


Prefix Property

[image]
ActiveReports 13
Prefix Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > DesignerSettings Class : Prefix Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


ImageNotFoundException Class

[image]
ActiveReports 13
ImageNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

Object Model

ImageNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ImageNotFoundException
   Inherits System.Exception
C#
public class ImageNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnet.Designer.ImageNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ImageNotFoundException Class Members

[image]
ActiveReports 13
ImageNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ImageNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ImageNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ImageNotFoundException Constructor

[image]
ActiveReports 13
ImageNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : ImageNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InvalidReportContentException Class

[image]
ActiveReports 13
InvalidReportContentException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

Object Model

InvalidReportContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidReportContentException
   Inherits System.Exception
C#
public class InvalidReportContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnet.Designer.InvalidReportContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


InvalidReportContentException Class Members

[image]
ActiveReports 13
InvalidReportContentException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidReportContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidReportContentException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


InvalidReportContentException Constructor

[image]
ActiveReports 13
InvalidReportContentException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : InvalidReportContentException Constructor

message

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidReportContentException(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class

[image]
ActiveReports 13
InvalidThemeContentException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

Object Model

InvalidThemeContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidThemeContentException
   Inherits System.Exception
C#
public class InvalidThemeContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnet.Designer.InvalidThemeContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


InvalidThemeContentException Class Members

[image]
ActiveReports 13
InvalidThemeContentException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidThemeContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidThemeContentException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


InvalidThemeContentException Constructor

[image]
ActiveReports 13
InvalidThemeContentException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : InvalidThemeContentException Constructor

message

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidThemeContentException(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ReportNotFoundException Class

[image]
ActiveReports 13
ReportNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

Object Model

ReportNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ReportNotFoundException
   Inherits System.Exception
C#
public class ReportNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnet.Designer.ReportNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ReportNotFoundException Class Members

[image]
ActiveReports 13
ReportNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ReportNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ReportNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ReportNotFoundException Constructor

[image]
ActiveReports 13
ReportNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : ReportNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ThemeNotFoundException Class

[image]
ActiveReports 13
ThemeNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

Object Model

ThemeNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ThemeNotFoundException
   Inherits System.Exception
C#
public class ThemeNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnet.Designer.ThemeNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ThemeNotFoundException Class Members

[image]
ActiveReports 13
ThemeNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ThemeNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ThemeNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ThemeNotFoundException Constructor

[image]
ActiveReports 13
ThemeNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : ThemeNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


WebHostBuilderExtensions Class

[image]
ActiveReports 13
WebHostBuilderExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

Contains methods for configuring of web host application.

Object Model

WebHostBuilderExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class WebHostBuilderExtensions
C#
public static class WebHostBuilderExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.WebHostBuilderExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Members
GrapeCity.ActiveReports.Aspnet.Designer Namespace


WebHostBuilderExtensions Class Members

[image]
ActiveReports 13
WebHostBuilderExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

The following tables list the members exposed by WebHostBuilderExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseDesigner | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


WebHostBuilderExtensions Class Methods

[image]
ActiveReports 13
WebHostBuilderExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

For a list of all members of this type, see WebHostBuilderExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseDesigner | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


UseDesigner Method

[image]
ActiveReports 13
UseDesigner Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > WebHostBuilderExtensions Class : UseDesigner Method

builder
configure

Glossary Item Box

Configures middleware for ActiveReports API and handlers.

Syntax

Visual Basic (Declaration)
Public Shared Function UseDesigner( _
   ByVal builder As Owin.IAppBuilder, _
   Optional ByVal configure As Action(Of DesignerSettings) _
) As Owin.IAppBuilder
C#
public static Owin.IAppBuilder UseDesigner(
   Owin.IAppBuilder builder,
   Action<DesignerSettings> configure
)

Parameters

builder
configure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Class
WebHostBuilderExtensions Members


GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace

GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Theme |
Class | ThemeColors |
Class | ThemeConstant |
Class | ThemeFont |
Class | ThemeFonts |
Class | ThemeImage |

Interfaces

 | Interface | Description
Interface | IImageInfo | Defines the minimum required image info
Interface | IReportInfo | Defines the minimum required report info
Interface | IResourcesService | Allows to load resources (reports, themes, images) from custom storage.
Interface | IThemeInfo | Defines the minimum required theme info

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Designer Assembly


Theme Class

[image]
ActiveReports 13
Theme Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : Theme Class

Glossary Item Box

Object Model

Theme Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Theme
C#
public sealed class Theme

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Services.Theme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Theme Class Members

[image]
ActiveReports 13
Theme Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : Theme Class

Glossary Item Box

The following tables list the members exposed by Theme.

Public Constructors

 | Name | Description
Public Constructor | Theme Constructor |
Top

Public Properties

 | Name | Description
Public Property | Colors |
Public Property | Constants |
Public Property | Fonts |
Public Property | Images |
Top

See Also

Reference

Theme Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Theme Constructor

[image]
ActiveReports 13
Theme Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > Theme Class : Theme Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Theme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Theme Class Properties

[image]
ActiveReports 13
Theme Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : Theme Class

Glossary Item Box

For a list of all members of this type, see Theme members.

Public Properties

 | Name | Description
Public Property | Colors |
Public Property | Constants |
Public Property | Fonts |
Public Property | Images |
Top

See Also

Reference

Theme Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Colors Property

[image]
ActiveReports 13
Colors Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > Theme Class : Colors Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Colors As ThemeColors
C#
public ThemeColors Colors {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Constants Property

[image]
ActiveReports 13
Constants Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > Theme Class : Constants Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Constants As ThemeConstant()
C#
public ThemeConstant[] Constants {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Fonts Property

[image]
ActiveReports 13
Fonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > Theme Class : Fonts Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Fonts As ThemeFonts
C#
public ThemeFonts Fonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Images Property

[image]
ActiveReports 13
Images Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > Theme Class : Images Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Images As ThemeImage()
C#
public ThemeImage[] Images {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


ThemeColors Class

[image]
ActiveReports 13
ThemeColors Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeColors Class

Glossary Item Box

Object Model

ThemeColors Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeColors
C#
public sealed class ThemeColors

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeColors

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeColors Class Members

[image]
ActiveReports 13
ThemeColors Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeColors Class

Glossary Item Box

The following tables list the members exposed by ThemeColors.

Public Constructors

 | Name | Description
Public Constructor | ThemeColors Constructor |
Top

Public Properties

 | Name | Description
Public Property | Accent1 |
Public Property | Accent2 |
Public Property | Accent3 |
Public Property | Accent4 |
Public Property | Accent5 |
Public Property | Accent6 |
Public Property | Dark1 |
Public Property | Dark2 |
Public Property | Hyperlink |
Public Property | HyperlinkFollowed |
Public Property | Light1 |
Public Property | Light2 |
Top

See Also

Reference

ThemeColors Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeColors Constructor

[image]
ActiveReports 13
ThemeColors Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : ThemeColors Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeColors()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


ThemeColors Class Properties

[image]
ActiveReports 13
ThemeColors Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeColors Class

Glossary Item Box

For a list of all members of this type, see ThemeColors members.

Public Properties

 | Name | Description
Public Property | Accent1 |
Public Property | Accent2 |
Public Property | Accent3 |
Public Property | Accent4 |
Public Property | Accent5 |
Public Property | Accent6 |
Public Property | Dark1 |
Public Property | Dark2 |
Public Property | Hyperlink |
Public Property | HyperlinkFollowed |
Public Property | Light1 |
Public Property | Light2 |
Top

See Also

Reference

ThemeColors Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Accent1 Property

[image]
ActiveReports 13
Accent1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Accent1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent1 As String
C#
public string Accent1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent2 Property

[image]
ActiveReports 13
Accent2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Accent2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent2 As String
C#
public string Accent2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent3 Property

[image]
ActiveReports 13
Accent3 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Accent3 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent3 As String
C#
public string Accent3 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent4 Property

[image]
ActiveReports 13
Accent4 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Accent4 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent4 As String
C#
public string Accent4 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent5 Property

[image]
ActiveReports 13
Accent5 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Accent5 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent5 As String
C#
public string Accent5 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent6 Property

[image]
ActiveReports 13
Accent6 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Accent6 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent6 As String
C#
public string Accent6 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Dark1 Property

[image]
ActiveReports 13
Dark1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Dark1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dark1 As String
C#
public string Dark1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Dark2 Property

[image]
ActiveReports 13
Dark2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Dark2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dark2 As String
C#
public string Dark2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Hyperlink Property

[image]
ActiveReports 13
Hyperlink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Hyperlink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Hyperlink As String
C#
public string Hyperlink {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


HyperlinkFollowed Property

[image]
ActiveReports 13
HyperlinkFollowed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : HyperlinkFollowed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HyperlinkFollowed As String
C#
public string HyperlinkFollowed {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Light1 Property

[image]
ActiveReports 13
Light1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Light1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Light1 As String
C#
public string Light1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Light2 Property

[image]
ActiveReports 13
Light2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeColors Class : Light2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Light2 As String
C#
public string Light2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


ThemeConstant Class

[image]
ActiveReports 13
ThemeConstant Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeConstant Class

Glossary Item Box

Object Model

ThemeConstant Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeConstant
C#
public sealed class ThemeConstant

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeConstant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeConstant Class Members

[image]
ActiveReports 13
ThemeConstant Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeConstant Class

Glossary Item Box

The following tables list the members exposed by ThemeConstant.

Public Constructors

 | Name | Description
Public Constructor | ThemeConstant Constructor |
Top

Public Properties

 | Name | Description
Public Property | Key |
Public Property | Value |
Top

See Also

Reference

ThemeConstant Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeConstant Constructor

[image]
ActiveReports 13
ThemeConstant Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeConstant Class : ThemeConstant Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeConstant()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


ThemeConstant Class Properties

[image]
ActiveReports 13
ThemeConstant Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeConstant Class

Glossary Item Box

For a list of all members of this type, see ThemeConstant members.

Public Properties

 | Name | Description
Public Property | Key |
Public Property | Value |
Top

See Also

Reference

ThemeConstant Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Key Property

[image]
ActiveReports 13
Key Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeConstant Class : Key Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


Value Property

[image]
ActiveReports 13
Value Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeConstant Class : Value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


ThemeFont Class

[image]
ActiveReports 13
ThemeFont Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeFont Class

Glossary Item Box

Object Model

ThemeFont Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeFont
C#
public sealed class ThemeFont

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeFont Class Members

[image]
ActiveReports 13
ThemeFont Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeFont Class

Glossary Item Box

The following tables list the members exposed by ThemeFont.

Public Constructors

 | Name | Description
Public Constructor | ThemeFont Constructor |
Top

Public Properties

 | Name | Description
Public Property | Family |
Public Property | Size |
Public Property | Style |
Public Property | Weight |
Top

See Also

Reference

ThemeFont Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeFont Constructor

[image]
ActiveReports 13
ThemeFont Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFont Class : ThemeFont Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeFont()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


ThemeFont Class Properties

[image]
ActiveReports 13
ThemeFont Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeFont Class

Glossary Item Box

For a list of all members of this type, see ThemeFont members.

Public Properties

 | Name | Description
Public Property | Family |
Public Property | Size |
Public Property | Style |
Public Property | Weight |
Top

See Also

Reference

ThemeFont Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Family Property

[image]
ActiveReports 13
Family Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFont Class : Family Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Family As String
C#
public string Family {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFont Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Size As String
C#
public string Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


Style Property

[image]
ActiveReports 13
Style Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFont Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


Weight Property

[image]
ActiveReports 13
Weight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFont Class : Weight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Weight As String
C#
public string Weight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


ThemeFonts Class

[image]
ActiveReports 13
ThemeFonts Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeFonts Class

Glossary Item Box

Object Model

ThemeFonts Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeFonts
C#
public sealed class ThemeFonts

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeFonts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeFonts Class Members

[image]
ActiveReports 13
ThemeFonts Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeFonts Class

Glossary Item Box

The following tables list the members exposed by ThemeFonts.

Public Constructors

 | Name | Description
Public Constructor | ThemeFonts Constructor |
Top

Public Properties

 | Name | Description
Public Property | MajorFont |
Public Property | MinorFont |
Top

See Also

Reference

ThemeFonts Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeFonts Constructor

[image]
ActiveReports 13
ThemeFonts Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFonts Class : ThemeFonts Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeFonts()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Class
ThemeFonts Members


ThemeFonts Class Properties

[image]
ActiveReports 13
ThemeFonts Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeFonts Class

Glossary Item Box

For a list of all members of this type, see ThemeFonts members.

Public Properties

 | Name | Description
Public Property | MajorFont |
Public Property | MinorFont |
Top

See Also

Reference

ThemeFonts Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


MajorFont Property

[image]
ActiveReports 13
MajorFont Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFonts Class : MajorFont Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MajorFont As ThemeFont
C#
public ThemeFont MajorFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Class
ThemeFonts Members


MinorFont Property

[image]
ActiveReports 13
MinorFont Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeFonts Class : MinorFont Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MinorFont As ThemeFont
C#
public ThemeFont MinorFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Class
ThemeFonts Members


ThemeImage Class

[image]
ActiveReports 13
ThemeImage Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeImage Class

Glossary Item Box

Object Model

ThemeImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeImage
C#
public sealed class ThemeImage

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeImage Class Members

[image]
ActiveReports 13
ThemeImage Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeImage Class

Glossary Item Box

The following tables list the members exposed by ThemeImage.

Public Constructors

 | Name | Description
Public Constructor | ThemeImage Constructor |
Top

Public Properties

 | Name | Description
Public Property | ImageData |
Public Property | MIMEType |
Public Property | Name |
Top

See Also

Reference

ThemeImage Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ThemeImage Constructor

[image]
ActiveReports 13
ThemeImage Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeImage Class : ThemeImage Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


ThemeImage Class Properties

[image]
ActiveReports 13
ThemeImage Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : ThemeImage Class

Glossary Item Box

For a list of all members of this type, see ThemeImage members.

Public Properties

 | Name | Description
Public Property | ImageData |
Public Property | MIMEType |
Public Property | Name |
Top

See Also

Reference

ThemeImage Class
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ImageData Property

[image]
ActiveReports 13
ImageData Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeImage Class : ImageData Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImageData As String
C#
public string ImageData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


MIMEType Property

[image]
ActiveReports 13
MIMEType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeImage Class : MIMEType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MIMEType As String
C#
public string MIMEType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > ThemeImage Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


IImageInfo Interface

[image]
ActiveReports 13
IImageInfo Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IImageInfo Interface

Glossary Item Box

Defines the minimum required image info

Syntax

Visual Basic (Declaration)
Public Interface IImageInfo
C#
public interface IImageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IImageInfo Interface Members

[image]
ActiveReports 13
IImageInfo Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IImageInfo Interface

Glossary Item Box

The following tables list the members exposed by IImageInfo.

Public Properties

 | Name | Description
Property | ContentType | Image content type
Property | Id | Image id
Property | Name | Image name
Property | Thumbnail | Image thumbnail
Top

See Also

Reference

IImageInfo Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IImageInfo Interface Properties

[image]
ActiveReports 13
IImageInfo Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IImageInfo Interface

Glossary Item Box

For a list of all members of this type, see IImageInfo members.

Public Properties

 | Name | Description
Property | ContentType | Image content type
Property | Id | Image id
Property | Name | Image name
Property | Thumbnail | Image thumbnail
Top

See Also

Reference

IImageInfo Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


ContentType Property

[image]
ActiveReports 13
ContentType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IImageInfo Interface : ContentType Property

Glossary Item Box

Image content type

Syntax

Visual Basic (Declaration)
Property ContentType As String
C#
string ContentType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


Id Property

[image]
ActiveReports 13
Id Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IImageInfo Interface : Id Property

Glossary Item Box

Image id

Syntax

Visual Basic (Declaration)
Property Id As String
C#
string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IImageInfo Interface : Name Property

Glossary Item Box

Image name

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


Thumbnail Property

[image]
ActiveReports 13
Thumbnail Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IImageInfo Interface : Thumbnail Property

Glossary Item Box

Image thumbnail

Syntax

Visual Basic (Declaration)
Property Thumbnail As Byte()
C#
byte[] Thumbnail {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


IReportInfo Interface

[image]
ActiveReports 13
IReportInfo Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IReportInfo Interface

Glossary Item Box

Defines the minimum required report info

Syntax

Visual Basic (Declaration)
Public Interface IReportInfo
C#
public interface IReportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IReportInfo Interface Members

[image]
ActiveReports 13
IReportInfo Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IReportInfo Interface

Glossary Item Box

The following tables list the members exposed by IReportInfo.

Public Properties

 | Name | Description
Property | Id | Report id
Property | Name | Report name
Property | Type | Report type
Top

See Also

Reference

IReportInfo Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IReportInfo Interface Properties

[image]
ActiveReports 13
IReportInfo Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IReportInfo Interface

Glossary Item Box

For a list of all members of this type, see IReportInfo members.

Public Properties

 | Name | Description
Property | Id | Report id
Property | Name | Report name
Property | Type | Report type
Top

See Also

Reference

IReportInfo Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Id Property

[image]
ActiveReports 13
Id Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IReportInfo Interface : Id Property

Glossary Item Box

Report id

Syntax

Visual Basic (Declaration)
Property Id As String
C#
string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Interface
IReportInfo Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IReportInfo Interface : Name Property

Glossary Item Box

Report name

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Interface
IReportInfo Members


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IReportInfo Interface : Type Property

Glossary Item Box

Report type

Syntax

Visual Basic (Declaration)
Property Type As String
C#
string Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Interface
IReportInfo Members


IResourcesService Interface

[image]
ActiveReports 13
IResourcesService Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IResourcesService Interface

Glossary Item Box

Allows to load resources (reports, themes, images) from custom storage.

Syntax

Visual Basic (Declaration)
Public Interface IResourcesService
C#
public interface IResourcesService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IResourcesService Interface Members

[image]
ActiveReports 13
IResourcesService Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IResourcesService Interface

Glossary Item Box

The following tables list the members exposed by IResourcesService.

Public Methods

 | Name | Description
Method | DeleteReport | Delete report
Method | GetImage | Get image content by id
Method | GetImagesList | Get images list
Method | GetReport | Get report content by id
Method | GetReportsList | Get reports list
Method | GetTheme | Get theme content by id
Method | GetThemesList | Get themes list
Method | SaveReport | Save report
Method | UpdateReport | Update report
Top

See Also

Reference

IResourcesService Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IResourcesService Interface Methods

[image]
ActiveReports 13
IResourcesService Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IResourcesService Interface

Glossary Item Box

For a list of all members of this type, see IResourcesService members.

Public Methods

 | Name | Description
Method | DeleteReport | Delete report
Method | GetImage | Get image content by id
Method | GetImagesList | Get images list
Method | GetReport | Get report content by id
Method | GetReportsList | Get reports list
Method | GetTheme | Get theme content by id
Method | GetThemesList | Get themes list
Method | SaveReport | Save report
Method | UpdateReport | Update report
Top

See Also

Reference

IResourcesService Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


DeleteReport Method

[image]
ActiveReports 13
DeleteReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : DeleteReport Method

id
Report id

Glossary Item Box

Delete report

Syntax

Visual Basic (Declaration)
Sub DeleteReport( _
   ByVal id As String _
)
C#
void DeleteReport(
   string id
)

Parameters

id
Report id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetImage Method

[image]
ActiveReports 13
GetImage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : GetImage Method

id
Image id
mimeType
Image MIME type

Glossary Item Box

Get image content by id

Syntax

Visual Basic (Declaration)
Function GetImage( _
   ByVal id As String, _
   ByRef mimeType As String _
) As Byte()
C#
byte[] GetImage(
   string id,
   out string mimeType
)

Parameters

id
Image id
mimeType
Image MIME type

Return Value

Image content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetImagesList Method

[image]
ActiveReports 13
GetImagesList Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : GetImagesList Method

Glossary Item Box

Get images list

Syntax

Visual Basic (Declaration)
Function GetImagesList() As IImageInfo()
C#
IImageInfo[] GetImagesList()

Return Value

Images list

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetReport Method

[image]
ActiveReports 13
GetReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : GetReport Method

id
Report id

Glossary Item Box

Get report content by id

Syntax

Visual Basic (Declaration)
Function GetReport( _
   ByVal id As String _
) As GrapeCity.ActiveReports.PageReportModel.Report
C#
GrapeCity.ActiveReports.PageReportModel.Report GetReport(
   string id
)

Parameters

id
Report id

Return Value

Report content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetReportsList Method

[image]
ActiveReports 13
GetReportsList Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : GetReportsList Method

Glossary Item Box

Get reports list

Syntax

Visual Basic (Declaration)
Function GetReportsList() As IReportInfo()
C#
IReportInfo[] GetReportsList()

Return Value

Reports list

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetTheme Method

[image]
ActiveReports 13
GetTheme Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : GetTheme Method

id
Theme id

Glossary Item Box

Get theme content by id

Syntax

Visual Basic (Declaration)
Function GetTheme( _
   ByVal id As String _
) As Theme
C#
Theme GetTheme(
   string id
)

Parameters

id
Theme id

Return Value

Theme content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetThemesList Method

[image]
ActiveReports 13
GetThemesList Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : GetThemesList Method

Glossary Item Box

Get themes list

Syntax

Visual Basic (Declaration)
Function GetThemesList() As IThemeInfo()
C#
IThemeInfo[] GetThemesList()

Return Value

Themes list

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


SaveReport Method

[image]
ActiveReports 13
SaveReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : SaveReport Method

name
Report name
report
isTemporary
Save report as temporary report

Glossary Item Box

Save report

Syntax

Visual Basic (Declaration)
Function SaveReport( _
   ByVal name As String, _
   ByVal report As GrapeCity.ActiveReports.PageReportModel.Report, _
   Optional ByVal isTemporary As Boolean _
) As String
C#
string SaveReport(
   string name,
   GrapeCity.ActiveReports.PageReportModel.Report report,
   bool isTemporary
)

Parameters

name
Report name
report
isTemporary
Save report as temporary report

Return Value

Report id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


UpdateReport Method

[image]
ActiveReports 13
UpdateReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IResourcesService Interface : UpdateReport Method

id
Report id
report

Glossary Item Box

Update report

Syntax

Visual Basic (Declaration)
Function UpdateReport( _
   ByVal id As String, _
   ByVal report As GrapeCity.ActiveReports.PageReportModel.Report _
) As String
C#
string UpdateReport(
   string id,
   GrapeCity.ActiveReports.PageReportModel.Report report
)

Parameters

id
Report id
report

Return Value

Report id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


IThemeInfo Interface

[image]
ActiveReports 13
IThemeInfo Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IThemeInfo Interface

Glossary Item Box

Defines the minimum required theme info

Syntax

Visual Basic (Declaration)
Public Interface IThemeInfo
C#
public interface IThemeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Members
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IThemeInfo Interface Members

[image]
ActiveReports 13
IThemeInfo Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IThemeInfo Interface

Glossary Item Box

The following tables list the members exposed by IThemeInfo.

Public Properties

 | Name | Description
Property | Accent1 | Colors/Accent1 value
Property | Accent2 | Colors/Accent2 value
Property | Accent3 | Colors/Accent3 value
Property | Accent4 | Colors/Accent4 value
Property | Accent5 | Colors/Accent5 value
Property | Accent6 | Colors/Accent6 value
Property | Dark1 | Colors/Dark1 value
Property | Dark2 | Colors/Dark2 value
Property | Id | Theme id
Property | Light1 | Colors/Light1 value
Property | Light2 | Colors/Light2 value
Property | MajorFontFamily | Fonts/MajorFont/Family value
Property | MinorFontFamily | Fonts/MinorFont/Family value
Property | Title | Theme title
Top

See Also

Reference

IThemeInfo Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


IThemeInfo Interface Properties

[image]
ActiveReports 13
IThemeInfo Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace : IThemeInfo Interface

Glossary Item Box

For a list of all members of this type, see IThemeInfo members.

Public Properties

 | Name | Description
Property | Accent1 | Colors/Accent1 value
Property | Accent2 | Colors/Accent2 value
Property | Accent3 | Colors/Accent3 value
Property | Accent4 | Colors/Accent4 value
Property | Accent5 | Colors/Accent5 value
Property | Accent6 | Colors/Accent6 value
Property | Dark1 | Colors/Dark1 value
Property | Dark2 | Colors/Dark2 value
Property | Id | Theme id
Property | Light1 | Colors/Light1 value
Property | Light2 | Colors/Light2 value
Property | MajorFontFamily | Fonts/MajorFont/Family value
Property | MinorFontFamily | Fonts/MinorFont/Family value
Property | Title | Theme title
Top

See Also

Reference

IThemeInfo Interface
GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace


Accent1 Property

[image]
ActiveReports 13
Accent1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Accent1 Property

Glossary Item Box

Colors/Accent1 value

Syntax

Visual Basic (Declaration)
Property Accent1 As String
C#
string Accent1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent2 Property

[image]
ActiveReports 13
Accent2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Accent2 Property

Glossary Item Box

Colors/Accent2 value

Syntax

Visual Basic (Declaration)
Property Accent2 As String
C#
string Accent2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent3 Property

[image]
ActiveReports 13
Accent3 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Accent3 Property

Glossary Item Box

Colors/Accent3 value

Syntax

Visual Basic (Declaration)
Property Accent3 As String
C#
string Accent3 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent4 Property

[image]
ActiveReports 13
Accent4 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Accent4 Property

Glossary Item Box

Colors/Accent4 value

Syntax

Visual Basic (Declaration)
Property Accent4 As String
C#
string Accent4 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent5 Property

[image]
ActiveReports 13
Accent5 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Accent5 Property

Glossary Item Box

Colors/Accent5 value

Syntax

Visual Basic (Declaration)
Property Accent5 As String
C#
string Accent5 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent6 Property

[image]
ActiveReports 13
Accent6 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Accent6 Property

Glossary Item Box

Colors/Accent6 value

Syntax

Visual Basic (Declaration)
Property Accent6 As String
C#
string Accent6 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Dark1 Property

[image]
ActiveReports 13
Dark1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Dark1 Property

Glossary Item Box

Colors/Dark1 value

Syntax

Visual Basic (Declaration)
Property Dark1 As String
C#
string Dark1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Dark2 Property

[image]
ActiveReports 13
Dark2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Dark2 Property

Glossary Item Box

Colors/Dark2 value

Syntax

Visual Basic (Declaration)
Property Dark2 As String
C#
string Dark2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Id Property

[image]
ActiveReports 13
Id Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Id Property

Glossary Item Box

Theme id

Syntax

Visual Basic (Declaration)
Property Id As String
C#
string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Light1 Property

[image]
ActiveReports 13
Light1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Light1 Property

Glossary Item Box

Colors/Light1 value

Syntax

Visual Basic (Declaration)
Property Light1 As String
C#
string Light1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Light2 Property

[image]
ActiveReports 13
Light2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Light2 Property

Glossary Item Box

Colors/Light2 value

Syntax

Visual Basic (Declaration)
Property Light2 As String
C#
string Light2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


MajorFontFamily Property

[image]
ActiveReports 13
MajorFontFamily Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : MajorFontFamily Property

Glossary Item Box

Fonts/MajorFont/Family value

Syntax

Visual Basic (Declaration)
Property MajorFontFamily As String
C#
string MajorFontFamily {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


MinorFontFamily Property

[image]
ActiveReports 13
MinorFontFamily Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : MinorFontFamily Property

Glossary Item Box

Fonts/MinorFont/Family value

Syntax

Visual Basic (Declaration)
Property MinorFontFamily As String
C#
string MinorFontFamily {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace > IThemeInfo Interface : Title Property

Glossary Item Box

Theme title

Syntax

Visual Basic (Declaration)
Property Title As String
C#
string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace

GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet.Viewer Namespace

GrapeCity.ActiveReports.Aspnet.Viewer Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnet.Viewer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | WebHostBuilderExtensions | Contains methods for configuring of web host application.

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Viewer Assembly


WebHostBuilderExtensions Class

[image]
ActiveReports 13
WebHostBuilderExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

Contains methods for configuring of web host application.

Object Model

WebHostBuilderExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class WebHostBuilderExtensions
C#
public static class WebHostBuilderExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Viewer.WebHostBuilderExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Members
GrapeCity.ActiveReports.Aspnet.Viewer Namespace


WebHostBuilderExtensions Class Members

[image]
ActiveReports 13
WebHostBuilderExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

The following tables list the members exposed by WebHostBuilderExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseReporting | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnet.Viewer Namespace


WebHostBuilderExtensions Class Methods

[image]
ActiveReports 13
WebHostBuilderExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

For a list of all members of this type, see WebHostBuilderExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | UseReporting | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnet.Viewer Namespace


UseReporting Method

[image]
ActiveReports 13
UseReporting Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnet.Viewer Namespace > WebHostBuilderExtensions Class : UseReporting Method

builder
configure

Glossary Item Box

Configures middleware for ActiveReports API and handlers.

Syntax

Visual Basic (Declaration)
Public Shared Function UseReporting( _
   ByVal builder As Owin.IAppBuilder, _
   Optional ByVal configure As Action(Of ReportingSettings) _
) As Owin.IAppBuilder
C#
public static Owin.IAppBuilder UseReporting(
   Owin.IAppBuilder builder,
   Action<ReportingSettings> configure
)

Parameters

builder
configure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Class
WebHostBuilderExtensions Members


GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnet.Viewer)

GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnet.Viewer)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ReportingSettings | Defines reporting middleware settings.
Class | ReportNotFoundException | Occurs when IReportService can't find the report with the specified identifier.

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Viewer Assembly


ReportingSettings Class

[image]
ActiveReports 13
ReportingSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

Defines reporting middleware settings.

Object Model

ReportingSettings Class

Syntax

Visual Basic (Declaration)
Public Class ReportingSettings
C#
public class ReportingSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportingSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Members
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportingSettings Class Members

[image]
ActiveReports 13
ReportingSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

The following tables list the members exposed by ReportingSettings.

Public Constructors

 | Name | Description
Public Constructor | ReportingSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | LocateDataSource | Sets or gets data source locator handler.
Public Property | Prefix | Web API endpoint prefix.
Public Property | ResolveCredentials | Sets or gets credentials resolving handler.
Public Property | UseCompression | Tells ActiveReports to compress temporary data before storing to memory/disk.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault |
Public Method | StoreTemporaryFilesInMemory | Instructs ActiveReports to store temporary data to a memory.
Public Method | StoreTemporaryFilesOnDisk | Instructs ActiveReports to store temporary files to a disk to reduce memory consumption.
Public Method | UseCustomStore | Use custom report templates store.
Public Method | UseEmbeddedTemplates | Use embedded resources to locate the report templates.
Public Method | UseFileStore | Use directory as a source of report templates.
Top

See Also

Reference

ReportingSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportingSettings Constructor

[image]
ActiveReports 13
ReportingSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : ReportingSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportingSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ReportingSettings Class Methods

[image]
ActiveReports 13
ReportingSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

For a list of all members of this type, see ReportingSettings members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault |
Public Method | StoreTemporaryFilesInMemory | Instructs ActiveReports to store temporary data to a memory.
Public Method | StoreTemporaryFilesOnDisk | Instructs ActiveReports to store temporary files to a disk to reduce memory consumption.
Public Method | UseCustomStore | Use custom report templates store.
Public Method | UseEmbeddedTemplates | Use embedded resources to locate the report templates.
Public Method | UseFileStore | Use directory as a source of report templates.
Top

See Also

Reference

ReportingSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


CreateDefault Method

[image]
ActiveReports 13
CreateDefault Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : CreateDefault Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefault() As ReportingSettings
C#
public static ReportingSettings CreateDefault()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


StoreTemporaryFilesInMemory Method

[image]
ActiveReports 13
StoreTemporaryFilesInMemory Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : StoreTemporaryFilesInMemory Method

Glossary Item Box

Instructs ActiveReports to store temporary data to a memory.

Syntax

Visual Basic (Declaration)
Public Sub StoreTemporaryFilesInMemory()
C#
public void StoreTemporaryFilesInMemory()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


StoreTemporaryFilesOnDisk Method

[image]
ActiveReports 13
StoreTemporaryFilesOnDisk Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : StoreTemporaryFilesOnDisk Method

path

Glossary Item Box

Instructs ActiveReports to store temporary files to a disk to reduce memory consumption.

Syntax

Visual Basic (Declaration)
Public Sub StoreTemporaryFilesOnDisk( _
   ByVal path As DirectoryInfo _
)
C#
public void StoreTemporaryFilesOnDisk(
   DirectoryInfo path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseCustomStore Method

[image]
ActiveReports 13
UseCustomStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseCustomStore Method

getReportFn
The function that returns report template for a given report string identifier.

Glossary Item Box

Use custom report templates store.

Syntax

Visual Basic (Declaration)
Public Sub UseCustomStore( _
   ByVal getReportFn As Func(Of String,Object) _
)
C#
public void UseCustomStore(
   Func<string,object> getReportFn
)

Parameters

getReportFn
The function that returns report template for a given report string identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseEmbeddedTemplates Method

[image]
ActiveReports 13
UseEmbeddedTemplates Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseEmbeddedTemplates Method

prefix
asm

Glossary Item Box

Use embedded resources to locate the report templates.

Syntax

Visual Basic (Declaration)
Public Sub UseEmbeddedTemplates( _
   ByVal prefix As String, _
   ByVal asm As Assembly _
)
C#
public void UseEmbeddedTemplates(
   string prefix,
   Assembly asm
)

Parameters

prefix
asm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseFileStore Method

[image]
ActiveReports 13
UseFileStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseFileStore Method

rootPath

Glossary Item Box

Use directory as a source of report templates.

Syntax

Visual Basic (Declaration)
Public Sub UseFileStore( _
   ByVal rootPath As DirectoryInfo _
)
C#
public void UseFileStore(
   DirectoryInfo rootPath
)

Parameters

rootPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ReportingSettings Class Properties

[image]
ActiveReports 13
ReportingSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

For a list of all members of this type, see ReportingSettings members.

Public Properties

 | Name | Description
Public Property | LocateDataSource | Sets or gets data source locator handler.
Public Property | Prefix | Web API endpoint prefix.
Public Property | ResolveCredentials | Sets or gets credentials resolving handler.
Public Property | UseCompression | Tells ActiveReports to compress temporary data before storing to memory/disk.
Top

See Also

Reference

ReportingSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


LocateDataSource Property

[image]
ActiveReports 13
LocateDataSource Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : LocateDataSource Property

Glossary Item Box

Sets or gets data source locator handler.

Syntax

Visual Basic (Declaration)
Public Property LocateDataSource As Func(Of LocateDataSourceArgs,Object)
C#
public Func<LocateDataSourceArgs,object> LocateDataSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


Prefix Property

[image]
ActiveReports 13
Prefix Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : Prefix Property

Glossary Item Box

Web API endpoint prefix.

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ResolveCredentials Property

[image]
ActiveReports 13
ResolveCredentials Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : ResolveCredentials Property

Glossary Item Box

Sets or gets credentials resolving handler.

Syntax

Visual Basic (Declaration)
Public Property ResolveCredentials As GrapeCity.BI.Data.DataProviders.ResolveCredentials
C#
public GrapeCity.BI.Data.DataProviders.ResolveCredentials ResolveCredentials {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseCompression Property

[image]
ActiveReports 13
UseCompression Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseCompression Property

Glossary Item Box

Tells ActiveReports to compress temporary data before storing to memory/disk.

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
C#
public bool UseCompression {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ReportNotFoundException Class

[image]
ActiveReports 13
ReportNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

Occurs when IReportService can't find the report with the specified identifier.

Object Model

ReportNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ReportNotFoundException
   Inherits System.Exception
C#
public class ReportNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Members
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportNotFoundException Class Members

[image]
ActiveReports 13
ReportNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ReportNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ReportNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportNotFoundException Constructor

[image]
ActiveReports 13
ReportNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : ReportNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnet.Viewer)

GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnet.Viewer)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace

Glossary Item Box

Classes

 | Class | Description
Class | RenderSettings | Render report payload.

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Viewer Assembly


RenderSettings Class

[image]
ActiveReports 13
RenderSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace : RenderSettings Class

Glossary Item Box

Render report payload.

Object Model

RenderSettings Class

Syntax

Visual Basic (Declaration)
Public Class RenderSettings
C#
public class RenderSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services.RenderSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Members
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace


RenderSettings Class Members

[image]
ActiveReports 13
RenderSettings Class Members
See Also Fields
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace : RenderSettings Class

Glossary Item Box

The following tables list the members exposed by RenderSettings.

Public Constructors

 | Name | Description
Public Constructor | RenderSettings Constructor |
Top

Public Fields

 | Name | Description
Public Field | InteractiveActions | Interactive actions.
Public Field | Parameters | Specified parameter values
Public Field | Settings | Settings for rendering extensions.
Top

See Also

Reference

RenderSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace


RenderSettings Constructor

[image]
ActiveReports 13
RenderSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : RenderSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RenderSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


RenderSettings Class Fields

[image]
ActiveReports 13
RenderSettings Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace : RenderSettings Class

Glossary Item Box

For a list of all members of this type, see RenderSettings members.

Public Fields

 | Name | Description
Public Field | InteractiveActions | Interactive actions.
Public Field | Parameters | Specified parameter values
Public Field | Settings | Settings for rendering extensions.
Top

See Also

Reference

RenderSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace


InteractiveActions Field

[image]
ActiveReports 13
InteractiveActions Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : InteractiveActions Field

Glossary Item Box

Interactive actions.

Syntax

Visual Basic (Declaration)
Public InteractiveActions As String()
C#
public string[] InteractiveActions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


Parameters Field

[image]
ActiveReports 13
Parameters Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : Parameters Field

Glossary Item Box

Specified parameter values

Syntax

Visual Basic (Declaration)
Public Parameters As Dictionary(Of String,Object())
C#
public Dictionary<string,object[]> Parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


Settings Field

[image]
ActiveReports 13
Settings Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : Settings Field

Glossary Item Box

Settings for rendering extensions.

Syntax

Visual Basic (Declaration)
Public Settings As Dictionary(Of String,String)
C#
public Dictionary<string,string> Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


GrapeCity.ActiveReports.Aspnetcore.Designer Namespace

GrapeCity.ActiveReports.Aspnetcore.Designer Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DesignerSettings | Defines middleware settings.
Class | ImageNotFoundException |
Class | InvalidReportContentException |
Class | InvalidThemeContentException |
Class | ReportNotFoundException |
Class | ThemeNotFoundException |
Class | WebHostBuilderExtensions | Contains methods for configuring of web host application.

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Designer Assembly


DesignerSettings Class

[image]
ActiveReports 13
DesignerSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : DesignerSettings Class

Glossary Item Box

Defines middleware settings.

Object Model

DesignerSettings Class

Syntax

Visual Basic (Declaration)
Public Class DesignerSettings
C#
public class DesignerSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.DesignerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


DesignerSettings Class Members

[image]
ActiveReports 13
DesignerSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : DesignerSettings Class

Glossary Item Box

The following tables list the members exposed by DesignerSettings.

Public Constructors

 | Name | Description
Public Constructor | DesignerSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Prefix |
Top

Public Methods

 | Name | Description
Public Method | UseCustomStore |
Public Method | UseFileStore | Use directory as the resources source.
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


DesignerSettings Constructor

[image]
ActiveReports 13
DesignerSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > DesignerSettings Class : DesignerSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DesignerSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DesignerSettings Class Methods

[image]
ActiveReports 13
DesignerSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : DesignerSettings Class

Glossary Item Box

For a list of all members of this type, see DesignerSettings members.

Public Methods

 | Name | Description
Public Method | UseCustomStore |
Public Method | UseFileStore | Use directory as the resources source.
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


UseCustomStore Method

[image]
ActiveReports 13
UseCustomStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > DesignerSettings Class : UseCustomStore Method

resourcesService

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub UseCustomStore( _
   ByVal resourcesService As IResourcesService _
)
C#
public void UseCustomStore(
   IResourcesService resourcesService
)

Parameters

resourcesService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


UseFileStore Method

[image]
ActiveReports 13
UseFileStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > DesignerSettings Class : UseFileStore Method

rootPath
useTopDirectoryOnly

Glossary Item Box

Use directory as the resources source.

Syntax

Visual Basic (Declaration)
Public Sub UseFileStore( _
   ByVal rootPath As DirectoryInfo, _
   Optional ByVal useTopDirectoryOnly As Boolean _
)
C#
public void UseFileStore(
   DirectoryInfo rootPath,
   bool useTopDirectoryOnly
)

Parameters

rootPath
useTopDirectoryOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


DesignerSettings Class Properties

[image]
ActiveReports 13
DesignerSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : DesignerSettings Class

Glossary Item Box

For a list of all members of this type, see DesignerSettings members.

Public Properties

 | Name | Description
Public Property | Prefix |
Top

See Also

Reference

DesignerSettings Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


Prefix Property

[image]
ActiveReports 13
Prefix Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > DesignerSettings Class : Prefix Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerSettings Class
DesignerSettings Members


ImageNotFoundException Class

[image]
ActiveReports 13
ImageNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

Object Model

ImageNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ImageNotFoundException
   Inherits System.Exception
C#
public class ImageNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Designer.ImageNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ImageNotFoundException Class Members

[image]
ActiveReports 13
ImageNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ImageNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ImageNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ImageNotFoundException Constructor

[image]
ActiveReports 13
ImageNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : ImageNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InvalidReportContentException Class

[image]
ActiveReports 13
InvalidReportContentException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

Object Model

InvalidReportContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidReportContentException
   Inherits System.Exception
C#
public class InvalidReportContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Designer.InvalidReportContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


InvalidReportContentException Class Members

[image]
ActiveReports 13
InvalidReportContentException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidReportContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidReportContentException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


InvalidReportContentException Constructor

[image]
ActiveReports 13
InvalidReportContentException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : InvalidReportContentException Constructor

message

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidReportContentException(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class

[image]
ActiveReports 13
InvalidThemeContentException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

Object Model

InvalidThemeContentException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidThemeContentException
   Inherits System.Exception
C#
public class InvalidThemeContentException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Designer.InvalidThemeContentException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


InvalidThemeContentException Class Members

[image]
ActiveReports 13
InvalidThemeContentException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

The following tables list the members exposed by InvalidThemeContentException.

Public Constructors

 | Name | Description
Public Constructor | InvalidThemeContentException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


InvalidThemeContentException Constructor

[image]
ActiveReports 13
InvalidThemeContentException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : InvalidThemeContentException Constructor

message

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public InvalidThemeContentException(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ReportNotFoundException Class

[image]
ActiveReports 13
ReportNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

Object Model

ReportNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ReportNotFoundException
   Inherits System.Exception
C#
public class ReportNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Designer.ReportNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ReportNotFoundException Class Members

[image]
ActiveReports 13
ReportNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ReportNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ReportNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ReportNotFoundException Constructor

[image]
ActiveReports 13
ReportNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : ReportNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ThemeNotFoundException Class

[image]
ActiveReports 13
ThemeNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

Object Model

ThemeNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ThemeNotFoundException
   Inherits System.Exception
C#
public class ThemeNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Designer.ThemeNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ThemeNotFoundException Class Members

[image]
ActiveReports 13
ThemeNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ThemeNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ThemeNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ThemeNotFoundException Constructor

[image]
ActiveReports 13
ThemeNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : ThemeNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


WebHostBuilderExtensions Class

[image]
ActiveReports 13
WebHostBuilderExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

Contains methods for configuring of web host application.

Object Model

WebHostBuilderExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class WebHostBuilderExtensions
C#
public static class WebHostBuilderExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.WebHostBuilderExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Members
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


WebHostBuilderExtensions Class Members

[image]
ActiveReports 13
WebHostBuilderExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

The following tables list the members exposed by WebHostBuilderExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddDesigner | Adds services required for designer.
static (Shared in Visual Basic) | UseDesigner | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


WebHostBuilderExtensions Class Methods

[image]
ActiveReports 13
WebHostBuilderExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

For a list of all members of this type, see WebHostBuilderExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddDesigner | Adds services required for designer.
static (Shared in Visual Basic) | UseDesigner | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


AddDesigner Method

[image]
ActiveReports 13
AddDesigner Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > WebHostBuilderExtensions Class : AddDesigner Method

services

Glossary Item Box

Adds services required for designer.

Syntax

Visual Basic (Declaration)
Public Shared Function AddDesigner( _
   ByVal services As IServiceCollection _
) As IServiceCollection
C#
public static IServiceCollection AddDesigner(
   IServiceCollection services
)

Parameters

services

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Class
WebHostBuilderExtensions Members


UseDesigner Method

[image]
ActiveReports 13
UseDesigner Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > WebHostBuilderExtensions Class : UseDesigner Method

builder
configure

Glossary Item Box

Configures middleware for ActiveReports API and handlers.

Syntax

Visual Basic (Declaration)
Public Shared Function UseDesigner( _
   ByVal builder As IApplicationBuilder, _
   Optional ByVal configure As Action(Of DesignerSettings) _
) As IApplicationBuilder
C#
public static IApplicationBuilder UseDesigner(
   IApplicationBuilder builder,
   Action<DesignerSettings> configure
)

Parameters

builder
configure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Class
WebHostBuilderExtensions Members


GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace

GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace

Glossary Item Box

Classes

 | Class | Description
Class | Theme |
Class | ThemeColors |
Class | ThemeConstant |
Class | ThemeFont |
Class | ThemeFonts |
Class | ThemeImage |

Interfaces

 | Interface | Description
Interface | IImageInfo | Defines the minimum required image info
Interface | IReportInfo | Defines the minimum required report info
Interface | IResourcesService | Allows to load resources (reports, themes, images) from custom storage.
Interface | IThemeInfo | Defines the minimum required theme info

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Designer Assembly


Theme Class

[image]
ActiveReports 13
Theme Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : Theme Class

Glossary Item Box

Object Model

Theme Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Theme
C#
public sealed class Theme

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.Theme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Theme Class Members

[image]
ActiveReports 13
Theme Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : Theme Class

Glossary Item Box

The following tables list the members exposed by Theme.

Public Constructors

 | Name | Description
Public Constructor | Theme Constructor |
Top

Public Properties

 | Name | Description
Public Property | Colors |
Public Property | Constants |
Public Property | Fonts |
Public Property | Images |
Top

See Also

Reference

Theme Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Theme Constructor

[image]
ActiveReports 13
Theme Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > Theme Class : Theme Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Theme()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Theme Class Properties

[image]
ActiveReports 13
Theme Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : Theme Class

Glossary Item Box

For a list of all members of this type, see Theme members.

Public Properties

 | Name | Description
Public Property | Colors |
Public Property | Constants |
Public Property | Fonts |
Public Property | Images |
Top

See Also

Reference

Theme Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Colors Property

[image]
ActiveReports 13
Colors Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > Theme Class : Colors Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Colors As ThemeColors
C#
public ThemeColors Colors {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Constants Property

[image]
ActiveReports 13
Constants Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > Theme Class : Constants Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Constants As ThemeConstant()
C#
public ThemeConstant[] Constants {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Fonts Property

[image]
ActiveReports 13
Fonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > Theme Class : Fonts Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Fonts As ThemeFonts
C#
public ThemeFonts Fonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


Images Property

[image]
ActiveReports 13
Images Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > Theme Class : Images Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Images As ThemeImage()
C#
public ThemeImage[] Images {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Theme Class
Theme Members


ThemeColors Class

[image]
ActiveReports 13
ThemeColors Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeColors Class

Glossary Item Box

Object Model

ThemeColors Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeColors
C#
public sealed class ThemeColors

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeColors

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeColors Class Members

[image]
ActiveReports 13
ThemeColors Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeColors Class

Glossary Item Box

The following tables list the members exposed by ThemeColors.

Public Constructors

 | Name | Description
Public Constructor | ThemeColors Constructor |
Top

Public Properties

 | Name | Description
Public Property | Accent1 |
Public Property | Accent2 |
Public Property | Accent3 |
Public Property | Accent4 |
Public Property | Accent5 |
Public Property | Accent6 |
Public Property | Dark1 |
Public Property | Dark2 |
Public Property | Hyperlink |
Public Property | HyperlinkFollowed |
Public Property | Light1 |
Public Property | Light2 |
Top

See Also

Reference

ThemeColors Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeColors Constructor

[image]
ActiveReports 13
ThemeColors Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : ThemeColors Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeColors()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


ThemeColors Class Properties

[image]
ActiveReports 13
ThemeColors Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeColors Class

Glossary Item Box

For a list of all members of this type, see ThemeColors members.

Public Properties

 | Name | Description
Public Property | Accent1 |
Public Property | Accent2 |
Public Property | Accent3 |
Public Property | Accent4 |
Public Property | Accent5 |
Public Property | Accent6 |
Public Property | Dark1 |
Public Property | Dark2 |
Public Property | Hyperlink |
Public Property | HyperlinkFollowed |
Public Property | Light1 |
Public Property | Light2 |
Top

See Also

Reference

ThemeColors Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Accent1 Property

[image]
ActiveReports 13
Accent1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Accent1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent1 As String
C#
public string Accent1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent2 Property

[image]
ActiveReports 13
Accent2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Accent2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent2 As String
C#
public string Accent2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent3 Property

[image]
ActiveReports 13
Accent3 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Accent3 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent3 As String
C#
public string Accent3 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent4 Property

[image]
ActiveReports 13
Accent4 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Accent4 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent4 As String
C#
public string Accent4 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent5 Property

[image]
ActiveReports 13
Accent5 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Accent5 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent5 As String
C#
public string Accent5 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Accent6 Property

[image]
ActiveReports 13
Accent6 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Accent6 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Accent6 As String
C#
public string Accent6 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Dark1 Property

[image]
ActiveReports 13
Dark1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Dark1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dark1 As String
C#
public string Dark1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Dark2 Property

[image]
ActiveReports 13
Dark2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Dark2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dark2 As String
C#
public string Dark2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Hyperlink Property

[image]
ActiveReports 13
Hyperlink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Hyperlink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Hyperlink As String
C#
public string Hyperlink {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


HyperlinkFollowed Property

[image]
ActiveReports 13
HyperlinkFollowed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : HyperlinkFollowed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HyperlinkFollowed As String
C#
public string HyperlinkFollowed {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Light1 Property

[image]
ActiveReports 13
Light1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Light1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Light1 As String
C#
public string Light1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


Light2 Property

[image]
ActiveReports 13
Light2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeColors Class : Light2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Light2 As String
C#
public string Light2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeColors Class
ThemeColors Members


ThemeConstant Class

[image]
ActiveReports 13
ThemeConstant Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeConstant Class

Glossary Item Box

Object Model

ThemeConstant Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeConstant
C#
public sealed class ThemeConstant

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeConstant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeConstant Class Members

[image]
ActiveReports 13
ThemeConstant Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeConstant Class

Glossary Item Box

The following tables list the members exposed by ThemeConstant.

Public Constructors

 | Name | Description
Public Constructor | ThemeConstant Constructor |
Top

Public Properties

 | Name | Description
Public Property | Key |
Public Property | Value |
Top

See Also

Reference

ThemeConstant Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeConstant Constructor

[image]
ActiveReports 13
ThemeConstant Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeConstant Class : ThemeConstant Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeConstant()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


ThemeConstant Class Properties

[image]
ActiveReports 13
ThemeConstant Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeConstant Class

Glossary Item Box

For a list of all members of this type, see ThemeConstant members.

Public Properties

 | Name | Description
Public Property | Key |
Public Property | Value |
Top

See Also

Reference

ThemeConstant Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Key Property

[image]
ActiveReports 13
Key Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeConstant Class : Key Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


Value Property

[image]
ActiveReports 13
Value Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeConstant Class : Value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeConstant Class
ThemeConstant Members


ThemeFont Class

[image]
ActiveReports 13
ThemeFont Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeFont Class

Glossary Item Box

Object Model

ThemeFont Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeFont
C#
public sealed class ThemeFont

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeFont Class Members

[image]
ActiveReports 13
ThemeFont Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeFont Class

Glossary Item Box

The following tables list the members exposed by ThemeFont.

Public Constructors

 | Name | Description
Public Constructor | ThemeFont Constructor |
Top

Public Properties

 | Name | Description
Public Property | Family |
Public Property | Size |
Public Property | Style |
Public Property | Weight |
Top

See Also

Reference

ThemeFont Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeFont Constructor

[image]
ActiveReports 13
ThemeFont Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFont Class : ThemeFont Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeFont()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


ThemeFont Class Properties

[image]
ActiveReports 13
ThemeFont Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeFont Class

Glossary Item Box

For a list of all members of this type, see ThemeFont members.

Public Properties

 | Name | Description
Public Property | Family |
Public Property | Size |
Public Property | Style |
Public Property | Weight |
Top

See Also

Reference

ThemeFont Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Family Property

[image]
ActiveReports 13
Family Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFont Class : Family Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Family As String
C#
public string Family {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFont Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Size As String
C#
public string Size {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


Style Property

[image]
ActiveReports 13
Style Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFont Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Style As String
C#
public string Style {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


Weight Property

[image]
ActiveReports 13
Weight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFont Class : Weight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Weight As String
C#
public string Weight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFont Class
ThemeFont Members


ThemeFonts Class

[image]
ActiveReports 13
ThemeFonts Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeFonts Class

Glossary Item Box

Object Model

ThemeFonts Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeFonts
C#
public sealed class ThemeFonts

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeFonts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeFonts Class Members

[image]
ActiveReports 13
ThemeFonts Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeFonts Class

Glossary Item Box

The following tables list the members exposed by ThemeFonts.

Public Constructors

 | Name | Description
Public Constructor | ThemeFonts Constructor |
Top

Public Properties

 | Name | Description
Public Property | MajorFont |
Public Property | MinorFont |
Top

See Also

Reference

ThemeFonts Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeFonts Constructor

[image]
ActiveReports 13
ThemeFonts Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFonts Class : ThemeFonts Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeFonts()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Class
ThemeFonts Members


ThemeFonts Class Properties

[image]
ActiveReports 13
ThemeFonts Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeFonts Class

Glossary Item Box

For a list of all members of this type, see ThemeFonts members.

Public Properties

 | Name | Description
Public Property | MajorFont |
Public Property | MinorFont |
Top

See Also

Reference

ThemeFonts Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


MajorFont Property

[image]
ActiveReports 13
MajorFont Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFonts Class : MajorFont Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MajorFont As ThemeFont
C#
public ThemeFont MajorFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Class
ThemeFonts Members


MinorFont Property

[image]
ActiveReports 13
MinorFont Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeFonts Class : MinorFont Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MinorFont As ThemeFont
C#
public ThemeFont MinorFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeFonts Class
ThemeFonts Members


ThemeImage Class

[image]
ActiveReports 13
ThemeImage Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeImage Class

Glossary Item Box

Object Model

ThemeImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThemeImage
C#
public sealed class ThemeImage

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeImage Class Members

[image]
ActiveReports 13
ThemeImage Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeImage Class

Glossary Item Box

The following tables list the members exposed by ThemeImage.

Public Constructors

 | Name | Description
Public Constructor | ThemeImage Constructor |
Top

Public Properties

 | Name | Description
Public Property | ImageData |
Public Property | MIMEType |
Public Property | Name |
Top

See Also

Reference

ThemeImage Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ThemeImage Constructor

[image]
ActiveReports 13
ThemeImage Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeImage Class : ThemeImage Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ThemeImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


ThemeImage Class Properties

[image]
ActiveReports 13
ThemeImage Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : ThemeImage Class

Glossary Item Box

For a list of all members of this type, see ThemeImage members.

Public Properties

 | Name | Description
Public Property | ImageData |
Public Property | MIMEType |
Public Property | Name |
Top

See Also

Reference

ThemeImage Class
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ImageData Property

[image]
ActiveReports 13
ImageData Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeImage Class : ImageData Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImageData As String
C#
public string ImageData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


MIMEType Property

[image]
ActiveReports 13
MIMEType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeImage Class : MIMEType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MIMEType As String
C#
public string MIMEType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > ThemeImage Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeImage Class
ThemeImage Members


IImageInfo Interface

[image]
ActiveReports 13
IImageInfo Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IImageInfo Interface

Glossary Item Box

Defines the minimum required image info

Syntax

Visual Basic (Declaration)
Public Interface IImageInfo
C#
public interface IImageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IImageInfo Interface Members

[image]
ActiveReports 13
IImageInfo Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IImageInfo Interface

Glossary Item Box

The following tables list the members exposed by IImageInfo.

Public Properties

 | Name | Description
Property | ContentType | Image content type
Property | Id | Image id
Property | Name | Image name
Property | Thumbnail | Image thumbnail
Top

See Also

Reference

IImageInfo Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IImageInfo Interface Properties

[image]
ActiveReports 13
IImageInfo Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IImageInfo Interface

Glossary Item Box

For a list of all members of this type, see IImageInfo members.

Public Properties

 | Name | Description
Property | ContentType | Image content type
Property | Id | Image id
Property | Name | Image name
Property | Thumbnail | Image thumbnail
Top

See Also

Reference

IImageInfo Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


ContentType Property

[image]
ActiveReports 13
ContentType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IImageInfo Interface : ContentType Property

Glossary Item Box

Image content type

Syntax

Visual Basic (Declaration)
Property ContentType As String
C#
string ContentType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


Id Property

[image]
ActiveReports 13
Id Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IImageInfo Interface : Id Property

Glossary Item Box

Image id

Syntax

Visual Basic (Declaration)
Property Id As String
C#
string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IImageInfo Interface : Name Property

Glossary Item Box

Image name

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


Thumbnail Property

[image]
ActiveReports 13
Thumbnail Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IImageInfo Interface : Thumbnail Property

Glossary Item Box

Image thumbnail

Syntax

Visual Basic (Declaration)
Property Thumbnail As Byte()
C#
byte[] Thumbnail {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IImageInfo Interface
IImageInfo Members


IReportInfo Interface

[image]
ActiveReports 13
IReportInfo Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IReportInfo Interface

Glossary Item Box

Defines the minimum required report info

Syntax

Visual Basic (Declaration)
Public Interface IReportInfo
C#
public interface IReportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IReportInfo Interface Members

[image]
ActiveReports 13
IReportInfo Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IReportInfo Interface

Glossary Item Box

The following tables list the members exposed by IReportInfo.

Public Properties

 | Name | Description
Property | Id | Report id
Property | Name | Report name
Property | Type | Report type
Top

See Also

Reference

IReportInfo Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IReportInfo Interface Properties

[image]
ActiveReports 13
IReportInfo Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IReportInfo Interface

Glossary Item Box

For a list of all members of this type, see IReportInfo members.

Public Properties

 | Name | Description
Property | Id | Report id
Property | Name | Report name
Property | Type | Report type
Top

See Also

Reference

IReportInfo Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Id Property

[image]
ActiveReports 13
Id Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IReportInfo Interface : Id Property

Glossary Item Box

Report id

Syntax

Visual Basic (Declaration)
Property Id As String
C#
string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Interface
IReportInfo Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IReportInfo Interface : Name Property

Glossary Item Box

Report name

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Interface
IReportInfo Members


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IReportInfo Interface : Type Property

Glossary Item Box

Report type

Syntax

Visual Basic (Declaration)
Property Type As String
C#
string Type {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportInfo Interface
IReportInfo Members


IResourcesService Interface

[image]
ActiveReports 13
IResourcesService Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IResourcesService Interface

Glossary Item Box

Allows to load resources (reports, themes, images) from custom storage.

Syntax

Visual Basic (Declaration)
Public Interface IResourcesService
C#
public interface IResourcesService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IResourcesService Interface Members

[image]
ActiveReports 13
IResourcesService Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IResourcesService Interface

Glossary Item Box

The following tables list the members exposed by IResourcesService.

Public Methods

 | Name | Description
Method | DeleteReport | Delete report
Method | GetImage | Get image content by id
Method | GetImagesList | Get images list
Method | GetReport | Get report content by id
Method | GetReportsList | Get reports list
Method | GetTheme | Get theme content by id
Method | GetThemesList | Get themes list
Method | SaveReport | Save report
Method | UpdateReport | Update report
Top

See Also

Reference

IResourcesService Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IResourcesService Interface Methods

[image]
ActiveReports 13
IResourcesService Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IResourcesService Interface

Glossary Item Box

For a list of all members of this type, see IResourcesService members.

Public Methods

 | Name | Description
Method | DeleteReport | Delete report
Method | GetImage | Get image content by id
Method | GetImagesList | Get images list
Method | GetReport | Get report content by id
Method | GetReportsList | Get reports list
Method | GetTheme | Get theme content by id
Method | GetThemesList | Get themes list
Method | SaveReport | Save report
Method | UpdateReport | Update report
Top

See Also

Reference

IResourcesService Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


DeleteReport Method

[image]
ActiveReports 13
DeleteReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : DeleteReport Method

id
Report id

Glossary Item Box

Delete report

Syntax

Visual Basic (Declaration)
Sub DeleteReport( _
   ByVal id As String _
)
C#
void DeleteReport(
   string id
)

Parameters

id
Report id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetImage Method

[image]
ActiveReports 13
GetImage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : GetImage Method

id
Image id
mimeType
Image MIME type

Glossary Item Box

Get image content by id

Syntax

Visual Basic (Declaration)
Function GetImage( _
   ByVal id As String, _
   ByRef mimeType As String _
) As Byte()
C#
byte[] GetImage(
   string id,
   out string mimeType
)

Parameters

id
Image id
mimeType
Image MIME type

Return Value

Image content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetImagesList Method

[image]
ActiveReports 13
GetImagesList Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : GetImagesList Method

Glossary Item Box

Get images list

Syntax

Visual Basic (Declaration)
Function GetImagesList() As IImageInfo()
C#
IImageInfo[] GetImagesList()

Return Value

Images list

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetReport Method

[image]
ActiveReports 13
GetReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : GetReport Method

id
Report id

Glossary Item Box

Get report content by id

Syntax

Visual Basic (Declaration)
Function GetReport( _
   ByVal id As String _
) As GrapeCity.ActiveReports.PageReportModel.Report
C#
GrapeCity.ActiveReports.PageReportModel.Report GetReport(
   string id
)

Parameters

id
Report id

Return Value

Report content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetReportsList Method

[image]
ActiveReports 13
GetReportsList Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : GetReportsList Method

Glossary Item Box

Get reports list

Syntax

Visual Basic (Declaration)
Function GetReportsList() As IReportInfo()
C#
IReportInfo[] GetReportsList()

Return Value

Reports list

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetTheme Method

[image]
ActiveReports 13
GetTheme Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : GetTheme Method

id
Theme id

Glossary Item Box

Get theme content by id

Syntax

Visual Basic (Declaration)
Function GetTheme( _
   ByVal id As String _
) As Theme
C#
Theme GetTheme(
   string id
)

Parameters

id
Theme id

Return Value

Theme content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


GetThemesList Method

[image]
ActiveReports 13
GetThemesList Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : GetThemesList Method

Glossary Item Box

Get themes list

Syntax

Visual Basic (Declaration)
Function GetThemesList() As IThemeInfo()
C#
IThemeInfo[] GetThemesList()

Return Value

Themes list

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


SaveReport Method

[image]
ActiveReports 13
SaveReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : SaveReport Method

name
Report name
report
isTemporary
Save report as temporary report

Glossary Item Box

Save report

Syntax

Visual Basic (Declaration)
Function SaveReport( _
   ByVal name As String, _
   ByVal report As GrapeCity.ActiveReports.PageReportModel.Report, _
   Optional ByVal isTemporary As Boolean _
) As String
C#
string SaveReport(
   string name,
   GrapeCity.ActiveReports.PageReportModel.Report report,
   bool isTemporary
)

Parameters

name
Report name
report
isTemporary
Save report as temporary report

Return Value

Report id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


UpdateReport Method

[image]
ActiveReports 13
UpdateReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IResourcesService Interface : UpdateReport Method

id
Report id
report

Glossary Item Box

Update report

Syntax

Visual Basic (Declaration)
Function UpdateReport( _
   ByVal id As String, _
   ByVal report As GrapeCity.ActiveReports.PageReportModel.Report _
) As String
C#
string UpdateReport(
   string id,
   GrapeCity.ActiveReports.PageReportModel.Report report
)

Parameters

id
Report id
report

Return Value

Report id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IResourcesService Interface
IResourcesService Members


IThemeInfo Interface

[image]
ActiveReports 13
IThemeInfo Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IThemeInfo Interface

Glossary Item Box

Defines the minimum required theme info

Syntax

Visual Basic (Declaration)
Public Interface IThemeInfo
C#
public interface IThemeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Members
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IThemeInfo Interface Members

[image]
ActiveReports 13
IThemeInfo Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IThemeInfo Interface

Glossary Item Box

The following tables list the members exposed by IThemeInfo.

Public Properties

 | Name | Description
Property | Accent1 | Colors/Accent1 value
Property | Accent2 | Colors/Accent2 value
Property | Accent3 | Colors/Accent3 value
Property | Accent4 | Colors/Accent4 value
Property | Accent5 | Colors/Accent5 value
Property | Accent6 | Colors/Accent6 value
Property | Dark1 | Colors/Dark1 value
Property | Dark2 | Colors/Dark2 value
Property | Id | Theme id
Property | Light1 | Colors/Light1 value
Property | Light2 | Colors/Light2 value
Property | MajorFontFamily | Fonts/MajorFont/Family value
Property | MinorFontFamily | Fonts/MinorFont/Family value
Property | Title | Theme title
Top

See Also

Reference

IThemeInfo Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


IThemeInfo Interface Properties

[image]
ActiveReports 13
IThemeInfo Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace : IThemeInfo Interface

Glossary Item Box

For a list of all members of this type, see IThemeInfo members.

Public Properties

 | Name | Description
Property | Accent1 | Colors/Accent1 value
Property | Accent2 | Colors/Accent2 value
Property | Accent3 | Colors/Accent3 value
Property | Accent4 | Colors/Accent4 value
Property | Accent5 | Colors/Accent5 value
Property | Accent6 | Colors/Accent6 value
Property | Dark1 | Colors/Dark1 value
Property | Dark2 | Colors/Dark2 value
Property | Id | Theme id
Property | Light1 | Colors/Light1 value
Property | Light2 | Colors/Light2 value
Property | MajorFontFamily | Fonts/MajorFont/Family value
Property | MinorFontFamily | Fonts/MinorFont/Family value
Property | Title | Theme title
Top

See Also

Reference

IThemeInfo Interface
GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace


Accent1 Property

[image]
ActiveReports 13
Accent1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Accent1 Property

Glossary Item Box

Colors/Accent1 value

Syntax

Visual Basic (Declaration)
Property Accent1 As String
C#
string Accent1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent2 Property

[image]
ActiveReports 13
Accent2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Accent2 Property

Glossary Item Box

Colors/Accent2 value

Syntax

Visual Basic (Declaration)
Property Accent2 As String
C#
string Accent2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent3 Property

[image]
ActiveReports 13
Accent3 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Accent3 Property

Glossary Item Box

Colors/Accent3 value

Syntax

Visual Basic (Declaration)
Property Accent3 As String
C#
string Accent3 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent4 Property

[image]
ActiveReports 13
Accent4 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Accent4 Property

Glossary Item Box

Colors/Accent4 value

Syntax

Visual Basic (Declaration)
Property Accent4 As String
C#
string Accent4 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent5 Property

[image]
ActiveReports 13
Accent5 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Accent5 Property

Glossary Item Box

Colors/Accent5 value

Syntax

Visual Basic (Declaration)
Property Accent5 As String
C#
string Accent5 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Accent6 Property

[image]
ActiveReports 13
Accent6 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Accent6 Property

Glossary Item Box

Colors/Accent6 value

Syntax

Visual Basic (Declaration)
Property Accent6 As String
C#
string Accent6 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Dark1 Property

[image]
ActiveReports 13
Dark1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Dark1 Property

Glossary Item Box

Colors/Dark1 value

Syntax

Visual Basic (Declaration)
Property Dark1 As String
C#
string Dark1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Dark2 Property

[image]
ActiveReports 13
Dark2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Dark2 Property

Glossary Item Box

Colors/Dark2 value

Syntax

Visual Basic (Declaration)
Property Dark2 As String
C#
string Dark2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Id Property

[image]
ActiveReports 13
Id Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Id Property

Glossary Item Box

Theme id

Syntax

Visual Basic (Declaration)
Property Id As String
C#
string Id {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Light1 Property

[image]
ActiveReports 13
Light1 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Light1 Property

Glossary Item Box

Colors/Light1 value

Syntax

Visual Basic (Declaration)
Property Light1 As String
C#
string Light1 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Light2 Property

[image]
ActiveReports 13
Light2 Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Light2 Property

Glossary Item Box

Colors/Light2 value

Syntax

Visual Basic (Declaration)
Property Light2 As String
C#
string Light2 {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


MajorFontFamily Property

[image]
ActiveReports 13
MajorFontFamily Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : MajorFontFamily Property

Glossary Item Box

Fonts/MajorFont/Family value

Syntax

Visual Basic (Declaration)
Property MajorFontFamily As String
C#
string MajorFontFamily {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


MinorFontFamily Property

[image]
ActiveReports 13
MinorFontFamily Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : MinorFontFamily Property

Glossary Item Box

Fonts/MinorFont/Family value

Syntax

Visual Basic (Declaration)
Property MinorFontFamily As String
C#
string MinorFontFamily {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace > IThemeInfo Interface : Title Property

Glossary Item Box

Theme title

Syntax

Visual Basic (Declaration)
Property Title As String
C#
string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IThemeInfo Interface
IThemeInfo Members


GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace

GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Designer Assembly


GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer)

GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ReportingSettings | Defines reporting middleware settings.
Class | ReportNotFoundException | Occurs when IReportService can't find the report with the specified identifier.
Class | WebHostBuilderExtensions | Contains methods for configuring of web host application.

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly


ReportingSettings Class

[image]
ActiveReports 13
ReportingSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

Defines reporting middleware settings.

Object Model

ReportingSettings Class

Syntax

Visual Basic (Declaration)
Public Class ReportingSettings
C#
public class ReportingSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportingSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Members
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportingSettings Class Members

[image]
ActiveReports 13
ReportingSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

The following tables list the members exposed by ReportingSettings.

Public Constructors

 | Name | Description
Public Constructor | ReportingSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | LocateDataSource | Sets or gets data source locator handler.
Public Property | Prefix | Web API endpoint prefix.
Public Property | ResolveCredentials | Sets or gets credentials resolving handler.
Public Property | UseCompression | Tells ActiveReports to compress temporary data before storing to memory/disk.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault |
Public Method | StoreTemporaryFilesInMemory | Instructs ActiveReports to store temporary data to a memory.
Public Method | StoreTemporaryFilesOnDisk | Instructs ActiveReports to store temporary files to a disk to reduce memory consumption.
Public Method | UseCustomStore | Use custom report templates store.
Public Method | UseEmbeddedTemplates | Use embedded resources to locate the report templates.
Public Method | UseFileStore | Use directory as a source of report templates.
Top

See Also

Reference

ReportingSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportingSettings Constructor

[image]
ActiveReports 13
ReportingSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : ReportingSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportingSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ReportingSettings Class Methods

[image]
ActiveReports 13
ReportingSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

For a list of all members of this type, see ReportingSettings members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault |
Public Method | StoreTemporaryFilesInMemory | Instructs ActiveReports to store temporary data to a memory.
Public Method | StoreTemporaryFilesOnDisk | Instructs ActiveReports to store temporary files to a disk to reduce memory consumption.
Public Method | UseCustomStore | Use custom report templates store.
Public Method | UseEmbeddedTemplates | Use embedded resources to locate the report templates.
Public Method | UseFileStore | Use directory as a source of report templates.
Top

See Also

Reference

ReportingSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


CreateDefault Method

[image]
ActiveReports 13
CreateDefault Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : CreateDefault Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefault() As ReportingSettings
C#
public static ReportingSettings CreateDefault()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


StoreTemporaryFilesInMemory Method

[image]
ActiveReports 13
StoreTemporaryFilesInMemory Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : StoreTemporaryFilesInMemory Method

Glossary Item Box

Instructs ActiveReports to store temporary data to a memory.

Syntax

Visual Basic (Declaration)
Public Sub StoreTemporaryFilesInMemory()
C#
public void StoreTemporaryFilesInMemory()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


StoreTemporaryFilesOnDisk Method

[image]
ActiveReports 13
StoreTemporaryFilesOnDisk Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : StoreTemporaryFilesOnDisk Method

path

Glossary Item Box

Instructs ActiveReports to store temporary files to a disk to reduce memory consumption.

Syntax

Visual Basic (Declaration)
Public Sub StoreTemporaryFilesOnDisk( _
   ByVal path As DirectoryInfo _
)
C#
public void StoreTemporaryFilesOnDisk(
   DirectoryInfo path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseCustomStore Method

[image]
ActiveReports 13
UseCustomStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseCustomStore Method

getReportFn
The function that returns report template for a given report string identifier.

Glossary Item Box

Use custom report templates store.

Syntax

Visual Basic (Declaration)
Public Sub UseCustomStore( _
   ByVal getReportFn As Func(Of String,Object) _
)
C#
public void UseCustomStore(
   Func<string,object> getReportFn
)

Parameters

getReportFn
The function that returns report template for a given report string identifier.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseEmbeddedTemplates Method

[image]
ActiveReports 13
UseEmbeddedTemplates Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseEmbeddedTemplates Method

prefix
asm

Glossary Item Box

Use embedded resources to locate the report templates.

Syntax

Visual Basic (Declaration)
Public Sub UseEmbeddedTemplates( _
   ByVal prefix As String, _
   ByVal asm As Assembly _
)
C#
public void UseEmbeddedTemplates(
   string prefix,
   Assembly asm
)

Parameters

prefix
asm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseFileStore Method

[image]
ActiveReports 13
UseFileStore Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseFileStore Method

rootPath

Glossary Item Box

Use directory as a source of report templates.

Syntax

Visual Basic (Declaration)
Public Sub UseFileStore( _
   ByVal rootPath As DirectoryInfo _
)
C#
public void UseFileStore(
   DirectoryInfo rootPath
)

Parameters

rootPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ReportingSettings Class Properties

[image]
ActiveReports 13
ReportingSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportingSettings Class

Glossary Item Box

For a list of all members of this type, see ReportingSettings members.

Public Properties

 | Name | Description
Public Property | LocateDataSource | Sets or gets data source locator handler.
Public Property | Prefix | Web API endpoint prefix.
Public Property | ResolveCredentials | Sets or gets credentials resolving handler.
Public Property | UseCompression | Tells ActiveReports to compress temporary data before storing to memory/disk.
Top

See Also

Reference

ReportingSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


LocateDataSource Property

[image]
ActiveReports 13
LocateDataSource Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : LocateDataSource Property

Glossary Item Box

Sets or gets data source locator handler.

Syntax

Visual Basic (Declaration)
Public Property LocateDataSource As Func(Of LocateDataSourceArgs,Object)
C#
public Func<LocateDataSourceArgs,object> LocateDataSource {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


Prefix Property

[image]
ActiveReports 13
Prefix Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : Prefix Property

Glossary Item Box

Web API endpoint prefix.

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ResolveCredentials Property

[image]
ActiveReports 13
ResolveCredentials Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : ResolveCredentials Property

Glossary Item Box

Sets or gets credentials resolving handler.

Syntax

Visual Basic (Declaration)
Public Property ResolveCredentials As GrapeCity.BI.Data.DataProviders.ResolveCredentials
C#
public GrapeCity.BI.Data.DataProviders.ResolveCredentials ResolveCredentials {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


UseCompression Property

[image]
ActiveReports 13
UseCompression Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportingSettings Class : UseCompression Property

Glossary Item Box

Tells ActiveReports to compress temporary data before storing to memory/disk.

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
C#
public bool UseCompression {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportingSettings Class
ReportingSettings Members


ReportNotFoundException Class

[image]
ActiveReports 13
ReportNotFoundException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

Occurs when IReportService can't find the report with the specified identifier.

Object Model

ReportNotFoundException Class

Syntax

Visual Basic (Declaration)
Public Class ReportNotFoundException
   Inherits System.Exception
C#
public class ReportNotFoundException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportNotFoundException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Members
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportNotFoundException Class Members

[image]
ActiveReports 13
ReportNotFoundException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

The following tables list the members exposed by ReportNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | ReportNotFoundException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportNotFoundException Constructor

[image]
ActiveReports 13
ReportNotFoundException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : ReportNotFoundException Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportNotFoundException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


WebHostBuilderExtensions Class

[image]
ActiveReports 13
WebHostBuilderExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

Contains methods for configuring of web host application.

Object Model

WebHostBuilderExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class WebHostBuilderExtensions
C#
public static class WebHostBuilderExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.WebHostBuilderExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Members
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


WebHostBuilderExtensions Class Members

[image]
ActiveReports 13
WebHostBuilderExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

The following tables list the members exposed by WebHostBuilderExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddReporting | Adds services required for reporting.
static (Shared in Visual Basic) | UseReporting | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


WebHostBuilderExtensions Class Methods

[image]
ActiveReports 13
WebHostBuilderExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : WebHostBuilderExtensions Class

Glossary Item Box

For a list of all members of this type, see WebHostBuilderExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddReporting | Adds services required for reporting.
static (Shared in Visual Basic) | UseReporting | Configures middleware for ActiveReports API and handlers.
Top

See Also

Reference

WebHostBuilderExtensions Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


AddReporting Method

[image]
ActiveReports 13
AddReporting Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > WebHostBuilderExtensions Class : AddReporting Method

services

Glossary Item Box

Adds services required for reporting.

Syntax

Visual Basic (Declaration)
Public Shared Function AddReporting( _
   ByVal services As IServiceCollection _
) As IServiceCollection
C#
public static IServiceCollection AddReporting(
   IServiceCollection services
)

Parameters

services

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Class
WebHostBuilderExtensions Members


UseReporting Method

[image]
ActiveReports 13
UseReporting Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > WebHostBuilderExtensions Class : UseReporting Method

builder
configure

Glossary Item Box

Configures middleware for ActiveReports API and handlers.

Syntax

Visual Basic (Declaration)
Public Shared Function UseReporting( _
   ByVal builder As IApplicationBuilder, _
   Optional ByVal configure As Action(Of ReportingSettings) _
) As IApplicationBuilder
C#
public static IApplicationBuilder UseReporting(
   IApplicationBuilder builder,
   Action<ReportingSettings> configure
)

Parameters

builder
configure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebHostBuilderExtensions Class
WebHostBuilderExtensions Members


GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer)

GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace

Glossary Item Box

Classes

 | Class | Description
Class | RenderSettings | Render report payload.

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly


RenderSettings Class

[image]
ActiveReports 13
RenderSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace : RenderSettings Class

Glossary Item Box

Render report payload.

Object Model

RenderSettings Class

Syntax

Visual Basic (Declaration)
Public Class RenderSettings
C#
public class RenderSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services.RenderSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Members
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace


RenderSettings Class Members

[image]
ActiveReports 13
RenderSettings Class Members
See Also Fields
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace : RenderSettings Class

Glossary Item Box

The following tables list the members exposed by RenderSettings.

Public Constructors

 | Name | Description
Public Constructor | RenderSettings Constructor |
Top

Public Fields

 | Name | Description
Public Field | InteractiveActions | Interactive actions.
Public Field | Parameters | Specified parameter values
Public Field | Settings | Settings for rendering extensions.
Top

See Also

Reference

RenderSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace


RenderSettings Constructor

[image]
ActiveReports 13
RenderSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : RenderSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RenderSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


RenderSettings Class Fields

[image]
ActiveReports 13
RenderSettings Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace : RenderSettings Class

Glossary Item Box

For a list of all members of this type, see RenderSettings members.

Public Fields

 | Name | Description
Public Field | InteractiveActions | Interactive actions.
Public Field | Parameters | Specified parameter values
Public Field | Settings | Settings for rendering extensions.
Top

See Also

Reference

RenderSettings Class
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace


InteractiveActions Field

[image]
ActiveReports 13
InteractiveActions Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : InteractiveActions Field

Glossary Item Box

Interactive actions.

Syntax

Visual Basic (Declaration)
Public InteractiveActions As String()
C#
public string[] InteractiveActions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


Parameters Field

[image]
ActiveReports 13
Parameters Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : Parameters Field

Glossary Item Box

Specified parameter values

Syntax

Visual Basic (Declaration)
Public Parameters As Dictionary(Of String,Object())
C#
public Dictionary<string,object[]> Parameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


Settings Field

[image]
ActiveReports 13
Settings Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace > RenderSettings Class : Settings Field

Glossary Item Box

Settings for rendering extensions.

Syntax

Visual Basic (Declaration)
Public Settings As Dictionary(Of String,String)
C#
public Dictionary<string,string> Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderSettings Class
RenderSettings Members


GrapeCity.ActiveReports.Dashboard.Design Namespace

GrapeCity.ActiveReports.Dashboard.Design Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Dashboard.Design Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ReportItemDesignerBase | Represents the base class for dashboard report item designers.

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


ReportItemDesignerBase Class

[image]
ActiveReports 13
ReportItemDesignerBase Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace : ReportItemDesignerBase Class

Glossary Item Box

Represents the base class for dashboard report item designers.

Object Model

ReportItemDesignerBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportItemDesignerBase
   Inherits GrapeCity.ActiveReports.Design.DdrDesigner.Designers.CustomReportItemDesigner
C#
public abstract class ReportItemDesignerBase : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.CustomReportItemDesigner

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
GrapeCity.ActiveReports.Dashboard.Design.ReportItemDesignerBase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Members
GrapeCity.ActiveReports.Dashboard.Design Namespace


ReportItemDesignerBase Class Members

[image]
ActiveReports 13
ReportItemDesignerBase Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace : ReportItemDesignerBase Class

Glossary Item Box

The following tables list the members exposed by ReportItemDesignerBase.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | Initialize | Overridden. Initializes the designer component and adds the properties specified for it.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PostFilterProperties | Overridden. Adds the custom property collection to the property editor.
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportItemDesignerBase Class
GrapeCity.ActiveReports.Dashboard.Design Namespace


ReportItemDesignerBase Class Methods

[image]
ActiveReports 13
ReportItemDesignerBase Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace : ReportItemDesignerBase Class

Glossary Item Box

For a list of all members of this type, see ReportItemDesignerBase members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | Initialize | Overridden. Initializes the designer component and adds the properties specified for it.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PostFilterProperties | Overridden. Adds the custom property collection to the property editor.
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportItemDesignerBase Class
GrapeCity.ActiveReports.Dashboard.Design Namespace


Initialize Method

[image]
ActiveReports 13
Initialize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Initialize Method

component

Glossary Item Box

Initializes the designer component and adds the properties specified for it.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Initialize( _
   ByVal component As IComponent _
)
C#
public override void Initialize(
   IComponent component
)

Parameters

component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PostFilterProperties Method

[image]
ActiveReports 13
PostFilterProperties Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PostFilterProperties Method

properties

Glossary Item Box

Adds the custom property collection to the property editor.

Syntax

Visual Basic (Declaration)
Public Overrides Sub PostFilterProperties( _
   ByVal properties As IDictionary _
)
C#
public override void PostFilterProperties(
   IDictionary properties
)

Parameters

properties

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GrapeCity.ActiveReports.Design Namespace

GrapeCity.ActiveReports.Design Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Design namespace contains the designer classes and designer controls.

Classes

 | Class | Description
Class | ChartDataSourceClickedEventArgs | Provides data for the Designer.ChartDataSourceClicked event.
Class | ContextMenuOpenArgs | The ContextMenuOpenArgs class provides data needed for the ContextMenuOpen event.
Class | DataSourceIconClickedEventArgs | This class retrieves the value from the DialogResult after the data source icon is clicked.
Class | DataSourceIconClickEventArgs | DatasourceClickEventArgs holds the cancel value to stop the default Datasource dialog from showing.
Class | Designer | The Designer class is the base class for the End-User Report Designer control.
Class | DesignerTabChangedEventArgs | Contains the active tab information.
Class | EditModeEnteringEventArgs | This class retrieves the type of control to be edited when the user enters edit mode, allowing you to cancel editing for specified types of controls.
Class | EditModeExitEventArgs | This class retrieves the type of control edited when the user exits edit mode.
Class | LayerList | ActiveReports Layer List.
Class | LayerSelectionChangedEventArgs | Provides data for the SelectionChanged event of the LayerList
Class | LayoutChangedArgs | The LayoutChangedArgs class provides data required for the LayoutChanged event.
Class | LayoutChangingArgs | The LayoutChangingArgs class provides data required for the LayoutChanging event.
Class | Selection | Indicates the currently selected items in the report layout.
Class | ServerConnectionChangedEventArgs | Information about connection with ARS
Class | UndoManager | The UndoManager class allows users to undo and redo changes.

Interfaces

 | Interface | Description
Interface | ITrackSelectionService | Defines the common interface that enables the transmission of events related to change in selection in the host environment.
Interface | IVsPackageIntegration | Provides an interface for the IVsPackageIntegration service.

Delegates

 | Delegate | Description
Delegate | ContextMenuOpenEventHandler | Represents a method that handles the ContextMenuOpen event.
Delegate | DataSourceIconClickedEventHandler | Represents a method that handles the DataSourceIconClicked event.
Delegate | DataSourceIconClickEventHandler | Represents a method that handles the DataSourceIconClick event.
Delegate | DesignerTabChangedEventHandler | Represents the method that handles the event, containing the active tab information.
Delegate | EditModeEnteringEventHandler | Represents a method that handles the EditModeEntering event.
Delegate | EditModeExitEventHandler | Represents a method that handles the EditModeExit event.
Delegate | LayoutChangedEventHandler | Represents a method that handles the LayoutChanged event.
Delegate | LayoutChangingEventHandler | Represents a method that handles the LayoutChanging method.
Delegate | ScriptChangedEventHandler | Represents a method that handles the ScriptChanged event.
Delegate | SelectionChangedEventHandler | Represents a method that handles the SelectionChanged event.
Delegate | ServerConnectionChangedEventHandler | Delegate for ServerConnectionChanged event
Delegate | StatusChangedEventHandler | Represents a method that handles the StatusChanged event.
Delegate | ToolboxItemChangedEventHandler | Represents a method that will handle the ToolboxItemChanged event.

Enumerations

 | Enumeration | Description
Enumeration | ContextMenuTypes | Specifies the type of menu that will be opened for this sourceObject.
Enumeration | DebugMode | Specifies the type of debugging.
Enumeration | DesignerAction | List of available designer commands (actions)
Enumeration | DesignerReportType | Available report types.
Enumeration | DesignerTab | Lists the available designer tab options.
Enumeration | DesignerToolStrips | Enumeration of the types of tool strips to use with the designer.
Enumeration | ExitType | Specifies the action to perform when the user exits edit mode.
Enumeration | GridMode | Specifies the type of the grid to draw in the designer surface.
Enumeration | LayoutChangeType | Enumeration of change settings for the report layout.
Enumeration | LayoutMode | Enumeration of modes for laying out controls on the report designer.
Enumeration | MeasurementUnits | Specifies the ruler measurement units.
Enumeration | MouseMode | Available designer MouseMode types.
Enumeration | PageReportDesignerActions | Controls the accessibility of actions of FplTabControl.
Enumeration | ReportExplorerNodes | The visibility of the nodes in ReportExplorer
Enumeration | ToolPanelButton | Controls the visibility of ToolPanelButton controls on the Designer.

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


ChartDataSourceClickedEventArgs Class

[image]
ActiveReports 13
ChartDataSourceClickedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

Glossary Item Box

Provides data for the Designer.ChartDataSourceClicked event.

Object Model

ChartDataSourceClickedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ChartDataSourceClickedEventArgs
   Inherits System.EventArgs
C#
public sealed class ChartDataSourceClickedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


ChartDataSourceClickedEventArgs Class Members

[image]
ActiveReports 13
ChartDataSourceClickedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ChartDataSourceClickedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ChartDataSourceClickedEventArgs Constructor | Initializes a new instance of the ChartDataSourceClickedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Indicates that the default action should be skipped.
Public Property | Chart | Provides access to the control.
Top

See Also

Reference

ChartDataSourceClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ChartDataSourceClickedEventArgs Constructor

[image]
ActiveReports 13
ChartDataSourceClickedEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : ChartDataSourceClickedEventArgs Constructor

control
Control whose data source icon is clicked.

Glossary Item Box

Initializes a new instance of the ChartDataSourceClickedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As ChartControl _
)
C#
public ChartDataSourceClickedEventArgs(
   ChartControl control
)

Parameters

control
Control whose data source icon is clicked.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


ChartDataSourceClickedEventArgs Class Properties

[image]
ActiveReports 13
ChartDataSourceClickedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ChartDataSourceClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Indicates that the default action should be skipped.
Public Property | Chart | Provides access to the control.
Top

See Also

Reference

ChartDataSourceClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 13
Cancel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : Cancel Property

Glossary Item Box

Indicates that the default action should be skipped.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


Chart Property

[image]
ActiveReports 13
Chart Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : Chart Property

Glossary Item Box

Provides access to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Chart As ChartControl
C#
public ChartControl Chart {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


ContextMenuOpenArgs Class

[image]
ActiveReports 13
ContextMenuOpenArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

Glossary Item Box

The ContextMenuOpenArgs class provides data needed for the ContextMenuOpen event.

Object Model

ContextMenuOpenArgs Class

Syntax

Visual Basic (Declaration)
Public Class ContextMenuOpenArgs
   Inherits System.EventArgs
C#
public class ContextMenuOpenArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ContextMenuOpenArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Members
GrapeCity.ActiveReports.Design Namespace


ContextMenuOpenArgs Class Members

[image]
ActiveReports 13
ContextMenuOpenArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

Glossary Item Box

The following tables list the members exposed by ContextMenuOpenArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default menu handler should be cancelled.
Public Property | MenuType | Specifies the type of menu that will be opened for this sourceObject.
Public Property | Source | A reference to the object that is opening the menu.
Top

See Also

Reference

ContextMenuOpenArgs Class
GrapeCity.ActiveReports.Design Namespace


ContextMenuOpenArgs Class Properties

[image]
ActiveReports 13
ContextMenuOpenArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

Glossary Item Box

For a list of all members of this type, see ContextMenuOpenArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default menu handler should be cancelled.
Public Property | MenuType | Specifies the type of menu that will be opened for this sourceObject.
Public Property | Source | A reference to the object that is opening the menu.
Top

See Also

Reference

ContextMenuOpenArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 13
Cancel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : Cancel Property

Glossary Item Box

Determines whether the default menu handler should be cancelled.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Property Value

Boolean value.

Remarks

This parameter should be set to True to disable or replace built-in context menus.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members


MenuType Property

[image]
ActiveReports 13
MenuType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : MenuType Property

Glossary Item Box

Specifies the type of menu that will be opened for this sourceObject.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MenuType As ContextMenuTypes
C#
public ContextMenuTypes MenuType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members
ActiveReports.Design6~GrapeCity.ActiveReports.Design.ContextMenuTypes


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : Source Property

Glossary Item Box

A reference to the object that is opening the menu.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As Object
C#
public object Source {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members


DataSourceIconClickedEventArgs Class

[image]
ActiveReports 13
DataSourceIconClickedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

Glossary Item Box

This class retrieves the value from the DialogResult after the data source icon is clicked.

Object Model

DataSourceIconClickedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceIconClickedEventArgs
   Inherits System.EventArgs
C#
public class DataSourceIconClickedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventArgs Class Members

[image]
ActiveReports 13
DataSourceIconClickedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

Glossary Item Box

The following tables list the members exposed by DataSourceIconClickedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataSourceIconClickedEventArgs Constructor | Initializes a new instance of the DatasourceClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | DialogResult | Gets the value from the data source dialog.
Top

See Also

Reference

DataSourceIconClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventArgs Constructor

[image]
ActiveReports 13
DataSourceIconClickedEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickedEventArgs Class : DataSourceIconClickedEventArgs Constructor

dialogResult
The enumerated DialogResult value returned from the dialog.

Glossary Item Box

Initializes a new instance of the DatasourceClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dialogResult As DialogResult _
)
C#
public DataSourceIconClickedEventArgs(
   DialogResult dialogResult
)

Parameters

dialogResult
The enumerated DialogResult value returned from the dialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickedEventArgs Class
DataSourceIconClickedEventArgs Members


DataSourceIconClickedEventArgs Class Properties

[image]
ActiveReports 13
DataSourceIconClickedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataSourceIconClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | DialogResult | Gets the value from the data source dialog.
Top

See Also

Reference

DataSourceIconClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DialogResult Property

[image]
ActiveReports 13
DialogResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickedEventArgs Class : DialogResult Property

Glossary Item Box

Gets the value from the data source dialog.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DialogResult As DialogResult
C#
public DialogResult DialogResult {get;}

Property Value

An enumerated System.Windows.Forms.DialogResult value:

  • None
  • OK
  • Cancel
  • Abort
  • Retry
  • Ignore
  • Yes
  • No

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickedEventArgs Class
DataSourceIconClickedEventArgs Members


DataSourceIconClickEventArgs Class

[image]
ActiveReports 13
DataSourceIconClickEventArgs Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

Glossary Item Box

DatasourceClickEventArgs holds the cancel value to stop the default Datasource dialog from showing.

Object Model

DataSourceIconClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceIconClickEventArgs
   Inherits System.EventArgs
C#
public class DataSourceIconClickEventArgs : System.EventArgs

Example

C# Copy Code
//Create the DataSourceClick event handler
this.arDesigner.DataSourceIconClick += new DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick);

//Create the event handling method to respond to the user clicking the Datasource Icon
//Set Cancel to True to stop the default Datasource dialog from showing
private void arDesigner_DataSourceIconClick(object sender, DataSourceIconClickArgs e)
{
    e.Cancel = true;

    Form f = new Form();
    f.ShowDialog(this);

    // Add custom code to modify the report data source based on user preference
}
Visual Basic Copy Code
'Create the DataSourceClick event handler
Me.arDesigner.DataSourceIconClick += New DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick)

'Create the event handling method to respond to the user clicking the Datasource Icon
'Set Cancel to True to stop the default Datasource dialog from showi
Private Sub arDesigner_DataSourceIconClick(ByVal sender As Object, ByVal e As DataSourceIconClickArgs)
    e.Cancel = True

    Dim f As Form = New Form()
    f.ShowDialog(Me)

    ' Add custom code to modify the report data source based on user preference
End Sub

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventArgs Class Members

[image]
ActiveReports 13
DataSourceIconClickEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

Glossary Item Box

The following tables list the members exposed by DataSourceIconClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataSourceIconClickEventArgs Constructor | Initializes a new instance of the DatasourceClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
Top

See Also

Reference

DataSourceIconClickEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventArgs Constructor

[image]
ActiveReports 13
DataSourceIconClickEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickEventArgs Class : DataSourceIconClickEventArgs Constructor

Glossary Item Box

Initializes a new instance of the DatasourceClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataSourceIconClickEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickEventArgs Class
DataSourceIconClickEventArgs Members


DataSourceIconClickEventArgs Class Properties

[image]
ActiveReports 13
DataSourceIconClickEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataSourceIconClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
Top

See Also

Reference

DataSourceIconClickEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 13
Cancel Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickEventArgs Class : Cancel Property

Glossary Item Box

Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Remarks

For End-User Designer only. The DataSourceClick event must be attached to the Designer in order for this to take effect. If the value is set to True, the default Datasource dialog will not open when the Datasource Icon is clicked in End-User Designer. In a typical scenario a custom dialog can be showed instead.

Example

C# Copy Code
//Create the DataSourceClick event handler
this.arDesigner.DataSourceIconClick += new DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick);

//Create the event handling method to respond to the user clicking the Datasource Icon
//Set Cancel to True to stop the default Datasource dialog from showing
private void arDesigner_DataSourceIconClick(object sender, DataSourceIconClickArgs e)
{
    e.Cancel = true;

    Form f = new Form();
    f.ShowDialog(this);

    // Add custom code to modify the report data source based on user preference
}
Visual Basic Copy Code
'Create the DataSourceClick event handler
Me.arDesigner.DataSourceIconClick += New DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick)

'Create the event handling method to respond to the user clicking the Datasource Icon
'Set Cancel to True to stop the default Datasource dialog from showi
Private Sub arDesigner_DataSourceIconClick(ByVal sender As Object, ByVal e As DataSourceIconClickArgs)
    e.Cancel = True

    Dim f As Form = New Form()
    f.ShowDialog(Me)

    ' Add custom code to modify the report data source based on user preference
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickEventArgs Class
DataSourceIconClickEventArgs Members


Designer Class

[image]
ActiveReports 13
Designer Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

The Designer class is the base class for the End-User Report Designer control.

Object Model

Designer Class

Syntax

Visual Basic (Declaration)
Public Class Designer
   Inherits System.Windows.Forms.UserControl
C#
public class Designer : System.Windows.Forms.UserControl

Remarks

The designer control is used to customize report layouts at run time.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
this.designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches;
this.designer1.DrawGrid = true;
this.designer1.GridX = 16;
this.designer1.GridY = 16;
this.designer1.LockControls = false;
this.designer1.ShowDataSourceIcon = true;
this.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid;
this.designer1.ToolBoxItem = null;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
    Me.Designer1.LockControls = False
    Me.Designer1.ShowDataSourceIcon = True
    Me.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid
    Me.Designer1.ToolBoxItem = Nothing
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Designer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Members
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


Designer Class Members

[image]
ActiveReports 13
Designer Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

The following tables list the members exposed by Designer.

Public Constructors

 | Name | Description
Public Constructor | Designer Constructor | Creates a new Instance of Designer class.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ColorTheme | Gets or sets the colors of the report designer's section bands and ruler.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerUnits | Gets or sets the measurement units for the designer.
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | DrawGrid | Gets or sets a value indicating whether a grid is drawn in the designer.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | EnableOleObject | Enable or disable the OleObject control in the Visual Studio Toolbox.
Public Property | EnablePreview | Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.
Public Property | EnableScripting | Sets or returns a value indicating whether scripting is enabled for the designer.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | GridMode | Gets or sets the GridMode in the designer.
Public Property | GridX | Determines how coarse the designer grid should be.
Public Property | GridY | Determines how coarse the designer grid should be.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutMode | Gets or sets the value that determines how the end user can lay out controls on the report design surface.
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | LockControls | Specifies whether the controls are locked in place.
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageReportDesignerActions | Specify the allowed actions in PageReport Designer.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Gets or sets the number of pages of report that should be generated for preview.
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | PromptUser | Determines whether to display a dialog when a control is deleted.
Public Property | PropertyGrid | Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Report | Returns a reference to the designer's report object.
Public Property | ReportPartsDirectory | Gets or sets the path to load reports in to the report items library. By default it's current user's Documents folder.
Public Property | ReportTabsPanelVisible | Shows/Hides the Report Design/Script/Preview tabs panel.
Public Property | ReportTabsVisible | Sets or returns a value indicating whether the report tabs are shown below the designer.
Public Property | ReportType | Temporary report type indicator. Used by Report Explorer and (potentially) by Toolbox.
Public Property | ResourceLocator | Gets or sets the resource locator implementation that used to locate the custom resources.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Selection | Returns the collection of selected objects.
Public Property | ShowDataSourceIcon | Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SnapGrid | Sets or returns a value indicating whether the controls should be snapped to the grid points.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Toolbox | Gets or Sets the IToolboxService for the Report Designer.
Public Property | ToolBoxItem | Sets the type of control in the toolbox.
Public Property | ToolPanel | Gets or sets the value that indicate the tools that are available in the designer tool panel.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UndoManager | The UndoManager allows users to undo and redo changes.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the zoom value for the Designer.
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | CreateToolStrips | Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.
Public Method | Dispose | Disposes objects referenced by the designer. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | ExecuteAction | Overloaded. Executes a specified DesignerAction command.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | NewReport | Overloaded. Initializes the designer with a new report layout.
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToSection | Returns the screen coordinates of a specified point in a given section.
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | QueryActionChecked | Queries the object for the checked status of one or more commands.
Public Method | QueryActionEnabled | Queries the object for the enabled status of one or more commands.
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | SaveReport | Overloaded. Saves a report XML layout to the filename or stream specified.
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SectionAt | Returns the section at the specified point.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | ChartDataSourceClicked | Fires after a chart data source item has been clicked.
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuOpen | Fires before a context menu is opened.
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DataSourceIconClick | Raised when the Datasource icon is clicked in the designer.
Public Event | DataSourceIconClicked | Gets the value from the DialogResult when the data source icon is clicked.
Public Event | DesignerTabChanged | Raised when the designer tab changes.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EditModeEntering | This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.
Public Event | EditModeExit | This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | LayoutChanged | Raised when the layout is changed.
Public Event | LayoutChanging | Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocateCredentials | Occurs when the report is previewed and credentials are needed.
Public Event | LocateDataSource | Occurs when a data provider of the previewed report needs to locate the data at runtime.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ReportChanged | Notifies about report changes.
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ScriptChanged | Raised when the script for a report in the End User Report Designer is changed.
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Raised when the selection changes.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StatusChanged | This event is raised for each change in the status of the designer actions.
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ToolboxItemChanged | Raised when a toolbox control is drawn on the Report Designer.
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


Designer Constructor

[image]
ActiveReports 13
Designer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Designer Constructor

Glossary Item Box

Creates a new Instance of Designer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Designer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Designer Class Methods

[image]
ActiveReports 13
Designer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

For a list of all members of this type, see Designer members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | CreateToolStrips | Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.
Public Method | Dispose | Disposes objects referenced by the designer. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | ExecuteAction | Overloaded. Executes a specified DesignerAction command.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | NewReport | Overloaded. Initializes the designer with a new report layout.
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToSection | Returns the screen coordinates of a specified point in a given section.
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | QueryActionChecked | Queries the object for the checked status of one or more commands.
Public Method | QueryActionEnabled | Queries the object for the enabled status of one or more commands.
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | SaveReport | Overloaded. Saves a report XML layout to the filename or stream specified.
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SectionAt | Returns the section at the specified point.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


CreateToolStrips Method

[image]
ActiveReports 13
CreateToolStrips Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateToolStrips Method

strips
The ToolStrip or ToolStripContainer control in which to create the ToolStrips.

Glossary Item Box

Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.

Syntax

Visual Basic (Declaration)
Public Function CreateToolStrips( _
   ByVal ParamArray strips() As DesignerToolStrips _
) As ToolStrip()
C#
public ToolStrip[] CreateToolStrips(
   params DesignerToolStrips[] strips
)

Parameters

strips
The ToolStrip or ToolStripContainer control in which to create the ToolStrips.

Example

Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
        Dim menuStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)(0)
        Dim editStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)(0)
        Dim formatStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)(0)
        Dim layoutStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)(0)
        Dim reportStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)(0)
        Dim undoStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)(0)
        Dim zoomStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)(0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(menuStrip, 0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(editStrip, 1)
        Me.ToolStripContainer1.TopToolStripPanel.Join(formatStrip, 2)
        Me.ToolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3)
        Me.ToolStripContainer1.TopToolStripPanel.Join(reportStrip, 4)
        Me.ToolStripContainer1.TopToolStripPanel.Join(undoStrip, 5)
        Me.ToolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6)
    End Sub
C# Copy Code
private void designer1_Load(object sender, EventArgs e)
       {
           ToolStrip menuStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)[0];
           ToolStrip editStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)[0];
           ToolStrip formatStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)[0];
           ToolStrip layoutStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)[0];
           ToolStrip reportStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)[0];
           ToolStrip undoStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)[0];
           ToolStrip zoomStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)[0];
           this.toolStripContainer1.TopToolStripPanel.Join(menuStrip, 0);
           this.toolStripContainer1.TopToolStripPanel.Join(editStrip, 1);
           this.toolStripContainer1.TopToolStripPanel.Join(formatStrip, 2);
           this.toolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3);
           this.toolStripContainer1.TopToolStripPanel.Join(reportStrip, 4);
           this.toolStripContainer1.TopToolStripPanel.Join(undoStrip, 5);
           this.toolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6);
       }

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ExecuteAction Method

[image]
ActiveReports 13
ExecuteAction Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ExecuteAction Method

Glossary Item Box

Executes a specified DesignerAction command.

Overload List

Overload | Description
ExecuteAction(DesignerAction) | Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.
ExecuteAction(DesignerAction,Object) | Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.

Remarks

This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.

Example

C# Copy Code
private void mnuLoadLayout_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.FileOpen);
}

private void mnuSaveLayout_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.FileSave);
}

private void mnuPageSetup_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.ReportSettings);
}
Visual Basic Copy Code
Private Sub mnuLoadLayout_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuLoadLayout.Click
    Me.Designer1.ExecuteAction(DesignerAction.FileOpen)
End Sub

Private Sub mnuSaveLayout_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuSaveLayout.Click
    Me.Designer1.ExecuteAction(DesignerAction.FileSave)
End Sub

Private Sub mnuPageSetup_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuPageSetup.Click
    Me.Designer1.ExecuteAction(DesignerAction.ReportSettings)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
DesignerAction Enumeration

Walkthroughs

Creating a Basic End User Report Designer


ExecuteAction(DesignerAction) Method

[image]
ActiveReports 13
ExecuteAction(DesignerAction) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ExecuteAction Method : ExecuteAction(DesignerAction) Method

action
DesignerAction

Glossary Item Box

Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExecuteAction( _
   ByVal action As DesignerAction _
)
C#
public void ExecuteAction(
   DesignerAction action
)

Parameters

action
DesignerAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


ExecuteAction(DesignerAction,Object) Method

[image]
ActiveReports 13
ExecuteAction(DesignerAction,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ExecuteAction Method : ExecuteAction(DesignerAction,Object) Method

action
DesignerAction
parameter
parameter

Glossary Item Box

Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExecuteAction( _
   ByVal action As DesignerAction, _
   ByVal parameter As Object _
)
C#
public void ExecuteAction(
   DesignerAction action,
   object parameter
)

Parameters

action
DesignerAction
parameter
parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


NewReport Method

[image]
ActiveReports 13
NewReport Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : NewReport Method

Glossary Item Box

Initializes the designer with a new report layout.

Overload List

Overload | Description
NewReport() | Initializes the designer with a new report layout.
NewReport(DesignerReportType) | Initializes the designer with a new report layout with specified type.

Example

C# Copy Code
/// <summary>
/// NewReport - an Interface function from IPlugInHost
/// </summary>
/// <param name="name">Name to use for the Document</param>
/// <returns>Current report object in the designer</returns>
public object NewReport(string name)
{
    try
    {
        this.ardMain.NewReport();
        this.ardMain.Report.Document.Name = name;
        return this.ardMain.Report;
    }
    catch(GrapeCity.ActiveReports.ReportException)
    {
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports");
        return null;
    }

}
Visual Basic Copy Code
'NewReport - an Interface function from IPlugInHost
'Parameter Name: name - Name to use for the Document
'Returns: Current report object in the designer
Public Function NewReport(ByVal name As String) As Object Implements IPlugInHost.NewReport
    Try
        Me.ardMain.NewReport()
        Me.ardMain.Report.Document.Name = name
        Return Me.ardMain.Report
    Catch ex As GrapeCity.ActiveReports.ReportException
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports")
        Return Nothing
    End Try
End Function 'NewReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


NewReport() Method

[image]
ActiveReports 13
NewReport() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > NewReport Method : NewReport() Method

Glossary Item Box

Initializes the designer with a new report layout.

Syntax

Visual Basic (Declaration)
Public Overloads Sub NewReport()
C#
public void NewReport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


NewReport(DesignerReportType) Method

[image]
ActiveReports 13
NewReport(DesignerReportType) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > NewReport Method : NewReport(DesignerReportType) Method

type
Section or Page report.

Glossary Item Box

Initializes the designer with a new report layout with specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Sub NewReport( _
   ByVal type As DesignerReportType _
)
C#
public void NewReport(
   DesignerReportType type
)

Parameters

type
Section or Page report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


PointToSection Method

[image]
ActiveReports 13
PointToSection Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PointToSection Method

section
The section that contains the specified point.
point
Point within designer coordinates

Glossary Item Box

Returns the screen coordinates of a specified point in a given section.

Syntax

Visual Basic (Declaration)
Public Function PointToSection( _
   ByVal section As Object, _
   ByVal point As Point _
) As Point
C#
public Point PointToSection(
   object section,
   Point point
)

Parameters

section
The section that contains the specified point.
point
Point within designer coordinates

Return Value

Point within a section with

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


QueryActionChecked Method

[image]
ActiveReports 13
QueryActionChecked Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryActionChecked Method

action
DesignerAction Types

Glossary Item Box

Queries the object for the checked status of one or more commands.

Syntax

Visual Basic (Declaration)
Public Function QueryActionChecked( _
   ByVal action As DesignerAction _
) As Boolean
C#
public bool QueryActionChecked(
   DesignerAction action
)

Parameters

action
DesignerAction Types

Example

C# Copy Code
/// <summary>
/// SetStatus - Updates a toolbutton's status, based on a designer action
/// </summary>
/// <param name="action">DesignerAction to take in string format</param>
/// <param name="toolButton">ToolButton to update</param>
private void SetStatus(string action,System.Windows.Forms.ToolBarButton toolButton)
{
    DesignerAction daAction = GetActionFromString(action);
    //Do the following if the DesignerAction isn't a FileOpen
    if(daAction != DesignerAction.FileOpen)
    {
        //Set toolButton attributes based on the Designer Action
        toolButton.Enabled = this.ardMain.QueryActionEnabled(daAction);
        toolButton.Pushed = this.ardMain.QueryActionChecked(daAction);
    }
}
Visual Basic Copy Code
'SetStatus - Updates a toolbutton's status, based on a designer action
'Parameter Name: action - DesignerAction to take in string format
'Parameter Name: toolButton - ToolButton to update
Private Sub SetStatus(ByVal action As String, ByVal toolButton As System.Windows.Forms.ToolBarButton)
    Dim daAction As DesignerAction = GetActionFromString(action)
    'Do the following if the DesignerAction isn't a FileOpen
    If daAction <> DesignerAction.FileOpen Then
        'Set toolButton attributes based on the Designer Action
        toolButton.Enabled = Me.ardMain.QueryActionEnabled(daAction)
        toolButton.Pushed = Me.ardMain.QueryActionChecked(daAction)
    End If
End Sub 'SetStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
DesignerAction Enumeration


QueryActionEnabled Method

[image]
ActiveReports 13
QueryActionEnabled Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryActionEnabled Method

action
DesignerAction Types

Glossary Item Box

Queries the object for the enabled status of one or more commands.

Syntax

Visual Basic (Declaration)
Public Function QueryActionEnabled( _
   ByVal action As DesignerAction _
) As Boolean
C#
public bool QueryActionEnabled(
   DesignerAction action
)

Parameters

action
DesignerAction Types

Return Value

True, if the enabled status is true, else False.

Example

C# Copy Code
/// <summary>
/// SetStatus - Updates a toolbutton's status, based on a designer action
/// </summary>
/// <param name="action">DesignerAction to take in string format</param>
/// <param name="toolButton">ToolButton to update</param>
private void SetStatus(string action,System.Windows.Forms.ToolBarButton toolButton)
{
    DesignerAction daAction = GetActionFromString(action);
    //Do the following if the DesignerAction isn't a FileOpen
    if(daAction != DesignerAction.FileOpen)
    {
        //Set toolButton attributes based on the Designer Action
        toolButton.Enabled = this.ardMain.QueryActionEnabled(daAction);
        toolButton.Pushed = this.ardMain.QueryActionChecked(daAction);
    }
}
Visual Basic Copy Code
'SetStatus - Updates a toolbutton's status, based on a designer action
'Parameter Name: action - DesignerAction to take in string format
'Parameter Name: toolButton - ToolButton to update
Private Sub SetStatus(ByVal action As String, ByVal toolButton As System.Windows.Forms.ToolBarButton)
    Dim daAction As DesignerAction = GetActionFromString(action)
    'Do the following if the DesignerAction isn't a FileOpen
    If daAction <> DesignerAction.FileOpen Then
        'Set toolButton attributes based on the Designer Action
        toolButton.Enabled = Me.ardMain.QueryActionEnabled(daAction)
        toolButton.Pushed = Me.ardMain.QueryActionChecked(daAction)
    End If
End Sub 'SetStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
DesignerAction Enumeration


SaveReport Method

[image]
ActiveReports 13
SaveReport Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SaveReport Method

Glossary Item Box

Saves a report XML layout to the filename or stream specified.

Overload List

Overload | Description
SaveReport(FileInfo) | Saves a report layout as an XML file to the specified file name.
SaveReport(Stream) | Saves a report layout as an XML file to the specified Stream.
SaveReport(XmlWriter) | Saves a report XML layout to the writer.

Example

C# Copy Code
// SetReportViaStream - sets a report design stream to the Designer
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
Visual Basic Copy Code
'SetReportViaStream - sets a report design stream to the Designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SaveReport(FileInfo) Method

[image]
ActiveReports 13
SaveReport(FileInfo) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(FileInfo) Method

file
Specifies the File object to contain the report layout.

Glossary Item Box

Saves a report layout as an XML file to the specified file name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveReport( _
   ByVal file As FileInfo _
)
C#
public void SaveReport(
   FileInfo file
)

Parameters

file
Specifies the File object to contain the report layout.

Example

C# Copy Code
/// <summary>
/// SaveReportFile - opens the Save File Dialog to save the report out to an rpx file
/// </summary>
private void SaveReportFile()
{
    //If the Report was saved once, we already have a valid path, call Save on it.
    if(this._alreadySaved)
    {
        this.ardMain.SaveReport(this._savedPath);
    }
    else
    {
        //Open Save dialog to retrieve a file and path to save to
        this.dlgSaveFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx";
        this.dlgSaveFile.FileName = "Report.rpx";
        this.dlgSaveFile.FilterIndex = 2;
        this.dlgSaveFile.RestoreDirectory = true ;
        this.dlgSaveFile.DefaultExt = ".rpx";

        if(dlgSaveFile.ShowDialog() == DialogResult.OK)
        {
            //Add new saved report to the recent documents cache
            if(System.IO.File.Exists(Application.StartupPath + @"\Settings\recent.xml"))
            {
                DataSet _reportsDS = new DataSet();
                _reportsDS.Locale = CultureInfo.InvariantCulture;
                _reportsDS.ReadXml(Application.StartupPath + @"\Settings\recent.xml");
                DataTable _reportsTable = _reportsDS.Tables["Reports"];
                _reportsTable.Locale = CultureInfo.InvariantCulture;

                //Create a Row
                DataRow _rowReports = _reportsTable.NewRow();
                object [] _myArray = new object[2];
                this._savedPath = this.dlgSaveFile.FileName;
                _myArray[0] = this.dlgSaveFile.FileName;
                _myArray[1] = System.DateTime.Now;
                _rowReports.ItemArray = _myArray;
                _reportsTable.Rows.Add(_rowReports);
                _reportsDS.WriteXml(Application.StartupPath + @"\Settings\recent.xml", XmlWriteMode.WriteSchema);
            }
            this.ardMain.SaveReport(this._savedPath);
        }
    }
}
Visual Basic Copy Code
'SaveReportFile - opens the Save File Dialog to save the report out to an rpx file
Private Sub SaveReportFile()
    'If the Report was saved once, we already have a valid path, call Save on it.
    If Me._alreadySaved Then
        Me.ardMain.SaveReport(Me._savedPath)
    Else
        'Open Save dialog to retrieve a file and path to save to
        Me.dlgSaveFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx"
        Me.dlgSaveFile.FileName = "Report.rpx"
        Me.dlgSaveFile.FilterIndex = 2
        Me.dlgSaveFile.RestoreDirectory = True
        Me.dlgSaveFile.DefaultExt = ".rpx"

        If dlgSaveFile.ShowDialog() = DialogResult.OK Then
            'Add new saved report to the recent documents cache
            If System.IO.File.Exists((Application.StartupPath + "\Settings\recent.xml")) Then
                Dim _reportsDS As New DataSet()
                _reportsDS.Locale = CultureInfo.InvariantCulture
                _reportsDS.ReadXml((Application.StartupPath + "\Settings\recent.xml"))
                Dim _reportsTable As DataTable = _reportsDS.Tables("Reports")
                _reportsTable.Locale = CultureInfo.InvariantCulture

                'Create a Row
                Dim _rowReports As DataRow = _reportsTable.NewRow()
                Dim _myArray(1) As Object
                Me._savedPath = Me.dlgSaveFile.FileName
                _myArray(0) = Me.dlgSaveFile.FileName
                _myArray(1) = System.DateTime.Now
                _rowReports.ItemArray = _myArray
                _reportsTable.Rows.Add(_rowReports)
                _reportsDS.WriteXml(Application.StartupPath + "\Settings\recent.xml", XmlWriteMode.WriteSchema)
            End If
            Me.ardMain.SaveReport(Me._savedPath)
        End If
    End If
End Sub 'SaveReportFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


SaveReport(Stream) Method

[image]
ActiveReports 13
SaveReport(Stream) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(Stream) Method

stream
Specifies the Stream object to contain the report layout.

Glossary Item Box

Saves a report layout as an XML file to the specified Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveReport( _
   ByVal stream As Stream _
)
C#
public void SaveReport(
   Stream stream
)

Parameters

stream
Specifies the Stream object to contain the report layout.

Example

C# Copy Code
/// <summary>
/// SetReportViaStream - sets a report design stream to the Designer
/// </summary>
/// <param name="memStream">Report Memory Stream to set to the designer</param>
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
Visual Basic Copy Code
'SetReportViaStream - sets a report design stream to the Designer
'Parameter Name: memStream - Report Memory Stream to set to the designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


SaveReport(XmlWriter) Method

[image]
ActiveReports 13
SaveReport(XmlWriter) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(XmlWriter) Method

writer
The writer used to save the report.

Glossary Item Box

Saves a report XML layout to the writer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveReport( _
   ByVal writer As XmlWriter _
)
C#
public void SaveReport(
   XmlWriter writer
)

Parameters

writer
The writer used to save the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


SectionAt Method

[image]
ActiveReports 13
SectionAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SectionAt Method

point
Screen point.

Glossary Item Box

Returns the section at the specified point.

Syntax

Visual Basic (Declaration)
Public Function SectionAt( _
   ByVal point As Point _
) As Object
C#
public object SectionAt(
   Point point
)

Parameters

point
Screen point.

Return Value

object

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Designer Class Properties

[image]
ActiveReports 13
Designer Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

For a list of all members of this type, see Designer members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ColorTheme | Gets or sets the colors of the report designer's section bands and ruler.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerUnits | Gets or sets the measurement units for the designer.
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | DrawGrid | Gets or sets a value indicating whether a grid is drawn in the designer.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | EnableOleObject | Enable or disable the OleObject control in the Visual Studio Toolbox.
Public Property | EnablePreview | Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.
Public Property | EnableScripting | Sets or returns a value indicating whether scripting is enabled for the designer.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | GridMode | Gets or sets the GridMode in the designer.
Public Property | GridX | Determines how coarse the designer grid should be.
Public Property | GridY | Determines how coarse the designer grid should be.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutMode | Gets or sets the value that determines how the end user can lay out controls on the report design surface.
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | LockControls | Specifies whether the controls are locked in place.
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageReportDesignerActions | Specify the allowed actions in PageReport Designer.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Gets or sets the number of pages of report that should be generated for preview.
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | PromptUser | Determines whether to display a dialog when a control is deleted.
Public Property | PropertyGrid | Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Report | Returns a reference to the designer's report object.
Public Property | ReportPartsDirectory | Gets or sets the path to load reports in to the report items library. By default it's current user's Documents folder.
Public Property | ReportTabsPanelVisible | Shows/Hides the Report Design/Script/Preview tabs panel.
Public Property | ReportTabsVisible | Sets or returns a value indicating whether the report tabs are shown below the designer.
Public Property | ReportType | Temporary report type indicator. Used by Report Explorer and (potentially) by Toolbox.
Public Property | ResourceLocator | Gets or sets the resource locator implementation that used to locate the custom resources.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Selection | Returns the collection of selected objects.
Public Property | ShowDataSourceIcon | Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SnapGrid | Sets or returns a value indicating whether the controls should be snapped to the grid points.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Toolbox | Gets or Sets the IToolboxService for the Report Designer.
Public Property | ToolBoxItem | Sets the type of control in the toolbox.
Public Property | ToolPanel | Gets or sets the value that indicate the tools that are available in the designer tool panel.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UndoManager | The UndoManager allows users to undo and redo changes.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the zoom value for the Designer.
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


ColorTheme Property

[image]
ActiveReports 13
ColorTheme Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ColorTheme Property

Glossary Item Box

Gets or sets the colors of the report designer's section bands and ruler.

Syntax

Visual Basic (Declaration)
Public Property ColorTheme As ColorTheme
C#
public ColorTheme ColorTheme {get; set;}

Remarks

Select an enumerated value for the color theme:

  • Normal
  • SystemTheme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DesignerUnits Property

[image]
ActiveReports 13
DesignerUnits Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DesignerUnits Property

Glossary Item Box

Gets or sets the measurement units for the designer.

Syntax

Visual Basic (Declaration)
Public Property DesignerUnits As MeasurementUnits
C#
public MeasurementUnits DesignerUnits {get; set;}

Property Value

Integer.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches;
    this.designer1.ToolBoxItem = null;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches
    Me.Designer1.ToolBoxItem = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
MeasurementUnits Enumeration


DrawGrid Property

[image]
ActiveReports 13
DrawGrid Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DrawGrid Property

Glossary Item Box

Gets or sets a value indicating whether a grid is drawn in the designer.

Syntax

Visual Basic (Declaration)
Public Property DrawGrid As Boolean
C#
public bool DrawGrid {get; set;}

Property Value

Boolean value.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EnableOleObject Property

[image]
ActiveReports 13
EnableOleObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnableOleObject Property

Glossary Item Box

Enable or disable the OleObject control in the Visual Studio Toolbox.

Syntax

Visual Basic (Declaration)
Public Property EnableOleObject As Boolean
C#
public bool EnableOleObject {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EnablePreview Property

[image]
ActiveReports 13
EnablePreview Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnablePreview Property

Glossary Item Box

Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.

Syntax

Visual Basic (Declaration)
Public Property EnablePreview As Boolean
C#
public bool EnablePreview {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EnableScripting Property

[image]
ActiveReports 13
EnableScripting Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnableScripting Property

Glossary Item Box

Sets or returns a value indicating whether scripting is enabled for the designer.

Syntax

Visual Basic (Declaration)
Public Property EnableScripting As Boolean
C#
public bool EnableScripting {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
ReportTabsVisible Property


GridMode Property

[image]
ActiveReports 13
GridMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridMode Property

Glossary Item Box

Gets or sets the GridMode in the designer.

Syntax

Visual Basic (Declaration)
Public Property GridMode As GridMode
C#
public GridMode GridMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GridX Property

[image]
ActiveReports 13
GridX Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridX Property

Glossary Item Box

Determines how coarse the designer grid should be.

Syntax

Visual Basic (Declaration)
Public Property GridX As Integer
C#
public int GridX {get; set;}

Property Value

An integer value that represents the number of horizontal grid points per ruler unit.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GridY Property

[image]
ActiveReports 13
GridY Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridY Property

Glossary Item Box

Determines how coarse the designer grid should be.

Syntax

Visual Basic (Declaration)
Public Property GridY As Integer
C#
public int GridY {get; set;}

Property Value

An integer value that represents the number of vertical grid points per ruler unit.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayoutMode Property

[image]
ActiveReports 13
LayoutMode Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutMode Property

Glossary Item Box

Gets or sets the value that determines how the end user can lay out controls on the report design surface.

Syntax

Visual Basic (Declaration)
Public Property LayoutMode As LayoutMode
C#
public LayoutMode LayoutMode {get; set;}

Remarks

Select from an enumerated value:

  • None allows free movement of controls.
  • SnapGrid snaps controls to the grid.
  • SnapLines snaps controls to lines showing alignment to other controls.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid;
}
VB.NET Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LockControls Property

[image]
ActiveReports 13
LockControls Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LockControls Property

Glossary Item Box

Specifies whether the controls are locked in place.

Syntax

Visual Basic (Declaration)
Public Property LockControls As Boolean
C#
public bool LockControls {get; set;}

Property Value

Boolean value. If True, the controls cannot be moved or sized. If False, the controls can be moved or sized.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
    this.designer1.LockControls = false;
    this.designer1.ShowDataSourceIcon = true;
    this.designer1.ToolBoxItem = null;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
    Me.Designer1.LockControls = False
    Me.Designer1.ShowDataSourceIcon = True
    Me.Designer1.ToolBoxItem = Nothing
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PageReportDesignerActions Property

[image]
ActiveReports 13
PageReportDesignerActions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PageReportDesignerActions Property

Glossary Item Box

Specify the allowed actions in PageReport Designer.

Syntax

Visual Basic (Declaration)
Public Property PageReportDesignerActions As PageReportDesignerActions
C#
public PageReportDesignerActions PageReportDesignerActions {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PreviewPages Property

[image]
ActiveReports 13
PreviewPages Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreviewPages Property

Glossary Item Box

Gets or sets the number of pages of report that should be generated for preview.

Syntax

Visual Basic (Declaration)
Public Property PreviewPages As Integer
C#
public int PreviewPages {get; set;}

Remarks

Note: This property does not determine the total number of pages generated when the report is run to completion. If this value is set to 0, all pages of the report is generated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PromptUser Property

[image]
ActiveReports 13
PromptUser Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PromptUser Property

Glossary Item Box

Determines whether to display a dialog when a control is deleted.

Syntax

Visual Basic (Declaration)
Public Property PromptUser As Boolean
C#
public bool PromptUser {get; set;}

Remarks

If set to true, the dialog is presented when a control is deleted at report design time.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PropertyGrid Property

[image]
ActiveReports 13
PropertyGrid Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PropertyGrid Property

Glossary Item Box

Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.

Syntax

Visual Basic (Declaration)
Public Property PropertyGrid As PropertyGrid
C#
public PropertyGrid PropertyGrid {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Report Property

[image]
ActiveReports 13
Report Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Report Property

Glossary Item Box

Returns a reference to the designer's report object.

Syntax

Visual Basic (Declaration)
Public Property Report As Object
C#
public object Report {get; set;}

Property Value

ActiveReport

Remarks

This report object is used to gain access to the layout and controls properties.

Example

C# Copy Code
public object NewReport(string name)
{
    try
    {
     this.ardMain.NewReport();
      GrapeCity.ActiveReports.SectionReport rpt = (GrapeCity.ActiveReports.SectionReport)this.ardMain.Report;
      rpt.Document.Name = name;
      return this.ardMain.Report;
     }

    catch(GrapeCity.ActiveReports.ReportException)
    {
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports");
        return null;
    }

}
Visual Basic Copy Code
Public Function NewReport(ByVal name As String) As Object Implements IPlugInHost.NewReport
    Try
        Me.ardMain.NewReport()
        Me.ardMain.Report.Document.Name = name
        Return Me.ardMain.Report
    Catch ex As GrapeCity.ActiveReports.ReportException
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports")
        Return Nothing
    End Try
End Function

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportPartsDirectory Property

[image]
ActiveReports 13
ReportPartsDirectory Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportPartsDirectory Property

Glossary Item Box

Gets or sets the path to load reports in to the report items library. By default it's current user's Documents folder.

Syntax

Visual Basic (Declaration)
Public Property ReportPartsDirectory As String
C#
public string ReportPartsDirectory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportTabsPanelVisible Property

[image]
ActiveReports 13
ReportTabsPanelVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportTabsPanelVisible Property

Glossary Item Box

Shows/Hides the Report Design/Script/Preview tabs panel.

Syntax

Visual Basic (Declaration)
Public Property ReportTabsPanelVisible As Boolean
C#
public bool ReportTabsPanelVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportTabsVisible Property

[image]
ActiveReports 13
ReportTabsVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportTabsVisible Property

Glossary Item Box

Sets or returns a value indicating whether the report tabs are shown below the designer.

Syntax

Visual Basic (Declaration)
Public Property ReportTabsVisible As Boolean
C#
public bool ReportTabsVisible {get; set;}

Remarks

The report tabs allow the user to choose between the preview, the script view and the designer view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
EnableScripting Property


ReportType Property

[image]
ActiveReports 13
ReportType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportType Property

Glossary Item Box

Temporary report type indicator. Used by Report Explorer and (potentially) by Toolbox.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportType As DesignerReportType
C#
public DesignerReportType ReportType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ResourceLocator Property

[image]
ActiveReports 13
ResourceLocator Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ResourceLocator Property

Glossary Item Box

Gets or sets the resource locator implementation that used to locate the custom resources.

Syntax

Visual Basic (Declaration)
Public Property ResourceLocator As GrapeCity.ActiveReports.ResourceLocator
C#
public GrapeCity.ActiveReports.ResourceLocator ResourceLocator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Selection Property

[image]
ActiveReports 13
Selection Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Selection Property

Glossary Item Box

Returns the collection of selected objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
C#
public Selection Selection {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ShowDataSourceIcon Property

[image]
ActiveReports 13
ShowDataSourceIcon Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ShowDataSourceIcon Property

Glossary Item Box

Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.

Syntax

Visual Basic (Declaration)
Public Property ShowDataSourceIcon As Boolean
C#
public bool ShowDataSourceIcon {get; set;}

Property Value

Boolean. If True, the data source icon will be visible; otherwise, False.

Remarks

You can use this property to hide the Data Source icon and provide your own interface for manipulating the report's data source.

Example

C# Copy Code
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.ShowDataSourceIcon = false;
}
Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.ShowDataSourceIcon = False
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SnapGrid Property

[image]
ActiveReports 13
SnapGrid Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SnapGrid Property

Glossary Item Box

Sets or returns a value indicating whether the controls should be snapped to the grid points.

Syntax

Visual Basic (Declaration)
Public Property SnapGrid As Boolean
C#
public bool SnapGrid {get; set;}

Property Value

Boolean value. If True, the controls are snapped to the grid points. If False, the controls can be sized and positioned freely.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Toolbox Property

[image]
ActiveReports 13
Toolbox Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Toolbox Property

Glossary Item Box

Gets or Sets the IToolboxService for the Report Designer.

Syntax

Visual Basic (Declaration)
Public Property Toolbox As IToolboxService
C#
public IToolboxService Toolbox {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ToolBoxItem Property

[image]
ActiveReports 13
ToolBoxItem Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolBoxItem Property

Glossary Item Box

Sets the type of control in the toolbox.

Syntax

Visual Basic (Declaration)
Public Property ToolBoxItem As Object
C#
public object ToolBoxItem {get; set;}

Remarks

This property is used to implement a custom toolbox toolbar.

Example

C# Copy Code
private GrapeCity.ActiveReports.Design.Toolbox.Toolbox arToolbox;
private void formDesigner_Load(object sender, System.EventArgs e)
{
    this.arDesigner.Toolbox = this.arToolbox;
    System.Drawing.Design.ToolboxItem tbItem = new System.Drawing.Design.ToolboxItem(typeof(GrapeCity.ActiveReports.Viewer.Win.Viewer));
    this.arToolbox.AddToolboxItem(tbItem, "General");
}
Visual Basic Copy Code
Private arToolbox As GrapeCity.ActiveReports.Design.Toolbox.Toolbox
Private Sub formDesigner_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.arDesigner.Toolbox = Me.arToolbox
    Dim tbItem As System.Drawing.Design.ToolboxItem = New System.Drawing.Design.ToolboxItem(GetType(GrapeCity.ActiveReports.Viewer.Win.Viewer))
    arToolbox.AddToolboxItem(tbItem, "General")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ToolPanel Property

[image]
ActiveReports 13
ToolPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolPanel Property

Glossary Item Box

Gets or sets the value that indicate the tools that are available in the designer tool panel.

Syntax

Visual Basic (Declaration)
Public Property ToolPanel As ToolPanelButton
C#
public ToolPanelButton ToolPanel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


UndoManager Property

[image]
ActiveReports 13
UndoManager Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : UndoManager Property

Glossary Item Box

The UndoManager allows users to undo and redo changes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UndoManager As UndoManager
C#
public UndoManager UndoManager {get;}

Example

C# Copy Code
private void mnuEditUndo_Click(object sender, System.EventArgs e)
{
    this.ardMain.UndoManager.Undo();
}
Visual Basic Copy Code
'mnuEditUndo_Click - calls the UndoManager.Undo command from the Designer
Private Sub mnuEditUndo_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles mnuEditUndo.Click
    Me.ardMain.UndoManager.Undo()
End Sub 'mnuEditUndo_Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Zoom Property

[image]
ActiveReports 13
Zoom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Zoom Property

Glossary Item Box

Gets or sets the zoom value for the Designer.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Single
C#
public float Zoom {get; set;}

Remarks

Values can range from >= 1.0f to <= 8.0f.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Designer Class Events

[image]
ActiveReports 13
Designer Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

Glossary Item Box

For a list of all members of this type, see Designer members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | ChartDataSourceClicked | Fires after a chart data source item has been clicked.
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuOpen | Fires before a context menu is opened.
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DataSourceIconClick | Raised when the Datasource icon is clicked in the designer.
Public Event | DataSourceIconClicked | Gets the value from the DialogResult when the data source icon is clicked.
Public Event | DesignerTabChanged | Raised when the designer tab changes.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EditModeEntering | This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.
Public Event | EditModeExit | This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | LayoutChanged | Raised when the layout is changed.
Public Event | LayoutChanging | Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocateCredentials | Occurs when the report is previewed and credentials are needed.
Public Event | LocateDataSource | Occurs when a data provider of the previewed report needs to locate the data at runtime.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ReportChanged | Notifies about report changes.
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ScriptChanged | Raised when the script for a report in the End User Report Designer is changed.
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Raised when the selection changes.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StatusChanged | This event is raised for each change in the status of the designer actions.
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ToolboxItemChanged | Raised when a toolbox control is drawn on the Report Designer.
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


ChartDataSourceClicked Event

[image]
ActiveReports 13
ChartDataSourceClicked Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ChartDataSourceClicked Event

Glossary Item Box

Fires after a chart data source item has been clicked.

Syntax

Visual Basic (Declaration)
Public Event ChartDataSourceClicked As EventHandler(Of ChartDataSourceClickedEventArgs)
C#
public event EventHandler<ChartDataSourceClickedEventArgs> ChartDataSourceClicked

Event Data

The event handler receives an argument of type ChartDataSourceClickedEventArgs containing data related to this event. The following ChartDataSourceClickedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Indicates that the default action should be skipped.
Chart | Provides access to the control.

Example

Visual Basic Copy Code
'Disable the Chart DataSource dialog
Private Sub arDesigner_ChartDataSourceClicked(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs) Handles arDesigner.ChartDataSourceClicked
    e.Cancel = True
    System.Windows.Forms.MessageBox.Show("The chart datasource can not be changed!")
End Sub
C# Copy Code
//Disable the Chart DataSource dialog
void arDesigner_ChartDataSourceClicked(object sender, ChartDataSourceClickedEventArgs e)
{
    e.Cancel = true;
    System.Windows.Forms.MessageBox.Show("The chart datasource can not be changed!");
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ContextMenuOpen Event

[image]
ActiveReports 13
ContextMenuOpen Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuOpen Event

Glossary Item Box

Fires before a context menu is opened.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuOpen As ContextMenuOpenEventHandler
C#
public event ContextMenuOpenEventHandler ContextMenuOpen

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DataSourceIconClick Event

[image]
ActiveReports 13
DataSourceIconClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataSourceIconClick Event

Glossary Item Box

Raised when the Datasource icon is clicked in the designer.

Syntax

Visual Basic (Declaration)
Public Event DataSourceIconClick As DataSourceIconClickEventHandler
C#
public event DataSourceIconClickEventHandler DataSourceIconClick

Event Data

The event handler receives an argument of type DataSourceIconClickEventArgs containing data related to this event. The following DataSourceIconClickEventArgs properties provide information specific to this event.

Property | Description
Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DataSourceIconClicked Event

[image]
ActiveReports 13
DataSourceIconClicked Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataSourceIconClicked Event

Glossary Item Box

Gets the value from the DialogResult when the data source icon is clicked.

Syntax

Visual Basic (Declaration)
Public Event DataSourceIconClicked As DataSourceIconClickedEventHandler
C#
public event DataSourceIconClickedEventHandler DataSourceIconClicked

Event Data

The event handler receives an argument of type DataSourceIconClickedEventArgs containing data related to this event. The following DataSourceIconClickedEventArgs properties provide information specific to this event.

Property | Description
DialogResult | Gets the value from the data source dialog.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DesignerTabChanged Event

[image]
ActiveReports 13
DesignerTabChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DesignerTabChanged Event

Glossary Item Box

Raised when the designer tab changes.

Syntax

Visual Basic (Declaration)
Public Event DesignerTabChanged As DesignerTabChangedEventHandler
C#
public event DesignerTabChangedEventHandler DesignerTabChanged

Event Data

The event handler receives an argument of type DesignerTabChangedEventArgs containing data related to this event. The following DesignerTabChangedEventArgs properties provide information specific to this event.

Property | Description
ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EditModeEntering Event

[image]
ActiveReports 13
EditModeEntering Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EditModeEntering Event

Glossary Item Box

This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.

Syntax

Visual Basic (Declaration)
Public Event EditModeEntering As EditModeEnteringEventHandler
C#
public event EditModeEnteringEventHandler EditModeEntering

Event Data

The event handler receives an argument of type EditModeEnteringEventArgs containing data related to this event. The following EditModeEnteringEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Control | Gets the type of control that enters edit mode.

Example

This code allows you to disable edit mode for the TextBox control.
C# Copy Code
private void arDesigner_EditModeEntering(object sender, EditModeEnteringEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.TextBox)
            {
                e.Cancel = true;
            }
        }
This code allows you to disable edit mode for the TextBox control.
Visual Basic Copy Code
Private Sub arDesigner_EditModeEntering(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs) Handles arDesigner.EditModeEntering
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.TextBox Then
            e.Cancel = True
        End If
    End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EditModeExit Event

[image]
ActiveReports 13
EditModeExit Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EditModeExit Event

Glossary Item Box

This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.

Syntax

Visual Basic (Declaration)
Public Event EditModeExit As EditModeExitEventHandler
C#
public event EditModeExitEventHandler EditModeExit

Event Data

The event handler receives an argument of type EditModeExitEventArgs containing data related to this event. The following EditModeExitEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the type of control that is exiting edit mode.
Type | Gets the exit type.

Example

C# Copy Code
private void arDesigner_EditModeExit(object sender, EditModeExitEventArgs e)
        {
            string a=((GrapeCity.ActiveReports.SectionReportModel.ARControl)e.Control).Name;
            if (e.Type == ExitType.Save && a == "txtDocumentOwner")
            {
                // save the new value of textbox control in the temporary field
                _global_do = (e.Control as TextBox).Text;
            }
        }
Visual Basic Copy Code
Private Sub arDesigner_EditModeExit(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeExitEventArgs) Handles arDesigner.EditModeExit
        If (e.Type = ExitType.Save) And (((GrapeCity.ActiveReports.SectionReportModel.ARControl)e.Control).Name = "txtDocumentOwner") Then
            ' save the new value of textbox control in the temporary field
            _global_do = CType(e.Control, TextBox).Text
        End If
    End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayoutChanged Event

[image]
ActiveReports 13
LayoutChanged Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutChanged Event

Glossary Item Box

Raised when the layout is changed.

Syntax

Visual Basic (Declaration)
Public Event LayoutChanged As LayoutChangedEventHandler
C#
public event LayoutChangedEventHandler LayoutChanged

Remarks

You can use this event to monitor changes to the report layout and update any dependent data such as SQL queries or custom user interfaces (report explorers, group sections dialog, etc).

Example

C# Copy Code
// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved

private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
Visual Basic Copy Code
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayoutChanging Event

[image]
ActiveReports 13
LayoutChanging Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutChanging Event

Glossary Item Box

Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.

Syntax

Visual Basic (Declaration)
Public Event LayoutChanging As LayoutChangingEventHandler
C#
public event LayoutChangingEventHandler LayoutChanging

Example

Visual Basic Copy Code
Private Sub ardMain_LayoutChanging(ByVal sender As Object, ByVal e As Design.LayoutChangingArgs) Handles ardMain.LayoutChanging
    If e.Type = Design.LayoutChangeType.SectionDelete Then
        Dim Result As DialogResult
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1)
        If Result = DialogResult.Cancel Then
            e.AllowChange = False
        Else
            e.AllowChange = True
        End If
    End If
End Sub
C# Copy Code
private void ardMain_LayoutChanging(object sender, GrapeCity.ActiveReports.Design.LayoutChangingArgs e)
{
    if (e.Type == Design.LayoutChangeType.SectionDelete)
    {
        DialogResult Result;
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1);
        if (Result == DialogResult.Cancel)
        {
            e.AllowChange = false;
        }
        else
        {
            e.AllowChange = true;
        }
    }
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LocateCredentials Event

[image]
ActiveReports 13
LocateCredentials Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocateCredentials Event

Glossary Item Box

Occurs when the report is previewed and credentials are needed.

Syntax

Visual Basic (Declaration)
Public Event LocateCredentials As LocateCredentialsEventHandler
C#
public event LocateCredentialsEventHandler LocateCredentials

Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSource | Gets the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LocateDataSource Event

[image]
ActiveReports 13
LocateDataSource Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocateDataSource Event

Glossary Item Box

Occurs when a data provider of the previewed report needs to locate the data at runtime.

Syntax

Visual Basic (Declaration)
Public Event LocateDataSource As LocateDataSourceEventHandler
C#
public event LocateDataSourceEventHandler LocateDataSource

Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Parameters | Gets the Parameters collection specified for a given report instance.
Report | Gets the Report that is trying to locate the data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportChanged Event

[image]
ActiveReports 13
ReportChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportChanged Event

Glossary Item Box

Notifies about report changes.

Syntax

Visual Basic (Declaration)
Public Event ReportChanged As EventHandler
C#
public event EventHandler ReportChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ScriptChanged Event

[image]
ActiveReports 13
ScriptChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScriptChanged Event

Glossary Item Box

Raised when the script for a report in the End User Report Designer is changed.

Syntax

Visual Basic (Declaration)
Public Event ScriptChanged As ScriptChangedEventHandler
C#
public event ScriptChangedEventHandler ScriptChanged

Remarks

This event is raised when the user switches from the Design view to the Script view of the report. It is not raised by changes to the script.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SelectionChanged Event

[image]
ActiveReports 13
SelectionChanged Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SelectionChanged Event

Glossary Item Box

Raised when the selection changes.

Syntax

Visual Basic (Declaration)
Public Event SelectionChanged As SelectionChangedEventHandler
C#
public event SelectionChangedEventHandler SelectionChanged

Remarks

You can use the Selection property to inspect the current selection.

Example

C# Copy Code
// ardMain_SelectionChanged - runs when a control/section in the layout is selected

private void ardMain_SelectionChanged()
{
    //Update the property grid with the new control/section properties
    this.SelChangePropGrid();

    if(this._controlAdded)  //Control is newly added
    {
        //Add item to ComboBox and PropGrid
        this._isCboDirty = true;
        this._controlAdded = false;
    }

    if(this._controlDeleted)  //Control is newly deleted
    {
        this._isCboDirty = true;
    }

    if(this._sectionAdded)  //Section is newly added
    {
        this._isCboDirty = true;
    }

    if(this._sectionDeleted)  //Section is newly deleted
    {
        this._isCboDirty = true;
    }
}
Visual Basic Copy Code
'ardMain_SelectionChanged - runs when a control/section in the layout is selected
Private Sub ardMain_SelectionChanged() Handles ardMain.SelectionChanged
    'Update the property grid with the new control/section properties
    Me.SelChangePropGrid()

    If Me._controlAdded Then 'Control is newly added
        'Add item to ComboBox and PropGrid
        Me._isCboDirty = True
        Me._controlAdded = False
    End If

    If Me._controlDeleted Then 'Control is newly deleted
        Me._isCboDirty = True
    End If

    If Me._sectionAdded Then 'Section is newly added
        Me._isCboDirty = True
    End If

    If Me._sectionDeleted Then 'Section is newly deleted
        Me._isCboDirty = True
    End If
End Sub 'ardMain_SelectionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members

Walkthroughs

Creating a Basic End User Report Designer


StatusChanged Event

[image]
ActiveReports 13
StatusChanged Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : StatusChanged Event

Glossary Item Box

This event is raised for each change in the status of the designer actions.

Syntax

Visual Basic (Declaration)
Public Event StatusChanged As StatusChangedEventHandler
C#
public event StatusChangedEventHandler StatusChanged

Remarks

Designer actions represent the commands that are typically invoked from UI elements such as a toolbar or a menu. You can use the QueryAction methods to check the status of the changed action and update your custom UI elements.

Example

C# Copy Code
// ardMain_StatusChanged - runs with the status of the Designer has changed
// (button is pressed)

private void ardMain_StatusChanged(object sender, System.EventArgs e)
{
    for(int i=0;i<this.tbAlign.Buttons.Count;i++)
    {
        System.Windows.Forms.ToolBarButton tb = this.tbAlign.Buttons[i];
        if(tb.Tag != null)
        {
            //If Alignment toolbar button is pressed, call SetStatus()
            SetStatus (tb.Tag.ToString(),tb);
        }
    }
    for(int i=0;i<this.tbFormat.Buttons.Count;i++)
    {
        System.Windows.Forms.ToolBarButton tb = this.tbFormat.Buttons[i];
        if(tb.Tag != null)
        {
            //if Format toolbar button is pressed, call SetStatus()
            SetStatus (tb.Tag.ToString(),tb);
        }
    }

    //Update Menus and other toolbars
    StatusStandardToolbar();
    UpdateFormatMenus();
}
Visual Basic Copy Code
'ardMain_StatusChanged - runs with the status of the Designer has changed
'(button is pressed)
Private Sub ardMain_StatusChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ardMain.StatusChanged
    Dim i As Integer
    For i = 0 To (Me.tbAlign.Buttons.Count) - 1
        Dim tb As System.Windows.Forms.ToolBarButton = Me.tbAlign.Buttons(i)
        If Not (tb.Tag Is Nothing) Then
            'If Alignment toolbar button is pressed, call SetStatus()
            SetStatus(tb.Tag.ToString(), tb)
        End If
    Next i

    For i = 0 To (Me.tbFormat.Buttons.Count) - 1
        Dim tb As System.Windows.Forms.ToolBarButton = Me.tbFormat.Buttons(i)
        If Not (tb.Tag Is Nothing) Then
            'if Format toolbar button is pressed, call SetStatus()
            SetStatus(tb.Tag.ToString(), tb)
        End If
    Next i

    'Update Menus and other toolbars
    StatusStandardToolbar()
    UpdateFormatMenus()
End Sub 'ardMain_StatusChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members

Walkthroughs

Creating a Basic End User Report Designer


ToolboxItemChanged Event

[image]
ActiveReports 13
ToolboxItemChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolboxItemChanged Event

Glossary Item Box

Raised when a toolbox control is drawn on the Report Designer.

Syntax

Visual Basic (Declaration)
Public Event ToolboxItemChanged As ToolboxItemChangedEventHandler
C#
public event ToolboxItemChangedEventHandler ToolboxItemChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DesignerTabChangedEventArgs Class

[image]
ActiveReports 13
DesignerTabChangedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

Glossary Item Box

Contains the active tab information.

Object Model

DesignerTabChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DesignerTabChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class DesignerTabChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DesignerTabChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerTabChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventArgs Class Members

[image]
ActiveReports 13
DesignerTabChangedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by DesignerTabChangedEventArgs.

Public Properties

 | Name | Description
Public Property | ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.
Top

See Also

Reference

DesignerTabChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventArgs Class Properties

[image]
ActiveReports 13
DesignerTabChangedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see DesignerTabChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.
Top

See Also

Reference

DesignerTabChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ActiveTab Property

[image]
ActiveReports 13
ActiveTab Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > DesignerTabChangedEventArgs Class : ActiveTab Property

Glossary Item Box

Gets the DesignerTab enumeration that indicates what tab is currently active.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActiveTab As DesignerTab
C#
public DesignerTab ActiveTab {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerTabChangedEventArgs Class
DesignerTabChangedEventArgs Members


EditModeEnteringEventArgs Class

[image]
ActiveReports 13
EditModeEnteringEventArgs Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

Glossary Item Box

This class retrieves the type of control to be edited when the user enters edit mode, allowing you to cancel editing for specified types of controls.

Object Model

EditModeEnteringEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EditModeEnteringEventArgs
   Inherits System.EventArgs
C#
public sealed class EditModeEnteringEventArgs : System.EventArgs

Remarks

Edit mode applies to the following types of controls:

  • RichTextBox
  • TextBox
  • CheckBox
  • Label

Example

Visual Basic Copy Code
Private Sub arDesigner_EditModeEntering(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs) Handles arDesigner.EditModeEntering
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.TextBox Then
            e.Cancel = True
        End If
    End Sub
C# Copy Code
private void arDesigner_EditModeEntering(object sender, EditModeEnteringEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.TextBox)
            {
                e.Cancel = true;
            }
        }

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Members
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventArgs Class Members

[image]
ActiveReports 13
EditModeEnteringEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

Glossary Item Box

The following tables list the members exposed by EditModeEnteringEventArgs.

Public Constructors

 | Name | Description
Public Constructor | EditModeEnteringEventArgs Constructor | Initializes a new instance of the EditModeEnteringEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Public Property | Control | Gets the type of control that enters edit mode.
Top

See Also

Reference

EditModeEnteringEventArgs Class
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventArgs Constructor

[image]
ActiveReports 13
EditModeEnteringEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : EditModeEnteringEventArgs Constructor

control

The type of control that is entering edit mode.

Glossary Item Box

Initializes a new instance of the EditModeEnteringEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As Object _
)
C#
public EditModeEnteringEventArgs(
   object control
)

Parameters

control

The type of control that is entering edit mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


EditModeEnteringEventArgs Class Properties

[image]
ActiveReports 13
EditModeEnteringEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

Glossary Item Box

For a list of all members of this type, see EditModeEnteringEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Public Property | Control | Gets the type of control that enters edit mode.
Top

See Also

Reference

EditModeEnteringEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property

[image]
ActiveReports 13
Cancel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : Cancel Property

Glossary Item Box

Gets or sets a value indicating whether to cancel edit mode for the control.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


Control Property

[image]
ActiveReports 13
Control Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : Control Property

Glossary Item Box

Gets the type of control that enters edit mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Object
C#
public object Control {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


EditModeExitEventArgs Class

[image]
ActiveReports 13
EditModeExitEventArgs Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

Glossary Item Box

This class retrieves the type of control edited when the user exits edit mode.

Object Model

EditModeExitEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EditModeExitEventArgs
   Inherits System.EventArgs
C#
public sealed class EditModeExitEventArgs : System.EventArgs

Remarks

Edit mode applies to the following types of controls:

  • RichTextBox
  • TextBox
  • CheckBox
  • Label

Example

C# Copy Code
private void arDesigner_EditModeExit(object sender, EditModeExitEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.Label)
            {
                (e.Control as GrapeCity.ActiveReports.SectionReportModel.Label).Text = "Trial version!";
            }
        }
Visual Basic Copy Code
Private Sub arDesigner_EditModeExit(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeExitEventArgs) Handles arDesigner.EditModeExit
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.Label Then
            CType(e.Control, GrapeCity.ActiveReports.SectionReportModel.Label).Text = "Trial version!"
        End If
    End Sub

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.EditModeExitEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Members
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventArgs Class Members

[image]
ActiveReports 13
EditModeExitEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

Glossary Item Box

The following tables list the members exposed by EditModeExitEventArgs.

Public Constructors

 | Name | Description
Public Constructor | EditModeExitEventArgs Constructor | Initializes a new instance of the EditModeExitEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Control | Gets the type of control that is exiting edit mode.
Public Property | Type | Gets the exit type.
Top

See Also

Reference

EditModeExitEventArgs Class
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventArgs Constructor

[image]
ActiveReports 13
EditModeExitEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : EditModeExitEventArgs Constructor

control

The type of control that is exiting edit mode.

type
Exit type.

Glossary Item Box

Initializes a new instance of the EditModeExitEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As Object, _
   ByVal type As ExitType _
)
C#
public EditModeExitEventArgs(
   object control,
   ExitType type
)

Parameters

control

The type of control that is exiting edit mode.

type
Exit type.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


EditModeExitEventArgs Class Properties

[image]
ActiveReports 13
EditModeExitEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

Glossary Item Box

For a list of all members of this type, see EditModeExitEventArgs members.

Public Properties

 | Name | Description
Public Property | Control | Gets the type of control that is exiting edit mode.
Public Property | Type | Gets the exit type.
Top

See Also

Reference

EditModeExitEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Control Property

[image]
ActiveReports 13
Control Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : Control Property

Glossary Item Box

Gets the type of control that is exiting edit mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Object
C#
public object Control {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : Type Property

Glossary Item Box

Gets the exit type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ExitType
C#
public ExitType Type {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


LayerList Class

[image]
ActiveReports 13
LayerList Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

ActiveReports Layer List.

Object Model

LayerList Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayerList
   Inherits System.Windows.Forms.UserControl
   Implements GrapeCity.ActiveReports.Viewer.Win.Theming.IColorableControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IObservableColorableControl
C#
public sealed class LayerList : System.Windows.Forms.UserControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IColorableControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IObservableColorableControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.LayerList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Members
GrapeCity.ActiveReports.Design Namespace


LayerList Class Members

[image]
ActiveReports 13
LayerList Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

The following tables list the members exposed by LayerList.

Public Constructors

 | Name | Description
Public Constructor | LayerList Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReportDesigner | Gets or sets the Designer instance to bind to this control.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged |
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


LayerList Constructor

[image]
ActiveReports 13
LayerList Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LayerList Constructor

Glossary Item Box

Overload List

Overload | Description
LayerList Constructor() | Initializes a new instance of layer list.
LayerList Constructor(IThemeManager) | Initializes a new instance of layer list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LayerList Constructor()

[image]
ActiveReports 13
LayerList Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > LayerList Constructor : LayerList Constructor()

Glossary Item Box

Initializes a new instance of layer list.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LayerList()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


LayerList Constructor(IThemeManager)

[image]
ActiveReports 13
LayerList Constructor(IThemeManager)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > LayerList Constructor : LayerList Constructor(IThemeManager)

themeManager
An object for managing colors of the UI-controls

Glossary Item Box

Initializes a new instance of layer list.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal themeManager As IThemeManager _
)
C#
public LayerList(
   IThemeManager themeManager
)

Parameters

themeManager
An object for managing colors of the UI-controls

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


LayerList Class Properties

[image]
ActiveReports 13
LayerList Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

For a list of all members of this type, see LayerList members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReportDesigner | Gets or sets the Designer instance to bind to this control.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


ReportDesigner Property

[image]
ActiveReports 13
ReportDesigner Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ReportDesigner Property

Glossary Item Box

Gets or sets the Designer instance to bind to this control.

Syntax

Visual Basic (Declaration)
Public Property ReportDesigner As Designer
C#
public Designer ReportDesigner {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LayerList Class Events

[image]
ActiveReports 13
LayerList Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

For a list of all members of this type, see LayerList members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged |
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


SelectionChanged Event

[image]
ActiveReports 13
SelectionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SelectionChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event SelectionChanged As Action(Of LayerSelectionChangedEventArgs)
C#
public event Action<LayerSelectionChangedEventArgs> SelectionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LayerSelectionChangedEventArgs Class

[image]
ActiveReports 13
LayerSelectionChangedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

Glossary Item Box

Provides data for the SelectionChanged event of the LayerList

Object Model

LayerSelectionChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayerSelectionChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class LayerSelectionChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayerSelectionChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerSelectionChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


LayerSelectionChangedEventArgs Class Members

[image]
ActiveReports 13
LayerSelectionChangedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by LayerSelectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LayerSelectionChangedEventArgs Constructor | Initializes a new instance of the LayoutSelectionChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | SelectedLayer | Gets the currently selected Layer.
Top

See Also

Reference

LayerSelectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


LayerSelectionChangedEventArgs Constructor

[image]
ActiveReports 13
LayerSelectionChangedEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerSelectionChangedEventArgs Class : LayerSelectionChangedEventArgs Constructor

selectedLayer
The selected layer.

Glossary Item Box

Initializes a new instance of the LayoutSelectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectedLayer As IComponent _
)
C#
public LayerSelectionChangedEventArgs(
   IComponent selectedLayer
)

Parameters

selectedLayer
The selected layer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerSelectionChangedEventArgs Class
LayerSelectionChangedEventArgs Members


LayerSelectionChangedEventArgs Class Properties

[image]
ActiveReports 13
LayerSelectionChangedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see LayerSelectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | SelectedLayer | Gets the currently selected Layer.
Top

See Also

Reference

LayerSelectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


SelectedLayer Property

[image]
ActiveReports 13
SelectedLayer Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerSelectionChangedEventArgs Class : SelectedLayer Property

Glossary Item Box

Gets the currently selected Layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedLayer As IComponent
C#
public IComponent SelectedLayer {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerSelectionChangedEventArgs Class
LayerSelectionChangedEventArgs Members


LayoutChangedArgs Class

[image]
ActiveReports 13
LayoutChangedArgs Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

Glossary Item Box

The LayoutChangedArgs class provides data required for the LayoutChanged event.

Object Model

LayoutChangedArgs Class

Syntax

Visual Basic (Declaration)
Public Class LayoutChangedArgs
   Inherits System.EventArgs
C#
public class LayoutChangedArgs : System.EventArgs

Example

C# Copy Code
// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved

private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
Visual Basic Copy Code
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub 'ardMain_LayoutChanged

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayoutChangedArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangedArgs Members
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


LayoutChangedArgs Class Members

[image]
ActiveReports 13
LayoutChangedArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

Glossary Item Box

The following tables list the members exposed by LayoutChangedArgs.

Public Constructors

 | Name | Description
Public Constructor | LayoutChangedArgs Constructor | Initializes a new instance of the LayoutChangedArgs class.
Top

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of layout change that caused the event to be raised.
Top

See Also

Reference

LayoutChangedArgs Class
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


LayoutChangedArgs Constructor

[image]
ActiveReports 13
LayoutChangedArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangedArgs Class : LayoutChangedArgs Constructor

type
Specifies the type of layout change.

Glossary Item Box

Initializes a new instance of the LayoutChangedArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As LayoutChangeType _
)
C#
public LayoutChangedArgs(
   LayoutChangeType type
)

Parameters

type
Specifies the type of layout change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangedArgs Class
LayoutChangedArgs Members


LayoutChangedArgs Class Properties

[image]
ActiveReports 13
LayoutChangedArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

Glossary Item Box

For a list of all members of this type, see LayoutChangedArgs members.

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the type of layout change that caused the event to be raised.
Top

See Also

Reference

LayoutChangedArgs Class
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


Type Property

[image]
ActiveReports 13
Type Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangedArgs Class : Type Property

Glossary Item Box

Gets or sets the type of layout change that caused the event to be raised.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As LayoutChangeType
C#
public LayoutChangeType Type {get;}

Property Value

LayoutChangeType enumeration value that determines the type of change.

Example

C# Copy Code
/// <summary>
/// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
/// </summary>
private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
Visual Basic Copy Code
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub 'ardMain_LayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangedArgs Class
LayoutChangedArgs Members
LayoutChangeType Enumeration


LayoutChangingArgs Class

[image]
ActiveReports 13
LayoutChangingArgs Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

Glossary Item Box

The LayoutChangingArgs class provides data required for the LayoutChanging event.

Object Model

LayoutChangingArgs Class

Syntax

Visual Basic (Declaration)
Public Class LayoutChangingArgs
   Inherits System.EventArgs
C#
public class LayoutChangingArgs : System.EventArgs

Example

Visual Basic Copy Code
Private Sub ardMain_LayoutChanging(ByVal sender As Object, ByVal e As Design.LayoutChangingArgs) Handles ardMain.LayoutChanging
    If e.Type = Design.LayoutChangeType.SectionDelete Then
        Dim Result As DialogResult
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1)
        If Result = DialogResult.Cancel Then
            e.AllowChange = False
        Else
            e.AllowChange = True
        End If
    End If
End Sub
C# Copy Code
private void ardMain_LayoutChanging(object sender, GrapeCity.ActiveReports.Design.LayoutChangingArgs e)
{
    if (e.Type == Design.LayoutChangeType.SectionDelete)
    {
        DialogResult Result;
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1);
        if (Result == DialogResult.Cancel)
        {
            e.AllowChange = false;
        }
        else
        {
            e.AllowChange = true;
        }
    }
}

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayoutChangingArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Members
GrapeCity.ActiveReports.Design Namespace


LayoutChangingArgs Class Members

[image]
ActiveReports 13
LayoutChangingArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

Glossary Item Box

The following tables list the members exposed by LayoutChangingArgs.

Public Constructors

 | Name | Description
Public Constructor | LayoutChangingArgs Constructor | Initializes a new instance of the LayoutChangingArgs class.
Top

Public Properties

 | Name | Description
Public Property | AllowChange | Sets or returns a value indicating whether to allow the change.
Public Property | Name | The array of names of the controls or sections to be updated or changed.
Public Property | NewSectionName | Gets the name of the new section.
Public Property | NewValue | The array of controls or sections to be added.
Public Property | OldSectionName | Gets the name of the old section.
Public Property | OldValue | The array of controls or sections to be deleted.
Public Property | Type | Returns the type of layout change that is to occur.
Top

See Also

Reference

LayoutChangingArgs Class
GrapeCity.ActiveReports.Design Namespace


LayoutChangingArgs Constructor

[image]
ActiveReports 13
LayoutChangingArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : LayoutChangingArgs Constructor

type
The type of layout change that is to occur.
selectionType
The selection type.
name
The array of names of the controls or sections to be updated or changed.
newValue
The array of controls or sections to be added.
oldValue
The array of controls or sections to be deleted.
oldSectionName
Name of the old section.
newSectionName
Name of the new section.

Glossary Item Box

Initializes a new instance of the LayoutChangingArgs class.

Initializes a new instance of the LayoutChangingArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As LayoutChangeType, _
   ByVal selectionType As SelectionType, _
   ByVal name As String, _
   ByVal newValue As Object, _
   ByVal oldValue As Object, _
   ByVal oldSectionName As String, _
   ByVal newSectionName As String _
)
C#
public LayoutChangingArgs(
   LayoutChangeType type,
   SelectionType selectionType,
   string name,
   object newValue,
   object oldValue,
   string oldSectionName,
   string newSectionName
)

Parameters

type
The type of layout change that is to occur.
selectionType
The selection type.
name
The array of names of the controls or sections to be updated or changed.
newValue
The array of controls or sections to be added.
oldValue
The array of controls or sections to be deleted.
oldSectionName
Name of the old section.
newSectionName
Name of the new section.

Remarks

In the type parameter, any of the enumerated values except ReportClear, ReportLoad, and ReportSize may be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members
LayoutChangeType Enumeration


LayoutChangingArgs Class Properties

[image]
ActiveReports 13
LayoutChangingArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

Glossary Item Box

For a list of all members of this type, see LayoutChangingArgs members.

Public Properties

 | Name | Description
Public Property | AllowChange | Sets or returns a value indicating whether to allow the change.
Public Property | Name | The array of names of the controls or sections to be updated or changed.
Public Property | NewSectionName | Gets the name of the new section.
Public Property | NewValue | The array of controls or sections to be added.
Public Property | OldSectionName | Gets the name of the old section.
Public Property | OldValue | The array of controls or sections to be deleted.
Public Property | Type | Returns the type of layout change that is to occur.
Top

See Also

Reference

LayoutChangingArgs Class
GrapeCity.ActiveReports.Design Namespace


AllowChange Property

[image]
ActiveReports 13
AllowChange Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : AllowChange Property

Glossary Item Box

Sets or returns a value indicating whether to allow the change.

Syntax

Visual Basic (Declaration)
Public Property AllowChange As Boolean
C#
public bool AllowChange {get; set;}

Property Value

Boolean.

Remarks

The default value of this property is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : Name Property

Glossary Item Box

The array of names of the controls or sections to be updated or changed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


NewSectionName Property

[image]
ActiveReports 13
NewSectionName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : NewSectionName Property

Glossary Item Box

Gets the name of the new section.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewSectionName As String
C#
public string NewSectionName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


NewValue Property

[image]
ActiveReports 13
NewValue Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : NewValue Property

Glossary Item Box

The array of controls or sections to be added.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewValue As Object
C#
public object NewValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


OldSectionName Property

[image]
ActiveReports 13
OldSectionName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : OldSectionName Property

Glossary Item Box

Gets the name of the old section.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldSectionName As String
C#
public string OldSectionName {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


OldValue Property

[image]
ActiveReports 13
OldValue Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : OldValue Property

Glossary Item Box

The array of controls or sections to be deleted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldValue As Object
C#
public object OldValue {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : Type Property

Glossary Item Box

Returns the type of layout change that is to occur.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As LayoutChangeType
C#
public LayoutChangeType Type {get;}

Property Value

LayoutChangeType enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members
LayoutChangeType Enumeration


Selection Class

[image]
ActiveReports 13
Selection Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

Indicates the currently selected items in the report layout.

Object Model

Selection Class

Syntax

Visual Basic (Declaration)
Public Class Selection
C#
public class Selection

Example

C# Copy Code
// cboPropList_SelectedIndexChanged - runs when the Property List Drop Down is changed

private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item);
}
Visual Basic Copy Code
'cboPropList_SelectedIndexChanged - runs when the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item)
End Sub 'cboPropList_SelectedIndexChanged

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.Selection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Members
GrapeCity.ActiveReports.Design Namespace


Selection Class Members

[image]
ActiveReports 13
Selection Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

The following tables list the members exposed by Selection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of selected objects.
Public Property | Item | Returns a reference to the specified selected item.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the current selection in the Report Designer.
Public Method | CopyTo | Copies the selected items to an Array, starting at a particular Array index.
Public Method | Select | Overloaded. The Select method allows one or more objects to be selected in the designer.
Top

See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Selection Class Methods

[image]
ActiveReports 13
Selection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

For a list of all members of this type, see Selection members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the current selection in the Report Designer.
Public Method | CopyTo | Copies the selected items to an Array, starting at a particular Array index.
Public Method | Select | Overloaded. The Select method allows one or more objects to be selected in the designer.
Top

See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Clear Method

Glossary Item Box

Clears the current selection in the Report Designer.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
/// <summary>
/// DesignView - updates the Design tab, sets defaults for the menu
/// </summary>
private void DesignView()
{
    this.sb.Text = "Loading Report";
    this.ardMain.Selection.Clear();
    this.ardMain.Selection.Select(this.ardMain.Report);
    this.mnuFilePrint.Enabled = false;

    //Reset Menu Items
    this.mnuFileNew.Enabled = true;
    this.mnuFileOpen.Enabled = true;
    this.mnuFileSave.Enabled = true;
    this.mnuFilePrint.Enabled = false;
    this.mnuFileExport.Enabled = false;
    this.mnuFilePrintPreview.Enabled = true;
    this.mnuFormat.Enabled = true;
    this.mnuInsert.Enabled = true;
    this.mnuEditCopyPage.Enabled = false;
    this.mnuEditFind.Enabled = false;
    this.mnuFileExport.Enabled = false;
    this.mnuEditProperties.Enabled = true;
    this.mnuFileSaveAs.Enabled = true;
    this.mnuFileReportProperties.Enabled = true;
    this.sb.Text = "Ready";
}
Visual Basic Copy Code
'DesignView - updates the Design tab, sets defaults for the menu
Private Sub DesignView()
    Me.sb.Text = "Loading Report"
    Me.ardMain.Selection.Clear()
    Me.ardMain.Selection.Select(Me.ardMain.Report)
    Me.mnuFilePrint.Enabled = False

    'Reset Menu Items
    Me.mnuFileNew.Enabled = True
    Me.mnuFileOpen.Enabled = True
    Me.mnuFileSave.Enabled = True
    Me.mnuFilePrint.Enabled = False
    Me.mnuFileExport.Enabled = False
    Me.mnuFilePrintPreview.Enabled = True
    Me.mnuFormat.Enabled = True
    Me.mnuInsert.Enabled = True
    Me.mnuEditCopyPage.Enabled = False
    Me.mnuEditFind.Enabled = False
    Me.mnuFileExport.Enabled = False
    Me.mnuEditProperties.Enabled = True
    Me.mnuFileSaveAs.Enabled = True
    Me.mnuFileReportProperties.Enabled = True
    Me.sb.Text = "Ready"
End Sub 'DesignView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Class
Selection Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : CopyTo Method

array
The array to which to copy the collection.
index
The array index from which to start.

Glossary Item Box

Copies the selected items to an Array, starting at a particular Array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The array to which to copy the collection.
index
The array index from which to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Class
Selection Members


Select Method

[image]
ActiveReports 13
Select Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Select Method

Glossary Item Box

The Select method allows one or more objects to be selected in the designer.

Overload List

Overload | Description
Select(Object) | Allows one object to be selected in the designer.
Select(Object,Boolean) | Allows more than one item to be selected in the designer.

Example

C# Copy Code
/// <summary>
/// cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
/// </summary>
private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item);
}
Visual Basic Copy Code
'cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item)
End Sub 'cboPropList_SelectedIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Class
Selection Members


Select(Object) Method

[image]
ActiveReports 13
Select(Object) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class > Select Method : Select(Object) Method

selectedObject
Object to select.

Glossary Item Box

Allows one object to be selected in the designer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select( _
   ByVal selectedObject As Object _
)
C#
public void Select(
   object selectedObject
)

Parameters

selectedObject
Object to select.

Example

C# Copy Code
/// <summary>
/// cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
/// </summary>
private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item);
}
Visual Basic Copy Code
'cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item)
End Sub 'cboPropList_SelectedIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Class
Selection Members
Overload List


Select(Object,Boolean) Method

[image]
ActiveReports 13
Select(Object,Boolean) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class > Select Method : Select(Object,Boolean) Method

selectedObject
Object to select.
continuous
Boolean.

Glossary Item Box

Allows more than one item to be selected in the designer.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select( _
   ByVal selectedObject As Object, _
   ByVal continuous As Boolean _
)
C#
public void Select(
   object selectedObject,
   bool continuous
)

Parameters

selectedObject
Object to select.
continuous
Boolean.

Return Value

Boolean value. If true, more than one object can be selected in the designer. If false, only one object can be selected in the designer.

Example

C# Copy Code
/// <summary>
/// cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
/// </summary>
private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item, false);
}
Visual Basic Copy Code
'cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item, False)
End Sub 'cboPropList_SelectedIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Class
Selection Members
Overload List


Selection Class Properties

[image]
ActiveReports 13
Selection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Glossary Item Box

For a list of all members of this type, see Selection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of selected objects.
Public Property | Item | Returns a reference to the specified selected item.
Top

See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Count Property

[image]
ActiveReports 13
Count Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Count Property

Glossary Item Box

Returns the number of selected objects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Example

C# Copy Code
/// <summary>
/// SetClassName - sets the ClassName of the selected object to the name in the drop down list
/// </summary>
private void SetClassName()
{
    for(int i=0;i<this.ardMain.Selection.Count;i++)
    {
        string ctl = this.ardMain.Selection[i].GetType().ToString();
        if((ctl.IndexOf("TextBox") >0)||(ctl.IndexOf("CheckBox") >0)||(ctl.IndexOf("Label") >0))
        {
            switch(ctl)
            {
                case "GrapeCity.ActiveReports.SectionReportModel.TextBox":  //Control type is TextBox
                    ((GrapeCity.ActiveReports.SectionReportModel.TextBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "GrapeCity.ActiveReports.SectionReportModel.Label":  //Control type is Label
                    ((GrapeCity.ActiveReports.SectionReportModel.Label)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "GrapeCity.ActiveReports.SectionReportModel.CheckBox":  //Control type is CheckBox
                    ((GrapeCity.ActiveReports.SectionReportModel.CheckBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
            }
        }
    }
}
Visual Basic Copy Code
'SetClassName - sets the ClassName of the selected object to the name in the drop down list
Private Sub SetClassName()
    Dim i As Integer
    For i = 0 To (Me.ardMain.Selection.Count) - 1
        Dim ctl As String = Me.ardMain.Selection(i).GetType().ToString()
        If ctl.IndexOf("TextBox") > 0 OrElse ctl.IndexOf("CheckBox") > 0 OrElse ctl.IndexOf("Label") > 0 Then
            Select Case ctl
                Case "GrapeCity.ActiveReports.SectionReportModel.TextBox" 'Control type is TextBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.TextBox).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.Label" 'Control type is Label
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.Label).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.CheckBox" 'Control type is CheckBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.CheckBox).ClassName = Me.cboClassName.Text
            End Select
        End If
    Next i
End Sub 'SetClassName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Class
Selection Members


Item Property

[image]
ActiveReports 13
Item Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Item Property

index
Specifies the index of the selected item.

Glossary Item Box

Returns a reference to the specified selected item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Object
C#
public object this[
   int index
]; {get;}

Parameters

index
Specifies the index of the selected item.

Example

C# Copy Code
/// <summary>
/// SetClassName - sets the ClassName of the selected object to the name in the drop down list
/// </summary>
private void SetClassName()
{
    for(int i=0;i<this.ardMain.Selection.Count;i++)
    {
        string ctl = this.ardMain.Selection[i].GetType().ToString();
        if((ctl.IndexOf("TextBox") >0)||(ctl.IndexOf("CheckBox") >0)||(ctl.IndexOf("Label") >0))
        {
            switch(ctl)
            {
                case "GrapeCity.ActiveReports.SectionReportModel.TextBox":  //Control type is TextBox
                    ((GrapeCity.ActiveReports.SectionReportModel.TextBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "DGrapeCity.ActiveReports.SectionReportModel.Label":  //Control type is Label
                    ((GrapeCity.ActiveReports.SectionReportModel.Label)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "GrapeCity.ActiveReports.SectionReportModel.CheckBox":  //Control type is CheckBox
                    ((GrapeCity.ActiveReports.SectionReportModel.CheckBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
            }
        }
    }
}
Visual Basic Copy Code
'SetClassName - sets the ClassName of the selected object to the name in the drop down list
Private Sub SetClassName()
    Dim i As Integer
    For i = 0 To (Me.ardMain.Selection.Count) - 1
        Dim ctl As String = Me.ardMain.Selection(i).GetType().ToString()
        If ctl.IndexOf("TextBox") > 0 OrElse ctl.IndexOf("CheckBox") > 0 OrElse ctl.IndexOf("Label") > 0 Then
            Select Case ctl
                Case "GrapeCity.ActiveReports.SectionReportModel.TextBox" 'Control type is TextBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.TextBox).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.Label" 'Control type is Label
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.Label).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.CheckBox" 'Control type is CheckBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.CheckBox).ClassName = Me.cboClassName.Text
            End Select
        End If
    Next i
End Sub 'SetClassName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Selection Class
Selection Members


ServerConnectionChangedEventArgs Class

[image]
ActiveReports 13
ServerConnectionChangedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

Glossary Item Box

Information about connection with ARS

Object Model

ServerConnectionChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ServerConnectionChangedEventArgs
   Inherits System.EventArgs
C#
public class ServerConnectionChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ServerConnectionChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerConnectionChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventArgs Class Members

[image]
ActiveReports 13
ServerConnectionChangedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ServerConnectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ServerConnectionChangedEventArgs Constructor | Initializes a new instance of the ServerConnectionChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Connected | Gets the connection state.
Public Property | ServerUrl | Gets the server URL.
Top

See Also

Reference

ServerConnectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventArgs Constructor

[image]
ActiveReports 13
ServerConnectionChangedEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ServerConnectionChangedEventArgs Class : ServerConnectionChangedEventArgs Constructor

connected
The connection state.
serverUrl
The server URL.

Glossary Item Box

Initializes a new instance of the ServerConnectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connected As Boolean, _
   ByVal serverUrl As String _
)
C#
public ServerConnectionChangedEventArgs(
   bool connected,
   string serverUrl
)

Parameters

connected
The connection state.
serverUrl
The server URL.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerConnectionChangedEventArgs Class
ServerConnectionChangedEventArgs Members


ServerConnectionChangedEventArgs Class Properties

[image]
ActiveReports 13
ServerConnectionChangedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ServerConnectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Connected | Gets the connection state.
Public Property | ServerUrl | Gets the server URL.
Top

See Also

Reference

ServerConnectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Connected Property

[image]
ActiveReports 13
Connected Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ServerConnectionChangedEventArgs Class : Connected Property

Glossary Item Box

Gets the connection state.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Connected As Boolean
C#
public bool Connected {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerConnectionChangedEventArgs Class
ServerConnectionChangedEventArgs Members


ServerUrl Property

[image]
ActiveReports 13
ServerUrl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ServerConnectionChangedEventArgs Class : ServerUrl Property

Glossary Item Box

Gets the server URL.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerUrl As String
C#
public string ServerUrl {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerConnectionChangedEventArgs Class
ServerConnectionChangedEventArgs Members


UndoManager Class

[image]
ActiveReports 13
UndoManager Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

The UndoManager class allows users to undo and redo changes.

Object Model

UndoManager Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UndoManager
C#
public sealed class UndoManager

Example

C# Copy Code
// tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
// based on the button clicked.

private void tbStandard_ButtonClick(object sender, System.Windows.Forms.ToolBarButtonClickEventArgs e)
{
    if((string)e.Button.Tag == "NewReport")  //New Report was Clicked
    {
        this.ardMain.NewReport();
        this.FillCombo();
    }
    if((string)e.Button.Tag == "Open")  //Open Report was Clicked
    {
        this.OpenReportFile();
    }
    if((string)e.Button.Tag == "Save")  //Save Report was Clicked
    {
        this.SaveReportFile();
    }
    if((string)e.Button.Tag == "SaveAs")  //SaveAs was Clicked
    {
        this.SaveAsReportFile();
    }
    if((string)e.Button.Tag == "ReportSettings")  //ReportSettings was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReportSettings);
    }
    if((string)e.Button.Tag == "Undo")  //Undo was Clicked
    {
        this.ardMain.UndoManager.Undo();
    }
    if((string)e.Button.Tag == "Cut")  //Cut was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCut);
    }
    if((string)e.Button.Tag == "Copy")  //Copy was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCopy);
    }
    if((string)e.Button.Tag == "Paste")  //Paste was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditPaste);
    }
    if((string)e.Button.Tag == "Delete")  //Delete was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditDelete);
    }
    if((string)e.Button.Tag == "ReorderGroups")  //ReorderGroups was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReorderGroups);
    }
}
Visual Basic Copy Code
'tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
'based on the button clicked.
Private Sub tbStandard_ButtonClick(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tbStandard.ButtonClick
    If CStr(e.Button.Tag) = "NewReport" Then 'New Report was Clicked
        Me.ardMain.NewReport()
        Me.FillCombo()
    End If
    If CStr(e.Button.Tag) = "Open" Then 'Open Report was Clicked
        Me.OpenReportFile()
    End If
    If CStr(e.Button.Tag) = "Save" Then 'Save Report was Clicked
        Me.SaveReportFile()
    End If
    If CStr(e.Button.Tag) = "SaveAs" Then 'SaveAs was Clicked
        Me.SaveAsReportFile()
    End If
    If CStr(e.Button.Tag) = "ReportSettings" Then 'ReportSettings was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReportSettings)
    End If
    If CStr(e.Button.Tag) = "Undo" Then 'Undo was Clicked
        Me.ardMain.UndoManager.Undo()
    End If
    If CStr(e.Button.Tag) = "Cut" Then 'Cut was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCut)
    End If
    If CStr(e.Button.Tag) = "Copy" Then 'Copy was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCopy)
    End If
    If CStr(e.Button.Tag) = "Paste" Then 'Paste was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditPaste)
    End If
    If CStr(e.Button.Tag) = "Delete" Then 'Delete was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditDelete)
    End If
    If CStr(e.Button.Tag) = "ReorderGroups" Then 'ReorderGroups was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReorderGroups)
    End If
End Sub 'tbStandard_ButtonClick

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.UndoManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Members
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Members

[image]
ActiveReports 13
UndoManager Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

The following tables list the members exposed by UndoManager.

Public Properties

 | Name | Description
Public Property | RedoCount | Returns the number of repeated actions.
Public Property | UndoCount | Returns the number of undone actions.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the Undo stack.Clears the Redo stack.
Public Method | Dispose | Releases the UndoManager instance from the memory.
Public Method | Redo | Repeats the last action.
Public Method | RedoDescription | Returns a description of the last repeated action.
Public Method | Undo | Undoes the last action.
Public Method | UndoDescription | Returns a description of the last undone action.
Top

Public Events

 | Name | Description
Public Event | Changed | Raised when the Undo stack has changed.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Methods

[image]
ActiveReports 13
UndoManager Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

For a list of all members of this type, see UndoManager members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the Undo stack.Clears the Redo stack.
Public Method | Dispose | Releases the UndoManager instance from the memory.
Public Method | Redo | Repeats the last action.
Public Method | RedoDescription | Returns a description of the last repeated action.
Public Method | Undo | Undoes the last action.
Public Method | UndoDescription | Returns a description of the last undone action.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Clear Method

Glossary Item Box

Clears the Undo stack.Clears the Redo stack.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Dispose Method

Glossary Item Box

Releases the UndoManager instance from the memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


Redo Method

[image]
ActiveReports 13
Redo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Redo Method

Glossary Item Box

Repeats the last action.

Syntax

Visual Basic (Declaration)
Public Sub Redo()
C#
public void Redo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


RedoDescription Method

[image]
ActiveReports 13
RedoDescription Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : RedoDescription Method

index
Specifies the index of the RedoDescription.

Glossary Item Box

Returns a description of the last repeated action.

Syntax

Visual Basic (Declaration)
Public Function RedoDescription( _
   ByVal index As Integer _
) As String
C#
public string RedoDescription(
   int index
)

Parameters

index
Specifies the index of the RedoDescription.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


Undo Method

[image]
ActiveReports 13
Undo Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Undo Method

Glossary Item Box

Undoes the last action.

Syntax

Visual Basic (Declaration)
Public Sub Undo()
C#
public void Undo()

Example

C# Copy Code
// <summary>
/// tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
/// based on the button clicked.
/// </summary>
private void tbStandard_ButtonClick(object sender, System.Windows.Forms.ToolBarButtonClickEventArgs e)
{
    if((string)e.Button.Tag == "NewReport")  //New Report was Clicked
    {
        this.ardMain.NewReport();
        this.FillCombo();
    }
    if((string)e.Button.Tag == "Open")  //Open Report was Clicked
    {
        this.OpenReportFile();
    }
    if((string)e.Button.Tag == "Save")  //Save Report was Clicked
    {
        this.SaveReportFile();
    }
    if((string)e.Button.Tag == "SaveAs")  //SaveAs was Clicked
    {
        this.SaveAsReportFile();
    }
    if((string)e.Button.Tag == "ReportSettings")  //ReportSettings was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReportSettings);
    }
    if((string)e.Button.Tag == "Undo")  //Undo was Clicked
    {
        this.ardMain.UndoManager.Undo();
    }
    if((string)e.Button.Tag == "Cut")  //Cut was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCut);
    }
    if((string)e.Button.Tag == "Copy")  //Copy was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCopy);
    }
    if((string)e.Button.Tag == "Paste")  //Paste was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditPaste);
    }
    if((string)e.Button.Tag == "Delete")  //Delete was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditDelete);
    }
    if((string)e.Button.Tag == "ReorderGroups")  //ReorderGroups was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReorderGroups);
    }
}
Visual Basic Copy Code
'tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
'based on the button clicked.
Private Sub tbStandard_ButtonClick(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tbStandard.ButtonClick
    If CStr(e.Button.Tag) = "NewReport" Then 'New Report was Clicked
        Me.ardMain.NewReport()
        Me.FillCombo()
    End If
    If CStr(e.Button.Tag) = "Open" Then 'Open Report was Clicked
        Me.OpenReportFile()
    End If
    If CStr(e.Button.Tag) = "Save" Then 'Save Report was Clicked
        Me.SaveReportFile()
    End If
    If CStr(e.Button.Tag) = "SaveAs" Then 'SaveAs was Clicked
        Me.SaveAsReportFile()
    End If
    If CStr(e.Button.Tag) = "ReportSettings" Then 'ReportSettings was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReportSettings)
    End If
    If CStr(e.Button.Tag) = "Undo" Then 'Undo was Clicked
        Me.ardMain.UndoManager.Undo()
    End If
    If CStr(e.Button.Tag) = "Cut" Then 'Cut was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCut)
    End If
    If CStr(e.Button.Tag) = "Copy" Then 'Copy was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCopy)
    End If
    If CStr(e.Button.Tag) = "Paste" Then 'Paste was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditPaste)
    End If
    If CStr(e.Button.Tag) = "Delete" Then 'Delete was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditDelete)
    End If
    If CStr(e.Button.Tag) = "ReorderGroups" Then 'ReorderGroups was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReorderGroups)
    End If
End Sub 'tbStandard_ButtonClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


UndoDescription Method

[image]
ActiveReports 13
UndoDescription Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : UndoDescription Method

index
Specifies the index of the UndoDescription.

Glossary Item Box

Returns a description of the last undone action.

Syntax

Visual Basic (Declaration)
Public Function UndoDescription( _
   ByVal index As Integer _
) As String
C#
public string UndoDescription(
   int index
)

Parameters

index
Specifies the index of the UndoDescription.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


UndoManager Class Properties

[image]
ActiveReports 13
UndoManager Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

For a list of all members of this type, see UndoManager members.

Public Properties

 | Name | Description
Public Property | RedoCount | Returns the number of repeated actions.
Public Property | UndoCount | Returns the number of undone actions.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


RedoCount Property

[image]
ActiveReports 13
RedoCount Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : RedoCount Property

Glossary Item Box

Returns the number of repeated actions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RedoCount As Integer
C#
public int RedoCount {get;}

Property Value

Integer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


UndoCount Property

[image]
ActiveReports 13
UndoCount Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : UndoCount Property

Glossary Item Box

Returns the number of undone actions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UndoCount As Integer
C#
public int UndoCount {get;}

Property Value

Integer.

Example

C# Copy Code
If(this.ardMain.UndoManager.UndoCount == 0 )
{
    this.tSTDUndo.Enabled = False;
    this.mnuEditUndo.Enabled = False;
}
Else
{
    this.tSTDUndo.Enabled = True;
    this.mnuEditUndo.Enabled = True;
}
Visual Basic Copy Code
If Me.ardMain.UndoManager.UndoCount = 0 Then
    Me.tSTDUndo.Enabled = False
    Me.mnuEditUndo.Enabled = False
Else
    Me.tSTDUndo.Enabled = True
    Me.mnuEditUndo.Enabled = True
End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


UndoManager Class Events

[image]
ActiveReports 13
UndoManager Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

Glossary Item Box

For a list of all members of this type, see UndoManager members.

Public Events

 | Name | Description
Public Event | Changed | Raised when the Undo stack has changed.
Top

See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


Changed Event

[image]
ActiveReports 13
Changed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Changed Event

Glossary Item Box

Raised when the Undo stack has changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UndoManager Class
UndoManager Members


ContextMenuTypes Enumeration

[image]
ActiveReports 13
ContextMenuTypes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuTypes Enumeration

Glossary Item Box

Specifies the type of menu that will be opened for this sourceObject.

Syntax

Visual Basic (Declaration)
Public Enum ContextMenuTypes
   Inherits System.Enum
C#
public enum ContextMenuTypes : System.Enum

Members

Member | Description
Control | Control context menu.
Page | Page context menu.
PageTab | Page tab context menu.
Report | Report object context menu.
RichText | RichText context menu.
Section | Section context menu.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ContextMenuTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
MenuType Property


DebugMode Enumeration

[image]
ActiveReports 13
DebugMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DebugMode Enumeration

Glossary Item Box

Specifies the type of debugging.

Syntax

Visual Basic (Declaration)
Public Enum DebugMode
   Inherits System.Enum
C#
public enum DebugMode : System.Enum

Members

Member | Description
Break | Debugging during a break in run time.
Design | Design time debugging.
Run | Run time debugging.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DebugMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerAction Enumeration

[image]
ActiveReports 13
DesignerAction Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerAction Enumeration

Glossary Item Box

List of available designer commands (actions)

Syntax

Visual Basic (Declaration)
Public Enum DesignerAction
   Inherits System.Enum
C#
public enum DesignerAction : System.Enum

Members

Member | Description
AddLayer | Adds and activates new layer.
BackColorDlg | Opens the back color editor.
BorderBottom | Sets bottom border.
BorderLeft | Sets left border.
BorderRight | Sets right border.
BordersAll | Sets all borders.
BordersNone | Sets no borders.
BorderTop | Sets top border.
ConvertToMaster | Converts the regular RDL report to the RDL Master report.
DataSourceSetup | View: Data Source setup.
DeleteLayer | Removes active layer.
EditCopy | Edit: Copy.
EditCut | Edit: Cut.
EditDelete | Edit: Delete.
EditDesigner | View report Designer tab.
EditOleObject | Edit: Ole object.
EditPaste | Edit: Paste.
EditPreview | View report Preview tab.
EditRedo | Edit: Redo.
EditScript | View: Script code editor.
EditUndo | Edit: Undo.
EnableChartWizard | Enable the chart wizard.
FileOpen | File: Open.
FileSave | File: Save.
ForeColorDlg | Opens the dialog for setting the foreground color for a control.
FormatAlignBottom | Format: Align control bottom.
FormatAlignCenter | Format: Align control center.
FormatAlignLeft | Format: Align control left.
FormatAlignMiddle | Format: Align control middle.
FormatAlignRight | Format: Align control right.
FormatAlignToGrid | Format: Align controls to grid.
FormatAlignTop | Format: Align control top.
FormatBackColor | Format: Background color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatBorder | Format: Border.
FormatBringToFront | Brings a control to the front of the z-order.
FormatCenterHorizontally | Format: Center control horizontally.
FormatCenterVertically | Format: Center control vertically.
FormatFontBold | Format: Bold. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontItalic | Format: Italic. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontName | Format: Font name. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontSize | Format: Font size. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontUnderline | Format: Underline. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatForeColor | Format: Foreground color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLineColor | Format: Line color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLineStyle | Format: Line style. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLockControls | Format: Lock control size and position.
FormatOrderBringToFront | Format: Bring control to the foreground.
FormatOrderSendToBack | Format: Send control to the background.
FormatRTFBullets | Format: Set RTF bullet style.
FormatRTFIndent | Format: Indent RTF text.
FormatRTFOutdent | Format: Outdent RTF text.
FormatSendToBack | Sends a control to the back of the z-order.
FormatSizeBoth | Format: Size controls to the same width and height.
FormatSizeSameHeight | Format: Size controls to the same height.
FormatSizeSameWidth | Format: Size controls to the same width.
FormatSizeToGrid | Format: Make control sizes correspond to grid marks.
FormatSpaceDecreaseHorizontal | Format: Decrease horizontal spacing.
FormatSpaceDecreaseVertical | Format: Decrease vertical spacing.
FormatSpaceEquallyHorizontal | Format: Space horizontal controls evenly.
FormatSpaceEquallyVertical | Format: Space vertical controls evenly.
FormatSpaceIncreaseHorizontal | Format: Increase horizontal spacing.
FormatSpaceIncreaseVertical | Format: Increase vertical spacing.
FormatSpaceRemoveHorizontal | Format: Remove horizontal spacing.
FormatSpaceRemoveVertical | Format: Remove vertical spacing.
FormatStyle | Format: Style.
FormatTextAlignBottom | Format : Align text bottom
FormatTextAlignCenter | Format: Align text center.
FormatTextAlignJustify | Format: Justify text.
FormatTextAlignLeft | Format: Align text left.
FormatTextAlignMiddle | Format: Align text middle.
FormatTextAlignRight | Format: Align text right.
FormatTextAlignTop | Format: Align text top
GridMode | Switches the grid mode.
InsertGroupHF | Edit: Insert a Group Header/Footer section pair.
InsertPageHF | Edit: Insert a Page Header/Footer section pair.
InsertReportHF | Edit: Insert a Report Header/Footer section pair.
InsertRTFField | Edit: Insert an RTF Field.
LayerBringToFront | Brings all layers of active layer to the foreground.
LayerSendToBack | Send all controls of active layer to the background.
LayerSetActive | Sets active layer by name.
MouseModePan | Sets the pan mouse mode.
MouseModeSelect | Sets the selection mouse mode
NewReport | Displays the new report dialog.
OpenOutputFormatDialog | Open the OutputFormat dialog.
PageFooter | Adds or removes the page footer of the RDL report.
PageHeader | Adds or removes the page header of the RDL report.
ReorderGroups | Edit: Reorder Groups.
ReportImages | Displays the page report images dialog.
ReportParams | Displays the page report parameters dialog.
ReportProperties | Displays the page report properties dialog.
ReportSettings | File: Report Settings.
SelectAll | Selects all the report controls.
SetMasterReport | Sets the master report of the RDL report.
ToggleDimensionLines | Turns on/off the dimensions helper lines.
ToggleSnapToGrid | View: Snap to grid instead of using snap lines.
ToggleSnapToLines | View: Use Snap Lines instead of snap to grid. .
ToggleViewGrid | View: Grid.
ZoomActual | Resets the zoom.
ZoomIn | Zooms the report design surface in.
ZoomOut | Zooms the report design surface out.
ZoomValue | Sets the zoom value of the report design surface.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerReportType Enumeration

[image]
ActiveReports 13
DesignerReportType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerReportType Enumeration

Glossary Item Box

Available report types.

Syntax

Visual Basic (Declaration)
Public Enum DesignerReportType
   Inherits System.Enum
C#
public enum DesignerReportType : System.Enum

Members

Member | Description
Page | Specifies page report type.
Rdl | Rdl report type.
Section | Specifies section report type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerReportType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerTab Enumeration

[image]
ActiveReports 13
DesignerTab Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTab Enumeration

Glossary Item Box

Lists the available designer tab options.

Syntax

Visual Basic (Declaration)
Public Enum DesignerTab
   Inherits System.Enum
C#
public enum DesignerTab : System.Enum

Members

Member | Description
Designer | Designer tab.
Preview | Preview tab.
Script | Script tab.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerTab

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerToolStrips Enumeration

[image]
ActiveReports 13
DesignerToolStrips Enumeration
Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerToolStrips Enumeration

Glossary Item Box

Enumeration of the types of tool strips to use with the designer.

Syntax

Visual Basic (Declaration)
Public Enum DesignerToolStrips
   Inherits System.Enum
C#
public enum DesignerToolStrips : System.Enum

Members

Member | Description
All | Adds all of the available tool strips.
Borders | The toolstrip contains the border editors.
Edit | The Edit tool strip includes these tools: Cut, Copy, Paste, and Delete.
Format | The Format tool strip includes these tools: Font Name, Font Size, Bold, Italic, Underline, Fore Color, Back Color, Align Left, Align Center, Align Right, Align Justify, Indent and Outdent.
Layout | The Layout tool strip includes these tools: Align to Grid, Align Lefts, Align Centers, Align Rights, Align Tops, Align Middles, Align Bottoms, Bring to Front, and Send to Back.
Menu | Adds the menu tool strip, which includes the File and Edit menus. The File menu includes these commands: New, Open, Save, and Export. The Edit menu includes these commands: Undo, Redo, Cut, Copy, Paste, Delete, and Select All.
Report | The Report tool strip includes these tools: New, Open, and Save.
Undo | The Undo tool strip includes these tools: Undo and Redo.
Zoom | The Zoom tool strip includes these tools: Zoom Out, Zoom In, Zoom %, and Actual Size.

Example

Visual Basic Copy Code
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
        Dim menuStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)(0)
        Dim editStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)(0)
        Dim formatStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)(0)
        Dim layoutStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)(0)
        Dim reportStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)(0)
        Dim undoStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)(0)
        Dim zoomStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)(0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(menuStrip, 0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(editStrip, 1)
        Me.ToolStripContainer1.TopToolStripPanel.Join(formatStrip, 2)
        Me.ToolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3)
        Me.ToolStripContainer1.TopToolStripPanel.Join(reportStrip, 4)
        Me.ToolStripContainer1.TopToolStripPanel.Join(undoStrip, 5)
        Me.ToolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6)
    End Sub
C# Copy Code
private void designer1_Load(object sender, EventArgs e)
        {
            ToolStrip menuStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)[0];
            ToolStrip editStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)[0];
            ToolStrip formatStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)[0];
            ToolStrip layoutStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)[0];
            ToolStrip reportStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)[0];
            ToolStrip undoStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)[0];
            ToolStrip zoomStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)[0];
            this.toolStripContainer1.TopToolStripPanel.Join(menuStrip, 0);
            this.toolStripContainer1.TopToolStripPanel.Join(editStrip, 1);
            this.toolStripContainer1.TopToolStripPanel.Join(formatStrip, 2);
            this.toolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3);
            this.toolStripContainer1.TopToolStripPanel.Join(reportStrip, 4);
            this.toolStripContainer1.TopToolStripPanel.Join(undoStrip, 5);
            this.toolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6);
        }

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerToolStrips

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
CreateToolStrips Method


ExitType Enumeration

[image]
ActiveReports 13
ExitType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ExitType Enumeration

Glossary Item Box

Specifies the action to perform when the user exits edit mode.

Syntax

Visual Basic (Declaration)
Public Enum ExitType
   Inherits System.Enum
C#
public enum ExitType : System.Enum

Members

Member | Description
Cancel | Restore the previous state of the control.
Save | Save any changes made to the control during edit mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ExitType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


GridMode Enumeration

[image]
ActiveReports 13
GridMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : GridMode Enumeration

Glossary Item Box

Specifies the type of the grid to draw in the designer surface.

Syntax

Visual Basic (Declaration)
Public Enum GridMode
   Inherits System.Enum
C#
public enum GridMode : System.Enum

Members

Member | Description
Dots | Specifies the dots grid type.
Lines | Specifies the lines grid type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.GridMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


LayoutChangeType Enumeration

[image]
ActiveReports 13
LayoutChangeType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangeType Enumeration

Glossary Item Box

Enumeration of change settings for the report layout.

Syntax

Visual Basic (Declaration)
Public Enum LayoutChangeType
   Inherits System.Enum
C#
public enum LayoutChangeType : System.Enum

Members

Member | Description
ControlAdd | A control has been added.
ControlDelete | A control has been deleted.
ControlMove | A control has been moved.
ControlSize | The size of a control has changed.
ControlZOrder | A control's ZOrder has been changed.
ReportClear | The report has been cleared.
ReportLoad | A report has been loaded.
ReportSize | A report's size has changed.
SectionAdd | A section has been added.
SectionDelete | A section has been deleted.
SectionMove | A section has been moved.
SectionSize | The size of a section has changed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.LayoutChangeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
LayoutChangedArgs Class


LayoutMode Enumeration

[image]
ActiveReports 13
LayoutMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutMode Enumeration

Glossary Item Box

Enumeration of modes for laying out controls on the report designer.

Syntax

Visual Basic (Declaration)
Public Enum LayoutMode
   Inherits System.Enum
C#
public enum LayoutMode : System.Enum

Members

Member | Description
DimHelperLines | Specifies dimensions helper line layout mode.
None | Allow free movement of controls.
SnapGrid | Snap controls to the grid.
SnapLines | Snap controls to lines showing alignment to other controls.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.LayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
LayoutMode Property


MeasurementUnits Enumeration

[image]
ActiveReports 13
MeasurementUnits Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : MeasurementUnits Enumeration

Glossary Item Box

Specifies the ruler measurement units.

Syntax

Visual Basic (Declaration)
Public Enum MeasurementUnits
   Inherits System.Enum
C#
public enum MeasurementUnits : System.Enum

Members

Member | Description
Inches | Inches.
Metric | Centimeters.
Point | Points.
System | Unit specified in the system.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.MeasurementUnits

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
DesignerUnits Property


MouseMode Enumeration

[image]
ActiveReports 13
MouseMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : MouseMode Enumeration

Glossary Item Box

Available designer MouseMode types.

Syntax

Visual Basic (Declaration)
Public Enum MouseMode
   Inherits System.Enum
C#
public enum MouseMode : System.Enum

Members

Member | Description
Pan | Pan Mode.
Select | Select Mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.MouseMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


PageReportDesignerActions Enumeration

[image]
ActiveReports 13
PageReportDesignerActions Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : PageReportDesignerActions Enumeration

Glossary Item Box

Controls the accessibility of actions of FplTabControl.

Syntax

Visual Basic (Declaration)
Public Enum PageReportDesignerActions
   Inherits System.Enum
C#
public enum PageReportDesignerActions : System.Enum

Members

Member | Description
AddPage | Allows to add a new page.
All | All actions are accessible.
DeletePage | Allows to delete pages.
DuplicatePage | Allows to duplicate pages.
InsertPage | Allows to insert pages.
None | All actions are inaccessible.
RearrangePage | Allows to rearrange pages.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.PageReportDesignerActions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ReportExplorerNodes Enumeration

[image]
ActiveReports 13
ReportExplorerNodes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ReportExplorerNodes Enumeration

Glossary Item Box

The visibility of the nodes in ReportExplorer

Syntax

Visual Basic (Declaration)
Public Enum ReportExplorerNodes
   Inherits System.Enum
C#
public enum ReportExplorerNodes : System.Enum

Members

Member | Description
All | Show all.
DataSourceAndFields | Show datasources and fields.
None | Hide all.
Parameters | Show parameters.
Settings | Show settings.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ReportExplorerNodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ToolPanelButton Enumeration

[image]
ActiveReports 13
ToolPanelButton Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ToolPanelButton Enumeration

Glossary Item Box

Controls the visibility of ToolPanelButton controls on the Designer.

Syntax

Visual Basic (Declaration)
Public Enum ToolPanelButton
   Inherits System.Enum
C#
public enum ToolPanelButton : System.Enum

Members

Member | Description
All | Show or hide all the available buttons
DimensionLines | Show or hide the DimensionLines button
GridMode | Show or hide the GridMode button
MouseMode | Show or hide the MouseMode button
None | Displays no button
SnapGrid | Show or hide the SnapGrid button
SnapLines | Show or hide the SnapLines button
ZoomSlider | Show or hide the ZoomSlider button

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ToolPanelButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ITrackSelectionService Interface

[image]
ActiveReports 13
ITrackSelectionService Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface

Glossary Item Box

Defines the common interface that enables the transmission of events related to change in selection in the host environment.

Syntax

Visual Basic (Declaration)
Public Interface ITrackSelectionService
C#
public interface ITrackSelectionService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITrackSelectionService Members
GrapeCity.ActiveReports.Design Namespace


ITrackSelectionService Interface Members

[image]
ActiveReports 13
ITrackSelectionService Interface Members
See Also Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface

Glossary Item Box

The following tables list the members exposed by ITrackSelectionService.

Public Methods

 | Name | Description
Method | OnSelectChange | Reports that the currently selected container has been changed.
Method | RefreshPropertyBrowser | Updates all the properties within the properties browser.
Method | ShowFrame | Checks whether the focus or the routing of command has been updated correctly, based on the activation of the hosting window frame.
Top

Public Events

 | Name | Description
Event | SelectionChange | This event is fired when there is a change in the state of the currently selected container.
Top

See Also

Reference

ITrackSelectionService Interface
GrapeCity.ActiveReports.Design Namespace


ITrackSelectionService Interface Methods

[image]
ActiveReports 13
ITrackSelectionService Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface

Glossary Item Box

For a list of all members of this type, see ITrackSelectionService members.

Public Methods

 | Name | Description
Method | OnSelectChange | Reports that the currently selected container has been changed.
Method | RefreshPropertyBrowser | Updates all the properties within the properties browser.
Method | ShowFrame | Checks whether the focus or the routing of command has been updated correctly, based on the activation of the hosting window frame.
Top

See Also

Reference

ITrackSelectionService Interface
GrapeCity.ActiveReports.Design Namespace


OnSelectChange Method

[image]
ActiveReports 13
OnSelectChange Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : OnSelectChange Method

Glossary Item Box

Reports that the currently selected container has been changed.

Syntax

Visual Basic (Declaration)
Function OnSelectChange() As Integer
C#
int OnSelectChange()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


RefreshPropertyBrowser Method

[image]
ActiveReports 13
RefreshPropertyBrowser Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : RefreshPropertyBrowser Method

Glossary Item Box

Updates all the properties within the properties browser.

Syntax

Visual Basic (Declaration)
Sub RefreshPropertyBrowser()
C#
void RefreshPropertyBrowser()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


ShowFrame Method

[image]
ActiveReports 13
ShowFrame Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : ShowFrame Method

Glossary Item Box

Checks whether the focus or the routing of command has been updated correctly, based on the activation of the hosting window frame.

Syntax

Visual Basic (Declaration)
Sub ShowFrame()
C#
void ShowFrame()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


ITrackSelectionService Interface Events

[image]
ActiveReports 13
ITrackSelectionService Interface Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface

Glossary Item Box

For a list of all members of this type, see ITrackSelectionService members.

Public Events

 | Name | Description
Event | SelectionChange | This event is fired when there is a change in the state of the currently selected container.
Top

See Also

Reference

ITrackSelectionService Interface
GrapeCity.ActiveReports.Design Namespace


SelectionChange Event

[image]
ActiveReports 13
SelectionChange Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : SelectionChange Event

Glossary Item Box

This event is fired when there is a change in the state of the currently selected container.

Syntax

Visual Basic (Declaration)
Event SelectionChange As EventHandler
C#
event EventHandler SelectionChange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


IVsPackageIntegration Interface

[image]
ActiveReports 13
IVsPackageIntegration Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

Glossary Item Box

Provides an interface for the IVsPackageIntegration service.

Syntax

Visual Basic (Declaration)
Public Interface IVsPackageIntegration
C#
public interface IVsPackageIntegration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Members
GrapeCity.ActiveReports.Design Namespace


IVsPackageIntegration Interface Members

[image]
ActiveReports 13
IVsPackageIntegration Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

Glossary Item Box

The following tables list the members exposed by IVsPackageIntegration.

Public Methods

 | Name | Description
Method | GetStyleSheets | Returns the Stylesheets.
Method | OnDebugModeChanged | Specifies the function that is called if the debugging mode changes.
Method | OnSolutionBuilding | Specifies the function that is called before any solution build action is initialized.
Top

See Also

Reference

IVsPackageIntegration Interface
GrapeCity.ActiveReports.Design Namespace


IVsPackageIntegration Interface Methods

[image]
ActiveReports 13
IVsPackageIntegration Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

Glossary Item Box

For a list of all members of this type, see IVsPackageIntegration members.

Public Methods

 | Name | Description
Method | GetStyleSheets | Returns the Stylesheets.
Method | OnDebugModeChanged | Specifies the function that is called if the debugging mode changes.
Method | OnSolutionBuilding | Specifies the function that is called before any solution build action is initialized.
Top

See Also

Reference

IVsPackageIntegration Interface
GrapeCity.ActiveReports.Design Namespace


GetStyleSheets Method

[image]
ActiveReports 13
GetStyleSheets Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : GetStyleSheets Method

Glossary Item Box

Returns the Stylesheets.

Syntax

Visual Basic (Declaration)
Function GetStyleSheets() As String()
C#
string[] GetStyleSheets()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


OnDebugModeChanged Method

[image]
ActiveReports 13
OnDebugModeChanged Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : OnDebugModeChanged Method

dbgmodeNew
A value from the DebugMode enumeration, indicating the new debugger mode.

Glossary Item Box

Specifies the function that is called if the debugging mode changes.

Syntax

Visual Basic (Declaration)
Sub OnDebugModeChanged( _
   ByVal dbgmodeNew As DebugMode _
)
C#
void OnDebugModeChanged(
   DebugMode dbgmodeNew
)

Parameters

dbgmodeNew
A value from the DebugMode enumeration, indicating the new debugger mode.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


OnSolutionBuilding Method

[image]
ActiveReports 13
OnSolutionBuilding Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : OnSolutionBuilding Method

Glossary Item Box

Specifies the function that is called before any solution build action is initialized.

Syntax

Visual Basic (Declaration)
Sub OnSolutionBuilding()
C#
void OnSolutionBuilding()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


ContextMenuOpenEventHandler Delegate

[image]
ActiveReports 13
ContextMenuOpenEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenEventHandler Delegate

sender
The source of the event.
e
ContextMenuOpenArgs class which contains the event data.

Glossary Item Box

Represents a method that handles the ContextMenuOpen event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ContextMenuOpenEventHandler( _
   ByVal sender As Object, _
   ByVal e As ContextMenuOpenArgs _
)
C#
public delegate void ContextMenuOpenEventHandler(
   object sender,
   ContextMenuOpenArgs e
)

Parameters

sender
The source of the event.
e
ContextMenuOpenArgs class which contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ContextMenuOpenEventHandler Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventHandler Delegate

[image]
ActiveReports 13
DataSourceIconClickedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventHandler Delegate

sender
The source of the event.
e
DataSourceIconClickedEventArgs class which contains the event data.

Glossary Item Box

Represents a method that handles the DataSourceIconClicked event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataSourceIconClickedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataSourceIconClickedEventArgs _
)
C#
public delegate void DataSourceIconClickedEventHandler(
   object sender,
   DataSourceIconClickedEventArgs e
)

Parameters

sender
The source of the event.
e
DataSourceIconClickedEventArgs class which contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventHandler Delegate

[image]
ActiveReports 13
DataSourceIconClickEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventHandler Delegate

sender
The source of the event.
e
DataSourceIconClickArgs class which contains the event data.

Glossary Item Box

Represents a method that handles the DataSourceIconClick event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataSourceIconClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataSourceIconClickEventArgs _
)
C#
public delegate void DataSourceIconClickEventHandler(
   object sender,
   DataSourceIconClickEventArgs e
)

Parameters

sender
The source of the event.
e
DataSourceIconClickArgs class which contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceIconClickEventHandler Members
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventHandler Delegate

[image]
ActiveReports 13
DesignerTabChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventHandler Delegate

sender
The source of the event.
e
A DesignerTabChangedEventArgs that does not contain any event data.

Glossary Item Box

Represents the method that handles the event, containing the active tab information.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DesignerTabChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DesignerTabChangedEventArgs _
)
C#
public delegate void DesignerTabChangedEventHandler(
   object sender,
   DesignerTabChangedEventArgs e
)

Parameters

sender
The source of the event.
e
A DesignerTabChangedEventArgs that does not contain any event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DesignerTabChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventHandler Delegate

[image]
ActiveReports 13
EditModeEnteringEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventHandler Delegate

sender
The source of the event.
e
A EditModeEnteringEventArgs that does not contain any event data.

Glossary Item Box

Represents a method that handles the EditModeEntering event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub EditModeEnteringEventHandler( _
   ByVal sender As Object, _
   ByVal e As EditModeEnteringEventArgs _
)
C#
public delegate void EditModeEnteringEventHandler(
   object sender,
   EditModeEnteringEventArgs e
)

Parameters

sender
The source of the event.
e
A EditModeEnteringEventArgs that does not contain any event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeEnteringEventHandler Members
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventHandler Delegate

[image]
ActiveReports 13
EditModeExitEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventHandler Delegate

sender
The source of the event.
e
A EditModeExitEventArgs that does not contain any event data.

Glossary Item Box

Represents a method that handles the EditModeExit event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub EditModeExitEventHandler( _
   ByVal sender As Object, _
   ByVal e As EditModeExitEventArgs _
)
C#
public delegate void EditModeExitEventHandler(
   object sender,
   EditModeExitEventArgs e
)

Parameters

sender
The source of the event.
e
A EditModeExitEventArgs that does not contain any event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditModeExitEventHandler Members
GrapeCity.ActiveReports.Design Namespace


LayoutChangedEventHandler Delegate

[image]
ActiveReports 13
LayoutChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedEventHandler Delegate

sender
The source of the event.
e
A LayoutChangedArgs that does not contain any event data.

Glossary Item Box

Represents a method that handles the LayoutChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LayoutChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As LayoutChangedArgs _
)
C#
public delegate void LayoutChangedEventHandler(
   object sender,
   LayoutChangedArgs e
)

Parameters

sender
The source of the event.
e
A LayoutChangedArgs that does not contain any event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


LayoutChangingEventHandler Delegate

[image]
ActiveReports 13
LayoutChangingEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingEventHandler Delegate

sender
The source of the event.
e
A LayoutChangingArgs that does not contain any event data.

Glossary Item Box

Represents a method that handles the LayoutChanging method.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LayoutChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As LayoutChangingArgs _
)
C#
public delegate void LayoutChangingEventHandler(
   object sender,
   LayoutChangingArgs e
)

Parameters

sender
The source of the event.
e
A LayoutChangingArgs that does not contain any event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutChangingEventHandler Members
GrapeCity.ActiveReports.Design Namespace


ScriptChangedEventHandler Delegate

[image]
ActiveReports 13
ScriptChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ScriptChangedEventHandler Delegate

sender
The source of the event.
e
A ScriptEditorEventArgs that does not contain any event data.

Glossary Item Box

Represents a method that handles the ScriptChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ScriptChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScripEditorEventArgs _
)
C#
public delegate void ScriptChangedEventHandler(
   object sender,
   ScripEditorEventArgs e
)

Parameters

sender
The source of the event.
e
A ScriptEditorEventArgs that does not contain any event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScriptChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


SelectionChangedEventHandler Delegate

[image]
ActiveReports 13
SelectionChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : SelectionChangedEventHandler Delegate

Glossary Item Box

Represents a method that handles the SelectionChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SelectionChangedEventHandler()
C#
public delegate void SelectionChangedEventHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectionChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventHandler Delegate

[image]
ActiveReports 13
ServerConnectionChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventHandler Delegate

sender
e

Glossary Item Box

Delegate for ServerConnectionChanged event

Syntax

Visual Basic (Declaration)
Public Delegate Sub ServerConnectionChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ServerConnectionChangedEventArgs _
)
C#
public delegate void ServerConnectionChangedEventHandler(
   object sender,
   ServerConnectionChangedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServerConnectionChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


StatusChangedEventHandler Delegate

[image]
ActiveReports 13
StatusChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : StatusChangedEventHandler Delegate

sender
The source of the event.
e
LayoutChangingArgs class which contains the event data.

Glossary Item Box

Represents a method that handles the StatusChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub StatusChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void StatusChangedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
The source of the event.
e
LayoutChangingArgs class which contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatusChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


ToolboxItemChangedEventHandler Delegate

[image]
ActiveReports 13
ToolboxItemChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : ToolboxItemChangedEventHandler Delegate

sender
The source of the event.
e
ToolboxItemChangedArgs class which contains the event data.

Glossary Item Box

Represents a method that will handle the ToolboxItemChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ToolboxItemChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void ToolboxItemChangedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
The source of the event.
e
ToolboxItemChangedArgs class which contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolboxItemChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace

GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace

Glossary Item Box

Classes

 | Class | Description
Class | DvChartDesigner | DvChart report item designer

Enumerations

 | Enumeration | Description
Enumeration | DvChartTemplateType |

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


DvChartDesigner Class

[image]
ActiveReports 13
DvChartDesigner Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace : DvChartDesigner Class

Glossary Item Box

DvChart report item designer

Object Model

DvChartDesigner Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DvChartDesigner
   Inherits GrapeCity.ActiveReports.Design.DdrDesigner.Designers.ReportItemDesigner
C#
public sealed class DvChartDesigner : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.ReportItemDesigner

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.DvChartDesigner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Members
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace


DvChartDesigner Class Members

[image]
ActiveReports 13
DvChartDesigner Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace : DvChartDesigner Class

Glossary Item Box

The following tables list the members exposed by DvChartDesigner.

Public Constructors

 | Name | Description
Public Constructor | DvChartDesigner Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | ControlGlyph | Overridden.
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataAdornersVisible | Specifies that adorners are currently visible
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost |
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | LockRemoveDataAdorner | Allows to block the removal of the DataAdorner.
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReportItem |
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedItem | Currently selected adorner component, if any
Public Property | ShowChartTypeSelector |
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | AddAreaAdorner |
Public Method | AddDataAdorner | Adds data adorner for the designer
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | Initialize | Overridden.
Public Method | InitializeComponentDefaults | Overridden. Allows initialization of component properties with their default values
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetTemplate |
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DvChartDesigner Class
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace


DvChartDesigner Constructor

[image]
ActiveReports 13
DvChartDesigner Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DvChartDesigner Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DvChartDesigner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DvChartDesigner Class Methods

[image]
ActiveReports 13
DvChartDesigner Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace : DvChartDesigner Class

Glossary Item Box

For a list of all members of this type, see DvChartDesigner members.

Public Methods

 | Name | Description
Public Method | AddAreaAdorner |
Public Method | AddDataAdorner | Adds data adorner for the designer
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | Initialize | Overridden.
Public Method | InitializeComponentDefaults | Overridden. Allows initialization of component properties with their default values
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetTemplate |
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DvChartDesigner Class
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace


AddAreaAdorner Method

[image]
ActiveReports 13
AddAreaAdorner Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AddAreaAdorner Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddAreaAdorner()
C#
public void AddAreaAdorner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


AddDataAdorner Method

[image]
ActiveReports 13
AddDataAdorner Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AddDataAdorner Method

Glossary Item Box

Adds data adorner for the designer

Syntax

Visual Basic (Declaration)
Public Sub AddDataAdorner()
C#
public void AddDataAdorner()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Initialize Method

[image]
ActiveReports 13
Initialize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Initialize Method

component

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Initialize( _
   ByVal component As IComponent _
)
C#
public override void Initialize(
   IComponent component
)

Parameters

component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


InitializeComponentDefaults Method

[image]
ActiveReports 13
InitializeComponentDefaults Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : InitializeComponentDefaults Method

Glossary Item Box

Allows initialization of component properties with their default values

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub InitializeComponentDefaults()
C#
public override void InitializeComponentDefaults()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SetTemplate Method

[image]
ActiveReports 13
SetTemplate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SetTemplate Method

type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetTemplate( _
   ByVal type As DvChartTemplateType _
)
C#
public void SetTemplate(
   DvChartTemplateType type
)

Parameters

type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DvChartDesigner Class Properties

[image]
ActiveReports 13
DvChartDesigner Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace : DvChartDesigner Class

Glossary Item Box

For a list of all members of this type, see DvChartDesigner members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | ControlGlyph | Overridden.
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataAdornersVisible | Specifies that adorners are currently visible
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost |
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | LockRemoveDataAdorner | Allows to block the removal of the DataAdorner.
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReportItem |
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedItem | Currently selected adorner component, if any
Public Property | ShowChartTypeSelector |
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DvChartDesigner Class
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace


ControlGlyph Property

[image]
ActiveReports 13
ControlGlyph Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ControlGlyph Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ControlGlyph As Glyph
C#
public override Glyph ControlGlyph {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DataAdornersVisible Property

[image]
ActiveReports 13
DataAdornersVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DataAdornersVisible Property

Glossary Item Box

Specifies that adorners are currently visible

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataAdornersVisible As Boolean
C#
public bool DataAdornersVisible {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DesignerHost Property

[image]
ActiveReports 13
DesignerHost Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DesignerHost Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesignerHost As IDesignerHost
C#
public IDesignerHost DesignerHost {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


LockRemoveDataAdorner Property

[image]
ActiveReports 13
LockRemoveDataAdorner Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : LockRemoveDataAdorner Property

Glossary Item Box

Allows to block the removal of the DataAdorner.

Syntax

Visual Basic (Declaration)
Public Property LockRemoveDataAdorner As Boolean
C#
public bool LockRemoveDataAdorner {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ReportItem Property

[image]
ActiveReports 13
ReportItem Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ReportItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property ReportItem As GrapeCity.ActiveReports.PageReportModel.DV.Chart
C#
public new GrapeCity.ActiveReports.PageReportModel.DV.Chart ReportItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SelectedItem Property

[image]
ActiveReports 13
SelectedItem Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SelectedItem Property

Glossary Item Box

Currently selected adorner component, if any

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As IComponent
C#
public IComponent SelectedItem {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ShowChartTypeSelector Property

[image]
ActiveReports 13
ShowChartTypeSelector Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ShowChartTypeSelector Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ShowChartTypeSelector As Boolean
C#
public bool ShowChartTypeSelector {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DvChartTemplateType Enumeration

[image]
ActiveReports 13
DvChartTemplateType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace : DvChartTemplateType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum DvChartTemplateType
   Inherits System.Enum
C#
public enum DvChartTemplateType : System.Enum

Members

Member | Description
Area |
AreaPercent |
AreaStacked |
Bar |
BarPercent |
BarStacked |
Bubble |
Candlestick |
Column |
ColumnPercent |
ColumnStacked |
Doughnut |
Funnel |
Gantt |
HighLowClose |
HighLowOpenClose |
Line |
LineSmooth |
Pie |
Polar |
PolarPercent |
PolarStacked |
Pyramid |
Scatter |
Spiral |
SpiralPercent |
SpiralStacked |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.DvChartTemplateType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace


GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.Component Namespace

GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.Component Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.Component Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.UI Namespace

GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.UI Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.UI Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace

GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers namespace includes DataVisualizerBasePanel class which is the base class of the data visualizer panel.

Classes

 | Class | Description
Class | DataVisualizerBasePanel | Represents a base class of the data visualizer panel that dynamically lays out its contents in a grid composed of rows and columns.

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


DataVisualizerBasePanel Class

[image]
ActiveReports 13
DataVisualizerBasePanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace : DataVisualizerBasePanel Class

Glossary Item Box

Represents a base class of the data visualizer panel that dynamically lays out its contents in a grid composed of rows and columns.

Object Model

DataVisualizerBasePanel Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataVisualizerBasePanel
   Inherits System.Windows.Forms.TableLayoutPanel
C#
public abstract class DataVisualizerBasePanel : System.Windows.Forms.TableLayoutPanel

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
System.Windows.Forms.TableLayoutPanel
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers.DataVisualizerBasePanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Members
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace


DataVisualizerBasePanel Class Members

[image]
ActiveReports 13
DataVisualizerBasePanel Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace : DataVisualizerBasePanel Class

Glossary Item Box

The following tables list the members exposed by DataVisualizerBasePanel.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from System.Windows.Forms.Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from System.Windows.Forms.Panel)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CellBorderStyle | Gets or sets the style of the cell borders. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ColumnCount | Gets or sets the number of columns in the table. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | ColumnStyles | Gets a collection of column styles for the System.Windows.Forms.TableLayoutPanel. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the System.Windows.Forms.TableLayoutPanel. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | GrowStyle | Gets or sets a value indicating whether the System.Windows.Forms.TableLayoutPanel control should expand to accommodate new cells when all existing cells are occupied. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the panel's layout engine. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | RowCount | Gets or sets the number of rows in the table. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | RowStyles | Gets a collection of row styles for the System.Windows.Forms.TableLayoutPanel. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Panel)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetCellPosition | Gets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetColumn | Returns the column position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetColumnSpan | Returns the number of columns spanned by the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetControlFromPosition | Returns the child control occupying the specified position. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetExpression | Returns the expression.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPositionFromControl | Gets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell that contains the control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetRow | Returns the row position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetRowSpan | Returns the number of rows spanned by the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCellPosition | Sets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetColumn | Sets the column position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetColumnSpan | Sets the number of columns spanned by the child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetExpression | Sets the arguments used in expression.
Public Method | SetRow | Sets the row position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetRowSpan | Sets the number of rows spanned by the child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a string representation for this control. (Inherited from System.Windows.Forms.Panel)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the value of the System.Windows.Forms.Panel.AutoSize property has changed. (Inherited from System.Windows.Forms.Panel)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CellPaint | Occurs when the cell is redrawn. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DataVisualizerBasePanel Class
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace


DataVisualizerBasePanel Class Methods

[image]
ActiveReports 13
DataVisualizerBasePanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace : DataVisualizerBasePanel Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerBasePanel members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetCellPosition | Gets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetColumn | Returns the column position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetColumnSpan | Returns the number of columns spanned by the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetControlFromPosition | Returns the child control occupying the specified position. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetExpression | Returns the expression.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPositionFromControl | Gets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell that contains the control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetRow | Returns the row position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | GetRowSpan | Returns the number of rows spanned by the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCellPosition | Sets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetColumn | Sets the column position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetColumnSpan | Sets the number of columns spanned by the child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetExpression | Sets the arguments used in expression.
Public Method | SetRow | Sets the row position of the specified child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | SetRowSpan | Sets the number of rows spanned by the child control. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a string representation for this control. (Inherited from System.Windows.Forms.Panel)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DataVisualizerBasePanel Class
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace


GetExpression Method

[image]
ActiveReports 13
GetExpression Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetExpression Method

Glossary Item Box

Returns the expression.

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetExpression() As String
C#
public abstract string GetExpression()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetExpression Method

[image]
ActiveReports 13
SetExpression Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetExpression Method

arguments
the arguments for expression.
functionName
The name of the function.

Glossary Item Box

Sets the arguments used in expression.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetExpression( _
   ByVal arguments() As GrapeCity.Enterprise.Data.DataEngine.Expressions.ExpressionInfo, _
   Optional ByVal functionName As String _
)
C#
public abstract void SetExpression(
   GrapeCity.Enterprise.Data.DataEngine.Expressions.ExpressionInfo[] arguments,
   string functionName
)

Parameters

arguments
the arguments for expression.
functionName
The name of the function.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GrapeCity.ActiveReports.Design.ReportExplorer Namespace

GrapeCity.ActiveReports.Design.ReportExplorer Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.ReportExplorer Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Design.ReportExplorer namespace includes the ReportExplorer class which is the base class for the ReportExplorer control.

Classes

 | Class | Description
Class | ReportExplorer | Represents ActiveReports Report Explorer.

Remarks

The ReportExplorer control can be used in conjunction with the End-User Report Designer control to show the report sections and controls as well as a list of available data source fields based on the report's current database connection.

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


ReportExplorer Class

[image]
ActiveReports 13
ReportExplorer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

Glossary Item Box

Represents ActiveReports Report Explorer.

Object Model

ReportExplorer Class

Syntax

Visual Basic (Declaration)
Public Class ReportExplorer
   Inherits ReportExplorerInternal
   Implements GrapeCity.ActiveReports.Viewer.Win.Theming.IColorableControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IObservableColorableControl
C#
public class ReportExplorer : ReportExplorerInternal, GrapeCity.ActiveReports.Viewer.Win.Theming.IColorableControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IObservableColorableControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.ReportExplorer.ReportExplorer

Requirements

See Also

Reference

ReportExplorer Members
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


ReportExplorer Class Members

[image]
ActiveReports 13
ReportExplorer Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

Glossary Item Box

The following tables list the members exposed by ReportExplorer.

Public Constructors

 | Name | Description
Public Constructor | ReportExplorer Constructor | Initializes a new instance of the ReportExplorer class.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


ReportExplorer Constructor

[image]
ActiveReports 13
ReportExplorer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ReportExplorer Constructor

Glossary Item Box

Initializes a new instance of the ReportExplorer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportExplorer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GrapeCity.ActiveReports.Design.ReportsLibrary Namespace

GrapeCity.ActiveReports.Design.ReportsLibrary Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.ReportsLibrary Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Design.ReportsLibrary namespace includes the ReportsLibrary class which is the base class for ReportsLibrary control, and ReportsLibraryArsExtension class that extends the ReportsLibrary class.

Classes

 | Class | Description
Class | ReportsLibrary |

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


ReportsLibrary Class

[image]
ActiveReports 13
ReportsLibrary Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace : ReportsLibrary Class

Glossary Item Box

Object Model

ReportsLibrary Class

Syntax

Visual Basic (Declaration)
Public Class ReportsLibrary
   Inherits System.Windows.Forms.UserControl
   Implements GrapeCity.ActiveReports.Viewer.Win.Theming.IColorableControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IIconicControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IObservableColorableControl
C#
public class ReportsLibrary : System.Windows.Forms.UserControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IColorableControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IIconicControl, GrapeCity.ActiveReports.Viewer.Win.Theming.IObservableColorableControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.ReportsLibrary.ReportsLibrary

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Members
GrapeCity.ActiveReports.Design.ReportsLibrary Namespace


ReportsLibrary Class Members

[image]
ActiveReports 13
ReportsLibrary Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace : ReportsLibrary Class

Glossary Item Box

The following tables list the members exposed by ReportsLibrary.

Public Constructors

 | Name | Description
Public Constructor | ReportsLibrary Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReportDesigner |
Public Property | ReportsLibraryService |
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ServiceProvider |
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add Page or RDL Report to the library.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clears the report library.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetReportTypeFilter |
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportsLibrary Class
GrapeCity.ActiveReports.Design.ReportsLibrary Namespace


ReportsLibrary Constructor

[image]
ActiveReports 13
ReportsLibrary Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ReportsLibrary Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportsLibrary()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ReportsLibrary Class Methods

[image]
ActiveReports 13
ReportsLibrary Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace : ReportsLibrary Class

Glossary Item Box

For a list of all members of this type, see ReportsLibrary members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add Page or RDL Report to the library.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clears the report library.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetReportTypeFilter |
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

ReportsLibrary Class
GrapeCity.ActiveReports.Design.ReportsLibrary Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Add Method

Glossary Item Box

Add Page or RDL Report to the library.

Overload List

Overload | Description
Add(PageReport,String) | Add Page or RDL Report to the library.
Add(SectionReport,String) | Add Section Report to the library.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Add(PageReport,String) Method

[image]
ActiveReports 13
Add(PageReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Add Method : Add(PageReport,String) Method

report
The report to be added.
nodeName
The name of the report node in library.

Glossary Item Box

Add Page or RDL Report to the library.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal report As PageReport, _
   ByVal nodeName As String _
)
C#
public void Add(
   PageReport report,
   string nodeName
)

Parameters

report
The report to be added.
nodeName
The name of the report node in library.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Add(SectionReport,String) Method

[image]
ActiveReports 13
Add(SectionReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Add Method : Add(SectionReport,String) Method

report
The report to be added.
nodeName
The name of the report node in library.

Glossary Item Box

Add Section Report to the library.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal report As SectionReport, _
   ByVal nodeName As String _
)
C#
public void Add(
   SectionReport report,
   string nodeName
)

Parameters

report
The report to be added.
nodeName
The name of the report node in library.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Clear Method

Glossary Item Box

Clears the report library.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SetReportTypeFilter Method

[image]
ActiveReports 13
SetReportTypeFilter Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SetReportTypeFilter Method

reportType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetReportTypeFilter( _
   ByVal reportType As Nullable(Of DesignerReportType) _
)
C#
public void SetReportTypeFilter(
   Nullable<DesignerReportType> reportType
)

Parameters

reportType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ReportsLibrary Class Properties

[image]
ActiveReports 13
ReportsLibrary Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace : ReportsLibrary Class

Glossary Item Box

For a list of all members of this type, see ReportsLibrary members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReportDesigner |
Public Property | ReportsLibraryService |
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ServiceProvider |
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportsLibrary Class
GrapeCity.ActiveReports.Design.ReportsLibrary Namespace


ReportDesigner Property

[image]
ActiveReports 13
ReportDesigner Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ReportDesigner Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ReportDesigner As Designer
C#
public Designer ReportDesigner {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ReportsLibraryService Property

[image]
ActiveReports 13
ReportsLibraryService Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ReportsLibraryService Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ReportsLibraryService As IReportsLibraryService
C#
public IReportsLibraryService ReportsLibraryService {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ServiceProvider Property

[image]
ActiveReports 13
ServiceProvider Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ServiceProvider Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ServiceProvider As IServiceProvider
C#
public IServiceProvider ServiceProvider {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GrapeCity.ActiveReports.Design.Toolbox Namespace

GrapeCity.ActiveReports.Design.Toolbox Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.Toolbox Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Design.Toolbox namespace contains classes for adding controls to the designer toolbox.

Classes

 | Class | Description
Class | BaseToolbox |
Class | FlatToolbox |
Class | Group | Represents a grouping of related tools within the Toolbox control.
Class | GroupChangedEventArgs | Provides data for the GroupChanged event of the GroupListBar object.
Class | Toolbox | The base class for the Toolbox control that provides the methods and properties to manage and query the Designer toolbox.
Class | ToolClickEventArgs | Provides data for the ToolClick event.

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


BaseToolbox Class

[image]
ActiveReports 13
BaseToolbox Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : BaseToolbox Class

Glossary Item Box

Object Model

BaseToolbox Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseToolbox
   Inherits GroupListbar
C#
public abstract class BaseToolbox : GroupListbar

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox
GrapeCity.ActiveReports.Design.Toolbox.FlatToolbox
GrapeCity.ActiveReports.Design.Toolbox.Toolbox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


BaseToolbox Class Members

[image]
ActiveReports 13
BaseToolbox Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : BaseToolbox Class

Glossary Item Box

The following tables list the members exposed by BaseToolbox.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | The CategoryNames property indicates the categories currently available on the toolbox.
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | The SelectedCategory property indicates the currently selected toolbox category.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | AddCreator | Overloaded. The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem.
Public Method | AddLinkedToolboxItem | Overloaded. The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox.
Public Method | AddToolboxItem | Overloaded. The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ChangeVisibilityCategory | Change the visibility of the category
Public Method | ConfigureToolboxItems | Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Enable/disable disable category.
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EnsureCategories | Update all categories.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns readonly wrapper under groups collection.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected toolbox item.
Public Method | GetToolboxItems | Overloaded. Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox.
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes.
Public Method | IsToolboxItem | Overloaded.
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | RemoveCreator | Overloaded. The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented
Public Method | RemoveToolboxItem | Overloaded. The RemoveToolboxItem method removes the specified ToolboxItem.
Public Method | Reorder | Update according designer state.
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | The SelectedToolboxItemUsed method signals the toolbox that the selected toolbox item has been used.
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | The SerializeToolboxItem method returns a serialized object representing the specified ToolboxItem.
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | The SetCursor method sets the mouse cursor to a cursor that represents the current toolbox item.
Public Method | SetSelectedToolboxItem | The SetSelectedToolboxItem method selects the specified ToolboxItem as the current toolbox item.
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BaseToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


BaseToolbox Class Methods

[image]
ActiveReports 13
BaseToolbox Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : BaseToolbox Class

Glossary Item Box

For a list of all members of this type, see BaseToolbox members.

Public Methods

 | Name | Description
Public Method | AddCreator | Overloaded. The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem.
Public Method | AddLinkedToolboxItem | Overloaded. The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox.
Public Method | AddToolboxItem | Overloaded. The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ChangeVisibilityCategory | Change the visibility of the category
Public Method | ConfigureToolboxItems | Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Enable/disable disable category.
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EnsureCategories | Update all categories.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns readonly wrapper under groups collection.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected toolbox item.
Public Method | GetToolboxItems | Overloaded. Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox.
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes.
Public Method | IsToolboxItem | Overloaded.
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | RemoveCreator | Overloaded. The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented
Public Method | RemoveToolboxItem | Overloaded. The RemoveToolboxItem method removes the specified ToolboxItem.
Public Method | Reorder | Update according designer state.
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | The SelectedToolboxItemUsed method signals the toolbox that the selected toolbox item has been used.
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | The SerializeToolboxItem method returns a serialized object representing the specified ToolboxItem.
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | The SetCursor method sets the mouse cursor to a cursor that represents the current toolbox item.
Public Method | SetSelectedToolboxItem | The SetSelectedToolboxItem method selects the specified ToolboxItem as the current toolbox item.
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

BaseToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


AddCreator Method

[image]
ActiveReports 13
AddCreator Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AddCreator Method

Glossary Item Box

The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem.

Overload List

Overload | Description
AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) | The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem.
AddCreator(ToolboxItemCreatorCallback,String) | The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) Method

[image]
ActiveReports 13
AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > AddCreator Method : AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) Method

creator
format
host

Glossary Item Box

The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddCreator( _
   ByVal creator As ToolboxItemCreatorCallback, _
   ByVal format As String, _
   ByVal host As IDesignerHost _
)
C#
public void AddCreator(
   ToolboxItemCreatorCallback creator,
   string format,
   IDesignerHost host
)

Parameters

creator
format
host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


AddCreator(ToolboxItemCreatorCallback,String) Method

[image]
ActiveReports 13
AddCreator(ToolboxItemCreatorCallback,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > AddCreator Method : AddCreator(ToolboxItemCreatorCallback,String) Method

creator
format

Glossary Item Box

The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddCreator( _
   ByVal creator As ToolboxItemCreatorCallback, _
   ByVal format As String _
)
C#
public void AddCreator(
   ToolboxItemCreatorCallback creator,
   string format
)

Parameters

creator
format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


AddLinkedToolboxItem Method

[image]
ActiveReports 13
AddLinkedToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AddLinkedToolboxItem Method

Glossary Item Box

The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox.

Overload List

Overload | Description
AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) | The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox.
AddLinkedToolboxItem(ToolboxItem,IDesignerHost) | The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) Method

[image]
ActiveReports 13
AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > AddLinkedToolboxItem Method : AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) Method

toolboxItem
category
host

Glossary Item Box

The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddLinkedToolboxItem( _
   ByVal toolboxItem As ToolboxItem, _
   ByVal category As String, _
   ByVal host As IDesignerHost _
)
C#
public void AddLinkedToolboxItem(
   ToolboxItem toolboxItem,
   string category,
   IDesignerHost host
)

Parameters

toolboxItem
category
host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


AddLinkedToolboxItem(ToolboxItem,IDesignerHost) Method

[image]
ActiveReports 13
AddLinkedToolboxItem(ToolboxItem,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > AddLinkedToolboxItem Method : AddLinkedToolboxItem(ToolboxItem,IDesignerHost) Method

toolboxItem
host

Glossary Item Box

The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddLinkedToolboxItem( _
   ByVal toolboxItem As ToolboxItem, _
   ByVal host As IDesignerHost _
)
C#
public void AddLinkedToolboxItem(
   ToolboxItem toolboxItem,
   IDesignerHost host
)

Parameters

toolboxItem
host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


AddToolboxItem Method

[image]
ActiveReports 13
AddToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AddToolboxItem Method

Glossary Item Box

The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.

Overload List

Overload | Description
AddToolboxItem(ToolboxItem,String) | The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.
AddToolboxItem(ToolboxItem) | The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AddToolboxItem(ToolboxItem,String) Method

[image]
ActiveReports 13
AddToolboxItem(ToolboxItem,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > AddToolboxItem Method : AddToolboxItem(ToolboxItem,String) Method

toolboxItem
category

Glossary Item Box

The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub AddToolboxItem( _
   ByVal toolboxItem As ToolboxItem, _
   ByVal category As String _
)
C#
public virtual void AddToolboxItem(
   ToolboxItem toolboxItem,
   string category
)

Parameters

toolboxItem
category

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


AddToolboxItem(ToolboxItem) Method

[image]
ActiveReports 13
AddToolboxItem(ToolboxItem) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > AddToolboxItem Method : AddToolboxItem(ToolboxItem) Method

toolboxItem

Glossary Item Box

The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddToolboxItem( _
   ByVal toolboxItem As ToolboxItem _
)
C#
public void AddToolboxItem(
   ToolboxItem toolboxItem
)

Parameters

toolboxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


ChangeVisibilityCategory Method

[image]
ActiveReports 13
ChangeVisibilityCategory Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ChangeVisibilityCategory Method

category
enableVisibility

Glossary Item Box

Change the visibility of the category

Syntax

Visual Basic (Declaration)
Public Sub ChangeVisibilityCategory( _
   ByVal category As String, _
   ByVal enableVisibility As Boolean _
)
C#
public void ChangeVisibilityCategory(
   string category,
   bool enableVisibility
)

Parameters

category
enableVisibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ConfigureToolboxItems(IToolboxUser) Method

[image]
ActiveReports 13
ConfigureToolboxItems(IToolboxUser) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ConfigureToolboxItems(IToolboxUser) Method

toolboxUser

Glossary Item Box

Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable

Syntax

Visual Basic (Declaration)
Public Sub ConfigureToolboxItems( _
   ByVal toolboxUser As IToolboxUser _
)
C#
public void ConfigureToolboxItems(
   IToolboxUser toolboxUser
)

Parameters

toolboxUser

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DeserializeToolboxItem Method

[image]
ActiveReports 13
DeserializeToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DeserializeToolboxItem Method

Glossary Item Box

The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object.

Overload List

Overload | Description
DeserializeToolboxItem(Object,IDesignerHost) | The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object.
DeserializeToolboxItem(Object) | The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DeserializeToolboxItem(Object,IDesignerHost) Method

[image]
ActiveReports 13
DeserializeToolboxItem(Object,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > DeserializeToolboxItem Method : DeserializeToolboxItem(Object,IDesignerHost) Method

serializedObject
host

Glossary Item Box

The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object.

Syntax

Visual Basic (Declaration)
Public Overloads Function DeserializeToolboxItem( _
   ByVal serializedObject As Object, _
   ByVal host As IDesignerHost _
) As ToolboxItem
C#
public ToolboxItem DeserializeToolboxItem(
   object serializedObject,
   IDesignerHost host
)

Parameters

serializedObject
host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


DeserializeToolboxItem(Object) Method

[image]
ActiveReports 13
DeserializeToolboxItem(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > DeserializeToolboxItem Method : DeserializeToolboxItem(Object) Method

serializedObject

Glossary Item Box

The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object.

Syntax

Visual Basic (Declaration)
Public Overloads Function DeserializeToolboxItem( _
   ByVal serializedObject As Object _
) As ToolboxItem
C#
public ToolboxItem DeserializeToolboxItem(
   object serializedObject
)

Parameters

serializedObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


EnableCategory Method

[image]
ActiveReports 13
EnableCategory Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : EnableCategory Method

category
enable

Glossary Item Box

Enable/disable disable category.

Syntax

Visual Basic (Declaration)
Public Sub EnableCategory( _
   ByVal category As String, _
   ByVal enable As Boolean _
)
C#
public void EnableCategory(
   string category,
   bool enable
)

Parameters

category
enable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


EnsureCategories Method

[image]
ActiveReports 13
EnsureCategories Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : EnsureCategories Method

Glossary Item Box

Update all categories.

Syntax

Visual Basic (Declaration)
Public Sub EnsureCategories()
C#
public void EnsureCategories()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetGroups Method

[image]
ActiveReports 13
GetGroups Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetGroups Method

Glossary Item Box

Returns readonly wrapper under groups collection.

Syntax

Visual Basic (Declaration)
Public Function GetGroups() As ReadOnlyCollection(Of Group)
C#
public ReadOnlyCollection<Group> GetGroups()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetSelectedToolboxItem Method

[image]
ActiveReports 13
GetSelectedToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetSelectedToolboxItem Method

Glossary Item Box

Gets the currently selected toolbox item.

Overload List

Overload | Description
GetSelectedToolboxItem(IDesignerHost) | Gets the currently selected toolbox item.
GetSelectedToolboxItem() | Gets the currently selected toolbox item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetSelectedToolboxItem(IDesignerHost) Method

[image]
ActiveReports 13
GetSelectedToolboxItem(IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetSelectedToolboxItem Method : GetSelectedToolboxItem(IDesignerHost) Method

host

Glossary Item Box

Gets the currently selected toolbox item.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSelectedToolboxItem( _
   ByVal host As IDesignerHost _
) As ToolboxItem
C#
public ToolboxItem GetSelectedToolboxItem(
   IDesignerHost host
)

Parameters

host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


GetSelectedToolboxItem() Method

[image]
ActiveReports 13
GetSelectedToolboxItem() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetSelectedToolboxItem Method : GetSelectedToolboxItem() Method

Glossary Item Box

Gets the currently selected toolbox item.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSelectedToolboxItem() As ToolboxItem
C#
public ToolboxItem GetSelectedToolboxItem()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


GetToolboxItems Method

[image]
ActiveReports 13
GetToolboxItems Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetToolboxItems Method

Glossary Item Box

Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox.

Overload List

Overload | Description
GetToolboxItems(String,IDesignerHost) | Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox.
GetToolboxItems(String) | Gets a collection of toolbox items from the toolbox that match the specified category.
GetToolboxItems(IDesignerHost) | Gets the collection of toolbox items that are associated with the specified designer host from the toolbox.
GetToolboxItems() | Gets the entire collection of toolbox items from the toolbox.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetToolboxItems(String,IDesignerHost) Method

[image]
ActiveReports 13
GetToolboxItems(String,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetToolboxItems Method : GetToolboxItems(String,IDesignerHost) Method

category
The toolbox item category to retrieve the toolbox items from.
host
The System.ComponentModel.Design.IDesignerHost that is associated with the toolbox items to retrieve.

Glossary Item Box

Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetToolboxItems( _
   ByVal category As String, _
   ByVal host As IDesignerHost _
) As ToolboxItemCollection
C#
public ToolboxItemCollection GetToolboxItems(
   string category,
   IDesignerHost host
)

Parameters

category
The toolbox item category to retrieve the toolbox items from.
host
The System.ComponentModel.Design.IDesignerHost that is associated with the toolbox items to retrieve.

Return Value

A System.Drawing.Design.ToolboxItemCollection that contains the current toolbox items that are associated with the specified category and designer host.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


GetToolboxItems(String) Method

[image]
ActiveReports 13
GetToolboxItems(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetToolboxItems Method : GetToolboxItems(String) Method

category
The toolbox item category to retrieve all the toolbox items from.

Glossary Item Box

Gets a collection of toolbox items from the toolbox that match the specified category.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetToolboxItems( _
   ByVal category As String _
) As ToolboxItemCollection
C#
public ToolboxItemCollection GetToolboxItems(
   string category
)

Parameters

category
The toolbox item category to retrieve all the toolbox items from.

Return Value

A System.Drawing.Design.ToolboxItemCollection that contains the current toolbox items that are associated with the specified category.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


GetToolboxItems(IDesignerHost) Method

[image]
ActiveReports 13
GetToolboxItems(IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetToolboxItems Method : GetToolboxItems(IDesignerHost) Method

host
The System.ComponentModel.Design.IDesignerHost that is associated with the toolbox items to retrieve.

Glossary Item Box

Gets the collection of toolbox items that are associated with the specified designer host from the toolbox.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetToolboxItems( _
   ByVal host As IDesignerHost _
) As ToolboxItemCollection
C#
public ToolboxItemCollection GetToolboxItems(
   IDesignerHost host
)

Parameters

host
The System.ComponentModel.Design.IDesignerHost that is associated with the toolbox items to retrieve.

Return Value

A System.Drawing.Design.ToolboxItemCollection that contains the current toolbox items that are associated with the specified designer host.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


GetToolboxItems() Method

[image]
ActiveReports 13
GetToolboxItems() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetToolboxItems Method : GetToolboxItems() Method

Glossary Item Box

Gets the entire collection of toolbox items from the toolbox.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetToolboxItems() As ToolboxItemCollection
C#
public ToolboxItemCollection GetToolboxItems()

Return Value

A System.Drawing.Design.ToolboxItemCollection that contains the current toolbox items.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


IsSupported Method

[image]
ActiveReports 13
IsSupported Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : IsSupported Method

Glossary Item Box

The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes.

Overload List

Overload | Description
IsSupported(Object,ICollection) | The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes.
IsSupported(Object,IDesignerHost) | The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


IsSupported(Object,ICollection) Method

[image]
ActiveReports 13
IsSupported(Object,ICollection) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > IsSupported Method : IsSupported(Object,ICollection) Method

serializedObject
filterAttributes

Glossary Item Box

The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsSupported( _
   ByVal serializedObject As Object, _
   ByVal filterAttributes As ICollection _
) As Boolean
C#
public bool IsSupported(
   object serializedObject,
   ICollection filterAttributes
)

Parameters

serializedObject
filterAttributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


IsSupported(Object,IDesignerHost) Method

[image]
ActiveReports 13
IsSupported(Object,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > IsSupported Method : IsSupported(Object,IDesignerHost) Method

serializedObject
host

Glossary Item Box

The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsSupported( _
   ByVal serializedObject As Object, _
   ByVal host As IDesignerHost _
) As Boolean
C#
public bool IsSupported(
   object serializedObject,
   IDesignerHost host
)

Parameters

serializedObject
host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


IsToolboxItem Method

[image]
ActiveReports 13
IsToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : IsToolboxItem Method

Glossary Item Box

Overload List

Overload | Description
IsToolboxItem(Object,IDesignerHost) |
IsToolboxItem(Object) | The IsToolboxItem method indicates whether the specified serialized object is a ToolboxItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


IsToolboxItem(Object,IDesignerHost) Method

[image]
ActiveReports 13
IsToolboxItem(Object,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > IsToolboxItem Method : IsToolboxItem(Object,IDesignerHost) Method

serializedObject
host

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsToolboxItem( _
   ByVal serializedObject As Object, _
   ByVal host As IDesignerHost _
) As Boolean
C#
public bool IsToolboxItem(
   object serializedObject,
   IDesignerHost host
)

Parameters

serializedObject
host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


IsToolboxItem(Object) Method

[image]
ActiveReports 13
IsToolboxItem(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > IsToolboxItem Method : IsToolboxItem(Object) Method

serializedObject

Glossary Item Box

The IsToolboxItem method indicates whether the specified serialized object is a ToolboxItem.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsToolboxItem( _
   ByVal serializedObject As Object _
) As Boolean
C#
public bool IsToolboxItem(
   object serializedObject
)

Parameters

serializedObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


RemoveCreator Method

[image]
ActiveReports 13
RemoveCreator Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RemoveCreator Method

Glossary Item Box

The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented

Overload List

Overload | Description
RemoveCreator(String,IDesignerHost) | The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented
RemoveCreator(String) | The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RemoveCreator(String,IDesignerHost) Method

[image]
ActiveReports 13
RemoveCreator(String,IDesignerHost) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > RemoveCreator Method : RemoveCreator(String,IDesignerHost) Method

format
host

Glossary Item Box

The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented

Syntax

Visual Basic (Declaration)
Public Overloads Sub RemoveCreator( _
   ByVal format As String, _
   ByVal host As IDesignerHost _
)
C#
public void RemoveCreator(
   string format,
   IDesignerHost host
)

Parameters

format
host

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


RemoveCreator(String) Method

[image]
ActiveReports 13
RemoveCreator(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > RemoveCreator Method : RemoveCreator(String) Method

format

Glossary Item Box

The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented

Syntax

Visual Basic (Declaration)
Public Overloads Sub RemoveCreator( _
   ByVal format As String _
)
C#
public void RemoveCreator(
   string format
)

Parameters

format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


RemoveToolboxItem Method

[image]
ActiveReports 13
RemoveToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RemoveToolboxItem Method

Glossary Item Box

The RemoveToolboxItem method removes the specified ToolboxItem.

Overload List

Overload | Description
RemoveToolboxItem(ToolboxItem,String) | The RemoveToolboxItem method removes the specified ToolboxItem.
RemoveToolboxItem(ToolboxItem) | The RemoveToolboxItem method removes the specified ToolboxItem.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RemoveToolboxItem(ToolboxItem,String) Method

[image]
ActiveReports 13
RemoveToolboxItem(ToolboxItem,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > RemoveToolboxItem Method : RemoveToolboxItem(ToolboxItem,String) Method

toolboxItem
category

Glossary Item Box

The RemoveToolboxItem method removes the specified ToolboxItem.

Syntax

Visual Basic (Declaration)
Public Overloads Sub RemoveToolboxItem( _
   ByVal toolboxItem As ToolboxItem, _
   ByVal category As String _
)
C#
public void RemoveToolboxItem(
   ToolboxItem toolboxItem,
   string category
)

Parameters

toolboxItem
category

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


RemoveToolboxItem(ToolboxItem) Method

[image]
ActiveReports 13
RemoveToolboxItem(ToolboxItem) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > RemoveToolboxItem Method : RemoveToolboxItem(ToolboxItem) Method

toolboxItem

Glossary Item Box

The RemoveToolboxItem method removes the specified ToolboxItem.

Syntax

Visual Basic (Declaration)
Public Overloads Sub RemoveToolboxItem( _
   ByVal toolboxItem As ToolboxItem _
)
C#
public void RemoveToolboxItem(
   ToolboxItem toolboxItem
)

Parameters

toolboxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Reorder Method

[image]
ActiveReports 13
Reorder Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Reorder Method

designer

Glossary Item Box

Update according designer state.

Syntax

Visual Basic (Declaration)
Public Sub Reorder( _
   ByVal designer As Designer _
)
C#
public void Reorder(
   Designer designer
)

Parameters

designer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SelectedToolboxItemUsed Method

[image]
ActiveReports 13
SelectedToolboxItemUsed Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SelectedToolboxItemUsed Method

Glossary Item Box

The SelectedToolboxItemUsed method signals the toolbox that the selected toolbox item has been used.

Syntax

Visual Basic (Declaration)
Public Sub SelectedToolboxItemUsed()
C#
public void SelectedToolboxItemUsed()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SerializeToolboxItem Method

[image]
ActiveReports 13
SerializeToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SerializeToolboxItem Method

toolboxItem

Glossary Item Box

The SerializeToolboxItem method returns a serialized object representing the specified ToolboxItem.

Syntax

Visual Basic (Declaration)
Public Function SerializeToolboxItem( _
   ByVal toolboxItem As ToolboxItem _
) As Object
C#
public object SerializeToolboxItem(
   ToolboxItem toolboxItem
)

Parameters

toolboxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SetCursor Method

[image]
ActiveReports 13
SetCursor Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SetCursor Method

Glossary Item Box

The SetCursor method sets the mouse cursor to a cursor that represents the current toolbox item.

Syntax

Visual Basic (Declaration)
Public Function SetCursor() As Boolean
C#
public bool SetCursor()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SetSelectedToolboxItem Method

[image]
ActiveReports 13
SetSelectedToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SetSelectedToolboxItem Method

toolboxItem

Glossary Item Box

The SetSelectedToolboxItem method selects the specified ToolboxItem as the current toolbox item.

Syntax

Visual Basic (Declaration)
Public Sub SetSelectedToolboxItem( _
   ByVal toolboxItem As ToolboxItem _
)
C#
public void SetSelectedToolboxItem(
   ToolboxItem toolboxItem
)

Parameters

toolboxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BaseToolbox Class Properties

[image]
ActiveReports 13
BaseToolbox Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : BaseToolbox Class

Glossary Item Box

For a list of all members of this type, see BaseToolbox members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | The CategoryNames property indicates the categories currently available on the toolbox.
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | The SelectedCategory property indicates the currently selected toolbox category.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BaseToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


CategoryNames Property

[image]
ActiveReports 13
CategoryNames Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CategoryNames Property

Glossary Item Box

The CategoryNames property indicates the categories currently available on the toolbox.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CategoryNames As CategoryNameCollection
C#
public CategoryNameCollection CategoryNames {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DesignerHost Property

[image]
ActiveReports 13
DesignerHost Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DesignerHost Property

Glossary Item Box

DesignerHost provides additional features for toolbox then it used as part of designer application

Syntax

Visual Basic (Declaration)
Public Property DesignerHost As IDesignerHost
C#
public IDesignerHost DesignerHost {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Groups Property

[image]
ActiveReports 13
Groups Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Groups Property

Glossary Item Box

Returns groups collection.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Groups As IList(Of Group)
C#
public new IList<Group> Groups {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SelectedCategory Property

[image]
ActiveReports 13
SelectedCategory Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SelectedCategory Property

Glossary Item Box

The SelectedCategory property indicates the currently selected toolbox category.

Syntax

Visual Basic (Declaration)
Public Property SelectedCategory As String
C#
public string SelectedCategory {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


FlatToolbox Class

[image]
ActiveReports 13
FlatToolbox Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : FlatToolbox Class

Glossary Item Box

Object Model

FlatToolbox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FlatToolbox
   Inherits BaseToolbox
C#
public sealed class FlatToolbox : BaseToolbox

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox
GrapeCity.ActiveReports.Design.Toolbox.FlatToolbox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


FlatToolbox Class Members

[image]
ActiveReports 13
FlatToolbox Class Members
See Also Fields Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : FlatToolbox Class

Glossary Item Box

The following tables list the members exposed by FlatToolbox.

Public Constructors

 | Name | Description
Public Constructor | FlatToolbox Constructor |
Top

Public Fields

 | Name | Description
Public Field | _tooltip |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | The CategoryNames property indicates the categories currently available on the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | Maximized |
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | The SelectedCategory property indicates the currently selected toolbox category. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | AddCreator | Overloaded. The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddLinkedToolboxItem | Overloaded. The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddToolboxItem | Overloaded. Overridden. The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ChangeVisibilityCategory | Change the visibility of the category (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ConfigureToolboxItems | Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Enable/disable disable category. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EnsureCategories | Update all categories. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns readonly wrapper under groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected toolbox item. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetToolboxItems | Overloaded. Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | IsToolboxItem | Overloaded. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | RemoveCreator | Overloaded. The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | RemoveToolboxItem | Overloaded. The RemoveToolboxItem method removes the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Reorder | Update according designer state. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | The SelectedToolboxItemUsed method signals the toolbox that the selected toolbox item has been used. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | The SerializeToolboxItem method returns a serialized object representing the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | The SetCursor method sets the mouse cursor to a cursor that represents the current toolbox item. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetSelectedToolboxItem | The SetSelectedToolboxItem method selects the specified ToolboxItem as the current toolbox item. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FlatToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


FlatToolbox Constructor

[image]
ActiveReports 13
FlatToolbox Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : FlatToolbox Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FlatToolbox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


FlatToolbox Class Methods

[image]
ActiveReports 13
FlatToolbox Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : FlatToolbox Class

Glossary Item Box

For a list of all members of this type, see FlatToolbox members.

Public Methods

 | Name | Description
Public Method | AddCreator | Overloaded. The AddCreator method adds a ToolboxItemCreatorCallback delegate capable of converting some type of data stored on the toolbox to a ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddLinkedToolboxItem | Overloaded. The AddLinkedToolboxItem method adds a ToolboxItem that is only enabled for the current project to the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddToolboxItem | Overloaded. Overridden. The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ChangeVisibilityCategory | Change the visibility of the category (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ConfigureToolboxItems | Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. The DeserializeToolboxItem method attemps to return a ToolboxItem from the specified serialized toolbox item object. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Enable/disable disable category. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EnsureCategories | Update all categories. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns readonly wrapper under groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected toolbox item. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetToolboxItems | Overloaded. Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. The IsSupported method indicates whether the specified serialized object, if it is a ToolboxItem, is supported by the specified designer host, or whether it matches the specified attributes. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | IsToolboxItem | Overloaded. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | RemoveCreator | Overloaded. The RemoveCreator method removes any ToolboxItemCreatorCallback delegates for the specified data type. Currently not implemented (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | RemoveToolboxItem | Overloaded. The RemoveToolboxItem method removes the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Reorder | Update according designer state. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | The SelectedToolboxItemUsed method signals the toolbox that the selected toolbox item has been used. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | The SerializeToolboxItem method returns a serialized object representing the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | The SetCursor method sets the mouse cursor to a cursor that represents the current toolbox item. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetSelectedToolboxItem | The SetSelectedToolboxItem method selects the specified ToolboxItem as the current toolbox item. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

FlatToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


AddToolboxItem Method

[image]
ActiveReports 13
AddToolboxItem Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AddToolboxItem Method

Glossary Item Box

The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.

Overload List

Overload | Description
AddToolboxItem(ToolboxItem,String) | The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.
AddToolboxItem(ToolboxItem) | The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AddToolboxItem(ToolboxItem,String) Method

[image]
ActiveReports 13
AddToolboxItem(ToolboxItem,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > AddToolboxItem Method : AddToolboxItem(ToolboxItem,String) Method

toolboxItem
category

Glossary Item Box

The AddToolboxItem method adds a ToolboxItem to the toolbox, creating the optionally specified category if it does not exist.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub AddToolboxItem( _
   ByVal toolboxItem As ToolboxItem, _
   ByVal category As String _
)
C#
public override void AddToolboxItem(
   ToolboxItem toolboxItem,
   string category
)

Parameters

toolboxItem
category

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


FlatToolbox Class Properties

[image]
ActiveReports 13
FlatToolbox Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : FlatToolbox Class

Glossary Item Box

For a list of all members of this type, see FlatToolbox members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | The CategoryNames property indicates the categories currently available on the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | Maximized |
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | The SelectedCategory property indicates the currently selected toolbox category. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FlatToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Maximized Property

[image]
ActiveReports 13
Maximized Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Maximized Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Maximized As Boolean
C#
public bool Maximized {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


FlatToolbox Class Fields

[image]
ActiveReports 13
FlatToolbox Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : FlatToolbox Class

Glossary Item Box

For a list of all members of this type, see FlatToolbox members.

Public Fields

 | Name | Description
Public Field | _tooltip |
Top

See Also

Reference

FlatToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


_tooltip Field

[image]
ActiveReports 13
_tooltip Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : _tooltip Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public _tooltip As ToolTip
C#
public ToolTip _tooltip

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Group Class

[image]
ActiveReports 13
Group Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

Glossary Item Box

Represents a grouping of related tools within the Toolbox control.

Object Model

Group Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Group
   Inherits System.ComponentModel.Component
C#
public sealed class Group : System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Design.Toolbox.Group

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Class Members

[image]
ActiveReports 13
Group Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

Glossary Item Box

The following tables list the members exposed by Group.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the group caption. The default value is 'Group'.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Class Properties

[image]
ActiveReports 13
Group Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

Glossary Item Box

For a list of all members of this type, see Group members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the group caption. The default value is 'Group'.
Top

See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Text Property

Glossary Item Box

Gets or sets the group caption. The default value is 'Group'.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


GroupChangedEventArgs Class

[image]
ActiveReports 13
GroupChangedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : GroupChangedEventArgs Class

Glossary Item Box

Provides data for the GroupChanged event of the GroupListBar object.

Object Model

GroupChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GroupChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class GroupChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.Toolbox.GroupChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupChangedEventArgs Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


GroupChangedEventArgs Class Members

[image]
ActiveReports 13
GroupChangedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : GroupChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by GroupChangedEventArgs.

Public Properties

 | Name | Description
Public Property | Group | Gets the currently selected group.
Top

See Also

Reference

GroupChangedEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


GroupChangedEventArgs Class Properties

[image]
ActiveReports 13
GroupChangedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : GroupChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see GroupChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Group | Gets the currently selected group.
Top

See Also

Reference

GroupChangedEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Property

[image]
ActiveReports 13
Group Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > GroupChangedEventArgs Class : Group Property

Glossary Item Box

Gets the currently selected group.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Group As String
C#
public string Group {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupChangedEventArgs Class
GroupChangedEventArgs Members


Toolbox Class

[image]
ActiveReports 13
Toolbox Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

Glossary Item Box

The base class for the Toolbox control that provides the methods and properties to manage and query the Designer toolbox.

Object Model

Toolbox Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Toolbox
   Inherits BaseToolbox
C#
public sealed class Toolbox : BaseToolbox

Remarks

The Toolbox control can be used in conjunction with the End-User Report Designer control to provide a drag-and-drop interface of the tools available for use on reports.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox
GrapeCity.ActiveReports.Design.Toolbox.Toolbox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


Toolbox Class Members

[image]
ActiveReports 13
Toolbox Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

Glossary Item Box

The following tables list the members exposed by Toolbox.

Public Constructors

 | Name | Description
Public Constructor | Toolbox Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | Gets the System.Drawing.Design CategoryNameCollection containing the categories available in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | Gets or sets the currently selected toolbox category. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | AddCreator | Overloaded. Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddLinkedToolboxItem | Overloaded. Adds a ToolboxItem that is only available in the current project to the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddToolboxItem | Overloaded. Adds a ToolboxItem to the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ChangeVisibilityCategory | Change the visibility of the category (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ConfigureToolboxItems | Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. Gets a ToolboxItem from the specified serialized object. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Specifies a category name to enable or disable. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns a read-only wrapper for the Groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetToolboxItems | Overloaded. Gets the ToolboxItemCollection associated with the specified host from the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. Indicates whether the ToolboxItem in the specified serialized object is matches the specified attributes. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | IsToolboxItem | Overloaded. Indicates whether the item in the specified serialized object that is supported by the specified host is a ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | RemoveToolboxItem | Overloaded. Removes the specified ToolboxItem from the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | Signals the toolbox that the selected ToolboxItem has been used. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | Creates a serialized System.Object representing the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | Sets the cursor to a cursor that represents the current ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetSelectedToolboxItem | Selects the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Toolbox Constructor

[image]
ActiveReports 13
Toolbox Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Toolbox Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Toolbox()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ToolClickEventArgs Class

[image]
ActiveReports 13
ToolClickEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : ToolClickEventArgs Class

Glossary Item Box

Provides data for the ToolClick event.

Object Model

ToolClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolClickEventArgs
   Inherits System.EventArgs
C#
public sealed class ToolClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.Toolbox.ToolClickEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolClickEventArgs Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


ToolClickEventArgs Class Members

[image]
ActiveReports 13
ToolClickEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : ToolClickEventArgs Class

Glossary Item Box

The following tables list the members exposed by ToolClickEventArgs.

Public Properties

 | Name | Description
Public Property | Clicks | Number of clicks on the toolbox item.
Public Property | ToolText | Gets clicked tool text.
Top

See Also

Reference

ToolClickEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


ToolClickEventArgs Class Properties

[image]
ActiveReports 13
ToolClickEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : ToolClickEventArgs Class

Glossary Item Box

For a list of all members of this type, see ToolClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Clicks | Number of clicks on the toolbox item.
Public Property | ToolText | Gets clicked tool text.
Top

See Also

Reference

ToolClickEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Clicks Property

[image]
ActiveReports 13
Clicks Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > ToolClickEventArgs Class : Clicks Property

Glossary Item Box

Number of clicks on the toolbox item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Clicks As Integer
C#
public int Clicks {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolClickEventArgs Class
ToolClickEventArgs Members


ToolText Property

[image]
ActiveReports 13
ToolText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > ToolClickEventArgs Class : ToolText Property

Glossary Item Box

Gets clicked tool text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToolText As String
C#
public string ToolText {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolClickEventArgs Class
ToolClickEventArgs Members


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document)

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports Namespace

Glossary Item Box

The GrapeCity.ActiveReports namespace contains the Border class and its settings.

Classes

 | Class | Description
Class | Border | Paints a border around the control area.
Class | Border.BorderMargins | Gets the amount of padding around the content of the control.
Class | PaddingExtension |

Structures

 | Structure | Description
Structure | PaddingEx | Provides the settings used to set a margin (four edges) inside a control.

Enumerations

 | Enumeration | Description
Enumeration | BorderLineStyle | Specifies the line style used to draw the border line.

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


Border Class

[image]
ActiveReports 13
Border Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

Paints a border around the control area.

Object Model

Border Class

Syntax

Visual Basic (Declaration)
Public Class Border
C#
public class Border

Remarks

Borders are painted outside the control area.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.Shadow = true;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.Shadow = True
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Border

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Members
GrapeCity.ActiveReports Namespace


Border Class Members

[image]
ActiveReports 13
Border Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

The following tables list the members exposed by Border.

Public Constructors

 | Name | Description
Public Constructor | Border Constructor | Initializes a new instance of the Border class.
Top

Public Properties

 | Name | Description
Public Property | BottomColor | Gets or sets the line color of the bottom edge of the border.
Public Property | BottomStyle | Gets or sets the line style of the bottom edge of the border.
Public Property | Color | Sets or returns the color of a control's border.
Public Property | LeftColor | Gets or sets the line color of the left edge of the border.
Public Property | LeftStyle | Gets or sets the line style of the left edge of the border.
Public Property | RightColor | Gets or sets the line color of the right edge of the border.
Public Property | RightStyle | Gets or sets the line style of the right edge of the border.
Public Property | Shadow | Determines whether ActiveReports should paint a shadow around the right bottom edges of the control.
Public Property | Style | Sets or returns the BorderLineStyle of the border.
Public Property | TopColor | Gets or sets the line color of the top edge of the border.
Public Property | TopStyle | Gets or sets the line style of the top edge of the border.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance of the Border class.
Public Method | CopyTo | Copies the border to the specified border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


Border Constructor

[image]
ActiveReports 13
Border Constructor
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Border Constructor

Glossary Item Box

Initializes a new instance of the Border class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Border()

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.Shadow = true;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.Shadow = True
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Methods

[image]
ActiveReports 13
Border Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance of the Border class.
Public Method | CopyTo | Copies the border to the specified border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


Clone Method

[image]
ActiveReports 13
Clone Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance of the Border class.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Border
C#
public Border Clone()

Return Value

Border.

Example

Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Dim b As New GrapeCity.ActiveReports.Border
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
   b = Me.TextBox1.Border.Clone()
   Me.TextBox2.Border.BottomStyle = b.BottomStyle
   Me.TextBox2.Border.TopStyle = b.TopStyle
End Sub
C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    this.TextBox1.Border.BottomStyle = BorderLineStyle.ThickDash;
    this.TextBox1.Border.TopStyle = BorderLineStyle.ThickDash;
    b = this.TextBox1.Border.Clone();
    this.TextBox2.Border.BottomStyle = b.BottomStyle;
    this.TextBox2.Border.TopStyle = b.TopStyle;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : CopyTo Method

border
GrapeCity.ActiveReports.Border object.

Glossary Item Box

Copies the border to the specified border.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal border As Border _
)
C#
public void CopyTo(
   Border border
)

Parameters

border
GrapeCity.ActiveReports.Border object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border Class Properties

[image]
ActiveReports 13
Border Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : Border Class

Glossary Item Box

For a list of all members of this type, see Border members.

Public Properties

 | Name | Description
Public Property | BottomColor | Gets or sets the line color of the bottom edge of the border.
Public Property | BottomStyle | Gets or sets the line style of the bottom edge of the border.
Public Property | Color | Sets or returns the color of a control's border.
Public Property | LeftColor | Gets or sets the line color of the left edge of the border.
Public Property | LeftStyle | Gets or sets the line style of the left edge of the border.
Public Property | RightColor | Gets or sets the line color of the right edge of the border.
Public Property | RightStyle | Gets or sets the line style of the right edge of the border.
Public Property | Shadow | Determines whether ActiveReports should paint a shadow around the right bottom edges of the control.
Public Property | Style | Sets or returns the BorderLineStyle of the border.
Public Property | TopColor | Gets or sets the line color of the top edge of the border.
Public Property | TopStyle | Gets or sets the line style of the top edge of the border.
Top

See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


BottomColor Property

[image]
ActiveReports 13
BottomColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : BottomColor Property

Glossary Item Box

Gets or sets the line color of the bottom edge of the border.

Syntax

Visual Basic (Declaration)
Public Property BottomColor As Color
C#
public Color BottomColor {get; set;}

Property Value

The color of the bottom.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


BottomStyle Property

[image]
ActiveReports 13
BottomStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : BottomStyle Property

Glossary Item Box

Gets or sets the line style of the bottom edge of the border.

Syntax

Visual Basic (Declaration)
Public Property BottomStyle As BorderLineStyle
C#
public BorderLineStyle BottomStyle {get; set;}

Property Value

The bottom style.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Color Property

[image]
ActiveReports 13
Color Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Color Property

Glossary Item Box

Sets or returns the color of a control's border.

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Property Value

System.Drawing.Color.

Example

C# Copy Code
Private void GroupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.txtShipCountry.Border.Color = System.Drawing.Color.Purple;
}
Visual Basic Copy Code
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    Me.txtShipCountry.Border.Color = System.Drawing.Color.Purple
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


LeftColor Property

[image]
ActiveReports 13
LeftColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : LeftColor Property

Glossary Item Box

Gets or sets the line color of the left edge of the border.

Syntax

Visual Basic (Declaration)
Public Property LeftColor As Color
C#
public Color LeftColor {get; set;}

Property Value

The color of the left.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


LeftStyle Property

[image]
ActiveReports 13
LeftStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : LeftStyle Property

Glossary Item Box

Gets or sets the line style of the left edge of the border.

Syntax

Visual Basic (Declaration)
Public Property LeftStyle As BorderLineStyle
C#
public BorderLineStyle LeftStyle {get; set;}

Property Value

The left style.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


RightColor Property

[image]
ActiveReports 13
RightColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : RightColor Property

Glossary Item Box

Gets or sets the line color of the right edge of the border.

Syntax

Visual Basic (Declaration)
Public Property RightColor As Color
C#
public Color RightColor {get; set;}

Property Value

The color of the right.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


RightStyle Property

[image]
ActiveReports 13
RightStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : RightStyle Property

Glossary Item Box

Gets or sets the line style of the right edge of the border.

Syntax

Visual Basic (Declaration)
Public Property RightStyle As BorderLineStyle
C#
public BorderLineStyle RightStyle {get; set;}

Property Value

The right style.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Shadow Property

[image]
ActiveReports 13
Shadow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Shadow Property

Glossary Item Box

Determines whether ActiveReports should paint a shadow around the right bottom edges of the control.

Syntax

Visual Basic (Declaration)
Public Property Shadow As Boolean
C#
public bool Shadow {get; set;}

Property Value

true if shadow; otherwise, false.

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
         SectionReport1 rpt = new SectionReport1();
         rpt.Sections[0].Controls[0].Border.Shadow = true;
         rpt.Run();
         viewer1.Document = rpt.Document;
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Sections(0).Controls(0).Border.Shadow = True
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Style Property

[image]
ActiveReports 13
Style Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : Style Property

Glossary Item Box

Sets or returns the BorderLineStyle of the border.

Syntax

Visual Basic (Declaration)
Public Property Style As BorderLineStyle
C#
public BorderLineStyle Style {get; set;}

Property Value

GrapeCity.ActiveReports.BorderLineStyle enumeration.

Example

C# Copy Code
Private void PageHeader_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.Style = BorderLineStyle.ThickDashDotDot;
}
Visual Basic Copy Code
Private Sub PageHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles PageHeader.Format
    With Me.TextBox1.Border.Style = BorderLineStyle.ThickDashDotDot
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members
BorderLineStyle Enumeration


TopColor Property

[image]
ActiveReports 13
TopColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : TopColor Property

Glossary Item Box

Gets or sets the line color of the top edge of the border.

Syntax

Visual Basic (Declaration)
Public Property TopColor As Color
C#
public Color TopColor {get; set;}

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


TopStyle Property

[image]
ActiveReports 13
TopStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border Class : TopStyle Property

Glossary Item Box

Gets or sets the line style of the top edge of the border.

Syntax

Visual Basic (Declaration)
Public Property TopStyle As BorderLineStyle
C#
public BorderLineStyle TopStyle {get; set;}

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border Class
Border Members


Border.BorderMargins Class

[image]
ActiveReports 13
Border.BorderMargins Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

Glossary Item Box

Gets the amount of padding around the content of the control.

Object Model

Border.BorderMargins Class

Syntax

Visual Basic (Declaration)
Public Class Border.BorderMargins
C#
public class Border.BorderMargins

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Border.BorderMargins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Members
GrapeCity.ActiveReports Namespace


Border.BorderMargins Class Members

[image]
ActiveReports 13
Border.BorderMargins Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

Glossary Item Box

The following tables list the members exposed by Border.BorderMargins.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the amount of padding at the bottom edge of the control.
Public Property | Left | Gets the amount of padding at the left edge of the control.
Public Property | Right | Gets the amount of padding at the right edge of the control.
Public Property | Top | Gets the amount of padding at the top edge of the control.
Top

See Also

Reference

Border.BorderMargins Class
GrapeCity.ActiveReports Namespace


Border.BorderMargins Class Properties

[image]
ActiveReports 13
Border.BorderMargins Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

Glossary Item Box

For a list of all members of this type, see Border.BorderMargins members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the amount of padding at the bottom edge of the control.
Public Property | Left | Gets the amount of padding at the left edge of the control.
Public Property | Right | Gets the amount of padding at the right edge of the control.
Public Property | Top | Gets the amount of padding at the top edge of the control.
Top

See Also

Reference

Border.BorderMargins Class
GrapeCity.ActiveReports Namespace


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Bottom Property

Glossary Item Box

Gets the amount of padding at the bottom edge of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Left Property

Glossary Item Box

Gets the amount of padding at the left edge of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Integer
C#
public int Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Right Property

Glossary Item Box

Gets the amount of padding at the right edge of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Top Property

Glossary Item Box

Gets the amount of padding at the top edge of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Integer
C#
public int Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


PaddingExtension Class

[image]
ActiveReports 13
PaddingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingExtension Class

Glossary Item Box

Object Model

PaddingExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PaddingExtension
C#
public static class PaddingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PaddingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingExtension Members
GrapeCity.ActiveReports Namespace


PaddingExtension Class Members

[image]
ActiveReports 13
PaddingExtension Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingExtension Class

Glossary Item Box

The following tables list the members exposed by PaddingExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToGdiPadding |
Top

See Also

Reference

PaddingExtension Class
GrapeCity.ActiveReports Namespace


PaddingExtension Class Methods

[image]
ActiveReports 13
PaddingExtension Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingExtension Class

Glossary Item Box

For a list of all members of this type, see PaddingExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ToGdiPadding |
Top

See Also

Reference

PaddingExtension Class
GrapeCity.ActiveReports Namespace


ToGdiPadding Method

[image]
ActiveReports 13
ToGdiPadding Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingExtension Class : ToGdiPadding Method

padding

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ToGdiPadding( _
   ByVal padding As PaddingEx _
) As GrapeCity.ActiveReports.Drawing.Gdi.RText.PaddingEx
C#
public static GrapeCity.ActiveReports.Drawing.Gdi.RText.PaddingEx ToGdiPadding(
   PaddingEx padding
)

Parameters

padding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingExtension Class
PaddingExtension Members


BorderLineStyle Enumeration

[image]
ActiveReports 13
BorderLineStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : BorderLineStyle Enumeration

Glossary Item Box

Specifies the line style used to draw the border line.

Syntax

Visual Basic (Declaration)
Public Enum BorderLineStyle
   Inherits System.Enum
C#
public enum BorderLineStyle : System.Enum

Members

Member | Description
Dash | Dashed one pixel line.
DashDot | Dash dot one pixel line.
DashDotDot | Dash dot dot one pixel line.
Dot | Dotted one pixel line.
Double | Double line.
ExtraThickSolid | Extra thick solid line.
None | No line.
Solid | Solid one pixel line.
ThickDash | Thick dash line.
ThickDashDot | Thick dash dot line.
ThickDashDotDot | Thick dash dot dot line.
ThickDot | Thick dotted line.
ThickDouble | Thick double line.
ThickSolid | Thick solid line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BorderLineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports Namespace
Style Property


PaddingEx Structure

[image]
ActiveReports 13
PaddingEx Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

Provides the settings used to set a margin (four edges) inside a control.

Object Model

PaddingEx Structure

Syntax

Visual Basic (Declaration)
Public Structure PaddingEx
   Inherits System.ValueType
C#
public struct PaddingEx : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.PaddingEx

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Members
GrapeCity.ActiveReports Namespace


PaddingEx Structure Members

[image]
ActiveReports 13
PaddingEx Structure Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

The following tables list the members exposed by PaddingEx.

Public Constructors

 | Name | Description
Public Constructor | PaddingEx Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a PaddingEx object with no padding.
Top

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Public Method | GetHashCode | Generates a hash code for the PaddingEx object.
Top

Public Operators

public Operator Equality | Tests whether two PaddingEx objects are equivalent.
public Operator Inequality | Tests whether two PaddingEx objects are not equivalent.
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


PaddingEx Constructor

[image]
ActiveReports 13
PaddingEx Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : PaddingEx Constructor

Glossary Item Box

Initializes a new instance of the PaddingEx structure.

Overload List

Overload | Description
PaddingEx Constructor(Int32) | Initializes a new instance of the PaddingEx structure using the same value for all edges.
PaddingEx Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the PaddingEx structure using the specified value for each edge.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Constructor(Int32)

[image]
ActiveReports 13
PaddingEx Constructor(Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > PaddingEx Constructor : PaddingEx Constructor(Int32)

all
Applies the same value to all four edges of the control.

Glossary Item Box

Initializes a new instance of the PaddingEx structure using the same value for all edges.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal all As Integer _
)
C#
public PaddingEx(
   int all
)

Parameters

all
Applies the same value to all four edges of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


PaddingEx Constructor(Int32,Int32,Int32,Int32)

[image]
ActiveReports 13
PaddingEx Constructor(Int32,Int32,Int32,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > PaddingEx Constructor : PaddingEx Constructor(Int32,Int32,Int32,Int32)

left
The value to set for the left edge of the control.
top
The value to set for the top edge of the control.
right
The value to set for the right edge of the control.
bottom
The value to set for the bottom edge of the control.

Glossary Item Box

Initializes a new instance of the PaddingEx structure using the specified value for each edge.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
C#
public PaddingEx(
   int left,
   int top,
   int right,
   int bottom
)

Parameters

left
The value to set for the left edge of the control.
top
The value to set for the top edge of the control.
right
The value to set for the right edge of the control.
bottom
The value to set for the bottom edge of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


PaddingEx Structure Methods

[image]
ActiveReports 13
PaddingEx Structure Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see PaddingEx members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Public Method | GetHashCode | Generates a hash code for the PaddingEx object.
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Equals Method

Glossary Item Box

Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.

Overload List

Overload | Description
Equals(PaddingEx) | Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Equals(Object) | Determines whether the value of the specified object equals the current PaddingEx object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Equals(PaddingEx) Method

[image]
ActiveReports 13
Equals(PaddingEx) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > Equals Method : Equals(PaddingEx) Method

paddingEx
The PaddingEx object to compare to the current PaddingEx object.

Glossary Item Box

Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal paddingEx As PaddingEx _
) As Boolean
C#
public bool Equals(
   PaddingEx paddingEx
)

Parameters

paddingEx
The PaddingEx object to compare to the current PaddingEx object.

Return Value

true if the specified PaddingEx is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


Equals(Object) Method

[image]
ActiveReports 13
Equals(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > Equals Method : Equals(Object) Method

obj
The object to compare to the current PaddingEx object.

Glossary Item Box

Determines whether the value of the specified object equals the current PaddingEx object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare to the current PaddingEx object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : GetHashCode Method

Glossary Item Box

Generates a hash code for the PaddingEx object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Structure Properties

[image]
ActiveReports 13
PaddingEx Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see PaddingEx members.

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


All Property

[image]
ActiveReports 13
All Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : All Property

Glossary Item Box

Gets or sets the padding value for all of the edges.

Syntax

Visual Basic (Declaration)
Public Property All As Integer
C#
public int All {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Bottom Property

Glossary Item Box

Gets or sets the padding value for the bottom edge.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Integer
C#
public int Bottom {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Horizontal Property

[image]
ActiveReports 13
Horizontal Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Horizontal Property

Glossary Item Box

Gets or sets the combined padding value for the left and right edges.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Horizontal As Integer
C#
public int Horizontal {get;}

Property Value

An integer value in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Left Property

Glossary Item Box

Gets or sets the padding value for the left edge.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Right Property

Glossary Item Box

Gets or sets the padding value for the right edge.

Syntax

Visual Basic (Declaration)
Public Property Right As Integer
C#
public int Right {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Size Property

Glossary Item Box

Gets the padding information for the control as a System.Drawing.Size structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size
C#
public Size Size {get;}

Property Value

A System.Drawing.Size structure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Top Property

Glossary Item Box

Gets or sets the padding value for the top edge.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An integer in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Vertical Property

[image]
ActiveReports 13
Vertical Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Vertical Property

Glossary Item Box

Gets or sets the combined padding value for the top and bottom edges.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Vertical As Integer
C#
public int Vertical {get;}

Property Value

An integer value in points.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Structure Fields

[image]
ActiveReports 13
PaddingEx Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

Glossary Item Box

For a list of all members of this type, see PaddingEx members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a PaddingEx object with no padding.
Top

See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Empty Field

Glossary Item Box

Returns a PaddingEx object with no padding.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As PaddingEx
C#
public static readonly PaddingEx Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Equality Operator

[image]
ActiveReports 13
Equality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Equality Operator

p1
The first PaddingEx object to compare.
p2
The second PaddingEx object to compare.

Glossary Item Box

Tests whether two PaddingEx objects are equivalent.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal p1 As PaddingEx, _
   ByVal p2 As PaddingEx _
) As Boolean
C#
public bool operator ==(
   PaddingEx p1,
   PaddingEx p2
)

Parameters

p1
The first PaddingEx object to compare.
p2
The second PaddingEx object to compare.

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


Inequality Operator

[image]
ActiveReports 13
Inequality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Inequality Operator

p1
The first PaddingEx object to compare.
p2
The second PaddingEx object to compare.

Glossary Item Box

Tests whether two PaddingEx objects are not equivalent.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal p1 As PaddingEx, _
   ByVal p2 As PaddingEx _
) As Boolean
C#
public bool operator !=(
   PaddingEx p1,
   PaddingEx p2
)

Parameters

p1
The first PaddingEx object to compare.
p2
The second PaddingEx object to compare.

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PaddingEx Structure
PaddingEx Members


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document)

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.

Classes

 | Class | Description
Class | SectionDocument | The Document object represents the generated output of a report.

Delegates

 | Delegate | Description
Delegate | LoadCompletedEventHandler | Represents the method that will handle the LoadCompleted event of a Document.
Delegate | StateChangedHandler | Specifies the type of the StateChanged event of a Document.

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


SectionDocument Class

[image]
ActiveReports 13
SectionDocument Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

The Document object represents the generated output of a report.

Object Model

SectionDocument Class

Syntax

Visual Basic (Declaration)
Public Class SectionDocument
C#
public class SectionDocument

Remarks

ActiveReports renders its output to the pages of a document object. The document can be used with any of the viewer controls, saved for later retrieval or exported using any of ActiveReports export filters.

If you need to have a serializable section document (to move it between application domains), then you should use the simple derived class. See the example of code below.

Example

C# Copy Code
[Serializable]
public class SerializableSectionDocument : SectionDocument, ISerializable
{
   public SerializableSectionDocument()
   {
   }

   protected SerializableSectionDocument(SerializationInfo info, StreamingContext context) : base (info, context)
   {
   }
}
Visual Basic Copy Code
<Serializable>
Public Class SerializableSectionDocument
    Inherits SectionDocument
    Implements ISerializable

    Public Sub New()
    End Sub

    Protected Sub New(ByVal info As SerializationInfo, ByVal context As StreamingContext)
        MyBase.New(info, context)
    End Sub
End Class

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.SectionDocument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Members
GrapeCity.ActiveReports.Document Namespace


SectionDocument Class Members

[image]
ActiveReports 13
SectionDocument Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

The following tables list the members exposed by SectionDocument.

Public Properties

 | Name | Description
Public Property | Bookmarks | Gets or sets a reference to the document's bookmarks.
Public Property | CacheToDisk | Sets or returns a value indicating whether to optimize the amount of memory used by the document by caching the report to disk instead of holding it in memory.
Public Property | CacheToDiskLocation | Gets or set the location of CacheToDisk files. The location can be a physical path or IsolateStorage.
Public Property | Content | Allows a document to be assigned to a web service.
Public Property | InProgress | Determines whether the document is currently being loaded with pages.
Public Property | LoadUrl | Gets or sets a URL from which to download the document asynchronously using internet protocols.
Public Property | Name | Gets or sets the name of the document.
Public Property | Pages | Gets a reference to the document's pages.
Public Property | Password | Gets or sets a password string used to protect the saved document file.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Print options
Public Property | UserPreferences | Gets or sets user preferences in the viewer such as hyperlink and background colors.
Top

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Exports the page(s) to Text and Rtf data and copies it to clipboard.
Public Method | Find | Overloaded. Searches for the specified string in the Document's pages collection.
Public Method | Load | Overloaded. Loads a Document from a stream or a file.
Public Method | ResetPrinter | Resets the printer defaults.
Public Method | Save | Overloaded. Saves the Document content to a stream or a file.
Top

Public Events

 | Name | Description
Public Event | DownloadError | Occurs when an exception is thrown while downloading a document asynchronously from the LoadUrl location.
Public Event | LoadCompleted | Occurs after all the document pages have been fully loaded.
Public Event | PrintAborted | Occurs when printing of the document pages is cancelled.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Public Event | StateChanged | Raised when the state is changed.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


SectionDocument Class Methods

[image]
ActiveReports 13
SectionDocument Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

For a list of all members of this type, see SectionDocument members.

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Exports the page(s) to Text and Rtf data and copies it to clipboard.
Public Method | Find | Overloaded. Searches for the specified string in the Document's pages collection.
Public Method | Load | Overloaded. Loads a Document from a stream or a file.
Public Method | ResetPrinter | Resets the printer defaults.
Public Method | Save | Overloaded. Saves the Document content to a stream or a file.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


CopyToClipboard Method

[image]
ActiveReports 13
CopyToClipboard Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CopyToClipboard Method

firstPageIndex
The zero-based starting page index.
count
The number of pages, copied to clipboard.

Glossary Item Box

Exports the page(s) to Text and Rtf data and copies it to clipboard.

Syntax

Visual Basic (Declaration)
Public Sub CopyToClipboard( _
   ByVal firstPageIndex As Integer, _
   ByVal count As Integer _
)
C#
public void CopyToClipboard(
   int firstPageIndex,
   int count
)

Parameters

firstPageIndex
The zero-based starting page index.
count
The number of pages, copied to clipboard.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Find Method

[image]
ActiveReports 13
Find Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Find Method

Glossary Item Box

Searches for the specified string in the Document's pages collection. Searches for text in the document.

Overload List

Overload | Description
Find(String,Int32) | Searches the text in the document for a specified string starting at a specified location.
Find(String,FindOptions,Int32,Single) | Searches the text in the document for a specified string starting at a specified location and with specific options applied to the search.

Remarks

If found, returns the location of the string in the currentIndex parameter. To continue searching after the first occurrence, call the method again with the returned currentIndex.

Example

C# Copy Code
private void btnFind_Click(object sender, System.EventArgs e)
{
    int i = 0;
    if (viewer1.Document.Find("Coyote", ref i) == true)
    {
        MessageBox.Show ("This document contains the word Coyote.");
        viewer1.Document.ClearFindTextSelection();
    }
}
Visual Basic Copy Code
Private Sub btnFind_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnFind.Click
    If Viewer1.Document.Find("Coyote", 0) Then
        MsgBox("This document contains the word Coyote.")
        Viewer1.Document.ClearFindTextSelection()
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Find(String,Int32) Method

[image]
ActiveReports 13
Find(String,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Find Method : Find(String,Int32) Method

searchString

String to search for in the document.

currentIndex
Starting position of the search. If the string was found, currentIndex is set to the position where the string was found.

Glossary Item Box

Searches the text in the document for a specified string starting at a specified location.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal searchString As String, _
   ByRef currentIndex As Integer _
) As Boolean
C#
public bool Find(
   string searchString,
   ref int currentIndex
)

Parameters

searchString

String to search for in the document.

currentIndex
Starting position of the search. If the string was found, currentIndex is set to the position where the string was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


Find(String,FindOptions,Int32,Single) Method

[image]
ActiveReports 13
Find(String,FindOptions,Int32,Single) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Find Method : Find(String,FindOptions,Int32,Single) Method

searchString
The string you are searching for
options
which direction you are searching
currentIndex
The page's collection zero based index
currentOffset
The current offset into the text string

Glossary Item Box

Searches the text in the document for a specified string starting at a specified location and with specific options applied to the search.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal searchString As String, _
   ByVal options As FindOptions, _
   ByRef currentIndex As Integer, _
   ByRef currentOffset As Single _
) As FindResult
C#
public FindResult Find(
   string searchString,
   FindOptions options,
   ref int currentIndex,
   ref float currentOffset
)

Parameters

searchString
The string you are searching for
options
which direction you are searching
currentIndex
The page's collection zero based index
currentOffset
The current offset into the text string

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


Load Method

[image]
ActiveReports 13
Load Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Load Method

Glossary Item Box

Loads a Document from a stream or a file.

Overload List

Overload | Description
Load(Stream) | Loads the report document from a stream.
Load(String) | Loads a document from the specified file.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members

How To

Save and Load Report Files (RDF)


Load(Stream) Method

[image]
ActiveReports 13
Load(Stream) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Load Method : Load(Stream) Method

stream
A Stream that contains a valid persisted report document.

Glossary Item Box

Loads the report document from a stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal stream As Stream _
)
C#
public void Load(
   Stream stream
)

Parameters

stream
A Stream that contains a valid persisted report document.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


Load(String) Method

[image]
ActiveReports 13
Load(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Load Method : Load(String) Method

fileName
Document file name.

Glossary Item Box

Loads a document from the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Load( _
   ByVal fileName As String _
)
C#
public void Load(
   string fileName
)

Parameters

fileName
Document file name.

Example

C# Copy Code
private void btnLoad_Click(object sender, System.EventArgs e)
{
    arv.Document.Load(Application.StartupPath + "\\Document.rdf");
}
Visual Basic Copy Code
Private Sub btnLoad_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Load(Application.StartupPath & "\Document.rdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


ResetPrinter Method

[image]
ActiveReports 13
ResetPrinter Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : ResetPrinter Method

Glossary Item Box

Resets the printer defaults.

Syntax

Visual Basic (Declaration)
Public Sub ResetPrinter()
C#
public void ResetPrinter()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Save Method

[image]
ActiveReports 13
Save Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Save Method

Glossary Item Box

Saves the Document content to a stream or a file.

Overload List

Overload | Description
Save(String,RdfFormat) | Saves the report document to the specified file using the specified file format.
Save(String,RdfFormat,SaveOptions) | Saves the report document to the specified file using the specified file format with the specified compression.
Save(String) | Saves the report document to the specified file.
Save(Stream,RdfFormat) | Saves the Document content to a stream in the specified file format.
Save(Stream,RdfFormat,SaveOptions) | Saves the Document content to a stream in the specified file format with the specified compression.
Save(Stream) | Saves the Document content to a Stream.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Load method
LoadUrl property

How To

Save and Load Report Files (RDF)


Save(String,RdfFormat) Method

[image]
ActiveReports 13
Save(String,RdfFormat) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(String,RdfFormat) Method

fileName
File path where the document will be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.

Glossary Item Box

Saves the report document to the specified file using the specified file format.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal fileName As String, _
   ByVal fmt As RdfFormat _
)
C#
public void Save(
   string fileName,
   RdfFormat fmt
)

Parameters

fileName
File path where the document will be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.

Example

C# Copy Code
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Save(Application.StartupPath + "\\Document.rdf", GrapeCity.ActiveReports..Document.Section.RdfFormat.AR20);
}
Visual Basic Copy Code
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Save(Application.StartupPath & "\Document.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load method
LoadUrl property


Save(String,RdfFormat,SaveOptions) Method

[image]
ActiveReports 13
Save(String,RdfFormat,SaveOptions) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(String,RdfFormat,SaveOptions) Method

fileName
File path where the document will be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
options

Uses the SaveOptions enumeration to specify the compression to use on the document.

Glossary Item Box

Saves the report document to the specified file using the specified file format with the specified compression.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal fileName As String, _
   ByVal fmt As RdfFormat, _
   ByVal options As SaveOptions _
)
C#
public void Save(
   string fileName,
   RdfFormat fmt,
   SaveOptions options
)

Parameters

fileName
File path where the document will be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
options

Uses the SaveOptions enumeration to specify the compression to use on the document.

Example

C# Copy Code
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Save(Application.StartupPath + "\\Document.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed);
}
Visual Basic Copy Code
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Save(Application.StartupPath & "\Document.rdf", GrapeCity.ActiveReports.Document.Secction.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
SaveOptions Enumeration


Save(String) Method

[image]
ActiveReports 13
Save(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(String) Method

fileName
File path where the document will be saved.

Glossary Item Box

Saves the report document to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal fileName As String _
)
C#
public void Save(
   string fileName
)

Parameters

fileName
File path where the document will be saved.

Remarks

Default file format is ARNet RDF file.

Example

C# Copy Code
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Save(Application.StartupPath + "\\Document.rdf");
}
Visual Basic Copy Code
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Save(Application.StartupPath & "\Document.rdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load method
LoadUrl property


Save(Stream,RdfFormat) Method

[image]
ActiveReports 13
Save(Stream,RdfFormat) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(Stream,RdfFormat) Method

stream
Specifies the Stream object where the document should be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.

Glossary Item Box

Saves the Document content to a stream in the specified file format.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal fmt As RdfFormat _
)
C#
public void Save(
   Stream stream,
   RdfFormat fmt
)

Parameters

stream
Specifies the Stream object where the document should be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load Method
LoadUrl property
RdfFormat Enumeration


Save(Stream,RdfFormat,SaveOptions) Method

[image]
ActiveReports 13
Save(Stream,RdfFormat,SaveOptions) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(Stream,RdfFormat,SaveOptions) Method

stream
Specifies the Stream object where the document should be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
options

Uses the SaveOptions enumeration to specify the compression to use on the document.

Glossary Item Box

Saves the Document content to a stream in the specified file format with the specified compression.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal stream As Stream, _
   ByVal fmt As RdfFormat, _
   ByVal options As SaveOptions _
)
C#
public void Save(
   Stream stream,
   RdfFormat fmt,
   SaveOptions options
)

Parameters

stream
Specifies the Stream object where the document should be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
options

Uses the SaveOptions enumeration to specify the compression to use on the document.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
SaveOptions
RdfFormat Enumeration


Save(Stream) Method

[image]
ActiveReports 13
Save(Stream) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(Stream) Method

stream
Specifies the Stream object where the document should be saved.

Glossary Item Box

Saves the Document content to a Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal stream As Stream _
)
C#
public void Save(
   Stream stream
)

Parameters

stream
Specifies the Stream object where the document should be saved.

Remarks

Default document file format is ARNet file.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load method
LoadUrl property


SectionDocument Class Properties

[image]
ActiveReports 13
SectionDocument Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

For a list of all members of this type, see SectionDocument members.

Public Properties

 | Name | Description
Public Property | Bookmarks | Gets or sets a reference to the document's bookmarks.
Public Property | CacheToDisk | Sets or returns a value indicating whether to optimize the amount of memory used by the document by caching the report to disk instead of holding it in memory.
Public Property | CacheToDiskLocation | Gets or set the location of CacheToDisk files. The location can be a physical path or IsolateStorage.
Public Property | Content | Allows a document to be assigned to a web service.
Public Property | InProgress | Determines whether the document is currently being loaded with pages.
Public Property | LoadUrl | Gets or sets a URL from which to download the document asynchronously using internet protocols.
Public Property | Name | Gets or sets the name of the document.
Public Property | Pages | Gets a reference to the document's pages.
Public Property | Password | Gets or sets a password string used to protect the saved document file.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Print options
Public Property | UserPreferences | Gets or sets user preferences in the viewer such as hyperlink and background colors.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


Bookmarks Property

[image]
ActiveReports 13
Bookmarks Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Bookmarks Property

Glossary Item Box

Gets or sets a reference to the document's bookmarks.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As BookmarksCollection
C#
public BookmarksCollection Bookmarks {get;}

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    viewer1.Document=rpt.Document;
    MessageBox.Show("There are " + viewer1.Document.Bookmarks.Count.ToString() + " bookmarks.");
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New rptDocument
    rpt.Run()
    Viewer1.Document = rpt.Document
    MsgBox("There are " & Viewer1.Document.Bookmarks.Count.ToString & " bookmarks.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Bookmark Class


CacheToDisk Property

[image]
ActiveReports 13
CacheToDisk Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CacheToDisk Property

Glossary Item Box

Sets or returns a value indicating whether to optimize the amount of memory used by the document by caching the report to disk instead of holding it in memory.

Syntax

Visual Basic (Declaration)
Public Property CacheToDisk As Boolean
C#
public bool CacheToDisk {get; set;}

Property Value

Boolean. The default value is False.

Remarks

Temporary files are written when this property is set to True. If there is an unhandled exception during report execution, these temporary files may remain on the system. The location of these files is:

WinForms: C:\Documents and Settings\All Users\Application Data\IsolatedStorage

WebForms: C:\Documents and Settings\<machine name>\ASPNET\ Local Settings\Application Data\IsolatedStorage

CacheToDisk uses IsolatedStorage to store a page’s canvasItems to disk. To use CacheToDisk you must have permissions set for the IsolatedStorage folder.

Temporary files and folders created in IsolatedStorage are not deleted automatically.

Note: This property should only be set to True for reports that consume large amounts of memory, as it slows processing time. The property was created to be used with reports for which there is a danger of being unable to finish processing due to memory usage.

The PDF export will also detect this setting and export the cached report. Other exports will ignore this setting, so very large reports may cause them to run out of memory.

Note that the ClearCanvasItems method does not work correctly if this property is set to True.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Document.CacheToDisk = true;
    arv.LoadDocument(rpt);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Document.CacheToDisk = True
    arv.LoadDocument(rpt)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
ClearCanvasItems Method


CacheToDiskLocation Property

[image]
ActiveReports 13
CacheToDiskLocation Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CacheToDiskLocation Property

Glossary Item Box

Gets or set the location of CacheToDisk files. The location can be a physical path or IsolateStorage.

Syntax

Visual Basic (Declaration)
Public Property CacheToDiskLocation As String
C#
public string CacheToDiskLocation {get; set;}

Remarks

Temporary files and folders created in IsolatedStorage are not deleted automatically.

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Document.CacheToDisk = true;
    rpt.Document.CacheToDiskLocation = "C:\\Temp";
    rpt.Run();
    viewer1.Document=rpt.Document;
}
Visual Basic Copy Code
Private Sub viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Document.CacheToDisk = True
    rpt.Document.CacheToDiskLocation = "C:\\Temp
    rpt.Run()
    viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Content Property

[image]
ActiveReports 13
Content Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Content Property

Glossary Item Box

Allows a document to be assigned to a web service.

Syntax

Visual Basic (Declaration)
Public Property Content As Byte()
C#
public byte[] Content {get; set;}

Property Value

A valid xml schema of the report.

Remarks

This is for XML Serialization used in retrieving a report from a web service. It is basically the same information that the viewer loads from an RDF file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members

Walkthroughs

Document Web Service


InProgress Property

[image]
ActiveReports 13
InProgress Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : InProgress Property

Glossary Item Box

Determines whether the document is currently being loaded with pages.

Syntax

Visual Basic (Declaration)
Public Property InProgress As Boolean
C#
public bool InProgress {get; set;}

Property Value

A Boolean value. True if the document loading is currently in progress; otherwise, false.

Example

C# Copy Code
private void viewer1_Load(object sender, System.EventArgs e)
{
    if (arv.Document.InProgress)
    {
        this.progressBar1.Visible = true;
    }
    else
    {
        this.progressBar1.Visible = false;
    }
}
Visual Basic Copy Code
Private Sub viewer1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If arv.Document.InProgress Then
        Me.ProgressBar1.Visible = True
    Else
        Me.ProgressBar1.Visible = False
    End If
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


LoadUrl Property

[image]
ActiveReports 13
LoadUrl Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : LoadUrl Property

Glossary Item Box

Gets or sets a URL from which to download the document asynchronously using internet protocols.

Syntax

Visual Basic (Declaration)
Public Property LoadUrl As String
C#
public string LoadUrl {get; set;}

Example

C# Copy Code
private void Form1_Load(object sender, EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    rpt.Document.Save(@"C:\Inetpub\wwwroot\LoadURLTest\report_Normal.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.ARNet, GrapeCity.ActiveReports.Document.Section.SaveOptions.Normal);
    this.viewer1.Document.LoadUrl = "http://localhost/Loadurltest/report_Normal.rdf";

}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    Dim rpt As New SectionReport1
    rpt.Run()
    rpt.Document.Save("C:\Inetpub\wwwroot\LoadURLTest\report_Normal.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.ARNet, GrapeCity.ActiveReports.Document.Section.SaveOptions.Normal)
    Me.Viewer1.Document.LoadUrl = "http://localhost/Loadurltest/report_Normal.rdf"

End

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Name Property

[image]
ActiveReports 13
Name Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Name Property

Glossary Item Box

Gets or sets the name of the document.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

A string value that represents the name of the document.

Remarks

The name of the document appears in the print job listing of the printer when the document is printed.

Example

C# Copy Code
private void btnPrint_Click(object sender, System.EventArgs e)
{
    arv.Document.Name = System.Windows.Forms.SystemInformation.UserName;
    arv.Document.Print();
}
Visual Basic Copy Code
Private Sub btnPrint_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPrint.Click
    arv.Document.Name = System.Windows.Forms.SystemInformation.UserName
    arv.Document.Print()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Pages Property

[image]
ActiveReports 13
Pages Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Pages Property

Glossary Item Box

Gets a reference to the document's pages.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As PagesCollection
C#
public PagesCollection Pages {get;}

Remarks

Use this collection to add, remove or modify the pages of the document.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    for(int i = 0; i<Document.Pages.Count;i++)
    {
        this.Document.Pages[i].AddBookmark("New Bookmark", 25);
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim i As Integer
    Try
        For i = 0 To Me.Document.Pages.Count - 1
            Me.Document.Pages(1).AddBookmark("New Bookmark", 8)
        Next
    Catch ex As Exception
    End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Password Property

[image]
ActiveReports 13
Password Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Password Property

Glossary Item Box

Gets or sets a password string used to protect the saved document file.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Property Value

String.

Remarks

The password is used with the ActiveReports RDF file format.

Example

C# Copy Code
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Password = "Mortimer";
    arv.Document.Save(Application.StartupPath + "\\Document.rdf");
}
Visual Basic Copy Code
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Password = "Mortimer"
    arv.Document.Save(Application.StartupPath & "Document.rdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


Printer Property

[image]
ActiveReports 13
Printer Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Printer Property

Glossary Item Box

Gets a reference to the document's printer settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Printer As Printer
C#
public Printer Printer {get;}

Property Value

A GrapeCity.ActiveReports.Document.Printer value that represents the current document printing options.

Remarks

Use this property to set the printer options before displaying a print dialog or directly printing the document to the printer with the specified options.

Example

C# Copy Code
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Document.Printer.PrinterSettings.Copies=5;
}

private void SectionReport1_ReportEnd(object sender, System.EventArgs eArgs)
{
    this.Document.Print(false, false);
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Document.Printer.PrinterSettings.Copies = 5
End Sub

Private Sub SectionReport1_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Document.Print(False, False)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Printer class


PrintOptions Property

[image]
ActiveReports 13
PrintOptions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintOptions Property

Glossary Item Box

Print options

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOptions As PrintOptions
C#
public PrintOptions PrintOptions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


UserPreferences Property

[image]
ActiveReports 13
UserPreferences Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : UserPreferences Property

Glossary Item Box

Gets or sets user preferences in the viewer such as hyperlink and background colors.

Syntax

Visual Basic (Declaration)
Public Property UserPreferences As UserPreferences
C#
public UserPreferences UserPreferences {get; set;}

Property Value

The user preferences.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


SectionDocument Class Events

[image]
ActiveReports 13
SectionDocument Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

Glossary Item Box

For a list of all members of this type, see SectionDocument members.

Public Events

 | Name | Description
Public Event | DownloadError | Occurs when an exception is thrown while downloading a document asynchronously from the LoadUrl location.
Public Event | LoadCompleted | Occurs after all the document pages have been fully loaded.
Public Event | PrintAborted | Occurs when printing of the document pages is cancelled.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Public Event | StateChanged | Raised when the state is changed.
Top

See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


DownloadError Event

[image]
ActiveReports 13
DownloadError Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : DownloadError Event

Glossary Item Box

Occurs when an exception is thrown while downloading a document asynchronously from the LoadUrl location.

Syntax

Visual Basic (Declaration)
Public Event DownloadError As UrlErrorEventHandler
C#
public event UrlErrorEventHandler DownloadError

Event Data

The event handler receives an argument of type UrlErrorEventArgs containing data related to this event. The following UrlErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets a value that specifies the exception that caused the download error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
LoadUrl


LoadCompleted Event

[image]
ActiveReports 13
LoadCompleted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : LoadCompleted Event

Glossary Item Box

Occurs after all the document pages have been fully loaded.

Syntax

Visual Basic (Declaration)
Public Event LoadCompleted As LoadCompletedEventHandler
C#
public event LoadCompletedEventHandler LoadCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members
Load method
LoadUrl property


PrintAborted Event

[image]
ActiveReports 13
PrintAborted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintAborted Event

Glossary Item Box

Occurs when printing of the document pages is cancelled.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As PrintAbortedEventHandler
C#
public event PrintAbortedEventHandler PrintAborted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


PrintingThreadErrorEvent Event

[image]
ActiveReports 13
PrintingThreadErrorEvent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintingThreadErrorEvent Event

Glossary Item Box

Occurs when an exception is thrown by the printing thread.

Syntax

Visual Basic (Declaration)
Public Event PrintingThreadErrorEvent As PrintingThreadErrorEventHandler
C#
public event PrintingThreadErrorEventHandler PrintingThreadErrorEvent

Event Data

The event handler receives an argument of type PrintingThreadErrorEventArgs containing data related to this event. The following PrintingThreadErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the printing thread exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


PrintProgress Event

[image]
ActiveReports 13
PrintProgress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintProgress Event

Glossary Item Box

Occurs when the document pages are printing.

Syntax

Visual Basic (Declaration)
Public Event PrintProgress As PrintProgressEventHandler
C#
public event PrintProgressEventHandler PrintProgress

Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the current printing page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


StateChanged Event

[image]
ActiveReports 13
StateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : StateChanged Event

Glossary Item Box

Raised when the state is changed.

Syntax

Visual Basic (Declaration)
Public Event StateChanged As StateChangedHandler
C#
public event StateChangedHandler StateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionDocument Class
SectionDocument Members


LoadCompletedEventHandler Delegate

[image]
ActiveReports 13
LoadCompletedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace : LoadCompletedEventHandler Delegate

sender
Source of the event.
e
An LoadCompletedEventArgs value that contains the event data.

Glossary Item Box

Represents the method that will handle the LoadCompleted event of a Document.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LoadCompletedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void LoadCompletedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
Source of the event.
e
An LoadCompletedEventArgs value that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LoadCompletedEventHandler Members
GrapeCity.ActiveReports.Document Namespace


StateChangedHandler Delegate

[image]
ActiveReports 13
StateChangedHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document Namespace : StateChangedHandler Delegate

sender
Source of the event.
e
An EventArgs value that contains the event data.

Glossary Item Box

Specifies the type of the StateChanged event of a Document.

Syntax

Visual Basic (Declaration)
Public Delegate Sub StateChangedHandler( _
   ByVal sender As Object, _
   ByVal e As StateChangedArgs _
)
C#
public delegate void StateChangedHandler(
   object sender,
   StateChangedArgs e
)

Parameters

sender
Source of the event.
e
An EventArgs value that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StateChangedHandler Members
GrapeCity.ActiveReports.Document Namespace


GrapeCity.ActiveReports.Document.Section Namespace

GrapeCity.ActiveReports.Document.Section Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Section Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Document.Section Namespace contains various classes that can be set in the report document.

Classes

 | Class | Description
Class | ActiveReportPrintControllerWithStatusDialog | Controls how a document is printed.
Class | Bookmark | Specifies a named location in the report document or page that can be reached by name using hyperlinks or using the table of contents outline tree.
Class | BookmarksCollection | Specifies a collection of Bookmark objects.
Class | Margins | Used to specify the printed page margins.
Class | Page | Represents a printed page in the report document.
Class | PageDoubleLineExtensions | Provides extension methods for Page
Class | PagesCollection | Manages a set of pages in the Document object.
Class | SetScaleX | SetMinCondenseRate canvas item
Class | TextBoundsRange | Text bounds range canvas item
Class | UrlErrorEventArgs | Specifies the arguments of a downloadError event.
Class | UserPreferences | Specifies the look of hyperlinks and the controls that host them in the Viewer control.

Delegates

 | Delegate | Description
Delegate | UrlErrorEventHandler | Represents the method that will handle the downloadError event of a Document.

Enumerations

 | Enumeration | Description
Enumeration | BackgroundStyle | Specifies the background style when using the low level page drawing APIs.
Enumeration | PageOrientation | Specifies the orientation of a page when rendered to the printer.
Enumeration | PenStyles | Specifies the pen style used to draw lines on a page.
Enumeration | RdfFormat | Specifies the file format used to save the report document.
Enumeration | SaveOptions | Specifies the compression type used to save the report document.
Enumeration | Units | Specifies the document measurement units when using low level drawing API on a document page.

Remarks

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


ActiveReportPrintControllerWithStatusDialog Class

[image]
ActiveReports 13
ActiveReportPrintControllerWithStatusDialog Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

Glossary Item Box

Controls how a document is printed.

Object Model

ActiveReportPrintControllerWithStatusDialog Class

Syntax

Visual Basic (Declaration)
Public Class ActiveReportPrintControllerWithStatusDialog
   Inherits System.Drawing.Printing.StandardPrintController
C#
public class ActiveReportPrintControllerWithStatusDialog : System.Drawing.Printing.StandardPrintController

Remarks

Implements a StandardPrintController and adds a print status dialog.

Inheritance Hierarchy

System.Object
System.Drawing.Printing.PrintController
System.Drawing.Printing.StandardPrintController
GrapeCity.ActiveReports.Document.Section.ActiveReportPrintControllerWithStatusDialog

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Members
GrapeCity.ActiveReports.Document.Section Namespace


ActiveReportPrintControllerWithStatusDialog Class Members

[image]
ActiveReports 13
ActiveReportPrintControllerWithStatusDialog Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

Glossary Item Box

The following tables list the members exposed by ActiveReportPrintControllerWithStatusDialog.

Public Constructors

 | Name | Description
Public Constructor | ActiveReportPrintControllerWithStatusDialog Constructor | Initializes a new instance of the ActiveReportPrintControllerWithStatusDialog class.
Top

Public Properties

 | Name | Description
Public Property | IsPreview | Gets a value indicating whether the System.Drawing.Printing.PrintController is used for print preview. (Inherited from System.Drawing.Printing.PrintController)
Top

Public Methods

 | Name | Description
Public Method | OnEndPage | Overridden. Completes the control sequence that determines when and how to print a page of a document.
Public Method | OnEndPrint | Overridden. Completes the control sequence that determines when and how to print a document.
Public Method | OnStartPage | Overridden. Begins the control sequence that determines when and how to print a page in a document.
Public Method | OnStartPrint | Overridden. Begins the control sequence that determines when and how to print a document.
Top

Public Events

 | Name | Description
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingProgress | Raised for each page printed in the print controller.
Top

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


ActiveReportPrintControllerWithStatusDialog Constructor

[image]
ActiveReports 13
ActiveReportPrintControllerWithStatusDialog Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : ActiveReportPrintControllerWithStatusDialog Constructor

Glossary Item Box

Initializes a new instance of the ActiveReportPrintControllerWithStatusDialog class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ActiveReportPrintControllerWithStatusDialog()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


ActiveReportPrintControllerWithStatusDialog Class Methods

[image]
ActiveReports 13
ActiveReportPrintControllerWithStatusDialog Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

Glossary Item Box

For a list of all members of this type, see ActiveReportPrintControllerWithStatusDialog members.

Public Methods

 | Name | Description
Public Method | OnEndPage | Overridden. Completes the control sequence that determines when and how to print a page of a document.
Public Method | OnEndPrint | Overridden. Completes the control sequence that determines when and how to print a document.
Public Method | OnStartPage | Overridden. Begins the control sequence that determines when and how to print a page in a document.
Public Method | OnStartPrint | Overridden. Begins the control sequence that determines when and how to print a document.
Top

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


OnEndPage Method

[image]
ActiveReports 13
OnEndPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnEndPage Method

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Glossary Item Box

Completes the control sequence that determines when and how to print a page of a document.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnEndPage( _
   ByVal prnDoc As PrintDocument, _
   ByVal ppea As PrintPageEventArgs _
)
C#
public override void OnEndPage(
   PrintDocument prnDoc,
   PrintPageEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Remarks

See the System.Drawing.Printing namespace for additional information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


OnEndPrint Method

[image]
ActiveReports 13
OnEndPrint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnEndPrint Method

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Glossary Item Box

Completes the control sequence that determines when and how to print a document.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnEndPrint( _
   ByVal prnDoc As PrintDocument, _
   ByVal ppea As PrintEventArgs _
)
C#
public override void OnEndPrint(
   PrintDocument prnDoc,
   PrintEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Remarks

See the System.Drawing.Printing namespace for additional information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


OnStartPage Method

[image]
ActiveReports 13
OnStartPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnStartPage Method

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Glossary Item Box

Begins the control sequence that determines when and how to print a page in a document.

Syntax

Visual Basic (Declaration)
Public Overrides Function OnStartPage( _
   ByVal prnDoc As PrintDocument, _
   ByVal ppea As PrintPageEventArgs _
) As Graphics
C#
public override Graphics OnStartPage(
   PrintDocument prnDoc,
   PrintPageEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Remarks

See the System.Drawing.Printing namespace for additional information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


OnStartPrint Method

[image]
ActiveReports 13
OnStartPrint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnStartPrint Method

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Glossary Item Box

Begins the control sequence that determines when and how to print a document.

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnStartPrint( _
   ByVal prnDoc As PrintDocument, _
   ByVal ppea As PrintEventArgs _
)
C#
public override void OnStartPrint(
   PrintDocument prnDoc,
   PrintEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.

Remarks

See the System.Drawing.Printing namespace for additional information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


ActiveReportPrintControllerWithStatusDialog Class Events

[image]
ActiveReports 13
ActiveReportPrintControllerWithStatusDialog Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

Glossary Item Box

For a list of all members of this type, see ActiveReportPrintControllerWithStatusDialog members.

Public Events

 | Name | Description
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingProgress | Raised for each page printed in the print controller.
Top

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


PrintAborted Event

[image]
ActiveReports 13
PrintAborted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : PrintAborted Event

Glossary Item Box

Occurs if the user clicks the Abort button on the status dialog.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As PrintAbortedEventHandler
C#
public event PrintAbortedEventHandler PrintAborted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


PrintingProgress Event

[image]
ActiveReports 13
PrintingProgress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : PrintingProgress Event

Glossary Item Box

Raised for each page printed in the print controller.

Syntax

Visual Basic (Declaration)
Public Event PrintingProgress As PrintProgressEventHandler
C#
public event PrintProgressEventHandler PrintingProgress

Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the current printing page number.

Remarks

Use this event to display a progress UI to the user.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


Bookmark Class

[image]
ActiveReports 13
Bookmark Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

Glossary Item Box

Specifies a named location in the report document or page that can be reached by name using hyperlinks or using the table of contents outline tree.

Object Model

Bookmark Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Bookmark
C#
public sealed class Bookmark

Remarks

Bookmarks are added to the report in a section's BeforePrint event using the Section.AddBookmark method. In addition, bookmarks can be added to any page in the document after the report has completed processing using the Page.AddBookmark method.

Bookmarks are stored within each page; when pages are added to a document the bookmarks are merged with the document's Bookmarks collection.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    int i;
    for (i = 1; i <= arv.Document.Bookmarks.Count; i++)
    {
        arv.Document.Bookmarks[i - 1].Label = "Bookmark number " + i;
    }
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim i As Integer
    For i = 1 To arv.Document.Bookmarks.Count
        arv.Document.Bookmarks(i - 1).Label = "Bookmark number " & i
    Next i
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Bookmark

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Members
GrapeCity.ActiveReports.Document.Section Namespace
Bookmarks collection


Bookmark Class Members

[image]
ActiveReports 13
Bookmark Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

Glossary Item Box

The following tables list the members exposed by Bookmark.

Public Constructors

 | Name | Description
Public Constructor | Bookmark Constructor | Creates a new instance of the Bookmark class.
Top

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the caption of the bookmark.
Public Property | Offset | Gets or sets the location of the bookmark relative to the top of the page.
Public Property | PageNumber | Gets or sets the page number to which the bookmark was added.
Top

See Also

Reference

Bookmark Class
GrapeCity.ActiveReports.Document.Section Namespace
Bookmarks collection


Bookmark Constructor

[image]
ActiveReports 13
Bookmark Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Bookmark Constructor

Glossary Item Box

Creates a new instance of the Bookmark class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Bookmark()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


Bookmark Class Properties

[image]
ActiveReports 13
Bookmark Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

Glossary Item Box

For a list of all members of this type, see Bookmark members.

Public Properties

 | Name | Description
Public Property | Label | Gets or sets the caption of the bookmark.
Public Property | Offset | Gets or sets the location of the bookmark relative to the top of the page.
Public Property | PageNumber | Gets or sets the page number to which the bookmark was added.
Top

See Also

Reference

Bookmark Class
GrapeCity.ActiveReports.Document.Section Namespace
Bookmarks collection


Label Property

[image]
ActiveReports 13
Label Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Label Property

Glossary Item Box

Gets or sets the caption of the bookmark.

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label {get; set;}

Property Value

String.

Remarks

The name can be a simple string or a path to create a hierarchy. For example, "Entry 1" is a node with no parent, "Entry 1\Child 1.1" is a bookmark node with a caption "Child 1.1" whose parent is "Entry 1".

Example

C# Copy Code
Private void viewer1_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = New rptDocument();
    rpt.Run();
    viewer1.Document=rpt.Document;
    int i;
    For (i = 1; i <= viewer1.Document.Bookmarks.Count; i++)
    {
        viewer1.Document.Bookmarks[i - 1].Label = "Bookmark number " + i;
    }
}
Visual Basic Copy Code
Private Sub viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    viewer1.Document = rpt.Document
    Dim i As Integer
    For i = 1 To viewer1.Document.Bookmarks.Count
        viewer1.Document.Bookmarks(i - 1).Label = "Bookmark number " & i
    Next i
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


Offset Property

[image]
ActiveReports 13
Offset Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Offset Property

Glossary Item Box

Gets or sets the location of the bookmark relative to the top of the page.

Syntax

Visual Basic (Declaration)
Public Property Offset As Single
C#
public float Offset {get; set;}

Property Value

A float value that represents the location of the bookmark in inches.

Example

C# Copy Code
private void viewer1_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = viewer1.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show ("You are leaving the bookmark at page " + viewer1.Document.Bookmarks[toc].PageNumber.ToString() + ", " + viewer1.Document.Bookmarks[toc].Offset.ToString() + " inches from the top of the page.");
}
Visual Basic Copy Code
Private Sub viewer1_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = viewer1.Document.Bookmarks.CurrentBookmark
    MessageBox.Show("You are leaving the bookmark at page " & viewer1.Document.Bookmarks(toc).PageNumber.ToString & ", " & viewer1.Document.Bookmarks(toc).Offset.ToString & " inches from the top of the page.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


PageNumber Property

[image]
ActiveReports 13
PageNumber Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : PageNumber Property

Glossary Item Box

Gets or sets the page number to which the bookmark was added.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
C#
public int PageNumber {get; set;}

Property Value

Integer.

Example

C# Copy Code
private void viewer1_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = viewer1.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show ("You are leaving the bookmark at page " + viewer1.Document.Bookmarks[toc].PageNumber.ToString() + ", " + viewer1.Document.Bookmarks[toc].Offset.ToString() + " inches from the top of the page.");
}
Visual Basic Copy Code
Private Sub viewer1_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = viewer1.Document.Bookmarks.CurrentBookmark
    MessageBox.Show("You are leaving the bookmark at page " & viewer1.Document.Bookmarks(toc).PageNumber.ToString & ", " & viewer1.Document.Bookmarks(toc).Offset.ToString & " inches from the top of the page.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


BookmarksCollection Class

[image]
ActiveReports 13
BookmarksCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

Specifies a collection of Bookmark objects.

Object Model

BookmarksCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BookmarksCollection
   Inherits System.Collections.CollectionBase
C#
public sealed class BookmarksCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.BookmarksCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Members
GrapeCity.ActiveReports.Document.Section Namespace


BookmarksCollection Class Members

[image]
ActiveReports 13
BookmarksCollection Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

The following tables list the members exposed by BookmarksCollection.

Public Constructors

 | Name | Description
Public Constructor | BookmarksCollection Constructor | Creates a new instance of the BookmarkCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of Bookmark objects in the collection. (Inherited from System.Collections.CollectionBase)
Public Property | CurrentBookmark | Returns the index of the currently selected bookmark.
Public Property | Item | Returns a reference to the bookmark object at the specified index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified Bookmark object to the collection.
Public Method | Clear | Removes all bookmarks from the collection.
Public Method | Contains | Determines whether the specified bookmark object exists in the collection.
Public Method | CopyTo | Copies the Bookmarks collection from the specified report to a Bookmarks collection at the specified index.
Public Method | Dispose | Releases the BookmarksCollection instance from memory.
Public Method | FillTree | Loads the Bookmark objects into the Windows Forms TreeView control.
Public Method | IndexOf | Returns the index of the specified Bookmark object in the collection.
Public Method | Insert | Inserts the specified Bookmark object at the specified index in the collection.
Public Method | Remove | Removes the specified Bookmark object from the collection.
Public Method | RemoveAt | Removes the Bookmark object at the specified index from the collection. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


BookmarksCollection Constructor

[image]
ActiveReports 13
BookmarksCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : BookmarksCollection Constructor

Glossary Item Box

Creates a new instance of the BookmarkCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BookmarksCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


BookmarksCollection Class Methods

[image]
ActiveReports 13
BookmarksCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

For a list of all members of this type, see BookmarksCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified Bookmark object to the collection.
Public Method | Clear | Removes all bookmarks from the collection.
Public Method | Contains | Determines whether the specified bookmark object exists in the collection.
Public Method | CopyTo | Copies the Bookmarks collection from the specified report to a Bookmarks collection at the specified index.
Public Method | Dispose | Releases the BookmarksCollection instance from memory.
Public Method | FillTree | Loads the Bookmark objects into the Windows Forms TreeView control.
Public Method | IndexOf | Returns the index of the specified Bookmark object in the collection.
Public Method | Insert | Inserts the specified Bookmark object at the specified index in the collection.
Public Method | Remove | Removes the specified Bookmark object from the collection.
Public Method | RemoveAt | Removes the Bookmark object at the specified index from the collection. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Add Method

value
Specifies the Bookmark object to be added to the collection.

Glossary Item Box

Adds the specified Bookmark object to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Bookmark _
) As Integer
C#
public int Add(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object to be added to the collection.

Return Value

An integer index of the added bookmark in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Clear Method

Glossary Item Box

Removes all bookmarks from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Example

C# Copy Code
private void btnClearTOC_Click(object sender, System.EventArgs e)
{
    MessageBox.Show ("Clearing " + arv.Document.Bookmarks.Count.ToString() + " bookmarks.");
    arv.Document.Bookmarks.Clear();
    arv.TableOfContents.Clear();
}
Visual Basic Copy Code
Private Sub btnClearTOC_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClearTOC.Click
    MsgBox("Clearing " & arv.Document.Bookmarks.Count.ToString & " bookmarks.")
    arv.Document.Bookmarks.Clear()
    arv.TableOfContents.Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Contains Method

value
Specifies the Bookmark object to be searched for in the collection.

Glossary Item Box

Determines whether the specified bookmark object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Bookmark _
) As Boolean
C#
public bool Contains(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object to be searched for in the collection.

Return Value

Boolean. True, if the bookmark is a member of the collection; otherwise, False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : CopyTo Method

values
The array containing the copied Bookmarks.
index
The insertion index in the collection.

Glossary Item Box

Copies the Bookmarks collection from the specified report to a Bookmarks collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal values() As Bookmark, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Bookmark[] values,
   int index
)

Parameters

values
The array containing the copied Bookmarks.
index
The insertion index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Dispose Method

Glossary Item Box

Releases the BookmarksCollection instance from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


FillTree Method

[image]
ActiveReports 13
FillTree Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : FillTree Method

treeView
Specifies the TreeView control to be filled with the bookmark objects.

Glossary Item Box

Loads the Bookmark objects into the Windows Forms TreeView control.

Syntax

Visual Basic (Declaration)
Public Sub FillTree( _
   ByVal treeView As TreeView _
)
C#
public void FillTree(
   TreeView treeView
)

Parameters

treeView
Specifies the TreeView control to be filled with the bookmark objects.

Remarks

You can use this method to fill any TreeView with the bookmarks collection and customize the look and feel of the Table of Contents.

Example

C# Copy Code
private void frmViewer_Load(object sender, System.EventArgs e)
{
   arv.Document.Bookmarks.FillTree(treeView1);
}
Visual Basic Copy Code
Private Sub frmViewer_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    arv.Document.Bookmarks.FillTree(TreeView1)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : IndexOf Method

value
Specifies the Bookmark object for which to search.

Glossary Item Box

Returns the index of the specified Bookmark object in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Bookmark _
) As Integer
C#
public int IndexOf(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object for which to search.

Return Value

An integer specifying the index of the specified Bookmark.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Insert Method

index
Insertion index in the collection.
value
New Bookmark object to be inserted at the specified index.

Glossary Item Box

Inserts the specified Bookmark object at the specified index in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Bookmark _
)
C#
public void Insert(
   int index,
   Bookmark value
)

Parameters

index
Insertion index in the collection.
value
New Bookmark object to be inserted at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Remove Method

value
Specifies the Bookmark object to be removed.

Glossary Item Box

Removes the specified Bookmark object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Bookmark _
)
C#
public void Remove(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


BookmarksCollection Class Properties

[image]
ActiveReports 13
BookmarksCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

Glossary Item Box

For a list of all members of this type, see BookmarksCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of Bookmark objects in the collection. (Inherited from System.Collections.CollectionBase)
Public Property | CurrentBookmark | Returns the index of the currently selected bookmark.
Public Property | Item | Returns a reference to the bookmark object at the specified index.
Top

See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


CurrentBookmark Property

[image]
ActiveReports 13
CurrentBookmark Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : CurrentBookmark Property

Glossary Item Box

Returns the index of the currently selected bookmark.

Syntax

Visual Basic (Declaration)
Public Property CurrentBookmark As Integer
C#
public int CurrentBookmark {get; set;}

Property Value

An integer value that represents the number of bookmark objects in the collection.

Example

C# Copy Code
private void arv_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = arv.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show ("You are leaving the bookmark at page " + arv.Document.Bookmarks[toc].PageNumber.ToString() + ", " + arv.Document.Bookmarks[toc].Offset.ToString() + " inches from the top of the page.");
}
Visual Basic Copy Code
Private Sub arv_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = arv.Document.Bookmarks.CurrentBookmark
    MsgBox("You are leaving the bookmark at page " & arv.Document.Bookmarks(toc).PageNumber.ToString & ", " & arv.Document.Bookmarks(toc).Offset.ToString & " inches from the top of the page.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Item Property

index
Index of the requested item.

Glossary Item Box

Returns a reference to the bookmark object at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Bookmark
C#
public Bookmark this[
   int index
]; {get;}

Parameters

index
Index of the requested item.

Property Value

A Bookmark object at the specified index in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Margins Class

[image]
ActiveReports 13
Margins Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

Used to specify the printed page margins.

Object Model

Margins Class

Syntax

Visual Basic (Declaration)
Public Class Margins
C#
public class Margins

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Margins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Members
GrapeCity.ActiveReports.Document.Section Namespace


Margins Class Members

[image]
ActiveReports 13
Margins Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

The following tables list the members exposed by Margins.

Public Constructors

 | Name | Description
Public Constructor | Margins Constructor | Overloaded. Creates a new instance of the Margins class.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin of the page, in inches.
Public Property | Left | Gets or sets the left margin of the page, in inches.
Public Property | Right | Gets or sets the right margin of the page, in inches.
Public Property | Top | Gets or sets the top margin of the page, in inches.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates a clone of the Margins object.
Public Method | Equals | Determines whether the specified object is equal to the current object.
Top

Public Events

 | Name | Description
Public Event | Changed | Fires when the margins are changed.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Margins Constructor

[image]
ActiveReports 13
Margins Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Margins Constructor

Glossary Item Box

Creates a new instance of the Margins class.

Overload List

Overload | Description
Margins Constructor() | Creates a new instance of the Margins class.
Margins Constructor(Single,Single,Single,Single) | Initializes a new instance of the Margins class with the specified margins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Constructor()

[image]
ActiveReports 13
Margins Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class > Margins Constructor : Margins Constructor()

Glossary Item Box

Creates a new instance of the Margins class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Margins()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members
Overload List


Margins Constructor(Single,Single,Single,Single)

[image]
ActiveReports 13
Margins Constructor(Single,Single,Single,Single)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class > Margins Constructor : Margins Constructor(Single,Single,Single,Single)

left
Specifies the left margin, in inches.
top
Specifies the top margin, in inches.
right
Specifies the right margin, in inches.
bottom
Specifies the bottom margin, in inches.

Glossary Item Box

Initializes a new instance of the Margins class with the specified margins.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal right As Single, _
   ByVal bottom As Single _
)
C#
public Margins(
   float left,
   float top,
   float right,
   float bottom
)

Parameters

left
Specifies the left margin, in inches.
top
Specifies the top margin, in inches.
right
Specifies the right margin, in inches.
bottom
Specifies the bottom margin, in inches.

Exceptions

Exception | Description
System.ArgumentException | Left margin value must be greater than 0 or Top margin value must be greater than 0 or Right margin value must be greater than 0 or Bottom margin value must be greater than 0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members
Overload List


Margins Class Methods

[image]
ActiveReports 13
Margins Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Methods

 | Name | Description
Public Method | Clone | Creates a clone of the Margins object.
Public Method | Equals | Determines whether the specified object is equal to the current object.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 13
Clone Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Clone Method

Glossary Item Box

Creates a clone of the Margins object.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Equals Method

obj
The object to compare with the current object.

Glossary Item Box

Determines whether the specified object is equal to the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Class Properties

[image]
ActiveReports 13
Margins Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin of the page, in inches.
Public Property | Left | Gets or sets the left margin of the page, in inches.
Public Property | Right | Gets or sets the right margin of the page, in inches.
Public Property | Top | Gets or sets the top margin of the page, in inches.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Bottom Property

Glossary Item Box

Gets or sets the bottom margin of the page, in inches.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
C#
public float Bottom {get; set;}

Property Value

float value that represents the bottom margin in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Left Property

Glossary Item Box

Gets or sets the left margin of the page, in inches.

Syntax

Visual Basic (Declaration)
Public Property Left As Single
C#
public float Left {get; set;}

Property Value

float value that represents the left margin in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Right Property

Glossary Item Box

Gets or sets the right margin of the page, in inches.

Syntax

Visual Basic (Declaration)
Public Property Right As Single
C#
public float Right {get; set;}

Property Value

float value that represents the right margin in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Top Property

Glossary Item Box

Gets or sets the top margin of the page, in inches.

Syntax

Visual Basic (Declaration)
Public Property Top As Single
C#
public float Top {get; set;}

Property Value

float value that represents the top margin in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Class Events

[image]
ActiveReports 13
Margins Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Events

 | Name | Description
Public Event | Changed | Fires when the margins are changed.
Top

See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Changed Event

[image]
ActiveReports 13
Changed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Changed Event

Glossary Item Box

Fires when the margins are changed.

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Page Class

[image]
ActiveReports 13
Page Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

Represents a printed page in the report document.

Object Model

Page Class

Syntax

Visual Basic (Declaration)
Public Class Page
C#
public class Page

Remarks

The Page class provides primitive drawing methods that you can use to create content on the page in the PageStart or PageEnd events or after the report has completed execution.

Drawing to the page in the PageStart event renders behind the report's page content, while drawing in the PageEnd event renders in the foreground on top of the report content.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Members
GrapeCity.ActiveReports.Document.Section Namespace


Page Class Members

[image]
ActiveReports 13
Page Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

The following tables list the members exposed by Page.

Public Constructors

 | Name | Description
Public Constructor | Page Constructor | Initializes a new instance of the Page class.
Top

Public Properties

 | Name | Description
Public Property | Annotations | Gets or sets the annotations associated with the page.
Public Property | BackColor | Specifies the background color used to render shapes and text to the page.
Public Property | Bookmarks | Returns a list of the page's bookmarks.
Public Property | CanvasItems | Returns a list of the page's canvas items.
Public Property | CharacterSpacing | Gets or sets the CharacterSpacing value in inches for the page.
Public Property | Compress | Sets or returns a value indicating whether the page is compressed.
Public Property | Font | Gets or sets the current font used to draw text on the page.
Public Property | Fonts | Returns the collection of fonts for the page.
Public Property | ForeColor | Gets or sets the current foreground color used to draw text and shapes on the page.
Public Property | Height | Gets or sets the height of the page in inches.
Public Property | Identifier | Gets unique page identifier (used in PagesCollection to track swapped out pages)
Public Property | LineSpacing | Gets or sets the LineSpacing value in inches for the page.
Public Property | Margins | Gets a reference to the page margins settings.
Public Property | Orientation | Gets or sets the orientation of the page.
Public Property | Padding | Gets or sets the amount of padding to use around the text inside a control.
Public Property | PenStyle | Gets or sets the line style used to draw lines and shapes.
Public Property | PenWidth | Gets or sets the width of the pen used to draw lines and shapes. (1/10 point)(1/2 point).
Public Property | RightToLeft | Determines whether DrawText should render text RightToLeft.
Public Property | ScaleX | Gets or sets the minimal character condensed rate.
Public Property | Size | Returns a SizeF structure with the height and width of the page, in inches.
Public Property | TextAlignment | Determines the text alignment when using the DrawText method.
Public Property | TextAngle | Gets or sets the angle of text used to draw text.
Public Property | TextJustify | Gets or sets the type of justification to use when the TextAlignment property is set to Justify.
Public Property | TextRenderHint | Specifies the quality of rendering.
Public Property | Units | Gets or sets the units used with the page primitive drawing methods.
Public Property | VerticalText | Sets or returns a value indicating whether to draw text vertically when using the DrawText method.
Public Property | VerticalTextAlignment | Determines the vertical text alignment when using the DrawText method.
Public Property | Width | Gets or sets the width of the page (in inches).
Public Property | WrapMode | Gets or sets the wrap mode for rendering text.
Top

Public Methods

 | Name | Description
Public Method | AddBookmark | Summary description for AddBookmark.
Public Method | Clear | Clears all items from all pages.
Public Method | ClearCanvasItems | Clears all CanvasItems from the page.
Public Method | Clone | Creates a clone of the Page object.
Public Method | Dispose | Releases the Page instance from memory.
Public Method | Draw | Renders the page's content to the specified Graphics object at the specified coordinates.
Public Method | DrawBorder | Overloaded. Paints the specified border at the specified coordinates.
Public Method | DrawEllipse | Draws an ellipse on the page.
Public Method | DrawImage | Overloaded. Draws an image on the page.
Public Method | DrawLine | Draws a line on the page at the specified coordinates.
Public Method | DrawRect | Overloaded. Draws a rectangular shape on the page at the specified coordinates.
Public Method | DrawRoundRect | Overloaded. Draws a rounded rectangle on the page at the specified coordinates.
Public Method | DrawText | Overloaded. Draws text on the page.
Public Method | FillRect | Overloaded. Fills the specified area with the current page BackColor.
Public Method | Load | Overloaded. Loads page content from a reader or a file.
Public Method | MeasureParagraphHeight | Overloaded. Measures the height of the specified text if rendered using the current page settings with the specified width.
Public Method | MeasureText | Overloaded. Determines the width and height of text string.
Public Method | Overlay | Overlays the specified page object on top of the Page.
Public Method | Save | Overloaded. Saves page content.
Public Method | SetTextBoundsRange | Sets text top/bottom bounds.
Public Method | ToString | Renders the page's settings and content to a string.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


Page Constructor

[image]
ActiveReports 13
Page Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Page Constructor

Glossary Item Box

Initializes a new instance of the Page class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Page()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Page Class Methods

[image]
ActiveReports 13
Page Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

For a list of all members of this type, see Page members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Summary description for AddBookmark.
Public Method | Clear | Clears all items from all pages.
Public Method | ClearCanvasItems | Clears all CanvasItems from the page.
Public Method | Clone | Creates a clone of the Page object.
Public Method | Dispose | Releases the Page instance from memory.
Public Method | Draw | Renders the page's content to the specified Graphics object at the specified coordinates.
Public Method | DrawBorder | Overloaded. Paints the specified border at the specified coordinates.
Public Method | DrawEllipse | Draws an ellipse on the page.
Public Method | DrawImage | Overloaded. Draws an image on the page.
Public Method | DrawLine | Draws a line on the page at the specified coordinates.
Public Method | DrawRect | Overloaded. Draws a rectangular shape on the page at the specified coordinates.
Public Method | DrawRoundRect | Overloaded. Draws a rounded rectangle on the page at the specified coordinates.
Public Method | DrawText | Overloaded. Draws text on the page.
Public Method | FillRect | Overloaded. Fills the specified area with the current page BackColor.
Public Method | Load | Overloaded. Loads page content from a reader or a file.
Public Method | MeasureParagraphHeight | Overloaded. Measures the height of the specified text if rendered using the current page settings with the specified width.
Public Method | MeasureText | Overloaded. Determines the width and height of text string.
Public Method | Overlay | Overlays the specified page object on top of the Page.
Public Method | Save | Overloaded. Saves page content.
Public Method | SetTextBoundsRange | Sets text top/bottom bounds.
Public Method | ToString | Renders the page's settings and content to a string.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


AddBookmark(String,Single) Method

[image]
ActiveReports 13
AddBookmark(String,Single) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : AddBookmark(String,Single) Method

strBookmark
Specifies the name of the bookmark. You can use backslash "\" as a path separator to create a hierarchy of bookmarks.
offset
Specifies the location of the bookmark on the page.

Glossary Item Box

Summary description for AddBookmark.

Syntax

Visual Basic (Declaration)
Public Function AddBookmark( _
   ByVal strBookmark As String, _
   ByVal offset As Single _
) As Integer
C#
public int AddBookmark(
   string strBookmark,
   float offset
)

Parameters

strBookmark
Specifies the name of the bookmark. You can use backslash "\" as a path separator to create a hierarchy of bookmarks.
offset
Specifies the location of the bookmark on the page.

Example

C# Copy Code
private void SectionReport1_ReportEnd(object sender, System.EventArgs eArgs)
{
    for(int i = 0; i<Document.Pages.Count;i++)
    {
        this.Document.Pages[i].AddBookmark("New Bookmark", 25);
    }
}
Visual Basic Copy Code
Private Sub SectionReport1_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles SectionReport1.ReportEnd
    Dim i As Integer
    Try
        For i = 0 To Me.Document.Pages.Count - 1
            Me.Document.Pages(i).AddBookmark("New Bookmark", 8)
        Next
    Catch ex As Exception
    End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Clear Method

Glossary Item Box

Clears all items from all pages.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
    arv.Document.Pages[0].Clear();
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
    arv.Document.Pages(0).Clear();
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ClearCanvasItems Method

[image]
ActiveReports 13
ClearCanvasItems Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ClearCanvasItems Method

Glossary Item Box

Clears all CanvasItems from the page.

Syntax

Visual Basic (Declaration)
Public Sub ClearCanvasItems()
C#
public void ClearCanvasItems()

Remarks

This property works correctly only if the Document's CacheToDisk property is set to False.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
    arv.Document.Pages[0].ClearCanvasItems();
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
    arv.Document.Pages(0).ClearCanvasItems()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
CacheToDisk Property


Clone Method

[image]
ActiveReports 13
Clone Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Clone Method

Glossary Item Box

Creates a clone of the Page object.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Dispose() Method

Glossary Item Box

Releases the Page instance from memory.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Draw(Graphics,RectangleF) Method

[image]
ActiveReports 13
Draw(Graphics,RectangleF) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Draw Method : Draw(Graphics,RectangleF) Method

graphics
Graphics object to render on the page.
bounds
System.Drawing.RectangleF coordinates to which to draw the page.

Glossary Item Box

Renders the page's content to the specified Graphics object at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal graphics As Graphics, _
   ByVal bounds As RectangleF _
)
C#
public void Draw(
   Graphics graphics,
   RectangleF bounds
)

Parameters

graphics
Graphics object to render on the page.
bounds
System.Drawing.RectangleF coordinates to which to draw the page.

Example

C# Copy Code
private void arScale()
{
    aPage = new GrapeCity.ActiveReports.Document.Page();
    GrapeCity.ActiveReports.Interop.SystemPrinter m_myARPrinter = new GrapeCity.
        ActiveReports.Interop.SystemPrinter();
    m_myARPrinter.StartJob("Test Printer");
    System.Drawing.RectangleF rec;
    float xOffSet = m_myARPrinter.PhysicalOffsetX/m_myARPrinter.Graphics.DpiX;
    float yOffSet = m_myARPrinter.PhysicalOffsetY/m_myARPrinter.Graphics.DpiY;
    float adjustedWidth = (aPage.Width/3)-(xOffSet*2);
    float xPos = 0;
    int nCount = rpt.Document.Pages.Count;
    m_myARPrinter.StartPage();
    For(int i=0; i < nCount; i++)
    {
        aPage = rpt.Document.Pages[i];
        m_myARPrinter.Graphics.PageUnit = System.Drawing.GraphicsUnit.Pixel;
        rec = System.Drawing.RectangleF.FromLTRB(xOffSet+xPos, yOffSet,(xOffSet+xPos)+
            adjustedWidth,yOffSet+adjustedWidth);
        xPos = adjustedWidth + xPos;
        aPage.Draw(m_myARPrinter.Graphics,rec);
    }
    m_myARPrinter.EndPage();
    m_myARPrinter.EndJob();
}
Visual Basic Copy Code
Private Sub arScale()
    m_myARPrinter.StartJob("Test Printer")
    Dim aPage As New GrapeCity.ActiveReports.Document.Page()
    Dim rec As New System.Drawing.RectangleF()
    Dim xOffSet As Single
    Dim yOffSet As Single
    Dim adjustedWidth As Single
    Dim xPos As Single
    xOffSet = m_myARPrinter.PhysicalOffsetX / m_myARPrinter.Graphics.DpiX
    yOffSet = m_myARPrinter.PhysicalOffsetY / m_myARPrinter.Graphics.DpiY
    adjustedWidth = (aPage.Width / 3) - (xOffSet / 2)
    xPos = 0
    Dim nCount As Integer
    nCount = rpt.Document.Pages.Count
    m_myARPrinter.StartPage()
    For i = 0 To nCount - 1
        aPage = rpt.Document.Pages(i)
        m_myARPrinter.Graphics.PageUnit = GraphicsUnit.Pixel
        rec = System.Drawing.RectangleF.FromLTRB(xOffSet + xPos, yOffSet, (xOffSet + xPos) + _
            adjustedWidth, yOffSet + adjustedWidth)
        xPos = adjustedWidth + xPos
        aPage.Draw(m_myARPrinter.Graphics, rec)
    Next
    m_myARPrinter.EndPage()
    m_myARPrinter.EndJob()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawBorder Method

[image]
ActiveReports 13
DrawBorder Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawBorder Method

Glossary Item Box

Paints the specified border at the specified coordinates.

Overload List

Overload | Description
DrawBorder(Border,Single,Single,Single,Single) | Paints the specified border at the specified coordinates.
DrawBorder(Border,RectangleF) | Paints the specified border with the specified boundaries.

Remarks

Units are determined by the Page.Units property.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    b.BottomColor = System.Drawing.Color.Red;
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.LeftColor = System.Drawing.Color.Red;
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.RightColor = System.Drawing.Color.Red;
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.TopColor = System.Drawing.Color.Red;
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;

    arv.Document.Pages[0].DrawBorder(b, 1, 1, 4, 4);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim b As New GrapeCity.ActiveReports.Border
    b.BottomColor = System.Drawing.Color.Red
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.LeftColor = System.Drawing.Color.Red
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.RightColor = System.Drawing.Color.Red
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.TopColor = System.Drawing.Color.Red
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid

    arv.Document.Pages(0).DrawBorder(b, 1, 1, 4, 4)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawBorder(Border,Single,Single,Single,Single) Method

[image]
ActiveReports 13
DrawBorder(Border,Single,Single,Single,Single) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawBorder Method : DrawBorder(Border,Single,Single,Single,Single) Method

border
Border object to render on the page.
left
Left position of the border (in inches).
top
Top position of the border (in inches).
width
Width of the border (in inches).
height
Height of the border (in inches).

Glossary Item Box

Paints the specified border at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawBorder(
   Border border,
   float left,
   float top,
   float width,
   float height
)

Parameters

border
Border object to render on the page.
left
Left position of the border (in inches).
top
Top position of the border (in inches).
width
Width of the border (in inches).
height
Height of the border (in inches).

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    b.BottomColor = System.Drawing.Color.Red;
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.LeftColor = System.Drawing.Color.Red;
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.RightColor = System.Drawing.Color.Red;
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.TopColor = System.Drawing.Color.Red;
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;

    arv.Document.Pages[0].DrawBorder(b, 1, 1, 4, 4);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim b As New GrapeCity.ActiveReports.Border
    b.BottomColor = System.Drawing.Color.Red
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.LeftColor = System.Drawing.Color.Red
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.RightColor = System.Drawing.Color.Red
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.TopColor = System.Drawing.Color.Red
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid

    arv.Document.Pages(0).DrawBorder(b, 1, 1, 4, 4)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawBorder(Border,RectangleF) Method

[image]
ActiveReports 13
DrawBorder(Border,RectangleF) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawBorder Method : DrawBorder(Border,RectangleF) Method

border
Border object to render on the page.
bounds
System.Drawing.RectangleF coordinates to which to draw the border.

Glossary Item Box

Paints the specified border with the specified boundaries.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal bounds As RectangleF _
)
C#
public void DrawBorder(
   Border border,
   RectangleF bounds
)

Parameters

border
Border object to render on the page.
bounds
System.Drawing.RectangleF coordinates to which to draw the border.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    b.BottomColor = System.Drawing.Color.Red;
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.LeftColor = System.Drawing.Color.Red;
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.RightColor = System.Drawing.Color.Red;
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.TopColor = System.Drawing.Color.Red;
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawBorder(b, drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim b As New GrapeCity.ActiveReports.Border
    b.BottomColor = System.Drawing.Color.Red
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.LeftColor = System.Drawing.Color.Red
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.RightColor = System.Drawing.Color.Red
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.TopColor = System.Drawing.Color.Red
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid

    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    arv.Document.Pages(0).DrawBorder(b, drawRect)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawEllipse Method

[image]
ActiveReports 13
DrawEllipse Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawEllipse Method

left
Left position of the ellipse (in inches).
top
Top position of the ellipse (in inches).
width
Width of the ellipse (in inches)
height
Height of the ellipse (in inches).

Glossary Item Box

Draws an ellipse on the page.

Syntax

Visual Basic (Declaration)
Public Sub DrawEllipse( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawEllipse(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
Left position of the ellipse (in inches).
top
Top position of the ellipse (in inches).
width
Width of the ellipse (in inches)
height
Height of the ellipse (in inches).

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawEllipse(2, 2, 4, 8);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawEllipse(2, 2, 4, 8)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawImage Method

[image]
ActiveReports 13
DrawImage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawImage Method

Glossary Item Box

Draws an image on the page.

Overload List

Overload | Description
DrawImage(Image,Single,Single,Single,Single) | Draws the specified image within the specified coordinates.
DrawImage(Image,Single,Single,Single,Single,String,String) | Draws the specified image within the specified coordinates.
DrawImage(Image,RectangleF) | Draws the specified image within the specified rectangle bounds.
DrawImage(Image,Single,Single,Single,Single,String) | Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.
DrawImage(Image,Single,Single,Single,Single,String,String,String) | Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.
DrawImage(Image,RectangleF,String) | Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.
DrawImage(Image,Boolean,RectangleF,String) | Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.

Remarks

Units are determined by the Page.Units property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawImage(Image,Single,Single,Single,Single) Method

[image]
ActiveReports 13
DrawImage(Image,Single,Single,Single,Single) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single) Method

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).

Glossary Item Box

Draws the specified image within the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), 1, 1, 1, 1);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), 1, 1, 1, 1)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String,String) Method

[image]
ActiveReports 13
DrawImage(Image,Single,Single,Single,Single,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String,String) Method

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
title
Title of the image.
description
Description of the image.

Glossary Item Box

Draws the specified image within the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal title As String, _
   ByVal description As String _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   string title,
   string description
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
title
Title of the image.
description
Description of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,RectangleF) Method

[image]
ActiveReports 13
DrawImage(Image,RectangleF) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,RectangleF) Method

image
The System.Drawing.Image to draw on the page.
bounds
RectangleF structure that specifies the location and size of the drawn image.

Glossary Item Box

Draws the specified image within the specified rectangle bounds.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal bounds As RectangleF _
)
C#
public void DrawImage(
   Image image,
   RectangleF bounds
)

Parameters

image
The System.Drawing.Image to draw on the page.
bounds
RectangleF structure that specifies the location and size of the drawn image.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), drawRect)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String) Method

[image]
ActiveReports 13
DrawImage(Image,Single,Single,Single,Single,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String) Method

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
strLink
Hyperlink URL.

Glossary Item Box

Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
strLink
Hyperlink URL.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), 1, 1, 1, 1, "www.grapecity.com");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), 1, 1, 1, 1, "www.grapecity.com")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

[image]
ActiveReports 13
DrawImage(Image,Single,Single,Single,Single,String,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
strLink
Hyperlink URL.
title
Title of the image.
description
Description of the image.

Glossary Item Box

Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String, _
   ByVal title As String, _
   ByVal description As String _
)
C#
public void DrawImage(
   Image image,
   float left,
   float top,
   float width,
   float height,
   string strLink,
   string title,
   string description
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
strLink
Hyperlink URL.
title
Title of the image.
description
Description of the image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,RectangleF,String) Method

[image]
ActiveReports 13
DrawImage(Image,RectangleF,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,RectangleF,String) Method

image
The System.Drawing.Image to draw on the page.
bounds
RectangleF structure that specifies the location and size of the drawn image.
strLink
Hyperlink URL.

Glossary Item Box

Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal bounds As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawImage(
   Image image,
   RectangleF bounds,
   string strLink
)

Parameters

image
The System.Drawing.Image to draw on the page.
bounds
RectangleF structure that specifies the location and size of the drawn image.
strLink
Hyperlink URL.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), drawRect, "www.grapecity.com");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), drawRect, "www.grapecity.com")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Boolean,RectangleF,String) Method

[image]
ActiveReports 13
DrawImage(Image,Boolean,RectangleF,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Boolean,RectangleF,String) Method

image
The System.Drawing.Image to draw on the page.
imageChanged
Boolean value determining whether the image has changed.
text
Bounds of the image.
strLink
Hyperlink URL.

Glossary Item Box

Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal imageChanged As Boolean, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawImage(
   Image image,
   bool imageChanged,
   RectangleF text,
   string strLink
)

Parameters

image
The System.Drawing.Image to draw on the page.
imageChanged
Boolean value determining whether the image has changed.
text
Bounds of the image.
strLink
Hyperlink URL.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), true, drawRect, "www.grapecity.com");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), True, drawRect, "www.grapecity.com")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawLine Method

[image]
ActiveReports 13
DrawLine Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawLine Method

x1

Starting horizontal position of the line (in inches).

y1
Starting vertical position of the line (in inches).
x2

Ending horizontal position of the line (in inches).

y2
Starting vertical position of the line (in inches).

Glossary Item Box

Draws a line on the page at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Sub DrawLine( _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public void DrawLine(
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

x1

Starting horizontal position of the line (in inches).

y1
Starting vertical position of the line (in inches).
x2

Ending horizontal position of the line (in inches).

y2
Starting vertical position of the line (in inches).

Remarks

Uses PenStyle and PenWidth to draw the line.

Units are determined by the Page.Units property.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
PenStyle Property
PenWidth Property


DrawRect Method

[image]
ActiveReports 13
DrawRect Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawRect Method

Glossary Item Box

Draws a rectangular shape on the page at the specified coordinates.

Overload List

Overload | Description
DrawRect(Single,Single,Single,Single) | Draws a rectangular shape on the page at the specified coordinates.
DrawRect(RectangleF) | Draws a rectangular shape on the page at the specified rectangle bounds.

Remarks

Uses PenStyle, PenWidth and BackColor to draw the rectangle.

Units are determined by the Page.Units property.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawRect(drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRect(drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawRect(Single,Single,Single,Single) Method

[image]
ActiveReports 13
DrawRect(Single,Single,Single,Single) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRect Method : DrawRect(Single,Single,Single,Single) Method

left
Left position of the rectangle (in inches).
top

Top position of the rectangle (in inches).

width
Width of the rectangle (in inches).
height
Height of the rectangle (in inches).

Glossary Item Box

Draws a rectangular shape on the page at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawRect(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
Left position of the rectangle (in inches).
top

Top position of the rectangle (in inches).

width
Width of the rectangle (in inches).
height
Height of the rectangle (in inches).

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawRect(1,1,3,5);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRect(1, 1, 3, 5)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawRect(RectangleF) Method

[image]
ActiveReports 13
DrawRect(RectangleF) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRect Method : DrawRect(RectangleF) Method

rc
Bounds of the rectangle.

Glossary Item Box

Draws a rectangular shape on the page at the specified rectangle bounds.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRect( _
   ByVal rc As RectangleF _
)
C#
public void DrawRect(
   RectangleF rc
)

Parameters

rc
Bounds of the rectangle.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawRect(drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRect(drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawRoundRect Method

[image]
ActiveReports 13
DrawRoundRect Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawRoundRect Method

Glossary Item Box

Draws a rounded rectangle on the page at the specified coordinates.

Overload List

Overload | Description
DrawRoundRect(Single,Single,Single,Single,Single,Single) | Draws the round rect.
DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) | Renders rounded rect with different corner radiuses.

Remarks

Uses PenStyle, PenWidth and BackColor to draw the rectangle.

Units are determined by the Page.Units property.

Example

C# Copy Code
Private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = New rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawRoundRect(1, 1, 3, 2, 1, 1);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRoundRect(1, 1, 3, 2, 1, 1)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

[image]
ActiveReports 13
DrawRoundRect(Single,Single,Single,Single,Single,Single) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Glossary Item Box

Draws the round rect.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal edgeWidth As Single, _
   ByVal edgeHeight As Single _
)
C#
public void DrawRoundRect(
   float left,
   float top,
   float width,
   float height,
   float edgeWidth,
   float edgeHeight
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

[image]
ActiveReports 13
DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

left
top
width
height
topLeftEdge
topRightEdge
bottomLeftEdge
bottomRightEdge
precision
Parameter to specify when we should fail back to old round rect with equals corners

Glossary Item Box

Renders rounded rect with different corner radiuses.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawRoundRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal topLeftEdge As Single, _
   ByVal topRightEdge As Single, _
   ByVal bottomLeftEdge As Single, _
   ByVal bottomRightEdge As Single, _
   ByVal precision As Single _
)
C#
public void DrawRoundRect(
   float left,
   float top,
   float width,
   float height,
   float topLeftEdge,
   float topRightEdge,
   float bottomLeftEdge,
   float bottomRightEdge,
   float precision
)

Parameters

left
top
width
height
topLeftEdge
topRightEdge
bottomLeftEdge
bottomRightEdge
precision
Parameter to specify when we should fail back to old round rect with equals corners

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText Method

[image]
ActiveReports 13
DrawText Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawText Method

Glossary Item Box

Draws text on the page.

Overload List

Overload | Description
DrawText(String,Single,Single,Single,Single) | Draws the specified string within the specified coordinates.
DrawText(String,RectangleF) | Draws the specified string within the specified bounds.
DrawText(String[],Single,Single,Single,Single) | Draws the specified array of strings within the specified coordinates.
DrawText(String[],RectangleF) | Draws the specified array of strings within the specified bounds.
DrawText(String,Single,Single,Single,Single,String) | Draws the specified string within the specified coordinates and creates a hyperlink for the text area.
DrawText(String,RectangleF,String) | Draws the specified string within the specified bounds and creates a hyperlink at the specified area.
DrawText(String[],Single,Single,Single,Single,String) | Draws the specified array of strings within the specified coordinates and creates a hyperlink for the text area.
DrawText(String[],RectangleF,String) | Draws the specified array of strings within the specified bounds and creates a hyperlink at the specified area.

Remarks

Units are determined by the Page.Units property.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


DrawText(String,Single,Single,Single,Single) Method

[image]
ActiveReports 13
DrawText(String,Single,Single,Single,Single) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,Single,Single,Single,Single) Method

strText
Text string to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).

Glossary Item Box

Draws the specified string within the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawText(
   string strText,
   float left,
   float top,
   float width,
   float height
)

Parameters

strText
Text string to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).

Remarks

Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText("Confidential", 1, 1, 6.5f, 9);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", 1, 1, 6.5, 9)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,RectangleF) Method

[image]
ActiveReports 13
DrawText(String,RectangleF) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,RectangleF) Method

strText
Text string to be drawn on the page.
text
Bounds of the text.

Glossary Item Box

Draws the specified string within the specified bounds.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal text As RectangleF _
)
C#
public void DrawText(
   string strText,
   RectangleF text
)

Parameters

strText
Text string to be drawn on the page.
text
Bounds of the text.

Remarks

Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],Single,Single,Single,Single) Method

[image]
ActiveReports 13
DrawText(String[],Single,Single,Single,Single) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],Single,Single,Single,Single) Method

astrText
Array of text strings to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).

Glossary Item Box

Draws the specified array of strings within the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void DrawText(
   string[] astrText,
   float left,
   float top,
   float width,
   float height
)

Parameters

astrText
Array of text strings to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};

    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText(strArray, 1, 1, 6.5f, 9);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, 1, 1, 6.5, 9)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],RectangleF) Method

[image]
ActiveReports 13
DrawText(String[],RectangleF) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],RectangleF) Method

astrText
Array of text strings to be drawn on the page.
text
Bounds of the text.

Glossary Item Box

Draws the specified array of strings within the specified bounds.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal text As RectangleF _
)
C#
public void DrawText(
   string[] astrText,
   RectangleF text
)

Parameters

astrText
Array of text strings to be drawn on the page.
text
Bounds of the text.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText(strArray, drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,Single,Single,Single,Single,String) Method

[image]
ActiveReports 13
DrawText(String,Single,Single,Single,Single,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,Single,Single,Single,Single,String) Method

strText
Text string to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
strLink
Hyperlink URL.

Glossary Item Box

Draws the specified string within the specified coordinates and creates a hyperlink for the text area.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string strText,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

strText
Text string to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
strLink
Hyperlink URL.

Remarks

Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText("Confidential", 1, 1, 6.5f, 9, "www.grapecity.com");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", 1, 1, 6.5, 9, "www.grapecity.com")
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,RectangleF,String) Method

[image]
ActiveReports 13
DrawText(String,RectangleF,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,RectangleF,String) Method

strText
Text string to be drawn on the page.
text
Bounds of the text.
strLink
Hyperlink URL.

Glossary Item Box

Draws the specified string within the specified bounds and creates a hyperlink at the specified area.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal strText As String, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string strText,
   RectangleF text,
   string strLink
)

Parameters

strText
Text string to be drawn on the page.
text
Bounds of the text.
strLink
Hyperlink URL.

Remarks

Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect, "www.grapecity.com");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect, "www.grapecity.com")
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],Single,Single,Single,Single,String) Method

[image]
ActiveReports 13
DrawText(String[],Single,Single,Single,Single,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],Single,Single,Single,Single,String) Method

astrText
Array of text strings to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
strLink
Hyperlink URL.

Glossary Item Box

Draws the specified array of strings within the specified coordinates and creates a hyperlink for the text area.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string[] astrText,
   float left,
   float top,
   float width,
   float height,
   string strLink
)

Parameters

astrText
Array of text strings to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
strLink
Hyperlink URL.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};

    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText(strArray, 1, 1, 6.5f, 9, "www.grapecity.com");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, 1, 1, 6.5, 9, "www.grapecity.com")
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],RectangleF,String) Method

[image]
ActiveReports 13
DrawText(String[],RectangleF,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],RectangleF,String) Method

astrText
Array of text strings to be drawn on the page.
text
Bounds of the text.
strLink
Hyperlink URL.

Glossary Item Box

Draws the specified array of strings within the specified bounds and creates a hyperlink at the specified area.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawText( _
   ByVal astrText() As String, _
   ByVal text As RectangleF, _
   ByVal strLink As String _
)
C#
public void DrawText(
   string[] astrText,
   RectangleF text,
   string strLink
)

Parameters

astrText
Array of text strings to be drawn on the page.
text
Bounds of the text.
strLink
Hyperlink URL.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText(strArray, drawRect, "www.grapecity.com");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, drawRect, "www.grapecity.com")
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


FillRect Method

[image]
ActiveReports 13
FillRect Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : FillRect Method

Glossary Item Box

Fills the specified area with the current page BackColor.

Overload List

Overload | Description
FillRect(Single,Single,Single,Single) | Fills the specified coordinates with the current page BackColor.
FillRect(RectangleF) | Fills the specified bounds with the current page BackColor.

Remarks

Units are determined by the Page.Units property.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;

    arv.Document.Pages[0].FillRect(1, 1, 2, 2);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .FillRect(1, 1, 2, 2)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


FillRect(Single,Single,Single,Single) Method

[image]
ActiveReports 13
FillRect(Single,Single,Single,Single) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > FillRect Method : FillRect(Single,Single,Single,Single) Method

left
Left position of the rectangle (in inches).
top

Top position of the rectangle (in inches).

width
Width of the rectangle (in inches).
height
Height of the rectangle (in inches).

Glossary Item Box

Fills the specified coordinates with the current page BackColor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRect( _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public void FillRect(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
Left position of the rectangle (in inches).
top

Top position of the rectangle (in inches).

width
Width of the rectangle (in inches).
height
Height of the rectangle (in inches).

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;

    arv.Document.Pages[0].FillRect(1, 1, 2, 2);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .FillRect(1, 1, 2, 2)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


FillRect(RectangleF) Method

[image]
ActiveReports 13
FillRect(RectangleF) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > FillRect Method : FillRect(RectangleF) Method

rc
Bounds of the rectangle.

Glossary Item Box

Fills the specified bounds with the current page BackColor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub FillRect( _
   ByVal rc As RectangleF _
)
C#
public void FillRect(
   RectangleF rc
)

Parameters

rc
Bounds of the rectangle.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].FillRect(drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .FillRect(drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Load Method

[image]
ActiveReports 13
Load Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Load Method

Glossary Item Box

Loads page content from a reader or a file.

Overload List

Overload | Description
Load(String) | Loads page content from the specified file name.
Load(Stream) | Loads page content from the specified stream.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Load(String) Method

[image]
ActiveReports 13
Load(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Load Method : Load(String) Method

strFileName
Specifies the name of the file that contains the previously saved page content.

Glossary Item Box

Loads page content from the specified file name.

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal strFileName As String _
) As Boolean
C#
public bool Load(
   string strFileName
)

Parameters

strFileName
Specifies the name of the file that contains the previously saved page content.

Remarks

Page content can be saved using the Page.Save method.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Load(Stream) Method

[image]
ActiveReports 13
Load(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Load Method : Load(Stream) Method

stm
Specifies the Stream that contains the previously saved page content.

Glossary Item Box

Loads page content from the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Function Load( _
   ByVal stm As Stream _
) As Boolean
C#
public bool Load(
   Stream stm
)

Parameters

stm
Specifies the Stream that contains the previously saved page content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureParagraphHeight Method

[image]
ActiveReports 13
MeasureParagraphHeight Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : MeasureParagraphHeight Method

Glossary Item Box

Measures the height of the specified text if rendered using the current page settings with the specified width.

Overload List

Overload | Description
MeasureParagraphHeight(String,Single) | Measures the height of the specified text in a specified width at run time.
MeasureParagraphHeight(String,Single,Font,StringFormat) | Measures the height of the specified text in a specified width, font, and format at run time.

Remarks

Units are determined by the Page.Units property.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    System.Drawing.SizeF x;

    rpt.CurrentPage.Font = this.TextBox1.Font;
    Console.WriteLine("TextBox1 Size = " + this.TextBox1.Size.ToString());
    string y;
    y = "This is a really long textbox with text that should wrap multiple lines so I can then measure the height of the text using the MeasureParagrahHeight method off of the page object.";
    x = arv.Document.Pages[0].MeasureParagraphHeight(y,this.TextBox1.Width);
    Console.WriteLine("MPH = " + x.ToString());
    this.TextBox1.Size = x.ToSize();
    this.TextBox1.Text = y;
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Dim x As System.Drawing.SizeF

    rpt.CurrentPage.Font = Me.TextBox1.Font
    Console.WriteLine("TextBox1 Size = " + Me.TextBox1.Size.ToString())
    Dim y As String
    y = "This is a really long textbox with text that should wrap multiple lines so I can then measure the height of the text using the MeasureParagrahHeight method off of the page object."
    x = arv.Document.Pages(0).MeasureParagraphHeight(y, Me.TextBox1.Width)
    Console.WriteLine("MPH = " + x.ToString())
    Me.TextBox1.Size = x.ToSize()
    Me.TextBox1.Text = y
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


MeasureParagraphHeight(String,Single) Method

[image]
ActiveReports 13
MeasureParagraphHeight(String,Single) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureParagraphHeight Method : MeasureParagraphHeight(String,Single) Method

strText

Text string to be measured.

width
Width of the text (in inches).

Glossary Item Box

Measures the height of the specified text in a specified width at run time.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureParagraphHeight( _
   ByVal strText As String, _
   ByVal width As Single _
) As SizeF
C#
public SizeF MeasureParagraphHeight(
   string strText,
   float width
)

Parameters

strText

Text string to be measured.

width
Width of the text (in inches).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureParagraphHeight(String,Single,Font,StringFormat) Method

[image]
ActiveReports 13
MeasureParagraphHeight(String,Single,Font,StringFormat) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureParagraphHeight Method : MeasureParagraphHeight(String,Single,Font,StringFormat) Method

strText

Text string to be measured.

width
Width of the text (in inches).
textFont
The font of the text string to be measured.
strFormat
The format of the text string to be measured.

Glossary Item Box

Measures the height of the specified text in a specified width, font, and format at run time.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureParagraphHeight( _
   ByVal strText As String, _
   ByVal width As Single, _
   ByVal textFont As Font, _
   ByVal strFormat As StringFormat _
) As SizeF
C#
public SizeF MeasureParagraphHeight(
   string strText,
   float width,
   Font textFont,
   StringFormat strFormat
)

Parameters

strText

Text string to be measured.

width
Width of the text (in inches).
textFont
The font of the text string to be measured.
strFormat
The format of the text string to be measured.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureText Method

[image]
ActiveReports 13
MeasureText Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : MeasureText Method

Glossary Item Box

Determines the width and height of text string.

Overload List

Overload | Description
MeasureText(String) | Measures the text string with the currently selected font.
MeasureText(String,Font) | Measures the text string.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    SizeF sz = arv.Document.Pages[0].MeasureText("This is my string. How long is it?");
    arv.Document.Pages[0].DrawText("This is my string. How long is it? " + sz.ToString(),0,0,6f,9f);
    arv.Document.Pages[0].DrawLine(0,sz.Height,sz.Width,sz.Height);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Dim sz As SizeF = arv.Document.Pages(0).MeasureText("This is my string. How long is it?")
    arv.Document.Pages(0).DrawText("This is my string. How long is it? " + sz.ToString(), 0, 0, 6.0F, 9.0F)
    arv.Document.Pages(0).DrawLine(0, sz.Height, sz.Width, sz.Height)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


MeasureText(String) Method

[image]
ActiveReports 13
MeasureText(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureText Method : MeasureText(String) Method

strText
The text string to measure.

Glossary Item Box

Measures the text string with the currently selected font.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureText( _
   ByVal strText As String _
) As SizeF
C#
public SizeF MeasureText(
   string strText
)

Parameters

strText
The text string to measure.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


MeasureText(String,Font) Method

[image]
ActiveReports 13
MeasureText(String,Font) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureText Method : MeasureText(String,Font) Method

strText
The text string to measure.
font
The font of the text.

Glossary Item Box

Measures the text string.

Syntax

Visual Basic (Declaration)
Public Overloads Function MeasureText( _
   ByVal strText As String, _
   ByVal font As Font _
) As SizeF
C#
public SizeF MeasureText(
   string strText,
   Font font
)

Parameters

strText
The text string to measure.
font
The font of the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Overlay Method

[image]
ActiveReports 13
Overlay Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Overlay Method

page
Page to be laid on top of the current page.

Glossary Item Box

Overlays the specified page object on top of the Page.

Syntax

Visual Basic (Declaration)
Public Sub Overlay( _
   ByVal page As Page _
)
C#
public void Overlay(
   Page page
)

Parameters

page
Page to be laid on top of the current page.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    rptReport rpt = new rptReport();
    rpt.Run();
    rptTemplate rpt2 = new rptTemplate();
    rpt2.Run();
    viewer1.Document = rpt.Document;
    for(int i = 0; i < rpt.Document.Pages.Count; i++)
    {
        rpt.Document.Pages[i].Overlay(rpt2.Document.Pages[0]);
    }
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptReport()
    rpt.Run()
    Dim rpt2 As New rptTemplate()
    rpt2.Run()
    Viewer1.Document = rpt.Document
    For i = 0 To rpt.Document.Pages.Count - 1
        rpt.Document.Pages(i).Overlay(rpt2.Document.Pages(0))
    Next
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members

Walkthroughs

Overlaying Reports (Letterhead)


Save Method

[image]
ActiveReports 13
Save Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Save Method

Glossary Item Box

Saves page content.

Overload List

Overload | Description
Save(String) | Saves page content to the specified file name.
Save(Stream) | Saves page content to the specified Stream.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Save(String) Method

[image]
ActiveReports 13
Save(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Save Method : Save(String) Method

strFileName
Specifies the name of the file in which to store the page content.

Glossary Item Box

Saves page content to the specified file name.

Syntax

Visual Basic (Declaration)
Public Overloads Function Save( _
   ByVal strFileName As String _
) As Boolean
C#
public bool Save(
   string strFileName
)

Parameters

strFileName
Specifies the name of the file in which to store the page content.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


Save(Stream) Method

[image]
ActiveReports 13
Save(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Save Method : Save(Stream) Method

stm
Specifies the stream to which to store the page content.

Glossary Item Box

Saves page content to the specified Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Function Save( _
   ByVal stm As Stream _
) As Boolean
C#
public bool Save(
   Stream stm
)

Parameters

stm
Specifies the stream to which to store the page content.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Overload List


SetTextBoundsRange Method

[image]
ActiveReports 13
SetTextBoundsRange Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : SetTextBoundsRange Method

startPos
endPos

Glossary Item Box

Sets text top/bottom bounds.

Syntax

Visual Basic (Declaration)
Public Sub SetTextBoundsRange( _
   ByVal startPos As Single, _
   ByVal endPos As Single _
)
C#
public void SetTextBoundsRange(
   float startPos,
   float endPos
)

Parameters

startPos
endPos

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ToString Method

Glossary Item Box

Renders the page's settings and content to a string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    Console.WriteLine(arv.Document.Pages[0].ToString());
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Console.WriteLine(arv.Document.Pages(0).ToString())
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Page Class Properties

[image]
ActiveReports 13
Page Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

Glossary Item Box

For a list of all members of this type, see Page members.

Public Properties

 | Name | Description
Public Property | Annotations | Gets or sets the annotations associated with the page.
Public Property | BackColor | Specifies the background color used to render shapes and text to the page.
Public Property | Bookmarks | Returns a list of the page's bookmarks.
Public Property | CanvasItems | Returns a list of the page's canvas items.
Public Property | CharacterSpacing | Gets or sets the CharacterSpacing value in inches for the page.
Public Property | Compress | Sets or returns a value indicating whether the page is compressed.
Public Property | Font | Gets or sets the current font used to draw text on the page.
Public Property | Fonts | Returns the collection of fonts for the page.
Public Property | ForeColor | Gets or sets the current foreground color used to draw text and shapes on the page.
Public Property | Height | Gets or sets the height of the page in inches.
Public Property | Identifier | Gets unique page identifier (used in PagesCollection to track swapped out pages)
Public Property | LineSpacing | Gets or sets the LineSpacing value in inches for the page.
Public Property | Margins | Gets a reference to the page margins settings.
Public Property | Orientation | Gets or sets the orientation of the page.
Public Property | Padding | Gets or sets the amount of padding to use around the text inside a control.
Public Property | PenStyle | Gets or sets the line style used to draw lines and shapes.
Public Property | PenWidth | Gets or sets the width of the pen used to draw lines and shapes. (1/10 point)(1/2 point).
Public Property | RightToLeft | Determines whether DrawText should render text RightToLeft.
Public Property | ScaleX | Gets or sets the minimal character condensed rate.
Public Property | Size | Returns a SizeF structure with the height and width of the page, in inches.
Public Property | TextAlignment | Determines the text alignment when using the DrawText method.
Public Property | TextAngle | Gets or sets the angle of text used to draw text.
Public Property | TextJustify | Gets or sets the type of justification to use when the TextAlignment property is set to Justify.
Public Property | TextRenderHint | Specifies the quality of rendering.
Public Property | Units | Gets or sets the units used with the page primitive drawing methods.
Public Property | VerticalText | Sets or returns a value indicating whether to draw text vertically when using the DrawText method.
Public Property | VerticalTextAlignment | Determines the vertical text alignment when using the DrawText method.
Public Property | Width | Gets or sets the width of the page (in inches).
Public Property | WrapMode | Gets or sets the wrap mode for rendering text.
Top

See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


Annotations Property

[image]
ActiveReports 13
Annotations Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Annotations Property

Glossary Item Box

Gets or sets the annotations associated with the page.

Syntax

Visual Basic (Declaration)
Public Property Annotations As AnnotationCollection
C#
public AnnotationCollection Annotations {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : BackColor Property

Glossary Item Box

Specifies the background color used to render shapes and text to the page.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

System.Drawing.Color value.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Bookmarks Property

[image]
ActiveReports 13
Bookmarks Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Bookmarks Property

Glossary Item Box

Returns a list of the page's bookmarks.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As IList
C#
public IList Bookmarks {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


CanvasItems Property

[image]
ActiveReports 13
CanvasItems Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : CanvasItems Property

Glossary Item Box

Returns a list of the page's canvas items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanvasItems As IList
C#
public IList CanvasItems {get;}

Remarks

Use the Clear method to remove all CanvasItems from the Page object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


CharacterSpacing Property

[image]
ActiveReports 13
CharacterSpacing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : CharacterSpacing Property

Glossary Item Box

Gets or sets the CharacterSpacing value in inches for the page.

Syntax

Visual Basic (Declaration)
Public Property CharacterSpacing As Single
C#
public float CharacterSpacing {get; set;}

Property Value

The character spacing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Compress Property

[image]
ActiveReports 13
Compress Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Compress Property

Glossary Item Box

Sets or returns a value indicating whether the page is compressed.

Syntax

Visual Basic (Declaration)
Public Property Compress As Boolean
C#
public bool Compress {get; set;}

Property Value

Boolean. The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Font Property

[image]
ActiveReports 13
Font Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Font Property

Glossary Item Box

Gets or sets the current font used to draw text on the page.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

System.Drawing.Font value.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Fonts Property

[image]
ActiveReports 13
Fonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Fonts Property

Glossary Item Box

Returns the collection of fonts for the page.

Syntax

Visual Basic (Declaration)
Public Property Fonts As FontsCollection
C#
public FontsCollection Fonts {get; set;}

Property Value

The fonts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ForeColor Property

Glossary Item Box

Gets or sets the current foreground color used to draw text and shapes on the page.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color value.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Height Property

Glossary Item Box

Gets or sets the height of the page in inches.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Identifier Property

[image]
ActiveReports 13
Identifier Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Identifier Property

Glossary Item Box

Gets unique page identifier (used in PagesCollection to track swapped out pages)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Identifier As Guid
C#
public Guid Identifier {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


LineSpacing Property

[image]
ActiveReports 13
LineSpacing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : LineSpacing Property

Glossary Item Box

Gets or sets the LineSpacing value in inches for the page.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Single
C#
public float LineSpacing {get; set;}

Property Value

The line spacing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Margins Property

[image]
ActiveReports 13
Margins Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Margins Property

Glossary Item Box

Gets a reference to the page margins settings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Margins As Margins
C#
public Margins Margins {get;}

Property Value

A Margins object used to set the margins of the page.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    Console.WriteLine(arv.Document.Pages[0].Margins.Bottom);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Console.WriteLine(arv.Document.Pages(0).Margins.Bottom)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Orientation Property

[image]
ActiveReports 13
Orientation Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Orientation Property

Glossary Item Box

Gets or sets the orientation of the page.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
C#
public PageOrientation Orientation {get; set;}

Property Value

PageOrientation enumeration value that specifies the orientation of the page.

Remarks

The Printer.PaperHeight measurement is for the portrait orientation of the paper. In Landscape, the height is equal to Printer.PaperWidth.

Example

C# Copy Code
private void rptPrint_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;
}
Visual Basic Copy Code
Private Sub rptPrint_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
PageOrientation Enumeration
Printer Class


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Padding Property

Glossary Item Box

Gets or sets the amount of padding to use around the text inside a control.

Syntax

Visual Basic (Declaration)
Public Property Padding As PaddingEx
C#
public PaddingEx Padding {get; set;}

Property Value

The padding.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PenStyle Property

[image]
ActiveReports 13
PenStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : PenStyle Property

Glossary Item Box

Gets or sets the line style used to draw lines and shapes.

Syntax

Visual Basic (Declaration)
Public Property PenStyle As PenStyles
C#
public PenStyles PenStyle {get; set;}

Property Value

PenStyles enumeration value that determines the line style used to draw lines and shapes.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
PenStyles Enumeration


PenWidth Property

[image]
ActiveReports 13
PenWidth Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : PenWidth Property

Glossary Item Box

Gets or sets the width of the pen used to draw lines and shapes. (1/10 point)(1/2 point).

Syntax

Visual Basic (Declaration)
Public Property PenWidth As Short
C#
public short PenWidth {get; set;}

Property Value

Integer value (in 1/2 point) that specifies the width of the line.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub

Requirements

See Also

Reference

Page Class
Page Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : RightToLeft Property

Glossary Item Box

Determines whether DrawText should render text RightToLeft.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
C#
public bool RightToLeft {get; set;}

Property Value

A Boolean value. True if the text is rendered right to left; otherwise, false. Default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


ScaleX Property

[image]
ActiveReports 13
ScaleX Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ScaleX Property

Glossary Item Box

Gets or sets the minimal character condensed rate.

Syntax

Visual Basic (Declaration)
Public Property ScaleX As Single
C#
public float ScaleX {get; set;}

Property Value

The minimal character condensed rate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Size Property

Glossary Item Box

Returns a SizeF structure with the height and width of the page, in inches.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As SizeF
C#
public SizeF Size {get;}

Property Value

A SizeF value specifying the height and width in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextAlignment Property

[image]
ActiveReports 13
TextAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextAlignment Property

Glossary Item Box

Determines the text alignment when using the DrawText method.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As GrapeCity.ActiveReports.Drawing.TextAlignment
C#
public GrapeCity.ActiveReports.Drawing.TextAlignment TextAlignment {get; set;}

Property Value

TextAlignment enumeration.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextAngle Property

[image]
ActiveReports 13
TextAngle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextAngle Property

Glossary Item Box

Gets or sets the angle of text used to draw text.

Syntax

Visual Basic (Declaration)
Public Property TextAngle As Integer
C#
public int TextAngle {get; set;}

Property Value

Integer value of the text angle (1/10 degree).

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextJustify Property

[image]
ActiveReports 13
TextJustify Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextJustify Property

Glossary Item Box

Gets or sets the type of justification to use when the TextAlignment property is set to Justify.

Syntax

Visual Basic (Declaration)
Public Property TextJustify As GrapeCity.ActiveReports.Drawing.TextJustify
C#
public GrapeCity.ActiveReports.Drawing.TextJustify TextJustify {get; set;}

Property Value

The text justify.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


TextRenderHint Property

[image]
ActiveReports 13
TextRenderHint Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextRenderHint Property

Glossary Item Box

Specifies the quality of rendering.

Syntax

Visual Basic (Declaration)
Public Property TextRenderHint As TextRenderHint
C#
public TextRenderHint TextRenderHint {get; set;}

Property Value

The text render hint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Units Property

[image]
ActiveReports 13
Units Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Units Property

Glossary Item Box

Gets or sets the units used with the page primitive drawing methods.

Syntax

Visual Basic (Declaration)
Public Property Units As Units
C#
public Units Units {get; set;}

Property Value

Units enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members
Units Enumeration


VerticalText Property

[image]
ActiveReports 13
VerticalText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : VerticalText Property

Glossary Item Box

Sets or returns a value indicating whether to draw text vertically when using the DrawText method.

Syntax

Visual Basic (Declaration)
Public Property VerticalText As Boolean
C#
public bool VerticalText {get; set;}

Property Value

true if [vertical text]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


VerticalTextAlignment Property

[image]
ActiveReports 13
VerticalTextAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : VerticalTextAlignment Property

Glossary Item Box

Determines the vertical text alignment when using the DrawText method.

Syntax

Visual Basic (Declaration)
Public Property VerticalTextAlignment As GrapeCity.ActiveReports.Drawing.VerticalTextAlignment
C#
public GrapeCity.ActiveReports.Drawing.VerticalTextAlignment VerticalTextAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
Visual Basic Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Width Property

Glossary Item Box

Gets or sets the width of the page (in inches).

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


WrapMode Property

[image]
ActiveReports 13
WrapMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : WrapMode Property

Glossary Item Box

Gets or sets the wrap mode for rendering text.

Syntax

Visual Basic (Declaration)
Public Property WrapMode As GrapeCity.ActiveReports.Drawing.WrapMode
C#
public GrapeCity.ActiveReports.Drawing.WrapMode WrapMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


PageDoubleLineExtensions Class

[image]
ActiveReports 13
PageDoubleLineExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageDoubleLineExtensions Class

Glossary Item Box

Provides extension methods for Page

Object Model

PageDoubleLineExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PageDoubleLineExtensions
C#
public static class PageDoubleLineExtensions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PageDoubleLineExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Members
GrapeCity.ActiveReports.Document.Section Namespace


PageDoubleLineExtensions Class Members

[image]
ActiveReports 13
PageDoubleLineExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageDoubleLineExtensions Class

Glossary Item Box

The following tables list the members exposed by PageDoubleLineExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawDoubleLine | Draws the double line.
static (Shared in Visual Basic) | DrawEllipseDoubleLine | Draws the double line ellipse.
static (Shared in Visual Basic) | DrawRoundRectDoubleLine | Draws the double line round rect.
Top

See Also

Reference

PageDoubleLineExtensions Class
GrapeCity.ActiveReports.Document.Section Namespace


PageDoubleLineExtensions Class Methods

[image]
ActiveReports 13
PageDoubleLineExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageDoubleLineExtensions Class

Glossary Item Box

For a list of all members of this type, see PageDoubleLineExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawDoubleLine | Draws the double line.
static (Shared in Visual Basic) | DrawEllipseDoubleLine | Draws the double line ellipse.
static (Shared in Visual Basic) | DrawRoundRectDoubleLine | Draws the double line round rect.
Top

See Also

Reference

PageDoubleLineExtensions Class
GrapeCity.ActiveReports.Document.Section Namespace


DrawDoubleLine Method

[image]
ActiveReports 13
DrawDoubleLine Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageDoubleLineExtensions Class : DrawDoubleLine Method

page
x1
y1
x2
y2

Glossary Item Box

Draws the double line.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawDoubleLine( _
   ByVal page As Page, _
   ByVal x1 As Single, _
   ByVal y1 As Single, _
   ByVal x2 As Single, _
   ByVal y2 As Single _
)
C#
public static void DrawDoubleLine(
   Page page,
   float x1,
   float y1,
   float x2,
   float y2
)

Parameters

page
x1
y1
x2
y2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Class
PageDoubleLineExtensions Members


DrawEllipseDoubleLine Method

[image]
ActiveReports 13
DrawEllipseDoubleLine Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageDoubleLineExtensions Class : DrawEllipseDoubleLine Method

page
left
The left.
top
The top.
width
The width.
height
The height.

Glossary Item Box

Draws the double line ellipse.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawEllipseDoubleLine( _
   ByVal page As Page, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public static void DrawEllipseDoubleLine(
   Page page,
   float left,
   float top,
   float width,
   float height
)

Parameters

page
left
The left.
top
The top.
width
The width.
height
The height.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Class
PageDoubleLineExtensions Members


DrawRoundRectDoubleLine Method

[image]
ActiveReports 13
DrawRoundRectDoubleLine Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PageDoubleLineExtensions Class : DrawRoundRectDoubleLine Method

page
left
The left.
top
The top.
width
The width.
height
The height.
topLeftEdge
Top Left edge.
topRightEdge
Top Right edge.
bottomLeftEdge
Bottom Left edge.
bottomRightEdge
Bottom Right Edge.
precision
Parameter to specify when we should fail back to old round rect with equals corners

Glossary Item Box

Draws the double line round rect.

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawRoundRectDoubleLine( _
   ByVal page As Page, _
   ByVal left As Single, _
   ByVal top As Single, _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal topLeftEdge As Single, _
   ByVal topRightEdge As Single, _
   ByVal bottomLeftEdge As Single, _
   ByVal bottomRightEdge As Single, _
   ByVal precision As Single _
)
C#
public static void DrawRoundRectDoubleLine(
   Page page,
   float left,
   float top,
   float width,
   float height,
   float topLeftEdge,
   float topRightEdge,
   float bottomLeftEdge,
   float bottomRightEdge,
   float precision
)

Parameters

page
left
The left.
top
The top.
width
The width.
height
The height.
topLeftEdge
Top Left edge.
topRightEdge
Top Right edge.
bottomLeftEdge
Bottom Left edge.
bottomRightEdge
Bottom Right Edge.
precision
Parameter to specify when we should fail back to old round rect with equals corners

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageDoubleLineExtensions Class
PageDoubleLineExtensions Members


PagesCollection Class

[image]
ActiveReports 13
PagesCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

Glossary Item Box

Manages a set of pages in the Document object.

Object Model

PagesCollection Class

Syntax

Visual Basic (Declaration)
Public Class PagesCollection
C#
public class PagesCollection

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PagesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Members
GrapeCity.ActiveReports.Document.Section Namespace


PagesCollection Class Members

[image]
ActiveReports 13
PagesCollection Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

Glossary Item Box

The following tables list the members exposed by PagesCollection.

Public Constructors

 | Name | Description
Public Constructor | PagesCollection Constructor | Overloaded. Initializes a new instance of the PagesCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of Page members in the collection.
Public Property | Fonts | Returns the FontsCollection that is used in the PagesCollection.
Public Property | IsFixedSize | Gets a value indicating whether the PagesCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the PagesCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the PagesCollection is synchronized (thread safe). (Inherited from ICollection.)
Public Property | Item | Returns the member at the specified index in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the PagesCollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified Page object to the collection.
Public Method | AddRange | Overloaded. Adds an array or collection of pages.
Public Method | Clear | Clears all pages from the collection.
Public Method | Clone | Creates a clone of the PagesCollection.
Public Method | Contains | Overloaded. Determines whether the specified object is a member of the collection.
Public Method | CopyTo | Overloaded. Copies pages from the collection to an array, starting at a particular array index.
Public Method | GetRange | Returns a new collection of the specified number of pages starting with the specified index
Public Method | IndexOf | Overloaded. Returns the index of a page in the collection.
Public Method | Insert | Overloaded. Inserts the specified page into the collection at the specified index.
Public Method | InsertNew | Creates a new Page object and inserts it into the collection at the specified index.
Public Method | InsertRange | Overloaded. Inserts a range of pages into the collection at a specified position.
Public Method | Remove | Overloaded. Removes the specified page object from the collection.
Public Method | RemoveAt | Removes the page at the specified index from the collection.
Top

See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


PagesCollection Constructor

[image]
ActiveReports 13
PagesCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : PagesCollection Constructor

Glossary Item Box

Initializes a new instance of the PagesCollection class.

Overload List

Overload | Description
PagesCollection Constructor() | Initializes a new instance of the PagesCollection class.
PagesCollection Constructor(SectionDocument) | Initializes a new instance of the PagesCollection class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


PagesCollection Constructor()

[image]
ActiveReports 13
PagesCollection Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > PagesCollection Constructor : PagesCollection Constructor()

Glossary Item Box

Initializes a new instance of the PagesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PagesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


PagesCollection Constructor(SectionDocument)

[image]
ActiveReports 13
PagesCollection Constructor(SectionDocument)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > PagesCollection Constructor : PagesCollection Constructor(SectionDocument)

document
Section document.

Glossary Item Box

Initializes a new instance of the PagesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal document As SectionDocument _
)
C#
public PagesCollection(
   SectionDocument document
)

Parameters

document
Section document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


PagesCollection Class Methods

[image]
ActiveReports 13
PagesCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

Glossary Item Box

For a list of all members of this type, see PagesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified Page object to the collection.
Public Method | AddRange | Overloaded. Adds an array or collection of pages.
Public Method | Clear | Clears all pages from the collection.
Public Method | Clone | Creates a clone of the PagesCollection.
Public Method | Contains | Overloaded. Determines whether the specified object is a member of the collection.
Public Method | CopyTo | Overloaded. Copies pages from the collection to an array, starting at a particular array index.
Public Method | GetRange | Returns a new collection of the specified number of pages starting with the specified index
Public Method | IndexOf | Overloaded. Returns the index of a page in the collection.
Public Method | Insert | Overloaded. Inserts the specified page into the collection at the specified index.
Public Method | InsertNew | Creates a new Page object and inserts it into the collection at the specified index.
Public Method | InsertRange | Overloaded. Inserts a range of pages into the collection at a specified position.
Public Method | Remove | Overloaded. Removes the specified page object from the collection.
Public Method | RemoveAt | Removes the page at the specified index from the collection.
Top

See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Add Method

Glossary Item Box

Adds the specified Page object to the collection.

Overload List

Overload | Description
Add(Object) | Adds a Page object to the end of the PagesCollection.
Add(Page) | Adds a Page object to the end of the PagesCollection.

Example

C# Copy Code
int i;
private void Form1_Load(object sender, System.EventArgs e)
{
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    for(i = 0; i < rpt2.Document.Pages.Count; i++)
    {
        rpt1.Document.Pages.Add(rpt2.Document.Pages[i]);
    }
    viewer1.Document = rpt1.Document;
}
Visual Basic Copy Code
Dim i As Integer
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptOne()
    rpt.Run()
    Dim rpt2 As New rptTwo()
    rpt2.Run()
    For i = 0 To rpt2.Document.Pages.Count - 1
        rpt.Document.Pages.Add(rpt2.Document.Pages(i))
    Next
    Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


Add(Object) Method

[image]
ActiveReports 13
Add(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Add Method : Add(Object) Method

value
The page object to add.

Glossary Item Box

Adds a Page object to the end of the PagesCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As Object _
) As Integer
C#
public int Add(
   object value
)

Parameters

value
The page object to add.

Return Value

The position into which the new element was inserted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Add(Page) Method

[image]
ActiveReports 13
Add(Page) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Add Method : Add(Page) Method

value
The page object to add.

Glossary Item Box

Adds a Page object to the end of the PagesCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As Page _
) As Integer
C#
public int Add(
   Page value
)

Parameters

value
The page object to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


AddRange Method

[image]
ActiveReports 13
AddRange Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : AddRange Method

Glossary Item Box

Adds an array or collection of pages.

Overload List

Overload | Description
AddRange(Page[]) | Adds the specified array of Page objects to the collection.
AddRange(PagesCollection) | Adds the pages from the specified collection into the collection.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    rpt1.Document.Pages.AddRange(rpt2.Document.Pages);
    viewer1.Document = rpt1.Document;
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim rpt As New rptOne()
        rpt.Run()
        Dim rpt2 As New rptTwo()
        rpt2.Run()
        rpt.Document.Pages.AddRange(rpt2.Document.Pages)
        Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


AddRange(Page[]) Method

[image]
ActiveReports 13
AddRange(Page[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > AddRange Method : AddRange(Page[]) Method

pages
Array of pages to be added to the collection.

Glossary Item Box

Adds the specified array of Page objects to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal pages() As Page _
)
C#
public void AddRange(
   Page[] pages
)

Parameters

pages
Array of pages to be added to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


AddRange(PagesCollection) Method

[image]
ActiveReports 13
AddRange(PagesCollection) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > AddRange Method : AddRange(PagesCollection) Method

pages

Collection of pages to be added to the collection.

Glossary Item Box

Adds the pages from the specified collection into the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal pages As PagesCollection _
)
C#
public void AddRange(
   PagesCollection pages
)

Parameters

pages

Collection of pages to be added to the collection.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    rpt1.Document.Pages.AddRange(rpt2.Document.Pages);
    viewer1.Document = rpt1.Document;
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim rpt As New rptOne()
        rpt.Run()
        Dim rpt2 As New rptTwo()
        rpt2.Run()
        rpt.Document.Pages.AddRange(rpt2.Document.Pages)
        Viewer1.Document = rpt.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Clear Method

Glossary Item Box

Clears all pages from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


Clone Method

[image]
ActiveReports 13
Clone Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Clone Method

Glossary Item Box

Creates a clone of the PagesCollection.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Contains Method

Glossary Item Box

Determines whether the specified object is a member of the collection.

Overload List

Overload | Description
Contains(Object) | Determines whether the specified object is a member of the collection.
Contains(Page) | Determines whether a Page element is in the PagesCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


Contains(Object) Method

[image]
ActiveReports 13
Contains(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Contains Method : Contains(Object) Method

value
The page to locate in the collection.

Glossary Item Box

Determines whether the specified object is a member of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public bool Contains(
   object value
)

Parameters

value
The page to locate in the collection.

Return Value

true if the System.Object is found in the System.Collections.IList; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Contains(Page) Method

[image]
ActiveReports 13
Contains(Page) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Contains Method : Contains(Page) Method

value
The page to locate in the collection.

Glossary Item Box

Determines whether a Page element is in the PagesCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal value As Page _
) As Boolean
C#
public bool Contains(
   Page value
)

Parameters

value
The page to locate in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : CopyTo Method

Glossary Item Box

Copies pages from the collection to an array, starting at a particular array index.

Overload List

Overload | Description
CopyTo(Array,Int32) | Copies pages from the collection to an array, starting at a particular array index.
CopyTo(Page[],Int32) | Copies an array of Page objects to PagesCollection from the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


CopyTo(Array,Int32) Method

[image]
ActiveReports 13
CopyTo(Array,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > CopyTo Method : CopyTo(Array,Int32) Method

array

The array that is the destination of the elements copied from the current pages collection.

index

A 32-bit integer that represents the index in pages collection at which copying begins.

Glossary Item Box

Copies pages from the collection to an array, starting at a particular array index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array

The array that is the destination of the elements copied from the current pages collection.

index

A 32-bit integer that represents the index in pages collection at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


CopyTo(Page[],Int32) Method

[image]
ActiveReports 13
CopyTo(Page[],Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > CopyTo Method : CopyTo(Page[],Int32) Method

values
The pages array that is the destination of the elements copied from the current pages collection.
index

A 32-bit integer that represents the index in pages collection at which copying begins.

Glossary Item Box

Copies an array of Page objects to PagesCollection from the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal values() As Page, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Page[] values,
   int index
)

Parameters

values
The pages array that is the destination of the elements copied from the current pages collection.
index

A 32-bit integer that represents the index in pages collection at which copying begins.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


GetRange Method

[image]
ActiveReports 13
GetRange Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : GetRange Method

index
Specifies the starting page index of the range.
count
The number of pages to be returned.

Glossary Item Box

Returns a new collection of the specified number of pages starting with the specified index

Syntax

Visual Basic (Declaration)
Public Function GetRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
) As PagesCollection
C#
public PagesCollection GetRange(
   int index,
   int count
)

Parameters

index
Specifies the starting page index of the range.
count
The number of pages to be returned.

Return Value

A collection of pages from the collection starting at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IndexOf Method

Glossary Item Box

Returns the index of a page in the collection.

Overload List

Overload | Description
IndexOf(Object) | Returns the index of a page object in the collection.
IndexOf(Page) | Returns the zero-based index of the first occurrence of the Page object in the PagesCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


IndexOf(Object) Method

[image]
ActiveReports 13
IndexOf(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > IndexOf Method : IndexOf(Object) Method

value
The page to locate in the collection.

Glossary Item Box

Returns the index of a page object in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public int IndexOf(
   object value
)

Parameters

value
The page to locate in the collection.

Return Value

The index of value if found in the list; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


IndexOf(Page) Method

[image]
ActiveReports 13
IndexOf(Page) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > IndexOf Method : IndexOf(Page) Method

value
The page to locate in the collection.

Glossary Item Box

Returns the zero-based index of the first occurrence of the Page object in the PagesCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As Page _
) As Integer
C#
public int IndexOf(
   Page value
)

Parameters

value
The page to locate in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Insert Method

[image]
ActiveReports 13
Insert Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Insert Method

Glossary Item Box

Inserts the specified page into the collection at the specified index.

Overload List

Overload | Description
Insert(Int32,Object) | Inserts a Page object element into the PagesCollection at the specified index.
Insert(Int32,Page) | Inserts a Page element into the PagesCollection at the specified index.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    rptInsertPage rpt = new rptInsertPage();
    rptCoverPage rpt2 = new rptCoverPage();
    viewer1.Document = rpt.Document;
    rpt.Run();
    rpt2.Run();
    rpt.Document.Pages.Insert(0, rpt2.Document.Pages[0]);
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptInsertPage()
    Viewer1.Document = rpt.Document    rpt.Run()
    Dim rpt2 As New rptCoverPage()
    rpt2.Run()
    rpt.Document.Pages.Insert(0, rpt2.Document.Pages(0))
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


Insert(Int32,Object) Method

[image]
ActiveReports 13
Insert(Int32,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Insert Method : Insert(Int32,Object) Method

index
The zero based index at which value should be inserted.
value
The page to insert.

Glossary Item Box

Inserts a Page object element into the PagesCollection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public void Insert(
   int index,
   object value
)

Parameters

index
The zero based index at which value should be inserted.
value
The page to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Insert(Int32,Page) Method

[image]
ActiveReports 13
Insert(Int32,Page) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Insert Method : Insert(Int32,Page) Method

index
The zero based index at which value should be inserted.
value
The page to insert.

Glossary Item Box

Inserts a Page element into the PagesCollection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Page _
)
C#
public void Insert(
   int index,
   Page value
)

Parameters

index
The zero based index at which value should be inserted.
value
The page to insert.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


InsertNew Method

[image]
ActiveReports 13
InsertNew Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : InsertNew Method

index
Index of the new page.

Glossary Item Box

Creates a new Page object and inserts it into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Function InsertNew( _
   ByVal index As Integer _
) As Page
C#
public Page InsertNew(
   int index
)

Parameters

index
Index of the new page.

Example

C# Copy Code
Private void Form1_Load(object sender, System.EventArgs e)
{
    rptInsertPage rpt = New rptInsertPage();
    viewer1.Document = rpt.Document;
    rpt.Run();
    rpt.Document.Pages.InsertNew(3);
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptInsertPage()
    Viewer1.Document = rpt.Document    rpt.Run()
    rpt.Document.Pages.InsertNew(3)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


InsertRange Method

[image]
ActiveReports 13
InsertRange Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : InsertRange Method

Glossary Item Box

Inserts a range of pages into the collection at a specified position.

Overload List

Overload | Description
InsertRange(Int32,PagesCollection) | Inserts the members of the specified PagesCollection into the collection at the specified index.
InsertRange(Int32,Page[]) | Inserts an array of Page objects into the collection at the specified index.

Example

C# Copy Code
private void button1_Click(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.ActiveReport merge = new GrapeCity.ActiveReports.SectionReport();
    GrapeCity.ActiveReports.Document.Document fRdf = new GrapeCity.ActiveReports.Document.SectionDocument();
    fRdf.Load(@"C:\a.rdf");
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages);
    fRdf.Load(@"C:\b.rdf");
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages);
    arv.Document = merge.Document;
}
Visual Basic Copy Code
Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim merge As New GrapeCity.ActiveReports.SectionReport
    Dim fRdf As New GrapeCity.ActiveReports.Document.SectionDocument
    fRdf.Load("C:\a.rdf")
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages)
    fRdf.Load("C:\b.rdf")
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages)
    Me.arv.Document = merge.Document
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


InsertRange(Int32,PagesCollection) Method

[image]
ActiveReports 13
InsertRange(Int32,PagesCollection) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > InsertRange Method : InsertRange(Int32,PagesCollection) Method

index
A zero-based index in the collection where the pages collection will be inserted.
pages
The pages array whose elements should be inserted into the current pages collection.

Glossary Item Box

Inserts the members of the specified PagesCollection into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertRange( _
   ByVal index As Integer, _
   ByVal pages As PagesCollection _
)
C#
public void InsertRange(
   int index,
   PagesCollection pages
)

Parameters

index
A zero-based index in the collection where the pages collection will be inserted.
pages
The pages array whose elements should be inserted into the current pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


InsertRange(Int32,Page[]) Method

[image]
ActiveReports 13
InsertRange(Int32,Page[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > InsertRange Method : InsertRange(Int32,Page[]) Method

index
A zero-based index in the collection where the pages array will be inserted.
pages
The pages array whose elements should be inserted into the current pages collection.

Glossary Item Box

Inserts an array of Page objects into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InsertRange( _
   ByVal index As Integer, _
   ByVal pages() As Page _
)
C#
public void InsertRange(
   int index,
   Page[] pages
)

Parameters

index
A zero-based index in the collection where the pages array will be inserted.
pages
The pages array whose elements should be inserted into the current pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Remove Method

[image]
ActiveReports 13
Remove Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Remove Method

Glossary Item Box

Removes the specified page object from the collection.

Overload List

Overload | Description
Remove(Object) | Removes the specified page object from the collection.
Remove(Page) | Removes the first occurrence of Page object from the PagesCollection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


Remove(Object) Method

[image]
ActiveReports 13
Remove(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Remove Method : Remove(Object) Method

value
The page to remove from the collection.

Glossary Item Box

Removes the specified page object from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal value As Object _
)
C#
public void Remove(
   object value
)

Parameters

value
The page to remove from the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Remove(Page) Method

[image]
ActiveReports 13
Remove(Page) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Remove Method : Remove(Page) Method

page
The page to remove from the current pages collection.

Glossary Item Box

Removes the first occurrence of Page object from the PagesCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal page As Page _
)
C#
public void Remove(
   Page page
)

Parameters

page
The page to remove from the current pages collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : RemoveAt Method

index

A zero-based index of the page to be removed.

Glossary Item Box

Removes the page at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

A zero-based index of the page to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


PagesCollection Class Properties

[image]
ActiveReports 13
PagesCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

Glossary Item Box

For a list of all members of this type, see PagesCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of Page members in the collection.
Public Property | Fonts | Returns the FontsCollection that is used in the PagesCollection.
Public Property | IsFixedSize | Gets a value indicating whether the PagesCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the PagesCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the PagesCollection is synchronized (thread safe). (Inherited from ICollection.)
Public Property | Item | Returns the member at the specified index in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the PagesCollection.
Top

See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Count Property

Glossary Item Box

Returns the number of Page members in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

Integer value that represents the number of pages in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


Fonts Property

[image]
ActiveReports 13
Fonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Fonts Property

Glossary Item Box

Returns the FontsCollection that is used in the PagesCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fonts As FontsCollection
C#
public FontsCollection Fonts {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


IsFixedSize Property

[image]
ActiveReports 13
IsFixedSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IsFixedSize Property

Glossary Item Box

Gets a value indicating whether the PagesCollection has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
C#
public bool IsFixedSize {get;}

Property Value

true if this instance is fixed size; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


IsReadOnly Property

[image]
ActiveReports 13
IsReadOnly Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IsReadOnly Property

Glossary Item Box

Gets a value indicating whether the PagesCollection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true if this instance is read only; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


IsSynchronized Property

[image]
ActiveReports 13
IsSynchronized Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the PagesCollection is synchronized (thread safe). (Inherited from ICollection.)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized {get;}

Property Value

true if this instance is synchronized; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Item Property

index
Index of the member to be returned.

Glossary Item Box

Returns the member at the specified index in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Page
C#
public Page this[
   int index
]; {get;}

Parameters

index
Index of the member to be returned.

Property Value

Page object at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


SyncRoot Property

[image]
ActiveReports 13
SyncRoot Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the PagesCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Property Value

The synchronize root.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PagesCollection Class
PagesCollection Members


SetScaleX Class

[image]
ActiveReports 13
SetScaleX Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetScaleX Class

Glossary Item Box

SetMinCondenseRate canvas item

Object Model

SetScaleX Class

Syntax

Visual Basic (Declaration)
Public Class SetScaleX
   Inherits CanvasItem
C#
public class SetScaleX : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.SetScaleX

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetScaleX Members
GrapeCity.ActiveReports.Document.Section Namespace


SetScaleX Class Members

[image]
ActiveReports 13
SetScaleX Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetScaleX Class

Glossary Item Box

The following tables list the members exposed by SetScaleX.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this instance.
static (Shared in Visual Basic) | CreateRead | Creates SetMinCondenseRate and reads it from specified reader.
Public Method | ToString | Overridden. Returns a System.String that represents this instance.
Top

See Also

Reference

SetScaleX Class
GrapeCity.ActiveReports.Document.Section Namespace


SetScaleX Class Methods

[image]
ActiveReports 13
SetScaleX Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SetScaleX Class

Glossary Item Box

For a list of all members of this type, see SetScaleX members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this instance.
static (Shared in Visual Basic) | CreateRead | Creates SetMinCondenseRate and reads it from specified reader.
Public Method | ToString | Overridden. Returns a System.String that represents this instance.
Top

See Also

Reference

SetScaleX Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 13
Clone Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SetScaleX Class : Clone Method

Glossary Item Box

Clones this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As CanvasItem
C#
public override CanvasItem Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetScaleX Class
SetScaleX Members


CreateRead Method

[image]
ActiveReports 13
CreateRead Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SetScaleX Class : CreateRead Method

reader
The reader.
fileVersion
The file version.

Glossary Item Box

Creates SetMinCondenseRate and reads it from specified reader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As SetScaleX
C#
public static SetScaleX CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
The reader.
fileVersion
The file version.

Return Value

SetMinCondenseRate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetScaleX Class
SetScaleX Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > SetScaleX Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SetScaleX Class
SetScaleX Members


TextBoundsRange Class

[image]
ActiveReports 13
TextBoundsRange Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextBoundsRange Class

Glossary Item Box

Text bounds range canvas item

Object Model

TextBoundsRange Class

Syntax

Visual Basic (Declaration)
Public Class TextBoundsRange
   Inherits CanvasItem
C#
public class TextBoundsRange : CanvasItem

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.TextBoundsRange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoundsRange Members
GrapeCity.ActiveReports.Document.Section Namespace


TextBoundsRange Class Members

[image]
ActiveReports 13
TextBoundsRange Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextBoundsRange Class

Glossary Item Box

The following tables list the members exposed by TextBoundsRange.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this instance.
static (Shared in Visual Basic) | CreateRead | Creates SetMinCondenseRate and reads it from specified reader.
Public Method | ToString | Overridden. Returns a System.String that represents this instance.
Top

See Also

Reference

TextBoundsRange Class
GrapeCity.ActiveReports.Document.Section Namespace


TextBoundsRange Class Methods

[image]
ActiveReports 13
TextBoundsRange Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextBoundsRange Class

Glossary Item Box

For a list of all members of this type, see TextBoundsRange members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this instance.
static (Shared in Visual Basic) | CreateRead | Creates SetMinCondenseRate and reads it from specified reader.
Public Method | ToString | Overridden. Returns a System.String that represents this instance.
Top

See Also

Reference

TextBoundsRange Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method

[image]
ActiveReports 13
Clone Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextBoundsRange Class : Clone Method

Glossary Item Box

Clones this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As CanvasItem
C#
public override CanvasItem Clone()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoundsRange Class
TextBoundsRange Members


CreateRead Method

[image]
ActiveReports 13
CreateRead Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextBoundsRange Class : CreateRead Method

reader
The reader.
fileVersion
The file version.

Glossary Item Box

Creates SetMinCondenseRate and reads it from specified reader.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRead( _
   ByVal reader As BinaryReader, _
   ByVal fileVersion As Short _
) As TextBoundsRange
C#
public static TextBoundsRange CreateRead(
   BinaryReader reader,
   short fileVersion
)

Parameters

reader
The reader.
fileVersion
The file version.

Return Value

SetMinCondenseRate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoundsRange Class
TextBoundsRange Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > TextBoundsRange Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextBoundsRange Class
TextBoundsRange Members


UrlErrorEventArgs Class

[image]
ActiveReports 13
UrlErrorEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

Glossary Item Box

Specifies the arguments of a downloadError event.

Object Model

UrlErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UrlErrorEventArgs
   Inherits System.EventArgs
C#
public class UrlErrorEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Document.Section.UrlErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Members
GrapeCity.ActiveReports.Document.Section Namespace


UrlErrorEventArgs Class Members

[image]
ActiveReports 13
UrlErrorEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by UrlErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | UrlErrorEventArgs Constructor | Overloaded. Creates a new instance of the UrlErrorEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Exception | Gets or sets a value that specifies the exception that caused the download error.
Top

See Also

Reference

UrlErrorEventArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


UrlErrorEventArgs Constructor

[image]
ActiveReports 13
UrlErrorEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class : UrlErrorEventArgs Constructor

Glossary Item Box

Creates a new instance of the UrlErrorEventArgs class.

Overload List

Overload | Description
UrlErrorEventArgs Constructor() | Creates a new instance of the UrlErrorEventArgs class.
UrlErrorEventArgs Constructor(Exception) | Initializes a new instance of the UrlErrorEventArgs class with the exception thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members


UrlErrorEventArgs Constructor()

[image]
ActiveReports 13
UrlErrorEventArgs Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class > UrlErrorEventArgs Constructor : UrlErrorEventArgs Constructor()

Glossary Item Box

Creates a new instance of the UrlErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public UrlErrorEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members
Overload List


UrlErrorEventArgs Constructor(Exception)

[image]
ActiveReports 13
UrlErrorEventArgs Constructor(Exception)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class > UrlErrorEventArgs Constructor : UrlErrorEventArgs Constructor(Exception)

e
A value that represents the exception.

Glossary Item Box

Initializes a new instance of the UrlErrorEventArgs class with the exception thrown.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal e As Exception _
)
C#
public UrlErrorEventArgs(
   Exception e
)

Parameters

e
A value that represents the exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members
Overload List


UrlErrorEventArgs Class Properties

[image]
ActiveReports 13
UrlErrorEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see UrlErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception | Gets or sets a value that specifies the exception that caused the download error.
Top

See Also

Reference

UrlErrorEventArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


Exception Property

[image]
ActiveReports 13
Exception Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class : Exception Property

Glossary Item Box

Gets or sets a value that specifies the exception that caused the download error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception {get;}

Property Value

The exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members


UserPreferences Class

[image]
ActiveReports 13
UserPreferences Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

Glossary Item Box

Specifies the look of hyperlinks and the controls that host them in the Viewer control.

Object Model

UserPreferences Class

Syntax

Visual Basic (Declaration)
Public Class UserPreferences
C#
public class UserPreferences

Example

C# Copy Code
private void myForm_Load(object sender, System.EventArgs e)
{
    rptKewl rpt = new rptKewl();
    rpt.Run();
    this.arViewer.Document = rpt.Document;

    this.arViewer.ReportViewer.HyperLinkBackColor = Color.Transparent;
    this.arViewer.ReportViewer.HyperLinkForeColor = Color.Aquamarine;
    this.arViewer.ReportViewer.HyperLinkUnderline = false;
    this.arViewer.ReportViewer.SearchResultsBackColor = Color.AliceBlue;
    this.arViewer.ReportViewer.SearchResultsForeColor = Color.Coral;
}
Visual Basic Copy Code
Private Sub myForm_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptKewl
    rpt.Run
    Me.arViewer.Document = rpt.Document

    Me.arViewer.ReportViewer.HyperLinkBackColor = Color.Transparent;
    Me.arViewer.ReportViewer.HyperLinkForeColor = Color.Aquamarine;
    Me.arViewer.ReportViewer.HyperLinkUnderline = False;
    Me.arViewer.ReportViewer.SearchResultsBackColor = Color.AliceBlue;
    Me.arViewer.ReportViewer.SearchResultsForeColor = Color.Coral;
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.UserPreferences

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Members
GrapeCity.ActiveReports.Document.Section Namespace


UserPreferences Class Members

[image]
ActiveReports 13
UserPreferences Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

Glossary Item Box

The following tables list the members exposed by UserPreferences.

Public Constructors

 | Name | Description
Public Constructor | UserPreferences Constructor | Initializes a new instance of the UserPreference class.
Top

Public Properties

 | Name | Description
Public Property | HyperLinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent.
Public Property | HyperLinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue.
Public Property | HyperLinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find dialog.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find dialog.
Public Property | UseHyperLinkSettings | If True, these settings will be applied to links. Otherwise, each link will be displayed according to their own settings.
Top

See Also

Reference

UserPreferences Class
GrapeCity.ActiveReports.Document.Section Namespace


UserPreferences Constructor

[image]
ActiveReports 13
UserPreferences Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : UserPreferences Constructor

Glossary Item Box

Initializes a new instance of the UserPreference class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public UserPreferences()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


UserPreferences Class Properties

[image]
ActiveReports 13
UserPreferences Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

Glossary Item Box

For a list of all members of this type, see UserPreferences members.

Public Properties

 | Name | Description
Public Property | HyperLinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent.
Public Property | HyperLinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue.
Public Property | HyperLinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find dialog.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find dialog.
Public Property | UseHyperLinkSettings | If True, these settings will be applied to links. Otherwise, each link will be displayed according to their own settings.
Top

See Also

Reference

UserPreferences Class
GrapeCity.ActiveReports.Document.Section Namespace


HyperLinkBackColor Property

[image]
ActiveReports 13
HyperLinkBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkBackColor Property

Glossary Item Box

Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent.

Syntax

Visual Basic (Declaration)
Public Property HyperLinkBackColor As Color
C#
public Color HyperLinkBackColor {get; set;}

Property Value

The color of the hyper link back.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


HyperLinkForeColor Property

[image]
ActiveReports 13
HyperLinkForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkForeColor Property

Glossary Item Box

Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue.

Syntax

Visual Basic (Declaration)
Public Property HyperLinkForeColor As Color
C#
public Color HyperLinkForeColor {get; set;}

Property Value

The color of the hyper link fore.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


HyperLinkUnderline Property

[image]
ActiveReports 13
HyperLinkUnderline Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkUnderline Property

Glossary Item Box

Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.

Syntax

Visual Basic (Declaration)
Public Property HyperLinkUnderline As Boolean
C#
public bool HyperLinkUnderline {get; set;}

Property Value

true if [hyper link underline]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


SearchResultsBackColor Property

[image]
ActiveReports 13
SearchResultsBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : SearchResultsBackColor Property

Glossary Item Box

Gets or sets the background color of the highlighted text when using the Viewer control's Find dialog.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsBackColor As Color
C#
public Color SearchResultsBackColor {get; set;}

Property Value

The color of the search results back.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


SearchResultsForeColor Property

[image]
ActiveReports 13
SearchResultsForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : SearchResultsForeColor Property

Glossary Item Box

Gets or sets the color of the highlighted text when using the Viewer control's Find dialog.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsForeColor As Color
C#
public Color SearchResultsForeColor {get; set;}

Property Value

The color of the search results fore.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


UseHyperLinkSettings Property

[image]
ActiveReports 13
UseHyperLinkSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : UseHyperLinkSettings Property

Glossary Item Box

If True, these settings will be applied to links. Otherwise, each link will be displayed according to their own settings.

Syntax

Visual Basic (Declaration)
Public Property UseHyperLinkSettings As Boolean
C#
public bool UseHyperLinkSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserPreferences Class
UserPreferences Members


BackgroundStyle Enumeration

[image]
ActiveReports 13
BackgroundStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackgroundStyle Enumeration

Glossary Item Box

Specifies the background style when using the low level page drawing APIs.

Syntax

Visual Basic (Declaration)
Public Enum BackgroundStyle
   Inherits System.Enum
C#
public enum BackgroundStyle : System.Enum

Members

Member | Description
Opaque | Filled background, objects in the background will not show through.
Transparent | Background is transparent, objects in the background will show through.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.BackgroundStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


PageOrientation Enumeration

[image]
ActiveReports 13
PageOrientation Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageOrientation Enumeration

Glossary Item Box

Specifies the orientation of a page when rendered to the printer.

Syntax

Visual Basic (Declaration)
Public Enum PageOrientation
   Inherits System.Enum
C#
public enum PageOrientation : System.Enum

Members

Member | Description
Default | Follow printer default setting.
Landscape | Print pages in landscape.
Portrait | Print pages in portrait.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.PageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Page.Orientation Property


PenStyles Enumeration

[image]
ActiveReports 13
PenStyles Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenStyles Enumeration

Glossary Item Box

Specifies the pen style used to draw lines on a page.

Syntax

Visual Basic (Declaration)
Public Enum PenStyles
   Inherits System.Enum
C#
public enum PenStyles : System.Enum

Members

Member | Description
Dash | Dashed line.
DashDot | Dash dot line.
DashDotDot | Dash dot dot line.
Dot | Dotted line.
Solid | Solid line.
Transparent | No line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.PenStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


RdfFormat Enumeration

[image]
ActiveReports 13
RdfFormat Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RdfFormat Enumeration

Glossary Item Box

Specifies the file format used to save the report document.

Syntax

Visual Basic (Declaration)
Public Enum RdfFormat
   Inherits System.Enum
C#
public enum RdfFormat : System.Enum

Members

Member | Description
AR20 | ActiveReports 2.0 file format.
ARNet | ActiveReports for .NET 2.0 file format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.RdfFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Document.Save Method


SaveOptions Enumeration

[image]
ActiveReports 13
SaveOptions Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SaveOptions Enumeration

Glossary Item Box

Specifies the compression type used to save the report document.

Syntax

Visual Basic (Declaration)
Public Enum SaveOptions
   Inherits System.Enum
C#
public enum SaveOptions : System.Enum

Members

Member | Description
Compressed | Saves the RDF as a compressed file.
Normal | Saves the RDF as an uncompressed file.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.SaveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Document.Save Method


Units Enumeration

[image]
ActiveReports 13
Units Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Units Enumeration

Glossary Item Box

Specifies the document measurement units when using low level drawing API on a document page.

Syntax

Visual Basic (Declaration)
Public Enum Units
   Inherits System.Enum
C#
public enum Units : System.Enum

Members

Member | Description
Centimeters | Page drawing method parameters are specified in centimeters.
Document | Page drawing method parameters are specified in document units.
Inches | Page drawing method parameters are specified in inches.
Pixels | Page drawing method parameters are specified in pixels.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Units

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Units Property


UrlErrorEventHandler Delegate

[image]
ActiveReports 13
UrlErrorEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventHandler Delegate

sender

Source of the event.

e
UrlErrorEventArgs value that contains the event data.

Glossary Item Box

Represents the method that will handle the downloadError event of a Document.

Syntax

Visual Basic (Declaration)
Public Delegate Sub UrlErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As UrlErrorEventArgs _
)
C#
public delegate void UrlErrorEventHandler(
   object sender,
   UrlErrorEventArgs e
)

Parameters

sender

Source of the event.

e
UrlErrorEventArgs value that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UrlErrorEventHandler Members
GrapeCity.ActiveReports.Document.Section Namespace


GrapeCity.ActiveReports.Document.Section.Adapter Namespace

GrapeCity.ActiveReports.Document.Section.Adapter Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Section.Adapter Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


GrapeCity.ActiveReports.Document.Section.Annotations Namespace

GrapeCity.ActiveReports.Document.Section.Annotations Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Section.Annotations Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Document.Section.Annotations namespace contains the Annotations classes and its settings.

Classes

 | Class | Description
Class | Annotation | Annotation is the base class for Annotation objects.
Class | AnnotationArrow | Represents the AnnotationArrow object.
Class | AnnotationBalloon | Represents the AnnotationBalloon object.
Class | AnnotationBaseText | Represents the base class for all of the Annotation objects.
Class | AnnotationCircle | Represents a circular Annotation object.
Class | AnnotationCollection | Represents a collection of Annotation objects.
Class | AnnotationImage | Represents the AnnotationImage object.
Class | AnnotationLine | Represents the AnnotationLine object.
Class | AnnotationRectangle | Represents the rectangular Annotation object.
Class | AnnotationText | Represents the characteristics of the text of the Annotation object.
Class | BorderCircle | Draws a border around an AnnotationCircle.
Class | BorderRectangle | Draws a border around an AnnotationRectangle.

Enumerations

 | Enumeration | Description
Enumeration | AnnotationBalloon.BallonQuadrant | Specifies the location of the balloon tail relative to the AnnotationBalloon object.
Enumeration | AnnotationLine.LinePlacement | Specifies the location relative to the Annotation object in which the line will be drawn.
Enumeration | AnnotationLine.ShowArrowCap | Specifies the location of the arrow cap on the AnnotationLine.
Enumeration | ArrowDirection | Specifies the direction in which the arrow points.
Enumeration | ImageLayout | Specifies the positioning for Annotation Images.

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


Annotation Class

[image]
ActiveReports 13
Annotation Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

Annotation is the base class for Annotation objects.

Object Model

Annotation Class

Syntax

Visual Basic (Declaration)
Public Class Annotation
   Inherits System.ComponentModel.Component
C#
public class Annotation : System.ComponentModel.Component

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
Visual Basic Copy Code
Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   'Run the report first
   rpt.Run()

   'Assign the viewer
   Me.Viewer1.Document = rpt.Document

   'Create an annotation and assign property values
   Dim circle As New AnnotationCircle
   circle.Color = System.Drawing.Color.GreenYellow
   circle.Border.Color = System.Drawing.Color.Chartreuse

   'Add the annotation
   circle.Attach(1,1) 'screen location
   Me.Viewer1.Document.Pages(0).Annotations.Add(circle)

   'Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25
   circle.Width = 0.50

   'Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf")
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Annotation Class Members

[image]
ActiveReports 13
Annotation Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

The following tables list the members exposed by Annotation.

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object.
Public Property | Border | Gets the border for the annotation object.
Public Property | Color | Gets or sets the color that is used to fill the annotation object.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation.
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation.
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Annotation Class Methods

[image]
ActiveReports 13
Annotation Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

For a list of all members of this type, see Annotation members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Attach Method

[image]
ActiveReports 13
Attach Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Attach Method

x
The x coordinate for the annotation object.
y
The y coordinate for the annotation object.

Glossary Item Box

Sets the top left most coordinates for the annotation object.

Syntax

Visual Basic (Declaration)
Public Sub Attach( _
   ByVal x As Single, _
   ByVal y As Single _
)
C#
public void Attach(
   float x,
   float y
)

Parameters

x
The x coordinate for the annotation object.
y
The y coordinate for the annotation object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Refresh Method

Glossary Item Box

Refreshes the display of the annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Annotation Class Properties

[image]
ActiveReports 13
Annotation Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

For a list of all members of this type, see Annotation members.

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object.
Public Property | Border | Gets the border for the annotation object.
Public Property | Color | Gets or sets the color that is used to fill the annotation object.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation.
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation.
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Alpha Property

[image]
ActiveReports 13
Alpha Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Alpha Property

Glossary Item Box

Gets or sets the opacity of the Annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable Property Alpha As Integer
C#
public virtual int Alpha {get; set;}

Remarks

Acceptable values are 0 to 255.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;
   circle.Alpha = 150;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
Visual Basic Copy Code
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
'Run the report first
rpt.Run()

'Assign the viewer
Me.viewer1.Document = rpt.Document

'Create an annotation and assign property values
Dim circle As New AnnotationCircle()
circle.Color = System.Drawing.Color.GreenYellow
circle.Border.Color = System.Drawing.Color.Chartreuse
circle.Alpha = 150

'Add the annotation
circle.Attach(1, 1)
'screen location
Me.viewer1.Document.Pages(0).Annotations.Add(circle)

'Set the size properties. The annotation must be added to the page first.
circle.Height = 0.25F
circle.Width = 0.5F

'Save annotations to an RDF file
rpt.Document.Save("C:\MyAnnotations.rdf")

End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Border Property

[image]
ActiveReports 13
Border Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Border Property

Glossary Item Box

Gets the border for the annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Border As Border
C#
public virtual Border Border {get;}

Property Value

The Border property allows you to access the border object for the annotation object.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
Visual Basic Copy Code
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Color Property

[image]
ActiveReports 13
Color Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Color Property

Glossary Item Box

Gets or sets the color that is used to fill the annotation object.

Syntax

Visual Basic (Declaration)
Public Overridable Property Color As Color
C#
public virtual Color Color {get; set;}

Property Value

The color used to fill the annotation object.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
Visual Basic Copy Code
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Height Property

[image]
ActiveReports 13
Height Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Height Property

Glossary Item Box

Gets or sets the height of the annotation object, in inches.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Property Value

A float or single value in inches.

Remarks

You must add the annotation to the page before you can set the height of the annotation.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
Visual Basic Copy Code
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


PageRectangle Property

[image]
ActiveReports 13
PageRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : PageRectangle Property

Glossary Item Box

Gets or sets the rectangular area of the page on which the annotation is drawn.

Syntax

Visual Basic (Declaration)
Public Property PageRectangle As RectangleF
C#
public RectangleF PageRectangle {get; set;}

Property Value

A RectangleF.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Width Property

[image]
ActiveReports 13
Width Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Width Property

Glossary Item Box

Gets or sets the width of the annotation object, in inches.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Single
C#
public virtual float Width {get; set;}

Property Value

A float or single value in inches.

Remarks

You must add the annotation to the page before you can set the width of the annotation.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
Visual Basic Copy Code
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


X Property

[image]
ActiveReports 13
X Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : X Property

Glossary Item Box

Gets or sets the value in inches of the horizontal location of the annotation.

Syntax

Visual Basic (Declaration)
Public Property X As Single
C#
public float X {get; set;}

Property Value

A single or float value in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Y Property

[image]
ActiveReports 13
Y Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Y Property

Glossary Item Box

Gets or sets the value in inches of the vertical location of the annotation.

Syntax

Visual Basic (Declaration)
Public Property Y As Single
C#
public float Y {get; set;}

Property Value

A single or float value in inches.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


AnnotationArrow Class

[image]
ActiveReports 13
AnnotationArrow Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

Represents the AnnotationArrow object.

Object Model

AnnotationArrow Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationArrow
   Inherits AnnotationText
C#
public sealed class AnnotationArrow : AnnotationText

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations

private void AddAnnotations()
{
   rptAnno rpt = new rptAnno();
   rpt.Run();
   this.viewer1.Document = rpt.Document;

   AnnotationArrow arrow = new AnnotationArrow();
   arrow.ArrowDirection = ArrowDirection.Right;
   arrow.Text = "Look";
   arrow.TextColor = Color.Blue;
   arrow.Alpha = 255;
   arrow.Color = Color.Gray;

   arrow.Attach(2, 2);
   this.viewer1.Document.Pages[0].Annotations.Add(arrow);

   arrow.Height = 0.25f;
   arrow.Width = 1.50f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
   Dim rptAnno As New rptAnno()
   rpt.Run()
   Me.Viewer1.Document = rpt.Document

   Dim arrow As New AnnotationArrow
   arrow.ArrowDirection = ArrowDirection.Right
   arrow.Text = "Look"
   arrow.TextColor = Color.Blue
   arrow.Alpha = 255
   arrow.Color = Color.Gray

   arrow.Attach(2, 2)
   this.Viewer1.Document.Pages(0).Annotations.Add(arrow)

   arrow.Height = 0.25
   arrow.Width = 1.50
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Members

[image]
ActiveReports 13
AnnotationArrow Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

The following tables list the members exposed by AnnotationArrow.

Public Constructors

 | Name | Description
Public Constructor | AnnotationArrow Constructor | Initializes a new instance of the AnnotationArrow class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ArrowDirection | Gets or sets the direction of the AnnotationArrow object.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Constructor

[image]
ActiveReports 13
AnnotationArrow Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : AnnotationArrow Constructor

Glossary Item Box

Initializes a new instance of the AnnotationArrow class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationArrow()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationArrow Class Properties

[image]
ActiveReports 13
AnnotationArrow Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

For a list of all members of this type, see AnnotationArrow members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ArrowDirection | Gets or sets the direction of the AnnotationArrow object.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowDirection Property

[image]
ActiveReports 13
ArrowDirection Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : ArrowDirection Property

Glossary Item Box

Gets or sets the direction of the AnnotationArrow object.

Syntax

Visual Basic (Declaration)
Public Property ArrowDirection As ArrowDirection
C#
public ArrowDirection ArrowDirection {get; set;}

Property Value

The arrow direction.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationBalloon Class

[image]
ActiveReports 13
AnnotationBalloon Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

Represents the AnnotationBalloon object.

Object Model

AnnotationBalloon Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationBalloon
   Inherits AnnotationText
C#
public sealed class AnnotationBalloon : AnnotationText

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationBalloon ball = new AnnotationBalloon();
    ball.Color = Color.LightSalmon;
    ball.Alpha = 75;
    ball.Border.Color = Color.Red;
    ball.Text = "Needs Review";
    ball.TextColor = Color.Black;
    ball.LineAligment = System.Drawing.StringAlignment.Center;
    ball.Alignment = System.Drawing.StringAlignment.Center;
    ball.Quadrant = AnnotationBalloon.BallonQuadrant.BottomLeft;

    ball.Attach(3, 3);
    this.viewer1.Document.Pages[0].Annotations.Add(ball);

    ball.Height = 1;
    ball.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   rpt.Run()
   Me.Viewer1.Document = rpt.Document

   Dim ball As New AnnotationBalloon()
   ball.Color = Color.LightSalmon;
   ball.Alpha = 75;
   ball.Border.Color = Color.Red;
   ball.Text = "Needs Review";
   ball.TextColor = Color.Black;
   ball.LineAligment = System.Drawing.StringAlignment.Center;
   ball.Alignment = System.Drawing.StringAlignment.Center;
   ball.Quadrant = AnnotationBalloon.BallonQuadrant.BottomLeft;

   ball.Attach(4, 4)
   Me.Viewer1.Document.Pages(0).Annotations.Add(ball)

   ball.Height = 1
   ball.Width = 1.5
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Class Members

[image]
ActiveReports 13
AnnotationBalloon Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

The following tables list the members exposed by AnnotationBalloon.

Public Constructors

 | Name | Description
Public Constructor | AnnotationBalloon Constructor | Initializes a new instance of the AnnotationBalloon class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Quadrant | Gets or sets the quadrant for the tail of the AnnotationBalloon object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Constructor

[image]
ActiveReports 13
AnnotationBalloon Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : AnnotationBalloon Constructor

Glossary Item Box

Initializes a new instance of the AnnotationBalloon class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationBalloon()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBalloon Class Properties

[image]
ActiveReports 13
AnnotationBalloon Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

For a list of all members of this type, see AnnotationBalloon members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Quadrant | Gets or sets the quadrant for the tail of the AnnotationBalloon object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Quadrant Property

[image]
ActiveReports 13
Quadrant Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Quadrant Property

Glossary Item Box

Gets or sets the quadrant for the tail of the AnnotationBalloon object.

Syntax

Visual Basic (Declaration)
Public Property Quadrant As AnnotationBalloon.BallonQuadrant
C#
public AnnotationBalloon.BallonQuadrant Quadrant {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBaseText Class

[image]
ActiveReports 13
AnnotationBaseText Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

Represents the base class for all of the Annotation objects.

Object Model

AnnotationBaseText Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class AnnotationBaseText
   Inherits Annotation
C#
public abstract class AnnotationBaseText : Annotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Members

[image]
ActiveReports 13
AnnotationBaseText Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

The following tables list the members exposed by AnnotationBaseText.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation.
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation.
Public Property | TextColor | Gets or sets the color of text used in the annotation.
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Properties

[image]
ActiveReports 13
AnnotationBaseText Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

For a list of all members of this type, see AnnotationBaseText members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation.
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation.
Public Property | TextColor | Gets or sets the color of text used in the annotation.
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Alignment Property

Glossary Item Box

Gets or sets the text alignment for the annotation.

Syntax

Visual Basic (Declaration)
Public Property Alignment As StringAlignment
C#
public StringAlignment Alignment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Font Property

Glossary Item Box

Gets or sets the font for the annotation text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


LineAligment Property

[image]
ActiveReports 13
LineAligment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : LineAligment Property

Glossary Item Box

Gets or sets the alignment of annotation lines.

Syntax

Visual Basic (Declaration)
Public Property LineAligment As StringAlignment
C#
public StringAlignment LineAligment {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Text Property

Glossary Item Box

Gets or sets the text to use in the annotation.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


TextColor Property

[image]
ActiveReports 13
TextColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : TextColor Property

Glossary Item Box

Gets or sets the color of text used in the annotation.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
C#
public Color TextColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


AnnotationCircle Class

[image]
ActiveReports 13
AnnotationCircle Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

Represents a circular Annotation object.

Object Model

AnnotationCircle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationCircle
   Inherits Annotation
C#
public sealed class AnnotationCircle : Annotation

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
Visual Basic Copy Code
Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   'Run the report first
   rpt.Run()

   'Assign the viewer
   Me.Viewer1.Document = rpt.Document

   'Create an annotation and assign property values
   Dim circle As New AnnotationCircle
   circle.Color = System.Drawing.Color.GreenYellow
   circle.Border.Color = System.Drawing.Color.Chartreuse

   'Add the annotation
   circle.Attach(1,1) 'screen location
   Me.Viewer1.Document.Pages(0).Annotations.Add(circle)

   'Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25
   circle.Width = 0.50

   'Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf")
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Members

[image]
ActiveReports 13
AnnotationCircle Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

The following tables list the members exposed by AnnotationCircle.

Public Constructors

 | Name | Description
Public Constructor | AnnotationCircle Constructor | Initializes a new instance of the AnnotationCircle class.
Top

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Constructor

[image]
ActiveReports 13
AnnotationCircle Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : AnnotationCircle Constructor

Glossary Item Box

Initializes a new instance of the AnnotationCircle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationCircle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


AnnotationCollection Class

[image]
ActiveReports 13
AnnotationCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

Represents a collection of Annotation objects.

Object Model

AnnotationCollection Class

Syntax

Visual Basic (Declaration)
Public Class AnnotationCollection
   Inherits System.Collections.CollectionBase
C#
public class AnnotationCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCollection Class Members

[image]
ActiveReports 13
AnnotationCollection Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

The following tables list the members exposed by AnnotationCollection.

Public Constructors

 | Name | Description
Public Constructor | AnnotationCollection Constructor | Initializes a new instance of the AnnotationCollection class.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the fill color.
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the annotation item in the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an annotation to the end of the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Refresh | Forces an annotation to refresh its display.
Public Method | Remove | Removes an annotation from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCollection Constructor

[image]
ActiveReports 13
AnnotationCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : AnnotationCollection Constructor

Glossary Item Box

Initializes a new instance of the AnnotationCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Class Methods

[image]
ActiveReports 13
AnnotationCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an annotation to the end of the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Refresh | Forces an annotation to refresh its display.
Public Method | Remove | Removes an annotation from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Add Method

annotation
The annotation object to be added.

Glossary Item Box

Adds an annotation to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal annotation As Annotation _
)
C#
public void Add(
   Annotation annotation
)

Parameters

annotation
The annotation object to be added.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Refresh Method

annotation
The annotation object to be refreshed.

Glossary Item Box

Forces an annotation to refresh its display.

Syntax

Visual Basic (Declaration)
Public Sub Refresh( _
   ByVal annotation As Annotation _
)
C#
public void Refresh(
   Annotation annotation
)

Parameters

annotation
The annotation object to be refreshed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Remove Method

annotation
The annotation object to be removed.

Glossary Item Box

Removes an annotation from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal annotation As Annotation _
)
C#
public void Remove(
   Annotation annotation
)

Parameters

annotation
The annotation object to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Class Properties

[image]
ActiveReports 13
AnnotationCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

Glossary Item Box

For a list of all members of this type, see AnnotationCollection members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the fill color.
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the annotation item in the collection.
Top

See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : BackColor Property

Glossary Item Box

Gets or sets the fill color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

The color of the back.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Item Property

index
The location of the item.

Glossary Item Box

Gets the annotation item in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Annotation
C#
public Annotation this[
   int index
]; {get;}

Parameters

index
The location of the item.

Property Value

Returns the element at the specified index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationImage Class

[image]
ActiveReports 13
AnnotationImage Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

Represents the AnnotationImage object.

Object Model

AnnotationImage Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationImage
   Inherits AnnotationText
C#
public sealed class AnnotationImage : AnnotationText

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Class Members

[image]
ActiveReports 13
AnnotationImage Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

The following tables list the members exposed by AnnotationImage.

Public Constructors

 | Name | Description
Public Constructor | AnnotationImage Constructor | Initializes a new instance of the AnnotationImage class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | BackgroundImage | Gets or sets the System.Drawing.Image to use as the annotation image.
Public Property | BackgroundLayout | Gets or sets the enumerated value that determines the positioning of the image within the annotation box.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowBorder | Gets or sets a value indicating whether to draw a border around the edge of the annotation box.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Constructor

[image]
ActiveReports 13
AnnotationImage Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : AnnotationImage Constructor

Glossary Item Box

Initializes a new instance of the AnnotationImage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationImage()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationImage Class Properties

[image]
ActiveReports 13
AnnotationImage Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

For a list of all members of this type, see AnnotationImage members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | BackgroundImage | Gets or sets the System.Drawing.Image to use as the annotation image.
Public Property | BackgroundLayout | Gets or sets the enumerated value that determines the positioning of the image within the annotation box.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowBorder | Gets or sets a value indicating whether to draw a border around the edge of the annotation box.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : BackgroundImage Property

Glossary Item Box

Gets or sets the System.Drawing.Image to use as the annotation image.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImage As Image
C#
public Image BackgroundImage {get; set;}

Property Value

A System.Drawing.Image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


BackgroundLayout Property

[image]
ActiveReports 13
BackgroundLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : BackgroundLayout Property

Glossary Item Box

Gets or sets the enumerated value that determines the positioning of the image within the annotation box.

Syntax

Visual Basic (Declaration)
Public Property BackgroundLayout As ImageLayout
C#
public ImageLayout BackgroundLayout {get; set;}

Property Value

The background layout.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


ShowBorder Property

[image]
ActiveReports 13
ShowBorder Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : ShowBorder Property

Glossary Item Box

Gets or sets a value indicating whether to draw a border around the edge of the annotation box.

Syntax

Visual Basic (Declaration)
Public Property ShowBorder As Boolean
C#
public bool ShowBorder {get; set;}

Property Value

true if [show border]; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationLine Class

[image]
ActiveReports 13
AnnotationLine Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

Represents the AnnotationLine object.

Object Model

AnnotationLine Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationLine
   Inherits Annotation
C#
public sealed class AnnotationLine : Annotation

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   rpt.Run()
   Me.Viewer1.Document = rpt.Document

   Dim line As New AnnotationLine()
   line.ArrowCapWidth = 4.5
   line.ArrowCapHeight = 4.5
   line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
   line.DashCap = System.Drawing.Drawing2D.DashCap.Round
   line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
   line.FillArrowCaps = True
   line.LineColor = Color.Red
   line.LineWidth = 1
   line.LineLocation = AnnotationLine.LinePlacement.Bottom
   line.Text = "Please review."
   line.TextColor = Color.Blue
   line.TextAlignment = System.Drawing.StringAlignment.Center

   line.Attach(4, 4)
   Me.Viewer1.Document.Pages(0).Annotations.Add(line)

   line.Height = 0.50
   line.Width = 1.5
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Class Members

[image]
ActiveReports 13
AnnotationLine Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

The following tables list the members exposed by AnnotationLine.

Public Constructors

 | Name | Description
Public Constructor | AnnotationLine Constructor | Initializes a new instance of the AnnotationLine class.
Top

Public Properties

 | Name | Description
Public Property | ArrowCapHeight | Gets or sets the height of the arrow cap of the AnnotationLine, in pixels.
Public Property | ArrowCapWidth | Gets or sets the arrow cap width of the AnnotationLine, in pixels.
Public Property | Color | Overridden. Gets the color of the AnnotationLine.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DashCap | Gets or sets the graphic shape to be used on both ends of each dash of the AnnotationLine.
Public Property | DashStyle | Gets or sets the dash style of the AnnotationLine.
Public Property | FillArrowCaps | Determines whether the arrows caps of the AnnotationLine object will be filled.
Public Property | Font | Gets or sets the font for the text of the AnnotationLine object.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineColor | Gets or sets the color of the AnnotationLine object.
Public Property | LineLocation | Gets or sets the location of the AnnotationLine within the Annotation object. The three possible values are Top, Middle, and Bottom.
Public Property | LineWidth | Gets or sets the width of the AnnotationLine line object, in pixels.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowArrowCaps | Gets or sets the location on the AnnotationLine that displays arrow caps.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation.
Public Property | TextAlignment | Gets or sets the horizontal alignment of the text string relative to the bounds of the AnnotationLine object.
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation.
Public Property | TextWidth | Gets or sets the amount of width, in inches, allocated to the text within the AnnotationLine object.
Public Property | Width | Overridden. Gets or sets the width of the AnnotationLine object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Constructor

[image]
ActiveReports 13
AnnotationLine Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : AnnotationLine Constructor

Glossary Item Box

Initializes a new instance of the AnnotationLine class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationLine()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationLine Class Properties

[image]
ActiveReports 13
AnnotationLine Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

Public Properties

 | Name | Description
Public Property | ArrowCapHeight | Gets or sets the height of the arrow cap of the AnnotationLine, in pixels.
Public Property | ArrowCapWidth | Gets or sets the arrow cap width of the AnnotationLine, in pixels.
Public Property | Color | Overridden. Gets the color of the AnnotationLine.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DashCap | Gets or sets the graphic shape to be used on both ends of each dash of the AnnotationLine.
Public Property | DashStyle | Gets or sets the dash style of the AnnotationLine.
Public Property | FillArrowCaps | Determines whether the arrows caps of the AnnotationLine object will be filled.
Public Property | Font | Gets or sets the font for the text of the AnnotationLine object.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineColor | Gets or sets the color of the AnnotationLine object.
Public Property | LineLocation | Gets or sets the location of the AnnotationLine within the Annotation object. The three possible values are Top, Middle, and Bottom.
Public Property | LineWidth | Gets or sets the width of the AnnotationLine line object, in pixels.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowArrowCaps | Gets or sets the location on the AnnotationLine that displays arrow caps.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation.
Public Property | TextAlignment | Gets or sets the horizontal alignment of the text string relative to the bounds of the AnnotationLine object.
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation.
Public Property | TextWidth | Gets or sets the amount of width, in inches, allocated to the text within the AnnotationLine object.
Public Property | Width | Overridden. Gets or sets the width of the AnnotationLine object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowCapHeight Property

[image]
ActiveReports 13
ArrowCapHeight Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ArrowCapHeight Property

Glossary Item Box

Gets or sets the height of the arrow cap of the AnnotationLine, in pixels.

Syntax

Visual Basic (Declaration)
Public Property ArrowCapHeight As Single
C#
public float ArrowCapHeight {get; set;}

Property Value

The height of the arrow cap.

Remarks

The height is measured from the base of the arrow to the tip.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ArrowCapWidth Property

[image]
ActiveReports 13
ArrowCapWidth Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ArrowCapWidth Property

Glossary Item Box

Gets or sets the arrow cap width of the AnnotationLine, in pixels.

Syntax

Visual Basic (Declaration)
Public Property ArrowCapWidth As Single
C#
public float ArrowCapWidth {get; set;}

Property Value

The width of the arrow cap.

Remarks

The width of the arrow cap is measured from each end of the base of the arrow cap.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Color Property

[image]
ActiveReports 13
Color Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Color Property

Glossary Item Box

Gets the color of the AnnotationLine.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Color As Color
C#
public override Color Color {get;}

Property Value

The color is used to fill the annotation object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


DashCap Property

[image]
ActiveReports 13
DashCap Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : DashCap Property

Glossary Item Box

Gets or sets the graphic shape to be used on both ends of each dash of the AnnotationLine.

Syntax

Visual Basic (Declaration)
Public Property DashCap As DashCap
C#
public DashCap DashCap {get; set;}

Property Value

The dash cap.

Remarks

If the DashStyle property is set to Solid, the DashCap property has no effect.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


DashStyle Property

[image]
ActiveReports 13
DashStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : DashStyle Property

Glossary Item Box

Gets or sets the dash style of the AnnotationLine.

Syntax

Visual Basic (Declaration)
Public Property DashStyle As DashStyle
C#
public DashStyle DashStyle {get; set;}

Property Value

The dash style.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


FillArrowCaps Property

[image]
ActiveReports 13
FillArrowCaps Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : FillArrowCaps Property

Glossary Item Box

Determines whether the arrows caps of the AnnotationLine object will be filled.

Syntax

Visual Basic (Declaration)
Public Property FillArrowCaps As Boolean
C#
public bool FillArrowCaps {get; set;}

Property Value

true if [fill arrow caps]; otherwise, false.

Remarks

If the ShowArrowCaps property is set to None, the FillArrowCaps property has no effect on the AnnotationLine object.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Font Property

[image]
ActiveReports 13
Font Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Font Property

Glossary Item Box

Gets or sets the font for the text of the AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

The font.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.Font = new Font("Arial", 12f, FontStyle.Bold);
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineColor Property

[image]
ActiveReports 13
LineColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineColor Property

Glossary Item Box

Gets or sets the color of the AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor {get; set;}

Property Value

The color of the line.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineLocation Property

[image]
ActiveReports 13
LineLocation Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineLocation Property

Glossary Item Box

Gets or sets the location of the AnnotationLine within the Annotation object. The three possible values are Top, Middle, and Bottom.

Syntax

Visual Basic (Declaration)
Public Property LineLocation As AnnotationLine.LinePlacement
C#
public AnnotationLine.LinePlacement LineLocation {get; set;}

Property Value

The line location.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineWidth Property

[image]
ActiveReports 13
LineWidth Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineWidth Property

Glossary Item Box

Gets or sets the width of the AnnotationLine line object, in pixels.

Syntax

Visual Basic (Declaration)
Public Property LineWidth As Single
C#
public float LineWidth {get; set;}

Property Value

A float or single value in pixels.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ShowArrowCaps Property

[image]
ActiveReports 13
ShowArrowCaps Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ShowArrowCaps Property

Glossary Item Box

Gets or sets the location on the AnnotationLine that displays arrow caps.

Syntax

Visual Basic (Declaration)
Public Property ShowArrowCaps As AnnotationLine.ShowArrowCap
C#
public AnnotationLine.ShowArrowCap ShowArrowCaps {get; set;}

Property Value

The show arrow caps.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Text Property

[image]
ActiveReports 13
Text Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Text Property

Glossary Item Box

Gets or sets the text to be rendered in the annotation.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

The text of the AnnotationLine object.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextAlignment Property

[image]
ActiveReports 13
TextAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextAlignment Property

Glossary Item Box

Gets or sets the horizontal alignment of the text string relative to the bounds of the AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As StringAlignment
C#
public StringAlignment TextAlignment {get; set;}

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextColor Property

[image]
ActiveReports 13
TextColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextColor Property

Glossary Item Box

Gets or sets the color of the text that is rendered with the annotation.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
C#
public Color TextColor {get; set;}

Property Value

The color of the text.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextWidth Property

[image]
ActiveReports 13
TextWidth Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextWidth Property

Glossary Item Box

Gets or sets the amount of width, in inches, allocated to the text within the AnnotationLine object.

Syntax

Visual Basic (Declaration)
Public Property TextWidth As Single
C#
public float TextWidth {get; set;}

Property Value

A float or single value in inches.

Remarks

If the TextWidth property is set on the viewer to a value larger than the width of the AnnotationLine object, the AnnotationLine object is redrawn to accommodate the text.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;
    line.TextWidth = 1.2f;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Width Property

[image]
ActiveReports 13
Width Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Width Property

Glossary Item Box

Gets or sets the width of the AnnotationLine object, in inches.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Width As Single
C#
public override float Width {get; set;}

Property Value

A float or single value in inches.

Example

C# Copy Code
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;
    line.TextWidth = 1.2f;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
Visual Basic Copy Code
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationRectangle Class

[image]
ActiveReports 13
AnnotationRectangle Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

Represents the rectangular Annotation object.

Object Model

AnnotationRectangle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AnnotationRectangle
   Inherits Annotation
C#
public sealed class AnnotationRectangle : Annotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Members

[image]
ActiveReports 13
AnnotationRectangle Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

The following tables list the members exposed by AnnotationRectangle.

Public Constructors

 | Name | Description
Public Constructor | AnnotationRectangle Constructor | Initializes a new instance of the AnnotationRectangle object.
Top

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Constructor

[image]
ActiveReports 13
AnnotationRectangle Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : AnnotationRectangle Constructor

Glossary Item Box

Initializes a new instance of the AnnotationRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationRectangle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


AnnotationText Class

[image]
ActiveReports 13
AnnotationText Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

Represents the characteristics of the text of the Annotation object.

Object Model

AnnotationText Class

Syntax

Visual Basic (Declaration)
Public Class AnnotationText
   Inherits AnnotationBaseText
C#
public class AnnotationText : AnnotationBaseText

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Members

[image]
ActiveReports 13
AnnotationText Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

The following tables list the members exposed by AnnotationText.

Public Constructors

 | Name | Description
Public Constructor | AnnotationText Constructor | Initializes a new instance of the AnnotationText object.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the text within the bounds of an annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the text font associated with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the vertical alignment of the text within the bounds of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Constructor

[image]
ActiveReports 13
AnnotationText Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : AnnotationText Constructor

Glossary Item Box

Initializes a new instance of the AnnotationText object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AnnotationText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


BorderCircle Class

[image]
ActiveReports 13
BorderCircle Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class

Glossary Item Box

Draws a border around an AnnotationCircle.

Object Model

BorderCircle Class

Syntax

Visual Basic (Declaration)
Public Class BorderCircle
   Inherits Border
C#
public class BorderCircle : Border

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.BorderCircle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderCircle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderCircle Class Members

[image]
ActiveReports 13
BorderCircle Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class

Glossary Item Box

The following tables list the members exposed by BorderCircle.

Public Constructors

 | Name | Description
Public Constructor | BorderCircle Constructor | Initializes a new instance of the BorderCircle class.
Top

See Also

Reference

BorderCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderCircle Constructor

[image]
ActiveReports 13
BorderCircle Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > BorderCircle Class : BorderCircle Constructor

Glossary Item Box

Initializes a new instance of the BorderCircle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderCircle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderCircle Class
BorderCircle Members


BorderRectangle Class

[image]
ActiveReports 13
BorderRectangle Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class

Glossary Item Box

Draws a border around an AnnotationRectangle.

Object Model

BorderRectangle Class

Syntax

Visual Basic (Declaration)
Public Class BorderRectangle
   Inherits Border
C#
public class BorderRectangle : Border

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.BorderRectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderRectangle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Class Members

[image]
ActiveReports 13
BorderRectangle Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class

Glossary Item Box

The following tables list the members exposed by BorderRectangle.

Public Constructors

 | Name | Description
Public Constructor | BorderRectangle Constructor | Initializes a new instance of the BorderRectangle class.
Top

See Also

Reference

BorderRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Constructor

[image]
ActiveReports 13
BorderRectangle Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > BorderRectangle Class : BorderRectangle Constructor

Glossary Item Box

Initializes a new instance of the BorderRectangle class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public BorderRectangle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BorderRectangle Class
BorderRectangle Members


AnnotationBalloon.BallonQuadrant Enumeration

[image]
ActiveReports 13
AnnotationBalloon.BallonQuadrant Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon.BallonQuadrant Enumeration

Glossary Item Box

Specifies the location of the balloon tail relative to the AnnotationBalloon object.

Syntax

Visual Basic (Declaration)
Public Enum AnnotationBalloon.BallonQuadrant
   Inherits System.Enum
C#
public enum AnnotationBalloon.BallonQuadrant : System.Enum

Members

Member | Description
BottomLeft | The balloon tail is drawn to the bottom left of the balloon.
BottomRight | The balloon tail is drawn to the bottom right of the balloon.
LeftBottom | The balloon tail is drawn to the left bottom of the balloon.
LeftTop | The balloon tail is drawn to the left top of the balloon.
None | The balloon is drawn without a tail.
RightBottom | The balloon tail is drawn to the right bottom of the balloon.
RightTop | The balloon tail is drawn to the right top of the balloon.
TopLeft | The balloon tail is drawn to the top left of the balloon.
TopRight | The balloon tail is drawn to the top right of the balloon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon.BallonQuadrant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine.LinePlacement Enumeration

[image]
ActiveReports 13
AnnotationLine.LinePlacement Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine.LinePlacement Enumeration

Glossary Item Box

Specifies the location relative to the Annotation object in which the line will be drawn.

Syntax

Visual Basic (Declaration)
Public Enum AnnotationLine.LinePlacement
   Inherits System.Enum
C#
public enum AnnotationLine.LinePlacement : System.Enum

Members

Member | Description
Bottom | The line is drawn at the bottom of the Annotation object.
Middle | The line is drawn in the middle of the Annotation object.
Top | The line is drawn at the top of the Annotation object.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine.LinePlacement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine.ShowArrowCap Enumeration

[image]
ActiveReports 13
AnnotationLine.ShowArrowCap Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine.ShowArrowCap Enumeration

Glossary Item Box

Specifies the location of the arrow cap on the AnnotationLine.

Syntax

Visual Basic (Declaration)
Public Enum AnnotationLine.ShowArrowCap
   Inherits System.Enum
C#
public enum AnnotationLine.ShowArrowCap : System.Enum

Members

Member | Description
LeftOnly | The arrow cap displays on the left end of the line.
LeftRight | The arrow cap displays on both end of the line.
None | The arrow cap does not display.
RightOnly | The arrow cap displays on the right end of the line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine.ShowArrowCap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowDirection Enumeration

[image]
ActiveReports 13
ArrowDirection Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : ArrowDirection Enumeration

Glossary Item Box

Specifies the direction in which the arrow points.

Syntax

Visual Basic (Declaration)
Public Enum ArrowDirection
   Inherits System.Enum
C#
public enum ArrowDirection : System.Enum

Members

Member | Description
Bottom | The arrow points to the bottom.
Left | The arrow points to the left.
Right | The arrow points to the right.
Top | The arrow points to the top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.ArrowDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ImageLayout Enumeration

[image]
ActiveReports 13
ImageLayout Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : ImageLayout Enumeration

Glossary Item Box

Specifies the positioning for Annotation Images.

Syntax

Visual Basic (Declaration)
Public Enum ImageLayout
   Inherits System.Enum
C#
public enum ImageLayout : System.Enum

Members

Member | Description
Bottom | The bottom edge of the image is aligned with the bottom edge of the annotation rectangle.
Center | The image is centered within the annotation rectangle.
Left | The left edge of the image is aligned with the left edge of the annotation rectangle.
LeftBottom | The left and bottom edges of the image are aligned with the left and bottom edges of the annotation rectangle.
LeftTop | The left and top edges of the image are aligned with the left and top edges of the annotation rectangle.
Right | The right edge of the image is aligned with the right edge of the annotation rectangle.
RightBottom | The right and bottom edges of the image are aligned with the right and bottom edges of the annotation rectangle.
RightTop | The right and top edges of the image are aligned with the right and top edges of the annotation rectangle.
Stretch | The image is stretched (or shrunk) to fit the annotation rectangle exactly without regard to aspect ratio.
Tile | The image, at its actual size, is tiled within the annotation rectangle.
Top | The top edge of the image is aligned with the top edge of the annotation rectangle.
Zoom | The image is resized to fit within the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.ImageLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


GrapeCity.ActiveReports.Document.Tools Namespace

GrapeCity.ActiveReports.Document.Tools Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Tools Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document)

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Export Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.

Interfaces

 | Interface | Description
Interface | IDocumentExport | Provides a common interface for all the export filters.

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


IDocumentExport Interface

[image]
ActiveReports 13
IDocumentExport Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

Glossary Item Box

Provides a common interface for all the export filters.

Syntax

Visual Basic (Declaration)
Public Interface IDocumentExport
C#
public interface IDocumentExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Members
GrapeCity.ActiveReports.Export Namespace


IDocumentExport Interface Members

[image]
ActiveReports 13
IDocumentExport Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

Glossary Item Box

The following tables list the members exposed by IDocumentExport.

Public Methods

 | Name | Description
Method | Export | Overloaded. Exports the specified range of pages to an HTML file.
Top

See Also

Reference

IDocumentExport Interface
GrapeCity.ActiveReports.Export Namespace


IDocumentExport Interface Methods

[image]
ActiveReports 13
IDocumentExport Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

Glossary Item Box

For a list of all members of this type, see IDocumentExport members.

Public Methods

 | Name | Description
Method | Export | Overloaded. Exports the specified range of pages to an HTML file.
Top

See Also

Reference

IDocumentExport Interface
GrapeCity.ActiveReports.Export Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface : Export Method

Glossary Item Box

Exports the specified range of pages to an HTML file. Exports the specified document to HTML.

Overload List

Overload | Description
Export(SectionDocument,String,String) | Exports the specified range of pages to an HTML file.
Export(SectionDocument,String) | Exports the entire ActiveReports document to the specified HTML file.
Export(SectionDocument,Stream) | Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(SectionDocument,Stream,String) | Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(SectionDocument,IOutputHtml,String) | Exports the specified range of pages of the document to the chosen outputHandler.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members


Export(SectionDocument,String,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,String,String) Method

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages to an HTML file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
void Export(
   SectionDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,String) Method

document
The ActiveReports Document object to export.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.

Glossary Item Box

Exports the entire ActiveReports document to the specified HTML file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,Stream) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,Stream) Method

document
The ActiveReports document to be exported.
outputStream
The destination System.IO.Stream to which to save the MHT file.

Glossary Item Box

Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream _
)
C#
void Export(
   SectionDocument document,
   Stream outputStream
)

Parameters

document
The ActiveReports document to be exported.
outputStream
The destination System.IO.Stream to which to save the MHT file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,Stream,String) Method

document
The ActiveReports document to be exported.
outputStream
The destination System.IO.Stream to which to save the MHT file.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
void Export(
   SectionDocument document,
   Stream outputStream,
   string pageRange
)

Parameters

document
The ActiveReports document to be exported.
outputStream
The destination System.IO.Stream to which to save the MHT file.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,IOutputHtml,String) Method

[image]
ActiveReports 13
Export(SectionDocument,IOutputHtml,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,IOutputHtml,String) Method

document
The ActiveReports document to be exported.
outputHandler
The destination System.IO.Stream to which to save the MHT file.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages of the document to the chosen outputHandler.

Syntax

Visual Basic (Declaration)
Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputHandler As IOutputHtml, _
   ByVal pageRange As String _
)
C#
void Export(
   SectionDocument document,
   IOutputHtml outputHandler,
   string pageRange
)

Parameters

document
The ActiveReports document to be exported.
outputHandler
The destination System.IO.Stream to which to save the MHT file.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


GrapeCity.ActiveReports.Export.Html Namespace

GrapeCity.ActiveReports.Export.Html Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Export.Html Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Html namespace contains the class which gives control over the HTML output of the report.

Classes

 | Class | Description
Class | HtmlOutputInfoArgs | Used as an argument to the IOutputHtml interface's OutputHtmlData function.

Interfaces

 | Interface | Description
Interface | IOutputHtml | Provides an interface that can be passed for Export.

Enumerations

 | Enumeration | Description
Enumeration | HtmlOutputKind | Specifies the HTML output.

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


HtmlOutputInfoArgs Class

[image]
ActiveReports 13
HtmlOutputInfoArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

Glossary Item Box

Used as an argument to the IOutputHtml interface's OutputHtmlData function.

Object Model

HtmlOutputInfoArgs Class

Syntax

Visual Basic (Declaration)
Public Class HtmlOutputInfoArgs
C#
public class HtmlOutputInfoArgs

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.HtmlOutputInfoArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Members
GrapeCity.ActiveReports.Export.Html Namespace


HtmlOutputInfoArgs Class Members

[image]
ActiveReports 13
HtmlOutputInfoArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

Glossary Item Box

The following tables list the members exposed by HtmlOutputInfoArgs.

Public Constructors

 | Name | Description
Public Constructor | HtmlOutputInfoArgs Constructor | Initializes a new instance of the HtmlOutputInfoArgs class.
Top

Public Properties

 | Name | Description
Public Property | OutputKind | The type that is being outputted. Can be of type ImagePng, ImageJpg, HtmlPage, BookmarksHtml, or FramesetHtml.
Public Property | OutputStream | The System.IO.Stream that is being outputted.
Top

See Also

Reference

HtmlOutputInfoArgs Class
GrapeCity.ActiveReports.Export.Html Namespace


HtmlOutputInfoArgs Constructor

[image]
ActiveReports 13
HtmlOutputInfoArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : HtmlOutputInfoArgs Constructor

outputKind
The type that is being outputted.
outputStream
The System.IO.Stream that is being outputted.

Glossary Item Box

Initializes a new instance of the HtmlOutputInfoArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal outputKind As HtmlOutputKind, _
   ByVal outputStream As Stream _
)
C#
public HtmlOutputInfoArgs(
   HtmlOutputKind outputKind,
   Stream outputStream
)

Parameters

outputKind
The type that is being outputted.
outputStream
The System.IO.Stream that is being outputted.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


HtmlOutputInfoArgs Class Properties

[image]
ActiveReports 13
HtmlOutputInfoArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

Glossary Item Box

For a list of all members of this type, see HtmlOutputInfoArgs members.

Public Properties

 | Name | Description
Public Property | OutputKind | The type that is being outputted. Can be of type ImagePng, ImageJpg, HtmlPage, BookmarksHtml, or FramesetHtml.
Public Property | OutputStream | The System.IO.Stream that is being outputted.
Top

See Also

Reference

HtmlOutputInfoArgs Class
GrapeCity.ActiveReports.Export.Html Namespace


OutputKind Property

[image]
ActiveReports 13
OutputKind Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : OutputKind Property

Glossary Item Box

The type that is being outputted. Can be of type ImagePng, ImageJpg, HtmlPage, BookmarksHtml, or FramesetHtml.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputKind As HtmlOutputKind
C#
public HtmlOutputKind OutputKind {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


OutputStream Property

[image]
ActiveReports 13
OutputStream Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : OutputStream Property

Glossary Item Box

The System.IO.Stream that is being outputted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputStream As Stream
C#
public Stream OutputStream {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


HtmlOutputKind Enumeration

[image]
ActiveReports 13
HtmlOutputKind Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputKind Enumeration

Glossary Item Box

Specifies the HTML output.

Syntax

Visual Basic (Declaration)
Public Enum HtmlOutputKind
   Inherits System.Enum
C#
public enum HtmlOutputKind : System.Enum

Members

Member | Description
BookmarksHtml | The output is an HTML page containing a list of bookmarks for the main HTML page.
FramesetHtml | The output is an html page containing a Frameset declaration for a TOC page or navigation page if TOC not available, and the "target" document pages on the right.
HtmlPage | The output is the HTML page.
ImageJpg | The HTML output is an image of type JPEG.
ImagePng | The HTML output is an image of type PNG.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.HtmlOutputKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface

[image]
ActiveReports 13
IOutputHtml Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

Glossary Item Box

Provides an interface that can be passed for Export.

Syntax

Visual Basic (Declaration)
Public Interface IOutputHtml
C#
public interface IOutputHtml

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOutputHtml Members
GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface Members

[image]
ActiveReports 13
IOutputHtml Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

Glossary Item Box

The following tables list the members exposed by IOutputHtml.

Public Methods

 | Name | Description
Method | Finish | Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementer to flush any remaining output, or to write out a frame set page for the previously exported document.
Method | OutputHtmlData | Called by the HtmlExport class to output data. The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementer requires.
Top

See Also

Reference

IOutputHtml Interface
GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface Methods

[image]
ActiveReports 13
IOutputHtml Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

Glossary Item Box

For a list of all members of this type, see IOutputHtml members.

Public Methods

 | Name | Description
Method | Finish | Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementer to flush any remaining output, or to write out a frame set page for the previously exported document.
Method | OutputHtmlData | Called by the HtmlExport class to output data. The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementer requires.
Top

See Also

Reference

IOutputHtml Interface
GrapeCity.ActiveReports.Export.Html Namespace


Finish Method

[image]
ActiveReports 13
Finish Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace > IOutputHtml Interface : Finish Method

Glossary Item Box

Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementer to flush any remaining output, or to write out a frame set page for the previously exported document.

Syntax

Visual Basic (Declaration)
Sub Finish()
C#
void Finish()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOutputHtml Interface
IOutputHtml Members


OutputHtmlData Method

[image]
ActiveReports 13
OutputHtmlData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Export.Html Namespace > IOutputHtml Interface : OutputHtmlData Method

info
Information about the output

Glossary Item Box

Called by the HtmlExport class to output data. The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementer requires.

Syntax

Visual Basic (Declaration)
Function OutputHtmlData( _
   ByVal info As HtmlOutputInfoArgs _
) As String
C#
string OutputHtmlData(
   HtmlOutputInfoArgs info
)

Parameters

info
Information about the output

Return Value

The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implentator requires. The return value should be a "file name" that the calling HtmlExport class can use to place links in the main HTML page to the data. For example, as an HTML page is being created and an image is encountered that will be outputed as an HTML img the HtmlExport object will call this method to provide the data to the implentor, and the return value from OutputHtmlData (i.e. the filename) will be used as the src attribute's value. When the HTML page is ready, OutputHtmlData will be called again to pass the actual HTML page's data, in this case the filename returned by the OutputHtmlData implementation will not be used.

Remarks

The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementor requires. The return value should be a "file name" that the calling HtmlExport class can use to place links in the main HTML page to the data. For example, as an HTML page is being created and an image is encountered that will be output as an HTML img. the HtmlExport object will call this method to provide the data to the implementor and the return value from OutputHtmlData (i.e. the filename) will be used as the src attribute's value.

When the HTML page is ready, OutputHtmlData will be called again to pass the actual HTML page's data. In this case the filename returned by the OutputHtmlData implementation will not be used."

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOutputHtml Interface
IOutputHtml Members


GrapeCity.ActiveReports.Extensibility.Printing Namespace

GrapeCity.ActiveReports.Extensibility.Printing Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Extensibility.Printing Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ActiveReportPrintController | Class ActiveReportPrintController.
Class | DDPaperSize | Summary description for DDPaperSize.
Class | Margin | Page margins
Class | Printer | Summary description for Printer.
Class | PrintingThreadErrorEventArgs | Summary description for PrintingThreadErrorEventArgs.
Class | PrintOptions | Print options
Class | PrintProgressEventArgs | PrintProgressEventArgs
Class | WatermarkOptions | Watermark options

Delegates

 | Delegate | Description
Delegate | PrintAbortedEventHandler | Summary description for Document Events.
Delegate | PrintingThreadErrorEventHandler | Summary description for Document Events.
Delegate | PrintProgressEventHandler | Summary description for Document Events.

Enumerations

 | Enumeration | Description
Enumeration | PageOrder | Specifies page printing order
Enumeration | PageScaling | Specifies page scaling

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


ActiveReportPrintController Class

[image]
ActiveReports 13
ActiveReportPrintController Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : ActiveReportPrintController Class

Glossary Item Box

Class ActiveReportPrintController.

Object Model

ActiveReportPrintController Class

Syntax

Visual Basic (Declaration)
Public Class ActiveReportPrintController
   Inherits System.Drawing.Printing.StandardPrintController
C#
public class ActiveReportPrintController : System.Drawing.Printing.StandardPrintController

Inheritance Hierarchy

System.Object
System.Drawing.Printing.PrintController
System.Drawing.Printing.StandardPrintController
GrapeCity.ActiveReports.Extensibility.Printing.ActiveReportPrintController

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


ActiveReportPrintController Class Members

[image]
ActiveReports 13
ActiveReportPrintController Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : ActiveReportPrintController Class

Glossary Item Box

The following tables list the members exposed by ActiveReportPrintController.

Public Constructors

 | Name | Description
Public Constructor | ActiveReportPrintController Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel | Cancel
Public Property | IsPreview | Gets a value indicating whether the System.Drawing.Printing.PrintController is used for print preview. (Inherited from System.Drawing.Printing.PrintController)
Top

Public Methods

 | Name | Description
Public Method | OnEndPage | Overridden. OnEndPage
Public Method | OnEndPrint | Completes the control sequence that determines when and how to print a document. (Inherited from System.Drawing.Printing.StandardPrintController)
Public Method | OnStartPage | Overridden. OnStartPage
Public Method | OnStartPrint | Begins the control sequence that determines when and how to print a document. (Inherited from System.Drawing.Printing.StandardPrintController)
Top

Public Events

 | Name | Description
Public Event | PrintAborted | Occurs when print is aborted.
Public Event | PrintingProgress | Occurs when printing progress is changed.
Top

See Also

Reference

ActiveReportPrintController Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


ActiveReportPrintController Constructor

[image]
ActiveReports 13
ActiveReportPrintController Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : ActiveReportPrintController Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ActiveReportPrintController()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


ActiveReportPrintController Class Methods

[image]
ActiveReports 13
ActiveReportPrintController Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : ActiveReportPrintController Class

Glossary Item Box

For a list of all members of this type, see ActiveReportPrintController members.

Public Methods

 | Name | Description
Public Method | OnEndPage | Overridden. OnEndPage
Public Method | OnEndPrint | Completes the control sequence that determines when and how to print a document. (Inherited from System.Drawing.Printing.StandardPrintController)
Public Method | OnStartPage | Overridden. OnStartPage
Public Method | OnStartPrint | Begins the control sequence that determines when and how to print a document. (Inherited from System.Drawing.Printing.StandardPrintController)
Top

See Also

Reference

ActiveReportPrintController Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


OnEndPage Method

[image]
ActiveReports 13
OnEndPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : OnEndPage Method

prnDoc
ppea

Glossary Item Box

OnEndPage

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnEndPage( _
   ByVal prnDoc As PrintDocument, _
   ByVal ppea As PrintPageEventArgs _
)
C#
public override void OnEndPage(
   PrintDocument prnDoc,
   PrintPageEventArgs ppea
)

Parameters

prnDoc
ppea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


OnStartPage Method

[image]
ActiveReports 13
OnStartPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : OnStartPage Method

prnDoc
ppea

Glossary Item Box

OnStartPage

Syntax

Visual Basic (Declaration)
Public Overrides Function OnStartPage( _
   ByVal prnDoc As PrintDocument, _
   ByVal ppea As PrintPageEventArgs _
) As Graphics
C#
public override Graphics OnStartPage(
   PrintDocument prnDoc,
   PrintPageEventArgs ppea
)

Parameters

prnDoc
ppea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


ActiveReportPrintController Class Properties

[image]
ActiveReports 13
ActiveReportPrintController Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : ActiveReportPrintController Class

Glossary Item Box

For a list of all members of this type, see ActiveReportPrintController members.

Public Properties

 | Name | Description
Public Property | Cancel | Cancel
Public Property | IsPreview | Gets a value indicating whether the System.Drawing.Printing.PrintController is used for print preview. (Inherited from System.Drawing.Printing.PrintController)
Top

See Also

Reference

ActiveReportPrintController Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Cancel Property

[image]
ActiveReports 13
Cancel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : Cancel Property

Glossary Item Box

Cancel

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


ActiveReportPrintController Class Events

[image]
ActiveReports 13
ActiveReportPrintController Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : ActiveReportPrintController Class

Glossary Item Box

For a list of all members of this type, see ActiveReportPrintController members.

Public Events

 | Name | Description
Public Event | PrintAborted | Occurs when print is aborted.
Public Event | PrintingProgress | Occurs when printing progress is changed.
Top

See Also

Reference

ActiveReportPrintController Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintAborted Event

[image]
ActiveReports 13
PrintAborted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : PrintAborted Event

Glossary Item Box

Occurs when print is aborted.

Syntax

Visual Basic (Declaration)
Public Event PrintAborted As PrintAbortedEventHandler
C#
public event PrintAbortedEventHandler PrintAborted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


PrintingProgress Event

[image]
ActiveReports 13
PrintingProgress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : PrintingProgress Event

Glossary Item Box

Occurs when printing progress is changed.

Syntax

Visual Basic (Declaration)
Public Event PrintingProgress As PrintProgressEventHandler
C#
public event PrintProgressEventHandler PrintingProgress

Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the current printing page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


DDPaperSize Class

[image]
ActiveReports 13
DDPaperSize Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : DDPaperSize Class

Glossary Item Box

Summary description for DDPaperSize.

Object Model

DDPaperSize Class

Syntax

Visual Basic (Declaration)
Public Class DDPaperSize
   Inherits System.Drawing.Printing.PaperSize
C#
public class DDPaperSize : System.Drawing.Printing.PaperSize

Inheritance Hierarchy

System.Object
System.Drawing.Printing.PaperSize
GrapeCity.ActiveReports.Extensibility.Printing.DDPaperSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


DDPaperSize Class Members

[image]
ActiveReports 13
DDPaperSize Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : DDPaperSize Class

Glossary Item Box

The following tables list the members exposed by DDPaperSize.

Public Constructors

 | Name | Description
Public Constructor | DDPaperSize Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the paper, in hundredths of an inch. (Inherited from System.Drawing.Printing.PaperSize)
Public Property | Kind | Kind
Public Property | PaperName | Gets or sets the name of the type of paper. (Inherited from System.Drawing.Printing.PaperSize)
Public Property | RawKind | Gets or sets an integer representing one of the System.Drawing.Printing.PaperSize values or a custom value. (Inherited from System.Drawing.Printing.PaperSize)
Public Property | Width | Gets or sets the width of the paper, in hundredths of an inch. (Inherited from System.Drawing.Printing.PaperSize)
Top

Public Methods

 | Name | Description
Public Method | ToString | Provides information about the System.Drawing.Printing.PaperSize in string form. (Inherited from System.Drawing.Printing.PaperSize)
Top

See Also

Reference

DDPaperSize Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


DDPaperSize Constructor

[image]
ActiveReports 13
DDPaperSize Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class : DDPaperSize Constructor

Glossary Item Box

Overload List

Overload | Description
DDPaperSize Constructor(PaperKind,String,Int32,Int32) | DDPaperSize
DDPaperSize Constructor(String,String,Single,Single) | DDPaperSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members


DDPaperSize Constructor(PaperKind,String,Int32,Int32)

[image]
ActiveReports 13
DDPaperSize Constructor(PaperKind,String,Int32,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class > DDPaperSize Constructor : DDPaperSize Constructor(PaperKind,String,Int32,Int32)

kind
name
width
height

Glossary Item Box

DDPaperSize

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal kind As PaperKind, _
   ByVal name As String, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public DDPaperSize(
   PaperKind kind,
   string name,
   int width,
   int height
)

Parameters

kind
name
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members
Overload List


DDPaperSize Constructor(String,String,Single,Single)

[image]
ActiveReports 13
DDPaperSize Constructor(String,String,Single,Single)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class > DDPaperSize Constructor : DDPaperSize Constructor(String,String,Single,Single)

printerName
paperName
width
height

Glossary Item Box

DDPaperSize

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal paperName As String, _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public DDPaperSize(
   string printerName,
   string paperName,
   float width,
   float height
)

Parameters

printerName
paperName
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members
Overload List


DDPaperSize Class Properties

[image]
ActiveReports 13
DDPaperSize Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : DDPaperSize Class

Glossary Item Box

For a list of all members of this type, see DDPaperSize members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the paper, in hundredths of an inch. (Inherited from System.Drawing.Printing.PaperSize)
Public Property | Kind | Kind
Public Property | PaperName | Gets or sets the name of the type of paper. (Inherited from System.Drawing.Printing.PaperSize)
Public Property | RawKind | Gets or sets an integer representing one of the System.Drawing.Printing.PaperSize values or a custom value. (Inherited from System.Drawing.Printing.PaperSize)
Public Property | Width | Gets or sets the width of the paper, in hundredths of an inch. (Inherited from System.Drawing.Printing.PaperSize)
Top

See Also

Reference

DDPaperSize Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Kind Property

[image]
ActiveReports 13
Kind Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class : Kind Property

Glossary Item Box

Kind

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Kind As PaperKind
C#
public new PaperKind Kind {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members


Margin Class

[image]
ActiveReports 13
Margin Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Margin Class

Glossary Item Box

Page margins

Object Model

Margin Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Margin
C#
public sealed class Margin

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Printing.Margin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Margin Class Members

[image]
ActiveReports 13
Margin Class Members
See Also Fields Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Margin Class

Glossary Item Box

The following tables list the members exposed by Margin.

Public Constructors

 | Name | Description
Public Constructor | Margin Constructor | Initializes a new instance of the Margin class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty margins
Top

Public Properties

 | Name | Description
Public Property | Bottom | Bottom margin.
Public Property | Left | Left margin.
Public Property | Right | Right margin.
Public Property | Top | Top margin.
Top

See Also

Reference

Margin Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Margin Constructor

[image]
ActiveReports 13
Margin Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Margin Constructor

left
The left margin.
right
The right margin.
top
The top margin.
bottom
The bottom margin.

Glossary Item Box

Initializes a new instance of the Margin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal right As Single, _
   ByVal top As Single, _
   ByVal bottom As Single _
)
C#
public Margin(
   float left,
   float right,
   float top,
   float bottom
)

Parameters

left
The left margin.
right
The right margin.
top
The top margin.
bottom
The bottom margin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Margin Class Properties

[image]
ActiveReports 13
Margin Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Margin Class

Glossary Item Box

For a list of all members of this type, see Margin members.

Public Properties

 | Name | Description
Public Property | Bottom | Bottom margin.
Public Property | Left | Left margin.
Public Property | Right | Right margin.
Public Property | Top | Top margin.
Top

See Also

Reference

Margin Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Bottom Property

Glossary Item Box

Bottom margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Single
C#
public float Bottom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Left Property

Glossary Item Box

Left margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
C#
public float Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Right Property

Glossary Item Box

Right margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Single
C#
public float Right {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Top Property

Glossary Item Box

Top margin.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
C#
public float Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Margin Class Fields

[image]
ActiveReports 13
Margin Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Margin Class

Glossary Item Box

For a list of all members of this type, see Margin members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | The empty margins
Top

See Also

Reference

Margin Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Empty Field

Glossary Item Box

The empty margins

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Margin
C#
public static readonly Margin Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Class
Margin Members


Printer Class

[image]
ActiveReports 13
Printer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

Glossary Item Box

Summary description for Printer.

Object Model

Printer Class

Syntax

Visual Basic (Declaration)
Public Class Printer
   Inherits System.Drawing.Printing.PrintDocument
C#
public class Printer : System.Drawing.Printing.PrintDocument

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
GrapeCity.ActiveReports.Extensibility.Printing.Printer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Printer Class Members

[image]
ActiveReports 13
Printer Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

Glossary Item Box

The following tables list the members exposed by Printer.

Public Constructors

 | Name | Description
Public Constructor | Printer Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | Landscape | Landscape There is a potential problem if some one uses the DefaultPageSettings.Landscape to change the the landscape instead of Printer.Landscape.
Public Property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | PaperHeight | PaperHeight
Public Property | PaperKind | PaperKind
Public Property | PaperSize | PaperSize
Public Property | PaperSizes | PaperSizes
Public Property | PaperWidth | PaperWidth
Public Property | PrintController | Gets or sets the print controller that guides the printing process.
Public Property | PrinterName | PrinterName
Public Property | PrinterSettings | Gets or sets the printer that prints the document.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | VisibleBounds | VisibleBounds
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Print | Starts the document's printing process. (Inherited from System.Drawing.Printing.PrintDocument)
Public Method | Reinitialize | Reinitialize
Public Method | ToString | Provides information about the print document, in string form. (Inherited from System.Drawing.Printing.PrintDocument)
Top

Public Events

 | Name | Description
Public Event | BeginPrint | Occurs when the System.Drawing.Printing.PrintDocument.Print method is called and before the first page of the document prints. (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | EndPrint | Occurs when the last page of the document has printed. (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | QueryPageSettings | Occurs immediately before each System.Drawing.Printing.PrintDocument.PrintPage event. (Inherited from System.Drawing.Printing.PrintDocument)
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Printer Constructor

[image]
ActiveReports 13
Printer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Printer Constructor

Glossary Item Box

Overload List

Overload | Description
Printer Constructor() | Initializes a new instance of the Printer class.
Printer Constructor(Func<PrintController>,PrintProgressEventHandler,PrintAbortedEventHandler,Action<Exception>) | Initializes a new instance of the Printer class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Printer Constructor()

[image]
ActiveReports 13
Printer Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class > Printer Constructor : Printer Constructor()

Glossary Item Box

Initializes a new instance of the Printer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Printer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members
Overload List


Printer Constructor(Func<PrintController>,PrintProgressEventHandler,PrintAbortedEventHandler,Action<Exception>)

[image]
ActiveReports 13
Printer Constructor(Func<PrintController>,PrintProgressEventHandler,PrintAbortedEventHandler,Action<Exception>)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class > Printer Constructor : Printer Constructor(Func<PrintController>,PrintProgressEventHandler,PrintAbortedEventHandler,Action<Exception>)

printControllerInitializer
Print controller initializer.
printProgress
Print progress handler.
printAborted
Print aborted handler.
printingThreadErrorEventHandler
The printing thread error event handler.

Glossary Item Box

Initializes a new instance of the Printer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printControllerInitializer As Func(Of PrintController), _
   ByVal printProgress As PrintProgressEventHandler, _
   ByVal printAborted As PrintAbortedEventHandler, _
   ByVal printingThreadErrorEventHandler As Action(Of Exception) _
)
C#
public Printer(
   Func<PrintController> printControllerInitializer,
   PrintProgressEventHandler printProgress,
   PrintAbortedEventHandler printAborted,
   Action<Exception> printingThreadErrorEventHandler
)

Parameters

printControllerInitializer
Print controller initializer.
printProgress
Print progress handler.
printAborted
Print aborted handler.
printingThreadErrorEventHandler
The printing thread error event handler.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members
Overload List


Printer Class Methods

[image]
ActiveReports 13
Printer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Print | Starts the document's printing process. (Inherited from System.Drawing.Printing.PrintDocument)
Public Method | Reinitialize | Reinitialize
Public Method | ToString | Provides information about the print document, in string form. (Inherited from System.Drawing.Printing.PrintDocument)
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Reinitialize Method

[image]
ActiveReports 13
Reinitialize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Reinitialize Method

Glossary Item Box

Reinitialize

Syntax

Visual Basic (Declaration)
Public Sub Reinitialize()
C#
public void Reinitialize()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Printer Class Properties

[image]
ActiveReports 13
Printer Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | Landscape | Landscape There is a potential problem if some one uses the DefaultPageSettings.Landscape to change the the landscape instead of Printer.Landscape.
Public Property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | PaperHeight | PaperHeight
Public Property | PaperKind | PaperKind
Public Property | PaperSize | PaperSize
Public Property | PaperSizes | PaperSizes
Public Property | PaperWidth | PaperWidth
Public Property | PrintController | Gets or sets the print controller that guides the printing process.
Public Property | PrinterName | PrinterName
Public Property | PrinterSettings | Gets or sets the printer that prints the document.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | VisibleBounds | VisibleBounds
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Landscape Property

[image]
ActiveReports 13
Landscape Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Landscape Property

Glossary Item Box

Landscape There is a potential problem if some one uses the DefaultPageSettings.Landscape to change the the landscape instead of Printer.Landscape.

Syntax

Visual Basic (Declaration)
Public Property Landscape As Boolean
C#
public bool Landscape {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperHeight Property

[image]
ActiveReports 13
PaperHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperHeight Property

Glossary Item Box

PaperHeight

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperHeight As Single
C#
public float PaperHeight {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperKind Property

[image]
ActiveReports 13
PaperKind Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperKind Property

Glossary Item Box

PaperKind

Syntax

Visual Basic (Declaration)
Public Property PaperKind As PaperKind
C#
public PaperKind PaperKind {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperSize Property

[image]
ActiveReports 13
PaperSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperSize Property

Glossary Item Box

PaperSize

Syntax

Visual Basic (Declaration)
Public Property PaperSize As PaperSize
C#
public PaperSize PaperSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperSizes Property

[image]
ActiveReports 13
PaperSizes Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperSizes Property

Glossary Item Box

PaperSizes

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperSizes As PrinterSettings.PaperSizeCollection
C#
public PrinterSettings.PaperSizeCollection PaperSizes {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PaperWidth Property

[image]
ActiveReports 13
PaperWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperWidth Property

Glossary Item Box

PaperWidth

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperWidth As Single
C#
public float PaperWidth {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrintController Property

[image]
ActiveReports 13
PrintController Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrintController Property

Glossary Item Box

Gets or sets the print controller that guides the printing process.

Syntax

Visual Basic (Declaration)
Public Shadows Property PrintController As PrintController
C#
public new PrintController PrintController {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrinterName Property

[image]
ActiveReports 13
PrinterName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrinterName Property

Glossary Item Box

PrinterName

Syntax

Visual Basic (Declaration)
Public Property PrinterName As String
C#
public string PrinterName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrinterSettings Property

[image]
ActiveReports 13
PrinterSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrinterSettings Property

Glossary Item Box

Gets or sets the printer that prints the document.

Syntax

Visual Basic (Declaration)
Public Overridable Shadows Property PrinterSettings As PrinterSettings
C#
public virtual new PrinterSettings PrinterSettings {get; set;}

Property Value

A System.Drawing.Printing.PrinterSettings that specifies where and how the document is printed. The default is a System.Drawing.Printing.PrinterSettings with its properties set to their default values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


VisibleBounds Property

[image]
ActiveReports 13
VisibleBounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : VisibleBounds Property

Glossary Item Box

VisibleBounds

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleBounds As RectangleF
C#
public RectangleF VisibleBounds {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrintingThreadErrorEventArgs Class

[image]
ActiveReports 13
PrintingThreadErrorEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventArgs Class

Glossary Item Box

Summary description for PrintingThreadErrorEventArgs.

Object Model

PrintingThreadErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PrintingThreadErrorEventArgs
   Inherits System.EventArgs
C#
public class PrintingThreadErrorEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintingThreadErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventArgs Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintingThreadErrorEventArgs Class Members

[image]
ActiveReports 13
PrintingThreadErrorEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by PrintingThreadErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PrintingThreadErrorEventArgs Constructor | Initializes a new instance of the PrintingThreadErrorEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Exception | Gets the printing thread exception.
Top

See Also

Reference

PrintingThreadErrorEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintingThreadErrorEventArgs Constructor

[image]
ActiveReports 13
PrintingThreadErrorEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintingThreadErrorEventArgs Class : PrintingThreadErrorEventArgs Constructor

exception
The printing thread exception.

Glossary Item Box

Initializes a new instance of the PrintingThreadErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
C#
public PrintingThreadErrorEventArgs(
   Exception exception
)

Parameters

exception
The printing thread exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventArgs Class
PrintingThreadErrorEventArgs Members


PrintingThreadErrorEventArgs Class Properties

[image]
ActiveReports 13
PrintingThreadErrorEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see PrintingThreadErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the printing thread exception.
Top

See Also

Reference

PrintingThreadErrorEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Exception Property

[image]
ActiveReports 13
Exception Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintingThreadErrorEventArgs Class : Exception Property

Glossary Item Box

Gets the printing thread exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventArgs Class
PrintingThreadErrorEventArgs Members


PrintOptions Class

[image]
ActiveReports 13
PrintOptions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class

Glossary Item Box

Print options

Object Model

PrintOptions Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PrintOptions
C#
public sealed class PrintOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Printing.PrintOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintOptions Class Members

[image]
ActiveReports 13
PrintOptions Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class

Glossary Item Box

The following tables list the members exposed by PrintOptions.

Public Properties

 | Name | Description
Public Property | AutoRotate | Auto-rotate
Public Property | Margin | Gets or sets page margins
Public Property | PageOrder | Page order
Public Property | PageScaling | Page scaling
Public Property | PagesPerSheet | Pages per sheet
Public Property | PrintPageBorder | Print page border
Public Property | Watermark | Watermark options
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Creates the default print options.
Top

See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintOptions Class Methods

[image]
ActiveReports 13
PrintOptions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class

Glossary Item Box

For a list of all members of this type, see PrintOptions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Creates the default print options.
Top

See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


CreateDefault Method

[image]
ActiveReports 13
CreateDefault Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : CreateDefault Method

Glossary Item Box

Creates the default print options.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefault() As PrintOptions
C#
public static PrintOptions CreateDefault()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PrintOptions Class Properties

[image]
ActiveReports 13
PrintOptions Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class

Glossary Item Box

For a list of all members of this type, see PrintOptions members.

Public Properties

 | Name | Description
Public Property | AutoRotate | Auto-rotate
Public Property | Margin | Gets or sets page margins
Public Property | PageOrder | Page order
Public Property | PageScaling | Page scaling
Public Property | PagesPerSheet | Pages per sheet
Public Property | PrintPageBorder | Print page border
Public Property | Watermark | Watermark options
Top

See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


AutoRotate Property

[image]
ActiveReports 13
AutoRotate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : AutoRotate Property

Glossary Item Box

Auto-rotate

Syntax

Visual Basic (Declaration)
Public Property AutoRotate As Boolean
C#
public bool AutoRotate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : Margin Property

Glossary Item Box

Gets or sets page margins

Syntax

Visual Basic (Declaration)
Public Property Margin As Margin
C#
public Margin Margin {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PageOrder Property

[image]
ActiveReports 13
PageOrder Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PageOrder Property

Glossary Item Box

Page order

Syntax

Visual Basic (Declaration)
Public Property PageOrder As PageOrder
C#
public PageOrder PageOrder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PageScaling Property

[image]
ActiveReports 13
PageScaling Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PageScaling Property

Glossary Item Box

Page scaling

Syntax

Visual Basic (Declaration)
Public Property PageScaling As PageScaling
C#
public PageScaling PageScaling {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PagesPerSheet Property

[image]
ActiveReports 13
PagesPerSheet Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PagesPerSheet Property

Glossary Item Box

Pages per sheet

Syntax

Visual Basic (Declaration)
Public Property PagesPerSheet As Integer
C#
public int PagesPerSheet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PrintPageBorder Property

[image]
ActiveReports 13
PrintPageBorder Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PrintPageBorder Property

Glossary Item Box

Print page border

Syntax

Visual Basic (Declaration)
Public Property PrintPageBorder As Boolean
C#
public bool PrintPageBorder {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


Watermark Property

[image]
ActiveReports 13
Watermark Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : Watermark Property

Glossary Item Box

Watermark options

Syntax

Visual Basic (Declaration)
Public Property Watermark As WatermarkOptions
C#
public WatermarkOptions Watermark {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintOptions Class
PrintOptions Members


PrintProgressEventArgs Class

[image]
ActiveReports 13
PrintProgressEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventArgs Class

Glossary Item Box

PrintProgressEventArgs

Object Model

PrintProgressEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PrintProgressEventArgs
   Inherits System.EventArgs
C#
public sealed class PrintProgressEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintProgressEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintProgressEventArgs Class Members

[image]
ActiveReports 13
PrintProgressEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventArgs Class

Glossary Item Box

The following tables list the members exposed by PrintProgressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PrintProgressEventArgs Constructor | Initializes a new instance of the PrintProgressEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | CurrentPage | Gets the current printing page number.
Top

See Also

Reference

PrintProgressEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintProgressEventArgs Constructor

[image]
ActiveReports 13
PrintProgressEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintProgressEventArgs Class : PrintProgressEventArgs Constructor

currentPage
The current ptinting page number.

Glossary Item Box

Initializes a new instance of the PrintProgressEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal currentPage As Integer _
)
C#
public PrintProgressEventArgs(
   int currentPage
)

Parameters

currentPage
The current ptinting page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


PrintProgressEventArgs Class Properties

[image]
ActiveReports 13
PrintProgressEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventArgs Class

Glossary Item Box

For a list of all members of this type, see PrintProgressEventArgs members.

Public Properties

 | Name | Description
Public Property | CurrentPage | Gets the current printing page number.
Top

See Also

Reference

PrintProgressEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


CurrentPage Property

[image]
ActiveReports 13
CurrentPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintProgressEventArgs Class : CurrentPage Property

Glossary Item Box

Gets the current printing page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPage As Integer
C#
public int CurrentPage {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


WatermarkOptions Class

[image]
ActiveReports 13
WatermarkOptions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : WatermarkOptions Class

Glossary Item Box

Watermark options

Object Model

WatermarkOptions Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WatermarkOptions
C#
public sealed class WatermarkOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Printing.WatermarkOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


WatermarkOptions Class Members

[image]
ActiveReports 13
WatermarkOptions Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : WatermarkOptions Class

Glossary Item Box

The following tables list the members exposed by WatermarkOptions.

Public Constructors

 | Name | Description
Public Constructor | WatermarkOptions Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | Test rotation angle, degrees, counter-clockwise
Public Property | Color | Color
Public Property | DrawOver | If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content
Public Property | Font | Font
Public Property | Title | Watermark text
Top

See Also

Reference

WatermarkOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


WatermarkOptions Constructor

[image]
ActiveReports 13
WatermarkOptions Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : WatermarkOptions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WatermarkOptions()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


WatermarkOptions Class Properties

[image]
ActiveReports 13
WatermarkOptions Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : WatermarkOptions Class

Glossary Item Box

For a list of all members of this type, see WatermarkOptions members.

Public Properties

 | Name | Description
Public Property | Angle | Test rotation angle, degrees, counter-clockwise
Public Property | Color | Color
Public Property | DrawOver | If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content
Public Property | Font | Font
Public Property | Title | Watermark text
Top

See Also

Reference

WatermarkOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Angle Property

[image]
ActiveReports 13
Angle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Angle Property

Glossary Item Box

Test rotation angle, degrees, counter-clockwise

Syntax

Visual Basic (Declaration)
Public Property Angle As Single
C#
public float Angle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Color Property

[image]
ActiveReports 13
Color Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Color Property

Glossary Item Box

Color

Syntax

Visual Basic (Declaration)
Public Property Color As Color
C#
public Color Color {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


DrawOver Property

[image]
ActiveReports 13
DrawOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : DrawOver Property

Glossary Item Box

If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content

Syntax

Visual Basic (Declaration)
Public Property DrawOver As Boolean
C#
public bool DrawOver {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Font Property

Glossary Item Box

Font

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Title Property

Glossary Item Box

Watermark text

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


PageOrder Enumeration

[image]
ActiveReports 13
PageOrder Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PageOrder Enumeration

Glossary Item Box

Specifies page printing order

Syntax

Visual Basic (Declaration)
Public Enum PageOrder
   Inherits System.Enum
C#
public enum PageOrder : System.Enum

Members

Member | Description
Horizontal | Horizontal order.
HorizontalReversed | Reversed horizontal order.
Vertical | Vertical order.
VerticalReversed | Vertical reversed order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Printing.PageOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Printing Namespace


PageScaling Enumeration

[image]
ActiveReports 13
PageScaling Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PageScaling Enumeration

Glossary Item Box

Specifies page scaling

Syntax

Visual Basic (Declaration)
Public Enum PageScaling
   Inherits System.Enum
C#
public enum PageScaling : System.Enum

Members

Member | Description
Booklet | Booklet mode.
FitToPrintableArea | Mode that scales small pages up and large pages down to fit the paper.
MultiplePages | Multiple pages per sheet mode.
None | No scaling mode.
ShrinkToPrintableArea | Mode that resizes only large pages to fit the paper and prints small pages as they are.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Printing.PageScaling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintAbortedEventHandler Delegate

[image]
ActiveReports 13
PrintAbortedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintAbortedEventHandler Delegate

sender
e

Glossary Item Box

Summary description for Document Events.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintAbortedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public delegate void PrintAbortedEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintAbortedEventHandler Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintingThreadErrorEventHandler Delegate

[image]
ActiveReports 13
PrintingThreadErrorEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventHandler Delegate

sender
e

Glossary Item Box

Summary description for Document Events.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintingThreadErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintingThreadErrorEventArgs _
)
C#
public delegate void PrintingThreadErrorEventHandler(
   object sender,
   PrintingThreadErrorEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingThreadErrorEventHandler Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintProgressEventHandler Delegate

[image]
ActiveReports 13
PrintProgressEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventHandler Delegate

sender
e

Glossary Item Box

Summary description for Document Events.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintProgressEventArgs _
)
C#
public delegate void PrintProgressEventHandler(
   object sender,
   PrintProgressEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintProgressEventHandler Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


GrapeCity.ActiveReports.Export.Excel.DDR Namespace

GrapeCity.ActiveReports.Export.Excel.DDR Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.ActiveReports.Export.Excel.DDR Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


GrapeCity.ActiveReports.Export.Excel.Page Namespace

GrapeCity.ActiveReports.Export.Excel.Page Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.ActiveReports.Export.Excel.Page Namespace

Glossary Item Box

Classes

 | Class | Description
Class | ExcelRenderingExtension | Renders report layout to excel file.
Class | ExcelRenderingExtensionPageSettings | Encapsulates the information necessary to provide Xls document print settings.
Class | ExcelRenderingExtensionSecurity | Encapsulates the information necessary to provide excel document security and encryption.
Class | ExcelRenderingExtensionSettings | Settings class for ExcelRenderingExtension.
Class | ExcelTransformationDevice | Allows for the creation of an excel spreadsheet containing rendered data from a report. Render Page report through RDF.
Class | Settings | Contains the settings used for rendering reports to Excel.

Enumerations

 | Enumeration | Description
Enumeration | ExcelRenderingExtensionPageSettings.PageOrientation | Valid paper orientation values.
Enumeration | ExcelRenderingExtensionPageSettings.PaperSizes | Valid paper size values.

Remarks

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


ExcelRenderingExtension Class

[image]
ActiveReports 13
ExcelRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtension Class

Glossary Item Box

Renders report layout to excel file.

Object Model

ExcelRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExcelRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public sealed class ExcelRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Remarks

In comparison to ExcelTransformationDevice it doesn't use templates and try to obtain layout, not plain data. In comparison to GrapeCity.ActiveReports.Export.Excel.Section.XlsExport it doesn't use any intermediate formats, so output can be more WYSIWYG.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtension Class Members

[image]
ActiveReports 13
ExcelRenderingExtension Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by ExcelRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | ExcelRenderingExtension Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns settings of current ExcelRenderingExtension instance.
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension
Top

See Also

Reference

ExcelRenderingExtension Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtension Constructor

[image]
ActiveReports 13
ExcelRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : ExcelRenderingExtension Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ExcelRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


ExcelRenderingExtension Class Methods

[image]
ActiveReports 13
ExcelRenderingExtension Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtension Class

Glossary Item Box

For a list of all members of this type, see ExcelRenderingExtension members.

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns settings of current ExcelRenderingExtension instance.
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension
Top

See Also

Reference

ExcelRenderingExtension Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


GetSupportedSettings Method

[image]
ActiveReports 13
GetSupportedSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : GetSupportedSettings Method

Glossary Item Box

Returns settings of current ExcelRenderingExtension instance.

Overload List

Overload | Description
GetSupportedSettings() | Gets the supported settings.
GetSupportedSettings(Boolean) | Gets the supported settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


GetSupportedSettings() Method

[image]
ActiveReports 13
GetSupportedSettings() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Gets the supported settings.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings() As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

[image]
ActiveReports 13
GetSupportedSettings(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method

fpl
Is fixed page layout

Glossary Item Box

Gets the supported settings.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings( _
   ByVal fpl As Boolean _
) As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings(
   bool fpl
)

Parameters

fpl
Is fixed page layout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


Render Method

[image]
ActiveReports 13
Render Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : Render Method

Glossary Item Box

Provides the output of the report to the specified rendering extension

Overload List

Overload | Description
Render(IReport,StreamProvider) | Renders the specified report.
Render(IReport,StreamProvider,NameValueCollection) | Renders the specified report.
Render(IReport,StreamProvider,ExcelRenderingExtensionSettings) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


Render(IReport,StreamProvider) Method

[image]
ActiveReports 13
Render(IReport,StreamProvider) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > Render Method : Render(IReport,StreamProvider) Method

report
The report.
streams
The streams.

Glossary Item Box

Renders the specified report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal streams As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider _
)
C#
public void Render(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streams
)

Parameters

report
The report.
streams
The streams.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


Render(IReport,StreamProvider,NameValueCollection) Method

[image]
ActiveReports 13
Render(IReport,StreamProvider,NameValueCollection) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > Render Method : Render(IReport,StreamProvider,NameValueCollection) Method

report
The report.
streamProvider
The stream provider.
settings
The settings.

Glossary Item Box

Renders the specified report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal streamProvider As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection _
)
C#
public void Render(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streamProvider,
   NameValueCollection settings
)

Parameters

report
The report.
streamProvider
The stream provider.
settings
The settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


Render(IReport,StreamProvider,ExcelRenderingExtensionSettings) Method

[image]
ActiveReports 13
Render(IReport,StreamProvider,ExcelRenderingExtensionSettings) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > Render Method : Render(IReport,StreamProvider,ExcelRenderingExtensionSettings) Method

report
streamProvider
settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Render( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal streamProvider As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As ExcelRenderingExtensionSettings _
)
C#
public void Render(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streamProvider,
   ExcelRenderingExtensionSettings settings
)

Parameters

report
streamProvider
settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


ExcelRenderingExtensionPageSettings Class

[image]
ActiveReports 13
ExcelRenderingExtensionPageSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class

Glossary Item Box

Encapsulates the information necessary to provide Xls document print settings.

Object Model

ExcelRenderingExtensionPageSettings Class

Syntax

Visual Basic (Declaration)
Public Class ExcelRenderingExtensionPageSettings
C#
public class ExcelRenderingExtensionPageSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionPageSettings Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionPageSettings Class Members

[image]
ActiveReports 13
ExcelRenderingExtensionPageSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class

Glossary Item Box

The following tables list the members exposed by ExcelRenderingExtensionPageSettings.

Public Properties

 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top

Public Methods

 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

ExcelRenderingExtensionPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionPageSettings Class Methods

[image]
ActiveReports 13
ExcelRenderingExtensionPageSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class

Glossary Item Box

For a list of all members of this type, see ExcelRenderingExtensionPageSettings members.

Public Methods

 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

ExcelRenderingExtensionPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionPageSettings Class : ToString Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionPageSettings Class
ExcelRenderingExtensionPageSettings Members


ExcelRenderingExtensionPageSettings Class Properties

[image]
ActiveReports 13
ExcelRenderingExtensionPageSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class

Glossary Item Box

For a list of all members of this type, see ExcelRenderingExtensionPageSettings members.

Public Properties

 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top

See Also

Reference

ExcelRenderingExtensionPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Orientation Property

[image]
ActiveReports 13
Orientation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionPageSettings Class : Orientation Property

Glossary Item Box

Gets or sets the print orientation of Excel sheet.

Syntax

Visual Basic (Declaration)
Public Property Orientation As ExcelRenderingExtensionPageSettings.PageOrientation
C#
public ExcelRenderingExtensionPageSettings.PageOrientation Orientation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionPageSettings Class
ExcelRenderingExtensionPageSettings Members


PaperSize Property

[image]
ActiveReports 13
PaperSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionPageSettings Class : PaperSize Property

Glossary Item Box

Gets or sets the print paper size of Excel sheet.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As ExcelRenderingExtensionPageSettings.PaperSizes
C#
public ExcelRenderingExtensionPageSettings.PaperSizes PaperSize {get; set;}

Remarks

Reset this property to use default AR document print paper size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionPageSettings Class
ExcelRenderingExtensionPageSettings Members


ExcelRenderingExtensionSecurity Class

[image]
ActiveReports 13
ExcelRenderingExtensionSecurity Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class

Glossary Item Box

Encapsulates the information necessary to provide excel document security and encryption.

Object Model

ExcelRenderingExtensionSecurity Class

Syntax

Visual Basic (Declaration)
Public Class ExcelRenderingExtensionSecurity
C#
public class ExcelRenderingExtensionSecurity

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSecurity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSecurity Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSecurity Class Members

[image]
ActiveReports 13
ExcelRenderingExtensionSecurity Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class

Glossary Item Box

The following tables list the members exposed by ExcelRenderingExtensionSecurity.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top

Public Methods

 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

ExcelRenderingExtensionSecurity Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSecurity Class Methods

[image]
ActiveReports 13
ExcelRenderingExtensionSecurity Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class

Glossary Item Box

For a list of all members of this type, see ExcelRenderingExtensionSecurity members.

Public Methods

 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

ExcelRenderingExtensionSecurity Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : ToString Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ExcelRenderingExtensionSecurity Class Properties

[image]
ActiveReports 13
ExcelRenderingExtensionSecurity Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class

Glossary Item Box

For a list of all members of this type, see ExcelRenderingExtensionSecurity members.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top

See Also

Reference

ExcelRenderingExtensionSecurity Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Password Property

[image]
ActiveReports 13
Password Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : Password Property

Glossary Item Box

Gets or sets the password which can be entered to permit to open Excel document.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ProtectedBy Property

[image]
ActiveReports 13
ProtectedBy Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : ProtectedBy Property

Glossary Item Box

Gets or sets the User Name responsible to password protect the excel spreadsheet.

Syntax

Visual Basic (Declaration)
Public Property ProtectedBy As String
C#
public string ProtectedBy {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ReadOnlyRecommended Property

[image]
ActiveReports 13
ReadOnlyRecommended Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : ReadOnlyRecommended Property

Glossary Item Box

Gets or sets the value to indicate if the Excel file was saved as read only recommended.

Syntax

Visual Basic (Declaration)
Public Property ReadOnlyRecommended As Boolean
C#
public bool ReadOnlyRecommended {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


WritePassword Property

[image]
ActiveReports 13
WritePassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : WritePassword Property

Glossary Item Box

Gets or sets the write password of the Excel file.

Syntax

Visual Basic (Declaration)
Public Property WritePassword As String
C#
public string WritePassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ExcelRenderingExtensionSettings Class

[image]
ActiveReports 13
ExcelRenderingExtensionSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class

Glossary Item Box

Settings class for ExcelRenderingExtension.

Object Model

ExcelRenderingExtensionSettings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExcelRenderingExtensionSettings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public sealed class ExcelRenderingExtensionSettings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSettings Class Members

[image]
ActiveReports 13
ExcelRenderingExtensionSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class

Glossary Item Box

The following tables list the members exposed by ExcelRenderingExtensionSettings.

Public Constructors

 | Name | Description
Public Constructor | ExcelRenderingExtensionSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | EnableToggles | Specifies whether to export toggles from table details or groups to collapsible rows.
Public Property | FileFormat | Indicates whether to use Biff or OpenXml format for the output file. OpenXml is default.
Public Property | MultiSheet | Indicates whether to generate single-sheet or multisheet document.
Public Property | OpenXmlStandard | Open XML conformance level.
Public Property | PageSettings | Returns a ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Force paginated or galley report layout mode.
Public Property | Security | Returns a ExcelRenderingExtensionSecurity object for initializing document security.
Public Property | SheetName | Sets or returns a value indicating the name of sheet. Sheet is default.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format. True by default.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Top

Public Operators

public Operator Implicit Type Conversion Performs an implicit conversion from Settings to System.Collections.Specialized.NameValueCollection.
Top

See Also

Reference

ExcelRenderingExtensionSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSettings Constructor

[image]
ActiveReports 13
ExcelRenderingExtensionSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : ExcelRenderingExtensionSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ExcelRenderingExtensionSettings Constructor() |
ExcelRenderingExtensionSettings Constructor(NameValueCollection) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


ExcelRenderingExtensionSettings Constructor()

[image]
ActiveReports 13
ExcelRenderingExtensionSettings Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class > ExcelRenderingExtensionSettings Constructor : ExcelRenderingExtensionSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ExcelRenderingExtensionSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members
Overload List


ExcelRenderingExtensionSettings Constructor(NameValueCollection)

[image]
ActiveReports 13
ExcelRenderingExtensionSettings Constructor(NameValueCollection)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class > ExcelRenderingExtensionSettings Constructor : ExcelRenderingExtensionSettings Constructor(NameValueCollection)

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal settings As NameValueCollection _
)
C#
public ExcelRenderingExtensionSettings(
   NameValueCollection settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members
Overload List


ExcelRenderingExtensionSettings Class Methods

[image]
ActiveReports 13
ExcelRenderingExtensionSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class

Glossary Item Box

For a list of all members of this type, see ExcelRenderingExtensionSettings members.

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Top

See Also

Reference

ExcelRenderingExtensionSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ApplySettings Method

[image]
ActiveReports 13
ApplySettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : ApplySettings Method

settings
Settings for the rendering extension.

Glossary Item Box

Applies any settings passed in the NameValueCollection settings parameters.

Syntax

Visual Basic (Declaration)
Public Sub ApplySettings( _
   ByVal settings As NameValueCollection _
)
C#
public void ApplySettings(
   NameValueCollection settings
)

Parameters

settings
Settings for the rendering extension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


GetSettings Method

[image]
ActiveReports 13
GetSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : GetSettings Method

Glossary Item Box

Gets the settings for rendering a report to Excel.

Syntax

Visual Basic (Declaration)
Public Function GetSettings() As NameValueCollection
C#
public NameValueCollection GetSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


ExcelRenderingExtensionSettings Class Properties

[image]
ActiveReports 13
ExcelRenderingExtensionSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class

Glossary Item Box

For a list of all members of this type, see ExcelRenderingExtensionSettings members.

Public Properties

 | Name | Description
Public Property | EnableToggles | Specifies whether to export toggles from table details or groups to collapsible rows.
Public Property | FileFormat | Indicates whether to use Biff or OpenXml format for the output file. OpenXml is default.
Public Property | MultiSheet | Indicates whether to generate single-sheet or multisheet document.
Public Property | OpenXmlStandard | Open XML conformance level.
Public Property | PageSettings | Returns a ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Force paginated or galley report layout mode.
Public Property | Security | Returns a ExcelRenderingExtensionSecurity object for initializing document security.
Public Property | SheetName | Sets or returns a value indicating the name of sheet. Sheet is default.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format. True by default.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

See Also

Reference

ExcelRenderingExtensionSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


EnableToggles Property

[image]
ActiveReports 13
EnableToggles Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : EnableToggles Property

Glossary Item Box

Specifies whether to export toggles from table details or groups to collapsible rows.

Syntax

Visual Basic (Declaration)
Public Property EnableToggles As Boolean
C#
public bool EnableToggles {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


FileFormat Property

[image]
ActiveReports 13
FileFormat Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : FileFormat Property

Glossary Item Box

Indicates whether to use Biff or OpenXml format for the output file. OpenXml is default.

Syntax

Visual Basic (Declaration)
Public Property FileFormat As GrapeCity.ActiveReports.Export.Excel.Page.FileFormat
C#
public GrapeCity.ActiveReports.Export.Excel.Page.FileFormat FileFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


MultiSheet Property

[image]
ActiveReports 13
MultiSheet Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : MultiSheet Property

Glossary Item Box

Indicates whether to generate single-sheet or multisheet document.

Syntax

Visual Basic (Declaration)
Public Property MultiSheet As Boolean
C#
public bool MultiSheet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


OpenXmlStandard Property

[image]
ActiveReports 13
OpenXmlStandard Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : OpenXmlStandard Property

Glossary Item Box

Open XML conformance level.

Syntax

Visual Basic (Declaration)
Public Property OpenXmlStandard As GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard
C#
public GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard OpenXmlStandard {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


PageSettings Property

[image]
ActiveReports 13
PageSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : PageSettings Property

Glossary Item Box

Returns a ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSettings As ExcelRenderingExtensionPageSettings
C#
public ExcelRenderingExtensionPageSettings PageSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : Pagination Property

Glossary Item Box

Force paginated or galley report layout mode.

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


Security Property

[image]
ActiveReports 13
Security Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : Security Property

Glossary Item Box

Returns a ExcelRenderingExtensionSecurity object for initializing document security.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Security As ExcelRenderingExtensionSecurity
C#
public ExcelRenderingExtensionSecurity Security {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


SheetName Property

[image]
ActiveReports 13
SheetName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : SheetName Property

Glossary Item Box

Sets or returns a value indicating the name of sheet. Sheet is default.

Syntax

Visual Basic (Declaration)
Public Property SheetName As String
C#
public string SheetName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


UseCompression Property

[image]
ActiveReports 13
UseCompression Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : UseCompression Property

Glossary Item Box

Gets or sets the value indicating should compression be used on exporting with Xlsx file format. True by default.

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
C#
public bool UseCompression {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


UseDefaultPalette Property

[image]
ActiveReports 13
UseDefaultPalette Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : UseDefaultPalette Property

Glossary Item Box

Sets or returns whether export document with Excel default palette.

Syntax

Visual Basic (Declaration)
Public Property UseDefaultPalette As Boolean
C#
public bool UseDefaultPalette {get; set;}

Remarks

Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


Implicit Type Conversion Operator

[image]
ActiveReports 13
Implicit Type Conversion Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : Implicit Type Conversion Operator

settings
The settings.

Glossary Item Box

Performs an implicit conversion from Settings to System.Collections.Specialized.NameValueCollection.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal settings As ExcelRenderingExtensionSettings _
) As NameValueCollection
C#
public NameValueCollection operator implicit(
   ExcelRenderingExtensionSettings settings
)

Parameters

settings
The settings.

Return Value

The result of the conversion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


ExcelTransformationDevice Class

[image]
ActiveReports 13
ExcelTransformationDevice Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class

Glossary Item Box

Allows for the creation of an excel spreadsheet containing rendered data from a report. Render Page report through RDF.

Object Model

ExcelTransformationDevice Class

Syntax

Visual Basic (Declaration)
Public Class ExcelTransformationDevice
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public class ExcelTransformationDevice : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Remarks

Works good with RDL reports, but not good with Page reports. Use ExcelRenderingExtension or GrapeCity.ActiveReports.Export.Excel.Section.XlsExport to export Excel data.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelTransformationDevice Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelTransformationDevice Class Members

[image]
ActiveReports 13
ExcelTransformationDevice Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class

Glossary Item Box

The following tables list the members exposed by ExcelTransformationDevice.

Public Constructors

 | Name | Description
Public Constructor | ExcelTransformationDevice Constructor | Initializes a new instance of ExcelTransformationDevice class.
Top

Public Properties

 | Name | Description
Public Property | TemplateStream | Gets or sets the template as a System.IO.Stream to use for rendering.
Top

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Gets the settings that are supported for rendering a report to Excel.
Top

See Also

Reference

ExcelTransformationDevice Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelTransformationDevice Constructor

[image]
ActiveReports 13
ExcelTransformationDevice Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class : ExcelTransformationDevice Constructor

Glossary Item Box

Initializes a new instance of ExcelTransformationDevice class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ExcelTransformationDevice()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members


ExcelTransformationDevice Class Methods

[image]
ActiveReports 13
ExcelTransformationDevice Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class

Glossary Item Box

For a list of all members of this type, see ExcelTransformationDevice members.

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Gets the settings that are supported for rendering a report to Excel.
Top

See Also

Reference

ExcelTransformationDevice Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


GetSupportedSettings() Method

[image]
ActiveReports 13
GetSupportedSettings() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Gets the settings that are supported for rendering a report to Excel.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings() As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members
Overload List


ExcelTransformationDevice Class Properties

[image]
ActiveReports 13
ExcelTransformationDevice Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class

Glossary Item Box

For a list of all members of this type, see ExcelTransformationDevice members.

Public Properties

 | Name | Description
Public Property | TemplateStream | Gets or sets the template as a System.IO.Stream to use for rendering.
Top

See Also

Reference

ExcelTransformationDevice Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


TemplateStream Property

[image]
ActiveReports 13
TemplateStream Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class : TemplateStream Property

Glossary Item Box

Gets or sets the template as a System.IO.Stream to use for rendering.

Syntax

Visual Basic (Declaration)
Public Property TemplateStream As Stream
C#
public Stream TemplateStream {get; set;}

Remarks

The value of this property will override the Template setting if not null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members


Settings Class

[image]
ActiveReports 13
Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class

Glossary Item Box

Contains the settings used for rendering reports to Excel.

Object Model

Settings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Settings Class Members

[image]
ActiveReports 13
Settings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class

Glossary Item Box

The following tables list the members exposed by Settings.

Public Constructors

 | Name | Description
Public Constructor | Settings Constructor | Allows internal callers to create instances of this class.
Top

Public Properties

 | Name | Description
Public Property | PaperHeight | Gets or sets the height of the paper size that will be set for the output document.
Public Property | PaperWidth | Gets or sets the width of the paper size that will be set for the output document.
Public Property | ProtectWorkbookPassword | Gets or sets the path of the ProtectWorkbookPassword used during the rendering process.
Public Property | ReadOnlyRecommended | Gets or sets the value ReadOnlyRecommended file sharing flag for the saved Excel file.
Public Property | Template | Gets or sets the path of the Template used during the rendering process. Doesn't work with Page reports, only with RDL reports.
static (Shared in Visual Basic) | TemplatePropertyName | Specifies the full path and filename of a Template to use during the rendering process.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Public Method | ToString | Returns a System.String that represents this instance.
Top

Public Operators

public Operator Implicit Type Conversion Performs an implicit conversion from Settings to System.Collections.Specialized.NameValueCollection.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Settings Constructor

[image]
ActiveReports 13
Settings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : Settings Constructor

Glossary Item Box

Allows internal callers to create instances of this class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Settings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Class Methods

[image]
ActiveReports 13
Settings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ApplySettings Method

[image]
ActiveReports 13
ApplySettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ApplySettings Method

settings
A System.Collections.Specialized.NameValueCollection containing new settings.

Glossary Item Box

Applies any settings passed in the NameValueCollection settings parameters.

Syntax

Visual Basic (Declaration)
Public Sub ApplySettings( _
   ByVal settings As NameValueCollection _
)
C#
public void ApplySettings(
   NameValueCollection settings
)

Parameters

settings
A System.Collections.Specialized.NameValueCollection containing new settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


GetSettings Method

[image]
ActiveReports 13
GetSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : GetSettings Method

Glossary Item Box

Gets the settings for rendering a report to Excel.

Syntax

Visual Basic (Declaration)
Public Function GetSettings() As NameValueCollection
C#
public NameValueCollection GetSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Class Properties

[image]
ActiveReports 13
Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Properties

 | Name | Description
Public Property | PaperHeight | Gets or sets the height of the paper size that will be set for the output document.
Public Property | PaperWidth | Gets or sets the width of the paper size that will be set for the output document.
Public Property | ProtectWorkbookPassword | Gets or sets the path of the ProtectWorkbookPassword used during the rendering process.
Public Property | ReadOnlyRecommended | Gets or sets the value ReadOnlyRecommended file sharing flag for the saved Excel file.
Public Property | Template | Gets or sets the path of the Template used during the rendering process. Doesn't work with Page reports, only with RDL reports.
static (Shared in Visual Basic) | TemplatePropertyName | Specifies the full path and filename of a Template to use during the rendering process.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


PaperHeight Property

[image]
ActiveReports 13
PaperHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : PaperHeight Property

Glossary Item Box

Gets or sets the height of the paper size that will be set for the output document.

Syntax

Visual Basic (Declaration)
Public Property PaperHeight As String
C#
public string PaperHeight {get; set;}

Requirements

See Also

Reference

Settings Class
Settings Members


PaperWidth Property

[image]
ActiveReports 13
PaperWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : PaperWidth Property

Glossary Item Box

Gets or sets the width of the paper size that will be set for the output document.

Syntax

Visual Basic (Declaration)
Public Property PaperWidth As String
C#
public string PaperWidth {get; set;}

Requirements

See Also

Reference

Settings Class
Settings Members


ProtectWorkbookPassword Property

[image]
ActiveReports 13
ProtectWorkbookPassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ProtectWorkbookPassword Property

Glossary Item Box

Gets or sets the path of the ProtectWorkbookPassword used during the rendering process.

Syntax

Visual Basic (Declaration)
Public Property ProtectWorkbookPassword As String
C#
public string ProtectWorkbookPassword {get; set;}

Requirements

See Also

Reference

Settings Class
Settings Members


ReadOnlyRecommended Property

[image]
ActiveReports 13
ReadOnlyRecommended Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ReadOnlyRecommended Property

Glossary Item Box

Gets or sets the value ReadOnlyRecommended file sharing flag for the saved Excel file.

Syntax

Visual Basic (Declaration)
Public Property ReadOnlyRecommended As Boolean
C#
public bool ReadOnlyRecommended {get; set;}

Requirements

See Also

Reference

Settings Class
Settings Members


Template Property

[image]
ActiveReports 13
Template Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : Template Property

Glossary Item Box

Gets or sets the path of the Template used during the rendering process. Doesn't work with Page reports, only with RDL reports.

Syntax

Visual Basic (Declaration)
Public Property Template As String
C#
public string Template {get; set;}

Requirements

See Also

Reference

Settings Class
Settings Members


TemplatePropertyName Property

[image]
ActiveReports 13
TemplatePropertyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : TemplatePropertyName Property

Glossary Item Box

Specifies the full path and filename of a Template to use during the rendering process.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TemplatePropertyName As String
C#
public static string TemplatePropertyName {get;}

Requirements

See Also

Reference

Settings Class
Settings Members


UseDefaultPalette Property

[image]
ActiveReports 13
UseDefaultPalette Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : UseDefaultPalette Property

Glossary Item Box

Sets or returns whether export document with Excel default palette.

Syntax

Visual Basic (Declaration)
Public Property UseDefaultPalette As Boolean
C#
public bool UseDefaultPalette {get; set;}

Remarks

Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.

Requirements

See Also

Reference

Settings Class
Settings Members


Implicit Type Conversion Operator

[image]
ActiveReports 13
Implicit Type Conversion Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : Implicit Type Conversion Operator

settings
The rendering extention settings.

Glossary Item Box

Performs an implicit conversion from Settings to System.Collections.Specialized.NameValueCollection.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal settings As Settings _
) As NameValueCollection
C#
public NameValueCollection operator implicit(
   Settings settings
)

Parameters

settings
The rendering extention settings.

Return Value

The result of the conversion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


ExcelRenderingExtensionPageSettings.PageOrientation Enumeration

[image]
ActiveReports 13
ExcelRenderingExtensionPageSettings.PageOrientation Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings.PageOrientation Enumeration

Glossary Item Box

Valid paper orientation values.

Syntax

Visual Basic (Declaration)
Public Enum ExcelRenderingExtensionPageSettings.PageOrientation
   Inherits System.Enum
C#
public enum ExcelRenderingExtensionPageSettings.PageOrientation : System.Enum

Members

Member | Description
Default | Default printer orientation.
Landscape | Landscape orientation.
Portrait | Portrait orientation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings.PageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionPageSettings.PaperSizes Enumeration

[image]
ActiveReports 13
ExcelRenderingExtensionPageSettings.PaperSizes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings.PaperSizes Enumeration

Glossary Item Box

Valid paper size values.

Syntax

Visual Basic (Declaration)
Public Enum ExcelRenderingExtensionPageSettings.PaperSizes
   Inherits System.Enum
C#
public enum ExcelRenderingExtensionPageSettings.PaperSizes : System.Enum

Members

Member | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 extra transverse paper (322 mm by 445 mm).
A3Rotated | A3 rotated paper (420 mm by 297 mm).
A3Transverse | A3 transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 extra paper (236 mm by 322 mm). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 plus paper (210 mm by 330 mm).
A4Rotated | A4 rotated paper (297 mm by 210 mm).
A4Small | A4 small paper (210 mm by 297 mm).
A4Transverse | A4 transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 extra paper (174 mm by 235 mm).
A5Rotated | A5 rotated paper (210 mm by 148 mm).
A5Transverse | A5 transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm).
A6Rotated | A6 rotated paper (148 mm by 105 mm).
APlus | SuperA/SuperA/A4 paper (227 mm by 356 mm).
B4 | B4 paper (250 mm by 353 mm).
B4Envelope | B4 envelope (250 mm by 353 mm).
B4JisRotated | JIS B4 rotated paper (364 mm by 257 mm).
B5 | B5 paper (176 mm by 250 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 extra paper (201 mm by 276 mm).
B5JisRotated | JIS B5 rotated paper (257 mm by 182 mm).
B5Transverse | JIS B5 transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6Jis | JIS B6 paper (128 mm by 182 mm).
B6JisRotated | JIS B6 rotated paper (182 mm by 128 mm).
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 229 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Default | The paper size is defined by the user.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German legal fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German standard fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invitation envelope (220 mm by 220 mm).
IsoB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese double postcard (200 mm by 148 mm).
JapaneseDoublePostcardRotated | Japanese rotated double postcard (148 mm by 200 mm).
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope.
JapaneseEnvelopeChouNumber3Rotated | Japanese rotated Chou #3 envelope.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope.
JapaneseEnvelopeChouNumber4Rotated | Japanese rotated Chou #4 envelope.
JapaneseEnvelopeKakuNumber2 | Japanese Kaku #2 envelope.
JapaneseEnvelopeKakuNumber2Rotated | Japanese rotated Kaku #2 envelope.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope.
JapaneseEnvelopeKakuNumber3Rotated | Japanese rotated Kaku #3 envelope.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope.
JapaneseEnvelopeYouNumber4Rotated | Japanese You #4 rotated envelope.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Japanese rotated postcard (148 mm by 100 mm).
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter extra transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter plus paper (8.5 in. by 12.69 in.).
LetterRotated | Letter rotated paper (11 in. by 8.5 in.).
LetterSmall | Letter small paper (8.5 in. by 11 in.).
LetterTransverse | Letter transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.)
Number11Envelope | #11 envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
Prc16K | People's Republic of China 16K paper (146 mm by 215 mm).
Prc16KRotated | People's Republic of China 16K rotated paper (146 mm by 215 mm).
Prc32K | People's Republic of China 32K paper (97 mm by 151 mm).
Prc32KBig | People's Republic of China 32K big paper (97 mm by 151 mm).
Prc32KBigRotated | People's Republic of China 32K big rotated paper (97 mm by 151 mm).
Prc32KRotated | People's Republic of China 32K rotated paper (97 mm by 151 mm).
PrcEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm).
PrcEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm).
PrcEnvelopeNumber10Rotated | People's Republic of China #10 rotated envelope (458 mm by 324 mm).
PrcEnvelopeNumber1Rotated | People's Republic of China #1 rotated envelope (165 mm by 102 mm).
PrcEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm).
PrcEnvelopeNumber2Rotated | People's Republic of China #2 rotated envelope (176 mm by 102 mm).
PrcEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm).
PrcEnvelopeNumber3Rotated | People's Republic of China #3 rotated envelope (176 mm by 125 mm).
PrcEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm).
PrcEnvelopeNumber4Rotated | People's Republic of China #4 rotated envelope (208 mm by 110 mm).
PrcEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm).
PrcEnvelopeNumber5Rotated | People's Republic of China Envelope #5 rotated envelope (220 mm by 110 mm).
PrcEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm).
PrcEnvelopeNumber6Rotated | People's Republic of China #6 rotated envelope (230 mm by 120 mm).
PrcEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm).
PrcEnvelopeNumber7Rotated | People's Republic of China #7 rotated envelope (230 mm by 160 mm).
PrcEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm).
PrcEnvelopeNumber8Rotated | People's Republic of China #8 rotated envelope (309 mm by 120 mm).
PrcEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm).
PrcEnvelopeNumber9Rotated | People's Republic of China #9 rotated envelope (324 mm by 229 mm).
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | Standard paper (10 in. by 11 in.).
Standard10x14 | Standard paper (10 in. by 14 in.).
Standard11x17 | Standard paper (11 in. by 17 in.).
Standard12x11 | Standard paper (12 in. by 11 in.).
Standard15x11 | Standard paper (15 in. by 11 in.).
Standard9x11 | Standard paper (9 in. by 11 in.).
Statement | Statement paper (5.5 in. by 8.5 in.).
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US standard fanfold (14.875 in. by 11 in.).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings.PaperSizes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Page Namespace


GrapeCity.ActiveReports.Export.Excel.Section Namespace

GrapeCity.ActiveReports.Export.Excel.Section Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.ActiveReports.Export.Excel.Section Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Excel.Section namespace provides Excel Export functionality for ActiveReports for .NET.

Classes

 | Class | Description
Class | XlsExport | Allows ActiveReports documents to be exported to Excel format.
Class | XlsExportException | The exception that is thrown for general exceptions that occur in the ActiveReports.XlsExport assembly.
Class | XlsPageSettings | Encapsulates the information necessary to provide Xls document print settings.
Class | XlsSecurity | Encapsulates the information necessary to provide excel document security and encryption.

Enumerations

 | Enumeration | Description
Enumeration | FileFormat | An enumeration of values which specify the file format that the exported file should support.
Enumeration | OpenXmlStandard | Specifies the level of Open XML document conformance on exporting with Xlsx file format.
Enumeration | PaperSizes | Specifies the standard paper sizes.

Remarks

Any public static members of this type (Shared in Visual Basic) are safe for multi-threaded operations. However, instance members are not guaranteed to be thread safe. For example, changing a property value in one thread while an Export method is running in a separate thread could yield unexpected results.

Optimizing your report for exporting to Excel:
Since Excel is basically a table of rows and columns and ActiveReports is a free form type output, it may be necessary to “optimize” your ActiveReport for Excel exporting. When you want two controls to be in the same column when exported to Excel, it is imperative that the two controls have exactly the same Left property value. It may also help to ensure that the font of the two controls is the same. Attempting to make the height of the two controls similar will often times lead to a cleaner looking output in Excel. Similarly if you want two controls to be in the same row when exported to Excel, you should make sure that the two controls have exactly the same Top value, that their font is the same, and that their width is similar if not the same. Using RichText controls in your ActiveReports often results in poorly formatted output in Excel. Using the Page object's drawing methods to draw anything in the margin areas of the export will cause pagination problems. To keep the pagination accurate when printing Excel-exported output with items drawn on the page, do not draw them in the margin area.

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


XlsExport Class

[image]
ActiveReports 13
XlsExport Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

Glossary Item Box

Allows ActiveReports documents to be exported to Excel format.

Object Model

XlsExport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XlsExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
C#
public sealed class XlsExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx

Remarks

Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe. For example changing a property value in one thread while an Export method is running in a separate thread could yield unexpected results.

Optimizing your report for exporting to Excel:
Since Excel is basically a table of rows and columns, and ActiveReports is a free form type output it may be necessary to “optimize?your ActiveReport for Excel exporting. When you want two controls to be in the same column when outputted to excel it is imperative that the two controls have *exactly* the same left value. And it may also help to ensure that the font of the two controls is the same. Attempting to make the height of the two controls similar will often times lead to a cleaner looking output in excel. Similarly if you want two controls to be in the same row when outputted to Excel, you should make sure the two controls have exactly the same Top value, that their font is the same, and that their width is similar if not the same. Using RichText controls on your ActiveReports will often will not have good output in Excel. Using the Page object's drawing methods to draw anything in the margin areas of the export will cause pagination problems. If you draw items on the page, do not draw them in the margin area to keep the pagination accurate when printing excel exported output.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExport Class Members

[image]
ActiveReports 13
XlsExport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

Glossary Item Box

The following tables list the members exposed by XlsExport.

Public Constructors

 | Name | Description
Public Constructor | XlsExport Constructor | Initializes a new instance of the XlsExport class.
Top

Public Properties

 | Name | Description
Public Property | AutoRowHeight | Sets or returns a value indicating whether Excel should set the height of the row based on the contents of that row.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DisplayGridLines | Sets or returns a value indicating whether grid lines in a workbook are displayed.
Public Property | FileFormat | Sets or returns a value indicating which file format version the exported file should support.
Public Property | MinColumnWidth | Sets or returns a value in inches indicating how small columns can be in the Excel document. Larger values reduce number of columns in a sheet.
Public Property | MinRowHeight | Sets or returns a value in inches indicating the minimum height rows can be in the Excel document. Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space.
Public Property | MultiSheet | Sets or returns a value indicating whether each page is to be exported to its own sheet. True indicates that each page in the ActiveReports document will be exported to a separate sheet.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | PageSettings | Returns a XlsPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Gets or sets the value indicates should pagination be used for resulted xls document or not
Public Property | RemoveVerticalSpace | Sets or returns a value that indicates whether completely empty vertical spacing will be removed from the output.
Public Property | Security | Returns a XlsSecurity object for initializing document security.
Public Property | SheetName | Sets or returns a value indicating the name of sheet. Sheet is default.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | UseCellMerging | Sets or returns a value indicating whether cells should be merged together where applicable.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to Excel format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExport Constructor

[image]
ActiveReports 13
XlsExport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : XlsExport Constructor

Glossary Item Box

Initializes a new instance of the XlsExport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public XlsExport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


XlsExport Class Methods

[image]
ActiveReports 13
XlsExport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

Glossary Item Box

For a list of all members of this type, see XlsExport members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to Excel format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Export Method

Glossary Item Box

Exports the specified document to Excel format.

Overload List

Overload | Description
Export(PageDocument,String) | Exports the specified document to a .xls file.
Export(PageDocument,String,String) | Exports the specified page document to Excel.
Export(PageDocument,Stream) | Exports the specified page document to Excel.
Export(PageDocument,Stream,String) | Exports the specified document to Excel.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String) | Exports the specified document to an Excel file.
Export(SectionDocument,String,String) | Exports the specified range of pages in a document to an Excel file.
Export(SectionDocument,Stream) | Exports the specified document to a stream in Excel format.
Export(SectionDocument,Stream,String) | Exports the specified range of pages in a document to a stream in Excel format.

Remarks

Only when the output on the report is valid for the following conditions, the format settings of the cells exported to Excel are set automatically.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    rptExports rpt = new rptExports();
    this.viewer1.Document = rpt.Document;
    rpt.Run(false);

    xlsExport1.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
}
VB.NET Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptExports()
    Viewer1.Document = rpt.Document
    rpt.Run(False)

    XlsExport1.Export(rpt.Document, Application.StartupPath + "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


Export(PageDocument,String) Method

[image]
ActiveReports 13
Export(PageDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,String) Method

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main .xls file to.

Glossary Item Box

Exports the specified document to a .xls file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   PageDocument document,
   string filePath
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main .xls file to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(PageDocument,String,String) Method

[image]
ActiveReports 13
Export(PageDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,String,String) Method

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main .xls file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified page document to Excel.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main .xls file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(PageDocument,Stream) Method

[image]
ActiveReports 13
Export(PageDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,Stream) Method

document
The ActiveReports Document object to export.
stream
The Stream to write the Excel workbook to.

Glossary Item Box

Exports the specified page document to Excel.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream _
)
C#
public void Export(
   PageDocument document,
   Stream stream
)

Parameters

document
The ActiveReports Document object to export.
stream
The Stream to write the Excel workbook to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(PageDocument,Stream,String) Method

[image]
ActiveReports 13
Export(PageDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,Stream,String) Method

document
The ActiveReports Document object to export.
stream
The Stream to write the Excel workbook to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified document to Excel.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   Stream stream,
   string pageRange
)

Parameters

document
The ActiveReports Document object to export.
stream
The Stream to write the Excel workbook to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,String,String) Method

[image]
ActiveReports 13
Export(IReport,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,String,String) Method

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath,
   string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,String) Method

[image]
ActiveReports 13
Export(IReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,String) Method

report
IReport instance to Export
filePath
Path to export

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,Stream) Method

[image]
ActiveReports 13
Export(IReport,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,Stream) Method

report
IReport instance to Export
outputStream
The output stream.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,Stream,String) Method

[image]
ActiveReports 13
Export(IReport,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,Stream,String) Method

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream,
   string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,String) Method

document
The ActiveReports object to export.
filePath
The file name and path to which to save the spreadsheet.

Glossary Item Box

Exports the specified document to an Excel file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the spreadsheet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,String,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,String,String) Method

document
The ActiveReports object to export.
filePath
The file name and path to which to save the spreadsheet.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages in a document to an Excel file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the spreadsheet.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,Stream) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,Stream) Method

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.

Glossary Item Box

Exports the specified document to a stream in Excel format.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,Stream,String) Method

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages in a document to a stream in Excel format.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream,
   string pageRange
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


XlsExport Class Properties

[image]
ActiveReports 13
XlsExport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

Glossary Item Box

For a list of all members of this type, see XlsExport members.

Public Properties

 | Name | Description
Public Property | AutoRowHeight | Sets or returns a value indicating whether Excel should set the height of the row based on the contents of that row.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DisplayGridLines | Sets or returns a value indicating whether grid lines in a workbook are displayed.
Public Property | FileFormat | Sets or returns a value indicating which file format version the exported file should support.
Public Property | MinColumnWidth | Sets or returns a value in inches indicating how small columns can be in the Excel document. Larger values reduce number of columns in a sheet.
Public Property | MinRowHeight | Sets or returns a value in inches indicating the minimum height rows can be in the Excel document. Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space.
Public Property | MultiSheet | Sets or returns a value indicating whether each page is to be exported to its own sheet. True indicates that each page in the ActiveReports document will be exported to a separate sheet.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | PageSettings | Returns a XlsPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Gets or sets the value indicates should pagination be used for resulted xls document or not
Public Property | RemoveVerticalSpace | Sets or returns a value that indicates whether completely empty vertical spacing will be removed from the output.
Public Property | Security | Returns a XlsSecurity object for initializing document security.
Public Property | SheetName | Sets or returns a value indicating the name of sheet. Sheet is default.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | UseCellMerging | Sets or returns a value indicating whether cells should be merged together where applicable.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


AutoRowHeight Property

[image]
ActiveReports 13
AutoRowHeight Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : AutoRowHeight Property

Glossary Item Box

Sets or returns a value indicating whether Excel should set the height of the row based on the contents of that row.

Syntax

Visual Basic (Declaration)
Public Property AutoRowHeight As Boolean
C#
public bool AutoRowHeight {get; set;}

Property Value

Boolean. Set to True if Excel should set the height of the row based on the contents of that row. Otherwise the XlsExport will calculate the height of the rows. In some cases this may make the output look better inside Excel. However, a value of True may adversely affect pagination when printing from Excel, as it will often cause Excel to stretch the height of the page. The default value is False.

Remarks

This property should usually not be set to True when the UseCellMerging property is True.

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


DisplayGridLines Property

[image]
ActiveReports 13
DisplayGridLines Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : DisplayGridLines Property

Glossary Item Box

Sets or returns a value indicating whether grid lines in a workbook are displayed.

Syntax

Visual Basic (Declaration)
Public Property DisplayGridLines As Boolean
C#
public bool DisplayGridLines {get; set;}

Property Value

Boolean. The default value is True.

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


FileFormat Property

[image]
ActiveReports 13
FileFormat Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : FileFormat Property

Glossary Item Box

Sets or returns a value indicating which file format version the exported file should support.

Syntax

Visual Basic (Declaration)
Public Property FileFormat As FileFormat
C#
public FileFormat FileFormat {get; set;}

Property Value

FileFormat enumeration. The default value is Xls97Plus.

Example

Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members
FileFormat Enumeration


MinColumnWidth Property

[image]
ActiveReports 13
MinColumnWidth Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : MinColumnWidth Property

Glossary Item Box

Sets or returns a value in inches indicating how small columns can be in the Excel document. Larger values reduce number of columns in a sheet.

Syntax

Visual Basic (Declaration)
Public Property MinColumnWidth As Single
C#
public float MinColumnWidth {get; set;}

Property Value

Single. The default value is 0.1.

Remarks

This is typically the single most important variable to tweak when exporting to Excel.

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


MinRowHeight Property

[image]
ActiveReports 13
MinRowHeight Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : MinRowHeight Property

Glossary Item Box

Sets or returns a value in inches indicating the minimum height rows can be in the Excel document. Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space.

Syntax

Visual Basic (Declaration)
Public Property MinRowHeight As Single
C#
public float MinRowHeight {get; set;}

Property Value

Single. The default value is 0.1.

Remarks

The MinRowHeight property takes effect only if the UseCellMerging property is set to True.

Example

Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


MultiSheet Property

[image]
ActiveReports 13
MultiSheet Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : MultiSheet Property

Glossary Item Box

Sets or returns a value indicating whether each page is to be exported to its own sheet. True indicates that each page in the ActiveReports document will be exported to a separate sheet.

Syntax

Visual Basic (Declaration)
Public Property MultiSheet As Boolean
C#
public bool MultiSheet {get; set;}

Property Value

Boolean. The default value is False.

Remarks

Setting this value to True can often increase performance and output quality at the cost of memory consumption up to a certain number of pages. The more complex the pages and the more deviation between page layouts in a single document, the lower the number of pages that should be exported to a single sheet. The complicity and deviation of layout between the pages drastically effects this number, but in general, a report with more than 30 pages would be a good candidate for setting this property to False.

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


OpenXmlStandard Property

[image]
ActiveReports 13
OpenXmlStandard Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : OpenXmlStandard Property

Glossary Item Box

Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.

Syntax

Visual Basic (Declaration)
Public Property OpenXmlStandard As OpenXmlStandard
C#
public OpenXmlStandard OpenXmlStandard {get; set;}

Remarks

The Open XML SDK saves the xlsx document in Strict standard. Use this property to convert the xlsx file to the Transitional standard for applications that cannot read the xlsx file.

Example

C# Copy Code
SectionReport1 rpt = new SectionReport1();
GrapeCity.ActiveReports.Document.SectionDocument doc = new GrapeCity.ActiveReports.Document.SectionDocument();
doc.Pages.Add(new GrapeCity.ActiveReports.Document.Section.Page());
XlsExport export = new XlsExport();
export.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx;
export.OpenXmlStandard = GrapeCity.ActiveReports.Export.Excel.Section.OpenXmlStandard.Transitional;
Stream stream = new MemoryStream();
export.Export(rpt.Document, stream);
VB.NET Copy Code
Dim rpt As New SectionReport1()
Dim doc As New GrapeCity.ActiveReports.Document.SectionDocument()
doc.Pages.Add(New GrapeCity.ActiveReports.Document.Section.Page())
Dim export As New XlsExport()
export.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx
export.OpenXmlStandard = GrapeCity.ActiveReports.Export.Excel.Section.OpenXmlStandard.Transitional
Dim stream As Stream = New MemoryStream()
export.Export(rpt.Document, stream)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


PageSettings Property

[image]
ActiveReports 13
PageSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : PageSettings Property

Glossary Item Box

Returns a XlsPageSettings object for initializing Excel file print setting.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSettings As XlsPageSettings
C#
public XlsPageSettings PageSettings {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Pagination Property

Glossary Item Box

Gets or sets the value indicates should pagination be used for resulted xls document or not

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


RemoveVerticalSpace Property

[image]
ActiveReports 13
RemoveVerticalSpace Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : RemoveVerticalSpace Property

Glossary Item Box

Sets or returns a value that indicates whether completely empty vertical spacing will be removed from the output.

Syntax

Visual Basic (Declaration)
Public Property RemoveVerticalSpace As Boolean
C#
public bool RemoveVerticalSpace {get; set;}

Property Value

Boolean. The default value is False.

Remarks

This may improve pagination if you wish to print the output from Excel.

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


Security Property

[image]
ActiveReports 13
Security Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Security Property

Glossary Item Box

Returns a XlsSecurity object for initializing document security.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Security As XlsSecurity
C#
public XlsSecurity Security {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


SheetName Property

[image]
ActiveReports 13
SheetName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : SheetName Property

Glossary Item Box

Sets or returns a value indicating the name of sheet. Sheet is default.

Syntax

Visual Basic (Declaration)
Public Property SheetName As String
C#
public string SheetName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


UseCellMerging Property

[image]
ActiveReports 13
UseCellMerging Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : UseCellMerging Property

Glossary Item Box

Sets or returns a value indicating whether cells should be merged together where applicable.

Syntax

Visual Basic (Declaration)
Public Property UseCellMerging As Boolean
C#
public bool UseCellMerging {get; set;}

Property Value

Boolean. The default value is False.

Remarks

Since Excel95 does not support cell merging this property is not applicable when Version is set to Excel 95.

Example

Visual Basic Copy Code
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
C# Copy Code
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


UseCompression Property

[image]
ActiveReports 13
UseCompression Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : UseCompression Property

Glossary Item Box

Gets or sets the value indicating should compression be used on exporting with Xlsx file format.

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
C#
public bool UseCompression {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


UseDefaultPalette Property

[image]
ActiveReports 13
UseDefaultPalette Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : UseDefaultPalette Property

Glossary Item Box

Sets or returns whether export document with Excel default palette.

Syntax

Visual Basic (Declaration)
Public Property UseDefaultPalette As Boolean
C#
public bool UseDefaultPalette {get; set;}

Remarks

Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


XlsExportException Class

[image]
ActiveReports 13
XlsExportException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class

Glossary Item Box

The exception that is thrown for general exceptions that occur in the ActiveReports.XlsExport assembly.

Object Model

XlsExportException Class

Syntax

Visual Basic (Declaration)
Public Class XlsExportException
   Inherits System.ApplicationException
C#
public class XlsExportException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Excel.Section.XlsExportException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Class Members

[image]
ActiveReports 13
XlsExportException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class

Glossary Item Box

The following tables list the members exposed by XlsExportException.

Public Constructors

 | Name | Description
Public Constructor | XlsExportException Constructor | Overloaded. Initializes a new instance of the ExcelExportException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

XlsExportException Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Constructor

[image]
ActiveReports 13
XlsExportException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : XlsExportException Constructor

Glossary Item Box

Initializes a new instance of the ExcelExportException class.

Overload List

Overload | Description
XlsExportException Constructor(String) | Initializes a new instance of the ExcelExportException class with a specified error message.
XlsExportException Constructor(String,Exception) | Initializes a new instance of the XlsExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
XlsExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the ExcelExportException class with serialized data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


XlsExportException Constructor(String)

[image]
ActiveReports 13
XlsExportException Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class > XlsExportException Constructor : XlsExportException Constructor(String)

message
A message that describes the error.

Glossary Item Box

Initializes a new instance of the ExcelExportException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public XlsExportException(
   string message
)

Parameters

message
A message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members
Overload List


XlsExportException Constructor(String,Exception)

[image]
ActiveReports 13
XlsExportException Constructor(String,Exception)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class > XlsExportException Constructor : XlsExportException Constructor(String,Exception)

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the XlsExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public XlsExportException(
   string message,
   Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members
Overload List


XlsExportException Constructor(SerializationInfo,StreamingContext)

[image]
ActiveReports 13
XlsExportException Constructor(SerializationInfo,StreamingContext)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class > XlsExportException Constructor : XlsExportException Constructor(SerializationInfo,StreamingContext)

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Glossary Item Box

Initializes a new instance of the ExcelExportException class with serialized data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public XlsExportException(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Remarks

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members
Overload List


XlsPageSettings Class

[image]
ActiveReports 13
XlsPageSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class

Glossary Item Box

Encapsulates the information necessary to provide Xls document print settings.

Object Model

XlsPageSettings Class

Syntax

Visual Basic (Declaration)
Public Class XlsPageSettings
C#
public class XlsPageSettings

Remarks

If you want to use default AR document print settings, you should Reset the properties on ProperGrid or invoke Reset() method.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Section.XlsPageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsPageSettings Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsPageSettings Class Members

[image]
ActiveReports 13
XlsPageSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class

Glossary Item Box

The following tables list the members exposed by XlsPageSettings.

Public Properties

 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top

Public Methods

 | Name | Description
Public Method | Reset | Reset the properties of XlsPageSettings class.
Top

See Also

Reference

XlsPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsPageSettings Class Methods

[image]
ActiveReports 13
XlsPageSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class

Glossary Item Box

For a list of all members of this type, see XlsPageSettings members.

Public Methods

 | Name | Description
Public Method | Reset | Reset the properties of XlsPageSettings class.
Top

See Also

Reference

XlsPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Reset Method

[image]
ActiveReports 13
Reset Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsPageSettings Class : Reset Method

Glossary Item Box

Reset the properties of XlsPageSettings class.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsPageSettings Class
XlsPageSettings Members


XlsPageSettings Class Properties

[image]
ActiveReports 13
XlsPageSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class

Glossary Item Box

For a list of all members of this type, see XlsPageSettings members.

Public Properties

 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top

See Also

Reference

XlsPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Orientation Property

[image]
ActiveReports 13
Orientation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsPageSettings Class : Orientation Property

Glossary Item Box

Gets or sets the print orientation of Excel sheet.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
C#
public PageOrientation Orientation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsPageSettings Class
XlsPageSettings Members


PaperSize Property

[image]
ActiveReports 13
PaperSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsPageSettings Class : PaperSize Property

Glossary Item Box

Gets or sets the print paper size of Excel sheet.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As PaperSizes
C#
public PaperSizes PaperSize {get; set;}

Remarks

Reset this property to use default AR document print paper size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsPageSettings Class
XlsPageSettings Members


XlsSecurity Class

[image]
ActiveReports 13
XlsSecurity Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsSecurity Class

Glossary Item Box

Encapsulates the information necessary to provide excel document security and encryption.

Object Model

XlsSecurity Class

Syntax

Visual Basic (Declaration)
Public Class XlsSecurity
C#
public class XlsSecurity

Remarks

If a WritePassword or a Password is supplied the Excel application will prompt for a write or open access password. If a WritePassword or a Password is not supplied no password will be requested to open the document. By correctly supplying the Password, the user will be able to open the document. By correctly supplying the WritePassword, the user will be able to write the document. If the read only recommended is set to true, the Excel application will prompt user whether to open document as read-only.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Section.XlsSecurity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsSecurity Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsSecurity Class Members

[image]
ActiveReports 13
XlsSecurity Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsSecurity Class

Glossary Item Box

The following tables list the members exposed by XlsSecurity.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top

See Also

Reference

XlsSecurity Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsSecurity Class Properties

[image]
ActiveReports 13
XlsSecurity Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsSecurity Class

Glossary Item Box

For a list of all members of this type, see XlsSecurity members.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top

See Also

Reference

XlsSecurity Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Password Property

[image]
ActiveReports 13
Password Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : Password Property

Glossary Item Box

Gets or sets the password which can be entered to permit to open Excel document.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsSecurity Class
XlsSecurity Members


ProtectedBy Property

[image]
ActiveReports 13
ProtectedBy Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : ProtectedBy Property

Glossary Item Box

Gets or sets the User Name responsible to password protect the excel spreadsheet.

Syntax

Visual Basic (Declaration)
Public Property ProtectedBy As String
C#
public string ProtectedBy {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsSecurity Class
XlsSecurity Members


ReadOnlyRecommended Property

[image]
ActiveReports 13
ReadOnlyRecommended Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : ReadOnlyRecommended Property

Glossary Item Box

Gets or sets the value to indicate if the Excel file was saved as read only recommended.

Syntax

Visual Basic (Declaration)
Public Property ReadOnlyRecommended As Boolean
C#
public bool ReadOnlyRecommended {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsSecurity Class
XlsSecurity Members


WritePassword Property

[image]
ActiveReports 13
WritePassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : WritePassword Property

Glossary Item Box

Gets or sets the write password of the Excel file.

Syntax

Visual Basic (Declaration)
Public Property WritePassword As String
C#
public string WritePassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsSecurity Class
XlsSecurity Members


FileFormat Enumeration

[image]
ActiveReports 13
FileFormat Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : FileFormat Enumeration

Glossary Item Box

An enumeration of values which specify the file format that the exported file should support.

Syntax

Visual Basic (Declaration)
Public Enum FileFormat
   Inherits System.Enum
C#
public enum FileFormat : System.Enum

Members

Member | Description
Xls95 | Microsoft Excel 95 format.
Xls97Plus | Optimized for Microsoft Excel 97 and newer versions.
Xlsx | Microsoft Excel OpenXml format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Section.FileFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Section Namespace


OpenXmlStandard Enumeration

[image]
ActiveReports 13
OpenXmlStandard Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : OpenXmlStandard Enumeration

Glossary Item Box

Specifies the level of Open XML document conformance on exporting with Xlsx file format.

Syntax

Visual Basic (Declaration)
Public Enum OpenXmlStandard
   Inherits System.Enum
C#
public enum OpenXmlStandard : System.Enum

Members

Member | Description
Strict | ISO/IEC 29500 Strict.
Transitional | ISO/IEC 29500 Transitional.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Section.OpenXmlStandard

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Section Namespace


PaperSizes Enumeration

[image]
ActiveReports 13
PaperSizes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : PaperSizes Enumeration

Glossary Item Box

Specifies the standard paper sizes.

Syntax

Visual Basic (Declaration)
Public Enum PaperSizes
   Inherits System.Enum
C#
public enum PaperSizes : System.Enum

Members

Member | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 extra transverse paper (322 mm by 445 mm).
A3Rotated | A3 rotated paper (420 mm by 297 mm).
A3Transverse | A3 transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 extra paper (236 mm by 322 mm). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 plus paper (210 mm by 330 mm).
A4Rotated | A4 rotated paper (297 mm by 210 mm).
A4Small | A4 small paper (210 mm by 297 mm).
A4Transverse | A4 transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 extra paper (174 mm by 235 mm).
A5Rotated | A5 rotated paper (210 mm by 148 mm).
A5Transverse | A5 transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm).
A6Rotated | A6 rotated paper (148 mm by 105 mm).
APlus | SuperA/SuperA/A4 paper (227 mm by 356 mm).
B4 | B4 paper (250 mm by 353 mm).
B4Envelope | B4 envelope (250 mm by 353 mm).
B4JisRotated | JIS B4 rotated paper (364 mm by 257 mm).
B5 | B5 paper (176 mm by 250 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 extra paper (201 mm by 276 mm).
B5JisRotated | JIS B5 rotated paper (257 mm by 182 mm).
B5Transverse | JIS B5 transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6Jis | JIS B6 paper (128 mm by 182 mm).
B6JisRotated | JIS B6 rotated paper (182 mm by 128 mm).
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 229 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Default | No specific paper.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German legal fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German standard fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invitation envelope (220 mm by 220 mm).
IsoB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese double postcard (200 mm by 148 mm).
JapaneseDoublePostcardRotated | Japanese rotated double postcard (148 mm by 200 mm).
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope.
JapaneseEnvelopeChouNumber3Rotated | Japanese rotated Chou #3 envelope.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope.
JapaneseEnvelopeChouNumber4Rotated | Japanese rotated Chou #4 envelope.
JapaneseEnvelopeKakuNumber2 | Japanese Kaku #2 envelope.
JapaneseEnvelopeKakuNumber2Rotated | Japanese rotated Kaku #2 envelope.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope.
JapaneseEnvelopeKakuNumber3Rotated | Japanese rotated Kaku #3 envelope.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope.
JapaneseEnvelopeYouNumber4Rotated | Japanese You #4 rotated envelope.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Japanese rotated postcard (148 mm by 100 mm).
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter extra transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter plus paper (8.5 in. by 12.69 in.).
LetterRotated | Letter rotated paper (11 in. by 8.5 in.).
LetterSmall | Letter small paper (8.5 in. by 11 in.).
LetterTransverse | Letter transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.).
Number11Envelope | #11 envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
Prc16K | People's Republic of China 16K paper (146 mm by 215 mm).
Prc16KRotated | People's Republic of China 16K rotated paper (146 mm by 215 mm).
Prc32K | People's Republic of China 32K paper (97 mm by 151 mm).
Prc32KBig | People's Republic of China 32K big paper (97 mm by 151 mm).
Prc32KBigRotated | People's Republic of China 32K big rotated paper (97 mm by 151 mm).
Prc32KRotated | People's Republic of China 32K rotated paper (97 mm by 151 mm).
PrcEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm).
PrcEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm).
PrcEnvelopeNumber10Rotated | People's Republic of China #10 rotated envelope (458 mm by 324 mm).
PrcEnvelopeNumber1Rotated | People's Republic of China #1 rotated envelope (165 mm by 102 mm).
PrcEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm).
PrcEnvelopeNumber2Rotated | People's Republic of China #2 rotated envelope (176 mm by 102 mm).
PrcEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm).
PrcEnvelopeNumber3Rotated | People's Republic of China #3 rotated envelope (176 mm by 125 mm).
PrcEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm).
PrcEnvelopeNumber4Rotated | People's Republic of China #4 rotated envelope (208 mm by 110 mm).
PrcEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm).
PrcEnvelopeNumber5Rotated | People's Republic of China Envelope #5 rotated envelope (220 mm by 110 mm).
PrcEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm).
PrcEnvelopeNumber6Rotated | People's Republic of China #6 rotated envelope (230 mm by 120 mm).
PrcEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm).
PrcEnvelopeNumber7Rotated | People's Republic of China #7 rotated envelope (230 mm by 160 mm).
PrcEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm).
PrcEnvelopeNumber8Rotated | People's Republic of China #8 rotated envelope (309 mm by 120 mm).
PrcEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm).
PrcEnvelopeNumber9Rotated | People's Republic of China #9 rotated envelope (324 mm by 229 mm).
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | Standard paper (10 in. by 11 in.).
Standard10x14 | Standard paper (10 in. by 14 in.).
Standard11x17 | Standard paper (11 in. by 17 in.).
Standard12x11 | Standard paper (12 in. by 11 in.).
Standard15x11 | Standard paper (15 in. by 11 in.).
Standard9x11 | Standard paper (9 in. by 11 in.).
Statement | Statement paper (5.5 in. by 8.5 in.).
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US standard fanfold (14.875 in. by 11 in.).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Section.PaperSizes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Section Namespace


GrapeCity.SpreadBuilder Namespace

GrapeCity.SpreadBuilder Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder Namespace

Glossary Item Box

The GrapeCity.SpreadBuilder namespace contains the Column, Row, Sheet and Workbook classes used for building Excel spreadsheets.

Classes

 | Class | Description
Class | ColumnCountOutOfRangeException | Thrown when the columns' count is out of range in a specific excel format.
Class | CompressionException | Indicates that an error (most likely related to images) occurred in the compression library.
Class | DDColumn | Represents a column in a spreadsheet.
Class | DDRow | Represents a single row in a sheet.
Class | DDSecurity | Encapsulates the information necessary to provide spreadsheet document security and encryption.
Class | DDSheet | Represents an Excel worksheet.
Class | DDSheetNameAlreadyExistsException | Thrown when you try to set a Name property to a value already in use.
Class | DDSheets | A collection of DDSheet objects.
Class | EncryptedOpenXmlTools | The tool class for encrypting OpenXml format and exporting it. Can find the spec in [MS-OFFCRYPTO].
Class | InvalidDDSheetNameException | Thrown when change a sheet's name to an invalid value. The name cannot be empty, cannot exceed 31 characters and cannot contain any of following characters: : \ / ? * [ or ]
Class | InvalidPasswordException | Thrown when the password is invalid in a specific excel format.(For example: the length of password is out of range.)
Class | NoDDSheetsException | Thrown when an operation is requested that requires at least one sheet in the Sheets collection (for example Saving the workbook) and no sheets exist.
Class | RowCountOutOfRangeException | Thrown when the rows' count is out of range in a specific excel format.
Class | SpreadBuilderException | A general exception thrown for application errors in the GrapeCity.SpreadBuilder assembly.
Class | VersionNotImplementedException | Indicates that a feature or features were not implemented for a particular version of the Excel/BIFF file format.
Class | Workbook | Represents a workbook that contains spreadsheets. This object presents information that is relevant to all spreadsheets in the workbook (e.g. Author, BIFF/file version, etc.).

Enumerations

 | Enumeration | Description
Enumeration | FileFormat | Specifies the file format that the outputted file should support.

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


ColumnCountOutOfRangeException Class

[image]
ActiveReports 13
ColumnCountOutOfRangeException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class

Glossary Item Box

Thrown when the columns' count is out of range in a specific excel format.

Object Model

ColumnCountOutOfRangeException Class

Syntax

Visual Basic (Declaration)
Public Class ColumnCountOutOfRangeException
   Inherits SpreadBuilderException
C#
public class ColumnCountOutOfRangeException : SpreadBuilderException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.ColumnCountOutOfRangeException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Members
GrapeCity.SpreadBuilder Namespace


ColumnCountOutOfRangeException Class Members

[image]
ActiveReports 13
ColumnCountOutOfRangeException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class

Glossary Item Box

The following tables list the members exposed by ColumnCountOutOfRangeException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ColumnCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


CompressionException Class

[image]
ActiveReports 13
CompressionException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class

Glossary Item Box

Indicates that an error (most likely related to images) occurred in the compression library.

Object Model

CompressionException Class

Syntax

Visual Basic (Declaration)
Public Class CompressionException
   Inherits SpreadBuilderException
C#
public class CompressionException : SpreadBuilderException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.CompressionException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Members
GrapeCity.SpreadBuilder Namespace


CompressionException Class Members

[image]
ActiveReports 13
CompressionException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class

Glossary Item Box

The following tables list the members exposed by CompressionException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CompressionException Class
GrapeCity.SpreadBuilder Namespace


DDColumn Class

[image]
ActiveReports 13
DDColumn Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDColumn Class

Glossary Item Box

Represents a column in a spreadsheet.

Object Model

DDColumn Class

Syntax

Visual Basic (Declaration)
Public Class DDColumn
C#
public class DDColumn

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDColumn Members
GrapeCity.SpreadBuilder Namespace


DDColumn Class Members

[image]
ActiveReports 13
DDColumn Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDColumn Class

Glossary Item Box

The following tables list the members exposed by DDColumn.

Public Properties

 | Name | Description
Public Property | Column | Returns the zero-based column number that this object represents.
Public Property | OwnerSheet | Returns the sheet on which this column is located.
Public Property | Width | Sets or returns the width of the column in Twips.
Top

See Also

Reference

DDColumn Class
GrapeCity.SpreadBuilder Namespace


DDColumn Class Properties

[image]
ActiveReports 13
DDColumn Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDColumn Class

Glossary Item Box

For a list of all members of this type, see DDColumn members.

Public Properties

 | Name | Description
Public Property | Column | Returns the zero-based column number that this object represents.
Public Property | OwnerSheet | Returns the sheet on which this column is located.
Public Property | Width | Sets or returns the width of the column in Twips.
Top

See Also

Reference

DDColumn Class
GrapeCity.SpreadBuilder Namespace


Column Property

[image]
ActiveReports 13
Column Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDColumn Class : Column Property

Glossary Item Box

Returns the zero-based column number that this object represents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As Short
C#
public short Column {get;}

Property Value

Short.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDColumn Class
DDColumn Members


OwnerSheet Property

[image]
ActiveReports 13
OwnerSheet Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDColumn Class : OwnerSheet Property

Glossary Item Box

Returns the sheet on which this column is located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OwnerSheet As DDSheet
C#
public DDSheet OwnerSheet {get;}

Property Value

GrapeCity.SpreadBuilder.DDSheet.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDColumn Class
DDColumn Members
DDSheet Class


Width Property

[image]
ActiveReports 13
Width Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDColumn Class : Width Property

Glossary Item Box

Sets or returns the width of the column in Twips.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

Integer.

Remarks

The value will be converted to Excel's "1/256 character width" unit system.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDColumn Class
DDColumn Members


DDRow Class

[image]
ActiveReports 13
DDRow Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDRow Class

Glossary Item Box

Represents a single row in a sheet.

Object Model

DDRow Class

Syntax

Visual Basic (Declaration)
Public Class DDRow
C#
public class DDRow

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDRow Members
GrapeCity.SpreadBuilder Namespace


DDRow Class Members

[image]
ActiveReports 13
DDRow Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDRow Class

Glossary Item Box

The following tables list the members exposed by DDRow.

Public Constructors

 | Name | Description
Public Constructor | DDRow Constructor | Initializes a new instance of a DDRow with the specified sheet as a parent, and the specified row number as the row this instance represents.
Top

Public Properties

 | Name | Description
Public Property | AutoSize | Sets or returns a value indicating whether Excel will automatically determine the row's height based on its contents.
Public Property | Height | Sets or returns a value indicating the height for the row in 1/20ths of a point.
Top

See Also

Reference

DDRow Class
GrapeCity.SpreadBuilder Namespace


DDRow Constructor

[image]
ActiveReports 13
DDRow Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDRow Class : DDRow Constructor

parentSheet
The sheet on which this row is located.
row
Returns the zero-based row number this instance represents.

Glossary Item Box

Initializes a new instance of a DDRow with the specified sheet as a parent, and the specified row number as the row this instance represents.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentSheet As DDSheet, _
   ByVal row As Integer _
)
C#
public DDRow(
   DDSheet parentSheet,
   int row
)

Parameters

parentSheet
The sheet on which this row is located.
row
Returns the zero-based row number this instance represents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDRow Class
DDRow Members


DDRow Class Properties

[image]
ActiveReports 13
DDRow Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDRow Class

Glossary Item Box

For a list of all members of this type, see DDRow members.

Public Properties

 | Name | Description
Public Property | AutoSize | Sets or returns a value indicating whether Excel will automatically determine the row's height based on its contents.
Public Property | Height | Sets or returns a value indicating the height for the row in 1/20ths of a point.
Top

See Also

Reference

DDRow Class
GrapeCity.SpreadBuilder Namespace


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDRow Class : AutoSize Property

Glossary Item Box

Sets or returns a value indicating whether Excel will automatically determine the row's height based on its contents.

Syntax

Visual Basic (Declaration)
Public Property AutoSize As Boolean
C#
public bool AutoSize {get; set;}

Property Value

Boolean. The default value is True.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    sb.Sheets[0].Rows(0).AutoSize = false;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        .Rows(0).AutoSize = False
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDRow Class
DDRow Members


Height Property

[image]
ActiveReports 13
Height Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDRow Class : Height Property

Glossary Item Box

Sets or returns a value indicating the height for the row in 1/20ths of a point.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

Integer. The default value is 12.75 points (or 255 in twips).

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDRow Class
DDRow Members


DDSecurity Class

[image]
ActiveReports 13
DDSecurity Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSecurity Class

Glossary Item Box

Encapsulates the information necessary to provide spreadsheet document security and encryption.

Object Model

DDSecurity Class

Syntax

Visual Basic (Declaration)
Public Class DDSecurity
C#
public class DDSecurity

Remarks

If a WritePassword or a Password is supplied the spreadsheet application will prompt for a write or open access password. If a WritePassword or a Password is not supplied no password will be requested to open the document. By correctly supplying the Password, the user will be able to open the document. By correctly supplying the WritePassword, the user will be able to write the document. If the read only recommended is set to true, the Excel application will prompt user whether to open document as read-only.

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDSecurity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSecurity Members
GrapeCity.SpreadBuilder Namespace


DDSecurity Class Members

[image]
ActiveReports 13
DDSecurity Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSecurity Class

Glossary Item Box

The following tables list the members exposed by DDSecurity.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open spreadsheet document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the spreadsheet document.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the spreadsheet document was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the spreadsheet document.
Top

See Also

Reference

DDSecurity Class
GrapeCity.SpreadBuilder Namespace


DDSecurity Class Properties

[image]
ActiveReports 13
DDSecurity Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSecurity Class

Glossary Item Box

For a list of all members of this type, see DDSecurity members.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open spreadsheet document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the spreadsheet document.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the spreadsheet document was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the spreadsheet document.
Top

See Also

Reference

DDSecurity Class
GrapeCity.SpreadBuilder Namespace


Password Property

[image]
ActiveReports 13
Password Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : Password Property

Glossary Item Box

Gets or sets the password which can be entered to permit to open spreadsheet document.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Remarks

Checks if the password is valid when Workbook.Save method is invoked.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSecurity Class
DDSecurity Members


ProtectedBy Property

[image]
ActiveReports 13
ProtectedBy Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : ProtectedBy Property

Glossary Item Box

Gets or sets the User Name responsible to password protect the spreadsheet document.

Syntax

Visual Basic (Declaration)
Public Property ProtectedBy As String
C#
public string ProtectedBy {get; set;}

Remarks

Cannot exceed 52 characters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSecurity Class
DDSecurity Members


ReadOnlyRecommended Property

[image]
ActiveReports 13
ReadOnlyRecommended Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : ReadOnlyRecommended Property

Glossary Item Box

Gets or sets the value to indicate if the spreadsheet document was saved as read only recommended.

Syntax

Visual Basic (Declaration)
Public Property ReadOnlyRecommended As Boolean
C#
public bool ReadOnlyRecommended {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSecurity Class
DDSecurity Members


WritePassword Property

[image]
ActiveReports 13
WritePassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : WritePassword Property

Glossary Item Box

Gets or sets the write password of the spreadsheet document.

Syntax

Visual Basic (Declaration)
Public Property WritePassword As String
C#
public string WritePassword {get; set;}

Property Value

Cannot exceed 15 characters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSecurity Class
DDSecurity Members


DDSheet Class

[image]
ActiveReports 13
DDSheet Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class

Glossary Item Box

Represents an Excel worksheet.

Object Model

DDSheet Class

Syntax

Visual Basic (Declaration)
Public Class DDSheet
C#
public class DDSheet

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDSheet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Members
GrapeCity.SpreadBuilder Namespace


DDSheet Class Members

[image]
ActiveReports 13
DDSheet Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class

Glossary Item Box

The following tables list the members exposed by DDSheet.

Public Properties

 | Name | Description
Public Property | DisplayGridLines | Sets or returns the flag indicating whether grid lines are displayed in the sheet.
Public Property | Name | Sets or returns the name of the DDSheet.
Public Property | PageSetup | Returns the current information about this sheet when printed. This information is displayed in Excel in the page setup dialog.
Public Property | ParentSheets | Returns the DDSheets collection of which this DDSheet is a member.
Top

Public Methods

 | Name | Description
Public Method | AddHorizontalPageBreak | Adds a horizontal (row) page break.
Public Method | AddImage | Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.
Public Method | AddLine | Adds one line with the specified coordinates and properties.
Public Method | AddVerticalPageBreak | Adds a vertical (column) page break.
Public Method | Cell | Returns the DDCell object for the specified row and column.
Public Method | Cells | Returns a DDCell instance for the specified cell number.
Public Method | Clear | Deletes all properties and content, creating a blank sheet.
Public Method | Columns | Returns the DDColumn object representing the specified column.
Public Method | IsMerged | Sets or returns a value indicating whether the specified cell's XFRecord has its fMergeCell member set to True.
Public Method | Rows | Returns a DDRow instance for the specified row number.
Public Method | UnMergeCells | Removes the MergeArea from the MergedAreas record for this sheet.
Top

See Also

Reference

DDSheet Class
GrapeCity.SpreadBuilder Namespace


DDSheet Class Methods

[image]
ActiveReports 13
DDSheet Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class

Glossary Item Box

For a list of all members of this type, see DDSheet members.

Public Methods

 | Name | Description
Public Method | AddHorizontalPageBreak | Adds a horizontal (row) page break.
Public Method | AddImage | Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.
Public Method | AddLine | Adds one line with the specified coordinates and properties.
Public Method | AddVerticalPageBreak | Adds a vertical (column) page break.
Public Method | Cell | Returns the DDCell object for the specified row and column.
Public Method | Cells | Returns a DDCell instance for the specified cell number.
Public Method | Clear | Deletes all properties and content, creating a blank sheet.
Public Method | Columns | Returns the DDColumn object representing the specified column.
Public Method | IsMerged | Sets or returns a value indicating whether the specified cell's XFRecord has its fMergeCell member set to True.
Public Method | Rows | Returns a DDRow instance for the specified row number.
Public Method | UnMergeCells | Removes the MergeArea from the MergedAreas record for this sheet.
Top

See Also

Reference

DDSheet Class
GrapeCity.SpreadBuilder Namespace


AddHorizontalPageBreak Method

[image]
ActiveReports 13
AddHorizontalPageBreak Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddHorizontalPageBreak Method

row
The one-based row value of the break.
columnstart
The one-based starting column for the break.
columnend
The one-based ending column for the break.

Glossary Item Box

Adds a horizontal (row) page break.

Syntax

Visual Basic (Declaration)
Public Sub AddHorizontalPageBreak( _
   ByVal row As UShort, _
   ByVal columnstart As UShort, _
   ByVal columnend As UShort _
)
C#
public void AddHorizontalPageBreak(
   ushort row,
   ushort columnstart,
   ushort columnend
)

Parameters

row
The one-based row value of the break.
columnstart
The one-based starting column for the break.
columnend
The one-based ending column for the break.

Remarks

PageBreaks may not overlap. The break occurs after the specified row or column.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    sb.Sheets[0].AddHorizontalPageBreak(2, 0, 2);

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

     sb.Sheets(0).AddHorizontalPageBreak(2, 0, 2)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


AddImage(Image,ImageInfo,Color,Color,Int32,Int16,Int32,Int16,Int32,Int16,Int32,Int16,String) Method

[image]
ActiveReports 13
AddImage(Image,ImageInfo,Color,Color,Int32,Int16,Int32,Int16,Int32,Int16,Int32,Int16,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class > AddImage Method : AddImage(Image,ImageInfo,Color,Color,Int32,Int16,Int32,Int16,Int32,Int16,Int32,Int16,String) Method

img
This is an image object that represents the image to be placed on the sheet.
imageOptions
SpreadBuilder.Imaging.ImageInfo.
lineColor
A System.Drawing.Color for the border lines on the image.
backColor
A System.Drawing.Color for the background of the image.
columnLeft
The column containing the upper-left corner of the object's bounding rectangle.
dxL
The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
rowTop
The row containing the upper-left corner of the object's bounding rectangle.
dyT
The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
columnRight
The column containing the lower-right corner of the object's bounding rectangle.
dxR
The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
rowBottom

The row containing the lower-right corner of the object's bounding rectangle.
dyB
The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
hyperlink
To add a clickable hyperlink to the image, specify the URL here. Otherwise use an empty string.

Glossary Item Box

Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddImage( _
   ByVal img As Image, _
   ByVal imageOptions As ImageInfo, _
   ByVal lineColor As Color, _
   ByVal backColor As Color, _
   ByVal columnLeft As Integer, _
   ByVal dxL As Short, _
   ByVal rowTop As Integer, _
   ByVal dyT As Short, _
   ByVal columnRight As Integer, _
   ByVal dxR As Short, _
   ByVal rowBottom As Integer, _
   ByVal dyB As Short, _
   ByVal hyperlink As String _
)
C#
public void AddImage(
   Image img,
   ImageInfo imageOptions,
   Color lineColor,
   Color backColor,
   int columnLeft,
   short dxL,
   int rowTop,
   short dyT,
   int columnRight,
   short dxR,
   int rowBottom,
   short dyB,
   string hyperlink
)

Parameters

img
This is an image object that represents the image to be placed on the sheet.
imageOptions
SpreadBuilder.Imaging.ImageInfo.
lineColor
A System.Drawing.Color for the border lines on the image.
backColor
A System.Drawing.Color for the background of the image.
columnLeft
The column containing the upper-left corner of the object's bounding rectangle.
dxL
The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
rowTop
The row containing the upper-left corner of the object's bounding rectangle.
dyT
The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
columnRight
The column containing the lower-right corner of the object's bounding rectangle.
dxR
The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
rowBottom

The row containing the lower-right corner of the object's bounding rectangle.
dyB
The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
hyperlink
To add a clickable hyperlink to the image, specify the URL here. Otherwise use an empty string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members
Overload List


AddLine Method

[image]
ActiveReports 13
AddLine Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddLine Method

li
A LineInfo object with its members set to the proper line configuration values. See the LineInfo class for more information.

Glossary Item Box

Adds one line with the specified coordinates and properties.

Syntax

Visual Basic (Declaration)
Public Sub AddLine( _
   ByVal li As LineInfo _
)
C#
public void AddLine(
   LineInfo li
)

Parameters

li
A LineInfo object with its members set to the proper line configuration values. See the LineInfo class for more information.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
//Dimension a Workbook and add a sheet to its Sheets collection
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.Sheets.AddNew();

//Set up properties and values for columns, rows and cells as desired
sb.Sheets[0].Name = "Customer Call List";
sb.Sheets[0].Columns(0).Width = 2 * 1440;
sb.Sheets[0].Columns(1).Width = 1440;
sb.Sheets[0].Columns(2).Width = 1440;
sb.Sheets[0].Rows(0).Height = 1440 / 4;
//Header row
sb.Sheets[0].Cell(0, 0).SetValue("Company Name");
sb.Sheets[0].Cell(0, 0).FontBold = true;
sb.Sheets[0].Cell(0, 1).SetValue("Contact Name");
sb.Sheets[0].Cell(0, 1).FontBold = true;
sb.Sheets[0].Cell(0, 2).SetValue("Phone");
sb.Sheets[0].Cell(0, 2).FontBold = true;
//First row of data
sb.Sheets[0].Cell(1, 0).SetValue("GrapeCity");
sb.Sheets[0].Cell(1, 1).SetValue("Mortimer");
sb.Sheets[0].Cell(1, 2).SetValue("(614) 895-3142");

GrapeCity.SpreadBuilder.Imaging.LineInfo l = new GrapeCity.SpreadBuilder.Imaging.LineInfo();
l.ColumnLeft = 3; //starting column for the line
l.Color = System.Drawing.Color.Salmon; //color for the line
l.ColumnRight = 8; //ending column for the line
l.dxL = 50;
l.dxR = 60;
l.dyB = 80;
l.dyT = 10;
l.EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the ending arrowhead
l.EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the ending arrowhead
l.EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide; //width of the ending arrowhead
l.fAuto = true;
l.iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight; //direction of the line
l.MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize; //sets whether user will be able to move and/or resize the line
l.RowBottom = 8; //bottom row for the line
l.RowTop = 1; //top row for the line
l.StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the starting arrowhead
l.StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the starting arrowhead
l.StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide;
l.Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash; //style of the line
l.Weight = 5; //thickness of the line

sb.Sheets[0].AddLine(l);

//Save the Workbook to an Excel file
sb.Save(Application.StartupPath + @"\x.xls");

MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        .Rows(0).AutoSize = False
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
    End With
    Dim l As New GrapeCity.SpreadBuilder.Imaging.LineInfo
    With l
        .ColumnLeft = 3 'starting column for the line
        .Color = System.Drawing.Color.Salmon 'color for the line
        .ColumnRight = 8 'ending column for the line
        .dxL = 50
        .dxR = 60
        .dyB = 80
        .dyT = 10
        .EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the ending arrowhead
        .EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the ending arrowhead
        .EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide 'width of the ending arrowhead
        .fAuto = True
        .iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight 'direction of the line
        .MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize 'sets whether user will be able to move and/or resize the line
        .RowBottom = 8 'bottom row for the line
        .RowTop = 1 'top row for the line
        .StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the starting arrowhead
        .StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the starting arrowhead
        .StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide
        .Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash 'style of the line
        .Weight = 5 'thickness of the line
    End With
    sb.Sheets(0).AddLine(l)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members
LineInfo Class


AddVerticalPageBreak Method

[image]
ActiveReports 13
AddVerticalPageBreak Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddVerticalPageBreak Method

col
The one-based column of the break.
rowstart
The one-based starting row for the break.
rowend
The one-based ending row for the break.

Glossary Item Box

Adds a vertical (column) page break.

Syntax

Visual Basic (Declaration)
Public Sub AddVerticalPageBreak( _
   ByVal col As UShort, _
   ByVal rowstart As UShort, _
   ByVal rowend As UShort _
)
C#
public void AddVerticalPageBreak(
   ushort col,
   ushort rowstart,
   ushort rowend
)

Parameters

col
The one-based column of the break.
rowstart
The one-based starting row for the break.
rowend
The one-based ending row for the break.

Remarks

Pagebreaks may not overlap. The break occurs after the row or column.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    sb.Sheets[0].AddVerticalPageBreak(2, 0, 2);

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

     sb.Sheets(0).AddVerticalPageBreak(2, 0, 2)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


Cell Method

[image]
ActiveReports 13
Cell Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Cell Method

iRow
The zero-based row number of the cell.
iColumn

The zero-based column number of the cell.

Glossary Item Box

Returns the DDCell object for the specified row and column.

Syntax

Visual Basic (Declaration)
Public Function Cell( _
   ByVal iRow As Integer, _
   ByVal iColumn As Integer _
) As DDCell
C#
public DDCell Cell(
   int iRow,
   int iColumn
)

Parameters

iRow
The zero-based row number of the cell.
iColumn

The zero-based column number of the cell.

Return Value

The DDCell object for the specified row and column.

Remarks

This function will throw an ArgumentOutOfRangeException if the specified iRow or iColumn is not in the valid range. The maximum iRow value is 65535. The maximum iColumn value is 255. The minimum value for both the iRow and iColumn argument is 0.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


Cells Method

[image]
ActiveReports 13
Cells Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Cells Method

start
The DDCell showing the cell position of starting point.
end
The DDCell showing the cell position of ending point.

Glossary Item Box

Returns a DDCell instance for the specified cell number.

Syntax

Visual Basic (Declaration)
Public Function Cells( _
   ByVal start As DDCell, _
   ByVal end As DDCell _
) As DDCells
C#
public DDCells Cells(
   DDCell start,
   DDCell end
)

Parameters

start
The DDCell showing the cell position of starting point.
end
The DDCell showing the cell position of ending point.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    // Add a sheet to the Sheets collection of the Workbook.
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    // Set the properties, values, for columns, rows, and cells.
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    // Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,1).SetValue("Department Name");
    sb.Sheets[0].Cell(0,2).SetValue("Phone Number");

    // Data for the first row
    sb.Sheets[0].Cell(1,0).SetValue("Grapecity");
    sb.Sheets[0].Cell(1,1).SetValue("Sales Department");
    sb.Sheets[0].Cell(1,2).SetValue("(022) 777-8210");

    //Specify the cell range and set the format
    sb.Sheets[0].Cells(sb.Sheets[0].Cell(0, 0), sb.Sheets[0].Cell(0, 2)).FontBold = true;
    sb.Sheets[0].Cells(sb.Sheets[0].Cell(0, 0), sb.Sheets[0].Cell(1, 2)).FontName = "MS UI Gothic";

    // Save the Workbook to an Excel file.
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show(Application.StartupPath + @"Saved to" + "\x.xls.");
}
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    ' Add a sheet to the Sheets collection of the Workbook.
    Dim sb As New GrapeCity.SpreadBuilder.Workbook()
    sb.Sheets.AddNew()
    ' Set the properties, values, for columns, rows, and cells.
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        ' Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 1).SetValue("Department Name")
        .Cell(0, 2).SetValue("Phone Number")

        ' Data for the first row
        .Cell(1, 0).SetValue("Grapecity")
        .Cell(1, 1).SetValue("Sales Department")
        .Cell(1, 2).SetValue("(022) 777-8210")
    End With

    ' Specify the cell range and set the format
    sb.Sheets(0).Cells(sb.Sheets(0).Cell(0, 0), sb.Sheets(0).Cell(0, 2)).FontBold = True
    sb.Sheets(0).Cells(sb.Sheets(0).Cell(0, 0), sb.Sheets(0).Cell(1, 2)).FontName = "MS UI Gothic"

    ' Save the Workbook to an Excel file.
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox(Application.StartupPath & "Saved to" & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Clear Method

Glossary Item Box

Deletes all properties and content, creating a blank sheet.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


Columns Method

[image]
ActiveReports 13
Columns Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Columns Method

column

The zero-based non-negative column index.

Glossary Item Box

Returns the DDColumn object representing the specified column.

Syntax

Visual Basic (Declaration)
Public Function Columns( _
   ByVal column As Short _
) As DDColumn
C#
public DDColumn Columns(
   short column
)

Parameters

column

The zero-based non-negative column index.

Return Value

The DDColumn object representing the specified column.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


IsMerged Method

[image]
ActiveReports 13
IsMerged Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : IsMerged Method

row
The zero-based row where the cell to check for merged status resides.
column
The zero-based column where the cell to check for merged status resides.

Glossary Item Box

Sets or returns a value indicating whether the specified cell's XFRecord has its fMergeCell member set to True.

Syntax

Visual Basic (Declaration)
Public Function IsMerged( _
   ByVal row As Integer, _
   ByVal column As Integer _
) As Boolean
C#
public bool IsMerged(
   int row,
   int column
)

Parameters

row
The zero-based row where the cell to check for merged status resides.
column
The zero-based column where the cell to check for merged status resides.

Return Value

Boolean. The default value is False.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


Rows Method

[image]
ActiveReports 13
Rows Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Rows Method

iRow
The zero-based row number the returned DDRow will represent.

Glossary Item Box

Returns a DDRow instance for the specified row number.

Syntax

Visual Basic (Declaration)
Public Function Rows( _
   ByVal iRow As Integer _
) As DDRow
C#
public DDRow Rows(
   int iRow
)

Parameters

iRow
The zero-based row number the returned DDRow will represent.

Return Value

A DDRow instance that represents the specified row number.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members
DDRow Class


UnMergeCells Method

[image]
ActiveReports 13
UnMergeCells Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : UnMergeCells Method

row
The zero-based row where the cell to unmerge resides.
column
The zero-based column where the cell to unmerge resides.

Glossary Item Box

Removes the MergeArea from the MergedAreas record for this sheet.

Syntax

Visual Basic (Declaration)
Public Sub UnMergeCells( _
   ByVal row As Integer, _
   ByVal column As Integer _
)
C#
public void UnMergeCells(
   int row,
   int column
)

Parameters

row
The zero-based row where the cell to unmerge resides.
column
The zero-based column where the cell to unmerge resides.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].UnMergeCells(0, 0);
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).UnMergeCells(0, 0)
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


DDSheet Class Properties

[image]
ActiveReports 13
DDSheet Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class

Glossary Item Box

For a list of all members of this type, see DDSheet members.

Public Properties

 | Name | Description
Public Property | DisplayGridLines | Sets or returns the flag indicating whether grid lines are displayed in the sheet.
Public Property | Name | Sets or returns the name of the DDSheet.
Public Property | PageSetup | Returns the current information about this sheet when printed. This information is displayed in Excel in the page setup dialog.
Public Property | ParentSheets | Returns the DDSheets collection of which this DDSheet is a member.
Top

See Also

Reference

DDSheet Class
GrapeCity.SpreadBuilder Namespace


DisplayGridLines Property

[image]
ActiveReports 13
DisplayGridLines Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : DisplayGridLines Property

Glossary Item Box

Sets or returns the flag indicating whether grid lines are displayed in the sheet.

Syntax

Visual Basic (Declaration)
Public Property DisplayGridLines As Boolean
C#
public bool DisplayGridLines {get; set;}

Property Value

Boolean. The default value is True.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].DisplayGridLines = false;
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .DisplayGridLines = False
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


Name Property

[image]
ActiveReports 13
Name Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Name Property

Glossary Item Box

Sets or returns the name of the DDSheet.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

String.

Remarks

This property will throw an ArgumentException if the specified name is already in use, or is invalid (e.g. empty).

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


PageSetup Property

[image]
ActiveReports 13
PageSetup Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : PageSetup Property

Glossary Item Box

Returns the current information about this sheet when printed. This information is displayed in Excel in the page setup dialog.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSetup As PageSetup
C#
public PageSetup PageSetup {get;}

Property Value

PageSetup class.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].PageSetup.Zoom = 200;
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .PageSetup.Zoom = 200
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


ParentSheets Property

[image]
ActiveReports 13
ParentSheets Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : ParentSheets Property

Glossary Item Box

Returns the DDSheets collection of which this DDSheet is a member.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentSheets As DDSheets
C#
public DDSheets ParentSheets {get;}

Property Value

DDSheets collection.

Remarks

This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheet Class
DDSheet Members


DDSheetNameAlreadyExistsException Class

[image]
ActiveReports 13
DDSheetNameAlreadyExistsException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class

Glossary Item Box

Thrown when you try to set a Name property to a value already in use.

Object Model

DDSheetNameAlreadyExistsException Class

Syntax

Visual Basic (Declaration)
Public Class DDSheetNameAlreadyExistsException
   Inherits System.ArgumentException
C#
public class DDSheetNameAlreadyExistsException : System.ArgumentException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
GrapeCity.SpreadBuilder.DDSheetNameAlreadyExistsException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Members
GrapeCity.SpreadBuilder Namespace


DDSheetNameAlreadyExistsException Class Members

[image]
ActiveReports 13
DDSheetNameAlreadyExistsException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class

Glossary Item Box

The following tables list the members exposed by DDSheetNameAlreadyExistsException.

Public Constructors

 | Name | Description
Public Constructor | DDSheetNameAlreadyExistsException Constructor | Initializes an instance of the DDSheetNameAlreadyExistsException.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from System.ArgumentException)
Public Property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from System.ArgumentException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Sets the System.Runtime.Serialization.SerializationInfo object with the parameter name and additional exception information. (Inherited from System.ArgumentException)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DDSheetNameAlreadyExistsException Class
GrapeCity.SpreadBuilder Namespace


DDSheetNameAlreadyExistsException Constructor

[image]
ActiveReports 13
DDSheetNameAlreadyExistsException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : DDSheetNameAlreadyExistsException Constructor

Glossary Item Box

Initializes an instance of the DDSheetNameAlreadyExistsException.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DDSheetNameAlreadyExistsException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


DDSheets Class

[image]
ActiveReports 13
DDSheets Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class

Glossary Item Box

A collection of DDSheet objects.

Object Model

DDSheets Class

Syntax

Visual Basic (Declaration)
Public Class DDSheets
C#
public class DDSheets

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDSheets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Members
GrapeCity.SpreadBuilder Namespace


DDSheets Class Members

[image]
ActiveReports 13
DDSheets Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class

Glossary Item Box

The following tables list the members exposed by DDSheets.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the DDSheets collection.
Public Property | Item | Overloaded. Gets the specified DDSheet object.
Top

Public Methods

 | Name | Description
Public Method | AddNew | Adds a new blank DDSheet object to the collection and returns a reference to it.
Public Method | Clear | Removes all of the DDSheet objects contained in the collection.
Public Method | Move | Overloaded. Moves a sheet to the specified position.
Public Method | RemoveAt | Removes the DDSheet at the specified index from the collection.
Public Method | Select | Overloaded. Selects a DDSheet object, while deselecting all other DDSheet objects.
Top

See Also

Reference

DDSheets Class
GrapeCity.SpreadBuilder Namespace


DDSheets Class Methods

[image]
ActiveReports 13
DDSheets Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class

Glossary Item Box

For a list of all members of this type, see DDSheets members.

Public Methods

 | Name | Description
Public Method | AddNew | Adds a new blank DDSheet object to the collection and returns a reference to it.
Public Method | Clear | Removes all of the DDSheet objects contained in the collection.
Public Method | Move | Overloaded. Moves a sheet to the specified position.
Public Method | RemoveAt | Removes the DDSheet at the specified index from the collection.
Public Method | Select | Overloaded. Selects a DDSheet object, while deselecting all other DDSheet objects.
Top

See Also

Reference

DDSheets Class
GrapeCity.SpreadBuilder Namespace


AddNew Method

[image]
ActiveReports 13
AddNew Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : AddNew Method

Glossary Item Box

Adds a new blank DDSheet object to the collection and returns a reference to it.

Syntax

Visual Basic (Declaration)
Public Function AddNew() As DDSheet
C#
public DDSheet AddNew()

Return Value

The newly added DDSheet object.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Clear Method

Glossary Item Box

Removes all of the DDSheet objects contained in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members


Move Method

[image]
ActiveReports 13
Move Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Move Method

Glossary Item Box

Moves a sheet to the specified position.

Overload List

Overload | Description
Move(String,Int16) | Moves the sheet with the specified name to the specified position.
Move(Int16,Int16) | Moves the sheet at the specified position to the specified new position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members


Move(String,Int16) Method

[image]
ActiveReports 13
Move(String,Int16) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Move Method : Move(String,Int16) Method

sName
The Name value of the DDSheet that you want to move.
newPosition
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.

Glossary Item Box

Moves the sheet with the specified name to the specified position.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Move( _
   ByVal sName As String, _
   ByVal newPosition As Short _
)
C#
public void Move(
   string sName,
   short newPosition
)

Parameters

sName
The Name value of the DDSheet that you want to move.
newPosition
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members
Overload List


Move(Int16,Int16) Method

[image]
ActiveReports 13
Move(Int16,Int16) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Move Method : Move(Int16,Int16) Method

oldPosition
The current position (index) of the sheet you want to move.
newPosition
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.

Glossary Item Box

Moves the sheet at the specified position to the specified new position.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Move( _
   ByVal oldPosition As Short, _
   ByVal newPosition As Short _
)
C#
public void Move(
   short oldPosition,
   short newPosition
)

Parameters

oldPosition
The current position (index) of the sheet you want to move.
newPosition
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members
Overload List


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : RemoveAt Method

iIndex

The zero-based index of the DDSheet object to be removed.

Glossary Item Box

Removes the DDSheet at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal iIndex As Integer _
)
C#
public void RemoveAt(
   int iIndex
)

Parameters

iIndex

The zero-based index of the DDSheet object to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Select Method

Glossary Item Box

Selects a DDSheet object, while deselecting all other DDSheet objects.

Overload List

Overload | Description
Select(String) | Selects the sheet with the specified name, and deselects all other sheets.
Select(Int32) | Selects the sheet at the specified index, and deselects all other sheets.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members


Select(String) Method

[image]
ActiveReports 13
Select(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Select Method : Select(String) Method

sheetName
The value of the Name property of the DDSheet object to be selected.

Glossary Item Box

Selects the sheet with the specified name, and deselects all other sheets.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select( _
   ByVal sheetName As String _
)
C#
public void Select(
   string sheetName
)

Parameters

sheetName
The value of the Name property of the DDSheet object to be selected.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members
Overload List


Select(Int32) Method

[image]
ActiveReports 13
Select(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Select Method : Select(Int32) Method

sheetIndex
The zero-based index of the sheet whose tab is to be selected.

Glossary Item Box

Selects the sheet at the specified index, and deselects all other sheets.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select( _
   ByVal sheetIndex As Integer _
)
C#
public void Select(
   int sheetIndex
)

Parameters

sheetIndex
The zero-based index of the sheet whose tab is to be selected.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members
Overload List


DDSheets Class Properties

[image]
ActiveReports 13
DDSheets Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class

Glossary Item Box

For a list of all members of this type, see DDSheets members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the DDSheets collection.
Public Property | Item | Overloaded. Gets the specified DDSheet object.
Top

See Also

Reference

DDSheets Class
GrapeCity.SpreadBuilder Namespace


Count Property

[image]
ActiveReports 13
Count Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Count Property

Glossary Item Box

Gets the number of elements contained in the DDSheets collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

Integer.

Remarks

This property is read-only.

Example

C# Copy Code
if (MessageBox.Show ("Your spreadsheet is " + sb.Sheets.Count.ToString() + " sheet(s) long. Okay to save?", "Save", MessageBoxButtons.YesNo) == DialogResult.Yes)
{
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
sb.Clear();
Visual Basic Copy Code
If MessageBox.Show("Your spreadsheet is " + sb.Sheets.Count.ToString() + " sheet(s) long. Okay to save?", "Save", MessageBoxButtons.YesNo) = DialogResult.Yes Then
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath + "\x.xls")
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets(0).Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\x.xls")
End If
sb.Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members


Item Property

[image]
ActiveReports 13
Item Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Item Property

Glossary Item Box

Gets the specified DDSheet object.

Overload List

Overload | Description
Item(Int32) | Gets the DDSheet at the specified index. In C#, this property is an indexer for the DDSheets class.
Item(String) | Gets the DDSheet with the specified name. In C#, this property is an indexer for the DDSheets class. If a DDSheet with the specified name does not exist in the collection, null will be returned.

Remarks

This property is read-only.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members
DDSheet Class


Item(Int32) Property

[image]
ActiveReports 13
Item(Int32) Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Item Property : Item(Int32) Property

iIndex
The zero-based index of the DDSheet in the collection.

Glossary Item Box

Gets the DDSheet at the specified index. In C#, this property is an indexer for the DDSheets class.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal iIndex As Integer _
) As DDSheet
C#
public DDSheet Item(
   int iIndex
) {get;}

Parameters

iIndex
The zero-based index of the DDSheet in the collection.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members
Overload List


Item(String) Property

[image]
ActiveReports 13
Item(String) Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Item Property : Item(String) Property

sheetName
The Name value of the DDSheet object.

Glossary Item Box

Gets the DDSheet with the specified name. In C#, this property is an indexer for the DDSheets class. If a DDSheet with the specified name does not exist in the collection, null will be returned.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal sheetName As String _
) As DDSheet
C#
public DDSheet Item(
   string sheetName
) {get;}

Parameters

sheetName
The Name value of the DDSheet object.

Remarks

The sheetName argument is not case sensitive.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets["Customer Call List"].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets("Customer Call List").Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheets Class
DDSheets Members
Overload List


EncryptedOpenXmlTools Class

[image]
ActiveReports 13
EncryptedOpenXmlTools Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : EncryptedOpenXmlTools Class

Glossary Item Box

The tool class for encrypting OpenXml format and exporting it. Can find the spec in [MS-OFFCRYPTO].

Object Model

EncryptedOpenXmlTools Class

Syntax

Visual Basic (Declaration)
Public Class EncryptedOpenXmlTools
C#
public class EncryptedOpenXmlTools

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.EncryptedOpenXmlTools

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EncryptedOpenXmlTools Members
GrapeCity.SpreadBuilder Namespace


EncryptedOpenXmlTools Class Members

[image]
ActiveReports 13
EncryptedOpenXmlTools Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : EncryptedOpenXmlTools Class

Glossary Item Box

The following tables list the members exposed by EncryptedOpenXmlTools.

Public Constructors

 | Name | Description
Public Constructor | EncryptedOpenXmlTools Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Export | Overloaded. Export the inputStream with encryption to a file.
Top

See Also

Reference

EncryptedOpenXmlTools Class
GrapeCity.SpreadBuilder Namespace


EncryptedOpenXmlTools Constructor

[image]
ActiveReports 13
EncryptedOpenXmlTools Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > EncryptedOpenXmlTools Class : EncryptedOpenXmlTools Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public EncryptedOpenXmlTools()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EncryptedOpenXmlTools Class
EncryptedOpenXmlTools Members


EncryptedOpenXmlTools Class Methods

[image]
ActiveReports 13
EncryptedOpenXmlTools Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : EncryptedOpenXmlTools Class

Glossary Item Box

For a list of all members of this type, see EncryptedOpenXmlTools members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Export | Overloaded. Export the inputStream with encryption to a file.
Top

See Also

Reference

EncryptedOpenXmlTools Class
GrapeCity.SpreadBuilder Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > EncryptedOpenXmlTools Class : Export Method

Glossary Item Box

Export the inputStream with encryption to a file.

Overload List

Overload | Description
Export(Stream,String,String) | Export the inputStream with encryption to a file.
Export(Stream,Stream,String) | Export the inputStream with encryption to an outputstream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EncryptedOpenXmlTools Class
EncryptedOpenXmlTools Members


Export(Stream,String,String) Method

[image]
ActiveReports 13
Export(Stream,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > EncryptedOpenXmlTools Class > Export Method : Export(Stream,String,String) Method

inputStream
An input stream which is a OpenXml format document.
path
The output file path.
password
The password

Glossary Item Box

Export the inputStream with encryption to a file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Export( _
   ByVal inputStream As Stream, _
   ByVal path As String, _
   ByVal password As String _
)
C#
public static void Export(
   Stream inputStream,
   string path,
   string password
)

Parameters

inputStream
An input stream which is a OpenXml format document.
path
The output file path.
password
The password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EncryptedOpenXmlTools Class
EncryptedOpenXmlTools Members
Overload List


Export(Stream,Stream,String) Method

[image]
ActiveReports 13
Export(Stream,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > EncryptedOpenXmlTools Class > Export Method : Export(Stream,Stream,String) Method

inputStream
An input stream which is a OpenXml format document.
outputStream
The output stream.
password
The password

Glossary Item Box

Export the inputStream with encryption to an outputstream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Export( _
   ByVal inputStream As Stream, _
   ByVal outputStream As Stream, _
   ByVal password As String _
)
C#
public static void Export(
   Stream inputStream,
   Stream outputStream,
   string password
)

Parameters

inputStream
An input stream which is a OpenXml format document.
outputStream
The output stream.
password
The password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EncryptedOpenXmlTools Class
EncryptedOpenXmlTools Members
Overload List


InvalidDDSheetNameException Class

[image]
ActiveReports 13
InvalidDDSheetNameException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class

Glossary Item Box

Thrown when change a sheet's name to an invalid value. The name cannot be empty, cannot exceed 31 characters and cannot contain any of following characters: : \ / ? * [ or ]

Object Model

InvalidDDSheetNameException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidDDSheetNameException
   Inherits System.ArgumentException
C#
public class InvalidDDSheetNameException : System.ArgumentException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
GrapeCity.SpreadBuilder.InvalidDDSheetNameException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Members
GrapeCity.SpreadBuilder Namespace


InvalidDDSheetNameException Class Members

[image]
ActiveReports 13
InvalidDDSheetNameException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class

Glossary Item Box

The following tables list the members exposed by InvalidDDSheetNameException.

Public Constructors

 | Name | Description
Public Constructor | InvalidDDSheetNameException Constructor | Overloaded. Initializes a new instance of InvalidDDSheetNameException Class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from System.ArgumentException)
Public Property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from System.ArgumentException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Sets the System.Runtime.Serialization.SerializationInfo object with the parameter name and additional exception information. (Inherited from System.ArgumentException)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDDSheetNameException Class
GrapeCity.SpreadBuilder Namespace


InvalidDDSheetNameException Constructor

[image]
ActiveReports 13
InvalidDDSheetNameException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : InvalidDDSheetNameException Constructor

Glossary Item Box

Initializes a new instance of InvalidDDSheetNameException Class.

Overload List

Overload | Description
InvalidDDSheetNameException Constructor(String) | Create a InvalidDDSheetNameException instance with parameter name.
InvalidDDSheetNameException Constructor() | Create a InvalidDDSheetNameException instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


InvalidDDSheetNameException Constructor(String)

[image]
ActiveReports 13
InvalidDDSheetNameException Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class > InvalidDDSheetNameException Constructor : InvalidDDSheetNameException Constructor(String)

paramName
Gets the name of the parameter that causes the exception.

Glossary Item Box

Create a InvalidDDSheetNameException instance with parameter name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal paramName As String _
)
C#
public InvalidDDSheetNameException(
   string paramName
)

Parameters

paramName
Gets the name of the parameter that causes the exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members
Overload List


InvalidDDSheetNameException Constructor()

[image]
ActiveReports 13
InvalidDDSheetNameException Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class > InvalidDDSheetNameException Constructor : InvalidDDSheetNameException Constructor()

Glossary Item Box

Create a InvalidDDSheetNameException instance.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public InvalidDDSheetNameException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members
Overload List


InvalidPasswordException Class

[image]
ActiveReports 13
InvalidPasswordException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class

Glossary Item Box

Thrown when the password is invalid in a specific excel format.(For example: the length of password is out of range.)

Object Model

InvalidPasswordException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidPasswordException
   Inherits SpreadBuilderException
C#
public class InvalidPasswordException : SpreadBuilderException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.InvalidPasswordException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Members
GrapeCity.SpreadBuilder Namespace


InvalidPasswordException Class Members

[image]
ActiveReports 13
InvalidPasswordException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class

Glossary Item Box

The following tables list the members exposed by InvalidPasswordException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
GrapeCity.SpreadBuilder Namespace


NoDDSheetsException Class

[image]
ActiveReports 13
NoDDSheetsException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class

Glossary Item Box

Thrown when an operation is requested that requires at least one sheet in the Sheets collection (for example Saving the workbook) and no sheets exist.

Object Model

NoDDSheetsException Class

Syntax

Visual Basic (Declaration)
Public Class NoDDSheetsException
   Inherits SpreadBuilderException
C#
public class NoDDSheetsException : SpreadBuilderException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.NoDDSheetsException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Members
GrapeCity.SpreadBuilder Namespace


NoDDSheetsException Class Members

[image]
ActiveReports 13
NoDDSheetsException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class

Glossary Item Box

The following tables list the members exposed by NoDDSheetsException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoDDSheetsException Class
GrapeCity.SpreadBuilder Namespace


NoDDSheetsException Class Properties

[image]
ActiveReports 13
NoDDSheetsException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class

Glossary Item Box

For a list of all members of this type, see NoDDSheetsException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoDDSheetsException Class
GrapeCity.SpreadBuilder Namespace


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : Message Property

Glossary Item Box

Returns a message that describes the error.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


RowCountOutOfRangeException Class

[image]
ActiveReports 13
RowCountOutOfRangeException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class

Glossary Item Box

Thrown when the rows' count is out of range in a specific excel format.

Object Model

RowCountOutOfRangeException Class

Syntax

Visual Basic (Declaration)
Public Class RowCountOutOfRangeException
   Inherits SpreadBuilderException
C#
public class RowCountOutOfRangeException : SpreadBuilderException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.RowCountOutOfRangeException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Members
GrapeCity.SpreadBuilder Namespace


RowCountOutOfRangeException Class Members

[image]
ActiveReports 13
RowCountOutOfRangeException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class

Glossary Item Box

The following tables list the members exposed by RowCountOutOfRangeException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

RowCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


SpreadBuilderException Class

[image]
ActiveReports 13
SpreadBuilderException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class

Glossary Item Box

A general exception thrown for application errors in the GrapeCity.SpreadBuilder assembly.

Object Model

SpreadBuilderException Class

Syntax

Visual Basic (Declaration)
Public Class SpreadBuilderException
   Inherits System.ApplicationException
C#
public class SpreadBuilderException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.ColumnCountOutOfRangeException
GrapeCity.SpreadBuilder.CompressionException
GrapeCity.SpreadBuilder.InvalidPasswordException
GrapeCity.SpreadBuilder.NoDDSheetsException
GrapeCity.SpreadBuilder.RowCountOutOfRangeException
GrapeCity.SpreadBuilder.VersionNotImplementedException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Members
GrapeCity.SpreadBuilder Namespace


SpreadBuilderException Class Members

[image]
ActiveReports 13
SpreadBuilderException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class

Glossary Item Box

The following tables list the members exposed by SpreadBuilderException.

Public Constructors

 | Name | Description
Public Constructor | SpreadBuilderException Constructor | Overloaded. Initializes a new instance of the SpreadBuilderException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SpreadBuilderException Class
GrapeCity.SpreadBuilder Namespace


SpreadBuilderException Constructor

[image]
ActiveReports 13
SpreadBuilderException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : SpreadBuilderException Constructor

Glossary Item Box

Initializes a new instance of the SpreadBuilderException class.

Overload List

Overload | Description
SpreadBuilderException Constructor(String,Exception) | Initializes a new instance of the SpreadBuilderException class with the specified error message and a reference to the inner exception that is the cause of this exception.
SpreadBuilderException Constructor(String) | Initializes a new instance of the SpreadBuilderException class with the specified error message.
SpreadBuilderException Constructor() | Initializes a new instance of the SpreadBuilderException class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


SpreadBuilderException Constructor(String,Exception)

[image]
ActiveReports 13
SpreadBuilderException Constructor(String,Exception)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class > SpreadBuilderException Constructor : SpreadBuilderException Constructor(String,Exception)

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the SpreadBuilderException class with the specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public SpreadBuilderException(
   string message,
   Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members
Overload List


SpreadBuilderException Constructor(String)

[image]
ActiveReports 13
SpreadBuilderException Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class > SpreadBuilderException Constructor : SpreadBuilderException Constructor(String)

message
A message that describes the error.

Glossary Item Box

Initializes a new instance of the SpreadBuilderException class with the specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public SpreadBuilderException(
   string message
)

Parameters

message
A message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members
Overload List


SpreadBuilderException Constructor()

[image]
ActiveReports 13
SpreadBuilderException Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class > SpreadBuilderException Constructor : SpreadBuilderException Constructor()

Glossary Item Box

Initializes a new instance of the SpreadBuilderException class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SpreadBuilderException()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members
Overload List


VersionNotImplementedException Class

[image]
ActiveReports 13
VersionNotImplementedException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class

Glossary Item Box

Indicates that a feature or features were not implemented for a particular version of the Excel/BIFF file format.

Object Model

VersionNotImplementedException Class

Syntax

Visual Basic (Declaration)
Public Class VersionNotImplementedException
   Inherits SpreadBuilderException
C#
public class VersionNotImplementedException : SpreadBuilderException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.VersionNotImplementedException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Members
GrapeCity.SpreadBuilder Namespace


VersionNotImplementedException Class Members

[image]
ActiveReports 13
VersionNotImplementedException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class

Glossary Item Box

The following tables list the members exposed by VersionNotImplementedException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

VersionNotImplementedException Class
GrapeCity.SpreadBuilder Namespace


VersionNotImplementedException Class Properties

[image]
ActiveReports 13
VersionNotImplementedException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class

Glossary Item Box

For a list of all members of this type, see VersionNotImplementedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

VersionNotImplementedException Class
GrapeCity.SpreadBuilder Namespace


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : Message Property

Glossary Item Box

Returns a message that describes the error.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


Workbook Class

[image]
ActiveReports 13
Workbook Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

Glossary Item Box

Represents a workbook that contains spreadsheets. This object presents information that is relevant to all spreadsheets in the workbook (e.g. Author, BIFF/file version, etc.).

Object Model

Workbook Class

Syntax

Visual Basic (Declaration)
Public Class Workbook
C#
public class Workbook

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
   GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Workbook

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Members
GrapeCity.SpreadBuilder Namespace


Workbook Class Members

[image]
ActiveReports 13
Workbook Class Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

Glossary Item Box

The following tables list the members exposed by Workbook.

Public Constructors

 | Name | Description
Public Constructor | Workbook Constructor | Initializes a new instance of the Workbook class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultFontName | Returns the default font name for the workbook.
static (Shared in Visual Basic) | DefaultFontSizeInPoints | Returns the default font size in points for the workbook.
Top

Public Properties

 | Name | Description
Public Property | FileFormat | Sets/gets the file format that the spreadsheet will be saved in.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | ProtectWorkbookPassword | Sets/gets the password for protecting the elements in workbook.
Public Property | ProtectWorkBookStructure | Sets or returns a value indicating whether Excel will let the user add, delete, reorder, or rename sheets in the workbook.
Public Property | ProtectWorkbookWindows | Sets or returns a value indicating whether the workbook or sheet is protected.
Public Property | Security | Returns a DDSecurity object for initializing document security.
Public Property | SheetName | Sets or returns a value indicating the name of sheet. Sheet is default.
Public Property | Sheets | Returns a DDSheets object, which is a collection of DDSheet objects, which make up the workbook.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

Public Methods

 | Name | Description
Public Method | Clear | Removes all sheets, creates a fresh instance of all member class variables and initializes all member data variables to their default value.
Public Method | Save | Overloaded. Saves the current workbook.
Top

See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


Workbook Constructor

[image]
ActiveReports 13
Workbook Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Workbook Constructor

Glossary Item Box

Initializes a new instance of the Workbook class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Workbook()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


Workbook Class Methods

[image]
ActiveReports 13
Workbook Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

Glossary Item Box

For a list of all members of this type, see Workbook members.

Public Methods

 | Name | Description
Public Method | Clear | Removes all sheets, creates a fresh instance of all member class variables and initializes all member data variables to their default value.
Public Method | Save | Overloaded. Saves the current workbook.
Top

See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Clear Method

Glossary Item Box

Removes all sheets, creates a fresh instance of all member class variables and initializes all member data variables to their default value.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


Save Method

[image]
ActiveReports 13
Save Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Save Method

Glossary Item Box

Saves the current workbook.

Overload List

Overload | Description
Save(Stream) | Saves the current workbook to the specified stream.
Save(String) | Saves the current workbook to the specified file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


Save(Stream) Method

[image]
ActiveReports 13
Save(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class > Save Method : Save(Stream) Method

outputStream

The output stream to which to save the workbook. The stream can be of various types, for example, a MemoryStream, or an HttpResponse.OutputStream.

Glossary Item Box

Saves the current workbook to the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal outputStream As Stream _
)
C#
public void Save(
   Stream outputStream
)

Parameters

outputStream

The output stream to which to save the workbook. The stream can be of various types, for example, a MemoryStream, or an HttpResponse.OutputStream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members
Overload List


Save(String) Method

[image]
ActiveReports 13
Save(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class > Save Method : Save(String) Method

filePath
The file name and path to which to save the workbook.

Glossary Item Box

Saves the current workbook to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Save( _
   ByVal filePath As String _
)
C#
public void Save(
   string filePath
)

Parameters

filePath
The file name and path to which to save the workbook.

Remarks

Permissions to write to the specified file are Demanded.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members
Overload List


Workbook Class Properties

[image]
ActiveReports 13
Workbook Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

Glossary Item Box

For a list of all members of this type, see Workbook members.

Public Properties

 | Name | Description
Public Property | FileFormat | Sets/gets the file format that the spreadsheet will be saved in.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | ProtectWorkbookPassword | Sets/gets the password for protecting the elements in workbook.
Public Property | ProtectWorkBookStructure | Sets or returns a value indicating whether Excel will let the user add, delete, reorder, or rename sheets in the workbook.
Public Property | ProtectWorkbookWindows | Sets or returns a value indicating whether the workbook or sheet is protected.
Public Property | Security | Returns a DDSecurity object for initializing document security.
Public Property | SheetName | Sets or returns a value indicating the name of sheet. Sheet is default.
Public Property | Sheets | Returns a DDSheets object, which is a collection of DDSheet objects, which make up the workbook.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top

See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


FileFormat Property

[image]
ActiveReports 13
FileFormat Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : FileFormat Property

Glossary Item Box

Sets/gets the file format that the spreadsheet will be saved in.

Syntax

Visual Basic (Declaration)
Public Property FileFormat As FileFormat
C#
public FileFormat FileFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


OpenXmlStandard Property

[image]
ActiveReports 13
OpenXmlStandard Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : OpenXmlStandard Property

Glossary Item Box

Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.

Syntax

Visual Basic (Declaration)
Public Property OpenXmlStandard As OpenXmlStandard
C#
public OpenXmlStandard OpenXmlStandard {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


ProtectWorkbookPassword Property

[image]
ActiveReports 13
ProtectWorkbookPassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : ProtectWorkbookPassword Property

Glossary Item Box

Sets/gets the password for protecting the elements in workbook.

Syntax

Visual Basic (Declaration)
Public Property ProtectWorkbookPassword As String
C#
public string ProtectWorkbookPassword {get; set;}

Remarks

The password will take effect when one of ProtectWorkbookWindows and ProtectWorkBookStructure property is true. If one or both ProtectWorkbookWindows and ProtectWorkBookStructure property are set to true, Workbook.Save method will be invoked.At this time, ProtectWorkbookPassword validity will be checked.
If file format is Xls95/Xls97Plus, InvalidPasswordExpection will be thrown out if ProtectWorkbookPassword contains more than 15 characters.If file format is Xlsx, InvalidPasswordExpection will be thrown out if ProtectWorkbookPassword contains more than 255 characters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


ProtectWorkBookStructure Property

[image]
ActiveReports 13
ProtectWorkBookStructure Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : ProtectWorkBookStructure Property

Glossary Item Box

Sets or returns a value indicating whether Excel will let the user add, delete, reorder, or rename sheets in the workbook.

Syntax

Visual Basic (Declaration)
Public Property ProtectWorkBookStructure As Boolean
C#
public bool ProtectWorkBookStructure {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.ProtectWorkBookStructure = true;
Visual Basic Copy Code
Dim sb As New GrapeCity.SpreadBuilder.Workbook
sb.ProtectWorkBookStructure = True

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


ProtectWorkbookWindows Property

[image]
ActiveReports 13
ProtectWorkbookWindows Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : ProtectWorkbookWindows Property

Glossary Item Box

Sets or returns a value indicating whether the workbook or sheet is protected.

Syntax

Visual Basic (Declaration)
Public Property ProtectWorkbookWindows As Boolean
C#
public bool ProtectWorkbookWindows {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.ProtectWorkbookWindows = true;
Visual Basic Copy Code
Dim sb As New GrapeCity.SpreadBuilder.Workbook
sb.ProtectWorkbookWindows = True

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


Security Property

[image]
ActiveReports 13
Security Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Security Property

Glossary Item Box

Returns a DDSecurity object for initializing document security.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Security As DDSecurity
C#
public DDSecurity Security {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


SheetName Property

[image]
ActiveReports 13
SheetName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : SheetName Property

Glossary Item Box

Sets or returns a value indicating the name of sheet. Sheet is default.

Syntax

Visual Basic (Declaration)
Public Property SheetName As String
C#
public string SheetName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


Sheets Property

[image]
ActiveReports 13
Sheets Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Sheets Property

Glossary Item Box

Returns a DDSheets object, which is a collection of DDSheet objects, which make up the workbook.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sheets As DDSheets
C#
public DDSheets Sheets {get;}

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


UseCompression Property

[image]
ActiveReports 13
UseCompression Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : UseCompression Property

Glossary Item Box

Gets or sets the value indicating should compression be used on exporting with Xlsx file format.

Syntax

Visual Basic (Declaration)
Public Property UseCompression As Boolean
C#
public bool UseCompression {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


UseDefaultPalette Property

[image]
ActiveReports 13
UseDefaultPalette Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : UseDefaultPalette Property

Glossary Item Box

Sets or returns whether export document with Excel default palette.

Syntax

Visual Basic (Declaration)
Public Property UseDefaultPalette As Boolean
C#
public bool UseDefaultPalette {get; set;}

Remarks

Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


Workbook Class Fields

[image]
ActiveReports 13
Workbook Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

Glossary Item Box

For a list of all members of this type, see Workbook members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultFontName | Returns the default font name for the workbook.
static (Shared in Visual Basic) | DefaultFontSizeInPoints | Returns the default font size in points for the workbook.
Top

See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


DefaultFontName Field

[image]
ActiveReports 13
DefaultFontName Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : DefaultFontName Field

Glossary Item Box

Returns the default font name for the workbook.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultFontName As String
C#
public static readonly string DefaultFontName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


DefaultFontSizeInPoints Field

[image]
ActiveReports 13
DefaultFontSizeInPoints Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : DefaultFontSizeInPoints Field

Glossary Item Box

Returns the default font size in points for the workbook.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultFontSizeInPoints As Integer
C#
public static readonly int DefaultFontSizeInPoints

Example

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Workbook Class
Workbook Members


FileFormat Enumeration

[image]
ActiveReports 13
FileFormat Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : FileFormat Enumeration

Glossary Item Box

Specifies the file format that the outputted file should support.

Syntax

Visual Basic (Declaration)
Public Enum FileFormat
   Inherits System.Enum
C#
public enum FileFormat : System.Enum

Members

Member | Description
Xls95 | Microsoft Excel 95 format.
Xls97Plus | Optimized for Microsoft Excel 97 and newer versions.
Xlsx | Microsoft Excel OpenXml format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.FileFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder Namespace


GrapeCity.SpreadBuilder.Cells Namespace

GrapeCity.SpreadBuilder.Cells Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Cells Namespace

Glossary Item Box

The GrapeCity.SpreadBuilder.Cells namespace contains the DDCell class.

Classes

 | Class | Description
Class | DDCell | Represents a single cell in a spreadsheet.
Class | DDCells | Returns a DDCell instance for the specified cell number.

Structures

 | Structure | Description
Structure | MergeArea | A structure that represents a merged rectangular region of cells in the spreadsheet.

Enumerations

 | Enumeration | Description
Enumeration | BiffCellBoolErrValues | The values available for the BiffCellBoolErr.ValueBoolErr property.
Enumeration | CellTypes | The available types of spreadsheet cells that SpreadBuilder supports. This value is used with the DDCell class's Type property to get a specific cell's type.

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


DDCell Class

[image]
ActiveReports 13
DDCell Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class

Glossary Item Box

Represents a single cell in a spreadsheet.

Object Model

DDCell Class

Syntax

Visual Basic (Declaration)
Public Class DDCell
C#
public class DDCell

Example

Visual Basic Copy Code
'specify a font for a range of cells
Dim sb As New Workbook()
sb.Sheets.AddNew()
Dim start As DDCell = sb.Sheets(0).Cell(0, 0)
Dim end As DDCell = sb.Sheets(0).Cell(1, 2)
sb.Sheets(0).Cells(start, [end]).FontName = "Comic sans ms"
C# Copy Code
Workbook sb = new Workbook();
sb.Sheets.AddNew();
DDCell start = sb.Sheets[0].Cell(0, 0);
DDCell end = sb.Sheets[0].Cell(1, 2);
sb.Sheets[0].Cells(start, end).FontName = "Comic sans ms";

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Cells.DDCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Members
GrapeCity.SpreadBuilder.Cells Namespace


DDCell Class Members

[image]
ActiveReports 13
DDCell Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class

Glossary Item Box

The following tables list the members exposed by DDCell.

Public Properties

 | Name | Description
Public Property | Alignment | Sets or returns the horizontal alignment value for the cell.
Public Property | BorderBottomColor | Sets or returns the color of the bottom border.
Public Property | BorderBottomStyle | Sets or returns the line style for the bottom portion of the cell's border.
Public Property | BorderDiagonalColor | Sets or returns the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets or returns a value indicating whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Public Property | BorderDiagonalStyle | Sets or returns the line style for the diagonal portion of the cell's border.
Public Property | BorderLeftColor | Sets or returns the color of the left border.
Public Property | BorderLeftStyle | Sets or returns the line style for the left portion of the cell's border.
Public Property | BorderRightColor | Sets or returns the color of the right border.
Public Property | BorderRightStyle | Sets or returns the line style for the right portion of the cell's border.
Public Property | BorderTopColor | Sets or returns the color of the top border.
Public Property | BorderTopStyle | Sets or returns the line style for the top portion of the cell's border.
Public Property | FillColor | Sets or returns the background color for the cell.
Public Property | FontBold | Sets or returns a value indicating whether the bold property of the cell's font is used.
Public Property | FontItalic | Sets or returns a value indicating whether the cell's font's Italic property is used.
Public Property | FontName | Sets or returns the name of the font.
Public Property | FontSize | Sets or returns a value indicating the point size to use in the cell's font size property.
Public Property | FontStrikeOut | Sets or returns a value indicating whether the text in the cell is rendered with a horizontal line striking through the text.
Public Property | FontUnderlineStyle | Sets or returns the underline style for the cell.
Public Property | ForeColor | Sets or returns the foreground color or text color of the cell.
Public Property | Hyperlink | Sets or returns a hyperlink for the cell that will automatically be launched by Excel when it is clicked.
Public Property | IsMerged | Sets or returns a value indicating whether the cell is in a merged group of cells.
Public Property | MergeArea | Returns a MergeArea object that represents the merged range containing this cell. If this cell is not in a merged area, this property returns MergeArea.Empty.
Public Property | NumberFormat | Sets or returns an Excel-style number format string.
Public Property | TextAngle | Sets or returns the text rotation for the cell in degrees.
Public Property | Type | The type of cell this DDCell object represents.
Public Property | VertAlignment | Sets or returns the vertical alignment value for the cell.
Public Property | WrapText | Sets or returns a value indicating whether the cell's text can be wrapped.
Top

Public Methods

 | Name | Description
Public Method | GetValue | Returns the cell's current value.
Public Method | Merge | Merges the cell with adjacent cells.
Public Method | SetValue | Overloaded. Sets the cell's type and stores its current value.
Public Method | SetValueBlank | Sets the cell's type to DDCellType.Blank and clears any other current value.
Public Method | UnMerge | Causes the cell and all cells that are currently merged with it to separate and behave as independent cells with their own values and styles.
Top

See Also

Reference

DDCell Class
GrapeCity.SpreadBuilder.Cells Namespace


DDCell Class Methods

[image]
ActiveReports 13
DDCell Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class

Glossary Item Box

For a list of all members of this type, see DDCell members.

Public Methods

 | Name | Description
Public Method | GetValue | Returns the cell's current value.
Public Method | Merge | Merges the cell with adjacent cells.
Public Method | SetValue | Overloaded. Sets the cell's type and stores its current value.
Public Method | SetValueBlank | Sets the cell's type to DDCellType.Blank and clears any other current value.
Public Method | UnMerge | Causes the cell and all cells that are currently merged with it to separate and behave as independent cells with their own values and styles.
Top

See Also

Reference

DDCell Class
GrapeCity.SpreadBuilder.Cells Namespace


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : GetValue Method

Glossary Item Box

Returns the cell's current value.

Syntax

Visual Basic (Declaration)
Public Function GetValue() As Object
C#
public object GetValue()

Return Value

The return type is one of the following:

  • Null reference (for CellTypes.Blank)
  • System.String (for CellTypes.Label)
  • System.Double (for CellTypes.Number)
  • A value in the BiffCellBoolErrValues enumeration (for CellTypes.BoolErr)

Use DDCell's Type property to determine the type of the cell before returning the value, or check the type of the returned value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members
BiffCellBoolErrValues Enumeration
Type Property


Merge Method

[image]
ActiveReports 13
Merge Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Merge Method

numberOfRowsToMerge
The number of vertical rows from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.
numberOfColumnsToMerge
The number of horizontal columns from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.

Glossary Item Box

Merges the cell with adjacent cells.

Syntax

Visual Basic (Declaration)
Public Sub Merge( _
   ByVal numberOfRowsToMerge As UShort, _
   ByVal numberOfColumnsToMerge As UShort _
)
C#
public void Merge(
   ushort numberOfRowsToMerge,
   ushort numberOfColumnsToMerge
)

Parameters

numberOfRowsToMerge
The number of vertical rows from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.
numberOfColumnsToMerge
The number of horizontal columns from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.

Remarks

Do not merge a cell more than once.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //To the dimensions of the workbook,add a sheet to sheet collection.
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'To the dimensions of the workbook,add a sheet to sheet collection.
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : SetValue Method

Glossary Item Box

Sets the cell's type and stores its current value.

Overload List

Overload | Description
SetValue(Double) | Sets the cell's type to DDCellType.Number, and sets its value to the specified numeric value.
SetValue(String) | Sets the cell's type to DDCellType.Label, and sets its value to the specified string value.
SetValue(BiffCellBoolErrValues) | Sets the cell's type to DDCellType.Boolean, and sets its value to the specified BiffCellBoolErrValues enumeration.

Example

C# Copy Code
Private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook And add a sheet To its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties And values For columns, rows And cells As desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    //Save the Workbook To an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


SetValue(Double) Method

[image]
ActiveReports 13
SetValue(Double) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class > SetValue Method : SetValue(Double) Method

dblValue
The numeric value to store as the cell's current value.

Glossary Item Box

Sets the cell's type to DDCellType.Number, and sets its value to the specified numeric value.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dblValue As Double _
)
C#
public void SetValue(
   double dblValue
)

Parameters

dblValue
The numeric value to store as the cell's current value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members
Overload List


SetValue(String) Method

[image]
ActiveReports 13
SetValue(String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class > SetValue Method : SetValue(String) Method

sValue
The string value to store as the cell's current value.

Glossary Item Box

Sets the cell's type to DDCellType.Label, and sets its value to the specified string value.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal sValue As String _
)
C#
public void SetValue(
   string sValue
)

Parameters

sValue
The string value to store as the cell's current value.

Example

C# Copy Code
Private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook And add a sheet To its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties And values For columns, rows And cells As desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    //Save the Workbook To an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members
Overload List


SetValue(BiffCellBoolErrValues) Method

[image]
ActiveReports 13
SetValue(BiffCellBoolErrValues) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class > SetValue Method : SetValue(BiffCellBoolErrValues) Method

boolerrValue
A BiffCellBoolErrValues enumeration value.

Glossary Item Box

Sets the cell's type to DDCellType.Boolean, and sets its value to the specified BiffCellBoolErrValues enumeration.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal boolerrValue As BiffCellBoolErrValues _
)
C#
public void SetValue(
   BiffCellBoolErrValues boolerrValue
)

Parameters

boolerrValue
A BiffCellBoolErrValues enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members
Overload List
BiffCellBoolErrValues Enumeration


SetValueBlank Method

[image]
ActiveReports 13
SetValueBlank Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : SetValueBlank Method

Glossary Item Box

Sets the cell's type to DDCellType.Blank and clears any other current value.

Syntax

Visual Basic (Declaration)
Public Sub SetValueBlank()
C#
public void SetValueBlank()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


UnMerge Method

[image]
ActiveReports 13
UnMerge Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : UnMerge Method

Glossary Item Box

Causes the cell and all cells that are currently merged with it to separate and behave as independent cells with their own values and styles.

Syntax

Visual Basic (Declaration)
Public Sub UnMerge()
C#
public void UnMerge()

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


DDCell Class Properties

[image]
ActiveReports 13
DDCell Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class

Glossary Item Box

For a list of all members of this type, see DDCell members.

Public Properties

 | Name | Description
Public Property | Alignment | Sets or returns the horizontal alignment value for the cell.
Public Property | BorderBottomColor | Sets or returns the color of the bottom border.
Public Property | BorderBottomStyle | Sets or returns the line style for the bottom portion of the cell's border.
Public Property | BorderDiagonalColor | Sets or returns the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets or returns a value indicating whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Public Property | BorderDiagonalStyle | Sets or returns the line style for the diagonal portion of the cell's border.
Public Property | BorderLeftColor | Sets or returns the color of the left border.
Public Property | BorderLeftStyle | Sets or returns the line style for the left portion of the cell's border.
Public Property | BorderRightColor | Sets or returns the color of the right border.
Public Property | BorderRightStyle | Sets or returns the line style for the right portion of the cell's border.
Public Property | BorderTopColor | Sets or returns the color of the top border.
Public Property | BorderTopStyle | Sets or returns the line style for the top portion of the cell's border.
Public Property | FillColor | Sets or returns the background color for the cell.
Public Property | FontBold | Sets or returns a value indicating whether the bold property of the cell's font is used.
Public Property | FontItalic | Sets or returns a value indicating whether the cell's font's Italic property is used.
Public Property | FontName | Sets or returns the name of the font.
Public Property | FontSize | Sets or returns a value indicating the point size to use in the cell's font size property.
Public Property | FontStrikeOut | Sets or returns a value indicating whether the text in the cell is rendered with a horizontal line striking through the text.
Public Property | FontUnderlineStyle | Sets or returns the underline style for the cell.
Public Property | ForeColor | Sets or returns the foreground color or text color of the cell.
Public Property | Hyperlink | Sets or returns a hyperlink for the cell that will automatically be launched by Excel when it is clicked.
Public Property | IsMerged | Sets or returns a value indicating whether the cell is in a merged group of cells.
Public Property | MergeArea | Returns a MergeArea object that represents the merged range containing this cell. If this cell is not in a merged area, this property returns MergeArea.Empty.
Public Property | NumberFormat | Sets or returns an Excel-style number format string.
Public Property | TextAngle | Sets or returns the text rotation for the cell in degrees.
Public Property | Type | The type of cell this DDCell object represents.
Public Property | VertAlignment | Sets or returns the vertical alignment value for the cell.
Public Property | WrapText | Sets or returns a value indicating whether the cell's text can be wrapped.
Top

See Also

Reference

DDCell Class
GrapeCity.SpreadBuilder.Cells Namespace


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Alignment Property

Glossary Item Box

Sets or returns the horizontal alignment value for the cell.

Syntax

Visual Basic (Declaration)
Public Property Alignment As HorzAlignments
C#
public HorzAlignments Alignment {get; set;}

Property Value

HorzAlignments Enumeration. The default value is General.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members
HorzAlignments Enumeration


BorderBottomColor Property

[image]
ActiveReports 13
BorderBottomColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderBottomColor Property

Glossary Item Box

Sets or returns the color of the bottom border.

Syntax

Visual Basic (Declaration)
Public Property BorderBottomColor As Color
C#
public Color BorderBottomColor {get; set;}

Property Value

System.Drawing.Color.

Remarks

This property has no effect if the BorderBottomStyle property is not set.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderBottomStyle Property

[image]
ActiveReports 13
BorderBottomStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderBottomStyle Property

Glossary Item Box

Sets or returns the line style for the bottom portion of the cell's border.

Syntax

Visual Basic (Declaration)
Public Property BorderBottomStyle As BorderLineStyle
C#
public BorderLineStyle BorderBottomStyle {get; set;}

Property Value

BorderLineStyle enumeration.

Remarks

This property must be set for the BorderBottomColor property to have an effect.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderDiagonalColor Property

[image]
ActiveReports 13
BorderDiagonalColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderDiagonalColor Property

Glossary Item Box

Sets or returns the color of the diagonal border.

Syntax

Visual Basic (Declaration)
Public Property BorderDiagonalColor As Color
C#
public Color BorderDiagonalColor {get; set;}

Property Value

System.Drawing.Color.

Remarks

This property has no effect if the BorderDiagonalStyle and BorderDiagonalEnum properties are not set.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderDiagonalEnum Property

[image]
ActiveReports 13
BorderDiagonalEnum Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderDiagonalEnum Property

Glossary Item Box

Sets or returns a value indicating whether a diagonal border goes up or down, or both (which forms an "X" across the cell).

Syntax

Visual Basic (Declaration)
Public Property BorderDiagonalEnum As BorderDiagonalStyles
C#
public BorderDiagonalStyles BorderDiagonalEnum {get; set;}

Property Value

BorderDiagonalStyles enumeration.

Remarks

The default value of this property is DiagonalEnum=0, so if it is not set, no BorderDiagonal lines will be visible.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderDiagonalStyle Property

[image]
ActiveReports 13
BorderDiagonalStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderDiagonalStyle Property

Glossary Item Box

Sets or returns the line style for the diagonal portion of the cell's border.

Syntax

Visual Basic (Declaration)
Public Property BorderDiagonalStyle As BorderLineStyle
C#
public BorderLineStyle BorderDiagonalStyle {get; set;}

Property Value

BorderLineStyle enumeration.

Remarks

This property, as well as the BorderDiagonalEnum property, must be set for the BorderDiagonalColor property to have an effect.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderLeftColor Property

[image]
ActiveReports 13
BorderLeftColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderLeftColor Property

Glossary Item Box

Sets or returns the color of the left border.

Syntax

Visual Basic (Declaration)
Public Property BorderLeftColor As Color
C#
public Color BorderLeftColor {get; set;}

Property Value

System.Drawing.Color.

Remarks

This property has no effect if the BorderLeftStyle property is not set.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderLeftStyle Property

[image]
ActiveReports 13
BorderLeftStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderLeftStyle Property

Glossary Item Box

Sets or returns the line style for the left portion of the cell's border.

Syntax

Visual Basic (Declaration)
Public Property BorderLeftStyle As BorderLineStyle
C#
public BorderLineStyle BorderLeftStyle {get; set;}

Property Value

BorderLineStyle enumeration.

Remarks

This property must be set for the BorderLeftColor property to have an effect.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderRightColor Property

[image]
ActiveReports 13
BorderRightColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderRightColor Property

Glossary Item Box

Sets or returns the color of the right border.

Syntax

Visual Basic (Declaration)
Public Property BorderRightColor As Color
C#
public Color BorderRightColor {get; set;}

Property Value

System.Drawing.Color.

Remarks

This property has no effect if the BorderRightStyle property is not set.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderRightStyle Property

[image]
ActiveReports 13
BorderRightStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderRightStyle Property

Glossary Item Box

Sets or returns the line style for the right portion of the cell's border.

Syntax

Visual Basic (Declaration)
Public Property BorderRightStyle As BorderLineStyle
C#
public BorderLineStyle BorderRightStyle {get; set;}

Property Value

BorderLineStyle enumeration.

Remarks

This property must be set for the BorderRightColor property to have an effect.

Example

Visual Basic Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = True;
sb.Sheets[0].Cell(0,0).FontItalic = True;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = True;
C# Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderTopColor Property

[image]
ActiveReports 13
BorderTopColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderTopColor Property

Glossary Item Box

Sets or returns the color of the top border.

Syntax

Visual Basic (Declaration)
Public Property BorderTopColor As Color
C#
public Color BorderTopColor {get; set;}

Property Value

System.Drawing.Color.

Remarks

This property has no effect if the BorderTopStyle property is not set.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


BorderTopStyle Property

[image]
ActiveReports 13
BorderTopStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderTopStyle Property

Glossary Item Box

Sets or returns the line style for the top portion of the cell's border.

Syntax

Visual Basic (Declaration)
Public Property BorderTopStyle As BorderLineStyle
C#
public BorderLineStyle BorderTopStyle {get; set;}

Property Value

BorderLineStyle enumeration.

Remarks

This property must be set for the BorderTopColor property to have an effect.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


FillColor Property

[image]
ActiveReports 13
FillColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FillColor Property

Glossary Item Box

Sets or returns the background color for the cell.

Syntax

Visual Basic (Declaration)
Public Property FillColor As Color
C#
public Color FillColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Empty

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


FontBold Property

[image]
ActiveReports 13
FontBold Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontBold Property

Glossary Item Box

Sets or returns a value indicating whether the bold property of the cell's font is used.

Syntax

Visual Basic (Declaration)
Public Property FontBold As Boolean
C#
public bool FontBold {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook And add a sheet To its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties And values For columns, rows And cells As desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    //Save the Workbook To an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


FontItalic Property

[image]
ActiveReports 13
FontItalic Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontItalic Property

Glossary Item Box

Sets or returns a value indicating whether the cell's font's Italic property is used.

Syntax

Visual Basic (Declaration)
Public Property FontItalic As Boolean
C#
public bool FontItalic {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


FontName Property

[image]
ActiveReports 13
FontName Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontName Property

Glossary Item Box

Sets or returns the name of the font.

Syntax

Visual Basic (Declaration)
Public Property FontName As String
C#
public string FontName {get; set;}

Property Value

String.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


FontSize Property

[image]
ActiveReports 13
FontSize Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontSize Property

Glossary Item Box

Sets or returns a value indicating the point size to use in the cell's font size property.

Syntax

Visual Basic (Declaration)
Public Property FontSize As Double
C#
public double FontSize {get; set;}

Property Value

Double. The number size specified is rounded to the nearest half of a point.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


FontStrikeOut Property

[image]
ActiveReports 13
FontStrikeOut Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontStrikeOut Property

Glossary Item Box

Sets or returns a value indicating whether the text in the cell is rendered with a horizontal line striking through the text.

Syntax

Visual Basic (Declaration)
Public Property FontStrikeOut As Boolean
C#
public bool FontStrikeOut {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontStrikeOut = true;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontStrikeOut = True
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


FontUnderlineStyle Property

[image]
ActiveReports 13
FontUnderlineStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontUnderlineStyle Property

Glossary Item Box

Sets or returns the underline style for the cell.

Syntax

Visual Basic (Declaration)
Public Property FontUnderlineStyle As FontUnderlineStyles
C#
public FontUnderlineStyles FontUnderlineStyle {get; set;}

Property Value

FontUnderlineStyles enumeration.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : ForeColor Property

Glossary Item Box

Sets or returns the foreground color or text color of the cell.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Black.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


Hyperlink Property

[image]
ActiveReports 13
Hyperlink Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Hyperlink Property

Glossary Item Box

Sets or returns a hyperlink for the cell that will automatically be launched by Excel when it is clicked.

Syntax

Visual Basic (Declaration)
Public Property Hyperlink As String
C#
public string Hyperlink {get; set;}

Property Value

String.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


IsMerged Property

[image]
ActiveReports 13
IsMerged Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : IsMerged Property

Glossary Item Box

Sets or returns a value indicating whether the cell is in a merged group of cells.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMerged As Boolean
C#
public bool IsMerged {get;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


MergeArea Property

[image]
ActiveReports 13
MergeArea Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : MergeArea Property

Glossary Item Box

Returns a MergeArea object that represents the merged range containing this cell. If this cell is not in a merged area, this property returns MergeArea.Empty.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MergeArea As MergeArea
C#
public MergeArea MergeArea {get;}

Property Value

MergeArea object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


NumberFormat Property

[image]
ActiveReports 13
NumberFormat Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : NumberFormat Property

Glossary Item Box

Sets or returns an Excel-style number format string.

Syntax

Visual Basic (Declaration)
Public Property NumberFormat As String
C#
public string NumberFormat {get; set;}

Property Value

String.

Remarks

For foreign currency symbols such as the Japanese Yen you can use a format such as: "[$¥-0]#,##0.00". Replace the Yen sign (¥) with whatever currency symbol you want to use.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


TextAngle Property

[image]
ActiveReports 13
TextAngle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : TextAngle Property

Glossary Item Box

Sets or returns the text rotation for the cell in degrees.

Syntax

Visual Basic (Declaration)
Public Property TextAngle As Short
C#
public short TextAngle {get; set;}

Property Value

Short.

  • Values 0-90 angle the text upward 0-90 degrees.
  • Values 91-180 angle the text downward 1-90 degrees.
  • The value 255 is vertical.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


Type Property

[image]
ActiveReports 13
Type Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Type Property

Glossary Item Box

The type of cell this DDCell object represents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As CellTypes
C#
public CellTypes Type {get;}

Property Value

CellTypes enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


VertAlignment Property

[image]
ActiveReports 13
VertAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : VertAlignment Property

Glossary Item Box

Sets or returns the vertical alignment value for the cell.

Syntax

Visual Basic (Declaration)
Public Property VertAlignment As VertAlignments
C#
public VertAlignments VertAlignment {get; set;}

Property Value

VertAlignments enumeration.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


WrapText Property

[image]
ActiveReports 13
WrapText Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : WrapText Property

Glossary Item Box

Sets or returns a value indicating whether the cell's text can be wrapped.

Syntax

Visual Basic (Declaration)
Public Property WrapText As Boolean
C#
public bool WrapText {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
Visual Basic Copy Code
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCell Class
DDCell Members


DDCells Class

[image]
ActiveReports 13
DDCells Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCells Class

Glossary Item Box

Returns a DDCell instance for the specified cell number.

Object Model

DDCells Class

Syntax

Visual Basic (Declaration)
Public Class DDCells
C#
public class DDCells

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Cells.DDCells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Members
GrapeCity.SpreadBuilder.Cells Namespace


DDCells Class Members

[image]
ActiveReports 13
DDCells Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCells Class

Glossary Item Box

The following tables list the members exposed by DDCells.

Public Properties

 | Name | Description
Public Property | Alignment | Sets the horizontal alignment value for all cells.
Public Property | BorderBottomColor | Sets the color of the bottom border.
Public Property | BorderBottomStyle | Sets the line style for the bottom portion of each cell's border.
Public Property | BorderDiagonalColor | Sets the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets whether a diagonal border goes up or down, or both (which forms an "X" accross the cell).
Public Property | BorderDiagonalStyle | Sets/gets the line style for the diagonal portion of each cell's border.
Public Property | BorderLeftColor | Sets the color of the left border.
Public Property | BorderLeftStyle | Sets the line style for the left portion of each cell's border.
Public Property | BorderRightColor | Sets the color of the right border.
Public Property | BorderRightStyle | Sets the line style for the right portion of each cell's border.
Public Property | BorderTopColor | Sets the color of the top border.
Public Property | BorderTopStyle | Sets the line style for the top portion of each cell's border.
Public Property | Count | Gets the number of cells contained in this collection
Public Property | FillColor | Sets the "fill color" ("background color") for each cell.
Public Property | FontBold | Sets the bold property of the cell's font.
Public Property | FontItalic | Sets the italic property of the cell's font.
Public Property | FontName | Sets the name of the font.
Public Property | FontSize | Sets the size of the font in points. It will round the number size specified to the nearest half of a point.
Public Property | FontStrikeOut | Sets/gets the bold property of the cell's font.
Public Property | FontUnderlineStyle | Sets the underline style for the cell.
Public Property | ForeColor | Sets the "fore color" ("text color") for each cell.
Public Property | NumberFormat | Sets an Excel style number format string.
Public Property | TextAngle | Sets the text rotation for each cell, in degrees: Values 0-90 is up 0-90 degrees, values 91-180 is down 1-90 degrees, and the value 255 is vertical.
Public Property | VertAlignment | Sets vertical alignment value for all cells.
Public Property | WrapText | Gets/sets whether the cell's text can be wrapped or not.
Top

See Also

Reference

DDCells Class
GrapeCity.SpreadBuilder.Cells Namespace


DDCells Class Properties

[image]
ActiveReports 13
DDCells Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCells Class

Glossary Item Box

For a list of all members of this type, see DDCells members.

Public Properties

 | Name | Description
Public Property | Alignment | Sets the horizontal alignment value for all cells.
Public Property | BorderBottomColor | Sets the color of the bottom border.
Public Property | BorderBottomStyle | Sets the line style for the bottom portion of each cell's border.
Public Property | BorderDiagonalColor | Sets the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets whether a diagonal border goes up or down, or both (which forms an "X" accross the cell).
Public Property | BorderDiagonalStyle | Sets/gets the line style for the diagonal portion of each cell's border.
Public Property | BorderLeftColor | Sets the color of the left border.
Public Property | BorderLeftStyle | Sets the line style for the left portion of each cell's border.
Public Property | BorderRightColor | Sets the color of the right border.
Public Property | BorderRightStyle | Sets the line style for the right portion of each cell's border.
Public Property | BorderTopColor | Sets the color of the top border.
Public Property | BorderTopStyle | Sets the line style for the top portion of each cell's border.
Public Property | Count | Gets the number of cells contained in this collection
Public Property | FillColor | Sets the "fill color" ("background color") for each cell.
Public Property | FontBold | Sets the bold property of the cell's font.
Public Property | FontItalic | Sets the italic property of the cell's font.
Public Property | FontName | Sets the name of the font.
Public Property | FontSize | Sets the size of the font in points. It will round the number size specified to the nearest half of a point.
Public Property | FontStrikeOut | Sets/gets the bold property of the cell's font.
Public Property | FontUnderlineStyle | Sets the underline style for the cell.
Public Property | ForeColor | Sets the "fore color" ("text color") for each cell.
Public Property | NumberFormat | Sets an Excel style number format string.
Public Property | TextAngle | Sets the text rotation for each cell, in degrees: Values 0-90 is up 0-90 degrees, values 91-180 is down 1-90 degrees, and the value 255 is vertical.
Public Property | VertAlignment | Sets vertical alignment value for all cells.
Public Property | WrapText | Gets/sets whether the cell's text can be wrapped or not.
Top

See Also

Reference

DDCells Class
GrapeCity.SpreadBuilder.Cells Namespace


Alignment Property

[image]
ActiveReports 13
Alignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : Alignment Property

Glossary Item Box

Sets the horizontal alignment value for all cells.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Alignment As HorzAlignments
C#
public HorzAlignments Alignment {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderBottomColor Property

[image]
ActiveReports 13
BorderBottomColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderBottomColor Property

Glossary Item Box

Sets the color of the bottom border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderBottomColor As Color
C#
public Color BorderBottomColor {set;}

Remarks

See BorderTopColor property for more comments in the implementation of these BorderColor props.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderBottomStyle Property

[image]
ActiveReports 13
BorderBottomStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderBottomStyle Property

Glossary Item Box

Sets the line style for the bottom portion of each cell's border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderBottomStyle As BorderLineStyle
C#
public BorderLineStyle BorderBottomStyle {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderDiagonalColor Property

[image]
ActiveReports 13
BorderDiagonalColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderDiagonalColor Property

Glossary Item Box

Sets the color of the diagonal border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderDiagonalColor As Color
C#
public Color BorderDiagonalColor {set;}

Remarks

See BorderTopColor property for more comments in the implementation of these BorderColor props.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderDiagonalEnum Property

[image]
ActiveReports 13
BorderDiagonalEnum Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderDiagonalEnum Property

Glossary Item Box

Sets whether a diagonal border goes up or down, or both (which forms an "X" accross the cell).

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderDiagonalEnum As BorderDiagonalStyles
C#
public BorderDiagonalStyles BorderDiagonalEnum {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderDiagonalStyle Property

[image]
ActiveReports 13
BorderDiagonalStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderDiagonalStyle Property

Glossary Item Box

Sets/gets the line style for the diagonal portion of each cell's border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderDiagonalStyle As BorderLineStyle
C#
public BorderLineStyle BorderDiagonalStyle {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderLeftColor Property

[image]
ActiveReports 13
BorderLeftColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderLeftColor Property

Glossary Item Box

Sets the color of the left border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderLeftColor As Color
C#
public Color BorderLeftColor {set;}

Remarks

See BorderTopColor property for more comments in the implementation of these BorderColor props.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderLeftStyle Property

[image]
ActiveReports 13
BorderLeftStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderLeftStyle Property

Glossary Item Box

Sets the line style for the left portion of each cell's border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderLeftStyle As BorderLineStyle
C#
public BorderLineStyle BorderLeftStyle {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderRightColor Property

[image]
ActiveReports 13
BorderRightColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderRightColor Property

Glossary Item Box

Sets the color of the right border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderRightColor As Color
C#
public Color BorderRightColor {set;}

Remarks

See BorderTopColor property for more comments in the implementation of these BorderColor props.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderRightStyle Property

[image]
ActiveReports 13
BorderRightStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderRightStyle Property

Glossary Item Box

Sets the line style for the right portion of each cell's border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderRightStyle As BorderLineStyle
C#
public BorderLineStyle BorderRightStyle {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderTopColor Property

[image]
ActiveReports 13
BorderTopColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderTopColor Property

Glossary Item Box

Sets the color of the top border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderTopColor As Color
C#
public Color BorderTopColor {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BorderTopStyle Property

[image]
ActiveReports 13
BorderTopStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderTopStyle Property

Glossary Item Box

Sets the line style for the top portion of each cell's border.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property BorderTopStyle As BorderLineStyle
C#
public BorderLineStyle BorderTopStyle {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : Count Property

Glossary Item Box

Gets the number of cells contained in this collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


FillColor Property

[image]
ActiveReports 13
FillColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FillColor Property

Glossary Item Box

Sets the "fill color" ("background color") for each cell.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FillColor As Color
C#
public Color FillColor {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


FontBold Property

[image]
ActiveReports 13
FontBold Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontBold Property

Glossary Item Box

Sets the bold property of the cell's font.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FontBold As Boolean
C#
public bool FontBold {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


FontItalic Property

[image]
ActiveReports 13
FontItalic Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontItalic Property

Glossary Item Box

Sets the italic property of the cell's font.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FontItalic As Boolean
C#
public bool FontItalic {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


FontName Property

[image]
ActiveReports 13
FontName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontName Property

Glossary Item Box

Sets the name of the font.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FontName As String
C#
public string FontName {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


FontSize Property

[image]
ActiveReports 13
FontSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontSize Property

Glossary Item Box

Sets the size of the font in points. It will round the number size specified to the nearest half of a point.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FontSize As Double
C#
public double FontSize {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


FontStrikeOut Property

[image]
ActiveReports 13
FontStrikeOut Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontStrikeOut Property

Glossary Item Box

Sets/gets the bold property of the cell's font.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FontStrikeOut As Boolean
C#
public bool FontStrikeOut {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


FontUnderlineStyle Property

[image]
ActiveReports 13
FontUnderlineStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontUnderlineStyle Property

Glossary Item Box

Sets the underline style for the cell.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FontUnderlineStyle As FontUnderlineStyles
C#
public FontUnderlineStyles FontUnderlineStyle {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : ForeColor Property

Glossary Item Box

Sets the "fore color" ("text color") for each cell.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ForeColor As Color
C#
public Color ForeColor {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


NumberFormat Property

[image]
ActiveReports 13
NumberFormat Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : NumberFormat Property

Glossary Item Box

Sets an Excel style number format string.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property NumberFormat As String
C#
public string NumberFormat {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


TextAngle Property

[image]
ActiveReports 13
TextAngle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : TextAngle Property

Glossary Item Box

Sets the text rotation for each cell, in degrees: Values 0-90 is up 0-90 degrees, values 91-180 is down 1-90 degrees, and the value 255 is vertical.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property TextAngle As Short
C#
public short TextAngle {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


VertAlignment Property

[image]
ActiveReports 13
VertAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : VertAlignment Property

Glossary Item Box

Sets vertical alignment value for all cells.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property VertAlignment As VertAlignments
C#
public VertAlignments VertAlignment {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


WrapText Property

[image]
ActiveReports 13
WrapText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : WrapText Property

Glossary Item Box

Gets/sets whether the cell's text can be wrapped or not.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property WrapText As Boolean
C#
public bool WrapText {set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDCells Class
DDCells Members


BiffCellBoolErrValues Enumeration

[image]
ActiveReports 13
BiffCellBoolErrValues Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : BiffCellBoolErrValues Enumeration

Glossary Item Box

The values available for the BiffCellBoolErr.ValueBoolErr property.

Syntax

Visual Basic (Declaration)
Public Enum BiffCellBoolErrValues
   Inherits System.Enum
C#
public enum BiffCellBoolErrValues : System.Enum

Members

Member | Description
Div0 | Excel shows "#DIV/0!" as the error value when IsError is True.
False | Excel shows "False" as the error value when IsError is False.
NA | Excel shows "#N/A" as the error value when IsError is True.
Name | Excel shows "#NAME!" as the error value when IsError is True.
Null | Excel shows "#NULL!" as the error value when IsError is True.
Num | Excel shows "#NUM!" as the error value when IsError is True.
Ref | Excel shows "#REF!" as the error value when IsError is True.
True | Excel shows "True" as the error value when IsError is True.
Value | Excel shows "#VALUE!" as the error value when IsError is True.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Cells.BiffCellBoolErrValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Cells Namespace


CellTypes Enumeration

[image]
ActiveReports 13
CellTypes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : CellTypes Enumeration

Glossary Item Box

The available types of spreadsheet cells that SpreadBuilder supports. This value is used with the DDCell class's Type property to get a specific cell's type.

Syntax

Visual Basic (Declaration)
Public Enum CellTypes
   Inherits System.Enum
C#
public enum CellTypes : System.Enum

Members

Member | Description
Blank | The cell is empty.
BoolErr | The cell is a boolean error.
Label | The cell is a label.
Number | The cell is a number.

Remarks

At this time DDCell does not support all of Excel's cell types.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Cells.CellTypes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Cells Namespace


MergeArea Structure

[image]
ActiveReports 13
MergeArea Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

Glossary Item Box

A structure that represents a merged rectangular region of cells in the spreadsheet.

Object Model

MergeArea Structure

Syntax

Visual Basic (Declaration)
Public Structure MergeArea
   Inherits System.ValueType
C#
public struct MergeArea : System.ValueType

Remarks

This structure is immutable; you cannot change the values once an instance has been initialized. To extend or truncate an existing MergeArea, remove the existing one and add a new one representing the extended or truncated region.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.SpreadBuilder.Cells.MergeArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Members
GrapeCity.SpreadBuilder.Cells Namespace


MergeArea Structure Members

[image]
ActiveReports 13
MergeArea Structure Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

Glossary Item Box

The following tables list the members exposed by MergeArea.

Public Constructors

 | Name | Description
Public Constructor | MergeArea Constructor | Initializes a new instance of the MergeArea structure from the specified row and column to the specified row and column.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an empty merge area.
static (Shared in Visual Basic) | SizeOf | Returns the size of the merged area when written to BIFF.
Top

Public Properties

 | Name | Description
Public Property | ColumnFrom | The leftmost row of the merged area.
Public Property | ColumnTo | The rightmost row of the merged area.
Public Property | RowFrom | The topmost row of the merged area.
Public Property | RowTo | The bottommost row of the merged area.
Top

Public Methods

 | Name | Description
Public Method | ContainsCell | Returns a Boolean value indicating whether the specified cell is contained within the MergeArea.
Top

See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


MergeArea Constructor

[image]
ActiveReports 13
MergeArea Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : MergeArea Constructor

rowFrom
The top most row of the merged rectangular region.
rowTo
The bottom most row of the merged rectangular region.
columnFrom
The leftmost column of the merged rectangular region.
columnTo
The rightmost column of the merged rectangular region.

Glossary Item Box

Initializes a new instance of the MergeArea structure from the specified row and column to the specified row and column.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rowFrom As UShort, _
   ByVal rowTo As UShort, _
   ByVal columnFrom As UShort, _
   ByVal columnTo As UShort _
)
C#
public MergeArea(
   ushort rowFrom,
   ushort rowTo,
   ushort columnFrom,
   ushort columnTo
)

Parameters

rowFrom
The top most row of the merged rectangular region.
rowTo
The bottom most row of the merged rectangular region.
columnFrom
The leftmost column of the merged rectangular region.
columnTo
The rightmost column of the merged rectangular region.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


MergeArea Structure Methods

[image]
ActiveReports 13
MergeArea Structure Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

Glossary Item Box

For a list of all members of this type, see MergeArea members.

Public Methods

 | Name | Description
Public Method | ContainsCell | Returns a Boolean value indicating whether the specified cell is contained within the MergeArea.
Top

See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


ContainsCell Method

[image]
ActiveReports 13
ContainsCell Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : ContainsCell Method

row
The row of the cell.
column
The column of the cell.

Glossary Item Box

Returns a Boolean value indicating whether the specified cell is contained within the MergeArea.

Syntax

Visual Basic (Declaration)
Public Function ContainsCell( _
   ByVal row As Integer, _
   ByVal column As Integer _
) As Boolean
C#
public bool ContainsCell(
   int row,
   int column
)

Parameters

row
The row of the cell.
column
The column of the cell.

Return Value

True if the MergeArea contains the specified cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


MergeArea Structure Properties

[image]
ActiveReports 13
MergeArea Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

Glossary Item Box

For a list of all members of this type, see MergeArea members.

Public Properties

 | Name | Description
Public Property | ColumnFrom | The leftmost row of the merged area.
Public Property | ColumnTo | The rightmost row of the merged area.
Public Property | RowFrom | The topmost row of the merged area.
Public Property | RowTo | The bottommost row of the merged area.
Top

See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


ColumnFrom Property

[image]
ActiveReports 13
ColumnFrom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : ColumnFrom Property

Glossary Item Box

The leftmost row of the merged area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnFrom As UShort
C#
public ushort ColumnFrom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


ColumnTo Property

[image]
ActiveReports 13
ColumnTo Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : ColumnTo Property

Glossary Item Box

The rightmost row of the merged area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnTo As UShort
C#
public ushort ColumnTo {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


RowFrom Property

[image]
ActiveReports 13
RowFrom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : RowFrom Property

Glossary Item Box

The topmost row of the merged area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowFrom As UShort
C#
public ushort RowFrom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


RowTo Property

[image]
ActiveReports 13
RowTo Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : RowTo Property

Glossary Item Box

The bottommost row of the merged area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowTo As UShort
C#
public ushort RowTo {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


MergeArea Structure Fields

[image]
ActiveReports 13
MergeArea Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

Glossary Item Box

For a list of all members of this type, see MergeArea members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an empty merge area.
static (Shared in Visual Basic) | SizeOf | Returns the size of the merged area when written to BIFF.
Top

See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : Empty Field

Glossary Item Box

Represents an empty merge area.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As MergeArea
C#
public static readonly MergeArea Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


SizeOf Field

[image]
ActiveReports 13
SizeOf Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : SizeOf Field

Glossary Item Box

Returns the size of the merged area when written to BIFF.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SizeOf As Short
C#
public static readonly short SizeOf

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MergeArea Structure
MergeArea Members


GrapeCity.SpreadBuilder.Imaging Namespace

GrapeCity.SpreadBuilder.Imaging Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Imaging Namespace

Glossary Item Box

The GrapeCity.SpreadBuilder.Imaging namespace contains the LineInfo class.

Classes

 | Class | Description
Class | Biff7PictureRecord | This class represents the binary representation of an OBJ record for BIFF7 Pictures. The picture data will be saved as WMF or BMP depending on what is programmatically determined to be more appropriate. Essentially it will be stored as an OBJ record with some additional "subrecord" fields specific to pictures in BIFF7.
Class | LineInfo | The LineInfo class represents a line on a spreadsheet, and all of its settings.

Structures

 | Structure | Description
Structure | ImageInfo | The ImageInfo structure is used by DDSheet.AddImage to specify various options about the image.Initializes a new instance of the ImageInfo structure.

Enumerations

 | Enumeration | Description
Enumeration | ImageLineStyle | Used with ImageInfo.LineStyle to specify the style of the line bounding an image.
Enumeration | ImageLineWeight | Used with ImageInfo.LineWeight to specify the weight of a line bounding an image.
Enumeration | LineArrowHeadLengths | Enumerated type for the Excel arrowhead length.
Enumeration | LineArrowHeadStyles | Excel enumerated type for arrowhead styles.
Enumeration | LineArrowHeadWidths | Enumerated type for Excel arrowhead widths.
Enumeration | LineStyles | Contains the various line styles for several versions of BIFF. Note that some values are not valid in some versions of the Excel BIFF file format.
Enumeration | ObjectDirection | Defines the direction in which a line should render.
Enumeration | SBFloatingMoveType | Defines whether users will be allowed to move or resize the line with cells in the spreadsheet.

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


Biff7PictureRecord Class

[image]
ActiveReports 13
Biff7PictureRecord Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : Biff7PictureRecord Class

Glossary Item Box

This class represents the binary representation of an OBJ record for BIFF7 Pictures. The picture data will be saved as WMF or BMP depending on what is programmatically determined to be more appropriate. Essentially it will be stored as an OBJ record with some additional "subrecord" fields specific to pictures in BIFF7.

Object Model

Biff7PictureRecord Class

Syntax

Visual Basic (Declaration)
Public Class Biff7PictureRecord
C#
public class Biff7PictureRecord

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Imaging.Biff7PictureRecord

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Biff7PictureRecord Members
GrapeCity.SpreadBuilder.Imaging Namespace


Biff7PictureRecord Class Members

[image]
ActiveReports 13
Biff7PictureRecord Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : Biff7PictureRecord Class

Glossary Item Box

The following tables list the members exposed by Biff7PictureRecord.

Public Constructors

 | Name | Description
Public Constructor | Biff7PictureRecord Constructor | Initializes a new instance of Biff7PictureRecord class.
Top

See Also

Reference

Biff7PictureRecord Class
GrapeCity.SpreadBuilder.Imaging Namespace


Biff7PictureRecord Constructor

[image]
ActiveReports 13
Biff7PictureRecord Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > Biff7PictureRecord Class : Biff7PictureRecord Constructor

Glossary Item Box

Initializes a new instance of Biff7PictureRecord class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Biff7PictureRecord()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Biff7PictureRecord Class
Biff7PictureRecord Members


LineInfo Class

[image]
ActiveReports 13
LineInfo Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class

Glossary Item Box

The LineInfo class represents a line on a spreadsheet, and all of its settings.

Object Model

LineInfo Class

Syntax

Visual Basic (Declaration)
Public Class LineInfo
C#
public class LineInfo

Example

C# Copy Code
Private void btnSpread_Click(Object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();

    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    GrapeCity.SpreadBuilder.Imaging.LineInfo l = new GrapeCity.SpreadBuilder.Imaging.LineInfo();
    l.ColumnLeft = 3; //starting column for the line
    l.Color = System.Drawing.Color.Salmon; //color for the line
    l.ColumnRight = 8; //ending column for the line
    l.dxL = 50;
    l.dxR = 60;
    l.dyB = 80;
    l.dyT = 10;
    l.EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the ending arrowhead
    l.EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the ending arrowhead
    l.EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide; //width of the ending arrowhead
    l.fAuto = true;
    l.iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight; //direction of the line
    l.MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize; //sets whether user will be able to move and/or resize the line
    l.RowBottom = 8; //bottom row for the line
    l.RowTop = 1; //top row for the line
    l.StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the starting arrowhead
    l.StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the starting arrowhead
    l.StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide;
    l.Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash; //style of the line
    l.Weight = 5; //thickness of the line

    sb.Sheets[0].AddLine(l);

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
Visual Basic Copy Code
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        .Rows(0).AutoSize = False
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
    End With
    Dim l As New GrapeCity.SpreadBuilder.Imaging.LineInfo
    With l
        .ColumnLeft = 3 'starting column for the line
        .Color = System.Drawing.Color.Salmon 'color for the line
        .ColumnRight = 8 'ending column for the line
        .dxL = 50
        .dxR = 60
        .dyB = 80
        .dyT = 10
        .EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the ending arrowhead
        .EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the ending arrowhead
        .EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide 'width of the ending arrowhead
        .fAuto = True
        .iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight 'direction of the line
        .MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize 'sets whether user will be able to move and/or resize the line
        .RowBottom = 8 'bottom row for the line
        .RowTop = 1 'top row for the line
        .StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the starting arrowhead
        .StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the starting arrowhead
        .StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide
        .Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash 'style of the line
        .Weight = 5 'thickness of the line
    End With
    sb.Sheets(0).AddLine(l)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MessageBox.Show("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Imaging.LineInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Members
GrapeCity.SpreadBuilder.Imaging Namespace


LineInfo Class Members

[image]
ActiveReports 13
LineInfo Class Members
See Also Fields Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class

Glossary Item Box

The following tables list the members exposed by LineInfo.

Public Constructors

 | Name | Description
Public Constructor | LineInfo Constructor | Initializes a new instance of the LineInfo class.
Top

Public Fields

 | Name | Description
Public Field | Color | The System.Drawing.Color for the line.
Public Field | dxL | The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
Public Field | dxR | The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
Public Field | dyB | The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | dyT | The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | EndAHLength | The length of the ending arrowhead.
Public Field | EndAHStyle | The style of the ending arrowhead.
Public Field | EndAHWidth | The width of the ending arrowhead.
Public Field | fAuto | Excel automatic border option.
Public Field | iQu | The direction of the line. Use GrapeCity.SpreadBuilder.Escher.LineDirections constants to define the "quadrant index."
Public Field | MoveType | The options users will have for moving or resizing the line with cells in spreadsheet.
Public Field | StartAHLength | The length of the starting arrowhead.
Public Field | StartAHStyle | The style of the starting arrowhead.
Public Field | StartAHWidth | The width of the starting arrowhead.
Public Field | Style | The style of the line.
Public Field | Weight | The thickness of the line.
Top

Public Properties

 | Name | Description
Public Property | ColumnLeft | Column containing the upper-left corner of the object's bounding rectangle.
Public Property | ColumnRight | Column containing the lower-right corner of the object's bounding rectangle.
Public Property | RowBottom | Row containing the lower-right corner of the object's bounding rectangle.
Public Property | RowTop | Row containing the upper-left corner of the object's bounding rectangle.
Top

See Also

Reference

LineInfo Class
GrapeCity.SpreadBuilder.Imaging Namespace


LineInfo Constructor()

[image]
ActiveReports 13
LineInfo Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class > LineInfo Constructor : LineInfo Constructor()

Glossary Item Box

Initializes a new instance of the LineInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public LineInfo()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members
Overload List


LineInfo Class Properties

[image]
ActiveReports 13
LineInfo Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class

Glossary Item Box

For a list of all members of this type, see LineInfo members.

Public Properties

 | Name | Description
Public Property | ColumnLeft | Column containing the upper-left corner of the object's bounding rectangle.
Public Property | ColumnRight | Column containing the lower-right corner of the object's bounding rectangle.
Public Property | RowBottom | Row containing the lower-right corner of the object's bounding rectangle.
Public Property | RowTop | Row containing the upper-left corner of the object's bounding rectangle.
Top

See Also

Reference

LineInfo Class
GrapeCity.SpreadBuilder.Imaging Namespace


ColumnLeft Property

[image]
ActiveReports 13
ColumnLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : ColumnLeft Property

Glossary Item Box

Column containing the upper-left corner of the object's bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Property ColumnLeft As Integer
C#
public int ColumnLeft {get; set;}

Remarks

Cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


ColumnRight Property

[image]
ActiveReports 13
ColumnRight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : ColumnRight Property

Glossary Item Box

Column containing the lower-right corner of the object's bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Property ColumnRight As Integer
C#
public int ColumnRight {get; set;}

Remarks

Cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


RowBottom Property

[image]
ActiveReports 13
RowBottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : RowBottom Property

Glossary Item Box

Row containing the lower-right corner of the object's bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Property RowBottom As Integer
C#
public int RowBottom {get; set;}

Remarks

Cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


RowTop Property

[image]
ActiveReports 13
RowTop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : RowTop Property

Glossary Item Box

Row containing the upper-left corner of the object's bounding rectangle.

Syntax

Visual Basic (Declaration)
Public Property RowTop As Integer
C#
public int RowTop {get; set;}

Remarks

Cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


LineInfo Class Fields

[image]
ActiveReports 13
LineInfo Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class

Glossary Item Box

For a list of all members of this type, see LineInfo members.

Public Fields

 | Name | Description
Public Field | Color | The System.Drawing.Color for the line.
Public Field | dxL | The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
Public Field | dxR | The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
Public Field | dyB | The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | dyT | The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | EndAHLength | The length of the ending arrowhead.
Public Field | EndAHStyle | The style of the ending arrowhead.
Public Field | EndAHWidth | The width of the ending arrowhead.
Public Field | fAuto | Excel automatic border option.
Public Field | iQu | The direction of the line. Use GrapeCity.SpreadBuilder.Escher.LineDirections constants to define the "quadrant index."
Public Field | MoveType | The options users will have for moving or resizing the line with cells in spreadsheet.
Public Field | StartAHLength | The length of the starting arrowhead.
Public Field | StartAHStyle | The style of the starting arrowhead.
Public Field | StartAHWidth | The width of the starting arrowhead.
Public Field | Style | The style of the line.
Public Field | Weight | The thickness of the line.
Top

See Also

Reference

LineInfo Class
GrapeCity.SpreadBuilder.Imaging Namespace


Color Field

[image]
ActiveReports 13
Color Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : Color Field

Glossary Item Box

The System.Drawing.Color for the line.

Syntax

Visual Basic (Declaration)
Public Color As Color
C#
public Color Color

Field Value

System.Drawing.Color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


dxL Field

[image]
ActiveReports 13
dxL Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dxL Field

Glossary Item Box

The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.

Syntax

Visual Basic (Declaration)
Public dxL As Short
C#
public short dxL

Field Value

Short.

Remarks

This value cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


dxR Field

[image]
ActiveReports 13
dxR Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dxR Field

Glossary Item Box

The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.

Syntax

Visual Basic (Declaration)
Public dxR As Short
C#
public short dxR

Field Value

Short.

Remarks

This value cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


dyB Field

[image]
ActiveReports 13
dyB Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dyB Field

Glossary Item Box

The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.

Syntax

Visual Basic (Declaration)
Public dyB As Short
C#
public short dyB

Field Value

Short.

Remarks

This value cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


dyT Field

[image]
ActiveReports 13
dyT Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dyT Field

Glossary Item Box

The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.

Syntax

Visual Basic (Declaration)
Public dyT As Short
C#
public short dyT

Field Value

Short.

Remarks

This value cannot be negative.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


EndAHLength Field

[image]
ActiveReports 13
EndAHLength Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : EndAHLength Field

Glossary Item Box

The length of the ending arrowhead.

Syntax

Visual Basic (Declaration)
Public EndAHLength As LineArrowHeadLengths
C#
public LineArrowHeadLengths EndAHLength

Field Value

A LineArrowHeadLengths enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


EndAHStyle Field

[image]
ActiveReports 13
EndAHStyle Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : EndAHStyle Field

Glossary Item Box

The style of the ending arrowhead.

Syntax

Visual Basic (Declaration)
Public EndAHStyle As LineArrowHeadStyles
C#
public LineArrowHeadStyles EndAHStyle

Field Value

A LineArrowHeadStyles enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


EndAHWidth Field

[image]
ActiveReports 13
EndAHWidth Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : EndAHWidth Field

Glossary Item Box

The width of the ending arrowhead.

Syntax

Visual Basic (Declaration)
Public EndAHWidth As LineArrowHeadWidths
C#
public LineArrowHeadWidths EndAHWidth

Field Value

A LineArrowHeadWidths enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


fAuto Field

[image]
ActiveReports 13
fAuto Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : fAuto Field

Glossary Item Box

Excel automatic border option.

Syntax

Visual Basic (Declaration)
Public fAuto As Boolean
C#
public bool fAuto

Field Value

Boolean.

Remarks

Set fAuto to 1 if you want the Excel automatic border option turned on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


iQu Field

[image]
ActiveReports 13
iQu Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : iQu Field

Glossary Item Box

The direction of the line. Use GrapeCity.SpreadBuilder.Escher.LineDirections constants to define the "quadrant index."

Syntax

Visual Basic (Declaration)
Public iQu As ObjectDirection
C#
public ObjectDirection iQu

Field Value

An ObjectDirection enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


MoveType Field

[image]
ActiveReports 13
MoveType Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : MoveType Field

Glossary Item Box

The options users will have for moving or resizing the line with cells in spreadsheet.

Syntax

Visual Basic (Declaration)
Public MoveType As SBFloatingMoveType
C#
public SBFloatingMoveType MoveType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


StartAHLength Field

[image]
ActiveReports 13
StartAHLength Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : StartAHLength Field

Glossary Item Box

The length of the starting arrowhead.

Syntax

Visual Basic (Declaration)
Public StartAHLength As LineArrowHeadLengths
C#
public LineArrowHeadLengths StartAHLength

Field Value

A LineArrowHeadLengths enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


StartAHStyle Field

[image]
ActiveReports 13
StartAHStyle Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : StartAHStyle Field

Glossary Item Box

The style of the starting arrowhead.

Syntax

Visual Basic (Declaration)
Public StartAHStyle As LineArrowHeadStyles
C#
public LineArrowHeadStyles StartAHStyle

Field Value

A LineArrowHeadStyles enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


StartAHWidth Field

[image]
ActiveReports 13
StartAHWidth Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : StartAHWidth Field

Glossary Item Box

The width of the starting arrowhead.

Syntax

Visual Basic (Declaration)
Public StartAHWidth As LineArrowHeadWidths
C#
public LineArrowHeadWidths StartAHWidth

Field Value

A LineArrowHeadWidths enumeration value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


Style Field

[image]
ActiveReports 13
Style Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : Style Field

Glossary Item Box

The style of the line.

Syntax

Visual Basic (Declaration)
Public Style As LineStyles
C#
public LineStyles Style

Field Value

A LineStyles enumeration value.

Remarks

Effect for Microsoft Excel 97 file format (BIFF8):

0-Solid
1-Small Dash (No Equivalent Menu for Excel 2000)
2-Square Dot
3-Small Dash, Square Dot (No Equivalent Menu for Excel 2000)
4-Small Dash, Square Dot, Square Dot (No Equivalent Menu for Excel 2000)
5-Loosely spaced Square Dot (No Equivalent Menu for Excel 2000)
6-Dash
7-Long Dash
8-Dash Dot
9-Long Dash Dot
10-Long Dash Dot Dot
11-Round Dot

Effect for versions 3, 4, 5, and 7.

0-Solid
1-Long Dash
2-Dash
3-Long Dash Dot
4-Long Dash Dot Dot
5-Pattern 50% Solid (No Equivalent Menu for Excel 2000)
6-Pattern 75% Solid (No Equivalent Menu for Excel 2000)
7-Pattern 25% Solid (No Equivalent Menu for Excel 2000)
15-Transparent (No Line)

Version 2 does not support lines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


Weight Field

[image]
ActiveReports 13
Weight Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : Weight Field

Glossary Item Box

The thickness of the line.

Syntax

Visual Basic (Declaration)
Public Weight As Integer
C#
public int Weight

Field Value

An Excel enumerated line weight value.

Remarks

Effect for Microsoft Excel 97 file format (BIFF8):

Parameter will generate line with weight parameter as points.

Effect for versions 3, 4, 5, and 7.

0-Hairline: 0 points
1-Single: .75 points
2-Double: 1.35 points
3-Thick: 1.95 points

Version 2 does not support lines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


ImageLineStyle Enumeration

[image]
ActiveReports 13
ImageLineStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageLineStyle Enumeration

Glossary Item Box

Used with ImageInfo.LineStyle to specify the style of the line bounding an image.

Syntax

Visual Basic (Declaration)
Public Enum ImageLineStyle
   Inherits System.Enum
C#
public enum ImageLineStyle : System.Enum

Members

Member | Description
DarkGray | Renders a dark gray line.
Dash | Renders a dashed line.
DashDot | Renders a line of alternating dashes and dots.
DashDotDot | Renders a line of alternating dashes and pairs of dots.
Dot | Renders a dotted line.
LightGray | Renders a light gray line.
MediumGray | Renders a medium gray line.
Null | Renders no line.
Solid | Renders a solid line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.ImageLineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


ImageLineWeight Enumeration

[image]
ActiveReports 13
ImageLineWeight Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageLineWeight Enumeration

Glossary Item Box

Used with ImageInfo.LineWeight to specify the weight of a line bounding an image.

Syntax

Visual Basic (Declaration)
Public Enum ImageLineWeight
   Inherits System.Enum
C#
public enum ImageLineWeight : System.Enum

Members

Member | Description
Double | Renders a double line around the image.
Hairline | Renders a thin line around the image.
Single | Renders a single line around the image.
Thick | Renders a thick line around the image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.ImageLineWeight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineArrowHeadLengths Enumeration

[image]
ActiveReports 13
LineArrowHeadLengths Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineArrowHeadLengths Enumeration

Glossary Item Box

Enumerated type for the Excel arrowhead length.

Syntax

Visual Basic (Declaration)
Public Enum LineArrowHeadLengths
   Inherits System.Enum
C#
public enum LineArrowHeadLengths : System.Enum

Members

Member | Description
Long | Renders a long arrowhead on the line.
Medium | Renders a medium-length arrowhead on the line.
Short | Renders a short arrowhead on the line.

Remarks

Used with DDSheet.AddLine(..).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineArrowHeadStyles Enumeration

[image]
ActiveReports 13
LineArrowHeadStyles Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineArrowHeadStyles Enumeration

Glossary Item Box

Excel enumerated type for arrowhead styles.

Syntax

Visual Basic (Declaration)
Public Enum LineArrowHeadStyles
   Inherits System.Enum
C#
public enum LineArrowHeadStyles : System.Enum

Members

Member | Description
DoubleEndedFilled | Renders a line with a circular arrowhead.
DoubleEndedOpen | Renders a line with a diamond-shaped arrowhead.
Filled | Renders a line with a stylized, arrow-shaped arrowhead.
None | Renders a line with no arrowhead.
Open | Renders a line with a triangular arrowhead.

Remarks

Used with DDSheet.AddLine(..).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineArrowHeadWidths Enumeration

[image]
ActiveReports 13
LineArrowHeadWidths Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineArrowHeadWidths Enumeration

Glossary Item Box

Enumerated type for Excel arrowhead widths.

Syntax

Visual Basic (Declaration)
Public Enum LineArrowHeadWidths
   Inherits System.Enum
C#
public enum LineArrowHeadWidths : System.Enum

Members

Member | Description
Medium | Renders a line with a medium-width arrowhead.
Narrow | Renders a line with a narrow arrowhead.
Wide | Renders a line with a wide arrowhead.

Remarks

Used with DDSheet.AddLine(..).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineStyles Enumeration

[image]
ActiveReports 13
LineStyles Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineStyles Enumeration

Glossary Item Box

Contains the various line styles for several versions of BIFF. Note that some values are not valid in some versions of the Excel BIFF file format.

Syntax

Visual Basic (Declaration)
Public Enum LineStyles
   Inherits System.Enum
C#
public enum LineStyles : System.Enum

Members

Member | Description
Dash | Renders a dashed line.
DashDot | Renders a line of alternating dashes and dots.
LongDash | Renders a line of long dashes.
LongDashDot | Renders a line of alternating long dashes and dots.
LongDashDotDot | Renders a line of alternating long dashes and pairs of dots.
LooselySpacedSquareDot | Renders a line of loosely spaced square dots.
OldTransparent | Renders no line, i.e. Transparent. Only effective in BIFF versions 3, 4, 5, and 7.
RoundDot | Renders a line of round dots.
SmallDash | Renders a line of small dashes. (No equivalent in Excel 2000.)
SmallDashSquareDot | Renders a line of alternating small dashes and square dots.
SmallDashSquareDotSquareDot | Renders a line of alternating small dashes and pairs of square dots.
Solid | Renders a solid line.
SquareDot | Renders a line of square dots.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


ObjectDirection Enumeration

[image]
ActiveReports 13
ObjectDirection Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ObjectDirection Enumeration

Glossary Item Box

Defines the direction in which a line should render.

Syntax

Visual Basic (Declaration)
Public Enum ObjectDirection
   Inherits System.Enum
C#
public enum ObjectDirection : System.Enum

Members

Member | Description
LowerLeftToUpperRight | Renders the starting arrowhead at the lower left end of the line, and the ending arrowhead at the upper right end of the line.
LowerRightToUpperLeft | Renders the starting arrowhead at the lower right end of the line, and the ending arrowhead at the upper left end of the line.
UpperLeftToLowerRight | Renders the starting arrowhead at the upper left end of the line, and the ending arrowhead at the lower right end of the line.
UpperRightToLowerLeft | Renders the starting arrowhead at the upper left end of the line, and the ending arrowhead at the lower right end of the line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.ObjectDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


SBFloatingMoveType Enumeration

[image]
ActiveReports 13
SBFloatingMoveType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : SBFloatingMoveType Enumeration

Glossary Item Box

Defines whether users will be allowed to move or resize the line with cells in the spreadsheet.

Syntax

Visual Basic (Declaration)
Public Enum SBFloatingMoveType
   Inherits System.Enum
C#
public enum SBFloatingMoveType : System.Enum

Members

Member | Description
MoveNoSize | The user may move the line with cells, but the size is fixed.
MoveSize | The user may move and resize the line with cells.
NoMoveNoSize | The line is fixed. The user can neither move it nor resize it with cells.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


ImageInfo Structure

[image]
ActiveReports 13
ImageInfo Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageInfo Structure

Glossary Item Box

The ImageInfo structure is used by DDSheet.AddImage to specify various options about the image.Initializes a new instance of the ImageInfo structure.

Object Model

ImageInfo Structure

Syntax

Visual Basic (Declaration)
Public Structure ImageInfo
   Inherits System.ValueType
C#
public struct ImageInfo : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.SpreadBuilder.Imaging.ImageInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Members
GrapeCity.SpreadBuilder.Imaging Namespace


ImageInfo Structure Members

[image]
ActiveReports 13
ImageInfo Structure Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageInfo Structure

Glossary Item Box

The following tables list the members exposed by ImageInfo.

Public Properties

 | Name | Description
Public Property | AutoFill | Sets or returns a value indicating whether the image should automatically fill the specified range of cells.
Public Property | AutoSize | Sets or returns a value indicating whether the image automatically moves and sizes with the cells.
Public Property | FillPattern | Sets or returns a value indicating whether the background of the image is filled.
Public Property | LineStyle | Specifies the style of the line bounding the image.
Public Property | LineWeight | Specifies the weight of the line bounding the image.
Public Property | MoveWithCells | Sets or returns a value indicating whether the image moves with the cells.
Public Property | QuadrantIndex | Sets or returns the direction in which the image begins and ends.
Top

See Also

Reference

ImageInfo Structure
GrapeCity.SpreadBuilder.Imaging Namespace


ImageInfo Structure Properties

[image]
ActiveReports 13
ImageInfo Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageInfo Structure

Glossary Item Box

For a list of all members of this type, see ImageInfo members.

Public Properties

 | Name | Description
Public Property | AutoFill | Sets or returns a value indicating whether the image should automatically fill the specified range of cells.
Public Property | AutoSize | Sets or returns a value indicating whether the image automatically moves and sizes with the cells.
Public Property | FillPattern | Sets or returns a value indicating whether the background of the image is filled.
Public Property | LineStyle | Specifies the style of the line bounding the image.
Public Property | LineWeight | Specifies the weight of the line bounding the image.
Public Property | MoveWithCells | Sets or returns a value indicating whether the image moves with the cells.
Public Property | QuadrantIndex | Sets or returns the direction in which the image begins and ends.
Top

See Also

Reference

ImageInfo Structure
GrapeCity.SpreadBuilder.Imaging Namespace


AutoFill Property

[image]
ActiveReports 13
AutoFill Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : AutoFill Property

Glossary Item Box

Sets or returns a value indicating whether the image should automatically fill the specified range of cells.

Syntax

Visual Basic (Declaration)
Public Property AutoFill As Boolean
C#
public bool AutoFill {get; set;}

Property Value

Boolean. Returns True if the Automatic Fill option is turned on in the Format Object dialog box, Patterns tab.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Structure
ImageInfo Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : AutoSize Property

Glossary Item Box

Sets or returns a value indicating whether the image automatically moves and sizes with the cells.

Syntax

Visual Basic (Declaration)
Public Property AutoSize As Boolean
C#
public bool AutoSize {get; set;}

Property Value

Boolean. If left False, the picture is clipped if it exceeds the area of the added image.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Structure
ImageInfo Members


FillPattern Property

[image]
ActiveReports 13
FillPattern Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : FillPattern Property

Glossary Item Box

Sets or returns a value indicating whether the background of the image is filled.

Syntax

Visual Basic (Declaration)
Public Property FillPattern As Boolean
C#
public bool FillPattern {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Structure
ImageInfo Members


LineStyle Property

[image]
ActiveReports 13
LineStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : LineStyle Property

Glossary Item Box

Specifies the style of the line bounding the image.

Syntax

Visual Basic (Declaration)
Public Property LineStyle As ImageLineStyle
C#
public ImageLineStyle LineStyle {get; set;}

Property Value

GrapeCity.SpreadBuilder.Imaging.ImageLineStyle enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Structure
ImageInfo Members


LineWeight Property

[image]
ActiveReports 13
LineWeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : LineWeight Property

Glossary Item Box

Specifies the weight of the line bounding the image.

Syntax

Visual Basic (Declaration)
Public Property LineWeight As ImageLineWeight
C#
public ImageLineWeight LineWeight {get; set;}

Property Value

GrapeCity.SpreadBuilder.Imaging.ImageLineWeight enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Structure
ImageInfo Members


MoveWithCells Property

[image]
ActiveReports 13
MoveWithCells Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : MoveWithCells Property

Glossary Item Box

Sets or returns a value indicating whether the image moves with the cells.

Syntax

Visual Basic (Declaration)
Public Property MoveWithCells As Boolean
C#
public bool MoveWithCells {get; set;}

Property Value

Boolean. Returns True if the object moves with the cells (Format Object dialog box, Properties tab).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Structure
ImageInfo Members


QuadrantIndex Property

[image]
ActiveReports 13
QuadrantIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : QuadrantIndex Property

Glossary Item Box

Sets or returns the direction in which the image begins and ends.

Syntax

Visual Basic (Declaration)
Public Property QuadrantIndex As ObjectDirection
C#
public ObjectDirection QuadrantIndex {get; set;}

Property Value

GrapeCity.SpreadBuilder.Imaging.ObjectDirection enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageInfo Structure
ImageInfo Members


GrapeCity.SpreadBuilder.Printing Namespace

GrapeCity.SpreadBuilder.Printing Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Printing Namespace

Glossary Item Box

The GrapeCity.SpreadBuilder.Printing namespace contains the PageSetup class.

Classes

 | Class | Description
Class | PageSetup | Represents page setup information for a worksheet such as margins, paper size, etc.

Enumerations

 | Enumeration | Description
Enumeration | PagePrintOrder | Used with the PageSetup.Order property to set the order in which pages are numbered when printing a large worksheet.
Enumeration | PagePrintOrientation | Used with PageSetup.Orientation to set pages to be printed in landscape or portrait.

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


PageSetup Class

[image]
ActiveReports 13
PageSetup Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class

Glossary Item Box

Represents page setup information for a worksheet such as margins, paper size, etc.

Object Model

PageSetup Class

Syntax

Visual Basic (Declaration)
Public Class PageSetup
C#
public class PageSetup

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Printing.PageSetup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Members
GrapeCity.SpreadBuilder.Printing Namespace


PageSetup Class Members

[image]
ActiveReports 13
PageSetup Class Members
See Also Fields Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class

Glossary Item Box

The following tables list the members exposed by PageSetup.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FirstPageNumberAuto | Use this value with PageSetup.FirstPageNumber to specify that the first page number used should be determined automatically.
Top

Public Properties

 | Name | Description
Public Property | BlackAndWhite | Sets or returns a value indicating whether elements of the document are printed in black and white.
Public Property | BottomMargin | Sets or returns the bottom margin value in points.
Public Property | Draft | Sets or returns a value indicating whether the sheet will be printed without graphics.
Public Property | FirstPageNumber | Returns or sets the first page number that will be used when this sheet is printed.
Public Property | FitToPage | Returns a value indicating whether the FitToPage option is selected in the page setup dialog.
Public Property | FitToPagesTall | Returns or sets the number of pages tall to which the worksheet will be scaled when it's printed.
Public Property | FitToPagesWide | Returns or sets the number of pages wide to which the worksheet will be scaled when it's printed.
Public Property | FooterMargin | Returns or sets the distance in points from the bottom of the page to the footer.
Public Property | HeaderMargin | Returns or sets the distance in points from the top of the page to the header.
Public Property | LeftMargin | Sets or returns the left margin value in points.
Public Property | Order | Returns or sets the order in which pages are numbered when printing a large worksheet.
Public Property | Orientation | Sets or returns a value indicating whether pages are printed in landscape or portrait.
Public Property | PaperSize | Sets or returns the size of the paper to use.
Public Property | PrintNotes | Sets or returns a value indicating whether cell notes are printed as end notes with the sheet.
Public Property | RightMargin | Sets or returns the right margin value in points.
Public Property | TopMargin | Sets or returns the top margin value in points.
Public Property | Zoom | Sets or returns the zoom value at which to print the spreadsheet.
Top

See Also

Reference

PageSetup Class
GrapeCity.SpreadBuilder.Printing Namespace


PageSetup Class Properties

[image]
ActiveReports 13
PageSetup Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class

Glossary Item Box

For a list of all members of this type, see PageSetup members.

Public Properties

 | Name | Description
Public Property | BlackAndWhite | Sets or returns a value indicating whether elements of the document are printed in black and white.
Public Property | BottomMargin | Sets or returns the bottom margin value in points.
Public Property | Draft | Sets or returns a value indicating whether the sheet will be printed without graphics.
Public Property | FirstPageNumber | Returns or sets the first page number that will be used when this sheet is printed.
Public Property | FitToPage | Returns a value indicating whether the FitToPage option is selected in the page setup dialog.
Public Property | FitToPagesTall | Returns or sets the number of pages tall to which the worksheet will be scaled when it's printed.
Public Property | FitToPagesWide | Returns or sets the number of pages wide to which the worksheet will be scaled when it's printed.
Public Property | FooterMargin | Returns or sets the distance in points from the bottom of the page to the footer.
Public Property | HeaderMargin | Returns or sets the distance in points from the top of the page to the header.
Public Property | LeftMargin | Sets or returns the left margin value in points.
Public Property | Order | Returns or sets the order in which pages are numbered when printing a large worksheet.
Public Property | Orientation | Sets or returns a value indicating whether pages are printed in landscape or portrait.
Public Property | PaperSize | Sets or returns the size of the paper to use.
Public Property | PrintNotes | Sets or returns a value indicating whether cell notes are printed as end notes with the sheet.
Public Property | RightMargin | Sets or returns the right margin value in points.
Public Property | TopMargin | Sets or returns the top margin value in points.
Public Property | Zoom | Sets or returns the zoom value at which to print the spreadsheet.
Top

See Also

Reference

PageSetup Class
GrapeCity.SpreadBuilder.Printing Namespace


BlackAndWhite Property

[image]
ActiveReports 13
BlackAndWhite Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : BlackAndWhite Property

Glossary Item Box

Sets or returns a value indicating whether elements of the document are printed in black and white.

Syntax

Visual Basic (Declaration)
Public Property BlackAndWhite As Boolean
C#
public bool BlackAndWhite {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


BottomMargin Property

[image]
ActiveReports 13
BottomMargin Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : BottomMargin Property

Glossary Item Box

Sets or returns the bottom margin value in points.

Syntax

Visual Basic (Declaration)
Public Property BottomMargin As Double
C#
public double BottomMargin {get; set;}

Property Value

Double. The default value is 72.

Remarks

The value MUST be greater than or equal to 0 and less than 3528.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


Draft Property

[image]
ActiveReports 13
Draft Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Draft Property

Glossary Item Box

Sets or returns a value indicating whether the sheet will be printed without graphics.

Syntax

Visual Basic (Declaration)
Public Property Draft As Boolean
C#
public bool Draft {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


FirstPageNumber Property

[image]
ActiveReports 13
FirstPageNumber Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FirstPageNumber Property

Glossary Item Box

Returns or sets the first page number that will be used when this sheet is printed.

Syntax

Visual Basic (Declaration)
Public Property FirstPageNumber As Short
C#
public short FirstPageNumber {get; set;}

Property Value

Short. The default value is PageSetup.FirstPageNumberAuto. With this value, the first page number will be chosen automatically.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


FitToPage Property

[image]
ActiveReports 13
FitToPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FitToPage Property

Glossary Item Box

Returns a value indicating whether the FitToPage option is selected in the page setup dialog.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FitToPage As Boolean
C#
public bool FitToPage {get;}

Property Value

Boolean. The default value is False.

Remarks

If FitToPagesWide or FitToPagesTall was set since the last Zoom, this property will return True to indicate that the FitToPage option in the Page Setup dialog is selected. If Zoom was set since FitToPagesWide or FitToPagesTall (or none of these properties were set at all) this property returns False, indicating that the zoom/percentage scaling option is selected.

Example

C# Copy Code
sb.Sheets[0].PageSetup.FitToPagesTall = 2;
sb.Sheets[0].PageSetup.FitToPagesWide = 2;

if (sb.Sheets[0].PageSetup.FitToPage == true)
{
    MessageBox.Show("FitToPage");
}
Visual Basic Copy Code
sb.Sheets(0).PageSetup.FitToPagesTall = 2
sb.Sheets(0).PageSetup.FitToPagesWide = 2

If sb.Sheets(0).PageSetup.FitToPage = True Then
    MsgBox("FitToPage")
End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


FitToPagesTall Property

[image]
ActiveReports 13
FitToPagesTall Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FitToPagesTall Property

Glossary Item Box

Returns or sets the number of pages tall to which the worksheet will be scaled when it's printed.

Syntax

Visual Basic (Declaration)
Public Property FitToPagesTall As Short
C#
public short FitToPagesTall {get; set;}

Property Value

Short.

Remarks

If the Zoom property is set to True, this property is ignored.

Example

C# Copy Code
sb.Sheets[0].PageSetup.FitToPagesTall = 2;
sb.Sheets[0].PageSetup.FitToPagesWide = 2;

if (sb.Sheets[0].PageSetup.FitToPage == true)
{
    MessageBox.Show("FitToPage");
}
Visual Basic Copy Code
sb.Sheets(0).PageSetup.FitToPagesTall = 2
sb.Sheets(0).PageSetup.FitToPagesWide = 2

If sb.Sheets(0).PageSetup.FitToPage = True Then
    MsgBox("FitToPage")
End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


FitToPagesWide Property

[image]
ActiveReports 13
FitToPagesWide Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FitToPagesWide Property

Glossary Item Box

Returns or sets the number of pages wide to which the worksheet will be scaled when it's printed.

Syntax

Visual Basic (Declaration)
Public Property FitToPagesWide As Short
C#
public short FitToPagesWide {get; set;}

Property Value

Short.

Remarks

If the Zoom property is set to True, this property is ignored.

Example

C# Copy Code
sb.Sheets[0].PageSetup.FitToPagesTall = 2;
sb.Sheets[0].PageSetup.FitToPagesWide = 2;

if (sb.Sheets[0].PageSetup.FitToPage == true)
{
    MessageBox.Show("FitToPage");
}
Visual Basic Copy Code
sb.Sheets(0).PageSetup.FitToPagesTall = 2
sb.Sheets(0).PageSetup.FitToPagesWide = 2

If sb.Sheets(0).PageSetup.FitToPage = True Then
    MsgBox("FitToPage")
End If

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


FooterMargin Property

[image]
ActiveReports 13
FooterMargin Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FooterMargin Property

Glossary Item Box

Returns or sets the distance in points from the bottom of the page to the footer.

Syntax

Visual Basic (Declaration)
Public Property FooterMargin As Double
C#
public double FooterMargin {get; set;}

Property Value

Short. The default value is 36.

Remarks

The value MUST be greater than or equal to 0 and less than 3528.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


HeaderMargin Property

[image]
ActiveReports 13
HeaderMargin Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : HeaderMargin Property

Glossary Item Box

Returns or sets the distance in points from the top of the page to the header.

Syntax

Visual Basic (Declaration)
Public Property HeaderMargin As Double
C#
public double HeaderMargin {get; set;}

Property Value

Short. The default value is 36.

Remarks

The value MUST be greater than or equal to 0 and less than 3528.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


LeftMargin Property

[image]
ActiveReports 13
LeftMargin Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : LeftMargin Property

Glossary Item Box

Sets or returns the left margin value in points.

Syntax

Visual Basic (Declaration)
Public Property LeftMargin As Double
C#
public double LeftMargin {get; set;}

Property Value

Double. The default value is 54.

Remarks

The value MUST be greater than or equal to 0 and less than 3528.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


Order Property

[image]
ActiveReports 13
Order Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Order Property

Glossary Item Box

Returns or sets the order in which pages are numbered when printing a large worksheet.

Syntax

Visual Basic (Declaration)
Public Property Order As PagePrintOrder
C#
public PagePrintOrder Order {get; set;}

Property Value

PagePrintOrder enumeration.

The default value is GrapeCity.SpreadBuilder.Printing.PagePrintOrder.DownThenOver

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


Orientation Property

[image]
ActiveReports 13
Orientation Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Orientation Property

Glossary Item Box

Sets or returns a value indicating whether pages are printed in landscape or portrait.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PagePrintOrientation
C#
public PagePrintOrientation Orientation {get; set;}

Property Value

PagePrintOrientation enumeration.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


PaperSize Property

[image]
ActiveReports 13
PaperSize Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : PaperSize Property

Glossary Item Box

Sets or returns the size of the paper to use.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As PaperKind
C#
public PaperKind PaperSize {get; set;}

Property Value

Printing.PaperKind enumeration. The default value is Letter.

Remarks

Custom paper size is not fully implemented at this time.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


PrintNotes Property

[image]
ActiveReports 13
PrintNotes Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : PrintNotes Property

Glossary Item Box

Sets or returns a value indicating whether cell notes are printed as end notes with the sheet.

Syntax

Visual Basic (Declaration)
Public Property PrintNotes As Boolean
C#
public bool PrintNotes {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


RightMargin Property

[image]
ActiveReports 13
RightMargin Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : RightMargin Property

Glossary Item Box

Sets or returns the right margin value in points.

Syntax

Visual Basic (Declaration)
Public Property RightMargin As Double
C#
public double RightMargin {get; set;}

Property Value

Double. The default value is 54.

Remarks

The value MUST be greater than or equal to 0 and less than 3528.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


TopMargin Property

[image]
ActiveReports 13
TopMargin Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : TopMargin Property

Glossary Item Box

Sets or returns the top margin value in points.

Syntax

Visual Basic (Declaration)
Public Property TopMargin As Double
C#
public double TopMargin {get; set;}

Property Value

Double. The default value is 72.

Remarks

The value MUST be greater than or equal to 0 and less than 3528.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


Zoom Property

[image]
ActiveReports 13
Zoom Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Zoom Property

Glossary Item Box

Sets or returns the zoom value at which to print the spreadsheet.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Short
C#
public short Zoom {get; set;}

Property Value

Short. The default value is 100%.

Example

C# Copy Code
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
Visual Basic Copy Code
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


PageSetup Class Fields

[image]
ActiveReports 13
PageSetup Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class

Glossary Item Box

For a list of all members of this type, see PageSetup members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | FirstPageNumberAuto | Use this value with PageSetup.FirstPageNumber to specify that the first page number used should be determined automatically.
Top

See Also

Reference

PageSetup Class
GrapeCity.SpreadBuilder.Printing Namespace


FirstPageNumberAuto Field

[image]
ActiveReports 13
FirstPageNumberAuto Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FirstPageNumberAuto Field

Glossary Item Box

Use this value with PageSetup.FirstPageNumber to specify that the first page number used should be determined automatically.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FirstPageNumberAuto As Short
C#
public static readonly short FirstPageNumberAuto

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSetup Class
PageSetup Members


PagePrintOrder Enumeration

[image]
ActiveReports 13
PagePrintOrder Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PagePrintOrder Enumeration

Glossary Item Box

Used with the PageSetup.Order property to set the order in which pages are numbered when printing a large worksheet.

Syntax

Visual Basic (Declaration)
Public Enum PagePrintOrder
   Inherits System.Enum
C#
public enum PagePrintOrder : System.Enum

Members

Member | Description
DownThenOver | For spreadsheets that are wider and longer than a single page, Excel will print the left side of the spreadsheet from top to bottom, and then go over to the right and print the right side of the spreadsheet from top to bottom.
OverThenDown | For spreadsheets that are wider and longer than a single page, Excel will print the top page of the spreadsheet from left to right, and then go down to the next page and print that part of the spreadsheet from left to right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Printing.PagePrintOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Printing Namespace


PagePrintOrientation Enumeration

[image]
ActiveReports 13
PagePrintOrientation Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PagePrintOrientation Enumeration

Glossary Item Box

Used with PageSetup.Orientation to set pages to be printed in landscape or portrait.

Syntax

Visual Basic (Declaration)
Public Enum PagePrintOrientation
   Inherits System.Enum
C#
public enum PagePrintOrientation : System.Enum

Members

Member | Description
Landscape | Prints in landscape orientation.
Portrait | Prints in portrait orientation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Printing.PagePrintOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Printing Namespace


GrapeCity.SpreadBuilder.Style Namespace

GrapeCity.SpreadBuilder.Style Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Style Namespace

Glossary Item Box

The GrapeCity.SpreadBuilder.Style namespace contains various style enumerations.

Enumerations

 | Enumeration | Description
Enumeration | BorderDiagonalStyles | Used with DDCell's BorderDiagonalEnum property to determine whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Enumeration | BorderLineStyle | Used to set the border line styles for DDCell's borders (i.e. BorderTopStyle, BorderBottomStyle, etc.).
Enumeration | FontUnderlineStyles | Used with the DDCell.FontUnderlineStyle property to set the underline style for the cell.
Enumeration | HorzAlignments | Used with the DDCell.Alignment property to set the the horizontal alignment value for the cell.
Enumeration | VertAlignments | Used with the DDCell.VertAlignment property to set the vertical alignment value for the cell.

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


BorderDiagonalStyles Enumeration

[image]
ActiveReports 13
BorderDiagonalStyles Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Style Namespace : BorderDiagonalStyles Enumeration

Glossary Item Box

Used with DDCell's BorderDiagonalEnum property to determine whether a diagonal border goes up or down, or both (which forms an "X" across the cell).

Syntax

Visual Basic (Declaration)
Public Enum BorderDiagonalStyles
   Inherits System.Enum
C#
public enum BorderDiagonalStyles : System.Enum

Members

Member | Description
Both | One diagonal border starts in the bottom left corner and goes to the upper right corner, and a second one starts in the upper left corner and goes to the bottom right corner, forming an X.
Down | The diagonal border starts in the upper left corner, and goes down to the lower right corner.
None | No diagonal border will be drawn.
Up | The diagonal border starts in the bottom left corner, and goes up to the upper right corner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


BorderLineStyle Enumeration

[image]
ActiveReports 13
BorderLineStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Style Namespace : BorderLineStyle Enumeration

Glossary Item Box

Used to set the border line styles for DDCell's borders (i.e. BorderTopStyle, BorderBottomStyle, etc.).

Syntax

Visual Basic (Declaration)
Public Enum BorderLineStyle
   Inherits System.Enum
C#
public enum BorderLineStyle : System.Enum

Members

Member | Description
DashDot | Renders a line of alternating dashes and dots.
DashDotDot | Renders a line of alternating dashes and pairs of dots.
Dashed | Renders a dashed line.
Dotted | Renders a dotted line.
Double | Renders two parallel lines.
Hair | Renders a very thin line.
Medium | Renders a medium-weight line.
MediumDashDot | Renders a medium-weight line of alternating dashes and dots.
MediumDashDotDot | Renders a medium-weight line of alternating dashes and pairs of dots.
MediumDashed | Renders a medium-weight dashed line.
None | Renders no line.
SlantedDashDot | Renders a line of slanted alternating dashes and dots.
Thick | Renders a thick line.
Thin | Renders a thin line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.BorderLineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


FontUnderlineStyles Enumeration

[image]
ActiveReports 13
FontUnderlineStyles Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Style Namespace : FontUnderlineStyles Enumeration

Glossary Item Box

Used with the DDCell.FontUnderlineStyle property to set the underline style for the cell.

Syntax

Visual Basic (Declaration)
Public Enum FontUnderlineStyles
   Inherits System.Enum
C#
public enum FontUnderlineStyles : System.Enum

Members

Member | Description
Double | Double underline.
DoubleAcc | Double accounting underline.
None | No underline.
Single | Single underline.
SingleAcc | Single accounting underline.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.FontUnderlineStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


HorzAlignments Enumeration

[image]
ActiveReports 13
HorzAlignments Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Style Namespace : HorzAlignments Enumeration

Glossary Item Box

Used with the DDCell.Alignment property to set the the horizontal alignment value for the cell.

Syntax

Visual Basic (Declaration)
Public Enum HorzAlignments
   Inherits System.Enum
C#
public enum HorzAlignments : System.Enum

Members

Member | Description
Center | Centers the text horizontally across the cell.
CenterAcrossSelection | Centers the text horizontally across the selected cells.
Fill | Repeats the text to fill the width of the cell.
General | This is the default value. Numbers are aligned to the right of the cell; letters are aligned to the left.
Justify | Horizontally justifies text that is distributed in a cell (indented from both sides).
Left | Aligns text to the left of the cell.
Right | Aligns text to the right of the cell.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.HorzAlignments

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


VertAlignments Enumeration

[image]
ActiveReports 13
VertAlignments Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Style Namespace : VertAlignments Enumeration

Glossary Item Box

Used with the DDCell.VertAlignment property to set the vertical alignment value for the cell.

Syntax

Visual Basic (Declaration)
Public Enum VertAlignments
   Inherits System.Enum
C#
public enum VertAlignments : System.Enum

Members

Member | Description
Bottom | Aligns text to the bottom of the cell.
Center | Centers text vertically in the cell.
Justify | Justifies text vertically in the cell.
Top | Aligns text to the top of the cell.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.VertAlignments

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


GrapeCity.ActiveReports.Export.Html.Page Namespace

GrapeCity.ActiveReports.Export.Html.Page Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html : GrapeCity.ActiveReports.Export.Html.Page Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Html.Page namespace contains the information related to HTML rendering extensions and settings.

Classes

 | Class | Description
Class | EmailRenderingExtensionSettings | Contains settings specific to the EmailRenderingExtension.
Class | HtmlRenderingExtension | Rendering extension responsible for rendering report to HTML format.
Class | Settings | Settings for the Html rendering extension.

See Also

Reference

GrapeCity.ActiveReports.Export.Html


EmailRenderingExtensionSettings Class

[image]
ActiveReports 13
EmailRenderingExtensionSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : EmailRenderingExtensionSettings Class

Glossary Item Box

Contains settings specific to the EmailRenderingExtension.

Object Model

EmailRenderingExtensionSettings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EmailRenderingExtensionSettings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public sealed class EmailRenderingExtensionSettings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Page.EmailRenderingExtensionSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmailRenderingExtensionSettings Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


EmailRenderingExtensionSettings Class Members

[image]
ActiveReports 13
EmailRenderingExtensionSettings Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : EmailRenderingExtensionSettings Class

Glossary Item Box

The following tables list the members exposed by EmailRenderingExtensionSettings.

Public Constructors

 | Name | Description
Public Constructor | EmailRenderingExtensionSettings Constructor | Overloaded.
Top

See Also

Reference

EmailRenderingExtensionSettings Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


EmailRenderingExtensionSettings Constructor

[image]
ActiveReports 13
EmailRenderingExtensionSettings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtensionSettings Class : EmailRenderingExtensionSettings Constructor

Glossary Item Box

Overload List

Overload | Description
EmailRenderingExtensionSettings Constructor() | Initializes a new instance of the EmailRenderingExtensionSettings class.
EmailRenderingExtensionSettings Constructor(NameValueCollection) | Initializes a new instance of the EmailRenderingExtensionSettings class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmailRenderingExtensionSettings Class
EmailRenderingExtensionSettings Members


EmailRenderingExtensionSettings Constructor()

[image]
ActiveReports 13
EmailRenderingExtensionSettings Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtensionSettings Class > EmailRenderingExtensionSettings Constructor : EmailRenderingExtensionSettings Constructor()

Glossary Item Box

Initializes a new instance of the EmailRenderingExtensionSettings class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public EmailRenderingExtensionSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmailRenderingExtensionSettings Class
EmailRenderingExtensionSettings Members
Overload List


EmailRenderingExtensionSettings Constructor(NameValueCollection)

[image]
ActiveReports 13
EmailRenderingExtensionSettings Constructor(NameValueCollection)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtensionSettings Class > EmailRenderingExtensionSettings Constructor : EmailRenderingExtensionSettings Constructor(NameValueCollection)

settings

Glossary Item Box

Initializes a new instance of the EmailRenderingExtensionSettings class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal settings As NameValueCollection _
)
C#
public EmailRenderingExtensionSettings(
   NameValueCollection settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmailRenderingExtensionSettings Class
EmailRenderingExtensionSettings Members
Overload List


HtmlRenderingExtension Class

[image]
ActiveReports 13
HtmlRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : HtmlRenderingExtension Class

Glossary Item Box

Rendering extension responsible for rendering report to HTML format.

Object Model

HtmlRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class HtmlRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public sealed class HtmlRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlRenderingExtension Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


HtmlRenderingExtension Class Members

[image]
ActiveReports 13
HtmlRenderingExtension Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : HtmlRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by HtmlRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | HtmlRenderingExtension Constructor | Initializes a new instance of the HtmlRenderingExtension class.
Top

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the HtmlRenderingExtension class.
Public Method | SetLinkProvider | Sets link provider.
Top

See Also

Reference

HtmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


HtmlRenderingExtension Constructor

[image]
ActiveReports 13
HtmlRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class : HtmlRenderingExtension Constructor

Glossary Item Box

Initializes a new instance of the HtmlRenderingExtension class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public HtmlRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members


HtmlRenderingExtension Class Methods

[image]
ActiveReports 13
HtmlRenderingExtension Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : HtmlRenderingExtension Class

Glossary Item Box

For a list of all members of this type, see HtmlRenderingExtension members.

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the HtmlRenderingExtension class.
Public Method | SetLinkProvider | Sets link provider.
Top

See Also

Reference

HtmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


GetSupportedSettings Method

[image]
ActiveReports 13
GetSupportedSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class : GetSupportedSettings Method

Glossary Item Box

Returns the settings for the HtmlRenderingExtension class.

Overload List

Overload | Description
GetSupportedSettings() | Returns settings of current HtmlRenderingExtension instance.
GetSupportedSettings(Boolean) | Returns settings of current HtmlRenderingExtension instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members


GetSupportedSettings() Method

[image]
ActiveReports 13
GetSupportedSettings() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Returns settings of current HtmlRenderingExtension instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings() As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

[image]
ActiveReports 13
GetSupportedSettings(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method

fpl
Returns the HTML rendering settings.

Glossary Item Box

Returns settings of current HtmlRenderingExtension instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings( _
   ByVal fpl As Boolean _
) As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings(
   bool fpl
)

Parameters

fpl
Returns the HTML rendering settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members
Overload List


SetLinkProvider Method

[image]
ActiveReports 13
SetLinkProvider Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class : SetLinkProvider Method

linkProvider

Glossary Item Box

Sets link provider.

Syntax

Visual Basic (Declaration)
Public Sub SetLinkProvider( _
   ByVal linkProvider As GrapeCity.ActiveReports.Export.Html.Page.ILinkProvider _
)
C#
public void SetLinkProvider(
   GrapeCity.ActiveReports.Export.Html.Page.ILinkProvider linkProvider
)

Parameters

linkProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members


Settings Class

[image]
ActiveReports 13
Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : Settings Class

Glossary Item Box

Settings for the Html rendering extension.

Object Model

Settings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Page.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


Settings Class Members

[image]
ActiveReports 13
Settings Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : Settings Class

Glossary Item Box

The following tables list the members exposed by Settings.

Public Constructors

 | Name | Description
Public Constructor | Settings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | EmbedImages | Gets or sets whether or not the images content will be contained inside the html file as Base64, or inside a different stream.
Public Property | Fragment | Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.
Public Property | LinkTarget | Gets or set the target for hyperlinks contained inside the report. By default this value is not set.
Public Property | MhtOutput | Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.
Public Property | Mode | Gets or sets the mode to use when rendering to html.
Public Property | OutputTOC | Indicates whether the report's existing TOC should be added in the output.
Public Property | RenderingEngine | Indicates whether we should use SVG internally or not.
Public Property | StyleStream | Gets or sets whether or not the CSS style information will be contained inside the html file, or inside a different stream. True indicates the CSS style information will be contained in its own stream; otherwise false. The default is true.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


Settings Constructor

[image]
ActiveReports 13
Settings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : Settings Constructor

Glossary Item Box

Overload List

Overload | Description
Settings Constructor() | Initializes a new instance of the Settings class.
Settings Constructor(NameValueCollection) | Initializes a new instance of the Settings class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Constructor()

[image]
ActiveReports 13
Settings Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class > Settings Constructor : Settings Constructor()

Glossary Item Box

Initializes a new instance of the Settings class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Settings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members
Overload List


Settings Constructor(NameValueCollection)

[image]
ActiveReports 13
Settings Constructor(NameValueCollection)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class > Settings Constructor : Settings Constructor(NameValueCollection)

settings

Glossary Item Box

Initializes a new instance of the Settings class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal settings As NameValueCollection _
)
C#
public Settings(
   NameValueCollection settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members
Overload List


Settings Class Properties

[image]
ActiveReports 13
Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Properties

 | Name | Description
Public Property | EmbedImages | Gets or sets whether or not the images content will be contained inside the html file as Base64, or inside a different stream.
Public Property | Fragment | Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.
Public Property | LinkTarget | Gets or set the target for hyperlinks contained inside the report. By default this value is not set.
Public Property | MhtOutput | Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.
Public Property | Mode | Gets or sets the mode to use when rendering to html.
Public Property | OutputTOC | Indicates whether the report's existing TOC should be added in the output.
Public Property | RenderingEngine | Indicates whether we should use SVG internally or not.
Public Property | StyleStream | Gets or sets whether or not the CSS style information will be contained inside the html file, or inside a different stream. True indicates the CSS style information will be contained in its own stream; otherwise false. The default is true.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


EmbedImages Property

[image]
ActiveReports 13
EmbedImages Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : EmbedImages Property

Glossary Item Box

Gets or sets whether or not the images content will be contained inside the html file as Base64, or inside a different stream.

Syntax

Visual Basic (Declaration)
Public Property EmbedImages As Boolean
C#
public bool EmbedImages {get; set;}

Property Value

A boolean value indicating whether or not to write the images content to a different stream, or embed it in the html file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Fragment Property

[image]
ActiveReports 13
Fragment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : Fragment Property

Glossary Item Box

Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.

Syntax

Visual Basic (Declaration)
Public Property Fragment As Boolean
C#
public bool Fragment {get; set;}

Property Value

A boolean value indicating whether or not to return the full html contents, or just the contents inside the body tag.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


LinkTarget Property

[image]
ActiveReports 13
LinkTarget Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : LinkTarget Property

Glossary Item Box

Gets or set the target for hyperlinks contained inside the report. By default this value is not set.

Syntax

Visual Basic (Declaration)
Public Property LinkTarget As String
C#
public string LinkTarget {get; set;}

Property Value

A string value representing the LinkTarget.

Remarks

You can target a window by specifying the window name, or specify to open the target in a new window by setting the value to _blank. Acceptable values are WindowName, _blank, _self, _parent, and _top.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MhtOutput Property

[image]
ActiveReports 13
MhtOutput Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : MhtOutput Property

Glossary Item Box

Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.

Syntax

Visual Basic (Declaration)
Public Property MhtOutput As Boolean
C#
public bool MhtOutput {get; set;}

Property Value

A boolean value indicating whether or not the output should be in Mht format.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Mode Property

[image]
ActiveReports 13
Mode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : Mode Property

Glossary Item Box

Gets or sets the mode to use when rendering to html.

Syntax

Visual Basic (Declaration)
Public Property Mode As GrapeCity.ActiveReports.Export.Html.Page.RenderMode
C#
public GrapeCity.ActiveReports.Export.Html.Page.RenderMode Mode {get; set;}

Property Value

RenderMode indicating the rendering mode to use.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


OutputTOC Property

[image]
ActiveReports 13
OutputTOC Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : OutputTOC Property

Glossary Item Box

Indicates whether the report's existing TOC should be added in the output.

Syntax

Visual Basic (Declaration)
Public Property OutputTOC As Boolean
C#
public bool OutputTOC {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


RenderingEngine Property

[image]
ActiveReports 13
RenderingEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : RenderingEngine Property

Glossary Item Box

Indicates whether we should use SVG internally or not.

Syntax

Visual Basic (Declaration)
Public Property RenderingEngine As GrapeCity.ActiveReports.Export.Html.Page.RenderingEngine
C#
public GrapeCity.ActiveReports.Export.Html.Page.RenderingEngine RenderingEngine {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


StyleStream Property

[image]
ActiveReports 13
StyleStream Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : StyleStream Property

Glossary Item Box

Gets or sets whether or not the CSS style information will be contained inside the html file, or inside a different stream. True indicates the CSS style information will be contained in its own stream; otherwise false. The default is true.

Syntax

Visual Basic (Declaration)
Public Property StyleStream As Boolean
C#
public bool StyleStream {get; set;}

Property Value

A boolean value indicating whether or not to write the CSS style information to a different stream, or embed it in the html file.

Remarks

When this value is set to False the full report will be rendered before being returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


GrapeCity.ActiveReports.Export.Html.Section Namespace

GrapeCity.ActiveReports.Export.Html.Section Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html : GrapeCity.ActiveReports.Export.Html.Section Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Html.Section namespace contains the Html export component.

Classes

 | Class | Description
Class | HtmlExport | Provides HTML creation functionality for ActiveReports documents.
Class | OutputHtmlFiles | OutputHtmlFiles is an implementation of the IHandleHtmlOutput interface that directs the HtmlExport object's output to files.

Enumerations

 | Enumeration | Description
Enumeration | BookmarkStyle | An enumeration of values for the HtmlExport.BookmarkStyle property.
Enumeration | HtmlCharacterSet | An enumeration of values for the HtmlExport.CharacterSet property.
Enumeration | HtmlOutputType | An enumeration of values for the HtmlExport.OutputType property.

See Also

Reference

GrapeCity.ActiveReports.Export.Html


HtmlExport Class

[image]
ActiveReports 13
HtmlExport Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

Glossary Item Box

Provides HTML creation functionality for ActiveReports documents.

Object Model

HtmlExport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class HtmlExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
C#
public sealed class HtmlExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Members
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


HtmlExport Class Members

[image]
ActiveReports 13
HtmlExport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

Glossary Item Box

The following tables list the members exposed by HtmlExport.

Public Constructors

 | Name | Description
Public Constructor | HtmlExport Constructor | Initializes a new instance of the Export.Html class.
Top

Public Properties

 | Name | Description
Public Property | BookmarkStyle | Sets or returns a value indicating whether a page of bookmarks will be created if the ActiveReports document contains bookmarks.
Public Property | CharacterSet | Sets or returns the character set encoding that will be used in the exported HTML pages.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CreateFramesetPage | Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".
Public Property | IncludeHtmlHeader | Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.
Public Property | IncludePageMargins | Sets or returns a value indicating whether the page's margins are included in the output.
Public Property | MultiPage | Sets or returns a value indicating whether multiple HTML pages are generated for the document.
Public Property | OutputType | Gets or sets a value indicating whether the document will be exported as DHTML or HTML.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for the resultant html document or not.
Public Property | RemoveVerticalSpace | Sets or returns a value indicating whether completely empty vertical spacing will be removed from the output.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Title | Sets or returns the Title used in the header of HTML pages.
Top

Public Methods

 | Name | Description
Public Method | AddMetadata | Adds specified metadata property to be written as HTML meta.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to HTML.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


HtmlExport Constructor

[image]
ActiveReports 13
HtmlExport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : HtmlExport Constructor

Glossary Item Box

Initializes a new instance of the Export.Html class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public HtmlExport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


HtmlExport Class Methods

[image]
ActiveReports 13
HtmlExport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

Glossary Item Box

For a list of all members of this type, see HtmlExport members.

Public Methods

 | Name | Description
Public Method | AddMetadata | Adds specified metadata property to be written as HTML meta.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to HTML.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


AddMetadata Method

[image]
ActiveReports 13
AddMetadata Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : AddMetadata Method

name
The property name.
value
The property value.

Glossary Item Box

Adds specified metadata property to be written as HTML meta.

Syntax

Visual Basic (Declaration)
Public Sub AddMetadata( _
   ByVal name As String, _
   ByVal value As String _
)
C#
public void AddMetadata(
   string name,
   string value
)

Parameters

name
The property name.
value
The property value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


Export Method

[image]
ActiveReports 13
Export Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Export Method

Glossary Item Box

Exports the specified document to HTML.

Overload List

Overload | Description
Export(PageDocument,String) | Exports the specified document to html.
Export(PageDocument,String,String) | Exports the specified page document to HTML.
Export(PageDocument,Stream) | Exports the specified page document to HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.
Export(PageDocument,Stream,String) | Exports the specified GrapeCity.ActiveReports.Document.SectionDocumentto HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.
Export(PageDocument,IOutputHtml,String) | Provides advanced control over how the HtmlExport stores all output, including all html pages, images, bookmark pages, etc...
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String) | Exports the entire ActiveReports document to the specified HTML file.
Export(SectionDocument,String,String) | Exports the specified range of pages to an HTML file.
Export(SectionDocument,Stream,String) | Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(SectionDocument,IOutputHtml,String) | Exports the specified range of pages of the document to the chosen outputHandler.
Export(SectionDocument,Stream) | Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
rptGrapeCity rpt = new rptGrapeCity();
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
rpt.Run();
this.arv.Document = rpt.Document;
h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


Export(PageDocument,String) Method

[image]
ActiveReports 13
Export(PageDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.

Glossary Item Box

Exports the specified document to html.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   PageDocument document,
   string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,String,String) Method

[image]
ActiveReports 13
Export(PageDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,String,String) Method

document
The GrapeCity.ActiveReports.Document.SectionDocument to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified page document to HTML.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The GrapeCity.ActiveReports.Document.SectionDocument to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,Stream) Method

[image]
ActiveReports 13
Export(PageDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,Stream) Method

document
The PageDocument to export.
stream
The destination System.IO.Stream to save the MHT file to.

Glossary Item Box

Exports the specified page document to HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream _
)
C#
public void Export(
   PageDocument document,
   Stream stream
)

Parameters

document
The PageDocument to export.
stream
The destination System.IO.Stream to save the MHT file to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,Stream,String) Method

[image]
ActiveReports 13
Export(PageDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,Stream,String) Method

document
The GrapeCity.ActiveReports.Document.SectionDocument to export.
stream
The destination System.IO.Stream to save the MHT file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified GrapeCity.ActiveReports.Document.SectionDocumentto HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   Stream stream,
   string pageRange
)

Parameters

document
The GrapeCity.ActiveReports.Document.SectionDocument to export.
stream
The destination System.IO.Stream to save the MHT file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,IOutputHtml,String) Method

[image]
ActiveReports 13
Export(PageDocument,IOutputHtml,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,IOutputHtml,String) Method

document
The ActiveReports PageDocument to export to HTML.
outputHandler
An implementation of GrapeCity.ActiveReports.Export.Html.IOutputHtml that will receive all HTML output.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Provides advanced control over how the HtmlExport stores all output, including all html pages, images, bookmark pages, etc...

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal outputHandler As IOutputHtml, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   IOutputHtml outputHandler,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument to export to HTML.
outputHandler
An implementation of GrapeCity.ActiveReports.Export.Html.IOutputHtml that will receive all HTML output.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,String,String) Method

[image]
ActiveReports 13
Export(IReport,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,String,String) Method

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath,
   string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,String) Method

[image]
ActiveReports 13
Export(IReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,String) Method

report
IReport instance to Export
filePath
Path to export

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,Stream) Method

[image]
ActiveReports 13
Export(IReport,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,Stream) Method

report
IReport instance to Export
outputStream
The output stream.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,Stream,String) Method

[image]
ActiveReports 13
Export(IReport,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,Stream,String) Method

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream,
   string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,String) Method

document
The ActiveReports document to be exported to HTML.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.

Glossary Item Box

Exports the entire ActiveReports document to the specified HTML file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The ActiveReports document to be exported to HTML.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,String,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,String,String) Method

document
The ActiveReports document to be exported to HTML.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pagesRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages to an HTML file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pagesRange As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath,
   string pagesRange
)

Parameters

document
The ActiveReports document to be exported to HTML.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pagesRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html", "1-3");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.HtmlExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html", "1-3")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,Stream,String) Method

document
The ActiveReports document to be exported to HTML.
outputStream
The destination System.IO.Stream to which to save the MHT file.
pagesRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream, _
   ByVal pagesRange As String _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream,
   string pagesRange
)

Parameters

document
The ActiveReports document to be exported to HTML.
outputStream
The destination System.IO.Stream to which to save the MHT file.
pagesRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,IOutputHtml,String) Method

[image]
ActiveReports 13
Export(SectionDocument,IOutputHtml,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,IOutputHtml,String) Method

document
The ActiveReports document to be exported to HTML.
outputHandler
An implementation of IOutputHandler that will receive the HTML output.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages of the document to the chosen outputHandler.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputHandler As IOutputHtml, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   IOutputHtml outputHandler,
   string pageRange
)

Parameters

document
The ActiveReports document to be exported to HTML.
outputHandler
An implementation of IOutputHandler that will receive the HTML output.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Remarks

Provides advanced control over how the HtmlExport stores all output, including html pages, images, bookmark pages, etc.

Example

C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
    rptCustExHTML rpt = new rptCustExHTML();
    try
    {
        rpt.Run(false);
    }
    catch (Exception eRunReport)
    {
        // Failure running report, just report the error to the user:
        Response.Clear();
        Response.Write("<h1>Error running report:</h1>");
        Response.Write(eRunReport.ToString());
        return;
    }
    // Buffer this page's output until the report output is ready.
    Response.Buffer = true;
    // Clear any part of this page that might have already been buffered for output.
    Response.ClearContent();
    // Clear any headers that might have already been buffered (such as the content type for an HTML page)
    Response.ClearHeaders();
    // Tell the browser and the "network" that this resulting data of this page should be be cached since this
     // could be a dynamic report that changes upon each request.
    Response.Cache.SetCacheability(HttpCacheability.NoCache);
    // Tell the browser this is an Html document so it will use an appropriate viewer.
    Response.ContentType = "text/html";
    // Create the HTML export object
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport html = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    // Export the report to HTML in this session's webcache:
    //this.htmlExport1.Export(rpt.Document, GrapeCity.ActiveReports.Web
    MyCustomHtmlOutputter outputter = new MyCustomHtmlOutputter(this.Context);
    this.htmlExport1.Export(rpt.Document, outputter, "");
    Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage));
}
Visual Basic Copy Code
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim rpt As New ActiveReport1()
        Try
            rpt.Run(False)
        Catch eRunReport As Exception
            ' Failure running report, just report the error to the user:
            Response.Clear()
            Response.Write("<h1>Error running report:</h1>")
            Response.Write(eRunReport.ToString())
            Return
        End Try
        ' Buffer this page's output until the report output is ready.
        Response.Buffer = True
        ' Clear any part of this page that might have already been buffered for output.
        Response.ClearContent()
        ' Clear any headers that might have already been buffered (such as the content type for an HTML page)
        Response.ClearHeaders()
        ' Tell the browser and the "network" that this resulting data of this page should be be cached since
        ' this could be a dynamic report that changes upon each request.
        Response.Cache.SetCacheability(HttpCacheability.NoCache)
        ' Tell the browser this is an Html document so it will use an appropriate viewer.
        Response.ContentType = "text/HTML"
        ' Create the Html export object
        Dim HtmlExport1 As New HtmlExport()
        Dim outputter As New MyCustomHtmlOutputter(Me.Context)
        Me.HtmlExport1.Export(rpt.Document, outputter, "")
        Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage))
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List
OutputType Property


Export(SectionDocument,Stream) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,Stream) Method

document
The ActiveReports document to be exported to HTML.
outputStream
The destination System.IO.Stream to which to save the MHT file.

Glossary Item Box

Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream
)

Parameters

document
The ActiveReports document to be exported to HTML.
outputStream
The destination System.IO.Stream to which to save the MHT file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


HtmlExport Class Properties

[image]
ActiveReports 13
HtmlExport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

Glossary Item Box

For a list of all members of this type, see HtmlExport members.

Public Properties

 | Name | Description
Public Property | BookmarkStyle | Sets or returns a value indicating whether a page of bookmarks will be created if the ActiveReports document contains bookmarks.
Public Property | CharacterSet | Sets or returns the character set encoding that will be used in the exported HTML pages.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CreateFramesetPage | Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".
Public Property | IncludeHtmlHeader | Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.
Public Property | IncludePageMargins | Sets or returns a value indicating whether the page's margins are included in the output.
Public Property | MultiPage | Sets or returns a value indicating whether multiple HTML pages are generated for the document.
Public Property | OutputType | Gets or sets a value indicating whether the document will be exported as DHTML or HTML.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for the resultant html document or not.
Public Property | RemoveVerticalSpace | Sets or returns a value indicating whether completely empty vertical spacing will be removed from the output.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Title | Sets or returns the Title used in the header of HTML pages.
Top

See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


BookmarkStyle Property

[image]
ActiveReports 13
BookmarkStyle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : BookmarkStyle Property

Glossary Item Box

Sets or returns a value indicating whether a page of bookmarks will be created if the ActiveReports document contains bookmarks.

Syntax

Visual Basic (Declaration)
Public Property BookmarkStyle As BookmarkStyle
C#
public BookmarkStyle BookmarkStyle {get; set;}

Property Value

BookmarkStyle enumeration.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.BookmarkStyle = GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html;
    h.CreateFramesetPage = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New  GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.BookmarkStyle =  GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html
    h.CreateFramesetPage = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
BookmarkStyle Enumeration


CharacterSet Property

[image]
ActiveReports 13
CharacterSet Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : CharacterSet Property

Glossary Item Box

Sets or returns the character set encoding that will be used in the exported HTML pages.

Syntax

Visual Basic (Declaration)
Public Property CharacterSet As HtmlCharacterSet
C#
public HtmlCharacterSet CharacterSet {get; set;}

Property Value

HtmlCharacterSet enumeration.

Remarks

The default character set is UTF8. Setting this property will change the meta tag in the header of the resulting HTML pages to the appropriate IANA character set value.

For example: <META content="text/html;charset=ISO-8859-1" http-equiv=Content-Type>.

Additionally, the inner text portion of the pages will be encoded according to the specific character set's encoding rules and font names. If you are exporting a Document without headers (IncludeHtmlHeader=false), then you must insert the appropriate meta tag to ensure that the browser knows how the text is encoded.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new  GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.CharacterSet =  GrapeCity.ActiveReports.Export.Html.Section.HtmlCharacterSet.Big5;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    Dim h As New  GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.CharacterSet =  GrapeCity.ActiveReports.Export.Html.Section.HtmlCharacterSet.Big5
    h.Export(rpt.Document, Application.StartupPath + "/export.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
HtmlCharacterSet Enumeration


CreateFramesetPage Property

[image]
ActiveReports 13
CreateFramesetPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : CreateFramesetPage Property

Glossary Item Box

Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".

Syntax

Visual Basic (Declaration)
Public Property CreateFramesetPage As Boolean
C#
public bool CreateFramesetPage {get; set;}

Property Value

Boolean.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.BookmarkStyle = GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html;
    h.CreateFramesetPage = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.BookmarkStyle = GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html
    h.CreateFramesetPage = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


IncludeHtmlHeader Property

[image]
ActiveReports 13
IncludeHtmlHeader Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : IncludeHtmlHeader Property

Glossary Item Box

Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.

Syntax

Visual Basic (Declaration)
Public Property IncludeHtmlHeader As Boolean
C#
public bool IncludeHtmlHeader {get; set;}

Property Value

Boolean. The default value is True.

Remarks

Set this value to False if you want to use the resulting HTML output in the middle of another HTML page.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.IncludeHtmlHeader = false;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.IncludeHtmlHeader = False
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


IncludePageMargins Property

[image]
ActiveReports 13
IncludePageMargins Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : IncludePageMargins Property

Glossary Item Box

Sets or returns a value indicating whether the page's margins are included in the output.

Syntax

Visual Basic (Declaration)
Public Property IncludePageMargins As Boolean
C#
public bool IncludePageMargins {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.IncludePageMargins = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.IncludePageMargins = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


MultiPage Property

[image]
ActiveReports 13
MultiPage Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : MultiPage Property

Glossary Item Box

Sets or returns a value indicating whether multiple HTML pages are generated for the document.

Syntax

Visual Basic (Declaration)
Public Property MultiPage As Boolean
C#
public bool MultiPage {get; set;}

Property Value

Boolean. If True, an HTML page will be generated for each page in the ActiveReports document. If False, (the default value) a single HTML page is generated which includes all of the pages in the ActiveReports document.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.MultiPage = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.MultiPage = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


OutputType Property

[image]
ActiveReports 13
OutputType Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : OutputType Property

Glossary Item Box

Gets or sets a value indicating whether the document will be exported as DHTML or HTML.

Syntax

Visual Basic (Declaration)
Public Property OutputType As HtmlOutputType
C#
public HtmlOutputType OutputType {get; set;}

Property Value

HtmlOutputType enumeration. The default value is DynamicHtml.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.OutputType = GrapeCity.ActiveReports.Export.Html.Section.HtmlOutputType.LegacyHtml;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.HtmlExport
    h.OutputType = GrapeCity.ActiveReports.Export.Html.HtmlOutputType.LegacyHtml
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members
HtmlOutputType Enumeration


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Pagination Property

Glossary Item Box

Gets or sets the value, that indicates whether pagination should be used for the resultant html document or not.

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


RemoveVerticalSpace Property

[image]
ActiveReports 13
RemoveVerticalSpace Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : RemoveVerticalSpace Property

Glossary Item Box

Sets or returns a value indicating whether completely empty vertical spacing will be removed from the output.

Syntax

Visual Basic (Declaration)
Public Property RemoveVerticalSpace As Boolean
C#
public bool RemoveVerticalSpace {get; set;}

Property Value

Boolean. The default value is False.

Remarks

This property has no effect if you are using the default OutputType option (DynamicHtml). This may improve pagination if you wish to print the HTML output from a browser with the LegacyHtml OutputType option.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.OutputType = GrapeCity.ActiveReports.Export.Html.Section.HtmlOutputType.LegacyHtml;
    h.RemoveVerticalSpace = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.HtmlExport
    h.OutputType = GrapeCity.ActiveReports.Export.Html.HtmlOutputType.LegacyHtml
    h.RemoveVerticalSpace = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


Title Property

[image]
ActiveReports 13
Title Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Title Property

Glossary Item Box

Sets or returns the Title used in the header of HTML pages.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Property Value

String.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.Title = "ActiveReports HTML Export";
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.Title = "ActiveReports HTML Export"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


OutputHtmlFiles Class

[image]
ActiveReports 13
OutputHtmlFiles Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : OutputHtmlFiles Class

Glossary Item Box

OutputHtmlFiles is an implementation of the IHandleHtmlOutput interface that directs the HtmlExport object's output to files.

Object Model

OutputHtmlFiles Class

Syntax

Visual Basic (Declaration)
Public Class OutputHtmlFiles
   Implements GrapeCity.ActiveReports.Export.Html.IOutputHtml
C#
public class OutputHtmlFiles : GrapeCity.ActiveReports.Export.Html.IOutputHtml

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Section.OutputHtmlFiles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OutputHtmlFiles Members
GrapeCity.ActiveReports.Export.Html.Section Namespace


OutputHtmlFiles Class Members

[image]
ActiveReports 13
OutputHtmlFiles Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : OutputHtmlFiles Class

Glossary Item Box

The following tables list the members exposed by OutputHtmlFiles.

Public Constructors

 | Name | Description
Public Constructor | OutputHtmlFiles Constructor | Initializes an instance of the OutputHtmlFiles class using the specified filePath as the base html page.
Top

See Also

Reference

OutputHtmlFiles Class
GrapeCity.ActiveReports.Export.Html.Section Namespace


OutputHtmlFiles Constructor

[image]
ActiveReports 13
OutputHtmlFiles Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > OutputHtmlFiles Class : OutputHtmlFiles Constructor

filePath
The file path to the main or starting HTML page. Other created files (such as linked images and table of contents pages) will use this file path as a prefix.
htmlExport
The parent HtmlExport object with which this object is working.

Glossary Item Box

Initializes an instance of the OutputHtmlFiles class using the specified filePath as the base html page.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal htmlExport As HtmlExport _
)
C#
public OutputHtmlFiles(
   string filePath,
   HtmlExport htmlExport
)

Parameters

filePath
The file path to the main or starting HTML page. Other created files (such as linked images and table of contents pages) will use this file path as a prefix.
htmlExport
The parent HtmlExport object with which this object is working.

Remarks

When this class is created, it demands permission to write files in the parent folder of the specified file. If permission is not granted, a SecurityException is thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OutputHtmlFiles Class
OutputHtmlFiles Members


BookmarkStyle Enumeration

[image]
ActiveReports 13
BookmarkStyle Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : BookmarkStyle Enumeration

Glossary Item Box

An enumeration of values for the HtmlExport.BookmarkStyle property.

Syntax

Visual Basic (Declaration)
Public Enum BookmarkStyle
   Inherits System.Enum
C#
public enum BookmarkStyle : System.Enum

Members

Member | Description
Html | If the ActiveReports document contains bookmarks, an HTML page containing bookmark links to the document's pages is created.
None | No bookmark page is created.

Remarks

More styles may be added in future.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Html.Section Namespace
BookmarkStyle Property


HtmlCharacterSet Enumeration

[image]
ActiveReports 13
HtmlCharacterSet Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlCharacterSet Enumeration

Glossary Item Box

An enumeration of values for the HtmlExport.CharacterSet property.

Syntax

Visual Basic (Declaration)
Public Enum HtmlCharacterSet
   Inherits System.Enum
C#
public enum HtmlCharacterSet : System.Enum

Members

Member | Description
Big5 | Known as "Chinese for Taiwan Multi-byte set." The charset name is "Big5."
EucJp | Known as "Extended UNIX Code Packed Format for Japanese." The charset name is "EUC-JP."
HzGb2312 | Known as "ASCII Printable Characters-Based Chinese Character Encoding" per RFC1842 and RFC1843. The charset name is "HZ-GB-2312."
Ibm850 | Known only as "IBM850." The charset name is "IBM850."
Iso2022Jp | Known as "Japanese Character Encoding for Internet Messages" per RFC1468. The charset name is "ISO-2022-JP."
Iso2022Kr | Known as "Korean Character Encoding for Internet Messages" per RFC1557. The charset name is "ISO-2022-KR."
Iso8859_1 | Known as "Latin alphabet No. 1." The charset name is "ISO-8859-1."
Iso8859_2 | Known as "Latin alphabet No. 2." The charset name is "ISO-8859-2."
Iso8859_5 | Known as "Latin/Cyrillic alphabet." The charset name is "ISO-8859-5."
Iso8859_6 | Known as "Latin/Arabic alphabet." The charset name is "ISO-8859-6."
Koi8r | Known as "Russian Net Character Set." The charset name is "KOI8-R."
Ksc5601 | Known as "Unified Hangeul" (Korean). The charset name is "KSC5601."
ShiftJis | Known as "Shift-JIS" (Japanese). The charset name is "shift-jis."
UnicodeUtf16 | Per RFC 2781. An encoding for the Unicode character set in little-endian byte order using UTF-16 encoding.
UnicodeUtf8 | Per RFC 3629. An encoding for the Unicode character set using UTF-8 encoding.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.Section.HtmlCharacterSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Html.Section Namespace
CharacterSet Property


HtmlOutputType Enumeration

[image]
ActiveReports 13
HtmlOutputType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlOutputType Enumeration

Glossary Item Box

An enumeration of values for the HtmlExport.OutputType property.

Syntax

Visual Basic (Declaration)
Public Enum HtmlOutputType
   Inherits System.Enum
C#
public enum HtmlOutputType : System.Enum

Members

Member | Description
DynamicHtml | Default. Exports the document to DHTML format.
LegacyHtml | Exports the document to static HTML format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.Section.HtmlOutputType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Html.Section Namespace
OutputType Property


GrapeCity.ActiveReports.Export.Image.Page Namespace

GrapeCity.ActiveReports.Export.Image.Page Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly : GrapeCity.ActiveReports.Export.Image.Page Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Image.Page contains Image export classes for page layout.

Classes

 | Class | Description
Class | ImageRenderingExtension | Represents implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport in image.
Class | Settings | Represents settings for ImageRenderingExtension.

See Also

Reference

GrapeCity.ActiveReports.Export.Image Assembly


ImageRenderingExtension Class

[image]
ActiveReports 13
ImageRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : ImageRenderingExtension Class

Glossary Item Box

Represents implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport in image.

Object Model

ImageRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ImageRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IImageRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public sealed class ImageRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IImageRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageRenderingExtension Members
GrapeCity.ActiveReports.Export.Image.Page Namespace


ImageRenderingExtension Class Members

[image]
ActiveReports 13
ImageRenderingExtension Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : ImageRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by ImageRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | ImageRenderingExtension Constructor | Initializes a new instance of the ImageRenderingExtension class.
Top

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the ImageRenderingExtension class.
Top

See Also

Reference

ImageRenderingExtension Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


ImageRenderingExtension Constructor

[image]
ActiveReports 13
ImageRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class : ImageRenderingExtension Constructor

Glossary Item Box

Initializes a new instance of the ImageRenderingExtension class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ImageRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members


ImageRenderingExtension Class Methods

[image]
ActiveReports 13
ImageRenderingExtension Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : ImageRenderingExtension Class

Glossary Item Box

For a list of all members of this type, see ImageRenderingExtension members.

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the ImageRenderingExtension class.
Top

See Also

Reference

ImageRenderingExtension Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


GetSupportedSettings Method

[image]
ActiveReports 13
GetSupportedSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class : GetSupportedSettings Method

Glossary Item Box

Returns the settings for the ImageRenderingExtension class.

Overload List

Overload | Description
GetSupportedSettings() | Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.
GetSupportedSettings(Boolean) | Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members


GetSupportedSettings() Method

[image]
ActiveReports 13
GetSupportedSettings() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings() As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings()

Return Value

settings of current ImageRenderingExtension instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

[image]
ActiveReports 13
GetSupportedSettings(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method

fpl
Returns the image rendering settings.

Glossary Item Box

Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings( _
   ByVal fpl As Boolean _
) As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings(
   bool fpl
)

Parameters

fpl
Returns the image rendering settings.

Return Value

settings of current ImageRenderingExtension instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members
Overload List


Settings Class

[image]
ActiveReports 13
Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class

Glossary Item Box

Represents settings for ImageRenderingExtension.

Object Model

Settings Class

Syntax

Visual Basic (Declaration)
Public Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Image.Page.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Image.Page Namespace


Settings Class Members

[image]
ActiveReports 13
Settings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class

Glossary Item Box

The following tables list the members exposed by Settings.

Public Constructors

 | Name | Description
Public Constructor | Settings Constructor | Overloaded. Initializes a new instance of the Settings class.
Top

Public Properties

Name | Description
Public Property | Compression | Sets or returns a value which specifies the compression to be used when exporting.
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
Public Property DpiX

Adjust the horizontal resolution of rendered images. The default value is 96.

Public Property | DpiY | Adjust the vertical resolution of rendered images.
Public Property | EndPage | The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.
Public Property | ImageType | Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.
Public Property | MarginBottom | Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginLeft | Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginRight | Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginTop | Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | PageHeight | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
Public Property | PageWidth | Set the value in inches to use for the width of the image. The format is an integer or decimal with "in" as the suffix, for example "8in" for 8 inches. The value set in this property overrides the report's settings.
Public Property | Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
Public Property PrintLayoutMode Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)
Public Property | Quality | Gets or sets the quality of the report to be rendered as an image.
Public Property | SizeToFit | By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.
Public Property | StartPage | The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.
Public Property | WatermarkAngle | Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.
Public Property | WatermarkColor | Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
Public Property | WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
Public Property | WatermarkTitle | Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.
Top

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of ImageRenderingExtension.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


Settings Constructor

[image]
ActiveReports 13
Settings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Settings Constructor

Glossary Item Box

Initializes a new instance of the Settings class.

Overload List

Overload | Description
Settings Constructor() | Initializes a new instance of the Settings class.
Settings Constructor(NameValueCollection,Boolean) | Initializes new instance of GrapeCity.ActiveReports.Export.Image.Page.Settings class with specified settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Constructor()

[image]
ActiveReports 13
Settings Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class > Settings Constructor : Settings Constructor()

Glossary Item Box

Initializes a new instance of the Settings class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Settings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members
Overload List


Settings Constructor(NameValueCollection,Boolean)

[image]
ActiveReports 13
Settings Constructor(NameValueCollection,Boolean)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class > Settings Constructor : Settings Constructor(NameValueCollection,Boolean)

settings
System.Collections.Specialized.NameValueCollection of specified settings.
fpl
FPL flag

Glossary Item Box

Initializes new instance of GrapeCity.ActiveReports.Export.Image.Page.Settings class with specified settings.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal settings As NameValueCollection, _
   ByVal fpl As Boolean _
)
C#
public Settings(
   NameValueCollection settings,
   bool fpl
)

Parameters

settings
System.Collections.Specialized.NameValueCollection of specified settings.
fpl
FPL flag

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members
Overload List


Settings Class Methods

[image]
ActiveReports 13
Settings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of ImageRenderingExtension.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


ApplySettings Method

[image]
ActiveReports 13
ApplySettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : ApplySettings Method

settings
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.

Glossary Item Box

Applies any settings passed in the NameValueCollection settings parameters.

Syntax

Visual Basic (Declaration)
Public Sub ApplySettings( _
   ByVal settings As NameValueCollection _
)
C#
public void ApplySettings(
   NameValueCollection settings
)

Parameters

settings
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


GetSettings Method

[image]
ActiveReports 13
GetSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : GetSettings Method

Glossary Item Box

Returns settings of ImageRenderingExtension.

Syntax

Visual Basic (Declaration)
Public Function GetSettings() As NameValueCollection
C#
public NameValueCollection GetSettings()

Return Value

System.Collections.Specialized.NameValueCollection of ImageRenderingExtension settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Class Properties

[image]
ActiveReports 13
Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Properties

Name | Description
Public Property | Compression | Sets or returns a value which specifies the compression to be used when exporting.
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
Public Property DpiX

Adjust the horizontal resolution of rendered images. The default value is 96.

Public Property | DpiY | Adjust the vertical resolution of rendered images.
Public Property | EndPage | The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.
Public Property | ImageType | Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.
Public Property | MarginBottom | Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginLeft | Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginRight | Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginTop | Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | PageHeight | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
Public Property | PageWidth | Set the value in inches to use for the width of the image. The format is an integer or decimal with "in" as the suffix, for example "8in" for 8 inches. The value set in this property overrides the report's settings.
Public Property | Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
Public Property PrintLayoutMode Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)
Public Property | Quality | Gets or sets the quality of the report to be rendered as an image.
Public Property | SizeToFit | By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.
Public Property | StartPage | The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.
Public Property | WatermarkAngle | Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.
Public Property | WatermarkColor | Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
Public Property | WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
Public Property | WatermarkTitle | Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


Compression Property

[image]
ActiveReports 13
Compression Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Compression Property

Glossary Item Box

Sets or returns a value which specifies the compression to be used when exporting.

Syntax

Visual Basic (Declaration)
Public Property Compression As Compression
C#
public Compression Compression {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Dither Property

[image]
ActiveReports 13
Dither Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Dither Property

Glossary Item Box

Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).

Syntax

Visual Basic (Declaration)
Public Property Dither As Boolean
C#
public bool Dither {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DpiX Property

[image]
ActiveReports 13
DpiX Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : DpiX Property

Glossary Item Box

Adjust the horizontal resolution of rendered images. The default value is 96.

Syntax

Visual Basic (Declaration)
Public Property DpiX As Single
C#
public float DpiX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DpiY Property

[image]
ActiveReports 13
DpiY Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : DpiY Property

Glossary Item Box

Adjust the vertical resolution of rendered images.

Syntax

Visual Basic (Declaration)
Public Property DpiY As Single
C#
public float DpiY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


EndPage Property

[image]
ActiveReports 13
EndPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : EndPage Property

Glossary Item Box

The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.

Syntax

Visual Basic (Declaration)
Public Property EndPage As Integer
C#
public int EndPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


ImageType Property

[image]
ActiveReports 13
ImageType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : ImageType Property

Glossary Item Box

Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.

Syntax

Visual Basic (Declaration)
Public Property ImageType As ImageType
C#
public ImageType ImageType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginBottom Property

[image]
ActiveReports 13
MarginBottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginBottom Property

Glossary Item Box

Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.

Syntax

Visual Basic (Declaration)
Public Property MarginBottom As String
C#
public string MarginBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginLeft Property

[image]
ActiveReports 13
MarginLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginLeft Property

Glossary Item Box

Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.

Syntax

Visual Basic (Declaration)
Public Property MarginLeft As String
C#
public string MarginLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginRight Property

[image]
ActiveReports 13
MarginRight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginRight Property

Glossary Item Box

Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.

Syntax

Visual Basic (Declaration)
Public Property MarginRight As String
C#
public string MarginRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginTop Property

[image]
ActiveReports 13
MarginTop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginTop Property

Glossary Item Box

Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.

Syntax

Visual Basic (Declaration)
Public Property MarginTop As String
C#
public string MarginTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PageHeight Property

[image]
ActiveReports 13
PageHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : PageHeight Property

Glossary Item Box

Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.

Syntax

Visual Basic (Declaration)
Public Property PageHeight As String
C#
public string PageHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PageWidth Property

[image]
ActiveReports 13
PageWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : PageWidth Property

Glossary Item Box

Set the value in inches to use for the width of the image. The format is an integer or decimal with "in" as the suffix, for example "8in" for 8 inches. The value set in this property overrides the report's settings.

Syntax

Visual Basic (Declaration)
Public Property PageWidth As String
C#
public string PageWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Pagination Property

Glossary Item Box

By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PrintLayoutMode Property

[image]
ActiveReports 13
PrintLayoutMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : PrintLayoutMode Property

Glossary Item Box

Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)

Syntax

Visual Basic (Declaration)
Public Property PrintLayoutMode As GrapeCity.ActiveReports.ImageRenderers.PageControl.PrintLayoutMode
C#
public GrapeCity.ActiveReports.ImageRenderers.PageControl.PrintLayoutMode PrintLayoutMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Quality Property

[image]
ActiveReports 13
Quality Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Quality Property

Glossary Item Box

Gets or sets the quality of the report to be rendered as an image.

Syntax

Visual Basic (Declaration)
Public Property Quality As Integer
C#
public int Quality {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SizeToFit Property

[image]
ActiveReports 13
SizeToFit Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : SizeToFit Property

Glossary Item Box

By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.

Syntax

Visual Basic (Declaration)
Public Property SizeToFit As Boolean
C#
public bool SizeToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


StartPage Property

[image]
ActiveReports 13
StartPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : StartPage Property

Glossary Item Box

The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.

Syntax

Visual Basic (Declaration)
Public Property StartPage As Integer
C#
public int StartPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkAngle Property

[image]
ActiveReports 13
WatermarkAngle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkAngle Property

Glossary Item Box

Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.

Syntax

Visual Basic (Declaration)
Public Property WatermarkAngle As Single
C#
public float WatermarkAngle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkColor Property

[image]
ActiveReports 13
WatermarkColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkColor Property

Glossary Item Box

Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.

Syntax

Visual Basic (Declaration)
Public Property WatermarkColor As Color
C#
public Color WatermarkColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkFont Property

[image]
ActiveReports 13
WatermarkFont Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkFont Property

Glossary Item Box

Set the font to use for the watermark to any valid System.Drawing.Font.

Syntax

Visual Basic (Declaration)
Public Property WatermarkFont As Font
C#
public Font WatermarkFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkTitle Property

[image]
ActiveReports 13
WatermarkTitle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkTitle Property

Glossary Item Box

Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.

Syntax

Visual Basic (Declaration)
Public Property WatermarkTitle As String
C#
public string WatermarkTitle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly : GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Page.Renderers namespace contains the information on images to be rendered.

Enumerations

 | Enumeration | Description
Enumeration | Compression | Compression of rendered Tiff image.
Enumeration | ImageType | Represents Image types supported by GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension.

See Also

Reference

GrapeCity.ActiveReports.Export.Image Assembly


Compression Enumeration

[image]
ActiveReports 13
Compression Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace : Compression Enumeration

Glossary Item Box

Compression of rendered Tiff image.

Syntax

Visual Basic (Declaration)
Public Enum Compression
   Inherits System.Enum
C#
public enum Compression : System.Enum

Members

Member | Description
Ccitt3 | This uses the CCITT Group 3 compression. This compression format is used mainly in faxes and delivers a Black and White output. The standards of CCITT Group 3 are 1728 x 2376 pixels, and the resolution is 200 x 196 DPI. If the aspect ratio of the report does not meet these standards, a margin gets inserted at the bottom.
Lzw | This uses LZW compression which is a lossless compression and delivers color output.
None | Specifies no compression and delivers color output.
Rle | PackBits compression format that uses the Run-Length Encoding (RLE) compression method and delivers Black and White output.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Image.Page.Renderers.Compression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace


ImageType Enumeration

[image]
ActiveReports 13
ImageType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace : ImageType Enumeration

Glossary Item Box

Represents Image types supported by GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension.

Syntax

Visual Basic (Declaration)
Public Enum ImageType
   Inherits System.Enum
C#
public enum ImageType : System.Enum

Members

Member | Description
BMP | Represents a BMP image type
EMF | Represents a EMF image type
GIF | Represents a GIF image type
JPEG | Represents a JPEG image type
PNG | Represents a PNG image type
TIFF | Represents a TIFF image type

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Image.Page.Renderers.ImageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace


GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace

GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly : GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Tiff.Section namespace contains the TIFF export classes.

Classes

 | Class | Description
Class | TiffExport | The ActiveReports Tag Image File Format (TIFF) Export Component.
Class | TiffExportException | The exception thrown when a TiffExport-specific error occurs.

Enumerations

 | Enumeration | Description
Enumeration | CompressionScheme | An enumeration of values which specify the compression scheme used in the resulting TIFF image of the TiffExport component.

See Also

Reference

GrapeCity.ActiveReports.Export.Image Assembly


TiffExport Class

[image]
ActiveReports 13
TiffExport Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

Glossary Item Box

The ActiveReports Tag Image File Format (TIFF) Export Component.

Object Model

TiffExport Class

Syntax

Visual Basic (Declaration)
Public Class TiffExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
C#
public class TiffExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx

Example

Visual Basic Copy Code
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff")
C# Copy Code
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Members
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExport Class Members

[image]
ActiveReports 13
TiffExport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

Glossary Item Box

The following tables list the members exposed by TiffExport.

Public Constructors

 | Name | Description
Public Constructor | TiffExport Constructor | Initializes a new instance of the TiffExport class.
Top

Public Properties

 | Name | Description
Public Property | CompressionScheme | Sets or returns a value which specifies the compression scheme to be used when exporting a TIFF file.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format such as Ccitt4, Ccitt3 or Rle. If the CompressionScheme is set to Lzw or None (indicating color output) this property has no effect.
Public Property | DpiX | Get or set the horizonal resolution value when exporting a TIFF.
Public Property | DpiY | Get or set the vertical resolution value when exporting a TIFF.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant TIFF document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to TIFF format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExport Constructor

[image]
ActiveReports 13
TiffExport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : TiffExport Constructor

Glossary Item Box

Initializes a new instance of the TiffExport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TiffExport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


TiffExport Class Methods

[image]
ActiveReports 13
TiffExport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

Glossary Item Box

For a list of all members of this type, see TiffExport members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to TIFF format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Export Method

Glossary Item Box

Exports the specified document to TIFF format.

Overload List

Overload | Description
Export(PageDocument,String) | Exports the specified document to a TIFF file.
Export(PageDocument,String,String) | Exports the specified document to a TIFF file.
Export(PageDocument,Stream) | Exports the specified document to the specified stream in TIFF.
Export(PageDocument,Stream,String) | Exports the specified document to the specified stream in TIFF.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String,String) | Exports the specified range of pages from the document to a TIFF file.
Export(SectionDocument,String) | Exports the specified document to a TIFF file.
Export(SectionDocument,Stream) | Exports the document to the specified stream.
Export(SectionDocument,Stream,String) | Exports the specified range of pages from the document to the specified stream.

Example

Visual Basic Copy Code
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff")
C# Copy Code
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


Export(PageDocument,String) Method

[image]
ActiveReports 13
Export(PageDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.

Glossary Item Box

Exports the specified document to a TIFF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   PageDocument document,
   string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(PageDocument,String,String) Method

[image]
ActiveReports 13
Export(PageDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,String,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified document to a TIFF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(PageDocument,Stream) Method

[image]
ActiveReports 13
Export(PageDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,Stream) Method

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.

Glossary Item Box

Exports the specified document to the specified stream in TIFF.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream _
)
C#
public void Export(
   PageDocument document,
   Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(PageDocument,Stream,String) Method

[image]
ActiveReports 13
Export(PageDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,Stream,String) Method

document
The ActiveReports PageDocument object to export.
stream
The System.IO.Stream to write the TIFF data to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified document to the specified stream in TIFF.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   Stream stream,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The System.IO.Stream to write the TIFF data to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,String,String) Method

[image]
ActiveReports 13
Export(IReport,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,String,String) Method

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath,
   string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,String) Method

[image]
ActiveReports 13
Export(IReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,String) Method

report
IReport instance to Export
filePath
Path to export

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,Stream) Method

[image]
ActiveReports 13
Export(IReport,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,Stream) Method

report
IReport instance to Export
outputStream
The output stream.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,Stream,String) Method

[image]
ActiveReports 13
Export(IReport,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,Stream,String) Method

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream,
   string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,String,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,String,String) Method

document
The ActiveReports object to export.
filePath
The file name and path to which to save the TIFF.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages from the document to a TIFF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the TIFF.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Example

Visual Basic Copy Code
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff", "1-2")
C# Copy Code
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff", "1-2");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,String) Method

document
The ActiveReports object to export.
filePath
The file name and path to which to save the TIFF.

Glossary Item Box

Exports the specified document to a TIFF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the TIFF.

Example

Visual Basic Copy Code
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff")
C# Copy Code
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,Stream) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,Stream) Method

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the TIFF.

Glossary Item Box

Exports the document to the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the TIFF.

Example

Visual Basic Copy Code
Dim rpt As New SectionReport1()
rpt.Run(False)
Response.ContentType="image/tiff"
Dim Astream = New System.IO.MemoryStream()
Response.AddHeader("content-disposition","attachment;filename=temp.tiff")
Me.TiffExport1.Export(rpt.Document,Astream)
Response.AddHeader("Content-Length",Astream.Length.ToString())
Response.BinaryWrite(stream.ToArray())
Response.End()
C# Copy Code
SectionReport1 rpt = new SectionReport1();

try
{
rpt.Run(false);
}
catch(Exception eRunReport)
{
Response.Clear();
Response.Write("<h1>ErrorArunningAreport:</h1>");
Response.Write(eRunReport.ToString());
return;
}
Response.ContentType="image/tiff";
Response.AddHeader("content-disposition","attachment;Afilename=temp.tiff");
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport T = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
System.IO.MemoryStream memStream= new System.IO.MemoryStream();
T.Export(rpt.Document,memStream);
Response.AddHeader("Content-Length",memStream.Length.ToString());
Response.BinaryWrite(memStream.ToArray());
Response.End();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,Stream,String) Method

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the TIFF.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages from the document to the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream,
   string pageRange
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the TIFF.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Example

Visual Basic Copy Code
Dim rpt As New SectionReport1()
rpt.Run(False)
Response.ContentType="image/tiff"
Dim Astream = New System.IO.MemoryStream()
Response.AddHeader("content-disposition","attachment;filename=temp.tiff")
Me.TiffExport1.Export(rpt.Document,Astream,"1-2")
Response.AddHeader("Content-Length",Astream.Length.ToString())
Response.BinaryWrite(Astream.ToArray())
Response.End()
C# Copy Code
SectionReport1 rpt = new SectionReport1();
try
{
rpt.Run(false);
}
catch(Exception eRunReport)
{
Response.Clear();
Response.Write("<h1>Errorrunningreport:</h1>");
Response.Write(eRunReport.ToString());
return;
}
Response.ContentType="image/tiff";
Response.AddHeader("content-disposition","attachment;filename=temp.tiff");
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport T= new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
System.IO.MemoryStream AmemStream = new System.IO.MemoryStream();
T.Export(rpt.Document,AmemStream, "1-2");
Response.AddHeader("Content-Length",AmemStream.Length.ToString());
Response.BinaryWrite(AmemStream.ToArray());
Response.End();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
Overload List


TiffExport Class Properties

[image]
ActiveReports 13
TiffExport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

Glossary Item Box

For a list of all members of this type, see TiffExport members.

Public Properties

 | Name | Description
Public Property | CompressionScheme | Sets or returns a value which specifies the compression scheme to be used when exporting a TIFF file.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format such as Ccitt4, Ccitt3 or Rle. If the CompressionScheme is set to Lzw or None (indicating color output) this property has no effect.
Public Property | DpiX | Get or set the horizonal resolution value when exporting a TIFF.
Public Property | DpiY | Get or set the vertical resolution value when exporting a TIFF.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant TIFF document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


CompressionScheme Property

[image]
ActiveReports 13
CompressionScheme Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : CompressionScheme Property

Glossary Item Box

Sets or returns a value which specifies the compression scheme to be used when exporting a TIFF file.

Syntax

Visual Basic (Declaration)
Public Property CompressionScheme As CompressionScheme
C#
public CompressionScheme CompressionScheme {get; set;}

Property Value

CompressionScheme enumeration.

Remarks

The default value for CompressionScheme is Ccitt3, which can be used for 1 color depth, the old standard for faxes. Another enumeration of this property which will produce black and white TIFF files are Ccitt4 and RLE, or run-length encoding.

To export color TIFF files, set the CompressionScheme to None. There is also a new Lzw compression scheme. The new scheme provides a lossless color export for 1, 4 and 8 bit color depths with a smaller footprint, and is based on the Unisys patent on Lzw compression.

Example

Visual Basic Copy Code
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'Setting the CompressionScheme to None allows colors to be exported
Me.tiffExport1.Export(rpt.Document, Application.StartupPath & "\t.tiff")
C# Copy Code
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//Setting the CompressionScheme to None allows colors to be exported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members
CompressionScheme Enumeration


Dither Property

[image]
ActiveReports 13
Dither Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Dither Property

Glossary Item Box

Specifies whether the image should be dithered when saving to a black and white output format such as Ccitt4, Ccitt3 or Rle. If the CompressionScheme is set to Lzw or None (indicating color output) this property has no effect.

Syntax

Visual Basic (Declaration)
Public Property Dither As Boolean
C#
public bool Dither {get; set;}

Property Value

Boolean. The default value is False.

Example

C# Copy Code
private void btnExport_Click(Object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport t = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
    rpt.Run();
    this.arv.Document = rpt.Document;
    t.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.Ccitt3;
    t.Dither = True;
    t.Export(rpt.Document, Application.StartupPath + "\\t.tiff","1-2");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport
    Dim t As New GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.Ccitt3
    t.Dither = True
    t.Export(rpt.Document, Application.StartupPath & "\t.tiff")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


DpiX Property

[image]
ActiveReports 13
DpiX Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : DpiX Property

Glossary Item Box

Get or set the horizonal resolution value when exporting a TIFF.

Syntax

Visual Basic (Declaration)
Public Property DpiX As Integer
C#
public int DpiX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


DpiY Property

[image]
ActiveReports 13
DpiY Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : DpiY Property

Glossary Item Box

Get or set the vertical resolution value when exporting a TIFF.

Syntax

Visual Basic (Declaration)
Public Property DpiY As Integer
C#
public int DpiY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Pagination Property

Glossary Item Box

Gets or sets the value, that indicates whether pagination should be used for resultant TIFF document or not.

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

See Also

Reference

TiffExport Class
TiffExport Members


TiffExportException Class

[image]
ActiveReports 13
TiffExportException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class

Glossary Item Box

The exception thrown when a TiffExport-specific error occurs.

Object Model

TiffExportException Class

Syntax

Visual Basic (Declaration)
Public Class TiffExportException
   Inherits System.ApplicationException
C#
public class TiffExportException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExportException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Members
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Class Members

[image]
ActiveReports 13
TiffExportException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class

Glossary Item Box

The following tables list the members exposed by TiffExportException.

Public Constructors

 | Name | Description
Public Constructor | TiffExportException Constructor | Overloaded. Initializes a new instance of the TiffExportException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffExportException Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Constructor

[image]
ActiveReports 13
TiffExportException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : TiffExportException Constructor

Glossary Item Box

Initializes a new instance of the TiffExportException class.

Overload List

Overload | Description
TiffExportException Constructor(String) | Initializes a new instance of the TiffExportException class with the specified error message.
TiffExportException Constructor(String,Exception) | Initializes a new instance of the TiffExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
TiffExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the TiffExportException class with serialized data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


TiffExportException Constructor(String)

[image]
ActiveReports 13
TiffExportException Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class > TiffExportException Constructor : TiffExportException Constructor(String)

message
A message that describes the error.

Glossary Item Box

Initializes a new instance of the TiffExportException class with the specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public TiffExportException(
   string message
)

Parameters

message
A message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members
Overload List


TiffExportException Constructor(String,Exception)

[image]
ActiveReports 13
TiffExportException Constructor(String,Exception)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class > TiffExportException Constructor : TiffExportException Constructor(String,Exception)

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the TiffExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public TiffExportException(
   string message,
   Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members
Overload List


TiffExportException Constructor(SerializationInfo,StreamingContext)

[image]
ActiveReports 13
TiffExportException Constructor(SerializationInfo,StreamingContext)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class > TiffExportException Constructor : TiffExportException Constructor(SerializationInfo,StreamingContext)

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Glossary Item Box

Initializes a new instance of the TiffExportException class with serialized data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public TiffExportException(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members
Overload List


CompressionScheme Enumeration

[image]
ActiveReports 13
CompressionScheme Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : CompressionScheme Enumeration

Glossary Item Box

An enumeration of values which specify the compression scheme used in the resulting TIFF image of the TiffExport component.

Syntax

Visual Basic (Declaration)
Public Enum CompressionScheme
   Inherits System.Enum
C#
public enum CompressionScheme : System.Enum

Members

Member | Description
Ccitt3 | This compression method can be used only for 1 color depth, and is used in old standard faxes.
Ccitt4 | This compression method is a successor to Ccitt3.
Lzw | Specifies the LZW compression scheme. This lossless compression can be used for for 1, 4, and 8 bit color depths with a smaller footprint, and is based on the Unisys patent on Lzw compression.
None | Specifies no compression and delivers color output.
Rle | Run-length encoding. This compression method can be used for 1, 4, and 8 bit color depths.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace
CompressionScheme Property


GrapeCity.ActiveReports.Export.Pdf Namespace

GrapeCity.ActiveReports.Export.Pdf Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Pdf namespace includes the Enums.ImageInterpolation enumeration.

Classes

 | Class | Description
Class | PrintPresets | Specifies the print presets.

Enumerations

 | Enumeration | Description
Enumeration | Enums.DuplexMode | Specifies Printer duplex option. For best results, the selected printer should support duplex printing if you select a duplex option.
Enumeration | Enums.ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, at the time of exporting the file to PDF.
Enumeration | Enums.NumberOfCopies | Specifies the Number of copies supported by PDF.
Enumeration | Enums.PageScaling | Specifies the Page Scaling.

Remarks

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


PrintPresets Class

[image]
ActiveReports 13
PrintPresets Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : PrintPresets Class

Glossary Item Box

Specifies the print presets.

Object Model

PrintPresets Class

Syntax

Visual Basic (Declaration)
Public Class PrintPresets
C#
public class PrintPresets

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.PrintPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Members
GrapeCity.ActiveReports.Export.Pdf Namespace


PrintPresets Class Members

[image]
ActiveReports 13
PrintPresets Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : PrintPresets Class

Glossary Item Box

The following tables list the members exposed by PrintPresets.

Public Constructors

 | Name | Description
Public Constructor | PrintPresets Constructor | Initializes a new instance of the PrintPresets class.
Top

Public Properties

 | Name | Description
Public Property | DuplexMode | Gets or sets the duplex mode.
Public Property | NumberOfCopies | Gets or sets the number of copies.
Public Property | PageScaling | Gets or sets the page scaling.
Public Property | PaperSourceByPageSize | Gets or sets the paper source by page size flag.
Public Property | PrintPageRange | Gets or sets the print page range.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

PrintPresets Class
GrapeCity.ActiveReports.Export.Pdf Namespace


PrintPresets Constructor

[image]
ActiveReports 13
PrintPresets Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace > PrintPresets Class : PrintPresets Constructor

Glossary Item Box

Initializes a new instance of the PrintPresets class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PrintPresets()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PrintPresets Class Methods

[image]
ActiveReports 13
PrintPresets Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : PrintPresets Class

Glossary Item Box

For a list of all members of this type, see PrintPresets members.

Public Methods

 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

PrintPresets Class
GrapeCity.ActiveReports.Export.Pdf Namespace


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace > PrintPresets Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PrintPresets Class Properties

[image]
ActiveReports 13
PrintPresets Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : PrintPresets Class

Glossary Item Box

For a list of all members of this type, see PrintPresets members.

Public Properties

 | Name | Description
Public Property | DuplexMode | Gets or sets the duplex mode.
Public Property | NumberOfCopies | Gets or sets the number of copies.
Public Property | PageScaling | Gets or sets the page scaling.
Public Property | PaperSourceByPageSize | Gets or sets the paper source by page size flag.
Public Property | PrintPageRange | Gets or sets the print page range.
Top

See Also

Reference

PrintPresets Class
GrapeCity.ActiveReports.Export.Pdf Namespace


DuplexMode Property

[image]
ActiveReports 13
DuplexMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace > PrintPresets Class : DuplexMode Property

Glossary Item Box

Gets or sets the duplex mode.

Syntax

Visual Basic (Declaration)
Public Property DuplexMode As Enums.DuplexMode
C#
public Enums.DuplexMode DuplexMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


NumberOfCopies Property

[image]
ActiveReports 13
NumberOfCopies Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace > PrintPresets Class : NumberOfCopies Property

Glossary Item Box

Gets or sets the number of copies.

Syntax

Visual Basic (Declaration)
Public Property NumberOfCopies As Enums.NumberOfCopies
C#
public Enums.NumberOfCopies NumberOfCopies {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PageScaling Property

[image]
ActiveReports 13
PageScaling Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace > PrintPresets Class : PageScaling Property

Glossary Item Box

Gets or sets the page scaling.

Syntax

Visual Basic (Declaration)
Public Property PageScaling As Enums.PageScaling
C#
public Enums.PageScaling PageScaling {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PaperSourceByPageSize Property

[image]
ActiveReports 13
PaperSourceByPageSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace > PrintPresets Class : PaperSourceByPageSize Property

Glossary Item Box

Gets or sets the paper source by page size flag.

Syntax

Visual Basic (Declaration)
Public Property PaperSourceByPageSize As Boolean
C#
public bool PaperSourceByPageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PrintPageRange Property

[image]
ActiveReports 13
PrintPageRange Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace > PrintPresets Class : PrintPageRange Property

Glossary Item Box

Gets or sets the print page range.

Syntax

Visual Basic (Declaration)
Public Property PrintPageRange As String
C#
public string PrintPageRange {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


Enums.DuplexMode Enumeration

[image]
ActiveReports 13
Enums.DuplexMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : Enums.DuplexMode Enumeration

Glossary Item Box

Specifies Printer duplex option. For best results, the selected printer should support duplex printing if you select a duplex option.

Syntax

Visual Basic (Declaration)
Public Enum Enums.DuplexMode
   Inherits System.Enum
C#
public enum Enums.DuplexMode : System.Enum

Members

Member | Description
DuplexFlipLongEdge | Prints on both sides of the paper; the paper flips along the long edge.
DuplexFlipShortEdge | Prints on both sides of the paper; the paper flips along the short edge.
Simplex | Prints on one side of the paper.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Enums.DuplexMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Namespace


Enums.ImageInterpolation Enumeration

[image]
ActiveReports 13
Enums.ImageInterpolation Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : Enums.ImageInterpolation Enumeration

Glossary Item Box

Interpolation value of images. Allows to enable/disable image interpolation, at the time of exporting the file to PDF.

Syntax

Visual Basic (Declaration)
Public Enum Enums.ImageInterpolation
   Inherits System.Enum
C#
public enum Enums.ImageInterpolation : System.Enum

Members

Member | Description
Auto | Interpolation is enabled.
None | Interpolation is disabled.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Enums.ImageInterpolation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Namespace


Enums.NumberOfCopies Enumeration

[image]
ActiveReports 13
Enums.NumberOfCopies Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : Enums.NumberOfCopies Enumeration

Glossary Item Box

Specifies the Number of copies supported by PDF.

Syntax

Visual Basic (Declaration)
Public Enum Enums.NumberOfCopies
   Inherits System.Enum
C#
public enum Enums.NumberOfCopies : System.Enum

Members

Member | Description
Default | Print 1 copy.
Five | Print 5 copies.
Four | Print 4 copies.
Three | Print 3 copies.
Two | Print 2 copies.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Enums.NumberOfCopies

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Namespace


Enums.PageScaling Enumeration

[image]
ActiveReports 13
Enums.PageScaling Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : Enums.PageScaling Enumeration

Glossary Item Box

Specifies the Page Scaling.

Syntax

Visual Basic (Declaration)
Public Enum Enums.PageScaling
   Inherits System.Enum
C#
public enum Enums.PageScaling : System.Enum

Members

Member | Description
Default | Uses the application default setting, which is Shrink To Printable Area.
None | Prevents automatic scaling to fit the printable area. Use this setting to preserve the scale in engineering documents or the point size required for legal reasons.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Enums.PageScaling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Namespace


GrapeCity.ActiveReports.Export.Pdf.Page Namespace

GrapeCity.ActiveReports.Export.Pdf.Page Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf.Page Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Pdf.Page namspace includes the PDF export controls.

Classes

 | Class | Description
Class | PdfRenderingExtension | GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension implementation used to create a PDF report.
Class | Settings | Settings for PDF Rendering Extension

Enumerations

 | Enumeration | Description
Enumeration | DisplayMode | Used to specify Settings.DisplayMode.
Enumeration | PdfPermissions | Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination.
Enumeration | PdfVersion | Output pdf conformance level. Allows to export to PDF/A.

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


PdfRenderingExtension Class

[image]
ActiveReports 13
PdfRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class

Glossary Item Box

GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension implementation used to create a PDF report.

Object Model

PdfRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PdfRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public sealed class PdfRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfRenderingExtension Members
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfRenderingExtension Class Members

[image]
ActiveReports 13
PdfRenderingExtension Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by PdfRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | PdfRenderingExtension Constructor | Initializes a new instance of the PdfRenderingExtension class.
Top

Public Properties

 | Name | Description
Public Property | CertificateRawData | Gets or Sets the X.509 certificate byte array to use in the PDF document signature.
Top

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns settings of current PdfRenderingExtension class.
Top

See Also

Reference

PdfRenderingExtension Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfRenderingExtension Constructor

[image]
ActiveReports 13
PdfRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class : PdfRenderingExtension Constructor

Glossary Item Box

Initializes a new instance of the PdfRenderingExtension class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PdfRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members


PdfRenderingExtension Class Methods

[image]
ActiveReports 13
PdfRenderingExtension Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class

Glossary Item Box

For a list of all members of this type, see PdfRenderingExtension members.

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns settings of current PdfRenderingExtension class.
Top

See Also

Reference

PdfRenderingExtension Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


GetSupportedSettings Method

[image]
ActiveReports 13
GetSupportedSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class : GetSupportedSettings Method

Glossary Item Box

Returns settings of current PdfRenderingExtension class.

Overload List

Overload | Description
GetSupportedSettings() | Returns settings of current PdfRenderingExtension instance.
GetSupportedSettings(Boolean) | Returns settings of current PdfRenderingExtension instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members


GetSupportedSettings() Method

[image]
ActiveReports 13
GetSupportedSettings() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Returns settings of current PdfRenderingExtension instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings() As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings()

Return Value

System.Collections.Specialized.NameValueCollection of PdfRenderingExtension settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

[image]
ActiveReports 13
GetSupportedSettings(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method

fpl
Returns the PDF rendering settings.

Glossary Item Box

Returns settings of current PdfRenderingExtension instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings( _
   ByVal fpl As Boolean _
) As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings(
   bool fpl
)

Parameters

fpl
Returns the PDF rendering settings.

Return Value

System.Collections.Specialized.NameValueCollection of PdfRenderingExtension settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members
Overload List


PdfRenderingExtension Class Properties

[image]
ActiveReports 13
PdfRenderingExtension Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class

Glossary Item Box

For a list of all members of this type, see PdfRenderingExtension members.

Public Properties

 | Name | Description
Public Property | CertificateRawData | Gets or Sets the X.509 certificate byte array to use in the PDF document signature.
Top

See Also

Reference

PdfRenderingExtension Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


CertificateRawData Property

[image]
ActiveReports 13
CertificateRawData Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class : CertificateRawData Property

Glossary Item Box

Gets or Sets the X.509 certificate byte array to use in the PDF document signature.

Syntax

Visual Basic (Declaration)
Public Property CertificateRawData As Byte()
C#
public byte[] CertificateRawData {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members


Settings Class

[image]
ActiveReports 13
Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class

Glossary Item Box

Settings for PDF Rendering Extension

Object Model

Settings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Page.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


Settings Class Members

[image]
ActiveReports 13
Settings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class

Glossary Item Box

The following tables list the members exposed by Settings.

Public Constructors

 | Name | Description
Public Constructor | Settings Constructor | Initializes a new instance of the Settings class.
Top

Public Properties

 | Name | Description
Public Property | Application | Gets or sets the value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | Gets or sets the the name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | DisplayMode | Specifies how the document should be displayed when opened.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | DocumentToAddAfterReport | Gets or sets the path to the PDF document that should be inserted to the end of the rendering output.
Public Property | DocumentToAddBeforeReport | Gets or sets the path to the PDF document that should be inserted to the beginning of the rendering output.
Public Property | DpiX | Gets or sets the resolution of the output device in x-direction. The default value is 300.
Public Property | DpiY | Gets or sets the resolution of the output device in y-direction. The default value is 300.
Public Property | EmbedFonts | Gets or sets the value indicating whether the fonts used in th report are embedded in the PDF document. You can choose from the following options: All: Embed all fonts except the one's specified in NeverEmbedFonts property. Partial: Embed fonts displaying non-ASCII characters. None: Do not embed fonts.
Public Property | Encrypt | Gets or sets a value indicating whether the document is encrypted or not.
Public Property | EndPage | Gets or sets the last page of the report to render. The default value is the value for StartPage.
Public Property | FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Public Property | Keywords | Gets or sets keywords associated with the document.
Public Property | MarginBottom | Gets or sets the bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginLeft | Gets or sets the left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginRight | Gets or sets the right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginTop | Gets or sets the top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | NeverEmbedFonts | Gets or sets a semicolon-delimited string of font families which should not be embedded in the pdf document.
Public Property | OptimizeStatic | True to generate a PDF file optimized with XObjects. Static report items are reused to a generate a smaller PDF file in less time.
Public Property | OwnerPassword | Gets or sets the owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | PageHeight | Gets or sets the page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | PageWidth | Gets or sets the page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | Permissions | Gets or sets the the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | PrintLayoutMode | Gets or sets the layout mode to be used for PDF document.
Public Property | PrintOnOpen | Gets or sets the value indicating whether the document should be printed after open.
Public Property | PrintPresets | Gets or sets the PDF print dialog presets.
Public Property | SignatureCertificateFileName | Gets/sets the signing certificate file name location
Public Property | SignatureCertificatePassword | Gets/sets the signing certificate password
Public Property | SignatureCertificationLevel | Gets/sets type of the signature certification
Public Property | SignatureContact | Gets/sets the signing contact.
Public Property | SignatureDistinguishedNameVisible | Gets/sets value visibility for the Distinguished Name of the certificate. If true, then the value will be written
Public Property | SignatureDistinguishedShowLabel | Gets/sets value, indicating that label for the Distinguished Name of the certificate should be shown
Public Property | SignatureLocation | Gets/sets the signing location.
Public Property | SignatureNameShowLabel | Gets/sets value, indicating that label for the name of the certificate should be shown
Public Property | SignatureNameVisible | Gets/sets value visibility for the name of the certificate. If true, then the value will be written
Public Property | SignatureReason | Gets/sets the signing reason.
Public Property | SignatureSignDate | Gets/sets the sign date. Default value is DateTime.Now
Public Property | SignatureStampBounds | Gets/sets the bounds of the signature
Public Property | SignatureStampCustomText | Gets/sets the custom text that drawn on signature
Public Property | SignatureStampFont | Gets/sets stamp text font
Public Property | SignatureStampImageAlignment | Gets/sets stamp image alignment inside signature
Public Property | SignatureStampImageFileName | Gets/sets the file location for image shown on signature
Public Property | SignatureStampImageRectangle | Gets/sets area where image should be placed. By default entire signature rectangle will be used.
Public Property | SignatureStampPageIndex | Gets/sets index of the page, where signature should be placed
Public Property | SignatureStampTextAlignment | Gets/sets stamp text alignment
Public Property | SignatureStampTextColor | Gets/sets stamp text color
Public Property | SignatureStampTextRectangle | Gets/sets area where text should be placed. By default entire signature area will be used.
Public Property | SignatureTimeStamp | Gets the settings for TSA server
Public Property | SignatureVisibilityType | Gets/sets visible type for the signature
Public Property | SizeToFit | Gets or sets a value indicating whether PDF pages are fit to the selected paper size or not.
Public Property | StartPage | Gets or sets the first page of the report to render. A value of 0 indicates that all pages are rendered. The default value is 1.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the document's title.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Public Property | Version | Sets output PDF version.
Public Property | WatermarkAngle | Gets or sets the watermark angle for PDF document.
Public Property | WatermarkColor | Gets or sets the watermark color for PDF document.
Public Property | WatermarkFont | Gets or sets the watermark font for PDF document.
Public Property | WatermarkTitle | Gets or sets the watermark title for PDF document.
Top

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


Settings Constructor

[image]
ActiveReports 13
Settings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Settings Constructor

Glossary Item Box

Initializes a new instance of the Settings class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Settings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Class Methods

[image]
ActiveReports 13
Settings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


ApplySettings Method

[image]
ActiveReports 13
ApplySettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : ApplySettings Method

settings
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.

Glossary Item Box

Applies any settings passed in the NameValueCollection settings parameters.

Syntax

Visual Basic (Declaration)
Public Sub ApplySettings( _
   ByVal settings As NameValueCollection _
)
C#
public void ApplySettings(
   NameValueCollection settings
)

Parameters

settings
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Class Properties

[image]
ActiveReports 13
Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Properties

 | Name | Description
Public Property | Application | Gets or sets the value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | Gets or sets the the name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | DisplayMode | Specifies how the document should be displayed when opened.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | DocumentToAddAfterReport | Gets or sets the path to the PDF document that should be inserted to the end of the rendering output.
Public Property | DocumentToAddBeforeReport | Gets or sets the path to the PDF document that should be inserted to the beginning of the rendering output.
Public Property | DpiX | Gets or sets the resolution of the output device in x-direction. The default value is 300.
Public Property | DpiY | Gets or sets the resolution of the output device in y-direction. The default value is 300.
Public Property | EmbedFonts | Gets or sets the value indicating whether the fonts used in th report are embedded in the PDF document. You can choose from the following options: All: Embed all fonts except the one's specified in NeverEmbedFonts property. Partial: Embed fonts displaying non-ASCII characters. None: Do not embed fonts.
Public Property | Encrypt | Gets or sets a value indicating whether the document is encrypted or not.
Public Property | EndPage | Gets or sets the last page of the report to render. The default value is the value for StartPage.
Public Property | FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Public Property | Keywords | Gets or sets keywords associated with the document.
Public Property | MarginBottom | Gets or sets the bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginLeft | Gets or sets the left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginRight | Gets or sets the right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginTop | Gets or sets the top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | NeverEmbedFonts | Gets or sets a semicolon-delimited string of font families which should not be embedded in the pdf document.
Public Property | OptimizeStatic | True to generate a PDF file optimized with XObjects. Static report items are reused to a generate a smaller PDF file in less time.
Public Property | OwnerPassword | Gets or sets the owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | PageHeight | Gets or sets the page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | PageWidth | Gets or sets the page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | Permissions | Gets or sets the the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | PrintLayoutMode | Gets or sets the layout mode to be used for PDF document.
Public Property | PrintOnOpen | Gets or sets the value indicating whether the document should be printed after open.
Public Property | PrintPresets | Gets or sets the PDF print dialog presets.
Public Property | SignatureCertificateFileName | Gets/sets the signing certificate file name location
Public Property | SignatureCertificatePassword | Gets/sets the signing certificate password
Public Property | SignatureCertificationLevel | Gets/sets type of the signature certification
Public Property | SignatureContact | Gets/sets the signing contact.
Public Property | SignatureDistinguishedNameVisible | Gets/sets value visibility for the Distinguished Name of the certificate. If true, then the value will be written
Public Property | SignatureDistinguishedShowLabel | Gets/sets value, indicating that label for the Distinguished Name of the certificate should be shown
Public Property | SignatureLocation | Gets/sets the signing location.
Public Property | SignatureNameShowLabel | Gets/sets value, indicating that label for the name of the certificate should be shown
Public Property | SignatureNameVisible | Gets/sets value visibility for the name of the certificate. If true, then the value will be written
Public Property | SignatureReason | Gets/sets the signing reason.
Public Property | SignatureSignDate | Gets/sets the sign date. Default value is DateTime.Now
Public Property | SignatureStampBounds | Gets/sets the bounds of the signature
Public Property | SignatureStampCustomText | Gets/sets the custom text that drawn on signature
Public Property | SignatureStampFont | Gets/sets stamp text font
Public Property | SignatureStampImageAlignment | Gets/sets stamp image alignment inside signature
Public Property | SignatureStampImageFileName | Gets/sets the file location for image shown on signature
Public Property | SignatureStampImageRectangle | Gets/sets area where image should be placed. By default entire signature rectangle will be used.
Public Property | SignatureStampPageIndex | Gets/sets index of the page, where signature should be placed
Public Property | SignatureStampTextAlignment | Gets/sets stamp text alignment
Public Property | SignatureStampTextColor | Gets/sets stamp text color
Public Property | SignatureStampTextRectangle | Gets/sets area where text should be placed. By default entire signature area will be used.
Public Property | SignatureTimeStamp | Gets the settings for TSA server
Public Property | SignatureVisibilityType | Gets/sets visible type for the signature
Public Property | SizeToFit | Gets or sets a value indicating whether PDF pages are fit to the selected paper size or not.
Public Property | StartPage | Gets or sets the first page of the report to render. A value of 0 indicates that all pages are rendered. The default value is 1.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the document's title.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Public Property | Version | Sets output PDF version.
Public Property | WatermarkAngle | Gets or sets the watermark angle for PDF document.
Public Property | WatermarkColor | Gets or sets the watermark color for PDF document.
Public Property | WatermarkFont | Gets or sets the watermark font for PDF document.
Public Property | WatermarkTitle | Gets or sets the watermark title for PDF document.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


Application Property

[image]
ActiveReports 13
Application Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Application Property

Glossary Item Box

Gets or sets the value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.

Syntax

Visual Basic (Declaration)
Public Property Application As String
C#
public string Application {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Author Property

[image]
ActiveReports 13
Author Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Author Property

Glossary Item Box

Gets or sets the the name of the person who created the document.

Syntax

Visual Basic (Declaration)
Public Property Author As String
C#
public string Author {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


CenterWindow Property

[image]
ActiveReports 13
CenterWindow Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : CenterWindow Property

Glossary Item Box

True to position the document’s window in the center of the screen. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property CenterWindow As Boolean
C#
public bool CenterWindow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DisplayMode Property

[image]
ActiveReports 13
DisplayMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DisplayMode Property

Glossary Item Box

Specifies how the document should be displayed when opened.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As DisplayMode
C#
public DisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DisplayTitle Property

[image]
ActiveReports 13
DisplayTitle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DisplayTitle Property

Glossary Item Box

True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property DisplayTitle As Boolean
C#
public bool DisplayTitle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DocumentToAddAfterReport Property

[image]
ActiveReports 13
DocumentToAddAfterReport Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DocumentToAddAfterReport Property

Glossary Item Box

Gets or sets the path to the PDF document that should be inserted to the end of the rendering output.

Syntax

Visual Basic (Declaration)
Public Property DocumentToAddAfterReport As String
C#
public string DocumentToAddAfterReport {get; set;}

Example

Visual Basic Copy Code
' Create a new page report
Dim _reportDef As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\PageReport1.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(_reportDef)

' Set the information for the PDF file output.
Dim exportFile1 As String = Server.MapPath("") + "\PDF\" + System.IO.Path.GetRandomFileName + ".pdf"
Dim myFile1 As New System.IO.FileInfo(exportFile1)
Dim settings As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings = New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings.DocumentToAddAfterReport = exportFile1 'Document to add after report property.

' Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim _outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name))
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings)
C# Copy Code
// Create a new page report
GrapeCity.ActiveReports.PageReport _reportDef = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\PageReport1.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(_reportDef);

// Set the information for the PDF file output.
string exportFile1 = Server.MapPath("") + "\\PDF\\" + System.IO.Path.GetRandomFileName + ".pdf";
System.IO.FileInfo myFile1 = new System.IO.FileInfo(exportFile1);
GrapeCity.ActiveReports.Export.Pdf.Page.Settings settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings.DocumentToAddAfterReport = exportFile1; //Document to add after report property.

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider _outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name));
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DocumentToAddBeforeReport Property

[image]
ActiveReports 13
DocumentToAddBeforeReport Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DocumentToAddBeforeReport Property

Glossary Item Box

Gets or sets the path to the PDF document that should be inserted to the beginning of the rendering output.

Syntax

Visual Basic (Declaration)
Public Property DocumentToAddBeforeReport As String
C#
public string DocumentToAddBeforeReport {get; set;}

Example

Visual Basic Copy Code
' Create a new page report
Dim _reportDef As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\PageReport1.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(_reportDef)

' Set the information for the PDF file output.
Dim exportFile1 As String = Server.MapPath("") + "\PDF\" + System.IO.Path.GetRandomFileName + ".pdf"
Dim myFile1 As New System.IO.FileInfo(exportFile1)
Dim settings As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings = New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings.DocumentToAddBeforeReport = exportFile1 'Document to add before report property.

' Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim _outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name))
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings)
C# Copy Code
// Create a new page report
GrapeCity.ActiveReports.PageReport _reportDef = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\PageReport1.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(_reportDef);

// Set the information for the PDF file output.
string exportFile1 = Server.MapPath("") + "\\PDF\\" + System.IO.Path.GetRandomFileName + ".pdf";
System.IO.FileInfo myFile1 = new System.IO.FileInfo(exportFile1);
GrapeCity.ActiveReports.Export.Pdf.Page.Settings settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings.DocumentToAddBeforeReport = exportFile1; //Document to add before report property.

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider _outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name));
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings);

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DpiX Property

[image]
ActiveReports 13
DpiX Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DpiX Property

Glossary Item Box

Gets or sets the resolution of the output device in x-direction. The default value is 300.

Syntax

Visual Basic (Declaration)
Public Property DpiX As Single
C#
public float DpiX {get; set;}

Remarks

PDF hasn't its own DPI options. So this setting can be obtained throght GrapeCity.ActiveReports.Extensibility.Layout.Features.FeatureResoluton and used for customers rendering (overriding of GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.IGraphicsRenderer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DpiY Property

[image]
ActiveReports 13
DpiY Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DpiY Property

Glossary Item Box

Gets or sets the resolution of the output device in y-direction. The default value is 300.

Syntax

Visual Basic (Declaration)
Public Property DpiY As Single
C#
public float DpiY {get; set;}

Remarks

PDF hasn't its own DPI options. So this setting can be obtained throght GrapeCity.ActiveReports.Extensibility.Layout.Features.FeatureResoluton and used for customers rendering (overriding of GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.IGraphicsRenderer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


EmbedFonts Property

[image]
ActiveReports 13
EmbedFonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : EmbedFonts Property

Glossary Item Box

Gets or sets the value indicating whether the fonts used in th report are embedded in the PDF document. You can choose from the following options:

All: Embed all fonts except the one's specified in NeverEmbedFonts property.

Partial: Embed fonts displaying non-ASCII characters.

None: Do not embed fonts.

Syntax

Visual Basic (Declaration)
Public Property EmbedFonts As FontEmbedding
C#
public FontEmbedding EmbedFonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Encrypt Property

[image]
ActiveReports 13
Encrypt Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Encrypt Property

Glossary Item Box

Gets or sets a value indicating whether the document is encrypted or not.

Syntax

Visual Basic (Declaration)
Public Property Encrypt As Boolean
C#
public bool Encrypt {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


EndPage Property

[image]
ActiveReports 13
EndPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : EndPage Property

Glossary Item Box

Gets or sets the last page of the report to render. The default value is the value for StartPage.

Syntax

Visual Basic (Declaration)
Public Property EndPage As Integer
C#
public int EndPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


FallbackFonts Property

[image]
ActiveReports 13
FallbackFonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : FallbackFonts Property

Glossary Item Box

Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.

Syntax

Visual Basic (Declaration)
Public Property FallbackFonts As String
C#
public string FallbackFonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


FitWindow Property

[image]
ActiveReports 13
FitWindow Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : FitWindow Property

Glossary Item Box

True to resize the document’s window to fit the size of the first displayed page. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property FitWindow As Boolean
C#
public bool FitWindow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


HideMenubar Property

[image]
ActiveReports 13
HideMenubar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : HideMenubar Property

Glossary Item Box

True to hide the viewer application’s menu bar when the document is active. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property HideMenubar As Boolean
C#
public bool HideMenubar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


HideToolbar Property

[image]
ActiveReports 13
HideToolbar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : HideToolbar Property

Glossary Item Box

True to hide the viewer application’s toolbars when the document is active. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property HideToolbar As Boolean
C#
public bool HideToolbar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


HideWindowUI Property

[image]
ActiveReports 13
HideWindowUI Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : HideWindowUI Property

Glossary Item Box

True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property HideWindowUI As Boolean
C#
public bool HideWindowUI {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


ImageInterpolation Property

[image]
ActiveReports 13
ImageInterpolation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : ImageInterpolation Property

Glossary Item Box

Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.

Syntax

Visual Basic (Declaration)
Public Property ImageInterpolation As Enums.ImageInterpolation
C#
public Enums.ImageInterpolation ImageInterpolation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Keywords Property

[image]
ActiveReports 13
Keywords Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Keywords Property

Glossary Item Box

Gets or sets keywords associated with the document.

Syntax

Visual Basic (Declaration)
Public Property Keywords As String
C#
public string Keywords {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginBottom Property

[image]
ActiveReports 13
MarginBottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginBottom Property

Glossary Item Box

Gets or sets the bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.

Syntax

Visual Basic (Declaration)
Public Property MarginBottom As String
C#
public string MarginBottom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginLeft Property

[image]
ActiveReports 13
MarginLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginLeft Property

Glossary Item Box

Gets or sets the left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.

Syntax

Visual Basic (Declaration)
Public Property MarginLeft As String
C#
public string MarginLeft {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginRight Property

[image]
ActiveReports 13
MarginRight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginRight Property

Glossary Item Box

Gets or sets the right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.

Syntax

Visual Basic (Declaration)
Public Property MarginRight As String
C#
public string MarginRight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


MarginTop Property

[image]
ActiveReports 13
MarginTop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginTop Property

Glossary Item Box

Gets or sets the top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.

Syntax

Visual Basic (Declaration)
Public Property MarginTop As String
C#
public string MarginTop {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


NeverEmbedFonts Property

[image]
ActiveReports 13
NeverEmbedFonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : NeverEmbedFonts Property

Glossary Item Box

Gets or sets a semicolon-delimited string of font families which should not be embedded in the pdf document.

Syntax

Visual Basic (Declaration)
Public Property NeverEmbedFonts As String
C#
public string NeverEmbedFonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


OptimizeStatic Property

[image]
ActiveReports 13
OptimizeStatic Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : OptimizeStatic Property

Glossary Item Box

True to generate a PDF file optimized with XObjects. Static report items are reused to a generate a smaller PDF file in less time.

Syntax

Visual Basic (Declaration)
Public Property OptimizeStatic As Boolean
C#
public bool OptimizeStatic {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


OwnerPassword Property

[image]
ActiveReports 13
OwnerPassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : OwnerPassword Property

Glossary Item Box

Gets or sets the owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.

Syntax

Visual Basic (Declaration)
Public Property OwnerPassword As String
C#
public string OwnerPassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PageHeight Property

[image]
ActiveReports 13
PageHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PageHeight Property

Glossary Item Box

Gets or sets the page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.

Syntax

Visual Basic (Declaration)
Public Property PageHeight As String
C#
public string PageHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PageWidth Property

[image]
ActiveReports 13
PageWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PageWidth Property

Glossary Item Box

Gets or sets the page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.

Syntax

Visual Basic (Declaration)
Public Property PageWidth As String
C#
public string PageWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Permissions Property

[image]
ActiveReports 13
Permissions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Permissions Property

Glossary Item Box

Gets or sets the the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.

Syntax

Visual Basic (Declaration)
Public Property Permissions As PdfPermissions
C#
public PdfPermissions Permissions {get; set;}

Remarks

By default all permissions are set/allowed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PrintLayoutMode Property

[image]
ActiveReports 13
PrintLayoutMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PrintLayoutMode Property

Glossary Item Box

Gets or sets the layout mode to be used for PDF document.

Syntax

Visual Basic (Declaration)
Public Property PrintLayoutMode As GrapeCity.ActiveReports.ImageRenderers.PageControl.PrintLayoutMode
C#
public GrapeCity.ActiveReports.ImageRenderers.PageControl.PrintLayoutMode PrintLayoutMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PrintOnOpen Property

[image]
ActiveReports 13
PrintOnOpen Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PrintOnOpen Property

Glossary Item Box

Gets or sets the value indicating whether the document should be printed after open.

Syntax

Visual Basic (Declaration)
Public Property PrintOnOpen As Boolean
C#
public bool PrintOnOpen {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PrintPresets Property

[image]
ActiveReports 13
PrintPresets Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PrintPresets Property

Glossary Item Box

Gets or sets the PDF print dialog presets.

Syntax

Visual Basic (Declaration)
Public Property PrintPresets As PrintPresets
C#
public PrintPresets PrintPresets {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureCertificateFileName Property

[image]
ActiveReports 13
SignatureCertificateFileName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureCertificateFileName Property

Glossary Item Box

Gets/sets the signing certificate file name location

Syntax

Visual Basic (Declaration)
Public Property SignatureCertificateFileName As String
C#
public string SignatureCertificateFileName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureCertificatePassword Property

[image]
ActiveReports 13
SignatureCertificatePassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureCertificatePassword Property

Glossary Item Box

Gets/sets the signing certificate password

Syntax

Visual Basic (Declaration)
Public Property SignatureCertificatePassword As String
C#
public string SignatureCertificatePassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureCertificationLevel Property

[image]
ActiveReports 13
SignatureCertificationLevel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureCertificationLevel Property

Glossary Item Box

Gets/sets type of the signature certification

Syntax

Visual Basic (Declaration)
Public Property SignatureCertificationLevel As Nullable(Of CertificationLevel)
C#
public Nullable<CertificationLevel> SignatureCertificationLevel {get; set;}

Remarks

This value parsed from string. Possible values: NotCertified, NoChangesAllowed, FormFilling or FormFillingAnnotations

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureContact Property

[image]
ActiveReports 13
SignatureContact Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureContact Property

Glossary Item Box

Gets/sets the signing contact.

Syntax

Visual Basic (Declaration)
Public Property SignatureContact As SignatureField(Of String)
C#
public SignatureField<string> SignatureContact {get; set;}

Remarks

This value parsed from strings. Required 'contact' parameter passed via the 'SignatureContact' field. Optional parameters (visible and showLabel) passed via the 'SignatureContactVisible' and the 'SignatureContactShowLabel' fields

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureDistinguishedNameVisible Property

[image]
ActiveReports 13
SignatureDistinguishedNameVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureDistinguishedNameVisible Property

Glossary Item Box

Gets/sets value visibility for the Distinguished Name of the certificate. If true, then the value will be written

Syntax

Visual Basic (Declaration)
Public Property SignatureDistinguishedNameVisible As Nullable(Of Boolean)
C#
public Nullable<bool> SignatureDistinguishedNameVisible {get; set;}

Remarks

This value parsed from strings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureDistinguishedShowLabel Property

[image]
ActiveReports 13
SignatureDistinguishedShowLabel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureDistinguishedShowLabel Property

Glossary Item Box

Gets/sets value, indicating that label for the Distinguished Name of the certificate should be shown

Syntax

Visual Basic (Declaration)
Public Property SignatureDistinguishedShowLabel As Nullable(Of Boolean)
C#
public Nullable<bool> SignatureDistinguishedShowLabel {get; set;}

Remarks

This value parsed from strings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureLocation Property

[image]
ActiveReports 13
SignatureLocation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureLocation Property

Glossary Item Box

Gets/sets the signing location.

Syntax

Visual Basic (Declaration)
Public Property SignatureLocation As String
C#
public string SignatureLocation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureNameShowLabel Property

[image]
ActiveReports 13
SignatureNameShowLabel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureNameShowLabel Property

Glossary Item Box

Gets/sets value, indicating that label for the name of the certificate should be shown

Syntax

Visual Basic (Declaration)
Public Property SignatureNameShowLabel As Nullable(Of Boolean)
C#
public Nullable<bool> SignatureNameShowLabel {get; set;}

Remarks

This value parsed from strings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureNameVisible Property

[image]
ActiveReports 13
SignatureNameVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureNameVisible Property

Glossary Item Box

Gets/sets value visibility for the name of the certificate. If true, then the value will be written

Syntax

Visual Basic (Declaration)
Public Property SignatureNameVisible As Nullable(Of Boolean)
C#
public Nullable<bool> SignatureNameVisible {get; set;}

Remarks

This value parsed from strings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureReason Property

[image]
ActiveReports 13
SignatureReason Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureReason Property

Glossary Item Box

Gets/sets the signing reason.

Syntax

Visual Basic (Declaration)
Public Property SignatureReason As String
C#
public string SignatureReason {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureSignDate Property

[image]
ActiveReports 13
SignatureSignDate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureSignDate Property

Glossary Item Box

Gets/sets the sign date. Default value is DateTime.Now

Syntax

Visual Basic (Declaration)
Public Property SignatureSignDate As String
C#
public string SignatureSignDate {get; set;}

Remarks

Value must be a serialized DateTime value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampBounds Property

[image]
ActiveReports 13
SignatureStampBounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampBounds Property

Glossary Item Box

Gets/sets the bounds of the signature

Syntax

Visual Basic (Declaration)
Public Property SignatureStampBounds As Nullable(Of RectangleF)
C#
public Nullable<RectangleF> SignatureStampBounds {get; set;}

Remarks

This value parsed from strings. Should be passed as serialized RectangleF struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampCustomText Property

[image]
ActiveReports 13
SignatureStampCustomText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampCustomText Property

Glossary Item Box

Gets/sets the custom text that drawn on signature

Syntax

Visual Basic (Declaration)
Public Property SignatureStampCustomText As String
C#
public string SignatureStampCustomText {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampFont Property

[image]
ActiveReports 13
SignatureStampFont Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampFont Property

Glossary Item Box

Gets/sets stamp text font

Syntax

Visual Basic (Declaration)
Public Property SignatureStampFont As Font
C#
public Font SignatureStampFont {get; set;}

Remarks

This value parsed from strings. Required 'familyName' parameter passed via the 'SignatureStampFont' field. Optional parameters passed via 'SignatureStampFontStyle', 'SignatureStampFontName', 'SignatureStampFontSize', 'SignatureStampFontCharset', 'SignatureStampFontVerticalText' fields

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampImageAlignment Property

[image]
ActiveReports 13
SignatureStampImageAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampImageAlignment Property

Glossary Item Box

Gets/sets stamp image alignment inside signature

Syntax

Visual Basic (Declaration)
Public Property SignatureStampImageAlignment As Nullable(Of Alignment)
C#
public Nullable<Alignment> SignatureStampImageAlignment {get; set;}

Remarks

This value parsed from strings. Should be passed as serialized Alignment struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampImageFileName Property

[image]
ActiveReports 13
SignatureStampImageFileName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampImageFileName Property

Glossary Item Box

Gets/sets the file location for image shown on signature

Syntax

Visual Basic (Declaration)
Public Property SignatureStampImageFileName As String
C#
public string SignatureStampImageFileName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampImageRectangle Property

[image]
ActiveReports 13
SignatureStampImageRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampImageRectangle Property

Glossary Item Box

Gets/sets area where image should be placed. By default entire signature rectangle will be used.

Syntax

Visual Basic (Declaration)
Public Property SignatureStampImageRectangle As Nullable(Of RectangleF)
C#
public Nullable<RectangleF> SignatureStampImageRectangle {get; set;}

Remarks

This value parsed from strings. Should be passed as serialized RectangleF struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampPageIndex Property

[image]
ActiveReports 13
SignatureStampPageIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampPageIndex Property

Glossary Item Box

Gets/sets index of the page, where signature should be placed

Syntax

Visual Basic (Declaration)
Public Property SignatureStampPageIndex As Nullable(Of Integer)
C#
public Nullable<int> SignatureStampPageIndex {get; set;}

Remarks

This value parsed from strings. First page have index 1

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampTextAlignment Property

[image]
ActiveReports 13
SignatureStampTextAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampTextAlignment Property

Glossary Item Box

Gets/sets stamp text alignment

Syntax

Visual Basic (Declaration)
Public Property SignatureStampTextAlignment As Nullable(Of Alignment)
C#
public Nullable<Alignment> SignatureStampTextAlignment {get; set;}

Remarks

This value parsed from strings. Should be passed as serialized Alignment struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampTextColor Property

[image]
ActiveReports 13
SignatureStampTextColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampTextColor Property

Glossary Item Box

Gets/sets stamp text color

Syntax

Visual Basic (Declaration)
Public Property SignatureStampTextColor As Nullable(Of Color)
C#
public Nullable<Color> SignatureStampTextColor {get; set;}

Remarks

This value parsed from strings. Should be passed as serialized Color struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureStampTextRectangle Property

[image]
ActiveReports 13
SignatureStampTextRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampTextRectangle Property

Glossary Item Box

Gets/sets area where text should be placed. By default entire signature area will be used.

Syntax

Visual Basic (Declaration)
Public Property SignatureStampTextRectangle As Nullable(Of RectangleF)
C#
public Nullable<RectangleF> SignatureStampTextRectangle {get; set;}

Remarks

This value parsed from strings. Should be passed as serialized RectangleF struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureTimeStamp Property

[image]
ActiveReports 13
SignatureTimeStamp Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureTimeStamp Property

Glossary Item Box

Gets the settings for TSA server

Syntax

Visual Basic (Declaration)
Public Property SignatureTimeStamp As TimeStamp
C#
public TimeStamp SignatureTimeStamp {get; set;}

Remarks

This value parsed from strings. Required 'serverUrl' parameter passed via the 'SignatureTimeStamp' field. Optional parameters (user and password) passed via the 'SignatureTimeStampUser' and the 'SignatureTimeStampPassword' fields

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SignatureVisibilityType Property

[image]
ActiveReports 13
SignatureVisibilityType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureVisibilityType Property

Glossary Item Box

Gets/sets visible type for the signature

Syntax

Visual Basic (Declaration)
Public Property SignatureVisibilityType As VisibilityType
C#
public VisibilityType SignatureVisibilityType {get; set;}

Remarks

This value parsed from string. Default value: Invisible. Possible values: Invisible, Text, Image, ImageText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SizeToFit Property

[image]
ActiveReports 13
SizeToFit Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SizeToFit Property

Glossary Item Box

Gets or sets a value indicating whether PDF pages are fit to the selected paper size or not.

Syntax

Visual Basic (Declaration)
Public Property SizeToFit As Boolean
C#
public bool SizeToFit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


StartPage Property

[image]
ActiveReports 13
StartPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : StartPage Property

Glossary Item Box

Gets or sets the first page of the report to render. A value of 0 indicates that all pages are rendered. The default value is 1.

Syntax

Visual Basic (Declaration)
Public Property StartPage As Integer
C#
public int StartPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Subject Property

[image]
ActiveReports 13
Subject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Subject Property

Glossary Item Box

Gets or sets the subject of the document.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Title Property

Glossary Item Box

Gets or sets the document's title.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Use128Bit Property

[image]
ActiveReports 13
Use128Bit Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Use128Bit Property

Glossary Item Box

True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.

Syntax

Visual Basic (Declaration)
Public Property Use128Bit As Boolean
C#
public bool Use128Bit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


UserPassword Property

[image]
ActiveReports 13
UserPassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : UserPassword Property

Glossary Item Box

The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.

Syntax

Visual Basic (Declaration)
Public Property UserPassword As String
C#
public string UserPassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Version Property

[image]
ActiveReports 13
Version Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Version Property

Glossary Item Box

Sets output PDF version.

Syntax

Visual Basic (Declaration)
Public Property Version As PdfVersion
C#
public PdfVersion Version {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkAngle Property

[image]
ActiveReports 13
WatermarkAngle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkAngle Property

Glossary Item Box

Gets or sets the watermark angle for PDF document.

Syntax

Visual Basic (Declaration)
Public Property WatermarkAngle As Single
C#
public float WatermarkAngle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkColor Property

[image]
ActiveReports 13
WatermarkColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkColor Property

Glossary Item Box

Gets or sets the watermark color for PDF document.

Syntax

Visual Basic (Declaration)
Public Property WatermarkColor As Color
C#
public Color WatermarkColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkFont Property

[image]
ActiveReports 13
WatermarkFont Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkFont Property

Glossary Item Box

Gets or sets the watermark font for PDF document.

Syntax

Visual Basic (Declaration)
Public Property WatermarkFont As Font
C#
public Font WatermarkFont {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WatermarkTitle Property

[image]
ActiveReports 13
WatermarkTitle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkTitle Property

Glossary Item Box

Gets or sets the watermark title for PDF document.

Syntax

Visual Basic (Declaration)
Public Property WatermarkTitle As String
C#
public string WatermarkTitle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DisplayMode Enumeration

[image]
ActiveReports 13
DisplayMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : DisplayMode Enumeration

Glossary Item Box

Used to specify Settings.DisplayMode.

Syntax

Visual Basic (Declaration)
Public Enum DisplayMode
   Inherits System.Enum
C#
public enum DisplayMode : System.Enum

Members

Member | Description
FullScreen | Full-screen mode with no menu bar, window controls, or any other window visible.
None | Neither document outline nor thumbnail images are visible.
Outlines | The document outline is visible.
Thumbs | Thumbnail images are visible. If thumbnails and outline flags are set, thumbnails will be shown.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Page.DisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfPermissions Enumeration

[image]
ActiveReports 13
PdfPermissions Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfPermissions Enumeration

Glossary Item Box

Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination.

Syntax

Visual Basic (Declaration)
Public Enum PdfPermissions
   Inherits System.Enum
C#
public enum PdfPermissions : System.Enum

Members

Member | Description
AllowAccessibleReaders | Set to permit extracting the text and graphics of the document for accessibility purposes or otherwise (it is most likely for accessibility reasons, but possibly for other “screen reading” purposes) when it is opened with user access permission. This is revision 3 only permission.
AllowAssembly | Set to permit the following operations when the document is opened with user access permission:Insert, rotate, or delete pages, and create bookmarks or thumbnail images even if AllowModifyContents is false. This is revision 3 only permission.
AllowCopy | Set to permit copying text or graphics from the document when it is opened with user access permission. This is a revision 2 permission.
AllowFillIn | Set to permit filling in form fields in the document when it is opened with user access permission. This is revision 3 only permission.
AllowModifyAnnotations | Set to permit adding or modifying annotations in the document when it is opened with user access permission. This permission is a revision 2 or revision 3 permission. Under revision three, the ability to copy/paste document contents is restricted other than what is specified by bit 10 (AllowAccessibleReaders).
AllowModifyContents | Set to permit modifying the document’s contents when it is opened with user access permission. Text annotations can still be added or modified. This is a revision 2 permission.
AllowPrint | Set to permit printing the document when it is opened with user access permission. This is a revision 2 permission.
Default | The default permissions.
None | You can use this setting alone to specify that none of the other permissions are set. It has no effect if you bitwise or this flag together with the other flags.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Page.PdfPermissions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfVersion Enumeration

[image]
ActiveReports 13
PdfVersion Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfVersion Enumeration

Glossary Item Box

Output pdf conformance level. Allows to export to PDF/A.

Syntax

Visual Basic (Declaration)
Public Enum PdfVersion
   Inherits System.Enum
C#
public enum PdfVersion : System.Enum

Members

Member | Description
Pdf12 | PDF version 1.2. This is the native file format of Acrobat 3.0.
Pdf13 | PDF version 1.3. This is the native file format of Acrobat 4.0.
Pdf14 | PDF version 1.4. This is the native file format of Acrobat 5.0.
Pdf15 | PDF version 1.5.
Pdf16 | PDF version 1.6.
Pdf17 | PDF version 1.7.
PDFA1a | PDF/A-1a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA1b | PDF/A-1b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2a | PDF/A-2a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2b | PDF/A-2b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2u | PDF/A-2u level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3a | PDF/A-3a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3b | PDF/A-3b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3u | PDF/A-3u level, see http://en.wikipedia.org/wiki/PDF/A
PDFUA1 | PDF/UA-1 level, see http://en.wikipedia.org/wiki/PDF/UA

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Page.PdfVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Page Namespace


GrapeCity.ActiveReports.Export.Pdf.Section Namespace

GrapeCity.ActiveReports.Export.Pdf.Section Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf.Section Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Pdf Section namespace includes PDF export filters.

Classes

 | Class | Description
Class | PdfDocumentOptions | Encapsulates viewer preferences and document information/metadata for an output PDF document.
Class | PdfExport | Provides PDF document creation functionality for ActiveReports documents.
Class | PdfExportException | The exception that is thrown when a nonfatal PdfExport specific application error occurs.
Class | PdfSecurity | Encapsulates the information necessary to provide PDF document security and encryption.
Class | PdfSigningException | Thrown while signing .pdf

Enumerations

 | Enumeration | Description
Enumeration | DisplayMode | Used to specify PdfDocumentOptions.DisplayMode.
Enumeration | ImageQuality | Specifies the quality used for any images that are converted by ActiveReports.
Enumeration | PdfPermissions | Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination
Enumeration | PdfVersion | Specifies the file format version of a PDF document.

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


PdfDocumentOptions Class

[image]
ActiveReports 13
PdfDocumentOptions Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfDocumentOptions Class

Glossary Item Box

Encapsulates viewer preferences and document information/metadata for an output PDF document.

Object Model

PdfDocumentOptions Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PdfDocumentOptions
C#
public sealed class PdfDocumentOptions

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.PdfDocumentOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfDocumentOptions Class Members

[image]
ActiveReports 13
PdfDocumentOptions Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfDocumentOptions Class

Glossary Item Box

The following tables list the members exposed by PdfDocumentOptions.

Public Properties

 | Name | Description
Public Property | Application | The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | The name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | DisplayMode | Specifies how the document should be displayed when opened. Default value: DisplayMode.None.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | Keywords | Keywords associated with the document.
Public Property | OnlyForPrint | Indicate whether the PDF is only for print.
Public Property | Subject | The subject of the document.
Public Property | Title | The document’s title.
Top

See Also

Reference

PdfDocumentOptions Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfDocumentOptions Class Properties

[image]
ActiveReports 13
PdfDocumentOptions Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfDocumentOptions Class

Glossary Item Box

For a list of all members of this type, see PdfDocumentOptions members.

Public Properties

 | Name | Description
Public Property | Application | The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | The name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | DisplayMode | Specifies how the document should be displayed when opened. Default value: DisplayMode.None.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | Keywords | Keywords associated with the document.
Public Property | OnlyForPrint | Indicate whether the PDF is only for print.
Public Property | Subject | The subject of the document.
Public Property | Title | The document’s title.
Top

See Also

Reference

PdfDocumentOptions Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Application Property

[image]
ActiveReports 13
Application Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Application Property

Glossary Item Box

The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.

Syntax

Visual Basic (Declaration)
Public Property Application As String
C#
public string Application {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Author Property

[image]
ActiveReports 13
Author Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Author Property

Glossary Item Box

The name of the person who created the document.

Syntax

Visual Basic (Declaration)
Public Property Author As String
C#
public string Author {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


CenterWindow Property

[image]
ActiveReports 13
CenterWindow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : CenterWindow Property

Glossary Item Box

True to position the document’s window in the center of the screen. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property CenterWindow As Boolean
C#
public bool CenterWindow {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


DisplayMode Property

[image]
ActiveReports 13
DisplayMode Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : DisplayMode Property

Glossary Item Box

Specifies how the document should be displayed when opened. Default value: DisplayMode.None.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As DisplayMode
C#
public DisplayMode DisplayMode {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


DisplayTitle Property

[image]
ActiveReports 13
DisplayTitle Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : DisplayTitle Property

Glossary Item Box

True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property DisplayTitle As Boolean
C#
public bool DisplayTitle {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


FitWindow Property

[image]
ActiveReports 13
FitWindow Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : FitWindow Property

Glossary Item Box

True to resize the document’s window to fit the size of the first displayed page. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property FitWindow As Boolean
C#
public bool FitWindow {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


HideMenubar Property

[image]
ActiveReports 13
HideMenubar Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : HideMenubar Property

Glossary Item Box

True to hide the viewer application’s menu bar when the document is active. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property HideMenubar As Boolean
C#
public bool HideMenubar {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


HideToolbar Property

[image]
ActiveReports 13
HideToolbar Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : HideToolbar Property

Glossary Item Box

True to hide the viewer application’s toolbars when the document is active. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property HideToolbar As Boolean
C#
public bool HideToolbar {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


HideWindowUI Property

[image]
ActiveReports 13
HideWindowUI Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : HideWindowUI Property

Glossary Item Box

True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.

Syntax

Visual Basic (Declaration)
Public Property HideWindowUI As Boolean
C#
public bool HideWindowUI {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Keywords Property

[image]
ActiveReports 13
Keywords Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Keywords Property

Glossary Item Box

Keywords associated with the document.

Syntax

Visual Basic (Declaration)
Public Property Keywords As String
C#
public string Keywords {get; set;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


OnlyForPrint Property

[image]
ActiveReports 13
OnlyForPrint Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : OnlyForPrint Property

Glossary Item Box

Indicate whether the PDF is only for print.

Syntax

Visual Basic (Declaration)
Public Property OnlyForPrint As Boolean
C#
public bool OnlyForPrint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Subject Property

[image]
ActiveReports 13
Subject Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Subject Property

Glossary Item Box

The subject of the document.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject {get; set;}

Property Value

String type.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Pdf.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.PdfExport();
    p.Options.Application = "Mortimer&#39;s Reporting Software";
    p.Options.Author = "Mortimer";
    p.Options.Keywords = "annual";
}
Visual Basic Copy Code
private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
   Dim rpt As New rptDD
   Dim p As New GrapeCity.ActiveReports.Export.Pdf.PdfExport
   With p.Options
       .Application = "Mortimer&#39;s Reporting Software"
       .Author = "Mortimer"
       .Keywords = "annual"
End sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Title Property

[image]
ActiveReports 13
Title Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Title Property

Glossary Item Box

The document’s title.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Remarks

String Type.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = New rptGrapeCity();
    GrapeCity.ActiveReports.Export.Pdf.PdfExport p = New GrapeCity.ActiveReports.Export.Pdf.PdfExport();
    p.Options.Application = "Mortimer&#39;s Reporting Software";
    p.Options.Author = "Mortimer";
    p.Options.Keywords = "annual";
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New rptDD
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.PdfExport
    With p.Options
        .Application = "Mortimer&#39;s Reporting Software"
        .Author = "Mortimer"
        .Keywords = "annual"
End sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


PdfExport Class

[image]
ActiveReports 13
PdfExport Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

Glossary Item Box

Provides PDF document creation functionality for ActiveReports documents.

Object Model

PdfExport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PdfExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
C#
public sealed class PdfExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExport Class Members

[image]
ActiveReports 13
PdfExport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

Glossary Item Box

The following tables list the members exposed by PdfExport.

Public Constructors

 | Name | Description
Public Constructor | PdfExport Constructor | Initializes a new instance of the PdfExport class.
Top

Public Properties

Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ConvertMetaToPng | Sets or returns a value indicating whether Windows metafiles are converted to PNG files in the exported PDF document.
Public Property | ExportBookmarks | Sets or returns a value indicating whether bookmarks are exported to the PDF document.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs missing in original font
Public Property | ImageInterpolation | Specifies the images interpolation value.
Public Property | ImageQuality | Specifies the quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will effect.
Public Property | ImageResolution | Sets or returns the resolution of images converted from metafiles.
Public Property NeverEmbedFonts

Sets or returns a semicolon-delimited string of values indicating fonts that should not be embedded in a PDF document.

Note: When you add fonts to NeverEmbedFonts property, 2 bytes characters may be distorted in PDF output since the export filter in such cases uses the glyphs from the default system font.

Public Property | Options | Returns an object allowing you to specify viewer preferences and document information options for the exported PDF document.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant PDF document or not.
Public Property | PrintPresets | Gets the print presets.
Public Property | Security | Returns a PdfSecurity object for initializing document encryption and security.
Public Property | Signature | Specifies the signature settings for pdf export
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Sets or returns the version of the PDF format the exported document is saved in.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified page document to a PDF file.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExport Constructor

[image]
ActiveReports 13
PdfExport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : PdfExport Constructor

Glossary Item Box

Initializes a new instance of the PdfExport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PdfExport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


PdfExport Class Methods

[image]
ActiveReports 13
PdfExport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

Glossary Item Box

For a list of all members of this type, see PdfExport members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified page document to a PDF file.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Export Method

Glossary Item Box

Exports the specified page document to a PDF file.

Overload List

Overload | Description
Export(PageDocument,String) | Exports the specified page document to a PDF file.
Export(PageDocument,String,String) | Exports the specified page document to a PDF file.
Export(PageDocument,Stream) | Exports the specified page document to a PDF stream.
Export(PageDocument,Stream,String) | Exports the specified page document to a PDF stream.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String) | Exports the specified document to a PDF file.
Export(SectionDocument,String,String) | Exports the specified document to a PDF file.
Export(SectionDocument,Stream) | Exports the specified document to a PDF stream.
Export(SectionDocument,Stream,String) | Exports the specified document to a PDF stream.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Export(PageDocument,String) Method

[image]
ActiveReports 13
Export(PageDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main PDF file to.

Glossary Item Box

Exports the specified page document to a PDF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   PageDocument document,
   string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main PDF file to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(PageDocument,String,String) Method

[image]
ActiveReports 13
Export(PageDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,String,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main PDF file to.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified page document to a PDF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main PDF file to.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(PageDocument,Stream) Method

[image]
ActiveReports 13
Export(PageDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,Stream) Method

document
The ActiveReports PageDocument object to export.
stream
The stream to save the PDF document to.

Glossary Item Box

Exports the specified page document to a PDF stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream _
)
C#
public void Export(
   PageDocument document,
   Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The stream to save the PDF document to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(PageDocument,Stream,String) Method

[image]
ActiveReports 13
Export(PageDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,Stream,String) Method

document
ActiveReports PageDocument to be exported.
stream
Stream that saves the PDF document.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified page document to a PDF stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   Stream stream,
   string pageRange
)

Parameters

document
ActiveReports PageDocument to be exported.
stream
Stream that saves the PDF document.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,String,String) Method

[image]
ActiveReports 13
Export(IReport,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,String,String) Method

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath,
   string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,String) Method

[image]
ActiveReports 13
Export(IReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,String) Method

report
IReport instance to Export
filePath
Path to export

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,Stream) Method

[image]
ActiveReports 13
Export(IReport,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,Stream) Method

report
IReport instance to Export
outputStream
The output stream.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,Stream,String) Method

[image]
ActiveReports 13
Export(IReport,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,Stream,String) Method

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream,
   string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,String) Method

document
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
filePath
The file name and path to save the main PDF file to.

Glossary Item Box

Exports the specified document to a PDF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
filePath
The file name and path to save the main PDF file to.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,String,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,String,String) Method

document
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
filePath
The file name and path to save the main PDF file to.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified document to a PDF file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
filePath
The file name and path to save the main PDF file to.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf", "1-3");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf", "1-3")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,Stream) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,Stream) Method

document
The ActiveReports Document object to export.
stream
System.IO.Stream to save the PDF document.

Glossary Item Box

Exports the specified document to a PDF stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal stream As Stream _
)
C#
public void Export(
   SectionDocument document,
   Stream stream
)

Parameters

document
The ActiveReports Document object to export.
stream
System.IO.Stream to save the PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,Stream,String) Method

document
The ActiveReports Document object to export.
stream
System.IO.Stream to save the PDF document.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified document to a PDF stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   Stream stream,
   string pageRange
)

Parameters

document
The ActiveReports Document object to export.
stream
System.IO.Stream to save the PDF document.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


PdfExport Class Properties

[image]
ActiveReports 13
PdfExport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

Glossary Item Box

For a list of all members of this type, see PdfExport members.

Public Properties

Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ConvertMetaToPng | Sets or returns a value indicating whether Windows metafiles are converted to PNG files in the exported PDF document.
Public Property | ExportBookmarks | Sets or returns a value indicating whether bookmarks are exported to the PDF document.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs missing in original font
Public Property | ImageInterpolation | Specifies the images interpolation value.
Public Property | ImageQuality | Specifies the quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will effect.
Public Property | ImageResolution | Sets or returns the resolution of images converted from metafiles.
Public Property NeverEmbedFonts

Sets or returns a semicolon-delimited string of values indicating fonts that should not be embedded in a PDF document.

Note: When you add fonts to NeverEmbedFonts property, 2 bytes characters may be distorted in PDF output since the export filter in such cases uses the glyphs from the default system font.

Public Property | Options | Returns an object allowing you to specify viewer preferences and document information options for the exported PDF document.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant PDF document or not.
Public Property | PrintPresets | Gets the print presets.
Public Property | Security | Returns a PdfSecurity object for initializing document encryption and security.
Public Property | Signature | Specifies the signature settings for pdf export
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Sets or returns the version of the PDF format the exported document is saved in.
Top

See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


ConvertMetaToPng Property

[image]
ActiveReports 13
ConvertMetaToPng Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ConvertMetaToPng Property

Glossary Item Box

Sets or returns a value indicating whether Windows metafiles are converted to PNG files in the exported PDF document.

Syntax

Visual Basic (Declaration)
Public Property ConvertMetaToPng As Boolean
C#
public bool ConvertMetaToPng {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


ExportBookmarks Property

[image]
ActiveReports 13
ExportBookmarks Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ExportBookmarks Property

Glossary Item Box

Sets or returns a value indicating whether bookmarks are exported to the PDF document.

Syntax

Visual Basic (Declaration)
Public Property ExportBookmarks As Boolean
C#
public bool ExportBookmarks {get; set;}

Remarks

To control the display method of the bookmarks that have been exported, Options.DisplayMode is used.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf", "1-3");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf", "1-3")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


FontFallback Property

[image]
ActiveReports 13
FontFallback Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : FontFallback Property

Glossary Item Box

Gets or sets a comma-delimited string of font families that will be used to lookup glyphs missing in original font

Syntax

Visual Basic (Declaration)
Public Property FontFallback As String
C#
public string FontFallback {get; set;}

Remarks

This function can only be used with the Professional version.
Note: If you use the Standard version, this setting gets disabled.
If there is a probelm in the output when it is exported to PDF, or if any problems occur with a particular font, then it is a limitation of the product.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


ImageInterpolation Property

[image]
ActiveReports 13
ImageInterpolation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ImageInterpolation Property

Glossary Item Box

Specifies the images interpolation value.

Syntax

Visual Basic (Declaration)
Public Property ImageInterpolation As Enums.ImageInterpolation
C#
public Enums.ImageInterpolation ImageInterpolation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


ImageQuality Property

[image]
ActiveReports 13
ImageQuality Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ImageQuality Property

Glossary Item Box

Specifies the quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will effect.

Syntax

Visual Basic (Declaration)
Public Property ImageQuality As ImageQuality
C#
public ImageQuality ImageQuality {get; set;}

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


ImageResolution Property

[image]
ActiveReports 13
ImageResolution Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ImageResolution Property

Glossary Item Box

Sets or returns the resolution of images converted from metafiles.

Syntax

Visual Basic (Declaration)
Public Property ImageResolution As Integer
C#
public int ImageResolution {get; set;}

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


NeverEmbedFonts Property

[image]
ActiveReports 13
NeverEmbedFonts Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : NeverEmbedFonts Property

Glossary Item Box

Sets or returns a semicolon-delimited string of values indicating fonts that should not be embedded in a PDF document.

Note: When you add fonts to NeverEmbedFonts property, 2 bytes characters may be distorted in PDF output since the export filter in such cases uses the glyphs from the default system font.

Syntax

Visual Basic (Declaration)
Public Property NeverEmbedFonts As String
C#
public string NeverEmbedFonts {get; set;}

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Options Property

[image]
ActiveReports 13
Options Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Options Property

Glossary Item Box

Returns an object allowing you to specify viewer preferences and document information options for the exported PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Options As PdfDocumentOptions
C#
public PdfDocumentOptions Options {get;}

Example

C# Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
VB.NET Copy Code
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Pagination Property

Glossary Item Box

Gets or sets the value, that indicates whether pagination should be used for resultant PDF document or not.

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


PrintPresets Property

[image]
ActiveReports 13
PrintPresets Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : PrintPresets Property

Glossary Item Box

Gets the print presets.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintPresets As PrintPresets
C#
public PrintPresets PrintPresets {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Security Property

[image]
ActiveReports 13
Security Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Security Property

Glossary Item Box

Returns a PdfSecurity object for initializing document encryption and security.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Security As PdfSecurity
C#
public PdfSecurity Security {get;}

Remarks

You must set the PdfSecurity.Encrypt property to true in order for the document to be encrypted and the permissions enforced.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Signature Property

[image]
ActiveReports 13
Signature Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Signature Property

Glossary Item Box

Specifies the signature settings for pdf export

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Signature As PdfSignature
C#
public PdfSignature Signature {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Version Property

[image]
ActiveReports 13
Version Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Version Property

Glossary Item Box

Sets or returns the version of the PDF format the exported document is saved in.

Syntax

Visual Basic (Declaration)
Public Property Version As PdfVersion
C#
public PdfVersion Version {get; set;}

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf11;
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf11
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


PdfExportException Class

[image]
ActiveReports 13
PdfExportException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class

Glossary Item Box

The exception that is thrown when a nonfatal PdfExport specific application error occurs.

Object Model

PdfExportException Class

Syntax

Visual Basic (Declaration)
Public Class PdfExportException
   Inherits System.ApplicationException
C#
public class PdfExportException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExportException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExportException Class Members

[image]
ActiveReports 13
PdfExportException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class

Glossary Item Box

The following tables list the members exposed by PdfExportException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfExportException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSecurity Class

[image]
ActiveReports 13
PdfSecurity Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSecurity Class

Glossary Item Box

Encapsulates the information necessary to provide PDF document security and encryption.

Object Model

PdfSecurity Class

Syntax

Visual Basic (Declaration)
Public Class PdfSecurity
C#
public class PdfSecurity

Remarks

If a user password is supplied the viewer application should prompt for a password. If a user password is not supplied no password will be requested to open the document. By correctly supplying either the user password, or the owner password, the user will be able to open the document, decrypt it and display it on the screen. Whether additional operations are allowed on a decrypted document depends on which password (if any) was supplied when the document was opened and on any access restrictions specified using this class's Permissions property.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSecurity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSecurity Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSecurity Class Members

[image]
ActiveReports 13
PdfSecurity Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSecurity Class

Glossary Item Box

The following tables list the members exposed by PdfSecurity.

Public Properties

 | Name | Description
Public Property | Encrypt | Determines whether the document is encrypted or not.
Public Property | OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | Permissions | Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Top

See Also

Reference

PdfSecurity Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSecurity Class Properties

[image]
ActiveReports 13
PdfSecurity Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSecurity Class

Glossary Item Box

For a list of all members of this type, see PdfSecurity members.

Public Properties

 | Name | Description
Public Property | Encrypt | Determines whether the document is encrypted or not.
Public Property | OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | Permissions | Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Top

See Also

Reference

PdfSecurity Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Encrypt Property

[image]
ActiveReports 13
Encrypt Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : Encrypt Property

Glossary Item Box

Determines whether the document is encrypted or not.

Syntax

Visual Basic (Declaration)
Public Property Encrypt As Boolean
C#
public bool Encrypt {get; set;}

Remarks

You must set this property to true for the document to be encrypted and the permissions enforced.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSecurity Class
PdfSecurity Members


OwnerPassword Property

[image]
ActiveReports 13
OwnerPassword Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : OwnerPassword Property

Glossary Item Box

The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.

Syntax

Visual Basic (Declaration)
Public Property OwnerPassword As String
C#
public string OwnerPassword {get; set;}

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSecurity Class
PdfSecurity Members


Permissions Property

[image]
ActiveReports 13
Permissions Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : Permissions Property

Glossary Item Box

Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.

Syntax

Visual Basic (Declaration)
Public Property Permissions As PdfPermissions
C#
public PdfPermissions Permissions {get; set;}

Remarks

By default all permissions are set/allowed.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSecurity Class
PdfSecurity Members


Use128Bit Property

[image]
ActiveReports 13
Use128Bit Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : Use128Bit Property

Glossary Item Box

True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.

Syntax

Visual Basic (Declaration)
Public Property Use128Bit As Boolean
C#
public bool Use128Bit {get; set;}

Remarks

The default value is true.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSecurity Class
PdfSecurity Members


UserPassword Property

[image]
ActiveReports 13
UserPassword Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : UserPassword Property

Glossary Item Box

The user password that can be entered in the reader. If this value is left empty the user will not be prompted for a password, however the user will be restricted by the specified permissions.

Syntax

Visual Basic (Declaration)
Public Property UserPassword As String
C#
public string UserPassword {get; set;}

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSecurity Class
PdfSecurity Members


PdfSigningException Class

[image]
ActiveReports 13
PdfSigningException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class

Glossary Item Box

Thrown while signing .pdf

Object Model

PdfSigningException Class

Syntax

Visual Basic (Declaration)
Public Class PdfSigningException
   Inherits System.ApplicationException
C#
public class PdfSigningException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSigningException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSigningException Class Members

[image]
ActiveReports 13
PdfSigningException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class

Glossary Item Box

The following tables list the members exposed by PdfSigningException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfSigningException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


DisplayMode Enumeration

[image]
ActiveReports 13
DisplayMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : DisplayMode Enumeration

Glossary Item Box

Used to specify PdfDocumentOptions.DisplayMode.

Syntax

Visual Basic (Declaration)
Public Enum DisplayMode
   Inherits System.Enum
C#
public enum DisplayMode : System.Enum

Members

Member | Description
FullScreen | Displays the exported PDF using the Full Screen. Bookmarks are not displayed until opened by the user.
None | Default value for DisplayMode. Bookmarks are not displayed until opened by the user.
Outlines | Shows bookmarks in Outline format.
Thumbs | Shows Bookmarks as thumbnail views of the pages of the exported PDF.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


ImageQuality Enumeration

[image]
ActiveReports 13
ImageQuality Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : ImageQuality Enumeration

Glossary Item Box

Specifies the quality used for any images that are converted by ActiveReports.

Syntax

Visual Basic (Declaration)
Public Enum ImageQuality
   Inherits System.Enum
C#
public enum ImageQuality : System.Enum

Members

Member | Description
Highest | Exports Windows metafiles at the highest quality level. (Best for printing.)
Lowest | Exports Windows metafiles at the lowest quality level. (Used to save space.)
Medium | Exports Windows metafiles at a medium quality level. (For normal screen viewing.)

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfPermissions Enumeration

[image]
ActiveReports 13
PdfPermissions Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfPermissions Enumeration

Glossary Item Box

Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination

Syntax

Visual Basic (Declaration)
Public Enum PdfPermissions
   Inherits System.Enum
C#
public enum PdfPermissions : System.Enum

Members

Member | Description
AllowAccessibleReaders | Allows the user to open the PDF in a variety of devices, including hand-held computers and screen readers. Value is 512. The PdfSecurity.Use128Bit property must be set to True for this setting to function.
AllowAssembly | Allows insertion, deletion, or rotation of pages and creation of bookmarks and thumbnails even if AllowModifyContents hasn't been specified. Value is 1024. The PdfSecurity.Use128Bit property must be set to True for this setting to function.
AllowCopy | Allows the user to copy from the PDF file. Value is 16.
AllowFillIn | Allows the user to fill in a PDF form. Value is 256. The PdfSecurity.Use128Bit property must be set to True for this setting to function.
AllowModifyAnnotations | Allows the user to modify annotations in the PDF. Value is 32.
AllowModifyContents | Allows the user to modify the contents of the PDF. Value is 8.
AllowPrint | Allows the user to print the PDF. Value is 4.
None | Allows the user to read the PDF file, but not to modify it in any way. Value is 0.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfVersion Enumeration

[image]
ActiveReports 13
PdfVersion Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfVersion Enumeration

Glossary Item Box

Specifies the file format version of a PDF document.

Syntax

Visual Basic (Declaration)
Public Enum PdfVersion
   Inherits System.Enum
C#
public enum PdfVersion : System.Enum

Members

Member | Description
Pdf11 | PDF version 1.1. Suitable for legacy viewers.
Pdf12 | PDF version 1.2. This is the native file format of Acrobat 3.0.
Pdf13 | PDF version 1.3. This is the native file format of Acrobat 4.0.
Pdf14 | PDF version 1.4.
Pdf15 | PDF version 1.5.
Pdf16 | PDF version 1.6.
Pdf17 | PDF version 1.7.
PDFA1a | PDF/A-1a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA1b | PDF/A-1b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2a | PDF/A-2a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2b | PDF/A-2b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2u | PDF/A-2u level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3a | PDF/A-3a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3b | PDF/A-3b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3u | PDF/A-3u level, see http://en.wikipedia.org/wiki/PDF/A
PDFUA1 | PDF/UA-1 level, see http://en.wikipedia.org/wiki/PDF/UA

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace

Glossary Item Box

This function is only supported in the Professional version.
In the Standard version, a banner indicating that a Professional license is required to output the PDF, is displayed.

Classes

 | Class | Description
Class | PdfSignature | Encapsulates the information necessary to provide PDF document digital signatures and certification.
Class | PdfStamp | Encapsulates the information necessary to draw PDF document digital signatures and certification on documents.
Class | SignatureField<T> | Class wrapper, provides additional fields to values which should be placed on signature
Class | TimeStamp | Encapsulates the information necessary to include timestamps from a Time Stamping Authority in digital signatures on PDF documents.

Enumerations

 | Enumeration | Description
Enumeration | Alignment | Sets the type of alignment to use for text or images.
Enumeration | CertificationLevel | Enumerates possible certification types
Enumeration | VisibilityType | Sets a value indicating whether and how to display certification on the document.

Remarks

Note: In case of exporting to a PDF document that is encrypted, an electronic signature cannot be added.

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


PdfSignature Class

[image]
ActiveReports 13
PdfSignature Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class

Glossary Item Box

Encapsulates the information necessary to provide PDF document digital signatures and certification.

Object Model

PdfSignature Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PdfSignature
C#
public sealed class PdfSignature

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfSignature

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfSignature Class Members

[image]
ActiveReports 13
PdfSignature Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class

Glossary Item Box

The following tables list the members exposed by PdfSignature.

Public Properties

 | Name | Description
Public Property | Certificate | Gets or sets the X.509 certificate to use in the signature.
Public Property | CertificationLevel | Sets an enumerated Allowed Actions value as in the Save as Certified Document wizard in Adobe Acrobat.
Public Property | Contact | Gets or sets signer's contact information. For example, phone number.
Public Property | DistinguishedName | Gets the distinguished name to display in the signature.
Public Property | Location | Gets or sets the location. For example, city name.
Public Property | Name | The name to display in the signed by field.
Public Property | Reason | Allows you to add a reason for digitally signing the document.
Public Property | SignDate | Gets or sets the date on with the document is signed.
Public Property | Stamp | Gets the PdfStamp object used in the signature.
Public Property | TimeStamp | Gets or sets the TimeStamp object to use in the signature.
Public Property | VisibilityType | Gets or sets an enumerated value indicating whether and how to display certification on the document.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones current signatures
Top

See Also

Reference

PdfSignature Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfSignature Class Methods

[image]
ActiveReports 13
PdfSignature Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class

Glossary Item Box

For a list of all members of this type, see PdfSignature members.

Public Methods

 | Name | Description
Public Method | Clone | Clones current signatures
Top

See Also

Reference

PdfSignature Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Clone Method

[image]
ActiveReports 13
Clone Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Clone Method

Glossary Item Box

Clones current signatures

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

Copy of the current signature

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


PdfSignature Class Properties

[image]
ActiveReports 13
PdfSignature Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class

Glossary Item Box

For a list of all members of this type, see PdfSignature members.

Public Properties

 | Name | Description
Public Property | Certificate | Gets or sets the X.509 certificate to use in the signature.
Public Property | CertificationLevel | Sets an enumerated Allowed Actions value as in the Save as Certified Document wizard in Adobe Acrobat.
Public Property | Contact | Gets or sets signer's contact information. For example, phone number.
Public Property | DistinguishedName | Gets the distinguished name to display in the signature.
Public Property | Location | Gets or sets the location. For example, city name.
Public Property | Name | The name to display in the signed by field.
Public Property | Reason | Allows you to add a reason for digitally signing the document.
Public Property | SignDate | Gets or sets the date on with the document is signed.
Public Property | Stamp | Gets the PdfStamp object used in the signature.
Public Property | TimeStamp | Gets or sets the TimeStamp object to use in the signature.
Public Property | VisibilityType | Gets or sets an enumerated value indicating whether and how to display certification on the document.
Top

See Also

Reference

PdfSignature Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Certificate Property

[image]
ActiveReports 13
Certificate Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Certificate Property

Glossary Item Box

Gets or sets the X.509 certificate to use in the signature.

Syntax

Visual Basic (Declaration)
Public Property Certificate As X509Certificate2
C#
public X509Certificate2 Certificate {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


CertificationLevel Property

[image]
ActiveReports 13
CertificationLevel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : CertificationLevel Property

Glossary Item Box

Sets an enumerated Allowed Actions value as in the Save as Certified Document wizard in Adobe Acrobat.

Syntax

Visual Basic (Declaration)
Public Property CertificationLevel As CertificationLevel
C#
public CertificationLevel CertificationLevel {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


Contact Property

[image]
ActiveReports 13
Contact Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Contact Property

Glossary Item Box

Gets or sets signer's contact information. For example, phone number.

Syntax

Visual Basic (Declaration)
Public Property Contact As SignatureField(Of String)
C#
public SignatureField<string> Contact {get; set;}

Remarks

In Adobe Acrobat, this is an optional field. This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


DistinguishedName Property

[image]
ActiveReports 13
DistinguishedName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : DistinguishedName Property

Glossary Item Box

Gets the distinguished name to display in the signature.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DistinguishedName As SignatureField(Of String)
C#
public SignatureField<string> DistinguishedName {get;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


Location Property

[image]
ActiveReports 13
Location Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Location Property

Glossary Item Box

Gets or sets the location. For example, city name.

Syntax

Visual Basic (Declaration)
Public Property Location As SignatureField(Of String)
C#
public SignatureField<string> Location {get; set;}

Remarks

In Adobe Acrobat, this is an optional field. This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Name Property

Glossary Item Box

The name to display in the signed by field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As SignatureField(Of String)
C#
public SignatureField<string> Name {get;}

Remarks

The Name is displayed with the text "Signed by." This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


Reason Property

[image]
ActiveReports 13
Reason Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Reason Property

Glossary Item Box

Allows you to add a reason for digitally signing the document.

Syntax

Visual Basic (Declaration)
Public Property Reason As SignatureField(Of String)
C#
public SignatureField<string> Reason {get; set;}

Remarks

In the Adobe Acrobat Save as Certified Document wizard, the following reasons can be selected:

  • I am the author of this document
  • I have reviewed this document
  • I am approving this document
  • I attest to the accuracy and integrity of this document
  • I agree to the terms defined by the placement of my signature on this document
  • I agree to 'specified' portions of this document

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


SignDate Property

[image]
ActiveReports 13
SignDate Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : SignDate Property

Glossary Item Box

Gets or sets the date on with the document is signed.

Syntax

Visual Basic (Declaration)
Public Property SignDate As SignatureField(Of Date)
C#
public SignatureField<DateTime> SignDate {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


Stamp Property

[image]
ActiveReports 13
Stamp Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Stamp Property

Glossary Item Box

Gets the PdfStamp object used in the signature.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stamp As PdfStamp
C#
public PdfStamp Stamp {get;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


TimeStamp Property

[image]
ActiveReports 13
TimeStamp Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : TimeStamp Property

Glossary Item Box

Gets or sets the TimeStamp object to use in the signature.

Syntax

Visual Basic (Declaration)
Public Property TimeStamp As TimeStamp
C#
public TimeStamp TimeStamp {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


VisibilityType Property

[image]
ActiveReports 13
VisibilityType Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : VisibilityType Property

Glossary Item Box

Gets or sets an enumerated value indicating whether and how to display certification on the document.

Syntax

Visual Basic (Declaration)
Public Property VisibilityType As VisibilityType
C#
public VisibilityType VisibilityType {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSignature Class
PdfSignature Members


PdfStamp Class

[image]
ActiveReports 13
PdfStamp Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfStamp Class

Glossary Item Box

Encapsulates the information necessary to draw PDF document digital signatures and certification on documents.

Object Model

PdfStamp Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PdfStamp
C#
public sealed class PdfStamp

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
// Text signature.
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfStamp

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfStamp Class Members

[image]
ActiveReports 13
PdfStamp Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfStamp Class

Glossary Item Box

The following tables list the members exposed by PdfStamp.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the rectangular bounding area in which to print the signature.
Public Property | CustomText | Gets or sets a string to the signature.
Public Property | Font | Gets or sets the font to use on the signature text.
Public Property | Image | Gets or sets the System.Drawing.Image file to use in the signature.
Public Property | ImageAlignment | Gets or sets an enumerated Alignment value to determine the placement of the image in the signature.
Public Property | ImageRectangle | Gets or sets a RectangleF value to determine the location of the image in the signature bounds.
Public Property | PageIndex | Gets or sets the index of the page on which to display the signature.
Public Property | TextAlignment | Gets or sets an enumerated Alignment value to determine the placement of the text in the signature.
Public Property | TextColor | Gets or sets the color of the text used in the signature.
Public Property | TextRectangle | Gets or sets a RectangleF value to determine the location of the text in the signature bounds.
Top

See Also

Reference

PdfStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfStamp Class Properties

[image]
ActiveReports 13
PdfStamp Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfStamp Class

Glossary Item Box

For a list of all members of this type, see PdfStamp members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the rectangular bounding area in which to print the signature.
Public Property | CustomText | Gets or sets a string to the signature.
Public Property | Font | Gets or sets the font to use on the signature text.
Public Property | Image | Gets or sets the System.Drawing.Image file to use in the signature.
Public Property | ImageAlignment | Gets or sets an enumerated Alignment value to determine the placement of the image in the signature.
Public Property | ImageRectangle | Gets or sets a RectangleF value to determine the location of the image in the signature bounds.
Public Property | PageIndex | Gets or sets the index of the page on which to display the signature.
Public Property | TextAlignment | Gets or sets an enumerated Alignment value to determine the placement of the text in the signature.
Public Property | TextColor | Gets or sets the color of the text used in the signature.
Public Property | TextRectangle | Gets or sets a RectangleF value to determine the location of the text in the signature bounds.
Top

See Also

Reference

PdfStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : Bounds Property

Glossary Item Box

Gets or sets the rectangular bounding area in which to print the signature.

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
C#
public RectangleF Bounds {get; set;}

Property Value

A RectangleF object.

Remarks

In Adobe Acrobat, the user does this by clicking and dragging a rectangle in the document. This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


CustomText Property

[image]
ActiveReports 13
CustomText Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : CustomText Property

Glossary Item Box

Gets or sets a string to the signature.

Syntax

Visual Basic (Declaration)
Public Property CustomText As String
C#
public string CustomText {get; set;}

Property Value

String.

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : Font Property

Glossary Item Box

Gets or sets the font to use on the signature text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

A System.Drawing.Font.

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


Image Property

[image]
ActiveReports 13
Image Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : Image Property

Glossary Item Box

Gets or sets the System.Drawing.Image file to use in the signature.

Syntax

Visual Basic (Declaration)
Public Property Image As Image
C#
public Image Image {get; set;}

Property Value

A System.Drawing.Image.

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


ImageAlignment Property

[image]
ActiveReports 13
ImageAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : ImageAlignment Property

Glossary Item Box

Gets or sets an enumerated Alignment value to determine the placement of the image in the signature.

Syntax

Visual Basic (Declaration)
Public Property ImageAlignment As Alignment
C#
public Alignment ImageAlignment {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


ImageRectangle Property

[image]
ActiveReports 13
ImageRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : ImageRectangle Property

Glossary Item Box

Gets or sets a RectangleF value to determine the location of the image in the signature bounds.

Syntax

Visual Basic (Declaration)
Public Property ImageRectangle As RectangleF
C#
public RectangleF ImageRectangle {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


PageIndex Property

[image]
ActiveReports 13
PageIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : PageIndex Property

Glossary Item Box

Gets or sets the index of the page on which to display the signature.

Syntax

Visual Basic (Declaration)
Public Property PageIndex As Integer
C#
public int PageIndex {get; set;}

Property Value

An integer.

Remarks

First page have index 1.

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


TextAlignment Property

[image]
ActiveReports 13
TextAlignment Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : TextAlignment Property

Glossary Item Box

Gets or sets an enumerated Alignment value to determine the placement of the text in the signature.

Syntax

Visual Basic (Declaration)
Public Property TextAlignment As Alignment
C#
public Alignment TextAlignment {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example

Visual Basic Copy Code
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
C# Copy Code
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


TextColor Property

[image]
ActiveReports 13
TextColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : TextColor Property

Glossary Item Box

Gets or sets the color of the text used in the signature.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
C#
public Color TextColor {get; set;}

Property Value

A System.Drawing.Color.

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


TextRectangle Property

[image]
ActiveReports 13
TextRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : TextRectangle Property

Glossary Item Box

Gets or sets a RectangleF value to determine the location of the text in the signature bounds.

Syntax

Visual Basic (Declaration)
Public Property TextRectangle As RectangleF
C#
public RectangleF TextRectangle {get; set;}

Property Value

A RectangleF.

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfStamp Class
PdfStamp Members


SignatureField<T> Class

T
A generic type.
[image]
ActiveReports 13
SignatureField<T> Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class

Glossary Item Box

Class wrapper, provides additional fields to values which should be placed on signature

Object Model

SignatureField<T> Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SignatureField(Of T)
C#
public sealed class SignatureField<T>

Type Parameters

T
A generic type.

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SignatureField<T> Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


SignatureField<T> Class Members

[image]
ActiveReports 13
SignatureField<T> Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class

Glossary Item Box

The following tables list the members exposed by SignatureField<T>.

Public Properties

 | Name | Description
Public Property | ShowLabel | Gets or sets a value indicating whether to label the fields in the signature.
Public Property | Value | Gets the generic type from the constructor.
Public Property | Visible | Gets or sets a value indicating whether to display the signature.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateEmpty | Creates an empty generic signature field.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

Public Operators

public Operator Implicit Type Conversion Converts value to SignatureField<T> object
Top

See Also

Reference

SignatureField<T> Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


SignatureField<T> Class Methods

[image]
ActiveReports 13
SignatureField<T> Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class

Glossary Item Box

For a list of all members of this type, see SignatureField<T> members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateEmpty | Creates an empty generic signature field.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top

See Also

Reference

SignatureField<T> Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


CreateEmpty Method

[image]
ActiveReports 13
CreateEmpty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : CreateEmpty Method

Glossary Item Box

Creates an empty generic signature field.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateEmpty() As SignatureField(Of T)
C#
public static SignatureField<T> CreateEmpty()

Return Value

Created empty field

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : ToString Method

Glossary Item Box

Converts the value of the current instance to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Returns Value.ToString()

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


SignatureField<T> Class Properties

[image]
ActiveReports 13
SignatureField<T> Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class

Glossary Item Box

For a list of all members of this type, see SignatureField<T> members.

Public Properties

 | Name | Description
Public Property | ShowLabel | Gets or sets a value indicating whether to label the fields in the signature.
Public Property | Value | Gets the generic type from the constructor.
Public Property | Visible | Gets or sets a value indicating whether to display the signature.
Top

See Also

Reference

SignatureField<T> Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


ShowLabel Property

[image]
ActiveReports 13
ShowLabel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : ShowLabel Property

Glossary Item Box

Gets or sets a value indicating whether to label the fields in the signature.

Syntax

Visual Basic (Declaration)
Public Property ShowLabel As Boolean
C#
public bool ShowLabel {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


Value Property

[image]
ActiveReports 13
Value Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : Value Property

Glossary Item Box

Gets the generic type from the constructor.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As T
C#
public T Value {get;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether to display the signature.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


Implicit Type Conversion Operator

[image]
ActiveReports 13
Implicit Type Conversion Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : Implicit Type Conversion Operator

value
Value to convert

Glossary Item Box

Converts value to SignatureField<T> object

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As T _
) As SignatureField(Of T)
C#
public SignatureField<T> operator implicit(
   T value
)

Parameters

value
Value to convert

Return Value

Converted value

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


TimeStamp Class

[image]
ActiveReports 13
TimeStamp Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : TimeStamp Class

Glossary Item Box

Encapsulates the information necessary to include timestamps from a Time Stamping Authority in digital signatures on PDF documents.

Object Model

TimeStamp Class

Syntax

Visual Basic (Declaration)
Public Class TimeStamp
C#
public class TimeStamp

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeStamp Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


TimeStamp Class Members

[image]
ActiveReports 13
TimeStamp Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : TimeStamp Class

Glossary Item Box

The following tables list the members exposed by TimeStamp.

Public Constructors

 | Name | Description
Public Constructor | TimeStamp Constructor | Overloaded. Initializes a new instance of the TimeStamp class.
Top

Public Properties

 | Name | Description
Public Property | Password | The user ID to send to the Time Stamping Authority (TSA) server.
Public Property | ServerUrl | Gets or sets the uniform resource identifier for the Time Stamping Authority (TSA) server providing the timestamp.
Public Property | UserName | The user ID to send to the Time Stamping Authority (TSA) server.
Top

See Also

Reference

TimeStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


TimeStamp Constructor

[image]
ActiveReports 13
TimeStamp Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : TimeStamp Constructor

Glossary Item Box

Initializes a new instance of the TimeStamp class.

Overload List

Overload | Description
TimeStamp Constructor(String,String,String) | Initializes a new instance of the TimeStamp class using the specified server string, user name, and password.
TimeStamp Constructor(Uri,String,String) | Initializes a new instance of the TimeStamp class using the specified server URI, user name, and password.

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeStamp Class
TimeStamp Members


TimeStamp Constructor(String,String,String)

[image]
ActiveReports 13
TimeStamp Constructor(String,String,String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class > TimeStamp Constructor : TimeStamp Constructor(String,String,String)

server
TSA server address
user
User ID for TSA server
password
Password for TSA server

Glossary Item Box

Initializes a new instance of the TimeStamp class using the specified server string, user name, and password.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal server As String, _
   ByVal user As String, _
   ByVal password As String _
)
C#
public TimeStamp(
   string server,
   string user,
   string password
)

Parameters

server
TSA server address
user
User ID for TSA server
password
Password for TSA server

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeStamp Class
TimeStamp Members
Overload List


TimeStamp Constructor(Uri,String,String)

[image]
ActiveReports 13
TimeStamp Constructor(Uri,String,String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class > TimeStamp Constructor : TimeStamp Constructor(Uri,String,String)

serverUrl
TSA server URL
user
User ID for TSA server
password
Password for TSA server

Glossary Item Box

Initializes a new instance of the TimeStamp class using the specified server URI, user name, and password.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal serverUrl As Uri, _
   ByVal user As String, _
   ByVal password As String _
)
C#
public TimeStamp(
   Uri serverUrl,
   string user,
   string password
)

Parameters

serverUrl
TSA server URL
user
User ID for TSA server
password
Password for TSA server

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeStamp Class
TimeStamp Members
Overload List


TimeStamp Class Properties

[image]
ActiveReports 13
TimeStamp Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : TimeStamp Class

Glossary Item Box

For a list of all members of this type, see TimeStamp members.

Public Properties

 | Name | Description
Public Property | Password | The user ID to send to the Time Stamping Authority (TSA) server.
Public Property | ServerUrl | Gets or sets the uniform resource identifier for the Time Stamping Authority (TSA) server providing the timestamp.
Public Property | UserName | The user ID to send to the Time Stamping Authority (TSA) server.
Top

See Also

Reference

TimeStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Password Property

[image]
ActiveReports 13
Password Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : Password Property

Glossary Item Box

The user ID to send to the Time Stamping Authority (TSA) server.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeStamp Class
TimeStamp Members


ServerUrl Property

[image]
ActiveReports 13
ServerUrl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : ServerUrl Property

Glossary Item Box

Gets or sets the uniform resource identifier for the Time Stamping Authority (TSA) server providing the timestamp.

Syntax

Visual Basic (Declaration)
Public Property ServerUrl As Uri
C#
public Uri ServerUrl {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeStamp Class
TimeStamp Members


UserName Property

[image]
ActiveReports 13
UserName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : UserName Property

Glossary Item Box

The user ID to send to the Time Stamping Authority (TSA) server.

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName {get; set;}

Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeStamp Class
TimeStamp Members


Alignment Enumeration

[image]
ActiveReports 13
Alignment Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : Alignment Enumeration

Glossary Item Box

Sets the type of alignment to use for text or images.

Syntax

Visual Basic (Declaration)
Public Enum Alignment
   Inherits System.Enum
C#
public enum Alignment : System.Enum

Members

Member | Description
Center | Align in the center of the stamp bounds.
Left | Align to the left edge of the stamp bounds.
Right | Align to the right edge of the stamp bounds.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


CertificationLevel Enumeration

[image]
ActiveReports 13
CertificationLevel Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : CertificationLevel Enumeration

Glossary Item Box

Enumerates possible certification types

Syntax

Visual Basic (Declaration)
Public Enum CertificationLevel
   Inherits System.Enum
C#
public enum CertificationLevel : System.Enum

Members

Member | Description
FormFilling | Certified, permit changes to form field and signing
FormFillingAnnotations | Certified, permit changes to form field, annotation and signing
NoChangesAllowed | Certified, but no changes permitted
NotCertified | Document is not certified

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.CertificationLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


VisibilityType Enumeration

[image]
ActiveReports 13
VisibilityType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : VisibilityType Enumeration

Glossary Item Box

Sets a value indicating whether and how to display certification on the document.

Syntax

Visual Basic (Declaration)
Public Enum VisibilityType
   Inherits System.Enum
C#
public enum VisibilityType : System.Enum

Members

Member | Description
Image | Show only image on signature
ImageText | Show both, image and text
Invisible | Invisible signature, it means no data will be shown on page, but it will be accessible via "Signatures" tab in reader
Text | Show only text on signature

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


GrapeCity.ActiveReports.Export.Word Namespace

GrapeCity.ActiveReports.Export.Word Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly : GrapeCity.ActiveReports.Export.Word Namespace

Glossary Item Box

Classes

 | Class | Description
Class | WordPageSettings | Encapsulates the information necessary to provide word document print settings.
Class | WordSecurity | Provides the word security settings.

Enumerations

 | Enumeration | Description
Enumeration | WordPageSettings.PageOrientation | Valid paper orientation values.
Enumeration | WordPageSettings.PaperSizes | Valid paper size values.

See Also

Reference

GrapeCity.ActiveReports.Export.Word Assembly


WordPageSettings Class

[image]
ActiveReports 13
WordPageSettings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordPageSettings Class

Glossary Item Box

Encapsulates the information necessary to provide word document print settings.

Object Model

WordPageSettings Class

Syntax

Visual Basic (Declaration)
Public Class WordPageSettings
C#
public class WordPageSettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.WordPageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordPageSettings Members
GrapeCity.ActiveReports.Export.Word Namespace


WordPageSettings Class Members

[image]
ActiveReports 13
WordPageSettings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordPageSettings Class

Glossary Item Box

The following tables list the members exposed by WordPageSettings.

Public Properties

 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Word doc.
Public Property | PaperSize | Gets or sets the print paper size of Word doc.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

WordPageSettings Class
GrapeCity.ActiveReports.Export.Word Namespace


WordPageSettings Class Methods

[image]
ActiveReports 13
WordPageSettings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordPageSettings Class

Glossary Item Box

For a list of all members of this type, see WordPageSettings members.

Public Methods

 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

WordPageSettings Class
GrapeCity.ActiveReports.Export.Word Namespace


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace > WordPageSettings Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordPageSettings Class
WordPageSettings Members


WordPageSettings Class Properties

[image]
ActiveReports 13
WordPageSettings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordPageSettings Class

Glossary Item Box

For a list of all members of this type, see WordPageSettings members.

Public Properties

 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Word doc.
Public Property | PaperSize | Gets or sets the print paper size of Word doc.
Top

See Also

Reference

WordPageSettings Class
GrapeCity.ActiveReports.Export.Word Namespace


Orientation Property

[image]
ActiveReports 13
Orientation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace > WordPageSettings Class : Orientation Property

Glossary Item Box

Gets or sets the print orientation of Word doc.

Syntax

Visual Basic (Declaration)
Public Property Orientation As WordPageSettings.PageOrientation
C#
public WordPageSettings.PageOrientation Orientation {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordPageSettings Class
WordPageSettings Members


PaperSize Property

[image]
ActiveReports 13
PaperSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace > WordPageSettings Class : PaperSize Property

Glossary Item Box

Gets or sets the print paper size of Word doc.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As WordPageSettings.PaperSizes
C#
public WordPageSettings.PaperSizes PaperSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordPageSettings Class
WordPageSettings Members


WordSecurity Class

[image]
ActiveReports 13
WordSecurity Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordSecurity Class

Glossary Item Box

Provides the word security settings.

Object Model

WordSecurity Class

Syntax

Visual Basic (Declaration)
Public Class WordSecurity
C#
public class WordSecurity

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.WordSecurity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordSecurity Members
GrapeCity.ActiveReports.Export.Word Namespace


WordSecurity Class Members

[image]
ActiveReports 13
WordSecurity Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordSecurity Class

Glossary Item Box

The following tables list the members exposed by WordSecurity.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Word document.
Public Property | ReadOnlyRecommended | When set to true, Word will recommend opening the document in read-only mode.
Public Property | WritePassword | Gets or sets the password to be required to edit the document.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

WordSecurity Class
GrapeCity.ActiveReports.Export.Word Namespace


WordSecurity Class Methods

[image]
ActiveReports 13
WordSecurity Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordSecurity Class

Glossary Item Box

For a list of all members of this type, see WordSecurity members.

Public Methods

 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

WordSecurity Class
GrapeCity.ActiveReports.Export.Word Namespace


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace > WordSecurity Class : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordSecurity Class
WordSecurity Members


WordSecurity Class Properties

[image]
ActiveReports 13
WordSecurity Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordSecurity Class

Glossary Item Box

For a list of all members of this type, see WordSecurity members.

Public Properties

 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Word document.
Public Property | ReadOnlyRecommended | When set to true, Word will recommend opening the document in read-only mode.
Public Property | WritePassword | Gets or sets the password to be required to edit the document.
Top

See Also

Reference

WordSecurity Class
GrapeCity.ActiveReports.Export.Word Namespace


Password Property

[image]
ActiveReports 13
Password Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace > WordSecurity Class : Password Property

Glossary Item Box

Gets or sets the password which can be entered to permit to open Word document.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordSecurity Class
WordSecurity Members


ReadOnlyRecommended Property

[image]
ActiveReports 13
ReadOnlyRecommended Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace > WordSecurity Class : ReadOnlyRecommended Property

Glossary Item Box

When set to true, Word will recommend opening the document in read-only mode.

Syntax

Visual Basic (Declaration)
Public Property ReadOnlyRecommended As Boolean
C#
public bool ReadOnlyRecommended {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordSecurity Class
WordSecurity Members


WritePassword Property

[image]
ActiveReports 13
WritePassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace > WordSecurity Class : WritePassword Property

Glossary Item Box

Gets or sets the password to be required to edit the document.

Syntax

Visual Basic (Declaration)
Public Property WritePassword As String
C#
public string WritePassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordSecurity Class
WordSecurity Members


WordPageSettings.PageOrientation Enumeration

[image]
ActiveReports 13
WordPageSettings.PageOrientation Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordPageSettings.PageOrientation Enumeration

Glossary Item Box

Valid paper orientation values.

Syntax

Visual Basic (Declaration)
Public Enum WordPageSettings.PageOrientation
   Inherits System.Enum
C#
public enum WordPageSettings.PageOrientation : System.Enum

Members

Member | Description
Default | Default printer orientation.
Landscape | Landscape orientation.
Portrait | Portrait orientation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Word.WordPageSettings.PageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Word Namespace


WordPageSettings.PaperSizes Enumeration

[image]
ActiveReports 13
WordPageSettings.PaperSizes Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word Namespace : WordPageSettings.PaperSizes Enumeration

Glossary Item Box

Valid paper size values.

Syntax

Visual Basic (Declaration)
Public Enum WordPageSettings.PaperSizes
   Inherits System.Enum
C#
public enum WordPageSettings.PaperSizes : System.Enum

Members

Member | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 extra transverse paper (322 mm by 445 mm).
A3Rotated | A3 rotated paper (420 mm by 297 mm).
A3Transverse | A3 transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 extra paper (236 mm by 322 mm). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 plus paper (210 mm by 330 mm).
A4Rotated | A4 rotated paper (297 mm by 210 mm).
A4Small | A4 small paper (210 mm by 297 mm).
A4Transverse | A4 transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 extra paper (174 mm by 235 mm).
A5Rotated | A5 rotated paper (210 mm by 148 mm).
A5Transverse | A5 transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm).
A6Rotated | A6 rotated paper (148 mm by 105 mm).
APlus | SuperA/SuperA/A4 paper (227 mm by 356 mm).
B4 | B4 paper (250 mm by 353 mm).
B4Envelope | B4 envelope (250 mm by 353 mm).
B4JisRotated | JIS B4 rotated paper (364 mm by 257 mm).
B5 | B5 paper (176 mm by 250 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 extra paper (201 mm by 276 mm).
B5JisRotated | JIS B5 rotated paper (257 mm by 182 mm).
B5Transverse | JIS B5 transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6Jis | JIS B6 paper (128 mm by 182 mm).
B6JisRotated | JIS B6 rotated paper (182 mm by 128 mm).
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 229 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Default | The paper size is defined by the user.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German legal fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German standard fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invitation envelope (220 mm by 220 mm).
IsoB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese double postcard (200 mm by 148 mm).
JapaneseDoublePostcardRotated | Japanese rotated double postcard (148 mm by 200 mm).
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope.
JapaneseEnvelopeChouNumber3Rotated | Japanese rotated Chou #3 envelope.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope.
JapaneseEnvelopeChouNumber4Rotated | Japanese rotated Chou #4 envelope.
JapaneseEnvelopeKakuNumber2 | Japanese Kaku #2 envelope.
JapaneseEnvelopeKakuNumber2Rotated | Japanese rotated Kaku #2 envelope.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope.
JapaneseEnvelopeKakuNumber3Rotated | Japanese rotated Kaku #3 envelope.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope.
JapaneseEnvelopeYouNumber4Rotated | Japanese You #4 rotated envelope.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Japanese rotated postcard (148 mm by 100 mm).
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter extra transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter plus paper (8.5 in. by 12.69 in.).
LetterRotated | Letter rotated paper (11 in. by 8.5 in.).
LetterSmall | Letter small paper (8.5 in. by 11 in.).
LetterTransverse | Letter transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.)
Number11Envelope | #11 envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
Prc16K | People's Republic of China 16K paper (146 mm by 215 mm).
Prc16KRotated | People's Republic of China 16K rotated paper (146 mm by 215 mm).
Prc32K | People's Republic of China 32K paper (97 mm by 151 mm).
Prc32KBig | People's Republic of China 32K big paper (97 mm by 151 mm).
Prc32KBigRotated | People's Republic of China 32K big rotated paper (97 mm by 151 mm).
Prc32KRotated | People's Republic of China 32K rotated paper (97 mm by 151 mm).
PrcEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm).
PrcEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm).
PrcEnvelopeNumber10Rotated | People's Republic of China #10 rotated envelope (458 mm by 324 mm).
PrcEnvelopeNumber1Rotated | People's Republic of China #1 rotated envelope (165 mm by 102 mm).
PrcEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm).
PrcEnvelopeNumber2Rotated | People's Republic of China #2 rotated envelope (176 mm by 102 mm).
PrcEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm).
PrcEnvelopeNumber3Rotated | People's Republic of China #3 rotated envelope (176 mm by 125 mm).
PrcEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm).
PrcEnvelopeNumber4Rotated | People's Republic of China #4 rotated envelope (208 mm by 110 mm).
PrcEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm).
PrcEnvelopeNumber5Rotated | People's Republic of China Envelope #5 rotated envelope (220 mm by 110 mm).
PrcEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm).
PrcEnvelopeNumber6Rotated | People's Republic of China #6 rotated envelope (230 mm by 120 mm).
PrcEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm).
PrcEnvelopeNumber7Rotated | People's Republic of China #7 rotated envelope (230 mm by 160 mm).
PrcEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm).
PrcEnvelopeNumber8Rotated | People's Republic of China #8 rotated envelope (309 mm by 120 mm).
PrcEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm).
PrcEnvelopeNumber9Rotated | People's Republic of China #9 rotated envelope (324 mm by 229 mm).
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | Standard paper (10 in. by 11 in.).
Standard10x14 | Standard paper (10 in. by 14 in.).
Standard11x17 | Standard paper (11 in. by 17 in.).
Standard12x11 | Standard paper (12 in. by 11 in.).
Standard15x11 | Standard paper (15 in. by 11 in.).
Standard9x11 | Standard paper (9 in. by 11 in.).
Statement | Statement paper (5.5 in. by 8.5 in.).
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US standard fanfold (14.875 in. by 11 in.).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Word.WordPageSettings.PaperSizes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Word Namespace


GrapeCity.ActiveReports.Export.Word.Page Namespace

GrapeCity.ActiveReports.Export.Word.Page Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly : GrapeCity.ActiveReports.Export.Word.Page Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Word.Page namespace includes information related to Settings and Word Rendering Extension.

Classes

 | Class | Description
Class | Settings | GrapeCity.ActiveReports.Extensibility.Rendering.ISettings implementation for Word Rendering Extension.
Class | WordRenderingExtension | Implementes GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to Word Html document.

Enumerations

 | Enumeration | Description
Enumeration | DocumentCompatibilityVersion | Specifies whe word document compatibility version
Enumeration | FileFormat | Specifies the output format of Word document.

See Also

Reference

GrapeCity.ActiveReports.Export.Word Assembly


Settings Class

[image]
ActiveReports 13
Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : Settings Class

Glossary Item Box

GrapeCity.ActiveReports.Extensibility.Rendering.ISettings implementation for Word Rendering Extension.

Object Model

Settings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.Page.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Word.Page Namespace


Settings Class Members

[image]
ActiveReports 13
Settings Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : Settings Class

Glossary Item Box

The following tables list the members exposed by Settings.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the name of the author of document.
Public Property | BaseUrl | Gets or sets the base Url used for hyperlinks on the document.
Public Property | CompanyName | Gets or sets the company name used for exported file document properties.
Public Property | DocumentCompatibilityVersion | Gets or sets the word version which should open the exported document.
Public Property | DpiX | Adjust the horizontal resolution of custom report items. The default value is 96.
Public Property | DpiY | Adjust the vertical resolution of custom report items. The default value is 96.
Public Property | FileFormat | Indicates whether to use WordHtml or OpenXml format for the output file. WordHtml is default.
Public Property | Generator | Gets or sets identity of the generator of the document.
Public Property | PageHeight | Gets or sets the height of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.PageReportModel.Length class("8.5in", "11cm", etc.).
Public Property | PageSettings | Gets or sets the settings of page size and orientation.
Public Property | PageWidth | Gets or sets the width of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.PageReportModel.Length class("8.5in", "11cm", etc.).
Public Property | SecuritySettings | Gets or sets the settings of document encryption and security.
Public Property | Title | Gets or sets the title of the document.
Public Property | TOCAutoUpdate | If true in the document will be inserted macros that automatically updates ToC control on opening.
Public Property | UseMhtOutput | Gets or sets the value indicates should Mht output be used for resulted word document or not.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Word.Page Namespace


Settings Class Properties

[image]
ActiveReports 13
Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the name of the author of document.
Public Property | BaseUrl | Gets or sets the base Url used for hyperlinks on the document.
Public Property | CompanyName | Gets or sets the company name used for exported file document properties.
Public Property | DocumentCompatibilityVersion | Gets or sets the word version which should open the exported document.
Public Property | DpiX | Adjust the horizontal resolution of custom report items. The default value is 96.
Public Property | DpiY | Adjust the vertical resolution of custom report items. The default value is 96.
Public Property | FileFormat | Indicates whether to use WordHtml or OpenXml format for the output file. WordHtml is default.
Public Property | Generator | Gets or sets identity of the generator of the document.
Public Property | PageHeight | Gets or sets the height of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.PageReportModel.Length class("8.5in", "11cm", etc.).
Public Property | PageSettings | Gets or sets the settings of page size and orientation.
Public Property | PageWidth | Gets or sets the width of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.PageReportModel.Length class("8.5in", "11cm", etc.).
Public Property | SecuritySettings | Gets or sets the settings of document encryption and security.
Public Property | Title | Gets or sets the title of the document.
Public Property | TOCAutoUpdate | If true in the document will be inserted macros that automatically updates ToC control on opening.
Public Property | UseMhtOutput | Gets or sets the value indicates should Mht output be used for resulted word document or not.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Word.Page Namespace


Author Property

[image]
ActiveReports 13
Author Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : Author Property

Glossary Item Box

Gets or sets the name of the author of document.

Syntax

Visual Basic (Declaration)
Public Property Author As String
C#
public string Author {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


BaseUrl Property

[image]
ActiveReports 13
BaseUrl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : BaseUrl Property

Glossary Item Box

Gets or sets the base Url used for hyperlinks on the document.

Syntax

Visual Basic (Declaration)
Public Property BaseUrl As String
C#
public string BaseUrl {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : CompanyName Property

Glossary Item Box

Gets or sets the company name used for exported file document properties.

Syntax

Visual Basic (Declaration)
Public Property CompanyName As String
C#
public string CompanyName {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DocumentCompatibilityVersion Property

[image]
ActiveReports 13
DocumentCompatibilityVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : DocumentCompatibilityVersion Property

Glossary Item Box

Gets or sets the word version which should open the exported document.

Syntax

Visual Basic (Declaration)
Public Property DocumentCompatibilityVersion As DocumentCompatibilityVersion
C#
public DocumentCompatibilityVersion DocumentCompatibilityVersion {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DpiX Property

[image]
ActiveReports 13
DpiX Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : DpiX Property

Glossary Item Box

Adjust the horizontal resolution of custom report items. The default value is 96.

Syntax

Visual Basic (Declaration)
Public Property DpiX As Single
C#
public float DpiX {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


DpiY Property

[image]
ActiveReports 13
DpiY Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : DpiY Property

Glossary Item Box

Adjust the vertical resolution of custom report items. The default value is 96.

Syntax

Visual Basic (Declaration)
Public Property DpiY As Single
C#
public float DpiY {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


FileFormat Property

[image]
ActiveReports 13
FileFormat Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : FileFormat Property

Glossary Item Box

Indicates whether to use WordHtml or OpenXml format for the output file. WordHtml is default.

Syntax

Visual Basic (Declaration)
Public Property FileFormat As FileFormat
C#
public FileFormat FileFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Generator Property

[image]
ActiveReports 13
Generator Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : Generator Property

Glossary Item Box

Gets or sets identity of the generator of the document.

Syntax

Visual Basic (Declaration)
Public Property Generator As String
C#
public string Generator {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PageHeight Property

[image]
ActiveReports 13
PageHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : PageHeight Property

Glossary Item Box

Gets or sets the height of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.PageReportModel.Length class("8.5in", "11cm", etc.).

Syntax

Visual Basic (Declaration)
Public Property PageHeight As String
C#
public string PageHeight {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PageSettings Property

[image]
ActiveReports 13
PageSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : PageSettings Property

Glossary Item Box

Gets or sets the settings of page size and orientation.

Syntax

Visual Basic (Declaration)
Public Property PageSettings As WordPageSettings
C#
public WordPageSettings PageSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


PageWidth Property

[image]
ActiveReports 13
PageWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : PageWidth Property

Glossary Item Box

Gets or sets the width of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.PageReportModel.Length class("8.5in", "11cm", etc.).

Syntax

Visual Basic (Declaration)
Public Property PageWidth As String
C#
public string PageWidth {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


SecuritySettings Property

[image]
ActiveReports 13
SecuritySettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : SecuritySettings Property

Glossary Item Box

Gets or sets the settings of document encryption and security.

Syntax

Visual Basic (Declaration)
Public Property SecuritySettings As WordSecurity
C#
public WordSecurity SecuritySettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : Title Property

Glossary Item Box

Gets or sets the title of the document.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


TOCAutoUpdate Property

[image]
ActiveReports 13
TOCAutoUpdate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : TOCAutoUpdate Property

Glossary Item Box

If true in the document will be inserted macros that automatically updates ToC control on opening.

Syntax

Visual Basic (Declaration)
Public Property TOCAutoUpdate As Boolean
C#
public bool TOCAutoUpdate {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


UseMhtOutput Property

[image]
ActiveReports 13
UseMhtOutput Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : UseMhtOutput Property

Glossary Item Box

Gets or sets the value indicates should Mht output be used for resulted word document or not.

Syntax

Visual Basic (Declaration)
Public Property UseMhtOutput As Boolean
C#
public bool UseMhtOutput {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


WordRenderingExtension Class

[image]
ActiveReports 13
WordRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : WordRenderingExtension Class

Glossary Item Box

Implementes GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to Word Html document.

Object Model

WordRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WordRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public sealed class WordRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordRenderingExtension Members
GrapeCity.ActiveReports.Export.Word.Page Namespace


WordRenderingExtension Class Members

[image]
ActiveReports 13
WordRenderingExtension Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : WordRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by WordRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | WordRenderingExtension Constructor | Initializes a new instance of the WordRenderingExtension class.
Top

See Also

Reference

WordRenderingExtension Class
GrapeCity.ActiveReports.Export.Word.Page Namespace


WordRenderingExtension Constructor

[image]
ActiveReports 13
WordRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > WordRenderingExtension Class : WordRenderingExtension Constructor

Glossary Item Box

Initializes a new instance of the WordRenderingExtension class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WordRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WordRenderingExtension Class
WordRenderingExtension Members


DocumentCompatibilityVersion Enumeration

[image]
ActiveReports 13
DocumentCompatibilityVersion Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : DocumentCompatibilityVersion Enumeration

Glossary Item Box

Specifies whe word document compatibility version

Syntax

Visual Basic (Declaration)
Public Enum DocumentCompatibilityVersion
   Inherits System.Enum
C#
public enum DocumentCompatibilityVersion : System.Enum

Members

Member | Description
Word2007 | Word 2007
Word2010 | Word 2010
Word2013 | Word 2013

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Word.Page.DocumentCompatibilityVersion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Word.Page Namespace


FileFormat Enumeration

[image]
ActiveReports 13
FileFormat Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : FileFormat Enumeration

Glossary Item Box

Specifies the output format of Word document.

Syntax

Visual Basic (Declaration)
Public Enum FileFormat
   Inherits System.Enum
C#
public enum FileFormat : System.Enum

Members

Member | Description
HTML | Word html format.
OOXML | Word Open XML format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Word.Page.FileFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Export.Word.Page Namespace


GrapeCity.ActiveReports.Export.Word.Section Namespace

GrapeCity.ActiveReports.Export.Word.Section Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly : GrapeCity.ActiveReports.Export.Word.Section Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Word.Section namespace contains the RTF (Rich Text Format) export classes.

Classes

 | Class | Description
Class | RtfExport | The Rich Text Format (RTF) export component for ActiveReports.
Class | RtfExportException | The error thrown when an RtfExport-specific error occurs.

See Also

Reference

GrapeCity.ActiveReports.Export.Word Assembly


RtfExport Class

[image]
ActiveReports 13
RtfExport Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

Glossary Item Box

The Rich Text Format (RTF) export component for ActiveReports.

Object Model

RtfExport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RtfExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
C#
public sealed class RtfExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Word.Section.RtfExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Members
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExport Class Members

[image]
ActiveReports 13
RtfExport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

Glossary Item Box

The following tables list the members exposed by RtfExport.

Public Constructors

 | Name | Description
Public Constructor | RtfExport Constructor | Initializes a new instance of the RtfExport class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | EnableShapes | Setting this value to true will export the Shapes and Lines to RTF Format. You will require Microsoft Word to view it correctly.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant RTF document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to RTF format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExport Constructor

[image]
ActiveReports 13
RtfExport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : RtfExport Constructor

Glossary Item Box

Initializes a new instance of the RtfExport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RtfExport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


RtfExport Class Methods

[image]
ActiveReports 13
RtfExport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

Glossary Item Box

For a list of all members of this type, see RtfExport members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to RTF format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Export Method

Glossary Item Box

Exports the specified document to RTF format.

Overload List

Overload | Description
Export(PageDocument,String) | Exports the specified document to a Rich Text Format (RTF) file.
Export(PageDocument,String,String) | Exports the specified document to a Rich Text Format (RTF) file.
Export(PageDocument,Stream) | Exports the specified document to the specified stream in Rich Text Format (RTF).
Export(PageDocument,Stream,String) | Exports the specified document to the specified stream in Rich Text Format (RTF).
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String,String) | Exports the specified range of pages of the document to a Rich Text Format (RTF) file.
Export(SectionDocument,String) | Exports the specified document to a Rich Text Format (RTF) file.
Export(SectionDocument,Stream) | Exports the specified document to the specified stream in Rich Text Format (RTF).
Export(SectionDocument,Stream,String) | Exports the specified range of pages of the document to the specified stream in Rich Text Format (RTF).

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, Application.StartupPath + "\\r.rtf");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, Application.StartupPath & "\r.rtf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


Export(PageDocument,String) Method

[image]
ActiveReports 13
Export(PageDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.

Glossary Item Box

Exports the specified document to a Rich Text Format (RTF) file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   PageDocument document,
   string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(PageDocument,String,String) Method

[image]
ActiveReports 13
Export(PageDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,String,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified document to a Rich Text Format (RTF) file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(PageDocument,Stream) Method

[image]
ActiveReports 13
Export(PageDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,Stream) Method

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.

Glossary Item Box

Exports the specified document to the specified stream in Rich Text Format (RTF).

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream _
)
C#
public void Export(
   PageDocument document,
   Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(PageDocument,Stream,String) Method

[image]
ActiveReports 13
Export(PageDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,Stream,String) Method

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified document to the specified stream in Rich Text Format (RTF).

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   Stream stream,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,String,String) Method

[image]
ActiveReports 13
Export(IReport,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,String,String) Method

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath,
   string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,String) Method

[image]
ActiveReports 13
Export(IReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,String) Method

report
IReport instance to Export
filePath
Path to export

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,Stream) Method

[image]
ActiveReports 13
Export(IReport,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,Stream) Method

report
IReport instance to Export
outputStream
The output stream.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,Stream,String) Method

[image]
ActiveReports 13
Export(IReport,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,Stream,String) Method

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream,
   string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,String,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,String,String) Method

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified range of pages of the document to a Rich Text Format (RTF) file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, Application.StartupPath + "\\r.rtf", "1-3");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, Application.StartupPath & "\r.rtf", "1-3")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,String) Method

document
The ActiveReports Document object to export.
filePath
The file name and path to which to save the RTF file.

Glossary Item Box

Exports the specified document to a Rich Text Format (RTF) file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to which to save the RTF file.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, Application.StartupPath + "\\r.rtf");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, Application.StartupPath & "\r.rtf")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,Stream) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,Stream) Method

document
The ActiveReports Document object to export.
outputStream
The System.IO.Stream to which to write the RTF.

Glossary Item Box

Exports the specified document to the specified stream in Rich Text Format (RTF).

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream
)

Parameters

document
The ActiveReports Document object to export.
outputStream
The System.IO.Stream to which to write the RTF.

Example

This code snippet assumes that you have a Windows RichTextBox control on your viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    System.IO.MemoryStream s = new System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, s);
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New Sectionreport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    Dim s As New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, s)
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,Stream,String) Method

document
The ActiveReports Document object to export.
outputStream
The System.IO.Stream to which to write the RTF.
pageRange
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified range of pages of the document to the specified stream in Rich Text Format (RTF).

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream,
   string pageRange
)

Parameters

document
The ActiveReports Document object to export.
outputStream
The System.IO.Stream to which to write the RTF.
pageRange
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.

Example

This code snippet assumes that you have a Windows RichTextBox control on your viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    System.IO.MemoryStream s = new System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, s,"1");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    Dim s As New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, s, "1")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members
Overload List


RtfExport Class Properties

[image]
ActiveReports 13
RtfExport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

Glossary Item Box

For a list of all members of this type, see RtfExport members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | EnableShapes | Setting this value to true will export the Shapes and Lines to RTF Format. You will require Microsoft Word to view it correctly.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant RTF document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


EnableShapes Property

[image]
ActiveReports 13
EnableShapes Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : EnableShapes Property

Glossary Item Box

Setting this value to true will export the Shapes and Lines to RTF Format. You will require Microsoft Word to view it correctly.

Syntax

Visual Basic (Declaration)
Public Property EnableShapes As Boolean
C#
public bool EnableShapes {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Pagination Property

Glossary Item Box

Gets or sets the value, that indicates whether pagination should be used for resultant RTF document or not.

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

See Also

Reference

RtfExport Class
RtfExport Members


RtfExportException Class

[image]
ActiveReports 13
RtfExportException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class

Glossary Item Box

The error thrown when an RtfExport-specific error occurs.

Object Model

RtfExportException Class

Syntax

Visual Basic (Declaration)
Public Class RtfExportException
   Inherits System.ApplicationException
C#
public class RtfExportException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Word.Section.RtfExportException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Members
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Class Members

[image]
ActiveReports 13
RtfExportException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class

Glossary Item Box

The following tables list the members exposed by RtfExportException.

Public Constructors

 | Name | Description
Public Constructor | RtfExportException Constructor | Overloaded. Initializes a new instance of the RtfExportException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

RtfExportException Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Constructor

[image]
ActiveReports 13
RtfExportException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : RtfExportException Constructor

Glossary Item Box

Initializes a new instance of the RtfExportException class.

Overload List

Overload | Description
RtfExportException Constructor(String) | Initializes a new instance of the RtfExportException class with the specified error message.
RtfExportException Constructor(String,Exception) | Initializes a new instance of the RtfExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
RtfExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the RtfExportException class with serialized data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


RtfExportException Constructor(String)

[image]
ActiveReports 13
RtfExportException Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class > RtfExportException Constructor : RtfExportException Constructor(String)

message
A message that describes the error.

Glossary Item Box

Initializes a new instance of the RtfExportException class with the specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public RtfExportException(
   string message
)

Parameters

message
A message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members
Overload List


RtfExportException Constructor(String,Exception)

[image]
ActiveReports 13
RtfExportException Constructor(String,Exception)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class > RtfExportException Constructor : RtfExportException Constructor(String,Exception)

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the RtfExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public RtfExportException(
   string message,
   Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members
Overload List


RtfExportException Constructor(SerializationInfo,StreamingContext)

[image]
ActiveReports 13
RtfExportException Constructor(SerializationInfo,StreamingContext)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class > RtfExportException Constructor : RtfExportException Constructor(SerializationInfo,StreamingContext)

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Glossary Item Box

Initializes a new instance of the RtfExportException class with serialized data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public RtfExportException(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members
Overload List


GrapeCity.ActiveReports.Export.Text.Page Namespace

GrapeCity.ActiveReports.Export.Text.Page Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Text.Page Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Text.Page namespace includes information related to CSV Rendering Extension and JSON Rendering Extension.

Classes

 | Class | Description
Class | CsvRenderingExtension | Provides export of Page and RDL reports to CSV format.
Class | CsvRenderingExtension.Settings | CsvRenderingExtension settings class
Class | JsonRenderingExtension | Provides export of Page and RDL reports to JSON format.
Class | JsonRenderingExtension.Settings | JsonRenderingExtensions settings class.

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


CsvRenderingExtension Class

[image]
ActiveReports 13
CsvRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : CsvRenderingExtension Class

Glossary Item Box

Provides export of Page and RDL reports to CSV format.

Object Model

CsvRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public Class CsvRenderingExtension
   Inherits GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension(Of CsvRenderingExtension.Settings)
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public class CsvRenderingExtension : GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension<CsvRenderingExtension.Settings>, GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension Members
GrapeCity.ActiveReports.Export.Text.Page Namespace


CsvRenderingExtension Class Members

[image]
ActiveReports 13
CsvRenderingExtension Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : CsvRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by CsvRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | CsvRenderingExtension Constructor | Initializes a new instance of the CsvRenderingExtension class.
Top

See Also

Reference

CsvRenderingExtension Class
GrapeCity.ActiveReports.Export.Text.Page Namespace


CsvRenderingExtension Constructor

[image]
ActiveReports 13
CsvRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > CsvRenderingExtension Class : CsvRenderingExtension Constructor

Glossary Item Box

Initializes a new instance of the CsvRenderingExtension class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CsvRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension Class
CsvRenderingExtension Members


CsvRenderingExtension.Settings Class

[image]
ActiveReports 13
CsvRenderingExtension.Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : CsvRenderingExtension.Settings Class

Glossary Item Box

CsvRenderingExtension settings class

Object Model

CsvRenderingExtension.Settings Class

Syntax

Visual Basic (Declaration)
Public Class CsvRenderingExtension.Settings
   Inherits GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension`1.SettingsBase(Of CsvRenderingExtension.Settings)
C#
public class CsvRenderingExtension.Settings : GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension`1.SettingsBase<CsvRenderingExtension.Settings>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension.Settings Members
GrapeCity.ActiveReports.Export.Text.Page Namespace


CsvRenderingExtension.Settings Class Members

[image]
ActiveReports 13
CsvRenderingExtension.Settings Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : CsvRenderingExtension.Settings Class

Glossary Item Box

The following tables list the members exposed by CsvRenderingExtension.Settings.

Public Constructors

 | Name | Description
Public Constructor | CsvRenderingExtension.Settings Constructor | Initializes new Settings instance with default properties values.
Top

Public Properties

 | Name | Description
Public Property | ColumnsDelimiter | The string to be placed between fields in data row.
Public Property | Encoding | The result file encoding.
Public Property | NoHeader | Determines whether CSV Header should be omitted.
Public Property | QuotationSymbol | The quotation symbol.
Public Property | RowsDelimiter | The string to be placed between data rows.
Top

See Also

Reference

CsvRenderingExtension.Settings Class
GrapeCity.ActiveReports.Export.Text.Page Namespace


CsvRenderingExtension.Settings Constructor

[image]
ActiveReports 13
CsvRenderingExtension.Settings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > CsvRenderingExtension.Settings Class : CsvRenderingExtension.Settings Constructor

Glossary Item Box

Initializes new Settings instance with default properties values.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CsvRenderingExtension.Settings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension.Settings Class
CsvRenderingExtension.Settings Members


CsvRenderingExtension.Settings Class Properties

[image]
ActiveReports 13
CsvRenderingExtension.Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : CsvRenderingExtension.Settings Class

Glossary Item Box

For a list of all members of this type, see CsvRenderingExtension.Settings members.

Public Properties

 | Name | Description
Public Property | ColumnsDelimiter | The string to be placed between fields in data row.
Public Property | Encoding | The result file encoding.
Public Property | NoHeader | Determines whether CSV Header should be omitted.
Public Property | QuotationSymbol | The quotation symbol.
Public Property | RowsDelimiter | The string to be placed between data rows.
Top

See Also

Reference

CsvRenderingExtension.Settings Class
GrapeCity.ActiveReports.Export.Text.Page Namespace


ColumnsDelimiter Property

[image]
ActiveReports 13
ColumnsDelimiter Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > CsvRenderingExtension.Settings Class : ColumnsDelimiter Property

Glossary Item Box

The string to be placed between fields in data row.

Syntax

Visual Basic (Declaration)
Public Property ColumnsDelimiter As String
C#
public string ColumnsDelimiter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension.Settings Class
CsvRenderingExtension.Settings Members


Encoding Property

[image]
ActiveReports 13
Encoding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > CsvRenderingExtension.Settings Class : Encoding Property

Glossary Item Box

The result file encoding.

Syntax

Visual Basic (Declaration)
Public Property Encoding As Encoding
C#
public Encoding Encoding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension.Settings Class
CsvRenderingExtension.Settings Members


NoHeader Property

[image]
ActiveReports 13
NoHeader Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > CsvRenderingExtension.Settings Class : NoHeader Property

Glossary Item Box

Determines whether CSV Header should be omitted.

Syntax

Visual Basic (Declaration)
Public Property NoHeader As Boolean
C#
public bool NoHeader {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension.Settings Class
CsvRenderingExtension.Settings Members


QuotationSymbol Property

[image]
ActiveReports 13
QuotationSymbol Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > CsvRenderingExtension.Settings Class : QuotationSymbol Property

Glossary Item Box

The quotation symbol.

Syntax

Visual Basic (Declaration)
Public Property QuotationSymbol As Char
C#
public char QuotationSymbol {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension.Settings Class
CsvRenderingExtension.Settings Members


RowsDelimiter Property

[image]
ActiveReports 13
RowsDelimiter Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > CsvRenderingExtension.Settings Class : RowsDelimiter Property

Glossary Item Box

The string to be placed between data rows.

Syntax

Visual Basic (Declaration)
Public Property RowsDelimiter As String
C#
public string RowsDelimiter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CsvRenderingExtension.Settings Class
CsvRenderingExtension.Settings Members


JsonRenderingExtension Class

[image]
ActiveReports 13
JsonRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : JsonRenderingExtension Class

Glossary Item Box

Provides export of Page and RDL reports to JSON format.

Object Model

JsonRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public Class JsonRenderingExtension
   Inherits GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension(Of JsonRenderingExtension.Settings)
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public class JsonRenderingExtension : GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension<JsonRenderingExtension.Settings>, GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonRenderingExtension Members
GrapeCity.ActiveReports.Export.Text.Page Namespace


JsonRenderingExtension Class Members

[image]
ActiveReports 13
JsonRenderingExtension Class Members
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : JsonRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by JsonRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | JsonRenderingExtension Constructor | Initializes a new instance of the JsonRenderingExtension class.
Top

See Also

Reference

JsonRenderingExtension Class
GrapeCity.ActiveReports.Export.Text.Page Namespace


JsonRenderingExtension Constructor

[image]
ActiveReports 13
JsonRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > JsonRenderingExtension Class : JsonRenderingExtension Constructor

Glossary Item Box

Initializes a new instance of the JsonRenderingExtension class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public JsonRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonRenderingExtension Class
JsonRenderingExtension Members


JsonRenderingExtension.Settings Class

[image]
ActiveReports 13
JsonRenderingExtension.Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : JsonRenderingExtension.Settings Class

Glossary Item Box

JsonRenderingExtensions settings class.

Object Model

JsonRenderingExtension.Settings Class

Syntax

Visual Basic (Declaration)
Public Class JsonRenderingExtension.Settings
   Inherits GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension`1.SettingsBase(Of JsonRenderingExtension.Settings)
C#
public class JsonRenderingExtension.Settings : GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension`1.SettingsBase<JsonRenderingExtension.Settings>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonRenderingExtension.Settings Members
GrapeCity.ActiveReports.Export.Text.Page Namespace


JsonRenderingExtension.Settings Class Members

[image]
ActiveReports 13
JsonRenderingExtension.Settings Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : JsonRenderingExtension.Settings Class

Glossary Item Box

The following tables list the members exposed by JsonRenderingExtension.Settings.

Public Constructors

 | Name | Description
Public Constructor | JsonRenderingExtension.Settings Constructor | Initializes new Settings instance with default properties values.
Top

Public Properties

 | Name | Description
Public Property | Formatted | Specifies whether to format the output json text to be more readable.
Public Property | QuotePropertyNames | Specifies whether property names should be enclosed in quotation marks.
Top

See Also

Reference

JsonRenderingExtension.Settings Class
GrapeCity.ActiveReports.Export.Text.Page Namespace


JsonRenderingExtension.Settings Constructor

[image]
ActiveReports 13
JsonRenderingExtension.Settings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > JsonRenderingExtension.Settings Class : JsonRenderingExtension.Settings Constructor

Glossary Item Box

Initializes new Settings instance with default properties values.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public JsonRenderingExtension.Settings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonRenderingExtension.Settings Class
JsonRenderingExtension.Settings Members


JsonRenderingExtension.Settings Class Properties

[image]
ActiveReports 13
JsonRenderingExtension.Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace : JsonRenderingExtension.Settings Class

Glossary Item Box

For a list of all members of this type, see JsonRenderingExtension.Settings members.

Public Properties

 | Name | Description
Public Property | Formatted | Specifies whether to format the output json text to be more readable.
Public Property | QuotePropertyNames | Specifies whether property names should be enclosed in quotation marks.
Top

See Also

Reference

JsonRenderingExtension.Settings Class
GrapeCity.ActiveReports.Export.Text.Page Namespace


Formatted Property

[image]
ActiveReports 13
Formatted Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > JsonRenderingExtension.Settings Class : Formatted Property

Glossary Item Box

Specifies whether to format the output json text to be more readable.

Syntax

Visual Basic (Declaration)
Public Property Formatted As Boolean
C#
public bool Formatted {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonRenderingExtension.Settings Class
JsonRenderingExtension.Settings Members


QuotePropertyNames Property

[image]
ActiveReports 13
QuotePropertyNames Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Text.Page Namespace > JsonRenderingExtension.Settings Class : QuotePropertyNames Property

Glossary Item Box

Specifies whether property names should be enclosed in quotation marks.

Syntax

Visual Basic (Declaration)
Public Property QuotePropertyNames As Boolean
C#
public bool QuotePropertyNames {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonRenderingExtension.Settings Class
JsonRenderingExtension.Settings Members


GrapeCity.ActiveReports.Export.Xml.DDR.AssemblyResources Namespace

GrapeCity.ActiveReports.Export.Xml.DDR.AssemblyResources Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Xml.DDR.AssemblyResources Namespace

Glossary Item Box

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


GrapeCity.ActiveReports.Export.Xml.Page Namespace

GrapeCity.ActiveReports.Export.Xml.Page Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Xml.Page Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Xml.Page namespace includes information related to Settings and XML Rendering Extension.

Classes

 | Class | Description
Class | Settings | Specifies the available setting names used with the XmlRenderingExtension.
Class | XmlRenderingExtension | Implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to XML file.

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


Settings Class

[image]
ActiveReports 13
Settings Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class

Glossary Item Box

Specifies the available setting names used with the XmlRenderingExtension.

Object Model

Settings Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Xml.Page.Settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Xml.Page Namespace


Settings Class Members

[image]
ActiveReports 13
Settings Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class

Glossary Item Box

The following tables list the members exposed by Settings.

Public Constructors

 | Name | Description
Public Constructor | Settings Constructor | Initializes a new instance of Settings class.
Top

Public Properties

 | Name | Description
Public Property | Encoding | Returns the value of the current Encoding setting.
Public Property | XslStylesheet | Gets or sets the path of the Xsl Stylesheet used during the rendering process.
Top

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of XmlRenderingExtension.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


Settings Constructor

[image]
ActiveReports 13
Settings Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : Settings Constructor

Glossary Item Box

Initializes a new instance of Settings class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Settings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Class Methods

[image]
ActiveReports 13
Settings Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Methods

 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of XmlRenderingExtension.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


ApplySettings Method

[image]
ActiveReports 13
ApplySettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : ApplySettings Method

settings
A System.Collections.Specialized.NameValueCollection containing new settings.

Glossary Item Box

Applies any settings passed in the NameValueCollection settings parameters.

Syntax

Visual Basic (Declaration)
Public Sub ApplySettings( _
   ByVal settings As NameValueCollection _
)
C#
public void ApplySettings(
   NameValueCollection settings
)

Parameters

settings
A System.Collections.Specialized.NameValueCollection containing new settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


GetSettings Method

[image]
ActiveReports 13
GetSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : GetSettings Method

Glossary Item Box

Returns settings of XmlRenderingExtension.

Syntax

Visual Basic (Declaration)
Public Function GetSettings() As NameValueCollection
C#
public NameValueCollection GetSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


Settings Class Properties

[image]
ActiveReports 13
Settings Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class

Glossary Item Box

For a list of all members of this type, see Settings members.

Public Properties

 | Name | Description
Public Property | Encoding | Returns the value of the current Encoding setting.
Public Property | XslStylesheet | Gets or sets the path of the Xsl Stylesheet used during the rendering process.
Top

See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


Encoding Property

[image]
ActiveReports 13
Encoding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : Encoding Property

Glossary Item Box

Returns the value of the current Encoding setting.

Syntax

Visual Basic (Declaration)
Public Property Encoding As String
C#
public string Encoding {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


XslStylesheet Property

[image]
ActiveReports 13
XslStylesheet Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : XslStylesheet Property

Glossary Item Box

Gets or sets the path of the Xsl Stylesheet used during the rendering process.

Syntax

Visual Basic (Declaration)
Public Property XslStylesheet As String
C#
public string XslStylesheet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Settings Class
Settings Members


XmlRenderingExtension Class

[image]
ActiveReports 13
XmlRenderingExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : XmlRenderingExtension Class

Glossary Item Box

Implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to XML file.

Object Model

XmlRenderingExtension Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
C#
public sealed class XmlRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlRenderingExtension Members
GrapeCity.ActiveReports.Export.Xml.Page Namespace


XmlRenderingExtension Class Members

[image]
ActiveReports 13
XmlRenderingExtension Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : XmlRenderingExtension Class

Glossary Item Box

The following tables list the members exposed by XmlRenderingExtension.

Public Constructors

 | Name | Description
Public Constructor | XmlRenderingExtension Constructor | Initializes a new instance of XmlRenderingExtension class.
Top

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Gets supported settings of XmlRenderingExtension.
Top

See Also

Reference

XmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


XmlRenderingExtension Constructor

[image]
ActiveReports 13
XmlRenderingExtension Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > XmlRenderingExtension Class : XmlRenderingExtension Constructor

Glossary Item Box

Initializes a new instance of XmlRenderingExtension class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public XmlRenderingExtension()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlRenderingExtension Class
XmlRenderingExtension Members


XmlRenderingExtension Class Methods

[image]
ActiveReports 13
XmlRenderingExtension Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : XmlRenderingExtension Class

Glossary Item Box

For a list of all members of this type, see XmlRenderingExtension members.

Public Methods

 | Name | Description
Public Method | GetSupportedSettings | Gets supported settings of XmlRenderingExtension.
Top

See Also

Reference

XmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


GetSupportedSettings() Method

[image]
ActiveReports 13
GetSupportedSettings() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > XmlRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method

Glossary Item Box

Gets supported settings of XmlRenderingExtension.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSupportedSettings() As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.ISettings GetSupportedSettings()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlRenderingExtension Class
XmlRenderingExtension Members
Overload List


GrapeCity.ActiveReports.Export.Xml.Section Namespace

GrapeCity.ActiveReports.Export.Xml.Section Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Xml.Section Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Export.Xml.Section namespace contains the Text export classes.

Classes

 | Class | Description
Class | TextExport | Allows ActiveReports documents to be exported to plain text.
Class | TextExportException | The exception thrown when a TextExport-specific error occurs.

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


TextExport Class

[image]
ActiveReports 13
TextExport Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

Glossary Item Box

Allows ActiveReports documents to be exported to plain text.

Object Model

TextExport Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TextExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
C#
public sealed class TextExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx

Remarks

The default character encoding used for the TextExport is ASCII. If your reports may contain internationalized characters then consider using the Encoding property to specify the System.Text.UTF8Encoding or System.Text.UnicodeEncoding instead. The current Encoding’s preamble is written out according to the rules of System.IO.StreamWriter.

Example

This code sample assumes that you have a RichTextBox on the viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = new System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Xml.Section.TextExport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Members
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExport Class Members

[image]
ActiveReports 13
TextExport Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

Glossary Item Box

The following tables list the members exposed by TextExport.

Public Constructors

 | Name | Description
Public Constructor | TextExport Constructor | Initializes a new instance of the TextExport class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Gets or sets the character encoding used for the exported text.
Public Property | PageDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a page.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant text document or not.
Public Property | QuotationSymbol | Gets or sets the quotation symbol.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SuppressEmptyLines | Gets or sets a value which determines whether empty lines will be inserted for layout purposes.
Public Property | TextDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a text field.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to text format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExport Constructor

[image]
ActiveReports 13
TextExport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : TextExport Constructor

Glossary Item Box

Initializes a new instance of the TextExport class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TextExport()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


TextExport Class Methods

[image]
ActiveReports 13
TextExport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

Glossary Item Box

For a list of all members of this type, see TextExport members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Export | Overloaded. Exports the specified document to text format.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


Export Method

[image]
ActiveReports 13
Export Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Export Method

Glossary Item Box

Exports the specified document to text format.

Overload List

Overload | Description
Export(PageDocument,String) | Exports the specified document to a text format file.
Export(PageDocument,String,String) | Exports the specified document to a text format file.
Export(PageDocument,Stream) | Exports the specified document to the specified stream in Rich Text Format.
Export(PageDocument,Stream,String) | Exports the specified document to the specified stream in text format.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String,String) | Exports the specified range of pages in the document to a text file.
Export(SectionDocument,String) | Exports the specified document to a text file.
Export(SectionDocument,Stream) | Exports the specified document to a text stream.
Export(SectionDocument,Stream,String) | Exports the specified range of pages in the document to a text stream.

Example

This code sample assumes that you have a RichTextBox on the viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


Export(PageDocument,String) Method

[image]
ActiveReports 13
Export(PageDocument,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.

Glossary Item Box

Exports the specified document to a text format file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   PageDocument document,
   string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(PageDocument,String,String) Method

[image]
ActiveReports 13
Export(PageDocument,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,String,String) Method

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified document to a text format file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(PageDocument,Stream) Method

[image]
ActiveReports 13
Export(PageDocument,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,Stream) Method

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the text to.

Glossary Item Box

Exports the specified document to the specified stream in Rich Text Format.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream _
)
C#
public void Export(
   PageDocument document,
   Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the text to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(PageDocument,Stream,String) Method

[image]
ActiveReports 13
Export(PageDocument,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,Stream,String) Method

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the text to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified document to the specified stream in text format.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   PageDocument document,
   Stream stream,
   string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the text to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,String,String) Method

[image]
ActiveReports 13
Export(IReport,String,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,String,String) Method

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath,
   string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,String) Method

[image]
ActiveReports 13
Export(IReport,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,String) Method

report
IReport instance to Export
filePath
Path to export

Glossary Item Box

Exports the specified IReport to file

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal filePath As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,Stream) Method

[image]
ActiveReports 13
Export(IReport,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,Stream) Method

report
IReport instance to Export
outputStream
The output stream.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,Stream,String) Method

[image]
ActiveReports 13
Export(IReport,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,Stream,String) Method

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified IReport to stream

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal report As GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport report,
   Stream outputStream,
   string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,String,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,String,String) Method

document
The ActiveReports object to export.
filePath
The file name and path to which to save the text.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Glossary Item Box

Exports the specified range of pages in the document to a text file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath,
   string pageRange
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the text.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New  SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, Application.StartupPath & "\\t.txt", "1-3");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, Application.StartupPath & "\t.txt", "1-3")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,String) Method

[image]
ActiveReports 13
Export(SectionDocument,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,String) Method

document
The ActiveReports object to export.
filePath
The file name and path to which to save the text.

Glossary Item Box

Exports the specified document to a text file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As String _
)
C#
public void Export(
   SectionDocument document,
   string filePath
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the text.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
     SectionReport1 rpt = New  SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, Application.StartupPath & "\\t.txt");
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, Application.StartupPath & "\t.txt")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,Stream) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,Stream) Method

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.

Glossary Item Box

Exports the specified document to a text stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.

Example

C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New  SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s);
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s)
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,Stream,String) Method

[image]
ActiveReports 13
Export(SectionDocument,Stream,String) Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,Stream,String) Method

document
The ActiveReports Document object to export.
outputStream
The Stream to write the text to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified range of pages in the document to a text stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   SectionDocument document,
   Stream outputStream,
   string pageRange
)

Parameters

document
The ActiveReports Document object to export.
outputStream
The Stream to write the text to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Example

This code sample assumes that you have a RichTextBox on the viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members
Overload List


TextExport Class Properties

[image]
ActiveReports 13
TextExport Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

Glossary Item Box

For a list of all members of this type, see TextExport members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Gets or sets the character encoding used for the exported text.
Public Property | PageDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a page.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant text document or not.
Public Property | QuotationSymbol | Gets or sets the quotation symbol.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SuppressEmptyLines | Gets or sets a value which determines whether empty lines will be inserted for layout purposes.
Public Property | TextDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a text field.
Top

See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


Encoding Property

[image]
ActiveReports 13
Encoding Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Encoding Property

Glossary Item Box

Gets or sets the character encoding used for the exported text.

Syntax

Visual Basic (Declaration)
Public Property Encoding As Encoding
C#
public Encoding Encoding {get; set;}

Property Value

System.Text.Encoding enumeration. The default value is System.Text.Encoding.ASCII

Example

This code sample assumes that you have a RichTextBox on the viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
VB.NET Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


PageDelimiter Property

[image]
ActiveReports 13
PageDelimiter Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : PageDelimiter Property

Glossary Item Box

Gets or sets the character or sequence of characters that marks the beginning or end of a page.

Syntax

Visual Basic (Declaration)
Public Property PageDelimiter As String
C#
public string PageDelimiter {get; set;}

Property Value

String. The default value is an empty string.

Example

This code sample assumes that you have a RichTextBox on the viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


Pagination Property

[image]
ActiveReports 13
Pagination Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Pagination Property

Glossary Item Box

Gets or sets the value, that indicates whether pagination should be used for resultant text document or not.

Syntax

Visual Basic (Declaration)
Public Property Pagination As Boolean
C#
public bool Pagination {get; set;}

Requirements

See Also

Reference

TextExport Class
TextExport Members


QuotationSymbol Property

[image]
ActiveReports 13
QuotationSymbol Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : QuotationSymbol Property

Glossary Item Box

Gets or sets the quotation symbol.

Syntax

Visual Basic (Declaration)
Public Property QuotationSymbol As Char
C#
public char QuotationSymbol {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


SuppressEmptyLines Property

[image]
ActiveReports 13
SuppressEmptyLines Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : SuppressEmptyLines Property

Glossary Item Box

Gets or sets a value which determines whether empty lines will be inserted for layout purposes.

Syntax

Visual Basic (Declaration)
Public Property SuppressEmptyLines As Boolean
C#
public bool SuppressEmptyLines {get; set;}

Property Value

Boolean. The default value is True.

Example

This code sample assumes that you have a RichTextBox on the viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


TextDelimiter Property

[image]
ActiveReports 13
TextDelimiter Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : TextDelimiter Property

Glossary Item Box

Gets or sets the character or sequence of characters that marks the beginning or end of a text field.

Syntax

Visual Basic (Declaration)
Public Property TextDelimiter As String
C#
public string TextDelimiter {get; set;}

Property Value

String. The default value is a comma (,).

Example

This code sample assumes that you have a RichTextBox on the viewer's form.
C# Copy Code
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
Visual Basic Copy Code
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


TextExportException Class

[image]
ActiveReports 13
TextExportException Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

Glossary Item Box

The exception thrown when a TextExport-specific error occurs.

Object Model

TextExportException Class

Syntax

Visual Basic (Declaration)
Public Class TextExportException
   Inherits System.ApplicationException
C#
public class TextExportException : System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Xml.Section.TextExportException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Members
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Class Members

[image]
ActiveReports 13
TextExportException Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

Glossary Item Box

The following tables list the members exposed by TextExportException.

Public Constructors

 | Name | Description
Public Constructor | TextExportException Constructor | Overloaded. Initializes a new instance of the TextExportException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TextExportException Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Constructor

[image]
ActiveReports 13
TextExportException Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : TextExportException Constructor

Glossary Item Box

Initializes a new instance of the TextExportException class.

Overload List

Overload | Description
TextExportException Constructor(String) | Initializes a new instance of the TextExportException class with the specified error message.
TextExportException Constructor(String,Exception) | Initializes a new instance of the TextExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
TextExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the TextExportException class with serialized data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


TextExportException Constructor(String)

[image]
ActiveReports 13
TextExportException Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class > TextExportException Constructor : TextExportException Constructor(String)

message
A message that describes the error.

Glossary Item Box

Initializes a new instance of the TextExportException class with the specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public TextExportException(
   string message
)

Parameters

message
A message that describes the error.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members
Overload List


TextExportException Constructor(String,Exception)

[image]
ActiveReports 13
TextExportException Constructor(String,Exception)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class > TextExportException Constructor : TextExportException Constructor(String,Exception)

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

Initializes a new instance of the TextExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
C#
public TextExportException(
   string message,
   Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members
Overload List


TextExportException Constructor(SerializationInfo,StreamingContext)

[image]
ActiveReports 13
TextExportException Constructor(SerializationInfo,StreamingContext)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class > TextExportException Constructor : TextExportException Constructor(SerializationInfo,StreamingContext)

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Glossary Item Box

Initializes a new instance of the TextExportException class with serialized data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public TextExportException(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members
Overload List


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win)

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win)
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly : GrapeCity.ActiveReports Namespace

Glossary Item Box

The GrapeCity.ActiveReports Namespace contains the PrintExtension class.

Classes

 | Class | Description
Class | PrintExtension | Provides the print methods for page and section documents.

See Also

Reference

GrapeCity.ActiveReports.Viewer.Win Assembly


PrintExtension Class

[image]
ActiveReports 13
PrintExtension Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace : PrintExtension Class

Glossary Item Box

Provides the print methods for page and section documents.

Object Model

PrintExtension Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class PrintExtension
C#
public static class PrintExtension

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PrintExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Members
GrapeCity.ActiveReports Namespace


PrintExtension Class Members

[image]
ActiveReports 13
PrintExtension Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace : PrintExtension Class

Glossary Item Box

The following tables list the members exposed by PrintExtension.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Print | Overloaded. Prints the section-based document.
Top

See Also

Reference

PrintExtension Class
GrapeCity.ActiveReports Namespace


PrintExtension Class Methods

[image]
ActiveReports 13
PrintExtension Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace : PrintExtension Class

Glossary Item Box

For a list of all members of this type, see PrintExtension members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Print | Overloaded. Prints the section-based document.
Top

See Also

Reference

PrintExtension Class
GrapeCity.ActiveReports Namespace


Print Method

[image]
ActiveReports 13
Print Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class : Print Method

Glossary Item Box

Prints the section-based document.

Overload List

Overload | Description
Print(SectionDocument) | Prints the section-based document.
Print(SectionDocument,Boolean) | Prints the section-based document.
Print(SectionDocument,Boolean,Boolean) | Prints the section-based document.
Print(SectionDocument,PrintingSettings) | Print the section-based document.
Print(SectionDocument,Boolean,Boolean,Boolean) | Prints the section-based document.
Print(PageDocument) | Prints Page-based document
Print(PageDocument,Boolean) | Prints Page-based document
Print(PageDocument,Boolean,Boolean) | Prints Page-based document
Print(PageDocument,Boolean,Boolean,Boolean) | Print the page based document.
Print(PageDocument,PrintingSettings) | Print the page based document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members


Print(SectionDocument) Method

[image]
ActiveReports 13
Print(SectionDocument) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument) Method

sectionDocument
Document to be printed.

Glossary Item Box

Prints the section-based document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument _
) As Boolean
C#
public static bool Print(
   SectionDocument sectionDocument
)

Parameters

sectionDocument
Document to be printed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,Boolean) Method

[image]
ActiveReports 13
Print(SectionDocument,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,Boolean) Method

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.

Glossary Item Box

Prints the section-based document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal showPrintDialog As Boolean _
) As Boolean
C#
public static bool Print(
   SectionDocument sectionDocument,
   bool showPrintDialog
)

Parameters

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,Boolean,Boolean) Method

[image]
ActiveReports 13
Print(SectionDocument,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,Boolean,Boolean) Method

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.

Glossary Item Box

Prints the section-based document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean _
) As Boolean
C#
public static bool Print(
   SectionDocument sectionDocument,
   bool showPrintDialog,
   bool showPrintProgressDialog
)

Parameters

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,PrintingSettings) Method

[image]
ActiveReports 13
Print(SectionDocument,PrintingSettings) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,PrintingSettings) Method

sectionDocument
Document to be printed.
settings

Glossary Item Box

Print the section-based document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal settings As PrintingSettings _
) As Boolean
C#
public static bool Print(
   SectionDocument sectionDocument,
   PrintingSettings settings
)

Parameters

sectionDocument
Document to be printed.
settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,Boolean,Boolean,Boolean) Method

[image]
ActiveReports 13
Print(SectionDocument,Boolean,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,Boolean,Boolean,Boolean) Method

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
usePrintingThread
If True the printing will be run in new thread.

Glossary Item Box

Prints the section-based document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean, _
   ByVal usePrintingThread As Boolean _
) As Boolean
C#
public static bool Print(
   SectionDocument sectionDocument,
   bool showPrintDialog,
   bool showPrintProgressDialog,
   bool usePrintingThread
)

Parameters

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
usePrintingThread
If True the printing will be run in new thread.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument) Method

[image]
ActiveReports 13
Print(PageDocument) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument) Method

pageDocument
Document to be printed.

Glossary Item Box

Prints Page-based document

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument _
) As Boolean
C#
public static bool Print(
   PageDocument pageDocument
)

Parameters

pageDocument
Document to be printed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,Boolean) Method

[image]
ActiveReports 13
Print(PageDocument,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,Boolean) Method

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.

Glossary Item Box

Prints Page-based document

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal showPrintDialog As Boolean _
) As Boolean
C#
public static bool Print(
   PageDocument pageDocument,
   bool showPrintDialog
)

Parameters

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,Boolean,Boolean) Method

[image]
ActiveReports 13
Print(PageDocument,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,Boolean,Boolean) Method

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.

Glossary Item Box

Prints Page-based document

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean _
) As Boolean
C#
public static bool Print(
   PageDocument pageDocument,
   bool showPrintDialog,
   bool showPrintProgressDialog
)

Parameters

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,Boolean,Boolean,Boolean) Method

[image]
ActiveReports 13
Print(PageDocument,Boolean,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,Boolean,Boolean,Boolean) Method

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
usePrintingThread
If True the printing will be run in new thread.

Glossary Item Box

Print the page based document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean, _
   ByVal usePrintingThread As Boolean _
) As Boolean
C#
public static bool Print(
   PageDocument pageDocument,
   bool showPrintDialog,
   bool showPrintProgressDialog,
   bool usePrintingThread
)

Parameters

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
usePrintingThread
If True the printing will be run in new thread.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,PrintingSettings) Method

[image]
ActiveReports 13
Print(PageDocument,PrintingSettings) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,PrintingSettings) Method

pageDocument
Document to be printed.
settings

Glossary Item Box

Print the page based document.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal settings As PrintingSettings _
) As Boolean
C#
public static bool Print(
   PageDocument pageDocument,
   PrintingSettings settings
)

Parameters

pageDocument
Document to be printed.
settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


GrapeCity.ActiveReports.Viewer.Win Namespace

GrapeCity.ActiveReports.Viewer.Win Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly : GrapeCity.ActiveReports.Viewer.Win Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Viewer.Win namespace, contains the Viewer that is used to control the viewer, TocPanel, and other classes.

Classes

 | Class | Description
Class | FindEventArgs | Provides data for the Find event.
Class | HyperLinkEventArgs | Provides data for the HyperLink event.
Class | ParametersPanel | Represents the parameter panel of the Viewer.
Class | ReportParameter | Represents a report parameter.
Class | SearchPanel | Represents the search panel of the Viewer.
Class | Sidebar | Exposes Viewer's public API.
Class | ThumbnailsPanel | Represents the thumbnail panel of the Viewer.
Class | TocPanel | Shows the panel of parameters of the Viewer control.
Class | Viewer | The Viewer control is used to preview report documents on the screen.
Class | Viewer.ActionEventArgs | Provides data for Action event.
Class | Viewer.ViewerToolbar | Gets the viewer toolbar object, allowing you to add and remove items on each of the component ToolStrips, and to implement tool click events for added items.
Class | ZoomChangedEventArgs | Provides data for the ZoomChanged event.

Delegates

 | Delegate | Description
Delegate | FindEventHandler | Represents the method that will handle the Find click event.
Delegate | HyperLinkEventHandler | Represents the method that will handle the HyperLink click event.
Delegate | ZoomChangedEventHandler | Represents the method that will handle the zoom click event.

Enumerations

 | Enumeration | Description
Enumeration | TargetView | Determines the current active view in the viewer.

See Also

Reference

GrapeCity.ActiveReports.Viewer.Win Assembly


FindEventArgs Class

[image]
ActiveReports 13
FindEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventArgs Class

Glossary Item Box

Provides data for the Find event.

Object Model

FindEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FindEventArgs
   Inherits System.EventArgs
C#
public sealed class FindEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.FindEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


FindEventArgs Class Members

[image]
ActiveReports 13
FindEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventArgs Class

Glossary Item Box

The following tables list the members exposed by FindEventArgs.

Public Constructors

 | Name | Description
Public Constructor | FindEventArgs Constructor | Overloaded. Initializes a new instance of the FindEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Found | Gets the value that determines whether the text was found.
Public Property | PageIndex | Gets the page number where the text was found.
Top

See Also

Reference

FindEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


FindEventArgs Constructor

[image]
ActiveReports 13
FindEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class : FindEventArgs Constructor

Glossary Item Box

Initializes a new instance of the FindEventArgs class.

Overload List

Overload | Description
FindEventArgs Constructor(Boolean,Int32) | Initializes a new instance of the FindEventArgs class and sets the Found and PageIndex properties.
FindEventArgs Constructor() | Initializes a new instance of the FindEventArgs class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindEventArgs Class
FindEventArgs Members


FindEventArgs Constructor(Boolean,Int32)

[image]
ActiveReports 13
FindEventArgs Constructor(Boolean,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class > FindEventArgs Constructor : FindEventArgs Constructor(Boolean,Int32)

found
Specifies whether the text was found.
pageIndex
Specifies the page number where the text was found.

Glossary Item Box

Initializes a new instance of the FindEventArgs class and sets the Found and PageIndex properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal found As Boolean, _
   ByVal pageIndex As Integer _
)
C#
public FindEventArgs(
   bool found,
   int pageIndex
)

Parameters

found
Specifies whether the text was found.
pageIndex
Specifies the page number where the text was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindEventArgs Class
FindEventArgs Members
Overload List


FindEventArgs Constructor()

[image]
ActiveReports 13
FindEventArgs Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class > FindEventArgs Constructor : FindEventArgs Constructor()

Glossary Item Box

Initializes a new instance of the FindEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public FindEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindEventArgs Class
FindEventArgs Members
Overload List


FindEventArgs Class Properties

[image]
ActiveReports 13
FindEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventArgs Class

Glossary Item Box

For a list of all members of this type, see FindEventArgs members.

Public Properties

 | Name | Description
Public Property | Found | Gets the value that determines whether the text was found.
Public Property | PageIndex | Gets the page number where the text was found.
Top

See Also

Reference

FindEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Found Property

[image]
ActiveReports 13
Found Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class : Found Property

Glossary Item Box

Gets the value that determines whether the text was found.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Found As Boolean
C#
public bool Found {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindEventArgs Class
FindEventArgs Members


PageIndex Property

[image]
ActiveReports 13
PageIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class : PageIndex Property

Glossary Item Box

Gets the page number where the text was found.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageIndex As Integer
C#
public int PageIndex {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindEventArgs Class
FindEventArgs Members


HyperLinkEventArgs Class

[image]
ActiveReports 13
HyperLinkEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventArgs Class

Glossary Item Box

Provides data for the HyperLink event.

Object Model

HyperLinkEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class HyperLinkEventArgs
   Inherits System.EventArgs
C#
public sealed class HyperLinkEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


HyperLinkEventArgs Class Members

[image]
ActiveReports 13
HyperLinkEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventArgs Class

Glossary Item Box

The following tables list the members exposed by HyperLinkEventArgs.

Public Constructors

 | Name | Description
Public Constructor | HyperLinkEventArgs Constructor | Initializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Button and HyperLink properties.
Top

Public Properties

 | Name | Description
Public Property | Button | Gets the mouse button that the user clicked to raise the event.
Public Property | CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Public Property | Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
Public Property | HyperLink | Gets the hyperlink target.
Top

See Also

Reference

HyperLinkEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


HyperLinkEventArgs Constructor

[image]
ActiveReports 13
HyperLinkEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : HyperLinkEventArgs Constructor

button
The mouse button clicked.
hyperLink
The hyperlink target.

Glossary Item Box

Initializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Button and HyperLink properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal button As MouseButtons, _
   ByVal hyperLink As String _
)
C#
public HyperLinkEventArgs(
   MouseButtons button,
   string hyperLink
)

Parameters

button
The mouse button clicked.
hyperLink
The hyperlink target.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


HyperLinkEventArgs Class Properties

[image]
ActiveReports 13
HyperLinkEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventArgs Class

Glossary Item Box

For a list of all members of this type, see HyperLinkEventArgs members.

Public Properties

 | Name | Description
Public Property | Button | Gets the mouse button that the user clicked to raise the event.
Public Property | CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Public Property | Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
Public Property | HyperLink | Gets the hyperlink target.
Top

See Also

Reference

HyperLinkEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Button Property

[image]
ActiveReports 13
Button Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : Button Property

Glossary Item Box

Gets the mouse button that the user clicked to raise the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Button As MouseButtons
C#
public MouseButtons Button {get;}

Property Value

System.Windows.MouseButtons value that represents the button that has fired this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


CreateNewTab Property

[image]
ActiveReports 13
CreateNewTab Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : CreateNewTab Property

Glossary Item Box

Gets or sets a value indicating whether a new tab has been created.

Syntax

Visual Basic (Declaration)
Public Property CreateNewTab As Boolean
C#
public bool CreateNewTab {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


Handled Property

[image]
ActiveReports 13
Handled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : Handled Property

Glossary Item Box

Sets or returns a value indicating whether the HyperLinkEvent is handled.

Syntax

Visual Basic (Declaration)
Public Property Handled As Boolean
C#
public bool Handled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


HyperLink Property

[image]
ActiveReports 13
HyperLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : HyperLink Property

Glossary Item Box

Gets the hyperlink target.

Syntax

Visual Basic (Declaration)
Public Property HyperLink As String
C#
public string HyperLink {get; set;}

Property Value

Character string value that represents the target of the hyperlink.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


ParametersPanel Class

[image]
ActiveReports 13
ParametersPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

Glossary Item Box

Represents the parameter panel of the Viewer.

Object Model

ParametersPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParametersPanel
   Inherits SidebarPanel
C#
public sealed class ParametersPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.ParametersPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ParametersPanel Class Members

[image]
ActiveReports 13
ParametersPanel Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

Glossary Item Box

The following tables list the members exposed by ParametersPanel.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of parameters panel.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Refreshes the Parameters panel.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ParametersPanel Class Methods

[image]
ActiveReports 13
ParametersPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

Glossary Item Box

For a list of all members of this type, see ParametersPanel members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Refreshes the Parameters panel.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Refresh Method

Glossary Item Box

Refreshes the Parameters panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Refresh()
C#
public override void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ParametersPanel Class Properties

[image]
ActiveReports 13
ParametersPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

Glossary Item Box

For a list of all members of this type, see ParametersPanel members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of parameters panel.
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Text Property

Glossary Item Box

Gets or sets the caption of parameters panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Property Value

The caption text.

Requirements

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ReportParameter Class

[image]
ActiveReports 13
ReportParameter Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ReportParameter Class

Glossary Item Box

Represents a report parameter.

Object Model

ReportParameter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportParameter
C#
public sealed class ReportParameter

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Viewer.Win.ReportParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ReportParameter Class Members

[image]
ActiveReports 13
ReportParameter Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ReportParameter Class

Glossary Item Box

The following tables list the members exposed by ReportParameter.

Public Constructors

 | Name | Description
Public Constructor | ReportParameter Constructor | Overloaded. Initializes a new instance of ReportParameter class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the report parameter.
Public Property | Values | Gets the collection of zero or more values for the report parameter.
Top

See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ReportParameter Constructor

[image]
ActiveReports 13
ReportParameter Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class : ReportParameter Constructor

Glossary Item Box

Initializes a new instance of ReportParameter class.

Overload List

Overload | Description
ReportParameter Constructor(String,Object) | Initializes a new instance with a single value.
ReportParameter Constructor(String,ICollection<Object>) | Initializes a new instance multiple values.
ReportParameter Constructor(String) | Initializes a new instance without a value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Constructor(String,Object)

[image]
ActiveReports 13
ReportParameter Constructor(String,Object)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor(String,Object)

name
Parameter name.
value
Parameter value.

Glossary Item Box

Initializes a new instance with a single value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public ReportParameter(
   string name,
   object value
)

Parameters

name
Parameter name.
value
Parameter value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Constructor(String,ICollection<Object>)

[image]
ActiveReports 13
ReportParameter Constructor(String,ICollection<Object>)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor(String,ICollection<Object>)

name
Parameter Name.
values
Collection of parameter values.

Glossary Item Box

Initializes a new instance multiple values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal values As ICollection(Of Object) _
)
C#
public ReportParameter(
   string name,
   ICollection<object> values
)

Parameters

name
Parameter Name.
values
Collection of parameter values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Constructor(String)

[image]
ActiveReports 13
ReportParameter Constructor(String)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor(String)

name
Parameter Name.

Glossary Item Box

Initializes a new instance without a value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public ReportParameter(
   string name
)

Parameters

name
Parameter Name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Class Properties

[image]
ActiveReports 13
ReportParameter Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ReportParameter Class

Glossary Item Box

For a list of all members of this type, see ReportParameter members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the report parameter.
Public Property | Values | Gets the collection of zero or more values for the report parameter.
Top

See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class : Name Property

Glossary Item Box

Gets the name of the report parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Values Property

[image]
ActiveReports 13
Values Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class : Values Property

Glossary Item Box

Gets the collection of zero or more values for the report parameter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As IEnumerable(Of Object)
C#
public IEnumerable<object> Values {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


SearchPanel Class

[image]
ActiveReports 13
SearchPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

Glossary Item Box

Represents the search panel of the Viewer.

Object Model

SearchPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SearchPanel
   Inherits SidebarPanel
C#
public sealed class SearchPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.SearchPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


SearchPanel Class Members

[image]
ActiveReports 13
SearchPanel Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

Glossary Item Box

The following tables list the members exposed by SearchPanel.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of search panel.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the search panel UI, resets the search parameters and clears the search result.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


SearchPanel Class Methods

[image]
ActiveReports 13
SearchPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

Glossary Item Box

For a list of all members of this type, see SearchPanel members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the search panel UI, resets the search parameters and clears the search result.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Clear Method

Glossary Item Box

Clears the search panel UI, resets the search parameters and clears the search result.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


SearchPanel Class Properties

[image]
ActiveReports 13
SearchPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

Glossary Item Box

For a list of all members of this type, see SearchPanel members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of search panel.
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Text Property

Glossary Item Box

Gets or sets the caption of search panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Property Value

The caption text.

Requirements

See Also

Reference

SearchPanel Class
SearchPanel Members


Sidebar Class

[image]
ActiveReports 13
Sidebar Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

Glossary Item Box

Exposes Viewer's public API.

Object Model

Sidebar Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Sidebar
   Inherits System.ComponentModel.Component
C#
public sealed class Sidebar : System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.Sidebar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Members
GrapeCity.ActiveReports.Viewer.Win Namespace


Sidebar Class Members

[image]
ActiveReports 13
Sidebar Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

Glossary Item Box

The following tables list the members exposed by Sidebar.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ParametersPanel | Gets the parameters panel object.
Public Property | SearchPanel | Gets the search panel object.
Public Property | SelectedIndex | Gets or Sets the index of the selected panel.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | ThumbnailsPanel | Gets the thumbnails panel object.
Public Property | TocPanel | Gets the Toc panel object.
Public Property | Visible | Gets or sets the value indicating whether the sidebar is visible.
Public Property | Width | Gets or Sets the width of the sidebar.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToggleVisibility | Toggles the Sidebar visibility.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | SelectedIndexChanged | Raises when the index of the selected panel changes.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Sidebar Class Methods

[image]
ActiveReports 13
Sidebar Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToggleVisibility | Toggles the Sidebar visibility.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ToggleVisibility Method

[image]
ActiveReports 13
ToggleVisibility Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ToggleVisibility Method

Glossary Item Box

Toggles the Sidebar visibility.

Syntax

Visual Basic (Declaration)
Public Sub ToggleVisibility()
C#
public void ToggleVisibility()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Properties

[image]
ActiveReports 13
Sidebar Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ParametersPanel | Gets the parameters panel object.
Public Property | SearchPanel | Gets the search panel object.
Public Property | SelectedIndex | Gets or Sets the index of the selected panel.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | ThumbnailsPanel | Gets the thumbnails panel object.
Public Property | TocPanel | Gets the Toc panel object.
Public Property | Visible | Gets or sets the value indicating whether the sidebar is visible.
Public Property | Width | Gets or Sets the width of the sidebar.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ParametersPanel Property

[image]
ActiveReports 13
ParametersPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ParametersPanel Property

Glossary Item Box

Gets the parameters panel object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParametersPanel As ParametersPanel
C#
public ParametersPanel ParametersPanel {get;}

Property Value

The parameters panel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SearchPanel Property

[image]
ActiveReports 13
SearchPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : SearchPanel Property

Glossary Item Box

Gets the search panel object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SearchPanel As SearchPanel
C#
public SearchPanel SearchPanel {get;}

Property Value

The search panel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SelectedIndex Property

[image]
ActiveReports 13
SelectedIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : SelectedIndex Property

Glossary Item Box

Gets or Sets the index of the selected panel.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
C#
public int SelectedIndex {get; set;}

Property Value

The index of the selected panel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Property

[image]
ActiveReports 13
ThumbnailsPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ThumbnailsPanel Property

Glossary Item Box

Gets the thumbnails panel object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ThumbnailsPanel As ThumbnailsPanel
C#
public ThumbnailsPanel ThumbnailsPanel {get;}

Property Value

The thumbnails panel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


TocPanel Property

[image]
ActiveReports 13
TocPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : TocPanel Property

Glossary Item Box

Gets the Toc panel object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TocPanel As TocPanel
C#
public TocPanel TocPanel {get;}

Property Value

The toc panel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Visible Property

Glossary Item Box

Gets or sets the value indicating whether the sidebar is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Width Property

Glossary Item Box

Gets or Sets the width of the sidebar.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Events

[image]
ActiveReports 13
Sidebar Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | SelectedIndexChanged | Raises when the index of the selected panel changes.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


SelectedIndexChanged Event

[image]
ActiveReports 13
SelectedIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : SelectedIndexChanged Event

Glossary Item Box

Raises when the index of the selected panel changes.

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChanged As EventHandler
C#
public event EventHandler SelectedIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Class

[image]
ActiveReports 13
ThumbnailsPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

Glossary Item Box

Represents the thumbnail panel of the Viewer.

Object Model

ThumbnailsPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThumbnailsPanel
   Inherits SidebarPanel
C#
public sealed class ThumbnailsPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.ThumbnailsPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ThumbnailsPanel Class Members

[image]
ActiveReports 13
ThumbnailsPanel Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

Glossary Item Box

The following tables list the members exposed by ThumbnailsPanel.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of thumbnails panel.
Public Property | Zoom | Gets or sets the zoom level of items in the ThumbnailsPanel.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ZoomChanged | Occurs when the zoom level changes in the ThumbnailsPanel.
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ThumbnailsPanel Class Properties

[image]
ActiveReports 13
ThumbnailsPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

Glossary Item Box

For a list of all members of this type, see ThumbnailsPanel members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of thumbnails panel.
Public Property | Zoom | Gets or sets the zoom level of items in the ThumbnailsPanel.
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Text Property

Glossary Item Box

Gets or sets the caption of thumbnails panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Property Value

The caption text.

Requirements

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Zoom Property

[image]
ActiveReports 13
Zoom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Zoom Property

Glossary Item Box

Gets or sets the zoom level of items in the ThumbnailsPanel.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Double
C#
public double Zoom {get; set;}

Property Value

The zoom level.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ThumbnailsPanel Class Events

[image]
ActiveReports 13
ThumbnailsPanel Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

Glossary Item Box

For a list of all members of this type, see ThumbnailsPanel members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ZoomChanged | Occurs when the zoom level changes in the ThumbnailsPanel.
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChanged Event

[image]
ActiveReports 13
ZoomChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : ZoomChanged Event

Glossary Item Box

Occurs when the zoom level changes in the ThumbnailsPanel.

Syntax

Visual Basic (Declaration)
Public Event ZoomChanged As ZoomChangedEventHandler
C#
public event ZoomChangedEventHandler ZoomChanged

Event Data

The event handler receives an argument of type ZoomChangedEventArgs containing data related to this event. The following ZoomChangedEventArgs properties provide information specific to this event.

Property | Description
Zoom | Returns the viewer's new Zoom value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


TocPanel Class

[image]
ActiveReports 13
TocPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

Glossary Item Box

Shows the panel of parameters of the Viewer control.

Object Model

TocPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TocPanel
   Inherits SidebarPanel
C#
public sealed class TocPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.TocPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


TocPanel Class Members

[image]
ActiveReports 13
TocPanel Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

Glossary Item Box

The following tables list the members exposed by TocPanel.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContextMenu | Overridden. Gets or sets a context menu when the user right clicks on the toc panel.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of table of content panel.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


TocPanel Class Methods

[image]
ActiveReports 13
TocPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

Glossary Item Box

For a list of all members of this type, see TocPanel members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Clear Method

Glossary Item Box

Clears the table of contents panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Refresh Method

Glossary Item Box

Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Refresh()
C#
public override void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


TocPanel Class Properties

[image]
ActiveReports 13
TocPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

Glossary Item Box

For a list of all members of this type, see TocPanel members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContextMenu | Overridden. Gets or sets a context menu when the user right clicks on the toc panel.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of table of content panel.
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : ContextMenu Property

Glossary Item Box

Gets or sets a context menu when the user right clicks on the toc panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property ContextMenu As ContextMenu
C#
public override ContextMenu ContextMenu {get; set;}

Property Value

The context menu.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Expanded Property

[image]
ActiveReports 13
Expanded Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Expanded Property

Glossary Item Box

Gets or sets a value that indicates whether the TocPanel is expanded.

Syntax

Visual Basic (Declaration)
Public Property Expanded As Boolean
C#
public bool Expanded {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Text Property

Glossary Item Box

Gets or sets the caption of table of content panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Property Value

The caption text.

Requirements

See Also

Reference

TocPanel Class
TocPanel Members


Viewer Class

[image]
ActiveReports 13
Viewer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

Glossary Item Box

The Viewer control is used to preview report documents on the screen.

Object Model

Viewer Class

Syntax

Visual Basic (Declaration)
Public Class Viewer
   Inherits System.Windows.Forms.UserControl
C#
public class Viewer : System.Windows.Forms.UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Viewer.Win.Viewer

Requirements

See Also

Reference

Viewer Members
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer Class Members

[image]
ActiveReports 13
Viewer Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

Glossary Item Box

The following tables list the members exposed by Viewer.

Public Constructors

 | Name | Description
Public Constructor | Viewer Constructor | Initializes a new instance of Viewer class.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationDropDownVisible | Gets or Sets the dropdown of annotation toolbar.
Public Property | AnnotationToolbarVisible | Gets or Sets the annotation toolbar's visibility.
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanExport | Indicates whether the currently loaded report can be exported.
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the Active Reports document to be displayed on the Viewer control.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MouseMode | Gets or sets the mouse mode of the viewer.
Public Property | MouseModeButtonsVisible | Indicates whether the "Pan", "Selection Mode" and "Snapshot" buttons are visible in the viewer toolbar.
Public Property | MultiplePageCols | Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.
Public Property | MultiplePageRows | Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageOffset | Specifies the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TableOfContents | Gets or sets a reference to the TableOfContentsObject.
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Toolbar | Gets the reference to ToolbarObject of the control.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TouchContextMenuStrip | Get or sets the context menu of touch enabled Viewer.
Public Property | TouchMode | Enable touch mode or not.
Public Property | TouchModeButtonVisibility | Display Touch mode button on viewer's toolbar or not.
Public Property | TouchModeToolbar | Pubilc API for touch mode Toolbar manipulation.
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ViewType | Gets or sets a value that determines how the viewer shows pages(single/multi/continous).
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the viewer's zoom level. 1 for FitWidth mode 2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | CancelRender | Cancels report rendering.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | HandleError | Reports about runtime error
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | Print | Overloaded. Prints the currently opened document (section or page).
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetParametersValues | Loads the specified remote report. Sets values of parameters for the report that is shown.
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | ShowFindDialog | Displays Find Dialog
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | ErrorOccured | Fires in case of any error (in error panel etc.).
Public Event | Find | Occurs when the Find dialog finds the requested text in the document.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RefreshReport | Fires before report refreshes (right after opening of new report, toggling/sorting and drill-through actions, pressing of buttons: view report (parameters panel), galley mode, refresh, back to parent). In case of no error it fires before LoadCompleted event.
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TableOfContentsAfterSelect | Occurs after an item is selected in the table of contents treeview.
Public Event | TableOfContentsClick | Occurs when the user clicks an item in the table of contents treeview.
Public Event | TableOfContentsSelectedIndexChanged | Occurs when the index of the currently selected item in the table of contents changes.
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ZoomChanged | Occurs when the zoom has changed in the viewer.
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer Constructor

[image]
ActiveReports 13
Viewer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Viewer Constructor

Glossary Item Box

Initializes a new instance of Viewer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Viewer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Methods

[image]
ActiveReports 13
Viewer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

Glossary Item Box

For a list of all members of this type, see Viewer members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | CancelRender | Cancels report rendering.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | HandleError | Reports about runtime error
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | Print | Overloaded. Prints the currently opened document (section or page).
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetParametersValues | Loads the specified remote report. Sets values of parameters for the report that is shown.
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | ShowFindDialog | Displays Find Dialog
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


CancelRender Method

[image]
ActiveReports 13
CancelRender Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CancelRender Method

Glossary Item Box

Cancels report rendering.

Syntax

Visual Basic (Declaration)
Public Sub CancelRender()
C#
public void CancelRender()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Export Method

[image]
ActiveReports 13
Export Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Export Method

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.

Overload List

Overload | Description
Export(IDocumentExportEx,FileInfo) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,FileInfo,String) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,Stream) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Export(IDocumentExportEx,Stream,String) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Export(IDocumentExportEx,FileInfo) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,FileInfo) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo) Method

filter
The filter that will export the currently loaded report.
file
The file to which the exported result will be saved.

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As FileInfo _
)
C#
public void Export(
   IDocumentExportEx filter,
   FileInfo file
)

Parameters

filter
The filter that will export the currently loaded report.
file
The file to which the exported result will be saved.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,FileInfo,String) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,FileInfo,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo,String) Method

filter
The filter that will export the currently loaded report.
file
The file to which the exported result will be saved.
pageRange
A range of page numbers to export separated by a comma. Between each comma you can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range."

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As FileInfo, _
   ByVal pageRange As String _
)
C#
public void Export(
   IDocumentExportEx filter,
   FileInfo file,
   string pageRange
)

Parameters

filter
The filter that will export the currently loaded report.
file
The file to which the exported result will be saved.
pageRange
A range of page numbers to export separated by a comma. Between each comma you can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range."

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream) Method

filter
The filter that will export the currently loaded report.
stream

The System.IO.Stream to which to save the exported result

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As Stream _
)
C#
public void Export(
   IDocumentExportEx filter,
   Stream stream
)

Parameters

filter
The filter that will export the currently loaded report.
stream

The System.IO.Stream to which to save the exported result

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream,String) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream,String) Method

filter
the filter that will export the currently loaded report.
stream
The System.IO.Stream to which to save the exported result.
pageRange
A range of page numbers to export separated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   IDocumentExportEx filter,
   Stream stream,
   string pageRange
)

Parameters

filter
the filter that will export the currently loaded report.
stream
The System.IO.Stream to which to save the exported result.
pageRange
A range of page numbers to export separated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


HandleError Method

[image]
ActiveReports 13
HandleError Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HandleError Method

ex
The exception to report.

Glossary Item Box

Reports about runtime error

Syntax

Visual Basic (Declaration)
Public Sub HandleError( _
   ByVal ex As Exception _
)
C#
public void HandleError(
   Exception ex
)

Parameters

ex
The exception to report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LoadDocument Method

[image]
ActiveReports 13
LoadDocument Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LoadDocument Method

Glossary Item Box

Loads a report.

Overload List

Overload | Description
LoadDocument(Stream,DocumentFormat) | Loads a document from a stream in the specified binary or XML report format.
LoadDocument(String) | Load the report from a specified file path.
LoadDocument(PageDocument) | Load the specified static page report document.
LoadDocument(SectionReport) | Load the specified section report object during run-time.
LoadDocument(SectionDocument) | Load the specified static section report document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LoadDocument(Stream,DocumentFormat) Method

[image]
ActiveReports 13
LoadDocument(Stream,DocumentFormat) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(Stream,DocumentFormat) Method

stream
The System.IO.Stream to load the report from.
format
Specify the DocumentFormat of the report to be loaded.

Glossary Item Box

Loads a document from a stream in the specified binary or XML report format.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal stream As Stream, _
   ByVal format As DocumentFormat _
)
C#
public void LoadDocument(
   Stream stream,
   DocumentFormat format
)

Parameters

stream
The System.IO.Stream to load the report from.
format
Specify the DocumentFormat of the report to be loaded.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(String) Method

[image]
ActiveReports 13
LoadDocument(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(String) Method

filePath

The path to the file to load the report form.

Glossary Item Box

Load the report from a specified file path.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal filePath As String _
)
C#
public void LoadDocument(
   string filePath
)

Parameters

filePath

The path to the file to load the report form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(PageDocument) Method

[image]
ActiveReports 13
LoadDocument(PageDocument) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(PageDocument) Method

pageDocument

The page report to open in the viewer.

Glossary Item Box

Load the specified static page report document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal pageDocument As PageDocument _
)
C#
public void LoadDocument(
   PageDocument pageDocument
)

Parameters

pageDocument

The page report to open in the viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionReport) Method

[image]
ActiveReports 13
LoadDocument(SectionReport) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionReport) Method

report

The section report to view in the viewer.

Glossary Item Box

Load the specified section report object during run-time.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal report As SectionReport _
)
C#
public void LoadDocument(
   SectionReport report
)

Parameters

report

The section report to view in the viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionDocument) Method

[image]
ActiveReports 13
LoadDocument(SectionDocument) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionDocument) Method

document
the section document to open in the viewer.

Glossary Item Box

Load the specified static section report document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal document As SectionDocument _
)
C#
public void LoadDocument(
   SectionDocument document
)

Parameters

document
the section document to open in the viewer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print Method

[image]
ActiveReports 13
Print Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Print Method

Glossary Item Box

Prints the currently opened document (section or page).

Overload List

Overload | Description
Print(Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean,Boolean) | Prints the currently opened document(section or page)
Print(PrintingSettings) | Prints the currently opened document(section or page)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Print(Boolean) Method

[image]
ActiveReports 13
Print(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(Boolean) Method

showPrintDialog
Specifies whether or not the Print dialog should be shown.

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal showPrintDialog As Boolean _
) As Boolean
C#
public bool Print(
   bool showPrintDialog
)

Parameters

showPrintDialog
Specifies whether or not the Print dialog should be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean) Method

[image]
ActiveReports 13
Print(Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(Boolean,Boolean) Method

showPrintDialog
Specifies whether or not the Print dialog should be shown.
showPrintProgressDialog
Specifies whether or not the PrintProgress dialog should be shown.

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean _
) As Boolean
C#
public bool Print(
   bool showPrintDialog,
   bool showPrintProgressDialog
)

Parameters

showPrintDialog
Specifies whether or not the Print dialog should be shown.
showPrintProgressDialog
Specifies whether or not the PrintProgress dialog should be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean,Boolean) Method

[image]
ActiveReports 13
Print(Boolean,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(Boolean,Boolean,Boolean) Method

showPrintDialog
If this property is set to True, then a dialog in which the user can set the printer options beforethe document contents are sent to the printer, is displayed.
showPrintProgressDialog
If this property is set to True, then a print progress dialog, in which the user can cancel the printing job, is displayed.
usePrintingThread
Specifies whether printing should be performed for individual threads or not.

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean, _
   ByVal usePrintingThread As Boolean _
) As Boolean
C#
public bool Print(
   bool showPrintDialog,
   bool showPrintProgressDialog,
   bool usePrintingThread
)

Parameters

showPrintDialog
If this property is set to True, then a dialog in which the user can set the printer options beforethe document contents are sent to the printer, is displayed.
showPrintProgressDialog
If this property is set to True, then a print progress dialog, in which the user can cancel the printing job, is displayed.
usePrintingThread
Specifies whether printing should be performed for individual threads or not.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(PrintingSettings) Method

[image]
ActiveReports 13
Print(PrintingSettings) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(PrintingSettings) Method

settings

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal settings As PrintingSettings _
) As Boolean
C#
public bool Print(
   PrintingSettings settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Render Method

[image]
ActiveReports 13
Render Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Render Method

extension
The rendering extension to render the currently loaded report.
streamProvider
The stream provider to store the render output.
settings
The rendering extension settings.

Glossary Item Box

Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal extension As IRenderingExtension, _
   ByVal streamProvider As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection _
)
C#
public void Render(
   IRenderingExtension extension,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streamProvider,
   NameValueCollection settings
)

Parameters

extension
The rendering extension to render the currently loaded report.
streamProvider
The stream provider to store the render output.
settings
The rendering extension settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetParametersValues Method

[image]
ActiveReports 13
SetParametersValues Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SetParametersValues Method

parameters
Values of parameters to be set

Glossary Item Box

Loads the specified remote report. Sets values of parameters for the report that is shown.

Syntax

Visual Basic (Declaration)
Public Sub SetParametersValues( _
   ByVal parameters As IEnumerable(Of IParameter) _
)
C#
public void SetParametersValues(
   IEnumerable<IParameter> parameters
)

Parameters

parameters
Values of parameters to be set

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ShowFindDialog Method

[image]
ActiveReports 13
ShowFindDialog Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ShowFindDialog Method

Glossary Item Box

Displays Find Dialog

Syntax

Visual Basic (Declaration)
Public Sub ShowFindDialog()
C#
public void ShowFindDialog()

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;
    arv.ShowFindDialog();
}
VB.NET Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document
    arv.ShowFindDialog()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Properties

[image]
ActiveReports 13
Viewer Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

Glossary Item Box

For a list of all members of this type, see Viewer members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationDropDownVisible | Gets or Sets the dropdown of annotation toolbar.
Public Property | AnnotationToolbarVisible | Gets or Sets the annotation toolbar's visibility.
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanExport | Indicates whether the currently loaded report can be exported.
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the Active Reports document to be displayed on the Viewer control.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MouseMode | Gets or sets the mouse mode of the viewer.
Public Property | MouseModeButtonsVisible | Indicates whether the "Pan", "Selection Mode" and "Snapshot" buttons are visible in the viewer toolbar.
Public Property | MultiplePageCols | Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.
Public Property | MultiplePageRows | Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageOffset | Specifies the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TableOfContents | Gets or sets a reference to the TableOfContentsObject.
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Toolbar | Gets the reference to ToolbarObject of the control.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TouchContextMenuStrip | Get or sets the context menu of touch enabled Viewer.
Public Property | TouchMode | Enable touch mode or not.
Public Property | TouchModeButtonVisibility | Display Touch mode button on viewer's toolbar or not.
Public Property | TouchModeToolbar | Pubilc API for touch mode Toolbar manipulation.
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ViewType | Gets or sets a value that determines how the viewer shows pages(single/multi/continous).
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the viewer's zoom level. 1 for FitWidth mode 2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


AllowSplitter Property

[image]
ActiveReports 13
AllowSplitter Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AllowSplitter Property

Glossary Item Box

Gets or sets a value that determines whether the user is allowed to split the view.

Syntax

Visual Basic (Declaration)
Public Property AllowSplitter As Boolean
C#
public bool AllowSplitter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AnnotationDropDownVisible Property

[image]
ActiveReports 13
AnnotationDropDownVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AnnotationDropDownVisible Property

Glossary Item Box

Gets or Sets the dropdown of annotation toolbar.

Syntax

Visual Basic (Declaration)
Public Property AnnotationDropDownVisible As Boolean
C#
public bool AnnotationDropDownVisible {get; set;}

Remarks

It only takes effect in mouse mode toolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AnnotationToolbarVisible Property

[image]
ActiveReports 13
AnnotationToolbarVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AnnotationToolbarVisible Property

Glossary Item Box

Gets or Sets the annotation toolbar's visibility.

Syntax

Visual Basic (Declaration)
Public Property AnnotationToolbarVisible As Boolean
C#
public bool AnnotationToolbarVisible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CanExport Property

[image]
ActiveReports 13
CanExport Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CanExport Property

Glossary Item Box

Indicates whether the currently loaded report can be exported.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanExport As Boolean
C#
public bool CanExport {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CurrentPage Property

[image]
ActiveReports 13
CurrentPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CurrentPage Property

Glossary Item Box

Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.

Syntax

Visual Basic (Declaration)
Public Property CurrentPage As Integer
C#
public int CurrentPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Document Property

[image]
ActiveReports 13
Document Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Document Property

Glossary Item Box

Gets or sets the Active Reports document to be displayed on the Viewer control.

Syntax

Visual Basic (Declaration)
Public Property Document As SectionDocument
C#
public SectionDocument Document {get; set;}

Property Value

Document value that represents the document currently displayed on the Viewer.

Example

C# Copy Code
private void Form1_Load(object sender, System.EventArgs e)
{
    ResourceManager res = new ResourceManager("rptLocalize.localization", this.GetType().Assembly);
    this.viewer1.Localize = res;
    rptLocalize rpt = new rptLocalize();
    viewer1.Document = rpt.Document;
    rpt.Run(true);
}
VB.NET Copy Code
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim res As New ResourceManager("rptLocalize.localization", Me.GetType().Assembly)
    Me.Viewer1.Localize = res
    Dim rpt As New rptLocalize()
    Viewer1.Document = rpt.Document
    rpt.Run(True)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GalleyMode Property

[image]
ActiveReports 13
GalleyMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GalleyMode Property

Glossary Item Box

Gets or sets GalleyMode of report

Syntax

Visual Basic (Declaration)
Public Property GalleyMode As Boolean
C#
public bool GalleyMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


History Property

[image]
ActiveReports 13
History Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : History Property

Glossary Item Box

Public API for history manipulation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property History As IHistoryApi
C#
public IHistoryApi History {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkBackColor Property

[image]
ActiveReports 13
HyperlinkBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperlinkBackColor Property

Glossary Item Box

Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property HyperlinkBackColor As Color
C#
public Color HyperlinkBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkForeColor Property

[image]
ActiveReports 13
HyperlinkForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperlinkForeColor Property

Glossary Item Box

Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property HyperlinkForeColor As Color
C#
public Color HyperlinkForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkUnderline Property

[image]
ActiveReports 13
HyperlinkUnderline Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperlinkUnderline Property

Glossary Item Box

Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property HyperlinkUnderline As Boolean
C#
public bool HyperlinkUnderline {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseMode Property

[image]
ActiveReports 13
MouseMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseMode Property

Glossary Item Box

Gets or sets the mouse mode of the viewer.

Syntax

Visual Basic (Declaration)
Public Property MouseMode As MouseMode
C#
public MouseMode MouseMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseModeButtonsVisible Property

[image]
ActiveReports 13
MouseModeButtonsVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseModeButtonsVisible Property

Glossary Item Box

Indicates whether the "Pan", "Selection Mode" and "Snapshot" buttons are visible in the viewer toolbar.

Syntax

Visual Basic (Declaration)
Public Property MouseModeButtonsVisible As Boolean
C#
public bool MouseModeButtonsVisible {get; set;}

Remarks

It only takes effect in mouse mode toolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MultiplePageCols Property

[image]
ActiveReports 13
MultiplePageCols Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MultiplePageCols Property

Glossary Item Box

Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.

Syntax

Visual Basic (Declaration)
Public Property MultiplePageCols As Integer
C#
public int MultiplePageCols {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MultiplePageRows Property

[image]
ActiveReports 13
MultiplePageRows Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MultiplePageRows Property

Glossary Item Box

Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.

Syntax

Visual Basic (Declaration)
Public Property MultiplePageRows As Integer
C#
public int MultiplePageRows {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PageOffset Property

[image]
ActiveReports 13
PageOffset Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PageOffset Property

Glossary Item Box

Specifies the location of the page in the viewer.

Syntax

Visual Basic (Declaration)
Public Property PageOffset As Point
C#
public Point PageOffset {get; set;}

Example

C# Copy Code
private void Form1_Load(System.Object sender, System.EventArgs e)
{
    Viewer1.LoadDocument(new SectionReport1());
}

private void  Viewer1_LoadCompleted(System.Object sender, System.EventArgs e)
{
    Viewer1.PageOffset = new System.Drawing.Point(100, 200);
}
VB.NET Copy Code
Private Sub Form1_Load(sender As System.Object, e As System.EventArgs) Handles MyBase.Load
        Viewer1.LoadDocument(New SectionReport1())
End Sub

Private Sub Viewer1_LoadCompleted(sender As System.Object, e As System.EventArgs) Handles Viewer1.LoadCompleted
        Viewer1.PageOffset = New System.Drawing.Point(100, 200)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PagesBackColor Property

[image]
ActiveReports 13
PagesBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PagesBackColor Property

Glossary Item Box

Public API for background color of report pane.

Syntax

Visual Basic (Declaration)
Public Property PagesBackColor As Color
C#
public Color PagesBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewPages Property

[image]
ActiveReports 13
PreviewPages Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreviewPages Property

Glossary Item Box

Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances

Syntax

Visual Basic (Declaration)
Public Property PreviewPages As Integer
C#
public int PreviewPages {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PrintingSettings Property

[image]
ActiveReports 13
PrintingSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PrintingSettings Property

Glossary Item Box

Gets or sets printing settings

Syntax

Visual Basic (Declaration)
Public Property PrintingSettings As PrintingSettings
C#
public PrintingSettings PrintingSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RepositionPage Property

[image]
ActiveReports 13
RepositionPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RepositionPage Property

Glossary Item Box

Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.

Syntax

Visual Basic (Declaration)
Public Property RepositionPage As Boolean
C#
public bool RepositionPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ScrollbarEnabled Property

[image]
ActiveReports 13
ScrollbarEnabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ScrollbarEnabled Property

Glossary Item Box

Public API. Show or hide scrolls within report pane.

Syntax

Visual Basic (Declaration)
Public Property ScrollbarEnabled As Boolean
C#
public bool ScrollbarEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SearchResultsBackColor Property

[image]
ActiveReports 13
SearchResultsBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SearchResultsBackColor Property

Glossary Item Box

Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsBackColor As Color
C#
public Color SearchResultsBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SearchResultsForeColor Property

[image]
ActiveReports 13
SearchResultsForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SearchResultsForeColor Property

Glossary Item Box

Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsForeColor As Color
C#
public Color SearchResultsForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Sidebar Property

[image]
ActiveReports 13
Sidebar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Sidebar Property

Glossary Item Box

Gets the sidebar component of the viewer control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sidebar As Sidebar
C#
public Sidebar Sidebar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SplitView Property

[image]
ActiveReports 13
SplitView Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SplitView Property

Glossary Item Box

Gets or sets a value that determines whether the viewer is split into two views.

Syntax

Visual Basic (Declaration)
Public Property SplitView As Boolean
C#
public bool SplitView {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TableOfContents Property

[image]
ActiveReports 13
TableOfContents Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContents Property

Glossary Item Box

Gets or sets a reference to the TableOfContentsObject.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableOfContents As TocPanel
C#
public TocPanel TableOfContents {get;}

Property Value

TableOfContentsObject value which is used in setting the tree view option of the Viewer's heading list.

Remarks

This property is used in setting the option of TableOfContentsObject component of the control.

Example

C# Copy Code
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    arv.Document = rpt.Document;

    arv.TableOfContents.Enabled = true;
    arv.TableOfContents.Text = "Country";
    arv.TableOfContents.Visible = true;
    arv.TableOfContents.Width = 150;
}
VB.NET Copy Code
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New SectionReport1
    rpt.Run()
    arv.Document = rpt.Document

    arv.TableOfContents.Enabled = True
    arv.TableOfContents.Text = "Country"
    arv.TableOfContents.Visible = True
    arv.TableOfContents.Width = 150
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TargetView Property

[image]
ActiveReports 13
TargetView Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TargetView Property

Glossary Item Box

Gets or sets a value that specifies the current target view when SplitView is true.

Syntax

Visual Basic (Declaration)
Public Property TargetView As TargetView
C#
public TargetView TargetView {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Toolbar Property

[image]
ActiveReports 13
Toolbar Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Toolbar Property

Glossary Item Box

Gets the reference to ToolbarObject of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Toolbar As Viewer.ViewerToolbar
C#
public Viewer.ViewerToolbar Toolbar {get;}

Property Value

ToolbarObject used for setting tool bar options of view.

Example

C# Copy Code
private ToolStripButton tsbPrint = new System.Windows.Forms.ToolStripButton();

        private void Form1_Load(object sender, EventArgs e)
        {
            System.Windows.Forms.ToolStrip toolStrip;
            System.Windows.Forms.ToolStripItem orgItem;
            System.Windows.Forms.ToolStripButton orgBtn = null;

            // Get the standard Print button, to get the image.
            toolStrip = this.viewer1.Toolbar.ToolStrip;
            orgItem = toolStrip.Items[2];
            if (orgItem is System.Windows.Forms.ToolStripButton)
            {
                orgBtn = (System.Windows.Forms.ToolStripButton)orgItem;
            }

            // Delete the standard Print button.
            toolStrip.Items.RemoveAt(2);

            // Add the Custom button, in place of the standard Print button.
            if (orgBtn == null)
            {
                tsbPrint.Text = "Print";
                tsbPrint.ToolTipText = "Print";
            }
            else
            {
                tsbPrint.Text = orgBtn.Text;
                tsbPrint.ToolTipText = orgBtn.ToolTipText;
                tsbPrint.Image = orgBtn.Image;
            }
            tsbPrint.Enabled = false;

            // Set the event handler of the Custom button.
            tsbPrint.Click += this.PrintButtonClick;

            // Add the custom button to the tool bar.
            toolStrip.Items.Insert(2, tsbPrint);
        }

        //Event to be called when the report is loaded in the Viewer.
        private void viewer1_LoadCompleted(object sender, EventArgs e)

        {
            // Enable the Custom button.
            tsbPrint.Enabled = true;
        }

        // Event to be called when the Custom button is clicked.
        private void PrintButtonClick(System.Object sender, System.EventArgs e)
        {
            // Perform the print processing.
            this.viewer1.Print(true, true, false);
        }
    }
}
VB.NET Copy Code
Private tsbPrint As New System.Windows.Forms.ToolStripButton

Private Sub Form1_Load(...) Handles MyBase.Load
    Dim toolStrip As System.Windows.Forms.ToolStrip
    Dim orgBtn As System.Windows.Forms.ToolStripButton = Nothing
    Dim orgItem As System.Windows.Forms.ToolStripItem

    ' Get the standard Print button, to get the image.
    toolStrip = Me.Viewer1.Toolbar.ToolStrip
    orgItem = toolStrip.Items(2)
    If TypeOf orgItem Is System.Windows.Forms.ToolStripButton Then
        orgBtn = CType(orgItem, ToolStripButton)
    End If

    ' Delete the standard Print button.。
    toolStrip.Items.RemoveAt(2)

    ' Add the Custom button, in place of the standard Print button.
    If orgBtn Is Nothing Then
        tsbPrint.Text = "Print"
        tsbPrint.ToolTipText = "Print"
    Else
        tsbPrint.Text = orgBtn.Text
        tsbPrint.ToolTipText = orgBtn.ToolTipText
        tsbPrint.Image = orgBtn.Image
    End If
    tsbPrint.Enabled = False

    ' Set the event handler of the Custom button.
    AddHandler tsbPrint.Click, AddressOf Me.PrintButtonClick

    ' Add the custom button to the tool bar.
    toolStrip.Items.Insert(2, tsbPrint)

End Sub

' Event to be called when the report is loaded in the Viewer.
Private Sub Viewer1_LoadCompleted(...) Handles Viewer1.LoadCompleted
    'Enable the Custom button.
    tsbPrint.Enabled = True
End Sub

' Event to be called when the Custom button is clicked.
Private Sub PrintButtonClick(ByVal sender As Object, ByVal e As System.EventArgs)
    ' Perform the print processing.
    Me.Viewer1.Print(True, True, False)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchContextMenuStrip Property

[image]
ActiveReports 13
TouchContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchContextMenuStrip Property

Glossary Item Box

Get or sets the context menu of touch enabled Viewer.

Syntax

Visual Basic (Declaration)
Public Property TouchContextMenuStrip As ToolStripDropDown
C#
public ToolStripDropDown TouchContextMenuStrip {get; set;}

Remarks

This property provides the ability to customize the context menu of the touch enabled Viewer.

Requirements

See Also

Reference

Viewer Class
Viewer Members


TouchMode Property

[image]
ActiveReports 13
TouchMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchMode Property

Glossary Item Box

Enable touch mode or not.

Syntax

Visual Basic (Declaration)
Public Property TouchMode As TouchMode
C#
public TouchMode TouchMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchModeButtonVisibility Property

[image]
ActiveReports 13
TouchModeButtonVisibility Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchModeButtonVisibility Property

Glossary Item Box

Display Touch mode button on viewer's toolbar or not.

Syntax

Visual Basic (Declaration)
Public Property TouchModeButtonVisibility As TouchModeButtonVisibility
C#
public TouchModeButtonVisibility TouchModeButtonVisibility {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchModeToolbar Property

[image]
ActiveReports 13
TouchModeToolbar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchModeToolbar Property

Glossary Item Box

Pubilc API for touch mode Toolbar manipulation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TouchModeToolbar As Viewer.ViewerToolbar
C#
public Viewer.ViewerToolbar TouchModeToolbar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UseHyperlinkSettings Property

[image]
ActiveReports 13
UseHyperlinkSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : UseHyperlinkSettings Property

Glossary Item Box

Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property UseHyperlinkSettings As Boolean
C#
public bool UseHyperlinkSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ViewType Property

[image]
ActiveReports 13
ViewType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ViewType Property

Glossary Item Box

Gets or sets a value that determines how the viewer shows pages(single/multi/continous).

Syntax

Visual Basic (Declaration)
Public Property ViewType As ViewType
C#
public ViewType ViewType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Zoom Property

[image]
ActiveReports 13
Zoom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Zoom Property

Glossary Item Box

Gets or sets the viewer's zoom level. 1 for FitWidth mode 2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Single
C#
public float Zoom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Events

[image]
ActiveReports 13
Viewer Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

Glossary Item Box

For a list of all members of this type, see Viewer members.

Public Events

 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | ErrorOccured | Fires in case of any error (in error panel etc.).
Public Event | Find | Occurs when the Find dialog finds the requested text in the document.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RefreshReport | Fires before report refreshes (right after opening of new report, toggling/sorting and drill-through actions, pressing of buttons: view report (parameters panel), galley mode, refresh, back to parent). In case of no error it fires before LoadCompleted event.
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TableOfContentsAfterSelect | Occurs after an item is selected in the table of contents treeview.
Public Event | TableOfContentsClick | Occurs when the user clicks an item in the table of contents treeview.
Public Event | TableOfContentsSelectedIndexChanged | Occurs when the index of the currently selected item in the table of contents changes.
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ZoomChanged | Occurs when the zoom has changed in the viewer.
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Action Event

[image]
ActiveReports 13
Action Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Action Event

Glossary Item Box

This event fires when report item with specified action was clicked in the report preview control.

Syntax

Visual Basic (Declaration)
Public Event Action As EventHandler(Of Viewer.ActionEventArgs)
C#
public event EventHandler<Viewer.ActionEventArgs> Action

Event Data

The event handler receives an argument of type Viewer.ActionEventArgs containing data related to this event. The following Viewer.ActionEventArgs properties provide information specific to this event.

Property | Description
Action | Specifies the action that should be performed in response to this event.
Cancel | (Inherited from System.ComponentModel.CancelEventArgs) (Inherited from System.ComponentModel.CancelEventArgs)
PageNumber | Specifies the page number in current layout tree that should be navigated to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ErrorOccured Event

[image]
ActiveReports 13
ErrorOccured Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ErrorOccured Event

Glossary Item Box

Fires in case of any error (in error panel etc.).

Syntax

Visual Basic (Declaration)
Public Event ErrorOccured As EventHandler(Of ErrorInfo)
C#
public event EventHandler<ErrorInfo> ErrorOccured

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Find Event

[image]
ActiveReports 13
Find Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Find Event

Glossary Item Box

Occurs when the Find dialog finds the requested text in the document.

Syntax

Visual Basic (Declaration)
Public Event Find As FindEventHandler
C#
public event FindEventHandler Find

Event Data

The event handler receives an argument of type FindEventArgs containing data related to this event. The following FindEventArgs properties provide information specific to this event.

Property | Description
Found | Gets the value that determines whether the text was found.
PageIndex | Gets the page number where the text was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperLink Event

[image]
ActiveReports 13
HyperLink Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperLink Event

Glossary Item Box

Occurs when the user clicks on text or an image that has a hyperlink assigned to it.

Syntax

Visual Basic (Declaration)
Public Event HyperLink As HyperLinkEventHandler
C#
public event HyperLinkEventHandler HyperLink

Event Data

The event handler receives an argument of type HyperLinkEventArgs containing data related to this event. The following HyperLinkEventArgs properties provide information specific to this event.

Property | Description
Button | Gets the mouse button that the user clicked to raise the event.
CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
HyperLink | Gets the hyperlink target.

Example

C# Copy Code
private void viewer1_HyperLink(object sender, GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs e)
{
    rptDrillDown1 rpt2 = new rptDrillDown1();
    frmViewDrillDown1 frm2 = new frmViewDrillDown1();
    rpt2.Parameters["customerID"].Value = e.HyperLink.ToString();
    rpt2.Run();
    frm2.viewer1.Document = rpt2.Document;
    frm2.ShowDialog(this);
}
Visual Basic Copy Code
Private Sub Viewer1_HyperLink(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Viewer.Win _
    HyperLinkEventArgs) Handles Viewer1.HyperLink
    Dim rpt2 As New rptDrillDown1()
    Dim frm2 As New frmViewDrillDown1()
    rpt2.Parameters("customerID").Value = e.HyperLink.ToString
    Console.WriteLine(rpt2.ds.SQL.ToString)
    rpt2.Run()
    frm2.Viewer1.Document = rpt2.Document
    frm2.ShowDialog(Me)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LoadCompleted Event

[image]
ActiveReports 13
LoadCompleted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LoadCompleted Event

Glossary Item Box

Occurs after all the viewer pages have been fully loaded.

Syntax

Visual Basic (Declaration)
Public Event LoadCompleted As LoadCompletedEventHandler
C#
public event LoadCompletedEventHandler LoadCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RefreshReport Event

[image]
ActiveReports 13
RefreshReport Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RefreshReport Event

Glossary Item Box

Fires before report refreshes (right after opening of new report, toggling/sorting and drill-through actions, pressing of buttons: view report (parameters panel), galley mode, refresh, back to parent). In case of no error it fires before LoadCompleted event.

Syntax

Visual Basic (Declaration)
Public Event RefreshReport As EventHandler
C#
public event EventHandler RefreshReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TableOfContentsAfterSelect Event

[image]
ActiveReports 13
TableOfContentsAfterSelect Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContentsAfterSelect Event

Glossary Item Box

Occurs after an item is selected in the table of contents treeview.

Syntax

Visual Basic (Declaration)
Public Event TableOfContentsAfterSelect As TreeViewEventHandler
C#
public event TreeViewEventHandler TableOfContentsAfterSelect

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the type of action that raised the event.
Node | Gets the tree node that has been checked, expanded, collapsed, or selected.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TableOfContentsClick Event

[image]
ActiveReports 13
TableOfContentsClick Event
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContentsClick Event

Glossary Item Box

Occurs when the user clicks an item in the table of contents treeview.

Syntax

Visual Basic (Declaration)
Public Event TableOfContentsClick As EventHandler
C#
public event EventHandler TableOfContentsClick

Example

C# Copy Code
private void arv_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = arv.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show("Boomark is on page" + arv.Document.Bookmarks[toc].PageNumber.ToString + "at a distance of" + arv.Document.Bookmarks[toc].Offset.ToString + "inches from the top.");
}
Visual Basic Copy Code
Private Sub arv_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = arv.Document.Bookmarks.CurrentBookmark
    MessageBox.Show("Boomark is on page" & arv.Document.Bookmarks(toc).PageNumber.ToString　& "at a distance of"　& arv.Document.Bookmarks(toc).Offset.ToString & "inches from the top.")
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TableOfContentsSelectedIndexChanged Event

[image]
ActiveReports 13
TableOfContentsSelectedIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContentsSelectedIndexChanged Event

Glossary Item Box

Occurs when the index of the currently selected item in the table of contents changes.

Syntax

Visual Basic (Declaration)
Public Event TableOfContentsSelectedIndexChanged As EventHandler
C#
public event EventHandler TableOfContentsSelectedIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ZoomChanged Event

[image]
ActiveReports 13
ZoomChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ZoomChanged Event

Glossary Item Box

Occurs when the zoom has changed in the viewer.

Syntax

Visual Basic (Declaration)
Public Event ZoomChanged As ZoomChangedEventHandler
C#
public event ZoomChangedEventHandler ZoomChanged

Event Data

The event handler receives an argument of type ZoomChangedEventArgs containing data related to this event. The following ZoomChangedEventArgs properties provide information specific to this event.

Property | Description
Zoom | Returns the viewer's new Zoom value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer.ActionEventArgs Class

[image]
ActiveReports 13
Viewer.ActionEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ActionEventArgs Class

Glossary Item Box

Provides data for Action event.

Object Model

Viewer.ActionEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class Viewer.ActionEventArgs
   Inherits System.ComponentModel.CancelEventArgs
C#
public class Viewer.ActionEventArgs : System.ComponentModel.CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Win.Viewer.ActionEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer.ActionEventArgs Class Members

[image]
ActiveReports 13
Viewer.ActionEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ActionEventArgs Class

Glossary Item Box

The following tables list the members exposed by Viewer.ActionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | Viewer.ActionEventArgs Constructor | Overloaded. Initializes a new instance of Viewer.ActionEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Action | Specifies the action that should be performed in response to this event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs) (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Specifies the page number in current layout tree that should be navigated to.
Top

See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer.ActionEventArgs Constructor

[image]
ActiveReports 13
Viewer.ActionEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : Viewer.ActionEventArgs Constructor

Glossary Item Box

Initializes a new instance of Viewer.ActionEventArgs class.

Overload List

Overload | Description
Viewer.ActionEventArgs Constructor() | Default ctor.
Viewer.ActionEventArgs Constructor(IAction) | Initalizes rendering event data with Action
Viewer.ActionEventArgs Constructor(IAction,Int32) | Initalizes rendering event data with Action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


Viewer.ActionEventArgs Constructor()

[image]
ActiveReports 13
Viewer.ActionEventArgs Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor()

Glossary Item Box

Default ctor.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Viewer.ActionEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Constructor(IAction)

[image]
ActiveReports 13
Viewer.ActionEventArgs Constructor(IAction)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor(IAction)

action
Action that should be performed in response to this event.

Glossary Item Box

Initalizes rendering event data with Action

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As IAction _
)
C#
public Viewer.ActionEventArgs(
   IAction action
)

Parameters

action
Action that should be performed in response to this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Constructor(IAction,Int32)

[image]
ActiveReports 13
Viewer.ActionEventArgs Constructor(IAction,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor(IAction,Int32)

action
Action that should be performed in response to this event.
pageNumber
The page number in current layout tree that should be navigated to.

Glossary Item Box

Initalizes rendering event data with Action

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As IAction, _
   ByVal pageNumber As Integer _
)
C#
public Viewer.ActionEventArgs(
   IAction action,
   int pageNumber
)

Parameters

action
Action that should be performed in response to this event.
pageNumber
The page number in current layout tree that should be navigated to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Class Properties

[image]
ActiveReports 13
Viewer.ActionEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ActionEventArgs Class

Glossary Item Box

For a list of all members of this type, see Viewer.ActionEventArgs members.

Public Properties

 | Name | Description
Public Property | Action | Specifies the action that should be performed in response to this event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs) (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Specifies the page number in current layout tree that should be navigated to.
Top

See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Action Property

[image]
ActiveReports 13
Action Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : Action Property

Glossary Item Box

Specifies the action that should be performed in response to this event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As IAction
C#
public IAction Action {get;}

Remarks

There could be no action defined for the event in that case PageNumber specifies page which should be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


PageNumber Property

[image]
ActiveReports 13
PageNumber Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : PageNumber Property

Glossary Item Box

Specifies the page number in current layout tree that should be navigated to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


Viewer.ViewerToolbar Class

[image]
ActiveReports 13
Viewer.ViewerToolbar Class
Members Example See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ViewerToolbar Class

Glossary Item Box

Gets the viewer toolbar object, allowing you to add and remove items on each of the component ToolStrips, and to implement tool click events for added items.

Object Model

Viewer.ViewerToolbar Class

Syntax

Visual Basic (Declaration)
Public Class Viewer.ViewerToolbar
C#
public class Viewer.ViewerToolbar

Remarks

Also see the System.Windows.Forms.ToolStripItemClickedEventArgs class and ClickedItem property on MSDN for more information on working with ToolStrips.

Example

To implement tool click events, use code like the following in the Form Load event of the form that contains the Viewer control, and then drop down the IntelliSense Generate Method Stub arrow to generate method stubs for the events.
C# code to use in the Form Load event
C# Copy Code
this.viewer1.Toolbar.NavigationBar.ItemClicked +=new ToolStripItemClickedEventHandler(NavigationBar_ItemClicked);
this.viewer1.Toolbar.MainBar.ItemClicked += new ToolStripItemClickedEventHandler(MainBar_ItemClicked);
this.viewer1.Toolbar.MouseModeBar.ItemClicked += new ToolStripItemClickedEventHandler(MouseModeBar_ItemClicked);
Visual Basic code to use in the Form Load event
VB.NET Copy Code
AddHandler me.Viewer1.Toolbar.NavigationBar.ItemClicked, AddressOf NavigationBar_ItemClicked
AddHandler me.Viewer1.Toolbar.MainBar.ItemClicked, AddressOf MainBar_ItemClicked
AddHandler me.Viewer1.Toolbar.MouseModeBar.ItemClicked, AddressOf MouseModeBar_ItemClicked

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Viewer.Win.Viewer.ViewerToolbar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ViewerToolbar Members
GrapeCity.ActiveReports.Viewer.Win Namespace
1cb59ebd-fc3b-4301-ab86-d63ff01caa6c
13672da7-5681-476c-9406-8578b99b9a68


Viewer.ViewerToolbar Class Members

[image]
ActiveReports 13
Viewer.ViewerToolbar Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ViewerToolbar Class

Glossary Item Box

The following tables list the members exposed by Viewer.ViewerToolbar.

Public Properties

 | Name | Description
Public Property | MainBar | The main tool strip in the Windows Forms Viewer control.
Public Property | MouseModeBar | The mouse mode tool strip in the Windows Forms Viewer control.
Public Property | NavigationBar | The navigation tool strip in the Windows Forms Viewer control.
Public Property | ToolStrip | Reference to the ToolStrip.
Top

See Also

Reference

Viewer.ViewerToolbar Class
GrapeCity.ActiveReports.Viewer.Win Namespace
1cb59ebd-fc3b-4301-ab86-d63ff01caa6c
13672da7-5681-476c-9406-8578b99b9a68


Viewer.ViewerToolbar Class Properties

[image]
ActiveReports 13
Viewer.ViewerToolbar Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ViewerToolbar Class

Glossary Item Box

For a list of all members of this type, see Viewer.ViewerToolbar members.

Public Properties

 | Name | Description
Public Property | MainBar | The main tool strip in the Windows Forms Viewer control.
Public Property | MouseModeBar | The mouse mode tool strip in the Windows Forms Viewer control.
Public Property | NavigationBar | The navigation tool strip in the Windows Forms Viewer control.
Public Property | ToolStrip | Reference to the ToolStrip.
Top

See Also

Reference

Viewer.ViewerToolbar Class
GrapeCity.ActiveReports.Viewer.Win Namespace
1cb59ebd-fc3b-4301-ab86-d63ff01caa6c
13672da7-5681-476c-9406-8578b99b9a68


MainBar Property

[image]
ActiveReports 13
MainBar Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : MainBar Property

Glossary Item Box

The main tool strip in the Windows Forms Viewer control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MainBar As ToolStrip
C#
public ToolStrip MainBar {get;}

Remarks

Items on this toolstrip and their index numbers:

  • 0 Toggle sidebar
  • 1 Separator
  • 2 Print
  • 3 Galley mode
  • 4 Separator
  • 5 Copy
  • 6 Find
  • 7 Separator
  • 8 Zoom out
  • 9 Current zoom
  • 10 Zoom in
  • 11 Separator
  • 12 Fit width
  • 13 Fit page
  • 14 Separator
  • 15 Single page view
  • 16 Continuous view
  • 17 Multipage view
  • 18 Refresh
  • 19 Cancel

You can access these items by index with the Insert and RemoveAt methods. Other methods are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

Example

This code removes the print button and replaces it with one that calls a custom print dialog.
C# Copy Code
private void Form1_Load(object sender, EventArgs e)
      {
          //Remove the print button.
          viewer1.Toolbar.MainBar.Items.RemoveAt(2);
          //Remove the extra separator.
          viewer1.Toolbar.MainBar.Items.RemoveAt(1);
          //Add a new button to the end of the main bar with the caption "Print."
          ToolStripButton tsbPrint = new ToolStripButton("Print");
          viewer1.Toolbar.MainBar.Items.Add(tsbPrint);
          //Create a click event handler for the button.
          tsbPrint.Click += new EventHandler(tsbPrint_Click);

          SectionReport1 rpt = new SectionReport1();
          viewer1.LoadDocument(rpt);

      }

      //Call the custom dialog from the new button's click event.
      void tsbPrint_Click(object sender, EventArgs e)
      {
          this.CustomPrint();
      }

//Call the custom print dialog.
      private void CustomPrint()
      {
          frmPrintDlg _printForm = new frmPrintDlg();
          _printForm.ShowDialog(this);
      }
VB.NET Copy Code
Private Sub Form1_Load(sender As System.Object, e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New SectionReport1
    Viewer1.LoadDocument(rpt)

    'Remove the print button.
    Viewer1.Toolbar.MainBar.Items.RemoveAt(2)
    'Remove the extra separator.
    Viewer1.Toolbar.MainBar.Items.RemoveAt(1)
    'Add a new button to the end of the main bar with the caption "Print."
    Dim tsbPrint As New ToolStripButton("Print")
    Viewer1.Toolbar.MainBar.Items.Add(tsbPrint)
    'Create a click event handler for the button.
    AddHandler tsbPrint.Click, AddressOf tsbPrint_Click
End Sub

'Call the custom dialog from the new button's click event.
Private Sub tsbPrint_Click(sender As Object, e As EventArgs)
    Me.CustomPrint()
End Sub

'Call the custom print dialog.
Private Sub CustomPrint()
    Dim _printForm As New frmPrintDlg()
    _printForm.ShowDialog(Me)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


MouseModeBar Property

[image]
ActiveReports 13
MouseModeBar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : MouseModeBar Property

Glossary Item Box

The mouse mode tool strip in the Windows Forms Viewer control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MouseModeBar As ToolStrip
C#
public ToolStrip MouseModeBar {get;}

Remarks

Items on this toolstrip and their index numbers:

  • 0 Default
  • 1 Pan mode
  • 2 Selection mode

You can access these items by index with the Insert and RemoveAt methods. Other methods are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


NavigationBar Property

[image]
ActiveReports 13
NavigationBar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : NavigationBar Property

Glossary Item Box

The navigation tool strip in the Windows Forms Viewer control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NavigationBar As ToolStrip
C#
public ToolStrip NavigationBar {get;}

Remarks

Items on this toolstrip and their index numbers:

  • 0 First page
  • 1 Previous page
  • 2 Current page
  • 3 Next page
  • 4 Last page
  • 5 Separator
  • 6 Backward
  • 7 Forward
  • 8 Separator
  • 9 Back to parent report

You can access these items by index with the Insert and RemoveAt methods. Other methods are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


ToolStrip Property

[image]
ActiveReports 13
ToolStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : ToolStrip Property

Glossary Item Box

Reference to the ToolStrip.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToolStrip As ToolStrip
C#
public ToolStrip ToolStrip {get;}

Remarks

It is only for mouse mode toolbar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


ZoomChangedEventArgs Class

[image]
ActiveReports 13
ZoomChangedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventArgs Class

Glossary Item Box

Provides data for the ZoomChanged event.

Object Model

ZoomChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ZoomChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class ZoomChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.ZoomChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomChangedEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChangedEventArgs Class Members

[image]
ActiveReports 13
ZoomChangedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ZoomChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ZoomChangedEventArgs Constructor | Overloaded. Initializes a new instance of ZoomChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Zoom | Returns the viewer's new Zoom value.
Top

See Also

Reference

ZoomChangedEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChangedEventArgs Constructor

[image]
ActiveReports 13
ZoomChangedEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class : ZoomChangedEventArgs Constructor

Glossary Item Box

Initializes a new instance of ZoomChangedEventArgs class.

Overload List

Overload | Description
ZoomChangedEventArgs Constructor(Double) | Initializes an instance of the ZoomChangedEventArgs class and sets the Zoom property value.
ZoomChangedEventArgs Constructor() | Initializes a new instance of the ZoomChangedEventArgs class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members


ZoomChangedEventArgs Constructor(Double)

[image]
ActiveReports 13
ZoomChangedEventArgs Constructor(Double)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class > ZoomChangedEventArgs Constructor : ZoomChangedEventArgs Constructor(Double)

zoom
Specifies the new zoom value.

Glossary Item Box

Initializes an instance of the ZoomChangedEventArgs class and sets the Zoom property value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal zoom As Double _
)
C#
public ZoomChangedEventArgs(
   double zoom
)

Parameters

zoom
Specifies the new zoom value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members
Overload List


ZoomChangedEventArgs Constructor()

[image]
ActiveReports 13
ZoomChangedEventArgs Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class > ZoomChangedEventArgs Constructor : ZoomChangedEventArgs Constructor()

Glossary Item Box

Initializes a new instance of the ZoomChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ZoomChangedEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members
Overload List


ZoomChangedEventArgs Class Properties

[image]
ActiveReports 13
ZoomChangedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ZoomChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Zoom | Returns the viewer's new Zoom value.
Top

See Also

Reference

ZoomChangedEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Zoom Property

[image]
ActiveReports 13
Zoom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class : Zoom Property

Glossary Item Box

Returns the viewer's new Zoom value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Zoom As Double
C#
public double Zoom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members


TargetView Enumeration

[image]
ActiveReports 13
TargetView Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TargetView Enumeration

Glossary Item Box

Determines the current active view in the viewer.

Syntax

Visual Basic (Declaration)
Public Enum TargetView
   Inherits System.Enum
C#
public enum TargetView : System.Enum

Members

Member | Description
Primary | The primary (Bottom) view is the active view.
Secondary | The secondary (Upper) view is the active view.

Remarks

The viewer can be split into two views using the splitter. This enumeration determines which view will be effected by methods and property calls.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Viewer.Win.TargetView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Viewer.Win Namespace


FindEventHandler Delegate

[image]
ActiveReports 13
FindEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventHandler Delegate

sender
The source of the event.
e
A FindEventArgs that contains the event data.

Glossary Item Box

Represents the method that will handle the Find click event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub FindEventHandler( _
   ByVal sender As Object, _
   ByVal e As FindEventArgs _
)
C#
public delegate void FindEventHandler(
   object sender,
   FindEventArgs e
)

Parameters

sender
The source of the event.
e
A FindEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindEventHandler Members
GrapeCity.ActiveReports.Viewer.Win Namespace


HyperLinkEventHandler Delegate

[image]
ActiveReports 13
HyperLinkEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventHandler Delegate

sender
The source of the event.
e
A HyperLinkEventArgs that contains the event data.

Glossary Item Box

Represents the method that will handle the HyperLink click event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub HyperLinkEventHandler( _
   ByVal sender As Object, _
   ByVal e As HyperLinkEventArgs _
)
C#
public delegate void HyperLinkEventHandler(
   object sender,
   HyperLinkEventArgs e
)

Parameters

sender
The source of the event.
e
A HyperLinkEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperLinkEventHandler Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChangedEventHandler Delegate

[image]
ActiveReports 13
ZoomChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventHandler Delegate

sender
The source of the event.
e
A ZoomChangedEventArgs that contains the event data.

Glossary Item Box

Represents the method that will handle the zoom click event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ZoomChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ZoomChangedEventArgs _
)
C#
public delegate void ZoomChangedEventHandler(
   object sender,
   ZoomChangedEventArgs e
)

Parameters

sender
The source of the event.
e
A ZoomChangedEventArgs that contains the event data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ZoomChangedEventHandler Members
GrapeCity.ActiveReports.Viewer.Win Namespace


GrapeCity.ActiveReports.Viewer.Wpf Namespace

GrapeCity.ActiveReports.Viewer.Wpf Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly : GrapeCity.ActiveReports.Viewer.Wpf Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Viewer.Wpf namepace contains the WPF viewer control and related types.

Classes

 | Class | Description
Class | ParametersPanel | Manages the viewer's parameters panel properties.
Class | SearchPanel | Manages the viewer's search panel properties.
Class | Sidebar | Represents the sidebar of the Viewer.
Class | SidebarPanel | Exposes public properties of the sidebar panels.
Class | ThumbnailsPanel | Manages the viewer's thumbnails panel properties.
Class | TocPanel | Manages the viewer's table of contents panel properties.
Class | Viewer | The WPF based report Viewer control. The WPF Viewer control is used to preview report documents.
Class | Viewer.ActionEventArgs | Provides data for Action event.

Enumerations

 | Enumeration | Description
Enumeration | TargetView | Determines the current active view in the viewer.

See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf Assembly


ParametersPanel Class

[image]
ActiveReports 13
ParametersPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

Glossary Item Box

Manages the viewer's parameters panel properties.

Object Model

ParametersPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParametersPanel
   Inherits SidebarPanel
C#
public sealed class ParametersPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ParametersPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ParametersPanel Class Members

[image]
ActiveReports 13
ParametersPanel Class Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

Glossary Item Box

The following tables list the members exposed by ParametersPanel.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's parameters panel is visible.
Top

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets a value that determines whether the viewer's panel of parameters is visible.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the parameters panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the panel of parameters to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ParametersPanel Class Methods

[image]
ActiveReports 13
ParametersPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

Glossary Item Box

For a list of all members of this type, see ParametersPanel members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the parameters panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the panel of parameters to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Dispose Method

Glossary Item Box

Releases the resources used by the parameters panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Dispose()
C#
public override void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Refresh Method

Glossary Item Box

Forces the panel of parameters to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Refresh()
C#
public override void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ParametersPanel Class Properties

[image]
ActiveReports 13
ParametersPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

Glossary Item Box

For a list of all members of this type, see ParametersPanel members.

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets a value that determines whether the viewer's panel of parameters is visible.
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Enabled Property

Glossary Item Box

Gets or sets the value that determines whether the viewer's parameters panel is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Text Property

Glossary Item Box

Gets or sets the text.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Property Value

The text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Visible Property

Glossary Item Box

Gets or sets a value that determines whether the viewer's panel of parameters is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ParametersPanel Class Fields

[image]
ActiveReports 13
ParametersPanel Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

Glossary Item Box

For a list of all members of this type, see ParametersPanel members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's parameters panel is visible.
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field

[image]
ActiveReports 13
EnabledProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : EnabledProperty Field

Glossary Item Box

Gets or sets the value that determines whether the viewer's parameters panel is enabled.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly EnabledProperty As DependencyProperty
C#
public static readonly DependencyProperty EnabledProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


VisibleProperty Field

[image]
ActiveReports 13
VisibleProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : VisibleProperty Field

Glossary Item Box

Gets or sets the value that determines whether the viewer's parameters panel is visible.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VisibleProperty As DependencyProperty
C#
public static readonly DependencyProperty VisibleProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


SearchPanel Class

[image]
ActiveReports 13
SearchPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

Glossary Item Box

Manages the viewer's search panel properties.

Object Model

SearchPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SearchPanel
   Inherits SidebarPanel
C#
public sealed class SearchPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.SearchPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SearchPanel Class Members

[image]
ActiveReports 13
SearchPanel Class Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

Glossary Item Box

The following tables list the members exposed by SearchPanel.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's search panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's search panel is visible.
Top

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's search panel is enabled.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets the value that determines whether the viewer's search panel is visible.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the search panel.
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the search panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SearchPanel Class Methods

[image]
ActiveReports 13
SearchPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

Glossary Item Box

For a list of all members of this type, see SearchPanel members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the search panel.
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the search panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Clear Method

Glossary Item Box

Clears the search panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Dispose Method

Glossary Item Box

Releases the resources used by the search panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Dispose()
C#
public override void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


SearchPanel Class Properties

[image]
ActiveReports 13
SearchPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

Glossary Item Box

For a list of all members of this type, see SearchPanel members.

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's search panel is enabled.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets the value that determines whether the viewer's search panel is visible.
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Enabled Property

Glossary Item Box

Gets or sets the value that determines whether the viewer's search panel is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Text Property

Glossary Item Box

Gets or sets the text.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Visible Property

Glossary Item Box

Gets or sets the value that determines whether the viewer's search panel is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


SearchPanel Class Fields

[image]
ActiveReports 13
SearchPanel Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

Glossary Item Box

For a list of all members of this type, see SearchPanel members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's search panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's search panel is visible.
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field

[image]
ActiveReports 13
EnabledProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : EnabledProperty Field

Glossary Item Box

Gets or sets the value that determines whether the viewer's search panel is enabled.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly EnabledProperty As DependencyProperty
C#
public static readonly DependencyProperty EnabledProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


VisibleProperty Field

[image]
ActiveReports 13
VisibleProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : VisibleProperty Field

Glossary Item Box

Gets or sets the value that determines whether the viewer's search panel is visible.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VisibleProperty As DependencyProperty
C#
public static readonly DependencyProperty VisibleProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Sidebar Class

[image]
ActiveReports 13
Sidebar Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

Glossary Item Box

Represents the sidebar of the Viewer.

Object Model

Sidebar Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Sidebar
   Inherits System.Windows.DependencyObject
C#
public sealed class Sidebar : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.Sidebar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Sidebar Class Members

[image]
ActiveReports 13
Sidebar Class Members
See Also Fields Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

Glossary Item Box

The following tables list the members exposed by Sidebar.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SelectedIndexProperty | Sets or returns the index of the currently selected panel of the sidebar.
static (Shared in Visual Basic) | WidthProperty | Gets or sets the width of the sidebar, in pixels.
Top

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | ParametersPanel | Gets the parameters panel component of sidebar.
Public Property | SearchPanel | Gets the search panel component of sidebar.
Public Property | SelectedIndex | Sets or returns the index of the currently selected panel of the sidebar.
Public Property | ThumbnailsPanel | Gets the thumbnail panel component of sidebar.
Public Property | TocPanel | Gets the table of content panel component of sidebar.
Public Property | Width | Gets or sets the width of the sidebar, in pixels.
Top

Public Methods

 | Name | Description
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Public Method | ToggleVisibility | Toggles the visibility of the viewer's sidebar.
Top

Public Events

 | Name | Description
Public Event | SelectedIndexChanged | Raises when the selected panel of the sidebar is changed.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Sidebar Class Methods

[image]
ActiveReports 13
Sidebar Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Methods

 | Name | Description
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Public Method | ToggleVisibility | Toggles the visibility of the viewer's sidebar.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Dispose Method

Glossary Item Box

Releases the resources used by the sidebar.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ToggleVisibility Method

[image]
ActiveReports 13
ToggleVisibility Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ToggleVisibility Method

Glossary Item Box

Toggles the visibility of the viewer's sidebar.

Syntax

Visual Basic (Declaration)
Public Sub ToggleVisibility()
C#
public void ToggleVisibility()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Properties

[image]
ActiveReports 13
Sidebar Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | ParametersPanel | Gets the parameters panel component of sidebar.
Public Property | SearchPanel | Gets the search panel component of sidebar.
Public Property | SelectedIndex | Sets or returns the index of the currently selected panel of the sidebar.
Public Property | ThumbnailsPanel | Gets the thumbnail panel component of sidebar.
Public Property | TocPanel | Gets the table of content panel component of sidebar.
Public Property | Width | Gets or sets the width of the sidebar, in pixels.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ParametersPanel Property

[image]
ActiveReports 13
ParametersPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ParametersPanel Property

Glossary Item Box

Gets the parameters panel component of sidebar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParametersPanel As ParametersPanel
C#
public ParametersPanel ParametersPanel {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SearchPanel Property

[image]
ActiveReports 13
SearchPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SearchPanel Property

Glossary Item Box

Gets the search panel component of sidebar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SearchPanel As SearchPanel
C#
public SearchPanel SearchPanel {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SelectedIndex Property

[image]
ActiveReports 13
SelectedIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SelectedIndex Property

Glossary Item Box

Sets or returns the index of the currently selected panel of the sidebar.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
C#
public int SelectedIndex {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Property

[image]
ActiveReports 13
ThumbnailsPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ThumbnailsPanel Property

Glossary Item Box

Gets the thumbnail panel component of sidebar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ThumbnailsPanel As ThumbnailsPanel
C#
public ThumbnailsPanel ThumbnailsPanel {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


TocPanel Property

[image]
ActiveReports 13
TocPanel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : TocPanel Property

Glossary Item Box

Gets the table of content panel component of sidebar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TocPanel As TocPanel
C#
public TocPanel TocPanel {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Width Property

Glossary Item Box

Gets or sets the width of the sidebar, in pixels.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Fields

[image]
ActiveReports 13
Sidebar Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SelectedIndexProperty | Sets or returns the index of the currently selected panel of the sidebar.
static (Shared in Visual Basic) | WidthProperty | Gets or sets the width of the sidebar, in pixels.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SelectedIndexProperty Field

[image]
ActiveReports 13
SelectedIndexProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SelectedIndexProperty Field

Glossary Item Box

Sets or returns the index of the currently selected panel of the sidebar.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty
C#
public static readonly DependencyProperty SelectedIndexProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


WidthProperty Field

[image]
ActiveReports 13
WidthProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : WidthProperty Field

Glossary Item Box

Gets or sets the width of the sidebar, in pixels.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly WidthProperty As DependencyProperty
C#
public static readonly DependencyProperty WidthProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Events

[image]
ActiveReports 13
Sidebar Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

Glossary Item Box

For a list of all members of this type, see Sidebar members.

Public Events

 | Name | Description
Public Event | SelectedIndexChanged | Raises when the selected panel of the sidebar is changed.
Top

See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SelectedIndexChanged Event

[image]
ActiveReports 13
SelectedIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SelectedIndexChanged Event

Glossary Item Box

Raises when the selected panel of the sidebar is changed.

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChanged As EventHandler
C#
public event EventHandler SelectedIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SidebarPanel Class

[image]
ActiveReports 13
SidebarPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class

Glossary Item Box

Exposes public properties of the sidebar panels.

Object Model

SidebarPanel Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class SidebarPanel
   Inherits System.Windows.DependencyObject
C#
public abstract class SidebarPanel : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ParametersPanel
GrapeCity.ActiveReports.Viewer.Wpf.SearchPanel
GrapeCity.ActiveReports.Viewer.Wpf.ThumbnailsPanel
GrapeCity.ActiveReports.Viewer.Wpf.TocPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SidebarPanel Class Members

[image]
ActiveReports 13
SidebarPanel Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class

Glossary Item Box

The following tables list the members exposed by SidebarPanel.

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Gets or sets the text to be displayed in sidebar.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the sidebar panel.
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

SidebarPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SidebarPanel Class Methods

[image]
ActiveReports 13
SidebarPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class

Glossary Item Box

For a list of all members of this type, see SidebarPanel members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the sidebar panel.
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

SidebarPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Clear Method

Glossary Item Box

Clears the sidebar panel.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Dispose Method

Glossary Item Box

Releases the resources used by the sidebar panel.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Dispose()
C#
public abstract void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Refresh Method

Glossary Item Box

Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


SidebarPanel Class Properties

[image]
ActiveReports 13
SidebarPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class

Glossary Item Box

For a list of all members of this type, see SidebarPanel members.

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Gets or sets the text to be displayed in sidebar.
Top

See Also

Reference

SidebarPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Text Property

Glossary Item Box

Gets or sets the text to be displayed in sidebar.

Syntax

Visual Basic (Declaration)
Public Overridable Property Text As String
C#
public virtual string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


ThumbnailsPanel Class

[image]
ActiveReports 13
ThumbnailsPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

Glossary Item Box

Manages the viewer's thumbnails panel properties.

Object Model

ThumbnailsPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ThumbnailsPanel
   Inherits SidebarPanel
C#
public sealed class ThumbnailsPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ThumbnailsPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ThumbnailsPanel Class Members

[image]
ActiveReports 13
ThumbnailsPanel Class Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

Glossary Item Box

The following tables list the members exposed by ThumbnailsPanel.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the thumbnails panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ThumbnailsPanel Class Methods

[image]
ActiveReports 13
ThumbnailsPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

Glossary Item Box

For a list of all members of this type, see ThumbnailsPanel members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the thumbnails panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Dispose Method

Glossary Item Box

Releases the resources used by the thumbnails panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Dispose()
C#
public override void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ThumbnailsPanel Class Properties

[image]
ActiveReports 13
ThumbnailsPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

Glossary Item Box

For a list of all members of this type, see ThumbnailsPanel members.

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Enabled Property

Glossary Item Box

Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Text Property

Glossary Item Box

Gets or sets the text of the panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Visible Property

Glossary Item Box

Gets or sets the value that determines whether the viewer's thumbnails panel is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ThumbnailsPanel Class Fields

[image]
ActiveReports 13
ThumbnailsPanel Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

Glossary Item Box

For a list of all members of this type, see ThumbnailsPanel members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field

[image]
ActiveReports 13
EnabledProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : EnabledProperty Field

Glossary Item Box

Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly EnabledProperty As DependencyProperty
C#
public static readonly DependencyProperty EnabledProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


VisibleProperty Field

[image]
ActiveReports 13
VisibleProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : VisibleProperty Field

Glossary Item Box

Gets or sets the value that determines whether the viewer's thumbnails panel is visible.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VisibleProperty As DependencyProperty
C#
public static readonly DependencyProperty VisibleProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


TocPanel Class

[image]
ActiveReports 13
TocPanel Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

Glossary Item Box

Manages the viewer's table of contents panel properties.

Object Model

TocPanel Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TocPanel
   Inherits SidebarPanel
C#
public sealed class TocPanel : SidebarPanel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.TocPanel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


TocPanel Class Members

[image]
ActiveReports 13
TocPanel Class Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

Glossary Item Box

The following tables list the members exposed by TocPanel.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
static (Shared in Visual Basic) | ExpandedProperty | Expanded binding property
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | SelectedItem | Sets or returns the currently selected item in the table of contents.
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the table of contents panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


TocPanel Class Methods

[image]
ActiveReports 13
TocPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

Glossary Item Box

For a list of all members of this type, see TocPanel members.

Public Methods

 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the table of contents panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Clear Method

Glossary Item Box

Clears the table of contents panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Clear()
C#
public override void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Dispose Method

Glossary Item Box

Releases the resources used by the table of contents panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Dispose()
C#
public override void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Refresh Method

Glossary Item Box

Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Refresh()
C#
public override void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


TocPanel Class Properties

[image]
ActiveReports 13
TocPanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

Glossary Item Box

For a list of all members of this type, see TocPanel members.

Public Properties

 | Name | Description
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | SelectedItem | Sets or returns the currently selected item in the table of contents.
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Enabled Property

Glossary Item Box

Gets or sets the value determines whether the viewer's table of contents panel is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Expanded Property

[image]
ActiveReports 13
Expanded Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Expanded Property

Glossary Item Box

Gets or sets a value that indicates whether the TocPanel is expanded.

Syntax

Visual Basic (Declaration)
Public Property Expanded As Boolean
C#
public bool Expanded {get; set;}

Property Value

true if expanded; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


SelectedItem Property

[image]
ActiveReports 13
SelectedItem Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SelectedItem Property

Glossary Item Box

Sets or returns the currently selected item in the table of contents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedItem As Object
C#
public object SelectedItem {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Text Property

Glossary Item Box

Gets or sets the text of the panel.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Text As String
C#
public override string Text {get; set;}

Property Value

The text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Visible Property

Glossary Item Box

Gets or sets the value determines whether the viewer's table of contents panel is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


TocPanel Class Fields

[image]
ActiveReports 13
TocPanel Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

Glossary Item Box

For a list of all members of this type, see TocPanel members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
static (Shared in Visual Basic) | ExpandedProperty | Expanded binding property
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field

[image]
ActiveReports 13
EnabledProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : EnabledProperty Field

Glossary Item Box

Gets or sets the value determines whether the viewer's table of contents panel is enabled.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly EnabledProperty As DependencyProperty
C#
public static readonly DependencyProperty EnabledProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


ExpandedProperty Field

[image]
ActiveReports 13
ExpandedProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : ExpandedProperty Field

Glossary Item Box

Expanded binding property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ExpandedProperty As DependencyProperty
C#
public static readonly DependencyProperty ExpandedProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


VisibleProperty Field

[image]
ActiveReports 13
VisibleProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : VisibleProperty Field

Glossary Item Box

Gets or sets the value determines whether the viewer's table of contents panel is visible.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly VisibleProperty As DependencyProperty
C#
public static readonly DependencyProperty VisibleProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Viewer Class

[image]
ActiveReports 13
Viewer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

Glossary Item Box

The WPF based report Viewer control. The WPF Viewer control is used to preview report documents.

Object Model

Viewer Class

Syntax

Visual Basic (Declaration)
Public Class Viewer
   Inherits System.Windows.Controls.Control
C#
public class Viewer : System.Windows.Controls.Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
GrapeCity.ActiveReports.Viewer.Wpf.Viewer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer Class Members

[image]
ActiveReports 13
Viewer Class Members
See Also Fields Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

Glossary Item Box

The following tables list the members exposed by Viewer.

Public Constructors

 | Name | Description
Public Constructor | Viewer Constructor | Initializes the new instance of Viewer class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AllowSplitterProperty | Gets or sets a value that determines whether the user is allowed to split the view.
static (Shared in Visual Basic) | HyperlinkBackColorProperty | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkForeColorProperty | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkUnderlineProperty | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
static (Shared in Visual Basic) | MultiplePageColsProperty | MultiplePageCols binding property
static (Shared in Visual Basic) | MultiplePageRowsProperty | MultiplePageRows binding property
static (Shared in Visual Basic) | PageOffsetProperty | Gets or sets the location of the page in the viewer.
static (Shared in Visual Basic) | PagesBackColorProperty | Public API for background color of report pane.
static (Shared in Visual Basic) | PreviewPagesProperty | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances.
static (Shared in Visual Basic) | PrintingSettingsProperty | DesignPrintingSettings binding property
static (Shared in Visual Basic) | RepositionPageProperty | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
static (Shared in Visual Basic) | ScrollbarEnabledProperty | Public API. Show or hide scrolls within report pane.
static (Shared in Visual Basic) | SearchResultsBackColorProperty | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SearchResultsForeColorProperty | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SourceFormatProperty | SourceFormat Dependency Property
static (Shared in Visual Basic) | SourceProperty | Source Dependency Property
static (Shared in Visual Basic) | SplitViewProperty | Gets or sets a value that determines whether the viewer is split into two views.
static (Shared in Visual Basic) | TargetViewProperty | Gets or sets a value that specifies the current target view when SplitView is true.
static (Shared in Visual Basic) | UseHyperlinkSettingsProperty | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
static (Shared in Visual Basic) | ViewTypeProperty | ViewType binding property
static (Shared in Visual Basic) | ZoomProperty | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top

Public Properties

 | Name | Description
Public Property | ActualHeight | Gets the rendered height of this element. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of this element. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that describes the background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BindingGroup | Gets or sets the System.Windows.Data.BindingGroup that is used for the element. (Inherited from System.Windows.FrameworkElement)
Public Property | BitmapEffect | Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | BitmapEffectInput | Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a cached representation of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | CanExport | Indicates whether the loaded report can be exported or not. Returns "false" if export is not permitted.
Public Property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | CommandBindings | Gets a collection of System.Windows.Input.CommandBinding objects associated with this element. A System.Windows.Input.CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from System.Windows.UIElement)
Public Property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from System.Windows.FrameworkElement)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Effect | Gets or sets the bitmap effect to apply to the System.Windows.UIElement. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font family of the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the font size. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the font style. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | ForceCursor | Gets or sets a value that indicates whether this System.Windows.FrameworkElement should force the user interface (UI) to render the cursor as declared by the System.Windows.FrameworkElement.Cursor property. (Inherited from System.Windows.FrameworkElement)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from System.Windows.UIElement)
Public Property | Height | Gets or sets the suggested height of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from System.Windows.UIElement)
Public Property | InputScope | Gets or sets the context for input used by this System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from System.Windows.UIElement)
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its System.Windows.FrameworkElement.EndInit method called. (Inherited from System.Windows.FrameworkElement)
Public Property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from System.Windows.FrameworkElement)
Public Property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from System.Windows.FrameworkElement)
Public Property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of an element. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MultiplePageCols | Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.
Public Property | MultiplePageRows | Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.
Public Property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the opacity factor applied to the entire System.Windows.UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets an opacity mask, as a System.Windows.Media.Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from System.Windows.FrameworkElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | PageOffset | Gets or sets the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | Gets the logical parent element of this element. (Inherited from System.Windows.FrameworkElement)
Public Property | PersistId | Gets a value that uniquely identifies this element. (Inherited from System.Windows.UIElement)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from System.Windows.FrameworkElement)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | Source | Specifies the local/remote report source Uri to display the report in Viewer (i.e. 'http://www.mysite.com/invoice.rpx')
Public Property | SourceFormat | Specifies the format of the report source Uri. Should be used when Source does not have an extension.
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TableOfContents | Gets the table of contents panel component of sidebar component.
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from System.Windows.FrameworkElement)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from System.Windows.FrameworkElement)
Public Property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from System.Windows.FrameworkElement)
Public Property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from System.Windows.UIElement)
Public Property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from System.Windows.UIElement)
Public Property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from System.Windows.FrameworkElement)
Public Property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | ViewType | Gets or sets a value that determines how the viewer shows pages(single/multi/continous).
Public Property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | Zoom | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top

Public Methods

 | Name | Description
Public Method | AddHandler | Overloaded. Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from System.Windows.UIElement)
Public Method | AddToEventRoute | Adds handlers to the specified System.Windows.EventRoute for the current System.Windows.UIElement event handler collection. (Inherited from System.Windows.UIElement)
Public Method | ApplyAnimationClock | Overloaded. Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from System.Windows.FrameworkElement)
Public Method | Arrange | Positions child elements and determines a size for a System.Windows.UIElement. Parent elements call this method from their System.Windows.UIElement.ArrangeCore(System.Windows.Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from System.Windows.UIElement)
Public Method | BeginAnimation | Overloaded. Starts an animation for a specified animated property on this element. (Inherited from System.Windows.UIElement)
Public Method | BeginInit | Starts the initialization process for this element. (Inherited from System.Windows.FrameworkElement)
Public Method | BeginStoryboard | Overloaded. Begins the sequence of actions that are contained in the provided storyboard. (Inherited from System.Windows.FrameworkElement)
Public Method | BringIntoView | Overloaded. Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from System.Windows.FrameworkElement)
Public Method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from System.Windows.UIElement)
Public Method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from System.Windows.UIElement)
Public Method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by Viewer control.
Public Method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from System.Windows.FrameworkElement)
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from System.Windows.Media.Visual)
Public Method | FindName | Finds an element that has the provided identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set focus to this element. (Inherited from System.Windows.UIElement)
Public Method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from System.Windows.UIElement)
Public Method | GetBindingExpression | Returns the System.Windows.Data.BindingExpression that represents the binding on the specified property. (Inherited from System.Windows.FrameworkElement)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | HandleError | Reports about runtime error
Public Method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from System.Windows.UIElement)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by System.Windows.UIElement.UpdateLayout. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from System.Windows.UIElement)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. System.Windows.UIElement.OnRender(System.Windows.Media.DrawingContext) is called after the layout cycle is completed. (Inherited from System.Windows.UIElement)
Public Method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from System.Windows.Media.Visual)
Public Method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from System.Windows.Media.Visual)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Parent elements call this method from their own System.Windows.UIElement.MeasureCore(System.Windows.Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from System.Windows.UIElement)
Public Method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from System.Windows.FrameworkElement)
Public Method | PointFromScreen | Converts a System.Windows.Point in screen coordinates into a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual. (Inherited from System.Windows.Media.Visual)
Public Method | PointToScreen | Converts a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual into a System.Windows.Point in screen coordinates. (Inherited from System.Windows.Media.Visual)
Public Method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from System.Windows.FrameworkElement)
Public Method | Print | Overloaded. Prints the currently opened document(section or page)
Public Method | RaiseEvent | Raises a specific routed event. The System.Windows.RoutedEvent to be raised is identified within the System.Windows.RoutedEventArgs instance that is provided (as the System.Windows.RoutedEventArgs.RoutedEvent property of that event data). (Inherited from System.Windows.UIElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | RegisterName | Provides an accessor that simplifies access to the System.Windows.NameScope registration method. (Inherited from System.Windows.FrameworkElement)
Public Method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from System.Windows.UIElement)
Public Method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from System.Windows.UIElement)
Public Method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from System.Windows.UIElement)
Public Method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | (Inherited from System.Windows.UIElement)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | SetBinding | Overloaded. Attaches a binding to this element, based on the provided binding object. (Inherited from System.Windows.FrameworkElement)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetParametersValues | Sets values of parameters for the report that is shown.
Public Method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Public Method | ToString | Returns the string representation of a System.Windows.Controls.Control object. (Inherited from System.Windows.Controls.Control)
Public Method | TransformToAncestor | Overloaded. Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Visual ancestor of the visual object. (Inherited from System.Windows.Media.Visual)
Public Method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object descendant. (Inherited from System.Windows.Media.Visual)
Public Method | TransformToVisual | Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object. (Inherited from System.Windows.Media.Visual)
Public Method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from System.Windows.UIElement)
Public Method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from System.Windows.FrameworkElement)
Public Method | UnregisterName | Simplifies access to the System.Windows.NameScope de-registration method. (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateDefaultStyle | Reapplies the default style to the current System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from System.Windows.UIElement)
Top

Public Events

 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from System.Windows.FrameworkElement)
Public Event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | ErrorOccured | Fires in case of any error (in error panel etc.).
Public Event | FocusableChanged | Occurs when the value of the System.Windows.UIElement.Focusable property changes. (Inherited from System.Windows.UIElement)
Public Event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when this element gets logical focus. (Inherited from System.Windows.UIElement)
Public Event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from System.Windows.UIElement)
Public Event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from System.Windows.UIElement)
Public Event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from System.Windows.UIElement)
Public Event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from System.Windows.UIElement)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | Initialized | Occurs when this System.Windows.FrameworkElement is initialized. This event coincides with cases where the value of the System.Windows.FrameworkElement.IsInitialized property changes from false (or undefined) to true. (Inherited from System.Windows.FrameworkElement)
Public Event | IsEnabledChanged | Occurs when the value of the System.Windows.UIElement.IsEnabled property on this element changes. (Inherited from System.Windows.UIElement)
Public Event | IsHitTestVisibleChanged | Occurs when the value of the System.Windows.UIElement.IsHitTestVisible dependency property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusedChanged | Occurs when the value of the System.Windows.UIElement.IsKeyboardFocused property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusWithinChanged | Occurs when the value of the System.Windows.UIElement.IsKeyboardFocusWithinChanged property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsMouseCapturedChanged | Occurs when the value of the System.Windows.UIElement.IsMouseCaptured property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsMouseCaptureWithinChanged | Occurs when the value of the System.Windows.UIElement.IsMouseCaptureWithinProperty changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsMouseDirectlyOverChanged | Occurs when the value of the System.Windows.UIElement.IsMouseDirectlyOver property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsStylusCapturedChanged | Occurs when the value of the System.Windows.UIElement.IsStylusCaptured property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsStylusCaptureWithinChanged | Occurs when the value of the System.Windows.UIElement.IsStylusCaptureWithin property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsStylusDirectlyOverChanged | Occurs when the value of the System.Windows.UIElement.IsStylusDirectlyOver property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsVisibleChanged | Occurs when the value of the System.Windows.UIElement.IsVisible property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current System.Windows.Threading.Dispatcher changes. (Inherited from System.Windows.UIElement)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when this element loses logical focus. (Inherited from System.Windows.UIElement)
Public Event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from System.Windows.UIElement)
Public Event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from System.Windows.UIElement)
Public Event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from System.Windows.UIElement)
Public Event | ManipulationCompleted | Occurs when a manipulation and inertia on the System.Windows.UIElement object is complete. (Inherited from System.Windows.UIElement)
Public Event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from System.Windows.UIElement)
Public Event | ManipulationInertiaStarting | Occurs when the input device loses contact with the System.Windows.UIElement object during a manipulation and inertia begins. (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarted | Occurs when an input device begins a manipulation on the System.Windows.UIElement object. (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from System.Windows.UIElement)
Public Event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from System.Windows.Controls.Control)
Public Event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from System.Windows.UIElement)
Public Event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from System.Windows.UIElement)
Public Event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from System.Windows.UIElement)
Public Event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from System.Windows.Controls.Control)
Public Event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, System.Windows.UIElement.PreviewStylusInAirMove is raised instead. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from System.Windows.UIElement)
Public Event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from System.Windows.UIElement)
Public Event | RefreshReport | Fires before report refreshes (right after opening of new report, toggling/sorting and drill-through actions, pressing of buttons: view report (parameters panel), galley mode, refresh, back to parent). In case of no error it fires before LoadCompleted event.
Public Event | RequestBringIntoView | Occurs when System.Windows.FrameworkElement.BringIntoView(System.Windows.Rect) is called on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from System.Windows.UIElement)
Public Event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from System.Windows.UIElement)
Public Event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, System.Windows.UIElement.StylusInAirMove is raised instead. (Inherited from System.Windows.UIElement)
Public Event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from System.Windows.UIElement)
Public Event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from System.Windows.UIElement)
Public Event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from System.Windows.FrameworkElement)
Public Event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from System.Windows.FrameworkElement)
Public Event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer Constructor

[image]
ActiveReports 13
Viewer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Viewer Constructor

Glossary Item Box

Initializes the new instance of Viewer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Viewer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Methods

[image]
ActiveReports 13
Viewer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

Glossary Item Box

For a list of all members of this type, see Viewer members.

Public Methods

 | Name | Description
Public Method | AddHandler | Overloaded. Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from System.Windows.UIElement)
Public Method | AddToEventRoute | Adds handlers to the specified System.Windows.EventRoute for the current System.Windows.UIElement event handler collection. (Inherited from System.Windows.UIElement)
Public Method | ApplyAnimationClock | Overloaded. Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from System.Windows.FrameworkElement)
Public Method | Arrange | Positions child elements and determines a size for a System.Windows.UIElement. Parent elements call this method from their System.Windows.UIElement.ArrangeCore(System.Windows.Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from System.Windows.UIElement)
Public Method | BeginAnimation | Overloaded. Starts an animation for a specified animated property on this element. (Inherited from System.Windows.UIElement)
Public Method | BeginInit | Starts the initialization process for this element. (Inherited from System.Windows.FrameworkElement)
Public Method | BeginStoryboard | Overloaded. Begins the sequence of actions that are contained in the provided storyboard. (Inherited from System.Windows.FrameworkElement)
Public Method | BringIntoView | Overloaded. Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from System.Windows.FrameworkElement)
Public Method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from System.Windows.UIElement)
Public Method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from System.Windows.UIElement)
Public Method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Overloaded. Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by Viewer control.
Public Method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from System.Windows.FrameworkElement)
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from System.Windows.Media.Visual)
Public Method | FindName | Finds an element that has the provided identifier name. (Inherited from System.Windows.FrameworkElement)
Public Method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | Attempts to set focus to this element. (Inherited from System.Windows.UIElement)
Public Method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from System.Windows.UIElement)
Public Method | GetBindingExpression | Returns the System.Windows.Data.BindingExpression that represents the binding on the specified property. (Inherited from System.Windows.FrameworkElement)
Public Method | GetHashCode | Gets a hash code for this System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject. (Inherited from System.Windows.DependencyObject)
Public Method | HandleError | Reports about runtime error
Public Method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from System.Windows.UIElement)
Public Method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by System.Windows.UIElement.UpdateLayout. (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from System.Windows.UIElement)
Public Method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. System.Windows.UIElement.OnRender(System.Windows.Media.DrawingContext) is called after the layout cycle is completed. (Inherited from System.Windows.UIElement)
Public Method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from System.Windows.Media.Visual)
Public Method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from System.Windows.Media.Visual)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | Measure | Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Parent elements call this method from their own System.Windows.UIElement.MeasureCore(System.Windows.Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from System.Windows.UIElement)
Public Method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from System.Windows.FrameworkElement)
Public Method | PointFromScreen | Converts a System.Windows.Point in screen coordinates into a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual. (Inherited from System.Windows.Media.Visual)
Public Method | PointToScreen | Converts a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual into a System.Windows.Point in screen coordinates. (Inherited from System.Windows.Media.Visual)
Public Method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from System.Windows.FrameworkElement)
Public Method | Print | Overloaded. Prints the currently opened document(section or page)
Public Method | RaiseEvent | Raises a specific routed event. The System.Windows.RoutedEvent to be raised is identified within the System.Windows.RoutedEventArgs instance that is provided (as the System.Windows.RoutedEventArgs.RoutedEvent property of that event data). (Inherited from System.Windows.UIElement)
Public Method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from System.Windows.DependencyObject)
Public Method | RegisterName | Provides an accessor that simplifies access to the System.Windows.NameScope registration method. (Inherited from System.Windows.FrameworkElement)
Public Method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from System.Windows.UIElement)
Public Method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from System.Windows.UIElement)
Public Method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from System.Windows.UIElement)
Public Method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | (Inherited from System.Windows.UIElement)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | SetBinding | Overloaded. Attaches a binding to this element, based on the provided binding object. (Inherited from System.Windows.FrameworkElement)
Public Method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)
Public Method | SetParametersValues | Sets values of parameters for the report that is shown.
Public Method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | Overloaded. Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
Public Method | ToString | Returns the string representation of a System.Windows.Controls.Control object. (Inherited from System.Windows.Controls.Control)
Public Method | TransformToAncestor | Overloaded. Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Visual ancestor of the visual object. (Inherited from System.Windows.Media.Visual)
Public Method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object descendant. (Inherited from System.Windows.Media.Visual)
Public Method | TransformToVisual | Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object. (Inherited from System.Windows.Media.Visual)
Public Method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from System.Windows.UIElement)
Public Method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from System.Windows.FrameworkElement)
Public Method | UnregisterName | Simplifies access to the System.Windows.NameScope de-registration method. (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateDefaultStyle | Reapplies the default style to the current System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from System.Windows.UIElement)
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Dispose Method

Glossary Item Box

Releases the resources used by Viewer control.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Export Method

[image]
ActiveReports 13
Export Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Export Method

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.

Overload List

Overload | Description
Export(IDocumentExportEx,FileInfo) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,FileInfo,String) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,Stream) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Export(IDocumentExportEx,Stream,String) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Export(IDocumentExportEx,FileInfo) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,FileInfo) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo) Method

filter
The export filter component to export the currently displayed report with.
file
The file to write the output to.

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As FileInfo _
)
C#
public void Export(
   IDocumentExportEx filter,
   FileInfo file
)

Parameters

filter
The export filter component to export the currently displayed report with.
file
The file to write the output to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,FileInfo,String) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,FileInfo,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo,String) Method

filter
The export filter component to export the currently displayed report with; file.
file
The file to write the output to.
pageRange
The page range of the report to export.

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As FileInfo, _
   ByVal pageRange As String _
)
C#
public void Export(
   IDocumentExportEx filter,
   FileInfo file,
   string pageRange
)

Parameters

filter
The export filter component to export the currently displayed report with; file.
file
The file to write the output to.
pageRange
The page range of the report to export.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream) Method

filter
The export filter component to export the currently displayed report with.
stream
The stream to write the output to.

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As Stream _
)
C#
public void Export(
   IDocumentExportEx filter,
   Stream stream
)

Parameters

filter
The export filter component to export the currently displayed report with.
stream
The stream to write the output to.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream,String) Method

[image]
ActiveReports 13
Export(IDocumentExportEx,Stream,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream,String) Method

filter
The export filter component to export the currently displayed report with.
stream
The stream to write the output to.
pageRange
The page range of the report to export.

Glossary Item Box

Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As Stream, _
   ByVal pageRange As String _
)
C#
public void Export(
   IDocumentExportEx filter,
   Stream stream,
   string pageRange
)

Parameters

filter
The export filter component to export the currently displayed report with.
stream
The stream to write the output to.
pageRange
The page range of the report to export.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


HandleError Method

[image]
ActiveReports 13
HandleError Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HandleError Method

ex
The exception to report.

Glossary Item Box

Reports about runtime error

Syntax

Visual Basic (Declaration)
Public Sub HandleError( _
   ByVal ex As Exception _
)
C#
public void HandleError(
   Exception ex
)

Parameters

ex
The exception to report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LoadDocument Method

[image]
ActiveReports 13
LoadDocument Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LoadDocument Method

Glossary Item Box

Loads a report.

Overload List

Overload | Description
LoadDocument(Stream,DocumentFormat) | Loads the document from stream.
LoadDocument(String) | Loads a report from the specified file path.
LoadDocument(PageDocument) | Loads the specified page document.
LoadDocument(SectionReport) | Loads the specified section report.
LoadDocument(SectionDocument) | Loads the specified section document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LoadDocument(Stream,DocumentFormat) Method

[image]
ActiveReports 13
LoadDocument(Stream,DocumentFormat) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(Stream,DocumentFormat) Method

stream
Stream to load from. Note: Page report with master file should contains full path to master file.
format
The format of the report to load.

Glossary Item Box

Loads the document from stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal stream As Stream, _
   ByVal format As DocumentFormat _
)
C#
public void LoadDocument(
   Stream stream,
   DocumentFormat format
)

Parameters

stream
Stream to load from. Note: Page report with master file should contains full path to master file.
format
The format of the report to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(String) Method

[image]
ActiveReports 13
LoadDocument(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(String) Method

filePath
The file to load.

Glossary Item Box

Loads a report from the specified file path.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal filePath As String _
)
C#
public void LoadDocument(
   string filePath
)

Parameters

filePath
The file to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(PageDocument) Method

[image]
ActiveReports 13
LoadDocument(PageDocument) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(PageDocument) Method

pageDocument
The page document to load.

Glossary Item Box

Loads the specified page document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal pageDocument As PageDocument _
)
C#
public void LoadDocument(
   PageDocument pageDocument
)

Parameters

pageDocument
The page document to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionReport) Method

[image]
ActiveReports 13
LoadDocument(SectionReport) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionReport) Method

report
The section report to load.

Glossary Item Box

Loads the specified section report.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal report As SectionReport _
)
C#
public void LoadDocument(
   SectionReport report
)

Parameters

report
The section report to load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionDocument) Method

[image]
ActiveReports 13
LoadDocument(SectionDocument) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionDocument) Method

document
The section document top load.

Glossary Item Box

Loads the specified section document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadDocument( _
   ByVal document As SectionDocument _
)
C#
public void LoadDocument(
   SectionDocument document
)

Parameters

document
The section document top load.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print Method

[image]
ActiveReports 13
Print Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Print Method

Glossary Item Box

Prints the currently opened document(section or page)

Overload List

Overload | Description
Print(Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean,Boolean) | Prints the currently opened document(section or page)
Print(PrintingSettings) | Prints the currently opened document(section or page)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Print(Boolean) Method

[image]
ActiveReports 13
Print(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(Boolean) Method

showPrintDialog

Specifies whether or not the Print dialog should be shown.

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal showPrintDialog As Boolean _
) As Boolean
C#
public bool Print(
   bool showPrintDialog
)

Parameters

showPrintDialog

Specifies whether or not the Print dialog should be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean) Method

[image]
ActiveReports 13
Print(Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(Boolean,Boolean) Method

showPrintDialog

Specifies whether or not the Print dialog should be shown.

showPrintProgressDialog

Specifies whether or not the PrintProgress dialog should be shown.

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean _
) As Boolean
C#
public bool Print(
   bool showPrintDialog,
   bool showPrintProgressDialog
)

Parameters

showPrintDialog

Specifies whether or not the Print dialog should be shown.

showPrintProgressDialog

Specifies whether or not the PrintProgress dialog should be shown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean,Boolean) Method

[image]
ActiveReports 13
Print(Boolean,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(Boolean,Boolean,Boolean) Method

showPrintDialog

Specifies whether or not the Print dialog should be shown.

showPrintProgressDialog

Specifies whether or not the PrintProgress dialog should be shown.

usePrintingThread

If True the printing will run in new thread.

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean, _
   ByVal usePrintingThread As Boolean _
) As Boolean
C#
public bool Print(
   bool showPrintDialog,
   bool showPrintProgressDialog,
   bool usePrintingThread
)

Parameters

showPrintDialog

Specifies whether or not the Print dialog should be shown.

showPrintProgressDialog

Specifies whether or not the PrintProgress dialog should be shown.

usePrintingThread

If True the printing will run in new thread.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(PrintingSettings) Method

[image]
ActiveReports 13
Print(PrintingSettings) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(PrintingSettings) Method

settings

Glossary Item Box

Prints the currently opened document(section or page)

Syntax

Visual Basic (Declaration)
Public Overloads Function Print( _
   ByVal settings As PrintingSettings _
) As Boolean
C#
public bool Print(
   PrintingSettings settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

[image]
ActiveReports 13
Render(IRenderingExtension,StreamProvider,NameValueCollection) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

extension
Rendering extension used to render a report.
streamProvider

The stream provider to store the render output.

settings

The rendering extension settings.

Glossary Item Box

Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal extension As IRenderingExtension, _
   ByVal streamProvider As GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider, _
   ByVal settings As NameValueCollection _
)
C#
public void Render(
   IRenderingExtension extension,
   GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider streamProvider,
   NameValueCollection settings
)

Parameters

extension
Rendering extension used to render a report.
streamProvider

The stream provider to store the render output.

settings

The rendering extension settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetParametersValues Method

[image]
ActiveReports 13
SetParametersValues Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetParametersValues Method

parameters
Values of parameters to be set.

Glossary Item Box

Sets values of parameters for the report that is shown.

Syntax

Visual Basic (Declaration)
Public Sub SetParametersValues( _
   ByVal parameters As IEnumerable(Of IParameter) _
)
C#
public void SetParametersValues(
   IEnumerable<IParameter> parameters
)

Parameters

parameters
Values of parameters to be set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Properties

[image]
ActiveReports 13
Viewer Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

Glossary Item Box

For a list of all members of this type, see Viewer members.

Public Properties

 | Name | Description
Public Property | ActualHeight | Gets the rendered height of this element. (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | Gets the rendered width of this element. (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | Background | Gets or sets a brush that describes the background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BindingGroup | Gets or sets the System.Windows.Data.BindingGroup that is used for the element. (Inherited from System.Windows.FrameworkElement)
Public Property | BitmapEffect | Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | BitmapEffectInput | Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | Gets or sets a cached representation of the System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | CanExport | Indicates whether the loaded report can be exported or not. Returns "false" if export is not permitted.
Public Property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | CommandBindings | Gets a collection of System.Windows.Input.CommandBinding objects associated with this element. A System.Windows.Input.CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from System.Windows.UIElement)
Public Property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from System.Windows.FrameworkElement)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from System.Windows.FrameworkElement)
Public Property | DependencyObjectType | Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance. (Inherited from System.Windows.DependencyObject)
Public Property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with. (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Effect | Gets or sets the bitmap effect to apply to the System.Windows.UIElement. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from System.Windows.FrameworkElement)
Public Property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | Gets or sets the font family of the control. (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | Gets or sets the font size. (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | Gets or sets the font style. (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from System.Windows.Controls.Control)
Public Property | ForceCursor | Gets or sets a value that indicates whether this System.Windows.FrameworkElement should force the user interface (UI) to render the cursor as declared by the System.Windows.FrameworkElement.Cursor property. (Inherited from System.Windows.FrameworkElement)
Public Property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from System.Windows.Controls.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from System.Windows.UIElement)
Public Property | Height | Gets or sets the suggested height of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from System.Windows.UIElement)
Public Property | InputScope | Gets or sets the context for input used by this System.Windows.FrameworkElement. (Inherited from System.Windows.FrameworkElement)
Public Property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from System.Windows.UIElement)
Public Property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its System.Windows.FrameworkElement.EndInit method called. (Inherited from System.Windows.FrameworkElement)
Public Property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from System.Windows.FrameworkElement)
Public Property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this System.Windows.UIElement. (Inherited from System.Windows.UIElement)
Public Property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from System.Windows.DependencyObject)
Public Property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from System.Windows.Controls.Control)
Public Property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from System.Windows.FrameworkElement)
Public Property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | Gets or sets the outer margin of an element. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | MultiplePageCols | Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.
Public Property | MultiplePageRows | Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.
Public Property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | Gets or sets the opacity factor applied to the entire System.Windows.UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | Gets or sets an opacity mask, as a System.Windows.Media.Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from System.Windows.FrameworkElement)
Public Property | Padding | Gets or sets the padding inside a control. (Inherited from System.Windows.Controls.Control)
Public Property | PageOffset | Gets or sets the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | Gets the logical parent element of this element. (Inherited from System.Windows.FrameworkElement)
Public Property | PersistId | Gets a value that uniquely identifies this element. (Inherited from System.Windows.UIElement)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from System.Windows.FrameworkElement)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | Source | Specifies the local/remote report source Uri to display the report in Viewer (i.e. 'http://www.mysite.com/invoice.rpx')
Public Property | SourceFormat | Specifies the format of the report source Uri. Should be used when Source does not have an extension.
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from System.Windows.Controls.Control)
Public Property | TableOfContents | Gets the table of contents panel component of sidebar component.
Public Property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from System.Windows.FrameworkElement)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Template | Gets or sets a control template. (Inherited from System.Windows.Controls.Control)
Public Property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from System.Windows.FrameworkElement)
Public Property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from System.Windows.FrameworkElement)
Public Property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from System.Windows.UIElement)
Public Property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from System.Windows.UIElement)
Public Property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from System.Windows.UIElement)
Public Property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from System.Windows.FrameworkElement)
Public Property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from System.Windows.Controls.Control)
Public Property | ViewType | Gets or sets a value that determines how the viewer shows pages(single/multi/continous).
Public Property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from System.Windows.UIElement)
Public Property | Width | Gets or sets the width of the element. (Inherited from System.Windows.FrameworkElement)
Public Property | Zoom | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


AllowSplitter Property

[image]
ActiveReports 13
AllowSplitter Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AllowSplitter Property

Glossary Item Box

Gets or sets a value that determines whether the user is allowed to split the view.

Syntax

Visual Basic (Declaration)
Public Property AllowSplitter As Boolean
C#
public bool AllowSplitter {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CanExport Property

[image]
ActiveReports 13
CanExport Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CanExport Property

Glossary Item Box

Indicates whether the loaded report can be exported or not. Returns "false" if export is not permitted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanExport As Boolean
C#
public bool CanExport {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CurrentPage Property

[image]
ActiveReports 13
CurrentPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CurrentPage Property

Glossary Item Box

Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.

Syntax

Visual Basic (Declaration)
Public Property CurrentPage As Integer
C#
public int CurrentPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GalleyMode Property

[image]
ActiveReports 13
GalleyMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GalleyMode Property

Glossary Item Box

Gets or sets GalleyMode of report

Syntax

Visual Basic (Declaration)
Public Property GalleyMode As Boolean
C#
public bool GalleyMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


History Property

[image]
ActiveReports 13
History Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : History Property

Glossary Item Box

Public API for history manipulation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property History As IHistoryApi
C#
public IHistoryApi History {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkBackColor Property

[image]
ActiveReports 13
HyperlinkBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkBackColor Property

Glossary Item Box

Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property HyperlinkBackColor As Color
C#
public Color HyperlinkBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkForeColor Property

[image]
ActiveReports 13
HyperlinkForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkForeColor Property

Glossary Item Box

Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property HyperlinkForeColor As Color
C#
public Color HyperlinkForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkUnderline Property

[image]
ActiveReports 13
HyperlinkUnderline Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkUnderline Property

Glossary Item Box

Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property HyperlinkUnderline As Boolean
C#
public bool HyperlinkUnderline {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MultiplePageCols Property

[image]
ActiveReports 13
MultiplePageCols Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MultiplePageCols Property

Glossary Item Box

Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.

Syntax

Visual Basic (Declaration)
Public Property MultiplePageCols As Integer
C#
public int MultiplePageCols {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MultiplePageRows Property

[image]
ActiveReports 13
MultiplePageRows Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MultiplePageRows Property

Glossary Item Box

Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.

Syntax

Visual Basic (Declaration)
Public Property MultiplePageRows As Integer
C#
public int MultiplePageRows {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PageOffset Property

[image]
ActiveReports 13
PageOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PageOffset Property

Glossary Item Box

Gets or sets the location of the page in the viewer.

Syntax

Visual Basic (Declaration)
Public Property PageOffset As Point
C#
public Point PageOffset {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PagesBackColor Property

[image]
ActiveReports 13
PagesBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PagesBackColor Property

Glossary Item Box

Public API for background color of report pane.

Syntax

Visual Basic (Declaration)
Public Property PagesBackColor As Color
C#
public Color PagesBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewPages Property

[image]
ActiveReports 13
PreviewPages Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewPages Property

Glossary Item Box

Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances

Syntax

Visual Basic (Declaration)
Public Property PreviewPages As Integer
C#
public int PreviewPages {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PrintingSettings Property

[image]
ActiveReports 13
PrintingSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PrintingSettings Property

Glossary Item Box

Gets or sets printing settings

Syntax

Visual Basic (Declaration)
Public Property PrintingSettings As PrintingSettings
C#
public PrintingSettings PrintingSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RepositionPage Property

[image]
ActiveReports 13
RepositionPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RepositionPage Property

Glossary Item Box

Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.

Syntax

Visual Basic (Declaration)
Public Property RepositionPage As Boolean
C#
public bool RepositionPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ScrollbarEnabled Property

[image]
ActiveReports 13
ScrollbarEnabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ScrollbarEnabled Property

Glossary Item Box

Public API. Show or hide scrolls within report pane.

Syntax

Visual Basic (Declaration)
Public Property ScrollbarEnabled As Boolean
C#
public bool ScrollbarEnabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SearchResultsBackColor Property

[image]
ActiveReports 13
SearchResultsBackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsBackColor Property

Glossary Item Box

Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsBackColor As Color
C#
public Color SearchResultsBackColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SearchResultsForeColor Property

[image]
ActiveReports 13
SearchResultsForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsForeColor Property

Glossary Item Box

Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.

Syntax

Visual Basic (Declaration)
Public Property SearchResultsForeColor As Color
C#
public Color SearchResultsForeColor {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Sidebar Property

[image]
ActiveReports 13
Sidebar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Sidebar Property

Glossary Item Box

Gets the sidebar component of the viewer control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sidebar As Sidebar
C#
public Sidebar Sidebar {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Source Property

Glossary Item Box

Specifies the local/remote report source Uri to display the report in Viewer (i.e. 'http://www.mysite.com/invoice.rpx')

Syntax

Visual Basic (Declaration)
Public Property Source As Uri
C#
public Uri Source {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SourceFormat Property

[image]
ActiveReports 13
SourceFormat Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SourceFormat Property

Glossary Item Box

Specifies the format of the report source Uri. Should be used when Source does not have an extension.

Syntax

Visual Basic (Declaration)
Public Property SourceFormat As Nullable(Of DocumentFormat)
C#
public Nullable<DocumentFormat> SourceFormat {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SplitView Property

[image]
ActiveReports 13
SplitView Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SplitView Property

Glossary Item Box

Gets or sets a value that determines whether the viewer is split into two views.

Syntax

Visual Basic (Declaration)
Public Property SplitView As Boolean
C#
public bool SplitView {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TableOfContents Property

[image]
ActiveReports 13
TableOfContents Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TableOfContents Property

Glossary Item Box

Gets the table of contents panel component of sidebar component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableOfContents As TocPanel
C#
public TocPanel TableOfContents {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TargetView Property

[image]
ActiveReports 13
TargetView Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TargetView Property

Glossary Item Box

Gets or sets a value that specifies the current target view when SplitView is true.

Syntax

Visual Basic (Declaration)
Public Property TargetView As TargetView
C#
public TargetView TargetView {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UseHyperlinkSettings Property

[image]
ActiveReports 13
UseHyperlinkSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UseHyperlinkSettings Property

Glossary Item Box

Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Property UseHyperlinkSettings As Boolean
C#
public bool UseHyperlinkSettings {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ViewType Property

[image]
ActiveReports 13
ViewType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ViewType Property

Glossary Item Box

Gets or sets a value that determines how the viewer shows pages(single/multi/continous).

Syntax

Visual Basic (Declaration)
Public Property ViewType As ViewType
C#
public ViewType ViewType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Zoom Property

[image]
ActiveReports 13
Zoom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Zoom Property

Glossary Item Box

Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Single
C#
public float Zoom {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Fields

[image]
ActiveReports 13
Viewer Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

Glossary Item Box

For a list of all members of this type, see Viewer members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AllowSplitterProperty | Gets or sets a value that determines whether the user is allowed to split the view.
static (Shared in Visual Basic) | HyperlinkBackColorProperty | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkForeColorProperty | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkUnderlineProperty | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
static (Shared in Visual Basic) | MultiplePageColsProperty | MultiplePageCols binding property
static (Shared in Visual Basic) | MultiplePageRowsProperty | MultiplePageRows binding property
static (Shared in Visual Basic) | PageOffsetProperty | Gets or sets the location of the page in the viewer.
static (Shared in Visual Basic) | PagesBackColorProperty | Public API for background color of report pane.
static (Shared in Visual Basic) | PreviewPagesProperty | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances.
static (Shared in Visual Basic) | PrintingSettingsProperty | DesignPrintingSettings binding property
static (Shared in Visual Basic) | RepositionPageProperty | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
static (Shared in Visual Basic) | ScrollbarEnabledProperty | Public API. Show or hide scrolls within report pane.
static (Shared in Visual Basic) | SearchResultsBackColorProperty | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SearchResultsForeColorProperty | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SourceFormatProperty | SourceFormat Dependency Property
static (Shared in Visual Basic) | SourceProperty | Source Dependency Property
static (Shared in Visual Basic) | SplitViewProperty | Gets or sets a value that determines whether the viewer is split into two views.
static (Shared in Visual Basic) | TargetViewProperty | Gets or sets a value that specifies the current target view when SplitView is true.
static (Shared in Visual Basic) | UseHyperlinkSettingsProperty | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
static (Shared in Visual Basic) | ViewTypeProperty | ViewType binding property
static (Shared in Visual Basic) | ZoomProperty | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


AllowSplitterProperty Field

[image]
ActiveReports 13
AllowSplitterProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AllowSplitterProperty Field

Glossary Item Box

Gets or sets a value that determines whether the user is allowed to split the view.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AllowSplitterProperty As DependencyProperty
C#
public static readonly DependencyProperty AllowSplitterProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkBackColorProperty Field

[image]
ActiveReports 13
HyperlinkBackColorProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkBackColorProperty Field

Glossary Item Box

Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HyperlinkBackColorProperty As DependencyProperty
C#
public static readonly DependencyProperty HyperlinkBackColorProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkForeColorProperty Field

[image]
ActiveReports 13
HyperlinkForeColorProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkForeColorProperty Field

Glossary Item Box

Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HyperlinkForeColorProperty As DependencyProperty
C#
public static readonly DependencyProperty HyperlinkForeColorProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperlinkUnderlineProperty Field

[image]
ActiveReports 13
HyperlinkUnderlineProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkUnderlineProperty Field

Glossary Item Box

Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly HyperlinkUnderlineProperty As DependencyProperty
C#
public static readonly DependencyProperty HyperlinkUnderlineProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MultiplePageColsProperty Field

[image]
ActiveReports 13
MultiplePageColsProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MultiplePageColsProperty Field

Glossary Item Box

MultiplePageCols binding property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MultiplePageColsProperty As DependencyProperty
C#
public static readonly DependencyProperty MultiplePageColsProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MultiplePageRowsProperty Field

[image]
ActiveReports 13
MultiplePageRowsProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MultiplePageRowsProperty Field

Glossary Item Box

MultiplePageRows binding property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MultiplePageRowsProperty As DependencyProperty
C#
public static readonly DependencyProperty MultiplePageRowsProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PageOffsetProperty Field

[image]
ActiveReports 13
PageOffsetProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PageOffsetProperty Field

Glossary Item Box

Gets or sets the location of the page in the viewer.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PageOffsetProperty As DependencyProperty
C#
public static readonly DependencyProperty PageOffsetProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PagesBackColorProperty Field

[image]
ActiveReports 13
PagesBackColorProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PagesBackColorProperty Field

Glossary Item Box

Public API for background color of report pane.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PagesBackColorProperty As DependencyProperty
C#
public static readonly DependencyProperty PagesBackColorProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewPagesProperty Field

[image]
ActiveReports 13
PreviewPagesProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewPagesProperty Field

Glossary Item Box

Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PreviewPagesProperty As DependencyProperty
C#
public static readonly DependencyProperty PreviewPagesProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PrintingSettingsProperty Field

[image]
ActiveReports 13
PrintingSettingsProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PrintingSettingsProperty Field

Glossary Item Box

DesignPrintingSettings binding property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PrintingSettingsProperty As DependencyProperty
C#
public static readonly DependencyProperty PrintingSettingsProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RepositionPageProperty Field

[image]
ActiveReports 13
RepositionPageProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RepositionPageProperty Field

Glossary Item Box

Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly RepositionPageProperty As DependencyProperty
C#
public static readonly DependencyProperty RepositionPageProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ScrollbarEnabledProperty Field

[image]
ActiveReports 13
ScrollbarEnabledProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ScrollbarEnabledProperty Field

Glossary Item Box

Public API. Show or hide scrolls within report pane.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ScrollbarEnabledProperty As DependencyProperty
C#
public static readonly DependencyProperty ScrollbarEnabledProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SearchResultsBackColorProperty Field

[image]
ActiveReports 13
SearchResultsBackColorProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsBackColorProperty Field

Glossary Item Box

Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SearchResultsBackColorProperty As DependencyProperty
C#
public static readonly DependencyProperty SearchResultsBackColorProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SearchResultsForeColorProperty Field

[image]
ActiveReports 13
SearchResultsForeColorProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsForeColorProperty Field

Glossary Item Box

Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SearchResultsForeColorProperty As DependencyProperty
C#
public static readonly DependencyProperty SearchResultsForeColorProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SourceFormatProperty Field

[image]
ActiveReports 13
SourceFormatProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SourceFormatProperty Field

Glossary Item Box

SourceFormat Dependency Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SourceFormatProperty As DependencyProperty
C#
public static readonly DependencyProperty SourceFormatProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SourceProperty Field

[image]
ActiveReports 13
SourceProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SourceProperty Field

Glossary Item Box

Source Dependency Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SourceProperty As DependencyProperty
C#
public static readonly DependencyProperty SourceProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SplitViewProperty Field

[image]
ActiveReports 13
SplitViewProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SplitViewProperty Field

Glossary Item Box

Gets or sets a value that determines whether the viewer is split into two views.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SplitViewProperty As DependencyProperty
C#
public static readonly DependencyProperty SplitViewProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TargetViewProperty Field

[image]
ActiveReports 13
TargetViewProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TargetViewProperty Field

Glossary Item Box

Gets or sets a value that specifies the current target view when SplitView is true.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TargetViewProperty As DependencyProperty
C#
public static readonly DependencyProperty TargetViewProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UseHyperlinkSettingsProperty Field

[image]
ActiveReports 13
UseHyperlinkSettingsProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UseHyperlinkSettingsProperty Field

Glossary Item Box

Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UseHyperlinkSettingsProperty As DependencyProperty
C#
public static readonly DependencyProperty UseHyperlinkSettingsProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ViewTypeProperty Field

[image]
ActiveReports 13
ViewTypeProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ViewTypeProperty Field

Glossary Item Box

ViewType binding property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ViewTypeProperty As DependencyProperty
C#
public static readonly DependencyProperty ViewTypeProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ZoomProperty Field

[image]
ActiveReports 13
ZoomProperty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ZoomProperty Field

Glossary Item Box

Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ZoomProperty As DependencyProperty
C#
public static readonly DependencyProperty ZoomProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Events

[image]
ActiveReports 13
Viewer Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

Glossary Item Box

For a list of all members of this type, see Viewer members.

Public Events

 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from System.Windows.FrameworkElement)
Public Event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from System.Windows.UIElement)
Public Event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from System.Windows.UIElement)
Public Event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | ErrorOccured | Fires in case of any error (in error panel etc.).
Public Event | FocusableChanged | Occurs when the value of the System.Windows.UIElement.Focusable property changes. (Inherited from System.Windows.UIElement)
Public Event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from System.Windows.UIElement)
Public Event | GotFocus | Occurs when this element gets logical focus. (Inherited from System.Windows.UIElement)
Public Event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from System.Windows.UIElement)
Public Event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from System.Windows.UIElement)
Public Event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from System.Windows.UIElement)
Public Event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from System.Windows.UIElement)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | Initialized | Occurs when this System.Windows.FrameworkElement is initialized. This event coincides with cases where the value of the System.Windows.FrameworkElement.IsInitialized property changes from false (or undefined) to true. (Inherited from System.Windows.FrameworkElement)
Public Event | IsEnabledChanged | Occurs when the value of the System.Windows.UIElement.IsEnabled property on this element changes. (Inherited from System.Windows.UIElement)
Public Event | IsHitTestVisibleChanged | Occurs when the value of the System.Windows.UIElement.IsHitTestVisible dependency property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusedChanged | Occurs when the value of the System.Windows.UIElement.IsKeyboardFocused property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusWithinChanged | Occurs when the value of the System.Windows.UIElement.IsKeyboardFocusWithinChanged property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsMouseCapturedChanged | Occurs when the value of the System.Windows.UIElement.IsMouseCaptured property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsMouseCaptureWithinChanged | Occurs when the value of the System.Windows.UIElement.IsMouseCaptureWithinProperty changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsMouseDirectlyOverChanged | Occurs when the value of the System.Windows.UIElement.IsMouseDirectlyOver property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsStylusCapturedChanged | Occurs when the value of the System.Windows.UIElement.IsStylusCaptured property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsStylusCaptureWithinChanged | Occurs when the value of the System.Windows.UIElement.IsStylusCaptureWithin property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsStylusDirectlyOverChanged | Occurs when the value of the System.Windows.UIElement.IsStylusDirectlyOver property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | IsVisibleChanged | Occurs when the value of the System.Windows.UIElement.IsVisible property changes on this element. (Inherited from System.Windows.UIElement)
Public Event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current System.Windows.Threading.Dispatcher changes. (Inherited from System.Windows.UIElement)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | Occurs when this element loses logical focus. (Inherited from System.Windows.UIElement)
Public Event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from System.Windows.UIElement)
Public Event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from System.Windows.UIElement)
Public Event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from System.Windows.UIElement)
Public Event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from System.Windows.UIElement)
Public Event | ManipulationCompleted | Occurs when a manipulation and inertia on the System.Windows.UIElement object is complete. (Inherited from System.Windows.UIElement)
Public Event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from System.Windows.UIElement)
Public Event | ManipulationInertiaStarting | Occurs when the input device loses contact with the System.Windows.UIElement object during a manipulation and inertia begins. (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarted | Occurs when an input device begins a manipulation on the System.Windows.UIElement object. (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from System.Windows.UIElement)
Public Event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from System.Windows.Controls.Control)
Public Event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from System.Windows.UIElement)
Public Event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from System.Windows.UIElement)
Public Event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from System.Windows.UIElement)
Public Event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from System.Windows.UIElement)
Public Event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from System.Windows.UIElement)
Public Event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from System.Windows.Controls.Control)
Public Event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, System.Windows.UIElement.PreviewStylusInAirMove is raised instead. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from System.Windows.UIElement)
Public Event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from System.Windows.UIElement)
Public Event | RefreshReport | Fires before report refreshes (right after opening of new report, toggling/sorting and drill-through actions, pressing of buttons: view report (parameters panel), galley mode, refresh, back to parent). In case of no error it fires before LoadCompleted event.
Public Event | RequestBringIntoView | Occurs when System.Windows.FrameworkElement.BringIntoView(System.Windows.Rect) is called on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | SizeChanged | Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from System.Windows.UIElement)
Public Event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from System.Windows.UIElement)
Public Event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, System.Windows.UIElement.StylusInAirMove is raised instead. (Inherited from System.Windows.UIElement)
Public Event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from System.Windows.UIElement)
Public Event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from System.Windows.UIElement)
Public Event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from System.Windows.UIElement)
Public Event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from System.Windows.UIElement)
Public Event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from System.Windows.FrameworkElement)
Public Event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from System.Windows.FrameworkElement)
Public Event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from System.Windows.UIElement)
Public Event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from System.Windows.UIElement)
Public Event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from System.Windows.FrameworkElement)
Top

See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Action Event

[image]
ActiveReports 13
Action Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Action Event

Glossary Item Box

This event fires when report item with specified action was clicked in the report preview control.

Syntax

Visual Basic (Declaration)
Public Event Action As EventHandler(Of Viewer.ActionEventArgs)
C#
public event EventHandler<Viewer.ActionEventArgs> Action

Event Data

The event handler receives an argument of type Viewer.ActionEventArgs containing data related to this event. The following Viewer.ActionEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the Action that caused the event.
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PageNumber | Gets the page number the action happened on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ErrorOccured Event

[image]
ActiveReports 13
ErrorOccured Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ErrorOccured Event

Glossary Item Box

Fires in case of any error (in error panel etc.).

Syntax

Visual Basic (Declaration)
Public Event ErrorOccured As EventHandler(Of ErrorInfo)
C#
public event EventHandler<ErrorInfo> ErrorOccured

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HyperLink Event

[image]
ActiveReports 13
HyperLink Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperLink Event

Glossary Item Box

Occurs when the user clicks on text or an image that has a hyperlink assigned to it.

Syntax

Visual Basic (Declaration)
Public Event HyperLink As HyperLinkEventHandler
C#
public event HyperLinkEventHandler HyperLink

Event Data

The event handler receives an argument of type HyperLinkEventArgs containing data related to this event. The following HyperLinkEventArgs properties provide information specific to this event.

Property | Description
Button | Gets the mouse button that the user clicked to raise the event.
CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
HyperLink | Gets the hyperlink target.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LoadCompleted Event

[image]
ActiveReports 13
LoadCompleted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LoadCompleted Event

Glossary Item Box

Occurs after all the viewer pages have been fully loaded.

Syntax

Visual Basic (Declaration)
Public Event LoadCompleted As LoadCompletedEventHandler
C#
public event LoadCompletedEventHandler LoadCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RefreshReport Event

[image]
ActiveReports 13
RefreshReport Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RefreshReport Event

Glossary Item Box

Fires before report refreshes (right after opening of new report, toggling/sorting and drill-through actions, pressing of buttons: view report (parameters panel), galley mode, refresh, back to parent). In case of no error it fires before LoadCompleted event.

Syntax

Visual Basic (Declaration)
Public Event RefreshReport As EventHandler
C#
public event EventHandler RefreshReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Viewer.ActionEventArgs Class

[image]
ActiveReports 13
Viewer.ActionEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer.ActionEventArgs Class

Glossary Item Box

Provides data for Action event.

Object Model

Viewer.ActionEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class Viewer.ActionEventArgs
   Inherits System.ComponentModel.CancelEventArgs
C#
public class Viewer.ActionEventArgs : System.ComponentModel.CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Wpf.Viewer.ActionEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer.ActionEventArgs Class Members

[image]
ActiveReports 13
Viewer.ActionEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer.ActionEventArgs Class

Glossary Item Box

The following tables list the members exposed by Viewer.ActionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | Viewer.ActionEventArgs Constructor | Initializes the new instance of ActionEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets the Action that caused the event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Gets the page number the action happened on.
Top

See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer.ActionEventArgs Constructor()

[image]
ActiveReports 13
Viewer.ActionEventArgs Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor()

Glossary Item Box

Initializes the new instance of ActionEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public Viewer.ActionEventArgs()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Class Properties

[image]
ActiveReports 13
Viewer.ActionEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer.ActionEventArgs Class

Glossary Item Box

For a list of all members of this type, see Viewer.ActionEventArgs members.

Public Properties

 | Name | Description
Public Property | Action | Gets the Action that caused the event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Gets the page number the action happened on.
Top

See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Action Property

[image]
ActiveReports 13
Action Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : Action Property

Glossary Item Box

Gets the Action that caused the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As IAction
C#
public IAction Action {get;}

Property Value

The action.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


PageNumber Property

[image]
ActiveReports 13
PageNumber Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : PageNumber Property

Glossary Item Box

Gets the page number the action happened on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Property Value

The page number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


TargetView Enumeration

[image]
ActiveReports 13
TargetView Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TargetView Enumeration

Glossary Item Box

Determines the current active view in the viewer.

Syntax

Visual Basic (Declaration)
Public Enum TargetView
   Inherits System.Enum
C#
public enum TargetView : System.Enum

Members

Member | Description
Primary | The primary (Bottom) view is the active view.
Secondary | The secondary (Upper) view is the active view.

Remarks

The viewer can be split into two views using the splitter. This enumeration determines which view will be effected by methods and property calls.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Viewer.Wpf.TargetView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf Namespace


GrapeCity.Viewer.Common Namespace

GrapeCity.Viewer.Common Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly : GrapeCity.Viewer.Common Namespace

Glossary Item Box

The GrapeCity.Viewer.Common Namespace contains the IHistoryApi interface.

Classes

 | Class | Description
Class | CachedPageView | Base class for page views with caching
Class | DelegateCommand | Parameterless command delegate
Class | DelegateCommand<TParm> | DelegateCommand implementation
Class | DisposablesCollection | Utility class to redirect Dispose call to its inner items
Class | DocumentRendererAttribute | Allows to specified document renderer type for class.
Class | DocumentSearchService | Search service implementation for ISearchableDocument
Class | DoubleDelegateCommand | Command that delegates implementation to another delegate command
Class | EnumerableExtensions | Extends methods of work with IEnumerable.
Class | NotifyCollectionChangedEventArgs | Describes the action that caused a System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Class | NullDelegateCommand | NullDelegateCommand implementation.
Class | NullRenderer | Null-object implementation for IDocumentRenderer interface
Class | NullRenderer.Factory | IDocumentRenderer factory.
Class | ObservableCollection<T> | Wrapped System.Collections.ObjectModel observable collection
Class | PageView | Base abstract class for concrete page renderers.
Class | RectExtensions | Extends Rect struct with helper methods.
Class | StreamDocumentLoader | Served to download documents from the stream

Interfaces

 | Interface | Description
Interface | IApplicationContext | Provides access to different services and factories
Interface | ICommand | Defines the contract for commanding, using the same contract as used in WPF.
Interface | ICopySelectionService | Base interface for copy operations
Interface | IDelegateCommand | Delegated command interface
Interface | IDocumentLoader | Base interface for document loads
Interface | IDocumentRenderer | Base interface for Document renderers
Interface | IDocumentRendererFactory | IDocumentRenderer factory interface.
Interface | IHistoryApi | This is public interface for user to work with HistoryService.
Interface | ILoadableFromFileAndStream | Interface ILoadableFromFileAndStream
Interface | INotifyCollectionChanged | Notifies listeners of dynamic changes to a collection, such as when items are added and removed, or the entire collection object is reset.
Interface | IOrientedPageView | Interface to access orientation of the report page.
Interface | IParameter | Defines an object that can be used as a report parameter.
Interface | IPrintService | Interface IPrintService.
Interface | IRasteredPageView | IRasteredPageView interface
Interface | IRasteredRenderer | Interface for rastered document renderer
Interface | ISearchService | Base interface for search
Interface | IServiceContainer | Provides a container for services.

Structures

 | Structure | Description
Structure | Color | Platform independent color implementation
Structure | Margin | Stores page margins
Structure | Point | Platform independent point
Structure | Rect | Platform aware rectangle structure
Structure | Size | Platform aware Size structure

Delegates

 | Delegate | Description
Delegate | NotifyCollectionChangedEventHandler | Represents the method that handles events that implement the System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.

Enumerations

 | Enumeration | Description
Enumeration | DeviceKind | Defines enumeration of possible target devices for view.
Enumeration | DocumentFormat | Specifies possible document formats
Enumeration | LoadState | Possible loading states
Enumeration | NotifyCollectionChangedAction | Enum NotifyCollectionChangedAction
Enumeration | PrintingSettings | Print process settings

See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf Assembly


CachedPageView Class

[image]
ActiveReports 13
CachedPageView Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

Glossary Item Box

Base class for page views with caching

Object Model

CachedPageView Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class CachedPageView
   Inherits PageView
C#
public abstract class CachedPageView : PageView

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.CachedPageView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CachedPageView Members
GrapeCity.Viewer.Common Namespace


CachedPageView Class Members

[image]
ActiveReports 13
CachedPageView Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

Glossary Item Box

The following tables list the members exposed by CachedPageView.

Public Properties

 | Name | Description
Public Property | Device | Gets the device kind. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Property | Size | Gets the page view size. (Inherited from GrapeCity.Viewer.Common.PageView)
Top

Public Methods

 | Name | Description
Public Method | AsCachable | Convert to CachedPageView. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Method | Dispose | Disposes allocated resources.
Top

See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


CachedPageView Class Methods

[image]
ActiveReports 13
CachedPageView Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

Glossary Item Box

For a list of all members of this type, see CachedPageView members.

Public Methods

 | Name | Description
Public Method | AsCachable | Convert to CachedPageView. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Method | Dispose | Disposes allocated resources.
Top

See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > CachedPageView Class : Dispose Method

Glossary Item Box

Disposes allocated resources.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Dispose()
C#
public abstract void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CachedPageView Class
CachedPageView Members


DelegateCommand Class

[image]
ActiveReports 13
DelegateCommand Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

Glossary Item Box

Parameterless command delegate

Object Model

DelegateCommand Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DelegateCommand
   Inherits GrapeCity.Viewer.Common.DelegateCommand(Of Object)
   Implements ICommand, IDelegateCommand
C#
public sealed class DelegateCommand : GrapeCity.Viewer.Common.DelegateCommand<object>, ICommand, IDelegateCommand

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DelegateCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand Members
GrapeCity.Viewer.Common Namespace


DelegateCommand Class Members

[image]
ActiveReports 13
DelegateCommand Class Members
See Also Fields Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

Glossary Item Box

The following tables list the members exposed by DelegateCommand.

Public Constructors

 | Name | Description
Public Constructor | DelegateCommand Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | NullCommand | Gets "Null" command instance which does nothing and is always disabled
Top

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top

See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DelegateCommand Constructor

[image]
ActiveReports 13
DelegateCommand Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class : DelegateCommand Constructor

Glossary Item Box

Overload List

Overload | Description
DelegateCommand Constructor(Action,Func<Boolean>) | Initializes a new instance of the DelegateCommand class.
DelegateCommand Constructor(Action) | Initializes a new instance of the DelegateCommand class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand Class
DelegateCommand Members


DelegateCommand Constructor(Action,Func<Boolean>)

[image]
ActiveReports 13
DelegateCommand Constructor(Action,Func<Boolean>)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class > DelegateCommand Constructor : DelegateCommand Constructor(Action,Func<Boolean>)

executeAction
The command will be executed.
canExecute
Determines whether the command can be executed or not.

Glossary Item Box

Initializes a new instance of the DelegateCommand class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal executeAction As Action, _
   ByVal canExecute As Func(Of Boolean) _
)
C#
public DelegateCommand(
   Action executeAction,
   Func<bool> canExecute
)

Parameters

executeAction
The command will be executed.
canExecute
Determines whether the command can be executed or not.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand Class
DelegateCommand Members
Overload List


DelegateCommand Constructor(Action)

[image]
ActiveReports 13
DelegateCommand Constructor(Action)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class > DelegateCommand Constructor : DelegateCommand Constructor(Action)

executeAction
The command will be executed.

Glossary Item Box

Initializes a new instance of the DelegateCommand class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal executeAction As Action _
)
C#
public DelegateCommand(
   Action executeAction
)

Parameters

executeAction
The command will be executed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand Class
DelegateCommand Members
Overload List


DelegateCommand Class Fields

[image]
ActiveReports 13
DelegateCommand Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

Glossary Item Box

For a list of all members of this type, see DelegateCommand members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | NullCommand | Gets "Null" command instance which does nothing and is always disabled
Top

See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


NullCommand Field

[image]
ActiveReports 13
NullCommand Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class : NullCommand Field

Glossary Item Box

Gets "Null" command instance which does nothing and is always disabled

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NullCommand As IDelegateCommand
C#
public static readonly IDelegateCommand NullCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand Class
DelegateCommand Members


DelegateCommand<TParm> Class

TParm
[image]
ActiveReports 13
DelegateCommand<TParm> Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

Glossary Item Box

DelegateCommand implementation

Object Model

DelegateCommand<TParm> Class

Syntax

Visual Basic (Declaration)
Public Class DelegateCommand(Of TParm)
   Implements ICommand, IDelegateCommand
C#
public class DelegateCommand<TParm> : ICommand, IDelegateCommand

Type Parameters

TParm

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DelegateCommand<TParm>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Members
GrapeCity.Viewer.Common Namespace


DelegateCommand<TParm> Class Members

[image]
ActiveReports 13
DelegateCommand<TParm> Class Members
See Also Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

Glossary Item Box

The following tables list the members exposed by DelegateCommand<TParm>.

Public Constructors

 | Name | Description
Public Constructor | DelegateCommand<TParm> Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


DelegateCommand<TParm> Constructor

[image]
ActiveReports 13
DelegateCommand<TParm> Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : DelegateCommand<TParm> Constructor

Glossary Item Box

Overload List

Overload | Description
DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>) | Initializes a new instance of the DelegateCommand<TParm> class.
DelegateCommand<TParm> Constructor(Action<TParm>) | Initializes a new instance of the DelegateCommand<TParm> class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)

[image]
ActiveReports 13
DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class > DelegateCommand<TParm> Constructor : DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)

executeAction
canExecute

Glossary Item Box

Initializes a new instance of the DelegateCommand<TParm> class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal executeAction As Action(Of TParm), _
   ByVal canExecute As Predicate(Of TParm) _
)
C#
public DelegateCommand<TParm>(
   Action<TParm> executeAction,
   Predicate<TParm> canExecute
)

Parameters

executeAction
canExecute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members
Overload List


DelegateCommand<TParm> Constructor(Action<TParm>)

[image]
ActiveReports 13
DelegateCommand<TParm> Constructor(Action<TParm>)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class > DelegateCommand<TParm> Constructor : DelegateCommand<TParm> Constructor(Action<TParm>)

executeAction

Glossary Item Box

Initializes a new instance of the DelegateCommand<TParm> class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal executeAction As Action(Of TParm) _
)
C#
public DelegateCommand<TParm>(
   Action<TParm> executeAction
)

Parameters

executeAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members
Overload List


DelegateCommand<TParm> Class Methods

[image]
ActiveReports 13
DelegateCommand<TParm> Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

Glossary Item Box

For a list of all members of this type, see DelegateCommand<TParm> members.

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top

See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


CanExecute Method

[image]
ActiveReports 13
CanExecute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : CanExecute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method that determines whether the command can execute in its current state.

Syntax

Visual Basic (Declaration)
Public Function CanExecute( _
   ByVal parameter As Object _
) As Boolean
C#
public bool CanExecute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this instance can execute the specified parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


Execute Method

[image]
ActiveReports 13
Execute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : Execute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method to be called when the command is invoked.

Syntax

Visual Basic (Declaration)
Public Sub Execute( _
   ByVal parameter As Object _
)
C#
public void Execute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


RaiseCanExecuteChanged Method

[image]
ActiveReports 13
RaiseCanExecuteChanged Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : RaiseCanExecuteChanged Method

Glossary Item Box

Raise CanExecuteChanged event from external code.

Syntax

Visual Basic (Declaration)
Public Sub RaiseCanExecuteChanged()
C#
public void RaiseCanExecuteChanged()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DelegateCommand<TParm> Class Events

[image]
ActiveReports 13
DelegateCommand<TParm> Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

Glossary Item Box

For a list of all members of this type, see DelegateCommand<TParm> members.

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event

[image]
ActiveReports 13
CanExecuteChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : CanExecuteChanged Event

Glossary Item Box

Occurs when changes occur that affect whether the command should execute.

Syntax

Visual Basic (Declaration)
Public Event CanExecuteChanged As EventHandler
C#
public event EventHandler CanExecuteChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DisposablesCollection Class

[image]
ActiveReports 13
DisposablesCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class

Glossary Item Box

Utility class to redirect Dispose call to its inner items

Object Model

DisposablesCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DisposablesCollection
C#
public sealed class DisposablesCollection

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DisposablesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Members
GrapeCity.Viewer.Common Namespace


DisposablesCollection Class Members

[image]
ActiveReports 13
DisposablesCollection Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class

Glossary Item Box

The following tables list the members exposed by DisposablesCollection.

Public Constructors

 | Name | Description
Public Constructor | DisposablesCollection Constructor |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Registers object to be disposed on this collection disposal
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
static (Shared in Visual Basic) | From | Overloaded. Initialized new collection for another list of disposables
Top

See Also

Reference

DisposablesCollection Class
GrapeCity.Viewer.Common Namespace


DisposablesCollection Constructor

[image]
ActiveReports 13
DisposablesCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : DisposablesCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DisposablesCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


DisposablesCollection Class Methods

[image]
ActiveReports 13
DisposablesCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class

Glossary Item Box

For a list of all members of this type, see DisposablesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Registers object to be disposed on this collection disposal
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
static (Shared in Visual Basic) | From | Overloaded. Initialized new collection for another list of disposables
Top

See Also

Reference

DisposablesCollection Class
GrapeCity.Viewer.Common Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : Add Method

Glossary Item Box

Registers object to be disposed on this collection disposal

Overload List

Overload | Description
Add(IDisposable[]) | Registers object to be disposed on this collection disposal
Add(IDisposable) | Registers action to be invoked on object dispose
Add(Action[]) | Registers action to be invoked on object dispose

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


Add(IDisposable[]) Method

[image]
ActiveReports 13
Add(IDisposable[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(IDisposable[]) Method

disposables

Glossary Item Box

Registers object to be disposed on this collection disposal

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal ParamArray disposables() As IDisposable _
)
C#
public void Add(
   params IDisposable[] disposables
)

Parameters

disposables

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Add(IDisposable) Method

[image]
ActiveReports 13
Add(IDisposable) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(IDisposable) Method

disposable

Glossary Item Box

Registers action to be invoked on object dispose

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal disposable As IDisposable _
)
C#
public void Add(
   IDisposable disposable
)

Parameters

disposable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Add(Action[]) Method

[image]
ActiveReports 13
Add(Action[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(Action[]) Method

disposables

Glossary Item Box

Registers action to be invoked on object dispose

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal ParamArray disposables() As Action _
)
C#
public void Add(
   params Action[] disposables
)

Parameters

disposables

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : Dispose Method

Glossary Item Box

Performs tasks associated with freeing and releasing resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


From Method

[image]
ActiveReports 13
From Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : From Method

Glossary Item Box

Initialized new collection for another list of disposables

Overload List

Overload | Description
From(IDisposable[]) | Initialized new collection for another list of disposables
From(Action[]) | Initialized new collection for another list of actions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


From(IDisposable[]) Method

[image]
ActiveReports 13
From(IDisposable[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > From Method : From(IDisposable[]) Method

disposables

Glossary Item Box

Initialized new collection for another list of disposables

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function From( _
   ByVal ParamArray disposables() As IDisposable _
) As DisposablesCollection
C#
public static DisposablesCollection From(
   params IDisposable[] disposables
)

Parameters

disposables

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


From(Action[]) Method

[image]
ActiveReports 13
From(Action[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > From Method : From(Action[]) Method

actions

Glossary Item Box

Initialized new collection for another list of actions

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function From( _
   ByVal ParamArray actions() As Action _
) As DisposablesCollection
C#
public static DisposablesCollection From(
   params Action[] actions
)

Parameters

actions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


DocumentRendererAttribute Class

[image]
ActiveReports 13
DocumentRendererAttribute Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

Glossary Item Box

Allows to specified document renderer type for class.

Object Model

DocumentRendererAttribute Class

Syntax

Visual Basic (Declaration)
Public Class DocumentRendererAttribute
   Inherits System.Attribute
C#
public class DocumentRendererAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Viewer.Common.DocumentRendererAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Members
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Class Members

[image]
ActiveReports 13
DocumentRendererAttribute Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

Glossary Item Box

The following tables list the members exposed by DocumentRendererAttribute.

Public Constructors

 | Name | Description
Public Constructor | DocumentRendererAttribute Constructor | Initializes a new instance of the DocumentRendererAttribute class.
Top

Public Properties

 | Name | Description
Public Property | RendererType | Gets the type of the renderer.
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this System.Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Constructor

[image]
ActiveReports 13
DocumentRendererAttribute Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : DocumentRendererAttribute Constructor

rendererType
Type of the renderer.

Glossary Item Box

Initializes a new instance of the DocumentRendererAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rendererType As Type _
)
C#
public DocumentRendererAttribute(
   Type rendererType
)

Parameters

rendererType
Type of the renderer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


DocumentRendererAttribute Class Properties

[image]
ActiveReports 13
DocumentRendererAttribute Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

Glossary Item Box

For a list of all members of this type, see DocumentRendererAttribute members.

Public Properties

 | Name | Description
Public Property | RendererType | Gets the type of the renderer.
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this System.Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


RendererType Property

[image]
ActiveReports 13
RendererType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : RendererType Property

Glossary Item Box

Gets the type of the renderer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RendererType As Type
C#
public Type RendererType {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


DocumentSearchService Class

[image]
ActiveReports 13
DocumentSearchService Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class

Glossary Item Box

Search service implementation for ISearchableDocument

Object Model

DocumentSearchService Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DocumentSearchService
   Implements ISearchService
C#
public sealed class DocumentSearchService : ISearchService

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DocumentSearchService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentSearchService Members
GrapeCity.Viewer.Common Namespace


DocumentSearchService Class Members

[image]
ActiveReports 13
DocumentSearchService Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class

Glossary Item Box

The following tables list the members exposed by DocumentSearchService.

Public Constructors

 | Name | Description
Public Constructor | DocumentSearchService Constructor |
Top

Public Methods

 | Name | Description
Public Method | Find | Searches the document according to find options.
Top

See Also

Reference

DocumentSearchService Class
GrapeCity.Viewer.Common Namespace


DocumentSearchService Constructor

[image]
ActiveReports 13
DocumentSearchService Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentSearchService Class : DocumentSearchService Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DocumentSearchService()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentSearchService Class
DocumentSearchService Members


DocumentSearchService Class Methods

[image]
ActiveReports 13
DocumentSearchService Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class

Glossary Item Box

For a list of all members of this type, see DocumentSearchService members.

Public Methods

 | Name | Description
Public Method | Find | Searches the document according to find options.
Top

See Also

Reference

DocumentSearchService Class
GrapeCity.Viewer.Common Namespace


Find Method

[image]
ActiveReports 13
Find Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentSearchService Class : Find Method

document
findOptions
startFrom
maxCount
handler

Glossary Item Box

Searches the document according to find options.

Syntax

Visual Basic (Declaration)
Public Sub Find( _
   ByVal document As DocumentModel, _
   ByVal findOptions As FindOptions, _
   ByVal startFrom As SearchResult, _
   ByVal maxCount As Integer, _
   ByVal handler As Action(Of DocumentModel,IEnumerable(Of SearchResult)) _
)
C#
public void Find(
   DocumentModel document,
   FindOptions findOptions,
   SearchResult startFrom,
   int maxCount,
   Action<DocumentModel,IEnumerable<SearchResult>> handler
)

Parameters

document
findOptions
startFrom
maxCount
handler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentSearchService Class
DocumentSearchService Members


DoubleDelegateCommand Class

[image]
ActiveReports 13
DoubleDelegateCommand Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

Glossary Item Box

Command that delegates implementation to another delegate command

Object Model

DoubleDelegateCommand Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DoubleDelegateCommand
   Implements ICommand, IDelegateCommand
C#
public sealed class DoubleDelegateCommand : ICommand, IDelegateCommand

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DoubleDelegateCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Members
GrapeCity.Viewer.Common Namespace


DoubleDelegateCommand Class Members

[image]
ActiveReports 13
DoubleDelegateCommand Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

Glossary Item Box

The following tables list the members exposed by DoubleDelegateCommand.

Public Constructors

 | Name | Description
Public Constructor | DoubleDelegateCommand Constructor |
Top

Public Properties

 | Name | Description
Public Property | Command | Gets or sets the command.
Top

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event.
Top

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


DoubleDelegateCommand Constructor

[image]
ActiveReports 13
DoubleDelegateCommand Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : DoubleDelegateCommand Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DoubleDelegateCommand()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Methods

[image]
ActiveReports 13
DoubleDelegateCommand Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

Glossary Item Box

For a list of all members of this type, see DoubleDelegateCommand members.

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event.
Top

See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecute Method

[image]
ActiveReports 13
CanExecute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : CanExecute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method that determines whether the command can execute in its current state.

Syntax

Visual Basic (Declaration)
Public Function CanExecute( _
   ByVal parameter As Object _
) As Boolean
C#
public bool CanExecute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this instance can execute the specified parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Dispose Method

Glossary Item Box

Performs tasks associated with freeing and releasing resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


Execute Method

[image]
ActiveReports 13
Execute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Execute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method to be called when the command is invoked.

Syntax

Visual Basic (Declaration)
Public Sub Execute( _
   ByVal parameter As Object _
)
C#
public void Execute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


RaiseCanExecuteChanged Method

[image]
ActiveReports 13
RaiseCanExecuteChanged Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : RaiseCanExecuteChanged Method

Glossary Item Box

Raises CanExecuteChanged event.

Syntax

Visual Basic (Declaration)
Public Sub RaiseCanExecuteChanged()
C#
public void RaiseCanExecuteChanged()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Properties

[image]
ActiveReports 13
DoubleDelegateCommand Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

Glossary Item Box

For a list of all members of this type, see DoubleDelegateCommand members.

Public Properties

 | Name | Description
Public Property | Command | Gets or sets the command.
Top

See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


Command Property

[image]
ActiveReports 13
Command Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Command Property

Glossary Item Box

Gets or sets the command.

Syntax

Visual Basic (Declaration)
Public Property Command As IDelegateCommand
C#
public IDelegateCommand Command {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Events

[image]
ActiveReports 13
DoubleDelegateCommand Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

Glossary Item Box

For a list of all members of this type, see DoubleDelegateCommand members.

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event

[image]
ActiveReports 13
CanExecuteChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : CanExecuteChanged Event

Glossary Item Box

Occurs when changes occur that affect whether the command should execute.

Syntax

Visual Basic (Declaration)
Public Event CanExecuteChanged As EventHandler
C#
public event EventHandler CanExecuteChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


EnumerableExtensions Class

[image]
ActiveReports 13
EnumerableExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class

Glossary Item Box

Extends methods of work with IEnumerable.

Object Model

EnumerableExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class EnumerableExtensions
C#
public static class EnumerableExtensions

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.EnumerableExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Members
GrapeCity.Viewer.Common Namespace


EnumerableExtensions Class Members

[image]
ActiveReports 13
EnumerableExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class

Glossary Item Box

The following tables list the members exposed by EnumerableExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ForEach<T> | Executes action for each sequence item
static (Shared in Visual Basic) | GetRecursive<T> | Extract all descendants recursively
static (Shared in Visual Basic) | ZipEx<TSource1,TSource2,TResult> | Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Top

See Also

Reference

EnumerableExtensions Class
GrapeCity.Viewer.Common Namespace


EnumerableExtensions Class Methods

[image]
ActiveReports 13
EnumerableExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class

Glossary Item Box

For a list of all members of this type, see EnumerableExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ForEach<T> | Executes action for each sequence item
static (Shared in Visual Basic) | GetRecursive<T> | Extract all descendants recursively
static (Shared in Visual Basic) | ZipEx<TSource1,TSource2,TResult> | Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Top

See Also

Reference

EnumerableExtensions Class
GrapeCity.Viewer.Common Namespace


ForEach<T> Method

T
[image]
ActiveReports 13
ForEach<T> Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : ForEach<T> Method

source
action

Glossary Item Box

Executes action for each sequence item

Syntax

Visual Basic (Declaration)
Public Shared Sub ForEach(Of T)( _
   ByVal source As IEnumerable(Of T), _
   ByVal action As Action(Of T) _
)
C#
public static void ForEach<T>(
   IEnumerable<T> source,
   Action<T> action
)

Parameters

source
action

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


GetRecursive<T> Method

T
[image]
ActiveReports 13
GetRecursive<T> Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : GetRecursive<T> Method

source
selector

Glossary Item Box

Extract all descendants recursively

Syntax

Visual Basic (Declaration)
Public Shared Function GetRecursive(Of T)( _
   ByVal source As IEnumerable(Of T), _
   ByVal selector As Func(Of T,IEnumerable(Of T)) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> GetRecursive<T>(
   IEnumerable<T> source,
   Func<T,IEnumerable<T>> selector
)

Parameters

source
selector

Type Parameters

T

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


ZipEx<TSource1,TSource2,TResult> Method

TSource1
TSource2
TResult
[image]
ActiveReports 13
ZipEx<TSource1,TSource2,TResult> Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : ZipEx<TSource1,TSource2,TResult> Method

source1
source2
selector

Glossary Item Box

Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences

Syntax

Visual Basic (Declaration)
Public Shared Function ZipEx
    (Of TSource1,TSource2,TResult)( _
   ByVal source1 As IEnumerable(Of TSource1), _
   ByVal source2 As IEnumerable(Of TSource2), _
   ByVal selector As Func(Of TSource1,TSource2,TResult) _
) As IEnumerable(Of TResult)
C#
public static IEnumerable<TResult> ZipEx<TSource1,TSource2,TResult>(
   IEnumerable<TSource1> source1,
   IEnumerable<TSource2> source2,
   Func<TSource1,TSource2,TResult> selector
)

Parameters

source1
source2
selector

Type Parameters

TSource1
TSource2
TResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


NotifyCollectionChangedEventArgs Class

[image]
ActiveReports 13
NotifyCollectionChangedEventArgs Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class

Glossary Item Box

Describes the action that caused a System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.

Object Model

NotifyCollectionChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NotifyCollectionChangedEventArgs
   Inherits System.EventArgs
C#
public sealed class NotifyCollectionChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.Viewer.Common.NotifyCollectionChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Members
GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedEventArgs Class Members

[image]
ActiveReports 13
NotifyCollectionChangedEventArgs Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by NotifyCollectionChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | NotifyCollectionChangedEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets the action type.
Public Property | NewItems | Gets the new items.
Public Property | NewStartingIndex | Gets the index of the starting of new items.
Public Property | OldItems | Gets the old items.
Public Property | OldStartingIndex | Gets the index of the starting of old items.
Top

See Also

Reference

NotifyCollectionChangedEventArgs Class
GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedEventArgs Constructor

[image]
ActiveReports 13
NotifyCollectionChangedEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NotifyCollectionChangedEventArgs Constructor

Glossary Item Box

Overload List

Overload | Description
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)

[image]
ActiveReports 13
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)

action
newItem
oldItem
index

Glossary Item Box

Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As NotifyCollectionChangedAction, _
   ByVal newItem As Object, _
   ByVal oldItem As Object, _
   ByVal index As Integer _
)
C#
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action,
   object newItem,
   object oldItem,
   int index
)

Parameters

action
newItem
oldItem
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)

[image]
ActiveReports 13
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)

action
changedItem
index

Glossary Item Box

Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As NotifyCollectionChangedAction, _
   ByVal changedItem As Object, _
   ByVal index As Integer _
)
C#
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action,
   object changedItem,
   int index
)

Parameters

action
changedItem
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)

[image]
ActiveReports 13
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)

action

Glossary Item Box

Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As NotifyCollectionChangedAction _
)
C#
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action
)

Parameters

action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Class Properties

[image]
ActiveReports 13
NotifyCollectionChangedEventArgs Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see NotifyCollectionChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Action | Gets the action type.
Public Property | NewItems | Gets the new items.
Public Property | NewStartingIndex | Gets the index of the starting of new items.
Public Property | OldItems | Gets the old items.
Public Property | OldStartingIndex | Gets the index of the starting of old items.
Top

See Also

Reference

NotifyCollectionChangedEventArgs Class
GrapeCity.Viewer.Common Namespace


Action Property

[image]
ActiveReports 13
Action Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : Action Property

Glossary Item Box

Gets the action type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As NotifyCollectionChangedAction
C#
public NotifyCollectionChangedAction Action {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NewItems Property

[image]
ActiveReports 13
NewItems Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NewItems Property

Glossary Item Box

Gets the new items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewItems As IList
C#
public IList NewItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NewStartingIndex Property

[image]
ActiveReports 13
NewStartingIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NewStartingIndex Property

Glossary Item Box

Gets the index of the starting of new items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewStartingIndex As Integer
C#
public int NewStartingIndex {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


OldItems Property

[image]
ActiveReports 13
OldItems Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : OldItems Property

Glossary Item Box

Gets the old items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldItems As IList
C#
public IList OldItems {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


OldStartingIndex Property

[image]
ActiveReports 13
OldStartingIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : OldStartingIndex Property

Glossary Item Box

Gets the index of the starting of old items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldStartingIndex As Integer
C#
public int OldStartingIndex {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NullDelegateCommand Class

[image]
ActiveReports 13
NullDelegateCommand Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

Glossary Item Box

NullDelegateCommand implementation.

Object Model

NullDelegateCommand Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullDelegateCommand
   Implements ICommand, IDelegateCommand
C#
public sealed class NullDelegateCommand : ICommand, IDelegateCommand

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullDelegateCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullDelegateCommand Members
GrapeCity.Viewer.Common Namespace


NullDelegateCommand Class Members

[image]
ActiveReports 13
NullDelegateCommand Class Members
See Also Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

Glossary Item Box

The following tables list the members exposed by NullDelegateCommand.

Public Constructors

 | Name | Description
Public Constructor | NullDelegateCommand Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


NullDelegateCommand Constructor

[image]
ActiveReports 13
NullDelegateCommand Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : NullDelegateCommand Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public NullDelegateCommand()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullDelegateCommand Class Methods

[image]
ActiveReports 13
NullDelegateCommand Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

Glossary Item Box

For a list of all members of this type, see NullDelegateCommand members.

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top

See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecute Method

[image]
ActiveReports 13
CanExecute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : CanExecute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method that determines whether the command can execute in its current state.

Syntax

Visual Basic (Declaration)
Public Function CanExecute( _
   ByVal parameter As Object _
) As Boolean
C#
public bool CanExecute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this instance can execute the specified parameter; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


Execute Method

[image]
ActiveReports 13
Execute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : Execute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method to be called when the command is invoked.

Syntax

Visual Basic (Declaration)
Public Sub Execute( _
   ByVal parameter As Object _
)
C#
public void Execute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


RaiseCanExecuteChanged Method

[image]
ActiveReports 13
RaiseCanExecuteChanged Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : RaiseCanExecuteChanged Method

Glossary Item Box

Raise CanExecuteChanged event from external code.

Syntax

Visual Basic (Declaration)
Public Sub RaiseCanExecuteChanged()
C#
public void RaiseCanExecuteChanged()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullDelegateCommand Class Events

[image]
ActiveReports 13
NullDelegateCommand Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

Glossary Item Box

For a list of all members of this type, see NullDelegateCommand members.

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event

[image]
ActiveReports 13
CanExecuteChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : CanExecuteChanged Event

Glossary Item Box

Occurs when changes occur that affect whether the command should execute.

Syntax

Visual Basic (Declaration)
Public Event CanExecuteChanged As EventHandler
C#
public event EventHandler CanExecuteChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullRenderer Class

[image]
ActiveReports 13
NullRenderer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

Glossary Item Box

Null-object implementation for IDocumentRenderer interface

Object Model

NullRenderer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullRenderer
   Implements IDocumentRenderer
C#
public sealed class NullRenderer : IDocumentRenderer

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer Members
GrapeCity.Viewer.Common Namespace


NullRenderer Class Members

[image]
ActiveReports 13
NullRenderer Class Members
See Also Fields Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

Glossary Item Box

The following tables list the members exposed by NullRenderer.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | The NullRenderer instance
Top

Public Methods

 | Name | Description
Public Method | RenderPage | Renders page from current document
Top

See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


NullRenderer Class Methods

[image]
ActiveReports 13
NullRenderer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

Glossary Item Box

For a list of all members of this type, see NullRenderer members.

Public Methods

 | Name | Description
Public Method | RenderPage | Renders page from current document
Top

See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


RenderPage Method

[image]
ActiveReports 13
RenderPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer Class : RenderPage Method

index
Index of the page to render

Glossary Item Box

Renders page from current document

Syntax

Visual Basic (Declaration)
Public Function RenderPage( _
   ByVal index As Integer _
) As PageView
C#
public PageView RenderPage(
   int index
)

Parameters

index
Index of the page to render

Return Value

Rendered page view

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer Class
NullRenderer Members


NullRenderer Class Fields

[image]
ActiveReports 13
NullRenderer Class Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

Glossary Item Box

For a list of all members of this type, see NullRenderer members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | The NullRenderer instance
Top

See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


Instance Field

[image]
ActiveReports 13
Instance Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer Class : Instance Field

Glossary Item Box

The NullRenderer instance

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As IDocumentRenderer
C#
public static readonly IDocumentRenderer Instance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer Class
NullRenderer Members


NullRenderer.Factory Class

[image]
ActiveReports 13
NullRenderer.Factory Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class

Glossary Item Box

IDocumentRenderer factory.

Object Model

NullRenderer.Factory Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullRenderer.Factory
   Implements IDocumentRendererFactory
C#
public sealed class NullRenderer.Factory : IDocumentRendererFactory

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullRenderer.Factory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer.Factory Members
GrapeCity.Viewer.Common Namespace


NullRenderer.Factory Class Members

[image]
ActiveReports 13
NullRenderer.Factory Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class

Glossary Item Box

The following tables list the members exposed by NullRenderer.Factory.

Public Constructors

 | Name | Description
Public Constructor | NullRenderer.Factory Constructor |
Top

Public Methods

 | Name | Description
Public Method | Create | Overloaded. Returns MullRenderer.Instance object.
Top

See Also

Reference

NullRenderer.Factory Class
GrapeCity.Viewer.Common Namespace


NullRenderer.Factory Constructor

[image]
ActiveReports 13
NullRenderer.Factory Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class : NullRenderer.Factory Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public NullRenderer.Factory()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members


NullRenderer.Factory Class Methods

[image]
ActiveReports 13
NullRenderer.Factory Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class

Glossary Item Box

For a list of all members of this type, see NullRenderer.Factory members.

Public Methods

 | Name | Description
Public Method | Create | Overloaded. Returns MullRenderer.Instance object.
Top

See Also

Reference

NullRenderer.Factory Class
GrapeCity.Viewer.Common Namespace


Create Method

[image]
ActiveReports 13
Create Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class : Create Method

Glossary Item Box

Returns MullRenderer.Instance object.

Overload List

Overload | Description
Create(IApplicationContext,DocumentModel) | Returns MullRenderer.Instance object.
Create(IApplicationContext,DocumentModel,DeviceKind) | Returns MullRenderer.Instance object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members


Create(IApplicationContext,DocumentModel) Method

[image]
ActiveReports 13
Create(IApplicationContext,DocumentModel) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class > Create Method : Create(IApplicationContext,DocumentModel) Method

context
document

Glossary Item Box

Returns MullRenderer.Instance object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel _
) As IDocumentRenderer
C#
public IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document
)

Parameters

context
document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members
Overload List


Create(IApplicationContext,DocumentModel,DeviceKind) Method

[image]
ActiveReports 13
Create(IApplicationContext,DocumentModel,DeviceKind) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class > Create Method : Create(IApplicationContext,DocumentModel,DeviceKind) Method

context
document
device

Glossary Item Box

Returns MullRenderer.Instance object.

Syntax

Visual Basic (Declaration)
Public Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
C#
public IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document,
   DeviceKind device
)

Parameters

context
document
device

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members
Overload List


ObservableCollection<T> Class

T
[image]
ActiveReports 13
ObservableCollection<T> Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

Glossary Item Box

Wrapped System.Collections.ObjectModel observable collection

Object Model

ObservableCollection<T> Class

Syntax

Visual Basic (Declaration)
Public Class ObservableCollection(Of T)
   Inherits System.Collections.ObjectModel.Collection(Of T)
   Implements INotifyCollectionChanged
C#
public class ObservableCollection<T> : System.Collections.ObjectModel.Collection<T>, INotifyCollectionChanged

Type Parameters

T

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.Viewer.Common.ObservableCollection<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Members
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Class Members

[image]
ActiveReports 13
ObservableCollection<T> Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

Glossary Item Box

The following tables list the members exposed by ObservableCollection<T>.

Public Constructors

 | Name | Description
Public Constructor | ObservableCollection<T> Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Public Event | PropertyChanged | Occurs when a property value changes.
Top

See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Constructor

[image]
ActiveReports 13
ObservableCollection<T> Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : ObservableCollection<T> Constructor

Glossary Item Box

Overload List

Overload | Description
ObservableCollection<T> Constructor(IList<T>) | Initializes a new instance of the ObservableCollection<T> class.
ObservableCollection<T> Constructor() | Initializes a new instance of the ObservableCollection<T> class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


ObservableCollection<T> Constructor(IList<T>)

[image]
ActiveReports 13
ObservableCollection<T> Constructor(IList<T>)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class > ObservableCollection<T> Constructor : ObservableCollection<T> Constructor(IList<T>)

data
The initial items list.

Glossary Item Box

Initializes a new instance of the ObservableCollection<T> class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As IList(Of T) _
)
C#
public ObservableCollection<T>(
   IList<T> data
)

Parameters

data
The initial items list.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members
Overload List


ObservableCollection<T> Constructor()

[image]
ActiveReports 13
ObservableCollection<T> Constructor()
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class > ObservableCollection<T> Constructor : ObservableCollection<T> Constructor()

Glossary Item Box

Initializes a new instance of the ObservableCollection<T> class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ObservableCollection<T>()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members
Overload List


ObservableCollection<T> Class Events

[image]
ActiveReports 13
ObservableCollection<T> Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

Glossary Item Box

For a list of all members of this type, see ObservableCollection<T> members.

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Public Event | PropertyChanged | Occurs when a property value changes.
Top

See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


CollectionChanged Event

[image]
ActiveReports 13
CollectionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : CollectionChanged Event

Glossary Item Box

Occurs when the items list of the collection has changed, or the collection is reset.

Syntax

Visual Basic (Declaration)
Public Event CollectionChanged As NotifyCollectionChangedEventHandler
C#
public event NotifyCollectionChangedEventHandler CollectionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


PropertyChanged Event

[image]
ActiveReports 13
PropertyChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : PropertyChanged Event

Glossary Item Box

Occurs when a property value changes.

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged

Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


PageView Class

[image]
ActiveReports 13
PageView Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

Glossary Item Box

Base abstract class for concrete page renderers.

Object Model

PageView Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class PageView
C#
public abstract class PageView

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.PageView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageView Members
GrapeCity.Viewer.Common Namespace


PageView Class Members

[image]
ActiveReports 13
PageView Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

Glossary Item Box

The following tables list the members exposed by PageView.

Public Properties

 | Name | Description
Public Property | Device | Gets the device kind.
Public Property | Size | Gets the page view size.
Top

Public Methods

 | Name | Description
Public Method | AsCachable | Convert to CachedPageView.
Top

See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


PageView Class Methods

[image]
ActiveReports 13
PageView Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

Glossary Item Box

For a list of all members of this type, see PageView members.

Public Methods

 | Name | Description
Public Method | AsCachable | Convert to CachedPageView.
Top

See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


AsCachable Method

[image]
ActiveReports 13
AsCachable Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : AsCachable Method

format

Glossary Item Box

Convert to CachedPageView.

Syntax

Visual Basic (Declaration)
Public MustOverride Function AsCachable( _
   ByVal format As CacheFormat _
) As CachedPageView
C#
public abstract CachedPageView AsCachable(
   CacheFormat format
)

Parameters

format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageView Class
PageView Members


PageView Class Properties

[image]
ActiveReports 13
PageView Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

Glossary Item Box

For a list of all members of this type, see PageView members.

Public Properties

 | Name | Description
Public Property | Device | Gets the device kind.
Public Property | Size | Gets the page view size.
Top

See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


Device Property

[image]
ActiveReports 13
Device Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : Device Property

Glossary Item Box

Gets the device kind.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Device As DeviceKind
C#
public DeviceKind Device {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageView Class
PageView Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : Size Property

Glossary Item Box

Gets the page view size.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Size As Size
C#
public abstract Size Size {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageView Class
PageView Members


RectExtensions Class

[image]
ActiveReports 13
RectExtensions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class

Glossary Item Box

Extends Rect struct with helper methods.

Object Model

RectExtensions Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class RectExtensions
C#
public static class RectExtensions

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.RectExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RectExtensions Members
GrapeCity.Viewer.Common Namespace


RectExtensions Class Members

[image]
ActiveReports 13
RectExtensions Class Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class

Glossary Item Box

The following tables list the members exposed by RectExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Round | Rounds the coordinates and size of the rectangle.
Top

See Also

Reference

RectExtensions Class
GrapeCity.Viewer.Common Namespace


RectExtensions Class Methods

[image]
ActiveReports 13
RectExtensions Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class

Glossary Item Box

For a list of all members of this type, see RectExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Round | Rounds the coordinates and size of the rectangle.
Top

See Also

Reference

RectExtensions Class
GrapeCity.Viewer.Common Namespace


Round Method

[image]
ActiveReports 13
Round Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > RectExtensions Class : Round Method

rect
digits

Glossary Item Box

Rounds the coordinates and size of the rectangle.

Syntax

Visual Basic (Declaration)
Public Shared Function Round( _
   ByVal rect As Rect, _
   ByVal digits As Integer _
) As Rect
C#
public static Rect Round(
   Rect rect,
   int digits
)

Parameters

rect
digits

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RectExtensions Class
RectExtensions Members


StreamDocumentLoader Class

[image]
ActiveReports 13
StreamDocumentLoader Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class

Glossary Item Box

Served to download documents from the stream

Object Model

StreamDocumentLoader Class

Syntax

Visual Basic (Declaration)
Public Class StreamDocumentLoader
   Implements IDocumentLoader
C#
public class StreamDocumentLoader : IDocumentLoader

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.StreamDocumentLoader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamDocumentLoader Members
GrapeCity.Viewer.Common Namespace


StreamDocumentLoader Class Members

[image]
ActiveReports 13
StreamDocumentLoader Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class

Glossary Item Box

The following tables list the members exposed by StreamDocumentLoader.

Public Constructors

 | Name | Description
Public Constructor | StreamDocumentLoader Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DocumentFormat | Gets document format
Top

See Also

Reference

StreamDocumentLoader Class
GrapeCity.Viewer.Common Namespace


StreamDocumentLoader Constructor

[image]
ActiveReports 13
StreamDocumentLoader Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class : StreamDocumentLoader Constructor

Glossary Item Box

Overload List

Overload | Description
StreamDocumentLoader Constructor(Stream,DocumentFormat) | Initializes a new instance of the StreamDocumentLoader class
StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat) | Initializes a new instance of the StreamDocumentLoader class

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members


StreamDocumentLoader Constructor(Stream,DocumentFormat)

[image]
ActiveReports 13
StreamDocumentLoader Constructor(Stream,DocumentFormat)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class > StreamDocumentLoader Constructor : StreamDocumentLoader Constructor(Stream,DocumentFormat)

s
Stream with report
format
Nessesary document format

Glossary Item Box

Initializes a new instance of the StreamDocumentLoader class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal s As Stream, _
   ByVal format As DocumentFormat _
)
C#
public StreamDocumentLoader(
   Stream s,
   DocumentFormat format
)

Parameters

s
Stream with report
format
Nessesary document format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members
Overload List


StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)

[image]
ActiveReports 13
StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class > StreamDocumentLoader Constructor : StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)

s
Stream with report
baseUri
Base uri
format
Nessesary document format

Glossary Item Box

Initializes a new instance of the StreamDocumentLoader class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal s As Stream, _
   ByVal baseUri As Uri, _
   ByVal format As DocumentFormat _
)
C#
public StreamDocumentLoader(
   Stream s,
   Uri baseUri,
   DocumentFormat format
)

Parameters

s
Stream with report
baseUri
Base uri
format
Nessesary document format

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members
Overload List


StreamDocumentLoader Class Properties

[image]
ActiveReports 13
StreamDocumentLoader Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class

Glossary Item Box

For a list of all members of this type, see StreamDocumentLoader members.

Public Properties

 | Name | Description
Public Property | DocumentFormat | Gets document format
Top

See Also

Reference

StreamDocumentLoader Class
GrapeCity.Viewer.Common Namespace


DocumentFormat Property

[image]
ActiveReports 13
DocumentFormat Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class : DocumentFormat Property

Glossary Item Box

Gets document format

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DocumentFormat As DocumentFormat
C#
public DocumentFormat DocumentFormat {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members


DeviceKind Enumeration

[image]
ActiveReports 13
DeviceKind Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DeviceKind Enumeration

Glossary Item Box

Defines enumeration of possible target devices for view.

Syntax

Visual Basic (Declaration)
Public Enum DeviceKind
   Inherits System.Enum
C#
public enum DeviceKind : System.Enum

Members

Member | Description
Export | Output to Export target device
Paper | Output to Paper target device
Screen | Output to Screen target device

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.DeviceKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Viewer.Common Namespace


DocumentFormat Enumeration

[image]
ActiveReports 13
DocumentFormat Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentFormat Enumeration

Glossary Item Box

Specifies possible document formats

Syntax

Visual Basic (Declaration)
Public Enum DocumentFormat
   Inherits System.Enum
C#
public enum DocumentFormat : System.Enum

Members

Member | Description
Rdf | AR document, binary format
Rdlx | DDR document, xml format
Rpx | AR document, xml format

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.DocumentFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Viewer.Common Namespace


LoadState Enumeration

[image]
ActiveReports 13
LoadState Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : LoadState Enumeration

Glossary Item Box

Possible loading states

Syntax

Visual Basic (Declaration)
Public Enum LoadState
   Inherits System.Enum
C#
public enum LoadState : System.Enum

Members

Member | Description
Cancelled | Loading cancelled.
Cancelling | Loading is cancelling.
Completed | Loading completed.
Error | Error occured.
InProgress | Loading in progress.
NotStarted | Loading not started.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.LoadState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedAction Enumeration

[image]
ActiveReports 13
NotifyCollectionChangedAction Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedAction Enumeration

Glossary Item Box

Enum NotifyCollectionChangedAction

Syntax

Visual Basic (Declaration)
Public Enum NotifyCollectionChangedAction
   Inherits System.Enum
C#
public enum NotifyCollectionChangedAction : System.Enum

Members

Member | Description
Add | Add action.
Remove | Remove action.
Replace | Replace action.
Reset | Reset action.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.NotifyCollectionChangedAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Viewer.Common Namespace


PrintingSettings Enumeration

[image]
ActiveReports 13
PrintingSettings Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : PrintingSettings Enumeration

Glossary Item Box

Print process settings

Syntax

Visual Basic (Declaration)
Public Enum PrintingSettings
   Inherits System.Enum
C#
public enum PrintingSettings : System.Enum

Members

Member | Description
None | If set the Print-dialog will not be shown.
ShowPrintDialog | If set the Print-dialog will be shown.
ShowPrintProgressDialog | If set the dialog with printing state information will be shown.
UsePrintingThread | If set the printing will be run in new thread.
UseStandardDialog | If set the printing will use standard PrintDialog
UseXpStyleDialog | If set the printing will use the XP style dialog

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.PrintingSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Viewer.Common Namespace


Color Structure

[image]
ActiveReports 13
Color Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

Glossary Item Box

Platform independent color implementation

Object Model

Color Structure

Syntax

Visual Basic (Declaration)
Public Structure Color
   Inherits System.ValueType
C#
public struct Color : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Color

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Members
GrapeCity.Viewer.Common Namespace


Color Structure Members

[image]
ActiveReports 13
Color Structure Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

Glossary Item Box

The following tables list the members exposed by Color.

Public Constructors

 | Name | Description
Public Constructor | Color Constructor | Initializes a new instance of the Color struct.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Black | Black color.
static (Shared in Visual Basic) | Blue | Blue color.
static (Shared in Visual Basic) | DarkBlue | Dark blue color.
static (Shared in Visual Basic) | Empty | Empty color.
static (Shared in Visual Basic) | Gray | Gray color.
static (Shared in Visual Basic) | Red | Red color.
static (Shared in Visual Basic) | Transparent | Transparent color.
static (Shared in Visual Basic) | White | White color.
Top

Public Properties

 | Name | Description
Public Property | A | Gets the A color component.
Public Property | B | Gets the B color component.
Public Property | G | Gets the G color component.
Public Property | IsEmpty | Gets a value indicating whether this instance is empty.
Public Property | R | Gets the R color component.
Public Property | Value | Gets the value.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified instance of Color is equal to this instance
static (Shared in Visual Basic) | FromArgb | Overloaded. Creates new color from color components.
Public Method | GetHashCode | Returns the hash code for this instance.
Public Method | ToArgb | Gets ARGB value of the color.
Top

Public Operators

public Operator Equality | Implements the operator ==.
public Operator Implicit Type Conversion | Performs an implicit conversion from Color to System.UInt32.
public Operator Inequality | Implements the operator !=.
Top

See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Color Constructor

[image]
ActiveReports 13
Color Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Color Constructor

value
The value.

Glossary Item Box

Initializes a new instance of the Color struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
C#
public Color(
   long value
)

Parameters

value
The value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Color Structure Methods

[image]
ActiveReports 13
Color Structure Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

Glossary Item Box

For a list of all members of this type, see Color members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified instance of Color is equal to this instance
static (Shared in Visual Basic) | FromArgb | Overloaded. Creates new color from color components.
Public Method | GetHashCode | Returns the hash code for this instance.
Public Method | ToArgb | Gets ARGB value of the color.
Top

See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Equals Method

Glossary Item Box

Determines whether the specified instance of Color is equal to this instance

Overload List

Overload | Description
Equals(Color) | Determines whether the specified instance of Color is equal to this instance
Equals(Object) | Determines whether the specified System.Object is equal to this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Equals(Color) Method

[image]
ActiveReports 13
Equals(Color) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > Equals Method : Equals(Color) Method

obj
The instance of Color to compare.

Glossary Item Box

Determines whether the specified instance of Color is equal to this instance

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal obj As Color _
) As Boolean
C#
public bool Equals(
   Color obj
)

Parameters

obj
The instance of Color to compare.

Return Value

True, if these instances are equal, false otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members
Overload List


Equals(Object) Method

[image]
ActiveReports 13
Equals(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > Equals Method : Equals(Object) Method

obj

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members
Overload List


FromArgb Method

[image]
ActiveReports 13
FromArgb Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : FromArgb Method

Glossary Item Box

Creates new color from color components.

Overload List

Overload | Description
FromArgb(Int32) | Creates new color from color components.
FromArgb(Int32,Color) | Creates new color from color components.
FromArgb(Byte,Byte,Byte,Byte) | Creates new color from color components.
FromArgb(Int32,Int32,Int32) | Creates new color from color components.
FromArgb(Int32,Int32,Int32,Int32) | Creates new color from color components.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


FromArgb(Int32) Method

[image]
ActiveReports 13
FromArgb(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32) Method

value
The value.

Glossary Item Box

Creates new color from color components.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromArgb( _
   ByVal value As Integer _
) As Color
C#
public static Color FromArgb(
   int value
)

Parameters

value
The value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Color) Method

[image]
ActiveReports 13
FromArgb(Int32,Color) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Color) Method

a
A.
c
The c.

Glossary Item Box

Creates new color from color components.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromArgb( _
   ByVal a As Integer, _
   ByVal c As Color _
) As Color
C#
public static Color FromArgb(
   int a,
   Color c
)

Parameters

a
A.
c
The c.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Byte,Byte,Byte,Byte) Method

[image]
ActiveReports 13
FromArgb(Byte,Byte,Byte,Byte) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Byte,Byte,Byte,Byte) Method

a
A.
r
The r.
g
The g.
b
The b.

Glossary Item Box

Creates new color from color components.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromArgb( _
   ByVal a As Byte, _
   ByVal r As Byte, _
   ByVal g As Byte, _
   ByVal b As Byte _
) As Color
C#
public static Color FromArgb(
   byte a,
   byte r,
   byte g,
   byte b
)

Parameters

a
A.
r
The r.
g
The g.
b
The b.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Int32,Int32) Method

[image]
ActiveReports 13
FromArgb(Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Int32,Int32) Method

r
g
b

Glossary Item Box

Creates new color from color components.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromArgb( _
   ByVal r As Integer, _
   ByVal g As Integer, _
   ByVal b As Integer _
) As Color
C#
public static Color FromArgb(
   int r,
   int g,
   int b
)

Parameters

r
g
b

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
FromArgb(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Int32,Int32,Int32) Method

a
r
g
b

Glossary Item Box

Creates new color from color components.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromArgb( _
   ByVal a As Integer, _
   ByVal r As Integer, _
   ByVal g As Integer, _
   ByVal b As Integer _
) As Color
C#
public static Color FromArgb(
   int a,
   int r,
   int g,
   int b
)

Parameters

a
r
g
b

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members
Overload List


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : GetHashCode Method

Glossary Item Box

Returns the hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


ToArgb Method

[image]
ActiveReports 13
ToArgb Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : ToArgb Method

Glossary Item Box

Gets ARGB value of the color.

Syntax

Visual Basic (Declaration)
Public Function ToArgb() As Integer
C#
public int ToArgb()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Color Structure Properties

[image]
ActiveReports 13
Color Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

Glossary Item Box

For a list of all members of this type, see Color members.

Public Properties

 | Name | Description
Public Property | A | Gets the A color component.
Public Property | B | Gets the B color component.
Public Property | G | Gets the G color component.
Public Property | IsEmpty | Gets a value indicating whether this instance is empty.
Public Property | R | Gets the R color component.
Public Property | Value | Gets the value.
Top

See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


A Property

[image]
ActiveReports 13
A Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : A Property

Glossary Item Box

Gets the A color component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A As Byte
C#
public byte A {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


B Property

[image]
ActiveReports 13
B Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : B Property

Glossary Item Box

Gets the B color component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B As Byte
C#
public byte B {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


G Property

[image]
ActiveReports 13
G Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : G Property

Glossary Item Box

Gets the G color component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property G As Byte
C#
public byte G {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


IsEmpty Property

[image]
ActiveReports 13
IsEmpty Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : IsEmpty Property

Glossary Item Box

Gets a value indicating whether this instance is empty.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Property Value

true if this instance is empty; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


R Property

[image]
ActiveReports 13
R Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : R Property

Glossary Item Box

Gets the R color component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property R As Byte
C#
public byte R {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Value Property

[image]
ActiveReports 13
Value Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Value Property

Glossary Item Box

Gets the value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Long
C#
public long Value {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Color Structure Fields

[image]
ActiveReports 13
Color Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

Glossary Item Box

For a list of all members of this type, see Color members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Black | Black color.
static (Shared in Visual Basic) | Blue | Blue color.
static (Shared in Visual Basic) | DarkBlue | Dark blue color.
static (Shared in Visual Basic) | Empty | Empty color.
static (Shared in Visual Basic) | Gray | Gray color.
static (Shared in Visual Basic) | Red | Red color.
static (Shared in Visual Basic) | Transparent | Transparent color.
static (Shared in Visual Basic) | White | White color.
Top

See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Black Field

[image]
ActiveReports 13
Black Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Black Field

Glossary Item Box

Black color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Black As Color
C#
public static readonly Color Black

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Blue Field

[image]
ActiveReports 13
Blue Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Blue Field

Glossary Item Box

Blue color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Blue As Color
C#
public static readonly Color Blue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


DarkBlue Field

[image]
ActiveReports 13
DarkBlue Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : DarkBlue Field

Glossary Item Box

Dark blue color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DarkBlue As Color
C#
public static readonly Color DarkBlue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Empty Field

Glossary Item Box

Empty color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Color
C#
public static readonly Color Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Gray Field

[image]
ActiveReports 13
Gray Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Gray Field

Glossary Item Box

Gray color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Gray As Color
C#
public static readonly Color Gray

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Red Field

[image]
ActiveReports 13
Red Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Red Field

Glossary Item Box

Red color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Red As Color
C#
public static readonly Color Red

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Transparent Field

[image]
ActiveReports 13
Transparent Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Transparent Field

Glossary Item Box

Transparent color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Transparent As Color
C#
public static readonly Color Transparent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


White Field

[image]
ActiveReports 13
White Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : White Field

Glossary Item Box

White color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly White As Color
C#
public static readonly Color White

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Equality Operator

[image]
ActiveReports 13
Equality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Equality Operator

color1
The color1.
color2
The color2.

Glossary Item Box

Implements the operator ==.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal color1 As Color, _
   ByVal color2 As Color _
) As Boolean
C#
public bool operator ==(
   Color color1,
   Color color2
)

Parameters

color1
The color1.
color2
The color2.

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Implicit Type Conversion Operator

[image]
ActiveReports 13
Implicit Type Conversion Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Implicit Type Conversion Operator

color
The color.

Glossary Item Box

Performs an implicit conversion from Color to System.UInt32.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal color As Color _
) As UInteger
C#
public uint operator implicit(
   Color color
)

Parameters

color
The color.

Return Value

The result of the conversion.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Inequality Operator

[image]
ActiveReports 13
Inequality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Inequality Operator

color1
The color1.
color2
The color2.

Glossary Item Box

Implements the operator !=.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal color1 As Color, _
   ByVal color2 As Color _
) As Boolean
C#
public bool operator !=(
   Color color1,
   Color color2
)

Parameters

color1
The color1.
color2
The color2.

Return Value

The result of the operator.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


Margin Structure

[image]
ActiveReports 13
Margin Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

Glossary Item Box

Stores page margins

Object Model

Margin Structure

Syntax

Visual Basic (Declaration)
Public Structure Margin
   Inherits System.ValueType
C#
public struct Margin : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Margin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Members
GrapeCity.Viewer.Common Namespace


Margin Structure Members

[image]
ActiveReports 13
Margin Structure Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

Glossary Item Box

The following tables list the members exposed by Margin.

Public Constructors

 | Name | Description
Public Constructor | Margin Constructor | Ctor
Top

Public Fields

 | Name | Description
Public Field | Bottom | Bottom margin
static (Shared in Visual Basic) | Empty | Initializes an empty margin with all margins setted to zero.
Public Field | Left | Left margin
Public Field | Right | Right margin
Public Field | Top | Top margin
Top

Public Properties

 | Name | Description
Public Property | Horizontal | Horizontal margin (left plus right)
Public Property | Vertical | Vertical margin (top plus bottom)
Top

Public Methods

 | Name | Description
Public Method | Equals | Checks whether the Margin equals to the specified one.
Top

See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Margin Constructor

[image]
ActiveReports 13
Margin Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Margin Constructor

left
Left margin
right
Right margin
top
Top margin
bottom
Bottom margin

Glossary Item Box

Ctor

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Single, _
   ByVal right As Single, _
   ByVal top As Single, _
   ByVal bottom As Single _
)
C#
public Margin(
   float left,
   float right,
   float top,
   float bottom
)

Parameters

left
Left margin
right
Right margin
top
Top margin
bottom
Bottom margin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Margin Structure Methods

[image]
ActiveReports 13
Margin Structure Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

Glossary Item Box

For a list of all members of this type, see Margin members.

Public Methods

 | Name | Description
Public Method | Equals | Checks whether the Margin equals to the specified one.
Top

See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Equals Method

obj
Margin to check with.

Glossary Item Box

Checks whether the Margin equals to the specified one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
Margin to check with.

Return Value

True if the margins are equal, False othervise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Margin Structure Properties

[image]
ActiveReports 13
Margin Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

Glossary Item Box

For a list of all members of this type, see Margin members.

Public Properties

 | Name | Description
Public Property | Horizontal | Horizontal margin (left plus right)
Public Property | Vertical | Vertical margin (top plus bottom)
Top

See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Horizontal Property

[image]
ActiveReports 13
Horizontal Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Horizontal Property

Glossary Item Box

Horizontal margin (left plus right)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Horizontal As Single
C#
public float Horizontal {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Vertical Property

[image]
ActiveReports 13
Vertical Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Vertical Property

Glossary Item Box

Vertical margin (top plus bottom)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Vertical As Single
C#
public float Vertical {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Margin Structure Fields

[image]
ActiveReports 13
Margin Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

Glossary Item Box

For a list of all members of this type, see Margin members.

Public Fields

 | Name | Description
Public Field | Bottom | Bottom margin
static (Shared in Visual Basic) | Empty | Initializes an empty margin with all margins setted to zero.
Public Field | Left | Left margin
Public Field | Right | Right margin
Public Field | Top | Top margin
Top

See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Bottom Field

[image]
ActiveReports 13
Bottom Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Bottom Field

Glossary Item Box

Bottom margin

Syntax

Visual Basic (Declaration)
Public ReadOnly Bottom As Single
C#
public readonly float Bottom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Empty Field

Glossary Item Box

Initializes an empty margin with all margins setted to zero.

Syntax

Visual Basic (Declaration)
Public Shared Empty As Margin
C#
public static Margin Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Left Field

[image]
ActiveReports 13
Left Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Left Field

Glossary Item Box

Left margin

Syntax

Visual Basic (Declaration)
Public ReadOnly Left As Single
C#
public readonly float Left

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Right Field

[image]
ActiveReports 13
Right Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Right Field

Glossary Item Box

Right margin

Syntax

Visual Basic (Declaration)
Public ReadOnly Right As Single
C#
public readonly float Right

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Top Field

[image]
ActiveReports 13
Top Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Top Field

Glossary Item Box

Top margin

Syntax

Visual Basic (Declaration)
Public ReadOnly Top As Single
C#
public readonly float Top

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margin Structure
Margin Members


Point Structure

[image]
ActiveReports 13
Point Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

Glossary Item Box

Platform independent point

Object Model

Point Structure

Syntax

Visual Basic (Declaration)
Public Structure Point
   Inherits System.ValueType
C#
public struct Point : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Point

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Members
GrapeCity.Viewer.Common Namespace


Point Structure Members

[image]
ActiveReports 13
Point Structure Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

Glossary Item Box

The following tables list the members exposed by Point.

Public Constructors

 | Name | Description
Public Constructor | Point Constructor | Initializes a new instance of the Point class with the specified coordinates.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a Point that has X and Y values set to zero
Top

Public Properties

 | Name | Description
Public Property | X | Gets the x-coordinate of this Point.
Public Property | Y | Gets the y-coordinate of this Point.
Top

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Returns a System.String that represents this instance.
Top

Public Operators

public Operator Addition | Translates a Point by a given Size.
public Operator Unary Negation | Multiplies the point coordinates by -1.
Top

See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Point Constructor

[image]
ActiveReports 13
Point Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Point Constructor

x
The horizontal position of the point.
y
The vertical position of the point.

Glossary Item Box

Initializes a new instance of the Point class with the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
C#
public Point(
   double x,
   double y
)

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Point Structure Methods

[image]
ActiveReports 13
Point Structure Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

Glossary Item Box

For a list of all members of this type, see Point members.

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Equals Method

obj

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Offset Method

[image]
ActiveReports 13
Offset Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Offset Method

Glossary Item Box

Adjusts the location of this rectangle by the specified amount.

Overload List

Overload | Description
Offset(Double,Double) | Adjusts the location of this rectangle by the specified amount.
Offset(Size) | Adjusts the location of this rectangle by the specified amount.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Offset(Double,Double) Method

[image]
ActiveReports 13
Offset(Double,Double) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure > Offset Method : Offset(Double,Double) Method

x
The horizontal offset.
y
The vertical offset.

Glossary Item Box

Adjusts the location of this rectangle by the specified amount.

Syntax

Visual Basic (Declaration)
Public Overloads Function Offset( _
   ByVal x As Double, _
   ByVal y As Double _
) As Point
C#
public Point Offset(
   double x,
   double y
)

Parameters

x
The horizontal offset.
y
The vertical offset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members
Overload List


Offset(Size) Method

[image]
ActiveReports 13
Offset(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure > Offset Method : Offset(Size) Method

offset
Amount to offset the location.

Glossary Item Box

Adjusts the location of this rectangle by the specified amount.

Syntax

Visual Basic (Declaration)
Public Overloads Function Offset( _
   ByVal offset As Size _
) As Point
C#
public Point Offset(
   Size offset
)

Parameters

offset
Amount to offset the location.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members
Overload List


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String that represents this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Point Structure Properties

[image]
ActiveReports 13
Point Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

Glossary Item Box

For a list of all members of this type, see Point members.

Public Properties

 | Name | Description
Public Property | X | Gets the x-coordinate of this Point.
Public Property | Y | Gets the y-coordinate of this Point.
Top

See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


X Property

[image]
ActiveReports 13
X Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : X Property

Glossary Item Box

Gets the x-coordinate of this Point.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Double
C#
public double X {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Y Property

[image]
ActiveReports 13
Y Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Y Property

Glossary Item Box

Gets the y-coordinate of this Point.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Double
C#
public double Y {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Point Structure Fields

[image]
ActiveReports 13
Point Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

Glossary Item Box

For a list of all members of this type, see Point members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a Point that has X and Y values set to zero
Top

See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Empty Field

Glossary Item Box

Represents a Point that has X and Y values set to zero

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Point
C#
public static readonly Point Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Addition Operator

[image]
ActiveReports 13
Addition Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Addition Operator

p1
The Point to translate.
sz
A Size that specifies the pair of numbers to add to the coordinates of pt.

Glossary Item Box

Translates a Point by a given Size.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal p1 As Point, _
   ByVal sz As Size _
) As Point
C#
public Point operator +(
   Point p1,
   Size sz
)

Parameters

p1
The Point to translate.
sz
A Size that specifies the pair of numbers to add to the coordinates of pt.

Return Value

The translated Point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Unary Negation Operator

[image]
ActiveReports 13
Unary Negation Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Unary Negation Operator

pt

Glossary Item Box

Multiplies the point coordinates by -1.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal pt As Point _
) As Point
C#
public Point operator -(
   Point pt
)

Parameters

pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Point Structure
Point Members


Rect Structure

[image]
ActiveReports 13
Rect Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

Glossary Item Box

Platform aware rectangle structure

Object Model

Rect Structure

Syntax

Visual Basic (Declaration)
Public Structure Rect
   Inherits System.ValueType
C#
public struct Rect : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Rect

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Members
GrapeCity.Viewer.Common Namespace


Rect Structure Members

[image]
ActiveReports 13
Rect Structure Members
See Also Fields Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

Glossary Item Box

The following tables list the members exposed by Rect.

Public Constructors

 | Name | Description
Public Constructor | Rect Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Initializes an empty Rect with zero location and size.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the bottom edge of this rectangle.
Public Property | Height | Gets the height of this rectangle.
Public Property | IsEmpty | Tests whether the size of this rectangle less or equal 0.
Public Property | Left | Gets the x-coordinate of the left edge of this rectangle.
Public Property | Location | Gets the coordinates of the upper-left corner of this rectangle.
Public Property | Right | Gets the x-coordinate of the right edge of this rectangle.
Public Property | Size | Gets the size of this rectangle.
Public Property | Top | Gets the y-coordinate of the top edge of this rectangle.
Public Property | Width | Gets the width of this rectangle.
Public Property | X | Gets the x-coordinate of the upper-left corner of this rectangle.
Public Property | Y | Gets the y-coordinate of the upper-left corner of this rectangle.
Top

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this rectangle.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromLTRB | Creates a Rect with the specified edge locations.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Inflate | Overloaded. Enlarges this Rect by the specified amount.
Public Method | Intersect | Overloaded. Replaces this Rect with the intersection of itself and the specified Rect.
Public Method | IntersectsWith | Determines if this rectangle intersects with specified rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | Scale | Overloaded. Scales the rectangle by specified scale factor.
Public Method | ToString | Returns a System.String that represents this instance.
static (Shared in Visual Basic) | Union | Creates a Rect structure that contains the union of two Rect structures.
Top

See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Rect Constructor

[image]
ActiveReports 13
Rect Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Rect Constructor

Glossary Item Box

Overload List

Overload | Description
Rect Constructor(Double,Double,Double,Double) | Initializes a new instance of the Rect class with the specified location and size.
Rect Constructor(Point,Size) | Initializes a new instance of the Rect class with the specified location and size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Rect Constructor(Double,Double,Double,Double)

[image]
ActiveReports 13
Rect Constructor(Double,Double,Double,Double)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Rect Constructor : Rect Constructor(Double,Double,Double,Double)

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

Glossary Item Box

Initializes a new instance of the Rect class with the specified location and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
C#
public Rect(
   double x,
   double y,
   double width,
   double height
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Rect Constructor(Point,Size)

[image]
ActiveReports 13
Rect Constructor(Point,Size)
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Rect Constructor : Rect Constructor(Point,Size)

location
A Point that represents the upper-left corner of the rectangle.
size
A Rect.Size that represents the width and height of the rectangle.

Glossary Item Box

Initializes a new instance of the Rect class with the specified location and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal location As Point, _
   ByVal size As Size _
)
C#
public Rect(
   Point location,
   Size size
)

Parameters

location
A Point that represents the upper-left corner of the rectangle.
size
A Rect.Size that represents the width and height of the rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Rect Structure Methods

[image]
ActiveReports 13
Rect Structure Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

Glossary Item Box

For a list of all members of this type, see Rect members.

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this rectangle.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromLTRB | Creates a Rect with the specified edge locations.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Inflate | Overloaded. Enlarges this Rect by the specified amount.
Public Method | Intersect | Overloaded. Replaces this Rect with the intersection of itself and the specified Rect.
Public Method | IntersectsWith | Determines if this rectangle intersects with specified rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | Scale | Overloaded. Scales the rectangle by specified scale factor.
Public Method | ToString | Returns a System.String that represents this instance.
static (Shared in Visual Basic) | Union | Creates a Rect structure that contains the union of two Rect structures.
Top

See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Contains Method

Glossary Item Box

Determines if the specified point is contained within this rectangle.

Overload List

Overload | Description
Contains(Double,Double) | Determines if the specified point is contained within this rectangle.
Contains(Point) | Determines if the specified point is contained within this rectangle.
Contains(Rect) | Determines if the rectangular region represented by rect is entirely contained within this rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Contains(Double,Double) Method

[image]
ActiveReports 13
Contains(Double,Double) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Double,Double) Method

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.

Glossary Item Box

Determines if the specified point is contained within this rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal x As Double, _
   ByVal y As Double _
) As Boolean
C#
public bool Contains(
   double x,
   double y
)

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Contains(Point) Method

[image]
ActiveReports 13
Contains(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Point) Method

pt
The Point to test.

Glossary Item Box

Determines if the specified point is contained within this rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal pt As Point _
) As Boolean
C#
public bool Contains(
   Point pt
)

Parameters

pt
The Point to test.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Contains(Rect) Method

[image]
ActiveReports 13
Contains(Rect) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Rect) Method

rect
The Rect to test.

Glossary Item Box

Determines if the rectangular region represented by rect is entirely contained within this rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal rect As Rect _
) As Boolean
C#
public bool Contains(
   Rect rect
)

Parameters

rect
The Rect to test.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Equals Method

obj
Another object to compare to.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
Another object to compare to.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


FromLTRB Method

[image]
ActiveReports 13
FromLTRB Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : FromLTRB Method

left
The x-coordinate of the upper-left corner of the rectangle.
top
The y-coordinate of the upper-left corner of the rectangle.
right
The x-coordinate of the lower-right corner of the rectangle.
bottom
The y-coordinate of the lower-right corner of the rectangle

Glossary Item Box

Creates a Rect with the specified edge locations.

Syntax

Visual Basic (Declaration)
Public Shared Function FromLTRB( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal right As Double, _
   ByVal bottom As Double _
) As Rect
C#
public static Rect FromLTRB(
   double left,
   double top,
   double right,
   double bottom
)

Parameters

left
The x-coordinate of the upper-left corner of the rectangle.
top
The y-coordinate of the upper-left corner of the rectangle.
right
The x-coordinate of the lower-right corner of the rectangle.
bottom
The y-coordinate of the lower-right corner of the rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Inflate Method

[image]
ActiveReports 13
Inflate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Inflate Method

Glossary Item Box

Enlarges this Rect by the specified amount.

Overload List

Overload | Description
Inflate(Double,Double) | Enlarges this Rect by the specified amount.
Inflate(Size) | Enlarges this Rect by the specified amount.
Inflate(Rect,Single,Single) | Creates and returns an enlarged copy of the specified Rect structure. The copy is enlarged by the specified amount. The original Rect structure remains unmodified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Inflate(Double,Double) Method

[image]
ActiveReports 13
Inflate(Double,Double) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Double,Double) Method

x
The amount to inflate this Rect horizontally.
y
The amount to inflate this Rect vertically.

Glossary Item Box

Enlarges this Rect by the specified amount.

Syntax

Visual Basic (Declaration)
Public Overloads Function Inflate( _
   ByVal x As Double, _
   ByVal y As Double _
) As Rect
C#
public Rect Inflate(
   double x,
   double y
)

Parameters

x
The amount to inflate this Rect horizontally.
y
The amount to inflate this Rect vertically.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Inflate(Size) Method

[image]
ActiveReports 13
Inflate(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Size) Method

size
The amount to inflate this rectangle.

Glossary Item Box

Enlarges this Rect by the specified amount.

Syntax

Visual Basic (Declaration)
Public Overloads Function Inflate( _
   ByVal size As Size _
) As Rect
C#
public Rect Inflate(
   Size size
)

Parameters

size
The amount to inflate this rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Inflate(Rect,Single,Single) Method

[image]
ActiveReports 13
Inflate(Rect,Single,Single) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Rect,Single,Single) Method

rect
The Rect with which to start. This rectangle is not modified.
x
The amount to inflate the rectangle horizontally.
y
The amount to inflate the rectangle vertically.

Glossary Item Box

Creates and returns an enlarged copy of the specified Rect structure. The copy is enlarged by the specified amount. The original Rect structure remains unmodified.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Inflate( _
   ByVal rect As Rect, _
   ByVal x As Single, _
   ByVal y As Single _
) As Rect
C#
public static Rect Inflate(
   Rect rect,
   float x,
   float y
)

Parameters

rect
The Rect with which to start. This rectangle is not modified.
x
The amount to inflate the rectangle horizontally.
y
The amount to inflate the rectangle vertically.

Return Value

Rect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Intersect Method

[image]
ActiveReports 13
Intersect Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Intersect Method

Glossary Item Box

Replaces this Rect with the intersection of itself and the specified Rect.

Overload List

Overload | Description
Intersect(Rect) | Replaces this Rect with the intersection of itself and the specified Rect.
Intersect(Rect,Rect) | Returns a third Rect structure that represents the intersection of two other Rect structures. If there is no intersection, an empty Rect is returned.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Intersect(Rect) Method

[image]
ActiveReports 13
Intersect(Rect) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Intersect Method : Intersect(Rect) Method

rect
The Rect with which to intersect.

Glossary Item Box

Replaces this Rect with the intersection of itself and the specified Rect.

Syntax

Visual Basic (Declaration)
Public Overloads Function Intersect( _
   ByVal rect As Rect _
) As Rect
C#
public Rect Intersect(
   Rect rect
)

Parameters

rect
The Rect with which to intersect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Intersect(Rect,Rect) Method

[image]
ActiveReports 13
Intersect(Rect,Rect) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Intersect Method : Intersect(Rect,Rect) Method

a
A rectangle to intersect.
b
A rectangle to intersect.

Glossary Item Box

Returns a third Rect structure that represents the intersection of two other Rect structures. If there is no intersection, an empty Rect is returned.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Intersect( _
   ByVal a As Rect, _
   ByVal b As Rect _
) As Rect
C#
public static Rect Intersect(
   Rect a,
   Rect b
)

Parameters

a
A rectangle to intersect.
b
A rectangle to intersect.

Return Value

Rect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


IntersectsWith Method

[image]
ActiveReports 13
IntersectsWith Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : IntersectsWith Method

rect
The rectangle to test.

Glossary Item Box

Determines if this rectangle intersects with specified rectangle.

Syntax

Visual Basic (Declaration)
Public Function IntersectsWith( _
   ByVal rect As Rect _
) As Boolean
C#
public bool IntersectsWith(
   Rect rect
)

Parameters

rect
The rectangle to test.

Return Value

This method returns true if there is any intersection, otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Offset Method

[image]
ActiveReports 13
Offset Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Offset Method

Glossary Item Box

Adjusts the location of this rectangle by the specified amount.

Overload List

Overload | Description
Offset(Point) | Adjusts the location of this rectangle by the specified amount.
Offset(Double,Double) | Adjusts the location of this rectangle by the specified amount.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Offset(Point) Method

[image]
ActiveReports 13
Offset(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Offset Method : Offset(Point) Method

pos
Amount to offset the location.

Glossary Item Box

Adjusts the location of this rectangle by the specified amount.

Syntax

Visual Basic (Declaration)
Public Overloads Function Offset( _
   ByVal pos As Point _
) As Rect
C#
public Rect Offset(
   Point pos
)

Parameters

pos
Amount to offset the location.

Return Value

Rect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Offset(Double,Double) Method

[image]
ActiveReports 13
Offset(Double,Double) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Offset Method : Offset(Double,Double) Method

x
The horizontal offset.
y
The vertical offset.

Glossary Item Box

Adjusts the location of this rectangle by the specified amount.

Syntax

Visual Basic (Declaration)
Public Overloads Function Offset( _
   ByVal x As Double, _
   ByVal y As Double _
) As Rect
C#
public Rect Offset(
   double x,
   double y
)

Parameters

x
The horizontal offset.
y
The vertical offset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Scale Method

Glossary Item Box

Scales the rectangle by specified scale factor.

Overload List

Overload | Description
Scale(Double) | Scales the rectangle by specified scale factor.
Scale(Double,Double) | Scales the rectangle by specified scale factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Scale(Double) Method

[image]
ActiveReports 13
Scale(Double) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Scale Method : Scale(Double) Method

scaleFactor

Glossary Item Box

Scales the rectangle by specified scale factor.

Syntax

Visual Basic (Declaration)
Public Overloads Function Scale( _
   ByVal scaleFactor As Double _
) As Rect
C#
public Rect Scale(
   double scaleFactor
)

Parameters

scaleFactor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


Scale(Double,Double) Method

[image]
ActiveReports 13
Scale(Double,Double) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Scale Method : Scale(Double,Double) Method

scaleX
scaleY

Glossary Item Box

Scales the rectangle by specified scale factors.

Syntax

Visual Basic (Declaration)
Public Overloads Function Scale( _
   ByVal scaleX As Double, _
   ByVal scaleY As Double _
) As Rect
C#
public Rect Scale(
   double scaleX,
   double scaleY
)

Parameters

scaleX
scaleY

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members
Overload List


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Union Method

[image]
ActiveReports 13
Union Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Union Method

a
A rectangle to union.
b
A rectangle to union.

Glossary Item Box

Creates a Rect structure that contains the union of two Rect structures.

Syntax

Visual Basic (Declaration)
Public Shared Function Union( _
   ByVal a As Rect, _
   ByVal b As Rect _
) As Rect
C#
public static Rect Union(
   Rect a,
   Rect b
)

Parameters

a
A rectangle to union.
b
A rectangle to union.

Return Value

A rectangle that bounds the union of the two rectangles.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Rect Structure Properties

[image]
ActiveReports 13
Rect Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

Glossary Item Box

For a list of all members of this type, see Rect members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the bottom edge of this rectangle.
Public Property | Height | Gets the height of this rectangle.
Public Property | IsEmpty | Tests whether the size of this rectangle less or equal 0.
Public Property | Left | Gets the x-coordinate of the left edge of this rectangle.
Public Property | Location | Gets the coordinates of the upper-left corner of this rectangle.
Public Property | Right | Gets the x-coordinate of the right edge of this rectangle.
Public Property | Size | Gets the size of this rectangle.
Public Property | Top | Gets the y-coordinate of the top edge of this rectangle.
Public Property | Width | Gets the width of this rectangle.
Public Property | X | Gets the x-coordinate of the upper-left corner of this rectangle.
Public Property | Y | Gets the y-coordinate of the upper-left corner of this rectangle.
Top

See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Bottom Property

Glossary Item Box

Gets the y-coordinate of the bottom edge of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Double
C#
public double Bottom {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Height Property

Glossary Item Box

Gets the height of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Double
C#
public double Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


IsEmpty Property

[image]
ActiveReports 13
IsEmpty Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : IsEmpty Property

Glossary Item Box

Tests whether the size of this rectangle less or equal 0.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Left Property

Glossary Item Box

Gets the x-coordinate of the left edge of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Double
C#
public double Left {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Location Property

Glossary Item Box

Gets the coordinates of the upper-left corner of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As Point
C#
public Point Location {get;}

Property Value

The location.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Right Property

Glossary Item Box

Gets the x-coordinate of the right edge of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Double
C#
public double Right {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Size Property

Glossary Item Box

Gets the size of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Size
C#
public Size Size {get;}

Property Value

The size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Top Property

Glossary Item Box

Gets the y-coordinate of the top edge of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Double
C#
public double Top {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Width Property

Glossary Item Box

Gets the width of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Double
C#
public double Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


X Property

[image]
ActiveReports 13
X Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : X Property

Glossary Item Box

Gets the x-coordinate of the upper-left corner of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Double
C#
public double X {get;}

Property Value

The x.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Y Property

[image]
ActiveReports 13
Y Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Y Property

Glossary Item Box

Gets the y-coordinate of the upper-left corner of this rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Double
C#
public double Y {get;}

Property Value

The y.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Rect Structure Fields

[image]
ActiveReports 13
Rect Structure Fields
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

Glossary Item Box

For a list of all members of this type, see Rect members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Initializes an empty Rect with zero location and size.
Top

See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Empty Field

[image]
ActiveReports 13
Empty Field
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Empty Field

Glossary Item Box

Initializes an empty Rect with zero location and size.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Rect
C#
public static readonly Rect Empty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Rect Structure
Rect Members


Size Structure

[image]
ActiveReports 13
Size Structure
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

Glossary Item Box

Platform aware Size structure

Object Model

Size Structure

Syntax

Visual Basic (Declaration)
Public Structure Size
   Inherits System.ValueType
C#
public struct Size : System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Size

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Members
GrapeCity.Viewer.Common Namespace


Size Structure Members

[image]
ActiveReports 13
Size Structure Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

Glossary Item Box

The following tables list the members exposed by Size.

Public Constructors

 | Name | Description
Public Constructor | Size Constructor | Initializes a new instance of the Size struct.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size with zero width and height.
Public Property | Height | Gets the height.
Public Property | Width | Gets the width.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Scale | Scales the size by specified values.
Public Method | ToString | Returns a System.String that represents this instance.
Top

Public Operators

public Operator Addition | Enlarge the size by specified value.
public Operator Equality | Checks whether the two sizes are equals.
public Operator Inequality | Check whether the two sizes are not equals.
public Operator Multiplication | Scales the size by specified value
Top

See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Size Constructor

[image]
ActiveReports 13
Size Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Size Constructor

width
height

Glossary Item Box

Initializes a new instance of the Size struct.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
C#
public Size(
   double width,
   double height
)

Parameters

width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Size Structure Methods

[image]
ActiveReports 13
Size Structure Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

Glossary Item Box

For a list of all members of this type, see Size members.

Public Methods

 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Scale | Scales the size by specified values.
Public Method | ToString | Returns a System.String that represents this instance.
Top

See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Equals Method

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Overload List

Overload | Description
Equals(Object) | Determines whether the specified System.Object is equal to this instance.
Equals(Size) | Checks whether this size equals to specified.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Equals(Object) Method

[image]
ActiveReports 13
Equals(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure > Equals Method : Equals(Object) Method

obj
The object to compare.

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to compare.

Return Value

The result of comparison.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members
Overload List


Equals(Size) Method

[image]
ActiveReports 13
Equals(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure > Equals Method : Equals(Size) Method

other

Glossary Item Box

Checks whether this size equals to specified.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As Size _
) As Boolean
C#
public bool Equals(
   Size other
)

Parameters

other

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members
Overload List


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : GetHashCode Method

Glossary Item Box

Returns a hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Scale Method

factorX
The width scaling factor.
factorY
The height scaling factor.

Glossary Item Box

Scales the size by specified values.

Syntax

Visual Basic (Declaration)
Public Function Scale( _
   ByVal factorX As Double, _
   ByVal factorY As Double _
) As Size
C#
public Size Scale(
   double factorX,
   double factorY
)

Parameters

factorX
The width scaling factor.
factorY
The height scaling factor.

Return Value

Size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : ToString Method

Glossary Item Box

Returns a System.String that represents this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Size Structure Properties

[image]
ActiveReports 13
Size Structure Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

Glossary Item Box

For a list of all members of this type, see Size members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size with zero width and height.
Public Property | Height | Gets the height.
Public Property | Width | Gets the width.
Top

See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Empty Property

[image]
ActiveReports 13
Empty Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Empty Property

Glossary Item Box

Gets the size with zero width and height.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As Size
C#
public static Size Empty {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Height Property

Glossary Item Box

Gets the height.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Double
C#
public double Height {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Width Property

Glossary Item Box

Gets the width.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Double
C#
public double Width {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Addition Operator

[image]
ActiveReports 13
Addition Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Addition Operator

size
The size to enlarge.
offset
The offset.

Glossary Item Box

Enlarge the size by specified value.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal size As Size, _
   ByVal offset As Size _
) As Size
C#
public Size operator +(
   Size size,
   Size offset
)

Parameters

size
The size to enlarge.
offset
The offset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Equality Operator

[image]
ActiveReports 13
Equality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Equality Operator

s1
s2

Glossary Item Box

Checks whether the two sizes are equals.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal s1 As Size, _
   ByVal s2 As Size _
) As Boolean
C#
public bool operator ==(
   Size s1,
   Size s2
)

Parameters

s1
s2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Inequality Operator

[image]
ActiveReports 13
Inequality Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Inequality Operator

s1
s2

Glossary Item Box

Check whether the two sizes are not equals.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal s1 As Size, _
   ByVal s2 As Size _
) As Boolean
C#
public bool operator !=(
   Size s1,
   Size s2
)

Parameters

s1
s2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


Multiplication Operator

[image]
ActiveReports 13
Multiplication Operator
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Multiplication Operator

size
factor

Glossary Item Box

Scales the size by specified value

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal size As Size, _
   ByVal factor As Double _
) As Size
C#
public Size operator *(
   Size size,
   double factor
)

Parameters

size
factor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Size Structure
Size Members


IApplicationContext Interface

[image]
ActiveReports 13
IApplicationContext Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

Glossary Item Box

Provides access to different services and factories

Syntax

Visual Basic (Declaration)
Public Interface IApplicationContext
C#
public interface IApplicationContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IApplicationContext Members
GrapeCity.Viewer.Common Namespace


IApplicationContext Interface Members

[image]
ActiveReports 13
IApplicationContext Interface Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

Glossary Item Box

The following tables list the members exposed by IApplicationContext.

Public Properties

 | Name | Description
Property | Context | Gets the synchronization context.
Property | ServiceContainer | Gets service container
Top

Public Methods

 | Name | Description
Method | CreateRenderer | Overloaded. Creates page renderer for specific document
Method | CreateReport | Creates loader for documents with specific formats
Top

See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


IApplicationContext Interface Methods

[image]
ActiveReports 13
IApplicationContext Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

Glossary Item Box

For a list of all members of this type, see IApplicationContext members.

Public Methods

 | Name | Description
Method | CreateRenderer | Overloaded. Creates page renderer for specific document
Method | CreateReport | Creates loader for documents with specific formats
Top

See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


CreateRenderer Method

[image]
ActiveReports 13
CreateRenderer Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : CreateRenderer Method

Glossary Item Box

Creates page renderer for specific document

Overload List

Overload | Description
CreateRenderer(DocumentModel) | Creates page renderer for specific document
CreateRenderer(DocumentModel,DeviceKind) | Creates the renderer for specific document considering specific target device kind.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


CreateRenderer(DocumentModel) Method

[image]
ActiveReports 13
CreateRenderer(DocumentModel) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface > CreateRenderer Method : CreateRenderer(DocumentModel) Method

document
Document for rendering

Glossary Item Box

Creates page renderer for specific document

Syntax

Visual Basic (Declaration)
Overloads Function CreateRenderer( _
   ByVal document As DocumentModel _
) As IDocumentRenderer
C#
IDocumentRenderer CreateRenderer(
   DocumentModel document
)

Parameters

document
Document for rendering

Return Value

Newly created renderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IApplicationContext Interface
IApplicationContext Members
Overload List


CreateRenderer(DocumentModel,DeviceKind) Method

[image]
ActiveReports 13
CreateRenderer(DocumentModel,DeviceKind) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface > CreateRenderer Method : CreateRenderer(DocumentModel,DeviceKind) Method

document
The document model.
device
The target device kind.

Glossary Item Box

Creates the renderer for specific document considering specific target device kind.

Syntax

Visual Basic (Declaration)
Overloads Function CreateRenderer( _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
C#
IDocumentRenderer CreateRenderer(
   DocumentModel document,
   DeviceKind device
)

Parameters

document
The document model.
device
The target device kind.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IApplicationContext Interface
IApplicationContext Members
Overload List


CreateReport Method

[image]
ActiveReports 13
CreateReport Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : CreateReport Method

format
Format of the document

Glossary Item Box

Creates loader for documents with specific formats

Syntax

Visual Basic (Declaration)
Function CreateReport( _
   ByVal format As DocumentFormat _
) As ReportModelBase
C#
ReportModelBase CreateReport(
   DocumentFormat format
)

Parameters

format
Format of the document

Return Value

Created loader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


IApplicationContext Interface Properties

[image]
ActiveReports 13
IApplicationContext Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

Glossary Item Box

For a list of all members of this type, see IApplicationContext members.

Public Properties

 | Name | Description
Property | Context | Gets the synchronization context.
Property | ServiceContainer | Gets service container
Top

See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


Context Property

[image]
ActiveReports 13
Context Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : Context Property

Glossary Item Box

Gets the synchronization context.

Syntax

Visual Basic (Declaration)
ReadOnly Property Context As SynchronizationContext
C#
SynchronizationContext Context {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ServiceContainer Property

[image]
ActiveReports 13
ServiceContainer Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : ServiceContainer Property

Glossary Item Box

Gets service container

Syntax

Visual Basic (Declaration)
ReadOnly Property ServiceContainer As IServiceContainer
C#
IServiceContainer ServiceContainer {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ICommand Interface

[image]
ActiveReports 13
ICommand Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

Glossary Item Box

Defines the contract for commanding, using the same contract as used in WPF.

Syntax

Visual Basic (Declaration)
Public Interface ICommand
C#
public interface ICommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Members
GrapeCity.Viewer.Common Namespace


ICommand Interface Members

[image]
ActiveReports 13
ICommand Interface Members
See Also Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

Glossary Item Box

The following tables list the members exposed by ICommand.

Public Methods

 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Method | Execute | Defines the method to be called when the command is invoked.
Top

Public Events

 | Name | Description
Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


ICommand Interface Methods

[image]
ActiveReports 13
ICommand Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

Glossary Item Box

For a list of all members of this type, see ICommand members.

Public Methods

 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Method | Execute | Defines the method to be called when the command is invoked.
Top

See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


CanExecute Method

[image]
ActiveReports 13
CanExecute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : CanExecute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method that determines whether the command can execute in its current state.

Syntax

Visual Basic (Declaration)
Function CanExecute( _
   ByVal parameter As Object _
) As Boolean
C#
bool CanExecute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


Execute Method

[image]
ActiveReports 13
Execute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : Execute Method

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Glossary Item Box

Defines the method to be called when the command is invoked.

Syntax

Visual Basic (Declaration)
Sub Execute( _
   ByVal parameter As Object _
)
C#
void Execute(
   object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


ICommand Interface Events

[image]
ActiveReports 13
ICommand Interface Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

Glossary Item Box

For a list of all members of this type, see ICommand members.

Public Events

 | Name | Description
Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top

See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event

[image]
ActiveReports 13
CanExecuteChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : CanExecuteChanged Event

Glossary Item Box

Occurs when changes occur that affect whether the command should execute.

Syntax

Visual Basic (Declaration)
Event CanExecuteChanged As EventHandler
C#
event EventHandler CanExecuteChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommand Interface
ICommand Members


ICopySelectionService Interface

[image]
ActiveReports 13
ICopySelectionService Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface

Glossary Item Box

Base interface for copy operations

Syntax

Visual Basic (Declaration)
Public Interface ICopySelectionService
C#
public interface ICopySelectionService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICopySelectionService Members
GrapeCity.Viewer.Common Namespace


ICopySelectionService Interface Members

[image]
ActiveReports 13
ICopySelectionService Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface

Glossary Item Box

The following tables list the members exposed by ICopySelectionService.

Public Methods

 | Name | Description
Method | CopySelection | Copies given selection into platform specific storage
Method | CopyToClipBoard | Copies given text into clipboard
Top

See Also

Reference

ICopySelectionService Interface
GrapeCity.Viewer.Common Namespace


ICopySelectionService Interface Methods

[image]
ActiveReports 13
ICopySelectionService Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface

Glossary Item Box

For a list of all members of this type, see ICopySelectionService members.

Public Methods

 | Name | Description
Method | CopySelection | Copies given selection into platform specific storage
Method | CopyToClipBoard | Copies given text into clipboard
Top

See Also

Reference

ICopySelectionService Interface
GrapeCity.Viewer.Common Namespace


CopySelection Method

[image]
ActiveReports 13
CopySelection Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ICopySelectionService Interface : CopySelection Method

selection

Glossary Item Box

Copies given selection into platform specific storage

Syntax

Visual Basic (Declaration)
Sub CopySelection( _
   ByVal selection As DocumentSelection _
)
C#
void CopySelection(
   DocumentSelection selection
)

Parameters

selection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICopySelectionService Interface
ICopySelectionService Members


CopyToClipBoard Method

[image]
ActiveReports 13
CopyToClipBoard Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ICopySelectionService Interface : CopyToClipBoard Method

text

Glossary Item Box

Copies given text into clipboard

Syntax

Visual Basic (Declaration)
Sub CopyToClipBoard( _
   ByVal text As String _
)
C#
void CopyToClipBoard(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICopySelectionService Interface
ICopySelectionService Members


IDelegateCommand Interface

[image]
ActiveReports 13
IDelegateCommand Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface

Glossary Item Box

Delegated command interface

Syntax

Visual Basic (Declaration)
Public Interface IDelegateCommand
   Inherits ICommand
C#
public interface IDelegateCommand : ICommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDelegateCommand Members
GrapeCity.Viewer.Common Namespace


IDelegateCommand Interface Members

[image]
ActiveReports 13
IDelegateCommand Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface

Glossary Item Box

The following tables list the members exposed by IDelegateCommand.

Public Methods

 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event
Top

See Also

Reference

IDelegateCommand Interface
GrapeCity.Viewer.Common Namespace


IDelegateCommand Interface Methods

[image]
ActiveReports 13
IDelegateCommand Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface

Glossary Item Box

For a list of all members of this type, see IDelegateCommand members.

Public Methods

 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event
Top

See Also

Reference

IDelegateCommand Interface
GrapeCity.Viewer.Common Namespace


RaiseCanExecuteChanged Method

[image]
ActiveReports 13
RaiseCanExecuteChanged Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IDelegateCommand Interface : RaiseCanExecuteChanged Method

Glossary Item Box

Raises CanExecuteChanged event

Syntax

Visual Basic (Declaration)
Sub RaiseCanExecuteChanged()
C#
void RaiseCanExecuteChanged()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDelegateCommand Interface
IDelegateCommand Members


IDocumentLoader Interface

[image]
ActiveReports 13
IDocumentLoader Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

Glossary Item Box

Base interface for document loads

Syntax

Visual Basic (Declaration)
Public Interface IDocumentLoader
C#
public interface IDocumentLoader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentLoader Members
GrapeCity.Viewer.Common Namespace


IDocumentLoader Interface Members

[image]
ActiveReports 13
IDocumentLoader Interface Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

Glossary Item Box

The following tables list the members exposed by IDocumentLoader.

Public Properties

 | Name | Description
Property | DocumentFormat | Gets document format
Top

Public Methods

 | Name | Description
Method | Load | Loads a document
Top

See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


IDocumentLoader Interface Methods

[image]
ActiveReports 13
IDocumentLoader Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

Glossary Item Box

For a list of all members of this type, see IDocumentLoader members.

Public Methods

 | Name | Description
Method | Load | Loads a document
Top

See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


Load Method

[image]
ActiveReports 13
Load Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IDocumentLoader Interface : Load Method

obj

Glossary Item Box

Loads a document

Syntax

Visual Basic (Declaration)
Sub Load( _
   ByVal obj As ILoadableFromFileAndStream _
)
C#
void Load(
   ILoadableFromFileAndStream obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentLoader Interface
IDocumentLoader Members


IDocumentLoader Interface Properties

[image]
ActiveReports 13
IDocumentLoader Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

Glossary Item Box

For a list of all members of this type, see IDocumentLoader members.

Public Properties

 | Name | Description
Property | DocumentFormat | Gets document format
Top

See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


DocumentFormat Property

[image]
ActiveReports 13
DocumentFormat Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IDocumentLoader Interface : DocumentFormat Property

Glossary Item Box

Gets document format

Syntax

Visual Basic (Declaration)
ReadOnly Property DocumentFormat As DocumentFormat
C#
DocumentFormat DocumentFormat {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentLoader Interface
IDocumentLoader Members


IDocumentRenderer Interface

[image]
ActiveReports 13
IDocumentRenderer Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface

Glossary Item Box

Base interface for Document renderers

Syntax

Visual Basic (Declaration)
Public Interface IDocumentRenderer
C#
public interface IDocumentRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentRenderer Members
GrapeCity.Viewer.Common Namespace


IDocumentRenderer Interface Members

[image]
ActiveReports 13
IDocumentRenderer Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface

Glossary Item Box

The following tables list the members exposed by IDocumentRenderer.

Public Methods

 | Name | Description
Method | RenderPage | Renders page from current document
Top

See Also

Reference

IDocumentRenderer Interface
GrapeCity.Viewer.Common Namespace


IDocumentRenderer Interface Methods

[image]
ActiveReports 13
IDocumentRenderer Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface

Glossary Item Box

For a list of all members of this type, see IDocumentRenderer members.

Public Methods

 | Name | Description
Method | RenderPage | Renders page from current document
Top

See Also

Reference

IDocumentRenderer Interface
GrapeCity.Viewer.Common Namespace


RenderPage Method

[image]
ActiveReports 13
RenderPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRenderer Interface : RenderPage Method

index
Index of the page to render

Glossary Item Box

Renders page from current document

Syntax

Visual Basic (Declaration)
Function RenderPage( _
   ByVal index As Integer _
) As PageView
C#
PageView RenderPage(
   int index
)

Parameters

index
Index of the page to render

Return Value

Rendered page view

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentRenderer Interface
IDocumentRenderer Members


IDocumentRendererFactory Interface

[image]
ActiveReports 13
IDocumentRendererFactory Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface

Glossary Item Box

IDocumentRenderer factory interface.

Syntax

Visual Basic (Declaration)
Public Interface IDocumentRendererFactory
C#
public interface IDocumentRendererFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentRendererFactory Members
GrapeCity.Viewer.Common Namespace


IDocumentRendererFactory Interface Members

[image]
ActiveReports 13
IDocumentRendererFactory Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface

Glossary Item Box

The following tables list the members exposed by IDocumentRendererFactory.

Public Methods

 | Name | Description
Method | Create | Overloaded. Creates the IDocumentRenderer for specified document with specified context.
Top

See Also

Reference

IDocumentRendererFactory Interface
GrapeCity.Viewer.Common Namespace


IDocumentRendererFactory Interface Methods

[image]
ActiveReports 13
IDocumentRendererFactory Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface

Glossary Item Box

For a list of all members of this type, see IDocumentRendererFactory members.

Public Methods

 | Name | Description
Method | Create | Overloaded. Creates the IDocumentRenderer for specified document with specified context.
Top

See Also

Reference

IDocumentRendererFactory Interface
GrapeCity.Viewer.Common Namespace


Create Method

[image]
ActiveReports 13
Create Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface : Create Method

Glossary Item Box

Creates the IDocumentRenderer for specified document with specified context.

Overload List

Overload | Description
Create(IApplicationContext,DocumentModel) | Creates the IDocumentRenderer for specified document with specified context.
Create(IApplicationContext,DocumentModel,DeviceKind) | Creates the IDocumentRenderer for specified document with specified context and target device kind.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members


Create(IApplicationContext,DocumentModel) Method

[image]
ActiveReports 13
Create(IApplicationContext,DocumentModel) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface > Create Method : Create(IApplicationContext,DocumentModel) Method

context
The application context.
document
The document model.

Glossary Item Box

Creates the IDocumentRenderer for specified document with specified context.

Syntax

Visual Basic (Declaration)
Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel _
) As IDocumentRenderer
C#
IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document
)

Parameters

context
The application context.
document
The document model.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members
Overload List


Create(IApplicationContext,DocumentModel,DeviceKind) Method

[image]
ActiveReports 13
Create(IApplicationContext,DocumentModel,DeviceKind) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface > Create Method : Create(IApplicationContext,DocumentModel,DeviceKind) Method

context
The application context.
document
The document model.
device
The target device.

Glossary Item Box

Creates the IDocumentRenderer for specified document with specified context and target device kind.

Syntax

Visual Basic (Declaration)
Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
C#
IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document,
   DeviceKind device
)

Parameters

context
The application context.
document
The document model.
device
The target device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members
Overload List


IHistoryApi Interface

[image]
ActiveReports 13
IHistoryApi Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

Glossary Item Box

This is public interface for user to work with HistoryService.

Syntax

Visual Basic (Declaration)
Public Interface IHistoryApi
C#
public interface IHistoryApi

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHistoryApi Members
GrapeCity.Viewer.Common Namespace


IHistoryApi Interface Members

[image]
ActiveReports 13
IHistoryApi Interface Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

Glossary Item Box

The following tables list the members exposed by IHistoryApi.

Public Properties

 | Name | Description
Property | Count | Returns the number of page views in the history.
Property | Position | Gets the current page's position in the navigation history.
Top

Public Methods

 | Name | Description
Method | Clear | Clears the page views from the history.
Method | MoveNext | Navigates to the next page in the history.
Method | MovePrev | Navigates to the previous page in the view history.
Top

See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


IHistoryApi Interface Methods

[image]
ActiveReports 13
IHistoryApi Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

Glossary Item Box

For a list of all members of this type, see IHistoryApi members.

Public Methods

 | Name | Description
Method | Clear | Clears the page views from the history.
Method | MoveNext | Navigates to the next page in the history.
Method | MovePrev | Navigates to the previous page in the view history.
Top

See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Clear Method

Glossary Item Box

Clears the page views from the history.

Syntax

Visual Basic (Declaration)
Sub Clear()
C#
void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHistoryApi Interface
IHistoryApi Members


MoveNext Method

[image]
ActiveReports 13
MoveNext Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : MoveNext Method

Glossary Item Box

Navigates to the next page in the history.

Syntax

Visual Basic (Declaration)
Sub MoveNext()
C#
void MoveNext()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHistoryApi Interface
IHistoryApi Members


MovePrev Method

[image]
ActiveReports 13
MovePrev Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : MovePrev Method

Glossary Item Box

Navigates to the previous page in the view history.

Syntax

Visual Basic (Declaration)
Sub MovePrev()
C#
void MovePrev()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHistoryApi Interface
IHistoryApi Members


IHistoryApi Interface Properties

[image]
ActiveReports 13
IHistoryApi Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

Glossary Item Box

For a list of all members of this type, see IHistoryApi members.

Public Properties

 | Name | Description
Property | Count | Returns the number of page views in the history.
Property | Position | Gets the current page's position in the navigation history.
Top

See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Count Property

Glossary Item Box

Returns the number of page views in the history.

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
C#
int Count {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHistoryApi Interface
IHistoryApi Members


Position Property

[image]
ActiveReports 13
Position Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Position Property

Glossary Item Box

Gets the current page's position in the navigation history.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
C#
int Position {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHistoryApi Interface
IHistoryApi Members


ILoadableFromFileAndStream Interface

[image]
ActiveReports 13
ILoadableFromFileAndStream Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface

Glossary Item Box

Interface ILoadableFromFileAndStream

Syntax

Visual Basic (Declaration)
Public Interface ILoadableFromFileAndStream
C#
public interface ILoadableFromFileAndStream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILoadableFromFileAndStream Members
GrapeCity.Viewer.Common Namespace


ILoadableFromFileAndStream Interface Members

[image]
ActiveReports 13
ILoadableFromFileAndStream Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface

Glossary Item Box

The following tables list the members exposed by ILoadableFromFileAndStream.

Public Methods

 | Name | Description
Method | LoadFromFile | Load from file.
Method | LoadFromStream | Overloaded. Load from the stream.
Top

See Also

Reference

ILoadableFromFileAndStream Interface
GrapeCity.Viewer.Common Namespace


ILoadableFromFileAndStream Interface Methods

[image]
ActiveReports 13
ILoadableFromFileAndStream Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface

Glossary Item Box

For a list of all members of this type, see ILoadableFromFileAndStream members.

Public Methods

 | Name | Description
Method | LoadFromFile | Load from file.
Method | LoadFromStream | Overloaded. Load from the stream.
Top

See Also

Reference

ILoadableFromFileAndStream Interface
GrapeCity.Viewer.Common Namespace


LoadFromFile Method

[image]
ActiveReports 13
LoadFromFile Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface : LoadFromFile Method

f
instance of the System.IO.FileInfo.

Glossary Item Box

Load from file.

Syntax

Visual Basic (Declaration)
Sub LoadFromFile( _
   ByVal f As FileInfo _
)
C#
void LoadFromFile(
   FileInfo f
)

Parameters

f
instance of the System.IO.FileInfo.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members


LoadFromStream Method

[image]
ActiveReports 13
LoadFromStream Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface : LoadFromStream Method

Glossary Item Box

Load from the stream.

Overload List

Overload | Description
LoadFromStream(Stream) | Load from the stream.
LoadFromStream(Stream,Uri) | Load from the stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members


LoadFromStream(Stream) Method

[image]
ActiveReports 13
LoadFromStream(Stream) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface > LoadFromStream Method : LoadFromStream(Stream) Method

s
instance of the System.IO.Stream.

Glossary Item Box

Load from the stream.

Syntax

Visual Basic (Declaration)
Overloads Sub LoadFromStream( _
   ByVal s As Stream _
)
C#
void LoadFromStream(
   Stream s
)

Parameters

s
instance of the System.IO.Stream.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members
Overload List


LoadFromStream(Stream,Uri) Method

[image]
ActiveReports 13
LoadFromStream(Stream,Uri) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface > LoadFromStream Method : LoadFromStream(Stream,Uri) Method

s
instance of the System.IO.Stream.
baseUri
base uri.

Glossary Item Box

Load from the stream.

Syntax

Visual Basic (Declaration)
Overloads Sub LoadFromStream( _
   ByVal s As Stream, _
   ByVal baseUri As Uri _
)
C#
void LoadFromStream(
   Stream s,
   Uri baseUri
)

Parameters

s
instance of the System.IO.Stream.
baseUri
base uri.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members
Overload List


INotifyCollectionChanged Interface

[image]
ActiveReports 13
INotifyCollectionChanged Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface

Glossary Item Box

Notifies listeners of dynamic changes to a collection, such as when items are added and removed, or the entire collection object is reset.

Syntax

Visual Basic (Declaration)
Public Interface INotifyCollectionChanged
C#
public interface INotifyCollectionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INotifyCollectionChanged Members
GrapeCity.Viewer.Common Namespace


INotifyCollectionChanged Interface Members

[image]
ActiveReports 13
INotifyCollectionChanged Interface Members
See Also Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface

Glossary Item Box

The following tables list the members exposed by INotifyCollectionChanged.

Public Events

 | Name | Description
Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top

See Also

Reference

INotifyCollectionChanged Interface
GrapeCity.Viewer.Common Namespace


INotifyCollectionChanged Interface Events

[image]
ActiveReports 13
INotifyCollectionChanged Interface Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface

Glossary Item Box

For a list of all members of this type, see INotifyCollectionChanged members.

Public Events

 | Name | Description
Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top

See Also

Reference

INotifyCollectionChanged Interface
GrapeCity.Viewer.Common Namespace


CollectionChanged Event

[image]
ActiveReports 13
CollectionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > INotifyCollectionChanged Interface : CollectionChanged Event

Glossary Item Box

Occurs when the items list of the collection has changed, or the collection is reset.

Syntax

Visual Basic (Declaration)
Event CollectionChanged As NotifyCollectionChangedEventHandler
C#
event NotifyCollectionChangedEventHandler CollectionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INotifyCollectionChanged Interface
INotifyCollectionChanged Members


IOrientedPageView Interface

[image]
ActiveReports 13
IOrientedPageView Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface

Glossary Item Box

Interface to access orientation of the report page.

Syntax

Visual Basic (Declaration)
Public Interface IOrientedPageView
C#
public interface IOrientedPageView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOrientedPageView Members
GrapeCity.Viewer.Common Namespace


IOrientedPageView Interface Members

[image]
ActiveReports 13
IOrientedPageView Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface

Glossary Item Box

The following tables list the members exposed by IOrientedPageView.

Public Properties

 | Name | Description
Property | Orientation | Gets orientation of the report page.
Top

See Also

Reference

IOrientedPageView Interface
GrapeCity.Viewer.Common Namespace


IOrientedPageView Interface Properties

[image]
ActiveReports 13
IOrientedPageView Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface

Glossary Item Box

For a list of all members of this type, see IOrientedPageView members.

Public Properties

 | Name | Description
Property | Orientation | Gets orientation of the report page.
Top

See Also

Reference

IOrientedPageView Interface
GrapeCity.Viewer.Common Namespace


Orientation Property

[image]
ActiveReports 13
Orientation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IOrientedPageView Interface : Orientation Property

Glossary Item Box

Gets orientation of the report page.

Syntax

Visual Basic (Declaration)
ReadOnly Property Orientation As Nullable(Of Orientation)
C#
Nullable<Orientation> Orientation {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOrientedPageView Interface
IOrientedPageView Members


IParameter Interface

[image]
ActiveReports 13
IParameter Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface

Glossary Item Box

Defines an object that can be used as a report parameter.

Syntax

Visual Basic (Declaration)
Public Interface IParameter
C#
public interface IParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IParameter Members
GrapeCity.Viewer.Common Namespace


IParameter Interface Members

[image]
ActiveReports 13
IParameter Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface

Glossary Item Box

The following tables list the members exposed by IParameter.

Public Properties

 | Name | Description
Property | Name | Gets the name of the report parameter.
Property | Values | Gets the collection of zero or more values for the report parameter.
Top

See Also

Reference

IParameter Interface
GrapeCity.Viewer.Common Namespace


IParameter Interface Properties

[image]
ActiveReports 13
IParameter Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface

Glossary Item Box

For a list of all members of this type, see IParameter members.

Public Properties

 | Name | Description
Property | Name | Gets the name of the report parameter.
Property | Values | Gets the collection of zero or more values for the report parameter.
Top

See Also

Reference

IParameter Interface
GrapeCity.Viewer.Common Namespace


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IParameter Interface : Name Property

Glossary Item Box

Gets the name of the report parameter.

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IParameter Interface
IParameter Members


Values Property

[image]
ActiveReports 13
Values Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IParameter Interface : Values Property

Glossary Item Box

Gets the collection of zero or more values for the report parameter.

Syntax

Visual Basic (Declaration)
ReadOnly Property Values As IEnumerable(Of Object)
C#
IEnumerable<object> Values {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IParameter Interface
IParameter Members


IPrintService Interface

[image]
ActiveReports 13
IPrintService Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

Glossary Item Box

Interface IPrintService.

Syntax

Visual Basic (Declaration)
Public Interface IPrintService
C#
public interface IPrintService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrintService Members
GrapeCity.Viewer.Common Namespace


IPrintService Interface Members

[image]
ActiveReports 13
IPrintService Interface Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

Glossary Item Box

The following tables list the members exposed by IPrintService.

Public Properties

 | Name | Description
Property | CanPrint | Gets the value showing can the printing be executed or not.
Top

Public Methods

 | Name | Description
Method | Print | Overloaded. Prints the currently opened document(section or page).
Top

See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


IPrintService Interface Methods

[image]
ActiveReports 13
IPrintService Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

Glossary Item Box

For a list of all members of this type, see IPrintService members.

Public Methods

 | Name | Description
Method | Print | Overloaded. Prints the currently opened document(section or page).
Top

See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


Print Method

[image]
ActiveReports 13
Print Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface : Print Method

Glossary Item Box

Prints the currently opened document(section or page).

Overload List

Overload | Description
Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) | Prints the currently opened document(section or page).
Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) | Prints the currently opened document(section or page).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrintService Interface
IPrintService Members


Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method

[image]
ActiveReports 13
Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface > Print Method : Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method

documentModel
Document model.
reportModel
Report instance.
context
Application context.
showPrintDialog
if true Print Dialog will be shown, otherwise not.
showPrintProgressDialog
if true Print Progress Dialog will be shown, otherwise not.
usePrintingThread
if true Printing Thread will be used, otherwise not.

Glossary Item Box

Prints the currently opened document(section or page).

Syntax

Visual Basic (Declaration)
Overloads Function Print( _
   ByVal documentModel As DocumentModel, _
   ByVal reportModel As ReportModelBase, _
   ByVal context As IApplicationContext, _
   ByVal showPrintDialog As Boolean, _
   ByVal showPrintProgressDialog As Boolean, _
   ByVal usePrintingThread As Boolean _
) As Boolean
C#
bool Print(
   DocumentModel documentModel,
   ReportModelBase reportModel,
   IApplicationContext context,
   bool showPrintDialog,
   bool showPrintProgressDialog,
   bool usePrintingThread
)

Parameters

documentModel
Document model.
reportModel
Report instance.
context
Application context.
showPrintDialog
if true Print Dialog will be shown, otherwise not.
showPrintProgressDialog
if true Print Progress Dialog will be shown, otherwise not.
usePrintingThread
if true Printing Thread will be used, otherwise not.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrintService Interface
IPrintService Members
Overload List


Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method

[image]
ActiveReports 13
Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface > Print Method : Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method

documentModel
Document model.
reportModel
Report instance.
context
Application context.
settings
Settings for print.

Glossary Item Box

Prints the currently opened document(section or page).

Syntax

Visual Basic (Declaration)
Overloads Function Print( _
   ByVal documentModel As DocumentModel, _
   ByVal reportModel As ReportModelBase, _
   ByVal context As IApplicationContext, _
   ByVal settings As PrintingSettings _
) As Boolean
C#
bool Print(
   DocumentModel documentModel,
   ReportModelBase reportModel,
   IApplicationContext context,
   PrintingSettings settings
)

Parameters

documentModel
Document model.
reportModel
Report instance.
context
Application context.
settings
Settings for print.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrintService Interface
IPrintService Members
Overload List


IPrintService Interface Properties

[image]
ActiveReports 13
IPrintService Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

Glossary Item Box

For a list of all members of this type, see IPrintService members.

Public Properties

 | Name | Description
Property | CanPrint | Gets the value showing can the printing be executed or not.
Top

See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


CanPrint Property

[image]
ActiveReports 13
CanPrint Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface : CanPrint Property

Glossary Item Box

Gets the value showing can the printing be executed or not.

Syntax

Visual Basic (Declaration)
ReadOnly Property CanPrint As Boolean
C#
bool CanPrint {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPrintService Interface
IPrintService Members


IRasteredPageView Interface

[image]
ActiveReports 13
IRasteredPageView Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IRasteredPageView Interface

Glossary Item Box

IRasteredPageView interface

Syntax

Visual Basic (Declaration)
Public Interface IRasteredPageView
C#
public interface IRasteredPageView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRasteredPageView Members
GrapeCity.Viewer.Common Namespace


IRasteredPageView Interface Members

[image]
ActiveReports 13
IRasteredPageView Interface Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IRasteredPageView Interface

Glossary Item Box

The following tables list the members exposed by IRasteredPageView.

Public Properties

 | Name | Description
Property | Resolution | Gets the resolution.
Top

See Also

Reference

IRasteredPageView Interface
GrapeCity.Viewer.Common Namespace


IRasteredPageView Interface Properties

[image]
ActiveReports 13
IRasteredPageView Interface Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IRasteredPageView Interface

Glossary Item Box

For a list of all members of this type, see IRasteredPageView members.

Public Properties

 | Name | Description
Property | Resolution | Gets the resolution.
Top

See Also

Reference

IRasteredPageView Interface
GrapeCity.Viewer.Common Namespace


Resolution Property

[image]
ActiveReports 13
Resolution Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IRasteredPageView Interface : Resolution Property

Glossary Item Box

Gets the resolution.

Syntax

Visual Basic (Declaration)
ReadOnly Property Resolution As Point
C#
Point Resolution {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRasteredPageView Interface
IRasteredPageView Members


IRasteredRenderer Interface

[image]
ActiveReports 13
IRasteredRenderer Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IRasteredRenderer Interface

Glossary Item Box

Interface for rastered document renderer

Syntax

Visual Basic (Declaration)
Public Interface IRasteredRenderer
   Inherits IDocumentRenderer
C#
public interface IRasteredRenderer : IDocumentRenderer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRasteredRenderer Members
GrapeCity.Viewer.Common Namespace


IRasteredRenderer Interface Members

[image]
ActiveReports 13
IRasteredRenderer Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IRasteredRenderer Interface

Glossary Item Box

The following tables list the members exposed by IRasteredRenderer.

Public Methods

 | Name | Description
Method | RenderPage | Renders the page.
Top

See Also

Reference

IRasteredRenderer Interface
GrapeCity.Viewer.Common Namespace


IRasteredRenderer Interface Methods

[image]
ActiveReports 13
IRasteredRenderer Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IRasteredRenderer Interface

Glossary Item Box

For a list of all members of this type, see IRasteredRenderer members.

Public Methods

 | Name | Description
Method | RenderPage | Renders the page.
Top

See Also

Reference

IRasteredRenderer Interface
GrapeCity.Viewer.Common Namespace


RenderPage Method

[image]
ActiveReports 13
RenderPage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IRasteredRenderer Interface : RenderPage Method

index
The page index to render.
screenDpiFactor
The screen dpi factor.

Glossary Item Box

Renders the page.

Syntax

Visual Basic (Declaration)
Function RenderPage( _
   ByVal index As Integer, _
   ByVal screenDpiFactor As Double _
) As PageView
C#
PageView RenderPage(
   int index,
   double screenDpiFactor
)

Parameters

index
The page index to render.
screenDpiFactor
The screen dpi factor.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRasteredRenderer Interface
IRasteredRenderer Members


ISearchService Interface

[image]
ActiveReports 13
ISearchService Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface

Glossary Item Box

Base interface for search

Syntax

Visual Basic (Declaration)
Public Interface ISearchService
C#
public interface ISearchService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISearchService Members
GrapeCity.Viewer.Common Namespace


ISearchService Interface Members

[image]
ActiveReports 13
ISearchService Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface

Glossary Item Box

The following tables list the members exposed by ISearchService.

Public Methods

 | Name | Description
Method | Find | Searches the document according to find options.
Top

See Also

Reference

ISearchService Interface
GrapeCity.Viewer.Common Namespace


ISearchService Interface Methods

[image]
ActiveReports 13
ISearchService Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface

Glossary Item Box

For a list of all members of this type, see ISearchService members.

Public Methods

 | Name | Description
Method | Find | Searches the document according to find options.
Top

See Also

Reference

ISearchService Interface
GrapeCity.Viewer.Common Namespace


Find Method

[image]
ActiveReports 13
Find Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ISearchService Interface : Find Method

document
findOptions
startFrom
maxCount
handler

Glossary Item Box

Searches the document according to find options.

Syntax

Visual Basic (Declaration)
Sub Find( _
   ByVal document As DocumentModel, _
   ByVal findOptions As FindOptions, _
   ByVal startFrom As SearchResult, _
   ByVal maxCount As Integer, _
   ByVal handler As Action(Of DocumentModel,IEnumerable(Of SearchResult)) _
)
C#
void Find(
   DocumentModel document,
   FindOptions findOptions,
   SearchResult startFrom,
   int maxCount,
   Action<DocumentModel,IEnumerable<SearchResult>> handler
)

Parameters

document
findOptions
startFrom
maxCount
handler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISearchService Interface
ISearchService Members


IServiceContainer Interface

[image]
ActiveReports 13
IServiceContainer Interface
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface

Glossary Item Box

Provides a container for services.

Syntax

Visual Basic (Declaration)
Public Interface IServiceContainer
C#
public interface IServiceContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServiceContainer Members
GrapeCity.Viewer.Common Namespace


IServiceContainer Interface Members

[image]
ActiveReports 13
IServiceContainer Interface Members
See Also Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface

Glossary Item Box

The following tables list the members exposed by IServiceContainer.

Public Methods

 | Name | Description
Method | AddService<T> | Adds the specified service to the service container.
Method | GetService<T> | Gets service from container
Method | RemoveService<T> | Removes the specified service type from the service container
Top

See Also

Reference

IServiceContainer Interface
GrapeCity.Viewer.Common Namespace


IServiceContainer Interface Methods

[image]
ActiveReports 13
IServiceContainer Interface Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface

Glossary Item Box

For a list of all members of this type, see IServiceContainer members.

Public Methods

 | Name | Description
Method | AddService<T> | Adds the specified service to the service container.
Method | GetService<T> | Gets service from container
Method | RemoveService<T> | Removes the specified service type from the service container
Top

See Also

Reference

IServiceContainer Interface
GrapeCity.Viewer.Common Namespace


AddService<T> Method

T
The type of service to add.
[image]
ActiveReports 13
AddService<T> Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : AddService<T> Method

serviceInstance
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.

Glossary Item Box

Adds the specified service to the service container.

Syntax

Visual Basic (Declaration)
Sub AddService(Of T)( _
   ByVal serviceInstance As T _
)
C#
void AddService<T>(
   T serviceInstance
)

Parameters

serviceInstance
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.

Type Parameters

T
The type of service to add.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServiceContainer Interface
IServiceContainer Members


GetService<T> Method

T
[image]
ActiveReports 13
GetService<T> Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : GetService<T> Method

Glossary Item Box

Gets service from container

Syntax

Visual Basic (Declaration)
Function GetService(Of T)() As T
C#
T GetService<T>()

Type Parameters

T

Return Value

Service or null if service is not found

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServiceContainer Interface
IServiceContainer Members


RemoveService<T> Method

T
The type of service to remove.
[image]
ActiveReports 13
RemoveService<T> Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : RemoveService<T> Method

Glossary Item Box

Removes the specified service type from the service container

Syntax

Visual Basic (Declaration)
Sub RemoveService(Of T)()
C#
void RemoveService<T>()

Type Parameters

T
The type of service to remove.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServiceContainer Interface
IServiceContainer Members


NotifyCollectionChangedEventHandler Delegate

[image]
ActiveReports 13
NotifyCollectionChangedEventHandler Delegate
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles events that implement the System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NotifyCollectionChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As NotifyCollectionChangedEventArgs _
)
C#
public delegate void NotifyCollectionChangedEventHandler(
   object sender,
   NotifyCollectionChangedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NotifyCollectionChangedEventHandler Members
GrapeCity.Viewer.Common Namespace


GrapeCity.ActiveReports.Web Namespace

GrapeCity.ActiveReports.Web Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Web namespace contains the WebViewer class.

Classes

 | Class | Description
Class | WebViewer | The ActiveReports viewer for ASP.NET Web Forms. In addition to providing an easy way to deploy and view reports under ASP.NET, this control provides report caching functionality that reduces the number of times a report executes per user session as the user navigates between pages in the report document.

Enumerations

 | Enumeration | Description
Enumeration | OutputFormat | An enumeration of output formats available with the WebViewer control.
Enumeration | RenderMode | The different ways of rendering
Enumeration | ViewerType | An enumeration of viewing options for the ActiveReports WebForms WebViewer server control for ASP.NET.

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


WebViewer Class

[image]
ActiveReports 13
WebViewer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

Glossary Item Box

The ActiveReports viewer for ASP.NET Web Forms. In addition to providing an easy way to deploy and view reports under ASP.NET, this control provides report caching functionality that reduces the number of times a report executes per user session as the user navigates between pages in the report document.

Object Model

WebViewer Class

Syntax

Visual Basic (Declaration)
Public Class WebViewer
   Inherits System.Web.UI.WebControls.WebControl
C#
public class WebViewer : System.Web.UI.WebControls.WebControl

Remarks

Implements INamingContainer (a marker interface with no members) so that contained controls are in a new namespace in which all child control ID attributes are guaranteed to be unique within an entire application. You can add controls to this control, and they'll always get a unique name on the client.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
GrapeCity.ActiveReports.Web.WebViewer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Members
GrapeCity.ActiveReports.Web Namespace


WebViewer Class Members

[image]
ActiveReports 13
WebViewer Class Members
See Also Properties Methods Events
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

Glossary Item Box

The following tables list the members exposed by WebViewer.

Public Constructors

 | Name | Description
Public Constructor | WebViewer Constructor | Initializes a new instance of the WebViewer class.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Gets or sets the height of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HtmlExportOptions | Returns an HtmlExportOptions object to set HTML-specific properties when you use the HTML ViewerType in the WebViewer control.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | MaxReportRunTime | The maximum number of seconds that a request for a report's output should wait for the report to finish executing.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PdfExportOptions | Returns a PdfExportOptions object to set PDF-specific properties when you use the PDF ViewerType in the WebViewer control.
Public Property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from System.Web.UI.Control)
Public Property | RenderMode | The configure way of rendering.
Public Property | Report | Specifies the report object to display to the client.
Public Property | ReportName | Specifies the name of the report object to display to the client.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SlidingExpirationInterval | The interval in seconds between the time the report was last retrieved and when the report will be removed from the ASP.NET WebCache.
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's System.Web.UI.WebControls.WebControl.IsEnabled property is false. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from System.Web.UI.Control)
Public Property | ViewerType | Determines the type of viewer that will be used to show the report in the client machine's browser.
Public Property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Dispose | Overridden. Releases the WebViewer instance from memory.
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | Returns the prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Extracts the style attribute from the outer div or table tag when using Acrobat and uses a percentage of the width or height. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


WebViewer Constructor

[image]
ActiveReports 13
WebViewer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : WebViewer Constructor

Glossary Item Box

Initializes a new instance of the WebViewer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WebViewer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


WebViewer Class Methods

[image]
ActiveReports 13
WebViewer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

Glossary Item Box

For a list of all members of this type, see WebViewer members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | Dispose | Overridden. Releases the WebViewer instance from memory.
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | Returns the prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Extracts the style attribute from the outer div or table tag when using Acrobat and uses a percentage of the width or height. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Dispose Method

Glossary Item Box

Releases the WebViewer instance from memory.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Dispose()
C#
public override void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


WebViewer Class Properties

[image]
ActiveReports 13
WebViewer Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

Glossary Item Box

For a list of all members of this type, see WebViewer members.

Public Properties

 | Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Gets or sets the height of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HtmlExportOptions | Returns an HtmlExportOptions object to set HTML-specific properties when you use the HTML ViewerType in the WebViewer control.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | MaxReportRunTime | The maximum number of seconds that a request for a report's output should wait for the report to finish executing.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PdfExportOptions | Returns a PdfExportOptions object to set PDF-specific properties when you use the PDF ViewerType in the WebViewer control.
Public Property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from System.Web.UI.Control)
Public Property | RenderMode | The configure way of rendering.
Public Property | Report | Specifies the report object to display to the client.
Public Property | ReportName | Specifies the name of the report object to display to the client.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SlidingExpirationInterval | The interval in seconds between the time the report was last retrieved and when the report will be removed from the ASP.NET WebCache.
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's System.Web.UI.WebControls.WebControl.IsEnabled property is false. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from System.Web.UI.Control)
Public Property | ViewerType | Determines the type of viewer that will be used to show the report in the client machine's browser.
Public Property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


HtmlExportOptions Property

[image]
ActiveReports 13
HtmlExportOptions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : HtmlExportOptions Property

Glossary Item Box

Returns an HtmlExportOptions object to set HTML-specific properties when you use the HTML ViewerType in the WebViewer control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HtmlExportOptions As HtmlExportOptions
C#
public HtmlExportOptions HtmlExportOptions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


MaxReportRunTime Property

[image]
ActiveReports 13
MaxReportRunTime Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : MaxReportRunTime Property

Glossary Item Box

The maximum number of seconds that a request for a report's output should wait for the report to finish executing.

Syntax

Visual Basic (Declaration)
Public Property MaxReportRunTime As TimeSpan
C#
public TimeSpan MaxReportRunTime {get; set;}

Property Value

The default value is 10 seconds.

Remarks

If a report takes longer to run than the value of this property, the control will make subsequent requests at 5 second intervals for the report to see when it is finished executing.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


PdfExportOptions Property

[image]
ActiveReports 13
PdfExportOptions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : PdfExportOptions Property

Glossary Item Box

Returns a PdfExportOptions object to set PDF-specific properties when you use the PDF ViewerType in the WebViewer control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PdfExportOptions As PdfExportOptions
C#
public PdfExportOptions PdfExportOptions {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


RenderMode Property

[image]
ActiveReports 13
RenderMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderMode Property

Glossary Item Box

The configure way of rendering.

Syntax

Visual Basic (Declaration)
Public Property RenderMode As RenderMode
C#
public RenderMode RenderMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Report Property

[image]
ActiveReports 13
Report Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Report Property

Glossary Item Box

Specifies the report object to display to the client.

Syntax

Visual Basic (Declaration)
Public Property Report As Object
C#
public object Report {get; set;}

Property Value

An ActiveReport object.

Remarks

If the control is being loaded in response to a client postback ( ) the property will not use the specified report. Instead the control uses a previously cached copy of the report's Document in the WebCache service to supply speedy responses to clients.

Requirements

See Also

Reference

WebViewer Class
WebViewer Members


ReportName Property

[image]
ActiveReports 13
ReportName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ReportName Property

Glossary Item Box

Specifies the name of the report object to display to the client.

Syntax

Visual Basic (Declaration)
Public Property ReportName As String
C#
public string ReportName {get; set;}

Property Value

A string.

Remarks

This property is set from the property window of WebViewer control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


SlidingExpirationInterval Property

[image]
ActiveReports 13
SlidingExpirationInterval Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SlidingExpirationInterval Property

Glossary Item Box

The interval in seconds between the time the report was last retrieved and when the report will be removed from the ASP.NET WebCache.

Syntax

Visual Basic (Declaration)
Public Property SlidingExpirationInterval As TimeSpan
C#
public TimeSpan SlidingExpirationInterval {get; set;}

Remarks

By using this property, you can advance the retention period for the reports that are stored in the cache. For the reports that have exceeded the retention period, they are not necessarily always destroyed at that very moment, and the timing for that depends on the garbage collection.

In particular, if the report to be generated does not change every time, then there is no need to retain it in the cache for a long time, therefore efficiency can be achieved by setting just the minimum value of the generation time of the report.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ViewerType Property

[image]
ActiveReports 13
ViewerType Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ViewerType Property

Glossary Item Box

Determines the type of viewer that will be used to show the report in the client machine's browser.

Syntax

Visual Basic (Declaration)
Public Property ViewerType As ViewerType
C#
public ViewerType ViewerType {get; set;}

Example

C# Copy Code
private void cboViewerType_SelectedIndexChanged(object sender, System.EventArgs e)
{
    // Set the Viewer Type from the dropdown list in the Viewer type property
    string selection = this.cboViewerType.Items[this.cboViewerType.SelectedIndex].Text;
    switch (selection)
    {
                case "AcrobatReader":  //Acrobat Reader was chosen as the viewer type
                    this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader;
                    break;
                case "HtmlViewer":  //HTML Viewer was chosen as the viewer type
                    this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer;
                    break;
                case "RawHtml":  //Raw HTML was chosen as the viewer type
                    this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml;
                    break;
    }
}
Visual Basic Copy Code
Private Sub cboViewerType_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboViewerType.SelectedIndexChanged
    ' Set the Viewer Type from the dropdown list to the ActiveReports WebViewer
    Dim selection As String = Me.cboViewerType.Items(Me.cboViewerType.SelectedIndex).Text
    Select Case selection
        Case "AcrobatReader" 'Acrobat Reader was chosen as the viewer type
            Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader
        Case "HtmlViewer" 'HTML Viewer was chosen as the viewer type
            Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer
        Case "RawHtml" 'Raw HTML was chosen as the viewer type
            Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml
    End Select
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


WebViewer Class Events

[image]
ActiveReports 13
WebViewer Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

Glossary Item Box

For a list of all members of this type, see WebViewer members.

Public Events

 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


LocateCredentials Event

[image]
ActiveReports 13
LocateCredentials Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : LocateCredentials Event

Glossary Item Box

Fires when the PageReport to view generates LocateCredentials event.

Syntax

Visual Basic (Declaration)
Public Event LocateCredentials As LocateCredentialsEventHandler
C#
public event LocateCredentialsEventHandler LocateCredentials

Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSource | Gets the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


LocateDataSource Event

[image]
ActiveReports 13
LocateDataSource Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : LocateDataSource Event

Glossary Item Box

Fires when the PageReport to view generates LocateDataSource event.

Syntax

Visual Basic (Declaration)
Public Event LocateDataSource As LocateDataSourceEventHandler
C#
public event LocateDataSourceEventHandler LocateDataSource

Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSet | Gets the report's GrapeCity.ActiveReports.PageReportModel.IDataSet object to locate data for.
Parameters | Gets the Parameters collection specified for a given report instance.
Report | Gets the Report that is trying to locate the data set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


OutputFormat Enumeration

[image]
ActiveReports 13
OutputFormat Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : OutputFormat Enumeration

Glossary Item Box

An enumeration of output formats available with the WebViewer control.

Syntax

Visual Basic (Declaration)
Public Enum OutputFormat
   Inherits System.Enum
C#
public enum OutputFormat : System.Enum

Members

Member | Description
Html | Browser compatible HTML Format.
Pdf | Portable Document Format (PDF). Good for printing and exact WYSIWYG layout.
Rdf2 | ActiveReports 2.0 (COM) native file format. It provides precise output, and the comprehensive ActiveReports features (such as table of contents and hyperlinks).
Rdf3 | ActiveReports.NET native file format. This format is used with the ActiveReports .NET WinForms Viewer control. It provides precise output, and the comprehensive ActiveReports features (such as table of contents and hyperlinks).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.OutputFormat

Requirements

See Also

Reference

GrapeCity.ActiveReports.Web Namespace


RenderMode Enumeration

[image]
ActiveReports 13
RenderMode Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : RenderMode Enumeration

Glossary Item Box

The different ways of rendering

Syntax

Visual Basic (Declaration)
Public Enum RenderMode
   Inherits System.Enum
C#
public enum RenderMode : System.Enum

Members

Member | Description
Galley | Rendering in galley mode
Paginated | Page rendering

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.RenderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web Namespace


ViewerType Enumeration

[image]
ActiveReports 13
ViewerType Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace : ViewerType Enumeration

Glossary Item Box

An enumeration of viewing options for the ActiveReports WebForms WebViewer server control for ASP.NET.

Syntax

Visual Basic (Declaration)
Public Enum ViewerType
   Inherits System.Enum
C#
public enum ViewerType : System.Enum

Members

Member | Description
AcrobatReader | Returns output as a PDF document viewable in Acrobat Reader. Client requirements: Adobe Acrobat Reader.
HtmlViewer | Provides a scrollable view of a single page of the report at a time. Downloads only HTML and javascript to the client browser. Not preferable for printable output. Client Requirements: Internet Explorer 11 and above.
RawHtml | Shows all pages in the report document as a single continuous HTML page. Provides a static view of the entire report document, and usually decent printable output, although under some circumstances, pagination is not preserved. Client Requirements: Internet Explorer 11 and above.

Remarks

Some barcode types may render incorrectly and contain white lines in the Html and RawHtml views. However, this limitation does not affect printing and scanning. These barcodes are:

  • Code49
  • QRCode
  • Pdf417
  • RSSExpandedStacked
  • RSS14Stacked
  • RSS14StackedOmnidirectional

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.ViewerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web Namespace


GrapeCity.ActiveReports.Web.Controls Namespace

GrapeCity.ActiveReports.Web.Controls Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web.Controls Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Web.Controls namespace contains the customizable toolbar object and tools that can be used with the FlashViewer ViewerType of the WebViewer.

Classes

 | Class | Description
Class | Tool | Represents tools that can be added to the customizable toolbar object for the FlashViewer.
Class | ToolBarObject | A customizable toolbar object to be used with the FlashViewer.
Class | ToolBase | Represents the toolbox items that can be used with the FlashViewer.
Class | ToolButton | Represents a tool button for use with the customizable FlashViewer ToolBarObject.
Class | ToolsCollection | Represents a collection of tools for use with the customizable FlashViewer ToolBarObject.

Enumerations

 | Enumeration | Description
Enumeration | ToolsCollection.ToolCommands | An enumeration of all default toolbar commands.

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


Tool Class

[image]
ActiveReports 13
Tool Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class

Glossary Item Box

Represents tools that can be added to the customizable toolbar object for the FlashViewer.

Object Model

Tool Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class Tool
   Inherits ToolBase
C#
public abstract class Tool : ToolBase

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool
GrapeCity.ActiveReports.Web.Controls.ToolButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Members
GrapeCity.ActiveReports.Web.Controls Namespace


Tool Class Members

[image]
ActiveReports 13
Tool Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class

Glossary Item Box

The following tables list the members exposed by Tool.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool.
Public Property | Name | Gets or sets the name of the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool.
Public Property | Visible | Gets or sets a value indicating whether to display the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates standard commands.
static (Shared in Visual Basic) | CreateButton | Creates custom buttons.
static (Shared in Visual Basic) | CreateSeparator | Overloaded. Creates the tool separator.
Top

See Also

Reference

Tool Class
GrapeCity.ActiveReports.Web.Controls Namespace


Tool Class Methods

[image]
ActiveReports 13
Tool Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class

Glossary Item Box

For a list of all members of this type, see Tool members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates standard commands.
static (Shared in Visual Basic) | CreateButton | Creates custom buttons.
static (Shared in Visual Basic) | CreateSeparator | Overloaded. Creates the tool separator.
Top

See Also

Reference

Tool Class
GrapeCity.ActiveReports.Web.Controls Namespace


Create Method

[image]
ActiveReports 13
Create Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : Create Method

command
Creates standard commands.

Glossary Item Box

Creates standard commands.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal command As ToolsCollection.ToolCommands _
) As Tool
C#
public static Tool Create(
   ToolsCollection.ToolCommands command
)

Parameters

command
Creates standard commands.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Class
Tool Members


CreateButton Method

[image]
ActiveReports 13
CreateButton Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : CreateButton Method

name
Name of the custom button.

Glossary Item Box

Creates custom buttons.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateButton( _
   ByVal name As String _
) As ToolButton
C#
public static ToolButton CreateButton(
   string name
)

Parameters

name
Name of the custom button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Class
Tool Members


CreateSeparator Method

[image]
ActiveReports 13
CreateSeparator Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : CreateSeparator Method

Glossary Item Box

Creates the tool separator.

Overload List

Overload | Description
CreateSeparator() | Creates the tool separator.
CreateSeparator(String) | Creates the tool separator with a given name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Class
Tool Members


CreateSeparator() Method

[image]
ActiveReports 13
CreateSeparator() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class > CreateSeparator Method : CreateSeparator() Method

Glossary Item Box

Creates the tool separator.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateSeparator() As ToolSeparator
C#
public static ToolSeparator CreateSeparator()

Return Value

Created separator

Remarks

Guid will be used as separator name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Class
Tool Members
Overload List


CreateSeparator(String) Method

[image]
ActiveReports 13
CreateSeparator(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class > CreateSeparator Method : CreateSeparator(String) Method

name
Name of the separator

Glossary Item Box

Creates the tool separator with a given name.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateSeparator( _
   ByVal name As String _
) As ToolSeparator
C#
public static ToolSeparator CreateSeparator(
   string name
)

Parameters

name
Name of the separator

Return Value

Created separator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Class
Tool Members
Overload List


Tool Class Properties

[image]
ActiveReports 13
Tool Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class

Glossary Item Box

For a list of all members of this type, see Tool members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool.
Public Property | Name | Gets or sets the name of the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool.
Public Property | Visible | Gets or sets a value indicating whether to display the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top

See Also

Reference

Tool Class
GrapeCity.ActiveReports.Web.Controls Namespace


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether to enable the tool.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Class
Tool Members


ToolTip Property

[image]
ActiveReports 13
ToolTip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : ToolTip Property

Glossary Item Box

Gets or sets the text to display when the users hovers the pointer over the tool.

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
C#
public string ToolTip {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Tool Class
Tool Members


ToolBarObject Class

[image]
ActiveReports 13
ToolBarObject Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBarObject Class

Glossary Item Box

A customizable toolbar object to be used with the FlashViewer.

Object Model

ToolBarObject Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolBarObject
C#
public sealed class ToolBarObject

Remarks

Once you create a custom toolbar, specify this object in the WebViewer's FlashViewerToolBar property.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBarObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBarObject Members
GrapeCity.ActiveReports.Web.Controls Namespace
FlashViewerToolBar Property


ToolBarObject Class Members

[image]
ActiveReports 13
ToolBarObject Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBarObject Class

Glossary Item Box

The following tables list the members exposed by ToolBarObject.

Public Constructors

 | Name | Description
Public Constructor | ToolBarObject Constructor | Initializes a new instance of the ToolBarObject class.
Top

Public Properties

 | Name | Description
Public Property | Tools | Gets or sets the collection of tools to display in the toolbar.
Public Property | Visible | Gets or sets a value indicating whether the ToolBarObject is visible.
Top

See Also

Reference

ToolBarObject Class
GrapeCity.ActiveReports.Web.Controls Namespace
FlashViewerToolBar Property


ToolBarObject Constructor

[image]
ActiveReports 13
ToolBarObject Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBarObject Class : ToolBarObject Constructor

Glossary Item Box

Initializes a new instance of the ToolBarObject class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToolBarObject()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBarObject Class
ToolBarObject Members


ToolBarObject Class Properties

[image]
ActiveReports 13
ToolBarObject Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBarObject Class

Glossary Item Box

For a list of all members of this type, see ToolBarObject members.

Public Properties

 | Name | Description
Public Property | Tools | Gets or sets the collection of tools to display in the toolbar.
Public Property | Visible | Gets or sets a value indicating whether the ToolBarObject is visible.
Top

See Also

Reference

ToolBarObject Class
GrapeCity.ActiveReports.Web.Controls Namespace
FlashViewerToolBar Property


Tools Property

[image]
ActiveReports 13
Tools Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBarObject Class : Tools Property

Glossary Item Box

Gets or sets the collection of tools to display in the toolbar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tools As ToolsCollection
C#
public ToolsCollection Tools {get;}

Property Value

A ToolsCollection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBarObject Class
ToolBarObject Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBarObject Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the ToolBarObject is visible.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

A Boolean value. The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBarObject Class
ToolBarObject Members


ToolBase Class

[image]
ActiveReports 13
ToolBase Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBase Class

Glossary Item Box

Represents the toolbox items that can be used with the FlashViewer.

Object Model

ToolBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ToolBase
C#
public abstract class ToolBase

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBase Members
GrapeCity.ActiveReports.Web.Controls Namespace


ToolBase Class Members

[image]
ActiveReports 13
ToolBase Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBase Class

Glossary Item Box

The following tables list the members exposed by ToolBase.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the toolbox item.
Public Property | Visible | Gets or sets the toolbox item's visibility.
Top

See Also

Reference

ToolBase Class
GrapeCity.ActiveReports.Web.Controls Namespace


ToolBase Class Properties

[image]
ActiveReports 13
ToolBase Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBase Class

Glossary Item Box

For a list of all members of this type, see ToolBase members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the toolbox item.
Public Property | Visible | Gets or sets the toolbox item's visibility.
Top

See Also

Reference

ToolBase Class
GrapeCity.ActiveReports.Web.Controls Namespace


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBase Class : Name Property

Glossary Item Box

Gets the name of the toolbox item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBase Class
ToolBase Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBase Class : Visible Property

Glossary Item Box

Gets or sets the toolbox item's visibility.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolBase Class
ToolBase Members


ToolButton Class

[image]
ActiveReports 13
ToolButton Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolButton Class

Glossary Item Box

Represents a tool button for use with the customizable FlashViewer ToolBarObject.

Object Model

ToolButton Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolButton
   Inherits Tool
C#
public sealed class ToolButton : Tool

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool
GrapeCity.ActiveReports.Web.Controls.ToolButton

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolButton Members
GrapeCity.ActiveReports.Web.Controls Namespace


ToolButton Class Members

[image]
ActiveReports 13
ToolButton Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolButton Class

Glossary Item Box

The following tables list the members exposed by ToolButton.

Public Properties

 | Name | Description
Public Property | Caption | Gets or sets the caption for a button.
Public Property | ClickNavigateTo | Gets or sets a string value that specifies a URL that the button opens in a new browser window.
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Name | Gets the name of the toolbox item. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Visible | Gets or sets the toolbox item's visibility. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top

See Also

Reference

ToolButton Class
GrapeCity.ActiveReports.Web.Controls Namespace


ToolButton Class Properties

[image]
ActiveReports 13
ToolButton Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolButton Class

Glossary Item Box

For a list of all members of this type, see ToolButton members.

Public Properties

 | Name | Description
Public Property | Caption | Gets or sets the caption for a button.
Public Property | ClickNavigateTo | Gets or sets a string value that specifies a URL that the button opens in a new browser window.
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Name | Gets the name of the toolbox item. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Visible | Gets or sets the toolbox item's visibility. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top

See Also

Reference

ToolButton Class
GrapeCity.ActiveReports.Web.Controls Namespace


Caption Property

[image]
ActiveReports 13
Caption Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolButton Class : Caption Property

Glossary Item Box

Gets or sets the caption for a button.

Syntax

Visual Basic (Declaration)
Public Property Caption As String
C#
public string Caption {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolButton Class
ToolButton Members


ClickNavigateTo Property

[image]
ActiveReports 13
ClickNavigateTo Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolButton Class : ClickNavigateTo Property

Glossary Item Box

Gets or sets a string value that specifies a URL that the button opens in a new browser window.

Syntax

Visual Basic (Declaration)
Public Property ClickNavigateTo As String
C#
public string ClickNavigateTo {get; set;}

Property Value

A string URL.

Example

C# Copy Code
GrapeCity.ActiveReports.Web.Controls.ToolButton button = new GrapeCity.ActiveReports.Web.Controls.ToolButton();
button.ClickNavigateTo = "http://www.grapecity.com";
button.ToolTip = "Test tooltip";
WebViewer1.FlashViewerToolBar.Tools.Add(button);
Visual Basic Copy Code
Dim button As New GrapeCity.ActiveReports.Web.Controls.ToolButton()
button.ClickNavigateTo = "http://www.grapecity.com"
button.ToolTip = "Test tooltip"
WebViewer1.FlashViewerToolBar.Tools.Add(button)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolButton Class
ToolButton Members


ToolsCollection Class

[image]
ActiveReports 13
ToolsCollection Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class

Glossary Item Box

Represents a collection of tools for use with the customizable FlashViewer ToolBarObject.

Object Model

ToolsCollection Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolsCollection
   Inherits System.Collections.ObjectModel.Collection(Of ToolBase)
C#
public sealed class ToolsCollection : System.Collections.ObjectModel.Collection<ToolBase>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.Web.Controls.ToolsCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Members
GrapeCity.ActiveReports.Web.Controls Namespace


ToolsCollection Class Members

[image]
ActiveReports 13
ToolsCollection Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class

Glossary Item Box

The following tables list the members exposed by ToolsCollection.

Public Constructors

 | Name | Description
Public Constructor | ToolsCollection Constructor | Initializes a new instance of the ToolsCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Property | Item | Overloaded. The Tool object to remove from the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Add the specified tool to the tools collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Clear | Clears all tools from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Remove | Removes the specified tool from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | RemoveAt | Removes the tool in the specified position from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Top

See Also

Reference

ToolsCollection Class
GrapeCity.ActiveReports.Web.Controls Namespace


ToolsCollection Constructor

[image]
ActiveReports 13
ToolsCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : ToolsCollection Constructor

Glossary Item Box

Initializes a new instance of the ToolsCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ToolsCollection()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


ToolsCollection Class Properties

[image]
ActiveReports 13
ToolsCollection Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class

Glossary Item Box

For a list of all members of this type, see ToolsCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Property | Item | Overloaded. The Tool object to remove from the collection.
Top

See Also

Reference

ToolsCollection Class
GrapeCity.ActiveReports.Web.Controls Namespace


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Item Property

Glossary Item Box

The Tool object to remove from the collection.

Overload List

Overload | Description
Item(String) | Gets item with correspinding name. Null will be returned, if nothing found
Item(Int32) | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


Item(String) Property

[image]
ActiveReports 13
Item(String) Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class > Item Property : Item(String) Property

name

Glossary Item Box

Gets item with correspinding name. Null will be returned, if nothing found

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ToolBase
C#
public ToolBase Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members
Overload List


ToolsCollection.ToolCommands Enumeration

[image]
ActiveReports 13
ToolsCollection.ToolCommands Enumeration
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection.ToolCommands Enumeration

Glossary Item Box

An enumeration of all default toolbar commands.

Syntax

Visual Basic (Declaration)
Public Enum ToolsCollection.ToolCommands
   Inherits System.Enum
C#
public enum ToolsCollection.ToolCommands : System.Enum

Members

Member | Description
BackwardButton | Navigates backward.
ContinuousViewButton | Displays the report in the continuous view mode.
CurPageTextArea | Displays the page index.
ForwardButton | Navigates forward.
MultiPageBox | Shows multiple pages of the report.
NextPageButton | Takes to the next page of the report.
PageRangeButton | Sets the page range for printing the report.
PreviousPageButton | Takes to the previous page of the report.
PrintButton | Prints the report.
SearchButton | Shows the Find dialog.
SinglePageViewButton | Displays the report as a single page.
TOCButton | Displays the table of contents pane.
ZoomBox | Sets the zoom level at which to display the report.
ZoomInButton | Increases the zoom level for displaying the report, with 800% as the highest level.
ZoomOutButton | Decreases the zoom level for displaying the report, with 10% as the lowest level.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Controls.ToolsCollection.ToolCommands

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.ActiveReports.Web.Controls Namespace


GrapeCity.ActiveReports.Web.ExportOptions Namespace

GrapeCity.ActiveReports.Web.ExportOptions Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web.ExportOptions Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Web.ExportOptions namespace contains the HtmlExport and PdfExport classes.

Classes

 | Class | Description
Class | HtmlExportOptions | Allows you to set options when using the HTML ViewerType.
Class | PdfExportOptions | Allows you to set options when using the PDF ViewerType.
Class | PrintPresets | Specifies the print presets.

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


HtmlExportOptions Class

[image]
ActiveReports 13
HtmlExportOptions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : HtmlExportOptions Class

Glossary Item Box

Allows you to set options when using the HTML ViewerType.

Object Model

HtmlExportOptions Class

Syntax

Visual Basic (Declaration)
Public Class HtmlExportOptions
C#
public class HtmlExportOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.HtmlExportOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


HtmlExportOptions Class Members

[image]
ActiveReports 13
HtmlExportOptions Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : HtmlExportOptions Class

Glossary Item Box

The following tables list the members exposed by HtmlExportOptions.

Public Properties

 | Name | Description
Public Property | BookmarkStyle | Specifies a BookmarkStyle to use when exporting to an HTML format.
Public Property | CharacterSet | Specifies the HTML character set to use when exporting to an HTML format.
Public Property | CreateFramesetPage | Specifies if a Frameset page should be created when exporting to an HTML format.
Public Property | IncludeHtmlHeader | Specifies if an HTML header section should be created when exporting to an HTML format.
Public Property | IncludePageMargins | Specifies if the report margins should be used when exporting to an HTML format.
Public Property | MultiPage | Specifies if the report should be exported to multiple pages when exporting to an HTML format.
Public Property | OutputType | Specifies the HTML output type to be used with exporting to an HTML viewer type.
Public Property | RemoveVerticalSpace | Specifies if vertical spacing should be removed when exporting to an HTML viewer type.
Public Property | Title | Specifies the text used in the HTML tags of the exported document when using an HTML viewer type.
Top

See Also

Reference

HtmlExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


HtmlExportOptions Class Properties

[image]
ActiveReports 13
HtmlExportOptions Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : HtmlExportOptions Class

Glossary Item Box

For a list of all members of this type, see HtmlExportOptions members.

Public Properties

 | Name | Description
Public Property | BookmarkStyle | Specifies a BookmarkStyle to use when exporting to an HTML format.
Public Property | CharacterSet | Specifies the HTML character set to use when exporting to an HTML format.
Public Property | CreateFramesetPage | Specifies if a Frameset page should be created when exporting to an HTML format.
Public Property | IncludeHtmlHeader | Specifies if an HTML header section should be created when exporting to an HTML format.
Public Property | IncludePageMargins | Specifies if the report margins should be used when exporting to an HTML format.
Public Property | MultiPage | Specifies if the report should be exported to multiple pages when exporting to an HTML format.
Public Property | OutputType | Specifies the HTML output type to be used with exporting to an HTML viewer type.
Public Property | RemoveVerticalSpace | Specifies if vertical spacing should be removed when exporting to an HTML viewer type.
Public Property | Title | Specifies the text used in the HTML tags of the exported document when using an HTML viewer type.
Top

See Also

Reference

HtmlExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


BookmarkStyle Property

[image]
ActiveReports 13
BookmarkStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : BookmarkStyle Property

Glossary Item Box

Specifies a BookmarkStyle to use when exporting to an HTML format.

Syntax

Visual Basic (Declaration)
Public Property BookmarkStyle As BookmarkStyle
C#
public BookmarkStyle BookmarkStyle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


CharacterSet Property

[image]
ActiveReports 13
CharacterSet Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : CharacterSet Property

Glossary Item Box

Specifies the HTML character set to use when exporting to an HTML format.

Syntax

Visual Basic (Declaration)
Public Property CharacterSet As HtmlCharacterSet
C#
public HtmlCharacterSet CharacterSet {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


CreateFramesetPage Property

[image]
ActiveReports 13
CreateFramesetPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : CreateFramesetPage Property

Glossary Item Box

Specifies if a Frameset page should be created when exporting to an HTML format.

Syntax

Visual Basic (Declaration)
Public Property CreateFramesetPage As Boolean
C#
public bool CreateFramesetPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


IncludeHtmlHeader Property

[image]
ActiveReports 13
IncludeHtmlHeader Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : IncludeHtmlHeader Property

Glossary Item Box

Specifies if an HTML header section should be created when exporting to an HTML format.

Syntax

Visual Basic (Declaration)
Public Property IncludeHtmlHeader As Boolean
C#
public bool IncludeHtmlHeader {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


IncludePageMargins Property

[image]
ActiveReports 13
IncludePageMargins Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : IncludePageMargins Property

Glossary Item Box

Specifies if the report margins should be used when exporting to an HTML format.

Syntax

Visual Basic (Declaration)
Public Property IncludePageMargins As Boolean
C#
public bool IncludePageMargins {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


MultiPage Property

[image]
ActiveReports 13
MultiPage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : MultiPage Property

Glossary Item Box

Specifies if the report should be exported to multiple pages when exporting to an HTML format.

Syntax

Visual Basic (Declaration)
Public Property MultiPage As Boolean
C#
public bool MultiPage {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


OutputType Property

[image]
ActiveReports 13
OutputType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : OutputType Property

Glossary Item Box

Specifies the HTML output type to be used with exporting to an HTML viewer type.

Syntax

Visual Basic (Declaration)
Public Property OutputType As HtmlOutputType
C#
public HtmlOutputType OutputType {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


RemoveVerticalSpace Property

[image]
ActiveReports 13
RemoveVerticalSpace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : RemoveVerticalSpace Property

Glossary Item Box

Specifies if vertical spacing should be removed when exporting to an HTML viewer type.

Syntax

Visual Basic (Declaration)
Public Property RemoveVerticalSpace As Boolean
C#
public bool RemoveVerticalSpace {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : Title Property

Glossary Item Box

Specifies the text used in the HTML tags of the exported document when using an HTML viewer type.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


PdfExportOptions Class

[image]
ActiveReports 13
PdfExportOptions Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PdfExportOptions Class

Glossary Item Box

Allows you to set options when using the PDF ViewerType.

Object Model

PdfExportOptions Class

Syntax

Visual Basic (Declaration)
Public Class PdfExportOptions
C#
public class PdfExportOptions

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.PdfExportOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


PdfExportOptions Class Members

[image]
ActiveReports 13
PdfExportOptions Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PdfExportOptions Class

Glossary Item Box

The following tables list the members exposed by PdfExportOptions.

Public Properties

 | Name | Description
Public Property | Application | Specifies the Application used to produce the PDF when using the PDF Viewer type.
Public Property | Author | Specifies the Author of the PDF when using the PDF Viewer type.
Public Property | CenterWindow | Specifies if the export should include the CenterWindow flag in the PDF document when using the PDF Viewer type.
Public Property | ConvertMetaToPng | Specifies if the PDF Export should convert WMF/EMF images into PNG for the PDF Viewer type.
Public Property | DisplayMode | Specifies the PDF DisplayMode when using the PDF Viewer type.
Public Property | DisplayTitle | Specifies the PDF DisplayTitle when using the PDF Viewer type.
Public Property | Encrypt | Specifies if the export should encrypt the PDF when using the PDF Viewer type.
Public Property | ExportBookmarks | Specifies if the PDF Export should export bookmarks for the PDF Viewer type.
Public Property | FileName | Gets or sets the name of an exported file in the Save file dialog.
Public Property | FitWindow | Specifies if the export should use the FitWindow flag when using the PDF Viewer type.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs that are missing in the original font (Professional Edition).
Public Property | HideMenubar | Specifies if the export should use the hideMenubar flag when using the PDF Viewer type.
Public Property | HideToolbar | Specifies if the export should use the HideToolbar flag when using the PDF Viewer type.
Public Property | HideWindowUI | Specifies if the export should use the HideWindowUI flag when using the PDF Viewer type.
Public Property | ImageQuality | Specifies the ImageQuality the PDF Export should use for the PDF Viewer type.
Public Property | ImageResolution | Specifies the ImageResolution the PDF Export should use for the PDF Viewer type.
Public Property | Keywords | Specifies the Keywords the export will embed in the PDF when using the PDF Viewer type.
Public Property | NeverEmbedFonts | Specifies the fonts the PDF Export should not embed for the PDF Viewer type.
Public Property | OnlyForPrint | Gets or sets a value indicating whether the PDF is only for print.
Public Property | OwnerPassword | Specifies the PDF Owner's password when using the PDF Viewer type and the Encrypt property is set to true. If this value is left null or empty, the user is not granted full permissions to the pdf file security settings.
Public Property | Permissions | Specifies the PDF permissions when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | PrintPresets | Specifies the Print Presets the PDF Export should use for the PDF Viewer type
Public Property | Subject | Specifies the Subject the export will use when using the PDF Viewer type.
Public Property | Title | Specifies the Title the export will use when using the PDF Viewer type.
Public Property | Use128Bit | Specifies if the export should use 128Bit encryption when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | UserPassword | Specifies the PDF User's password when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | Version | Specifies the PDF Version to use when using the PDF Viewer type.
Top

See Also

Reference

PdfExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


PdfExportOptions Class Properties

[image]
ActiveReports 13
PdfExportOptions Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PdfExportOptions Class

Glossary Item Box

For a list of all members of this type, see PdfExportOptions members.

Public Properties

 | Name | Description
Public Property | Application | Specifies the Application used to produce the PDF when using the PDF Viewer type.
Public Property | Author | Specifies the Author of the PDF when using the PDF Viewer type.
Public Property | CenterWindow | Specifies if the export should include the CenterWindow flag in the PDF document when using the PDF Viewer type.
Public Property | ConvertMetaToPng | Specifies if the PDF Export should convert WMF/EMF images into PNG for the PDF Viewer type.
Public Property | DisplayMode | Specifies the PDF DisplayMode when using the PDF Viewer type.
Public Property | DisplayTitle | Specifies the PDF DisplayTitle when using the PDF Viewer type.
Public Property | Encrypt | Specifies if the export should encrypt the PDF when using the PDF Viewer type.
Public Property | ExportBookmarks | Specifies if the PDF Export should export bookmarks for the PDF Viewer type.
Public Property | FileName | Gets or sets the name of an exported file in the Save file dialog.
Public Property | FitWindow | Specifies if the export should use the FitWindow flag when using the PDF Viewer type.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs that are missing in the original font (Professional Edition).
Public Property | HideMenubar | Specifies if the export should use the hideMenubar flag when using the PDF Viewer type.
Public Property | HideToolbar | Specifies if the export should use the HideToolbar flag when using the PDF Viewer type.
Public Property | HideWindowUI | Specifies if the export should use the HideWindowUI flag when using the PDF Viewer type.
Public Property | ImageQuality | Specifies the ImageQuality the PDF Export should use for the PDF Viewer type.
Public Property | ImageResolution | Specifies the ImageResolution the PDF Export should use for the PDF Viewer type.
Public Property | Keywords | Specifies the Keywords the export will embed in the PDF when using the PDF Viewer type.
Public Property | NeverEmbedFonts | Specifies the fonts the PDF Export should not embed for the PDF Viewer type.
Public Property | OnlyForPrint | Gets or sets a value indicating whether the PDF is only for print.
Public Property | OwnerPassword | Specifies the PDF Owner's password when using the PDF Viewer type and the Encrypt property is set to true. If this value is left null or empty, the user is not granted full permissions to the pdf file security settings.
Public Property | Permissions | Specifies the PDF permissions when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | PrintPresets | Specifies the Print Presets the PDF Export should use for the PDF Viewer type
Public Property | Subject | Specifies the Subject the export will use when using the PDF Viewer type.
Public Property | Title | Specifies the Title the export will use when using the PDF Viewer type.
Public Property | Use128Bit | Specifies if the export should use 128Bit encryption when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | UserPassword | Specifies the PDF User's password when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | Version | Specifies the PDF Version to use when using the PDF Viewer type.
Top

See Also

Reference

PdfExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


Application Property

[image]
ActiveReports 13
Application Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Application Property

Glossary Item Box

Specifies the Application used to produce the PDF when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property Application As String
C#
public string Application {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Author Property

[image]
ActiveReports 13
Author Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Author Property

Glossary Item Box

Specifies the Author of the PDF when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property Author As String
C#
public string Author {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


CenterWindow Property

[image]
ActiveReports 13
CenterWindow Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : CenterWindow Property

Glossary Item Box

Specifies if the export should include the CenterWindow flag in the PDF document when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property CenterWindow As Boolean
C#
public bool CenterWindow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ConvertMetaToPng Property

[image]
ActiveReports 13
ConvertMetaToPng Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ConvertMetaToPng Property

Glossary Item Box

Specifies if the PDF Export should convert WMF/EMF images into PNG for the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property ConvertMetaToPng As Boolean
C#
public bool ConvertMetaToPng {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


DisplayMode Property

[image]
ActiveReports 13
DisplayMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : DisplayMode Property

Glossary Item Box

Specifies the PDF DisplayMode when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As DisplayMode
C#
public DisplayMode DisplayMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


DisplayTitle Property

[image]
ActiveReports 13
DisplayTitle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : DisplayTitle Property

Glossary Item Box

Specifies the PDF DisplayTitle when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property DisplayTitle As Boolean
C#
public bool DisplayTitle {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Encrypt Property

[image]
ActiveReports 13
Encrypt Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Encrypt Property

Glossary Item Box

Specifies if the export should encrypt the PDF when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property Encrypt As Boolean
C#
public bool Encrypt {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ExportBookmarks Property

[image]
ActiveReports 13
ExportBookmarks Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ExportBookmarks Property

Glossary Item Box

Specifies if the PDF Export should export bookmarks for the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property ExportBookmarks As Boolean
C#
public bool ExportBookmarks {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


FileName Property

[image]
ActiveReports 13
FileName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : FileName Property

Glossary Item Box

Gets or sets the name of an exported file in the Save file dialog.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName {get; set;}

Property Value

The name of the file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


FitWindow Property

[image]
ActiveReports 13
FitWindow Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : FitWindow Property

Glossary Item Box

Specifies if the export should use the FitWindow flag when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property FitWindow As Boolean
C#
public bool FitWindow {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


FontFallback Property

[image]
ActiveReports 13
FontFallback Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : FontFallback Property

Glossary Item Box

Gets or sets a comma-delimited string of font families that will be used to lookup glyphs that are missing in the original font (Professional Edition).

Syntax

Visual Basic (Declaration)
Public Property FontFallback As String
C#
public string FontFallback {get; set;}

Remarks

This feature is for use with the Professional Edition license only.

Note: The value of this property is ignored when used with the Standard Edition license. Some characters are not guaranteed to render correctly in the generated PDF.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


HideMenubar Property

[image]
ActiveReports 13
HideMenubar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : HideMenubar Property

Glossary Item Box

Specifies if the export should use the hideMenubar flag when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property HideMenubar As Boolean
C#
public bool HideMenubar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


HideToolbar Property

[image]
ActiveReports 13
HideToolbar Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : HideToolbar Property

Glossary Item Box

Specifies if the export should use the HideToolbar flag when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property HideToolbar As Boolean
C#
public bool HideToolbar {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


HideWindowUI Property

[image]
ActiveReports 13
HideWindowUI Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : HideWindowUI Property

Glossary Item Box

Specifies if the export should use the HideWindowUI flag when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property HideWindowUI As Boolean
C#
public bool HideWindowUI {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ImageQuality Property

[image]
ActiveReports 13
ImageQuality Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ImageQuality Property

Glossary Item Box

Specifies the ImageQuality the PDF Export should use for the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property ImageQuality As ImageQuality
C#
public ImageQuality ImageQuality {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ImageResolution Property

[image]
ActiveReports 13
ImageResolution Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ImageResolution Property

Glossary Item Box

Specifies the ImageResolution the PDF Export should use for the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property ImageResolution As Integer
C#
public int ImageResolution {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Keywords Property

[image]
ActiveReports 13
Keywords Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Keywords Property

Glossary Item Box

Specifies the Keywords the export will embed in the PDF when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property Keywords As String
C#
public string Keywords {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


NeverEmbedFonts Property

[image]
ActiveReports 13
NeverEmbedFonts Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : NeverEmbedFonts Property

Glossary Item Box

Specifies the fonts the PDF Export should not embed for the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property NeverEmbedFonts As String
C#
public string NeverEmbedFonts {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


OnlyForPrint Property

[image]
ActiveReports 13
OnlyForPrint Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : OnlyForPrint Property

Glossary Item Box

Gets or sets a value indicating whether the PDF is only for print.

Syntax

Visual Basic (Declaration)
Public Property OnlyForPrint As Boolean
C#
public bool OnlyForPrint {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


OwnerPassword Property

[image]
ActiveReports 13
OwnerPassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : OwnerPassword Property

Glossary Item Box

Specifies the PDF Owner's password when using the PDF Viewer type and the Encrypt property is set to true. If this value is left null or empty, the user is not granted full permissions to the pdf file security settings.

Syntax

Visual Basic (Declaration)
Public Property OwnerPassword As String
C#
public string OwnerPassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Permissions Property

[image]
ActiveReports 13
Permissions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Permissions Property

Glossary Item Box

Specifies the PDF permissions when using the PDF Viewer type and the Encrypt property is set to true.

Syntax

Visual Basic (Declaration)
Public Property Permissions As PdfPermissions
C#
public PdfPermissions Permissions {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


PrintPresets Property

[image]
ActiveReports 13
PrintPresets Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : PrintPresets Property

Glossary Item Box

Specifies the Print Presets the PDF Export should use for the PDF Viewer type

Syntax

Visual Basic (Declaration)
Public Property PrintPresets As PrintPresets
C#
public PrintPresets PrintPresets {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Subject Property

[image]
ActiveReports 13
Subject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Subject Property

Glossary Item Box

Specifies the Subject the export will use when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Title Property

[image]
ActiveReports 13
Title Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Title Property

Glossary Item Box

Specifies the Title the export will use when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Use128Bit Property

[image]
ActiveReports 13
Use128Bit Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Use128Bit Property

Glossary Item Box

Specifies if the export should use 128Bit encryption when using the PDF Viewer type and the Encrypt property is set to true.

Syntax

Visual Basic (Declaration)
Public Property Use128Bit As Boolean
C#
public bool Use128Bit {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


UserPassword Property

[image]
ActiveReports 13
UserPassword Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : UserPassword Property

Glossary Item Box

Specifies the PDF User's password when using the PDF Viewer type and the Encrypt property is set to true.

Syntax

Visual Basic (Declaration)
Public Property UserPassword As String
C#
public string UserPassword {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Version Property

[image]
ActiveReports 13
Version Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Version Property

Glossary Item Box

Specifies the PDF Version to use when using the PDF Viewer type.

Syntax

Visual Basic (Declaration)
Public Property Version As PdfVersion
C#
public PdfVersion Version {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


PrintPresets Class

[image]
ActiveReports 13
PrintPresets Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PrintPresets Class

Glossary Item Box

Specifies the print presets.

Object Model

PrintPresets Class

Syntax

Visual Basic (Declaration)
Public Class PrintPresets
C#
public class PrintPresets

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.PrintPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


PrintPresets Class Members

[image]
ActiveReports 13
PrintPresets Class Members
See Also Properties
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PrintPresets Class

Glossary Item Box

The following tables list the members exposed by PrintPresets.

Public Constructors

 | Name | Description
Public Constructor | PrintPresets Constructor | Initializes a new instance of the PrintPresets class.
Top

Public Properties

 | Name | Description
Public Property | DuplexMode | Gets or sets the duplex mode.
Public Property | NumberOfCopies | Gets or sets the number of copies.
Public Property | PageScaling | Gets or sets the page scaling.
Public Property | PaperSourceByPageSize | Gets or sets the paper source by page size flag.
Public Property | PrintPageRange | Gets or sets the print page range.
Top

See Also

Reference

PrintPresets Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


PrintPresets Constructor

[image]
ActiveReports 13
PrintPresets Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PrintPresets Class : PrintPresets Constructor

Glossary Item Box

Initializes a new instance of the PrintPresets class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PrintPresets()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PrintPresets Class Properties

[image]
ActiveReports 13
PrintPresets Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PrintPresets Class

Glossary Item Box

For a list of all members of this type, see PrintPresets members.

Public Properties

 | Name | Description
Public Property | DuplexMode | Gets or sets the duplex mode.
Public Property | NumberOfCopies | Gets or sets the number of copies.
Public Property | PageScaling | Gets or sets the page scaling.
Public Property | PaperSourceByPageSize | Gets or sets the paper source by page size flag.
Public Property | PrintPageRange | Gets or sets the print page range.
Top

See Also

Reference

PrintPresets Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


DuplexMode Property

[image]
ActiveReports 13
DuplexMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PrintPresets Class : DuplexMode Property

Glossary Item Box

Gets or sets the duplex mode.

Syntax

Visual Basic (Declaration)
Public Property DuplexMode As Enums.DuplexMode
C#
public Enums.DuplexMode DuplexMode {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


NumberOfCopies Property

[image]
ActiveReports 13
NumberOfCopies Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PrintPresets Class : NumberOfCopies Property

Glossary Item Box

Gets or sets the number of copies.

Syntax

Visual Basic (Declaration)
Public Property NumberOfCopies As Enums.NumberOfCopies
C#
public Enums.NumberOfCopies NumberOfCopies {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PageScaling Property

[image]
ActiveReports 13
PageScaling Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PrintPresets Class : PageScaling Property

Glossary Item Box

Gets or sets the page scaling.

Syntax

Visual Basic (Declaration)
Public Property PageScaling As Enums.PageScaling
C#
public Enums.PageScaling PageScaling {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PaperSourceByPageSize Property

[image]
ActiveReports 13
PaperSourceByPageSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PrintPresets Class : PaperSourceByPageSize Property

Glossary Item Box

Gets or sets the paper source by page size flag.

Syntax

Visual Basic (Declaration)
Public Property PaperSourceByPageSize As Boolean
C#
public bool PaperSourceByPageSize {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


PrintPageRange Property

[image]
ActiveReports 13
PrintPageRange Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PrintPresets Class : PrintPageRange Property

Glossary Item Box

Gets or sets the print page range.

Syntax

Visual Basic (Declaration)
Public Property PrintPageRange As String
C#
public string PrintPageRange {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintPresets Class
PrintPresets Members


GrapeCity.ActiveReports.Web.Handlers Namespace

GrapeCity.ActiveReports.Web.Handlers Namespace
See Also Inheritance Hierarchy
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web.Handlers Namespace

Glossary Item Box

The GrapeCity.ActiveReports.Web.Handlers namespace contains the classes which handle the report types for web consumption.

Classes

 | Class | Description
Class | ArHandlerBase | This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code. This is a base class that contains some methods used between the report processing HttpHandlers for ActiveReports.
Class | CompiledReportHandler | By default the handler is registered with the *.ActiveReport file extension to pick up any request for an ActiveReport that has been compiled into a CLR/.NET assembly. The handler loads the ActiveReport from the specified assembly, runs and exports it to a specified format, defaulting to HTML.
Class | RdlxHandler | Should be registered with the *.rdlx file extension to pick up any request for an rdlx file and process it. The handler loads the rdlx file into ActiveReport, runs and exports it to a specified format, defaulting to HTML.
Class | ReportBinariesStreamer | Responsible for intercepting requests for "*.arXX".
Class | RpxHandler | Should be registered with the *.rpx file extension to pick up and process any request for an rpx file. The handler loads the rpx file into ActiveReports, runs and exports it to a specified format, defaulting to HTML.
Class | WebCacheAccessHandler | This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code.

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


ArHandlerBase Class

[image]
ActiveReports 13
ArHandlerBase Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class

Glossary Item Box

This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code. This is a base class that contains some methods used between the report processing HttpHandlers for ActiveReports.

Object Model

ArHandlerBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ArHandlerBase
C#
public abstract class ArHandlerBase

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler
GrapeCity.ActiveReports.Web.Handlers.RdlxHandler
GrapeCity.ActiveReports.Web.Handlers.RpxHandler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ArHandlerBase Members
GrapeCity.ActiveReports.Web.Handlers Namespace


ArHandlerBase Class Members

[image]
ActiveReports 13
ArHandlerBase Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class

Glossary Item Box

The following tables list the members exposed by ArHandlerBase.

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

ArHandlerBase Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ArHandlerBase Class Methods

[image]
ActiveReports 13
ArHandlerBase Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class

Glossary Item Box

For a list of all members of this type, see ArHandlerBase members.

Public Methods

 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

ArHandlerBase Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method

[image]
ActiveReports 13
ProcessRequest Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ArHandlerBase Class : ProcessRequest Method

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Glossary Item Box

This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub ProcessRequest( _
   ByVal context As HttpContext _
)
C#
public abstract void ProcessRequest(
   HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ArHandlerBase Class
ArHandlerBase Members


ArHandlerBase Class Properties

[image]
ActiveReports 13
ArHandlerBase Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class

Glossary Item Box

For a list of all members of this type, see ArHandlerBase members.

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top

See Also

Reference

ArHandlerBase Class
GrapeCity.ActiveReports.Web.Handlers Namespace


IsReusable Property

[image]
ActiveReports 13
IsReusable Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ArHandlerBase Class : IsReusable Property

Glossary Item Box

Returns a value indicating whether the class can be pooled.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
C#
public bool IsReusable {get;}

Property Value

True if the class can be pooled. The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ArHandlerBase Class
ArHandlerBase Members


CompiledReportHandler Class

[image]
ActiveReports 13
CompiledReportHandler Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class

Glossary Item Box

By default the handler is registered with the *.ActiveReport file extension to pick up any request for an ActiveReport that has been compiled into a CLR/.NET assembly. The handler loads the ActiveReport from the specified assembly, runs and exports it to a specified format, defaulting to HTML.

Object Model

CompiledReportHandler Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CompiledReportHandler
   Inherits ArHandlerBase
C#
public sealed class CompiledReportHandler : ArHandlerBase

Remarks

Uses reflection to load the assembly and the specified report class; executes, and exports the report.

Assembly is to be specified as the first folder, and report class name as the subfolder. For example: http://localhost/MyAssemblyName/ActiveReport1.ActiveReport where MyAssemblyName.dll is the actual assembly filename, and ActiveReport1 the report class name. The special folder name indicating the assembly is evaluated from right to left, so if there are multiple folder levels, the folder name directly preceding the file name is always the assembly name.

For example, this would allow the following URL to be used: http://localhost/AnyFolder/AnySubFolder/MyAssemblyName/ActiveReport1.ActiveReport

You may also set any parameters you've added to the report's Parameters collection via the DataSource icon in the URL. For example:

http://localhost/AnyFolder/AnySubFolder/MyAssemblyName/ActiveReport1.ActiveReport?Country=USA

To use this handler you must enter the following into your web.config file (making sure to use the correct Version):

<httpHandlers>
<add verb="*" path="*.ActiveReport" type="GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler, GrapeCity.ActiveReports.Web.v10" />
</httpHandlers>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledReportHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


CompiledReportHandler Class Members

[image]
ActiveReports 13
CompiledReportHandler Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class

Glossary Item Box

The following tables list the members exposed by CompiledReportHandler.

Public Constructors

 | Name | Description
Public Constructor | CompiledReportHandler Constructor | Initializes a new instance of the CompiledReportHandler class.
Top

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

CompiledReportHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


CompiledReportHandler Constructor

[image]
ActiveReports 13
CompiledReportHandler Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > CompiledReportHandler Class : CompiledReportHandler Constructor

Glossary Item Box

Initializes a new instance of the CompiledReportHandler class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public CompiledReportHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledReportHandler Class
CompiledReportHandler Members


CompiledReportHandler Class Methods

[image]
ActiveReports 13
CompiledReportHandler Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class

Glossary Item Box

For a list of all members of this type, see CompiledReportHandler members.

Public Methods

 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

CompiledReportHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method

[image]
ActiveReports 13
ProcessRequest Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > CompiledReportHandler Class : ProcessRequest Method

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Glossary Item Box

This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub ProcessRequest( _
   ByVal context As HttpContext _
)
C#
public override void ProcessRequest(
   HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompiledReportHandler Class
CompiledReportHandler Members


RdlxHandler Class

[image]
ActiveReports 13
RdlxHandler Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class

Glossary Item Box

Should be registered with the *.rdlx file extension to pick up any request for an rdlx file and process it. The handler loads the rdlx file into ActiveReport, runs and exports it to a specified format, defaulting to HTML.

Object Model

RdlxHandler Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RdlxHandler
   Inherits ArHandlerBase
C#
public sealed class RdlxHandler : ArHandlerBase

Remarks

To use this handler you must enter the following into your web.config file:
<httpHandlers>
<add verb="*" path="*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v12" />
</httpHandlers>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.RdlxHandler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


RdlxHandler Class Members

[image]
ActiveReports 13
RdlxHandler Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class

Glossary Item Box

The following tables list the members exposed by RdlxHandler.

Public Constructors

 | Name | Description
Public Constructor | RdlxHandler Constructor | Initializes an instance of the RdlxHandler class.
Top

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

RdlxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RdlxHandler Constructor

[image]
ActiveReports 13
RdlxHandler Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RdlxHandler Class : RdlxHandler Constructor

Glossary Item Box

Initializes an instance of the RdlxHandler class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RdlxHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxHandler Class
RdlxHandler Members


RdlxHandler Class Methods

[image]
ActiveReports 13
RdlxHandler Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class

Glossary Item Box

For a list of all members of this type, see RdlxHandler members.

Public Methods

 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

RdlxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method

[image]
ActiveReports 13
ProcessRequest Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RdlxHandler Class : ProcessRequest Method

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Glossary Item Box

This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub ProcessRequest( _
   ByVal context As HttpContext _
)
C#
public override void ProcessRequest(
   HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RdlxHandler Class
RdlxHandler Members


ReportBinariesStreamer Class

[image]
ActiveReports 13
ReportBinariesStreamer Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class

Glossary Item Box

Responsible for intercepting requests for "*.arXX".

Object Model

ReportBinariesStreamer Class

Syntax

Visual Basic (Declaration)
Public Class ReportBinariesStreamer
C#
public class ReportBinariesStreamer

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportBinariesStreamer Members
GrapeCity.ActiveReports.Web.Handlers Namespace


ReportBinariesStreamer Class Members

[image]
ActiveReports 13
ReportBinariesStreamer Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class

Glossary Item Box

The following tables list the members exposed by ReportBinariesStreamer.

Public Constructors

 | Name | Description
Public Constructor | ReportBinariesStreamer Constructor | Initializes a new instance of the ReportBinariesStreamer class.
Top

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

ReportBinariesStreamer Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ReportBinariesStreamer Constructor

[image]
ActiveReports 13
ReportBinariesStreamer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ReportBinariesStreamer Class : ReportBinariesStreamer Constructor

Glossary Item Box

Initializes a new instance of the ReportBinariesStreamer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ReportBinariesStreamer()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportBinariesStreamer Class
ReportBinariesStreamer Members


ReportBinariesStreamer Class Methods

[image]
ActiveReports 13
ReportBinariesStreamer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class

Glossary Item Box

For a list of all members of this type, see ReportBinariesStreamer members.

Public Methods

 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

ReportBinariesStreamer Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method

[image]
ActiveReports 13
ProcessRequest Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ReportBinariesStreamer Class : ProcessRequest Method

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Glossary Item Box

This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal context As HttpContext _
)
C#
public void ProcessRequest(
   HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportBinariesStreamer Class
ReportBinariesStreamer Members


ReportBinariesStreamer Class Properties

[image]
ActiveReports 13
ReportBinariesStreamer Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class

Glossary Item Box

For a list of all members of this type, see ReportBinariesStreamer members.

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top

See Also

Reference

ReportBinariesStreamer Class
GrapeCity.ActiveReports.Web.Handlers Namespace


IsReusable Property

[image]
ActiveReports 13
IsReusable Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ReportBinariesStreamer Class : IsReusable Property

Glossary Item Box

Returns a value indicating whether the class can be pooled.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
C#
public bool IsReusable {get;}

Property Value

True if the class can be pooled. The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportBinariesStreamer Class
ReportBinariesStreamer Members


RpxHandler Class

[image]
ActiveReports 13
RpxHandler Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class

Glossary Item Box

Should be registered with the *.rpx file extension to pick up and process any request for an rpx file. The handler loads the rpx file into ActiveReports, runs and exports it to a specified format, defaulting to HTML.

Object Model

RpxHandler Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RpxHandler
   Inherits ArHandlerBase
C#
public sealed class RpxHandler : ArHandlerBase

Remarks

To use this handler you must enter the following into your web.config file (making sure that the Version is correct):

<httpHandlers>
<add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, ActiveReports.Web, Version=5.0.0.105, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
</httpHandlers>

You may also set any parameters you've added to the report's Parameters collection via the DataSource icon in the URL. For example:

http://localhost/AnyFolder/AnySubFolder/MyAssemblyName/ActiveReport1.rpx?Country=USA

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.RpxHandler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


RpxHandler Class Members

[image]
ActiveReports 13
RpxHandler Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class

Glossary Item Box

The following tables list the members exposed by RpxHandler.

Public Constructors

 | Name | Description
Public Constructor | RpxHandler Constructor | Initializes a new instance of the RpxHandler class.
Top

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

RpxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RpxHandler Constructor

[image]
ActiveReports 13
RpxHandler Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RpxHandler Class : RpxHandler Constructor

Glossary Item Box

Initializes a new instance of the RpxHandler class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public RpxHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxHandler Class
RpxHandler Members


RpxHandler Class Methods

[image]
ActiveReports 13
RpxHandler Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class

Glossary Item Box

For a list of all members of this type, see RpxHandler members.

Public Methods

 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top

See Also

Reference

RpxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method

[image]
ActiveReports 13
ProcessRequest Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RpxHandler Class : ProcessRequest Method

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Glossary Item Box

This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub ProcessRequest( _
   ByVal context As HttpContext _
)
C#
public override void ProcessRequest(
   HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpxHandler Class
RpxHandler Members


WebCacheAccessHandler Class

[image]
ActiveReports 13
WebCacheAccessHandler Class
Members See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class

Glossary Item Box

This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code.

Object Model

WebCacheAccessHandler Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebCacheAccessHandler
C#
public sealed class WebCacheAccessHandler

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCacheAccessHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


WebCacheAccessHandler Class Members

[image]
ActiveReports 13
WebCacheAccessHandler Class Members
See Also Properties Methods
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class

Glossary Item Box

The following tables list the members exposed by WebCacheAccessHandler.

Public Constructors

 | Name | Description
Public Constructor | WebCacheAccessHandler Constructor | Initializes a new instance of the WebCacheAccessHandler class.
Top

Public Properties

 | Name | Description
Public Property | IsReusable | An implementation of IHttpHandler.IsReusable.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GenCacheKey | Generates a WebCache key for the items being cached.
Public Method | ProcessRequest | An implementation of IHttpHandler.ProcessRequest.
Top

See Also

Reference

WebCacheAccessHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


WebCacheAccessHandler Constructor

[image]
ActiveReports 13
WebCacheAccessHandler Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : WebCacheAccessHandler Constructor

Glossary Item Box

Initializes a new instance of the WebCacheAccessHandler class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WebCacheAccessHandler()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


WebCacheAccessHandler Class Methods

[image]
ActiveReports 13
WebCacheAccessHandler Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class

Glossary Item Box

For a list of all members of this type, see WebCacheAccessHandler members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GenCacheKey | Generates a WebCache key for the items being cached.
Public Method | ProcessRequest | An implementation of IHttpHandler.ProcessRequest.
Top

See Also

Reference

WebCacheAccessHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


GenCacheKey Method

[image]
ActiveReports 13
GenCacheKey Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : GenCacheKey Method

Glossary Item Box

Generates a WebCache key for the items being cached.

Syntax

Visual Basic (Declaration)
Public Shared Function GenCacheKey() As String
C#
public static string GenCacheKey()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


ProcessRequest Method

[image]
ActiveReports 13
ProcessRequest Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : ProcessRequest Method

context
An HttpContext object that provides references to the intrinsic server objects

Glossary Item Box

An implementation of IHttpHandler.ProcessRequest.

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal context As HttpContext _
)
C#
public void ProcessRequest(
   HttpContext context
)

Parameters

context
An HttpContext object that provides references to the intrinsic server objects

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


WebCacheAccessHandler Class Properties

[image]
ActiveReports 13
WebCacheAccessHandler Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class

Glossary Item Box

For a list of all members of this type, see WebCacheAccessHandler members.

Public Properties

 | Name | Description
Public Property | IsReusable | An implementation of IHttpHandler.IsReusable.
Top

See Also

Reference

WebCacheAccessHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


IsReusable Property

[image]
ActiveReports 13
IsReusable Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : IsReusable Property

Glossary Item Box

An implementation of IHttpHandler.IsReusable.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
C#
public bool IsReusable {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


Add TableOfContents

Add TableOfContents

Glossary Item Box

The Table of Contents control allows you to display the document map, an organized hierarchy of the report bookmark labels and heading levels along with their page numbers, in the body of a report.

To add items to the Document Map using HeadingLevel Property

You can define an hierarchical structure for your report using the HeadingLevel property of the TextBox control. For example, you can set the HeadingLevel property of the TextBox displaying the report title to Heading1 and then set the HeadingLevel property of the TextBox displaying a group header to Heading2, this will club all the Heading2 entries under the Heading1 entry in the Document Map.

These steps assume that you have already set the HeadingLevel property of the TextBox controls that your report contains. See, Add Items to the Document Map for more information.

  1. In the Report Explorer, right-click the Report item and select Report Properties...
  2. In the Report Properties dialog that appears, go to the Document Map page.
  3. On the Document Map page, set Source to Headings Only and optionally select the Numbering Style from the dropdown list.
    Tip: You can also set Source to Labels and Headings to include both labels and headings in the Document Map.
  4. Click OK to close the dialog.

To add items to the Document Map using Label Property or Document Map Labels

By setting the Label property or Document Map Label of the controls in your page report/RDL report, you can show a hierarchical structure based on the parent - child relationship between the controls in the Document Map. For example, set the Label property or Document Map Label of a List data region and a TextBox control and then place the TextBox control inside the List data region. When you view the Document Map, the TextBox label appears nested inside the List data region label, thereby displaying a hierarchical structure. Similarly, if you set a Document map label on multiple Groups of a data region, they appear nested below each other in the document map displaying the same hierarchy in which they were set.

These steps assume that you have already set the Label property or Document Map Label of the controls that your report contains. See, Add Items to the Document Map for more information.

  1. In the Report Explorer, right-click the control and select Report Properties...
  2. In the Report Properties dialog that appears, go to the Document Map page.
  3. In the Document Map page, set Source to Labels Only and optionally select the Numbering Style from the dropdown list.
    Tip: You can also set Source to Labels and Headings to include both labels and headings in the Document Map.
  4. Click OK to close the dialog.

To add items to the Document Map

  1. On the design surface, select a control you want to add to the Document map.
  2. In the command section of the Properties Window, click the Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  3. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.
  4. Click OK to close the dialog.

To add and configure TableOfContents

Follow these steps to setup the TableOfContents control in the report layout displaying the document map set in the procedures above.

To add a TableOfContents control in Page Report

  1. In the Report designer, click the New tab to add a new page to the report layout.
  2. From the toolbox, drag and drop the TableOfContents control onto Page 1 while use Page 2 to create layout for displaying the main content of the report. Using the same page that contains the TableOfContents may disrupt the flow of data displayed in the report.
  3. On the design surface, select the TableOfContents control and go to the Properties window to set its FixedHeight property. The use of the FixedHeight property is similar to the use of the FixedSize property that is available with other report controls.
    Note: You can also place the Overflow Place Holder control and link it with the TableOfContents control using its OverflowName property to display data that does not fit inside the fixed size of the TableOfContents control.
  4. With the TableOfContents control selected, click the Levels (Collection) property and then click the ellipsis button that appears.
  5. In the LevelDesigner Collection Editor that appears, consider the hierarchy of entries that appear in the Document Map and add as many levels required using the Add button. This allows you to customize entries at different nested levels. Using just a single Level will list down all the TableOfContents entries at the same level. You can also set various numbering styles for all levels or an individual level by setting the Numbering Style for document map levels using the Report dialog or using the DocumentMap property that gets directly applied to the TableOfContents control. For more information see Add Items to the Document Map.
  6. Select each level and set its related properties available in the LevelDesigner Collection Editor. These properties could be general properties like DisplayPageNumber or DisplayFillCharacter, or they could be related to the level's appearance like BackgroundColor, Font, Padding etc. These properties directly affect all the entries that appear in the selected level, thereby allowing you to customize them. For information on the important properties of the TableOfContents control, see Table of Contents.
  7. Click OK to close the dialog and return to the design surface.
  8. Go to the Preview Tab to view the Table of Contents appear in the report output.
  9. Click any TableOfContents entry and navigate to the targeted report control in the report.

To add a TableOfContents control in Report Definition Language (RDL)

  1. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.

To configure TableOfContents Appearance

  1. With the TableOfContents control selected, click the Levels (Collection) property and then click the ellipsis button that appears.
  2. In the LevelDesigner Collection Editor that appears, consider the hierarchy of entries that appear in the Document Map and add as many levels required using the Add button. This allows you to customize entries at different nested levels. Using just a single Level will list down all the TableOfContents entries at the same level.
  3. Select each level and set its related properties available in the LevelDesigner Collection Editor. These properties could be general properties like DisplayPageNumber or DisplayFillCharacter, or they could be related to the level's appearance like BackgroundColor, Font, Padding etc. These properties directly affect all the entries that appear in the selected level, thereby allowing you to customize them. For information on the important properties of the TableOfContents control, see Table of Contents.
    Note: You can also set various numbering styles for all levels or individual level by setting the Numbering Style for document map levels using the Report dialog or using the DocumentMap property that gets directly applied to the TableOfContents control. For more information see Add Items to the Document Map.
  4. Click OK to close the dialog and return to the design surface.
  5. Go to the Preview Tab to view the Table of Contents appear in the report output.
  6. Click any TableOfContents entry and navigate to that targeted report control in the report.

To apply styles to the TableOfContents control

In the TableOfContents control, styles can be applied using the StyleName property.

  1. Create a new style sheet and add styles that you want to apply to the TableOfContents control. For more information on creating style sheets and style types, see Working with Styles and Style Elements.
  2. Apply the style sheet to the report. For details on how to apply style sheets to reports at design time, see Working with Styles.
  3. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  4. On the design surface, select the TableOfContents control.
  5. In the Properties Window, from the StyleName property drop-down, select a style to apply to the TableOfContents control.

To apply styles to the TableOfContents levels

In the TableOfContents control, styles can be applied to each TableOfContents level using the StyleName property available in the LevelDesigner Collection Editor dialog.

  1. Create a new style sheet and add styles that you want to apply for the TableOfContents level. For more information on creating style sheets and and the type of styles available for TableOfContents level, see Working with Styles and Style Elements.
  2. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  3. With the TableOfContents control selected, click the Levels (Collection) property from the Properties window and then click the ellipsis button that appears.
  4. In the LevelDesigner Collection Edior dialog that appears, select a TableOfContents level on which to want to apply the style.
  5. From the list of properties on the right, drop-down the StyleName property to select a style to apply.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Glossary

Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

D

data region
Data regions are report controls (Table, List, Banded List, Tablix and Chart) in page reports that can contain other report controls.

design surface
Part of the report design view that lets you create or edit report layouts using controls or data regions in Visual Studio or Stand-Alone Designer Application.

Design View

designer buttons
Buttons located at the bottom of the report designer tabs adjacent to the designer surface.

Designer tab
Default tab that is used to create layouts, connect to a data source or implement other design time features.

designer tabs
Designer, Script and Preview tabs located at the bottom of the report designer surface.

detail

The only required section in a section-based report. This section repeats once for every row of data in the report.

document map
A table of contents for the report in the viewer. When a user clicks an item in the document map, the viewer jumps to that item in the report.

E

ESRI shapefile
An ESRI Shapefile is a collection of files, where a .shp file defines the geographical or geometrical shapes and the .dbf file provides attributes for the shapes in the .shp file. To successfully add spatial data using this option, both files (.shp and .dbf) must be copied to the same folder. ESRI files are available on public domain data sources on the Web, including government and university sites. For more information, go to www.census.gov/geo/maps-data/data/tiger.html.

F

field selection adorner
An icon that appears when you hover over a textbox. It is used to quickly bind the textbox to a field from the DataSet. Selecting a field through this adorner adds a field expression similar to the one that is added when you drag a field into a control from the ReportExplorer.

fixed page
Refers to a page in the Page report represented by the Page node in the Report Explorer.

FixedPage dialog
Dialog that contains the properties to be set for the fixed page in a Page report. You can access this dialog when you right-click on the gray area of the report designer and select Fixed Layout Settings... from the context menu. Alternatively, with the Page selected on the report, right-click and open the Properties window to select the Property dialog... link at the bottom.

FixedSize
FixedSize property expands the area of a data region upto a set size in case of excessive data. You can use the Properties Window to enter the property value manually, or you can also set the FixedSize by dragging the grey adorners that appears at the bottom and on the right side of a data region.

G

Group Editor
Group Editor window is specifically designed to manage the tablix structure. It consists of a Row Groups pane and a Column Groups pane. The Group Editor window displays the row and column groups for the currently selected Tablix data region on the design surface.

group footer
Section inserted below the detail section in a section report, where grouping is set.

group header
Section inserted above the detail section in a section report, where grouping is set.

L

Layers
Layers are a named group of controls.

layers pane
The area labeled "Right click to add the new layer." that appears at the bottom of the Map data region. It display the list of layers that are defined for the map. Use this pane to add, delete or edit a layer.

P

page footer
Section that appears at the bottom of each page of a section report. You can also add a page footer to a page report if you convert it to RDL.

page header
Section that appears at the top of each page of a section report. You can also add a page header to a page report if you convert it to RDL.

page layout
Report layout type where designing is done on a page to provide a dynamic layout environment.

Page report
Report type where designing is done on a page to provide a dynamic layout environmennt. This type allows you to create forms and other layouts that do not allow report controls to change sizes based on the data.

polygon center points
Markers that gets displayed at the center of each polygon

preview
Tab to view the report without actually running the application containing the report.

Preview tab
Tab to view the report without actually running the application containing the report.

Professional Edition
This is a license for ActiveReports that includes all of the features of the Standard Edition, plus the WebViewer control, HTTP Handlers, the Designer control, the ReportExplorer control, the Toolbox control, and advanced PDF and Font features.

properties window

R

RDL

Report Definition Language (RDL) is a report type that allows report controls to increase in size to accommodate your data.

RDL report
Report Definition Layout (RDL) is a report type that allows report controls to increase in size to accommodate your data.

RDLX
Report Definition Language Extended file. This is a layout file for page reports and RDL reports.

RDLX-master
Report Definition Language Extended Master file. This is a layout file for RDL reports that allows you to specify standard elements to apply to all content reports that use it.

report layout
Layouts available in ActiveReports for designing reports. The two layout types are, Section Layout and Page Layout.

RPX
Report XML file. This is a layout file for section-based reports. It can contain VB.NET or C# script, but does not contain code that may have been added behind the report.

S

Scope
A parameter for functions, which the grouping, data region, or dataset to be considered when calculating the aggregate or other function.

Script tab
Tab used to add VB.NET or C# functionality through script.

section layout
Report layout type where designing is done in banded sections. There is always a detail section present, while header and footer sections (report, page, or group) can be added or removed as you require.

Section Report
Report type where designing is done in banded sections. There is always a detail section present, while header and footer sections(report, page, or group) can be added or removed as you require.

snap to grid
Feature to move controls and data regions from one grid line to another on the report design surface.

Stand-alone Designer Application
Refers to GrapeCity.ActiveReports.Designer.exe bundled with ActiveReports. This application provides major features of the Designer to create or save reports and works on systems which do not have Visual Studio installed.

Standard Edition
This is a license for ActiveReports that includes the Windows Forms Viewer control, all of the exports, and the Visual Studio report designer.

T

table details
Middle row of the Table data region, that functions as the detail row for the table. When you drag a field into a cell in the table detail row, a label is added automatically in the table header row.

Tablix
A Tablix data region provides enhanced layout capabilities ranging from creation of simple tables to complex grid layouts in Page and RDL reports.

V

View Pane

View Pane display the view center keys and zoom level slider for the map viewport. Use the arrow keys to adjust the view center and the slider to adjust the zoom level.

Viewer
A stand-alone application where you can preview your report.

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.


Assembly Overview

GrapeCity.ActiveReports Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports | The GrapeCity.ActiveReports namespace contains the report, control, and section classes that are the basis of all reports.
GrapeCity.ActiveReports.Configuration | The GrapeCity.ActiveReports.Configuration namespace consists of classes that configure the report.
GrapeCity.ActiveReports.Data | The GrapeCity.ActiveReports.Data namespace contains the classes used for section report data binding in section reports.
GrapeCity.ActiveReports.Document | The Grape.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.
GrapeCity.ActiveReports.Export | The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.
GrapeCity.ActiveReports.Extensibility.Data |
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel |
GrapeCity.ActiveReports.Extensibility.Rendering |
GrapeCity.ActiveReports.General |
GrapeCity.ActiveReports.Rendering |
GrapeCity.ActiveReports.ReportsCore |
GrapeCity.ActiveReports.ReportsCore.Configuration |
GrapeCity.ActiveReports.ReportsCore.Data |
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders |
GrapeCity.ActiveReports.ReportsCore.Tools |
GrapeCity.ActiveReports.SectionReportModel | The GrapeCity.ActiveReports.SectionReportModel namespace includes classes that can be used in section reports.
GrapeCity.BI.Data.DataProviders | The GrapeCity.BI.Data.DataProviders namespace contains the DataProviderInfo class.


Assembly Overview

GrapeCity.ActiveReports.Aspnet.Designer Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnet.Designer |
GrapeCity.ActiveReports.Aspnet.Designer.Services |
GrapeCity.ActiveReports.Aspnet.Designer.Utilities |


Getting Started - ActiveReports 13

Getting Started
Product Support Forum | Print this page

Glossary Item Box


Introduction - ActiveReports 13

Introduction
Product Support Forum | Print this page

Glossary Item Box


ImageNotFoundException Class Methods

[image]
ActiveReports 13
ImageNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ImageNotFoundException Class Properties

[image]
ActiveReports 13
ImageNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ImageNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InvalidReportContentException Class Methods

[image]
ActiveReports 13
InvalidReportContentException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


InvalidReportContentException Class Properties

[image]
ActiveReports 13
InvalidReportContentException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidReportContentException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class Methods

[image]
ActiveReports 13
InvalidThemeContentException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


InvalidThemeContentException Class Properties

[image]
ActiveReports 13
InvalidThemeContentException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > InvalidThemeContentException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ReportNotFoundException Class Methods

[image]
ActiveReports 13
ReportNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ReportNotFoundException Class Properties

[image]
ActiveReports 13
ReportNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ReportNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.Services Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.Services.Theme
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeColors
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeConstant
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeFont
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeFonts
GrapeCity.ActiveReports.Aspnet.Designer.Services.ThemeImage

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Designer Assembly


ThemeNotFoundException Class Methods

[image]
ActiveReports 13
ThemeNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


ThemeNotFoundException Class Properties

[image]
ActiveReports 13
ThemeNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Aspnet.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly > GrapeCity.ActiveReports.Aspnet.Designer Namespace > ThemeNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer.Utilities Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Designer Assembly


GrapeCity.ActiveReports.Aspnet.Designer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Designer Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Designer Assembly : GrapeCity.ActiveReports.Aspnet.Designer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Designer.DesignerSettings
GrapeCity.ActiveReports.Aspnet.Designer.WebHostBuilderExtensions
System.Exception
GrapeCity.ActiveReports.Aspnet.Designer.ImageNotFoundException
GrapeCity.ActiveReports.Aspnet.Designer.InvalidReportContentException
GrapeCity.ActiveReports.Aspnet.Designer.InvalidThemeContentException
GrapeCity.ActiveReports.Aspnet.Designer.ReportNotFoundException
GrapeCity.ActiveReports.Aspnet.Designer.ThemeNotFoundException

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Designer Assembly


Assembly Overview

GrapeCity.ActiveReports.Aspnet.Viewer Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnet.Viewer |
GrapeCity.ActiveReports.Aspnetcore.Viewer |
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services |


GrapeCity.ActiveReports.Aspnet.Viewer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnet.Viewer Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnet.Viewer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnet.Viewer.WebHostBuilderExtensions

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Viewer Assembly


ReportNotFoundException Class Methods

[image]
ActiveReports 13
ReportNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportNotFoundException Class Properties

[image]
ActiveReports 13
ReportNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnet.Viewer) Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnet.Viewer) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services.RenderSettings

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Viewer Assembly


GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnet.Viewer) Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnet.Viewer) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnet.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportingSettings
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportNotFoundException

See Also

Reference

GrapeCity.ActiveReports.Aspnet.Viewer Assembly


Assembly Overview

GrapeCity.ActiveReports.Aspnetcore.Designer Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnetcore.Designer |
GrapeCity.ActiveReports.Aspnetcore.Designer.Services |
GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities |


ImageNotFoundException Class Methods

[image]
ActiveReports 13
ImageNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ImageNotFoundException Class Properties

[image]
ActiveReports 13
ImageNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ImageNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ImageNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ImageNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageNotFoundException Class
ImageNotFoundException Members


InvalidReportContentException Class Methods

[image]
ActiveReports 13
InvalidReportContentException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


InvalidReportContentException Class Properties

[image]
ActiveReports 13
InvalidReportContentException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidReportContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidReportContentException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidReportContentException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidReportContentException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidReportContentException Class
InvalidReportContentException Members


InvalidThemeContentException Class Methods

[image]
ActiveReports 13
InvalidThemeContentException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


InvalidThemeContentException Class Properties

[image]
ActiveReports 13
InvalidThemeContentException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : InvalidThemeContentException Class

Glossary Item Box

For a list of all members of this type, see InvalidThemeContentException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidThemeContentException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > InvalidThemeContentException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidThemeContentException Class
InvalidThemeContentException Members


ReportNotFoundException Class Methods

[image]
ActiveReports 13
ReportNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ReportNotFoundException Class Properties

[image]
ActiveReports 13
ReportNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ReportNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.Services Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.Theme
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeColors
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeConstant
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeFont
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeFonts
GrapeCity.ActiveReports.Aspnetcore.Designer.Services.ThemeImage

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Designer Assembly


ThemeNotFoundException Class Methods

[image]
ActiveReports 13
ThemeNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


ThemeNotFoundException Class Properties

[image]
ActiveReports 13
ThemeNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace : ThemeNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ThemeNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThemeNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Designer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly > GrapeCity.ActiveReports.Aspnetcore.Designer Namespace > ThemeNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeNotFoundException Class
ThemeNotFoundException Members


GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer.Utilities Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Designer Assembly


GrapeCity.ActiveReports.Aspnetcore.Designer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Designer Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Designer Assembly : GrapeCity.ActiveReports.Aspnetcore.Designer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Designer.DesignerSettings
GrapeCity.ActiveReports.Aspnetcore.Designer.WebHostBuilderExtensions
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Designer.ImageNotFoundException
GrapeCity.ActiveReports.Aspnetcore.Designer.InvalidReportContentException
GrapeCity.ActiveReports.Aspnetcore.Designer.InvalidThemeContentException
GrapeCity.ActiveReports.Aspnetcore.Designer.ReportNotFoundException
GrapeCity.ActiveReports.Aspnetcore.Designer.ThemeNotFoundException

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Designer Assembly


Assembly Overview

GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Aspnetcore.Viewer |
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services |


ReportNotFoundException Class Methods

[image]
ActiveReports 13
ReportNotFoundException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


ReportNotFoundException Class Properties

[image]
ActiveReports 13
ReportNotFoundException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace : ReportNotFoundException Class

Glossary Item Box

For a list of all members of this type, see ReportNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportNotFoundException Class
GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly > GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace > ReportNotFoundException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportNotFoundException Class
ReportNotFoundException Members


GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer) Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer.Services Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.Services.RenderSettings

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly


GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer) Inheritance Hierarchy

GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace (GrapeCity.ActiveReports.Aspnetcore.Viewer) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly : GrapeCity.ActiveReports.Aspnetcore.Viewer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportingSettings
GrapeCity.ActiveReports.Aspnetcore.Viewer.WebHostBuilderExtensions
System.Exception
GrapeCity.ActiveReports.Aspnetcore.Viewer.ReportNotFoundException

See Also

Reference

GrapeCity.ActiveReports.Aspnetcore.Viewer Assembly


Assembly Overview

GrapeCity.ActiveReports.Design.Win Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Dashboard.Design |
GrapeCity.ActiveReports.Design | The GrapeCity.ActiveReports.Design namespace contains the designer classes and designer controls.
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart |
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.Component |
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.UI |
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers | The GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers namespace includes DataVisualizerBasePanel class which is the base class of the data visualizer panel.
GrapeCity.ActiveReports.Design.ReportExplorer | The GrapeCity.ActiveReports.Design.ReportExplorer namespace includes the ReportExplorer class which is the base class for the ReportExplorer control.
GrapeCity.ActiveReports.Design.ReportsLibrary | The GrapeCity.ActiveReports.Design.ReportsLibrary namespace includes the ReportsLibrary class which is the base class for ReportsLibrary control, and ReportsLibraryArsExtension class that extends the ReportsLibrary class.
GrapeCity.ActiveReports.Design.Toolbox | The GrapeCity.ActiveReports.Design.Toolbox namespace contains classes for adding controls to the designer toolbox.


ReportItemDesignerBase Class Events

[image]
ActiveReports 13
ReportItemDesignerBase Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace : ReportItemDesignerBase Class

Glossary Item Box

For a list of all members of this type, see ReportItemDesignerBase members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportItemDesignerBase Class
GrapeCity.ActiveReports.Dashboard.Design Namespace


ReportItemDesignerBase Class Properties

[image]
ActiveReports 13
ReportItemDesignerBase Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace : ReportItemDesignerBase Class

Glossary Item Box

For a list of all members of this type, see ReportItemDesignerBase members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportItemDesignerBase Class
GrapeCity.ActiveReports.Dashboard.Design Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowDrop As Boolean
C#
public virtual bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
C#
public virtual AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScrollOffset As Point
C#
public virtual Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImageLayout As ImageLayout
C#
public virtual ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BindingContext As BindingContext
C#
public virtual BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenu As ContextMenu
C#
public virtual ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenuStrip As ContextMenuStrip
C#
public virtual ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As Cursor
C#
public virtual Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the display area of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As Rectangle
C#
public virtual Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Dock As DockStyle
C#
public virtual DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Focused As Boolean
C#
public virtual bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
C#
public virtual Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
C#
public virtual Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
C#
public virtual Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Overridable Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public virtual bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Overridable Property RightToLeft As RightToLeft
C#
public virtual RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Text Property

Glossary Item Box

Gets or sets the text associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Text As String
C#
public virtual string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


TextChanged Event

[image]
ActiveReports 13
TextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : TextChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Declaration)
Public Event TextChanged As EventHandler
C#
public event EventHandler TextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Dashboard.Design Namespace > ReportItemDesignerBase Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportItemDesignerBase Class
ReportItemDesignerBase Members


GrapeCity.ActiveReports.Dashboard.Design Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Dashboard.Design Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Dashboard.Design Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.ReportComponentDesigner
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.ReportItemDesigner
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.ReportItemContainerDesigner
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.CustomReportItemDesigner
GrapeCity.ActiveReports.Dashboard.Design.ReportItemDesignerBase

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.Component Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.Component Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.Component Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


DvChartDesigner Class Events

[image]
ActiveReports 13
DvChartDesigner Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace : DvChartDesigner Class

Glossary Item Box

For a list of all members of this type, see DvChartDesigner members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DvChartDesigner Class
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Property AllowDrop As Boolean
C#
public bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Property Anchor As AnchorStyles
C#
public AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Property AutoScrollOffset As Point
C#
public Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageLayout As ImageLayout
C#
public ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Property BindingContext As BindingContext
C#
public BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenu As ContextMenu
C#
public ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenuStrip As ContextMenuStrip
C#
public ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Property Cursor As Cursor
C#
public Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the display area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayRectangle As Rectangle
C#
public Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Property Dock As DockStyle
C#
public DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Focused As Boolean
C#
public bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutEngine As LayoutEngine
C#
public LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MaximumSize As Size
C#
public Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MinimumSize As Size
C#
public Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
C#
public void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Sub ResetText()
C#
public void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As RightToLeft
C#
public RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Text Property

[image]
ActiveReports 13
Text Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Text Property

Glossary Item Box

Gets or sets the text associated with this control.

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


TextChanged Event

[image]
ActiveReports 13
TextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : TextChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Declaration)
Public Event TextChanged As EventHandler
C#
public event EventHandler TextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace > DvChartDesigner Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DvChartDesigner Class
DvChartDesigner Members


GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.UI Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.UI Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.UI Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.ReportComponentDesigner
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.ReportItemDesigner
GrapeCity.ActiveReports.Design.DdrDesigner.Designers.DvChart.DvChartDesigner

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


DataVisualizerBasePanel Class Events

[image]
ActiveReports 13
DataVisualizerBasePanel Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace : DataVisualizerBasePanel Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerBasePanel members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the value of the System.Windows.Forms.Panel.AutoSize property has changed. (Inherited from System.Windows.Forms.Panel)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CellPaint | Occurs when the cell is redrawn. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DataVisualizerBasePanel Class
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace


DataVisualizerBasePanel Class Properties

[image]
ActiveReports 13
DataVisualizerBasePanel Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace : DataVisualizerBasePanel Class

Glossary Item Box

For a list of all members of this type, see DataVisualizerBasePanel members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from System.Windows.Forms.Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from System.Windows.Forms.Panel)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CellBorderStyle | Gets or sets the style of the cell borders. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ColumnCount | Gets or sets the number of columns in the table. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | ColumnStyles | Gets a collection of column styles for the System.Windows.Forms.TableLayoutPanel. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the System.Windows.Forms.TableLayoutPanel. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | GrowStyle | Gets or sets a value indicating whether the System.Windows.Forms.TableLayoutPanel control should expand to accommodate new cells when all existing cells are occupied. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the panel's layout engine. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | RowCount | Gets or sets the number of rows in the table. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | RowStyles | Gets a collection of row styles for the System.Windows.Forms.TableLayoutPanel. (Inherited from System.Windows.Forms.TableLayoutPanel)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Panel)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DataVisualizerBasePanel Class
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowDrop As Boolean
C#
public virtual bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
C#
public virtual AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScroll As Boolean
C#
public virtual bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScrollOffset As Point
C#
public virtual Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoSize Property

Glossary Item Box

Gets or sets a value that indicates whether the control resizes based on its contents.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
C#
public virtual bool AutoSize {get; set;}

Property Value

true if the control automatically resizes based on its contents; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Panel.AutoSize property has changed.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : AutoSizeMode Property

Glossary Item Box

Indicates the automatic sizing behavior of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSizeMode As AutoSizeMode
C#
public virtual AutoSizeMode AutoSizeMode {get; set;}

Property Value

One of the System.Windows.Forms.AutoSizeMode values.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified value when setting this property is not a valid System.Windows.Forms.AutoSizeMode values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImage As Image
C#
public virtual Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImageLayout As ImageLayout
C#
public virtual ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BindingContext As BindingContext
C#
public virtual BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CellBorderStyle Property

[image]
ActiveReports 13
CellBorderStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CellBorderStyle Property

Glossary Item Box

Gets or sets the style of the cell borders.

Syntax

Visual Basic (Declaration)
Public Property CellBorderStyle As TableLayoutPanelCellBorderStyle
C#
public TableLayoutPanelCellBorderStyle CellBorderStyle {get; set;}

Property Value

One of the System.Windows.Forms.TableLayoutPanelCellBorderStyle values describing the style of all the cell borders in the table. The default is System.Windows.Forms.TableLayoutPanelCellBorderStyle.None.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CellPaint Event

[image]
ActiveReports 13
CellPaint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CellPaint Event

Glossary Item Box

Occurs when the cell is redrawn.

Syntax

Visual Basic (Declaration)
Public Event CellPaint As TableLayoutCellPaintEventHandler
C#
public event TableLayoutCellPaintEventHandler CellPaint

Event Data

The event handler receives an argument of type TableLayoutCellPaintEventArgs containing data related to this event. The following TableLayoutCellPaintEventArgs properties provide information specific to this event.

Property | Description
CellBounds | Gets the size and location of the cell.
ClipRectangle | Gets the rectangle in which to paint. (Inherited from System.Windows.Forms.PaintEventArgs)
Column | Gets the column of the cell.
Graphics | Gets the graphics used to paint. (Inherited from System.Windows.Forms.PaintEventArgs)
Row | Gets the row of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ColumnCount Property

[image]
ActiveReports 13
ColumnCount Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ColumnCount Property

Glossary Item Box

Gets or sets the number of columns in the table.

Syntax

Visual Basic (Declaration)
Public Property ColumnCount As Integer
C#
public int ColumnCount {get; set;}

Property Value

The number of columns in the System.Windows.Forms.TableLayoutPanel control. The default is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ColumnStyles Property

[image]
ActiveReports 13
ColumnStyles Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ColumnStyles Property

Glossary Item Box

Gets a collection of column styles for the System.Windows.Forms.TableLayoutPanel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnStyles As TableLayoutColumnStyleCollection
C#
public TableLayoutColumnStyleCollection ColumnStyles {get;}

Property Value

A System.Windows.Forms.TableLayoutColumnStyleCollection containing a System.Windows.Forms.ColumnStyle for each column in the System.Windows.Forms.TableLayoutPanel control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenu As ContextMenu
C#
public virtual ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenuStrip As ContextMenuStrip
C#
public virtual ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the System.Windows.Forms.TableLayoutPanel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As TableLayoutControlCollection
C#
public TableLayoutControlCollection Controls {get;}

Property Value

A System.Windows.Forms.TableLayoutControlCollection containing the controls associated with the current System.Windows.Forms.TableLayoutPanel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As Cursor
C#
public virtual Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As Rectangle
C#
public virtual Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Dispose Method

Glossary Item Box

Releases the unmanaged resources used by the System.Windows.Forms.Control and its child controls and optionally releases the managed resources.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Dock As DockStyle
C#
public virtual DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Focused As Boolean
C#
public virtual bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
C#
public virtual Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetCellPosition Method

[image]
ActiveReports 13
GetCellPosition Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetCellPosition Method

control
A control contained within a cell.

Glossary Item Box

Gets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell.

Syntax

Visual Basic (Declaration)
Public Function GetCellPosition( _
   ByVal control As Control _
) As TableLayoutPanelCellPosition
C#
public TableLayoutPanelCellPosition GetCellPosition(
   Control control
)

Parameters

control
A control contained within a cell.

Return Value

A System.Windows.Forms.TableLayoutPanelCellPosition that represents the cell position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


GetColumn Method

[image]
ActiveReports 13
GetColumn Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetColumn Method

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Glossary Item Box

Returns the column position of the specified child control.

Syntax

Visual Basic (Declaration)
Public Function GetColumn( _
   ByVal control As Control _
) As Integer
C#
public int GetColumn(
   Control control
)

Parameters

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Return Value

The column position of the specified child control, or -1 if the position of control is determined by System.Windows.Forms.TableLayoutPanel.LayoutEngine.

Exceptions

Exception | Description
System.ArgumentNullException | control is a null reference (Nothing in Visual Basic).
System.NotSupportedException | control is not a type that can be arranged by this System.Windows.Forms.Layout.LayoutEngine.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetColumnSpan Method

[image]
ActiveReports 13
GetColumnSpan Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetColumnSpan Method

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Glossary Item Box

Returns the number of columns spanned by the specified child control.

Syntax

Visual Basic (Declaration)
Public Function GetColumnSpan( _
   ByVal control As Control _
) As Integer
C#
public int GetColumnSpan(
   Control control
)

Parameters

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Return Value

The number of columns spanned by the child control. The default is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetControlFromPosition Method

[image]
ActiveReports 13
GetControlFromPosition Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetControlFromPosition Method

column
The column position of the control to retrieve.
row
The row position of the control to retrieve.

Glossary Item Box

Returns the child control occupying the specified position.

Syntax

Visual Basic (Declaration)
Public Function GetControlFromPosition( _
   ByVal column As Integer, _
   ByVal row As Integer _
) As Control
C#
public Control GetControlFromPosition(
   int column,
   int row
)

Parameters

column
The column position of the control to retrieve.
row
The row position of the control to retrieve.

Return Value

The child control occupying the specified cell; otherwise, a null reference (Nothing in Visual Basic) if no control exists at the specified column and row, or if the control has its System.Windows.Forms.Control.Visible property set to false.

Exceptions

Exception | Description
System.ArgumentException | Either column or row (or both) is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetPositionFromControl Method

[image]
ActiveReports 13
GetPositionFromControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetPositionFromControl Method

control
A control contained within a cell.

Glossary Item Box

Gets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell that contains the control.

Syntax

Visual Basic (Declaration)
Public Function GetPositionFromControl( _
   ByVal control As Control _
) As TableLayoutPanelCellPosition
C#
public TableLayoutPanelCellPosition GetPositionFromControl(
   Control control
)

Parameters

control
A control contained within a cell.

Return Value

A System.Windows.Forms.TableLayoutPanelCellPosition that represents the cell position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetRow Method

[image]
ActiveReports 13
GetRow Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetRow Method

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Glossary Item Box

Returns the row position of the specified child control.

Syntax

Visual Basic (Declaration)
Public Function GetRow( _
   ByVal control As Control _
) As Integer
C#
public int GetRow(
   Control control
)

Parameters

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Return Value

The row position of control, or -1 if the position of control is determined by System.Windows.Forms.TableLayoutPanel.LayoutEngine.

Exceptions

Exception | Description
System.ArgumentNullException | control is a null reference (Nothing in Visual Basic).
System.NotSupportedException | control is not a type that can be arranged by this System.Windows.Forms.Layout.LayoutEngine.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GetRowSpan Method

[image]
ActiveReports 13
GetRowSpan Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GetRowSpan Method

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Glossary Item Box

Returns the number of rows spanned by the specified child control.

Syntax

Visual Basic (Declaration)
Public Function GetRowSpan( _
   ByVal control As Control _
) As Integer
C#
public int GetRowSpan(
   Control control
)

Parameters

control
A child control of the System.Windows.Forms.TableLayoutPanel.

Return Value

The number of rows spanned by the child control. The default is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GrowStyle Property

[image]
ActiveReports 13
GrowStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : GrowStyle Property

Glossary Item Box

Gets or sets a value indicating whether the System.Windows.Forms.TableLayoutPanel control should expand to accommodate new cells when all existing cells are occupied.

Syntax

Visual Basic (Declaration)
Public Property GrowStyle As TableLayoutPanelGrowStyle
C#
public TableLayoutPanelGrowStyle GrowStyle {get; set;}

Property Value

A System.Windows.Forms.TableLayoutPanelGrowStyle indicating the growth scheme. The default is System.Windows.Forms.TableLayoutPanelGrowStyle.AddRows.

Exceptions

Exception | Description
System.ArgumentException | The property value is invalid for the System.Windows.Forms.TableLayoutPanelGrowStyle enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the panel's layout engine.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the panel's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
C#
public virtual Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
C#
public virtual Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Overridable Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public virtual bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Overridable Property RightToLeft As RightToLeft
C#
public virtual RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RowCount Property

[image]
ActiveReports 13
RowCount Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RowCount Property

Glossary Item Box

Gets or sets the number of rows in the table.

Syntax

Visual Basic (Declaration)
Public Property RowCount As Integer
C#
public int RowCount {get; set;}

Property Value

The number of rows in the System.Windows.Forms.TableLayoutPanel control. The default is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


RowStyles Property

[image]
ActiveReports 13
RowStyles Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : RowStyles Property

Glossary Item Box

Gets a collection of row styles for the System.Windows.Forms.TableLayoutPanel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowStyles As TableLayoutRowStyleCollection
C#
public TableLayoutRowStyleCollection RowStyles {get;}

Property Value

A System.Windows.Forms.TableLayoutRowStyleCollection containing a System.Windows.Forms.RowStyle for each row in the System.Windows.Forms.TableLayoutPanel control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members
Overload List


SetCellPosition Method

[image]
ActiveReports 13
SetCellPosition Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetCellPosition Method

control
A control contained within a cell.
position
A System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell.

Glossary Item Box

Sets the System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell.

Syntax

Visual Basic (Declaration)
Public Sub SetCellPosition( _
   ByVal control As Control, _
   ByVal position As TableLayoutPanelCellPosition _
)
C#
public void SetCellPosition(
   Control control,
   TableLayoutPanelCellPosition position
)

Parameters

control
A control contained within a cell.
position
A System.Windows.Forms.TableLayoutPanelCellPosition that represents the row and the column of the cell.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetColumn Method

[image]
ActiveReports 13
SetColumn Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetColumn Method

control
The control to move to another column.
column
The column to which control will be moved.

Glossary Item Box

Sets the column position of the specified child control.

Syntax

Visual Basic (Declaration)
Public Sub SetColumn( _
   ByVal control As Control, _
   ByVal column As Integer _
)
C#
public void SetColumn(
   Control control,
   int column
)

Parameters

control
The control to move to another column.
column
The column to which control will be moved.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetColumnSpan Method

[image]
ActiveReports 13
SetColumnSpan Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetColumnSpan Method

control
A child control of the System.Windows.Forms.TableLayoutPanel.
value
The number of columns to span.

Glossary Item Box

Sets the number of columns spanned by the child control.

Syntax

Visual Basic (Declaration)
Public Sub SetColumnSpan( _
   ByVal control As Control, _
   ByVal value As Integer _
)
C#
public void SetColumnSpan(
   Control control,
   int value
)

Parameters

control
A child control of the System.Windows.Forms.TableLayoutPanel.
value
The number of columns to span.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | value is less than 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetRow Method

[image]
ActiveReports 13
SetRow Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetRow Method

control
The control to move to another row.
row
The row to which control will be moved.

Glossary Item Box

Sets the row position of the specified child control.

Syntax

Visual Basic (Declaration)
Public Sub SetRow( _
   ByVal control As Control, _
   ByVal row As Integer _
)
C#
public void SetRow(
   Control control,
   int row
)

Parameters

control
The control to move to another row.
row
The row to which control will be moved.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SetRowSpan Method

[image]
ActiveReports 13
SetRowSpan Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SetRowSpan Method

control
A child control of the System.Windows.Forms.TableLayoutPanel.
value
The number of rows to span.

Glossary Item Box

Sets the number of rows spanned by the child control.

Syntax

Visual Basic (Declaration)
Public Sub SetRowSpan( _
   ByVal control As Control, _
   ByVal value As Integer _
)
C#
public void SetRowSpan(
   Control control,
   int value
)

Parameters

control
A child control of the System.Windows.Forms.TableLayoutPanel.
value
The number of rows to span.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | value is less than 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : ToString Method

Glossary Item Box

Returns a string representation for this control.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A System.String representation of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace > DataVisualizerBasePanel Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataVisualizerBasePanel Class
DataVisualizerBasePanel Members


GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
System.Windows.Forms.TableLayoutPanel
GrapeCity.ActiveReports.Design.DdrDesigner.Tools.DataVisualizers.DataVisualizerBasePanel

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


Designer Constructor

[image]
ActiveReports 13
Designer Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Designer Constructor

Glossary Item Box

Initializes a new instance of the Designer class.

Overload List

Overload | Description
Designer Constructor | Creates a new Instance of Designer class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowDrop As Boolean
C#
public virtual bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
C#
public virtual AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScroll As Boolean
C#
public virtual bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScrollOffset As Point
C#
public virtual Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
C#
public virtual bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoValidate As AutoValidate
C#
public virtual AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImage As Image
C#
public virtual Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImageLayout As ImageLayout
C#
public virtual ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BindingContext As BindingContext
C#
public virtual BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BorderStyle Property

[image]
ActiveReports 13
BorderStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BorderStyle Property

Glossary Item Box

Gets or sets the border style of the user control.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
C#
public BorderStyle BorderStyle {get; set;}

Property Value

One of the System.Windows.Forms.BorderStyle values. The default is System.Windows.Forms.BorderStyle.Fixed3D.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.BorderStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenu As ContextMenu
C#
public virtual ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenuStrip As ContextMenuStrip
C#
public virtual ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As Cursor
C#
public virtual Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As Rectangle
C#
public virtual Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Dispose Method

Glossary Item Box

Clears the Designer from memory.

Overload List

Overload | Description
Dispose | Disposes objects referenced by the designer. (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Dispose() Method

Glossary Item Box

Disposes objects referenced by the designer.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Dock As DockStyle
C#
public virtual DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Focused As Boolean
C#
public virtual bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
C#
public virtual Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
C#
public virtual Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
C#
public virtual Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Overridable Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public virtual bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Overridable Property RightToLeft As RightToLeft
C#
public virtual RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren() As Boolean
C#
public virtual bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public virtual bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LayerList Class Methods

[image]
ActiveReports 13
LayerList Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

Glossary Item Box

For a list of all members of this type, see LayerList members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Property AllowDrop As Boolean
C#
public bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Property Anchor As AnchorStyles
C#
public AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Property AutoScroll As Boolean
C#
public bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Property AutoScrollOffset As Point
C#
public Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Property AutoSize As Boolean
C#
public bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Property AutoValidate As AutoValidate
C#
public AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImage As Image
C#
public Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageLayout As ImageLayout
C#
public ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Property BindingContext As BindingContext
C#
public BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BorderStyle Property

[image]
ActiveReports 13
BorderStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BorderStyle Property

Glossary Item Box

Gets or sets the border style of the user control.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
C#
public BorderStyle BorderStyle {get; set;}

Property Value

One of the System.Windows.Forms.BorderStyle values. The default is System.Windows.Forms.BorderStyle.Fixed3D.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.BorderStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenu As ContextMenu
C#
public ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenuStrip As ContextMenuStrip
C#
public ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Property Cursor As Cursor
C#
public Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayRectangle As Rectangle
C#
public Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Property Dock As DockStyle
C#
public DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Focused As Boolean
C#
public bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutEngine As LayoutEngine
C#
public LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MaximumSize As Size
C#
public Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MinimumSize As Size
C#
public Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
C#
public void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Sub ResetText()
C#
public void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As RightToLeft
C#
public RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Function ValidateChildren() As Boolean
C#
public bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayerList Class
LayerList Members


ReportExplorer Class Events

[image]
ActiveReports 13
ReportExplorer Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

Glossary Item Box

For a list of all members of this type, see ReportExplorer members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


ReportExplorer Class Methods

[image]
ActiveReports 13
ReportExplorer Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

Glossary Item Box

For a list of all members of this type, see ReportExplorer members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


ReportExplorer Class Properties

[image]
ActiveReports 13
ReportExplorer Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

Glossary Item Box

For a list of all members of this type, see ReportExplorer members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets or sets the border style of the user control. (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowDrop As Boolean
C#
public virtual bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
C#
public virtual AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScroll As Boolean
C#
public virtual bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScrollOffset As Point
C#
public virtual Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
C#
public virtual bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoValidate As AutoValidate
C#
public virtual AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImage As Image
C#
public virtual Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImageLayout As ImageLayout
C#
public virtual ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BindingContext As BindingContext
C#
public virtual BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BorderStyle Property

[image]
ActiveReports 13
BorderStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BorderStyle Property

Glossary Item Box

Gets or sets the border style of the user control.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
C#
public BorderStyle BorderStyle {get; set;}

Property Value

One of the System.Windows.Forms.BorderStyle values. The default is System.Windows.Forms.BorderStyle.Fixed3D.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.BorderStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenu As ContextMenu
C#
public virtual ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenuStrip As ContextMenuStrip
C#
public virtual ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As Cursor
C#
public virtual Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As Rectangle
C#
public virtual Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Dispose Method

Glossary Item Box

Clears the ReportExplorer from memory.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Dock As DockStyle
C#
public virtual DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Focused As Boolean
C#
public virtual bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
C#
public virtual Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
C#
public virtual Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
C#
public virtual Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Overridable Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public virtual bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Overridable Property RightToLeft As RightToLeft
C#
public virtual RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren() As Boolean
C#
public virtual bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public virtual bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportExplorer Class
ReportExplorer Members


GrapeCity.ActiveReports.Design.ReportExplorer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.ReportExplorer Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.ReportExplorer Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.ReportExplorer.ReportExplorerInternal
GrapeCity.ActiveReports.Design.ReportExplorer.ReportExplorer

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


ReportsLibrary Class Events

[image]
ActiveReports 13
ReportsLibrary Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace : ReportsLibrary Class

Glossary Item Box

For a list of all members of this type, see ReportsLibrary members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportsLibrary Class
GrapeCity.ActiveReports.Design.ReportsLibrary Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowDrop As Boolean
C#
public virtual bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
C#
public virtual AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScroll As Boolean
C#
public virtual bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScrollOffset As Point
C#
public virtual Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
C#
public virtual bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoValidate As AutoValidate
C#
public virtual AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImage As Image
C#
public virtual Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImageLayout As ImageLayout
C#
public virtual ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BindingContext As BindingContext
C#
public virtual BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BorderStyle Property

[image]
ActiveReports 13
BorderStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BorderStyle Property

Glossary Item Box

Gets or sets the border style of the user control.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
C#
public BorderStyle BorderStyle {get; set;}

Property Value

One of the System.Windows.Forms.BorderStyle values. The default is System.Windows.Forms.BorderStyle.Fixed3D.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.BorderStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenu As ContextMenu
C#
public virtual ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenuStrip As ContextMenuStrip
C#
public virtual ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As Cursor
C#
public virtual Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As Rectangle
C#
public virtual Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Dock As DockStyle
C#
public virtual DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Focused As Boolean
C#
public virtual bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
C#
public virtual Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
C#
public virtual Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
C#
public virtual Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Overridable Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public virtual bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Overridable Property RightToLeft As RightToLeft
C#
public virtual RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren() As Boolean
C#
public virtual bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public virtual bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.ReportsLibrary Namespace > ReportsLibrary Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportsLibrary Class
ReportsLibrary Members


GrapeCity.ActiveReports.Design.ReportsLibrary Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.ReportsLibrary Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.ReportsLibrary Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.ReportsLibrary.ReportsLibrary

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


BaseToolbox Class Events

[image]
ActiveReports 13
BaseToolbox Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : BaseToolbox Class

Glossary Item Box

For a list of all members of this type, see BaseToolbox members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BaseToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowDrop As Boolean
C#
public virtual bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
C#
public virtual AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScroll As Boolean
C#
public virtual bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScrollOffset As Point
C#
public virtual Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
C#
public virtual bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoValidate As AutoValidate
C#
public virtual AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImage As Image
C#
public virtual Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImageLayout As ImageLayout
C#
public virtual ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BindingContext As BindingContext
C#
public virtual BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ConfigureToolboxItems Method

[image]
ActiveReports 13
ConfigureToolboxItems Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ConfigureToolboxItems Method

Glossary Item Box

Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable

Overload List

Overload | Description
ConfigureToolboxItems | Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenu As ContextMenu
C#
public virtual ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenuStrip As ContextMenuStrip
C#
public virtual ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As Cursor
C#
public virtual Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As Rectangle
C#
public virtual Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Dispose Method

Glossary Item Box

Clean up any CommonResources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Focused As Boolean
C#
public virtual bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
C#
public virtual Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
C#
public virtual Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
C#
public virtual Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Overridable Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public virtual bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Overridable Property RightToLeft As RightToLeft
C#
public virtual RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren() As Boolean
C#
public virtual bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public virtual bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > BaseToolbox Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseToolbox Class
BaseToolbox Members


FlatToolbox Class Events

[image]
ActiveReports 13
FlatToolbox Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : FlatToolbox Class

Glossary Item Box

For a list of all members of this type, see FlatToolbox members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FlatToolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Property AllowDrop As Boolean
C#
public bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Property Anchor As AnchorStyles
C#
public AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Property AutoScroll As Boolean
C#
public bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Property AutoScrollOffset As Point
C#
public Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Property AutoSize As Boolean
C#
public bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Property AutoValidate As AutoValidate
C#
public AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImage As Image
C#
public Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageLayout As ImageLayout
C#
public ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Property BindingContext As BindingContext
C#
public BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenu As ContextMenu
C#
public ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenuStrip As ContextMenuStrip
C#
public ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Property Cursor As Cursor
C#
public Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayRectangle As Rectangle
C#
public Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Dispose Method

Glossary Item Box

Clean up any CommonResources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Focused As Boolean
C#
public bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutEngine As LayoutEngine
C#
public LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MaximumSize As Size
C#
public Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MinimumSize As Size
C#
public Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
C#
public void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Sub ResetText()
C#
public void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As RightToLeft
C#
public RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Function ValidateChildren() As Boolean
C#
public bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > FlatToolbox Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlatToolbox Class
FlatToolbox Members


Group Class Events

[image]
ActiveReports 13
Group Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

Glossary Item Box

For a list of all members of this type, see Group members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Class Methods

[image]
ActiveReports 13
Group Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

Glossary Item Box

For a list of all members of this type, see Group members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


Toolbox Class Events

[image]
ActiveReports 13
Toolbox Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

Glossary Item Box

For a list of all members of this type, see Toolbox members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from System.Windows.Forms.Control)
Public Event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Toolbox Class Methods

[image]
ActiveReports 13
Toolbox Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

Glossary Item Box

For a list of all members of this type, see Toolbox members.

Public Methods

 | Name | Description
Public Method | AddCreator | Overloaded. Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddLinkedToolboxItem | Overloaded. Adds a ToolboxItem that is only available in the current project to the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | AddToolboxItem | Overloaded. Adds a ToolboxItem to the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ChangeVisibilityCategory | Change the visibility of the category (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ConfigureToolboxItems | Method sets state to toolbox according to IToolboxUser object: toolbox items that this object supports became available and other items became disable (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. Gets a ToolboxItem from the specified serialized object. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Specifies a category name to enable or disable. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns a read-only wrapper for the Groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | GetToolboxItems | Overloaded. Gets the ToolboxItemCollection associated with the specified host from the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. Indicates whether the ToolboxItem in the specified serialized object is matches the specified attributes. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | IsToolboxItem | Overloaded. Indicates whether the item in the specified serialized object that is supported by the specified host is a ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | LogicalToDeviceUnits | Overloaded. Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | RemoveToolboxItem | Overloaded. Removes the specified ToolboxItem from the specified category in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty). (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)
Public Method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | Signals the toolbox that the selected ToolboxItem has been used. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | Creates a serialized System.Object representing the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | Sets the cursor to a cursor that represents the current ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | SetSelectedToolboxItem | Selects the specified ToolboxItem. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Toolbox Class Properties

[image]
ActiveReports 13
Toolbox Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

Glossary Item Box

For a list of all members of this type, see Toolbox members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | This property is not relevant for this class. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | Gets the System.Drawing.Design CategoryNameCollection containing the categories available in the toolbox. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | Gets or sets the currently selected toolbox category. (Inherited from GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Property AllowDrop As Boolean
C#
public bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Property Anchor As AnchorStyles
C#
public AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Property AutoScroll As Boolean
C#
public bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Property AutoScrollOffset As Point
C#
public Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Property AutoSize As Boolean
C#
public bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Property AutoValidate As AutoValidate
C#
public AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
C#
public Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImage As Image
C#
public Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Property BackgroundImageLayout As ImageLayout
C#
public ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Property BindingContext As BindingContext
C#
public BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenu As ContextMenu
C#
public ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Property ContextMenuStrip As ContextMenuStrip
C#
public ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Property Cursor As Cursor
C#
public Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayRectangle As Rectangle
C#
public Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Dispose Method

Glossary Item Box

Clean up any CommonResources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Focused As Boolean
C#
public bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
C#
public Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
C#
public Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutEngine As LayoutEngine
C#
public LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MaximumSize As Size
C#
public Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Property MinimumSize As Size
C#
public Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
C#
public void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Sub ResetText()
C#
public void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As RightToLeft
C#
public RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Function ValidateChildren() As Boolean
C#
public bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Toolbox Class
Toolbox Members


GrapeCity.ActiveReports.Design.Toolbox Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.Toolbox Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design.Toolbox Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.Toolbox.GroupChangedEventArgs
GrapeCity.ActiveReports.Design.Toolbox.ToolClickEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Design.Toolbox.Group
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Toolbox.GroupListbar
GrapeCity.ActiveReports.Design.Toolbox.BaseToolbox
GrapeCity.ActiveReports.Design.Toolbox.FlatToolbox
GrapeCity.ActiveReports.Design.Toolbox.Toolbox

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


GrapeCity.ActiveReports.Design Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Design.Win Assembly : GrapeCity.ActiveReports.Design Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.Selection
GrapeCity.ActiveReports.Design.UndoManager
System.EventArgs
GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs
GrapeCity.ActiveReports.Design.ContextMenuOpenArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickedEventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickEventArgs
GrapeCity.ActiveReports.Design.DesignerTabChangedEventArgs
GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs
GrapeCity.ActiveReports.Design.EditModeExitEventArgs
GrapeCity.ActiveReports.Design.LayerSelectionChangedEventArgs
GrapeCity.ActiveReports.Design.LayoutChangedArgs
GrapeCity.ActiveReports.Design.LayoutChangingArgs
GrapeCity.ActiveReports.Design.ServerConnectionChangedEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Designer
GrapeCity.ActiveReports.Design.LayerList

See Also

Reference

GrapeCity.ActiveReports.Design.Win Assembly


Assembly Overview

GrapeCity.ActiveReports.Document Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports | The GrapeCity.ActiveReports namespace contains the Border class and its settings.
GrapeCity.ActiveReports.Document | The GrapeCity.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.
GrapeCity.ActiveReports.Document.Section | The GrapeCity.ActiveReports.Document.Section Namespace contains various classes that can be set in the report document.
GrapeCity.ActiveReports.Document.Section.Adapter |
GrapeCity.ActiveReports.Document.Section.Annotations | The GrapeCity.ActiveReports.Document.Section.Annotations namespace contains the Annotations classes and its settings.
GrapeCity.ActiveReports.Document.Tools |
GrapeCity.ActiveReports.Export | The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.
GrapeCity.ActiveReports.Export.Html | The GrapeCity.ActiveReports.Export.Html namespace contains the class which gives control over the HTML output of the report.
GrapeCity.ActiveReports.Extensibility.Printing |


ActiveReportPrintControllerWithStatusDialog Class Properties

[image]
ActiveReports 13
ActiveReportPrintControllerWithStatusDialog Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

Glossary Item Box

For a list of all members of this type, see ActiveReportPrintControllerWithStatusDialog members.

Public Properties

 | Name | Description
Public Property | IsPreview | Gets a value indicating whether the System.Drawing.Printing.PrintController is used for print preview. (Inherited from System.Drawing.Printing.PrintController)
Top

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


IsPreview Property

[image]
ActiveReports 13
IsPreview Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : IsPreview Property

Glossary Item Box

Gets a value indicating whether the System.Drawing.Printing.PrintController is used for print preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsPreview As Boolean
C#
public virtual bool IsPreview {get;}

Property Value

false in all cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


GrapeCity.ActiveReports.Document.Section.Adapter Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section.Adapter Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Section.Adapter Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


Annotation Class Events

[image]
ActiveReports 13
Annotation Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

Glossary Item Box

For a list of all members of this type, see Annotation members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Events

[image]
ActiveReports 13
AnnotationArrow Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

For a list of all members of this type, see AnnotationArrow members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Methods

[image]
ActiveReports 13
AnnotationArrow Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

Glossary Item Box

For a list of all members of this type, see AnnotationArrow members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Dispose Method

Glossary Item Box

Releases the unmanaged resources used by the System.ComponentModel.Component and optionally releases the managed resources.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationBalloon Class Events

[image]
ActiveReports 13
AnnotationBalloon Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

For a list of all members of this type, see AnnotationBalloon members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Class Methods

[image]
ActiveReports 13
AnnotationBalloon Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

Glossary Item Box

For a list of all members of this type, see AnnotationBalloon members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Dispose Method

Glossary Item Box

Releases the unmanaged resources used by the System.ComponentModel.Component and optionally releases the managed resources. Releases the AnnotationBalloon instance from memory.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBaseText Class Events

[image]
ActiveReports 13
AnnotationBaseText Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

For a list of all members of this type, see AnnotationBaseText members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Methods

[image]
ActiveReports 13
AnnotationBaseText Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

Glossary Item Box

For a list of all members of this type, see AnnotationBaseText members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


AnnotationCircle Class Events

[image]
ActiveReports 13
AnnotationCircle Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

For a list of all members of this type, see AnnotationCircle members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Methods

[image]
ActiveReports 13
AnnotationCircle Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

For a list of all members of this type, see AnnotationCircle members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Properties

[image]
ActiveReports 13
AnnotationCircle Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

Glossary Item Box

For a list of all members of this type, see AnnotationCircle members.

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Capacity Property

[image]
ActiveReports 13
Capacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationImage Class Events

[image]
ActiveReports 13
AnnotationImage Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

For a list of all members of this type, see AnnotationImage members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Class Methods

[image]
ActiveReports 13
AnnotationImage Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

Glossary Item Box

For a list of all members of this type, see AnnotationImage members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationLine Class Events

[image]
ActiveReports 13
AnnotationLine Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Class Methods

[image]
ActiveReports 13
AnnotationLine Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

Glossary Item Box

For a list of all members of this type, see AnnotationLine members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationRectangle Class Events

[image]
ActiveReports 13
AnnotationRectangle Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

For a list of all members of this type, see AnnotationRectangle members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Methods

[image]
ActiveReports 13
AnnotationRectangle Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

For a list of all members of this type, see AnnotationRectangle members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Properties

[image]
ActiveReports 13
AnnotationRectangle Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

Glossary Item Box

For a list of all members of this type, see AnnotationRectangle members.

Public Properties

 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


AnnotationText Class Events

[image]
ActiveReports 13
AnnotationText Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

For a list of all members of this type, see AnnotationText members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Methods

[image]
ActiveReports 13
AnnotationText Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

For a list of all members of this type, see AnnotationText members.

Public Methods

 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Properties

[image]
ActiveReports 13
AnnotationText Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

Glossary Item Box

For a list of all members of this type, see AnnotationText members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the text within the bounds of an annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the text font associated with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the vertical alignment of the text within the bounds of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top

See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationText Class
AnnotationText Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


GrapeCity.ActiveReports.Document.Section.Annotations Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section.Annotations Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Section.Annotations Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.Border
GrapeCity.ActiveReports.Document.Section.Annotations.BorderCircle
GrapeCity.ActiveReports.Document.Section.Annotations.BorderRectangle
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCollection
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


BookmarksCollection Constructor

[image]
ActiveReports 13
BookmarksCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : BookmarksCollection Constructor

Glossary Item Box

Initializes a new instance of the BookmarksCollection class.

Overload List

Overload | Description
BookmarksCollection Constructor | Creates a new instance of the BookmarkCollection class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Capacity Property

[image]
ActiveReports 13
Capacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Count Property

Glossary Item Box

Gets the number of Bookmark objects in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Example

C# Copy Code
private void btnClearTOC_Click(object sender, System.EventArgs e)
{
    MessageBox.Show ("Clearing " + arv.Document.Bookmarks.Count.ToString() + " bookmarks.");
    arv.Document.Bookmarks.Clear();
    arv.TableOfContents.Clear();
}
Visual Basic Copy Code
Private Sub btnClearTOC_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClearTOC.Click
    MsgBox("Clearing " & arv.Document.Bookmarks.Count.ToString & " bookmarks.")
    arv.Document.Bookmarks.Clear()
    arv.TableOfContents.Clear()
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : RemoveAt Method

index
Specifies the index of the Bookmark object to be removed from the collection.

Glossary Item Box

Removes the Bookmark object at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
Specifies the index of the Bookmark object to be removed from the collection.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Bookmark Constructor

[image]
ActiveReports 13
Bookmark Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Bookmark Constructor

Glossary Item Box

Creates a new instance of the Bookmark class.

Overload List

Overload | Description
Bookmark Constructor | Creates a new instance of the Bookmark class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Bookmark Class
Bookmark Members


AddBookmark Method

[image]
ActiveReports 13
AddBookmark Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : AddBookmark Method

Glossary Item Box

Adds a bookmark to the page at the specified offset.

Overload List

Overload | Description
AddBookmark | Summary description for AddBookmark.

Remarks

Bookmarks appear in the viewer's table of contents.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    for(int i = 0; i<Document.Pages.Count;i++)
    {
        this.Document.Pages[i].AddBookmark("New Bookmark", 25);
    }
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim i As Integer
    Try
        For i = 0 To Me.Document.Pages.Count - 1
            Me.Document.Pages(1).AddBookmark("New Bookmark", 8)
        Next
    Catch ex As Exception
    End Try
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members

How To

Add Bookmarks


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Dispose Method

Glossary Item Box

Releases the Page instance from memory.

Overload List

Overload | Description
Dispose | Releases the Page instance from memory.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


Draw Method

[image]
ActiveReports 13
Draw Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Draw Method

Glossary Item Box

Renders the page's content to the specified Graphics object at the specified coordinates.

Overload List

Overload | Description
Draw | Renders the page's content to the specified Graphics object at the specified coordinates.

Remarks

You can use this method to render the page content scaled to a rectangle. This allows you to create thumbnail images of the pages or print multiple pages on a single sheet of paper.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Page Class
Page Members


GrapeCity.ActiveReports.Document.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Bookmark
GrapeCity.ActiveReports.Document.Section.CanvasItem
GrapeCity.ActiveReports.Document.Section.SetScaleX
GrapeCity.ActiveReports.Document.Section.TextBoundsRange
GrapeCity.ActiveReports.Document.Section.Margins
GrapeCity.ActiveReports.Document.Section.Page
GrapeCity.ActiveReports.Document.Section.PageDoubleLineExtensions
GrapeCity.ActiveReports.Document.Section.PagesCollection
GrapeCity.ActiveReports.Document.Section.UserPreferences
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.BookmarksCollection
System.Drawing.Printing.PrintController
System.Drawing.Printing.StandardPrintController
GrapeCity.ActiveReports.Document.Section.ActiveReportPrintControllerWithStatusDialog
System.EventArgs
GrapeCity.ActiveReports.Document.Section.UrlErrorEventArgs

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


GrapeCity.ActiveReports.Document.Tools Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Tools Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document.Tools Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document) Inheritance Hierarchy

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Document Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.SectionDocument

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


GrapeCity.ActiveReports.Export.Html Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Html Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Export.Html Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.HtmlOutputInfoArgs

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document) Inheritance Hierarchy

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Export Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


IsPreview Property

[image]
ActiveReports 13
IsPreview Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : IsPreview Property

Glossary Item Box

Gets a value indicating whether the System.Drawing.Printing.PrintController is used for print preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsPreview As Boolean
C#
public virtual bool IsPreview {get;}

Property Value

false in all cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


OnEndPrint Method

[image]
ActiveReports 13
OnEndPrint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : OnEndPrint Method

document
A System.Drawing.Printing.PrintDocument that represents the document being printed.
e
A System.Drawing.Printing.PrintEventArgs that contains data about how to print the document.

Glossary Item Box

Completes the control sequence that determines when and how to print a document.

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnEndPrint( _
   ByVal document As PrintDocument, _
   ByVal e As PrintEventArgs _
)
C#
public virtual void OnEndPrint(
   PrintDocument document,
   PrintEventArgs e
)

Parameters

document
A System.Drawing.Printing.PrintDocument that represents the document being printed.
e
A System.Drawing.Printing.PrintEventArgs that contains data about how to print the document.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | The native Win32 Application Programming Interface (API) could not complete the print job. -or- The native Win32 API could not delete the specified device context (DC).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


OnStartPrint Method

[image]
ActiveReports 13
OnStartPrint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > ActiveReportPrintController Class : OnStartPrint Method

document
A System.Drawing.Printing.PrintDocument that represents the document being printed.
e
A System.Drawing.Printing.PrintEventArgs that contains data about how to print the document.

Glossary Item Box

Begins the control sequence that determines when and how to print a document.

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnStartPrint( _
   ByVal document As PrintDocument, _
   ByVal e As PrintEventArgs _
)
C#
public virtual void OnStartPrint(
   PrintDocument document,
   PrintEventArgs e
)

Parameters

document
A System.Drawing.Printing.PrintDocument that represents the document being printed.
e
A System.Drawing.Printing.PrintEventArgs that contains data about how to print the document.

Exceptions

Exception | Description
System.Drawing.Printing.InvalidPrinterException | The printer settings are not valid.
System.ComponentModel.Win32Exception | The native Win32 Application Programming Interface (API) could not start a print job.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReportPrintController Class
ActiveReportPrintController Members


DDPaperSize Class Methods

[image]
ActiveReports 13
DDPaperSize Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : DDPaperSize Class

Glossary Item Box

For a list of all members of this type, see DDPaperSize members.

Public Methods

 | Name | Description
Public Method | ToString | Provides information about the System.Drawing.Printing.PaperSize in string form. (Inherited from System.Drawing.Printing.PaperSize)
Top

See Also

Reference

DDPaperSize Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class : Height Property

Glossary Item Box

Gets or sets the height of the paper, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the paper, in hundredths of an inch.

Exceptions

Exception | Description
System.ArgumentException | The System.Drawing.Printing.PaperSize.Kind property is not set to System.Drawing.Printing.PaperKind.Custom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members


PaperName Property

[image]
ActiveReports 13
PaperName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class : PaperName Property

Glossary Item Box

Gets or sets the name of the type of paper.

Syntax

Visual Basic (Declaration)
Public Property PaperName As String
C#
public string PaperName {get; set;}

Property Value

The name of the type of paper.

Exceptions

Exception | Description
System.ArgumentException | The System.Drawing.Printing.PaperSize.Kind property is not set to System.Drawing.Printing.PaperKind.Custom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members


RawKind Property

[image]
ActiveReports 13
RawKind Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class : RawKind Property

Glossary Item Box

Gets or sets an integer representing one of the System.Drawing.Printing.PaperSize values or a custom value.

Syntax

Visual Basic (Declaration)
Public Property RawKind As Integer
C#
public int RawKind {get; set;}

Property Value

An integer representing one of the System.Drawing.Printing.PaperSize values, or a custom value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class : ToString Method

Glossary Item Box

Provides information about the System.Drawing.Printing.PaperSize in string form.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > DDPaperSize Class : Width Property

Glossary Item Box

Gets or sets the width of the paper, in hundredths of an inch.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the paper, in hundredths of an inch.

Exceptions

Exception | Description
System.ArgumentException | The System.Drawing.Printing.PaperSize.Kind property is not set to System.Drawing.Printing.PaperKind.Custom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDPaperSize Class
DDPaperSize Members


Printer Class Events

[image]
ActiveReports 13
Printer Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Events

 | Name | Description
Public Event | BeginPrint | Occurs when the System.Drawing.Printing.PrintDocument.Print method is called and before the first page of the document prints. (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | EndPrint | Occurs when the last page of the document has printed. (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | QueryPageSettings | Occurs immediately before each System.Drawing.Printing.PrintDocument.PrintPage event. (Inherited from System.Drawing.Printing.PrintDocument)
Top

See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


BeginPrint Event

[image]
ActiveReports 13
BeginPrint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : BeginPrint Event

Glossary Item Box

Occurs when the System.Drawing.Printing.PrintDocument.Print method is called and before the first page of the document prints.

Syntax

Visual Basic (Declaration)
Public Event BeginPrint As PrintEventHandler
C#
public event PrintEventHandler BeginPrint

Event Data

The event handler receives an argument of type PrintEventArgs containing data related to this event. The following PrintEventArgs properties provide information specific to this event.

Property | Description
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PrintAction | Returns System.Drawing.Printing.PrintAction.PrintToFile in all cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


DefaultPageSettings Property

[image]
ActiveReports 13
DefaultPageSettings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : DefaultPageSettings Property

Glossary Item Box

Gets or sets page settings that are used as defaults for all pages to be printed.

Syntax

Visual Basic (Declaration)
Public Property DefaultPageSettings As PageSettings
C#
public PageSettings DefaultPageSettings {get; set;}

Property Value

A System.Drawing.Printing.PageSettings that specifies the default page settings for the document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Dispose Method

Glossary Item Box

Releases the unmanaged resources used by the System.ComponentModel.Component and optionally releases the managed resources.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


DocumentName Property

[image]
ActiveReports 13
DocumentName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : DocumentName Property

Glossary Item Box

Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document.

Syntax

Visual Basic (Declaration)
Public Property DocumentName As String
C#
public string DocumentName {get; set;}

Property Value

The document name to display while printing the document. The default is "document".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


EndPrint Event

[image]
ActiveReports 13
EndPrint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : EndPrint Event

Glossary Item Box

Occurs when the last page of the document has printed.

Syntax

Visual Basic (Declaration)
Public Event EndPrint As PrintEventHandler
C#
public event PrintEventHandler EndPrint

Event Data

The event handler receives an argument of type PrintEventArgs containing data related to this event. The following PrintEventArgs properties provide information specific to this event.

Property | Description
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PrintAction | Returns System.Drawing.Printing.PrintAction.PrintToFile in all cases.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


OriginAtMargins Property

[image]
ActiveReports 13
OriginAtMargins Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : OriginAtMargins Property

Glossary Item Box

Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page.

Syntax

Visual Basic (Declaration)
Public Property OriginAtMargins As Boolean
C#
public bool OriginAtMargins {get; set;}

Property Value

true if the graphics origin starts at the page margins; false if the graphics origin is at the top-left corner of the printable page. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Print Method

[image]
ActiveReports 13
Print Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Print Method

Glossary Item Box

Starts the document's printing process.

Syntax

Visual Basic (Declaration)
Public Sub Print()
C#
public void Print()

Exceptions

Exception | Description
System.Drawing.Printing.InvalidPrinterException | The printer named in the System.Drawing.Printing.PrinterSettings.PrinterName property does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


PrintPage Event

[image]
ActiveReports 13
PrintPage Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrintPage Event

Glossary Item Box

Occurs when the output to print for the current page is needed.

Syntax

Visual Basic (Declaration)
Public Event PrintPage As PrintPageEventHandler
C#
public event PrintPageEventHandler PrintPage

Event Data

The event handler receives an argument of type PrintPageEventArgs containing data related to this event. The following PrintPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the print job should be canceled.
Graphics | Gets the System.Drawing.Graphics used to paint the page.
HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Gets the page settings for the current page.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


QueryPageSettings Event

[image]
ActiveReports 13
QueryPageSettings Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : QueryPageSettings Event

Glossary Item Box

Occurs immediately before each System.Drawing.Printing.PrintDocument.PrintPage event.

Syntax

Visual Basic (Declaration)
Public Event QueryPageSettings As QueryPageSettingsEventHandler
C#
public event QueryPageSettingsEventHandler QueryPageSettings

Event Data

The event handler receives an argument of type QueryPageSettingsEventArgs containing data related to this event. The following QueryPageSettingsEventArgs properties provide information specific to this event.

Property | Description
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PageSettings | Gets or sets the page settings for the page to be printed.
PrintAction | Returns System.Drawing.Printing.PrintAction.PrintToFile in all cases. (Inherited from System.Drawing.Printing.PrintEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : ToString Method

Glossary Item Box

Provides information about the print document, in string form.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Printer Class
Printer Members


GrapeCity.ActiveReports.Extensibility.Printing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Printing Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports.Extensibility.Printing Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Printing.Margin
GrapeCity.ActiveReports.Extensibility.Printing.PrintOptions
GrapeCity.ActiveReports.Extensibility.Printing.WatermarkOptions
System.Drawing.Printing.PaperSize
GrapeCity.ActiveReports.Extensibility.Printing.DDPaperSize
System.Drawing.Printing.PrintController
System.Drawing.Printing.StandardPrintController
GrapeCity.ActiveReports.Extensibility.Printing.ActiveReportPrintController
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintingThreadErrorEventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintProgressEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
GrapeCity.ActiveReports.Extensibility.Printing.Printer

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document) Inheritance Hierarchy

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Document Assembly : GrapeCity.ActiveReports Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Border
GrapeCity.ActiveReports.Border.BorderMargins
GrapeCity.ActiveReports.PaddingExtension
System.ValueType
GrapeCity.ActiveReports.PaddingEx

See Also

Reference

GrapeCity.ActiveReports.Document Assembly


Assembly Overview

GrapeCity.ActiveReports.Export.Excel Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Export.Excel.DDR |
GrapeCity.ActiveReports.Export.Excel.Page |
GrapeCity.ActiveReports.Export.Excel.Section | The GrapeCity.ActiveReports.Export.Excel.Section namespace provides Excel Export functionality for ActiveReports for .NET.
GrapeCity.SpreadBuilder | The GrapeCity.SpreadBuilder namespace contains the Column, Row, Sheet and Workbook classes used for building Excel spreadsheets.
GrapeCity.SpreadBuilder.Cells | The GrapeCity.SpreadBuilder.Cells namespace contains the DDCell class.
GrapeCity.SpreadBuilder.Imaging | The GrapeCity.SpreadBuilder.Imaging namespace contains the LineInfo class.
GrapeCity.SpreadBuilder.Printing | The GrapeCity.SpreadBuilder.Printing namespace contains the PageSetup class.
GrapeCity.SpreadBuilder.Style | The GrapeCity.SpreadBuilder.Style namespace contains various style enumerations.


GrapeCity.ActiveReports.Export.Excel.DDR Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Excel.DDR Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.ActiveReports.Export.Excel.DDR Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


GetSupportedSettings Method

[image]
ActiveReports 13
GetSupportedSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class : GetSupportedSettings Method

Glossary Item Box

Gets the settings that are supported for rendering a report to Excel.

Overload List

Overload | Description
GetSupportedSettings | Gets the settings that are supported for rendering a report to Excel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members


GrapeCity.ActiveReports.Export.Excel.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Excel.Page Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.ActiveReports.Export.Excel.Page Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSecurity
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings
GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice
GrapeCity.ActiveReports.Export.Excel.Page.Settings

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


XlsExport Class Events

[image]
ActiveReports 13
XlsExport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

Glossary Item Box

For a list of all members of this type, see XlsExport members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Class Methods

[image]
ActiveReports 13
XlsExportException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class

Glossary Item Box

For a list of all members of this type, see XlsExportException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

XlsExportException Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Class Properties

[image]
ActiveReports 13
XlsExportException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class

Glossary Item Box

For a list of all members of this type, see XlsExportException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

XlsExportException Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExportException Class
XlsExportException Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XlsExport Class
XlsExport Members


GrapeCity.ActiveReports.Export.Excel.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Excel.Section Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.ActiveReports.Export.Excel.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Section.XlsPageSettings
GrapeCity.ActiveReports.Export.Excel.Section.XlsSecurity
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Excel.Section.XlsExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


GrapeCity.SpreadBuilder.Cells Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Cells Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Cells Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Cells.DDCell
GrapeCity.SpreadBuilder.Cells.DDCells
System.ValueType
GrapeCity.SpreadBuilder.Cells.MergeArea

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


ColumnCountOutOfRangeException Class Methods

[image]
ActiveReports 13
ColumnCountOutOfRangeException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see ColumnCountOutOfRangeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ColumnCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


ColumnCountOutOfRangeException Class Properties

[image]
ActiveReports 13
ColumnCountOutOfRangeException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see ColumnCountOutOfRangeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ColumnCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


CompressionException Class Methods

[image]
ActiveReports 13
CompressionException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class

Glossary Item Box

For a list of all members of this type, see CompressionException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CompressionException Class
GrapeCity.SpreadBuilder Namespace


CompressionException Class Properties

[image]
ActiveReports 13
CompressionException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class

Glossary Item Box

For a list of all members of this type, see CompressionException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CompressionException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionException Class
CompressionException Members


DDSheetNameAlreadyExistsException Class Methods

[image]
ActiveReports 13
DDSheetNameAlreadyExistsException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class

Glossary Item Box

For a list of all members of this type, see DDSheetNameAlreadyExistsException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Sets the System.Runtime.Serialization.SerializationInfo object with the parameter name and additional exception information. (Inherited from System.ArgumentException)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DDSheetNameAlreadyExistsException Class
GrapeCity.SpreadBuilder Namespace


DDSheetNameAlreadyExistsException Class Properties

[image]
ActiveReports 13
DDSheetNameAlreadyExistsException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class

Glossary Item Box

For a list of all members of this type, see DDSheetNameAlreadyExistsException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from System.ArgumentException)
Public Property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from System.ArgumentException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DDSheetNameAlreadyExistsException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : GetObjectData Method

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Glossary Item Box

Sets the System.Runtime.Serialization.SerializationInfo object with the parameter name and additional exception information.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info object is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : Message Property

Glossary Item Box

Gets the error message and the parameter name, or only the error message if no parameter name is set.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

A text string describing the details of the exception. The value of this property takes one of two forms: Condition Value The paramName is a null reference (Nothing in Visual Basic) or of zero length. The message string passed to the constructor. The paramName is not null reference (Nothing in Visual Basic) and it has a length greater than zero. The message string appended with the name of the invalid parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


ParamName Property

[image]
ActiveReports 13
ParamName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : ParamName Property

Glossary Item Box

Gets the name of the parameter that causes this exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ParamName As String
C#
public virtual string ParamName {get;}

Property Value

The parameter name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


AddImage Method

[image]
ActiveReports 13
AddImage Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddImage Method

Glossary Item Box

Adds the specified image (stored in PNG format) to the sheet at the specified location with the specified settings.

Overload List

Overload | Description
AddImage | Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.

Example

C# Copy Code

Visual Basic   Copy Code

  Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

  See Also
Reference
DDSheet Class

DDSheet Members


LineInfo Constructor

[image]
ActiveReports 13
LineInfo Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : LineInfo Constructor

Glossary Item Box

Initializes a new instance of the LineInfo class.

Overload List

Overload | Description
LineInfo Constructor | Initializes a new instance of the LineInfo class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LineInfo Class
LineInfo Members


GrapeCity.SpreadBuilder.Imaging Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Imaging Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Imaging Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Imaging.Biff7PictureRecord
GrapeCity.SpreadBuilder.Imaging.LineInfo
System.ValueType
GrapeCity.SpreadBuilder.Imaging.ImageInfo

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


InvalidDDSheetNameException Class Methods

[image]
ActiveReports 13
InvalidDDSheetNameException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class

Glossary Item Box

For a list of all members of this type, see InvalidDDSheetNameException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | Sets the System.Runtime.Serialization.SerializationInfo object with the parameter name and additional exception information. (Inherited from System.ArgumentException)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDDSheetNameException Class
GrapeCity.SpreadBuilder Namespace


InvalidDDSheetNameException Class Properties

[image]
ActiveReports 13
InvalidDDSheetNameException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class

Glossary Item Box

For a list of all members of this type, see InvalidDDSheetNameException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from System.ArgumentException)
Public Property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from System.ArgumentException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDDSheetNameException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : GetObjectData Method

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Glossary Item Box

Sets the System.Runtime.Serialization.SerializationInfo object with the parameter name and additional exception information.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info object is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : Message Property

Glossary Item Box

Gets the error message and the parameter name, or only the error message if no parameter name is set.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

A text string describing the details of the exception. The value of this property takes one of two forms: Condition Value The paramName is a null reference (Nothing in Visual Basic) or of zero length. The message string passed to the constructor. The paramName is not null reference (Nothing in Visual Basic) and it has a length greater than zero. The message string appended with the name of the invalid parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


ParamName Property

[image]
ActiveReports 13
ParamName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : ParamName Property

Glossary Item Box

Gets the name of the parameter that causes this exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ParamName As String
C#
public virtual string ParamName {get;}

Property Value

The parameter name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


InvalidPasswordException Class Methods

[image]
ActiveReports 13
InvalidPasswordException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class

Glossary Item Box

For a list of all members of this type, see InvalidPasswordException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
GrapeCity.SpreadBuilder Namespace


InvalidPasswordException Class Properties

[image]
ActiveReports 13
InvalidPasswordException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class

Glossary Item Box

For a list of all members of this type, see InvalidPasswordException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


NoDDSheetsException Class Methods

[image]
ActiveReports 13
NoDDSheetsException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class

Glossary Item Box

For a list of all members of this type, see NoDDSheetsException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoDDSheetsException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GrapeCity.SpreadBuilder.Printing Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Printing Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Printing Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Printing.PageSetup

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


RowCountOutOfRangeException Class Methods

[image]
ActiveReports 13
RowCountOutOfRangeException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see RowCountOutOfRangeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

RowCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


RowCountOutOfRangeException Class Properties

[image]
ActiveReports 13
RowCountOutOfRangeException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see RowCountOutOfRangeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

RowCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


SpreadBuilderException Class Methods

[image]
ActiveReports 13
SpreadBuilderException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class

Glossary Item Box

For a list of all members of this type, see SpreadBuilderException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SpreadBuilderException Class
GrapeCity.SpreadBuilder Namespace


SpreadBuilderException Class Properties

[image]
ActiveReports 13
SpreadBuilderException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class

Glossary Item Box

For a list of all members of this type, see SpreadBuilderException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SpreadBuilderException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GrapeCity.SpreadBuilder.Style Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Style Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder.Style Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


VersionNotImplementedException Class Methods

[image]
ActiveReports 13
VersionNotImplementedException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class

Glossary Item Box

For a list of all members of this type, see VersionNotImplementedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

VersionNotImplementedException Class
GrapeCity.SpreadBuilder Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


Product Support Forum | Print this page

Glossary Item Box

Copy Code


GrapeCity.SpreadBuilder Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Excel Assembly : GrapeCity.SpreadBuilder Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDColumn
GrapeCity.SpreadBuilder.DDRow
GrapeCity.SpreadBuilder.DDSecurity
GrapeCity.SpreadBuilder.DDSheet
GrapeCity.SpreadBuilder.DDSheets
GrapeCity.SpreadBuilder.EncryptedOpenXmlTools
GrapeCity.SpreadBuilder.Workbook
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.ColumnCountOutOfRangeException
GrapeCity.SpreadBuilder.CompressionException
GrapeCity.SpreadBuilder.InvalidPasswordException
GrapeCity.SpreadBuilder.NoDDSheetsException
GrapeCity.SpreadBuilder.RowCountOutOfRangeException
GrapeCity.SpreadBuilder.VersionNotImplementedException
System.SystemException
System.ArgumentException
GrapeCity.SpreadBuilder.DDSheetNameAlreadyExistsException
GrapeCity.SpreadBuilder.InvalidDDSheetNameException

See Also

Reference

GrapeCity.ActiveReports.Export.Excel Assembly


Assembly Overview

GrapeCity.ActiveReports.Export.Html Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

The ActiveReports.HtmlExport Assembly contains the GrapeCity.ActiveReports.Export.Html Namespace.

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Export.Html.Page | The GrapeCity.ActiveReports.Export.Html.Page namespace contains the information related to HTML rendering extensions and settings.
GrapeCity.ActiveReports.Export.Html.Section | The GrapeCity.ActiveReports.Export.Html.Section namespace contains the Html export component.


GrapeCity.ActiveReports.Export.Html.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Html.Page Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html : GrapeCity.ActiveReports.Export.Html.Page Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Page.EmailRenderingExtensionSettings
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension
GrapeCity.ActiveReports.Export.Html.Page.Settings

See Also

Reference

GrapeCity.ActiveReports.Export.Html


HtmlExport Class Events

[image]
ActiveReports 13
HtmlExport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

Glossary Item Box

For a list of all members of this type, see HtmlExport members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HtmlExport Class
HtmlExport Members


GrapeCity.ActiveReports.Export.Html.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Html.Section Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Html : GrapeCity.ActiveReports.Export.Html.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Section.OutputHtmlFiles
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport

See Also

Reference

GrapeCity.ActiveReports.Export.Html


Assembly Overview

GrapeCity.ActiveReports.Export.Image Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Export.Image.Page | The GrapeCity.ActiveReports.Export.Image.Page contains Image export classes for page layout.
GrapeCity.ActiveReports.Export.Image.Page.Renderers | The GrapeCity.ActiveReports.Export.Page.Renderers namespace contains the information on images to be rendered.
GrapeCity.ActiveReports.Export.Image.Tiff.Section | The GrapeCity.ActiveReports.Export.Tiff.Section namespace contains the TIFF export classes.


GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly : GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Export.Image Assembly


GrapeCity.ActiveReports.Export.Image.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Image.Page Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly : GrapeCity.ActiveReports.Export.Image.Page Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension
GrapeCity.ActiveReports.Export.Image.Page.Settings

See Also

Reference

GrapeCity.ActiveReports.Export.Image Assembly


TiffExport Class Events

[image]
ActiveReports 13
TiffExport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

Glossary Item Box

For a list of all members of this type, see TiffExport members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Class Methods

[image]
ActiveReports 13
TiffExportException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class

Glossary Item Box

For a list of all members of this type, see TiffExportException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffExportException Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Class Properties

[image]
ActiveReports 13
TiffExportException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class

Glossary Item Box

For a list of all members of this type, see TiffExportException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffExportException Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExportException Class
TiffExportException Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TiffExport Class
TiffExport Members


GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Image Assembly : GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport

See Also

Reference

GrapeCity.ActiveReports.Export.Image Assembly


Assembly Overview

GrapeCity.ActiveReports.Export.Pdf Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Export.Pdf | The GrapeCity.ActiveReports.Export.Pdf namespace includes the Enums.ImageInterpolation enumeration.
GrapeCity.ActiveReports.Export.Pdf.Page | The GrapeCity.ActiveReports.Export.Pdf.Page namspace includes the PDF export controls.
GrapeCity.ActiveReports.Export.Pdf.Section | The GrapeCity.ActiveReports.Export.Pdf Section namespace includes PDF export filters.
GrapeCity.ActiveReports.Export.Pdf.Section.Signing | This function is only supported in the Professional version. In the Standard version, a banner indicating that a Professional license is required to output the PDF, is displayed.


GrapeCity.ActiveReports.Export.Pdf.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf.Page Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf.Page Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension
GrapeCity.ActiveReports.Export.Pdf.Page.Settings

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


PdfExport Class Events

[image]
ActiveReports 13
PdfExport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

Glossary Item Box

For a list of all members of this type, see PdfExport members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExportException Class Methods

[image]
ActiveReports 13
PdfExportException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class

Glossary Item Box

For a list of all members of this type, see PdfExportException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfExportException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExportException Class Properties

[image]
ActiveReports 13
PdfExportException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class

Glossary Item Box

For a list of all members of this type, see PdfExportException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfExportException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExportException Class
PdfExportException Members


PdfExport Constructor

[image]
ActiveReports 13
PdfExport Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : PdfExport Constructor

Glossary Item Box

Overload List

Overload | Description
PdfExport Constructor | Initializes a new instance of the PdfExport class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Dispose Method

Glossary Item Box

Disposes the engine.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfExport Class
PdfExport Members


PdfSigningException Class Methods

[image]
ActiveReports 13
PdfSigningException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class

Glossary Item Box

For a list of all members of this type, see PdfSigningException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfSigningException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSigningException Class Properties

[image]
ActiveReports 13
PdfSigningException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class

Glossary Item Box

For a list of all members of this type, see PdfSigningException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfSigningException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PdfSigningException Class
PdfSigningException Members


GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfSignature
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfStamp
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<T>
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


GrapeCity.ActiveReports.Export.Pdf.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf.Section Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.PdfDocumentOptions
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSecurity
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExportException
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSigningException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


GrapeCity.ActiveReports.Export.Pdf Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Pdf Assembly : GrapeCity.ActiveReports.Export.Pdf Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.PrintPresets

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Assembly


Assembly Overview

GrapeCity.ActiveReports.Export.Word Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Export.Word |
GrapeCity.ActiveReports.Export.Word.Page | The GrapeCity.ActiveReports.Export.Word.Page namespace includes information related to Settings and Word Rendering Extension.
GrapeCity.ActiveReports.Export.Word.Section | The GrapeCity.ActiveReports.Export.Word.Section namespace contains the RTF (Rich Text Format) export classes.


GrapeCity.ActiveReports.Export.Word.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Word.Page Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly : GrapeCity.ActiveReports.Export.Word.Page Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.Page.Settings
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension

See Also

Reference

GrapeCity.ActiveReports.Export.Word Assembly


RtfExport Class Events

[image]
ActiveReports 13
RtfExport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

Glossary Item Box

For a list of all members of this type, see RtfExport members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Class Methods

[image]
ActiveReports 13
RtfExportException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class

Glossary Item Box

For a list of all members of this type, see RtfExportException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

RtfExportException Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Class Properties

[image]
ActiveReports 13
RtfExportException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class

Glossary Item Box

For a list of all members of this type, see RtfExportException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

RtfExportException Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExportException Class
RtfExportException Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RtfExport Class
RtfExport Members


GrapeCity.ActiveReports.Export.Word.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Word.Section Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly : GrapeCity.ActiveReports.Export.Word.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Word.Section.RtfExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Word.Section.RtfExport

See Also

Reference

GrapeCity.ActiveReports.Export.Word Assembly


GrapeCity.ActiveReports.Export.Word Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Word Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Word Assembly : GrapeCity.ActiveReports.Export.Word Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.WordPageSettings
GrapeCity.ActiveReports.Export.Word.WordSecurity

See Also

Reference

GrapeCity.ActiveReports.Export.Word Assembly


Assembly Overview

GrapeCity.ActiveReports.Export.Xml Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Export.Text.Page | The GrapeCity.ActiveReports.Export.Text.Page namespace includes information related to CSV Rendering Extension and JSON Rendering Extension.
GrapeCity.ActiveReports.Export.Xml.DDR.AssemblyResources |
GrapeCity.ActiveReports.Export.Xml.Page | The GrapeCity.ActiveReports.Export.Xml.Page namespace includes information related to Settings and XML Rendering Extension.
GrapeCity.ActiveReports.Export.Xml.Section | The GrapeCity.ActiveReports.Export.Xml.Section namespace contains the Text export classes.


GrapeCity.ActiveReports.Export.Text.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Text.Page Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Text.Page Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension`1.SettingsBase<TSettings>
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension.Settings
GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension.Settings
GrapeCity.ActiveReports.Export.Text.Page.RenderingExtensionBase<TSettings>
GrapeCity.ActiveReports.Export.Text.Page.ConfigurableRenderingExtension<TSettings>
GrapeCity.ActiveReports.Export.Text.Page.CsvRenderingExtension
GrapeCity.ActiveReports.Export.Text.Page.JsonRenderingExtension

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


GrapeCity.ActiveReports.Export.Xml.DDR.AssemblyResources Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Xml.DDR.AssemblyResources Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Xml.DDR.AssemblyResources Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


GetSupportedSettings Method

[image]
ActiveReports 13
GetSupportedSettings Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > XmlRenderingExtension Class : GetSupportedSettings Method

Glossary Item Box

Gets supported settings of XmlRenderingExtension.

Overload List

Overload | Description
GetSupportedSettings | Gets supported settings of XmlRenderingExtension.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlRenderingExtension Class
XmlRenderingExtension Members


GrapeCity.ActiveReports.Export.Xml.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Xml.Page Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Xml.Page Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Xml.Page.Settings
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


TextExport Class Events

[image]
ActiveReports 13
TextExport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

Glossary Item Box

For a list of all members of this type, see TextExport members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Class Methods

[image]
ActiveReports 13
TextExportException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

Glossary Item Box

For a list of all members of this type, see TextExportException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TextExportException Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Class Properties

[image]
ActiveReports 13
TextExportException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

Glossary Item Box

For a list of all members of this type, see TextExportException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TextExportException Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExportException Class
TextExportException Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextExport Class
TextExport Members


GrapeCity.ActiveReports.Export.Xml.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Xml.Section Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Export.Xml Assembly : GrapeCity.ActiveReports.Export.Xml.Section Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Xml.Section.TextExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Xml.Section.TextExport

See Also

Reference

GrapeCity.ActiveReports.Export.Xml Assembly


Assembly Overview

GrapeCity.ActiveReports.Viewer.Win Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports | The GrapeCity.ActiveReports Namespace contains the PrintExtension class.
GrapeCity.ActiveReports.Viewer.Win | The GrapeCity.ActiveReports.Viewer.Win namespace, contains the Viewer that is used to control the viewer, TocPanel, and other classes.


ParametersPanel Class Events

[image]
ActiveReports 13
ParametersPanel Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

Glossary Item Box

For a list of all members of this type, see ParametersPanel members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


SearchPanel Class Events

[image]
ActiveReports 13
SearchPanel Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

Glossary Item Box

For a list of all members of this type, see SearchPanel members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Class Methods

[image]
ActiveReports 13
ThumbnailsPanel Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

Glossary Item Box

For a list of all members of this type, see ThumbnailsPanel members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


TocPanel Class Events

[image]
ActiveReports 13
TocPanel Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

Glossary Item Box

For a list of all members of this type, see TocPanel members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Cancel Property

[image]
ActiveReports 13
Cancel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : Cancel Property

Glossary Item Box

(Inherited from System.ComponentModel.CancelEventArgs)

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


AccessibilityObject Property

[image]
ActiveReports 13
AccessibilityObject Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibilityObject Property

Glossary Item Box

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AccessibilityObject As AccessibleObject
C#
public AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AccessibleDefaultActionDescription Property

[image]
ActiveReports 13
AccessibleDefaultActionDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDefaultActionDescription As String
C#
public string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AccessibleDescription Property

[image]
ActiveReports 13
AccessibleDescription Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleDescription Property

Glossary Item Box

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleDescription As String
C#
public string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AccessibleName Property

[image]
ActiveReports 13
AccessibleName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleName Property

Glossary Item Box

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Declaration)
Public Property AccessibleName As String
C#
public string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AccessibleRole Property

[image]
ActiveReports 13
AccessibleRole Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleRole Property

Glossary Item Box

Gets or sets the accessible role of the control

Syntax

Visual Basic (Declaration)
Public Property AccessibleRole As AccessibleRole
C#
public AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ActiveControl Property

[image]
ActiveReports 13
ActiveControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ActiveControl Property

Glossary Item Box

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
Public Property ActiveControl As Control
C#
public Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Overridable Property AllowDrop As Boolean
C#
public virtual bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Anchor Property

[image]
ActiveReports 13
Anchor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Anchor Property

Glossary Item Box

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Anchor As AnchorStyles
C#
public virtual AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoScaleDimensions Property

[image]
ActiveReports 13
AutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScaleDimensions Property

Glossary Item Box

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleDimensions As SizeF
C#
public SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoScaleMode Property

[image]
ActiveReports 13
AutoScaleMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScaleMode Property

Glossary Item Box

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Declaration)
Public Property AutoScaleMode As AutoScaleMode
C#
public AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoScroll Property

[image]
ActiveReports 13
AutoScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScroll As Boolean
C#
public virtual bool AutoScroll {get; set;}

Property Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoScrollMargin Property

[image]
ActiveReports 13
AutoScrollMargin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMargin As Size
C#
public Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoScrollMinSize Property

[image]
ActiveReports 13
AutoScrollMinSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollMinSize As Size
C#
public Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoScrollOffset Property

[image]
ActiveReports 13
AutoScrollOffset Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollOffset Property

Glossary Item Box

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoScrollOffset As Point
C#
public virtual Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoScrollPosition Property

[image]
ActiveReports 13
AutoScrollPosition Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollPosition Property

Glossary Item Box

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollPosition As Point
C#
public Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoSize Property

[image]
ActiveReports 13
AutoSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoSize Property

Glossary Item Box

This property is not relevant for this class.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
C#
public virtual bool AutoSize {get; set;}

Property Value

true if enabled; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoSizeChanged Event

[image]
ActiveReports 13
AutoSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoSizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoSize property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoSizeChanged As EventHandler
C#
public event EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoSizeMode Property

[image]
ActiveReports 13
AutoSizeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoSizeMode Property

Glossary Item Box

Gets or sets how the control will resize itself.

Syntax

Visual Basic (Declaration)
Public Property AutoSizeMode As AutoSizeMode
C#
public AutoSizeMode AutoSizeMode {get; set;}

Property Value

A value from the System.Windows.Forms.AutoSizeMode enumeration. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoValidate Property

[image]
ActiveReports 13
AutoValidate Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoValidate Property

Glossary Item Box

Gets or sets how the control performs validation when the user changes focus to another control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoValidate As AutoValidate
C#
public virtual AutoValidate AutoValidate {get; set;}

Property Value

A member of the System.Windows.Forms.AutoValidate enumeration. The default value for System.Windows.Forms.UserControl is System.Windows.Forms.AutoValidate.EnablePreventFocusChange.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AutoValidateChanged Event

[image]
ActiveReports 13
AutoValidateChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoValidateChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes.

Syntax

Visual Basic (Declaration)
Public Event AutoValidateChanged As EventHandler
C#
public event EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BackColorChanged Event

[image]
ActiveReports 13
BackColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackColorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged As EventHandler
C#
public event EventHandler BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BackgroundImage Property

[image]
ActiveReports 13
BackgroundImage Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImage As Image
C#
public virtual Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BackgroundImageChanged Event

[image]
ActiveReports 13
BackgroundImageChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImageChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged As EventHandler
C#
public event EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BackgroundImageLayout Property

[image]
ActiveReports 13
BackgroundImageLayout Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackgroundImageLayout As ImageLayout
C#
public virtual ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BackgroundImageLayoutChanged Event

[image]
ActiveReports 13
BackgroundImageLayoutChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged As EventHandler
C#
public event EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BeginInvoke Method

[image]
ActiveReports 13
BeginInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BeginInvoke Method

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BeginInvoke(Delegate) Method

[image]
ActiveReports 13
BeginInvoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.

Glossary Item Box

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
ActiveReports 13
BeginInvoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Glossary Item Box

Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginInvoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As IAsyncResult
C#
public IAsyncResult BeginInvoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be a null reference (Nothing in Visual Basic) if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BindingContext Property

[image]
ActiveReports 13
BindingContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BindingContext Property

Glossary Item Box

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BindingContext As BindingContext
C#
public virtual BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BindingContextChanged Event

[image]
ActiveReports 13
BindingContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BindingContextChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged As EventHandler
C#
public event EventHandler BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BorderStyle Property

[image]
ActiveReports 13
BorderStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BorderStyle Property

Glossary Item Box

Gets or sets the border style of the user control.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
C#
public BorderStyle BorderStyle {get; set;}

Property Value

One of the System.Windows.Forms.BorderStyle values. The default is System.Windows.Forms.BorderStyle.Fixed3D.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.BorderStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Bottom Property

[image]
ActiveReports 13
Bottom Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Bottom Property

Glossary Item Box

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
C#
public int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Bounds Property

[image]
ActiveReports 13
Bounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Bounds Property

Glossary Item Box

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Rectangle
C#
public Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BringToFront Method

[image]
ActiveReports 13
BringToFront Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BringToFront Method

Glossary Item Box

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CanFocus Property

[image]
ActiveReports 13
CanFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CanFocus Property

Glossary Item Box

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanFocus As Boolean
C#
public bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CanSelect Property

[image]
ActiveReports 13
CanSelect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CanSelect Property

Glossary Item Box

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanSelect As Boolean
C#
public bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Capture Property

[image]
ActiveReports 13
Capture Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Capture Property

Glossary Item Box

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Declaration)
Public Property Capture As Boolean
C#
public bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CausesValidation Property

[image]
ActiveReports 13
CausesValidation Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CausesValidation Property

Glossary Item Box

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Declaration)
Public Property CausesValidation As Boolean
C#
public bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CausesValidationChanged Event

[image]
ActiveReports 13
CausesValidationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CausesValidationChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Declaration)
Public Event CausesValidationChanged As EventHandler
C#
public event EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ChangeUICues Event

[image]
ActiveReports 13
ChangeUICues Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ChangeUICues Event

Glossary Item Box

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Declaration)
Public Event ChangeUICues As UICuesEventHandler
C#
public event UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Click Event

[image]
ActiveReports 13
Click Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Click Event

Glossary Item Box

Occurs when the control is clicked.

Syntax

Visual Basic (Declaration)
Public Event Click As EventHandler
C#
public event EventHandler Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ClientRectangle Property

[image]
ActiveReports 13
ClientRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ClientRectangle Property

Glossary Item Box

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As Rectangle
C#
public Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ClientSize Property

[image]
ActiveReports 13
ClientSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ClientSize Property

Glossary Item Box

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Declaration)
Public Property ClientSize As Size
C#
public Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ClientSizeChanged Event

[image]
ActiveReports 13
ClientSizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ClientSizeChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Declaration)
Public Event ClientSizeChanged As EventHandler
C#
public event EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CompanyName Property

[image]
ActiveReports 13
CompanyName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CompanyName Property

Glossary Item Box

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompanyName As String
C#
public string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.

Glossary Item Box

Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As Control _
) As Boolean
C#
public bool Contains(
   Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContainsFocus Property

[image]
ActiveReports 13
ContainsFocus Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContainsFocus Property

Glossary Item Box

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsFocus As Boolean
C#
public bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenu Property

Glossary Item Box

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenu As ContextMenu
C#
public virtual ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContextMenuChanged Event

[image]
ActiveReports 13
ContextMenuChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenuChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuChanged As EventHandler
C#
public event EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContextMenuStrip Property

[image]
ActiveReports 13
ContextMenuStrip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenuStrip Property

Glossary Item Box

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ContextMenuStrip As ContextMenuStrip
C#
public virtual ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or a null reference (Nothing in Visual Basic) if there is no System.Windows.Forms.ContextMenuStrip. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContextMenuStripChanged Event

[image]
ActiveReports 13
ContextMenuStripChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenuStripChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuStripChanged As EventHandler
C#
public event EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ControlAdded Event

[image]
ActiveReports 13
ControlAdded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ControlAdded Event

Glossary Item Box

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded As ControlEventHandler
C#
public event ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ControlRemoved Event

[image]
ActiveReports 13
ControlRemoved Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ControlRemoved Event

Glossary Item Box

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved As ControlEventHandler
C#
public event ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Controls Property

Glossary Item Box

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controls As Control.ControlCollection
C#
public Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CreateControl Method

[image]
ActiveReports 13
CreateControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateControl Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CreateControl() Method

[image]
ActiveReports 13
CreateControl() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateControl() Method

Glossary Item Box

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Created Property

[image]
ActiveReports 13
Created Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Created Property

Glossary Item Box

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created As Boolean
C#
public bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CreateGraphics Method

[image]
ActiveReports 13
CreateGraphics Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateGraphics Method

Glossary Item Box

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As Graphics
C#
public Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CurrentAutoScaleDimensions Property

[image]
ActiveReports 13
CurrentAutoScaleDimensions Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
C#
public SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Cursor As Cursor
C#
public virtual Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CursorChanged Event

[image]
ActiveReports 13
CursorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CursorChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged As EventHandler
C#
public event EventHandler CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DataBindings Property

[image]
ActiveReports 13
DataBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DataBindings Property

Glossary Item Box

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ControlBindingsCollection
C#
public ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DeviceDpi Property

[image]
ActiveReports 13
DeviceDpi Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DeviceDpi Property

Glossary Item Box

Gets the DPI value for the display device where the control is currently being displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceDpi As Integer
C#
public int DeviceDpi {get;}

Property Value

The DPI value of the display device.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DisplayRectangle Property

[image]
ActiveReports 13
DisplayRectangle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DisplayRectangle Property

Glossary Item Box

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As Rectangle
C#
public virtual Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Disposing Property

[image]
ActiveReports 13
Disposing Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Disposing Property

Glossary Item Box

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposing As Boolean
C#
public bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Dock Property

[image]
ActiveReports 13
Dock Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Dock Property

Glossary Item Box

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Declaration)
Public Overridable Property Dock As DockStyle
C#
public virtual DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DockChanged Event

[image]
ActiveReports 13
DockChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DockChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Declaration)
Public Event DockChanged As EventHandler
C#
public event EventHandler DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DoDragDrop Method

[image]
ActiveReports 13
DoDragDrop Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Glossary Item Box

Begins a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Function DoDragDrop( _
   ByVal data As Object, _
   ByVal allowedEffects As DragDropEffects _
) As DragDropEffects
C#
public DragDropEffects DoDragDrop(
   object data,
   DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DoubleClick Event

[image]
ActiveReports 13
DoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DoubleClick Event

Glossary Item Box

Occurs when the control is double-clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick As EventHandler
C#
public event EventHandler DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DpiChangedAfterParent Event

[image]
ActiveReports 13
DpiChangedAfterParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DpiChangedAfterParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedAfterParent As EventHandler
C#
public event EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DpiChangedBeforeParent Event

[image]
ActiveReports 13
DpiChangedBeforeParent Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DpiChangedBeforeParent Event

Glossary Item Box

Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred.

Syntax

Visual Basic (Declaration)
Public Event DpiChangedBeforeParent As EventHandler
C#
public event EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DragDrop Event

[image]
ActiveReports 13
DragDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragDrop Event

Glossary Item Box

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
Public Event DragDrop As DragEventHandler
C#
public event DragEventHandler DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragEnter Event

Glossary Item Box

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragLeave Event

Glossary Item Box

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As EventHandler
C#
public event EventHandler DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragOver Event

Glossary Item Box

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DrawToBitmap Method

[image]
ActiveReports 13
DrawToBitmap Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Glossary Item Box

Supports rendering to the specified bitmap.

Syntax

Visual Basic (Declaration)
Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
C#
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


EnabledChanged Event

[image]
ActiveReports 13
EnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : EnabledChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Declaration)
Public Event EnabledChanged As EventHandler
C#
public event EventHandler EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


EndInvoke Method

[image]
ActiveReports 13
EndInvoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Glossary Item Box

Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Declaration)
Public Function EndInvoke( _
   ByVal asyncResult As IAsyncResult _
) As Object
C#
public object EndInvoke(
   IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is a null reference (Nothing in Visual Basic).
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Enter Event

[image]
ActiveReports 13
Enter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Enter Event

Glossary Item Box

Occurs when the control is entered.

Syntax

Visual Basic (Declaration)
Public Event Enter As EventHandler
C#
public event EventHandler Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FindForm Method

[image]
ActiveReports 13
FindForm Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : FindForm Method

Glossary Item Box

Retrieves the form that the control is on.

Syntax

Visual Basic (Declaration)
Public Function FindForm() As Form
C#
public Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Focus Method

Glossary Item Box

Sets input focus to the control.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Focused Property

[image]
ActiveReports 13
Focused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Focused Property

Glossary Item Box

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Focused As Boolean
C#
public virtual bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Font Property

Glossary Item Box

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
C#
public virtual Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FontChanged Event

[image]
ActiveReports 13
FontChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : FontChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged As EventHandler
C#
public event EventHandler FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ForeColorChanged Event

[image]
ActiveReports 13
ForeColorChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ForeColorChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged As EventHandler
C#
public event EventHandler ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetChildAtPoint Method

[image]
ActiveReports 13
GetChildAtPoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetChildAtPoint Method

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetChildAtPoint(Point) Method

[image]
ActiveReports 13
GetChildAtPoint(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As Control
C#
public Control GetChildAtPoint(
   Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
ActiveReports 13
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Glossary Item Box

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As GetChildAtPointSkip _
) As Control
C#
public Control GetChildAtPoint(
   Point pt,
   GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


GetContainerControl Method

[image]
ActiveReports 13
GetContainerControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetContainerControl Method

Glossary Item Box

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As IContainerControl
C#
public IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetNextControl Method

[image]
ActiveReports 13
GetNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Glossary Item Box

Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetPreferredSize Method

[image]
ActiveReports 13
GetPreferredSize Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.

Glossary Item Box

Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
C#
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GiveFeedback Event

Glossary Item Box

Occurs during a drag operation.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GotFocus Event

Glossary Item Box

Occurs when the control receives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As EventHandler
C#
public event EventHandler GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Handle Property

[image]
ActiveReports 13
Handle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Handle Property

Glossary Item Box

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HandleCreated Event

[image]
ActiveReports 13
HandleCreated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HandleCreated Event

Glossary Item Box

Occurs when a handle is created for the control.

Syntax

Visual Basic (Declaration)
Public Event HandleCreated As EventHandler
C#
public event EventHandler HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HandleDestroyed Event

[image]
ActiveReports 13
HandleDestroyed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HandleDestroyed Event

Glossary Item Box

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Declaration)
Public Event HandleDestroyed As EventHandler
C#
public event EventHandler HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HasChildren Property

[image]
ActiveReports 13
HasChildren Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HasChildren Property

Glossary Item Box

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
C#
public bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Height Property

Glossary Item Box

Gets or sets the height of the control.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
C#
public int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HelpRequested Event

[image]
ActiveReports 13
HelpRequested Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HelpRequested Event

Glossary Item Box

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
Public Event HelpRequested As HelpEventHandler
C#
public event HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Hide Method

[image]
ActiveReports 13
Hide Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Hide Method

Glossary Item Box

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HorizontalScroll Property

[image]
ActiveReports 13
HorizontalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HorizontalScroll Property

Glossary Item Box

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalScroll As HScrollProperties
C#
public HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ImeMode Property

[image]
ActiveReports 13
ImeMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ImeMode Property

Glossary Item Box

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Declaration)
Public Property ImeMode As ImeMode
C#
public ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ImeModeChanged Event

[image]
ActiveReports 13
ImeModeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ImeModeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Declaration)
Public Event ImeModeChanged As EventHandler
C#
public event EventHandler ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function InitializeLifetimeService() As Object
C#
public virtual object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Invalidate Method

[image]
ActiveReports 13
Invalidate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Invalidate Method

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Invalidate() Method

[image]
ActiveReports 13
Invalidate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Boolean) Method

[image]
ActiveReports 13
Invalidate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Rectangle) Method

[image]
ActiveReports 13
Invalidate(Rectangle) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
C#
public void Invalidate(
   Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
ActiveReports 13
Invalidate(Rectangle,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Rectangle rc,
   bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Region) Method

[image]
ActiveReports 13
Invalidate(Region) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
C#
public void Invalidate(
   Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Region,Boolean) Method

[image]
ActiveReports 13
Invalidate(Region,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Glossary Item Box

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As Boolean _
)
C#
public void Invalidate(
   Region region,
   bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidated Event

[image]
ActiveReports 13
Invalidated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Invalidated Event

Glossary Item Box

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
C#
public event InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Invoke Method

[image]
ActiveReports 13
Invoke Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Invoke Method

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Invoke(Delegate) Method

[image]
ActiveReports 13
Invoke(Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.

Glossary Item Box

Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate _
) As Object
C#
public object Invoke(
   Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
ActiveReports 13
Invoke(Delegate,Object[]) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Glossary Item Box

Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As Delegate, _
   ByVal ParamArray args() As Object _
) As Object
C#
public object Invoke(
   Delegate method,
   params object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be a null reference (Nothing in Visual Basic) if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or a null reference (Nothing in Visual Basic) if the delegate has no return value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


InvokeRequired Property

[image]
ActiveReports 13
InvokeRequired Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : InvokeRequired Property

Glossary Item Box

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvokeRequired As Boolean
C#
public bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsAccessible Property

[image]
ActiveReports 13
IsAccessible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsAccessible Property

Glossary Item Box

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Property IsAccessible As Boolean
C#
public bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsDisposed Property

[image]
ActiveReports 13
IsDisposed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsDisposed Property

Glossary Item Box

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsHandleCreated Property

[image]
ActiveReports 13
IsHandleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsHandleCreated Property

Glossary Item Box

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHandleCreated As Boolean
C#
public bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMirrored Property

[image]
ActiveReports 13
IsMirrored Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsMirrored Property

Glossary Item Box

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMirrored As Boolean
C#
public bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


KeyPress Event

[image]
ActiveReports 13
KeyPress Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : KeyPress Event

Glossary Item Box

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyPress As KeyPressEventHandler
C#
public event KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Layout Event

[image]
ActiveReports 13
Layout Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Layout Event

Glossary Item Box

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Declaration)
Public Event Layout As LayoutEventHandler
C#
public event LayoutEventHandler Layout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LayoutEngine Property

[image]
ActiveReports 13
LayoutEngine Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LayoutEngine Property

Glossary Item Box

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Leave Event

[image]
ActiveReports 13
Leave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Leave Event

Glossary Item Box

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Declaration)
Public Event Leave As EventHandler
C#
public event EventHandler Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Left Property

[image]
ActiveReports 13
Left Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Left Property

Glossary Item Box

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Left As Integer
C#
public int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Load Event

Glossary Item Box

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Location Property

[image]
ActiveReports 13
Location Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Location Property

Glossary Item Box

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Declaration)
Public Property Location As Point
C#
public Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LocationChanged Event

[image]
ActiveReports 13
LocationChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LocationChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged As EventHandler
C#
public event EventHandler LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LogicalToDeviceUnits Method

[image]
ActiveReports 13
LogicalToDeviceUnits Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LogicalToDeviceUnits Method

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Overload List

Overload | Description
LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from System.Windows.Forms.Control)
LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LogicalToDeviceUnits(Int32) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Int32) Method

value
The Logical value to convert.

Glossary Item Box

Converts a Logical DPI value to its equivalent DeviceUnit DPI value.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Integer _
) As Integer
C#
public int LogicalToDeviceUnits(
   int value
)

Parameters

value
The Logical value to convert.

Return Value

The resulting DeviceUnit value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LogicalToDeviceUnits(Size) Method

[image]
ActiveReports 13
LogicalToDeviceUnits(Size) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LogicalToDeviceUnits Method : LogicalToDeviceUnits(Size) Method

value
The size to be scaled.

Glossary Item Box

Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height.

Syntax

Visual Basic (Declaration)
Public Overloads Function LogicalToDeviceUnits( _
   ByVal value As Size _
) As Size
C#
public Size LogicalToDeviceUnits(
   Size value
)

Parameters

value
The size to be scaled.

Return Value

The scaled size.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LostFocus Event

Glossary Item Box

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As EventHandler
C#
public event EventHandler LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Property Margin As Padding
C#
public Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MarginChanged Event

[image]
ActiveReports 13
MarginChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MarginChanged Event

Glossary Item Box

Occurs when the control's margin changes.

Syntax

Visual Basic (Declaration)
Public Event MarginChanged As EventHandler
C#
public event EventHandler MarginChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MaximumSize Property

[image]
ActiveReports 13
MaximumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MaximumSize Property

Glossary Item Box

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
C#
public virtual Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MinimumSize Property

[image]
ActiveReports 13
MinimumSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MinimumSize Property

Glossary Item Box

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
C#
public virtual Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseCaptureChanged Event

[image]
ActiveReports 13
MouseCaptureChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseCaptureChanged Event

Glossary Item Box

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event MouseCaptureChanged As EventHandler
C#
public event EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseClick Event

[image]
ActiveReports 13
MouseClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseClick Event

Glossary Item Box

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler
C#
public event MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseDoubleClick Event

Glossary Item Box

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler
C#
public event MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseDown Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
C#
public event MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As EventHandler
C#
public event EventHandler MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseHover Event

[image]
ActiveReports 13
MouseHover Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseHover Event

Glossary Item Box

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Declaration)
Public Event MouseHover As EventHandler
C#
public event EventHandler MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As EventHandler
C#
public event EventHandler MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseUp Event

Glossary Item Box

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
C#
public event MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseWheel Event

Glossary Item Box

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseEventHandler
C#
public event MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Move Event

[image]
ActiveReports 13
Move Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Move Event

Glossary Item Box

Occurs when the control is moved.

Syntax

Visual Basic (Declaration)
Public Event Move As EventHandler
C#
public event EventHandler Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Name Property

Glossary Item Box

Gets or sets the name of the control.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Padding Property

Glossary Item Box

Gets or sets padding within the control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Padding
C#
public Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PaddingChanged Event

[image]
ActiveReports 13
PaddingChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PaddingChanged Event

Glossary Item Box

Occurs when the control's padding changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged As EventHandler
C#
public event EventHandler PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Paint Event

[image]
ActiveReports 13
Paint Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Paint Event

Glossary Item Box

Occurs when the control is redrawn.

Syntax

Visual Basic (Declaration)
Public Event Paint As PaintEventHandler
C#
public event PaintEventHandler Paint

Event Data

The event handler receives an argument of type PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Parent Property

Glossary Item Box

Gets or sets the parent container of the control.

Syntax

Visual Basic (Declaration)
Public Property Parent As Control
C#
public Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ParentChanged Event

[image]
ActiveReports 13
ParentChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ParentChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Declaration)
Public Event ParentChanged As EventHandler
C#
public event EventHandler ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ParentForm Property

[image]
ActiveReports 13
ParentForm Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ParentForm Property

Glossary Item Box

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentForm As Form
C#
public Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PerformAutoScale Method

[image]
ActiveReports 13
PerformAutoScale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PerformAutoScale Method

Glossary Item Box

Performs scaling of the container control and its children.

Syntax

Visual Basic (Declaration)
Public Sub PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PerformLayout Method

[image]
ActiveReports 13
PerformLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PerformLayout Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PerformLayout() Method

[image]
ActiveReports 13
PerformLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


PerformLayout(Control,String) Method

[image]
ActiveReports 13
PerformLayout(Control,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Glossary Item Box

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
C#
public void PerformLayout(
   Control affectedControl,
   string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


PointToClient Method

[image]
ActiveReports 13
PointToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToClient( _
   ByVal p As Point _
) As Point
C#
public Point PointToClient(
   Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.

Glossary Item Box

Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As Point _
) As Point
C#
public Point PointToScreen(
   Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreferredSize Property

[image]
ActiveReports 13
PreferredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreferredSize Property

Glossary Item Box

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreferredSize As Size
C#
public Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreProcessControlMessage Method

[image]
ActiveReports 13
PreProcessControlMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Function PreProcessControlMessage( _
   ByRef msg As Message _
) As PreProcessControlState
C#
public PreProcessControlState PreProcessControlMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreProcessMessage Method

[image]
ActiveReports 13
PreProcessMessage Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Glossary Item Box

Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Declaration)
Public Overridable Function PreProcessMessage( _
   ByRef msg As Message _
) As Boolean
C#
public virtual bool PreProcessMessage(
   ref Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreviewKeyDown Event

Glossary Item Box

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As PreviewKeyDownEventHandler
C#
public event PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key code combined with key modifiers such as the SHIFT, CONTROL, and ALT keys for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ProductName Property

[image]
ActiveReports 13
ProductName Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ProductName Property

Glossary Item Box

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductName As String
C#
public string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ProductVersion Property

[image]
ActiveReports 13
ProductVersion Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ProductVersion Property

Glossary Item Box

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductVersion As String
C#
public string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


QueryAccessibilityHelp Event

[image]
ActiveReports 13
QueryAccessibilityHelp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : QueryAccessibilityHelp Event

Glossary Item Box

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Declaration)
Public Event QueryAccessibilityHelp As QueryAccessibilityHelpEventHandler
C#
public event QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : QueryContinueDrag Event

Glossary Item Box

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RecreatingHandle Property

[image]
ActiveReports 13
RecreatingHandle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RecreatingHandle Property

Glossary Item Box

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecreatingHandle As Boolean
C#
public bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RectangleToClient Method

[image]
ActiveReports 13
RectangleToClient Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RectangleToScreen Method

[image]
ActiveReports 13
RectangleToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.

Glossary Item Box

Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
C#
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Refresh Method

[image]
ActiveReports 13
Refresh Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Refresh Method

Glossary Item Box

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Region Property

[image]
ActiveReports 13
Region Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Region Property

Glossary Item Box

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Declaration)
Public Property Region As Region
C#
public Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RegionChanged Event

[image]
ActiveReports 13
RegionChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RegionChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Declaration)
Public Event RegionChanged As EventHandler
C#
public event EventHandler RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ResetText Method

[image]
ActiveReports 13
ResetText Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ResetText Method

Glossary Item Box

Resets the System.Windows.Forms.Control.Text property to its default value (System.String.Empty).

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Resize Event

[image]
ActiveReports 13
Resize Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Resize Event

Glossary Item Box

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize As EventHandler
C#
public event EventHandler Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ResumeLayout Method

[image]
ActiveReports 13
ResumeLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ResumeLayout Method

Glossary Item Box

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ResumeLayout() Method

[image]
ActiveReports 13
ResumeLayout() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Resumes usual layout logic.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


ResumeLayout(Boolean) Method

[image]
ActiveReports 13
ResumeLayout(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.

Glossary Item Box

Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
C#
public void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Right Property

[image]
ActiveReports 13
Right Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Right Property

Glossary Item Box

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
C#
public int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RightToLeft Property

[image]
ActiveReports 13
RightToLeft Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Overridable Property RightToLeft As RightToLeft
C#
public virtual RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RightToLeftChanged Event

[image]
ActiveReports 13
RightToLeftChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RightToLeftChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Declaration)
Public Event RightToLeftChanged As EventHandler
C#
public event EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Scale Method

[image]
ActiveReports 13
Scale Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Scale Method

Glossary Item Box

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Scale(SizeF) Method

[image]
ActiveReports 13
Scale(SizeF) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Glossary Item Box

Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
C#
public void Scale(
   SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


ScaleBitmapLogicalToDevice Method

[image]
ActiveReports 13
ScaleBitmapLogicalToDevice Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ScaleBitmapLogicalToDevice Method

logicalBitmap
The bitmap to scale.

Glossary Item Box

Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs.

Syntax

Visual Basic (Declaration)
Public Sub ScaleBitmapLogicalToDevice( _
   ByRef logicalBitmap As Bitmap _
)
C#
public void ScaleBitmapLogicalToDevice(
   ref Bitmap logicalBitmap
)

Parameters

logicalBitmap
The bitmap to scale.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Scroll Event

[image]
ActiveReports 13
Scroll Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Scroll Event

Glossary Item Box

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler
C#
public event ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ScrollControlIntoView Method

[image]
ActiveReports 13
ScrollControlIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.

Glossary Item Box

Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
C#
public void ScrollControlIntoView(
   Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Select Method

[image]
ActiveReports 13
Select Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Select Method

Glossary Item Box

Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Select() Method

[image]
ActiveReports 13
Select() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Select() Method

Glossary Item Box

Activates the control.

Syntax

Visual Basic (Declaration)
Public Sub Select()
C#
public void Select()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SelectNextControl Method

[image]
ActiveReports 13
SelectNextControl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Glossary Item Box

Activates the next control.

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean, _
   ByVal tabStopOnly As Boolean, _
   ByVal nested As Boolean, _
   ByVal wrap As Boolean _
) As Boolean
C#
public bool SelectNextControl(
   Control ctl,
   bool forward,
   bool tabStopOnly,
   bool nested,
   bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SendToBack Method

[image]
ActiveReports 13
SendToBack Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SendToBack Method

Glossary Item Box

Sends the control to the back of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetAutoScrollMargin Method

[image]
ActiveReports 13
SetAutoScrollMargin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Glossary Item Box

Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
C#
public void SetAutoScrollMargin(
   int x,
   int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetBounds Method

[image]
ActiveReports 13
SetBounds Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SetBounds Method

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Glossary Item Box

Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
ActiveReports 13
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Glossary Item Box

Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
C#
public void SetBounds(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Show Method

[image]
ActiveReports 13
Show Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Show Method

Glossary Item Box

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Sub Show()
C#
public void Show()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Site Property

Glossary Item Box

Gets or sets the site of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Site As ISite
C#
public virtual ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Size Property

[image]
ActiveReports 13
Size Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Size Property

Glossary Item Box

Gets or sets the height and width of the control.

Syntax

Visual Basic (Declaration)
Public Property Size As Size
C#
public Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SizeChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
C#
public event EventHandler SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StyleChanged Event

[image]
ActiveReports 13
StyleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : StyleChanged Event

Glossary Item Box

Occurs when the control style changes.

Syntax

Visual Basic (Declaration)
Public Event StyleChanged As EventHandler
C#
public event EventHandler StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SuspendLayout Method

[image]
ActiveReports 13
SuspendLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SuspendLayout Method

Glossary Item Box

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SystemColorsChanged Event

[image]
ActiveReports 13
SystemColorsChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SystemColorsChanged Event

Glossary Item Box

Occurs when the system colors change.

Syntax

Visual Basic (Declaration)
Public Event SystemColorsChanged As EventHandler
C#
public event EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabIndex Property

Glossary Item Box

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TabIndexChanged Event

[image]
ActiveReports 13
TabIndexChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabIndexChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabIndexChanged As EventHandler
C#
public event EventHandler TabIndexChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TabStop Property

[image]
ActiveReports 13
TabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabStop Property

Glossary Item Box

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
C#
public bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true. This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TabStopChanged Event

[image]
ActiveReports 13
TabStopChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabStopChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Declaration)
Public Event TabStopChanged As EventHandler
C#
public event EventHandler TabStopChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Tag Property

Glossary Item Box

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Top Property

[image]
ActiveReports 13
Top Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Top Property

Glossary Item Box

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Declaration)
Public Property Top As Integer
C#
public int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TopLevelControl Property

[image]
ActiveReports 13
TopLevelControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TopLevelControl Property

Glossary Item Box

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TopLevelControl As Control
C#
public Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Update Method

[image]
ActiveReports 13
Update Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Update Method

Glossary Item Box

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UseWaitCursor Property

[image]
ActiveReports 13
UseWaitCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Property UseWaitCursor As Boolean
C#
public bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Validate Method

[image]
ActiveReports 13
Validate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Validate Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Validate() Method

[image]
ActiveReports 13
Validate() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Validate Method : Validate() Method

Glossary Item Box

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate() As Boolean
C#
public bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Validate(Boolean) Method

[image]
ActiveReports 13
Validate(Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Glossary Item Box

Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As Boolean _
) As Boolean
C#
public bool Validate(
   bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


ValidateChildren Method

[image]
ActiveReports 13
ValidateChildren Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ValidateChildren Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.UserControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ValidateChildren() Method

[image]
ActiveReports 13
ValidateChildren() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren() As Boolean
C#
public virtual bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
ActiveReports 13
ValidateChildren(ValidationConstraints) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Glossary Item Box

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As ValidationConstraints _
) As Boolean
C#
public virtual bool ValidateChildren(
   ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Validated Event

[image]
ActiveReports 13
Validated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Validated Event

Glossary Item Box

Occurs when the control is finished validating.

Syntax

Visual Basic (Declaration)
Public Event Validated As EventHandler
C#
public event EventHandler Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Validating Event

[image]
ActiveReports 13
Validating Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Validating Event

Glossary Item Box

Occurs when the control is validating.

Syntax

Visual Basic (Declaration)
Public Event Validating As CancelEventHandler
C#
public event CancelEventHandler Validating

Event Data

The event handler receives an argument of type CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


VerticalScroll Property

[image]
ActiveReports 13
VerticalScroll Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : VerticalScroll Property

Glossary Item Box

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalScroll As VScrollProperties
C#
public VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Visible Property

Glossary Item Box

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


VisibleChanged Event

[image]
ActiveReports 13
VisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : VisibleChanged Event

Glossary Item Box

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
Public Event VisibleChanged As EventHandler
C#
public event EventHandler VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Width Property

Glossary Item Box

Gets or sets the width of the control.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GrapeCity.ActiveReports.Viewer.Win Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Viewer.Win Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly : GrapeCity.ActiveReports.Viewer.Win Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Viewer.Win.ReportParameter
GrapeCity.ActiveReports.Viewer.Win.Viewer.ViewerToolbar
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.FindEventArgs
GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs
GrapeCity.ActiveReports.Viewer.Win.ZoomChangedEventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Win.Viewer.ActionEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.Sidebar
GrapeCity.ActiveReports.Viewer.Win.SidebarPanel
GrapeCity.ActiveReports.Viewer.Win.ParametersPanel
GrapeCity.ActiveReports.Viewer.Win.SearchPanel
GrapeCity.ActiveReports.Viewer.Win.ThumbnailsPanel
GrapeCity.ActiveReports.Viewer.Win.TocPanel
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Viewer.Win.Viewer

See Also

Reference

GrapeCity.ActiveReports.Viewer.Win Assembly


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win) Inheritance Hierarchy

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Win Assembly : GrapeCity.ActiveReports Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PrintExtension

See Also

Reference

GrapeCity.ActiveReports.Viewer.Win Assembly


Assembly Overview

GrapeCity.ActiveReports.Viewer.Wpf Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Viewer.Wpf | The GrapeCity.ActiveReports.Viewer.Wpf namepace contains the WPF viewer control and related types.
GrapeCity.Viewer.Common | The GrapeCity.Viewer.Common Namespace contains the IHistoryApi interface.


ClearValue Method

[image]
ActiveReports 13
ClearValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : ClearValue Method

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Overload List

Overload | Description
ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ClearValue(DependencyProperty) Method

[image]
ActiveReports 13
ClearValue(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

[image]
ActiveReports 13
ClearValue(DependencyPropertyKey) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.

Glossary Item Box

Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal key As DependencyPropertyKey _
)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


CoerceValue Method

[image]
ActiveReports 13
CoerceValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.

Glossary Item Box

Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Sub CoerceValue( _
   ByVal dp As DependencyProperty _
)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


DependencyObjectType Property

[image]
ActiveReports 13
DependencyObjectType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : DependencyObjectType Property

Glossary Item Box

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyObjectType As DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


Dispatcher Property

[image]
ActiveReports 13
Dispatcher Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Dispatcher Property

Glossary Item Box

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dispatcher As Dispatcher
C#
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : GetHashCode Method

Glossary Item Box

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


InvalidateProperty Method

[image]
ActiveReports 13
InvalidateProperty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : InvalidateProperty Method

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Overload List

Overload | Description
InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


InvalidateProperty(DependencyProperty) Method

[image]
ActiveReports 13
InvalidateProperty(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Declaration)
Public Sub InvalidateProperty( _
   ByVal dp As DependencyProperty _
)
C#
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


IsSealed Property

[image]
ActiveReports 13
IsSealed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : IsSealed Property

Glossary Item Box

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ReadLocalValue Method

[image]
ActiveReports 13
ReadLocalValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Declaration)
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetCurrentValue Method

[image]
ActiveReports 13
SetCurrentValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : SetCurrentValue Method

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Overload List

Overload | Description
SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetCurrentValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetCurrentValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : SetValue Method

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Overload List

Overload | Description
SetValue(DependencyProperty,Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

[image]
ActiveReports 13
SetValue(DependencyPropertyKey,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal key As DependencyPropertyKey, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


ClearValue Method

[image]
ActiveReports 13
ClearValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : ClearValue Method

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Overload List

Overload | Description
ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


ClearValue(DependencyProperty) Method

[image]
ActiveReports 13
ClearValue(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

[image]
ActiveReports 13
ClearValue(DependencyPropertyKey) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.

Glossary Item Box

Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal key As DependencyPropertyKey _
)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


CoerceValue Method

[image]
ActiveReports 13
CoerceValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.

Glossary Item Box

Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Sub CoerceValue( _
   ByVal dp As DependencyProperty _
)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


DependencyObjectType Property

[image]
ActiveReports 13
DependencyObjectType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : DependencyObjectType Property

Glossary Item Box

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyObjectType As DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Dispatcher Property

[image]
ActiveReports 13
Dispatcher Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Dispatcher Property

Glossary Item Box

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dispatcher As Dispatcher
C#
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : GetHashCode Method

Glossary Item Box

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


InvalidateProperty Method

[image]
ActiveReports 13
InvalidateProperty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : InvalidateProperty Method

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Overload List

Overload | Description
InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


InvalidateProperty(DependencyProperty) Method

[image]
ActiveReports 13
InvalidateProperty(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Declaration)
Public Sub InvalidateProperty( _
   ByVal dp As DependencyProperty _
)
C#
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


IsSealed Property

[image]
ActiveReports 13
IsSealed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : IsSealed Property

Glossary Item Box

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


ReadLocalValue Method

[image]
ActiveReports 13
ReadLocalValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Declaration)
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


SetCurrentValue Method

[image]
ActiveReports 13
SetCurrentValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : SetCurrentValue Method

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Overload List

Overload | Description
SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


SetCurrentValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetCurrentValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : SetValue Method

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Overload List

Overload | Description
SetValue(DependencyProperty,Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members


SetValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

[image]
ActiveReports 13
SetValue(DependencyPropertyKey,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal key As DependencyPropertyKey, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


ClearValue Method

[image]
ActiveReports 13
ClearValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : ClearValue Method

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Overload List

Overload | Description
ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


ClearValue(DependencyProperty) Method

[image]
ActiveReports 13
ClearValue(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

[image]
ActiveReports 13
ClearValue(DependencyPropertyKey) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.

Glossary Item Box

Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal key As DependencyPropertyKey _
)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


CoerceValue Method

[image]
ActiveReports 13
CoerceValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.

Glossary Item Box

Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Sub CoerceValue( _
   ByVal dp As DependencyProperty _
)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


DependencyObjectType Property

[image]
ActiveReports 13
DependencyObjectType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : DependencyObjectType Property

Glossary Item Box

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyObjectType As DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


Dispatcher Property

[image]
ActiveReports 13
Dispatcher Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Dispatcher Property

Glossary Item Box

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dispatcher As Dispatcher
C#
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : GetHashCode Method

Glossary Item Box

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


InvalidateProperty Method

[image]
ActiveReports 13
InvalidateProperty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : InvalidateProperty Method

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Overload List

Overload | Description
InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


InvalidateProperty(DependencyProperty) Method

[image]
ActiveReports 13
InvalidateProperty(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Declaration)
Public Sub InvalidateProperty( _
   ByVal dp As DependencyProperty _
)
C#
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


IsSealed Property

[image]
ActiveReports 13
IsSealed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : IsSealed Property

Glossary Item Box

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


ReadLocalValue Method

[image]
ActiveReports 13
ReadLocalValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Declaration)
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetCurrentValue Method

[image]
ActiveReports 13
SetCurrentValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : SetCurrentValue Method

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Overload List

Overload | Description
SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetCurrentValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetCurrentValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : SetValue Method

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Overload List

Overload | Description
SetValue(DependencyProperty,Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

[image]
ActiveReports 13
SetValue(DependencyPropertyKey,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal key As DependencyPropertyKey, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


ClearValue Method

[image]
ActiveReports 13
ClearValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ClearValue Method

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Overload List

Overload | Description
ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ClearValue(DependencyProperty) Method

[image]
ActiveReports 13
ClearValue(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members
Overload List


ClearValue(DependencyPropertyKey) Method

[image]
ActiveReports 13
ClearValue(DependencyPropertyKey) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.

Glossary Item Box

Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal key As DependencyPropertyKey _
)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members
Overload List


CoerceValue Method

[image]
ActiveReports 13
CoerceValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.

Glossary Item Box

Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Sub CoerceValue( _
   ByVal dp As DependencyProperty _
)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


DependencyObjectType Property

[image]
ActiveReports 13
DependencyObjectType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : DependencyObjectType Property

Glossary Item Box

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyObjectType As DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Dispatcher Property

[image]
ActiveReports 13
Dispatcher Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Dispatcher Property

Glossary Item Box

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dispatcher As Dispatcher
C#
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : GetHashCode Method

Glossary Item Box

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


InvalidateProperty Method

[image]
ActiveReports 13
InvalidateProperty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : InvalidateProperty Method

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Overload List

Overload | Description
InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


InvalidateProperty(DependencyProperty) Method

[image]
ActiveReports 13
InvalidateProperty(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Declaration)
Public Sub InvalidateProperty( _
   ByVal dp As DependencyProperty _
)
C#
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


IsSealed Property

[image]
ActiveReports 13
IsSealed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : IsSealed Property

Glossary Item Box

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


ReadLocalValue Method

[image]
ActiveReports 13
ReadLocalValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Declaration)
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SetCurrentValue Method

[image]
ActiveReports 13
SetCurrentValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SetCurrentValue Method

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Overload List

Overload | Description
SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SetCurrentValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetCurrentValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SetValue Method

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Overload List

Overload | Description
SetValue(DependencyProperty,Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members


SetValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

[image]
ActiveReports 13
SetValue(DependencyPropertyKey,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal key As DependencyPropertyKey, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Sidebar Class
Sidebar Members
Overload List


ClearValue Method

[image]
ActiveReports 13
ClearValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : ClearValue Method

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Overload List

Overload | Description
ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ClearValue(DependencyProperty) Method

[image]
ActiveReports 13
ClearValue(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

[image]
ActiveReports 13
ClearValue(DependencyPropertyKey) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.

Glossary Item Box

Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal key As DependencyPropertyKey _
)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


CoerceValue Method

[image]
ActiveReports 13
CoerceValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.

Glossary Item Box

Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Sub CoerceValue( _
   ByVal dp As DependencyProperty _
)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


DependencyObjectType Property

[image]
ActiveReports 13
DependencyObjectType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : DependencyObjectType Property

Glossary Item Box

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyObjectType As DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Dispatcher Property

[image]
ActiveReports 13
Dispatcher Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Dispatcher Property

Glossary Item Box

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dispatcher As Dispatcher
C#
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : GetHashCode Method

Glossary Item Box

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


InvalidateProperty Method

[image]
ActiveReports 13
InvalidateProperty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : InvalidateProperty Method

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Overload List

Overload | Description
InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


InvalidateProperty(DependencyProperty) Method

[image]
ActiveReports 13
InvalidateProperty(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Declaration)
Public Sub InvalidateProperty( _
   ByVal dp As DependencyProperty _
)
C#
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


IsSealed Property

[image]
ActiveReports 13
IsSealed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : IsSealed Property

Glossary Item Box

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ReadLocalValue Method

[image]
ActiveReports 13
ReadLocalValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Declaration)
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetCurrentValue Method

[image]
ActiveReports 13
SetCurrentValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : SetCurrentValue Method

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Overload List

Overload | Description
SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetCurrentValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetCurrentValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : SetValue Method

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Overload List

Overload | Description
SetValue(DependencyProperty,Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

[image]
ActiveReports 13
SetValue(DependencyPropertyKey,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal key As DependencyPropertyKey, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


ClearValue Method

[image]
ActiveReports 13
ClearValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : ClearValue Method

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Overload List

Overload | Description
ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


ClearValue(DependencyProperty) Method

[image]
ActiveReports 13
ClearValue(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

[image]
ActiveReports 13
ClearValue(DependencyPropertyKey) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.

Glossary Item Box

Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal key As DependencyPropertyKey _
)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members
Overload List


CoerceValue Method

[image]
ActiveReports 13
CoerceValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.

Glossary Item Box

Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Sub CoerceValue( _
   ByVal dp As DependencyProperty _
)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


DependencyObjectType Property

[image]
ActiveReports 13
DependencyObjectType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : DependencyObjectType Property

Glossary Item Box

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyObjectType As DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Dispatcher Property

[image]
ActiveReports 13
Dispatcher Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Dispatcher Property

Glossary Item Box

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dispatcher As Dispatcher
C#
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : GetHashCode Method

Glossary Item Box

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


InvalidateProperty Method

[image]
ActiveReports 13
InvalidateProperty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : InvalidateProperty Method

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Overload List

Overload | Description
InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


InvalidateProperty(DependencyProperty) Method

[image]
ActiveReports 13
InvalidateProperty(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Declaration)
Public Sub InvalidateProperty( _
   ByVal dp As DependencyProperty _
)
C#
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


IsSealed Property

[image]
ActiveReports 13
IsSealed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : IsSealed Property

Glossary Item Box

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


ReadLocalValue Method

[image]
ActiveReports 13
ReadLocalValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Declaration)
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


SetCurrentValue Method

[image]
ActiveReports 13
SetCurrentValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SetCurrentValue Method

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Overload List

Overload | Description
SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


SetCurrentValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetCurrentValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SetValue Method

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Overload List

Overload | Description
SetValue(DependencyProperty,Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members


SetValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

[image]
ActiveReports 13
SetValue(DependencyPropertyKey,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal key As DependencyPropertyKey, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TocPanel Class
TocPanel Members
Overload List


Viewer.ActionEventArgs Constructor

[image]
ActiveReports 13
Viewer.ActionEventArgs Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : Viewer.ActionEventArgs Constructor

Glossary Item Box

Initializes the new instance of Viewer.ActionEventArgs class.

Overload List

Overload | Description
Viewer.ActionEventArgs Constructor | Initializes the new instance of ActionEventArgs class.

Requirements

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


Cancel Property

[image]
ActiveReports 13
Cancel Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : Cancel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


ActualHeight Property

[image]
ActiveReports 13
ActualHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ActualHeight Property

Glossary Item Box

Gets the rendered height of this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualHeight As Double
C#
public double ActualHeight {get;}

Property Value

The element's height, as a value in device-independent units (1/96th inch per unit). The default value is 0 (zero).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ActualWidth Property

[image]
ActiveReports 13
ActualWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ActualWidth Property

Glossary Item Box

Gets the rendered width of this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualWidth As Double
C#
public double ActualWidth {get;}

Property Value

The element's width, as a value in device-independent units (1/96th inch per unit). The default value is 0 (zero).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AddHandler Method

[image]
ActiveReports 13
AddHandler Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AddHandler Method

Glossary Item Box

Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element.

Overload List

Overload | Description
AddHandler(RoutedEvent,Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from System.Windows.UIElement)
AddHandler(RoutedEvent,Delegate,Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from System.Windows.UIElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AddHandler(RoutedEvent,Delegate) Method

[image]
ActiveReports 13
AddHandler(RoutedEvent,Delegate) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > AddHandler Method : AddHandler(RoutedEvent,Delegate) Method

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.

Glossary Item Box

Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
C#
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler
)

Parameters

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


AddHandler(RoutedEvent,Delegate,Boolean) Method

[image]
ActiveReports 13
AddHandler(RoutedEvent,Delegate,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > AddHandler Method : AddHandler(RoutedEvent,Delegate,Boolean) Method

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.
handledEventsToo
true to register the handler such that it is invoked even when the routed event is marked handled in its event data; false to register the handler with the default condition that it will not be invoked if the routed event is already marked handled. The default is false. Do not routinely ask to rehandle a routed event.

Glossary Item Box

Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
C#
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
)

Parameters

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.
handledEventsToo
true to register the handler such that it is invoked even when the routed event is marked handled in its event data; false to register the handler with the default condition that it will not be invoked if the routed event is already marked handled. The default is false. Do not routinely ask to rehandle a routed event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


AddToEventRoute Method

[image]
ActiveReports 13
AddToEventRoute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AddToEventRoute Method

route
The event route that handlers are added to.
e
The event data that is used to add the handlers. This method uses the System.Windows.RoutedEventArgs.RoutedEvent property of the event data to create the handlers.

Glossary Item Box

Adds handlers to the specified System.Windows.EventRoute for the current System.Windows.UIElement event handler collection.

Syntax

Visual Basic (Declaration)
Public Sub AddToEventRoute( _
   ByVal route As EventRoute, _
   ByVal e As RoutedEventArgs _
)
C#
public void AddToEventRoute(
   EventRoute route,
   RoutedEventArgs e
)

Parameters

route
The event route that handlers are added to.
e
The event data that is used to add the handlers. This method uses the System.Windows.RoutedEventArgs.RoutedEvent property of the event data to create the handlers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AllowDrop Property

[image]
ActiveReports 13
AllowDrop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property AllowDrop As Boolean
C#
public bool AllowDrop {get; set;}

Property Value

true if this element can be used as the target of a drag-and-drop operation; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ApplyAnimationClock Method

[image]
ActiveReports 13
ApplyAnimationClock Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ApplyAnimationClock Method

Glossary Item Box

Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation.

Overload List

Overload | Description
ApplyAnimationClock(DependencyProperty,AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from System.Windows.UIElement)
ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from System.Windows.UIElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ApplyAnimationClock(DependencyProperty,AnimationClock) Method

[image]
ActiveReports 13
ApplyAnimationClock(DependencyProperty,AnimationClock) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ApplyAnimationClock Method : ApplyAnimationClock(DependencyProperty,AnimationClock) Method

dp
The identifier for the property to animate.
clock
The animation clock that controls and declares the animation.

Glossary Item Box

Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ApplyAnimationClock( _
   ByVal dp As DependencyProperty, _
   ByVal clock As AnimationClock _
)
C#
public void ApplyAnimationClock(
   DependencyProperty dp,
   AnimationClock clock
)

Parameters

dp
The identifier for the property to animate.
clock
The animation clock that controls and declares the animation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method

[image]
ActiveReports 13
ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ApplyAnimationClock Method : ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method

dp
The property to animate.
clock
The animation clock that controls and declares the animation.
handoffBehavior
A value of the enumeration. The default is System.Windows.Media.Animation.HandoffBehavior.SnapshotAndReplace, which will stop any existing animation and replace with the new one.

Glossary Item Box

Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ApplyAnimationClock( _
   ByVal dp As DependencyProperty, _
   ByVal clock As AnimationClock, _
   ByVal handoffBehavior As HandoffBehavior _
)
C#
public void ApplyAnimationClock(
   DependencyProperty dp,
   AnimationClock clock,
   HandoffBehavior handoffBehavior
)

Parameters

dp
The property to animate.
clock
The animation clock that controls and declares the animation.
handoffBehavior
A value of the enumeration. The default is System.Windows.Media.Animation.HandoffBehavior.SnapshotAndReplace, which will stop any existing animation and replace with the new one.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


ApplyTemplate Method

[image]
ActiveReports 13
ApplyTemplate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ApplyTemplate Method

Glossary Item Box

Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call.

Syntax

Visual Basic (Declaration)
Public Function ApplyTemplate() As Boolean
C#
public bool ApplyTemplate()

Return Value

true if visuals were added to the tree; returns false otherwise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesCaptured Property

[image]
ActiveReports 13
AreAnyTouchesCaptured Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesCaptured Property

Glossary Item Box

Gets a value that indicates whether at least one touch is captured to this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AreAnyTouchesCaptured As Boolean
C#
public bool AreAnyTouchesCaptured {get;}

Property Value

true if at least one touch is captured to this element; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesCapturedWithin Property

[image]
ActiveReports 13
AreAnyTouchesCapturedWithin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesCapturedWithin Property

Glossary Item Box

Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AreAnyTouchesCapturedWithin As Boolean
C#
public bool AreAnyTouchesCapturedWithin {get;}

Property Value

true if at least one touch is captured to this element or any child elements in its visual tree; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesDirectlyOver Property

[image]
ActiveReports 13
AreAnyTouchesDirectlyOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesDirectlyOver Property

Glossary Item Box

Gets a value that indicates whether at least one touch is pressed over this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AreAnyTouchesDirectlyOver As Boolean
C#
public bool AreAnyTouchesDirectlyOver {get;}

Property Value

true if at least one touch is pressed over this element; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesOver Property

[image]
ActiveReports 13
AreAnyTouchesOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesOver Property

Glossary Item Box

Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AreAnyTouchesOver As Boolean
C#
public bool AreAnyTouchesOver {get;}

Property Value

true if at least one touch is pressed over this element or any child elements in its visual tree; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Arrange Method

[image]
ActiveReports 13
Arrange Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Arrange Method

finalRect
The final size that the parent computes for the child element, provided as a System.Windows.Rect instance.

Glossary Item Box

Positions child elements and determines a size for a System.Windows.UIElement. Parent elements call this method from their System.Windows.UIElement.ArrangeCore(System.Windows.Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update.

Syntax

Visual Basic (Declaration)
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
C#
public void Arrange(
   Rect finalRect
)

Parameters

finalRect
The final size that the parent computes for the child element, provided as a System.Windows.Rect instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Background Property

[image]
ActiveReports 13
Background Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Background Property

Glossary Item Box

Gets or sets a brush that describes the background of a control.

Syntax

Visual Basic (Declaration)
Public Property Background As Brush
C#
public Brush Background {get; set;}

Property Value

The brush that is used to fill the background of the control. The default is System.Windows.Media.Brushes.Transparent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BeginAnimation Method

[image]
ActiveReports 13
BeginAnimation Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BeginAnimation Method

Glossary Item Box

Starts an animation for a specified animated property on this element.

Overload List

Overload | Description
BeginAnimation(DependencyProperty,AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from System.Windows.UIElement)
BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from System.Windows.UIElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BeginAnimation(DependencyProperty,AnimationTimeline) Method

[image]
ActiveReports 13
BeginAnimation(DependencyProperty,AnimationTimeline) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginAnimation Method : BeginAnimation(DependencyProperty,AnimationTimeline) Method

dp
The property to animate, which is specified as a dependency property identifier.
animation
The timeline of the animation to start.

Glossary Item Box

Starts an animation for a specified animated property on this element.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BeginAnimation( _
   ByVal dp As DependencyProperty, _
   ByVal animation As AnimationTimeline _
)
C#
public void BeginAnimation(
   DependencyProperty dp,
   AnimationTimeline animation
)

Parameters

dp
The property to animate, which is specified as a dependency property identifier.
animation
The timeline of the animation to start.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method

[image]
ActiveReports 13
BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginAnimation Method : BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method

dp
The property to animate, which is specified as the dependency property identifier.
animation
The timeline of the animation to be applied.
handoffBehavior
A value of the enumeration that specifies how the new animation interacts with any current (running) animations that are already affecting the property value.

Glossary Item Box

Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BeginAnimation( _
   ByVal dp As DependencyProperty, _
   ByVal animation As AnimationTimeline, _
   ByVal handoffBehavior As HandoffBehavior _
)
C#
public void BeginAnimation(
   DependencyProperty dp,
   AnimationTimeline animation,
   HandoffBehavior handoffBehavior
)

Parameters

dp
The property to animate, which is specified as the dependency property identifier.
animation
The timeline of the animation to be applied.
handoffBehavior
A value of the enumeration that specifies how the new animation interacts with any current (running) animations that are already affecting the property value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginInit Method

[image]
ActiveReports 13
BeginInit Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BeginInit Method

Glossary Item Box

Starts the initialization process for this element.

Syntax

Visual Basic (Declaration)
Public Overridable Sub BeginInit()
C#
public virtual void BeginInit()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BeginStoryboard Method

[image]
ActiveReports 13
BeginStoryboard Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BeginStoryboard Method

Glossary Item Box

Begins the sequence of actions that are contained in the provided storyboard.

Overload List

Overload | Description
BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from System.Windows.FrameworkElement)
BeginStoryboard(Storyboard,HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from System.Windows.FrameworkElement)
BeginStoryboard(Storyboard,HandoffBehavior,Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from System.Windows.FrameworkElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BeginStoryboard(Storyboard) Method

[image]
ActiveReports 13
BeginStoryboard(Storyboard) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginStoryboard Method : BeginStoryboard(Storyboard) Method

storyboard
The storyboard to begin.

Glossary Item Box

Begins the sequence of actions that are contained in the provided storyboard.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BeginStoryboard( _
   ByVal storyboard As Storyboard _
)
C#
public void BeginStoryboard(
   Storyboard storyboard
)

Parameters

storyboard
The storyboard to begin.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginStoryboard(Storyboard,HandoffBehavior) Method

[image]
ActiveReports 13
BeginStoryboard(Storyboard,HandoffBehavior) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginStoryboard Method : BeginStoryboard(Storyboard,HandoffBehavior) Method

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.

Glossary Item Box

Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BeginStoryboard( _
   ByVal storyboard As Storyboard, _
   ByVal handoffBehavior As HandoffBehavior _
)
C#
public void BeginStoryboard(
   Storyboard storyboard,
   HandoffBehavior handoffBehavior
)

Parameters

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method

[image]
ActiveReports 13
BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginStoryboard Method : BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.
isControllable
Declares whether the animation is controllable (can be paused) after it is started.

Glossary Item Box

Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BeginStoryboard( _
   ByVal storyboard As Storyboard, _
   ByVal handoffBehavior As HandoffBehavior, _
   ByVal isControllable As Boolean _
)
C#
public void BeginStoryboard(
   Storyboard storyboard,
   HandoffBehavior handoffBehavior,
   bool isControllable
)

Parameters

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.
isControllable
Declares whether the animation is controllable (can be paused) after it is started.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BindingGroup Property

[image]
ActiveReports 13
BindingGroup Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BindingGroup Property

Glossary Item Box

Gets or sets the System.Windows.Data.BindingGroup that is used for the element.

Syntax

Visual Basic (Declaration)
Public Property BindingGroup As BindingGroup
C#
public BindingGroup BindingGroup {get; set;}

Property Value

The System.Windows.Data.BindingGroup that is used for the element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BitmapEffect Property

[image]
ActiveReports 13
BitmapEffect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BitmapEffect Property

Glossary Item Box

Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property BitmapEffect As BitmapEffect
C#
public BitmapEffect BitmapEffect {get; set;}

Property Value

The bitmap effect to apply.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BitmapEffectInput Property

[image]
ActiveReports 13
BitmapEffectInput Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BitmapEffectInput Property

Glossary Item Box

Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property BitmapEffectInput As BitmapEffectInput
C#
public BitmapEffectInput BitmapEffectInput {get; set;}

Property Value

The source for bitmap effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BorderBrush Property

[image]
ActiveReports 13
BorderBrush Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BorderBrush Property

Glossary Item Box

Gets or sets a brush that describes the border background of a control.

Syntax

Visual Basic (Declaration)
Public Property BorderBrush As Brush
C#
public Brush BorderBrush {get; set;}

Property Value

The brush that is used to fill the control's border; the default is System.Windows.Media.Brushes.Transparent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BorderThickness Property

[image]
ActiveReports 13
BorderThickness Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BorderThickness Property

Glossary Item Box

Gets or sets the border thickness of a control.

Syntax

Visual Basic (Declaration)
Public Property BorderThickness As Thickness
C#
public Thickness BorderThickness {get; set;}

Property Value

A thickness value; the default is a thickness of 0 on all four sides.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BringIntoView Method

[image]
ActiveReports 13
BringIntoView Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BringIntoView Method

Glossary Item Box

Attempts to bring this element into view, within any scrollable regions it is contained within.

Overload List

Overload | Description
BringIntoView() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from System.Windows.FrameworkElement)
BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from System.Windows.FrameworkElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


BringIntoView() Method

[image]
ActiveReports 13
BringIntoView() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BringIntoView Method : BringIntoView() Method

Glossary Item Box

Attempts to bring this element into view, within any scrollable regions it is contained within.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BringIntoView()
C#
public void BringIntoView()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


BringIntoView(Rect) Method

[image]
ActiveReports 13
BringIntoView(Rect) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BringIntoView Method : BringIntoView(Rect) Method

targetRectangle
Specified size of the element that should also be brought into view.

Glossary Item Box

Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BringIntoView( _
   ByVal targetRectangle As Rect _
)
C#
public void BringIntoView(
   Rect targetRectangle
)

Parameters

targetRectangle
Specified size of the element that should also be brought into view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


CacheMode Property

[image]
ActiveReports 13
CacheMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CacheMode Property

Glossary Item Box

Gets or sets a cached representation of the System.Windows.UIElement.

Syntax

Visual Basic (Declaration)
Public Property CacheMode As CacheMode
C#
public CacheMode CacheMode {get; set;}

Property Value

A System.Windows.Media.CacheMode that holds a cached representation of the System.Windows.UIElement.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CaptureMouse Method

[image]
ActiveReports 13
CaptureMouse Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CaptureMouse Method

Glossary Item Box

Attempts to force capture of the mouse to this element.

Syntax

Visual Basic (Declaration)
Public Function CaptureMouse() As Boolean
C#
public bool CaptureMouse()

Return Value

true if the mouse is successfully captured; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CaptureStylus Method

[image]
ActiveReports 13
CaptureStylus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CaptureStylus Method

Glossary Item Box

Attempts to force capture of the stylus to this element.

Syntax

Visual Basic (Declaration)
Public Function CaptureStylus() As Boolean
C#
public bool CaptureStylus()

Return Value

true if the stylus was successfully captured; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CaptureTouch Method

[image]
ActiveReports 13
CaptureTouch Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CaptureTouch Method

touchDevice
The device to capture.

Glossary Item Box

Attempts to force capture of a touch to this element.

Syntax

Visual Basic (Declaration)
Public Function CaptureTouch( _
   ByVal touchDevice As TouchDevice _
) As Boolean
C#
public bool CaptureTouch(
   TouchDevice touchDevice
)

Parameters

touchDevice
The device to capture.

Return Value

true if the specified touch is captured to this element; otherwise, false.

Exceptions

Exception | Description
System.ArgumentNullException | touchDevice is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ClearValue Method

[image]
ActiveReports 13
ClearValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ClearValue Method

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Overload List

Overload | Description
ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier. (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ClearValue(DependencyProperty) Method

[image]
ActiveReports 13
ClearValue(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Glossary Item Box

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


ClearValue(DependencyPropertyKey) Method

[image]
ActiveReports 13
ClearValue(DependencyPropertyKey) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.

Glossary Item Box

Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearValue( _
   ByVal key As DependencyPropertyKey _
)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


Clip Property

[image]
ActiveReports 13
Clip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Clip Property

Glossary Item Box

Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Clip As Geometry
C#
public Geometry Clip {get; set;}

Property Value

The geometry to be used for clipping area sizing. The default is a null System.Windows.Media.Geometry.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ClipToBounds Property

[image]
ActiveReports 13
ClipToBounds Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ClipToBounds Property

Glossary Item Box

Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property ClipToBounds As Boolean
C#
public bool ClipToBounds {get; set;}

Property Value

true if the content should be clipped; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CoerceValue Method

[image]
ActiveReports 13
CoerceValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.

Glossary Item Box

Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Sub CoerceValue( _
   ByVal dp As DependencyProperty _
)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


CommandBindings Property

[image]
ActiveReports 13
CommandBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CommandBindings Property

Glossary Item Box

Gets a collection of System.Windows.Input.CommandBinding objects associated with this element. A System.Windows.Input.CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CommandBindings As CommandBindingCollection
C#
public CommandBindingCollection CommandBindings {get;}

Property Value

The collection of all System.Windows.Input.CommandBinding objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContextMenu Property

[image]
ActiveReports 13
ContextMenu Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ContextMenu Property

Glossary Item Box

Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element.

Syntax

Visual Basic (Declaration)
Public Property ContextMenu As ContextMenu
C#
public ContextMenu ContextMenu {get; set;}

Property Value

The context menu assigned to this element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContextMenuClosing Event

[image]
ActiveReports 13
ContextMenuClosing Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ContextMenuClosing Event

Glossary Item Box

Occurs just before any context menu on the element is closed.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuClosing As ContextMenuEventHandler
C#
public event ContextMenuEventHandler ContextMenuClosing

Event Data

The event handler receives an argument of type ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
CursorLeft | Gets the horizontal position of the mouse.
CursorTop | Gets the vertical position of the mouse.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ContextMenuOpening Event

[image]
ActiveReports 13
ContextMenuOpening Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ContextMenuOpening Event

Glossary Item Box

Occurs when any context menu on the element is opened.

Syntax

Visual Basic (Declaration)
Public Event ContextMenuOpening As ContextMenuEventHandler
C#
public event ContextMenuEventHandler ContextMenuOpening

Event Data

The event handler receives an argument of type ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
CursorLeft | Gets the horizontal position of the mouse.
CursorTop | Gets the vertical position of the mouse.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Cursor Property

[image]
ActiveReports 13
Cursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Cursor Property

Glossary Item Box

Gets or sets the cursor that displays when the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Property Cursor As Cursor
C#
public Cursor Cursor {get; set;}

Property Value

The cursor to display. The default value is defined as a null reference (Nothing in Visual Basic) per this dependency property. However, the practical default at run time will come from a variety of factors.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DataContext Property

[image]
ActiveReports 13
DataContext Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DataContext Property

Glossary Item Box

Gets or sets the data context for an element when it participates in data binding.

Syntax

Visual Basic (Declaration)
Public Property DataContext As Object
C#
public object DataContext {get; set;}

Property Value

The object to use as data context.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DataContextChanged Event

[image]
ActiveReports 13
DataContextChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DataContextChanged Event

Glossary Item Box

Occurs when the data context for this element changes.

Syntax

Visual Basic (Declaration)
Public Event DataContextChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler DataContextChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DependencyObjectType Property

[image]
ActiveReports 13
DependencyObjectType Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DependencyObjectType Property

Glossary Item Box

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyObjectType As DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DesiredSize Property

[image]
ActiveReports 13
DesiredSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DesiredSize Property

Glossary Item Box

Gets the size that this element computed during the measure pass of the layout process.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredSize As Size
C#
public Size DesiredSize {get;}

Property Value

The computed size, which becomes the desired size for the arrange pass.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Dispatcher Property

[image]
ActiveReports 13
Dispatcher Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Dispatcher Property

Glossary Item Box

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dispatcher As Dispatcher
C#
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DragEnter Event

[image]
ActiveReports 13
DragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DragEnter Event

Glossary Item Box

Occurs when the input system reports an underlying drag event with this element as the drag target.

Syntax

Visual Basic (Declaration)
Public Event DragEnter As DragEventHandler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DragLeave Event

[image]
ActiveReports 13
DragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DragLeave Event

Glossary Item Box

Occurs when the input system reports an underlying drag event with this element as the drag origin.

Syntax

Visual Basic (Declaration)
Public Event DragLeave As DragEventHandler
C#
public event DragEventHandler DragLeave

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


DragOver Event

[image]
ActiveReports 13
DragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DragOver Event

Glossary Item Box

Occurs when the input system reports an underlying drag event with this element as the potential drop target.

Syntax

Visual Basic (Declaration)
Public Event DragOver As DragEventHandler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Drop Event

[image]
ActiveReports 13
Drop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Drop Event

Glossary Item Box

Occurs when the input system reports an underlying drop event with this element as the drop target.

Syntax

Visual Basic (Declaration)
Public Event Drop As DragEventHandler
C#
public event DragEventHandler Drop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Effect Property

[image]
ActiveReports 13
Effect Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Effect Property

Glossary Item Box

Gets or sets the bitmap effect to apply to the System.Windows.UIElement. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Effect As Effect
C#
public Effect Effect {get; set;}

Property Value

An System.Windows.Media.Effects.Effect that represents the bitmap effect.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


EndInit Method

[image]
ActiveReports 13
EndInit Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : EndInit Method

Glossary Item Box

Indicates that the initialization process for the element is complete.

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndInit()
C#
public virtual void EndInit()

Exceptions

Exception | Description
System.InvalidOperationException | System.Windows.FrameworkElement.EndInit was called without System.Windows.FrameworkElement.BeginInit having previously been called on the element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FindCommonVisualAncestor Method

[image]
ActiveReports 13
FindCommonVisualAncestor Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindCommonVisualAncestor Method

otherVisual
A visual object of type System.Windows.DependencyObject.

Glossary Item Box

Returns the common ancestor of two visual objects.

Syntax

Visual Basic (Declaration)
Public Function FindCommonVisualAncestor( _
   ByVal otherVisual As DependencyObject _
) As DependencyObject
C#
public DependencyObject FindCommonVisualAncestor(
   DependencyObject otherVisual
)

Parameters

otherVisual
A visual object of type System.Windows.DependencyObject.

Return Value

The common ancestor of the visual object and otherVisual if one exists; otherwise, a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FindName Method

[image]
ActiveReports 13
FindName Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindName Method

Glossary Item Box

Finds an element that has the provided identifier name.

Overload List

Overload | Description
FindName | Finds an element that has the provided identifier name. (Inherited from System.Windows.FrameworkElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FindName(String) Method

[image]
ActiveReports 13
FindName(String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindName(String) Method

name
The name of the requested element.

Glossary Item Box

Finds an element that has the provided identifier name.

Syntax

Visual Basic (Declaration)
Public Function FindName( _
   ByVal name As String _
) As Object
C#
public object FindName(
   string name
)

Parameters

name
The name of the requested element.

Return Value

The requested element. This can be a null reference (Nothing in Visual Basic) if no matching element was found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FindResource Method

[image]
ActiveReports 13
FindResource Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindResource Method

resourceKey
The key identifier for the requested resource.

Glossary Item Box

Searches for a resource with the specified key, and throws an exception if the requested resource is not found.

Syntax

Visual Basic (Declaration)
Public Function FindResource( _
   ByVal resourceKey As Object _
) As Object
C#
public object FindResource(
   object resourceKey
)

Parameters

resourceKey
The key identifier for the requested resource.

Return Value

The requested resource. If no resource with the provided key was found, an exception is thrown. An System.Windows.DependencyProperty.UnsetValue value might also be returned in the exception case.

Exceptions

Exception | Description
System.Windows.ResourceReferenceKeyNotFoundException | resourceKey was not found and an event handler does not exist for the System.Windows.Threading.Dispatcher.UnhandledException event.-or- resourceKey was not found and the System.Windows.Threading.DispatcherUnhandledExceptionEventArgs.Handled property is false in the System.Windows.Threading.Dispatcher.UnhandledException event.
System.ArgumentNullException | resourceKey is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FlowDirection Property

[image]
ActiveReports 13
FlowDirection Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FlowDirection Property

Glossary Item Box

Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout.

Syntax

Visual Basic (Declaration)
Public Property FlowDirection As FlowDirection
C#
public FlowDirection FlowDirection {get; set;}

Property Value

The direction that text and other UI elements flow within their parent element, as a value of the enumeration. The default value is System.Windows.FlowDirection.LeftToRight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Focus Method

Glossary Item Box

Attempts to set focus to this element.

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
C#
public bool Focus()

Return Value

true if keyboard focus and logical focus were set to this element; false if only logical focus was set to this element, or if the call to this method did not force the focus to change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Focusable Property

[image]
ActiveReports 13
Focusable Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Focusable Property

Glossary Item Box

Gets or sets a value that indicates whether the element can receive focus. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Focusable As Boolean
C#
public bool Focusable {get; set;}

Property Value

true if the element is focusable; otherwise false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FocusableChanged Event

[image]
ActiveReports 13
FocusableChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FocusableChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.Focusable property changes.

Syntax

Visual Basic (Declaration)
Public Event FocusableChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler FocusableChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FocusVisualStyle Property

[image]
ActiveReports 13
FocusVisualStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FocusVisualStyle Property

Glossary Item Box

Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus.

Syntax

Visual Basic (Declaration)
Public Property FocusVisualStyle As Style
C#
public Style FocusVisualStyle {get; set;}

Property Value

The desired style to apply on focus. The default value as declared in the dependency property is an empty static System.Windows.Style. However, the effective value at run time is often (but not always) a style as supplied by theme support for controls.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FontFamily Property

[image]
ActiveReports 13
FontFamily Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontFamily Property

Glossary Item Box

Gets or sets the font family of the control.

Syntax

Visual Basic (Declaration)
Public Property FontFamily As FontFamily
C#
public FontFamily FontFamily {get; set;}

Property Value

A font family. The default is the system dialog font.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FontSize Property

[image]
ActiveReports 13
FontSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontSize Property

Glossary Item Box

Gets or sets the font size.

Syntax

Visual Basic (Declaration)
Public Property FontSize As Double
C#
public double FontSize {get; set;}

Property Value

The size of the text in the System.Windows.Controls.Control. The default is System.Windows.SystemFonts.MessageFontSize. The font size must be a positive number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FontStretch Property

[image]
ActiveReports 13
FontStretch Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontStretch Property

Glossary Item Box

Gets or sets the degree to which a font is condensed or expanded on the screen.

Syntax

Visual Basic (Declaration)
Public Property FontStretch As FontStretch
C#
public FontStretch FontStretch {get; set;}

Property Value

A System.Windows.FontStretch value. The default is System.Windows.FontStretches.Normal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FontStyle Property

[image]
ActiveReports 13
FontStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontStyle Property

Glossary Item Box

Gets or sets the font style.

Syntax

Visual Basic (Declaration)
Public Property FontStyle As FontStyle
C#
public FontStyle FontStyle {get; set;}

Property Value

A System.Windows.FontStyle value. The default is System.Windows.FontStyles.Normal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


FontWeight Property

[image]
ActiveReports 13
FontWeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontWeight Property

Glossary Item Box

Gets or sets the weight or thickness of the specified font.

Syntax

Visual Basic (Declaration)
Public Property FontWeight As FontWeight
C#
public FontWeight FontWeight {get; set;}

Property Value

A System.Windows.FontWeight value. The default is System.Windows.FontWeights.Normal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ForceCursor Property

[image]
ActiveReports 13
ForceCursor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ForceCursor Property

Glossary Item Box

Gets or sets a value that indicates whether this System.Windows.FrameworkElement should force the user interface (UI) to render the cursor as declared by the System.Windows.FrameworkElement.Cursor property.

Syntax

Visual Basic (Declaration)
Public Property ForceCursor As Boolean
C#
public bool ForceCursor {get; set;}

Property Value

true if cursor presentation while over this element is forced to use current System.Windows.FrameworkElement.Cursor settings for the cursor (including on all child elements); otherwise false. The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Foreground Property

[image]
ActiveReports 13
Foreground Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Foreground Property

Glossary Item Box

Gets or sets a brush that describes the foreground color.

Syntax

Visual Basic (Declaration)
Public Property Foreground As Brush
C#
public Brush Foreground {get; set;}

Property Value

The brush that paints the foreground of the control. The default value is the system dialog font color.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetAnimationBaseValue Method

[image]
ActiveReports 13
GetAnimationBaseValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetAnimationBaseValue Method

dp
The dependency property to check.

Glossary Item Box

Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation.

Syntax

Visual Basic (Declaration)
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to check.

Return Value

The property value as if no animations are attached to the specified dependency property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetBindingExpression Method

[image]
ActiveReports 13
GetBindingExpression Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetBindingExpression Method

dp
The target System.Windows.DependencyProperty to get the binding from.

Glossary Item Box

Returns the System.Windows.Data.BindingExpression that represents the binding on the specified property.

Syntax

Visual Basic (Declaration)
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
C#
public BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp
The target System.Windows.DependencyProperty to get the binding from.

Return Value

A System.Windows.Data.BindingExpression if the target property has an active binding; otherwise, returns a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetHashCode Method

Glossary Item Box

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetHashCode() As Integer
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GetValue Method

[image]
ActiveReports 13
GetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GiveFeedback Event

[image]
ActiveReports 13
GiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GiveFeedback Event

Glossary Item Box

Occurs when the input system reports an underlying drag-and-drop event that involves this element.

Syntax

Visual Basic (Declaration)
Public Event GiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effects | Gets a value that indicates the effects of drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
UseDefaultCursors | Gets or sets a Boolean value indicating whether default cursor feedback behavior should be used for the associated drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GotFocus Event

[image]
ActiveReports 13
GotFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotFocus Event

Glossary Item Box

Occurs when this element gets logical focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus As RoutedEventHandler
C#
public event RoutedEventHandler GotFocus

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GotKeyboardFocus Event

[image]
ActiveReports 13
GotKeyboardFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotKeyboardFocus Event

Glossary Item Box

Occurs when the keyboard is focused on this element.

Syntax

Visual Basic (Declaration)
Public Event GotKeyboardFocus As KeyboardFocusChangedEventHandler
C#
public event KeyboardFocusChangedEventHandler GotKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GotMouseCapture Event

[image]
ActiveReports 13
GotMouseCapture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotMouseCapture Event

Glossary Item Box

Occurs when this element captures the mouse.

Syntax

Visual Basic (Declaration)
Public Event GotMouseCapture As MouseEventHandler
C#
public event MouseEventHandler GotMouseCapture

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GotStylusCapture Event

[image]
ActiveReports 13
GotStylusCapture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotStylusCapture Event

Glossary Item Box

Occurs when this element captures the stylus.

Syntax

Visual Basic (Declaration)
Public Event GotStylusCapture As StylusEventHandler
C#
public event StylusEventHandler GotStylusCapture

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GotTouchCapture Event

[image]
ActiveReports 13
GotTouchCapture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotTouchCapture Event

Glossary Item Box

Occurs when a touch is captured to this element.

Syntax

Visual Basic (Declaration)
Public Event GotTouchCapture As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> GotTouchCapture

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HasAnimatedProperties Property

[image]
ActiveReports 13
HasAnimatedProperties Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HasAnimatedProperties Property

Glossary Item Box

Gets a value indicating whether this element has any animated properties.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasAnimatedProperties As Boolean
C#
public bool HasAnimatedProperties {get;}

Property Value

true if this element has animations attached to any of its properties; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Height Property

Glossary Item Box

Gets or sets the suggested height of the element.

Syntax

Visual Basic (Declaration)
Public Property Height As Double
C#
public double Height {get; set;}

Property Value

The height of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.NaN. This value must be equal to or greater than 0.0. See Remarks for upper bound information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HorizontalAlignment Property

[image]
ActiveReports 13
HorizontalAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HorizontalAlignment Property

Glossary Item Box

Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control.

Syntax

Visual Basic (Declaration)
Public Property HorizontalAlignment As HorizontalAlignment
C#
public HorizontalAlignment HorizontalAlignment {get; set;}

Property Value

A horizontal alignment setting, as a value of the enumeration. The default is System.Windows.HorizontalAlignment.Stretch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


HorizontalContentAlignment Property

[image]
ActiveReports 13
HorizontalContentAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HorizontalContentAlignment Property

Glossary Item Box

Gets or sets the horizontal alignment of the control's content.

Syntax

Visual Basic (Declaration)
Public Property HorizontalContentAlignment As HorizontalAlignment
C#
public HorizontalAlignment HorizontalContentAlignment {get; set;}

Property Value

One of the System.Windows.HorizontalAlignment values. The default is System.Windows.HorizontalAlignment.Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Initialized Event

[image]
ActiveReports 13
Initialized Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Initialized Event

Glossary Item Box

Occurs when this System.Windows.FrameworkElement is initialized. This event coincides with cases where the value of the System.Windows.FrameworkElement.IsInitialized property changes from false (or undefined) to true.

Syntax

Visual Basic (Declaration)
Public Event Initialized As EventHandler
C#
public event EventHandler Initialized

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InputBindings Property

[image]
ActiveReports 13
InputBindings Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputBindings Property

Glossary Item Box

Gets the collection of input bindings associated with this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InputBindings As InputBindingCollection
C#
public InputBindingCollection InputBindings {get;}

Property Value

The collection of input bindings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InputHitTest Method

[image]
ActiveReports 13
InputHitTest Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputHitTest Method

Glossary Item Box

Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin.

Overload List

Overload | Description
InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from System.Windows.UIElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InputHitTest(Point) Method

[image]
ActiveReports 13
InputHitTest(Point) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputHitTest(Point) Method

point
The offset coordinates within this element.

Glossary Item Box

Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin.

Syntax

Visual Basic (Declaration)
Public Function InputHitTest( _
   ByVal point As Point _
) As IInputElement
C#
public IInputElement InputHitTest(
   Point point
)

Parameters

point
The offset coordinates within this element.

Return Value

The element child that is located at the given position.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InputScope Property

[image]
ActiveReports 13
InputScope Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputScope Property

Glossary Item Box

Gets or sets the context for input used by this System.Windows.FrameworkElement.

Syntax

Visual Basic (Declaration)
Public Property InputScope As InputScope
C#
public InputScope InputScope {get; set;}

Property Value

The input scope, which modifies how input from alternative input methods is interpreted. The default value is a null reference (Nothing in Visual Basic) (which results in a default handling of commands).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InvalidateArrange Method

[image]
ActiveReports 13
InvalidateArrange Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateArrange Method

Glossary Item Box

Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by System.Windows.UIElement.UpdateLayout.

Syntax

Visual Basic (Declaration)
Public Sub InvalidateArrange()
C#
public void InvalidateArrange()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InvalidateMeasure Method

[image]
ActiveReports 13
InvalidateMeasure Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateMeasure Method

Glossary Item Box

Invalidates the measurement state (layout) for the element.

Syntax

Visual Basic (Declaration)
Public Sub InvalidateMeasure()
C#
public void InvalidateMeasure()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InvalidateProperty Method

[image]
ActiveReports 13
InvalidateProperty Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateProperty Method

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Overload List

Overload | Description
InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InvalidateProperty(DependencyProperty) Method

[image]
ActiveReports 13
InvalidateProperty(DependencyProperty) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Glossary Item Box

Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Declaration)
Public Sub InvalidateProperty( _
   ByVal dp As DependencyProperty _
)
C#
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


InvalidateVisual Method

[image]
ActiveReports 13
InvalidateVisual Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateVisual Method

Glossary Item Box

Invalidates the rendering of the element, and forces a complete new layout pass. System.Windows.UIElement.OnRender(System.Windows.Media.DrawingContext) is called after the layout cycle is completed.

Syntax

Visual Basic (Declaration)
Public Sub InvalidateVisual()
C#
public void InvalidateVisual()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsAncestorOf Method

[image]
ActiveReports 13
IsAncestorOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsAncestorOf Method

descendant
A value of type System.Windows.DependencyObject.

Glossary Item Box

Determines whether the visual object is an ancestor of the descendant visual object.

Syntax

Visual Basic (Declaration)
Public Function IsAncestorOf( _
   ByVal descendant As DependencyObject _
) As Boolean
C#
public bool IsAncestorOf(
   DependencyObject descendant
)

Parameters

descendant
A value of type System.Windows.DependencyObject.

Return Value

true if the visual object is an ancestor of descendant; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsArrangeValid Property

[image]
ActiveReports 13
IsArrangeValid Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsArrangeValid Property

Glossary Item Box

Gets a value indicating whether the computed size and position of child elements in this element's layout are valid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsArrangeValid As Boolean
C#
public bool IsArrangeValid {get;}

Property Value

true if the size and position of layout are valid; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsDescendantOf Method

[image]
ActiveReports 13
IsDescendantOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsDescendantOf Method

ancestor
A value of type System.Windows.DependencyObject.

Glossary Item Box

Determines whether the visual object is a descendant of the ancestor visual object.

Syntax

Visual Basic (Declaration)
Public Function IsDescendantOf( _
   ByVal ancestor As DependencyObject _
) As Boolean
C#
public bool IsDescendantOf(
   DependencyObject ancestor
)

Parameters

ancestor
A value of type System.Windows.DependencyObject.

Return Value

true if the visual object is a descendant of ancestor; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsEnabled Property

[image]
ActiveReports 13
IsEnabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsEnabled Property

Glossary Item Box

Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsEnabled As Boolean
C#
public bool IsEnabled {get; set;}

Property Value

true if the element is enabled; otherwise, false. The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsEnabledChanged Event

[image]
ActiveReports 13
IsEnabledChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsEnabledChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsEnabled property on this element changes.

Syntax

Visual Basic (Declaration)
Public Event IsEnabledChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsEnabledChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsFocused Property

[image]
ActiveReports 13
IsFocused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsFocused Property

Glossary Item Box

Gets a value that determines whether this element has logical focus. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
C#
public bool IsFocused {get;}

Property Value

true if this element has logical focus; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsHitTestVisible Property

[image]
ActiveReports 13
IsHitTestVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsHitTestVisible Property

Glossary Item Box

Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property IsHitTestVisible As Boolean
C#
public bool IsHitTestVisible {get; set;}

Property Value

true if this element could be returned as a hit test result from at least one point; otherwise, false. The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsHitTestVisibleChanged Event

[image]
ActiveReports 13
IsHitTestVisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsHitTestVisibleChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsHitTestVisible dependency property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsHitTestVisibleChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsHitTestVisibleChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsInitialized Property

[image]
ActiveReports 13
IsInitialized Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsInitialized Property

Glossary Item Box

Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its System.Windows.FrameworkElement.EndInit method called.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInitialized As Boolean
C#
public bool IsInitialized {get;}

Property Value

true if the element is initialized per the aforementioned XAML processing or method calls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsInputMethodEnabled Property

[image]
ActiveReports 13
IsInputMethodEnabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsInputMethodEnabled Property

Glossary Item Box

Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInputMethodEnabled As Boolean
C#
public bool IsInputMethodEnabled {get;}

Property Value

true if an input method is active; otherwise, false. The default value of the underlying attached property is true; however, this will be influenced by the actual state of input methods at runtime.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocused Property

[image]
ActiveReports 13
IsKeyboardFocused Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocused Property

Glossary Item Box

Gets a value indicating whether this element has keyboard focus. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsKeyboardFocused As Boolean
C#
public bool IsKeyboardFocused {get;}

Property Value

true if this element has keyboard focus; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocusedChanged Event

[image]
ActiveReports 13
IsKeyboardFocusedChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocusedChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsKeyboardFocused property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsKeyboardFocusedChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsKeyboardFocusedChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocusWithin Property

[image]
ActiveReports 13
IsKeyboardFocusWithin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocusWithin Property

Glossary Item Box

Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsKeyboardFocusWithin As Boolean
C#
public bool IsKeyboardFocusWithin {get;}

Property Value

true if keyboard focus is on the element or its child elements; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocusWithinChanged Event

[image]
ActiveReports 13
IsKeyboardFocusWithinChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocusWithinChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsKeyboardFocusWithinChanged property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsKeyboardFocusWithinChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsKeyboardFocusWithinChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsLoaded Property

[image]
ActiveReports 13
IsLoaded Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsLoaded Property

Glossary Item Box

Gets a value that indicates whether this element has been loaded for presentation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLoaded As Boolean
C#
public bool IsLoaded {get;}

Property Value

true if the current element is attached to an element tree; false if the element has never been attached to a loaded element tree.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsManipulationEnabled Property

[image]
ActiveReports 13
IsManipulationEnabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsManipulationEnabled Property

Glossary Item Box

Gets or sets a value that indicates whether manipulation events are enabled on this System.Windows.UIElement.

Syntax

Visual Basic (Declaration)
Public Property IsManipulationEnabled As Boolean
C#
public bool IsManipulationEnabled {get; set;}

Property Value

true if manipulation events are enabled on this System.Windows.UIElement; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMeasureValid Property

[image]
ActiveReports 13
IsMeasureValid Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMeasureValid Property

Glossary Item Box

Gets a value indicating whether the current size returned by layout measure is valid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMeasureValid As Boolean
C#
public bool IsMeasureValid {get;}

Property Value

true if the measure pass of layout returned a valid and current value; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMouseCaptured Property

[image]
ActiveReports 13
IsMouseCaptured Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCaptured Property

Glossary Item Box

Gets a value indicating whether the mouse is captured to this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMouseCaptured As Boolean
C#
public bool IsMouseCaptured {get;}

Property Value

true if the element has mouse capture; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMouseCapturedChanged Event

[image]
ActiveReports 13
IsMouseCapturedChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCapturedChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsMouseCaptured property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsMouseCapturedChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsMouseCapturedChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMouseCaptureWithin Property

[image]
ActiveReports 13
IsMouseCaptureWithin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCaptureWithin Property

Glossary Item Box

Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMouseCaptureWithin As Boolean
C#
public bool IsMouseCaptureWithin {get;}

Property Value

true if this element or a contained element has mouse capture; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMouseCaptureWithinChanged Event

[image]
ActiveReports 13
IsMouseCaptureWithinChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCaptureWithinChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsMouseCaptureWithinProperty changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsMouseCaptureWithinChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsMouseCaptureWithinChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMouseDirectlyOver Property

[image]
ActiveReports 13
IsMouseDirectlyOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseDirectlyOver Property

Glossary Item Box

Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMouseDirectlyOver As Boolean
C#
public bool IsMouseDirectlyOver {get;}

Property Value

true if the mouse pointer is over the same element result as a hit test; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMouseDirectlyOverChanged Event

[image]
ActiveReports 13
IsMouseDirectlyOverChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseDirectlyOverChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsMouseDirectlyOver property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsMouseDirectlyOverChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsMouseDirectlyOverChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsMouseOver Property

[image]
ActiveReports 13
IsMouseOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseOver Property

Glossary Item Box

Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsMouseOver As Boolean
C#
public bool IsMouseOver {get;}

Property Value

true if mouse pointer is over the element or its child elements; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsSealed Property

[image]
ActiveReports 13
IsSealed Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsSealed Property

Glossary Item Box

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsStylusCaptured Property

[image]
ActiveReports 13
IsStylusCaptured Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCaptured Property

Glossary Item Box

Gets a value indicating whether the stylus is captured by this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsStylusCaptured As Boolean
C#
public bool IsStylusCaptured {get;}

Property Value

true if the element has stylus capture; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsStylusCapturedChanged Event

[image]
ActiveReports 13
IsStylusCapturedChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCapturedChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsStylusCaptured property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsStylusCapturedChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsStylusCapturedChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsStylusCaptureWithin Property

[image]
ActiveReports 13
IsStylusCaptureWithin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCaptureWithin Property

Glossary Item Box

Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsStylusCaptureWithin As Boolean
C#
public bool IsStylusCaptureWithin {get;}

Property Value

true if this element or a contained element has stylus capture; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsStylusCaptureWithinChanged Event

[image]
ActiveReports 13
IsStylusCaptureWithinChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCaptureWithinChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsStylusCaptureWithin property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsStylusCaptureWithinChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsStylusCaptureWithinChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsStylusDirectlyOver Property

[image]
ActiveReports 13
IsStylusDirectlyOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusDirectlyOver Property

Glossary Item Box

Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsStylusDirectlyOver As Boolean
C#
public bool IsStylusDirectlyOver {get;}

Property Value

true if the stylus pointer is over the same element result as a hit test; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsStylusDirectlyOverChanged Event

[image]
ActiveReports 13
IsStylusDirectlyOverChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusDirectlyOverChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsStylusDirectlyOver property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsStylusDirectlyOverChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsStylusDirectlyOverChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsStylusOver Property

[image]
ActiveReports 13
IsStylusOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusOver Property

Glossary Item Box

Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsStylusOver As Boolean
C#
public bool IsStylusOver {get;}

Property Value

true if stylus cursor is over the element or its child elements; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsTabStop Property

[image]
ActiveReports 13
IsTabStop Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsTabStop Property

Glossary Item Box

Gets or sets a value that indicates whether a control is included in tab navigation.

Syntax

Visual Basic (Declaration)
Public Property IsTabStop As Boolean
C#
public bool IsTabStop {get; set;}

Property Value

true if the control is included in tab navigation; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsVisible Property

[image]
ActiveReports 13
IsVisible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsVisible Property

Glossary Item Box

Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsVisible As Boolean
C#
public bool IsVisible {get;}

Property Value

true if the element is visible; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


IsVisibleChanged Event

[image]
ActiveReports 13
IsVisibleChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsVisibleChanged Event

Glossary Item Box

Occurs when the value of the System.Windows.UIElement.IsVisible property changes on this element.

Syntax

Visual Basic (Declaration)
Public Event IsVisibleChanged As DependencyPropertyChangedEventHandler
C#
public event DependencyPropertyChangedEventHandler IsVisibleChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


KeyDown Event

[image]
ActiveReports 13
KeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : KeyDown Event

Glossary Item Box

Occurs when a key is pressed while focus is on this element.

Syntax

Visual Basic (Declaration)
Public Event KeyDown As KeyEventHandler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
KeyStates | Gets the state of the keyboard key associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


KeyUp Event

[image]
ActiveReports 13
KeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : KeyUp Event

Glossary Item Box

Occurs when a key is released while focus is on this element.

Syntax

Visual Basic (Declaration)
Public Event KeyUp As KeyEventHandler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
KeyStates | Gets the state of the keyboard key associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Language Property

[image]
ActiveReports 13
Language Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Language Property

Glossary Item Box

Gets or sets localization/globalization language information that applies to an element.

Syntax

Visual Basic (Declaration)
Public Property Language As XmlLanguage
C#
public XmlLanguage Language {get; set;}

Property Value

The language information for this element. The default value is an System.Windows.Markup.XmlLanguage with its System.Windows.Markup.XmlLanguage.IetfLanguageTag value set to the string "en-US".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LayoutTransform Property

[image]
ActiveReports 13
LayoutTransform Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LayoutTransform Property

Glossary Item Box

Gets or sets a graphics transformation that should apply to this element when layout is performed.

Syntax

Visual Basic (Declaration)
Public Property LayoutTransform As Transform
C#
public Transform LayoutTransform {get; set;}

Property Value

The transform this element should use. The default is System.Windows.Media.Transform.Identity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LayoutUpdated Event

[image]
ActiveReports 13
LayoutUpdated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LayoutUpdated Event

Glossary Item Box

Occurs when the layout of the various visual elements associated with the current System.Windows.Threading.Dispatcher changes.

Syntax

Visual Basic (Declaration)
Public Event LayoutUpdated As EventHandler
C#
public event EventHandler LayoutUpdated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Loaded Event

[image]
ActiveReports 13
Loaded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Loaded Event

Glossary Item Box

Occurs when the element is laid out, rendered, and ready for interaction.

Syntax

Visual Basic (Declaration)
Public Event Loaded As RoutedEventHandler
C#
public event RoutedEventHandler Loaded

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LostFocus Event

[image]
ActiveReports 13
LostFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostFocus Event

Glossary Item Box

Occurs when this element loses logical focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus As RoutedEventHandler
C#
public event RoutedEventHandler LostFocus

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LostKeyboardFocus Event

[image]
ActiveReports 13
LostKeyboardFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostKeyboardFocus Event

Glossary Item Box

Occurs when the keyboard is no longer focused on this element,.

Syntax

Visual Basic (Declaration)
Public Event LostKeyboardFocus As KeyboardFocusChangedEventHandler
C#
public event KeyboardFocusChangedEventHandler LostKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LostMouseCapture Event

[image]
ActiveReports 13
LostMouseCapture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostMouseCapture Event

Glossary Item Box

Occurs when this element loses mouse capture.

Syntax

Visual Basic (Declaration)
Public Event LostMouseCapture As MouseEventHandler
C#
public event MouseEventHandler LostMouseCapture

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LostStylusCapture Event

[image]
ActiveReports 13
LostStylusCapture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostStylusCapture Event

Glossary Item Box

Occurs when this element loses stylus capture.

Syntax

Visual Basic (Declaration)
Public Event LostStylusCapture As StylusEventHandler
C#
public event StylusEventHandler LostStylusCapture

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


LostTouchCapture Event

[image]
ActiveReports 13
LostTouchCapture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostTouchCapture Event

Glossary Item Box

Occurs when this element loses a touch capture.

Syntax

Visual Basic (Declaration)
Public Event LostTouchCapture As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> LostTouchCapture

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ManipulationBoundaryFeedback Event

[image]
ActiveReports 13
ManipulationBoundaryFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationBoundaryFeedback Event

Glossary Item Box

Occurs when the manipulation encounters a boundary.

Syntax

Visual Basic (Declaration)
Public Event ManipulationBoundaryFeedback As EventHandler(Of ManipulationBoundaryFeedbackEventArgs)
C#
public event EventHandler<ManipulationBoundaryFeedbackEventArgs> ManipulationBoundaryFeedback

Event Data

The event handler receives an argument of type ManipulationBoundaryFeedbackEventArgs containing data related to this event. The following ManipulationBoundaryFeedbackEventArgs properties provide information specific to this event.

Property | Description
BoundaryFeedback | Gets the unused portion of the direct manipulation.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationBoundaryFeedbackEventArgs.BoundaryFeedback property is relative to.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ManipulationCompleted Event

[image]
ActiveReports 13
ManipulationCompleted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationCompleted Event

Glossary Item Box

Occurs when a manipulation and inertia on the System.Windows.UIElement object is complete.

Syntax

Visual Basic (Declaration)
Public Event ManipulationCompleted As EventHandler(Of ManipulationCompletedEventArgs)
C#
public event EventHandler<ManipulationCompletedEventArgs> ManipulationCompleted

Event Data

The event handler receives an argument of type ManipulationCompletedEventArgs containing data related to this event. The following ManipulationCompletedEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
FinalVelocities | Gets the velocities that are used for the manipulation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
IsInertial | Gets a value that indicates whether the System.Windows.UIElement.ManipulationCompleted event occurs during inertia.
ManipulationContainer | Gets the container that defines the coordinates for the manipulation.
ManipulationOrigin | Gets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TotalManipulation | Gets the total transformation that occurs during the current manipulation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ManipulationDelta Event

[image]
ActiveReports 13
ManipulationDelta Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationDelta Event

Glossary Item Box

Occurs when the input device changes position during a manipulation.

Syntax

Visual Basic (Declaration)
Public Event ManipulationDelta As EventHandler(Of ManipulationDeltaEventArgs)
C#
public event EventHandler<ManipulationDeltaEventArgs> ManipulationDelta

Event Data

The event handler receives an argument of type ManipulationDeltaEventArgs containing data related to this event. The following ManipulationDeltaEventArgs properties provide information specific to this event.

Property | Description
CumulativeManipulation | Gets the cumulated changes of the current manipulation.
DeltaManipulation | Gets the most recent changes of the current manipulation.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
IsInertial | Gets a value that indicates whether the System.Windows.UIElement.ManipulationDelta event occurs during inertia.
ManipulationContainer | Gets the container that defines the coordinates for the manipulation.
ManipulationOrigin | Gets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
Velocities | Gets the rates of the most recent changes to the manipulation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ManipulationInertiaStarting Event

[image]
ActiveReports 13
ManipulationInertiaStarting Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationInertiaStarting Event

Glossary Item Box

Occurs when the input device loses contact with the System.Windows.UIElement object during a manipulation and inertia begins.

Syntax

Visual Basic (Declaration)
Public Event ManipulationInertiaStarting As EventHandler(Of ManipulationInertiaStartingEventArgs)
C#
public event EventHandler<ManipulationInertiaStartingEventArgs> ManipulationInertiaStarting

Event Data

The event handler receives an argument of type ManipulationInertiaStartingEventArgs containing data related to this event. The following ManipulationInertiaStartingEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
ExpansionBehavior | Get or sets the rate of slowdown of expansion inertial movement.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InitialVelocities | Gets the rates of changes to the manipulation that occur before inertia starts.
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationStartedEventArgs.ManipulationOrigin property is relative to.
ManipulationOrigin | Gets or sets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RotationBehavior | Gets or sets the rate of slowdown of rotational inertial movement.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TranslationBehavior | Gets or sets the rate of slowdown of linear inertial movement.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ManipulationStarted Event

[image]
ActiveReports 13
ManipulationStarted Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationStarted Event

Glossary Item Box

Occurs when an input device begins a manipulation on the System.Windows.UIElement object.

Syntax

Visual Basic (Declaration)
Public Event ManipulationStarted As EventHandler(Of ManipulationStartedEventArgs)
C#
public event EventHandler<ManipulationStartedEventArgs> ManipulationStarted

Event Data

The event handler receives an argument of type ManipulationStartedEventArgs containing data related to this event. The following ManipulationStartedEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationStartedEventArgs.ManipulationOrigin property is relative to.
ManipulationOrigin | Gets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ManipulationStarting Event

[image]
ActiveReports 13
ManipulationStarting Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationStarting Event

Glossary Item Box

Occurs when the manipulation processor is first created.

Syntax

Visual Basic (Declaration)
Public Event ManipulationStarting As EventHandler(Of ManipulationStartingEventArgs)
C#
public event EventHandler<ManipulationStartingEventArgs> ManipulationStarting

Event Data

The event handler receives an argument of type ManipulationStartingEventArgs containing data related to this event. The following ManipulationStartingEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
IsSingleTouchEnabled | Gets or sets whether one finger can start a manipulation.
ManipulationContainer | Gets or sets the container that all manipulation events and calculations are relative to.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
Mode | Gets or sets which types of manipulations are possible.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
Pivot | Gets or sets an object that describes the pivot for a single-point manipulation.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Margin Property

[image]
ActiveReports 13
Margin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Margin Property

Glossary Item Box

Gets or sets the outer margin of an element.

Syntax

Visual Basic (Declaration)
Public Property Margin As Thickness
C#
public Thickness Margin {get; set;}

Property Value

Provides margin values for the element. The default value is a System.Windows.Thickness with all properties equal to 0 (zero).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MaxHeight Property

[image]
ActiveReports 13
MaxHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MaxHeight Property

Glossary Item Box

Gets or sets the maximum height constraint of the element.

Syntax

Visual Basic (Declaration)
Public Property MaxHeight As Double
C#
public double MaxHeight {get; set;}

Property Value

The maximum height of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.PositiveInfinity. This value can be any value equal to or greater than 0.0. System.Double.PositiveInfinity is also valid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MaxWidth Property

[image]
ActiveReports 13
MaxWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MaxWidth Property

Glossary Item Box

Gets or sets the maximum width constraint of the element.

Syntax

Visual Basic (Declaration)
Public Property MaxWidth As Double
C#
public double MaxWidth {get; set;}

Property Value

The maximum width of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.PositiveInfinity. This value can be any value equal to or greater than 0.0. System.Double.PositiveInfinity is also valid.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Measure Method

[image]
ActiveReports 13
Measure Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Measure Method

availableSize
The available space that a parent element can allocate a child element. A child element can request a larger space than what is available; the provided size might be accommodated if scrolling is possible in the content model for the current element.

Glossary Item Box

Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Parent elements call this method from their own System.Windows.UIElement.MeasureCore(System.Windows.Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update.

Syntax

Visual Basic (Declaration)
Public Sub Measure( _
   ByVal availableSize As Size _
)
C#
public void Measure(
   Size availableSize
)

Parameters

availableSize
The available space that a parent element can allocate a child element. A child element can request a larger space than what is available; the provided size might be accommodated if scrolling is possible in the content model for the current element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MinHeight Property

[image]
ActiveReports 13
MinHeight Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MinHeight Property

Glossary Item Box

Gets or sets the minimum height constraint of the element.

Syntax

Visual Basic (Declaration)
Public Property MinHeight As Double
C#
public double MinHeight {get; set;}

Property Value

The minimum height of the element, in device-independent units (1/96th inch per unit). The default value is 0.0. This value can be any value equal to or greater than 0.0. However, System.Double.PositiveInfinity is NOT valid, nor is System.Double.NaN.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MinWidth Property

[image]
ActiveReports 13
MinWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MinWidth Property

Glossary Item Box

Gets or sets the minimum width constraint of the element.

Syntax

Visual Basic (Declaration)
Public Property MinWidth As Double
C#
public double MinWidth {get; set;}

Property Value

The minimum width of the element, in device-independent units (1/96th inch per unit). The default value is 0.0. This value can be any value equal to or greater than 0.0. However, System.Double.PositiveInfinity is not valid, nor is System.Double.NaN.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseDoubleClick Event

[image]
ActiveReports 13
MouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseDoubleClick Event

Glossary Item Box

Occurs when a mouse button is clicked two or more times.

Syntax

Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseButtonEventHandler
C#
public event MouseButtonEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseDown Event

[image]
ActiveReports 13
MouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseDown Event

Glossary Item Box

Occurs when any mouse button is pressed while the pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseDown As MouseButtonEventHandler
C#
public event MouseButtonEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseEnter Event

[image]
ActiveReports 13
MouseEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseEnter Event

Glossary Item Box

Occurs when the mouse pointer enters the bounds of this element.

Syntax

Visual Basic (Declaration)
Public Event MouseEnter As MouseEventHandler
C#
public event MouseEventHandler MouseEnter

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseLeave Event

[image]
ActiveReports 13
MouseLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseLeave Event

Glossary Item Box

Occurs when the mouse pointer leaves the bounds of this element.

Syntax

Visual Basic (Declaration)
Public Event MouseLeave As MouseEventHandler
C#
public event MouseEventHandler MouseLeave

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseLeftButtonDown Event

[image]
ActiveReports 13
MouseLeftButtonDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseLeftButtonDown Event

Glossary Item Box

Occurs when the left mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseLeftButtonDown As MouseButtonEventHandler
C#
public event MouseButtonEventHandler MouseLeftButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseLeftButtonUp Event

[image]
ActiveReports 13
MouseLeftButtonUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseLeftButtonUp Event

Glossary Item Box

Occurs when the left mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseLeftButtonUp As MouseButtonEventHandler
C#
public event MouseButtonEventHandler MouseLeftButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseMove Event

[image]
ActiveReports 13
MouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseMove Event

Glossary Item Box

Occurs when the mouse pointer moves while over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseRightButtonDown Event

[image]
ActiveReports 13
MouseRightButtonDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseRightButtonDown Event

Glossary Item Box

Occurs when the right mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseRightButtonDown As MouseButtonEventHandler
C#
public event MouseButtonEventHandler MouseRightButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseRightButtonUp Event

[image]
ActiveReports 13
MouseRightButtonUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseRightButtonUp Event

Glossary Item Box

Occurs when the right mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseRightButtonUp As MouseButtonEventHandler
C#
public event MouseButtonEventHandler MouseRightButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseUp Event

[image]
ActiveReports 13
MouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseUp Event

Glossary Item Box

Occurs when any mouse button is released over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseUp As MouseButtonEventHandler
C#
public event MouseButtonEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MouseWheel Event

[image]
ActiveReports 13
MouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseWheel Event

Glossary Item Box

Occurs when the user rotates the mouse wheel while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event MouseWheel As MouseWheelEventHandler
C#
public event MouseWheelEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseWheelEventArgs containing data related to this event. The following MouseWheelEventArgs properties provide information specific to this event.

Property | Description
Delta | Gets a value that indicates the amount that the mouse wheel has changed.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


MoveFocus Method

[image]
ActiveReports 13
MoveFocus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MoveFocus Method

request
The direction that focus is to be moved, as a value of the enumeration.

Glossary Item Box

Moves the keyboard focus away from this element and to another element in a provided traversal direction.

Syntax

Visual Basic (Declaration)
Public Function MoveFocus( _
   ByVal request As TraversalRequest _
) As Boolean
C#
public bool MoveFocus(
   TraversalRequest request
)

Parameters

request
The direction that focus is to be moved, as a value of the enumeration.

Return Value

Returns true if focus is moved successfully; false if the target element in direction as specified does not exist or could not be keyboard focused.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Name Property

[image]
ActiveReports 13
Name Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Name Property

Glossary Item Box

Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the element. The default is an empty string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Opacity Property

[image]
ActiveReports 13
Opacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Opacity Property

Glossary Item Box

Gets or sets the opacity factor applied to the entire System.Windows.UIElement when it is rendered in the user interface (UI). This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Double
C#
public double Opacity {get; set;}

Property Value

The opacity factor. Default opacity is 1.0. Expected values are between 0.0 and 1.0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


OpacityMask Property

[image]
ActiveReports 13
OpacityMask Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : OpacityMask Property

Glossary Item Box

Gets or sets an opacity mask, as a System.Windows.Media.Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property OpacityMask As Brush
C#
public Brush OpacityMask {get; set;}

Property Value

The brush to use for opacity masking.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


OverridesDefaultStyle Property

[image]
ActiveReports 13
OverridesDefaultStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : OverridesDefaultStyle Property

Glossary Item Box

Gets or sets a value that indicates whether this element incorporates style properties from theme styles.

Syntax

Visual Basic (Declaration)
Public Property OverridesDefaultStyle As Boolean
C#
public bool OverridesDefaultStyle {get; set;}

Property Value

true if this element does not use theme style properties; all style-originating properties come from local application styles, and theme style properties do not apply. false if application styles apply first, and then theme styles apply for properties that were not specifically set in application styles. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Padding Property

[image]
ActiveReports 13
Padding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Padding Property

Glossary Item Box

Gets or sets the padding inside a control.

Syntax

Visual Basic (Declaration)
Public Property Padding As Thickness
C#
public Thickness Padding {get; set;}

Property Value

The amount of space between the content of a System.Windows.Controls.Control and its System.Windows.FrameworkElement.Margin or System.Windows.Controls.Border. The default is a thickness of 0 on all four sides.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Parent Property

Glossary Item Box

Gets the logical parent element of this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As DependencyObject
C#
public DependencyObject Parent {get;}

Property Value

This element's logical parent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PersistId Property

[image]
ActiveReports 13
PersistId Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PersistId Property

Glossary Item Box

Gets a value that uniquely identifies this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PersistId As Integer
C#
public int PersistId {get;}

Property Value

The unique identifier for this element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PointFromScreen Method

[image]
ActiveReports 13
PointFromScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PointFromScreen Method

point
The System.Windows.Point value in screen coordinates.

Glossary Item Box

Converts a System.Windows.Point in screen coordinates into a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual.

Syntax

Visual Basic (Declaration)
Public Function PointFromScreen( _
   ByVal point As Point _
) As Point
C#
public Point PointFromScreen(
   Point point
)

Parameters

point
The System.Windows.Point value in screen coordinates.

Return Value

The converted System.Windows.Point value that represents the current coordinate system of the System.Windows.Media.Visual.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PointToScreen Method

[image]
ActiveReports 13
PointToScreen Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PointToScreen Method

point
The System.Windows.Point value that represents the current coordinate system of the System.Windows.Media.Visual.

Glossary Item Box

Converts a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual into a System.Windows.Point in screen coordinates.

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal point As Point _
) As Point
C#
public Point PointToScreen(
   Point point
)

Parameters

point
The System.Windows.Point value that represents the current coordinate system of the System.Windows.Media.Visual.

Return Value

The converted System.Windows.Point value in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PredictFocus Method

[image]
ActiveReports 13
PredictFocus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PredictFocus Method

direction
The direction for which a prospective focus change should be determined.

Glossary Item Box

Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus.

Syntax

Visual Basic (Declaration)
Public Function PredictFocus( _
   ByVal direction As FocusNavigationDirection _
) As DependencyObject
C#
public DependencyObject PredictFocus(
   FocusNavigationDirection direction
)

Parameters

direction
The direction for which a prospective focus change should be determined.

Return Value

The next element that focus would move to if focus were actually traversed. May return a null reference (Nothing in Visual Basic) if focus cannot be moved relative to this element for the provided direction.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Specified one of the following directions in the System.Windows.Input.TraversalRequest: System.Windows.Input.FocusNavigationDirection.Next, System.Windows.Input.FocusNavigationDirection.Previous, System.Windows.Input.FocusNavigationDirection.First, System.Windows.Input.FocusNavigationDirection.Last. These directions are not legal for System.Windows.FrameworkElement.PredictFocus(System.Windows.Input.FocusNavigationDirection) (but they are legal for System.Windows.FrameworkElement.MoveFocus(System.Windows.Input.TraversalRequest)).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewDragEnter Event

[image]
ActiveReports 13
PreviewDragEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDragEnter Event

Glossary Item Box

Occurs when the input system reports an underlying drag event with this element as the drag target.

Syntax

Visual Basic (Declaration)
Public Event PreviewDragEnter As DragEventHandler
C#
public event DragEventHandler PreviewDragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewDragLeave Event

[image]
ActiveReports 13
PreviewDragLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDragLeave Event

Glossary Item Box

Occurs when the input system reports an underlying drag event with this element as the drag origin.

Syntax

Visual Basic (Declaration)
Public Event PreviewDragLeave As DragEventHandler
C#
public event DragEventHandler PreviewDragLeave

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewDragOver Event

[image]
ActiveReports 13
PreviewDragOver Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDragOver Event

Glossary Item Box

Occurs when the input system reports an underlying drag event with this element as the potential drop target.

Syntax

Visual Basic (Declaration)
Public Event PreviewDragOver As DragEventHandler
C#
public event DragEventHandler PreviewDragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewDrop Event

[image]
ActiveReports 13
PreviewDrop Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDrop Event

Glossary Item Box

Occurs when the input system reports an underlying drop event with this element as the drop target.

Syntax

Visual Basic (Declaration)
Public Event PreviewDrop As DragEventHandler
C#
public event DragEventHandler PreviewDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewGiveFeedback Event

[image]
ActiveReports 13
PreviewGiveFeedback Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewGiveFeedback Event

Glossary Item Box

Occurs when a drag-and-drop operation is started.

Syntax

Visual Basic (Declaration)
Public Event PreviewGiveFeedback As GiveFeedbackEventHandler
C#
public event GiveFeedbackEventHandler PreviewGiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effects | Gets a value that indicates the effects of drag-and-drop operation.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
UseDefaultCursors | Gets or sets a Boolean value indicating whether default cursor feedback behavior should be used for the associated drag-and-drop operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewGotKeyboardFocus Event

[image]
ActiveReports 13
PreviewGotKeyboardFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewGotKeyboardFocus Event

Glossary Item Box

Occurs when the keyboard is focused on this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewGotKeyboardFocus As KeyboardFocusChangedEventHandler
C#
public event KeyboardFocusChangedEventHandler PreviewGotKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewKeyDown Event

[image]
ActiveReports 13
PreviewKeyDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewKeyDown Event

Glossary Item Box

Occurs when a key is pressed while focus is on this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyDown As KeyEventHandler
C#
public event KeyEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
KeyStates | Gets the state of the keyboard key associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewKeyUp Event

[image]
ActiveReports 13
PreviewKeyUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewKeyUp Event

Glossary Item Box

Occurs when a key is released while focus is on this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewKeyUp As KeyEventHandler
C#
public event KeyEventHandler PreviewKeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
KeyStates | Gets the state of the keyboard key associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewLostKeyboardFocus Event

[image]
ActiveReports 13
PreviewLostKeyboardFocus Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewLostKeyboardFocus Event

Glossary Item Box

Occurs when the keyboard is no longer focused on this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewLostKeyboardFocus As KeyboardFocusChangedEventHandler
C#
public event KeyboardFocusChangedEventHandler PreviewLostKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseDoubleClick Event

[image]
ActiveReports 13
PreviewMouseDoubleClick Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseDoubleClick Event

Glossary Item Box

Occurs when a user clicks the mouse button two or more times.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseDoubleClick As MouseButtonEventHandler
C#
public event MouseButtonEventHandler PreviewMouseDoubleClick

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseDown Event

[image]
ActiveReports 13
PreviewMouseDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseDown Event

Glossary Item Box

Occurs when any mouse button is pressed while the pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseDown As MouseButtonEventHandler
C#
public event MouseButtonEventHandler PreviewMouseDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseLeftButtonDown Event

[image]
ActiveReports 13
PreviewMouseLeftButtonDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseLeftButtonDown Event

Glossary Item Box

Occurs when the left mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseLeftButtonDown As MouseButtonEventHandler
C#
public event MouseButtonEventHandler PreviewMouseLeftButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseLeftButtonUp Event

[image]
ActiveReports 13
PreviewMouseLeftButtonUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseLeftButtonUp Event

Glossary Item Box

Occurs when the left mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseLeftButtonUp As MouseButtonEventHandler
C#
public event MouseButtonEventHandler PreviewMouseLeftButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseMove Event

[image]
ActiveReports 13
PreviewMouseMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseMove Event

Glossary Item Box

Occurs when the mouse pointer moves while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseMove As MouseEventHandler
C#
public event MouseEventHandler PreviewMouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseRightButtonDown Event

[image]
ActiveReports 13
PreviewMouseRightButtonDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseRightButtonDown Event

Glossary Item Box

Occurs when the right mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseRightButtonDown As MouseButtonEventHandler
C#
public event MouseButtonEventHandler PreviewMouseRightButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseRightButtonUp Event

[image]
ActiveReports 13
PreviewMouseRightButtonUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseRightButtonUp Event

Glossary Item Box

Occurs when the right mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseRightButtonUp As MouseButtonEventHandler
C#
public event MouseButtonEventHandler PreviewMouseRightButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseUp Event

[image]
ActiveReports 13
PreviewMouseUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseUp Event

Glossary Item Box

Occurs when any mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseUp As MouseButtonEventHandler
C#
public event MouseButtonEventHandler PreviewMouseUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewMouseWheel Event

[image]
ActiveReports 13
PreviewMouseWheel Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseWheel Event

Glossary Item Box

Occurs when the user rotates the mouse wheel while the mouse pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewMouseWheel As MouseWheelEventHandler
C#
public event MouseWheelEventHandler PreviewMouseWheel

Event Data

The event handler receives an argument of type MouseWheelEventArgs containing data related to this event. The following MouseWheelEventArgs properties provide information specific to this event.

Property | Description
Delta | Gets a value that indicates the amount that the mouse wheel has changed.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewQueryContinueDrag Event

[image]
ActiveReports 13
PreviewQueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewQueryContinueDrag Event

Glossary Item Box

Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Event PreviewQueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler PreviewQueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the current status of the associated drag-and-drop operation.
EscapePressed | Gets a Boolean value indicating whether the ESC key has been pressed.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusButtonDown Event

[image]
ActiveReports 13
PreviewStylusButtonDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusButtonDown Event

Glossary Item Box

Occurs when the stylus button is pressed while the pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusButtonDown As StylusButtonEventHandler
C#
public event StylusButtonEventHandler PreviewStylusButtonDown

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusButtonUp Event

[image]
ActiveReports 13
PreviewStylusButtonUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusButtonUp Event

Glossary Item Box

Occurs when the stylus button is released while the pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusButtonUp As StylusButtonEventHandler
C#
public event StylusButtonEventHandler PreviewStylusButtonUp

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusDown Event

[image]
ActiveReports 13
PreviewStylusDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusDown Event

Glossary Item Box

Occurs when the stylus touches the digitizer while it is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusDown As StylusDownEventHandler
C#
public event StylusDownEventHandler PreviewStylusDown

Event Data

The event handler receives an argument of type StylusDownEventArgs containing data related to this event. The following StylusDownEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
TapCount | Gets the number of times the tablet pen was tapped.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusInAirMove Event

[image]
ActiveReports 13
PreviewStylusInAirMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusInAirMove Event

Glossary Item Box

Occurs when the stylus moves over an element without actually touching the digitizer.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusInAirMove As StylusEventHandler
C#
public event StylusEventHandler PreviewStylusInAirMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusInRange Event

[image]
ActiveReports 13
PreviewStylusInRange Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusInRange Event

Glossary Item Box

Occurs when the stylus is close enough to the digitizer to be detected, while over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusInRange As StylusEventHandler
C#
public event StylusEventHandler PreviewStylusInRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusMove Event

[image]
ActiveReports 13
PreviewStylusMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusMove Event

Glossary Item Box

Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, System.Windows.UIElement.PreviewStylusInAirMove is raised instead.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusMove As StylusEventHandler
C#
public event StylusEventHandler PreviewStylusMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusOutOfRange Event

[image]
ActiveReports 13
PreviewStylusOutOfRange Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusOutOfRange Event

Glossary Item Box

Occurs when the stylus is too far from the digitizer to be detected.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusOutOfRange As StylusEventHandler
C#
public event StylusEventHandler PreviewStylusOutOfRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusSystemGesture Event

[image]
ActiveReports 13
PreviewStylusSystemGesture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusSystemGesture Event

Glossary Item Box

Occurs when a user performs one of several stylus gestures.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusSystemGesture As StylusSystemGestureEventHandler
C#
public event StylusSystemGestureEventHandler PreviewStylusSystemGesture

Event Data

The event handler receives an argument of type StylusSystemGestureEventArgs containing data related to this event. The following StylusSystemGestureEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
SystemGesture | Gets the System.Windows.Input.SystemGesture that raises the event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewStylusUp Event

[image]
ActiveReports 13
PreviewStylusUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusUp Event

Glossary Item Box

Occurs when the user raises the stylus off the digitizer while the stylus is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewStylusUp As StylusEventHandler
C#
public event StylusEventHandler PreviewStylusUp

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewTextInput Event

[image]
ActiveReports 13
PreviewTextInput Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTextInput Event

Glossary Item Box

Occurs when this element gets text in a device-independent manner.

Syntax

Visual Basic (Declaration)
Public Event PreviewTextInput As TextCompositionEventHandler
C#
public event TextCompositionEventHandler PreviewTextInput

Event Data

The event handler receives an argument of type TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
ControlText | Gets control text associated with a System.Windows.Input.TextComposition event.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
SystemText | Gets system text associated with a System.Windows.Input.TextComposition event.
Text | Gets input text associated with a System.Windows.Input.TextComposition event.
TextComposition | Gets the System.Windows.Input.TextComposition associated with a System.Windows.Input.TextComposition event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewTouchDown Event

[image]
ActiveReports 13
PreviewTouchDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTouchDown Event

Glossary Item Box

Occurs when a finger touches the screen while the finger is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewTouchDown As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> PreviewTouchDown

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewTouchMove Event

[image]
ActiveReports 13
PreviewTouchMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTouchMove Event

Glossary Item Box

Occurs when a finger moves on the screen while the finger is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewTouchMove As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> PreviewTouchMove

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


PreviewTouchUp Event

[image]
ActiveReports 13
PreviewTouchUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTouchUp Event

Glossary Item Box

Occurs when a finger is raised off of the screen while the finger is over this element.

Syntax

Visual Basic (Declaration)
Public Event PreviewTouchUp As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> PreviewTouchUp

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


QueryContinueDrag Event

[image]
ActiveReports 13
QueryContinueDrag Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : QueryContinueDrag Event

Glossary Item Box

Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Event QueryContinueDrag As QueryContinueDragEventHandler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the current status of the associated drag-and-drop operation.
EscapePressed | Gets a Boolean value indicating whether the ESC key has been pressed.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


QueryCursor Event

[image]
ActiveReports 13
QueryCursor Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : QueryCursor Event

Glossary Item Box

Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position.

Syntax

Visual Basic (Declaration)
Public Event QueryCursor As QueryCursorEventHandler
C#
public event QueryCursorEventHandler QueryCursor

Event Data

The event handler receives an argument of type QueryCursorEventArgs containing data related to this event. The following QueryCursorEventArgs properties provide information specific to this event.

Property | Description
Cursor | Gets or sets the cursor associated with this event.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
LeftButton | Gets the current state of the left mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | Gets the current state of the middle mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | Gets the mouse device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RightButton | Gets the current state of the right mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the stylus device associated with this event. (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | Gets the current state of the first extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | Gets the state of the second extended mouse button. (Inherited from System.Windows.Input.MouseEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RaiseEvent Method

[image]
ActiveReports 13
RaiseEvent Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RaiseEvent Method

Glossary Item Box

Raises a specific routed event. The System.Windows.RoutedEvent to be raised is identified within the System.Windows.RoutedEventArgs instance that is provided (as the System.Windows.RoutedEventArgs.RoutedEvent property of that event data).

Overload List

Overload | Description
RaiseEvent | Raises a specific routed event. The System.Windows.RoutedEvent to be raised is identified within the System.Windows.RoutedEventArgs instance that is provided (as the System.Windows.RoutedEventArgs.RoutedEvent property of that event data). (Inherited from System.Windows.UIElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RaiseEvent(RoutedEventArgs) Method

[image]
ActiveReports 13
RaiseEvent(RoutedEventArgs) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RaiseEvent(RoutedEventArgs) Method

e
A System.Windows.RoutedEventArgs that contains the event data and also identifies the event to raise.

Glossary Item Box

Raises a specific routed event. The System.Windows.RoutedEvent to be raised is identified within the System.Windows.RoutedEventArgs instance that is provided (as the System.Windows.RoutedEventArgs.RoutedEvent property of that event data).

Syntax

Visual Basic (Declaration)
Public Sub RaiseEvent( _
   ByVal e As RoutedEventArgs _
)
C#
public void RaiseEvent(
   RoutedEventArgs e
)

Parameters

e
A System.Windows.RoutedEventArgs that contains the event data and also identifies the event to raise.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ReadLocalValue Method

[image]
ActiveReports 13
ReadLocalValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Glossary Item Box

Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Declaration)
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RegisterName Method

[image]
ActiveReports 13
RegisterName Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RegisterName Method

name
Name to use for the specified name-object mapping.
scopedElement
Object for the mapping.

Glossary Item Box

Provides an accessor that simplifies access to the System.Windows.NameScope registration method.

Syntax

Visual Basic (Declaration)
Public Sub RegisterName( _
   ByVal name As String, _
   ByVal scopedElement As Object _
)
C#
public void RegisterName(
   string name,
   object scopedElement
)

Parameters

name
Name to use for the specified name-object mapping.
scopedElement
Object for the mapping.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ReleaseAllTouchCaptures Method

[image]
ActiveReports 13
ReleaseAllTouchCaptures Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseAllTouchCaptures Method

Glossary Item Box

Releases all captured touch devices from this element.

Syntax

Visual Basic (Declaration)
Public Sub ReleaseAllTouchCaptures()
C#
public void ReleaseAllTouchCaptures()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ReleaseMouseCapture Method

[image]
ActiveReports 13
ReleaseMouseCapture Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseMouseCapture Method

Glossary Item Box

Releases the mouse capture, if this element held the capture.

Syntax

Visual Basic (Declaration)
Public Sub ReleaseMouseCapture()
C#
public void ReleaseMouseCapture()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ReleaseStylusCapture Method

[image]
ActiveReports 13
ReleaseStylusCapture Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseStylusCapture Method

Glossary Item Box

Releases the stylus device capture, if this element held the capture.

Syntax

Visual Basic (Declaration)
Public Sub ReleaseStylusCapture()
C#
public void ReleaseStylusCapture()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ReleaseTouchCapture Method

[image]
ActiveReports 13
ReleaseTouchCapture Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseTouchCapture Method

touchDevice
The device to release.

Glossary Item Box

Attempts to release the specified touch device from this element.

Syntax

Visual Basic (Declaration)
Public Function ReleaseTouchCapture( _
   ByVal touchDevice As TouchDevice _
) As Boolean
C#
public bool ReleaseTouchCapture(
   TouchDevice touchDevice
)

Parameters

touchDevice
The device to release.

Return Value

true if the touch device is released; otherwise, false.

Exceptions

Exception | Description
System.ArgumentNullException | touchDevice is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RemoveHandler Method

[image]
ActiveReports 13
RemoveHandler Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RemoveHandler Method

routedEvent
handler

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
C#
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
)

Parameters

routedEvent
handler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Render Method

[image]
ActiveReports 13
Render Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Render Method

Glossary Item Box

Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.

Overload List

Overload | Description
Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RenderSize Property

[image]
ActiveReports 13
RenderSize Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RenderSize Property

Glossary Item Box

Gets (or sets) the final render size of this element.

Syntax

Visual Basic (Declaration)
Public Property RenderSize As Size
C#
public Size RenderSize {get; set;}

Property Value

The rendered size for this element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RenderTransform Property

[image]
ActiveReports 13
RenderTransform Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RenderTransform Property

Glossary Item Box

Gets or sets transform information that affects the rendering position of this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property RenderTransform As Transform
C#
public Transform RenderTransform {get; set;}

Property Value

Describes the specifics of the desired render transform. The default is System.Windows.Media.Transform.Identity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RenderTransformOrigin Property

[image]
ActiveReports 13
RenderTransformOrigin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RenderTransformOrigin Property

Glossary Item Box

Gets or sets the center point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property RenderTransformOrigin As Point
C#
public Point RenderTransformOrigin {get; set;}

Property Value

The value that declares the render transform. The default value is a System.Windows.Point with coordinates (0,0).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


RequestBringIntoView Event

[image]
ActiveReports 13
RequestBringIntoView Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RequestBringIntoView Event

Glossary Item Box

Occurs when System.Windows.FrameworkElement.BringIntoView(System.Windows.Rect) is called on this element.

Syntax

Visual Basic (Declaration)
Public Event RequestBringIntoView As RequestBringIntoViewEventHandler
C#
public event RequestBringIntoViewEventHandler RequestBringIntoView

Event Data

The event handler receives an argument of type RequestBringIntoViewEventArgs containing data related to this event. The following RequestBringIntoViewEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
TargetObject | Gets the object that should be made visible in response to the event.
TargetRect | Gets the rectangular region in the object's coordinate space which should be made visible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Resources Property

[image]
ActiveReports 13
Resources Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Resources Property

Glossary Item Box

Gets or sets the locally-defined resource dictionary.

Syntax

Visual Basic (Declaration)
Public Property Resources As ResourceDictionary
C#
public ResourceDictionary Resources {get; set;}

Property Value

The current locally-defined dictionary of resources, where each resource can be accessed by key.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetBinding Method

[image]
ActiveReports 13
SetBinding Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetBinding Method

Glossary Item Box

Attaches a binding to this element, based on the provided binding object.

Overload List

Overload | Description
SetBinding(DependencyProperty,BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from System.Windows.FrameworkElement)
SetBinding(DependencyProperty,String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from System.Windows.FrameworkElement)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetBinding(DependencyProperty,BindingBase) Method

[image]
ActiveReports 13
SetBinding(DependencyProperty,BindingBase) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetBinding Method : SetBinding(DependencyProperty,BindingBase) Method

dp
Identifies the property where the binding should be established.
binding
Represents the specifics of the data binding.

Glossary Item Box

Attaches a binding to this element, based on the provided binding object.

Syntax

Visual Basic (Declaration)
Public Overloads Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As BindingBase _
) As BindingExpressionBase
C#
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   BindingBase binding
)

Parameters

dp
Identifies the property where the binding should be established.
binding
Represents the specifics of the data binding.

Return Value

Records the conditions of the binding. This return value can be useful for error checking.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


SetBinding(DependencyProperty,String) Method

[image]
ActiveReports 13
SetBinding(DependencyProperty,String) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetBinding Method : SetBinding(DependencyProperty,String) Method

dp
Identifies the destination property where the binding should be established.
path
The source property name or the path to the property used for the binding.

Glossary Item Box

Attaches a binding to this element, based on the provided source property name as a path qualification to the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal path As String _
) As BindingExpression
C#
public BindingExpression SetBinding(
   DependencyProperty dp,
   string path
)

Parameters

dp
Identifies the destination property where the binding should be established.
path
The source property name or the path to the property used for the binding.

Return Value

Records the conditions of the binding. This return value can be useful for error checking.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


SetCurrentValue Method

[image]
ActiveReports 13
SetCurrentValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetCurrentValue Method

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Overload List

Overload | Description
SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetCurrentValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetCurrentValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetResourceReference Method

[image]
ActiveReports 13
SetResourceReference Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetResourceReference Method

dp
The property to which the resource is bound.
name
The name of the resource.

Glossary Item Box

Searches for a resource with the specified name and sets up a resource reference to it for the specified property.

Syntax

Visual Basic (Declaration)
Public Sub SetResourceReference( _
   ByVal dp As DependencyProperty, _
   ByVal name As Object _
)
C#
public void SetResourceReference(
   DependencyProperty dp,
   object name
)

Parameters

dp
The property to which the resource is bound.
name
The name of the resource.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetValue Method

[image]
ActiveReports 13
SetValue Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetValue Method

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Overload List

Overload | Description
SetValue(DependencyProperty,Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property. (Inherited from System.Windows.DependencyObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SetValue(DependencyProperty,Object) Method

[image]
ActiveReports 13
SetValue(DependencyProperty,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

[image]
ActiveReports 13
SetValue(DependencyPropertyKey,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Glossary Item Box

Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal key As DependencyPropertyKey, _
   ByVal value As Object _
)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


SizeChanged Event

[image]
ActiveReports 13
SizeChanged Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SizeChanged Event

Glossary Item Box

Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on this element.

Syntax

Visual Basic (Declaration)
Public Event SizeChanged As SizeChangedEventHandler
C#
public event SizeChangedEventHandler SizeChanged

Event Data

The event handler receives an argument of type SizeChangedEventArgs containing data related to this event. The following SizeChangedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
HeightChanged | Gets a value that indicates whether the System.Windows.FrameworkElement.Height component of the size changed.
NewSize | Gets the new System.Windows.Size of the object.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
PreviousSize | Gets the previous System.Windows.Size of the object.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
WidthChanged | Gets a value that indicates whether the System.Windows.FrameworkElement.Width component of the size changed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SnapsToDevicePixels Property

[image]
ActiveReports 13
SnapsToDevicePixels Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SnapsToDevicePixels Property

Glossary Item Box

Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property SnapsToDevicePixels As Boolean
C#
public bool SnapsToDevicePixels {get; set;}

Property Value

true if the element should render in accordance to device pixels; otherwise, false. The default as declared on System.Windows.UIElement is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


SourceUpdated Event

[image]
ActiveReports 13
SourceUpdated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SourceUpdated Event

Glossary Item Box

Occurs when the source value changes for any existing property binding on this element.

Syntax

Visual Basic (Declaration)
Public Event SourceUpdated As EventHandler(Of DataTransferEventArgs)
C#
public event EventHandler<DataTransferEventArgs> SourceUpdated

Event Data

The event handler receives an argument of type DataTransferEventArgs containing data related to this event. The following DataTransferEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
Property | Gets the specific binding target property that is involved in the data transfer event.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
TargetObject | Gets the binding target object of the binding that raised the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Style Property

[image]
ActiveReports 13
Style Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Style Property

Glossary Item Box

Gets or sets the style used by this element when it is rendered.

Syntax

Visual Basic (Declaration)
Public Property Style As Style
C#
public Style Style {get; set;}

Property Value

The applied, nondefault style for the element, if present. Otherwise, a null reference (Nothing in Visual Basic). The default for a default-constructed System.Windows.FrameworkElement is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusButtonDown Event

[image]
ActiveReports 13
StylusButtonDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusButtonDown Event

Glossary Item Box

Occurs when the stylus button is pressed while the pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event StylusButtonDown As StylusButtonEventHandler
C#
public event StylusButtonEventHandler StylusButtonDown

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusButtonUp Event

[image]
ActiveReports 13
StylusButtonUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusButtonUp Event

Glossary Item Box

Occurs when the stylus button is released while the pointer is over this element.

Syntax

Visual Basic (Declaration)
Public Event StylusButtonUp As StylusButtonEventHandler
C#
public event StylusButtonEventHandler StylusButtonUp

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusDown Event

[image]
ActiveReports 13
StylusDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusDown Event

Glossary Item Box

Occurs when the stylus touches the digitizer while the stylus is over this element.

Syntax

Visual Basic (Declaration)
Public Event StylusDown As StylusDownEventHandler
C#
public event StylusDownEventHandler StylusDown

Event Data

The event handler receives an argument of type StylusDownEventArgs containing data related to this event. The following StylusDownEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
TapCount | Gets the number of times the tablet pen was tapped.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusEnter Event

[image]
ActiveReports 13
StylusEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusEnter Event

Glossary Item Box

Occurs when the stylus enters the bounds of this element.

Syntax

Visual Basic (Declaration)
Public Event StylusEnter As StylusEventHandler
C#
public event StylusEventHandler StylusEnter

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusInAirMove Event

[image]
ActiveReports 13
StylusInAirMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusInAirMove Event

Glossary Item Box

Occurs when the stylus moves over an element without actually touching the digitizer.

Syntax

Visual Basic (Declaration)
Public Event StylusInAirMove As StylusEventHandler
C#
public event StylusEventHandler StylusInAirMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusInRange Event

[image]
ActiveReports 13
StylusInRange Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusInRange Event

Glossary Item Box

Occurs when the stylus is close enough to the digitizer to be detected, while over this element.

Syntax

Visual Basic (Declaration)
Public Event StylusInRange As StylusEventHandler
C#
public event StylusEventHandler StylusInRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusLeave Event

[image]
ActiveReports 13
StylusLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusLeave Event

Glossary Item Box

Occurs when the stylus leaves the bounds of the element.

Syntax

Visual Basic (Declaration)
Public Event StylusLeave As StylusEventHandler
C#
public event StylusEventHandler StylusLeave

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusMove Event

[image]
ActiveReports 13
StylusMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusMove Event

Glossary Item Box

Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, System.Windows.UIElement.StylusInAirMove is raised instead.

Syntax

Visual Basic (Declaration)
Public Event StylusMove As StylusEventHandler
C#
public event StylusEventHandler StylusMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusOutOfRange Event

[image]
ActiveReports 13
StylusOutOfRange Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusOutOfRange Event

Glossary Item Box

Occurs when the stylus is too far from the digitizer to be detected, while over this element.

Syntax

Visual Basic (Declaration)
Public Event StylusOutOfRange As StylusEventHandler
C#
public event StylusEventHandler StylusOutOfRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusSystemGesture Event

[image]
ActiveReports 13
StylusSystemGesture Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusSystemGesture Event

Glossary Item Box

Occurs when a user performs one of several stylus gestures.

Syntax

Visual Basic (Declaration)
Public Event StylusSystemGesture As StylusSystemGestureEventHandler
C#
public event StylusSystemGestureEventHandler StylusSystemGesture

Event Data

The event handler receives an argument of type StylusSystemGestureEventArgs containing data related to this event. The following StylusSystemGestureEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer. (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | Gets a value that indicates whether the stylus in inverted. (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus. (Inherited from System.Windows.Input.StylusEventArgs)
SystemGesture | Gets the System.Windows.Input.SystemGesture that raises the event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


StylusUp Event

[image]
ActiveReports 13
StylusUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusUp Event

Glossary Item Box

Occurs when the user raises the stylus off the digitizer while it is over this element.

Syntax

Visual Basic (Declaration)
Public Event StylusUp As StylusEventHandler
C#
public event StylusEventHandler StylusUp

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TabIndex Property

Glossary Item Box

Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
C#
public int TabIndex {get; set;}

Property Value

A value that determines the order of logical navigation for a device. The default value is System.Int32.MaxValue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Tag Property

[image]
ActiveReports 13
Tag Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Tag Property

Glossary Item Box

Gets or sets an arbitrary object value that can be used to store custom information about this element.

Syntax

Visual Basic (Declaration)
Public Property Tag As Object
C#
public object Tag {get; set;}

Property Value

The intended value. This property has no default value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TargetUpdated Event

[image]
ActiveReports 13
TargetUpdated Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TargetUpdated Event

Glossary Item Box

Occurs when the target value changes for any property binding on this element.

Syntax

Visual Basic (Declaration)
Public Event TargetUpdated As EventHandler(Of DataTransferEventArgs)
C#
public event EventHandler<DataTransferEventArgs> TargetUpdated

Event Data

The event handler receives an argument of type DataTransferEventArgs containing data related to this event. The following DataTransferEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
Property | Gets the specific binding target property that is involved in the data transfer event.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
TargetObject | Gets the binding target object of the binding that raised the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Template Property

[image]
ActiveReports 13
Template Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Template Property

Glossary Item Box

Gets or sets a control template.

Syntax

Visual Basic (Declaration)
Public Property Template As ControlTemplate
C#
public ControlTemplate Template {get; set;}

Property Value

The template that defines the appearance of the System.Windows.Controls.Control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TemplatedParent Property

[image]
ActiveReports 13
TemplatedParent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TemplatedParent Property

Glossary Item Box

Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TemplatedParent As DependencyObject
C#
public DependencyObject TemplatedParent {get;}

Property Value

The element whose System.Windows.FrameworkTemplate System.Windows.FrameworkTemplate.VisualTree caused this element to be created. This value is frequently a null reference (Nothing in Visual Basic); see Remarks.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TextInput Event

[image]
ActiveReports 13
TextInput Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TextInput Event

Glossary Item Box

Occurs when this element gets text in a device-independent manner.

Syntax

Visual Basic (Declaration)
Public Event TextInput As TextCompositionEventHandler
C#
public event TextCompositionEventHandler TextInput

Event Data

The event handler receives an argument of type TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
ControlText | Gets control text associated with a System.Windows.Input.TextComposition event.
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
SystemText | Gets system text associated with a System.Windows.Input.TextComposition event.
Text | Gets input text associated with a System.Windows.Input.TextComposition event.
TextComposition | Gets the System.Windows.Input.TextComposition associated with a System.Windows.Input.TextComposition event.
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ToolTip Property

[image]
ActiveReports 13
ToolTip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToolTip Property

Glossary Item Box

Gets or sets the tool-tip object that is displayed for this element in the user interface (UI).

Syntax

Visual Basic (Declaration)
Public Property ToolTip As Object
C#
public object ToolTip {get; set;}

Property Value

The tooltip object. See Remarks below for details on why this parameter is not strongly typed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ToolTipClosing Event

[image]
ActiveReports 13
ToolTipClosing Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToolTipClosing Event

Glossary Item Box

Occurs just before any tooltip on the element is closed.

Syntax

Visual Basic (Declaration)
Public Event ToolTipClosing As ToolTipEventHandler
C#
public event ToolTipEventHandler ToolTipClosing

Event Data

The event handler receives an argument of type ToolTipEventArgs containing data related to this event. The following ToolTipEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ToolTipOpening Event

[image]
ActiveReports 13
ToolTipOpening Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToolTipOpening Event

Glossary Item Box

Occurs when any tooltip on the element is opened.

Syntax

Visual Basic (Declaration)
Public Event ToolTipOpening As ToolTipEventHandler
C#
public event ToolTipEventHandler ToolTipOpening

Event Data

The event handler receives an argument of type ToolTipEventArgs containing data related to this event. The following ToolTipEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToString Method

Glossary Item Box

Returns the string representation of a System.Windows.Controls.Control object.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string that represents the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchDown Event

[image]
ActiveReports 13
TouchDown Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchDown Event

Glossary Item Box

Occurs when a finger touches the screen while the finger is over this element.

Syntax

Visual Basic (Declaration)
Public Event TouchDown As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> TouchDown

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchEnter Event

[image]
ActiveReports 13
TouchEnter Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchEnter Event

Glossary Item Box

Occurs when a touch moves from outside to inside the bounds of this element.

Syntax

Visual Basic (Declaration)
Public Event TouchEnter As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> TouchEnter

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchesCaptured Property

[image]
ActiveReports 13
TouchesCaptured Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesCaptured Property

Glossary Item Box

Gets all touch devices that are captured to this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TouchesCaptured As IEnumerable(Of TouchDevice)
C#
public IEnumerable<TouchDevice> TouchesCaptured {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are captured to this element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchesCapturedWithin Property

[image]
ActiveReports 13
TouchesCapturedWithin Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesCapturedWithin Property

Glossary Item Box

Gets all touch devices that are captured to this element or any child elements in its visual tree.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TouchesCapturedWithin As IEnumerable(Of TouchDevice)
C#
public IEnumerable<TouchDevice> TouchesCapturedWithin {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are captured to this element or any child elements in its visual tree.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchesDirectlyOver Property

[image]
ActiveReports 13
TouchesDirectlyOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesDirectlyOver Property

Glossary Item Box

Gets all touch devices that are over this element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TouchesDirectlyOver As IEnumerable(Of TouchDevice)
C#
public IEnumerable<TouchDevice> TouchesDirectlyOver {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are over this element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchesOver Property

[image]
ActiveReports 13
TouchesOver Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesOver Property

Glossary Item Box

Gets all touch devices that are over this element or any child elements in its visual tree.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TouchesOver As IEnumerable(Of TouchDevice)
C#
public IEnumerable<TouchDevice> TouchesOver {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are over this element or any child elements in its visual tree.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchLeave Event

[image]
ActiveReports 13
TouchLeave Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchLeave Event

Glossary Item Box

Occurs when a touch moves from inside to outside the bounds of this element.

Syntax

Visual Basic (Declaration)
Public Event TouchLeave As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> TouchLeave

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchMove Event

[image]
ActiveReports 13
TouchMove Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchMove Event

Glossary Item Box

Occurs when a finger moves on the screen while the finger is over this element.

Syntax

Visual Basic (Declaration)
Public Event TouchMove As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> TouchMove

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TouchUp Event

[image]
ActiveReports 13
TouchUp Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchUp Event

Glossary Item Box

Occurs when a finger is raised off of the screen while the finger is over this element.

Syntax

Visual Basic (Declaration)
Public Event TouchUp As EventHandler(Of TouchEventArgs)
C#
public event EventHandler<TouchEventArgs> TouchUp

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | Gets the input device that initiated this event. (Inherited from System.Windows.Input.InputEventArgs)
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class. (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance. (Inherited from System.Windows.RoutedEventArgs)
Source | Gets or sets a reference to the object that raised the event. (Inherited from System.Windows.RoutedEventArgs)
Timestamp | Gets the time when this event occurred. (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TransformToAncestor Method

[image]
ActiveReports 13
TransformToAncestor Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TransformToAncestor Method

Glossary Item Box

Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Visual ancestor of the visual object.

Overload List

Overload | Description
TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Visual ancestor of the visual object. (Inherited from System.Windows.Media.Visual)
TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Media3D.Visual3D ancestor of the visual object. (Inherited from System.Windows.Media.Visual)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TransformToAncestor(Visual3D) Method

[image]
ActiveReports 13
TransformToAncestor(Visual3D) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > TransformToAncestor Method : TransformToAncestor(Visual3D) Method

ancestor
The System.Windows.Media.Media3D.Visual3D to which the coordinates are transformed.

Glossary Item Box

Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Media3D.Visual3D ancestor of the visual object.

Syntax

Visual Basic (Declaration)
Public Overloads Function TransformToAncestor( _
   ByVal ancestor As Visual3D _
) As GeneralTransform2DTo3D
C#
public GeneralTransform2DTo3D TransformToAncestor(
   Visual3D ancestor
)

Parameters

ancestor
The System.Windows.Media.Media3D.Visual3D to which the coordinates are transformed.

Return Value

A transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Media3D.Visual3D ancestor of the visual object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


TransformToAncestor(Visual) Method

[image]
ActiveReports 13
TransformToAncestor(Visual) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > TransformToAncestor Method : TransformToAncestor(Visual) Method

ancestor
The System.Windows.Media.Visual to which the coordinates are transformed.

Glossary Item Box

Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Visual ancestor of the visual object.

Syntax

Visual Basic (Declaration)
Public Overloads Function TransformToAncestor( _
   ByVal ancestor As Visual _
) As GeneralTransform
C#
public GeneralTransform TransformToAncestor(
   Visual ancestor
)

Parameters

ancestor
The System.Windows.Media.Visual to which the coordinates are transformed.

Return Value

A value of type System.Windows.Media.GeneralTransform.

Exceptions

Exception | Description
System.ArgumentNullException | ancestor is a null reference (Nothing in Visual Basic).
System.ArgumentException | ancestor is not an ancestor of the visual.
System.InvalidOperationException | The visual objects are not related.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members
Overload List


TransformToDescendant Method

[image]
ActiveReports 13
TransformToDescendant Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TransformToDescendant Method

descendant
The System.Windows.Media.Visual to which the coordinates are transformed.

Glossary Item Box

Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object descendant.

Syntax

Visual Basic (Declaration)
Public Function TransformToDescendant( _
   ByVal descendant As Visual _
) As GeneralTransform
C#
public GeneralTransform TransformToDescendant(
   Visual descendant
)

Parameters

descendant
The System.Windows.Media.Visual to which the coordinates are transformed.

Return Value

A value of type System.Windows.Media.GeneralTransform.

Exceptions

Exception | Description
System.ArgumentNullException | descendant is a null reference (Nothing in Visual Basic).
System.ArgumentException | The visual is not an ancestor of the descendant visual.
System.InvalidOperationException | The visual objects are not related.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TransformToVisual Method

[image]
ActiveReports 13
TransformToVisual Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TransformToVisual Method

visual
The System.Windows.Media.Visual to which the coordinates are transformed.

Glossary Item Box

Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object.

Syntax

Visual Basic (Declaration)
Public Function TransformToVisual( _
   ByVal visual As Visual _
) As GeneralTransform
C#
public GeneralTransform TransformToVisual(
   Visual visual
)

Parameters

visual
The System.Windows.Media.Visual to which the coordinates are transformed.

Return Value

A value of type System.Windows.Media.GeneralTransform.

Exceptions

Exception | Description
System.ArgumentNullException | visual is a null reference (Nothing in Visual Basic).
System.InvalidOperationException | The visual objects are not related.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TranslatePoint Method

[image]
ActiveReports 13
TranslatePoint Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TranslatePoint Method

point
The point value, as relative to this element.
relativeTo
The element to translate the given point into.

Glossary Item Box

Translates a point relative to this element to coordinates that are relative to the specified element.

Syntax

Visual Basic (Declaration)
Public Function TranslatePoint( _
   ByVal point As Point, _
   ByVal relativeTo As UIElement _
) As Point
C#
public Point TranslatePoint(
   Point point,
   UIElement relativeTo
)

Parameters

point
The point value, as relative to this element.
relativeTo
The element to translate the given point into.

Return Value

A point value, now relative to the target element rather than this source element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Triggers Property

[image]
ActiveReports 13
Triggers Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Triggers Property

Glossary Item Box

Gets the collection of triggers established directly on this element, or in child elements.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Triggers As TriggerCollection
C#
public TriggerCollection Triggers {get;}

Property Value

A strongly typed collection of System.Windows.Trigger objects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


TryFindResource Method

[image]
ActiveReports 13
TryFindResource Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TryFindResource Method

resourceKey
The key identifier of the resource to be found.

Glossary Item Box

Searches for a resource with the specified key, and returns that resource if found.

Syntax

Visual Basic (Declaration)
Public Function TryFindResource( _
   ByVal resourceKey As Object _
) As Object
C#
public object TryFindResource(
   object resourceKey
)

Parameters

resourceKey
The key identifier of the resource to be found.

Return Value

The found resource, or a null reference (Nothing in Visual Basic) if no resource with the provided key is found.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Uid Property

[image]
ActiveReports 13
Uid Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Uid Property

Glossary Item Box

Gets or sets the unique identifier (for localization) for this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Uid As String
C#
public string Uid {get; set;}

Property Value

A string that is the unique identifier for this element.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Unloaded Event

[image]
ActiveReports 13
Unloaded Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Unloaded Event

Glossary Item Box

Occurs when the element is removed from within an element tree of loaded elements.

Syntax

Visual Basic (Declaration)
Public Event Unloaded As RoutedEventHandler
C#
public event RoutedEventHandler Unloaded

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UnregisterName Method

[image]
ActiveReports 13
UnregisterName Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UnregisterName Method

name
Name of the name-object pair to remove from the current scope.

Glossary Item Box

Simplifies access to the System.Windows.NameScope de-registration method.

Syntax

Visual Basic (Declaration)
Public Sub UnregisterName( _
   ByVal name As String _
)
C#
public void UnregisterName(
   string name
)

Parameters

name
Name of the name-object pair to remove from the current scope.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UpdateDefaultStyle Method

[image]
ActiveReports 13
UpdateDefaultStyle Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UpdateDefaultStyle Method

Glossary Item Box

Reapplies the default style to the current System.Windows.FrameworkElement.

Syntax

Visual Basic (Declaration)
Public Sub UpdateDefaultStyle()
C#
public void UpdateDefaultStyle()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UpdateLayout Method

[image]
ActiveReports 13
UpdateLayout Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UpdateLayout Method

Glossary Item Box

Ensures that all visual child elements of this element are properly updated for layout.

Syntax

Visual Basic (Declaration)
Public Sub UpdateLayout()
C#
public void UpdateLayout()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


UseLayoutRounding Property

[image]
ActiveReports 13
UseLayoutRounding Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UseLayoutRounding Property

Glossary Item Box

Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout.

Syntax

Visual Basic (Declaration)
Public Property UseLayoutRounding As Boolean
C#
public bool UseLayoutRounding {get; set;}

Property Value

true if layout rounding is applied; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


VerticalAlignment Property

[image]
ActiveReports 13
VerticalAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : VerticalAlignment Property

Glossary Item Box

Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As VerticalAlignment
C#
public VerticalAlignment VerticalAlignment {get; set;}

Property Value

A vertical alignment setting. The default is System.Windows.VerticalAlignment.Stretch.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


VerticalContentAlignment Property

[image]
ActiveReports 13
VerticalContentAlignment Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : VerticalContentAlignment Property

Glossary Item Box

Gets or sets the vertical alignment of the control's content.

Syntax

Visual Basic (Declaration)
Public Property VerticalContentAlignment As VerticalAlignment
C#
public VerticalAlignment VerticalContentAlignment {get; set;}

Property Value

One of the System.Windows.VerticalAlignment values. The default is System.Windows.VerticalAlignment.Top.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Visibility Property

[image]
ActiveReports 13
Visibility Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Visibility Property

Glossary Item Box

Gets or sets the user interface (UI) visibility of this element. This is a dependency property.

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
C#
public Visibility Visibility {get; set;}

Property Value

A value of the enumeration. The default value is System.Windows.Visibility.Visible.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Width Property

Glossary Item Box

Gets or sets the width of the element.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
C#
public double Width {get; set;}

Property Value

The width of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.NaN. This value must be equal to or greater than 0.0. See Remarks for upper bound information.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewer Class
Viewer Members


GrapeCity.ActiveReports.Viewer.Wpf Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Viewer.Wpf Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly : GrapeCity.ActiveReports.Viewer.Wpf Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Wpf.Viewer.ActionEventArgs
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.Sidebar
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ParametersPanel
GrapeCity.ActiveReports.Viewer.Wpf.SearchPanel
GrapeCity.ActiveReports.Viewer.Wpf.ThumbnailsPanel
GrapeCity.ActiveReports.Viewer.Wpf.TocPanel
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
GrapeCity.ActiveReports.Viewer.Wpf.Viewer

See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf Assembly


CachedPageView Class Properties

[image]
ActiveReports 13
CachedPageView Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

Glossary Item Box

For a list of all members of this type, see CachedPageView members.

Public Properties

 | Name | Description
Public Property | Device | Gets the device kind. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Property | Size | Gets the page view size. (Inherited from GrapeCity.Viewer.Common.PageView)
Top

See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


Color Constructor

[image]
ActiveReports 13
Color Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Color Constructor

Glossary Item Box

Overload List

Overload | Description
Color Constructor | Initializes a new instance of the Color struct.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Color Structure
Color Members


DelegateCommand Class Events

[image]
ActiveReports 13
DelegateCommand Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

Glossary Item Box

For a list of all members of this type, see DelegateCommand members.

Public Events

 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top

See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DelegateCommand Class Methods

[image]
ActiveReports 13
DelegateCommand Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

Glossary Item Box

For a list of all members of this type, see DelegateCommand members.

Public Methods

 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top

See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Class Methods

[image]
ActiveReports 13
DocumentRendererAttribute Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

Glossary Item Box

For a list of all members of this type, see DocumentRendererAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : Equals Method

obj
An System.Object to compare with this instance or a null reference (Nothing in Visual Basic).

Glossary Item Box

Returns a value that indicates whether this instance is equal to a specified object.

Syntax

Visual Basic (Declaration)
Public Overridable Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public virtual bool Equals(
   object obj
)

Parameters

obj
An System.Object to compare with this instance or a null reference (Nothing in Visual Basic).

Return Value

true if obj and this instance are of the same type and have identical field values; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


GetHashCode Method

[image]
ActiveReports 13
GetHashCode Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : GetHashCode Method

Glossary Item Box

Returns the hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As Integer
C#
public virtual int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


IsDefaultAttribute Method

[image]
ActiveReports 13
IsDefaultAttribute Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : IsDefaultAttribute Method

Glossary Item Box

When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
C#
public virtual bool IsDefaultAttribute()

Return Value

true if this instance is the default attribute for the class; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


Match Method

[image]
ActiveReports 13
Match Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : Match Method

obj
An System.Object to compare with this instance of System.Attribute.

Glossary Item Box

When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
C#
public virtual bool Match(
   object obj
)

Parameters

obj
An System.Object to compare with this instance of System.Attribute.

Return Value

true if this instance equals obj; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


TypeId Property

[image]
ActiveReports 13
TypeId Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : TypeId Property

Glossary Item Box

When implemented in a derived class, gets a unique identifier for this System.Attribute.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
C#
public virtual object TypeId {get;}

Property Value

An System.Object that is a unique identifier for the attribute.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


ObservableCollection<T> Class Methods

[image]
ActiveReports 13
ObservableCollection<T> Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

Glossary Item Box

For a list of all members of this type, see ObservableCollection<T> members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Class Properties

[image]
ActiveReports 13
ObservableCollection<T> Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

Glossary Item Box

For a list of all members of this type, see ObservableCollection<T> members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Add Method

item
The object to be added to the end of the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Adds an object to the end of the Collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As T _
)
C#
public void Add(
   T item
)

Parameters

item
The object to be added to the end of the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Clear Method

Glossary Item Box

Removes all elements from the Collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Contains Method

item
The object to locate in the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Determines whether an element is in the Collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As T _
) As Boolean
C#
public bool Contains(
   T item
)

Parameters

item
The object to locate in the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As T, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   T[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is a null reference (Nothing in Visual Basic).
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Count Property

Glossary Item Box

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : IndexOf Method

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As T _
) As Integer
C#
public int IndexOf(
   T item
)

Parameters

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

The zero-based index of the first occurrence of item within the entire Collection, if found; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Insert Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Inserts an element into the Collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As T _
)
C#
public void Insert(
   int index,
   T item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Item Property

[image]
ActiveReports 13
Item Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Item Property

index
The zero-based index of the element to get or set.

Glossary Item Box

Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As T
C#
public T this[
   int index
]; {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Remove Method

[image]
ActiveReports 13
Remove Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Remove Method

item
The object to remove from the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Removes the first occurrence of a specific object from the Collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As T _
) As Boolean
C#
public bool Remove(
   T item
)

Parameters

item
The object to remove from the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the original Collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the Collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


GrapeCity.Viewer.Common Namespace Inheritance Hierarchy

GrapeCity.Viewer.Common Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Viewer.Wpf Assembly : GrapeCity.Viewer.Common Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DelegateCommand<TParm>
GrapeCity.Viewer.Common.DelegateCommand
GrapeCity.Viewer.Common.DisposablesCollection
GrapeCity.Viewer.Common.DocumentSearchService
GrapeCity.Viewer.Common.DoubleDelegateCommand
GrapeCity.Viewer.Common.EnumerableExtensions
GrapeCity.Viewer.Common.NullDelegateCommand
GrapeCity.Viewer.Common.NullRenderer
GrapeCity.Viewer.Common.NullRenderer.Factory
GrapeCity.Viewer.Common.PageView
GrapeCity.Viewer.Common.CachedPageView
GrapeCity.Viewer.Common.RectExtensions
GrapeCity.Viewer.Common.StreamDocumentLoader
System.Attribute
GrapeCity.Viewer.Common.DocumentRendererAttribute
System.Collections.ObjectModel.Collection<T>
GrapeCity.Viewer.Common.ObservableCollection<T>
System.EventArgs
GrapeCity.Viewer.Common.NotifyCollectionChangedEventArgs
System.ValueType
GrapeCity.Viewer.Common.Color
GrapeCity.Viewer.Common.Margin
GrapeCity.Viewer.Common.Point
GrapeCity.Viewer.Common.Rect
GrapeCity.Viewer.Common.Size

See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf Assembly


Assembly Overview

GrapeCity.ActiveReports.Web Assembly
See Also
Product Support Forum | Print this page

Glossary Item Box

Namespaces

Namespace | Description
GrapeCity.ActiveReports.Web | The GrapeCity.ActiveReports.Web namespace contains the WebViewer class.
GrapeCity.ActiveReports.Web.Controls | The GrapeCity.ActiveReports.Web.Controls namespace contains the customizable toolbar object and tools that can be used with the FlashViewer ViewerType of the WebViewer.
GrapeCity.ActiveReports.Web.ExportOptions | The GrapeCity.ActiveReports.Web.ExportOptions namespace contains the HtmlExport and PdfExport classes.
GrapeCity.ActiveReports.Web.Handlers | The GrapeCity.ActiveReports.Web.Handlers namespace contains the classes which handle the report types for web consumption.


ToolsCollection Class Methods

[image]
ActiveReports 13
ToolsCollection Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class

Glossary Item Box

For a list of all members of this type, see ToolsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Add the specified tool to the tools collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Clear | Clears all tools from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Remove | Removes the specified tool from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | RemoveAt | Removes the tool in the specified position from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Top

See Also

Reference

ToolsCollection Class
GrapeCity.ActiveReports.Web.Controls Namespace


Add Method

[image]
ActiveReports 13
Add Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Add Method

item
The Tool object to add to the collection.

Glossary Item Box

Add the specified tool to the tools collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As ToolBase _
)
C#
public void Add(
   ToolBase item
)

Parameters

item
The Tool object to add to the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members
Tool Class


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Clear Method

Glossary Item Box

Clears all tools from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


Contains Method

[image]
ActiveReports 13
Contains Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Contains Method

item
The object to locate in the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Determines whether an element is in the Collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ToolBase _
) As Boolean
C#
public bool Contains(
   ToolBase item
)

Parameters

item
The object to locate in the Collection. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


CopyTo Method

[image]
ActiveReports 13
CopyTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ToolBase, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   ToolBase[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is a null reference (Nothing in Visual Basic).
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Count Property

Glossary Item Box

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : IndexOf Method

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As ToolBase _
) As Integer
C#
public int IndexOf(
   ToolBase item
)

Parameters

item
The object to locate in the List. The value can be a null reference (Nothing in Visual Basic) for reference types.

Return Value

The zero-based index of the first occurrence of item within the entire Collection, if found; otherwise, -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


Insert Method

[image]
ActiveReports 13
Insert Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Insert Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Glossary Item Box

Inserts an element into the Collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ToolBase _
)
C#
public void Insert(
   int index,
   ToolBase item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be a null reference (Nothing in Visual Basic) for reference types.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


Item(Int32) Property

[image]
ActiveReports 13
Item(Int32) Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class > Item Property : Item(Int32) Property

index
The zero-based index of the element to get or set.

Glossary Item Box

Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As ToolBase
C#
public ToolBase Item(
   int index
) {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members
Overload List


Remove Method

[image]
ActiveReports 13
Remove Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Remove Method

item
The Tool object to remove from the collection.

Glossary Item Box

Removes the specified tool from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As ToolBase _
) As Boolean
C#
public bool Remove(
   ToolBase item
)

Parameters

item
The Tool object to remove from the collection.

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the original Collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : RemoveAt Method

index
The zero-based indexed position of the tool to remove from the toolbar.

Glossary Item Box

Removes the tool in the specified position from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based indexed position of the tool to remove from the toolbar.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ToolsCollection Class
ToolsCollection Members


GrapeCity.ActiveReports.Web.Controls Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web.Controls Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web.Controls Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBarObject
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool
GrapeCity.ActiveReports.Web.Controls.ToolButton
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.Web.Controls.ToolsCollection

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


GrapeCity.ActiveReports.Web.ExportOptions Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web.ExportOptions Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web.ExportOptions Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.HtmlExportOptions
GrapeCity.ActiveReports.Web.ExportOptions.PdfExportOptions
GrapeCity.ActiveReports.Web.ExportOptions.PrintPresets

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


CompiledReportHandler Class Properties

[image]
ActiveReports 13
CompiledReportHandler Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class

Glossary Item Box

For a list of all members of this type, see CompiledReportHandler members.

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top

See Also

Reference

CompiledReportHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RdlxHandler Class Properties

[image]
ActiveReports 13
RdlxHandler Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class

Glossary Item Box

For a list of all members of this type, see RdlxHandler members.

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top

See Also

Reference

RdlxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RpxHandler Class Properties

[image]
ActiveReports 13
RpxHandler Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class

Glossary Item Box

For a list of all members of this type, see RpxHandler members.

Public Properties

 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top

See Also

Reference

RpxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


GrapeCity.ActiveReports.Web.Handlers Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web.Handlers Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web.Handlers Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler
GrapeCity.ActiveReports.Web.Handlers.RdlxHandler
GrapeCity.ActiveReports.Web.Handlers.RpxHandler
GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer
GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


AccessKey Property

[image]
ActiveReports 13
AccessKey Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : AccessKey Property

Glossary Item Box

Gets or sets the access key that allows you to quickly navigate to the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property AccessKey As String
C#
public virtual string AccessKey {get; set;}

Property Value

The access key for quick navigation to the Web server control. The default value is System.String.Empty, which indicates that this property is not set.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The specified access key is neither a null reference (Nothing in Visual Basic), System.String.Empty nor a single character string.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ApplyStyle Method

[image]
ActiveReports 13
ApplyStyle Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ApplyStyle Method

s
A System.Web.UI.WebControls.Style that represents the style to be copied.

Glossary Item Box

Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As Style _
)
C#
public void ApplyStyle(
   Style s
)

Parameters

s
A System.Web.UI.WebControls.Style that represents the style to be copied.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ApplyStyleSheetSkin Method

[image]
ActiveReports 13
ApplyStyleSheetSkin Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ApplyStyleSheetSkin Method

page
The System.Web.UI.Page containing the control.

Glossary Item Box

Applies the style properties defined in the page style sheet to the control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As Page _
)
C#
public virtual void ApplyStyleSheetSkin(
   Page page
)

Parameters

page
The System.Web.UI.Page containing the control.

Exceptions

Exception | Description
System.InvalidOperationException | The style sheet is already applied.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


AppRelativeTemplateSourceDirectory Property

[image]
ActiveReports 13
AppRelativeTemplateSourceDirectory Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : AppRelativeTemplateSourceDirectory Property

Glossary Item Box

Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control.

Syntax

Visual Basic (Declaration)
Public Property AppRelativeTemplateSourceDirectory As String
C#
public string AppRelativeTemplateSourceDirectory {get; set;}

Property Value

The application-relative virtual directory of the page or user control that contains this control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Attributes Property

[image]
ActiveReports 13
Attributes Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Attributes Property

Glossary Item Box

Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attributes As AttributeCollection
C#
public AttributeCollection Attributes {get;}

Property Value

A System.Web.UI.AttributeCollection of name and value pairs.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


BackColor Property

[image]
ActiveReports 13
BackColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BackColor Property

Glossary Item Box

Gets or sets the background color of the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As Color
C#
public virtual Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is System.Drawing.Color.Empty, which indicates that this property is not set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


BorderColor Property

[image]
ActiveReports 13
BorderColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BorderColor Property

Glossary Item Box

Gets or sets the border color of the Web control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderColor As Color
C#
public virtual Color BorderColor {get; set;}

Property Value

A System.Drawing.Color that represents the border color of the control. The default is System.Drawing.Color.Empty, which indicates that this property is not set.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


BorderStyle Property

[image]
ActiveReports 13
BorderStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BorderStyle Property

Glossary Item Box

Gets or sets the border style of the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderStyle As BorderStyle
C#
public virtual BorderStyle BorderStyle {get; set;}

Property Value

One of the System.Web.UI.WebControls.BorderStyle enumeration values. The default is NotSet.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


BorderWidth Property

[image]
ActiveReports 13
BorderWidth Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BorderWidth Property

Glossary Item Box

Gets or sets the border width of the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property BorderWidth As Unit
C#
public virtual Unit BorderWidth {get; set;}

Property Value

A System.Web.UI.WebControls.Unit that represents the border width of a Web server control. The default value is System.Web.UI.WebControls.Unit.Empty, which indicates that this property is not set.

Exceptions

Exception | Description
System.ArgumentException | The specified border width is a negative value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ClientID Property

[image]
ActiveReports 13
ClientID Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ClientID Property

Glossary Item Box

Gets the control ID for HTML markup that is generated by ASP.NET.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ClientID As String
C#
public virtual string ClientID {get;}

Property Value

The control ID for HTML markup that is generated by ASP.NET.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ClientIDMode Property

[image]
ActiveReports 13
ClientIDMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ClientIDMode Property

Glossary Item Box

Gets or sets the algorithm that is used to generate the value of the System.Web.UI.Control.ClientID property.

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientIDMode As ClientIDMode
C#
public virtual ClientIDMode ClientIDMode {get; set;}

Property Value

A value that indicates how the System.Web.UI.Control.ClientID property is generated. The default is System.Web.UI.ClientIDMode.Inherit.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Controls Property

[image]
ActiveReports 13
Controls Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Controls Property

Glossary Item Box

Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Controls As ControlCollection
C#
public virtual ControlCollection Controls {get;}

Property Value

The collection of child controls for the specified server control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ControlStyle Property

[image]
ActiveReports 13
ControlStyle Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ControlStyle Property

Glossary Item Box

Gets the style of the Web server control. This property is used primarily by control developers.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlStyle As Style
C#
public Style ControlStyle {get;}

Property Value

A System.Web.UI.WebControls.Style that encapsulates the appearance properties of the Web server control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ControlStyleCreated Property

[image]
ActiveReports 13
ControlStyleCreated Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ControlStyleCreated Property

Glossary Item Box

Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlStyleCreated As Boolean
C#
public bool ControlStyleCreated {get;}

Property Value

true if a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


CopyBaseAttributes Method

[image]
ActiveReports 13
CopyBaseAttributes Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : CopyBaseAttributes Method

controlSrc
A System.Web.UI.WebControls.WebControl that represents the source control with properties to be copied to the Web server control that this method is called from.

Glossary Item Box

Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As WebControl _
)
C#
public void CopyBaseAttributes(
   WebControl controlSrc
)

Parameters

controlSrc
A System.Web.UI.WebControls.WebControl that represents the source control with properties to be copied to the Web server control that this method is called from.

Exceptions

Exception | Description
System.ArgumentNullException | controlSrc is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


CssClass Property

[image]
ActiveReports 13
CssClass Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : CssClass Property

Glossary Item Box

Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.

Syntax

Visual Basic (Declaration)
Public Overridable Property CssClass As String
C#
public virtual string CssClass {get; set;}

Property Value

The CSS class rendered by the Web server control on the client. The default is System.String.Empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


DataBinding Event

[image]
ActiveReports 13
DataBinding Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : DataBinding Event

Glossary Item Box

Occurs when the server control binds to a data source.

Syntax

Visual Basic (Declaration)
Public Event DataBinding As EventHandler
C#
public event EventHandler DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Disposed Event

Glossary Item Box

Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Enabled Property

[image]
ActiveReports 13
Enabled Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Enabled Property

Glossary Item Box

Gets or sets a value indicating whether the Web server control is enabled.

Syntax

Visual Basic (Declaration)
Public Overridable Property Enabled As Boolean
C#
public virtual bool Enabled {get; set;}

Property Value

true if control is enabled; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


EnableTheming Property

[image]
ActiveReports 13
EnableTheming Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : EnableTheming Property

Glossary Item Box

Gets or sets a value indicating whether themes apply to this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableTheming As Boolean
C#
public virtual bool EnableTheming {get; set;}

Property Value

true to use themes; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


EnableViewState Property

[image]
ActiveReports 13
EnableViewState Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : EnableViewState Property

Glossary Item Box

Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.

Syntax

Visual Basic (Declaration)
Public Overridable Property EnableViewState As Boolean
C#
public virtual bool EnableViewState {get; set;}

Property Value

true if the server control maintains its view state; otherwise false. The default is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Focus Method

[image]
ActiveReports 13
Focus Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Focus Method

Glossary Item Box

Sets input focus to a control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
C#
public virtual void Focus()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Font Property

[image]
ActiveReports 13
Font Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Font Property

Glossary Item Box

Gets the font properties associated with the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Font As FontInfo
C#
public virtual FontInfo Font {get;}

Property Value

A System.Web.UI.WebControls.FontInfo that represents the font properties of the Web server control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ForeColor Property

[image]
ActiveReports 13
ForeColor Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color (typically the color of the text) of the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ForeColor As Color
C#
public virtual Color ForeColor {get; set;}

Property Value

A System.Drawing.Color that represents the foreground color of the control. The default is System.Drawing.Color.Empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


GetRouteUrl Method

[image]
ActiveReports 13
GetRouteUrl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : GetRouteUrl Method

Glossary Item Box

Gets the URL that corresponds to a set of route parameters.

Overload List

Overload | Description
GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


GetRouteUrl(Object) Method

[image]
ActiveReports 13
GetRouteUrl(Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters
The route parameters.

Glossary Item Box

Gets the URL that corresponds to a set of route parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As Object _
) As String
C#
public string GetRouteUrl(
   object routeParameters
)

Parameters

routeParameters
The route parameters.

Return Value

The URL that corresponds to the specified route parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
ActiveReports 13
GetRouteUrl(RouteValueDictionary) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters
The route parameters.

Glossary Item Box

Gets the URL that corresponds to a set of route parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As RouteValueDictionary _
) As String
C#
public string GetRouteUrl(
   RouteValueDictionary routeParameters
)

Parameters

routeParameters
The route parameters.

Return Value

The URL that corresponds to the specified route parameters.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetRouteUrl(String,Object) Method

[image]
ActiveReports 13
GetRouteUrl(String,Object) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
The name of the route.
routeParameters
The route parameters.

Glossary Item Box

Gets the URL that corresponds to a set of route parameters and a route name.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As Object _
) As String
C#
public string GetRouteUrl(
   string routeName,
   object routeParameters
)

Parameters

routeName
The name of the route.
routeParameters
The route parameters.

Return Value

The URL that corresponds to the specified route parameters and route name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
ActiveReports 13
GetRouteUrl(String,RouteValueDictionary) Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
The name of the route.
routeParameters
The route parameters.

Glossary Item Box

Gets the URL that corresponds to a set of route parameters and a route name.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As String, _
   ByVal routeParameters As RouteValueDictionary _
) As String
C#
public string GetRouteUrl(
   string routeName,
   RouteValueDictionary routeParameters
)

Parameters

routeName
The name of the route.
routeParameters
The route parameters.

Return Value

The URL that corresponds to the specified route parameters and route name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetUniqueIDRelativeTo Method

[image]
ActiveReports 13
GetUniqueIDRelativeTo Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : GetUniqueIDRelativeTo Method

control
A control that is within a naming container.

Glossary Item Box

Returns the prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control.

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As Control _
) As String
C#
public string GetUniqueIDRelativeTo(
   Control control
)

Parameters

control
A control that is within a naming container.

Return Value

The prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control.

Exceptions

Exception | Description
System.InvalidOperationException | The System.Web.UI.Control.NamingContainer property of control is a null reference (Nothing in Visual Basic).
System.ArgumentNullException | control is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


HasAttributes Property

[image]
ActiveReports 13
HasAttributes Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : HasAttributes Property

Glossary Item Box

Gets a value indicating whether the control has attributes set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasAttributes As Boolean
C#
public bool HasAttributes {get;}

Property Value

true if the control has attributes set; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


HasControls Method

[image]
ActiveReports 13
HasControls Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : HasControls Method

Glossary Item Box

Determines if the server control contains any child controls.

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As Boolean
C#
public virtual bool HasControls()

Return Value

true if the control contains other controls; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Height Property

[image]
ActiveReports 13
Height Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Height Property

Glossary Item Box

Gets or sets the height of the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As Unit
C#
public virtual Unit Height {get; set;}

Property Value

A System.Web.UI.WebControls.Unit that represents the height of the control. The default is System.Web.UI.WebControls.Unit.Empty.

Exceptions

Exception | Description
System.ArgumentException | The height was set to a negative value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ID Property

[image]
ActiveReports 13
ID Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ID Property

Glossary Item Box

Gets or sets the programmatic identifier assigned to the server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ID As String
C#
public virtual string ID {get; set;}

Property Value

The programmatic identifier assigned to the control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Init Event

[image]
ActiveReports 13
Init Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Init Event

Glossary Item Box

Occurs when the server control is initialized, which is the first step in its lifecycle.

Syntax

Visual Basic (Declaration)
Public Event Init As EventHandler
C#
public event EventHandler Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Load Event

[image]
ActiveReports 13
Load Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Load Event

Glossary Item Box

Occurs when the server control is loaded into the System.Web.UI.Page object.

Syntax

Visual Basic (Declaration)
Public Event Load As EventHandler
C#
public event EventHandler Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


MergeStyle Method

[image]
ActiveReports 13
MergeStyle Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : MergeStyle Method

s
A System.Web.UI.WebControls.Style that represents the style to be copied.

Glossary Item Box

Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As Style _
)
C#
public void MergeStyle(
   Style s
)

Parameters

s
A System.Web.UI.WebControls.Style that represents the style to be copied.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


NamingContainer Property

[image]
ActiveReports 13
NamingContainer Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : NamingContainer Property

Glossary Item Box

Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NamingContainer As Control
C#
public virtual Control NamingContainer {get;}

Property Value

The server control's naming container.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Page Property

[image]
ActiveReports 13
Page Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Page Property

Glossary Item Box

Gets a reference to the System.Web.UI.Page instance that contains the server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As Page
C#
public virtual Page Page {get; set;}

Property Value

The System.Web.UI.Page instance that contains the server control.

Exceptions

Exception | Description
System.InvalidOperationException | The control is a System.Web.UI.WebControls.Substitution control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Parent Property

[image]
ActiveReports 13
Parent Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Parent Property

Glossary Item Box

Gets a reference to the server control's parent control in the page control hierarchy.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Parent As Control
C#
public virtual Control Parent {get;}

Property Value

A reference to the server control's parent control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


PreRender Event

[image]
ActiveReports 13
PreRender Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : PreRender Event

Glossary Item Box

Occurs after the System.Web.UI.Control object is loaded but prior to rendering.

Syntax

Visual Basic (Declaration)
Public Event PreRender As EventHandler
C#
public event EventHandler PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


RenderBeginTag Method

[image]
ActiveReports 13
RenderBeginTag Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderBeginTag Method

writer
HtmlTextWriter.

Glossary Item Box

Extracts the style attribute from the outer div or table tag when using Acrobat and uses a percentage of the width or height.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As HtmlTextWriter _
)
C#
public virtual void RenderBeginTag(
   HtmlTextWriter writer
)

Parameters

writer
HtmlTextWriter.

Remarks

The width or height being specified as 100% on both the div and the object or iframe causes problems.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


RenderEndTag Method

[image]
ActiveReports 13
RenderEndTag Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderEndTag Method

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

Glossary Item Box

Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderEndTag( _
   ByVal writer As HtmlTextWriter _
)
C#
public virtual void RenderEndTag(
   HtmlTextWriter writer
)

Parameters

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


RenderingCompatibility Property

[image]
ActiveReports 13
RenderingCompatibility Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderingCompatibility Property

Glossary Item Box

Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with.

Syntax

Visual Basic (Declaration)
Public Overridable Property RenderingCompatibility As Version
C#
public virtual Version RenderingCompatibility {get; set;}

Property Value

The ASP.NET version that rendered HTML will be compatible with.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ResolveClientUrl Method

[image]
ActiveReports 13
ResolveClientUrl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ResolveClientUrl Method

relativeUrl
A URL relative to the current page.

Glossary Item Box

Gets a URL that can be used by the browser.

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
C#
public string ResolveClientUrl(
   string relativeUrl
)

Parameters

relativeUrl
A URL relative to the current page.

Return Value

A fully qualified URL to the specified resource suitable for use on the browser.

Exceptions

Exception | Description
System.ArgumentNullException | relativeUrl is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ResolveUrl Method

[image]
ActiveReports 13
ResolveUrl Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ResolveUrl Method

relativeUrl
The URL associated with the System.Web.UI.Control.TemplateSourceDirectory property.

Glossary Item Box

Converts a URL into one that is usable on the requesting client.

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
C#
public string ResolveUrl(
   string relativeUrl
)

Parameters

relativeUrl
The URL associated with the System.Web.UI.Control.TemplateSourceDirectory property.

Return Value

The converted URL.

Exceptions

Exception | Description
System.ArgumentNullException | Occurs if the relativeUrl parameter contains a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


SetRenderMethodDelegate Method

[image]
ActiveReports 13
SetRenderMethodDelegate Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SetRenderMethodDelegate Method

renderMethod
The information necessary to pass to the delegate so that it can render the server control.

Glossary Item Box

Assigns an event handler delegate to render the server control and its content into its parent control.

Syntax

Visual Basic (Declaration)
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As RenderMethod _
)
C#
public void SetRenderMethodDelegate(
   RenderMethod renderMethod
)

Parameters

renderMethod
The information necessary to pass to the delegate so that it can render the server control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Site Property

Glossary Item Box

Gets information about the container that hosts the current control when rendered on a design surface.

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Property Value

An System.ComponentModel.ISite that contains information about the container that the control is hosted in.

Exceptions

Exception | Description
System.InvalidOperationException | The control is a System.Web.UI.WebControls.Substitution control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


SkinID Property

[image]
ActiveReports 13
SkinID Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SkinID Property

Glossary Item Box

Gets or sets the skin to apply to the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinID As String
C#
public virtual string SkinID {get; set;}

Property Value

The name of the skin to apply to the control. The default is System.String.Empty.

Exceptions

Exception | Description
System.ArgumentException | The skin specified in the System.Web.UI.WebControls.WebControl.SkinID property does not exist in the theme.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Style Property

[image]
ActiveReports 13
Style Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Style Property

Glossary Item Box

Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As CssStyleCollection
C#
public CssStyleCollection Style {get;}

Property Value

A System.Web.UI.CssStyleCollection that contains the HTML style attributes to render on the outer tag of the Web server control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


SupportsDisabledAttribute Property

[image]
ActiveReports 13
SupportsDisabledAttribute Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SupportsDisabledAttribute Property

Glossary Item Box

Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's System.Web.UI.WebControls.WebControl.IsEnabled property is false.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SupportsDisabledAttribute As Boolean
C#
public virtual bool SupportsDisabledAttribute {get;}

Property Value

Always true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


TabIndex Property

[image]
ActiveReports 13
TabIndex Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : TabIndex Property

Glossary Item Box

Gets or sets the tab index of the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property TabIndex As Short
C#
public virtual short TabIndex {get; set;}

Property Value

The tab index of the Web server control. The default is 0, which indicates that this property is not set.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The specified tab index is not between -32768 and 32767.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


TemplateControl Property

[image]
ActiveReports 13
TemplateControl Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : TemplateControl Property

Glossary Item Box

Gets or sets a reference to the template that contains this control.

Syntax

Visual Basic (Declaration)
Public Property TemplateControl As TemplateControl
C#
public TemplateControl TemplateControl {get; set;}

Property Value

The System.Web.UI.TemplateControl instance that contains this control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


TemplateSourceDirectory Property

[image]
ActiveReports 13
TemplateSourceDirectory Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : TemplateSourceDirectory Property

Glossary Item Box

Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TemplateSourceDirectory As String
C#
public virtual string TemplateSourceDirectory {get;}

Property Value

The virtual directory of the page or user control that contains the server control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ToolTip Property

[image]
ActiveReports 13
ToolTip Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ToolTip Property

Glossary Item Box

Gets or sets the text displayed when the mouse pointer hovers over the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ToolTip As String
C#
public virtual string ToolTip {get; set;}

Property Value

The text displayed when the mouse pointer hovers over the Web server control. The default is System.String.Empty.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


UniqueID Property

[image]
ActiveReports 13
UniqueID Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : UniqueID Property

Glossary Item Box

Gets the unique, hierarchically qualified identifier for the server control.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UniqueID As String
C#
public virtual string UniqueID {get;}

Property Value

The fully qualified identifier for the server control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Unload Event

[image]
ActiveReports 13
Unload Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Unload Event

Glossary Item Box

Occurs when the server control is unloaded from memory.

Syntax

Visual Basic (Declaration)
Public Event Unload As EventHandler
C#
public event EventHandler Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ValidateRequestMode Property

[image]
ActiveReports 13
ValidateRequestMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ValidateRequestMode Property

Glossary Item Box

Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values.

Syntax

Visual Basic (Declaration)
Public Overridable Property ValidateRequestMode As ValidateRequestMode
C#
public virtual ValidateRequestMode ValidateRequestMode {get; set;}

Property Value

A value that determines whether the control checks client input. Values can include System.Web.UI.ValidateRequestMode.Disabled, System.Web.UI.ValidateRequestMode.Enabled, and System.Web.UI.ValidateRequestMode.Inherit. The default is System.Web.UI.ValidateRequestMode.Inherit, which means that the control gets the value from its parent.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


ViewStateMode Property

[image]
ActiveReports 13
ViewStateMode Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ViewStateMode Property

Glossary Item Box

Gets or sets the view-state mode of this control.

Syntax

Visual Basic (Declaration)
Public Overridable Property ViewStateMode As ViewStateMode
C#
public virtual ViewStateMode ViewStateMode {get; set;}

Property Value

The view-state mode of this control.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | An attempt was made to set this property to a value that is not in the System.Web.UI.ViewStateMode enumeration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Visible Property

[image]
ActiveReports 13
Visible Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Visible Property

Glossary Item Box

Gets or sets a value that indicates whether a server control is rendered as UI on the page.

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
C#
public virtual bool Visible {get; set;}

Property Value

true if the control is visible on the page; otherwise false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


Width Property

[image]
ActiveReports 13
Width Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Width Property

Glossary Item Box

Gets or sets the width of the Web server control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Unit
C#
public virtual Unit Width {get; set;}

Property Value

A System.Web.UI.WebControls.Unit that represents the width of the control. The default is System.Web.UI.WebControls.Unit.Empty.

Exceptions

Exception | Description
System.ArgumentException | The width of the Web server control was set to a negative value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebViewer Class
WebViewer Members


GrapeCity.ActiveReports.Web Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports.Web Assembly : GrapeCity.ActiveReports.Web Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
GrapeCity.ActiveReports.Web.WebViewer

See Also

Reference

GrapeCity.ActiveReports.Web Assembly


Capacity Property

[image]
ActiveReports 13
Capacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the RenderingExtensionInfoCollection can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the RenderingExtensionInfoCollection instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


GrapeCity.ActiveReports.Configuration Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Configuration Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Configuration Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.CustomDesignerConfigurationDictionary
GrapeCity.ActiveReports.Configuration.DefaultConfigurationProvider
GrapeCity.ActiveReports.Configuration.PropertyElement
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfo
GrapeCity.ActiveReports.Configuration.ReportItemsConfigurationDictionary
GrapeCity.ActiveReports.Configuration.ToolboxItemConfig
System.Collections.CollectionBase
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfoCollection

See Also

Reference

GrapeCity.ActiveReports Assembly


FieldCollection Constructor

[image]
ActiveReports 13
FieldCollection Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : FieldCollection Constructor

Glossary Item Box

Initializes a new instance of the FieldCollection class.

Overload List

Overload | Description
FieldCollection Constructor | Initializes a new instance of the FieldCollection class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Capacity Property

[image]
ActiveReports 13
Capacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the FieldCollection can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the FieldCollection instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : IndexOf Method

Glossary Item Box

Finds the index number of the field with specified name in the collection. Finds the index number of the specified field in the collection.

Overload List

Overload | Description
IndexOf | Finds the index number of the specified field in the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldCollection Class
FieldCollection Members


Field Constructor

[image]
ActiveReports 13
Field Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Field Constructor

Glossary Item Box

Initializes a new instance of the Field class.

Overload List

Overload | Description
Field Constructor | Initializes a new instance of the Field class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Field Class
Field Members


GrapeCity.ActiveReports.Data Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Data Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Data Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.CsvDataSource
GrapeCity.ActiveReports.Data.Field
GrapeCity.ActiveReports.Data.ListDataSource
GrapeCity.ActiveReports.Data.OdbcDataSource
GrapeCity.ActiveReports.Data.OleDBDataSource
GrapeCity.ActiveReports.Data.ProviderSerializer
GrapeCity.ActiveReports.Data.SqlDBDataSource
GrapeCity.ActiveReports.Data.XMLDataSource
System.Collections.CollectionBase
GrapeCity.ActiveReports.Data.FieldCollection

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports) Inheritance Hierarchy

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Document Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.PageDocument

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports) Inheritance Hierarchy

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Export Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports Assembly


Equals Method

[image]
ActiveReports 13
Equals Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace > DbName Class : Equals Method

Glossary Item Box

Determines whether the specified System.Object is equal to this instance.

Overload List

Overload | Description
Equals | Determines whether the specified System.Object is equal to this instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DbName Class
DbName Members


GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Extensibility.Data.SchemaModel Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.Column
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.DataSchema
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.DbName
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.ForeignKey
GrapeCity.ActiveReports.Extensibility.Data.SchemaModel.Table

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.Extensibility.Data Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Data Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Extensibility.Data Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataRow
GrapeCity.ActiveReports.Extensibility.Data.DataTable
System.ValueType
GrapeCity.ActiveReports.Extensibility.Data.DataColumn

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.Extensibility.Rendering Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Extensibility.Rendering Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.General Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.General Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.General Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports Assembly


PageReport Class Events

[image]
ActiveReports 13
PageReport Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

Glossary Item Box

For a list of all members of this type, see PageReport members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


Container Property

[image]
ActiveReports 13
Container Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Container Property

Glossary Item Box

Gets the IContainer that contains the Component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
C#
public IContainer Container {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : CreateObjRef Method

requestedType
The Type of the object that the new ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The Type of the object that the new ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Dispose Method

Glossary Item Box

Releases the resources used by the Component.

Overload List

Overload | Description
Dispose | Releases the resources used by the Component. (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Dispose() Method

[image]
ActiveReports 13
Dispose() Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Dispose() Method

Glossary Item Box

Releases the resources used by the Component.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Disposed Event

[image]
ActiveReports 13
Disposed Event
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Disposed Event

Glossary Item Box

Occurs when the component is disposed by a call to the Dispose method.

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


InitializeLifetimeService Method

[image]
ActiveReports 13
InitializeLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : InitializeLifetimeService Method

Glossary Item Box

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function InitializeLifetimeService() As Object
C#
public object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Site Property

[image]
ActiveReports 13
Site Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Site Property

Glossary Item Box

Gets or sets the ISite of the Component.

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
C#
public ISite Site {get; set;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ToString Method

Glossary Item Box

Returns a String containing the name of the Component, if any.

Syntax

Visual Basic (Declaration)
Public Function ToString() As String
C#
public string ToString()

Remarks

This method should not be overridden.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageReport Class
PageReport Members


Dispose Method

[image]
ActiveReports 13
Dispose Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Dispose Method

Glossary Item Box

Releases unmanaged and - optionally - managed resources. Releases the PageSettings object from memory.

Overload List

Overload | Description
Dispose | Releases the PageSettings object from memory.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageSettings Class
PageSettings Members


GrapeCity.ActiveReports.Rendering Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Rendering Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.Rendering Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GdiRenderersFactory

See Also

Reference

GrapeCity.ActiveReports Assembly


ReportDataException Class Methods

[image]
ActiveReports 13
ReportDataException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

Glossary Item Box

For a list of all members of this type, see ReportDataException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportDataException Class
GrapeCity.ActiveReports Namespace


ReportDataException Class Properties

[image]
ActiveReports 13
ReportDataException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

Glossary Item Box

For a list of all members of this type, see ReportDataException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportDataException Class
GrapeCity.ActiveReports Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the Info with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : InnerException Property

Glossary Item Box

Gets the Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDataException Class
ReportDataException Members


ReportException Class Methods

[image]
ActiveReports 13
ReportException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

Glossary Item Box

For a list of all members of this type, see ReportException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the Info with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : InnerException Property

Glossary Item Box

Gets the Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportException Class
ReportException Members


GrapeCity.ActiveReports.ReportsCore.Configuration Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ReportsCore.Configuration Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Configuration Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Configuration.MapTileServerConfiguration

See Also

Reference

GrapeCity.ActiveReports Assembly


OracleConnectionAdapter Class Methods

[image]
ActiveReports 13
OracleConnectionAdapter Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace : OracleConnectionAdapter Class

Glossary Item Box

For a list of all members of this type, see OracleConnectionAdapter members.

Public Methods

 | Name | Description
Public Method | SetConnectionString | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Method | SetCredentials | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Method | SetMultiValueParameter | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Top

See Also

Reference

OracleConnectionAdapter Class
GrapeCity.ActiveReports.ReportsCore.Data Namespace


OracleConnectionAdapter Class Properties

[image]
ActiveReports 13
OracleConnectionAdapter Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace : OracleConnectionAdapter Class

Glossary Item Box

For a list of all members of this type, see OracleConnectionAdapter members.

Public Properties

 | Name | Description
Public Property | IsCredentialsSupported | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Property | IsSetConnectionStringSupported | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Public Property | IsSetMultiValueParameterSupported | (Inherited from GrapeCity.BI.Data.DataProviders.DbConnectionAdapter)
Top

See Also

Reference

OracleConnectionAdapter Class
GrapeCity.ActiveReports.ReportsCore.Data Namespace


IsCredentialsSupported Property

[image]
ActiveReports 13
IsCredentialsSupported Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : IsCredentialsSupported Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCredentialsSupported As Boolean
C#
public bool IsCredentialsSupported {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


IsSetConnectionStringSupported Property

[image]
ActiveReports 13
IsSetConnectionStringSupported Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : IsSetConnectionStringSupported Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSetConnectionStringSupported As Boolean
C#
public bool IsSetConnectionStringSupported {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


IsSetMultiValueParameterSupported Property

[image]
ActiveReports 13
IsSetMultiValueParameterSupported Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : IsSetMultiValueParameterSupported Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSetMultiValueParameterSupported As Boolean
C#
public bool IsSetMultiValueParameterSupported {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


SetConnectionString Method

[image]
ActiveReports 13
SetConnectionString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : SetConnectionString Method

connection
connectionString

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetConnectionString( _
   ByVal connection As DbConnection, _
   ByVal connectionString As String _
)
C#
public void SetConnectionString(
   DbConnection connection,
   string connectionString
)

Parameters

connection
connectionString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


SetCredentials Method

[image]
ActiveReports 13
SetCredentials Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : SetCredentials Method

connection
userName
password

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetCredentials( _
   ByVal connection As DbConnection, _
   ByVal userName As String, _
   ByVal password As String _
)
C#
public void SetCredentials(
   DbConnection connection,
   string userName,
   string password
)

Parameters

connection
userName
password

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


SetMultiValueParameter Method

[image]
ActiveReports 13
SetMultiValueParameter Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Data Namespace > OracleConnectionAdapter Class : SetMultiValueParameter Method

command
parameterName
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetMultiValueParameter( _
   ByVal command As DbCommand, _
   ByVal parameterName As String, _
   ByVal value() As Object _
)
C#
public void SetMultiValueParameter(
   DbCommand command,
   string parameterName,
   object[] value
)

Parameters

command
parameterName
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OracleConnectionAdapter Class
OracleConnectionAdapter Members


GrapeCity.ActiveReports.ReportsCore.Data Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ReportsCore.Data Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Data Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.BI.Data.DataProviders.DbConnectionAdapter
GrapeCity.ActiveReports.ReportsCore.Data.OracleConnectionAdapter

See Also

Reference

GrapeCity.ActiveReports Assembly


ConfigurableTileProvidersManager Class Methods

[image]
ActiveReports 13
ConfigurableTileProvidersManager Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ConfigurableTileProvidersManager Class

Glossary Item Box

For a list of all members of this type, see ConfigurableTileProvidersManager members.

Public Methods

 | Name | Description
Public Method | CreateTileProvider | Create and configure specified tile provider (Inherited from GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager)
Top

See Also

Reference

ConfigurableTileProvidersManager Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


ConfigurableTileProvidersManager Class Properties

[image]
ActiveReports 13
ConfigurableTileProvidersManager Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ConfigurableTileProvidersManager Class

Glossary Item Box

For a list of all members of this type, see ConfigurableTileProvidersManager members.

Public Properties

 | Name | Description
Public Property | Providers | (Inherited from GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager)
Top

See Also

Reference

ConfigurableTileProvidersManager Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


CreateTileProvider Method

[image]
ActiveReports 13
CreateTileProvider Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > ConfigurableTileProvidersManager Class : CreateTileProvider Method

name
Invariant tile provider name
useSecureConnection
tileStyle
tileLanguage

Glossary Item Box

Create and configure specified tile provider

Syntax

Visual Basic (Declaration)
Public Function CreateTileProvider( _
   ByVal name As String, _
   ByVal useSecureConnection As Boolean, _
   ByVal tileStyle As GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapTileStyle, _
   ByVal tileLanguage As String _
) As GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapTileProvider
C#
public GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapTileProvider CreateTileProvider(
   string name,
   bool useSecureConnection,
   GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapTileStyle tileStyle,
   string tileLanguage
)

Parameters

name
Invariant tile provider name
useSecureConnection
tileStyle
tileLanguage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigurableTileProvidersManager Class
ConfigurableTileProvidersManager Members


Providers Property

[image]
ActiveReports 13
Providers Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > ConfigurableTileProvidersManager Class : Providers Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Providers As IEnumerable(Of TileProviderInfo)
C#
public IEnumerable<TileProviderInfo> Providers {get;}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConfigurableTileProvidersManager Class
ConfigurableTileProvidersManager Members


GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Rendering.GraphicalRenderers.Map.TileProviders.TileProvidersManager
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders.ConfigurableTileProvidersManager

See Also

Reference

GrapeCity.ActiveReports Assembly


DataSourceException Class Methods

[image]
ActiveReports 13
DataSourceException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace : DataSourceException Class

Glossary Item Box

For a list of all members of this type, see DataSourceException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataSourceException Class
GrapeCity.ActiveReports.ReportsCore.Tools Namespace


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : GetObjectData Method

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Glossary Item Box

When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : InnerException Property

Glossary Item Box

Gets the System.Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.ReportsCore.Tools Namespace > DataSourceException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceException Class
DataSourceException Members


GrapeCity.ActiveReports.ReportsCore.Tools Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ReportsCore.Tools Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore.Tools Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Tools.DataVisualizerInfoExtensions
GrapeCity.ActiveReports.ReportsCore.Tools.ReportCombiner
System.Exception
GrapeCity.ActiveReports.ReportsCore.Tools.DataSourceException
System.ValueType
GrapeCity.ActiveReports.ReportsCore.Tools.LocationOptions

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.ActiveReports.ReportsCore Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ReportsCore Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.ReportsCore Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

GrapeCity.ActiveReports Assembly


ReportScriptException Class Methods

[image]
ActiveReports 13
ReportScriptException Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

Glossary Item Box

For a list of all members of this type, see ReportScriptException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportScriptException Class
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports~GrapeCity.ActiveReports.ActiveReport~Script


ReportScriptException Class Properties

[image]
ActiveReports 13
ReportScriptException Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

Glossary Item Box

For a list of all members of this type, see ReportScriptException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ReportScriptException Class
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports~GrapeCity.ActiveReports.ActiveReport~Script


Data Property

[image]
ActiveReports 13
Data Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : Data Property

Glossary Item Box

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
C#
public virtual IDictionary Data {get;}

Property Value

An object that implements the System.Collections.IDictionary interface and contains a collection of user-defined key/value pairs. The default is an empty collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


GetBaseException Method

[image]
ActiveReports 13
GetBaseException Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : GetBaseException Method

Glossary Item Box

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
C#
public virtual Exception GetBaseException()

Return Value

The first exception thrown in a chain of exceptions. If the System.Exception.InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


GetObjectData Method

[image]
ActiveReports 13
GetObjectData Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : GetObjectData Method

info
SerializationInfo.
context
StreamingContext.

Glossary Item Box

When overridden in a derived class, sets the Info with information about the exception.

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
SerializationInfo.
context
StreamingContext.

Exceptions

Exception | Description
System.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


GetType Method

[image]
ActiveReports 13
GetType Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : GetType Method

Glossary Item Box

Gets the runtime type of the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
C#
public Type GetType()

Return Value

A System.Type object that represents the exact runtime type of the current instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


HelpLink Property

[image]
ActiveReports 13
HelpLink Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : HelpLink Property

Glossary Item Box

Gets or sets a link to the help file associated with this exception.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
C#
public virtual string HelpLink {get; set;}

Property Value

The Uniform Resource Name (URN) or Uniform Resource Locator (URL).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


HResult Property

[image]
ActiveReports 13
HResult Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : HResult Property

Glossary Item Box

Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HResult As Integer
C#
public int HResult {get;}

Property Value

The HRESULT value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


InnerException Property

[image]
ActiveReports 13
InnerException Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : InnerException Property

Glossary Item Box

Gets the Exception instance that caused the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
C#
public Exception InnerException {get;}

Property Value

An object that describes the error that caused the current exception. The System.Exception.InnerException property returns the same value as was passed into the System.Exception.#ctor(System.String,System.Exception) constructor, or a null reference (Nothing in Visual Basic) if the inner exception value was not supplied to the constructor. This property is read-only.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


Message Property

[image]
ActiveReports 13
Message Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : Message Property

Glossary Item Box

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
C#
public virtual string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


Source Property

[image]
ActiveReports 13
Source Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : Source Property

Glossary Item Box

Gets or sets the name of the application or the object that causes the error.

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
C#
public virtual string Source {get; set;}

Property Value

The name of the application or the object that causes the error.

Exceptions

Exception | Description
System.ArgumentException | The object must be a runtime System.Reflection object.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


StackTrace Property

[image]
ActiveReports 13
StackTrace Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : StackTrace Property

Glossary Item Box

Gets a string representation of the immediate frames on the call stack.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
C#
public virtual string StackTrace {get;}

Property Value

A string that describes the immediate frames of the call stack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


TargetSite Property

[image]
ActiveReports 13
TargetSite Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : TargetSite Property

Glossary Item Box

Gets the method that throws the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
C#
public MethodBase TargetSite {get;}

Property Value

The System.Reflection.MethodBase that threw the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


ToString Method

[image]
ActiveReports 13
ToString Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : ToString Method

Glossary Item Box

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
C#
public virtual string ToString()

Return Value

A string representation of the current exception.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportScriptException Class
ReportScriptException Members


Capacity Property

[image]
ActiveReports 13
Capacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the SectionCollection can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the SectionCollection instance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


IndexOf Method

[image]
ActiveReports 13
IndexOf Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : IndexOf Method

Glossary Item Box

Determines the specific index of the specified section in the collection.

Overload List

Overload | Description
IndexOf | Determines the specific index of the specified section in the collection.

Example

C# Copy Code
private void rpt_ReportEnd(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show(this.Sections.IndexOf(this.Sections["detail"]).ToString());
}
Visual Basic Copy Code
Private Sub rpt_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    MsgBox(Me.Sections.IndexOf(Me.Sections("Detail1")).ToString)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


InsertPageHF Method

[image]
ActiveReports 13
InsertPageHF Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertPageHF Method

Glossary Item Box

Inserts a page header and a matching page footer into the SectionCollection.

Overload List

Overload | Description
InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.

Remarks

Only one PageHeader and one PageFooter section are allowed in a report layout.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = New GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail,"Detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail, "Detail")
    rpt.Sections.InsertPageHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
PageHeader Class
PageFooter Class
Section Class


InsertReportHF Method

[image]
ActiveReports 13
InsertReportHF Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertReportHF Method

Glossary Item Box

Inserts a report header and a matching report footer into the SectionCollection.

Overload List

Overload | Description
InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.

Remarks

Only one ReportHeader and one ReportFooter section are allowed in a report layout.

Example

C# Copy Code
GrapeCity.ActiveReports.SectionReport rpt = New GrapeCity.SectionReports.ActiveReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail,"Detail");
    rpt.Sections.InsertReportHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
Visual Basic Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail, "Detail")
    rpt.Sections.InsertReportHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members
ReportHeader Class
ReportFooter Class
Section Class


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Inherited from System.Collections.CollectionBase.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionCollection Class
SectionCollection Members


Barcode Class Methods

[image]
ActiveReports 13
Barcode Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

Glossary Item Box

For a list of all members of this type, see Barcode members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CheckBox Class Methods

[image]
ActiveReports 13
CheckBox Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

Glossary Item Box

For a list of all members of this type, see CheckBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Capacity Property

[image]
ActiveReports 13
Capacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlCollection Class
ControlCollection Members


CrossSectionControl Class Methods

[image]
ActiveReports 13
CrossSectionControl Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

Glossary Item Box

For a list of all members of this type, see CrossSectionControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Class Methods

[image]
ActiveReports 13
CrossSectionLine Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

Glossary Item Box

For a list of all members of this type, see CrossSectionLine members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CrossSectionLine Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Class Properties

[image]
ActiveReports 13
CrossSectionLine Class Properties
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

Glossary Item Box

For a list of all members of this type, see CrossSectionLine members.

Public Properties

 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | The starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top

See Also

Reference

CrossSectionLine Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Class Methods

[image]
ActiveReports 13
CustomControl Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

Glossary Item Box

For a list of all members of this type, see CustomControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Class Events

[image]
ActiveReports 13
Detail Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

For a list of all members of this type, see Detail members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Class Methods

[image]
ActiveReports 13
Detail Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

Glossary Item Box

For a list of all members of this type, see Detail members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Class Events

[image]
ActiveReports 13
GroupFooter Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

For a list of all members of this type, see GroupFooter members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Class Methods

[image]
ActiveReports 13
GroupFooter Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

Glossary Item Box

For a list of all members of this type, see GroupFooter members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Class Events

[image]
ActiveReports 13
GroupHeader Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

For a list of all members of this type, see GroupHeader members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Class Methods

[image]
ActiveReports 13
GroupHeader Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

Glossary Item Box

For a list of all members of this type, see GroupHeader members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Class Methods

[image]
ActiveReports 13
Label Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Glossary Item Box

For a list of all members of this type, see Label members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Class Methods

[image]
ActiveReports 13
Line Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

Glossary Item Box

For a list of all members of this type, see Line members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageBreak Class Methods

[image]
ActiveReports 13
PageBreak Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

Glossary Item Box

For a list of all members of this type, see PageBreak members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Class Events

[image]
ActiveReports 13
PageFooter Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

For a list of all members of this type, see PageFooter members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Class Methods

[image]
ActiveReports 13
PageFooter Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

Glossary Item Box

For a list of all members of this type, see PageFooter members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Class Events

[image]
ActiveReports 13
PageHeader Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

For a list of all members of this type, see PageHeader members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Class Methods

[image]
ActiveReports 13
PageHeader Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

Glossary Item Box

For a list of all members of this type, see PageHeader members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Capacity Property

[image]
ActiveReports 13
Capacity Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Capacity Property

Glossary Item Box

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Declaration)
Public Property Capacity As Integer
C#
public int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Clear Method

[image]
ActiveReports 13
Clear Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Clear Method

Glossary Item Box

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Count Property

[image]
ActiveReports 13
Count Property
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Count Property

Glossary Item Box

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance. Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


RemoveAt Method

[image]
ActiveReports 13
RemoveAt Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ReportFooter Class Events

[image]
ActiveReports 13
ReportFooter Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

For a list of all members of this type, see ReportFooter members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Class Methods

[image]
ActiveReports 13
ReportFooter Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

Glossary Item Box

For a list of all members of this type, see ReportFooter members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Class Events

[image]
ActiveReports 13
ReportHeader Class Events
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

For a list of all members of this type, see ReportHeader members.

Public Events

 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Class Methods

[image]
ActiveReports 13
ReportHeader Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

Glossary Item Box

For a list of all members of this type, see ReportHeader members.

Public Methods

 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top

See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Class Methods

[image]
ActiveReports 13
ReportInfo Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

Glossary Item Box

For a list of all members of this type, see ReportInfo members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Section Constructor

[image]
ActiveReports 13
Section Constructor
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Section Constructor

Glossary Item Box

Initializes a new instance of the Section class.

Overload List

Overload | Description
Section Constructor | Initializes a new instance of the Section class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members


AddBookmark Method

[image]
ActiveReports 13
AddBookmark Method
See Also Example
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AddBookmark Method

Glossary Item Box

Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event.

Overload List

Overload | Description
AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.

Remarks

This method is used while the report is running. The method should be called in either the section's Format or BeforePrint events.

Calling this method in the Format event of the section creates a bookmark at the top of the section. Calling the method in the BeforePrint event of the section creates a bookmark at the bottom of the section.

Example

C# Copy Code
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    Detail.AddBookmark(txtCategoryName.Text + "\\" + txtProductName.Text);
}
Visual Basic Copy Code
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Detail.AddBookmark(txtCategoryName.Text + "\" + txtProductName.Text)
End Sub

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Section Class
Section Members

How To

Add Bookmarks


Shape Class Methods

[image]
ActiveReports 13
Shape Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

Glossary Item Box

For a list of all members of this type, see Shape members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Class Methods

[image]
ActiveReports 13
SubReport Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

Glossary Item Box

For a list of all members of this type, see SubReport members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


TextBox Class Methods

[image]
ActiveReports 13
TextBox Class Methods
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

Glossary Item Box

For a list of all members of this type, see TextBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top

See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GrapeCity.ActiveReports.SectionReportModel Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.SectionReportModel Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports.SectionReportModel Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode
GrapeCity.ActiveReports.SectionReportModel.ChartControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine
GrapeCity.ActiveReports.SectionReportModel.CustomControl
GrapeCity.ActiveReports.SectionReportModel.Label
GrapeCity.ActiveReports.SectionReportModel.Line
GrapeCity.ActiveReports.SectionReportModel.OleObject
GrapeCity.ActiveReports.SectionReportModel.PageBreak
GrapeCity.ActiveReports.SectionReportModel.Picture
GrapeCity.ActiveReports.SectionReportModel.ReportInfo
GrapeCity.ActiveReports.SectionReportModel.RichTextBox
GrapeCity.ActiveReports.SectionReportModel.Shape
GrapeCity.ActiveReports.SectionReportModel.SubReport
GrapeCity.ActiveReports.SectionReportModel.TextBox
GrapeCity.ActiveReports.SectionReportModel.Parameter
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail
GrapeCity.ActiveReports.SectionReportModel.GroupFooter
GrapeCity.ActiveReports.SectionReportModel.GroupHeader
GrapeCity.ActiveReports.SectionReportModel.PageFooter
GrapeCity.ActiveReports.SectionReportModel.PageHeader
GrapeCity.ActiveReports.SectionReportModel.ReportFooter
GrapeCity.ActiveReports.SectionReportModel.ReportHeader
GrapeCity.ActiveReports.SectionReportModel.Style
GrapeCity.ActiveReports.SectionReportModel.StyleSheet
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionReportModel.ControlCollection
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection

See Also

Reference

GrapeCity.ActiveReports Assembly


CreateObjRef Method

[image]
ActiveReports 13
CreateObjRef Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Glossary Item Box

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
C#
public virtual ObjRef CreateObjRef(
   Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


GetLifetimeService Method

[image]
ActiveReports 13
GetLifetimeService Method
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : GetLifetimeService Method

Glossary Item Box

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Declaration)
Public Function GetLifetimeService() As Object
C#
public object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SectionReport Class
SectionReport Members


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports) Inheritance Hierarchy

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports) Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.ActiveReports Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.GraphicsExtensions
GrapeCity.ActiveReports.PageSettings
GrapeCity.ActiveReports.SystemPrinter
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionCollection
System.EventArgs
GrapeCity.ActiveReports.LocateCredentialsEventArgs
GrapeCity.ActiveReports.LocateDataSourceEventArgs
GrapeCity.ActiveReports.SectionReport.FetchEventArgs
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportDataException
GrapeCity.ActiveReports.ReportScriptException
System.MarshalByRefObject
GrapeCity.ActiveReports.SectionReport
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReport

See Also

Reference

GrapeCity.ActiveReports Assembly


GrapeCity.BI.Data.DataProviders Namespace Inheritance Hierarchy

GrapeCity.BI.Data.DataProviders Namespace Inheritance Hierarchy
See Also
Product Support Forum | Print this page
GrapeCity.ActiveReports Assembly : GrapeCity.BI.Data.DataProviders Namespace

Glossary Item Box

Inheritance Hierarchy

System.Object
GrapeCity.BI.Data.DataProviders.MssqlSchemaProvider
System.ValueType
GrapeCity.BI.Data.DataProviders.DataProviderInfo

See Also

Reference

GrapeCity.ActiveReports Assembly


Digital Signature

Digital Signature
See Also

Glossary Item Box

Show All Show All
Hide All Hide All

This sample demonstrates how you can digitally sign or set time stamp for a section report when exporting it to PDF format.

Note: PDF digital signatures is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Sample Location

Show Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Professional\DigitalSignature\VB.NET

Show C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 13\Professional\DigitalSignature\C#

Show Run-Time Features

When you run this sample, the Invoice report is displayed in the Viewer control.

Clicking the Generate Digitally Signed PDF button in the Viewer toolbar creates a PDF file with a time stamp or digital signatures, based on the settings you have specified in the Viewer toolbar. You can change the content of signatures in the Signature Format box and you can add the time stamp to the generated pdf file by checking the Set TimeStamp checkbox, in the Viewer toolbar.

When you click the Generate Digitally Signed PDF button, a dialog for saving the destination file appears. After you indicate the location for a new PDF file, the PDF report file is created. Digital signature certificates dynamically reference and use GrapeCity.pfx, included in the project. Also, digital signatures dynamically load and use the gc.bmp file that you can find in the Image folder of this sample project.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 13\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Show Project Details

Show Image folder

This folder stores the gc.bmp file with the GrapeCity logo that digital signatures dynamically load and use.

Show Invoice report

The Invoice report is the Sample report that uses three GroupHeader sections, a Detail section and a GroupFooter section as well as a label in the PageFooter section to display data.

See The Bound Data Sample topic for details on the Invoice report.

Show GrapeCity.pfx

In order to create a digital signature, you must have a valid PKCS#12 certificate (*.pfx) file.

For information on creating a self-signed certificate, see the Adobe Acrobat Help topic "Create a self-signed digital ID."

You can also create a PFX file from the Visual Studio command line. For more information and links to SDK downloads, see http://www.source-code.biz/snippets/vbasic/3.htm.

Show PDFDigitalSignature form

This is the main form of the Sample that uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains the Create Digitally Signed PDF button, the Signature Format box with the drop-down list and the Set TimeStamp checkbox.

Clicking the Generate Digitally Signed PDF button opens a dialog for saving the destination file. After you indicate the location for a new PDF file, the PDF report file is created.

The drop-down list of the Signature Format box contains the following options.

  • Invisible - the invisible pdf digital signature.
  • Text - the pdf digital signature that contains text only.
  • Image - the pdf digital signature that contains graphics only.
  • ImageText - the pdf digital signature that contains text and graphics.

Checking the Set TimeStamp checkbox allows you to add the time stamp to the signature of the generated pdf file. The time stamp contains the Time Stamp Server address, its login and password information.

Right-click PDFDigitalSignature in the Solution Explorer and select View Code to see the code implementation for the pdf digital signature options.

Show Resource1.resx

This file contains the string for the message box that appears after the PDF file is generated.

See Also

Concepts
PDF Export

Copyright © 2020 GrapeCity, Inc. All rights reserved.

Product Support Forum | Print this page

©2020. All Rights Reserved.